| 1.2.5.1 | Office Connector Prerequisites | 65 |
| 1.2.5.2 | Displaying Office Files in Confluence | 66 |
| 1.2.5.3 | Importing an Office Document into Confluence | 68 |
| 1.2.5.4 | Editing an Office Document from Confluence | 71 |
| 1.2.5.5 | Editing an Office Spreadsheet from Confluence | 73 |
| 1.2.5.6 | Editing an Office Presentation from Confluence | 76 |
| 1.2.5.7 | Installing the Firefox Add-On for the Office Connector | 79 |
| 1.2.6 | Importing Content Into Confluence | 87 |
| 1.2.6.1 | Importing Pages from Disk | 88 |
| 1.3 | Sharing Content | 88 |
| 1.3.1 | Network Overview | 88 |
| 1.3.1.1 | Subscribing to a Network RSS Feed | 90 |
| 1.3.2 | Using Mentions | 91 |
| 1.4 | Watching Changes | 92 |
| 1.4.1 | Watching a Page or Blog Post | 93 |
| 1.4.2 | Watching a Space | 94 |
| 1.4.3 | Managing Watchers | 96 |
| 1.4.4 | Subscribing to Email Notifications of Updates to Confluence Content | 97 |
| 1.4.5 | Subscribing to RSS Feeds within Confluence | 97 |
| 1.4.5.1 | Using pre-specified RSS feeds | 98 |
| 1.4.5.2 | Using the RSS Feed Builder | 99 |
| 1.4.5.3 | Working with RSS Feeds | 100 |
| 1.4.5.3.1 | RSS Readers Compatibility | 100 |
| 1.5 | Searching Confluence | 101 |
| 1.5.1 | Confluence Search Fields | 107 |
| 1.5.2 | Confluence Search Syntax | 111 |
| 1.5.3 | Ranking of Search Results | 113 |
| 1.5.4 | Searching the People Directory | 116 |
| 1.5.5 | Text Tokenisation and Filtering | 117 |
| 1.6 | Organising Content | 118 |
| 1.6.1 | Working with Pages | 118 |
| 1.6.1.1 | Moving a Page | 119 |
| 1.6.1.2 | Working with Page Families | 120 |
| 1.6.1.2.1 | Viewing a Page's Family | 120 |
| 1.6.1.2.2 | Setting a Page Family to Alphabetical Order | 121 |
| 1.6.1.3 | Using the Documentation Theme | 123 |
| 1.6.1.4 | Sequential Order of Pages | 124 |
| 1.6.1.5 | Viewing Page Information | 125 |
| 1.6.1.6 | Copying a Page | 126 |
| 1.6.1.7 | Working with Comments | 127 |
| 1.6.1.7.1 | Adding a Comment | 128 |
| 1.6.1.7.2 | Deleting Comments | 128 |
| 1.6.1.7.3 | Editing a Comment | 128 |
| 1.6.1.7.4 | Linking to Comments | 129 |
| 1.6.1.8 | Recently Viewed Content | 129 |
| 1.6.1.9 | E-mailing a Page | 130 |
| 1.6.1.10 | Renaming a Page | 132 |
| 1.6.1.11 | Deleting a Page | 132 |
| 1.6.1.11.1 | Purging Deleted Pages | 133 |
| 1.6.1.11.2 | Restoring a Deleted Page | 133 |
| 1.6.1.12 | Page History and Page Comparison Views | 133 |
| 1.6.1.12.1 | Restoring an Older Version of a Page | 135 |
| 1.6.1.12.2 | Viewing an Older Version of a Page | 136 |
| 1.6.1.13 | Using a WebDAV Client to Work with Pages | 137 |
| 1.6.2 | Working with Blog Posts | 137 |
| 1.6.2.1 | Deleting Blog Posts | 137 |
| 1.6.2.2 | Editing Blog Posts | 138 |
| 1.6.2.3 | Viewing Blog Posts | 138 |
| 1.6.3 | Working with Spaces | 139 |
| 1.6.3.1 | Viewing Space Activity | 140 |
| 1.6.3.2 | Viewing All Confluence Spaces | 142 |
| 1.6.3.3 | Administering Spaces | 145 |
| 1.6.3.4 | Deleting a Space | 146 |
| 1.6.3.5 | Setting up a New Global Space | 146 |
| 1.6.3.6 | Setting up your Personal Space | 147 |
| 1.6.3.7 | Exporting Confluence Pages and Spaces to Other Formats | 150 |
| 1.6.3.7.1 | Exporting Confluence Pages and Spaces to HTML | 150 |
| 1.6.3.7.2 | Exporting Confluence Pages and Spaces to PDF | 151 |
| 1.6.3.7.3 | Exporting to a Word document | 150 |
| 1.6.3.7.4 | Exporting Confluence Pages and Spaces to XML | 160 |
| 1.6.3.8 | Browsing a space | 161 |
| 1.6.3.8.1 | Editing Space Details | 163 |
| 1.6.3.8.2 | Managing Orphaned Pages | 163 |
| 1.6.3.8.3 | Managing Undefined Pages | 164 |
| 1.6.3.8.4 | Viewing Hierarchy of Pages within a Space | 164 |
| 1.6.3.8.5 | Viewing Pages Alphabetically | 164 |
| 1.6.3.8.6 | Viewing Recently Updated Content | 164 |
| 1.6.3.8.7 | Viewing Space Details | 165 |
| 1.6.3.9 | Space Backup and Restore | 165 |
| 1.6.4 | Archiving Mail Overview | 166 |
Welcome

About
The Confluence User’s Guide begins with an overview of the key features of Confluence, and goes on to describe the use of Confluence as a knowledge management tool and a collaborative environment. If you still have a question that has not been answered, please ask us.

This guide assumes that your Confluence site uses the default theme. If your site’s theme has been customised, menu items, and the look and feel, may appear differently from those in this guide.

For more documentation please visit Confluence Documentation Home.

Download
You can download the Confluence documentation in PDF, HTML or XML formats.

Getting Started

Confluence User’s Guide

Getting Started
Creating Content
Sharing Content
Watching Changes
Searching Confluence
Organising Content
Customising Confluence

Getting to know Confluence:
The Dashboard
Page Layout
Spaces in Confluence
Other Users

Personalising Confluence:
Change your password
Update your User Profile
Create your personal space
Choose the homepage you see when you log in
Customise the dashboard for yourself
Get notifications about changes
Dashboard

The dashboard is the front page of a Confluence site. It provides an overview of the site, access to all spaces to which you have ‘view’ permission, and displays a list of the most recently updated content within them.

You can go to the dashboard from anywhere in your site by clicking Dashboard at the top-left of the page.

The dashboard is divided into three sections:

- **Welcome message** — the welcome message for the site. Confluence Administrators can customise this message using the Administration Console.

- **Spaces, Pages, Network** — tabs that display your favourite content and people.
  - **Spaces** displays all the spaces to which you have access in the Confluence site, as well as the spaces you have marked as favourites.
  - **Pages** displays the pages you have marked as favourites.
  - **Network** displays the users that you are following (or who are following you).

- **Recent activity** — tabs that display recently updated content in All spaces, your Favourite spaces, or by space Categories.
  - **All Updates** displays updates from all spaces that you have permission to view.
  - **Favourite Spaces** displays updates from your favourite spaces.
  - **Space Categories** displays updates from spaces in the category you have selected from the list.
Notes

- The dashboard is the only place in Confluence where you can add a new space to the site. Use Add Space on the Spaces tab.
- By default, the dashboard is the home page for the Confluence site. However, you can set any other page in Confluence as the home page using the Space Admin tab or your user profile settings.
- Administrators can customise the global dashboard that all users see.
- Users can customise the dashboard for themselves.
- There are quick Add Page and Add Blog Post buttons at the top right of the dashboard.
- Clicking view change beside a page name displays a ‘comparison view’ against the content’s previous version.
- The Feed Builder link is now in the Browse menu.
- The People Directory link is now in the Browse menu.

Related Topics

Confluence Glossary
Confluence Icons
Working with Spaces

Take me back to the Confluence User’s Guide.

Page Layout in View Mode

The image below shows the menus and other controls on a typical Confluence page.

<table>
<thead>
<tr>
<th>Menu or option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse</td>
<td>Gives access to wiki content such as pages, blog posts, etc, and allows you to browse the People Directory. If you are an administrator, the space and site administration options appear here too.</td>
</tr>
<tr>
<td>User</td>
<td>After you have logged in, your name will appear at top right of the screen. This is the 'User' menu, and allows you to log out, access your user profile or view your editing history, personal labels and page watches. You can also retrieve drafts of pages you are editing.</td>
</tr>
<tr>
<td>Search</td>
<td>Type into this box and press 'Enter' to search.</td>
</tr>
</tbody>
</table>
**Related Topics**

Using the Editor
Overview of Spaces
Overview of Pages

Take me back to Confluence User’s Guide

**Confluence Glossary**

**Administration Console**

The Administration Console is the interface for the global administration of Confluence.

Only administrators can access the Administration Console.

**Administrators**

The Confluence permission scheme allows the following main levels of administrator permissions:

- System Administrator – full administrative access to Confluence.
- Confluence Administrator – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

**CamelCase**

CamelCase is a form of markup commonly used in wikis where words compounded together LikeThis without spaces are used to create links.

In Confluence, Camelcasing can be turned on from the Administration Console.

**Change Comment**

A change comment is a short description entered during the edit of a page to record the changes being made in the edit.

**Child Pages**

Creating child pages is a means of hierarchically organising content in Confluence. A child page can only have one parent page.

**Comments**

A comment may be a remark, question, or any other additional information you wish to add to a page pertaining to the topic the page covers. You can comment on any page or news item in Confluence.
Confluence Administrators

The Confluence permission scheme allows the following main levels of administrator permissions:

- **System Administrator** – full administrative access to Confluence.
- **Confluence Administrator** – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

Custom Decorators

Decorator files are used to define layouts in Confluence. They are vmd files and require knowledge of the language, Velocity, to edit.

Dashboard

The dashboard is the front page of a Confluence site. It provides an overview of the site, access to all spaces, and displays a list of the most recently updated content within them.

Form Field Markup

Form field markup is a specialised markup for creating form fields and is used when creating page templates.

Global Administrators

A global administrator is the same as a system administrator.

Global Spaces

Global spaces contain content on any theme or topic of your choice.

For more information about global spaces and personal spaces, see Working with Spaces.

Hover Profile

The hover profile is the pop-up you see when the mouse pointer pauses over a Confluence user's name. Use the hover profile to follow the user, visit their profile, and more.

JIRA

JIRA is Atlassian's award winning Issue tracking and project management application.

Visit Atlassian's website to learn more about JIRA.

Labels

Labels are user-defined tag words assigned to pages to categorise content in Confluence.

Macros

A macro is a command wrapped inside curly braces {...} used to perform programmatic functions and generate more complex content structures in Confluence.

Blog Posts

A blog post may be a journal entry, status report or any other timely information pertaining to a space.

Notifications

A notification is an email message sent to you updating you of changes to pages and spaces you choose to 'watch'.

Orphaned Pages

An orphaned page is a page without any incoming links.
Pages

Pages are the primary means of storing information in Confluence and are the building blocks of spaces.

Parent Page

A parent page is a page that has one or more child pages. It may itself be a child of another page.

People Directory

The People Directory contains a list of all users in your Confluence site. Each user's name links to their personal space.

Permalink

A permalink is the url used to link to specific content items like comments.

Personal Spaces

Personal spaces belong to particular users, and rather than being listed on the Dashboard, are available from the People Directory.

For more information about global spaces and personal spaces, see Working with Spaces.

RSS Feeds

An RSS feed is a format for delivering summaries of regularly changing web content. RSS is read by RSS newsreader programs.

You will need an RSS reader to subscribe to feeds within Confluence.

Confluence acts as an RSS reader for feeds from sites outside of Confluence.

RSS Reader

An RSS reader is a specialised RSS program (also called aggregator) that displays the contents of RSS feeds for you. To subscribe to RSS feeds within Confluence, you will need an RSS reader.

Site Administrators

The Confluence permission scheme allows two levels of administrator permissions:

- System Administrator – full administrative access to Confluence.
- Confluence Administrator – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

System Administrators

The Confluence permission scheme allows two levels of administrator permissions:

- System Administrator – full administrative access to Confluence.
- Confluence Administrator – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

Space Administrators

A space administrator is a user with the 'Space Admin' permission for the space. A user with this permission can perform a host of functions relating to the management of a space and has complete access to the space regardless of any other control settings or permissions.

Permissions for a space are only assigned and modified by space administrators.

Spaces

A space is an area within Confluence, containing your wiki pages. You can think of each space as a sub-site, or mini-site, each with its own home page.

There are two types of spaces: global spaces and personal spaces.
**Templates**

A template is a pre-defined page that can be used as a prototype when creating pages. Templates are useful for giving pages a common style or format.

**Themes**

Themes are pre-defined 'look and feel' styles which are configured from the administration menu and can be applied across Confluence or to a single space.

**Thumbnails**

As of Confluence 4.0, all images on the page that aren’t links are displayed as thumbnails: when you click on an image the full-size image is displayed in a pop-up.

**Tiny links**

A tiny link is the shortened url of a page which is useful when sending links to the page, for example, via email.

**Trackback**

Trackback is a mechanism by which two sites can stay informed each time one site refers to the other by means of trackback ‘pings’.

In Confluence, Trackback is enabled from the Administration Console.

**Trackback Autodiscovery**

Trackback autodiscovery is a block of code that can be placed in a web-page to describe where trackback pings should be sent for that page. You can read the technical specification for autodiscovery here.

When Trackback is enabled, Confluence uses Trackback Autodiscovery to ping pages that are linked to, and to advertise its own pages as being able to receive pings.

**Undefined Links**

An undefined link is a link to a page that has not yet been created. Clicking on the page link allows you create the page.

**User Profile**

Every user account in Confluence is linked to a profile that contains user related information and options to configuring user preferences.

**Watching a Page or Blog Post**

When you watch a page, you are sent an email notification whenever that page has been modified.

**Watching a Space**

When you watch a space, you are sent an email notification whenever content has been added or modified in that space.

**Wiki**

Pioneered by Ward Cunningham, and named after the Hawaiian word for ‘quick’, a wiki is a website that makes it easy for anyone to contribute pages, and link them together.

**Wiki Markup**

This is the markup used to write and edit page templates in Confluence.

**Related Topics**

Confluence Icons

Take me back to Confluence User's Guide

**Confluence Icons**
Icons are used throughout Confluence to provide quick links and indicators. The most frequently used icons are:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>inode</td>
<td>Indicates that restrictions apply to the current page. Click to see the restrictions and edit them.</td>
</tr>
<tr>
<td>attachment</td>
<td>Indicates that there are attachments to the current page. Click to open the 'Attachments View'.</td>
</tr>
<tr>
<td>people</td>
<td>Go to the people directory.</td>
</tr>
<tr>
<td>person</td>
<td>View a user profile.</td>
</tr>
<tr>
<td>personal</td>
<td>Go to a personal space.</td>
</tr>
<tr>
<td>global</td>
<td>Go to a global space.</td>
</tr>
<tr>
<td>space</td>
<td>View a space's homepage.</td>
</tr>
<tr>
<td>page</td>
<td>View a page.</td>
</tr>
<tr>
<td>page</td>
<td>Add a page.</td>
</tr>
<tr>
<td>page</td>
<td>Add a child page to the current page.</td>
</tr>
<tr>
<td>blog</td>
<td>View a blog post.</td>
</tr>
<tr>
<td>blog</td>
<td>Add a blog post.</td>
</tr>
<tr>
<td>edit</td>
<td>This page has been edited since you last viewed it. Click to view the page.</td>
</tr>
<tr>
<td>comment</td>
<td>View a comment.</td>
</tr>
<tr>
<td>comment</td>
<td>Add a comment.</td>
</tr>
<tr>
<td>email</td>
<td>View a piece of archived mail that has been imported into Confluence.</td>
</tr>
<tr>
<td>checkmark</td>
<td>View a page that has been imported into Confluence.</td>
</tr>
<tr>
<td>attachment</td>
<td>View an attachment.</td>
</tr>
<tr>
<td>star</td>
<td>This page/space/person is currently a favourite. Click to remove from your favourites.</td>
</tr>
<tr>
<td>star</td>
<td>Add this page, space or person to your favourites.</td>
</tr>
<tr>
<td>watch</td>
<td>You are currently watching this page or space. Click to stop watching.</td>
</tr>
<tr>
<td>watch</td>
<td>Start watching this page or space.</td>
</tr>
</tbody>
</table>
Go to the RSS feed builder.

Subscribe to a pre-defined RSS feed.

View a printable version of this page. Note: From Confluence 2.8, most pages do not show this icon. You can print a Confluence page via your browser's print option.

Export the contents of this space to PDF, HTML and XML.

Define labels.

Choose a space's theme.

Choose a space's colour scheme.

Define a layout for a space, its pages and/or blog posts.

View space permissions.

View page permissions.

### Related Topics

Dashboard
Confluence Glossary

Take me back to Confluence User's Guide

# Keyboard Shortcuts

Confluence provides a number of keyboard shortcuts that you can use to speed up your editing and viewing. This page describes the keyboard shortcuts for the English language. The shortcut keys (letters of the alphabet) may be different in other languages.

- Press the key combination **Shift+?** to see all the keyboard shortcuts available in Confluence.

---

### On this page:

- Keyboard Shortcuts
  - All Screens
  - Editor
  - Tables (in the Editor)
  - View Screen
  - Autocomplete
  - Viewing a List of Available Keyboard Shortcuts
  - Enabling and Re-Enabling Keyboard Shortcuts
  - Notes
  - Related Topics

### Keyboard Shortcuts

The first section below describes the keyboard shortcuts that are available on all Confluence screens. Subsequent sections describe the shortcuts specific to each type of screen.

### All Screens
<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>/</td>
<td>Enable the quick search</td>
<td>/</td>
</tr>
</tbody>
</table>
| Ctrl+S  | • Submit (where a form is active).  
          • Editor -- save the Confluence page.  
          • Outside the editor -- save the browser page. | Cmd+S    |
| G then D| Go to the dashboard                                                    | G then D |
| G then S| Browse the current space                                              | G then S |
| ?       | Open the Keyboard Shortcut help                                       | ?        |
| S       | Open the status dialog for a status update                            | S        |
| [       | Toggle the left-hand navigation bar, when the space is using the Documentation theme. | [       |

**Editor**

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Alt+0</td>
<td>Apply the paragraph style.</td>
<td>Cmd+0</td>
</tr>
<tr>
<td>Ctrl+Alt+(1–6)</td>
<td>Apply a heading level (of the number chosen) to the current line.</td>
<td>Cmd+(1–6)</td>
</tr>
<tr>
<td>Ctrl+Alt+7</td>
<td>Apply the preformatted style.</td>
<td>Cmd+7</td>
</tr>
<tr>
<td>Ctrl+Alt+8</td>
<td>Apply the block quote style.</td>
<td>Cmd+8</td>
</tr>
<tr>
<td>Ctrl+Shift+A</td>
<td>Open the Macro Browser.</td>
<td>Cmd+Shift+A</td>
</tr>
<tr>
<td>Ctrl+B</td>
<td>Make the selected text <strong>bold</strong>.</td>
<td>Cmd+B</td>
</tr>
<tr>
<td>Ctrl+Shift+B</td>
<td>Format text as a bulleted list.</td>
<td>Cmd+Shift+B</td>
</tr>
<tr>
<td>Ctrl+Shift+D</td>
<td>Insert wiki markup. (Opens the Wiki Markup dialog.)</td>
<td>Cmd+Shift+D</td>
</tr>
<tr>
<td>Ctrl+Shift+E</td>
<td>Preview the page you are editing.</td>
<td>Cmd+Shift+E</td>
</tr>
<tr>
<td>Ctrl+Shift+F</td>
<td>Toggle full screen mode.</td>
<td>Cmd+Shift+F</td>
</tr>
<tr>
<td>Ctrl+I</td>
<td>Make the selected text <em>italic</em>.</td>
<td>Cmd+I</td>
</tr>
<tr>
<td>Ctrl+Shift+J</td>
<td>Insert a JIRA issue. (Opens the Insert JIRA Issue dialog.)</td>
<td>Cmd+Shift+J</td>
</tr>
<tr>
<td>Ctrl+K</td>
<td>Insert a link. (Opens the Insert Link dialog.)</td>
<td>Cmd+K</td>
</tr>
<tr>
<td>Ctrl+Shift+K</td>
<td>Suggests a list of pages or other locations to link to from your page.</td>
<td>Cmd+Shift+K</td>
</tr>
<tr>
<td>Ctrl+M</td>
<td>Insert an image. (Opens the Insert Image dialog.)</td>
<td>Cmd+M</td>
</tr>
<tr>
<td>Ctrl+Shift+M</td>
<td>Suggests a list of images, documents and other files to embed in your page.</td>
<td>Cmd+Shift+M</td>
</tr>
</tbody>
</table>
### Ctrl+Shift+N Format text as a numbered list.  
Cmd+Shift+N

### Ctrl+S Save the page you are editing.  
Cmd+S

### Ctrl+Shift+S Format text with a strike through.  
Cmd+Shift+S

### Ctrl+Alt+Q Apply the quote style to the current line.  
Cmd+Alt+Q

### Ctrl+U Make the selected text underlined.  
Cmd+U

### Ctrl+Y Revert an action that was undone.  
Cmd+Y

### Ctrl+Z Undo the most recent action.  
Cmd+Z

### Ctrl+Alt+7 Apply the default paragraph style to the current line.  
Cmd+7

### Tab Indent current line (only in bulleted lists and numbered lists).  
Tab

### Shift+Tab ‘Outdent’ current line (only in bulleted lists and numbered lists).  
Shift+Tab

---

### Tables (in the Editor)

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+C</td>
<td>Copy the current table row.</td>
<td>Cmd+Shift+C</td>
</tr>
<tr>
<td>Ctrl+Shift+I</td>
<td>Insert a table. (Opens the Insert Table dialog.)</td>
<td>Cmd+Shift+I</td>
</tr>
<tr>
<td>Ctrl+Shift+V</td>
<td>Paste the current table row.</td>
<td>Cmd+Shift+V</td>
</tr>
<tr>
<td>Ctrl+Shift+X</td>
<td>Cut the current table row.</td>
<td>Cmd+Shift+X</td>
</tr>
</tbody>
</table>

### View Screen

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Create a blog post.</td>
<td>B</td>
</tr>
<tr>
<td>C</td>
<td>Create a child page of your current page.</td>
<td>C</td>
</tr>
<tr>
<td>E</td>
<td>Edit a page or blog post, or return to Edit mode when previewing.</td>
<td>E</td>
</tr>
<tr>
<td>K</td>
<td>Open the Link To dialog.</td>
<td>K</td>
</tr>
<tr>
<td>L</td>
<td>Add or edit labels.</td>
<td>L</td>
</tr>
<tr>
<td>M</td>
<td>Add a comment to a page or blog post.</td>
<td>M</td>
</tr>
<tr>
<td>T</td>
<td>View attachments.</td>
<td>T</td>
</tr>
<tr>
<td>V</td>
<td>Return to page view (only if you are viewing page attachments).</td>
<td>V</td>
</tr>
<tr>
<td>W</td>
<td>Add or edit watchers.</td>
<td>W</td>
</tr>
</tbody>
</table>
Autocomplete

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>[]</td>
<td>See a list of suggested pages or other locations to link to from your page.</td>
</tr>
<tr>
<td>!</td>
<td>See a list of suggested images, multimedia files and documents to embed in your page.</td>
</tr>
<tr>
<td>{}</td>
<td>See a list of suggestions as you begin typing a macro name.</td>
</tr>
<tr>
<td>@</td>
<td>See a list of suggested users to mention.</td>
</tr>
</tbody>
</table>

See more about using autocomplete.

Viewing a List of Available Keyboard Shortcuts

Choose Browse > Keyboard Shortcuts (or press the key combination Shift+?) to show the Keyboard Shortcuts dialog.

In the Keyboard Shortcuts dialog, you can:

- Select the **General** tab to view global, page and blog post shortcuts.
- Select the **Editor** tab to view the text editing and formatting shortcuts.
- Select the **Editor Autoformatting** tab to view the wiki markup and autoformatting shortcuts.

**Screenshot: General keyboard shortcuts**

```
<table>
<thead>
<tr>
<th>Keyboard Shortcuts</th>
<th>View All Shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>Enable General Shortcuts</td>
<td></td>
</tr>
<tr>
<td><strong>Global Shortcuts</strong></td>
<td><strong>Page / Blog Post Actions</strong></td>
</tr>
<tr>
<td>Go to Dashboard:</td>
<td>g then d</td>
</tr>
<tr>
<td>Browse Current Space:</td>
<td>g then a</td>
</tr>
<tr>
<td>Open Shortcut Help:</td>
<td>?</td>
</tr>
<tr>
<td>Quick Search:</td>
<td>/</td>
</tr>
<tr>
<td>Update Status:</td>
<td>s</td>
</tr>
<tr>
<td>Add Page:</td>
<td>c</td>
</tr>
<tr>
<td>Add Blog:</td>
<td>b</td>
</tr>
<tr>
<td>Edit:</td>
<td>e</td>
</tr>
<tr>
<td>Comment:</td>
<td>m</td>
</tr>
<tr>
<td>Edit Labels:</td>
<td>l</td>
</tr>
<tr>
<td>Edit Watchers:</td>
<td>w</td>
</tr>
<tr>
<td>View Attachments:</td>
<td>t</td>
</tr>
<tr>
<td>Link to Page:</td>
<td>k</td>
</tr>
</tbody>
</table>
```

**Screenshot: Editor keyboard shortcuts**
### Disabling and Re-Enabling Keyboard Shortcuts

Keyboard shortcuts are enabled by default. If required, you can disable general keyboard shortcuts. You cannot disable the editor keyboard shortcuts.

**To disable or re-enable general keyboard shortcuts:**

1. Choose Browse > Keyboard Shortcuts (or press the key combination Shift+?).
2. Click the General tab on the left of the Keyboard Shortcuts dialog.
3. Select or clear the Enable General Shortcuts checkbox as required.

### Notes
Supported Web Browsers

Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. You can find the list of supported web browsers and browser versions on this page: Supported Platforms.

- The Keyboard Shortcuts dialog also displays the trigger characters for the Confluence autocomplete feature. See Using Autocomplete.

Related Topics

Confluence keyboard shortcuts are consistent with JIRA keyboard shortcuts. Please see the JIRA documentation: Using Keyboard Shortcuts.

Confluence Wiki Markup

Using Autocomplete

Take me back to Confluence User's Guide

Creating Content

You can create the following types of content in Confluence:

- Pages
- Blog posts
- Comments

For each of these, you use the editor to enter and format the text, and to embed content, or add links to other pages.

When you first create the page, you can choose a template that the page should be based on.

When you first save the page, you can choose where the page should be located.

You can also import content into Confluence from a variety of other sources.

Related Topics

Organising Content

Managing Users

Take me back to the Confluence User's Guide.

Using the Editor

The editor in Confluence provides an easy and fast way to create and edit Confluence pages, blog posts and comments. It allows you to enter content as you would in a Word document, to apply formatting simply by clicking buttons on a toolbar, and to embed other content and files into the page.

You begin an editing session by clicking Edit at the top of a page (or by pressing ‘E’ on the keyboard) when viewing a Confluence page or blog post.

Permissions

To edit a page, you need the 'Add Pages' permission for that space, which is assigned by a space administrator from the Space Administration screens. See space permissions or contact a space administrator for more information.

Note that the options available to you when editing depend on the permissions granted to you by the space administrator.
On this page:

- The Toolbar
- An Editing Session
- Embedding Content in the Page
- Things to Help You Work Faster
  - Autoformatting
  - Autocomplete
  - Drag-and-Drop
  - Keyboard Shortcuts
- Related Topics

Screenshot: The Confluence Editor

<table>
<thead>
<tr>
<th>Page Item</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page title</td>
<td>This name is used in links to the page.</td>
</tr>
<tr>
<td>Page content</td>
<td>Type content for the page here.</td>
</tr>
<tr>
<td>Editor toolbar</td>
<td>Provides tools to format and colour content, create lists and tables, indent and align text, and insert other content into the page such as symbols, links, images, multimedia files and macros.</td>
</tr>
<tr>
<td>Restrictions</td>
<td>View the current page restrictions, and control who can view or edit the page.</td>
</tr>
<tr>
<td>Attachments</td>
<td>View, and manage, the attached files on the page.</td>
</tr>
<tr>
<td>Labels</td>
<td>Add labels to a page, to categorise the page content.</td>
</tr>
<tr>
<td>Change comment</td>
<td>Type a comment that describes the changes you have made.</td>
</tr>
<tr>
<td>Notify watchers</td>
<td>When selected, users who are watching the page will be receive email notification of your changes to the page.</td>
</tr>
<tr>
<td>Preview</td>
<td>See how your changes will appear, without saving the page.</td>
</tr>
<tr>
<td>Save</td>
<td>Save the changes you have made to the page. (Ctrl+S)</td>
</tr>
<tr>
<td>Cancel</td>
<td>End the editing session, without saving any changes.</td>
</tr>
</tbody>
</table>

The Toolbar

The editor toolbar allows you to:
- Apply paragraph styles and character formatting (such as bold, italics, superscript).
- Choose colour for text.
- Create numbered and bulleted lists.
- Set the indenting and alignment for text and images.
- Create links to other pages, attachments, anchors and external resources.
- Add tables, and add, remove, cut and paste rows and columns, highlight cells, rows and columns, and merge and split cells.
- Insert other content into the page, such as images, multimedia, attachments, symbols and wiki markup.
- Use macros to add other types of content, such as a list of JIRA issues or a table of contents.

Screenshots: The Editor Toolbar

An Editing Session

You start an editing session whenever you:

- create a new page, blog post or page comment
- edit an existing page, blog post or comment (by pressing ‘E’ on the keyboard, or clicking Edit).

While in an editing session, you can also:

- Name, or rename, a page or blog post. Note that renaming has effects that you should consider.
- Add a comment describing the changes you made.
- Choose whether or not people watching the page get notified of the change you made.
- Add labels to the page.

Confluence automatically saves drafts of your page as you work. If another user begins editing the same page as you, Confluence will display a message, and will try to merge the changes when you save your page.

Click Cancel (at the bottom of the page) if you want to end the session without saving any changes.

The session ends when you click Save.

When you create a new page you can choose the location where the page should be saved. You can also move a page after it has been saved, to make it a child page of a different page, or to move it to another space.

To see changes between different versions of the page, look at the history of the page.

Embedding Content in the Page

Click Insert on the editor toolbar to embed any of the following types of content so that they are displayed on your page:

- An image.
- A link to another Confluence page or external URL, or a link to an attachment or image.
- An emoticon, symbol or horizontal line.
- A macro. Choose either a specific macro, or Other Macros, from the Insert menu.

Things to Help You Work Faster

Autoformatting

You can type Confluence wiki markup directly into the editor to have Confluence “auto-format” your text on the fly. To learn more, click ? on the editor toolbar and choose the 'Editor Autoformatting' tab.
**Autocomplete**

When editing a page or blog post, you can enter a trigger character to show a list of suggested links, media files or macros to add to your page. This feature is called ‘autocomplete’ and provides you with a fast editing solution if you prefer to use key strokes rather than pointing and clicking with the mouse.

Quick summary of autocomplete:

<table>
<thead>
<tr>
<th>Type</th>
<th>To see suggested:</th>
</tr>
</thead>
<tbody>
<tr>
<td>[</td>
<td>pages and blog posts</td>
</tr>
<tr>
<td>!</td>
<td>multimedia files</td>
</tr>
<tr>
<td>{</td>
<td>macros</td>
</tr>
<tr>
<td>@</td>
<td>mentions</td>
</tr>
</tbody>
</table>

For details, see Using Autocomplete.

**Drag-and-Drop**

You can drag a file such as an image, video, audio file, Office document or PDF file, directly into the editor. The contents of the file will be embedded into the page or blog post. Please refer to the following pages for more information:

- Displaying Images – Embedding images onto a Confluence page or blog post.
- Embedding Multimedia Content – Embedding videos, audio files and other multimedia files onto a Confluence page or blog post.
- Displaying Office Files in Confluence – Embedding Office and PDF files onto a Confluence page or blog post.

**Keyboard Shortcuts**

You can view the Keyboard Shortcuts dialog by clicking ? on the toolbar.

**Related Topics**

- Page Layout in View Mode
- Working with Tables
- Displaying Images
- Editing and Removing Links
- Linking to Images
- Linking to Attachments
- Inserting Emoticons and Icons
- Inserting Symbols

Take me back to Confluence User's Guide

**Working with Text Effects**

The Confluence editor supports most text effects available in standard text editing applications.

On this page:

- Applying Paragraph Styles
- Applying Character Formats
- Applying Text Colours
- Related Topics

**Applying Paragraph Styles**

Choose a paragraph style from the editor toolbar, or click in the paragraph and use one of the keyboard shortcuts Ctrl+(0–8) .

_Screenshot: Choosing paragraph styles from the editor toolbar_
Applying Character Formats

To apply a character format, select the text and click one of the editor toolbar buttons, or use a keyboard shortcut. Some formats are available from the 'More' menu.

**Screenshot: Text formatting buttons on the editor toolbar**

<table>
<thead>
<tr>
<th>Format</th>
<th>Shortcut Key</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Ctrl+B</td>
</tr>
<tr>
<td><em>Italics</em></td>
<td>Ctrl+I</td>
</tr>
<tr>
<td><strong>Underline</strong></td>
<td>Ctrl+U</td>
</tr>
<tr>
<td><strong>Strikethrough</strong></td>
<td>Ctrl+Shift+S</td>
</tr>
<tr>
<td><strong>Superscript</strong></td>
<td>none</td>
</tr>
<tr>
<td><strong>Subscript</strong></td>
<td>none</td>
</tr>
<tr>
<td><strong>Monospace</strong></td>
<td>none</td>
</tr>
</tbody>
</table>

Choose **Clear Formatting** from the 'More' menu to remove all formatting.

Applying Text Colours

To apply colour to text, select the text and click the 'Colour' button. Choose which colour is applied using the 'More colours' button.

**Screenshot: Picking colours from the editor toolbar**
Confluence makes adding links as simple as possible. You can link to content anywhere within the Confluence site or on another web site.

You can add links to the following types of content:

- Pages in the same space, in another space, or outside Confluence (i.e. webpages)
- Blog posts
- Pages that haven't yet been created, but for which you require a placeholder on the current page.
- Attachments, such as images and multimedia files
- User profiles or personal spaces

You can also link from an image, and use a link to begin composing a new email message.

You create all these kinds of links using the ‘Insert Link’ dialog that is available in the editor (choose Insert > Link). You can also create links:

- using autocomplete as a shorthand way of creating the most common types of links.
- by copying a link from one page and paste it when editing another page.

You can edit and remove links while editing the page, using the link properties panel.

![Confluence 4.0 Documentation](image)

**Handy Hints**

- Links in Confluence will not break even when you rename pages or move them between spaces on your site. This only works for page links that use the relative link syntax, for example [Renaming a Page].
- Looking for a link type not shown above? You might find a plugin can help you.

**Related Topics**

- Working with Anchors
- Trackback
- Linking to Confluence Pages from Outside Confluence

**Linking to Personal Spaces and User Profiles**

This page describes how to add a link to a user's personal space or user profile from within another Confluence page.

You can link to a user's personal space (or user profile) easily if you know their username.

If the user does not have a personal space, then the link will go to their user profile.

**Linking to a User's Personal Space using Autocompletion**

You can use autocomplete to create a link to a user's personal space in the Confluence site. Trigger autocomplete and start typing their name.

You can type [ to see a list of suggested links. For details, see Using Autocomplete.
**Linking to a User’s Personal Space using the Insert Link Dialog**

1. While editing the page, place your cursor at the point where you want to create the link, or highlight the text that you want linked.
2. Click Link in the toolbar, or press Ctrl+K. See keyboard shortcuts for more information.
3. Click the Search tab on the left.
4. Start typing the user’s name into the search field. Confluence will suggest options as you type.
5. Select the user from the autocomplete results.
6. Enter link text that will be displayed on the page, if required. If you have not highlighted text in the page, and leave the 'Link Text' text box empty, the link will display the destination page name or URL.
7. Click Insert.

**Related Topics**

User Profile Overview
Setting up your Personal Space
Working with Links

Take me back to Confluence User’s Guide

**Linking from an Image**

This page describes how to create a link from an image on one page to another page or URL. When the user clicks the image, they will be redirected to the linked page or other resource.

To create a link from an image:

1. Display the image on the page. The image can either be attached to the page or available on another page. See Displaying Images.
2. Create the link by clicking on the image and then clicking Link in the properties panel. Specify the link target using the 'Insert Link' dialog. See Linking to Pages.

You can edit the link by clicking on the image, when editing the page, and clicking Edit Link in the properties panel.

**Related Topics**

Using Images
Working with Links
Working with Attachments
Displaying Images

Take a look at some plugins too.

⚠️ First read the warning on support of third-party plugins.

- ImageMap Plugin
- Other image and visualisation plugins

Take me back to Confluence User's Guide

**Using a Link to Create a New Email Message**

This page describes how to insert a link that, when clicked, launches the default email client.

You can provide your own text to use as the link text instead of the 'mailto' tag.

To insert a link that creates a new email message:

1. Edit the page on which you want to insert the link.
2. Choose Insert > Link and select the Web Link tab.
3. Enter an email address, such as 'jsmith@non.existent.corp.com'.
Linking to Attachments

This page describes how to add a text link pointing to a file attached to your Confluence page. When a reader clicks the link, the file is displayed in the browser.

Quick guide to linking to an attachment

1. Click Link on the editor toolbar.
2. Select one of these options:
   • Search – to search for and link to any image or file attached to any page in your Confluence site.
   • Recently Viewed – to link to a recently visited page.
   • Attachments – to link to an image or file attached to the current Confluence page.
   • Web Link – to link to any webpage.

On this page:

- Adding a Link using Autocomplete
- Adding a Link using the Link Browser
- Related Topics

Adding a Link using Autocomplete

You can use autocomplete to add a text link to a file or image attached to any Confluence page.

You can type [ to see a list of suggested links. For details, see Using Autocomplete.

Adding a Link using the Link Browser

The ‘link browser’ is the ‘Insert Link’ or ‘Edit Link’ dialog that appears when you click Link in the editor toolbar.

To link to a file or image that is attached to the current page:

1. Edit the page where you want to insert the link.
2. Click Link in the editor toolbar, and then the Attachments tab. You will see a list of all files attached to the page. Now you can do one of the following:
   • Click on the file that you want to link to, if it is already attached to the page.
   • Attach a new file to the page by clicking Browse and uploading your file.
3. Enter the Link Text. These are the words that will appear as the hyperlink on the page.
4. Click Insert to add the link.

To link to a file or image that is attached to any Confluence page:

1. Edit the page where you want to insert the link.
2. Click Link in the editor toolbar, and then the Search tab.
3. Start typing the name of the file or image. Confluence will offer a list of matching file names. If the file does not appear, click Search to find pages that contain the search text.
4. Click the required file in the list or the search results.
5. Enter the Link Text. These are the words that will appear as the hyperlink on the page.
6. Click Insert to add the link.

Screenshot: The link browser, showing autocomplete in the ‘Search’ option
The Anchor macro allows you to link to specific parts of a page. Anchor links can be especially useful when navigating between sections of a long document or when you want to link to a segment of a page and not to the page as a whole.

Anchors are invisible to the reader when the page is rendered.

There are two steps to using an anchor:

1. Create the anchor for the content.
2. Create the link to the anchor.

### Creating an Anchor

You use the Anchor macro to create an anchor for content that you want to be able to link to.

**To add the Anchor macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

#### Parameter

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists...
parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anchor Name</td>
<td>None; name must be supplied</td>
<td>This is the name of the anchor that you will link to.</td>
</tr>
</tbody>
</table>

The page Linking to Pages does not exist.

**Notes**

- If you are adding an anchor to the site welcome message, it can only be linked to from another page. Internal-only links will not render.
- Page titles and links to other spaces can be combined with anchors and attachments, but you cannot use attachments and anchors in the same link.

**Related Topics**

Working with Links

Take me back to the Confluence User's Guide.

**Linking to Confluence Pages from Outside Confluence**

Sometimes you may want to link to a Confluence page from outside of Confluence, such as from another website or from within an email. In this case, you should consider using a link to a 'permanent' URL (also called a 'permalink'), in case the name of the Confluence page changes.

If you are linking to a page from another page in the same Confluence site, it is better to use an internal wiki link rather than a permalink. Confluence can keep track of internal links and will let you know if the link is broken, such as when someone removes the linked page. See Linking to Pages. Internal wiki links are automatically updated if the page is renamed. This only works for page links that use the relative link syntax, for example [Renaming a Page].

**To link to a page's permanent URL:**

1. Choose Tools > Link to this Page.
2. Copy the Tiny Link and paste it into your email or external web page. This will create a link to the latest version of your Confluence page.

**Trackback**

Trackback is a mechanism by which two sites can stay informed each time one site refers to the other by means of trackback 'pings'.

In Confluence, Trackback is enabled by a site administrator from the Administration Console. When Trackback is enabled, any time you link to an external webpage that supports Trackback Autodiscovery, Confluence will send a Trackback ping to that page to inform it that it has been linked to.

Confluence pages also support Trackback Autodiscovery, and when Trackback is enabled can receive trackback pings sent by other sites.

**To see who has sent a Trackback ping to a Confluence page:**

1. Go to the page.
2. Choose Tools > Info to go to the 'Information' view for the page.

Any Trackback pings the page has received will be listed under the page's Incoming Links

Confluence incoming trackback pings only work with referenced pages that are public (anonymously viewable)

See more information about the Information View.

**Related Topics**

Enabling Trackback
Managing External Referrers
Linking to Pages
Linking to Blog Posts

You can link to blog posts in similar ways to how you link to pages. Only two methods are described on this page.

You can also use the Blog Posts macro to display a dynamic list of blog posts on your page.

**You must create the blog post first**

Linking to a blog post that has not been created yet will not result in a link. Blog posts are very tightly bound to the time at which they were created, so it makes no sense to link to them before they exist.

**Linking to a Blog Post using Autocomplete**

**You need to know the title of the blog post.**

You can use autocomplete to create a link to any blog post in the Confluence site, if you know the name of the post you want to link to.

You can type [ to see a list of suggested links. For details, see Using Autocomplete.

**Linking to a Blog Post using its URL**

**You need to know the absolute path to the blog post.**

To create a link to a blog post using the 'Insert Link' dialog:

1. While editing the page, place your cursor at the point where you want to create the link, or highlight the text that you want linked.
2. Click Link in the toolbar, or press Ctrl+K. See keyboard shortcuts for more information.
3. Click Web Link and enter or paste the absolute path to the blog post into the URL text box.
4. Enter link text that will be displayed on the page if required. If you have not highlighted text in the page, and leave the 'Link Text' text box empty, the link will display the destination page name or URL.
5. Click Insert.

**Related Topics**

Working with Blog Posts
Working with Links
Blog Posts Macro

Linking to Images

This page describes how to insert a link on your Confluence page that points to an image. Linking to an image is a way to have text on a page that, when clicked, takes the user to that image.

**Quick guide to linking to an image**

1. Click Link on the editor toolbar.
2. Select one of these options:
   - Search – Search for and link to any image or file attached to any page in your Confluence site.
   - Attachments – Link to an image or file attached to the current Confluence page.

The rest of this page gives more details of the above procedure and additional options.

**On this page:**

- Adding a Link with the Link Browser
- Adding a Link using Autocomplete
- Related Topics

**Adding a Link with the Link Browser**

To link to an image that is attached to the current page:
1. Edit the page where you want to insert the link.
2. Click **Link** on the toolbar.
3. Choose the **Attachments** tab in the left-hand panel. You will see a list of all files attached to the page. Now you can:
   - Select an image that is already attached to the page.
   - Attach a new image to the page by clicking **Browse** and uploading your file.
4. Enter the **Link Text**. These are the words that will appear as the hyperlink on the page.
5. Click **Insert**.

**To link to an image that is attached to any Confluence page:**

1. Edit the page where you want to insert the link.
2. Click **Link** on the toolbar.
3. Select the **Search** option in the left-hand panel.
4. Start typing the name of the image. Confluence will suggest image files. If the image does not appear in the list, click **Search**.
5. Click the image name in the autocomplete results or the search results.
6. Click **Insert**.

_Screenshot: The link browser, showing autocomplete in the ‘Search’ option_

---

**Adding a Link using Autocomplete**

You can use the autocomplete functionality to link to an image attached to any Confluence page.

You can type `[]` to see a list of suggested links. For details, see Using Autocomplete.

**Related Topics**

- Linking to Attachments
- Editing and Removing Links
- Displaying Images

**Working with Tables**

The Confluence editor provides several table editing features.

**Inserting a Table**

**To create a table:**

1. While editing the page, place your cursor at the point where you want to insert the table.
2. Click **Table** on the toolbar.
3. Click in a cell to set the number of columns and rows for your table.

**Table Operations**

While editing a page, the following table operations are available from the toolbar.

<table>
<thead>
<tr>
<th>Table operation</th>
<th>Toolbar button</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert an empty row above the current one</td>
<td><img src="image" alt="Insert Row Above" /></td>
</tr>
<tr>
<td>Insert an empty row below the current one</td>
<td><img src="image" alt="Insert Row Below" /></td>
</tr>
<tr>
<td>Remove the current row</td>
<td><img src="image" alt="Remove Row" /></td>
</tr>
<tr>
<td>Cut the current row and copy it to the Clipboard</td>
<td><img src="image" alt="Cut Row" /></td>
</tr>
<tr>
<td>Copy the current row to the Clipboard</td>
<td><img src="image" alt="Copy Row" /></td>
</tr>
<tr>
<td>Paste the row from the Clipboard to the current row</td>
<td><img src="image" alt="Paste Row" /></td>
</tr>
<tr>
<td>Insert an empty column to the left of the current one</td>
<td><img src="image" alt="Insert Column Left" /></td>
</tr>
<tr>
<td>Insert an empty column to the right of the current one</td>
<td><img src="image" alt="Insert Column Right" /></td>
</tr>
<tr>
<td>Remove the current column</td>
<td><img src="image" alt="Remove Column" /></td>
</tr>
<tr>
<td>Merge the selected cells</td>
<td><img src="image" alt="Merge Cells" /></td>
</tr>
<tr>
<td>Split the selected merged cells</td>
<td><img src="image" alt="Split Cells" /></td>
</tr>
<tr>
<td>Highlight the current row</td>
<td><img src="image" alt="Highlight Row" /></td>
</tr>
<tr>
<td>Highlight the current column</td>
<td><img src="image" alt="Highlight Column" /></td>
</tr>
<tr>
<td>Highlight the current cell</td>
<td><img src="image" alt="Highlight Cell" /></td>
</tr>
<tr>
<td>Remove the table</td>
<td><img src="image" alt="Remove Table" /></td>
</tr>
</tbody>
</table>

**Related Topics**

Take me back to the [Confluence User's Guide](Confluence User's Guide).

**Using Images**
Confluence 4.0 Documentation

Confluence allows you to add images to a page, or a blog post, either individually, or as a gallery that can be viewed as a slide show. All images on the page are displayed as thumbnails: when you click on an image the full-size image is displayed in a pop-up.

In general, you display an image on a page by either of the following:

- Attach the image to the page first, and then edit the page to choose where the image should appear.
- Insert an image on the page, where the image is attached to another Confluence page, or is available on an external webpage.

You can also add text links to a page that point to an image located elsewhere.

More information about using images in Confluence can be found here:

- Displaying an image on a Confluence page.
- Linking from an image.
- Linking to images.

A Confluence Administrator can set the sizes of thumbnails via the Administration Console. This will also affect the images displayed by the Gallery macro.

Related Topics

Image File Formats
Thumbnail Settings
Choosing a Profile Picture
Working with Attachments
Embedding PowerPoint Presentations in a Page
Gallery Macro

Take me back to Confluence User's Guide

Displaying Images

An image can be displayed on a Confluence page in the following cases:

- the image is attached to the page.
- the image is attached to another page of the same Confluence site, even if in another space.
- the image is on a remote webpage.

Once the image is displayed on the page, you can:

- move the image to a new position on the page simply by cutting and pasting.
- click on the image to change how it appears on the page.

You can also link from an image to another page.

On this page:

- Displaying an image attached to the page
- Displaying an image attached to a different page
- Displaying an image from a remote webpage
- Controlling the image appearance
- Related Topics

Displaying an image attached to the page

There are several methods for attaching image files to a page.

Once you have attached an image to a page, there are different methods for choosing where on the page the image should appear:

Using the 'Insert Image' dialog

Once an image is attached to the page, you can edit the page to choose where the image should appear.

To position an attached image on the page:

1. While editing the page, position the cursor where you want to place the image.
2. Choose Insert > Image and click on the Attached Images tab.
3. Select the required image and click Insert (or just double-click on the image).

Using autocomplete

Once an image is attached to the page, you can use autocomplete while editing the page to choose where the image should appear.

To position an attached image on the page:

1. While editing the page, position the cursor where you want to place the image.
2. Trigger the autocomplete function by typing '!'.
3. Choose the image from the list that appears.

Using drag-and-drop

Depending on the browser you are using, you can attach and position an image in one step. While you are editing a page, simply drag-and-drop an image file on to the page. The image is attached to the page and is placed at the current cursor position.

Displaying an image attached to a different page

You can display an image that is attached to a different page of the same Confluence site, as long as you know the name of the image. This approach can make it easier to manage your images by allowing you to keep them all in the same place.

To display an image attached to a different page:
1. While editing the page, position the cursor where you want to place the image.
2. Choose Insert > Image and click on the Search tab.
3. Type in the name of the image.
4. Choose whether to search the current space or All Spaces and click Search.
5. Select the required image from the search results and click Insert.

Alternatively, you can simply cut and paste the image from another page.

Displaying an image from a remote webpage

You can display an image from a remote webpage on your Confluence page, without needing to attach it to your page. You need to know the URL for the image, not for the webpage it appears on. Note that you should have permission to use that image on your page.

To display an image located on a webpage:
1. While editing the page, position the cursor where you want to place the image.
2. Choose Insert > Image and click on From the Web.
3. Type in the URL for the image. An example is: http://www.atlassian.com/software/confluence/images/icon_customerslove_big.png
4. Click Preview to check that the URL and image are correct.
5. Click Insert.

Alternatively, you can simply cut and paste the image from a webpage.

Controlling the image appearance

When editing the page, click on the image to show the image properties panel. The panel allows you to set the display size for the image and choose whether the image has a border. See also Linking from an Image.

To set the size of the image, do one of the following:

- Click on one of the size ‘preset’ buttons (the image width in pixels is displayed to the left).
- Click on the image size text and enter a new image width, in pixels.

Note that images are displayed as thumbnails.

To add a border to the image:

- Click Border in the image properties panel.

To align an image:

- Select the image and use the alignment buttons in the editor toolbar.

Screenshot: The image properties panel beneath an image
For further information regarding image appearance see Confluence Wiki Markup.

**Related Topics**

Using Images  
Working with Links  
Working with Attachments

**Image File Formats**

Confluence allows you to attach image files of any format to a page. However, your ability to display them depends on the image file formats supported by the browser you are using.

Confluence supports the following image formats for its Thumbnail and Gallery macros:

- gif
- jpeg
- png

The bmp format is not supported.

**Using Autocomplete**

When using the Confluence editor, you can type a trigger character or press a keyboard shortcut to see a list of suggested links, files or macros to add to your page, or to mention another user (and automatically notify them of this).

<table>
<thead>
<tr>
<th>What You Want to Do</th>
<th>Trigger Character</th>
<th>Keyboard Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a link on your page</td>
<td>[</td>
<td>Ctrl+Shift+K</td>
<td>See a list of suggested pages or other locations to link to from your page. More...</td>
</tr>
<tr>
<td>Display an image, video, audio file or document on your page</td>
<td>!</td>
<td>Ctrl+Shift+M</td>
<td>See a list of suggested images, multimedia files and documents to embed in your page. More...</td>
</tr>
<tr>
<td>Add a macro on your page</td>
<td>{</td>
<td>None</td>
<td>See a list of suggestions as you begin typing a macro name. More...</td>
</tr>
<tr>
<td>Notify another user by email that you have mentioned them on your page</td>
<td>@</td>
<td>None</td>
<td>See a list of suggested users to mention. More...</td>
</tr>
</tbody>
</table>

**Using Autocomplete for Links**

Type '[', or press Ctrl+Shift+K, to see a list of suggested pages or other locations to link to from your page. You can link to pages, user profiles, images, documents and other file attachments.
To autocomplete a link:

1. Edit the page.
2. Click where you want to insert a link and do one of the following:
   - Type '[' and then the first few characters of the page title, user's name, image name or file name.
   - Type the first few characters of the page title, user's name, image name or file name (or select relevant text) and then press Ctrl+Shift+K.
3. Click the relevant link from the list of suggestions.

If the item you need is not in the list, either:

   - Choose Search for 'xxx' to continue looking for the page within Confluence, or
   - Choose Insert Web Link to insert a link to an external web page using the Link Browser.

Screenshot: Autocomplete for a Link

Using Autocomplete for Images, Videos, Audio Files and Documents

You can use the autocomplete as a fast way of embedding images, videos, audio files and documents into your page. Type an exclamation mark or press Ctrl+Shift+M to see a list of suggested images, multimedia files and documents to display on your page. You can use autocomplete to embed the following file types:

- Images – any format that Confluence supports. See Image File Formats.
- Videos, audio files and all multimedia formats that Confluence supports. See Embedding Multimedia Content.
- Office documents supported by the Confluence Office Connector: Word, Excel and PowerPoint.
- PDF files.

Autocomplete works most efficiently for files that are already attached to the Confluence page. See Attaching Files to a Page.

To embed an image, video, audio file or document:

1. Edit the page.
2. Click where you want to insert the image, video, audio file or document and do one of the following:
   - Type '!' and then the first few characters of the image, file or document name.
   - Type the first few characters of the name of the image, file or document (or select relevant text) and then press Ctrl+Shift+M.
3. Choose the relevant file from the list of suggestions.

If the item you need is not in the list, either:

   - Choose Open Image Browser to find images and documents using the Image Browser, or
   - Choose Insert Other Media to embed videos, audio and other multimedia files using the Macro Browser. Insert the 'Multimedia' macro to display your multimedia file.

Screenshot: Autocomplete for an Image or Document
Using Autocomplete for Macros

Type '{' to see a list of suggested macros to add to your page.

Autocomplete provides access to all available macros in your Confluence site, including any user macros that your administrator has added and made visible to all.

⚠️ You need to know the name of macro. Autocomplete for macros will only match the name of the macro, not the description.

To autocomplete a macro using '{':

1. Edit the page.
2. Click where you want to insert the macro.
3. Type '{' and then the first few characters of the macro name.
4. Choose the relevant macro from the list of suggestions.
5. Configure the macro as described in Working with the Macro Browser.

If the macro you need is not in the list, select Open Macro Browser in the list of suggestions to continue looking for the macro in the Macro Browser.

Screenshot: Autocomplete for a Macro

Using Autocomplete for Mentions
You can use autocomplete to automatically notify another Confluence user that you have mentioned them in a page, blog post, comment or status update.

Type @ to see a list of suggested users to mention. When you save the page, an email is automatically sent to the user to notify them that they have been mentioned on that page (if they have permission to view the page or blog post). This works for new and updated pages, blog posts, comment and status updates.

You need to know the user's real name – autocomplete for mentions suggests users' full names only, not their usernames.

To autocomplete a mention using '@':

1. Edit the page.
2. Click where you want to insert a mention and type '@' and then the first few characters of the user's real name.
3. Choose the user's name from the list of suggestions.

Screenshot: Autocomplete for mentions

Cancelling Autocomplete

The autocomplete starts automatically when you press the trigger characters. You may want to close the autocomplete menu or escape from autocomplete once it has started.

There are a few different ways to stop the autocomplete once it has started:

- Press the escape key, ‘Esc’, on your keyboard.
- Click somewhere else in the editor panel.
- Press an arrow key to move out of the autocomplete area.
- For the link autocomplete only: enter a right-hand square bracket, like this: ]

Enabling and Disabling Autocomplete

You can turn off the triggering of autocomplete by the '[' and ']' characters. This will prevent the autocomplete from starting automatically when you press one of the trigger characters. You can also turn it back on again.

Notes:

- This setting does not affect the keyboard shortcuts for autocomplete (Ctrl+Shift+K and Ctrl+Shift+M). Even if the trigger characters are disabled, you can still use the keyboard shortcuts for autocomplete.
- This setting affects only you. Other people using Confluence can enable or disable the setting on their user profiles independently.
- Note that autocomplete is enabled by default.

To enable or disable the autocomplete trigger characters:

1. Go to your name (the 'User' menu) at the top of the page and choose Settings.
2. Choose Editor under 'Your Settings' in the left-hand panel.
3. Click Edit.
4. Either:
   - Disable autocompletion by selecting Disable Autocomplete.
   - Enable autocompletion by clearing Disable Autocomplete.
5. Click Submit.

Screenshot: User Settings for the Editor
Using Special Characters

There are different kinds of special characters that you can add to Confluence content (pages, blog posts, comments):

**Symbols**

Symbols are special characters such as © and ™.

To insert a symbol, choose Insert > Symbol, and click on the required symbol.

**Emoticons and Icons**

Emoticons and icons are special characters such as 😃 and 😊.

To insert an emoticon or icon, simply type the character combination for it.

**Related Topics**

How to Disable Emoticons

Take me back to Confluence User’s Guide

Inserting Emoticons and Icons

**Adding Emoticons**

There are two ways to add an emoticon, or smiley, to your Confluence page.

**By choosing an emoticon from those available:**

1. Choose Insert > Emoticon when editing, to display the available emoticons.
2. Click on an emoticon to insert it.

**By typing a character combination:**

You can insert emoticons by typing commonly-used character combinations. For example, the following code appears as an emoticon when the page is rendered.

```
;) 
```

This example creates this emoticon: 😃.

The emoticons (and other icons) available in Confluence, and the character combinations that create them, are shown in this table:
### Preventing Emoticons from Appearing

To prevent Confluence from turning parts of text into emoticons, 'escape' the character sequence by inserting a `\` character.

For example, this character sequence contains an emoticon:

```
(-example_here;)
```

This example appears as: (-example_here😊).

To 'escape' the emoticon sequence, insert a slash as in the following example:

```
(-example_here\;)
```

The characters will then appear exactly as typed.

### Related Topics

- Displaying Images
- How to Disable Emoticons

Take me back to Confluence User's Guide

### Inserting Symbols

There are various symbols, or special characters, that you can add to your Confluence page.

**To insert a symbol:**

1. Choose Insert > Symbol. This will display the 'Insert Custom Character' window.
2. Click on the required symbol to insert it.

**Screenshot : Custom Characters**

1. Related Topics
Working with the Macro Browser

The Macro Browser allows you to browse through Confluence's extensive range of macros and to preview them before adding them to your page.

The Macro Browser provides access to all available macros in your Confluence site, including any user macros and plugins that your administrator has added and made visible to all.

Accessing the Macro Browser

You can access the Macro Browser whenever you edit a page, blog post or comment.

To access the Macro Browser:

1. Log in to Confluence, if you have not already done so.
2. Edit a page or blog post.
3. Click where you want to insert the macro.
4. Either choose Insert > Other Macros, or type '{' and choose Open Macro Browser.

Each macro is represented in the Macro Browser by its icon, its name and a brief description of its function.

Finding a Macro

The Macro Browser provides two methods for finding a macro:

- Browsing by category
• Searching

You can also simply type ‘{’ to see a list of suggested macros. For more details, see Using Autocomplete.

Browsing by Category

Each macro is assigned to one or more categories. Click a category name to see the macros in that category.

Screenshot: Macro Browser List Restricted by Category

Searching

Enter a word or words into the search field at the top of the Macro Browser. As you start typing, the macro list is filtered to show only those macros whose name or description matches the characters you have entered.

Screenshot: Macro Browser List Restricted by Word Search

Adding a Macro to a Page or Blog Post

When you choose a macro and add it to a page or blog post, you may need to configure the macro’s parameters.

To choose and configure a macro:

1. Access the Macro Browser and browse to the required macro as described above, if you have not already done so.
2. Click the required macro to choose it. The Macro Browser window changes to the 'Edit Macro' mode with a preview pane on the left and parameter pane on the right.
3. If necessary, modify the macro’s parameters in the parameter pane. Some parameters allow auto-completion.
4. Click Refresh to preview the effect of your changes to the macro’s parameters.
5. Any parameters marked by an asterisk (*) are mandatory and must be set before you can preview or insert the macro.
6. Click Insert to add the macro to the page or blog post.
Not all macros can be previewed in the Macro Browser. This is often the case with macros that require the page to be saved first to render correctly, such as the Table of Contents Macro, or macros that do not generate output, such as the Anchor Macro. Nevertheless, you can still use the Macro Browser to browse for these macros and set their specific parameters before inserting them into your page.

### Editing a Macro

You can edit a macro that has already been added to a page or blog post, modifying the parameter data and previewing the changes.

#### To edit a macro:

1. Edit the page or blog post containing the macro you wish to edit.
2. Click on the macro placeholder and choose **Edit**.
3. Modify the macro's parameters in the parameter pane. Some parameters allow auto-completion.
4. Click **Refresh** to preview the effect of your changes to the macro's parameters.
   - Any parameters marked by an asterisk (*) are mandatory and must be set before you can preview or insert the macro.
5. Click **Save** in the Macro Browser to save your changes.

   > To leave the Macro Browser at any time, click its **Cancel** button or simply press the 'ESC' key.

#### Macro Browser Smart Fields

If a macro's parameter requires the entry of a single username, space key or page title, the macro browser provides an 'auto-complete' feature to help you enter the correct value. Use the up- and down-arrows on your keyboard to move up and down the dropdown list of matching items and select the appropriate item. This feature functions similarly to the Quick Navigation Aid when searching Confluence pages.

[Screenshot: Macro Browser Smart Fields]
Macro Placeholders
Macro placeholders are displayed in the editor where you have added a macro to the page.

When editing a page, you can:

- Double-click a macro placeholder to open the Macro Browser (or click on the placeholder and choose Edit), where you can edit the macro's parameters.
- Select a macro placeholder to cut, copy and paste the macro.

Related Topics
Working with Macros
Take me back to the Confluence User's Guide.

Inserting JIRA Issues
If your Confluence site is connected to a JIRA site using an application link, you can easily insert individual issues from this JIRA site directly into text on your Confluence page using the 'Insert JIRA Issue' dialog. Each issue inserted onto the page is linked to the issue in JIRA itself.

Using the 'Insert JIRA Issue' dialog, you can also:

- Create a new issue on the JIRA site and insert the issue onto your page.
- Insert a table of JIRA issues onto your page based on the results of a search (using JIRA Query Language (JQL) syntax).

If your Confluence site is not connected to any JIRA site via an application link, this feature will not be available. However, you can still list JIRA issues on a page or blog post using the JIRA issues macro.

On this page:
- Inserting a JIRA Issue from a List of Recently Viewed Issues
- Creating a New JIRA Issue and Inserting it
- Searching for JIRA Issues and Inserting them
- Notes
- Related Topics

Quick guide to inserting JIRA issues
- Choose Insert > JIRA Issue from the editor toolbar.
  - To insert a single issue, use either:
    - Recently Viewed — Insert an issue onto your page from a list of issues you have recently viewed on the JIRA server.
    - Create New Issue — Create a new issue on the JIRA server and insert it into your page.
    - Search — Use JQL syntax to narrow down a list of issues, from which you can select one to insert onto a page.
  - To insert a table of issues:
    - Click Search on the 'Insert JIRA Issues' dialog, use JQL syntax to narrow down a list of issues and choose to insert the list onto a page.

If Confluence is connected to more than one JIRA server, ensure that you choose the appropriate JIRA server before using this dialog to select, create or search for issues.
**Inserting a JIRA Issue from a List of Recently Viewed Issues**

To insert a JIRA issue onto a page from a list of recently viewed issues on a JIRA site:

1. Choose Insert > JIRA Issue from the editor toolbar.
2. Go to the Recently Viewed tab of the ‘Insert JIRA Issue’ dialog.
3. If necessary, select a JIRA server from the Server list. See the notes below regarding OAuth outgoing authentication.
4. Select an issue from your list of recently viewed JIRA issues on the JIRA site. The number of items in the list is defined in JIRA.

**Creating a New JIRA Issue and Inserting it**

This feature works best with JIRA issue types whose mandatory field requirements have not been altered. With the exception of a JIRA issue’s ‘Component/s’ or ‘Fix Version/s’ fields, you cannot use this dialog to add an issue whose issue type has customised mandatory field requirements upon issue creation.

To create a new JIRA issue on a JIRA site and insert this issue onto a page:

2. Complete the dialog:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server</td>
<td>The available JIRA servers. See the notes below regarding OAuth outgoing authentication.</td>
</tr>
<tr>
<td>Project</td>
<td>The project on the selected JIRA server to which the new issue will be added.</td>
</tr>
<tr>
<td>Issue Type</td>
<td>The type of issue to log in this project.</td>
</tr>
<tr>
<td>Summary</td>
<td>A one-line summary for the issue.</td>
</tr>
<tr>
<td>Component/s</td>
<td>Choose one or more components which apply to this issue.</td>
</tr>
<tr>
<td>Version/s</td>
<td>Choose one or more versions in which the issue will be addressed.</td>
</tr>
<tr>
<td>Description</td>
<td>A more detailed description about the issue.</td>
</tr>
</tbody>
</table>

3. Click Insert to create the JIRA issue and insert it onto the page.

**Searching for JIRA Issues and Inserting them**

To search a JIRA site for a subset of issues matching a JQL query and insert one or more of these issues:

1. Choose Insert > JIRA Issue from the editor toolbar.
3. Enter a JQL query.
4. If necessary, select the JIRA server whose issues you want to insert.
5. Click Search to find the issues on the JIRA server which match your JQL query. The first 20 issues retrieved by your JQL query are displayed.
   - To insert a single issue, select the issue from your list and click Insert.
   - To insert the full list of issues, select the Insert all query results as a table check box before clicking Insert.

**Notes**

The issues from a JIRA site which you can access in the ‘Insert JIRA Issues’ dialog depends on the application link’s outgoing authentication used by Confluence to communicate with that JIRA site. While you can always access publicly visible issues:

- If ‘Trusted Applications’ outgoing authentication is used — you can also view issues restricted to an account on JIRA whose user name matches your user name in Confluence.
- If ‘OAuth’ outgoing authentication is used, you may need to click Login & Approve at this point to gain access to the JIRA server and restricted issues. You can also view issues restricted to the user account that you ‘Login & Approve’ (to the JIRA site) on the ‘Insert JIRA Issues’ dialog.
- If ‘Basic Access’ outgoing authentication is used — you can also view issues restricted to the user account configured for the JIRA site’s ‘outgoing authentication’.

**Related Topics**
JIRA Issues Macro

Working with Drafts

A draft is a ‘snapshot’ of unsaved page content, which Confluence creates automatically at regular intervals while you are editing a page or blog post. This can minimise the loss of work if your Confluence site experiences a problem, since you can retrieve the page content from your last saved draft.

On this page:
  • How are drafts implemented in Confluence?
  • Viewing Unsaved Changes
  • Viewing Drafts
  • Related Topics

How are drafts implemented in Confluence?

At regular intervals, Confluence automatically saves a draft of the page you are editing. If a network failure or system error prevents you from saving your page, you can retrieve its last saved draft and continue working on the page from (or almost from) where you left off.

- Drafts are created while you are adding and editing a page or blog post. Each new draft replaces the previously saved draft.
- Each time Confluence saves a draft, it displays a message and the time of the last save near the Save button on the edit screen.

Screenshot: Message displaying the time when the draft was last saved

Draft saved at 11:14 AM (view change) Save Cancel

Whenever you edit a page and click one of the other page tabs, Confluence will automatically save a draft. When you click on the 'Edit' tab again, Confluence will let you know that a version of the page you are editing was not saved and will give you the option to resume editing it.

- By default, Confluence saves a draft of your page once every thirty seconds. However, a Confluence administrator can configure how often drafts are saved.

Drafts Possess the Following Characteristics

- A user only has access to the drafts of pages they have been working on and whose content has not yet been saved.
- A user cannot create a draft explicitly.
- A user’s drafts are listed in the ‘Drafts’ tab of their profile.
- Once a user has resumed editing a draft, or chosen to discard it, it is removed from their drafts tab.

Viewing Unsaved Changes

While editing a page or blog post, you can view any ‘unsaved’ changes you have made since the last automatically saved draft, by clicking view change (near the Save button).

Screenshot: Segment of the Unpublished Changes Window

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This line was removed</td>
<td>This word was added.</td>
</tr>
<tr>
<td>This word was added</td>
<td></td>
</tr>
</tbody>
</table>

A draft is a snapshot version of a page which Confluence saves automatically at regular intervals while you are editing the page. Confluence saves these interim versions even if you do not save the page yourself. This is a useful feature that minimises loss of work if your Confluence site experiences a problem.

A draft is created while you are adding and editing a page or blog post.
Viewing Drafts

Your drafts are listed on the Drafts tab of your user profile.

To see your drafts:

Go to your name (the 'User' menu) at the top of the page and choose Drafts.

Related Topics

Resuming the Editing of a Draft
Configuring the Time Interval at which Drafts are Saved
Concurrent Editing and Merging Changes

Configuring the Time Interval at which Drafts are Saved

By default, Confluence saves a draft of your page once every thirty seconds. However, as described below, a Confluence administrator can configure how often drafts are saved.

As a Confluence administrator, you can set the time interval at which drafts are saved as follows:

1. Go to the Confluence 'Administration Console':
   - Choose Browse > Confluence Admin. The 'Administrator Access' login screen will be displayed.
   - Enter your password and click Confirm. You will be temporarily logged into a secure session to access the 'Administration Console'.
2. Click General Configuration in the left-hand panel.
3. Edit the setting for Draft Save Interval.

Concurrent Editing and Merging Changes

Sometimes, two or more people may edit a page at the same time. When this happens, Confluence will do its best to ensure that nobody's changes are lost.

How will I know if someone else is editing the same page as I am?

If another user is editing the same page as you, Confluence will display a message above your edit screen letting you know who the other user is and when the last edit was made.

What happens if two of us are editing the same page and the other user saves before I do?

If someone else has saved the page before you, when you click 'Save', Confluence will check if there are any conflicts between your changes and theirs. If there are no conflicting changes, Confluence will merge both the edits successfully. If there are any conflicts, Confluence will display them for you and give you the option to either 'Overwrite' the other user's changes, 'Merge your changes' manually, or 'Discard' them.

Example Scenario

For example, Alice and Bob both edit the same page at the same time.

If Alice clicks save before Bob, Bob is now effectively editing an out-of-date version of the page. When Bob clicks save, Confluence will examine his changes to see if any overlap with Alice's. If the changes do not overlap (i.e. Alice and Bob edited different parts of the page), Bob's changes will be merged with Alice's automatically.

If Bob's changes overlap with Alice's, Confluence will display an error message to Bob showing where Alice has changed the page, and giving Bob the options to overwrite Alice's changes with his own, to re-edit the document to incorporate Alice's work, or to cancel his own
changes entirely.

Related Topics

Page History and Page Comparison Views
Viewing Page Information
Working with Drafts

Take me back to Confluence User’s Guide.

Resuming the Editing of a Draft

If you have typed some content into a Confluence page or blog post, Confluence will save a draft of it, even if you were not able to successfully save the page or blog post, or add a title to it.

There are two ways to resume editing an unsaved page or blog post:

A. Using your drafts view. To resume editing a draft from this view:

1. Go to your name (the ‘User’ menu) at the top of the page and choose Drafts.

2. Click Resume Editing next to the appropriate draft to resume editing that draft.

   If you had not yet entered a page title, the draft will be listed with the title ‘Untitled’.

B. If you had created a new page or blog post but did not save it, then when you next add a page or blog post in that space, Confluence will ask you if you want to resume editing the page that was not saved. If you click resume editing, the draft and its unsaved content will be restored, allowing you to continue editing it.

Screenshot: Resume Editing

What happens if I am editing the draft of a page that has since been updated?

When this happens, Confluence will display a message informing you that you are editing an outdated page. If there are no conflicts between the two versions, Confluence will give you the option to Merge and Resume editing.

If there are any conflicts, Confluence will give you the option to View the Conflict or to Discard your changes.

Screenshot: Editing Conflict in Draft

Related Topics

Working with Drafts

Recording Change Comments

A ‘change comment’ is a short description that summarises the changes made to a page during an editing session. Change comments are a useful way of keeping track of the history of a page.

A change comment is not the same as a comment added to a page. Refer to Working with Comments for information about that type of comment.

Note that once a change comment has been added and the page has been saved, it is not possible to update or remove the change comment.

On this page:

- Entering a Change Comment
- Viewing a Change Comment
- Viewing a History of Change Comments
- Related Topics

Entering a Change Comment

You can enter change comments in the field located below the edit screen:

Screenshot: Entering change comments
**Viewing a Change Comment**

Once a comment has been added, it becomes visible in the view mode of the page, so that users are aware of the most recent changes made to a page. If a comment has been recorded, you will see a show comment link below the page title. Click the link to view the comment.

**Screenshot: The 'show comment' link**

The hide comment link allows you to hide the comment again, so that it does not distract you from the content of the page.

**Screenshot: The 'hide comment' link**

**Viewing a History of Change Comments**

The change comments for a page are recorded under the 'Recent Changes' section of the page's 'Info' view and in the page's 'History' view.

**Screenshot: History of change comments on Info view**

<table>
<thead>
<tr>
<th>Time</th>
<th>Editor</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mar 02, 2011 17:15</td>
<td>Administrator</td>
<td>Added the cheese macro.</td>
</tr>
<tr>
<td>Mar 02, 2011 17:15</td>
<td>Administrator</td>
<td>Added the cheese macro.</td>
</tr>
<tr>
<td>Mar 02, 2011 17:04</td>
<td>Administrator</td>
<td>Added the cheese macro.</td>
</tr>
<tr>
<td>Mar 02, 2011 17:04</td>
<td>Administrator</td>
<td>Added the cheese macro.</td>
</tr>
</tbody>
</table>

**Screenshot: History of change comments on History view**

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Changed By</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>CURRENT (v. 12)</td>
<td>Mar 02, 2011 17:15</td>
<td>Administrator: Added the cheese macro.</td>
<td></td>
</tr>
<tr>
<td>v. 11</td>
<td>Mar 02, 2011 17:15</td>
<td>Administrator</td>
<td>Restore this version</td>
</tr>
<tr>
<td>v. 10</td>
<td>Mar 02, 2011 17:04</td>
<td>Administrator</td>
<td>Restore this version</td>
</tr>
</tbody>
</table>

**Related Topics**

- Viewing Page Information
- Page History and Page Comparison Views

Take me back to Confluence User's Guide
Creating a Page

The usual ways to create a page are described below.

Once you create a page, you can:

- add content to it using the editor
- set the page's location in the Confluence site, before you save the page.

You can always move the page to a different location in the page tree, or to a different space, after you have saved the page.

You may like to read about writing blog posts.

Permissions

To create a page, you need the ‘Create Pages’ permission for that space, which is assigned by a space administrator from the Space Administration screens. See space permissions or contact a space administrator for more information.

On this page:

- Add a page from the dashboard
- Add a page from any page in a space
- Add a page using an undefined link
- Notes about Page names
- Setting Page Location
- Importing an Office Document into One or More Confluence Pages
- Related Topics

Add a page from the dashboard

You can quickly add a page from the dashboard without having to browse to a specific space. Confluence adds the new page at the root of the space.

To add a new page from the dashboard:

1. Click Add Page at the top right of the dashboard.
2. Select the space where you want to add the page and choose a template on which to base the page content. For more details about using a template, see Creating a Page using a Template.
3. Click Next. Confluence opens the page in ‘Edit’ mode.

Add a page from any page in a space

By default, Confluence adds the new page as a child page of the current page.

To add a new page:

1. Go to any page in the space.
2. Choose Add > Page.
Note that you will only see the Add Page link if you have permission to create pages for the space. You can also create a page using a template.

**Pages with large amounts of text content**

One user reported having problems saving a page that contained approximately 700 kilobytes (700,000 characters) or more of text content. Refer to CONF-16467 for more information. Some browsers appear to be more susceptible to this issue than others. While it is highly unlikely that your page content will ever reach this size, if you work with large pages, structuring your content into separate pages will help to avoid this issue.

### Add a page using an undefined link

You may want to insert a link pointing to a Confluence page that does not yet exist, but which you intend to create later. This type of link is called an undefined link.

**To add an undefined link for later creation of a page:**

1. Edit the page in which the link should appear.
2. Type `T` to trigger autocomplete, and type the name of the undefined page.
3. Choose Insert Link to Create Page.

When you save the page, Confluence colours the undefined link red. When someone clicks on the link, the new page is opened in 'Edit' mode. You can then enter the page name, add content and save the page, as usual.

### Notes about Page names

- Confluence does not accept the following characters in the title of a page:

  ```
  :, @, /, \, ^, #, ;, [ , ] , { , }, < , >
  ```

- A page must not start with the following characters:

  ```
  $, .., ~
  ```

- Page names must be unique within a space. We are aware that this is a limitation, and there's a feature request at CONF-5926. If you like, you can vote for this feature and add yourself as a watcher for future updates. You can also vote for the improvement request CONF-9458 to remove the restrictions on characters.

### Setting Page Location

While you are editing a new page you can set the page's location to any space of your Confluence site.

**To set the location for a new page:**

1. While editing the page, click Location.
2. Use the tabs on the left of the 'Set Page Location' dialog to help you find the new space and parent page for your page, that is, the location where you want to move your page. The 'Current location' and 'New location' breadcrumb trails at the bottom of the dialog indicate the current parent page and new parent page.
3. If you want to move a page to a different position amongst the child pages, select Reorder to see a list of sibling pages when you click Move.
4. Click Move.
5. If you are reordering the child pages, click in the list to set the new position for the page and click Reorder.

See also Moving a Page.

**Screenshot: Setting page location for a new page**
Importing an Office Document into One or More Confluence Pages

The Office Connector allows you to import a Word document into Confluence, optionally creating one or more new pages. See Importing an Office Document into Confluence.

Related Topics

Creating a Page using a Template
Working with Drafts
Linking Pages
Page Restrictions
Working with the Office Connector
Moving a Page

Adding Blog Posts

To add a blog post for a space, you require 'Create Blog' permission which is assigned by a space administrator. See Space permissions or contact a space administrator for more information.

On this page:
- From the Dashboard
- From Any Page
- Notes
- Related Topics

From the Dashboard

You can add a blog post to any space from the Dashboard, without having to browse to that space.

To add a blog post from the Dashboard:

1. Click Add Blog Post at the top right of the Dashboard.
2. Select the space where you want to add the blog post.
3. Click Next. Confluence will open the Add Blog Post screen in edit mode.
4. Type your content as you would for any other page in Confluence.
5. Preview and click **Save** when you are finished.

**From Any Page**

You can add a blog post from any page (other than the Dashboard) in the space.

**To add a blog post from any page:**

1. Click **Add** near the top right of the page and choose **Blog Post**. Confluence will open the **Add Blog Post** screen in edit mode.
2. Type your content as you would for any other page in Confluence.
3. Preview and click **Save** when you are finished.

**Notes**

- Add **labels** if you want to categorise information this way.
- If you want to backdate your blog post, edit the date in **Posting Date**. You cannot set a date after today's. Also, you can only set the date when creating the blog post, not when editing it.
- You can view the blog for the current space by opening the **Browse** menu and selecting **Blog**. Your blog post should be listed.

**Related Topics**

- Creating a Page
- Working with Blog Posts
- Editing Blog Posts
- Linking to Blog Posts
- Deleting Blog Posts

**Working with Templates**

When you add a new page, you do not have to write the content from scratch. Instead, you can base your new page on a template. A template is a Confluence page with predefined content.

Some examples of where templates are useful:

- A software development project may have a template for use cases.
- A systems administration space may have a template for defining what information is kept about each server.

**Global Templates and Space Templates**

In Confluence, there are two places to store your templates:

- **Global templates**: These are defined by site administrators through the Administration Console and are available in every space.
- **Space templates**: These are defined by space administrators on the space administration screens, and are only available in the space in which they are defined.

Site administrators can also **import predefined templates**.

**Creating a Template**

You need to be a **space administrator** to create a space template.

You can write your template using Confluence **wiki markup**. You can also use **special form markup** if you wish to define form fields that the author will complete when adding the page.

See **Adding a Template** for further information about creating a space template.
See **Global Templates** for information about creating a global template.

*Screenshot: Template variables available when adding a template*
**Using a Template**

Templates are only used when adding a page. Once a page has been created, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide expanded functionality.

See Creating a Page using a Template for further information about using a space template.

**Useful Plugins**

Before installing a plugin into your Confluence site, please check the plugin’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

Two popular plugins provide extended template functionality:

- Zones plugin.
- Scaffolding plugin.

Below is a comparison:

<table>
<thead>
<tr>
<th>Field</th>
<th>Default</th>
<th>Zones Plugin</th>
<th>Scaffolding Plugin</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Basic</td>
<td>Flexible</td>
<td>Powerful</td>
</tr>
<tr>
<td>Saves page version history</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Allows return to form version</td>
<td>✗</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Suitable for dynamic data</td>
<td>✗</td>
<td>✗</td>
<td>✓</td>
</tr>
<tr>
<td>Has a library of examples</td>
<td>✗</td>
<td>✗</td>
<td>✓</td>
</tr>
</tbody>
</table>

**Related Topics**

- Adding a Template
- Form Field Markup for Templates
- Global Templates
- Importing Templates
- Creating a Page using a Template

**Adding a Template**

You need to be a space administrator to create a space template.

To add a template for a space:

1. From any page in the space, choose **Browse > Advanced**.
2. Click **Templates** in the left-hand panel.
3. Click **Add New Space Template**.
4. The ‘Create Template’ screen will appear. Enter a name for your template in the **Name** text field and an optional description in the **Description** text field.
5. Using regular Confluence wiki markup and form field markup (if you are using forms), enter content in the text-entry box as you
would in any other Confluence page. See the screenshot below.

4. Click Edit next to 'Labels' if you want to use labels to categorise information. Add your labels. These labels will be included in all pages created using this template.

5. Preview and click Save. Your template will be added to the list of space templates.

To view the space templates, choose Browse > Advanced > Templates.

Screenshot: creating a Confluence page template

---

**Related Topics**

Creating a Page using a Template
Working with Templates
Editing a template
Removing a Template
Browsing a space
Working with Pages

Working with Labels

Take me back to Confluence User's Guide

**Creating a Page using a Template**

Confluence allows you to create a page based on a global template (available to all spaces) or a space template (available only to that space). This page is intended for users who have already created a template.

![Labels are copied from the template](image)

If the template contains labels, the template labels will automatically be included in the new page created from that template.

To create a page using an existing template:

1. Do either of the following:
   - At the top of the Dashboard, click Add Page. Choose the space that contains the template you want to use.
   - At the top of any other page, choose Add > Page from template. This link is only displayed if there are templates already defined. If you do not see this link, then an administrator will have to create a template before you can use it.

2. Choose a template from the list and click Next. This will display one of the following:
   - A new page based on the template, if the template does not contain a form.
   - The Template Variables page, if the template contains a form. Type values into the form fields and click Insert Variables. This will display a new page based on the template, with the variable values you entered.

3. Type a name for the page where you see 'New Page'.
4. Add more content or make further changes as required.
5. Click **Save**.

**Screenshot: creating a page from a template**

![Add Page - Template Variables](image)

**Step 2: Fill in template variables**

Choose values for the variables in this template. These values will be automatically inserted into the template for you in the correct locations.

<table>
<thead>
<tr>
<th>Product</th>
<th>Quantity</th>
<th>Price</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unobtainium</td>
<td>1</td>
<td>$5,999.95</td>
<td>$5,999.95</td>
</tr>
</tbody>
</table>

[<< Back] [Insert Variables]

**Screenshot: previewing your page**

![New Page](image)

**Customer Order Form**

<table>
<thead>
<tr>
<th>Product</th>
<th>Quantity</th>
<th>Price</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unobtainium</td>
<td>1</td>
<td>$5,999.95</td>
<td>$5,999.95</td>
</tr>
</tbody>
</table>

**Related Topics**

- Adding a Template
- Editing a template
- Removing a Template
- Form Field Markup for Templates
- Browsing a space
- Working with Templates

Take me back to Confluence User’s Guide

**Editing a template**

You need to be a **space administrator** to modify a space template.

**To edit a template:**

1. Choose **Browse** > **Advanced** > **Templates**. A list of templates for the space is displayed.
2. Click the **Edit** link for the template to be modified.
3. Make changes, or add new content, as you would when creating a template, using **form field markup**, if required.
4. Click **Update** to save your changes.

**Related Topics**

- Adding a Template
- Creating a Page using a Template
- Working with Templates
- Working with Pages
Removing a Template

You need to be a space administrator to remove a space template.

**Warning**
Deleted templates cannot be restored.

To remove a space template:

1. Choose Browse > Advanced and click Templates in the left-hand panel. A list of templates for the space is displayed.
2. Click Remove beside the template you wish to delete.
3. Click OK to confirm the deletion.

Related Topics
Editing a template
Adding a Template
Creating a Page using a Template
Working with Templates
Working with Pages

Confluence Wiki Markup

This page describes the wiki markup used for page templates and in some administration screens in Confluence.

You can use wiki markup to write content for a page template. This content will appear in every page that uses the template. You can also use special form markup if you wish to define form fields that the page author will complete when adding the page.

Markup is also used in the following places:

- When creating links using the Advanced tab of the Links Browser.
- When using the Wiki Markup dialog in the Confluence editor (choose Insert > Wiki Markup).
- When working with some administration screens, such as the Theme Configuration screen.

On this page:
- Headings
- Lists
- Tables
- Text Effects
- Text Breaks
- Links
- Images
- Related Topics

Headings

You can use wiki markup to create headings in a page template.

Creating a header is easy. Simply place "hn." at the start of your line (where n can be a number from 1-6).

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>h1. Biggest heading</td>
<td>Biggest heading</td>
</tr>
<tr>
<td>h3. Big heading</td>
<td>Big heading</td>
</tr>
<tr>
<td>h5. Small heading</td>
<td>Small heading</td>
</tr>
</tbody>
</table>
Note that Confluence treats all headings as anchors.

Lists

Wiki markup allows you to create bulleted or numbered lists, and is flexible enough to allow a combination of the two list types.

ℹ️ If you need to separate the text within lists using line breaks, make sure you do so using a double slash (//). Empty lines may disrupt the list.

Simple lists

Use the hyphen (-) to create simple lists.
Make sure there is a space between the hyphen and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| - some
- bullet
- points | • some
• bullet
• points |

Bulleted lists

Use the asterisk (*) to create bullets. For each subsequent level, add an extra asterisk.
Make sure there is a space between the asterisk and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| * some
* bullet
** indented
** bullets
* points | • some
• bullet
• indented
• bullets
• points |

Numbered lists

Use the hash (#) to create numbered lists.
Make sure there is a space between the hash and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| # a
# numbered
# list | 1. a
2. numbered
3. list |

A second level of hashes will produce a sub-list, such as the alphabetical sub-list shown below.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| # Here’s a sentence.
# This is a sub-list point.
# And a second sub-list point.
# Here’s another sentence. | 1. Here’s a sentence.
a. This is a sub-list point.
b. And a second sub-list point.
2. Here’s another sentence. |
Try a third level of hashes to produce a sub-sub-list.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td># Here's a sentence.</td>
<td>1. Here's a sentence.</td>
</tr>
<tr>
<td>## This is a sub-list point.</td>
<td></td>
</tr>
<tr>
<td>### Third list level.</td>
<td></td>
</tr>
<tr>
<td>### Another point at the third level.</td>
<td></td>
</tr>
<tr>
<td># And a second sub-list point.</td>
<td></td>
</tr>
<tr>
<td># Here's another sentence.</td>
<td></td>
</tr>
</tbody>
</table>

In numbered lists as described above, the format of the 'number' displayed at each list level may be different, depending upon your browser and the style sheets installed on your Confluence instance. So in some cases, you may see letters (A, B, C, etc; or a, b, c, etc) or Roman numerals (i, ii, iii, etc) at different list levels.

Mixed lists

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td># Here</td>
<td>1. Here</td>
</tr>
<tr>
<td>* is</td>
<td>* is</td>
</tr>
<tr>
<td>* an</td>
<td>* an</td>
</tr>
<tr>
<td># example</td>
<td># example</td>
</tr>
<tr>
<td>* of</td>
<td>* of</td>
</tr>
<tr>
<td># a</td>
<td>* a</td>
</tr>
<tr>
<td># mixed</td>
<td>3. mixed</td>
</tr>
<tr>
<td># list</td>
<td>4. list</td>
</tr>
</tbody>
</table>

Tables

You can use wiki markup to create tables in a page template.

Confluence allows you to create two types of tables.

Table Type 1

Allows you to create a simple table with an optional header row. You cannot set the width of the columns in this table. Use double bars for a table heading row.

What you need to type:

| ||heading 1||heading 2||heading 3|| |
|---|---|---|---|---|
|cell A1|cell A2|cell A3| |
|cell B1|cell B2|cell B3|

What you will get:

<table>
<thead>
<tr>
<th>heading 1</th>
<th>heading 2</th>
<th>heading 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>cell A1</td>
<td>cell A2</td>
<td>cell A3</td>
</tr>
<tr>
<td>cell B1</td>
<td>cell B2</td>
<td>cell B3</td>
</tr>
</tbody>
</table>

You can also use a vertical header.

What you need to type:
Table Type 2

This method allows you to specify the width of the columns in the table.

**What you need to type**

```
{section:border=true}
{column:width=30%}
Text for this column goes here. This is the smaller column with a width of only 30%.
{column}
{column:width=70%}
Text for this column goes here. This is the larger column with a width of 70%.
{section}
```

**What you will get**

Text for this column goes here. This is the smaller column with a width of only 30%.

Text for this column goes here. This is the larger column with a width of 70%.

*For more details please see the [Column Macro](#) and the [Section Macro](#)*.

**Advanced Formatting**

**Colour and Other Formatting**

To add colour and other formatting to your tables, you can use the [Panel Macro](#) within columns.

More table-formatting options may be available if your Confluence administrator has installed additional [macros](#).

**Lists**

Here's an example of how to embed lists in a table:

**What you need to type**

```
||Heading 1||Heading 2||
* Item 1
* Item 2
* Item 3
# Item 1
# Item 2
# Item 3
```

**What you will get**

<table>
<thead>
<tr>
<th>Heading 1</th>
<th>Heading 2</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Text Effects

Use the markup shown in the examples below to format the text in your page templates.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>strong</em></td>
<td>strong</td>
</tr>
<tr>
<td><em>bold text</em></td>
<td>bold text</td>
</tr>
<tr>
<td><em>emphasis</em></td>
<td>emphasis</td>
</tr>
<tr>
<td><em>italics</em></td>
<td><em>italics</em></td>
</tr>
<tr>
<td></td>
<td>Hint: To italicise parts of a word, add braces (curly brackets) around the underscore. For example, Thing{<em>}x</em>; gives you this: Thingx</td>
</tr>
<tr>
<td>citation</td>
<td>citation</td>
</tr>
<tr>
<td>-deleted-</td>
<td>deleted</td>
</tr>
<tr>
<td>+inserted+</td>
<td>inserted</td>
</tr>
<tr>
<td>Text with*superscript^</td>
<td>Text with^{superscript}</td>
</tr>
<tr>
<td></td>
<td>Hint: There are two ways to make superscripts work, when used directly after another word or character:</td>
</tr>
<tr>
<td></td>
<td>• Add a space before the superscript. For example, kg/m ^3^ gives you this: kg/m^3^</td>
</tr>
<tr>
<td></td>
<td>• Add braces (curly brackets) around the superscript markup. For example,</td>
</tr>
<tr>
<td></td>
<td>kg/m{^3^}</td>
</tr>
<tr>
<td></td>
<td>gives you this: kg/m^3^</td>
</tr>
<tr>
<td>Text with<del>subscript</del></td>
<td>Text with^{subscript}</td>
</tr>
<tr>
<td>{{monospaced}}</td>
<td>monospaced</td>
</tr>
<tr>
<td>bq. Here's how you make a paragraph appear as a block quotation.</td>
<td>Here's how you make a paragraph appear as a block quotation.</td>
</tr>
<tr>
<td>[color:red]look ma, red text![color]</td>
<td>look ma, red text!</td>
</tr>
</tbody>
</table>

Text Breaks

Paragraph Break

In a Confluence page template, a continuous line of text with two carriage returns at its end forms a paragraph. This is equivalent to a
Continuous line of text followed by a blank line.
When rendered into HTML, the result is a line of text wrapped in a set of `<p></p>` tags.

**Line Break**

Confluence provides two options for forcing a line break within a paragraph of text:

- Implicitly, by entering a single carriage return at its end.
- Explicitly, by entering two consecutive backslashes: `\`\`

When rendered into HTML, the result is a paragraph of text that is split into separate lines by `<br>` tags, wherever a forced line break appears.

ℹ️ For most purposes, explicit line breaks are not required because a single carriage return is enough.

The examples below show how to use explicit line breaks.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>here is some text</td>
<td>here is some text</td>
</tr>
<tr>
<td><code>\</code>` divided <code>\</code>`using line <code>\</code>`breaks<code>\</code>`</td>
<td>divided using line breaks</td>
</tr>
</tbody>
</table>

This is a short list:
- Point 1
  - Text to go with point 1
- Point 2
  - Text to go with point 2 with a break

If you wish to use multiple consecutive line breaks, each should be separated by a space character. For example, use `\`\`\` for two consecutive line breaks.

**Horizontal Rule**

Use four dashes (----) to create a horizontal rule.

ℹ️ Make sure that the dashes are on a separate line from the rest of the text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>here is some text</td>
<td>here is some text</td>
</tr>
<tr>
<td><code>\</code>`----<code>\</code>`divided by a horizontal rule</td>
<td>divided by a horizontal rule</td>
</tr>
</tbody>
</table>

**Links**

You can use wiki markup to create links in a page template.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><code> [#anchor]</code></td>
<td>A link to an anchor on the same page.</td>
</tr>
</tbody>
</table>
Confluence 4.0 Documentation

| [Confluence Wiki Markup^attachment.ext]          | A link to a file attached to the page. |
| [pagetitle]                                     | A link to a page.                     |
| [pagetitle#anchor]                              | A link to an anchor on another page.  |
| [pagetitle^attachment.ext]                     | A link to a file attached to another page. |
| [spacekey:pagetitle]                            | A link to a page in another space.    |
| [spacekey:pagetitle#anchor]                     | A link to an anchor on a page in another space. |
| [spacekey:pagetitle^attachment.ext]            | A link to a file attached to a page in another space. |
| [/2004/01/12/blogposttitle]                    | A link to a blog post.                |
| [spacekey:/2004/01/12/blogposttitle]            | A link to a blog post in another space. |
| [/2004/01/12]                                   | A link to a whole day's blog posts.   |
| [spacekey:/2004/01/12]                          | A link to a whole day's blog posts in another space. |
| [spacekey:]                                    | A link to the space homepage (or the space summary page of the space). |
| [~username]                                    | A link to the user profile page of a particular user. |
| [phrase@shortcut]                               | A shortcut link to the specified shortcut site. Shortcuts are configured by the site administrator. |
| [mailto:legendaryservice@atlassian.com]        | A link to an email address.           |
| [file://z:/file/on/network/share.txt]          | A link to a file on your computer or on a network share that you have mapped to a drive. This only works on Internet Explorer. |

Note that Confluence treats headings as anchors, so you can link to headings using this pattern: [spacekey:pagename#headingname], where headingname is case-sensitive and must be entered without spaces.

For each of these link forms:

- You can prepend a link alias, so that alternate text is displayed on the page. Example: [link alias|pagetitle#anchor]
- You can append a link tip, which appears as a tooltip. Example: [pagetitle#anchor|link tip]

### Images

Images, from attached files or remote sources, can be displayed in a page template.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>![<a href="http://www.host.com/image.gif">http://www.host.com/image.gif</a>]!</td>
<td>An image from a remote source is displayed on the page. Uses a fully qualified URL.</td>
</tr>
<tr>
<td>![attached-image.gif]!</td>
<td>An image file attached to the page is displayed.</td>
</tr>
<tr>
<td>![pageTitle^image.gif]!</td>
<td>An image file attached to a different page is displayed.</td>
</tr>
<tr>
<td>![spaceKey:pageTitle^image.gif]!</td>
<td>An image file attached to a page in a different space is displayed.</td>
</tr>
</tbody>
</table>
An image file attached to a blog post is displayed.

The image is displayed as a thumbnail on the page (only works with images that are attached to the page). Users can click on the thumbnail to see the full-sized image. Thumbnails must be enabled by the site administrator for this to work.

For any image, you can specify attributes of the HTML image tag as a comma separated list of name=value pairs.

Available HTML image tags include:

<table>
<thead>
<tr>
<th>Image tag</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>align</td>
<td>Available values are 'left', 'right', 'bottom', 'center', 'top'.</td>
</tr>
<tr>
<td>border</td>
<td>Specifies the width of the border (in pixels).</td>
</tr>
<tr>
<td>bordercolor</td>
<td>Use with the 'border' tag. Specify colours by name or hex value.</td>
</tr>
<tr>
<td>hspace</td>
<td>Specifies the amount of whitespace to be inserted to the left and right of the image (in pixels).</td>
</tr>
<tr>
<td>vspace</td>
<td>Specifies the amount of whitespace to be inserted above and below the image (in pixels).</td>
</tr>
<tr>
<td>width</td>
<td>Specifies the width of the image (in pixels). This will override the natural width of the image.</td>
</tr>
<tr>
<td>height</td>
<td>Specifies the height of the image (in pixels). This will override the natural height of the image.</td>
</tr>
<tr>
<td>title</td>
<td>Specifies alternate text for the image, which is displayed when the pointer hovers over the image.</td>
</tr>
<tr>
<td>alt</td>
<td>Specifies alternate text for the image. This text is retrievable via search, and contributes to accessibility of the page for text-only viewing.</td>
</tr>
</tbody>
</table>

Form Field Markup for Templates

Please note, form field markup should only be used in templates. It does not work in wiki pages.

Templates are written using wiki markup, with special markup to insert form fields. When a user creates a page using a template that contains form fields, the user will be prompted to key in data. The data will be captured and stored in the new page.

Here are the three kinds of form fields supported and the markup to create them:

<table>
<thead>
<tr>
<th>Text field</th>
<th>Creates a text input field for a variable called VAR.</th>
</tr>
</thead>
</table>

Related Topics

Form Field Markup for Templates
Global Templates
Importing Templates
Adding a Template
Creating a Page using a Template

Take me back to the Confluence User's Guide.
<table>
<thead>
<tr>
<th>Text area</th>
<th>Creates a 5 x 10 text-area for a variable called VAR.</th>
</tr>
</thead>
<tbody>
<tr>
<td>@VAR</td>
<td>textarea(5,10)@</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Drop down menu</th>
<th>Creates a drop-down box containing the values &quot;one&quot;, &quot;two&quot;, &quot;three&quot; and &quot;four&quot;.</th>
</tr>
</thead>
<tbody>
<tr>
<td>@VAR</td>
<td>list(one,two,three,four)@</td>
</tr>
<tr>
<td></td>
<td>• special characters, such as ‘&amp;’</td>
</tr>
<tr>
<td></td>
<td>• punctuation marks, such as ‘:’</td>
</tr>
<tr>
<td></td>
<td>• brackets, such as ‘(‘</td>
</tr>
</tbody>
</table>

Every input field must have a unique name. If you have more than one text input field in the same template with the same name, Confluence will make sure that they all end up with the same value (This is useful if you need the same information in more than one place in the page).

For an example, please see Adding a Template.

**Warning**

There must be no spaces between the @-signs in the markup. This means you can't have items in your drop-down lists that contain spaces.

**Improved Markup**

The above formatting is the basic markup bundled with Confluence, but some plugins expand on this markup to provide greater functionality. Links to these plugins and a comparison can be found in the Working with Templates.

**Related Topics**

Working with Templates
Scaffolding Plugin
Adding a Template
Editing a template
Creating a Page using a Template

**Working with the Office Connector**

The Office Connector is bundled with Confluence 2.10 and later. It allows you to:

- Import an Office document into Confluence format.
- Attach an Office document to a Confluence page and display its content in Confluence, without converting the content.
- Edit the attached document in the Office application, directly from the Confluence page.

Please be aware that source code is currently not available for the Confluence Office Connector.

**Table of Contents**

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing an Office Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector

**Related Topics**

View File Macro
Office Connector Prerequisites

The page describes the software and setup you need to use the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

On this page:
- Overall Prerequisites
- Prerequisites for Viewing Office and PDF Files in Confluence
- Prerequisites for Importing Office Documents into Confluence
- Prerequisites for Editing Office Files Directly From Confluence
- Related Topics

Overall Prerequisites

- Ensure that Java 5 (JDK 1.5) or higher is installed on your Confluence server.
- The WebDAV plugin must be enabled, because the Office Connector uses WebDAV to transfer information to and from Office documents. Note that the WebDAV plugin is bundled with Confluence, and can be enabled or disabled by the System Administrator. If necessary, refer to the instructions on enabling plugins and configuring the WebDAV options.
- Ensure that your Confluence server’s base URL is set correctly. (Check it by going to the ‘General Configuration’ screen in the Confluence Administration Console, as described in Configuring the Server Base URL.) When a user edits a wiki page in Word and then uploads the page back to the Confluence server, the base URL determines where the document will be saved. If the base URL is incorrect, the documents may be saved to a different Confluence server.

Prerequisites for Viewing Office and PDF Files in Confluence

If you want to use the View File macro, or to view Office files attached to a Confluence page, you need the setup described below.

Browsers and Flash Player

You can use any browser to view an Office file on a wiki page or attachment view, provided that you have installed Adobe Flash Player version 9 or later. You do not need to have an Office desktop application installed on your computer in order to view Office files in Confluence.

File Types

Confluence can display files compatible with Microsoft Office 97-2007, and PDF files, of the following types:

- .doc and .docx
- .xls and .xlsx
- .ppt and .pptx
- .pdf

Prerequisites for Importing Office Documents into Confluence

- Document import can import Microsoft Word documents of the file types .doc and .docx. These must be valid Word 97-2007 format documents.

Prerequisites for Editing Office Files Directly From Confluence

The Office Connector allows you to edit Office files embedded in a wiki page or from the page’s attachments view.

To make use of these editing capabilities, you will need the setup described below.

Browsers

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.

Office File Editors

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

Configuration Matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7,</td>
<td>• OpenOffice 2.x – 3.x, or Microsoft Office XP, 2003, 2007 or 2010</td>
<td>• Internet Explorer 8.x – 9.x, or Firefox 4.x – 5.x</td>
</tr>
<tr>
<td>Windows Vista, or</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows XP with</td>
<td>• OpenOffice 2.x – 3.x, or Microsoft Office XP, 2003, 2007 or 2010</td>
<td></td>
</tr>
<tr>
<td>Service Pack 2 or</td>
<td>The “Edit in Word” feature is known to work in OpenOffice 3.2.0.</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mac OS X 10.5</td>
<td>• OpenOffice 2.x – 3.x</td>
<td>• Firefox 4.x – 5.x</td>
</tr>
<tr>
<td>and 10.6</td>
<td>The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.</td>
<td></td>
</tr>
<tr>
<td>Linux</td>
<td>• OpenOffice 2.x – 3.x</td>
<td>• Firefox 4.x – 5.x</td>
</tr>
</tbody>
</table>

Related Topics

Working with the Office Connector

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing an Office Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector

Configuring the Office Connector in the Confluence Administration Guide

Take me back to Confluence User’s Guide

Displaying Office Files in Confluence

Confluence can display Office files that are attached to a page. If you have an Office application installed, you will also be able to edit these Office files in your Office application.

These are two of the ways that Confluence can interact with Office files. For an overview of all Office Connector features, please refer to Working with the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

On this page:

- Prerequisites
- Attaching and Displaying Office Files and PDF Files
- Viewing and Editing the Attached Office Files
- Troubleshooting
- Related Topics

Prerequisites

If you want to use the View File macro, or to view Office files attached to a Confluence page, you need the setup described below.

**Browsers and Flash Player**

You can use any browser to view an Office file on a wiki page or attachment view, provided that you have installed Adobe Flash Player version 9 or later. You do not need to have an Office desktop application installed on your computer in order to view Office files in Confluence.


**File Types**

Confluence can display files compatible with Microsoft Office 97-2007, and PDF files, of the following types:

- .doc and .docx
- .xls and .xlsx
- .ppt and .pptx
- .pdf

**Attaching and Displaying Office Files and PDF Files**

There are two ways to do this in Confluence:

- Attach Office files to a page and display them in a Confluence page using the View File or Attachments macros
- Attach an Office or PDF file to a page and embed its contents onto the page by simply dragging and dropping it into the editor window

**To attach and display Office files in Confluence using macros:**

1. Attach the Office file(s) to a Confluence page:
   - View the Confluence page on which you want to display your document.
   - Choose **Tools > Attachments**.
   - Browse for your Office files and upload them to the Confluence page.
   - Refer to detailed instructions in Attaching Files to a Page.
2. Now you have two options for displaying the attached document:
   - You can embed the document into the Confluence page, using one of the Office Word, Office Excel, Office PowerPoint or View PDF macros. These macros can be found using the **macro browser**. Refer to the detailed instructions in the View File topic.
   - You can display a list of page attachments using the Attachments macro. People viewing the page will be able to click the View link to see the Office or PDF document in Confluence.

**To attach and display an Office file on a Confluence page using 'drag and drop':**

- Drag the Office file from your computer and drop it into the editor window. Only one file can be dragged and dropped at a time. The appropriate View File macro placeholder will appear in the position where you dragged the file. However, the contents of the file will be rendered in full when you preview, or save and view, the page.
  
  Older browser versions require Google Gears to have been installed for you to use drag and drop. Refer to Using Drag-and-Drop in Confluence for information about setting up Google Gears.

**Viewing and Editing the Attached Office Files**

If an Office document is attached to a Confluence page, you can view the attached Office document from within Confluence. View the Office document in one of the following ways:

- Search for the Office document by file name, then click View next to the Office document on the Search results page. (See Searching Confluence.)
- View the list of attachments for a specific Confluence page, then click View next to the Office document on the Attachments page. (See Viewing Attachment Details.)
- View a list of attachments displayed on a page via the Attachments macro, then click View next to the Office document in the list of attachments. (See Displaying a List of Attachments in a Page.)
- View a Confluence page which has the Office document embedded in the page via the View File macro. (See View File Macro.)

Any Confluence user who has an Office application installed will also be able to launch their Office editor from within Confluence:

- Editing an Office Document from Confluence.
- Editing an Office Presentation from Confluence.
- Editing an Office Spreadsheet from Confluence.

**Troubleshooting**

Problems? Please refer to our guide to the Office Connector limitations and known issues.

**Related Topics**

- View File Macro
- Working with the Office Connector
- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing an Office Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector
Importing an Office Document into Confluence

The Office Connector in Confluence allows you to import an Office document into Confluence, so that the document's content is copied onto one or more Confluence pages.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

The simplest way to import an Office document is to import the entire content of the document into a single wiki page. By default, the content of the document will be created as a new wiki page.

More advanced options allow you to import the content into a new page, to split a single document into more than one wiki page, and to resolve conflicts in the titles of your pages.

These options are described below.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root page title</td>
<td>The title of the wiki page that will contain the information from your imported document.</td>
</tr>
<tr>
<td>Import as a new page in the current space</td>
<td>A new wiki page will be created with the page title specified above.</td>
</tr>
</tbody>
</table>
Replace <pagename>
The contents of the existing page will be replaced. The page will be renamed to the page title specified above.

Delete existing children of <pagename>
The existing child pages of the page you are replacing will be deleted.

Rename imported pages if page name already exists
Assign new names to any new page which would otherwise have a duplicate name. The content of existing pages will remain unchanged.

Replace existing pages with imported pages of the same title
If imported pages have titles equal to existing pages, then the content of the Office document will overwrite the content on the existing page. Page history will be preserved.

Remove existing pages with the same title as imported pages
If imported pages have titles equal to existing pages, then the existing pages will be deleted. This will remove the page history as well as the content.

Split by heading
The content of the Office document will be split over multiple wiki pages. If you don't want to split your document into multiple wiki pages, leave the default Don’t split option selected. For more information on splitting your document, please see below.

7. Click Import.

When the upload has finished, the content of the Office document will have been transformed into Confluence page content. You can now view and edit this page in the usual way. There is no connection between the original Office document and this wiki page.

Screenshot: Empty page ready for import

Screenshot: Selecting Office document to import

Screenshot: Importing an Office document

Screenshot: Page after import
Splitting an Office Document into Multiple Wiki Pages

When importing an Office document, you can split a single document into more than one wiki page, based on the heading styles in the document.

By default, the page names will be the same as the heading text. This may result in a conflict, if a page already exists with the same title. You can instruct the importer how to handle such conflicts.

To import an Office document into multiple wiki pages:

1. Import an Office document as described above. On the import document options screen, choose how to split your document in the 'Split by heading' field:
   - 'Split by heading' — If you want to split the content under each heading in your document into separate child pages, select the desired heading level to split by. A preview of the page hierarchy that will be created by the split will be displayed under 'Document Outline'. Each bullet point in the 'Document Outline' represents a new page after import into Confluence.
2. Click 'Import' to import your document.
3. When the upload has finished, the content of the Office document will have been transformed into Confluence page content. You can now view and edit this page in the usual way. There is no connection between the original Office document and this wiki page.

Screenshot: Splitting a single Office document into multiple wiki pages

Related Topics

- Working with the Office Connector
- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing an Office Document into Confluence
- Editing an Office Document from Confluence
Editing an Office Document from Confluence

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows you to edit a Word document from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.

You can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

On this page:
- Prerequisites for Editing an Attached Office Document
- Editing an Office Document in your Office Application
- Troubleshooting
- Related Topics

Prerequisites for Editing an Attached Office Document

The Office Connector allows you to edit Office files embedded in a wiki page or from the page’s attachments view.

To make use of these editing capabilities, you will need the setup described below.

Browsers
- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.

Office File Editors

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

Configuration Matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7,</td>
<td>OpenOffice 2.x – 3.x, or Microsoft Office XP, 2003, 2007 or 2010</td>
<td>Internet Explorer 8.x – 9.x, or Firefox 4.x – 5.x</td>
</tr>
<tr>
<td>Windows Vista, or Windows XP with Service Pack 2 or 3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mac OS X 10.5 and 10.6</td>
<td>OpenOffice 2.x – 3.x The “Edit in Word” feature is known to work in OpenOffice 3.2.0.</td>
<td>Firefox 4.x – 5.x</td>
</tr>
<tr>
<td>Linux</td>
<td>OpenOffice 2.x – 3.x The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.</td>
<td>Firefox 4.x – 5.x</td>
</tr>
</tbody>
</table>

Editing an Office Document in your Office Application
To edit an Office document in your Office application:

1. There are two ways to do this:
   
   - **From an Office document embedded on a page:**
     
        a. Open a Confluence page with an Office document embedded on it.
        b. Move your mouse pointer to the top of the document embedded in the Confluence page, until the hidden title bar appears.

        Screenshot: The title bar showing 'document.doc' above an embedded Office document

   - **From an Office document in a list of attachments:**
     
        a. If an Office file is attached to a Confluence page, you can edit this file directly in your compatible Office application, in one of the following ways:
           - View the list of attachments for a specific Confluence page, then click Edit next to the Office file on the Attachments page. (See Viewing Attachment Details.)
           - View a list of attachments displayed on a page via the Attachments macro, then click Edit next to the Office file in the list of attachments. (See Displaying a List of Attachments in a Page.)

   c. Click the title bar above the embedded document.

2. A window will pop up, asking you to confirm that you want to open this document.

   Screenshot: Confirmation window in Firefox
3. Click ‘OK’. Now you may be asked to log in to your Confluence server.

4. Enter your Confluence username and password, then click ‘OK’.
5. The Office document will open in your Office application.
6. Make the necessary changes, then save the document. It will be saved back into Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Related Topics

Working with the Office Connector
- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing an Office Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector

Configuring the Office Connector in the Confluence Administration Guide

Take me back to the Confluence User’s Guide.
Editing an Office Spreadsheet from Confluence

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows you to edit an Excel spreadsheet from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.

ℹ️ Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

<table>
<thead>
<tr>
<th>On this page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Prerequisites for Editing an Attached Office Spreadsheet</td>
</tr>
<tr>
<td>• Editing an Office Spreadsheet in your Office Application</td>
</tr>
<tr>
<td>• Troubleshooting</td>
</tr>
<tr>
<td>• Related Topics</td>
</tr>
</tbody>
</table>

Prerequisites for Editing an Attached Office Spreadsheet

The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.

To make use of these editing capabilities, you will need the setup described below.

**Browsers**

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.

**Office File Editors**

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

**Configuration Matrix**

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, Windows Vista, or Windows XP with Service Pack 2 or 3</td>
<td>• OpenOffice 2.x – 3.x, or Microsoft Office XP. 2003, 2007 or 2010</td>
<td>• Internet Explorer 8.x – 9.x, or Firefox 4.x – 5.x</td>
</tr>
<tr>
<td>Mac OS X 10.5 and 10.6</td>
<td>• OpenOffice 2.x – 3.x, The “Edit in Word” feature is known to work in OpenOffice 3.2.0.</td>
<td>• Firefox 4.x – 5.x</td>
</tr>
<tr>
<td>Linux</td>
<td>• OpenOffice 2.x – 3.x, The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.</td>
<td>• Firefox 4.x – 5.x</td>
</tr>
</tbody>
</table>

Editing an Office Spreadsheet in your Office Application

To edit an Office spreadsheet in your Office application:

1. There are two ways to do this:
   - From an Office spreadsheet embedded on a page:
     a. Open a Confluence page with an Office document embedded on it.
     b. Move your mouse pointer to the top of the spreadsheet embedded in the Confluence page, until the hidden title bar appears.
c. Click the title bar above the embedded spreadsheet.

- **From an Office spreadsheet in a list of attachments:**
  - If an Office file is attached to a Confluence page, you can edit this file directly in your compatible Office application, in one of the following ways:
    - View the list of attachments for a specific Confluence page, then click **Edit** next to the Office file on the Attachments page. (See Viewing Attachment Details.)
    - View a list of attachments displayed on a page via the Attachments macro, then click **Edit** next to the Office file in the list of attachments. (See Displaying a List of Attachments in a Page.)

2. A window will pop up, asking you to confirm that you want to open this document.

   **Screenshot: Confirmation window in Firefox**

   ![Confirmation window in Firefox](image)

   **Screenshot: Confirmation window in Internet Explorer**

   ![Confirmation window in Internet Explorer](image)

3. Click ‘**OK**’. Now you may be asked to log in to your Confluence server.
Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Related Topics

Working with the Office Connector

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing an Office Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector

Configuring the Office Connector in the Confluence Administration Guide

Take me back to the Confluence User's Guide.

Editing an Office Presentation from Confluence

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows you to edit a PowerPoint presentation from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.
Prerequisites for Editing an Attached Office Presentation

The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.

To use these editing capabilities, you will need the setup described below.

Browsers

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.

Office File Editors

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

Configuration Matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, Vista, or XP Service Pack 2 or 3</td>
<td>OpenOffice 2.x – 3.x, or Microsoft Office XP, 2003, 2007 or 2010</td>
<td>Internet Explorer 8.x – 9.x, or Firefox 4.x – 5.x</td>
</tr>
<tr>
<td>Mac OS X 10.5 and 10.6</td>
<td>OpenOffice 2.x – 3.x, The “Edit in Word” feature is known to work in OpenOffice 3.2.0.</td>
<td>Firefox 4.x – 5.x</td>
</tr>
<tr>
<td>Linux</td>
<td>OpenOffice 2.x – 3.x, The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.</td>
<td>Firefox 4.x – 5.x</td>
</tr>
</tbody>
</table>

Editing an Office Presentation in your Office Application

To edit an Office presentation in your Office application:

1. There are two ways to do this:
   - From an Office presentation embedded on a page:
     a. Open a Confluence page with an Office presentation embedded on it.
     b. Click the 'Edit' icon on the bottom frame of the slide show.

   *Screenshot: PowerPoint presentation displayed on a Confluence page*
1. From an Office document in a list of attachments:
   - If an Office file is attached to a Confluence page, you can edit this file directly in your compatible Office application, in one of the following ways:
     - View the list of attachments for a specific Confluence page, then click **Edit** next to the Office file on the Attachments page. (See **Viewing Attachment Details**.)
     - View a list of attachments displayed on a page via the Attachments macro, then click **Edit** next to the Office file in the list of attachments. (See **Displaying a List of Attachments in a Page**.)

2. A window will pop up, asking you to confirm that you want to open this document.

*Screenshot: Confirmation window in Firefox*
3. Click ‘OK’. Now you may be asked to log in to your Confluence server.

4. Enter your Confluence username and password, then click ‘OK’.
5. The presentation will open in your Office application.
6. Make the necessary changes, then save the presentation. It will be saved back into Confluence.

**Troubleshooting**

Problems? Please refer to our guide to the Office Connector limitations and known issues.

**Related Topics**

Working with the Office Connector

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing an Office Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector

Configuring the Office Connector in the Confluence Administration Guide
Installing the Firefox Add-On for the Office Connector

If you are using Firefox as your browser, you will need to install an add-on into Firefox (the Firefox WebDAV Launcher) in order to use some features of the Office Connector. You will be prompted to install the add-on the first time you try to use a function which requires it.

For an overview of all Office Connector features, please refer to Working with the Office Connector.

Supported Web Browsers

Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. You can find the list of supported web browsers and browser versions on this page: Supported Platforms.

On this page:
- Installing the Firefox Add-On
- Configuring the Add-On
- Security Risks
- Information about this Firefox Add-On
- Related Topics

Installing the Firefox Add-On

You will be prompted to install the add-on the first time you try to use a function which requires it. The add-on is required for editing a wiki page in Office, or for editing an Office document which is displayed on a wiki page.

1. When you choose an option which requires the Firefox add-on, you will see a popup window like this one:

   ![Popup Window]

   Click 'OK'. Some browsers may now ask you to confirm the download with a message bar across the top of the page, beneath the browser’s address bar.

   - You may see a message like the yellow bar shown here:

     ![Message Bar]

     Click ‘Allow’.

   - Or you may see a similar message with an ‘Edit Options’ button like this:

     ![Message Bar with Edit Options]

     If you see the above message, click ‘Edit Options’. You will then see an ‘Allowed Sites’ window like this one:
This window lets you tell Firefox that your Confluence server is allowed to install add-ons into Firefox. The 'Address of web site' box should already contain the address of your Confluence server.

- Click the 'Allow' button to add your Confluence server to the list.
- Go back to your Confluence page and try to edit your Office document again, e.g. by clicking 'Edit in Word' again. Now you will see the option to install the add-on.

3. A 'Software Installation' window will appear, asking you to confirm the installation. The window will look something like the one below, but the URL will be the address of your own Confluence server:

4. Click 'Install Now'. The installation will happen and a window will pop up asking you to restart Firefox:
5. Make sure you have saved all your Confluence pages and any other work in your browser, then restart Firefox.
6. If Firefox asks you to confirm the restart, confirm it.
7. Firefox will close all the browser windows and will then start up again. You will see a window confirming that a new add-on has been installed, like this:

---

**Configuring the Add-On**

After you have installed the add-on into Firefox, you will need to configure it. Basically, you will associate a desktop application (editor) with each relevant file type. This tells the Office Connector which application to launch when it encounters a link to an editable file. The configuration is slightly different for each operating system, as described below.

**Configuring the Add-On in Windows**

The add-on can will automatically configure itself on Windows via the system registry. The first time you edit a new file type, the add-on will look up the default editor for that file type and make that the permanent setting.

If you want to override the registry settings, or if for some reason the automatic configuration is not working, you can configure the Firefox add-on manually.

1. In Firefox, go to the 'Tools' menu and select 'WebDAV Launcher Options', as shown in this screenshot:
1. A 'WebDAV Launcher Options' window will appear, allowing you to associate a specific file type (file extension) with a desktop application (editor). The window looks like this one:

![Screenshot: Configuring the WebDAV Launcher - adding the 'doc' file extension.](image1)

2. In the 'File Extension' box, enter the extension for a particular file type. For example, you may want to associate the 'doc' file extension with Microsoft Word 2003 or earlier. To do this, you would type 'doc' in the File Extension text box.

3. **If you use or have recently upgraded to Office 2007**

   In addition to the original Office 2003 file extensions (that is, 'doc', 'ppt' and 'xls'), you should additionally configure the WebDAV launcher to handle the new Office 2007-specific file extensions for Microsoft Word ('docx'), Microsoft Excel ('xlsx') and PowerPoint ('pptx').

   ![Screenshot: Configuring the WebDAV Launcher - adding the 'doc' file extension.](image2)
4. Enter the **Application Path** — Use one of the following methods to specify the associated application for editing the given file type:

- Click the **Auto** button to load the associated application from the Windows registry.
- Alternatively, you can click the **Browse** button to find the application on your computer.
- Or you can manually type in the path to the application’s executable file.

*Screenshot: Configuring the WebDAV Launcher - adding the 'Application Path' for the 'doc' file extension.*

---

**If you use or have recently upgraded to Office 2007**

Follow the instructions in this step to add the path to the relevant Office 2007 application for the Office 2007 file extension you configured above. For example, if you had a typical default installation of Office 2007, you would add the application path ‘C:\Program Files\Microsoft Office\Office12\WINWORD.EXE’ to the ‘docx’ extension.
5. Click the 'Add' button. The file extension association will be added to the list. For example, in the picture below you can see that the 'doc' extension has been associated with 'C:\Program Files\Microsoft Office\OFFICE11\WINWORD.EXE'. This is the path to the Microsoft Word 2003 executable on a specific Windows machine.

Screenshot: Configuring the WebDAV Launcher - configuration of the 'doc' file extension complete.

<table>
<thead>
<tr>
<th>File Extension</th>
<th>Application Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>doc</td>
<td>C:\Program Files\Microsoft Office\OFFICE11\WINWORD.EXE</td>
</tr>
</tbody>
</table>

Configuring the Add-On in Mac OS X

The only supported Office editor for Mac OS X is NeoOffice. (See Office Connector Prerequisites.)

The add-on will try to configure itself automatically by looking under /Applications/NeoOffice, which is the default installation location for NeoOffice.

If the automatic configuration does not work, you will need to associate your NeoOffice executable with each file type.

The configuration procedure is similar to Windows, as shown above. Note that there is no 'Auto' button in Mac OS X.

Configuring the Add-On in Linux

The only known supported Office editor for Linux is OpenOffice. (See Office Connector Prerequisites.)

There is no automatic configuration on Linux. You will need to associate each file type with your Office editor in Firefox. Note that there is no 'Auto' button in Linux.

The configuration procedure is similar to Windows, as shown above.

For both Ubuntu and OpenSUSE, the configuration will look something like this:

<table>
<thead>
<tr>
<th>File Extension</th>
<th>Application Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>doc and docx</td>
<td>/usr/bin/owriter</td>
</tr>
<tr>
<td>ppt and pptx</td>
<td>/usr/bin/ooimpress</td>
</tr>
<tr>
<td>xls and xlsx</td>
<td>/usr/bin/ocalc</td>
</tr>
</tbody>
</table>

Security Risks

Please be aware that there are security risks in installing this add-on to Firefox. Internet Explorer is exposed to the same risks, because it can directly open Office documents. By installing the add-in into Firefox, you are exposing Firefox to the same risks.
Summary of the risks:

- Office documents can contain macro viruses. Before opening an Office document, make sure that you trust the source of the document.
- There are known flaws in the Office file formats and Microsoft Office that an attacker can exploit to gain control of your machine. Microsoft has fixed the known exploits in the latest Service Packs for all Microsoft Office versions. But new exploitations may arise at any time. Again, be sure that you trust the source of a document before opening it.

The add-on tries to reduce the risk by supporting the following:

- **Same origin policy** — The add-on can only open documents from the same host that initiated the action.
- **Digital signature** — The add-on is digitally signed. When you install the add-on please verify that it is signed by Benryan Software Inc.

- **Prompt the user for confirmation** — You will always be warned before a file is opened. Please read these warnings carefully before opening a file. The warning tells you the complete URL of the file as well as the complete application path of the application opening the file.

### Information about this Firefox Add-On

<table>
<thead>
<tr>
<th>Add-on name:</th>
<th>WebDAV Launcher</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description:</td>
<td>Adds the ability to launch a WebDAV URL directly in a WebDAV-aware client.</td>
</tr>
<tr>
<td>Latest version:</td>
<td>1.0.4</td>
</tr>
<tr>
<td>Compatible with:</td>
<td>All versions of Firefox, up to and including 3.6.6</td>
</tr>
<tr>
<td>Author:</td>
<td>Atlassian Pty Ltd</td>
</tr>
</tbody>
</table>

We plan to host the add-on at Mozilla. When the add-on has its own page at Mozilla, we will add a link from this page to the Mozilla page. Please watch CONF-20394 for progress.

### Related Topics

- Working with the Office Connector
- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing an Office Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
Importing Content Into Confluence

Confluence 4.0, and later versions, stores all page content as XHTML.

On this page:
- Importing Content from Other Confluence Sites
- Importing Content from Other Wikis
- Importing Content from an Office Document
- Importing Web Content
- Importing Other Non-Wiki Content
- Other Useful Plugins
- Related Topics

Importing Content from Other Confluence Sites

For content originating from other instances of Confluence:
- If the Confluence major versions are the same, export the space from the originating Confluence site and import it into the destination Confluence site.
- If the Confluence major versions are different, you can use an intermediate server to migrate versions.

Page history, attachments, and page content will be preserved and you will be able to do multiple pages at once. The drawbacks are that it may be inconvenient if the Confluence versions differ, and you cannot have a duplicate space key on the destination instance. (You cannot import a space with the same space key as a space that already exists.)

Importing Content from Other Wikis

Check whether the Universal Wiki Converter can import the content. See Importing Content from another Wiki.

Importing Content from an Office Document

The Office Connector in Confluence allows you to import an Office document into Confluence, so that the document's content is copied onto one or more Confluence pages. See Importing an Office Document into Confluence.

Importing Web Content

Here are some options for importing or displaying web content on a Confluence page:
- Use the Widget Macro to display videos, slide shows, twitter chats, documents and more, sourced from other web sites and displayed on your Confluence page.
- Convert a HTML file to a Confluence page using the HTML To Confluence Converter plugin.
- Embed an external web page into Confluence with the HTML Include macro.
- Use HTML code in a page with the HTML macro.

Importing Other Non-Wiki Content

Importing non-wiki markup into Confluence requires a conversion process:
- Text with basic formatting can be pasted directly into the editor. This includes simple Word documents or web pages.
- Files such as Microsoft Excel documents can be imported using a content converter plugin.
- Confluence pages saved to disk can be imported from disk.
- Files can be uploaded in bulk using the Confluence WebDav Plugin.
- Full featured customisation is available using the Confluence XML-RPC and SOAP APIs.

Other Useful Plugins

- Content Import Plugin

Note about Plugin Support

Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.
Related Topics

Working with the Office Connector
Importing Content from another Wiki

Take me back to Confluence User's Guide

Importing Pages from Disk

Confluence allows you to import text files from a disk or a directory on the Confluence server, and convert them into Confluence pages. Each file will be imported as a Confluence page that has the same name as the file.

- The text file needs to contain Confluence wiki markup to be converted accurately into a Confluence page.
- You need to be a System Administrator to import text files.
- You can import pages from disk into global spaces, but not into personal spaces. Please see Working with Spaces for information about differences between global spaces and personal spaces.

To import text files:

1. Choose Browse > Space Admin. Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. Click Import pages from disk in the left panel under 'Import'.
3. Type the directory's path into the Import directory box.
4. Select Trim file extensions to remove file extensions from the page titles when converting the files to Confluence pages. Note that the Confluence pages will take their titles from the files' names (including their extensions). So to avoid having page titles with a suffix like '.txt', make sure you check this box.
5. Select Overwrite existing pages if you want to replace existing Confluence pages with the same page title.
6. Click Import.

Related Topics

Take me back to Confluence User's Guide

Sharing Content

Confluence provides a number of ways for you to notify other users about content that may be of interest to them:

- You can share a page link with them.
- You can mention the user when you write a page, blog post or comment. Mentioning a user automatically emails a notification to them about that content.
- You can broadcast a message that appears in Confluence activity streams.

Other users can also find out about changes to content in Confluence by watching pages and spaces.

You may also be interested in exporting Confluence content to other formats such as XML, HTML, MS Word and PDF.

Related Topics

Creating Content
Watching Changes
Organising Content

Take me back to the Confluence User's Guide.

Network Overview
The ‘network’ feature provides notifications on the activity of users that you choose to follow. This compares with Confluence’s other content tracking features, which provide notifications on specified types of content updates, made by any user. The types of activities tracked by the network feature include:

- Additions or edits to pages or blog posts
- Comments added to a page or blog post or edits to existing comments
- Updates to a user’s User Status Updates
- Updates to a user’s User Profile

On this page:
- Accessing Your Network View
- Following Another User
- Stop Following a User
- Notes
- Related Topics

Accessing Your Network View

To see your network view:

- Go to the ‘Network’ view for your user profile. To do this:
  - Go to your name (the ‘User’ menu) at the top of the page and choose Network. You can also access your ‘Network’ view by clicking More in the ‘Network’ section of your Profile Sidebar.

You can access another user’s Network view using the Hover Profile or from their Profile Sidebar.

Screenshot: Example of the Network view

Following Another User

You can follow another user by using either the Hover Profile or your Network view.

To follow a user with the Hover Profile:

1. Open the user's Hover Profile popup. To do this:
1. Log in to Confluence, if you have not already done so.
2. Move your mouse pointer over a user's linked name or profile picture. Wait until the hover profile popup appears.

To follow a user from your Network view:

1. Go to the 'Network' view for your user profile. To do this:

   • Go to your name (the 'User' menu) at the top of the page and choose Network.
     You can also access your 'Network' view by clicking More in the 'Network' section of your Profile Sidebar.

2. In the 'Following' section, at the right of the page, type the first few characters of the name (or username) of the user you wish to follow.
3. Choose the user from the list of suggestions.
4. Click Follow in the popup.

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just followed will appear within the 'Following' list on the right. Additionally, their tracked activities will start appearing in the 'Recent Activity' list on this page.

Stop Following a User

To stop following a user by using the Hover Profile:

1. Open the user's Hover Profile popup. To do this:

   a. Log in to Confluence, if you have not already done so.
   b. Move your mouse pointer over a user's linked name or profile picture. Wait until the hover profile popup appears.
2. Click Stop Following in the popup.

You can also stop following a user by going to their Profile view.

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just stopped following are removed from the 'Following' list on the right. Additionally, their tracked activities will stop appearing in the 'Recent Activity' list on this page.

Notes

Once you are following a user, you can see their activity in a number of ways:

• Your Network view: your Network view shows all the tracked activities that you have permission to view for all the users that you are following. In the same way, people who follow you will be able to see all your Confluence-based activities on their network views, provided they have permission to view the content. See below for instructions on accessing your network view.
• RSS feeds: you can subscribe to any Confluence user's network RSS feed and receive summaries on the activities of other users they are following in their network. See Subscribing to a Network RSS Feed.
• Email notifications: you can request email notifications of any activity in your network. See Subscribing to Email Notifications of Updates to Confluence Content.

Note that it is not possible to stop another user from following you. If you are interested in the ability to block followers, please watch CONF-16285 for updates on the feature request.

Related Topics

Network Macro
Subscribing to a Network RSS Feed
Subscribing to Email Notifications of Updates to Confluence Content

Take me back to the Confluence User's Guide.

Subscribing to a Network RSS Feed

You can create an RSS Feed from any user's network view, allowing you to receive summaries on the activities of users they are following in their network. The types of activities tracked in these RSS feed summaries include:

• Additions or edits to pages or blog posts
• Comments added to a page or blog post or edits to existing comments
• Updates to a user's User Status
• Updates to a user's User Profile

To subscribe to a user's network RSS feed,
Customising your Network RSS Feed

Currently, Confluence does not provide a user interface mechanism for customising your network RSS feed. However, you can modify the maximum number of results and type of content displayed in these feeds by directly editing the RSS feed link in your RSS newsreader.

To modify the maximum number of results displayed in your RSS feed,

1. Edit the RSS feed link in your RSS newsreader.
2. Change the value of the max parameter from its default value of 40 to a value of your choice. The following example shows this parameter-value combination highlighted in red:
   http://confluence.atlassian.com/feeds/network.action?username=ggaskell&max=60&publicFeed=false&os_authType= basic&rssType=atom
3. Save the modified link in your RSS newsreader.

To modify the type of content displayed in your RSS feed,

1. Edit the RSS feed link in your RSS newsreader.
2. Append the parameter contentType to the end of the link, followed by an equals sign (=) and then add the appropriate content type value of your choice:
   • USER_STATUS — restricts the RSS feed to user status updates.
   • PAGE — restricts the RSS feed to page additions or updates.
   • BLOG — restricts the RSS feed to blog post additions or updates.
   • ATTACHMENT — restricts the RSS feed to attachment additions or updates.
   • COMMENT — restricts the RSS feed to comment additions or updates.
   Content type values are case-sensitive and when editing the network RSS feed link, ensure that each parameter is separated from the other by an ampersand (&).
   The following example shows the content type parameter-value combination highlighted in red:
   http://confluence.atlassian.com/feeds/network.action?username=ggaskell&max=40&publicFeed=false&os_authType= basic&rssType=atom&contentType=USER_STATUS
3. Save the modified link in your RSS newsreader.

Filtering for more than one type of content (by adding multiple values to the contentType parameter) is not supported.

RELATED TOPICS

Network Overview
Subscribing to RSS Feeds within Confluence

Take me back to the Confluence User’s Guide.

Using Mentions

You can use autocomplete to automatically notify another Confluence user that you have mentioned them in a page, blog post, comment or status update.

Type '@' to see a list of suggested users to mention. When you save the page, an email is automatically sent to the user to notify them that they have been mentioned on that page (if they have permission to view the page or blog post). This works for new and updated pages, blog posts, comment and status updates.

You need to know the user's real name – autocomplete for mentions suggests users' full names only, not their usernames.

To autocomplete a mention using '@':

1. Edit the page.
2. Click where you want to insert a mention and type '@' and then the first few characters of the user's real name.
3. Choose the user's name from the list of suggestions.

Screenshot: Autocomplete for mentions
Confluence provides several ways by which you can watch for changes to single pages, entire spaces, and all spaces on the site. When you watch a page or space, Confluence sends you an email whenever that content changes.

You can also track a particular user's activity on the Confluence site.

You can only track updates to content that you have permission to see.

**Manually Watching Content**

You can ‘watch’ a page or a space that you have permission to view. Confluence will then send you a notification by email whenever anyone adds or updates content on, or adds a comment to, that page or space.

- There is no daily digest for these notifications. You will receive an email notification every time someone makes a change.
- You can choose the pages and/or spaces that you want to watch. You can ‘unwatch’ a page or a space at any time.

To set up a watch on a specific page or space, see:
- Watching a Page or Blog Post
- Watching a Space

**Configuring Watches**

All email notification settings can be changed from one location. See Editing User Settings.

**Manage Watchers**

Space administrators are able to manage watchers of pages and spaces.

**Using labels and RSS feeds as an alternative to watches**

You can use the RSS feed builder to track updates to labelled pages and comments on those pages. Here is an idea for customising your RSS feed by using your own personal label(s). This is useful if you want to track updates to specific pages or blog posts, and you do not want to deal with emails. You can use this method as an alternative to watching pages.

- Build an RSS feed that returns pages, blog posts and comments labelled with a personal label, such as 'my:feed'.
- Each time you want to ‘watch’ a page, just label it with 'my:feed'.
- All updates and comments will automatically come through your RSS feed.

**Confluence RSS Feeds**
You can watch for content changes in Confluence using RSS feeds.

- Create a customised RSS feed using the RSS Feed Builder.
- Subscribe to one of the pre-specified feeds generated by Confluence.

**Related Plugins**

- The **Contributors plugin** allows you to list the users, watchers, labels and etc in a page.
- The **Autowatch Plugin** allows you to automatically watch a page or blog post that you have created or edited. For example, if you comment on a page, you will be set to watch that page for further updates.

Plugins should be used with care. Please refer to the note on supported plugins.

**Related Topics**

Page History and Page Comparison Views
Viewing Space Activity

Take me back to the Confluence User's Guide.

**Watching a Page or Blog Post**

You can 'watch' a Confluence page, blog post or space. Confluence will then send you a notification by email whenever anyone updates the watched content.

You will receive email notifications for:

- Edits (unless the user clears the Notify watchers check box).
- Deletions.
- Attachments, including new versions or deletions of an existing attachment.
- Comments, including new comments, edits of existing comments or deletions of existing comments.

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called 'autowatch'. You can control autowatch.

There is no daily digest for email notifications. You will receive an email notification every time someone makes a change.

You will **not** receive email notifications for content changes due to the output of a macro, because the page content itself has not been edited.

---

You need 'View' permission for the page, blog post or space to receive notifications.

---

**On this page:**

- Watching a Page or Blog Post
- Setting Autowatch and Other Notification Options
- Watching an Entire Space
- Watching for New Blog Posts
- Managing Watches from your User Profile
- Managing Watches from the Email Message
- Related Topics

---

**Watching a Page or Blog Post**

To start watching a page or blog post:

1. Go to the page or blog post.
2. Choose **Tools > Watch**.

To stop watching a page or blog post:

1. Go to the page or blog post.
2. Choose **Tools > Stop watching**.

**Setting Autowatch and Other Notification Options**

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called 'autowatch'. You can turn autowatch on or off, and set other notification options, in the email settings section of your user profile. See Setting User Settings.
Watching an Entire Space

You can choose to watch all the pages and blog posts in a given space. See Watching a Space.

Watching for New Blog Posts

You can choose to watch for:

- New blog posts in a given space. See Watching a Space.
- All new blog posts in the Confluence site. See Subscribing to Email Notifications of Updates to Confluence Content.

Managing Watches from your User Profile

The ‘Watches’ page in your user profile displays a list of all pages and spaces you are currently watching.

To manage your watches:

1. Go to the ‘Watches’ view for your user profile, as follows:
   - Go to your name (the ‘user’ menu) at the top of the page and choose Watches.
2. Click the envelope icon next any unwanted watches to turn them off.

Managing Watches from the Email Message

The email notifications that you receive from Confluence have some useful links at the bottom of the email message. The links in each message vary, depending on the context. In general, the links allow you to view the page online, reply to a comment, and so on. In particular with respect to setting your notification preferences, you will see one or more of the following links:

- Stop watching page – Click this link to stop watching the page that triggered the email notification.
- Stop watching space – Click this link to stop watching the space that triggered the email notification.
- Stop following this user – Click this link to stop following the user whose update triggered the email notification.
- Manage Notifications – Click this link to go to the email settings page in your user profile.

Related Topics

Watching a Space
Subscribing to Email Notifications of Updates to Confluence Content
Watching Changes
Updating Email Address

Take me back to Confluence User’s Guide

Watching a Space

You can ‘watch’ a Confluence page, blog post or space. Confluence will then send you a notification by email whenever anyone updates the watched content.

You will receive email notifications for:

- Edits (unless the user clears the Notify watchers check box).
- Deletions.
- Attachments, including new versions or deletions of an existing attachment.
- Comments, including new comments, edits of existing comments or deletions of existing comments.

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called ‘autowatch’. You can control autowatch.

There is no daily digest for email notifications. You will receive an email notification every time someone makes a change.
You will **not** receive email notifications for content changes due to the output of a macro, because the page content itself has not been edited.

You need 'View' permission for the page, blog post or space to receive notifications.

On this page:

- Watching an Entire Space
- Watching for New Blog Posts in a Space
- Watching all Spaces on the Site
- Managing Watches from your User Profile
- Managing Watches from the Email Message
- Related Topics

### Watching an Entire Space

Watch a space if you want to receive notifications of updates to any content in the space.

**To start watching a space:**

1. Go to a page in the space and choose **Browse > Advanced**.
2. In the left-hand panel, click **Start watching this space** (or **Start watching all content**).

**To stop watching a space:**

1. Go to a page in the space and choose **Browse > Advanced**.
2. In the left-hand panel, click **Stop watching this space**.

### Watching for New Blog Posts in a Space

You can choose to receive a notification whenever someone adds a blog post in the space. You will not receive notification of updates to or deletions of blog posts, nor of comments on the blog posts.

**Hint:** By default, the option is labelled **Start watching space blogs**. If you are already watching the entire space, the wording will change to **Only watch space blogs**. If you choose that option, you will no longer be watching the entire space.

**To start watching for new blog posts in a space:**

1. Go to a page in the space and choose **Browse > Advanced**.
2. In the left-hand panel, click **Start watching space blogs** (or **Only watch space blogs**).

**To stop watching for new blog posts in a space:**

1. Go to a page in the space and choose **Browse > Advanced**.
2. In the left-hand panel, click **Stop watching space blogs**.

### Watching all Spaces on the Site

You can receive notifications about changes to the content of pages, blog posts and comments from across all spaces on a Confluence site.

**To start watching for content changes across the whole site:**

1. Go to **your name** (the 'User' menu) at the top of the page and choose **Settings**.
2. Click **Email** in the left-hand panel.
3. Click **Edit** and select **Subscribe to daily updates**.
4. Click **Submit**.

### Managing Watches from your User Profile

The 'Watches' page in your user **profile** displays a list of all pages and spaces you are currently watching.

**To manage your watches:**

1. Go to the 'Watches' view for your user profile, as follows:
   
   - Go to **your name** (the 'user' menu) at the top of the page and choose **Watches**.
2. Click the envelope icon next any unwanted watches to turn them off.
Managing Watches from the Email Message

The email notifications that you receive from Confluence have some useful links at the bottom of the email message. The links in each message vary, depending on the context. In general, the links allow you to view the page online, reply to a comment, and so on. In particular with respect to setting your notification preferences, you will see one or more of the following links:

- **Stop watching page** – Click this link to stop watching the page that triggered the email notification.
- **Stop watching space** – Click this link to stop watching the space that triggered the email notification.
- **Stop following this user** – Click this link to stop following the user whose update triggered the email notification.
- **Manage Notifications** – Click this link to go to the email settings page in your user profile.

Screenshot: Email notification footer showing links

Related Topics

- Watching a Page or Blog Post
- Subscribing to Email Notifications of Updates to Confluence Content
- Watching Changes
- Updating Email Address

Take me back to Confluence User's Guide

Managing Watchers

If you are a **space administrator** for a space, you can manage the watchers for all pages and blog posts in that space. This means that you can:

- View a list of the watchers of a page/blog post.
- View a list of the watchers of the space for that page/blog post.
- Add users as watchers of the page/blog post.
- Remove existing watchers of the page/blog post.

> **It is not possible to remove watchers of the space.**

To manage your watchers for a page/blog post:

1. Navigate to the page or blog post for which you want to manage the watchers. Note, you must be a space administrator for the space that the page is in.
2. Choose **Tools > Manage Watchers**. The ‘Manage Watchers’ screen will be displayed (see screenshot below). The left-hand column of the ‘Manage Watchers’ screen will contain the users watching the page/blog post, the right-hand column will contain the users watching the space.
   - To remove an existing page watcher, click the icon (trash can) next to the user’s name.
   - To add a user as a watcher of the page, type in the box and choose the user’s name from the list.
3. Click **Done** to save your changes.

Screenshot: Managing Watchers
You can 'watch' a page or a space. Confluence will then send you a notification by email whenever anyone adds or updates content on that page or space. You can also subscribe to daily email reports and other notifications of various updates, as described below.

Email notifications can be set to show the changes made to the page content. The changes are displayed as rendered page diffs. See Page History and Page Comparison Views.

**Subscribe to email notifications**

You can subscribe to email notifications about:

- Updates to a particular space or a page.
- Changes in all spaces that you have permission to see.
- Updates made by the people you are following.
- All pages that you create, edit or comment on.

**Subscribe to RSS feeds**

You can subscribe to Confluence RSS feeds to stay informed about:

- New and updated pages
- New comments
- New news items
- New attachments
- Updates to and comments on pages that have a given label

**Subscribing to RSS Feeds within Confluence**

RSS feeds allow you to track updates to content within Confluence. You will need an RSS newsreader to subscribe to them.
On this page:

- Confluence RSS Feeds
- RSS Newsreaders
- Removing an RSS Feed
- Related Topics

Confluence RSS Feeds

You can create a customised RSS feed using the RSS Feed Builder or subscribe to one of the pre-specified feeds generated by Confluence.

What would you like to do?

- Create and subscribe to customised RSS feeds using the RSS Feed Builder — create a customised RSS feed (e.g. filter your feed using a label; specify the number of items and days to include in your feed; etc.)
- Subscribe to pre-specified RSS feeds — generate an RSS feed automatically in a minimal number of steps.
- Subscribe to a feed of any Confluence user’s network to track the activities of users they are following in their network.

RSS Newsreaders

The following are some popular RSS newsreader programs for various operating systems. You can find a more comprehensive list on Google’s open directory.

Windows

- SharpReader
- NewsGator
- Syndirella
- FeedDemon
- NewzCrawler

Mac OS X

- Safari
- NetNewsWire
- NewsFire
- Shrook

Multi-Platform

- NewsMonster (Runs in the Mozilla web browser)
- Radio Userland (Windows and MacOS)
- AmphetaDesk (Windows, Unix, Mac OS X)

Removing an RSS Feed

There is no need to try to delete or remove an RSS feed built by the Confluence RSS feed builder.

Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL (address). For example, take a look at the following feed URL:

```
http://example.com/confluence/display/SPACE/Space+RSS+Feed?types=page&fields=modified&maxitems=10&days=7
```

The above feed URL will generate a list of pages ("types=page"), sorted by the modification date and showing the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no need to remove anything.

Related Topics

- Watching Changes
- Working with RSS Feeds
- RSS Feed Macro

Take me back to the Confluence User’s Guide.

Using pre-specified RSS feeds

If you want to customise your Confluence RSS feed (e.g. use a label to filter your feed), use the RSS Feed builder instead.

To subscribe to RSS feeds generated by Confluence, for a particular space:

1. Choose Browse > Advanced from the dropdown list. The "Advanced" screen will appear.
2. Click on RSS Feeds in the left-hand column.
3. Copy and paste the link for one of the following feeds into your RSS newsreader:
   - Pages
   - News
   - Mail
   - Comments
   - Attachments
   - All content

To subscribe to RSS feeds generated by Confluence, for a particular page (where available):

1. Locate the following icon, which is available in the top-right corner of certain pages: 
2. Copy and paste the icon's link into your RSS newsreader.

**Related Topics**

Using the RSS Feed Builder
Watching Changes
Working with RSS Feeds
RSS Feed Macro

Take me back to the Confluence User's Guide.

**Using the RSS Feed Builder**

Using the RSS feed builder, you can create customised RSS feeds to subscribe to changes within Confluence.

Wondering what an RSS feed is? See more information about RSS Feeds.

**On this page:**

- Building an RSS Feed
- Hint: Using Labels to Customise your Feed
- Notes
- Related Topics

**Building an RSS Feed**

Follow the steps below to build your feed, choosing the type of content and the time period you want to monitor.

**To create a customised RSS feed:**

1. Choose Browse > Feed Builder.
2. Select the content types you want in your feed. Check Mail if you want to know when the email archive is updated. (See the overview of mail archives in Confluence.)
3. Select one or more spaces from the list.
4. Click Advanced Options to set the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feed Name</td>
<td>The default name is based on the name of your Confluence installation, e.g. 'Extranet RSS Feed'</td>
</tr>
<tr>
<td>With these labels</td>
<td>Enter one or more labels separated by spaces or commas. Confluence returns all content (of the selected types) that matches one or more of the labels. See the hint below about using labels to customise your feeds.</td>
</tr>
<tr>
<td>Exclude these spaces</td>
<td>Exclude specific spaces from those already selected.</td>
</tr>
<tr>
<td>Sorted by</td>
<td>Sort content by either the date or creation or the date they were last updated.</td>
</tr>
<tr>
<td>Limit to</td>
<td>Specify the number of items returned in your feed.</td>
</tr>
<tr>
<td>Within the last</td>
<td>Specify how old items returned can be.</td>
</tr>
</tbody>
</table>
5. Click Create RSS Feed to create your feed.
6. Drag or copy the link into your RSS reader.

Tip: Try building separate feeds, one for pages only and one that includes comments as well. This allows you to monitor only pages if you are short of time, and to read the comments when you have more time.

Hint: Using Labels to Customise your Feed

You can use the RSS feed builder to track updates to labelled pages and comments on those pages. Here is an idea for customising your RSS feed by using your own personal label(s). This is useful if you want to track updates to specific pages or blog posts, and you do not want to deal with emails. You can use this method as an alternative to watching pages.

- Build an RSS feed that returns pages, blog posts and comments labelled with a personal label, such as 'my:feed'.
- Each time you want to 'watch' a page, just label it with 'my:feed'.
- All updates and comments will automatically come through your RSS feed.

Notes

- **Removing an RSS feed:** You need only delete the RSS feed link built by the Confluence RSS feed builder to remove an RSS feed from your page. This is because the feed is dynamically generated using the parameters in the feed URL.

- **Feed authentication options:** Confluence can offer you the option of an anonymous feed or a feed that requires authentication.
  - An anonymous feed will show only the content that is visible to anonymous users. The feed URL does not contain the `os_authType` parameter mentioned below. This feed is useful only if your Confluence site allows anonymous access. If a feed is anonymous, you only get anonymously-viewable content in the feed regardless of whether you are a Confluence user or not.
  - An authenticated feed requires you to log in to Confluence before you can retrieve the content. The feed URL contains the following parameter: `os_authType=basic`.
  - The option to choose between an anonymous and an authenticated feed is currently not available on the feed builder screen. The feed builder offers only authenticated feeds. See CONF-21601 for details and a workaround.

Related Topics

- RSS Feeds FAQ
- Watching Changes
- Working with RSS Feeds

Take me back to Confluence User's Guide

Working with RSS Feeds

An RSS feed is a format for delivering summaries of regularly changing web content. Subscribing to an RSS feed allows you to stay informed of the latest content from sites that you are interested in.

RSS isn't designed to be read in a regular web browser. Specialised RSS newsreader programs can check RSS files every so often, and tell you what's new on a site. Your reader may be on a website, an addon to your browser, part of your email program, or a stand-alone program.

Confluence works with RSS in two ways:

- Confluence generates its own RSS feeds for tracking updates to content within Confluence. You will need an RSS reader which can grab the RSS feeds from Confluence and display them for you.
- Confluence's RSS macro allows you to display the contents of RSS feeds on a Confluence page. The feeds may come from a Confluence feed generator or from external sites. In this way, Confluence can act as an RSS reader.

For a technical description of RSS, read Mark Pilgrim's "What is RSS?" article on XML.com.

Related Topics

- Subscribing to RSS Feeds within Confluence
- Displaying content from RSS feeds on a Confluence page
- Watching Changes

Take me back to Confluence User's Guide

RSS Readers Compatibility

Due to some users having problems with Confluence RSS Feeds, some research was done with several RSS Feed Readers. RSS Feeds have been created through the feed builder and tested on a Windows machine. For each feed reader they have been tested with both authentication and public access, checking for the visibility of content, icons and images. The results are in the tables below:
Feeds with authentication

<table>
<thead>
<tr>
<th>RSS Feed Reader</th>
<th>Content</th>
<th>Icons</th>
<th>Images</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>RssReader 1.0.880</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>• Shows the entire page (including the header panel &amp; view,edit tabs)</td>
</tr>
<tr>
<td>JetBrains Omea Reader 2.1.6</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>• Shows the changes between revisions in the nice red/green colours of Confluence</td>
</tr>
<tr>
<td>IE 7.0</td>
<td>✗</td>
<td>✓</td>
<td>✓</td>
<td>• Content is all there however not all html is rendered correctly (for example .tag {font-style:italic;} is shown in the content as raw text) • Shows the changes between revisions, but without the red/green colours</td>
</tr>
<tr>
<td>Thunderbird 1.5.0.7</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>• Shows the entire page</td>
</tr>
<tr>
<td>Bloglines</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>• Simple online feed reader • Shows the changes between revisions, but with arrows</td>
</tr>
<tr>
<td>Google Reader</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>• Simple online feed reader • Shows the entire page</td>
</tr>
<tr>
<td>Yahoo</td>
<td>✗</td>
<td>✗</td>
<td>✗</td>
<td>• Error message: Invalid URL format</td>
</tr>
</tbody>
</table>

Feeds with public access

<table>
<thead>
<tr>
<th>RSS Feed Reader</th>
<th>Content</th>
<th>Icons</th>
<th>Images</th>
</tr>
</thead>
<tbody>
<tr>
<td>RssReader 1.0.880</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>JetBrains Omea Reader 2.1.6</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>IE 7.0</td>
<td>✗</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Thunderbird 1.5.0.7</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Bloglines</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>

Searching Confluence

The search box at the top right of your Confluence screen allows you to search Confluence wherever you happen to be in the site. It offers you a quick navigation aid as well as a full site search.

You can also search Confluence directly from your browser's search box.
Quick guide to searching in Confluence

- You can search Confluence using your browser's search box (Firefox or Internet Explorer 7 or later). Just add your Confluence site as a search provider using the dropdown menu in your browser's search box.
- The Confluence search box (top-right corner) suggests search terms as you type. If your desired search term is suggested, you can open the page simply by clicking on it.
- Performing a full search provides you with more detailed search results, including the ability to preview images and Office documents.
- The full search also suggests alternative spellings ("Did you mean") as part of your search results.

On this page:
- Searching Confluence from your Browser’s Search Box
- Using the Quick Navigation Aid
- Search Options When Using the Documentation Theme
- Performing a Full Search
- Viewing Attached Office Documents
- Accepting 'Did you mean' Suggestions from Confluence
- Filtering your Search Results
- Advanced Search Syntax
- Browsing Related Labels
- Searching the Content of Attachments
- Related Topics

Searching Confluence from your Browser’s Search Box

If you are using Firefox or Internet Explorer 7 or later, you can add add your Confluence site as a search provider, using the dropdown menu next to the browser’s search box.

The example below shows the 'Extranet' Confluence site offered for inclusion as a search engine in the browser's search box.

Screenshot: Adding your Confluence site to your browser's search box

Information about OpenSearch:
- Confluence supports the autodiscovery part of the OpenSearch standard, by supplying an OpenSearch description document. This is an XML file that describes the web interface provided by Confluence's search function.
- Any client applications that support OpenSearch will be able to add Confluence to their list of search engines.
- Your Confluence Administrator can enable or disable the Open Search feature using the Confluence Administration Console.

Using the Quick Navigation Aid

The quick navigation aid automatically offers a dropdown list of pages and other items, matched by title to your search query. You can select one of the offered items or ignore them altogether.

To use the quick navigation aid:
1. Start typing your query into the search box located at the top right-hand corner of every screen. Confluence matches titles as you type, showing a quickly-adjusting dropdown list of pages, blog posts, personal profiles, attachments and so on.
   - Press the Enter key if you want to bypass the quick navigation aid and perform a full search, as described below.
2. To see the space to which an item belongs, let your mouse pointer hover over the item in the dropdown list.
3. Use the up- and down-arrows on your keyboard to move up and down the list of matching titles and select an item.
4. Press the Enter key to open the selected item.
5. If you do not find what you are looking for, click **Search for** at the bottom of the list to do a full search. This has the same effect as pressing Enter immediately after typing your search query. The full search is described below.

**Screenshot: The quick navigation aid showing titles matching the query 'con'**

Here is more information about how the quick navigation feature works:

- Confluence will truncate any titles that are too long to be displayed.
- If a title is too long to fit the box, hover your cursor over the title to see the full text.
- The matching items are grouped by content type so that you can quickly find the type you want. Confluence shows a maximum of 6 pages and/or blog posts, 2 attachments, 3 people and 2 spaces. If no matches are found in a particular category, then that category does not appear in the list.
- Items are ordered with the most recent updates first.
- When the matching item is a person's name, their profile picture appears next to their name in the list.
- The part of the title that is matched by the search query is highlighted in bold text.
- Your Confluence Administrator can enable or disable the quick navigation feature using the Confluence Administration Console.

**Search Options When Using the Documentation Theme**

When using the Documentation theme, the Confluence search offers a few options as described below.

**Using the search box at the top right of the page:**

- By default, the main Confluence search is configured to search the entire Confluence site.
  - You will see the words **Search Confluence** in the search box at top right of the page.
  - The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
- A space administrator can configure the Documentation theme to restrict the search to the current space.
  - You will see the words **Search this space** in the search box at top right of the page.
  - The search will return results from the current space only.
  - You can override the search restriction. Enter 'all:' and your search term to search the entire site. For example, enter the following into the search box at top right of the page to search the entire site for 'technical writing':

```
all: technical writing
```

**Using the search box in the left-hand panel:**

- By default, the Documentation theme's left-hand panel includes a search box. Enter your search term there, to restrict the search to the current space. Specifically, this will search only the pages that are children of the space's home page.
- If your administrator has restricted the main search to the current space, there will not be a search box in the left-hand panel.
Performing a Full Search

When you perform a full search, Confluence will search all content in all spaces (global and personal), mail, personal profiles, attachments and the space description. The results will appear on a new screen.

For the developers

The rendering of search results in Confluence is pluggable. If you are a developer, you may wish to write your own search result renderer to change how the search results are displayed. For more information, please refer to the following developer document: Writing a search result renderer.

To use the full search:

1. Type your query into the search box located at the top right-hand corner of every screen (or type it into the text box at the top of the Search screen).
2. Press the Enter key. (This means that you will ignore the dropdown list of titles offered by Confluence's quick navigation aid, described above.)
3. The Search screen appears, as shown below. If any Confluence pages or items match your search query, the Search screen shows a list of the matching items.
4. Click an item's title to open the Confluence page or other item.

Screenshot: Results of searching for 'permissions'

On the left of the screen you will see a text block for each item that matched the search criteria, with the following information for each item:

- An icon representing the content type (user profile, space, page, blog post, etc). See Confluence Icons.
- The title or name of the content item.
- For attachments: The size and type of file, with a link to download or view the attachment where relevant. See information on viewing Office attachments below.
- For image files: A thumbnail of the image will display to the right of the file name.
- The most relevant few lines of content from within the item. Any words that match your search query are highlighted within the content.
- For personal profile items: The email address.
- The space to which the item belongs, displayed on the last line of the item's text block.
- The date when the content item was last modified.

You will see only search results which you have permission to view.

On the right of the screen are further options which allow you to tailor or filter your search results. See below.

Viewing Attached Office Documents

When the search results include an attached Office document, you will see a View link as shown in the screen snippet below.
Click the View link to view the content of the Office document within Confluence. If you have an Office application installed, you will also be able to launch your Office editor from within Confluence. See Displaying Office Files in Confluence and Working with the Office Connector.

Accepting 'Did you mean' Suggestions from Confluence

When you perform a full Confluence search, as described above, Confluence may offer you an alternative spelling of your search query. The alternative spelling will appear next to the words 'Did you mean', as shown in the example below.

To accept an alternative spelling suggestion:

1. Type your query into the search box.
2. Press the Enter key.
3. Confluence will analyse the wiki content, to determine whether an alternative spelling of your search query occurs more often in the wiki content. If this is the case, the words 'Did you mean' will appear on the screen, along with an alternative spelling for your search query.
4. If you want to try the alternative spelling, click the word showing the suggested spelling. In the example below, you would click confluence.

Here is more information about how the 'Did you mean' feature works:

- Confluence uses both a dictionary (bundled with Confluence) and words mined from the content on your system to work out the best alternative spellings of your search terms. Practically, this means that Confluence can provide spelling corrections for specialised jargon that may not appear in a standard dictionary. In general, when deciding between alternative spellings, Confluence will favour words that appear more often in your content.
- In some cases, the 'Did you mean' suggestion may appear even when there are Confluence pages, etc, which match your search
query. In other cases, there will be no items which match your search criteria. In both cases, Confluence will offer a 'Did you mean' suggestion if there is a word which will help you find more relevant content.

- The 'Did you mean' feature may offer more than one suggestion.
- The 'Did you mean' suggestion may even offer an incorrect spelling. This would happen if the incorrect spelling occurs many times within your Confluence site. This is intentional, because the aim of the 'Did you mean' feature is to help you find content, not to correct your spelling.
- Your Confluence Administrator can enable or disable the 'Did you mean' feature using the Confluence Administration Console.

### Filtering your Search Results

The Search screen, pictured above, appears when you do your first search. By default, Confluence will search all content across your Confluence site, including all spaces, mail archives, attachments and all other content types.

On the right of the screen are options which allow you to tailor or filter the search results.

**Where** — Restrict your search results to a particular space, or to your favourite spaces, global spaces or personal spaces.

**What** — Restrict your search results to a particular content type (pages, blog posts, mail, etc).

**When** — Restrict your search results to content modified within a particular period of time (today, yesterday, within the last week or within the last month).

**Who** — Restrict your search results to content last modified by a particular user. You can start typing the person's username or part of their name into the text box as follows:

- Type the username (e.g. 'jsmith').
- Or start typing the person's first name (e.g. 'john').
- Or their last name (e.g. 'smith').
- Or another part of their name, such as a middle name.

Confluence will offer you a list of possible matches. Use your mouse to select the person you want, then press the Enter key to filter the search results.

*Screenshot: Filtering your search results by user*

More information about the user-matching filter:

- The user-matching filter is not case sensitive. You can enter upper or lower case letters and will receive the same results.
- When looking for users to match the name you entered, Confluence divides a person's name into logical units corresponding to first name, middle name (one or more) and last name. It matches the letters of each unit in the name you entered against the letters of each unit in the user directory. For example, you can enter 'jo sm' to look for John Smith. The search is triggered after you have entered at least two letters.
- For each part of the name, you need to enter at least two letters. For example, if you enter just 'john s', the filter will look for users
called 'john' and will ignore the 's'. Similarly, if you enter 'j smith' you will see everyone with the name 'smith' even if their first name does not start with a 'j'.

- You are not forced to use the auto-complete list. You can just type 'jsmith' or 'jo sm' and filter on that without choosing a match from the dropdown list. Confluence will warn you if there is more than one user corresponding to the name you have entered.

Click Clear Filter if you want to remove all your filters and perform the same search again but without the filter.

**Advanced Search Syntax**

See [Confluence Search Syntax](#) for more ways to refine the text you enter into the search box.

Additionally, see [Confluence Search Fields](#) for special parameters you can use in the search box to search on various metadata.

**Browsing Related Labels**

Also on the right of the Search screen, Confluence will offer a list of labels which are related to your search query. See the screenshot above.

You can click a label to see all pages and blog posts tagged with that label. See [Navigating Pages by Label](#).

**Searching the Content of Attachments**

When you search Confluence, by default the search will include the content of the following types of attachments:

- Word
- Text
- PowerPoint
- Excel
- PDF
- HTML

To search the content of other attachment types, you will need to use an attachment content extractor plugin. For more information, take a look at the following:

- [Existing extractor plugins](#) which you can install on your Confluence site.
- [Guidelines on developing your own attachment content extractor plugin](#).

**Related Topics**

- Confluence Search Syntax
- Confluence Search Fields
- Ranking of Search Results
- Text Tokenisation and Filtering
- Search Macro
- Livesearch Macro
- Pagetree Macro (includes an optional search box)
- Viewing Labelled Pages
- Searching the People Directory

Take me back to the [Confluence User's Guide](#).

**Confluence Search Fields**

This page is intended for developers and advanced users of Confluence. It gives an overview of the Apache Lucene search fields used in Confluence.

On this page:

- Searching for Content in Specific Fields
- Confluence Search Fields
  - Personal Information
  - Pages
  - Blog
  - Attachments
  - Mail Items
- Related Topics

**Searching for Content in Specific Fields**
Confluence data is stored in fields which can be specified in the search. To search a specific field, type the name of the field followed by a colon `:` and then the term you are looking for.

Examples:

```
title:"Some Title"
```

```
labelText:chalk
```

The field specification applies only to the term directly preceding the colon. For example, the query below will look for "Some" in the title field and will search for "Heading" in the default fields.

```
title:Some Heading
```

**Confluence Search Fields**

Below are the fields which can be searched, listed by content type.

### Personal Information

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>fullName</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>username</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

### Pages

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Indexed</td>
<td>Stored</td>
<td>Tokenised</td>
<td>Notes</td>
</tr>
<tr>
<td>------------</td>
<td>---------</td>
<td>--------</td>
<td>-----------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>lastModifiers</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>Username of the user who last updated the page.</td>
</tr>
<tr>
<td>creatorName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>Username of the user who added the page.</td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used on the page</td>
</tr>
</tbody>
</table>

**Blog**

**Attachments**

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>lastModifiers</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>Username of the user who last updated the blog post.</td>
</tr>
<tr>
<td>creatorName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>Username of the user who created the blog post.</td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used in the blog</td>
</tr>
</tbody>
</table>
### Mail Items

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>filename</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>comment</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>lastModifiers</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The username of the user who did the mail import, not the person who sent the email message.</td>
</tr>
</tbody>
</table>
Confluence Search Syntax

Here's how you can refine your search. Confluence will ignore common words like "the" unless you place your query within quotes.

**Exact phrase search**

To search for content that contains the exact phrase "chalk and cheese"

```
"chalk and cheese"
```

Confluence will ignore common words (stop words) like "and" above. This is the default list of stop words used by lucene. Please cast your vote towards this improvement request.

For eg:

1. Searching for "The One" returns all pages containing "One" because "The" is a stop word.
2. Searching for "Cheese One" would only return pages in which "One" appears as the first word (other than stop words) after "Cheese". So it would return "Cheese for One" or "Cheese to One" or "Cheese One". It would not match "One Cheese" or "Cheese Flamingo One"

**Or Search**

To search for content that contains one of the terms, "chalk" OR "cheese"

```
chalk OR cheese
```

**And Search**

To search for content that contains both the terms "chalk" AND "cheese"

```
chalk AND cheese
```

**Not search**

To search for content that contains "chalk" but NOT "cheese"

```
chalk NOT cheese
```

**Excluded Term search**

Similar to the NOT search, to search for content that contains "chalk" and "butter" but NOT "cheese"

```
chalk butter -cheese
```

**Grouping Search**

To search for content that MUST contain "chalk" but CAN contain either "cheese" or "butter" use the search:
(cheese OR butter) AND chalk

**Title Search**

To search for content with "chalk" in its title, where \texttt{title} is the field keyword.

\texttt{title:chalk}

**Wild card searches**

**Single character**

To search for "butter" or "batter" you can use the search:

\texttt{b?tter}

To search for "chicken" or "chickpea" you can use the search:

\texttt{chick*}

*Wildcards can be used anywhere within a word, except at the very beginning. For example:

\texttt{*chick}

is an invalid search term.

**Multiple characters**

To search for "chick" or "chickpea":

\texttt{c*c*}

You can also combine search characters to get the exact word. For example the search term below will return "chick" yet not "chickpea":

\texttt{c*c?}

**Case Sensitivity in wildcard searches**

Since the fix for CONF-13846 Confluence is case sensitive for wildcard searches.

You should note that all the example searches given previously search across the default set of fields which are stored as lower case and therefore all searches of that style should be given lower case search terms (as shown in the examples).

However, if you were to search one of the case sensitive fields, such as 'content-name-untokenized' the case of your search term would need to match the document you are searching for.

**Proximity searches**

This search ensure that the two words specified must be within a certain number of words of each other to be included.
"octagon post"~1

will return "Octagon blog post".

"octagon post"~0

is an invalid search term.

### Range search

Searches for names that fall alphabetically within the specified range.

```plaintext
[adam to ben]
```

Note: You can't use the **AND** keyword inside this statement.

### Fuzzy search

This search looks for words spelled similarly.

To search for octagon, if unsure about spelling:

```
octogan~
```

will correctly return "octagon"

### Combined search

You can also combine various search terms together:

```
o?tsg* AND past~ AND ("blog" AND "post")
```

---

### Related Topics

- Searching Confluence
- Confluence Search Fields

Take me back to [Confluence User's Guide](#)

---

### Ranking of Search Results

When you perform a search in Confluence, it is likely that there will be many pages or other content items that match your search terms. Confluence will rank the matching items by evaluating their relevance. This should mean that the items most relevant to you will appear at the top of the search results list, so that you can quickly select the item you need.

Below is an overview of the method Confluence uses to determine the relevance of the items returned by the search, i.e. to rank the search results.

**On this page:**

- Philosophy behind the Ranking
- Summary of the Ranking Method
- Weighting of Content Types
- Weighting of Fields
- Weighting Based on Age
- Simplified Example
- Related Topics

---

**Philosophy behind the Ranking**
Confluence gives highest priority to personal information i.e. documents which take you to a user's profile when you click on them. Collaboration is a primary function of a wiki, so Confluence makes it easy to find people.

For example, if you search for 'John Smith', the first results you see will be for John Smith's user profile and personal space. There may also be other content (wiki pages, email messages, etc) which contain the words 'John Smith'. These other content types may even have 'John Smith' as the page title and repeated multiple times in the content, but they will still appear lower down in the list of search results.

Matching terms found in the title of a page, or in the title of any content type, are considered a strong match. So are matches found in labels, because when someone applies a label it means that they think the content is particularly relevant to the labelled term.

Matches found in the content body are of average importance. If the matched term appears more than once, the document will be given a proportionately higher ranking.

We also assume that information created recently is slightly more relevant than older information.

**Summary of the Ranking Method**

When displaying the results of a search, Confluence applies a weighting to each of the content items returned.

To determine the weighting:

1. For each content item, Confluence first applies three weightings based on the following:
   a. The content type of the item returned — user profile, page, blog post, attachment, etc. (More details below.)
   b. The type of field in which the search term was found — title, name, label, or content body. (More details below.)
   c. The age of the item returned. (More details below.)

2. Confluence then combines the three weightings to arrive at a single weighting for the content item.

The item with the heaviest weighting will appear at the top of the list of search results, and the other items will appear below in descending order of weighting.

**Weighting of Content Types**

<table>
<thead>
<tr>
<th>Content Type</th>
<th>Weighting</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Profile</td>
<td>9</td>
</tr>
<tr>
<td>Page</td>
<td>8</td>
</tr>
<tr>
<td>Blog</td>
<td>7</td>
</tr>
<tr>
<td>Attachment</td>
<td>6</td>
</tr>
<tr>
<td>Comment</td>
<td>5</td>
</tr>
<tr>
<td>Mail</td>
<td>0.5</td>
</tr>
<tr>
<td>Space Description</td>
<td>0.4</td>
</tr>
</tbody>
</table>

**Simple example**

If the search returns 7 matching items, and each item is one of the above types, then the items will be presented in the above order on the results screen. (This example assumes that the search term is found in the same field in each item — see more about fields below.)

**Weighting of Fields**

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Weighting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>9</td>
</tr>
<tr>
<td>Full name</td>
<td>8</td>
</tr>
</tbody>
</table>
Note that ‘content’ above could be the content of a page, or the content of a comment, or the body of any other content type. See more about content types above.

Simple example

A match for a search term in the title of a document is 1.8 times (9/5) more important than a match in the content.

Weighting Based on Age

This weighting is based on the age of the item returned in the search results. The age of the item is calculated from the creation date of the item. The age intervals are quite coarse-grained, as shown in the table below.

<table>
<thead>
<tr>
<th>When the Item was Created</th>
<th>Weighting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Today</td>
<td>1.5</td>
</tr>
<tr>
<td>Yesterday</td>
<td>1.3</td>
</tr>
<tr>
<td>Up to 1 week ago</td>
<td>1.25</td>
</tr>
<tr>
<td>Up to 1 month ago</td>
<td>1.2</td>
</tr>
<tr>
<td>Up to 3 months ago</td>
<td>1.15</td>
</tr>
<tr>
<td>Up to 6 months ago</td>
<td>1.10</td>
</tr>
<tr>
<td>Up to 1 year ago</td>
<td>1.05</td>
</tr>
<tr>
<td>Beyond a year</td>
<td>1</td>
</tr>
</tbody>
</table>

The weighting is fairly small, so will not have a large effect. When an item is more than a year old, the age weighting is just '1' i.e. it has no effect.

Simple example

- If two documents match in all other ways then the newer one will be presented first.
- If the two documents being compared are both older than a year then their relative age does not matter.

Simplified Example

Let's assume you search for a single term.

Confluence finds a match in the title of an email message created today:

| Weighting for the content type (email) | 0.5   |
| Weighting for field (title)           | 9     |
| Weighting for age (today)             | 1.5   |
| **Total weighting**                   | **6.75** |
Confluence also finds a match in the content of a comment created three weeks ago:

<table>
<thead>
<tr>
<th>Weighting for the content type (comment)</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Weighting for field (content)</td>
<td>5</td>
</tr>
<tr>
<td>Weighting for age (up to 1 month ago)</td>
<td>1.2</td>
</tr>
<tr>
<td><strong>Total weighting</strong></td>
<td><strong>30</strong></td>
</tr>
</tbody>
</table>

**Result:** The comment (weighting 30) will be appear higher in the search results than the e-mail (6.75).

Confluence uses the Apache Lucene search engine library. Lucene's score calculation has a number of additional terms, not mentioned in the above example. We have simplified above, for purposes of illustration. If you are interested, you can see more information in the [Lucene documentation](#).

**Related Topics**

- Searching Confluence
- Confluence Search Syntax
- Confluence Search Fields
- Text Tokenisation and Filtering
- Search Macro
- Livesearch Macro
- Pagetree Macro (includes an optional search box)

Take me back to [Confluence Documentation Home](#)

**Searching the People Directory**

The people directory displays a list of people who use your Confluence site.

The people directory includes anybody who has logged into Confluence or who has had a user account created for them in Confluence. The people directory does not include users who can log into Confluence using external user management if they have never yet logged in.

**Viewing the People Directory**

Choose **Browse > People Directory**.

The Confluence administrator can hide the people directory. If it is hidden, you will not see the People Directory link in the Browse menu.

[Screenshot: The People Directory]
Searching for People

To search for a particular person, type their first name and/or last name into the search box and click Search.

- To search everyone who uses your Confluence site, click All People.
- To search just those people who have set up a personal space, click People with Personal Spaces.

Following People’s Activities

Confluence’s network features allow you to ‘follow’ (that is, keep track of) other people’s activities throughout a Confluence site. For more information, please refer to Network Overview. Using the hover profile feature, the people directory is a convenient area from which you can start following other people throughout your Confluence site.

- To start following another person’s activities, move your mouse over a user’s name or profile picture and in their hover profile popup, click Follow.
- To stop following another person’s activities, move your mouse over a user’s name or profile picture and in their hover profile popup, click Stop Following.

Once you start following another person, their activities will start appearing in your network view.

People Directory provides hCard microformat

The people directory uses the hCard microformat for simple integration with a variety of microformat-enabled tools. hCard is an open data format for representing people, companies, organisations, and places. Read more about microformats and hCard.

Related Topics

Setting up your Personal Space
Editing your User Profile
Choosing a Profile Picture

Take me back to the Confluence User’s Guide.

Text Tokenisation and Filtering

When searching for content based on search terms entered by the user, Confluence splits the text of the content into tokens, and then filters and modifies those tokens according to the following rules.
Tokenisation

Confluence uses Lucene’s Standard Tokenizer. This splits the text into tokens as follows:

- Splits words at punctuation characters, removing punctuation. However, a dot that’s not followed by white space is considered part of a token.
- Splits words at hyphens, unless there’s a number in the token, in which case the whole token is interpreted as a product number and is not split.
- Recognises email addresses and internet host names as one token.

An example: The string ‘foo-bar5’ won’t be split into ‘foo’ and ‘bar5’, so a search for ‘bar5’ or ‘bar*’ will not find any results.

Filtering

Confluence then:

- Removes “s” from the ends of words.
- Removes the dots from acronyms, e.g. I.B.M. becomes IBM.
- Converts everything to lower case.
- Removes common words like ‘the’ and ‘or’ are removed.
- Converts words to their stems. For example, ‘fishing’ and ‘fishes’ both become ‘fish’.

Related Topics

Searching Confluence

Organising Content

Confluence provides a number of ways for organising and structuring content in the wiki:

- **Spaces** allow you to group content according to major categories.
- **Pages** are used for discrete topics, and can be structured into page trees to show the relation between them.
- **Favourites** are particular pages or spaces that have been bookmarked by a user, to make them easy to find again.
- **Labels** are user-defined tags that are added to related pages in order to categorise them in some way.
- **Attachments** to a page can include images, multimedia, Office and PDF files, and provide a way to include other forms of content in the wiki.
- **Email** can be collected and archived within each space individually, to manage all mail related to a project.

Related Topics

Creating Content

Searching Confluence

Take me back to the Confluence User’s Guide.

Working with Pages

Pages are the primary means of storing and sharing information in Confluence. Pages are contained within spaces.

- **Use spaces** to organise your wiki content into your primary logical groups. For example, you could have a space per team, per product or per department.
- **Use pages** to organise your content into lower-level groups. For example, you could have a page for a particular team activity, or for a feature in a product, or for a chapter in a book. Add more child pages to contain lower-level details if necessary.

Things you can do with pages in Confluence:

- Create a new page from anywhere within the site.
- Write content using the editor.
- Rename a page.
- Copy an existing page.
- Organise pages hierarchically via parent-child relationships.
- Move pages while editing a page or while viewing the space’s Tree view.
- Navigate within and between spaces through flexible linking.
- Collaborate via comments on a page.
- Control access through page security restrictions.
- Monitor page updates and other activity through page notifications.
Moving a Page

This page describes how to move a page. You can move a page:

- to a different space, with a new parent
- to have a different parent page, within the same space
- to reorder sibling pages that are children of a common parent.

When you move a page, all of the page content such as attachments and comments will be moved with the page. Additionally, all child and descendant pages and their page content will also be moved.

You can also copy a page, and move an attachment.

On this page:
- Moving a Page to a Different Space
- Moving a Page within a Space
- Related Topics

Permissions

To move a page, you need the following permissions:

- 'Edit' permission on the page you are moving, and
- 'View' permission on the page's parent page. So if you are moving the page to a different parent, you need 'View' permission on the new parent.

To move a page into a different space, you will also need:

- 'Remove' permission on the space you are moving from, and
- 'Create' permission on the space you are moving to.

Moving a Page to a Different Space

You can move a page, along with its child pages, to a different space. Any links to a moved page from the current space will automatically be renamed to point to the page in the new space.

To move a page to another space in your Confluence site:

1. Go to the page and choose Tools > Move.
2. Use the tabs on the left to help you find the new space and parent page for your page, that is, the location where you want to move your page. The 'Current location' and 'New location' breadcrumb trails at the bottom of the dialog indicate the current parent page and new parent page.
3. If you want to move a page to a different position amongst the child pages, check Reorder to see a list of sibling pages when you click Move.
4. Click Move.
5. If you are reordering the child pages, click in the list to set the new position for the page and click Reorder.

Moving a Page within a Space

You can move a page to a different position in the page tree. This allows you to:

- Move a single page, or a family of pages, to have a different parent within the space.
- Reorder sibling pages that are children of a common parent.
Any links to the page are maintained. When a page that is itself a parent (that is, it has one or more child pages) is moved, the entire hierarchy of child pages of the moved page (including comments and attachments) is maintained.

To move a page using the space’s ‘Tree’ view:

1. From any page, choose Browse > Pages.
2. Click Tree.
3. Find the page you want to move.
4. Drag the page up or down the tree.
5. While dragging the page, you see one of the following:
   - A thin line between existing pages — this indicates the potential new position for the page. Release the mouse button when the page is where you want it.
   - A wide highlight over one or more existing pages — this indicates that you can drop the page into a page family. Release the mouse button to add the page to the family. The page will appear either in alphabetical sequence or as the last page in the family, depending on the family’s sequential order.

The new position of the page is saved as soon as you release the mouse button.

To cancel the move while still holding down the mouse button, press the ‘Esc’ key.

Related Topics

Moving an Attachment
Copying a Page
Deleting a Page
Sequential Order of Pages
Overview of Pages

Working with Page Families

A ‘page family’ is simply the parent and child pages in a part of the page hierarchy.

Things you can do with page families in Confluence:

- View a page’s family.
- View the hierarchy of all pages within a space.
- Move and re-order pages.
- Order the pages in a page family alphabetically.

Related Topics

Managing Orphaned Pages

Take me back to the Confluence User’s Guide

Viewing a Page’s Family

To view a page’s family, go to the page and choose Tools > Info.

The page’s parent and children, if any, are listed under ‘Hierarchy’.

Screenshot : Viewing a page’s family

<table>
<thead>
<tr>
<th>Hierarchy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent Page</td>
</tr>
<tr>
<td>Home</td>
</tr>
<tr>
<td>Children (1)</td>
</tr>
<tr>
<td>Choose a Page</td>
</tr>
<tr>
<td>Move an attachment from one space to another</td>
</tr>
<tr>
<td>Move a family of pages from one space to another</td>
</tr>
<tr>
<td>Move a page from one space to another</td>
</tr>
<tr>
<td>Page Families</td>
</tr>
</tbody>
</table>

Notes

- If there are more than 10 children, only the first 10 will be shown by default. To view all the children, click Show all....
- If no parent is displayed for the page, either the page sits in the root directory of the space or its parent has been deleted.
Setting a Page Family to Alphabetical Order

You can choose to display your Confluence pages in alphabetical or manual order. This page tells you how to set the pages within a family to alphabetical order. See Sequential Order of Pages.

On this page:

- About the Sequential Order of Pages
- Alphabetical versus Manual Order
- Changing the Page Order
- Setting Page Order to Alphabetical
- Related Topics

About the Sequential Order of Pages

Confluence allows you to present your pages in any order (sequence) you choose. The position of a page is reflected in the following places:

- The Tree tab on the space's 'Pages' view
- Exporting pages to PDF, HTML and XML
- The Pagetree macro
- The Children macro

Alphabetical versus Manual Order

By default, Confluence will present your pages in alphabetical order. When you move a page to a different position, the order becomes manual for the affected page family.

When ordering pages alphabetically, Confluence actually applies a more sophisticated 'natural' order rather than a straight alphabetical order. The natural order handles numeric values correctly when doing string comparisons.

Now let's consider what happens when you add a page to a page family, by creating a new page or by moving or copying a page into the family:

- If the page family's order is alphabetical, the new page will appear in alphabetical order too.
- If the page family's order is manual, the new page will appear at the bottom of the list of pages in the family.

Changing the Page Order

You can change the order of the pages by moving pages within the page tree — see Moving a Page.

You can also change the order of a page-family from manual to alphabetical (see the 'Setting Page Order to Alphabetical' section on Setting a Page Family to Alphabetical Order).

Setting Page Order to Alphabetical

If the pages in a page family have been ordered manually, you can reset the page order to alphabetical as described below.

A page family is a set of pages under a single parent page. In this section, when we say 'page family' we mean the immediate children of the parent page, not including the grand-children.

The screenshot below shows a family of pages in non-alphabetical order under the parent 'Sample Page'. Notice the A icon next to the parent 'Sample Page', giving you the option to order the pages alphabetically.
To set a page family to alphabetical order:

1. Go to a page in the space and choose Browse > Pages.
2. Go to the Tree tab.
3. Expand the branches of the tree to find the page family you want.
4. If the page family is in non-alphabetical (manual) order, the ‘Sort Alphabetically’ icon will appear next to the parent page as shown in the screenshot above. Click the icon.
5. The child pages will shuffle into alphabetical order and the icon will change to the ‘Undo Sorting’ icon as shown in the screenshot below.

Only the immediate children of the parent page will be affected. The grand-children will not be re-ordered. (If you want to re-order the grand-children, you need to click the ‘Sort Alphabetically’ icon next to the parent of those pages i.e. re-ordering happens for one node at a time.)

If you change your mind, you can click the ‘Undo Sorting’ icon to undo the alphabetical sort. This option is only available while you remain on the Tree tab and provided that you have not performed any other action on the page family. Once you move away from this screen or do something else with the page family, such as moving children in or out of the family, the undo option is no longer available.
Using the Documentation Theme

The Documentation theme is one of the themes bundled with Confluence. It provides an inbuilt table of contents for your wiki space, a configurable header and footer, and text styles suited to documentation. You can also configure it to restrict the search results to the current space, rather than searching the entire Confluence site.

This page tells you how to view pages in your Confluence space when your space uses the Documentation theme. For the full list of features and instructions on applying the theme to a space, see the guide to configuring the Documentation theme.

Quick guide to using the Documentation theme

- The left-hand panel contains a page tree. This is a table of contents that shows the pages in the space.
- Click the plus signs in the page tree to see the child pages.
- Drag the thick vertical bar to change the width of the panels.
- Show/hide the left-hand panel: Click the sidebar icon at top right, next to the search box, to remove the left-hand panel altogether. Click the icon again to restore the panel.
- Alternatively, press ' on your keyboard to show/hide the left-hand panel.
- Overriding a space-restricted search: If your theme is configured to restrict the search to the current space, you can enter 'all:' and your search term to search the entire site.

The rest of this page gives more details of the above guidelines.

Using the Documentation Theme

By default, the left-hand panel contains a search box and a table of contents (page tree) showing all the pages in your space. Specifically, it shows the pages that are children of the space's home page.

A space administrator can customise the Documentation theme as follows:
- Change the content in the left-hand panel and add a header and footer to the page. This means that your own pages may look different from the screenshot above.
- Restrict the search so that it will show results from the current space only, not from the entire Confluence site.

Searching the Space or the Site

When using the Documentation theme, the Confluence search offers a few options as described below.

Using the search box at the top right of the page:
- By default, the main Confluence search is configured to search the entire Confluence site.
• You will see the words 'Search Confluence' in the search box at top right of the page.
• The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
• A space administrator can configure the Documentation theme to restrict the search to the current space.
• You will see the words 'Search this space' in the search box at top right of the page.
• The search will return results from the current space only.
• You can override the search restriction. Enter 'all:' and your search term to search the entire site. For example, enter the following into the search box at top right of the page to search the entire site for 'technical writing':

```
all: technical writing
```

Using the search box in the left-hand panel:

• By default, the Documentation theme's left-hand panel includes a search box. Enter your search term there, to restrict the search to the current space. Specifically, this will search only the pages that are children of the space's home page.
• If your administrator has restricted the main search to the current space, there will not be a search box in the left-hand panel.

**Hints and Tips**

Below are some hints that you may find useful when using the Documentation theme.

*Where can I see a working example of the Documentation theme?*

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

*Which pages will appear in the Documentation theme’s table of contents?*

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page. Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

*Help, my pages do not appear in the Documentation theme table of contents*

**Cause 1: Your pages are not under the space’s home page.** The most probable reason why your pages do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space’s home page. If your pages are above the home page in the page tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

• You can change the designated space home page in the space administration section.
• Or you can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the ‘Pages’ section of the space ‘Browse’ screen. See Moving a Page.

**Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with Documentation theme bundled.** If your existing Confluence installation already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the Documentation theme plugin. See the knowledge base article.

*Help, my left-hand panel has disappeared*

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar icon at top right, next to the search box. Click the icon again to restore the panel.

**Related Topics**

Configuring the Documentation Theme
Space Jump Macro

Take me back to the Confluence User’s Guide

**Sequential Order of Pages**

Confluence allows you to present your pages in any order (sequence) you choose. The position of a page is reflected in the following places:

• The Tree tab on the space's 'Pages' view
• Exporting pages to PDF, HTML and XML
• The Pagetree macro
• The Children macro

**Alphabetical versus Manual Order**
By default, Confluence will present your pages in alphabetical order. When you move a page to a different position, the order becomes manual for the affected page family.

When ordering pages alphabetically, Confluence actually applies a more sophisticated 'natural' order rather than a straight alphabetical order. The natural order handles numeric values correctly when doing string comparisons.

Now let's consider what happens when you add a page to a page family, by creating a new page or by moving or copying a page into the family:

- If the page family's order is alphabetical, the new page will appear in alphabetical order too.
- If the page family's order is manual, the new page will appear at the bottom of the list of pages in the family.

Changing the Page Order

You can change the order of the pages by moving pages within the page tree — see Moving a Page.

You can also change the order of a page-family from manual to alphabetical (see the 'Setting Page Order to Alphabetical' section on Setting a Page Family to Alphabetical Order).

Related Topics

Overview of Pages
Overview of Page Families
Moving a Page

Take me back to Confluence User's Guide

Viewing Page Information

The 'Information View' for a page shows you various bits of useful information about the page.

To see the Information View for a page:

1. View the page.
2. Choose Tools > Info to go to the 'Information' view for the page.

The 'Information View' displays the following information:

1. Page Details: Title, author, date of creation, date of last modification and the tiny link of the page.
3. Page Permissions: Displays page-level security restrictions that apply to the page (if present).
4. Recent Changes: Links to the five most recent versions of the page along with the name of the editor and the date of modification.
5. View page history: A link to the page history, which displays all the versions of the page in reverse chronological order and allows you to compare versions or to restore a previous version.
6. Hot Referrers: The external website pages which send the most viewers to the page.

Screenshot: A page's Information View
Copying a Page

You can copy a page, to create a duplicate of the page content. You will need to rename the page, because a page name must be unique within a space.

You need 'Create Pages' permission, which is assigned by a space administrator from the Space Administration screens. See space permissions or contact a space administrator for more information.

To copy a page:

1. Go to a page in the space and choose Tools > Copy.
   Confluence will open a copy of the page in edit mode. By default, Confluence will name the page 'Copy of <<original page name>>'.
2. Rename the page and make any other changes required in the body of the page.
3. If you need to move the new page to a different space or a different parent, you can edit the Location. Refer to the instructions on moving a page.
4. Click Save.

Notes

- Copying a page will duplicate all of the original page's attachments and labels, but will not copy comments from the original page.
- This method of copying a page does not copy the child pages. Please add your vote to issue CONF-2814 if you'd like to see this improvement.
- You can copy an entire space, including all pages in the space (parents and children) — refer to these instructions on copying a space.
- Consider using the WebDav plugin to move or copy a page hierarchy from one space to another, provided that none of the page names already exist in the target space.
Related Topics

Working with Pages

Take me back to Confluence User's Guide

Working with Comments

A comment is a remark, question, or any other additional information you wish to add to a page. Comments are a means by which a community of users can interact with each other on the site.

You can add a comment to any page or blog post in Confluence.

Comments are displayed at the bottom of the page, below the page content. Comments in Confluence are displayed in one of two views, configured globally by a site administrator:

- **Threaded** - this view shows the comments in a hierarchy of responses. Each subsequent reply to a comment is indented to indicate the relationships between the comments.
- **Flat** - this view displays all the comments in one single list and does not indicate the relationships between comments.

What would you like to do?

Add a comment
Link to a comment
Delete a comment
Edit a comment
Enabling Threaded Comments

Related Topics
Adding a Comment

You can either add a new comment, or respond to a previous comment, on both pages and blog posts in Confluence.

To add a comment, you require 'Create Comments' permission which is assigned by a space administrator from the Space Administration screens. See Space permissions or contact a space administrator for more information.

To add a new comment:

1. Choose Add > Comment from the top of the page, or simply click beside your profile picture below the last comment.
2. Type in your comment.
3. Use Preview to see how your comment will appear.
4. Click Save. By default the current page is added to those that you receive notifications about.

To respond to a comment:

1. Click Reply located below the text of a comment.
2. Type in your response.
3. Click Save.

Notes

- You can only respond to a comment when comments are in 'threaded' view.
- You can choose Tools > Watch to receive an email notification whenever anyone edits the page or adds a comment to the page.
- Your profile picture will appear next to each comment that you have added. (This is true if your space uses the Confluence Default theme.)

Related Topics

Linking to Comments
Deleting Comments
Subscribing to Email Notifications of Updates to Confluence Content

Deleting Comments

To delete a comment from a page, you require 'Remove Comments' permission which is assigned by a space administrator from the Space Administration screens. See Space permissions or contact a space administrator for more information.

Currently, it is not possible to delete all comments for a page simultaneously.

To delete a comment:

1. Go to the page that contains the comment.
2. Click Remove at the bottom of the comments box. This is only displayed if you have permission to remove comments for this page.

Warning

Deleted comments cannot be restored.

Related Topics

Adding a Comment
Linking to Comments

Editing a Comment

Comments are editable if you are using Confluence version 2.4 or later.

You can edit any comments that you have created. Space administrators can edit all comments within their space. The date on a comment always indicates the time the comment was last edited.

To edit a comment:

1. Go to the comment and click Edit.
2. Make changes to the comment just as if you were adding a comment.
3. Click Save when you are finished.
Linking to Comments

You can add a link to a comment by making use of the PermaLink associated with each comment.

On this page:
- To link to a comment from within Confluence
- To link to a comment from outside Confluence
- Related Topics

To link to a comment from within Confluence

1. Right-click on the Permalink icon located at the lower right of the comments box.
2. Select Copy Link Location from the pop-up menu.
3. Edit the page from which you want to link to the comment.
4. Click Link in the toolbar, and select the Web Link tab.
5. Paste the PermaLink into the address field.
6. Provide link text if required.

To link to a comment from outside Confluence

1. Right-click on the Permalink icon located at the lower right of the comments box.
2. Select Copy Link Location from the pop-up menu.
3. Use this URL to link to the comment from your web page.

Alternately, click on the Permalink icon and copy the URL displayed in the address bar of your browser.

The older method of linking to comments (used in Confluence 3.5.x and older) using just the commentid has been removed. If you would like to see it reinstated, please visit this JIRA issue.

Related Topics

Working with Comments
Adding a Comment
Working with Links

Sample Page

Start of sample page content


End of sample page content

child page

Recently Viewed Content

Confluence keeps track of pages you have recently visited throughout all your accessible spaces within a Confluence installation. This history is available from the Recently Viewed content view, which you can use to go back to Confluence pages you have recently visited.

To view the list of recently visited pages and go back to one of them:

1. Go to the 'Recently Viewed' content view. To do this:
1. Go to your name (the 'User' menu) at the top of the page and choose Recently Viewed.
2. Click the title of the page you wish to revisit.

Screenshot: Recently Viewed content view

<table>
<thead>
<tr>
<th>Recently Viewed</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Navigating to the Your Recent History View - copy for Confluence 3.0</strong> by Giles Gaskell [Atlassian Technical Writer] (4 minutes ago)</td>
</tr>
<tr>
<td><strong>Navigating to the Your Recent History View</strong> by David Soul [Atlassian] (28 Jan)</td>
</tr>
<tr>
<td><strong>Your Recent History - copy for Confluence 3.0</strong> by Giles Gaskell [Atlassian Technical Writer] (11 minutes ago)</td>
</tr>
<tr>
<td><strong>Your Recent History</strong> by Giles Gaskell [Atlassian Technical Writer] (13 Jan)</td>
</tr>
<tr>
<td><strong>Viewing Space Activity - copy for Confluence 3.0</strong> by Giles Gaskell [Atlassian Technical Writer] (26 minutes ago)</td>
</tr>
<tr>
<td><strong>Viewing Space Activity</strong> by David Chui (12 Oct)</td>
</tr>
<tr>
<td><strong>Confluence Usage Tracking Plugin</strong> by Philip Cher (30 Nov)</td>
</tr>
<tr>
<td><strong>How Do I Get More Statistics From Confluence?</strong> by Matt Hodges [Atlassian] (06 Apr)</td>
</tr>
<tr>
<td><strong>Plugin Repository Macros</strong> by Giles Gaskell [Atlassian Technical Writer] (07 Apr)</td>
</tr>
<tr>
<td><strong>Popular Plugins Macro</strong> by Giles Gaskell [Atlassian Technical Writer] (07 Apr)</td>
</tr>
</tbody>
</table>

**Note**

This list records up to the last 20 pages visited. However, be aware that it is cleared when you log out of Confluence or your Confluence session terminates.

**Related Topics**

Working with Pages
Browsing a space

Take me back to the Confluence User's Guide.

**E-mailing a Page**

In Confluence, you can easily share a Confluence page or blog post by e-mailing it to recipients of your choice.

On this page:
- E-mailing a link to a Confluence page or blog post
- E-mailing a Confluence page or blog post
- Related Topics

**E-mailing a link to a Confluence page or blog post**

The 'Share' button provides a quick mechanism for e-mailing a link to a page or blog post to Confluence users or any e-mail addresses.

To e-mail a link to a Confluence page or blog post using the Share button:

1. Go to the page or blog post you wish to share.
2. Click Share at the top-right of the page. A popup for entering recipients and a note will appear.

   The Share button will not be visible if your Confluence administrator has not configured an outgoing mail server for your Confluence site.
   If you want to enable this feature, please ask your Confluence administrator. Instructions for enabling this feature can be found here: Configuring a Server for Outgoing Mail.
3. Enter the name or username of a Confluence user or any e-mail address to whom you wish to share the Confluence page. When you begin entering a name or username, or you have typed a valid e-mail address, an autocomplete dropdown will appear.
4. Use the mouse or cursor + Enter key to select the appropriate user or e-mail address from this dropdown. Use this dropdown to add multiple recipients to the list.

To remove a recipient from the list, click the 'bin' icon to the right of the recipient.
5. Enter an optional message into the Note box.
6. Click Share to send a link to the page with your note to the recipients listed on the popup.

E-mailing a Confluence page or blog post

The 'Mail Page' feature provides flexible options for e-mailing a page to Confluence users and groups, and/or any e-mail addresses. It also allows you to add a custom subject line to your e-mail message.

The 'Mail Page' feature is disabled by default and the options to access it will not be visible if this feature is turned off.

If you want to enable this feature, please ask your Confluence administrator. Instructions for enabling this feature can be found here: Enabling the 'Mail Page' plugin.

To e-mail a Confluence page or blog post using the 'Mail Page':

1. Go to the page or blog post you wish to e-mail.
2. Choose Tools > E-mail.
3. On the 'Mail Page', enter the following e-mail details:
   - Recipients: E-mail address(es) — To send the e-mail to someone who is not a Confluence user, type their e-mail address. You can type multiple addresses, separated by commas.
   - Recipients: Confluence Group(s) — Type the name of the Confluence group (or groups, separated by commas); or click this icon to select a group from the list:
   - Recipients: Confluence User(s) — Type the name of the Confluence user (or users, separated by commas); or click this icon to select a user from the list:
   - Subject — (Optional) Type the email's subject line.
   - Notes — (Optional) Type the text (if any) which you want to appear at the top of the e-mail's body. This text will appear before the contents of the Confluence page.
   - Format — Choose whether to send the email in 'Text' or 'HTML' format.
4. Click **Next** to see a preview of your e-mail.
   - To change the **Recipients**, **Subject**, **Notes**, or **Format**, click **Edit** (at the right of the page).
   - To send the e-mail, click **Send** (at the bottom of the page).

**Related Topics**

- Working with Pages
- Working with Blog Posts

Take me back to **Confluence User’s Guide**

### Renaming a Page

To rename an existing page, you require ‘Edit Pages’ permission which is assigned by a space administrator from the Space Administration screens. See **Space permissions** or contact a space administrator for more information.

**To rename a page:**

1. Go to a page in the space, and click **Edit** at the top to view the page in ‘Edit’ mode.
2. Change the page title as required.
3. Click **Save**.

**Notes**

- Confluence will automatically update all internal links to point to your new page title. This only works for page links that use the relative link syntax, for example [Renaming a Page].
- In macros, page links will not be updated. You need to update these manually.
- Links from external sites will be broken, unless they use the page's permanent URL.

**Related Topics**

- Linking Pages
- Working with Pages

Take me back to **Confluence User’s Guide**

### Deleting a Page

To delete a page, you require the ‘Remove Pages’ permission which is assigned by a space administrator from the Space Administration screens. See **Space Permissions** or contact a space administrator for more information.

**To delete a page:**

1. Go to the page.
2. Go to the ‘Remove Page’ option. To do this:
   - Go to a page in the space and choose **Tools > Remove**. You will be prompted to confirm the action.

**Notes**

- Pages deleted in this way are stored in the trash and can be recovered by a space administrator. **Purge** the trash to remove the
If the page you are deleting has any child pages, they will be moved to the root of the space.

Attachments attached to a deleted page will remain in the database (allowing potential retrieval) until the trash is purged. When the trash is purged, all attachments on that page are permanently removed.

**Related Topics**

- Restoring a Deleted Page
- Purging Deleted Pages

When a user deletes a page from a Confluence space, the page is not permanently removed. Instead, Confluence places the deleted page into the 'Trash'. The page will remain in 'Trash' until a space administrator purges the page.

Purging deleted pages permanently clears them from 'Trash'.

You need to be a space administrator to purge deleted pages for a space.

**To purge deleted pages:**

1. Choose **Browse > Space Admin**.
   
   *Space Admin* is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click **Trash** in the left-hand navigation panel. A list of deleted pages and blog posts for the space is displayed.

3. Click the **Purge** link beside a page or else click **Purge All** to permanently clear all deleted pages and news items.

   When the trash is purged, all attachments on purged pages are permanently removed as well.

**Related Topics**

- Deleting a Page
- Restoring a Deleted Page

When you restore a page, you are retrieving it from 'Trash' to the root of the space where it existed before it was deleted.

You need to be a space administrator to restore deleted pages.

**To restore a deleted page:**

1. Choose **Browse > Space Admin**.
   
   *Space Admin* is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click **Trash** from the left panel. A list of deleted pages and emails for the space is displayed.

3. Click **Restore** beside the page you want to restore.

**Note**

If a new page has already been created in that space with the same name as the deleted page, you will be given an option to rename the page before it is restored.

**Related Topics**

- Deleting a Page
- Purging Deleted Pages

**Page History and Page Comparison Views**

Confluence tracks histories of changes to pages by maintaining a version of the page each time it is modified. It is easy to view changes between different versions and to restore a previous version if required.
On this page:

- Accessing the Page History View
- Viewing Changes in a Page History
- Page Comparison View
- Other Page History View Features
- Related Topics

Accessing the Page History View

To view the history of a page:

- Go to the page and choose Tools > Page History.

You can click a version number to view that version. To get back to the page history view, click View Page History.

Screenshot: Page History View

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Changed By</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>v. 40</td>
<td>Jun 18, 2007 11:08</td>
<td>Rosie Jameson [Atlassian Technical Writer]</td>
<td>Restore this version</td>
</tr>
</tbody>
</table>

When you are viewing a specific version of the page, the following functions are available:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>current version</td>
<td>View the latest version of the page.</td>
</tr>
<tr>
<td>Compare with Current</td>
<td>Compare the differences between the version of the page you are viewing and the current version.</td>
</tr>
<tr>
<td>Restore this Version</td>
<td>Restore the page version you are viewing to be the current version.</td>
</tr>
<tr>
<td>View Page History</td>
<td>Return to the list of page versions.</td>
</tr>
<tr>
<td>&lt;&lt; Previous or Next &gt;&gt;</td>
<td>View the previous or next page version, respectively.</td>
</tr>
</tbody>
</table>

Viewing Changes in a Page History

The page history view and page information view allow you to view recent changes made to a page or to compare the differences between any two versions of a page.

Viewing Recent Changes

To view recent changes made to a page:

1. Click view change at the top of the page below the page title. The page comparison view is displayed, showing the differences between the current version and the previous version.

Or:

2. Choose Tools > Info to go to the 'Information' view for the page.

3. In the section titled 'Recent Changes' you will see the most recent versions of the page, along with the date of their modification and the name of the modifying author.

4. Click view changes beside the desired version. The page comparison view is displayed, showing the differences between the selected and previous versions.

Comparing Two Different Versions of a Page

To compare two different versions of a page:

1. Go to the page and choose Tools > Page History.

2. Select the versions you want to compare by selecting the check boxes beside them.

3. Click Compare selected versions. The page comparison view is displayed, showing the text differences between the selected versions.
**Page Comparison View**

The page comparison view shows the differences between selected page versions.

**Key**

On the page comparison view, the following key indicates the differences between the selected page versions:

<table>
<thead>
<tr>
<th>Highlight</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Added content</td>
</tr>
<tr>
<td>Red</td>
<td>Deleted content</td>
</tr>
<tr>
<td>Blue</td>
<td>Changed formatting</td>
</tr>
</tbody>
</table>

**Screenshot: Comparing Changes**

<table>
<thead>
<tr>
<th>Versions Compared</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>![111](Edwin Davson) Aug 16, 2011</td>
<td>This line was added.</td>
</tr>
<tr>
<td>![122](Paul Watson) Aug 19, 2011</td>
<td>This line was removed.</td>
</tr>
<tr>
<td></td>
<td>Formatting was changed.</td>
</tr>
</tbody>
</table>

**Interactive views**

When a page comparison view is first displayed, all large sections of unchanged text are hidden and reduced to an ellipsis . . .

You can view page changes between versions which are adjacent to your current page comparison view. Click the link containing:

- << to view the page comparison with the earlier adjacent version
- >> to view the page comparison with the more recent adjacent version.

For example, if your page comparison view is between v. 30 and v. 34 of a page, you can view changes between:

- v. 29 and v. 30 by clicking << Changes from 29 to 30
- v. 34 and v. 35 by clicking Changes from 34 to 35 >>

**Other Page History View Features**

You can also use the page history view to:

- View an older version of a page
- Restore an older version of a page
- View change comments

**Related Topics**

Viewing Page Information
Working with Pages
Tracking Updates

Take me back to the Confluence User's Guide.

**Restoring an Older Version of a Page**

To restore an an older version of a page:

1. Go to the page and choose Tools > Page History.
2. Click Restore this version beside the version to restore.
3. Change the default comment if desired and click OK.

**Notes**

- All page history is retained. Restoring an older version creates a copy of that version. For example, in the screenshot below, if you
selected v.39 and clicked **Restore this version**, a copy of v.39 would be created. This copy would be v.42 and would become the current version.

- You can click a version number's link to view the contents of that page version.
- Select the check boxes of two different versions and click **Compare selected versions** to view the changes made between them.
- If you are viewing a specific page version, you can restore that version of the page by clicking **Restore this Version** on that page.
- To get back to the page history view, click **View Page History**.

**Screenshot: Restoring an Older Version of a Page**

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Changed By</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>CURRENT</td>
<td>Jul 07, 2009 11:33</td>
<td>Giles Gaskell [Atlassian Technical Writer]</td>
<td></td>
</tr>
<tr>
<td>v.40</td>
<td>Jun 18, 2007 11:08</td>
<td>Rosie Jameson [Atlassian Technical Writer]</td>
<td>Restore this version</td>
</tr>
</tbody>
</table>

**Related Topics**

- Page History and Page Comparison Views
- Working with Pages

Take me back to the **Confluence User's Guide**.

**Viewing an Older Version of a Page**

Confluence keeps a **history of all page changes**. You can see what any of the previous versions of the page looked like, as well as link to them.

There are two ways that you can view an older version of a page.

- **Using the 'View Change' link** — this allows you to quickly check the most recent change to a page and the most recent version of the page, prior to the current version.
- **Using the Page History** — this allows you to look for a specific version of the page.

**On this page:**

- Viewing an Older Version of a Page using the 'View Change' Link
- Viewing an Older Version of a Page using the Page History
- Related Topics

**Viewing an Older Version of a Page using the 'View Change' Link**

To view an older version of a page using the 'View Change' link:

1. Go to the page and click **view change** (displayed under the page title).
2. Click the **Version ##** link in the top left-hand box to show the page content of the previous version.

**Notes**

- If you want to view an earlier version of the page, click the < link at the top left.
- If you want to send this page version to someone, simply copy and paste the URL from your browser. The link will look something like this: [http://confluence.atlassian.com/pages/viewpage.action?pageId=12345](http://confluence.atlassian.com/pages/viewpage.action?pageId=12345).

**Viewing an Older Version of a Page using the Page History**

To view an older version of a page using the page history:

1. Go to the page and choose **Tools > Page History**. The 'Page History' view will open. Read more about viewing the page history on Page History and Page Comparison Views.
2. Click a version number’s link to view the contents of that page version. The following header will display across the top of the old version of the page:

   ![Alert: You are viewing an old version of this page. View the current version.](image)

   **Compare with Current | Restore this Version | View Page History**

   Version 11

When you are viewing a specific version of the page, the following functions are available:
### Function Description

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>current version</td>
<td>View the latest version of the page.</td>
</tr>
<tr>
<td>Compare with Current</td>
<td>Compare the differences between the version of the page you are viewing and the current version.</td>
</tr>
<tr>
<td>Restore this Version</td>
<td>Restore the page version you are viewing to be the current version.</td>
</tr>
<tr>
<td>View Page History</td>
<td>Return to the list of page versions.</td>
</tr>
<tr>
<td>&lt;&lt; Previous or Next &gt;&gt;</td>
<td>View the previous or next page version, respectively.</td>
</tr>
</tbody>
</table>

If you want to send this page version to someone, simply copy and paste the URL from your browser. The link will look something like this: http://confluence.atlassian.com/pages/viewpage.action?pageId=12345.

**Related Topics**

- Page History and Page Comparison Views
- Restoring an Older Version of a Page
- Recording Change Comments

### Using a WebDAV Client to Work with Pages

You can access Confluence content via a WebDAV client, such as 'My Network Places' in Microsoft Windows. Provided that you have permission, you will be able to read and write to spaces, pages and attachments in Confluence. You will be asked to log in and the standard Confluence content access permissions will apply to the equivalent content available through the WebDAV client.

Please refer to the page on configuring and setting up a WebDAV client.

### Working with Blog Posts

You can publish a blog post from any space in Confluence, provided you have permission. Blog posts may be announcements, journal entries, status reports or any other timely information.

You can view the blog posts for a space by choosing Browse > Blog. Confluence catalogues the blog posts chronologically and allows you to browse blog posts for the space by navigating a calendar.

Creating and editing a blog post is just as easy as creating and editing any other page in Confluence.

**What would you like to do?**

- View blog posts
- Add blog posts
- Edit blog posts
- Link to blog posts
- Delete blog posts

**Related Topics**

- Subscribing to RSS Feeds within Confluence
- Watching Changes
- Blog Posts Macro

Take me back to the Confluence User's Guide.

### Deleting Blog Posts

To delete blog posts, you require 'Remove Blog' permission which is assigned by a space administrator. See Space Permissions or contact a space administrator for more information.

**To delete a blog post:**

- Go to the blog post and choose Tools > Remove.

  The Remove option is only displayed if you have permission to remove this blog post.
Confluence 4.0 Documentation

Handy Hint

Deleted blog posts are stored in the trash and can be recovered by a space administrator.

Related Topics

Viewing Blog Posts
Adding Blog Posts
Editing Blog Posts
Linking to Blog Posts

Take me back to Confluence User's Guide

Editing Blog Posts

To edit a blog post, you require the 'Create Blog' permission which is assigned by a space administrator. See Space Permissions or contact a space administrator for more information.

To edit a blog post:

1. Navigate to the space that has the blog post and choose Browse > Blog. A list of the most recent blog posts within the space is presented. A calendar allows you to browse earlier blog posts.
2. Locate the blog post and click Edit.
3. Make changes to the blog post.
4. (optional) Add a comment, in the text box below the editing pane, to describe your changes.
5. Preview your changes if desired, and click Save.

Editing a blog post is similar to editing any other page in Confluence. However, there are a few things to keep in mind:

- You cannot change the date of an existing blog post. You can only backdate when adding a blog post.
- You cannot move a blog post to another space.
- A blog post has no parent.

Related Topics

Working with Blog Posts
Adding Blog Posts
Deleting Blog Posts
Blog Posts Macro

Take me back to Confluence User's Guide

Viewing Blog Posts

To view the blog posts within a space:

- Navigate to the desired space, and select Browse > Blog.

A list of the most recent blog posts within the space will be displayed, along with the date of each post and the name of its author. The blog posts for the month will be shown in a panel, next to the list of the most recent blog posts. The panel will also contain links to the previous and next month (e.g. 'April 2010'), which you can use to browse blog posts from different months.
In Confluence, content is organised into spaces. There are two types of space:

- **Global** spaces are areas on your site into which you can group content items (pages, attachments, news, etc) based on any subject or topic of your choice. For example, you may want separate areas on your site for each team or project within your organisation.
- **Personal** spaces belong to specific users. They can be kept private, or opened up so the whole world can view and edit them, just like global spaces. These spaces are listed in the People Directory. They are not listed on the 'All' tab on the dashboard.

### What is a Space?

A space is an area within Confluence, containing your wiki pages. You can think of each space as a sub-site, or mini-site, each with its own home page.

Each space:

- Has its own pages, blog posts, comments, RSS feeds and mail (mail applies to global spaces only).
- Has its own access control settings. You can set different levels of access for different spaces.
- Can be separately exported to PDF, HTML or XML.

There is no limit to the number of global spaces you can create in Confluence.

### Viewing the Spaces in a Confluence Site

Confluence displays a list of spaces in the following locations:

- The **dashboard** displays a list of all the spaces in the Confluence site that you have permission to see. You can make a space a favourite, or categorise the space, to get easy access to the content that is most relevant to you. See Customising your Personal Dashboard.
The space directory displays a list of all the global and personal spaces in the Confluence site that you have permission to see. You can choose to see all spaces, the spaces you have marked as favourite, or the spaces in a given space category. You can further restrict the number of spaces displayed, by entering a word or words in the Filter box. Confluence will display only the spaces that have the matching words in the space name or description. See Viewing All Confluence Spaces.

The people directory displays a list of all Confluence users, including those who have personal spaces. See Searching the People Directory.

Guidelines for Dividing Content into Spaces and Pages

To ensure maintainable and logical spaces, consider the following points when allocating your content to pages and spaces:

- Group the content by topic, subject, project or team.
- Evaluate permissions across the wiki content. If members require conflicting access, for example John must access content on topics A and B, while Jane must access content for topics B and C, then the topics should be separated into three spaces.

Useful notes about spaces and pages:

- Spaces cannot be nested. You cannot have parent and child spaces, but you can have parent and child pages within a space.
- Page permissions alone cannot keep the existence of a page secret. The page should be in a restricted space instead.
- Pages can be moved between spaces.
- You can group related spaces, using space categories.

Example – Favourite Spaces as Shown on the Dashboard

The screenshot below shows the area of the Confluence dashboard that displays the spaces that you have marked as favourite:

![Favourite Spaces](image)

Related Topics

- Setting up a New Global Space
- Setting up your Personal Space
- Viewing All Confluence Spaces
- Browsing a space
- Moving a Page
- Deleting a Space
- Viewing Space Activity
- Using Labels to Categorise Spaces
- Administering Spaces

Take me back to Confluence User's Guide

Viewing Space Activity

Note that the space activity information is disabled by default. See notes below.
If enabled, the space activity screen displays statistics on the activity in each space. These include:

- How many pages and blog posts have been viewed, added or updated over a given period.
- Which content is the most popular (most frequently viewed).
- Which content is the most active (most frequently edited).
- Which people are the most active contributors/editors of content.

To view the activity in a space:

1. Go to a page in the space and choose **Browse > Space Admin**.
2. Go to the **Activity** tab.

Confluence will show a graphic display of the number of pages and blog posts that have been viewed, added and edited, showing trends over a period of time. For example:

![Space Activity](image)

### Activity for week starting 31 December 2006

This graph shows how many times pages and blog posts have been viewed over the current time period.

**Screenshot 1: Number of viewed pages and blog posts in a week**

The top ten most popular and most active pages and/or blog posts will be listed, with a link to each.

### Most popular content (Views)

1. [Confluence Documentation Home](#) (2262)
2. [Set JAVA_HOME variable in Windows](#) (1180)
3. [Confluence Installation Guide](#) (687)
4. [Remote API Specification](#) (467)
5. [User Macros](#) (436)
6. [Installing Confluence Standalone](#) (385)
7. [JIRA Issues Macro](#) (370)
8. [Administrators Guide](#) (353)
9. [Dynamic Tasklist Macro](#) (335)
10. [Frequently Asked Questions](#) (320)

**Screenshot 2: Popular content**

### Notes
• The Confluence Usage Stats plugin, which provides the 'Space Activity' screen, is known to cause performance problems on large installations. This plugin is **disabled by default**. A status report on the progress of the performance issues with this plugin is available in this issue: USGTRK-15.

• Your Confluence system administrator can enable the plugin, but please be aware of the possible impact upon your site’s performance.

• The plugin is sometimes called ‘Confluence Usage Tracking’.

• If your Confluence site is clustered, the space activity information will not be available.

## Related Topics

- Browsing a space
- Viewing Space Details
- Page History and Page Comparison Views
- Watching Changes
- Finding Unused Spaces
- How Do I Get More Statistics From Confluence?
- Installing and Configuring Plugins
- Viewing Site Statistics

Take me back to Confluence User’s Guide

## Viewing All Confluence Spaces

A space is an area within Confluence, containing your wiki pages. You can think of each space as a sub-site, or mini-site, each with its own home page.

### Quick guide to viewing Confluence spaces

- The **dashboard** displays a list of all the spaces in the Confluence site that you have permission to see. You can make a space a favourite, or categorise the space, to get easy access to the content that is most relevant to you. See [Customising your Personal Dashboard](#).

- The **space directory** displays a list of all the global and personal spaces in the Confluence site that you have permission to see. You can choose to see all spaces, the spaces you have marked as favourite, or the spaces in a given space category. You can further restrict the number of spaces displayed, by entering a word or words in the **Filter** box. Confluence will display only the spaces that have the matching words in the space name or description. See [Viewing All Confluence Spaces](#).

- The **people directory** displays a list of all Confluence users, including those who have personal spaces. See [Searching the People Directory](#).

### On this page:

- Viewing Spaces on the Dashboard
- Viewing Spaces in the Space Directory
- Viewing Personal Spaces in the People Directory
- Notes
- Related Topics

## Viewing Spaces on the Dashboard

The Confluence dashboard displays a list of spaces that you have permission to view. Remember to log in, so that you can see the complete list of spaces based on your username’s permissions.

The **Spaces** tab displays all the global spaces on the site, and the spaces you have marked as your **favourites**, that you have permission to view.

### To see the spaces on the dashboard:

1. Click **Dashboard** at the top left of your Confluence screen.
2. Scroll down and click on the **Spaces** tab.

**Screenshot: Viewing spaces on the dashboard**
Viewing Spaces in the Space Directory

The space directory displays a list of global and personal spaces that you have permission to view. Remember to log in, so that you can see the complete list of spaces based on your username's permissions. The order of spaces is random.

Categorising the spaces: The spaces are displayed on a number of tabs, each showing a different sets of spaces, as follows:

- **All Spaces** — all the global and personal spaces on the site that you have permission to view.
- **Favourite Spaces** — the spaces that you have marked as your favourites.
- **Categories** — tabs showing spaces categorised by label. Note that you can add any space category you like. See Using Labels to Categorise Spaces.

Filtering the list of spaces: To restrict the number of spaces displayed, enter a word or words in the Filter box. Confluence will display only the spaces that have the matching words in the space name or description.

To see the spaces in the space directory:

2. Click one of the tabs to see the spaces you want.
3. If you want to restrict the number of spaces shown, entering a word or words in the Filter box.

Screenshot: Viewing favourite spaces in the space directory
Viewing Personal Spaces in the People Directory

The people directory displays a list of Confluence users, including those who have personal spaces. See Searching the People Directory.

To see the personal spaces in the people directory:

2. Click People with Personal Spaces.

**Screenshots:** The people directory

<table>
<thead>
<tr>
<th>Name</th>
<th>Email</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audra Eng</td>
<td><a href="mailto:aeng@atlassian.com">aeng@atlassian.com</a></td>
</tr>
<tr>
<td>Boots Wang</td>
<td><a href="mailto:boots@atlassian.com">boots@atlassian.com</a></td>
</tr>
<tr>
<td>Dylan Etkin</td>
<td><a href="mailto:dylan@atlassian.com">dylan@atlassian.com</a></td>
</tr>
<tr>
<td>Edoardo Causarano</td>
<td><a href="mailto:ecausarano@atlassian.com">ecausarano@atlassian.com</a></td>
</tr>
<tr>
<td>Edwin Dawson</td>
<td><a href="mailto:edw@atlassian.com">edw@atlassian.com</a></td>
</tr>
<tr>
<td>Edwin Wong</td>
<td><a href="mailto:ewong@atlassian.com">ewong@atlassian.com</a></td>
</tr>
</tbody>
</table>

**Notes**

- If you do not log in, you will be treated as an ‘anonymous user’. Confluence will display only those spaces that an anonymous user has permission to access.
- Permission to access a space is granted by a space administrator. See the overview of space permissions.
- You can use the Spaces List macro to display a list of spaces on a Confluence page.

**Related Topics**
Administrating Spaces

This page gives an overview of the administration functions available in global and personal spaces. Note that you need to be a space administrator to perform space administration functions.

On this page:
- Administering a Global Space
- Administering a Personal Space
- Related Topics

Administering a Global Space

To view the space administration menu:

1. Choose Browse > Space Admin.
   - Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. All the options related to the management of a space are listed in the left-hand panel. Click a link to take you to the corresponding screen.

For global spaces, the options available are divided the following categories:

- **Space Operations**
  - Space Details – See Editing Space Details.
  - Space Labels – See Using Labels to Categorise Spaces.
  - Remove Space – See Deleting a Space.
  - Trash – See Purging Deleted Pages and Restoring a Deleted Page.
- **Security**
  - Permissions – See Viewing Space Permissions and Assigning Space Permissions.
  - Restricted Pages – See Viewing Restricted Pages.
- **Mail**
  - Mail Accounts – See Archiving Mail Overview.
  - Mailbox Import – See Importing Mail.
- **Look and Feel**
  - Themes – See Applying a Theme to a Space.
  - Colour Scheme – See Editing a Space's Colour Scheme.
  - Layout – See Customising Layouts for a Space.
  - Stylesheet – See Styling Confluence with CSS.
  - PDF Layout – See Editing the PDF Stylesheet.
  - PDF Stylesheet – See Editing the PDF Stylesheet.
  - Change Space Logo – See Changing a Space's Logo.
- **Import**
  - Import Pages from Disk – See Importing Pages from Disk.

Administering a Personal Space

To view the space administration menu:

1. Choose Browse > Space Admin.
   - Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. All the options related to the management of a space are listed in the left-hand panel. Click a link to take you to the corresponding screen.

For personal spaces, the options are divided into the following categories:

- **Space Operations**
  - Space Details – See Editing Space Details.
  - Space Labels – See Using Labels to Categorise Spaces.
  - Remove Space – See Deleting a Space.
  - Trash – See Purging Deleted Pages and Restoring a Deleted Page.
- **Security**
  - View or set space permissions
  - View restricted pages
- **Look and Feel**
  - Themes – See Applying a Theme to a Space.
  - Colour Scheme – See Editing a Space's Colour Scheme.
  - Layout – See Customising Layouts for a Space.
  - Stylesheet – See Styling Confluence with CSS.
1. **PDF Layout** – See [Editing the PDF Stylesheet](#).
2. **PDF Stylesheet** – See [Editing the PDF Stylesheet](#).

**Related Topics**

- Browsing a space
- Working with Spaces

Take me back to [Confluence User's Guide](#)

## Deleting a Space

Deleting a space permanently removes the space and all of its contents.

**Warning**

Use caution while deleting a space, and always create an XML Space Backup before proceeding. Once deleted, there is no way to restore a space unless you have made an XML Space Backup.

You need to be a space administrator to delete a space.

**To delete a space:**

1. Choose **Browse > Space Admin**.
   - **Space Admin** is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. Click **Remove Space** in the left panel under the heading ‘Space Operations’.
3. Click **OK** to confirm.

**Related Links**

- Working with spaces
- Setting up a New Global Space
- Viewing All Confluence Spaces
- Browsing a space
- Moving a Page
- Copying or Renaming a Space

Take me back to [Confluence User's Guide](#)

## Setting up a New Global Space

To set up a new global space, you require the 'Create Space' permission. 'Create Space' is one of the global permissions that can be assigned by a Confluence administrator. See [Security](#) or contact a Confluence administrator for more information.

**To create a new global space:**

1. Click **Add Space** located above the list of global spaces on the Dashboard. The 'Create Space' screen appears, as shown below.
2. Enter the following information about your new space:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space Name</td>
<td>A name for the space. Space names do not have to be unique.</td>
</tr>
<tr>
<td>Space Key</td>
<td>A simple key to identify your space (A-Z, a-z, 0-9). This key is a shorthand name for the space, used when linking content between spaces, for web URLs and for reports. For example, a 'Development Space' might have a space key of 'DEV'. The space key must be unique within the entire Confluence site.</td>
</tr>
<tr>
<td>Permissions</td>
<td>Choose who can view or contribute content to this space. A space administrator can change the permissions at any time after creating the space.</td>
</tr>
<tr>
<td>Theme</td>
<td>The look and feel for your space. A space administrator can change the theme later.</td>
</tr>
</tbody>
</table>

3. Click **OK**. The 'Home' page for your new space is displayed. Note that the home page will automatically contain any default space content as defined by your Confluence administrator.
4. Click **OK**.

Next, you can start adding pages to your space.
Confluence 4.0 Documentation

Screenshot: Creating a space

Create Space

Content in Confluence is organised into spaces.
A space is where your pages live, where your blog is posted, and where your mail is archived. Permissions determine who can view or contribute to the content of a space.
There is no limit to how many spaces you can create.

Enter a space name

Enter a space key

A space’s key is a short version of its name, used to link to it quickly. It must be unique globally.
Example: A Development Space might have a key of DEV.

Who can use this space?

You can customize these permissions once the space is created.

Choose who can view and comment on content:  
- Me
- Registered users - anyone logged into Confluence

Choose who can contribute (create and edit) content:
- Me
- Registered users - anyone logged into Confluence

Choose Theme

To change the theme of this space, select one below.

- Global Look and Feel
  The globally configured look and feel. You can customise colour-schemes and layouts manually.

- Documentation Theme
  This theme is well suited for structured content, such as documentation. It features a table of contents (page tree) on the left, making it easier to see the structure of a space and move from page to page. You can customise the left-hand panel, page header and page footer.

- Easy Reader Theme
  This is a fixed-width variation of the default Confluence theme. Its larger fonts, smooth gradient background and comfortable line length make it ideal for displaying and reading longer documents.

OK  Cancel

Related Topics

Working with Spaces
Setting up your Personal Space
Viewing Space Details
Editing Space Details
Browsing a space
Deleting a Space

Take me back to the Confluence User’s Guide.

Setting up your Personal Space

Your personal space is a place where you can publish your own pages and blog posts. Once you have set up your personal space, Confluence users can reach it by clicking your name in the People Directory.
Creating your personal space

To set up your personal space, you require the 'Personal Space' permission which is assigned by a Confluence administrator from the Administration Console. Refer to the Permissions Overview and Global Permissions Overview topics or contact a Confluence administrator for more information.

To create your personal space:

1. Go to your name at the top of the page. (This is the 'user' menu.)
2. Select Create Personal Space from the dropdown list. The 'Create Personal Space' view will open.
3. Enter a few details about your space:
   - Choose who can view content.
   - Choose who can contribute (create and edit) content.
   - Choose the Theme (look and feel) for your personal space.
Create Personal Space

Your personal space is your own private workspace within Confluence. You can optionally let other people view or contribute to it.

Who can contribute to your personal space?
You can customize these permissions once the space is created.

Choose who can view and comment on content:  
- Me
- Registered users - anyone logged into Confluence

Choose who can contribute (create and edit) content:  
- Me
- Registered users - anyone logged into Confluence

Choose Theme
To change the theme of this space, select one below.

- Default Theme
  Use the globally configured look and feel. You can customise colour schemes and layouts manually.

- Clickr Theme

- Modern Confluence Theme
  The Confluence default theme with a more modern feel. This theme requires Firefox 3, Internet Explorer 7+ and Safari 4.

- Left Navigation Theme
  Provides a navigation bar on the left hand side of the screen.

Where is my personal space?
Once created, your personal space will be accesible (to anyone who can view it) at:
BootstrapManager:domainName/display/-fredder

4. Click Create.
5. The 'Home' page for your new space is displayed.
   Note: Your home page will automatically contain any default space content as defined by your Confluence administrator.

Adding and changing content in your space
Now you can start adding pages to your personal space. You may also want to upload your photo.

Changing the colour scheme of Your Space
If you like, you can modify the colour scheme for your personal space.

Granting access to your space
When you created the space (see above), you made some preliminary decisions about who can view and contribute content to your space. You can change the permissions on your space at any time.

Notes
- Once you have set up your personal space, you can return to it any time by clicking on your name (at the top of the page) and choosing Personal Space.
Exporting Confluence Pages and Spaces to Other Formats

You can convert a part of, or the entire contents of a space to various formats, including Microsoft Word, HTML, PDF and XML. This is called 'exporting' the space.

What would you like to do?

- Exporting Confluence Pages and Spaces to HTML
- Exporting Confluence Pages and Spaces to PDF
- Exporting to a Word document
- Exporting Confluence Pages and Spaces to XML

Exporting Confluence Pages and Spaces to HTML

Confluence allows you to export part of, or the entire contents of, a space into a zipped archive of HTML files. This is useful if you want convert your space into a static website.

To use the space export functionality, you need 'Export Space' permission. See the guide to space permissions or contact a space administrator for more information.

To export pages to HTML:

1. Go to a page in the space and choose Browse > Advanced.
2. Click HTML Export in the left-hand panel.
   This option will only be visible if you have 'Export Space' permission.
3. Select the Include Comments check box if you want to include comments for the pages you are exporting.
4. Select the pages you want to export by selecting the check boxes in the tree view of pages displayed. By default, all pages are selected. You have the option to Select All or Deselect All pages.
   If you select the check box of a page that contains one or more child or descendant pages, all of these child and descendant pages will also be selected. Similarly, if you clear the check box of such a page, all of its child and descendant pages will also be cleared.
   This provides a convenient method of exporting subtrees, for example, chapters or sections within a document.
5. Click Export. This will create a zipped archive of HTML files.
6. When the export process has finished, download the zipped archive as prompted and extract the files into a folder.

Screenshot: Selecting pages to export
Notes

- Page attachments are placed in individual folders with names in the following format:
  
  \download\attachments\xxxxxx

  where 'xxxxxx' is the page ID of the page containing the attachments.

- By default, the 'Space Details' page is exported as index.html and displays the space's details as well as a list of all available pages within it.

- Blog posts are not included in the HTML export. See the feature request: CONF-14684.

Related Topics

Exporting Confluence Pages and Spaces to PDF
Exporting Confluence Pages and Spaces to XML

Take me back to the Confluence User's Guide.

Exporting Confluence Pages and Spaces to PDF

This page explains how you can export individual Confluence pages, entire spaces or selections of pages into a single PDF file.

On this page:

- Exporting Single Pages
- Exporting Multiple Pages or the Entire Space
- Customising the Appearance of PDF Exports
- Notes
- Related Topics

Exporting Single Pages

You can export a Confluence page to PDF. This option exports a single page and is available to all users who have permission to view the page:

- Go to a page in the space and choose Tools > Export to PDF. Follow the prompts to export the page.

Exporting Multiple Pages or the Entire Space

Using Confluence's space export functionality, you can convert multiple pages or an entire space to PDF.

To use the space export functionality, you need 'Export Space' permission. See the guide to space permissions or contact a space administrator for more information.
To export a space or selected pages to PDF:

1. Go to a page in the space and choose **Browse > Advanced**.
2. Click **PDF Export** in the left-hand panel. This option will only be visible if you have the ‘Export Space’ permission.
3. Select the pages you want to export:
   - You have the option to **Select All** or **Deselect All** pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
4. Click **Export**.
5. When the export process has finished, download and save the PDF file as prompted.

---

**Customising the Appearance of PDF Exports**

You can add a title page, a table of contents and customised headers and footers to the PDF output. For more advanced customisations, you can apply Cascading Style Sheet (CSS) modifications. These customisations are specific to each space. You need the ‘Space Administrator’ permission to be able to apply these customisations. For more information, see **Editing the PDF Stylesheet**.

**Notes**

- Only image attachments that have been inserted into a page are included when exporting to PDF.
- To export a PDF containing international text, you need to **install a Unicode font** in Confluence.
- Blog posts are not included within the PDF export. If you like, you can vote for this feature request: CONF-5599.
- If you have ‘Space Administrator’ permissions, the link to customise the PDF Stylesheet is provided at the top of the page tree, as shown in the screenshot above.
- Confluence’s PDF Export feature is designed to handle a wide variety of content. However, on rare occasions the PDF Export process may fail due to an unrecognised customisation. If that happens the PDF export screen will indicate the title of the page in which the problem occurred, to help you diagnose the cause of the failure.

**Related Topics**

- Editing the PDF Stylesheet
- Creating PDF in Another Language
- Exporting Confluence Pages and Spaces to HTML
- Exporting Confluence Pages and Spaces to XML

**Take me back to the Confluence User’s Guide.**

**Editing the PDF Stylesheet**

Confluence administrators and space administrators can customise the PDF exports for individual spaces. Possible customisations include:
Before You Start

Please take note of the following points:

- Most PDF customisations use a combination of HTML and CSS (Cascading Style Sheets). You need to be comfortable with these technologies before applying any customisations.
- PDF customisations are unique to each space.
- There are two aspects that control Confluence custom PDF exports. You will need to modify each of these to ensure that your PDF exports are customised to your requirements:
  - The PDF Layout defines the title page, headers and footers.
  - The PDF Stylesheet defines the page size and margins, font, colour, list numbering, and all other style customisations.

Customising the PDF Layout

You can add your own HTML to customise the title page, page headers and page footers in the PDF output.

To customise the PDF layout:

1. Choose Browse > Space Admin.
   - Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click PDF Layout in the 'Look and Feel' section of the left-hand panel.
3. Click Edit. You can now customise the HTML that generates following areas in the exported PDF document:
   - PDF Space Export Title Page – title page.
   - PDF Space Export Header – page headers.
   - PDF Space Export Footer – page footers.
4. Enter your customisations into each text box as required. The PDF layout section accepts HTML code. You can include inline CSS in the HTML too.
5. Click Save.

Customising the PDF Stylesheet

You can adjust the appearance of the PDF pages by editing the CSS stylesheet.

To customise the PDF Stylesheet:

1. Choose Browse > Space Admin.
   - Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click PDF Stylesheet in the left-hand panel. The 'PDF Export Stylesheet' section appears, showing the current contents of your PDF stylesheet. It contains all CSS rule customisations applied to the pages in the space.
3. Click the Edit.
4. Enter your customisations into the text box as required. The PDF stylesheet section accepts Cascading Style Sheets (CSS) rules.
5. Click Save.

Default CSS Settings

- If no PDF customisations are defined on the PDF stylesheet screen, the default CSS rules will be applied to your PDF exports. By default, the export does not include a title page, headers or footers.
- To get started, you can download the default CSS rules of the PDF stylesheet: confluencedefaultpdf.css. Any rule defined in this file can be customised and added to the 'PDF Export Stylesheet' section.
- You can also make further CSS customisations as required. This means you can override any default CSS rule by redefining it in the 'PDF Export Stylesheet' section with your own customisations.

PDF Export Methods

There are two PDF export methods (see Exporting Confluence Pages and Spaces to PDF):
- Exporting a single page via the 'Tools' menu on the page or blog post. Only the PDF stylesheet customisations apply to single page exports.
- Exporting one or more pages via the space export function. When exporting a space, all your customisations apply, including both the PDF stylesheet and the PDF layout.

To make your PDF layout customisations apply to a single page exported to PDF, either:

- use the 'space export' method to export that single page only, or
- if your header and footer customisations contain only text, follow the appropriate customisations provided in the advanced PDF stylesheet customisations.

Examples of Basic Customisations

This section provides examples of typical customisations that you can add to your PDF stylesheet. Once you are familiar these basic customisations, you may wish to try some advanced customisations.

Page Customisations

Modifications to page and margin sizes are made in the @page CSS rule. To make changes to this rule, implement the following type of code in the PDF stylesheet.

```css
@page {
  /*Page specific styles (that is, customisations of properties) go here*/
}
```

Customising the Page Size

The default page size is based on the locale of your Confluence server. For example, if this server is located in the US then the default paper size of your PDF export will be US Letter size (8.5 inches wide by 11 inches long). If the server is located in Australia, the default paper size will be A4 (210 mm wide by 297 mm high).

To modify the page size to A4, add a `size` property to the top of the rule like this:

```css
@page {
  size: 210mm 297mm;
}
```

More information about paper sizes can be found on Wikipedia.

Customising the Page Margins

To add a margin of 15 mm to a paper size of A4, your CSS @page rule would look like this:

```css
@page {
  size: 210mm 297mm;
  margin: 15mm;
}
```

Splitting Confluence Pages

By default, short Confluence pages will be grouped together if they can fit into a single PDF page. If you want each of the Confluence pages to remain as an individual PDF page you can use the code below:

```css
.pagetitle {
  page-break-before: always;
}
```

Customising the Table of Contents

By default, a table of contents will be generated after the title page, or at the beginning of the document if no title page is defined in the PDF
To make changes to the look and layout of the table of contents, define the appropriate CSS rules in the **PDF stylesheet**.

For details about the default CSS rules applied to the table of contents, download the default CSS rules (from the link above) and examine the specific rules with `toc` in their name.

### Disabling the Table of Contents

To prevent the table of contents from being generated in your PDF document, add the `div.toc` rule to the PDF stylesheet and set its `display` property to `none`:

```css
div.toc
{
    display: none;
}
```

### Changing the Leader Character in the Table of Contents

The leader character is used to link the name of a heading in the table of contents with its page number. The page number is usually aligned to the right-hand margin of the page. By default, the leader character is the '.' (dot) character. You can change it by customising the leader character CSS rule `span.toclead:before` and adding this to the PDF stylesheet.

To change the leader character to a solid line, modify the CSS rule to the following:

```css
span.toclead:before
{
    content: leader(solid);
}
```

To change the leader character to spaces, modify the CSS rule to:

```css
span.toclead:before
{
    content: leader(space);
}
```

(For aware that using a space as a leader character can make the table of contents difficult to read.)

### Wrapping Long Words

In order to break long words or words that are not separated by whitespace, add a selector to the PDF stylesheet containing the `word-wrap` property with a value of `break-word`:

```css
div
{
    word-wrap: break-word;
}
```

### Adding a Title Page

You can create a title or cover page to your PDF document using HTML. Use the **PDF Space Export Title Page** section of the PDF layout to do this. Adding a New Title Page

The following example uses HTML with an inline CSS rule to generate a title page.

```html

```

Including Content Above Table of Contents in Default Title Page

The following example includes content above the automatically-generated table of contents that appears on the default title page, so that your title page includes your own content plus the table of contents.

Adding an Image to your Title Page

In the examples above, the title page includes an image called `titlepage.png`, centred in the middle of the page. The image is attached to a
Confluence page and is referenced via its relative URL (that is, we use only the last part of the URL, excluding the Confluence site's base URL).

Follow these instructions to include an image on your title page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page.
3. Right-click the image and copy its location.
4. Paste the link into the appropriate `<src>` attribute within your PDF stylesheet, as shown above.
5. Remove the first part of the URL before `/download/`.

**Adding Headers and Footers**

You can add headers and footers to your PDF pages using HTML. Use the ‘PDF Space Export Header’ and ‘PDF Space Export Footer’ sections of the PDF layout to do this. For simple headers and footers, plain text is enough. The following example adds a simple copyright notice.

**Adding Page Numbering to a Header or Footer**

To add page numbering to your documentation, you need to combine some customised HTML in the header or footer with some customised CSS in the PDF stylesheet.

1. Create a header or footer with an empty `<span>` element and give it a unique ID, for example `pageNum`. This is a place holder for the page number in your PDF document.

2. Create the following CSS selector rule for the empty `<span>` and add it to the PDF stylesheet:

   ```css
   .pageNum { /* CSS rules */ }
   ```

   Analysing the above CSS selector rule in more detail:
   
   - The `#pageNum` rule selects the HTML element with the specified ID of "pageNum", which is the `<span>` element we created for the header or footer.
   - The `:before` part of the selector is a pseudo class that allows the insertion of content before the `<span>` element is processed.
   - The `counter(page)` is a function that returns the current page number as its content.
   - The `content` property tells the CSS processor that dynamic content (that is, an incrementing page number) is to be inserted before the `<span>` tag.

**General Formatting**

You can use the stylesheet to customise the output of just about anything else that will influence the look and feel of the final document. This includes fonts, tables, line spacing, macros, etc. The export engine works directly from the HTML output produced by Confluence. Therefore, the first step in customising something is to find a selector for the HTML element produced by Confluence or the Confluence macro. Then add a CSS rule to the PDF stylesheet. Your customisation will appear in the PDF export.

**Notes**

- **Demotion of heading elements:** `<h1>`, `<h2>`, and so on. Due to the hierarchical manner in which a space is exported, Confluence will modify the heading elements to generate a uniform appearance for the entire space export. This means that headings will be demoted. This will affect the application of custom PDF Stylesheets. It is possible to calculate the amount by which a heading will be demoted in order to have the correct CSS styling applied. A heading will be demoted by the value of its depth in the export tree. A page at the first level will be demoted by 1 (all `<h1>` elements will become `<h2>` elements, and so on). A page at the second level will be demoted by 2, and so on.

- **Atlassian support for PDF customisation is limited.** We support the mechanism for customising the PDF layout with HTML and CSS, and we will help if the mechanism is broken or does not work as we say it should in our published examples. But, since custom HTML and CSS offer potentially limitless possibilities, Atlassian will not support issues that are caused by or related to PDF customisations.

**Related Topics**

- Advanced PDF Stylesheet Customisations

**Advanced PDF Stylesheet Customisations**

This topic provides information and details on popular PDF stylesheet customisations. These expand upon the basic customisations described in Editing the PDF Stylesheet.

⚠️ The information below is for advanced users. Customisations are not supported by Atlassian. Be aware that the advanced customisations described below require knowledge of certain parts of Confluence, and of CSS and HTML. This documentation is intended for advanced users. Some of the suggestions below are moderately complex. If you are having trouble understanding them we strongly suggest you ask an expert. We do not support any of the customisations described below. This means that the Atlassian support engineers will not be able to help you with these modifications, because even for them this kind of configuration can be tricky.
Page Customisations

Modifications to page and margin properties are made in the `@page` Cascading Style Sheet (CSS) rule. As described in Editing the PDF Stylesheet, all CSS rule customisations are implemented in the space's PDF stylesheet.

Changing the Page Orientation to Landscape or Portrait

To change the page orientation of your PDF document, reverse the order of the values declared in the `@page` rule's `size` property. The first and second values of this property represent the width and height of the page, respectively.

For example, to generate PDF space exports in A4-sized landscape orientation, your `@page` rule might look like this:

```css
@page
{
/*A4-sized pages in landscape orientation are 297 mm wide by 210 mm high*/
size: 297mm 210mm;
}
```

Customising Page Margins Separately

To set the margins of each side of a page independently of the other, you can declare each margin size in the `@page` rule using the following properties:

<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>margin-top</td>
<td>Margin height at the top of the page.</td>
</tr>
<tr>
<td>margin-bottom</td>
<td>Margin height at the bottom of the page.</td>
</tr>
<tr>
<td>margin-left</td>
<td>Margin width on the left of the page.</td>
</tr>
<tr>
<td>margin-right</td>
<td>Margin width on the right of the page.</td>
</tr>
</tbody>
</table>

For example, to generate PDF space exports with top and bottom margins of 1 inch and left and right margins of half an inch, your `@page` rule might look like this:

```css
@page
{
margin-top: 2.54cm;
margin-bottom: 2.54cm;
margin-left: 1.27cm;
margin-right: 1.27cm;
}
```

Page Header and Footer Customisations

Adding Headers and Footers to Single Page Exports

As mentioned in Editing the PDF Stylesheet, custom headers and footers by default, only apply to space export and not to exports of single pages. However, it is possible to add CSS rules to your PDF export stylesheet that allow custom headers and footers to appear in single
page exports.

For custom headers, define `@top-left`, `@top-center` and `@top-right` rules within your `@page` rule. These rules apply respectively to content that appears on the left-hand side, centre and right-hand side of your page's header area.

For custom footers, define `@bottom-left`, `@bottom-center` and `@bottom-right` rules within your `@page` rule.

Add the following rules to add a document title at the centre of the header and a page number at the centre of the footer:

```css
@page
/* Any page-specific properties */
{
    @top-center
    {
        content: "Document Title Goes Here";
        font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
        font-size: 8pt;
    }
    @bottom-center
    {
        content: "Page " counter(page);
        font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
        font-size: 8pt;
    }
    /* Any other page-specific rules */
}
```

Notes:
- The `font-family` and `font-size` properties ensure that the header and footer text is rendered in the same default font style used for the body text, based on the default CSS rules.
- It is not possible to use this method to insert images (stored as attachments within your Confluence instance) into the headers and footers of single page exports.

Adding Images to Headers and Footers

To insert an image into a header or footer, edit the header and footer sections of the PDF layout and use an HTML `img` element with `src` attribute. The `src` attribute refers to an image attached to a Confluence page. The image element is usually placed within a `div` element container.

For example, to add an image to the left of the header:

```html
<div style="margin-top:10mm">
    <img src="/download/attachments/12346/header-image.png"/>
</div>
```

In the example above, the header includes an image called 'header-image.png'. The image is attached to a Confluence page and is referenced via its relative URL (that is, we use only the last part of the URL, excluding the Confluence site's base URL).

Follow these instructions to include an image on your PDF title page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page.
3. Right-click the image and copy its location.
4. Paste the link into the appropriate `src=""` attribute within your PDF stylesheet, as shown above.
5. Remove the first part of the URL before the `/download/...` part.

To add an image to a footer, add similar HTML code consisting of an `img` element and `src` attribute. Incorporate the inline CSS property `margin-bottom` to separate the image from the bottom of the page if necessary.

Notes:
- This code uses an inline CSS property in the `style` attribute to set formatting properties specific to this header image.
- The `margin-top:10mm` property forces the image away from the top of the page by 10mm. This comes in handy when your header image is large enough to touch or spill over the top of the page.
- Likewise, for footers, you can use the `margin-bottom:XXmm` property to force an image away from the bottom of the page by `XX` mm.
- Very large images can spill over into the body of a page or alter the position of text or other elements used within a header or footer. In such situations, it is recommended that you reduce the size of the image and then upload it to your Confluence site again. If you prefer to keep the image size and want to move the content lower instead, you can do so by configuring the `margin-top` properties in the `@page` CSS rule.
- By default, a header or footer image is aligned to the left-hand side of the page. However, you can align this image to the centre or right-hand side of a page by adding either the `text-align:center` or `text-align:right` properties to your `style` attribute.
For example, to align the header image to the right-hand side of the page, your style attribute would look similar to this:

```
style="margin-top:10mm; text-align:right".
```

### Page Selector Rules for Left- and Right-Hand Pages

If your PDF exports are destined for double-sided printed media (for example, books), you can define different customisations for left- or right-hand pages.

To do this, define two CSS pseudo-class page selectors as separate rules within the PDF stylesheet.

- Use the `:left` pseudo-class with the @page CSS rule to define customisations for left-hand pages.
- Use the `:right` pseudo-class with @page to define customisations for right-hand pages.

You can use these page selector CSS rules in your PDF stylesheet to define alternating left and right margins to allow room for binding a double-sided document. For example:

```
@page :left {
  margin-left: 3cm;
  margin-right: 1.27cm;
  /* Any other left-hand page-specific properties and rules */
}

@page :right {
  margin-left: 1.27cm;
  margin-right: 3cm;
  /* Any other right-hand page-specific properties and rules */
}
```

### Incorporating Other Fonts

Out of the box, Confluence provides Times New Roman, Helvetica or Courier fonts for use in PDF exports. You can incorporate your own fonts for use in PDF exports by declaring them within a @font-face CSS rule within your PDF export stylesheet.

The following CSS rule example shows how to embed the Consolas font into your PDF export:

```
@font-face {
  src: url(file:///usr/share/fonts/Consolas.ttf);
  -fs-pdf-font-embed: embed;
}

.code pre, .preformatted pre, tt, kbd, code, samp {
  font-family: Consolas, monospace;
  font-size: 9pt;
}
```

The font path specified in the CSS must be the path to the font on the Confluence server.

### Hiding Text from the PDF Output

This section describes a way to hide text from your PDF export. In other words, you can have text on the Confluence page that will not appear in the PDF export.

There are two stages:

1. Follow the instructions to define the NoPrint user macro.
2. Add the following CSS to your PDF stylesheet to make the PDF export recognise the NoPrint macro:

```
.noprint {
  display: none;
}
```

### Notes

If styling is not working as expected, it is useful to look at the HTML source to which the CSS is applied. Whenever you create an HTML export that contains multiple pages, the intermediary HTML is stored in the temp directory in Confluence’s home directory. For example:
Creating PDF in Another Language

To export a Confluence page written in a language other than English, you need to install the necessary font for that language. This means that you need to upload the font file to Confluence, as described below.

Uploading a Font File to Confluence

1. Find the appropriate font file:
   - **Windows users:** All font files in Windows are stored in a directory called:
     ```
     C:\WINDOWS\Fonts
     ```
   - **Unix users:** All font files in Unix are stored in:
     ```
     /usr/share/fonts
     ```

   - Microsoft True Type core fonts such as Verdana can be downloaded from this page: [http://corefonts.sourceforge.net/](http://corefonts.sourceforge.net/)

2. Copy the font file into a temporary folder, for example a folder on your desktop.
3. Go to the ‘PDF Export Language Support’ screen in the Confluence Administration Console and upload the file you copied in step 2.
4. Click Install.

Notes

- The only font files supported are true type fonts and true type collections. The accepted file extensions are *.ttf and *.ttc.
- We recommend that you use Unicode font Verdana for correct character encoding and exporting to PDF.

Related Topics

Exporting Confluence Pages and Spaces to PDF

Exporting to a Word document

Confluence allows you to export a single page into a Word document. This is extremely useful for emailing around content to non-Confluence users, printing a document or just creating a backup in Word.

You will require ‘Export Pages’ permission to export a page to a Word document.

To export to a Word document:

1. Go to the ‘Export to Word’ option for the page. To do this:
   - Go to a page in the space and choose **Tools > Export to Word**. You will be prompted by a series of dialog boxes.
2. By default, this will create a Word document with the same name as the Confluence page.

Exporting Confluence Pages and Spaces to XML

Confluence allows you to export a part of, or the entire contents of, a space into a zipped archive of XML files. This is useful if you want to make a backup of the space, export the space to another Confluence instance, or use the data from the space in another application. Please note that there are a few restrictions when restoring a Space, and that huge spaces exported for backup purposes may benefit from other means of backup. See **Production Backup Strategy**.

To export to XML, you will need ‘Export Space’ permission which is assigned by a space administrator. See **Space Permissions** or contact a space administrator for more information.

Site administrators can import a space from a zipped XML archive.

To export to XML:

1. Go to a page in the space and choose **Browse > Advanced**.
2. Click **XML Export** in the left-hand panel.
This option will only be visible if you have 'Export Space' permission.

3. Select Include Comments if you want to include comments made on the pages you are exporting.

4. Select Backup Attachments if you want include the images and other files attached to the pages.

5. Select the pages you want to export. Select the relevant check boxes in the tree view of pages displayed. By default, all the pages are selected. If you select a page that has one or more child or descendant pages, all of these child and descendant pages will also be selected. Similarly, if you clear the check box of such a page, all of its child and descendant pages will also be cleared. This provides a convenient method of exporting subtrees, for example, chapters or sections within a document.

6. Click Export. This will create a zipped archive of XML files.

**Screenshot: Exporting a space with administrator permissions**

- **Pages to export:**
  - All (includes pages not visible to you)
  - Visible to you

**Select All | Deselect All | Include comments | Include attachments**

- **Inclusions Library**
  - OAuth Consumer Definition
  - OAuth Definition
  - OAuth Provider Definition

- **bookmarks**
  - Google Provisioning API Developer's Guide
  - Google Apps APIs - Google Code

- **Home**
  - Documentation guidelines
  - How to update documentation
  - Disclaimer for Beta documentation
  - Exporting and uploading PDF, HTML and XML versions of the docs
  - Bookmarklet to toggle checkboxes on Confluence space export

**Notes**

- If you are running Confluence behind Apache HTTP Server and are facing timeout errors, please consider creating the export directly from Tomcat, instead of going through Apache. This will speed up the process and prevent timeouts.

- If you have Space Administrator or Confluence Administrator permissions, you can export either All pages or those pages Visible to you. All exports all content in the space, including pages that are protected by page-level restrictions which will prevent you from viewing the pages themselves. This option is available only to space administrators and Confluence administrators. It allows you to make a complete and comprehensive export of a space for backup purposes. Visible to you exports only content you can see. This is the default option.

**Related Topics**

- Browsing a space
- Restoring a Space
- Exporting Confluence Pages and Spaces to PDF
- Exporting Confluence Pages and Spaces to XML

**Browsing a space**

The Browse Space view gives you access to:

- Space-wide views of the content of the space — pages, news, labels, attachments, bookmarks and mail.
- Summary information about the space.
- Advanced space management tools.
- Tools to administer the space (for space administrators only).

The components of the Browse Space view are organised into a number of blue tabs.

Go to a page in the space and choose Browse > Space Admin.

**Screenshot: Browsing a space — 'Advanced' tab**
The tabs that are displayed will depend on your Confluence site configuration, the type of space you are viewing and the space permissions granted to you for the space.

**Pages**
- View pages alphabetically
- View recently updated content
  - More about Working with pages

**Labels**
- View labels

**Attachments**
- Find an attachment
- View details of an attachment
  - More about Working with attachments

**Mail**
- View mail for this space
- Fetch new mail
- Delete mail
  - More about Working with mail

**Blog Posts**
- View blog posts for this space
  - More about Working with blog posts

**Activity**
- View space activity

**Advanced**
- View space details
- Edit space details
- Manage orphaned pages
- Manage undefined pages
- Adding a Template
- Manage page templates
- Export pages to PDF, HTML and XML
- Subscribe to RSS feeds within Confluence
- Watch a space
- Add a space to your favourites

**Space Administration**
- Space Administration

**Related Topics**
- Working with Spaces
- Setting up a New Global Space
- Viewing All Confluence Spaces
- Moving a Page
- Deleting a Space
Edited Space Details

You need to be a space administrator to edit the details of a space.

To edit the details of a space:

1. Choose Browse > Space Admin.
2. In the 'Edit Space Details' screen which appears you can:
   - Enter a different name for the space.
   - Enter or modify the space description.
   - Select a new home page for the space from the drop-down menu. This is the default page to which users are directed when they click the link to the space from the Dashboard.
3. Click Save.

Notes

- You cannot edit the key or the creator's name.
- The Edit Space Details fields do not accept wiki markup. Any wiki markup entered in these fields will be displayed as plain text.

Related Topics

Viewing Space Details
Browsing a space

Managing Orphaned Pages

An orphaned page is a page without any incoming links. What this means is that unless you know that this page exists, you are not likely to come across it in the space during the natural course of navigation.

When you are working in a large space with a number of pages, it is difficult to keep track of all of them. An orphaned page may be redundant or need to be referred to from another page. Confluence allows you to view all the orphaned pages in a space so you can "tidy up" the space by either deleting pages or by reorganising them.

To view the orphaned pages in a space:

1. Choose Browse Space > Advanced.
2. Click on Orphaned Pages in the left panel.

You can:

- delete an orphaned page by clicking on the 'trash' icon beside it.
- give an orphaned page a parent — see Moving a Page.

Screenshot: Managing Orphaned Pages
Managing Undefined Pages

In Confluence, you can create links to pages that you intend to create later. This is useful as it allows you to create links first and enter content for those pages later.

For example, Link to new page is a link to a non-existent page. The link is shown in dark red. (A broken link is shown in grey.)

The Undefined Pages view gives a consolidated report of all undefined pages so that you can manage your space better. The undefined page links are badged with this icon to remind you that those pages need to be created.

To view a list of the undefined links in a space:

1. Click on the menu for the space, and choose Advanced.
2. Click on Undefined Pages in the left panel. This will display a list of all the undefined pages in the space.

You can click on the link for an undefined page to create the page and add content to it.

Related Topics
- Managing Orphaned Pages
- Browsing a space

Viewing Hierarchy of Pages within a Space

The 'Tree' view of the 'List Pages' page displays the hierarchy of the pages within the space. It is a useful way of viewing all the parent-child relationships between pages in the space at once.

To see the tree view of pages within a space:

1. Choose Browse > Pages.
2. Click Tree.

Screenshot: Tree View

Related Topics
- Moving a Page
- Working with Pages

Viewing Pages Alphabetically

Use this view when you are looking for a specific page in a space and you know its title.

To view the pages in your space alphabetically:

1. Choose Browse > Pages.
2. Click on Alphabetical View.
3. Click on a letter to display all the pages beginning with that letter. Clicking on a page link will take you to that page.

Notes
- If you know the title of a page, you might find it faster using the Quick Search.

Related Topics
- View Recently Updated pages
- Browsing a space

Viewing Recently Updated Content
The 'Recently Updated' view is a useful way of keeping track of the changes being made in a space. It displays links to the most recently added or modified content within the space including pages, blog posts, mail messages and comments.

To view the recently updated content in a space:

1. Choose Browse > Pages.
2. Click Recently Updated. A list of the most recently added or modified content in the space is displayed. Clicking on a link will open up the corresponding document.

To view a space's details:

1. Choose Browse > Advanced.
2. Click Space details and then Edit Space Details. This will open the Edit Space screen.
3. Edit the Space details as required. Note that the Edit Space Details fields do not accept wiki markup. On save, any wiki markup entered in these fields will display as plain text.

The following details are displayed:

- The Name of the space.
- The Key used to refer to the space. This key is a shorthand name for the space that is used for web urls, reports, and when linking content between spaces. Note that personal space keys always contain a ‘~’, whereas global space keys never do.
- Any Labels defined for this space. Optional.
- The Homepage of the space. Optional. This is the default page to which users are directed when they click on the link to the space from the dashboard. If this field is empty (not displayed) then the default home page is the Pages tab of the 'Browse Space' page.
- The Creator of the space. Optional. This is a short description of the space used to provide users with an idea of the space's contents.

Here is an example:

**Name:** Atlassian News  
**Key:** NEWS  
**Home Page:** [The Atlassian Newsletter](https://www.atlassian.com)  
**Created By:** Charles Miller (Aug 24, 2004)  
**Description:**

News and Announcements from Atlassian

**Edit Space Details**

Related Topics

- Editing Space Details  
- Browsing a space  
- Viewing Space Activity

**Space Backup and Restore**

Confluence can backup all the content, comments and attachments for a space. The process involves converting the data in the space into XML format. The end product is a zip file that contains XML file(s) and optionally, all the attachments in the space. To transfer this data to another Confluence site, you simply restore this zip file.

**Creating a Space Backup**

Instructions on how to create a backup for a space can be found [here](https://www.atlassian.com).

**Restoring/Importing a Space Backup**

Take me back to [Confluence User's Guide](https://www.atlassian.com)
Instructions on how to restore or import the backup of a space can be found here.

Archiving Mail Overview

Confluence allows you to collect and archive mail within each space individually. This is a useful facility that allows you to archive all emails pertaining to a particular project on Confluence alongside it in the same space.

You can download mail from one or more pop-accounts. You can also import mail from mbox files either on your local system or on the Confluence server.

Choose Browse > Mail to see archived mail.

(If you are not a space administrator for the target space, contact your Confluence administrator to request Space Admin permission.)

From here, you can navigate mail easily and also use the Quick Search to search mail and the attachments it contains.

What would you like to do?

Add a Mail Account
Manage Mail accounts
Import Mail
View Mail
Fetch Mail
Delete Mail
Restore Mail

The ability to archive mail applies only to global spaces, not personal spaces. Please see Working with Spaces for information about the differences between global spaces and personal spaces.

Related Topics

Take me back to the Confluence User's Guide.

Adding a Mail Account

When you add a mail account, you are configuring Confluence to download mail from that account and archive the mail within the space. Since Confluence removes emails from an email account as it is added to the Mail Archive, Confluence must be set up to poll a clone email account rather than the actual account. For example, to archive the actual account sales@company.com to your Confluence Sales space, you must first create a clone account such as conf-sales@company.com that contains the same email content.

Stage 1 - Creating A Clone Email Account

1. Add a new email account on the mail server with the clone email address.
2. Copy all existing emails from the actual account to the clone account.
3. Set up the actual account to bcc sent emails to the clone account.
4. Set up the actual account to forward received emails to the clone account.

Stage 2 - Archive Clone Account To Mail Archive

1. If you are not a space administrator for the target space, contact your Confluence administrator to request Space Admin permission.
2. Go to Browse > Mail.
3. Click on Mail Accounts under the heading ‘Mail’ in the left panel to show the list of existing mail accounts.
4. Click Add mail account located at the top of the page.
5. Enter configuration details for the account. The protocol may be POP/S or IMAP/S. Click Create when finished.

- Account Name: Enter a name for this account by which it will be known in Confluence.
- Description: Provide a description for this account (Optional).
- Protocol: Choose from POP, IMAP, POPS or IMAPS
- Hostname: Enter the account mail server host name.
- Port: The mail server’s port number will be displayed by default. Do not edit this field.
- Username: Enter a username for this account.
- Password: The account's password.

Configured accounts will have their mail downloaded and removed from the server, so make sure you are downloading from a clone account.
Deleting Mail

To delete mail for a space, you require 'Remove Mail' permission which is assigned by a space administrator from the Space Administration screens. See Space Permissions or contact a space administrator for more information. Only a space administrator can delete all email messages for the space simultaneously.

To delete mail for a space:

1. Go to Browse > Mail.
2. Go to the Mail tab. A list of messages in the space is displayed in reverse chronological order.
3. Delete an individual email by clicking the trash icon beside it. Deleted mail is stored under Trash and can be restored by a space administrator from the Space Admin tab.

   Warning

   Email messages deleted using the Delete All option cannot be restored.

Related Topics

Restoring Mail
Archiving Mail Overview
Browsing a space

Take me back to the Confluence User's Guide.

Fetching Mail

Confluence fetches mail from the server once every 30 minutes.

You need to be a space administrator to manually retrieve new mail from mail accounts.
To manually retrieve mail:

1. Go to Browse > Mail.
2. Go to the Mail tab. A list of messages for the space is displayed in reverse chronological order.
3. Click on the Fetch new mail link located above the list of messages. Any new messages will be displayed in order of most recent first.

**Note**

Once mail is fetched, it will be removed from the server.

**Related Topics**

Viewing Mail
Archiving Mail Overview
Deleting Mail
How do I Disable Automatic Mail Polling?

Take me back to the Confluence User's Guide.

**Importing Mail**

Confluence allows you to import mail from mbox files located either on your local system or on the Confluence server and archive it within the space.

You need to be a space administrator to import mail for a space.

**To import mail from mbox files:**

1. Go to Browse > Mail.
2. Click on Mail Import under the heading 'Mail' in the left panel.
   * To import from a Local system, click Browse to select the mbox file. Then click Import.
   * To import from the Server, enter the location of the mbox file on the server in the Server text field and click Import.

**Screenshot : Importing mail**

Import mail from a standard mbox file by either uploading a local file or specifying its location on the server.

- **Local**
  - Browse for mbox file on local filesystem:
    - **Filename:**
    - **Browse**
    - **Import**

- **Server**
  - Specify location of mbox file on server:
    - **Import**

**Note**

The ability to import mail applies only to global spaces, so the 'Import' section in the above screenshot does not appear in the 'Space Admin' tab for personal spaces. Please see Working with Spaces for information about the differences between global spaces and personal spaces.

**Related Topics**

Archiving Mail Overview
Adding a Mail Account
Importing Mail

Take me back to the Confluence User's Guide.

**Managing Mail Accounts**

You need to be a space administrator to manage mail accounts for a space.
To manage mail accounts:

1. Go to **Browse > Mail**.
2. Click on **Mail Accounts** under the heading 'Mail' in the left panel. For each of the mail accounts listed, you can:
   - **Edit**: change the configuration settings for the mail account.
   - **Remove**: remove the account permanently.
   - **Disable**: temporarily disable the account.

### Screenshot: Managing mail accounts

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Host</th>
<th>Status</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>conf-user archive</td>
<td>Archive of conf-user</td>
<td><a href="mailto:mail@lassian.com">mail@lassian.com</a></td>
<td>OK</td>
<td>Edit</td>
</tr>
<tr>
<td>ou</td>
<td>ui</td>
<td>ui</td>
<td>DISABLED</td>
<td>Edit</td>
</tr>
</tbody>
</table>

### Related Topics
- Archiving Mail Overview
- Adding a Mail Account
- Importing Mail
- Viewing Mail
- Fetching Mail
- Deleting Mail
- Restoring Mail

Take me back to the Confluence User's Guide.

## Restoring Mail

Deleted email messages are stored under 'Trash' and can be restored by a space administrator from the Space Administration screens.

ℹ️ You can only restore an email from trash if it was deleted individually and not using the 'Remove All' operation.

### To restore mail,

1. Go to the 'Space Admin' tab in the 'Browse Space' view.
   
   Go to a page in the space and choose **Browse > Space Admin**.

2. Click on 'Trash' in the left panel. A list of pages and emails deleted from the space is displayed.

3. Click on 'Restore' beside the email you want to restore.

To view this email, you will have to go to the 'Mail' tab in the 'Browse Space' view.

### RELATED TOPICS
- Viewing Mail
- Fetching Mail
- Deleting Mail
- Browsing a space

Take me back to the Confluence User's Guide.

## Viewing Mail

In Confluence, each global space can be set up to archive mail.

### To view mail messages archived within a particular space:

1. Go to a page in the space and choose **Browse > Space Admin**.

2. Click on the **Mail** tab. The mail is displayed in reverse chronological order with a default of 30 mails per page. You can move between pages by clicking the [Previous] and [Next] links or by selecting a particular page number.

3. Click on a mail message to view its contents.

### Screenshot: Mail Archive
If you are a space administrator, or have been given permission to delete mail messages, you can also delete emails from here.

Navigating Mail:

**Attachments** This link located below the email body allows you to view mail attachments. The link is only displayed if any attachments exist.

**Entire Thread** This link allows you to view the mail’s thread, if one exists.

The 'Mail Operations' panel is located to the right of the mail view and displays links to:

- **Entire Thread**: View the thread that this mail belongs to. This option is only available when the mail belongs to a thread.
- **Next By Date**: Navigate to the next message.
- **Previous By Date**: Navigate to the previous message.
- **Remove Mail**: Remove the current mail from the space.
- **Mail Archive**: Go to the mail archive view for this space.

**Related Topics**

- Archiving Mail Overview
- Viewing Mail
- Fetching Mail
- Deleting Mail
- How do I Disable Automatic Mail Polling?

Take me back to the Confluence User's Guide.

**Working with Labels**

Labels are key words or tags that you can add to pages and spaces. You can define your own labels and use them to categorise, identify or bookmark content in Confluence.

For example, you could assign the label 'accounting' to all accounts-related pages on the site. You can then browse all pages with that label in a single space or across the site, or display a list of pages with that label. You can search based on the label, and even use it to filter items when you subscribe to a Confluence RSS feed.

Because labels are user-defined, you can add any word (or even make up your own) that helps you identify the content in the site.

You can add or remove labels without affecting the page content.
Page Labels

There are two different types of labels that you can apply to a page:

- **Global labels.** See Adding a Global Label. A global label is available to all users across the site. Once a global label is added, any user with permission to view a page can also view its labels. Any user with permission to edit a page can add a global label to a page. See the global labels at the bottom of this page for examples.

- **Personal labels.** See Adding a Personal Label. A personal label is only available to the user that created it. Any user with 'view' permission can add a personal label to a page. The personal labels start with 'my:'.

Space Labels and Space Categories

You can also apply labels to spaces and use them to categorise your spaces. See Using Labels to Categorise Spaces.

Advantages of Labels

Here are some of the advantages of using labels:

- Labels are user-defined which means that you decide what information is relevant to you and how you are going to label it.
- You can group pages and spaces without having to restructure the site.
- Labels are easy to add and edit, and do not affect the actual content of the page.
- You can use labels to filter information during a search.
- You can add as many labels as you like to a page or space.
- The RSS feed builder allows you to create a news feed based on labels.

Related Topics

No content found for label(s) confluence-label-filter.

Take me back to Confluence User's Guide

Adding a Global Label

This page describes global labels. You may be interested in personal labels.

Any user with 'edit' permission for a page can add a global label to it.

To add a global label:

1. View the page. If the page already has labels, these will be listed at the bottom of the page, below the page content.
2. Click the icon beside the list of labels, or press 'L'.
3. Type in a new label. Existing labels are suggested as you type.
4. Click Add.

Screenshot: Adding a label
Adding a Personal Label

This page describes personal labels. You can also read about global labels.

You can use personal labels to mark content that you personally are interested in. Any user with 'view' permission can add a personal label. Personal labels are visible only to the user who created them. To differentiate them from global labels, personal labels include the prefix 'my:' in the label name.

You can view your personal labels from your user profile.

To add a personal label:

1. View the page. If the page already has labels, these will be listed at the bottom of the page, below the page content.
2. Click the icon beside the list of labels, or press 'L'.
3. Type in a new label, using the format 'my:label'. Existing labels are suggested as you type.
4. Click Add.

Screenshot: Adding a label

Using Labels to Categorise Spaces

Confluence provides the following types of space label:

- **Space labels.** A space label can be used to group related spaces for display by the Content by Label macro, and for ranking search results. You use space labels in a similar way to global labels.
- **Space categories.** A space category is a special type of space label that Confluence uses to group spaces in the space directory, and in the recent activity area of the dashboard. The rest of this page describes space categories.

Note that you can only set up space categories if you are a space administrator for that space, or you are a Confluence system administrator.

Using Space Categories

Here is an example of using space categories. Let's assume that you have one or more spaces that your Sales team may be interested in. You can use the category 'sales' to group those spaces together.

1. First add the 'sales' category to the relevant spaces, as described below.
2. Then, in the space directory, you can click the relevant tab to see only the spaces with the chosen label. See Viewing All Confluence
3. And, you can see updated content in those spaces by choosing the 'sales' category under the **Space Categories** tab in the recent activity area of the dashboard. See [Customising your Personal Dashboard](#).

### On this page:
- Using Space Categories
- Categorising a Space
- Removing a Space from a Category
- Removing an Entire Space Category
- Related Topics

---

**Categorising a Space**

When you categorise a space, you add a 'space category' to the space. A category cannot exist if there are no spaces labelled with that category.

**To categorise a space:**

1. Choose **Browse > Space Admin**.
   - **Space Admin** is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. Click **Space Labels** in the left-hand panel.
3. Under 'Space Categories', enter your category name and click **Add**.
   - Alternatively, click a category in the list of 'Suggested Space Categories' displayed on the screen.

**Removing a Space from a Category**

Removing a space from a category is the same thing as removing the category from the space.

**To remove a space from category:**

1. Choose **Browse > Space Admin**.
   - **Space Admin** is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. Click **Space Labels** in the left-hand panel.
3. Click the x next to the space category.

**Removing an Entire Space Category**

To remove a whole space category from Confluence, just remove that category from all spaces, as described above. A category cannot exist if there are no spaces labelled with that category. The space category will disappear from the dashboard and space directory.

**To remove an entire space category from Confluence:**

1. Choose **Browse > Space Directory**.
2. Click the tab corresponding to the space category that you want to remove.
3. You will see a list of all spaces in that category. Click the spaces one by one, and remove the category from each space, as described above.

*Screenshot: Space labels and space categories*
Navigating Pages by Label

This page describes how to navigate Confluence pages by label. To start, you should open the 'View Labels' page.

**Browsing Labels on the View Labels Page**

Click a label on a Confluence page to see a list of all pages in the space with that label. Click See content from all spaces to include content from all spaces of the Confluence site.

**Adding a Label to the Results**

If you click a label from the Related Labels list (at the top left), a new page loads, showing pages that contain both of the labels. You can continue to add labels to the results in this way.

**Subtracting a Label From the Results**

Once two labels are in use, links to subtract a label from the search appear at the end of the labels list. These are easily identified because these links have a preceding minus sign, like so:

- shipit
**Typing URLs To Find Labelled Pages**

Here is an alternative method for quickly searching for labelled pages:

**To search labelled pages by typing a URL:**

1. Open a new web browser window.
2. In the address bar of your web browser, type an URL such as:

   http://CONFLUENCE_HOSTNAME/label/foo+bar

3. Press Enter.

4. The 'View Labels' page will load, showing search results for pages with the labels 'foo' and 'bar'.

**Screenshot: The View Labels page**

```
Dashboard > Labels > fedex

Label: fedex

View: Popular Labels | All Labels

All content with label fedex.
Related Labels: lucene, clover, comments, shipping, specification, project, howto, shipment, html, gadget, javascript, bittorrent, zen, realtime, fedex5, label, feed, constraints, ideas, more

20% Time Ideas (David Taylor)
Batch labeling (multiple pages/blogs in space) User activity data:
http://www.codinghorror.com/blog/archives/001063.html Logging to separate files, with rolling for support

Add To Google plugin (Dushan Hanuska)
I just blogged about my FedEx project on Dev Blog
http://blogs.atlassian.com/devveloper/2007/05/addtogoogletplugin.html Read my entry here
http://blogs.atlassian.com/devveloper/2007/05/addtogoogletplugin.html ! jiraissuenavigatorandtogoog.png! jiraissuemessagescreenshoticons.png! For interested parties: docs on the gadget are at JIRA issues Gadget ...

Recent Labels
atlassian
seraph
release
module
commom
more a

Popular Labels
confluence
timesheet
jira
support
customerservice
more a
```

**Screenshot: Label Links on the View Labels Page**

```
Label: fedex+ideas

View: Popular Labels | All Labels

All content with label fedex+ideas.
Related Labels: lucene, clover, comments, shipping, specification, project, howto, shipment, html, dao, gadget, javascript, bittorrent, things-that-suck, zen, realtime, fedex5, label, feed, more ( -fedex, -ideas )
```

**Related Topics**

- Adding a Global Label
- Adding a Personal Label
- Using Labels to Categorise Spaces
- Navigating Pages by Label
Removing a Label from a Page

Labels are key words or tags that you can add to pages and spaces. You can define your own labels and use them to categorise, identify or bookmark content in Confluence.

You can see the existing labels, and the pages which contain the labels, by Viewing Global Labels.

To remove a label from a page:

1. Go to the page that contains the label. All labels are displayed at the bottom of the page below the page content.
2. Click the icon beside the list of labels, or press 'L'.
3. In the Labels dialog, click on the X for a label to remove it.
4. Click Close.

Using Label Macros to Categorise Wiki Content

Using labels, you can categorise pages and refer to content across multiple categories, pages and even spaces.

Example

For the purpose of this example, imagine we have a space with pages of content on various type of vehicles. Pages are shown in bold text, while the labels are in blue.

- Cars vehicle-type
  - Toyota Prius vehicle car
  - Honda Civic vehicle car
  - Porshce Carrera vehicle car
- Motorbikes vehicle-type
  - Harley Davidson Sportster vehicle motorbike
  - Suzuki GSX-R vehicle motorbike

This page hierarchy can then be categorised using labels, with pages referenced using the Content by Label Macro.

<table>
<thead>
<tr>
<th>If you want to list...</th>
<th>You would use this label:</th>
<th>These would be the pages that you would get:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vehicle types</td>
<td>vehicle-type</td>
<td>Cars, Motorbikes</td>
</tr>
<tr>
<td>All vehicles</td>
<td>vehicle</td>
<td>Toyota Prius, Honda Civic, Porshce Carrera, Harley Davidson Sportster, Suzuki GSX-R</td>
</tr>
<tr>
<td>All cars</td>
<td>car</td>
<td>Toyota Prius, Honda Civic, Porshce Carrera</td>
</tr>
</tbody>
</table>

Label Macros

**Navmap Macro**

The Navmap Macro renders the list of pages associated with a specified label as a navigation map.

**Related Labels Macro**

The Related Labels Macro lists labels commonly associated with the current page’s labels.

**Content by Label Macro**
The Content by Label Macro displays a list of content marked with specified labels.

**Labels List Macro**

The Labels List Macro lists all labels of a space, grouped alphabetically.

**Recently Used Labels Macro**

The Recently Used Labels Macro lists labels most recently used in a specified scope (global, space, or personal).

**Popular Labels Macro**

The Popular Labels Macro displays popular labels in a list or in a heatmap (also called a cloud).

**Related Topics**

Working with Labels
Working with Macros

Take me back to the Confluence User's Guide.

**Content by Label Macro**

The Content by Label macro shows links to content which has been tagged with specific labels.

---

**Using the Content by Label Macro**

To add the Content by Label macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Working Example of Usage**

Below is a working example of the Content by Label macro, displaying content with the label "LDAP".

No content found for label(s) LDAP.

**Parameters**

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label(s)</td>
<td>None</td>
<td>Filter by label(s) — only that content tagged with the label(s) specified is displayed. This parameter is required. Specify one or more labels, separated by a comma or a single space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labelled with ‘badpage’.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage,+goodpage you will get only content which has at least two labels, being ‘superpage’ and ‘goodpage’.</td>
</tr>
<tr>
<td>Author(s)</td>
<td>None</td>
<td>Filter by author — only that content created or updated by the author(s) specified is displayed. Specify one or more authors, separated by a comma.</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Include this Content Type Only | all   | Filter by content type — only content of the type specified is displayed. Specify one or more content types, separated by a comma or a space. To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of `-blogpost` you will get pages and all other content except for blog posts. Available values:  
  - Page — Pages.  
  - blogpost or news — Blog posts, also known as news items. |
| Show Labels for Each Page | true  | Show or hide labels for results. |
| Show Space Name for Each Page | true  | Show or hide spaces for results. |
| List Title              | None  | Adds a title or heading to the list. |
| Maximum Number of Pages | 15    | Limits the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied. |
| Display Excerpts        | false | Includes excerpts from each page listed. Note that you must have defined excerpts on each of those pages, by adding the `excerpt` macro to the page. Only the first few lines of the excerpt for each page are displayed. |
| Restrict to these Spaces | @all  | Filter by space — only that content which belongs to the space(s) specified is displayed. You can specify one or more space keys, separated by a comma or a space.  
  - To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of `-BADSPACE` you will get only content which is not in the BADSPACE.  
  - To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of `+GOODSPACE` you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)  
  Special values:  
  - `@self` — The current space.  
  - `@personal` — All personal spaces.  
  - `@global` — All global spaces.  
  - `@favorite` — The spaces you have marked as `favourite`.  
  - `@favourite` — The same as `@favorite`.  
  - `@all` — All spaces in your Confluence site.  
  - `*` — The same as `@all` above.  
  When specifying a personal space, remember to use the tilde (`~`) sign in front of the username, such as `~jbloggs` or `~jbloggs@example.com`. |
| Operator                | OR    | The operator to apply to the labels specified in Label(s):  
  - OR — Pages with any of the non-prefixed labels are listed.  
  - AND — Pages with all of the specified non-prefixed labels are listed.  
  Note that this parameter only modifies the behaviour of the Label(s) parameter and only affects label values without a plus (+) or minus (-) sign prefix. |
Sort By  modified  Specify how the results should be sorted.

Values:
- title — Sort alphabetically by title.
- creation — Sort by the date on which the content was added.
- modified — Sort by the date on which the content was last updated.

Note: If this parameter is not specified, the sort order defaults to descending order based on the last modification date (i.e., latest first). To change the sort order from ascending to descending, use the Reverse Sort parameter.

Reverse Sort  false  Select Reverse Sort to change the sort from descending to ascending. Use this parameter in conjunction with the Sort By parameter — Reverse Sort is ignored if Sort By is not specified.

Related Topics

Related Labels Macro
Navmap Macro
Recently Used Labels Macro
Working with Labels
Working with Macros

Take me back to the Confluence User's Guide.

Labels List Macro

The Labels List macro displays a hyperlinked alphabetical index of all labels within the current space.

The label index generated consists of numerous cells, each beginning with one or more letters of the alphabet or a number. Each label within the space is grouped alphabetically into its appropriately headed cell.

Each label in the Labels List macro links directly to its Labels page, that lists the pages on which the label occurs within the current space.

Screenshot: Labels List Macro segment

Below are the 582 labels used in Confluence Docs 2.10 listed alphabetically. Click on a label to see its associated content.

On this page:
- Usage with the Macro Browser
Usage with the Macro Browser

To insert the Labels List macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

This macro has no parameters.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Navmap Macro

The Navmap macro displays the list of pages associated with a specified label as a navigation map.

A label must be specified for this macro.

On this page:

- Usage with the Macro Browser
- Parameters
- Related Topics

Usage with the Macro Browser

To insert the navmap macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>yes</td>
<td>none</td>
<td>Specify the label associated with the pages you want to show in the navigation map.</td>
</tr>
<tr>
<td>Map Title</td>
<td>no</td>
<td>none</td>
<td>Specify a title for the navigation map.</td>
</tr>
<tr>
<td>Number of Cells Per Row</td>
<td>no</td>
<td>5</td>
<td>Specify the number of cells in a row</td>
</tr>
<tr>
<td>Cell Width (Pixels)</td>
<td>no</td>
<td>90 px</td>
<td>Specify the cell width</td>
</tr>
<tr>
<td>Cell Height (Pixels)</td>
<td>no</td>
<td>60 px</td>
<td>Specify the cell height</td>
</tr>
</tbody>
</table>
Define a theme for the navmap.

If you want to create your own navmap 'look and feel' (for example, one with rounded corners), you need to add a customised navmap macro theme file to the WEB-INF/classes/templates/macros directory. The file name convention to use is navmap-mytheme.vm. Use the name of your choice for the mytheme part of the file name, which is also the value you use for this parameter. Hence, if your theme was called navmap-roundededges.vm, use the value of roundededges for this parameter.

### Related Topics

**Related Labels Macro**
**Content by Label Macro**
**Recently Used Labels Macro**
**Working with Labels**
**Working with Macros**

Take me back to the Confluence User's Guide.

### Popular Labels Macro

The Popular Labels macro displays the most popular labels used throughout your Confluence site or within a space.

### On this page:

- **Usage with the Macro Browser**
- **Parameters**
- **Related Topics**

#### Usage with the Macro Browser

To insert the popular labels macro into a page using the Macro Browser:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

#### Parameters

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Labels to Display</td>
<td>no</td>
<td>100</td>
<td>Specifies the total number of labels to display in the heatmap.</td>
</tr>
<tr>
<td>Restrict Labels to this Space Key</td>
<td>no</td>
<td>none</td>
<td>Restricts the list of popular labels to the specified space.</td>
</tr>
<tr>
<td>Style of Labels</td>
<td>no</td>
<td>list</td>
<td>Displays the popular labels as a bulleted list or as a 'heatmap'. The list style orders labels by popularity (highest first). The heatmap style uses different font sizes for each label depending on the label's popularity, ordered by label names.</td>
</tr>
</tbody>
</table>

### Related Topics

**Using Label Macros to Categorise Wiki Content**
**Related Labels Macro**
**User-contributed extension: Sortable Popular Labels**

Take me back to the Confluence User's Guide.
Recently Used Labels Macro

The Recently Used Labels macro displays a list of the most recently used labels in a specified scope (Global/Space/Personal).

On this page:
- Usage with the Macro Browser
- Parameters
- Related Topics

Usage with the Macro Browser

To insert the recently used labels macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Labels to Display</td>
<td>no</td>
<td>10</td>
<td>Specifies the total number of labels to display in the list.</td>
</tr>
<tr>
<td>Scope for Retrieving Labels</td>
<td>no</td>
<td>global</td>
<td>Specifies the scope of labels to be displayed in the list. Valid values include:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- global — covers all non-personal spaces in the Confluence installation.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- space — the current space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- personal — your own personal space.</td>
</tr>
<tr>
<td>List Style</td>
<td>no</td>
<td>list</td>
<td>Specifies the list style. Valid values include:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- list — displays the list of labels horizontally.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- table — includes additional information such as the page to which the label was added and the user who added it.</td>
</tr>
<tr>
<td>Title</td>
<td>no</td>
<td>none</td>
<td>Adds a title to the top of the list in table style. Titles are only visible when the List Style parameter has been set to table.</td>
</tr>
</tbody>
</table>

Related Topics

- Related Labels Macro
- Content by Label Macro
- Recently Used Labels Macro
- Working with Labels
- Working with Macros

Take me back to the Confluence User's Guide.

Related Labels Macro

The Related Labels macro lists all tagged labels from every page which has one or more labels in common with the current page.

On this page:
- Usage with the Macro Browser
- Parameters
- Related Topics

Usage with the Macro Browser

To insert the related labels macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restrict to these</td>
<td>no</td>
<td>none</td>
<td>Specify the labels for which you want to view related labels. For example,</td>
</tr>
<tr>
<td>Labels</td>
<td></td>
<td></td>
<td>documentation, my:stuff.</td>
</tr>
</tbody>
</table>

**Related Topics**

- Navmap Macro
- Content by Label Macro
- Recently Used Labels Macro
- Working with Labels
- Working with Macros

Take me back to the Confluence User's Guide.

**Viewing Global Labels**

Any page that has labels will have them listed together in a block at the bottom of the page, with the heading 'Labels'.

Global labels are visible to all users with 'view' permission and personal labels are only visible to the user that created them.

**To view global labels:**

1. If you are in a page that has labels, clicking on a label will take you to the 'Label' tab of the 'Browse Space' view where all pages in the space with that label will be listed.

   Click **See content from all spaces** to view all pages with the same label across the site.

2. Go to a page in the space and choose **Browse > Space Admin**.

3. Click on the **Labels** tab. You have the option to view labels in one of two ways:

   - Click **All labels** to view all labels in the space. From this view, you can click on a link to view an alphabetical listing of all labels across the site. Clicking on a label will list all content in the space with that label. It will also display any related labels if they exist. Related labels are labels that frequently appear on pages together. For example, if pages labelled with 'sales' also tend to have the label 'marketing', these will be displayed as related labels.
   - Click **Popular Labels** to view a list of the most frequently used labels in that space. From here, you can also view the most popular global labels across the site.

Confluence defaults to one of these views when you go to the 'Labels' tab based on your preference on your last visit to the site. Each of these views also displays a list of up to fifteen most 'Recent Labels' or 'Popular Labels' in the space.

**Screenshot: Labels as they are displayed on a page**

**Labels**

*exciting* *frimcerous*

**Screenshot: Viewing all labels**
Related Topics

Viewing Labelled Pages
Viewing Personal Labels
Viewing Popular Labels
Navigating Pages by Label

Take me back to Confluence User's Guide

Viewing Labelled Pages

The easiest way to find labelled content is to do a quick search for it. If there is a label matching your query, it will be listed above the search results. Clicking on the link will display all content in the site with that label. (Clicking additional labels on the following page will conduct another search, adding that label to your existing search. See also Navigating Pages by Label.)

- You can view all labelled content for a space by going to the 'Label' tab in the 'Browse Space' view of a space.
- You can view content labelled with personal labels by going to your Profile and clicking on the Label tab.

Screenshot: Viewing labelled content

Searched for database in all spaces excluding Mail.
There are 201 matches in Mail. include these matches.
Matching labels: database
Related labels: oracle, appserver

Results 1 - 10 of 225 for database.

- Migrate to another database (Confluence)
  ... document will outline the steps to move your existing Confluence data from
  one database to another. This is relevant to all users who previously used the
  embedded database for their evaluation (or longer) and would like to move to a
  more robust external database (such as Oracle, Postgres).
  Jul 20, 2005

Advanced label searching

Using the Search Box to find labelled pages

In the search box, you can use the 'labelText:' prefix to search specifically for page labels.
### Searching for ...

<table>
<thead>
<tr>
<th>confluence labelText:plugin</th>
<th>contains the word confluence or has the label plugin</th>
</tr>
</thead>
<tbody>
<tr>
<td>confluence AND labelText:plugin</td>
<td>contains the word confluence and has the label plugin</td>
</tr>
<tr>
<td>labelText:import labelText:plugin</td>
<td>has the label import or has the label plugin</td>
</tr>
<tr>
<td>labelText:import AND labelText:plugin</td>
<td>has the label import and has the label plugin</td>
</tr>
</tbody>
</table>

### Typing URLs to find labelled pages

In the URL bar of your web browser, you can type URLs like the following to search for multiple labels in pages:

```
http://CONFLUENCE_HOSTNAME/label/foo+bar
```

On pressing enter, the 'View Labels' page will load, showing search results on pages with the labels `foo` and `bar`.

Also see Navigating Pages by Label

### Related Topics

- Viewing Global Labels
- Viewing Personal Labels
- Viewing Popular Labels
- Searching Confluence

Take me back to Confluence User's Guide

### Viewing Personal Labels

Any page that has labels (global or personal) will have them listed at the bottom of the page. Personal labels are only visible to the user that created them.

**To view your personal labels:**

- Go to your name (the 'user' menu) at the top of the page, and choose **Labels**.

The 'Labels' view displays all content with personal labels. You will also see a list of your personal labels along with the number of pages that contain the label. Click a link to see all content with that label.

*Screenshot: Viewing personal labels*
Another way to get to your personal labels

If you are on a page that has personal labels, click on a label to go to the 'Labels' tab of your profile, described above.

Related Topics

Adding a Personal Label
Viewing Labelled Pages
Viewing Global Labels
Viewing Popular Labels

Take me back to the Confluence User's Guide.

Viewing Popular Labels

Popular labels are those labels that are more frequently used. Confluence allows you to view the popular labels both within a space and across the site.

To view popular labels:

1. Choose Browse > Labels.
2. Click Popular Labels, if necessary. This will list the most popular labels in the space and also display a link to view all global popular labels (across the site).

   - Clicking on a label will display all the content in the site with that label.
   - Click global popular labels to view the most popular global labels in the site.

In both these views, you have the option to sort the listing of labels to display them alphabetically or in order of their popularity.

The bigger the font size, the more popular the label.

Screenshot: Viewing popular labels

Related Topics

Viewing Labelled Pages
Viewing Global Labels
Viewing Personal Labels

Take me back to Confluence User's Guide

Working with Favourites

The Favourites feature provides a convenient way to quickly access specific pages or spaces that interest you, as soon as you log in to
Confluence. Pages and spaces that you have added to your list of favourites are easily accessible from your Dashboard and from within your user profile area.

What do you want to do?

Adding Favourites
Viewing Favourites
Removing Favourites

Related Topics
Dashboard
User Profile Overview

Take me back to the Confluence User's Guide.

Adding Favourites

To add a page as a favourite:

1. Go to the page.
2. Choose Tools > Favourite.
   This will change to 🟠 Favourite (when you next open the Tools menu) to indicate that you have added this page as a favourite.

To add a global space as a favourite:

1. Go to the Dashboard.
2. Click the Spaces tab.
3. Click the star icon ✨ located beside the space name in the list of global spaces.
   This will change to ✨ to indicate that you have added this global space as a favourite.

To add a personal space as a favourite:

ℹ️ If a person has not yet created a personal space, then you will not be able to perform this procedure. Furthermore, these options will not be available to you.

2. Click on a person’s name or profile picture to view their personal space.
3. Go to a page in the space and choose Browse > Advanced.
4. Click on 🟠 Add Space to Favourites in the left-hand panel.
   This will change to ✨ Remove Space from Favourites to indicate that you have added that person’s personal space as a favourite.

Once you have added a personal space to your list of favourites, that personal space will be added to your list of favourite spaces, which can be accessed from the dashboard or your profile.

For more information about global spaces and personal spaces, see Working with Spaces.

Related Topics

Viewing Favourites
Searching the People Directory

Take me back to the Confluence User's Guide.

Removing Favourites

To remove a page as a favourite:

1. Go to the page.
2. Choose Tools > 🔴 Favourite.
   This will change to 🔴 Favourite to indicate that you have removed this page from your favourites.

To remove a global space as a favourite:

1. Go to the dashboard.
2. Click on the star icon ✨ located beside the space in the list of spaces displayed.
   This will change to ✨ to indicate that you have removed this global space as a favourite.

To remove a personal space as a favourite:

1. Go to the People Directory.
2. Click on a person's name or profile picture to view their personal space.
3. Go to a page in the space and choose Browse > Advanced.

4. Click on 🌟 Remove Space from Favourites in the left-hand panel.
   This will change to 🌟 Add Space to Favourites to indicate that you have removed that person's personal space as a favourite.

Related Topics

Viewing Favourites
Spaces Cannot be Unmarked as Favourites

Take me back to the Confluence User's Guide.

Viewing Favourites

Once you add a spaces or pages as favourites, you can see them on your dashboard or in your profile.

The Dashboard

On the left-hand side of the Dashboard, you can see:

- your favourite spaces in the Spaces tab.
- your most recently added favourite pages in the Pages tab.

Recently updated content in your favourite spaces will be listed on the Favourite Spaces tab at the top right of the dashboard.

Screenshot: Viewing your favourites on your dashboard

<table>
<thead>
<tr>
<th>Favourite Spaces</th>
<th>Global Spaces</th>
</tr>
</thead>
<tbody>
<tr>
<td>🌟 Angry Nerds</td>
<td>🌟 Admin Space</td>
</tr>
<tr>
<td>🌟 Confluence</td>
<td>🌟 Angry Nerds</td>
</tr>
<tr>
<td>🌟 Paul Watson</td>
<td>🌟 Archive</td>
</tr>
<tr>
<td>🌟 Technical Writing</td>
<td>🌟 Atlassian Foundation</td>
</tr>
</tbody>
</table>

Your Profile

To view your favourites in your profile:

1. Log in to Confluence, if you have not already done so.
2. Go to your name (the 'User' menu) at the top of the page and choose Labels.
3. Click on favourite (under 'Your Labels') to see the list of your favourite spaces and pages.

Screenshot: Viewing your favourites in your profile
Working with Attachments

An attachment is any file that is included with your page. Examples of attachments are images, screenshots, photographs, Word documents, presentations, and PDF, multimedia and sound files.

Quick guide to attachments

- Go to Tools > Attachments to view and attach files to a Confluence page. See Attaching Files to a Page.
- If you attach a file with the same name as an existing attachment, Confluence will create a new version of the existing attachment.
- Once you have attached a file, you can then create a link to it on a Confluence page. When a user clicks the link, the attachment will open, provided that the user has the software application needed to open the attachment.
- You can display attached images and multimedia content on the page.
- If the attachment is an Office document, use the View File macro to display the content of the document on the Confluence page. If you have an Office application installed, you will also be able to launch your Office editor from within Confluence. See Displaying Office Files in Confluence and Working with the Office Connector.

Attachments are useful when you want to share information that exists in another file format. If you want an attachment to be displayed on more than one page, you may wish to consider creating a special page to hold such attachments. This special page could be part of an ‘inclusions library’.

In Confluence you can attach files to any page or blog post, provided you have permission to do so.

When a page you are viewing contains attachments, a small paperclip icon appears next to the page byline. Clicking the paperclip will take you to the ‘Attachments’ view, where the full list of attachments is displayed.

Working with attachments:

- Using Drag-and-Drop in Confluence
- Attaching Files to a Page
- Attachment Versions
- Deleting an Attachment
- Displaying a List of Attachments in a Page
- Downloading Attachments
- Editing Attachment Properties
- Embedding Multimedia Content
- Embedding PowerPoint Presentations in a Page
- Finding an Attachment
- Moving an Attachment
- Viewing Attachment Details

Related Topics
Using Drag-and-Drop in Confluence

This page describes Confluence's drag-and-drop feature and provides details of its requirements.

On this page:
- Overview of the Drag-and-Drop Feature
- Requirements for the Confluence Drag-and-Drop Feature
- Disabling Drag-and-Drop
- Related Topics

Overview of the Drag-and-Drop Feature

Confluence's drag-and-drop feature allows you to drag files from your computer or file system onto your browser and attach them to your Confluence pages or blog posts. You can drag-and-drop:

- multiple files at once.
- image, multimedia and PDF files, and Office documents.

When you drag-and-drop files onto the different Confluence views, you get the following results:

<table>
<thead>
<tr>
<th>Confluence View</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachments</td>
<td>Files are attached</td>
</tr>
<tr>
<td>Page</td>
<td>Files are attached</td>
</tr>
<tr>
<td>Edit</td>
<td>Files are attached, and embedded at the cursor position</td>
</tr>
</tbody>
</table>

Requirements for the Confluence Drag-and-Drop Feature

- Confluence's drag-and-drop feature relies on your browser's support for the drag-and-drop functionality of HTML5.

- Some browsers, such as Internet Explorer 9, Firefox 3.5 and Safari 4 do not support the drag-and-drop functionality of HTML5. For these browsers, Confluence will attempt to use the drag-and-drop functionality provided by Google Gears.
  
  - The first time you try to drag and drop a file into one of these browsers, Confluence will prompt you to install Google Gears into your browser. Refer to the prompt below for more information. For more details on the installation requirements for Google Gears, refer to Google's own How to install instructions.
  
  - Please check the Google Gears website for the most up-to-date browser support details. To check if Google Gears is already installed on your computer, refer to Google's own How to check if Gears is installed instructions.

Supported Web Browsers

Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. You can find the list of supported web browsers and browser versions on this page: Supported Platforms.

- Some older Confluence themes do not support Confluence's drag-and-drop feature.
  
  - **Supported themes**: Confluence Default theme, Documentation theme, Easy Reader theme.
  
  - **Themes that are not supported**: Left Navigation theme, Clickr theme. You cannot drag and drop attachments into spaces that use these themes.
**Prompt to Install Google Gears**

If you are using a browser that does not support the drag-and-drop feature, and Google Gears has not yet been installed:

- When you attempt to drag and drop a file into Confluence (but not the editor), you will be prompted with the following message:

  *Screenshot: Generic Confluence Prompt to Install Google Gears*

  ![Generic Confluence Prompt to Install Google Gears](image)

  Click **OK** to proceed with the Google Gears installation.

- When you attempt to drag and drop a file into the editor, you will be prompted with the following message:

  *Screenshot: Confluence Prompt to Install Google Gears*

  ![Confluence Prompt to Install Google Gears](image)

  Click **Save Changes to Draft** if the draft saves successfully, you can proceed with the installation.

  ![Save any drafted content before continuing with the installation of Google Gears.](image)

  Click **Proceed with Installation** to install Google Gears.

**Initial Use with Google Gears**

When adding an attachment to a page or blog post in your Confluence site for the first time (after **Google Gears has been installed**), you will be prompted to allow Google Gears to trust your Confluence site as shown in the following screenshot. If this warning message appears, select the **I trust this site. Allow it to use Gears** check box and click **Allow**.

*Screenshot: Google Gears Security Prompt*
Disabling Drag-and-Drop

If you are a Confluence administrator and wish to disable Confluence's drag-and-drop feature for any reason, please refer to Disabling Drag-and-Drop for details.

Related Topics

Attaching Files to a Page

An attachment is any file that is included with your page. Images, word documents, presentations and PDF, multimedia and sound files are some examples of attachments. Attachments are useful when you want to share information that exists in another file format. Read more in Working with Attachments.

When you attach a file to a page, Confluence makes a copy of the file and stores it on the server. Page attachments in Confluence are managed using the 'Attachments' view of the page.

To attach a file, you need the 'Create Attachments' permission which is assigned by a space administrator from the Space Administration screens. See Space Permissions or contact a space administrator for more information.

On this page:

- Attaching files
- Attachment Versions
- Attachment Information Icon
- Related Topics

Attaching files

There are several ways to attach files to a Confluence page:

- Drag-and-dropping files on to a Confluence page.
- By browsing to, and uploading files from, your computer or network.

To attach a file to a page using drag-and-drop:
1. View the page to which you want to attach files.
2. Drag one or more files from your computer onto the page. The 'Attach File(s)' message box appears, indicating the upload status of the files being attached to your page.

You cannot drag-and-drop a folder onto a page.

Expand this section to see other ways to drag-and-drop a file on to a page...

You can also drag-and-drop files:

- directly on to the 'Attachments' view for the page
- directly on to the editor view of the page
- on to any tab of the Edit Link or Insert Image dialogs, which are available from the Insert menu while editing.

To attach a file to a page from the computer's (or network's) file system:

1. Choose Tools > Attachments to go to the 'Attachments' view for the page.
2. Click Browse... and navigate to the file.
3. Select the file and click Open.
4. Add a descriptive comment for the file (optional).
5. Click Attach more files if required.
6. Click Attach.

Expand this section to see other ways to upload a file to a page...

You can also browse for, and upload, a file from:

- the Attachments tab of the Edit Link dialog (while editing the page, click on Link in the toolbar)
- the Attached Images tab of the Insert Image dialog (while editing the page, go to Insert > Image)

Attachment Versions

If you upload a file with the same name as an existing attachment, Confluence will rename the old file and maintain a version of it on the server. Read more about Attachment Versions and Viewing Attachment Details.

Please note that changes you make to the source file don’t affect the copy that was uploaded to Confluence. To update the Confluence copy, you need to upload the new version of the file.

Attachment Information Icon

The page Working with Attachments Overview does not exist.

Related Topics

Working with Attachments
Displaying Images
Attachment Versions
Deleting an Attachment

Take me back to the Confluence User's Guide.

Attachment Versions

When viewing a list of attachments, a new version of an existing attachment can be added simply by uploading an attachment with the same filename on the attachment view. Click the blue arrow next to an attachment to display previous versions of the attachment.

Existing files will be kept with the name 'Version x', where the value of ‘x’ increments with each upload of an attachment with the same filename.

Screenshot: Attachment versions

<table>
<thead>
<tr>
<th>Attached Files</th>
<th>Name</th>
<th>Size</th>
<th>Creator</th>
<th>Creation Date</th>
<th>Last Mod. Date</th>
<th>Comment</th>
<th>Properties</th>
<th>Remove</th>
<th>Edit</th>
<th>View</th>
</tr>
</thead>
</table>

Some additional notes:
You cannot remove specific versions of an attachment — if you remove an attachment, all versions will be removed as well. (See feature request CONF-3079.)

You cannot revert to a previous version of an attachment. (See feature request CONF-1943.)

By default, attachments and their versions are stored in the `<confluence_home>/attachments` directory. (See Attachment Storage Configuration in the Administrator's Guide.) There is no limit to the number of attachments/versions, provided that there is enough disk space.

**Related Topics**

Attaching Files to a Page  
Moving an Attachment  
Viewing Attachment Details  
Working with Attachments

Take me back to the Confluence User's Guide.

### Deleting an Attachment

To delete an attachment, you require 'Remove Attachments' permission which is assigned by a space administrator from the Space Administration screens. See Space permissions or contact a space administrator for more information.

**To delete an attachment:**

1. Go to the page that contains the attachment.
2. Choose **Tools > Attachments** to go to the 'Attachments' view for the page.
3. Click **Remove** beside the attachment you want to delete.
4. Click **OK** to confirm your action.

**Related Topics**

Working with Attachments  
Finding an Attachment

Take me back to the Confluence User's Guide.

### Displaying a List of Attachments in a Page

Use Confluence's Attachments macro to display a list of the files attached to the current page. It will generate a table similar to that in the screenshot below.

#### On this page:

- Using the Attachments Macro
- Parameters
- Viewing and Editing Files from the Attachments Macro
- Attachment Information Icon
- Notes
- Related Topics

**Using the Attachments Macro**

**To add the Attachments macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filename Patterns</td>
<td>all</td>
<td>Filters the attachments to display, using a comma-separated list of regular expressions. So, to match a file suffix of 'jpg', use .*jpg, not *.jpg. Here's a <a href="#">detailed tutorial on regular expressions</a>.</td>
</tr>
</tbody>
</table>
Include Old Attachment Versions | false | Include previous attachment versions in the list.

Sort By | date | Specifies the sort order for attachments. Note that people viewing the page can change the sort order by clicking the column headings. Valid values are:

- **date** – sorts by reverse chronological order (newest first)
- **size** – sorts largest to smallest
- **name** – sorts alphabetically

Allow Upload | false | Provides the ability to browse for, and attach, new files.

### Viewing and Editing Files from the Attachments Macro

If an attachment is an Office or PDF file, you will see a **View** link as shown in the screen snippet below. Furthermore, if the attachment is an Office file, it will also have an **Edit** link.

**Screenshot: Office and PDF file page attachments showing the 'View' and 'Edit' links**

<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Creator</th>
<th>Creation Date</th>
<th>Last Mod Date</th>
<th>Comment</th>
</tr>
</thead>
</table>

Click **View** to view the content of the Office file within Confluence.

Click **Edit** to edit the content of the Office file in your Office application. You must have a compatible Office application installed to do this. Refer to [Working with the Office Connector](#) for more information.

### Attachment Information Icon

When a page you are viewing contains attachments, a small paperclip icon 📄 appears next to the page byline. Clicking the paperclip will take you to the ‘Attachments’ view, where the full list of attachments is displayed.

### Notes

The macro can only list the attachments on the current page. It is not possible to display attachments from another page. If you are interested in this feature request, please watch or vote for [CONF-6351](#).

### Related Topics

- Working with Attachments
- Working with Macros

Take me back to the [Confluence User’s Guide](#).

### Downloading Attachments

**To download a single attachment of a page:**

1. Choose **Tools > Attachments** to go to the ‘Attachments’ view for the page.
2. Right-click the link on the attachment name, and select **Save Link As**, **Save Target As** or a similar option provided by your browser. This will open a ‘Save’ dialog.
3. Select the directory into which you want to download the file and click **Save**.

**To download all the attachments of a page:**

1. Choose **Tools > Attachments** to go to the ‘Attachments’ view for the page.
2. Click the **Download All** button at the end of the page to download a zipped file of all the page’s attachments.

### Related Topics

- Working with Attachments
- Viewing Attachment Details

Take me back to the [Confluence User’s Guide](#).

### Editing Attachment Properties
To edit an attachment's properties, you need 'Create Attachments' permission which is assigned by a space administrator from the Space Administration screens. See Space Permissions or contact a space administrator for more information.

**To edit the properties of an attachment:**

1. Go to the page that contains the attachment.
2. Choose Tools > Attachments to go to the 'Attachments' view for the page.
3. Click the Properties link beside the attachment. This will display a new screen.
4. Make your changes:
   - **File Name** — Rename or modify the name of the attachment.
   - **New Comment** — Update the existing comment or enter a new comment.
   - **New Content Type** — Change the content type of the attachment by entering a valid MIME type.
   - **Page** — Move the attachment to another page.
5. Click OK.

**Screenshot: Editing an Attachment's Properties**

**Related Topics**

- Moving an Attachment
- Viewing Attachment Details
- Working with Attachments

Take me back to the Confluence User's Guide.

**Embedding Multimedia Content**

Using multimedia files you can display movies, animations, and videos, and embed audio files on your Confluence page. There are several methods for attaching files to a page. Once you have attached the multimedia file to a Confluence page, you then edit the page to set where the multimedia content should appear.

In the example below, we display a Flash file that is attached to this page.

Confluence supports the following multimedia formats:

- Adobe Flash (.swf)
- Apple QuickTime (.mov)
- Windows Media (.wma, .wmv)
- Real Media (.rm, .ram)
- MP3 and MP4 files (.mp3, .mp4)
- MPEG files (.mpeg, .mpg)
- AVI files (.avi) You may need to enable an avi decoder within your browser.
Quick guide to displaying multimedia content on a page

Choose one of these methods:

- **Add the macro yourself**: Attach the multimedia file to the page in the usual way. Add the Multimedia macro using the macro browser.
- **Autocomplete**: Attach the multimedia file to the page in the usual way. Type '!' in the editor and choose the multimedia file from the list that appears.
- **Drag and drop**: Drop the video or other file into the editor. Confluence will attach the file and insert the Multimedia macro for you.
- **Adjust parameters if necessary**: Click on the Multimedia macro placeholder to set options for the macro, such as adjusting the width or height of the display, or setting autoplay on.

Displaying a multimedia file attached to the page

Once you have attached a multimedia file to a page, there are different methods for choosing where on the page the multimedia content should appear:

**Inserting the Multimedia macro yourself**

You can add the Multimedia macro to the page yourself using the Macro Browser. This allows you to display a multimedia file that is attached to either the current page or to another page in the Confluence site.

**To insert the Multimedia macro on the page at the current cursor position:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Using autocomplete**

Once a multimedia file is attached to the page, you can use autocomplete, while editing the page, to choose where the multimedia content should appear.

**To position an attached multimedia file on the page using autocomplete:**

1. While editing the page, position the cursor where you want to place the multimedia content.
2. Trigger the autocomplete function by typing '!'.
3. Choose the multimedia file from the list that appears.
4. If necessary, click on the Multimedia macro placeholder and choose Edit to set various options such as the width, height or autoplay.

**Using drag-and-drop**

Depending on the browser you are using, you can attach and position a multimedia file in one step using drag-and-drop.

**To attach and position multimedia content using drag-and-drop:**

1. While you are editing a page, simply drag-and-drop the multimedia file on to the page. Confluence will attach the file to the page and insert the Multimedia macro at the current cursor position for you.
2. If necessary, click on the Multimedia macro placeholder and choose Edit to set various options such as the width, height or autoplay.

**Multimedia macro parameters**

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

197
Embedding PowerPoint Presentations in a Page

Below are some ideas on how your wiki page can include information from a Microsoft PowerPoint presentation.

On this page:

- Option 1 — Office Connector for Confluence
- Option 2 — Gallery or Slide Show of JPEG or PNG Images
- Option 3 — Convert PowerPoint to HTML
- Related Topics

Option 1 — Office Connector for Confluence

The Office Connector provides the most straightforward way to display PowerPoint slides.
To attach and display a PowerPoint presentation in Confluence:

1. **Attach the presentation to a Confluence page:**
   - View the Confluence page where you want to display your presentation.
   - Open the 'Tools' menu and select 'Attachments' menu.
   - Browse for your PowerPoint presentation and upload it to the Confluence page.
   You will find detailed instructions in [Attaching Files to a Page](#).
2. **Now you can display the document embedded into the Confluence page, using the View File macro.**
   Refer to the detailed instructions for the [View File macro](#).

   The Office Connector is shipped with Confluence 2.10 and later. The Office Connector plugin is supported for Confluence versions 2.8.0 and later.

---

**Option 2 — Gallery or Slide Show of JPEG or PNG Images**

1. Convert your PowerPoint pages into JPEG or PNG images, using 'save as' from PowerPoint (slide1.jpg, slide2.jpg...).
2. Upload the image files as attachments to your Confluence page. To upload in bulk, use the [WebDAV plugin](#).
3. Use the [Gallery macro](#) or the [Slideshow plugin](#) to render the images as a slide show in Confluence.

   Optionally, you could create a page template or a user macro that uses the Slideshow plugin, so that you do not have to code this into the wiki page each time you create a new show.

   The Slideshow plugin is not supported by Atlassian. Please weigh up your options carefully before deciding which way to go.

---

**Option 3 — Convert PowerPoint to HTML**

You can convert the PowerPoint file to web page format and embed the page inside your Confluence document.

1. Review the risks associated with enabling the [html-include macro](#) here.
2. If you decide to proceed, follow the instructions to enable embedded HTML pages using the macro.
3. Select an PowerPoint converter. There are at least two applications that can convert PPT to HTML:
   - [Producer for PowerPoint](#).
   - If you do not have the PowerPoint application on your machine, you can use the [Internet Assistant for Powerpoint](#) instead.
4. Download and install your chosen converter.
5. Follow the converter documentation to perform the HTML conversion. An Internet Assistant conversion guide can be found here. The conversion process will create a small collection of HTML pages. Each slide will have its own page, plus an index page with buttons to let you switch between slide pages.
6. If you wish, you can test the HTML presentation now by loading the index page in your browser.
7. Place the HTML files into their own directory, named uniquely by the title of your presentation.
8. Find a suitable location to host these files within your web server. Confluence hosts all files within the `<my-install-directory>/confluence/pages/` directory, so a good example location for Confluence standalone users is to go to `<my-install-directory>/confluence/pages/powerpoint` and create a subdirectory called 'powerpoint'.
9. Move the HTML directory into the PowerPoint folder, e.g.
   `<my-install-directory>/confluence/pages/powerpoint/<my-presentation-name>` containing index.html, slide01.html... or similar.
10. Edit or create the page where you wish to embed the PowerPoint presentation. Add the HTML Include macro pointing to the index page of your slides. Remember that URLs are case sensitive.
11. Save the page. The index page to your slides should now appear.

---

**Related Topics**

- Working with the Office Connector
- Working with Attachments

Take me back to [Confluence User's Guide](#)
Finding an Attachment

To find an attachment, you can search the list of attachments in a space or the attachments on a specific page.

To find an attachment associated with a space:

1. Go to a page in the space and choose Browse > Attachments.
2. This will display a list of all attachments in the space.
3. Browse through the list to locate the attachment.
4. You can choose to view only files of a particular type:
   - Type the last part of the file name in the Filter By File Extension box. For example, enter ‘gif’ to see only image files of the GIF format.
   - Click Filter.
5. You can view the attachment itself or the page to which it is attached by clicking on the corresponding link.

Screenshot : Space Attachments

To find attachments associated with a page:

1. Choose Tools > Attachments to go to the 'Attachments' view for the page.
2. This will display a list of all files attached to the page.
3. Click the attachment's linked name to view its contents in your computer's associated application.
   - This is different from clicking an Office or PDF file's View link, which opens the file for viewing in Confluence itself.

Screenshot : Page Attachments

Handy Hint

If you know the title of an attachment, you might find it faster by doing a Quick Search.

Related Topics

- Working with attachments
- Attaching Files to a Page
- Viewing Attachment Details
- Deleting an Attachment
- Browsing a space

Take me back to Confluence User's Guide

Moving an Attachment
You can move an attachment from its current location to any page within the site.

To move an attachment, you need the following permissions:

- Edit page permission on the page where the attachment currently exists.
- Create attachment permission on the space into which you are moving the attachment.

Space permissions are assigned by a space administrator from the Space Administration screens. See Space permissions or contact a space administrator for more information.

To move an attachment:

1. Go to the page that contains the attachment.
2. Choose Tools > Attachments.
3. Click the Properties link beside the attachment. This will display a new screen, where you can edit the properties of an attachment.
4. Select the page where you want to move the attachment by either:
   - Entering the page's title into the Page field
   - Clicking the Choose a Page icon and using the 'Choose a Page' pop-up window to choose a page within the site.
5. Click OK.

Screenshot: Moving an attachment

Related Topics

Moving a Page

Choose a Page

The 'Choose a Page' window allows you to locate a page in your Confluence site. The window appears when you are moving an attachment.

To choose a page:

1. Click the page picker icon to display the 'Choose a Page' window. You will see the following tabs:
   - Search: Allows you to search for your page in all Confluence spaces.
   - History: Displays a list of pages recently visited by you.
   - Recently Modified: Displays pages most recently modified by you.
   - Referring Pages: Displays a list of all pages that refer to the current page.
2. Select the required page from the list of pages in one of the tabs.

Related Topics

Moving an Attachment

Viewing Attachment Details

There are two places in Confluence where you can view attachment details:
• View the list of attachments in a space — this will show all files/images attached to all pages in the space.
• View the list of attachments for a specific page.

Viewing Attachments in a Space

To view the attachments associated with a space:

1. Go to a page in the space and choose Browse > Attachments.
   
   This displays a list of all the attachments in the space, along with their details and the pages they are attached to.

2. You can choose to view only files of a particular type:
   • Type the last part of the file name in the Filter By File Extension box. For example, enter 'gif' to see only image files of the GIF format.
   • Click Go.

Screenshot: Space Attachment Details

Viewing Attachments on a Page

To view the attachments associated with a page:

1. Go to the page.

2. Choose Tools > Attachments to go to the 'Attachments' view for the page.

   This will display a list of all the attachments in the page along with their details. For each attachment, links are also provided to edit the attachment's details and to delete the attachment.

Screenshot: Page Attachment Details

In the screenshot above, Fred Ferdinando created the first version of Example Word 2007 Doc.docx. Administrator uploaded the second version and Fred Ferdinando added the third (current) version.

Attachment Details

The attachment views show the following fields. (The page view shows a different subset of fields from the space view.)
• **Name** is the name of the attached file.
• **Size** tells you how much space the attachment takes up. You can sort by size by clicking the column title.
• **Creator** is the user who attached this file. The person who uploaded each new version of a file will be acknowledged as the creator of that version. Clicking on the link takes you to their profile.
• **Creation Date** is the date the file was attached. You can sort by date by clicking the column title.
• **Last Mod. Date** is the date the file was last modified. Please refer to definition of Last Modifier for a list of actions that qualify as a modification.
• **Attached To** (in the space view) tells you which page contains the attachment.
• **Comment** (in the page view) is a short description of the attachment.
• The **Properties** link (in the page view) lets you edit the attachment details.
• The **Remove** link (in the page view) lets you delete the attachment.
• The **Edit** link (in the page view) only appears next to Office files and lets you edit that attachment directly from the list of attachments. See Viewing and Editing Attached Files.
• The **View** link (in the page view) only appears next to Office and PDF files and lets you view that attached attachment directly from the list of attachments. See Viewing and Editing Attached Files.

### Viewing and Editing Attached Files

If an attachment is an Office or PDF file, you will see a **View** link as shown in the screen snippet below. Furthermore, if the attachment is an Office file, it will also have an **Edit** link.

**Screenshot: Office and PDF file page attachments showing the 'View' and 'Edit' links**

<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Creator</th>
<th>Creation Date</th>
<th>Last Mod. Date</th>
<th>Comment</th>
<th>Properties</th>
<th>Remove</th>
<th>Edit</th>
<th>View</th>
</tr>
</thead>
</table>

Click **View** to view the content of the Office file within Confluence.

Click **Edit** to edit the content of the Office file in your Office application. You must have a compatible Office application installed to do this. Refer to Working with the Office Connector for more information.

### Attachment Information Icon

When a page you are viewing contains attachments, a small paperclip icon 🔄 appears next to the page byline. Clicking the paperclip will take you to the 'Attachments' view, where the full list of attachments is displayed.

### Related Topics

- Working with Attachments
- Displaying a List of Attachments in a Page
- Finding an Attachment
- Editing Attachment Properties
- Deleting an Attachment
- Browsing a space

Take me back to the Confluence User's Guide.

### Customising Confluence

You can customise or configure many aspects of Confluence:

- The look and feel of any Confluence space.
- Personal aspects, including your personal profile and homepage.
- Setting up your user profile.
- User access, including permissions and page restrictions.
- Add-ons such as gadgets and macros.
- Customisations for specific uses of Confluence.

### Related Topics

- Configuring Confluence
- Configuring Confluence Security

Take me back to the Confluence User's Guide.

### Personal Customisations

There are several ways that you can customise the way that Confluence works for you, personally, including:
User Profile Overview

Each Confluence user has a User Profile area, where numerous account management features can be accessed.

Finding your User Profile

Go to your name (the ‘User’ menu) at the top of the page and choose Profile.

The profile view is divided into tabs, each of which is described in a separate section below.

On this page:

- Finding your User Profile
- Profile
- Network
- Status Updates
- Labels
- Watches
- Drafts
- Settings

Screenshot: User profile

Giles Gaskell

Profile

About Me

I'm a Technical Writer at Atlassian. I started working at Atlassian back in December 2006 and focus mainly on documenting new features for Confluence. In my spare time, I enjoy participating in traditional Indonesian 'gamelan' orchestral groups. This is one of my favourite instruments - the 'rebana'.

Activity

Giles Gaskell profile updated less than a minute ago
reong.png attached 19 minutes ago

"Touching up Community-based features." yesterday at 1:53 PM

Drafts for Confluence 3.0 forum announcements - including Advanced Warnings updated May 25

AODC conference happened and was good commented May 25
The 'Administer User' link is visible to Confluence administrators only. The administrator can click this link to go directly to the user management screen in the Administration Console.

**Profile**

- View and edit your personal details, such as your name and email address details and optionally, your photograph and other personal information. Note that as a security precaution, in order to change your email address, you will be required to re-enter your password.
- Upload a profile picture (optional).
- Change your password.

**Network**

- View the recent activity of users that you are following via the Network view.
- Follow other users from this view.

**Status Updates**

- View your history of status updates.

**Labels**

- View your personal labels.

**Watches**

- View a list of the pages and spaces you are currently watching.

**Drafts**

- Retrieve any pages you were in the process of editing. See Working with Drafts.

**Settings**

- Edit your General Settings (homepage, language and timezone).
- Subscribe to email notifications.
- View and revoke your OAuth access tokens.

**Related Topics**

- Watching Changes
- Setting up your Personal Space

Take me back to the Confluence User's Guide.

**Changing Password**

To change your Confluence password:

1. Go to your name (the 'User' menu) at the top of the page and choose Profile.
2. On your Profile tab, click Password in the left-hand column.
3. Enter your current password and your new password in the form displayed.
4. Click Submit.

Related Topics

- Viewing User Profile
- Editing Your User Profile
- Choosing a Profile Picture
- Setting up your Personal Space
- Updating Email Address
- Email Address Privacy

Take me back to the Confluence User's Guide.

**Editing User Settings**

You can set various Confluence preferences that affect your personal session:

- General preferences such as home page, language and time zone, as described below.
- Editor settings, as described below.
- Email settings for subscriptions to Email Reports.
OAuth access tokens that you have granted from your Confluence user account. Please refer to Viewing and Revoking OAuth Access Tokens.

On this page:

- General User Preferences
- Language
- Editor Preferences
- Email Notification Settings
- Related Topics

**General User Preferences**

To edit your general user settings:

1. Go to your name (the 'User' menu) at the top of the page and choose Settings.
2. Click Edit and make general settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site Homepage</td>
<td>Select the page that you would like to see whenever you log into Confluence.</td>
</tr>
<tr>
<td>Language</td>
<td>Select your language. See below.</td>
</tr>
<tr>
<td>Time zone</td>
<td>Select your time zone.</td>
</tr>
<tr>
<td>Use Keyboard Shortcuts</td>
<td>Enable keyboard shortcuts, other than for the editor.</td>
</tr>
</tbody>
</table>

3. Click Submit.

**Language**

Setting your language preference in your user profile is described in the section above. This section gives more information about that setting and other settings that affect the language Confluence will use.

Individual users can choose the language that Confluence will use to display screen text and messages. Note that the list of supported languages depends on the language packs installed on your Confluence site.

The language used for your session will depend on the settings below, in the following order of priority from highest to lowest:

- The language preference defined in your user profile. Note that you need to be logged in for this setting to take effect.
- The language that you choose by clicking an option at the bottom of the Confluence login screen. Confluence stores this value in a cookie. When the cookie expires, the setting will expire too.
- The language set in your browser:
  - Note that your Confluence administrator can disable this option by setting a system property.
  - The browser sends a header with a prioritised list of languages. Confluence will use the first supported language in that list.
- The default language for your site, as defined by your Confluence site administrator.
**Editor Preferences**

You can set some options that determine the way the Confluence editor works. Note that these settings affect only you. Other people using Confluence can enable or disable the settings on their user profiles independently.

To change your editor preferences:

1. Go to your name (the 'User' menu) at the top of the page and choose Settings.
2. Click Editor under "Your Settings" in the left-hand panel.
3. Click Edit.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable Autocomplete</td>
<td>Select to disable autocomplete when you press one of the trigger characters.</td>
</tr>
<tr>
<td>Disable Autoformatting</td>
<td>Select to disable autoformatting when you type wiki markup in the editor.</td>
</tr>
</tbody>
</table>

4. Click Submit.

**Email Notification Settings**

You can 'watch' a page, a blog post or a space. Confluence will then send you a notification by email whenever anyone adds or updates content on that page, blog post or space. You can also subscribe to daily email reports and other notifications of various updates, as described below. See Watching Changes.

You will only receive notifications for content that you have permission to view. Users who have been disabled by an administrator will not receive email notifications.

For instructions on configuring an email server so that Confluence can send email notifications, see the administrator's guide to Configuring a Server for Outgoing Mail.

To edit your email notification settings:

1. Go to your name (the 'User' menu) at the top of the page and choose Settings.
2. Click Email in the left-hand panel.
3. Click Edit.

Each email setting is explained below:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Content</th>
<th>Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autowatch</td>
<td>Automatically watch content for future changes.</td>
<td>• Pages and blog posts that you create, edit or comment on.</td>
<td>Immediately</td>
</tr>
</tbody>
</table>
Subscribe to daily updates

Receive email reports showing changes to content in all spaces that you have permission to view.

Note: Daily email reports do not include information about attachments on a page or blog post that are added, edited or deleted.

- Pages and blog posts that are added, edited or deleted.
- Comments on a page or blog post that are added, edited or deleted.
- Updates by users who have changed their personal profile.

Daily

Subscribe to all blog posts

Receive email notifications for changes to blogs in your Confluence installation that you have permission to view.

- Blog posts added, edited or deleted.

Immediately

Subscribe to network

Receive email notifications for changes to content by all users that you are following, which you have permission to view.

- Pages being added, edited or deleted.
- Blog posts being added, edited or deleted.
- Comments being added, edited or deleted.
- Status updates by the user.

Immediately

Subscribe to new follower notifications

Receive an email when anyone chooses to follow you.

Immediately

Notify on my actions

Receive email notifications for your own changes.

Note: If you have not subscribed to any email notifications and are not watching any pages/spaces, then selecting 'Notify on my actions' will not do anything.

- All pages and spaces that you are watching.
- This affects all subscriptions set.

Immediately

Show changed content

Notifications will include details of the changes made to the content. See Page History and Page Comparison Views.

- Edits to pages and blog posts.

Immediately

Related Topics

Editing Your User Profile
Choosing a Profile Picture
Setting up your Personal Space
Email Address Privacy
Using Autocomplete

Take me back to the Confluence User’s Guide.

Editing Your User Profile

Your user profile contains basic information about you. If you do not have a personal space, your user profile will be displayed when anyone clicks your name in the People Directory.

To edit your user profile:

1. Go to your name (the ‘User’ menu) at the top of the page and choose Profile.
2. On your Profile view, click Edit in the Personal details section.
3. Enter details about yourself in the form displayed.
4. Click Save.

<table>
<thead>
<tr>
<th>Detail</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Name</td>
<td>Your name as you would like it to appear in your profile.</td>
</tr>
<tr>
<td>Email</td>
<td>Your email address which will be used to send you mail notifications.</td>
</tr>
<tr>
<td>Phone</td>
<td>Your phone number.</td>
</tr>
</tbody>
</table>
IM | Your Instant Messenger (IM) details.

To suit a variety of IM applications, this option accepts any string value. For example, you can enter IM details in the form of an email address, such as ' or a user ID, like '123456789'.

Website | Your website’s URL.

Position | The title of your position within your organisation.

Department | The name of your department within your organisation.

Location | Your location. This could be a town, city, region or country.

About me | Information about yourself that other users can view (such as your professional information, hobbies, and other interests). You can use Confluence wiki markup in this field.

Note that your Username cannot be changed.

---

**Fred Ferdinando**

**Profile**

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Name</td>
<td>Fred Ferdinando</td>
</tr>
<tr>
<td>Email</td>
<td><a href="mailto:fredfer@example-company.com">fredfer@example-company.com</a></td>
</tr>
<tr>
<td>Phone</td>
<td>+61 0 1234 5678</td>
</tr>
<tr>
<td>IM</td>
<td><a href="mailto:fredfer@chat.example-company.com">fredfer@chat.example-company.com</a></td>
</tr>
<tr>
<td>Website</td>
<td><a href="http://www.example-company.com/">http://www.example-company.com/</a></td>
</tr>
</tbody>
</table>

**About Me**

I completed a Masters in Mathematical Linguistics at the University of Cape York.

**Company**

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position</td>
<td>Production Manager</td>
</tr>
<tr>
<td>Department</td>
<td>Management</td>
</tr>
<tr>
<td>Location</td>
<td>Sydney</td>
</tr>
</tbody>
</table>

---

**Handy Hint**

Confluence administrators can configure Confluence to mask email addresses (e.g. ‘example at atlassian dot com’), protecting your email address from search engine spiders and the like.
Email Address Privacy

Confluence can mask the email addresses of users to protect them from mail spammers.

This is done by a Confluence administrator and is configured through the Administration Console. The Confluence administrator has three options for email address privacy:

- **Public**: email addresses are displayed publicly.
- **Masked**: email addresses are still displayed publicly, but masked in such a way to make it harder for spam-bots to harvest them.
- **Private**: only Confluence administrators can see the email addresses.

For more information on setting these options, which are configured using the Administration Console, refer to User Email Visibility.

Updating Email Address

The email address you specify in your profile settings is used for your mail notifications and is also displayed in your profile description.

To update your email address:

1. Go to your name (the 'User' menu) at the top of the page and choose Profile.
2. Click Edit in the 'Personal' section.
3. In the Email field, specify your new email address which will be used when sending you mail notifications.
4. Click Save.

Choosing a Profile Picture

Your profile picture is used as the icon for your personal space, to represent you in the People Directory, and to illustrate your comments. It also appears in various other places next to your name, such as in the list of recent updates on the dashboard.

You can upload your own profile picture or use one of the images provided by Confluence. If you upload your own profile picture, you will have an opportunity to crop (trim) the picture.

To choose a profile picture:

1. Go to your name (the 'User' menu) at the top of the page and choose Profile.
2. Click Picture on the left.
3. Choose one of the following two options:
   - Upload a new picture: Click Browse to locate your picture, then click Upload to upload it from your computer or file server.
   - Or select one of the default icons provided.
4. Click Set Profile Picture.

Screenshot: Choosing a profile picture
If you upload a profile picture that is larger than 48x48 pixels, the 'Edit My Profile Picture' screen will appear. You can select part of the picture or the entire picture, to be used as the final image for your profile. Note that the size of the final image will always be scaled down to 48x48 pixels.

To edit your profile picture:

1. Click and drag the centre of the superimposed square to select the centre of the new image.
2. Click the corners of the square to resize the area for your new image.
3. Click **Save**.
4. The image from your selected area will be cropped, resized to 48x48 pixels and saved.

*Screenshot: Trimming a profile picture*
Deleting a Profile Picture

You can delete the profile picture images that you have uploaded to Confluence.

To delete a profile picture:

1. Go to your name (the ‘User’ menu) at the top of the page and choose Profile.
2. Click Picture on the left.
3. Locate and select the picture file you wish to delete, then click Delete.
4. Click Delete to confirm the action. The picture is permanently removed from the server.

Note that you can only delete images that you have uploaded to Confluence. The standard icons cannot be deleted.
A Confluence User's Profile view shows details about that person and lists their recent activity. If you are viewing your own Profile view, you can also update your profile picture and login password. If you are viewing another user's Profile view, you can add them to your Network of users you are following and if they have set up a Personal Space, you can add this to your list of Favourites.

To access your User Profile view:

- Go to your name (the 'User' menu) at the top of the page and choose Profile.
Updating your Profile

You can update the following aspects of your Profile from this view:

- **Information about yourself** - to modify these details, see [Editing Your User Profile](#).
- **Your Profile picture** - to change your Profile picture or upload a new one, see [Choosing a Profile Picture](#).
- **Your login password** - to change your login password, see [Changing Password](#).

You can switch between your Profile, Profile picture update and login password update views by clicking the 'Details', 'Picture' and 'Password' links in the left-hand column, respectively.

**Related Topics**

*Editing Your User Profile*

Take me back to the [Confluence User’s Guide](#).

**Viewing and Revoking OAuth Access Tokens**

This page describes the purpose of OAuth access tokens which have been issued on behalf of your Confluence user account and provides instructions on how to revoke them.

**On this page:**

- OAuth Access Tokens
- Viewing your OAuth Access Tokens
  - OAuth Access Token Details
- Revoking your OAuth Access Tokens

**OAuth Access Tokens**

OAuth access tokens allow you to use a Confluence gadget on an external web application or website (also known as the 'consumer') and grant this gadget access to Confluence data which is restricted or privy to your Confluence user account.
OAuth access tokens will only appear in your user profile if the following conditions have been met:

1. Your Confluence Administrator has established an OAuth relationship between your Confluence site and the consumer. Confluence Administrators should refer to Configuring OAuth for more information about establishing these OAuth relationships.
2. You have accessed a Confluence gadget on the consumer and have conducted the following tasks:
   a. Logged in to your Confluence user account via the gadget and then,
   b. Clicked the 'Approve Access' button to allow the gadget access to data that is privy to your Confluence user account.

   Confluence will then send the consumer an OAuth 'access token', which is specific to this gadget. You can view the details of this access token from your Confluence site's user account.

   An OAuth access token acts as a type of 'key'. As long as the consumer is in possession of this access token, the Confluence gadget on the consumer will be able to access Confluence data that is both publicly available and privy to your Confluence user account. As a Confluence user, you can revoke this access token at any time. Furthermore, all access tokens expire after seven days. Once the access token is revoked or has expired, the Confluence gadget will only have access to publicly available Confluence data.

**Viewing your OAuth Access Tokens**

To view all of your Confluence user account's OAuth access tokens:

1. Go to your name (the 'User' menu) at the top of the page and choose Settings.
2. Click View OAuth Access Tokens. A view similar to screenshot below is displayed. Refer to OAuth Access Token Details below for information on interpreting this table.

   If no access tokens have been set, then 'None specified' is shown.

**Screenshot: Viewing your OAuth Access Tokens**

<table>
<thead>
<tr>
<th>Consumer</th>
<th>Consumer Description</th>
<th>Issued On</th>
<th>Expires On</th>
<th>Actions</th>
</tr>
</thead>
</table>

**OAuth Access Token Details**

Your list of OAuth access tokens is presented in a tabular format, with each access token presented in separate rows and each property of these tokens presented in a separate columns:

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Consumer</td>
<td>The name of the Confluence gadget that was added on the consumer.</td>
</tr>
<tr>
<td>Consumer Description</td>
<td>A description of this consumer application. This information would have been obtained from the consumer's own OAuth settings when an OAuth relationship was established between Confluence and that consumer. If the consumer is another Atlassian application, this information is obtained from the Consumer Info tab's 'Description' field of the OAuth Administration settings. The application's administrator can customise this Consumer Info detail.</td>
</tr>
<tr>
<td>Issued On</td>
<td>The date on which the OAuth access token was issued to the consumer by Confluence. This would have occurred immediately after you approved this gadget access to your Confluence data (privy to your Confluence user account).</td>
</tr>
<tr>
<td>Expires On</td>
<td>The date when the OAuth access token expires. This is seven days after the 'Issued On' date. When this date is reached, the access token will be automatically removed from this list.</td>
</tr>
<tr>
<td>Actions</td>
<td>The functionality for revoking the access token.</td>
</tr>
</tbody>
</table>
**Revoking your OAuth Access Tokens**

To revoke one of your OAuth access tokens:

1. View your Confluence user account's OAuth access tokens (described above).
2. Locate the Confluence gadget whose OAuth access token you wish to revoke and click **Revoke OAuth Access Token** next to it.
   - The gadget's access token is revoked and the Confluence gadget on the consumer will only have access to publicly available Confluence data.

**Choosing Your Homepage**

By default, all users are directed to the Dashboard after logging in. However, you can choose to be redirected to the home page of any space on the Confluence site after logging in.

To set the home page:

1. Click on your name (the 'user' menu) at the top of the page and choose **Settings**.
2. Click **Edit**.
3. Use the **Site Homepage** list to select a space. Note that only the list of spaces to which you have 'view' access is displayed here.
   - You will be directed to the home page of the selected space when you next log in.
4. Click **Submit**.

**Screenshot: General Preferences Settings**

![General Preferences Settings](image)

**Related Topics**

- User Profile Overview
- Space Homepage

Take me back to **Confluence User's Guide**

**Customising your Personal Dashboard**

You can customise the Confluence dashboard to provide access to the content on the site that is most relevant to you. The options described on this page will change your own personal dashboard, but will not affect the dashboard that other people see.

If you are a Confluence Administrator, you can change the global dashboard, as seen by all Confluence users. See the administrator's guide to customising the dashboard.

**On this page:**

- Displaying your Favourite Spaces
- Categorising your Spaces
- Displaying your Favourite Pages
- Related Topics

**Displaying your Favourite Spaces**

Mark some spaces as **favourites**. You can now click the **Spaces** tab on the dashboard to see a list of your favourite spaces. You can also click the **Favourite Spaces** tab at the top right of the dashboard to see recently updated content from just your favourite spaces.

**Categorising your Spaces**

To help keep Confluence spaces organised, you can label spaces with different space categories. See **Using Labels to Categorise Spaces**. Space categories are used to group related spaces.
For example, you might want to group spaces on your Confluence site by applying the following space categories to the relevant spaces:

- ‘design’ (for spaces relevant to a design team), and
- ‘development’ (for spaces relevant to a development team).

If a subset of these spaces is relevant to both teams, apply both the ‘design’ and ‘development’ categories to each of these spaces to make the spaces appear in both groups.

Once you have added space categories, you can click the Space Categories tab at the top right of the dashboard and select a category from the drop-down menu to display only spaces belonging to that category.

Displaying your Favourite Pages

Mark some pages as favourites. You can now click the Pages tab on the dashboard to see a list of your favourite pages.

Screenshot: The dashboard, showing favourite pages and space categories

Customising the Look and Feel

Confluence allows you to customise the ‘look and feel’ of an individual space on the Confluence instance through options available in the Space Administration menu. By default, the look and feel of a space is based on global settings configured from the Administration Console.

You need to be a space administrator to edit the look and feel of a space.

- Applying a Theme to a Space
- Changing a Space’s Logo
- Changing the Confluence Browser Icon
- Customising Layouts for a Space
- Editing a Space’s Colour Scheme
- Styling Confluence with CSS

Related Topics

Browsing a space
Administrator's Guide - Design and Layout

Applying a Theme to a Space
Themes allow you to personalise the 'look and feel' of Confluence. You can apply a theme to your entire Confluence site and to individual spaces. Choose a specific theme if you want to add new functionality or significantly alter the appearance of Confluence.

Confluence comes with a selection of themes. In addition, a site administrator can install new themes as plugins via the Confluence Administration Console. Provided that the theme is installed into your Confluence site, any space administrator can apply a theme to a space.

By default when you create a new space, the space will have the Confluence default theme.

To apply a theme to a space:

1. Choose Browse > Space Admin. 
   * Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Themes in the left-hand panel under 'Look and Feel'.
3. Select a theme option.
4. Click Confirm.

**Screenshot: Applying a theme**

**Related Topics**

Applying a Theme to a Site
Editing a Space's Colour Scheme
Customising the Look and Feel

Take me back to Confluence User's Guide

**Configuring the Documentation Theme**

The Documentation theme is one of the themes bundled with Confluence. (See availability below). The theme is designed for spaces containing technical documentation, but you may find it useful for other types of content too. It provides an inbuilt table of contents for your wiki space, a configurable header and footer, and text styles suited to documentation. (See features below.)
Quick guide to applying and customising the Documentation theme

- Go to Space Admin and click Themes.
- Select Documentation Theme and click Confirm.
- If you want to customise the theme, click Configure theme.
  - Select or deselect the default page tree.
  - Select or deselect the space-restricted search.
  - Enter the text and wiki markup for your custom left-hand panel header and footer.
  - Click Save.

The rest of this page gives more details of the above procedure.

On this page:
- Applying the Documentation Theme to your Space
- Applying the Documentation Theme to your Site
- Customising the Documentation Theme
- Features of the Documentation Theme
- Availability of the Theme
- Hints and Tips
- Related Topics

Screenshot: A wiki page using the Documentation theme

Applying the Documentation Theme to your Space

You need space administrator permissions to apply a theme to a space.

Follow the steps below to apply the 'Documentation Theme' to your space. All pages in the space will start using the theme immediately.

To apply a theme to a space:

1. Choose Browse > Space Admin.

   Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. Click **Themes** in the left-hand panel under 'Look and Feel'.
3. Select a theme option.
4. Click **Confirm**.

**Screenshot: Applying a theme**

---

**Applying the Documentation Theme to your Site**

If you have site administrator permissions, you can apply the theme at site level. It will then be the default theme for all spaces in the site. See the administrator's guide to applying a theme.

**Customising the Documentation Theme**

The theme works well without any customisation. If necessary, you can restrict the search to just one space, change the content of the left-hand navigation panel and add your own header and footer.

**To customise the Documentation theme:**

1. Choose **Browse > Space Admin**.
   - **Space Admin** is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. Click **Themes** in the left-hand panel under the heading 'Look and Feel'.
3. If the space is not yet using the Documentation theme, apply the theme as described above.
4. Click **Configure theme** in the yellow area of the 'Current Theme' section at the top of the page. See screenshot below. The 'Documentation Theme Configuration' screen appears. See screenshot below.
5. Select or deselect the **Page Tree** check box. This determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.
6. Select or deselect the **Limit search results to the current space** check box.
   - If you select the check box:
     - The Confluence search will look for matches only in the current space by default. Users can override this restriction when entering their search term. See Using the Documentation Theme.
     - The default page tree in the left-hand panel will not include a search box.
   - If you do not select the check box:
     - The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
     - The default page tree in the left-hand panel will include a search box, which restricts search results to the current space.
7. Enter text, images, macros and other wiki markup into any or all of the three text boxes.
   - You can use the **Include** or **Excerpt Include** to include re-usable content into your footer. See hint below.
   - **Navigation** – This text box contains content for the left-hand panel.
   - If the **Page Tree** check box is selected, the navigation panel contains the default search box and page tree. Any content you enter into the 'Navigation' text box will appear above the page tree and search box.
   - You can include your own content underneath the page tree as well as above. See hint below. In summary:
Deselect the Page Tree check box. Insert your own page tree using the Pagetree macro, then add your own content under the macro.

- 'Header' – This text box contains content for a page header that will appear above the page title on all pages in the space. See example screenshot below.
- 'Footer' – This text box contains content for a page footer that will appear after the comments and above the site footer, on all pages in the space. See example screenshot below.

8. Click Save.

Screenshot: The 'Configure theme' option

![Configure theme - further customise this theme's options]

Screenshot: Customising the Documentation theme

![Documentation Theme Configuration]

- **Navigation**
  - Page Tree
    - Show the page tree in the sidebar.
  - Limit search results to the current space
    - Limit search results returned by the top right search field to the current space.

- **Messages**
  - **Header**
    - ![Info]
    - This documentation relates to (except/includes): Major Release Number (optional).
    - If you are using an earlier version, please view the [previous versions of the Crowd documentation](http://confluence.atlassian.com/crowd/documentation#downloads).
    - ![Info]
    - Display a banner or text at the top of every page in this space by entering wiki markup here.
  - **Footer**
    - ![Include]
    - ![Include]
    - Display a banner or text at the bottom of every page in this space by entering wiki markup here.
Customising the Theme at Site Level

If you have site administrator permissions, you can apply and customise the theme at site level. The customisation options are the same as the space level options, as described above.

Features of the Documentation Theme

Screenshot: A customised header, footer and left-hand panel

The above screenshot shows a wiki space with a customised left-hand panel, header and footer.

Here is a summary of the features that the Documentation theme provides:

- By default, the left-hand panel contains a search box and a table of contents (page tree) showing all the pages in your space. Specifically, it shows the pages that are children of the space’s home page.
- The left-hand panel is fully customisable. You can choose to include or exclude the search box and page tree. You can enter your own text, images and wiki markup.
- People viewing the page can drag the thick bar between the left-hand panel and the content, to increase or decrease the width of the panel. They can also remove the panel altogether, by clicking the sidebar icon at top right, next to the search box.
- The left-hand and right-hand panels scroll independently of each other.
- The page title is neatly above the page content, and not uncomfortably above the navigation panel as tends to happen when you insert the navigation panel yourself.
- Because the left-hand panel is part of the theme, it will be upgraded whenever Confluence is upgraded. There is no need to remove and then re-apply your customisations on each upgrade, as you would do if you added your own left-hand navigation bar.
- The theme also provides a customisable header and footer, which will appear at the top and bottom of every page.
- The text and heading styles are designed to enhance the content typically found in a documentation space.
- You can use the Space Jump macro to link from a page in one wiki space to a page with the same name in another space, without knowing the name of the page when you create the link.
- You can limit the Confluence search results to the current space. If you choose this option, the Confluence search will look for matches only in the current space by default. Users can override the restriction. See Using the Documentation Theme.
Availability of the Theme

Confluence Versions

The Documentation theme is bundled with Confluence 3.2 and later. If you have Confluence 3.1, your Confluence Administrator can download the theme from the Atlassian Plugin Exchange and install it as a plugin.

The theme is not available for versions of Confluence earlier than Confluence 3.1.

Hints and Tips

Below are some hints that you may find useful when using the Documentation theme. Where can I see a working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme's table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page. Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

Cause 1: Your pages are not under the space’s home page. The most probable reason why your pages do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space’s home page. If your pages are above the home page in the page tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

- You can change the designated space home page in the space administration section.
- Or you can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the ‘Pages’ section of the space ‘Browse’ screen. See Moving a Page.

Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with Documentation theme bundled. If your existing Confluence installation already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar icon at top right, next to the search box. Click the icon again to restore the panel.

Hiding Pages from the Left-Hand Table of Contents

You can ‘hide’ pages by putting them at the same level as or higher than the space home page.

Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page.

If your documentation pages are at the same level as the space home page, they will not appear in the left-hand navigation bar. So you can ‘hide’ pages by putting them at the same level as or higher than the space home page. The pages will show up in the search results and people can see the content if they open the page, but the pages will not appear in the left-hand panel.

More detail: The theme uses the Pagetree macro to produce the table of contents. When entering the Pagetree macro, you can choose the top page in the page tree. The Documentation theme chooses the space home page as the top page.

Using reusable Content in your Header, Footer or Left-Hand Panel

You can use any text or wiki markup in your theme header, footer or left-hand panel. One useful hint is to use the Include or Excerpt Include to include re-usable content into your footer.

The screenshot above shows the theme customisation options, with examples of the macros used to include content from other pages. And the example screenshot also above shows the resulting header, footer and left-hand panel.

Adding Content Below the Page Tree in your Left-Hand Panel

If you want to include your own content underneath the page tree, you can deselect the ‘Page Tree’ check box, add your own page tree using the Pagetree macro in the ‘Navigation’ text box, and then add your own content under the macro.
Adding Underlines to your Links

By default, the Documentation theme does not underline hyperlinks. If you prefer to have your links underlined, you can edit the CSS stylesheet for your space and add the following CSS code:

```
.wiki-content a:link, .wiki-content a:visited, .wiki-content a:active {
  text-decoration: underline;
}
```

To edit a space’s CSS style sheets:

1. Choose Browse > Space Admin. Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. Click Stylesheet in the left-hand panel under the heading 'Look and Feel'.
3. Click Edit.
4. Paste your custom CSS into the text field.
5. Click Save. The new CSS will be visible on all content pages in the space.

Jumping to the Same Page in Another Space

The {spacejump} macro is provided along with the Documentation theme. You can use space jumping to link from a page in one wiki space to a page with the same name in another space, without knowing the name of the page when you create the link. When a reader is viewing a page and clicks the link provided by the macro, they will go to a page with the same name, but in the space specified in the macro. See more about the Space Jump macro.

**Related Topics**

Using the Documentation Theme
Space Jump Macro
Applying a Theme to a Space
Applying a Theme to a Site
Editing a Space’s Colour Scheme
Customising the Look and Feel

Take me back to Confluence User's Guide

**Configuring the Easy Reader Theme**

The Easy Reader theme is one of the themes bundled with Confluence. This is a fixed-width variation of the default Confluence theme. Its larger fonts, smooth gradient background and comfortable line length make it ideal for displaying and reading longer documents.

**Quick guide to applying the Easy Reader theme**

1. Choose Space Admin > Themes.
2. Select Easy Reader Theme.
3. Click Confirm.

The rest of this page gives more details of the above procedure.

**On this page:**

- Applying the Easy Reader Theme to your Space
- Customising the Look and Feel of the Easy Reader Theme
- Hints and Tips
- Related Topics

**Screenshot:** A wiki page using the Easy Reader theme
You need space administrator permissions to apply a theme to a space.

**Applying the Easy Reader Theme to your Space**

Follow the steps below to apply the 'Easy Reader Theme' to your space. All pages in the space will start using the theme immediately.

**To apply a theme to a space:**

1. Choose Browse > Space Admin.
   
   Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Themes in the left-hand panel under 'Look and Feel'.
3. Select a theme option.
4. Click Confirm.

_Screenshot: Applying a theme_
Applying the theme to your entire Confluence site

If you have site administrator permissions, you can apply the theme at site level. It will then be the default theme for all spaces in the site. See the administrator’s guide to applying a theme.

Customising the Look and Feel of the Easy Reader Theme

You can customise the space CSS style sheets to change the colours, background image and other styles in the theme. See the guide to using CSS to customise the Easy Reader theme.

Hints and Tips

If a page has content that is very wide, it will either:

- cause a scroll bar to appear, or
- break out, i.e. the content will extend over the right-hand border of the page.

Related Topics

Applying a Theme to a Space
Applying a Theme to a Site
Customising the Look and Feel

Take me back to the Confluence User’s Guide

Changing a Space’s Logo

In Confluence, you can replace the default logo for a space with a logo of your own choice.

You need to be a space administrator to replace a space’s logo.

The instructions below refer to global spaces. For your personal space, your profile picture is used as the space icon.

To change a space’s logo:

1. Choose Browse > Space Admin.  
   - Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Change Space Logo in the left panel under the heading ‘Look and Feel’. See the screenshot below.
3. Use the browse option to locate the new logo and click **Upload**.

**Screenshot: Changing a space’s logo**

**Change the logo for this space.**

<table>
<thead>
<tr>
<th>Image</th>
<th>Browse</th>
<th>Upload Logo</th>
</tr>
</thead>
</table>

**Current** (default)

**Image Data**
- H: 30
- W: 42
- GIF

---

**Related Topics**

- Customising the Look and Feel

Take me back to [Confluence User’s Guide](#)

### Changing the Confluence Browser Icon

The Confluence logo is displayed in the user's browser to identify the Confluence browser tab. To use a custom image for your Confluence site:

1. Obtain or create an image in PNG file format. To maximise browser compatibility, it should be 32x32 pixels in size, 71x71 DPI (dots per inch) and have an 8 bit colour depth.
2. In your Confluence installation, find the `...\confluence\images\icons` directory.
3. Back up the file `favicon.png`.
4. Replace the `favicon.png` file with your custom PNG image.
   - You may also need to back up and replace the following images in your Confluence installation:
     - `...\confluence\images\icons\favicon.ico`
     - `...\confluence\favicon.ico`
     - `...\confluence\images\logo\confluence_16.png` (Reduce this image to 16x16 pixels.)
5. Restart your application server.

Users may need to clear their browser cache before they will see the new image.

**Converting an icon to a PNG**

To create an ICO out of your PNG image, you can use the freeware tool [png2ico](http://converticon.com/).  

---

**Related Topics**

- Customising the Look and Feel

### Customising Layouts for a Space

Confluence's look and feel can be modified by editing the 'decorator' (layout) files. Modifying these files allows you to change the look and feel of:

- The Confluence site as a whole, which includes all spaces within the Confluence site.
- An individual space within the Confluence site.

This page tells you how to customise the layout files for a space. To perform these customisations, you will require space administrator permissions for that space.
For security reasons, you must also have Confluence system administrator permissions to modify any space layout throughout your Confluence site.

A feature request (CONF-5808) has been submitted to allow space administrators (who are not system administrators) to access and modify space layouts. Please feel free to vote on this issue if you would like to see this feature implemented.

Confluence system administrators can also customise the layout of their entire Confluence site as a whole. For more information, please refer to Customising Layouts.

Be aware that site layout file customisations modify the default layout files of all spaces in the Confluence site. However, any space layout file customisations will override the equivalent site layout file customisations.

If you modify the look and feel of Confluence by following these instructions, you will need to update your customisations when upgrading Confluence. The more dramatic the customisations are, the harder it will be to reapply your changes when upgrading. Please take this into account before proceeding with any customisations. For more information on updating your customisations, please refer to Upgrading Custom Layouts.

Confluence is built on top of the Open Source SiteMesh library, a web-page layout system that provides a consistent look and feel across a site. SiteMesh works through ‘decorators’ that define a page’s layout and structure.

To edit the layout of Confluence, you will need to modify these decorator files. A decorator file is a vmd file and is written in a very simple programming language called Velocity. Learn more about Velocity. Once you become familiar with Velocity, you can edit the decorator files to personalise the appearance of Confluence.

These decorator files are grouped into:

- **Site layouts**: These are used to define the controls that surround each page in the site. For example, if you want to make changes to the header and the footer, you will need to modify these layouts.
- **Content layouts**: These control the appearance of content such as pages and blog posts: they don't change the way the pages themselves are displayed, but they allow you to alter the way the surrounding comments or attachments are shown.
- **Export Layouts**: These control the appearance of spaces and pages when they are exported to HTML. If you are using Confluence to generate a static website, for example, you will need to modify these layouts.

Learn more about using decorators.

To edit a decorator file:

1. Choose Browse > Space Admin.
   - **Space Admin** is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click the Layout link in the left panel under the heading 'Look and Feel'. A list of the layouts for the space is listed.
   - **Layout** is only displayed if you are a Confluence system administrator.
     - Click View Default to view the vmd file.
     - Click Create Custom to edit the default vmd file. This will open up the vmd file in edit mode. Make changes and click Update.

**Screenshot : Edit Layouts Example**

<table>
<thead>
<tr>
<th>Decorator</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space Export Layout</td>
<td>&lt; default</td>
</tr>
<tr>
<td>Page Export Layout</td>
<td>&lt; default</td>
</tr>
</tbody>
</table>

Click the thumbnail to see an example of a vmd file:
Editing a Space's Colour Scheme

Confluence allows you to customise the colour scheme of a space. By default, a space's colour scheme is based on global settings configured from the Administration Console.

You need to be a space administrator to edit a space's colour scheme.

To change the colour scheme for a space:

1. Choose Browse > Space Admin.
   
   Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Colour Scheme in the left-hand panel under the heading Look and Feel.

3. Click Select next to a colour scheme under Custom Colour Scheme (if not already selected).

4. Click the Edit link. This will bring up a new screen. See screenshot below.

5. Enter standard HTML/CSS2 colour codes, or use the colour-picker to choose a new colour from the palette provided. Any changes you make will immediately be reflected in this space.

The colour scheme applies to the following UI elements:

- Top Bar - the bar across the top of the page that contains the breadcrumbs
- Tab Navigation Background - the background colour of the tab navigation menus
- Tab Navigation Text - the text of the tab navigation menus
- Breadcrumbs Text - the breadcrumbs text in the top bar of the page
- Space Name Text - the text of the current space name located above the page title
- Heading Text - all heading tags throughout the space
- Links - all links throughout the space
- Borders and Dividers - table borders and dividing lines
- Tab Navigation Background Highlight - the background colour of the tab navigation menu when highlighted
- Tab Navigation Text Highlight - the text of the tab navigation menu when highlighted
- Top Bar Menu Selected Background - the background colour of the top bar drop down menu when selected
- Top Bar Menu Item - the text colour of the menu items in the top bar drop down menu
- Page Menu Selected Background - the background colour of the drop down page menu when selected
- Page Menu Item Text - the text of the menu items in the drop down page menu
- Menu Item Selected Background - the background colour of the menu item when selected (applies to both the top bar and page drop down menus)
- Menu Item Selected Text - the text colour of the menu item when selected (applies to both the top bar and page drop down menus)

Please note that some UI elements are specific to the default theme and may not take affect for other themes.

Screenshot: Editing a space's colour scheme
Handy Hint

If you mess things up, just click the Reset button and then try again.

Related Topics

Customising the Look and Feel

Take me back to Confluence User’s Guide

Styling Confluence with CSS

This page explains the facility for making visual changes to the look and feel of Confluence with CSS.

On this page:

- Introduction
- Considerations for Using Custom CSS
- Getting Started
- CSS Resources
- Related Pages

Introduction

Cascading Style Sheets (CSS) are an industry-standard way of styling a web page. The content of a page is rendered with HTML, and its look and feel is determined by CSS files.

With the release of Confluence 2.10, you can upload a CSS text file and apply it to a space or even a whole Confluence instance.
Creating CSS styles that work seamlessly across different browsers is a delicate task for basic web sites, and reasonably challenging when customising web applications like Confluence. It is important to test each change that you make and ensure it works as expected in all areas of Confluence – for example, on the Confluence Dashboard as well as on regular pages.

In order to get you started, we have compiled this introduction, a basic styling tutorial and a more advanced tutorial.

Considerations for Using Custom CSS

CSS Knowledge is Required

If you are not familiar with CSS, see the links in the CSS Resources section below. You should spend some time to become confident with Cascading Style Sheets before you start editing your Confluence style sheets.

Security

Custom CSS can be used to inject scripts into a page, opening the risk of cross-site scripting (XSS) attacks. With this feature enabled, space administrators could upload styles that steal other users' login credentials, trick their browsers into performing actions on the wiki without their knowledge, or even obtain global administration privileges. As such, this feature is disabled by default. Confluence administrators should only enable custom CSS if they are comfortable with the risks listed in this paragraph.

Scaling

Each page needs to scale. Depending on the resolution of the user's screen, the content should render intelligently. Your designs need to degrade gracefully. Try resizing each page that exists in Confluence. There are quite a few pages in the browse-space-section, like drafts, labels, page hierarchy, and so on. Your style has to work everywhere, not just in the first page you happen to be looking at.

Features Cannot Be Disabled

It is easy to turn off certain links, headers, or even menu items by simply setting their style to 'hidden'. This can help you to roll out Confluence to users that may not be very Wiki-savvy yet. The simpler the UI, the easier it may be for them to use. However, please remember that removing the link to a part of the application does not mean that the functionality is not available. Every user can still change their style from within their browsers, or access the URL directly. Don't rely on CSS to disable parts of Confluence.

Features Should Not Be Disabled

Users familiar with Confluence will expect to find the same controls that they are accustomed to. Removing buttons or controls from the interface is not advised as it may frustrate your users and cause them to circumvent your design by using direct URL access, as mentioned above.

Confluence Version Compatibility

Be aware of any plans to upgrade your Confluence instance. Future versions of Confluence may not be compatible with your custom CSS — this may cause your CSS to break, requiring maintenance when Confluence is upgraded. Ask your Confluence administrator for more information.

Test on Different Web Browsers

As a rule you should test your modifications on different web browsers. Internet Explorer, Firefox, Opera and Safari (on Mac OS X) are some of the more popular browsers.

CSS Customisation is Not Supported

As creating custom CSS has potentially limitless possibilities, Atlassian will not support issues that are caused by or related to CSS customisation.

Getting Started

Editing the CSS

To edit a space's CSS style sheets:
1. Choose Browse > Space Admin. 
   Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Stylesheet in the left-hand panel under the heading 'Look and Feel'.
3. Click Edit.
4. Paste your custom CSS into the text field.
5. Click Save. The new CSS will be visible on all content pages in the space.

Follow the Tutorial

Follow the examples in the Basic Styling Tutorial or the more advanced Styling Tabs in Confluence to get started.

CSS Resources

- W3C CSS Standards
- W3schools CSS Introduction
- Mozilla Developer Network
- W3resource.com

Related Pages

Basic Styling Tutorial
Styling Tabs in Confluence
Styling Fonts in Confluence
Including Cascading Stylesheets in Themes

Basic Styling Tutorial

This page contains instructions on how to get started with custom CSS styling in Confluence.

On this page:

- CSS Editing Quick-Start
- Tutorial: Changing the Header Background
- CSS Editing Tips
  - Begin With a Space Stylesheet
  - Use the Right Tools
  - Edit Simple Elements First
- Related Topics

CSS Editing Quick-Start

To edit a space's CSS style sheets:

1. Choose Browse > Space Admin. 
   Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Stylesheet in the left-hand panel under the heading 'Look and Feel'.
3. Click Edit.
4. Paste your custom CSS into the text field.
5. Click Save. The new CSS will be visible on all content pages in the space.

Tutorial: Changing the Header Background

The header is the menu area at the top of a default Confluence page where the Breadcrumb Links, Browse menu, User menu and the Quick Search box reside. In this example, we are going to change the background of the header to include a custom graphic.

1. Create a custom graphic. For this example, we created a custom header graphic of 1046 x 61 pixels.
2. Upload the custom graphic to a page in the space that you are customising.
3. Note the page ID of the page where you uploaded the new graphic. (in this example, the page ID was '658833839').
4. Compose your custom CSS for the header. The example below loads the new graphic (called 'header.png') from a specific page (denoted by page ID '658833839') in the same space.

   ```css
   #header {
       background-image:url('..download/attachments/658833839/header.png');
       background-repeat: no-repeat;
   }
   ```

5. Log in as the Space Administrator.
6. Open the Space Admin page.
7. Click Stylesheet.
8. Click Edit to change the code in the text field.
9. Paste your custom CSS into the text field.
10. Click **Save** and then reload the page (you may have to shift-reload). The background of the header will change.
11. The custom header will be visible on all content pages in the space. To revert your change, simple delete the custom code from the 'Stylesheet' page and click **Save**.

**CSS Editing Tips**

**Begin With a Space Stylesheet**

A space stylesheet is a good starting point for CSS customisation, as it already includes all of the elements that can be changed. When you work on the space stylesheet it styles all content pages in the space. Build and test it at space-level, before considering applying the new stylesheet to your entire site. Once you are satisfied with your space design, test it thoroughly until you are confident that it has no problems. Then, you can look into advanced customisation of the Confluence CSS such as adjusting the Search page, the Dashboard and other integral pages.

**Use the Right Tools**

As the Confluence CSS is reasonably sophisticated, web development applications will help you to understand how the page styles have been created. In particular, you will need to view the existing source for the pages you're starting to work on. If you don't already have some, tools such as the following free applications will allow you to do this.

1. **Firebug**
   Firebug, a plugin for the Firefox web browser, allows you to take a look at the style of each element on your page. This is very useful to see what styles are currently applied, for example styles applied to the header only.

2. **Web Developer**
   The Web Developer plugin for Firefox allows you to edit CSS inline and create new page designs.

3. **CSS Edit**
   CSS Edit is a stand-alone CSS editor for Macintosh that extracts all existing styles from a given page and allows you to overwrite these.

**Edit Simple Elements First**

Begin by editing simple elements and checking that they work. By making changes, then checking that each one worked, you can easily isolate any CSS code that is causing problems. Be aware that some page elements are more suited to customisation than others. For example, adding a gradient to the toolbar is less likely to 'break' the page than changing the page width. Editing reasonably static elements such as background graphics will render more predictably than designs which attempt to completely change the user interface or the Javascript-powered drop-down menus (which we don't recommend editing).

**Related Topics**

- **Styling Confluence with CSS**
- **Styling Tabs in Confluence**
- **Including Cascading Stylesheets in Themes**

**Styling Fonts in Confluence**

Confluence provides the ability to adjust its visual style via Cascading Style Sheets (CSS). With this feature, it is very easy to change the look and feel of Confluence.

This tutorial shows you to change the fonts of a normal Confluence page. We will show how to change the font and font sizes with a few lines of CSS.

**Screenshot 1: Default Font in a Confluence Page**

**Screenshot 2: Custom Font in a Confluence Page**
At the bottom of this page you can find the code for the custom font. Simply copy and paste it into the Space Stylesheet form within the Space Administration section.

**Changing the fonts**

In order to customise the fonts in Confluence, you first need to set the body font to the font you want. Second, you may want to adjust the font size to account for the fact that different fonts have different relative sizes.

The relevant CSS is shown below, and can be configured in Space Admin > Stylesheets. These styles change Confluence’s font from its default of Helvetica/Arial – *sans serif* fonts – to Times/Times New Roman – *serif* fonts. To adjust for the fact that Times is a bit smaller than Helvetica, we increase the font size to 14 pixels.

```css
body {
    font-family: Times, "Times New Roman", serif;
    font-size: 14px;
}
.wiki-content, 
.wiki-content p, 
.wiki-content table, 
.wiki-content tr, 
.wiki-content td, 
.wiki-content th, 
.wiki-content ol, 
.wiki-content ul, 
.wiki-content li {
    font-size: 14px;
}
```

The many styles which include ‘wiki-content’ are necessary to change the font-size for all the tags in the wiki content.

**Related Topics**

- Basic Styling Tutorial
- Styling Tabs in Confluence
- Including Cascading Stylesheets in Themes

**Styling Tabs in Confluence**

Confluence provides the ability to adjust its visual style via Cascading Style Sheets (CSS). With this feature, it is very easy to change the look and feel of Confluence.

This tutorial shows you to change the look and feel of Confluence. We will address the Confluence tabs in this tutorial and how we can change their look completely with a few lines of CSS.

Let’s take a look at what we are trying to achieve. Notice the dark blue tabs in Screenshot 1? Our goal is to blend them into the background and change the text style as in Screenshot 2.

*Screenshot 1: Default Confluence Tabs in Admin Screen*
At the bottom of this page you can find the code for the custom tabs. Simply copy and paste it into the Space Stylesheet form within the Space Administration section. Let's discuss each selector in detail:

**Container Style**

```
#navigation, #tab-navigation{
  border-bottom: 1px solid #CCC;
  background-color: transparent;
  margin: 1em 0 2em -5px;
}
```

Let's start with the container around the tabs. We don't want a background-color for the tabs and the container, therefore we will set the color to be transparent. With the border-bottom attribute we will create a thin grey line at the bottom to separate the navigation from the rest of the page. Lastly we adjust the margins of the container to create some space around the tabs.

**Tab Style**

```
.tab-navigation .tab a {
  font-weight: normal;
  color: #999999;
  background-color: transparent;
  border: none;
}
```

Then we style each link within the tab. We set the font-weight to normal, to make the tabs less dominant and change the color to a dark grey. We also have to specify the border and background-color attributes explicitly to overwrite the default styles in Confluence. If we don't specify the background color for example, the blue color of the default style will be applied.

**Hover Style**
Now we want to specify the hover attributes of the links. Note that we have to overwrite the background-color and the border attributes again, otherwise the default styles will be applied. We also change the color of the text for the hover effect of the link.

**Currently Selected Element Style**

```css
ul.tab-navigation .current a:hover, ul.tab-navigation .current a {
  color: #000000;
  background-color: transparent;
  border: none;
}
```

The last selector we will need to customise is the element with the class current. Note that we use a more specific selector this time. The reason we are doing this is because these specific selectors are used in the default CSS stylesheet. If we were to use more general selectors, like we did above (ignoring the `ul`), the default style would still be applied since more specific selectors are rendered with a higher priority. We want to keep the general style of the other links but simply change the color of the text to black.

**Complete CSS Style**

Simply copy and paste the code below to change the look of the tabs in Confluence.

```css
/* @group Tab Styles */
.tab-navigation .tab a {
  font-weight: normal;
  color: #999999;
  background-color: transparent;
  border: none;
}

.tab-navigation .tab a:hover {
  font-weight: normal;
  color: #0088CC;
  background-color: transparent;
  border: none;
}

#navigation, #tab-navigation{
  border-bottom-color: #CCC;
  margin: 1em 0 2em -10px;
  background-color: transparent;
}

ul.tab-navigation .current a:hover, ul.tab-navigation .current a {
  background-color: transparent;
  border: none;
  color: #000000;
}

/* @end */
```

**Related Topics**

- Basic Styling Tutorial
- Styling Tabs in Confluence
- Including Cascading Stylesheets in Themes
Using CSS to Customise the Easy Reader Theme

This page gives some hints on using the space CSS style sheets to customise the Easy Reader theme.

You can customise the Easy Reader theme using CSS at space or site level. A common modification is to change or remove the background image.

CSS elements are specific to each theme

You will need to match your theme choice and custom CSS. If you want to use the CSS on this page, you will need to apply it to a space that is using the Easy Reader theme. If you apply the CSS at site level, then your entire site must use the Easy Reader theme.

Editing the CSS

To edit a space’s CSS style sheets:

1. Choose Browse > Space Admin.
   * Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. Click Stylesheet in the left-hand panel under the heading ‘Look and Feel’.
3. Click Edit.
4. Paste your custom CSS into the text field.
5. Click Save. The new CSS will be visible on all content pages in the space.

Simple CSS Customisations for Easy Reader Theme

To change the background image:

```
body { background: #ccc url("path/to/your/background.gif") 50% 0 repeat-y; }
```

Remember to set an appropriate background colour to extend past the left and right edges of the image. In the example we use colour code #ccc. This colour should match the last pixel on the left and right of your background image.

Upload your background image as a page attachment

You can upload your background as a page attachment. Make sure that you restrict editing (but not viewing) of that page to yourself or the space/site administrators.

To replace the theme’s gradient image with your choice of background colour:

```
body { background: #ccc; }
```

To add a border to the left and right of the content area, using a specific colour (in the example we use colour code #ccc):

```
#full-height-container { border-left: 1px solid #ccc; border-right: 1px solid #ccc; }
```

Related Topics

Configuring the Easy Reader Theme
Styling Confluence with CSS

Permissions Overview

Confluence gives you the choice to make the site as open or as closed as you wish. Here are some points to consider:

- As a tool for communication and collaboration, Confluence is at its best when all your users can participate fully.
- So it’s advisable not to restrict users unless you have a good reason for doing so.
- Confluence keeps a history of all changes to pages and other content. So it is easy to see who has changed what, and to reverse any edits if required.
Levels of Permission

There are three levels of permissions in Confluence.

Global Permissions

Global permissions are site-wide permissions, and are assigned by administrators. Confluence allows two levels of administrator permissions:

- **System Administrator** - Users with this permission can perform all the Confluence administrative functions.
- **Confluence Administrator** - Users with this permission can perform most of the Confluence administrative functions, but excluding those functions which could compromise the security of the Confluence system.

Users with 'System Administrator' or 'Confluence Administrator' permission can assign permissions to other users. For full details, please refer to the overview of global permissions in the **Administrator's Guide**.

Space Permissions

The permission to create a new space or to administer one is granted by a **Confluence Administrator** from the global **Administration Console**. Every space has its own independent set of permissions. These permissions determine the access settings for different users of the space. In order to assign these permissions to other users, a user must be a **space administrator** i.e. must have the 'Admin' permission for that space.

See **Users and Groups** to learn how these permissions are assigned.

Page Restrictions

You can set **page-level restrictions**, if you have the 'Restrict Pages' permission within the space concerned.

Page restrictions allow you to control who can view or edit individual pages. To set page restrictions, edit the page and use the page restriction options below the text-entry box.

More Information

*How do space permissions and page restrictions work together?*

**Example:** In the HR (Human Resources) space, everyone in the organisation has the 'View' space permission, but only the HR team has the 'Pages --> Create' space permission (i.e. the ability to create and edit pages in the space). A member of the HR team starts to create a new page called 'Annual Leave Policy'. Because the page is not yet finished, she sets the 'Viewing' page restriction so that only the HR team can view the page. When the page is finished, she will remove the 'Viewing' restriction so that everyone in the company can see the page.

*How do space permissions and page restrictions affect links?*

Space permissions and page restrictions affect how links between pages are displayed to a visitor:

- if the link points to a page in a space to which the visitor does not have 'View' space permission, the link will not be rendered at all.
- if the visitor has 'View' space permission, but page restrictions prohibit her from viewing the page, the link will be rendered but an 'Access Denied' message will be displayed when she clicks the link.
- if the visitor has 'View' space permission, and is not restricted from viewing the page, the link will display and behave as normal.

Links to attachments are also affected:

- if the visitor does not have permission to view the page to which the attachment is attached, the link will not be rendered.
**Warning**

If you misconfigure a space so that nobody has access to administer it any more, you will need to have someone in the 'confluence-administrators' group fix the permissions for you.

---

**Related Topics**

Users and Groups  
Global Permissions Overview  
Space Permissions Overview  
Page Restrictions  
Configuring Confluence Security  
Confluence Security

Take me back to Confluence User's Guide

**Page Restrictions**

Page restrictions allow you to control who can view or edit individual pages. You set the page restrictions using the Page Restrictions dialog, either directly by choosing Tools > Restrictions, or when editing a page.

For instructions on using the Page Restrictions dialog, refer to Setting a Page's Restrictions.

When a page you are viewing has restrictions applied, a small padlock icon appears next to the page byline. Clicking the padlock will open the Page Restrictions dialog, where full details on the page restrictions are displayed.

---

**On this page:**

- The Confluence Permissions and Page Restrictions Hierarchy  
- Requirements for Setting Restrictions  
- Page Security Rules  
- Inherited Restrictions and Child Pages  
- Example of Child Page Restrictions  
- How to Open Part of a Space  
- Related Topics

---

**Screenshot: The Confluence Page Restrictions dialog**

---

**The Confluence Permissions and Page Restrictions Hierarchy**

Permissions and page restrictions in Confluence work within a hierarchical manner. For example, users who can access and modify global permissions (for instance, Confluence Administrators) can define which users can access and modify space level permissions (that is, space administrators). Space administrators can then define which users have access to create and modify pages. These users in turn can then apply viewing and editing restrictions to a page. By inheritance, these restrictions will also be applied to any child or descendant pages which are then added to that page.
See the diagram below for an illustration.

Diagram: Confluence Restrictions Hierarchy

Requirements for Setting Restrictions

In order to set or modify page restrictions, you need to have both:

- 'Restrict Pages' permission in the space to which the page belongs (since page restrictions operate within the bounds of space permissions).
- Permission to edit the page itself. That is, if a user is prevented from editing a page through page restrictions, they are also prevented from changing the restrictions themselves.

Page Security Rules

Users can only view page or space content for which they (or a group they are in) have 'View' permission. Pages that a user does not have 'View' access to are referred to as 'inaccessible' pages. Visit Inaccessible Page to see how Confluence deals with pages a user cannot view:

- Anonymous users are directed to the login page.
- Logged-in users are shown a permissions error page.

It is not possible to conceal the existence of pages, though you can restrict 'View' access to page content. Users will still be able to find the page if they know its URL. But they will not be able to view the content if they don't have the correct...
Inherited Restrictions and Child Pages

If a page has its 'View' restriction set, that restriction will be inherited by all its children (and their children, and so on). If a 'View' restriction is added to a page that has already inherited page restrictions from its parent, users must satisfy both restrictions in order to see the page. 'Edit' restrictions are not inherited from the parent page, only from the space.

Example of Child Page Restrictions

Consider the page 'Documents', with a child page 'Executive', which itself has a child page 'Payroll'. To begin with, anyone who can view the space to which these pages belong can see all three pages.

For security reasons, 'View' restrictions are set on the 'Executive' page, restricting it to the 'mycompany-management group'. At this point, anyone can still see the 'Documents' page, but you must be in the 'mycompany-management group' in order to view either 'Executive' or 'Payroll'.

Since 'Payroll' information is considered particularly private, the 'Payroll' page then has its page restrictions set to only allow members of the 'mycompany-financial' group to view it. At this point, anyone can see the 'Documents' page, only members of 'mycompany-management' can see 'Executive', and only users who are members of both the 'mycompany-management' and 'mycompany-financial' groups can view 'Payroll'.

How to Open Part of a Space

If designing a large site implementation with this strategy, consult Page Restrictions Performance Considerations.

Often there are cases for which a section of a space should be opened to a group or set of users (for this example, we'll call them group B), but the rest of the space should not be visible to your main users (for this example, we'll call them group A). In this case:

1. Add 'view' permission for both groups A and B in space permissions.
2. Move the page to be opened to the root of the space. When browsing the pages in the space, your normal space home page and this page should both be at the root level.
3. Add a page restriction to allow Group A and B to see this page.
4. Add a page restriction to your main landing page for Group A, thereby excluding this set of pages from Group B.

You can repeat this with any page hierarchy.

Administrators

- Space administrators are responsible for the management of a space and its contents. They therefore have the ability to remove all restrictions from a page (as described in 'Viewing Restricted Pages'). This means that space administrators can view and edit all content in the space.
- Users who are members of the 'confluence-administrators' group ('super-users') cannot immediately see pages from which they are excluded by page restrictions. Also, to be able to edit the page, you will need to remove the restriction from it first – go to Space Administration > Restricted Pages.

You cannot exclude yourself

As creator or editor of a page, you cannot use page restrictions to deny yourself access to the page. Confluence will automatically add your username into the list of users/groups allowed to view/edit the page. If you remove your username, Confluence will put it back again.

Related Topics

View a Page's Restrictions
Set a Page's Restrictions
View All Restricted Pages
Page Restrictions Performance Considerations

Working with Pages

Take me back to the Confluence User's Guide.

Setting a Page's Restrictions

Page restrictions control who may view or edit a specific page, within the bounds of the space permissions:
• View restrictions make the page invisible to everyone except the chosen users and groups.
• Edit restrictions prevent everyone except the chosen users and groups from editing the page.

You can restrict the page to as many users and groups as you like.

In order to set or modify page restrictions, you need to have the 'Restrict Pages' permission in the space to which the page belongs, as well as permission to edit the page itself.

Setting Page Restrictions

To set restrictions on a page:

1. Choose Tools > Restrictions. The Page Restrictions dialog opens. You can also click the padlock icon  in the page’s byline (if available), or click either Unrestricted or Restricted when editing the page.
2. Select the restriction option required.
3. Choose the users and groups who you want to be able to view or edit the page:
   • To choose just yourself, click Me.
   • To choose a particular user or group, type the user’s username (or their full name), or the group name, into the Enter ... name box, and click Restrict. You can enter multiple user and group names, when separated by commas.
   • To search for a user or group (if you are unsure of the name), click Person... or Group... (You can read more about searching for users.)
4. Click Save.

Removing Page Restrictions

To remove restrictions on a page:

1. Choose Tools > Restrictions. The Page Restrictions dialog opens. You can also click the padlock icon  in the page’s byline (if available), or click either Unrestricted or Restricted when editing the page.
2. Click Remove restriction next to the appropriate users or groups.
3. Click Save.

You can both set and remove restrictions for different users or groups when using the Page Restrictions dialog.

Notes

When a page you are viewing has restrictions applied, a small padlock icon  appears next to the page byline. Clicking the padlock will open the Page Restrictions dialog, where full details on the page restrictions are displayed.

View and edit restrictions apply to all users including space administrators. However, space administrators can remove any restriction on a page. See Viewing Restricted Pages.

Related Topics

Space Permissions Overview
Viewing a Page’s Restrictions
Viewing Restricted Pages
Working with Pages
Viewing a Page’s Restrictions

Viewing page restrictions in View mode

When a page you are viewing has restrictions applied, a small padlock icon 🛠 appears next to the page byline. Clicking the padlock will open the Page Restrictions dialog, where full details on the page restrictions are displayed. See Setting a Page’s Restrictions for instructions on how to change these.

Viewing page restrictions in Edit mode

You can view a page's restrictions when editing the page. You can only edit the page if you have permissions to do so.

To view the restrictions that apply to a page:

- When editing the page, click Restrictions. See Setting a Page’s Restrictions for instructions on how to change these.

Related Topics

Setting a Page’s Restrictions
Viewing Restricted Pages
Working with Pages

Viewing Restricted Pages

Restricted pages are pages that have ‘View’ or ‘Edit’ restrictions applied to them through page-level restrictions.

You need to be a space administrator to view the list of restricted pages in a space.

To view restricted pages:

1. Choose Browse > Space Admin for the space.
2. Click Restricted Pages in the left panel under ‘Security’. A list of all restricted pages in the space is displayed.
3. Click on the ‘lock’ 🛠 icon to remove restrictions for the page.

Here’s an example:
Site Administrators and their Permissions

All site administrative functions are performed from the Administration Console. You need to have System Administrator or Confluence Administrator permissions to access the Administration Console.

The Confluence permission scheme allows the following levels of administrator permissions:

- **Super-User** – full administrative access to Confluence, plus visibility to all the content.
- **System Administrator** – full administrative access to Confluence.
- **Confluence Administrator** – access to most of the Confluence administrative functions.

Please refer to the overview of global permissions in the Administrator's Guide for full details.

Related Topics

Users and Groups

Contacting Confluence Administrators

If you receive an error message from Confluence, the error page may offer you a link to click in order to contact the administrators of the Confluence site.

When you click the link to contact the Confluence administrators, you will see an administrator contact page with the title 'Contact Site Administrators'. By default, the administrator contact page looks like the screenshot below.

Screenshot: The administrator contact screen

The screen may look different

In certain configurations of Confluence, you will not be able to use the form shown in the screenshot above. Instead, you will see a message telling you about one of the following conditions:

- If your Confluence administrator has not configured a mail server for Confluence, this means that Confluence will not be able to send an email message to the administrators.
- If none of the Confluence administrators has an email address, Confluence will not be able to send an email message to them.
- If there are no Confluence administrators defined to Confluence, Confluence will not be able to send an email message to them.
- The Confluence administrator can disable the form and specify a different message to be displayed on the above screen instead of the default message and form. See the administrator's guide.

Related Topics

Configuring the Administrator Contact Page

Space Administrators and their Permissions
A space administrator is a user with the 'Space Admin' permission for a space. This permission itself is assigned from the Space Administration screens by a space administrator.

Who is a space administrator?

The person who creates a space is automatically the administrator of that space. That person can then assign other space administrators as required.

Confluence administrators are not necessarily space administrators.

- A user who has the 'Administer Confluence' permission is not automatically a space administrator for a particular space. In order for them to be a space administrator, they must belong to a group which has space administration rights on the space, or their username must be specifically granted space administration rights on the space.
- Users who are members of the 'confluence-administrators' group do automatically have space administration permissions for all spaces.

Refer to the Administrator's Guide for more details about Confluence administrator permissions.

What can a space administrator do?

A space administrator has permission to do anything in the space regardless of any other setting. Space administrators are responsible for the management of a space and its contents. Note that page permissions affect space administrators differently from other users.

Space administrators can:

- view all content in the space. If there are page permissions that restrict the viewing of a page to a single user, or to a group to which the space administrator doesn't belong, a space administrator can still view the page by removing the restriction.
- edit all content on any page in the space.
- remove restrictions from any page in the space (using the Space Administration interface).
- manage the watchers for any page in the space (but not watchers of the space).
- grant themselves any other space permissions (e.g. permission to set restrictions on a particular page).

All space administration functions, with the exception of managing watchers, are performed from the 'Space Admin' tab (choose Browse > Space Admin). You need to be a space administrator to access the Space Administration screens.

Related Topics

Space Permissions Overview

Take me back to Confluence User's Guide

Space Permissions Overview

Every space has its own independent set of permissions.

Space permissions can only be granted by a space administrator. A space administrator has permission to do anything in the space regardless of any other setting.

Permissions can be assigned to any group, to any individual user in the Confluence-User group, and to users in the Anonymous group.

These are the different permissions that can be assigned at the space level:

- **View**: user can view this space's content, including the space's details, and its pages and news items (blog posts).
- **Pages**:
  - Create – user may create and edit pages in this space.
  - Export – user may export pages in this space.
  - Restrict – user may apply page-level restrictions.
  - Remove – user may remove pages in this space.
- **Blog**:
  - Create – user may add and edit blog posts in this space.
  - Remove – user may remove blog posts in this space.
- **Comments**:
  - Create – user may make comments in this space.
  - Remove – user may remove comments from this space.
- **Attachments**:
  - Create – user may add attachments in this space.
  - Remove – user may remove attachments from this space.
- **Mail**:
  - Remove – user may delete individual mail items.
- **Space**:
  - Export – user may export content from this space.
  - Admin – user has administrative permissions over this space.
Warning

If you deny all administrative access to a space by mistake, so that nobody has access to administer the space any more, you will need to ask someone in the confluence-administrators group to fix the permissions for you.

Related Topics

Space Administrators and their Permissions
Users and Groups
Viewing Space Permissions
Assigning Space Permissions
Revoking Space Permissions
Page Restrictions

Take me back to Confluence User's Guide

Assigning Space Permissions

Space permissions can be assigned to user groups or to individual users of Confluence. You need to be a space administrator to assign space permissions.

These are the different permissions that can be assigned at the space level:

- **View**: user can view this space's content, including the space's details, and its pages and news items (blog posts)
- **Pages**:
  - Create – user may create and edit pages in this space.
  - Export – user may export pages in this space.
  - Restrict – user may apply page-level restrictions.
  - Remove – user may remove pages in this space.
- **Blog**:
  - Create – user may add and edit blog posts in this space.
  - Remove – user may remove blog posts in this space.
- **Comments**:
  - Create – user may make comments in this space.
  - Remove – user may remove comments from this space.
- **Attachments**:
  - Create – user may add attachments in this space.
  - Remove – user may remove attachments from this space.
- **Mail**:
  - Remove – user may delete individual mail items.
- **Space**:
  - Export – user may export content from this space.
  - Admin – user has administrative permissions over this space.

Warning

If you deny all administrative access to a space by mistake, so that nobody has access to administer the space any more, you will need to ask someone in the confluence-administrators group to fix the permissions for you.

To access the space permissions:

a. Go to the 'Space Permissions' view. To do this:
   i. Go to a page in the space where you want to view or assign permissions.
   ii. Choose **Browse > Space Admin**.
      
      Space Admin is displayed only if you are a space administrator.
   iii. Click **Permissions** in the 'Security' section of the left-hand panel.
   b. Click the **Edit Permissions** button.
      
      The 'Edit Space Permissions' screen appears, as shown below.

To assign space permissions to groups:

1. Access the 'Edit Space Permissions' screen as described above.
   The **Groups** section shows a list of groups which already have permissions to access the site.
   - To assign permissions, check the box next to the relevant group, for each of the required permissions.
   - To deny a permission, uncheck the relevant box.
   - To add a new group to the list, type the group name into the text box labelled 'Grant permission to' and click the 'Add'
button. The group will appear in the list of groups and you can then assign the permissions.

- To bulk assign or revoke group member permissions, from the **Actions** drop-down list, choose either **Select All** or **Deselect All**.
- To search for a group:
  - Click the **icon**.
  - In the 'Group Search' window, enter all or part of the group name. You can use an asterisk '*' as a wild card.
  - Check the boxes to select the required group(s).
  - Click the **Select Groups** button. The group name(s) will appear in the 'Grant permission to' text box.
  - Click the **Add** button.
  - Click 'Save All' to apply the permissions.

To assign space permissions to users:

1. Access the 'Edit Space Permissions' screen as described above. The **Individual Users** section shows a list of users who already have permissions to access the site.

   - To assign permissions, check the box next to the relevant user, for each of the required permissions.
   - To deny a permission, uncheck the relevant box.
   - To add a new user to the list, type the username into the text box labelled 'Grant browse permission to' and click the 'Add' button. The user will appear in the list of users, with 'View' permission assigned, and you can then add more permissions if necessary.
   - To bulk assign or revoke individual user permissions, from the **Actions** drop-down list, choose either **Select All** or **Deselect All**.
   - To search for a user:
     - Click the **icon**.
     - The 'User Search' window will appear. You can read more about searching for users.
     - Check the boxes to select the required user(s).
     - Click the 'Select Users' button. The username(s) will appear in the 'Grant browse permission to' text box.
     - Click the 'Add' button.
     - Click 'Save All' to apply the permissions.

To assign space permissions to anonymous users:

1. Access the 'Edit Space Permissions' screen as described above. The **Anonymous Access** section shows the space permissions granted to all anonymous users of the site.

   - To assign permissions, check the box for the required permission.
   - To deny a permission, uncheck the relevant box.
   - To bulk assign or revoke anonymous user permissions, from the **Actions** drop-down list, choose either **Select All** or **Deselect All**.

2. Click 'Save All' to apply the permissions.

ℹ️ You cannot grant space administration rights or page restriction rights to anonymous users.

**Screenshot : Editing space permissions**

You can edit the current space permissions here. Permissions can be granted to specific users or groups. You can also grant permissions to anonymous users. Anonymous users refers to all users that are not logged in. For more information about the individual permissions that can be assigned, please see the permissions guide. You can add or remove users via the 'Add' and 'Remove' buttons.

Notes about some error messages you may see

In **Confluence 2.7.2** and later, Confluence will let you know if there is a problem with some permissions. In rare situations, you may see the
following error messages below a permission:

- "User/Group not found" – This message may appear if your LDAP repository is unavailable, or if the user/group has been deleted after the permission was created.
- "Case incorrect. Correct case is: xxxxxx" – This message may appear if the upper/lower case in the permission does not match the case of the username or group name. If you see a number of occurrences of this message, you should consider running the routine supplied to fix the problem.

Related Topics

Space Permissions Overview
Viewing Space Permissions
Revoking Space Permissions
Users and Groups

Take me back to Confluence User's Guide

Revoking Space Permissions

You need to be a space administrator to remove or revoke space permissions.

To revoke space permissions:

1. Choose Browse > Space Admin.
   - Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. Click Permissions in the left-hand panel under the heading ‘Security’. This will display the space’s current permissions assigned to the different groups and users.
3. Click Edit permissions. See screenshot below.
4. Uncheck the permissions you which to revoke.
5. To bulk assign or revoke permissions for groups or individual users, from the Actions drop-down list, choose either Select All or Deselect All.
   - Removing the View permission for a user or group will remove all access to that space for the user or group.
6. Click Save All to apply the permissions.

Quick removal of permissions

To remove all permissions for a user or group, just remove the View permission. The user or group will disappear from the list when you save the permission updates. There’s no need to clear all the permissions for that user or group.

Screenshot: Assigning or Revoking Space Permissions

Related Topics

Space Permissions Overview
Assigning Space Permissions
Viewing Space Permissions
Users and Groups

Take me back to Confluence User's Guide

Viewing Space Permissions
You need to be a **space administrator** to view the permissions assigned for a space.

**To view the permissions assigned for a space:**

1. Choose **Browse > Space Admin**. This tab is only displayed if you are a space administrator.
2. Click **Permissions** in the left-hand panel under the 'Security' heading. This will display all the permissions assigned to the different groups and users for this space.

Below is an example. The ticks in the boxes indicate which permissions have been granted. The crosses indicate which permissions have been denied.

**Screenshot : Viewing space permissions**

Notes about some error messages you may see

In **Confluence 2.7.2** and later, Confluence will let you know if there is a problem with some permissions. In rare situations, you may see the following error messages below a permission:

- **'User/Group not found'** – This message may appear if your LDAP repository is unavailable, or if the user/group has been deleted after the permission was created.
- **'Case incorrect. Correct case is: xxxxxx'** – This message may appear if the upper/lower case in the permission does not match the case of the username or group name. If you see a number of occurrences of this message, you should consider running the routine supplied to fix the problem.

Related Topics

- Space Permissions Overview
- Users and Groups
- Assigning Space Permissions
- Page Permissions

Take me back to **Confluence User’s Guide**

**Users and Groups**

A ‘user’ is the account for an individual who accesses Confluence.

**New users are created by a Confluence administrator via the Administration Console. See Searching For and Managing Users for more**
A Confluence administrator can also group users together into user groups for more convenient administration. This means that any permissions you assign at the site, space and page levels can be assigned to a whole group. A user in one of these groups will automatically be granted all permissions granted to the group.

There are two special groups in Confluence:

- **Confluence-Administrators** - This is a 'super-group' and a user from this group has permission to do anything in the site regardless of any other setting.
- **Confluence-Users** - This is the default group into which all new users are assigned. Permissions you assign to this group will be assigned to all newly signed-up users of Confluence.

**Anonymous Users**

Confluence treats all users who do not log in when they access Confluence as being 'Anonymous'. Administrators can assign permissions to this group separately.

**Overlapping group and user permissions**

When a user is assigned more than one permission, the most powerful permission will prevail.

Further explanation:

- A user may be assigned a permission specifically to their username. They may also be assigned a permission by belonging to a group, or even several groups.
- The user will then be able to perform all functions assigned to them.
- So if a user is allowed to do something over and above what the group can do, the user will be able to do it. And if the group is allowed to do something over and above the specific permissions granted to the user, the user will still be able to do it.
1. Select the **User** tab on the 'User Search' screen. (See above for instructions on accessing the screen.)
2. If the **Simple** link is showing, click it. (If you see the **Advanced** link instead, then you're fine. The simple search is already active.)
3. The simple user search screen will appear, as shown below.
4. Type some information about the user into the 'Search' box. You can type all or part of their username, full name or email address.
5. **Click Search.**
6. Confluence will return a list of matching users. See below for instructions on selecting one or more users.

**Screenshot: Simple user search**

### Using the Advanced User Search

The advanced user search allows you to specify the field in which your search term appears, i.e. username, full name or email address. You may find this useful if you need to limit the number of users appearing in the search results.

**To search via the advanced user search:**

1. Select the **User** tab on the 'User Search' screen. (See above for instructions on accessing the screen.)
2. If the **Advanced** link is showing, click it. (If you see the **Simple** link instead, then you're fine. The advanced search is already active.)
3. The advanced user search screen will appear, as shown below.
4. Complete one or more of the following fields:
   - **User Name** — Enter all or part of the person's username i.e. their login id, e.g. 'joe', or 'bloggs'.
   - **Full Name** — Enter all or part of the person's name, e.g. 'joe bloggs', or 'bloggs', or 'joe'.
   - **E-Mail** — Enter all or part of the person's email address, e.g. 'acme'
5. **Click Search.**
6. Confluence will return a list of matching users. See below for instructions on selecting one or more users.

**Screenshot: Advanced user search**

### Searching for Users in One or More Groups

You can also list the users who appear in a particular group or in a set of groups.

**To search for users in a particular group:**

1. Select the **Membership** tab on the 'User Search' screen. (See above for instructions on accessing the screen.)
2. The 'Group Membership' search screen will appear, as shown below.
3. Type all or part of a group name into the 'Search' box.
4. **Click Search.**
5. Confluence will return a list of users belonging to any groups which match your search term.

**In the example screenshot below, we entered a group name of 'dev'. The search results show all users belonging to the group 'developers' and all users belonging to the group 'developers-mates'.**
6. Now you can select one or more users, as described below.

Screenshot: Searching for users in a group

---

**Selecting One or More Users**

After searching for users and receiving a list of names from Confluence, as described above, you can now select the user(s) you need.

**To select one or more users:**

1. Click the box next to the username(s) to select or unselect one or more users.
   You can click **Check All** to select or unselect all users.
2. Click **Select User(s)**.
3. The 'User Search' window will close and the selected users will appear on the screen which you were using before you accessed the user search.

Screenshot: Selecting one or more users

---
Notes

- **Case sensitivity**: The search is not case sensitive. You can enter either upper- or lower-case text, and it will make no difference to the search results.
- **Wild cards**: The search allows the asterisk as a wild card, but you do not need to use it. The search results will be the same whether you use a wild card or not. The wildcard functionality remains available for compatibility with older versions of Confluence.
- **Multiple user directories**: You may define multiple user directories in Confluence, so that Confluence looks in more than one place for its users and groups. For example, you may use the default Confluence internal directory and also connect to an LDAP directory server. In such cases, you can define the directory order to determine where Confluence looks first when processing users and groups. Here is a summary of how the directory order affects the processing:
  - The order of the directories is the order in which they will be searched for users and groups.
  - Changes to users and groups will be made only in the first directory where the application has permission to make changes.

See Managing Multiple Directories.

- **Crowd and the user search**: If you are using Atlassian's Crowd for user management, you will need Crowd 1.5.1 or later to use the 'Simple' option in the user search. If your version of Crowd does not support the simple user search, you will see only the 'Advanced' search form.

Related Topics

- Searching Confluence
- Setting a Page’s Restrictions
- Assigning Space Permissions
- Adding or Removing Users in Groups

Take me back to Confluence User’s Guide

## Working with Confluence Gadgets

This section introduces the concept of gadgets in Confluence and provides an outline on how to use gadgets in Confluence and other web applications.

On this page:

- Introduction to Gadgets in Confluence
- Using Gadgets in Confluence
- Adding Confluence Gadgets in Other Applications
  - Adding a Confluence Gadget to JIRA
  - Adding a Confluence Gadget to Non-Atlassian Web Applications
- Related Topics

### Introduction to Gadgets in Confluence

A gadget is a small object (i.e. a piece of functionality) offering dynamic content that can be placed into the page of:

- An Atlassian application’s website, such as a Confluence page or blog post or a JIRA 4.0+ dashboard.
- A third-party application’s website, such as iGoogle or Gmail. (But see the limitations on using Confluence gadgets in other applications.)

Gadgets allow interactions between Confluence and other compatible websites. Confluence interacts with gadgets that support the OpenSocial specification.

For more information about Atlassian gadgets, please refer to the introduction to Atlassian gadgets and the big list of Atlassian gadgets.

### Using Gadgets in Confluence

You can place any gadget that complies with the OpenSocial specification from an external source, such as iGoogle or other Atlassian applications such as JIRA 4.0+, onto a Confluence page or blog post. To add a gadget to a page, use the Confluence macro browser to add a Gadget macro.

See the page on adding JIRA gadgets to a Confluence page.

### Adding Confluence Gadgets in Other Applications

You can add a Confluence gadget to a JIRA dashboard or another Confluence site. In principle, you can also put a Confluence gadget on any other OpenSocial-compliant website such as iGoogle or Gmail. See the limitations on using Confluence gadgets in other applications.

**Adding a Confluence Gadget to JIRA**
See Adding a Confluence Gadget to a JIRA Dashboard.

**Adding a Confluence Gadget to Non-Atlassian Web Applications**

For instructions on how to add Confluence gadgets in another compatible non-Atlassian web application or container, refer to Configuring Confluence Gadgets for Use in Other Applications.

**Confluence Gadgets**

The Confluence Gadgets topic explains the purpose of the ‘Confluence Gadgets’ window and provides information about the gadgets which are bundled with Confluence.

**Related Topics**

Gadget Macro
Working with the Macro Browser
Configuring Confluence Gadgets for Use in Other Applications
Adding a Confluence Gadget to a JIRA Dashboard
Confluence Gadgets
Configuring OAuth
All Atlassian gadgets

**Adding a Confluence Gadget to a JIRA Dashboard**

JIRA 4.0 is the first major Atlassian application that can incorporate OpenSocial-compliant gadgets, such as Confluence gadgets onto its dashboard. This page explains how to add a Confluence gadget to the dashboard of a JIRA 4.0+ installation.

To add a Confluence gadget to a JIRA dashboard, complete the sections below in order.

On this page:

- Create an Application Link Between Confluence and JIRA
- Finding a Confluence Gadget's URL
- Adding a Confluence Gadget to a JIRA server's Gadgets Directory
- Adding a Confluence Gadget to the JIRA Dashboard
- Related Topics

**Create an Application Link Between Confluence and JIRA**

If your Confluence gadgets need to access user-restricted Confluence data, then your Confluence administrator must first establish an Application Link between your Confluence site and the JIRA site. For more information about configuring an Application Link between Confluence and other web applications, refer to Configuring OAuth Authentication for an Application Link.

If you only need to access anonymously accessible Confluence data, then you can proceed to Finding a Confluence Gadget's URL, below.

**Finding a Confluence Gadget's URL**

The Confluence gadget's URL is the gadget's XML specification file. These URLs look something like this:

<table>
<thead>
<tr>
<th>Gadget URL</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
</tr>
</tbody>
</table>

To find a Confluence gadget's URL:

1. Choose **Browse > Confluence Gadgets**. The ‘Confluence Gadgets’ window will open.
   The 'Confluence Gadgets' window displays a list of available Confluence gadgets in your Confluence installation, as shown in the screenshot below.
   By default, Confluence only includes a few gadgets. However, if your Confluence administrator has installed more Confluence gadgets (typically as Confluence plugins), these will also appear in this list. If a scrollbar is available, use it to find the gadget you want.
2. After finding your gadget, use the **Gadget URL** link to copy the gadget's URL to your clipboard. Many operating systems and browsers allow you to do this by right-clicking the **Gadget URL** link and copying it using the context menu.

*Screenshot: Finding a gadget's URL*
Adding a Confluence Gadget to a JIRA server's Gadgets Directory

To add a Confluence Gadget to the Gadgets Directory in JIRA:

1. Go to the dashboard by clicking Dashboard at the top left of the screen.
2. The dashboard will appear. Click Add Gadget.
3. The 'Add Gadget' screen appears, showing the list of gadgets in your directory. See screenshot 1 below. Click Add Gadget to Directory.
   - You will only see this button if you have administrator permissions for your dashboard.
4. The 'Add Gadget to Directory' screen appears. See screenshot 2 below. Paste the gadget URL (which you copied to your clipboard above) into the text box.
5. Click Add Gadget.
6. The gadget appears in your gadget directory. (It will be highlighted for a short time, so that you can see it easily.)

Screenshot 1: Gadget directory with 'Add Gadget to Directory' button

Screenshot 2: Add Gadget to Directory screen with gadget URL input field
Adding a Confluence Gadget to the JIRA Dashboard

In the procedure below, 'your Atlassian dashboard' and 'your Atlassian application' refers to the JIRA Dashboard and application, respectively.

You can add a gadget from the directory of gadgets that are available to your Atlassian application.

To add a gadget to your Atlassian dashboard,

1. Go to the dashboard by clicking the 'Dashboard' link or the 'Home' link at the top left of the screen.
2. The dashboard will appear, looking something like screenshot 1 below. Click 'Add Gadget'.
3. The 'Add Gadget' screen will display a list of available gadgets in your gadget directory, as shown in screenshot 2 below. Find the gadget you want, using one or more of the following tools:
   • Use the scroll bar on the right to move up and down the list of gadgets.
   • Select a category in the left-hand panel to display only gadgets in that category.
   • Start typing a key word for your gadget in the 'Search' textbox. The list of gadgets will change as you type, showing only gadgets that match your search term.
4. When you have found the gadget you want, click the 'Add it Now' button to add the gadget to your dashboard.

Screenshot 1: An Atlassian dashboard
Screenshot 2: Adding a gadget from the gadget directory
Adding a Gadget to the Directory of Available Gadgets

You need to have administrator privileges to add a gadget to the list of available gadgets. If you have permission to add gadgets to and remove gadgets from the directory itself, you will see the 'Add Gadget to Directory' and 'Remove' buttons on the 'Add Gadget' screen. Please refer to the Gadgets and Dashboards Administration Guide.

Related Topics

All Atlassian gadgets

Configuring Confluence Gadgets for Use in Other Applications

This page tells you how to add a Confluence gadget to another (external) application. The instructions and examples given in this topic focus on adding and using Confluence Gadgets in other web applications.

Atlassian support does not cover gadgets on external sites like iGoogle and Gmail

In principle, you should be able to add Atlassian gadgets to iGoogle, Gmail and other external sites that support OpenSocial gadgets. However, these external integrations are experimental at this stage and we have encountered problems with them. Please do have fun playing around with them, but be aware that Atlassian does not support the use of Atlassian gadgets on iGoogle, Gmail or other external web sites. See the detailed section on gadget limitations.

Gadgets that display information from Atlassian applications, such as Confluence, should be able to run on iGoogle, Gmail and other web applications that provide OpenSocial containers. Below are specific instructions for iGoogle and Gmail. You can experiment by adding a Confluence gadget to other web sites and applications, such as a Ning community like The Content Wrangler.

On this page:

- Overview of Adding a Confluence Gadget to Another Web Application
- Finding a Confluence Gadget's URL
- Adding an Atlassian Gadget to iGoogle
- Adding an Atlassian Gadget to Gmail
- Limitations and Support
- Related Topics

Overview of Adding a Confluence Gadget to Another Web Application

The exact procedure for adding a Confluence gadget depends on the application where you want to add the gadget. The basic steps are the same:

1. Find the Confluence gadget's URL, i.e. the URL for the gadget's XML specification file.
2. Ensure one of the following two mandatory (typically one-off) procedures have been conducted:
   - An OAuth relationship between Confluence (as the 'service provider') and the other web application (as the 'consumer') has been established. Refer to Configuring OAuth for more information about OAuth and instructions on establishing these relationships.
   - A Trusted Applications relationship between Confluence and JIRA has been established. Refer to Configuring Trusted Applications in the JIRA documentation for more information about establishing these relationships.
3. Follow the procedure provided by the external web application where you want to add the Confluence gadget.

Finding a Confluence Gadget's URL

The Confluence gadget's URL is the gadget's XML specification file. These URLs look something like this:

To find a Confluence gadget's URL:

1. Choose Browse > Confluence Gadgets. The 'Confluence Gadgets' window will open. The 'Confluence Gadgets' window displays a list of available Confluence gadgets in your Confluence installation, as shown in the screenshot below. By default, Confluence only includes a few gadgets. However, if your Confluence administrator has installed more Confluence gadgets (typically as Confluence plugins), these will also appear in this list. If a scrollbar is available, use it to find the gadget you want.
2. After finding your gadget, use the Gadget URL link to copy the gadget's URL to your clipboard. Many operating systems and browsers allow you to do this by right-clicking the Gadget URL link and copying it using the context menu.
Adding an Atlassian Gadget to iGoogle

You can customise your iGoogle home page by adding gadgets and moving them around on the page.

**To add an Atlassian gadget to your iGoogle page:**

1. First find the gadget’s URL as described above.
2. Go to iGoogle and log in if you have a username and password.
3. Click Add stuff near the top right of the iGoogle page.
4. The Google gadget directory will appear, showing a list of available gadgets. Click Add feed or gadget in the right-hand panel.
5. A text box will open, as shown above. Enter or paste the gadget’s URL from your clipboard into the textbox and click Add.
6. Go back to your iGoogle home page. The gadget will appear on your iGoogle page.

Adding an Atlassian Gadget to Gmail

You can add gadgets to the left-hand panel of your Gmail page.

**To add an Atlassian gadget to your Gmail page:**

1. First find the gadget’s URL as described above.
2. Log in to Gmail.
3. Click Settings near the top right of the Gmail page. The Gmail settings page will appear.
4. Click the Labs tab. The Gmail Labs page will appear. This is a laboratory area or testing ground where Google allows you to use experimental features in Gmail.
5. Scroll down to find the feature called ‘Add any gadget by URL’.
6. Select the Enable option, as shown here:
7. Click Save Changes.
8. A new Gadgets tab will appear on your ‘Settings’ page. Click the Gadgets tab. The ‘Gadgets’ page will appear, as shown in the
Confluence 4.0 Documentation

9. Enter or paste your gadget's URL into the Add a gadget by its URL box, then click Add.
10. The gadget will appear in the left-hand panel of your Gmail page, as shown in the screenshot below.

Screenshot: Adding a gadget to Gmail

Limitations and Support

Atlassian support does not cover gadgets on external sites like iGoogle and Gmail

In principle, you should be able to add Atlassian gadgets to iGoogle, Gmail and other external sites that support OpenSocial gadgets. However, these external integrations are experimental at this stage and we have encountered problems with them. Please do have fun playing around with them, but be aware that Atlassian does not support the use of Atlassian gadgets on iGoogle, Gmail or other external web sites. See the detailed section on gadget limitations.

Related Topics

The big list of Atlassian gadgets

Confluence Gadgets

This page describes the purpose of the ‘Confluence Gadgets’ dialog and how to access it, and provides information about the gadgets that are bundled with Confluence.

Gadgets:

- Interact with and provide access to data in your Confluence installation
- Can be used externally such as on a JIRA 4+ server's dashboard, a page or blog post of another Confluence server, or any compatible page on a web site that accepts gadgets, such as iGoogle. (But see the limitations on using Confluence gadgets in other applications.)

On this page:

- The Confluence Gadgets Dialog
- Confluence Gadgets
- Related Topics
The Confluence Gadgets Dialog

The ‘Confluence Gadgets’ dialog displays a list of all the Confluence gadgets available in your Confluence installation. The Confluence gadgets bundled with Confluence are described below. Any additional Confluence gadgets installed by your Confluence administrator (typically as Confluence plugins), will also appear in this list.

To access the Confluence Gadgets dialog:

- Choose Browse > Confluence Gadgets. The ‘Confluence Gadgets’ dialog will open.

Refer to Adding a Confluence Gadget to a JIRA Dashboard or Configuring Confluence Gadgets for Use in Other Applications for more information on adding Confluence gadgets to external applications. A Confluence gadget can also be used within the same Confluence installation, by adding it to a page or blog post using the gadget macro.

Confluence Gadgets

This following table lists the gadgets which are bundled with Confluence. Click the name of the gadget for more information.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Confluence Page Gadget</td>
<td>The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.</td>
</tr>
<tr>
<td>Activity Stream Gadget</td>
<td>The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your Confluence site.</td>
</tr>
<tr>
<td>Confluence News Gadget</td>
<td>The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs and events at Atlassian.</td>
</tr>
<tr>
<td>Confluence Quicknav Gadget</td>
<td>The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence site. For more information on how to use this feature, refer to the Quick Navigation Aid section of Searching Confluence.</td>
</tr>
</tbody>
</table>

Related Topics
Activity Stream Gadget

The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your Confluence site.

For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

In addition to showing a list of most recently changed content, the activity stream gadget also provides the following features:

- The ability to add comments to pages and blog posts, by clicking the 'add comment' icon at the top-right of an added or edited page or blog post in the activity stream.
- The ability to reply to a comment by clicking the 'add comment' icon at the top-right of a comment in the activity stream.
- Activities are grouped by separate date.
- An RSS feed link to its content in the top-right corner of the gadget.

Screenshot: Adding a Comment in the Activity Stream Gadget

Activity Stream Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro’s parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Yes</td>
<td>None</td>
<td>Adds a title to the top of the Activity Stream.</td>
</tr>
<tr>
<td>Projects</td>
<td>No</td>
<td>None specified (i.e. display content in all spaces)</td>
<td>Filters the content by space. This gadget will display only the pages etc. which belong to the space(s) you specify here.</td>
</tr>
<tr>
<td>Username</td>
<td>No</td>
<td>None specified (i.e. display content by all users)</td>
<td>Filters the results by user. The macro will display only the pages etc. which were last modified by the user(s) you specify here. You can specify one or more user, separated by a comma or a space.</td>
</tr>
<tr>
<td>Number of Entries</td>
<td>No</td>
<td>10</td>
<td>Specify the maximum number of results to be displayed. A maximum of 10 results will be displayed by default. The maximum value that this property can accept is 100.</td>
</tr>
<tr>
<td>Refresh Interval</td>
<td>No</td>
<td>Never/false</td>
<td>Specify the time interval between each 'refresh' action undertaken by the activity stream gadget. A refresh makes the activity stream gadget reflect any new activity that has been conducted on the Confluence site.</td>
</tr>
</tbody>
</table>

Confluence News Gadget

The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs and events at Atlassian.

For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

Clicking an item in the Confluence news gadget takes you directly to the selected blog post of the Confluence Product Blogs feed or event...
details on the events at Atlassian page.

Clicking More news takes you to the Confluence Product Blogs feed page and clicking More events takes you to the events at Atlassian page.

Screenshot: Using the News Gadget

<table>
<thead>
<tr>
<th><strong>News</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Movember @ Atlassian: The Home Stretch - Cast your votes!</td>
</tr>
<tr>
<td>Confluence 3.1 Beta 2 is where the wild things are</td>
</tr>
<tr>
<td>Cliffy is helping you make better decisions this November</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Events</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>JIRA 4.0 Seminar Hosted by Cally – 24 Nov</td>
</tr>
<tr>
<td>Ottawa Atlassian User Group – 25 Nov</td>
</tr>
<tr>
<td>JavaEdge 2009 – 26 Nov</td>
</tr>
</tbody>
</table>

Confluence: News Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro’s parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show News?</td>
<td>No</td>
<td>True</td>
<td>Shows a short list of the most recent Confluence Product Blogs.</td>
</tr>
<tr>
<td>Show Events?</td>
<td>No</td>
<td>True</td>
<td>Shows a short list of the most recent events at Atlassian.</td>
</tr>
<tr>
<td>Show Banners?</td>
<td>No</td>
<td>True</td>
<td>Shows any banner advertisements (if available).</td>
</tr>
</tbody>
</table>

Confluence Page Gadget

The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.

For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

Macros that work with the page gadget

Please note, not all macros work with the page gadget. Please refer to the Working Macros section below for more information.

On this page:

- Confluence Page Gadget Properties
- Working Macros
- Related Topics

Screenshot: The Confluence page gadget displaying a sample page
Confluence Page Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>No</td>
<td>None</td>
<td>Specify the space that your desired page is located in. Suggestions will display in a dropdown when you start typing. (Note, this property is only used to make searching for pages easier. It is not required.)</td>
</tr>
<tr>
<td>Page</td>
<td>Yes</td>
<td>None</td>
<td>Specify the page that you want to display in your gadget. Suggestions will display in a dropdown when you start typing.</td>
</tr>
<tr>
<td>Show View Link</td>
<td>No</td>
<td>Yes</td>
<td>Select whether to display a link to view the page on your Confluence site. Clicking the link will open the page in Confluence.</td>
</tr>
<tr>
<td>Show Edit Link</td>
<td>No</td>
<td>No</td>
<td>Select whether to display a link to edit the page on your Confluence site. Clicking the link will open the page for editing in Confluence.</td>
</tr>
<tr>
<td>Refresh Interval</td>
<td>No</td>
<td>Never/false</td>
<td>Specify the time interval between each 'refresh' action undertaken by the page gadget. A refresh makes the activity stream gadget reflect any new activity that has been conducted on the Confluence site.</td>
</tr>
</tbody>
</table>

Working Macros

The Confluence page gadget will only render a subset of the macros that are used in Confluence correctly. Refer to the table below for the list of macros that work and do not work with the page gadget and known limitations.
Some of the issues with macros in the page gadget can be worked around, if you are comfortable developing in Confluence. Please see Troubleshooting Macros in the Page Gadget for more information.

**Key:**
- ✓ Works with the page gadget
- * Partially works with the page gadget
- X Does not work with the page gadget

<table>
<thead>
<tr>
<th>Macro</th>
<th>Works with page gadget?</th>
<th>Limitations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Stream</td>
<td>X</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Anchor (within a page)</td>
<td>✓ *</td>
<td>Opens in a new page</td>
</tr>
<tr>
<td>Attachments</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Blog Posts</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Chart</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Children Display</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By Label</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By User</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Excerpt</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Gallery</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Include Page</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Info</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Labels List</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Livesearch</td>
<td>X</td>
<td>N/A</td>
</tr>
<tr>
<td>Note</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata Summary</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Pagetree Search</td>
<td>X</td>
<td>N/A</td>
</tr>
<tr>
<td>-----------------</td>
<td>---</td>
<td>-----</td>
</tr>
<tr>
<td>Pagetree</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Panel</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Quick Nav</td>
<td>X</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Recently Updated</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>RSS Feed</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Section &amp; Column</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Spaces List</td>
<td>✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>✓</td>
<td>Works, however links will be opened in a new browser window when clicked.</td>
</tr>
<tr>
<td>Tasklist</td>
<td>✓</td>
<td>Tasks can be viewed but not added/edited.</td>
</tr>
<tr>
<td>View File (PDF or PPT)</td>
<td>✓</td>
<td>Works, but you may need to refresh the gadget the first time (see CONF-19932).</td>
</tr>
<tr>
<td>Widget Connector</td>
<td>✓</td>
<td>Only works for some content:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>Works:</strong> blip.tv, Episodic, Flickr, Google Calendar, presentations on Google Docs, MySpace Video, Scribd, Skitch.com, SlideRocket, SlideShare, Viddler, Vimeo, YouTube, Dailymotion, Metacafe, FriendFeed, Yahoo Video, Wufoo HTML Form Builder</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>Does not work:</strong> FriendFeed, Google Gadgets, Google Video (service discontinued), Twitter, Widgetbox, DabbleDB, BackType</td>
</tr>
</tbody>
</table>

**Related Topics**

**Confluence Gadgets**

**Confluence Quicknav Gadget**

The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence site. For more information on how to use this feature, refer to the Quick Navigation Aid section of Searching Confluence.

For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

Screenshot: Using the QuickNav Gadget
Adding JIRA Gadgets to a Confluence Page

This is a summary of steps of the steps required to add a JIRA gadget to a Confluence page:

- If your JIRA site does not allow anonymous access, your JIRA administrator will need to configure JIRA to trust Confluence via Application Links. See the JIRA administrator's guide.
- Your Confluence administrator will need to add the JIRA gadget URL to the list of authorised external gadgets in Confluence. See the Confluence administrator's guide.
- Now you can add the gadget to a wiki page in Confluence using the Macro Browser. See the Confluence user's guide to the Macro Browser and the Gadget macro.

Note that the Confluence Gadget macro is a specific type of macro which is used to display a gadget in a Confluence page - so once you have configured external gadgets in the Confluence Administration Console, they will appear in the Macro Browser.

Related Topics

All Atlassian gadgets
External Gadgets

Working with Macros

Using a macro, you can add extra functionality or include dynamic content in a page. For example, the Attachments macro will list a page's attachments in the page itself, so that readers do not have to visit the Attachments tab.

Including a Macro in your Page

Including Macros with the Macro Browser

To insert a macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
For a complete description of the macro browser, see Working with the Macro Browser.

Macro Parameters

Many macros allow you to include optional parameters to control the macro's output.

With the Attachments Macro, for instance, you have two optional parameters:

- To specify the file formats of the attachments displayed.
- To choose whether or not you want old versions of the attachments displayed.

Macro Placeholders

Macro placeholders are displayed in the editor where you have added a macro to the page.

When editing a page, you can:

- Double-click a macro placeholder to open the Macro Browser (or click on the placeholder and choose Edit), where you can edit the macro's parameters.
- Select a macro placeholder to cut, copy and paste the macro.

 Macros Shipped with your Confluence Installation

When you download your Confluence installation file, many macros are shipped with the download. Below is a list of the macros currently shipped with Confluence. Click a macro name for details of the usage, including optional parameters and examples.

<table>
<thead>
<tr>
<th>Macro Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachments Macro</td>
<td>Displays a list of attachments belonging to the current page.</td>
</tr>
<tr>
<td>Blog Posts Macro</td>
<td>Lists the most recent news items in the space.</td>
</tr>
<tr>
<td>Change-History Macro</td>
<td>Displays a history of updates made to a page.</td>
</tr>
<tr>
<td>Chart Macro</td>
<td>Displays a chart based on tabular data.</td>
</tr>
<tr>
<td>Cheese Macro</td>
<td>Displays the words &quot;I like cheese!&quot;</td>
</tr>
<tr>
<td>Children Display Macro</td>
<td>Displays the children and descendants of the current page.</td>
</tr>
<tr>
<td>Code Block Macro</td>
<td>Displays code in your document with the appropriate syntax highlighting.</td>
</tr>
<tr>
<td>Column Macro</td>
<td>Used with the Section Macro. Defines columns within the page.</td>
</tr>
<tr>
<td>Content by Label Macro</td>
<td>Renders a list of content associated with specific labels.</td>
</tr>
<tr>
<td>Create Space Button Macro</td>
<td>Renders a create space button linked to the create space page.</td>
</tr>
<tr>
<td>Excerpt Macro</td>
<td>Define a part of a page as the page's 'excerpt' which can then be displayed in another page.</td>
</tr>
<tr>
<td>Excerpt Include Macro</td>
<td>Allows you to display an excerpt from another page within the current page.</td>
</tr>
<tr>
<td>Expand Macro</td>
<td>Displays an expandable/collapsible section of text.</td>
</tr>
<tr>
<td>Favourite Pages Macro</td>
<td>Displays a list of your favourite pages.</td>
</tr>
<tr>
<td>Gallery Macro</td>
<td>Forms a thumbnail gallery of all images attached to a page.</td>
</tr>
<tr>
<td>Global Reports Macro</td>
<td>Renders a list of links to global reports within a table.</td>
</tr>
<tr>
<td>HTML Macro</td>
<td>Renders your specified HTML code within the current page.</td>
</tr>
<tr>
<td>Macro Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>HTML Include Macro</td>
<td>Includes the content of an external HTML file into a Confluence page.</td>
</tr>
<tr>
<td>IM Presence Macro</td>
<td>Displays graphically when a contact is online.</td>
</tr>
<tr>
<td>Include Page Macro</td>
<td>Inserts the contents of the specified page into the current one.</td>
</tr>
<tr>
<td>Info Macro</td>
<td>Displays a block of text in a blue highlight box.</td>
</tr>
<tr>
<td>JIRA Macro</td>
<td>Displays one or more JIRA issues on your Confluence page.</td>
</tr>
<tr>
<td>JIRA Issues Macro</td>
<td>Displays a list of JIRA issues in a page.</td>
</tr>
<tr>
<td>JIRA Portlet Macro</td>
<td>Displays a JIRA dashboard portlet in Confluence.</td>
</tr>
<tr>
<td>JUnit Report Macro</td>
<td>Displays a summary of JUnit test results.</td>
</tr>
<tr>
<td>Livesearch Macro</td>
<td>Add a dynamic search box to a wiki page.</td>
</tr>
<tr>
<td>Loremipsum Macro</td>
<td>Display a few paragraphs of pseudo-Latin text.</td>
</tr>
<tr>
<td>Multimedia Macro</td>
<td>Displays videos, animations and more, sourced from a file attached to a Confluence page and displayed on your page.</td>
</tr>
<tr>
<td>Navmap Macro</td>
<td>Renders the list of pages associated with a specified label as a navigable map.</td>
</tr>
<tr>
<td>Noformat Macro</td>
<td>Displays a block of text in monospace font.</td>
</tr>
<tr>
<td>Note Macro</td>
<td>Displays a block of text in a yellow highlight box.</td>
</tr>
<tr>
<td>Panel Macro</td>
<td>Displays a block of text within a fully customisable panel.</td>
</tr>
<tr>
<td>Pagetree Macro</td>
<td>Displays a dynamic, hierarchical list of pages starting from a specified parent (root) page.</td>
</tr>
<tr>
<td>Pagetree Search Macro</td>
<td>Adds a search box to your Confluence page and searches a hierarchy of pages starting from a specified parent (root) page.</td>
</tr>
<tr>
<td>Profile Picture Macro</td>
<td>Displays a user's profile picture on a page.</td>
</tr>
<tr>
<td>Recently Updated Macro</td>
<td>Displays a list of recently changed content (pages, news items, comments, etc).</td>
</tr>
<tr>
<td>Recently Used Labels Macro</td>
<td>Lists labels most recently used in a specified scope (Global, Space, or Personal)</td>
</tr>
<tr>
<td>Related Labels Macro</td>
<td>Lists labels frequently appearing on the same pages as the current page's labels.</td>
</tr>
<tr>
<td>RSS Feed Macro</td>
<td>Displays the contents of an RSS feed.</td>
</tr>
<tr>
<td>Search Macro</td>
<td>Searches Confluence, and includes the results in the page.</td>
</tr>
<tr>
<td>Section Macro</td>
<td>Used with the Column Macro to define columns within the page.</td>
</tr>
<tr>
<td>Space Details Macro</td>
<td>Includes the summary of a Confluence space in the page.</td>
</tr>
<tr>
<td>Spaces List Macro</td>
<td>Displays a list of all spaces visible to the user.</td>
</tr>
</tbody>
</table>
### Information about Other Macros

**Macros Provided by Plugins or User Macros**

Other macros are available as [plugins](#) or as [user macros](#), and can be installed by your Confluence administrator.

Customers using Adaptavist macros or plugins might be interested in the [Adaptavist’s Confluence user guide](#).

Some examples are:

- `{sp-list}` macro, provided by the [Confluence SharePoint Connector](#) – full documentation in the [SharePoint Connector space](#).
- `{float}` macro and others, provided by the [Composition plugin](#) – full documentation by [CustomWare](#).

**Macros that Do Not Work**

Some macros were never intended for external use, and we have always recommended that you do not add them to a wiki page. Nevertheless, it is possible that some Confluence sites have these macros on some pages. Please note that these macros no longer work in Confluence 3.4 onwards. They were part of the Plugin Repository, which we have now replaced with a new plugin manager.

These macros no longer work:

- `{repository-plugin}`
- `{recentlyupdated-plugins}`
- `{popular-plugins}`
- `{download-stat}`
- `{confluence-status}`
- `{plugin-status}`
- `{plugin-repository}`
- `{plugins-supported}`

### Writing your own Macros

To learn how to write your own macro, take a look at the following documentation:

- User macros are simple template-like macros that allow you to create simple formatting macros using the Confluence web interface. Read more about [Writing User Macros](#).
- The [Confluence Plugin Guide](#) tells you how to develop a plugin for Confluence.

### Related Topics
Anchor Macro

The Anchor Macro is documented in Working with Anchors.

Attachments Macro

See Displaying a List of Attachments in a Page.

Blog Posts Macro

The Blog Posts macro allows you to display blog posts on a Confluence page. Clicking on a title takes you to the blog post. The Blog Posts macro generates output like that in the screenshot below:

```
On this page:
  • Using the Blog Posts Macro
  • Parameters
  • Related Topics
```

Using the Blog Posts Macro

To add the Blog Posts macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Content Type to Display</td>
<td>entire</td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• titles — Display a list of blog posts, showing titles only.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• excerpts — Display short excerpts from each blog posts. 'Read more...' links to the full blog post, if the content is more than 500 characters long.</td>
</tr>
<tr>
<td>Time Frame</td>
<td>no limit</td>
<td>Specify how far back in time Confluence should look for the blog posts to be displayed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• m — Minutes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• h — Hours, so '12h' displays blog posts created in the last twelve hours.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• d — Days, so '7d' displays blog posts created in the last seven days.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• w — Weeks</td>
</tr>
<tr>
<td>Parameter</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>----------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Restrict to these Labels</strong></td>
<td>None</td>
<td>Filter the results by label. The macro will display only the blog posts which are tagged with the label(s) you specify here.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can specify one or more label values, separated by a comma or a space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of <code>-badpage</code> you will get only content which is not labelled with <code>badpage</code>.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- To indicate that the results <strong>must</strong> match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of <code>+superpage,+goodpage</code> you will get only content which has at least two labels, being <code>superpage</code> and <code>goodpage</code>.</td>
</tr>
<tr>
<td><strong>Restrict to these Authors</strong></td>
<td>None</td>
<td>Filter the results by author. The macro will display only the blog posts which are written by the author(s) you specify here.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can specify one or more authors, separated by a comma.</td>
</tr>
<tr>
<td><strong>Restrict to these Spaces</strong></td>
<td><code>@self</code>, i.e. the space which contains the page on which the macro is coded</td>
<td>This parameter allows you to filter content by space. The macro will display only the pages which belong to the space(s) you specify here.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can specify one or more space keys, separated by a comma or a space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of <code>-BADSPACE</code> you will get only content which is not in the BADSPACE.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- To indicate that the results <strong>must</strong> come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of <code>+GOODSPACE</code> you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Special values:</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>@self</code> — The current space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>@personal</code> — All personal spaces.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>@global</code> — All global spaces.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>@favorite</code> — The spaces you have marked as favourite.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>@favourite</code> — The same as <code>@favorite</code> above.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>@all</code> — All spaces in your Confluence site.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>*</code> — The same as <code>@all</code> above.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Note:</strong> When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as <code>~jbloggs</code> or <code>~jbloggs@example.com</code>.</td>
</tr>
<tr>
<td><strong>Maximum Number of Blog Posts</strong></td>
<td>15</td>
<td>Specify the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied.</td>
</tr>
<tr>
<td><strong>Sort By</strong></td>
<td>creation</td>
<td>Specify how the results should be sorted. If this parameter is not specified, the sort order defaults to descending order (newest first) based on the creation date.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Values:</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>title</code> — Sort alphabetically by title.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>creation</code> — Sort by the date on which the content was added.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>modified</code> — Sort by the date on which the content was last updated.</td>
</tr>
<tr>
<td><strong>Reverse Sort</strong></td>
<td>false</td>
<td>Select to change the sort from descending to ascending order (oldest first). Use this parameter in conjunction with the <strong>Sort By</strong> parameter. This parameter is ignored if the <strong>Sort By</strong> parameter is not specified.</td>
</tr>
</tbody>
</table>

**Related Topics**

- Working with Macros
- Working with Blog Posts

Take me back to the [Confluence User’s Guide](#).

**Change-History Macro**

The Change-History macro shows the history of updates made to a page — version number, author, date and comment. It displays this
information inline, as shown in the following screenshot.

_Screenshot: The Change-History Macro in Confluence_

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Version (v. 3)</td>
<td>Apr 01, 2009 16:55</td>
<td>Conf Admin</td>
</tr>
<tr>
<td>v. 2</td>
<td>Apr 01, 2009 13:09</td>
<td>Conf Admin</td>
</tr>
<tr>
<td>v. 1</td>
<td>Apr 01, 2009 11:03</td>
<td>Conf Admin</td>
</tr>
</tbody>
</table>

On this page:

- Using the Change-History Macro
- Notes
- Related Topics

### Using the Change-History Macro

To add the Change-History macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

### Notes

There are no parameters for this macro.

### Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

### Chart Macro

The Chart macro allows you to display a chart based on tabular data. When you add the macro to a page, you:

- supply the data to be charted by the macro as a table in the placeholder of the macro.
- edit the macro parameters in the Macro Browser to configure the format of the chart.

_Screenshots: A table of data in the Chart macro placeholder, and the resulting chart image._
Using the Chart Macro

To add the Chart macro to a page:

1. When editing the page, use autocomplete to add the Chart macro to the page. (Type '{' then begin typing the name of the macro, and choose it from the list of suggestions.)
2. Enter your chart data as one or more tables in the body of the macro placeholder (see the screenshot above)
3. Edit the macro and select a chart type using the Type parameter (see below).
4. Make other parameter settings, in the Macro Browser, as described below.
5. Click Preview to check that the chart appears as you expect.
6. Finally, click Save to add the chart to your page.

Parameters

Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification Parameters | Colour Parameters | Axis Parameters | Pie Chart Parameters | Attachment Parameters

Chart Type Parameters

These parameters determine the type of chart to display and the way the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>pie</td>
<td>The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based (see the Time Series parameter).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>* Standard — pie, bar, line, area</td>
</tr>
<tr>
<td></td>
<td></td>
<td>* XY Plots — xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries</td>
</tr>
<tr>
<td></td>
<td></td>
<td>* Other — gantt (beta)</td>
</tr>
</tbody>
</table>

| Display Orientation | vertical | Applies to area, bar and line charts.                                       |
|                    |          | * vertical — y-axis is vertical                                              |
|                    |          | * horizontal — x-axis is vertical                                            |

| Show in 3D | false | Applies to area, bar and line charts.                                       |
| Stacked Values | false | Applies to area and bar charts.                                             |
| Show shapes | true | Applies to line charts. Shapes are shown at each data point.               |
| Opacity | 75 percent for 3D charts, 50 percent for non-stacked area charts, 100 percent for all other charts | A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are. |

Display Control Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Width</strong></td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td><strong>Height</strong></td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
<tr>
<td>Display rendered data</td>
<td>false</td>
<td>Sets whether to display the rendered body of the macro (usually the data tables). By default, the chart data table isn't rendered.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>* before — the data are displayed before the chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>* after — the data are displayed after the chart.</td>
</tr>
<tr>
<td>Image format</td>
<td>png</td>
<td>The image format to be used for the chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>* png</td>
</tr>
<tr>
<td></td>
<td></td>
<td>* jpg</td>
</tr>
</tbody>
</table>

**Title and Label Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart Title</td>
<td>none</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>Chart Subtitle</td>
<td>none</td>
<td>A subtitle for the chart, using a smaller font than for Title.</td>
</tr>
<tr>
<td>Horizontal-axis Label</td>
<td>none</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>Vertical-axis Label</td>
<td>none</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Show a legend or key.</td>
</tr>
</tbody>
</table>

**Data Specification Parameters**

The data for the chart is taken from tables found when the macro body is rendered. These options control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. Additional conversion options can be specified using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables</td>
<td>all first level tables</td>
<td>Comma separated list of table ids and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
</tr>
<tr>
<td>Columns</td>
<td>all columns</td>
<td>Comma separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the (html) title attribute for the column in the header row.</td>
</tr>
<tr>
<td>Content Orientation</td>
<td>horizontal</td>
<td>• vertical — data table columns will be interpreted as series.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• horizontal — data tables rows will be interpreted as series.</td>
</tr>
<tr>
<td>Time Series</td>
<td>false</td>
<td>• true — the x values in an XY plot will be treated as time series data and so will be converted according to date formats.</td>
</tr>
<tr>
<td>Date format</td>
<td>Confluence language defined date formats</td>
<td>For time series data, the date format allows for additional customization of the conversion of data to date values. If a Date format is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See simple date format.</td>
</tr>
<tr>
<td>Time Period</td>
<td>Day</td>
<td>The time period for time series data. Defines the granularity of how the data is interpreted. Valid values are: Millisecond, Second, Minute, Hour, Day, Week, Month, Quarter, Year.</td>
</tr>
<tr>
<td>Language</td>
<td>none</td>
<td>Use in combination with the Country parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages. Valid values are 2 character ISO 639-1 alpha-2 codes.</td>
</tr>
<tr>
<td>Country</td>
<td>none</td>
<td>Use in combination with the Language parameter to form a locale. Valid values are 2 character ISO 3166 codes.</td>
</tr>
</tbody>
</table>
Forgive

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>true — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>false — enforce strict data format. Data format errors will cause the chart to not be produced.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Colour Parameters

Colours are specified using hexadecimal notation or HTML colour names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background Colour</td>
<td>White</td>
<td>Background of the chart.</td>
</tr>
<tr>
<td>Border Colour</td>
<td>no border</td>
<td>Border around the chart.</td>
</tr>
<tr>
<td>Colours</td>
<td></td>
<td>Comma-separated list of colours used to customise category, sections, and series colours.</td>
</tr>
</tbody>
</table>

Axis Parameters

Depending on the chart type, the range and domain axis may be customised. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range Minimum Value</td>
<td>none</td>
<td>Range axis lower bound.</td>
</tr>
<tr>
<td>Range Maximum Value</td>
<td>none</td>
<td>Range axis upper bound.</td>
</tr>
<tr>
<td>Range Axis Tick Unit</td>
<td>none</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>Range Axis Label Angle</td>
<td>none</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>Domain Axis Lower Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the Date format parameter.</td>
</tr>
<tr>
<td>Domain Axis Upper Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the Date format parameter.</td>
</tr>
<tr>
<td>Domain Axis Tick Unit</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the Time Period parameter. The Time Period unit can be overridden by specifying a trailing character: y (years), M (months), d (days), h (hours), m (minutes), s (seconds), u (milliseconds).</td>
</tr>
<tr>
<td>Domain Axis Label Angle</td>
<td>none</td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
</tr>
<tr>
<td>Category Label Position</td>
<td>none</td>
<td>Placement of the axis label text for categories.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• up45 — 45 degrees going upward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• up90 — 90 degrees going upward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• down45 — 45 degrees going downward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• down90 — 90 degrees going downward</td>
</tr>
<tr>
<td>Date Tick Mark Position</td>
<td>start</td>
<td>Placement of the date tick mark.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• start — tick mark is at the start of the date period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• middle — tick mark is in the middle of the date period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• end — tick mark is at the end of the date period.</td>
</tr>
</tbody>
</table>
### Pie Chart Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Pie Section Label | Show only the pie section key value | Format for how pie section labels are displayed. The format uses a string with special replacement variables:  
  * %0% is replaced by the pie section key.  
  * %1% is replaced by the pie section numeric value.  
  * %2% is replaced by the pie section percent value.  
  Example 1: "%0% = %1%" would display something like "Independent = 20%"  
  Example 2: "%0% (%2%)" would display something like "Independent (20%)" |
| Pie Section Explode | No exploded sections | Comma separated list of pie keys that are to be shown exploded. Note: requires jFreeChart version 1.0.3 or higher. |

### Attachment Parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is displayed. These options allow for the generated image to be saved as an attachment and have subsequent access re-use the attachment. This can be useful especially when combined with the Cache Plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Attachment | none | The name and location with which the chart image will be saved as an attachment. The user must be authorised to add attachments to the page specified.  
  * ^attachmentName.png — the chart is saved as an attachment to the current page.  
  * page^attachmentName.png — the chart is saved as an attachment to the page name provided.  
  * space:page^attachmentName.png — the chart is saved as an attachment to the page name provided in the space indicated. |
| Attachment Version | new | Defines the the versioning mechanism for saved charts.  
  * new — creates new version of the attachment.  
  * replace — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorized to remove attachments for the page specified.  
  * keep — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated. |
| Attachment Comment | none | Comment used for a saved chart attachment. |
| Thumbnail | false | true — the chart image attachment will be shown as a thumbnail. |

### Chart Parameters

- **Type**
- **Chart Title**
- **Show Legend**
- **Fish Type 2011**
  - Herring: 9,500
  - Salmon: 2,900
  - Tuna: 1,500

### Examples

**Pie Chart**

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>pie</td>
<td></td>
</tr>
<tr>
<td>Chart Title</td>
<td>Fish Sold 2011</td>
<td></td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>Fish Type 2011</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fish Type</td>
<td>2011</td>
<td></td>
</tr>
<tr>
<td>Herring</td>
<td>9,500</td>
<td></td>
</tr>
<tr>
<td>Salmon</td>
<td>2,900</td>
<td></td>
</tr>
<tr>
<td>Tuna</td>
<td>1,500</td>
<td></td>
</tr>
</tbody>
</table>
Time Series Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Tables in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td><strong>Time Series</strong></td>
<td></td>
</tr>
<tr>
<td>Date Format</td>
<td>MM/yyyy</td>
<td></td>
</tr>
<tr>
<td>Time Period</td>
<td>Month</td>
<td></td>
</tr>
<tr>
<td>Data Orientation</td>
<td>vertical</td>
<td></td>
</tr>
<tr>
<td>Range Axis Lower Bound</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Month</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2011</td>
<td>31.8</td>
</tr>
<tr>
<td>2/2011</td>
<td>41.8</td>
</tr>
<tr>
<td>3/2011</td>
<td>51.3</td>
</tr>
<tr>
<td>4/2011</td>
<td>33.8</td>
</tr>
<tr>
<td>5/2011</td>
<td>27.6</td>
</tr>
<tr>
<td>6/2011</td>
<td>49.8</td>
</tr>
<tr>
<td>7/2011</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2011</td>
<td>77.3</td>
</tr>
<tr>
<td>9/2011</td>
<td>73.8</td>
</tr>
<tr>
<td>10/2011</td>
<td>97.6</td>
</tr>
<tr>
<td>11/2011</td>
<td>101.2</td>
</tr>
<tr>
<td>12/2011</td>
<td>113.7</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Month</th>
<th>Expenses</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2011</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2011</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2011</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2011</td>
<td>45.0</td>
</tr>
<tr>
<td>5/2011</td>
<td>44.6</td>
</tr>
<tr>
<td>6/2011</td>
<td>43.8</td>
</tr>
<tr>
<td>7/2011</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2011</td>
<td>52.3</td>
</tr>
<tr>
<td>9/2011</td>
<td>53.8</td>
</tr>
<tr>
<td>10/2011</td>
<td>55.6</td>
</tr>
<tr>
<td>11/2011</td>
<td>61.2</td>
</tr>
<tr>
<td>12/2011</td>
<td>63.7</td>
</tr>
</tbody>
</table>

XY Line Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>xyLine</td>
<td></td>
</tr>
</tbody>
</table>

| 12 | 14 | 23 |
### XY Area Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>xyArea</td>
<td>12 14 23</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Revenue 41.1 31.8 12.4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Expense 31.1 41.8 43.6</td>
</tr>
</tbody>
</table>

### Area Charts

#### Example 1

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>area</td>
<td>Satisfaction 2009 2010 2011</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Very satisfied 20 23 34</td>
</tr>
<tr>
<td>Width</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Opacity</td>
<td>50</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Satisfied 40 34 23</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Dissatisfied 25 26 25</td>
<td></td>
</tr>
</tbody>
</table>
Example 2

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>area</td>
<td></td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Stacked Values</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td><strong>Satisfaction</strong></td>
<td><strong>2009</strong>  <strong>2010</strong>  <strong>2011</strong></td>
<td></td>
</tr>
<tr>
<td>Very satisfied</td>
<td>12 23 31</td>
<td></td>
</tr>
<tr>
<td>Satisfied</td>
<td>1 34 36</td>
<td></td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>4 6 22</td>
<td></td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>2 7 12</td>
<td></td>
</tr>
</tbody>
</table>

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Cheese Macro

The Cheese macro simply displays the words "I like cheese!"

You can use this macro to test the Confluence macro functionality. 😊

Using the Cheese Macro
To add the Cheese macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

The cheese macro renders the following message on the page: I like cheese!

There are no parameters for this macro.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Children Display Macro

Use the Children Display macro to display the child pages of a page and the descendents (childrens' children). Links to the children are displayed as in the screenshot below:

Screenshot: The Children Display Macro in Confluence

Confluence allows you to collect and archive mail within each space individually. all emails pertaining to a particular project on Confluence alongside it in the same

- Adding a Mail Account
- Deleting Mail
- Fetching Mail
- Importing Mail
- Linking to Mail
- Managing Mail Accounts
- Restoring Mail
- Viewing Mail

Note that only pages for which you have 'View' permission will be displayed.

On this page:

- Using the Children Display Macro
- Parameters
- Related Topics

Using the Children Display Macro

To add the Children Display macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Descendants</td>
<td>false</td>
<td>Select to display all descendents.</td>
</tr>
</tbody>
</table>
| **Parent Page** | current | Specify the page to display children for, from either the current space or a different space. Enter:
| | | • ‘/’ — to list the top-level pages of the current space, i.e. those without parents.
| | | • ‘pagename’ — to list the children of the specified page.
| | | • ‘spacekey:pagename’ — to list the children of the specified page in the specified space.
| **Number of Children** | none | Restrict the number of children displayed at the top level.
| **Depth of Descendants** | none | Enter a number to specify the depth of descendents to display.
| **Heading Style** | none | Choose the style used to display descendents.
| **Include Excerpts** | false | Display excerpts for the child pages, if they exist.
| **Sort Children By** | Manual if manually ordered, otherwise alphabetical | Optional. Choose:
| | | • creation — to sort by content creation date
| | | • title — to sort alphabetically on title
| | | • modified — to sort of last modification date.
| **Reverse Sort** | false | Use with the Sort Children By parameter. When set, the sort order changes from ascending to descending.

**Related Topics**

- Working with Page Families
- Working with Macros

Take me back to the Confluence User's Guide.

**Child Page 1**

**Grandchild**

**Child Page 2**

This page is used to test the `{children}` macro.

**Related Topics**

- Children Display Macro

**Code Block Macro**

The Code Block macro allows you to display source code in your document with the appropriate syntax highlighting. The code block displays on the page as shown below:

```java
public static void main(String[] args) {
    System.out.println("Hello World!");
}
```

On this page:

- Using the Code Block Macro
- Parameters
- Related Topics
Using the Code Block Macro

To add the Code Block macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

You can now type the code block directly into the macro placeholder in the editor. Note that any white space contained in the placeholder is not manipulated in any way by the Code Block macro. This is to provide the writer with flexibility over code indentation.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Syntax highlighting      | java    | Specifies the language (or environment) for syntax highlighting. The default language is Java but you can choose from one of the following languages/environments:
  * actionscript3
  * bash
  * csharp (C#)
  * coldfusion
  * cpp (C++)
  * css
  * delphi
  * diff
  * erlang
  * groovy
  * html/xml
  * java
  * javafx
  * javascript
  * none (no syntax highlighting)
  * perl
  * php
  * powershell
  * python
  * ruby
  * scala
  * sql
  * vb |
| Title                    | none    | Adds a title to the code block. If specified, the title will be displayed in a header row at the top of the code block. |
| Collapsible              | false   | If selected, the code macro’s content will be collapsed upon visiting or refreshing the Confluence page. Clicking the expand source link allows you to view this content. If false, the code macro’s content is always displayed in full. |
| Show line numbers        | false   | If selected, line numbers will be shown to the left of the lines of code. |
| First line number        | 1       | When Show line numbers is selected, this value defines the number of the first line of code. |
| Theme                    | Default | Specifies the colour scheme used for displaying your code block. Many of these themes are based on the default colour schemes of popular integrated development environments (IDEs). The default theme is Confluence (also known as Default), which is typically black and coloured text on a blank background. However, you can also choose from one of the following other popular themes:
  * DJango
  * Emacs
  * FadeToGrey
  * Midnight
  * RDark
  * Eclipse
  * Confluence |
Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Column Macro

The Column macro allows you to define a single column in a page.

Columns must be defined within a 'section' of a page. So, to display columns correctly in a page, the Column macro placeholders must be inserted within a Section macro placeholder.

Once you have defined the columns inside a Section macro, you can add content to each of the Column macro placeholders.

On this page:
- Using the Column Macro
- Parameters
- Related Topics

The following screenshot shows two columns defined within a section of a page:

![Section]

<table>
<thead>
<tr>
<th>Column</th>
<th>Column</th>
</tr>
</thead>
<tbody>
<tr>
<td>The content of column one is entered within the placeholder of the first Column macro placeholder here.</td>
<td>The content of column two is entered within the placeholder of the second Column macro placeholder here.</td>
</tr>
</tbody>
</table>

which renders on the page like this:

The content of column one is entered within the placeholder of the first Column macro placeholder here.

The content of column two is entered within the placeholder of the second Column macro placeholder here.

Using the Column Macro

To add the Column macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

⚠️ Column macros must be inserted within a Section macro for columns to be displayed correctly on a page.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

285
Column Width

| Column Width | 100% of the page width, divided equally by the number of columns in the section. | The width of the column. Can be specified either in pixels (e.g. 400px) or as a percentage of the available page width (e.g. 50%). |

Related Topics

- Working with Macros
- Working with Tables

Take me back to the Confluence User's Guide.

Content by User Macro

The Content by User macro generates a tabulated list of the content items, throughout the Confluence installation, that have been created by a specified Confluence user. The list includes all current pages, comments and spaces created by the user. Each item in the table is linked to its corresponding page, page comment or space dashboard.

Note that items for page comments contain a link to the page, followed by a second link to the comment itself, with these separated by a greater-than sign (>).

On this page:

- Using the Content by User Macro
- Parameters
- Related Topics

Using the Content by User Macro

To add the Content by User macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>none</td>
<td>The Confluence username for a person who has created content.</td>
</tr>
</tbody>
</table>

Related Topics

- Working with Macros

Take me back to the Confluence User's Guide.

Contributors Macro

The Contributors macro displays a list of Confluence users who have made a contribution of some type to a page. It can also be used to list watchers of this page.

The scope of this macro can be extended to include the immediate children or descendants of the specified page. The list of contributors can be based on people who have:

- authored or edited the page(s)
- contributed comments or added labels to the page(s), or
- are simply watching the page(s).

On this page:

- Using the Contributors Macro
- Parameters
- Related Topics
Using the Contributors Macro

To add the Contributors macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Contribution Type                | authors | Filters by either the type of contribution made to a page (and optionally its descendant pages), or the watches on the page. Contribution types are:
|                                  |         | - authors - includes people who created or have edited the page(s)
|                                  |         | - comments - includes people who have added comments to the page(s)
|                                  |         | - labels - includes people who have added labels to the page(s)
|                                  |         | - watches - includes people who are watching the page(s).
|                                  |         | You can specify one or more contribution types, each of which must be separated by a comma. |
| Sort By                          | count   | Specifies the criteria used to sort contributors. Sort criteria are:
|                                  |         | - count - sorts people based on the total number of contributions to the page(s)
|                                  |         | - name - sorts people into alphabetical order
|                                  |         | - update - sorts people based on the date of their last contribution to the page(s). |
| Reverse Sort                     | false   | Reverses the sort order of contributors in the list. Must be used in conjunction with the Sort By parameter. |
| Maximum Number of Contributors   | no limit | Limits the number of contributors in the list. If a number is not specified, all contributors are included. |
| Display Format                   | inline  | Sets how the list of contributor's names is formatted:
|                                  |         | - inline — a comma-separated list
|                                  |         | - list — a bullet-point list. |
| Show Anonymous Contributions?    | false   | Sets whether to include those who contributed anonymously to a page. |
| Show Count?                      | false   | Sets whether to show the number of times each person made a contribution of the specified Contribution Type. |
| Show Last Contribution Time?     | false   | Sets whether to show the last time each person made a contribution of the specified Contribution Type. |
**Page Name** | current | Specifies the page to use when generating the list of contributors. If *Page Name* and *Space(s)* are left blank, the current page is assumed.

**Label(s)** | none | Filters the list of contributors to those who created the specified labels from a page. You can specify one or more labels, each of which must be separated by a comma.

**Space(s)** | current | Specifies the space key of the Confluence space that contains the page set in *Page Name* or alternatively, specifies the spaces to search. Space keys are case-sensitive.

This parameter also takes special values, including:

- `@global` — All global spaces.
- `@personal` — All personal spaces.
- `@all` — All spaces in your Confluence site.

You can specify one or more space keys or special values, each of which must be separated by a comma.

If no *Page Name* and *Label(s)* are specified, all pages from the specified set of spaces are included.

**Content Type** | both pages and blog posts | Restricts the content type to use when generating the list of contributors:

- **pages** — pages
- **blogposts** — blog posts.

**Blog Post Date** | none | Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD.

**Include Page Hierarchy** | specified page only | Specifies additional pages to include when generating the list of contributors:

- **children** — just the child pages of the specified page
- **descendants** — all descendants of the specified page.

**Show Selected Pages** | false | Sets whether to show a list of the pages used to generate the list of contributors.

**Custom "None Found" Message** | default message | Specifies the message to be used to override the default message that is displayed when no contributors are found.

### Related Topics

- **Contributors Summary Macro**
- **Working with Macros**

Take me back to the [Confluence User's Guide](#).

## Contributors Summary Macro

The Contributors Summary macro displays a table of contribution-based statistics for a set of pages. These statistics can be grouped according to individual pages or individual contributors.

The default scope for this macro is an individual page, but this can be extended to include the immediate children or descendants of a specified page. The statistics cover the following types of contributions:

- edits to the page(s)
- comments added to the page(s)
- labels added to the page(s)
- people watching the page(s)

### On this page:

- Using the Contributors Summary Macro
- Parameters
- Related Topics

A simple example of the Contributors Summary macro is shown in the screenshot below. It lists statistics for the number of times each contributor has edited, added comments and added labels to this page.
Using the Contributors Summary Macro

To add the Contributors Summary macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Group By**       | contributors| Specifies the basis for grouping contribution-based statistics:  
|                    |             | • contributors — group by the people who have contributed  
|                    |             | • pages — group by the pages used to find contributors.  
| **Columns to Display** | edits,comments,labels | Sets the columns that should appear in the table. The statistics or type of information presented depends on the basis for grouping set with the **Group By** parameter. Statistics may be calculated for:  
|                    |             | • edits — the number of times each contributor has edited the page(s) or the number of edits made to each page.  
|                    |             | • edited — a list of the pages edited by each contributor or a list of contributors who have edited each page.  
|                    |             | • comments — the number of times each contributor has added comments to the page(s) or the number of comments on each page.  
|                    |             | • commented — a list of pages to which each contributor has added comments or a list of contributors who have commented on each page.  
|                    |             | • labels — the number of times each contributor has added labels to the page(s) or the number of labels on each page.  
|                    |             | • labeled — a list of pages to which each contributor has added labels or a list of contributors who have added a label to each page.  
|                    |             | • labellist — a list of labels either added by each contributor or on each page.  
|                    |             | • watches — the number of pages being watched by each contributor/person or the number of contributors/people watching each page.  
|                    |             | • watching — a list of pages being watched by each contributor/person or a list of contributors/people watching each page.  
|                    |             | • lastupdate — the last time each contributor made an update or when each page was last updated. Valid updates can include edit, comment or label modifications to a page.  
|                    |             | One or more columns can be used.  

In this example, all default parameter settings are used. For more information about this macro's parameters, refer to the Parameters section below.
<table>
<thead>
<tr>
<th>Table Heading</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sort By</strong></td>
<td>count</td>
<td>Sets the criterion used for sorting items in the table. The items sorted depend on the basis for grouping set with the <strong>Group By</strong> parameter. Sort criteria are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>edits</strong> — sorts items in the table based on the total number of edits made, either by a contributor or to a page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>name</strong> — sorts items in the table in alphabetical order, either by contributor or page name.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>editTime</strong> — sorts items in the table based on when the contributor last edited a page (or a specified set of pages) or when the page was last edited.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>update</strong> — sorts items in the table based on when the contributor last made any contribution to a page (or a specified set of pages) or when the page last had any contribution made to it.</td>
</tr>
<tr>
<td><strong>Reverse Sort</strong></td>
<td>false</td>
<td>Reverses the sort order of items in the table, as specified using the <strong>Sort By</strong> parameter. (Used only in conjunction with the <strong>Sort By</strong> parameter.)</td>
</tr>
<tr>
<td><strong>Maximum Number of Items</strong></td>
<td>no limit</td>
<td>Limits the number of contributors or pages in the table to the value specified. If no number is specified, all items are included.</td>
</tr>
<tr>
<td><strong>Show Anonymous Contributions?</strong></td>
<td>false</td>
<td>Includes individuals who have made anonymous contributions to a page.</td>
</tr>
<tr>
<td><strong>Show Zero Counts?</strong></td>
<td>false</td>
<td>Sets whether contributors or pages are included for which a calculated statistic is zero.</td>
</tr>
<tr>
<td><strong>Page Name</strong></td>
<td>current</td>
<td>Sets the page for which to calculate the contribution-based statistics. If no values for <strong>Page Name</strong> and <strong>Space(s)</strong> are specified, the current page is assumed.</td>
</tr>
<tr>
<td><strong>Label(s)</strong></td>
<td>none</td>
<td>Restricts the contribution-based statistics to the specified labels only. You can specify one or more labels, each of which must be separated by a comma.</td>
</tr>
<tr>
<td><strong>Space(s)</strong></td>
<td>current</td>
<td>Specifies the space key of the Confluence space which contains the specified page name or alternatively, specifies a scope of spaces to search. Space keys are case-sensitive.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This parameter also takes special values, including:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- @global — All global spaces.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- @personal — All personal spaces.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- all — All spaces in your Confluence site.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can specify one or more space keys or special values, each of which must be separated by a comma.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If no <strong>Page Name</strong> and <strong>Label(s)</strong> are specified, all pages from the specified set of spaces are included.</td>
</tr>
<tr>
<td><strong>Content Type</strong></td>
<td>both pages and blog posts</td>
<td>Restricts page types to either pages (<strong>pages</strong>) or blog posts (<strong>blogposts</strong>). If no value is specified in the Macro Browser, both pages and blog posts are included.</td>
</tr>
<tr>
<td><strong>Blog Post Date</strong></td>
<td>none</td>
<td>Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD.</td>
</tr>
<tr>
<td><strong>Include Page Hierarchy</strong></td>
<td>specified page only</td>
<td>Includes either the immediate <strong>children</strong> or all <strong>descendants</strong> of the specified page. If no value is indicated in the Macro Browser, only the specified page is included.</td>
</tr>
</tbody>
</table>

**Related Topics**

- **Contributors Macro**
- **Working with Macros**

Take me back to the Confluence User’s Guide.

**Create Space Button Macro**

The Create Space Button macro renders a create space icon that links to the 'Create Space' page. The icon appears as rendered below.
Using the Create Space Button Macro

To add the Create Space Button macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Icon Size</td>
<td>large</td>
<td>Specify whether to use large or small icon:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• large</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• small</td>
</tr>
</tbody>
</table>

Related Topics

Setting up a New Global Space
Working with Macros

Take me back to the Confluence User's Guide.

Documentation Link Macro

The Documentation Link macro generates a customisable text link to a page on http://confluence.atlassian.com/.

This macro accepts a relative link value and automatically prefixes that value with the URL:

http://confluence.atlassian.com/

For example, if you use the following relative link:

display/DOC/Working+with+Macros

then the resulting URL is:

http://confluence.atlassian.com/display/DOC/Working+with+Macros

The text that will be hyperlinked is the macro's body text (that is, the text between the macro tags). See the example below.

On this page:

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters
- Related Topics
Usage with the Macro Browser

To insert the Documentation Link macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Usage with the Wiki Markup Editor

Example of what you need to type | What you will get
---|---
{doc:display/DOC/Working+with+Macros}this link{doc} | this link

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required in Wiki Markup?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relative Link</td>
<td>yes</td>
<td>none</td>
<td>The relative link (that is, the URL portion after <a href="http://confluence.atlassian.com/">http://confluence.atlassian.com/</a>) that leads to the required page on <a href="http://confluence.atlassian.com/">http://confluence.atlassian.com/</a> .</td>
</tr>
</tbody>
</table>

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Excerpt Include Macro

The Excerpt Include macro is used to display 'excerpted' (that is, a segment of) content from one page in another.

To use this macro, the excerpt must have been defined using the Excerpt macro and both pages must exist in the same space. Note that you can have more than one Excerpt Include macro on a page (although you can have only one Excerpt macro on a page).

The excerpt appears as shown below:

On this page:
- Using the Excerpt Include Macro
- Parameters
- Related Topics

For this example, we are taking content from a page called 'Excerpt Macro', where the Excerpt macro has already been placed. The title of the page is shown at the top of the panel and the content within the body of the macro placeholder is rendered in the panel.

Using the Excerpt Include Macro

To add the Excerpt Include macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Containing the Excerpt</td>
<td>none</td>
<td>Specifies the page that contains the excerpt to be displayed.</td>
</tr>
<tr>
<td>Remove Surrounding Panel</td>
<td>false</td>
<td>Controls whether the panel border around the excerpt and the page title should be hidden. By default, the panel is always shown.</td>
</tr>
</tbody>
</table>

**Related Topics**

*Excerpt Macro*

*Working with Macros*

Take me back to the Confluence User's Guide.

**Excerpt Macro**

The Excerpt macro is used to mark a part of a page's content for re-use. By itself, the Excerpt macro does not change the display of a page. However, defining an excerpt enables other macros, such as the Excerpt Include and Blog Posts macros to display the marked content elsewhere.

ℹ️ You can only define one excerpt per page. In other words, you can only add the Excerpt macro once to a page.

---

**Using the Excerpt Macro**

**To add the Excerpt macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

You can then add content to the body of the Excerpt macro placeholder.

**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Excerpted Content</td>
<td>false</td>
<td>Controls whether the page content contained in the Excerpt macro placeholder is displayed on the page.</td>
</tr>
</tbody>
</table>

**Related Topics**

*Excerpt Include Macro*

*Working with Macros*

Take me back to the Confluence User's Guide.

**Expand Macro**
The Expand macro displays an expandable/collapsible section of text on your page. Here is an example:

.expand

Click here to expand...
This text is hidden until you expand the section.

Using the Expand Macro

To insert the Expand macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Click here to expand...</td>
<td>Defines the text that appears next to the expand/collapse icon.</td>
</tr>
</tbody>
</table>

Notes

- **HTML exports do not show the expanded text.** When you export the page to HTML, the text between the macro tags is not visible. Nothing happens when readers click the 'expand' icon. This issue is logged as CONF-21092. If you like, you can vote for the issue or 'watch' it to keep informed of progress.

- **Text is expanded in PDF exports.** When you export the page to PDF, the text between the macro tags is expanded so that readers can see it on the PDF page.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Favourite Pages Macro

Use the Favourite Pages macro to display a list of your favourite pages.

The output of the Favourite Pages macro appears as in the following screenshot.

Screenshot: The Favourite Pages Macro in Confluence

<table>
<thead>
<tr>
<th>Favourite Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Displaying pages recently added to your favourites list.</td>
</tr>
<tr>
<td>🏡 Home</td>
</tr>
<tr>
<td>📜 Macro Testing Page</td>
</tr>
</tbody>
</table>

On this page:

- Using the Favourite Pages Macro
- Related Topics
Using the Favourite Pages Macro

To insert the favourite pages macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

There are no parameters for this macro.

Related Topics

Working with Favourites
Working with Macros

Take me back to the Confluence User's Guide.

Gadget Macro

Gadgets are small applications that can offer dynamic content. They are typically served from a web application server and can be re-used in many other web applications. In Confluence, add gadgets to pages or blog posts with the gadget macro.

Confluence comes bundled with a few of its own gadgets which can be added to your pages or blog posts using the gadget macro via the macro browser. Refer to Confluence Gadgets for more information. However, you can access additional gadgets in this list if your Confluence Administrator has:

- Installed additional gadgets locally within your Confluence installation (typically as a Confluence plugin) or
- Registered gadgets served from an external web application or website (such as those from a JIRA installation or iGoogle) via the External Gadgets page.

Unlike other macros in the macro browser, the name of each gadget macro in the macro browser is typically unique and follows the convention "<gadget-name>"macro" where <gadget-name> is the name supplied by the gadget itself.

On this page:

- Inserting Gadgets into a Confluence Page or Blog Post
- Editing Gadgets on a Confluence Page or Blog Post
- Parameters
- Contents of a Gadget Macro
- Related Topics

Inserting Gadgets into a Confluence Page or Blog Post

To insert a gadget into a page using the Macro Browser:

1. Edit your page or blog post.
2. Choose Insert > Other Macros.
3. Click External Content to see a list of gadgets configured for use in your Confluence installation.
   - Some Confluence macros like the JIRA Issues, JIRA Portlet, RSS Feed, Tasklist and Widget Connector macros also appear in this category because they can also access external content.
4. Click on the desired gadget to access its parameters and properties and preview any changes to these values.
5. Set the gadget's parameters and properties to your requirements.
   - Click Refresh to update the gadget with any changes to parameters, properties or external data.
6. Click Insert when finished.

Editing Gadgets on a Confluence Page or Blog Post

To edit an existing gadget on a page or blog post using the Macro Browser:

1. Edit your page or blog post.
2. Double-click on the Gadget macro placeholder.
3. Set the gadget's parameters and properties to your requirements.
   - Click Refresh to update the gadget with any changes to parameters, properties or external data.
4. Save the gadget.

Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the Macro Browser. Each gadget may also have its own set of modifiable properties.
Parameters

Parameters are settings for Confluence gadgets, controlling presentation.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>450 pixels</td>
<td>Expands or shrinks the size of the gadget to match the specified width. The width can be specified in pixels (using px or plain numbers, for example, 500px or 500), as a percentage of the page width (using %, for example, 50%), or automatically resized to fit 100% of the page width (using the value auto).</td>
</tr>
<tr>
<td>Border</td>
<td>false</td>
<td>Places a thin grey border around the perimeter of the gadget.</td>
</tr>
</tbody>
</table>

Contents of a Gadget Macro

The body of a gadget macro contains 'parameter-like' content, which represents specific property settings that are particular to each gadget. Hence they are not documented here. Typically, this content would only be changed by customising the gadget's default properties using the macro browser.

Related Topics

The big list of Atlassian gadgets

Gallery Macro

The Gallery Macro displays a gallery of thumbnail images in a table, based on the images attached to a Confluence page. When viewing the page, a user can click a thumbnail image to zoom into the full-size image and then view the images as a slide show.

See below for instructions on how to add the gallery macro to your page.

The gallery macro appears as in the screenshot below.

On this page:

- Using the Gallery Macro
- Parameters
- Related Topics

Screenshot: The Gallery Macro in Confluence

Using the Gallery Macro

To insert the Gallery macro into a page:
1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

### Parameters

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

The full list of parameters is shown in the following table.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Gallery Title</strong></td>
<td>Nothing</td>
<td>Specify a title for your gallery.</td>
</tr>
<tr>
<td><strong>Number of Columns</strong></td>
<td>4</td>
<td>Specify the number of columns for your table.</td>
</tr>
<tr>
<td><strong>Images to Exclude</strong></td>
<td>No exclusions i.e. include all the pictures on the page.</td>
<td>The gallery will ignore any pictures specified. You can specify more than one picture, separated by commas. Please note, the filename and filetype for this parameter are case-sensitive, i.e. 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
<tr>
<td><strong>Include these Images Only</strong></td>
<td>Include all the pictures on the page.</td>
<td>If you specifically include one or more pictures, the gallery will show only those pictures. You can specify more than one picture, separated by commas. Please note, the filename and filetype for this parameter are case-sensitive, i.e. 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
<tr>
<td><strong>Use Images in these Pages</strong></td>
<td>If no page is specified, the gallery macro displays the images attached to the page on which the macro is used.</td>
<td>Specify the title of the page which contains the images you want displayed. To specify a page in a different space, use the SPACEKEY:Page Title syntax.</td>
</tr>
</tbody>
</table>
| **Sort Images By**        | None, i.e. the sort order is unspecified and therefore unpredictable.       | Specify an attribute to sort the images by. Sort order is ascending, unless you select the **Reverse Sort** parameter (see below). Options are:
  * name – file name.
  * comment – comment linked to the attached file.
  * date – date/time last modified.
  * size – size of the attached file. |
| **Reverse Sort**          | Off, i.e. sort order is ascending | Used in conjunction with the **Sort Images By** parameter above. Use **Reverse Sort** to reverse the sort order, from ascending to descending. |

ℹ️ If the name of an attached file or page contains a comma, you can refer to it in the relevant parameters above by enclosing it in single or double quotes, for example "this,that.jpg", theother.png.
Considerations for using the gallery macro

- The images shown in the gallery are taken from the files attached to the Confluence page. You can also specify a different page where the attachments are located. For information about attaching images to a page, see Attaching Files to a Page.
- The comments below the images are drawn from the comments on the attachments. For information about adding comments to attachments, see Attaching Files to a Page.
- By default, the gallery will include all the images attached to the page. You can also exclude or include images using parameters.
- Only the following file formats are supported: .gif, .png, .jpeg. The .bmp format is not supported.
- You can sort your images into a particular order.
- You can specify a title for the gallery and also configure how many columns you want for the table in which your images are displayed.

Related Topics

Displaying Images
Attaching Files to a Page
Editing Attachment Properties
Working with Macros

Global Reports Macro

The Global Reports macro renders a list of links to global reports.

This includes a list of new or updated pages Managing Undefined Pages on the site and RSS feeds for new pages and blog posts.

The Global Reports macro appears as shown in the screenshot below.

Screenshot: The Global Reports macro in Confluence

Using the Global Reports Macro

To add the Global Reports macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width of Table</td>
<td>99%</td>
<td>Specifies the width of the table in which the links are displayed, as a percentage of the window width.</td>
</tr>
</tbody>
</table>

Related Topics

Subscribing to RSS Feeds within Confluence
Working with Macros

Take me back to the Confluence User's Guide.
HTML Include Macro

The HTML Include macro allows you to include the contents of an external HTML file in a Confluence page.

**CAUTION: Including unknown HTML inside a webpage is dangerous.**

HTML can contain active scripting components. This means that it would be possible for a malicious attacker to present a user of your site with script that their web browser would believe came from you. Such code could be used, for example, to steal a user's authentication cookie and give the attacker their Confluence login password.

Using the HTML Include Macro

To insert the HTML Include macro into a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML Page's URL</td>
<td>None</td>
<td>The URL of the page to include.</td>
</tr>
</tbody>
</table>

Troubleshooting

- The HTML Include macro will only be available if it has been enabled by your Confluence administrator. Also, your Confluence Administrator can define a whitelist of trusted URLs. You will see an error message on the Confluence page if the included URL is not in the whitelist.
- You can only use the HTML Include macro for pages with absolute links. If you use the macro to include an HTML page that has relative links, navigating those links in the wiki results in a 'Page Not Found' error. See CONF-6567.

Related Topics

HTML Macro
Working with Macros
Configuring a URL Whitelist

Take me back to Confluence User's Guide

HTML Macro

The HTML macro allows you to add HTML code to a Confluence page.

ℹ️ Note that the HTML macro will only be available if it has been enabled by your System Administrator.

Using the HTML Macro

To add the HTML macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

There are no parameters for this macro.

Enter the HTML code into the body of the macro placeholder.

Related Topics

- HTML Plugin (has better security than the HTML macro)
- HTML Include Macro (embeds remote HTML or pages)
- Working with Macros
- Enabling HTML macros

Take me back to Confluence User’s Guide
**IM Presence Macro**

The IM Presence macro indicates graphically when a contact is signed into an Instant Messaging (IM) service. The IM Presence macro appears as a small icon on the page, like this image: 📱Online Now.

**Using the IM Presence Macro**

To add the IM Presence macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User ID/Screen Name</td>
<td>Identify the user by their ID, account name or screen name.</td>
</tr>
<tr>
<td>Service</td>
<td>aim – AOL Instant Messenger</td>
</tr>
<tr>
<td></td>
<td>gtalk – Google Talk</td>
</tr>
<tr>
<td></td>
<td>icq – ICQ</td>
</tr>
<tr>
<td></td>
<td>jabber – Jabber</td>
</tr>
<tr>
<td></td>
<td>msn – MSN Instant Messenger</td>
</tr>
<tr>
<td></td>
<td>sametime – IBM Lotus Sametime</td>
</tr>
<tr>
<td></td>
<td>skype – Skype</td>
</tr>
<tr>
<td></td>
<td>skypeme – Skype</td>
</tr>
<tr>
<td></td>
<td>wildfire – Openfire Server</td>
</tr>
<tr>
<td></td>
<td>yahoo – Yahoo! Messenger</td>
</tr>
<tr>
<td>Show User ID</td>
<td>Shows or hides the User ID of the contact.</td>
</tr>
</tbody>
</table>

**Related Topics**

[Working with Macros](#)

[Take me back to the Confluence User's Guide.](#)

**Include Page Macro**

You can use the Include Page macro to display the contents of one Confluence page or blog post in another page or blog post.

**Using the Include Page Macro**

To add the Include Page macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.
Parameter | Default | Description
---|---|---
Page to Include | None | This is the name of the Confluence page or blog post that you want to include in the current page.  
- If the page or blog post is located in another space, add the space key and a colon in front of the page name. For example, DOC:My page name.
- To include a blog post, specify the date as well as the title of the blog post. For example: /2010/12/01/My blog post.
- The space key is case sensitive.
- You can include pages from personal spaces using ~username as the space key, where 'username' is the person's username. For example, ~jsmith:My page name.

Notes
- If you want to include part of a page rather than the whole page, use the Excerpt and Excerpt Include macros.
- To display a page's contents, you need 'View' permission for that page. Similarly, people who view the page will need 'View' permissions for the embedded page as well as the page into which it is embedded. See space permissions or contact your Confluence space administrator for more information.
- If someone changes the name of the included page after you have added the macro to your page, the page name does not change automatically in the macro. You will need to change the page name manually in the macro parameters.
- If you want to embed an external page into a Confluence page, you need the HTML Include Macro.

Related Topics
- Working with Macros

Take me back to the Confluence User's Guide.

Sample Include Page

Start of sample page content


End of sample page content

Info Macro

The Info macro allows you to highlight helpful information on a Confluence page.

It creates a blue-coloured box surrounding your text, as shown below.

![Info Macro Example](image)

This text is rendered inside the info macro.

Using the Info Macro

To add the Info macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Optional Title
The title of the information box. If specified, the title text will be displayed in bold next to the icon.

Show Information Icon
true
If "false", the icon will not be displayed.

Related Topics
Working with Macros

Take me back to the Confluence User's Guide.

JIRA Issues Macro

JIRA is the issue tracking and project management system supplied by Atlassian. The **JIRA Issues macro** allows you to display a list of issues from a JIRA site on a Confluence page.

This macro allows you to list publicly accessible issues from any JIRA site, as well as issues restricted to your user account on a JIRA site, assuming:

- You are logged in to both the JIRA and Confluence sites, and
- Your usernames on both of these sites match.

You can also create, find and insert JIRA issues directly within text on a Confluence page or blog post. For more information, refer to Inserting JIRA Issues.

Screenshot: Example of JIRA Issues shown on a Confluence page

---

### Example of the JIRA Issues macro

Added by Sarah Maddox, last edited by Sarah Maddox on Oct 03, 2008 ([view change](#))

Below is a list of issues from the Atlassian public JIRA site, displayed on this Confluence page:

<table>
<thead>
<tr>
<th>Type</th>
<th>Key</th>
<th>Summary</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONF-1181</td>
<td>Parse exception in jiraissues</td>
<td></td>
</tr>
<tr>
<td>CONF-2746</td>
<td>jiraissues macro flaky</td>
<td></td>
</tr>
<tr>
<td>CONF-4472</td>
<td>jiraissues macro is broken in Preview mode</td>
<td></td>
</tr>
<tr>
<td>CONF-3723</td>
<td>robust (and safer) [jiraissues] macro authentication</td>
<td></td>
</tr>
<tr>
<td>CONF-6878</td>
<td>jiraissue macro not including desired columns</td>
<td></td>
</tr>
<tr>
<td>CONF-1415</td>
<td>jiraissues macro custom icons break</td>
<td></td>
</tr>
<tr>
<td>CONF-864</td>
<td>ParseException when trying to use rss / jiraissues macro</td>
<td></td>
</tr>
<tr>
<td>CONF-11829</td>
<td>jiraissues macro issues when multiple on page</td>
<td></td>
</tr>
<tr>
<td>CONF-7322</td>
<td>jiraissues macro doesn't show icons or timestamps</td>
<td></td>
</tr>
<tr>
<td>CONF-2711</td>
<td>Better authentication method for jiraissues and jiraplet macros</td>
<td></td>
</tr>
</tbody>
</table>

The list of issues above is generated by the [jiraissues] macro.

Add Labels
Add Comment

On this page:

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Displaying a List of JIRA Issues from any accessible JIRA site
- Parameters
- Issues Displayed a Page at a Time
- Example
- Displaying Issues which have Restricted Viewing
Usage with the Macro Browser

To insert the JIRA issues macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the JIRA issues macro, click Insert to add it to your page.

Usage with the Wiki Markup Editor

To show a list of issues from any JIRA site to which you and your readers have access, the syntax is:

```
{jiraissues:<URL of the XML view of a search conducted on any accessible JIRA site>}
```

OR:

```
{jira:<URL of the XML view of a search conducted on any accessible JIRA site>}
```

Refer to the instructions below for details on obtaining this URL.

Displaying a List of JIRA Issues from any accessible JIRA site

Step 1 — Obtain the URL of the Issue Filter

1. Log in to your JIRA system.
2. Go to the ‘Issues’ screen and create a new filter. Do not modify an existing filter. This is the ‘Find Issues’ screen in JIRA 3.13.x and earlier.
3. Set up your search parameters and use ‘View’ to check the issues returned.
4. Once the filter is finished, go to the Filter’s ‘View’ tab/section in the top-left area of the JIRA interface.
5. Copy the XML link. To do this, follow the appropriate steps below:
   - If you are using JIRA 4.0.x or later:
     - Choose Views, right-click on XML, and choose Copy Link Location.
   - If you are using JIRA 3.13.x or earlier:
     a. Locate the ‘Current View’ links section (see example below) and find the XML link.
5. Right-click on XML and choose Copy Link Location.

b. Right-click on XML and choose Copy Link Location.

Step 2 — Embed the Issue Filter URL onto your Confluence Page

1. Log in to your Confluence system.
2. Edit the page where you wish to display the list of JIRA issues.
3. Type the following text into a new line at the appropriate location:

   ```
   {jira:CONTENT}
   ```

4. Replace 'CONTENT' with the JIRA filter URL from your clipboard.
5. Customise the macro output by adding optional parameters. See below.
6. Save the Confluence page.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

The JIRA Issues macro allows the following parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anonymous Retrieval</td>
<td>no</td>
<td>false</td>
<td>If this parameter is set to 'true', JIRA will return only the issues which allow unrestricted viewing i.e. the issues which are visible to anonymous viewers, as determined by JIRA's viewing restrictions. If this parameter is omitted or set to 'false', then the results depend on how your administrator has configured the communication between JIRA and Confluence. By default, Confluence will show only the JIRA issues which the user is authorised to view. See more details below.</td>
</tr>
<tr>
<td>baseurl</td>
<td>no</td>
<td>The value of the 'url' parameter</td>
<td>If you specify a 'baseurl', then the link in the header, pointing to your JIRA site, will use this base URL instead of the value of the 'url' parameter. This is useful when Confluence connects to JIRA with a different URL from the one used by other users.</td>
</tr>
</tbody>
</table>
**JIRA Field Columns to Display (columns)**

| no | By default, the following columns are shown:  
|    | • type  
|    | • key  
|    | • summary  
|    | • assignee  
|    | • reporter  
|    | • priority  
|    | • status  
|    | • resolution  
|    | • created  
|    | • updated  
|    | • due  

A list of JIRA column names, separated by semi-colons (;). Example columns are: key, summary, type, created, fixversion, updated, due, assignee, reporter, priority, status and resolution. You can include any columns recognised by your JIRA site, including custom columns. See the [JIRA documentation](#) for a list of names.

---

**Display Total Numbers Only (count)**

| no | false | If this parameter is set to 'true', the issue list will show the number of issues in JIRA. The count will be linked to your JIRA site.

**Cache (cache)**

| no | on | The macro maintains a cache of the issues which result from the JIRA query. If the 'cache' parameter is set to 'off', the relevant part of the cache is cleared each time the macro is reloaded. (The value 'false' also works and has the same effect as 'off'.)

**Height (Pixel Value Only) (height)**

| no | 480 | The height in pixels of the table displaying the JIRA issues. Note that this height specification is ignored in the following situations:
|    |    | • If you set the 'renderMode' parameter (see below) to 'static'.
|    |    | • When the JIRA issues are displayed in a PDF or Word document, in an email message or in an RSS feed.

**renderMode**

| no | In formats not mentioned below, the default is 'dynamic'. The default is 'static' when the JIRA issues are displayed in a PDF or Word document, in an email message or in an RSS feed. By default, the JIRA Issues macro offers a dynamic display with the following features:
|    | • Click the column headers to sort the output.  
|    | • Drag and drop the columns into a different order.  
|    | • Temporarily remove a column from the display.  
|    | • View a page of issues at a time, for faster response times.  
|    | • Set the 'renderMode' parameter to 'static' if you want to disable the dynamic display features.

**Title (title)**

| no | JIRA Issues | You can customise the title text at the top of the JIRA issues table with this parameter. For instance, setting the title to 'Bugs-to-fix' will replace the default 'JIRA Issues' text. This can help provide more context to the list of issues displayed.

**URL (url)**

| yes | none | The URL of the XML view of your selected issues in JIRA Issue Navigator. Note: If the URL in the 'url' parameter does not contain a tempMax argument, then the value of tempMax will default to 500. If your JIRA server is version 3.12 or earlier, this means that the JIRA Issues macro will return a maximum of 500 issues. If your JIRA server is version 3.13 or later, a value of 500 means that the JIRA Issues macro will return a maximum of 500 issues per page.

**Width (width)**

| no | 100% | The width of the table displaying the JIRA issues. Can be indicated either as a percentage (%) or in pixels (px).

---

### Issues Displayed a Page at a Time

If you are using **JIRA 3.13 or later**, the JIRA Issues macro will retrieve and show a 'page' of issues at a time. The buttons underneath the table allow you to move to the next or previous page, or to the start or end of the list. The number of issues retrieved per page is determined by the url parameter — see the description of the macro parameters above.

If your version of JIRA is **3.12 or earlier**, the JIRA Issues macro will retrieve all the issues at once and display them as a single 'page'.

**Example**
Below is an example of some macro markup code, requesting a list of issues from the Atlassian public JIRA site:

```plaintext
[jira:anonymous=true|url=http://jira.atlassian.com/sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml?jqlQuery=project+%3D+CONF+AND+%28summary+%7E+jiraissues+OR+description+%7E+jiraissues+OR+comment+%7E+jiraissues%29&tempMax=10|columns=type;key;summary]
```

The example code contains three parameters (see above parameter table for their meanings):

- **anonymous=true**
- **url=[a long URL derived from the XML view of a JIRA filter]**
- **columns=type;key;summary**

Below are the results of the above macro markup, displayed on this Confluence page:

<table>
<thead>
<tr>
<th>JIRA Issues (10 issues)</th>
<th>Type</th>
<th>Key</th>
<th>Summary</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>CONF-1181</td>
<td>Parse exception in jiraissues</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CONF-4472</td>
<td>jiraissues macro is broken in Preview mode</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CONF-3729</td>
<td>robust (and safer) jiraissues macro authentication</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CONF-6878</td>
<td>jiraissue macro not including desired columns</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CONF-854</td>
<td>ParseException when trying to use rss / jiraissues macro</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CONF-11829</td>
<td>jiraissues macro issues when multiple on page</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CONF-7322</td>
<td>jiraissues macro doesn't show icons or timestamps</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CONF-16617</td>
<td>PDF export ignore jiraissues macro in included page</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CONF-967</td>
<td>Make (jiraissues) macro's output column sortable</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CONF-2711</td>
<td>Better authentication method for jiraissues and jiraportlet macros</td>
<td></td>
</tr>
</tbody>
</table>

**Displaying Issues which have Restricted Viewing**

Maybe your JIRA instance is not visible to anonymous visitors — everyone has to log in before they can see JIRA issues. Or maybe some of the JIRA issues are restricted to viewing by certain users only. This section explains how to handle JIRA issues that have restricted viewing.

**Using Confluence-to-JIRA Trusted Communication (Recommended)**

For Confluence 2.7.0 and later and JIRA 3.12 and later, your administrator can set up trusted communication between Confluence and JIRA. The entire process is described in the Confluence Administrator's Guide. Provided that your administrator has set up trusted communication, you don't need to add any extra parameters. Confluence and JIRA will work out the security between them, ensuring that the user will see only the issues they are authorised to see. Read the section below if you want more detail.

- **Remove the username and password from your macro markup code**

Prior to Confluence 2.7, you needed to include a username and password in the macro markup code if you wanted to display JIRA issues which had restricted viewing. Once your administrator has set up trusted communication between Confluence and JIRA, you no longer need to include a username and password in the markup code for your JIRA macros.

The following options are available for determining the issues which will be retrieved from JIRA and displayed on the Confluence page:

<table>
<thead>
<tr>
<th>What you want to do</th>
<th>Macro parameter</th>
<th>URL parameter</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Display the JIRA issues which the logged-in user is authorised to see. And if the user is not logged in, display only issues which allow unrestricted viewing.

Ensure that Confluence will display only the JIRA issues which allow unrestricted viewing.

Use a pre-determined username and password to access the JIRA issues.

Ensure that Confluence will display only the JIRA issues which allow unrestricted viewing.

anonymous

Use a pre-determined username and password to access the JIRA issues.

&os_username=MYNAME&os_password=MYPASSWORD

Not recommended. Prior to Confluence 2.7, this was the only way of displaying issues with restricted viewing. For Confluence 2.7 and later, this method will still work. Confluence will not attempt to set up a trusted communication link with JIRA in this case.

Troubleshooting

HTTPS

The JIRA Issues macro can access a JIRA instance running under SSL as long as the Confluence server is set to accept the JIRA SSL certificate. Refer to the Confluence Knowledge Base article for more information about problems connecting to SSL services.

And see also:

- Troubleshooting Trusted Communication between JIRA and Confluence

Related Topics

Inserting JIRA Issues
JIRA Portlet Macro
Working with Macros

In the Administrator's Guide:

- Configuring JIRA with Confluence
- Setting Up Trusted Communication between JIRA and Confluence

Take me back to the Confluence User's Guide.

JIRA Macro

See Inserting JIRA Issues.

JIRA Portlet Macro

The JIRA Portlet macro, for JIRA 3.x and earlier, allows you to display a JIRA dashboard portlet on a Confluence page. JIRA is the issue tracking and project management system supplied by Atlassian.

Using JIRA 4.0 and Later
Setting up new JIRA portlets will not work when using JIRA 4.0 and later. Please consider using a JIRA gadget instead of a JIRA Portlet macro.

- Gadgets replaced portlets in JIRA 4.0 and Confluence 3.1.
- Existing JIRA portlet macros based on earlier versions of JIRA will continue to work in Confluence.
- However, due to architectural changes in JIRA 4.0, the ability to create new JIRA portlet macros in Confluence is not available. Please refer to JIRA-19285 and JIRA-18521 for more information.

### On this page:
- Using JIRA 4.0 and Later
- Using JIRA 3.x
  - Obtaining the JIRA Portlet URL
  - Usage with the Macro Browser
  - Parameters
  - Displaying Issues which have Restricted Viewing
    - Using Confluence-to-JIRA Trusted Communication
- Troubleshooting
  - Ideas for new features or want more tips?
  - Logging Bugs and Requesting Support
  - Known Limitations when used with JIRA Calendar
- Related Topics

### Using JIRA 3.x

The JIRA portlet macro appears as shown in the screenshot below.

![Screenshot above: The JIRA Portlet Macro in Confluence](image)

**Obtaining the JIRA Portlet URL**

The JIRA Portlet macro requires the URL of the JIRA portlet you wish to show on a Confluence page.

**To obtain the JIRA portlet URL:**

1. Log in to your JIRA system.
2. Add the portlet you wish to include in Confluence to your JIRA dashboard. (Once you have copied the portlet's URL into Confluence, you can remove it from your JIRA dashboard.)
3. Click "Configure" on your JIRA dashboard. (If you don't see this link, you need to click the 'Manage Portal' link, click the 'Configure' button and then return to the dashboard.)
4. Right-click the title located at the top-left corner of the portlet and copy its link location. See Screenshot 1.

**Screenshot 1: Copy link location**

**Usage with the Macro Browser**

**To add the JIRA Portlet macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>JIRA Portlet URL</td>
<td>yes</td>
<td>none</td>
<td>URL of the JIRA portlet, as described above. Certain JIRA portlets may require user authentication details in order to display their content. Hence you may need to append: &amp;os_username=yourJiraUsername&amp;os_password=yourJiraPassword to the end of this url.</td>
</tr>
<tr>
<td>Anonymous Retrieval</td>
<td>no</td>
<td>false</td>
<td>For Confluence 2.7.0 and later. If this parameter is selected, JIRA will return only the issues which allow unrestricted viewing i.e. the issues which are visible to anonymous viewers, as determined by JIRA's viewing restrictions. If this parameter is not set, then the results depend on how your administrator has configured the communication between JIRA and Confluence. By default, Confluence will show only the JIRA issues which the user is authorised to view. See more details below.</td>
</tr>
<tr>
<td>Base URL</td>
<td>no</td>
<td>none</td>
<td>If Confluence retrieves the JIRA portlet from some other URL than JIRA's public URL, you should supply JIRA's public URL in the baseurl parameter.</td>
</tr>
</tbody>
</table>

Displaying Issues which have Restricted Viewing

This section explains how to handle JIRA issues that have restricted viewing. Maybe your JIRA instance is not visible to anonymous visitors - everyone has to log in before they can see JIRA issues. Or maybe some of the JIRA issues are restricted to viewing by certain users only.

Using Confluence-to-JIRA Trusted Communication

Your administrator can set up trusted communication between Confluence and JIRA. The entire process is described in the Confluence Administrator's Guide.

Here is a relevant extract from the above page:

Check the username and password from your macro markup code

Prior to Confluence 2.7, you needed to include a username and password in the macro markup code if you wanted to display JIRA issues which had restricted viewing. Once your administrator has set up trusted communication between Confluence and JIRA, you no longer need to include a username and password in the markup code for your JIRA macros.

The following options are available for determining the issues which will be retrieved from JIRA and displayed on the Confluence page:

<table>
<thead>
<tr>
<th>What you want to do</th>
<th>Macro parameter</th>
<th>URL parameter</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the JIRA issues which the logged-in user is authorised to see. And if the user is not logged in, display only issues which allow unrestricted viewing.</td>
<td>JIRA parameter</td>
<td>JIRA parameter</td>
<td>Do not specify any authentication parameters. In this case, the behaviour depends on the way your administrator has set up trusted communication between JIRA and Confluence. Here is a summary of the behaviour. If trusted communication is enabled, the authorisation will work seamlessly. When a logged-in user views your page, they will see only the JIRA issues they are allowed to see. And if they are not logged in, they will see only the issues which allow unrestricted viewing. If trusted communication is disabled, the Confluence page will show only the JIRA issues which allow unrestricted viewing.</td>
</tr>
</tbody>
</table>
Ensure that Confluence will display only the JIRA issues which allow unrestricted viewing. Regardless of who the user is (logged in or not), the Confluence page will show only anonymously-visible issues. Confluence will not attempt to set up a trusted communication link with JIRA in this case.

Use a pre-determined username and password to access the JIRA issues. &os_username=MYNAME&os_password=MYPASSWORD

Not recommended. Prior to Confluence 2.7, this was the only way of displaying issues with restricted viewing. For Confluence 2.7 and later, this method will still work. Confluence will not attempt to set up a trusted communication link with JIRA in this case.

Troubleshooting

Ideas for new features or want more tips?

If you have an idea for a new feature, please log it on our JIRA site.

You will also find many hints and tips on Atlassian Answers. Try asking a question or sharing your ideas with other Confluence users.

Logging Bugs and Requesting Support

If you have found a bug in this macro, please log it on our JIRA site.

If you encounter a problem using this macro, please raise a ticket on our Support site.

Known Limitations when used with JIRA Calendar

If you are using the JIRA Portlet macro in combination with the JIRA Calendar, paging will work only if your Confluence and JIRA sites are running on the same host. Otherwise, you see error messages like Access to restricted URI.

Reason: the Calendar portlet communicates with JIRA via AJAX requests. Because of security concerns, browsers by default do not allow requests to any host different from the one the page was originally downloaded from.

There is a workaround. If you wish, you can turn off this security check in your browser. The exact way depends on your browser version, so Google for hints.

⚠ Please consider all implications of turning off this security check before you perform this action.

There is an existing request to develop support for proxying of the AJAX requests from Confluence to JIRA. If you need this feature, please vote for this issue: JCAL-64.

Related Topics

JIRA Issues Macro
Working with Macros

In the Administrator's Guide:

- Configuring JIRA with Confluence
- Setting Up Trusted Communication between JIRA and Confluence

Take me back to the Confluence User's Guide.

JUnit Report Macro

The JUnit Report macro displays a summary of JUnit test results from a directory accessible by the Confluence server. JUnit is a unit testing framework which allows programmers to ensure that individual units of Java source code are functioning correctly.

The JUnit Report macro appears as shown in the screenshot below.

Screenshot: The JUnit Report macro in Confluence
When generating reports from the JUnit Report macro, set the Apache Ant formatter to 'XML'.

Using the JUnit Report Macro

To add the JUnit Report macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| URL of the test result XML file | None    | URL of a particular test result XML file. Is overridden by the Directory (URL) of your test result files parameter if you use both. Example, from a Confluence instance: http://yourConfluenceinstance.com/download/attachments/<page id>/file.xml For Confluence installations without anonymous user access, you can specify logon credentials as part of this parameter in the form of URL parameters:
• os_username — The username of a Confluence user with permission to access to the JUnit test results.
• os_password — The password of the Confluence user specified in the os_username parameter. |
| Directory (URL) of your test result files | None    | URL of a directory containing your test result files. This must be a directory name and not the XML file itself. Overrides the URL of the test result XML file parameter if you use both. Example, for a local drive: file://C:/TEMP/ Example, for a network drive: http://*host*/*path* |
| Report Detail              | all     | Detail for the report. Can be all, fixture, summary or failuresonly.         |
| Debug                      | None    | Shows the content of failures, as well as the error messages.                |

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Livesearch Macro

The Livesearch macro allows you to add a search box to a Confluence page. When users enter a search term into the search box, Confluence will dynamically display matching results as they type.

Using the Livesearch Macro

To add the Livesearch macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.
Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>none</td>
<td>Uniquely identifies the Livesearch when there are multiple Livesearch macros in one page.</td>
</tr>
<tr>
<td>Restrict to this Space Key</td>
<td>all spaces</td>
<td>Specify a space key to limit the search to the given space. Case-sensitive.</td>
</tr>
</tbody>
</table>

**Related Topics**

- Searching Confluence
- Search Macro
- Working with Macros

Take me back to the Confluence User's Guide.

### Loremipsum Macro

The Loremipsum macro displays paragraphs of pseudo-Latin text ([more information](#)). You can use this macro to generate more-or-less meaningless text for demonstration purposes in pages showing a draft layout or arrangement of page elements. The text is deliberately non-meaningful so that it does not influence the viewer's perception of the page arrangement or design.

A basic example of the Loremipsum text:

```
```

**Using the Loremipsum Macro**

To add the Loremipsum macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Paragraphs</td>
<td>3</td>
<td>The amount of pseudo-Latin (space-filler) text to display.</td>
</tr>
</tbody>
</table>

**Related Topics**

- Working with Macros

Take me back to the Confluence User's Guide.

### Metadata Macro

The **Metadata macro** allows you to embed metadata into pages and blog posts for presentation with the **Metadata Summary Macro**. Each metadata item consists of a field name and an associated value. When a metadata macro is rendered on a page, each metadata item is presented on a single line, starting with the name of the field, followed by its value, for example:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is-Secret</td>
<td>Yes</td>
</tr>
<tr>
<td>Author-Nickname</td>
<td>Banana Split</td>
</tr>
</tbody>
</table>
Each metadata macro is ‘labelled’, allowing you to:

- insert multiple Metadata macros on a single page or blog post, each with a different label
- use the Metadata Summary macro to generate a summary based on Metadata macros tagged with a specific label.

Metadata macro ‘label’s are completely unrelated to page labels. A Metadata macro’s label is only used by the Metadata Summary macro for the purpose of generating its summary.

As far as the Metadata Summary macro is concerned, each field only possesses a single value. Hence, if you added multiple values to a field (for example, by separating each value with a comma), the Metadata Summary macro treats this as a single value and presents it as such.

On this page:

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters

Usage with the Macro Browser

To insert the metadata macro into a page using the Macro Browser,

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

Once you’ve found the metadata macro, click ‘insert’ to add it to your page.

Usage with the Wiki Markup Editor

```
{details:label=test}
Is-Secret: Yes
Author-Nickname: Banana Split
{details}
```

Each metadata item is added on a separate line. Separate each field and value with a colon (:) followed by a space. For example: `colour: Red`.

In the example above,

- **test** is the label of this metadata macro, which can be identified uniquely on a page in a metadata summary
- **Is-Secret** is a field of value *Yes*
- **Author-Nickname** is another field with a value of *Banana Split*.

Parameters

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required in Wiki Markup?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Metadata Label (label)</td>
<td>yes</td>
<td>none</td>
<td>Used by the Metadata Summary macro to generate a summary based on all Metadata macros tagged with this label throughout the current space.</td>
</tr>
<tr>
<td>hidden (hidden)</td>
<td>no</td>
<td>false</td>
<td>Controls whether the text between the details tags will appear on that page when users read it.</td>
</tr>
</tbody>
</table>

**RELATED TOPICS**

Working with Macros
Metadata Summary Macro

The Metadata Summary macro presents a tabulated summary of selected metadata, which has been embedded using the Metadata Macro on any page or blog post in the current Confluence space.

The left-most column of the metadata summary shows the name of each page or blog post within current space that contains the selected metadata. Each page or blog post is presented on a single row and is hyperlinked to its appropriate destination page.

Each subsequent column represents a unique field within the selected metadata. The value associated with each metadata field on a page or blog post is presented in the appropriate cell of the metadata summary table. For example, the following Metadata Summary macro shows all Metadata macros tagged with the 'test' label in the current space.

<table>
<thead>
<tr>
<th>Metadata Macro</th>
<th>Author-Firstname</th>
<th>Author-Nickname</th>
<th>Is-Secret</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;p&gt;Banana Split&lt;/p&gt;</td>
<td>&lt;p&gt;Fred&lt;/p&gt;</td>
<td>&lt;p&gt;Strawberry Sundae&lt;/p&gt;</td>
<td>&lt;p&gt;Yes&lt;/p&gt;</td>
</tr>
</tbody>
</table>

Metadata macro 'label's are completely unrelated to page labels. A Metadata macro's label is only used by the Metadata Summary macro for the purpose of generating its summary.

On this page:
- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters
- Another Metadata Macro Example

Usage with the Macro Browser

To insert the metadata summary macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the metadata summary macro, click 'insert' to add it to your page.

Usage with the Wiki Markup Editor

```
{detailsSummary:label=test}
```

This shows a metadata summary based on all Metadata macros in pages or blog posts of the current space, which have been labelled with 'test'.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required in Wiki Markup?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Metadata Label</td>
<td>yes</td>
<td>none</td>
<td>Restricts the Metadata Summary macro to summarise the contents of Metadata macros throughout the current space, which have been tagged with this label only.</td>
</tr>
</tbody>
</table>

Another Metadata Macro Example

The following Metadata macro example generates the second line in the Metadata Summary macro (above).
**Network Macro**

The Network macro displays a list of network interactions between users in your Confluence site, on a Confluence page or blog post. The Network macro allows you to specify the user whose network interactions you wish to show. These interactions include the users that the specified user is following or users who are following the specified user. The Network macro shows each listed user by their profile picture. It also provides a choice of two themes and the ability to limit the number of users in the list.

**Screenshot: Network Macro**

### Using the Network Macro

**To add the Network macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser. Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>current user's username</td>
<td>The username of the Confluence user whose network interactions you wish to show. If no username is specified, then current user's (that is, your) network interactions are shown.</td>
</tr>
</tbody>
</table>
| Mode      | following | Determines which users are listed, with respect to the specified user:  
* following – those who the user is following.  
* followers – those who are following the user. |
**Theme**

<table>
<thead>
<tr>
<th>Theme</th>
<th>full</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Determines how the user's network is displayed:</td>
</tr>
<tr>
<td></td>
<td>• <strong>full</strong> – shows a large version of user's profile pictures and, if the <strong>following</strong> mode is set, provides an entry field function to follow more users.</td>
</tr>
<tr>
<td></td>
<td>• <strong>tiny</strong> – shows only the small version of user's profile pictures.</td>
</tr>
</tbody>
</table>

**Maximum Results**

<table>
<thead>
<tr>
<th>Maximum Results</th>
<th>no limit imposed up to a maximum of 30</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Restrictions the number of users displayed. If the number of users exceeds the specified maximum, then a <strong>Show All</strong> link is provided. This link leads to the specified user's <strong>Network view</strong>, showing the complete list of network interactions.</td>
</tr>
</tbody>
</table>

---

**Related Topics**

**Working with Macros**

Take me back to the *Confluence User's Guide*.

### Noformat Macro

The *Noformat* macro displays a block of text in monospace font with no other formatting.

#### Using the Noformat Macro

**To add the Noformat macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

Enter the content that is to be unformatted into the body of the macro placeholder.

**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>No Panel</strong></td>
<td>False</td>
<td>Removes the panel around the content.</td>
</tr>
</tbody>
</table>

---

**Related Topics**

**Working with Macros**

Take me back to the *Confluence User's Guide*.

### Note Macro

The *Note* macro allows you to highlight a note on a Confluence page.

It creates a yellow-coloured box surrounding your text:

#### Using the Note Macro

**To add the Note macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

Add the text of the note to the body of the macro placeholder.
Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>If specified, the title is displayed in bold next to the icon.</td>
</tr>
</tbody>
</table>
| Show Exclamation Mark Icon | true    | • true – displays the warning icon  
                                  • false – the icon is not displayed |

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Page Index Macro

The Page Index macro creates a hyperlinked alphabetical index of all pages within the current space.

The top section of the Index contains a cell for letter of the alphabet, including separate cells for numbers and symbols. Each of these cells indicates the number of pages in which the first letter of the title matched the corresponding letter, number or symbol in the cell.

The lower section is effectively an extended version of the top section. However, each cell shows the page name followed by the first few sentences of content on that page.

Each letter, number or symbol in the top section is hyperlinked and leads to its corresponding cell in the lower section. Additionally, each page title in the lower section is hyperlinked and leads to its corresponding page in the space.

Screenshot: Index Macro segment
### Usage with the Macro Browser

To insert the Page Index macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the Page Index macro, click 'insert' to add it to your page.

### Usage in Wiki Markup

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>Segment of what you will get</th>
</tr>
</thead>
</table>

---

**Access Log Scripts**

access log scripts are attached to this page Access Log Scripts.

**Accessing Confluence Components From Plugin Modules**

Confluence is built around Spring http://www.springframework.org.

**Activating External User Management**

your user management is being handled outside of Confluence by option in Confluence, from the Administration Console. Running Confluence user management outside of Confluence ...

**Add Confluence EAR-WAR to JIRA Standalone**

document will assist you in adding Confluence to your existing JIRA.

**Add LDAP Integration**

Atlassian's Crowd http://www.atlassian.com/software/crowd is a

**Add LDAP Integration For User Authentication Only**

Confluence 2.7.0 and above, all user management is performed by

**Confluence 4.0 Documentation**

<table>
<thead>
<tr>
<th>0-9</th>
<th>A</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>4 Interface - Where Did Everything Go?</td>
</tr>
<tr>
<td>2.</td>
<td>2.5 Security Patch</td>
</tr>
<tr>
<td>3.</td>
<td>Access Log Scripts</td>
</tr>
<tr>
<td>4.</td>
<td>Accessing Confluence Components From Plugin Modules</td>
</tr>
<tr>
<td>5.</td>
<td>Activating External User Management</td>
</tr>
<tr>
<td>6.</td>
<td>Add Confluence EAR-WAR to JIRA Standalone</td>
</tr>
<tr>
<td>7.</td>
<td>Add LDAP Integration</td>
</tr>
<tr>
<td>8.</td>
<td>Add LDAP Integration For User Authentication Only</td>
</tr>
<tr>
<td>9.</td>
<td>What you need to type</td>
</tr>
</tbody>
</table>
Parameters

This macro accepts no parameters.

RELATED TOPICS

Working with Macros

Take me back to the Confluence User's Guide.

Pagetree Macro

The Pagetree macro displays a dynamic, hierarchical list of pages starting from a specified parent (root) page. You can embed the page tree into your Confluence page, where it can act as a table of contents or a list of related topics.

When viewing the page tree, your reader can click a link to open the relevant page. The page's current position is highlighted in the page tree.

Below we tell you how to add the Pagetree macro to your page.

Creating a navigation panel for your space

The Pagetree macro is used in the Confluence Documentation theme, to create a navigation panel showing a table of contents for your space. Read the instructions on Configuring the Documentation Theme.
On this page:

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Macro Parameters
- Examples
  - All Parameters
  - Specifying the Parent Page by Name
  - Showing All Pages in the Space
  - Setting the Current Page as the Parent Page
  - Showing Excerpts from Each Page
  - Allowing your Readers to Expand or Collapse All Branches
  - Including a Search Box
  - Sorting the Pages in Reverse Natural Order

Usage with the Macro Browser

To insert the Pagetree macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the Pagetree macro and have added the required parameter values, click 'Insert' to add it to your page.

Usage with the Wiki Markup Editor

Include the following markup in your page:

```
{pagetree}
```

There are more examples below.

Macro Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include Excerpts in Page Tree (excerpt)</td>
<td>no</td>
<td>false</td>
<td>Set this value to ‘true’ if you want the page tree to show excerpts from each page. The excerpts must be defined on each page by the Excerpt macro.</td>
</tr>
<tr>
<td>Show Expand/Collapse Links (expandCollapseAll)</td>
<td>no</td>
<td>false</td>
<td>Set this value to ‘true’ if you want to display the ‘expand all’ and ‘collapse all’ links at the top of your page tree. Your readers can click these links to open or close all branches of the tree at once.</td>
</tr>
<tr>
<td>Reverse Order (reverse)</td>
<td>no</td>
<td>false</td>
<td>Use this parameter in combination with the sort parameter described below. Set this value to ‘true’ if you want the pages displayed in descending order rather than ascending order.</td>
</tr>
</tbody>
</table>
| **Root Page**  
(root) | no | The home page of the space | Specify the parent page for the page tree. The tree will include all children of the given page, plus their children and grand-children etc. The tree will not include the root page itself.  
Specify the page title or a special value as follows:  
- Your page title — Page tree shows all pages under the specified page.  
- '@home' — Page tree shows all pages under the home page of the space (default).  
- '@self' — Page tree shows all pages under the current page.  
- '@parent' — Page tree shows all pages under the parent of the current page, including the current page.  
- '@none' — Page tree shows all pages in the space, including orphaned pages and the home page. |
| **Include Search Box above Page Tree**  
(searchBox) | no | false | Set this value to 'true' if you want to include a search box above the page tree. The search box allows your readers to enter a search term, and then searches within the page tree for the specified value. |
| **Sort Pages By**  
(sort) | no | position | Specify the order to display the pages in the tree. This sort order is for display purposes only. It does not permanently re-arrange the page order. The value may be one of the following:  
- 'bitwise' — Display the pages using standard alphabetical sorting, such as: title1, title10, title2.  
- 'creation' — Display the pages in order of date created.  
- 'modified' — Display the pages in order of date last modified.  
- 'natural' — Display the pages in 'natural' alphabetical order, such as: title1, title2, title10.  
- 'position' — Display the pages using the default Confluence sorting rules. If your pages have been ordered manually, this sort will respect the defined order. Otherwise the pages will be displayed in the 'natural' alphabetical order, such as: title1, title2, title10. |
| **Start Depth**  
(startDepth) | no | 1 | Enter any number greater than 0, indicating how many levels of children the tree should show when it opens for the first time. |

### Examples

#### All Parameters

Here's an example using all the parameters:

```plaintext
{pagetree:root=Page Name|sort=natural|excerpt=true|reverse=false|startDepth=3|expandCollapseAll=true|searchBox=true}
```

#### Specifying the Parent Page by Name

Use the following code to specify a page name for the parent or root of the tree. The tree will include all children and grand-children of the specified root. The tree will not include the specified root page itself.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>{pagetree:root=Pagetree Macro}</code></td>
<td></td>
</tr>
</tbody>
</table>

The above example is a 'live' example. It uses the child pages of this page to form the page tree.

#### Showing All Pages in the Space

Use the following code to make the page tree show all pages in the space, including orphaned pages and the home page.
### Setting the Current Page as the Parent Page

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>{pagetree:root=@self}</code></td>
<td></td>
</tr>
</tbody>
</table>

The above example is a 'live' example. It uses the child pages of this page to form the page tree.

### Showing Excerpts from Each Page

Use the following code if you want your page tree to include excerpts from each page. The excerpts must be defined on each page by the Excerpt macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>`{pagetree:root=@self</td>
<td>excerpt=true}`</td>
</tr>
</tbody>
</table>

The above example is a 'live' example. It uses the child pages of this page to form the page tree.

### Allowing your Readers to Expand or Collapse All Branches

Use the following code if you want to show the 'expand all' and 'collapse all' links at the top of your page tree.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>`{pagetree:root=@self</td>
<td>expandCollapseAll=true}`</td>
</tr>
</tbody>
</table>

The above example is a 'live' example. It uses the child pages of this page to form the page tree.

### Including a Search Box

Use the following code if you want to include a search box at the top of your page tree.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>`{pagetree:root=@self</td>
<td>searchBox=true}`</td>
</tr>
</tbody>
</table>

The above example is a 'live' example. It uses the child pages of this page to form the page tree.

### Sorting the Pages in Reverse Natural Order

Use the following code if you want to show the pages in reverse natural order.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>{pagetree:root=@self}</code></td>
<td></td>
</tr>
</tbody>
</table>

The above example is a 'live' example. It uses the child pages of this page to form the page tree.
The above example is a 'live' example. It uses the child pages of this page to form the page tree.

**RELATED TOPICS**

Pagetree Search Macro  
Adding a Navigation Sidebar  
Working with Macros

Take me back to the Confluence User's Guide.

**Sample Page Tree**

This page is a sample, used to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Pagetree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>`{pagetree:root=@parent</td>
<td>expandCollapseAll=false}`</td>
</tr>
</tbody>
</table>

**Another Sample Page Tree**

We're using this page to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Pagetree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| `{pagetree:root=@parent|expandCollapseAll=true}` | Collapse all  
Expand all  
Collapse all |

**Sample Page Tree 2**

This is another sample page, used to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Pagetree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| `{pagetree:root=@parent|expandCollapseAll=true}` | Collapse all  
Expand all  
Collapse all |

**Pagetree Search Macro**

The Pagetree Search macro allows you to add a search box to your Confluence page. When a viewer enters a search term, Confluence will search a hierarchy of pages starting from a specified parent (root) page and return the search results on a new screen.

Below we tell you how to add the Pagetree Search macro to your page.
You may be interested in the Pagetree macro

You can also add a search box as part of a dynamic page tree, which looks like a table of contents. Read the instructions on the Pagetree macro.

On this page:

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Macro Parameters

Usage with the Macro Browser

To insert the Pagetree Search macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the Pagetree Search macro and have added the required parameter values, click 'Insert' to add it to your page.

Usage with the Wiki Markup Editor

Include the following markup in your page:

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetreesearch}</td>
<td></td>
</tr>
</tbody>
</table>

Macro Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name of Root Page (rootPage)</td>
<td>no</td>
<td>none</td>
<td>The name of the root page whose hierarchy of pages will be searched by this macro. If this not specified, the root page is the current page.</td>
</tr>
</tbody>
</table>

RELATED TOPICS

Pagetree Macro
Adding a Navigation Sidebar
Working with Macros

Take me back to the Confluence User's Guide.

Panel Macro

The Panel Macro allows you to display a block of text within a customisable panel, like a text box.

On this page:

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters
- Notes
- Related Topics

Usage with the Macro Browser
To insert the Panel macro into a page using the Macro Browser,

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

### Usage with the Wiki Markup Editor

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>{panel}</code></td>
<td>A simple panel</td>
</tr>
<tr>
<td><code>{panel}</code></td>
<td>A simple panel</td>
</tr>
<tr>
<td>`{panel:title=My Title</td>
<td>borderStyle=dashed</td>
</tr>
<tr>
<td><code>{panel}</code></td>
<td>A formatted panel</td>
</tr>
</tbody>
</table>

### Parameters

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panel Title <em>(title)</em></td>
<td>no</td>
<td>none</td>
<td>The title of the panel. If specified, this title will be displayed in its own title row.</td>
</tr>
<tr>
<td>Border Style <em>(borderStyle)</em></td>
<td>no</td>
<td>solid</td>
<td>The style of the panel's border. Accepted values are 'solid', 'dashed' and other valid CSS border styles.</td>
</tr>
<tr>
<td>Border Colour <em>(borderColor)</em></td>
<td>no</td>
<td></td>
<td>The colour of the panel's border.</td>
</tr>
<tr>
<td>Border Pixel Width <em>(Value Only)</em> <em>(borderWidth)</em></td>
<td>no</td>
<td></td>
<td>The width of the panel's border (in pixels).</td>
</tr>
<tr>
<td>Background Colour <em>(bgColor)</em></td>
<td>no</td>
<td></td>
<td>The background colour of the panel.</td>
</tr>
<tr>
<td>Title Background Colour <em>(titleBGColor)</em></td>
<td>no</td>
<td></td>
<td>The background colour of the title row of the panel.</td>
</tr>
<tr>
<td>Title Text Colour <em>(titleColor)</em></td>
<td>no</td>
<td></td>
<td>The colour of the text in the title row of the panel.</td>
</tr>
</tbody>
</table>

### Notes

- You can use panels within columns and table cells.

### Related Topics

**Working with Macros**

Take me back to the Confluence User's Guide.

**Profile Macro**
The **Profile** macro displays a short summary of any Confluence user's profile on your Confluence page or blog. This is the same summary that appears in a **Hover Profile**, which appears whenever you mouse-over any user's name in the Confluence interface.

> The information contained within your own summarised profile can be **edited** using your **User Profile view**.

**Screenshots: Example of the Profile Macro**

![Giles Gaskell](image)

*Giles Gaskell*

ggaskell@atlassian.com

"Working on final User Profile updates."

**Website:** [http://www.atlassian.com](http://www.atlassian.com)

**Position:** Technical Writer

**Department:** Development

**Location:** Sydney

On this page:

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters

**Usage with the Macro Browser**

To insert the Profile macro into a page using the Macro Browser:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

Once you've found the Profile macro and have added the required parameter values, click '**Insert**' to add it to your page.

**Usage with the Wiki Markup Editor**

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>Example of what you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>{profile:user=ggaskell}</code></td>
<td><img src="image" alt="Giles Gaskell" /></td>
</tr>
</tbody>
</table>

**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required in Wiki Markup?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username (user)</td>
<td>yes</td>
<td>none</td>
<td>The username of the Confluence user whose profile summary you wish to show.</td>
</tr>
</tbody>
</table>
Profile Picture Macro

The Profile Picture macro displays a user's profile picture on a page.

- When viewing the page, mouse-over the picture to see the Hover Profile for the user.
- When editing the page, click on the picture and choose View User Profile to see the profile for the user.

The Profile Picture macro is useful for such tasks as creating Team Pages that show all members of a project team.

Using the Profile Picture Macro

To add the Profile Picture macro to a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User</td>
<td>none</td>
<td>The username, or real name, of a Confluence user.</td>
</tr>
</tbody>
</table>

Recently Updated Dashboard Macro

The Recently Updated Dashboard macro displays a list of the most recently changed content within Confluence. It is similar to the Recently Updated macro but is intended for use on the Confluence dashboard.

Usage with the Macro Browser

To insert the Recently Updated Dashboard macro into a page using the Macro Browser:
In the Confluence editor, choose Insert > Other Macros.

Find and select the required macro.

### Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space(s)</td>
<td>The space which contains the page on which the macro is added.</td>
<td></td>
</tr>
<tr>
<td>Filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here. You can specify one or more space keys, separated by commas. &quot;*&quot; means all spaces.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Include these Content Types Only</td>
<td>all types</td>
<td>Filter content by type. You can specify one or more types, separated by commas. Available types are: page, blogpost or news, spacedesc, attachment, comment, mail, userinfo.</td>
</tr>
<tr>
<td>Label(s)</td>
<td>none</td>
<td>Filter content by label. The macro will display only the pages etc which are tagged with the label(s) you specify here. You can specify one or more labels, separated by commas. If there are no pages matching any of the specified labels, then Confluence will ignore the labels and will list all recently updated pages, as well as showing a message, “These labels don’t exist and were ignored: xxx”. This unexpected behaviour is noted in issue CONF-10167.</td>
</tr>
<tr>
<td>Width of Table</td>
<td>100%</td>
<td>Specify the width of the macro display, as a percentage of the window width.</td>
</tr>
<tr>
<td>Show User Profile Pictures</td>
<td>false</td>
<td>Select whether profile pictures of the users who updated the content are displayed.</td>
</tr>
</tbody>
</table>

### Related Topics

Recently Updated Macro

Viewing Recently Updated Content

Working with Macros

Take me back to the Confluence User’s Guide.

### Recently Updated Macro

The Recently Updated macro displays a list of the most recently changed content within Confluence.

The Recently Updated Dashboard macro is similar to this macro, but is intended for display on the Confluence dashboard.

On this page:

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Working Example of Usage
- Recently Updated
- Parameters
- Examples
  - 1. Include content from all spaces
  - 2. Include content from specific spaces
  - 3. Specify the width of the display
  - 4. Filter content using labels
  - 5. Filter by content type
  - 6. Change the number of results in the list
  - 7. Display profile pictures
  - 8. Display recent comments, including profile pictures and text

### Usage with the Macro Browser
To insert the recently updated macro into a page using the Macro Browser:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

Once you've found the recently updated macro and have added the required parameter values, click '**Insert**' to add it to your page.

**Usage with the Wiki Markup Editor**

```
{recently-updated}
```

**Working Example of Usage**

Below is a working example of the 'Recently Updated' macro which by default, lists 15 results.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>{recently-updated}</code></td>
<td>Recently Updated</td>
</tr>
<tr>
<td></td>
<td>• No recent updates found.</td>
</tr>
</tbody>
</table>

**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Author(s) by username</strong></td>
<td>no</td>
<td>None specified i.e. display all content</td>
<td>Filter the results by author. The macro will display only the pages etc which were last modified by the author(s) you specify here. You can specify one or more authors, separated by a comma or a space.</td>
</tr>
<tr>
<td><strong>Label(s)</strong></td>
<td>no</td>
<td>None specified i.e. display all content</td>
<td>Filter the results by label. The macro will display only the pages etc which are tagged with the label(s) you specify here. You can specify one or more label values, separated by a comma or a space. To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labelled with 'badpage'. To indicate that the results <strong>must</strong> match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage,+goodpage you will get only content which has at least two labels, being 'superpage' and 'goodpage'.</td>
</tr>
<tr>
<td><strong>Maximum Number of Results</strong></td>
<td>no</td>
<td>15</td>
<td>Specify the maximum number of results to be displayed. If this parameter is omitted, then a maximum of 15 results are displayed. The theoretical maximum value that this parameter can accept is 2 to the power of 31, minus 1 (or 2,147,483,647), though this has been limited to 200 in the code, for performance reasons. More details are here.</td>
</tr>
</tbody>
</table>

---

If there are no pages matching any of the specified labels, then Confluence will ignore the labels and will list all recently updated pages, as well as showing a message, "These labels don't exist and were ignored: xxx ". This unexpected behaviour is noted in issue CONF-10167.
| **Show User Profile Pictures**  
| (`showProfilePic`) | no | false | Specify `showProfilePic=true` to display the profile pictures of the users who updated the content. |
| **Space(s)**  
| (space) or (spaces) | no | @self, i.e. the space which contains the page on which the macro is used | This parameter allows you to filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here. You can specify one or more space keys, separated by a comma or a space. |
|  |  |  | • To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of `-BADSPACE` you will get only content which is not in the BADSPACE. |
|  |  |  | • To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of `+GOODSPACE` you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.) |
|  |  |  | Special values: |
|  |  |  | • @self — The current space. |
|  |  |  | • @personal — All personal spaces. |
|  |  |  | • @global — All global spaces. |
|  |  |  | • @favorite — The spaces you have marked as favourite. |
|  |  |  | • @favourite — The same as @favorite above. |
|  |  |  | • @all — All spaces in your Confluence site. |
|  |  |  | • * — The same as @all above. |
|  |  |  | **i** When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as `-jbloggs` or `-jbloggs@example.com. |
| **Include these Content Types Only**  
| (`type`) or (`types`) | no | all types | This parameter allows you to filter content by content type. The macro will display only the content of the type you specify here. You can specify one or more types, separated by a comma or a space. To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of `-blogpost` you will get pages and all other content except for blog posts. |
|  |  |  | Available values: |
|  |  |  | • page — Pages. |
|  |  |  | • blogpost or news — Blog posts, also known as news items. |
|  |  |  | • comment — Comments on pages and blog posts. |
|  |  |  | • attachment — Attachments. |
|  |  |  | • status — Status updates made by other users. |
| **Width of Table**  
| (`width`) | no | 100% | Specify the width of the macro display, as a percentage of the window width. |
| **theme**  
| (`theme`) | no | 'concise' with the heading 'Recently Updated' | Choose the appearance of this macro: |
|  |  |  | • concise — the default list, showing the names of pages which were updated or commented on, the users who made the page modifications and time when the modifications occurred. |
|  |  |  | • social — lists recent modifications in reverse chronological order, but groups them by user into short time segments. A 'sub' list appears within each user's time segment, showing the names of pages which they updated or commented on and time when these modifications occurred. |
|  |  |  | • sidebar — lists recent updates in reverse chronological order, showing the names of pages which were updated or commented on and time when the page modifications occurred. This theme does not show authorship. |
Examples

1. Include content from all spaces

The code below will show all the pages from all the spaces that have been recently updated:

```
{recently-updated:space=all}
```

2. Include content from specific spaces

Use the code below to specify the spaces for which you want to view recently updated content:

```
{recently-updated:space=SPACEKEY1,SPACEKEY2}
```

3. Specify the width of the display

Use the code below to limit the width of the display to 50% of the window:

```
{recently-updated:width=50%}
```

4. Filter content using labels

The code below will include recently updated content labelled with 'timesheets' or 'summaries', from the 'sales' and 'marketing' spaces, provided that the content is not labelled with 'obsolete':

```
{recently-updated:space=sales,marketing|label=timesheets,summaries,-obsolete}
```

5. Filter by content type

Use the code below to show pages only (not news items, comments or any other content type):

```
{recently-updated:type=page}
```

6. Change the number of results in the list

The code below changes the number of results listed (from the default value of 15) to 8:

```
{recently-updated:maxResults=8}
```

7. Display profile pictures

The code below will display the profile picture of the user who most recently updated the content.

```
{recently-updated-dashboard:showProfilePic=true}
```

8. Display recent comments, including profile pictures and text

The code below will display recent comments in the current space, showing the profile picture of the users who made the comments, plus the first line or two of the comment text.

```
{recently-updated-dashboard:types=comment|showProfilePic=true}
```

*This is the only way to ensure that the text of the comments is displayed, using this macro.*
Customising the wording

If you would like to change the wording displayed by the 'Recently Updated' macro, please refer to the document on modifying the Confluence interface text.

Related Topics

Recently Updated Dashboard Macro
Viewing Recently Updated Content
Working with Macros

Take me back to the Confluence User's Guide.

RSS Feed Macro

The RSS feed macro embeds an RSS feed on a page. It can display the contents of external feeds, or of internal feeds generated by Confluence. To display blog posts or to list recently updated pages in a space, use the Feed Builder to create an internal feed, then render it using this macro.

CAUTION: Including unknown HTML inside a webpage is dangerous.

HTML inside an RSS feed can contain active scripting components. This means that it would be possible for a malicious attacker to present a user of your site with script that their web browser would believe came from you. Such code could be used, for example, to steal a user's authentication cookie and give the attacker their Confluence login password.

The RSS macro will only be available if it has been enabled by your Confluence administrator. Also, your Confluence Administrator can define a whitelist of trusted URLs. You will see an error message on the Confluence page, if the included URL is not in the whitelist.

On this page:

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters
- Examples
  - 1. Limit the number of entries displayed
  - 2. Show only the RSS feed titles
  - 3. Hide the feeds titlebar
- Working Example
- How Up to Date is the Feed?
- What Happens to a Page Containing a Disallowed URL?
- Authentication
- Accessing Internal HTTPS Feeds
- Related Topics

Usage with the Macro Browser

To insert the RSS feed macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you’ve found the RSS feed macro and have added the required parameter values, click ‘Insert’ to add it to your page.

Usage with the Wiki Markup Editor

Use the Wiki Markup editor to edit the page and insert the RSS macro. Replace the ‘http://www.example.com/rss/’ URL with your own feed link in this example:

```text
{rss:url=http://www.example.com/rss/}
```
Parameters

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RSS Feed URL (url)</td>
<td>yes</td>
<td>none</td>
<td>The URL of the RSS feed link you want to show.</td>
</tr>
<tr>
<td>Maximum Number of Entries (max)</td>
<td>no</td>
<td>15</td>
<td>Limit the number of entries displayed.</td>
</tr>
<tr>
<td>Show Item Titles Only (showTitlesOnly)</td>
<td>no</td>
<td>false</td>
<td>Show only the titles of the news items, not the content.</td>
</tr>
<tr>
<td>Show Name/Title of RSS Feed (titleBar)</td>
<td>no</td>
<td>true</td>
<td>Hide the feeds title bar.</td>
</tr>
</tbody>
</table>

Examples

1. Limit the number of entries displayed

   ```text
   {rss:url=http://host.com/rss.xml|max=5}
   ```

2. Show only the RSS feed titles

   ```text
   {rss:url=http://host.com/rss.xml|showTitlesOnly=true}
   ```

3. Hide the feeds titlebar

   ```text
   {rss:url=http://host.com/rss.xml|titleBar=false}
   ```

Working Example

What you need to type:

```text
{rss:url=http://www.abc.net.au/news/feed/51120/rss.xml|max=5|showTitlesOnly=true}
```

What you will get:

Error rendering macro 'rss': null

How Up to Date is the Feed?

By default, the RSS Feed macro caches the feed results for 60 minutes before fetching the data again.

If you wish to change the default caching, use the `{cache}` macro to define how often the RSS Feed macro fetches the feed updates. You may want to set the cache to a longer period, so that your page loads faster. Or you may want to retrieve feed results more often, if you need to see the updates sooner. You will need to install the Cache plugin page onto your Confluence site.

To enable caching:
1. Using the Confluence Repository, install the ‘Scripting Plugin’ and the ‘Utilities Plugin’.

2. For each RSS macro that you wish to cache, surround your RSS macro with a Cache macro. For example, to cache feeds for 30 minutes:

   ```
   {cache:refresh=30m}
   {rss:url=http://rss.news.yahoo.com/rss/stocks|max=5}
   {cache}
   ```

   The Cache plugin page provides more information on customising the cache behaviour.

**What Happens to a Page Containing a Disallowed URL?**

Your Confluence Administrator can set up a whitelist of allowed URLs. If this is the case, you may see an error on the pages which contain the RSS macro.

A user can add the RSS macro or the HTML-include macro to a Confluence page. The macro code includes a URL from which the content is drawn. When the page is displayed, Confluence will check the URL against the whitelist. If the URL is not allowed, Confluence will display an error message on the page.

The error message says that Confluence “could not access the content at the URL because it is not from an allowed source” and displays the offending URL. If the person viewing the page is a Confluence Administrator, they will also see a link to the Administration page where they can configure the URL whitelist.

Here is an example of the error message, including the link shown only to Confluence Administrators:

```
Could not access the content at the URL because it is not from an allowed source.
http://ffetters.wordpress.com
Configure whitelist >>
```

Here is an example of the error message, but without the link.

```
Could not access the content at the URL because it is not from an allowed source.
http://ffetters.wordpress.com
You may contact your site administrator and request that this URL be added to the list of allowed sources.
```

**Authentication**

*Private Feeds from External Sites*

RSS feeds which require authentication cannot be accessed using the RSS Macro.

**Accessing Internal HTTPS Feeds**

This applies only to Confluence instances which have enabled HTTPS for all content. If your site is fully HTTPS, the RSS macro cannot access internal feeds. To enable the RSS macro to access internal feeds without affecting your HTTPS setup, enable local-only HTTP access:

1. Shut down Confluence.
2. Consult the SSL guide to enable HTTP access to Confluence. You’ll want to ensure that you have an HTTP connector and an SSL connector, both commented in. This means that Confluence will be accessible via both HTTP and HTTPS. However, you should not have a redirect port, nor rules in web.xml to redirect all traffic.
3. Instead of using web.xml to redirect traffic, insert a firewall rule to redirect all HTTP requests not from the Confluence server to the equivalent HTTPS URL. This ensures that users will only be able to access Confluence via HTTPS, as intended. If you have still left HTTP access for attachments enabled (to avoid the IE download bug) you must selectively enable those URLs as well.
4. Modify your Confluence RSS macro feed link to use the HTTP URL, and restart Confluence.

**Related Topics**

- Subscribing to RSS Feeds within Confluence
- Watching Changes
- Working with Macros
- Configuring a URL Whitelist
Confluence 4.0 Documentation

Return to the Confluence User's Guide.

Search Macro

The Search macro searches your Confluence site based on search terms specified in the macro code, and displays the results on the wiki page.

On this page:

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
  - Found 0 search result(s) for my_query.
- Parameters
  - 1. Setting a limit to the number of search results displayed
  - 2. Specifying the key of the space you want to search
  - 3. Specifying the content type
  - 4. Specifying a time period in which the content was last modified
  - 5. Limiting the search results to content created or modified by a specific user

Usage with the Macro Browser

To insert the search macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you’ve found the search macro and have added the required parameter values, click ‘insert’ to add it to your page.

Usage with the Wiki Markup Editor

In the example below, we assume that you want to search for all pages and other content types which contain the term ‘my_query’.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{search:query=my_query}</td>
<td>Found 0 search result(s) for my_query.</td>
</tr>
</tbody>
</table>

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Terms (query)</td>
<td>yes</td>
<td>none</td>
<td>The search terms which this macro will use to generate its results. You can refine your search query by using operators such as 'AND' and 'OR'. For example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• In the macro browser Search Terms entry box: my_query1 AND my_query2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• In wiki markup editor: {search:query=my_query1 AND my_query2} For more information, take a look at the documentation on the Confluence search syntax.</td>
</tr>
<tr>
<td>Maximum Number of Results (maxLimit)</td>
<td>no</td>
<td>10</td>
<td>Set a limit to the number of search results displayed.</td>
</tr>
</tbody>
</table>
### Confluence 4.0 Documentation

<table>
<thead>
<tr>
<th>Search Parameter</th>
<th>Default Value</th>
<th>Required</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restrict to this Space Key</strong></td>
<td>no</td>
<td>all</td>
<td>Specify the key of the space you want to search. Note that this is case sensitive.</td>
</tr>
<tr>
<td><strong>Content Type</strong></td>
<td>no</td>
<td>all</td>
<td>Specify the content type. The content types are: page, comment, blogpost, attachment, userinfo (the content of user profiles only), spacedesc (the content of space descriptions only) and mail.</td>
</tr>
<tr>
<td><strong>Last Modified</strong></td>
<td>no</td>
<td>all</td>
<td>Specify a period of time in weeks, days, hours and/or minutes, to see the content modified within that time frame. For example: 2h 35m, 3d 30m. These are the values you can use: w = weeks, d = days, h = hours, m = minutes. If no time category is specified, Confluence assumes minutes. If you specify more than one time period (e.g. weeks and days), the periods must be separated by a space and they can come in any order. The time categories are not case sensitive e.g. ‘4d’ is the same as ‘4D’.</td>
</tr>
<tr>
<td><strong>Restrict to this Username</strong></td>
<td>no</td>
<td>all</td>
<td>Specify the username of a Confluence user, to show only content created or updated by that user.</td>
</tr>
</tbody>
</table>

1. Setting a limit to the number of search results displayed

Display a maximum of 20 results.

```
{search:query=my_query|maxLimit=20}
```

2. Specifying the key of the space you want to search

Global space: Search within the Doctemp space only.

```
{search:query=my_query|spacekey=Doctemp}
```

Personal space: Search within jsmith's space only.

```
{search:query=my_query|spacekey=~jsmith}
```

3. Specifying the content type

Search within comments only.

```
{search:query=my_query|type=comment}
```

4. Specifying a time period in which the content was last modified

Search for content modified in the last one week and two days.

```
{search:query=my_query|lastModified=1w 2d}
```

5. Limiting the search results to content created or modified by a specific user
Search within content created or updated by jsmith only.

```
{search:query=my_query|contributor=jsmith}
```

Permissions

When a user views the page containing the Search macro, the search results will show only pages and other content types for which the user has 'View' permission.

**RELATED TOPICS**

- Livesearch Macro
- Searching Confluence
- Working with Macros

Take me back to the Confluence User's Guide.

**Section Macro**

The **section macro** allows you to define a section of a page in which you can insert one or more columns across the page.

**To add sections and columns to a page:**

1. Insert a pair of section macro elements to define the section of page that will contain your set of columns.
2. Within this pair of section macro elements, insert a pair of **column macro** elements. Please note, all content within your section elements must be enclosed by a pair of column macro elements. If you do not do this, the section macro will not work.
3. Repeat step 2 for each column you want to insert across this section of the page.

**On this page:**

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters

**Usage with the Macro Browser**

To insert the section macro into a page using the Macro Browser,

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

Once you’ve found the section macro and have added the required parameter values, click ‘insert’ to add it to your page.

**Usage with the Wiki Markup Editor**

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>{section:border=true}</code></td>
<td><img src="image" alt="Column one text goes here" /></td>
</tr>
<tr>
<td><code>{column}</code></td>
<td><img src="image" alt="Column one text goes here" /></td>
</tr>
<tr>
<td><code>{column}Column two text goes here{column}</code></td>
<td><img src="image" alt="Column two text goes here" /></td>
</tr>
<tr>
<td><code>{section}</code></td>
<td><img src="image" alt="Column two text goes here" /></td>
</tr>
</tbody>
</table>

**Parameters**
When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Border</td>
<td>no</td>
<td>false</td>
<td>Determines whether to draw a border around the section and columns.</td>
</tr>
</tbody>
</table>

**RELATED TOPICS**

Working with Macros
Working with Tables

Take me back to the Confluence User's Guide.

**Space Details Macro**

The **Space Details** macro renders the space's details in a table within the page.

**On this page:**

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters

**Usage with the Macro Browser**

To insert the space details macro into a page using the Macro Browser,

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

   Once you've found the space details macro, click 'Insert' to add it to your page.

**Usage with the Wiki Markup Editor**

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| {space-details}       | Name: Confluence 4.0  
                        | Key: DOC  
                        | Home Page: Home page: Confluence Documentation Home  
                        | Created By: Mike Cannon-Brookes (Dec 17, 2003)  
                        | Space Labels: (None)  
                        | Space Categories: (None)  

**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width of Table</td>
<td>no</td>
<td>100%</td>
<td>The width of the space details table, specified as a percentage (%) of the page width.</td>
</tr>
</tbody>
</table>
Space Jump Macro

This page describes the **Space Jump Macro**, provided with the Documentation theme. You can use space jumping to link from a page in one space to a page with the same name in another space, without knowing the name of the page when you create the link.

The Space Jump macro inserts a link onto the page. When the reader clicks the link, they will jump to a page that has the same name in another space. You specify the space when you insert the Space Jump macro.

**Example:** We use the Space Jump macro to put a standard message at the top of our archive spaces, telling people that they’re reading an old version of the documentation and letting them jump quickly to the same page in the latest documentation. See the words ‘**this page in the current documentation**’ in the screenshot below.

*Screenshot: One way of using the Space Jump macro*

On this page:
- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters
- Examples
- More Information

### Usage with the Macro Browser

To insert the Space Jump macro into a page using the Macro Browser,

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

### Usage with the Wiki Markup Editor

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>`{spacejump:CONF31</td>
<td>alias=This page in the Confluence 3.1 documentation}`</td>
</tr>
</tbody>
</table>

### Parameters

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Alias</strong></td>
<td>None</td>
<td>The text to display as the hyperlinked text. If you do not supply an alias, Confluence will display the page name.</td>
</tr>
</tbody>
</table>
Examples

To jump to a page in the 'MYSPACE' space, displaying the page name as the linked text:

```
{spacejump:MYSPACE}
```

To jump to a page in the 'MYSPACE' space, displaying 'another version of this page' as the linked text:

```
{spacejump:MYSPACE|alias=another version of this page}
```

More Information

**What happens if there is no page with the same name in the target space?**

For the space jump to work, the target space must contain a page with the same name as the page that renders the `{spacejump}` macro. If the target space does not contain such a page, you will see a broken link. Confluence handles this in its usual manner: the link is coloured red. If you click the link, Confluence offers to create the page for you.

**Can I use the Space Jump macro in any space?**

Yes. You can use the Space Jump macro in any space, even if that space is not currently using the Documentation theme. Provided that the Documentation theme plugin and its components are installed and enabled on your Confluence site, the Space Jump macro is available in any space.

**RELATED TOPICS**

Configuring the Documentation Theme
Working with Macros

Take me back to the Confluence User's Guide.

Spaces List Macro

The Spaces List Macro is used to display a list of spaces from within a page, similar to the list of spaces seen on the dashboard.

**On this page:**

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters
- Related Topics

**Usage with the Macro Browser**

To insert the spaces list macro into a page using the Macro Browser:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Usage with the Wiki Markup Editor**

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{spaces} or {spaces-list}</td>
<td>• All</td>
</tr>
<tr>
<td></td>
<td>• Spaces: Favourite</td>
</tr>
<tr>
<td></td>
<td>• Category</td>
</tr>
<tr>
<td>Space: Application Links 1.x</td>
<td></td>
</tr>
<tr>
<td>-----------------------------</td>
<td></td>
</tr>
<tr>
<td>Documentation for AppLinks version 1.x</td>
<td>Browse the “APPLINKS011” space You don't have permission to add pages to &quot;APPLINKS011&quot; Remove “Application Links 1.x” from your favourites Add “Application Links 1.x” to your favourites Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Application Links 2.0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documentation for AppLinks 2.0</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Application Links 2.1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documentation for AppLinks 2.1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Application Links 3.0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documentation for AppLinks 3.0</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Application Links 3.2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documentation for AppLinks 3.2</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Application Links 3.3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documentation for AppLinks 3.3</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Application Links 3.4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documentation for AppLinks 3.4</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Application Links 3.5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documentation for the latest version of AppLinks.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Application Links 3.5 Archive</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documentation for AppLinks 3.5 Archive</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: AtlasCamp 2010</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “ATL” space You don't have permission to add pages to &quot;ATL&quot; Remove “AtlasCamp 2010” from your favourites Add “AtlasCamp 2010” to your favourites Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: AtlasCamp 2011</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “CAMP” space Add a page to “CAMP” Remove “AtlasCamp 2011” from your favourites Add “AtlasCamp 2011” to your favourites Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Atlassian Bonfire</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documentation for the latest version of Bonfire</td>
</tr>
</tbody>
</table>
Space: Atlassian Customer Resources
Browse the "CUST" space You don't have permission to add pages to "CUST" Remove "Atlassian Customer Resources" from your favourites Add "Atlassian Customer Resources" to your favourites Loading

Space: Atlassian Developer Network
For the community of developers modifying and extending Atlassian products.
Browse the "DEVNET" space You don't have permission to add pages to "DEVNET" Remove "Atlassian Developer Network" from your favourites Add "Atlassian Developer Network" to your favourites Loading

Space: Atlassian Development
Atlassian Developers. Because they're just too good to be kept hidden in an office in Sydney.
Browse the "DEV" space You don't have permission to add pages to "DEV" Remove "Atlassian Development" from your favourites Add "Atlassian Development" to your favourites Loading

Space: Atlassian Documentation
Information about and links to the Atlassian product documentation, including downloadable documentation
Browse the "ALLDOC" space You don't have permission to add pages to "ALLDOC" Remove "Atlassian Documentation" from your favourites Add "Atlassian Documentation" to your favourites Loading

Space: Atlassian Events
Browse the "EVENTS" space You don't have permission to add pages to "EVENTS" Remove "Atlassian Events" from your favourites Add "Atlassian Events" to your favourites Loading

Space: Atlassian IDE Connectors
Documentation for the Atlassian Connectors for Eclipse and IntelliJ IDEA
Browse the "IDEPLUGIN" space You don't have permission to add pages to "IDEPLUGIN" Remove "Atlassian IDE Connectors" from your favourites Add "Atlassian IDE Connectors" to your favourites Loading

Space: Atlassian Integration Guide
The ways your Atlassian applications work together and how you can make it happen
Browse the "ATLAS" space You don't have permission to add pages to "ATLAS" Remove "Atlassian Integration Guide" from your favourites Add "Atlassian Integration Guide" to your favourites Loading

Space: Atlassian KnowledgeBase
Browse the "KB" space You don't have permission to add pages to "KB" Remove "Atlassian KnowledgeBase" from your favourites Add "Atlassian KnowledgeBase" to your favourites Loading

Space: Atlassian OnDemand
The current documentation for Atlassian OnDemand
Browse the "AOD" space You don't have permission to add pages to "AOD" Remove "Atlassian OnDemand" from your favourites Add "Atlassian OnDemand" to your favourites Loading

Space: Atlassian OnDemand Test Space
Documentation for the current version of JIRA Studio.
Browse the "AODTest" space You don't have permission to add pages to "AODTest" Remove "Atlassian OnDemand Test Space" from your favourites Add "Atlassian OnDemand Test Space" to your favourites Loading

Space: Atlassian Partner Wiki
Browse the "APW" space You don't have permission to add pages to "APW" Remove "Atlassian Partner Wiki" from your favourites Add "Atlassian Partner Wiki" to your favourites Loading

Space: Atlassian Presentations
Browse the "ATLP" space You don't have permission to add pages to "ATLP" Remove "Atlassian Presentations" from your favourites Add "Atlassian Presentations" to your favourites Loading

Space: Atlassian Training
Browse the "Training" space You don't have permission to add pages to "Training" Remove "Atlassian Training" from your favourites Add "Atlassian Training" to your favourites Loading
<table>
<thead>
<tr>
<th>Space: Atlassian Translations</th>
<th>Browse the &quot;TRANS&quot; space You don't have permission to add pages to &quot;TRANS&quot; Remove &quot;Atlassian Translations&quot; from your favourites Add &quot;Atlassian Translations&quot; to your favourites Loading</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space: Atlassian t-shirt Competition</td>
<td>Browse the &quot;tshirt&quot; space You don't have permission to add pages to &quot;tshirt&quot; Remove &quot;Atlassian t-shirt Competition&quot; from your favourites Add &quot;Atlassian t-shirt Competition&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Atlassian User Group</td>
<td>Browse the &quot;AUG&quot; space Add a page to &quot;AUG&quot; Remove &quot;Atlassian User Group&quot; from your favourites Add &quot;Atlassian User Group&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Atlassian User Interface (AUI)</td>
<td>Browse the &quot;AU&quot; space You don't have permission to add pages to &quot;AU&quot; Remove &quot;Atlassian User Interface (AUI)&quot; from your favourites Add &quot;Atlassian User Interface (AUI)&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Atlassian User Management 1.0 Documentation for version 1.0 of the Atlassian user management interface, as used in Confluence and JIRA.</td>
<td>Browse the &quot;USERMAN010&quot; space You don't have permission to add pages to &quot;USERMAN010&quot; Remove &quot;Atlassian User Management 1.0&quot; from your favourites Add &quot;Atlassian User Management 1.0&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Atlassian User Management 2.0 Documentation for version 2.0 of the Atlassian user management interface, as used in Confluence and JIRA.</td>
<td>Browse the &quot;USERMAN020&quot; space You don't have permission to add pages to &quot;USERMAN020&quot; Remove &quot;Atlassian User Management 2.0&quot; from your favourites Add &quot;Atlassian User Management 2.0&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Atlassian User Management 3.0 Documentation for the latest version of the Atlassian user management interface, as used in Confluence and JIRA.</td>
<td>Browse the &quot;USERMAN&quot; space You don't have permission to add pages to &quot;USERMAN&quot; Remove &quot;Atlassian User Management 3.0&quot; from your favourites Add &quot;Atlassian User Management 3.0&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Atlassian Webinars</td>
<td>Browse the &quot;WEBINAR&quot; space You don't have permission to add pages to &quot;WEBINAR&quot; Remove &quot;Atlassian Webinars&quot; from your favourites Add &quot;Atlassian Webinars&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Bamboo 1.0 Documentation for Bamboo 1.0</td>
<td>Browse the &quot;BAMBOO010&quot; space You don't have permission to add pages to &quot;BAMBOO010&quot; Remove &quot;Bamboo 1.0&quot; from your favourites Add &quot;Bamboo 1.0&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Bamboo 1.1 Documentation for Bamboo 1.1</td>
<td>Browse the &quot;BAMBOO011&quot; space You don't have permission to add pages to &quot;BAMBOO011&quot; Remove &quot;Bamboo 1.1&quot; from your favourites Add &quot;Bamboo 1.1&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Bamboo 1.2 Documentation for Bamboo 1.2</td>
<td>Browse the &quot;BAMBOO012&quot; space You don't have permission to add pages to &quot;BAMBOO012&quot; Remove &quot;Bamboo 1.2&quot; from your favourites Add &quot;Bamboo 1.2&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Bamboo 2.0 Documentation for Bamboo 2.0</td>
<td>Browse the &quot;BAMBOO020&quot; space You don't have permission to add pages to &quot;BAMBOO020&quot; Remove &quot;Bamboo 2.0&quot; from your favourites Add &quot;Bamboo 2.0&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Bamboo 2.1 Documentation for Bamboo 2.1</td>
<td>Browse the &quot;BAMBOO021&quot; space You don't have permission to add pages to &quot;BAMBOO021&quot; Remove &quot;Bamboo 2.1&quot; from your favourites Add &quot;Bamboo 2.1&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Bamboo 2.2</td>
<td></td>
</tr>
<tr>
<td>------------------</td>
<td></td>
</tr>
<tr>
<td><strong>Documentation for Bamboo 2.2</strong></td>
<td></td>
</tr>
<tr>
<td>Browse the &quot;BAMBOO022&quot; space You don't have permission to add pages to &quot;BAMBOO022&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Bamboo 2.2&quot; from your favourites</td>
<td></td>
</tr>
<tr>
<td>Add &quot;Bamboo 2.2&quot; to your favourites</td>
<td></td>
</tr>
<tr>
<td>Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Bamboo 2.3</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Documentation for Bamboo 2.3</strong></td>
</tr>
<tr>
<td>Browse the &quot;BAMBOO023&quot; space You don't have permission to add pages to &quot;BAMBOO023&quot;</td>
</tr>
<tr>
<td>Remove &quot;Bamboo 2.3&quot; from your favourites</td>
</tr>
<tr>
<td>Add &quot;Bamboo 2.3&quot; to your favourites</td>
</tr>
<tr>
<td>Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Bamboo 2.4</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Documentation for Bamboo 2.4</strong></td>
</tr>
<tr>
<td>Browse the &quot;BAMBOO024&quot; space You don't have permission to add pages to &quot;BAMBOO024&quot;</td>
</tr>
<tr>
<td>Remove &quot;Bamboo 2.4&quot; from your favourites</td>
</tr>
<tr>
<td>Add &quot;Bamboo 2.4&quot; to your favourites</td>
</tr>
<tr>
<td>Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Bamboo 2.5</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Documentation for Bamboo 2.5</strong></td>
</tr>
<tr>
<td>Browse the &quot;BAMBOO025&quot; space You don't have permission to add pages to &quot;BAMBOO025&quot;</td>
</tr>
<tr>
<td>Remove &quot;Bamboo 2.5&quot; from your favourites</td>
</tr>
<tr>
<td>Add &quot;Bamboo 2.5&quot; to your favourites</td>
</tr>
<tr>
<td>Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Bamboo 2.6</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Documentation for Bamboo 2.6</strong></td>
</tr>
<tr>
<td>Browse the &quot;BAMBOO026&quot; space You don't have permission to add pages to &quot;BAMBOO026&quot;</td>
</tr>
<tr>
<td>Remove &quot;Bamboo 2.6&quot; from your favourites</td>
</tr>
<tr>
<td>Add &quot;Bamboo 2.6&quot; to your favourites</td>
</tr>
<tr>
<td>Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Bamboo 2.7</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Documentation for Bamboo 2.7</strong></td>
</tr>
<tr>
<td>Browse the &quot;BAMBOO027&quot; space You don't have permission to add pages to &quot;BAMBOO027&quot;</td>
</tr>
<tr>
<td>Remove &quot;Bamboo 2.7&quot; from your favourites</td>
</tr>
<tr>
<td>Add &quot;Bamboo 2.7&quot; to your favourites</td>
</tr>
<tr>
<td>Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Bamboo 2.7 Archive Backup</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Archived Documentation for Bamboo 2.7 (supersedes BAMBOO027 space)</strong></td>
</tr>
<tr>
<td>Browse the &quot;BAMBOO027A&quot; space You don't have permission to add pages to &quot;BAMBOO027A&quot;</td>
</tr>
<tr>
<td>Remove &quot;Bamboo 2.7 Archive Backup&quot; from your favourites</td>
</tr>
<tr>
<td>Add &quot;Bamboo 2.7 Archive Backup&quot; to your favourites</td>
</tr>
<tr>
<td>Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Bamboo 3.0</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Documentation for Bamboo 3.0</strong></td>
</tr>
<tr>
<td>Browse the &quot;BAMBOO030&quot; space You don't have permission to add pages to &quot;BAMBOO030&quot;</td>
</tr>
<tr>
<td>Remove &quot;Bamboo 3.0&quot; from your favourites</td>
</tr>
<tr>
<td>Add &quot;Bamboo 3.0&quot; to your favourites</td>
</tr>
<tr>
<td>Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Bamboo 3.1</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Documentation for Bamboo 3.1</strong></td>
</tr>
<tr>
<td>Browse the &quot;BAMBOO031&quot; space You don't have permission to add pages to &quot;BAMBOO031&quot;</td>
</tr>
<tr>
<td>Remove &quot;Bamboo 3.1&quot; from your favourites</td>
</tr>
<tr>
<td>Add &quot;Bamboo 3.1&quot; to your favourites</td>
</tr>
<tr>
<td>Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Bamboo 3.2</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Documentation for the latest version of Bamboo</strong></td>
</tr>
<tr>
<td>Browse the &quot;BAMBOO&quot; space You don't have permission to add pages to &quot;BAMBOO&quot;</td>
</tr>
<tr>
<td>Remove &quot;Bamboo 3.2&quot; from your favourites</td>
</tr>
<tr>
<td>Add &quot;Bamboo 3.2&quot; to your favourites</td>
</tr>
<tr>
<td>Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Bamboo Development</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Browse the &quot;BAMBOODEV&quot; space</strong> You don't have permission to add pages to &quot;BAMBOODEV&quot;</td>
</tr>
<tr>
<td>Remove &quot;Bamboo Development&quot; from your favourites</td>
</tr>
<tr>
<td>Add &quot;Bamboo Development&quot; to your favourites</td>
</tr>
<tr>
<td>Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Bamboo Extensions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Browse the &quot;BAMEXT&quot; space</strong> You don't have permission to add pages to &quot;BAMEXT&quot;</td>
</tr>
<tr>
<td>Remove &quot;Bamboo Extensions&quot; from your favourites</td>
</tr>
<tr>
<td>Add &quot;Bamboo Extensions&quot; to your favourites</td>
</tr>
<tr>
<td>Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Bamboo Knowledge Base</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Troubleshooting and support tips for Bamboo</strong></td>
</tr>
<tr>
<td>Browse the &quot;BAMKB&quot; space You don't have permission to add pages to &quot;BAMKB&quot;</td>
</tr>
<tr>
<td>Remove &quot;Bamboo Knowledge Base&quot; from your favourites</td>
</tr>
<tr>
<td>Add &quot;Bamboo Knowledge Base&quot; to your favourites</td>
</tr>
<tr>
<td>Loading</td>
</tr>
<tr>
<td>Space</td>
</tr>
<tr>
<td>-------</td>
</tr>
<tr>
<td>Bitbucket</td>
</tr>
<tr>
<td>Bitbucket Knowledge Base</td>
</tr>
<tr>
<td>Clover 2.0</td>
</tr>
<tr>
<td>Clover 2.1</td>
</tr>
<tr>
<td>Clover 2.3</td>
</tr>
<tr>
<td>Clover 2.4</td>
</tr>
<tr>
<td>Clover 2.5</td>
</tr>
<tr>
<td>Clover 2.6</td>
</tr>
<tr>
<td>Clover 3.0</td>
</tr>
<tr>
<td>Clover 3.1</td>
</tr>
<tr>
<td>Clover Knowledge Base</td>
</tr>
<tr>
<td>Codegeist</td>
</tr>
<tr>
<td>Confluence 1.4 User Guide</td>
</tr>
<tr>
<td>Confluence 2.0</td>
</tr>
<tr>
<td>Space: Confluence 2.10</td>
</tr>
<tr>
<td>------------------------</td>
</tr>
<tr>
<td>Space: Confluence 2.5</td>
</tr>
<tr>
<td>Space: Confluence 2.5.6</td>
</tr>
<tr>
<td>Space: Confluence 2.6</td>
</tr>
<tr>
<td>Space: Confluence 2.7</td>
</tr>
<tr>
<td>Space: Confluence 2.8</td>
</tr>
<tr>
<td>Space: Confluence 2.9</td>
</tr>
<tr>
<td>Space: Confluence 3.0</td>
</tr>
<tr>
<td>Space: Confluence 3.1</td>
</tr>
<tr>
<td>Space: Confluence 3.2</td>
</tr>
<tr>
<td>Space: Confluence 3.3</td>
</tr>
<tr>
<td>Space: Confluence 3.4</td>
</tr>
<tr>
<td>Space: Confluence 3.5</td>
</tr>
<tr>
<td>Space: Confluence 4.0 Documentation for the latest version of the Confluence wiki: Installation Guide, User Guide, Admin Guide and other techn...</td>
</tr>
<tr>
<td>---</td>
</tr>
<tr>
<td>Space: Confluence Development</td>
</tr>
<tr>
<td>Space: Confluence Evaluator Resources</td>
</tr>
<tr>
<td>Space: Confluence Extensions</td>
</tr>
<tr>
<td>Space: Confluence Homepage Image</td>
</tr>
<tr>
<td>Space: Confluence Hosted Evaluator Resources</td>
</tr>
<tr>
<td>Space: Confluence Knowledge Base Troubleshooting and support tips for Confluence</td>
</tr>
<tr>
<td>Space: Confluence SharePoint Connector 1.0 Documentation for version 1.0.x of the Confluence SharePoint Connector.</td>
</tr>
<tr>
<td>Space: Confluence SharePoint Connector 1.1 Documentation for version 1.1.x of the Confluence SharePoint Connector.</td>
</tr>
<tr>
<td>Space: Confluence SharePoint Connector 1.2 Documentation for the Confluence SharePoint Connector 1.2. This product integrates Confluence with Microsoft SharePoint.</td>
</tr>
<tr>
<td>Space: Confluence SharePoint Connector 1.3 Documentation for the Confluence SharePoint Connector 1.3. This product integrates Confluence with Microsoft SharePoint.</td>
</tr>
<tr>
<td>Space: Confluence SharePoint Connector 1.4 Documentation for the Confluence SharePoint Connector 1.4. This product integrates Confluence with Microsoft SharePoint.</td>
</tr>
<tr>
<td>Space: Confluence User Community</td>
</tr>
<tr>
<td>----------------------------------</td>
</tr>
<tr>
<td>Space: Crowd 1.0 Documentation for Crowd version 1.0.x</td>
</tr>
<tr>
<td>Space: Crowd 1.1 Documentation for Crowd version 1.1.x</td>
</tr>
<tr>
<td>Space: Crowd 1.2 Documentation for Crowd version 1.2.x</td>
</tr>
<tr>
<td>Space: Crowd 1.3 Documentation for Crowd version 1.3.x</td>
</tr>
<tr>
<td>Space: Crowd 1.4 Documentation for Crowd version 1.4.x</td>
</tr>
<tr>
<td>Space: Crowd 1.5 Documentation for Crowd version 1.5.x</td>
</tr>
<tr>
<td>Space: Crowd 1.6 Documentation for Crowd version 1.6.x</td>
</tr>
<tr>
<td>Space: Crowd 2.0 Documentation for Crowd version 2.0.x</td>
</tr>
<tr>
<td>Space: Crowd 2.1 Documentation for Crowd version 2.1.x</td>
</tr>
<tr>
<td>Space: Crowd 2.2 Documentation for Crowd version 2.2.x</td>
</tr>
<tr>
<td>Space: Crowd 2.3 Documentation for the latest version of Crowd single signon and identity management</td>
</tr>
<tr>
<td>Space: Crowd Development</td>
</tr>
<tr>
<td>Space: Crowd Extension</td>
</tr>
<tr>
<td>Space: Crowd Knowledge Base Troubleshooting and support tips for Crowd</td>
</tr>
<tr>
<td>Space: Crucible 1.1</td>
</tr>
<tr>
<td>-------------------</td>
</tr>
<tr>
<td>Browse the &quot;CRUCIBLE011&quot; space You don't have permission to add pages to &quot;CRUCIBLE011&quot;</td>
</tr>
<tr>
<td>Remove &quot;Crucible 1.1&quot; from your favourites Add &quot;Crucible 1.1&quot; to your favourites Loading</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Crucible 1.2</th>
<th>Documentation for Crucible 1.2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the &quot;CRUCIBLE012&quot; space You don't have permission to add pages to &quot;CRUCIBLE012&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Crucible 1.2&quot; from your favourites Add &quot;Crucible 1.2&quot; to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Crucible 1.5</th>
<th>Documentation for Crucible 1.5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the &quot;CRUCIBLE015&quot; space You don't have permission to add pages to &quot;CRUCIBLE015&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Crucible 1.5&quot; from your favourites Add &quot;Crucible 1.5&quot; to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Crucible 1.6</th>
<th>Documentation for Crucible 1.6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the &quot;CRUCIBLE016&quot; space You don't have permission to add pages to &quot;CRUCIBLE016&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Crucible 1.6&quot; from your favourites Add &quot;Crucible 1.6&quot; to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Crucible 2.0</th>
<th>Documentation for Crucible 2.0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the &quot;CRUCIBLE020&quot; space You don't have permission to add pages to &quot;CRUCIBLE020&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Crucible 2.0&quot; from your favourites Add &quot;Crucible 2.0&quot; to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Crucible 2.1</th>
<th>Documentation for Crucible 2.1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the &quot;CRUCIBLE021&quot; space You don't have permission to add pages to &quot;CRUCIBLE021&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Crucible 2.1&quot; from your favourites Add &quot;Crucible 2.1&quot; to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Crucible 2.2</th>
<th>Documentation for Crucible 2.2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the &quot;CRUCIBLE022&quot; space You don't have permission to add pages to &quot;CRUCIBLE022&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Crucible 2.2&quot; from your favourites Add &quot;Crucible 2.2&quot; to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Crucible 2.3</th>
<th>Documentation for Crucible 2.3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the &quot;CRUCIBLE023&quot; space You don't have permission to add pages to &quot;CRUCIBLE023&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Crucible 2.3&quot; from your favourites Add &quot;Crucible 2.3&quot; to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Crucible 2.4</th>
<th>Documentation for Crucible 2.4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the &quot;CRUCIBLE024&quot; space You don't have permission to add pages to &quot;CRUCIBLE024&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Crucible 2.4&quot; from your favourites Add &quot;Crucible 2.4&quot; to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Crucible 2.5</th>
<th>Documentation for Crucible 2.5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the &quot;CRUCIBLE025&quot; space You don't have permission to add pages to &quot;CRUCIBLE025&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Crucible 2.5&quot; from your favourites Add &quot;Crucible 2.5&quot; to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Crucible 2.6</th>
<th>Documentation for Crucible 2.6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the &quot;CRUCIBLE026&quot; space You don't have permission to add pages to &quot;CRUCIBLE026&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Crucible 2.6&quot; from your favourites Add &quot;Crucible 2.6&quot; to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Crucible 2.7</th>
<th>Latest documentation for Crucible: do your code reviews, your way</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the &quot;CRUCIBLE&quot; space You don't have permission to add pages to &quot;CRUCIBLE&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Crucible 2.7&quot; from your favourites Add &quot;Crucible 2.7&quot; to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Crucible Knowledge Base</th>
<th>Troubleshooting and support tips for Crucible</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the &quot;CRUCKB&quot; space You don't have permission to add pages to &quot;CRUCKB&quot;</td>
<td></td>
</tr>
<tr>
<td>Remove &quot;Crucible Knowledge Base&quot; from your favourites Add &quot;Crucible Knowledge Base&quot; to your favourites Loading</td>
<td></td>
</tr>
<tr>
<td>Space: Demonstration Space</td>
<td>A space which demonstrates Confluence functionality.</td>
</tr>
<tr>
<td>---------------------------</td>
<td>------------------------------------------------</td>
</tr>
<tr>
<td>Space: Doc Sprint</td>
<td></td>
</tr>
<tr>
<td>Space: Enterprise Hosting</td>
<td>Documentation and resources for Enterprise Hosted versions of Confluence and JIRA</td>
</tr>
<tr>
<td>Space: Evaluator Resources</td>
<td></td>
</tr>
<tr>
<td>Space: FishEye 1.3</td>
<td>Documentation for FishEye 1.3</td>
</tr>
<tr>
<td>Space: FishEye 1.4</td>
<td>Documentation for FishEye 1.4</td>
</tr>
<tr>
<td>Space: FishEye 1.5</td>
<td>Documentation for FishEye 1.5</td>
</tr>
<tr>
<td>Space: FishEye 1.6</td>
<td>Documentation for FishEye 1.6</td>
</tr>
<tr>
<td>Space: FishEye 2.0</td>
<td>Documentation for FishEye 2.0</td>
</tr>
<tr>
<td>Space: FishEye 2.1</td>
<td>Documentation for FishEye 2.1</td>
</tr>
<tr>
<td>Space: FishEye 2.2</td>
<td>Documentation for FishEye 2.2</td>
</tr>
<tr>
<td>Space: FishEye 2.3</td>
<td>Documentation for FishEye 2.3</td>
</tr>
<tr>
<td>Space: FishEye 2.4</td>
<td>Documentation for FishEye 2.4</td>
</tr>
<tr>
<td>Space: FishEye 2.5</td>
<td>Documentation for FishEye 2.5</td>
</tr>
<tr>
<td>Space: FishEye 2.6</td>
<td>Documentation for FishEye 2.5</td>
</tr>
<tr>
<td>Space: FishEye 2.7</td>
<td>Latest documentation for FishEye, your view into your source code repository</td>
</tr>
<tr>
<td>Space: FishEye and Crucible Development</td>
<td>Tutorials and reference for enhancing and integrating FishEye and Crucible</td>
</tr>
<tr>
<td>Space: Fisheye Knowledge Base</td>
<td>Troubleshooting and support tips for FishEye</td>
</tr>
<tr>
<td>Space: Gadget Development</td>
<td></td>
</tr>
<tr>
<td>Space: Gadgets and Dashboards 1.0</td>
<td>Documentation for version 1.0.x of Atlassian Gadgets and Dashboards</td>
</tr>
<tr>
<td>Space: Gadgets and Dashboards 2.0</td>
<td>Documentation for version 2.0.x of Atlassian Gadgets and Dashboards</td>
</tr>
<tr>
<td>Space: Gadgets and Dashboards 3.0</td>
<td>Documentation for the latest version of Atlassian Gadgets and Dashboards</td>
</tr>
<tr>
<td>Space: GreenHopper 3.8</td>
<td>Documentation archive for GreenHopper 3.8</td>
</tr>
<tr>
<td>Space: GreenHopper 4.0</td>
<td>Documentation for GreenHopper 4.0</td>
</tr>
<tr>
<td>Space: GreenHopper 4.1</td>
<td>Documentation for GreenHopper 4.1</td>
</tr>
<tr>
<td>Space: GreenHopper 4.2</td>
<td>Documentation for GreenHopper 4.2</td>
</tr>
<tr>
<td>Space: GreenHopper 4.3</td>
<td>Documentation for GreenHopper 4.3</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>Browse the “GH043” space You don’t have permission to add pages to “GH043”</td>
<td></td>
</tr>
<tr>
<td>Remove “GreenHopper 4.3” from your favourites Add “GreenHopper 4.3” to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: GreenHopper 4.4</th>
<th>Documentation for GreenHopper 4.4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “GH044” space You don’t have permission to add pages to “GH044”</td>
<td></td>
</tr>
<tr>
<td>Remove “GreenHopper 4.4” from your favourites Add “GreenHopper 4.4” to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: GreenHopper 5.0</th>
<th>Documentation for GreenHopper 5.0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “GH050” space You don’t have permission to add pages to “GH050”</td>
<td></td>
</tr>
<tr>
<td>Remove “GreenHopper 5.0” from your favourites Add “GreenHopper 5.0” to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: GreenHopper 5.1</th>
<th>Documentation for GreenHopper 5.1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “GH051” space You don’t have permission to add pages to “GH051”</td>
<td></td>
</tr>
<tr>
<td>Remove “GreenHopper 5.1” from your favourites Add “GreenHopper 5.1” to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: GreenHopper 5.2</th>
<th>Documentation for GreenHopper 5.2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “GH052” space You don’t have permission to add pages to “GH052”</td>
<td></td>
</tr>
<tr>
<td>Remove “GreenHopper 5.2” from your favourites Add “GreenHopper 5.2” to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: GreenHopper 5.3</th>
<th>Documentation for GreenHopper 5.3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “GH053” space You don’t have permission to add pages to “GH053”</td>
<td></td>
</tr>
<tr>
<td>Remove “GreenHopper 5.3” from your favourites Add “GreenHopper 5.3” to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: GreenHopper 5.4</th>
<th>Documentation for GreenHopper 5.4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “GH054” space You don’t have permission to add pages to “GH054”</td>
<td></td>
</tr>
<tr>
<td>Remove “GreenHopper 5.4” from your favourites Add “GreenHopper 5.4” to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: GreenHopper 5.5</th>
<th>Documentation for GreenHopper 5.5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “GH055” space You don’t have permission to add pages to “GH055”</td>
<td></td>
</tr>
<tr>
<td>Remove “GreenHopper 5.5” from your favourites Add “GreenHopper 5.5” to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: GreenHopper 5.6</th>
<th>Documentation for GreenHopper 5.6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “GH056” space You don’t have permission to add pages to “GH056”</td>
<td></td>
</tr>
<tr>
<td>Remove “GreenHopper 5.6” from your favourites Add “GreenHopper 5.6” to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: GreenHopper 5.7</th>
<th>Documentation for the latest version of GreenHopper.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “GH” space You don’t have permission to add pages to “GH”</td>
<td></td>
</tr>
<tr>
<td>Remove “GreenHopper 5.7” from your favourites Add “GreenHopper 5.7” to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: GreenHopper Development</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “GHDEV” space You don’t have permission to add pages to “GHDEV”</td>
<td></td>
</tr>
<tr>
<td>Remove “GreenHopper Development” from your favourites Add “GreenHopper Development” to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: GreenHopper Knowledge Base</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “GHKB” space You don’t have permission to add pages to “GHKB”</td>
<td></td>
</tr>
<tr>
<td>Remove “GreenHopper Knowledge Base” from your favourites Add “GreenHopper Knowledge Base” to your favourites Loading</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Space: Integrating with JIRA</th>
<th>Documentation for the latest version of the JIRA integration interface</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse the “JIRAHOOKUP” space You don’t have permission to add pages to “JIRAHOOKUP”</td>
<td></td>
</tr>
<tr>
<td>Remove “Integrating with JIRA” from your favourites Add “Integrating with JIRA” to your favourites Loading</td>
<td></td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA 3.0 Developer Documentation Archive</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA 4.0 Documentation for JIRA 4.0</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA 4.1 Documentation for JIRA 4.1</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA 4.2 Documentation for JIRA 4.2</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA 4.3 Documentation for JIRA 4.3</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA 4.4 Documentation for JIRA 4.4</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA Community Space</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA Development</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA Download Evaluator Resources</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA Extensions</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA Hosted Evaluator Resources</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA in JIRA Studio Documentation for JIRA 4.4</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA Knowledge Base Troubleshooting and support tips for Jira</td>
</tr>
<tr>
<td>Space:</td>
<td>JIRA Mobile Connect</td>
</tr>
<tr>
<td>Space: JIRA Staging</td>
<td>Browse the &quot;JIRASTAG&quot; space You don't have permission to add pages to &quot;JIRASTAG&quot; Remove &quot;JIRA Staging&quot; from your favourites Add &quot;JIRA Staging&quot; to your favourites Loading</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Space: JIRA Studio</td>
<td>Browse the &quot;JIRASTUDIO&quot; space You don't have permission to add pages to &quot;JIRASTUDIO&quot; Remove &quot;JIRA Studio&quot; from your favourites Add &quot;JIRA Studio&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: JIRA Studio Evaluator Resources</td>
<td>Browse the &quot;STUDEVAL&quot; space You don't have permission to add pages to &quot;STUDEVAL&quot; Remove &quot;JIRA Studio Evaluator Resources&quot; from your favourites Add &quot;JIRA Studio Evaluator Resources&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Plugin Framework</td>
<td>Browse the &quot;PLUGINFRAMEWORK&quot; space You don't have permission to add pages to &quot;PLUGINFRAMEWORK&quot; Remove &quot;Plugin Framework&quot; from your favourites Add &quot;Plugin Framework&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: REST APIs</td>
<td>Browse the &quot;REST&quot; space You don't have permission to add pages to &quot;REST&quot; Remove &quot;REST APIs&quot; from your favourites Add &quot;REST APIs&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Security</td>
<td>Browse the &quot;SECURITY&quot; space You don't have permission to add pages to &quot;SECURITY&quot; Remove &quot;Security&quot; from your favourites Add &quot;Security&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Shared Access Layer</td>
<td>Browse the &quot;SAL&quot; space You don't have permission to add pages to &quot;SAL&quot; Remove &quot;Shared Access Layer&quot; from your favourites Add &quot;Shared Access Layer&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Summit 2011 Speaker Guidelines</td>
<td>Browse the &quot;SMT&quot; space You don't have permission to add pages to &quot;SMT&quot; Remove &quot;Summit 2011 Speaker Guidelines&quot; from your favourites Add &quot;Summit 2011 Speaker Guidelines&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Summit 2011 Sponsorship</td>
<td>Browse the &quot;SMT11&quot; space You don't have permission to add pages to &quot;SMT11&quot; Remove &quot;Summit 2011 Sponsorship&quot; from your favourites Add &quot;Summit 2011 Sponsorship&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Support</td>
<td>Browse the &quot;Support&quot; space You don't have permission to add pages to &quot;Support&quot; Remove &quot;Support&quot; from your favourites Add &quot;Support&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Team Calendars</td>
<td>Browse the &quot;TEAMCAL&quot; space You don't have permission to add pages to &quot;TEAMCAL&quot; Remove &quot;Team Calendars&quot; from your favourites Add &quot;Team Calendars&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Test space</td>
<td>Browse the &quot;TESTRSS&quot; space You don't have permission to add pages to &quot;TESTRSS&quot; Remove &quot;Test space&quot; from your favourites Add &quot;Test space&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Test Space</td>
<td>Browse the &quot;TST&quot; space Add a page to &quot;TST&quot; Remove &quot;Test Space&quot; from your favourites Add &quot;Test Space&quot; to your favourites Loading</td>
</tr>
<tr>
<td>Space: Test Space</td>
<td>Browse the &quot;TST&quot; space Add a page to &quot;TST&quot; Remove &quot;Test Space&quot; from your favourites Add &quot;Test Space&quot; to your favourites Loading</td>
</tr>
</tbody>
</table>
### Parameters

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scope of spaces</td>
<td>no</td>
<td>all</td>
<td>Specify the view from which spaces are listed. Available options are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- all – All spaces in the Confluence installation.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- category – Spaces grouped according to space categories.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- team – Same as ‘category’ above. Space categories were</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>formerly known as team labels, and this option remains in the</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>macro to ensure backwards compatibility with earlier versions of</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>the macro.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- favourite – Spaces which you have added to your favourites list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- my – Same as ‘favourite’ above. This option remains in the</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>macro to ensure backwards compatibility with earlier versions of</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>the macro.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- new – New spaces which have been created within the last 7 days.</td>
</tr>
</tbody>
</table>
### Width of List (width)

| Width of List | no | 100% | Specify the width of the table. The width of the spaces list table, specified as a percentage (%).

### Examples

Display the spaces in a table with a width of 40% of the window size:

\{spaces:width=40%\}

Display the spaces grouped by space category:

\{spaces:team\}

### Related Topics

- Browsing a space
- Creating a Page
- Working with Macros

Take me back to the Confluence User’s Guide

## Status Macro

The Status macro displays a coloured lozenge (a rounded box) that is useful for reporting project status. You can choose the colour of the lozenge and the text that appears inside the lozenge. The macro also displays its current status in the editor, and you can change the status directly in the editor.

All good!

Screenshot: Click on the Status macro lozenge to change the status.

All good!

### On this page:

- Using the Status Macro
- Parameters
- Related Topics

### Using the Status Macro

To add the Status macro to a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

### Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.
Table of Contents Macro

The Table of Contents macro scans the headings of the current Confluence page to dynamically create a table of contents from your page headings. This helps readers navigate lengthy pages by summarising the content structure and providing links to headings. Headings are indented progressively.

On this page:

- Using the Table of Contents Macro
- Macro Parameters
- Examples
  - Filtered Table of Contents
  - Flat List
- Notes
- Related Topics

Using the Table of Contents Macro

To add the 'Table of Contents' macro to a page using the Macro Browser:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

You can also add the macro to a page by choosing **Insert > Table of Contents** from the editor toolbar.

Macro Parameters

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Output Type** | list    | • **list** — produces a typical list type TOC.  
               |         | • **flat** — produces a horizontal menu-type series of links. |
| **Display Section Numbering** | clear | Select the check box to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3. |
List Style | none | Select the style of bullet point for each list item. You can use any valid CSS style. For example:
- none — no list style is displayed
- circle — the list style is a circle
- disc — the list style is a filled circle. This is the typical bullet list, and is used for this example list.
- square — the list style is a square
- decimal — the list is numbered (1, 2, 3, 4, 5)
- lower-alpha — the list is lower-case, alphabetised (a, b, c, d, e)
- lower-roman — the list style is lower roman numerals (i, ii, iii, iv, v, vi)
- upper-roman — the list style is upper roman numerals (I, II, III, IV, V, VI)

Heading Indent | Sets the indent for a list according to CSS quantities. Entering 10px will successively indent heading groups by 10px. For example, level 1 headings will be indented 10px and level 2 headings will be indented an additional 10px.

Separator | brackets | This parameter applies to flat lists only. You can enter any of the following values:
- brackets — Each item is enclosed by square brackets: [ ].
- braces — Each item is enclosed by braces: { }.
- parens — Each item is enclosed by parentheses: ( ).
- pipe — Each item is separated by a pipe:
- anything — Each item is separated by the value you enter. You can enter any text as a separator, for example "***". If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters.

Minimum Heading Level | 1 | Select the highest heading level to start your TOC list. For example, entering 2 will include levels 2, and lower, headings, but will not include level 1 headings.

Maximum Heading Level | 7 | Select the lowest heading level to include. For example, entering 2 will include levels 1 and 2, but will not include level 3 headings and below.

Include Headings | Filter headings to include according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings.

Exclude Headings | Filter headings to exclude according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings.

Printable | checked | By default, the TOC is set to print. If you clear the check box, the TOC will not be visible when you print the page.

CSS Class Name | If you have custom TOC styles in your CSS style sheet, use this parameter to output the TOC inside <div> tags with the specified class attribute.

Examples

The examples below are based on this table of contents:
Filtered Table of Contents

This example filters the headings to include those that contain 'Favourite', but excludes headings which end with 'Things'. The list is styled with Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
<tr>
<td>Exclude Headings</td>
<td>.*Things</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

1. **Favourite Places**
2. **Favourite Foods**

Flat List

This example filters all headings to render a flat list of 'Unknowns' enclosed in square brackets (the default list style).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Maximum Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

[Unknown Places] [Unknown Foods] [Unknown Things]

Notes

- Due to an outstanding issue in the Table of Contents macro (CONF-10619), the Macro Browser's **Refresh** function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Contents macro occurs only after the page is saved.
- **Using HTML Heading Markup with the Table of Contents Macro**

The Table of Contents macro cannot handle HTML heading markup on its own. Hence, if you use the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Contents macro will not create a contents list out of these headings. (For more information about this issue, please refer to TOC-93.) However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Contents macro will incorporate these headings into your contents list.
The syntax for the anchor name is the page name and heading name separated by a hyphen, in which the page and heading names have all spaces removed and are converted to lowercase. If punctuation marks occur within a page or heading name, each mark should usually be converted to its URL escape code in the anchor name.

Related Topics
Table of Contents Zone Macro
Pagetree Macro
Adding a Navigation Sidebar
Working with Macros

Table of Contents Zone Macro
The Table of Contents Zone macro enables you to mark out a 'page zone' from which you can use the headings to create a table of contents. Styling the headings as a flat list enables you to enclose the page text by top and bottom navigation bars similar to web navigation. When styled as a list, headings are indented progressively.

On this page:
- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Macro Parameters
- Examples
  - Basic Table of Contents
  - Filtered Table of Contents
  - Flat List
- Notes

Usage with the Macro Browser
To insert the Pagetree macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the Pagetree macro and have added the required parameter values, click 'Insert' to add it to your page.

Usage with the Wiki Markup Editor
Include the following markup in your page:

```markdown
{toc-zone:type:=[[list,flat]|[maxLevel=1]]
Content in the zone, including other macros and page content.
{toc-zone}
```

There are more examples below.

Macro Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location</td>
<td>no</td>
<td>both</td>
<td>Use this parameter to specify whether the output list displays at the top, at the bottom, or encloses the page zone content. By default, the macro displays headings at both the top and the bottom of the page.</td>
</tr>
<tr>
<td>Output Type (type)</td>
<td>no</td>
<td>list</td>
<td>Set this to &quot;list&quot; or &quot;flat&quot;. Selecting list produces a typical list type TOC. Selecting flat produces a horizontal menu-type series of links, for example: [Heading 1] [Heading 2] [Heading 3].</td>
</tr>
<tr>
<td>-------------------</td>
<td>----</td>
<td>------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Display Section Numbering (outline)</td>
<td>no</td>
<td>false</td>
<td>Select the tick box to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.</td>
</tr>
<tr>
<td>List Style (style)</td>
<td>no</td>
<td>none</td>
<td>Use this parameter to select the style of bullet point for each list item. You can use any valid CSS style. For example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- none — no list style is displayed</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- circle — the list style is a circle</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- disc — the list style is a filled circle — this is the typical bullet list, and is the one we're using for this example list</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- square — the list style is a square</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- decimal — the list is numbered (1, 2, 3, 4, 5)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- lower-alpha — the list is lower-case, alphabetised (a, b, c, d, e)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- lower-roman — the list style is lower roman numerals (i, ii, iii, iv, v, vi)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- upper-roman — the list style is upper roman numerals (I, II, III, IV, V, VI)</td>
</tr>
<tr>
<td>Separator (separator)</td>
<td>no</td>
<td>brackets</td>
<td>This parameter applies to &quot;flat&quot; lists only. Use this parameter to style the display of a &quot;flat&quot; or horizontal list. You can enter any of the following parameters:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- brackets — Each item is enclosed by square brackets: [ ].</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- braces — Each item is enclosed by braces: { }.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- parens — Each item is enclosed by parentheses: ( ).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- pipe — Each item is separated by a pipe:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- anything — Each is separated by the value you enter. You can enter any text as a separator, for example &quot;***&quot;. If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters.</td>
</tr>
<tr>
<td>Indent</td>
<td>no</td>
<td></td>
<td>Use this parameter to style the indent for a &quot;list&quot; according to CSS quantities, entering &quot;10px&quot; will successively indent list heading groups 10px. For example, h1 headings will be indented 10px and h2 headings will be indented an additional 10px.</td>
</tr>
<tr>
<td>Minimum Heading Level (minLevel)</td>
<td>no</td>
<td>1</td>
<td>Use this parameter to select the heading level to start your TOC list. For example, 2 will list h2, h3, and h4 headings, but will not include h1 headings.</td>
</tr>
<tr>
<td>Maximum Heading Level (maxLevel)</td>
<td>no</td>
<td>7</td>
<td>Use this parameter to select the maximum heading levels to include. For example, 2 will list h1 and h2, but will not include h3 and below.</td>
</tr>
<tr>
<td>Include Headings (include)</td>
<td>no</td>
<td></td>
<td>Use this parameter as a way of filtering to include headings according to specific criteria. You can use wildcard characters to filter the headings. See Sun's Regex documentation for examples of constructing regular expression strings.</td>
</tr>
</tbody>
</table>

⚠️ Because '|' is the macro parameter separator, use a comma ',' where you would normally use a '|'. If you need to match a comma, use its escape code: '\x2c'.
Exclude Headings (exclude)  no
Use this parameter as a way of filtering to exclude headings according to specific criteria. You can use wildcard characters to filter the headings. See Sun’s Regex documentation for examples of constructing regular expression strings.

Printable (printable)  no true
By default, the TOC is set to print. If you set this parameter to false, the TOC will not be visible when you print the page.

CSS Class Name (class)  no
If you have a custom TOC in your CSS style sheet, you can use this parameter to output the TOC with the specified “class” attribute.

Examples
The examples are based on a page with the following headings:

h1. Places
h2. Favourite Places
h2. Unknown Places
h1. Foods
h2. Favourite Foods
h2. Unknown Foods
h1. Things
h2. Favourite Things
h2. Unknown Things

Basic Table of Contents
This will display only level 1 headings as a numbered list at the top of the page.

```
{toc-zone:type|location=top|type=flat|maxLevel=1}

h1. Places
h2. Favourite Places
h2. Unknown Places
h1. Foods
h2. Favourite Foods
h2. Unknown Foods
h1. Things
h2. Favourite Things
h2. Unknown Things
{toc-zone}
```

Filtered Table of Contents
This example will filter all headings to include those that contain “Favourite”, but will exclude any heading which ends with the word “Things”. The list is styled with Roman numerals. It will not display on the printed page.

```
{toc-zone:minLevel=2|maxLevel=4|exclude=Adding your own Tip}

Page zone content
{toc-zone}
```

You can see this example ‘live’ by visiting the Tips via Twitter page.

Flat List
This will filter all headings to render a flat list of 'Unknowns' enclosed in square brackets.

```{toc:type=flat|maxLevel=2|include=Unknown.*}
```

**Screenshot: Filtered TOC 'zone' headings displayed as flat list**

[ Unknown Places ] [ Unknown Foods ] [ Unknown Things ]

**Notes**

- Due to an outstanding issue in the Table of Contents Zone macro (CONF-10619), the Macro Browser's Refresh function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Contents Zone macro occurs only after the page is saved.
- Using HTML Heading Markup with the Table of Contents Zone Macro — The Table of Contents Zone macro cannot handle HTML heading markup on its own. Hence, if you used the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Contents Zone macro will not create a contents list out of these headings. (For more information on about this issue, please refer to TOC-93.)

However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Contents Zone macro will incorporate these headings into your contents list.

```
<h2><a name="pagename-headingname"></a>Heading Name</h2>
```

The syntax for the anchor name is usually the page name and heading name separated by a hyphen, in which the page and heading names have all spaces removed and are converted to lowercase. If punctuation marks occur within a page or heading name, each mark should usually be converted to its URL escape code in the anchor name.

**RELATED TOPICS**

Table of Contents Macro
Pagetree Macro
Adding a Navigation Sidebar
Working with Macros

Take me back to the Confluence User's Guide.

**Tasklist Macro**

The Tasklist macro allows you to create and update a list of tasks on the wiki page. Users viewing the page can modify the tasks without having to edit the page, provided they have the required permissions to modify the page.

**On this page:**

- Using the Tasklist Macro
- Parameters
- Editing the Task List while Viewing a Page
- Sorting the Tasks
- Viewing the Progress on Tasks Completed
- Related Topics

**Using the Tasklist Macro**

To add the Tasklist macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Parameters**

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.
Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>‘Task List’</td>
<td>The name of the task list. This is displayed as the title above the list of tasks.</td>
</tr>
<tr>
<td>Width of List</td>
<td>530px</td>
<td>The width of the task list.</td>
</tr>
<tr>
<td>Enable Locking</td>
<td>clear</td>
<td>When selected, you can lock individual tasks so that they cannot be changed. See instructions below on editing the task list.</td>
</tr>
<tr>
<td>Prompt on Delete</td>
<td>clear</td>
<td>When selected, the user must confirm the deletion of a task in the list.</td>
</tr>
</tbody>
</table>

**Editing the Task List while Viewing a Page**

While viewing a page, you can change the tasks in a task list as follows:

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a task</td>
<td>Type the task description in the box under the list title, and click Add.</td>
</tr>
<tr>
<td>Completing/uncompleting a task</td>
<td>Click the check box next to a task to mark the task as complete. The task name will become a lighter color and the progress bar will be updated. Clear the check box to mark the task as uncompleted. You can also click Uncheck all to mark all tasks as uncompleted.</td>
</tr>
<tr>
<td>Editing a task</td>
<td>Move your cursor over the task and click the edit icon (pencil) that appears to the right of the task. The task name will become editable and the edit icon will be replaced with a save icon. Make your change and press the ‘Enter’ key to save or click the save icon.</td>
</tr>
<tr>
<td>Deleting a task</td>
<td>Move your cursor over the task and click the delete icon (trash can) that appears to the right of the task.</td>
</tr>
<tr>
<td>Viewing details of a task</td>
<td>Click the arrow icon to the left of the task name. The task details will open in an expanded view.</td>
</tr>
<tr>
<td>Locking a task</td>
<td>Provided that the Enable Locking parameter has been selected, you can click the lock icon to prevent the task from being edited, deleted, or otherwise changed.</td>
</tr>
<tr>
<td>Changing the priority</td>
<td>When the task details are visible, click the appropriate option — High, Medium or Low.</td>
</tr>
<tr>
<td>Assigning the task</td>
<td>When the task details are visible, change the assignee of the task by typing in or searching for a username.</td>
</tr>
</tbody>
</table>

*Screenshot: Task List showing task details*
Sorting the Tasks

There are two ways to sort the tasks in the list:

- Using the Sort by list.
- Using drag and drop.

Select one of the sort options from the ‘Sort by’ list:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom</td>
<td>This is the default option.</td>
</tr>
<tr>
<td>Priority</td>
<td>Sort the list in order of the priority you have allocated to each task.</td>
</tr>
<tr>
<td>Date Created</td>
<td>Sort the list in order of the dates upon which the tasks were created.</td>
</tr>
<tr>
<td>Completed</td>
<td>Move all completed tasks to the bottom or top of the list.</td>
</tr>
<tr>
<td>Name</td>
<td>Sort the list in order of the task names.</td>
</tr>
<tr>
<td>Assignee</td>
<td>Sort the list in order of the usernames assigned to the tasks.</td>
</tr>
</tbody>
</table>

Once you have selected a sort option, use the icon beside the Sort by box to reverse the sort order.

Dragging and dropping a task into a new position:

Drag a task up or down the list using the ‘drag me’ handle to the right of the task name. Make sure the task is positioned to the left of the existing tasks. A space will open and you will be able to drop the task into its new position.

Viewing the Progress on Tasks Completed

The bar at the top of the task list displays two different colours, indicating the percentage of tasks completed.

Screenshot: Progress Bar on Task List
Tip Macro

The Tip Macro allows you to highlight a helpful tip on a Confluence page. It creates a green-coloured box surrounding your text as shown below.

![Tip Macro Example]

This text is rendered inside the tip macro.

On this page:
- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters

Usage with the Macro Browser

To insert the tip macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the tip macro, click 'insert' to add it to your page.

Usage with the Wiki Markup Editor

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{tip}Ask a question at Atlassian Answers!{tip}</td>
<td>✅ Ask a question at Atlassian Answers!</td>
</tr>
</tbody>
</table>

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output.
The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title (title)</td>
<td>no</td>
<td>none</td>
<td>The title of the tip. If specified, will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>Show Tip Icon (icon)</td>
<td>no</td>
<td>true</td>
<td>If &quot;false&quot;, the icon will not be displayed.</td>
</tr>
</tbody>
</table>

**RELATED TOPICS**

Working with Macros

Take me back to the Confluence User's Guide.

**Userlister Macro**

The Userlister macro displays a list of users registered in Confluence, based on their group membership.

On this page:

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters
- Examples
  - Listing all Users
  - Specifying a Group
  - Listing Only Online Users

**Usage with the Macro Browser**

To insert the userlister macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
3. Once you've found the userlister macro, click 'insert' to add it to your page.

**Usage with the Wiki Markup Editor**

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>{userlister:groups=*}</code></td>
<td>Group: All Users</td>
</tr>
<tr>
<td></td>
<td>deep (deep)</td>
</tr>
<tr>
<td></td>
<td>a (abcd)</td>
</tr>
<tr>
<td></td>
<td>Wim De Woelo (<a href="mailto:wim.devosle@ibbt.be">wim.devosle@ibbt.be</a>)</td>
</tr>
<tr>
<td></td>
<td>xyz (xyz xyz)</td>
</tr>
<tr>
<td></td>
<td>(<a href="http://confluence.atlassian.com/designt">http://confluence.atlassian.com/designt</a>)</td>
</tr>
<tr>
<td></td>
<td>lmm (lmm)</td>
</tr>
</tbody>
</table>
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group(s)</td>
<td>yes</td>
<td>none</td>
<td>Use parameter name 'group' or 'groups' to specify one or more groups whose Confluence users you want to list, using a comma-separated list of group names. To see all users registered in a Confluence installation, specify an asterisk ('*') for this parameter's value.</td>
</tr>
<tr>
<td>Display Online/Offline Users</td>
<td>no</td>
<td>none</td>
<td>Specify 'true' to generate a list of online users. Specify 'false' to generate a list of offline users.</td>
</tr>
</tbody>
</table>

Examples

Listing all Users

Here is an example that lists all the users registered on your Confluence site.

```
{userlister:groups=*}
```

Specifying a Group

Here is an example that lists the users that belong to the group 'my-staff'.

```
{userlister:groups=my-staff}
```

Listing Only Online Users

In order to make this feature functional, a System Administrator needs to enable the User Log In Listener for your Confluence site.

Here is an example that lists all currently online users in the 'my-staff' group.

```
{userlister:groups=my-staff|online=true}
```

List of online users can be misleading

When the parameter 'online=true' is used, Confluence uses a context listener to generate the list of online users. A context listener is a J2EE term for something that listens for events in the application server. We listen for session open and close events, so a user is ‘online’ if they have a session on the application server. Some application servers don't correctly despatch close events for sessions – in these cases, the list of online users may be misleading.

RELATED TOPICS

Working with Macros
Configuring the userlister Macro in the Confluence Administrator's Guide

Take me back to the Confluence User's Guide.

User Status List Macro
The **User Status List** macro displays a history of any Confluence user's Status Updates on your Confluence page or blog. This is the same history that appears in the user's Status Updates view.

*Screenshot: Example Usage of the User Status List Macro*

```
<table>
<thead>
<tr>
<th>History of my Status Updates</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Working on final User Profile updates.&quot;</td>
</tr>
<tr>
<td>&quot;Moving onto Networks.&quot;</td>
</tr>
<tr>
<td>&quot;Well... Just one last status update.&quot;</td>
</tr>
<tr>
<td>&quot;Now venturing off onto other topics.&quot;</td>
</tr>
<tr>
<td>&quot;Now working on User Status Updates. At last...&quot;</td>
</tr>
</tbody>
</table>
```

**On this page:**

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters
- Related Topics

**Usage with the Macro Browser**

To insert the User Status List macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the User Status List macro and have added the required parameter values, click 'insert' to add it to your page.

**Usage with the Wiki Markup Editor**

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>Example of what you will get</th>
</tr>
</thead>
</table>
h5. History of my Status Updates
{status-list:username=ggaskell}

<table>
<thead>
<tr>
<th>History of my Status Updates</th>
</tr>
</thead>
</table>
| "Working on final User Profile updates."
  Clear | Delete | about 2 hours ago |
| "Moving onto Networks."
  Delete | May 06 |
| "Well… Just one last status update."
  Delete | May 01 |
| "Now venturing off onto other topics."
  Delete | April 30 |
| "Now working on User Status Updates. At last..."
  Delete | April 30 |

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required in Wiki Markup?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>yes</td>
<td>none</td>
<td>The username of the Confluence user whose history of Status Updates you wish to show.</td>
</tr>
</tbody>
</table>

If you wish to list status updates made by more than just one user, you can use the recently updated macro in conjunction with the following parameter-value combinations:

- Include these Content Types Only — status
- Author(s) by username — the user(s) whose status updates you want to include in the list. If you leave this field blank, the status updates of all users will be included.

Related Topics

Working with Macros
User Status Updates

Take me back to the Confluence User's Guide.

View File Macro

The view file macro allows you to embed an Office or PDF document into your Confluence page. First attach the document to a wiki page and then use the view file macro to display the document's content.

When viewing the page, users will see the content of the Office document. Users do not need to have Office installed, in order to see the content of the Office document.

Where applicable, users will be able to open the document for editing in their Office application.
This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.

The view file macro provides several unique parameter options for some of the types of files it handles. Hence, to simplify its use, the view file macro is separated into the following four macros in the macro browser:

- Office Word
- Office Powerpoint
- Office Excel
- View PDF

On this page:

- Basic Usage without the Macro Browser
- Example of Usage
- Prerequisites for Viewing and Displaying Office Documents
- Displaying a Word Document in Confluence
  - Usage with the Macro Browser (doc)
  - Basic Usage with the Wiki Markup Editor (doc)
  - Parameters (doc)
  - Editing the Word Document
- Displaying a PowerPoint Presentation in Confluence
  - Usage with the Macro Browser (ppt)
  - Basic Usage with the Wiki Markup Editor (ppt)
  - Parameters (ppt)
  - Viewing the Slide Show and Editing the Presentation
- Displaying an Excel Spreadsheet in Confluence
  - Usage with the Macro Browser (xls)
  - Basic Usage with the Wiki Markup Editor (xls)
  - Parameters (xls)
  - Editing the Excel Spreadsheet
- Displaying a PDF Document in Confluence
  - Usage with the Macro Browser (pdf)
  - Basic Usage with the Wiki Markup Editor (pdf)
  - Parameters (pdf)
  - Viewing the PDF Document
- Troubleshooting
- Related Topics

Basic Usage without the Macro Browser

To use the view file macro without the macro browser, enter it directly in the Wiki Markup or Rich Text editors based on one of the following examples, along with any parameters (described below) that suit the type of file.

```
{viewdoc:name=my document.doc}
{viewppt:name=my presentation.ppt}
{viewxls:name=my spreadsheet.xls}
{viewpdf:name=my document.pdf}
```

Editing 'older style' (viewfile) macros

In Confluence 3.0, the (viewfile) macro's syntax was changed to be file type-specific (as indicated by the examples above). If your Confluence site was upgraded to Confluence 3.0 and you had existing content which used the 'older style' syntax for this macro ((viewfile)), you can still edit these macros via the macro browser. Just place your cursor inside the viewfile macro's braces and click the macro browser icon  to edit it. The 'edit only' version of the view file macro will open in the macro browser, allowing you to edit its specific parameters.

Example of Usage

The live example below shows how to display an Excel spreadsheet on a Confluence page. The Excel spreadsheet is attached to this documentation page.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>

---

371
Prerequisites for Viewing and Displaying Office Documents

If you want to use the `View File` macro, or to view Office files attached to a Confluence page, you need the setup described below.

**Browsers and Flash Player**

You can use any browser to view an Office file on a wiki page or attachment view, provided that you have installed Adobe Flash Player version 9 or later. You do not need to have an Office desktop application installed on your computer in order to view Office files in Confluence.

**File Types**

Confluence can display files compatible with Microsoft Office 97-2007, and PDF files, of the following types:

- `.doc` and `.docx`
- `.xls` and `.xlsx`
- `.ppt` and `.pptx`
- `.pdf`

Above are the prerequisites for viewing or displaying Office documents in Confluence. For a full list of Office Connector prerequisites and limitations, please refer to:

- Office Connector Prerequisites
- Office Connector Limitations and Known Issues

Displaying a Word Document in Confluence

**Usage with the Macro Browser (doc)**

To insert the Office Word macro into a page using the Macro Browser,

1. In the Confluence editor, choose `Insert > Other Macros`.
2. Find and select the required macro.

Once you have found the Office Word macro and have added the required parameter values, click 'insert' to add it to your page.

**Basic Usage with the Wiki Markup Editor (doc)**

```
{viewdoc:name=my document.doc}
```

**Parameters (doc)**

When editing, you can click on the macro placeholder and choose `Edit` to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Name (name)</td>
<td>yes</td>
<td>none</td>
<td>The file name of the Office Word document to be displayed. The document must be attached to a wiki page on your Confluence site.</td>
</tr>
</tbody>
</table>
Editing the Word Document

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence.

- Move your mouse pointer to the top of the document embedded in the Confluence page, until the hidden title bar appears. (See the screenshot below.)
- Click the title bar.
- Confirm your action and log in as prompted.
- The Office document will open in your Office application. Make any necessary changes, then save the document. It will be saved back into Confluence.

Screenshot: The title bar showing ‘document.doc’ above an embedded Office document

You will find detailed instructions in Editing an Office Document from Confluence.

Displaying a PowerPoint Presentation in Confluence

You can display a PowerPoint presentation on a Confluence page. By default, the presentation will be displayed as a dynamic slide show, using Adobe Flash Player. You can also choose to display just one of the slides as a static JPEG image.

Usage with the Macro Browser (ppt)

To insert the Office PowerPoint macro into a page using the Macro Browser,
1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

Once you have found the Office Powerpoint macro and have added the required parameter values, click '**Insert**' to add it to your page.

### Basic Usage with the Wiki Markup Editor (ppt)

```
{viewppt:name=my presentation.ppt}
```

### Parameters (ppt)

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **File Name**  
(name)          | yes       | none    | This file name of the PowerPoint presentation to be displayed. The document must be attached to a wiki page on your Confluence site. |
| **Height**  
(height)       | no        |         | Specify the height of the display, in pixels (default) or as a percentage of the window’s height. For example, to specify a height of 200 pixels: |
|              |           |         | `{viewppt:name=my presentation.ppt|height=200}` |
|              |           |         | This code also specifies a height of 200 pixels: |
|              |           |         | `{viewppt:name=my presentation.ppt|height=200px}` |
|              |           |         | This code specifies a height of 10 percent of the window’s height: |
|              |           |         | `{viewppt:name=my presentation.ppt|height=10%}` |
| **Page Name**  
(page)          | no        |         | Enter a page name, if you wish to display a document which is attached to another Confluence page. For example: |
|              |           |         | `{viewppt:name=my presentation.ppt|page=Sample Page}` |
| **Slide Number**  
(slide)         | no        | none    | Specify the number of the slide which you want displayed on the Confluence page, starting with '0' for the first slide. Instead of a slide show, the page will display just the single slide represented as a JPEG image. |
| Space Key (space) | no | The space of the page which contains the {viewppt} macro. | Enter a space key, if you wish to display a document which is attached to a page in another Confluence space. For example:

\{viewppt: name=my presentation.ppt | space=DOC | page=Sample Page\} |

| Width (width) | no | Specify the width of the display, in pixels (default) or as a percent the window’s width. For example, to specify a width and height of pixels: |

\{viewppt: name=my presentation.ppt | width=200 | height=200\} |

This code also specifies a width and height of 200 pixels:

\{viewppt: name=my presentation.ppt | width=200px | height=200px\} |

This code specifies a width of 10 percent of the window’s width:

\{viewppt: name=my presentation.ppt | width=10\%\} |

| Date (date) | no | none | If the Page Name refers to a blog post instead of a conventional enter the date of the post in the form mm/dd/yyyy. |

---

**Viewing the Slide Show and Editing the Presentation**

When you view the PowerPoint presentation on a Confluence page, options on the bottom frame of the slide show allow you to:

- ![Download](download_icon) — Download the presentation and save it onto your computer.

- ![Edit](edit_icon) — Edit the presentation in your Office application. You will find detailed instructions in Editing an Office Presentation from Confluence.

- ![Slide Navigation](navigation_icon) — Move to the first, previous, next and last slides in the presentation. Or enter a slide number to move directly to that slide.

- ![Refresh](refresh_icon) — Refresh the display.

- ![Full-screen](fullscreen_icon) — Open the presentation in full-screen mode. To return to normal viewing mode, press the escape key (’Esc’) on your keyboard.

*Screenshot: PowerPoint presentation embedded on a Confluence page*
**Displaying an Excel Spreadsheet in Confluence**

### Usage with the Macro Browser (xls)

To insert the Office Excel macro into a page using the Macro Browser,

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

Once you have found the Office Excel macro and have added the required parameter values, click 'insert' to add it to your page.

### Basic Usage with the Wiki Markup Editor (xls)

```
{viewxls:name=my_spreadsheet.xls}
```

### Parameters (xls)

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.
### Reducing the size of the spreadsheet

Use the **Last Column** and **Last Row** parameters to reduce the size of the spreadsheet displayed on the wiki page. This is especially useful to prevent the display from showing empty cells. This will also help to prevent 'out of memory' errors.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File Name</strong></td>
<td>yes</td>
<td>none</td>
<td>This is the file name of the document to be displayed. The document must be attached to a wiki page on your Confluence site.</td>
</tr>
<tr>
<td><strong>Last Column</strong></td>
<td>no</td>
<td>Last column with content</td>
<td>Enter the number of the last column you want displayed, starting from '0' as the first column. For example, the following code will show the first 3 rows and the first 3 columns:</td>
</tr>
<tr>
<td><strong>Show Grid?</strong></td>
<td>no</td>
<td>true</td>
<td>Select the check box in the macro browser (true in Wiki Markup) to show grid lines around each cell of the Excel spreadsheet. Clear the check box in the macro browser (false in Wiki Markup) to hide these grid lines.</td>
</tr>
<tr>
<td><strong>Page Name</strong></td>
<td>no</td>
<td>The page which contains the <strong>viewxls</strong> macro</td>
<td>Enter a page name, if you wish to display a document which is attached to another Confluence page. For example:</td>
</tr>
<tr>
<td><strong>Last Row</strong></td>
<td>no</td>
<td>Last row with content</td>
<td>Enter the number of the last row you want displayed, starting '0' as the first row. For example, the following code will show first 3 rows and the first 3 columns:</td>
</tr>
<tr>
<td><strong>Worksheet Name</strong></td>
<td>no</td>
<td>Last worksheet viewed in the spreadsheet</td>
<td>Enter the name of the worksheet that you want displayed.</td>
</tr>
<tr>
<td><strong>Space Key</strong></td>
<td>no</td>
<td>The space of the page which contains the <strong>viewxls</strong> macro</td>
<td>Enter a space key, if you wish to display a document which is attached to a page in another Confluence space. For example:</td>
</tr>
<tr>
<td><strong>Date</strong></td>
<td>no</td>
<td>none</td>
<td>If the Page Name refers to a blog post instead of a conventional page, enter the date of the post in the form mm/dd/yyyy.</td>
</tr>
</tbody>
</table>

### Editing the Excel Spreadsheet

...
When viewing a wiki page that displays an attached Office spreadsheet, you can launch your Office editor directly from Confluence.

- Move your mouse pointer to the top of the spreadsheet embedded in the Confluence page, until the hidden title bar appears. (See the screenshot below.)
- Click the title bar.
- Confirm your action and log in as prompted.
- The spreadsheet will open in your Office application. Make any necessary changes, then save the spreadsheet. It will be saved back into Confluence.

Screenshot: The title bar showing 'spreadsheet.xls' above an embedded Excel spreadsheet

---

**Displaying an Excel Spreadsheet**

<table>
<thead>
<tr>
<th>Task</th>
<th>Monday</th>
<th>Tuesday</th>
<th>Wednesday</th>
<th>Thursday</th>
<th>Friday</th>
<th>Saturday</th>
<th>Sunday</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design</td>
<td>5</td>
<td>6</td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Development</td>
<td>3</td>
<td>3</td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Testing</td>
<td>2</td>
<td>3</td>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Admin</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

You will find detailed instructions in Editing an Office Spreadsheet from Confluence.

**Displaying a PDF Document in Confluence**

**Usage with the Macro Browser (pdf)**

To insert the View PDF macro into a page using the Macro Browser,

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

Once you have found the View PDF macro and have added the required parameter values, click 'insert' to add it to your page.

**Basic Usage with the Wiki Markup Editor (pdf)**

```
{viewpdf:name=my document.pdf}
```

**Parameters (pdf)**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Name</td>
<td>yes</td>
<td>none</td>
<td>This is the file name of the document to be displayed. The document must be attached to a wiki page on your Confluence site.</td>
</tr>
</tbody>
</table>
The page which contains the \{viewpdf\} macro

Enter a page name, if you wish to display a document which is attached to another Confluence page. For example:

\{viewpdf:name=my document.pdf|page=Sample Page\}

The space of the page which contains the \{viewpdf\} macro

Enter a space key, if you wish to display a document which is attached to a page in another Confluence space. For example:

\{viewpdf:name=my document.pdf|space=DOC|page=Sample Page\}

If the Page Name refers to a blog post instead of a conventional page, enter the date of the post in the form mm/dd/yyyy.

Viewing the PDF Document

When you view the PDF document on a Confluence page, it is displayed as a slide show. Options on the bottom frame of the slide show allow you to:

- Download the PDF file and save it onto your computer.
- Move to the first, previous, next and last pages in the document. Or enter a page number to move directly to that page.
- Refresh the display.
- Open the document in full-screen mode. To return to normal viewing mode, press the escape key ('Esc') on your keyboard.

Screenshot: PDF document embedded on a Confluence page
Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Related Topics

- Working with the Office Connector
- Working with Macros

Take me back to the Confluence User's Guide.

Warning Macro

The Warning Macro allows you to highlight a warning note on a Confluence page.

It creates a red-coloured box surrounding your text as shown below.

Warning Macro Example

This text is rendered inside the warning macro.

On this page:

- Usage with the Macro Browser
- Usage with the Wiki Markup Editor
- Parameters

Usage with the Macro Browser

To insert the warning macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert -> Other Macros.
2. Find and select the required macro.

Once you’ve found the warning macro and have added the required parameter values, click 'insert' to add it to your page.

Usage with the Wiki Markup Editor
What you need to type | What you will get
---|---
{warning}Insert warning message here! {warning} | ![Insert warning message here!]

**Parameters**

When editing, you can click on the macro placeholder and choose **Edit** to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title ({title})</td>
<td>no</td>
<td>none</td>
<td>The title of the warning note. If specified, will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>Show Warning Icon ({icon})</td>
<td>no</td>
<td>true</td>
<td>If &quot;false&quot;, the icon will not be displayed.</td>
</tr>
</tbody>
</table>

**RELATED TOPICS**

Working with Macros

Take me back to the [Confluence User’s Guide](#).

**Web-Widget Macro**

The **Web-Widget** macro is just another name for the **Widget** macro.

Confluence supports `web-widget` as an alias for `widget`. Your **System Administrator** can enable or disable one or both these macro names. The alias is useful for Confluence sites which use Adaptavist’s Community Bubbles plugin, to avoid conflict with the ‘widget’ macro supplied by that plugin.

If the `web-widget` alias is enabled on your Confluence site, you can use `web-widget` instead of `widget` in all the examples given in the page about the **Widget** macro.

**RELATED TOPICS**

- [Widget Macro](#)
- [Working with Macros](#)

Take me back to [Confluence User’s Guide](#).

**Welcome Message macro**

The **Welcome Macro** allows you to include the Confluence site welcome message in your page.

The welcome message is configured by a **Confluence administrator** from the **Administration Console**.

> For more information about editing the Confluence site welcome message, please refer to [Editing the Site Welcome Message in the Confluence Administrators Guide](#).

On this page:

- Usage with the Wiki Markup Editor
  - Looking for the Atlassian product documentation?
  - About this Confluence wiki
- Parameters
- Related Topics

**Usage with the Wiki Markup Editor**
<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{welcome-message}</td>
<td></td>
</tr>
</tbody>
</table>

**Looking for the Atlassian product documentation?**

Quick links:

More:

- Latest JIRA documentation
- Latest Confluence documentation
- Atlassian documentation home page

**About this Confluence wiki**

Confluence is the enterprise wiki designed to make it easy for you and your team to share information with each other, and the world.

For information on Confluence please check out the feature tour, our competitive pricing, free 30-day evaluation.

Alternatively, experiment with our public Confluence Sandbox installation, home to Atlassian's popular Confluence Demonstration Space.

Atlassian produces agile development tools, including the bug tracker (JIRA), an agile project management tool (GreenHopper), a source code insight tool (FishEye), a code review tool (Crucible), and more.

---

**Parameters**

This macro accepts no parameters.

**Related Topics**

- Working with Macros

Take me back to the Confluence User's Guide.

**Widget Macro**

The Widget macro, or Widget Connector, allows you to embed multi-media content from other web sites into your Confluence page.

It supports content such as:

- Gadgets and other widgets: Google Gadgets, Widgetbox.
• Videos: YouTube, MySpace Video, Google Video, Yahoo Video, Dailymotion, Episodic, Vimeo, Metacafe, blip.tv, Viddler.
• Photos and images: Flickr, Skitch.com.
• Micro-blogging: Twitter, FriendFeed, BackType.
• Documents and presentations: SlideShare, SlideRocket, Scribd, presentations on Google Docs.
• Calendars: Google Calendar.
• Forms and online databases: Wufoo HTML Form Builder, Dabble DB.
• Support and customer satisfaction: Get Satisfaction.

On this page:

• Usage with the Macro Browser
• Usage with the Wiki Markup Editor
• Parameters
• Live Example of Flickr Photos
• Live Example of Google Gadget
• More Examples of Macro Code
• About the Web-Widget and Widget Macros
• Troubleshooting

Usage with the Macro Browser

To insert the Widget macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the Widget macro and have added the required parameter values, click 'insert' to add it to your page.

Usage with the Wiki Markup Editor

Just type the word 'widget' in curly brackets, and give it the URL (web address) of the thing you want to display.

{widget:url=http://example.com/my-location}

If the web-widget alias is enabled on your Confluence site, you can use web-widget instead of widget. See below.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web Sites Widget URL (url)</td>
<td>yes</td>
<td></td>
<td>This is the URL provided by the external web site for embedding content.</td>
</tr>
</tbody>
</table>
| **Pixel Height (Value Only)** (height) | no | Specify the height of the display, in pixels (default) or as a percentage of the window's height:

```
{widget:url=http://www.flickr.com/photos/tags/atlassian/|height=200}
```

This code also specifies a height of 200 pixels:

```
{widget:url=http://www.flickr.com/photos/tags/atlassian/|height=200px}
```

This code specifies a height of 10 percent of the window's height:

```
{widget:url=http://www.flickr.com/photos/tags/atlassian/|height=10%}
```

| **Pixel Width (Value Only)** (width) | no | Specify the width of the display, in pixels (default) or as a percentage of the window's width:

```
{widget:url=http://www.flickr.com/photos/tags/atlassian/|width=200|height=200}
```

This code also specifies a width and height of 200 pixels:

```
{widget:url=http://www.flickr.com/photos/tags/atlassian/|width=200px|height=200px}
```

This code specifies a width of 10 percent of the window's width:

```
{widget:url=http://www.flickr.com/photos/tags/atlassian/|width=10%}
```

---

**Live Example of Flickr Photos**

This example shows the Widget macro in action. It displays all photos from Flickr with the tag 'Atlassian'.

**What You Need to Type**

```
{widget:url=http://www.flickr.com/photos/tags/atlassian}
```

**What You Will Get**

**Live Example of Google Gadget**

This example shows the Widget macro in action. It lets you play with a Google Gadget, Gadzi's Monkey Virtual Pet.

**What You Need to Type**

```
```

**What You Will Get**

**More Examples of Macro Code**

---

**Google Gadgets**

You will need to find the URL for the Google Gadget you want to display.
Here is one way to find a gadget's URL:

1. Go to the Google Gadgets directory.
2. Find the gadget you want then click its name, such as ‘Spider’.
3. The gadget's summary page will open. Copy the URL from your browser's address bar. The URL looks something like this one:


4. Paste the URL into the Widget macro code on your Confluence page.

You can also use the URL of the ‘add gadget’ page. The page is called 'Add "gadgetx" to your iGoogle page':

1. There are a couple of ways to get to the ‘add gadget’ page:
   • Click a '+Google' button underneath the gadget when displayed on a page somewhere.
   • Or click 'Add Stuff' on your iGoogle page.
2. Copy the URL from your browser's address bar. The URL would look something like this one:

   http://www.google.com/ig/adde?synd=open&source=ggyp&moduleurl=abowman.googlepages.com/spider.xml

Here is an example of the Widget macro code for embedding a Google Gadget:

{widget:url=http://www.google.com/ig/adde?synd=open&source=ggyp&moduleurl=abowman.googlepages.com/spider.xml}

**Widgetbox widgets**

You will need to find the URL for the Widgetbox widget you want to display.

Here is one way to find a widget's URL:

1. Ensure you are logged in to Widgetbox and that you are viewing the Widgetbox Gallery.
2. Find the widget you want then click its name, such as 'cyber-pet'.
3. The widget's summary page will open. Within the Get Widget section, click the Atlassian Confluence icon. The Widgetbox Add to Confluence dialog box appears, containing the URL required for the Widget Macro.
4. If you cannot see this icon, click the more... link to reveal it.
5. In the Widgetbox Add to Confluence dialog box, click the Copy button.
6. Copy the URL from your browser's address bar. The URL looks something like this one:

   http://widgetbox.com/confluence/b8327e33-c8eb-4a38-b842-fba866ffdd

Here is an example of the Widget macro code for embedding a Widgetbox widget:

{widget:url=http://widgetbox.com/confluence/b8327e33-c8eb-4a38-b842-fba86}

**YouTube**

You will need to find the URL for the YouTube video that you want to display.

To find a YouTube video's URL:

1. Go to YouTube and search for the video you want.
2. Click the title of the video, such as 'Wikis in Plain English'.
3. The video's summary page will open. Copy the URL from your browser's address bar. The URL looks something like this one:

   http://au.youtube.com/watch?v=-dnL00TdmLY
4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a YouTube video:

```
{widget:url=http://au.youtube.com/watch?v=dnL00TdmLY}
```

**MySpace Videos**

You will need to find the URL for the MySpace video that you want to display.

To find a MySpace video's URL:

1. Go to MySpace Video and search for the video you want.
2. Click the title of the video, such as 'Glacier Creek Confluence Time Lapse'.
3. The video's summary page will open. Copy the URL from your browser's address bar. The URL looks something like this:
   ```
   http://vids.myspace.com/index.cfm?fuseaction=vids.individual&videoid=3376248&searchid=20c789f6-1ae9-459a-bfec-75efcfc2847c
   ```
4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a MySpace video:

```
{widget:url=http://vids.myspace.com/index.cfm?fuseaction=vids.individual&videoid=3376248&searchid=20c789f6-1ae9-459a-bfec-75efcfc2847c}
```

**Google Video**

You will need to find the URL for the Google video that you want to display.

To find a Google video's URL:

1. Go to Google Video and search for the video you want.
2. Click the title of the video, such as 'An Evening With Wiki Inventor Ward Cunningham in Conversation'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:
   ```
   http://video.google.com/videoplay?docid=-7739076742312910146&ei=nJAfSbrzPIWOwgOhv_GKDA&q=An+Evening+With+Wiki+Inventor+Ward+Cunningham+in+Conversation&emb=1
   ```
4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Google video:

```
{widget:url=http://video.google.com/videoplay?docid=-7739076742312910146&ei=nJAfSbrzPIWOwgOhv_GKDA&q=An+Evening+With+Wiki+Inventor+Ward+Cunningham+in+Conversation&emb=1}
```

**Yahoo Video**

You will need to find the URL for the Yahoo video that you want to display.

To find a Yahoo video's URL:

1. Go to Yahoo Video and search for the video you want.
2. Click the title of the video, such as 'Wiki Technology Trend: Past, Now and Future'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:
   ```
   http://video.yahoo.com/watch/423158/2424140
   ```
4. Paste the URL into the Widget macro code on your Confluence page.

   If you are unable to obtain a unique URL from your browser's address bar, click the envelope (Share) icon on the lower section of the video screen and copy the contents of the Link field.
Here is an example of the Widget macro code for embedding a Yahoo video:

```{widget:url=http://video.yahoo.com/watch/423158/2424140}
```

**Dailymotion Video**

You will need to find the URL for the Dailymotion video that you want to display.

To find a Dailymotion video's URL:

1. Go to [Dailymotion](https://www.dailymotion.com/) and search for the video you want.
2. Click the title of the video, such as 'Wiki Technology Trend: Past, Now and Future'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:

   ```http://www.dailymotion.com/user/spacevidcast/video/x7zevj_spacevidcast-2009-promo-video_tech```

   If you are unable to obtain a unique URL from your browser's address bar, click **Menu** at the lower right section of the video screen, select **URL & Embed Code** and copy the contents of the **Link** field.

4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Dailymotion video:

```{widget:http://www.dailymotion.com/user/spacevidcast/video/x7zevj_spacevidcast-2009-promo-video_tech}
```

**Episodic**

You will need an [Episodic](https://app.episodic.com/) user account if you want to create and distribute videos via Episodic.

To embed an Episodic video onto a Confluence page:

1. Find the video and copy the URL from the address bar of your browser. The URL looks something like this:

   ```http://app.episodic.com/shows/13/episodes/493```

2. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding an Episodic video:

```{widget:url=http://app.episodic.com/shows/13/episodes/493}
```

**Vimeo**

You will need to find the URL for the Vimeo video that you want to display.

To find a Vimeo video's URL:

1. Go to [Vimeo](https://www.vimeo.com/) and search for the video you want.
2. Click the title of the video, such as 'The Wiki Show - Allison the Russian High Kicker'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:

   ```http://www.vimeo.com/909808```

4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Vimeo video:

```{widget:url=http://www.vimeo.com/909808}
```
Metacafe

You will need to find the URL for the Metacafe video that you want to display.

To find a Metacafe video's URL:

1. Go to Metacafe and search for the video you want.
2. Click the title of the video, such as 'Wikis In Plain English (How To)'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.metacafe.com/watch/679493/wikis_in_plain_english_how_to/

4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Metacafe video:

   {widget:url=http://www.metacafe.com/watch/679493/wikis_in_plain_english_how_to/}

blip.tv

You will need to find the URL for the blip.tv video that you want to display.

To find a blip.tv video's URL:

1. Go to blip.tv and search for the video you want.
2. Click the title of the video, such as 'River cruising on the Rhine'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://blip.tv/file/996864/

4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a blip.tv video:

   {widget:url=http://blip.tv/file/996864/}

Viddler

You will need to find the URL for the Viddler video that you want to display.

To find a Viddler video's URL:

1. Go to Viddler and search for the video you want.
2. Click the title of the video, such as 'Gliffy Diagramm in Conflu...'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.viddler.com/explore/Markus_Z/videos/1/

4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Viddler video:

   {widget:url=http://www.viddler.com/explore/Markus_Z/videos/1/}
Flickr

You can embed a slide show of photos from Flickr by supplying a URL that specifies one of the following:

- Photos with a specific tag.
- Photos belonging to the photostream of a specific Flickr user.
- A set of photos as defined by the Flickr user.
- A user's photostream starting at a specific photo.

If you want to do something else, we suggest that you try any Flickr URL. It should work.

Below are some examples of the Widget macro code for embedding Flickr images.

Flickr Photos with a Specific Tag

This example displays a slide show of Flickr photos that are tagged with the word 'Atlassian'.

{widget:url=http://www.flickr.com/photos/tags/atlassian/}

Flickr Photos from a Specific User

This example displays a slide show of photos from the Flickr photostream of user 'Atlassian'.

{widget:url=http://www.flickr.com/photos/atlassian/}

Flickr Photos from a Specific Set

This example displays a slide show of Flickr photos from the set 'Melbourne Cup - November 2008' created by user 'Atlassian'.

{widget:url=http://www.flickr.com/photos/atlassian/set/72157608657271078}

A Specific Flickr Photo

This example displays a slide show of photos from the Flickr photostream of the user 'Atlassian', starting with a specific photo.

{widget:url=http://www.flickr.com/photos/atlassian/3003538919/}

Skitch.com

You will need to find the URL for the Skitch image that you want to display.

To embed a Skitch image onto a Confluence page:

2. Find the image and copy the URL from the address bar of your browser. The URL looks something like this:

   http://skitch.com/atlassian/411g/example-image

3. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Skitch image:

{widget:url=http://skitch.com/atlassian/411g/example-image}

Twitter

Use a Twitter link in the Widget macro to display a dynamic list of the latest tweets sent by a user or
matching a Twitter search.

To display the latest messages from a Twitter user, add the user's Twitter link as a URL in the Widget macro.

```
{widget:url=http://twitter.com/username}
```

The example below will display Mike Cannon-Brooke's Twitter messages:

```
{widget:url=http://twitter.com/mcannonbrookes}
```

To display the latest messages resulting from a Twitter search, add the Twitter search link as a URL in the Widget macro.

- Make sure you use the supported format of the search URL:

```
http://search.twitter.com/search?q=my search term
```

The following format is not supported:

```
http://twitter.com/#search?q=my search term
```

- The '#' tag is not supported (not even in its URL-encoded form `%23`).

Format:

```
{widget:url=http://search.twitter.com/search?q=my search term}
```

The example below will display the most recent tweets containing the word 'AtlassianDragons':

```
{widget:url=http://search.twitter.com/search?q=AtlassianDragons}
```

**FriendFeed**

To display the latest messages from a FriendFeed user, add the user's FriendFeed link as a URL in the Widget macro. For example:

```
{widget:url=http://friendfeed.com/mynname}
```

**BackType**

To display the latest blog or website comments from a BackType user, add the user's BackType widget link as a URL in the Widget macro. For example:

```
{widget:url=http://www.backtype.com/myname}
```

**SlideShare**

You will need to find the URL for the SlideShare presentation that you want to display.

To find a SlideShare presentation's URL:

1. Go to SlideShare and search for the presentation you want.
2. Click the title of the presentation, such as 'Using JIRA & Greenhopper for Agile Development'.
3. The presentation’s summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

http://www.slideshare.net/jleyser/using-jira-greenhopper-for-agile-development

4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a SlideShare presentation:

{widget:url=http://www.slideshare.net/jleyser/using-jira-greenhopper-for-agile-development}

**SlideRocket**

You will need to find the URL for the SlideRocket presentation that you want to display.

To find a SlideRocket presentation’s URL:

1. Log in to SlideRocket and go to your library of presentations.
2. Copy the ‘web link’ for the presentation you want to display. This will give you a URL that looks something like this one:

http://app.sliderocket.com/app/FullPlayer.aspx?id=132f9db7-b0fb-4f51-b974-36652774971b

3. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a SlideRocket presentation:

{widget:url=http://app.sliderocket.com/app/FullPlayer.aspx?id=132f9db7-b0fb-4f51-b974-36652774971b}

**Scribd**

You will need to find the URL for the Scribd presentation that you want to display.

To find a Scribd presentation’s URL:

1. Go to Scribd and search for the presentation you want.
2. Click the title of the presentation, such as 'My Sea Friends Coloring Book'.
3. The presentation’s summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:


4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Scribd presentation and displaying it with a height of 600 pixels:


**Google Docs Presentations**

You can embed presentations from Google Docs, but not other document types. You will need to find the URL for the Google Docs presentation that you want to display.

To find the URL of a Google Docs presentation:

1. Publish your presentation in Google Docs.
2. View your published document, then copy the URL from your browser’s address bar. The URL will look something like this:
3. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Google Docs presentation:

```
{widget:url=http://docs.google.com/Presentation?docid=ddpqn8g5_0fx96zmmq&mm=en_GB}
```

### Google Calendar

You can embed a Google Calendar into your page and to do this, you will need to add the URL for the Google Calendar that you want to display.

To find the URL for a Google Calendar:

1. Log in to Google Calendar.
2. In the calendar list on the left side of the page, ensure the appropriate calendar is selected, click the down-arrow button next to the calendar name and then select the Calendar settings option. (Alternatively, if available, click the Manage Calendars link at the bottom of the calendar list and then click the name of the appropriate calendar.)
3. In the Calendar Address section, click the HTML button. A pop-up message with your calendar's public URL appears.
4. Copy the URL from this pop-up message. The URL looks something like this:

```
http://www.google.com/calendar/embed?src=somebody%40example.com&ctz=Australia/Sydney
```

5. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Google Calendar:

```
{widget:url=http://www.google.com/calendar/embed?src=somebody%40example.com&ctz=Australia/Sydney}
```

### Wufoo HTML Form Builder

To display an HTML form built in the Wufoo HTML Form Builder, add the form's link as a URL to the Widget Macro. For example:

```
{widget:url=http://examples.wufoo.com/forms/contact-form/}
```

### Dabble DB online database builder

To display a shared page built in Dabble DB, add the page's link as a URL to the Widget Macro. For example:

```
{widget:url=https://confluence-sample.dabbledb.com/page/confluence-sample/nSQqdgIg}
```

The Widget Macro supports shared Dabble DB view and form pages. You can insert a Dabble DB data entry form into a Confluence page. On the same page or another page, you can use a a Dabble DB view to display data submitted via the form.

### Get Satisfaction social support application

To display a feedback form for a Get Satisfaction community, add the community or company link as a URL to the Widget Macro. For example:
About the Web-Widget and Widget Macros

Confluence supports web-widget as an alias for widget. Your System Administrator can enable or disable one or both these macro names. The alias is useful for Confluence sites which use Adaptavist’s Community Bubbles plugin, to avoid conflict with the ‘widget’ macro supplied by that plugin.

If the web-widget alias is enabled on your Confluence site, you can use web-widget instead of widget in all the examples above.

Troubleshooting

If the URL given in the Widget macro does not work, the Widget macro displays an icon and the base URL. The icon will be linked to the full URL given in the macro code.

For example, the following code:

```
{widget:url=http://example.com/invalid}
```

will result in an image like the one below:

![example.com](http://example.com/invalid)

**RELATED TOPICS**

- Working with Macros

Take me back to the Confluence User’s Guide.

Widget Connector Examples

This page contains a working example of some services currently supported by the Widget Connector. This page lets you preview what each widget will look like and see how to interact with it.

- Flickr
- Google Video
- Google Docs
- YouTube
- MySpace
- Episodic
- Vimeo
- BlipTV
- Viddler
- Skitch
- Twitter
- FriendFeed
- SlideShare
- SlideRocket
- Scribd
- Wufoo
- Error Message
- Related Content

**Flickr**

```
{widget:url=http://www.flickr.com/photos/tags/atlassian}
```
Google Video

{widget:url=http://video.google.com/videoplay?docid=-7739076742312910146&ei=nJAfSbrzPIWOwgOhv_GKDA&q=An+Evening+With+Wiki+Inventor+Ward+Cunningham+in+Conversation&emb=1}

Google Docs

{widget:url=https://docs.google.com/present/view?id=dgjvr7tq_243fjgwvfx}

YouTube

{widget:url=http://au.youtube.com/watch?v=-dnL00TdmLY}

MySpace

{widget:url=http://vids.myspace.com/index.cfm?fuseaction=vids.individual&}

Episodic

{widget:url=http://app.episodic.com/shows/13/episodes/493}

Vimeo

{widget:url=http://www.vimeo.com/909808}
**BlipTV**

{widget:url=http://blip.tv/file/996864/}

**Viddler**

{widget:url=http://www.viddler.com/explore/Markus_Z/videos/1/}

**Skitch**

{widget:url=http://skitch.com/jnolen/bbybm/skitch.com-jnolen}

**Twitter**

{widget:url=http://twitter.com/mcannonbrookes}

{widget:url=http://search.twitter.com/search?q=AtlassianDragons}

**FriendFeed**

{widget:url=http://friendfeed.com/myname}

**SlideShare**

{widget:url=http://www.slideshare.net/jleyser/using-jira-greenhopper-for-}

**SlideRocket**

{widget:url=http://app.sliderocket.com/app/FullPlayer.aspx?id=132f9db7-b6}

**Scribd**

**Wufoo**

{panel:borderColor=#CCCCCC|bgColor=#FFFFFF}
{widget:url=http://atlassian.wufoo.com/forms/let-us-know-what-you-think-of-the-new-sdk/|height=800px} {panel}

**Error Message**

{widget:url=http://example.com/invalid}

**Related Content**

- Working with Macros

**Guides to Specific Uses of Confluence**

This section of the Confluence user's guide contains a number of targeted guides showing you how to use Confluence for a specific purpose. Each guide:

- Shows you how to set up a Confluence space to suit your purpose.
- Gives an overview of the Confluence functionality that you will find most useful in that particular usage of the wiki.
- Mentions plugins that you may find useful to extend Confluence's core functionality.

**Contents**

- Developing Technical Documentation on Confluence Wiki
- Developing a Knowledge Base on Confluence Wiki
- Developing an Intranet on Confluence Wiki

**Developing Technical Documentation on Confluence Wiki**

Welcome! This is a guide to using Confluence wiki for technical documentation. You will find this guide useful if you want to write a technical manual such as a user's guide, administrator's guide, installation guide, and so on.

- Creating your Technical Documentation Space
- Using Templates in Technical Documentation
- Re-using Content in Technical Documentation
- Managing the Life Cycle of your Technical Documentation
- Providing PDF Versions of your Technical Documentation
- Exporting and Printing Technical Documentation
- Essential Confluence Features for Technical Documentation
- Confluence Plugins for Technical Documentation
- Further Reading about Developing Technical Documentation on Confluence

**Creating your Technical Documentation Space**

This guide is for people who want to develop and publish technical documentation on Confluence wiki. You will find it useful if you want to write a technical manual such as a user's guide, administrator's guide, installation guide, and so on. This page is a quick-start guide to creating a wiki space for technical documentation.
Quick guide to creating a technical documentation space

- Add a space and select the Documentation theme.
- Set the space permissions.
- Change the title and content of the space home page.
- Customise the Documentation theme.
- Create an inclusions library to manage your re-usable content.
- Create the table of contents for your manual or manuals, by adding top-level pages for all the usual sections (user's guide, administrator's guide, and so on).
- Customise your PDF layout and stylesheet, if required.
- **Hint:** Now that you have a good skeleton for a documentation space, save the space as a template space.

The rest of this page gives more details of the above procedure.

### On this page:
- Step 1. Add your Space
- Step 2. Set the Space Permissions
  - A Bit More about Permissions
- Step 3. Customise the Title and Content of the Home Page
- Step 4. Customise the Documentation Theme
  - Example of a Customised Footer
- Step 5. Create an Inclusions Library
  - Examples of Inclusions Libraries
- Step 6. Create the Table of Contents
- Step 7. (Optional) Customise the PDF Layout and Stylesheet
- Step 8. Save your New Space as a Template Space

### Step 1. Add your Space

Below is a quick guide to adding a space. See Setting up a New Global Space for a full description.

1. Go to the Confluence dashboard and click the 'Add Space' link located above the list of spaces.

   ![Add Space](image)

   **Add Space**

   ![Feed Builder](image)

   **Feed Builder**

   ![People Directory](image)

   **People Directory**

   **Spaces:** Favourite | New (1) | Global

   ![Demonstration Space](image)

   An example of a Confluence space with a tutorial and sample content.

   **Hint:** If you cannot see the 'Add Space' link, this means that you do not have permission to add spaces. Please contact your Confluence administrator.

2. The 'Create Space' screen appears. Enter a **space name** and a short, **unique space key**.

3. Leave the **permission** settings as default, or choose to allow only yourself to view or contribute content to this space. You can change these settings later and with more flexible options.

4. Select the 'Documentation Theme'.

5. Click 'OK'.

The home page of your new space will appear. Because you created the space, you are the space administrator. Now you can do some basic configuration, as described in the sections below.

### Step 2. Set the Space Permissions

Define the space permissions to determine who can do what in your new space.
1. Open the 'Browse' menu and select 'Space Admin'.

2. Click 'Permissions' in the left-hand panel.
3. Confirm your administrator access as prompted.
4. Click 'Edit Permissions'.
5. Set the permissions to suit your needs then click 'Save All'.
   - You can add groups and/or individual users to the list, then select the permissions for each group or user.
   - You can also set the permissions for anonymous users – these are people who have not logged in to the wiki. Anonymous access is available only if enabled for the entire Confluence site.
   - Note that you can change these permissions at any time. You may want to restrict the permissions to specific groups now, and later open the space to more people.

A Bit More about Permissions

Confluence has a robust and granular permissions scheme that you can use to determine who can view, comment on and even update the documentation. There are three levels of permissions in Confluence:

- Global permissions apply across the entire site.
- Space permissions apply to a space.
- Page restrictions allow you to restrict the editing and/or viewing of a specific page. Below we discuss a way of using these in the draft, review and publishing workflow.

**Space permissions** in Confluence are simple yet granular enough to be useful for technical documentation. You can:

- Use the permission levels to control who can create pages in the space, delete pages, create comments, delete comments, administer the space, and so on.
- Grant a permission level to one or more users, and/or to one or more groups, and/or to anonymous users.

Terminology:

- 'Anonymous' means people who have not logged in to the wiki.
- The ‘confluence-users’ group is the default group into which all new users are assigned. Everyone who can log in to Confluence is a member of this group.

For example, you might allow your team full edit and administration rights while others can only add comments. Or you might grant the general public access to your documentation, while only staff members can update it.
For detailed information, see the documentation on:

- Global permissions
- Space permissions
- Page restrictions
- Users and groups

**Step 3. Customise the Title and Content of the Home Page**

When you created your space, Confluence created a home page with default content and a default title, 'Home'. You will want to change the title and content.
1. Go back to your space home page, by clicking the space name in the breadcrumbs at the top of the screen. In the example below, the space name is 'MyProduct Documentation':

   ![](image1.png)

   The space home page appears. By default, the page title is 'Home'.

   ![](image2.png)

2. Click 'Edit'.
3. The page opens in edit mode. Change the title to suit your needs.

   ![](image3.png)

4. Update the content to suit your needs.
   
   Hint: If you do not know what to add yet, just add a short description. You can refine the content of the page later. Take a look at an example of a home page.

5. Click 'Save'.

**Step 4. Customise the Documentation Theme**

When you added the space you chose the Documentation theme, which provides a left-hand navigation bar and a good look and feel for technical documentation. If necessary, you can configure the Documentation theme to add your own page header and footer or to customise the default left-hand navigation bar. These customisations affect the online look and feel of your documentation. See Configuring the Documentation Theme for the full description.
1. Open the 'Browse' menu and select 'Space Admin'.
2. Click 'Themes' in the left-hand panel.
3. If the space is not yet using the Documentation theme, apply the theme now.
4. Click 'Configure theme' in the yellow area of the 'Current Theme' section at the top of the page.

5. The 'Documentation Theme Configuration' screen appears. Customise the left-hand navigation bar, header and footer to suit your needs. Details are in the documentation. Here are some hints:
   - The 'Page Tree' check box determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.
   - The 'Limit search results to the current space' check box determines whether Confluence will search only the current space or the whole Confluence site. This setting affects the default search. Viewers can override it each time they do a search.
   - Enter text, images, macros and other wiki markup into any or all of the three text boxes for the the left-hand navigation bar, header and footer. You can use the Include macro and the Excerpt Include macro to include re-usable content.
   - Any content you add to the navigation panel will appear above the default page tree.
   - If you like, you can remove the default page tree (by unticking the box) and add your own, customised version of the Pagetree macro instead.

6. Click 'Save'.

**Example of a Customised Footer**

Take a look at the footer of a page in the Crowd documentation space.

To produce the above footer, we have the following content in the footer panel in the Documentation theme configuration screen:

```
Footer: {include::Documentation Footer[nopanel=true]}
{include::ALLDOC::Copyright Notice[nopanel=true]}
```

Here it is in text form:
The above content consists of two Include macros.

- The first macro includes a page called _Documentation Footer. This page contains the big blue buttons and hyperlinked text.
- The second macro includes a page from a different space, the ALLDOC space, called _Copyright Notice. This page includes our standard copyright notice, used in all our documentation spaces.

**Step 5. Create an Inclusions Library**

Using Confluence, you can dynamically include content from one page into another page. You can include a whole page into another one, using the **Include** macro. You can also define an ‘excerpt’ on a page, and then include that excerpted text into another page using the **Excerpt Include** macro.

To organise your re-usable content, we recommend that you create a set of pages called an ‘inclusions library’.

1. Open the ‘Browse’ menu and select ‘Pages’.
   This will add a page at the root of the space, at the same level as the home page.
3. Enter a suitable title. We use ‘_InclusionsLibrary’. The unusual format of the title helps to let people know this page is special.
4. Enter some content on the page. We enter text explaining the purpose of the inclusions library and how to re-use the content. You can copy our text by clicking through to one of the example pages listed below.

5. Add child pages containing your re-usable content. See the examples of our own inclusions libraries listed below.

Some notes about inclusions libraries:

- The inclusions library is not a specific feature of Confluence. The pages in the inclusions library are just like any other Confluence page.
- The pages are located at the root of the wiki space, not under the home page. This means that they will not appear in the table of contents on the left and they will not be picked up by the search in the left-hand navigation bar either.
- The pages will be picked up by other searches, because they are just normal wiki pages.
- We have decided to start the page name with an underscore. For example, ‘_My Page Name’. This indicates that the page is slightly unusual, and will help prevent people from changing the page name or updating the content without realising that the content is re-used in various pages.

**Examples of Inclusions Libraries**

Here are some examples in our documentation:

- Crowd inclusions library
- Confluence inclusions library

**Step 6. Create the Table of Contents**

Create the table of contents for your documentation, by adding the top-level pages for all the usual sections:
1. Go back to your space home page, by clicking the space name in the breadcrumbs at the top of the screen.
2. Open the ‘Add’ menu and select ‘Page’. This will add the page as a child of the home page.
4. Enter the content of the page.
   Hint: If you do not know what to add yet, just add a short description then refine the content of the page later. If you like, you can add the Children macro. That will act as a table of contents on the page once you have added child pages.
5. Click ‘Save’.

Now do the same for all the sections of your technical document.

**Step 7. (Optional) Customise the PDF Layout and Stylesheet**

If you are planning to provide PDF versions of your documentation, you may want to customise the PDF layout and styles for your space. You can skip this step for now and do it later, if you prefer. The instructions are in a separate section of this guide, dedicated to PDF. See [Providing PDF Versions of your Technical Documentation](#).

**Step 8. Save your New Space as a Template Space**

This is a useful suggestion. Once you have set up your first documentation space and are more-or-less happy with it, use the Copy Space plugin (see notes below) to copy the space while it still has very little content. From this point on, you can copy it each time you want to create a new documentation space.
1. Open the 'Browse' menu and select 'Space Admin'.
2. Click 'Copy Space' in the left-hand panel.

Hint: If you cannot see the 'Copy Space' option, this means that the plugin is not installed on your Confluence site. Refer to the documentation on installing plugins.
3. The 'Copy Space' screen will appear. Enter the details as prompted, to copy your space to another new space.

4. Click 'Save'.

You now have a template space. From this point on, you can use the Copy Space plugin to copy the template space each time you want to create a new documentation space.

Notes:

- The Copy Space plugin is not covered by Atlassian support. However, the Atlassian technical writers use it for all our documentation. If you like, you can vote for an comment on the request for Atlassian support to cover this plugin: CONF-14198.
- Your site administrator will need to install the Copy Space plugin into Confluence. Refer to the documentation on installing plugins.

Next Steps

You now have the basic structure and configuration for your technical documentation space. You have also created a handy template to use next time you need a space. What next? Take a look at Using Templates in Technical Documentation.

Using Templates in Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. We have already shown you how to create your technical documentation space. Now we offer an introduction to the templates that Confluence provides.
Quick guide to templates in Confluence

- A template is a page with predefined content that can be used as a prototype when creating other pages.
- Templates are available across the Confluence site (global templates) or per space (space templates).
- Both 'global templates' and 'space templates', as described on this page, define the content of a page. They do not define the content of an entire space.
- You can import predefined templates, including those shipped with Confluence and additional templates from the Atlassian Plugin Exchange.
- To create a template for an entire space, see our guide to creating your documentation space.

On this page:

- Deciding Where to Put Your Templates
- Creating a Global Template
- Creating a Space Template
- Importing Templates
- Using a Template to Create a Page

Deciding Where to Put Your Templates

In Confluence, there are two places to store your templates:

- **Global templates**: These are defined by site administrators through the Administration Console and are available in every space.
- **Space templates**: These are defined by space administrators on the space administration screens, and are only available in the space in which they are defined.

Decide whether your template is useful across more than one space.

- If yes, create a global template. You will need Confluence administrator permissions.
- If no, create a space template.
  - You will need space administrator permissions for the relevant space(s).
  - You may have already saved your documentation space as a template, as described in our guide to creating your documentation space. In that case, it may be useful to save your template page in your template space. When you later copy the space, the template pages will be copied too.

Creating a Global Template

1. Choose Browse > Confluence Admin.
2. Enter your password and click Confirm. You will be temporarily logged into a secure session to access the 'Administration Console'.
3. Select Global Templates in the left-hand panel.
4. Click Add New Global Template.

See Global Templates for more information.

Creating a Space Template

1. From any page in the space, choose Browse > Advanced.
2. Click Templates in the left-hand panel.
3. Click Add New Space Template.

See Adding a Template for more information.

Importing Templates

Confluence ships with a number of templates, including the 'Charts', 'Document List' and 'Meeting Notes' templates. These templates are not available for use by default. However, if you have the appropriate permissions to access the Administration Console, you can import any of these templates to be used globally or within a specific space. In addition, you can find more template bundles on the Atlassian Plugin Exchange.

1. Go to the 'Confluence Administration Console' and click Import Templates.
2. Select the templates that you want to import.
3. Choose which space to import the templates to, or whether to import them as global templates.
4. Click Import.

Using a Template to Create a Page
When people add a page on your Confluence site, they can choose to base their new page on a template.

Next Steps

You now have a good idea of how Confluence templates work. What next? Take a look at Re-using Content in Technical Documentation.

Re-using Content in Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. In the page about creating your technical documentation space, we showed you how to set up an 'inclusions library' to contain content that you can re-use on more than one page. Now we offer further guidelines on re-using content in your documentation space.

Your documentation may be about using a software application, or it may be a technical manual for your product range. On this page, we use the term 'widget' to describe the things that you are documenting, such as the screen, form, document, product or object.

Quick guide to re-using content

- Create an ‘inclusions library’ to manage your re-usable content. See our guide to creating your technical documentation space.
- Use the excerpt macro to define a re-usable section ('excerpt') on a page, or just decide to re-use the entire content of the page.
- Use the excerpt-include macro to include the excerpt from one page onto another page.
- Use the include macro to include the entire content of a page onto another page.
- Consider installing the Multi Excerpt plugin if you need to define multiple excerpts per page.

The rest of this page gives an overview and more details of the above procedures.

Reasons for Re-Using Content

A golden rule for technical documentation is to write the content only once but allow that content to be used in many places and in many forms.

For example, you may have the following types of content:

- A technical manual that describes each widget in detail.
- Tips and tricks on how to get the most out of the widget.
A step-by-step user guide for first-time users on how to use the most common widgets.
A training manual with exercises or videos that people can follow in their own time.
A one-page cheat sheet for users to stick up on their workstation.
Text for a sales brochure that is sent out to a print house for production.

Each of these types of content will share common information, such as a glossary entry, a technical or marketing description of the widget, or a step-by-step guide on how to use the widget.

Some initial planning of your technical documentation will allow you to re-use any or all of the content you write, so there is only ever one place to update the content, and those changes flow through to all of your other documentation.

Defining an Inclusions Library

We recommend that you create an 'inclusions library' to manage your re-usable content. If you have not already done this when creating your documentation space, see our guide to creating your technical documentation space.

Working with Excerpts and Inclusions

Excerpts and inclusions (sometimes called 'includes') are very useful for re-using content:

- Use the Excerpt macro (`excerpt`) to define a re-usable section ('excerpt') on a page.
- Use the Excerpt Include macro (`excerpt-include`) to include the excerpt on another page.
- Use the Include Page macro (`include`) to include the entire content of a page onto another page.

A simple example of an inclusion is a note or warning that is used in many places in your documentation. Here is an example:

```
⚠️ Example note -- "Draft in progress"

This document is still in draft status. Please treat the content with caution.
```

Tip: Keep your re-usable pages short and sweet. Do not worry if you find that you need hundreds of pages to hold your inclusions. It helps to keep things separate and organised.

Using the Include Page Macro

In this example, we use the Include Page macro to create a note that you can re-use on your documentation pages. The Include Page macro will include the entire content of one page into another page. (See the 'Excerpt' macro below for including parts of a page.)

```
1. Create a page in your inclusions library called _Draft Note_.
2. Add the content of the page. In this example, we use the Note macro with some text in the title and body:
   `{{note:title=Draft in progress}This document is still in draft status. Please treat the content with caution.}{note}}`
3. Use the Include Page macro to include that note in any page in your documentation. For example:
   `{{include:_Draft Note|nopanel=true}}`
```

See the documentation on the Include Page macro for more details.

Using the Excerpt Include Macro

An excerpt is a section of a page that you can include into another page.
1. Use the **excerpt** macro to define any content in your page that you want to be able to use elsewhere. This content can be as short as a word or as long as the entire page. For example, let's assume we have a page called 'My Short Poem':

```
I really love this poem:
{excerpt}
Mary had a little lamb
Its fleece was white as snow
{excerpt}
And I'm going to use it all over the place.
```

2. Use the **Excerpt Include** macro to include the excerpt into another page. For example:

```
{excerpt-include:My Short Poem|nopanel=true}
```

You can only define one **excerpt** on a page. See the documentation on the **Excerpt Include** macro for more details.

To have multiple excerpts on a page, see the '**Multi Excerpt plugin**' below.

**Using the Multi Excerpt Plugin**

The Multi Excerpt plugin provides additional macros that enable you to have multiple excerpts on a page. A good example of where you would find this useful is in the glossary page discussed below. If you want to include a single glossary entry or a subset of the glossary entries in another page, then the named excerpts allowed by the Multi Excerpt plugin are very useful.

**Notes:**

- The **Multi Excerpt plugin** is a commercial plugin and is not free.
- Your Confluence administrator will need to download and install the plugin into your Confluence site before you can use the macros described below. Refer to the documentation on **installing plugins**.
- Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on **plugin support**. Please refer to the **Multi Excerpt plugin page** for support details.

1. Use the following code on the base page containing the content you want to use elsewhere:

```
{multi-excerpt:name=ExcerptName1}
Excerpt text 1
{multi-excerpt}
Any other text
{multi-excerpt:name=ExcerptName2}
Excerpt text 2
{multi-excerpt}
```

2. Use the following code on the page where you want to include the named excerpt:

```
{multi-excerpt-include:pageTitle=PageName|name=ExcerptName1|nopanel=true}
```

3. You can also include excerpts from other spaces using the following syntax:

```
{multi-excerpt-include:spaceKey:pageName|name=excerptName|nopanel=true}
```

See the **Multi Excerpt plugin page** for more details.

**An Example of Content Re-Use: A Glossary**

A glossary is something that most technical documentation will require. There are a few ways to set up glossaries in Confluence. These are the most popular:

- All glossary entries on one page.
- Each glossary entry on separate child pages with a main page showing excerpts of the glossary.
Once you have defined the glossary entry, you can refer to it from the main pages of your technical documentation.

Creating a One-Page Glossary

This style of glossary is useful if the glossary entries tend to be short and there are not too many of them.

1. Create a page named **Glossary**.
2. Add an alphabetical index at the top of the page and a heading for each letter of the alphabet:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="" alt="A" /></td>
<td><img src="" alt="B" /></td>
<td><img src="" alt="C" /></td>
</tr>
</tbody>
</table>

   h2. A
   h2. B
   h2. C ...

3. Enter each glossary entry under the relevant alphabetical heading. Each glossary entry (term) should include:
   - An anchor tag, so that you can link to it from other pages.
   - The term itself.
   - A definition of the term.
   - A link to the page in your technical documentation that explains the term in greater detail, where relevant.

   ![anchor:MyGlossaryTerm]
   h4. MyGlossaryTerm
   This is the definition of MyGlossaryTerm. See [Page Name] for more information.

4. Optionally, include a horizontal line between the terms. This depends on how long each entry is. If your glossary tends to have short entries, it may look too cluttered with horizontal lines.

---

See the glossary in the Confluence documentation for an example of this style of glossary (without the alphabetical index).

Creating a Glossary with Child Pages

This style of glossary is useful if the glossary entries tend to be quite long or have additional information over and above the definition of the term.

1. Create a page named **Glossary**.
2. Create a child page for each glossary entry (term). Each child page should contain:
   - The term as the title of the page.
   - The definition of the term in the body of the page.
   - Excerpt tags (excerpts) tags surrounding the definition.
   - Any additional information after the excerpt tags.

   ![excerpt]
   This is the definition of MyGlossaryTerm
   ![excerpt]
   More information to describe MyGlossaryTerm

3. On the 'Glossary' page, use the children macro to show the excerpts from each child page in a list, with the page name displayed in 'h4' style.

   ![children:excerpt-true|style-h4]

See the glossary in the Crowd documentation for an example of this style of glossary.
Referring to Glossary Terms

In the main pages of your technical documentation, create a link to the glossary page for each glossary term.

_\text{[MyGlossary Term|Glossary#MyGlossaryTerm]}_

Note that this is a standard page link with an anchor. We have formatted the link as italics, because it helps to have the glossary links looking different to other page links. Readers can just skip over the glossary link if they are already familiar with the term.

Further Reading

- A blog post about content re-use: Technical Writing in a Wiki - Content Re-use and Structure (November 2010).

Next Steps

You now have a good idea of how to re-use content in a Confluence documentation space. What next? Take a look at Managing the Life Cycle of your Technical Documentation.

Managing the Life Cycle of your Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. We have already shown you how to create your technical documentation space, including how to set permissions for your space. Now we offer a quick-start guide to managing the life cycle of your technical documentation in Confluence. The life cycle includes drafting, reviewing and publishing a document, as well as managing documentation that is release-specific.

Quick guide to managing the technical documentation life cycle

- Create draft pages with restricted permissions, to hide them until they are ready for publication.
- Set the permissions to allow reviewers to comment on and/or update the pages.
- When ready, publish the page by removing the permission restrictions.
- Monitor updates to your draft and published pages by watching your space and/or subscribing to RSS feeds.
- Use spaces as a mechanism for matching your documentation version to product releases: one space per major release number.
- Consider installing plugins for extended workflow and publication management.

The rest of this page gives more details of the above procedures.

On this page:

- Using the Built-In Confluence Functionality to Manage Workflow and Release Cycle
  - Drafting, Reviewing and Publishing a Page
  - Keeping Track of Documentation Updates
    - Viewing the History of a Page
    - Receiving Email Notification of Updates
    - Monitoring Updates via RSS Feeds
  - Release Management
    - Space Keys
    - The Release Management Process
  - Other Scenarios using the Built-In Confluence Functionality
  - Using Plugins for Extended Workflow and Publication Management
  - Notes

Using the Built-In Confluence Functionality to Manage Workflow and Release Cycle

This section describes how to use the built-in Confluence functionality to manage your workflow (draft, review, publish) and to align your documentation version control to the product release cycle.

In this scenario we also assume that you want a live space that always has the same space key and always contains the latest version of your documentation. This scenario suits the requirements of an organisation that wants their technical documentation to be ‘live’. Various groups of people can refine the content as and when required. People can also subscribe to the space, knowing that they will always get the latest version of the documentation and comments.

This is the way we manage our documentation at Atlassian. The content of the wiki is dynamic, continuously updated, commented on, subscribed to and watched by thousands of people all over the world.
Drafting, Reviewing and Publishing a Page

The workflow is simple.

1. Create a page with restricted permissions. For example, you might restrict viewing to a group of people such as your team. On a public wiki, you might restrict viewing to staff members, so that the general public cannot see the page.
2. Write the page content.
3. Ask other people to review the page. They can add comments to the page or simply edit the page content directly.
4. Publish the page when ready, by doing the following:
   • Delete the comments on the page.
   • Remove the permission restrictions on the page. The page has now been published. The space permissions and site permissions now determine who can see and/or update the page.

The screenshot below shows a page under review. Notice the lock icon at top left, indicating that restricted permissions apply to this page.

Keeping Track of Documentation Updates

On a wiki, it is quite usual for a number of different people to update a single page. Technical writers need to know what happens to our documents, both during review and after publication.

Viewing the History of a Page

Confluence creates a new version of the page every time someone edits the page. The page history shows all the versions, with date, author, and any comments made on the update.

Go to the page and choose Tools > Page History.

On the page history view, you can:

• View the content of a specific version of the page.
• Revert to (restore) a specific version.
• Select any two versions and ask for a comparison, to see what has changed between those two versions.

See Page History and Page Comparison Views for detailed information.
It is all very well to go to a specific page and see what has happened to it, but how do you know when to go and look at the page? You need a notification of any changes made to your documentation space.

In Confluence, you can monitor updates to your documentation via email notifications and via RSS feeds.

**Receiving Email Notification of Updates**

You can ‘watch’ a page or an entire space. Whenever anyone updates the page or space, you will receive an email notification.

To watch a page:

Open the 'Tools' menu and select 'Watch'.

To watch a space:

1. Go to a page in the space and choose Browse > Advanced.
2. In the left-hand panel, click 'Start watching this space'.

See Subscribing to Email Notifications of Updates to Confluence Content for details of the various notifications Confluence will send, and how to configure your notification settings.

**Monitoring Updates via RSS Feeds**

RSS feeds provide another way to keep track of updates. The simplest way to build an RSS feed is to use Confluence’s feed builder, accessible from the dashboard. This will give you a URL that you can ping to get the latest updates.

Below we describe how to set up a useful feed for your technical documentation space. Remember that you can adjust the settings to suit your own needs.

1. Choose Browse > Feed Builder. The RSS feed builder form appears.
2. Check the boxes to select all the content types. (Even if you are not expecting comments, blog posts or mail in your documentation space, it does no harm to receive notifications if they do arrive.):  
   - Pages and the comments and attachments on pages.
   - Blog posts and their comments and attachments.
   - Mail.
3. Select your documentation space from the list. Press Ctrl and click to select multiple spaces.
4. Click the Create RSS Feed button to create your feed.
5. This will take you to a new screen. Drag or copy the link into your RSS reader. The feed URL is linked to the words Drag or copy this link to your RSS reader.

Now that you have set up your RSS feed, you need to decide how to read it. There are various options to choose from. For example:

- Use an RSS reader, such as the Sage add-on for Firefox.
- Use an email client, such as Thunderbird.

See Subscribing to RSS Feeds within Confluence for details.

**Release Management**

Let’s assume that your product goes through a regular release cycle, and that you need to retain separate documentation for each major version of the product.

At Atlassian, we use spaces as our version-control mechanism.

- **Archive spaces.** At each release, we create a new archive space to house the previous version of the documentation.
- **The live space.** The documentation for the latest version of the product resides in the live space. The live space always retains the same space key and is always available for viewing and updating.

**Space Keys**

The live space has just the product name as its space key. For example, for the Crowd product the space key is ‘CROWD’. (See the Crowd documentation space.)

For the archived versions, we use a combination of the product name plus version number as the space key. For example, we use 'CROWD020' for the Crowd 2.0 documentation, 'CROWD016' for the Crowd 1.6 documentation, and so on.

**The Release Management Process**
Here is an overview of the process we follow at Atlassian.

1. **Leading up to release date.** Work with hidden draft pages in the live space. A "hidden draft" is simply a page that has restricted permissions applied:
   - For each new feature, create a new page with restricted permissions.
   - If you need to update existing pages, create a hidden copy of the existing page and apply the updates to the copy.
   - Follow the usual draft and review procedure for each page.

2. **A few days before release date.** Use the Copy Space plugin to copy the live space to a new space. This creates a snapshot of the current documentation, and will act as an archive for the current release which is soon to become the previous release. (We described the use of the Copy Space plugin in the earlier section of this guide: Creating your Technical Documentation Space.)

3. **On release date.** Publish the updated documentation for the new version of the product:
   - Rebrand the live documentation space to reflect the new release number. In other words, change the space name and any other descriptions that include the product release number.
   - Unhide all the new pages, by removing the permission restrictions on each hidden page.
   - Copy the content of the updated pages to the proper pages, then delete the copies.
   - Export the newly updated space to PDF, HTML and XML, for those customers who prefer offline versions of the documentation.

Note that the above process is applicable to major releases of the product. For minor bug-fix releases, we simply update the documentation in the live space. We do not create archive spaces for every minor release.

The example below shows an extract from the dashboard of our documentation wiki, listing the spaces for different versions of the Crowd documentation. (Crowd is one of our products.) Each space holds the documentation for a specific major release of Crowd.
Other Scenarios using the Built-In Confluence Functionality

It is easy to design other ways of managing your documentation spaces using the built-in Confluence functionality. For example, the simplest scenario is to publish a new space for every new release of your product, using the same Copy Space plugin as described above.

Using Plugins for Extended Workflow and Publication Management

For advanced workflow features, consider installing the Ad Hoc Workflows plugin onto your Confluence site.

Similarly, consider using the Content Publishing plugin to publish content from a master space to a published space. In this scenario, you will create a master space that contains your drafts in progress and new releases. The master space is visible only to the authors and reviewers. You will periodically publish the master space to a published space. This suits the requirements of an organisation that needs a 'published' or 'official' set of documentation, published only when a new version of the product is released. There is no requirement for continual updating of the documentation.

1. Install the Content Publishing plugin.
2. Create a space for your master content.
3. Create a space for your published content.
4. When the content in the master space is ready to publish, go to the 'Advanced' tab in the 'Space Admin' section of the master space.
5. Click 'Publish Space' to configure the settings and then publish your space. See the plugin documentation to choose the options best for your needs.
6. Click 'Publish'.

Notes

* Installing plugins. If you decide to use additional plugins, your site administrator will need to install the plugins into your Confluence site. Refer to the documentation on installing plugins.
* Plugin support. Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

Next Steps

Now you know about managing your workflow and documentation release process on Confluence. What next? Take a look at Providing PDF Versions of your Technical Documentation.

Providing PDF Versions of your Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. Confluence itself is an excellent platform for publishing online documentation. In some cases, though, you may need to produce PDF versions of your documentation for printing, or to supply to customers who cannot access the online version.

Confluence itself provides an export to PDF. Plugins provide additional functionality.

Quick guide to PDF exports

- Customise the PDF layout (title page, header and footer) and stylesheet, for use each time you export your documentation.
- Export a single page to PDF.
- Export an entire space or a selection of pages to PDF.
- Consider installing a third-party plugin for advanced functionality.

The rest of this page gives more details of the above procedures.

On this page:

- Customising the PDF Layout and Stylesheet
  - Editing the PDF Layout
  - Editing the PDF Stylesheet
  - Some Useful Examples
    - Adding a Title Page
    - Adding Headers and Footers
    - Adding Page Numbering to a Header or Footer
- Exporting a Single Page to PDF
- Exporting a Space or a Selection of Pages to PDF
- Exporting a Spaces or Pages to PDF via a Plugin
- Notes
**Customising the PDF Layout and Stylesheet**

If you are planning to provide PDF versions of your documentation, you may want to customise the PDF layout and styles for your space. These customisations will apply each time you export your documentation to PDF.

In the PDF layout, you can add your own HTML to customise the title page, page headers and page footers in the PDF output. In the PDF stylesheet, you can adjust the appearance of the PDF pages.

**Editing the PDF Layout**

1. Choose **Browse > Space Admin.**
   - **Space Admin** is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. Click **PDF Layout** in the 'Look and Feel' section of the left-hand panel.
3. Click **Edit.** You can now customise the HTML that generates following areas in the exported PDF document:
   - **PDF Space Export Title Page** – title page.
   - **PDF Space Export Header** – page headers.
   - **PDF Space Export Footer** – page footers.
4. Enter your customisations into each text box as required. The PDF layout section accepts HTML code. You can include inline CSS in the HTML too.
5. Click **Save.**

**Editing the PDF Stylesheet**

1. Choose **Browse > Space Admin.**
   - **Space Admin** is displayed only if you are a space administrator for that space or you are a Confluence system administrator.
2. Click **PDF Stylesheet** in the left-hand panel. The 'PDF Export Stylesheet' section appears, showing the current contents of your PDF stylesheet. It contains all CSS rule customisations applied to the pages in the space.
3. Click the **Edit.**
4. Enter your customisations into the text box as required. The PDF stylesheet section accepts Cascading Style Sheets (CSS) rules.
5. Click **Save.**

**Some Useful Examples**

Below are the typical customisations you may want to make for your technical documentation. For more examples, see **Editing the PDF Stylesheet.**

**Adding a Title Page**

You can create a title or cover page to your PDF document using HTML. Use the **PDF Space Export Title Page** section of the PDF layout to do this. Adding a New Title Page

The following example uses HTML with an inline CSS rule to generate a title page.

---

Including Content Above Table of Contents in Default Title Page

The following example includes content above the automatically-generated table of contents that appears on the default title page, so that your title page includes your own content plus the table of contents.

---

Adding an Image to your Title Page

In the examples above, the title page includes an image called 'titlepage.png', centred in the middle of the page. The image is attached to a Confluence page and is referenced via its relative URL (that is, we use only the last part of the URL, excluding the Confluence site's base URL).

Follow these instructions to include an image on your title page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page.
3. Right-click the image and copy its location.
4. Paste the link into the appropriate `src` attribute within your PDF stylesheet, as shown above.
5. Remove the first part of the URL before `/download/`.

**Adding Headers and Footers**
You can add headers and footers to your PDF pages using HTML. Use the 'PDF Space Export Header' and 'PDF Space Export Footer' sections of the PDF layout to do this. For simple headers and footers, plain text is enough. The following example adds a simple copyright notice.

Adding Page Numbering to a Header or Footer
To add page numbering to your documentation, you need to combine some customised HTML in the header or footer with some customised CSS in the PDF stylesheet.

1. Create a header or footer with an empty span element and give it a unique ID, for example `pageNum`. This is a placeholder for the page number in your PDF document.

2. Create the following CSS selector rule for the empty span and add it to the PDF stylesheet:

   ```css
   #pageNum span::before {
     content: counter(page);
     counter-reset: page;
   }
   ```

   Analysing the above CSS selector rule in more detail:
   - The `#pageNum` rule selects the HTML element with the specified ID of "pageNum", which is the `span` element we created for the header or footer.
   - The `:before` part of the selector is a pseudo class that allows the insertion of content before the `span` element is processed.
   - The `counter(page)` is a function that returns the current page number as its content.
   - The `counter-reset: page;` property tells the CSS processor that dynamic content (that is, an incrementing page number) is to be inserted before the `span` tag.

Exporting a Single Page to PDF
You can export a Confluence page to PDF. This option exports a single page and is available to all users who have permission to view the page:

- Go to a page in the space and choose Tools > Export to PDF. Follow the prompts to export the page.

Exporting a Space or a Selection of Pages to PDF
Using the built-in Confluence PDF export, you can export a single page, a selection of pages or an entire space into a single PDF file.

1. Go to a page in the space and choose Browse > Advanced.
2. Click PDF Export in the left-hand panel. This option will only be visible if you have the 'Export Space' permission.
3. Select the pages you want to export.
   - You have the option to Select All or Deselect All pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
4. Click Export.
5. When the export process has finished, download and save the PDF file as prompted.
Exporting a Spaces or Pages to PDF via a Plugin

For advanced PDF export, consider installing the Scroll Wiki Exporter plugin onto your Confluence site. Scroll provides flexible themes for configuring PDF layout and styles. You can select one of Scroll's built-in themes and configure your table of contents, header and title pages.

Advanced techniques for Scroll Wiki Exporter. For even more flexibility, you can add your own theme plugins. Scroll supports themes based on DocBook XSL stylesheets. See the Scroll developer's guide.

Notes

- Permissions required to export a space. To use the space export functionality, you need 'Export Space' permission. See the guide to space permissions or contact a space administrator for more information.
- Installing plugins. If you decide to use additional plugins, your site administrator will need to install the plugins into your Confluence site. Refer to the documentation on installing plugins.
- Plugin support. Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

Next Steps

Now you know all about providing PDF versions of your documentation. What next? See other ways of Exporting and Printing Technical Documentation.

Exporting and Printing Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. Confluence is a great tool for writing and maintaining technical documentation. There are times when we need to export the content out of Confluence into other forms, such as PDF, HTML, Microsoft Word and paper.

Confluence itself provides an export to both PDF and HTML. Plugins provide additional functionality. Below are guidelines on exporting your technical documentation to various formats, including printed output.

Quick guide to printing and exporting content

- Use the browser’s print option to print a single page.
- To print more than one page and for more advanced printing options, export your documentation to PDF.
- Confluence can export your pages to PDF, HTML, Confluence-specific XML and Word.
- Consider installing plugins to export your pages to PDF (enhanced functionality), Word (enhanced functionality), DocBook XML, Eclipse Help and JavaHelp.
- Make your exports available to your customers for download by attaching the exported file to a Confluence page.
The rest of this page gives more details of the above procedures.

### On this page:
- Printing
- Exporting to PDF
- Exporting to HTML
- Exporting to Confluence-Specific XML
- Exporting to DocBook XML via a Plugin
- Exporting to Microsoft Word
- Exporting to Word via a Plugin
- Exporting to Eclipse Help via a Plugin
- Exporting to JavaHelp via a Plugin
- Making the PDF and Other Exported Files Available to your Readers
- Notes
- Further Reading

### Printing

To print a single Confluence page, just use the browser's print option. This option is available to all users who have permission to view the page.

To print more than one page and for more advanced printing options, export your documentation to PDF. See Providing PDF Versions of your Technical Documentation.

### Exporting to PDF

Because this is such an important topic, we have a section of this guide dedicated to PDF. See Providing PDF Versions of your Technical Documentation.

### Exporting to HTML

Using the built-in Confluence HTML export, you can export a single page, a selection of pages or an entire space to HTML. Confluence supplies the HTML and associated files in a zip file.

1. Go to a page in the space and choose **Browse > Advanced**.
2. Click **HTML Export** in the left-hand panel. This option will only be visible if you have 'Export Space' permission.
3. Select the **Include Comments** check box if you want to include comments for the pages you are exporting.
4. Select the pages you want to export by selecting the check boxes in the tree view of pages displayed. By default, all pages are selected. You have the option to **Select All** or **Deselect All** pages. If you select the check box of a page that contains one or more child or descendant pages, all of these child and descendant pages will also be selected. Similarly, if you clear the check box of such a page, all of its child and descendant pages will also be cleared. This provides a convenient method of exporting subtrees, for example, chapters or sections within a document.
5. Click **Export**. This will create a zipped archive of HTML files.
6. When the export process has finished, download the zipped archive as prompted and extract the files into a folder.
Exporting to Confluence-Specific XML

Confluence provides an XML export. The XML produced is a proprietary format and is intended for
backups or for transferring a space from one Confluence instance to another. If you write your
documentation on Confluence and your customers have Confluence too, then you can export your manuals
to XML and customers can upload them onto their own Confluence site.

Exporting to DocBook XML via a Plugin

Scroll Wiki Exporter converts Confluence pages to DocBook XML. Your Confluence system administrator
will need install the plugin onto your Confluence site.

Exporting to Microsoft Word

Confluence can export a page to Word. (Select 'Export to Word' from the 'Tools' menu.) This option
performs a basic conversion of wiki content to HTML and applies some Word CSS stylesheets. It
processes just one page at a time.

Exporting to Word via a Plugin

Scroll Office is a Confluence plugin. Once installed, Scroll Office replaces Confluence’s built-in 'Export to
Word' functionality. You can export a single page or a hierarchy of pages.

You can define your templates in Word in the usual way, and upload them to Confluence as global
templates or space templates. When you export your Confluence pages to Word, Scroll Office will use
those templates to build Word documents from the wiki pages.

Scroll Office provides additional features such as enforcing page-breaks, setting the page orientation to
landscape or portrait, and ignoring content. The latest version offers a REST-style API for automated
export.

Exporting to Eclipse Help via a Plugin

Scroll Wiki Exporter provides an export to Eclipse Help format.

A hint about the Eclipse Help platform: You can use a cut-down version of the Eclipse Help platform to
provide online documentation for any system. It doesn’t have to be an Eclipse tool that you are
documenting. For some ideas, take a look at a couple of articles about documenting your project using the
Eclipse help system.

Exporting to JavaHelp via a Plugin

Scroll Wiki Exporter also converts Confluence pages to JavaHelp format.
Making the PDF and Other Exported Files Available to your Readers

There are a number of ways to make your exported files available to your readers, such as putting the files on a disc and shipping them with your product.

One of the simplest ways is to attach the files to a Confluence page. (See Attaching Files to a Page.)

For example, Atlassian uses the out-of-the-box Confluence export functionality to provide PDF, HTML and XML versions of our documentation. People can download the files from our documentation wiki. For example, here are the JIRA documentation downloads and the Confluence documentation downloads.

For those people who would like to use the XML files to recreate the documentation on their own Confluence sites, we provide instructions on setting up your own local documentation.

Notes

- **Permissions required to export a space.** To use the space export functionality, you need 'Export Space' permission. See the guide to space permissions or contact a space administrator for more information.
- **Installing plugins.** If you decide to use additional plugins, your site administrator will need to install the plugins into your Confluence site. Refer to the documentation on installing plugins.
- **Plugin support.** Before installing a plugin into your Confluence site, please check the plugin’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

Further Reading

- A blog post about exporting and importing content from/to Confluence: Technical Writing in a Wiki - Single Source Publishing (November 2010).
- A good overview of the Scroll Office features in this blog post (August 2010) and the followup post (November 2010).

Next Steps

Now you know about a number of ways to get your technical documentation out of Confluence into various formats, for printing or for input into another system or process flow. What next? Take a look at Essential Confluence Features for Technical Documentation.

Essential Confluence Features for Technical Documentation

This page is part of the guide to developing technical documentation on Confluence. In this section we highlight the built-in Confluence macros that are most useful in technical documentation. For more information about Confluence macros, see Working with Macros.

To add a macro to a Confluence page, use the Macro Browser.

On this page:

- Auto-Generating a Table of Contents for Page Content
- Drawing Attention to Elements of a Page
- Putting Content inside Customisable Panels
- Inserting Anchor Links on Pages
- Structuring Content using Sections and Columns
- Making your Documentation more Engaging by Embedding Videos

Auto-Generating a Table of Contents for Page Content

It is important to make it easy for viewers to jump to the section of a Confluence page that they are most interested in. The Table of Contents macro helps you navigate lengthy pages by summarising the content structure and providing links to headings used on the page. Headings are indented progressively.

Click here to see a common example >>

2. Each feature in the release is a heading on the page.
3. You can generate a list of hyperlinks to each of the features in the release notes by inserting the Table of Contents macro:

The image below shows the Table of Contents macro inserted at the top of the 'Release Notes' page. Note that we have excluded the 'Highlights of Confluence 3.4' heading from the table of contents by modifying the macro's parameters.
5. The image below shows the macro parameters specified in the Macro Browser. Note the 'Minimum Heading Level' and 'Maximum Heading Level' parameters.

Return to top of page

**Drawing Attention to Elements of a Page**

Often when creating documentation there are elements of a page that you want to highlight, or draw the the viewers attention to. Confluence ships with the following macros that help you focus a viewer's attention to a note, information, tip or warning.

Click here to see common examples >>

<table>
<thead>
<tr>
<th>Note Macro</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>What is it?</strong></td>
</tr>
<tr>
<td>The Note macro allows you to highlight a note on a Confluence page. It creates a yellow coloured box surrounding your text, as shown to the right.</td>
</tr>
</tbody>
</table>

See [Note Macro](#) for more examples and instructions.

<table>
<thead>
<tr>
<th>Info Macro</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>What is it?</strong></td>
</tr>
<tr>
<td>The Info macro allows you to highlight helpful information on a Confluence page. It creates a blue coloured box surrounding your text, as shown to the right.</td>
</tr>
</tbody>
</table>

See [Info Macro](#) for more examples and instructions.

<table>
<thead>
<tr>
<th>Tip Macro</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>What is it?</strong></td>
</tr>
</tbody>
</table>
The Tip macro allows you to highlight a helpful tip on a Confluence page. It creates a green coloured box surrounding your text, as shown to the right.

Learn more
Check out this blog post: Technical Writing in a Wiki: Technical Communicators Explain How & Why?

See Tip Macro for more examples and instructions.

Warning Macro

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Warning macro allows you to highlight a warning note on a Confluence page.</td>
<td>Draft</td>
</tr>
<tr>
<td>It creates a red coloured box surrounding your text, as shown to the right.</td>
<td>This page is a draft in progress and visible to Atlassian staff only.</td>
</tr>
</tbody>
</table>

See Warning Macro for more examples and instructions.

Putting Content inside Customisable Panels

The Panel macro allows you to place content inside a customisable coloured panel. This is particularly useful when you want to clearly separate elements on a page.

Click here to see a common example >>

Return to top of page

Inserting Anchor Links on Pages

Anchor links can be especially useful when navigating between sections of a long document or when you
want to link to a segment of a page from another page. The Anchor macro allows you to link to specific parts of a page.

1. You are documenting part of a user guide.
2. The page is split into multiple sections.
3. After each section you want to provide a link for viewers to click, taking them back to the top of the page.
4. To achieve this you first must create an anchor at the top of the page using the Anchor macro. You can give the anchor any name you like. In the image below, the anchor at the top of the page has been named 'top'.

![Anchor Macro Example](image)

5. Create a link to the anchor, anywhere on the page, using the Link Browser. The image below shows a link to the anchor called 'top', with an alias of 'Return to top of page'.

![Insert Link](image)

See Working with Anchors for more examples and instructions.

Return to top of page

Structuring Content using Sections and Columns

Sometimes it is necessary to structure content into sections and columns.

- You can create any number of sections on a Confluence page using the Section macro.
- Each section can contain any number of columns, created using the Column macro.
- Columns can either have a fixed width, specified in pixels, or a dynamic width, specified as a percentage of the page width.
- Note: A column must be created inside a section

The images below show part of a Confluence page with two sections (red), each with two columns (blue) of different widths.
1. **Section 1:**

   - Put a name to your face
   - Learn how content is organised
   - Get familiar with the Confluence screens
   - Start creating content
   - Add a panel to your page

   ![Profile Picture](image1)

2. **Section 1 columns – left column has a fixed width of 400 pixels:**

   - Put a name to your face
   - Learn how content is organised
   - Get familiar with the Confluence screens
   - Start creating content
   - Add a panel to your page

   ![Profile Picture](image2)
Making your Documentation more Engaging by Embedding Videos

Pictures can be worth a thousand words. The same can be said for videos. Often, it’s easy to explain a concept or demonstrate a procedure using a video. The Widget macro allows you to embed web content, including YouTube, Episodic and Vimeo videos, in a Confluence page.

Click here to see a common example >>

1. You release a new version of your product.
3. The marketing team creates a video demonstrating the new features of the release and uploads it to YouTube.
4. You can embed the video in your Release Notes using the Widget macro, for playback on your Confluence page.
4. Select 'Widget' from the 'Insert' menu in the Rich Text Editor toolbar.

b. Insert the URL of your YouTube video into the 'Web Sites Widget URL' field.
c. Click ‘Insert’ and save your page.

See Widget Macro for information on the supported services and for more usage examples.

Return to top of page

Next Steps

Take a look at Confluence Plugins for Technical Documentation.

Confluence Plugins for Technical Documentation

This page is part of the guide to developing technical documentation on Confluence. In this section we highlight some of the Confluence plugins that are useful for technical writers in designing and developing documentation.

A plugin is an extension module that you can add to your Confluence site, to extend the wiki’s core functionality. It is similar to an add-on for your browser. Confluence plugins may be developed by Atlassian or by third parties. To find the plugins featured on this page, and other plugins too, visit the Atlassian Plugin Exchange.

This page features plugins that provide the following extended capabilities:

- **Extended Wiki Markup Features**
  - Quick Overview of Macros
  - Composition Plugin
  - Using the Composition Plugin to Outline Text Blocks
  - Using the Composition Plugin to Add Tabs to a Page
  - Using the Composition Plugin to Flow your Text around Images
  - Scaffolding Plugin
- **Extended Version Control**
  - Attachment Checkout Plugin
- **Drawing Tools**
  - Gliffy Plugin
  - Notes
  - Further Reading

Quick guide to the plugins featured below

- **Composition plugin** – Provides macros which allow finer control over the layout (composition) of a page. For example, outline text; add tabs to your page; flow your text around diagrams. This plugin is free.
- **Scaffolding plugin** – Provides macros for creating ‘permanent templates’ and editable forms. Free.
- **Attachment Checkout plugin** – Adds check-out/check-in functionality for Confluence attachments. Free.
- **Gliffy plugin** – Provides an embedded diagram editor. Commercial.
Plugins featured in other parts of this guide

- Copy Space plugin – Provides an easy way of copying a space within a Confluence site. Free. See Creating your Technical Documentation Space.
- Multi Excerpt plugin – Enables you to have more than one excerpt (re-usable chunk) on a page. Commercial. See Re-using Content in Technical Documentation.
- Content Publishing plugin – Publishes content from a master space to a published space. Commercial. See Managing the Life Cycle of your Technical Documentation.

On this page:

- Extended Wiki Markup Features
  - Quick Overview of Macros
  - Composition Plugin
  - Using the Composition Plugin to Outline Text Blocks
  - Using the Composition Plugin to Add Tabs to a Page
  - Using the Composition Plugin to Flow your Text around Images
  - Scaffolding Plugin
  - Extended Version Control
  - Attachment Checkout Plugin
  - Drawing Tools
  - Gliffy Plugin

Extended Wiki Markup Features

All wiki markup extensions are provided by macros in Confluence. Some macros are built in to Confluence. Other macros are supplied by plugins.

Quick Overview of Macros

Before looking at plugins, let's take a quick look at macros in general. There are two ways to add a macro to your page:

- Use the Macro Browser. This is the simplest and recommended way.
- Or insert the macro's name in curly brackets into the text of your page and specify the parameters.

Click here to see an example of a macro >>

The following code uses the {include} macro to insert the text from the page called 'My Page'. The text will appear on the page where the macro is used:

```plaintext
Page text...
{include:My Page}
page text...
```

The resulting page will look like this:

```plaintext
Page text...
<text from the 'My Page' page>
page text...
```

A number of macros are shipped with your Confluence installation by default. See Working With Macros. Below we describe some plugins that provide additional useful macros for Confluence:

Composition Plugin

The Composition plugin adds some formatting features to compose a page in a more flexible way. Using the macros provided by the Composition plugin, you can:

- Outline your text blocks.
• Add tabs to a page.
• Flow your text around the images or diagrams on the page.

**Using the Composition Plugin to Outline Text Blocks**

Use the `{cloak}` macro to outline a text block.

**Usage:** The following code creates a text block named ‘SeeAlso’ for the outlined ‘See Also’ section within a page. The text block with id='SeeAlso' will be hidden after the ‘See Also’ title:

```plaintext
{composition-setup}
   h2. {toggle-cloak:id=SeeAlso} See Also
       {cloak:id=SeeAlso}

   h3. Working With Macros:
       [Link 1]
       [Link 2]

   h3. Working with Rich Text Editor:
       [Link 3]
       [Link 4]
   {cloak}
```

**Alternatives:** You can also use the `{expand}` macro available in Confluence by default, but this macro can outline only text of the same level and cannot hide headings within the text. The `{expand}` macro does not require parameters and just hides the text placed between the `{expand}` tags.

**Note:** If you need to outline a text block containing nested headings, consider the text structure. Maybe the block is too big. You could create a child page from this block to decompose the whole text. Then you can include and outline the text block using the `{include}` macro within `{expand}`.

**Using the Composition Plugin to Add Tabs to a Page**

Use the `{deck}` and `{card}` macros to separate content between tabs on the same page.

**Usage:** The following code creates two tabs with client information:

```plaintext
{composition-setup}
   h1. Client Name
       {deck:id=ClientName}

       {card:label=Basic}
       Client Company Name: Company
       [Client Web Site][http://url.com]
       Our projects: [Project1][Project1 Home]
       {card}

       {card:label=Contacts}
       Company CEO: John Brown, e_mail: brown@company.com
       {card}

   {deck}
```

The tabs on a page will look like this:
Using the Composition Plugin to Flow your Text around Images

Use the `{float}` macro to make your text flow around images or diagrams.

Usage: The following code demonstrates how a picture can be surrounded by the description, as often shown in printed publications:

```markdown
{composition-setup}
{float:left}
!shakespeare.jpg!
{float}

William Shakespeare (baptised 26 April 1564; died 23 April 1616) was an English poet and playwright, widely regarded as the greatest writer in the English language and the world’s pre-eminent dramatist.

... 
```

The page will look like this:

**Floating Text demo**

William Shakespeare (baptised 26 April 1564, died 23 April 1616) was an English poet and playwright, widely regarded as the greatest writer in the English language and the world’s pre-eminent dramatist. His enduring works, including some collaborations, consist of about 38 plays, 164 sonnets, two long narrative poems, and several other poems. His plays have been translated into every major living language and are performed more often than those of any other playwright.

Shakespeare was born and raised in Stratford-upon-Avon. At the age of 18, he married Anne Hathaway, with whom he had three children: Susanna, and twins Hamnet and Judith. Between 1586 and 1592, he began a successful career in London as an actor, writer, and part owner of a playing company called the Lord Chamberlain’s Men, later known as the King’s Men. He appears to have retired to Stratford around 1613, where he died three years later. Flow record of Shakespeare’s private life remain, and there has been considerable speculation about such matters as his physical appearance, sexuality, religious beliefs, and whether the works attributed to him were written by others.

Shakespeares produced most of his known work between 1599 and 1613. His early plays were mainly comedies and histories, genres he raised to the peak of sophistication and artistry by the end of the 16th century. He then wrote mainly tragedies until about 1608, including Hamlet, King Lear, and Macbeth, considered some of the finest works in the English language. In his last phase, he wrote tragicomedies, also known as romances, and collaborate with other playwrights.

For more macros, see the Composition plugin page.

Scaffolding Plugin

The Scaffolding plugin allows you to create sophisticated page templates in order to add content easily and fast. Scaffolding templates are suitable for dynamically-filled data and allow people to create pages by completing form fields and selecting values from drop-down lists.

The Scaffolding templates are useful for creating pages with a well-determined structure, such as:

- API methods or property descriptions.
- Constant list.
- Feature description.
- Software requirement specifications.

Example: The following Scaffolding template creates a description of an API method:
h3. Method Name
{text-data:methodName|required=true}{text-data}

h3. Method Description
{text-data:methodDescription|type=area|required=true|width=100%}description{text-data}

h3. Parameters
{table-data:parameters}
|| Name || Type || Mandatory || Description ||
| {text-data:paramName}ParamName{text-data} |
| {list-data:paramType}{{list-option:Number}Number{list-option}{list-option}String{list-option}{list-option:DateTime}DateTime{list-option}{list-option:MACaddress}MACaddress{list-option}{list-option:IPaddress}IPaddress{list-option}{list-data} |
| {list-data:paramMandatory}{{list-option:Required}Required{list-option}{list-option:Optional}Optional{list-option}{list-data} |
| {text-data:paramDescription|type=area}param description{text-data} |
| {table-data}

h3. Return Value

The returned value is an XML structure of the following format:

```xml
{code:xml}
{code}
```

Where elements mean:

{table-data:returnValues}
|| Name || Type || Description ||
| {text-data:paramName}ParamName{text-data} |
| {list-data:paramType}{{list-option:Number}Number{list-option}{{list-option:DateTime}DateTime{list-option}{{list-option:MACaddress}MACaddress{list-option}{{list-option:IPaddress}IPaddress{list-option}{list-data} |
| {text-data:paramDescription|type=area}param description{text-data} |
| {table-data}

h3. Remarks
{text-data:remarks}{text-data}

h3. See Also

This template will look like this:
For more information on how to create templates in Confluence, see Adding a Template.

Alternatives: Confluence includes built-in templates which are useful for static data and simple text. For more information, see Working with Templates.

Notes: The Scaffolding (and any) template changes will affect only new pages created from the modified template. In order to change the existing pages, you need to edit each individual page and add or modify the formatting manually.

For more information on Scaffolding, see the Scaffolding plugin page.

Extended Version Control

Attachment Checkout Plugin

The Attachment Checkout plugin adds check-out/check-in functionality for Confluence attachments. It allows you to control the versions of the documents attached to a page with the same file name.

Attachment checkout allows Confluence to warn contributors that the document is being edited by someone else. Note that there are no merge features for attachments.

Example: To store and control the versions of Project Vision documentation received from a customer on the Confluence page:

For information on working with attachments, see Working with Attachments. For information on attachment versioning, see Attachment Versions.

Drawing Tools
Gliffy Plugin

The Gliffy plugin provides an embedded diagram editor. Gliffy allows you to create and edit diagrams directly from a Confluence page. It supports various diagram types (UML, business process, and so on).

Alternatives: As an alternative you can use the standalone version of Gliffy available at http://www.gliffy.com/. Gliffy online has a free basic version.

For more information, see the Gliffy plugin page.

Notes

- Installing plugins. If you decide to use additional plugins, your site administrator will need to install the plugins into your Confluence site. Refer to the documentation on installing plugins.
- Plugin support. Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

Further Reading

- A blog post about useful plugins and tools for exporting and importing content from/to Confluence: Technical Writing in a Wiki - Single Source Publishing (November 2010).
- Website for exploring and downloading the available plugins: Atlassian Plugin Exchange.
- Documentation on installing and configuring plugins: Installing and Configuring Plugins using the Universal Plugin Manager.
- Documentation on using macros: Working With Macros.
- Further Reading about Developing Technical Documentation on Confluence

Further Reading about Developing Technical Documentation on Confluence

This page is part of the guide to developing technical documentation on Confluence. Once you have absorbed all the information in this guide, you may be ready for more reading.

- The Confluence documentation: Confluence 4.0.
- Tips from other technical writers, in the Confluence documentation: Tips of the Trade.
- Blog post about using Confluence for online help: Using a wiki for online help.
- Now you have your documentation space up and running, it's fun and rewarding to use the full power of the wiki to engage your readers and embed content from other social sites. Here is a blog post and presentation slides on engaging readers in the documentation.

Let us know about more links

We plan to add more links to this page or to the 'Tips of the Trade' page. Let us know of any we have missed.

Developing a Knowledge Base on Confluence Wiki

Welcome! This is a guide to using Confluence as a knowledge base. You will find this guide useful if you want to produce a knowledge base with a survey, content curation, intelligent search and standardized templates.

In these pages, we'll show you how to use Confluence to achieve a high-functioning knowledge base, including these features:

- Using Templates
- Subscriptions (RSS or Email)
- Exporting articles (PDF or Word)
- Organizing content (hierarchically or by label)
- Involving Customers (using comments)
- Populating data
- Scripts to update content programatically
- A "Was This Helpful?" survey
- Intelligent searching algorithms (higher ranked articles are promoted in search results)
- Targeted searching across specified Confluence spaces and content types
- How to show related content
- Extensive metrics and reporting
- Maintenance

PAGES IN THE GUIDE

- Creating Your Knowledge Base Space
- Using Templates and Formatting Macros in a Knowledge Base
- Proactive Communications in a Knowledge Base
- Additional Plugins for a Knowledge Base

RELATED TOPICS
Creating Your Knowledge Base Space

This guide is for people who want to develop and publish a knowledge base using Confluence. You’ll find Confluence useful because it combines professional web publishing features with the ease-of-use and flexibility of a wiki - requiring a low barrier to entry, but high quality output for all your team members. Confluence provides all of the collaborative features for your reports (such as automatic versioning, granular enterprise security, email and RSS subscriptions, and JIRA integration). This page is a quick-start guide to creating a wiki space for a knowledge base.

Quick guide to creating a knowledge base space

- Add a Space and Select the Documentation Theme
- Set the Space Permissions
- Customise the Title and Content of the Homepage
- Customise the Documentation Theme
- Create an Inclusions Library to Manage Reusable Content
- Create the Table of Contents
- Make your Knowledge Base Proactive with a Subscribable RSS Feed
- Insert Google Analytics Code into Confluence's Custom HTML
- Set up Atlassian's Content Survey and Reporting Plugin

The rest of this page gives more details of the above procedure.

On this page:

- Step 1. Add a Space and Select the Documentation Theme
- Step 2. Set the Space Permissions
- Step 3. Customise the Title and Content of the Homepage
- Step 4. Customise the Documentation Theme
- Step 5. Create an Inclusions Library to Manage Reusable Content
- Step 6. Create the Table of Contents
- Step 7. Make your Knowledge Base Proactive with a Subscribable RSS Feed
- Step 8. Insert Google Analytics Code into Confluence's Custom HTML
- Step 9. Set up Atlassian's Content Survey and Reporting Plugin
- Note about Plugin Support

Step 1. Add a Space and Select the Documentation Theme

Below is a quick guide to adding a space. See Setting up a New Global Space for a full description.

1. Go to the Confluence dashboard and click Add Space located on the ‘Spaces’ tab. Hint: If you cannot see the Add Space link, this means that you do not have permission to add spaces. Please contact your Confluence administrator.
2. In the ‘Create Space’ screen, enter a space name and a short, unique space key.
3. Leave the permission settings as default, or choose to allow only yourself to view or contribute content to this space. You can change these settings later and with more flexible options.
4. Select the Documentation Theme.
5. Click OK.

The homepage of your new space will appear. Because you created the space, you are the space administrator. Now you can do some basic configuration, as described in the sections below.

Step 2. Set the Space Permissions

Define the space permissions to determine who can do what in your new space.

1. Choose Browse > Space Admin.
2. Click Permissions in the left-hand panel.
3. Confirm your administrator access as prompted.
4. Click Edit Permissions.
5. Set the permissions to suit your needs then click Save All.
   - You can add groups and/or individual users to the list, then select the permissions for each group or user.
   - You can also set the permissions for anonymous users – these are people who have not logged in to the wiki. Anonymous access is available only if enabled for the entire Confluence site. We recommend this setting if you are using this space for Technical Documentation or for a Knowledge Base.
   - Note that you can change these permissions at any time. You may want to restrict the permissions to specific groups now, and later open the space to more people.
A Bit More about Permissions

Confluence has a robust and granular permissions scheme that you can use to determine who can view, comment on and even update the documentation. There are three levels of permissions in Confluence:

- Global permissions apply across the entire site.
- Space permissions apply to a space.
- Page restrictions allow you to restrict the editing and/or viewing of a specific page. Below we discuss a way of using these in the draft, review and publishing workflow.

Space permissions in Confluence are simple yet granular enough to be useful for technical documentation. You can:

- Use the permission levels to control who can create pages in the space, delete pages, create comments, delete comments, administer the space, and so on.
- Grant a permission level to one or more users, and/or to one or more groups, and/or to anonymous users.

Terminology:

- ‘Anonymous’ means people who have not logged in to the wiki. These are users that won’t affect your the number permitted by your license.
- The ‘confluence-users’ group is the default group into which all new users are assigned. Everyone who can log in to Confluence is a member of this group.

For example, you might allow ‘Anonymous’ users specific view and content creation rights so that they can access and engage with your knowledge base while your team lead (Bill) maintains full Space Administration rights.

For detailed information, see the documentation on:

- Global permissions
- Space permissions
- Page restrictions
- Users and groups

Step 3. Customise the Title and Content of the Homepage

When you created your space, Confluence created a homepage with default content and a default title, ‘Home’. You will want to change the title and content.
1. Go back to your space homepage, by clicking the space name in the breadcrumbs at the top of the screen. In the example below, the space name is 'My Knowledge Base':

Go back to your space homepage, by clicking the space name in the breadcrumbs at the top of the screen. In the example below, the space name is 'My Knowledge Base':

2. The space homepage appears. By default, the page title is 'Home'.

The space homepage appears. By default, the page title is 'Home'.

3. Click Edit.
4. Change the title to suit your needs.
5. Update the content to suit your needs.
   Hint: If you do not know what to add yet, just add a short description. You can refine the content of the page later. Take a look at an example of a homepage.
6. Click Save.

**Step 4. Customise the Documentation Theme**

When you added this space you chose the Documentation theme, which provides a left-hand navigation bar and a good look and feel for a knowledge base. If necessary, you can configure the Documentation theme to add your own page header and footer or to customise the default left-hand navigation bar. These customisations affect the online look and feel of your knowledge base. See Configuring the Documentation Theme for the full description in our product documentation.
1. Choose **Browse > Space Admin**.
2. Click **Themes** in the left-hand panel.
3. If the space is not yet using the Documentation theme, apply the theme now.
4. Click **Configure theme** in the yellow area of the 'Current Theme' section at the top of the page.

**Current Theme**

The current theme controls the layout and colours of Confluence.

**Documentation Theme**

This theme is well suited for spaces such as documentation. It features a page contents (page tree) on the left-hand panel and a default search box and table of contents (page tree) on the left-hand panel to see the structure of a space page to page. You can customise the panel, page header and page footer. The theme supports Firefox, Safari and Internet Explorer.

**Configure theme - further customise this theme's settings**

5. The 'Documentation Theme Configuration' screen appears. Customise the left-hand navigation bar, header and footer to suit your needs. Details are in the documentation. Here are some hints:
   - The **Page Tree** check box determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.
   - The **Limit search results to the current space** check box determines whether Confluence will search only the current space or the whole Confluence site. This setting affects the default search. Viewers can override it each time they do a search.
   - Enter text, images, macros and other wiki markup into any or all of the three text boxes for the left-hand navigation bar, header and footer. You can use the `include` macro and the `Excerpt` macro to include re-usable content.
   - Any content you add to the navigation panel will appear above the default page tree.
   - If you like, you can remove the default page tree (by unticking the box) and add your own, customised version of the `Pagetree` macro instead.

6. Click **Save**.

**Example of a Customised Footer**

Take a look at the footer of a page in the Crowd documentation space.

To produce the above footer, we have the following content in the footer panel in the Documentation theme configuration screen:

```
{include:_Documentation Footer|nopanel=true}
{include:ALLDOC:_Copyright Notice|nopanel=true}
```

Here it is in text form:
The above content consists of two Include macros.

- The first macro includes a page called _Documentation Footer. This page contains the big blue buttons and hyperlinked text.
- The second macro includes a page from a different space, the ALLDOC space, called _Copyright Notice. This page includes our standard copyright notice, used in all our documentation spaces.
- In each include macro, the content has been drawn from an inclusions library, a hidden content repository, from which you can store frequently and reusable content throughout your knowledge base space.

**Step 5. Create an Inclusions Library to Manage Reusable Content**

Using Confluence, you can dynamically include content from one page into another page. You can include a whole page into another one, using the Include macro. You can also define an excerpt on a page, and then include that excerpted text into another page using the Excerpt Include macro.

To organise your re-usable content, we recommend that you create a set of pages called an 'inclusions library'.

1. Choose Browse > Pages.
2. Choose Add > Page. This will add a page at the root of the space, at the same level as the homepage.
3. Enter a suitable title. We use '_InclusionsLibrary'. The unusual format of the title helps to let people know this page is special.
4. Enter some content on the page. We enter text explaining the purpose of the inclusions library and how to re-use the content. You can copy our text by clicking through to one of the example pages listed below.
5. Add child pages containing your re-usable content. See the examples of our own inclusions libraries listed below.

Some notes about inclusions libraries:

- The inclusions library is not a specific feature of Confluence. The pages in the inclusions library are just like any other Confluence page.
- The pages are located at the root of the wiki space, not under the homepage. This means that they will not appear in the table of contents on the left and they will not be picked up by the search in the left-hand navigation bar either.
- The pages will be picked up by other global searches, because they are just normal wiki pages.
- We have decided to start the page name with an underscore. For example, '_InclusionLibrary'. This indicates that the page is slightly unusual, and will help prevent people from changing the page name or updating the content without realising that the content is re-used in various pages.

**Examples of Inclusions Libraries**

Here are some examples in our documentation:

- Crowd inclusions library
- Confluence inclusions library

**Step 6. Create the Table of Contents**

Create the table of contents for your knowledge base, by adding the top-level pages for all the usual sections. For instance, our Technical Support Team designed the following pages in the Confluence Knowledge Base on our public wiki:

- Browse Articles by Label
- Browse Articles by Top Ranked Content
- Browse Articles by Page Tree Hierarchy
- Browse Articles by Version
- Subscribe to Proactive Announcements
1. Go back to your space homepage, by clicking the space name in the breadcrumbs at the top of the screen.
2. Choose Add > Page. This will add the page as a child of the homepage.
3. Enter the page title, for instance: 'Browse Articles by Label'.
4. Enter the content of the page.
   - Hint: If you do not know what to add yet, just add a short description then refine the content of the page later. If you like, you can follow a similar outline as the Confluence Knowledge Base and add the Label List macro. This displays a hyperlinked alphabetical index of all labels within the current space. As you create content in this space and apply appropriate labels, the macro will update this page automatically.

5. Click Save.

Now do the same for all the sections of your Knowledge Base that you wish to appear in the left-navigation bar of the Documentation theme. Below is what the Table of Contents looks like for our Confluence Knowledge Base:

---

**Step 7. Make your Knowledge Base Proactive with a Subscribable RSS Feed**

Let's populate the knowledge base homepage with content by creating an RSS feed that your coworkers and customers can subscribe to and receive important updates on your knowledge base and technical alerts on your products.

This is a strategy that Atlassian's Technical Support Team uses to create a proactive knowledge base that provides technical alerts to customers and coworkers and helps solve support issues before they're even created.

By following the quick guide below, you'll create a homepage similar to the one Atlassian's Technical Support Team has created for the Confluence Knowledge Base on our public wiki and turn your knowledge base from reactive to proactive:
Creating your RSS Feed

Confluence can filter spaces by content type. To filter your knowledge base for 'blog post' content, do the following:


2. Copy this URL to your clipboard.

3. Create an RSS feed for the URL of your knowledge base space.

Now your RSS feed will consist of any blog posts created in the knowledge base space.

Highlighting Your Technical Announcement RSS Feed

1. Go to your space homepage by clicking the appropriate breadcrumb in the top-left of your screen.
2. Click Edit.
3. Insert an 'h2' heading, such as 'Important Technical Announcements'.
4. Insert bold text that reads something like, 'Copy the RSS feed into your favourite RSS reader:'.
5. Choose Insert > Other Macros to open the Macro Browser.
6. Select the 'Panel' macro in the Macro Browser and specify your desired macro preferences. We recommend that you change the Panel Title, Border Style, and Background Color to further highlight the panel on the page.
7. Click Insert.
Insert a Blog Posts Macro

1. Click in the Panel macro placeholder and choose Insert > Other Macros to open the Macro Browser again.
2. Select the ‘Blog Posts’ macro in the Macro Browser and specify the following preferences:
   - Content Type to Display: Title
   - Restrict to These Spaces: Your knowledge base Spacekey
   - Maximum Number of News Items: 5
   - Sort By: Creation
   - Reverse Sort: Tick the box
3. Click Insert to insert the Blog Posts macro onto the page inside your Panel macro.

   Now your panel will display the last 5 blog posts created in your knowledge base space.

Inserting your RSS Feed into your ‘Technical Announcement’ Panel

First, let’s create a link so that your coworkers and customers can view all of the blog posts in your knowledge base space. See Working with Links for a full description in our product documentation.

1. Place your cursor after/below the Blog Posts macro in the Panel macro placeholder.
2. Type: ‘View more recent blog posts’.
3. Highlight this text and click Link on the editor toolbar.
4. Select ‘Web Link’ and paste the link you copied to create your RSS Feed.
5. Click Insert.

Now, let’s insert your RSS Feed into your panel by linking an image. See Linking an Image for a full description in our product documentation.

1. Attach an RSS Icon to the page by dragging and dropping it into the editor (preferably below the link you just created). See Drag-and-Drop for a full description in our product documentation.
2. Click the RSS Icon image and then click the ‘Align right’ button on the editor toolbar.
3. Click Border in the image properties panel.
4. Link the RSS Icon by selecting the image and then clicking Link on the editor toolbar.
5. Click the ‘Web Link’ tab and insert the RSS Feed URL you created.
6. Click Insert to link your RSS Feed to the RSS Icon image.
7. Click Save to save your page and test your RSS Icon.

Congratulations! You have successfully created a proactive knowledge base.

**Step 8. Insert Google Analytics Code into Confluence’s Custom HTML**

Now that you have a strong foundation for a knowledge base, it's critical to assess how effectively it
services your customers. Google Analytics is a tool that gives you rich insights into your website traffic and marketing effectiveness. You are going to want to understand how your customers are accessing the resources in your knowledge base. This is a quick guide to inserting Google Analytics HTML code into Confluence so you can measure your knowledge base traffic.

1. If you don't have one already, create a Google Account and then create a Google Analytics Account using your Confluence instance's URL.
2. Copy the Google Analytics code to your clipboard.
3. Log into Confluence as a System Administrator or Confluence Administrator.
4. Go to the Confluence 'Administration Console'. To do this:
   a. Choose Browse > Confluence Admin.
   b. Enter your password and click Confirm. You'll be temporarily logged into a secure session to access the 'Administrator Console'.
5. Click Custom HTML under 'Look and Feel'.
6. Click Edit to insert custom HTML into your Confluence instance.

You can now monitor the activity and traffic for every page you create in your Confluence instance and Knowledge Base.

Hint: If your knowledge base only represents a space within your greater Confluence instance, you can search Google Analytics for activity in the specific space by exclusively filtering for the space key.

Step 9. Set up Atlassian’s Content Survey and Reporting Plugin

Now that you can monitor the traffic and activity of your knowledge base, let’s measure its effectiveness. When the Content Survey and Reporting Plugin is activated for a space, it will generate a report that includes:

- Direct feedback from customers about article quality
- Amalgamated "composite score" results
- Answers to secondary questions, such as "Was the info complete?" or "Was the article well-written?"
- Rollup at-a-glance view of the metrics for the whole space.

Lastly, the Content Survey and Reporting Plugin will institute 'intelligent searching' which means that based on the results of the surveys, higher ranked pages are promoted in search results, so your best and most popular pages are found easiest. This is a quick guide for how to set up the Content Survey and Reporting Plugin.

Hint: This plugin only functions properly if the Documentation Theme is applied to the space. Let's install the Content Survey and Reporting Plugin using Confluence's Universal Plugin Manager.
Installing the Content Survey and Reporting Plugin

1. Log into Confluence as a System Administrator or Confluence Administrator.
2. Go to the Confluence 'Administration Console'. To do this:
   a. Choose Browse > Confluence Admin.
   b. Enter your password and click Confirm. You'll be temporarily logged into a secure session to access the 'Administrator Console'.
3. Click Plugins under 'Configuration'
4. Click the Install tab of the UPM and search for the 'Content Survey and Reporting Plugin'.

   ![Install](image)

   The Universal Plugin Manager allows you to view, manage and upgrade your installed plugins and new ones from the [Atlassian Plugin Exchange](https://atlassian.com/plugins).

   **Plugins to show:**

   Manage Existing  Upgrade (5)  Install  Confluence Upgrade Check

   **Plugins matching "content survey and reporting plugin"**

   ![Content Survey and Reporting Plugin](image)

   Great for a Knowledge Base, Documentation includes space-wide configurable surveys, interested algorithms, top articles and dynamic content multi-space QuickNav searching.

5. Click Install Now.

Now that you've installed the Content Survey and Reporting Plugin, let's configure a survey:

Configuring a Survey

1. Go to your space homepage by clicking the appropriate breadcrumb in the top-left of your screen.
2. Choose Browse > Space Admin.
3. Click Configure Survey under 'Knowledge Base Survey'. Here you can:
   - Add a question
   - Edit a question's text
   - Activate or deactivate a question
   - Edit the response text
4. Configure a 'Primary Question' for the survey

   ![Survey Configuration](image)

   **Primary Question:**

   **Was this helpful?**

   ![Additional Question](image)

   **Add an Additional Question:**

   ![Response Options](image)

   **Edit Survey Completed Response (anonymous):**

   **Thanks!**

   **Edit Survey Completed Response (user):**

   **Thanks!**

5. Click Save.

Now that you've added a primary question, let's test out the plugin by adding it to the footer of the Documentation theme so that every page within your Knowledge Base space includes your survey.
**Invoking the Content Survey and Reporting Macro**

1. Go to your space homepage by clicking the appropriate breadcrumb in the top-left of your screen.
2. Choose **Browse > Space Admin.**
3. Click **Themes** under ‘Look and Feel’.
4. Click **Configure theme** in the yellow area of the ‘Current Theme’ section at the top of the page.
5. Visit the ‘Footer’ section of the ‘Documentation Theme Configuration’ page and insert this recommended markup to achieve a nice layout of the Content Survey and Reporting Plugin:

   ```
   {section}
   {column:width=5%}
   {column}
   {column:width=90%}
   {panel}
   [kbsurvey]
   {panel}
   {column}
   {column:width=5%}
   {column}
   {section}
   ```

6. Click **Save** and go to your space homepage to view your Content Survey and Reporting Plugin in the footer of the page.

With the Content Survey and Reporting Plugin you can dramatically improve the quality of our knowledge base and the efficiency with which your team creates and maintains it. Here is an example of how our Technical Support Team uses the Content Survey and Reporting Plugin in the Confluence Knowledge Base:

**Help us improve!**

- **Is this article helpful?** Yes ☐ No ☐
- **Is the content complete?** Yes ☐ No ☐
- **Is it well written?** Yes ☐ No ☐

**Content Survey and Reporting Plugin Results:**

Survey results are viewable by Space Administrators only. The plugin develops three results:

- **Pages with Results** - Determine page-by-page, which are your most effective knowledge base articles and which ones need improvement.
As you can see, the plugin develops a ‘Composite Score’ which ranks articles in search, so your highest scoring (best) content can be found most easily. The score is based on the last 32 votes cast, using the global search configuration. See Confluence Content Survey and Reporting Plugin for a full description on how Global Search boosting works.

- **Pages without Results** - These are the pages in your knowledge base without survey results.
- **Rollup Report** - This is the summary of all survey results. The report can be used to determine how effective your overall knowledge base content is.

<table>
<thead>
<tr>
<th>Confluence Knowledge Base</th>
<th>Total Ballots</th>
<th>Composite Score</th>
<th>Is this article helpful?</th>
<th>Is the content complete?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cannot Save Large Pages with Over 700,000 Characters</td>
<td>2</td>
<td>6</td>
<td>100% (2/2)</td>
<td>100% (1/1)</td>
</tr>
<tr>
<td>Unable to Export to HTML due to Page Title with * Symbol</td>
<td>2</td>
<td>6</td>
<td>100% (2/2)</td>
<td>100% (1/1)</td>
</tr>
<tr>
<td>Unable to Download Attachments in IE over SSL</td>
<td>2</td>
<td>4</td>
<td>100% (2/2)</td>
<td>100% (2/2)</td>
</tr>
<tr>
<td>MySQL Table is Marked as Crushed and Should be Repaired</td>
<td>1</td>
<td>3</td>
<td>100% (1/1)</td>
<td>100% (1/1)</td>
</tr>
<tr>
<td>ClientAbortException java.net.SocketException Broken Pipe</td>
<td>1</td>
<td>3</td>
<td>100% (1/1)</td>
<td>100% (1/1)</td>
</tr>
<tr>
<td>Getting PacketTooBigException Error `Packet for query is too large'</td>
<td>1</td>
<td>3</td>
<td>100% (1/1)</td>
<td>100% (1/1)</td>
</tr>
<tr>
<td>Cluster Panic due to Multiple Deployments</td>
<td>1</td>
<td>3</td>
<td>100% (1/1)</td>
<td>0% (0/0)</td>
</tr>
<tr>
<td>Page Footer Appears in the Middle of the Page</td>
<td>1</td>
<td>3</td>
<td>100% (1/1)</td>
<td>0% (0/0)</td>
</tr>
<tr>
<td>Confluence Fails to Process Index Queue Automatically</td>
<td>1</td>
<td>3</td>
<td>100% (1/1)</td>
<td>0% (0/0)</td>
</tr>
<tr>
<td>Fatal JVM Crash - java.lang.OutOfMemoryError ... Out of Swap Space?</td>
<td>1</td>
<td>3</td>
<td>100% (1/1)</td>
<td>100% (1/1)</td>
</tr>
<tr>
<td>A call into SPS Single Sign-on failed Due to Invalid Credentials in the Database</td>
<td>1</td>
<td>2</td>
<td>100% (1/1)</td>
<td>100% (1/1)</td>
</tr>
<tr>
<td>Database Deadlock on Microsoft SQL Server</td>
<td>2</td>
<td>2</td>
<td>50% (1/2)</td>
<td>0% (0/2)</td>
</tr>
<tr>
<td>Cluster Panic due to Multicast Traffic Communication Problem</td>
<td>2</td>
<td>2</td>
<td>50% (1/2)</td>
<td>0% (0/0)</td>
</tr>
<tr>
<td>Confluence Rebuild Indexing task fails to complete.</td>
<td>1</td>
<td>2</td>
<td>100% (1/1)</td>
<td>100% (1/1)</td>
</tr>
<tr>
<td>Broken Page Layout Due to Disabled Velocity Helper Module in Documentation Theme Plugin</td>
<td>1</td>
<td>-1</td>
<td>0% (0/1)</td>
<td>0% (0/1)</td>
</tr>
</tbody>
</table>

Searching Multiple Spaces from your Knowledge Base

As mentioned, the Content Survey and Reporting Plugin generates a composite score that ranks pages and articles within your knowledge base to make the highest (most well regarded) pages more retrievable by visitors. The plugin also improves Confluence search by allowing users to search multiple spaces without ever leaving your knowledge base space. This is really helpful for users that are unfamiliar with Confluence because they can keep the knowledge base as a point of reference within the greater instance of Confluence.

At Atlassian, our product knowledge bases and product documentation exist in the same Confluence instance so that we can make both available to ‘Anonymous’ users. Our Technical Support team uses the Content Survey and Reporting Plugin to allow visiting users to search for Confluence resources in the product documentation space from the Confluence Knowledge Base space. This provides the visitor twice the chances of finding an answer to their question.

In the image below, you can see the space specific search used in the left-navigation bar to find content related to Confluence in both the ‘Documentation’ and ‘Knowledge Base’ spaces. Pages in the ‘Documentation’ space are listed first and pages in the ‘Knowledge Base’ space are listed second.
If a user doesn't choose one of the recommendations from the quick search drop-down menu, the plugin will display a search results page inside the Knowledge Base space rather than directing them to the Confluence global search page. By keeping the visitor in the same space, it will help new users find the information they need and only navigate to pages they intend to, minimizing confusion and the number of times a user has to hit the 'Back' button in their browser.

**Note about Plugin Support**

Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

**Next Steps**

See Using Templates and Formatting Macros in a Knowledge Base for next steps.

**Using Templates and Formatting Macros in a Knowledge Base**

This page is part of the guide to developing a knowledge base on Confluence Wiki. We have already...
shown you how to create your knowledge base space. Now we offer an introduction to the templates that Confluence provides.

Quick guide to templates in Confluence

- A template is a page with predefined content that can be used as a prototype when creating other pages.
- Templates are available across the Confluence site (global templates) or per space (space templates).
- Both ‘global templates’ and ‘space templates’, as described on this page, define the content of a page. They do not define the content of an entire space.
- You can import predefined templates, including those shipped with Confluence and additional templates from the Atlassian Plugin Exchange.
- To create a template for an entire space, see our guide to creating your documentation space.

Space Information Design

One question that comes up is whether a knowledge base should be implemented as a decision matrix, with a multi-select or other list. We knew that most of our users visit our documentation directly from search engines. Early on, we learned that at least for us, Google Analytics was showing that most traffic was coming from search engines, not from within our site. See Metrics for a discussion on that. So, we knew to focus on optimising page titles and tags rather than focus on a decision matrix.

Confluence’s Built-in Feature Set

Page Templates

Confluence’s Page Templates are an easy place to start. Begin by choosing how you want your templates to look. Here’s how we made our page template:

```plaintext
h3. Symptoms
FILL IN SYMPTOMS HERE

h3. Cause
FILL IN CAUSE HERE

h3. Resolution
FILL IN RESOLUTION HERE

{htmlcomment}
ENTER SUPPORT TICKET LINKS
{htmlcomment}
```

The {htmlcomment} macro is part of Adaptavist's Content Formatting Macros, a handy plugin.

You might consider the scaffolding plugin or Form Field Markup for filling out forms. Our support engineers are quite used to using wiki markup (we live and breathe Confluence!), so we left this template as is.

Construct a Home Page: Section, Panels, RSS, and Notifications

Check out the Confluence Knowledge Base Home. The colored content in the middle of the page is an amalgamation of panel, rss and attachment macros. Go to Tools >> Wiki Markup to see.

Wondering how we just made Tools >> Wiki Markup in a different font in the sentence above? Use the {{ ... }} notation to get the courier font, which you can use for breaking out text. And this would be, of course, a {tip}. Remember, you can visit Tools >> Wiki Markup on this page as well!

The wiki markup there is a little confusing, but it breaks down like this:

1. A `Section` macro, defining the top and bottom of the page
2. `Column` macros, dividing the panels into three
3. `Panel` macros, with hot, hot, hot html colours
4. `Content By Label` Macros
5. An RSS Icon, embedded as an attachment, with a link to the RSS feed. Notice the magic on this one:
That's a link, with the attachment as the alias, an alignment parameter, and the URL to the RSS feed. Cool, right?

Exporting Pages

These are built-in Confluence features. Check Page Exports. You can learn how to customise the PDF export as well.

Content Macros

Besides the ones listed above, some favourite macros for formatting content around the site are the Tip, Info, Warning, and Note Macros, ad the Code macro. They make things look great. We also use Adaptavist's Content Formatting Macros when we really want to bring our A-game.

JIRA Issues Macro

Using JIRA for bug tracking? You can't expect your users to necessarily have exactly the right JQL filters to show the appropriate topics. We have some nice JIRA Issues Macros on display. One of my favourites is in the JIRA KB's Causes for OutOfMemory Errors:

```text
{jiraissues:url=http://jira.atlassian.com/sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml?jqlQuery=project+%3D+PRINTER+%26+issuetype+%3D+BUG+%26+components+%3D+PERF+%22Performance+-+Memory+leaks%22+ORDER+BY+key+DESC&tempMax=200|columns=fixversion;summary;status;key|anonymous=true}
```

Notice the JQL there including components and sorting, plus the specific columns.

Labels

Sometimes, an article needs to be cross listed. For that we label our articles. Some great macros to use for this are {contentbylabel}, {listlabels} and the {dynamiccontentbylabels} macro in the Content Survey Plugin.

Next Steps

You now have a good idea of how Confluence templates work. What next? Take a look at Proactive Communications in a Knowledge Base.

Proactive Communications in a Knowledge Base

This page is part of the guide to developing a knowledge base on Confluence Wiki. We have already shown you how to create your knowledge base space and how to use templates and formatting macros. We touched a bit on creating proactive communications in Creating your Knowledge Base Space, and discuss a bit further here.

Quick guide to proactive communications

- A template is a page with predefined content that can be used as a prototype when creating other pages.
- Confluence can either produce or consume rss feeds
- Both the rss and blog-posts macro are a good way to show summaries

Proactive Alerts

Sending technical alerts to customers is a great way to keep customers and staff informed, and good way to reduce support load. At Atlassian we use the Knowledge Base both to consume and produce proactive content for which customers can opt in. This page describes how to achieve that.

Using Confluence as a producer

- The Working with Blog Posts describes how to produce blog posts from Confluence.
- E-mailing a Page is a great way to send mass emails to users or an email distribution list.

Using Confluence as a consumer

Even if your Confluence instance isn't producing your proactive content, it can consume and display it in a prominent way:
The RSS Feed Macro can consume content from any RSS feed on the Internet.
We use the Blog Posts Macro for It looks especially handsome in a panel, accentuated by an RSS image in a link. Here's the wiki markup:

```wiki
h4. Technical Alerts
[panel:title=Important Technical Alerts for Confluence|borderStyle=solid|borderColor=#ccc|titleBGColor=#f93|bgColor=#fc9]
{blog-posts:content-title|max=5|sort=modified|spaces=CONFKB|time=30d}*[View more recent blog posts|http://confluence.atlassian.com/pages/viewrecentblogposts.action?key=CONFKB]*
[!CONFKB:Confluence Knowledge Base|home^rss20.gif|align=right!|http://confluence.atlassian.com/createrssfeed.action?types=blogpost&blogpostSubTypes=comment&blogpostSubTypes=topic&topics=CONFKB]

Note that the blog posts macro can display mail! Use it to highlight mail you've sent as alerts, after archiving mail.
```

Next Steps

You now have a good idea of how to do proactive communications. Next up, consider Additional Plugins for a Knowledge Base in more detail.

Additional Plugins for a Knowledge Base

This page is part of the guide to developing a knowledge base on Confluence Wiki. This page includes additional plugins that might expand your usage.

Useful Plugins for a Knowledge Base

These are some great plugins for Confluence as a Knowledge Base:

- The Content Survey and Reporting Plugin gives a good report on popular and unpopular content.
- The Archiving Plugin flags old content.
- The Ad Hoc Workflows Plugin or Content Publishing Plugin, which manages workflows and a review process.

Note about Plugin Support

Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

Bye

Hope you enjoyed the tutorial! Have a chocolate, and please share with us your experiences. You can comment directly on this page or email us at.

Developing an Intranet on Confluence Wiki

This guide is for people who are using Confluence as a platform for an intranet. You will find this guide useful if you want to create a space where your team can collaborate and share information.

Quick guide to creating an intranet space

- Add a space.
- Set the space permissions.
- Customise the title and content of the home page.
- Subscribe to email notifications for any updates made to the space.
- Manage your existing Office documents.
- Import page templates.
- Set up your personal space.
- Publish a blog post.

The rest of this page gives more details of the above procedures.

Step 1. Add a Space

Below is a quick guide to adding a space for your team.
1. Go to the Confluence dashboard and click the 'Add Space' link.
2. The 'Create Space' screen appears. Enter a space name and a short, unique space key.
3. Leave the permission settings as default, or choose to allow only yourself to view or contribute content to this space. You can change these settings later and with more flexible options.
4. Select a theme. We recommend the 'Global Look and Feel' theme for an intranet.
5. Click 'OK' to add the space to your Confluence site.

The home page of your new space will appear. Because you created the space, you are the space administrator. Now you can do some basic configuration, as described in the sections below.

**Step 2. Set the Space Permissions**

Define the space permissions to determine who can do what in your new space.

1. Open the 'Browse' menu and select 'Space Admin'.
2. Click 'Permissions' in the left-hand navigation panel.
3. Confirm your administrator access as prompted.
4. Click 'Edit Permissions'.
5. Set the permissions to suit your needs then click 'Save All'.
   - You can add groups and/or individual users to the list, then select the permissions for each group or user.
   - You can also set the permissions for anonymous users – these are people who have not logged in to the wiki and will not count towards the number allocated by your license. Anonymous access is available only if enabled for the entire Confluence site. However, it is unlikely you will need anonymous users for your intranet.
   - Note that you can change these permissions at any time. You may want to restrict the permissions to specific groups now, and later open the space to more people.

**More about Permissions**
Confluence 4.0 Documentation

Confluence has a robust and granular permissions scheme that you can use to determine who can view, create content and comment within your intranet. There are three levels of permissions in Confluence:

- Global permissions apply across the entire site.
- Space permissions apply to a space.
- Page restrictions allow you to restrict the editing and/or viewing of a specific page.

**Space permissions** in Confluence are simple yet granular enough to be useful for an intranet. You can:

- Use the permission levels to control who can create pages, delete pages, create comments, delete comments, administer the space, and so on.
- Grant a permission level to one or more users, and/or to one or more groups, and/or to anonymous users. A space administrator has complete control.

**Terminology:**

- ‘Anonymous’ means people who have not logged in to the wiki.
- The ‘confluence-users’ group is the default group into which all new users are assigned. Everyone who can log in to Confluence is a member of this group.

For example, you might allow the ‘confluence-users’ group permission to create and edit comments, but reserve full editing rights for your team members. Let’s assume your team members are all members of the ‘dev-team’ group. The example below shows that members of the ‘dev-team’ group have all permissions except space administration, but ‘Ryan Reynolds’ only has a few editing rights.

For detailed information, see the documentation on:

- Global permissions
- Space permissions
- Page restrictions
- Users and groups

**Step 3. Customise the Title and Content of the Home Page**

When you created your space, Confluence created a home page with default content and a default title, ‘Home’. You will want to change the title and content to suit your team.
1. Go back to your space home page, by clicking the space name in the breadcrumbs at the top of the screen. In the example below, the space name is 'Development Team Space':

![View Space Permissions]

2. The space home page appears. By default, the page title is 'Home'.

![Home]

3. Click 'Edit'.
4. The page opens in edit mode. Change the title to suit your needs.

![Development Team Space]

5. Update the content to suit your needs. 
   
   Hint: If you do not know what to add yet, just add a short description. You can refine the content of the page at any time.
6. Click 'Save' to save your home page.

**Step 4. Subscribe to Email Notifications for Updates Made to the Space**

You can configure your email notifications to suit your needs: Subscribe to all blog posts from Confluence, subscribe to your network, or stay informed about any changes in a specific space. Below is a quick guide to monitoring a space's content. See [Watching a Space](#) for a full description.
1. Open the 'Browse' menu and select 'Advanced'.

2. Click 'Start watching this space' in the bottom section of the left-hand navigation panel.

If at any time you wish to stop watching the space, just click 'Stop watching this space'.

**Example of an Email Notification**

Here is an example of the email notification you will receive when someone adds a comment to a page:

![Example of an Email Notification](image)

**More about Notifications**

You can specify the notifications you want to receive on a global, space and page level. The quick guide above demonstrated how to set up notifications for a space. Now we will show you how to configure your notifications on the global and page levels.

**Global Notifications**

Global notification settings determine the overall behaviour of the notifications you receive from Confluence.
1. Open the 'User' menu (Your name) and select 'Settings'.

2. Click 'Email' in the left-hand navigation panel.
3. Click 'Edit'.
4. Change the default settings to suit your needs. You can alter these email settings at any time.
5. Click 'Submit' to save your changes.

**Page and Blog Post Notifications**

Follow the quick guide below to receive notifications from Confluence about changes to and comments on a specific page or blog post. See [Watching a Page or Blog Post](#) for a full description.

You can watch any given page or blog post that you have permission to view. We will use your space's home page as an example.
1. Open the home page of your space.
2. Open the 'Tools' menu and select 'Watch'.

You are now watching the current page and Confluence will notify you about any updates made or comments added.

Note that Confluence will **not** notify you about content changes that are due to the output of a macro. For example: The output of the *Children macro* will change if someone adds a child page. The page containing the Children macro will show the new child page. But the page content itself has not been edited, so no notifications will be sent.

You can stop watching a page or blog post at any time. Just open the page, go to the 'Tools' menu and click 'Stop Watching'.

**Step 5. Attach or Import Office Documents if Applicable**

Below are some guidelines on managing your existing Office documents in Confluence. You can choose to attach them to a Confluence page, so that team members can view and access them in Confluence. Or you can import the documents into Confluence, converting the content to wiki format.

**Attaching Office Documents to a Page**

You can use Confluence as a central repository for your team's Microsoft Office documents. This means that you can share your Office documents without having to email them to your teammates. People can view the Office documents even if they do not have Office installed on their computers.
1. Go to your space home page, by clicking the space name in the breadcrumbs at the top of the screen.
2. Hovering over the **Tools** menu and click **Attachments**.
3. Choose one of the following methods for attaching files to the page:
   - Use the 'Attachments' view's 'browse and attach' feature to attach one or more file(s):
     a. Click the 'Browse' button.
     b. Browse through your files and select the file that you would like to attach to the page.
     c. Enter a description for the attachment in the 'Comment' text field (optional).
     d. Click 'Attach more files' if required. More attachment entry fields will appear, allowing you to attach more files.
     e. Click the 'Attach' button.

   ![Attach File](image.png)

   - Alternatively, use the drag-and-drop feature to attach one or more file(s):
     Drag one or more file(s) accessible from your computer and drop them onto the 'Attachments' view. The 'Attach File(s)' message box appears, indicating the upload status of the file(s) being attached to your page.

   ![Attach File(s)](image.png)

---

**Importing Existing Word Documents into Confluence**

You can also import content from Microsoft Word into Confluence, so that it becomes a wiki page. See [Importing an Office Document into Confluence](#) for a full description.
1. Go to your space home page, by clicking the space name in the breadcrumbs at the top of the screen.
2. Open the 'Tools' menu and select 'Import Word Document'. The Office Connector import screen will appear.
3. Click the 'Browse' button and find the Office document on your local drive or network.
4. Click the 'Open' or 'Upload' button provided by your browser. The path and file name of the document will now appear in the text box on the Office Connector import screen.
5. Click the 'Next' button. The import document options screen will display.

6. Enter the following information:
   - **Root page title** – The title of the wiki page that will contain the information from your imported document.
   - **Import as a new page in the current space** – A new wiki page will be created with the page title specified above.
   - Choose what you want the importer to do if there are page title conflicts, by selecting one of the following options:
     - **Rename imported pages if page name already exists** – Confluence will assign new names to any new page which would otherwise have a duplicate name. The content of existing pages will remain unchanged.
     - **Split by heading** – Use this field to split your document into multiple wiki pages. If you do not want to split your document into multiple wiki pages, leave the default 'Don’t split' option selected.
   - **Import** to import your document.

When the upload has finished, the content of the Office document will have been transformed into Confluence page content. You can now view and edit this page in the normal way, using the Confluence Rich Text Editor or Wiki Markup. There is no connection between the original Office document and this wiki page.

**Step 6. Import Page Templates**

In order for an intranet to be effective, people need to use it. One way to spur new user adoption is to provide your team mates with templates so that they can focus more on content creation and less on page format. Confluence offers a number of templates, including a template for 'Meeting Notes' and a 'Three-Column Layout', to help your team get started populating your intranet and improving its productivity. See Importing Templates for a full description.
1. Log in to Confluence as an administrator and go to the Confluence 'Administration Console'.
2. Click 'Import Templates' in the left-hand navigation panel. The 'Import Templates' screen will appear, listing the template packages deployed to your Confluence instance (for example, 'Default Templates Package') and the templates included in each package.

<table>
<thead>
<tr>
<th>Security</th>
<th>Default Templates Package (4)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Security</td>
<td>Charts</td>
</tr>
<tr>
<td>Configuration</td>
<td>Document List</td>
</tr>
<tr>
<td>Manage Users</td>
<td>Meeting Notes</td>
</tr>
<tr>
<td>Manage Groups</td>
<td>Multimedia Content</td>
</tr>
<tr>
<td>Global Permissions</td>
<td>RSS News Feed</td>
</tr>
<tr>
<td>User Directories</td>
<td>Tasklist</td>
</tr>
<tr>
<td>Global Templates</td>
<td>Three-Column Layout</td>
</tr>
<tr>
<td>Global Templates</td>
<td>Two-Column Layout</td>
</tr>
</tbody>
</table>

3. Select the templates you want by ticking the check boxes next to the template names.
   Note: You can view a preview of the template by clicking the template name.
4. Select the import destination for the templates in the 'Import To' dropdown. If you want the templates to be available to a specific space only, select the name of the space, otherwise select 'Global Templates' to make the templates available to all spaces.
5. Click the 'Import' button to import the selected templates.

**How Users will Find Templates**

Now that you have made Confluence's templates available to your site or space, other Confluence users will be able to choose a template when they want to create a page.

**Choosing a Template from the Dashboard**

When you add a page from the Confluence dashboard, you will be able to select the template and space for the new page at the same time.
1. Go to the Confluence Dashboard by clicking 'Dashboard' from the breadcrumbs at the top left of your screen.
2. Click the 'Add Page' button. The 'Add Page' dialog appears.

![Add Page Dialog](image)

3. Select the space where you want to add the page.
4. Select the template you want to use to populate your page.

![Select Template](image)

5. Click 'Next' to create the page.

**Choosing a Template from within the Editor**

Often you will add a page from within a space, or as a child of another page. This guide shows you how to choose a template from within the Confluence editor.

1. Go to your space home page, by clicking the space name in the breadcrumbs at the top of the screen.
2. Hover over the 'Add' menu and click 'Page'. This will launch the Confluence editor.
3. To populate the editor from a template, click the 'Select a page template to start from' link below the 'Title' field. This will launch the 'Page Template Wizard'.

![New Page](image)
4. Choose a page template from those available in the list.

Step 1: Choose a page template

Please choose a template from below:

<table>
<thead>
<tr>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Charts</td>
</tr>
<tr>
<td>Document List</td>
</tr>
<tr>
<td>Meeting Notes</td>
</tr>
<tr>
<td>Multimedia Content</td>
</tr>
<tr>
<td>RSS News Feed</td>
</tr>
<tr>
<td>Tasklist</td>
</tr>
<tr>
<td>Three-Column Layout</td>
</tr>
<tr>
<td>Two-Column Layout</td>
</tr>
</tbody>
</table>

5. Click 'Next' to populate the editor with the selected template.

Step 7. Set Up your Personal Space

Now that you have created a space for your team, let's create your personal space. This is a place where you can publish your own pages and blog posts. Once you have created it, Confluence users can reach your personal space by clicking your name in the People Directory or by searching for your name via the quick navigation search box.
1. Go to your name at the top of the page and select ‘Create Personal Space’ from the dropdown list.

2. Enter a few details about your space:
   - Choose who can view content.
   - Choose who can contribute (create and edit) content.
   - Choose the ‘Global Look and Feel’ for your personal space.

3. Click the ‘Create’ button.

4. The ‘Home’ page for your new space is displayed.

**Step 8. Publish a Blog Post**

Blog posts are a good way of letting your team mates and the company know your news. People can blog about product and strategic ideas, team updates, and things they want to get ideas about. New employees can write blog posts introducing themselves. People write about getting married or the birth of a child. Blog posts are a great way for people to share their visions, get to know their coworkers and start lively discussions.

Remember to set your email notifications to alert you about the blog posts published within Confluence, as described in an earlier step.

See [Working with Blog Posts](#) for a full description of adding, editing, viewing and linking to blog posts.

1. Go to a page in your space.
2. Hover over the ‘Add’ menu and select ‘Blog Post’.
3. Change the title to suit your needs.
4. Update the content to suit your needs.
5. Click ‘Save’ to publish your blog post.

**Related Topics**

- Setting up a New Global Space
- Global Permissions Overview
- Assigning Space Permissions
- Setting a Page's Restrictions
- Users and Groups