Documentation for Confluence 4.3
# Contents

Confluence 101 ................................................. 7
Confluence User’s Guide ......................................... 10
  Getting Started with Confluence ................................. 10
    About Confluence ........................................... 11
    Dashboard .................................................. 12
    Page in View Mode ........................................ 13
    Confluence Glossary ...................................... 15
    Icons Used in Confluence ................................ 20
    Keyboard Shortcuts ....................................... 21
Creating Content ............................................... 26
Adding Pages .................................................... 26
Adding Blog Posts ............................................... 29
Using the Editor ................................................. 30
  Quick Reference Guide for the Confluence Editor .............. 35
  Working with Text Effects ................................ 47
  Working with Links ......................................... 49
    Linking to Pages ......................................... 50
    Linking to Images ........................................ 53
    Linking from an Image ................................... 54
    Linking to Attachments .................................. 55
    Linking to Blog Posts .................................... 56
    Linking to Personal Spaces and User Profiles .............. 57
  Working with Anchors ..................................... 58
  Using a Link to Create a New Email Message ................. 59
  Linking to Confluence Pages from Outside Confluence ....... 60
  Inserting JIRA Issues .................................... 60
  Trackback .................................................. 62
Displaying Images ............................................... 63
  Working with Tables ...................................... 67
  Using Symbols, Emoticons and Special Characters ............ 69
  Using Autocomplete ...................................... 71
Working with Page Layouts and Columns and Sections ........... 75
Working with Macros .......................................... 79
  Anchor Macro .............................................. 84
  Attachments Macro ......................................... 84
  Blog Posts Macro .......................................... 84
  Change-History Macro ..................................... 88
  Chart Macro ................................................ 89
  Cheese Macro .............................................. 101
  Children Display Macro .................................... 101
  Code Block Macro ......................................... 104
  Column Macro .............................................. 106
  Content by Label Macro ................................... 106
  Content by User Macro .................................... 110
  Contributors Macro ....................................... 111
  Contributors Summary Macro ................................ 114
  Create Space Button Macro ................................ 119
  Details Summary Macro ................................... 120
  Excerpt Include Macro .................................... 121
  Excerpt Macro ............................................. 122
  Expand Macro .............................................. 124
  Favourite Pages Macro .................................... 124
  Gadget Macro ................................................ 125
  Gallery Macro .............................................. 127
  Global Reports Macro ..................................... 130
  HTML Include Macro ...................................... 131
Configuring the Easy Reader Theme ................................................... 427
Changing a Space's Logo ................................................................. 429
Changing the Confluence Browser Icon, aka favicon ......................... 430
Customising Space Layouts ............................................................... 431
Editing a Space's Colour Scheme ......................................................... 432
Styling Confluence with CSS .............................................................. 434
  Basic Styling Tutorial ........................................................................ 436
  Styling Fonts in Confluence ............................................................... 438
  Styling Tabs in Confluence ............................................................... 439
  Using CSS to Customise the Easy Reader Theme .............................. 442
Giving People Access to Content .......................................................... 443
  Page Restrictions ............................................................................. 445
  Setting a Page's Restrictions ............................................................. 449
  Viewing a Page's Restrictions ............................................................ 450
  Viewing Restricted Pages ................................................................. 451
Site Administrators and their Permissions .......................................... 452
  Contacting Confluence Administrators ............................................. 452
Space Administrators and their Permissions ........................................... 453
  Space Permissions Overview ............................................................ 454
  Assigning Space Permissions ........................................................... 454
Users and Groups ............................................................................. 457
  Searching for Users ......................................................................... 458
Using Confluence on a Mobile Device ................................................... 461
  Notes about Confluence Mobile ....................................................... 465
Advanced and Special Uses of Confluence .............................................. 467
  Working with Confluence Markup .................................................... 467
    Confluence Storage Format ............................................................. 468
    Confluence Storage Format for Macros .......................................... 501
    Confluence Storage Format Examples for Chart Macro .................... 551
    Confluence Wiki Markup .............................................................. 569
    Confluence Wiki Markup for Macros .............................................. 578
    Wiki Markup Examples for Chart Macro ......................................... 620
  Working with Confluence Gadgets ...................................................... 626
    Adding a Confluence Gadget to a JIRA Dashboard ............................ 628
    Configuring Confluence Gadgets for Use in Other Applications ...... 632
    Confluence Gadgets ..................................................................... 636
      Activity Stream Gadget ................................................................. 637
      Confluence News Gadget .............................................................. 639
      Confluence Page Gadget ............................................................... 640
      Confluence Quicknav Gadget ....................................................... 644
    Adding JIRA Gadgets to a Confluence Page ................................... 645
  Developing Technical Documentation on Confluence Wiki ................. 645
    Creating your Technical Documentation Space ................................ 645
    Using Templates in Technical Documentation .................................. 654
    Re-using Content in Technical Documentation ................................ 656
    Managing the Life Cycle of your Technical Documentation ............... 662
    Providing PDF Versions of your Technical Documentation ............... 668
    Exporting and Printing Technical Documentation ............................ 673
    Essential Confluence Features for Technical Documentation ............ 676
    Confluence Plugins for Technical Documentation ............................ 686
    Further Reading about Developing Technical Documentation on Confluence 693
  Developing a Knowledge Base on Confluence Wiki ............................ 694
    Creating Your Knowledge Base Space ............................................. 694
    Using Templates and Formatting Macros in a Knowledge Base ......... 710
    Proactive Communications in a Knowledge Base ............................... 712
    Additional Plugins for a Knowledge Base ....................................... 713
  Developing an Intranet on Confluence Wiki ....................................... 713

Creative Commons Attribution 2.5 Australia License.
Confluence 101

We are delighted that you have chosen Confluence. This guide will take you through installing Confluence and trying out the most relevant features.

Getting started

1. Installing Confluence

If you have not already got Confluence up and running, carry out the following steps:

- **For Windows: (click to expand)**
  1. Go to the [Confluence download page](#).
  2. Download the Confluence Windows Installer file for 32-bit or 64-bit Windows.
  3. Run the installer, choose an installation directory, a home directory, and a port (‘8090’ will do). We recommend that, when prompted, you choose to install Confluence as a service.
  4. Confluence will start automatically when the installer finishes. The installer will also add Windows ‘Start’ menu shortcuts which you can use to start and stop Confluence.
  5. To access Confluence, go to your web browser and type this address: [http://localhost:8090](#).
  6. Follow the [Setup Wizard](#). This will guide you through the process of setting up your Confluence server and creating an administrative user.

For more help on the technical procedures in this section, see the [Confluence Installation Guide](#).

If you need assistance, please [create a support ticket](#).

- **For Linux/Solaris: (click to expand)**
  Download the Confluence Linux Installer (.BIN) file from the [Confluence download page](#), and follow the instructions. The [Setup Wizard](#) will guide you through the process of setting up your Confluence server and creating an administrative user.

If you need assistance, please [create a support ticket](#).

2. Importing existing content

**Why would I do this? (click to expand)**

The best way to spur adoption is to get some content in Confluence. It is likely that you have existing documentation stored in another wiki or in static documents. Confluence makes it easy to import your existing content so that you do not have to re-invent the wheel or start from scratch.

**How do I do this? (click to expand)**

Refer to our documentation on [Importing Content Into Confluence](#), for details on:

- Importing content from other Confluence sites
- Importing content from other wikis.
- Importing content from an Office document
- Importing web content
- Importing other non-wiki content

3. Adding users

Add people so that they can collaborate quickly.

**Add users and/or enable anonymous access. Click here**
to expand...
1. **Add or invite users** — add user accounts for the people who will create the pages and blog posts in your Confluence site, or send people invitations to sign up themselves.
2. (Optional) **Add users to groups** — your users will be automatically added to the 'confluence-users' group. You can add them to other groups too.
3. (Optional) **Set up public access** — allow non-logged-in users to access your Confluence site. Note that they will only be able to view content where the space permissions allow 'Anonymous' access.

4. **Configuring mail**

Confluence can send notifications based on user preferences, such as when people are watching the contributions to a particular space or page. To take advantage of this feature, you will first need to tell Confluence about your SMTP server.

5. **Mastering the basics**

Your users will need to access Confluence at `http://<Confluence site name>:8090` (not `http://localhost:8090`).

6. **Creating spaces, pages and blog posts**

Your new Confluence site contains a 'Demonstration' space, which includes a tutorial. This will guide you through the basics of using the dashboard, creating a space, adding pages and publishing blog posts.

7. **Searching Confluence**

- Searching Confluence
- Advanced search
- Searching the content of attachments

8. **Subscribing to updates**

- Creating an RSS feed.
- Watching a page (or space) to be emailed whenever it is edited.
- Marking your favourite places so you can get to them quickly.

9. **Customising Confluence**

You need Confluence Administrator permissions to do the tasks in this section. see [Global Permissions Overview](#).

10. **Adding your own logo**

   - **Why would I do this? (click to expand)**
     If you replace the default Confluence logo with your organisation's logo, your Confluence site will immediately appear more familiar to visitors.

   - **How do I do this? (click to expand)**
     See the following documentation:
     - Changing the Confluence-wide 'global' logo
     - Changing a space's logo

11. **Changing Confluence's colours**
Why would I do this? (click to expand)
If you replace the default Confluence colours with your organisation's standard colours, your Confluence site will immediately appear more familiar to visitors.

How do I do this? (click to expand)
See the following documentation:
- Customising Confluence's colour scheme
- Styling Confluence via CSS

10. Choosing a different theme

Why would I do this? (click to expand)
Depending on what you are using Confluence for, you may want to alter the theme for an individual space or for the entire site. A theme determines the look and feel of the site, including colours, styles and page layouts. For example, for a space that contains documentation, you may prefer a theme that displays a table of contents on the left and allows you to configure a page header and footer.

How do I do this? (click to expand)
See the following documentation:
- Applying a theme to a site
- Applying a theme to a space

11. Using a page template

Why would I do this? (click to expand)
A page template is a form that is displayed when a user creates a page, so that the user can enter content in particular fields. A page template can be made available to your entire Confluence site or just to a particular space. For example, a human resources space might have a template called 'Leave Request', or an information technology space might have a template called 'Asset Configuration'.

How do I do this? (click to expand)
See the following documentation: Adding a template

12. Installing plugins

Why would I do this? (click to expand)
There are hundreds of new features and customisations available for Confluence as plugins. For example, many additions to Confluence's macros are available as plugins. Take a look at our most popular plugins.

How do I do this? (click to expand)
Confluence comes with a number of bundled plugins. You can install others via the Confluence administration screens.

Important next steps
You need Confluence Administrator permissions to do the tasks in this section. see Global Permissions Overview.

13. Connecting to an external database
Before using Confluence as a production system, you need to switch from the default HSQL database, which is
provided for evaluation purposes only. Please see the documentation for details.

14. Backing up data

To back up your Confluence data, and establish processes for regular backups, please see the documentation.

We hope you have fun with Confluence

We're always happy to help. Feel free to contact us with any questions you have.

Confluence User's Guide

About this document

The Confluence user's guide begins with an overview of the key features of Confluence, and goes on to describe the use of Confluence as a knowledge management tool and a collaborative environment. If you still have a question that has not been answered, please ask us.

This guide assumes that your Confluence site uses the default theme. If your site's theme has been customised, then your site may look different and the menu items may appear in different locations from those in this guide.

For more documentation please visit Confluence Documentation Home.

Download

You can download the Confluence documentation in PDF, HTML and XML formats.

Getting Started with Confluence

Creating Content

Sharing Content

Managing Changes and Notifications and Tasks

Searching Confluence

Organising Content

Customising Confluence

Giving People Access to Content

Getting Started with Confluence
About Confluence

Confluence is a wiki. You can use it to collaborate on writing and sharing content with your team. Your team can be as small or as big as you like. It could encompass the whole world. Your content can be as simple or as rich as you like. It can be just words, or you can add images, diagrams, activity streams, web service integration and more.

In a nutshell, a wiki is a piece of software that runs on a server. It publishes web pages that you can read via a web browser such as Mozilla Firefox, Google Chrome or Microsoft Internet Explorer. The thing that makes wiki pages different from other web pages is the edit button. Provided that you have the right permissions, you can edit the page, save your changes, and the updates will be visible to other people immediately.

Confluence provides extra functionality that transforms it into a social collaboration platform:

- Add a space for your team, then add page or comment on someone else’s page.
- Share content by writing a blog post, sharing a link or calling someone's attention to a page via @mention. Form a social network and tell people what you are doing via a status update.
- Add images, picture galleries, videos and more.

Related pages:
- Getting Started with Confluence
- Confluence Documentation Home
Dashboard
The dashboard is the front page of a Confluence site. It provides an overview of the site, gives access to all spaces that you have permission to view, and displays a few different lists of the most recently updated content.

You can go to the dashboard from anywhere in your site by clicking Dashboard at the top left of the page. (By default, the first link at the top left of the page is named ‘Dashboard’. If your administrator has customised your site, the link may say something else. For example, ‘Documentation’.)

Overview of the dashboard
The dashboard is divided into three sections:

- **Welcome message**: The information that appears in the top left section of the dashboard. Confluence Administrators can customise this message.

- **Spaces, Pages, Network**: Tabs displaying your favourite content and people, displayed in the lower left section of the dashboard.
  - **Spaces** displays the spaces you have marked as favourites, followed by all the spaces that you have permission to view.
  - **Pages** displays the pages you have marked as favourites.
  - **Network** displays the users that you are following (or who are following you).

- **Recent activity**: Tabs on the right-hand section of the dashboard, displaying recently-updated content that is Popular, in All spaces, in your Favourite spaces, updated by people in your Network, or classified by space Categories.
  - **Popular** displays content that has been recently created, liked or commented on. See below for more details.
  - **All Updates** displays updates from all spaces that you have permission to view.
  - **Favourite Spaces** displays updates from your favourite spaces.
  - **Network** displays the users that you are following (or who are following you).
  - **Space Categories** displays updates from spaces in the category you have selected from the list.

On this page:
- Overview of the dashboard
- More about popular content
- Notes

Related pages:
- Confluence Glossary
- Icons Used in Confluence
- Working with Spaces
- Confluence User's Guide

Screenshot: The dashboard
More about popular content

The ‘Popular’ tab on the dashboard displays recent activity of the following types:

- Pages, blog posts and comments that people have recently **liked**.
- Pages and blog posts that people have recently **commented** on, and threaded comments that people have recently replied to.
- Pages and blog posts that have recently been **created**.

‘Recent’ means any activity in the last seven days.

A **bold** link means that you have not yet visited the page.

The activities are listed in order of popularity, with the most popular at the top. Likes, comments and content creations are scored equally. Activity that involves people in your network ranks higher than activity not involving your network. The most recent activity ranks higher than earlier activity.

**Notes**

- If you have the right permission, you can [add a new space](#) from the dashboard. Click **Add Space** at the top right of the dashboard, or on the ‘Spaces’ tab.
- By default, the dashboard is the home page for the Confluence site. However, you can set any other page in Confluence as your home page using your **user profile** settings.
- Administrators can [customise the global dashboard](#) that all users see.
- Users can [customise the dashboard](#) for themselves.
- There are quick **Add Page** and **Add Blog Post** buttons at the top right of the dashboard. If you have ‘Confluence Administrator’ or ‘System Administrator’ **permissions**, you will also see an **Add Users** button.
- If you have permission to create spaces, you will also see an **Add Space** button.
- Click **view change** beside a page name to see a comparison of the current and previous versions of the content.
- Are you looking for a way to build an **RSS feed**? Choose **Browse > Feed Builder**.
- Are you looking for a list of the **people** in your site? Choose **Browse > People Directory**.

**Page in View Mode**

The image below shows the menus and other controls on a typical Confluence page.
Related pages:

- Using the Editor
- Overview of Spaces
- Overview of Pages
- Sharing Content
- Confluence User's Guide

Menu or option | Explanation
--- | ---
Byline | Shows the original author and the most recent editor of the page, and the date of the most recent edit.
Byline icons | A small padlock indicates page restrictions. A paperclip indicates that the page has attachments. Both icons are clickable, leading to the 'Page Information' and 'Attachments' pages, respectively.
Browse | Gives access to wiki content such as pages, blog posts, and the directories of people and spaces. If you are an administrator of the space or the site, the administration options appear here too.
User | After you have logged in, your name will appear at top right of the screen. When you choose your name, the user menu drops down with options to log out, access your user profile, or view your editing history, personal labels and page watches. You can also retrieve drafts of pages you are editing.
Notification-and-task dialog

View and respond to notifications collected from Confluence page watches, shares and mentions. Manage your personal tasks.

Search

Type into this box to see a list of matching pages. Select a page to go directly to it, or press Enter to see the full Confluence search.

Tools

Miscellaneous actions relating to the page.

Edit

Edit the current page. (Shortcut: press e on your keyboard.)

Share

Email a link to the current page to another Confluence user or email address.

Labels

View and edit labels (tags) attached to the current page. (Shortcut: press l on your keyboard.)

Add

Add things to a page, or add new a new page or blog post to the space.

Like

Choose this option to let people know that you like this page.

Add a comment

Click in the text box to begin writing a comment. (Shortcut: press m on your keyboard.)

Confluence Glossary

Administration Console

The Administration Console is the interface for the global administration of Confluence.

Only administrators can access the Administration Console.

Administrators

The Confluence permission scheme allows the following main levels of administrator permissions:

- System Administrator – full administrative access to Confluence.
- Confluence Administrator – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

CamelCase

CamelCase is a form of markup commonly used in wikis where words compounded together LikeThis without spaces are used to create links.

In Confluence, Camelcasing can be turned on from the Administration Console.
**Change Comment**

A change comment is a short description entered during the edit of a page to record the changes being made in the edit.

---

**Child Pages**

Creating child pages is a means of hierarchically organising content in Confluence. A child page can only have one parent page.

---

**Comments**

A comment may be a remark, question, or any other additional information you wish to add to a page pertaining to the topic the page covers. You can comment on any page or news item in Confluence.

---

**Confluence Administrators**

The Confluence permission scheme allows the following main levels of administrator permissions:

- System Administrator – full administrative access to Confluence.
- Confluence Administrator – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

---

**Custom Decorators**

Decorator files are used to define layouts in Confluence. They are vmd files and require knowledge of the language, Velocity, to edit.

---

**Dashboard**

The dashboard is the front page of a Confluence site. It provides an overview of the site, access to all spaces, and displays a list of the most recently updated content within them.

---

**Form Field Markup**

Form field markup is a specialised markup used when creating page templates in Confluence 4.2 and earlier. It is no longer needed, because the template editor offers form fields as an option in the editor toolbar.

---

**Global Administrators**

A global administrator is the same as a system administrator.

---

**Global Spaces**

Global spaces contain content on any theme or topic of your choice.

For more information about global spaces and personal spaces, see Working with Spaces.

---

**Hover Profile**
The hover profile is the pop-up you see when the mouse pointer pauses over a Confluence user’s name. Use the hover profile to follow the user, visit their profile, and more.

---

**JIRA**

JIRA is Atlassian’s award winning Issue tracking and project management application.

Visit Atlassian’s website to learn more about JIRA.

---

**Labels**

Labels are user-defined tag words assigned to pages to categorise content in Confluence.

---

**Macros**

A macro is a command wrapped inside curly braces {...} used to perform programmatic functions and generate more complex content structures in Confluence.

---

**Blog Posts**

A blog post may be a journal entry, status report or any other timely information pertaining to a space.

---

**Notifications**

A notification is an email message sent to you updating you of changes to pages and spaces you choose to 'watch'.

---

**Orphaned Pages**

An orphaned page is a page without any incoming links.

---

**Pages**

Pages are the primary means of storing information in Confluence and are the building blocks of spaces.

---

**Parent Page**

A parent page is a page that has one or more child pages. It may itself be a child of another page.

---

**People Directory**

The People Directory contains a list of all users in your Confluence site. Each user’s name links to their personal space.

---

**Permalink**

A permalink is the url used to link to specific content items like comments.

---

**Personal Spaces**
Personal spaces belong to particular users, and rather than being listed on the Dashboard, are available from the People Directory.

For more information about global spaces and personal spaces, see Working with Spaces.

---

**RSS Feeds**

An RSS feed is a format for delivering summaries of regularly changing web content. RSS is read by RSS newsreader programs.

You will need an RSS reader to subscribe to feeds within Confluence.

Confluence acts as an RSS reader for feeds from sites outside of Confluence.

---

**RSS Reader**

An RSS reader is a specialised RSS program (also called aggregator) that displays the contents of RSS feeds for you. To subscribe to RSS feeds within Confluence, you will need an RSS reader.

---

**Site Administrators**

The Confluence permission scheme allows two levels of administrator permissions:

- System Administrator – full administrative access to Confluence.
- Confluence Administrator – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

---

**System Administrators**

The Confluence permission scheme allows two levels of administrator permissions:

- System Administrator – full administrative access to Confluence.
- Confluence Administrator – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

---

**Space Administrators**

A space administrator is a user with the ‘Space Admin’ permission for the space. A user with this permission can perform a host of functions relating to the management of a space and has complete access to the space regardless of any other control settings or permissions.

Permissions for a space are only assigned and modified by space administrators.

---

**Spaces**

A space is an area within Confluence, containing your wiki pages. You can think of each space as a sub-site, or mini-site, each with its own home page.

There are two types of spaces: global spaces and personal spaces.
**Templates**

A template is a pre-defined page that can be used as a prototype when creating pages. Templates are useful for giving pages a common style or format.

**Themes**

Themes are pre-defined 'look and feel' styles which are configured from the administration menu and can be applied across Confluence or to a single space.

** Thumbnails**

As of Confluence 4.0, all images on the page that aren't links are displayed as thumbnails: when you click on an image the full-size image is displayed in a pop-up.

**Tiny links**

A tiny link is the shortened url of a page which is useful when sending links to the page, for example, via email.

**Trackback**

Trackback is a mechanism by which two sites can stay informed each time one site refers to the other by means of trackback 'pings'.

In Confluence, Trackback is enabled from the Administration Console.

**Trackback Autodiscovery**

Trackback autodiscovery is a block of code that can be placed in a web-page to describe where trackback pings should be sent for that page. You can read the technical specification for autodiscovery here.

When Trackback is enabled, Confluence uses Trackback Autodiscovery to ping pages that are linked to, and to advertise its own pages as being able to receive pings.

**Undefined Links**

An undefined link is a link to a page that has not yet been created. Clicking on the page link allows you create the page.

**User Profile**

Every user account in Confluence is linked to a profile that contains user related information and options to configuring user preferences.

**Watching a Page or Blog Post**

When you watch a page, you are sent an email notification whenever that page has been modified.

**Watching a Space**

When you watch a space, you are sent an email notification whenever content has been added or modified in
that space.

Wiki

Pioneered by Ward Cunningham, and named after the Hawaiian word for 'quick', a wiki is a website that makes it easy for anyone to contribute pages, and link them together.

Wiki Markup

This is the markup used to write and edit page templates in Confluence.

Related Topics

Icons Used in Confluence

Take me back to Confluence User's Guide

Icons Used in Confluence

Confluence uses icons on various pages and screens, to provide quick links and indicators. This page lists the most frequently used icons and their meaning.

If you are looking for information about adding icons to your page, see Using Symbols, Emoticons and Special Characters.

<table>
<thead>
<tr>
<th>Related pages:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dashboard</td>
</tr>
<tr>
<td>Confluence Glossary</td>
</tr>
<tr>
<td>Using Symbols, Emoticons and Special Characters</td>
</tr>
<tr>
<td>Confluence User's Guide</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Indicates that restrictions apply to the current page. Click to see the restrictions and edit them.</td>
<td></td>
</tr>
<tr>
<td>Indicates that there are attachments to the current page. Click to open the 'Attachments View'.</td>
<td></td>
</tr>
<tr>
<td>Go to the people directory.</td>
<td></td>
</tr>
<tr>
<td>View a user profile.</td>
<td></td>
</tr>
<tr>
<td>Go to a personal space.</td>
<td></td>
</tr>
<tr>
<td>Go to a global space.</td>
<td></td>
</tr>
<tr>
<td>View a space's homepage.</td>
<td></td>
</tr>
<tr>
<td>View a page.</td>
<td></td>
</tr>
<tr>
<td>Add a page.</td>
<td></td>
</tr>
<tr>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="icon" alt="Add a child page" /></td>
<td>Add a <a href="#">child page</a> to the current page.</td>
</tr>
<tr>
<td><img src="icon" alt="View a blog post" /></td>
<td>View a <a href="#">blog post</a>.</td>
</tr>
<tr>
<td><img src="icon" alt="This page has been edited" /></td>
<td>This page has been <a href="#">edited</a> since you last viewed it. Click to view the page.</td>
</tr>
<tr>
<td><img src="icon" alt="View a comment" /></td>
<td>View a <a href="#">comment</a>.</td>
</tr>
<tr>
<td><img src="icon" alt="View a piece of archived mail" /></td>
<td>View a piece of archived mail that has been imported into Confluence.</td>
</tr>
<tr>
<td><img src="icon" alt="View a page that has been imported" /></td>
<td>View a page that has been <a href="#">imported</a> into Confluence.</td>
</tr>
<tr>
<td><img src="icon" alt="View an attachment" /></td>
<td>View an <a href="#">attachment</a>.</td>
</tr>
<tr>
<td><img src="icon" alt="This page/space/person is currently a favourite" /></td>
<td>This page/space/person is currently a <a href="#">favourite</a>. Click to remove from your favourites.</td>
</tr>
<tr>
<td><img src="icon" alt="Add this page, space or person to your favourites" /></td>
<td>Add this page, space or person to your <a href="#">favourites</a>.</td>
</tr>
<tr>
<td><img src="icon" alt="You are currently watching this page or space. Click to stop watching." /></td>
<td>You are currently <a href="#">watching</a> this page or space. Click to stop watching.</td>
</tr>
<tr>
<td><img src="icon" alt="Start watching this page or space." /></td>
<td>Start <a href="#">watching</a> this page or space.</td>
</tr>
<tr>
<td><img src="icon" alt="Subscribe to a pre-defined RSS feed." /></td>
<td>Subscribe to a pre-defined <a href="#">RSS</a> feed.</td>
</tr>
<tr>
<td><img src="icon" alt="Export the contents of this space to PDF, HTML and XML." /></td>
<td>Export the contents of this space to <a href="#">PDF</a>, <a href="#">HTML</a> and <a href="#">XML</a>.</td>
</tr>
<tr>
<td><img src="icon" alt="Define labels." /></td>
<td>Define <a href="#">labels</a>.</td>
</tr>
<tr>
<td><img src="icon" alt="Choose a space’s theme." /></td>
<td>Choose a space’s <a href="#">theme</a>.</td>
</tr>
<tr>
<td><img src="icon" alt="Choose a space’s colour scheme." /></td>
<td>Choose a space’s <a href="#">colour scheme</a>.</td>
</tr>
<tr>
<td><img src="icon" alt="Define a layout for a space, its pages and/or blog posts." /></td>
<td>Define a <a href="#">layout</a> for a space, its pages and/or blog posts.</td>
</tr>
<tr>
<td><img src="icon" alt="View space permissions." /></td>
<td>View <a href="#">space permissions</a>.</td>
</tr>
<tr>
<td><img src="icon" alt="View page permissions." /></td>
<td>View <a href="#">page permissions</a>.</td>
</tr>
<tr>
<td><img src="icon" alt="Manage watchers." /></td>
<td>Manage <a href="#">watchers</a>.</td>
</tr>
</tbody>
</table>

**Keyboard Shortcuts**

Confluence provides a number of keyboard shortcuts that you can use to speed up your editing and viewing. This page describes the keyboard shortcuts for the English language. The shortcut keys (letters of the alphabet) may be different in other languages.

**Hint:** Confluence can display a list of available keyboard shortcuts. There are a few ways to see this keyboard
shortcuts dialog:

- Choose **Browse > Keyboard Shortcuts**.
- When viewing a page, press Shift+?.
- In the editor, choose the question mark icon on the editor toolbar.

The keyboard shortcuts dialog shows the following information:

- **General** – global, page and blog post shortcuts.
- **Editor** – text editing and formatting shortcuts.
- **Editor Autoformatting** – wiki markup and autoformatting shortcuts.

---

### On this page:

- **Keyboard shortcuts**
  - **All screens**
  - **Editor**
  - **Tables in the editor**
  - **Autocomplete in the editor**
  - **View screen**
  - **Workbox**
- **Disabling and re-enabling keyboard shortcuts**
- **Notes**

### Related pages:

- **Using Autocomplete**
- **Confluence User's Guide**

---

### Keyboard shortcuts

The first section below describes the keyboard shortcuts that are available on all Confluence screens. Subsequent sections describe the shortcuts specific to each type of screen.

Please note, for Safari on OSX please substitute 'control' for 'Cmd' in the shortcuts below.

### All screens

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>/</td>
<td>Enable the quick search</td>
<td>/</td>
</tr>
</tbody>
</table>
| Ctrl+s  | - Submit (where a form is active).  
          - Editor -- save the Confluence page.  
          - Outside the editor -- save the browser page. | Cmd+s     |
<p>| g then d| Go to the dashboard | g then d |
| g then s| Browse the current space | g then s |
| ?       | Open the Keyboard Shortcut help | ?        |</p>
<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctr+0</td>
<td>Apply the paragraph style.</td>
<td>Cmd+0</td>
</tr>
<tr>
<td>Ctr+(1–6)</td>
<td>Apply a heading level (of the number chosen) to the current line.</td>
<td>Cmd+(1–6)</td>
</tr>
<tr>
<td>Ctr+7</td>
<td>Apply the preformatted style.</td>
<td>Cmd+7</td>
</tr>
<tr>
<td>Ctr+8</td>
<td>Apply the block quote style.</td>
<td>Cmd+8</td>
</tr>
<tr>
<td>Ctrl+Shift+a</td>
<td>Open the Macro Browser.</td>
<td>Cmd+Shift+a</td>
</tr>
<tr>
<td>Ctrl+B</td>
<td>Make the selected text <strong>bold</strong>.</td>
<td>Cmd+b</td>
</tr>
<tr>
<td>Ctrl+Shift+b</td>
<td>Format text as a bulleted list.</td>
<td>Cmd+Shift+b</td>
</tr>
<tr>
<td>Ctrl+Shift+d</td>
<td>Insert wiki markup. (Opens the Wiki Markup dialog.)</td>
<td>Cmd+Shift+d</td>
</tr>
<tr>
<td>Ctrl+Shift+e</td>
<td>Preview the page you are editing.</td>
<td>Cmd+Shift+e</td>
</tr>
<tr>
<td>Ctrl+Shift+f</td>
<td>Toggle full screen mode.</td>
<td>Cmd+Shift+f</td>
</tr>
<tr>
<td>Ctr+i</td>
<td>Make the selected text <em>italic</em>.</td>
<td>Cmd+i</td>
</tr>
<tr>
<td>Ctrl+Shift+j</td>
<td>Insert a JIRA issue. (Opens the Insert JIRA Issue dialog.)</td>
<td>Cmd+Shift+j</td>
</tr>
<tr>
<td>Ctrl+k</td>
<td>Insert a link. (Opens the Insert Link dialog.)</td>
<td>Cmd+k</td>
</tr>
<tr>
<td>Ctrl+Shift+k</td>
<td>See a list of suggested pages or other locations to link to from your page. More about autocomplete...</td>
<td>Cmd+Shift+k</td>
</tr>
<tr>
<td>Ctrl+m</td>
<td>Insert an image. (Opens the Insert Image dialog.)</td>
<td>Cmd+m</td>
</tr>
<tr>
<td>Ctrl+Shift+m</td>
<td>See a list of suggested images, documents and other files to embed in your page. More about autocomplete...</td>
<td>Cmd+Shift+m</td>
</tr>
<tr>
<td>Ctrl+Shift+n</td>
<td>Format text as a numbered list.</td>
<td>Cmd+Shift+n</td>
</tr>
<tr>
<td>Ctrl+s</td>
<td>Save the page you are editing.</td>
<td>Cmd+s</td>
</tr>
<tr>
<td>Ctrl+Shift+s</td>
<td>Format text with a strike through.</td>
<td>Cmd+Shift+s</td>
</tr>
<tr>
<td>Ctrl+u</td>
<td>Make the selected text underlined.</td>
<td>Cmd+u</td>
</tr>
<tr>
<td>Ctrl+y</td>
<td>Revert an action that was undone.</td>
<td>Cmd+y</td>
</tr>
<tr>
<td>Ctrl+z</td>
<td>Undo the most recent action.</td>
<td>Cmd+z</td>
</tr>
<tr>
<td>Tab</td>
<td>Indent current line (only in bulleted lists and numbered lists).</td>
<td>Tab</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>‘Outdent’ current line (only in bulleted lists and numbered lists).</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Shift+Enter</td>
<td>Force a line break without a paragraph break. This is a line break with no extra space.</td>
<td>Shift+Enter</td>
</tr>
<tr>
<td>[ then ]</td>
<td>Start a list of tasks. More about tasks...</td>
<td>[ then ]</td>
</tr>
</tbody>
</table>

### Tables in the editor

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+c</td>
<td>Copy the current table row.</td>
<td>Cmd+Shift+c</td>
</tr>
<tr>
<td>Ctrl+Shift+i</td>
<td>Insert a table. (Opens the Insert Table dialog.)</td>
<td>Cmd+Shift+i</td>
</tr>
<tr>
<td>Ctrl+Shift+v</td>
<td>Paste the current table row.</td>
<td>Cmd+Shift+v</td>
</tr>
<tr>
<td>Ctrl+Shift+x</td>
<td>Cut the current table row.</td>
<td>Cmd+Shift+x</td>
</tr>
<tr>
<td>Alt+Up Arrow</td>
<td>Add a row above the current row.</td>
<td>Alt+Up Arrow</td>
</tr>
<tr>
<td>Alt+Down Arrow</td>
<td>Add a row below the current row.</td>
<td>Alt+Down Arrow</td>
</tr>
</tbody>
</table>

### Autocomplete in the editor

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>[</td>
<td>See a list of suggested pages or other locations to link to from your page.</td>
</tr>
<tr>
<td>!</td>
<td>See a list of suggested images, multimedia files and documents to embed in your page.</td>
</tr>
<tr>
<td>{</td>
<td>See a list of suggestions as you begin typing a macro name.</td>
</tr>
</tbody>
</table>
See a list of suggested users to mention.

See more about using autocomplete.

View screen

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>b</td>
<td>Create a blog post.</td>
<td>b</td>
</tr>
<tr>
<td>c</td>
<td>Create a child page of your current page.</td>
<td>c</td>
</tr>
<tr>
<td>e</td>
<td>Edit a page or blog post, or return to Edit mode when previewing.</td>
<td>e</td>
</tr>
<tr>
<td>k</td>
<td>Open the Link To dialog.</td>
<td>I</td>
</tr>
<tr>
<td>l</td>
<td>Add or edit labels.</td>
<td>I</td>
</tr>
<tr>
<td>m</td>
<td>Add a comment to a page or blog post.</td>
<td>m</td>
</tr>
<tr>
<td>s</td>
<td>Share the current page</td>
<td>s</td>
</tr>
<tr>
<td>t</td>
<td>View attachments.</td>
<td>t</td>
</tr>
<tr>
<td>v</td>
<td>Return to page view (only if you are viewing page attachments).</td>
<td>v</td>
</tr>
<tr>
<td>w</td>
<td>Add or edit watchers.</td>
<td>w</td>
</tr>
</tbody>
</table>

Workbox

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>g then n</td>
<td>Open the Confluence workbox.</td>
</tr>
<tr>
<td>j</td>
<td>Move down to the next entry in the notification list.</td>
</tr>
<tr>
<td>k</td>
<td>Move up to the previous entry in the notification list.</td>
</tr>
<tr>
<td>n</td>
<td>Move down to the next notification for a particular page or blog post.</td>
</tr>
<tr>
<td>p</td>
<td>Move up to the previous notification for a particular page or blog post.</td>
</tr>
<tr>
<td>Enter</td>
<td>Open the selected notification.</td>
</tr>
<tr>
<td>u</td>
<td>Return to the notification list after opening a particular notification.</td>
</tr>
</tbody>
</table>

Note: The keyboard shortcuts are available for notifications only, not for tasks, inside the Confluence workbox.

See more about managing notifications and tasks.
Disabling and re-enabling keyboard shortcuts

Keyboard shortcuts are enabled by default. You can disable general keyboard shortcuts. You cannot disable the editor keyboard shortcuts.

To disable or re-enable general keyboard shortcuts:

1. Choose Browse > Keyboard Shortcuts (or press the key combination Shift+?).
2. Choose the General tab.
3. Select or clear the Enable General Shortcuts check box as required.

Notes

- **Note about supported web browsers**: Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. You can find the list of supported web browsers and browser versions on this page: [Supported Platforms](#).
- The keyboard shortcuts dialog also displays the trigger characters for the Confluence autocomplete feature. See [Using Autocomplete](#).
- Confluence keyboard shortcuts are consistent with [JIRA keyboard shortcuts](#).

Creating Content

You can create the following types of content in Confluence:

- [Pages](#)
- [Blog posts](#)
- [Comments](#)

For each of these, you use the editor to enter and format the text, and to embed content, or add links to other pages.

When you first create the page, you can choose a [template](#) that the page should be based on.

When you first save the page, you can choose where the page should be located.

You can also import content into Confluence from a variety of other sources.

**Related pages**

- [Organising Content](#)
- [Managing Users](#)

Take me back to the [Confluence User's Guide](#).

Adding Pages

The usual ways to add a page are described below.

Once you have created a page, you can:

- add content to it using the editor
- set the page's location in the Confluence site, even before you save the page.

You can always move the page to a different location in the page tree, or to a different space, after you have saved the page.

You may like to read about [writing blog posts](#).

**A note about permissions**: To create a page, you need the 'Create Pages' permission for that space, which is
assigned by a space administrator from the Space Administration screens. See space permissions or contact a space administrator for more information.

On this page:
- Adding a page from the dashboard
- Adding a page from any page in a space
- Adding a page using an undefined link
- Setting Page Location
- Importing an Office Document into One or More Confluence Pages
- Related Topics

Adding a page from the dashboard

You can add a page from the dashboard without having to browse to a specific space. Confluence adds the new page at the root of the space.

To add a new page from the dashboard:

1. Click Add Page at the top right of the dashboard.
2. Select the space where you want to add the page and choose a template on which to base the page content. For more details about using a template, see Creating a Page using a Template.
3. Click Next. Confluence opens the page in 'Edit' mode.

Adding a page from any page in a space

By default, Confluence adds the new page as a child page of the current page.

To add a new page:

1. Go to any page in the space.
2. Choose Add > Page.

Note that you will only see the Add Page link if you have permission to create pages for the space. You can also create a page using a template.
Pages with large amounts of text content

One user reported having problems saving a page that contained approximately 700 kilobytes (700,000 characters) or more of text content. Refer to CONF-16467 for more information. Some browsers appear to be more susceptible to this issue than others. While it is highly unlikely that your page content will ever reach this size, if you work with large pages, structuring your content into separate pages will help to avoid this issue.

Adding a page using an undefined link

You may want to insert a link pointing to a Confluence page that does not yet exist, but which you intend to create later. This type of link is called an undefined link.

To add an undefined link for later creation of a page:

1. Edit the page in which the link should appear.
2. Type '[' to trigger autocomplete, and type the name of the undefined page. Alternatively, type the text first, then select the text and type '['.
3. Choose Insert Link to Create Page.

When you save the page, Confluence colours the undefined link red. When someone clicks the link, the new page opens in edit mode. That person can then enter the page name, add content and save the page, as usual.

Setting Page Location

While you are editing a new page you can set the page's location to any space of your Confluence site.

To set the location for a new page:

1. While editing the page, click Location.
2. Use the tabs on the left of the 'Set Page Location' dialog to help you find the new space and parent page for your page, that is, the location where you want to move your page. The 'Current location' and 'New location' breadcrumb trails at the bottom of the dialog indicate the current parent page and new parent page.
3. If you want to move a page to a different position amongst the child pages, select Reorder to see a list of sibling pages when you click Move.
4. Click Move.
5. If you are reordering the child pages, click in the list to set the new position for the page and click Reorder.

See also Moving a Page.

Screenshot: Setting page location for a new page
Importing an Office Document into One or More Confluence Pages

The Office Connector allows you to import a Word document into Confluence, optionally creating one or more new pages. See Importing a Word Document into Confluence.

Related Topics

Creating a Page using a Template
Working with Drafts
Linking Pages
Page Restrictions
Working with the Office Connector
Moving a Page

Take me back to Confluence User's Guide

Adding Blog Posts

To add a blog post for a space, you require ‘Create Blog’ permission which is assigned by a space administrator. See Space permissions or contact a space administrator for more information.

On this page:

- From the Dashboard
- From Any Page
- Notes
- Related Topics

From the Dashboard

You can add a blog post to any space from the Dashboard, without having to browse to that space.
To add a blog post from the Dashboard:

1. Click Add Blog Post at the top right of the Dashboard.
2. Select the space where you want to add the blog post.
3. Click Next. Confluence will open the Add Blog Post screen in edit mode.
4. Type your content as you would for any other page in Confluence.
5. Preview and click Save when you are finished.

From Any Page

You can add a blog post from any page (other than the Dashboard) in the space.

To add a blog post from any page:

1. Click Add near the top right of the page and choose Blog Post. Confluence will open the Add Blog Post screen in edit mode.
2. Type your content as you would for any other page in Confluence.
3. Preview and click Save when you are finished.

Notes

- Add labels if you want to categorise information this way.
- If you want to backdate your blog post, edit the date in Posting Date. You cannot set a date after today’s. Also, you can only set the date when creating the blog post, not when editing it.
- You can view the blog for the current space by opening the Browse menu and selecting Blog. Your blog post should be listed.

Related Topics

Adding Pages
Working with Blog Posts
Editing Blog Posts
Linking to Blog Posts
Deleting Blog Posts

Take me back to Confluence User's Guide

Using the Editor

The Confluence editor is the tool that you will use to create and edit Confluence pages, blog posts and comments. You can enter content as you would in a Word document, apply formatting, and embed other content and files into the page.

Looking for a quick start? See the Quick Reference Guide for the Confluence Editor.

To begin an editing session, choose Edit at the top of a page (or press E on the keyboard).

A note about permissions: To edit a page, you need the ‘Add Pages’ permission for the space. See space permissions. Someone may also apply page restrictions that may prevent you from editing the page.

An editing session

You start an editing session whenever you:

- create a new page, blog post or page comment
- edit an existing page, blog post or comment (by pressing ‘E’ on the keyboard, or choosing Edit).

While in an editing session, you can also:
- Name, or rename, a page or blog post. Note that renaming has effects that you should consider.
- Add a comment describing the changes you made.
- Choose whether or not people watching the page get notified of the change you made.
- Add labels to the page.

Confluence automatically saves drafts of your page as you work. If another user begins editing the same page as you, Confluence will display a message, and will try to merge the changes when you save your page.

Click Cancel (at the bottom of the page) if you want to end the session without saving any changes.

The session ends when you click Save.

When you create a new page you can choose the location where the page should be saved. You can also move a page after it has been saved, to make it a child page of a different page, or to move it to another space.

To see changes between different versions of the page, look at the history of the page.

<table>
<thead>
<tr>
<th>On this page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>- An editing session</td>
</tr>
<tr>
<td>- The editor panel</td>
</tr>
<tr>
<td>- The toolbar</td>
</tr>
<tr>
<td>- Embedding content in the page</td>
</tr>
<tr>
<td>- Things to help you work faster</td>
</tr>
<tr>
<td>- Autoformatting</td>
</tr>
<tr>
<td>- Autocomplete</td>
</tr>
<tr>
<td>- Autoconvert for pasted links</td>
</tr>
<tr>
<td>- Drag-and-drop for external images and files</td>
</tr>
<tr>
<td>- Drag-and-drop within the editor</td>
</tr>
<tr>
<td>- Keyboard shortcuts</td>
</tr>
<tr>
<td>- Finding and replacing text</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Related pages:</th>
</tr>
</thead>
<tbody>
<tr>
<td>- Quick Reference Guide for the Confluence Editor</td>
</tr>
<tr>
<td>- Page in View Mode</td>
</tr>
<tr>
<td>- Working with Tables</td>
</tr>
<tr>
<td>- Working with Page Layouts and Columns and Sections</td>
</tr>
<tr>
<td>- Displaying Images</td>
</tr>
<tr>
<td>- Linking to Images</td>
</tr>
<tr>
<td>- Linking to Attachments</td>
</tr>
<tr>
<td>- Using Symbols, Emoticons and Special Characters</td>
</tr>
<tr>
<td>- Confluence User's Guide</td>
</tr>
</tbody>
</table>

The editor panel

Screenshot: The Confluence editor
The toolbar

<table>
<thead>
<tr>
<th>Item</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page title</td>
<td>Type the name of the page. This name is used in links to the page.</td>
</tr>
<tr>
<td>Page content</td>
<td>Add the words, images and other content that forms the content of the page.</td>
</tr>
<tr>
<td>Editor toolbar</td>
<td>Use these tools to format and colour content, create lists and tables, indent and align text, and insert other content into the page, such as symbols, links, images, multimedia files and macros. The toolbar also provides the find and replace option, and the help option.</td>
</tr>
<tr>
<td>Restrictions</td>
<td>Control who can view or edit the page. See Page Restrictions.</td>
</tr>
<tr>
<td>Attachments</td>
<td>View, and manage, the attached files on the page.</td>
</tr>
<tr>
<td>Labels</td>
<td>Add labels to a page, to categorise the page content.</td>
</tr>
<tr>
<td>Change comment</td>
<td>Type a comment that describes the changes you have made.</td>
</tr>
<tr>
<td>Notify watchers</td>
<td>Select this option to prompt Confluence to send an e mail notification of your changes to people who are watching the page.</td>
</tr>
<tr>
<td>Preview</td>
<td>See how your changes will appear, without saving the page.</td>
</tr>
<tr>
<td>Save</td>
<td>Save the changes you have made to the page. (Keyboard shortcut: Ctrl+S).</td>
</tr>
<tr>
<td>Cancel</td>
<td>End the editing session, without saving any changes.</td>
</tr>
</tbody>
</table>
You can use the editor toolbar to:

- Apply paragraph styles and character formatting (such as bold, italics, superscript).
- Choose colour for text.
- Create numbered and bulleted lists.
- Set the indenting and alignment for text and images.
- Create links to other pages, attachments, anchors and external resources.
- Add tables, and add, remove, cut and paste rows and columns, highlight cells, rows and columns, and merge and split cells.
- Insert other content into the page, such as images, multimedia, attachments, symbols and wiki markup.
- Use macros to add other types of content, such as a list of JIRA issues or a table of contents.
- Add layouts and columns and sections to your page.
- Find and replace content within the page that you are editing.

**Embedding content in the page**

Choose Insert on the editor toolbar to include any of the following types of content into your page:

- An image.
- A link to another Confluence page or external URL, or a link to an attachment or image.
- An emoticon or symbol, or a horizontal line.
- A macro. Choose either a specific macro, or Other Macros, from the Insert menu.

**Things to help you work faster**

**Autoformatting**

You can type Confluence wiki markup directly into the editor to have Confluence auto-format your text as you type. To learn more, choose ? on the editor toolbar and choose the Editor Autoformatting tab. See also See the Quick Reference Guide for the Confluence Editor.

**Autocomplete**

When editing a page or blog post, you can enter a trigger character to show a list of suggested links, media files or macros to add to your page. This feature is called ‘autocomplete’ and provides you with a fast editing solution if you prefer to use key strokes rather than pointing and clicking with the mouse.

Quick summary of autocomplete:
Autoconvert for pasted links

When you paste URLs into Confluence, the editor will analyse what you are pasting and automatically convert it into something that will display well in Confluence. Examples include:

- YouTube videos
- JIRA issue queries
- Google Maps
- Confluence pages, blog posts, comments, user statuses, user profiles.
- Shared screenshot links from Skitch
- And more.

Drag-and-drop for external images and files

You can drag a file from a location outside Confluence, and drop it directly into the editor. For example, try it with images, video files, audio files, Office documents, and PDF files. The contents of the file will be embedded into the page or blog post. Please refer to the following pages for more information:

- Using Drag-and-Drop in Confluence – Using Confluence’s drag-and-drop feature, including details about its requirements and configuration.
- Displaying Images – Embedding images onto a Confluence page or blog post.
- Embedding Multimedia Content – Embedding videos, audio files and other multimedia files onto a Confluence page or blog post.
- Displaying Office Files in Confluence – Embedding Office and PDF files onto a Confluence page or blog post.

Drag-and-drop within the editor

Working within the editor panel, you can drag an image or a macro from one location on the page and drop it into a different location on the page. Hover your cursor over the image or the macro placeholder. The cursor changes to a drag-and-drop icon and you can click the image or macro and drag it to a new location.

If you want to abandon the drag-and-drop action, press Escape. The image/macro will return to its original position.

Note: For the drag-and-drop of images and macros in the editor, Confluence supports the following browsers: Chrome, Firefox, and Internet Explorer 9. (Drag and drop in the editor does not work in Internet Explorer 8.)

Keyboard shortcuts

To see the keyboard shortcuts available, choose ? on the editor toolbar.

Finding and replacing text
Click the binoculars icon on the toolbar, or use the keyboard shortcut Ctrl+F (Windows) or Cmd+F (Mac OS).

Search matches are highlighted in yellow. You can step through the results one by one, replace the matching text strings one by one, or replace all matching strings at once. This find and replace feature works only within the current page.

**Quick Reference Guide for the Confluence Editor**

This page is a quick-reference guide to using the Confluence editor. The aim is to give you enough information about the editor’s features for you to experiment yourself, rather than describing every possible shortcut key, autocomplete feature or toolbar option.

This guide is for people who want to use the autocomplete, autoformatting and keyboard shortcuts provided by the editor. If you prefer to use the toolbar options, the editor itself should be mostly self-explanatory.

**Introductory tips**

1. **Jump in and start using the Confluence editor.** The editor toolbar contains the most important buttons you'll need for creating and editing content.

2. **Use the keyboard shortcuts.** For example, type these characters in the editor panel:
   - Type `(angle bracket)` to insert a link.
   - Type `!` (exclamation mark) to insert an image or other media.
   - Type `{` (curly bracket) to insert a macro.
   These characters will trigger the autocomplete functionality, prompting you with a list of suggestions to finish off the entry. For more shortcuts, click the help icon on the editor toolbar.

3. **See how to undo the autocomplete and autoformatting actions.** To undo something that autocomplete or autoformatting has done, press Ctrl+Z (Windows) or Cmd+Z (Mac).

**On this page:**

- Introductory tips
- Seeing it in action
- Using the most common formats and features
  - Formatting text
  - Using symbols
  - Linking text
  - Using lists
  - Using tables
  - Using macros
  - Displaying images and multimedia

**Related pages:**

- Using Autocomplete
- Confluence 4.0 Editor - What's Changed for Wiki Markup Users

**Seeing it in action**

This short video shows the autoformatting and autocomplete features of the editor.

[See the video on YouTube]
This video shows how to add macros, links and images by wiki markup alone. Type the macro, including its parameters and the closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket. Insert an image or other embedded object, enclosed between exclamation marks. As soon as you close the macro, link, or embedded image, Confluence will convert it to rich text format and add it to the page.

See the video on YouTube.

Using the most common formats and features

Below is a list of the most commonly used editor features, and the related keyboard shortcuts.

**Formatting text**

<table>
<thead>
<tr>
<th>Formatting text</th>
<th>What to do</th>
<th>Windows keyboard shortcuts (For Mac OS X, replace 'Ctrl' with 'Cmd')</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heading levels</td>
<td>Type the heading level and a full stop. Autoformat will convert the line to the appropriate heading immediately. You can continue typing your heading text immediately. Example: h2.</td>
<td>Ctrl + 1 to 6</td>
</tr>
<tr>
<td><strong>Bold text</strong></td>
<td>Type an asterisk ‘*’, your text, then another asterisk. Confluence autoformat will convert the text to bold immediately. Example: <em>Surf’s Up</em></td>
<td>Ctrl + b</td>
</tr>
<tr>
<td><strong>Italic text</strong></td>
<td>Type an underscore ‘_’, your text, then another underscore. Confluence autoformatting will convert the text to italics immediately. Example: <em>Surf’s Up</em></td>
<td>Ctrl + i</td>
</tr>
<tr>
<td><strong>Underlined text</strong></td>
<td>Type a plus sign ‘+’, your text, then another plus sign ‘+’. Confluence autoformatting will convert the text to underlined immediately. Example: +Surf’s Up+</td>
<td>Ctrl + u</td>
</tr>
</tbody>
</table>
**Monospace text**
Type two curly braces {{, your text, then another two curly braces }}. Confluence autoformat will convert the text to monospace immediately. Example:

```
{{Surf's Up}}
```

<table>
<thead>
<tr>
<th>Left, centre and right alignment</th>
<th>Click the left, centre and right alignment buttons on the editor toolbar:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image" alt="Alignment buttons" /></td>
</tr>
<tr>
<td></td>
<td>This can also be used to align images independently of text.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Indentation</th>
<th>Click the left and right indentation buttons on the editor toolbar:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image" alt="Indentation buttons" /></td>
</tr>
<tr>
<td></td>
<td>Tab (right), Shift + Tab (left)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Line break</th>
<th>Press Shift + Enter to force a line break without a paragraph break.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>This is a line break with no extra space.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Quotation</th>
<th>Use the <em>Quote</em> style – select 'Quote' from the style dropdown menu.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>or use the keyboard shortcut.</td>
</tr>
<tr>
<td></td>
<td>Example:</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Quote style menu" /></td>
</tr>
<tr>
<td></td>
<td>Ctrl + 8</td>
</tr>
<tr>
<td>Colour</td>
<td>Click the colour options on the editor toolbar. Example:</td>
</tr>
<tr>
<td>--------</td>
<td>--------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td><img src="image.png" alt="Colour Options" /></td>
</tr>
</tbody>
</table>

**Using symbols**

<table>
<thead>
<tr>
<th>Adding symbols and emoticons</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tick or check mark</td>
<td>Type a forward slash in round brackets. Autocomplete will convert it as you type. Example:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>( / )</td>
<td>( + / + )</td>
</tr>
<tr>
<td>Smiley</td>
<td>Type the globally-recognised markup for a smiley face (colon and round bracket), a wink (semicolon and round bracket), and so on. Autocomplete will convert it as you type. Example:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>: )</td>
<td>: + )</td>
</tr>
</tbody>
</table>

**Linking text**

<table>
<thead>
<tr>
<th>Linking text</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linking to a Confluence page</td>
<td>Type a square bracket <code>[</code> and start typing the page name to see the suggested pages to link to. Press the arrow keys to select the page you want. Example:</td>
<td></td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Link suggestions" /></td>
<td><img src="image" alt="Link suggestions" /> Alternatively, use <strong>wiki markup entirely</strong>. Type the link, including the alias and the page name or URL. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• This works if you have <code>Autoformatting</code> enabled in the editor settings in your user profile.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• <strong>Example:</strong> `[Modern Girl</td>
<td>Modern Girl song lyrics]`</td>
</tr>
<tr>
<td>Linking text to a web page</td>
<td>Type a square bracket <code>[</code> and select 'Insert Web Link', then paste the URL into the link dialog. Example:</td>
<td></td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
</tbody>
</table>
| | ![Link suggestions](image)
| | Alternatively, use **wiki markup entirely**. Type the link, including the alias and the URL. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.
| | • This works if you have 'Autoformatting' enabled in the editor settings in your user profile.
| | • This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.
| | • **Example:** `[Modern Girl|http://www.example.com/song]`
<table>
<thead>
<tr>
<th>Linking to a page that does not yet exist</th>
<th>Type a square bracket '[' and the name of the non-existent page, then select 'Insert Link to Create Page'. Example:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image" alt="Link suggestions" /></td>
</tr>
<tr>
<td></td>
<td>Alternatively, use <strong>wiki markup entirely</strong>. Type the link, including the alias and the page name or URL. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.</td>
</tr>
<tr>
<td></td>
<td>• This works if you have 'Autoformatting' enabled in the editor settings in your user profile.</td>
</tr>
<tr>
<td></td>
<td>• This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.</td>
</tr>
<tr>
<td></td>
<td>• Example: [Future of the Modern Girl]</td>
</tr>
</tbody>
</table>
Linking to an attachment

Type a square bracket `[` and start typing the attachment name to see the suggested attachments to link to. Press the arrow keys to select the item you want. Example:

```
[ chocs
```

Alternatively, use **wiki markup entirely**. Type the link, including the alias (if required), the caret character `^` and the attachment name. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.

- This works if you have `Autoformatting` enabled in the editor settings in your user profile.
- This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.
- Example: `[^attachment name]`
Linking to an anchor

To create the anchor: Add an anchor macro using wiki markup. Confluence will convert the macro to rich text format and add it to the page. For example, to create an anchor named 'index', type the following: \{anchor:index\}

To create the link: Use wiki markup too. Type the link, including the alias (if required), the hash character # and the anchor name. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.

- This works if you have 'Autoformatting' enabled in the editor settings in your user profile.
- This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.
- Example: [Index|#index]

Using lists

<table>
<thead>
<tr>
<th>Using lists</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a bullet list</td>
<td>Type an asterisk &quot;*&quot; followed by a space. Autoformat will convert the line to a bulleted list. You can continue typing your text immediately. Example: My list:</td>
<td>Ctrl + Shift + b</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="bullet item" /> To add another line of text to an entry without creating a new list item, press Shift + Enter at the end of the line.</td>
<td></td>
</tr>
</tbody>
</table>
| Adding a numbered list | Type a hash or pound '#' followed by a space. Autoformat will convert the line to a numbered list. You can continue typing your text immediately. Example:

My list:

1. | Keyboard shortcut (Windows) | Ctrl + Shift + n |

To add another line of text to an entry without creating a new list item, press Shift + Enter at the end of the line.

---

**Using tables**

<table>
<thead>
<tr>
<th>Using tables</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a table</td>
<td>Type a series of pipe characters '</td>
<td>' then press <strong>Enter</strong>. Autoformat will convert the pipes to a table. Example – to create a table with three columns:</td>
</tr>
</tbody>
</table>

| | | |
| | | |

---

**Using macros**

<table>
<thead>
<tr>
<th>Adding macros</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Adding a macro to your page.

Type '{' and start typing the macro name to see a list of macros that match your text. Press the arrow keys to select the macro you want. Example:

```
{ blog
```

Alternatively, use **wiki markup entirely**. Type the macro, including its parameters and the closing curly bracket. As soon as you close the macro, Confluence will convert it to rich text format and add it to the page. This means that you can skip the macro browser.

- This works if you have 'Autoformatting' enabled in the editor settings in your user profile.
- This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.
- Example: `{blogposts:content=titles}`

---

**Displaying images and multimedia**

<table>
<thead>
<tr>
<th>Displaying images</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Display an image attached to the page</td>
<td>Type an exclamation mark '!' and start typing the image name to see the suggested images to insert onto the page. Press the arrow keys to select the item you want. Example:</td>
<td></td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>--------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>!NoMatterWhat.png</td>
<td>Alternatively, use <strong>wiki markup entirely</strong>. Type the wiki markup for the image insertion, including the exclamation marks, the space and/or page name (if different from the current page) and the image name, as well as any other allowed parameters. As soon as you type the closing exclamation mark, Confluence will convert the image to rich text format and add it to the page. This means that you can skip the image browser.</td>
<td></td>
</tr>
<tr>
<td>!NoMatterWhere.png</td>
<td>• This works if you have 'Autoformatting' enabled in the editor settings in your user profile.</td>
<td></td>
</tr>
<tr>
<td>!NoMatchingImages.png</td>
<td>• This does not work if you paste the wiki markup onto the page. You need to enter the closing exclamation mark manually.</td>
<td></td>
</tr>
<tr>
<td>!Open Image Browser</td>
<td>• Example: <img src="align=right" alt="NoMatterWhat.png" />!</td>
<td></td>
</tr>
<tr>
<td>![Insert Other Media]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Displaying an image attached to another page</td>
<td><em>Exactly the same as when the image is attached to the same page.</em></td>
<td></td>
</tr>
<tr>
<td>!NoMatterWhat.png</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Embedding multimedia files</td>
<td>What to type</td>
<td>Keyboard shortcut (Windows)</td>
</tr>
<tr>
<td>Embedding a video, movie or audio file into a page</td>
<td>Type an exclamation mark '!' and select 'Insert Other Media'. Example:</td>
<td></td>
</tr>
<tr>
<td>--------------------------------------------------</td>
<td>-------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td><img src="image.png" alt="Media suggestions" /></td>
<td><img src="image.png" alt="Insert Image" /></td>
<td></td>
</tr>
<tr>
<td>Or type '{' and start typing the macro name 'Multimedia'. Example:</td>
<td><img src="image.png" alt="Macro suggestions" /></td>
<td></td>
</tr>
</tbody>
</table>

**Working with Text Effects**

The Confluence editor supports most text effects available in standard text editing applications.

**Applying paragraph styles**

Choose a paragraph style from the editor toolbar, or click in the paragraph and use one of the keyboard shortcuts Ctrl+(0–8).

*Screenshot: Choosing paragraph styles from the editor toolbar*
Applying character formats

To apply a character format, select the text and click one of the editor toolbar buttons, or use a keyboard shortcut. Some formats are available from the 'More' menu.

Screenshot: Text formatting buttons on the editor toolbar

<table>
<thead>
<tr>
<th>Format</th>
<th>Shortcut Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bold</td>
<td>Ctrl+B</td>
</tr>
<tr>
<td>Italic</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Underline</td>
<td>Ctrl+U</td>
</tr>
<tr>
<td>Strikethrough</td>
<td>Ctrl+Shift+S</td>
</tr>
<tr>
<td>Subscript</td>
<td>none</td>
</tr>
</tbody>
</table>
Applying colours to text

To apply a colour to text, select the text and click the ‘Colour’ button. Choose the colour using the ‘More colours’ button.

*Screenshot: Picking colours from the editor toolbar*

Aligning text

You can align text to the left, right or centre of a content block. Select the text and click the appropriate alignment option on the editor toolbar.

*Screenshot: Left, centre and right alignment options on the editor toolbar*

Indenting text

You can move text to the left or right by a predefined sequence of indentations. Confluence determines the size of the indentation. Select the text and click the left or right indentation option on the editor toolbar.

*Screenshot: Left and right indentation options on the editor toolbar*

Working with Links

By adding a link on a Confluence page, you can link to content anywhere within the Confluence site or on another web site.

You can add links to the following types of content:

- *Pages* in the same space, in another space, or outside Confluence (webpages).
- *Blog posts*.
- *Pages that haven’t yet been created*, but for which you require a placeholder on the current page.
• **Attachments**, such as images and multimedia files.
• **User profiles or personal spaces.**
• A section of a page, using an anchor.

You can also [link from an image](#), or use a link to begin composing a [new email message](#).

You create all these kinds of links using the 'Insert Link' dialog that is available in the editor (click **Link** in the menu bar while editing the page). You can also create links using **autocomplete** as a shorthand way of creating the most common types of links.

### Related pages:
- [Working with Anchors](#)
- [Trackback](#)
- [Linking to Confluence Pages from Outside Confluence](#)
- [Working with Attachments](#)
- [Confluence User's Guide](#)

You can edit and remove links while editing the page, using the link properties panel that appears when you click on a link in the editor:

### Notes
- Links in Confluence will not break even when you rename pages or move them between spaces on your site. Confluence will rename the links, provided you have inserted them as relative links, not as full URLs.
- Looking for a link type not shown above? You might find a [plugin](#) can help you.

### Linking to Pages
This page describes how to create a link in your Confluence page to another page.

You can create links on your page to:

- Other pages in the Confluence site.
- Webpages outside of Confluence.
- Anchors or headings, on the same page or other pages.

You can also create a link to a non-existent Confluence page.

You can use the following methods to create links:

- **Autocomplete** - to link to Confluence pages or a non-existent page.
- The 'Insert Link' dialog - to link to Confluence pages and webpages.
- Cutting and pasting a link from your browser - to link to Confluence pages and webpages.
On this page:
- Linking to Confluence Pages
  - Adding a Link using Autocomplete
  - Adding a Link using the Insert Link Dialog
  - Copying and Pasting a Link from your Web Browser
- Linking to Webpages
- Linking to an Anchor or Heading
- Linking to an Undefined Confluence Page
- Linking using a Shortcut Link
- Related Topics

Linking to Confluence Pages

Adding a Link using Autocomplete

You can use autocomplete to create a link to any page in the Confluence site, if you know the name of the page you want to link to.

You can type [ to see a list of suggested links. For details, see Using Autocomplete.

Adding a Link using the Insert Link Dialog

To create a new link using the ‘Insert Link’ dialog:

1. While editing the page, place your cursor at the point where you want to create the link, or highlight the text that you want linked.
2. Click Link in the toolbar, or press Ctrl+K. See keyboard shortcuts for more information.
3. Choose one of the tabs on the left to help you find the page or other location that you want to link to:
   - Search—Use this option to link to a page or file in Confluence.
     - Start typing the page name into the text box. Confluence will suggest options as you type.
     - If necessary, limit the search to the current space.
     - Select your link destination from the autocomplete results, or click Search and select the link destination from the search results.
   - Recently Viewed—Use this option to link to a page in Confluence.
     - Select your link destination from recently-visited pages.
4. Enter link text that will be displayed on the page, if required. If you have not highlighted text in the page, and leave the 'Link Text' text box empty, the link will display the destination page name or URL.
5. Click Insert.

Copying and Pasting a Link from your Web Browser

To paste a link from your web browser:

1. In your web browser, select and copy the title of a Confluence page.
2. Edit your Confluence page and paste the title where you want the link to appear.

Linking to Webpages

Use the 'Insert Link' dialog to link to an external web page.

To create a link to a webpage:

1. While editing the page, place your cursor at the point where you want to create the link, or highlight the text that you want linked.
2. Click Link in the toolbar, or press Ctrl+K. See keyboard shortcuts for more information.
3. Click Web Link and enter or paste the web address into the URL text box.
4. Enter link text that will be displayed on the page if required. If you have not highlighted text in the page,
and leave the 'Link Text' text box empty, the link will display the destination page name or URL.

5. Click Insert.

You can also simply copy and paste a link to a webpage into your Confluence page, as described above.

**Linking to an Anchor or Heading**

You can link to an anchor or heading that is on the same page, on another page in the same space, or on a page in another space of the same Confluence site.

**To link to an anchor or heading:**

1. Click Link in the toolbar, or press **Ctrl+K**, while editing the page.
2. Click Advanced and enter the anchor name (or heading) into the Link box, using the following syntax:

<table>
<thead>
<tr>
<th>Anchor or heading location</th>
<th>Link syntax for anchor</th>
<th>Link syntax for heading</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same page</td>
<td>#anchornname</td>
<td>#headingname</td>
</tr>
<tr>
<td>Different page</td>
<td>pagename#anchornname</td>
<td>pagename#headingname</td>
</tr>
<tr>
<td>Page in another space</td>
<td>spacekey:pagename#anchornname</td>
<td>spacekey:pagename#headingname</td>
</tr>
</tbody>
</table>

For more information about link syntax, see [Confluence Wiki Markup](#).

3. Enter link text that will be displayed on the page, if required. If you leave the **Link Text** box empty, the link will display the destination page name or URL.

4. Click Insert.
   
   - Note that when linking to a heading, **headingname** is case-sensitive and must be entered without spaces
   - Note that when linking to an anchor, **anchornname** is case-sensitive, and **pagename** must be entered with spaces as in the title.

See [Working with Anchors](#) for more information.

**Linking to an Undefined Confluence Page**

You may want to insert a link pointing to a Confluence page that does not yet exist, but which you intend to create later. This type of link is called an undefined link.

**To add an undefined link for later creation of a page:**

1. Edit the page in which the link should appear.
2. Type `^` to trigger autocomplete, and type the name of the undefined page. Alternatively, type the text first, then select the text and type `^`.
3. Choose Insert Link to Create Page.

When you save the page, Confluence colours the undefined link red. When someone clicks the link, the new page opens in edit mode. That person can then enter the page name, add content and save the page, as usual.

**Linking using a Shortcut Link**

If you have **configured shortcut links** on your Confluence site, then you can link to an external site using a shortcut link that looks like this: `CONF-17025@jira`. Our Confluence site (where this documentation is housed)
is configured to allow shortcut links to our JIRA site, using the shortcut @jira. So the shortcut link CONF-17025 @jira produces this link.

To add a shortcut link using the 'Insert Link' dialog:

1. Click Link in the toolbar, or press Ctrl+K. See keyboard shortcuts for more information.
2. Click Advanced and enter or paste the shortcut link into the Link box. Shortcut links are case-insensitive.
3. Enter link text that will be displayed on the page, if required. If you leave the Link Text box empty, the link will display the destination page name or URL.
4. Click Insert.

You can also type '@' and choose Insert Web Link > Advanced to enter a shortcut link.

See Configuring Shortcut Links for more details.

Related Topics

Working with Links
Trackback
Linking to Confluence Pages from Outside Confluence

Take me back to Confluence User's Guide

Linking to Images

This page describes how to insert a link on your Confluence page that points to an image. Linking to an image is a way to have text on a page that, when clicked, takes the user to that image.

Quick guide to linking to an image
1. Click Link on the editor toolbar.
2. Select one of these options:
   • Search – Search for and link to any image or file attached to any page in your Confluence site.
   • Attachments – Link to an image or file attached to the current Confluence page.

The rest of this page gives more details of the above procedure and additional options.

On this page:

- Adding a Link with the Link Browser
- Adding a Link using Autocomplete

Related pages:

- Linking to Attachments
- Displaying Images

Adding a Link with the Link Browser

To link to an image that is attached to the current page:

1. Edit the page where you want to insert the link.
2. Click Link on the toolbar.
3. Choose the Attachments tab in the left-hand panel. You will see a list of all files attached to the page.
   Now you can:
   • Select an image that is already attached to the page.
   • Attach a new image to the page by clicking Browse and uploading your file.
4. Enter the Link Text. These are the words that will appear as the hyperlink on the page.
5. Click Insert.
To link to an image that is attached to any Confluence page:

1. Edit the page where you want to insert the link.
2. Click Link on the toolbar.
3. Select the Search option in the left-hand panel.
4. Start typing the name of the image. Confluence will suggest image files. If the image does not appear in the list, click Search.
5. Click the image name in the autocomplete results or the search results.
6. Click Insert.

Screenshot: The link browser, showing autocomplete in the 'Search' option

Adding a Link using Autocomplete

You can use the autocomplete functionality to link to an image attached to any Confluence page.

You can type [ to see a list of suggested links. For details, see Using Autocomplete.

Linking from an Image

This page describes how to create a link from an image on one page to another page or URL. When the user clicks the image, they will be redirected to the linked page or other resource.

To create a link from an image:

1. Display the image on the page. The image can either be attached to the page or available on another page. See Displaying Images.
2. Create the link by clicking on the image and then clicking Link in the properties panel. Specify the link target using the 'Insert Link' dialog. See Linking to Pages.

You can edit the link by clicking on the image, when editing the page, and clicking Edit Link in the properties panel.
Linking to Attachments

This page describes how to add a text link pointing to a file attached to your Confluence page. When a reader clicks the link, the file is displayed in the browser.

Quick guide to linking to an attachment

1. Click Link on the editor toolbar.
2. Select one of these options:
   - **Search** – to search for and link to any image or file attached to any page in your Confluence site.
   - **Recently Viewed** – to link to a recently visited page.
   - **Attachments** – to link to an image or file attached to the current Confluence page.
   - **Web Link** – to link to any webpage.

On this page:

- [Adding a Link using Autocomplete](#)
- [Adding a Link using the Link Browser](#)

Related pages:

- [Linking to Images](#)

---

Adding a Link using Autocomplete

You can use autocomplete to add a text link to a file or image attached to any Confluence page.

You can type [ to see a list of suggested links. For details, see **Using Autocomplete**.

Adding a Link using the Link Browser

The 'link browser' is the 'Insert Link' or 'Edit Link' dialog that appears when you click Link in the editor toolbar.

To link to a file or image that is attached to the current page:
1. Edit the page where you want to insert the link.
2. Click Link in the editor toolbar, and then the Attachments tab. You will see a list of all files attached to the page. Now you can do one of the following:
   - Click on the file that you want to link to, if it is already attached to the page.
   - Attach a new file to the page by clicking Browse and uploading your file.
3. Enter the Link Text. These are the words that will appear as the hyperlink on the page.
4. Click Insert to add the link.

To link to a file or image that is attached to any Confluence page:

1. Edit the page where you want to insert the link.
2. Click Link in the editor toolbar, and then the Search tab.
3. Start typing the name of the file or image. Confluence will offer a list of matching file names. If the file does not appear, click Search to find pages that contain the search text.
4. Click the required file in the list or the search results.
5. Enter the Link Text. These are the words that will appear as the hyperlink on the page.
6. Click Insert to add the link.

Screenshot: The link browser, showing autocomplete in the 'Search' option

---

Linking to Blog Posts

You can link to blog posts in similar ways to how you link to pages. Only two methods are described on this page.

You can also use the Blog Posts macro to display a dynamic list of blog posts on your page.
You must create the blog post first

Linking to a blog post that has not been created yet will not result in a link. Blog posts are very tightly bound to the time at which they were created, so it makes no sense to link to them before they exist.

Linking to a Blog Post using Autocomplete

You need to know the title of the blog post.

You can use autocomplete to create a link to any blog post in the Confluence site, if you know the name of the post you want to link to.

You can type [ to see a list of suggested links. For details, see Using Autocomplete.

Linking to a Blog Post using its URL

You need to know the absolute path to the blog post.

To create a link to a blog post using the 'Insert Link' dialog:

1. While editing the page, place your cursor at the point where you want to create the link, or highlight the text that you want linked.
2. Click Link in the toolbar, or press Ctrl+K. See keyboard shortcuts for more information.
3. Click Web Link and enter or paste the absolute path to the blog post into the URL text box.
4. Enter link text that will be displayed on the page if required. If you have not highlighted text in the page, and leave the 'Link Text' text box empty, the link will display the destination page name or URL.
5. Click Insert.

Related Topics

Working with Blog Posts
Working with Links
Blog Posts Macro

Take me back to Confluence User's Guide

Linking to Personal Spaces and User Profiles

This page describes how to add a link to a user's personal space or user profile from within another Confluence page.

You can link to a user's personal space (or user profile) easily if you know their username.

If the user does not have a personal space, then the link will go to their user profile.

Linking to a User's Personal Space using Autocompletion

You can use autocomplete to create a link to a user's personal space in the Confluence site. Trigger autocomplete and start typing their name.

You can type [ to see a list of suggested links. For details, see Using Autocomplete.

Linking to a User's Personal Space using the Insert Link Dialog
1. While editing the page, place your cursor at the point where you want to create the link, or highlight the text that you want linked.
2. Click **Link** in the toolbar, or press **Ctrl+K**. See [keyboard shortcuts](https://confluence.atlassian.com/collaborationoverview/keyboardshortcuts) for more information.
3. Click the **Search** tab on the left.
4. Start typing the user's name into the search field. Confluence will suggest options as you type.
5. Select the user from the autocomplete results.
6. Enter link text that will be displayed on the page, if required. If you have not highlighted text in the page, and leave the 'Link Text' text box empty, the link will display the destination page name or URL.
7. Click **Insert**.

**Related Topics**

User Profile Overview
Setting Up your Personal Space
Working with Links

Take me back to [Confluence User's Guide](https://confluence.atlassian.com/collaborationoverview/)

**Working with Anchors**

The Anchor macro allows you to link to specific parts of a page. Anchor links can be especially useful when navigating between sections of a long document or when you want to link to a segment of a page and not to the page as a whole.

Anchors are invisible to the reader when the page is rendered.

There are two steps to using an anchor:
1. Create the anchor for the content.
2. Create the link to the anchor.

---

**On this page:**

- Creating an Anchor
- Parameters
- Linking to an Anchor or Heading
- Notes

**Related pages:**

- Working with Links
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

---

**Creating an Anchor**

You use the Anchor macro to create an anchor for content that you want to be able to link to.

**To add the Anchor macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in [Using Autocomplete](https://confluence.atlassian.com/collaborationoverview/using-autocomplete).

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anchor Name</td>
<td>None; name must be supplied</td>
<td>This is the value for anchorname that you use when creating the link.</td>
</tr>
</tbody>
</table>

Linking to an Anchor or Heading

You can link to an anchor or heading that is on the same page, on another page in the same space, or on a page in another space of the same Confluence site.

To link to an anchor or heading:

1. Click **Link** in the toolbar, or press **Ctrl+K**, while editing the page.
2. Click **Advanced** and enter the anchor name (or heading) into the **Link** box, using the following syntax:

<table>
<thead>
<tr>
<th>Anchor or heading location</th>
<th>Link syntax for anchor</th>
<th>Link syntax for heading</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same page</td>
<td>#anchorname</td>
<td>#headingname</td>
</tr>
<tr>
<td>Different page</td>
<td>pagename#anchorname</td>
<td>pagename#headingname</td>
</tr>
<tr>
<td>Page in another space</td>
<td>spacekey:pagename#anchorname</td>
<td>spacekey:pagename#headingname</td>
</tr>
</tbody>
</table>

For more information about link syntax, see [Confluence Wiki Markup](#).

3. Enter link text that will be displayed on the page, if required. If you leave the **Link Text** box empty, the link will display the destination page name or URL.
4. Click **Insert**.

- Note that when linking to a heading, **headingname** is case-sensitive and must be entered without spaces.
- Note that when linking to an anchor, **anchorname** is case-sensitive, and **pagename** must be entered with spaces as in the title.

Notes

- If you are adding an anchor to the site welcome message, it can only be linked to from another page. Internal-only links will not render.
- Page titles and links to other spaces can be combined with anchors and attachments, but you can't use attachments and anchors in the same link.

Using a Link to Create a New Email Message

This page describes how to insert a link that, when clicked, launches the default email client.

💡 You can provide your own text to use as the link text instead of the 'mailto' tag.

To insert a link that creates a new email message:

1. Edit the page on which you want to insert the link.
2. Choose **Insert > Link** and select the **Web Link** tab.
3. Enter an email address, such as 'jsmith@non-existent.corp.com'.
4. Enter your own link text, if required.
5. Click Save.

Related Topics

Working with Links

Linking to Confluence Pages from Outside Confluence

Sometimes you may want to link to a Confluence page from outside of Confluence, such as from another website or from within an email. In this case, you should consider using a link to a 'permanent' URL (also called a 'permalink'), in case the name of the Confluence page changes.

If you are linking to a page from another page in the same Confluence site, it is better to use an internal wiki link rather than a permalink. Confluence can keep track of internal links and will let you know if the link is broken, such as when someone removes the linked page. See Linking to Pages. Internal wiki links are automatically updated if the page is renamed. This only works for page links that use the relative link syntax, for example [Renaming a Page].

To link to a page's permanent URL:

1. Choose Tools > Link to this Page.
2. Copy the Tiny Link and paste it into your email or external web page. This will create a link to the latest version of your Confluence page.

Related Topics

Linking to Pages
Working with Links

Inserting JIRA Issues

If your Confluence site is connected to a JIRA site using an application link, you can easily insert individual issues from this JIRA site directly into text on your Confluence page using the 'Insert JIRA Issue' dialog. Each issue inserted onto the page is linked to the issue in JIRA itself.

Using the 'Insert JIRA Issue' dialog, you can also:

- Create a new issue on the JIRA site and insert the issue onto your page.
- Insert a table of JIRA issues onto your page based on the results of a search (using JIRA Query Language (JQL) syntax).

If your Confluence site is not connected to any JIRA site via an application link, this feature will not be available. However, you can still list JIRA issues on a page or blog post using the JIRA issues macro.

On this page:
- Inserting a JIRA Issue from a List of Recently Viewed Issues
- Creating a New JIRA Issue and Inserting it
- Searching for JIRA Issues and Inserting them
- Notes
- Related Topics
Quick guide to inserting JIRA issues

- Choose Insert > JIRA Issue from the editor toolbar.
  - To insert a single issue, use either:
    - Recently Viewed — Insert an issue onto your page from a list of issues you have recently viewed on the JIRA server.
    - Create New Issue — Create a new issue on the JIRA server and insert it into your page.
    - Search — Use JQL syntax to narrow down a list of issues, from which you can select one to insert onto a page.
  - To insert a table of issues:
    - Click Search on the ‘Insert JIRA Issues’ dialog, use JQL syntax to narrow down a list of issues and choose to insert the list onto a page.

ℹ️ If Confluence is connected to more than one JIRA server, ensure that you choose the appropriate JIRA server before using this dialog to select, create or search for issues.

Inserting a JIRA Issue from a List of Recently Viewed Issues

To insert a JIRA issue onto a page from a list of recently viewed issues on a JIRA site:

1. Choose Insert > JIRA Issue from the editor toolbar.
2. Go to the Recently Viewed tab of the ‘Insert JIRA Issue’ dialog.
3. If necessary, select a JIRA server from the Server list. See the notes below regarding OAuth outgoing authentication.
4. Select an issue from your list of recently viewed JIRA issues on the JIRA site. The number of items in the list is defined in JIRA.

Creating a New JIRA Issue and Inserting it

ℹ️ This feature works best with JIRA issue types whose mandatory field requirements have not been altered. With the exception of a JIRA issue's 'Component/s' or 'Fix Version/s' fields, you cannot use this dialog to add an issue whose issue type has customised mandatory field requirements upon issue creation.

To create a new JIRA issue on a JIRA site and insert this issue onto a page:

1. Go to the Create New Issue tab of the 'Insert JIRA Issue' dialog.
2. Complete the dialog:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server</td>
<td>The available JIRA servers. See the notes below regarding OAuth outgoing authentication.</td>
</tr>
<tr>
<td>Project</td>
<td>The project on the selected JIRA server to which the new issue will be added.</td>
</tr>
<tr>
<td>Issue Type</td>
<td>The type of issue to log in this project.</td>
</tr>
<tr>
<td>Summary</td>
<td>A one-line summary for the issue.</td>
</tr>
<tr>
<td>Component/s</td>
<td>Choose one or more components which apply to this issue.</td>
</tr>
<tr>
<td>Version/s</td>
<td>Choose one or more versions in which the issue will be addressed.</td>
</tr>
</tbody>
</table>
Searching for JIRA Issues and Inserting them

To search a JIRA site for a subset of issues matching a JQL query and insert one or more of these issues:

1. Choose **Insert > JIRA Issue** from the editor toolbar.
3. Enter a **JQL query**.
4. If necessary, select the JIRA server whose issues you want to insert.
5. Click **Search** to find the issues on the JIRA server which match your JQL query. The first 20 issues retrieved by your JQL query are displayed.
   - To insert a single issue, select the issue from your list and click **Insert**.
   - To insert the full list of issues, select the **Insert all query results as a table** check box before clicking **Insert**.

Notes

The issues from a JIRA site which you can access in the 'Insert JIRA Issues' dialog depends on the application link's *outgoing authentication* used by Confluence to communicate with that JIRA site. While you can always access publicly visible issues:

- If 'Trusted Applications' outgoing authentication is used — you can also view issues restricted to an account on JIRA whose user name matches your user name in Confluence.
- If 'OAuth' outgoing authentication is used, you may need to click **Login & Approve** at this point to gain access to the JIRA server and restricted issues. You can also view issues restricted to the user account that you 'Login & Approve' (to the JIRA site) on the 'Insert JIRA Issues' dialog.
- If 'Basic Access' outgoing authentication is used — you can also view issues restricted to the user account configured for the JIRA site's 'outgoing authentication'.

Related Topics

JIRA Issues Macro

Trackback

Trackback is a mechanism by which two sites can stay informed each time one site refers to the other by means of trackback 'pings'.

In Confluence, Trackback is enabled by a site administrator from the Administration Console. When Trackback is enabled, any time you link to an external webpage that supports Trackback Autodiscovery, Confluence will send a Trackback ping to that page to inform it that it has been linked to.

Confluence pages also support Trackback Autodiscovery, and when Trackback is enabled can receive trackback pings sent by other sites.

To see who has sent a Trackback ping to a Confluence page:

1. Go to the page.
2. Choose **Tools > Info** to go to the 'Information' view for the page.

Any Trackback pings the page has received will be listed under the page's **Incoming Links**.
Confluence incoming trackback pings only work with referenced pages that are public (anonymously viewable)

See more information about the Information View.

Related Topics

Enabling Trackback
Managing External Referrers
Linking to Pages
Working with Links

Take me back to Confluence User's Guide

Displaying Images

You can display an image on a Confluence page in the following cases:

- The image is attached to the page.
- The image is attached to another page of the same Confluence site, even if in another space.
- The image is on a remote web page.

Once the image is displayed on the page, you can:

- Move the image to a new position on the page simply by cutting and pasting.
- Change how the image appears on the page.
- Link from an image to another page.

Displaying an image attached to the page

There are several methods for attaching image files to a page.

Once you have attached an image to a page, there are different methods for choosing where on the page the image should appear:

Using the 'Insert Image' dialog

Once an image is attached to the page, you can edit the page to choose where the image should appear.

On this page:

- Displaying an image attached to the page
- Displaying an image attached to a different page
- Displaying an image from a remote web page
- Controlling the image appearance
- Setting other image attributes
- Displaying a gallery of images
- Image file formats

Related pages:

- Linking from an Image
- Linking to Images
- Working with Attachments
- Choosing a Profile Picture
- Confluence User's Guide

To position an attached image on the page:

1. While editing the page, position the cursor where you want to place the image.
2. Choose **Insert > Image** and choose the **Attached Images** tab.
3. Select the required image and choose **Insert** (or just double-click the image).

**Using autocomplete**

Once an image is attached to the page, you can use autocomplete while editing the page to choose where the image should appear.

**To position an attached image on the page:**

1. While editing the page, position the cursor where you want to place the image.
2. Trigger the autocomplete function by typing '?'.
3. Choose the image from the list that appears.

**Using drag-and-drop**

Depending on the browser you are using, you can attach and position an image in one step. While you are editing a page, simply **drag-and-drop** an image file on to the page. The image is attached to the page and is placed at the current cursor position.

**Displaying an image attached to a different page**

You can display an image that is attached to a different page of the same Confluence site, as long as you know the name of the image. This approach can make it easier to manage your images by allowing you to keep them all in the same place.

**To display an image attached to a different page:**

1. While editing the page, position the cursor where you want to place the image.
2. Choose **Insert > Image** and choose the **Search** tab.
3. Type in the name of the image.
4. Choose whether to search the current space or **All Spaces** and choose **Search**.
5. Select the required image from the search results and choose **Insert**.

Alternatively, you can simply cut and paste the image from another page.

**Displaying an image from a remote web page**

You can display an image from a remote web page on your Confluence page, without needing to attach it to your page. You need to know the URL for the image, not for the web page it appears on. Note that you should have permission to use that image on your page.

**To display an image located on a web page:**

1. While editing the page, position the cursor where you want to place the image.
2. Choose **Insert > Image** and choose **From the Web**.
3. Type in the URL for the image. An example is: `http://www.atlassian.com/software/confluence/images/icon_customerslove_big.png`
4. Choose **Preview** to check that the URL and image are correct.
5. Choose **Insert**.

Alternatively, you can simply cut and paste the image from a web page.

**Controlling the image appearance**

When editing the page, click the image to show the image properties panel. The panel allows you to set the display size for the image and choose whether the image has a border. See also **Linking from an Image**.

**To set the size of the image,** do one of the following:
Choose one of the size 'preset' buttons (the image width in pixels is displayed to the left).
Choose the image size text and enter a new image width in pixels (you can specify a size between 16px and 900px).

Note that images are displayed as thumbnails.

**To add a border to the image:**
- Choose **Border** in the image properties panel.

**To add a hyperlink to the image:**
- Choose **Link** in the image properties panel. For more detail, see [Linking from an Image](#).

**To align an image:**
- Select the image and choose the paragraph alignment buttons on the editor **toolbar**.
- If you choose the left or right alignment, the text will wrap around the image. The text does not wrap for centre alignment.

**To add border effects to an image:**
- Choose **Effects** in the image properties panel and make a choice.

**To add a caption to an image:**
- Choose **Effects** in the image properties panel and choose the **Instant Camera** image effect.
- Save the page.
- Choose **Tools > Attachments** to go to the 'Attachments' view of the page.
- Choose **Properties** next to the image file.
- Add a comment to the attachment. The text in your comment will appear as the image caption.

**Note:** You will need to re-do the comment each time you upload a new version of the image.

*Screenshot: The image properties panel beneath an image*
Screenshot: Examples of image border effects

Setting other image attributes

Certain attributes such as alt-text, title and other HTML parameters can still be set by using the **Insert > Wiki Markup** function from the editor toolbar, then using the syntax described in **Confluence Wiki Markup**.
Displaying a gallery of images

See the Gallery Macro.

Image file formats

You can attach image files of any format to a page. Confluence supports the following image formats in the Gallery macro and when displaying an image on a page:

- gif
- jpeg
- png
- bmp (depending on browser support)

Working with Tables

Confluence pages can include multi-row and multi-column tables. You can highlight cells, rows and columns in different colours. When viewing the page, people can sort the table by clicking the column headers.

Inserting a table

To create a table:

1. While editing the page, place your cursor at the point where you want to insert the table.
2. Choose Table on the toolbar.
3. A dropdown menu will appear, showing a table with a variable number of rows and columns. Click in a cell to set the number of columns and rows for your table.

What you can do with your table in the editor

While editing a page, place your cursor inside a table to see the following table operations appear in the toolbar.

<table>
<thead>
<tr>
<th>Table operation</th>
<th>Toolbar button</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert an empty row above the current one.</td>
<td><img src="image" alt="Insert Row" /></td>
</tr>
<tr>
<td>Insert an empty row below the current one.</td>
<td><img src="image" alt="Insert Row" /></td>
</tr>
<tr>
<td>Remove the current row.</td>
<td><img src="image" alt="Remove Row" /></td>
</tr>
<tr>
<td>Action</td>
<td>Icon</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>----------</td>
</tr>
<tr>
<td>Cut the current row and copy it to the clipboard.</td>
<td><img src="image" alt="Cut" /></td>
</tr>
<tr>
<td>Copy the current row to the clipboard.</td>
<td><img src="image" alt="Copy" /></td>
</tr>
<tr>
<td>Paste the row from the clipboard to the current row.</td>
<td><img src="image" alt="Paste" /></td>
</tr>
<tr>
<td>Insert an empty column to the left of the current one.</td>
<td><img src="image" alt="Insert" /></td>
</tr>
<tr>
<td>Insert an empty column to the right of the current one.</td>
<td><img src="image" alt="Insert" /></td>
</tr>
<tr>
<td>Remove the current column.</td>
<td><img src="image" alt="Remove" /></td>
</tr>
<tr>
<td>Merge the selected cells.</td>
<td><img src="image" alt="Merge" /></td>
</tr>
<tr>
<td>Split the selected merged cells.</td>
<td><img src="image" alt="Split" /></td>
</tr>
<tr>
<td>Highlight the current row. You can choose a colour from the dropdown</td>
<td><img src="image" alt="Highlight" /></td>
</tr>
<tr>
<td>arrow next to the three highlight options.</td>
<td></td>
</tr>
<tr>
<td>Highlight the current column. You can choose a colour from the dropdown</td>
<td><img src="image" alt="Highlight" /></td>
</tr>
<tr>
<td>arrow next to the three highlight options.</td>
<td></td>
</tr>
<tr>
<td>Highlight the current cell. You can choose a colour from the dropdown</td>
<td><img src="image" alt="Highlight" /></td>
</tr>
<tr>
<td>arrow next to the three highlight options.</td>
<td></td>
</tr>
<tr>
<td>Remove the table.</td>
<td><img src="image" alt="Remove" /></td>
</tr>
</tbody>
</table>

**Sorting the table in view mode**

When readers view a table on a page, they can sort the table by clicking the sort icons in the header row.

*Screenshot: A colourful, sortable table*
Using Symbols, Emoticons and Special Characters

You can add various symbols and special characters to Confluence pages. You can also use them in other places that display content, such as blog posts, comments, the dashboard welcome message and the configuration panels offered by the Documentation theme.

Inserting symbols and special characters

To add a symbol to your page:

1. Edit the page.
2. Choose **Insert > Symbol**. This will display the 'Insert Custom Character' window.
3. Choose a symbol to insert it.

**On this page:**
- Inserting symbols and special characters
- Inserting emoticons
- Preventing emoticons from appearing

**Related pages:**
- Icons Used in Confluence
- Quick Reference Guide for the Confluence Editor
- Confluence Wiki Markup
- Confluence User's Guide

**Screenshot : Available symbols**
Inserting emoticons

There are two ways to add an emoticon, or smiley, to your page.

By choosing an emoticon from those available:

1. Choose Insert > Emoticon.
2. Choose an emoticon to insert it.

By typing a character combination:

You can insert emoticons by typing commonly-used character combinations. For example, the following code appears as an emoticon when the page is rendered.

`;)

The above example creates this emoticon: 😊

This table shows the emoticons (and other icons) available in Confluence, and the character combinations that create them:

<table>
<thead>
<tr>
<th>Image</th>
<th>😊</th>
<th>😗</th>
<th>😈</th>
<th>😄</th>
<th>😅</th>
<th>😆</th>
<th>😇</th>
<th>😈</th>
<th>😉</th>
<th>😊</th>
</tr>
</thead>
<tbody>
<tr>
<td>Notation</td>
<td>:)</td>
<td>:(</td>
<td>:P</td>
<td>:D</td>
<td>:)</td>
<td>(y)</td>
<td>(n)</td>
<td>(/)</td>
<td>(x)</td>
<td>(l)</td>
</tr>
</tbody>
</table>
Preventing emoticons from appearing

To undo the conversion of a character combination into an emoticon, press **Ctrl+Z** (Windows) or **Cmd+Z** (Mac).

The Confluence knowledge base has an article on disabling emoticons.

Using Autocomplete

When using the Confluence editor, you can type a trigger character or press a keyboard shortcut to see a list of suggested links, files or macros to add to your page, or to mention another user (and automatically notify them of this).

Summary of autocomplete

<table>
<thead>
<tr>
<th>What you want to do</th>
<th>Trigger character</th>
<th>Keyboard shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a link on your page</td>
<td>[</td>
<td>Ctrl+Shift+K</td>
<td>See a list of suggested pages or other locations to link to from your page. More...</td>
</tr>
<tr>
<td>Display an image, video, audio file or document on your page</td>
<td>!</td>
<td>Ctrl+Shift+M</td>
<td>See a list of suggested images, multimedia files and documents to embed in your page. More...</td>
</tr>
<tr>
<td>Add a macro on your page</td>
<td>{</td>
<td>None</td>
<td>See a list of suggestions as you begin typing a macro name. More...</td>
</tr>
<tr>
<td>Notify another user by email that you have mentioned them on your page</td>
<td>@</td>
<td>None</td>
<td>See a list of suggested users to mention. More...</td>
</tr>
</tbody>
</table>

On this page:

- Summary of autocomplete
- Using autocomplete for links
- Using autocomplete for images, videos, audio files and documents
- Using autocomplete for macros
- Using autocomplete for mentions
- Cancelling autocomplete
- Enabling and disabling autocomplete
- Ignoring autocomplete

Related pages:

- Working with Links
- Using Images
- Working with Macros
- Keyboard Shortcuts
- User Profile Overview
- Confluence User's Guide
Using autocomplete for links

Type '[', or press Ctrl+Shift+K, to see a list of suggested pages or other locations to link to from your page. You can link to pages, user profiles, images, documents and other file attachments.

To autocomplete a link:

1. Edit the page.
2. Click where you want to insert a link and do one of the following:
   - Type '[' and then the first few characters of the page title, user's name, image name or file name.
   - Type the first few characters of the page title, user's name, image name or file name (or select relevant text) and then press Ctrl+Shift+K.
3. Click the relevant link from the list of suggestions.

If the item you need is not in the list, either:

   - Choose Search for 'xxx' to continue looking for the page within Confluence, or
   - Choose Insert Web Link to insert a link to an external web page using the link browser.

Screenshot: Autocomplete for a link

Using autocomplete for images, videos, audio files and documents

You can use the autocomplete as a fast way of embedding images, videos, audio files and documents into your page. Type an exclamation mark or press Ctrl+Shift+M to see a list of suggested images, multimedia files and documents to display on your page. You can use autocomplete to embed the following file types:

   - Images – any format that Confluence supports. See Displaying Images.
   - Videos, audio files and all multimedia formats that Confluence supports. See Embedding Multimedia Content.
   - Office documents supported by the Confluence Office Connector: Word, Excel and PowerPoint.
   - PDF files.

Autocomplete works most efficiently for files that are already attached to the Confluence page. See Attaching Files to a Page.
To embed an image, video, audio file or document:

1. Edit the page.
2. Click where you want to insert the image, video, audio file or document and do one of the following:
   - Type ‘!’ and then the first few characters of the image, file or document name.
   - Type the first few characters of the name of the image, file or document (or select relevant text) and then press Ctrl+Shift+M.
3. Choose the relevant file from the list of suggestions.

If the item you need is not in the list, either:

   - Choose [Open Image Browser](#) to find images and documents using the image browser, or
   - Choose [Insert Other Media](#) to embed videos, audio and other multimedia files using the macro browser. Insert the ‘Multimedia’ macro to display your multimedia file.

**Screenshot: Autocomplete for an image or document**

![Autocomplete for an image or document](image.png)

**Using autocomplete for macros**

Type ‘{’ to see a list of suggested macros to add to your page.

Autocomplete provides access to all available macros in your Confluence site, including any [user macros](#) that your administrator has added and made visible to all.

ℹ️ You need to know the name of macro. Autocomplete for macros will only match the name of the macro, not the description.

**To autocomplete a macro using ‘{’**: 

1. Edit the page.
2. Click where you want to insert the macro.
3. Type ‘{’ and then the first few characters of the macro name.
4. Choose the relevant macro from the list of suggestions.
5. Configure the macro by completing the form fields as prompted.

If the macro you need is not in the list, select [Open Macro Browser](#) in the list of suggestions to continue looking for the macro in the macro browser. See [Working with Macros](#).
Using autocomplete for mentions

You can use autocomplete to automatically notify another Confluence user that you have mentioned them in a page, blog post, or comment. Type '@' and part of the person's name, to see a list of suggested users.

**Note:** Use the person's full name. Autocomplete will recognise users' full names only, not their usernames.

**To mention someone using '@':**

1. Edit the page.
2. Click where you want to insert a mention and type '@' and then the first few characters of the user's full name.
3. Choose the user's name from the list of suggestions.

Cancelling autocomplete

The autocomplete starts automatically when you press the trigger characters. You may want to close the autocomplete menu or escape from autocomplete once it has started.

There are a few different ways to stop the autocomplete once it has started:

- Press the escape key, 'Esc', on your keyboard.
Enabling and disabling autocomplete

You can turn off the triggering of autocomplete by the '[' and ']' characters. This will prevent the autocomplete from starting automatically when you press one of the trigger characters. You can also turn it back on again.

Notes:
- This setting does not affect the keyboard shortcuts for autocomplete (Ctrl+Shift+K and Ctrl+Shift+M). Even if the trigger characters are disabled, you can still use the keyboard shortcuts for autocomplete.
- This setting affects only you. Other people using Confluence can enable or disable the setting on their user profiles independently.
- Note that autocomplete is enabled by default.

To enable or disable the autocomplete trigger characters:

1. Go to your name (the 'User' menu) at the top of the page and choose Settings.
2. Choose Editor under ‘Your Settings’ in the left-hand panel.
3. Click Edit.
4. Either:
   - Disable autocompletion by selecting Disable Autocomplete.
   - Enable autocompletion by clearing Disable Autocomplete.
5. Click Submit.

Screenshot: User Settings for the Editor

Ignoring autocomplete

You can add macros, links and images by wiki markup alone. Type the macro, including its parameters and the closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket. Insert an image or other embedded object, enclosed between exclamation marks. As soon as you close the macro, link, or embedded image, Confluence will convert it to rich text format and add it to the page.

More information about mouse-free macros, links and images:
- Quick Reference Guide for the Confluence Editor
- Video

Working with Page Layouts and Columns and Sections

When you want to add structure to the information on your page, it is often useful to split the information into columns. By 'column', we mean a vertical block of content. You may want more than one column across the width of the page.

You may also want to use a common structure on a number of pages, so that readers know where to find the
information within each page. In addition to columns, sections are useful here. By 'section', we mean an area of the page. A section may contain one or more columns.

Confluence provides the following ways of creating columns and sections on a page:

- Page layouts offer a set of predefined columns and sections.
- The Section and Column macros allow more flexibility. You can set the width of the columns, and put the sections and columns in any part of the page.

On this page:
- Using page layouts
- Using the Section and Column macros

Related pages:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Using the Editor
- Working with Macros
- Working with Tables

Using page layouts

The Confluence editor offers a set of predefined page layouts. Each layout provides one or more columns. Some layouts also provide a horizontal block at the top and bottom of the page. The layout that you select determines the position of the sections and columns on the page, as well as the relative width of the columns. The page's content is confined within the borders of the layout. You cannot add content above or below the sections and columns provided by the layout.

To choose a page layout:

1. While editing the page, click the page layout icon. A dropdown list appears, showing icons that illustrate the available layouts.
2. Select a layout.

Screenshot: Choosing a page layout

If your page already has content on it, Confluence will put the existing content into the left-hand column of the new layout. If the page was using a different layout, Confluence will put the content into the appropriate sections.
and columns of the new layout.

**Screenshot: A page with a three-column layout, in edit mode**

**Notes about page layouts**

- **Very wide tables.** The width of each column is set to a percentage of the page width. The icons in the dropdown menu indicate the relative widths for each layout. In most cases, Confluence will adapt the width of the columns to fit the width of the page. If a column includes a large table, the content may not fit into the width of the page. You will see a horizontal scroll bar when viewing the page.
- **Mixing and matching.** You can put Section and Column macros inside page layouts. You can also put tables inside page layouts.

**Using the Section and Column macros**

You can use the Section and Column macros to add a set of columns to the page. The Section macro defines an area that will contain the columns. You can have as many sections as you like. Within each section, you can have as many columns as you like.

**To add a section and some columns to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find the **Section** macro, select it and insert it onto the page.
3. Choose **Insert > Other Macros** again.
4. Find and insert the **Column** macro.
5. Add your content to the column.
6. Insert as many columns as you like within the section.

**Screenshot: A section and two columns in the editor**
Macro parameters

Parameters are options that you can set to control the content or format of the macro output.

Parameters of the Section macro

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Border</td>
<td>false</td>
<td>Select this option to draw a border around the section and columns.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Note</strong>: Without a Column macro, the border will not be displayed correctly.</td>
</tr>
</tbody>
</table>

Parameters of the Column macro

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Width</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>Specify the width of the column, in pixels (for example, 400px) or as a percentage of the available width (for example, 50%).</td>
</tr>
</tbody>
</table>

Notes about sections and columns

- All content within your section must be enclosed within a Column macro, otherwise the section layout will not work as expected.
- You can put tables inside columns.
- PDF exports do not handle page layouts. See this issue report:
Working with Macros

Using a macro, you can add extra functionality or include dynamic content on a page. For example, the *Attachments macro* will list a page's attachments in the page itself, so that readers do not have to visit the Attachments tab.

On this page:
- Adding a Macro to your Page
- Macros Shipped with your Confluence Installation
- Information about Other Macros
- Writing your own Macros
- Code examples
- Related Topics

Adding a Macro to your Page

Including Macros with the Macro Browser

To add a macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Macro Parameters**

Many macros allow you to include optional parameters to control the macro's output.

With the Attachments Macro, for instance, you have two optional parameters allowing you to:

- Specify the file formats of the attachments displayed.
- Choose whether or not you want old versions of the attachments displayed.

**Macro Placeholders**

Macro placeholders are displayed in the editor where you have added a macro to the page.

When editing a page, you can:

- Double-click a macro placeholder (or click the placeholder and choose Edit) to open the macro dialog window, where you can edit the macro's parameters.
- Select a macro placeholder to cut, copy and paste the macro.

**Macros Shipped with your Confluence Installation**

When you download your Confluence installation file, many macros are shipped with the download. Below is a list of the macros currently shipped with Confluence. Click a macro name for details of the usage, including optional parameters and examples.

- Anchor Macro

  Allows you to link to a specific part of a page.
Attachments Macro
Displays a list of attachments on a given page.

Blog Posts Macro
Lists the most recent news items in the space.

Change-History Macro
Displays a history of updates made to a page.

Chart Macro
Displays a chart based on tabular data.

Cheese Macro
Displays the words "I like cheese!"

Children Display Macro
Displays the children and descendants of the current page.

Code Block Macro
Displays code in your document with the appropriate syntax highlighting.

Column Macro
Used with the Section macro to define columns on a page. See Working with page layouts and columns and sections.

Content by Label Macro
Displays a list of content associated with specific labels.

Content by User Macro
Displays a list of the content items that have been created by a specified Confluence user.

Contributors Macro
Displays a list of Confluence users who have made a contribution of some type to a page.

Contributors Summary Macro
Displays a table of contribution-based statistics for a set of pages.

Create Space Button Macro
Renders a create space button linked to the create space page.

Detailssummary Macro
Presents a tabulated summary of selected metadata, which has been embedded using the Metadata Macro on any page or blog post in the current Confluence space.

Excerpt Include Macro
Allows you to display an excerpt from another page within the current page.
**Excerpt Macro**

Define a part of a page as the page's 'excerpt' which can then be displayed in another page.

**Expand Macro**

Displays an expandable/collapsible section of text.

**Favourite Pages Macro**

Displays a list of your favourite pages.

**Gadget Macro**

Allows you to add Confluence gadgets to pages or blog posts.

**Gallery Macro**

Forms a thumbnail gallery of all images attached to a page.

**Global Reports Macro**

Renders a list of links to global reports within a table.

**HTML Include Macro**

Includes the content of an external HTML file into a Confluence page.

**HTML Macro**

Renders your specified HTML code within the current page.

**IM Presence Macro**

Displays graphically when a contact is online.

**Include Page Macro**

Inserts the contents of the specified page into the current one.

**Info Macro**

Displays a block of text in a blue highlight box.

**JIRA Issues Macro**

Displays a list of JIRA issues in a page.

**JIRA Macro**

Displays one or more JIRA issues on your Confluence page.

**JUnit Report Macro**

Display a summary of JUnit test results.

**Labels List Macro**

Displays a hyperlinked alphabetical index of all labels within the current space.

**Livesearch Macro**

Add a dynamic search box to a wiki page.
Loremipsum Macro

Display a few paragraphs of pseudo-Latin text.

Metadata Macro

Allows you to embed metadata into pages and blog posts for presentation with the Detailssummary Macro

Multimedia Macro

Displays videos, animations and more, sourced from a file attached to a Confluence page and displayed on your page.

Navigation Map Macro

Renders the list of pages associated with a specified label as a navigable map.

Network Macro

Displays a list of Network activity for users in your Confluence site

Noformat Macro

Displays a block of text in monospace font.

Note Macro

Displays a block of text in a yellow highlight box.

Page Index Macro

Creates a hyperlinked alphabetical index of all page titles within the current space.

Page Tree Macro

Displays a dynamic, hierarchical list of pages starting from a specified parent (root) page.

Page Tree Search Macro

Adds a search box to your Confluence page and searches a hierarchy of pages starting from a specified parent (root) page.

Panel Macro

Displays a block of text within a fully customisable panel.

Popular Labels Macro

Displays the most popular labels used throughout your Confluence site or within a space.

Profile Picture Macro

Displays a user’s profile picture on a page.

Recently Updated Dashboard Macro

Displays a list of the most recently changed content within Confluence and is intended for use on the Confluence dashboard.

Recently Updated Macro

Displays a list of recently changed content (pages, news items, comments, etc).
Recently Used Labels Macro

Lists labels most recently used in a specified scope (global, space, or personal)

Related Labels Macro

Lists labels frequently appearing on the same pages as the current page's labels.

RSS Feed Macro

Displays the contents of an RSS feed.

Search Results Macro

Searches Confluence, and includes the results in the page.

Section Macro

Used with the Column macro to define columns on a page. See Working with page layouts and columns and sections.

Space Attachments Macro

Displays a list of attachments belonging to the current space.

Space Details Macro

Includes the summary of a Confluence space in the page.

Space Jump Macro

 Allows you to link from a page in one space to a page with the same name in another space, without knowing the name of the page when you create the link.

Spaces List Macro

Displays a list of all spaces visible to the user.

Status Macro

Displays a coloured lozenge, useful for reporting project status.

Table of Contents Macro

Displays a table of contents from your page headings.

Table of Content Zone Macro

Displays a table of contents from a defined page 'zone'.

Tasklist Macro

Displays a dynamic task list which can be modified in 'view' mode.

Tip Macro

Displays a block of text in a green highlight box.

User List Macro

Displays a list of Confluence users, from an optional group.

User Profile Macro
Displays a short summary of any Confluence user's profile on your Confluence page or blog.

*User Status List Macro*

Displays a history of any Confluence user's status updates on your Confluence page or blog.

*View File Macro*

Embeds an Office document or PDF file into your Confluence page.

*Warning Macro*

Displays a block of text in a red highlight box.

*Widget Connector Macro*

Displays videos, slide shows, twitter chats, documents and more, sourced from other web sites and displayed on your Confluence page.

**Information about Other Macros**

Other macros are available as plugins or as user macros, and can be installed by your Confluence administrator.

Macros that may be of interest are also available from Adaptavist, CustomWare and the Confluence SharePoint Connector.

**Writing your own Macros**

To learn how to write your own macro, take a look at the following documentation:

- User macros are simple template-like macros that allow you to create simple formatting macros using the Confluence web interface. Read more about Writing User Macros.
- The Confluence Plugin Guide tells you how to develop a plugin for Confluence.

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Related Topics**

Atlassian Plugin Exchange
Installing Plugins and Macros

Take me back to the Confluence User's Guide.

**Anchor Macro**

The Anchor Macro is documented in Working with Anchors.

**Attachments Macro**

See Displaying a List of Attachments.

**Blog Posts Macro**

The Blog Posts macro allows you to display blog posts on a Confluence page. Clicking on a title takes you to the blog post.
Using the Blog Posts Macro

To add the Blog Posts macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

---

On this page:

- Using the Blog Posts Macro
- Parameters

Related pages:

- Working with Macros
- Working with Blog Posts
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

---

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Content Type to Display</td>
<td>titles</td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>titles</strong> — Display only the title of each blog post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>excerpts</strong> — Display a short excerpt from each blog post. If the post contains an Excerpt macro, the Blog Posts macro will display the content defined in the Excerpt macro. If the post does not contain an Excerpt macro, the Blog Posts macro will display the first few sentences of the post.</td>
</tr>
</tbody>
</table>
| **Time Frame** | no limit | Specify how far back in time Confluence should look for the blog posts to be displayed.

Available values:
- **m** — Minutes
- **h** — Hours, so ’12h’ displays blog posts created in the last twelve hours.
- **d** — Days, so ’7d’ displays blog posts created in the last seven days.
- **w** — Weeks |

| **Restrict to these Labels** | None | Filter the results by label. The macro will display only the blog posts which are tagged with the label(s) you specify here.

You can specify one or more label values, separated by a comma or a space.

- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labelled with ‘badpage’.
- To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage,+goodpage you will get only content which has at least two labels, being 'superpage' and 'goodpage'. |

| **Restrict to these Authors** | None | Filter the results by author. The macro will display only the blog posts which are written by the author(s) you specify here.

You can specify one or more authors, separated by a comma. |
| **Restrict to these Spaces** | @self, i.e. the space which contains the page on which the macro is coded | This parameter allows you to filter content by space. The macro will display only the pages which belong to the space(s) you specify here.

You can specify one or more space keys, separated by a comma or a space.

- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of `-BADSPACE` you will get only content which is not in the BADSPACE.
- To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of `+GOODSPACE` you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:

- `@self` — The current space.
- `@personal` — All personal spaces.
- `@global` — All global spaces.
- `@favorite` — The spaces you have marked as favourite.
- `@favourite` — The same as @favorite above.
- `@all` — All spaces in your Confluence site.
- `*` — The same as @all above.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as `~jbloggs` or `~jbloggs@example.com`. |
<table>
<thead>
<tr>
<th>Maximum Number of Blog Posts</th>
<th>15</th>
<th>Specify the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort By</td>
<td>creation</td>
<td>Specify how the results should be sorted. If this parameter is not specified, the sort order defaults to descending order (newest first) based on the creation date. Values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>title</strong> — Sort alphabetically by title.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>creation</strong> — Sort by the date on which the content was added.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>modified</strong> — Sort by the date on which the content was last updated.</td>
</tr>
<tr>
<td>Reverse Sort</td>
<td>false</td>
<td>Select to change the sort from descending to ascending order (oldest first). Use this parameter in conjunction with the <strong>Sort By</strong> parameter. This parameter is ignored if the <strong>Sort By</strong> parameter is not specified.</td>
</tr>
</tbody>
</table>

**Change-History Macro**

The Change-History macro shows the history of updates made to a page: version number, author, date and comment. It displays the information inline.

**Screenshot: The Change-History macro in Confluence**

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Version (v. 3)</td>
<td>Apr 01, 2009 16:55</td>
<td>Conf Admin</td>
</tr>
<tr>
<td>v. 2</td>
<td>Apr 01, 2009 13:09</td>
<td>Conf Admin</td>
</tr>
<tr>
<td>v. 1</td>
<td>Apr 01, 2009 11:03</td>
<td>Conf Admin</td>
</tr>
</tbody>
</table>

**Related pages:**

- [Working with Macros](#)
- [Confluence Wiki Markup for Macros](#)
- [Confluence Storage Format for Macros](#)
- [Confluence User's Guide](#)

**To add the Change-History macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Note:** There are no parameters for this macro.

**Chart Macro**

The Chart macro allows you to display a chart based on tabular data. When you add the macro to a page, you:

- supply the data to be charted by the macro as a table in the placeholder of the macro.
- edit the macro parameters in the Macro Browser to configure the format of the chart.

**Screenshot 1: A table of data in the Chart macro placeholder**

<table>
<thead>
<tr>
<th>Weeks</th>
<th>Issues Burndown</th>
</tr>
</thead>
<tbody>
<tr>
<td>04/07/2011</td>
<td>81</td>
</tr>
<tr>
<td>11/07/2011</td>
<td>68</td>
</tr>
<tr>
<td>18/07/2011</td>
<td>67</td>
</tr>
<tr>
<td>25/07/2011</td>
<td>66</td>
</tr>
<tr>
<td>01/08/2011</td>
<td>65</td>
</tr>
<tr>
<td>08/08/2011</td>
<td>65</td>
</tr>
<tr>
<td>15/08/2011</td>
<td>64</td>
</tr>
<tr>
<td>22/08/2011</td>
<td>44</td>
</tr>
<tr>
<td>29/08/2011</td>
<td>24</td>
</tr>
<tr>
<td>05/09/2011</td>
<td>0</td>
</tr>
</tbody>
</table>

**Screenshot 2: The resulting chart**

![Chart](chart.png)
Using the Chart Macro

To add the Chart macro to a page:

1. Edit the page and use autocomplete to add the Chart macro. (Type `{chart}`.)
2. Enter your chart data as one or more tables in the body of the macro placeholder. (See the screenshot above.)
3. Click the macro placeholder and choose Edit.
4. Select a chart type using the Type parameter (see below).
5. Choose other parameter settings in the macro browser, as described below.
6. Click Refresh in the 'Preview' area, to check that the chart appears as you expect.
7. Click Save to add the chart to your page.
8. Click Save again when you are ready to save the page.

Parameters

Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification Parameters | Colour Parameters | Axis Parameters | Pie Chart Parameters | Attachment Parameters

Chart Type Parameters

These parameters determine the type of chart to display and the way the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Related pages:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Working with Macros
- Confluence User's Guide
### Display Control Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td>Height</td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
<tr>
<td>Display rendered data</td>
<td>false</td>
<td>Sets whether to display the rendered body of the macro (usually the data tables). By default, the chart data table isn't rendered.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>•  before — the data are displayed before the chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>•  after — the data are displayed after the chart.</td>
</tr>
</tbody>
</table>

- **Type**
  - **pie**

  The type of chart to display. **XY charts** have numerical x- and y-axes. The x values may optionally be time-based (see the **Time Series** parameter).

  - **Standard** — pie, bar, line, area
  - **XY Plots** — xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries
  - **Other** — gantt (beta)

- **Display Orientation**
  - **vertical**

  Applies to area, bar and line charts.

  - **vertical** — y-axis is vertical
  - **horizontal** — x-axis is vertical

- **Show in 3D**
  - **false**

  Applies to area, bar and line charts.

- **Stacked Values**
  - **false**

  Applies to area and bar charts.

- **Show shapes**
  - **true**

  Applies to line charts. Shapes are shown at each data point.

- **Opacity**
  - 75 percent for 3D charts
  - 50 percent for non-stacked area charts
  - 100 percent for all other charts

  A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are.
The image format to be used for the chart.

- **png**
- **jpg**

### Title and Label Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart Title</td>
<td>none</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>Chart Subtitle</td>
<td>none</td>
<td>A subtitle for the chart, using a smaller font than for Title.</td>
</tr>
<tr>
<td>Horizontal-axis Label</td>
<td>none</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>Vertical-axis Label</td>
<td>none</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Show a legend or key.</td>
</tr>
</tbody>
</table>

### Data Specification Parameters

The data for the chart is taken from tables found when the macro body is rendered. These options control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. Additional conversion options can be specified using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables</td>
<td>all first level tables</td>
<td>Comma separated list of table ids and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
</tr>
<tr>
<td>Columns</td>
<td>all columns</td>
<td>Comma separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the (html) title attribute for the column in the header row.</td>
</tr>
</tbody>
</table>
| Content Orientation | horizontal | • **vertical** — data table columns will be interpreted as series.  
• **horizontal** — data tables rows will be interpreted as series. |
<table>
<thead>
<tr>
<th>Time Series</th>
<th>false</th>
<th>• true — the x values in an XY plot will be treated as time series data and so will be converted according to date formats.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date format</td>
<td>Confluence language defined date formats</td>
<td>For time series data, the date format allows for additional customization of the conversion of data to date values. If a Date format is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See simple date format.</td>
</tr>
<tr>
<td>Time Period</td>
<td>Day</td>
<td>The time period for time series data. Defines the granularity of how the data is interpreted. Valid values are: Millisecond, Second, Minute, Hour, Day, Week, Month, Quarter, Year.</td>
</tr>
<tr>
<td>Language</td>
<td>none</td>
<td>Use in combination with the Country parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages. Valid values are 2 character ISO 639-1 alpha-2 codes.</td>
</tr>
<tr>
<td>Country</td>
<td>none</td>
<td>Use in combination with the Language parameter to form a locale. Valid values are 2 character ISO 3166 codes.</td>
</tr>
<tr>
<td>Forgive</td>
<td>true</td>
<td>• true — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats. • false — enforce strict data format. Data format errors will cause the chart to not be produced.</td>
</tr>
</tbody>
</table>

Colours are specified using hexadecimal notation or HTML colour names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background Colour</td>
<td>White</td>
<td>Background of the chart.</td>
</tr>
<tr>
<td>Border Colour</td>
<td>no border</td>
<td>Border around the chart.</td>
</tr>
</tbody>
</table>
Colours

Comma-separated list of colours used to customise category, sections, and series colours.

**Axis Parameters**

Depending on the chart type, the range and domain axis may be customised. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range Minimum Value</td>
<td>none</td>
<td>Range axis lower bound.</td>
</tr>
<tr>
<td>Range Maximum Value</td>
<td>none</td>
<td>Range axis upper bound.</td>
</tr>
<tr>
<td>Range Axis Tick Unit</td>
<td>none</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>Range Axis Label Angle</td>
<td>none</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>Domain Axis Lower Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the <strong>Date format</strong> parameter.</td>
</tr>
<tr>
<td>Domain Axis Upper Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the <strong>Date format</strong> parameter.</td>
</tr>
<tr>
<td>Domain Axis Tick Unit</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the <strong>Time Period</strong> parameter. The <strong>Time Period</strong> unit can be overridden by specifying a trailing character: y (years), M (months), d (days), h (hours), m (minutes), s (seconds), u (milliseconds).</td>
</tr>
<tr>
<td>Domain Axis Label Angle</td>
<td>none</td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
</tr>
<tr>
<td>Category Label Position</td>
<td>none</td>
<td>Placement of the axis label text for categories.</td>
</tr>
<tr>
<td>------------------------</td>
<td>------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• up45 — 45 degrees going upward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• up90 — 90 degrees going upward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• down45 — 45 degrees going downward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• down90 — 90 degrees going downward</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Date Tick Mark Position</th>
<th>start</th>
<th>Placement of the date tick mark.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>• start — tick mark is at the start of the date period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• middle — tick mark is in the middle of the date period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• end — tick mark is at the end of the date period.</td>
</tr>
</tbody>
</table>

### Pie Chart Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Pie Section Label  | Show only the pie section key value | Format for how pie section labels are displayed. The format uses a string with special replacement variables:  
  • %0% is replaced by the pie section key.  
  • %1% is replaced by the pie section numeric value.  
  • %2% is replaced by the pie section percent value.  
  Example 1: "%0% = %1%" would display something like "Independent = 20"  
  Example 2: "%0% (%2%)" would display something like "Independent (20%)" |
| Pie Section Explode| No exploded sections              | Comma separated list of pie keys that are to be shown exploded.  
  Note: requires jFreeChart version 1.0.3 or higher. |

### Attachment Parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is
displayed. These options allow for the generated image to be saved as an attachment and have subsequent access re-use the attachment. This can be useful especially when combined with the Cache Plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachment</td>
<td>none</td>
<td>The name and location with which the chart image will be saved as an attachment. The user must be authorised to add attachments to the page specified.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• ^attachmentName.png — the chart is saved as an attachment to the current page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• page^attachmentName.png — the chart is saved as an attachment to the page name provided.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• space:page^attachmentName.png — the chart is saved as an attachment to the page name provided in the space indicated.</td>
</tr>
<tr>
<td>Attachment Version</td>
<td>new</td>
<td>Defines the versioning mechanism for saved charts.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• new — creates new version of the attachment.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• replace — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorized to remove attachments for the page specified.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• keep — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated.</td>
</tr>
<tr>
<td>Attachment Comment</td>
<td>none</td>
<td>Comment used for a saved chart attachment.</td>
</tr>
<tr>
<td>Thumbnail</td>
<td>false</td>
<td>• true — the chart image attachment will be shown as a thumbnail.</td>
</tr>
</tbody>
</table>
## Colour Parameters | Axis Parameters | Pie Chart

### Parameters | Attachment Parameters

### Examples

#### Pie Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>pie</td>
<td></td>
</tr>
<tr>
<td><strong>Chart Title</strong></td>
<td>Fish Sold 2011</td>
<td></td>
</tr>
<tr>
<td><strong>Show Legend</strong></td>
<td>true</td>
<td></td>
</tr>
<tr>
<td><strong>Content Orientation</strong></td>
<td>vertical</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Fish Type</th>
<th>2011</th>
</tr>
</thead>
<tbody>
<tr>
<td>Herring</td>
<td>9,500</td>
</tr>
<tr>
<td>Salmon</td>
<td>2,900</td>
</tr>
<tr>
<td>Tuna</td>
<td>1,500</td>
</tr>
</tbody>
</table>

#### Bar Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>bar</td>
<td></td>
</tr>
<tr>
<td><strong>Chart Title</strong></td>
<td>Fish Sold</td>
<td></td>
</tr>
<tr>
<td><strong>Show Legend</strong></td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Fish Type</th>
<th>2010</th>
<th>2011</th>
</tr>
</thead>
<tbody>
<tr>
<td>Herring</td>
<td>9,500</td>
<td>8,300</td>
</tr>
<tr>
<td>Salmon</td>
<td>2,900</td>
<td>4,200</td>
</tr>
<tr>
<td>Tuna</td>
<td>1,500</td>
<td>1,500</td>
</tr>
</tbody>
</table>

#### 3D Bar Chart
### Parameters in Macro Browser

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>bar</td>
</tr>
<tr>
<td>Show in 3D</td>
<td>true</td>
</tr>
<tr>
<td>Opacity</td>
<td>50</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
</tr>
</tbody>
</table>

### Data Table in Macro Placeholder

<table>
<thead>
<tr>
<th>Year</th>
<th>Revenue</th>
<th>Expenses</th>
</tr>
</thead>
<tbody>
<tr>
<td>2009</td>
<td>12.4</td>
<td>43.6</td>
</tr>
<tr>
<td>2010</td>
<td>31.8</td>
<td>41.8</td>
</tr>
<tr>
<td>2011</td>
<td>41.1</td>
<td>31.1</td>
</tr>
</tbody>
</table>

### Rendered Chart

![Revenue and Expense Chart](chart.png)

### Time Series Chart

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Time Series</td>
</tr>
<tr>
<td>Date Format</td>
<td>MM/yyyy</td>
</tr>
<tr>
<td>Time Period</td>
<td>Month</td>
</tr>
<tr>
<td>Data Orientation</td>
<td>vertical</td>
</tr>
<tr>
<td>Range Axis Lower Bound</td>
<td>0</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
</tr>
</tbody>
</table>

### Data Tables in Macro Placeholder

<table>
<thead>
<tr>
<th>Year</th>
<th>Month</th>
<th>Revenue</th>
<th>Expenses</th>
</tr>
</thead>
<tbody>
<tr>
<td>2009</td>
<td>1/2011</td>
<td>31.8</td>
<td></td>
</tr>
<tr>
<td>2010</td>
<td>2/2011</td>
<td>41.8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3/2011</td>
<td>51.3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>4/2011</td>
<td>33.8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>5/2011</td>
<td>27.6</td>
<td></td>
</tr>
<tr>
<td></td>
<td>6/2011</td>
<td>49.8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>7/2011</td>
<td>51.8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>8/2011</td>
<td>77.3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>9/2011</td>
<td>73.8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>10/2011</td>
<td>97.6</td>
<td></td>
</tr>
<tr>
<td></td>
<td>11/2011</td>
<td>101.2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>12/2011</td>
<td>113.7</td>
<td></td>
</tr>
<tr>
<td>2010</td>
<td>1/2011</td>
<td>41.1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>2/2011</td>
<td>43.8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3/2011</td>
<td>45.3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>4/2011</td>
<td>45.0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>5/2011</td>
<td>44.6</td>
<td></td>
</tr>
<tr>
<td></td>
<td>6/2011</td>
<td>43.8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>7/2011</td>
<td>51.8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>8/2011</td>
<td>52.3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>9/2011</td>
<td>53.8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>10/2011</td>
<td>55.6</td>
<td></td>
</tr>
<tr>
<td></td>
<td>11/2011</td>
<td>61.2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>12/2011</td>
<td>63.7</td>
<td></td>
</tr>
</tbody>
</table>
### XY Line Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>xyLine</td>
<td></td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td></td>
<td>12 14 23</td>
<td><img src="image" alt="Chart" /></td>
</tr>
<tr>
<td>Revenue</td>
<td>41.1 31.8 12.4</td>
<td></td>
</tr>
<tr>
<td>Expense</td>
<td>31.1 41.8 43.6</td>
<td></td>
</tr>
</tbody>
</table>

### XY Area Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>xyArea</td>
<td></td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td></td>
<td>12 14 23</td>
<td><img src="image" alt="Chart" /></td>
</tr>
<tr>
<td>Revenue</td>
<td>41.1 31.8 12.4</td>
<td></td>
</tr>
<tr>
<td>Expense</td>
<td>31.1 41.8 43.6</td>
<td></td>
</tr>
</tbody>
</table>
## Parameters in Macro Browser

<table>
<thead>
<tr>
<th>Type</th>
<th>area</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Legend</td>
<td>true</td>
</tr>
<tr>
<td>Width</td>
<td>300</td>
</tr>
<tr>
<td>Height</td>
<td>300</td>
</tr>
<tr>
<td>Opacity</td>
<td>50</td>
</tr>
</tbody>
</table>

### Data Table in Macro Placeholder

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2009</th>
<th>2010</th>
<th>2011</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
<td>34</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>

### Rendered Chart

- Very satisfied
- Satisfied
- Dissatisfied
- Very dissatisfied

## Example 2

### Parameters in Macro Browser

<table>
<thead>
<tr>
<th>Type</th>
<th>area</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Legend</td>
<td>true</td>
</tr>
<tr>
<td>Width</td>
<td>300</td>
</tr>
<tr>
<td>Height</td>
<td>300</td>
</tr>
<tr>
<td>Stacked Values</td>
<td>true</td>
</tr>
</tbody>
</table>

### Data Table in Macro Placeholder

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2009</th>
<th>2010</th>
<th>2011</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>12</td>
<td>23</td>
<td>31</td>
</tr>
<tr>
<td>Satisfied</td>
<td>1</td>
<td>34</td>
<td>36</td>
</tr>
</tbody>
</table>

### Rendered Chart
Cheese Macro
The Cheese macro simply displays the words "I like cheese!" You can use this macro to test the Confluence macro functionality.

To add the Cheese macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Note: There are no parameters for this macro.

Related pages:
- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- How to Make Gorgonzola Cheese
- Confluence User's Guide

Children Display Macro
Use the Children Display macro to list the child pages of a page and the further descendants (children's children). By default, the macro displays links to the child pages as in the screenshot below. People viewing the page will see only the links for pages that they have permission to view.

Screenshot: The Children Display macro in Confluence
Using the Children Display macro

To add the Children Display macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Example

This list of child pages is generated by a Children Display macro on this page:

- Child Page 1
- Child Page 2

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Related pages:

- Working with Page Families
- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide
| **Show Descendants**         | false | Choose whether to display all the parent page's descendants.  
|                             |       | • If true shows the complete tree of pages underneath the parent page, regardless of Depth of Descendants  
| **Parent Page**             | current | Specify the page to display children for, from either the current space or a different space. Enter:  
|                             |       | • '/' — to list the top-level pages of the current space, i.e. those without parents.  
|                             |       | • 'pagename' — to list the children of the specified page.  
|                             |       | • 'spacekey:' — to list the top-level pages of the specified space.  
|                             |       | • 'spacekey:pagename' — to list the children of the specified page in the specified space.  
| **Number of Children**      | none | Restrict the number of child pages that are displayed at the top level.  
| **Depth of Descendants**    | none | Enter a number to specify the depth of descendants to display. This setting has no effect of Show Descendants is enabled.  
| **Heading Style**           | none | Choose the style used to display descendants.  
| **Include Excerpts**        | false | Display excerpts for the child pages, if they exist.  
| **Sort Children By**        | Manual if manually ordered, otherwise alphabetical | Optional. Choose:  
|                             |       | • creation — to sort by content creation date  
|                             |       | • title — to sort alphabetically on title  
|                             |       | • modified — to sort of last modification date.  
| **Reverse Sort**            | false | Use with the Sort Children By parameter. When set, the sort order changes from ascending to descending.  

**Child Page 1**

*Grandchild*
Child Page 2

This page is used to test the \{children\} macro.

Related Topics

Children Display Macro

Code Block Macro

The Code Block macro allows you to display source code in your document with the appropriate syntax highlighting. The code block displays on the page as shown below:

```java
public static void main(String[] args) {
    System.out.println("Hello World!");
}
```

On this page:

- Using the Code Block Macro
- Parameters

Related pages:

- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

**Using the Code Block Macro**

To add the Code Block macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type \{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

You can now type the code block directly into the macro placeholder in the editor. Note that any white space contained in the placeholder is not manipulated in any way by the Code Block macro. This is to provide the writer with flexibility over code indentation.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
| **Syntax highlighting** | java | Specifies the language (or environment) for syntax highlighting. The default language is Java but you can choose from one of the following languages/environments:

- actionscript3
- bash
- csharp (C#)
- coldfusion
- cpp (C++)
- css
- delphi
- diff
- erlang
- groovy
- html/xml
- java
- javafx
- javascript
- none (no syntax highlighting)
- perl
- php
- powershell
- python
- ruby
- scala
- sql
- vb |
<p>| <strong>Title</strong> | none | Adds a title to the code block. If specified, the title will be displayed in a header row at the top of the code block. |
| <strong>Collapsible</strong> | false | If selected, the code macro's content will be collapsed upon visiting or refreshing the Confluence page. Clicking the expand and source link allows you to view this content. If false, the code macro's content is always displayed in full. |
| <strong>Show line numbers</strong> | false | If selected, line numbers will be shown to the left of the lines of code. |
| <strong>First line number</strong> | 1 | When Show line numbers is selected, this value defines the number of the first line of code. |</p>
<table>
<thead>
<tr>
<th>Theme</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Specifies the colour scheme used for displaying your code block. Many of these themes are based on the default colour schemes of popular integrated development environments (IDEs). The default theme is <strong>Confluence</strong> (also known as <strong>Default</strong>), which is typically black and coloured text on a blank background. However, you can also choose from one of the following other popular themes:</td>
</tr>
<tr>
<td></td>
<td>- Django</td>
</tr>
<tr>
<td></td>
<td>- Emacs</td>
</tr>
<tr>
<td></td>
<td>- FadeToGrey</td>
</tr>
<tr>
<td></td>
<td>- Midnight</td>
</tr>
<tr>
<td></td>
<td>- RDark</td>
</tr>
<tr>
<td></td>
<td>- Eclipse</td>
</tr>
<tr>
<td></td>
<td>- Confluence</td>
</tr>
</tbody>
</table>

**Column Macro**

**Used with the Section macro to define columns on a page. See** [Working with page layouts and columns and sections](#).

**Content by Label Macro**

The Content by Label macro displays links to pages, blog posts and attachments that have been tagged with specific labels.

**A working example**

Below is a working example of the Content by Label macro, displaying content with the label 'LDAP'.

No content found for label(s) LDAP.

---

**On this page:**

- [A working example](#)
- [Using the Content by Label Macro](#)
- [Parameters](#)

**Related pages:**

- [Related Labels Macro](#)
- [Navigation Map Macro](#)
- [Recently Used Labels Macro](#)
- [Working with Confluence Labels](#)
- [Working with Macros](#)
- [Confluence Wiki Markup for Macros](#)
- [Confluence Storage Format for Macros](#)
- [Confluence User's Guide](#)

---

Using the Content by Label Macro

To add the Content by Label macro to a page:
1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Label(s)    | None    | Filter by label(s). The macro will display only the content tagged with the label(s) specified here. See also the **Operator** parameter below. This parameter is required. Specify one or more labels, separated by a comma or a single space.  
- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of `-badpage` you will get only content which is not labelled with 'badpage'.  
- To indicate that the results **must** match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of `+superpage,+goodpage` you will get only content which has at least two labels, being 'superpage' and 'goodpage'. |
| Author(s)   | None    | Filter by author. The macro will display only the content created or updated by the author(s) specified here. Specify one or more authors, separated by a comma. |
| **Include this Content Type Only** | all | Filter by content type. The macro will display only the content of the type specified here. Specify one or more content types, separated by a comma or a space. To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of `-blogpost` you will get pages and all other content except for blog posts. Available values:  
- page – Pages.  
- blogpost or news – Blog posts, also known as news items.  
- attachment – Attachments |
| **Show Labels for Each Page** | true | Show or hide labels in the results. |
| **Show Space Name for Each Page** | true | Show or hide spaces in the results. |
| **List Title** | None | Add a title or heading to the list. |
| **Maximum Number of Pages** | 15 | Limit the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied. |
| **Display Excerpts** | false | Include excerpts from each page listed. Note that you must have defined excerpts on each of those pages, by adding the **excerpt macro** to the page. Only the first few lines of the excerpt for each page are displayed. |
| **Restrict to these Spaces** | @all | Filter by space. The macro will display only the content which belongs to the space(s) specified here. Specify one or more space keys, separated by a comma or a space.

- To exclude content in a specific space, put a minus sign (−) immediately in front of that space key. For example: If you specify a space key of −BADSPACE you will get only content which is not in the BADSPACE.
- To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE.

(Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

**Special values:**

- @self — The current space.
- @personal — All personal spaces.
- @global — All global spaces.
- @favorite — The spaces you have marked as favourite.
- @favourite — The same as @favorite above.
- @all — All spaces in your Confluence site.
- * — The same as @all above.

When specifying a personal space, remember to use the tilde (〜) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com. |
### Operator

**OR**

The operator to apply when matching content against the labels specified in the **Label(s)** parameter:

- **OR** – Display content with any of the non-prefixed labels.
- **AND** – Display content with all of the specified non-prefixed labels.

Note: This parameter only modifies the behaviour of the **Label(s)** parameter and only affects label values without a plus (+) or minus (-) sign prefix.

### Sort By

**modified**

Specify how the results should be sorted.

Values:

- **title** — Sort alphabetically by title.
- **creation** — Sort by the date on which the content was added.
- **modified** — Sort by the date on which the content was last updated.

Note: If this parameter is not specified, the sort order defaults to descending, based on the last modification date (latest first). To change the sort order from ascending to descending, use the **Reverse Sort** parameter.

### Reverse Sort

**false**

Select **Reverse Sort** to change the sort from descending to ascending. Use this parameter in conjunction with the **Sort By** parameter. **Reverse Sort** is ignored if **Sort By** is not specified.

---

### Content by User Macro

The Content by User macro generates a tabulated list of the content items, throughout the Confluence installation, that have been created by a specified Confluence user. The list includes all current pages, comments and spaces created by the user. Each item in the table is linked to its corresponding page, page comment or space dashboard.

Note that items for page comments contain a link to the page, followed by a second link to the comment itself, with these separated by a greater-than sign (>).

**Using the Content by User macro**

To add the Content by User macro to a page:
1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>none</td>
<td>The Confluence username for a person who has created content.</td>
</tr>
</tbody>
</table>

### Contributors Macro

The Contributors macro displays a list of Confluence users who have made a contribution of some type to a page. It can also be used to list watchers of the page.

The scope of this macro can be extended to include the immediate children or descendants of the specified page. The list of contributors can be based on people who have:

- authored or edited the page(s)
- contributed comments or added labels to the page(s), or
- are simply watching the page(s).

Screenshot: Example list of Contributors
In this example, the **Display Format** parameter has been set to **list**.

*Using the Contributors Macro*

**To add the Contributors macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Contribution Type** | authors | Filters by either the type of contribution made to a page (and optionally its descendant pages), or the watches on the page. Contribution types are:  
- **authors** - includes people who created or have edited the page(s)  
- **comments** - includes people who have added comments to the page(s)  
- **labels** - includes people who have added labels to the page(s)  
- **watches** - includes people who are watching the page(s).  
You can specify one or more contribution types, separated by commas. |
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort By</td>
<td>count</td>
<td>Specifies the criteria used to sort contributors. Sort criteria are:</td>
</tr>
</tbody>
</table>
|                                   |           | • **count** - sorts people based on the total number of contributions to the page(s)  
• **name** - sorts people into alphabetical order  
• **update** - sorts people based on the date of their last contribution to the page(s). |
| Reverse Sort                      | false     | Reverses the sort order of contributors in the list. Must be used in conjunction with the **Sort By** parameter.                                                                                              |
| Maximum Number of Contributors    | no limit  | Limits the number of contributors in the list. If a number is not specified, all contributors are included.                                                                                                |
| Display Format                    | inline    | Sets how the list of contributor’s names is formatted:                                                                                                                                                    |
|                                   |           | • **inline** — a comma-separated list  
• **list** — a bullet list.                                                                                                                          |
| Show Anonymous Contributions?     | false     | Sets whether to include those who contributed anonymously to a page.                                                                                                                                       |
| Show Count?                       | false     | Sets whether to show the number of times each person made a contribution of the specified **Contribution Type**.                                                                                           |
| Show Last Contribution Time?      | false     | Sets whether to show the last time each person made a contribution of the specified **Contribution Type**.                                                                                                 |
| Page Name                         | current   | Specifies the page to use when generating the list of contributors. If **Page Name** and **Space(s)** are left blank, the current page is assumed.                                                                |
| Label(s)                          | none      | Filters the list of contributors to those who created the specified labels from a page. You can specify one or more labels, separated by commas.                                                            |
### Space(s)

| current |

Specifies the space key of the Confluence space that contains the page set in **Page Name** or alternatively, specifies the spaces to search. Space keys are case-sensitive.

This parameter also takes special values, including:
- `@global` — All [global](#) spaces.
- `@personal` — All [personal](#) spaces.
- `@all` — All spaces in your Confluence site.

You can specify one or more space keys or special values, separated by commas.

If no **Page Name** and **Label(s)** are specified, all pages from the specified set of spaces are included.

### Content Type

| both pages and blog posts |

Restricts the content type to use when generating the list of contributors:
- **pages** — pages
- **blogposts** — blog posts.

### Blog Post Date

| none |

Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD.

### Include Page Hierarchy

| specified page only |

Specifies additional pages to include when generating the list of contributors:
- **children** — just the child pages of the specified page
- **descendants** — all descendants of the specified page.

### Show Selected Pages

| false |

Sets whether to show a list of the pages used to generate the list of contributors.

### Custom "None Found" Message

| default message |

Specifies the message to be used to override the default message that is displayed when no contributors are found.

---

**Contributors Summary Macro**
The Contributors Summary macro displays a table of contribution-based statistics for a set of pages. These statistics can be grouped according to individual pages or individual contributors.

The default scope for this macro is an individual page, but this can be extended to include the immediate children or descendants of a specified page. The statistics cover the following types of contributions:

- edits to the page(s)
- comments added to the page(s)
- labels added to the page(s)
- people watching the page(s)

**On this page:**

- Using the Contributors Summary Macro
- Parameters

**Related pages:**

- Contributors Macro
- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

A simple example of the Contributors Summary macro is shown in the screenshot below. It lists statistics for the number of times each contributor has edited, added comments and added labels to this page.

**Screenshot: Example Contributors Summary table of statistics**

<table>
<thead>
<tr>
<th>User</th>
<th>Edits</th>
<th>Comments</th>
<th>Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sarah Maddox</td>
<td>2</td>
<td>2</td>
<td>0</td>
</tr>
<tr>
<td>Edwin Dawson</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Giles Gaskell</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Rosie Jameson</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Andrew Lui</td>
<td>2</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>Charles Miller</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Andrew Prentice</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
</tbody>
</table>

In this example, all default parameter settings are used. For more information about this macro's parameters, refer to the Parameters section below.

**Using the Contributors Summary Macro**

**To add the Contributors Summary macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.
**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Group By</strong></td>
<td>contributors</td>
<td>Specifies the basis for grouping contribution-based statistics:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>contributors</strong> — group by the people who have contributed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>pages</strong> — group by the pages used to find contributors.</td>
</tr>
<tr>
<td><strong>Columns to Display</strong></td>
<td>edits,comments,labels</td>
<td>Sets the columns that should appear in the table. The statistics or type of information presented depends on the basis for grouping set with the <strong>Group By</strong> parameter. Statistics may be calculated for:</td>
</tr>
</tbody>
</table>
- **edits** — the number of times each contributor has edited the page(s) or the number of edits made to each page.
- **edited** — a list of the pages edited by each contributor or a list of contributors who have edited each page.
- **comments** — the number of times each contributor has added comments to the page(s) or the number of comments on each page.
- **commented** — a list of pages to which each contributor has added comments or a list of contributors who have commented on each page.
- **labels** — the number of times each contributor has added labels to the page(s) or the number of labels on each page.
- **labeled** — a list of pages to which each contributor has added labels or a list of contributors who have added a label to each page.
- **labellist** — a list of labels either added by each contributor or on each page.
- **watches** — the number of pages being watched by each contributor/person or the number of contributors/people watching each page.
- **watching** — a list of pages being watched by each contributor/person or a list of contributors/people watching each page.
- **lastupdate** — the last time each contributor made an update or when each page was last updated. Valid updates can include edit, comment or label modifications to a page.

One or more columns can be used.
| Sort By          | edits                                  | Sets the criterion used for sorting items in the table. The items sorted depend on the basis for grouping set with the Group By parameter. Sort criteria are:
|                 |                                       | • edits — sorts items in the table based on the total number of edits made, either by a contributor or to a page.
|                 |                                       | • name — sorts items in the table in alphabetical order, either by contributor or page name.
|                 |                                       | • editTime — sorts items in the table based on when the contributor last edited a page (or a specified set of pages) or when the page was last edited.
|                 |                                       | • update — sorts items in the table based on when the contributor last made any contribution to a page (or a specified set of pages) or when the page last had any contribution made to it.
| Reverse Sort    | false                                 | Reverses the sort order of items in the table, as specified using the Sort By parameter. (Used only in conjunction with the Sort By parameter.)
| Maximum Number of Items | no limit                              | Limits the number of contributors or pages in the table to the value specified. If no number is specified, all items are included.
| Show Anonymous Contributions? | false                               | Includes individuals who have made anonymous contributions to a page.
| Show Zero Counts? | false                               | Sets whether contributors or pages are included for which a calculated statistic is zero.
| Page Name       | current                               | Sets the page for which to calculate the contribution-based statistics. If no values for Page Name and Space(s) are specified, the current page is assumed.
<table>
<thead>
<tr>
<th>Label(s)</th>
<th>none</th>
<th>Restricts the contribution-based statistics to the specified labels only. You can specify one or more labels, separated by commas.</th>
</tr>
</thead>
</table>
| Space(s)      | current                   | Specifies the space key of the Confluence space which contains the specified page name or alternatively, specifies a scope of spaces to search. Space keys are case-sensitive. This parameter also takes special values, including:  
  - @global — All global spaces.  
  - @personal — All personal spaces.  
  - @all — All spaces in your Confluence site.  
You can specify one or more space keys or special values, separated by commas. If no Page Name and Label(s) are specified, all pages from the specified set of spaces are included. |
| Content Type  | both pages and blog posts | Restricts page types to either pages (pages) or blog posts (blog posts). If no value is specified in the Macro Browser, both pages and blog posts are included. |
| Blog Post Date| none                      | Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD. |
| Include Page Hierarchy | specified page only | Includes either the immediate children or all descendants of the specified page. If no value is indicated in the Macro Browser, only the specified page is included. |

**Create Space Button Macro**

The Create Space Button macro renders a create space icon that links to the 'Create Space' page. The icon appears as rendered below.

*Screenshot: The Create Space Button in Confluence*
To display this icon, you require ‘Create Space’ permission which is assigned by a site administrator from the Administration Console. See Security or contact your site administrator for more information.

### On this page:
- Using the Create Space Button Macro
- Parameters
- Related Topics

#### Using the Create Space Button Macro

To add the Create Space Button macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

#### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Icon Size</td>
<td>large</td>
<td>Specify whether to use large or small icon:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• large</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• small</td>
</tr>
</tbody>
</table>

#### Related Topics

Setting up a New Global Space
Working with Macros

Take me back to the Confluence User's Guide.

#### Detailssummary Macro

The Detailssummary macro presents a tabulated summary of metadata that has been embedded on any page or blog post in the current Confluence space using the Metadata Macro. The Detailssummary macro collects metadata from only those pages or blog posts that have had a particular page label added to them.

The left-most column of the summary shows the name of each page or blog post with the specified label that contains metadata. Each page or blog post is presented on a single row and is hyperlinked to its appropriate destination page.

Each subsequent column represents a unique field within the selected metadata. The value associated with each metadata field on a page or blog post is presented in the appropriate cell of the summary table. For example, the following Detailssummary macro shows the pages in the current space that have metadata embedded using the Metadata macro, and also the ‘test’ label.

<table>
<thead>
<tr>
<th>Author-Firstname</th>
<th>Author-Nickname</th>
<th>Is-Secret</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Using the Detailssummary Macro

To add the Detailssummary macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Metadata Label</td>
<td>none</td>
<td>Restricts the summary to the contents of Metadata macros on the pages in the current space that have this page label.</td>
</tr>
</tbody>
</table>

**Another Metadata Macro Example**

The following Metadata macro example generates the second line in the Detailssummary macro (above). Note that this current page requires the 'test' label for this to work.

<table>
<thead>
<tr>
<th>Author-Nickname</th>
<th>Strawberry Sundae</th>
</tr>
</thead>
<tbody>
<tr>
<td>Author-Firstname</td>
<td>Fred</td>
</tr>
</tbody>
</table>

**Related Topics**

- Working with Macros
- Working with Confluence Labels

Take me back to the [Confluence User's Guide](#).

**Excerpt Include Macro**

The Excerpt Include macro is used to display 'excerpted' (that is, a segment of) content from one page in another.

To use this macro, the excerpt must have been defined using the **Excerpt macro** and both pages must exist in the same space. Note that you can have more than one Excerpt Include macro on a page (although you can have only one Excerpt macro on a page).

The excerpt appears as shown below:
On this page:

- Using the Excerpt Include Macro
- Parameters
- Related Topics

Excerpt Macro

Define a part of a page as the page's 'excerpt' which can then be displayed in another page.

For this example, we are taking content from a page called 'Excerpt Macro', where the Excerpt macro has already been placed. The title of the page is shown at the top of the panel and the content within the body of the macro placeholder is rendered in the panel.

Using the Excerpt Include Macro

To add the Excerpt Include macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Containing the Excerpt</td>
<td>none</td>
<td>Specifies the page that contains the excerpt to be displayed.</td>
</tr>
<tr>
<td>Remove Surrounding Panel</td>
<td>false</td>
<td>Controls whether the panel border around the excerpt and the page title should be hidden. By default, the panel is always shown.</td>
</tr>
</tbody>
</table>

**Related Topics**

- Excerpt Macro
- Working with Macros

Take me back to the Confluence User's Guide.

**Excerpt Macro**

The Excerpt macro is used to mark a part of a page's content for re-use. By itself, the Excerpt macro does not change the display of a page. However, defining an excerpt enables other macros, such as the **Excerpt Include** and **Blog Posts** macros, to display the marked content elsewhere.

You can only define one excerpt per page. In other words, you can only add the Excerpt macro once to a page.
Using the Excerpt Macro

To add the Excerpt macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type \ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

To add reusable content to the macro:

1. Add your content inside the Excerpt macro placeholder.
2. Click the macro placeholder to see the options panel, and select the option to Display on new line or to Display inline. The default is to display the content of the macro on a new line. If you choose the inline option, the content of the macro will form part of the same paragraph as the text preceding and following it. Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Excerpted Content</td>
<td>false</td>
<td>Controls whether the page content contained in the Excerpt macro placeholder is displayed on the page.</td>
</tr>
</tbody>
</table>

Related Topics

Excerpt Include Macro
Working with Macros

Take me back to the Confluence User's Guide.

Expand Macro

The Expand macro displays an expandable/collapsible section of text on your page. Here is an example:

كرة Click here to expand...
This text is hidden until you expand the section.

Using the Expand Macro

To insert the Expand macro into a page using the macro browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

On this page:

- Using the Expand Macro
- Parameters
- Notes

Related pages:

- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Click here to expand...</td>
<td>Defines the text that appears next to the expand/collapse icon.</td>
</tr>
</tbody>
</table>

Notes

Text is expanded in PDF and HTML exports. When you export the page to PDF or HTML, the text between the macro tags is expanded so that readers can see it in the PDF and HTML versions of the page.

Favourite Pages Macro

Use the Favourite Pages macro to display a list of your favourite pages.

The output of the Favourite Pages macro appears as in the following screenshot.

Screenshot: The Favourite Pages Macro in Confluence
Using the Favourite Pages Macro

To insert the favourite pages macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in [Using Autocomplete](#).

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

There are no parameters for this macro.

**Related Topics**

- Working with Favourites
- Working with Macros

Take me back to the [Confluence User's Guide](#).

**Gadget Macro**

Gadgets are small applications that can offer dynamic content. They are typically served from a web application server and can be re-used in many other web applications. In Confluence, use the Gadget macro to add gadgets to pages or blog posts.

Confluence comes bundled with a few of its own gadgets that you can add to your pages or blog posts. The Confluence gadgets are listed in [Confluence Gadgets](#). However, you can access additional gadgets in this list if your Confluence Administrator has:

- Installed additional gadgets in Confluence (typically as a Confluence plugin) or
- Registered gadgets served from an external web application or website (such as those from a JIRA installation or iGoogle) via the [Registering External Gadgets](#) page.

Unlike other macros, the name of each gadget macro is unique and follows the convention "<gadget-name>-macro", where <gadget-name> is the name supplied by the gadget itself.

---

**Favourite Pages**

Displaying pages recently added to your favourites list.

- Home
- Macro Testing Page

On this page:

- Using the Favourite Pages Macro
- Related Topics
Inserting Gadgets into a Confluence Page or Blog Post

To add a gadget to a page:

1. Edit your page or blog post.
2. Choose Insert > Other Macros.
3. Click External Content to see a list of gadgets configured for use in your Confluence installation. (Some Confluence macros like the JIRA Issues, RSS Feed, Tasklist and Widget Connector macros also appear in this category because they can also access external content.)
4. Click the desired gadget to access its parameters and properties.
5. Set the parameters to your requirements.
6. Click Refresh to preview your changes.
7. Click Insert to add the gadget to the page.

Editing Gadgets on a Confluence Page or Blog Post

To edit an existing gadget on a page or blog post:

1. Edit your page or blog post.
2. Click the Gadget macro placeholder and choose Edit (or double-click the placeholder).
3. Set the gadget's parameters to your requirements.
4. Click Refresh to preview your changes.
5. Save the gadget.

Standard gadget parameters

Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the macro dialog. Each gadget may also have its own set of parameters, which appear on the left of the macro dialog.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Related pages:

- The big list of Atlassian gadgets
- Confluence User's Guide

On this page:
- Inserting Gadgets into a Confluence Page or Blog Post
- Editing Gadgets on a Confluence Page or Blog Post
- Standard gadget parameters
- Contents of a Gadget Macro
### Gallery Macro

The Gallery macro displays a collection of thumbnail images in a table, based on the images attached to a Confluence page. When viewing the page, a user can click a thumbnail image to zoom into a screen-sized image and then view the images as a slide show.

#### Overview:

- The images shown in the gallery are taken from the files attached to the Confluence page. You can also specify a different page where the attachments are located. For information about attaching images to a page, see [Attaching Files to a Page](#).
- The captions below the images are drawn from the comments on the attachments. For information about adding comments to attachments, see [Attaching Files to a Page](#).
- By default, the gallery will include all the images attached to the page. You can also exclude or include images using parameters.
- You can sort your images into a particular order.
- You can specify a title for the gallery and also configure how many columns you want for the table in which your images are displayed.

### On this page:

- Using the Gallery macro
- Parameters
- Image file formats

### Related pages:

- Displaying Images
- Attaching Files to a Page
- Editing Attachment Properties
- Working with Macros
- Confluence User's Guide

*Screenshot: The Gallery macro as it appears on a page*
Using the Gallery macro

To insert the Gallery macro onto a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

The full list of parameters is shown in the following table. If the name of an attached file or page contains a comma, you can refer to it in the relevant parameters below by enclosing it in single or double quotes, for example "this,that.jpg", theother.png

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gallery Title</td>
<td>Nothing</td>
<td>Specify a title for your gallery.</td>
</tr>
<tr>
<td>Number of Columns</td>
<td>4</td>
<td>Specify the number of columns for your table.</td>
</tr>
<tr>
<td><strong>Images to Exclude</strong></td>
<td>No exclusions. Include all the pictures on the page.</td>
<td>The gallery will ignore any pictures specified. You can specify more than one picture, separated by commas. Note: The filename and filetype for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td><strong>Include these Images Only</strong></td>
<td>Include all the pictures on the page.</td>
<td>If you specifically include one or more pictures, the gallery will show only those pictures. You can specify more than one picture, separated by commas. Note: The filename and filetype for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
<tr>
<td><strong>Exclude Images with these Labels</strong></td>
<td>No exclusions. Include all the pictures on the page.</td>
<td>The gallery will ignore any pictures that have the specified label. You can specify more than one label, separated by commas. For information on labelling the attachments, see Adding Labels.</td>
</tr>
<tr>
<td><strong>Include Images with these Labels Only</strong></td>
<td>None. The images are not filtered by label.</td>
<td>Filters the images to display, based on a list of labels. If you wish to enter more than one label, separate the labels with commas. Confluence will show only images that have all the labels specified. (The match is an AND, not an OR.) For information on labelling the attachments, see Adding Labels.</td>
</tr>
<tr>
<td><strong>Use Images in these Pages</strong></td>
<td>If no page is specified, the gallery macro displays the images attached to the page on which the macro is used.</td>
<td>Specify the title of the page which contains the images you want displayed. To specify a page in a different space, use the following syntax: SPACEKEY:Page Title</td>
</tr>
</tbody>
</table>
| **Sort Images By** | None. The sort order is unspecified and therefore unpredictable. | Specify an attribute to sort the images by. Sort order is ascending, unless you select the **Reverse Sort** parameter (see below). Options are:  
- **name** – file name.  
- **comment** – comment linked to the attached file.  
- **date** – date/time last modified.  
- **size** – size of the attached file. |
Reverse Sort | Off. Sort order is ascending | Used in combination with the Sort Images By parameter above. Use Reverse Sort to reverse the sort order, from ascending to descending.

**Image file formats**

You can attach image files of any format to a page. Confluence supports the following image formats in the Gallery macro and when displaying an image on a page:

- gif
- jpeg
- png
- bmp (depending on browser support)

**Global Reports Macro**

The Global Reports macro renders a list of links to global reports.

This includes a list of new or updated pages Managing Undefined Pages on the site and RSS feeds for new pages and blog posts.

The Global Reports macro appears as shown in the screenshot below.

**Screenshot: The Global Reports macro in Confluence**

**Using the Global Reports Macro**

To add the Global Reports macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Width of Table | 99% | Specifies the width of the table in which the links are displayed, as a percentage of the window width.

**Related Topics**

- **Subscribing to RSS Feeds within Confluence**
- **Working with Macros**

Take me back to the Confluence User's Guide.

### HTML Include Macro

The HTML Include macro allows you to include the contents of an external HTML file in a Confluence page.

⚠️ **CAUTION:** Including unknown HTML inside a webpage is dangerous.

HTML can contain active scripting components. This means that it would be possible for a malicious attacker to present a user of your site with script that their web browser would believe came from you. Such code could be used, for example, to steal a user’s authentication cookie and give the attacker their Confluence login password.

### Using the HTML Include Macro

To insert the HTML Include macro into a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML Page’s URL</td>
<td>None</td>
<td>The URL of the page to include.</td>
</tr>
</tbody>
</table>

### Troubleshooting

- The HTML Include macro will only be available if it has been enabled by your Confluence administrator. Also, your Confluence Administrator can define a whitelist of trusted URLs. You will see an error message on the Confluence page if the included URL is not in the whitelist.
- You can only use the HTML Include macro for pages with absolute links. If you use the macro to include an HTML page that has relative links, navigating those links in the wiki results in a ‘Page Not Found’ error. See CONF-6567.

**Related Topics**

- **HTML Macro**
- **Working with Macros**
Configuring a URL Whitelist for Macros

Take me back to Confluence User's Guide

HTML Macro

The HTML macro allows you to add HTML code to a Confluence page.

Note that the HTML macro will only be available if it has been enabled by your System Administrator.

Using the HTML Macro

To add the HTML macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

There are no parameters for this macro.

Enter the HTML code into the body of the macro placeholder.

Related Topics

- HTML Plugin (has better security than the HTML macro)
- HTML Include Macro (embeds remote HTML or pages)
- Working with Macros
- Enabling HTML macros

Take me back to Confluence User's Guide

IM Presence Macro

The IM Presence macro indicates graphically when a contact is signed into an Instant Messaging (IM) service. The IM Presence macro appears as a small icon on the page, like this image: Online Now.

Using the IM Presence Macro

To add the IM Presence macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters
Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User ID/Screen Name</td>
<td>Identify the user by their ID, account name or screen name.</td>
</tr>
<tr>
<td>Service</td>
<td>aim – <a href="#">AOL Instant Messenger</a></td>
</tr>
<tr>
<td></td>
<td>gtalk – <a href="#">Google Talk</a></td>
</tr>
<tr>
<td></td>
<td>icq – <a href="#">ICQ</a></td>
</tr>
<tr>
<td></td>
<td>jabber – <a href="#">Jabber</a></td>
</tr>
<tr>
<td></td>
<td>msn – <a href="#">MSN Instant Messenger</a></td>
</tr>
<tr>
<td></td>
<td>sametime – <a href="#">IBM Lotus Sametime</a></td>
</tr>
<tr>
<td></td>
<td>skype – <a href="#">Skype</a></td>
</tr>
<tr>
<td></td>
<td>skypeme – <a href="#">Skype</a></td>
</tr>
<tr>
<td></td>
<td>wildfire – <a href="#">Openfire Server</a></td>
</tr>
<tr>
<td></td>
<td>yahoo – <a href="#">Yahoo! Messenger</a></td>
</tr>
<tr>
<td>Show User ID</td>
<td>Shows or hides the User ID of the contact.</td>
</tr>
</tbody>
</table>

Related Topics

[Working with Macros](#)

Take me back to the [Confluence User's Guide](#).

Include Page Macro

You can use the Include Page macro to display the contents of one Confluence page or blog post in another page or blog post.

**Using the Include Page Macro**

**To add the Include Page macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `#{` and the beginning of the macro name, to see a list of suggested macros. Details are in [Using Autocomplete](#).

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Page to Include   | None    | This is the name of the Confluence page or blog post that you want to include in the current page.  
|                   |         | • If the page or blog post is located in another space, add the space key and a colon in front of the page name. For example, DOC:My page name.  
|                   |         | • To include a blog post, specify the date as well as the title of the blog post. For example: /2010/12/01/My blog post.  
|                   |         | • The space key is case sensitive.  
|                   |         | • You can include pages from personal spaces using ~username as the space key, where 'username' is the person's username. For example, ~jsmith:My page name. |

**Notes**

- If you want to include part of a page rather than the whole page, use the Excerpt and Excerpt Include macros.
- To display a page's contents, you need 'View' permission for that page. Similarly, people who view the page will need 'View' permissions for the embedded page as well as the page into which it is embedded. See space permissions or contact your Confluence space administrator for more information.
- If someone changes the name of the included page after you have added the macro to your page, the page name does not change automatically in the macro. You will need to change the page name manually in the macro parameters.
- If you want to embed an external page into a Confluence page, you need the HTML Include Macro.

**Related Topics**

[Working with Macros](#)

Take me back to the Confluence User's Guide.

**Sample Include Page**

Start of sample page content


End of sample page content

**Info Macro**

The Info macro allows you to highlight helpful information on a Confluence page. It creates a blue-coloured box
surrounding your text, as shown below.

### Info Macro Example

This text is rendered inside the info macro.

---

**Using the Info Macro**

**To add the Info macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in *Using Autocomplete*.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

---

**On this page:**

- Using the Info Macro
- Parameters

**Related pages:**

- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

---

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>The title of the information box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>Show Information Icon</td>
<td>true</td>
<td>If &quot;false&quot;, the icon will not be displayed.</td>
</tr>
</tbody>
</table>

**JIRA Issues Macro**

**JIRA** is the issue tracking and project management system supplied by Atlassian. The JIRA Issues macro allows you to display a list of issues from a JIRA site on a Confluence page.

You can list publicly accessible issues from any JIRA site, as well as issues restricted to your user account on a JIRA site, assuming:

- You are logged in to both the JIRA and Confluence sites, and
- Your usernames on both of these sites match.

You can also create, find and insert JIRA issues directly within text on a Confluence page or blog post. For more information, refer to [Inserting JIRA Issues](#).
Using the JIRA Issues Macro

To add the JIRA Issues macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Refer to the instructions below for details on obtaining the URL of the XML view of a search. An example URL is:

http://jira.atlassian.com/sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml?jqlQuery=project+%3D+CONF+AND+%28summary+%7E+jiraissues+OR+description+%7E+jiraissues+OR+comment+%7E+jiraissues%29&tempMax=10

On this page:
- Using the JIRA Issues Macro
- Displaying a List of JIRA Issues from any Accessible JIRA Site
- Parameters
- Displaying Issues which have Restricted Viewing
- Rendering HTML from JIRA
- Troubleshooting

Related pages:
- Inserting JIRA Issues
- Working with Macros
- Configuring JIRA with Confluence
- Setting Up Trusted Communication between JIRA and Confluence
- Confluence User's Guide

Using Autocomplete
Displaying a List of JIRA Issues from any Accessible JIRA Site

Step 1 — Obtain the URL of the Issue Filter

1. Log in to your JIRA system.
2. Go to the 'Issues' screen and create a new filter. Do not modify an existing filter.
3. Set up your search parameters and use 'View' to check the issues returned.
4. Once the filter is finished, go to the Filter's 'View' tab/section in the top-left area of the JIRA interface.
5. Copy the XML link. To do this, follow the appropriate step below:
   - If you are using JIRA 4.0.x or later, choose Views, right-click on XML, and choose Copy Link Location.
   - If you are using JIRA 3.13.x or earlier, locate the 'Current View' links section, right-click on XML, and choose Copy Link Location.

Step 2 — Embed the Issue Filter URL onto your Confluence Page

1. Log in to your Confluence system.
2. Edit the page where you wish to display the list of JIRA issues.
3. Add the JIRA Issues macro to the page, as described above.
4. Edit the macro, and paste the JIRA filter URL from your clipboard into the URL box.
5. Customise the macro output using the optional parameters. See below.
6. Save the Confluence page.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

The JIRA Issues macro allows the following parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
### URL

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>URL</td>
<td>none</td>
<td>The URL of the XML view of your selected issues in the JIRA Issue Navigator. Note: If the URL in the URL parameter does not contain a <code>tempMax</code> argument, then the value of <code>tempMax</code> will default to 500. For JIRA 3.12 or earlier, the JIRA Issues macro will return a maximum of 500 issues. For JIRA 3.13 or later, the JIRA Issues macro will return a maximum of 500 issues per page.</td>
</tr>
</tbody>
</table>

### JIRA Field Columns to Display

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| JIRA Field Columns to Display | By default, the following columns are shown:  
  - type  
  - key  
  - summary  
  - assignee  
  - reporter  
  - priority  
  - status  
  - resolution  
  - created  
  - updated  
  - due | A list of JIRA column names, separated by semi-colons (;). Example columns are: key, summary, type, created, fixversion, updated, due, assignee, reporter, priority, status and resolution. You can include any columns recognised by your JIRA site, including custom columns. See the JIRA documentation for a list of names. |

### Display Total Numbers Only

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Total Numbers Only</td>
<td>false</td>
<td>When selected, the issue list will only show the number of issues in JIRA. The count will be linked to your JIRA site.</td>
</tr>
</tbody>
</table>

### Cache

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| Cache | on    | - on – the macro maintains a cache of the issues which result from the JIRA query.  
- off – the relevant part of the cache is cleared each time the macro is reloaded. |

### Anonymous Retrieval

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anonymous Retrieval</td>
<td>false</td>
<td>When selected, JIRA will return only the issues which allow unrestricted viewing i.e. the issues which are visible to anonymous viewers, as determined by JIRA's viewing restrictions. Otherwise, the results depend on how your administrator has configured the communication between JIRA and Confluence. By default, Confluence will show only the JIRA issues which the user is authorised to view. See more details below.</td>
</tr>
<tr>
<td>Width</td>
<td>100%</td>
<td>The width of the table displaying the JIRA issues. Can be indicated either as a percentage (%) or in pixels (px).</td>
</tr>
<tr>
<td>------------------------</td>
<td>------</td>
<td>---------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Height (pixel value only)</td>
<td>480</td>
<td>The height in pixels of the table displaying the JIRA issues. Note that this height specification is ignored in the following situations:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• If you set the Render Mode parameter (see below) to static.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• When the JIRA issues are displayed in a PDF or Word document, in an email message or in an RSS feed.</td>
</tr>
<tr>
<td>Title</td>
<td>JIRA Issues</td>
<td>You can customise the title text at the top of the JIRA issues table with this parameter. For instance, setting the title to 'Bugs-to-fix' will replace the default 'JIRA Issues' text. This can help provide more context to the list of issues displayed.</td>
</tr>
<tr>
<td>Render Mode</td>
<td>static</td>
<td>dynamic – dynamic issue display with the following features:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Click the column headers to sort the output.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Drag and drop the columns into a different order.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Temporarily remove a column from the display.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• View a page of issues at a time, for faster response times.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>static – disables the dynamic display features.</td>
</tr>
</tbody>
</table>

**Displaying Issues which have Restricted Viewing**

Maybe your JIRA instance is not visible to anonymous visitors — everyone has to log in before they can see JIRA issues. Or maybe some of the JIRA issues are restricted to viewing by certain users only. This section explains how to handle JIRA issues that have restricted viewing.

**Using Confluence-to-JIRA Trusted Communication (Recommended)**
For Confluence 2.7.0 and later and JIRA 3.12 and later, your administrator can set up trusted communication between Confluence and JIRA. The entire process is described in the Confluence Administrator’s Guide. Provided that your administrator has set up trusted communication, you don’t need to add any extra parameters. Confluence and JIRA will work out the security between them, ensuring that the user will see only the issues they are authorised to see. Read the section below if you want more detail.

**Remove the username and password from your macro markup code**

Prior to Confluence 2.7, you needed to include a username and password in the macro markup code if you wanted to display JIRA issues which had restricted viewing. Once your administrator has set up trusted communication between Confluence and JIRA, you no longer need to include a username and password in the markup code for your JIRA macros.

The following options are available for determining the issues which will be retrieved from JIRA and displayed on the Confluence page:

<table>
<thead>
<tr>
<th>What you want to do</th>
<th>Macro parameter</th>
<th>URL parameter</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the JIRA issues which the logged-in user is authorised to see. And if the user is not logged in, display only issues which allow unrestricted viewing.</td>
<td>Do not specify any authentication parameters. In this case, the behaviour depends on the way your administrator has set up trusted communication between JIRA and Confluence. Here is a summary of the behaviour. If trusted communication is enabled, the authorisation will work seamlessly. When a logged-in user views your page, they will see only the JIRA issues they are allowed to see. And if they are not logged in, they will see only the issues which allow unrestricted viewing. If trusted communication is disabled, the Confluence page will show only the JIRA issues which allow unrestricted viewing.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
| Ensure that Confluence will display only the JIRA issues which allow unrestricted viewing. | anonymous | Regardless of who the user is (logged in or not), the Confluence page will show only anonymously-visible issues. Confluence will not attempt to set up a trusted communication link with JIRA in this case.

Use a pre-determined username and password to access the JIRA issues. | \&os_username=MYNAME&os_password=MYPASSWORD | Not recommended. Prior to Confluence 2.7, this was the only way of displaying issues with restricted viewing. For Confluence 2.7 and later, this method will still work. Confluence will not attempt to set up a trusted communication link with JIRA in this case.

**Rendering HTML from JIRA**

Formatted fields from JIRA can be displayed in Confluence if you set up a Confluence-to-JIRA Trust as described above. Otherwise, such formatted fields will be escaped within the JIRA issues macro output. This is to prevent the possibility of malicious HTML being served by an untrusted JIRA server. The most likely field where you will notice this is in the description field.

So, for example, without the trust relationship, a description column that rendered in JIRA like this -

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
</table>
| This is
| • the description
| • of my issue

- would actually appear in the JIRA issues macro like this -

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;p&gt;This is&lt;ul&gt;&lt;li&gt;the description&lt;/li&gt;&lt;li&gt;of my issue&lt;/li&gt;&lt;/ul&gt;&lt;/p&gt;</td>
</tr>
</tbody>
</table>

Configuring Confluence-to-JIRA Trust as described above will enable the field to be rendered as expected.

**Troubleshooting**

**HTTPS**

The JIRA Issues macro can access a JIRA instance running under SSL as long as the Confluence server is set to accept the JIRA SSL certificate. Refer to the Confluence Knowledge Base article for more information about [p](#)
Problems connecting to SSL services.

And see also Troubleshooting Trusted Communication between JIRA and Confluence

JIRA Macro

See Inserting JIRA Issues.

JUnit Report Macro

The JUnit Report macro displays a summary of JUnit test results from a directory accessible by the Confluence server. JUnit is a unit testing framework which allows programmers to ensure that individual units of Java source code are functioning correctly.

The JUnit Report macro appears as shown in the screenshot below.

Screenshot: The JUnit Report macro in Confluence

When generating reports from the JUnit Report macro, set the Apache Ant formatter to 'XML'.

Using the JUnit Report Macro

To add the JUnit Report macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### URL of the test result XML file

None

URL of a particular test result XML file. Is overridden by the **Directory (URL) of your test result files** parameter if you use both.

Example, from a Confluence instance: `http://yourConfluenceInstance.com/download/attachments/<page id>/file.xml`

For Confluence installations without anonymous user access, you can specify logon credentials as part of this parameter in the form of URL parameters:

- **os_username** — The username of a Confluence user with permission to access to the JUnit test results.
- **os_password** — The password of the Confluence user specified in the **os_username** parameter.

### Directory (URL) of your test result files

None

URL of a directory containing your test result files. This must be a directory name and **not** the XML file itself. Overrides the **URL of the test result XML file** parameter if you use both.

Example, for a local drive: `file://C:/TEMP/

Example, for a network drive: `http://*host*/*path*

### Report Detail

**all**

Detail for the report. Can be **all**, **fixure**, **summary** or **failuresonly**.

### Debug

None

Shows the content of failures, as well as the error messages.

---

**Related Topics**

- [Working with Macros](#)

Take me back to the [Confluence User's Guide](#).

**Labels List Macro**

The Labels List macro displays a hyperlinked alphabetical index of all labels within the current space.

The label index generated consists of numerous cells, each beginning with one or more letters of the alphabet or
a number. Each label within the space is grouped alphanumerically into its appropriately headed cell.

Each label in the list links to a page that displays all the pages on which the label occurs within the current space.

Screenshot: Labels List Macro segment

Using the Labels List Macro

To add the Labels List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

This macro has no parameters.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Livesearch Macro
The Livesearch macro allows you to add a search box to a Confluence page. When users enter a search term into the search box, Confluence will dynamically display matching results as they type.

**Using the Livesearch Macro**

To add the Livesearch macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>none</td>
<td>Uniquely identifies the Livesearch when there are multiple Livesearch macros in one page.</td>
</tr>
<tr>
<td>Restrict to this Space Key</td>
<td>all spaces</td>
<td>Specify a space key to limit the search to the given space. Case-sensitive.</td>
</tr>
</tbody>
</table>

**Related Topics**

- Searching Confluence
- Search Results Macro
- Working with Macros

Take me back to the Confluence User's Guide.

**Loremipsum Macro**

The Loremipsum macro displays paragraphs of pseudo-Latin text (more information). You can use this macro to generate more-or-less meaningless text for demonstration purposes in pages showing a draft layout or arrangement of page elements. The text is deliberately non-meaningful so that it does not influence the viewer's perception of the page arrangement or design.

A basic example of the Loremipsum text:

**Using the Loremipsum Macro**

To add the Loremipsum macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Paragraphs</td>
<td>3</td>
<td>The amount of pseudo-Latin (space-filler) text to display.</td>
</tr>
</tbody>
</table>

**Related Topics**

[Working with Macros](#)

Take me back to the Confluence User's Guide.

**Metadata Macro**

The Metadata macro allows you to embed metadata into pages and blog posts for presentation with the Details summary Macro. Each metadata item consists of a field name and an associated value. When a Metadata macro is rendered on a page, each metadata item is presented as a table row, with the field name followed by its value, for example:

<table>
<thead>
<tr>
<th>Is-Secret</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Author-Nickname</td>
<td>Banana Split</td>
</tr>
</tbody>
</table>

The metadata added to a page using the Metadata macro is 'tagged', or identified, by adding a label to the page. This allows the Details summary macro to generate a summary based on Metadata macros from all pages that have each had the same page label added to them.

**Using the Metadata Macro**

1. **Add the Metadata macro to a page:**
   a. In the Confluence editor, choose Insert > Other Macros.
b. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

2. **Add metadata items as rows in a table inserted into the macro placeholder.**

   For example, the screenshot below shows a table, with rows containing metadata items, in the macro’s placeholder.

   ![Metadata](image)

3. **Add a label to the page to 'tag' the page.**

   For example, the current page has a 'test' label. This label is used by the example Detailssummary macro on the Detailssummary Macro page.

   **Parameters**

   This macro has no parameters.

   **Related Topics**

   Working with Macros

   Working with Confluence Labels

   Take me back to the Confluence User’s Guide.

**Multimedia Macro**

See Embedding Multimedia Content.

**Navigation Map Macro**

The Navigation Map macro displays the list of pages associated with a specified label as a navigation map.

A label must be specified for this macro.

**Using the Navigation Map Macro**

To add the Navigation Map macro to a page:
1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>none</td>
<td>Specify the label associated with the pages you want to show in the navigation map.</td>
</tr>
<tr>
<td>Map Title</td>
<td>none</td>
<td>Specify a title for the navigation map.</td>
</tr>
<tr>
<td>Number of Cells Per Row</td>
<td>5</td>
<td>Specify the number of cells in a row</td>
</tr>
<tr>
<td>Cell Width (Pixels)</td>
<td>90 px</td>
<td>Specify the cell width</td>
</tr>
<tr>
<td>Cell Height (Pixels)</td>
<td>60 px</td>
<td>Specify the cell height</td>
</tr>
<tr>
<td>Navigation Map Theme</td>
<td>Confluence</td>
<td>Define a theme for the navmap.</td>
</tr>
</tbody>
</table>

If you want to create your own navmap 'look and feel' (for example, one with rounded corners), you need to add a customised navmap macro theme file to the WEB-INF/classes/templates/macros directory. The file name convention to use is navmap-mytheme.vm. Use the name of your choice for the mytheme part of the file name, which is also the value you use for this parameter. Hence, if your theme was called navmap-roundededges.vm, use the value of rounded edges for this parameter.

**Related Topics**

- Related Labels Macro
- Content by Label Macro
Network Macro

The Network macro displays a list of Network activity on a Confluence page or blog post. You can specify the user whose network activity you wish to show. These interactions include the users that the specified user is following or users who are following the specified user. The Network macro shows each listed user by their profile picture. It also provides a choice of two themes and the ability to limit the number of users in the list.

Screenshot: Network macro

Using the Network macro

To add the Network macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Username</th>
<th>Current user's username</th>
<th>The username of the Confluence user whose network interactions you wish to show. If no username is specified, then current user's (that is, your) network interactions are shown.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mode</td>
<td>following</td>
<td>Determines which users are listed, with respect to the specified user:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- following – those who the user is following.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- followers – those who are following the user.</td>
</tr>
<tr>
<td>Theme</td>
<td>full</td>
<td>Determines how the user's network is displayed:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- full – shows a large version of user's profile pictures and, if the following mode is set, provides an entry field function to follow more users.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- tiny – shows only the small version of user's profile pictures.</td>
</tr>
<tr>
<td>Maximum Results</td>
<td>No limit imposed up to a maximum of 30</td>
<td>Restricts the number of users displayed. If the number of users exceeds the specified maximum, then a Show All link is provided. This link leads to the specified user's Network view, showing the complete list of network interactions.</td>
</tr>
</tbody>
</table>

**Disabling the Network macro**

The Network macro is provided by the 'network' module in the 'Profile Macros' plugin. To remove the macro from your site, you can disable the module in the plugin. See [Disabling or Enabling a Plugin](#).

**Noformat Macro**

The Noformat macro displays a block of text in monospace font with no other formatting.

**Using the Noformat Macro**

**To add the Noformat macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in [Using Autocomplete](#).

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Enter the content that is to be unformatted into the body of the macro placeholder.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Panel</td>
<td>False</td>
<td>Removes the panel around the content.</td>
</tr>
</tbody>
</table>

**Related Topics**

**Working with Macros**

[Take me back to the Confluence User's Guide](#).

**Note Macro**

The Note macro allows you to highlight a note on a Confluence page.

It creates a yellow-coloured box surrounding your text:

**Note Macro Example**

This text is rendered inside the Note macro.

**Using the Note Macro**

**To add the Note macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in [Using Autocomplete](#).

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Add the text of the note to the body of the macro placeholder.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>If specified, the title is displayed in bold next to the icon.</td>
</tr>
</tbody>
</table>
**Show Exclamation Mark Icon**  |  true  |  
|--------------------------------|-------|---|
| **true** – displays the warning icon  
| **false** – the icon is not displayed  

**Related Topics**

- **Working with Macros**

Take me back to the [Confluence User's Guide](#).

**Page Index Macro**

The Page Index macro creates a hyperlinked alphabetical index of all page titles within the current space.

The top section of the index contains a cell for each letter of the alphabet, with cells for numbers and symbols. Each cell indicates how many pages are in the corresponding list.

The lower section contains lists of page titles followed by the first few sentences of content on that page.

Each letter, number or symbol in the top section is hyperlinked to the corresponding cell in the lower section. Each page title in the lower section is hyperlinked to the page in the space.

*Screenshot: Page Index macro segment*
Using the Page Index Macro

To add the Page Index macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

This macro accepts no parameters.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Page Tree Macro
The Page Tree macro displays a dynamic, hierarchical list of pages starting from a specified parent (root) page. It can act as a table of contents or a list of related topics.

When viewing the page tree, your reader can click a link to view the relevant page. The page's current position is highlighted in the page tree.

Creating a navigation panel for your space

The Page Tree macro is used in the Confluence Documentation theme, to create a navigation panel showing a table of contents for your space. Read the instructions on Configuring the Documentation Theme.

Using the Page Tree Macro

To add the Page Tree macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Click Refresh in the Macro Browser to see the effect of changes to the macro parameters.

Macro Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Root Page** | The home page of the space | Specify the parent page for the page tree. The tree will include all children of the given page, plus their children and grand-children etc. The tree will *not* include the root page itself.

Specify the page title or a special value as follows:

- Your page title — to specify a page name for the parent or root of the tree. The tree will include all children and grand-children of the specified root. The tree will *not* include the specified root page itself.
- '@home' — will include all pages under the home page of the space (default).
- '@self' — will include all pages under the current page.
- '@parent' — will include all pages under the parent of the current page, including the current page.
- '@none' — will include all pages in the space, including orphaned pages and the home page. |
| **Sort Pages By** | **position** | Specify the order to display the pages in the tree. This sort order is for display purposes only. It does not permanently re-arrange the page order. The value may be one of the following:

- **bitwise** — sort alphabetically, for example: title1, title10, title2.
- **creation** — sort by date of creation.
- **modified** — sort by order of date last modified.
- **natural** — sort in 'natural' alphabetical order, for example: title1, title2, title10.
- **position** — sort by the default Confluence sorting rules. If your pages have been ordered manually, this sort will respect the defined order. Otherwise the pages will be displayed in the 'natural' alphabetical order, such as: title1, title2, title10. |
<table>
<thead>
<tr>
<th>Feature</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include Excerpts in Page Tree</td>
<td>false</td>
<td>Select if you want the page tree to show excerpts from each page. The excerpts must be defined on each page by the Excerpt macro.</td>
</tr>
<tr>
<td>Reverse Order</td>
<td>false</td>
<td>Select to show the pages in reverse (descending) natural order. Must be used in combination with the Sort Pages By parameter.</td>
</tr>
<tr>
<td>Include Search Box above Page Tree</td>
<td>false</td>
<td>Select if you want to include a search box above the page tree. The search box allows your readers to search within the page tree for the specified value.</td>
</tr>
<tr>
<td>Show Expand/Collapse Links</td>
<td>false</td>
<td>Select if you want to display the 'expand all' and 'collapse all' links at the top of your page tree. Your readers can click these links to open or close all branches of the tree at once.</td>
</tr>
<tr>
<td>Start Depth</td>
<td>1</td>
<td>Enter any number greater than 0 to set how many levels of children the tree should show when it opens for the first time.</td>
</tr>
</tbody>
</table>

**Related Topics**

- Page Tree Search Macro
- Adding a Navigation Sidebar
- Working with Macros

Take me back to the Confluence User's Guide.

**Sample Page Tree**

This page is a sample, used to demonstrate the Pagetree macro.

**For more information, take a look at the main page on the Page Tree Macro.**

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetree:root=@parent</td>
<td>expandCollapseAll=false}</td>
</tr>
</tbody>
</table>

**Another Sample Page Tree**

We're using this page to demonstrate the Pagetree macro.
For more information, take a look at the main page on the Page Tree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetree:root=@parent</td>
<td>expandCollapseAll=true}</td>
</tr>
<tr>
<td></td>
<td>Collapse all</td>
</tr>
</tbody>
</table>

Sample Page Tree 2

This is another sample page, used to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Page Tree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetree:root=@parent</td>
<td>expandCollapseAll=true}</td>
</tr>
<tr>
<td></td>
<td>Collapse all</td>
</tr>
</tbody>
</table>

Page Tree Search Macro

Using the Page Tree Search macro, you can add a search box to your Confluence page. When a viewer enters a search term, Confluence will search a hierarchy of pages starting from a specified parent (root) page and return the search results.

You can also add a search box as part of a dynamic page tree, which looks like a table of contents. See the Page Tree macro.

Using the Page Tree Search macro

To add the Page Tree Search macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Related pages:
- Page Tree Macro
- Adding a Navigation Sidebar
- Working with Macros
- Confluence User's Guide

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
### Name of Root Page

<table>
<thead>
<tr>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>none</td>
<td>The name of the root page whose hierarchy of pages will be searched by this macro. If this not specified, the root page is the current page.</td>
</tr>
</tbody>
</table>

**Note:** Unlike the Page Tree macro, the Page Tree Search macro does not accept the special values that start with an @ sign, such as @home or @self.

### Panel Macro

The Panel Macro allows you to display a block of text within a customisable panel, like a text box. Here is an example:

```markdown
My Title
A formatted panel.
```

**Using the Panel Macro**

**To add the Panel macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panel Title</td>
<td>none</td>
<td>The title of the panel. If specified, this title will be displayed in its own title row.</td>
</tr>
<tr>
<td>Border Style</td>
<td>solid</td>
<td>The style of the panel's border. Accepted values are solid, dashed and other valid CSS border styles.</td>
</tr>
<tr>
<td>Border Colour</td>
<td></td>
<td>The colour of the panel's border.</td>
</tr>
<tr>
<td>Border Pixel Width (Value Only)</td>
<td></td>
<td>The width of the panel's border (in pixels).</td>
</tr>
</tbody>
</table>
Background Colour

The background colour of the panel.

Title Background Colour

The background colour of the title row of the panel.

Title Text Colour

The colour of the text in the title row of the panel.

Colours can be specified HTML colour names or hexadecimal codes.

Notes

- You can use panels within columns and table cells.

Related Topics

Working with Macros

Take me back to the Confluence User’s Guide.

Popular Labels Macro

The Popular Labels macro displays the most popular labels used throughout your Confluence site or within a space.

Using the Popular Labels Macro

To add the Popular Labels macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Labels to Display</td>
<td>100</td>
<td>Specifies the total number of labels to display in the heatmap.</td>
</tr>
<tr>
<td>Restrict Labels to this Space Key</td>
<td>none</td>
<td>Restricts the list of popular labels to the specified space.</td>
</tr>
</tbody>
</table>
### Style of Labels

<table>
<thead>
<tr>
<th>list</th>
</tr>
</thead>
</table>

- **list** – displays the popular labels as a bulleted list, ordered by popularity (highest first).
- **heatmap** – displays the popular labels using different font sizes for each label depending on the label's popularity, ordered by label names.

### Related Topics

- Using Label Macros to Categorise Wiki Content
- Related Labels Macro
- User-contributed extension: Sortable Popular Labels

Take me back to the Confluence User's Guide.

### Profile Picture Macro

The Profile Picture macro displays a user's profile picture on a page.

- When viewing the page, mouse-over the picture to see the Hover Profile for the user.
- When editing the page, click on the picture and choose View User Profile to see the profile for the user.

The Profile Picture macro is useful for such tasks as creating Team Pages that show all members of a project team.

#### On this page:

- Using the Profile Picture Macro
- Parameters
- Related Topics

### Using the Profile Picture Macro

#### To add the Profile Picture macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

#### Speeding up macro entry with autocomplete:

Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

#### To edit an existing macro:

Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output.
The Recently Updated Dashboard macro displays a list of the most recently changed content within Confluence. It is similar to the Recently Updated macro but is intended for use on the Confluence dashboard.

**Using the Recently Updated Dashboard Macro**

To add the Recently Updated Dashboard macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space(s)</td>
<td></td>
<td>The space which contains the page on which the macro is added.</td>
</tr>
<tr>
<td>Include these Content Types</td>
<td>all types</td>
<td>Filter content by type. You can specify one or more types, separated by commas. Available types are: page, blogpost, news, spacedesc, attachment, comment, mail, userinfo.</td>
</tr>
</tbody>
</table>

**Related Topics**

**Working with Macros**

Take me back to the Confluence User's Guide
| **Label(s)** | none | Filter content by label. The macro will display only the pages etc which are tagged with the label(s) you specify here. You can specify one or more labels, separated by commas.
Note: If there are no pages matching any of the specified labels, then Confluence will ignore the labels and will list all recently updated pages, as well as showing a message, "These labels don't exist and were ignored: xxx ". This unexpected behaviour is noted in issue [CONF-13860 - Authenticate](#).

| **User(s)** | all users | Filter by username of the user who updated the content. The macro will only display content created and updated by the user(s) you specify here. You can specify one or more usernames separated by commas.

| **Width of Table** | 100% | Specify the width of the macro display, as a percentage of the window width.

| **Show User Profile Pictures** | false | Select whether profile pictures of the users who updated the content are displayed.

**Related Topics**

- [Recently Updated Macro](#)
- [Viewing Recently Updated Content](#)
- [Working with Macros](#)

Take me back to the [Confluence User's Guide](#).

**Recently Updated Macro**

The Recently Updated macro displays a list of the most recently changed content within Confluence.

The [Recently Updated Dashboard macro](#) is similar to this macro, but is intended for display on the Confluence dashboard.

**Using the Recently Updated Macro**

To add the Recently Updated macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.
**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in [Using Autocomplete](#).

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Author(s) by username</strong></td>
<td>None specified i.e. display all content</td>
<td>Filter the results by author. The macro will display only the pages etc which were last modified by the author(s) you specify here.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can specify one or more authors, separated by a comma or a space.</td>
</tr>
<tr>
<td>Space(s)</td>
<td>@self, i.e. the space which contains the page on which the macro is used</td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td>--------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
</tbody>
</table>

This parameter allows you to filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here.

You can specify one or more space keys, separated by a comma or a space.

- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.
- To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:

- @self — The current space.
- @personal — All personal spaces.
- @global — All global spaces.
- @favorite — The spaces you have marked as favourite.
- @favourite — The same as @favorite above.
- @all — All spaces in your Confluence site.
- * — The same as @all above.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.
| **Label(s)** | None specified i.e. display all content | Filter the results by label. The macro will display only the pages etc which are tagged with the label(s) you specify here. You can specify one or more label values, separated by a comma or a space.  
- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labelled with 'badpage'.  
- To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage,+goodpage you will get only content which has at least two labels, being 'superpage' and 'goodpage'. |
| **Width of Table** | 100% | Specify the width of the macro display, as a percentage of the window width. |
| **Include these Content Types Only** | all types | This parameter allows you to filter content by content type. The macro will display only the content of the type you specify here.

You can specify one or more types, separated by a comma or a space.

To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of `-blogpost` you will get pages and all other content except for blog posts.

Available values:
- page — [Pages](#).
- blogpost or news — [Blog posts](#), also known as news items.
- comment — [Comments](#) on pages and blog posts.
- attachment — [Attachments](#).
- status — [Status updates](#) made by other users. |

<p>| <strong>Maximum Number of Results</strong> | 15 | Specify the maximum number of results to be displayed. If this parameter is omitted, then a maximum of 15 results are displayed. The theoretical maximum value that this parameter can accept is 2 to the power of 31, minus 1 (or 2147483647), though this has been limited to 200 in the code, for performance reasons. More details are <a href="#">here</a>. |</p>
<table>
<thead>
<tr>
<th>theme</th>
<th>'concise' with the heading 'Recently Updated'</th>
<th>Choose the appearance of this macro:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>• concise — the default list, showing the names of pages which were updated or commented on, the users who made the page modifications and time when the modifications occurred.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• social — lists recent modifications in reverse chronological order, but groups them by user into short time segments. A 'sub' list appears within each user’s time segment, showing the names of pages which they updated or commented on and time when these modifications occurred.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• sidebar — lists recent updates in reverse chronological order, showing the names of pages which were updated or commented on and time when the page modifications occurred. This theme does not show authorship.</td>
</tr>
</tbody>
</table>

| Show User Profile Pictures | false | Specify `showProfilePic=true` to display the profile pictures of the users who updated the content. |

Customising the wording

If you would like to change the wording displayed by the Recently Updated macro, please refer to the document on modifying the Confluence interface text.

**Related Topics**

- Recently Updated Dashboard Macro
- Viewing Recently Updated Content
- Working with Macros

Take me back to the Confluence User's Guide.

**Recently Used Labels Macro**

The Recently Used Labels macro displays a list of the labels that have been most recently added to a page, blog post or attachment. You can define the number of labels to be displayed and the scope (global spaces, your personal space, or the current space).

**Using the Recently Used Labels Macro**

**To add the Recently Used Labels macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

---

### On this page:

- Using the Recently Used Labels Macro
- Parameters of this macro

### Related pages:

- Related Labels Macro
- Content by Label Macro
- Recently Used Labels Macro
- Working with Confluence Labels
- Working with Macros
- Confluence User's Guide

---

### Parameters of this macro

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Labels to Display</td>
<td>10</td>
<td>Specifies the total number of labels to display in the list.</td>
</tr>
<tr>
<td>Scope for Retrieving Labels</td>
<td>global</td>
<td>Specifies the scope of labels to be displayed in the list. Valid values include:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• global — covers all non-personal spaces in the Confluence installation.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• space — the current space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• personal — your own personal space.</td>
</tr>
<tr>
<td>List Style</td>
<td>list</td>
<td>• list – displays the list of labels horizontally.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• table – includes additional information such as the page to which the label was added and the user who added it.</td>
</tr>
<tr>
<td>Table Title</td>
<td>none</td>
<td>Adds a title to the top of the list in table style. Titles are only visible when the List Style parameter has been set to table.</td>
</tr>
</tbody>
</table>

---

**Related Labels Macro**
The Related Labels macro lists all labels from every page which has one or more labels in common with the current page.

**Using the Related Labels Macro**

**To add the Related Labels macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restrict to these Labels</strong></td>
<td>none</td>
<td>Specify the labels for which you want to view related labels. For example, <code>documentation,my:stuff</code></td>
</tr>
</tbody>
</table>

**Related Topics**

- [Navigation Map Macro](#)
- [Content by Label Macro](#)
- [Recently Used Labels Macro](#)
- [Working with Confluence Labels](#)
- [Working with Macros](#)

Take me back to the [Confluence User's Guide](#).

**RSS Feed Macro**

The RSS Feed macro embeds an [RSS feed](#) on a page. It can display the contents of external feeds, or of internal feeds generated by Confluence. To display blog posts or to list recently updated pages in a space, use the [Feed Builder](#) to create an internal feed, then render it using this macro.

⚠️ **CAUTION:** Including unknown HTML inside a webpage is dangerous.

HTML inside an RSS feed can contain active scripting components. This means that it would be possible for a malicious attacker to present a user of your site with script that their web browser would believe came from you. Such code could be used, for example, to steal a user’s authentication cookie and give the attacker their Confluence login password.

The RSS Feed macro will only be available if it has been enabled by your Confluence administrator. Also, your Confluence administrator can define a [whitelist of trusted URLs](#). You will see an error message on the Confluence page, if the included URL is not in the whitelist.

⚠️ The information on this page does not apply to Confluence OnDemand.
**Using the RSS Feed macro**

To add the RSS Feed macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RSS Feed URL</td>
<td>none</td>
<td>The URL of the RSS feed link you want to show.</td>
</tr>
<tr>
<td>Maximum Number of Entries</td>
<td>15</td>
<td>Limit the number of entries displayed.</td>
</tr>
<tr>
<td>Show Item Titles Only</td>
<td>false</td>
<td>Show only the titles of the news items, not the content.</td>
</tr>
<tr>
<td>Show Name/Title of RSS Feed</td>
<td>true</td>
<td>Hide the feeds title bar.</td>
</tr>
</tbody>
</table>

**How up to date is the feed?**

By default, the RSS Feed macro caches the feed results for 60 minutes before fetching the data again.

If you wish to change the default caching, use the Cache macro to define how often the RSS Feed macro fetches the feed updates. You will need to install the Cache plugin onto your Confluence site.

**What happens to a page containing a disallowed URL?**

Your Confluence Administrator can set up a whitelist of allowed URLs. If this is the case, you may see an error on the pages which contain the RSS Feed macro.

A user can add the RSS Feed macro or the HTML-include macro to a Confluence page. The macro code includes a URL from which the content is drawn. When the page is displayed, Confluence will check the URL against the whitelist. If the URL is not allowed, Confluence will display an error message on the page.

The error message says that Confluence "could not access the content at the URL because it is not from an allowed source" and displays the offending URL. If the person viewing the page is a Confluence Administrator, they will also see a link to the Administration page where they can configure the URL whitelist.

Here is an example of the error message, including the link shown only to Confluence Administrators:
Here is an example of the error message, but without the link.

Authentication

Privatefeeds from external sites

RSS feeds which require authentication cannot be accessed using the RSS Feed macro.

Accessing internal HTTPS feeds

This applies only to Confluence instances which have enabled HTTPS for all content. If your site is fully HTTPS, the RSS Feed macro cannot access internal feeds. To enable the RSS Feed macro to access internal feeds without affecting your HTTPS setup, enable local-only HTTP access:

1. Shut down Confluence.
2. Consult the SSL guide to enable HTTP access to Confluence. You'll want to ensure that you have an HTTP connector and an SSL connector, both commented in. This means that Confluence will be accessible via both HTTP and HTTPS. However, you should not have a redirect port, nor rules in web.xml to redirect all traffic.
3. Instead of using web.xml to redirect traffic, insert a firewall rule to redirect all HTTP requests not from the Confluence server to the equivalent HTTPS URL. This ensures that users will only be able to access Confluence via HTTPS, as intended. If you have still left HTTP access for attachments enabled (to avoid the IE download bug) you must selectively enable those URLs as well.
4. Modify your Confluence RSS Feed macro feed link to use the HTTP URL, and restart Confluence.

Enabling and disabling the RSS Feed macro

The RSS Feed macro is a module of the Confluence HTML Macros plugin.

To enable or disable the RSS Feed macro:

1. Enable the Confluence HTML Macros plugin by following the instructions in Enabling HTML macros.
2. In the plugin module list of the HTML macros, find the RSS (rss-xhtml) module and hover your cursor over it to enable or disable it.

Related Topics

- Subscribing to RSS Feeds within Confluence
- Managing Changes and Notifications and Tasks
- Working with Macros
- Configuring a URL Whitelist for Macros
- Confluence User's Guide

Search Results Macro
The Search Results macro searches your Confluence site based on search terms specified in the macro code, and displays the results on the wiki page.

**Using the Search Results Macro**

**To add the Search Results macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Terms</td>
<td>none</td>
<td>The search terms which this macro will use to generate its results. You can refine your search query by using operators such as 'AND' and 'OR'. For example: my_query 1 AND my_query2. For more information, take a look at the documentation on the Confluence search syntax.</td>
</tr>
<tr>
<td>Maximum Number of Results</td>
<td>10</td>
<td>Set a limit to the number of search results displayed.</td>
</tr>
<tr>
<td>Restrict to this Space Key</td>
<td>all</td>
<td>Specify the key of the space you want to search in. Note that this is case-sensitive.</td>
</tr>
<tr>
<td>Content Type</td>
<td>all</td>
<td>Specify the content type. The content types are: page, comment, blogpost, attachment, userinfo (the content of user profiles only) and spacedesc (the content of space descriptions only).</td>
</tr>
</tbody>
</table>
### Last Modified

| all
| Specify a period of time in weeks, days, hours and/or minutes, to see the content modified within that time frame. For example:
| - 2h 35m
| - 3d 30m
| These are the values you can use:
| - w = weeks
| - d = days
| - h = hours
| - m = minutes
| If no time category is specified, Confluence assumes minutes.
| If you specify more than one time period (e.g. weeks and days), the periods must be separated by a space and they can come in any order.
| The time categories are not case sensitive e.g. ‘4d’ is the same as ‘4D’.

### Restrict to this Username

| all
| Specify the username of a Confluence user, to show only content created or updated by that user.

---

#### Permissions

When a user views the page containing the Search Results macro, the search results will show only pages and other content types for which the user has 'View' permission.

---

### Related Topics

- Livesearch Macro
- Searching Confluence
- Working with Macros

Take me back to the Confluence User's Guide.

#### Section Macro

**Used with the Column macro to define columns on a page.** See Working with page layouts and columns and sections.

**Space Attachments Macro**

See Displaying a List of Attachments.

**Space Details Macro**

The Space Details macro renders the space's details in a table within the page.

**Using the Space Details Macro**
To add the Space Details macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width of Table</td>
<td>100%</td>
<td>The width of the space details table, specified as a percentage (%) of the page width.</td>
</tr>
</tbody>
</table>

**Related Topics**

Editing Space Details
Working with Macros

Take me back to the Confluence User’s Guide.

**Space Jump Macro**

This page describes the Space Jump Macro, which is provided with the Documentation theme. You can use space jumping to link from a page in one space to a page with the same name in another space, without knowing the name of the page when you create the link.

The Space Jump macro inserts a link onto the page. When the reader clicks the link, they will jump to a page that has the same name in another space. You specify the space when you insert the Space Jump macro.

**Example:** We use the Space Jump macro to put a standard message at the top of our archive spaces, telling people that they’re reading an old version of the documentation and letting them jump quickly to the same page in the latest documentation. See the words ‘this page in the current documentation’ in the screenshot below.

**Screenshot:** One way of using the Space Jump macro

This documentation relates to an earlier version of Confluence. View this page in the current documentation or visit the current documentation home.

Configuring the Documentation Theme

Using the Space Jump Macro
To add the Space Jump macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>None</td>
<td>The space key that contains a page with the same page title that you want the link to jump to. Space keys are case-sensitive.</td>
</tr>
<tr>
<td>Alias</td>
<td>None</td>
<td>The text to display as the hyperlinked text. If you do not supply an alias, Confluence will display the page name.</td>
</tr>
</tbody>
</table>

**More Information**

**What happens if there is no page with the same name in the target space?**

For the space jump to work, the target space must contain a page with the same name as the page that renders the Space Jump macro. If the target space does not contain such a page, you will see a broken link. Confluence handles this in its usual manner: the link is coloured red. If you click the link, Confluence offers to create the page for you.

**Can I use the Space Jump macro in any space?**

Yes. You can use the Space Jump macro in any space, even if that space is not currently using the Documentation theme. Provided that the Documentation theme plugin and its components are installed and enabled on your Confluence site, the Space Jump macro is available in any space.

**Related Topics**

Configuring the Documentation Theme
Working with Macros

Take me back to the Confluence User's Guide.

**Spaces List Macro**

The Spaces List macro is used to display a list of spaces within a page, similar to the list of spaces seen on the dashboard.

Using the Spaces List Macro
To add the Spaces List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scope of spaces</td>
<td>no</td>
<td>all</td>
<td>Specify the view from which spaces are listed. Available options are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <em>all</em> – All spaces in the Confluence installation.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <em>category</em> – Spaces grouped according to space categories.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <em>favourite</em> – Spaces which you have added to your favourites list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <em>new</em> – New spaces which have been created within the last 7 days.</td>
</tr>
<tr>
<td>Width of List</td>
<td>no</td>
<td>100%</td>
<td>Specify the width of the table. The width of the spaces list table,</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>specified as a percentage (%).</td>
</tr>
</tbody>
</table>

**Related Topics**

- Working with Spaces
- Creating a Page
- Working with Macros
- Confluence User's Guide

**Status Macro**

The Status macro displays a coloured lozenge (a rounded box) that is useful for reporting project status. You can choose the colour of the lozenge and the text that appears inside the lozenge. The macro also displays its current status in the editor, and you can change the status directly in the editor.

**Screenshot:** Click on the Status macro lozenge to change the status.

*All good!*
On this page:

- Using the Status Macro
- Parameters
- Related Topics

Using the Status Macro

To add the Status macro to a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Colour</td>
<td>Grey</td>
<td>The colour of the lozenge and its border. The border will be a darker version of the same colour. The following colours are available: Grey, Red, Yellow and Green.</td>
</tr>
<tr>
<td>Title</td>
<td>The colour that you select.</td>
<td>The text that will appear inside the lozenge. If you do not specify any text, the title will be the colour of the lozenge, that is ‘Grey’, ‘Red’, ‘Yellow’ or ‘Green’.</td>
</tr>
</tbody>
</table>

Related Topics

Working with Macros

Take me back to the Confluence User's Guide

Table of Contents Macro

The Table of Contents macro scans the headings of the current Confluence page to dynamically create a table of contents from your page headings. This helps readers navigate lengthy pages by summarising the content structure and providing links to headings. Headings are indented progressively.
Using the Table of Contents Macro

Hint: For quick access from the editor toolbar, choose Insert > Table of Contents.

To add the Table of Contents macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

<table>
<thead>
<tr>
<th>On this page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Using the Table of Contents Macro</td>
</tr>
<tr>
<td>• Macro Parameters</td>
</tr>
<tr>
<td>• Examples</td>
</tr>
<tr>
<td>• Code examples</td>
</tr>
<tr>
<td>• Notes</td>
</tr>
</tbody>
</table>

Related topics:

• Table of Content Zone Macro
• Page Tree Macro
• Adding a Navigation Sidebar
• Working with Macros
• Confluence Wiki Markup for Macros
• Confluence Storage Format for Macros
• Confluence User's Guide

Macro Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>list</td>
<td>• list — produces a typical list type TOC.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• flat — produces a horizontal menu-type series of links.</td>
</tr>
<tr>
<td>Display Section Numbering</td>
<td>clear</td>
<td>Select the check box to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.</td>
</tr>
</tbody>
</table>
| **List Style**       | none       | Select the style of bullet point for each list item. You can use any valid CSS style. For example:
|                    |            | - none — no list style is displayed
|                    |            | - circle — the list style is a circle
|                    |            | - disc — the list style is a filled circle. This is the typical bullet list, and is used for this example list.
|                    |            | - square — the list style is a square
|                    |            | - decimal — the list is numbered (1, 2, 3, 4, 5)
|                    |            | - lower-alpha — the list is lower-case, alphabetised (a, b, c, d, e)
|                    |            | - lower-roman — the list style is lower roman numerals (i, ii, iii, iv, v, vi)
|                    |            | - upper-roman — the list style is upper roman numerals (I, II, III, IV, V, VI)

| **Heading Indent** |            | Sets the indent for a list according to CSS quantities. Entering 10px will successively indent heading groups by 10px. For example, level 1 headings will be indented 10px and level 2 headings will be indented an additional 10px.

| **Separator**      | brackets   | This parameter applies to flat lists only. You can enter any of the following values:
|                    |            | - brackets — Each item is enclosed by square brackets: [ ].
|                    |            | - braces — Each item is enclosed by braces: { }. 
|                    |            | - parens — Each item is enclosed by parentheses: ( ).
|                    |            | - pipe — Each item is separated by a pipe:
|                    |            | - anything — Each item is separated by the value you enter. You can enter any text as a separator, for example "****". If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters.
### Minimum Heading Level

1

Select the highest heading level to start your TOC list. For example, entering 2 will include levels 2, and lower, headings, but will not include level 1 headings.

### Maximum Heading Level

7

Select the lowest heading level to include. For example, entering 2 will include levels 1 and 2, but will not include level 3 headings and below.

### Include Headings

Filter headings to include according to specific criteria. You can use wildcard characters. See [Sun's Regex documentation](http://docs.oracle.com/javase/6/docs/api/java/util/regex/package-summary.html) for examples of constructing regular expression strings.

### Exclude Headings

Filter headings to exclude according to specific criteria. You can use wildcard characters. See [Sun's Regex documentation](http://docs.oracle.com/javase/6/docs/api/java/util/regex/package-summary.html) for examples of constructing regular expression strings.

### Printable

checked

By default, the TOC is set to print. If you clear the check box, the TOC will not be visible when you print the page.

### CSS Class Name

If you have custom TOC styles in your CSS style sheet, use this parameter to output the TOC inside `<div>` tags with the specified class attribute.

### Examples

The examples below are based on this table of contents:

1. **Places**
   1. Favourite Places
   2. Unknown Places
2. **Foods**
   1. Favourite Foods
   2. Unknown Foods
3. **Things**
   1. Favourite Things
   2. Unknown Things
Filtered Table of Contents

This example filters the headings to include those that contain 'Favourite', but excludes headings which end with 'Things'. The list is styled with Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
<tr>
<td>Exclude Headings</td>
<td>.*Things</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

I. Favourite Places  
II. Favourite Foods

Flat List

This example filters all headings to render a flat list of 'Unknowns' enclosed in square brackets (the default list style).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Maximum Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

[ Unknown Places ] [ Unknown Foods ] [ Unknown Things ]

Code examples

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Notes

- When you use a Table of Contents macro in a template, you will see an error when you preview the template itself. But the Table of Contents macro works on the pages that people create from the template – the table of contents shows up after they have saved the page. (This is probably because the template is not defined as a page, and the Table of Contents macro works for pages only.)

- Due to an outstanding issue in the Table of Contents macro (CONF-10619), the macro browser's Refresh function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Contents macro occurs only after the page is saved.
Using HTML Heading Markup with the Table of Contents Macro

The Table of Contents macro cannot handle HTML heading markup on its own. Hence, if you use the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Contents macro will not create a contents list out of these headings. (For more information about this issue, please refer to TOC-93.) However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Contents macro will incorporate these headings into your contents list.

```html
<h2><a name="pagename-headingname"></a>Heading Name</h2>
```

The syntax for the anchor name is the page name and heading name separated by a hyphen, in which the page and heading names have all spaces removed and are converted to lowercase. If punctuation marks occur within a page or heading name, each mark should usually be converted to its URL escape code in the anchor name.

Table of Content Zone Macro

The Table of Content Zone macro enables you to mark out a ‘page zone’ from which to create a table of contents. Styling the headings as a flat list enables you to enclose the page text by top and bottom navigation bars similar to web navigation. When styled as a list, headings are indented progressively.

Using the Table of Content Zone Macro

To add the Table of Content Zone macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

On this page:

- Using the Table of Content Zone Macro
- Parameters
- Examples
  - Filtered Table of Contents
  - Flat List
- Notes
- Related Topics
<table>
<thead>
<tr>
<th><strong>location</strong></th>
<th>both</th>
<th>Specifies where in the zone the output list is displayed: <strong>top</strong>, <strong>bottom</strong>, or <strong>both</strong>, which encloses the page zone content.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Output Type</strong></td>
<td>list</td>
<td>Specifies the layout for the table of contents:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>list</strong> – produces a vertical list, typical of a TOC.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>flat</strong> – produces a horizontal menu-type series of links, for example: [Heading 1] [Heading 2] [Heading 3].</td>
</tr>
<tr>
<td><strong>Display Section Numbering</strong></td>
<td>false</td>
<td>Select to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.</td>
</tr>
<tr>
<td><strong>List Style</strong></td>
<td>none</td>
<td>Specifies the style of bullet point for each list item. You can use any valid CSS style. For example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• none — no list style is displayed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• circle --- the list style is a circle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• disc — the list style is a filled circle. This is the typical bullet list, and is the one we're using for this example list</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• square — the list style is a square</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• decimal — the list is numbered (1, 2, 3, 4, 5)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• lower-alpha — the list is lower-case, alphabetised (a, b, c, d, e)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• lower-roman — the list style is lower roman numerals (i, ii, iii, iv, v, vi)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• upper-roman — the list style is upper roman numerals (I, II, III, IV, V, VI)</td>
</tr>
<tr>
<td><strong>Heading Indent</strong></td>
<td></td>
<td>Sets the indent for a <strong>list</strong> output type, according to CSS quantities. Entering “10px” will successively indent list heading levels by 10px. For example, h1 headings will be indented 10px and h2 headings will be indented an additional 10px.</td>
</tr>
</tbody>
</table>
| **Separator** | **brackets** | Only applies to the **flat** output type. Specifies the display style of the links. You can enter any of the following values:  
- **brackets** — Each item is enclosed by square brackets: [ ].  
- **braces** — Each item is enclosed by braces: { }.  
- **parens** — Each item is enclosed by parentheses: ( ).  
- **pipe** — Each item is separated by a pipe:  
- **anything** — Each is separated by the value you enter. You can enter any text as a separator, for example `****`. If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters. |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Minimum Heading Level</strong></td>
<td>1</td>
<td>Select the largest heading level to start your TOC list. For example, 2 will list h2, h3, and h4 headings, but will not include h1 headings.</td>
</tr>
<tr>
<td><strong>Max Heading Level</strong></td>
<td>7</td>
<td>Select the smallest heading level to include in the TOC. For example, 2 will list h1 and h2, but will not include h3 and below.</td>
</tr>
<tr>
<td><strong>Include Headings</strong></td>
<td></td>
<td>Filter the included headings according to specific criteria. You can use wildcard characters. See <a href="https://docs.oracle.com/javase/7/docs/api/java/util/regex/Pattern.html">Sun's Regex documentation</a> examples of constructing regular expression strings.</td>
</tr>
<tr>
<td><strong>Exclude Headings</strong></td>
<td></td>
<td>Exclude headings according to specific criteria. You can use wildcard characters. See <a href="https://docs.oracle.com/javase/7/docs/api/java/util/regex/Pattern.html">Sun's Regex documentation</a> for examples of constructing regular expression strings.</td>
</tr>
<tr>
<td><strong>Printable</strong></td>
<td><strong>true</strong></td>
<td>By default, the TOC is set to print. If you clear this parameter, the TOC will not be visible when you print the page.</td>
</tr>
<tr>
<td><strong>CSS Class Name</strong></td>
<td></td>
<td>If you have a custom TOC in your CSS style sheet, you can use this parameter to output the TOC with the specified &quot;class&quot; attribute.</td>
</tr>
</tbody>
</table>
Examples

The examples are based on a page with the following headings:

1. Places
   1. Favourite Places
   2. Unknown Places
2. Foods
   1. Favourite Foods
   2. Unknown Foods
3. Things
   1. Favourite Things
   2. Unknown Things

Filtered Table of Contents

This example will filter all headings to include those that contain "Favourite", but will exclude any heading which ends with the word "Things". The list is styled with upper-case Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>list</td>
</tr>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
<tr>
<td>Exclude Headings</td>
<td>.*Things</td>
</tr>
</tbody>
</table>

Screenshot: Filtered TOC ‘zone’ headings

I. Favourite Places
   II. Favourite Foods

Flat List

This example will filter all headings to render a flat list of "Unknowns" enclosed in square brackets.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Separator</td>
<td>brackets</td>
</tr>
<tr>
<td>Max Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

Screenshot: Filtered TOC ‘zone’ headings displayed as a flat list

[ Unknown Places ] [ Unknown Foods ] [ Unknown Things ]

Notes
Due to an outstanding issue in the Table of Content Zone macro (CONF-10619), the Macro Browser’s Refresh function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Content Zone macro occurs only after the page is saved.

Using HTML Heading Markup with the Table of Content Zone Macro — The Table of Content Zone macro cannot handle HTML heading markup on its own. Hence, if you used the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Content Zone macro will not create a contents list out of these headings. (For more information on this issue, please refer to TOC-93.)

However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Content Zone macro will incorporate these headings into your contents list.

\[
\text{<h2><a name="pagename-headingname"/>Heading Name</h2>}
\]

The syntax for the anchor name is usually the page name and heading name separated by a hyphen, in which the page and heading names have all spaces removed and are converted to lowercase. If punctuation marks occur within a page or heading name, each mark should usually be converted to its URL escape code in the anchor name.

**Related Topics**

- Table of Contents Macro
- Page Tree Macro
- Adding a Navigation Sidebar
- Working with Macros

Take me back to the Confluence User’s Guide.

**Tasklist Macro**

The Tasklist macro allows you to create and update a list of tasks on the wiki page. Users viewing the page can modify the tasks without having to edit the page, provided they have the required permissions to modify the page.

You may also be interested in the lightweight task list that you can add directly onto your page, via the editor insert menu. This method also allows you to notify users that tasks have been assigned to them. See Managing Tasks in Confluence.

**Using the Tasklist macro**

To add the Tasklist macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>‘Task List’</td>
<td>The name of the task list. This is displayed as the title above the list of tasks.</td>
</tr>
<tr>
<td>Width of List</td>
<td>530px</td>
<td>The width of the task list.</td>
</tr>
<tr>
<td>Enable Locking</td>
<td>clear</td>
<td>When selected, you can lock individual tasks so that they cannot be changed. See instructions below on editing the task list.</td>
</tr>
<tr>
<td>Prompt on Delete</td>
<td>clear</td>
<td>When selected, the user must confirm the deletion of a task in the list.</td>
</tr>
</tbody>
</table>

**Editing the task list while viewing a page**

While viewing a page, you can change the tasks in a task list as follows:

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a task</td>
<td>Type the task description in the box under the list title, and click Add.</td>
</tr>
<tr>
<td>Completing/uncompleting a task</td>
<td>Click the check box next to a task to mark the task as complete. The task name will become a lighter color and the progress bar will be updated. Clear the check box to mark the task as uncompleted. You can also click Uncheck all to mark all tasks as uncompleted.</td>
</tr>
<tr>
<td><strong>Editing a task</strong></td>
<td>Move your cursor over the task and click the edit icon (pencil) that appears to the right of the task. The task name will become editable and the edit icon will be replaced with a save icon. Make your change and press the ‘Enter’ key to save or click the save icon.</td>
</tr>
<tr>
<td><strong>Deleting a task</strong></td>
<td>Move your cursor over the task and click the delete icon (trash can) that appears to the right of the task.</td>
</tr>
<tr>
<td><strong>Viewing details of a task</strong></td>
<td>Click the arrow icon to the left of the task name. The task details will open in an expanded view.</td>
</tr>
<tr>
<td><strong>Locking a task</strong></td>
<td>Provided that the Enable Locking parameter has been selected, you can click the lock icon to prevent the task from being edited, deleted, or otherwise changed.</td>
</tr>
<tr>
<td><strong>Changing the priority</strong></td>
<td>When the task details are visible, click the appropriate option — High, Medium or Low.</td>
</tr>
<tr>
<td><strong>Assigning the task</strong></td>
<td>When the task details are visible, change the assignee of the task by typing in or searching for a username.</td>
</tr>
</tbody>
</table>

**Screenshot: Task List showing task details**

![Planning a Holiday Task List](image)

**Sorting the tasks**

There are two ways to sort the tasks in the list:

- Using the Sort by list.
- Using drag and drop.

Select one of the sort options from the 'Sort by' list:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom</td>
<td>This is the default option.</td>
</tr>
<tr>
<td>Priority</td>
<td>Sort the list in order of the priority you have allocated to each task.</td>
</tr>
<tr>
<td>Date Created</td>
<td>Sort the list in order of the dates upon which the tasks were created.</td>
</tr>
<tr>
<td>Completed</td>
<td>Move all completed tasks to the bottom or top of the list.</td>
</tr>
<tr>
<td>Name</td>
<td>Sort the list in order of the task names.</td>
</tr>
<tr>
<td>Assignee</td>
<td>Sort the list in order of the usernames assigned to the tasks.</td>
</tr>
</tbody>
</table>

Once you have selected a sort option, use the icon beside the **Sort by** box to reverse the sort order.

**Dragging and dropping a task into a new position:**

Drag a task up or down the list using the ‘drag me’ handle to the right of the task name. Make sure the task is positioned to the left of the existing tasks. A space will open and you will be able to drop the task into its new position.

**Viewing the progress on tasks completed**

The bar at the top of the task list displays two different colours, indicating the percentage of tasks completed.

**Screenshot: Progress Bar on Task List**

**Notes**

- It is not possible to add a due date to the task list. If you interested in this improvement request, you can comment on or vote for this issue: [CONF-7371 - Authenticate](#) to see issue details.
- The Tasklist macro does not notify users that a task has been assigned to them. But you can do that
using the lightweight task list accessible from the editor tool bar. See Managing Tasks in Confluence.

**Tip Macro**

Using the Tip macro, you can highlight a helpful tip on a Confluence page. The macro creates a green-coloured box surrounding your text as shown below.

![Tip Macro Example](image)

This text is rendered inside the tip macro.

### Using the Tip macro

**To add the Tip macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

---

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>The title of the tip. If specified, it will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>Show Tip Icon</td>
<td>true</td>
<td>If cleared, the icon will not be displayed.</td>
</tr>
</tbody>
</table>

---

### User List Macro
The User List macro displays a list of users registered in Confluence, based on their group membership. See also Configuring the User List Macro.

Using the User List Macro

To add the User List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group(s)</td>
<td>none</td>
<td>Specifies one or more groups whose Confluence users you want to list, using a comma-separated list of group names. To see all users registered in a Confluence installation, specify an asterisk ('*') for this parameter's value.</td>
</tr>
<tr>
<td>Display Online/Offline Users</td>
<td>none</td>
<td>Select to generate a list of online users. Clear to generate a list of offline users. In order to make this feature functional, a System Administrator needs to enable the User Log In Listener for your Confluence site.</td>
</tr>
</tbody>
</table>

List of online users can be misleading

When the Display Online parameter is used, Confluence uses a context listener to generate the list of online users. A context listener is a J2EE term for something that listens for events in the application server. We listen for session open and close events, so a user is 'online' if they have a session on the application server. Some application servers don't correctly despatch close events for sessions – in these cases, the list of online users may be misleading.

Related Topics

Working with Macros
Configuring the User List Macro in the Confluence Administrator’s Guide

Take me back to the Confluence User's Guide.
User Profile Macro

The User Profile macro displays a short summary of any Confluence user's profile on your Confluence page or blog. This is the same summary that appears in a Hover Profile, which appears whenever you mouse-over any user's name in the Confluence interface.

The information contained within your own summarised profile can be edited using your User Profile view.

Screenshot: Example of the User Profile Macro

Giles Gaskell
ggaskell@atlassian.com
“Working on final User Profile updates.”
Website: http://www.atlassian.com
Position: Technical Writer
Department: Development
Location: Sydney

Using the User Profile Macro

To add the User Profile macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>none</td>
<td>The username of the Confluence user whose profile summary you wish to show.</td>
</tr>
</tbody>
</table>

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

User Status List Macro

The User Status List macro displays a history of any Confluence user's status updates on your Confluence page.
or blog. This is the same history that appears in the user’s Status Updates view.

Screenshot: Example output of the User Status List macro

![History of my Status Updates](image)

```
```
Working on final User Profile updates.
Delete | about 2 hours ago
```
```
Moving onto Networks.
Delete | May 06
```
```
Well... Just one last status update.
Delete | May 01
```
```
Now venturing off onto other topics.
Delete | April 30
```
```
Now working on User Status Updates. At last...
Delete | April 30
```
```
```

Using the User Status List Macro

To add the User Status List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>none</td>
<td>The username of the Confluence user whose history of status updates you wish to show.</td>
</tr>
</tbody>
</table>

- If you wish to list status updates made by more than just one user, you can use the Recently Updated macro with the following parameter-value combinations:
  - Include these Content Types Only — status
  - Author(s) by username — the user(s) whose status updates you want to include in the list. If you leave this field blank, the status updates of all users will be included.
View File Macro

The View File macro allows you to embed an Office or PDF document into your Confluence page. First attach the document to a wiki page and then use one of the View File macros to display the document's content.

When users view the page, they will see the content of the Office document. Users do not need to have Office installed in order to see the content of the Office document. If they do have Office installed, users will be able to open the document for editing in their Office application.

For a full list of Office Connector prerequisites and limitations, please refer to:

- Office Connector Prerequisites
- Office Connector Limitations and Known Issue

For an overview of all Office Connector features, please refer to Working with the Office Connector.

On this page:

- Displaying an Office or PDF Document in Confluence
- Parameters for the Office and PDF Macros
- Editing a Word Document or Excel Spreadsheet
- Troubleshooting
- Related Topics

Displaying an Office or PDF Document in Confluence

To display an Office or PDF document in a page, use one of the following View File macros in the macro browser:

- Office Excel
- Office Powerpoint
- Office Word
- PDF

To add one of the View File macros to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters for the Office and PDF Macros

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Macro</th>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>All View File macros</th>
<th>Page Name</th>
<th>The page which contains the macro</th>
<th>Enter a page name, if you wish to display a document which is attached to another Confluence page.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>File Name</td>
<td>none</td>
<td>The file name of the Office or PDF document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>Office Excel</td>
<td>Show Grid?</td>
<td>true</td>
<td>Select to show grid lines around each cell of the Excel spreadsheet. Clear to hide these grid lines.</td>
</tr>
<tr>
<td></td>
<td>Worksheet Name</td>
<td>Last worksheet viewed in the spreadsheet</td>
<td>The name of the worksheet that you want displayed.</td>
</tr>
<tr>
<td></td>
<td>Last Row</td>
<td>Last row with content</td>
<td>The number of the last row you want displayed, starting from '0' as the first row.</td>
</tr>
<tr>
<td></td>
<td>Last Column</td>
<td>Last column with content</td>
<td>The number of the last column you want displayed, starting from '0' as the first column.</td>
</tr>
<tr>
<td>Office Powerpoint</td>
<td>Height</td>
<td></td>
<td>Specify the height of the display, in pixels (default) or as a percentage of the window's height.</td>
</tr>
<tr>
<td></td>
<td>Slide Number</td>
<td>none</td>
<td>Specify the number of the slide that you want displayed on the Confluence page, where the first slide is numbered zero. Instead of a slide show, the page will display just the single slide, represented as a JPEG image.</td>
</tr>
<tr>
<td></td>
<td>Width</td>
<td></td>
<td>Specify the width of the display, in pixels (default) or as a percentage of the window's width.</td>
</tr>
</tbody>
</table>
Reducing the size of the spreadsheet

Use the Last Column and Last Row parameters to reduce the size of the spreadsheet displayed on the wiki page. This is especially useful to prevent the display from showing empty cells. This will also help to prevent 'out of memory' errors.

Presentation display options

By default, a presentation is displayed as a dynamic slide show, using Adobe Flash Player. However, you can use the Slide Number parameter to display just one of the slides as a static JPEG image.

Editing a Word Document or Excel Spreadsheet

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence by clicking the title bar of the document.

You will find detailed instructions in Editing an Office Document from Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Related Topics

- Working with the Office Connector
- Working with Macros

Take me back to the Confluence User's Guide.

Warning Macro

The Warning macro allows you to highlight a warning note on a Confluence page.

It creates a red-coloured box surrounding your text as shown below.

Warning Macro Example

This text is rendered inside the warning macro.

Using the Warning Macro

To add the Warning macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters
Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>The title of the warning note. If specified, will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>Show Warning Icon</td>
<td>true</td>
<td>If &quot;false&quot;, the icon will not be displayed.</td>
</tr>
</tbody>
</table>

**Related Topics**

*Working with Macros*

Take me back to the Confluence User's Guide.

**Widget Connector Macro**

The Widget macro, or Widget Connector, allows you to embed certain multimedia content from other web sites into your Confluence page.

It supports the following content:

- Gadgets and other widgets: Google Gadgets, Widgetbox.
- Videos: YouTube, MySpace Video, Yahoo Video, Dailymotion, Episodic, Vimeo, Metacafe, blip.tv, Viddler.
- Photos and images: Flickr, Skitch.com.
- Micro-blogging: Twitter, FriendFeed, BackType.
- Documents and presentations: SlideShare, SlideRocket, Scribd, presentations on Google Docs.
- Calendars: Google Calendar.
- Forms and online databases: Wufoo HTML Form Builder, Dabble DB.
- Support and customer satisfaction: Get Satisfaction.

There are live examples of many of these on the widget examples page. If you wish to extend the functionality of this plugin, please see Extending the Widget Connector.

**On this page:**

- Using the Widget Connector
- Parameters
- Live Example of Flickr Photos
- Live Example of Google Gadget
- More Examples of Macro Code
- Troubleshooting
- Related Topics

**Using the Widget Connector**

To add the Widget Connector to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.
### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web Site’s Widget URL</td>
<td>This is the URL provided by the external web site for embedding content from that web site onto another web page.</td>
</tr>
<tr>
<td>Pixel Height (Value Only)</td>
<td>Specify the height of the display, in pixels.</td>
</tr>
<tr>
<td>Pixel Width (Value Only)</td>
<td>Specify the width of the display, in pixels.</td>
</tr>
</tbody>
</table>

### Live Example of Flickr Photos

This example displays all photos from Flickr with the tag ‘Atlassian’. It uses this URL: [http://www.flickr.com/photos/tags/atlassian/](http://www.flickr.com/photos/tags/atlassian/)

### Live Example of Google Gadget


### More Examples of Macro Code

#### Google Gadgets

You need to find the URL for the Google Gadget you want to display.

Here is one way to find a gadget's URL:

1. Go to the [Google Gadgets directory](http://www.google.com/ig/directory).
2. Find the gadget you want then click its name, such as 'Spider'.
3. The gadget's summary page will open. Copy the URL from your browser's address bar. The URL looks something like this one:


You can also use the URL of the 'add gadget' page. The page is called 'Add "gadgetx" to your iGoogle page':

1. There are a couple of ways to get to the 'add gadget' page:
   - Click a '+'Google' button underneath the gadget when displayed on a page somewhere.
   - Or click 'Add Stuff' on your iGoogle page.
2. Copy the URL from your browser's address bar. The URL would look something like this one:

   http://www.google.com/ig/add?synd=open&source=ggyp&moduleurl=abowman.googlepages.com/spider.xml
Widgetbox widgets

You will need to find the URL for the Widgetbox widget you want to display.

Here is one way to find a widget's URL:

1. Ensure you are logged in to Widgetbox and that you are viewing the Widgetbox Gallery.
2. Find the widget you want then click its name, such as 'cyber-pet'.
3. The widget's summary page will open. Within the Get Widget section, click the Atlassian Confluence icon. The Widgetbox Add to Confluence dialog box appears, containing the URL required for the Widgetbox Add to Confluence dialog box appears, containing the URL required for the
4. If you cannot see this icon, click the more... link to reveal it.
5. In the Widgetbox Add to Confluence dialog box, click Copy.
6. Copy the URL from your browser's address bar. The URL looks something like this one:

   http://widgetbox.com/confluence/b8327e33-c8eb-4a38-b842-fba866ffdd28

YouTube

You will need to find the URL for the YouTube video that you want to display.

To find a YouTube video's URL:

1. Go to YouTube and search for the video you want.
2. Click the title of the video, such as 'Wikis in Plain English'.
3. The video's summary page will open. Copy the URL from your browser's address bar. The URL looks something like this one:

   http://au.youtube.com/watch?v=-dnL00TdmLY

MySpace Videos

You will need to find the URL for the MySpace video that you want to display.

To find a MySpace video's URL:

1. Go to MySpace Video and search for the video you want.
2. Click the title of the video, such as 'Glacier Creek Confluence Time Lapse'.
3. The video's summary page will open. Copy the URL from your browser's address bar. The URL looks something like this one:

   http://vids.myspace.com/index.cfm?fuseaction=vids.individual&videoid=3376248&searchid=20c789f6-lae9-459a-bfec-75efcfc2847c

Yahoo Video
You will need to find the URL for the Yahoo video that you want to display.

To find a Yahoo video's URL:

1. Go to [Yahoo Video](http://video.yahoo.com) and search for the video you want.
2. Click the title of the video, such as 'Wiki Technology Trend: Past, Now and Future'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:

   ![URL](http://video.yahoo.com/watch/423158/2424140)

- If you are unable to obtain a unique URL from your browser's address bar, click the envelope (Share) icon on the lower section of the video screen and copy the contents of the **Link** field.

**Dailymotion Video**

You will need to find the URL for the Dailymotion video that you want to display.

To find a Dailymotion video's URL:

1. Go to [Dailymotion](http://www.dailymotion.com) and search for the video you want.
2. Click the title of the video, such as 'Wiki Technology Trend: Past, Now and Future'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:

   ![URL](http://www.dailymotion.com/user/spacevidcast/video/x7zevj_spacevidcast-2009-promo-video_tech)

- If you are unable to obtain a unique URL from your browser's address bar, click **Menu** at the lower right section of the video screen, select **URL & Embed Code** and copy the contents of the **Link** field.

**Episodic**

You will need an [Episodic](http://www.episodic.com) user account if you want to create and distribute videos via Episodic.

To embed an Episodic video onto a Confluence page:

1. Find the video and copy the URL from the address bar of your browser. The URL looks something like this:

   ![URL](http://app.episodic.com/shows/13/episodes/493)

2. Paste the URL into the **Web Site's Widget URL** box in the Macro Browser.

**Vimeo**

You will need to find the URL for the Vimeo video that you want to display.

To find a Vimeo video's URL:
1. Go to Vimeo and search for the video you want.
2. Click the title of the video, such as 'The Wiki Show - Allison the Russian High Kicker'.
3. The video’s summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.vimeo.com/909808

---

**Metacafe**

You will need to find the URL for the Metacafe video that you want to display.

To find a Metacafe video's URL:

1. Go to Metacafe and search for the video you want.
2. Click the title of the video, such as 'Wikis In Plain English (How To)'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.metacafe.com/watch/679493/wikis_in_plain_english_how_to/

---

**blip.tv**

You will need to find the URL for the blip.tv video that you want to display.

To find a blip.tv video's URL:

1. Go to blip.tv and search for the video you want.
2. Click the title of the video, such as 'River cruising on the Rhine'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://blip.tv/file/996864/

---

**Viddler**

You will need to find the URL for the Viddler video that you want to display.

To find a Viddler video's URL:

1. Go to Viddler and search for the video you want.
2. Click the title of the video.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.viddler.com/explore/Markus_Z/videos/1/
Flickr

You can embed a slide show of photos from Flickr by supplying a URL that specifies one of the following:

- Photos with a specific tag.
- Photos belonging to the photostream of a specific Flickr user.
- A set of photos as defined by the Flickr user.
- A user's photostream starting at a specific photo.

If you want to do something else, we suggest that you try any Flickr URL. It should work.

Below are some examples of the Widget macro code for embedding Flickr images.

**Flickr Photos with a Specific Tag**

This URL displays a slide show of Flickr photos that are tagged with the word 'Atlassian': [http://www.flickr.com/photos/tags/atlassian/](http://www.flickr.com/photos/tags/atlassian/)

**Flickr Photos from a Specific User**

This URL displays a slide show of photos from the Flickr photostream of user 'Atlassian': [http://www.flickr.com/photos/atlassian/](http://www.flickr.com/photos/atlassian/)

**Flickr Photos from a Specific Set**

This URL displays a slide show of Flickr photos from the set 'Melbourne Cup - November 2008' created by user 'Atlassian': [http://www.flickr.com/photos/atlassian/sets/72157608657271078/](http://www.flickr.com/photos/atlassian/sets/72157608657271078/)

**A Specific Flickr Photo**

This URL displays a slide show of photos from the Flickr photostream of the user 'Atlassian', starting with a specific photo: [http://www.flickr.com/photos/atlassian/3003538919/](http://www.flickr.com/photos/atlassian/3003538919/)

Skitch.com

You will need to find the URL for the Skitch image that you want to display.

To embed a Skitch image onto a Confluence page:

1. Go to [Skitch.com](http://skitch.com).
2. Find the image and copy the URL from the address bar of your browser. The URL looks something like this:

   ```
   http://skitch.com/atlassian/411g/example-image
   ```

Twitter

Use a [Twitter](http://twitter.com) link in the Widget macro to display a dynamic list of the latest tweets sent by a user or matching a Twitter search.

To display the latest messages from a Twitter user, add the user's Twitter link as the URL in the Widget macro.
This URL will display Mike Cannon-Brooke's Twitter messages: http://twitter.com/mcannonbrookes

To display the latest messages resulting from a Twitter search, add the Twitter search link as a URL in the Widget macro.

- Make sure you use the supported format of the search URL:
  
  http://search.twitter.com/search?q=my search term

  The following format is not supported:

  http://twitter.com/#search?q=my search term

- The '#' tag is not supported (not even in its URL-encoded form %23).

This URL will display the most recent tweets containing the word 'AtlassianDragons': http://search.twitter.com/search?q=AtlassianDragons

**FriendFeed**

To display the latest messages from a FriendFeed user, add the user's FriendFeed link as the URL in the Widget macro. For example:

**BackType**

To display the latest blog or website comments from a BackType user, add the user's BackType widget link as the URL in the Widget macro. For example:

**SlideShare**

You will need to find the URL for the SlideShare presentation that you want to display.

To find a SlideShare presentation's URL:

1. Go to SlideShare and search for the presentation you want.
2. Click the title of the presentation, such as 'Using JIRA & Greenhopper for Agile Development'.
3. The presentation's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.slideshare.net/jleyser/using-jira-greenhopper-for-agile-development-presentation
SlideRocket

You will need to find the URL for the SlideRocket presentation that you want to display.

To find a SlideRocket presentation's URL:

1. Log in to SlideRocket and go to your library of presentations.
2. Copy the 'web link' for the presentation you want to display. This will give you a URL that looks something like this one:

   http://app.sliderocket.com/app/FullPlayer.aspx?id=132f9db7-b0fb-4f51-b974-36652774971b

3. Paste the URL into the Widget macro code on your Confluence page.

Scribd

You will need to find the URL for the Scribd presentation that you want to display.

To find a Scribd presentation's URL:

1. Go to Scribd and search for the presentation you want.
2. Click the title of the presentation, such as 'My Sea Friends Coloring Book'.
3. The presentation's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:


4. Paste the URL into the Widget macro code on your Confluence page.

Google Docs Presentations

You can embed presentations from Google Docs, but not other document types. You will need to find the URL for the Google Docs presentation that you want to display.

To find the URL of a Google Docs presentation:

1. Publish your presentation in Google Docs.
2. View your published document, then copy the URL from your browser's address bar. The URL will look something like this:

   http://docs.google.com/Presentation?docid=ddpqn8g5_0fx96zmmq&mm=en_GB

3. Paste the URL into the Widget macro code on your Confluence page.

Google Calendar

You can embed a Google Calendar into your page and to do this, you will need to add the URL for the Google Calendar that you want to display.
To find the URL for a Google Calendar:

1. Log in to Google Calendar.
2. In the calendar list on the left side of the page, ensure the appropriate calendar is selected, click the down-arrow button next to the calendar name and then select the Calendar settings option. (Alternatively, if available, click the Manage Calendars link at the bottom of the calendar list and then click the name of the appropriate calendar.)
3. In the Calendar Address section, click the HTML button. A pop-up message with your calendar’s public URL appears.
4. Copy the URL from this pop-up message. The URL looks something like this:

   http://www.google.com/calendar/embed?src=somebody%40example.com&ctz=Australia/Sydney

5. Paste the URL into the Widget macro code on your Confluence page.

**Wufoo HTML Form Builder**

To display an HTML form built in the Wufoo HTML Form Builder, add the form’s link as a URL to the Widget Macro. For example:

http://examples.wufoo.com/forms/contact-form/

**Dabble DB online database builder**

To display a shared page built in Dabble DB, add the page’s link as a URL to the Widget Macro. For example:

https://confluence-sample.dabbledb.com/page/confluence-sample/nSQqdgIg

The Widget Macro supports shared Dabble DB view and form pages. You can insert a Dabble DB data entry form into a Confluence page. On the same page or another page, you can use a a Dabble DB view to display data submitted via the form.

**Get Satisfaction social support application**

To display a feedback form for a Get Satisfaction community, add the community or company link as a URL to the Widget Macro. For example:

http://getsatisfaction.com/atlassian

**Troubleshooting**

If the URL given in the Widget Connector macro does not work, the macro displays an icon and the base URL. For example, the following code:
Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Widget Connector Examples

This page contains working examples of some services currently supported by the Widget Connector. This page lets you preview what each widget will look like and see how to interact with it.

- Flickr
- Google Docs
- YouTube
- MySpace
- Vimeo
- BlipTV
- Viddler
- Skitch
- Twitter
- FriendFeed
- SlideShare
- SlideRocket
- Scribd
- Wufoo
- Error Message
- Related Content

Flickr

http://www.flickr.com/photos/tags/atlassian

http://www.flickr.com/photos/atlassian/
Working with Drafts

A draft is a 'snapshot' of unsaved page content, which Confluence creates automatically at regular intervals while you are editing a page or blog post. This can minimise the loss of work if your Confluence site experiences a problem, since you can retrieve the page content from your last saved draft.

How do drafts work in Confluence?

At regular intervals, Confluence automatically saves a draft of the page you are editing. If a network failure or system error prevents you from saving your page, you can retrieve its last saved draft and continue working on the page from the last saved draft.

Drafts are created while you are adding and editing a page or blog post. Each new draft replaces the previously saved draft. By default, Confluence saves a draft of your page once every thirty seconds. However, an administrator can configure how often drafts are saved. In addition, whenever you edit a page and then move to another screen, Confluence will automatically save a draft.

When you edit the page again, Confluence will let you know that a version of the page you are editing was not saved and will give you the option to resume editing it.

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Each time Confluence saves a draft, it displays a message and the time of the last save near the Save button on the edit screen.

More about drafts:
- A user only has access to the drafts of pages they have been working on and whose content has not yet been saved.
- A user cannot create a draft explicitly.
- A user's drafts are listed in the 'Drafts' tab of their profile.
- Once a user has resumed editing a draft, or chosen to discard it, the draft is removed from their drafts tab.

Viewing drafts

Your drafts are listed on the Drafts tab of your user profile.

To see your drafts:

Go to your name (the 'User' menu) at the top of the page and choose Drafts.

Viewing your unsaved changes

While editing a page or blog post, you can view any 'unsaved' changes you have made since the last automatically saved draft, by clicking view change (near the Save button).
Configuring the Time Interval at which Drafts are Saved

By default, Confluence saves a draft of your page once every thirty seconds. However, as described below, a Confluence administrator can configure how often drafts are saved.

As a Confluence administrator, you can set the time interval at which drafts are saved as follows:

1. Choose Browse > Confluence Admin.
2. Click General Configuration in the left-hand panel.
3. Edit the setting for Draft Save Interval.

Related Topics

Working with Drafts
Resuming the Editing of a Draft

Concurrent Editing and Merging Changes

Sometimes, two or more people may edit a page at the same time. When this happens, Confluence will do its best to ensure that nobody's changes are lost.

How will I know if someone else is editing the same page as I am?

If another user is editing the same page as you, Confluence will display a message above your edit screen letting you know who the other user is and when the last edit was made.

Screenshot: Notification of Simultaneous Page Editing

⚠️ This page is being edited by Vidya Madabushi (last edit less than a minute ago)

What happens if two of us are editing the same page and the other user saves before I do?

If someone else has saved the page before you, when you click 'Save', Confluence will check if there are any conflicts between your changes and theirs. If there are no conflicting changes, Confluence will merge both the edits successfully. If there are any conflicts, Confluence will display them for you and give you the option to either 'Overwrite' the other user's changes, 'Merge your changes' manually, or 'Discard' them.
Example Scenario

For example, Alice and Bob both edit the same page at the same time.

If Alice clicks save before Bob, Bob is now effectively editing an out-of-date version of the page. When Bob clicks save, Confluence will examine his changes to see if any overlap with Alice's. If the changes do not overlap (i.e. Alice and Bob edited different parts of the page), Bob's changes will be merged with Alice's automatically.

If Bob's changes overlap with Alice's, Confluence will display an error message to Bob showing where Alice has changed the page, and giving Bob the options to overwrite Alice's changes with his own, to re-edit the document to incorporate Alice's work, or to cancel his own changes entirely.

Related Topics

Page History and Page Comparison Views
Viewing Page Information
Working with Drafts

Take me back to Confluence User's Guide.

Resuming the Editing of a Draft

If you have typed some content into a Confluence page or blog post, Confluence will save a draft of it, even if you were not able to successfully save the page or blog post, or add a title to it.

There are two ways to resume editing an unsaved page or blog post:

A. Using your drafts view. To resume editing a draft from this view:

1. Go to your name (the 'User' menu) at the top of the page and choose Drafts.
2. Click Resume Editing next to the appropriate draft to resume editing that draft.

   ▶️ If you had not yet entered a page title, the draft will be listed with the title 'Untitled'.

B. If you had created a new page or blog post but did not save it, then when you next add a page or blog post in that space, Confluence will ask you if you want to resume editing the page that was not saved. If you click resume editing, the draft and its unsaved content will be restored, allowing you to continue editing it.

Screenshot: Resume Editing

What happens if I am editing the draft of a page that has since been updated?

When this happens, Confluence will display a message informing you that you are editing an outdated page. If there are no conflicts between the two versions, Confluence will give you the option to Merge and Resume editing.

If there are any conflicts, Confluence will give you the option to View the Conflict or to Discard your changes.
Related Topics

Working with Drafts

Recording Change Comments

A 'change comment' is a short description that summarises the changes made to a page during an editing session. Change comments are a useful way of keeping track of the history of a page.

A change comment is not the same as a comment added to a page. Refer to Commenting on pages and blog posts for information about that type of comment.

Note that once a change comment has been added and the page has been saved, it is not possible to update or remove the change comment.

On this page:
- Entering a Change Comment
- Viewing a Change Comment
- Viewing a History of Change Comments
- Related Topics

Entering a Change Comment

You can enter change comments in the field located below the edit screen:

Screenshot: Entering change comments

Viewing a Change Comment

Once a comment has been added, it becomes visible in the view mode of the page, so that users are aware of the most recent changes made to a page. If a comment has been recorded, you will see a show comment link below the page title. Click the link to view the comment.

Screenshot: The 'show comment' link

The hide comment link allows you to hide the comment again, so that it does not distract you from the content of the page.

Screenshot: The 'hide comment' link
Viewing a History of Change Comments

The change comments for a page are recorded under the 'Recent Changes' section of the page's 'Info' view and in the page's 'History' view.

Screenshot: History of change comments on Info view

<table>
<thead>
<tr>
<th>Time</th>
<th>Editor</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mar 02, 2011 17:15</td>
<td>Administrator</td>
<td>Added the cheese macro.</td>
</tr>
</tbody>
</table>

Screenshot: History of change comments on History view

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Changed By</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>CURRENT</td>
<td>Mar 02, 2011 17:15</td>
<td>Administrator: Added the cheese macro.</td>
<td></td>
</tr>
<tr>
<td>v. 11</td>
<td>Mar 02, 2011 17:15</td>
<td>Administrator</td>
<td>Restore this version</td>
</tr>
<tr>
<td>v. 10</td>
<td>Mar 02, 2011 17:04</td>
<td>Administrator</td>
<td>Restore this version</td>
</tr>
</tbody>
</table>

Related Topics

Viewing Page Information
Page History and Page Comparison Views

Take me back to Confluence User's Guide

Working with Templates

When you add a new page, you do not have to write the content from scratch. Instead, you can base your new page on a template. A template is a Confluence page with predefined content.

Some examples of where templates are useful:

- A software development project may have a template for use cases.
- A systems administration space may have a template for defining what information is kept about each server.

Global templates and space templates

In Confluence, there are two places to store your page templates:
• **Space templates:** These page templates are available in a specific space only. People who have [space administrator](#) permission can define templates via the space administration screen.

• **Global templates:** These page templates are available in every space on the site. People who have [Confluence Administrator permission](#) can define the global templates via the Confluence Administration Console.

Confluence administrators can also import predefined templates.

## On this page:

- Global templates and space templates
- Creating a template
- Using a template
- Useful plugins

## Related pages:

- Adding a Template
- Global Templates
- Importing Templates
- Creating a Page using a Template
- Confluence User's Guide

## Creating a template

You can write your template using the Confluence rich text editor. You can also add special variables to the page, if you want to include fields that the author will complete when adding the page. See [Adding a Template](#) for more information.

## Using a template

Templates are used only when adding a page. Once a page has been added, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the [Atlassian Marketplace](#) for template add-ons.

See [Creating a Page using a Template](#) for more information.

## Useful plugins

Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on [plugin support](#).

Extended template functionality:

- [Scaffolding plugin](#)
- [Search the Atlassian Marketplace](#)

## Adding a Template

A template is a predefined page that can be used as a prototype when creating new pages. Templates are useful for giving pages a common style or format.

In Confluence, there are two places to store your page templates:

• **Space templates:** These page templates are available in a specific space only. People who have [space administrator](#) permission can define templates via the space administration screen.

• **Global templates:** These page templates are available in every space on the site. People who have [Confluence Administrator permission](#) can define the global templates via the Confluence Administration Console.
Adding a space template

Space templates are available in one space only.

To add a template for a space:

1. From any page in the space, choose Browse > Templates.
2. Choose Add New Space Template.

The 'Create Template' screen will appear. Add content as described below.

On this page:
- Adding a space template
- Adding a global template
- A template illustration
  - Using the template editor
  - The resulting form when the template contains variables
- Adding content to your template
  - Labels
  - Images and other attachments
  - Variables used as form fields
- Converting an existing page to a template
- Notes

Related pages:
- Creating a Page using a Template
- Working with Templates
- Working with Confluence Labels
- Working with Macros
- Using the Editor
- Confluence User's Guide

Adding a global template

Global templates are available in all spaces in your Confluence site.

To add a global template:

1. Choose Browse > Confluence Admin.
2. Enter your password if prompted.
3. Choose Global Templates in the left-hand panel.

The 'Create Template' screen will appear. Add content as described below.

A template illustration

Using the template editor

This illustration shows the template editor with an image, some text, styling, and variables.
The resulting form when the template contains variables

This screenshot shows the form displayed when someone creates a page based on the template containing the above variables. (See Creating a Page using a Template.)
Adding content to your template

Add a name for your template.

Enter text into the body of the template, and use the editor toolbar to apply styles, layout and formatting. You can add links and macros. In general, you can use the Confluence editor in the same way as on a page. In addition, you can add variables which will produce a form for data collection when someone adds a page based on the template.

Below are some points of special interest in templates.

Labels

Choose Labels to add one or more labels to the template. These labels will be included in all pages created using this template.

Images and other attachments

You cannot attach an image or other file to a template. Instead, attach the file to another page, and insert it into the body of the template.

For example:

- You can attach an image to a page and then choose Insert > Image to embed the image into the template.
- You can attach a PDF file to a page and then choose Insert > Other Macros > PDF to embed the PDF
file into the template.

The image or other file type will be displayed on all pages created using this template. The file will not be attached to the pages, but will be referenced from the page that you first attached it to.

**Variables used as form fields**

You can add variables to your template, to act as form fields. When someone creates a page based on the template, Confluence will display a text entry box for each field. The user can enter data into each field, and the data is inserted onto the new page.

Every variable must have a unique name. If you add the same variable more than once in the same template, Confluence will make sure that they have the same value when the user saves the page. This is useful if you need the same information in more than one place in the page.

**To insert a variable into a template:**

1. Place your cursor on the template where you want the variable to appear.
2. Choose $ Variables from the editor toolbar.
3. Choose **Add New Variable**. Alternatively, you can choose the name of an existing variable if you want the same variable to appear more than once in the template.
4. Enter the variable name.
5. Press **Enter**. By default this will create a single-line text input field.
6. To change the variable type, click the variable placeholder. The variable's property panel will appear. Choose one of the variable types: **Text**, **Multi-line Text**, or **List**. See [below](#) for a description of each type.

**Speeding up variable entry with autocomplete:** Type $ and the variable name, then press Enter, to add a new variable or to select an existing variable from a list of suggestions. The suggestions are drawn from variables already defined in this template.

These are the types of variable available:

<table>
<thead>
<tr>
<th>Variable type</th>
<th>Description</th>
</tr>
</thead>
</table>
| Text          | Creates a single-line text input field.  
**Screenshot:** A template variable called **$purpose** and its property panel  
This tutorial helps you to **$purpose**. |
<p>| Multi-line Text | |
| List | |</p>
<table>
<thead>
<tr>
<th>Multi-line text</th>
<th>Creates a text box that allows more than one line of text. By default, the text area is 5 rows depth and 100 characters wide. You can change the size by typing over the digits in the variable property panel.</th>
</tr>
</thead>
<tbody>
<tr>
<td>List</td>
<td>Creates a dropdown list. You must specify the values that will appear in the dropdown list. The values:</td>
</tr>
</tbody>
</table>
|                | - Must be separated by commas. 
|                | - Can include letters, numbers, special characters, and spaces. 
|                | - Cannot include commas (except as the list separation character). |

Screenshot: A multi-line variable and its property panel

$description2

| Text | Multi-line Text | List | 3 | x | 100 |

Screenshot: A list variable and its property panel

$product

| Text | Multi-line Text | List | Choc Berries | Choc |

Converting an existing page to a template

If you would like to convert an existing page to a template, you can copy the content from the page and paste it into the rich text editor pane in the template editor. There is no automated way of doing this.

Please note the section above about images and other attachments in templates.

Notes

- You cannot insert variables via the 'Insert wiki markup' option in the editor toolbar.
- Templates are used only when adding a page. Once a page has been added, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the Atlassian Marketplace for template add-ons.
- When you use a Table of Contents macro in a template, you will see an error when you preview the template itself. But the Table of Contents macro works on the pages that people create from the template – the table of contents shows up after they have saved the page. (This is probably because the template is not defined as a page, and the Table of Contents macro works for pages only.)
- The rich text editor for templates is available only in Confluence 4.3 and later. Please refer to the earlier documentation for a description of the wiki markup editor templates.

Creating a Page using a Template

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
You can create a page based on a global template (available to all spaces) or a space template (available only to that space). Before reading this page, make sure that someone has already created a template on your Confluence site.

Information copied from the template to the page

When you create a page based on a template, Confluence will copy the following content and information from the template to the new page:

- Labels
- Text and styles
- Layouts and formatting
- Macros
- Embedded images and other files. Note that you cannot attach an image or other file to a template. But if the template displays an image or file from another page, the new page will display that image or file too.

Form fields displayed by the template

If the template author included variables in the template, Confluence will display a form prompting you to supply values for the variables when you add the page. See screenshot below.

Using a template to create a page

To create a page based on a template:

1. Do one of the following:
   - Go to the dashboard and click Add Page. Choose the space and the template you want to use.
   - Or go to any page in the space where you want to add a page. Choose Add > Page from template, then choose a template.
   - Or go to the space where you want to add a page, and choose Browse > Templates. Then choose Create page from template next to the template you want to use.
2. If the template contains variables, you will now see a form. Type the relevant information into the form fields, and choose Next.
3. Now you will see a new page based on the template. If you added information in the form fields, the page content will include that information.
4. Type a name for the page where you see 'New Page'.
5. Add more content or make any other changes required.
6. Choose Save.

Screenshot: Form showing template variables when creating a page from a template
**Notes**

Templates are used only when adding a page. Once a page has been added, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the [Atlassian Marketplace](https://marketplace.atlassian.com) for template add-ons.

**Editing a template**

A template is a predefined page that can be used as a prototype when creating new pages. Templates are useful for giving pages a common style or format. This page is about changing an existing template.

**Note:** Templates are used only when adding a page. Once a page has been added, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the [Atlassian Marketplace](https://marketplace.atlassian.com) for template add-ons.

In Confluence, there are two places to store your page templates:

- **Space templates:** These page templates are available in a specific space only. People who have space administrator permission can define templates via the space administration screen.
- **Global templates:** These page templates are available in every space on the site. People who have Confluence Administrator permission can define the global templates via the Confluence Administration Console.
To edit a space template:

1. Go to a page in the space, and choose Browse > Templates. A list of templates for the space is displayed.
2. Choose Edit next to the template that you want to modify.
3. Make changes, or add new content, as you would when adding a template.
4. Choose Save.

To edit a global template:

1. Choose Browse > Confluence Admin.
2. Choose Global Templates in the left-hand navigation panel. A list of templates for the Confluence site is displayed.
3. Choose Edit next to the template that you want to modify.
4. Make changes, or add new content, as you would when adding a template.
5. Choose Save.

Removing a Template

A template is a predefined page that can be used as a prototype when creating new pages. Templates are useful for giving pages a common style or format. This page is about deleting an existing template, at space level or at site (global) level.

Templates are used only when adding a page. Once a page has been added, the template is no longer linked to the page. You can therefore remove the template without affecting any existing pages.

You need to be a space administrator to remove a space template, and you need Confluence Administrator permissions to remove a global template.

Note: Deleted templates cannot be restored.

To remove a space template:

1. Go to a page in the space, and choose Browse > Templates. A list of templates for the space is displayed.
2. Choose Remove next to the template that you want to delete.
3. Confirm the deletion when prompted.

To remove a global template:

1. Choose Browse > Confluence Admin.
2. Choose Global Templates in the left-hand navigation panel. A list of templates for the Confluence site is displayed.
3. Choose Remove next to the template that you want to delete.
4. Confirm the deletion when prompted.

Working with the Office Connector
The Office Connector is bundled with Confluence 2.10 and later. It allows you to:

- Import an Office document into Confluence format
- Attach an Office document to a Confluence page and display its content in Confluence, without converting the content.
- Edit the attached document in the Office application, directly from the Confluence page.

Please be aware that source code is currently not available for the Confluence Office Connector.

Table of Contents

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing a Word Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector

Related Topics

View File Macro
Configuring the Office Connector in the Confluence Administration Guide

Take me back to Confluence User's Guide

Office Connector Prerequisites

The page describes the software and setup you need to use the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

On this page:

- Overall Prerequisites
- Prerequisites for Viewing Office and PDF Files in Confluence
- Prerequisites for Importing Office Documents into Confluence
- Prerequisites for Editing Office Files Directly From Confluence
- Related Topics

The information on this page does not apply to Atlassian OnDemand sites with multiple apps. If you are using Confluence-only OnDemand, the information does apply.

Overall Prerequisites

- Ensure that Java 5 (JDK 1.5) or higher is installed on your Confluence server.
- The WebDAV plugin must be enabled, because the Office Connector uses WebDAV to transfer information to and from Office documents. Note that the WebDAV plugin is bundled with Confluence, and can be enabled or disabled by the System Administrator. If necessary, refer to the instructions on enabling plugins and configuring the WebDAV options.
• Ensure that your Confluence server's **base URL** is set correctly. (Check it by going to the 'General Configuration' screen in the Confluence Administration Console, as described in Configuring the Server Base URL.) When a user edits a wiki page in Word and then uploads the page back to the Confluence server, the base URL determines where the document will be saved. If the base URL is incorrect, the documents may be saved to a different Confluence server.

### Prerequisites for Viewing Office and PDF Files in Confluence

If you want to use the View File macro, or to view Office files attached to a Confluence page, you need the setup described below.

**Browsers and Flash Player**

You can use any browser to view an Office file on a wiki page or attachment view, provided that you have installed Adobe Flash Player version 9 or later. You do not need to have an Office desktop application installed on your computer in order to view Office files in Confluence.

**File Types**

Confluence can display files compatible with Microsoft Office 97-2007, and PDF files, of the following types:

- .doc and .docx
- .xls and .xlsx
- .ppt and .pptx
- .pdf

### Prerequisites for Importing Office Documents into Confluence

- Document import can import Microsoft Word documents of the file types .doc and .docx. These must be valid Word 97-2007 format documents.

### Prerequisites for Editing Office Files Directly From Confluence

The Office Connector allows you to edit Office files embedded in a wiki page or from the page’s attachments view.

To make use of these editing capabilities, you will need the setup described below.

**Browsers**

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.
- **Note: No Chrome support.** Chrome does not support WEBDAV clients, so this feature will not work. Please refer to this issue for more information: CONF-23322.

**Office editors**

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.
# Configuration matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, Windows Vista, or Windows XP with Service Pack 2 or 3</td>
<td><strong>OpenOffice</strong> 2.x – 3.x, or Microsoft Office XP, 2003, 2007 or 2010</td>
<td>Internet Explorer 8.x – 9.x, or Firefox – latest stable version</td>
</tr>
<tr>
<td>Mac OS X 10.5 and 10.6</td>
<td><strong>OpenOffice</strong> 2.x – 3.x The “Edit in Word” feature is known to work in <strong>OpenOffice</strong> 3.2 .0.</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td>Linux</td>
<td><strong>OpenOffice</strong> 2.x – 3.x The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.</td>
<td>Firefox – latest stable version</td>
</tr>
</tbody>
</table>

## Related Topics

- [Working with the Office Connector](#)
  - [Office Connector Prerequisites](#)
  - [Displaying Office Files in Confluence](#)
  - [Importing a Word Document into Confluence](#)
  - [Editing an Office Document from Confluence](#)
  - [Editing an Office Spreadsheet from Confluence](#)
  - [Editing an Office Presentation from Confluence](#)
  - [Installing the Firefox Add-On for the Office Connector](#)

- [Configuring the Office Connector](#) in the *Confluence Administration Guide*

Take me back to [Confluence User's Guide](#)

## Displaying Office Files in Confluence

Confluence can display Office files that are attached to a page. If you have an Office application installed, you will also be able to edit these Office files in your Office application.

These are two of the ways that Confluence can interact with Office files. For an overview of all Office Connector features, please refer to [Working with the Office Connector](#).

ℹ️ Your [System Administrator](#) can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to [Configuring the Office Connector](#) in the *Confluence Administration Guide* and discuss any configuration problems with your administrator.
Prerequisites

If you want to use the View File macro, or to view Office files attached to a Confluence page, you need the setup described below.

**Browsers and Flash Player**

You can use any browser to view an Office file on a wiki page or attachment view, provided that you have installed Adobe Flash Player version 9 or later. You do not need to have an Office desktop application installed on your computer in order to view Office files in Confluence.

**File Types**

Confluence can display files compatible with Microsoft Office 97-2007, and PDF files, of the following types:

- .doc and .docx
- .xls and .xlsx
- .ppt and .pptx
- .pdf

**Attaching and Displaying Office Files and PDF Files**

There are two ways to do this in Confluence:

- Attach Office files to a page and display them in a Confluence page using the View File or Attachments macros. These macros can be found using the View File macro. Refer to the detailed instructions in the Macro browser.
- Attach an Office or PDF file to a page and embed its contents onto the page by simply dragging and dropping it into the editor window.

**To attach and display Office files in Confluence using macros:**

1. Attach the Office file(s) to a Confluence page:
   - View the Confluence page on which you want to display your document.
   - Choose Tools > Attachments.
   - Browse for your Office files and upload them to the Confluence page.
   - Refer to detailed instructions in Attaching Files to a Page.
2. Now you have two options for displaying the attached document:
   - You can embed the document into the Confluence page, using one of the Office Word, Office Excel, Office PowerPoint or View PDF macros. These macros can be found using the macro browser. Refer to the detailed instructions in the View File macro topic.
   - You can display a list of page attachments using the Attachments macro. People viewing the page will be able to click the View link to see the Office or PDF document in Confluence.

**To attach and display an Office file on a Confluence page using 'drag and drop':**

- Drag the Office file from your computer and drop it into the editor window. Only one file can be dragged and dropped at a time. The appropriate View File macro placeholder will appear in the position where you dragged the file. However, the contents of the file will be rendered in full when you preview, or save and view, the page.
Viewing and Editing the Attached Office Files

If an Office document is **attached to a Confluence page**, you can view the attached Office document from within Confluence. View the Office document in one of the following ways:

- Search for the Office document by file name, then click View next to the Office document on the Search results page. (See [Searching Confluence](#).)
- View the list of attachments for a specific Confluence page, then click View next to the Office document on the Attachments page. (See [Viewing Attachment Details](#).)
- View a list of attachments displayed on a page via the Attachments macro, then click View next to the Office document in the list of attachments. (See [Displaying a List of Attachments](#).)
- View a Confluence page which has the Office document embedded in the page via the View File macro. (See [View File Macro](#).)

Any Confluence user who has an Office application installed will also be able to launch their Office editor from within Confluence:

- [Editing an Office Document from Confluence](#).
- [Editing an Office Presentation from Confluence](#).
- [Editing an Office Spreadsheet from Confluence](#).

### Troubleshooting

Problems? Please refer to our guide to the [Office Connector limitations and known issues](#).

### Related Topics

- [View File Macro](#)
- [Working with the Office Connector](#)
  - [Office Connector Prerequisites](#)
  - [Displaying Office Files in Confluence](#)
  - [Importing a Word Document into Confluence](#)
  - [Editing an Office Document from Confluence](#)
  - [Editing an Office Spreadsheet from Confluence](#)
  - [Editing an Office Presentation from Confluence](#)
  - [Installing the Firefox Add-On for the Office Connector](#)

[Configuring the Office Connector](#) in the *Confluence Administration Guide*

Take me back to the *Confluence User's Guide*.

### Importing a Word Document into Confluence

The Office Connector in Confluence allows you to import a Word document into Confluence, so that the document's content is copied onto one or more Confluence pages.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to [Working with the Office Connector](#).

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to [Configuring the Office Connector](#) in the *Confluence Administration Guide* and discuss any configuration problems with your administrator.

The simplest way to import a Word document is to import the entire content of the document into a single wiki page. By default, the content of the document will be created as a new wiki page.
More advanced options allow you to import the content into a new page, to split a single document into more than one wiki page, and to resolve conflicts in the titles of your pages.

These options are described below.

**Prerequisites**

Prerequisites for the Office Connector's document import feature:

- Document import can import Microsoft Word documents of the file types .doc and .docx. These must be valid Word 97-2007 format documents.

For a full list of Office Connector prerequisites and limitations, please refer to:

- [Office Connector Prerequisites](#)
- [Office Connector Limitations and Known Issues](#)

**Importing a Word Document**

The simplest way to import a Word document is to import the entire content of the document into a single wiki page.

This method will replace any existing content on the wiki page.

**To import a Word document onto a single wiki page:**

1. Create a page in Confluence (see [Creating a Page](#)) or go to an existing page whose content you want replaced. View the page in view mode (not edit mode).
3. Click Browse and find the Word document on your local drive or network.
4. Click the Open or Upload button provided by your browser. The path and file name of the document will now appear in the text box on the Office Connector import screen.
5. Click Next on the Office Connector import screen. The import document options screen will display.
6. The import document options are:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root page title</td>
<td>The title of the wiki page that will contain the information from your imported document.</td>
</tr>
<tr>
<td>Import as a new page in the current space</td>
<td>A new wiki page will be created with the page title specified above.</td>
</tr>
<tr>
<td>Replace <code>&lt;pagename&gt;</code></td>
<td>The contents of the existing page will be replaced. The page will be renamed to the page title specified above.</td>
</tr>
<tr>
<td>Delete existing children of <code>&lt;pagename&gt;</code></td>
<td>The existing child pages of the page you are replacing will be deleted.</td>
</tr>
<tr>
<td>Rename imported pages if page name already exists</td>
<td>Assign new names to any new page which would otherwise have a duplicate name. The content of existing pages will remain unchanged.</td>
</tr>
<tr>
<td>Replace existing pages with imported pages of the same title</td>
<td>If imported pages have titles equal to existing pages, then the content of the Word document will overwrite the content on the existing page. Page history will be preserved.</td>
</tr>
<tr>
<td>Remove existing pages with the same title as imported pages</td>
<td>If imported pages have titles equal to existing pages, then the existing pages will be deleted. This will remove the page history as well as the content.</td>
</tr>
<tr>
<td>Split by heading</td>
<td>The content of the Word document will be split over multiple wiki pages. If you don't want to split your document into multiple wiki pages, leave the default <strong>Don't split</strong> option selected. For more information on splitting your document, please see below.</td>
</tr>
</tbody>
</table>

7. Click **Import**.

When the upload has finished, the content of the Word document will have been transformed into Confluence page content. You can now view and edit this page in the usual way. There is no connection between the original Word document and this wiki page.

**Screenshot: Empty page ready for import**

![Empty page ready for import](image)

**Screenshot: Selecting Word document to import**

![Selecting Word document to import](image)
Splitting a Word Document into Multiple Wiki Pages

When importing a Word document, you can split a single document into more than one wiki page, based on the heading styles in the document.

By default, the page names will be the same as the heading text. This may result in a conflict, if a page already exists with the same title. You can instruct the importer how to handle such conflicts.

To import a Word document into multiple wiki pages:

1. Import a Word document as described above. On the import document options screen, choose how to split your document in the 'Split by heading' field:
   - 'Split by heading' — If you want to split the content under each heading in your document into separate child pages, select the desired heading level to split by. A preview of the page hierarchy that will be created by the split will be displayed under 'Document Outline'. Each bullet point in the 'Document Outline' represents a new page after import into Confluence.
2. Click 'Import' to import your document.
3. When the upload has finished, the content of the Word document will have been transformed into Confluence page content. You can now view and edit this page in the usual way. There is no connection between the original Word document and this wiki page.

Screenshot: Splitting a single Word document into multiple wiki pages

Editing an Office Document from Confluence
When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows you to edit a Word document from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

### On this page:
- Prerequisites for Editing an Attached Office Document
- Editing an Office Document in your Office Application
- Troubleshooting
- Related Topics

**Prerequisites for Editing an Attached Office Document**
The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.

To make use of these editing capabilities, you will need the setup described below.

**Browsers**
- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.
- **Note: No Chrome support.** Chrome does not support WEBDAV clients, so this feature will not work. Please refer to this issue for more information: CONF-23322.

**Office editors**
To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

### Configuration matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, Windows Vista, or Windows XP with Service Pack 2 or 3</td>
<td>OpenOffice 2.x – 3.x, or Microsoft Office XP, 2003, 2007 or 2010</td>
<td>Internet Explorer 8.x – 9.x, or Firefox – latest stable version</td>
</tr>
<tr>
<td>Mac OS X 10.5 and 10.6</td>
<td>OpenOffice 2.x – 3.x</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td></td>
<td>The &quot;Edit in Word&quot; feature is known to work in OpenOffice 3.2.0.</td>
<td></td>
</tr>
<tr>
<td>Linux</td>
<td>OpenOffice 2.x – 3.x</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td></td>
<td>The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.</td>
<td></td>
</tr>
</tbody>
</table>

### Editing an Office Document in your Office Application

To edit an Office document in your Office application:

1. There are two ways to do this:

   - **From an Office document embedded on a page:**
     a. Open a Confluence page with an Office document embedded on it.
     b. Move your mouse pointer to the top of the document embedded in the Confluence page, until the hidden title bar appears.
1. Click the title bar above the embedded document.

   - **From an Office document in a list of attachments:**
     - If an Office file is attached to a Confluence page, you can edit this file directly in your compatible Office application, in one of the following ways:
       - View the list of attachments for a specific Confluence page, then click **Edit** next to the Office file on the Attachments page. (See Viewing Attachment Details.)
       - View a list of attachments displayed on a page via the Attachments macro, then click **Edit** next to the Office file in the list of attachments. (See Displaying a List of Attachments.)

2. A window will pop up, asking you to confirm that you want to open this document.

   ![Confirmation window in Firefox](image)
3. Click ‘OK’. Now you may be asked to log in to your Confluence server.

4. Enter your Confluence username and password, then click ‘OK’.
5. The Office document will open in your Office application.
6. Make the necessary changes, then save the document. It will be saved back into Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Related Topics

Working with the Office Connector

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing a Word Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
Prerequisites for Editing an Attached Office Spreadsheet

The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.

To make use of these editing capabilities, you will need the setup described below.

Browsers

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.
- **Note: No Chrome support.** Chrome does not support WEBDAV clients, so this feature will not work. Please refer to this issue for more information: CONF-23322.

Office editors

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

Configuration matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Requirements</th>
<th>Confluence 4.3 Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating Systems</td>
<td>Windows 7, Windows Vista, or Windows XP with Service Pack 2 or 3</td>
</tr>
<tr>
<td></td>
<td>Microsoft Office XP, 2003, 2007 or 2010</td>
</tr>
<tr>
<td></td>
<td>Internet Explorer 8.x – 9.x, or Firefox – latest stable version</td>
</tr>
<tr>
<td></td>
<td>Mac OS X 10.5 and 10.6</td>
</tr>
<tr>
<td></td>
<td>OpenOffice 2.x – 3.x</td>
</tr>
<tr>
<td></td>
<td>The “Edit in Word” feature is known to work in OpenOffice 3.2 .0.</td>
</tr>
<tr>
<td></td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td></td>
<td>Linux</td>
</tr>
<tr>
<td></td>
<td>OpenOffice 2.x – 3.x</td>
</tr>
<tr>
<td></td>
<td>The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.</td>
</tr>
<tr>
<td></td>
<td>Firefox – latest stable version</td>
</tr>
</tbody>
</table>

### Editing an Office Spreadsheet in your Office Application

**To edit an Office spreadsheet in your Office application:**

1. There are two ways to do this:

   - **From an Office spreadsheet embedded on a page:**
     a. Open a Confluence page with an Office document embedded on it.
     b. Move your mouse pointer to the top of the spreadsheet embedded in the Confluence page, until the hidden title bar appears.

     *Screenshot: The title bar showing 'spreadsheet.xls' above an embedded Excel spreadsheet*

   - **From an Office spreadsheet in a list of attachments:**
     - If an Office file is [attached to a Confluence page](https://confluenceatitude.com), you can edit this file directly in your compatible Office application, in one of the following ways:
       - View the list of attachments for a specific Confluence page, then click **Edit** next to the Office file on the Attachments page. (See [Viewing Attachment Details](https://confluenceatitude.com).)
       - View a list of attachments displayed on a page via the Attachments macro, then click **Edit** next to the Office file in the list of attachments. (See [Displaying a List of Attachments](https://confluenceatitude.com).)

     *Screenshot: Confirmation window in Firefox*
3. Click ‘OK’. Now you may be asked to log in to your Confluence server.

Screenshot: Logging in to Confluence
4. Enter your Confluence username and password, then click ‘OK’.
5. The Office spreadsheet will open in your Office application.
6. Make the necessary changes, then save the spreadsheet. It will be saved back into Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Related Topics

Working with the Office Connector

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing a Word Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector

Configuring the Office Connector in the Confluence Administration Guide

Take me back to the Confluence User's Guide.

Editing an Office Presentation from Confluence

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows you to edit a PowerPoint presentation from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.

ℹ️ Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

On this page:

- Prerequisites for Editing an Attached Office Presentation
- Editing an Office Presentation in your Office Application
- Troubleshooting
- Related Topics

Prerequisites for Editing an Attached Office Presentation

The Office Connector allows you to edit Office files embedded in a wiki page or from the page’s attachments view.

To make use of these editing capabilities, you will need the setup described below.

Browsers

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.
- Note: No Chrome support. Chrome does not support WEBDAV clients, so this feature will not work. Please refer to this issue for more information: CONF-23322.
Office editors

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

Configuration matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, Windows Vista, or Windows XP with Service Pack 2 or 3</td>
<td>OpenOffice 2.x – 3.x, or Microsoft Office XP, 2003, 2007 or 2010</td>
<td>Internet Explorer 8.x – 9.x, or Firefox – latest stable version</td>
</tr>
<tr>
<td>Mac OS X 10.5 and 10.6</td>
<td>OpenOffice 2.x – 3.x</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td></td>
<td>The &quot;Edit in Word&quot; feature is known to work in OpenOffice 3.2.0.</td>
<td></td>
</tr>
<tr>
<td>Linux</td>
<td>OpenOffice 2.x – 3.x</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td></td>
<td>The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.</td>
<td></td>
</tr>
</tbody>
</table>

Editing an Office Presentation in your Office Application

To edit an Office presentation in your Office application:

1. There are two ways to do this:

   - From an Office presentation embedded on a page:
     a. Open a Confluence page with an Office presentation embedded on it.
     b. Click the 'Edit' icon on the bottom frame of the slide show.
1. **From an Office document in a list of attachments:**
   - If an Office file is attached to a Confluence page, you can edit this file directly in your compatible Office application, in one of the following ways:
     - View the list of attachments for a specific Confluence page, then click **Edit** next to the Office file on the Attachments page. (See Viewing Attachment Details.)
     - View a list of attachments displayed on a page via the Attachments macro, then click **Edit** next to the Office file in the list of attachments. (See Displaying a List of Attachments.)

2. A window will pop up, asking you to confirm that you want to open this document.

   Screenshot: Confirmation window in Firefox
3. Click ‘OK’. Now you may be asked to log in to your Confluence server.

4. Enter your Confluence username and password, then click ‘OK’.
5. The presentation will open in your Office application.
6. Make the necessary changes, then save the presentation. It will be saved back into Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Related Topics

Working with the Office Connector

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing a Word Document into Confluence
- Editing an Office Document from Confluence
• Editing an Office Spreadsheet from Confluence
• Editing an Office Presentation from Confluence
• Installing the Firefox Add-On for the Office Connector

Configuring the Office Connector in the Confluence Administration Guide

Take me back to Confluence User's Guide

Installing the Firefox Add-On for the Office Connector

If you are using Firefox as your browser, you will need to install an add-on into Firefox (the Firefox WebDAV Launcher) in order to use some features of the Office Connector. You will be prompted to install the add-on the first time you try to use a function which requires it.

For an overview of all Office Connector features, please refer to Working with the Office Connector.

Note about supported web browsers: Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. You can find the list of supported web browsers and browser versions on this page: Supported Platforms.

Installing the Firefox Add-On

You will be prompted to install the add-on the first time you try to use a function which requires it. The add-on is required for editing a wiki page in Office, or for editing an Office document which is displayed on a wiki page.

1. When you choose an option which requires the Firefox add-on, you will see a popup window like this one:

```
The page at http://extranet.atlassian.com says:

A plugin is required to use this feature. Would you like to download it?

OK Cancel
```

2. Click 'OK'. Some browsers may now ask you to confirm the download with a message bar across the top of the page, beneath the browser's address bar.

- You may see a message like the yellow bar shown here:

```
Viewfile macro

1 Added by Sarah Maddox, last edited by Sarah Maddox en Nov 03, 2008

Edit Add Tools
```

Click 'Allow'.
- Or you may see a similar message with an 'Edit Options' button like this:
If you see the above message, click 'Edit Options'. You will then see an 'Allowed Sites' window like this one:

![Allowed Sites window](image)

This window lets you tell Firefox that your Confluence server is allowed to install add-ons into Firefox. The 'Address of web site' box should already contain the address of your Confluence server.

- Click the 'Allow' button to add your Confluence server to the list.
- Go back to your Confluence page and try to edit your Office document again, e.g. by clicking 'Edit in Word' again. Now you will see the option to install the add-on.

3. A 'Software Installation' window will appear, asking you to confirm the installation. The window will look something like the one below, but the URL will be the address of your own Confluence server:
4. Click 'Install Now'. The installation will happen and a window will pop up asking you to restart Firefox:

5. Make sure you have saved all your Confluence pages and any other work in your browser, then restart Firefox.

6. If Firefox asks you to confirm the restart, confirm it.

7. Firefox will close all the browser windows and will then start up again. You will see a window confirming that a new add-on has been installed, like this:
Configuring the Add-On

After you have installed the add-on into Firefox, you will need to configure it. Basically, you will associate a desktop application (editor) with each relevant file type. This tells the Office Connector which application to launch when it encounters a link to an editable file. The configuration is slightly different for each operating system, as described below.

Configuring the Add-On in Windows

The add-on can will automatically configure itself on Windows via the system registry. The first time you edit a new file type, the add-on will look up the default editor for that file type and make that the permanent setting.

If you want to override the registry settings, or if for some reason the automatic configuration is not working, you can configure the Firefox add-on manually.

1. In Firefox, go to the 'Tools' menu and select 'WebDAV Launcher Options', as shown in this screenshot:
2. A 'WebDAV Launcher Options' window will appear, allowing you to associate a specific file type (file extension) with a desktop application (editor). The window looks like this one:

3. In the 'File Extension' box, enter the extension for a particular file type. For example, you may want to associate the 'doc' file extension with Microsoft Word 2003 or earlier. To do this, you would type 'doc' in the File Extension text box.

*If you use or have recently upgraded to Office 2007*

In addition to the original Office 2003 file extensions (that is, 'doc', 'ppt' and 'xls'), you should additionally configure the WebDAV launcher to handle the new Office 2007-specific file extensions for Microsoft Word ('docx'), Microsoft Excel ('xlsx') and PowerPoint ('pptx').
4. Enter the 'Application Path' — Use one of the following methods to specify the associated application for editing the given file type:

- Click the 'Auto' button to load the associated application from the Windows registry.
- Alternatively, you can click the 'Browse' button to find the application on your computer.
- Or you can manually type in the path to the application's executable file.

Screenshot: Configuring the WebDAV Launcher - adding the 'Application Path' for the 'doc' file extension.
If you use or have recently upgraded to Office 2007

Follow the instructions in this step to add the path to the relevant Office 2007 application for the Office 2007 file extension you configured above. For example, if you had a typical default installation of Office 2007, you would add the application path 'C:\Program Files\Microsoft Office\Office12\WINWORD.EXE' to the 'docx' extension.

5. Click the 'Add' button. The file extension association will be added to the list. For example, in the picture below you can see that the 'doc' extension has been associated with 'C:\Program Files\Microsoft Office\OFFICE11\WINWORD.EXE'. This is the path to the Microsoft Word 2003 executable on a specific Windows machine.

Screenshot: Configuring the WebDAV Launcher - configuration of the 'doc' file extension complete.

Configuring the Add-On in Mac OS X

The configuration procedure is similar to Windows, as shown above. Note that there is no 'Auto' button in Mac OS X.

Configuring the Add-On in Linux

The only known supported Office editor for Linux is OpenOffice. (See Office Connector Prerequisites.)

There is no automatic configuration on Linux. You will need to associate each file type with your Office editor in Firefox. Note that there is no 'Auto' button in Linux.

The configuration procedure is similar to Windows, as shown above.

For both Ubuntu and OpenSUSE, the configuration will look something like this:

<table>
<thead>
<tr>
<th>File Extension</th>
<th>Application Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>doc</td>
<td>C:\Program Files\Microsoft Office\OFFICE11\WINWORD.EXE</td>
</tr>
</tbody>
</table>
Security Risks

⚠️ Please be aware that there are security risks in installing this add-on to Firefox. Internet Explorer is exposed to the same risks, because it can directly open Office documents. By installing the add-in into Firefox, you are exposing Firefox to the same risks.

Summary of the risks:

- Office documents can contain macro viruses. Before opening an Office document, make sure that you trust the source of the document.
- There are known flaws in the Office file formats and Microsoft Office that an attacker can exploit to gain control of your machine. Microsoft has fixed the known exploits in the latest Service Packs for all Microsoft Office versions. But new exploitations may arise at any time. Again, be sure that you trust the source of a document before opening it.

The add-on tries to reduce the risk by supporting the following:

- **Same origin policy** — The add-on can only open documents from the same host that initiated the action.
- **Digital signature** — The add-on is digitally signed. When you install the add-on please verify that it is signed by Benryan Software Inc.

- **Prompt the user for confirmation** — You will always be warned before a file is opened. Please read these warnings carefully before opening a file. The warning tells you the complete URL of the file as well as the complete application path of the application opening the file.

Information about this Firefox Add-On
Add-on name: WebDAV Launcher

Description: Adds the ability to launch a WebDAV URL directly in a WebDAV-aware client.

Latest version: See the WebDAV Launcher add-on page at Mozilla

Compatible with: All versions of Firefox, up to and including the latest stable version.

Author: Atlassian Pty Ltd

Related Topics

- Working with the Office Connector
- Configuring the Office Connector in the Confluence Administration Guide

Importing Content Into Confluence

This page describes how to get text, pages, images and other content into Confluence, by converting the content from another storage format and importing it into the Confluence wiki.

Importing Content from Other Confluence Sites

For content originating from other instances of Confluence:

- If the Confluence major versions are the same, export the space from the originating Confluence site and import it into the destination Confluence site.
- If the Confluence major versions are different, you can use an intermediate server to migrate versions.

Page history, attachments, and page content will be preserved and you will be able to do multiple pages at once. The drawbacks are that it may be inconvenient if the Confluence versions differ, and you cannot have a duplicate space key on the destination instance. (You cannot import a space with the same space key as a space that already exists.)
On this page:

- Importing Content from Other Confluence Sites
- Importing Content from Other Wikis
- Importing Content from an Office Document
- Importing Web Content
- Importing Other Non-Wiki Content
- Note about Plugin Support

Related pages:

- Working with the Office Connector
- Confluence User’s Guide

Importing Content from Other Wikis

Check whether the Universal Wiki Converter can import the content. See Importing Content from Another Wiki.

Importing Content from an Office Document

The Office Connector in Confluence allows you to import an Office document into Confluence, so that the document’s content is copied onto one or more Confluence pages. See Importing a Word Document into Confluence.

Importing Web Content

Here are some options for importing or displaying web content on a Confluence page:

- Use the Widget Connector Macro to display videos, slide shows, twitter chats, documents and more, sourced from other web sites and displayed on your Confluence page.
- Convert a HTML file to a Confluence page using the HTML To Confluence Converter plugin.
- Embed an external web page into Confluence with the HTML Include macro.
- Use HTML code in a page with the HTML macro.

Importing Other Non-Wiki Content

Importing non-wiki markup into Confluence requires a conversion process:

- Text with basic formatting can be pasted directly into the editor. This includes simple Word documents or web pages.
- Files such as Microsoft Excel documents can be imported using a content converter plugin.
- Confluence pages saved to disk can be imported from disk.
- Files can be uploaded in bulk using the Confluence WebDav Plugin.
- Full featured customisation is available using the Confluence remote APIs.

Note about Plugin Support

Before installing a plugin into your Confluence site, please check the plugin’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

Importing Pages from Disk

Confluence allows you to import text files from a disk or a directory on the Confluence server, and convert them into Confluence pages. Each file will be imported as a Confluence page that has the same name as the file.

⚠️ The information on this page does not apply to Confluence OnDemand.
To import text files:

1. Choose Browse > Space Admin.  
   Note: 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
2. Click Import pages from disk in the left panel under 'Import'.
3. Type the directory's path into the Import directory box.
4. Select Trim file extensions to remove file extensions from the page titles when converting the files to Confluence pages. Note that the Confluence pages will take their titles from the files' names (including their extensions). So to avoid having page titles with a suffix like '.txt', make sure you check this box.
5. Select Overwrite existing pages if you want to replace existing Confluence pages with the same page title.
6. Click Import.

Screenshot : Importing text files

<table>
<thead>
<tr>
<th>Import directory:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trim file extensions:</td>
</tr>
<tr>
<td>Overwrite existing pages:</td>
</tr>
<tr>
<td>Import</td>
</tr>
</tbody>
</table>

Related Topics

Take me back to Confluence User's Guide

Sharing Content

Confluence provides a number of ways for you to notify other people about content that may be of interest to them:

- You can share a page link with them.
- You can mention a user when you write a page, blog post or comment. Mentioning a user automatically emails a notification to them about that content.
- You can broadcast a message that appears in Confluence activity streams.
- You can like a page, blog post or comment. The author will receive a notification. If enough people like the content, it will appear in the list of popular content on the dashboard and in the recommended updates email message.

Other users can also find out about changes to content in Confluence by watching pages and spaces.

You may also be interested in exporting Confluence content to other formats such as XML, HTML, Microsoft Word and PDF.
Network Overview

The 'network' feature provides notifications on the activity of users that you choose to follow. This compares with Confluence's other content tracking features, which provide notifications on specified types of content updates, made by any user.

The types of activities tracked by the network feature include:

- Additions or edits to pages or blog posts
- Comments added to a page or blog post or edits to existing comments
- Updates to a user's User Status Updates
- Updates to a user's User Profile

On this page:

- Accessing Your Network View
- Following Another User
- Stop Following a User
- Notes
- Related Topics

Accessing Your Network View

To see your network view:

- Go to the 'Network' view for your user profile. To do this:
  - Go to your name (the 'User' menu) at the top of the page and choose Network.

You can also access your 'Network' view by clicking More in the 'Network' section of your Profile Sidebar.

You can access another user's Network view using the Hover Profile or from their Profile Sidebar.

Screenshot: Example of the Network view
Following Another User

You can follow another user by using either the Hover Profile or your Network view.

To follow a user with the Hover Profile:

1. Open the user's Hover Profile popup. To do this:
   a. Log in to Confluence, if you have not already done so.
   b. Move your mouse pointer over a user's linked name or profile picture. Wait until the hover profile popup appears.
2. Click Follow in the popup.

To follow a user from your Network view:

1. Go to the 'Network' view for your user profile. To do this:
   - Go to your name (the 'User' menu) at the top of the page and choose Network.
     You can also access your 'Network' view by clicking More in the 'Network' section of your Profile Sidebar.
2. In the 'Following' section, at the right of the page, type the first few characters of the name (or username) of the user you wish to follow.
3. Choose the user from the list of suggestions.
4. Click Follow in the popup.

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just followed will appear within the 'Following' list on the right. Additionally, their tracked activities will start appearing in the 'Recent Activity' list on this page.

Stop Following a User

To stop following a user by using the Hover Profile:
1. Open the user's Hover Profile popup. To do this:
   a. Log in to Confluence, if you have not already done so.
   b. Move your mouse pointer over a user's linked name or profile picture. Wait until the hover profile popup appears.
2. Click **Stop Following** in the popup.

You can also stop following a user by going to their Profile view.

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just stopped following are removed from the 'Following' list on the right. Additionally, their tracked activities will stop appearing in the 'Recent Activity' list on this page.

**Notes**

Once you are following a user, you can see their activity in a number of ways:

- Your Network view: your Network view shows all the tracked activities that you have permission to view for all the users that you are following. In the same way, people who follow you will be able to see all your Confluence-based activities on their network views, provided they have permission to view the content. See below for instructions on accessing your network view.
- RSS feeds: you can subscribe to any Confluence user's network RSS feed and receive summaries on the activities of other users they are following in their network. See [Subscribing to a Network RSS Feed](#).
- Email notifications: you can request email notifications of any activity in your network. See [Subscribing to Email Notifications of Updates to Confluence Content](#).

Note that it is not possible to stop another user from following you. If you are interested in the ability to block followers, please watch [CONF-16285](#) for updates on the feature request.

**Related Topics**

- [Network Macro](#)
- [Subscribing to a Network RSS Feed](#)
- [Subscribing to Email Notifications of Updates to Confluence Content](#)

Take me back to the [Confluence User's Guide](#).

**Subscribing to a Network RSS Feed**

You can create an [RSS Feed](#) from any user's [network](#) view, allowing you to receive summaries on the activities of users they are following in their network. The types of activities tracked in these RSS feed summaries include:

- Additions or edits to [pages](#) or [blog posts](#)
- [Comments](#) added to a page or blog post or edits to existing comments
- Updates to a user's [User Status](#)
- Updates to a user's [User Profile](#)

**To subscribe to a user's network RSS feed,**

1. Locate the following icon , which is available from the top-right of:
   - The 'Recent activity of the users you are following' section of your network page, or
   - The 'Activity of followed users' section of another user's network page.
2. Copy and paste the icon's link into your RSS newsreader.
3. To have your newsreader log into Confluence, you can add your username and password to the feed URL.

⚠️ Please note that if you do this, someone with access to your RSS newsreader configuration can read these Confluence authentication details.
Customising your Network RSS Feed

Currently, Confluence does not provide a user interface mechanism for customising your network RSS feed. However, you can modify the maximum number of results and type of content displayed in these feeds by directly editing the RSS feed link in your RSS newsreader.

To modify the maximum number of results displayed in your RSS feed,
1. Edit the RSS feed link in your RSS newsreader.
2. Change the value of the `max` parameter from its default value of 40 to a value of your choice. The following example shows this parameter-value combination highlighted in red:
   http://confluence.atlassian.com/feeds/network.action?username=ggaskell&max=60&publicFeed=false&os_authType=basic&rssType=atom
3. Save the modified link in your RSS newsreader.

To modify the type of content displayed in your RSS feed,
1. Edit the RSS feed link in your RSS newsreader.
2. Append the parameter `contentType` to the end of the link, followed by an equals sign (=) and then add the appropriate content type value of your choice:
   - `USER_STATUS` — restricts the RSS feed to user status updates.
   - `PAGE` — restricts the RSS feed to page additions or updates.
   - `BLOG` — restricts the RSS feed to blog post additions or updates.
   - `ATTACHMENT` — restricts the RSS feed to attachment additions or updates.
   - `COMMENT` — restricts the RSS feed to comment additions or updates.
   Content type values are case-sensitive and when editing the network RSS feed link, ensure that each parameter is separated from the other by an ampersand (`&`). The following example shows the content type parameter-value combination highlighted in red:
   http://confluence.atlassian.com/feeds/network.action?username=ggaskell&max=40&publicFeed=false&os_authType=basic&rssType=atom&contentType=USER_STATUS
3. Save the modified link in your RSS newsreader.

Filtering for more than one type of content (by adding multiple values to the `contentType` parameter) is not supported.

RELATED TOPICS

Network Overview
Subscribing to RSS Feeds within Confluence

Take me back to the Confluence User's Guide.

Likes and Popular Content

Has someone written a good blog post or page on Confluence? Or has someone added a comment that you agree with? Click the Like button to them know. Like

Confluence has like buttons on every page, blog post and comment. If enough people like a page or post, it will show on the dashboard's 'Popular' tab. The information in the 'Recommended Updates' email message is based on the number of people who have liked the content.

Liking a page, blog post or comment

Click the Like button to let people know that you agree with or enjoy a page, blog post or comment. Click Unlike to remove your name from the list of people who like the content.
You can also see:

- Up to three names of people in your network who have most recently liked the content.
- A link showing the number of people how have liked the comment. For example, 19 people like this.

Click the link to see the names. At the top of the list are people in your network, sorted with the most recent likes first. Then follow other people, also sorted chronologically with the most recent first.

### Related pages:

- Dashboard
- Subscribing to Email Notifications of Updates to Confluence Content
- Network Overview

### Screenshot: The Like button at the bottom of a page and on comments

![Screenshot of the Like button and people who like this]

### Effects of liking content

When you like a page, blog post or comment:

- The author of the content receives a notification.
- People in your network receive a notification. They will receive the notification only if they do not already know about the content. Let's assume Arthur is in your network. Arthur will not receive a notification if:
  - Someone else in his network has already liked the content.
  - Arthur himself has already liked the content.
  - Arthur has already commented on it.
  - In the case of a threaded comment, Arthur has already replied to the comment.
• If enough people like the content, it will appear on the ‘Popular’ tab of the dashboard.
• Similarly, if the content is popular enough it will appear in the ‘Recommended Updates’ summary sent out by email.

Disabling the 'like' feature

The functionality is provided by a plugin called the ‘Confluence Like Plugin’. To remove the 'like' functionality from your site, you can disable the plugin. See Disabling or Enabling a Plugin.

Note: It is not currently possible to disable this feature in Confluence OnDemand. We are tracking this issue here: CONF-25469 - Authenticate to see issue details.

User Status Updates

The 'user status' feature allows any Confluence user to broadcast a short message, which other users can see on various activity streams in Confluence. These short messages could include:

• A description about what you are working on.
• A question you may want answered quickly.
• A hyperlink that you share immediately with other users.
• Any other message you may want to share quickly with other users.

Your 'Status Updates' view shows a history of updates you have made to your status.
Your current status message is shown on your:

• Profile view
• Profile sidebar
• Hover profile

On this page:

• Setting or updating your status
• Viewing your status updates
• Clearing your current status
• Deleting a status update
• More about user status updates
• Disabling status updates

Related pages:

• User Profile Overview
• User Status List Macro
• Confluence User's Guide

Setting or updating your status

To set or update your status:

1. Log in to Confluence, if you have not already done so.
2. Go to your name (the 'User' menu) at the top of the page and choose Update Status. The 'What are you working on' dialog will open.
3. Enter a short message (140 characters maximum) that describes your current status or what you are working on.
4. Click Update to publish your new or updated status to the activity streams (mentioned above), your personal space sidebar, your profile page and your status updates page.
Viewing your status updates

To view your status updates:

- Go to the ‘Status Updates’ view for your user profile. To do this:
  1. Go to your name (the ‘User’ menu) at the top of the page and choose Status Updates.

You can also view another user’s status by going to their profile.

Clearing your current status

You can clear your current status message using your profile or your status updates view.

Clearing a message is not the same as deleting it. If you clear a message, it is still shown in your status updates view until it is deleted.

**Using your Profile view...**

To clear your current status using your profile view:

1. Go to your name (the ‘User’ menu) at the top of the page and choose Profile.
2. Click Clear in the status message at the top of the page.
Using your Status Updates view...

To clear your current status using your status updates view:

1. Go to the 'Status Updates' view for your user profile. To do this:
   a. Go to your name (the 'User' menu) at the top of the page and choose Status Updates.
2. Click Clear in the status message at the top of the page.

Deleting a status update

To delete your current or a previous status message:

1. Go to the 'Status Updates' view for your user profile.
2. Click Delete next to the appropriate status message. Your status updates view will be refreshed and the message you deleted removed from the list.

More about user status updates

There are a number of activity streams in Confluence that show different types of status updates. These include:

- The 'Recently Updated' list on the Confluence Dashboard, which shows all status updates (when the All filter is selected on the dashboard).
ab is selected).

- Your **Network page**, which shows the status updates of Confluence users you are following.
- The **Network page** of Confluence users who are following you, which shows your status updates.
- The **Recently Updated** and **Recently Updated Dashboard** macros, which shows all status updates (provided that these macros' space parameters have been set to '@all').
- Any Confluence user's 'Activity' section of their **Profile Sidebar**, which is available on all pages within their personal space and shows their status updates.

While activity streams show recent status updates, they may soon disappear from the end of the list as subsequent user activity items appear on these streams. However, you can view any Confluence user's current status message in the following areas:

- Their **Hover Profile**.
- The **Profile** section of their **Profile Sidebar**, which is available on all pages within their personal space.
- Their **Profile page**.

You can also view any Confluence user's entire history of User Status updates in their **Status Updates page**.

**Disabling status updates**

The functionality is provided by a plugin called 'User Status'. To remove the status updates functionality from your site, you can disable the plugin. See [Disabling or Enabling a Plugin](#).

You can also control which users can and cannot use status updates with the global permissions. By default, users will not have permission to use this feature. See [Global Permissions Overview](#).

**Using Mentions**

You can mention a person in a special way that prompts Confluence to send that person an email notification. This is called an @mention. It works on Confluence pages, blog posts and comments.

When you save the page, Confluence sends an email message to the user letting them know that they have been mentioned on that page (if they have permission to view the page) with a link to the relevant page.

**Note**: Use the person's full name. The user mention feature recognises the full name only, not the username.

There are two ways to mention someone:

- The quickest way is to start typing '@' and the person's name, then choose from the suggestions that Confluence offers. This is called autocomplete.
- Alternatively, you can choose **Insert > User Mention** from the editor toolbar.

Each of these methods is described in more detail below.

**Using autocomplete to mention someone**

To mention someone using '@':

1. Edit the page.
2. Click where you want to insert a mention and type '@' and then the first few characters of the user's full name.
3. Choose the user's name from the list of suggestions.

**Screenshot: Autocomplete for mentions**
On this page:

- Using autocomplete to mention someone
- Accessing the user mention option in the editor toolbar
- Notes

Related pages:

- Using the Editor
- Using Autocomplete
- Keyboard Shortcuts
- Confluence User's Guide

Accessing the user mention option in the editor toolbar

To add a user mention via the editor toolbar:

1. Edit the page.
2. Choose Insert > User Mention. Confluence will add an '@' sign to the page, and display a dropdown list of suggested users for you to choose from.
3. Start typing the person's name, to refine the list of suggestions.
4. Choose the person from the list of names.

Screenshot: The user mention option in the editor toolbar
Notes

- **Seeing your mentions in the Confluence workbox.** The Confluence workbox displays all notifications collected from page watches, shares and mentions. See [Managing Notifications in Confluence](#).
- **Disabling the user mention feature.** The functionality is provided by a plugin called the 'Confluence Mentions Plugin'. To remove the user mention functionality from your site, you can disable the plugin. See [Disabling or Enabling a Plugin](#).
- **Mentioning groups.** It is not possible to mention a group and then have the email sent to the entire group. You can only mention individual users. There is a feature request to allow mentions for groups: [CONF-23015 - Authenticate](#) to see issue details

### Emailing a Page

You can share a Confluence page or blog post by emailing a link to recipients of your choice. The recipients can be Confluence users or any email addresses.

#### To email a link to a Confluence page or blog post using the Share button:

1. Go to the page or blog post you wish to share.
2. Click [Share](#) at the top right of the page.
   - Note: The [Share](#) button will not be visible if your Confluence administrator has not configured an outgoing mail server for your Confluence site. See [Configuring a Server for Outgoing Mail](#).
3. Enter the name or username of a Confluence user or any email address. As you start typing a name or username, or when you have typed a valid email address, an autocomplete dropdown will appear.
4. Select the appropriate user or email address from the dropdown. You can add multiple recipients to the list.
5. Enter an optional message into the [Note](#) box.
6. Click [Share](#) to send the link via email.

**Related pages:**

- [Working with Pages](#)
- [Working with Blog Posts](#)
- [Confluence User's Guide](#)
To remove a recipient from the list, click the bin icon to the right of the recipient.

Exporting Confluence Pages and Spaces to Other Formats

You can convert a part of, or the entire contents of a space to various formats, including Microsoft Word, HTML, PDF and XML. This is called 'exporting' the space.

What would you like to do?

- Exporting Confluence Pages and Spaces to HTML
- Exporting Confluence Pages and Spaces to PDF
- Exporting to a Word document
- Exporting Confluence Pages and Spaces to XML

Related topics

- Working with Spaces
- Confluence User's Guide

Exporting Confluence Pages and Spaces to HTML

Confluence allows you to export part of, or the entire contents of, a space into a zipped archive of HTML files. This is useful if you want convert your space into a static website.

To use the space export functionality, you need 'Export Space' permission. See the guide to space permissions or contact a space administrator for more information.

To export pages to HTML:

1. Go to a page in the space and choose Browse > Advanced.
2. Click HTML Export in the left-hand panel. This option will only be visible if you have 'Export Space' permission.
3. Select the Include Comments check box if you want to include comments for the pages you are exporting.
4. Select the pages you want to export by selecting the check boxes in the tree view of pages displayed. By default, all pages are selected. You have the option to **Select All** or **Deselect All** pages. If you select the check box of a page that contains one or more child or descendant pages, all of these child and descendant pages will also be selected. Similarly, if you clear the check box of such a page, all of its child and descendant pages will also be cleared. This provides a convenient method of exporting subtrees, for example, chapters or sections within a document.

5. Click **Export**. This will create a zipped archive of HTML files.

6. When the export process has finished, download the zipped archive as prompted and extract the files into a folder.

![Screenshot: Selecting pages to export](image)

**Notes**

- Page attachments are placed in individual folders with names in the following format: `...\download\attachments\xxxxxx` where `xxxxxx` is the page ID of the page containing the attachments.

- By default, the 'Space Details' page is exported as `index.html` and displays the space's details as well as a list of all available pages within it.

- Blog posts are not included in the HTML export. See the feature request: [CONF-14684](#).

**Related Topics**

- [Exporting Confluence Pages and Spaces to PDF](#)
- [Exporting Confluence Pages and Spaces to XML](#)

**Exporting Confluence Pages and Spaces to PDF**

This page explains how you can export individual Confluence pages, entire spaces or selections of pages into a single PDF file.
Exporting Single Pages

You can export a Confluence page to PDF. This option exports a single page and is available to all users who have permission to view the page:

- Go to a page in the space and choose Tools > Export to PDF. Follow the prompts to export the page.

Note that the export of a single page to PDF applies any PDF stylesheet customisations, but does not apply any PDF layout customisations. To make your PDF layout customisations apply to a single page exported to PDF, use the ‘multiple page’ method described below to export that single page only. See Customising Exports to PDF.

Comments on the page are not exported to the PDF file.

Exporting Multiple Pages or the Entire Space

Using Confluence's space export functionality, you can convert multiple pages or an entire space to PDF.

To use the space export functionality, you need 'Export Space' permission. See the guide to space permissions or contact a space administrator for more information.

To export a space or selected pages to PDF:

1. Go to a page in the space and choose Browse > Advanced.
2. Click PDF Export in the left-hand panel. This option will only be visible if you have the 'Export Space' permission.
3. Select the pages you want to export.
   - You have the option to Select All or Deselect All pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
4. Click Export.
5. When the export process has finished, download and save the PDF file as prompted.
Customising the Appearance of PDF Exports

You can add a title page, a table of contents and customised headers and footers to the PDF output. For more advanced customisations, you can apply Cascading Style Sheet (CSS) modifications. These customisations are specific to each space. You need the ‘Space Administrator’ permission to be able to apply these customisations. For more information, see Customising Exports to PDF.

Notes

- Only image attachments that have been inserted into a page are included when exporting to PDF.
- To export a PDF containing international text, you need to install a Unicode font in Confluence.
- Blog posts are not included within the PDF export. If you like, you can vote for this feature request: CONF-5599.
- If you have ‘Space Administrator’ permissions, the link to customise the PDF Stylesheet is provided at the top of the page tree, as shown in the screenshot above.
- Confluence's PDF Export feature is designed to handle a wide variety of content. However, on rare occasions the PDF Export process may fail due to an unrecognised customisation. If that happens the PDF export screen will indicate the title of the page in which the problem occurred, to help you diagnose the cause of the failure.

Related Topics

Customising Exports to PDF
Advanced PDF Stylesheet Customisations
Creating PDF in Another Language
Exporting Confluence Pages and Spaces to HTML
Exporting Confluence Pages and Spaces to XML

Take me back to the Confluence User's Guide.

Customising Exports to PDF
Confluence administrators and space administrators can customise the PDF exports for individual spaces.
Please take note of the following points:

- PDF customisations are unique to each space.
- Confluence's PDF customisations use a combination of HTML and CSS (Cascading Style Sheets).
- To achieve a particular requirement in the exported PDF file, you make changes in one or both of the following:
  - The PDF Layout, where HTML is used to define the structure of the exported content, including features such as the title page, headers and footers.
  - The PDF Stylesheet, where CSS is used to define the style of elements in the exported content, such as page size and margins, font, colour, and list numbering.

For further customisations, see the Advanced PDF Export Customisations page.

---

**Customising the PDF Layout**

You can add your own HTML to customise the title page, page headers and page footers in the PDF output.

**To customise the PDF Layout:**

**Setting a global PDF layout**
- Open the Confluence Admin screen.
- Select Look and Feel > PDF Layout. The following screens allows you to enter HTML and CSS that will be rendered on the PDF title page, as well as page headers and footers.

**Setting the PDF layout at space level**
- Choose Browse > Space Admin.  
  *Note: 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confucle-administrators group).
- Click PDF Layout in the 'Look and Feel' section of the left-hand panel.
- Click Edit, and customise the HTML that generates the following areas in the exported PDF document:
  - PDF Space Export Title Page – title page.
  - PDF Space Export Header – page headers.
  - PDF Space Export Footer – page footers.
- Enter your customisations into each text box as required. The PDF layout section accepts HTML code.
You can include inline CSS in the HTML too. Save your work.

**Customising the PDF Stylesheet**

You can adjust the appearance of the PDF pages by making CSS customisations in the PDF Stylesheet screen as required.

- To get started, you can download the default CSS rules of the PDF stylesheet: `confluencedefaultpdf.css`. Any rule defined in this file can be customised and added to the 'PDF Export Stylesheet' section.
- Your customisations override any default CSS rule.
- If no PDF customisations are defined in the PDF Stylesheet screen, the default CSS rules will be applied to your PDF exports. By default, the export does not include a title page, headers or footers.

**To customise the PDF Stylesheet:**

**Setting a global PDF Stylesheet**

1. Open the Confluence Admin screen.
2. Click **Look and Feel > PDF Stylesheet**. The following screen allows you to enter and save CSS code that will render content on each page.

**Setting a space-level PDF stylesheet**

1. Choose **Browse > Space Admin**. 
   
   *Note:* ‘Space Admin’ is displayed only if you are a space administrator for that space, or you are a super user (a member of the `confluence-administrators` group).
2. Click **PDF Stylesheet** in the left-hand panel. The 'PDF Export Stylesheet' section appears, showing the current contents of your PDF stylesheet. It contains all CSS rule customisations applied to the pages in the space.
3. Click **Edit** and enter your customisations into the text box as required. The PDF stylesheet section accepts Cascading Style Sheets (CSS) rules. Save your work.

**Example Customisations**

This section provides examples of typical customisations that you can add. See also [Advanced PDF Customisations](#).

**Page Size**

The default page size is based on the locale of your Confluence server. For example, if this server is located in the US then the default paper size of your PDF export will be US Letter (8.5 inches wide by 11 inches long). If the server is located in Australia, the default paper size will be A4 (210 mm wide by 297 mm long). More information about paper sizes can be found on [Wikipedia](https://en.wikipedia.org/wiki/Paper_size).

To modify the page size to A4, edit the PDF Stylesheet to add a `size` property to the `@page` rule, like this:

```css
CSS - PDF Stylesheet

@page
{
    /*The A4 paper size is 210 mm wide by 297 mm long*/
    size: 210mm 297mm;
}
```

**Page Orientation: Landscape or Portrait**

To change the page orientation of your PDF document, simply reverse the order of the values declared in the `@page` rule's `size` property. The first and second values of this property represent the width and height of the...
page, respectively.

For example, to generate PDF space exports in A4-sized landscape orientation, your \texttt{@page} rule might look like this:

```css
CSS - PDF Stylesheet

```@page
{
/*A4-sized pages in landscape orientation are 297 mm wide by 210 mm long*/
size: 297mm 210mm;
}
```

**Page Margins**

To set all margins to 15 mm, with a paper size of A4, edit the \texttt{CSS \textit{@page} rule in the PDF Stylesheet, like this:

```css
CSS - PDF Stylesheet

```@page
{
size: 210mm 297mm;
margin: 15mm;
}
```

To set the margins independently, edit the \texttt{@page} rule as follows:

```css
CSS - PDF Stylesheet

```@page
{
margin-top: 2.54cm;
margin-bottom: 2.54cm;
margin-left: 1.27cm;
margin-right: 1.27cm;
}
```

To set margins to provide a gutter for binding a printed document, use the \texttt{:left} and \texttt{:right} pseudo-classes, as follows:
CSS - PDF Stylesheet

```css
@page :left
{
    margin-left: 4cm;
    margin-right: 3cm;
}
@page :right
{
    margin-left: 3cm;
    margin-right: 4cm;
}
@page :first
{
    margin-top: 10cm /* Top margin on first page 10cm */
}
```

Note the use of the :first pseudo-class in the example above to define distinct margins for a cover or title page.

Page Breaks

By default, Confluence pages are exported without page breaks, so that shorter pages will appear on the same PDF page.

To make each Confluence page appear on a separate page in the PDF file, add the following rule in the PDF Stylesheet:

CSS - PDF Stylesheet

```css
.pagetitle
{
    page-break-before: always;
}
```

Title Page

You can add a title page to your PDF document by adding HTML to the Title Page section of the PDF Layout screen. The following example creates the title page and adds a title:

HTML - PDF Layout: Title Page Section

```html
<div class="fsTitlePage">
    <img src="/download/attachments/590719/titlepage.png" />
    <div class="fsTitle">Planning for Confluence 4.0</div>
</div>
```

Use CSS rules in the PDF Stylesheet to control the appearance of the title page and the title text:
Adding an Image to the Title Page

In the example above, the title page includes an image called 'titlepage.png', centred in the middle of the page. The "590719" in the src attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your title page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page, then right-click the image and copy its location.
3. Paste the link into the appropriate src="" attribute in your PDF Stylesheet, as shown above.
4. Edit the image URL so that it is relative, by removing the first part of the URL before /download/.

Table of Contents

By default, a table of contents will be generated after the title page, or at the beginning of the PDF document if no title page is defined in the PDF Layout. To see the default CSS rules applied to the table of contents, download the default CSS rules (confluencedefaultpdf.css) and examine the specific rules with toc in their name.

To make changes to the appearance of the table of contents, define CSS rules in the PDF Stylesheet.

Disabling the Table of Contents

To prevent the table of contents from being generated in your PDF document, add the div.toc rule to the PDF Stylesheet and set its display property to none:

Changing the Leader Character in the Table of Contents

The leader character is used to link a heading in the table of contents with its page number. By default, the leader character is the '.' (dot) character. Leader values of dotted, solid and space are allowed. You can
also use a string, for example `leader(".

To change the leader character to a solid line, modify the `leader()` value on the `content` property of the CSS rule as follows:

```css
span.toclead:before
{
  content: leader(solid);
}
```

### Headers and Footers

You can add headers and footers to your PDF pages using the ‘Header’ and ‘Footer’ sections of the PDF Layout screen. By default, headers and footers only apply to a space export and not to exports of single pages (however, see Advanced PDF Export Customisations). The following example adds a simple copyright notice.

#### HTML - PDF Layout: Footer Section

```
Copyright © 2011, Atlassian Pty Ltd.
```

### Page Numbering

To add page numbering, you need to combine customised HTML in the PDF Layout with customised CSS in the PDF Stylesheet.

1. **PDF Layout HTML**: In the Footer section (or the Header section), use an empty span element with a unique ID, for example `pageNum`, to act as a place holder for the page number.

   ```html
   <span id="pageNum"/>
   ```

2. **PDF Stylesheet CSS**: Create the following CSS selector rule for the empty span:

   ```css
   #pageNum:before
   {
     content: counter(page);
   }
   ```

   Analysing the above CSS selector rule in more detail:
   
   - The `#pageNum` rule selects the HTML element with the specified ID of "pageNum", which is the `span` element we created for the header or footer.
   - The `:before` part of the selector is a pseudo class that allows the insertion of content before the `span` element.
emement is processed.

- The `counter(page)` is a function that returns the current page number as its content.
- The `content` property tells the CSS processor that dynamic content (that is, an incrementing page number) is to be inserted at the span tag.

Wrapping Long Words

In order to break long words or words that are not separated by whitespace, add a selector to the PDF stylesheet containing the `word-wrap` property with a value of `break-word`:

```css
CSS - PDF Stylesheet

div
{
  word-wrap: break-word;
}
```

General Formatting

You can use the stylesheet to customise the output of just about anything else that will influence the look and feel of the final document. This includes fonts, tables, line spacing, macros, etc. The export engine works directly from the HTML output produced by Confluence. Therefore, the first step in customising something is to find a selector for the HTML element produced by Confluence or the Confluence macro. Then add a CSS rule to the PDF stylesheet. Your customisation will appear in the PDF export.

Notes

- **Demotion of heading elements:** `h1`, `h2`, and so on. Due to the hierarchical manner in which a space is exported, Confluence will modify the heading elements to generate a uniform appearance for the entire space export. This means that headings will be demoted. This will affect the application of custom PDF Stylesheets. It is possible to calculate the amount by which a heading will be demoted in order to have the correct CSS styling applied. A heading will be demoted by the value of its depth in the export tree. A page at the first level will be demoted by 1 (all `<h1>` elements will become `<h2>` elements, and so on). A page at the second level will be demoted by 2, and so on.

- **Atlassian support for PDF customisation is limited.** We support the mechanism for customising the PDF layout with HTML and CSS, and we will help if the mechanism is broken or does not work as we say it should in our published examples. But, since custom HTML and CSS offer potentially limitless possibilities, Atlassian will not support issues that are caused by or related to PDF customisations.

Related Topics

**Advanced PDF Export Customisations**

This page provides information about 'advanced' PDF export customisations. These expand upon the regular customisations described in [Customising Exports to PDF](#).

⚠️ The information below is for advanced users. Customisations are not supported by Atlassian. Be aware that the advanced customisations described below require knowledge of certain parts of Confluence, and of CSS and HTML. This documentation is intended for advanced users. Some of the suggestions below are moderately complex, or irregular in nature. If you are having trouble understanding them we strongly suggest you ask an expert. We do not support any of the customisations described below. This means that the Atlassian support engineers will not be able to help you with these modifications.
Adding Headers and Footers to Single Page Exports

By default, custom headers and footers set up in the PDF Layout screen (see Customising Exports to PDF), only apply to space exports and not to exports of single pages. However, it is possible to add CSS rules to your PDF Stylesheet that produce headers and footers in single page exports as well as space exports.

For custom headers, define `@top-left`, `@top-center` and `@top-right` rules within your `@page` rule. These rules apply respectively to content that appears on the left-hand side, centre and right-hand side of your page's header area.

For custom footers, define `@bottom-left`, `@bottom-center` and `@bottom-right` rules within your `@page` rule.

For example, the following rules add a document title at the centre of the header and a page number at the centre of the footer:

```
@page
{
    @top-center
    {
        content: "Document Title Goes Here";
        font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
        font-size: 8pt;
    }
    @bottom-center
    {
        content: "Page " counter(page);
        font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
        font-size: 8pt;
    }
    /* Any other page-specific rules */
}
```

Notes:

- The `font-family` and `font-size` properties ensure that the header and footer text is rendered in the same default font style used for the body text, based on the default CSS rules.
- It is not possible to use this method to insert images (stored as attachments within your Confluence instance) into the headers and footers of single page exports.
Adding Images to Headers and Footers

To insert an image into the header or footer, add HTML to the Header or Footer section of the PDF Layout screen.

The following example uses an HTML `img` element with `src` attribute to add an image to the left of the header. The `src` attribute refers to an image attached to a Confluence page. The image element is usually placed within a `div` element container.

### HTML - PDF Layout: Header Section

```html
<div style="margin-top:10mm">
  <img src="/download/attachments/12346/header-image.png"/>
</div>
```

In the example above, the header includes an image called 'header-image.png'. The "12346" in the `src` attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page, then right-click the image and copy its location.
3. Paste the link into the appropriate `src` attribute in your PDF Stylesheet, as shown above.
4. Edit the image URL so that it is relative, by removing the first part of the URL before `download/`.

Notes:

- This example uses an inline CSS property `margin-top` in the `style` attribute to force the image away from the top of the page by 10mm. This comes in handy when your header image is large enough to touch or spill over the top of the page.
- Likewise, for footers, you can use the `margin-bottom:XXmm` property to force an image away from the bottom of the page by 'XX' mm.
- Very large images can spill over into the body of a page or alter the position of text or other elements used within a header or footer. In such situations, it is recommended that you reduce the size of the image and then attach it to your Confluence page again. If you prefer to keep the image size and want to move the content lower instead, you can do so by configuring the `margin-top` properties in the `@page` CSS rule.
- By default, a header or footer image is aligned to the left-hand side of the page. However, you can align this image to the centre or right-hand side of a page by adding either the `text-align:center` or `text-align:right` properties to your `style` attribute. For example, to align the header image to the right-hand side of the page, your `style` attribute would look similar to this: `style="margin-top:10mm; text-align:right"`.

Incorporating Other Fonts

By default, Confluence provides Times New Roman, Helvetica or Courier fonts for use in PDF exports. You can use your own fonts for PDF exports by declaring them in a `@font-face` CSS rule in your PDF Stylesheet.

The following CSS rule example shows how to declare the Consolas font and apply it to some elements for your PDF export:
The font path specified in the CSS must be the path to the font on the Confluence server.

Adding a Dynamic Title to the Title Page

When you export an arbitrary set of pages from Confluence, you may like to have a corresponding title added to the cover (or title) page automatically. This can be done (in a somewhat irregular way) by using the top level item from the default table of contents as the title. This method relies on having the exported pages structured as sub-pages of the top-level page. In other words, the pages to be exported should consist of a page (at the top-level) and all of its child pages. The result is that the title that appears on the cover page changes depending on the top-level page that is used for the export.

The CSS below moves, and styles, the top-level TOC item for use as the title on the cover page, and turns off the leader and page number normally associated with this item in the TOC.
CSS - PDF Stylesheet

```
.fsTitlePage
{
    position:relative;
    left:0px;
}

/* Turn off the default section numbering for this TOC item */
.toclvl0:before
{
    content: " ";
    counter-reset: chapter 0;
}

/* Hide the default page numbering for this TOC item */
.toclvl0 .tocnum
{
    display: none;
}

/* Move and style this TOC item */
.toclvl0
{
    position:absolute;
    top:250px;
    font-size: 42px;
    font-weight: bold;
    margin: 72px 0 4px 0;
    text-align:center;
}
```

Hiding Text from the PDF Output

This section describes a way to hide text from your PDF export. In other words, you can have text on the Confluence page that will not appear in the PDF export.

There are three steps:

1. Follow the instructions to define the NoPrint user macro.
2. Use the NoPrint macro to mark some text on a Confluence page.
3. Add the following CSS to your PDF stylesheet to make the PDF export recognise the NoPrint macro:

CSS - PDF Stylesheet

```
.noprint
{
    display: none;
}
```

Indexing

To obtain an index at the end of the exported PDF file, consider using the Scroll Wiki PDF Exporter plugin that is produced by K15t Software GmbH.
Notes
If styling is not working as expected, it is useful to look at the intermediary HTML source to which the CSS is applied. This intermediary HTML is created whenever you create an HTML export that contains multiple pages, and is stored in the temp directory in Confluence's home directory. For example:

```
<confluence-home>/temp/htmlexport-20110308-154047-1/export-intermediate-154047-2.html
```

Related Topics

Customising Exports to PDF

Creating PDF in Another Language

To export a Confluence page written in a language other than English, you need to install the necessary font for that language. This means that you need to upload the font file to Confluence, as described below.

**Uploading a Font File to Confluence**

1. Find the appropriate font file:
   - **Windows users**: All font files in Windows are stored in a directory called:
     
     ```
     C:WINDOWS\Fonts
     ```
   - **Unix users**: All font files in Unix are stored in:
     
     ```
     /usr/share/fonts
     ```
   - Microsoft True Type core fonts such as Verdana can be downloaded from this page: [http://corefonts.sourceforge.net/](http://corefonts.sourceforge.net/)

2. Copy the font file into a temporary folder, for example a folder on your desktop.
3. Go to the 'PDF Export Language Support' screen in the Confluence Administration Console and upload the file you copied in step 2.
4. Click **Install**.

**Notes**

- The only font files supported are **true type fonts** and **true type collections**. The accepted file extensions are `.ttf` and `.ttc`.
- We recommend that you use Unicode font Verdana for correct character encoding and exporting to PDF.
- If the font file size is bigger than your current attachment size limit, you won't be able to upload it. Please increase the attachment size limit temporarily and re-upload again. An improvement of the error messaging is tracked at [CONF-24706 - Authenticate](http://jira.atlassian.com/browse/CONF-24706) to see issue details.

Related Topics

Exporting Confluence Pages and Spaces to PDF

Exporting to a Word document

Confluence allows you to export a single page into a Word document. This is useful for emailing content to people who do not have access to Confluence.
Exporting a page to Word

You will require ‘Export Pages’ permission to export a page to a Word document. By default, this will create a Word document with the same name as the Confluence page.

To export a page to a Word document:

Go to the page and choose Tools > Export to Word.

Useful plugins

Before installing a plugin into your Confluence site, please check the plugin’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

This plugin provides extended functionality for exporting Confluence pages to Microsoft Word: Scroll Office.

Exporting Confluence Pages and Spaces to XML

Confluence allows you to export a part of, or the entire contents of, a space into a zipped archive of XML files.

This is useful if you want to make a backup of the space, export the space to another Confluence instance, or use the data from the space in another application. Please note that there are a few restrictions when Restoring a Space, and that huge spaces exported for backup-purposes may benefit from other means of backup. See Production Backup Strategy.

To export to XML, you will need ‘Export Space’ permission which is assigned by a space administrator. See Space Permissions or contact a space administrator for more information.

Site administrators can import a space from a zipped XML archive.

To export to XML:

1. Go to a page in the space and choose Browse > Advanced.

2. Click XML Export in the left-hand panel.

   This option will only be visible if you have ‘Export Space’ permission.

3. Select Include Comments if you want to include comments made on the pages you are exporting.

4. Select Backup Attachments if you want include the images and other files attached to the pages.

5. Select the pages you want to export. Select the relevant check boxes in the tree view of pages displayed.

   By default, all the pages are selected. If you select a page that has one or more child or descendant pages, all of these child and descendant pages will also be selected. Similarly, if you clear the check box of such a page, all of its child and descendant pages will also be cleared. This provides a convenient method of exporting subtrees, for example, chapters or sections within a document.

6. Click Export. This will create a zipped archive of XML files. When the export has finished, Confluence will offer you the option to download the zip file.

Screenshot: Exporting a space with administrator permissions
Notes

- If you are running Confluence behind Apache HTTP Server and are facing timeout errors, please consider creating the export directly from Tomcat, instead of going through Apache. This will speed up the process and prevent timeouts.
- If you have Space Administrator or Confluence Administrator permissions, you can export either All pages or those pages Visible to you. All exports all content in the space, including pages that are protected by page-level restrictions which will prevent you from viewing the pages themselves. This option is available only to space administrators and Confluence administrators. It allows you to make a complete and comprehensive export of a space for backup purposes. Visible to you exports only content you can see. This is the default option.

Related Topics

- Restoring a Space
- Exporting Confluence Pages and Spaces to PDF
- Exporting Confluence Pages and Spaces to XML
- Working with Spaces
- Confluence User's Guide

Commenting on pages and blog posts

A comment is a remark, question, or any other additional information you wish to add to a page or blog post. Comments are a means by which a people can interact with each other on the site.

You can add a comment to any page or blog post, provided that you have the 'Add Comments' permission in the space. You can also show that you agree with or enjoyed someone else's comment, by liking it.

Comments are displayed at the bottom of the page, below the page content. Comments in Confluence are displayed in one of two views, configured globally by a site administrator:

- **Threaded** – This view shows the comments in a hierarchy of responses. Each subsequent reply to a comment is indented to indicate the relationships between the comments.
- **Flat** – This view displays all the comments in a single list and does not indicate the relationships between comments.
Adding a comment

You can add a new comment, on pages and blog posts in Confluence. If the Confluence site displays comments are in threaded view, you can respond to previous comments too.

To add a comment, you need the 'Add Comments' permission which is assigned by a space administrator. See Space permissions or contact a space administrator for more information.

To add a new comment:

1. Choose Add > Comment from the top of the page, or click in the box next to your profile picture below the last comment.
2. Type in your comment.
3. Click Preview to see how your comment will appear.
4. By default, Watch this page is ticked. This means that you will start receiving notifications about this page. Remove the tick if you do not want to watch the page.
5. Click Save.

To respond to a comment:

1. Click Reply located below the text of a comment.
2. Type in your response.
3. Click Save.

Editing a comment

To add a comment, you need the 'Add Comments' permission which is assigned by a space administrator. See Space permissions or contact a space administrator for more information. Space administrators can edit all comments within their space. The date on a comment always indicates the time the comment was last edited.

To edit a comment:

1. Go to the comment and click Edit.
2. Make changes to the comment just as if you were adding a comment.
3. Click Save when you are finished.

Deleting a comment

To delete a comment from a page, you need the 'Remove Comments' permission which is assigned by a space administrator. See Space permissions or contact a space administrator for more information.

- It is not possible to delete all comments for a page simultaneously.
• **Note:** Deleted comments cannot be restored.

**To delete a comment:**

1. Go to the page that contains the comment.
2. Click **Remove** at the bottom of the comments box. This is only displayed if you have permission to remove comments for this page.

**Notes**

- You can choose **Tools > Watch** to receive an email notification whenever anyone edits the page or adds a comment to the page.
- Your **profile picture** will appear next to each comment that you have added. (This is true if your space uses the Confluence Default theme.)
- On blog posts only, an ‘Author’ lozenge will appear on any comments made by the original author of the post. **AUTHOR**
- Comments are not auto-saved. See feature request: [CONF-12978 - Authenticate](https://jira.atlassian.com/browse/CONF-12978) to see issue details

**Linking to Comments**

You can add a link to a comment by making use of the PermaLink associated with each comment.

### On this page:

- To link to a comment from within Confluence
- To link to a comment from outside Confluence
- Related Topics

**To link to a comment from within Confluence**

1. Right-click on the Permalink icon located at the lower right of the comments box.
2. Select **Copy Link Location** from the pop-up menu.
3. Edit the page from which you want to link to the comment.
4. Click **Link** in the toolbar, and select the **Web Link** tab.
5. Paste the PermaLink into the address field.
6. Provide link text if required.

**To link to a comment from outside Confluence**

1. Right-click on the Permalink icon located at the lower right of the comments box.
2. Select **Copy Link Location** from the pop-up menu.
3. Use this URL to link to the comment from your web page.

Alternately, click on the Permalink icon and copy the URL displayed in the address bar of your browser.

ℹ️ The older method of linking to comments (used in Confluence 3.5.x and older) using just the commentid has been removed. If you would like to see it reinstated, please visit this JIRA issue.

**Related Topics**

- [Commenting on pages and blog posts](https://confluence.atlassian.com/server-collabdoc-commenting-on-pages-and-blog-posts-1603237565.html)
- [Working with Links](https://confluence.atlassian.com/server-collabdoc-working-with-links-2987814957.html)

Take me back to [Confluence User's Guide](https://confluence.atlassian.com/server-collabdoc-confluence-users-guide-2059683803.html)
Sample Page

Start of sample page content


End of sample page content

Printing Confluence Pages

You can print one or more Confluence pages:

- To print a single page, use your browser's 'Print' option.
- Confluence allows you to export a single page, a part of a space, or an entire space into a single PDF file. See Exporting Confluence Pages and Spaces to PDF.

Managing Changes and Notifications and Tasks

Confluence provides several ways in which you can watch for changes to single pages, entire spaces, and all spaces on the site. You can also follow the updates made by specific people. You can only track updates to content that you have permission to see.

Personal tasks appear in the task-and-notification dialog, and you can assign team tasks via a task list on a page.

Making yourself a watcher of pages or spaces

You can 'watch' a page, blog post or space that you have permission to view. Confluence will then send you an email notification whenever someone adds or updates content on, or adds a comment to, that page or space. See:

- Watching a Page or Blog Post
- Watching a Space

If you have space administrator permissions, you can manage watchers of pages and spaces.

Requesting other notifications

You can configure Confluence to send you various digest reports via email. See Subscribing to Email Notifications of Updates to Confluence Content.
Tracking updates by specific people

You can also follow the activity of people who interest you (see Network Overview) and receive a notification when someone follows you (see Subscribing to Email Notifications of Updates to Confluence Content).

Managing your notifications and tasks

There are a few ways to manage notifications and tasks in Confluence:

- You can manage your email notification settings via the options in your user profile. See Subscribing to Email Notifications of Updates to Confluence Content.
- The Confluence workbox displays all notifications collected from Confluence page watches, shares and mentions. See Managing Notifications in Confluence.
- You can manage your personal tasks in the Confluence workbox, and also create a list of tasks on a page. See Managing Tasks in Confluence.

Using Confluence RSS feeds

You can build RSS feeds to monitor content changes in Confluence.

- Create a customised RSS feed using the RSS Feed Builder.
- Subscribe to one of the pre-specified feeds generated by Confluence.

Watching a Page or Blog Post

You can ‘watch’ a Confluence page, blog post or space. Confluence will then send you a notification by email whenever anyone updates the watched content.

You will receive email notifications for:

- Edits (unless the user clears the Notify watchers check box).
- Deletions.
- Attachments, including new versions or deletions of an existing attachment.
- Comments, including new comments, edits of existing comments or deletions of existing comments.

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called ‘autowatch’. You can control autowatch.

There is no daily digest for email notifications. You will receive an email notification every time someone makes a change.

You will not receive email notifications for content changes due to the output of a macro, because the page content itself has not been edited.
You need 'View' permission for the page, blog post or space to receive notifications.

<table>
<thead>
<tr>
<th>On this page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Watching a Page or Blog Post</td>
</tr>
<tr>
<td>• Setting Autowatch and Other Notification Options</td>
</tr>
<tr>
<td>• Watching an Entire Space</td>
</tr>
<tr>
<td>• Watching for New Blog Posts</td>
</tr>
<tr>
<td>• Managing Watches from your User Profile</td>
</tr>
<tr>
<td>• Managing Watches from the Email Message</td>
</tr>
<tr>
<td>• Related Topics</td>
</tr>
</tbody>
</table>

Watching a Page or Blog Post

To start watching a page or blog post:

1. Go to the page or blog post.
2. Choose Tools > Watch.

To stop watching a page or blog post:

1. Go to the page or blog post.
2. Choose Tools > Stop watching.

Setting Autowatch and Other Notification Options

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called 'autowatch'. You can turn autowatch on or off, and set other notification options, in the email settings section of your user profile. See Setting User Settings.

Watching an Entire Space

You can choose to watch all the pages and blog posts in a given space. See Watching a Space.

Watching for New Blog Posts

You can choose to watch for:

- New blog posts in a given space. See Watching a Space.
- All new blog posts in the Confluence site. See Subscribing to Email Notifications of Updates to Confluence Content.

Managing Watches from your User Profile

The 'Watches' page in your user profile displays a list of all pages and spaces you are currently watching.

To manage your watches:

1. Go to the 'Watches' view for your user profile, as follows:
   - Go to your name (the 'user' menu) at the top of the page and choose Watches.
2. Click the envelope icon next any unwanted watches to turn them off.

Managing Watches from the Email Message

The email notifications that you receive from Confluence have some useful links at the bottom of the email message. The links in each message vary, depending on the context. In general, the links allow you to view the
page online, reply to a comment, and so on. In particular with respect to setting your notification preferences, you will see one or more of the following links:

- **Stop watching page** – Click this link to stop watching the page that triggered the email notification.
- **Stop watching space** – Click this link to stop watching the space that triggered the email notification.
- **Stop following this user** – Click this link to stop following the user whose update triggered the email notification.
- **Manage Notifications** – Click this link to go to the email settings page in your user profile.

**Screenshot: Email notification footer showing links**

![Email notification footer showing links](image)

**Related Topics**

- **Watching a Space**
- **Subscribing to Email Notifications of Updates to Confluence Content**
- **Managing Changes and Notifications and Tasks**
- **Updating Email Address**

Take me back to [Confluence User's Guide](#)

**Watching a Space**

You can 'watch' a Confluence page, blog post or space. Confluence will then send you a notification by email whenever anyone updates the watched content.

You will receive email notifications for:

- Edits (unless the user clears the Notify watchers check box).
- Deletions.
- Attachments, including new versions or deletions of an existing attachment.
- Comments, including new comments, edits of existing comments or deletions of existing comments.

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called 'autowatch'. You can control autowatch.

There is no daily digest for email notifications. You will receive an email notification every time someone makes a change.

You will **not** receive email notifications for content changes due to the output of a macro, because the page content itself has not been edited.

ℹ️ You need 'View' permission for the page, blog post or space to receive notifications.
On this page:

- Watching an Entire Space
- Watching for New Blog Posts in a Space
- Watching all Spaces on the Site
- Managing Watches from your User Profile
- Managing Watches from the Email Message
- Related Topics

Watching an Entire Space

Watch a space if you want to receive notifications of updates to any content in the space.

To start watching a space:

1. Go to a page in the space and choose Browse > Advanced.
2. In the left-hand panel, click Start watching this space (or Start watching all content).

To stop watching a space:

1. Go to a page in the space and choose Browse > Advanced.
2. In the left-hand panel, click Stop watching this space.

Watching for New Blog Posts in a Space

You can choose to receive a notification whenever someone adds a blog post in the space. You will not receive notification of updates to or deletions of blog posts, nor of comments on the blog posts.

Hint: By default, the option is labelled Start watching space blogs. If you are already watching the entire space, the wording will change to Only watch space blogs. If you choose that option, you will no longer be watching the entire space.

To start watching for new blog posts in a space:

1. Go to a page in the space and choose Browse > Advanced.
2. In the left-hand panel, click Start watching space blogs (or Only watch space blogs).

To stop watching for new blog posts in a space:

1. Go to a page in the space and choose Browse > Advanced.
2. In the left-hand panel, click Stop watching space blogs.

Watching all Spaces on the Site

You can receive notifications about changes to the content of pages, blog posts and comments from across all spaces on a Confluence site.

To start watching for content changes across the whole site:

1. Go to your name (the 'User' menu) at the top of the page and choose Settings.
2. Click Email in the left-hand panel.
3. Click Edit and select Subscribe to daily updates.
4. Click Submit.

Managing Watches from your User Profile
The 'Watches' page in your user profile displays a list of all pages and spaces you are currently watching.

**To manage your watches:**

1. Go to the 'Watches' view for your user profile, as follows:
   - Go to your name (the 'user' menu) at the top of the page and choose **Watches**.
2. Click the envelope icon next any unwanted watches to turn them off.

**Managing Watches from the Email Message**

The email notifications that you receive from Confluence have some useful links at the bottom of the email message. The links in each message vary, depending on the context. In general, the links allow you to view the page online, reply to a comment, and so on. In particular with respect to setting your notification preferences, you will see one or more of the following links:

- **Stop watching page** – Click this link to stop watching the page that triggered the email notification.
- **Stop watching space** – Click this link to stop watching the space that triggered the email notification.
- **Stop following this user** – Click this link to stop following the user whose update triggered the email notification.
- **Manage Notifications** – Click this link to go to the email settings page in your user profile.

**Screenshot: Email notification footer showing links**

---

**Related Topics**

- Watching a Page or Blog Post
- Subscribing to Email Notifications of Updates to Confluence Content
- Managing Changes and Notifications and Tasks
- Updating Email Address

Take me back to **Confluence User's Guide**

**Managing Watchers**

If you are a **space administrator** for a space, you can manage the watchers for all pages and blog posts in that space. This means that you can:

- View a list of the watchers of a page/blog post.
- View a list of the watchers of the space for that page/blog post.
- Add users as watchers of the page/blog post.
- Remove existing watchers of the page/blog post.

**It is not possible to remove watchers of the space.**

**To manage your watchers for a page/blog post:**

1. Navigate to the page or blog post for which you want to manage the watchers. Note, you must be a space
administrator for the space that the page is in.

2. Choose **Tools > Manage Watchers**. The 'Manage Watchers' screen will be displayed (see screenshot below). The left-hand column of the 'Manage Watchers' screen will contain the users watching the page/blog post, the right-hand column will contain the users watching the space.
   - To remove an existing page watcher, click the icon (trash can) next to the user's name.
   - To add a user as a watcher of the page, type in the box and choose the user's name from the list.

3. Click **Done** to save your changes.

**Screenshot: Managing Watchers**

![Managing Watchers Screenshot](image)

Related Topics

- **Watching a Space**
- **Watching a Page or Blog Post**
- **Subscribing to Email Notifications of Updates to Confluence Content**
- **Managing Changes and Notifications and Tasks**
- **User Profile Overview**

Take me back to the [Confluence User's Guide](#).

**Subscribing to Email Notifications of Updates to Confluence Content**

You can 'watch' a page, blog post or space. Confluence will then send you a notification by email whenever anyone adds or updates content on that page or space. You can also subscribe to daily email reports and other notifications of various updates, as described below.

You will only receive notifications for content that you have permission to view. Users that have been **disabled** by an administrator will not receive email notifications.

**Subscribing to email notifications**

You can subscribe to the following email summary reports:

- A daily report of updates to all spaces that you have permission to view.
- An immediate report of all blog posts added or changed, in all spaces that you have permission to view.
- An immediate report of all updates made by the people you are following, in all spaces that you have permission to view.
- An immediate report when someone follows you.
- A daily or weekly report of recommended updates, in all spaces that you have permission to view.

**To edit your email notification settings:**

1. Go to your **name** (the 'User' menu) at the top of the page and choose **Settings**.
2. Click **Email** in the left-hand panel.
3. Click **Edit**.
Below is an explanation of all the email settings is explained below.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Content</th>
<th>Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Autowatch</strong></td>
<td><strong>Option:</strong> Do you want Confluence to automatically add you as a watcher on each page or blog post that you add or update? If you are a watcher of a page or a post, you will receive notification of future changes.</td>
<td>• Pages and blog posts that you create, edit or comment on.</td>
<td>(Not applicable)</td>
</tr>
</tbody>
</table>
| **Subscribe to daily updates** | Receive email reports showing changes to content in all spaces that you have permission to view.  
  Note: Daily email reports do not include information about attachments on a page or blog post that are added, edited or deleted. | • Pages and blog posts that are added, edited or deleted.  
  • Comments on a page or blog post that are added, edited or deleted.  
  • Updates by users who have changed their personal profile. | Daily            |
| **Subscribe to all blog posts** | Receive email notifications for changes to blogs in your Confluence installation that you have permission to view. | • Blog posts added, edited or deleted.                                    | Immediately      |
| **Subscribe to network** | Receive email notifications for changes to content by all users that you are following, which you have permission to view. | • Pages being added, edited or deleted.  
• Blog posts being added, edited or deleted.  
• Comments being added, edited or deleted.  
• Status updates by the user. | Immediately |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Subscribe to new follower notifications</strong></td>
<td>Receive an email message when anyone chooses to follow you.</td>
<td></td>
<td>Immediately</td>
</tr>
</tbody>
</table>
| **Notify on my actions** | **Option:** Do you want to receive email notifications for your own changes?  
Note: If you have not subscribed to any email notifications and are not watching any pages/spaces, then selecting 'Notify on my actions' will not do anything. | • All pages and spaces that you are watching.  
• This affects all subscriptions set. | (Not applicable) |
| **Show changed content** | **Option:** Do you want your notifications to include details of the changes made to the content?  
• If you do not select this option, your notifications will include the full content of the page.  
• If you do select this option, your notifications will include the full content of the page as well as a list of the differences between the current and previous versions of the page. See Page History and Page Comparison Views. | • Edits to pages and blog posts. | (Not applicable) |
<table>
<thead>
<tr>
<th>Subscribe to recommended updates</th>
<th>Receive an email message showing the top content that is relevant to you.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>How do you set the frequency of the mail message? A link in the email message allows you to choose daily or weekly notifications.</td>
</tr>
<tr>
<td></td>
<td>How do you enable and disable the notification? You can turn off the notification by clicking a link in the email message. You can also turn the notification on or off by setting the 'Subscribe to recommended updates' option in your user profile.</td>
</tr>
<tr>
<td></td>
<td>Confluence chooses the content to display, based on:</td>
</tr>
<tr>
<td></td>
<td>• Pages and blog posts that people have recently liked.</td>
</tr>
<tr>
<td></td>
<td>• Pages and blog posts that people have recently commented on.</td>
</tr>
<tr>
<td></td>
<td>• Pages and blog posts that have recently been created.</td>
</tr>
<tr>
<td></td>
<td>‘Recent’ means any activity that occurred since the last recommended updates message was sent to you.</td>
</tr>
<tr>
<td></td>
<td>The activities are listed in order of popularity, with the most popular at the top. Likes, comments and content creations are scored equally. Activity that involves people in your network ranks higher than activity not involving your network.</td>
</tr>
<tr>
<td></td>
<td>Content in your favourite spaces also ranks higher than content in other spaces. The recommended updates summary does not include any content that you created yourself, and it gives a lower ranking to content that you have participated in, for example by adding a comment or updating the page.</td>
</tr>
<tr>
<td></td>
<td>If there is no activity to report, Confluence will not send the email message.</td>
</tr>
<tr>
<td></td>
<td>Daily (weekdays at 1pm) or weekly</td>
</tr>
<tr>
<td>Notes for administrators</td>
<td>To enable Confluence to send email notifications, a System Administrator must configure an email server. See Configuring a Server for Outgoing Mail.</td>
</tr>
<tr>
<td>Notes for administrators</td>
<td>Confluence Administrators can set the default options for the recommended updates notification. Choose</td>
</tr>
</tbody>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Subscribing to RSS Feeds within Confluence

RSS feeds allow you to track updates to content within Confluence. You will need an RSS newsreader to subscribe to them.

On this page:

- Confluence RSS Feeds
- RSS Newsreaders
- Removing an RSS Feed
- Related Topics

Confluence RSS Feeds

You can create a customised RSS feed using the RSS Feed Builder or subscribe to one of the pre-specified feeds generated by Confluence.

What would you like to do?

- Create and subscribe to customised RSS feeds using the RSS Feed Builder — create a customised RSS feed (e.g. filter your feed using a label; specify the number of items and days to include in your feed; etc.)
- Subscribe to pre-specified RSS feeds — generate an RSS feed automatically in a minimal number of steps.
- Subscribe to a feed of any Confluence user's network to track the activities of users they are following in their network.

RSS Newsreaders

The following are some popular RSS newsreader programs for various operating systems. You can find a more comprehensive list on Google’s open directory.

Windows

- SharpReader
- NewsGator
- Syndirella
- FeedDemon
- NewzCrawler

Mac OS X

- Safari
- NetNewsWire
- NewsFire
- Shrook

Multi-Platform

- NewsMonster (Runs in the Mozilla web browser)
- Radio Userland (Windows and MacOS)
- AmphetaDesk (Windows, Unix, Mac OS X)

Removing an RSS Feed
There is no need to try to delete or remove an RSS feed built by the Confluence RSS feed builder.

Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL (address). For example, take a look at the following feed URL:

```
http://confluence.atlassian.com/createrssfeed.action?types=page&sort=modified&showContent=true...
```

The above feed URL will generate a list of pages ('types=page'), sorted by the modification date and showing the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no need to remove anything.

**Related Topics**

Managing Changes and Notifications and Tasks
Working with RSS Feeds
RSS Feed Macro

Take me back to the Confluence User's Guide.

**Using pre-specified RSS feeds**

If you want to customise your Confluence RSS feed (e.g. use a label to filter your feed), use the RSS Feed builder instead.

To subscribe to RSS feeds generated by Confluence, for a particular space:

1. Choose Browse > Advanced from the dropdown list. The 'Advanced' screen will appear.
2. Click on RSS Feeds in the left-hand column.
3. Copy and paste the link for one of the following feeds into your RSS newsreader:
   - Pages
   - News
   - Mail
   - Comments
   - Attachments
   - All content

To subscribe to RSS feeds generated by Confluence, for a particular page (where available):

1. Locate the following icon, which is available in the top-right corner of certain pages: 
2. Copy and paste the icon's link into your RSS newsreader.

**Using the RSS Feed Builder**

Using the RSS feed builder, you can create customised RSS feeds to subscribe to changes within Confluence.

Wondering what an RSS feed is? See more information about RSS Feeds.
Building an RSS Feed

Follow the steps below to build your feed, choosing the type of content and the time period you want to monitor.

To create a customised RSS feed:

1. Choose Browse > Feed Builder.
2. Select the content types you want in your feed. Check Mail if you want to know when the email archive is updated. (See the overview of mail archives in Confluence.)
3. Select one or more spaces from the list.
4. Click Advanced Options to set the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feed Name</td>
<td>The default name is based on the name of your Confluence installation, e.g. &quot;Extranet RSS Feed&quot;</td>
</tr>
<tr>
<td>With these labels</td>
<td>Enter one or more labels separated by spaces or commas. Confluence returns all content (of the selected types) that matches one or more of the labels. See the hint below about using labels to customise your feeds.</td>
</tr>
<tr>
<td>Exclude these spaces</td>
<td>Exclude specific spaces from those already selected.</td>
</tr>
<tr>
<td>Sorted by</td>
<td>Sort content by either the date or creation or the date they were last updated.</td>
</tr>
<tr>
<td>Limit to</td>
<td>Specify the number of items returned in your feed.</td>
</tr>
<tr>
<td>Within the last</td>
<td>Specify how old items returned can be.</td>
</tr>
<tr>
<td>Include content for pages</td>
<td>Specify whether the entire page is displayed in the feed.</td>
</tr>
</tbody>
</table>

5. Click Create RSS Feed to create your feed.
6. Drag or copy the link into your RSS reader.

Tip: Try building separate feeds, one for pages only and one that includes comments as well. This allows you to monitor only pages if you are short of time, and to read the comments when you have more time.

Hint: Using Labels to Customise your Feed

You can use the RSS feed builder to track updates to labelled pages and comments on those pages. Here is an idea for customising your RSS feed by using your own personal label(s). This is useful if you want to track updates to specific pages or blog posts, and you do not want to deal with emails. You can use this method as an
alternative to watching pages.

- Build an RSS feed that returns pages, blog posts and comments labelled with a personal label, such as 'my:feed'.
- Each time you want to ‘watch’ a page, just label it with 'my:feed'.
- All updates and comments will automatically come through your RSS feed.

Notes

- **Removing an RSS feed**: You need only delete the RSS feed link built by the Confluence RSS feed builder to remove an RSS feed from your page. This is because the feed is dynamically generated using the parameters in the feed URL.

- **Feed authentication options**: Confluence can offer you the option of an anonymous feed or a feed that requires authentication.
  - An **anonymous** feed will show only the content that is visible to anonymous users. The feed URL does not contain the &os_authType parameter mentioned below. This feed is useful only if your Confluence site allows anonymous access. If a feed is anonymous, you only get anonymously-viewable content in the feed regardless of whether you are a Confluence user or not.
  - An **authenticated** feed requires you to log in to Confluence before you can retrieve the content. The feed URL contains the following parameter: &os_authType=basic.
  - The option to choose between an anonymous and an authenticated feed is currently not available on the feed builder screen. The feed builder offers only **authenticated** feeds. See CONF-21601 for details and a workaround.

Related Topics

- RSS Feeds FAQ
- Managing Changes and Notifications and Tasks
- Working with RSS Feeds

Take me back to Confluence User's Guide

**Working with RSS Feeds**

An RSS feed is a format for delivering summaries of regularly changing web content. Subscribing to an RSS feed allows you to stay informed of the latest content from sites that you are interested in.

RSS isn't designed to be read in a regular web browser. Specialised RSS newsreader programs can check RSS files every so often, and tell you what's new on a site. Your reader may be on a website, an addon to your browser, part of your email program, or a stand-alone program.

Confluence works with RSS in two ways:

- Confluence generates its own RSS feeds for tracking updates to content within Confluence. You will need an RSS reader which can grab the RSS feeds from Confluence and display them for you.
- Confluence's RSS macro allows you to display the contents of RSS feeds on a Confluence page. The feeds may come from a Confluence feed generator or from external sites. In this way, Confluence can act as an RSS reader.

For a technical description of RSS, read Mark Pilgrim's "What is RSS?" article on XML.com.

**Related Topics**

- Subscribing to RSS Feeds within Confluence
- Displaying content from RSS feeds on a Confluence page
- Managing Changes and Notifications and Tasks

Take me back to Confluence User's Guide

**RSS Readers Compatibility**
Due to some users having problems with Confluence RSS Feeds, some research was done with several RSS Feed Readers. RSS Feeds have been created through the feed builder and tested on a Windows machine. For each feed reader they have been tested with both authentication and public access, checking for the visibility of content, icons and images. The results are in the tables below:

**Feeds with authentication**

<table>
<thead>
<tr>
<th>RSS Feed Reader</th>
<th>Content</th>
<th>Icons</th>
<th>Images</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>RssReader 1.0.880</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>• Shows the entire page (including the header panel &amp; view, edit tabs)</td>
</tr>
<tr>
<td>JetBrains Omea Reader 2.1.6</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>• Shows the changes between revisions in the nice red/green colours of Confluence</td>
</tr>
<tr>
<td>IE 7.0</td>
<td>❌</td>
<td>✔️</td>
<td>✔️</td>
<td>• Content is all there however not all html is rendered correctly (for example {font-style:italic;} is shown in the content as raw text)</td>
</tr>
<tr>
<td>Thunderbird 1.5.0.7</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>• Shows the entire page</td>
</tr>
<tr>
<td>Bloglines</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>• Simple online feed reader</td>
</tr>
<tr>
<td>Google Reader</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>• Simple online feed reader</td>
</tr>
</tbody>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Managing Notifications in Confluence

This page is about the notification-and-task dialog, known as the Confluence ‘workbox’, which drops down when you choose the icon \( \text{} \) in the Confluence page header.

Do you want to manage your notification email messages instead? See Subscribing to Email Notifications of Updates to Confluence Content.

Managing your notifications in the Confluence workbox

The workbox displays all notifications collected from Confluence page watches, shares and mentions. You can view your notifications and convert them to personal tasks. Use the inline actions to reply to comments, like a comment or page, or watch a page. Follow the links in a notification to open the relevant page or blog post.

The workbox displays your notifications and your personal tasks in separate tabs.

To manage your notifications:

1. Choose the notification-and-task icon \( \text{} \) in the Confluence page header.
   - You can use the keyboard shortcut: Type g then n. (When in the Confluence editor, click outside the editor pane before pressing the keyboard shortcut keys.)
   - The icon above shows that you have 3 unread notifications.

2. Choose the notifications icon: 

3. Choose a notification from the list, to see the notification details. Now you can do the following:
   - Choose a link or Open to open the related page, blog post, or comment. The page will open in a new tab in your browser.
   - Choose Like or Unlike to let people know that you like, or have stopped liking, a page, blog post, or comment.
   - Choose Watch or Stop Watching to receive notifications, or stop receiving notifications, about a page or blog post.
   - Choose Reply to respond to a comment inline, within the workbox.
   - Choose the ‘add task’ icon \( \text{} \) to flag a notification as a task. The notification will remain in the notification list too.
Which notifications are included?

The workbox displays a notification when someone does one of the following in Confluence:

- **Shares** a page or blog post with you.
- **Mentions** you in a page, blog post or comment.
- Comments on a page or blog post that you are **watching**.
- **Likes** a page or blog post that you are watching.

The workbox does **not** show notifications triggered because you are watching a space. Only watches on pages and blog posts are relevant here.

**Keyboard shortcuts**
<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>g then n</td>
<td>Open the Confluence workbox.</td>
</tr>
<tr>
<td>j</td>
<td>Move down to the next entry in the notification list.</td>
</tr>
<tr>
<td>k</td>
<td>Move up to the previous entry in the notification list.</td>
</tr>
<tr>
<td>n</td>
<td>Move down to the next notification for a particular page or blog post.</td>
</tr>
<tr>
<td>p</td>
<td>Move up to the previous notification for a particular page or blog post.</td>
</tr>
<tr>
<td>Enter</td>
<td>Open the selected notification.</td>
</tr>
<tr>
<td>u</td>
<td>Return to the notification list after opening a particular notification.</td>
</tr>
</tbody>
</table>

**Note:** The keyboard shortcuts are available for notifications only, not for tasks, inside the Confluence workbox.

**Managing notifications with Confluence mobile**

You can view and respond to your notifications on your phone or other mobile device too. See [Using Confluence on a Mobile Device](#) for more about mobile platforms.

**Notes**

- Read notifications are automatically deleted after 2 weeks.
- Unread notifications are automatically deleted after 4 weeks.
- You cannot delete your notifications yourself.

- The notification-and-task dialog is not available in clustered environments. The plugin will be installed and enabled, but it will detect that the site is in clustered mode and will not display the dialog.
- The notification-and-task dialog is provided by a set of plugins. To remove the personal notifications and tasks functionality from your site, you can disable the following plugins. See [Disabling or Enabling a Plugin](#) for instructions. Disabling these plugins will disable the entire notification-and-task dialog. It is not possible to disable only tasks or only notifications:
  - Notifications and Tasks - Common Plugin
  - Notifications and Tasks - Host Plugin
  - Notifications and Tasks - Confluence Provider Plugin
- If you want to re-enable the plugins, do so in the following order: Common Plugin, Host Plugin,
Managing Tasks in Confluence

You can manage your personal tasks in the notification-and-task dialog, known as the Confluence 'workbox', which drops down when you choose the icon in the Confluence page header.

You can also create a list of tasks on a page, and assign them to your colleagues via @mention. Changes made in the workbox are reflected in the task list on the page, and changes made on the page are reflected in the workbox too.

Creating personal tasks and having tasks assigned to you

There are a few ways that you and other people can assign tasks to you:

- You can add a personal task via the workbox.
- You can add a notification to your task list, via the notification workbox. This is useful if you want to get back to it later.
- Someone can assign you a task from a task list on a Confluence page.
- Other Confluence actions may create a task for you. For example, your Confluence site may be running a plugin that creates and assigns tasks.

Managing your personal tasks in the workbox

The workbox displays your notifications and your personal tasks in separate tabs. The task tab shows the tasks assigned to you. When you update a task that originated in a task list on a page, the update is reflected in the task list too.

Screenshot: Your personal tasks in the workbox
To manage your tasks:

1. Choose the notification-and-task icon in the Confluence page header.
   - You can use the keyboard shortcut: Type g then n. (When in the Confluence editor, click outside the editor pane before pressing the keyboard shortcut keys.)
   - The icon above shows that you have 3 unread notifications.

2. Choose the personal tasks icon:

3. To add a task and assign it to yourself, type the task summary in the text box and choose Add task.

4. To prioritise tasks, drag and drop them into your chosen order. (Click a task, hold down your mouse button to drag the task into position, then release the mouse button.)

5. To complete a task, or mark it as incomplete, choose the check box next to the task.

6. To add notes to a task and see further information (for example, a related page) choose the task item.
   The task details dialog will open.

Adding your notifications to your task list

You can flag a notification as a task. This is useful if you want to take action on the notification later.

To add a notification to your task list:

1. Choose the task and notification icon in the Confluence page header.
   - You can use the keyboard shortcut: Type g then n. (When in the Confluence editor, click outside the editor pane before pressing the keyboard shortcut keys.)
   - The icon above shows that you have 3 unread notifications.
2. Choose the notifications icon: 
3. Choose the notification that you want to add to your task list. The notification details dialog will open.
4. Choose the 'add task' icon to add this notification to your tasks. The notification will remain in the notification list too.

See Managing Notifications in Confluence for a full description of notifications.

Creating task lists and managing tasks on a page

Task lists on a page are useful for assigning and managing tasks in a team.

To add a task list on a page:

1. Edit the page.
2. Choose the task-list icon in the editor toolbar, or press [ and then ] on your keyboard.
3. Type the description of the task.
4. If you want to assign a task to someone, type '@' and the person's name in the task description. (For more information about @mentions, see Using Mentions.) That person will receive a notification, and the task will appear in their personal task list in the workbox. If you @mention yourself, the task will appear in your personal task list.
5. To end the list, press Enter twice.

Managing tasks on a page:

- When viewing a page, you and other viewers can mark tasks as complete or incomplete. Updates to a task on the page will be transferred to the workbox too. (See above.)
- To be able to update a task list when in view mode, you need permission to edit the page:
  - You need the 'Create page' permission in the space. See Space Permissions Overview.
  - There must not be any page restrictions that prevent you from editing the page. See Page Restrictions.

What if the update fails?

This section describes what you should do if Confluence displays an error message saying that your change to a task list could not be saved. The cause is probably one of the following:

- Your session has expired. Resolution: Log in and update the task list again.
You do not have permission to update the task list. **Resolution:** Check your permissions. You need 'Create page' permission in the space. Please check also that there are no page restrictions that prevent you from editing the page.

- The network is down. **Resolution:** Please try again when the network is available.

**Screenshot: A task list on a page**

Managing tasks with Confluence mobile

You can view and manage your tasks on your phone or other mobile device too. See [Using Confluence on a Mobile Device](#) for more about mobile platforms.

**Notes**

- The notification-and-task dialog is not available in [clustered](#) environments. The plugin will be installed and enabled, but it will detect that the site is in clustered mode and will not display the dialog.
- The notification-and-task dialog is provided by a set of plugins. To remove the personal notifications and tasks functionality from your site, you can disable the following plugins. See [Disabling or Enabling a Plugin](#) for instructions. Disabling these plugins will disable the entire notification-and-task dialog. It is not possible to disable only tasks or only notifications:
  - Notifications and Tasks - Common Plugin
  - Notifications and Tasks - Host Plugin
  - Notifications and Tasks - Confluence Provider Plugin
- If you want to re-enable the plugins, do so in the following order: Common Plugin, Host Plugin,
Confluence Provider Plugin.
- There is no option to disable the notification-and-task dialog for an individual user.
- Completed tasks in the workbox are automatically deleted after 7 days.
- You cannot disable the functionality that provides task lists on a page.

**Searching Confluence**

Quick guide to searching in Confluence:

1. Use the search box at the top right of your Confluence screen. It offers you a quick navigation aid as well as a full site search.

2. You can search Confluence directly from your browser's search box. Just add your Confluence site as a search provider using the dropdown menu in your browser's search box.

3. While editing a page or a blog post, you can find and replace text on the page. See Using the Editor.

**On this page:**
- Using the Quick Navigation Aid
- Performing a Full Search
- Viewing Attached Office Documents
- Accepting 'Did you mean' Suggestions from Confluence
- Filtering your Search Results
- Search Options When Using the Documentation Theme
- Advanced Search Syntax
- Browsing Related Labels
- Searching the Content of Attachments
- Searching Confluence from your Browser's Search Box
- Related Topics

**Using the Quick Navigation Aid**

The quick navigation aid automatically offers a dropdown list of pages and other items, matched by title to your search query. You can select one of the offered items or ignore them altogether.

**To use the quick navigation aid:**

1. Start typing your query into the search box located at the top right-hand corner of every screen. Confluence matches titles as you type, showing a quickly-adjusting dropdown list of pages, blog posts, personal profiles, attachments and so on. Press the Enter key if you want to bypass the quick navigation aid and perform a full search, as described below.

2. To see the space to which an item belongs, let your mouse pointer hover over the item in the dropdown list.

3. Use the up- and down-arrows on your keyboard to move up and down the list of matching titles and select an item.

4. Press the Enter key to open the selected item.

5. If you do not find what you are looking for, click **Search for** at the bottom of the list to do a full search. This has the same effect as pressing Enter immediately after typing your search query. The full search is described below.

*Screenshot: The quick navigation aid showing titles matching the query 'con'*
Here is more information about how the quick navigation feature works:

- Confluence will truncate any titles that are too long to be displayed.
- The matching items are grouped by content type so that you can quickly find the type you want. Confluence shows a maximum of 6 pages and/or blog posts, 2 attachments, 3 people and 2 spaces. If no matches are found in a particular category, then that category does not appear in the list.
- Items are ordered with the most recent updates first.
- When the matching item is a person's name, their profile picture appears next to their name in the list.
- The part of the title that is matched by the search query is highlighted in bold text.
- Your Confluence Administrator can enable or disable the quick navigation feature using the Confluence Administration Console.

Performing a Full Search

When you perform a full search, Confluence will search all content in all spaces (global and personal), mail, personal profiles, attachments and the space description. The results will appear on a new screen.

For the developers

The rendering of search results in Confluence is pluggable. If you are a developer, you may wish to write your own search result renderer to change how the search results are displayed. For more information, please refer to the following developer document: Writing a search result renderer.

To use the full search:

1. Type your query into the search box located at the top right-hand corner of every screen (or type it into the text box at the top of the Search screen).
2. Press the Enter key. (This means that you will ignore the dropdown list of titles offered by Confluence’s quick navigation aid, described above.)
3. The Search screen appears, as shown below. If any Confluence pages or items match your search query, the Search screen shows a list of the matching items.
4. Click an item’s title to open the Confluence page or other item.
On the left of the screen you will see a text block for each item that matched the search criteria, with the following information for each item:

- An icon representing the content type (user profile, space, page, blog post, etc). See [Icons Used in Confluence](#).
- The title or name of the content item.
- For attachments: The size and type of file, with a link to download or view the attachment where relevant. See information on [viewing Office attachments](#) below.
- For image files: A thumbnail of the image will display to the right of the file name.
- The most relevant few lines of content from within the item. Any words that match your search query are highlighted within the content.
- For personal profile items: The email address.
- The space to which the item belongs, displayed on the last line of the item's text block.
- The date when the content item was last modified.

You will see only search results which you have permission to view.

On the right of the screen are further options which allow you to tailor or filter your search results. See [below](#).

### Viewing Attached Office Documents

When the search results include an attached Office document, you will see a **View** link as shown in the screen snippet below.

**Screenshot: Search results include an attached Office document with 'View' link**
Click the View link to view the content of the Office document within Confluence. If you have an Office application installed, you will also be able to launch your Office editor from within Confluence. See Displaying Office Files in Confluence and Working with the Office Connector.

Accepting 'Did you mean' Suggestions from Confluence

When you perform a full Confluence search, as described above, Confluence may offer you an alternative spelling of your search query. The alternative spelling will appear next to the words 'Did you mean', as shown in the example below.

To accept an alternative spelling suggestion:

1. Type your query into the search box.
2. Press the Enter key.
3. Confluence will analyse the wiki content, to determine whether an alternative spelling of your search query occurs more often in the wiki content. If this is the case, the words 'Did you mean' will appear on the screen, along with an alternative spelling for your search query.
4. If you want to try the alternative spelling, click the word showing the suggested spelling. In the example below, you would click confluence.

Screenshot: The Search screen with 'Did you mean' offering a corrected spelling
Here is more information about how the 'Did you mean' feature works:

- Confluence uses both a dictionary (bundled with Confluence) and words mined from the content on your system to work out the best alternative spellings of your search terms. Practically, this means that Confluence can provide spelling corrections for specialised jargon that may not appear in a standard dictionary. In general, when deciding between alternative spellings, Confluence will favour words that appear more often in your content.
- In some cases, the 'Did you mean' suggestion may appear even when there are Confluence pages, etc, which match your search query. In other cases, there will be no items which match your search criteria. In both cases, Confluence will offer a 'Did you mean' suggestion if there is a word which will help you find more relevant content.
- The 'Did you mean' feature may offer more than one suggestion.
- The 'Did you mean' suggestion may even offer an incorrect spelling. This would happen if the incorrect spelling occurs many times within your Confluence site. This is intentional, because the aim of the 'Did you mean' feature is to help you find content, not to correct your spelling.
- Your Confluence Administrator can enable or disable the 'Did you mean' feature using the Confluence Administration Console.

Filtering your Search Results

The Search screen, pictured above, appears when you do your first search. By default, Confluence will search all content across your Confluence site, including all spaces, mail archives, attachments and all other content types.

On the right of the screen are options which allow you to tailor or filter the search results.

Enter your filter criteria as described below, then click Filter.

- **Where** — Restrict your search results to a particular space, or to your favourite spaces, global spaces or personal spaces.
- **What** — Restrict your search results to a particular content type (pages, blog posts, mail, etc).
- **When** — Restrict your search results to content modified within a particular period of time (today, yesterday, within the last week or within the last month).
- **Who** — Restrict your search results to content last modified by a particular user. You can start typing the person's username or part of their name into the text box as follows:
  - Type the username (e.g. 'jsmith').
  - Or start typing the person's first name (e.g. 'john')
  - Or their last name (e.g. 'smith').
  - Or another part of their name, such as a middle name.
  Confluence will offer you a list of possible matches. Use your mouse to select the person you want,
then press the Enter key to filter the search results.

_Screenshot: Filtering your search results by user_

More information about the user-matching filter:

- The user-matching filter is _not_ case sensitive. You can enter upper or lower case letters and will receive the same results.
- When looking for users to match the name you entered, Confluence divides a person's name into logical units corresponding to first name, middle name (one or more) and last name. It matches the letters of each unit in the name you entered against the letters of each unit in the user directory. For example, you can enter 'jo sm' to look for John Smith. The search is triggered after you have entered at least two letters.
- For each part of the name, you need to enter at least two letters. For example, if you enter just 'john s', the filter will look for users called 'john' and will ignore the 's'. Similarly, if you enter 'j smith' you will see everyone with the name 'smith' even if their first name does not start with a 'j'.
- You are not forced to use the auto-complete list. You can just type 'jsmith' or 'jo sm' and filter on that without choosing a match from the dropdown list. Confluence will warn you if there is more than one user corresponding to the name you have entered.

Click **Clear Filter** if you want to remove all your filters and perform the same search again but without the filter.

**Search Options When Using the Documentation Theme**

When using the Documentation theme, the Confluence search offers a few options as described below.

Using the search box at the top right of the page:

- By default, the main Confluence search is configured to search the entire Confluence site.
  - You will see the words **Search Confluence** in the search box at top right of the page.
  - The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
- A space administrator can configure the Documentation theme to restrict the search to the current space.
  - You will see the words **Search this space** in the search box at top right of the page.
  - The search will return results from the current space only.
  - You can override the search restriction. Enter **all:** and your search term to search the entire site. For example, enter the following into the search box at top right of the page to search the entire site for 'technical writing':

```
all: technical writing
```

Using the search box in the left-hand panel:

- By default, the Documentation theme's left-hand panel includes a search box. Enter your search term
there, to restrict the search to the current space. Specifically, this will search only the pages that are children of the space’s home page.

- If your administrator has restricted the main search to the current space, there will not be a search box in the left-hand panel.

For screenshots and a full description, see Using the Documentation Theme.

**Advanced Search Syntax**

See Confluence Search Syntax for more ways to refine the text you enter into the search box.

Additionally, see Confluence Search Fields for special parameters you can use in the search box to search on various metadata.

**Browsing Related Labels**

Also on the right of the Search screen, Confluence will offer a list of labels which are related to your search query. See the screenshot above.

You can click a label to see all pages and blog posts tagged with that label. See Viewing Labels and Labelled Content.

**Searching the Content of Attachments**

When you search Confluence, by default the search will include the content of the following types of attachments:

- Word
- Text
- PowerPoint
- Excel
- PDF
- HTML

To search the content of other attachment types, you will need to use an attachment content extractor plugin. For more information, take a look at the following:

- Existing extractor plugins which you can install on your Confluence site.
- Guidelines on developing your own attachment content extractor plugin.

**Searching Confluence from your Browser’s Search Box**

If you are using Firefox or Internet Explorer 7 or later, you can add your Confluence site as a search provider, using the dropdown menu next to the browser's search box.

The example below shows the 'Extranet' Confluence site offered for inclusion as a search engine in the browser's search box.

*Screenshot: Adding your Confluence site to your browser's search box*
Information about OpenSearch:

- Confluence supports the autodiscovery part of the [OpenSearch description document](http://opensearch.org/). This is an XML file that describes the web interface provided by Confluence's search function.
- Any [client applications](http://opensearch.org/) that support OpenSearch will be able to add Confluence to their list of search engines.
- Your [Confluence Administrator](http://confluence.org/) can enable or disable the Open Search feature using the Confluence Administration Console.

**Related Topics**

- Confluence Search Syntax
- Confluence Search Fields
- Ranking of Search Results
- Text Tokenisation and Filtering
- Search Results Macro
- Livesearch Macro
- Page Tree Macro (includes an optional search box)
- Viewing Labels and Labelled Content
- Searching the People Directory

Take me back to the [Confluence User's Guide](http://confluence.org/).

**Text Tokenisation and Filtering**

When searching for content based on search terms entered by the user, Confluence splits the text of the content into tokens, and then filters and modifies those tokens according to the following rules.

**Tokenisation**

Confluence uses Lucene's [Standard Tokenizer](http://lucene.apache.org/). This splits the text into tokens as follows:

- Splits words at punctuation characters, removing punctuation. However, a dot that's not followed by white space is considered part of a token.
- Splits words at hyphens, unless there's a number in the token, in which case the whole token is interpreted as a product number and is not split.
- Recognises email addresses and internet host names as one token.

An example: The string 'foo-bar5' won't be split into 'foo' and 'bar5', so a search for 'bar5' or 'bar*' will not find any results.
Filtering

Confluence then:

- Removes "s" from the ends of words.
- Removes the dots from acronyms, e.g. I.B.M. becomes IBM.
- Converts everything to lower case.
- Removes common words like 'the' and 'or' are removed.
- Converts words to their stems. For example, 'fishing' and 'fishes' both become 'fish'.

Related Topics

Searching Confluence

Searching the People Directory

The people directory displays a list of people who use your Confluence site.

The people directory includes anybody who has logged into Confluence or who has had a user account created for them in Confluence. The people directory does not include users who can log into Confluence using external user management if they have never yet logged in.

Viewing the People Directory

Choose Browse > People Directory.

The Confluence administrator can hide the people directory. If it is hidden, you will not see the People Directory link in the Browse menu.

Screenshot: The People Directory

Searching for People

To search for a particular person, type their first name and/or last name into the search box and click Search.
• To search everyone who uses your Confluence site, click All People.
• To search just those people who have set up a personal space, click People with Personal Spaces.

Following People's Activities

Confluence's network features allow you to 'follow' (that is, keep track of) other people's activities throughout a Confluence site. For more information, please refer to Network Overview. Using the hover profile feature, the people directory is a convenient area from which you can start following other people throughout your Confluence site.

• To start following another person's activities, move your mouse over a user's name or profile picture and in their hover profile popup, click Follow.
• To stop following another person's activities, move your mouse over a user's name or profile picture and in their hover profile popup, click Stop Following.

Once you start following another person, their activities will start appearing in your network view.

People Directory provides hCard microformat

The people directory uses the hCard microformat for simple integration with a variety of microformat-enabled tools. hCard is an open data format for representing people, companies, organisations, and places. Read more about microformats and hCard.

Related Topics

Setting Up your Personal Space
Editing your User Profile
Choosing a Profile Picture

Take me back to the Confluence User's Guide.

Confluence Search Syntax

Here's how you can refine your search. Confluence will ignore common words like "the" unless you place your query within quotes.

Exact phrase search

To search for content that contains the exact phrase "chalk and cheese"

"chalk and cheese"

Confluence will ignore common words (stop words) like "and" above. This is the default list of stop words used by lucene. Please cast your vote towards this improvement request.

For eg:

1. Searching for "The One" returns all pages containing "One" because "The" is a stop word.
2. Searching for "Cheese One" would only return pages in which "One" appears as the first word (other than stop words) after "Cheese". So it would return "Cheese for One" or "Cheese to One" or "Cheese One". It would not match "One Cheese" or "Cheese Flamingo One"

Or Search

To search for content that contains one of the terms, "chalk" OR "cheese"
chalk OR cheese

Please note that the operator OR must be typed in capitals.

**And Search**

To search for content that contains both the terms "chalk" AND "cheese"

chalk AND cheese

Please note that the operator AND must be typed in capitals.

**Not search**

To search for content that contains "chalk" but NOT "cheese"

chalk NOT cheese

Please note that the operator NOT must be typed in capitals.

**Excluded Term search**

Similar to the NOT search, to search for content that contains "chalk" and "butter" but NOT "cheese"

chalk butter -cheese

**Grouping Search**

To search for content that MUST contain "chalk" but CAN contain either "cheese" or "butter" use the search:

(cheese OR butter) AND chalk

**Title Search**

To search for content with "chalk" in its title, where title is the field keyword.

title:chalk

**Wild card searches**

**Single character**
To search for "butter" or "batter" you can use the search:

```
b?tter
```

To search for "chicken" or "chickpea" you can use the search:

```
c?k*
```

Wildcards can be used anywhere within a word, except at the very beginning. For example:

```
*c?k
```

is an invalid search term.

**Multiple characters**

To search for "chick" or "chickpea":

```
c*c*
```

You can also combine search characters to get the exact word. For example the search term below will return "chick" yet not "chickpea":

```
c*c?
```

---

**Case Sensitivity in wildcard searches**

Since the fix for [CONF-13846](https://confluencelassian.net/CONF-13846) Confluence is case sensitive for wildcard searches.

You should note that all the example searches given previously search across the default set of fields which are stored as lower case and therefore all searches of that style should be given lower case search terms (as shown in the examples).

However, if you were to search one of the case sensitive fields, such as 'content-name-untokenized' the case of your search term would need to match the document you are searching for.

**Proximity searches**

This search ensure that the two words specified must be within a certain number of words of each other to be included.
"octagon post"~1 will return "Octagon blog post".

"octagon post"~0 is an invalid search term.

**Range search**

ℹ️ Searches for names that fall alphabetically within the specified range.

[adam TO ben]

Note: You can't use the **AND** keyword inside this statement and that TO must be written in capitals to form a valid search.

**Fuzzy search**

ℹ️ This search looks for words spelled similarly.

To search for octagon, if unsure about spelling:

octogan~

will correctly return "octagon"

**Combined search**

You can also combine various search terms together:

o?tag* AND past~ AND ("blog" AND "post")

**Search for macros**

You can search Confluence content for anywhere a macro is used. To do this, just add **macroName** to your search and append the macro name after the column. For example, search for all excerpt-include macros:

macroName:excerpt-include*

For more information about **macroName** and other search fields, see [Confluence Search Fields](#).

**Related Topics**
Searching Confluence
Confluence Search Fields

Take me back to Confluence User's Guide

Confluence Search Fields

Purpose of this document
This page is intended for developers and advanced users of Confluence. It gives an overview of the Apache Lucene search fields used in Confluence.

On this page:

- Searching for Content in Specific Fields
- Confluence Search Fields
  - Personal Information
  - Pages
  - Blog
  - Attachments
  - Mail Items
- Related Topics

Searching for Content in Specific Fields

Confluence data is stored in fields which can be specified in the search. To search a specific field, type the name of the field followed by a colon ':' and then the term you are looking for.

Examples:

```
title:"Some Title"
```

```
labelText:chalk
```

The field specification applies only to the term directly preceding the colon. For example, the query below will look for "Some" in the title field and will search for "Heading" in the default fields.

```
title:Some Heading
```

Confluence Search Fields

Below are the fields which can be searched, listed by content type.

**Personal Information**

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Indexed</td>
<td>Stored</td>
<td>Tokenised</td>
<td>Notes</td>
</tr>
<tr>
<td>----</td>
<td>---------</td>
<td>--------</td>
<td>-----------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>fullName</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>username</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>Pages</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>lastModifiers</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>Username of the user who last updated the page.</td>
</tr>
<tr>
<td>creatorName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>Username of the user who added the page.</td>
</tr>
</tbody>
</table>
### blog

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>lastModifiers</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>Username of the user who last updated the blog post.</td>
</tr>
<tr>
<td>creatorName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>Username of the user who created the blog post.</td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used in the blog</td>
</tr>
</tbody>
</table>

### attachments

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
</tbody>
</table>
### Mail Items

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>messageid</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>inreplyto</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>recipients</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>lastModifiers</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The username of the user who did the mail import, not the person who sent the email message.</td>
</tr>
<tr>
<td>--------------</td>
<td>------</td>
<td>------</td>
<td>-------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>creatorName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The username of the user who did the mail import, not the person who sent the email message.</td>
</tr>
</tbody>
</table>

**Related Topics**
- [Searching Confluence](#)
- [Text Tokenisation and Filtering](#)
- [Searching the People Directory](#)
- [Confluence Search Syntax](#)
- [Confluence Search Fields](#)
- [Ranking of Search Results](#)

**Ranking of Search Results**

When you perform a search in Confluence, it is likely that there will be many pages or other content items that match your search terms. Confluence will rank the matching items by evaluating their relevance. This should mean that the items most relevant to you will appear at the top of the search results list, so that you can quickly select the item you need.

Below is an overview of the method Confluence uses to determine the relevance of the items returned by the search, i.e. to rank the search results.

**On this page:**
- Philosophy behind the Ranking
- Summary of the Ranking Method
- Weighting of Content Types
- Weighting of Fields
- Weighting Based on Age
- Simplified Example
- Related Topics

**Philosophy behind the Ranking**

Confluence gives highest priority to personal information i.e. documents which take you to a user's profile when you click on them. Collaboration is a primary function of a wiki, so Confluence makes it easy to find people.

For example, if you search for 'John Smith', the first results you see will be for John Smith's user profile and personal space. There may also be other content (wiki pages, email messages, etc) which contain the words 'John Smith'. These other content types may even have 'John Smith' as the page title and repeated multiple times in the content, but they will still appear lower down in the list of search results.

Matching terms found in the title of a page, or in the title of any content type, are considered a strong match. So are matches found in labels, because when someone applies a label it means that they think the content is particularly relevant to the labelled term.
Matches found in the content body are of average importance. If the matched term appears more than once, the document will be given a proportionately higher ranking.

We also assume that information created recently is slightly more relevant than older information.

**Summary of the Ranking Method**

When displaying the results of a search, Confluence applies a weighting to each of the content items returned.

To determine the weighting:

1. For each content item, Confluence first applies three weightings based on the following:
   a. The content type of the item returned — user profile, page, blog post, attachment, etc. (More details below.)
   b. The type of field in which the search term was found — title, name, label, or content body. (More details below.)
   c. The age of the item returned. (More details below.)
2. Confluence then combines the three weightings to arrive at a single weighting for the content item.

The item with the heaviest weighting will appear at the top of the list of search results, and the other items will appear below in descending order of weighting.

**Weighting of Content Types**

<table>
<thead>
<tr>
<th>Content Type</th>
<th>Weighting</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Profile</td>
<td>9</td>
</tr>
<tr>
<td>Page</td>
<td>8</td>
</tr>
<tr>
<td>Blog</td>
<td>7</td>
</tr>
<tr>
<td>Attachment</td>
<td>6</td>
</tr>
<tr>
<td>Comment</td>
<td>5</td>
</tr>
<tr>
<td>Mail</td>
<td>0.5</td>
</tr>
<tr>
<td>Space Description</td>
<td>0.4</td>
</tr>
</tbody>
</table>

**Simple example**

If the search returns 7 matching items, and each item is one of the above types, then the items will be presented in the above order on the results screen. (This example assumes that the search term is found in the same field in each item — see more about fields below.)

**Weighting of Fields**

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Weighting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>9</td>
</tr>
</tbody>
</table>
Note that 'content' above could be the content of a page, or the content of a comment, or the body of any other content type. See more about content types above.

**Simple example**

A match for a search term in the title of a document is 1.8 times (9/5) more important than a match in the content.

### Weighting Based on Age

This weighting is based on the age of the item returned in the search results. The age of the item is calculated from the creation date of the item. The age intervals are quite coarse-grained, as shown in the table below.

<table>
<thead>
<tr>
<th>When the Item was Created</th>
<th>Weighting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Today</td>
<td>1.5</td>
</tr>
<tr>
<td>Yesterday</td>
<td>1.3</td>
</tr>
<tr>
<td>Up to 1 week ago</td>
<td>1.25</td>
</tr>
<tr>
<td>Up to 1 month ago</td>
<td>1.2</td>
</tr>
<tr>
<td>Up to 3 months ago</td>
<td>1.15</td>
</tr>
<tr>
<td>Up to 6 months ago</td>
<td>1.10</td>
</tr>
<tr>
<td>Up to 1 year ago</td>
<td>1.05</td>
</tr>
<tr>
<td>Beyond a year</td>
<td>1</td>
</tr>
</tbody>
</table>

The weighting is fairly small, so will not have a large effect. When an item is more than a year old, the age weighting is just ‘1’ i.e. it has no effect.

**Simple example**

- If two documents match in all other ways then the newer one will be presented first.
- If the two documents being compared are both older than a year then their relative age does not matter.

### Simplified Example

Let's assume you search for a single term.

Confluence finds a match in the title of an email message created today:
### Organising Content

Confluence provides a number of ways for organising and structuring content in the wiki:

- **Spaces** allow you to group content according to major categories.
- **Pages** are used for discrete topics, and can be structured into page trees to show the relation between them.
- **Favourites** are particular pages or spaces that have been bookmarked by a user, to make them easy to find again.
- **Labels** are user-defined tags that are added to related pages in order to categorise them in some way.
- **Attachments** to a page can include images, multimedia, Office and PDF files, and provide a way to include other forms of content in the wiki.
- **Email** can be collected and archived within each space individually, to manage all mail related to a project.

---

**Result:** The comment (weighting 30) will be appear higher in the search results than the e-mail (6.75).

ℹ️ Confluence uses the [Apache Lucene](https://lucene.apache.org) search engine library. Lucene's score calculation has a number of additional terms, not mentioned in the above example. We have simplified above, for purposes of illustration. If you are interested, you can see more information in the [Lucene documentation](https://lucene.apache.org).
Related Topics

Creating Content

Searching Confluence

Take me back to the Confluence User's Guide.

Working with Pages

Pages are the primary means of storing and sharing information in Confluence. Pages are contained within spaces.

- Use spaces to organise your wiki content into your primary logical groups. For example, you could have a space per team, per product, or per department.
- Use pages to organise your content into lower-level groups. For example, you could have a page for a particular team activity, or for a feature in a product, or for a chapter in a book. Add more child pages to contain lower-level details if necessary.

Things you can do with pages in Confluence:

- Create a new page from anywhere within the site.
- Write content using the editor.
- Rename a page.
- Copy an existing page.
- Organise pages hierarchically via parent-child relationships.
- Move pages while editing a page or while viewing the space’s Tree view.
- Navigate within and between spaces through flexible linking.
- Collaborate via comments on a page.
- Control access through page security restrictions.
- Monitor page updates and other activity through page notifications.
- View page history and link to older versions.
- Search page content, including attachments.
- Export pages to PDF, WORD, HTML or XML.
- Email page content.
- Like a page.

Related pages:
- Adding Pages
- Working with Page Families
- Working with Drafts
- Working with the Office Connector
- Viewing Recently Visited Content
- Confluence User's Guide

Moving a Page

This page describes how to move a page. You can move a page:

- to a different space, with a new parent
- to have a different parent page, within the same space
- to reorder sibling pages that are children of a common parent.

When you move a page, all of the page content such as attachments and comments will be moved with the page. Additionally, all child and descendent pages and their page content will also be moved.
You can also copy a page, and move an attachment.

On this page:
- Moving a Page to a Different Space
- Moving a Page within a Space
- Related Topics

Permissions

To move a page, you need the following permissions:

- 'Edit' permission on the page you are moving, and
- 'View' permission on the page's parent page. So if you are moving the page to a different parent, you need 'View' permission on the new parent.

To move a page into a different space, you will also need:

- 'Remove' permission on the space you are moving from, and
- 'Create' permission on the space you are moving to.

To move a page while keeping its page restrictions, you will also need:

- Space administrator permission on the space you are moving to. Alternatively, remove the page restrictions before performing the move.

Moving a Page to a Different Space

You can move a page, along with its child pages, to a different space. Any links to a moved page from the current space will automatically be renamed to point to the page in the new space.

To move a page to another space in your Confluence site:

1. Go to the page and choose Tools > Move.
2. Use the tabs on the left to help you find the new space and parent page for your page, that is, the location where you want to move your page. The 'Current location' and 'New location' breadcrumb trails at the bottom of the dialog indicate the current parent page and new parent page.
3. If you want to move a page to a different position amongst the child pages, check Reorder to see a list of sibling pages when you click Move.
4. Click Move.
5. If you are reordering the child pages, click in the list to set the new position for the page and click Reorder.

Moving a Page within a Space

You can move a page to a different position in the page tree. This allows you to:

- Move a single page, or a family of pages, to have a different parent within the space.
- Reorder sibling pages that are children of a common parent.

Any links to the page are maintained. When a page that is itself a parent (that is, it has one or more child pages) is moved, the entire hierarchy of child pages of the moved page (including comments and attachments) is maintained.

To move a page using the space's 'Tree' view:

1. From any page, choose Browse > Pages.
2. Click Tree.
3. Find the page you want to move.
4. Drag the page up or down the tree.
5. While dragging the page, you see one of the following:
   - A thin line between existing pages — this indicates the potential new position for the page. Release the mouse button when the page is where you want it.
   - A wide highlight over one or more existing pages — this indicates that you can drop the page into a page family. Release the mouse button to add the page to the family. The page will appear either in alphabetical sequence or as the last page in the family, depending on the family's sequential order.

⚠️ The new position of the page is saved as soon as you release the mouse button.
ℹ️ To cancel the move while still holding down the mouse button, press the 'Esc' key.

Related Topics

- Moving an Attachment
- Copying a Page
- Deleting a Page
- Sequential Order of Pages
- Overview of Pages

Take me back to the Confluence User's Guide.

### Copying a Page

You can copy a page, to create a duplicate of the page content. You will need to rename the page, because a page name must be unique within a space.

You need 'Create Pages' permission, which is assigned by a space administrator from the Space Administration screens. See space permissions or contact a space administrator for more information.

**To copy a page:**

1. Go to a page in the space and choose **Tools > Copy**.
   - Confluence will open a copy of the page in edit mode. By default, Confluence will name the page 'Copy of <<original page name>>'.
2. Rename the page and make any other changes required in the body of the page.
3. If you need to move the new page to a different space or a different parent, you can edit the Location. Refer to the instructions on moving a page.
4. Click **Save**.

**Notes**

- Copying a page will duplicate all of the original page's attachments and labels, but will not copy comments from the original page.
- This method of copying a page does not copy the child pages. Please add your vote to issue [CONF-2814] if you'd like to see this improvement.
- You can copy an entire space, including all pages in the space (parents and children) — refer to these instructions on copying a space.
- Consider using **WebDAV** to move or copy a page hierarchy from one space to another, provided that none of the page names already exist in the target space.
Renaming a Page

To rename an existing page, you require 'Edit Pages' permission which is assigned by a space administrator from the Space Administration screens. See Space permissions or contact a space administrator for more information.

To rename a page:

1. Go to a page in the space, and click **Edit** at the top to view the page in 'Edit' mode.
2. Change the page title as required.
3. Click **Save**.

**Notes**

- Confluence will automatically update all internal links to point to your new page title. This only works for page links that use the relative link syntax, for example [Renaming a Page].
- In macros, page links will not be updated. You need to update these manually.
- Links from external sites will be broken, unless they use the page's permanent URL.
Deleting a Page

To delete a page, you need the 'Remove Pages' permission. See Space Permissions or contact a space administrator for more information. If someone has applied page restrictions to the page, the restrictions may prevent you from deleting the page too.

To delete a page:

Go to the page and choose Tools > Remove. Confirm the action as prompted.

Note: The 'Remove' option will only appear if you have permission to remove this page.

Deleting a page and all its children

If the page you are deleting has any child pages, they will be moved to the root of the space. The child pages will not be deleted.

Hint: If you need to remove a parent page and a large number of child pages:

- Create a temporary new space.
- Move the parent page to the new space. The child pages will move too.
- Remove the space.

Notes

- When you delete a page, Confluence moves it to the trash. Space administrators can recover pages from the trash.
- Purge the trash to remove the page permanently.
- Attachments attached to a deleted page will remain in the database (allowing potential retrieval) until the trash is purged. When the trash is purged, all attachments on that page are permanently removed.

Purging Deleted Pages

When a user deletes a page from a Confluence space, the page is not permanently removed. Instead, Confluence places the deleted page into the 'Trash'. The page will remain in 'Trash' until a space administrator purges the page.

Purging deleted pages permanently clears them from 'Trash'.

You need to be a space administrator to purge deleted pages for a space.

To purge deleted pages:

1. Choose Browse > Space Admin.
   
   Note: 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super
1. When the trash is purged, all attachments on purged pages are permanently removed as well.

## Related Topics

- Deleting a Page
- Restoring a Deleted Page

Take me back to **Confluence User's Guide**

### Restoring a Deleted Page

When you restore a page, you are retrieving it from 'Trash' to the root of the space where it existed before it was deleted.

You need to be a **space administrator** to restore deleted pages.

### To restore a deleted page:

1. Choose **Browse > Space Admin.**
   
   *Note:* 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the **confluence-administrators** group).

2. Click **Trash** from the left panel. A list of deleted pages and emails for the space is displayed.

3. Click **Restore** beside the page you want to restore.

### Note

If a new page has already been created in that space with the same name as the deleted page, you will be given an option to rename the page before it is restored.

## Related Topics

- Deleting a Page
- Purging Deleted Pages

Take me back to **Confluence User's Guide**

### Working with Page Families

A 'page family' is simply the **parent** and **child** pages in a part of the page hierarchy.

Things you can do with page families in Confluence:

- View a page's family.
- View the hierarchy of all pages within a space.
- Move and re-order pages.
- Order the pages in a page family alphabetically.

### Related Topics

- Managing Orphaned Pages
- Working with Pages
Working with Spaces

Take me back to Confluence User's Guide

Viewing a Page's Family

To view a page's family, go to the page and choose Tools > Info.

The page's parent and children, if any, are listed under 'Hierarchy'.

Screenshot: Viewing a page's family

<table>
<thead>
<tr>
<th>Hierarchy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent Page</td>
</tr>
<tr>
<td>Home</td>
</tr>
<tr>
<td>Children (5)</td>
</tr>
</tbody>
</table>

Choose a Page
move an attachment from one space to another
Move a family of pages from one space to another
Move a page from one space to another
Page Families

Notes

- If there are more than 10 children, only the first 10 will be shown by default. To view all the children, click Show all....
- If no parent is displayed for the page, either the page sits in the root directory of the space or its parent has been deleted.

Related Topics

Working with Page Families
View Hierarchy of all Pages within a Space
Managing Orphaned Pages

Take me back to Confluence User's Guide

Sequential Order of Pages

Confluence allows you to present your pages in any order (sequence) you choose. The position of a page is reflected in the following places:

- The Tree tab on the space's 'Pages' view
- Exporting pages to PDF, HTML and XML
- The Pagetree macro
- The Children macro

Alphabetical versus Manual Order

By default, Confluence will present your pages in alphabetical order. When you move a page to a different position, the order becomes manual for the affected page family.

When ordering pages alphabetically, Confluence actually applies a more sophisticated 'natural' order rather than a straight alphabetical order. The natural order handles numeric values correctly when doing string comparisons.

Now let's consider what happens when you add a page to a page family, by creating a new page or by moving or copying a page into the family:

- If the page family's order is alphabetical, the new page will appear in alphabetical order too.
- If the page family's order is manual, the new page will appear at the bottom of the list of pages in the family.
Changing the Page Order

You can change the order of the pages by moving pages within the page tree — see Moving a Page.

You can also change the order of a page-family from manual to alphabetical (see the 'Setting Page Order to Alphabetical' section on Setting a Page Family to Alphabetical Order).

Related Topics

Overview of Pages
Overview of Page Families
Moving a Page

Take me back to Confluence User's Guide

Setting a Page Family to Alphabetical Order

You can choose to display your Confluence pages in alphabetical or manual order. This page tells you how to set the pages within a family to alphabetical order. See Sequential Order of Pages.

On this page:

- About the Sequential Order of Pages
- Alphabetical versus Manual Order
- Changing the Page Order
- Setting Page Order to Alphabetical
- Related Topics

About the Sequential Order of Pages

Confluence allows you to present your pages in any order (sequence) you choose. The position of a page is reflected in the following places:

- The Tree tab on the space's 'Pages' view
- Exporting pages to PDF, HTML and XML
- The Pagetree macro
- The Children macro

Alphabetical versus Manual Order

By default, Confluence will present your pages in alphabetical order. When you move a page to a different position, the order becomes manual for the affected page family.

When ordering pages alphabetically, Confluence actually applies a more sophisticated 'natural' order rather than a straight alphabetical order. The natural order handles numeric values correctly when doing string comparisons.

Now let's consider what happens when you add a page to a page family, by creating a new page or by moving or copying a page into the family:

- If the page family's order is alphabetical, the new page will appear in alphabetical order too.
- If the page family's order is manual, the new page will appear at the bottom of the list of pages in the family.

Changing the Page Order

You can change the order of the pages by moving pages within the page tree — see Moving a Page.

You can also change the order of a page-family from manual to alphabetical (see the 'Setting Page Order to Alphabetical' section on Setting a Page Family to Alphabetical Order).
**Setting Page Order to Alphabetical**

If the pages in a page family have been ordered manually, you can reset the page order to alphabetical as described below.

A page family is a set of pages under a single parent page. In this section, when we say 'page family' we mean the immediate children of the parent page, not including the grand-children.

The screenshot below shows a family of pages in non-alphabetical order under the parent 'Sample Page'. Notice the icon next to the parent 'Sample Page', giving you the option to order the pages alphabetically.

*Screenshot: A family of pages in non-alphabetical order with 'Sort Alphabetically' icon*

To set a page family to alphabetical order:

1. Go to a page in the space and choose **Browse > Pages**.
2. Go to the **Tree** tab.
3. Expand the branches of the tree to find the page family you want.
4. If the page family is in non-alphabetical (manual) order, the 'Sort Alphabetically' icon will appear next to the parent page as shown in the screenshot above. Click the icon.
5. The child pages will shuffle into alphabetical order and the icon will change to the 'Undo Sorting' icon as shown in the screenshot below.

   *Only the immediate children of the parent page will be affected. The grand-children will not be re-ordered. (If you want to re-order the grand-children, you need to click the 'Sort Alphabetically' icon next to the parent of those pages i.e. re-ordering happens for one node at a time.)*

*Screenshot: A family of pages in alphabetical order with 'Undo Sorting' icon*
If you change your mind, you can click the 'Undo Sorting' icon to undo the alphabetical sort. This option is only available while you remain on the Tree tab and provided that you have not performed any other action on the page family. Once you move away from this screen or do something else with the page family, such as moving children in or out of the family, the undo option is no longer available.

**Related Topics**

- Moving a Page
- Overview of Pages
- Overview of Page Families

Take me back to [Confluence User's Guide](#)

### Viewing Hierarchy of Pages within a Space

The 'Tree' view of the 'List Pages' page displays the hierarchy of the pages within the space. It is a useful way of viewing all the parent-child relationships between pages in the space at once.

#### To see the tree view of pages within a space:

1. Choose **Browse > Pages**.
2. Click **Tree**.

**Screenshot: Tree View**

![Tree View Screenshot](https://example.com/tree-view.png)

- [Confluence Security Advisory 2005-02-09](#)
- [RSS](#)
- [Confluence Plugin Guide](#)
- [Importing From JSPWiki](#)
- [Confluence Release Cycle](#)
- [Setup a mail session in standalone version](#)

**Related Topics**

- Moving a Page
- Working with Pages

Take me back to [Confluence User's Guide](#)
Viewing Pages Alphabetically

Use this view when you are looking for a specific page in a space and you know its title.

To view the pages in your space alphabetically:

1. Choose Browse > Pages.
2. Choose Alphabetical.
3. Choose a letter to display all the pages beginning with that letter. Choosing a page link will take you to that page.

Notes

If you know the title of a page, you might find it faster using the Quick Search.

Related Topics

- Viewing Recently Updated pages
- Working with Pages
- Confluence User's Guide

Managing Orphaned Pages

An orphaned page is a page without any incoming links. What this means is that unless you know that this page exists, you are not likely to come across it in the space during the natural course of navigation.

When you are working in a large space with a number of pages, it is difficult to keep track of all of them. An orphaned page may be redundant or need to be referred to from another page. Confluence allows you to view all the orphaned pages in a space so you can "tidy up" the space by either deleting pages or by reorganising them.

To view the orphaned pages in a space:

1. Choose Browse Space > Advanced.
2. Click on Orphaned Pages in the left panel.

You can:

- delete an orphaned page by clicking on the 'trash' icon beside it.
- give an orphaned page a parent — see Moving a Page.

Related Topics

- Managing Undefined Pages

![Orphaned Pages - Atlassian News](Image)
Managing Undefined Pages

In Confluence, you can create links to pages that you intend to create later. These are links to "undefined pages". This is useful because it allows you to create links first and enter content for those pages later.

For example, this link to new page is a link to a non-existent page, also called an undefined page. The link is shown in dark red. If someone clicks the link, Confluence will create a new page called 'link to new page'.

The 'Undefined Pages' view gives a consolidated report of all undefined pages so that you can manage your space better. The undefined page links are badged with this icon to remind you that those pages need to be created.

To view a list of the undefined links in a space:

1. Choose Browse > Advanced.
2. Choose Undefined Pages in the left-hand panel. This will display a list of all the undefined pages in the space.

You can click the link for an undefined page to create the page and add content to it.

Related Topics

- Managing Orphaned Pages
- Working with Pages
- Confluence User's Guide

Using the Documentation Theme

The Documentation theme is one of the themes bundled with Confluence. It provides an inbuilt table of contents for your wiki space, a configurable header and footer, and text styles suited to documentation. You can also configure it to restrict the search results to the current space, rather than searching the entire Confluence site.

This page tells you how to view pages in your Confluence space when your space uses the Documentation theme. For the full list of features and instructions on applying the theme to a space, see the guide to configuring the Documentation theme.

Quick guide to using the Documentation theme

- The left-hand panel contains a page tree. This is a table of contents that shows the pages in the space.
- Click the plus signs in the page tree to see the child pages.
- Drag the thick vertical bar to change the width of the panels.
- Show/hide the left-hand panel: Click the sidebar icon at top right, next to the search box, to remove the left-hand panel altogether. Click the icon again to restore the panel.
- Alternatively, press '[' on your keyboard to show/hide the left-hand panel.
- Overriding a space-restricted search: If your theme is configured to restrict the search to the current space, you can enter 'all:' and your search term to search the entire site.

The rest of this page gives more details of the above guidelines.
Using the Documentation Theme

By default, the left-hand panel contains a search box and a table of contents (page tree) showing all the pages in your space. Specifically, it shows the pages that are children of the space's home page.

![Documentation Theme Default](gliffy{name=Documentation Theme Default|align=left|size=L})

Screenshot above: The Documentation theme with default settings

A space administrator can customise the Documentation theme as follows:

- Change the content in the left-hand panel and add a header and footer to the page. This means that your own pages may look different from the screenshot above.
- Restrict the search so that it will show results from the current space only, not from the entire Confluence site.

![Documentation Theme](gliffy{name=Documentation Theme|align=left|size=L})

Screenshot above: The Documentation theme with space-restricted search

Here is a summary of the things you can do on a page that uses the Documentation theme:

- Click the plus signs to open and close the branches of the page tree (table of contents) in the left-hand panel.
- Drag the thick bar between the left-hand panel and the content, to increase or decrease the width of the panel.
- Click the sidebar icon at top right, next to the search box, to remove the left-hand panel. This will remove the panel for you only. Other people will still see it.
- Click the sidebar icon again to restore the left-hand panel.
- Alternatively, press '[' on your keyboard to show/hide the left-hand panel.
- Use the scroll bars to scroll the left-hand and right-hand panels independently of each other.
- Search the content of the space or the site. See below.

Searching the Space or the Site

When using the Documentation theme, the Confluence search offers a few options as described below.

Using the search box at the top right of the page:

- By default, the main Confluence search is configured to search the entire Confluence site.
  - You will see the words ‘Search Confluence’ in the search box at top right of the page.
  - The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
- A space administrator can configure the Documentation theme to restrict the search to the current space.
  - You will see the words ‘Search this space’ in the search box at top right of the page.
• The search will return results from the current space only.
• You can override the search restriction. Enter ‘all:’ and your search term to search the entire site. For example, enter the following into the search box at top right of the page to search the entire site for ‘technical writing’:

   all: technical writing

Using the search box in the left-hand panel:

• By default, the Documentation theme's left-hand panel includes a search box. Enter your search term there, to restrict the search to the current space. Specifically, this will search only the pages that are children of the space's home page.
• If your administrator has restricted the main search to the current space, there will not be a search box in the left-hand panel.

Hints and Tips

Below are some hints that you may find useful when using the Documentation theme.

Where can I see a working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme’s table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page. Each space has a single page designated as the 'Home' page. You can specify the home page in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

Cause 1: Your pages are not under the space’s home page. The most probable reason why your pages do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space’s home page. If your pages are above the home page in the page tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

• You can change the designated space home page in the space administration section.
• Or you can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the ‘Pages’ section of the space ‘Browse’ screen. See Moving a Page.

Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with Documentation theme bundled. If your existing Confluence installation already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar icon at top right, next to the search box. Click the icon again to restore the panel.
Viewing Page Information

The 'Information View' for a page shows you various bits of useful information about the page.

To see the Information View for a page:

1. View the page.
2. Choose **Tools > Info** to go to the 'Information' view for the page.

The 'Information View' displays the following information:

1. **Page Details**: Title, author, date of creation, date of last modification and the tiny link of the page.
2. **Page Hierarchy**: Parent-child relationships of the page.
3. **Page Permissions**: Displays page-level security restrictions that apply to the page (if present).
4. **Recent Changes**: Links to the five most recent versions of the page along with the name of the editor and the date of modification.
5. **View page history**: A link to the page history, which displays all the versions of the page in reverse chronological order and allows you to compare versions or to restore a previous version.
6. **Hot Referrers**: The external website pages which send the most viewers to the page.

Screenshot: A page's Information View

---

**Related Topics**

**Working with Pages**

Take me back to Confluence User's Guide

**Viewing Recently Visited Content**

Confluence keeps track of pages you have recently visited in Confluence. This history is available from the **Recently Viewed** screen. You can also use this screen to go back to Confluence pages you have recently visited.

To view the list of recently visited pages and go back to one of them:

1. Go to the 'Recently Viewed' content view. To do this:
1. Go to your name (the 'User' menu) at the top of the page and choose Recently Viewed.
2. Choose the title of the page you wish to revisit.

Screenshot: Recently viewed content

**Recently Viewed**

<table>
<thead>
<tr>
<th>Title</th>
<th>Author</th>
<th>Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigating to the Your Recent History View - copy for Confluence 3.0</td>
<td>Giles Gaskell [Atlassian Technical Writer]</td>
<td>(4 minutes ago)</td>
</tr>
<tr>
<td>Navigating to the Your Recent History View</td>
<td>David Soul [Atlassian]</td>
<td>(20 Jan)</td>
</tr>
<tr>
<td>Your Recent History - copy for Confluence 3.0</td>
<td>Giles Gaskell [Atlassian Technical Writer]</td>
<td>(11 minutes ago)</td>
</tr>
<tr>
<td>Your Recent History</td>
<td>Giles Gaskell [Atlassian Technical Writer]</td>
<td>(13 Jan)</td>
</tr>
<tr>
<td>Viewing Space Activity - copy for Confluence 3.0</td>
<td>Giles Gaskell [Atlassian Technical Writer]</td>
<td>(28 minutes ago)</td>
</tr>
<tr>
<td>Viewing Space Activity</td>
<td>David Chui</td>
<td>(12 Oct)</td>
</tr>
<tr>
<td>Confluence Usage Tracking Plugin</td>
<td>Philip Cher</td>
<td>(30 Nov)</td>
</tr>
<tr>
<td>How Do I Get More Statistics From Confluence?</td>
<td>Matt Hodges [Atlassian]</td>
<td>(06 Apr)</td>
</tr>
<tr>
<td>Plugin Repository Macros</td>
<td>Giles Gaskell [Atlassian Technical Writer]</td>
<td>(07 Apr)</td>
</tr>
<tr>
<td>Popular Plugins Macro</td>
<td>Giles Gaskell [Atlassian Technical Writer]</td>
<td>(07 Apr)</td>
</tr>
</tbody>
</table>

**Notes**

- The list of recently-viewed pages records up to the last 20 pages visited.
- The list is cleared when you log out of Confluence or your Confluence session terminates.

**Related Topics**

- Working with Pages
- Confluence User's Guide

**Page History and Page Comparison Views**

Confluence tracks histories of changes to pages by maintaining a version of the page each time it is modified. It is easy to view changes between different versions and to restore a previous version if required.

**On this page:**

- Accessing the Page History View
- Viewing Changes in a Page History
- Page Comparison View
- Other Page History View Features
- Related Topics

**Accessing the Page History View**

To view the history of a page:

- Go to the page and choose Tools > Page History.
You can click a version number to view that version. To get back to the page history view, click View Page History.

**Screenshot: Page History View**

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Changed By</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>v. 41</td>
<td>Jul 07, 2009 11:33</td>
<td>Giles Gaskell [Atlassian Technical Writer]</td>
<td></td>
</tr>
<tr>
<td>CURRENT</td>
<td>Jul 07, 2009 11:33</td>
<td>Giles Gaskell [Atlassian Technical Writer]</td>
<td></td>
</tr>
</tbody>
</table>

When you are viewing a specific version of the page, the following functions are available:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>current version</td>
<td>View the latest version of the page.</td>
</tr>
<tr>
<td>Compare with Current</td>
<td>Compare the differences between the version of the page you are viewing and the current version.</td>
</tr>
<tr>
<td>Restore this Version</td>
<td>Restore the page version you are viewing to be the current version.</td>
</tr>
<tr>
<td>View Page History</td>
<td>Return to the list of page versions.</td>
</tr>
<tr>
<td>&lt;&lt; Previous or Next &gt;&gt;</td>
<td>View the previous or next page version, respectively.</td>
</tr>
</tbody>
</table>

**Viewing Changes in a Page History**

The page history view and page information view allow you to view recent changes made to a page or to compare the differences between any two versions of a page.

**Viewing Recent Changes**

**To view recent changes made to a page:**

1. Click view change at the top of the page below the page title. The page comparison view is displayed, showing the differences between the current version and the previous version.
   Or:
2. Choose Tools > Info to go to the ‘Information’ view for the page.
3. In the section titled ‘Recent Changes’ you will see the most recent versions of the page, along with the date of their modification and the name of the modifying author.
4. Click view changes beside the desired version. The page comparison view is displayed, showing the differences between the selected and previous versions.

**Comparing Two Different Versions of a Page**

**To compare two different versions of a page:**

1. Go to the page and choose Tools > Page History.
2. Select the versions you want to compare by selecting the check boxes beside them.
3. Click Compare selected versions. The page comparison view is displayed, showing the text differences between the selected versions.

**Page Comparison View**
The page comparison view shows the differences between selected page versions.

Key

On the page comparison view, the following key indicates the differences between the selected page versions:

<table>
<thead>
<tr>
<th>Highlight</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Added content</td>
</tr>
<tr>
<td>Red</td>
<td>Deleted content</td>
</tr>
<tr>
<td>Blue</td>
<td>Changed formatting</td>
</tr>
</tbody>
</table>

Screenshot: Comparing Changes

Interactive views

When a page comparison view is first displayed, all large sections of unchanged text are hidden and reduced to an ellipsis . . . .

You can view page changes between versions which are adjacent to your current page comparison view. Click the link containing:

- << to view the page comparison with the earlier adjacent version
- >> to view the page comparison with the more recent adjacent version.

For example, if your page comparison view is between v. 30 and v. 34 of a page, you can view changes between:

- v. 29 and v. 30 by clicking << Changes from 29 to 30
- v. 34 and v. 35 by clicking Changes from 34 to 35 >>

Other Page History View Features

You can also use the page history view to:

- View an older version of a page
- Restore an older version of a page
- View change comments

Related Topics

Viewing Page Information
Working with Pages
Tracking Updates

Take me back to the Confluence User's Guide.
Restoring an Older Version of a Page

To restore an older version of a page:

1. Go to the page and choose Tools > Page History.
2. Click Restore this version beside the version to restore.
3. Change the default comment if desired and click OK.

Notes

- All page history is retained. Restoring an older version creates a copy of that version. For example, in the screenshot below, if you selected v.39 and clicked Restore this version, a copy of v.39 would be created. This copy would be v.42 and would become the current version.
- You can click a version number’s link to view the contents of that page version.
- Select the check boxes of two different versions and click Compare selected versions to view the changes made between them.
- If you are viewing a specific page version, you can restore that version of the page by clicking Restore this Version on that page.
- To get back to the page history view, click View Page History.

Screenshot: Restoring an Older Version of a Page

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Changed By</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>CURRENT</td>
<td>Jul 07, 2009 11:33</td>
<td>Giles Gaskell [Atlassian Technical Writer]</td>
<td></td>
</tr>
<tr>
<td>v. 40</td>
<td>Jun 18, 2007 11:08</td>
<td>Rosie Jameson [Atlassian Technical Writer]</td>
<td>Restore this version</td>
</tr>
</tbody>
</table>

Related Topics

Page History and Page Comparison Views
Working with Pages

Take me back to the Confluence User's Guide.

Viewing an Older Version of a Page

Confluence keeps a history of all page changes. You can see what any of the previous versions of the page looked like, as well as link to them.

There are two ways that you can view an older version of a page.

- Using the 'View Change' link — this allows you to quickly check the most recent change to a page and the most recent version of the page, prior to the current version.
- Using the Page History — this allows you to look for a specific version of the page.

On this page:

- Viewing an Older Version of a Page using the 'View Change' Link
- Viewing an Older Version of a Page using the Page History
- Related Topics

Viewing an Older Version of a Page using the 'View Change' Link

To view an older version of a page using the 'View Change' link:
1. Go to the page and click **view change** (displayed under the page title).
2. Click the **Version ##** link in the top left-hand box to show the page content of the previous version.

**Notes**
- If you want to view an earlier version of the page, click the < link at the top left.
- If you want to send this page version to someone, simply copy and paste the URL from your browser. The link will look something like this: http://confluence.atlassian.com/pages/viewpage.action?pageId=12345.

**Viewing an Older Version of a Page using the Page History**

To view an older version of a page using the page history:

1. Go to the page and choose **Tools > Page History**. The 'Page History' view will open. Read more about viewing the page history on [Page History and Page Comparison Views](#).
2. Click a version number's link to view the contents of that page version. The following header will display across the top of the old version of the page:

When you are viewing a specific version of the page, the following functions are available:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>current version</td>
<td>View the latest version of the page.</td>
</tr>
<tr>
<td>Compare with Current</td>
<td>Compare the differences between the version of the page you are viewing and the current version.</td>
</tr>
<tr>
<td>Restore this Version</td>
<td>Restore the page version you are viewing to be the current version.</td>
</tr>
<tr>
<td>View Page History</td>
<td>Return to the list of page versions.</td>
</tr>
<tr>
<td>&lt;&lt; Previous or Next &gt;&gt;</td>
<td>View the previous or next page version, respectively.</td>
</tr>
</tbody>
</table>

If you want to send this page version to someone, simply copy and paste the URL from your browser. The link will look something like this: http://confluence.atlassian.com/pages/viewpage.action?pageId=12345.

**Related Topics**
- [Page History and Page Comparison Views](#)
- [Restoring an Older Version of a Page](#)
- [Recording Change Comments](#)

**Using a WebDAV Client to Work with Pages**

You can access Confluence content via a WebDAV client, such as 'My Network Places' in Microsoft Windows. Provided that you have permission, you will be able to read and write to spaces, pages and attachments in Confluence. You will be asked to log in and the standard Confluence content access permissions will apply to the equivalent content available through the WebDAV client.

Please refer to the page on [configuring and setting up a WebDAV client](#).
Working with Blog Posts

You can publish a blog post from any space in Confluence, provided you have permission. Blog posts may be announcements, journal entries, status reports, or any other timely information.

You can view the blog posts for a space by choosing Browse > Blog. Confluence catalogues the blog posts chronologically and allows you to browse blog posts for the space by navigating a calendar.

Creating and editing a blog post is just as easy as creating and editing any other page in Confluence. You can also let people know you care by liking a blog post.

Related pages:
- Subscribing to RSS Feeds within Confluence
- Managing Changes and Notifications and Tasks
- Blog Posts Macro
- Sharing Content
- Confluence User's Guide

What would you like to do?
- View blog posts
- Add blog posts
- Edit blog posts
- Link to blog posts
- Delete blog posts

Deleting Blog Posts

To delete blog posts, you require 'Remove Blog' permission which is assigned by a space administrator. See Space Permissions or contact a space administrator for more information.

To delete a blog post:

- Go to the blog post and choose Tools > Remove.
  * The Remove option is only displayed if you have permission to remove this blog post.

Handy Hint

Deleted blog posts are stored in the trash and can be recovered by a space administrator.

Related Topics
- Viewing Blog Posts
- Adding Blog Posts
- Editing Blog Posts
- Linking to Blog Posts

Take me back to Confluence User's Guide

Editing Blog Posts

To edit a blog post, you require the 'Create Blog' permission which is assigned by a space administrator. See Space Permissions or contact a space administrator for more information.

To edit a blog post:

1. Navigate to the space that has the blog post and choose Browse > Blog. A list of the most recent blog posts within the space is presented. A calendar allows you to browse earlier blog posts.
2. Locate the blog post and click Edit.
3. Make changes to the blog post.
4. *(optional)* Add a comment, in the text box below the editing pane, to describe your changes.
5. **Preview** your changes if desired, and click **Save**.

Editing a blog post is similar to **editing** any other page in Confluence. However, there are a few things to keep in mind:

- You cannot change the date of an existing blog post. You can only backdate when **adding a blog post**.
- You cannot move a blog post to another space.
- A blog post has no parent.

**Related Topics**

*Working with Blog Posts*
- Adding Blog Posts
- Deleting Blog Posts
- Blog Posts Macro

Take me back to **Confluence User's Guide**

**Viewing Blog Posts**

To view the blog posts within a space:

- Navigate to the desired space, and select **Browse > Blog**.

A list of the most recent blog posts within the space will be displayed, along with the date of each post and the name of its author. The blog posts for the month will be shown in a panel, next to the list of the most recent blog posts. The panel will also contain links to the previous and next month (e.g. ‘April 2010’), which you can use to browse blog posts from different months.
Working with Spaces

In Confluence, content is organised into spaces. There are two types of space:

- **Global** spaces are areas on your site into which you can group content items (pages, attachments, news, etc.) based on any subject or topic of your choice. For example, you may want separate areas on your site for each team or project within your organisation.
- **Personal** spaces belong to specific users. They can be kept private, or opened up so the whole world can view and edit them, just like global spaces. These spaces are listed in the People Directory. They are not listed on the 'All' tab on the dashboard.

What is a Space?

A space is an area within Confluence, containing your wiki pages. You can think of each space as a sub-site, or mini-site, each with its own home page.

Each space:

- Has its own pages, blog posts, comments, RSS feeds and mail (mail applies to global spaces only).
- Has its own access control settings. You can set different levels of access for different spaces.
- Can be separately exported to PDF, HTML or XML.

There is no limit to the number of global spaces you can create in Confluence.

On this page:

- What is a Space?
- Viewing the spaces in a Confluence site
- Guidelines for dividing content into spaces and pages
- Example: Favourite spaces as shown on the dashboard
- Notes

Related pages:

- Setting up a New Global Space
- Setting Up your Personal Space
- Viewing All Confluence Spaces
- Archiving a Space
- Deleting a Space
- Viewing Space Activity
- Using Labels to Categorise Spaces
- Administering a Space
- Confluence User's Guide

Viewing the spaces in a Confluence site

Confluence displays a list of spaces in the following locations:

- The dashboard displays a list of all the spaces in the Confluence site that you have permission to see. You can make a space a favourite, or categorise the space, to get easy access to the content that is most relevant to you. See Customising your Personal Dashboard.
- The space directory displays a list of all the global and personal spaces in the Confluence site that you have permission to see. You can choose to see all spaces, the spaces you have marked as favourite, or the spaces in a given space category. You can further restrict the number of spaces displayed, by entering a word or words in the Filter box. Confluence will display only the spaces that have the matching words in the space name or description. See Viewing All Confluence Spaces.
- The people directory displays a list of all Confluence users, including those who have personal spaces. See Searching the People Directory.
Guidelines for dividing content into spaces and pages

To ensure maintainable and logical spaces, consider the following points when allocating your content to pages and spaces:

- Group the content by topic, subject, project or team.
- Evaluate permissions across the wiki content. If members require conflicting access, for example John must access content on topics A and B, while Jane must access content for topics B and C, then the topics should be separated into three spaces.

Useful notes about spaces and pages:

- Spaces cannot be nested. You cannot have parent and child spaces, but you can have parent and child pages within a space.
- Page permissions can prevent users from accessing a specific page, even though they have permission to access the space.
- Page permissions alone cannot keep the existence of a page secret. The page should be in a restricted space instead.
- Pages can be moved between spaces.
- You can group related spaces, using space categories.

Example: Favourite spaces as shown on the dashboard

The screenshot below shows the area of the Confluence dashboard that displays the spaces that you have marked as favourite:

![Screenshot of Confluence dashboard showing favourite spaces](image)

Notes

A space key is a short, unique identifier for a space. For example, you might give your documentation space a key of "DOC". To find the key of an existing space, look at the Confluence URL for a page in the space. The standard Confluence URL has this format:
Viewing All Confluence Spaces
Quick guide to viewing spaces

- The **dashboard** displays a list of all the spaces in the Confluence site that you have permission to see. You can make a space a **favourite**, or **categorise the space**, to get easy access to the content that is most relevant to you. See [Customising your Personal Dashboard](http://my.confluence.site.com/display/SPACEKEY/Page+Name).

- The **space directory** displays a list of all the global and personal spaces in the Confluence site that you have permission to see. You can choose to see all spaces, the spaces you have marked as favourite, or the spaces in a given space category. You can further restrict the number of spaces displayed, by entering a word or words in the **Filter** box. Confluence will display only the spaces that have the matching words in the space name or description. See [Viewing All Confluence Spaces](http://my.confluence.site.com/display/SPACEKEY/Page+Name).

- The **people directory** displays a list of all Confluence users, including those who have personal spaces. See [Searching the People Directory](http://my.confluence.site.com/display/SPACEKEY/Page+Name).

On this page:

- Quick guide to viewing spaces
- Viewing spaces on the dashboard
- Viewing spaces in the space directory
- Viewing personal spaces in the people directory
- Notes

Related pages:

- Working with Spaces
- Archiving a Space
- Confluence User's Guide

Viewing spaces on the dashboard

The Confluence dashboard displays a list of spaces that you have permission to view. Remember to log in, so that you can see the complete list of spaces based on your username's permissions.

The **Spaces** tab displays all the global spaces on the site that you have permission to view, and the spaces you have marked as your **favourites**.

To see the spaces on the dashboard:

1. Choose **Dashboard** at the top left of your Confluence screen.
2. Scroll down and choose the **Spaces** tab.

Screenshot: Viewing spaces on the dashboard
Viewing spaces in the space directory

The space directory displays a list of global and personal spaces that you have permission to view. Remember to log in, so that you can see the complete list of spaces based on your username's permissions. The order of spaces is random.

**Categorising the spaces:** The spaces are displayed on a number of tabs, each showing a different set of spaces, as follows:

- **All Spaces** – Shows all the global and personal spaces on the site. The list excludes spaces that you do not have permission to view, and spaces that have been archived.
- **Global Spaces** – Excludes personal spaces.
- **Personal Spaces** – Shows only personal spaces.
- **Favourite Spaces** – Shows the spaces that you have marked as your favourites.
- **Various categories** – You will see a number of tabs showing spaces categorised by label. You can add any space category you like. See [Using Labels to Categorise Spaces](#).
- **Archived Spaces** – Shows all the global and personal spaces on the site that have been archived, and that you have permission to view.

**Filtering the list of spaces:** To restrict the number of spaces displayed, enter a word or words in the Filter box. Confluence will display only the spaces that have the matching words in the space name or description.

**To see the spaces in the space directory:**

2. Click one of the tabs to see the spaces you want.
3. If you want to restrict the number of spaces shown, entering a word or words in the Filter box.

*Screenshot: Viewing favourite spaces in the space directory*
Viewing personal spaces in the people directory

The people directory displays a list of Confluence users, including those who have personal spaces. See Searching the People Directory. It excludes spaces that have been archived.

To see the personal spaces in the people directory:

2. Choose People with Personal Spaces.

Notes

- If you do not log in, you will be treated as an ‘anonymous user’. Confluence will display only those spaces that an anonymous user has permission to see.
- Permission to access a space is granted by a space administrator. See the overview of space permissions.
- You can use the Spaces List macro to display a list of spaces on a Confluence page.
Setting up a New Global Space

To set up a new global space, you need the 'Create Space' permission. 'Create Space' is one of the global permissions that can be assigned by a Confluence administrator.

To create a new global space:

1. Click Add Space located above the list of global spaces on the dashboard, or at the top right of the dashboard, or at the top right of the space directory. The 'Create Space' dialog appears.
2. Enter the following information about your new space:
   - **Space name**: A name for the space. Space names do not have to be unique.
   - **Space key**: A simple key to identify your space (A-Z, a-z, 0-9). This key is a shorthand name for the space, used when linking content between spaces, for web URLs and for reports. For example, a 'Development Space' might have a space key of 'DEV'. The space key must be unique within the entire Confluence site.
   - **Make this space private**: A private space will be visible only to the person who created it. If you do not make it private, the space will have the default space permissions. The creator will have space administrator permissions on the new space, and can change the permissions at any time after creating the space.
3. Click Create. The home page for your new space is displayed. Note that the home page will automatically contain any default space content as defined by your Confluence administrator.

Next, you can choose a theme and start adding pages to your space.

Related pages:
- Working with Spaces
- Setting Up your Personal Space
- Editing Space Details
- Deleting a Space
- Confluence User’s Guide

Screenshot: Adding a global space to Confluence

Create space

Create a space for your team or project:

- **Space name**: Chocolate
- **Space key**: CHOC

Used in the space's URL:
http://localhost:8090/display/CHOC

- Make this space private

Create Cancel

Notes

A space administrator can change the permissions at any time after creating the space.
Setting Up your Personal Space

Your personal space is a place where you can publish your own pages and blog posts. Once you have set up your personal space, Confluence users can reach it by clicking your name in the People Directory. You can get to it by clicking your name at the top of the page and choosing ‘Personal Space’.

Creating your personal space

To set up your personal space, you need the ‘Personal Space’ permission which is assigned by a Confluence administrator. See Giving People Access to Content and Global Permissions Overview.

To create your personal space:

1. Click your name at the top of the page. (This is the ‘user’ menu.)
2. Choose Add Personal Space from the dropdown list. The ‘Add your personal space’ dialog will open.
3. Indicate whether your space should be private or not. A private space will be visible only to you. If you do not make it private, the space will have the default space permissions. Note that you can change these settings again later. You will have space administrator permissions on your space.
4. Click Create.
5. The home page of your new space will appear. Your home page will contain any default space content as defined by your Confluence administrator. You can change this content at any time.
Now you can start adding pages to your personal space. You may also want to upload your photo.

Changing the look and feel of your space

If you like, you can apply a different theme to your personal space, or modify its colour scheme.

Granting access to your space

When you created the space, you set the option to make your space private, or to allow other people to view and contribute content to your space. You can change the permissions on your space at any time.

Watching updates made in your space

By default, Confluence assigns you as a watcher of your space. This means that you will receive an email notification each time someone adds or updates content in your space. You can stop watching the space (see Watching a Space) and change your notification settings at any time.

Administering a Space

This page gives an overview of the administration functions available in global and personal spaces. You need to be a space administrator to perform space administration functions.

Administering a global space

To view the space administration menu:

1. Go to a page in the space you wish to manage.
2. Choose Browse > Space Admin.
   Note: ‘Space Admin’ is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
3. Choose a link from the options available in the left-hand panel.

For global spaces, the options available are divided the following categories:

- **Space Operations**
  - Space Details – See Editing Space Details.
  - Space Labels – See Using Labels to Categorise Spaces.
  - Remove Space – See Deleting a Space.
  - Trash – See Purging Deleted Pages and Restoring a Deleted Page.
- **Security**
  - Permissions – See Assigning Space Permissions.
  - Restricted Pages – See Viewing Restricted Pages.
- **Mail**
  - Mail Accounts – See Archiving Mail Overview.
  - Mailbox Import – See Importing Mail.
- **Look and Feel**
  - Themes – See Applying a Theme to a Space.
  - Colour Scheme – See Editing a Space's Colour Scheme.
  - Layout – See Customising Space Layouts.
Administering a personal space

To view the space administration menu:

1. Go to a page in the personal space that you wish to manage.
2. Choose Browse > Space Admin.
   
   Note: ‘Space Admin’ is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
3. Choose a link from the options available in the left-hand panel.

For personal spaces, the options are divided into the following categories:

- **Space Operations**
  - Space Details – See Editing Space Details.
  - Space Labels – See Using Labels to Categorise Spaces.
  - Remove Space – See Deleting a Space.
  - Trash – See Purging Deleted Pages and Restoring a Deleted Page.

- **Security**
  - View or set space permissions
  - View restricted pages

- **Look and Feel**
  - Themes – See Applying a Theme to a Space.
  - Colour Scheme – See Editing a Space's Colour Scheme.
  - Layout – See Customising Space Layouts.
  - Stylesheet – See Styling Confluence with CSS.
  - PDF Layout – See Customising Exports to PDF.
  - PDF Stylesheet – See Customising Exports to PDF.

Editing Space Details

You need to be a space administrator for the space, to edit the details of that space.

To edit the details of a space:

1. Go to a page in the space you wish to archive.
2. Choose Browse > Space Admin.

   Note: ‘Space Admin’ is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
3. The 'Edit Space Details' screen appears. You can:
   - Change the name of the space.
   - Change the description of the space.
   - Change the status of the space from 'Current' to ' Archived' or back again. See Archiving a Space.
   - Select a new home page for the space. The home page is the default page to which users are directed when they click the link to the space from the Dashboard.

   Note: If you set this field to blank (no selection) then the default home page will be the 'Pages' tab of the 'Browse Space' screen for that space.
4. Choose Save.
Notes

- You cannot edit the key or the space creator's name.
- The Edit Space Details fields do not accept wiki markup. Any wiki markup entered in these fields will be displayed as plain text.

Deleting a Space

Deleting a space permanently removes the space and all of its contents. You need to be the space administrator of a space to delete that space.

Note: Deleting a space is permanent. Always create an XML backup of the space before proceeding. Once you have deleted the space, there is no way to restore it unless you have made an XML space backup.

To delete a space:

1. Go to a page in the space you wish to delete.
2. Choose Browse > Space Admin.
   Note: 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
3. Choose Remove Space in the left-hand panel.
4. Choose OK.

Notes

There is a problem in some versions of Confluence, where space deletion does not work. See issue [CONF-26122 - Authenticate](#) to see issue details. If you like, you can watch that issue to be informed of progress.

Backing Up and Restoring a Space

Confluence can back up all the content, comments and attachments for a space. The process involves converting the data in the space into XML format. The end product is a zip file that contains XML file(s) that define the content of the space, and optionally a folder containing the attachments in the space. To transfer this data to another Confluence site, you can upload the zip file.

Creating a space backup

See [Exporting Confluence Pages and Spaces to XML](#).

Restoring (importing) a space backup

See [Restoring a Space](#).

Archiving a Space

You can archive a space, so that its content is less visible but still available on your Confluence site. You need to
be a space administrator to archive a space. You can change a space's status from archived to current at any time.

**The effect of archiving a space**

If a space is archived:

- The pages and other content do not appear in the Confluence quick navigation aid, which drops down when you enter text in the search box.
- By default, the pages and other content do not appear in the Confluence search results. If a Confluence site contains any archived spaces, the search screen will provide an option to include them in the search results.
- The space and its pages do not appear on the dashboard.
- Updates to the space's content do not appear in activity streams, such as the recent updates section of the dashboard.
- The space does not appear in space-selection dropdown menus. Similarly, its pages and other content do not appear in any dropdown menus in the Confluence user interface.
- In the space directory, the archived space will no longer appear in the general space lists. Archived spaces will appear on the 'archived spaces' tab. They will also appear on the category tabs, as determined by their labels.

These functions remain available for archived spaces:

- People can view the content as usual, by following a link or typing in a URL belonging to the archived space.
- People can edit the content as usual, as determined by the space permissions.
- RSS feeds, watches and notifications remain active.

**On this page:**

- The effect of archiving a space
- Archiving a space
- Notes

**Related pages:**

- Working with Spaces
- Deleting a Space
- Confluence User's Guide

**Archiving a space**

**To archive a space:**

1. Go to a page in the space you wish to archive.
2. Choose Browse > Space Admin.
   
   *Note:* 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
3. The 'Edit Space Details' screen appears. Select Archived in the Status dropdown menu.
4. Choose Save.

**Notes**

Archiving a space has no effect on search results of external search engines. For example, the space will still appear in Google search results.

**Screenshot: An archived space**
Viewing Space Activity

Note that the space activity information is disabled by default. See notes below.

If enabled, the space activity screen displays statistics on the activity in each space. These include:

- How many pages and blog posts have been viewed, added or updated over a given period.
- Which content is the most popular (most frequently viewed).
- Which content is the most active (most frequently edited).
- Which people are the most active contributors/editors of content.

To view the activity in a space:

1. Navigate to any page in the space and choose Browse > Space Admin.
2. Go to the Activity tab.

Confluence will show a graphic display of the number of pages and blog posts that have been viewed, added and edited, showing trends over a period of time. For example:
Activity for week starting 31 December 2006

Period: month | week | day  Week: << Previous | Now | Next >>
See also: Global Confluence activity

Viewing

This graph shows how many times pages and news posts have been viewed over the current time period.

Screenshot 1: Number of viewed pages and blog posts in a week

The top ten most popular and most active pages and/or blog posts will be listed, with a link to each.

Most popular content (Views)

1. Confluence Documentation Home (2262)
2. Set JAVA_HOME variable in Windows (1180)
3. Confluence Installation Guide (687)
4. Remote API Specification (467)
5. User Macros (436)
6. installing Confluence Standalone (385)
7. JIRA Issue Macro (370)
8. Administrators Guide (353)
9. Dynamic Tasklist Macro (335)
10. Frequently Asked Questions (320)

Screenshot 2: Popular content

Notes

- The Confluence Usage Stats plugin, which provides the 'Space Activity' screen, is known to cause performance problems on large installations. This plugin is disabled by default. A status report on the progress of the performance issues with this plugin is available in this issue: USGTRK-15.
- Your Confluence system administrator can enable the plugin, but please be aware of the possible impact upon your site's performance.
- The plugin is sometimes called 'Confluence Usage Tracking'.
- If your Confluence site is clustered, the space activity information will not be available.

Related Topics
Viewing Recently Updated Content

The 'Recently Updated' view is a useful way of keeping track of the changes being made in a space. It displays links to the most recently added or modified content within the space including pages, blog posts, mail messages and comments.

To view the recently updated content in a space:

1. Choose Browse > Pages.
2. Choose Recently Updated. A list of the most recently added or modified content in the space is displayed. Choose a link to open the corresponding document.

Archiving Mail Overview

Confluence Mail Archiving is an optional feature. This means that the Mail elements will not appear in the Confluence user interface by default. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, activate the plugin from Confluence Admin > Plugins > Show System Plugins > Confluence Mail Archiving Plugin.

Confluence allows you to collect and archive mail within each space individually. This is a useful facility that allows you to archive all emails pertaining to a particular project on Confluence alongside it in the same space.

You can download mail from one or more pop-accounts. You can also import mail from mbox files either on your local system or on the Confluence server.

Choose Browse > Mail to see archived mail.

(If you are not a space administrator for the target space, contact your Confluence administrator to request Space Admin permission.)

From here, you can navigate mail easily and also use the Quick Search to search mail and the attachments it contains.

What would you like to do?

Add a Mail Account
Manage Mail accounts
Import Mail
View Mail
The ability to archive mail applies only to global spaces, not personal spaces. Please see Working with Spaces for information about the differences between global spaces and personal spaces.

Related Topics

Take me back to the Confluence User's Guide.

Adding a Mail Account

Confluence Mail Archiving is an optional feature. This means that the Mail elements will not appear in the Confluence user interface by default. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, activate the plugin from Confluence Admin > Plugins > Show System Plugins > Confluence Mail Archiving Plugin.

When you add a mail account, you are configuring Confluence to download mail from that account and archive the mail within the space. Since Confluence removes emails from an email account as it is added to the Mail Archive, Confluence must be set up to poll a clone email account rather than the actual account. For example, to archive the actual account sales@company.com to your Confluence Sales space, you must first create a clone account such as conf-sales@company.com that contains the same email content.

The information on this page does not apply to Confluence OnDemand.

Stage 1 - Creating A Clone Email Account

1. Add a new email account on the mail server with the clone email address.
2. Copy all existing emails from the actual account to the clone account.
3. Set up the actual account to bcc sent emails to the clone account.
4. Set up the actual account to forward received emails to the clone account.

Stage 2 - Archive Clone Account To Mail Archive

1. If you are not a space administrator for the target space, contact your Confluence administrator to request Space Admin permission. You need to be a space administrator before you can add a mail account to the space.
2. Go to Browse > Mail.
3. Click on Mail Accounts under the heading 'Mail' in the left panel to show the list of existing mail accounts.
4. Click Add mail account located at the top of the page.
5. Enter configuration details for the account. The protocol may be POP/S or IMAP/S. Click Create when finished.

- **Account Name:** Enter a name for this account by which it will be known in Confluence.
- **Description:** Provide a description for this account (Optional).
- **Protocol:** Choose from POP, IMAP, POPS or IMAPS
- **Hostname:** Enter the account mail server host name.
- **Port:** The mail server's port number will be displayed by default. Do not edit this field.
- **Username:** Enter a username for this account.
- **Password:** The account's password.
Configured accounts will have their mail downloaded and removed from the server, so make sure you are downloading from a clone account.

Note: The ability to import mail applies only to global spaces, so the 'Import' section does not appear in the 'Space Admin' tab for personal spaces. Please see Working with Spaces for information about the differences between global spaces and personal spaces.

Related Topics
- Archiving Mail Overview
- Managing Mail Accounts
- Importing Mail
- Viewing Mail
- Fetching Mail
- Deleting Mail
- How Do I Check Which Spaces Have Email Accounts?
- How Do I Disable Automatic Mail Polling?

Take me back to Confluence User's Guide

Deleting Mail

To delete mail for a space, you require 'Remove Mail' permission which is assigned by a space administrator from the Space Administration screens. See Space Permissions.

Only a space administrator can delete all email messages for the space simultaneously.

To delete mail for a space:

1. Go to Browse > Mail.
2. Go to the Mail tab. A list of messages in the space is displayed in reverse chronological order.
3. Delete an individual email by clicking the trash icon beside it. Deleted mail is stored under Trash and can be restored by a space administrator from the Space Admin tab.
   If you are a space administrator, you can delete all email messages within a space at once by clicking on the Delete All link at the top of the mail view.

Notes
- Email messages deleted using the Delete All option cannot be restored.
- Confluence Mail Archiving is an optional feature. This means that the Mail elements will not appear in the Confluence user interface by default. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, activate the plugin from Confluence Admin > Plugins > Show System Plugins > Confluence Mail Archiving Plugin.

Related Topics
- Restoring Mail
- Archiving Mail Overview
- Confluence User's Guide

Fetching Mail

Confluence Mail Archiving is an optional feature. This means that the Mail elements will not appear in the Confluence user interface by default. Mail archiving features are contained in a bundled plugin. To activate mail
To manually retrieve mail:

1. Go to Browse > Mail.
2. Go to the Mail tab. A list of messages for the space is displayed in reverse chronological order.
3. Click on the Fetch new mail link located above the list of messages. Any new messages will be displayed in order of most recent first.

**Note**

Once mail is fetched, it will be removed from the server.

Related Topics

- Viewing Mail
- Archiving Mail Overview
- Deleting Mail
- How Do I Disable Automatic Mail Polling?

Take me back to the Confluence User's Guide.

**Importing Mail**

**Confluence Mail Archiving is an optional feature.** This means that the Mail elements will not appear in the Confluence user interface by default. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, activate the plugin from Confluence Admin > Plugins > Show System Plugins > Confluence Mail Archiving Plugin.

Confluence allows you to import mail from mbox files located either on your local system or on the Confluence server and archive it within the space.

You need to be a space administrator to import mail for a space.

**To import mail from mbox files:**

1. Go to Browse > Mail.
2. Click on Mail Import under the heading 'Mail' in the left panel.
   - To import from a Local system, click Browse to select the mbox file. Then click Import.
   - To import from the Server, enter the location of the mbox file on the server in the Server text field and click Import.

The ability to import mail applies only to global spaces, so the 'Import' section in the above screenshot does not appear in the 'Space Admin' tab for personal spaces. Please see Working with Spaces for information about the differences between global spaces and personal spaces.
Managing Mail Accounts

**Confluence Mail Archiving is an optional feature.** This means that the Mail elements will not appear in the Confluence user interface by default. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, activate the plugin from Confluence Admin > Plugins > Show System Plugins > Confluence Mail Archiving Plugin.

You need to be a space administrator to manage mail accounts for a space.

![Warning icon: The information on this page does not apply to Confluence OnDemand.](image)

To manage mail accounts:

1. Go to Browse > Mail.
2. Click on Mail Accounts under the heading 'Mail' in the left panel. For each of the mail accounts listed, you can:
   - **Edit**: change the configuration settings for the mail account.
   - **Remove**: remove the account permanently.
   - **Disable**: temporarily disable the account.

**Screenshot: Managing mail accounts**

![Table with mail accounts](image)

**Related Topics**

Archiving Mail Overview
Adding a Mail Account
Importing Mail
Viewing Mail
Fetching Mail
Deleting Mail
Restoring Mail

Take me back to the Confluence User's Guide.

Restoring Mail

Deleted email messages are stored under 'Trash' and can be restored by a space administrator from the Space Administration screens.

You can only restore an email message from trash if it was deleted individually and not using the 'Remove All' operation.
To restore mail:

1. Navigate to any page in the space and choose **Browse > Space Admin**.
2. Choose **Trash** in the left-hand panel. A list of pages and email messages deleted from the space is displayed.
3. Choose **Restore** beside the email message you want to restore.
4. To view the restored email message, choose **Browse > Mail**.

Notes

**Confluence Mail Archiving is an optional feature.** This means that the Mail elements will not appear in the Confluence user interface by default. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, activate the plugin from **Confluence Admin > Plugins > Show System Plugins > Confluence Mail Archiving Plugin**.

Related topics

- **Viewing Mail**
- **Fetching Mail**
- **Deleting Mail**
- **Confluence User's Guide**

Viewing Mail

**Confluence Mail Archiving is an optional feature.** This means that the Mail elements will not appear in the Confluence user interface by default. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, activate the plugin from **Confluence Admin > Plugins > Show System Plugins > Confluence Mail Archiving Plugin**.

In Confluence, each global space can be set up to archive mail.

To view mail messages archived within a particular space:

1. Navigate to any page in the space and choose **Browse > Space Admin**.
2. Click on the **Mail** tab. The mail is displayed in reverse chronological order with a default of 30 mails per page. You can move between pages by clicking the **<< Previous** and **Next >>** links or by selecting a particular page number.
3. Click on a mail message to view its contents.

> The information on this page does not apply to Confluence OnDemand.

If you are a **space administrator**, or have been given permission to delete mail messages, you can also delete emails from here.

Navigating Mail:

**Find More** These links links at the top of an email message let you search for other emails from the same author or on the same subject.

**Attachments** This link located below the email body allows you to view mail attachments. The link is only displayed if any attachments exist.

**Entire Thread** This link allows you to view the mail's thread, if one exists.

The 'Mail Operations' panel is located to the right of the mail view and displays links to:

- **Entire Thread**: View the thread that this mail belongs to. This option is only available when the mail belongs to a thread.
- **Next By Date**: Navigate to the next message.
**Previous By Date:** Navigate to the previous message.
**Remove Mail:** Remove the current mail from the space.
**Mail Archive:** Go to the mail archive view for this space.

**Screenshot : Navigating mail**

Subject: Sample content for thread demo (find more)
From: David Loeng <dave@edessian.com> (find more)
Date: Nov 21, 2004

---


Fusce ac magna. Suspendisse euismod libero eget mauris.

---

**Handy Hint**

Use the **Quick Search** facility to quickly locate a mail

---

**Related Topics**

- Archiving Mail Overview
- Viewing Mail
- Fetching Mail
- Deleting Mail
- How Do I Disable Automatic Mail Polling?

Take me back to the [Confluence User's Guide](#).

## Working with Confluence Labels

Labels are key words or tags that you can add to pages, blog posts, attachments and spaces. You can define your own labels and use them to categorise, identify or bookmark content in Confluence.

For example, you could assign the label 'accounting' to all accounts-related pages on the site. You can then browse all pages with that label in a single space or across the site, or display a list of pages with that label. You can search based on the label, or use it to filter items when you subscribe to a Confluence RSS feed.

Because labels are user-defined, you can add any word that helps you identify the content in the site.

You can add or remove labels without affecting the page content.

### Content labels

You can add labels to pages, blog posts and attachments. Any user with permission to view the page can also view its labels. See [Adding Labels](#).
Space labels and space categories

You can also apply labels to spaces and use them to categorise your spaces. See Using Labels to Categorise Spaces.

Advantages of labels

Here are some of the advantages of using labels:

- Labels are user-defined which means that you decide what information is relevant to you and how you are going to label it.
- You can group pages and spaces without having to restructure the site.
- Labels are easy to add and edit, and do not affect the content of the page.
- You can add as many labels as you like to a page or space.

Using labels

- Adding Labels
- Using Labels to Categorise Spaces
- Removing Labels
- Using Label Macros to Categorise Wiki Content
- Viewing Labels and Labelled Content

Notes

Note: Personal labels are deprecated: Earlier versions of Confluence recognised a special type of label called a `personal' label. A personal label starts with `my:' and is only visible to the user who created it. We are removing personal labels from Confluence, as announced in the Confluence 4.1 Upgrade Notes. The functionality for personal labels is still in Confluence, but we recommend that you stop using them. In a future release, we plan to remove the functionality altogether.

Adding Labels

Labels are key words or tags that you can add to pages, blog posts, attachments and spaces. You can define your own labels and use them to categorise, identify or bookmark content.

Labelling a page or blog post

Any user with permission to edit a page can add a label to a page.
To add a label to a page or blog post:

1. Go to the page. If the page already has labels, these will be listed at the bottom of the page, below the page content.
2. Click the edit icon beside the list of labels, or press L on your keyboard.
3. Type in a new label. Existing labels are suggested as you type.
4. Click Add.

On this page:
- Labelling a page or blog post
- Labelling an attachment
- Notes

Related pages:
- Removing Labels
- Viewing Labels and Labelled Content
- Using Label Macros to Categorise Wiki Content
- Using Labels to Categorise Spaces
- Confluence User's Guide

Screenshot 1: Labels as they are displayed on a page

Screenshot 2: Adding a label to a page or blog post

Labelling an attachment

Any user who has permission to view or edit the page that contains the attachment can add a label to the attachment.

To add a label to an attachment:

1. Go to the page that contains the attachment. Choose Tools > Attachments.
2. Alternatively, go to the attachments view of the space:
   - Go to a page in the space and choose Browse > Attachments.
3. You will see a list of attachments, with columns for attachment name and other details. If the attachment already has labels, these will be listed in the Labels column.
4. Click the edit icon beside the list of labels.
5. Type in a new label. Existing labels are suggested as you type.
6. Click **Add**.

You can also add labels in a list of attachments displayed by the **Attachments macro**, by clicking the edit icon beside each label as described above.

*Screenshot 2: Adding a label to an attachment*

**Notes**

- **Note: Personal labels are deprecated**: Earlier versions of Confluence recognised a special type of label called a 'personal' label. A personal label starts with 'my:' and is only visible to the user who created it. We are removing personal labels from Confluence, as announced in the **Confluence 4.1 Upgrade Notes**. The functionality for personal labels is still in Confluence, but we recommend that you stop using them. In a future release, we plan to remove the functionality altogether.
- If you add a label to a template, that label will be copied to the page when someone adds a page based on that template. See **Adding a Template**.

**Using Labels to Categorise Spaces**

Confluence provides the following types of space label:

- **Space labels**. A space label can be used to group related spaces for display by the **Content by Label macro**, and for ranking search results. You use space labels in a similar way to global labels.
- **Space categories**. A 'space category' is a special type of space label that Confluence uses to group spaces in the **space directory**, and in the recent activity area of the **dashboard**. The rest of this page describes space categories.

Note that you can only set up space categories if you are a space administrator for that space, or you are a Confluence system administrator.

**Using Space Categories**

Here is an example of using space categories. Let's assume that you have one or more spaces that your Sales team may be interested in. You can use the category 'sales' to group those spaces together.

1. First add the 'sales' category to the relevant spaces, as described below.
2. Then, in the space directory, you can click the relevant tab to see only the spaces with the chosen label. See **Viewing All Confluence Spaces**.
3. And, you can see updated content in those spaces by choosing the 'sales' category under the **Space Categories** tab in the recent activity area of the dashboard. See **Customising your Personal Dashboard**.
Categorising a Space

When you categorise a space, you add a ‘space category’ to the space. A category cannot exist if there are no spaces labelled with that category.

To categorise a space:

1. Navigate to the space you wish to categorize.
2. Choose Browse > Space Admin.
   *Note:* ‘Space Admin’ is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
3. Click Space Labels in the left-hand panel.
4. Under ‘Space Categories’, enter your category name and click Add.
   Alternatively, click a category in the list of ‘Suggested Space Categories’ displayed on the screen.

Removing a Space from a Category

Removing a space from a category is the same thing as removing the category from the space.

To remove a space from category:

1. Navigate to the space you wish to remove the category from.
2. Choose Browse > Space Admin.
   *Note:* ‘Space Admin’ is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
3. Click Space Labels in the left-hand panel.
4. Click the x next to the space category.

Removing an Entire Space Category

To remove a whole space category from Confluence, just remove that category from all spaces, as described above. A category cannot exist if there are no spaces labelled with that category. The space category will disappear from the dashboard and space directory.

To remove an entire space category from Confluence:

2. Click the tab corresponding to the space category that you want to remove.
3. You will see a list of all spaces in that category. Click the spaces one by one, and remove the category from each space, as described above.

Screenshot: Space labels and space categories
Related Topics

- Working with Confluence Labels
- Viewing All Confluence Spaces

Take me back to the Confluence User's Guide.

Removing Labels

Labels are key words or tags that you can add to pages, blog posts and attachments. You can define your own labels and use them to categorise, identify or bookmark content in Confluence. You can see the existing labels, and the pages which contain the labels, by viewing labels and labelled content.

Removing labels in Confluence

To remove a label from a page or blog post:

1. Go to the page that contains the label. You will see the labels at the bottom of the page below the page content.
2. Choose the edit icon beside the list of labels, or press L on your keyboard.
3. In the 'Labels' dialog, choose the X next to a label to remove that label.
4. Choose Close.
To remove a label from an attachment:

1. Go to the page that contains the attachment. Choose Tools > Attachments.
2. Alternatively, go to the attachments view of the space:
   Go to a page in the space and choose Browse > Attachments.
3. You will see a list of attachments, with columns for the attachment name and other details. If the attachment already has labels, these will be listed in the Labels column.
4. Choose the edit icon beside the list of labels.
5. In the 'Labels' dialog, choose the X next to a label to remove that label.
6. Choose Close.

When you have removed the label from all content, the label will disappear from the labels view in the space too.

Notes

- **Deleted pages containing labels**: If you have deleted pages that contain a label, you may need to purge the deleted pages from the space's trash to ensure that the label disappears too.
- **Bulk removal of labels**: There is no way to remove a number of labels at once, via the Confluence user interface. Instead, we suggest that you use the Confluence Command Line Interface. See the 'removeLabels' action described in the CLI documentation. For an introduction to the CLI, see this blog post: Confluence CLI for bulk actions like deleting or publishing pages.

Using Label Macros to Categorise Wiki Content

Using labels, you can categorise pages and refer to content across multiple categories, pages and even spaces.

Example

For the purpose of this example, imagine we have a space with pages of content on various type of vehicles. Pages are shown in bold text, while the labels are in blue.

- **Cars** vehicle-type
  - Toyota Prius vehicle car
  - Honda Civic vehicle car
  - Porsche Carrera vehicle car
- **Motorbikes** vehicle-type
  - Harley Davidson Sportster vehicle motorbike
  - Suzuki GSX-R vehicle motorbike

This page hierarchy can then be categorised using labels, with pages referenced using the Content by Label Macro.

<table>
<thead>
<tr>
<th>If you want to list...</th>
<th>You would use this label:</th>
<th>These would be the pages that you would get:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vehicle types</td>
<td>vehicle-type</td>
<td>Cars, Motorbikes</td>
</tr>
<tr>
<td>All vehicles</td>
<td>vehicle</td>
<td>Toyota Prius, Honda Civic, Porshe Carrera, Harley Davidson Sportster, Suzuki GSX-R</td>
</tr>
<tr>
<td>-------------</td>
<td>---------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>All cars</td>
<td>car</td>
<td>Toyota Prius, Honda Civic, Porshe Carrera</td>
</tr>
</tbody>
</table>

**Related pages:**
- [Working with Confluence Labels](#)
- [Working with Macros](#)
- [Confluence User's Guide](#)

### Label Macros

**Navmap Macro**

The [Navigation Map Macro](#) renders the list of pages associated with a specified label as a navigation map.

**Related Labels Macro**

The [Related Labels Macro](#) lists labels commonly associated with the current page's labels.

**Content by Label Macro**

The [Content by Label Macro](#) displays a list of content marked with specified labels.

**Labels List Macro**

The [Labels List Macro](#) lists all labels of a space, grouped alphabetically.

**Recently Used Labels Macro**

The [Recently Used Labels Macro](#) lists labels most recently used in a specified scope (global, space, or personal).

**Popular Labels Macro**

The [Popular Labels Macro](#) displays popular labels in a list or in a heatmap (also called a cloud).

### Viewing Labels and Labelled Content

Labels are key words or tags that you can add to pages, blog posts, attachments and spaces. You can define your own labels and use them to categorise, identify or bookmark content in Confluence. This page describes a few ways of viewing labels and labelled content. The focus of this page is global labels. You may also be interested in [viewing personal labels](#).

### Finding the labels view

If you see a label on a page, blog post or attachment, click it to go to the labels view. Global labels are visible to all users with 'view' permission on the page, and personal labels are visible only to the person who added them.

- Any page or blog post that has labels will have them listed together in a block at the bottom of the page.
- You will also see labels in the 'Attachments' view or in a listing of attachments provided by the Attachments macro. (See [Displaying a List of Attachments](#).)

To find the labels view by clicking a label:
If you are in a page that has labels, click a label.

- If it is a personal label (starts with 'my:') you will go to the personal labels page in your user profile. See Viewing Personal Labels.
- If it is a global label, you will go to the 'Labels' tab of the space. You will see all labels for that space.

Screenshot 1: Labels as they are displayed on a page

To find the labels view from the menu:

Go to a page in the space and choose Browse > Labels.

On this page:

- Finding the labels view
- Using the labels view
- Searching for labels
- Navigating pages by URL and label

Related pages:

- Viewing Personal Labels
- Searching Confluence
- Confluence User's Guide

Using the labels view

The labels view in a space offers the following options:

- Popular Labels: Click this option to see a list of the most frequently used labels in that space. From here, you can also view the most popular labels across the site. The bigger the font size, the more popular the label.
- All Labels: View all labels in the space. From this view, you can click on a link to view an alphabetical listing of all labels across the site. Clicking on a label will list all content in the space with that label. It will also display any related labels if they exist. Related labels are labels that frequently appear on pages together. For example, if pages labelled with 'sales' also tend to have the label 'marketing', these will be displayed as related labels.
- See content from all spaces: Expand the list of labels to include pages and other labelled content from all spaces.

Screenshot 2: The labels view of the space
Searching for labels

A quick way to find labelled content is to search for it. If there is a label matching your query, you will see it in the panel titled **Browse Labels** in the search results. Click the label to see all content in the site with that label.

**Screenshot 3: Searching for labelled content**

**Advanced label searching**

Use the 'labelText:' prefix to search specifically for page labels. The table below gives examples of search terms that you can enter into Confluence's search box, and the search results that you can expect.

<table>
<thead>
<tr>
<th>Searching for ...</th>
<th>Returns content that ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>labelText: example</td>
<td>...</td>
</tr>
<tr>
<td>labelText: admin</td>
<td>...</td>
</tr>
<tr>
<td>labelText: doc</td>
<td>...</td>
</tr>
<tr>
<td>labelText: install</td>
<td>...</td>
</tr>
<tr>
<td>labelText: label</td>
<td>...</td>
</tr>
<tr>
<td>labelText: conf</td>
<td>...</td>
</tr>
</tbody>
</table>
Navigating pages by URL and label

This section describes how to move around your Confluence pages by adding and subtracting labels from the list of labels that you want to match. You can search for matching labels by entering a URL. You can also add and subtract labels from the search.

To search labelled pages by typing a URL:

1. Open a new web browser window.
2. In the address bar of your web browser, type an URL such as:
   
   http://CONFLUENCE_HOSTNAME/label/foo+bar
3. Press Enter.
4. The 'View Labels' page will load, showing search results for pages with the labels 'foo' and 'bar'.

Adding a label to your results:

- Click a label from the Related Labels list (at the top left).
- A new page loads, showing pages that contain all of the labels selected so far. You can continue to add labels to the results in this way.

Subtracting a label from your search results:

Once two labels are in use, links to subtract a label from the search appear at the end of the labels list. These are easily identified because these links have a preceding minus sign, like this:

```
- education
```

Screenshot 4: Labels view with links for subtracting labels

Viewing Personal Labels

Any page that has labels (global or personal) will have them listed at the bottom of the page. Personal labels
start with 'my:', and are only visible to the user that created them.

**Note: Personal labels are deprecated:** We are removing personal labels from Confluence, as announced in the [Confluence 4.1 Upgrade Notes](https://confluence.atlassian.com/display/C41/Upgrade+Notes+4.1). The functionality for personal labels is still in Confluence, but we recommend that you stop using them. In a future release, we plan to remove the functionality altogether.

**To view your personal labels:**

- If you are on a page that has personal labels, click one of those labels to get to the screen showing all your personal labels.
- Alternatively, visit the URL: `<your Confluence site>/users/viewmylabels.action`. For example: [http://confluence.atlassian.com/users/viewmylabels.action](http://confluence.atlassian.com/users/viewmylabels.action)

You will see a list of your personal labels along with the pages that contain the label, as shown in the screenshot below.

---

**Related pages:**

- [Adding Labels](https://confluence.atlassian.com/display/C41/Adding+Labels)
- [Viewing Labels and Labelled Content](https://confluence.atlassian.com/display/C41/Viewing+Labels+and+Labelled+Content)
- [Confluence User's Guide](https://confluence.atlassian.com/display/C41/Confluence+User%27s+Guide)

---

**Screenshot: Viewing personal labels**

---

**Working with Favourites**

The **Favourites** feature provides a convenient way to quickly access specific pages or spaces that interest you, as soon as you log in to Confluence. Pages and spaces that you have added to your list of favourites are easily accessible from your Dashboard and from within your user profile area.

---

**Related pages:**

- [Dashboard](https://confluence.atlassian.com/display/C41/Dashboard)
- [User Profile Overview](https://confluence.atlassian.com/display/C41/User+Profile+Overview)
- [Likes and Popular Content](https://confluence.atlassian.com/display/C41/Likes+and+Popular+Content)
- [Confluence User's Guide](https://confluence.atlassian.com/display/C41/Confluence+User%27s+Guide)

---

**What do you want to do?**

- Adding Favourites
- Viewing Favourites
Adding Favourites

To add a page as a favourite:

1. Go to the page.
2. Choose Tools > Favourite.
   This will change to ⭐ Favourite (when you next open the Tools menu) to indicate that you have added this page as a favourite.

To add a global space as a favourite:

1. Go to the Dashboard.
2. Click the Spaces tab.
3. Click the star icon '⭐' located beside the space name in the list of global spaces.
   This will change to '⭐' to indicate that you have added this global space as a favourite.

To add a personal space as a favourite:

1. If a person has not yet created a personal space, then you will not be able to perform this procedure. Furthermore, these options will not be available to you.

   2. Click on a person's name or profile picture to view their personal space.
   3. Go to a page in the space and choose Browse > Advanced.
   4. Click on ⭐ Add Space to Favourites in the left-hand panel.
      This will change to ⭐ Remove Space from Favourites to indicate that you have added that person's personal space as a favourite.

Once you have added a personal space to your list of favourites, that personal space will be added to your list of favourite spaces, which can be accessed from the dashboard or your profile.

For more information about global spaces and personal spaces, see Working with Spaces.

Related Topics

Viewing Favourites

Searching the People Directory

Take me back to the Confluence User's Guide.

Removing Favourites

To remove a page as a favourite:

1. Go to the page.
2. Choose Tools > ⭐ Favourite.
   This will change to ⭐ Favourite to indicate that you have removed this page from your favourites.

To remove a global space as a favourite:

1. Go to the dashboard.
2. Click on the star icon ⭐ located beside the space in the list of spaces displayed.
   This will change to ⭐ to indicate that you have removed this global space as a favourite.

To remove a personal space as a favourite:

1. Go to the People Directory.
2. Click on a person's name or profile picture to view their personal space.
3. Go to a page in the space and choose Browse > Advanced.
4. Click on 🌟 Remove Space from Favourites in the left-hand panel.
   This will change to 🌟 Add Space to Favourites to indicate that you have removed that person's personal space as a favourite.

Related Topics

**Viewing Favourites**

**Spaces Cannot be Unmarked as Favourites**

Take me back to the Confluence User's Guide.

**Viewing Favourites**

Once you add a spaces or pages as favourites, you can see them on your dashboard or in your profile.

**The Dashboard**

On the left-hand side of the Dashboard, you can see:

- your favourite spaces in the Spaces tab.
- your most recently added favourite pages in the Pages tab.

Recently updated content in your favourite spaces will be listed on the Favourite Spaces tab at the top right of the dashboard.

**Screenshot: Viewing your favourites on your dashboard**

<table>
<thead>
<tr>
<th>Spaces</th>
<th>Pages</th>
<th>Network</th>
</tr>
</thead>
</table>

**Favourite Spaces**

- 🌟 Angry Nerds
- 🌟 Confluence
- 🌟 Paul Watson
- 🌟 Technical Writing

**Global Spaces**

- 🌟 Admin Space
- 🌟 Angry Nerds
- 🌟 Archive
- 🌟 Atlassian Foundation

**Your Profile**

To view your favourites in your profile:

1. Log in to Confluence, if you have not already done so.
2. Go to your name (the 'User' menu) at the top of the page and choose Labels.
3. Click on favourite (under 'Your Labels') to see the list of your favourite spaces and pages.
Related Topics

Adding Favourites
Removing Favourites
Working with Favourites

Working with Confluence Labels

Working with Attachments

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format. You can attach files to any page or blog post, provided you have permission to do so.

When a page you are viewing contains attachments, a small paperclip icon appears next to the page byline, under the page name. Clicking the paperclip will take you to the 'Attachments' view, where you will see the full list of attachments.

On this page:
- A quick guide to attachments
- Working with attachments
- Notes

Related pages:
- Configuring Attachment Size
- Configuring your Attachment Storage
- Confluence User's Guide

A quick guide to attachments

Choose Tools > Attachments to view and attach files to a Confluence page. (See Attaching Files to a Page.) If you attach a file with the same name as an existing attachment, Confluence will create a new version of the existing attachment.

Once you have attached the relevant files, you can display attached images and multimedia content on the...
page. If the attachment is an Office document, use the View File macro to display the content of the document on the Confluence page. If you have an Office application installed, you will also be able to launch your Office editor from within Confluence. See Displaying Office Files in Confluence and Working with the Office Connector.

Your page can display a list of attachments – these may be the files that are attached to the page or to any page in the space. You can also display a link to an attachment. When a user clicks the link, the attachment will open, provided that the user has the software application needed to open the attachment.

You can label an attachment, and then use labels to categorise your content.

Working with attachments

- Using Drag-and-Drop in Confluence
- Attaching Files to a Page
- Attachment Versions
- Deleting an Attachment
- Displaying a List of Attachments
- Downloading Attachments
- Editing Attachment Properties
- Embedding Multimedia Content
- Embedding PowerPoint Presentations in a Page
- Moving an Attachment
- Viewing Attachment Details

Notes

If you want an attachment to be displayed on more than one page, you may wish to consider creating a special page to hold such attachments. This special page could be part of an inclusions library.

Using Drag-and-Drop in Confluence

This page describes the drag-and-drop functionality in Confluence, and the browser configurations needed to support that functionality.

Overview of the drag-and-drop features

Confluence supports these forms of drag-and-drop:

- Drag-and-drop within the editor. Working inside the editor panel, you can drag an image or a macro and drop it into a different location on the page.

- Drag-and-drop for external images and files. You can drag a file from a location outside Confluence, and drop it directly into the editor. For example, try it with images, video files, audio files, Office documents, and PDF files. The contents of the file will be embedded into the page or blog post.

Drag-and-drop within the editor

Working within the editor panel, you can drag an image or a macro from one location on the page and drop it into a different location on the page. Hover your cursor over the image or the macro placeholder. The cursor changes to a drag-and-drop icon and you can click the image or macro and drag it to a new location.

If you want to abandon the drag-and-drop action, press Escape. The image/macro will return to its original position.

Requirements for internal drag-and-drop

For the drag-and-drop of images and macros in the editor, Confluence supports the following browsers: Chrome,
Drag-and-drop for external images and files

You can drag files from your computer or file system onto your browser and attach them to your Confluence pages or blog posts. You can drag and drop:

- multiple files at once.
- image, multimedia and PDF files, and Office documents.

When you drag and drop files onto the different Confluence views, you get the following results:

<table>
<thead>
<tr>
<th>Confluence View</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachments</td>
<td>Files are attached</td>
</tr>
<tr>
<td>Page</td>
<td>Files are attached</td>
</tr>
<tr>
<td>Edit</td>
<td>Files are attached, and embedded at the cursor position</td>
</tr>
</tbody>
</table>

**Requirements for external drag-and-drop**

- Your browser must support the drag-and-drop functionality of HTML5.

- Some browsers, such as Internet Explorer 9, Firefox 3.5 and Safari 4 do not support the drag-and-drop functionality of HTML5. For these browsers, Confluence will attempt to use the drag-and-drop functionality provided by Google Gears.

  - The first time you try to drag and drop a file into one of these browsers, Confluence will prompt you to install Google Gears into your browser. Refer to the prompt below for more information. For more details on the installation requirements for Google Gears, refer to Google's own How to install instructions.
  
  - Please check the Google Gears website for the most up-to-date browser support details.

  - To check if Google Gears is already installed on your computer, refer to Google's own How to check if Gears is installed instructions.

Note about supported web browsers: Please ensure that you are using one of the web browsers...
supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. You can find the list of supported web browsers and browser versions on this page: Supported Platforms.

- Some older Confluence themes do not support Confluence's drag-and-drop feature.
  - **Supported themes**: Confluence Default theme, Documentation theme, Easy Reader theme.
  - **Themes that are not supported**: Left Navigation theme, Clickr theme. You cannot drag and drop attachments into spaces that use these themes.

**Prompt to install Google Gears**

If you are using a browser that does not support the drag-and-drop feature, and Google Gears has not yet been installed:

- When you attempt to drag and drop a file into Confluence (but not the editor), you will see the following message:

  **Screenshot: Generic Confluence prompt to install Google Gears**

  Click **OK** to install Google Gears.

- When you attempt to drag and drop a file into the editor, you will be prompted with the following message:

  **Screenshot: Confluence prompt to install Google Gears**

  **Note:** Save any drafted content before continuing with the installation of Google Gears. The installation process will replace your current Confluence page and you will need to restart your browser after the Google Gears installation has completed.

  Click **Proceed with Installation** to install Google Gears.
**Initial use with Google Gears**

When adding an attachment to a page or blog post in your Confluence site for the first time after Google Gears has been installed, you will be prompted to allow Google Gears to trust your Confluence site. If this warning message appears, choose **I trust this site. Allow it to use Gears** and then choose **Allow**.

*Screenshot: Google Gears security prompt*

![Google Gears security prompt](image)

**Note:** Google Gears is not supported on Safari. See [CONF-20032](#) for updates.

**Disabling drag-and-drop for external files**

- If you wish to disable the drag-and-drop feature, you can disable the entire Confluence Drag and Drop Plugin. See [Disabling or Enabling a Plugin](#).
- You can also disable the drop zone that appears on the 'Attachments' view or the image dialog box, by disabling the View Attachments Drop Zone or Image Dialog Drop Zone modules of the above plugin. This will remove these drop zones while retaining Confluence's drag-and-drop functionality.

**Attaching Files to a Page**

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format. Read more in [Working with Attachments](#).

When you attach a file to a page, Confluence makes a copy of the file and stores it on the Confluence server. Page attachments in Confluence are managed using the 'Attachments' view of the page.

To attach a file, you need the 'Create Attachments' permission. See [Space Permissions](#).

When a page you are viewing contains attachments, a small paperclip icon 📝 appears next to the page byline, under the page name. Clicking the paperclip will take you to the 'Attachments' view, where you will see the full list of attachments.
Attaching files

This page describes the following ways of attaching files to a Confluence page:

- Drag and drop files onto a Confluence page.
- Browse to, and upload files from, your computer or network.

To attach a file to a page using **drag-and-drop**:

1. View the page to which you want to attach files.
2. Drag one or more files from your computer onto the page. The 'Attach File(s)' message box appears, indicating the upload status of the files being attached to your page.

You can drag and drop more than one file at a time onto a page. You cannot drag a folder of files onto a page.

Expand this section to see other ways to drag-and-drop a file on to a page...

You can also drag and drop files:

- directly onto the 'Attachments' view for the page.
- directly onto the editor view of the page.
- onto any tab of the 'Insert Link' or 'Insert Image' dialogs, which are available from the **Insert** menu while editing.

To attach a file to a page from the computer's (or network's) file system:

1. Choose **Tools > Attachments.**
2. Choose **Browse** and navigate to the file.
3. Select the file and click **Open.**
4. Add a descriptive comment for the file (optional).
5. Choose **Attach more files** if required.
6. Choose **Attach.**

You can attach more than one file at a time. You cannot attach a folder of files.

Expand this section to see other ways to upload a file to a page...
You can also browse for, and upload, a file from:

- the 'Attachments' tab of the 'Insert Link' dialog. (While editing the page, choose Insert > Link.)
- the 'Attached Images' tab of the 'Insert Image' dialog. (While editing the page, choose Insert > Image.)

Attachment versions

If you upload a file with the same name as an existing attachment, Confluence will rename the old file and keep it as a previous version. Read more about Attachment Versions and Viewing Attachment Details.

Notes

- **Reusing attachments:** If you want to display the same file on more than one page, the best way is to put the attachment on a page (say, page A) and then use the Include Page Macro to include page A into page B, page C, and all the pages where you want the diagram, presentation, or other file. Alternatively, you can display an image that is attached to another page.
- **Updating the original file:** Any changes you make to the source file do not affect the copy that was uploaded to Confluence. To update the Confluence copy, you need to upload the new version of the file.

Attachment Versions

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

When viewing a list of attachments, you can add a new version of an existing attachment by uploading an attachment with the same file name, as displayed on the attachment view. Existing files will be kept with the name 'Version x', where the value of 'x' increments with each upload of an attachment with the same file name.

To see all versions of an attachment: Choose the arrow next to an attachment name.

### Related pages:

- Attaching Files to a Page
- Deleting an Attachment
- Moving an Attachment
- Viewing Attachment Details
- Working with Attachments
- Confluence User's Guide

### Screenshot: Attachment versions

<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Creator</th>
<th>Creation Date</th>
<th>Labels</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ChocolateBrownies-MadeByDuncan-36U.jpg</td>
<td>54 KB</td>
<td>Administrator</td>
<td>Jul 12, 2013 13:52</td>
<td>chocolate, rudge</td>
<td>Made by Duncan</td>
</tr>
<tr>
<td><em>Version 3 (current)</em></td>
<td>54 KB</td>
<td>Administrator</td>
<td>Jul 12, 2013 13:52</td>
<td>Made by Duncan</td>
<td></td>
</tr>
<tr>
<td><em>Version 2</em></td>
<td>54 KB</td>
<td>Administrator</td>
<td>Jul 12, 2013 13:52</td>
<td></td>
<td>Remove</td>
</tr>
<tr>
<td><em>Version 1</em></td>
<td>54 KB</td>
<td>Administrator</td>
<td>Jul 12, 2013 13:50</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Chocolate.jpg</td>
<td>259 KB</td>
<td>Administrator</td>
<td>Jul 12, 2013 13:52</td>
<td>chocolate</td>
<td></td>
</tr>
<tr>
<td><em>Volunteer Registration Form 12.pdf</em></td>
<td>155 KB</td>
<td>Administrator</td>
<td>Jul 12, 2013 13:50</td>
<td></td>
<td></td>
</tr>
<tr>
<td><em>KeysChocolateCake-MadeBySarah-9117.jpg</em></td>
<td>1.79 MB</td>
<td>Administrator</td>
<td>Jul 12, 2013 13:50</td>
<td>None</td>
<td>Properties</td>
</tr>
</tbody>
</table>

Download All
Notes

- You cannot revert to a previous version of an attachment. See feature request CONF-1943.
- Confluence does not track the history of attachments in the same way as it does for pages. See feature request CONF-13943.
- By default, attachments and their versions are stored in the \<confluence_home>/attachments directory. (See Attachment Storage Configuration.)
- There is no limit to the number of attachments or attachment versions, provided that there is enough disk space.

Deleting an Attachment

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

By default, when you remove an attachment, this will delete all versions of the attachment. To do that, you need the 'Remove Attachments' permission. See Space permissions.

If you want to delete a specific version of an attachment, you need to be a space administrator.

Related pages:
- Working with Attachments
- Displaying Images
- Confluence User’s Guide

To delete all versions of an attachment:

1. Go to the page that contains the attachment.
3. Choose Remove next to the attachment you want to delete.
4. Choose Remove to confirm your action.

To delete a specific version of an attachment:

1. Go to the page that contains the attachment.
2. Choose Tools > Attachments. A list of the page’s attachments will appear.
3. Choose the arrow on the left next to the attachment you want to manage. A list of attachment versions will appear.
4. Choose Remove next to the version you want to delete.
5. Choose Remove to confirm your action.

Screenshot: Attachments and attachment versions

Displaying a List of Attachments
An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

You can display a list of attachments on your page – these may be the files that are attached to the page or to any page in the space. Use the Attachments macro to show a list of the attachments on the current page. Use the Space Attachments macro to show a list of the attachments in the current space. Both these macros generate a table of attachments which is clickable.

**Using the macros**

**To add the Attachments or Space Attachments macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

---

**Parameters of the Attachments macro**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

---

**Related pages:**

- Attaching Files to a Page
- Working with Attachments
- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide
| **Filename Patterns** | all | A comma-separated list of regular expressions, used to filter the attachments by file name. Note that the parameter values must be regular expressions. For example:  
- To match a file suffix of 'jpg', use .*jpg (not *.jpg).  
- To match file names ending in 'jpg' or 'png', use .*jpg, .*png.  
Here is a [tutorial on regular expressions](#). |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Attachment Labels</strong></td>
<td>(none)</td>
<td>A list of labels, used to filter the attachments to display. If you wish to enter more than one label, separate the labels with commas. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.) For information on labelling the attachments, see <a href="#">Adding Labels</a>.</td>
</tr>
<tr>
<td><strong>Include Old Attachment Versions</strong></td>
<td>false</td>
<td>A value of <code>true</code> will include previous attachment versions in the list.</td>
</tr>
</tbody>
</table>
| **Sort By** | date | The sort order for attachments. Note that people viewing the page can change the sort order by clicking the column headings. Valid values are:  
- **date** – sorts by reverse chronological order (newest first)  
- **size** – sorts largest to smallest  
- **name** – sorts alphabetically |
| **Sort Order** | ascending | Used in combination with the **Sort By** parameter, to sort the attachments in ascending or descending order. |
| **Allow Upload** | true | If selected, the list of attachments will include options allowing users to browse for, and attach, new files. |
**Page Title** | *(none)* | Used to display attachments from another page. If you do not enter a page title, the macro will display the files attached to the current page.

---

**Viewing files and changing file properties from the Attachments macro**

The list of files displayed by the Attachments macro includes options for viewing the files and other actions, provided the user has the relevant permissions.

- If you have specified the ‘Allow Upload’ parameter, users will be able to upload attachments directly from the list.
- Users can remove attachments. Note that they can only remove the entire attachment, including all versions of the attachment. To remove a specific version of an attachment, they must go to the ‘Attachments’ view. See Deleting an Attachment.
- Users can edit attachment properties and labels. If an attachment is an Office or PDF file, they will see the appropriate options for Office Connector files.

**Screenshot 1: The Attachments macro**

Users can **and**... If an attachment is an Office or PDF file, they will see **edit attachment properties** and **labels**. If an attachment is an Office or PDF file, they will see **Office Connector** files.

**Parameters of the Space Attachments macro**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td><em>(none)</em></td>
<td>Selects the Confluence space to display all attachments for. If no space is specified, the current space will be used.</td>
</tr>
<tr>
<td>Attachment Labels</td>
<td><em>(none)</em></td>
<td>Filters the attachments to display, based on a list of labels. If you wish to enter more than one label, separate the labels with commas. For information on labelling the attachments, see Adding Labels.</td>
</tr>
</tbody>
</table>
Show Filter Controls | true | Determines whether or not the filter panel is shown. The filter panel allows you to filter the list of attachments by file type (extension).

Screenshot 2: The Space Attachments macro

Downloading Attachments
An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

To download a single attachment from a page:
1. View the page.
2. Choose Tools > Attachments.
3. Right-click the link on the attachment name, and select Save Link As, Save Target As or a similar option provided by your browser. This will open a ‘Save’ dialog.
4. Select the location into which you want to download the file and choose Save.

Related pages:
- Attaching Files to a Page
- Working with Attachments
- Confluence User's Guide

To download all the attachments from a page:
1. View the page.
2. Choose Tools > Attachments.
3. Choose the Download All button at the end of the page to download a zipped file of all the page’s attachments.

Notes
- There is no permission that controls the downloading of attachments. See an article in our knowledge base about disabling the download of attachments.
- Confluence does not supply an option to download all attachments from a space. See the closed feature request: [CONF-5669 - Authenticate](#) to see issue details.
**Editing Attachment Properties**

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

To edit an attachment's properties, you need the 'Create Attachments' permission. See [Space Permissions](#).

**To edit the properties of an attachment:**

1. View the page that contains the attachment.
2. Choose **Tools > Attachments**.
3. Choose **Properties** next to the attachment. The 'Properties' screen will appear.
4. Make your changes:
   - **File Name** — Rename or modify the name of the attachment.
   - **New Comment** — Update the existing comment or enter a new comment.
   - **New Content Type** — Change the content type of the attachment by entering a valid [MIME type](#).
   - **Page** — [Move the attachment](#) to another page.
5. Choose **Save**.

**Related pages:**
- [Attaching Files to a Page](#)
- [Moving an Attachment](#)
- [Viewing Attachment Details](#)
- [Working with Attachments](#)
- [Confluence User's Guide](#)

![Screenshot: Editing an attachment's properties](#)

**Embedding Multimedia Content**

Using multimedia files you can display movies, animations and videos, and embed audio files on your Confluence page.

There are several methods for [attaching files to a page](#). Once you have attached the multimedia file to a Confluence page, you then edit the page to set where the multimedia content should appear.

In the example below, we display a Flash file that is attached to this page.
Confluence supports the following multimedia formats:

- Adobe Flash (.swf)
- Apple QuickTime (.mov)
- Windows Media (.wma, .wmv)
- Real Media (.rm, .ram)
- MP3 and MP4 files (.mp3, .mp4)
- MPEG files (.mpeg, .mpg)
- AVI files (.avi) You may need to enable an avi decoder within your browser.

### On this page:
- Displaying a multimedia file attached to the page
- Multimedia macro parameters
- Notes
- Related Topics

### Quick guide to displaying multimedia content on a page

Choose one of these methods:

- **Add the macro yourself**: Attach the multimedia file to the page in the usual way. Add the Multimedia macro using the macro browser.
- **Autocomplete**: Attach the multimedia file to the page in the usual way. Type '!' in the editor and choose the multimedia file from the list that appears.
- **Drag and drop**: Drop the video or other file into the editor. Confluence will attach the file and insert the Multimedia macro for you.
- **Adjust parameters if necessary**: Click on the Multimedia macro placeholder to set options for the macro, such as adjusting the width or height of the display, or setting autoplay on.

### Displaying a multimedia file attached to the page

Once you have attached a multimedia file to a page, there are different methods for choosing where on the page the multimedia content should appear:

#### Inserting the Multimedia macro yourself

You can add the Multimedia macro to the page yourself using the Macro Browser. This allows you to display a multimedia file that is attached to either the current page or to another page in the Confluence site.

**To insert the Multimedia macro on the page at the current cursor position:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete**: Type {} and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro**: Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Using autocomplete**

Once a multimedia file is attached to the page, you can use autocomplete, while editing the page, to choose where the multimedia content should appear.

**To position an attached multimedia file on the page using autocomplete:**


1. While editing the page, position the cursor where you want to place the multimedia content.
2. Trigger the autocomplete function by typing '!'.
3. Choose the multimedia file from the list that appears.
4. If necessary, click on the Multimedia macro placeholder and choose Edit to set various options such as the width, height or autoplay.

Using drag-and-drop

Depending on the browser you are using, you can attach and position a multimedia file in one step using drag-and-drop.

**To attach and position multimedia content using drag-and-drop:**

1. While you are editing a page, simply drag-and-drop the multimedia file on to the page. Confluence will attach the file to the page and insert the Multimedia macro at the current cursor position for you.
2. If necessary, click on the Multimedia macro placeholder and choose Edit to set various options such as the width, height or autoplay.

**Multimedia macro parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Name</td>
<td>Current page</td>
<td>Name of the page to which the multimedia file is attached. If you are using the Macro Browser, just start typing the name of the page and then select it from the dropdown list that appears. The page can be in the same space or another space.</td>
</tr>
<tr>
<td>Attachment</td>
<td>None</td>
<td>File name of the multimedia file.</td>
</tr>
<tr>
<td>Width</td>
<td>If not specified, the browser will determine the width based on the file type.</td>
<td>Width of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's width, or any other value accepted by HTML.</td>
</tr>
<tr>
<td>Height</td>
<td>If not specified, the browser will determine the height based on the file type.</td>
<td>Height of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's height, or any other value accepted by HTML.</td>
</tr>
</tbody>
</table>
### Notes

- **The multimedia file must be attached to a Confluence page.** For security reasons, files located on remote servers are not permitted. See the [Widget Connector](#) for displaying live content from external sites.

- **You will need the relevant multimedia plugin for your browser.** Your browser (Firefox, Internet Explorer, Safari and others) needs a plugin to play the video or audio file on a Confluence page. For example, to play a Flash movie you need the Flash plugin. Many plugins are shipped with the major browsers by default. If a user does not have the required plugin installed and enabled in their browser, they will not be able to view the multimedia files on the page.

- **Autoplay may not always work as expected.** You can set autoplay on, so that your video or audio file should start playing as soon as the page is loaded into the browser. (See [parameters](#).) However, this setting may not always work as expected. Confluence will send an instruction to the browser plugin that plays the multimedia file. Different browsers and different media plugins behave in different ways, and not all of them respect such instructions.

- **Use the Office Connector to display Office documents.** Take a look at the [Office Connector](#) for embedding Word documents, presentations and other Office documents onto your Confluence page.

- **If you get the error, 'Unable to embed content of type application/octet-stream', this means the MIME type is not recognised.**

- **Advanced users can try styling via CSS.** By default, each embedded object is wrapped in a `<div>` tag. If you wish to style the `<div>` and its contents, override the `embeddedObject` CSS class. Specifying an ID as a property also allows you to style different embedded objects differently. CSS class names in the format `embeddedObject-ID` are used.

### Related Topics

- [Working with Macros](#)
- [Widget Connector Macro](#)
- [Working with the Office Connector](#)
- [Working with Attachments](#)

Take me back to [Confluence User's Guide](#)

### Embedding PowerPoint Presentations in a Page

Below are some ideas on how your wiki page can include information from a Microsoft PowerPoint presentation.

<table>
<thead>
<tr>
<th>On this page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>- Option 1 — Office Connector for Confluence</td>
</tr>
<tr>
<td>- Option 2 — Gallery or Slide Show of JPEG or PNG Images</td>
</tr>
<tr>
<td>- Option 3 — Convert PowerPoint to HTML</td>
</tr>
<tr>
<td>- Related Topics</td>
</tr>
</tbody>
</table>

Created in 2012 by Atlassian. Licensed under a [Creative Commons Attribution 2.5 Australia License](#).
Option 1 — Office Connector for Confluence

The Office Connector provides the most straightforward way to display PowerPoint slides.

To attach and display a PowerPoint presentation in Confluence:

1. Attach the presentation to a Confluence page:
   - View the Confluence page where you want to display your presentation.
   - Open the 'Tools' menu and select 'Attachments'.
   - Browse for your PowerPoint presentation and upload it to the Confluence page.
     You will find detailed instructions in Attaching Files to a Page.
2. Now you can display the document embedded into the Confluence page, using the View File macro.

Option 2 — Gallery or Slide Show of JPEG or PNG Images

1. Convert your PowerPoint pages into JPEG or PNG images, using 'save as' from PowerPoint (slide1.jpg, slide2.jpg...).
2. Upload the image files as attachments to your Confluence page. To upload in bulk, use the WebDAV plugin.
3. Use the Gallery macro or the Slideshow plugin to render the images as a slide show in Confluence.

Option 3 — Convert PowerPoint to HTML

You can convert the PowerPoint file to web page format and embed the page inside your Confluence document.

1. Review the risks associated with enabling the html-include macro here.
2. If you decide to proceed, follow the instructions to enable embedded HTML pages using the macro.
3. Select an PowerPoint converter. There are at least two applications that can convert PPT to HTML:
   - Producer for PowerPoint.
   - Internet Assistant for Powerpoint instead.
4. Download and install your chosen converter.
5. Follow the converter documentation to perform the HTML conversion. An Internet Assistant conversion guide can be found here. The conversion process will create a small collection of HTML pages. Each slide will have its own page, plus an index page with buttons to let you switch between slide pages.
6. If you wish, you can test the HTML presentation now by loading the index page in your browser.
7. Place the HTML files into their own directory, named uniquely by the title of your presentation.
8. Find a suitable location to host these files within your web server. Confluence hosts all files within the <my -install-directory>/confluence/directory, so a good example location for Confluence distribution users is to go to <my-install-directory>/confluence/pages/ and create a subdirectory called powerpoint.
9. Move the HTML directory into the PowerPoint folder, e.g. <my-install-directory>/confluence/p
ages/powerpoint/<my-presentation-name> containing index.html, slide01.html... or similar.

10. Edit or create the page where you wish to embed the PowerPoint presentation. Add the HTML Include macro pointing to the index page of your slides. Remember that URLs are case sensitive.
11. Save the page. The index page to your slides should now appear.

Related Topics

Working with the Office Connector
Working with Attachments

Take me back to Confluence User's Guide

Moving an Attachment

You can move an attachment from its current location to any page within the site.

To move an attachment, you need the following permissions:

- Edit page permission on the page where the attachment currently exists.
- Create attachment permission on the space into which you are moving the attachment.
  Space permissions are assigned by a space administrator from the Space Administration screens. See Space permissions or contact a space administrator for more information.

To move an attachment:

1. Go to the page that contains the attachment.
2. Choose Tools > Attachments.
3. Click the Properties link beside the attachment. This will display a new screen, where you can edit the properties of an attachment.
4. Select the page where you want to move the attachment by either:
   - Entering the page's title into the Page field
   - Clicking the Choose a Page icon and using the ‘Choose a Page’ pop-up window to choose a page within the site.
5. Click OK.

Screenshot: Moving an attachment
Moving a Page

Take me back to Confluence User's Guide

Choose a Page

The 'Choose a Page' window allows you to locate a page in your Confluence site. The window appears when you are moving an attachment.

To choose a page:

1. Click the page picker icon to display the 'Choose a Page' window. You will see the following tabs:
   - **Search**: Allows you to search for your page in all Confluence spaces.
   - **History**: Displays a list of pages recently visited by you.
   - **Recently Modified**: Displays pages most recently modified by you.
   - **Referring Pages**: Displays a list of all pages that refer to the current page.

2. Select the required page from the list of pages in one of the tabs.

Related Topics

Moving an Attachment

Take me back to Confluence User's Guide

Viewing Attachment Details

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

You can view attachment details in the following places:

- The list of attachments in a space — this will show all files attached to all pages in the space. See below.
- The list of attachments for a specific page. See below.
- A list of attachments created by a macro and displayed on a page. See Displaying a List of Attachments.

On this page:

- Viewing attachments in a space
- Viewing attachments on a page
- Attachment details

Related pages:

- Working with Attachments
- Displaying a List of Attachments
- Confluence User's Guide

Viewing attachments in a space

To view the attachments associated with a space:

1. Go to a page in the space and choose **Browse > Attachments**.
   You will see a list of all the attachments in the space, along with their details and the pages they are attached to.

2. To see only files of a particular type:
   - Type the last part of the file name in the **Filter By File Extension** box. For example, enter ‘gif’ to see only image files of the GIF format.
Click Filter.

3. To see only files that have a particular label or labels:
   - Type the label or labels in the Filter by Label box. If you enter more than one label, separate the labels with commas or spaces. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.)
   - Click Filter.

Screenshot 1: List of attachments for a space

Viewing attachments on a page

When a page you are viewing contains attachments, a small paperclip icon appears next to the page byline, under the page name. Clicking the paperclip will take you to the 'Attachments' view, where you will see the full list of attachments.

To view the attachments associated with a page:

1. Go to the page.
2. Choose Tools > Attachments. You will see a list of the attachments in the page along with their details.
3. To see all versions of an attachment, choose the arrow on the left of the attachment name.

The list of attachments includes options for viewing the files, and other actions, provided the user has the relevant permissions. If you have specified the 'Allow Upload' parameter, users will be able to upload attachments directly from the list too. Users can also remove attachments or edit attachment properties and labels. If an attachment is an Office or PDF file, you will see the appropriate options for Office Connector files.

Screenshot 2: List of attachments for a page

Attachment details
Note that the page view shows a different subset of fields from the space view.

- **Name** is the name of the attached file.
- **Size** tells you how much space the attachment takes up. You can sort by size by clicking the column title.
- **Creator** is the person who attached the file. Clicking on the link takes you to the person's user profile.
- **Creation Date** is the date the file was attached. You can sort by date by clicking the column title.
- **Labels** are keywords, or tags, that you can enter to categorise the attachments. See how to add labels.
- **Last Mod. Date** (in the space view) is the date the file was last modified.
- **Attached To** (in the space view) tells you which page contains the attachment.
- **Comment** (in the page view) is a short description of the attachment.
- The **Properties** link (in the page view) lets you edit the attachment details. See how to edit attachment properties.
- The **Remove** link (in the page view) lets you delete the attachment, or a specific version of the attachment.
- The **Edit in Office** link (in the page view) appears next to Office files only, and lets you edit that attachment.
- The **Attach File** option lets you add another attachment or another version of an existing attachment. See how to upload attachments.

### Customising Confluence

You can customise or configure many aspects of Confluence:

- The **look and feel** of any Confluence space.
- **Personal aspects**, including your personal profile and homepage.
- Setting up your user profile.
- **User access**, including permissions and page restrictions.
- Add-ons such as gadgets and macros.
- Customisations for specific uses of Confluence.

#### Related pages:
- Configuring Confluence
- Configuring Confluence Security
- Installing Plugins and Macros
- Confluence User's Guide

### Personal Customisations

There are several ways that you can customise the way that Confluence works for you, personally, including:

- Your personal homepage
- Your personal dashboard
- Your personal profile
- Your email notifications
- Your RSS Feed settings

### User Profile Overview

Each Confluence user has a User Profile area, where numerous account management features can be accessed.

**Finding your User Profile**

Go to your name (the 'User' menu) at the top of the page and choose Profile.

The profile view is divided into tabs, each of which is described in a separate section below.
On this page:

- Finding your User Profile
- Profile
- Network
- Status Updates
- Labels
- Watches
- Drafts
- Settings

Screenshot: User profile

Profile

- View and edit your personal details, such as your name and email address details and optionally, your photograph and other personal information. Note that as a security precaution, in order to change your email address, you will be required to re-enter your password.
- Upload a profile picture (optional).
- Change your password.

Network

- View the recent activity of users that you are following via the Network view.
- Follow other users from this view.

The 'Administer User' link is visible to Confluence administrators only. The administrator can click this link to go directly to the user management screen in the Administration Console.
Status Updates

- View your history of status updates.

Labels

- View your personal labels.

Watches

- View a list of the pages and spaces you are currently watching.

Drafts

- Retrieve any pages you were in the process of editing. See Working with Drafts.

Settings

- Edit your General Settings (homepage, language and timezone).
- Subscribe to email notifications.
- View and revoke your OAuth access tokens.

Related Topics

Managing Changes and Notifications and Tasks
Setting Up your Personal Space

Take me back to the Confluence User's Guide.

Changing Password

To change your Confluence password:

1. Go to your name (the 'User' menu) at the top of the page and choose Profile.
2. On your Profile tab, click Password in the left-hand column.
3. Enter your current password and your new password in the form displayed.
4. Click Submit.

Related Topics

Viewing User Profile
Editing Your User Profile
Choosing a Profile Picture
Setting Up your Personal Space
Updating Email Address
Email Address Privacy

Take me back to the Confluence User's Guide.

Editing User Settings

You can set various Confluence preferences that affect your personal session:

- General preferences such as home page, language and time zone, as described below.
- Editor settings, as described below.
- Email settings for subscriptions to email reports. See Subscribing to Email Notifications of Updates to Confluence Content.
- OAuth access tokens that you have granted from your Confluence user account. See Viewing and Revoking OAuth Access Tokens.

General User Preferences

To edit your general user settings:

1. Go to your name (the 'User' menu) at the top of the page and choose Settings.
2. Click **Edit** and update the settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site Homepage</td>
<td>Select the page that you would like to see whenever you log into Confluence.</td>
</tr>
<tr>
<td>Language</td>
<td>Select your language. See <a href="#">below</a>.</td>
</tr>
<tr>
<td>Time zone</td>
<td>Select your time zone.</td>
</tr>
<tr>
<td>Use Keyboard Shortcuts</td>
<td>Enable <a href="#">keyboard shortcuts</a>, other than for the editor.</td>
</tr>
</tbody>
</table>

3. Click **Submit**.

### On this page:
- [General User Preferences](#)
- [More about Language](#)
- [Editor Preferences](#)

### Related pages:
- [Editing Your User Profile](#)
- [Choosing a Profile Picture](#)
- [Setting Up your Personal Space](#)
- [Email Address Privacy](#)
- [Using Autocomplete](#)
- [Confluence User's Guide](#)

---

### Screenshot: Editing your user profile settings

![Screenshot: Editing your user profile settings]

---

### More about Language

Setting your language preference in your user profile is described in the section [above](#). This section gives more information about that setting and other settings that affect the language Confluence will use.

Individual users can choose the language that Confluence will use to display screen text and messages. Note that the list of supported languages depends on the language packs installed on your Confluence site.

The language used for your session will depend on the settings below, in the following order of priority from
highest to lowest:

- The language preference defined in your user profile. Note that you need to be logged in for this setting to take effect.
- The language that you choose by clicking an option at the bottom of the Confluence login screen. Confluence stores this value in a cookie. When the cookie expires, the setting will expire too.
- The language set in your browser.
  - Note that your Confluence administrator can disable this option by setting a system property.
  - The browser sends a header with a prioritised list of languages. Confluence will use the first supported language in that list.
- The default language for your site, as defined by your Confluence site administrator.

**Editor Preferences**

You can set some options that determine the way the Confluence editor works. Note that these settings affect only you. Other people using Confluence can enable or disable the settings on their user profiles independently.

**To change your editor preferences:**

1. Go to your name (the 'User' menu) at the top of the page and choose Settings.
2. Click Editor under 'Your Settings' in the left-hand panel.
3. Click Edit.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable Autocomplete</td>
<td>Select to disable autocompletion when you press one of the trigger characters.</td>
</tr>
<tr>
<td>Disable Autoformatting</td>
<td>Select to disable autoformatting when you type wiki markup in the editor. Click ? on the editor toolbar to learn more.</td>
</tr>
</tbody>
</table>

4. Click Submit.

**Screenshot: User settings for the editor**

**Editing Your User Profile**

Your user profile contains basic information about you. If you do not have a personal space, your user profile will be displayed when anyone clicks your name in the People Directory.

**To edit your user profile:**
1. Go to your name (the 'User' menu) at the top of the page and choose Profile.
2. On your Profile view, click Edit in the Personal details section.
3. Enter details about yourself in the form displayed.
4. Click Save.

<table>
<thead>
<tr>
<th>Detail</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Name</td>
<td>Your name as you would like it to appear in your profile.</td>
</tr>
<tr>
<td>Email</td>
<td>Your email address which will be used to send you mail notifications.</td>
</tr>
<tr>
<td>Phone</td>
<td>Your phone number.</td>
</tr>
<tr>
<td>IM</td>
<td>Your Instant Messenger (IM) details.</td>
</tr>
<tr>
<td></td>
<td>To suit a variety of IM applications, this option accepts any string value.</td>
</tr>
<tr>
<td></td>
<td>For example, you can enter IM details in the form of an email address, such as ' or a user ID, like '123456789'.</td>
</tr>
<tr>
<td>Website</td>
<td>Your website's URL.</td>
</tr>
<tr>
<td>Position</td>
<td>The title of your position within your organisation.</td>
</tr>
<tr>
<td>Department</td>
<td>The name of your department within your organisation.</td>
</tr>
<tr>
<td>Location</td>
<td>Your location. This could be a town, city, region or country.</td>
</tr>
<tr>
<td>About me</td>
<td>Information about yourself that other users can view (such as your professional information, hobbies, and other interests). You can use Confluence wiki markup in this field.</td>
</tr>
<tr>
<td></td>
<td>Note that your Username cannot be changed.</td>
</tr>
</tbody>
</table>

Screenshot: Edit profile
Handy Hint

Confluence administrators can configure Confluence to mask email addresses (e.g. 'example at atlassian dot com'), protecting your email address from search engine spiders and the like.

### Related Topics

- Viewing User Profile
- Choosing a Profile Picture
- Setting Up your Personal Space
- Email Address Privacy

Take me back to the [Confluence User's Guide](#).

**Email Address Privacy**

Confluence can mask the email addresses of users to protect them from mail spammers.

This is done by a Confluence administrator and is configured through the Administration Console. The Confluence administrator has three options for email address privacy:
- **Public**: email addresses are displayed publicly.
- **Masked**: email addresses are still displayed publicly, but masked in such a way to make it harder for spam-bots to harvest them.
- **Private**: only Confluence administrators can see the email addresses.

For more information on setting these options, which are configured using the Administration Console, refer to [User Email Visibility](#).

## Related Topics

- Editing Your User Profile
- Viewing User Profile
- User Email Visibility

Take me back to the [Confluence User's Guide](#).

### Updating Email Address

The email address you specify in your profile settings is used for your mail notifications and is also displayed in your profile description.

**To update your email address:**

1. Go to your name (the 'User' menu) at the top of the page and choose **Profile**.
2. Click **Edit** in the 'Personal' section.
3. In the **Email** field, specify your new email address which will be used when sending you mail notifications.
4. Click **Save**.

## Related Topics

- Changing Password
- Editing Your User Profile

Take me back to the [Confluence User's Guide](#).

### Choosing a Profile Picture

Your profile picture is used as the icon for your personal space, to represent you in the People Directory, and to illustrate your comments. It also appears in various other places next to your name, such as in the list of recent updates on the dashboard.

You can upload your own profile picture or use one of the images provided by Confluence. If you upload your own profile picture, you will have an opportunity to crop (trim) the picture.

**To choose a profile picture:**

1. Go to your name (the 'User' menu) at the top of the page and choose **Profile**.
2. Click **Picture** on the left.
3. Choose one of the following two options:
   - Upload a new picture: Click **Browse** to locate your picture, then click **Upload** to upload it from your computer or file server.
   - Or select one of the default icons provided.
4. Click **Set Profile Picture**.

*Screenshot: Choosing a profile picture*
If you upload a profile picture that is larger than 48x48 pixels, the 'Edit My Profile Picture' screen will appear. You can select part of the picture or the entire picture, to be used as the final image for your profile. Note that the size of the final image will always be scaled down to 48x48 pixels.

To edit your profile picture:

1. Click and drag the centre of the superimposed square to select the centre of the new image.
2. Click the corners of the square to resize the area for your new image.
3. Click Save.
4. The image from your selected area will be cropped, resized to 48x48 pixels and saved.

Screenshot: Trimming a profile picture
Deleting a Profile Picture

You can delete the profile picture images that you have uploaded to Confluence.

To delete a profile picture:

1. Go to your name (the 'User' menu) at the top of the page and choose Profile.
2. Click Picture on the left.
3. Locate and select the picture file you wish to delete, then click Delete.
   - Note that you can only delete images that you have uploaded to Confluence. The standard icons cannot be deleted.
4. Click Delete to confirm the action. The picture is permanently removed from the server.

Related Topics

Deleting a Profile Picture
Editing Your User Profile
Setting Up your Personal Space

Take me back to the Confluence User's Guide

Screenshot: Deleting a Profile Picture
Related Topics

Choosing a Profile Picture
Editing Your User Profile
Setting Up your Personal Space

Take me back to the Confluence User's Guide.

Viewing User Profile

A Confluence User's Profile view shows details about that person and lists their recent activity. If you are viewing your own Profile view, you can also update your profile picture and login password. If you are viewing another user's Profile view, you can add them to your Network of users you are following and if they have set up a Personal Space, you can add this to your list of Favourites.

To access your User Profile view:

- Go to your name (the 'User' menu) at the top of the page and choose Profile.

Screenshot: User Profile View
Updating your Profile

You can update the following aspects of your Profile from this view:

- **Information about yourself** - to modify these details, see Editing Your User Profile.
- **Your Profile picture** - to change your Profile picture or upload a new one, see Choosing a Profile Picture.
- **Your login password** - to change your login password, see Changing Password.

You can switch between your Profile, Profile picture update and login password update views by clicking the 'Details', 'Picture' and 'Password' links in the left-hand column, respectively.

Related Topics

Editing Your User Profile

Take me back to the Confluence User's Guide.

Viewing and Revoking OAuth Access Tokens

This page describes the purpose of OAuth access tokens which have been issued on behalf of your Confluence user account and provides instructions on how to revoke them.

On this page:

- OAuth Access Tokens
- Viewing your OAuth Access Tokens
  - OAuth Access Token Details
- Revoking your OAuth Access Tokens
OAuth Access Tokens

OAuth access tokens allow you to use a Confluence gadget on an external web application or website (also known as the 'consumer') and grant this gadget access to Confluence data which is restricted or privy to your Confluence user account.

OAuth access tokens will only appear in your user profile if the following conditions have been met:

1. Your Confluence Administrator has established an OAuth relationship between your Confluence site and the consumer. Confluence Administrators should refer to Configuring OAuth for more information about establishing these OAuth relationships.
2. You have accessed a Confluence gadget on the consumer and have conducted the following tasks:
   a. Logged in to your Confluence user account via the gadget and then,
   b. Clicked the 'Approve Access' button to allow the gadget access to data that is privy to your Confluence user account.

   Confluence will then send the consumer an OAuth 'access token', which is specific to this gadget. You can view the details of this access token from your Confluence site's user account.

   An OAuth access token acts as a type of 'key'. As long as the consumer is in possession of this access token, the Confluence gadget on the consumer will be able to access Confluence data that is both publicly available and privy to your Confluence user account. As a Confluence user, you can revoke this access token at any time. Furthermore, all access tokens expire after seven days. Once the access token is revoked or has expired, the Confluence gadget will only have access to publicly available Confluence data.

Viewing your OAuth Access Tokens

To view all of your Confluence user account’s OAuth access tokens:

1. Go to your name (the 'User' menu) at the top of the page and choose Settings.
2. Click View OAuth Access Tokens. A view similar to screenshot below is displayed. Refer to OAuth Access Token Details below for information on interpreting this table.

   If no access tokens have been set, then 'None specified' is shown.

Screenshot: Viewing your OAuth Access Tokens

OAuth Access Token Details

Your list of OAuth access tokens is presented in a tabular format, with each access token presented in separate rows and each property of these tokens presented in a separate columns:

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
### Consumer

The name of the Confluence gadget that was added on the consumer.

### Consumer Description

A description of this consumer application. This information would have been obtained from the consumer's own OAuth settings when an OAuth relationship was established between Confluence and that consumer.

*If the consumer is another Atlassian application, this information is obtained from the Consumer Info tab's 'Description' field of the OAuth Administration settings. The application's administrator can customise this Consumer Info detail.*

### Issued On

The date on which the OAuth access token was issued to the consumer by Confluence. This would have occurred immediately after you approved this gadget access to your Confluence data (privy to your Confluence user account).

### Expires On

The date when the OAuth access token expires. This is seven days after the 'Issued On' date. When this date is reached, the access token will be automatically removed from this list.

### Actions

The functionality for [revoking the access token](#).

---

**Revoking your OAuth Access Tokens**

To revoke one of your OAuth access tokens:

1. View your Confluence user account's OAuth access tokens ([described above](#)).
2. Locate the Confluence gadget whose OAuth access token you wish to revoke and click **Revoke OAuth Access Token** next to it.
   The gadget's access token is revoked and the Confluence gadget on the consumer will only have access to publicly available Confluence data.

**Choosing your Homepage**

By default, all users are directed to the dashboard after logging in. However, you can choose to be redirected to the home page of any space on the Confluence site after logging in.

To set the home page:

1. Click on **your name** (the 'user' menu) at the top of the page and choose **Settings**.
2. Click **Edit**.
3. Use the **Site Homepage** list to select a space. Note that only the list of spaces to which you have 'view' access is displayed here. You will be directed to the home page of the selected space when you next log in.
4. Click **Submit**.

_Screenshot: General Preferences Settings_
Customising your Personal Dashboard

You can customise the Confluence dashboard to provide access to the content on the site that is most relevant to you. The options described on this page will change your own personal dashboard, but will not affect the dashboard that other people see.

If you are a Confluence Administrator, you can change the global dashboard, as seen by all Confluence users. See the administrator's guide to customising the dashboard.

On this page:

- Displaying your Favourite Spaces
- Categorising your Spaces
- Displaying your Favourite Pages
- Related Topics

Displaying your Favourite Spaces

Mark some spaces as favourites. You can now click the Spaces tab on the dashboard to see a list of your favourite spaces. You can also click the Favourite Spaces tab at the top right of the dashboard to see recently updated content from just your favourite spaces.

Categorising your Spaces

To help keep Confluence spaces organised, you can label spaces with different space categories. See Using Labels to Categorise Spaces. Space categories are used to group related spaces.

For example, you might want to group spaces on your Confluence site by applying the following space categories to the relevant spaces:

- 'design' (for spaces relevant to a design team), and
- 'development' (for spaces relevant to a development team).

If a subset of these spaces is relevant to both teams, apply both the 'design' and 'development' categories to each of these spaces to make the spaces appear in both groups.

Once you have added space categories, you can click the Space Categories tab at the top right of the dashboard and select a category from the drop-down menu to display only spaces belonging to that category.

Displaying your Favourite Pages

Related Topics
Mark some pages as favourites. You can now click the Pages tab on the dashboard to see a list of your favourite pages.

Screenshot: The dashboard, showing favourite pages and space categories

Welcome to Confluence
Confluence combines powerful online authoring capabilities, deep Office integration and an extensive plugin catalogue to help people work better together and share information effortlessly.

Get started by adding a new space to create content in. Add a few users to try out Confluence with you.

If you want to display a different message here, you can easily change the welcome message.

Spaces  Pages  Network

Favourite Pages
- Egg-ding New Frontlines Reports
- World Saved, Services Will Now Resume As Usual
- Home
- Rise of the Machines Part 5 - Development in the World of Tomorrow
- Sales Q3 Release Notes
- Tech writer brilliance kickoff
- Atlassian Partner Milestones

Related Topics
Working with Confluence Labels
Working with Favourites
Configuring the Site Home Page
Customising the Dashboard

Take me back to the Confluence User's Guide.

Customising the Look and Feel of a Confluence Space
You can customise the 'look and feel' of a space on your Confluence site through options available in the Space Administration menu. By default, the look and feel of a space is based on global settings configured from the Administration Console.

You need to be a space administrator to change the look and feel of a space.

- Applying a Theme to a Space
- Changing a Space's Logo
- Changing the Confluence Browser Icon, aka favicon
- Customising Space Layouts
- Editing a Space’s Colour Scheme
- Styling Confluence with CSS

Related pages:
- Design and Layout
- Working with Spaces
- Confluence User's Guide

Applying a Theme to a Space
Themes allow you to personalise the 'look and feel' of Confluence. You can apply a theme to your entire Confluence site and to individual spaces. Choose a specific theme if you want to add new functionality or
significantly alter the appearance of Confluence.

Confluence comes with a selection of themes. In addition, a site administrator can install new themes as plugins via the Confluence Administration Console. Provided that the theme is installed into your Confluence site, any space administrator can apply a theme to a space.

By default when you create a new space, the space will have the Confluence default theme.

To apply a theme to a space:

1. Choose Browse > Space Admin.
   
   Note: 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
2. Click Themes in the left-hand panel under 'Look and Feel'.
3. Select a theme option.
4. Click Confirm.

Screenshot: Applying a theme

Related Topics

Applying a Theme to a Site
Editing a Space's Colour Scheme
Customising the Look and Feel of a Confluence Space

Take me back to Confluence User's Guide

Configuring the Documentation Theme

The Documentation theme is one of the themes bundled with Confluence. (See availability below). The theme is designed for spaces containing technical documentation, but you may find it useful for other types of content too. It provides an inbuilt table of contents for your wiki space, a configurable header and footer, and text styles suited to documentation. (See features below.)
Quick guide to applying and customising the Documentation theme

- Go to Space Admin and click Themes.
- Select Documentation Theme and click Confirm.
- If you want to customise the theme, click Configure theme.
  - Select or deselect the default page tree.
  - Select or deselect the space-restricted search.
  - Enter the text and wiki markup for your custom left-hand panel header and footer.
  - Click Save.

The rest of this page gives more details of the above procedure.

On this page:

- Applying the Documentation Theme to your Space
- Applying the Documentation Theme to your Site
- Customising the Documentation Theme
- Features of the Documentation Theme
- Availability of the Theme
- Hints and Tips
- Related Topics

Screenshot: A wiki page using the Documentation theme

Applying the Documentation Theme to your Space

You need space administrator permissions to apply a theme to a space.
Follow the steps below to apply the 'Documentation Theme' to your space. All pages in the space will start using the theme immediately.

To apply a theme to a space:
1. Choose Browse > Space Admin.
   *Note:* 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
2. Click Themes in the left-hand panel under 'Look and Feel'.
3. Select a theme option.
4. Click Confirm.

**Screenshot: Applying a theme**

**Applying the Documentation Theme to your Site**

If you have site administrator permissions, you can apply the theme at site level. It will then be the default theme for all spaces in the site. See the administrator's guide to applying a theme.

**Customising the Documentation Theme**

The theme works well without any customisation. If necessary, you can restrict the search to just one space, change the content of the left-hand navigation panel and add your own header and footer.

**To customise the Documentation theme:**

1. Choose Browse > Space Admin.
   *Note:* 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
2. Click Themes in the left-hand panel under the heading 'Look and Feel'.
3. If the space is not yet using the Documentation theme, apply the theme as described above.
4. Click Configure theme in the yellow area of the 'Current Theme' section at the top of the page. See screenshot below. The 'Documentation Theme Configuration' screen appears. See screenshot below.
5. Select or deselect the Page Tree check box. This determines whether your space will display the default
search box and table of contents (page tree) in the left-hand panel.

6. Select or deselect the **Limit search results to the current space** check box.
   - If you select the check box:
     - The Confluence search will look for matches only in the current space by default. Users can override this restriction when entering their search term. See *Using the Documentation Theme*.
     - The default page tree in the left-hand panel will not include a search box.
   - If you do not select the check box:
     - The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
     - The default page tree in the left-hand panel will include a search box, which restricts search results to the current space.

7. Enter text, images, macros and other wiki markup into any or all of the three text boxes.
   - You can use the *Include* or *Excerpt Include* to include re-usable content into your footer. See hint below.
   - 'Navigation' – This text box contains content for the left-hand panel.
     - If the *Page Tree* check box is selected, the navigation panel contains the default search box and page tree. Any content you enter into the 'Navigation' text box will appear above the page tree and search box.
     - You can include your own content *underneath* the page tree as well as above. See hint below. In summary: Deselect the *Page Tree* check box. Insert your own page tree using the Pagetree macro, then add your own content under the macro.
   - 'Header' – This text box contains content for a page header that will appear above the page title on all pages in the space. See example screenshot below.
   - 'Footer' – This text box contains content for a page footer that will appear after the comments and above the site footer, on all pages in the space. See example screenshot below.

8. Click **Save**.

**Screenshot: The 'Configure theme' option**

**Current Theme**

The current theme controls the layout and colours of this space.

<table>
<thead>
<tr>
<th>Documentation Theme</th>
</tr>
</thead>
<tbody>
<tr>
<td>Featuring a page tree or a custom navigation, the documentation theme makes it easy to navigate through your Confluence site. The theme is optimised for Firefox, Safari and Internet Explorer 7+.</td>
</tr>
</tbody>
</table>

**Configure theme** - further customise this theme’s options

**Screenshot: Customising the Documentation theme**
Customising the Theme at Site Level

If you have site administrator permissions, you can apply and customise the theme at site level. The customisation options are the same as the space level options, as described above.

Features of the Documentation Theme

Screenshot: A customised header, footer and left-hand panel
The above screenshot shows a wiki space with a customised left-hand panel, header and footer.

Here is a summary of the features that the Documentation theme provides:

- By default, the left-hand panel contains a search box and a table of contents (page tree) showing all the pages in your space. Specifically, it shows the pages that are children of the space's home page.
- The left-hand panel is fully customisable. You can choose to include or exclude the search box and page tree. You can enter your own text, images and wiki markup.
- People viewing the page can drag the thick bar between the left-hand panel and the content, to increase or decrease the width of the panel. They can also remove the panel altogether, by clicking the sidebar icon at top right, next to the search box.
- The left-hand and right-hand panels scroll independently of each other.
- The page title is neatly above the page content, and not uncomfortably above the navigation panel as tends to happen when you insert the navigation panel yourself.
- Because the left-hand panel is part of the theme, it will be upgraded whenever Confluence is upgraded. There is no need to remove and then re-apply your customisations on each upgrade, as you would do if you added your own left-hand navigation bar.
- The theme also provides a customisable header and footer, which will appear at the top and bottom of every page.
- The text and heading styles are designed to enhance the content typically found in a documentation space.
- You can use the Space Jump macro to link from a page in one wiki space to a page with the same name in another space, without knowing the name of the page when you create the link.
- You can limit the Confluence search results to the current space. If you choose this option, the
Confluence search will look for matches only in the current space by default. Users can override the restriction. See Using the Documentation Theme.

Availability of the Theme

Confluence Versions

The Documentation theme is bundled with Confluence 3.2 and later. If you have Confluence 3.1, your Confluence Administrator can download the theme from the Atlassian Plugin Exchange and install it as a plugin.

The theme is not available for versions of Confluence earlier than Confluence 3.1.

Hints and Tips

Below are some hints that you may find useful when using the Documentation theme. Where can I see a working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme's table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page. Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

Cause 1: Your pages are not under the space’s home page. The most probable reason why your pages do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space’s home page. If your pages are above the home page in the page tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

- You can change the designated space home page in the space administration section.
- Or you can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the ‘Pages’ section of the space ‘Browse’ screen. See Moving a Page.

Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with Documentation theme bundled. If your existing Confluence installation already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar icon at top right, next to the search box. Click the icon again to restore the panel.
Hiding pages from the left-hand table of contents

You can 'hide' pages by putting them at the same level as or higher than the space home page. Each space has a single page designated as the 'Home' page. You can specify the home page in the space administration section.

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page.

If your documentation pages are at the same level as the space home page, they will not appear in the left-hand navigation bar. So you can 'hide' pages by putting them at the same level as or higher than the space home page. The pages will show up in the search results and people can see the content if they open the page, but the pages will not appear in the left-hand panel.

More detail: The theme uses the Pagetree macro to produce the table of contents. When entering the Pagetree macro, you can choose the top page in the page tree. The Documentation theme chooses the space home page as the top page.

Using reusable content in your header, footer or left-hand panel

You can use any text or wiki markup in your theme header, footer or left-hand panel. One useful hint is to use the Include or Excerpt Include to include re-usable content into your footer.

The screenshot above shows the theme customisation options, with examples of the macros used to include content from other pages. And the example screenshot also above shows the resulting header, footer and left-hand panel.

Adding content below the page tree in your left-hand panel

If you want to include your own content underneath the page tree, you can deselect the 'Page Tree' check box, add your own page tree using the Pagetree macro in the 'Navigation' text box, and then add your own content under the macro.

The screenshot above shows the theme customisation options, with the default page tree deselected and a custom page tree inserted, along with additional content in the left-hand panel. The example screenshot also above shows the resulting left-hand panel.

Adding underlines to your links

By default, the Documentation theme does not underline hyperlinks. If you prefer to have your links underlined, you can edit the CSS stylesheet for your space and add the following CSS code:

```css
.wiki-content a:link, .wiki-content a:visited, .wiki-content a:active {
  text-decoration: underline;
}
```

To edit a space's CSS style sheets:
1. Choose **Browse > Space Admin.**
   *Note: 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).*

2. Click **Stylesheet** in the left-hand panel under the heading 'Look and Feel'.
3. Click **Edit**.
4. Paste your custom CSS into the text field.
5. Click **Save**. The new CSS will be visible on all content pages in the space.

Notes:
- You need system administrator permissions to edit the CSS for a space or for the site.
- This function is turned off by default. To turn it on, go to Confluence Admin > Security Configuration and choose Custom Stylesheets for Spaces.

**Jumping to the same page in another space**

The {spacejump} macro is provided along with the Documentation theme. You can use space jumping to link from a page in one wiki space to a page with the same name in another space, without knowing the name of the page when you create the link. When a reader is viewing a page and clicks the link provided by the macro, they will go to a page with the same name, but in the space specified in the macro. See more about the Space Jump macro.

**Hiding the left-hand panel completely**

It's not possible to remove the left-hand panel entirely, using the user interface supplied by the theme. There is an improvement request here: CONF-25923 - Authenticate to see issue details If you like, you can comment on and/or vote for that request. In the meantime, Atlassian Answers is a good place to ask the question and see if other people can help you with custom code to remove the panel.

**Related Topics**

- Using the Documentation Theme
- Space Jump Macro
- Applying a Theme to a Space
- Applying a Theme to a Site
- Editing a Space's Colour Scheme
- Customising the Look and Feel of a Confluence Space

Take me back to Confluence User's Guide

**Configuring the Easy Reader Theme**

The Easy Reader theme is one of the themes bundled with Confluence. This is a fixed-width variation of the default Confluence theme. Its larger fonts, smooth gradient background and comfortable line length make it ideal for displaying and reading longer documents.

Quick guide to applying the Easy Reader theme

1. Choose **Space Admin > Themes**.
2. Select **Easy Reader Theme**.
3. Click **Confirm**.

The rest of this page gives more details of the above procedure.

**On this page:**

- Applying the Easy Reader Theme to your Space
- Customising the Look and Feel of the Easy Reader Theme
You need space administrator permissions to apply a theme to a space.

**Applying the Easy Reader Theme to your Space**

Follow the steps below to apply the 'Easy Reader Theme' to your space. All pages in the space will start using the theme immediately.

**To apply a theme to a space:**

1. Choose **Browse > Space Admin**.
   
   *Note:* 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).

2. Click **Themes** in the left-hand panel under 'Look and Feel'.
3. Select a theme option.
4. Click **Confirm**.

**Screenshot: Applying a theme**
Applying the theme to your entire Confluence site

If you have site administrator permissions, you can apply the theme at site level. It will then be the default theme for all spaces in the site. See the administrator's guide to applying a theme.

Customising the Look and Feel of the Easy Reader Theme

You can customise the space CSS style sheets to change the colours, background image and other styles in the theme. See the guide to using CSS to customise the Easy Reader theme.

Hints and Tips

If a page has content that is very wide, it will either:

- cause a scroll bar to appear, or
- break out, i.e. the content will extend over the right-hand border of the page.

Related Topics

Applying a Theme to a Space
Applying a Theme to a Site
Customising the Look and Feel of a Confluence Space

Take me back to the Confluence User's Guide

Changing a Space's Logo

In Confluence, you can replace the default logo for a space with a logo of your own choice.

You need to be a space administrator to replace a space's logo.

The instructions below refer to global spaces. For your personal space, your profile picture is used as the space icon.
To change a space's logo:

1. Choose Browse > Space Admin.  
   *Note:* 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).

2. Click Change Space Logo in the left panel under the heading 'Look and Feel'. See the screenshot below.

3. Use the browse option to locate the new logo and click Upload.

**Hint:** A space logo looks best if the height and width of the image are of the same or similar length. In other words, the area occupied by the image, including white space, should be square rather than rectangular.

---

**Screenshot: Changing a space's logo**

**Change the logo for this space.**

- **Image**
- **Upload Logo**
- **Current** (default)

---

**Changing the Confluence Browser Icon, aka favicon**

⚠️ **Document status as of 26-Aug-2012**

These changes work in Confluence 4.2.x however some may not be needed. We're confirming which ones are redundant at the moment, however in the meantime please make all the changes listed below to ensure it works. Backing up the old files is strongly recommended.

The Confluence logo is displayed in the user's browser to identify the Confluence browser tab. To use a custom image for your Confluence site:

1. Obtain or create an image in PNG file format. To maximise browser compatibility, it should be 32x32 pixels in size, 71x71 DPI (dots per inch) and have an 8 bit colour depth.
2. In your Confluence installation, find the ...\confluence\images\icons directory.
3. Back up the file favicon.png.
4. Replace the favicon.png file with your custom PNG image.

***You may also need to back up and replace the following images in your Confluence installation:
5. Restart your application server.

The information on this page does not apply to Confluence OnDemand.

Users may need to clear their browser cache before they will see the new image.

Converting a PNG to an icon

To create an ICO out of your PNG image, you can use the freeware tool png2ico or the the online tool at http://converticon.com/.

Related Topics

Customising the Look and Feel of a Confluence Space

Customising Space Layouts

You can modify Confluence’s look and feel by editing the ‘decorator’ (layout) files. This page tells you how to customise the layout files for a space.

Confluence system administrators can also customise the layout of their entire Confluence site as a whole. For more information, please refer to Customising Site and Space Layouts. Site layout customisations modify the default layout of all spaces in the Confluence site. However, any space layout customisations will override the equivalent site customisations.

A note about permissions: To perform these customisations, you will require space administrator permissions for that space. For security reasons, you must also have Confluence system administrator permissions to modify any space layout throughout your Confluence site.

If you modify the look and feel of Confluence by following these instructions, you will need to update your customisations when upgrading Confluence. The more dramatic the customisations are, the harder it will be to reapply your changes when upgrading. Please take this into account before proceeding with any customisations. For more information on updating your customisations, please refer to Upgrading Customised Site and Space Layouts.

Confluence is built on top of the Open Source SiteMesh library, a web-page layout system that provides a consistent look and feel across a site. SiteMesh works through ‘decorators’ that define a page’s layout and structure.

To edit the layout of Confluence, you will need to modify these decorator files. A decorator file is a .vmd file and is written in a very simple programming language called Velocity. Learn more about Velocity. Once you become familiar with Velocity, you can edit the decorator files to personalise the appearance of Confluence.

The decorator files in Confluence are grouped into the following categories:

- **Site layouts**: These are used to define the controls that surround each page in the site. For example, if you want to make changes to the header and the footer, you will need to modify these layouts.

- **Content layouts**: These control the appearance of content such as pages and blog posts. They do not change the way the pages themselves are displayed, but they allow you to alter the way the surrounding comments or attachments are shown.

- **Export layouts**: These control the appearance of spaces and pages when they are exported to HTML. If you are using Confluence to generate a static website, for example, you will need to modify these layouts.
Learn more about using decorators.

To edit a decorator file:

1. Choose **Browse > Space Admin.**  
   *Note:* 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the `confluence-administrators` group).

2. Click the **Layout** link in the left-hand panel, under **Look and Feel.** You will see a list of the layouts for the space.  
   (Layout is displayed only if you are a Confluence system administrator.)
   - Click **View Default** to view the vmd file.
   - Click **Create Custom** to edit the default vmd file. This will open up the vmd file in edit mode.  
     Make changes and click **Update**.

**Screenshot: Edit Layouts Example**

<table>
<thead>
<tr>
<th>Decorator</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Space Export Layout</strong></td>
<td>&lt; default &gt;</td>
</tr>
<tr>
<td>When you export a space to HTML, this layout is used to create the index page.</td>
<td></td>
</tr>
<tr>
<td><strong>Page Export Layout</strong></td>
<td>&lt; default &gt;</td>
</tr>
<tr>
<td>When you perform an export, each page is converted to HTML using this layout.</td>
<td></td>
</tr>
</tbody>
</table>

Click the thumbnail to see an example of a vmd file:

Click the thumbnail to see an example of a vmd file:

**Related Topics**

- Customising the Look and Feel of a Confluence Space
- Applying a Theme to a Space
- Administrator’s Guide - Design and Layout

Take me back to the [Confluence User's Guide](#).

**Editing a Space’s Colour Scheme**

Confluence allows you to customise the colour scheme of a space. By default, a space’s colour scheme is based on [global settings](#) configured from the **Administration Console**.

You need to be a [space administrator](#) to edit a space’s colour scheme.

**To change the colour scheme for a space:**

1. Choose **Browse > Space Admin.**  
   *Note:* 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the `confluence-administrators` group).

2. Click **Colour Scheme** in the left-hand panel under the heading **Look and Feel.**

3. Click **Select** next to a colour scheme under **Custom Colour Scheme** (if not already selected).
4. Click the **Edit** link. This will bring up a new screen. See screenshot below.

5. Enter standard HTML/CSS2 colour codes, or use the colour-picker to choose a new colour from the palette provided. Any changes you make will immediately be reflected in this space.

The colour scheme applies to the following UI elements:

- **Top Bar** - the bar across the top of the page that contains the breadcrumbs
- **Tab Navigation Background** - the background colour of the tab navigation menus
- **Tab Navigation Text** - the text of the tab navigation menus
- **Breadcrumbs Text** - the breadcrumbs text in the top bar of the page
- **Space Name Text** - the text of the current space name located above the page title
- **Heading Text** - all heading tags throughout the space
- **Links** - all links throughout the space
- **Borders and Dividers** - table borders and dividing lines
- **Tab Navigation Background Highlight** - the background colour of the tab navigation menu when highlighted
- **Tab Navigation Text Highlight** - the text of the tab navigation menu when highlighted
- **Top Bar Menu Selected Background** - the background colour of the top bar drop down menu when selected
- **Top Bar Menu Item** - the text colour of the menu items in the top bar drop down menu
- **Page Menu Selected Background** - the background colour of the drop down page menu when selected
- **Page Menu Item Text** - the text of the menu items in the drop down page menu
- **Menu Item Selected Background** - the background colour of the menu item when selected (applies to both the top bar and page drop down menus)
- **Menu Item Selected Text** - the text colour of the menu item when selected (applies to both the top bar and page drop down menus)

Please note that some UI elements are specific to the default theme and may not take affect for other themes.

*Screenshot: Editing a space's colour scheme*
Custom Colour Scheme
A custom colour scheme which can be edited.

Selected

The following colours can be customised for this colour scheme.

- **Top Bar**: #003366
- **Tab Navigation Background**: #3c78b5
- **Tab Navigation Text**: #ffffff
- **Breadcrumbs Text**: #ffffff
- **Space Name Text**: #9f9f9f
- **Heading Text**: #003366
- **Links**: #003366
- **Borders and Dividers**: #3c78b5
- **Tab Navigation Background Highlight**: #003366
- **Tab Navigation Text Highlight**: #ffffff
- **Top Bar Menu Selected Background**: #336999
- **Top Bar Menu Item Text**: #003366
- **Page Menu Selected Background**: #699cc
- **Page Menu Item Text**: #535353
- **Menu Item Selected Background**: #699cc
- **Menu Item Selected Text**: #ffffff

Reset  Save  Cancel

Handy Hint
If you mess things up, just click the **Reset** button and then try again.

Related Topics

- Customising the Look and Feel of a Confluence Space
- Take me back to Confluence User’s Guide

Styling Confluence with CSS

This page explains the facility for changing the look and feel of Confluence with CSS.

On this page:

- Introduction
- Considerations for Using Custom CSS
- Getting Started
- CSS Resources
- Related Pages

Introduction

Cascading Style Sheets (CSS) are an industry-standard way of styling a web page. The content of a page is rendered with HTML, and its look and feel is determined by CSS files. You can upload a CSS text file, or simply
type in a stylesheet, and apply it to a space or even a whole Confluence site.

Notes:
- You need system administrator permissions to edit the CSS for a space or for the site.
- This function is turned off by default. To turn it on, go to Confluence Admin > Security Configuration and choose Custom Stylesheets for Spaces.

Creating CSS styles that work seamlessly across different browsers is a delicate task for basic web sites, and reasonably challenging when customising web applications like Confluence. It is important to test each change that you make and ensure it works as expected in all areas of Confluence – for example, on the Confluence dashboard as well as on regular pages.

In order to get you started, we have compiled this introduction, a basic styling tutorial and a more advanced tutorial.

Considerations for Using Custom CSS

CSS Knowledge is Required

If you are not familiar with CSS, see the links in the CSS Resources section below. You should spend some time to become confident with Cascading Style Sheets before you start editing your Confluence style sheets.

Security

Custom CSS can be used to inject scripts into a page, opening the risk of cross-site scripting (XSS) attacks. With this feature enabled, space administrators could upload styles that steal other users’ login credentials, trick their browsers into performing actions on the wiki without their knowledge, or even obtain global administration privileges. As such, this feature is disabled by default. Confluence administrators should only enable custom CSS if they are comfortable with the risks listed in this paragraph.

Scaling

Each page needs to scale. Depending on the resolution of the user's screen, the content should render intelligently. Your designs need to degrade gracefully. Try resizing each page that exists in Confluence. There are quite a few pages in the browse-space-section, like drafts, labels, page hierarchy, and so on. Your style has to work everywhere, not just in the first page you happen to be looking at.

Features Cannot Be Disabled

It is easy to turn off certain links, headers, or even menu items by simply setting their style to 'hidden'. This can help you to roll out Confluence to users that may not be very Wiki-savvy yet. The simpler the UI, the easier it may be for them to use. However, please remember that removing the link to a part of the application does not mean that the functionality is not available. Every user can still change their style from within their browsers, or access the URL directly. Don't rely on CSS to disable parts of Confluence.

Features Should Not Be Disabled

Users familiar with Confluence will expect to find the same controls that they are accustomed to. Removing buttons or controls from the interface is not advised as it may frustrate your users and cause them to circumvent your design by using direct URL access, as mentioned above.

Confluence Version Compatibility

Be aware of any plans to upgrade your Confluence instance. Future versions of Confluence may not be compatible with your custom CSS — this may cause your CSS to break, requiring maintenance when Confluence is upgraded. Ask your Confluence administrator for more information.

Test on Different Web Browsers

As a rule you should test your modifications on different web browsers. Internet Explorer, Firefox, Opera and
Safari (on Mac OS X) are some of the more popular browsers.

**Note about supported web browsers:** Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. You can find the list of supported web browsers and browser versions on this page: [Supported Platforms](#).

**CSS Customisation is Not Supported**

As creating custom CSS has potentially limitless possibilities, Atlassian will not support issues that are caused by or related to CSS customisation.

**Getting Started**

*Editing the CSS*

**To edit a space's CSS style sheets:**
1. Choose **Browse > Space Admin.**
   
   *Note:* 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
2. Click **Stylesheet** in the left-hand panel under the heading 'Look and Feel'.
3. Click **Edit**.
4. Paste your custom CSS into the text field.
5. Click **Save**. The new CSS will be visible on all content pages in the space.

*Follow the Tutorial*

Follow the examples in the [Basic Styling Tutorial](#) or the more advanced [Styling Tabs in Confluence](#) to get started.

**CSS Resources**

- [W3C CSS Standards](#)
- [W3schools CSS Introduction](#)
- [Mozilla Developer Network](#)
- [W3resource.com](#)

**Related Pages**

Basic Styling Tutorial
Styling Tabs in Confluence
Styling Fonts in Confluence
Including Cascading Stylesheets in Themes

**Basic Styling Tutorial**

This page contains instructions on how to get started with custom CSS styling in Confluence.

**On this page:**

- [CSS Editing Quick-Start](#)
- [Tutorial: Changing the Header Background](#)
- [CSS Editing Tips](#)
  - [Begin With a Space Stylesheet](#)
  - [Use the Right Tools](#)
  - [Edit Simple Elements First](#)
- [Related Topics](#)

*CSS Editing Quick-Start*
To edit a space’s CSS style sheets:
1. Choose Browse > Space Admin.
   Note: ‘Space Admin’ is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
2. Click Stylesheet in the left-hand panel under the heading ‘Look and Feel’.
3. Click Edit.
4. Paste your custom CSS into the text field.
5. Click Save. The new CSS will be visible on all content pages in the space.

Tutorial: Changing the Header Background

The header is the menu area at the top of a default Confluence page where the Breadcrumb Links, Browse menu, User menu and the Quick Search box reside. In this example, we are going to change the background of the header to include a custom graphic.

1. Create a custom graphic. For this example, we created a custom header graphic of 1046 x 61 pixels.
2. Upload the custom graphic to a page in the space that you are customising.
3. Note the page ID of the page where you uploaded the new graphic. (in this example, the page ID was ‘658833839’).
4. Compose your custom CSS for the header. The example below loads the new graphic (called ‘header.png’) from a specific page (denoted by page ID ‘658833839’) in the same space.

```css
#header {
    background-image:url('../download/attachments/658833839/header.png');
    background-repeat: no-repeat;
}
```

5. Log in as the Space Administrator.
6. Open the Space Admin page.
7. Click Stylesheet.
8. Click Edit to change the code in the text field.
9. Paste your custom CSS into the text field.
10. Click Save and then reload the page (you may have to shift-reload). The background of the header will change.
11. The custom header will be visible on all content pages in the space. To revert your change, simple delete the custom code from the ‘Stylesheet’ page and click Save.

CSS Editing Tips

Begin With a Space Stylesheet

A space stylesheet is a good starting point for CSS customisation, as it already includes all of the elements that can be changed. When you work on the space stylesheet it styles all content pages in the space. Build and test it at space-level, before considering applying the new stylesheet to your entire site. Once you are satisfied with your space design, test it thoroughly until you are confident that it has no problems. Then, you can look into advanced customisation of the Confluence CSS such as adjusting the Search page, the Dashboard and other integral pages.

Use the Right Tools

As the Confluence CSS is reasonably sophisticated, web development applications will help you to understand how the page styles have been created. In particular, you will need to view the existing source for the pages you’re starting to work on. If you don’t already have some, tools such as the following free applications will allow you to do this.
1. **Firebug**
Firebug, a plugin for the Firefox web browser, allows you to take a look at the style of each element on your page. This is very useful to see what styles are currently applied, for example styles applied to the header only.

2. **Web Developer**
The Web Developer plugin for Firefox allows you to edit CSS inline and create new page designs.

3. **CSS Edit**
CSS Edit is a stand-alone CSS editor for Macintosh that extracts all existing styles from a given page and allows you to overwrite these.

### Edit Simple Elements First

Begin by editing simple elements and checking that they work. By making changes, then checking that each one worked, you can easily isolate any CSS code that is causing problems. Be aware that some page elements are more suited to customisation than others. For example, adding a gradient to the toolbar is less likely to 'break' the page than changing the page width. Editing reasonably static elements such as background graphics will render more predictably than designs which attempt to completely change the user interface or the Javascript-powered drop-down menus (which we don't recommend editing).

### Related Topics
- Styling Confluence with CSS
- Styling Tabs in Confluence
- Including Cascading Stylesheets in Themes
- Styling Fonts in Confluence

Confluence provides the ability to adjust its visual style via Cascading Style Sheets (CSS). With this feature, it is very easy to change the look and feel of Confluence.

This tutorial shows you to change the fonts of a normal Confluence page. We will show how to change the font and font sizes with a few lines of CSS.

**Screenshot 1: Default Font in a Confluence Page**

**Screenshot 2: Custom Font in a Confluence Page**
At the bottom of this page you can find the code for the custom font. Simply copy and paste it into the Space Stylesheet form within the Space Administration section.

**Changing the fonts**

In order to customise the fonts in Confluence, you first need to set the body font to the font you want. Second, you may want to adjust the font size to account for the fact that different fonts have different relative sizes.

The relevant CSS is shown below, and can be configured in Space Admin > Stylesheets. These styles change Confluence’s font from its default of Helvetica/Arial – *sans serif* fonts – to Times/Times New Roman – *serif* fonts. To adjust for the fact that Times is a bit smaller than Helvetica, we increase the font size to 14 pixels.

```css
body {
  font-family: Times, "Times New Roman", serif;
  font-size: 14px;
}
.wiki-content,
  .wiki-content p,
  .wiki-content table,
  .wiki-content tr,
  .wiki-content td,
  .wiki-content th,
  .wiki-content ol,
  .wiki-content ul,
  .wiki-content li { font-size: 14px;
}
```

The many styles which include 'wiki-content' are necessary to change the font-size for all the tags in the wiki content.

**Related Topics**

- Basic Styling Tutorial
- Styling Tabs in Confluence
- Including Cascading Stylesheets in Themes

**Styling Tabs in Confluence**

Confluence provides the ability to adjust its visual style via Cascading Style Sheets (CSS). With this feature, it is very easy to change the look and feel of Confluence.
This tutorial shows you how to change the look and feel of Confluence. We will address the Confluence tabs in this tutorial and how we can change their look completely with a few lines of CSS.

Let's take a look at what we are trying to achieve. Notice the dark blue tabs in Screenshot 1? Our goal is to blend them into the background and change the text style as in Screenshot 2.

**Screenshot 1: Default Confluence Tabs in Admin Screen**

![Screenshot 1: Default Confluence Tabs in Admin Screen](image1)

**Screenshot 2: Customised Confluence Tabs in Admin Screen**

![Screenshot 2: Customised Confluence Tabs in Admin Screen](image2)

At the bottom of this page you can find the code for the custom tabs. Simply copy and paste it into the Space Stylesheet form within the Space Administration section. Let's discuss each selector in detail:

**Container Style**

```css
#navigation, #tab-navigation{
    border-bottom: 1px solid #CCC;
    background-color: transparent;
    margin: 1em 0 2em -5px;
}
```

Let's start with the container around the tabs. We don't want a background-color for the tabs and the container, therefore we will set the color to be transparent. With the border-bottom attribute we will create a thin grey line at the bottom to separate the navigation from the rest of the page. Lastly we adjust the margins of the container to create some space around the tabs.

**Tab Style**
Then we style each link within the tab. We set the `font-weight` to normal, to make the tabs less dominant and change the color to a dark grey. We also have to specify the `border` and `background-color` attributes explicitly to overwrite the default styles in Confluence. If we don’t specify the background color for example, the blue color of the default style will be applied.

**Hover Style**

```css
.tab-navigation .tab a:hover {
    font-weight: normal;
    color: #0088CC;
    background-color: transparent;
    border: none;
}
```

Now we want to specify the `hover` attributes of the links. Note that we have to overwrite the `background-color` and the `border` attributes again, otherwise the default styles will be applied. We also change the color of the text for the hover effect of the link.

**Currently Selected Element Style**

```css
ul.tab-navigation .current a:hover, ul.tab-navigation .current a {
    color: #000000;
    background-color: transparent;
    border: none;
}
```

The last selector we will need to customise is the element with the class current. Note that we use a more specific selector this time. The reason we are doing this is because these specific selectors are used in the default CSS stylesheet. If we were to use more general selectors, like we did above (ignoring the `ul`), the default style would still be applied since more specific selectors are rendered with a higher priority. We want to keep the general style of the other links but simply change the `color` of the text to black.

**Complete CSS Style**

Simply copy and paste the code below to change the look of the tabs in Confluence.
/* @group Tab Styles */

.tab-navigation .tab a {
    font-weight: normal;
    color: #999999;
    background-color: transparent;
    border: none;
}

.tab-navigation .tab a:hover {
    font-weight: normal;
    color: #0088CC;
    background-color: transparent;
    border: none;
}

#navigation, #tab-navigation {
    border-bottom-color: #CCC;
    margin: 1em 0 2em -10px;
    background-color: transparent;
}

ul.tab-navigation .current a:hover, ul.tab-navigation .current a {
    background-color: transparent;
    border: none;
    color: #000000;
}

/* @end */

Related Topics

Basic Styling Tutorial
Styling Tabs in Confluence
Including Cascading Stylesheets in Themes

Using CSS to Customise the Easy Reader Theme

This page gives some hints on using the space CSS style sheets to customise the Easy Reader theme.

You can customise the Easy Reader theme using CSS at space or site level. A common modification is to change or remove the background image.

⚠️ CSS elements are specific to each theme

You will need to match your theme choice and custom CSS. If you want to use the CSS on this page, you will need to apply it to a space that is using the Easy Reader theme. If you apply the CSS at site level, then your entire site must use the Easy Reader theme.

Editing the CSS

To edit a space’s CSS style sheets:
1. Choose Browse > Space Admin.
   
   Note: 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
To change the background image:

```css
body { background: #ccc url("path/to/your/background.gif") 50% 0 repeat-y; }
```

Remember to set an appropriate background colour to extend past the left and right edges of the image. In the example we use colour code #ccc. This colour should match the last pixel on the left and right of your background image.

To replace the theme’s gradient image with your choice of background colour:

```css
body { background: #ccc; }
```

To add a border to the left and right of the content area, using a specific colour (in the example we use colour code #ccc):

```css
#full-height-container { border-left: 1px solid #ccc; border-right: 1px solid #ccc; }
```

### Related Topics

- Configuring the Easy Reader Theme
- Styling Confluence with CSS

### Giving People Access to Content

Confluence gives you the choice to make the site as open or as closed as you wish. Here are some points to consider:

- As a tool for communication and collaboration, Confluence is at its best when all your users can participate fully.
- So it is advisable not to restrict users unless you have a good reason for doing so.
- Confluence keeps a history of all changes to pages and other content. So it is easy to see who has changed what, and to reverse any edits if required.
Levels of permission

There are three levels of permissions in Confluence.

Global permissions

Global permissions are site-wide permissions, and are assigned by administrators. Confluence allows two levels of administrator permissions:

- **System Administrator** - Users with this permission can perform all the Confluence administrative functions.
- **Confluence Administrator** - Users with this permission can perform most of the Confluence administrative functions, but excluding those functions which could compromise the security of the Confluence system.

Users with 'System Administrator' or 'Confluence Administrator' permission can assign permissions to other users. For full details, please refer to the overview of global permissions in the Administrator's Guide.

Space permissions

The permission to create a new space or to administer one is granted by a Confluence Administrator from the global Administration Console.

Every space has its own independent set of permissions. These permissions determine the access settings for different users of the space. In order to assign these permissions to other users, a user must be a space administrator i.e. must have the 'Admin' permission for that space.

See Users and Groups to learn how these permissions are assigned.

**Note:** If you misconfigure a space so that nobody has access to administer it any more, someone in the 'confluence-administrators' group will need to fix the permissions for you.

Page restrictions

You can set page-level restrictions, if you have the 'Restrict Pages' permission within the space concerned.

Page restrictions allow you to control who can view or edit individual pages. To set page restrictions, edit the page and use the page restriction options below the text-entry box.

On this page:

- Levels of permission
  - Global permissions
  - Space permissions
  - Page restrictions

- More information
  - How do space permissions and page restrictions work together?
  - How do space permissions and page restrictions affect links?

Related pages:

- Users and Groups
- Global Permissions Overview
- Space Permissions Overview
- Page Restrictions
- Configuring Confluence Security
- Confluence Security
- Confluence User's Guide
More information

How do space permissions and page restrictions work together?

Example: In the HR (Human Resources) space, everyone in the organisation has the 'View' space permission, but only the HR team has the 'Pages --> Create' space permission (i.e. the ability to create and edit pages in the space). A member of the HR team starts to create a new page called 'Annual Leave Policy'. Because the page is not yet finished, she sets the 'Viewing' page restriction so that only the HR team can view the page. When the page is finished, she will remove the 'Viewing' restriction so that everyone in the company can see the page.

How do space permissions and page restrictions affect links?

Space permissions and page restrictions affect how links between pages are displayed to a visitor:

- if the link points to a page in a space to which the visitor does not have 'View' space permission, the link will not be rendered at all.
- if the visitor has 'View' space permission, but page restrictions prohibit her from viewing the page, the link will be rendered but an 'Access Denied' message will be displayed when she clicks the link.
- if the visitor has 'View' space permission, and is not restricted from viewing the page, the link will display and behave as normal.

Links to attachments are also affected: If the visitor does not have permission to view the page to which the attachment is attached, the link will not be rendered.

Page Restrictions

Page restrictions allow you to control who can view or edit individual pages. You set the page restrictions using the Page Restrictions dialog, either directly by choosing Tools > Restrictions, or when editing a page.

For instructions on using the Page Restrictions dialog, refer to Setting a Page's Restrictions.

When a page you are viewing has restrictions applied, a small padlock icon 🗝 appears next to the page byline. Clicking the padlock will open the Page Restrictions dialog, where full details on the page restrictions are displayed.
The Confluence Permissions and Page Restrictions Hierarchy

Permissions and page restrictions in Confluence work within a hierarchical manner. For example, users who can access and modify global permissions (for instance, Confluence Administrators) can define which users can access and modify space level permissions (that is, space administrators). Space administrators can then define which users have access to create and modify pages. These users in turn can then apply viewing and editing restrictions to a page. By inheritance, these restrictions will also be applied to any child or descendant pages which are then added to that page.

See the diagram below for an illustration.

*Diagram: Confluence Restrictions Hierarchy*
Requirements for Setting Restrictions

In order to set or modify page restrictions, you need to have both:

- 'Restrict Pages' permission in the space to which the page belongs (since page restrictions operate within the bounds of space permissions).
- Permission to edit the page itself. That is, if a user is prevented from editing a page through page restrictions, they are also prevented from changing the restrictions themselves.

Page Security Rules

Users can only view page or space content for which they (or a group they are in) have 'View' permission. Pages that a user does not have 'View' access to are referred to as 'inaccessible' pages. Visit Inaccessible Page to see how Confluence deals with pages a user cannot view:

- Anonymous users are directed to the login page.
- Logged-in users are shown a permissions error page.
It is not possible to conceal the existence of pages, though you can restrict 'View' access to page content. Users will still be able to find the page if they know its URL. But they will not be able to view the content if they don't have the correct permissions.

**Inherited Restrictions and Child Pages**

If a page has its 'View' restriction set, that restriction will be inherited by all its children (and their children, and so on). If a 'View' restriction is added to a page that has already inherited page restrictions from its parent, users must satisfy both restrictions in order to see the page.

'Edit' restrictions are not inherited from the parent page, only from the space. In a space, the 'Add Pages' permission governs both the creation and the editing of pages. See [Space Permissions Overview](#).

**Example of Child Page Restrictions**

Consider the page 'Documents', with a child page 'Executive', which itself has a child page 'Payroll'. To begin with, anyone who can view the space to which these pages belong can see all three pages.

For security reasons, 'View' restrictions are set on the 'Executive' page, restricting it to the 'mycompany-management group'. At this point, anyone can still see the 'Documents' page, but you must be in the 'mycompany-management group' in order to view either 'Executive' or 'Payroll'.

Since 'Payroll' information is considered particularly private, the 'Payroll' page then has its page restrictions set to only allow members of the 'mycompany-financial' group to view it. At this point, anyone can see the 'Documents' page, only members of 'mycompany-management' can see 'Executive', and only users who are members of both the 'mycompany-management' and 'mycompany-financial' groups can view 'Payroll'.

**How to Open Part of a Space**

If designing a large site implementation with this strategy, consult [Page Restrictions Performance Considerations](#).

Often there are cases for which a section of a space should be opened to a group or set of users (for this example, we'll call them group B), but the rest of the space should not be visible to your main users (for this example, we'll call them group A). In this case:

1. Add 'view' permission for both groups A and B in space permissions.
2. Move the page to be opened to the root of the space. When browsing the pages in the space, your normal space home page and this page should both be at the root level.
3. Add a page restriction to allow Group A and B to see this page.
4. Add a page restriction to your main landing page for Group A, thereby excluding this set of pages from Group B.

You can repeat this with any page hierarchy.

**Administrators**

- Space administrators are responsible for the management of a space and its contents. They therefore have the ability to remove all restrictions from a page (as described in 'Viewing Restricted Pages'). This means that space administrators can view and edit all content in the space.
- Users who are members of the 'confluence-administrators' group ('super-users') cannot immediately see pages from which they are excluded by page restrictions. Also, to be able to edit the page, you will need to remove the restriction from it first – go to [Space Administration > Restricted Pages](#).
You cannot exclude yourself

As creator or editor of a page, you cannot use page restrictions to deny yourself access to the page. Confluence will automatically add your username into the list of users/groups allowed to view/edit the page. If you remove your username, Confluence will put it back again.

Related Topics

View a Page's Restrictions
Set a Page's Restrictions
View All Restricted Pages
Page Restrictions Performance Considerations

Working with Pages

Take me back to the Confluence User's Guide.

Setting a Page's Restrictions

Page restrictions control who may view or edit a specific page, within the bounds of the space permissions:

- View restrictions make the page invisible to everyone except the chosen users and groups.
- Edit restrictions prevent everyone except the chosen users and groups from editing the page.

You can restrict the page to as many users and groups as you like.

In order to set or modify page restrictions, you need to have the 'Restrict Pages' permission in the space to which the page belongs, as well as permission to edit the page itself.

Setting Page Restrictions

To set restrictions on a page:

1. Choose Tools > Restrictions. The Page Restrictions dialog opens. You can also click the padlock icon in the page's byline (if available), or click either Unrestricted or Restricted when editing the page.
2. Select the restriction option required.
3. Choose the users and groups who you want to be able to view or edit the page:
   - To choose just yourself, click Me.
   - To choose a particular user or group, type the user's username (or their full name), or the group name, into the Enter ... name box, and click Restrict. You can enter multiple user and group names, when separated by commas.
   - To search for a user or group (if you are unsure of the name), click Person... or Group... (You can read more about searching for users.)
4. Click Save.

Screenshot: The Confluence Page Restrictions dialog
Removing Page Restrictions

To remove restrictions on a page:

1. Choose **Tools > Restrictions**. The Page Restrictions dialog opens. You can also click the padlock icon in the page's byline (if available), or click either **Unrestricted** or **Restricted** when editing the page.
2. Click **Remove restriction** next to the appropriate users or groups.
3. Click **Save**.

You can both set and remove restrictions for different users or groups when using the Page Restrictions dialog.

Notes

When a page you are viewing has restrictions applied, a small padlock icon appears next to the page byline. Clicking the padlock will open the Page Restrictions dialog, where full details on the page restrictions are displayed.

View and edit restrictions apply to all users including space administrators. However, space administrators can remove any restriction on a page. See Viewing Restricted Pages.

Related Topics

* Space Permissions Overview
* Viewing a Page's Restrictions
* Viewing Restricted Pages
* Working with Pages

Take me back to the Confluence User's Guide.

Viewing a Page's Restrictions

Viewing page restrictions in View mode

When a page you are viewing has restrictions applied, a small padlock icon appears next to the page byline. Clicking the padlock will open the Page Restrictions dialog, where full details on the page restrictions are displayed. See Setting a Page's Restrictions for instructions on how to change these.

Viewing page restrictions in Edit mode

You can view a page's restrictions when editing the page. You can only edit the page if you have permissions to
To view the restrictions that apply to a page:

- When editing the page, click **Restrictions**. See [Setting a Page’s Restrictions](#) for instructions on how to change these.

Related Topics

[Setting a Page’s Restrictions](#)
[Viewing Restricted Pages](#)
[Working with Pages](#)

Take me back to the [Confluence User’s Guide](#).

**Viewing Restricted Pages**

Restricted pages are pages that have ‘View’ or ‘Edit’ restrictions applied to them through page-level restrictions.

You need to be a [space administrator](#) to view the list of restricted pages in a space.

**To view restricted pages:**

1. Choose **Browse > Space Admin** for the space.
2. Click **Restricted Pages** in the left panel under ‘Security’. A list of all restricted pages in the space is displayed.
3. Click on the ‘lock’ icon to remove restrictions for the page.

Here’s an example:

![Restricted Pages](image)

related Topics

[Viewing a Page’s Restrictions](#)
[Setting a Page’s Restrictions](#)
[Working with Pages](#)
Site Administrators and their Permissions

All site administrative functions are performed from the Administration Console. You need 'System Administrator' or 'Confluence Administrator' permissions to access the Administration Console.

The Confluence permission scheme allows the following levels of site administrator permissions, with the most powerful at the top of the list:

- **Super user** – A 'super user' belongs to the confluence-administrators group, has full administrative access to Confluence, and can see all the content.
- **System Administrator** – A person with 'System Administrator' permission has full administrative access to Confluence.
- **Confluence Administrator** – A person with 'Confluence Administrator' permission has access to most of the Confluence administrative functions.

Please refer to the overview of global permissions for full details.

Related Topics

- Users and Groups
- Confluence User's Guide

Contacting Confluence Administrators

If you receive an error message from Confluence, the error page may offer you a link to click in order to contact the administrators of the Confluence site.

When you click the link to contact the Confluence administrators, you will see an administrator contact page with the title **Contact Site Administrators**. By default, the administrator contact page looks like the screenshot below.

Screenshot: The administrator contact screen

In certain configurations of Confluence, you will not be able to use the form shown in the screenshot above.
Instead, you will see a message telling you about one of the following conditions:

- If your Confluence administrator has not configured a mail server for Confluence, this means that Confluence will not be able to send an email message to the administrators.
- If none of the Confluence administrators has an email address, Confluence will not be able to send an email message to them.
- If there are no Confluence administrators defined to Confluence, Confluence will not be able to send an email message to them.
- The Confluence administrator can disable the form and specify a different message to be displayed on the above screen instead of the default message and form. See the administrator's guide.

Related Topics

Configuring the Administrator Contact Page

Space Administrators and their Permissions

A space administrator is a user with the 'Space Admin' permission for a space. This permission itself is assigned from the Space Administration screens by a space administrator.

Who is a space administrator?

The person who creates a space is automatically the administrator of that space. That person can then assign other space administrators as required.

Confluence administrators are not necessarily space administrators.

- A user who has the 'Administer Confluence' permission is not automatically a space administrator for a particular space. In order for them to be a space administrator, they must belong to a group which has space administration rights on the space, or their username must be specifically granted space administration rights on the space.
- Users who are members of the 'confluence-administrators' group do automatically have space administration permissions for all spaces.

Refer to the Administrator's Guide for more details about Confluence administrator permissions.

What can a space administrator do?

A space administrator has permission to do anything in the space regardless of any other setting. Space administrators are responsible for the management of a space and its contents. Note that page permissions affect space administrators differently from other users.

Space administrators can:

- view all content in the space. If there are page permissions that restrict the viewing of a page to a single user, or to a group to which the space administrator doesn't belong, a space administrator can still view the page by removing the restriction.
- edit all content on any page in the space.
- remove restrictions from any page in the space (using the Space Administration interface).
- manage the watchers for any page in the space (but not watchers of the space).
- grant themselves any other space permissions (e.g. permission to set restrictions on a particular page).

All space administration functions, with the exception of managing watchers, are performed from the 'Space Admin' tab (choose Browse > Space Admin). You need to be a space administrator to access the Space Administration screens.

Related Topics

Space Permissions Overview
Space Permissions Overview

Every space has its own independent set of permissions. Space permissions can only be granted by a space administrator. A space administrator has permission to do anything in the space regardless of any other setting.

Permissions can be assigned to any group, to any individual user in the Confluence-User group, and to users in the Anonymous group.

These are the permissions that can be assigned at the space level:

- **View**: user can view this space's content, including the space's details, and its pages and news items (blog posts)
- **Pages**:
  - Add – user may create and edit pages in this space.
  - Export – user may export pages in this space.
  - Restrict – user may apply page-level restrictions.
  - Remove – user may remove pages in this space.
- **Blog**:
  - Add – user may add and edit blog posts in this space.
  - Remove – user may remove blog posts in this space.
- **Comments**:
  - Add – user may make comments in this space.
  - Remove – user may remove comments from this space.
- **Attachments**:
  - Add – user may add attachments in this space.
  - Remove – user may remove attachments from this space.
- **Mail**:
  - Remove – user may delete individual mail items.
- **Space**:
  - Export – user may export content from this space.
  - Admin – user has administrative permissions over this space.

Related pages:

- Space Administrators and their Permissions
- Users and Groups
- Assigning Space Permissions
- Page Restrictions
- Confluence User's Guide

Notes

**Warning:** If you deny all administrative access to a space by mistake, so that nobody has access to administer the space any more, you will need to ask someone in the confluence-administrators group to fix the permissions for you.

Assigning Space Permissions

You can assign space permissions to groups or to individual users. You need to be a space administrator to assign space permissions. In addition, Confluence administrators can set the default permissions that will be applied to new spaces as described below.

To access the permissions for a space:

1. Go to the 'Space Permissions' view. To do this:
   a. Go to a page in the space where you want to view or assign permissions.
b. Choose **Browse > Space Admin.**
   (You will see the 'Space Admin' option only if you are a space administrator of the current space.)

c. Click **Permissions** in the 'Security' section of the left-hand panel.

2. Click **Edit Permissions**.

The 'Edit Space Permissions' screen appears. It has the following sections:

- Groups – a list of groups which already have permissions to access the site.
- Individual Users – a list of users who already have permissions to access the site.
- Anonymous Access – the space permissions granted to all anonymous users of the site.

### On this page:

- Assigning space permissions to groups
- Assigning space permissions to users
- Assigning space permissions to anonymous users
- Setting default space permissions

### Related pages:

- Space Permissions Overview
- Users and Groups
- Confluence User's Guide

### Screenshot: Editing space permissions

You can edit the current space permissions here. Permissions can be granted to specific users or groups. You can also grant permissions to anonymous users. Anonymous users refers to all users that are not logged in. For information about the individual permissions that can be assigned, please see the permissions guide.
Assigning space permissions to groups

- To assign a permission, check the box next to the relevant group.
- To deny a permission, uncheck the relevant box.
- To add a new group to the list, type the group name into the text box in the 'Groups' section and click Add. The group will appear in the list of groups. You can then assign the permissions.
- To search for a group:
  - Click the icon.
  - The Group Search window opens. Enter all or part of the group name. You can use an asterisk '*' as a wild card.
  - Check the boxes to select the required group(s).
  - Click Select Groups. The group name(s) will appear in the text box in the 'Groups' section.
  - Click Add.
- To bulk assign or revoke group member permissions, choose either Select All or Deselect All from the Actions dropdown list.

Click Save All to apply the changes.

Assigning space permissions to users

- To assign a permission, check the box next to the relevant user.
- To deny a permission, uncheck the relevant box.
- To add a new user to the list, type the username into the text box in the 'Individual Users' section and click Add. The user will appear in the list of users, with 'View' permission assigned. You can then add more permissions if necessary.
- To search for a user:
  - Click the icon.
  - The User Search window opens. You can read more about searching for users.
  - Check the boxes to select the required user(s).
  - Click Select User(s). The username(s) will appear in the text box in the 'Individual Users' section.
  - Click Add.
- To bulk assign or revoke individual user permissions, choose either Select All or Deselect All from the Actions dropdown list.

Click Save All to apply the changes.

Assigning space permissions to anonymous users

- To assign a permission, check the box for the required permission.
- To deny a permission, uncheck the relevant box.
- To bulk assign or revoke anonymous user permissions, choose either Select All or Deselect All from the Actions dropdown list.

Click Save All to apply the changes.

Note: You cannot grant space administration rights or page restriction rights to anonymous users.

Setting default space permissions

If you have Confluence Administrator permission, you can set the default permissions that will be applied to new spaces. The default permissions are configurable for groups only, not for individual users or anonymous users.

To set the default space permissions:

1. Choose Browse > Confluence Admin.
2. Choose Space Permissions in the left-hand column.
3. Choose Edit Permissions.
Users and Groups

A 'user' is the account for an individual who accesses Confluence.

New users are created by a Confluence administrator via the Administration Console. See Searching For and Administering Users for more information.

A Confluence administrator can also group users together into user groups for more convenient administration. This means that any permissions you assign at the site, space and page levels can be assigned to a whole group. A user in one of these groups will automatically be granted all permissions granted to the group.

There are two special groups in Confluence:

- **Confluence-Administrators** - This is a 'super-group' and a user from this group has permission to do anything in the site regardless of any other setting.

- **Confluence-Users** - This is the default group into which all new users are assigned. Permissions you assign to this group will be assigned to all newly signed-up users of Confluence.

Anonymous Users

Confluence treats all users who do not log in when they access Confluence as being 'Anonymous'. Administrators can assign permissions to this group separately.

**Overlapping group and user permissions**

When a user is assigned more than one permission, the most powerful permission will prevail.

Further explanation:

- A user may be assigned a permission specifically to their username. They may also be assigned a permission by belonging to a group, or even several groups.
- The user will then be able to perform all functions assigned to them.
- So if a user is allowed to do something over and above what the group can do, the user will be able to do it. And if the group is allowed to do something over and above the specific permissions granted to the user, the user will still be able to do it.

Related Topics

- **Space Permissions Overview**
- **Assigning Space Permissions**
Page Permissions

Managing Confluence Users

Confluence User's Guide

Searching for Users
This page describes how to use the 'User Search' window, which appears when you click Choose Users or a user search icon on a Confluence page.

On this page:
- Accessing the User Search
- Using the Simple User Search
- Using the Advanced User Search
- Searching for Users in One or More Groups
- Selecting One or More Users
- Notes
- Related Topics

Accessing the User Search

To access the 'User Search' window:
1. Click the user search link or icon when you are performing one of the following actions:
   - When assigning space permissions, click the icon in the users section.
   - When adding members to a group, click the icon.
2. The simple 'User Search' window will appear, as shown below.

Using the Simple User Search

To search via the simple user search:
1. Select the User tab on the 'User Search' screen. (See above for instructions on accessing the screen.)
2. If the Simple link is showing, click it. (If you see the Advanced link instead, then you're fine. The simple search is already active.)
3. The simple user search screen will appear, as shown below.
4. Type some information about the user into the 'Search' box. You can type all or part of their username, full name or email address.
5. Click Search.
6. Confluence will return a list of matching users. See below for instructions on selecting one or more users.

Screenshot: Simple user search

User Search

User Details

Search for users by their user details eg: bob, Bob Smith, bob@example.com
Advanced
Using the Advanced User Search

The advanced user search allows you to specify the field in which your search term appears, i.e. username, full name or email address. You may find this useful if you need to limit the number of users appearing in the search results.

To search via the advanced user search:

1. Select the User tab on the 'User Search' screen. (See above for instructions on accessing the screen.)
2. If the Advanced link is showing, click it. (If you see the Simple link instead, then you're fine. The advanced search is already active.)
3. The advanced user search screen will appear, as shown below.
4. Complete one or more of the following fields:
   - **User Name** — Enter all or part of the person's username i.e. their login id, e.g. 'joe', or 'bloggs'.
   - **Full Name** — Enter all or part of the person's name, e.g. 'joe bloggs', or 'bloggs', or 'joe'.
   - **E-Mail** — Enter all or part of the person's email address, e.g. 'acme'
5. Click Search.
6. Confluence will return a list of matching users. See below for instructions on selecting one or more users.

Screenshot: Advanced user search

Searching for Users in One or More Groups

You can also list the users who appear in a particular group or in a set of groups.

To search for users in a particular group:

1. Select the Membership tab on the 'User Search' screen. (See above for instructions on accessing the screen.)
2. The 'Group Membership' search screen will appear, as shown below.
3. Type all or part of a group name into the 'Search' box.
4. Click Search.
5. Confluence will return a list of users belonging to any groups which match your search term.
6. Now you can select one or more users, as described below.

Screenshot: Searching for users in a group
Selecting One or More Users

After searching for users and receiving a list of names from Confluence, as described above, you can now select the user(s) you need.

To select one or more users:

1. Click the box next to the username(s) to select or unselect one or more users. You can click **Check All** to select or unselect all users.
2. Click **Select User(s)**.
3. The 'User Search' window will close and the selected users will appear on the screen which you were using before you accessed the user search.

Screenshot: Selecting one or more users
Notes

- **Case sensitivity**: The search is not case sensitive. You can enter either upper- or lower-case text, and it will make no difference to the search results.

- **Wild cards**: The search allows the asterisk as a wild card, but you do not need to use it. The search results will be the same whether you use a wild card or not. The wildcard functionality remains available for compatibility with older versions of Confluence.

- **Multiple user directories**: You may define multiple user directories in Confluence, so that Confluence looks in more than one place for its users and groups. For example, you may use the default Confluence directory and also connect to an LDAP directory server. In such cases, you can define the directory order to determine where Confluence looks first when processing users and groups. Here is a summary of how the directory order affects the processing:
  - The order of the directories is the order in which they will be searched for users and groups.
  - Changes to users and groups will be made only in the first directory where the application has permission to make changes.

See [Managing Multiple Directories](#).

- **Crowd and the user search**: If you are using Atlassian's Crowd for user management, you will need Crowd 1.5.1 or later to use the 'Simple' option in the user search. If your version of Crowd does not support the simple user search, you will see only the 'Advanced' search form.

Related Topics

- [Searching Confluence](#)
- [Setting a Page’s Restrictions](#)
- [Assigning Space Permissions](#)
- [Adding or Removing Users in Groups](#)

Take me back to [Confluence User's Guide](#)

Using Confluence on a Mobile Device

When you view a Confluence page on a mobile device, such as an iPhone or an iPad, Confluence will display an optimised version of the page. This is Confluence mobile.

On your phone or other supported mobile device, you can:

- View the Confluence dashboard, pages, blog posts, and user profiles.
- Add a comment to a page or blog post.
- Like a page, blog post or comment.
- Manage your personal tasks and notifications.

You cannot add or edit pages or blog posts, or edit existing comments, using the mobile interface.

See [Supported Platforms](#) for details of supported mobile devices.

The dashboard – the first thing you see

*Screenshot: The dashboard in Confluence mobile*
Choose a tab to see:

- Popular content – what people like in your wiki.
- Recent blogs – the latest blog posts.
- Network – updates by people in your network.

Tap the links to view the full content of a page, blog post or comment.

**Searching for content and people**

Tap the menu icon to open the menu panel on the left of the page. Then type text or a person's name in the Search box. The mobile interface offers the quick navigation search, which returns matches on page title only. (See Searching Confluence.) To use the full search, switch to desktop mode.

Screenshot: The menu panel in Confluence mobile

**Viewing pages, blog posts and comments**

Tap a link on the dashboard or on any other page. Confluence will display the linked page, blog post or comment.

You can:
• View the content, tap a link to move to another page, and interact with the page using the standard functionality supported by mobile browsers.
• Like or unlike a page, blog post or comment.
• Add a comment. Confluence mobile supports plain-text comments only.

Screenshot: A page with a 'Like' button and a comment box

Chocolate
By Sarah Maddox
9 minutes ago

The food of technical writers everywhere.

Like

Yum
Save

Viewing people's profiles

Search for a person's name, then view that person's user profile. Tap the options to phone, SMS or email a colleague directly from your mobile device.

Screenshot: A user profile on Confluence mobile

Sarah Maddox
sarah@atlassian.com
02 1234 5678

Call Message Email

Position Technical Writer
Department Engineering
Location Sydney

Following up on notifications
You can view and respond to your notifications on your phone or other mobile device. Tap the menu icon to open the menu panel on the left of the page. Choose **Notifications**, and tap a notification to see its details. You can reply, watch or like via the inline actions. Tap **Open** to open the page or blog post in a new page. For full details, see [Managing Notifications in Confluence](#).

**Screenshot: Notifications in Confluence mobile**

### Managing tasks

You can view and manage your tasks on your phone or other mobile device too. Tap the menu icon to open the menu panel on the left of the page. Choose **Tasks**, and tap the plus sign to add a new task. Tap a task to see its details. You can add notes, complete a task, and tap a link to open the related page. For full details, see [Managing Tasks in Confluence](#).

**Screenshot: Tasks in Confluence mobile**
More things you may need to know

See Notes about Confluence Mobile.

Related pages

- Dashboard
- Supported Platforms
- Managing Notifications in Confluence
- Managing Tasks in Confluence
- Confluence User's Guide

Notes about Confluence Mobile

When you view a Confluence page on a mobile device, such as an iPhone or an iPad, Confluence will display an optimised version of the page. This is Confluence mobile.

For a summary of mobile features, see Using Confluence on a Mobile Device. Below are additional notes that you will find useful.

On this page:

- Some macros may not work
- You can swap from mobile to standard Confluence and back again
- Confluence chooses the mobile or desktop interface based on your device
- Administrators can disable Confluence mobile on your site
- Confluence mobile is a web interface, not a native app
- Related pages

Some macros may not work

Confluence macros are not yet fully supported in Confluence mobile. If you view a page that contains an unsupported macro, you will see a message inviting you to click through to the desktop version of the page.

Screenshot: Macro not rendered in Confluence mobile
You can swap from mobile to standard Confluence and back again

You can swap from the mobile view to the standard view of a page at any time. Choose the menu icon and choose **Switch to desktop version**.

*Screenshot: The menu panel in Confluence mobile*

You can also swap from the desktop view to the mobile view, if you are on a mobile device. Choose the option **Switch to Confluence Mobile** at the top of the window.

*Screenshot: Option to switch to Confluence mobile*

Confluence chooses the mobile or desktop interface based on your device

Confluence mobile supports iOS and Android devices. For specific versions, see [Supported Platforms](#).

Administrators can disable Confluence mobile on your site

The mobile functionality is provided by a plugin called the 'Confluence Mobile Plugin'. To remove the functionality from your site, you can disable the plugin. See [Disabling or Enabling a Plugin](#).

Confluence mobile is a web interface, not a native app

Atlassian does not supply a native mobile application that you can download and install onto your mobile device. Confluence mobile is a web-based user interface that the Confluence server displays when it detects a mobile
Related pages

- Using Confluence on a Mobile Device
- Dashboard
- Supported Platforms
- Confluence User's Guide

Advanced and Special Uses of Confluence

This section describes the more advanced features of Confluence, and gives guidelines on some specific uses of the wiki.

Confluence markup formats

The syntax and usage of Confluence wiki markup and the Confluence XHTML-based storage format – see Working with Confluence Markup.

Gadgets

How to add gadgets to a wiki page, or use Confluence gadgets on other sites – see Working with Confluence Gadgets.

Using Confluence for technical documentation

A technical communicator’s guide to using Confluence – see Developing Technical Documentation on Confluence Wiki.

Setting up a knowledge base

A support engineer's guide to using Confluence as a knowledge base – see Developing a Knowledge Base on Confluence Wiki.

Setting up an intranet

A quick guide to setting up an intranet wiki – see Developing an Intranet on Confluence Wiki.

Related pages:

- Confluence User's Guide
- Confluence Administrator's Guide

Working with Confluence Markup

This section describes two types of markup found in Confluence:

- **Confluence storage format.** Confluence stores the content of pages and blog posts in an XHTML-based format. Advanced users can view the storage format of a page and even edit it, provided their Confluence site is configured to allow that. See Confluence Storage Format for a description of the core elements of the storage format. For details of the elements used to define a macro, see Confluence Storage Format for Macros.

- **Wiki markup.** Confluence allows data entry via a shorthand code called wiki markup. Some parts of the Confluence administration interface also accept wiki markup for defining content. For a description of the wiki markup syntax, see Confluence Wiki Markup. For details of the wiki markup used to define Confluence macros, see Confluence Wiki Markup for Macros.
A request from the Atlassian technical writers about comments and feedback: When adding comments to this page, please restrict your comments to constructive feedback on the documentation itself: Things we’ve missed in the documentation, and things that will be useful to other readers. If you have other feedback about the editor, wiki markup, the XML storage format, and Confluence 4 in general, please add your comments in the section titled Confluence 4 Editor - Customer Feedback, and its child pages. Our reason for this request: When a page attracts a large number of comments, it makes it difficult for everyone to read the page, and to add or respond to comments about the documentation. Thanks. 😊

Confluence Storage Format

This page describes the XHTML-based format that Confluence uses to store the content of pages, page templates, blog posts and comments. This information is intended for advanced users who need to interpret and edit the underlying markup of a Confluence page.

We refer to the Confluence storage format as 'XHTML-based'. To be correct, we should call it XML, because the Confluence storage format does not comply with the XHTML definition. In particular, Confluence includes custom elements for macros and more. We're using the term 'XHTML-based' to indicate that there is a large proportion of HTML in the storage format.

Notes:

- You can view the Confluence storage format for a given page by choosing Tools > View Storage Format. This option is only available if one of the following is true:
  - You are a Confluence administrator.
  - Your Confluence site has the Confluence Source Editor plugin installed and you have permission to use the source editor.
- If you would like to edit the storage format for a page, your Confluence system administrator will need to install the Confluence Source Editor plugin.
- Clarification of terminology: If you choose Tools > View Source, you will see the format used within the editor panel, not the storage format of the page.
- A request from the Atlassian technical writers about comments and feedback: When adding comments to this page, please restrict your comments to constructive feedback on the documentation itself: Things we’ve missed in the documentation, and things that will be useful to other readers. If you have other feedback about the editor, wiki markup, the XML storage format, and Confluence 4 in general, please add your comments in the section titled Confluence 4 Editor - Customer Feedback, and its child pages. Our reason for this request: When a page attracts a large number of comments, it makes it difficult for everyone to read the page, and to add or respond to comments about the documentation. Thanks. 😊
<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heading 1</td>
<td>h1. Heading 1</td>
<td>&lt;h1&gt;H e a d i n g 1&lt;/h1&gt;</td>
<td>Heading 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Underlined in the Documentation Theme</td>
</tr>
<tr>
<td>Heading 2</td>
<td>h2. Heading 2</td>
<td>&lt;h2&gt;H e a d i n g 2&lt;/h2&gt;</td>
<td>Heading 2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Underlined in the Documentation Theme</td>
</tr>
<tr>
<td>Heading 3</td>
<td>h3. Heading 3</td>
<td>&lt;h3&gt;H e a d i n g 3&lt;/h3&gt;</td>
<td>Heading 3</td>
</tr>
</tbody>
</table>
Text effects

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>strong/bold</td>
<td><em>strong</em></td>
<td>strong</td>
<td>&lt;b&gt; will also work but get converted to &lt;strong&gt; upon saving</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>emphasis</td>
<td><em>emphasis</em></td>
<td>emphasis</td>
<td>&lt;i&gt; will also work but get converted to &lt;em&gt; upon saving</td>
</tr>
<tr>
<td>--------------</td>
<td>------------</td>
<td>--------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td>italic</td>
<td>&lt;em&gt;ItalicsText&lt;/em&gt;</td>
<td>strikethrough</td>
<td>&lt;s&gt; and &lt;del&gt; will also work</td>
</tr>
</tbody>
</table>

---

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>underline</th>
<th>+underline+</th>
<th>underline</th>
</tr>
</thead>
<tbody>
<tr>
<td>[&lt;u&gt;underline&lt;/u&gt;]</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>superscript</th>
<th>^superscript^</th>
<th>superscript</th>
</tr>
</thead>
<tbody>
<tr>
<td>[&lt;sup&gt;superscript&lt;/sup&gt;]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>subscript</td>
<td><del>subscript</del></td>
<td>subscript</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
<td>-----------</td>
</tr>
<tr>
<td><code>&lt;sub&gt;subscript&lt;/sub&gt;</code></td>
<td></td>
<td><code>&lt;/sub&gt;</code></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>monospace</th>
<th>{{monospace d}}</th>
<th>monospaced</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;code&gt;monospaced&lt;/code&gt;</code></td>
<td></td>
<td><code>&lt;code&gt;</code></td>
</tr>
<tr>
<td>preformatted</td>
<td>n/a</td>
<td>preformatted text</td>
</tr>
<tr>
<td>--------------</td>
<td>-----</td>
<td>-------------------</td>
</tr>
</tbody>
</table>

```xml
preformatted text
```
<table>
<thead>
<tr>
<th>block quotes</th>
<th>bq. block quote or {quote} block quote {quote}</th>
<th>block quote</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><code>&lt;blockquote&gt;</code> <code>&lt;p&gt;</code> <code>blockquote</code> <code>&lt;p&gt;</code> <code>blockquote</code></td>
<td><code>&lt;blockquote&gt;</code></td>
</tr>
<tr>
<td>text colour</td>
<td>{color:red} red text{color}</td>
<td></td>
</tr>
<tr>
<td>-------------</td>
<td>-----------------------------</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&lt;span style=&quot;color:rgb(255,0,0);&quot;&gt;red text&lt;/span&gt;</td>
<td></td>
</tr>
</tbody>
</table>

red text
<table>
<thead>
<tr>
<th>small</th>
<th>n/a</th>
<th>small text</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td><code>&lt;small&gt;</code> small text <code>&lt;/small&gt;</code></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>big</th>
<th>n/a</th>
<th>big text</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td><code>&lt;big&gt;</code> big text <code>&lt;/big&gt;</code></td>
</tr>
<tr>
<td>center-align</td>
<td>n/a</td>
<td>centered text</td>
</tr>
<tr>
<td>--------------</td>
<td>-----</td>
<td>---------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td><code>&lt;p style=&quot;text-align: center;&quot;&gt; centered text&lt;/p&gt;</code></td>
</tr>
<tr>
<td>Format type</td>
<td>In Confluence 3.5 and earlier</td>
<td>In Confluence 4.0 and later</td>
</tr>
<tr>
<td>-----------------</td>
<td>--------------------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>right-align</td>
<td>n/a</td>
<td>right aligned text</td>
</tr>
</tbody>
</table>
New paragraph

Paragraph 1
(Empty line)

Paragraph 2

Paragraph 1
Paragraph 2

Line break

Line 1 \ Line 2

Line 1
Line 2

Note: Created in the editor using Shift + Return/Enter

Horizontal rule

----

---

--

— symbol

—

—

– symbol

—

–

—

Lists

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unordered list – round bullets</td>
<td>* Round bullet list item</td>
<td></td>
<td>• Round bullet list item</td>
</tr>
</tbody>
</table>
### Unordered list – squarebullets

- Square bullet
  list item

```
<ul style="list-style-type:square;">
  <li>square bullet list item</li>
</ul>
```

### Ordered list (numbered list)

# Ordered list item

```
<ol>
  <li>numbered list item</li>
</ol>
```

### Links

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link to another Confluence page</td>
<td>[Link to another Confluence page</td>
<td>Page Title]</td>
<td><a href="">ac:link</a> &lt;ri:page ri:content-title=&quot;Page Title&quot; /&gt; <a href="">ac:plain-text-link-body</a> &lt;![CDATA [Link to another Confluence Page]]&gt; &lt;/ac:plain-text-link-body&gt; &lt;/ac:link&gt;</td>
</tr>
</tbody>
</table>
Link to an attachment

[Link to an attachment](atlassian_logo.gif)

Link to an external site

[Atlassian](http://www.atlassian.com)

Anchor link

[Anchor Link](pagetitle#anchor)

Link to an attachment

[Link to a Confluence Attachment]

Atlassian

Anchor Link
A note about link bodies

All links received from the editor will be stored as plain text by default, unless they are detected to contain the limited set of mark up that we allow in link bodies. Here are some examples of markup we support in link bodies.

For rich content like images, you need to use `ac:link-body` to wrap the contents.
An example of different link bodies

```xml
<ac:link>
 <!-- Any resource identifier -->
 <ri:page ri:content-title="Home" ri:space-key="SANDBOX" />
 <ac:link-body>Some <strong>Rich</strong> Text</ac:link-body>
</ac:link>

<ac:link>
 <ri:page ri:content-title="Plugin developer tutorial stuff" ri:space-key="TECHWRITING" />
 <ac:plain-text-link-body><![CDATA[A plain <text> link body]]></ac:plain-text-link-body>
</ac:link>

<!-- A link body isn't necessary. Auto-generated from the resource identifier for display. -->
</ac:link>
```

The markup tags permitted within the `<ac:link-body>` are `<b>`, `<strong>`, `<em>`, `<i>`, `<code>`, `<tt>`, `<sub>`, `<sup>`, `<br>` and `<span>`.

### Images

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attached image</td>
<td><img src="image" alt="atlassian_logo.png" /></td>
<td><code>&lt;ac:image&gt;</code></td>
<td><img src="image" alt="Atlassian Logo" /></td>
</tr>
</tbody>
</table>

---

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Supported image attributes (some of these attributes mirror the equivalent HTML 4 IMG element):

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ac:align</td>
<td>image alignment</td>
</tr>
<tr>
<td>ac:border</td>
<td>Set to &quot;true&quot; to set a border</td>
</tr>
<tr>
<td>ac:class</td>
<td>css class attribute.</td>
</tr>
<tr>
<td>ac:title</td>
<td>image tool tip.</td>
</tr>
<tr>
<td>ac:style</td>
<td>css style</td>
</tr>
<tr>
<td>ac:thumbnail</td>
<td>Set to &quot;true&quot; to designate this image as a thumbnail.</td>
</tr>
<tr>
<td>ac:alt</td>
<td>alt text</td>
</tr>
<tr>
<td>ac:height</td>
<td>image height</td>
</tr>
<tr>
<td>ac:width</td>
<td>image width</td>
</tr>
<tr>
<td>ac:vspace</td>
<td>the white space on the top and bottom of an image</td>
</tr>
<tr>
<td>ac:hspace</td>
<td>the white space on the left and right of an image</td>
</tr>
</tbody>
</table>

**Tables**

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Two column, two row (top header row)</th>
<th>Table Heading Cell 1</th>
<th>Table Heading Cell 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal Cell 1</td>
<td>Normal Cell 2</td>
<td></td>
</tr>
</tbody>
</table>

```<table><tbody><tr><th>Table Heading Cell 1</th><th>Table Heading Cell 2</th></tr><tr><td>Normal Cell 1</td><td>Normal Cell 2</td></tr></tbody></table>```
Two column, three rows, 2nd and third with merged cells in first row

<table>
<thead>
<tr>
<th>Table Heading Cell 1</th>
<th>Table Heading Cell 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Merge Cell</td>
<td>Normal Cell 1</td>
</tr>
<tr>
<td>Normal Cell 1</td>
<td>Normal Cell 2</td>
</tr>
</tbody>
</table>

<pre><table>
  <tbody>
    <tr>
      <th>Table Heading Cell 1</th>
      <th>Table Heading Cell 2</th>
    </tr>
    <tr>
      <td rowspan="2">Merged Cell</td>
      <td>NORMAL Cell 1</td>
    </tr>
    <tr>
      <td>NORMAL Cell 2</td>
    </tr>
  </tbody>
</table></pre>
Page layouts

Confluence supports page layouts directly, as an alternative to macro-based layouts such as those using the section and column macros. This section documents the storage format XML created when these layouts are used in a page.

Notes:

- Page layouts were introduced in Confluence 4.2, and are not available in earlier versions of Confluence.
- The word {content} in the layouts below indicates where further XHTML or Confluence storage format block content would be entered, such as <p> or <table> tags.

<table>
<thead>
<tr>
<th>Layout Type</th>
<th>In Confluence 4.2 and later</th>
</tr>
</thead>
</table>
| ![Two columns](image) | `<div class="contentLayout" data-atlassian-layout="\{\"name\":\"pagelayout-two-si\n\mple\",\"columns\":\[\"\",\"\]\}"">  
|                  | `<div class="columnLayout twoColumns">  
|                  |   `<div class="cell ">  
|                  |     `<div class="innerCell">  
|                  |       {content}  
|                  |     </div>  
|                  |   </div>`
|                  | `</div>`
|                  | `</div>`
|                  | `</div>`
|                  | `</div>`
|                  | `</div>`

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Three columns

```html
<div class="contentLayout" data-atlassian-layout="{"name":"pagelayout-three-simple","columns":["","","" ] }">
  <div class="columnLayout threeColumns">
    <div class="cell">
      <div class="innerCell">
        {content}
      </div>
    </div>
    <div class="cell">
      <div class="innerCell">
        {content}
      </div>
    </div>
    <div class="cell">
      <div class="innerCell">
        {content}
      </div>
    </div>
  </div>
</div>
```
Two columns with header and footer

```html
<div class="contentLayout" data-atlassian-layout="{"name":"pagelayout-two","columns":["",""],"header":true,"footer":true}"

  <div class="header"
   <div class="innerCell">
     {content}
   </div>

  <div class="columnLayout twoColumns">
   <div class="cell ">
     <div class="innerCell">
       {content}
     </div>
   </div>
   <div class="cell ">
     <div class="innerCell">
       {content}
     </div>
   </div>

  </div>

  <div class="footer">
   <div class="innerCell">
     {content}
   </div>

  </div>
```
Left sidebar with header and footer

```html
<div class="contentLayout" data-atlassian-layout=""name":"pagelayout-two-left","columns": [{"aside"},{"large"}],"header":true,"footer":true}"
   <div class="header"
      <div class="innerCell">
        {content}
      </div>
    </div>
    <div class="columnLayout twoColumns"
      <div class="cell aside"
        <div class="innerCell">
          {content}
        </div>
      </div>
      <div class="cell large"
        <div class="innerCell">
          {content}
        </div>
      </div>
    </div>
    <div class="footer"
      <div class="innerCell">
        {content}
      </div>
    </div>
```
Three columns with header and footer

```html
<div class="contentLayout" data-atlassian-layout="{"name":"pagelayout-three","columns":null,"header":true,"footer":true}">
  <div class="header">
    <div class="innerCell">
      {content}
    </div>
  </div>
  <div class="columnLayout threeColumns">
    <div class="cell ">
      <div class="innerCell">
        {content}
      </div>
    </div>
    <div class="cell ">
      <div class="innerCell">
        {content}
      </div>
    </div>
    <div class="cell">
      <div class="innerCell">
        {content}
      </div>
    </div>
  </div>
  <div class="footer">
    <div class="innerCell">
      {content}
    </div>
  </div>
</div>
```
Emoticons

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Emoticons</td>
<td>:)</td>
<td>&lt;ac:icon ac:name=&quot;smile&quot; /&gt;</td>
<td>😊</td>
</tr>
<tr>
<td>Emoticon</td>
<td>Code</td>
<td></td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td>------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>😞</td>
<td>&lt;ac:emoticon ac:name=&quot;sad&quot; /&gt;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>😛</td>
<td>&lt;ac:emoticon ac:name=&quot;cheeky&quot; /&gt;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>😄</td>
<td>&lt;ac:emoticon ac:name=&quot;laugh&quot; /&gt;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>😘</td>
<td>&lt;ac:emoticon ac:name=&quot;wink&quot; /&gt;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>👍</td>
<td>&lt;ac:emoticon ac:name=&quot;thumbs-up&quot; /&gt;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>👎</td>
<td>&lt;ac:emoticon ac:name=&quot;thumbs-down&quot; /&gt;</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Resource identifiers

Resource identifiers are used to describe "links" or "references" to resources in the storage format. Examples of resources include pages, blog posts, comments, shortcuts, images and so forth.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Resource identifier format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>&lt;ri:page ri:space-key=&quot;FOO&quot; ri:content-title=&quot;Test Page&quot;/&gt;</td>
</tr>
</tbody>
</table>

Notes:
- `ri:space-key:` (optional) denotes the space key. This can be omitted to create a relative reference.
- `ri:content-title:` (required) denotes the title of the page.
### Blog Post

```xml
<ri:blog-post ri:space-key="FOO"
ri:content-title="First Post"
ri:posting-day="2012/01/30" />
```

**Notes:**
- `ri:space-key`: (optional) denotes the space key. This can be omitted to create a relative reference.
- `ri:content-title`: (required) denotes the title of the page.
- `ri:posting-day`: (required) denotes the posting day. The format is YYYY/MM/DD.

### Attachment

```xml
<ri:attachment ri:filename>
... resource identifier for the container of the attachment ...
</ri:attachment>
```

**Notes:**
- `ri:filename`: (required) denotes the name of the attachment.
- **the body of the** `ri:attachment` **element** **should** be a resource identifier denoting the container of the attachment. This can be omitted to create a relative attachment reference (similar to `[foo.png]` in wiki markup).

**Examples:**

**Relative Attachment Reference**

```xml
<ri:attachment
ri:filename="happy.gif" />
```

**Absolute Attachment Reference**

```xml
<ri:attachment
ri:filename="happy.gif">
<ri:page ri:space-key="TST"
ri:content-title="Test Page"/>
</ri:attachment>
```
<table>
<thead>
<tr>
<th><strong>URL</strong></th>
<th><code>&lt;ri:url ri:value=&quot;http://example.org/sample.gif&quot;/&gt;</code></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Notes:</strong></td>
<td>• <code>ri:value:</code> (required) denotes the actual URL value.</td>
</tr>
<tr>
<td><strong>Shortcut</strong></td>
<td><code>&lt;ri:shortcut ri:key=&quot;jira&quot; ri:parameter=&quot;ABC-123&quot;&gt;</code></td>
</tr>
</tbody>
</table>
| **Notes:** | • `ri:key:` (required) represents the key of the Confluence shortcut.  
• `ri:parameter:` (required) represents the parameter to pass into the Confluence shortcut.  
• The example above is equivalent to [ABC-123@jira] in wiki markup. |
| **User** | `<ri:user ri:username="fred"/>` |
| **Notes:** | • `ri:username:` (required) denotes the name of the user. |
| **Space** | `<ri:space ri:space-key="TST"/>` |
| **Notes:** | • `ri:space-key:` (required) denotes the key of the space. |
| **Content Entity** | `<ri:content-entity ri:content-id="123"/>` |
| **Notes:** | • `ri:content-id:` (required) denotes the id of the content. |
Template variables

This screenshot shows a simple template:

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Type</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>$MyText</td>
<td>Single-line text</td>
<td></td>
</tr>
<tr>
<td>$MyMulti</td>
<td>Multi-line text</td>
<td>Size: 5 x 100</td>
</tr>
<tr>
<td>$MyList</td>
<td>List</td>
<td>List items: Apples, Pears, Peaches</td>
</tr>
</tbody>
</table>

The XML export produces the following code for the template:

```
<at:declarations>
  <at:string at:name="MyText" />
  <at:textarea at:columns="100" at:name="MyMulti" at:rows="5" />
  <at:list at:name="MyList">
    <at:option at:value="Apples">Apples</at:option>
    <at:option at:value="Pears">Pears</at:option>
    <at:option at:value="Peaches">Peaches</at:option>
  </at:list>
</at:declarations>

<p>This is Sarah's template</p>
<p>A single-line text variable: $MyText</p>
<p>A multi-line text variable: $MyMulti</p>
<p>A selection list: $MyList</p>
<p>End of page.</p>

Confluence Storage Format for Macros
Anchor macro

Allows you to link to a specific part of a page.

Macro name: anchor

Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>Yes</td>
<td>(None)</td>
<td>The name of the anchor.</td>
</tr>
<tr>
<td>(Unnamed in wiki markup)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Example:

```xml
<ac:macro ac:name="anchor">
  <ac:default-parameter>here</ac:default-parameter>
</ac:macro>
```
Attachments macro

Displays a list of attachments on a given page.

**Macro name:** attachments

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>old</td>
<td>No</td>
<td>false</td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <strong>false</strong> – Displays only the latest version of each attachment.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <strong>true</strong> – Displays all versions of each attachment, including the old versions.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Available Values</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>---------</td>
<td>------------------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| patterns  | No      | (None)           | A comma-separated list of regular expressions, used to filter the attachments by file name. Note that the parameter values must be regular expressions. For example:  
- To match a file suffix of 'jpg', use `.*jpg` (not `*.jpg`).  
- To match file names ending in 'jpg' or 'png', use `.*jpg,.*png`. Here is a tutorial on regular expressions. |
| sortBy    | No      | date             | Available values:  
- date  
- size  
- name |
| page      | No      | The page on which the macro exists. | Page name, used to display attachments from another page. |
| sortOrder | No      | The default sort order is determined by the sortBy type:  
- Reverse chronological for 'date'.  
- Largest to smallest for 'size'.  
- Alphabetical for 'name'. | Available values:  
- ascending  
- descending |
| labels    | No      | (None)           | A comma-separated list of labels. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.) |
| upload    | No      | false            | Determines whether the list of attachments will include options allowing users to browse for, and attach, new files. |
Blog Posts macro

Lists the most recent news items in the space.

Macro name: blog-posts

Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>content</td>
<td>No</td>
<td>entire</td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- entire – Display the whole content of each blog post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- excerpts – Display a short extract from each blog post. If the post contains an Excerpt macro, the Blog Posts macro will display the content defined in the Excerpt macro. If the post does not contain an Excerpt macro, the Blog Posts macro will display the first few sentences of the post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- titles – Display a list of blog posts, showing titles only.</td>
</tr>
<tr>
<td>spaces</td>
<td>No</td>
<td>@self</td>
<td>One or more space keys, separated by a comma or a space.</td>
</tr>
</tbody>
</table>
To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example:
If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.

To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example:
If you specify a space key of +GOODSPACE you will get only content in GOODSPACE.
(Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:
When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~bloggs@example.com.
<table>
<thead>
<tr>
<th><strong>sort</strong></th>
<th>No</th>
<th><strong>creation</strong></th>
<th>Available values:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>title</strong> — Sort alphabetically by title.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>creation</strong> — Sort by the date on which the content was added.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>modified</strong> — Sort by the date on which the content was last updated.</td>
</tr>
</tbody>
</table>

| **max** | No | 15 | The maximum number of results to be displayed. |

| **label** | No | (None) | One or more label values, separated by a comma or a space. |
|  |  |  | • To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labelled with ‘badpage’. |
|  |  |  | • To indicate that the results **must** match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage,+goodpage you will get only content which has at least two labels, being ‘superpage’ and ‘goodpage’. |

**Example:**
Change-History macro

Displays a history of updates made to a page.

**Macro name:** change-history

**Macro body:** None.

**Parameters:** None

**Example:**

```xml
<ac:macro ac:name="change-history"/>
```

Chart macro

Displays a chart based on tabular data.

**Macro name:** chart

**Macro body:** Accepts rich text, consisting of tables that hold the chart's data.

This macro recognises a large number of parameters, listed here by type for convenience.

**Chart type parameters**

These parameters determine the type of chart to display and how the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| type       | No       | pie     | The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based. See the `timeSeries` parameter. Available values:  
  - *Standard charts* – pie, bar, line, area  
  - *XY plots* – xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries  
  - *Other charts* – gantt (beta) |
| orientation| No       | vertical| The display orientation. Applies to area, bar and line charts. Available values:  
  - *vertical* – y-axis is vertical  
  - *horizontal* – x-axis is vertical |
| 3D         | No       | false   | Show in three dimensions. Applies to area, bar and line charts. |
| stacked    | No       | false   | Stacked values. Applies to area and bar charts. |
| showShapes | No       | true    | Applies to line charts. Shapes are shown at each data point. |
| opacity    | No       |         | A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are.  
  - 75 percent for 3D charts  
  - 50 percent for non-stacked area charts  
  - 100 percent for all other charts |
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
</tbody>
</table>
| dataDisplay     | No       | false   | Determines whether to display the body of the macro, consisting of the data table. By default, the chart data table is not displayed. Available values:  
- false – the data is not displayed.  
- true or after – the data is displayed after the chart.  
- before – the data is displayed before the chart. |
| imageFormat     | No       | png     | The image format to be used for the chart. Available values:  
- png  
- jpg |

### Chart title and label parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>subTitle</td>
<td>No</td>
<td>(None)</td>
<td>A subtitle for the chart.</td>
</tr>
<tr>
<td>xLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>yLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>legend</td>
<td>No</td>
<td>false</td>
<td>Determines whether to show a legend (key) for the chart.</td>
</tr>
</tbody>
</table>

### Chart data parameters

The data for the chart is taken from tables found in the macro body. The parameters below control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. You can specify additional conversion options using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th><strong>tables</strong></th>
<th><strong>No</strong></th>
<th><strong>All first level tables</strong></th>
<th>You can supply a comma-separated list of table IDs and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>columns</strong></td>
<td><strong>No</strong></td>
<td><strong>All columns</strong></td>
<td>You can supply a comma-separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the HTML title attribute for the column in the header row.</td>
</tr>
</tbody>
</table>
| **dataOrientation** | **No** | **horizontal** | The content orientation. By default, the data tables will be interpreted as columns (horizontally) representing domain and x values. **Available values:**
- **vertical** – data table columns will be interpreted as series.
- **horizontal** – data table rows will be interpreted as series. |
<p>| <strong>timeSeries</strong> | <strong>No</strong> | <strong>false</strong> | If 'true', the x values in an XY plot will be treated as time series data and so will be converted according date formats. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>dateFormat</td>
<td>No</td>
<td>Confluence language defined date formats</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For time series data, the date format allows for additional customisation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>of the conversion of data to date values. If a date format is specified, it</td>
</tr>
<tr>
<td></td>
<td></td>
<td>will be the first format used to interpret date values. Specify a format</td>
</tr>
<tr>
<td></td>
<td></td>
<td>that matches the time series data. See simple date format.</td>
</tr>
<tr>
<td>timePeriod</td>
<td>No</td>
<td>day</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The time period for time series data. Defines the granularity of how the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>data is interpreted.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Available values: millisecond, second, minute, hour, day, week, month,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>quarter, year</td>
</tr>
<tr>
<td>language</td>
<td>No</td>
<td>(None)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Use in combination with the country parameter to form a locale. These</td>
</tr>
<tr>
<td></td>
<td></td>
<td>additional number and date formats will be used for data conversion before</td>
</tr>
<tr>
<td></td>
<td></td>
<td>the default languages.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Available values are the two-character ISO 639-1 alpha-2 codes.</td>
</tr>
<tr>
<td>country</td>
<td>No</td>
<td>(None)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Use in combination with the language parameter to form a locale. Valid</td>
</tr>
<tr>
<td></td>
<td></td>
<td>values are the two-character ISO 3166 codes.</td>
</tr>
</tbody>
</table>
**forgive** | No | true |
--- | --- | --- |
Determine whether the macro will forgive (allow) some data formatting errors.

**Available values:**
- **true** — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.
- **false** — the macro enforces strict data formatting. If there are data format errors, the chart will not be produced.

**Chart colour parameters**

Colours are specified using hexadecimal notation or HTML colour names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>bgColor</td>
<td>No</td>
<td>White</td>
<td>Background colour of the chart.</td>
</tr>
<tr>
<td>borderColor</td>
<td>No</td>
<td>No border</td>
<td>Colour of the border around the chart.</td>
</tr>
<tr>
<td>colors</td>
<td>No</td>
<td></td>
<td>A comma-separated list of colours used to customise the colours of categories, sections, and series.</td>
</tr>
</tbody>
</table>

**Chart axis parameters**

Depending on the chart type, the range and domain axis may be customised. These values are automatically generated based on the data but can be overridden by specifying one or more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rangeAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td>Minimum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td>Maximum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>rangeAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td><strong>domainAxisLowerBound</strong></td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the <code>dateFormat</code> parameter.</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----</td>
<td>--------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>domainAxisUpperBound</strong></td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the <code>dateFormat</code> parameter.</td>
</tr>
<tr>
<td><strong>domainAxisTickUnit</strong></td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the <code>timePeriod</code> parameter. The <code>timePeriod</code> unit can be overridden by specifying a trailing character: <code>y</code> (years), <code>M</code> (months), <code>d</code> (days), <code>h</code> (hours), <code>m</code> (minutes), <code>s</code> (seconds), <code>u</code> (milliseconds).</td>
</tr>
<tr>
<td><strong>domainAxisLabelAngle</strong></td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
</tr>
</tbody>
</table>
| **categoryLabelPosition** | No | (None) | Placement of the axis label text for categories. Available values:  
- `up45` — 45 degrees going upward  
- `up90` — 90 degrees going upward  
- `down45` — 45 degrees going downward  
- `down90` — 90 degrees going downward |
### Pie chart Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| pieSectionLabel | No       | Show only the pie section key value | Format of pie section labels. The format uses a string with special replacement variables:  
- `%0%` is replaced by the pie section key.  
- `%1%` is replaced by the pie section numeric value.  
- `%2%` is replaced by the pie section percent value.  
Example 1: To display something like 'Independent = 20':  
%0% = %1%  
Example 2: To display something like 'Independent (20%)':  
%0% (%2%) |

---

**dateTickMarkPosition**

<table>
<thead>
<tr>
<th>Placement of the date tick mark.</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
</tr>
<tr>
<td><strong>start</strong></td>
</tr>
</tbody>
</table>

Available values:
- **start** — tick mark is at the start of the date period.
- **middle** — tick mark is in the middle of the date period.
- **end** — tick mark is at the end of the date period.
pieSectionExplode | No | No exploded sections | A comma-separated list of pie keys that are to be shown exploded. Note: requires jFreeChart version 1.0.3 or higher.

Chart attachment parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is displayed. These options allow for the generated image to be saved as an attachment and have subsequent access to re-use the attachment. This can be useful especially when combined with the Cache plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| attachment | No | (None) | The name and location where the chart image will be saved as an attachment. The user must be authorised to add attachments to the page specified. Available syntax for this parameter:  
  - ^attachmentName.png — the chart is saved as an attachment to the current page.  
  - page name^attachmentName.png — the chart is saved as an attachment to the page name provided.  
  - spacekey:pageTitle^attachmentName.png — the chart is saved as an attachment to the page name provided in the space indicated. |
| attachmentVersion | No | new | Defines the the versioning mechanism for saved charts.
| | | | Available values:
| | | | • **new** — creates new version of the attachment.
| | | | • **replace** — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorised to remove attachments for the page specified.
| | | | • **keep** — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated.
| attachmentComment | No | (None) | Comment used for a saved chart attachment.
| thumbnail | No | false | If true, the chart image attachment will be shown as a thumbnail (small, expandable) image.

**Example:**

Below is a simple example of a pie chart. See more examples in [Storage Format Examples for Chart Macro](#).
Cheese macro

Displays the words "I like cheese!"
**Macro name:** cheese  
**Macro body:** None.  
**Parameters:** None  
**Example:**

```
<ac:macro ac:name="cheese"/>
```

**Children Display macro**

Displays the children and descendants of the current page.

**Macro name:** children  
**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>reverse</td>
<td>No</td>
<td>false</td>
<td>Reverses the sort order in the list of child pages. Use this parameter in conjunction with the sort parameter described below. A value of true will change the sort order from ascending to descending.</td>
</tr>
</tbody>
</table>
| sort           | No       | Manual if the pages have been manually reordered, otherwise alphabetical by page title | Determines the sort order of the list of child pages. Available values:  
  - creation – Sort by the date on which the page was created.  
  - title – Sort alphabetically by page name.  
  - modified – Sort by the date on which the page was last updated. |
<p>| style          | No       | Bullet list | A heading style to be applied to the list of child pages. Available values: h1 (heading level 1) through to h6 (heading level 6). |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>page</td>
<td>No</td>
<td></td>
<td>The page that contains the macro. The name of the parent page. The macro will display the children of the specified page. To specify a page in a different space, use a space key followed by a colon. For example: MYSPACE:My page. If the value of this parameter is a forward slash (/) the macro will list the pages at the root of the current space. In other words, the pages without parents.</td>
</tr>
<tr>
<td>excerpt</td>
<td>No</td>
<td>false</td>
<td>If true, Confluence will display any excerpts that are defined on the child pages. The excerpts must be defined via an Excerpt macro.</td>
</tr>
<tr>
<td>first</td>
<td>No</td>
<td>(None)</td>
<td>The maximum number of child pages to be displayed (at the top level). For example, if the value of this parameter is 99, the macro will display the first 99 pages at the top level. It will also display their children, as determined by the depth and all parameters.</td>
</tr>
<tr>
<td>depth</td>
<td>No</td>
<td>(None)</td>
<td>The number of levels of child pages to display. For example, if the value is 2, the macro will display 2 levels of child pages.</td>
</tr>
<tr>
<td>all</td>
<td>No</td>
<td>false</td>
<td>If true, Confluence will display all levels of child pages. This setting will override the depth setting.</td>
</tr>
</tbody>
</table>

**Example:**

---

*Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
Code Block macro

Displays code in your document with the appropriate syntax highlighting.

**Macro name:** code

**Macro body:** Accepts plain text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>Adds a title to the code macro box.</td>
</tr>
<tr>
<td>theme</td>
<td>No</td>
<td>Confluence</td>
<td></td>
</tr>
<tr>
<td>-------</td>
<td>----</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Specifies the colour scheme used for displaying your code. Many of these themes are based on the default colour schemes of popular integrated development environments (IDEs). The default theme is Confluence (also known as Default), which is typically black and coloured text on a blank background. Available themes:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• DJango</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Emacs</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• FadeToGrey</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Midnight</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• RDark</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Eclipse</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Confluence (same as default)</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>linenums</th>
<th>No</th>
<th>false</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>If true, a line number will be shown to the left of each line of code. Numbering is incremented by 1. If false, no line numbers are shown.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Value</td>
</tr>
<tr>
<td>-------------</td>
<td>---------</td>
<td>-------</td>
</tr>
<tr>
<td>language</td>
<td>No</td>
<td>java</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>firstline</td>
<td>No</td>
<td>1</td>
</tr>
<tr>
<td>collapse</td>
<td>No</td>
<td>false</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Example:**

The following example shows all parameters and a body:
Below are three examples of the Code Block macro with various optional parameters used.

<table>
<thead>
<tr>
<th>Description</th>
<th>Markup</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code block macro with a body and no optional parameters</td>
<td><code>&lt;ac:macro ac:name=&quot;code&quot;&gt;</code><a href="">ac:plain-text-body</a>&lt;![CDATA[This is my code]]&gt;&lt;/ac:plain-text-body&gt;`</td>
<td>this is my code</td>
</tr>
<tr>
<td>Code block macro with a body and the optional <code>language</code> parameter defined</td>
<td><code>&lt;ac:macro ac:name=&quot;code&quot;&gt;</code>&lt;ac:parameter ac:name=&quot;language&quot;&gt;html/xml&lt;/ac:parameter&gt;<code>&lt;ac:plain-text-body&gt;&lt;![CDATA[This is my code]]&gt;&lt;/ac:plain-text-body&gt;</code></td>
<td>this is my code</td>
</tr>
</tbody>
</table>
Code block macro with a body and optional title, line numbers and language parameters defined

```xml
<ac:macro
   ac:name="code">
   <ac:parameter
      ac:name="title">This is my title</ac:parameter>
   <ac:parameter
      ac:name="linenumbers">true</ac:parameter>
   <ac:parameter
      ac:name="language">html/xml</ac:parameter>
   <ac:plain-text-body><![CDATA[this is my code]]></ac:plain-text-body>
</ac:macro>
```

This is my title
this is my code

Column macro

Used with the Section macro to define columns on a page. See [Working with page layouts and columns and sections](#).

Macro name: column

Macro body: Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>The width of the column. Can be specified either in pixels (for example, 400px) or as a percentage of the available page width (for example, 50%).</td>
</tr>
</tbody>
</table>

Example:

```xml
<ac:macro ac:name="column">
  <ac:parameter ac:name="width">100px</ac:parameter>
  <ac:rich-text-body>
    <p>This is the content of <strong>column 1</strong>.</p>
  </ac:rich-text-body>
</ac:macro>
```

Content by Label macro
Displays a list of content associated with specific labels.

**Macro name:** contentbylabel

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>spaces</td>
<td>No</td>
<td>@all</td>
<td>Filters the results by space. The macro will display only the pages and other content types which belong to the space(s) you specify here. You can specify one or more space keys, separated by a comma or a space. • To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of (-\text{BADSPACE}) you will get only content which is not in the BADSPACE. • To indicate that the results <strong>must</strong> come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of (+\text{GOODSPACE}) you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)</td>
</tr>
</tbody>
</table>

Special values:
- **@self** — The current space.
- **@personal** — All personal spaces.
- **@global** — All global spaces.
- **@favorite** — The spaces you have marked as favourite.
- **@favourite** — The same as @favorite above.
- **@all** — All spaces in your Confluence site.
- **@** — The same as @all above.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.

<table>
<thead>
<tr>
<th>author</th>
<th>No</th>
<th>(None)</th>
<th>Filters the results by author. The macro will display only the pages and other content types which are written or updated by the author(s) you specify here. You can specify one or more authors, separated by a comma.</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>Adds a heading to the list.</td>
</tr>
<tr>
<td>showLabels</td>
<td>No</td>
<td>true</td>
<td>Determines whether to display the matching labels in the list of results.</td>
</tr>
<tr>
<td>reverse</td>
<td>No</td>
<td>false</td>
<td>Use this parameter in conjunction with the sort parameter. Set reverse=true to change the sort from ascending to descending. This parameter is ignored if the sort parameter is not specified.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-----------</td>
<td>---------</td>
<td>-------------</td>
<td></td>
</tr>
</tbody>
</table>
| sort | No | Determines how the results are sorted. To change the sort order from ascending to descending, use the `reverse` parameter described above. If this parameter is not specified, the sort order defaults to descending order based on the last modification date. Values:  
  - `title` — Sort alphabetically by title.  
  - `creation` — Sort by the date on which the content was added.  
  - `modified` — Sort by the date on which the content was last updated. |
| max | No | Determines the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied. |
| excerpt | No | If this parameter is set to `true`, the macro displays an excerpt from each page listed in the results. Note that you must define the excerpts on each of those pages, by adding the `Excerpt macro` to each page. If a particular page does not have an excerpt defined, then the Content by Label macro will not attempt to show an excerpt for that page. The Content by Label macro will show only the first few lines of the excerpt for each page. |
| labels     | Yes | (None) | Use this parameter to filter the results by label. The macro will display only the pages and other content types which are tagged with the label(s) you specify here. See also the operator parameter. You can specify one or more label values, separated by a comma or a space.  
- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of `badpage` you will get only content which is not labelled with 'badpage'.  
- To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of `superpage,goodpage` you will get only content which has at least two labels, being 'superpage' and 'goodpage'. |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>showSpace</td>
<td>No</td>
<td>true</td>
<td>Determines whether to display the spaces in the list of results.</td>
</tr>
<tr>
<td>type</td>
<td>No</td>
<td>All</td>
<td>Filters the results by content type. The macro will display only the content of the type you specify here. You can specify one or more types, separated by a comma or a space. To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of -blogpost you will get pages and all other content except for blog posts. Available values:</td>
</tr>
<tr>
<td>------</td>
<td>----</td>
<td>-----</td>
<td>-----------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- page — ages.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- blogpost or news — blog posts, also known as news items.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- attachment — attachments.</td>
</tr>
</tbody>
</table>
| operator | No | OR | The operator to apply to the supplied lists of labels. By default, a page with any of the non-prefixed labels (that is, labels without a plus (+) or minus (-) sign immediately preceding it) will be listed. If you specify a value of AND, only pages with all of the supplied non-prefixed labels will be listed.

Note that this parameter only modifies the behaviour of the 'Label(s)' parameter and only affects label values without a plus (+) or minus (-) sign prefix. To avoid confusion or unexpected results, we recommend that you do not use the operator parameter in conjunction with any label values prefixed with '+' or '-' signs.

Example:

```xml
<ac:macro ac:name="contentbylabel">
  <ac:parameter ac:name="spaces">@personal,@self</ac:parameter>
  <ac:parameter ac:name="author">admin,smaddox</ac:parameter>
  <ac:parameter ac:name="title">My labelled pages</ac:parameter>
  <ac:parameter ac:name="showLabels">false</ac:parameter>
  <ac:parameter ac:name="reverse">true</ac:parameter>
  <ac:parameter ac:name="sort">creation</ac:parameter>
  <ac:parameter ac:name="max">10</ac:parameter>
  <ac:parameter ac:name="labels">chocolate,cake</ac:parameter>
  <ac:parameter ac:name="showSpace">false</ac:parameter>
  <ac:parameter ac:name="type">page</ac:parameter>
  <ac:parameter ac:name="operator">AND</ac:parameter>
</ac:macro>
```

**Content by User macro**

Displays a list of the content items that have been created by a specified Confluence user.

**Macro name:** content-by-user

**Macro body:** None.
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter (Unnamed in wiki markup)</td>
<td>Yes</td>
<td>(None)</td>
<td>The Confluence username for the person whose content you wish to display</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:macro ac:name="content-by-user">
  <ac:default-parameter>jsmith</ac:default-parameter>
</ac:macro>
```

**Contributors macro**

Displays a list of Confluence users who have made a contribution of some type to a page.

**Macro name:** contributors

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>limit</td>
<td>No</td>
<td>(None)</td>
<td>Limits the number of contributors displayed in the list.</td>
</tr>
</tbody>
</table>
| spaces         | No       | Current space | Specifies the space key of the Confluence space to search. Space keys are case sensitive. Special values:  
  - @global — All global spaces.  
  - @personal — All personal spaces.  
  - @all — All spaces in the Confluence site.

You can specify one or more space keys or special values, separated by commas.

If no page and labels are specified, all pages from the specified set of spaces are included.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>reverse</td>
<td>No</td>
<td>false</td>
<td>Reverses the order of contributors in the list. Must be used in conjunction with the order parameter.</td>
</tr>
</tbody>
</table>
| scope          | No       | The specified page only | Specifies additional pages to include when generating the list of contributors. Available values:  
  - `children` – only the child pages of the specified page.  
  - `descendants` – all descendants of the specified page. |
<p>| labels         | No       | (None)  | Limits the list of contributors to those who created the specified labels on a page. You can specify one or more labels, separated by commas. |
| showPages      | No       | false   | If the value is true, the macro will display a list of the pages used to generate the list of contributors. |
| noneFoundMessage | No     | &quot;No contributors found for:&quot; (and a summary of selected parameter values) | Any message given here will override the default message that is displayed when no contributors are found. |
| showCount      | No       | false   | Determines whether the macro will show the number of times each person made a contribution. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| contentType   | No    | Restricts the content type that the macro will use when generating the list of contributors. Available values:  
|               |       | • pages – pages  
|               |       | • blogposts – blog posts.                                                   |
| include       | No    | Filters by either the type of contribution made to a page (and optionally its descendant pages), or the watches on the page. Contribution types are:  
|               |       | • authors - includes people who created or have edited the page(s)  
|               |       | • comments - includes people who have added comments to the page(s)  
|               |       | • labels - includes people who have added labels to the page(s)  
|               |       | • watches - includes people who are watching the page(s).  
|               |       | You can specify one or more contribution types, separated by commas.         |
| mode          | No    | Determines how the list of contributors is formatted:  
|               |       | • inline — a comma-separated list  
|               |       | • list — a bullet list.                                                     |
| showAnonymous | No    | Determines whether to include those who contributed anonymously to a page.    |
| **order** | No | **count** | Specifies the criteria used to sort contributors. Sort criteria are:
| | | | • **count** – sorts the names based on the total number of contributions to the page(s)
| | | | • **name** – sorts the names into alphabetical order
| | | | • **update** – sorts the names by the date of their last contribution to the page(s).
| **page** | No | The current page | Specifies the page to use when generating the list of contributors. If page and spaces are left blank, the current page is assumed.
| **showLastTime** | No | false | Determines whether to show the last time each person made a contribution.
| **publishDate** | No | (None) | Specifies the publication date for a blog post. The date format required is: YYYY/MM/DD.

**Example:**

This example specifies a content type of blog posts:
Contributors Summary macro

Displays a table of contribution-based statistics for a set of pages.

**Macro name:** contributors-summary

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>

This example specifies a content type of pages:

```
<ac:macro ac:name="contributors">
    <ac:parameter ac:name="limit">10</ac:parameter>
    <ac:parameter ac:name="spaces">ds,@personal</ac:parameter>
    <ac:parameter ac:name="reverse">true</ac:parameter>
    <ac:parameter ac:name="scope">descendants</ac:parameter>
    <ac:parameter ac:name="labels">chocolate,cake</ac:parameter>
    <ac:parameter ac:name="showPages">true</ac:parameter>
    <ac:parameter ac:name="noneFoundMessage">Oh dear, no contributors found</ac:parameter>
    <ac:parameter ac:name="showCount">true</ac:parameter>
    <ac:parameter ac:name="contentType">pages</ac:parameter>
    <ac:parameter ac:name="include">authors,comments,labels,watches</ac:parameter>
    <ac:parameter ac:name="mode">list</ac:parameter>
    <ac:parameter ac:name="showAnonymous">true</ac:parameter>
    <ac:parameter ac:name="order">update</ac:parameter>
    <ac:parameter ac:name="page">ds:Advanced Topics</ac:parameter>
    <ac:parameter ac:name="showLastTime">true</ac:parameter>
</ac:macro>
```
<table>
<thead>
<tr>
<th>Key</th>
<th>Default</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>limit</td>
<td>No</td>
<td>(None)</td>
<td>Limits the number of contributors or pages displayed in the table.</td>
</tr>
</tbody>
</table>
| spaces | No | Current space | Specifies the space key of the Confluence space to search. Space keys are case sensitive. Special values:  
  - @global — All global spaces.  
  - @personal — All personal spaces.  
  - @all — All spaces in the Confluence site. You can specify one or more space keys or special values, separated by commas. If no page and labels are specified, all pages from the specified set of spaces are included. |
| reverse | No | false | Reverses the order of items in the table. Must be used in conjunction with the order parameter. |
| showAnonymous | No | false | Determines whether to include those who contributed anonymously to a page. |
| scope | No | The specified page only | Specifies additional pages to include when generating the list of contributors. Available values:  
  - children — only the child pages of the specified page.  
  - descendants — all descendants of the specified page. |
| order | No | edits | Sets the criterion used for sorting items in the table. Available values:  
|       |    |       | • `edits` - sorts items in the table based on the total number of edits made, either by a contributor or to a page.  
|       |    |       | • `name` - sorts items in the table in alphabetical order, either by contributor or page name.  
|       |    |       | • `editTime` - sorts items in the table based on when the contributor last edited a page (or a specified set of pages) or when the page was last edited.  
|       |    |       | • `update` - sorts items in the table based on when the contributor last made any contribution to a page (or a specified set of pages) or when the page last had any contribution made to it.  
| page | No | The current page | A page title. Specifies the page to use when generating the list of contributors. If `page` and `spaces` are left blank, the current page is assumed.  
| labels | No | (None) | Limits contribution-based statistics to the specified labels only. You can specify one or more labels, separated by commas.  
| columns | No | `edits,comments,labels` | Determines the columns that should appear in the table. The statistics or type of information presented depends on the `groupby` parameter.
Available values:

- **edits** – the number of times each contributor has edited the page(s) or the number of edits made to each page.
- **edited** – a list of the pages edited by each contributor or a list of contributors who have edited each page.
- **comments** – the number of times each contributor has added comments to the page(s) or the number of comments on each page.
- **commented** – a list of pages to which each contributor has added comments or a list of contributors who have commented on each page.
- **labels** – the number of times each contributor has added labels to the page(s) or the number of labels on each page.
- **labeled** – a list of pages to which each contributor has added labels or a list of contributors who have added a label to each page.
- **labellist** – a list of labels either added by each contributor or on each page.
- **watches** – the number of pages being watched by each contributor/person or the number of contributors/people watching each page.
- **watching** – a list of pages being watched by each contributor/person or a list of contributors/people watching each page.
- **lastupdate** – the last time each contributor made an update or when each page was last updated. Valid updates can include edits, comments or label modifications to a page.

You can specify one or more columns, separated by commas.

<table>
<thead>
<tr>
<th>Option</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| groupby      | contributors  | Specifies the basis for grouping contribution-based statistics:  
- contributors – group by the people who have contributed.  
- pages – group by the pages used to find the contributors. |
| contentType  | Both pages and blog posts | Restricts the content type that the macro will use when generating the list of contributors.  
Available values:  
- pages – pages  
- blogposts – blog posts. |
| showZeroCounts | false | Determines whether contributors or pages are included for which the calculated statistic is zero. |
| publishDate  | (None)        | Specifies the publication date for a blog post. The date format required is: YYYY/MM/DD. |

**Example:**
This example specifies a content type of blog posts:

```
<ac:macro ac:name="contributors-summary">
  <ac:parameter ac:name="limit">10</ac:parameter>
  <ac:parameter ac:name="spaces">ds,@personal</ac:parameter>
  <ac:parameter ac:name="reverse">true</ac:parameter>
  <ac:parameter ac:name="showAnonymous">true</ac:parameter>
  <ac:parameter ac:name="order">update</ac:parameter>
  <ac:parameter ac:name="showZeroCounts">true</ac:parameter>
  <ac:parameter ac:name="contentType">blogposts</ac:parameter>
  <ac:parameter ac:name="publishDate">2012/06/07</ac:parameter>
</ac:macro>
```

This example specifies a content type of pages:

```
<ac:macro ac:name="contributors-summary">
  <ac:parameter ac:name="limit">10</ac:parameter>
  <ac:parameter ac:name="spaces">ds,@personal</ac:parameter>
  <ac:parameter ac:name="reverse">true</ac:parameter>
  <ac:parameter ac:name="showAnonymous">true</ac:parameter>
  <ac:parameter ac:name="scope">descendants</ac:parameter>
  <ac:parameter ac:name="order">update</ac:parameter>
  <ac:parameter ac:name="page">ds:Advanced Topics</ac:parameter>
  <ac:parameter ac:name="labels">chocolate,cake</ac:parameter>
  <ac:parameter ac:name="columns">edits,comments,labels,lastupdate</ac:parameter>
  <ac:parameter ac:name="groupby">pages</ac:parameter>
  <ac:parameter ac:name="contentType">pages</ac:parameter>
  <ac:parameter ac:name="showZeroCounts">true</ac:parameter>
</ac:macro>
```

**Expand macro**

Displays an expandable/collapsible section of text.

**Macro name:** expand

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>No</td>
<td>Click here to expand...</td>
<td>Text that will be displayed on the line that people can click to expand the hidden text.</td>
</tr>
<tr>
<td>(Unnamed in wiki markup)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Example:**
<ac:macro ac:name="expand">
<ac:default-parameter>This is my message</ac:default-parameter>
<ac:rich-text-body>
  <p>This text is <em>hidden</em> until you expand it.</p>
</ac:rich-text-body>
</ac:macro>

**Info macro**

Displays a block of text in a blue highlight box.

**Macro name:** info

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>icon</td>
<td>No</td>
<td>true</td>
<td>Determines whether to display the icon in the title bar of the information box.</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the information box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
</tbody>
</table>

**Example:**

The following example shows all parameters and a body:

<ac:macro ac:name="info">
  <ac:parameter ac:name="icon">false</ac:parameter>
  <ac:parameter ac:name="title">This is my title</ac:parameter>
  <ac:rich-text-body>
    <p>
      <span>This is </span>
      <em>important</em>
      <span> information.</span>
    </p>
  </ac:rich-text-body>
</ac:macro>

Below are some examples of the Info macro with various optional parameters used.

<table>
<thead>
<tr>
<th>Description</th>
<th>Markup</th>
<th>What you will get</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
| Info macro with a body defined and no optional parameters | <ac:macro ac:name="info">
  <ac:rich-text-body><p>This is <em>important</em> information.</p></ac:rich-text-body></ac:macro> |
| --- | --- |
| Info macro with a body and an optional Title parameter defined | <ac:macro ac:name="info">
  <ac:parameter ac:name="title">This is my title</ac:parameter>
  <ac:rich-text-body><p>This is <em>important</em> information.</p></ac:rich-text-body></ac:macro> |
### Info macro with a body and optional Title and Icon parameters defined

```
<ac:macro ac:name="info">
    <ac:parameter ac:name="icon">false</ac:parameter>
    <ac:parameter ac:name="title">This is my title</ac:parameter>
    <ac:rich-text-body>
        <p>
            <span>This is important information.</span>
        </p>
    </ac:rich-text-body>
</ac:macro>
```

### This is my title
This is *important* information.

---

### Section macro

Used with the Column macro to define columns on a page. See [Working with page layouts and columns and sections](#).

**Macro name:** section

**Macro body:** Rich text, consisting of one or more Column macros.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>border</td>
<td>No</td>
<td>False</td>
<td>If the value is true, the columns in this section will have a dashed border.</td>
</tr>
</tbody>
</table>

**Example:**
Table of Contents macro

Displays a table of contents from your page headings.

**Macro name:** toc

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>printable</td>
<td>No</td>
<td>true</td>
<td>If you set this parameter to false, the table of contents will not be visible when you print the page.</td>
</tr>
</tbody>
</table>
| **style** | **No** | **none** | The style of bullet point for each list item. You can use any valid CSS style. For example:  
- `none` — No list style is displayed.  
- `circle` — The list style is a circle.  
- `disc` — The list style is a filled circle. This is the typical bullet list, and is the one we are using in this example list.  
- `square` — The list style is a square.  
- `decimal` — The list is numbered (1, 2, 3, 4, 5).  
- `lower-alpha` — The list style is lower case, alphabetised (a, b, c, d, e).  
- `lower-roman` — The list style is lower-case roman numerals (i, ii, iii, iv, v, vi).  
- `upper-roman` — The list style is upper-case roman numerals (I, II, III, IV, V, VI). |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>maxLevel</strong></td>
<td><strong>No</strong></td>
<td><strong>7</strong></td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>indent</td>
<td>No</td>
<td>(None)</td>
</tr>
<tr>
<td>minLevel</td>
<td>No</td>
<td>1</td>
</tr>
<tr>
<td>class</td>
<td>No</td>
<td>(None)</td>
</tr>
<tr>
<td>exclude</td>
<td>No</td>
<td>(None)</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Value</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
<td>-------</td>
</tr>
<tr>
<td>type</td>
<td>No</td>
<td>list</td>
</tr>
<tr>
<td>outline</td>
<td>No</td>
<td>false</td>
</tr>
<tr>
<td>separator</td>
<td>No</td>
<td>brackets</td>
</tr>
<tr>
<td>include</td>
<td>No</td>
<td>(None)</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
</tbody>
</table>

**Example:**

This example shows a list-type table of contents.

```xml
<ac:macro ac:name="toc">
    <ac:parameter ac:name="printable">true</ac:parameter>
    <ac:parameter ac:name="style">square</ac:parameter>
    <ac:parameter ac:name="maxLevel">2</ac:parameter>
    <ac:parameter ac:name="indent">5px</ac:parameter>
    <ac:parameter ac:name="minLevel">2</ac:parameter>
    <ac:parameter ac:name="class">bigpink</ac:parameter>
    <ac:parameter ac:name="exclude">[1//2]</ac:parameter>
    <ac:parameter ac:name="type">list</ac:parameter>
    <ac:parameter ac:name="outline">true</ac:parameter>
    <ac:parameter ac:name="include">.*</ac:parameter>
</ac:macro>
```

This example shows a flat table of contents.

```xml
<ac:macro ac:name="toc">
    <ac:parameter ac:name="printable">true</ac:parameter>
    <ac:parameter ac:name="maxLevel">2</ac:parameter>
    <ac:parameter ac:name="minLevel">2</ac:parameter>
    <ac:parameter ac:name="class">bigpink</ac:parameter>
    <ac:parameter ac:name="exclude">[1//2]</ac:parameter>
    <ac:parameter ac:name="type">flat</ac:parameter>
    <ac:parameter ac:name="outline">true</ac:parameter>
    <ac:parameter ac:name="separator">pipe</ac:parameter>
    <ac:parameter ac:name="include">.*</ac:parameter>
</ac:macro>
```

**Macro format notes**

See [Sun's Regex documentation](https://docs.oracle.com/javase/7/docs/api/regex.html) for examples of constructing regular expression strings.
Macro bodies

Some macros accept a body as well as parameters.

- The Info macro and Expand macro are examples of macros that accept a rich text body.
- The Code Block macro is a good example of a macro that accepts a plain text body.

Plain text bodies

The body of a plain text macro must be inside a CDATA block. So the following is not sufficient:

```xml
<ac:plain-text-body>text</ac:plain-text-body>
```

The correct usage is:

```xml
<ac:plain-text-body><![CDATA[text]]></ac:plain-text-body>
```

Other notes

- The 'Required' column indicates whether the parameter is required on data entry. If the parameter is not supplied, Confluence will insert default values as indicated in the 'Default' column.
- **A request from the Atlassian technical writers about comments and feedback:** When adding comments to this page, please restrict your comments to constructive feedback on the documentation itself: Things we've missed in the documentation, and things that will be useful to other readers. If you have other feedback about the editor, wiki markup, the XML storage format, and Confluence 4 in general, please add your comments in the section titled Confluence 4 Editor - Customer Feedback, and its child pages. Our reason for this request: When a page attracts a large number of comments, it makes it difficult for everyone to read the page, and to add or respond to comments about the documentation. Thanks.

Confluence Storage Format Examples for Chart Macro

This page is an extension of Confluence Storage Format for Macros, which contains storage format examples for all Confluence macros. The Chart macro is a special case, because it offers so many options via parameters and chart types. This page offers additional examples for the Chart macro.

**Pie chart**

Here is a simple example of a pie chart.

Storage format
<ac:macro ac:name="chart">
  <ac:parameter ac:name="title">Fish Sold</ac:parameter>
  <ac:parameter ac:name="type">pie</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th><p>Fish Type</p></th>
          <th><p>2004</p></th>
          <th><p>2005</p></th>
        </tr>
        <tr>
          <td><p>Herring</p></td>
          <td><p>9,500</p></td>
          <td><p>8,300</p></td>
        </tr>
        <tr>
          <td><p>Salmon</p></td>
          <td><p>2,900</p></td>
          <td><p>4,200</p></td>
        </tr>
        <tr>
          <td><p>Tuna</p></td>
          <td><p>1,500</p></td>
          <td><p>1,500</p></td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:macro>

Resulting chart
Fish Sold

Here is a simple example of a bar chart.

Storage format
<ac:macro ac:name="chart">
    <ac:parameter ac:name="title">Fish Sold</ac:parameter>
    <ac:parameter ac:name="type">bar</ac:parameter>
    <ac:rich-text-body>
        <table>
            <tbody>
                <tr>
                    <th>Fish Type</th>
                    <th>2004</th>
                    <th>2005</th>
                </tr>
                <tr>
                    <th>Herring</th>
                    <td>9,500</td>
                    <td>8,300</td>
                </tr>
                <tr>
                    <th>Salmon</th>
                    <td>2,900</td>
                    <td>4,200</td>
                </tr>
                <tr>
                    <th>Tuna</th>
                    <td>1,500</td>
                    <td>1,500</td>
                </tr>
            </tbody>
        </table>
    </ac:rich-text-body>
</ac:macro>

Resulting chart
Time series chart

Here is an example of a time series chart.

Storage format

```xml
<ac:macro ac:name="chart">
  <ac:parameter ac:name="timePeriod">Month</ac:parameter>
  <ac:parameter ac:name="dataOrientation">vertical</ac:parameter>
  <ac:parameter ac:name="rangeAxisLowerBound">0</ac:parameter>
  <ac:parameter ac:name="dateFormat">MM/yyyy</ac:parameter>
  <ac:parameter ac:name="type">timeSeries</ac:parameter>
  <ac:parameter ac:name="domainaxisrotateticklabel">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th>Month</th>
          <th>Revenue</th>
        </tr>
        <tr>
          <td>1/2005</td>
          <td>31.8</td>
        </tr>
        <tr>
          <td>2/2005</td>
          <td>41.8</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:macro>
```
<table>
<thead>
<tr>
<th>Date</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>3/2005</td>
<td>51.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>33.8</td>
</tr>
<tr>
<td>5/2005</td>
<td>27.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>49.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>77.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>73.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>97.6</td>
</tr>
<tr>
<td>Month</td>
<td>Expenses</td>
</tr>
<tr>
<td>--------</td>
<td>----------</td>
</tr>
<tr>
<td>1/2005</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>45.0</td>
</tr>
<tr>
<td>5/2005</td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td>Value</td>
</tr>
<tr>
<td>--------</td>
<td>-------</td>
</tr>
<tr>
<td>6/2005</td>
<td>44.6</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>52.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>53.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>55.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>61.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>63.7</td>
</tr>
</tbody>
</table>
Resulting chart

![XY line chart](image)

**XY line chart**

Here is an example of an XY line chart.
### Resulting chart

```xml
<ac:macro ac:name="chart">
  <ac:parameter ac:name="type">xyline</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th></th>
          <th>12</th>
          <th>14</th>
          <th>23</th>
        </tr>
        <tr>
          <td>Revenue</td>
          <td>41.1</td>
          <td>31.8</td>
          <td>12.4</td>
        </tr>
        <tr>
          <td>Expense</td>
          <td>31.1</td>
          <td>41.8</td>
          <td>43.6</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:macro>
```
XY bar chart

Here is an example of an XY bar chart.

Storage format
Resulting chart
**XY area chart**

Here is an example of an XY area chart.

*Storage format*
<ac:macro ac:name="chart">
    <ac:parameter ac:name="type">xyarea</ac:parameter>
    <ac:rich-text-body>
        <table>
            <tbody>
                <tr>
                    <th>&nbsp;</th>
                    <th>12</th>
                    <th>14</th>
                    <th>23</th>
                </tr>
                <tr>
                    <td>Revenue</td>
                    <td>41.1</td>
                    <td>31.8</td>
                    <td>12.4</td>
                </tr>
                <tr>
                    <td>Expense</td>
                    <td>31.1</td>
                    <td>41.8</td>
                    <td>43.6</td>
                </tr>
            </tbody>
        </table>
    </ac:rich-text-body>
</ac:macro>

Resulting chart
Area chart

Here are two examples of area charts.

Storage format for area chart 1

```xml
<ac:macro ac:name="chart">
  <ac:parameter ac:name="height">300</ac:parameter>
  <ac:parameter ac:name="legend">true</ac:parameter>
  <ac:parameter ac:name="width">300</ac:parameter>
  <ac:parameter ac:name="opacity">50</ac:parameter>
  <ac:parameter ac:name="type">area</ac:parameter>
  <ac:parameter ac:name="dataDisplay">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th>Satisfaction</th>
          <th>2002</th>
          <th>2003</th>
          <th>2004</th>
        </tr>
        <tr>
          <td>Very satisfied</td>
          <td>20</td>
          <td>23</td>
          <td></td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:macro>
```
| Satisfied | 40 | 34 | 23 |
| Disatisfied | 25 | 26 | 25 |
| Very disatisfied | 15 | 17 | 18 |
Resulting area chart 1

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
<td>34</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Disatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>

Storage format for area chart 2

```xml
<ac:macro ac:name="chart">
  <ac:parameter ac:name="stacked">true</ac:parameter>
  <ac:parameter ac:name="height">300</ac:parameter>
  <ac:parameter ac:name="legend">true</ac:parameter>
  <ac:parameter ac:name="width">300</ac:parameter>
  <ac:parameter ac:name="type">area</ac:parameter>
  <ac:parameter ac:name="dataDisplay">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th>Satisfaction</th>
          <th>2002</th>
          <th>2003</th>
          <th>2004</th>
        </tr>
        <tr>
          <td>Very satisfied</td>
          <td>20</td>
          <td>23</td>
          <td>34</td>
        </tr>
        <tr>
          <td>Satisfied</td>
          <td>40</td>
          <td>34</td>
          <td>23</td>
        </tr>
        <tr>
          <td>Disatisfied</td>
          <td>25</td>
          <td>26</td>
          <td>25</td>
        </tr>
        <tr>
          <td>Very dissatisfied</td>
          <td>15</td>
          <td>17</td>
          <td>18</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:macro>
```
<table>
<thead>
<tr>
<th>Year</th>
<th>Very satisfied</th>
<th>Satisfied</th>
<th>Disatisfied</th>
<th>Very disatisfied</th>
</tr>
</thead>
<tbody>
<tr>
<td>2004</td>
<td>12</td>
<td>1</td>
<td>4</td>
<td>2</td>
</tr>
<tr>
<td>2005</td>
<td>23</td>
<td>34</td>
<td>6</td>
<td>7</td>
</tr>
<tr>
<td>2006</td>
<td>31</td>
<td>36</td>
<td>22</td>
<td>12</td>
</tr>
</tbody>
</table>
Confluence Wiki Markup

This page describes the wiki markup used on some administration screens in Confluence. Another page describes the wiki markup for macros.

Wiki markup is useful when you want to do one of the following:

- Configure the Documentation theme.
- Type wiki markup directly into the editor. Confluence will convert it to the rich text editor format as you type.
- Create links using the Advanced tab of the Links Browser.
- Insert a block of wiki markup into the Confluence editor. (Choose Insert > Wiki Markup.)

**Note: You cannot edit content in wiki markup.** Confluence does not store page content in wiki markup. Although you can enter wiki markup into the editor, Confluence will convert it to the rich text editor format immediately. You will not be able to edit the wiki markup after initial entry.

**A request from the Atlassian technical writers about comments and feedback:** When adding comments to this page, please restrict your comments to constructive feedback on the documentation itself: Things we’ve missed in the documentation, and things that will be useful to other readers. If you have other feedback about the editor, wiki markup, the XML storage format, and Confluence 4 in general, please add your comments in the section titled Confluence 4 Editor - Customer Feedback, and its child pages. Our reason for this request: When a

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>12</td>
<td>23</td>
<td>31</td>
</tr>
<tr>
<td>Satisfied</td>
<td>1</td>
<td>34</td>
<td>36</td>
</tr>
<tr>
<td>Disatisfied</td>
<td>4</td>
<td>6</td>
<td>22</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>2</td>
<td>7</td>
<td>12</td>
</tr>
</tbody>
</table>

Resulting area chart 2

Very satisfied | Satisfied | Disatisfied | Very dissatisfied

---

Confluence 4.3 Documentation

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
page attracts a large number of comments, it makes it difficult for everyone to read the page, and to add or respond to comments about the documentation. Thanks.

---

### Headings

To format a line as a heading, type "hn." at the start of your line, where n can be a number from 1 to 6.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>h1. Biggest heading</td>
<td>Biggest heading</td>
</tr>
<tr>
<td>h3. Big heading</td>
<td>Big heading</td>
</tr>
<tr>
<td>h5. Small heading</td>
<td>Small heading</td>
</tr>
</tbody>
</table>

### Lists

Wiki markup allows you to create bulleted or numbered lists, and is flexible enough to allow a combination of the two list types.

1. If you need to separate the text within lists using line breaks, make sure you do so using a double slash (//). Empty lines may disrupt the list.

#### Simple lists

Use the hyphen (-) to create simple lists.

Make sure there is a space between the hyphen and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>- some</td>
<td>• some</td>
</tr>
<tr>
<td>- bullet</td>
<td>• bullet</td>
</tr>
<tr>
<td>- points</td>
<td>• points</td>
</tr>
</tbody>
</table>

---
Use the asterisk (*) to create bullets. For each subsequent level, add an extra asterisk. Make sure there is a space between the asterisk and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>* some</td>
<td>• some</td>
</tr>
<tr>
<td>* bullet</td>
<td>• bullet</td>
</tr>
<tr>
<td>** indented</td>
<td>• indented</td>
</tr>
<tr>
<td>** bullets</td>
<td>• bullets</td>
</tr>
<tr>
<td>* points</td>
<td>• points</td>
</tr>
</tbody>
</table>

**Numbered lists**

Use the hash (#) to create numbered lists. Make sure there is a space between the hash and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td># a</td>
<td>1. a</td>
</tr>
<tr>
<td># numbered</td>
<td>2. numbered</td>
</tr>
<tr>
<td># list</td>
<td>3. list</td>
</tr>
</tbody>
</table>

A second level of hashes will produce a sub-list, such as the **alphabetical** sub-list shown below.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td># Here's a sentence.</td>
<td>1. Here's a sentence.</td>
</tr>
<tr>
<td>## This is a sub-list point.</td>
<td>a. This is a sub-list point.</td>
</tr>
<tr>
<td>## And a second sub-list point.</td>
<td>b. And a second sub-list point.</td>
</tr>
<tr>
<td># Here's another sentence.</td>
<td>2. Here's another sentence.</td>
</tr>
</tbody>
</table>

You can use a third level of hashes to produce a sub-sub-list.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td># Here's a sentence.</td>
<td>1. Here's a sentence.</td>
</tr>
<tr>
<td>## This is a sub-list point.</td>
<td>a. This is a sub-list point.</td>
</tr>
<tr>
<td>### Third list level.</td>
<td>i. Third list level.</td>
</tr>
<tr>
<td>### Another point at the third level.</td>
<td>ii. Another point at the third level.</td>
</tr>
<tr>
<td>## And a second sub-list point.</td>
<td>b. And a second sub-list point.</td>
</tr>
<tr>
<td># Here's another sentence.</td>
<td>2. Here's another sentence.</td>
</tr>
</tbody>
</table>

**Note:** In numbered lists as described above, the format of the 'number' displayed at each list level may be
different, depending upon your browser and the style sheets installed on your Confluence instance. So in some cases, you may see letters (A, B, C, etc; or a, b, c, etc) or Roman numerals (i, ii, iii, etc) at different list levels.

Mixed lists

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| # Here
#* is
#* an
# example
#* of
#* a
# mixed
# list |
| 1. Here
  • is
  • an
2. example
  • of
  • a
3. mixed
4. list |

Tables

You can create two types of tables.

Table Type 1

Allows you to create a simple table with an optional header row. You cannot set the width of the columns in this table.

Use double bars for a table heading row.

What you need to type:

<table>
<thead>
<tr>
<th>heading 1</th>
<th>heading 2</th>
<th>heading 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>cell A1</td>
<td>cell A2</td>
<td>cell A3</td>
</tr>
<tr>
<td>cell B1</td>
<td>cell B2</td>
<td>cell B3</td>
</tr>
</tbody>
</table>

What you will get:

<table>
<thead>
<tr>
<th>heading 1</th>
<th>heading 2</th>
<th>heading 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>cell A1</td>
<td>cell A2</td>
<td>cell A3</td>
</tr>
<tr>
<td>cell B1</td>
<td>cell B2</td>
<td>cell B3</td>
</tr>
</tbody>
</table>

You can also use a vertical header.

What you need to type:

<table>
<thead>
<tr>
<th>heading 1</th>
<th>col A1</th>
<th>col A2</th>
<th>col A3</th>
</tr>
</thead>
<tbody>
<tr>
<td>heading 2</td>
<td>col B1</td>
<td>col B2</td>
<td>col B3</td>
</tr>
</tbody>
</table>
Table Type 2

This method allows you to specify the width of the columns in the table.

**What you need to type**

```markdown
{section:border=true}
{column:width=30%}
Text for this column goes here. This is the smaller column with a width of only 30%.
{column}
{column:width=70%}
Text for this column goes here. This is the larger column with a width of 70%.
{section}
```

**What you will get**

Text for this column goes here. This is the smaller column with a width of only 30%.

Text for this column goes here. This is the larger column with a width of 70%.

* For more details please see the [Column Macro](#) and the [Section Macro](#).

**Advanced Formatting**

**Colour and Other Formatting**

To add colour and other formatting to your tables, you can use the [Panel Macro](#) within columns. More table-formatting options may be available if your Confluence administrator has installed additional [macros](#).

**Lists**

Here's an example of how to embed lists in a table:

**What you need to type**

```
||Heading 1||Heading 2||
* Item 1
* Item 2
* Item 3
# Item 1
# Item 2
# Item 3
```

**What you will get**

| Heading 1 | Heading 2 |
### Text Effects

Use the markup shown in the examples below to format text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>strong</em></td>
<td>strong</td>
</tr>
<tr>
<td><em>bold text</em></td>
<td>bold text</td>
</tr>
<tr>
<td><em>emphasis</em></td>
<td>emphasis</td>
</tr>
<tr>
<td><em>italics</em></td>
<td><em>italics</em></td>
</tr>
<tr>
<td></td>
<td><em>Hint</em>: To italicise parts of a word, add braces (curly brackets) around the underscore. For example, Thing(<em>,)</em> gives you this: Thingx</td>
</tr>
<tr>
<td>??citation??</td>
<td>citation</td>
</tr>
<tr>
<td>-deleted-</td>
<td>deleted</td>
</tr>
<tr>
<td>+inserted+</td>
<td>inserted</td>
</tr>
<tr>
<td>Text with^superscript^</td>
<td>Text with^superscript^</td>
</tr>
</tbody>
</table>
|                       | *Hint*: There are two ways to make superscripts work, when used directly after another word or character:  
|                       | • Add a space before the superscript. For example, kg/m^3^ gives you this: kg/m^3^  
|                       | • Add braces (curly brackets) around the superscript markup. For example, kg/m(^3^) gives you this: kg/m^3^ |
| Text with~subscript~  | Text with~subscript~ |
| ({monospaced})        | monospaced         |

bq. Here’s how you make a paragraph appear as a block quotation.
Text Breaks

Paragraph Break

In wiki markup, a paragraph is a continuous line of text ending in two carriage returns. This is equivalent to a continuous line of text followed by a blank line.

When rendered into HTML, the result is a line of text wrapped in a set of `<p>` tags.

Line Break

Confluence provides two options for forcing a line break within a paragraph of text:

- Implicitly, by entering a single carriage return at its end.
- Explicitly, by entering two consecutive backslashes: `\`

When rendered into HTML, the result is a paragraph of text that is split into separate lines by `<br>` tags, wherever a forced line break appears.

For most purposes, explicit line breaks are not required because a single carriage return is enough.

The examples below show how to use explicit line breaks.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>here is some text</td>
<td>here is some text divided using line breaks</td>
</tr>
<tr>
<td>\                                           \</td>
<td></td>
</tr>
<tr>
<td>divided \                                           \</td>
<td></td>
</tr>
<tr>
<td>using line \                                           \</td>
<td></td>
</tr>
<tr>
<td>breaks\                                            \</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>This is a short list:</th>
<th>This is a short list:</th>
</tr>
</thead>
<tbody>
<tr>
<td>* Point 1</td>
<td>* Point 1</td>
</tr>
<tr>
<td>Text to go with point 1</td>
<td>Text to go with point 1</td>
</tr>
<tr>
<td>* Point 2</td>
<td>* Point 2</td>
</tr>
<tr>
<td>\                                           \</td>
<td></td>
</tr>
<tr>
<td>Text to go with point 2 with a break</td>
<td>Text to go with point 2 with a break</td>
</tr>
</tbody>
</table>

If you wish to use multiple consecutive line breaks, each should be separated by a space character. For example, use this for two consecutive line breaks:

```
\ \ \ \  
```

Horizontal Rule

Use four dashes (----) then press Enter, to create a horizontal rule. (It does not work if you press space.)

Make sure that the dashes are on a separate line from the rest of the text.
### What you need to type | What you will get
--- | ---
here is some text
-----
divided by a horizontal rule

### Links
You can use wiki markup to add hyperlinks to your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>[#anchor]</td>
<td>A link to an anchor on the same page.</td>
</tr>
<tr>
<td>[Confluence Wiki Markup*attachment.ext]</td>
<td>A link to a file attached to the page.</td>
</tr>
<tr>
<td>[pagetitle]</td>
<td>A link to a page.</td>
</tr>
<tr>
<td>[pagetitle#anchor]</td>
<td>A link to an anchor on another page.</td>
</tr>
<tr>
<td>[pagetitle*attachment.ext]</td>
<td>A link to a file attached to another page.</td>
</tr>
<tr>
<td>[spacekey:pagetitle]</td>
<td>A link to a page in another space.</td>
</tr>
<tr>
<td>[spacekey:pagetitle#anchor]</td>
<td>A link to an anchor on a page in another space.</td>
</tr>
<tr>
<td>[spacekey:pagetitle*attachment.ext]</td>
<td>A link to a file attached to a page in another space.</td>
</tr>
<tr>
<td>[/2004/01/12/blogposttitle]</td>
<td>A link to a blog post.</td>
</tr>
<tr>
<td>[spacekey:/2004/01/12/blogposttitle]</td>
<td>A link to a blog post in another space.</td>
</tr>
<tr>
<td>[/2004/01/12]</td>
<td>A link to a whole day's blog posts.</td>
</tr>
<tr>
<td>[spacekey:/2004/01/12]</td>
<td>A link to a whole day's blog posts in another space.</td>
</tr>
<tr>
<td>[spacekey:]</td>
<td>A link to the space homepage (or the space summary page of the space.</td>
</tr>
<tr>
<td>[~username]</td>
<td>A link to the user profile page of a particular user.</td>
</tr>
<tr>
<td>[phrase@shortcut]</td>
<td>A shortcut link to the specified shortcut site. Shortcuts are configured by the site administrator.</td>
</tr>
<tr>
<td>[<a href="mailto:legendaryservice@atlassian.com">mailto:legendaryservice@atlassian.com</a>]</td>
<td>A link to an email address.</td>
</tr>
</tbody>
</table>
A link to a file on your computer or on a network share that you have mapped to a drive. This only works on Internet Explorer.

Note that Confluence treats headings as anchors, so you can link to headings using this pattern: [spacekey:pagename#headingname], where headingname is case-sensitive and must be entered without spaces.

For each of these link forms:

- You can prepend a link alias, so that alternate text is displayed on the page. Example: [link alias|pagetitle#anchor]
- You can append a link tip, which appears as a tooltip. Example: [pagetitle#anchor|link tip]

**Images**

You can display images from attached files or remote sources.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>![<a href="http://www.host.com/image.gif">http://www.host.com/image.gif</a>!]</td>
<td>An image from a remote source is displayed on the page. Uses a fully qualified URL.</td>
</tr>
<tr>
<td>![attached-image.gif!]</td>
<td>An image file attached to the page is displayed.</td>
</tr>
<tr>
<td>![pageTitle^image.gif!]</td>
<td>An image file attached to a different page is displayed.</td>
</tr>
<tr>
<td>![spaceKey:pageTitle^image.gif!]</td>
<td>An image file attached to a page in a different space is displayed.</td>
</tr>
<tr>
<td>![/2010/05/23/My Blog Post^image.gif!]</td>
<td>An image file attached to a blog post is displayed.</td>
</tr>
<tr>
<td>![image.jpg</td>
<td>thumbnail!]</td>
</tr>
<tr>
<td>![image.gif</td>
<td>align=right, vspace=4!]</td>
</tr>
</tbody>
</table>

Available HTML image tags include:

<table>
<thead>
<tr>
<th>Image tag</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>align</td>
<td>Available values are 'left', 'right', 'bottom', 'center', 'top'.</td>
</tr>
<tr>
<td>border</td>
<td>Specifies the width of the border (in pixels).</td>
</tr>
</tbody>
</table>
bordercolor | Use with the ‘border’ tag. Specify colours by name or hex value.

hspace | Specifies the amount of whitespace to be inserted to the left and right of the image (in pixels).

vspace | Specifies the amount of whitespace to be inserted above and below the image (in pixels).

width | Specifies the width of the image (in pixels). This will override the natural width of the image.

height | Specifies the height of the image (in pixels). This will override the natural height of the image.

title | Specifies alternate text for the image, which is displayed when the pointer hovers over the image.

alt | Specifies alternate text for the image. This text is retrievable via search, and contributes to accessibility of the page for text-only viewing.

---

**Page Layouts**

There is no wiki markup representation for page layouts.

**Useful Information**

- A **space key** is a short, unique identifier for a space. For example, you might give your documentation space a key of “DOC”. To find the key of an existing space, look at the Confluence URL for a page in the space. The standard Confluence URL has this format:

  http://my.confluence.site.com/display/SPACEKEY/Page+Name

- If you would like to edit the XML source of a page, your Confluence system administrator will need to install the Confluence Source Editor plugin. See more about the Confluence Storage Format.

- Before installing a plugin into your Confluence site, please check the plugin’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

---

**Confluence Wiki Markup for Macros**

*Work in progress*

We are adding the details for each macro in turn. They are not all here yet. See

[CONF-24972 - Authenticate](#) to see issue details. In the meantime, please refer to the Confluence 3.5 macro documentation.

This page is an extension of Confluence Wiki Markup. It describes the wiki markup used to define specific Confluence macros – the macros that are shipped with Confluence. For each macro, we define the macro name,
parameter names, and accepted parameter values.

Wiki markup is useful when you want to do one of the following:
- Configure the Documentation theme.
- Type wiki markup directly into the editor. Confluence will convert it to the rich text editor format as you type.
- Create links using the Advanced tab of the Links Browser.
- Insert a block of wiki markup into the Confluence editor. (Choose Insert > Wiki Markup.)

**Note: You cannot edit content in wiki markup.** Confluence does not store page content in wiki markup. Although you can enter wiki markup into the editor, Confluence will convert it to the rich text editor format immediately. You will not be able to edit the wiki markup after initial entry.

**Anchor macro**

Allows you to link to a specific part of a page.

**Macro name:** anchor

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>Yes</td>
<td>(None)</td>
<td>The name of the anchor.</td>
</tr>
</tbody>
</table>

(Unnamed in wiki markup)

**Example:**

```
{anchor:here}
```
Attachments macro

Displays a list of attachments on a given page.

**Macro name:** attachments

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>old</td>
<td>No</td>
<td>false</td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• false - Displays only the latest version of each attachment.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• true – Displays all versions of each attachment, including the old versions.</td>
</tr>
</tbody>
</table>
| **patterns** | No | (None) | A comma-separated list of regular expressions, used to filter the attachments by file name. Note that the parameter values must be regular expressions. For example:
  - To match a file suffix of 'jpg', use .jpg (not *.jpg).
  - To match file names ending in 'jpg' or 'png', use .*jpg,.*png.
Here is a [tutorial on regular expressions](https://regex101.com/). |
| **sortBy** | No | date | Available values:
  - date
  - size
  - name |
| **page** | No | The page on which the macro exists. | Page name, used to display attachments from another page. |
| **sortOrder** | No | The default sort order is determined by the sortBy type:
  - Reverse chronological for 'date'.
  - Largest to smallest for 'size'.
  - Alphabetical for 'name'. | Available values:
  - ascending
  - descending |
| **labels** | No | (None) | A comma-separated list of labels. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.) |
| **upload** | No | false | Determines whether the list of attachments will include options allowing users to browse for, and attach, new files. |
Blog Posts macro

Lists the most recent news items in the space.

**Macro name:** blog-posts

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>content</td>
<td>No</td>
<td>entire</td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• entire – Display the whole content of each blog post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• excerpts – Display a short extract from each blog post. If the post contains an Excerpt macro, the Blog Posts macro will display the content defined in the Excerpt macro. If the post does not contain an Excerpt macro, the Blog Posts macro will display the first few sentences of the post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• titles – Display a list of blog posts, showing titles only.</td>
</tr>
<tr>
<td>spaces</td>
<td>No</td>
<td>@self</td>
<td>One or more space keys, separated by a comma or a space.</td>
</tr>
</tbody>
</table>
• To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.
• To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>author</td>
<td>No</td>
<td>(None)</td>
<td>One or more usernames, separated by commas.</td>
</tr>
</tbody>
</table>
| time      | No       | (None)  | Available values:  
  - m — Minutes  
  - h — Hours  
  - d — Days  
  - w — Weeks  
  
  For example,  
  - time=12h — Display blog posts created in the last twelve hours.  
  - time=7d — Display blog posts created in the last seven days. |
| reverse   | No       | false   | A value of `true` changes the sort order. |

- `@self` — The current space.
- `@personal` — All *personal* spaces.
- `@global` — All *global* spaces.
- `@favorit` — The spaces you have marked as *favourite*.
- `@favourite` — The same as `@favorite` above.
- `@all` — All spaces in your Confluence site.
- `*` — The same as `@all` above.

When specifying a personal space, remember to use the tilde (`~`) sign in front of the username, such as `~jbloggs` or `~jbloggs@example.com`. 
<table>
<thead>
<tr>
<th><strong>sort</strong></th>
<th>No</th>
<th><strong>crea</strong>tion</th>
<th>Available values:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>title</strong> — Sort alphabetically by title.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>creation</strong> — Sort by the date on which the content was added.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>modified</strong> — Sort by the date on which the content was last updated.</td>
</tr>
</tbody>
</table>

| **max** | No | 15 | The maximum number of results to be displayed. |

| **label** | No | (None) | One or more label values, separated by a comma or a space. |
|  |  |  | • To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of `-badpage` you will get only content which is not labelled with `badpage`. |
|  |  |  | • To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of `+superpage,+goodpage` you will get only content which has at least two labels, being `superpage` and `goodpage`. |

Example:

```
{blog-posts:content=titles|spaces=@self,ds|author=jsmith|time=4w|reverse=true|sort=creation|max=10|label=chocolate,cookies}
```
Displays a history of updates made to a page.

**Macro name:** change-history

**Macro body:** None.

**Parameters:** None

**Example:**

```
{change-history}
```

---

**Chart macro**

Displays a chart based on tabular data.

**Macro name:** chart

**Macro body:** Accepts rich text, consisting of tables that hold the chart's data.

This macro recognises a large number of parameters, listed here by type for convenience.

**Chart type parameters**

These parameters determine the type of chart to display and how the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>type</td>
<td>No</td>
<td>pie</td>
<td>The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based. See the <code>timeSeries</code> parameter. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Standard charts – pie, bar, line, area</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- XY plots – xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Other charts – gantt (beta)</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>----------</td>
<td>---------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| orientation | No       | vertical | The display orientation. Applies to area, bar and line charts. Available values:
- `vertical` – y-axis is vertical
- `horizontal` – x-axis is vertical |
| 3D         | No       | false   | Show in three dimensions. Applies to area, bar and line charts. |
| stacked    | No       | false   | Stacked values. Applies to area and bar charts. |
| showShapes | No       | true    | Applies to line charts. Shapes are shown at each data point. |
| opacity    | No       |         | A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are. Example values:
- 75 percent for 3D charts
- 50 percent for non-stacked area charts
- 100 percent for all other charts |

**Chart display parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
</tbody>
</table>
| dataDisplay | No       | false   | Determines whether to display the body of the macro, consisting of the data table. By default, the chart data table is not displayed. Available values:
- `false` – the data is not displayed.
- `true` or `after` – the data is displayed after the chart.
- `before` – the data is displayed before the chart. |
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>subTitle</td>
<td>No</td>
<td>(None)</td>
<td>A subtitle for the chart.</td>
</tr>
<tr>
<td>xLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>yLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>legend</td>
<td>No</td>
<td>false</td>
<td>Determines whether to show a legend (key) for the chart.</td>
</tr>
</tbody>
</table>

Chart data parameters

The data for the chart is taken from tables found in the macro body. The parameters below control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. You can specify additional conversion options using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>tables</td>
<td>No</td>
<td>All first level tables</td>
<td>You can supply a comma-separated list of table IDs and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
</tr>
<tr>
<td>Parameter</td>
<td>Current Value</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>columns</td>
<td>No</td>
<td>All columns&lt;br&gt;You can supply a comma-separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the HTML title attribute for the column in the header row.</td>
<td></td>
</tr>
<tr>
<td>dataOrientation</td>
<td>No</td>
<td>horizontal&lt;br&gt;The content orientation. By default, the data tables will be interpreted as columns (horizontally) representing domain and x values. Available values:&lt;br&gt;• <em>vertical</em> – data table columns will be interpreted as series.&lt;br&gt;• <em>horizontal</em> – data tables rows will be interpreted as series.</td>
<td></td>
</tr>
<tr>
<td>timeSeries</td>
<td>No</td>
<td>false&lt;br&gt;If 'true', the x values in an XY plot will be treated as time series data and so will be converted according date formats.</td>
<td></td>
</tr>
<tr>
<td>dateFormat</td>
<td>No</td>
<td>Confluence language defined date formats&lt;br&gt;For time series data, the date format allows for additional customisation of the conversion of data to date values. If a dateFormat is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See <a href="#">simple date format</a>.</td>
<td></td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>----------</td>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>timePeriod</td>
<td>No</td>
<td>day</td>
<td>The time period for time series data. Defines the granularity of how the data is interpreted. Available values: millisecond, second, minute, hour, day, week, month, quarter, year</td>
</tr>
<tr>
<td>language</td>
<td>No</td>
<td>(None)</td>
<td>Use in combination with the country parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages. Available values are the two-character ISO 639-1 alpha-2 codes.</td>
</tr>
<tr>
<td>country</td>
<td>No</td>
<td>(None)</td>
<td>Use in combination with the language parameter to form a locale. Valid values are the two-character ISO 3166 codes.</td>
</tr>
</tbody>
</table>
| forgive     | No       | true      | Determines whether the macro will forgive (allow) some data formatting errors. Available values:  
  - true — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.  
  - false — the macro enforces strict data formatting. If there are data format errors, the chart will not be produced. |

**Chart colour parameters**

Colours are specified using hexadecimal notation or HTML colour names.
### Parameter

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>bgColor</td>
<td>No</td>
<td>White</td>
<td>Background colour of the chart.</td>
</tr>
<tr>
<td>borderColor</td>
<td>No</td>
<td>No border</td>
<td>Colour of the border around the chart.</td>
</tr>
<tr>
<td>colors</td>
<td>No</td>
<td></td>
<td>A comma-separated list of colours used to customise the colours of categories, sections, and series.</td>
</tr>
</tbody>
</table>

**Chart axis parameters**

Depending on the chart type, the range and domain axis may be customised. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rangeAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td>Minimum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td>Maximum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>rangeAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>domainAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the <code>dateFormat</code> parameter.</td>
</tr>
<tr>
<td>domainAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the <code>dateFormat</code> parameter.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------</td>
<td>----------</td>
<td>---------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>domainAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the <code>timePeriod</code> parameter. The <code>timePeriod</code> unit can be overridden by specifying a trailing character: y (years), M (months), d (days), h (hours), m (minutes), s (seconds), u (milliseconds).</td>
</tr>
<tr>
<td>domainAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
</tr>
<tr>
<td>categoryLabelPosition</td>
<td>No</td>
<td>(None)</td>
<td>Placement of the axis label text for categories. Available values: up45 — 45 degrees going upward, up90 — 90 degrees going upward, down45 — 45 degrees going downward, down90 — 90 degrees going downward</td>
</tr>
<tr>
<td>dateTickMarkPosition</td>
<td>No</td>
<td>start</td>
<td>Placement of the date tick mark. Available values: start — tick mark is at the start of the date period, middle — tick mark is in the middle of the date period, end — tick mark is at the end of the date period.</td>
</tr>
</tbody>
</table>
### pieSectionLabel

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| pieSectionLabel       | No       | Show only the pie section key value | Format of pie section labels. The format uses a string with special replacement variables:  
- %0% is replaced by the pie section key.  
- %1% is replaced by the pie section numeric value.  
- %2% is replaced by the pie section percent value.  
Example 1: To display something like 'Independent = 20':  

```
%0% = %1%
```

Example 2: To display something like 'Independent (20%)':  

```
%0% (%2%)
```

### pieSectionExplode

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pieSectionExplode</td>
<td>No</td>
<td>No exploded sections</td>
<td>A comma-separated list of pie keys that are to be shown exploded. Note: requires jFreeChart version 1.0.3 or higher.</td>
</tr>
</tbody>
</table>

### Chart attachment parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is displayed. These options allow for the generated image to be saved as an attachment and have subsequent access to re-use the attachment. This can be useful especially when combined with the Cache plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

---

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| attachment         | No      | The name and location where the chart image will be saved as an attachment. The user must be authorised to add attachments to the page specified. Available syntax for this parameter:  
  - `^attachmentName.png` — the chart is saved as an attachment to the current page.  
  - `page name^attachmentName.png` — the chart is saved as an attachment to the page name provided.  
  - `spacekey:page name^attachmentName.png` — the chart is saved as an attachment to the page name provided in the space indicated. |
| attachmentVersion  | No      | Defines the versioning mechanism for saved charts. Available values:  
  - `new` — creates new version of the attachment.  
  - `replace` — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorised to remove attachments for the page specified.  
  - `keep` — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated. |
| attachmentComment  | No      | Comment used for a saved chart attachment. (None) |
Example:

Below is a simple example of a pie chart. See more examples in Wiki Markup Examples for Chart Macro.

```markdown
{chart:type=pie|title=Fish Sold}
|| Fish Type || 2004 || 2005 ||
|| Herring | 9,500 | 8,300 |
|| Salmon | 2,900 | 4,200 |
|| Tuna | 1,500 | 1,500 |
{chart}
```

Cheese macro

Displays the words "I like cheese!"

Macro name: cheese

Macro body: None.

Parameters: None

Example:

```
{cheese}
```

Children Display macro

Displays the children and descendants of the current page.

Macro name: children

Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>reverse</td>
<td>No</td>
<td>false</td>
<td>Reverses the sort order in the list of child pages. Use this parameter in conjunction with the sort parameter described below. A value of true will change the sort order from ascending to descending.</td>
</tr>
</tbody>
</table>
| **sort** | **No** | Manual if the pages have been manually reordered, otherwise alphabetical by page title | Determines the sort order of the list of child pages. Available values:  
- **creation** – Sort by the date on which the page was created.  
- **title** – Sort alphabetically by page name.  
- **modified** – Sort by the date on which the page was last updated. |
<p>| <strong>style</strong> | <strong>No</strong> | <strong>Bullet list</strong> | A heading style to be applied to the list of child pages. Available values: h1 (heading level 1) through to h6 (heading level 6). |
| <strong>page</strong> | <strong>No</strong> | <strong>The page that contains the macro</strong> | The name of the parent page. The macro will display the children of the specified page. To specify a page in a different space, use a space key followed by a colon. For example: MYSPACE:My page If the value of this parameter is a forward slash (/) the macro will list the pages at the root of the current space. In other words, the pages without parents. |
| <strong>excerpt</strong> | <strong>No</strong> | <strong>false</strong> | If true, Confluence will display any excerpts that are defined on the child pages. The excerpts must be defined via an Excerpt macro. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>first</td>
<td>No</td>
<td>(None)</td>
<td>The maximum number of child pages to be displayed (at the top level). For example, if the value of this parameter is 99, the macro will display the first 99 pages at the top level. It will also display their children, as determined by the <code>depth</code> and <code>all</code> parameters.</td>
</tr>
<tr>
<td>depth</td>
<td>No</td>
<td>(None)</td>
<td>The number of levels of child pages to display. For example, if the value is 2, the macro will display 2 levels of child pages.</td>
</tr>
<tr>
<td>all</td>
<td>No</td>
<td>false</td>
<td>If true, Confluence will display all levels of child pages. This setting will override the <code>depth</code> setting.</td>
</tr>
</tbody>
</table>

Example:

```
{children:reverse=true|sort=creation|style=h4|page=Home|excerpt=true|first=99|depth=2|all=true}
```

**Code Block macro**

Displays code in your document with the appropriate syntax highlighting.

**Macro name:** code

**Macro body:** Accepts plain text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>Adds a title to the code macro box.</td>
</tr>
</tbody>
</table>
| theme       | No | Confluence  | Specifies the colour scheme used for displaying your code. Many of these themes are based on the default colour schemes of popular integrated development environments (IDEs). The default theme is Confluence (also known as Default), which is typically black and coloured text on a blank background. Available themes:
- DJango
- Emacs
- FadeToGrey
- Midnight
- RDark
- Eclipse
- Confluence (same as default) |

<p>| linenumbers | No | false | If true, a line number will be shown to the left of each line of code. Numbering is incremented by 1. If false, no line numbers are shown. |</p>
<table>
<thead>
<tr>
<th><strong>language</strong></th>
<th><strong>No</strong></th>
<th><strong>java</strong></th>
<th>Specifies the language (or environment) for syntax highlighting.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>• (none) — that is, no syntax highlighting</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• actionscript3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• bash</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• csharp — that is, C#</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• coldfusion</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• cpp — that is, C++</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• css</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• delphi</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• diff</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• erlang</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• groovy</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• java</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• javafx</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• javascript</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• perl</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• php</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• powershell</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• python</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• ruby</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• scala</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• sql</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• vb — that is, Visual Basic</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• html/xml</td>
</tr>
<tr>
<td><strong>firstline</strong></td>
<td><strong>No</strong></td>
<td><strong>1</strong></td>
<td>When linenumbers is true, this value defines the number of the first line of code.</td>
</tr>
<tr>
<td><strong>collapse</strong></td>
<td><strong>No</strong></td>
<td><strong>false</strong></td>
<td>If true, the code macro's content will be collapsed upon visiting or refreshing the Confluence page. Clicking the 'expand source' link allows you to view the content. If false, the code macro's content is always displayed in full.</td>
</tr>
</tbody>
</table>

**Example:**
Column macro

Used with the Section macro to define columns on a page. See Working with page layouts and columns and sections.

**Macro name:** column

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>The width of the column. Can be specified either in pixels (for example, 400 px) or as a percentage of the available page width (for example, 50%).</td>
</tr>
</tbody>
</table>

**Example:**

```{column:width=100px}
This is the content of *column 1*.
{column}
```

Content by Label macro

Displays a list of content associated with specific labels.

**Macro name:** contentbylabel

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>spaces</td>
<td>No</td>
<td>@all</td>
<td></td>
</tr>
</tbody>
</table>
Filters the results by space. The macro will display only the pages and other content types which belong to the space(s) you specify here.

You can specify one or more space keys, separated by a comma or a space.

- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADS
PACE you will get only content which is not in the BADSPACE.

- To indicate that the results **must** come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOOD
SPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>author</td>
<td>No</td>
<td>(None)</td>
<td>Filters the results by author. The macro will display only the pages and other content types which are written or updated by the author(s) you specify here. You can specify one or more authors, separated by a comma.</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>Adds a heading to the list.</td>
</tr>
<tr>
<td>showLabels</td>
<td>No</td>
<td>true</td>
<td>Determines whether to display the matching labels in the list of results.</td>
</tr>
<tr>
<td>reverse</td>
<td>No</td>
<td>false</td>
<td>Use this parameter in conjunction with the sort parameter. Set reverse=true to change the sort from ascending to descending. This parameter is ignored if the sort parameter is not specified.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Current Value</td>
<td>New Value</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>---------------</td>
<td>-----------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| sort      | No            | modified  | Determines how the results are sorted. To change the sort order from ascending to descending, use the `reverse` parameter described above. If this parameter is not specified, the sort order defaults to descending order based on the last modification date. Values:  
- **title** — Sort alphabetically by title.  
- **creation** — Sort by the date on which the content was added.  
- **modified** — Sort by the date on which the content was last updated. |
| max       | No            | 15        | Determines the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied. |
| excerpt   | No            | false     | If this parameter is set to `true`, the macro displays an excerpt from each page listed in the results. Note that you must define the excerpts on each of those pages, by adding the Excerpt macro to each page. If a particular page does not have an excerpt defined, then the Content by Label macro will not attempt to show an excerpt for that page. The Content by Label macro will show only the first few lines of the excerpt for each page. |
| labels       | Yes          | (None) | Use this parameter to filter the results by label. The macro will display only the pages and other content types which are tagged with the label(s) you specify here. See also the operator parameter.

You can specify one or more label values, separated by a comma or a space.

- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of `-badpage` you will get only content which is not labelled with 'badpage'.
- To indicate that the results **must** match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of `+superpage,+goodpage` you will get only content which has at least two labels, being 'superpage' and 'goodpage'. |
<p>| showSpace    | No           | true   | Determines whether to display the spaces in the list of results. |</p>
<table>
<thead>
<tr>
<th>type</th>
<th>No</th>
<th>All</th>
</tr>
</thead>
</table>

Filters the results by content type. The macro will display only the content of the type you specify here.

You can specify one or more types, separated by a comma or a space.

To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of `-blogpost` you will get pages and all other content except for blog posts.

Available values:
- page — *pages*
- blogpost or news — blog posts, also known as news items
- attachment — attachments
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>Yes</td>
<td>(None)</td>
<td>The Confluence username for the person whose content you wish to display</td>
</tr>
</tbody>
</table>

Example:

```{contentbylabel:spaces=@personal,@self|author=admin,smaddox|title=My labelled pages|showLabels=false|reverse=true|sort=creation|max=10|excerpt=true|labels=chocolate,cake|showSpace=false|type=page|operator=AND}```

Content by User macro

Displays a list of the content items that have been created by a specified Confluence user.

**Macro name:** content-by-user

**Macro body:** None.
Contributors macro

Displays a list of Confluence users who have made a contribution of some type to a page.

**Macro name:** contributors

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>limit</td>
<td>No</td>
<td>(None)</td>
<td>Limits the number of contributors displayed in the list.</td>
</tr>
</tbody>
</table>
| spaces         | No       | Current space | Specifies the space key of the Confluence space to search. Space keys are case sensitive. Special values:  
|                |          |         | • @global — All global spaces.  
|                |          |         | • @personal — All personal spaces.  
| reverse        | No       | false   | Reverses the order of contributors in the list. Must be used in conjunction with the order parameter. |

{content-by-user:jsmith}
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>scope</td>
<td>No</td>
<td>The specified page only</td>
<td>Specifies additional pages to include when generating the list of contributors. Available values: - <strong>children</strong> – only the child pages of the specified page. - <strong>descendants</strong> – all descendants of the specified page.</td>
</tr>
<tr>
<td>labels</td>
<td>No</td>
<td>(None)</td>
<td>Limits the list of contributors to those who created the specified labels on a page. You can specify one or more labels, separated by commas.</td>
</tr>
<tr>
<td>showPages</td>
<td>No</td>
<td>false</td>
<td>If the value is true, the macro will display a list of the pages used to generate the list of contributors.</td>
</tr>
<tr>
<td>noneFoundMessage</td>
<td>No</td>
<td>&quot;No contributors found for:&quot; (and a summary of selected parameter values)</td>
<td>Any message given here will override the default message that is displayed when no contributors are found.</td>
</tr>
<tr>
<td>showCount</td>
<td>No</td>
<td>false</td>
<td>Determines whether the macro will show the number of times each person made a contribution.</td>
</tr>
<tr>
<td>contentType</td>
<td>No</td>
<td>Both pages and blog posts</td>
<td>Restricts the content type that the macro will use when generating the list of contributors. Available values: - <strong>pages</strong> – pages - <strong>blogposts</strong> – blog posts.</td>
</tr>
<tr>
<td>Include</td>
<td>No</td>
<td>Authors</td>
<td></td>
</tr>
<tr>
<td>---------</td>
<td>----</td>
<td>---------</td>
<td></td>
</tr>
</tbody>
</table>
| Filters by either the type of contribution made to a page (and optionally its descendant pages), or the watches on the page. Contribution types are:  
- authors - includes people who created or have edited the page(s)  
- comments - includes people who have added comments to the page(s)  
- labels - includes people who have added labels to the page(s)  
- watches - includes people who are watching the page(s).  
You can specify one or more contribution types, separated by commas. |

<table>
<thead>
<tr>
<th>Mode</th>
<th>No</th>
<th>Inline</th>
</tr>
</thead>
</table>
| Determines how the list of contributors is formatted:  
- inline — a comma-separated list  
- list — a bullet list. |

<table>
<thead>
<tr>
<th>ShowAnonymous</th>
<th>No</th>
<th>False</th>
</tr>
</thead>
<tbody>
<tr>
<td>Determines whether to include those who contributed anonymously to a page.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Order</th>
<th>No</th>
<th>Count</th>
</tr>
</thead>
</table>
| Specifies the criteria used to sort contributors. Sort criteria are:  
- count — sorts the names based on the total number of contributions to the page(s)  
- name — sorts the names into alphabetical order  
- update — sorts the names by the date of their last contribution to the page(s). |
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>page</td>
<td>No</td>
<td></td>
<td>The current page. Specifies the page to use when generating the list of contributors. If page and spaces are left blank, the current page is assumed.</td>
</tr>
<tr>
<td>showLastTime</td>
<td>No</td>
<td>false</td>
<td>Determines whether to show the last time each person made a contribution.</td>
</tr>
<tr>
<td>publishDate</td>
<td>No</td>
<td>(None)</td>
<td>Specifies the publication date for a blog post. The date format required is: YYYY/MM/DD.</td>
</tr>
</tbody>
</table>

**Example:**

This example specifies a content type of blog posts:

```{contributors:limit=10|spaces=ds,@personal|reverse=true|labels=chocolate, cake|showPages=true|noneFoundMessage=Oh dear, no contributors found|showCount=true|contentType=blogposts|include=authors, comments, labels, watches|mode=list|showAnonymous=true|order=update|showLastTime=true|publishDate=2012/06/30}```

This example specifies a content type of pages:

```{contributors:limit=10|spaces=ds,@personal|reverse=true|scope=descendants|labels=chocolate, cake|showPages=true|noneFoundMessage=Oh dear, no contributors found|showCount=true|contentType=pages|include=authors, comments, labels, watches|mode=list|showAnonymous=true|order=update|page=ds:Advanced Topics|showLastTime=true}```

**Contributors Summary macro**

Displays a table of contribution-based statistics for a set of pages.

**Macro name:** contributors-summary

**Macro body:** None.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>limit</code></td>
<td>No</td>
<td>(None)</td>
<td>Limits the number of contributors or pages displayed in the table.</td>
</tr>
</tbody>
</table>
| `spaces`  | No      | Current space | Specifies the space key of the Confluence space to search. Space keys are case sensitive. Special values:  
- `@global` — All global spaces.  
- `@personal` — All personal spaces.  
- `@all` — All spaces in the Confluence site. You can specify one or more space keys or special values, separated by commas. If no page and labels are specified, all pages from the specified set of spaces are included. |
| `reverse` | No      | `false` | Reverses the order of items in the table. Must be used in conjunction with the `order` parameter. |
| `showAnonymous` | No | `false` | Determines whether to include those who contributed anonymously to a page. |
| `scope`   | No      | The specified page only | Specifies additional pages to include when generating the list of contributors. Available values:  
- `children` — only the child pages of the specified page.  
- `descendants` — all descendants of the specified page. |
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **order** | No | Edits | Sets the criterion used for sorting items in the table. **Available values:**
- *edits* - sorts items in the table based on the total number of edits made, either by a contributor or to a page.
- *name* - sorts items in the table in alphabetical order, either by contributor or page name.
- *editTime* - sorts items in the table based on when the contributor last edited a page (or a specified set of pages) or when the page was last edited.
- *update* - sorts items in the table based on when the contributor last made any contribution to a page (or a specified set of pages) or when the page last had any contribution made to it. |
| **page** | No | The current page | A page title. Specifies the page to use when generating the list of contributors. If *page* and *spaces* are left blank, the current page is assumed. |
| **labels** | No | (None) | Limits contribution-based statistics to the specified labels only. You can specify one or more labels, separated by commas. |
| **columns** | No | edits,comments,labels | Determines the columns that should appear in the table. The statistics or type of information presented depends on the *groupby* parameter. |
Available values:

- **edits** – the number of times each contributor has edited the page(s) or the number of edits made to each page.
- **edited** – a list of the pages edited by each contributor or a list of contributors who have edited each page.
- **comments** – the number of times each contributor has added comments to the page(s) or the number of comments on each page.
- **commented** – a list of pages to which each contributor has added comments or a list of contributors who have commented on each page.
- **labels** – the number of times each contributor has added labels to the page(s) or the number of labels on each page.
- **labeled** – a list of pages to which each contributor has added labels or a list of contributors who have added a label to each page.
- **labellist** – a list of labels either added by each contributor or on each page.
- **watches** – the number of pages being watched by each contributor/person or the number of contributors/people watching each page.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>watching</td>
<td></td>
<td>A list of pages being watched by each contributor/person or a list of contributors/people watching each page.</td>
</tr>
<tr>
<td>lastupdate</td>
<td></td>
<td>The last time each contributor made an update or when each page was last updated. Valid updates can include edits, comments or label modifications to a page.</td>
</tr>
<tr>
<td>You can specify one or more columns, separated by commas.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>groupby</td>
<td>No</td>
<td>Specifies the basis for grouping contribution-based statistics:</td>
</tr>
<tr>
<td>contributors</td>
<td></td>
<td>- contributors - group by the people who have contributed.</td>
</tr>
<tr>
<td>pages</td>
<td></td>
<td>- pages - group by the pages used to find the contributors.</td>
</tr>
<tr>
<td>contentType</td>
<td>No</td>
<td>Both pages and blog posts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Restricts the content type that the macro will use when generating the list of contributors.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- pages - pages</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- blogposts - blog posts</td>
</tr>
<tr>
<td>showZeroCounts</td>
<td>No</td>
<td>false</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Determines whether contributors or pages are included for which the calculated statistic is zero.</td>
</tr>
<tr>
<td>publishDate</td>
<td>No</td>
<td>(None)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Specifies the publication date for a blog post. The date format required is: YYYY/MM/DD.</td>
</tr>
</tbody>
</table>

**Example:**
This example specifies a content type of blog posts:

```
{contributors-summary:limit=10|spaces=ds,@personal|reverse=true|showAnonymous=true|order=update|labels=chocolate,cake|columns=edits,comments,labels,lastupdate|groupby=pages|contentType=blogposts|showZeroCounts=true|publishDate=2012/06/07}
```

This example specifies a content type of pages:

```
{contributors-summary:limit=10|spaces=ds,@personal|reverse=true|showAnonymous=true|scope=descendants|order=update|page=ds:Advanced Topics|labels=chocolate,cake|columns=edits,comments,labels,lastupdate|groupby=pages|contentType=pages|showZeroCounts=true}
```

**Expand macro**

Displays an expandable/collapsible section of text.

**Macro name:** expand

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>No</td>
<td>Click here to expand...</td>
<td>Text that will be displayed on the line that people can click to expand the hidden text.</td>
</tr>
</tbody>
</table>

(Unnamed in wiki markup)

**Example:**

```
{expand:This is my message}
This text is _hidden_ until you expand it.
{expand}
```

**Info macro**

Displays a block of text in a blue highlight box.

**Macro name:** info

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>

Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>icon</td>
<td>No</td>
<td>true</td>
<td>Determines whether to display the icon in the title bar of the information box.</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the information box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
</tbody>
</table>

**Example:**

```
{info:title=This is my title|icon=false}
This is _important_ information.
{info}
```

**Section macro**

Used with the Column macro to define columns on a page. See Working with page layouts and columns and sections.

**Macro name:** section

**Macro body:** Rich text, consisting of one or more Column macros.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>border</td>
<td>No</td>
<td>False</td>
<td>If the value is true, the columns in this section will have a dashed border.</td>
</tr>
</tbody>
</table>

**Example:**

```
{section:border=true}
{column:width=100px}
This is the content of *column 1*.
{column}
{column}
This is the content of *column 2*.
{column}
{section}
```

**Table of Contents macro**

Displays a table of contents from your page headings.

**Macro name:** toc
**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>printable</td>
<td>No</td>
<td>true</td>
<td>If you set this parameter to false, the table of contents will not be visible when you print the page.</td>
</tr>
</tbody>
</table>
| style          | No       | none    | The style of bullet point for each list item. You can use any valid CSS style. For example:  
- **none** — No list style is displayed.  
- **circle** — The list style is a circle.  
- **disc** — The list style is a filled circle. This is the typical bullet list, and is the one we are using in this example list.  
- **square** — The list style is a square.  
- **decimal** — The list is numbered (1, 2, 3, 4, 5).  
- **lower-alpha** — The list style is lower case, alphabetised (a, b, c, d, e).  
- **lower-roman** — The list style is lower-case Roman numerals (i, ii, iii, iv, v, vi).  
- **upper-roman** — The list style is upper-case Roman numerals (I, II, III, IV, V, VI). |
<p>| maxLevel       | No       | 7       | Maximum heading level. Use this parameter to select the highest heading level to include. For example, a value of 2 will list h1 and h2 levels, but will not include h3 and below. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>indent</td>
<td>No</td>
<td>(None)</td>
<td>This parameter applies to vertical lists only (type = list). Use this parameter to indent the list items according to CSS quantities. For example, a value of 10px will successively indent list heading groups by 10 pixels. Level 1 headings will be indented 10px, and level 2 headings by an additional 10px, and so on.</td>
</tr>
<tr>
<td>minLevel</td>
<td>No</td>
<td>1</td>
<td>Minimum heading level. The heading level at which the table of contents will start. For example, a value of 2 will list h2, h3, and h4 headings, but will not include h1 headings.</td>
</tr>
<tr>
<td>class</td>
<td>No</td>
<td>(None)</td>
<td>A CSS class name. If you have a custom style sheet, you can use this parameter to output the table of contents with the specified class attribute.</td>
</tr>
<tr>
<td>exclude</td>
<td>No</td>
<td>(None)</td>
<td>Specifies the headings to exclude by pattern matching. The value must be a regular expression. If this parameter is specified, the table of contents will include only the headings that match the regular expression. Example: .* .[1/2] See Sun's Regex documentation for examples of constructing regular expression strings.</td>
</tr>
<tr>
<td>parameter</td>
<td>required</td>
<td>value</td>
<td>description</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
<td>-------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| type      | No       | list  | Defines the overall format of the table of contents. Available values:  
- list – displays the table of contents in a vertical list.  
- flat – displays a horizontal series of links. For example: [Heading 1] [Heading 2] [Heading 3]. |
| outline   | No       | false | A value of true will apply outline numbering to the headings as displayed in the table of contents. For example: 1.1, 1.2, 1.3. |
| separator | No       | brackets | This parameter applies to flat lists only (type = flat). Use this parameter to style the display of a flat list. Available values:  
- brackets – Each item is enclosed by square brackets: [ ].  
- braces – Each item is enclosed by braces: { }.  
- parens – Each item is enclosed by parentheses: ( ).  
- pipe – The items are separated by a pipe: |  
- anything – The items are separated by the value you enter. You can enter any text as a separator, for example ***. If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters. |
| include | No | (None) | Specifies the headings to include by pattern matching. The value must be a regular expression. If this parameter is specified, the table of contents will ignore any headings that do not match the regular expression. Example: .*
\.[1/2] |
| --- | --- | --- | --- |

### Example:

This example shows a list-type table of contents.

```markdown
{toc:printable=true|style=square|maxLevel=2|indent=5px|minLevel=2|class=bigpink|exclude=[1/2]|type=list|outline=true|include=.*)
```

This example shows a flat table of contents.

```markdown
{toc:printable=true|maxLevel=2|minLevel=2|class=bigpink|exclude=[1/2]|type=flat|outline=true|separator=pipe|include=.*)
```

### Notes

- The 'Required' column indicates whether the parameter is required on data entry. If the parameter is not supplied, Confluence will insert default values as indicated in the 'Default' column.
- Wiki markup is not case sensitive. For example, you can specify a parameter name of `sortBy` or `sortby`.
- For a few macros in wiki markup, the default parameter may be unnamed. The examples on this page show the macros concerned. In such cases, the unnamed parameter is always the first parameter specified.
- **A request from the Atlassian technical writers about comments and feedback:** We would like to distinguish between the documentation of the current solution (this page) and any discussion of the solution and possible changes to Confluence wiki markup and/or the XHTML-based storage format. If you have a suggestion for, or correction of, this documentation, please add your suggestion to this page. If you have feedback on the Confluence markup, storage format and related functionality, please add your suggestion to the page titled [Confluence 4 Editor - Customer Feedback](https://confluence.atlassian.com/pages/createPage?title=Confluence 4 Editor - Customer Feedback). Thanks.

### Wiki Markup Examples for Chart Macro

This page is an extension of [Confluence Wiki Markup for Macros](https://confluence.atlassian.com/pages/createPage?title=Confluence Wiki Markup for Macros), which contains wiki markup examples for all Confluence macros. The Chart macro is a special case, because it offers so many options via parameters and chart types. This page offers additional examples for the Chart macro.

### Pie chart
Here is a simple example of a pie chart.

Wiki markup

```
{chart:type=pie|title=Fish Sold}
|| Fish Type || 2004 || 2005 ||
|| Herring | 9,500 | 8,300 |
|| Salmon | 2,900 | 4,200 |
|| Tuna | 1,500 | 1,500 |
{chart}
```

Resulting chart

![Fish Sold Pie Chart](chart_image)

Bar chart

Here is a simple example of a bar chart.

Wiki markup

```
{chart:type=bar|title=Fish Sold}
|| Fish Type || 2004 || 2005 ||
|| Herring | 9,500 | 8,300 |
|| Salmon | 2,900 | 4,200 |
|| Tuna | 1,500 | 1,500 |
{chart}
```

Resulting chart

![Fish Sold Bar Chart](chart_image)
**Time series chart**

Here is an example of a time series chart.

Wiki markup

```
{chart:type=timeSeries|dateFormat=MM/yyyy|timePeriod=Month|
 dataOrientation=vertical|rangeAxisLowerBound=0|domainaxisrotateticklabel=true}

|| Month || Revenue ||
|---|---|---|
| 1/2005 | 31.8 |
| 2/2005 | 41.8 |
| 3/2005 | 51.3 |
| 4/2005 | 33.8 |
| 5/2005 | 27.6 |
| 6/2005 | 49.8 |
| 7/2005 | 51.8 |
| 8/2005 | 77.3 |
| 9/2005 | 73.8 |
| 10/2005 | 97.6 |
| 11/2005 | 101.2 |
| 12/2005 | 113.7 |

|| Month || Expenses ||
|---|---|---|
| 1/2005 | 41.1 |
| 2/2005 | 43.8 |
| 3/2005 | 45.3 |
| 4/2005 | 45.0 |
| 5/2005 | 44.6 |
| 6/2005 | 43.8 |
| 7/2005 | 51.8 |
| 8/2005 | 52.3 |
| 9/2005 | 53.8 |
| 10/2005 | 55.6 |
| 11/2005 | 61.2 |
| 12/2005 | 63.7 |
```

Resulting chart
**XY line chart**

Here is an example of an XY line chart.

Wiki markup

```
{chart:type=xyline}
|| | | 12 | | 14 | | 23 | |
| Revenue | 41.1 | 31.8 | 12.4 |
| Expense | 31.1 | 41.8 | 43.6 |
{chart}
```

**Resulting chart**

**XY bar chart**

Here is an example of an XY bar chart.

Wiki markup
Here is an example of an XY area chart.

Wiki markup

```
{chart:type=xyarea}
|| || 12 || 14 || 23 ||
| Revenue | 41.1 | 31.8 | 12.4 |
| Expense  | 31.1 | 41.8 | 43.6 |
(chart)
```
Area chart

Here are two examples of area charts.

Wiki markup for area chart 1

```wiki
{chart:type=area|dataDisplay=true|legend=true|width=300|height=300|opacity=50}
|| Satisfaction || 2002 || 2003 || 2004 ||
| Very satisfied | 20 | 23 | 34 |
| Satisfied | 40 | 34 | 23 |
| Disatisfied | 25 | 26 | 25 |
| Very dissatisfied | 15 | 17 | 18 |
{chart}
```

Resulting area chart 1

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
<td>34</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Disatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>
### Wiki markup for area chart 2

```wiki
{chart:type=area|dataDisplay=true|legend=true|width=300|height=300|stacked=true}
| Satisfaction | 2002 | 2003 | 2004 |
| Very satisfied | 12 | 23 | 31 |
| Satisfied | 1 | 34 | 36 |
| Dissatisfied | 4 | 6 | 22 |
| Very dissatisfied | 2 | 7 | 12 |
```

#### Resulting area chart 2

![Area Chart](chart)

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>12</td>
<td>23</td>
<td>31</td>
</tr>
<tr>
<td>Satisfied</td>
<td>1</td>
<td>34</td>
<td>36</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>4</td>
<td>6</td>
<td>22</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>2</td>
<td>7</td>
<td>12</td>
</tr>
</tbody>
</table>

### Working with Confluence Gadgets

This section introduces the concept of gadgets in Confluence and provides an outline on how to use gadgets in Confluence and other web applications.
Introduction to Gadgets in Confluence

A gadget is a small object (i.e. a piece of functionality) offering dynamic content that can be placed into the page of:

- An Atlassian application's website, such as a Confluence page or blog post or a JIRA 4.0+ dashboard.
- A third-party application's website, such as iGoogle or Gmail. (But see the limitations on using Confluence gadgets in other applications.)

Gadgets allow interactions between Confluence and other compatible websites. Confluence interacts with gadgets that support the OpenSocial specification.

For more information about Atlassian gadgets, please refer to the introduction to Atlassian gadgets and the big list of Atlassian gadgets.

Using Gadgets in Confluence

You can place any gadget that complies with the OpenSocial specification from an external source, such as iGoogle or other Atlassian applications such as JIRA 4.0+, onto a Confluence page or blog post. To add a gadget to a page, use the Confluence macro browser to add a Gadget macro.

See the page on adding JIRA gadgets to a Confluence page.

Adding Confluence Gadgets in Other Applications

You can add a Confluence gadget to a JIRA dashboard or another Confluence site. In principle, you can also put a Confluence gadget on any other OpenSocial-compliant website such as iGoogle or Gmail. See the limitations on using Confluence gadgets in other applications.

Adding a Confluence Gadget to JIRA

See Adding a Confluence Gadget to a JIRA Dashboard.

Adding a Confluence Gadget to Non-Atlassian Web Applications

For instructions on how to add Confluence gadgets in another compatible non-Atlassian web application or container, refer to Configuring Confluence Gadgets for Use in Other Applications.

Confluence Gadgets

The Confluence Gadgets topic explains the purpose of the ‘Confluence Gadgets’ window and provides information about the gadgets which are bundled with Confluence.

Related Topics

Gadget Macro
Configuring Confluence Gadgets for Use in Other Applications
Adding a Confluence Gadget to a JIRA Dashboard
Confluence Gadgets
Configuring OAuth
All Atlassian gadgets

External Gadgets

Adding a Confluence Gadget to a JIRA Dashboard

JIRA 4.0 is the first major Atlassian application that can incorporate OpenSocial-compliant gadgets, such as Confluence gadgets onto its dashboard. This page explains how to add a Confluence gadget to the dashboard of a JIRA 4.0+ installation.

To add a Confluence gadget to a JIRA dashboard, complete the sections below in order.

On this page:

- Create an Application Link Between Confluence and JIRA
- Finding a Confluence Gadget's URL
- Adding a Confluence Gadget to a JIRA server's Gadgets Directory
- Adding a Confluence Gadget to the JIRA Dashboard
- Related Topics

Create an Application Link Between Confluence and JIRA

If your Confluence gadgets need to access user-restricted Confluence data, then your Confluence administrator must first establish an Application Link between your Confluence site and the JIRA site. For more information about configuring an Application Link between Confluence and other web applications, refer to Configuring OAuth Authentication for an Application Link.

If you only need to access anonymously accessible Confluence data, then you can proceed to Finding a Confluence Gadget's URL, below.

Finding a Confluence Gadget's URL

The Confluence gadget's URL is the gadget's XML specification file. These URLs look something like this:

```
http://example.com/my-gadget-location/my-gadget.xml
```

To find a Confluence gadget's URL:

1. Choose Browse > Confluence Gadgets. The 'Confluence Gadgets' window will open. The 'Confluence Gadgets' window displays a list of available Confluence gadgets in your Confluence installation, as shown in the screenshot below.

   ![Screenshot: Finding a gadget's URL](image)

   By default, Confluence only includes a few gadgets. However, if your Confluence administrator has installed more Confluence gadgets (typically as Confluence plugins), these will also appear in this list. If a scrollbar is available, use it to find the gadget you want.

2. After finding your gadget, use the Gadget URL link to copy the gadget's URL to your clipboard. Many operating systems and browsers allow you to do this by right-clicking the Gadget URL link and copying it using the context menu.
Adding a Confluence Gadget to a JIRA server’s Gadgets Directory

To add a Confluence Gadget to the Gadgets Directory in JIRA:

1. Go to the dashboard by clicking Dashboard at the top left of the screen.
2. The dashboard will appear. Click Add Gadget.
3. The 'Add Gadget' screen appears, showing the list of gadgets in your directory. See screenshot 1 below.
   Click Add Gadget to Directory.
   You will only see this button if you have administrator permissions for your dashboard.
4. The 'Add Gadget to Directory' screen appears. See screenshot 2 below. Paste the gadget URL (which you copied to your clipboard above) into the text box.
5. Click Add Gadget.
6. The gadget appears in your gadget directory. (It will be highlighted for a short time, so that you can see it easily.)

Screenshot 1: Gadget directory with 'Add Gadget to Directory' button
Adding a Confluence Gadget to the JIRA Dashboard

In the procedure below, 'your Atlassian dashboard' and 'your Atlassian application' refers to the JIRA Dashboard and application, respectively.

You can add a gadget from the directory of gadgets that are available to your Atlassian application.

To add a gadget to your Atlassian dashboard,
1. Go to the dashboard by clicking the ‘Dashboard’ link or the ‘Home’ link at the top left of the screen.
2. The dashboard will appear, looking something like screenshot 1 below. Click ‘Add Gadget’.
3. The 'Add Gadget' screen will display a list of available gadgets in your gadget directory, as shown in screenshot 2 below. Find the gadget you want, using one or more of the following tools:
   - Use the scroll bar on the right to move up and down the list of gadgets.
   - Select a category in the left-hand panel to display only gadgets in that category.
   - Start typing a key word for your gadget in the ‘Search’ textbox. The list of gadgets will change as you type, showing only gadgets that match your search term.
4. When you have found the gadget you want, click the ‘Add it Now’ button to add the gadget to your dashboard.

`Screenshot 1: An Atlassian dashboard`
Adding a Gadget to the Directory of Available Gadgets

You need to have administrator privileges to add a gadget to the list of available gadgets. If you have permission to add gadgets to and remove gadgets from the directory itself, you will see the 'Add Gadget to Directory' and 'Remove' buttons on the 'Add Gadget' screen. Please refer to the Gadgets and Dashboards Administration Guide.

Related Topics

All Atlassian gadgets

Configuring Confluence Gadgets for Use in Other Applications

This page tells you how to add a Confluence gadget to another (external) application. The instructions and examples given in this topic focus on adding and using Confluence Gadgets in other web applications.

Atlassian support does not cover gadgets on external sites like iGoogle and Gmail

In principle, you should be able to add Atlassian gadgets to iGoogle, Gmail and other external sites that support OpenSocial gadgets. However, these external integrations are experimental at this stage and we have encountered problems with them. Please do have fun playing around with them, but be aware that Atlassian does not support the use of Atlassian gadgets on iGoogle, Gmail or other external web sites. See the detailed section on gadget limitations.

Gadgets that display information from Atlassian applications, such as Confluence, should be able to run on iGoogle, Gmail and other web applications that provide OpenSocial containers. Below are specific instructions for iGoogle and Gmail. You can experiment by adding a Confluence gadget to other web sites and applications, such as a Ning community like The Content Wrangler.

On this page:

- Overview of Adding a Confluence Gadget to Another Web Application
Overview of Adding a Confluence Gadget to Another Web Application

The exact procedure for adding a Confluence gadget depends on the application where you want to add the gadget. The basic steps are the same:

1. Find the Confluence gadget's URL, i.e. the URL for the gadget's XML specification file.
2. Ensure one of the following two mandatory (typically one-off) procedures have been conducted:
   - An OAuth relationship between Confluence (as the 'service provider') and the other web application (as the 'consumer') has been established. Refer to Configuring OAuth for more information about OAuth and instructions on establishing these relationships.
   - A Trusted Applications relationship between Confluence and JIRA has been established. Refer to Configuring Trusted Applications in the JIRA documentation for more information about establishing these relationships.
3. Follow the procedure provided by the external web application where you want to add the Confluence gadget.

Finding a Confluence Gadget's URL

The Confluence gadget's URL is the gadget's XML specification file. These URLs look something like this:

```
http://example.com/my-gadget-location/my-gadget.xml
```

To find a Confluence gadget's URL:

1. Choose Browse > Confluence Gadgets. The 'Confluence Gadgets' window will open. The 'Confluence Gadgets' window displays a list of available Confluence gadgets in your Confluence installation, as shown in the screenshot below. By default, Confluence only includes a few gadgets. However, if your Confluence administrator has installed more Confluence gadgets (typically as Confluence plugins), these will also appear in this list. If a scrollbar is available, use it to find the gadget you want.
2. After finding your gadget, use the Gadget URL link to copy the gadget's URL to your clipboard. Many operating systems and browsers allow you to do this by right-clicking the Gadget URL link and copying it using the context menu.

Screenshot: Finding a gadget's URL
Adding an Atlassian Gadget to iGoogle

You can customise your iGoogle home page by adding gadgets and moving them around on the page.

To add an Atlassian gadget to your iGoogle page:

1. First find the gadget's URL as described above.
2. Go to iGoogle and log in if you have a username and password.
3. Click Add stuff near the top right of the iGoogle page.
4. The Google gadget directory will appear, showing a list of available gadgets. Click Add feed or gadget in the right-hand panel.

   ![Add feed or gadget](image)

5. A text box will open, as shown above. Enter or paste the gadget's URL from your clipboard into the textbox and click Add.
6. Go back to your iGoogle home page. The gadget will appear on your iGoogle page.

Adding an Atlassian Gadget to Gmail

You can add gadgets to the left-hand panel of your Gmail page.

To add an Atlassian gadget to your Gmail page:

1. First find the gadget's URL as described above.
2. Log in to Gmail.
3. Click Settings near the top right of the Gmail page. The Gmail settings page will appear.
4. Click the Labs tab. The Gmail Labs page will appear. This is a laboratory area or testing ground where Google allows you to use experimental features in Gmail.
5. Scroll down to find the feature called 'Add any gadget by URL'.
6. Select the Enable option, as shown here:
7. Click **Save Changes**.

8. A new **Gadgets** tab will appear on your 'Settings' page. Click the **Gadgets** tab. The 'Gadgets' page will appear, as shown in the screenshot below.

9. Enter or paste your gadget's URL into the **Add a gadget by its URL** box, then click **Add**.

10. The gadget will appear in the left-hand panel of your Gmail page, as shown in the screenshot below.

![Screenshot: Adding a gadget to Gmail](image)

**Limitations and Support**

⚠️ **Atlassian support does not cover gadgets on external sites like iGoogle and Gmail**

In principle, you should be able to add Atlassian gadgets to iGoogle, Gmail and other external sites that support OpenSocial gadgets. However, these external integrations are experimental at this stage and we have encountered problems with them. Please do have fun playing around with them, but be aware that Atlassian does not support the use of Atlassian gadgets on iGoogle, Gmail or other external web sites. See the detailed section on **gadget limitations**.

**Related Topics**
The big list of Atlassian gadgets

Confluence Gadgets

This page describes the purpose of the 'Confluence Gadgets' dialog and how to access it, and provides information about the gadgets that are bundled with Confluence.

Gadgets:

- Interact with and provide access to data in your Confluence installation
- Can be used externally such as on a JIRA 4+ server's dashboard, a page or blog post of another Confluence server, or any compatible page on a web site that accepts gadgets, such as iGoogle. (But see the limitations on using Confluence gadgets in other applications.)

On this page:

- The Confluence Gadgets Dialog
- Confluence Gadgets
- Related Topics

The Confluence Gadgets Dialog

The 'Confluence Gadgets' dialog displays a list of all the Confluence gadgets available in your Confluence installation. The Confluence gadgets bundled with Confluence are described below. Any additional Confluence gadgets installed by your Confluence administrator (typically as Confluence plugins), will also appear in this list.

To access the Confluence Gadgets dialog:

- Choose Browse > Confluence Gadgets. The 'Confluence Gadgets' dialog will open.

Refer to Adding a Confluence Gadget to a JIRA Dashboard or Configuring Confluence Gadgets for Use in Other Applications for more information on adding Confluence gadgets to external applications. A Confluence gadget can also be used within the same Confluence installation, by adding it to a page or blog post using the gadget macro.

Screenshot: The Confluence Gadgets dialog
Confluence Gadgets

This following table lists the gadgets which are bundled with Confluence. Click the name of the gadget for more information.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Confluence Page Gadget</td>
<td>The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.</td>
</tr>
<tr>
<td>Activity Stream Gadget</td>
<td>The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your Confluence site.</td>
</tr>
<tr>
<td>Confluence News Gadget</td>
<td>The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs and events at Atlassian.</td>
</tr>
<tr>
<td>Confluence Quicknav Gadget</td>
<td>The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence site. For more information on how to use this feature, refer to the Quick Navigation Aid section of Searching Confluence.</td>
</tr>
</tbody>
</table>

Related Topics

Adding a Confluence Gadget to a JIRA Dashboard
Configuring Confluence Gadgets for Use in Other Applications
Gadget Macro
The big list of Atlassian gadgets

Activity Stream Gadget

The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your Confluence site.

For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

In addition to showing a list of most recently changed content, the activity stream gadget also provides the following features:

- The ability to add comments to pages and blog posts, by clicking the 'add comment' icon at the top-right of an added or edited page or blog post in the activity stream.
- The ability to reply to a comment by clicking the 'add comment' icon at the top-right of a comment in the activity stream.
- Activities are grouped by separate date.
- An RSS feed link to its content in the top-right corner of the gadget.

Screenshot: Adding a Comment in the Activity Stream Gadget
Activity Stream Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Yes</td>
<td>None</td>
<td>Adds a title to the top of the Activity Stream.</td>
</tr>
<tr>
<td>Projects</td>
<td>No</td>
<td>None specified (i.e. display content in all spaces)</td>
<td>Filters the content by space. This gadget will display only the pages etc. which belong to the space(s) you specify here.</td>
</tr>
<tr>
<td>Username</td>
<td>No</td>
<td>None specified (i.e. display content by all users)</td>
<td>Filters the results by user. The macro will display only the pages etc. which were last modified by the user(s) you specify here. You can specify one or more user, separated by a comma or a space.</td>
</tr>
<tr>
<td>Number of Entries</td>
<td>No</td>
<td>10</td>
<td>Specify the maximum number of results to be displayed. A maximum of 10 results will be displayed by default. The maximum value that this property can accept is 100.</td>
</tr>
</tbody>
</table>
**Confluence News Gadget**

The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs and events at Atlassian.

For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

Clicking an item in the Confluence news gadget takes you directly to the selected blog post of the Confluence Product Blogs feed or event details on the events at Atlassian page.

Clicking More news takes you to the Confluence Product Blogs feed page and clicking More events takes you to the events at Atlassian page.

**Screenshot: Using the News Gadget**

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show News?</td>
<td>No</td>
<td>True</td>
<td>Shows a short list of the most recent Confluence Product Blogs.</td>
</tr>
<tr>
<td>Show Events?</td>
<td>No</td>
<td>True</td>
<td>Shows a short list of the most recent events at Atlassian.</td>
</tr>
<tr>
<td>Show Banners?</td>
<td>No</td>
<td>True</td>
<td>Shows any banner advertisements (if available).</td>
</tr>
</tbody>
</table>

**Confluence Page Gadget**

The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.

> For instructions on how to use Confluence gadgets in your applications, please see [Confluence Gadgets](#).

⚠️ **Macros that work with the page gadget**

Please note, not all macros work with the page gadget. Please refer to the [Working Macros](#) section below for more information.

**On this page:**

- [Confluence Page Gadget Properties](#)
- [Working Macros](#)
- [Related Topics](#)

Screenshot: The Confluence page gadget displaying a sample page
Confluence Page Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>No</td>
<td>None</td>
<td>Specify the space that your desired page is located in. Suggestions will display in a dropdown when you start typing. (Note, this property is only used to make searching for pages easier. It is not required.)</td>
</tr>
<tr>
<td>Page</td>
<td>Yes</td>
<td>None</td>
<td>Specify the page that you want to display in your gadget. Suggestions will display in a dropdown when you start typing.</td>
</tr>
<tr>
<td>Feature</td>
<td>Default</td>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------</td>
<td>--------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Show View Link</td>
<td>No</td>
<td>Yes</td>
<td>Select whether to display a link to view the page on your Confluence site. Clicking the link will open the page in Confluence.</td>
</tr>
<tr>
<td>Show Edit Link</td>
<td>No</td>
<td>No</td>
<td>Select whether to display a link to edit the page on your Confluence site. Clicking the link will open the page for editing in Confluence.</td>
</tr>
<tr>
<td>Refresh Interval</td>
<td>No</td>
<td>Never/False</td>
<td>Specify the time interval between each 'refresh' action undertaken by the page gadget. A refresh makes the activity stream gadget reflect any new activity that has been conducted on the Confluence site.</td>
</tr>
</tbody>
</table>

**Working Macros**

The Confluence page gadget will only render a subset of the macros that are used in Confluence correctly. Refer to the table below for the list of macros that work and do not work with the page gadget and known limitations.

> Some of the issues with macros in the page gadget can be worked around, if you are comfortable developing in Confluence. Please see Troubleshooting Macros in the Page Gadget for more information.

### Key:
- ✔️ Works with the page gadget
- ✔️ * Partially works with the page gadget
- ❌ Does not work with the page gadget

<table>
<thead>
<tr>
<th>Macro</th>
<th>Works with page gadget?</th>
<th>Limitations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Stream</td>
<td>❌</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Anchor (within a page)</td>
<td>✔️ *</td>
<td>Opens in a new page</td>
</tr>
<tr>
<td>Attachments</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Blog Posts</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Chart</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Children Display</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Feature</td>
<td>Compatibility</td>
<td>Notes</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Content By Label</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By User</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Excerpt</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Gallery</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Include Page</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Info</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Labels List</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Livesearch</td>
<td>✗</td>
<td>N/A</td>
</tr>
<tr>
<td>Note</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata Summary</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Pagetree Search</td>
<td>✗</td>
<td>N/A</td>
</tr>
<tr>
<td>Pagetree</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Panel</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Quick Nav</td>
<td>✗</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Recently Updated</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>RSS Feed</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Section &amp; Column</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Spaces List</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>✔️ *</td>
<td>Works, however links will be opened in a new browser window when clicked.</td>
</tr>
<tr>
<td>Tasklist</td>
<td>✔️ *</td>
<td>Tasks can be viewed but not added/edited.</td>
</tr>
<tr>
<td>View File (PDF or PPT)</td>
<td>✔️ *</td>
<td>Works, but you may need to refresh the gadget the first time (see CONF-19932).</td>
</tr>
<tr>
<td>Widget Connector</td>
<td>Only works for some content:</td>
<td></td>
</tr>
<tr>
<td>------------------</td>
<td>-------------------------------</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Works:</strong> blip.tv, Episodic, Flickr, Google Calendar, presentations on Google Docs, MySpace Video, Scribd, Skitch.com, SlideRocket, SlideShare, Viddler, Vimeo, YouTube, Dailymotion, Metacafe, FriendFeed, Yahoo Video, Wufoo HTML Form Builder</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Does not work:</strong> FriendFeed, Google Gadgets, Google Video (consumer service discontinued), Twitter, Widgetbox, DabbleDB, BackType</td>
<td></td>
</tr>
</tbody>
</table>

**Related Topics**

- Confluence Gadgets
- Confluence Quicknav Gadget

**Confluence Quicknav Gadget**

The Confluence QuickNav gadget provides the **Quick Navigation Aid** functionality for searching the Confluence site. For more information on how to use this feature, refer to the **Quick Navigation Aid section of Searching Confluence**.

**Screenshot: Using the QuickNav Gadget**

For instructions on how to use Confluence gadgets in your applications, please see [Confluence Gadgets](#).

*Confluence QuickNav Gadget Properties*
Adding JIRA Gadgets to a Confluence Page

This is a summary of the steps required to add a JIRA gadget to a Confluence page:

- If your JIRA site does not allow anonymous access, your JIRA administrator will need to configure JIRA to trust Confluence via Application Links. See the JIRA administrator's guide.
- Your Confluence administrator will need to add the JIRA gadget URL to the list of authorised external gadgets in Confluence. See the Confluence administrator's guide.
- Now you can add the gadget to a wiki page in Confluence using the Macro Browser. See the Confluence user's guide to the Gadget macro.

Note that the Confluence Gadget macro is a specific type of macro which is used to display a gadget in a Confluence page - so once you have configured external gadgets in the Confluence Administration Console, they will appear in the Macro Browser.

Related Topics

All Atlassian gadgets
External Gadgets
Developing Technical Documentation on Confluence Wiki

Welcome! This is a guide to using Confluence wiki for technical documentation. You will find this guide useful if you want to write a technical manual such as a user's guide, administrator's guide, installation guide, and so on.

- Creating your Technical Documentation Space
- Using Templates in Technical Documentation
- Re-using Content in Technical Documentation
- Managing the Life Cycle of your Technical Documentation
- Providing PDF Versions of your Technical Documentation
- Exporting and Printing Technical Documentation
- Essential Confluence Features for Technical Documentation
- Confluence Plugins for Technical Documentation
- Further Reading about Developing Technical Documentation on Confluence

Creating your Technical Documentation Space

This guide is for people who want to develop and publish technical documentation on Confluence wiki. You will find it useful if you want to write a technical manual such as a user's guide, administrator's guide, installation guide, and so on. This page is a quick-start guide to creating a wiki space for technical documentation.
Quick guide to creating a technical documentation space

- Add a space and select the Documentation theme.
- Set the space permissions.
- Change the title and content of the space home page.
- Customise the Documentation theme.
- Create an inclusions library to manage your re-usable content.
- Create the table of contents for your manual or manuals, by adding top-level pages for all the usual sections (user's guide, administrator's guide, and so on).
- Customise your PDF layout and stylesheet, if required.
- Hint: Now that you have a good skeleton for a documentation space, save the space as a template space.

The rest of this page gives more details of the above procedure.

On this page:

- Step 1. Add your Space
- Step 2. Set the Space Permissions
  - A Bit More about Permissions
- Step 3. Customise the Title and Content of the Home Page
- Step 4. Customise the Documentation Theme
  - Example of a Customised Footer
- Step 5. Create an Inclusions Library
  - Examples of Inclusions Libraries
- Step 6. Create the Table of Contents
- Step 7. (Optional) Customise the PDF Layout and Stylesheet
- Step 8. Save your New Space as a Template Space

Step 1. Add your Space

Below is a quick guide to adding a space. See Setting up a New Global Space for a full description.
1. Go to the Confluence dashboard and click the 'Add Space' link located above the list of spaces.

![Add Space](image)

**Hint:** If you cannot see the 'Add Space' link, this means that you do not have permission to add spaces. Please contact your Confluence administrator.

2. The 'Create Space' screen appears. Enter a **space name** and a short, unique **space key**.

3. Leave the **permission** settings as default, or choose to allow only yourself to view or contribute content to this space. You can change these settings later and with more flexible options.

4. Select the 'Documentation Theme'.

5. Click 'OK'.

The home page of your new space will appear. Because you created the space, you are the space administrator. Now you can do some basic configuration, as described in the sections below.

**Step 2. Set the Space Permissions**

Define the space permissions to determine who can do what in your new space.
1. Open the 'Browse' menu and select 'Space Admin'.

2. Click 'Permissions' in the left-hand panel.
3. Confirm your administrator access as prompted.
4. Click 'Edit Permissions'.
5. Set the permissions to suit your needs then click 'Save All'.
   - You can add **groups** and/or individual **users** to the list, then select the permissions for each group or user.
   - You can also set the permissions for **anonymous** users – these are people who have not logged in to the wiki. Anonymous access is available only if enabled for the entire Confluence site.
   - Note that you can change these permissions at any time. You may want to restrict the permissions to specific groups now, and later open the space to more people.

A Bit More about Permissions

Confluence has a robust and granular permissions scheme that you can use to determine who can view, comment on and even update the documentation. There are three levels of permissions in Confluence:

- Global permissions apply across the entire site.
- Space permissions apply to a space.
- Page restrictions allow you to restrict the editing and/or viewing of a specific page. Below we discuss a way of using these in the draft, review and publishing workflow.

**Space permissions** in Confluence are simple yet granular enough to be useful for technical documentation. You can:

- Use the permission levels to control who can create pages in the space, delete pages, create comments, delete comments, administer the space, and so on.
- Grant a permission level to one or more users, and/or to one or more groups, and/or to anonymous users.

**Terminology:**

- 'Anonymous' means people who have not logged in to the wiki.
- The 'confluence-users' group is the default group into which all new users are assigned. Everyone who can log in to Confluence is a member of this group.
For example, you might allow your team full edit and administration rights while others can only add comments. Or you might grant the general public access to your documentation, while only staff members can update it.

For detailed information, see the documentation on:

- Global permissions
- Space permissions
- Page restrictions
- Users and groups

Step 3. Customise the Title and Content of the Home Page

When you created your space, Confluence created a home page with default content and a default title, 'Home'. You will want to change the title and content.
1. Go back to your space home page, by clicking the space name in the breadcrumbs at the top of the screen. In the example below, the space name is 'MyProduct Documentation':

   ![View Space Permissions](image)

2. The space home page appears. By default, the page title is 'Home'.

   ![Home](image)

3. Click 'Edit'.

4. The page opens in edit mode. Change the title to suit your needs.

   ![MyProduct Documentation Home](image)

5. Update the content to suit your needs.  
   *Hint:* If you do not know what to add yet, just add a short description. You can refine the content of the page later. Take a look at an [example of a home page](#).

6. Click 'Save'.

**Step 4. Customise the Documentation Theme**

When you added the space you chose the Documentation theme, which provides a left-hand navigation bar and a good look and feel for technical documentation. If necessary, you can configure the Documentation theme to add your own page header and footer or to customise the default left-hand navigation bar. These customisations affect the online look and feel of your documentation. See [Configuring the Documentation Theme](#) for the full description.
1. Open the 'Browse' menu and select 'Space Admin'.
2. Click 'Themes' in the left-hand panel.
3. If the space is not yet using the Documentation theme, apply the theme now.
4. Click 'Configure theme' in the yellow area of the 'Current Theme' section at the top of the page.

**Current Theme**

The current theme controls the layout and colours of this space.

**Documentation Theme**

This theme is well suited for structured content, such as documentation. It features a table of contents (page tree) on the left, making it easier to see the structure of a space and move from page to page. You can customise the left-hand panel, page header and page footer. This theme supports Firefox, Safari and Internet Explorer 7+.

**Configure theme** - further customise this theme's options

5. The 'Documentation Theme Configuration' screen appears. Customise the left-hand navigation bar, header and footer to suit your needs. Details are in the documentation. Here are some hints:
   - The 'Page Tree' check box determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.
   - The 'Limit search results to the current space' check box determines whether Confluence will search only the current space or the whole Confluence site. This setting affects the default search. Viewers can override it each time they do a search.
   - Enter text, images, macros and other wiki markup into any or all of the three text boxes for the left-hand navigation bar, header and footer. You can use the Include macro and the Excerpt Include macro to include re-usable content.
   - Any content you add to the navigation panel will appear above the default page tree.
   - If you like, you can remove the default page tree (by unticking the box) and add your own, customised version of the Pagetree macro instead.

6. Click 'Save'.

**Example of a Customised Footer**

Take a look at the footer of a page in the Crowd documentation space.

To produce the above footer, we have the following content in the footer panel in the Documentation theme configuration screen:

---

*Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
Step 5. Create an Inclusions Library

Using Confluence, you can dynamically include content from one page into another page. You can include a whole page into another one, using the Include macro. You can also define an 'excerpt' on a page, and then include that excerpted text into another page using the Excerpt Include macro.

To organise your re-usable content, we recommend that you create a set of pages called an 'inclusions library'.

1. Open the 'Browse' menu and select 'Pages'.
2. The 'List Pages' screen will appear. Open the 'Add' menu and select 'Page'.
   This will add a page at the root of the space, at the same level as the home page.
3. Enter a suitable title. We use '_'InclusionsLibrary'. The unusual format of the title helps to let
   people know this page is special.
4. Enter some content on the page. We enter text explaining the purpose of the inclusions library
   and how to re-use the content. You can copy our text by clicking through to one of the
   example pages listed below.

5. Add child pages containing your re-usable content. See the examples of our own inclusions
   libraries listed below.

Some notes about inclusions libraries:

- The inclusions library is not a specific feature of Confluence. The pages in the inclusions library are just
like any other Confluence page.

- The pages are located at the root of the wiki space, not under the home page. This means that they will not appear in the table of contents on the left and they will not be picked up by the search in the left-hand navigation bar either.
- The pages will be picked up by other searches, because they are just normal wiki pages.
- We have decided to start the page name with an underscore. For example, '_My Page Name'. This indicates that the page is slightly unusual, and will help prevent people from changing the page name or updating the content without realising that the content is re-used in various pages.

**Examples of Inclusions Libraries**

Here are some examples in our documentation:
- Crowd inclusions library
- Confluence inclusions library

**Step 6. Create the Table of Contents**

Create the table of contents for your documentation, by adding the top-level pages for all the usual sections:

- User’s guide
- Administrator’s guide
- Installation guide
- Configuration guide
- Release notes
- FAQ
- Whatever else you need

1. Go back to your space home page, by clicking the space name in the breadcrumbs at the top of the screen.
2. Open the 'Add' menu and select 'Page'. This will add the page as a child of the home page.
3. Enter the page title, 'User’s Guide'.
4. Enter the content of the page.
   *Hint: If you do not know what to add yet, just add a short description then refine the content of the page later. If you like, you can add the Children macro. That will act as a table of contents on the page once you have added child pages.*
5. Click 'Save'.

Now do the same for all the sections of your technical document.

**Step 7. (Optional) Customise the PDF Layout and Stylesheet**

If you are planning to provide PDF versions of your documentation, you may want to customise the PDF layout and styles for your space. You can skip this step for now and do it later, if you prefer. The instructions are in a separate section of this guide, dedicated to PDF. See Providing PDF Versions of your Technical Documentation.

**Step 8. Save your New Space as a Template Space**

This is a useful suggestion. Once you have set up your first documentation space and are more-or-less happy with it, use the Copy Space plugin (see notes below) to copy the space while it still has very little content. From this point on, you can copy it each time you want to create a new documentation space.
1. Open the ‘Browse’ menu and select ‘Space Admin’.
2. Click ‘Copy Space’ in the left-hand panel.

Hint: If you cannot see the ‘Copy Space’ option, this means that the plugin is not installed on your Confluence site. Refer to the documentation on installing plugins.

3. The ‘Copy Space’ screen will appear. Enter the details as prompted, to copy your space to another new space.

4. Click ‘Save’.

You now have a template space. From this point on, you can use the Copy Space plugin to copy the template space each time you want to create a new documentation space.

Notes:

- The Copy Space plugin is not covered by Atlassian support. However, the Atlassian technical writers use it for all our documentation. If you like, you can vote for an comment on the request for Atlassian support to cover this plugin: CONF-14198.
- Your site administrator will need to install the Copy Space plugin into Confluence. Refer to the documentation on installing plugins.

Next Steps

You now have the basic structure and configuration for your technical documentation space. You have also created a handy template to use next time you need a space. What next? Take a look at Using Templates in Technical Documentation.

Using Templates in Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. We have already shown you how to create your technical documentation space. Now we offer an introduction to the templates
that Confluence provides.

Quick guide to templates in Confluence

- A template is a page with predefined content that can be used as a prototype when creating other pages.
- Templates are available across the Confluence site (global templates) or per space (space templates).
- Both 'global templates' and 'space templates', as described on this page, define the content of a page. They do not define the content of an entire space.
- You can import predefined templates, including those shipped with Confluence and additional templates from the Atlassian Plugin Exchange.
- To create a template for an entire space, see our guide to creating your documentation space.

On this page:

- Deciding Where to Put Your Templates
- Creating a Global Template
- Creating a Space Template
- Importing Templates
- Using a Template to Create a Page

Deciding Where to Put Your Templates

In Confluence, there are two places to store your page templates:

- **Space templates**: These page templates are available in a specific space only. People who have space administrator permission can define templates via the space administration screen.
- **Global templates**: These page templates are available in every space on the site. People who have Confluence Administrator permission can define the global templates via the Confluence Administration Console.

Decide whether your template is useful across more than one space.

- If yes, create a global template. You will need Confluence administrator permissions.
- If no, create a space template.
  - You will need space administrator permissions for the relevant space(s).
  - You may have already saved your documentation space as a template, as described in our guide to creating your documentation space. In that case, it may be useful to save your template page in your template space. When you later copy the space, the template pages will be copied too.

Creating a Global Template

1. Choose **Browse > Confluence Admin**.
2. Enter your password if prompted.
3. Choose **Global Templates** in the left-hand panel.
4. Choose **Add New Global Template**.

See **Global Templates** for more information.

Creating a Space Template

1. From any page in the space, choose **Browse > Templates**.
2. Choose **Add New Space Template**.

See **Adding a Template** for more information.
Importing Templates

Confluence ships with a number of templates, including the 'Charts', 'Document List' and 'Meeting Notes' templates. These templates are not available for use by default. However, if you have the appropriate permissions to access the Administration Console, you can import any of these templates to be used globally or within a specific space. In addition, you can find more template bundles on the Atlassian Plugin Exchange.

1. Go to the Confluence Administration Console and choose Import Templates.
2. Select the templates that you want to import.
3. Select the space to import the templates to, or choose to import them as global templates.
4. Choose Import.

Using a Template to Create a Page

When people add a page on your Confluence site, they can choose to base their new page on a template.

Go to the page that will be the parent of your new page, and choose Add > Page from template. (This link is only displayed if there are templates already defined.)

See Creating a Page using a Template for more information.

Next Steps

You now have a good idea of how Confluence templates work. What next? Take a look at Re-using Content in Technical Documentation.

Re-using Content in Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. In the page about creating your technical documentation space, we showed you how to set up an 'inclusions library' to contain content that you can re-use on more than one page. Now we offer further guidelines on re-using content in your documentation space.

Your documentation may be about using a software application, or it may be a technical manual for your product range. On this page, we use the term 'widget' to describe the things that you are documenting, such as the screen, form, document, product or object.
Quick guide to re-using content

- Create an ‘inclusions library’ to manage your re-usable content. See our guide to [creating your technical documentation space](https://confluence.atlassian.com/display/DOC/Creating+Your+Technical+Documentation+Space).
- Use the `excerpt` macro to define a re-usable section (‘excerpt’) on a page, or just decide to re-use the entire content of the page.
- Use the `excerpt-include` macro to include the excerpt from one page onto another page.
- Use the `include` macro to include the entire content of a page onto another page.
- Consider installing the Multi Excerpt plugin if you need to define multiple excerpts per page.

The rest of this page gives an overview and more details of the above procedures.

On this page:

- [Reasons for Re-Using Content](#)
- [Defining an Inclusions Library](#)
- [Working with Excerpts and Inclusions](#)
  - [Using the Include Page Macro](#)
  - [Using the Excerpt Include Macro](#)
  - [Using the Multi Excerpt Plugin](#)
- [An Example of Content Re-Use: A Glossary](#)
  - [Creating a One-Page Glossary](#)
  - [Creating a Glossary with Child Pages](#)
  - [Referring to Glossary Terms](#)
- [Further Reading](#)

Reasons for Re-Using Content

A golden rule for technical documentation is to write the content only once but allow that content to be used in many places and in many forms.

For example, you may have the following types of content:

- A technical manual that describes each widget in detail.
- Tips and tricks on how to get the most out of the widget.
- A step-by-step user guide for first-time users on how to use the most common widgets.
- A training manual with exercises or videos that people can follow in their own time.
- A one-page cheat sheet for users to stick up on their workstation.
- Text for a sales brochure that is sent out to a print house for production.

Each of these types of content will share common information, such as a glossary entry, a technical or marketing description of the widget, or a step-by-step guide on how to use the widget.

Some initial planning of your technical documentation will allow you to re-use any or all of the content you write, so there is only ever one place to update the content, and those changes flow through to all of your other documentation.

Defining an Inclusions Library

We recommend that you create an ‘inclusions library’ to manage your re-usable content. If you have not already done this when creating your documentation space, see our guide to [creating your technical documentation space](https://confluence.atlassian.com/display/DOC/Creating+Your+Technical+Documentation+Space).

Working with Excerpts and Inclusions
Excerpts and inclusions (sometimes called 'includes') are very useful for re-using content:

- Use the Excerpt macro (**excerpt**) to define a re-usable section ('excerpt') on a page.
- Use the Excerpt Include macro (**excerpt-include**) to include the excerpt on another page.
- Use the Include Page macro (**include**) to include the entire content of a page onto another page.

A simple example of an inclusion is a note or warning that is used in many places in your documentation. Here is an example:

**Example note -- "Draft in progress"**

This document is still in draft status. Please treat the content with caution.

*Tip:* Keep your re-usable pages short and sweet. Do not worry if you find that you need hundreds of pages to hold your inclusions. It helps to keep things separate and organised.

**Using the Include Page Macro**

In this example, we use the Include Page macro to create a note that you can re-use on your documentation pages. The Include Page macro will include the entire content of one page into another page. (See the 'Excerpt' macro below for including parts of a page.)

1. Create a page in your inclusions library called **_Draft Note**.
2. Add the content of the page. In this example, we use the Note macro with some text in the title and body:
   
   ```
   {note:title=Draft in progress}This document is still in draft status. Please treat the content with caution.{note}
   ```

3. Use the Include Page macro to include that note in any page in your documentation. For example:

   ```
   {include:_Draft Note|nopanel=true}
   ```

See the documentation on the [Include Page macro](https://confluence.atlassian.com/display/DOC/Include+Page+Macro) for more details.

**Using the Excerpt Include Macro**

An excerpt is a section of a page that you can include into another page.
1. Use the `excerpt` macro to define any content in your page that you want to be able to use elsewhere. This content can be as short as a word or as long as the entire page. For example, let's assume we have a page called 'My Short Poem':

```
I really love this poem:
(excerpt)
Mary had a little lamb
(excerpt)
And I'm going to use it all over the place.
```

2. Use the `Excerpt Include` macro to include the excerpt into another page. For example:

```
(excerpt-include:My Short Poem|nopanel=true)
```

You can only define one `excerpt` on a page. See the documentation on the `Excerpt Include` macro for more details.

To have multiple excerpts on a page, see the 'Multi Excerpt plugin' below.

**Using the Multi Excerpt Plugin**

The Multi Excerpt plugin provides additional macros that enable you to have multiple excerpts on a page. A good example of where you would find this useful is in the glossary page discussed below. If you want to include a single glossary entry or a subset of the glossary entries in another page, then the named excerpts allowed by the Multi Excerpt plugin are very useful.

Notes:

- The `Multi Excerpt plugin` is a commercial plugin and is not free.
- Your Confluence administrator will need to download and install the plugin into your Confluence site before you can use the macros described below. Refer to the documentation on installing plugins.
- *Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.* Please refer to the `Multi Excerpt plugin page` for support details.
1. Use the following code on the base page containing the content you want to use elsewhere:

   {multi-excerpt:name=ExcerptName1}
   Excerpt text 1
   {multi-excerpt}
   Any other text
   {multi-excerpt:name=ExcerptName2}
   Excerpt text 2
   {multi-excerpt}

2. Use the following code on the page where you want to include the named excerpt:

   {multi-excerpt-include:pageTitle=PageName|name=ExcerptName1|nopanel=true}

3. You can also include excerpts from other spaces using the following syntax:

   {multi-excerpt-include:spaceKey:pageName|name=excerptName|nopanel=true}

See the Multi Excerpt plugin page for more details.

An Example of Content Re-Use: A Glossary

A glossary is something that most technical documentation will require. There are a few ways to set up glossaries in Confluence. These are the most popular:

- All glossary entries on one page.
- Each glossary entry on separate child pages with a main page showing excerpts of the glossary.

Once you have defined the glossary entry, you can refer to it from the main pages of your technical documentation.

Creating a One-Page Glossary

This style of glossary is useful if the glossary entries tend to be short and there are not too many of them.
1. Create a page named **Glossary**.
2. Add an alphabetical index at the top of the page and a heading for each letter of the alphabet:

   ![Alphabetical Index Example]

3. Enter each glossary entry under the relevant alphabetical heading. Each glossary entry (term) should include:
   - An anchor tag, so that you can link to it from other pages.
   - The term itself.
   - A definition of the term.
   - A link to the page in your technical documentation that explains the term in greater detail, where relevant.

   ![Glossary Entry Example]

4. Optionally, include a horizontal line between the terms. This depends on how long each entry is. If your glossary tends to have short entries, it may look too cluttered with horizontal lines.

   ---

See the glossary in the [Confluence documentation](https://confluence.atlassian.com/) for an example of this style of glossary (without the alphabetical index).

**Creating a Glossary with Child Pages**

This style of glossary is useful if the glossary entries tend to be quite long or have additional information over and above the definition of the term.
1. Create a page named **Glossary**.
2. Create a child page for each glossary entry (term). Each child page should contain:
   - The term as the title of the page.
   - The definition of the term in the body of the page.
   - Excerpt tags `{excerpt}` tags surrounding the definition.
   - Any additional information after the `excerpt` tags.

```
{excerpt}
This is the definition of MyGlossaryTerm
{excerpt}
More information to describe MyGlossaryTerm
```

3. On the 'Glossary' page, use the `children` macro to show the excerpts from each child page in a list, with the page name displayed in 'h4' style.

```
{children:excerpt=true|style=h4}
```

See the glossary in the [Crowd documentation](#) for an example of this style of glossary.

**Referring to Glossary Terms**

In the main pages of your technical documentation, create a link to the glossary page for each glossary term.

```
_[MyGlossary Term|Glossary#MyGlossaryTerm]_
```

Note that this is a standard page link with an anchor. We have formatted the link as italics, because it helps to have the glossary links looking different to other page links. Readers can just skip over the glossary link if they are already familiar with the term.

**Further Reading**

- A blog post about content re-use: [Technical Writing in a Wiki - Content Re-use and Structure](#) (November 2010).

**Next Steps**

You now have a good idea of how to re-use content in a Confluence documentation space. What next? Take a look at [Managing the Life Cycle of your Technical Documentation](#).

**Managing the Life Cycle of your Technical Documentation**

This page is part of the guide to [developing technical documentation on Confluence Wiki](#). We have already shown you how to [create your technical documentation space](#), including how to set permissions for your space. Now we offer a quick-start guide to managing the life cycle of your technical documentation in Confluence. The life cycle includes drafting, reviewing and publishing a document, as well as managing documentation that is release-specific.
Quick guide to managing the technical documentation life cycle

- Create draft pages with restricted permissions, to hide them until they are ready for publication.
- Set the permissions to allow reviewers to comment on and/or update the pages.
- When ready, publish the page by removing the permission restrictions.
- Monitor updates to your draft and published pages by watching your space and/or subscribing to RSS feeds.
- Use spaces as a mechanism for matching your documentation version to product releases: one space per major release number.
- Consider installing plugins for extended workflow and publication management.

The rest of this page gives more details of the above procedures.

On this page:

- Using the Built-In Confluence Functionality to Manage Workflow and Release Cycle
  - Drafting, Reviewing and Publishing a Page
  - Keeping Track of Documentation Updates
    - Viewing the History of a Page
    - Receiving Email Notification of Updates
    - Monitoring Updates via RSS Feeds
  - Release Management
    - Space Keys
    - The Release Management Process
  - Other Scenarios using the Built-In Confluence Functionality
    - Using Add-Ons for Extended Workflow, Publication and Concurrent Version Management
  - Notes

Using the Built-In Confluence Functionality to Manage Workflow and Release Cycle

This section describes how to use the built-in Confluence functionality to manage your workflow (draft, review, publish) and to align your documentation version control to the product release cycle.

In this scenario we also assume that you want a live space that always has the same space key and always contains the latest version of your documentation. This scenario suits the requirements of an organisation that wants their technical documentation to be 'live'. Various groups of people can refine the content as and when required. People can also subscribe to the space, knowing that they will always get the latest version of the documentation and comments.

This is the way we manage our documentation at Atlassian. The content of the wiki is dynamic, continuously updated, commented on, subscribed to and watched by thousands of people all over the world.

Drafting, Reviewing and Publishing a Page

The workflow is simple.
1. Create a page with restricted permissions. For example, you might restrict viewing to a group of people such as your team. On a public wiki, you might restrict viewing to staff members, so that the general public cannot see the page.
2. Write the page content.
3. Ask other people to review the page. They can add comments to the page or simply edit the page content directly.
4. Publish the page when ready, by doing the following:
   - Delete the comments on the page.
   - Remove the permission restrictions on the page. The page has now been published. The space permissions and site permissions now determine who can see and/or update the page.

The screenshot below shows a page under review. Notice the lock icon at top left, indicating that restricted permissions apply to this page.

Keeping Track of Documentation Updates

On a wiki, it is quite usual for a number of different people to update a single page. Technical writers need to know what happens to our documents, both during review and after publication.

Viewing the History of a Page

Confluence creates a new version of the page every time someone edits the page. The page history shows all the versions, with date, author, and any comments made on the update.

Go to the page and choose Tools > Page History.

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Changed By</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>CURRENT</td>
<td>v. 41 Apr 2009 11:33</td>
<td>Giles Gaskell [Atlassian Technical Writer]</td>
<td>Restore this version</td>
</tr>
</tbody>
</table>

On the page history view, you can:
- View the content of a specific version of the page.
- Revert to (restore) a specific version.
- Select any two versions and ask for a comparison, to see what has changed between those two versions.

See [Page History and Page Comparison Views](#) for detailed information.

It is all very well to go to a specific page and see what has happened to it, but how do you know when to go and look at the page? You need a notification of any changes made to your documentation space.

In Confluence, you can monitor updates to your documentation via email notifications and via RSS feeds.

### Receiving Email Notification of Updates

You can ‘watch’ a page or an entire space. Whenever anyone updates the page or space, you will receive an email notification.

To watch a page:

Open the 'Tools' menu and select 'Watch'.

To watch a space:

1. Go to a page in the space and choose Browse > Advanced.
2. In the left-hand panel, click 'Start watching this space'.

See [Subscribing to Email Notifications of Updates to Confluence Content](#) for details of the various notifications Confluence will send, and how to configure your notification settings.

### Monitoring Updates via RSS Feeds

RSS feeds provide another way to keep track of updates. The simplest way to build an RSS feed is to use Confluence’s feed builder, accessible from the dashboard. This will give you a URL that you can ping to get the latest updates.

Below we describe how to set up a useful feed for your technical documentation space. Remember that you can adjust the settings to suit your own needs.

1. Choose Browse > Feed Builder. The RSS feed builder form appears.
2. Check the boxes to select all the content types. (Even if you are not expecting comments, blog posts or mail in your documentation space, it does no harm to receive notifications if they do arrive.):
   - Pages and the comments and attachments on pages.
   - Blog posts and their comments and attachments.
   - Mail.
3. Select your documentation space from the list. Press Ctrl and click to select multiple spaces.
4. Click the Create RSS Feed button to create your feed.
5. This will take you to a new screen. Drag or copy the link into your RSS reader. The feed URL is linked to the words Drag or copy this link to your RSS reader.

Now that you have set up your RSS feed, you need to decide how to read it. There are various options to choose from. For example:

- Use an RSS reader, such as the Sage add-on for Firefox.
- Use an email client, such as Thunderbird.

See [Subscribing to RSS Feeds within Confluence](#) for details.

### Release Management

---

*Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
Let's assume that your product goes through a regular release cycle, and that you need to retain separate documentation for each major version of the product.

At Atlassian, we use spaces as our version-control mechanism.

- **Archive spaces.** At each release, we create a new archive space to house the previous version of the documentation.
- **The live space.** The documentation for the latest version of the product resides in the live space. The live space always retains the same space key and is always available for viewing and updating.

**Space Keys**

The live space has just the product name as its space key. For example, for the Crowd product the space key is 'CROWD'. (See the Crowd documentation space.)

For the archived versions, we use a combination of the product name plus version number as the space key. For example, we use 'CROWD020' for the Crowd 2.0 documentation, 'CROWD016' for the Crowd 1.6 documentation, and so on.

**The Release Management Process**

Here is an overview of the process we follow at Atlassian.

1. **Leading up to release date.** Work with hidden draft pages in the live space. A 'hidden draft' is simply a page that has restricted permissions applied:
   - For each new feature, create a new page with restricted permissions.
   - If you need to update existing pages, create a hidden copy of the existing page and apply the updates to the copy.
   - Follow the usual draft and review procedure for each page.

2. **A few days before release date.** Use the Copy Space plugin to copy the live space to a new space. This creates a snapshot of the current documentation, and will act as an archive for the current release which is soon to become the previous release. (We described the use of the Copy Space plugin in the earlier section of this guide: Creating your Technical Documentation Space.)

3. **On release date.** Publish the updated documentation for the new version of the product:
   - Rebrand the live documentation space to reflect the new release number. In other words, change the space name and any other descriptions that include the product release number.
   - Unhide all the new pages, by removing the permission restrictions on each hidden page.
   - Copy the content of the updated pages to the proper pages, then delete the copies.
   - Export the newly updated space to PDF, HTML and XML, for those customers who prefer offline versions of the documentation.

Note that the above process is applicable to major releases of the product. For minor bug-fix releases, we simply update the documentation in the live space. We do not create archive spaces for every minor release.

The example below shows an extract from the dashboard of our documentation wiki, listing the spaces for different versions of the Crowd documentation. (Crowd is one of our products.) Each space holds the documentation for a specific major release of Crowd.
**Other Scenarios using the Built-In Confluence Functionality**

It is easy to design other ways of managing your documentation spaces using the built-in Confluence functionality. For example, the simplest scenario is to publish a new space for every new release of your product, using the same Copy Space plugin as described above.

**Using Add-Ons for Extended Workflow, Publication and Concurrent Version Management**

For advanced workflow features, consider installing the Ad Hoc Workflows add-on onto your Confluence site.

For advanced publication and concurrent version management consider using the Scroll Versions add-on. Scroll Versions enables you to set up and manage concurrent versions of your documentation in a single space. Multiple versions of software, different product variants, and even multiple languages of documentation can be managed. Changes to pages are scheduled for a specified version and then published all at once.

1. Install the Scroll Versions add-on from the Marketplace or using Confluence's Universal Plugin Manager.
2. Create a space for your documentation or activate Scroll Versions on your existing documentation.
3. Add the version numbers that you want to work with, via the version management screen.
4. When a version is ready to publish go to 'Browse' > 'Scroll Versions' > 'Manage Versions' and publish your documentation within the same space or to another space.

See the documentation of Scroll Versions for further information.
Similarly, consider using the Content Publishing add-on to publish content from a master space to a published space. In this scenario, you will create a master space that contains your drafts in progress and new releases. The master space is visible only to the authors and reviewers. You will periodically publish the master space to a published space. This suits the requirements of an organisation that needs a ‘published’ or ‘official’ set of documentation, published only when a new version of the product is released. There is no requirement for continual updating of the documentation.

1. Install the Content Publishing plugin.
2. Create a space for your master content.
3. Create a space for your published content.
4. When the content in the master space is ready to publish, go to the ‘Advanced’ tab in the ‘Space Admin’ section of the master space.
5. Click ‘Publish Space’ to configure the settings and then publish your space. See the plugin documentation to choose the options best for your needs.
6. Click ‘Publish’.

**Automatic publishing.** The Content Publishing plugin can work together with the Ad Hoc Workflows plugin to publish pages automatically when the page reaches a specified state in the workflow.

**Notes**

- **Installing plugins.** If you decide to use additional plugins, your site administrator will need to install the plugins into your Confluence site. Refer to the documentation on installing plugins.

- **Plugin support.** Before installing a plugin into your Confluence site, please check the plugin’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

**Next Steps**

Now you know about managing your workflow and documentation release process on Confluence. What next? Take a look at Providing PDF Versions of your Technical Documentation.

**Providing PDF Versions of your Technical Documentation**

This page is part of the guide on Developing Technical Documentation on Confluence Wiki.

Confluence is a platform for publishing online documentation. It also provides an export to PDF feature for producing PDF versions of your documentation, allowing you to print it, or to provide a copy to customers who are unable to access the online version. This guide describes how to export your technical documentation to PDF using Confluence’s built-in PDF export, and introduces a third-party plugin that provides additional PDF layout and style functionality.

**Quick guide to PDF exports**

- Customise the PDF layout (title page, header and footer) and style, for use each time you export your documentation.
- Export a single page to PDF.
- Export a selection of pages or an entire space to PDF.
- Consider installing a third-party plugin for advanced PDF export functionality.

The rest of this page gives more details of the above procedures.
Customising the PDF Layout and Style

If you plan to create PDF versions of your documentation, you may want to customise the PDF layout and styles for your space. These customisations will be applied every time you export documentation to PDF.

Under PDF layout you can add HTML to customise the PDF title page, and page headers and footers. Under PDF stylesheet, you can adjust the appearance of the PDF pages.

**Editing the PDF Layout**

**Setting a global PDF layout**

1. Open the Confluence Admin screen.
2. Select Look and Feel > PDF Layout. The following screens allows you to enter HTML and CSS that will be rendered on the PDF title page, as well as page headers and footers.

**Setting the PDF layout at space level**

1. Choose Browse > Space Admin.
   
   Note: 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
2. Click PDF Layout in the ‘Look and Feel’ section of the left-hand panel.
3. Click Edit, and customise the HTML that generates the following areas in the exported PDF document:
   - PDF Space Export Title Page – title page.
   - PDF Space Export Header – page headers.
   - PDF Space Export Footer – page footers.
4. Enter your customisations into each text box as required. The PDF layout section accepts HTML code. You can include inline CSS in the HTML too. Save your work.

**Editing the PDF Stylesheet**

**Exporting to PDF**

- Exporting a Single Page to PDF
- Exporting a Selection of Pages or a Space to PDF

**Notes**
Setting a global PDF Stylesheet

1. Open the Confluence Admin screen.
2. Click Look and Feel > PDF Stylesheet. The following screen allows you to enter and save CSS code that will render content on each page.

Setting a space-level PDF stylesheet

1. Choose Browse > Space Admin. 
   Note: 'Space Admin' is displayed only if you are a space administrator for that space, or you are a super user (a member of the confluence-administrators group).
2. Click PDF Stylesheet in the left-hand panel. The 'PDF Export Stylesheet' section appears, showing the current contents of your PDF stylesheet. It contains all CSS rule customisations applied to the pages in the space.
3. Click Edit and enter your customisations into the text box as required. The PDF stylesheet section accepts Cascading Style Sheets (CSS) rules. Save your work.

Examples of PDF Customisation

Below are typical customisations you may want to make for your technical documentation. For more examples, see Customising Exports to PDF.

Adding a Title Page

You can create a title or cover page to your PDF document using HTML. Use the PDF Space Export Title Page section of the PDF layout to do this.

Adding a New Title Page

The following example uses HTML with an inline CSS rule to generate a title page.

```html
<div class="fsTitlePage"
style="margin-left:auto;margin-top:75mm;margin-right:auto;page-break-after:always">
<img src="/download/attachments/12345/titlepage.png"/>
</div>
```

Including Content Above Table of Contents in Default Title Page

The following example includes content above the automatically-generated table of contents that appears on the default title page, so that your title page includes your own content plus the table of contents.

```html
<div class="fsTitlePage"
style="margin-left:auto;margin-top:75mm;margin-right:auto;">
<img src="/download/attachments/12345/titlepage.png"/>
</div>
```

Adding an Image to your Title Page

In the examples above, the title page includes an image called 'titlepage.png', centred in the middle of the page. The image is attached to a Confluence page and is referenced via its relative URL (that is, we use only the last part of the URL, excluding the Confluence site's base URL).

Follow these instructions to include an image on your title page:
1. Attach the image to a Confluence page.
2. View the list of attachments on that page.
3. Right-click the image and copy its location.
4. Paste the link into the appropriate src="" attribute within your PDF stylesheet, as shown above.
5. Remove the first part of the URL before /download/....

Adding Headers and Footers

You can add headers and footers to your PDF pages using HTML. Use the 'PDF Space Export Header' and 'PDF Space Export Footer' sections of the PDF layout to do this. For simple headers and footers, plain text is enough. The following example adds a simple copyright notice.

Copyright © 2010, Atlassian Pty Ltd.

Adding Page Numbering to a Header or Footer

To add page numbering, you need to combine customised HTML in the PDF Layout with customised CSS in the PDF Stylesheet.

1. PDF Layout HTML: In the Footer section (or the Header section), use an empty span element with a unique ID, for example pageNum, to act as a place holder for the page number.

   HTML - PDF Layout: Footer Section
   <span id="pageNum"/>

2. PDF Stylesheet CSS: Create the following CSS selector rule for the empty span:

   CSS - PDF Stylesheet
   #pageNum:before
   {  
     content: counter(page);  
   }

Analysing the above CSS selector rule in more detail:

- The #pageNum rule selects the HTML element with the specified ID of "pageNum", which is the span element we created for the header or footer.
- The :before part of the selector is a pseudo class that allows the insertion of content before the span element is processed.
- The counter (page) is a function that returns the current page number as its content.
- The content property tells the CSS processor that dynamic content (that is, an incrementing page number) is to be inserted at the span tag.

Exporting to PDF

You can use the built-in Confluence PDF export to export a single page, a selection of pages or an entire space to a single PDF file.

Exporting a Single Page to PDF

You can export a Confluence page to PDF. This option exports a single page and is available to all users who
have permission to view the page:

- Go to a page in the space and choose **Tools > Export to PDF**. Follow the prompts to export the page.

**Exporting a Selection of Pages or a Space to PDF**

1. Go to a page in the space and choose **Browse > Advanced**.
2. Click **PDF Export** in the left-hand panel. This option will only be visible if you have the 'Export Space' permission.
3. Select the pages you want to export.
   - You have the option to **Select All** or **Deselect All** pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
4. Click **Export**.
5. When the export process has finished, download and save the PDF file as prompted.

**Using the Scroll PDF Exporter Plugin to Export to PDF**

The Scroll PDF Exporter provides flexible themes for configuring PDF layout and styles. You can select one of Scroll PDF Exporter's built-in themes and configure your table of contents, header and title pages. For even more flexibility, see the section **HowTos** in the Scroll PDF Exporter documentation.

For this advanced PDF export functionality, you will need to install the **Scroll PDF Exporter** plugin to your Confluence site.

**Notes**

- **Permissions required to export a space**: To use the space export functionality, you need 'Export Space' permission. See the guide to **space permissions** or contact a **space administrator** for more information.
• **Installing plugins:** If you decide to use additional plugins, your site administrator will need to install the plugins to your Confluence site. Refer to the documentation on installing plugins.

• **Plugin support:** Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

---

**Related Topics**

Developing Technical Documentation on Confluence Wiki
Customising Exports to PDF
Exporting Confluence Pages and Spaces to PDF
Scroll PDF Exporter
Installing a Plugin

**Next Steps**

Now you know all about providing PDF versions of your documentation. What next? See other ways of Exporting and Printing Technical Documentation.

**Exporting and Printing Technical Documentation**

This page is part of the guide to developing technical documentation on Confluence Wiki. Confluence is a great tool for writing and maintaining technical documentation. There are times when we need to export the content out of Confluence into other forms, such as PDF, HTML, Microsoft Word and paper.

Confluence itself provides an export to both PDF and HTML. Plugins provide additional functionality. Below are guidelines on exporting your technical documentation to various formats, including printed output.

**Quick guide to printing and exporting content**

- Use the browser's print option to print a single page.
- To print more than one page and for more advanced printing options, export your documentation to PDF.
- Confluence can export your pages to PDF, HTML, Confluence-specific XML and Word.
- Consider installing plugins to export your pages to PDF (enhanced functionality). Word (enhanced functionality), DocBook XML, Eclipse Help and JavaHelp.
- Make your exports available to your customers for download by attaching the exported file to a Confluence page.

The rest of this page gives more details of the above procedures.

**On this page:**

- Printing
- Exporting to PDF
- Exporting to HTML
- Exporting to Confluence-Specific XML
- Exporting to DocBook XML via a Plugin
- Exporting to Microsoft Word
- Exporting to Microsoft Word via a Plugin
- Exporting to Eclipse Help via a Plugin
- Exporting to EPUB via a Plugin
- Exporting to HTML via a Plugin
- Making the PDF and Other Exported Files Available to your Readers
- Notes
- Further Reading
**Printing**

To print a single Confluence page, just use the browser’s print option. This option is available to all users who have permission to view the page.

To print more than one page and for more advanced printing options, export your documentation to PDF. See *Providing PDF Versions of your Technical Documentation*.

**Exporting to PDF**

Because this is such an important topic, we have a section of this guide dedicated to PDF. See *Providing PDF Versions of your Technical Documentation*.

**Exporting to HTML**

Using the built-in Confluence HTML export, you can export a single page, a selection of pages or an entire space to HTML. Confluence supplies the HTML and associated files in a zip file.

1. Go to a page in the space and choose **Browse > Advanced**.
2. Click **HTML Export** in the left-hand panel.  
   This option will only be visible if you have ‘Export Space’ permission.
3. Select the **Include Comments** check box if you want to include comments for the pages you are exporting.
4. Select the pages you want to export by selecting the check boxes in the tree view of pages displayed. By default, all pages are selected. You have the option to **Select All** or **Deselect All** pages.
   If you select the check box of a page that contains one or more child or descendant pages, all of these child and descendant pages will also be selected. Similarly, if you clear the check box of such a page, all of its child and descendant pages will also be cleared. This provides a convenient method of exporting subtrees, for example, chapters or sections within a document.
5. Click **Export**. This will create a zipped archive of HTML files.
6. When the export process has finished, download the zipped archive as prompted and extract the files into a folder.
Exporting to Confluence-Specific XML

Confluence provides an XML export. The XML produced is a proprietary format and is intended for backups or for transferring a space from one Confluence instance to another. If you write your documentation on Confluence and your customers have Confluence too, then you can export your manuals to XML and customers can upload them onto their own Confluence site.

Exporting to DocBook XML via a Plugin

Scroll DocBook Exporter converts Confluence pages to DocBook XML. Your Confluence system administrator will need install the plugin onto your Confluence site.

Exporting to Microsoft Word

Confluence can export a page to Word. (Select 'Export to Word' from the 'Tools' menu.) This option performs a basic conversion of wiki content to HTML and applies some Word CSS stylesheets. It processes just one page at a time.

Exporting to Microsoft Word via a Plugin

Scroll Office is a Confluence plugin. Once installed, Scroll Office replaces Confluence's built-in 'Export to Word' functionality. You can export a single page or a hierarchy of pages.

You can define your templates in Word in the usual way, and upload them to Confluence as global templates or space templates. When you export your Confluence pages to Word, Scroll Office will use those templates to build native Word documents from the wiki pages.

Scroll Office provides additional features such as enforcing page-breaks, setting the page orientation to landscape or portrait, and ignoring content. The latest version offers a REST-style API for automated export.

Exporting to Eclipse Help via a Plugin

Scroll EclipseHelp Exporter provides an export to Eclipse Help format.
You can produce embeddable online help for Eclipse-based applications. Scroll EclipseHelp Exporter converts the Confluence content into EclipseHelp-compatible JAR files to create a standalone online help or a context-sensitive help.

**A hint about the Eclipse Help platform:** You can use a cut-down version of the Eclipse Help platform to provide online documentation for any system. It doesn't have to be an Eclipse tool that you are documenting. For some ideas, take a look at a couple of articles about documenting your project using the Eclipse help system.

**Exporting to EPUB via a Plugin**

The Scroll EPUB Exporter outputs an ebook in the common EPUB format that can be read on iPads, iPhones and any other ebook reader.

**Exporting to HTML via a Plugin**

The Scroll HTML Exporter enables the delivery of Confluence content from a web server. It converts the pages into static HTML pages that can be uploaded to a web server. The output of the Scroll HTML exporter can also be used as an input to produce other HTML-based help formats such as WinHelp and HTML Help.

**Making the PDF and Other Exported Files Available to your Readers**

There are a number of ways to make your exported files available to your readers, such as putting the files on a disc and shipping them with your product.

One of the simplest ways is to attach the files to a Confluence page. (See [Attaching Files to a Page](#).)

For example, Atlassian uses the out-of-the-box Confluence export functionality to provide PDF, HTML and XML versions of our documentation. People can download the files from our [documentation wiki](http://jira.atlassian.com/wiki/display/DOC/). For example, here are the [JIRA documentation downloads](http://jira.atlassian.com/wiki/display/DOC/) and the [Confluence documentation downloads](http://confluence.atlassian.com/display/DOC/).

For those people who would like to use the XML files to recreate the documentation on their own Confluence sites, we provide instructions on [setting up your own local documentation](http://confluence.atlassian.com/display/DOC/).

**Notes**

- **Permissions required to export a space.** To use the space export functionality, you need 'Export Space' permission. See the guide to [space permissions](http://confluence.atlassian.com/display/DOC/) or contact a [space administrator](http://confluence.atlassian.com/display/DOC/) for more information.

- **Installing plugins.** If you decide to use additional plugins, your site administrator will need to install the plugins into your Confluence site. Refer to the documentation on [installing plugins](http://confluence.atlassian.com/display/DOC/).

- **Plugin support.** Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on [plugin support](http://confluence.atlassian.com/display/DOC/).

**Further Reading**

- A blog post about exporting and importing content from/to Confluence: [Technical Writing in a Wiki - Single Source Publishing](http://confluence.atlassian.com/display/DOC/) (November 2010).
- A good overview of the Scroll Office features in this [blog post](http://confluence.atlassian.com/display/DOC/) (August 2010) and the [followup post](http://confluence.atlassian.com/display/DOC/) (November 2010).

**Next Steps**

Now you know about a number of ways to get your technical documentation out of Confluence into various formats, for printing or for input into another system or process flow. What next? Take a look at [Essential Confluence Features for Technical Documentation](http://confluence.atlassian.com/display/DOC/).
Essential Confluence Features for Technical Documentation

This page is part of the guide to developing technical documentation on Confluence. In this section we highlight the built-in Confluence macros that are most useful in technical documentation. For more information about Confluence macros, see Working with Macros.

On this page:
- Auto-Generating a Table of Contents for Page Content
- Drawing Attention to Elements of a Page
- Putting Content inside Customisable Panels
- Inserting Anchor Links on Pages
- Structuring Content using Sections and Columns
- Making your Documentation more Engaging by Embedding Videos

Auto-Generating a Table of Contents for Page Content

It is important to make it easy for viewers to jump to the section of a Confluence page that they are most interested in. The Table of Contents macro helps you navigate lengthy pages by summarising the content structure and providing links to headings used on the page.

Click here to see a common example >>

2. Each feature in the release is a heading on the page.  
3. You can generate a list of hyperlinks to each of the features in the release notes by inserting the Table of Contents macro:
4. The image below shows the Table of Contents macro inserted at the top of the 'Release Notes' page. Note that we have excluded the 'Highlights of Confluence 4.0' heading from the table of contents by modifying the macro's parameters.

5. The image below shows the macro parameters specified in the macro browser. Note the 'Minimum Heading Level' and 'Maximum Heading Level' parameters.
Drawing Attention to Elements of a Page

Often when creating documentation there are elements of a page that you want to highlight, or draw the the viewers attention to. Confluence ships with the following macros that help you focus a viewer's attention to a note, information, tip or warning.

Click here to see common examples >>

**Note Macro**

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
</table>
| The Note macro allows you to highlight a note on a Confluence page. It creates a yellow coloured box surrounding your text, as shown to the right. | ☢️ Draft in progress
This document is a draft and is under development. |

See [Note Macro](#) for more examples and instructions.

**Info Macro**

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
</table>
| The Info macro allows you to highlight helpful information on a Confluence page. It creates a blue coloured box surrounding your text, as shown to the right. | 💡 Did you know?
Confluence is the best wiki ever. |

See [Info Macro](#) for more examples and instructions.

**Tip Macro**

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
</table>
| The Tip macro allows you to highlight a helpful tip on a Confluence page. It creates a green coloured box surrounding your text, as shown to the right. | ✅ Learn more
Check out this blog post: [Technical Writing in a Wiki: Technical Communicators Explain How & Why?](#) |

See [Tip Macro](#) for more examples and instructions.

**Warning Macro**
The Warning macro allows you to highlight a warning note on a Confluence page. It creates a red coloured box surrounding your text, as shown to the right.

See [Warning Macro](#) for more examples and instructions.

**Putting Content inside Customisable Panels**

The [Panel macro](#) allows you to place content inside a customisable coloured panel. This is particularly useful when you want to clearly separate elements on a page.

**Click here to see a common example >>**

1. You are documenting a procedure which involves a number of steps.
2. You want to call out the steps of the procedure from the rest of the page by placing it inside a coloured box, or panel.
3. You can create a coloured panel using the Panel macro.
4. The image below shows the parameters set for the panel using the macro browser.

**Inserting Anchor Links on Pages**

Anchor links can be especially useful when navigating between sections of a long document or when you want to link to a segment of a page from another page. The [Anchor macro](#) allows you to link to specific parts of a page.

**Click here to see a common example >>**

1. You are documenting part of a user guide.
2. The page is split into multiple sections.
3. After each section you want to provide a link for viewers to click, taking them back to the top of the page.
4. To achieve this you first must create an anchor at the top of the page using the Anchor macro. You can give the anchor any name you like. In the image below, the anchor at the top of the page will be named 'top'.

5. The anchor placeholder will appear to indicate where your anchor link is located on the page:
6. Create a link to the anchor, anywhere on the page, using the Link Browser. The image below shows a link to the anchor called 'top' by using the hash '#' followed by the name of the anchor you created earlier, with an alias of 'Return to Top'.

See Working with Anchors for more examples and instructions.

Return to top of page

Structuring Content using Sections and Columns

Sometimes it is necessary to structure content into sections and columns. The details are in Working with Page Layouts and Columns and Sections.

- Page layouts offer a set of predefined columns and sections.
- The Section and Column macros allow more flexibility. You can set the width of the columns, and put the sections and columns in any part of the page.
- You can create any number of sections on a Confluence page using the Section macro.
- Each section can contain any number of columns, created using the Column macro.
- Columns can either have a fixed width, specified in pixels, or a dynamic width, specified as a percentage of the page width.
- Note: A column must be created inside a section.

Click here to see a common example >>

The images below show part of a Confluence page with two sections (outlined in red), each with two columns (blue) of different widths.
1. **Section 1:**

   1. Put a name to your face
   2. Learn how content is organized
   3. Get familiar with the Confluence screens
   4. Start creating content
   5. Add a panel to your page

   ![Put a face to your name](image)

   *Your profile picture is used to identify you across Confluence. Upload your own picture via your Profile.*

2. **Columns in section 1 – left column has a fixed width of 400 pixels:**

   ![Put a face to your name](image)

   *Your profile picture is used to identify you across Confluence. Upload your own picture via your Profile.*
Making your Documentation more Engaging by Embedding Videos

Pictures can be worth a thousand words. The same can be said for videos. Often, it's easy to explain a concept or demonstrate a procedure using a video. The Widget macro allows you to embed web content, including YouTube, Episodic and Vimeo videos, in a Confluence page.

Click here to see a common example >>

1. You release a new version of your product.
3. The marketing team creates a video demonstrating the new features of the release and uploads it to YouTube.
4. You can embed the video in your Release Notes using the Widget macro, for playback on your Confluence page.
   a. Select ‘Other Macros’ from the ‘Insert’ menu in the Rich Text Editor toolbar.
   b. Search for the ‘Widget Connector’ in the macro browser.
c. Insert the URL of your YouTube video into the ‘Web Sites Widget URL’ field.

![Insert 'Widget Connector' Macro]

d. Click ‘Insert’ and save your page.

![Confluence 4.0 Release Notes]

See Widget Connector Macro for information on the supported services and for more usage examples.

Return to top of page

Next Steps

Take a look at Confluence Plugins for Technical Documentation.

Confluence Plugins for Technical Documentation

This page is part of the guide to developing technical documentation on Confluence. In this section we highlight some of the Confluence plugins that are useful for technical writers in designing and developing documentation.

A plugin is an extension module that you can add to your Confluence site, to extend the wiki’s core functionality. It is similar to an add-on for your browser. Confluence plugins may be developed by Atlassian or by third parties. To find the plugins featured on this page, and other plugins too, visit the Atlassian Plugin Exchange.
This page features plugins that provide the following extended capabilities:

- **Extended Wiki Markup Features**
  - Quick Overview of Macros
  - Composition Plugin
  - Using the Composition Plugin to Outline Text Blocks
  - Using the Composition Plugin to Add Tabs to a Page
  - Using the Composition Plugin to Flow your Text around Images
  - Scaffolding Plugin

- **Extended Version Control**
  - Scroll Versions
  - Attachment Checkout Plugin

- **Drawing Tools**
  - Gliffy Plugin
  - Notes
  - Further Reading

Quick guide to the plugins featured below

- **Scroll Versions** – Adds functionality for sophisticated version management, enhanced content reuse, support for context-sensitive help, permalinks, and duplicate page titles. This is a commercial plugin.
- **Composition plugin** – Provides macros which allow finer control over the layout (composition) of a page. For example, outline text; add tabs to your page; flow your text around diagrams. This plugin is free.
- **Scaffolding plugin** – Provides macros for creating 'permanent templates' and editable forms. Commercial.
- **Attachment Checkout plugin** – Adds check-out/check-in functionality for Confluence attachments. Free.
- **Gliffy plugin** – Provides an embedded diagram editor. Commercial.

Plugins featured in other parts of this guide

- **Copy Space plugin** – Provides an easy way of copying a space within a Confluence site. Free. See Creating your Technical Documentation Space.
- **Multi Excerpt plugin** – Enables you to have more than one excerpt (re-usable chunk) on a page. Commercial. See Re-using Content in Technical Documentation.
- **Ad Hoc Workflows plugin** – Provides advanced workflow features. Commercial. See Managing the Life Cycle of your Technical Documentation.
- **Content Publishing plugin** – Publishes content from a master space to a published space. Commercial. See Managing the Life Cycle of your Technical Documentation.
- **Scroll PDF Exporter** – Provides advanced PDF export features. Commercial. See Providing PDF Versions of your Technical Documentation and Exporting and Printing Technical Documentation.
- **Scroll EPUB Exporter** – Outputs an ebook in the common EPUB format that can be read on iPads, iPhones and any other ebook reader. Commercial.
- **Scroll HTML Exporter** – Enables the delivery of Confluence content from a web server. It converts the pages into static HTML pages that can be uploaded to a web server. The output of the Scroll HTML exporter can also be used as an input to produce other HTML-based help formats such as WinHelp and HTML Help. Commercial.
- **Scroll EclipseHelp Exporter** – Enables you to collaborate and author all your content in your wiki, and generate embeddable online help for Eclipse-based applications. Commercial.
Extended Wiki Markup Features

All wiki markup extensions are provided by macros in Confluence. Some macros are built in to Confluence. Other macros are supplied by plugins.

Quick Overview of Macros

Before looking at plugins, let's take a quick look at macros in general. There are two ways to add a macro to your page:

- Use the macro browser. This is the simplest and recommended way.
- Or insert the macro's name in curly brackets into the text of your page and specify the parameters.

Click here to see an example of a macro >>

The following code uses the {include} macro to insert the text from the page called 'My Page'. The text will appear on the page where the macro is used:

```
{include:My Page}
```

The resulting page will look like this:

```
Page text...
{text from the 'My Page' page}
page text...
```

A number of macros are shipped with your Confluence installation by default. See Working with Macros. Below we describe some plugins that provide additional useful macros for Confluence:

Composition Plugin

The Composition plugin adds some formatting features to compose a page in a more flexible way. Using the macros provided by the Composition plugin, you can:

- Outline your text blocks.
- Add tabs to a page.
- Flow your text around the images or diagrams on the page.
Using the Composition Plugin to Outline Text Blocks

Use the {cloak} macro to outline a text block.

Usage: The following code creates a text block named ‘SeeAlso’ for the outlined ‘See Also’ section within a page. The text block with id='SeeAlso' will be hidden after the ‘See Also’ title:

```plaintext
{composition-setup}
  h2. {toggle-cloak:id=SeeAlso} See Also
  {cloak:id=SeeAlso}
  h3. Working With Macros:
      [Link 1]
      [Link 2]
  h3. Working with Rich Text Editor:
      [Link 3]
      [Link 4]
  {cloak}
```

Alternatives: You can also use the {expand} macro available in Confluence by default, but this macro can outline only text of the same level and cannot hide headings within the text. The {expand} macro does not require parameters and just hides the text placed between the {expand} tags.

Note: If you need to outline a text block containing nested headings, consider the text structure. Maybe the block is too big. You could create a child page from this block to decompose the whole text. Then you can include and outline the text block using the {include} macro within {expand}.

Using the Composition Plugin to Add Tabs to a Page

Use the {deck} and {card} macros to separate content between tabs on the same page.

Usage: The following code creates two tabs with client information:

```plaintext
{composition-setup}
  h1. Client Name
  {deck:id=ClientName}
  {card:label=Basic}
  Client Company Name: Company
  [Client Web Site|http://url.com]
  Our projects: [Project1|Project1 Home]
  {card}
  {card:label=Contacts}
  Company CEO: John Brown, e_mail: brown@company.com
  {card}
  {deck}
```

The tabs on a page will look like this:
Using the Composition Plugin to Flow your Text around Images

Use the {float} macro to make your text flow around images or diagrams.

**Usage:** The following code demonstrates how a picture can be surrounded by the description, as often shown in printed publications:

```
{composition-setup}
{float:left}
!shakespeare.jpg!
{float}

William Shakespeare (baptised 26 April 1564; died 23 April 1616) was an English poet and playwright, widely regarded as the greatest writer in the English language and the world’s pre-eminent dramatist.
...
```

The page will look like this:

For more macros, see the [Composition plugin page](#).

**Scaffolding Plugin**

The Scaffolding plugin allows you to create sophisticated page templates in order to add content easily and fast. Scaffolding templates are suitable for dynamically-filled data and allow people to create pages by completing form fields and selecting values from drop-down lists.

The Scaffolding templates are useful for creating pages with a well-determined structure, such as:
- API methods or property descriptions.
- Constant list.
- Feature description.
- Software requirement specifications.

**Example:** The following Scaffolding template creates a description of an API method:

```
h3. Method Name
{text-data:methodName|required=true}{text-data}

h3. Method Description
{text-data:methodDescription|type=area|required=true|width=100%}description{text-data}

h3. Parameters
{table-data:parameters}
|| Name || Type || Mandatory || Description ||
| {text-data:paramName}ParamName{text-data} |
{list-data:paramType}{list-option:Number}Number{list-option}{list-option:String}String{list-option}{list-option:DateTime}DateTime{list-option}{list-option:MACaddress}MACaddress{list-option}{list-option:IPaddress}IPaddress{list-option}{list-data} |
{list-data:paramMandatory}{list-option:Optional}Optional{list-option}{list-data} |
{text-data:paramDescription|type=area}param description{text-data} |
{table-data}

h3. Return Value
The returned value is an XML structure of the following format:

```
{code:xml}
{code}
```
Where elements mean:
{table-data:returnValues}
|| Name || Type || Description ||
| {text-data:paramName}ParamName{text-data} |
{list-data:paramType}{list-option:Number}Number{list-option}{list-option:String}String{list-option}{list-option:DateTime}DateTime{list-option}{list-option:MACaddress}MACaddress{list-option}{list-option:IPaddress}IPaddress{list-option}{list-data} |
{table-data}

h3. Remarks
{text-data:remarks}remarks{text-data}

h3. See Also
```
This template will look like this:
For more information on how to create templates in Confluence, see Adding a Template.

Alternatives: Confluence includes built-in templates which are useful for static data and simple text. For more information, see Working with Templates.

Notes: The Scaffolding (and any) template changes will affect only new pages created from the modified template. In order to change the existing pages, you need to edit each individual page and add or modify the formatting manually.

For more information on Scaffolding, see the Scaffolding plugin page.

Extended Version Control

Scroll Versions

Scroll Versions enables you to set up and manage concurrent versions of your documentation in a single space. Multiple versions of software, different product variants, and even multiple translations of documentation can be managed. Changes to pages are scheduled for a specified version and then published all at once. See the Scroll Versions documentation for an overview of the key features.

Video: Scroll Versions - Version Management for Confluence (4:20)

Attachment Checkout Plugin

The Attachment Checkout plugin adds check-out/check-in functionality for Confluence attachments. It allows you to control the versions of the documents attached to a page with the same file name.
Attachment checkout allows Confluence to warn contributors that the document is being edited by someone else. Note that there are no merge features for attachments.

Example: To store and control the versions of Project Vision documentation received from a customer on the Confluence page:

<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Creator (Last Modifier)</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client1_Project1_Vision.doc</td>
<td>30 kB</td>
<td>Flavortti Stepalina</td>
<td>Checkout</td>
</tr>
<tr>
<td>Version 2 (30 kB - Flavortti Stepalina - Nov 8, 2010 11:19:49 AM MST)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Version 1 (30 kB - Flavortti Stepalina - Nov 8, 2010 11:19:03 AM MST)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

For information on working with attachments, see Working with Attachments.
For information on attachment versioning, see Attachment Versions.

Drawing Tools

Gliffy Plugin

The Gliffy plugin provides an embedded diagram editor. Gliffy allows you to create and edit diagrams directly from a Confluence page. It supports various diagram types (UML, business process, and so on).

Alternatives: As an alternative you can use the standalone version of Gliffy available at http://www.gliffy.com/. Gliffy online has a free basic version.

For more information, see the Gliffy plugin page.

Notes

- **Installing plugins.** If you decide to use additional plugins, your site administrator will need to install the plugins into your Confluence site. Refer to the documentation on installing plugins.
- **Plugin support.** Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

Further Reading

- A blog post about useful plugins and tools for exporting and importing content from/to Confluence: Technical Writing in a Wiki: Single Source Publishing (November 2010).
- Website for exploring and downloading the available plugins: Atlassian Plugin Exchange.
- Documentation on installing and configuring plugins: Installing and Configuring Plugins using the Universal Plugin Manager.
- Documentation on using macros: Working with Macros.
- Further Reading about Developing Technical Documentation on Confluence

Further Reading about Developing Technical Documentation on Confluence

This page is part of the guide to developing technical documentation on Confluence. Once you have absorbed all the information in this guide, you may be ready for more reading. 😊

- The Confluence documentation: Confluence Latest.
- Tips from other technical writers, in the Confluence documentation: Tips of the Trade.
- Blog post about using Confluence for online help: Using a wiki for online help.
- Blog posts about version management in Confluence with Scroll Versions plugin:
  - Announcing Scroll Versions.
  - Version management gets serious with Confluence Scroll Versions plugin.
- Now you have your documentation space up and running, it's fun and rewarding to use the full power of the wiki to engage your readers and embed content from other social sites. Here is a blog post and presentation slides on engaging readers in the documentation.
- A Wiki as Platform Extraordinaire for Technical Communication

Let us know about more links

We plan to add more links to this page or to the 'Tips of the Trade' page. Let us know of any we have missed.

Developing a Knowledge Base on Confluence Wiki

Welcome! This is a guide to using Confluence as a knowledge base. You will find this guide useful if you want to produce a knowledge base with a survey, content curation, intelligent search and standardized templates.

In these pages, we'll show you how to use Confluence to achieve a high-functioning knowledge base, including these features:

- **Using Templates**
- **Subscriptions** (RSS or Email)
- **Exporting** articles (PDF or Word)
- **Organizing content** (hierarchically or by label)
- **Involving Customers** (using comments)
- **Populating data**
- **Scripts** to update content programatically
- A "Was This Helpful?" survey
- **Intelligent searching** algorithms (higher ranked articles are promoted in search results)
- **Targeted searching** across specified Confluence spaces and content types
- How to show **related content**
- Extensive **metrics and reporting**
- **Maintenance**

PAGES IN THE GUIDE

- Creating Your Knowledge Base Space
- Using Templates and Formatting Macros in a Knowledge Base
- Proactive Communications in a Knowledge Base
- Additional Plugins for a Knowledge Base

RELATED TOPICS

- Confluence User's Guide
- Confluence Administrator's Guide

Creating Your Knowledge Base Space

This guide is for people who want to develop and publish a knowledge base using Confluence. You'll find Confluence useful because it combines professional web publishing features with the ease-of-use and flexibility of a wiki - requiring a low barrier to entry, but high quality output for all your team members. Confluence provides all of the collaborative features for your reports (such as automatic versioning, granular enterprise security, email and RSS subscriptions, and JIRA integration). This page is a quick-start guide to creating a wiki space for a knowledge base.
Quick guide to creating a knowledge base space

- Add a Space and Select the Documentation Theme
- Set the Space Permissions
- Customise the Title and Content of the Homepage
- Customise the Documentation Theme
- Create an Inclusions Library to Manage Reusable Content
- Create the Table of Contents
- Make your Knowledge Base Proactive with a Subscribable RSS Feed
- Insert Google Analytics Code into Confluence's Custom HTML
- Set up Atlassian's Content Survey and Reporting Plugin

The rest of this page gives more details of the above procedure.

On this page:

- Step 1. Add a Space and Select the Documentation Theme
- Step 2. Set the Space Permissions
- Step 3. Customise the Title and Content of the Homepage
- Step 4. Customise the Documentation Theme
- Step 5. Create an Inclusions Library to Manage Reusable Content
- Step 6. Create the Table of Contents
- Step 7. Make your Knowledge Base Proactive with a Subscribable RSS Feed
- Step 8. Insert Google Analytics Code into Confluence's Custom HTML
- Step 9. Set up Atlassian's Content Survey and Reporting Plugin
- Note about Plugin Support

Step 1. Add a Space and Select the Documentation Theme

Below is a quick guide to adding a space. See Setting up a New Global Space for a full description.

1. Go to the Confluence dashboard and click Add Space located on the 'Spaces' tab. 
   Hint: If you cannot see the Add Space link, this means that you do not have permission to add spaces. Please contact your Confluence administrator.
2. In the 'Create Space' screen, enter a space name and a short, unique space key.
3. Leave the permission settings as default, or choose to allow only yourself to view or contribute content to this space. You can change these settings later and with more flexible options.
4. Select the Documentation Theme.
5. Click OK.

The homepage of your new space will appear. Because you created the space, you are the space administrator. Now you can do some basic configuration, as described in the sections below.

Step 2. Set the Space Permissions

Define the space permissions to determine who can do what in your new space.
1. Choose **Browse > Space Admin**.
2. Click **Permissions** in the left-hand panel.
3. Confirm your administrator access as prompted.
4. Click **Edit Permissions**.
5. Set the permissions to suit your needs then click **Save All**.
   - You can add **groups** and/or individual **users** to the list, then select the permissions for each group or user.
   - You can also set the permissions for **anonymous** users – these are people who have not logged in to the wiki. Anonymous access is available only if enabled for the entire Confluence site. We recommend this setting if you are using this space for Technical Documentation or for a Knowledge Base.
   - Note that you can change these permissions at any time. You may want to restrict the permissions to specific groups now, and later open the space to more people.

**A Bit More about Permissions**

Confluence has a robust and granular permissions scheme that you can use to determine who can view, comment on and even update the documentation. There are three levels of permissions in Confluence:

- Global permissions apply across the entire site.
- Space permissions apply to a space.
- Page restrictions allow you to restrict the editing and/or viewing of a specific page. Below we discuss a way of using these in the draft, review and publishing workflow.

Space permissions in Confluence are simple yet granular enough to be useful for technical documentation. You can:

- Use the permission levels to control who can create pages in the space, delete pages, create comments, delete comments, administer the space, and so on.
- Grant a permission level to one or more users, and/or to one or more groups, and/or to anonymous users.

**Terminology:**

- 'Anonymous' means people who have not logged in to the wiki. These are users that won't affect your the number permitted by your license.
- The 'confluence-users' group is the default group into which all new users are assigned. Everyone who can log in to Confluence is a member of this group.

For example, you might allow 'Anonymous' users specific view and content creation rights so that they can access and engage with your knowledge base while your team lead (Bill) maintains full Space Administration rights.
Step 3. Customise the Title and Content of the Homepage

When you created your space, Confluence created a homepage with default content and a default title, 'Home'. You will want to change the title and content.
1. Go back to your space homepage, by clicking the space name in the breadcrumbs at the top of the screen. In the example below, the space name is 'My Knowledge Base':

![View Space Permissions](image)

2. The space homepage appears. By default, the page title is 'Home'.

3. Click **Edit**.
4. Change the title to suit your needs.
5. Update the content to suit your needs.  
   *Hint:* If you do not know what to add yet, just add a short description. You can refine the content of the page later. Take a look at an [example of a homepage](#).
6. Click **Save**.

**Step 4. Customise the Documentation Theme**

When you added this space you chose the Documentation theme, which provides a left-hand navigation bar and a good look and feel for a knowledge base. If necessary, you can configure the Documentation theme to add your own page header and footer or to customise the default left-hand navigation bar. These customisations affect the online look and feel of your knowledge base. See [Configuring the Documentation Theme](#) for the full description in our product documentation.
1. Choose **Browse > Space Admin**.
2. Click **Themes** in the left-hand panel.
3. If the space is not yet using the Documentation theme, apply the theme now.
4. Click **Configure theme** in the yellow area of the ‘Current Theme’ section at the top of the page.

### Current Theme

The current theme controls the layout and colours of this space.

### Documentation Theme

This theme is well suited for structured content, such as documentation. It features a table of contents (page tree) on the left, making it easier to see the structure of a space and move from page to page. You can customise the left-hand panel, page header and page footer. This theme supports Firefox, Safari and Internet Explorer 7+.

### Configure theme - further customise this theme's options

5. The 'Documentation Theme Configuration' screen appears. Customise the left-hand navigation bar, header and footer to suit your needs. Details are in the documentation. Here are some hints:

- The **Page Tree** check box determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.
- The **Limit search results to the current space** check box determines whether Confluence will search only the current space or the whole Confluence site. This setting affects the default search. Viewers can override it each time they do a search.
- Enter text, images, macros and other wiki markup into any or all of the three text boxes for the left-hand navigation bar, header and footer. You can use the **Include macro** and the **Excerpt Include macro** to include re-usable content.
- Any content you add to the navigation panel will appear above the default page tree.
- If you like, you can remove the default page tree (by unticking the box) and add your own, customised version of the Pagetree macro instead.

6. Click **Save**.

### Example of a Customised Footer

Take a look at the footer of a page in the **Crowd documentation space**.

To produce the above footer, we have the following content in the footer panel in the Documentation theme configuration screen:
Here it is in text form:

The above content consists of two Include macros.

- The first macro includes a page called _Documentation Footer. This page contains the big blue buttons and hyperlinked text.
- The second macro includes a page from a different space, the ALLDOC space, called _Copyright Notice. This page includes our standard copyright notice, used in all our documentation spaces.
- In each include macro, the content has been drawn from an inclusions library, a hidden content repository, from which you can store frequently and re-usable content throughout your knowledge base space.

**Step 5. Create an Inclusions Library to Manage Reusable Content**

Using Confluence, you can dynamically include content from one page into another page. You can include a whole page into another one, using the Include macro. You can also define an ‘excerpt’ on a page, and then include that excerpted text into another page using the Excerpt Include macro.

To organise your re-usable content, we recommend that you create a set of pages called an ‘inclusions library’.

1. Choose Browse > Pages.
2. Choose Add > Page. This will add a page at the root of the space, at the same level as the homepage.
3. Enter a suitable title. We use '_InclusionsLibrary'. The unusual format of the title helps to let people know this page is special.
4. Enter some content on the page. We enter text explaining the purpose of the inclusions library and how to re-use the content. You can copy our text by clicking through to one of the example pages listed below.
5. Add child pages containing your re-usable content. See the examples of our own inclusions libraries listed below.

Some notes about inclusions libraries:

- The inclusions library is not a specific feature of Confluence. The pages in the inclusions library are just like any other Confluence page.
- The pages are located at the root of the wiki space, not under the homepage. This means that they will not appear in the table of contents on the left and they will not be picked up by the search in the left-hand navigation bar either.
- The pages will be picked up by other global searches, because they are just normal wiki pages.
- We have decided to start the page name with an underscore. For example, '_InclusionLibrary'. This indicates that the page is slightly unusual, and will help prevent people from changing the page name or updating the content without realising that the content is re-used in various pages.

**Examples of Inclusions Libraries**

Here are some examples in our documentation:
Step 6. Create the Table of Contents

Create the table of contents for your knowledge base, by adding the top-level pages for all the usual sections. For instance, our Technical Support Team designed the following pages in the Confluence Knowledge Base on our public wiki:

- Browse Articles by Label
- Browse Articles by Top Ranked Content
- Browse Articles by Page Tree Hierarchy
- Browse Articles by Version
- Subscribe to Proactive Announcements

1. Go back to your space homepage, by clicking the space name in the breadcrumbs at the top of the screen.
2. Choose Add > Page. This will add the page as a child of the homepage.
3. Enter the page title, for instance: 'Browse Articles by Label'.
4. Enter the content of the page.
   - Hint: If you do not know what to add yet, just add a short description then refine the content of the page later. If you like, you can follow a similar outline as the Confluence Knowledge Base and add the Label List macro. This displays a hyperlinked alphabetical index of all labels within the current space. As you create content in this space and apply appropriate labels, the macro will update this page automatically.
5. Click Save.

Now do the same for all the sections of your Knowledge Base that you wish to appear in the left-navigation bar of the Documentation theme. Below is what the Table of Contents looks like for our Confluence Knowledge Base:

```
Browse Content by Label

Click on one of the labels below to find related content:

Below are the 181 labels used in Confluence Knowledge Base listed alphabetically. Click a label to see its associated content.

A-B: apache, applinks, appserver, attachments, backup, bamboo, build
C: cache, calendar, camelcase, camel_case, captcha, case_sensitivity
D: dashboard, database, db2, deadlock, directory, doc_import, documentation_theme, dynamic_tasklist

5. Click Save.
```
Step 7. Make your Knowledge Base Proactive with a Subscribable RSS Feed

Let's populate the knowledge base homepage with content by creating an RSS feed that your coworkers and customers can subscribe to and receive important updates on your knowledge base and technical alerts on your products.

This is a strategy that Atlassian's Technical Support Team uses to create a proactive knowledge base that provides technical alerts to customers and coworkers and helps solve support issues before they're even created.

By following the quick guide below, you'll create a homepage similar to the one Atlassian's Technical Support Team has created for the Confluence Knowledge Base on our public wiki and turn your knowledge base from reactive to proactive:

---

**Technical Announcements**

Copy the RSS feed into your favourite RSS reader:

<table>
<thead>
<tr>
<th>Important Technical Announcements for Confluence</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Blog Posts</strong></td>
</tr>
<tr>
<td>📜 End of Support and New Support Announcements for Confluence 3.5 and Confluence 4.0 created by Sarah Maddox [Atlassian Technical Writer] Confluence Knowledge Base Jan 06</td>
</tr>
<tr>
<td>📜 Welcome to the Confluence Technical Announcements Blog created by Jeremy Largman [Atlassian] Confluence Knowledge Base Dec 22</td>
</tr>
<tr>
<td>📜 Technical Alert for Confluence 3.4 - Login Errors when Delegating to Crowd created by Adam Laskowski [Atlassian] Confluence Knowledge Base Oct 14</td>
</tr>
</tbody>
</table>

View more recent blog posts
Creating your RSS Feed

Confluence can filter spaces by content type. To filter your knowledge base for 'blog post' content, do the following:


   ![Browse menu]

   - **Pages**
   - **Blog**
   - **Labels**
   - **Attachments**

2. Copy this URL to your clipboard.
3. Create an RSS feed for the URL of your knowledge base space. Now your RSS feed will consist of any blog posts created in the knowledge base space.

Highlighting Your Technical Announcement RSS Feed

1. Go to your space homepage by clicking the appropriate breadcrumb in the top-left of your screen.
2. Click Edit.
3. Insert an 'h2' heading, such as 'Important Technical Announcements'.
4. Insert bold text that reads something like, 'Copy the RSS feed into your favourite RSS reader:'.
5. Choose Insert > Other Macros to open the Macro Browser.
6. Select the 'Panel' macro in the Macro Browser and specify your desired macro preferences. We recommend that you change the Panel Title, Border Style, and Background Color to further highlight the panel on the page.
7. Click Insert.

Insert a Blog Posts Macro

1. Click in the Panel macro placeholder and choose Insert > Other Macros to open the Macro Browser again.
2. Select the 'Blog Posts' macro in the Macro Browser and specify the following preferences:

   ![Blog Posts icon]
   **Blog Posts**
   Lists the most recent news items in the space.

   - **Content Type to Display**: Title
   - **Restrict to These Spaces**: Your knowledge base Spacekey
   - **Maximum Number of News Items**: 5
   - **Sort By**: Creation
   - **Reverse Sort**: Tick the box
3. Click Insert to insert the Blog Posts macro onto the page inside your Panel macro. Now your panel will display the last 5 blog posts created in your knowledge base space.
Inserting your RSS Feed into your 'Technical Announcement' Panel

First, let's create a link so that your coworkers and customers can view all of the blog posts in your knowledge base space. See Working with Links for a full description in our product documentation.

1. Place your cursor after/below the Blog Posts macro in the Panel macro placeholder.
2. Type: 'View more recent blog posts'.
3. Highlight this text and click **Link** on the editor toolbar.

### Insert Link

<table>
<thead>
<tr>
<th>Search</th>
<th>URL:</th>
<th>Web Link</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recently Viewed</td>
<td>View more recent blog posts</td>
<td>http://</td>
</tr>
<tr>
<td>Attachments</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

4. Select 'Web Link' and paste the link you copied to create your RSS Feed.
5. Click **Insert**.

Now, let's insert your RSS Feed into your panel by linking an image. See Linking an Image for a full description in our product documentation.

1. Attach an RSS Icon ![RSS 2.0](http://) to the page by dragging and dropping it into the editor (preferably below the link you just created). See Drag-and-Drop for a full description in our product documentation.
2. Click the RSS Icon image and then click the 'Align right' button on the editor toolbar.
3. Click **Border** in the image properties panel.
4. Link the RSS Icon by selecting the image and then clicking **Link** on the editor toolbar.
5. Click the 'Web Link' tab and insert the RSS Feed URL you created.
6. Click **Insert** to link your RSS Feed to the RSS Icon image.
7. Click **Save** to save your page and test your RSS Icon.

Congratulations! You have successfully created a proactive knowledge base.

**Step 8. Insert Google Analytics Code into Confluence's Custom HTML**

Now that you have a strong foundation for a knowledge base, it's critical to assess how effectively it services your customers. Google Analytics is a tool that gives you rich insights into your website traffic and marketing effectiveness. You are going to want to understand how your customers are accessing the resources in your knowledge base. This is a quick guide to inserting Google Analytics HTML code into Confluence so you can measure your knowledge base traffic.
1. If you don’t have one already, create a Google Account and then create a Google Analytics Account using your Confluence instance’s URL.
2. Copy the Google Analytics code to your clipboard.
3. Log into Confluence as a System Administrator or Confluence Administrator.
4. Go to the Confluence ‘Administration Console’. To do this:
   a. Choose Browse > Confluence Admin.
   b. Enter your password and click Confirm. You’ll be temporarily logged into a secure session to access the ‘Administrator Console’.
5. Click Custom HTML under ‘Look and Feel’.
6. Click Edit to insert custom HTML into your Confluence instance.

   ![Insert Custom HTML]

   At end of the HEAD
   At beginning of the BODY
   At end of the BODY

   Paste your Analytics code you have saved to your clipboard into the table labeled At end of the BODY.
   7. Click Save.

You can now monitor the activity and traffic for every page you create in your Confluence instance and Knowledge Base.

*Hint: If your knowledge base only represents a space within your greater Confluence instance, you can search Google Analytics for activity in the specific space by exclusively filtering for the space key.*

![Filter "Top Content" using a Space Key]

Read David Simpson’s blog post about [Tracking Confluence Usage with Google Analytics](https://www.atlassian.com) for more information.

**Step 9. Set up Atlassian’s Content Survey and Reporting Plugin**

Now that you can monitor the traffic and activity of your knowledge base, let's measure its effectiveness. When the [Content Survey and Reporting Plugin](https://confluence.atlassian.com/display/DOCS/Content+Survey+and+Reporting+Plugin) is activated for a space, it will generate a report that includes:

- Direct feedback from customers about article quality
- Amalgamated "composite score" results
- Answers to secondary questions, such as "Was the info complete?" or "Was the article well-written?".
- Rollup at-a-glance view of the metrics for the whole space.

Lastly, the Content Survey and Reporting Plugin will institute 'intelligent searching' which means that based on the results of the surveys, higher ranked pages are promoted in search results, so your best and most popular pages are found easiest. This is a quick guide for how to set up the Content Survey and Reporting Plugin.
This plugin only functions properly if the Documentation Theme is applied to the space. Let's install the Content Survey and Reporting Plugin using Confluence's Universal Plugin Manager.

### Installing the Content Survey and Reporting Plugin

1. Log into Confluence as a System Administrator or Confluence Administrator.
2. Go to the Confluence 'Administration Console'. To do this:
   a. Choose Browse > Confluence Admin.
   b. Enter your password and click Confirm. You'll be temporarily logged into a secure session to access the 'Administrator Console'.
3. Click Plugins under 'Configuration'
4. Click the Install tab of the UPM and search for the 'Content Survey and Reporting Plugin'.

#### Install

The Universal Plugin Manager allows you to view, manage and upgrade your installed plugins, as well as install new ones from the [Atlassian Plugin Exchange](https://plugins.atlassian.com).

<table>
<thead>
<tr>
<th>Manage Existing</th>
<th>Upgrade (5)</th>
<th>Install</th>
<th>Confluence Upgrade Check</th>
<th>Audit Log</th>
<th><img src="https://i.imgur.com/3kt.png" alt="Upload Plugin" /></th>
</tr>
</thead>
</table>

**Plugins to show:**

Search results

**Search:** content survey and reporting plugin

**Clear**

**Plugins matching "content survey and reporting plugin"**

- [Content Survey and Reporting Plugin](https://plugins.atlassian.com/plugins/survey-reporting)

Great for a Knowledge Base, Documentation or an Intranet, this plugin includes space-wide configurable surveys, reports, intelligent searching algorithms, top articles and dynamic content by labels macros, and multi-space QuickNav searching.

5. Click Install

Now that you've installed the Content Survey and Reporting Plugin, let's configure a survey:

### Configuring a Survey

1. Go to your space homepage by clicking the appropriate breadcrumb in the top-left of your screen.
2. Choose Browse > Space Admin.
3. Click Configure Survey under 'Knowledge Base Survey'. Here you can:
   - Add a question
   - Edit a question's text
   - Activate or deactivate a question
   - Edit the response text
4. Configure a 'Primary Question' for the survey

#### Primary Question: Was this helpful?

<table>
<thead>
<tr>
<th>Add an Additional Question:</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Edit Survey Completed Response (anonymous):</th>
<th>Thanks!</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Edit Survey Completed Response (user):</th>
<th>Thanks!</th>
</tr>
</thead>
</table>

5. Click Save.

Now that you've added a primary question, let's test out the plugin by adding it to the footer of the

---

*Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
Documentation theme so that every page within your Knowledge Base space includes your survey.

### Invoking the Content Survey and Reporting Macro

1. Go to your space homepage by clicking the appropriate breadcrumb in the top-left of your screen.
2. Choose **Browse > Space Admin.**
3. Click **Themes** under 'Look and Feel'.
4. Click **Configure theme** in the yellow area of the 'Current Theme' section at the top of the page.
5. Visit the 'Footer' section of the 'Documentation Theme Configuration' page and insert this recommended markup to achieve a nice layout of the Content Survey and Reporting Plugin:

   ```
   {section}
   {column:width=5%}
   {column}
   {column:width=90%}
   {panel}
   {kbsurvey}
   {panel}
   {column}
   {column:width=5%}
   {column}
   {section}
   ```

6. Click **Save** and go to your space homepage to view your Content Survey and Reporting Plugin in the footer of the page.

With the Content Survey and Reporting Plugin you can dramatically improve the quality of your knowledge base and the efficiency with which your team creates and maintains it. Here is an example of how our Technical Support Team uses the Content Survey and Reporting Plugin in the Confluence Knowledge Base:

### Help us improve!

- **Is this article helpful?**  
  - [ ] Yes  
  - [ ] No  
- **Is the content complete?**  
  - [ ] Yes  
  - [ ] No  
- **Is it well written?**  
  - [ ] Yes  
  - [ ] No

### Content Survey and Reporting Plugin Results:

Survey results are viewable by Space Administrators only. The plugin develops three results:

- **Pages with Results** - Determine page-by-page, which are you most effective knowledge base articles and which ones need improvement.
As you can see, the plugin develops a 'Composite Score' which ranks articles in search, so your highest scoring (best) content can be found most easily. The score is based on the last 32 votes cast, using the global search configuration. See Confluence Content Survey and Reporting Plugin for a full description on how Global Search boosting works.

- **Pages without Results** - These are the pages in you knowledge base without survey results.
- **Rollup Report** - This is the summary of all survey results. The report can be used to determine how effective your overall knowledge base content is.

### Searching Multiple Spaces from your Knowledge Base

As mentioned, the Content Survey and Reporting Plugin generates a composite score that ranks pages and articles within your knowledge base to make the highest (most well regarded) pages more retrievable by visitors. The plugin also improves Confluence search by allowing users to search multiple spaces without ever leaving your knowledge base space. This is really helpful for users that are unfamiliar with Confluence because they can keep the knowledge base as a point of reference within the greater instance of Confluence.

At Atlassian, our product knowledge bases and product documentation exist in the same Confluence instance so that we can make both available to 'Anonymous' users. Our Technical Support team uses the Content Survey and Reporting Plugin to allow visiting users to search for Confluence resources in the product documentation space from the Confluence Knowledge Base space. This provides the visitor twice the chances of finding an answer to their question.

In the image below, you can see the space specific search used in the left-navigation bar to find content related to Confluence in both the 'Documentation' and 'Knowledge Base' spaces. Pages in the 'Documentation' space are listed first and pages in the 'Knowledge Base' space are listed second.
If a user doesn't choose one of the recommendations from the quick search drop-down menu, the plugin will display a search results page inside the Knowledge Base space rather than directing them to the Confluence global search page. By keeping the visitor in the same space, it will help new users find the information they need and only navigate to pages they intend to, minimising confusion and the number of times a user has to hit the 'Back' button in their browser.

Note about Plugin Support

Before installing a plugin into your Confluence site, please check the plugin’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

Next Steps
Using Templates and Formatting Macros in a Knowledge Base

This page is part of the guide to developing a knowledge base on Confluence Wiki. We have already shown you how to create your knowledge base space. Now we offer an introduction to the templates that Confluence provides.

Quick guide to templates in Confluence

- A template is a page with predefined content that can be used as a prototype when creating other pages.
- Templates are available across the Confluence site (global templates) or per space (space templates).
- Both ‘global templates’ and ‘space templates’, as described on this page, define the content of a page. They do not define the content of an entire space.
- You can import predefined templates, including those shipped with Confluence and additional templates from the Atlassian Plugin Exchange.
- To create a template for an entire space, see our guide to creating your documentation space.

Space Information Design

One question that comes up is whether a knowledge base should be implemented as a decision matrix, with a multi-select or other list. We knew that most of our users visit our documentation directly from search engines. Early on, we learned that at least for us, Google Analytics was showing that most traffic was coming from search engines, not from within our site. See Metrics for a discussion on that. So, we knew to focus on optimising page titles and tags rather than focus on a decision matrix.

Confluence’s Built-in Feature Set

Page Templates

Confluence’s Page Templates are an easy place to start. Begin by choosing how you want your templates to look. Here’s how we made our page template:

```
h3. Symptoms
FILL IN SYMPTOMS HERE

h3. Cause
FILL IN CAUSE HERE

h3. Resolution
FILL IN RESOLUTION HERE

{htmlcomment}
ENTER SUPPORT TICKET LINKS
{htmlcomment}
```

The {htmlcomment} macro is part of Adaptavist’s Content Formatting Macros, a handy plugin.

You might consider the scaffolding plugin or Form Field Markup for filling out forms. Our support engineers are quite used to using wiki markup (we live and breathe Confluence!), so we left this template as is.

Construct a Home Page: Section, Panels, RSS, and Notifications

Check out the Confluence Knowledge Base Home. The colored content in the middle of the page is an
amalgamation of panel, rss and attachment macros. Go to Tools >> Wiki Markup to see.

Wondering how we just made Tools >> Wiki Markup in a different font in the sentence above? Use the {{ }} notation to get the courier font, which you can use for breaking out text. And this would be, of course, a {tip}. Remember, you can visit Tools >> Wiki Markup on this page as well!

The wiki markup there is a little confusing, but it breaks down like this:

1. A Section macro, defining the top and bottom of the page
2. Column macros, dividing the panels into three
3. Panel macros, with hot, hot, hot html colours
4. Content By Label Macros
5. An RSS Icon, embedded as an attachment, with a link to the RSS feed. Notice the magic on this one:

![rss20.gif](http://confluence.atlassian.com/createrssfeed.action?types=page&sort=created&showContent=true&spaces=CONFKB&labelString=conf32&rssType=rss1&maxResults=50&timeSpan=120&publicFeed=true&title=Confluence+3.2+Knowledge+Base+Articles&showDiff=false)

That's a link, with the attachment as the alias, an alignment parameter, and the URL to the RSS feed. Cool, right?

Exporting Pages

These are built-in Confluence features. Check Page Exports. You can learn how to customise the PDF export as well.

Content Macros

Besides the ones listed above, some favourite macros for formatting content around the site are the Tip, Info, Warning, and Note Macros, ad the Code macro. They make things look great. We also use Adaptavist’s Content Formatting Macros when we really want to bring our A-game.

Every once in a while we get mileage out of the (nomarkup) user macro, when we want to discuss using a macro itself. I suppose that’s because Confluence is one of the products we support! It might be useful for other reasons...

JIRA Issues Macro

Using JIRA for bug tracking? You can’t expect your users to necessarily have exactly the right JQL filters to show the appropriate topics. We have some nice JIRA Issues Macros on display. One of my favourites is in the JIRA KB’s Causes for OutOfMemory Errors:

```
{jiraissues:url=http://jira.atlassian.com/sr/jira.issueviews:searchrequest-xml?temp/SearchRequest.xml?jqlQuery=project+%3DJRA+AND+issuetype+in+%28Bug%2C+Improvement%29+AND+component+%3D+%22Performance+-+Memory+leaks%22+ORDER+BY+key+DESC&tempMax=200|columns=fixversion;summary;status;key|anonymous=true}
```

Notice the JQL there including components and sorting, plus the specific columns.

Labels

Sometimes, an article needs to be cross listed. For that we label our articles. Some great macros to use for this
Next Steps

You now have a good idea of how Confluence templates work. What next? Take a look at Proactive Communications in a Knowledge Base.

Proactive Communications in a Knowledge Base

This page is part of the guide to developing a knowledge base on Confluence Wiki. We have already shown you how to create your knowledge base space and how to use templates and formatting macros. We touched a bit on creating proactive communications in Creating your Knowledge Base Space, and discuss a bit further here.

Quick guide to proactive communications

- A template is a page with predefined content that can be used as a prototype when creating other pages.
- Confluence can either produce or consume rss feeds
- Both the rss and blog-posts macro are a good way to show summaries

Proactive Alerts

Sending technical alerts to customers is a great way to keep customers and staff informed, and good way to reduce support load. At Atlassian we use the Knowledge Base both to consume and produce proactive content for which customers can opt in. This page describes how to achieve that.

Using Confluence as a producer

- The Working with Blog Posts describes how to produce blog posts from Confluence.
- Emailing a Page is a great way to send mass emails to users or an email distribution list.

Using Confluence as a consumer

Even if your Confluence instance isn't producing your proactive content, it can consume and display it in a prominent way:

- The RSS Feed Macro can consume content from any RSS feed on the Internet.
- We use the Blog Posts Macro for It looks especially handsome in a panel, accentuated by an RSS image in a link. Here's the wiki markup:

```markdown
h4. Technical Alerts
{panel:title=Important Technical Alerts for Confluence| borderStyle=solid| borderColor=##f93| titleBGColor=#fc9| bgColor=##ccc}
{blog-posts:content=title|max=5|sort=modified|spaces=CONFKB|time=30d} *{View more recent blog posts}[http://confluence.atlassian.com/pages/viewrecentblogposts.action?key=CONFKB]*
{{!!CONFKB:Confluence Knowledge Base Home|rss20.gif|align=right|http://confluence.atlassian.com/createrssfeed.action?types=blogpost&blogpostSubTypes=comment&blogpostSubTypes=attachment&spaces=CONFKB&title=Confluence+KB+-+Important+Technical+Alerts&labelString=techalert&excludedSpaceKeys%3D&sort=modified&maxResults=10&timeSpan=30&showContent=true&showDiff=true&confirm=Create+RSS+Feed|showTitleOnly=true}
{panel}
```

Note that the blog posts macro can display mail! Use it to highlight mail you've sent as alerts, after archiving mail.
Next Steps

You now have a good idea of how to do proactive communications. Next up, consider Additional Plugins for a Knowledge Base in more detail.

Additional Plugins for a Knowledge Base

This page is part of the guide to developing a knowledge base on Confluence Wiki. This page includes additional plugins that might expand your usage.

Useful Plugins for a Knowledge Base

These are some great plugins for Confluence as a Knowledge Base:

- The Content Survey and Reporting Plugin gives a good report on popular and unpopular content.
- The Archiving Plugin flags old content.
- The Ad Hoc Workflows Plugin or Content Publishing Plugin, which manages workflows and a review process.

Note about Plugin Support

Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

Bye

Hope you enjoyed the tutorial! Have a chocolate, and please share with us your experiences. You can comment directly on this page or email us at .

Developing an Intranet on Confluence Wiki

This guide is for people who are using Confluence as a platform for an intranet. You will find this guide useful if you want to create a space where your team can collaborate and share information.

Quick guide to creating an intranet space

- Add a space.
- Set the space permissions.
- Customise the title and content of the home page.
- Subscribe to email notifications for any updates made to the space.
- Manage your existing Office documents.
- Import page templates.
- Set up your personal space.
- Publish a blog post.

The rest of this page gives more details of the above procedures.

Step 1. Add a Space

Below is a quick guide to adding a space for your team.
1. Go to the Confluence dashboard and click the 'Add Space' link.
2. The 'Create Space' screen appears. Enter a space name and a short, unique space key.
3. Leave the permission settings as default, or choose to allow only yourself to view or contribute content to this space. You can change these settings later and with more flexible options.
4. Select a theme. We recommend the 'Global Look and Feel' theme for an intranet.
5. Click 'OK' to add the space to your Confluence site.

The home page of your new space will appear. Because you created the space, you are the space administrator. Now you can do some basic configuration, as described in the sections below.

**Step 2. Set the Space Permissions**

Define the space permissions to determine who can do what in your new space.
1. Open the 'Browse' menu and select 'Space Admin'.

2. Click 'Permissions' in the left-hand navigation panel.
3. Confirm your administrator access as prompted.
4. Click 'Edit Permissions'.
5. Set the permissions to suit your needs then click 'Save All'.
   - You can add groups and/or individual users to the list, then select the permissions for each group or user.
   - You can also set the permissions for anonymous users – these are people who have not logged in to the wiki and will not count towards the number allocated by your license. Anonymous access is available only if enabled for the entire Confluence site. However, it is unlikely you will need anonymous users for your intranet.
   - Note that you can change these permissions at any time. You may want to restrict the permissions to specific groups now, and later open the space to more people.

More about Permissions

Confluence has a robust and granular permissions scheme that you can use to determine who can view, create content and comment within your intranet. There are three levels of permissions in Confluence:

- Global permissions apply across the entire site.
- Space permissions apply to a space.
- Page restrictions allow you to restrict the editing and/or viewing of a specific page.

Space permissions in Confluence are simple yet granular enough to be useful for an intranet. You can:
Use the permission levels to control who can create pages, delete pages, create comments, delete comments, administer the space, and so on.

Grant a permission level to one or more users, and/or to one or more groups, and/or to anonymous users. A space administrator has complete control.

**Terminology:**

- 'Anonymous' means people who have not logged in to the wiki.
- The 'confluence-users' group is the default group into which all new users are assigned. Everyone who can log in to Confluence is a member of this group.

For example, you might allow the 'confluence-users' group permission to create and edit comments, but reserve full editing rights for your team members. Let's assume your team members are all members of the 'dev-team' group. The example below shows that members of the 'dev-team' group have all permissions except space administration, but 'Ryan Reynolds' only has a few editing rights.

For detailed information, see the documentation on:

- Global permissions
- Space permissions
- Page restrictions
- Users and groups

**Step 3. Customise the Title and Content of the Home Page**

When you created your space, Confluence created a home page with default content and a default title, 'Home'. You will want to change the title and content to suit your team.
1. Go back to your space home page, by clicking the space name in the breadcrumbs at the top of the screen. In the example below, the space name is ‘Development Team Space’:

   ![Dashboard > Development Team > Space Administration > View Space Permissions](image)

   **View Space Permissions**

   **Pages** **Blog** **Labels** **Attachments** **Bookmarks** **Mail** **Advanced** **Space Admin**

2. The space home page appears. By default, the page title is ‘Home’.

   ![Dashboard > Development Team > Home](image)

   **Home**

   4 Added by Administrator, last edited by Administrator on Jan 28, 2011 (view change)

3. Click ‘Edit’.

4. The page opens in edit mode. Change the title to suit your needs.

   ![Dashboard > Development Team > Home > Edit Page](image)

   **Development Team Space**

   ![Rich Text](image)

   ![Wiki Markup](image)

   ![Preview](image)

   This is the home of the Development Team space.

5. Update the content to suit your needs.

   *Hint: If you do not know what to add yet, just add a short description. You can refine the content of the page at any time.*

6. Click ‘Save’ to save your home page.

---

**Step 4. Subscribe to Email Notifications for Updates Made to the Space**

You can configure your email notifications to suit your needs: Subscribe to all blog posts from Confluence, subscribe to your network, or stay informed about any changes in a specific space. Below is a quick guide to monitoring a space’s content. See [Watching a Space](#) for a full description.
1. Open the 'Browse' menu and select 'Advanced'.

2. Click 'Start watching this space' in the bottom section of the left-hand navigation panel.

If at any time you wish to stop watching the space, just click 'Stop watching this space'.

**Example of an Email Notification**

Here is an example of the email notification you will receive when someone adds a comment to a page:

🌟 **Confluence@atlassian.com** to me

*Spend 5 minutes. Save a heck of a lot more.*

Blog post comment added by **Ryan Reynolds**

Required Reading. Auto-complete rocks. Nice video!

[View Online](#) | [Reply To This](#)

---

**More about Notifications**

You can specify the notifications you want to receive on a global, space and page level. The quick guide above demonstrated how to set up notifications for a space. Now we will show you how to configure your notifications on the global and page levels.

**Global Notifications**

Global notification settings determine the overall behaviour of the notifications you receive from Confluence.
1. Open the 'User' menu (Your name) and select 'Settings'.

2. Click 'Email' in the left-hand navigation panel.
3. Click 'Edit'.
4. Change the default settings to suit your needs. You can alter these email settings at any time.
5. Click 'Submit' to save your changes.

**Page and Blog Post Notifications**

Follow the quick guide below to receive notifications from Confluence about changes to and comments on a specific page or blog post. See [Watching a Page or Blog Post](#) for a full description.

You can watch any given page or blog post that you have permission to view. We will use your space's home page as an example.
1. Open the home page of your space.
2. Open the 'Tools' menu and select 'Watch'.

You are now watching the current page and Confluence will notify you about any updates made or comments added.

Note that Confluence will not notify you about content changes that are due to the output of a macro. For example: The output of the Children macro will change if someone adds a child page. The page containing the Children macro will show the new child page. But the page content itself has not been edited, so no notifications will be sent.

You can stop watching a page or blog post at any time. Just open the page, go to the 'Tools' menu and click 'Stop Watching'.

**Step 5. Attach or Import Office Documents if Applicable**

Below are some guidelines on managing your existing Office documents in Confluence. You can choose to attach them to a Confluence page, so that team members can view and access them in Confluence. Or you can import the documents into Confluence, converting the content to wiki format.

**Attaching Office Documents to a Page**

You can use Confluence as a central repository for your team's the Microsoft Office documents. This means that you can share your Office documents without having to email them to your teammates. People can view the Office documents even if they do not have Office installed on their computers.
1. Go to your space home page, by clicking the space name in the breadcrumbs at the top of the screen.
2. Hovering over the 'Tools' menu and click 'Attachments'.
3. Choose one of the following methods for attaching files to the page:
   - Use the 'Attachments' view’s 'browse and attach' feature to attach one or more file(s):
     a. Click the 'Browse' button.
     b. Browse through your files and select the file that you would like to attach to the page.
     c. Enter a description for the attachment in the 'Comment' text field (optional).
     d. Click 'Attach more files' if required. More attachment entry fields will appear, allowing you to attach more files.
     e. Click the 'Attach' button.

   * Alternatively, use the drag-and-drop feature to attach one or more file(s): Drag one or more file(s) accessible from your computer and drop them onto the 'Attachments' view. The 'Attach File(s)' message box appears, indicating the upload status of the file(s) being attached to your page.

**Attach File**
You cannot attach files with names containing '+' or '&' characters.

1. [Browse]  [Comment: ]

**Attach File(s)**

- Example of Image.png
  - 478.73 Kb of 478.73 Kb

- Excel Spread Sheet.xls
  - 515.23 Kb of 36.50 Kb

- Microsoft Word.docx
  - 672.22 Kb of 156.99 Kb

- PowerPoint.pptx
  - 805.72 Kb of 229.96 Kb

---

**Importing Existing Word Documents into Confluence**

You can also import content from Microsoft Word into Confluence, so that it becomes a wiki page. See Importing.
1. Go to your space home page, by clicking the space name in the breadcrumbs at the top of the screen.
2. Open the 'Tools' menu and select 'Import Word Document'. The Office Connector import screen will appear.
3. Click the 'Browse' button and find the Office document on your local drive or network.
4. Click the 'Open' or 'Upload' button provided by your browser. The path and file name of the document will now appear in the text box on the Office Connector import screen.
5. Click the 'Next' button. The import document options screen will display.

```
Development Team Space

Import Word Document: Configuration

Root page title: Microsoft Word

Where to import:   
- Import as a new page in the current space
- Replace Development Team Space
- Delete existing children of Development Team Space

Title conflicts:    
- Rename imported pages if page name already exists
- Replace existing pages with imported pages of the same title
- Remove existing pages with the same title as imported pages

Split by heading: Can't split this document. It contains no Heading styles.

import
```

6. Enter the following information:
   - 'Root page title' – The title of the wiki page that will contain the information from your imported document.
   - 'Import as a new page in the current space' – A new wiki page will be created with the page title specified above.
   - Choose what you want the importer to do if there are page title conflicts, by selecting one of the following options:
     - 'Rename imported pages if page name already exists' – Confluence will assign new names to any new page which would otherwise have a duplicate name. The content of existing pages will remain unchanged.
     - 'Split by heading' – Use this field to split your document into multiple wiki pages. If you do not want to split your document into multiple wiki pages, leave the default 'Don't split' option selected.

7. Click 'Import' to import your document.

When the upload has finished, the content of the Office document will have been transformed into Confluence page content. You can now view and edit this page in the normal way, using the Confluence Rich Text Editor or Wiki Markup. There is no connection between the original Office document and this wiki page.

**Step 6. Import Page Templates**

In order for an intranet to be effective, people need to use it. One way to spur new user adoption is to provide your team mates with templates so that they can focus more on content creation and less on page format. Confluence offers a number of templates, including a template for 'Meeting Notes' and a 'Three-Column Layout',

 Created in 2012 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
to help your team get started populating your intranet and improving its productivity. See Importing Templates for a full description.

1. Log in to Confluence as an administrator and go to the Confluence 'Administration Console'.
2. Click 'Import Templates' in the left-hand navigation panel. The 'Import Templates' screen will appear, listing the template packages deployed to your Confluence instance (for example, 'Default Templates Package') and the templates included in each package.
3. Select the templates you want by ticking the check boxes next to the template names. 
   **Note:** You can view a preview of the template by clicking the template name.
4. Select the import destination for the templates in the 'Import To' dropdown. If you want the templates to be available to a specific space only, select the name of the space, otherwise select 'Global Templates' to make the templates available to all spaces.
5. Click the 'Import' button to import the selected templates.

How Users will Find Templates

Now that you have made Confluence's templates available to your site or space, other Confluence users will be able to choose a template when they want to create a page.

Choosing a Template from the Dashboard
When you add a page from the Confluence dashboard, you will be able to select the template and space for the new page at the same time.

1. Go to the Confluence Dashboard by clicking 'Dashboard' from the breadcrumbs at the top left of your screen.
2. Click the 'Add Page' button. The 'Add Page' dialog appears.

![Add Page Dialog](image)

3. Select the space where you want to add the page.
4. Select the template you want to use to populate your page.

![Select Space and Template](image)

5. Click 'Next' to create the page.

Choosing a Template from within the Editor

Often you will add a page from within a space, or as a child of another page. This guide shows you how to choose a template from within the Confluence editor.

1. Go to your space home page, by clicking the space name in the breadcrumbs at the top of the screen.
2. Hover over the 'Add' menu and click 'Page'. This will launch the Confluence editor.
3. To populate the editor from a template, click the **Select a page template to start from** link below the 'Title' field. This will launch the 'Page Template Wizard'.
4. Choose a page template from those available in the list.

**Page Template Wizard**

**Step 1: Choose a page template**

Please choose a template from below:

<table>
<thead>
<tr>
<th>Name</th>
<th>Scope</th>
</tr>
</thead>
<tbody>
<tr>
<td>Charts</td>
<td>Global</td>
</tr>
<tr>
<td>Document List</td>
<td>Global</td>
</tr>
<tr>
<td>Meeting Notes</td>
<td>Global</td>
</tr>
<tr>
<td>Multimedia Content</td>
<td>Global</td>
</tr>
<tr>
<td>RSS News Feed</td>
<td>Global</td>
</tr>
<tr>
<td>Tasklist</td>
<td>Global</td>
</tr>
<tr>
<td>Three-Column Layout</td>
<td>Global</td>
</tr>
<tr>
<td>Two-Column Layout</td>
<td>Global</td>
</tr>
</tbody>
</table>

5. Click 'Next' to populate the editor with the selected template.

**Step 7. Set Up your Personal Space**

Now that you have created a space for your team, let's create your **personal space**. This is a place where you can publish your own pages and blog posts. Once you have created it, Confluence users can reach your personal space by clicking your name in the **People Directory** or by searching for your name via the **quick navigation search box**.
1. Go to your name at the top of the page and select ‘Create Personal Space’ from the dropdown list.

2. Enter a few details about your space:
   - Choose who can view content.
   - Choose who can contribute (create and edit) content.
   - Choose the ‘Global Look and Feel’ for your personal space.

3. Click the ‘Create’ button.
4. The ‘Home’ page for your new space is displayed.

Step 8. Publish a Blog Post

Blog posts are a good way of letting your team mates and the company know your news. People can blog about product and strategic ideas, team updates, and things they want to get ideas about. New employees can write blog posts introducing themselves. People write about getting married or the birth of a child. Blog posts are a great way for people to share their visions, get to know their co-workers and start lively discussions.

Remember to set your email notifications to alert you about the blog posts published within Confluence, as described in an earlier step.

See Working with Blog Posts for a full description of adding, editing, viewing and linking to blog posts.

1. Go to a page in your space.
2. Hover over the ‘Add’ menu and select ‘Blog Post’.
3. Change the title to suit your needs.
4. Update the content to suit your needs.
5. Click ‘Save’ to publish your blog post.

Related Topics

- Setting up a New Global Space
- Global Permissions Overview
- Assigning Space Permissions
- Setting a Page’s Restrictions
- Users and Groups