Contents

Confluence Documentation Home .............................................. 6
Get started .............................................................................. 7
  Tutorial: Navigate Confluence ............................................. 7
    The dashboard ................................................................... 8
    The space directory ......................................................... 9
    The space sidebar .......................................................... 10
    Keyboard shortcuts ......................................................... 11
    Complete your mission .................................................... 13
  Tutorial: Space ace ............................................................. 13
    Create a project space ..................................................... 14
    Create your personal space .............................................. 15
    Create the team's PR space .............................................. 16
    Delete and archive spaces .............................................. 17
Confluence Mobile .................................................................... 18
Spaces ....................................................................................... 21
  Create a Space ..................................................................... 22
    Create a Space From a Template ....................................... 25
    Space Keys ...................................................................... 26
  Navigate Spaces ................................................................... 26
  Space Permissions Overview .............................................. 28
    Assign Space Permissions .............................................. 29
    Make a Space Public ...................................................... 32
    Give Access to Unlicensed Users from JIRA Service Desk .... 33
Organize your Space ............................................................... 34
  Set up a Space Home Page .................................................. 38
  Use Labels to Categorize Spaces ......................................... 41
Customize your Space ............................................................ 43
  Configure the Sidebar ........................................................ 43
  Edit a Space's Color Scheme .............................................. 45
  Apply a Theme to a Space .................................................. 48
    Switch to the Default Theme ......................................... 48
    The Documentation Theme ............................................. 53
  Configure the Documentation Theme ................................. 56
  Customize Space Layouts .................................................... 65
  Archive a Space .................................................................. 67
  Delete a Space .................................................................... 68
  Export Content to Word, PDF, HTML and XML ................ 69
    Customize Exports to PDF .............................................. 70
    Advanced PDF Export Customizations ............................. 77
    Create a PDF in Another Language ................................ 80
Pages and Blogs ....................................................................... 81
  Create and Edit Pages ....................................................... 82
  Blog Posts ......................................................................... 84
  The Editor ......................................................................... 86
    Symbols, Emoticons and Special Characters .................... 89
Move and Reorder Pages .......................................................... 91
  Copy a Page ....................................................................... 93
  Delete or Restore a Page ................................................... 94
Add, Remove and Search for Labels ........................................ 96
  Display Pages with Label Macros ..................................... 98
Drafts ....................................................................................... 99
  Concurrent Editing and Merging Changes ......................... 100
Page Restrictions ..................................................................... 101
Links ....................................................................................... 104
Anchors ................................................................................... 109
Tables ....................................................................................... 111
<table>
<thead>
<tr>
<th>Add, Assign, and View Tasks</th>
<th>113</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autocomplete for links, files, macros and mentions</td>
<td>115</td>
</tr>
<tr>
<td>Page Layouts, Columns and Sections</td>
<td>120</td>
</tr>
<tr>
<td>Create Beautiful and Dynamic Pages</td>
<td>122</td>
</tr>
<tr>
<td>Page Templates</td>
<td>125</td>
</tr>
<tr>
<td>Create a Template</td>
<td>126</td>
</tr>
<tr>
<td>Create a Page from a Template</td>
<td>131</td>
</tr>
<tr>
<td>Blueprints</td>
<td>133</td>
</tr>
<tr>
<td>Decisions Blueprint</td>
<td>135</td>
</tr>
<tr>
<td>File List Blueprint</td>
<td>137</td>
</tr>
<tr>
<td>Meeting Notes Blueprint</td>
<td>138</td>
</tr>
<tr>
<td>Product Requirements Blueprint</td>
<td>140</td>
</tr>
<tr>
<td>Shared Links Blueprint</td>
<td>142</td>
</tr>
<tr>
<td>JIRA Report Blueprint</td>
<td>143</td>
</tr>
<tr>
<td>Retrospective Blueprint</td>
<td>146</td>
</tr>
<tr>
<td>Create a Blueprint-Style Report</td>
<td>148</td>
</tr>
<tr>
<td>Import Content Into Confluence</td>
<td>154</td>
</tr>
<tr>
<td>Import a Word Document into Confluence</td>
<td>154</td>
</tr>
<tr>
<td>Orphaned Pages</td>
<td>156</td>
</tr>
<tr>
<td>Undefined Page Links</td>
<td>157</td>
</tr>
<tr>
<td>View Page Information</td>
<td>158</td>
</tr>
<tr>
<td>Page History and Page Comparison Views</td>
<td>159</td>
</tr>
<tr>
<td>Confluence Markup</td>
<td>162</td>
</tr>
<tr>
<td>Confluence Storage Format</td>
<td>162</td>
</tr>
<tr>
<td>Confluence Wiki Markup</td>
<td>177</td>
</tr>
<tr>
<td>Files</td>
<td>185</td>
</tr>
<tr>
<td>Upload Files</td>
<td>185</td>
</tr>
<tr>
<td>Display Files and Images</td>
<td>186</td>
</tr>
<tr>
<td>Manage Files</td>
<td>190</td>
</tr>
<tr>
<td>Share and Comment on Files</td>
<td>192</td>
</tr>
<tr>
<td>Edit Office Files</td>
<td>194</td>
</tr>
<tr>
<td>Office Connector Prerequisites</td>
<td>195</td>
</tr>
<tr>
<td>Install the Firefox Add-On for the Office Connector</td>
<td>197</td>
</tr>
<tr>
<td>Macros</td>
<td>201</td>
</tr>
<tr>
<td>Activity Stream Macro</td>
<td>203</td>
</tr>
<tr>
<td>Anchor Macro</td>
<td>203</td>
</tr>
<tr>
<td>Attachments Macro</td>
<td>204</td>
</tr>
<tr>
<td>Blog Posts Macro</td>
<td>207</td>
</tr>
<tr>
<td>Change-History Macro</td>
<td>210</td>
</tr>
<tr>
<td>Chart Macro</td>
<td>211</td>
</tr>
<tr>
<td>Confluence Storage Format Examples for Chart Macro</td>
<td>228</td>
</tr>
<tr>
<td>Wiki Markup Examples for Chart Macro</td>
<td>248</td>
</tr>
<tr>
<td>Cheese Macro</td>
<td>254</td>
</tr>
<tr>
<td>Children Display Macro</td>
<td>255</td>
</tr>
<tr>
<td>Code Block Macro</td>
<td>257</td>
</tr>
<tr>
<td>Column Macro</td>
<td>261</td>
</tr>
<tr>
<td>Content by Label Macro</td>
<td>261</td>
</tr>
<tr>
<td>Content by User Macro</td>
<td>264</td>
</tr>
<tr>
<td>Content Report Table Macro</td>
<td>265</td>
</tr>
<tr>
<td>Contributors Macro</td>
<td>267</td>
</tr>
<tr>
<td>Contributors Summary Macro</td>
<td>270</td>
</tr>
<tr>
<td>Create from Template Macro</td>
<td>275</td>
</tr>
<tr>
<td>Create Space Button Macro</td>
<td>277</td>
</tr>
<tr>
<td>Excerpt Include Macro</td>
<td>278</td>
</tr>
<tr>
<td>Excerpt Macro</td>
<td>280</td>
</tr>
<tr>
<td>Expand Macro</td>
<td>282</td>
</tr>
<tr>
<td>Favorite Pages Macro</td>
<td>283</td>
</tr>
<tr>
<td>Gadget Macro</td>
<td>284</td>
</tr>
<tr>
<td>Gallery Macro</td>
<td>286</td>
</tr>
<tr>
<td>Global Reports Macro</td>
<td>290</td>
</tr>
<tr>
<td>HTML Include Macro</td>
<td>291</td>
</tr>
<tr>
<td>HTML Macro</td>
<td>293</td>
</tr>
</tbody>
</table>

Created in 2016 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>IM Presence Macro</td>
<td>294</td>
</tr>
<tr>
<td>Include Page Macro</td>
<td>295</td>
</tr>
<tr>
<td>Sample Include Page</td>
<td>296</td>
</tr>
<tr>
<td>Info, Tip, Note, and Warning Macros</td>
<td>297</td>
</tr>
<tr>
<td>JIRA Chart Macro</td>
<td>298</td>
</tr>
<tr>
<td>JIRA Issues Macro</td>
<td>304</td>
</tr>
<tr>
<td>JUnit Report Macro</td>
<td>311</td>
</tr>
<tr>
<td>Labels List Macro</td>
<td>313</td>
</tr>
<tr>
<td>Livesearch Macro</td>
<td>314</td>
</tr>
<tr>
<td>Loremipsum Macro</td>
<td>316</td>
</tr>
<tr>
<td>Multimedia Macro</td>
<td>317</td>
</tr>
<tr>
<td>Navigation Map Macro</td>
<td>318</td>
</tr>
<tr>
<td>Network Macro</td>
<td>320</td>
</tr>
<tr>
<td>Noformat Macro</td>
<td>321</td>
</tr>
<tr>
<td>Office Excel Macro</td>
<td>322</td>
</tr>
<tr>
<td>Office PowerPoint Macro</td>
<td>324</td>
</tr>
<tr>
<td>Office Word Macro</td>
<td>325</td>
</tr>
<tr>
<td>Page Index Macro</td>
<td>326</td>
</tr>
<tr>
<td>Page Properties Macro</td>
<td>327</td>
</tr>
<tr>
<td>Page Properties Report Macro</td>
<td>329</td>
</tr>
<tr>
<td>Page Tree Macro</td>
<td>333</td>
</tr>
<tr>
<td>Page Tree Search Macro</td>
<td>335</td>
</tr>
<tr>
<td>Panel Macro</td>
<td>336</td>
</tr>
<tr>
<td>PDF Macro</td>
<td>338</td>
</tr>
<tr>
<td>Popular Labels Macro</td>
<td>338</td>
</tr>
<tr>
<td>Profile Picture Macro</td>
<td>340</td>
</tr>
<tr>
<td>Recently Updated Dashboard Macro</td>
<td>340</td>
</tr>
<tr>
<td>Recently Updated Macro</td>
<td>342</td>
</tr>
<tr>
<td>Recently Used Labels Macro</td>
<td>345</td>
</tr>
<tr>
<td>Related Labels Macro</td>
<td>346</td>
</tr>
<tr>
<td>Roadmap Planner Macro</td>
<td>347</td>
</tr>
<tr>
<td>RSS Feed Macro</td>
<td>348</td>
</tr>
<tr>
<td>Search Results Macro</td>
<td>351</td>
</tr>
<tr>
<td>Section Macro</td>
<td>353</td>
</tr>
<tr>
<td>Space Attachments Macro</td>
<td>354</td>
</tr>
<tr>
<td>Space Details Macro</td>
<td>355</td>
</tr>
<tr>
<td>Space Jump Macro</td>
<td>356</td>
</tr>
<tr>
<td>Spaces List Macro</td>
<td>358</td>
</tr>
<tr>
<td>Status Macro</td>
<td>359</td>
</tr>
<tr>
<td>Table of Contents Macro</td>
<td>360</td>
</tr>
<tr>
<td>Table of Content Zone Macro</td>
<td>364</td>
</tr>
<tr>
<td>Task Report Macro</td>
<td>368</td>
</tr>
<tr>
<td>User List Macro</td>
<td>370</td>
</tr>
<tr>
<td>User Profile Macro</td>
<td>371</td>
</tr>
<tr>
<td>View File Macro</td>
<td>373</td>
</tr>
<tr>
<td>Widget Connector Macro</td>
<td>374</td>
</tr>
<tr>
<td>Your Profile and Settings</td>
<td>378</td>
</tr>
<tr>
<td>Your User Profile</td>
<td>378</td>
</tr>
<tr>
<td>Change Your Password</td>
<td>380</td>
</tr>
<tr>
<td>Edit Your User Settings</td>
<td>381</td>
</tr>
<tr>
<td>Set Your Profile Picture</td>
<td>383</td>
</tr>
<tr>
<td>Choose Your Home Page</td>
<td>384</td>
</tr>
<tr>
<td>Save for later</td>
<td>385</td>
</tr>
<tr>
<td>View and Revoke OAuth Access Tokens</td>
<td>386</td>
</tr>
<tr>
<td>Collaboration</td>
<td>387</td>
</tr>
<tr>
<td>Network Overview</td>
<td>388</td>
</tr>
<tr>
<td>Likes and Popular Content</td>
<td>389</td>
</tr>
<tr>
<td>Mentions</td>
<td>389</td>
</tr>
<tr>
<td>Share a Page or Blog Post</td>
<td>390</td>
</tr>
<tr>
<td>Comment on pages and blog posts</td>
<td>391</td>
</tr>
<tr>
<td>Watch Pages, Spaces and Blogs</td>
<td>393</td>
</tr>
<tr>
<td>Manage Watchers</td>
<td>396</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Email Notifications</td>
<td>396</td>
</tr>
<tr>
<td>Subscribe to RSS Feeds within Confluence</td>
<td>399</td>
</tr>
<tr>
<td>Subscribe to pre-specified RSS feeds</td>
<td>400</td>
</tr>
<tr>
<td>The RSS Feed Builder</td>
<td>401</td>
</tr>
<tr>
<td>Subscribe to a Network RSS Feed</td>
<td>403</td>
</tr>
<tr>
<td>Workbox Notifications</td>
<td>404</td>
</tr>
<tr>
<td>Search</td>
<td>406</td>
</tr>
<tr>
<td>Confluence Search Syntax</td>
<td>412</td>
</tr>
<tr>
<td>Confluence Search Fields</td>
<td>420</td>
</tr>
<tr>
<td>Search the People Directory</td>
<td>424</td>
</tr>
<tr>
<td>Recently Viewed Pages and Blog Posts</td>
<td>426</td>
</tr>
<tr>
<td>Permissions and Restrictions</td>
<td>427</td>
</tr>
<tr>
<td>Confluence Groups</td>
<td>428</td>
</tr>
<tr>
<td>Add-ons and Integrations</td>
<td>430</td>
</tr>
<tr>
<td>Use JIRA applications and Confluence together</td>
<td>430</td>
</tr>
<tr>
<td>Use HipChat and Confluence together</td>
<td>434</td>
</tr>
<tr>
<td>Request Add-ons</td>
<td>436</td>
</tr>
<tr>
<td>Use a WebDAV Client to Work with Pages</td>
<td>437</td>
</tr>
<tr>
<td>Mail Archives</td>
<td>438</td>
</tr>
<tr>
<td>Add a Mail Account</td>
<td>439</td>
</tr>
<tr>
<td>Delete and Restore Mail</td>
<td>440</td>
</tr>
<tr>
<td>Import Mail from an mbox</td>
<td>441</td>
</tr>
<tr>
<td>Gadgets</td>
<td>442</td>
</tr>
<tr>
<td>Activity Stream Gadget</td>
<td>444</td>
</tr>
<tr>
<td>Confluence News Gadget</td>
<td>444</td>
</tr>
<tr>
<td>Confluence Page Gadget</td>
<td>445</td>
</tr>
<tr>
<td>Confluence Quicknav Gadget</td>
<td>448</td>
</tr>
<tr>
<td>Confluence Use-Cases</td>
<td>448</td>
</tr>
<tr>
<td>Develop Technical Documentation in Confluence</td>
<td>449</td>
</tr>
<tr>
<td>Use Confluence as a Knowledge Base</td>
<td>454</td>
</tr>
<tr>
<td>Use Confluence as your Intranet</td>
<td>456</td>
</tr>
<tr>
<td>Confluence for Software Teams</td>
<td>459</td>
</tr>
</tbody>
</table>
Confluence Documentation Home

Confluence is where you create, organize and discuss work with your team. Learn more or try it for free.

Capture the knowledge that’s too often lost in email inboxes and shared network drives in Confluence instead – where it’s easy to find, use, and update. Give every team, project, or department its own space to create the things they need, whether it’s meeting notes, product requirements, file lists, or project plans, you can get it done in Confluence.

Confluence Server 5.10 (Latest)

Get started
- Get started
- Pages and Blogs
- Search

Popular
- Links
- Tables
- Macros

Integrations
- Integrate with JIRA applications
- Integrate with HipChat
- Get add-ons from the Marketplace

Installation
- Install Confluence
- Supported Platforms
- Database Configuration
- Release Notes

Tutorials
- Navigate Confluence
- Space Ace

Admin
- Manage Users
- Customize your Site
Get started

Welcome to the Confluence getting started documentation. In this section, you'll find tutorials and other information that'll be useful for evaluating Confluence, and getting to know it when you're starting out.

Teams in Space

For each tutorial in this section, we'll use a fictional organization known as 'Teams in Space'. Their mission is to:

"Perform flight research and technology integration to revolutionize aviation and pioneer aerospace technology. Also, land the first humans on Mars by 2020."

You're an astronaut in the 'See Space EZ' team, which is working on the upcoming colonization of Mars.

Go ahead – dive into the tutorials, and let us show you around Confluence and some of its handy features.

- Tutorial: Navigate Confluence
  - The dashboard
  - The space directory
  - The space sidebar
  - Keyboard shortcuts
  - Complete your mission
- Tutorial: Space ace
  - Create a project space
  - Create your personal space
  - Create the team's PR space
  - Delete and archive spaces
- Confluence Mobile

Tutorial: Navigate Confluence

Confluence is pretty simple to use, once you get to know it. This tutorial aims to get you acquainted with the Confluence user interface, and show you how and where to perform some common tasks.

Teams in Space

In this tutorial, you'll be working with some new Teams in Space recruits. Let's get to know them.
Now that you've met your team, let's take a look at your mission.

Mission brief

Your mission commander has thrown you a curveball: this week you'll be training new recruits at Teams in Space HQ on your collaboration tool – Confluence. You just need to know the basics, so we'll go through the main things you need to know to complete your mission.

Your mission is broken up into the following components:

- Get to know the dashboard
- Find your way in the space directory
- Master the space sidebar
- Impress everyone with keyboard shortcuts

Those new recruits will be here tomorrow; we better get started!

Let's go!

The dashboard

1. The dashboard
2. The space directory
3. The space sidebar
4. Keyboard shortcuts
5. Complete your mission

The dashboard is the hub of your Confluence site, providing you with access to information and updates that are important to you. It's also the first thing your new recruits will see, so you need to make a good impression on this one.

You can get to the dashboard from anywhere in Confluence by choosing the site logo at the left of the Confluence header.

The dashboard has a collapsible sidebar that helps you get around:

- **Discover**
  Watch the action unfold in real time with All updates or check out pages with lots of likes and activity in the Popular feed.
- **My Work**
  Get lightning fast access to your recently created and edited pages in Recently worked on, get back to that page you stumbled across yesterday in Recently viewed, and have mission critical pages on speed dial under Saved for later.
- **My Spaces**
  This is where you can keep links to the spaces that you hop in and out of several times a day.

If you're a Confluence admin you can give the dashboard some personality by adding useful announcements, links, or a photo from your last mission (or office party). The the whole right hand column is ready and waiting for you to customize.
Try clicking one of the spaces on the sidebar, then return to the dashboard by clicking the site logo. Even when your shuttle is spinning out of control, the dashboard is there to orient you.

You'll discover more about the dashboard as you get to know Confluence, but, for now, let's move on to the space directory.

**Pro tips**
- You can choose to set any page as your personal home page
- You can always get to the dashboard at https://yoursite.com/wiki/dashboard.action
- Your Confluence admin can customize the global dashboard that all users see

**The space directory**

1. The dashboard
2. The space directory
3. The space sidebar
4. Keyboard shortcuts
5. Complete your mission

The space directory won't let you look up ET in the intergalactic phone book, but it will let you see and filter all the spaces in your Confluence site. Spaces are places to collect pages with a common theme – you can create as many spaces as you like – and you can find them all in the space directory.

Here are some tasks to get you comfortable using the space directory:

1. **Visit the space directory** – To get to the space directory, choose Spaces > Space directory in the Confluence header.
2. **Choose the spaces you'll use the most** – No doubt there'll be a space or two that you'll use on a regular basis. Click the star to the right of a space to make it appear under My Spaces on the dashboard.
3. **Choose space categories** – Once you're there, you'll see a list of all the spaces in your Confluence site. Choose the 'My Spaces' category on the left to see only the spaces you marked with a star. Then choose all spaces again.
4. **Filter the list of spaces** – Type part of a space name in the Filter field at the top right. That'll quickly narrow down the list of spaces if there are a lot of them.
Understanding and using the space directory will make it much easier to find pages and blog posts that are relevant to you.

You're ready to impress those new recruits with your knowledge of Confluence's space directory; now it's time to sneak a peek at the space sidebar.

The space sidebar

1. The dashboard
2. The space directory
3. The space sidebar
4. Keyboard shortcuts
5. Complete your mission

What's in the sidebar?

The sidebar is a feature of every Confluence space; it's where you'll find the page tree (a hierarchical list of pages in the space), customizable space shortcuts, and a link to the space's blog.

The See Space EZ team will find their meeting notes, decisions, requirements, and other pages in the sidebar. Basically any page you create in the space will appear in the sidebar by default.

When you use certain page templates, like meeting notes, Confluence will automatically add an index page to your space shortcuts. The index page is just a place where you can view all pages of the same type – meeting notes in this example – in one place.

The space's blog is great for announcements and
Configure the sidebar

You can expand or collapse the sidebar using the left square bracket ( [ ) on your keyboard, or by dragging it with your mouse.

There are lots of things you can change in the sidebar, but we'll stick to the basics – just enough to train your new recruits.

You need to be a space admin to complete this task. Take a look, but feel free to skip it if you're not an admin of any space.

Try this out:

1. Choose **Space tools** > **Configure sidebar** from the bottom of the sidebar (or the cog menu if your sidebar is collapsed)
2. Add a space shortcut by clicking **+Add link**
   
   Shortcuts can be to Confluence pages or spaces, or to any other content on the web. Try linking to [this blog post](#), which mentions Teams in Space (we're always after a plug at Teams in Space HQ!)

You can also hide things – like the space's blog – in the sidebar, if they're of no use in the space.

The sidebar is pretty easy, right? You'll be schooling those recruits in no time. Next up: Impress them with your knowledge of keyboard shortcuts.

### Keyboard shortcuts

1. The dashboard
2. The space directory
3. The space sidebar
4. Keyboard shortcuts
5. Complete your mission

Give a person some space food, and they'll eat for a day; teach a person to rehydrate their own space food, and they're set for the whole mission. Or something like that. Keyboard shortcuts fall into this basket. We could give you a list here, but then you'd need to keep referring to this page. The best way to go is to show you how to find the list of keyboard shortcuts **within Confluence**.

Your recruits also need to work fast, so you'll need to pass this wisdom on to them.
Find the keyboard shortcuts

To open the list of keyboard shortcuts in Confluence, do any of the following:

- Choose the help icon at top right of the screen, then choose **Keyboard Shortcuts**
- When viewing a page, press **Shift+?**
- While editing a page, choose the question mark icon in the editor toolbar

What you’ll see is a dialog listing the available keyboard shortcuts in Confluence.

<table>
<thead>
<tr>
<th>Keyboard Shortcuts</th>
<th>View All Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td></td>
</tr>
<tr>
<td>Editor</td>
<td></td>
</tr>
<tr>
<td>Editor Autoformatting</td>
<td></td>
</tr>
</tbody>
</table>

The keyboard shortcuts are broken up into 3 categories:

- **General** – Global, page and blog post shortcuts.
- **Editor** – Text editing and formatting shortcuts.
- **Editor Autoformatting** – Wiki markup and autoformatting shortcuts.

You can turn the 'General' keyboard shortcuts off when you visit the **General** tab in the keyboard shortcuts dialog.

Take some time to open the dialog and take a look at the shortcuts, and maybe find some you’ll use a lot. Then, start practising!

Next, we’ll wrap up this mission and give you some ideas about where to head from here.
Complete your mission

1. The dashboard
2. The space directory
3. The space sidebar
4. Keyboard shortcuts
5. Complete your mission

Well done, astronaut, you've acquitted yourself admirably. I'm sure those new recruits will be mightily impressed with your knowledge of Confluence.

In this tutorial, we've:

- Explored the anatomy of the dashboard
- Navigated using the space directory and favorited a space
- Taken a look at and customized the space sidebar
- Found a handy list of keyboard shortcuts to help you work faster

Just look at your team's adoring faces...

If you'd like to take things to the next level, check out our tutorial on becoming a space ace.

Tutorial: Space ace

This tutorial will take you on a journey through Confluence to create and customize spaces, and delete them if you want to, so you can achieve the rank of 'Space Ace'!

You'll need to have the 'Create space' and 'Create personal space' permission to complete this tutorial. If you've just set up Confluence, you won't have any trouble; if you're using an existing instance and you're not an admin, speak to your Confluence admin to make sure you have the right permissions.

Teams in Space

In this tutorial you're a new recruit on the Teams in Space crew, but, even though you're new, you'll be given a lot of responsibility. You need the power to go with it.

Mission brief

You're in charge of organizing information and resources for the planned mission to Mars. There's going to be plenty of important information, and it must be readily available to the people who need it. Some information, though, will be sensitive, and may be 'for your eyes only.' You'll use the power and flexibility of Confluence spaces to organize information, and make sure it's visible to the right people.

Your mission is broken up into the following components:

- Create a space to house all of the important information related to the mission
• Create your own space to keep yourself organized
• Create a public relations space, where you'll introduce your team the world

What's a space?

Well, being an astronaut, I hope you know what space is, but what's a Confluence space all about? It's really just a place to put related things, like information pages and files. But spaces also give you a place to collaborate with groups of people, whether that's your team, people working on a common project, or the whole world.

Every space has its own permissions, allowing you to grant access and other privileges to the right people. They also have a blog, so you can post important messages and updates to whoever can see the space. You can have as many Confluence spaces as you like, and you can archive or delete spaces when you no longer need them.

Enough about that; let's begin.

Create a project space

1. Create a project space
2. Create your personal space
3. Create the team's PR space
4. Delete and archive spaces

The Mars colonization crew needs a place to put all their mission-critical information and resources, and you're charged with setting it up. This part is going to be easy, because the information needs to be viewable by the entire Teams in Space organization. That means we can set up the project space without any special permissions.

If you haven't done so already, open up Confluence and log in so we can get started.

Create the space

1. Choose Spaces > Create space from the Confluence header
2. Select the Blank space option and choose Next
3. Enter a Space name – for this space, we'll call it 'Mars Colony', as it's being used for the Mars colonization project.
4. Change the Space key to 'MARS' – this step isn't absolutely necessary, but it helps people if they're navigating to this space by name. The space key forms part of the URL, so making it a word or name makes it much easier to associate with your project.
5. Click Create

You now have a space set up for the Mars colonization project. Because everyone at Teams in Space HQ needs access to the information in this space, you don't need to do anything with the space's default permissions. It's visible to everyone in your organization, but not to the general public.

Every space has a default home page, which you can customize to suit your needs. Add the following image and text to your space's home page to get things started. Just click Edit (or press E on your keyboard) to edit the home page, and copy and paste the text. For the image it's best to drag it to your desktop and save it there, then drag it into your page. That'll make sure the image is attached directly to the page.

Hit Save when you're happy with the home page.

A human mission to Mars has been the subject of science fiction, engineering, and scientific proposals throughout the 20th century and into the
21st century. The plans comprise proposals to land on Mars, eventually settling on and terraforming the planet, while exploiting its moons, Phobos and Deimos.

Exploration of Mars has been a goal of national space programs for decades. Preliminary work for missions that would involve human explorers has been undertaken since the 1950s, with planned missions typically being cited as taking place 10 to 30 years in the future when they are drafted. The list of manned Mars mission plans in the 20th century shows the various mission proposals that have been put forth by multiple organizations and space agencies in this field of space exploration.

Your 'Mars colony' space is ready for your team to add pages to. If you want to find it again, choose Spaces in the Confluence header, and select it from the list; to add a page to it, navigate to the space and hit Create in the header.

Now it's on to your personal space; a place where you can work in peace, and be sure that no one's looking over your shoulder.

Create your personal space

1. Create a project space
2. Create your personal space
3. Create the team's PR space
4. Delete and archive spaces

As a newbie on the team, you might want to keep some work to yourself until you're ready to present it. There's always the chance your mission commander will also send you some information that's 'for your eyes only,' and you'll need to keep that in a safe place.

For this part of the mission, we'll be creating a special type of space: a personal space. We'll be using your personal space like a sandbox, at least to start with – somewhere you can play around, draft pages, try out features, and generally see what spaces are capable of.

Create your personal space

1. Choose your profile picture at the right side of the Confluence header
2. Select Add Personal Space...
3. Hit Create

You've now got a space that you can call your own. But we still need to lock it down to make sure it's only visible to you.
4. Choose **Space tools > Permissions** from the bottom of the siderbar
5. Hit **Edit Permissions** (enter your password if prompted)

   You should see the *confluence-users* group listed under **Groups**. To the left of the list of permissions is the **View** permission, which determines whether everyone in that group can see your space.

6. Uncheck **View** and hit **Save all** at the bottom of the page

You’re now the only one that can view this space. Feel free to try anything in this space, and store super secret stuff here.

---

**Create the team’s PR space**

1. Create a project space  
2. Create your personal space  
3. Create the team’s PR space  
4. Delete and archive spaces

Now it’s time to go public; the world needs to know about the mission and its brave participants.

In this step, we’ll create a team space and open it up to everyone. That’s right – you can open Confluence spaces up to anonymous (not logged in) users.

In order to allow anonymous access to your Confluence site, a site admin needs to grant anonymous users the 'Use Confluence' permission. Don’t worry if you can’t do that, or if it’s not done; it’s just something to note if you’re opening up your Confluence site for real.

---

**Create a Team space**

1. Choose **Spaces > Create space** from the header  
2. Select **Team Space** and hit **Next**  
3. Enter a **Space name** (let’s call it ‘Mars PR’)
4. Change the **Space key** to 'MarsPR'
5. If there are other people using Confluence with you, feel free to add them as **Team members** (you can remove them later), or just stick with yourself for now
6. Paste this in as the **Description**: Follow the progress of the brave Teams in Space astronauts as they embark on their mission to colonize Mars.

Great! You now have a team space, again with its own home page. This home page is a little different to the project space and your personal space – you'll see any team members you added, listed on the home page.

![Create Team Space](image)

Each space you create also has its own blog, so your social media team will be able to create posts in this space and speak directly to all those adoring fans. But none of those fans can see this space. Yet.

**Allow anonymous access**

It's time to let the world in by changing the permissions on this space.

1. Choose **Space tools > Permissions** from the bottom of the sidebar
2. Scroll down until you see **Anonymous**, then hit **Edit Permissions**
3. Tick the **View** permission for anonymous users and hit **Save all**

That's it. You can now share the space's URL, which will be `http(s)://<your_confluence_site>/display/MarsPR`. Visitors to that space don't need to log in, or have a license for Confluence.

**Delete and archive spaces**

1. Create a project space
2. Create your personal space
3. Create the team's PR space
4. Delete and archive spaces

We hope you've had a successful mission, and learned a bit about the power and versatility of Confluence spaces. Flash forward 18 months, and just look how well the colony is coming along!
If you need to clean up old spaces (or destroy the evidence of a failed mission!), you can either archive or delete a space. Archiving just means it won’t show up in the regular search, whereas deleting is obviously a lot more permanent.

**To archive a space:**
1. Choose **Space tools > Overview** from the bottom of the sidebar
2. Click **Edit Space Details**
3. Change the **Status** from 'Current' to 'Archived' and hit **Save**

**To delete a space:**
1. Choose **Space tools > Overview** from the bottom of the sidebar
2. Select the **Delete Space** tab

**What next?**
If you’d like to know more about spaces and the permissions that govern them, check out **Spaces and Permissions and Restrictions** in the Confluence documentation.

Teams in Space HQ, signing off.

**Confluence Mobile**

This page is about Confluence mobile web. If you're a Confluence Cloud customer, head over to our Cloud documentation to find out about the **Confluence iOS app**.

When you access Confluence on a mobile device, you'll see a version of Confluence which is optimized for mobile viewing. Confluence chooses the mobile or desktop interface based on your device, but you can still switch to the desktop site on your mobile by choosing menu

then choosing **Switch to desktop version**.

You can also swap from the desktop view to the mobile view if you're on a mobile device, by choosing **Switch to Confluence Mobile** at the top of the page.

On your supported mobile device, you can:

- View the Confluence dashboard, pages, blog posts, and user profiles.
- Add or reply to a comment on a page or blog post.
- Like a page, blog post or comment.
- Watch a page or blog post.
- See your notifications and tasks.

You can't add or edit pages or blog posts, or edit existing comments, using the mobile interface.
The dashboard – the first thing you see

Choose a tab to see:

- Popular content – what people like in your wiki.
- Recent blogs – the latest blog posts.
- Network – updates by people in your network.

Tap the links to view the full content of a page, blog post or comment.

Tap the menu icon to open the menu panel on the left of the page. Then type text or a person’s name in the Search box. The mobile interface offers the quick navigation search, which returns matches on page title only. (See Search.) To use the full search, switch to desktop mode.

Viewing pages, blog posts and comments

Tap a link on the dashboard or on any other page. Confluence will display the linked page, blog post or comment.

You can:

- View the content, tap a link to move to another page, and interact with the page using the standard functionality supported by mobile browsers.
Like or unlike a page, blog post or comment.
Watch or stop watching a page or blog post.
Add or reply to a comment.

Viewing people’s profiles

Search for a person’s name, then view that person’s user profile. Tap the options to phone, SMS or email a colleague directly from your mobile device.

Following up on notifications

You can view and respond to your notifications on your phone or other mobile device. Tap the menu icon to open the menu panel on the left of the page. Choose Notifications, and tap a notification to see its details. You can reply, watch or like via the inline actions. Tap Open to open the page or blog post in a new page. For full details, see Workbox Notifications.

Viewing tasks

You can view and manage your tasks on your phone or other mobile device too. Tap the menu icon to open the menu panel on the left of the page. Choose Tasks then tap a task to see its details.

More things you may need to know

Some macros may not appear

Confluence macros are not yet fully supported in Confluence mobile. If you view a page that contains an unsupported macro, you will see a message inviting you to click through to the desktop version of the page.

Screenshot: Macro not rendered in Confluence mobile
Administrators can disable Confluence mobile on your site

The mobile functionality is provided by a system add-on called the 'Confluence Mobile Plugin'. To remove the functionality from your site, you can disable the plugin.

In Confluence versions 5.9 and above, disabling the Confluence Mobile Plugin will also disable the Workbox - Host Plugin plugin. This issue is being tracked at

**CONF-40782** - Disabling the Confluence Mobile Plugin also disables the Workbox - Host Plugin in Confluence 5.9.X

Native Confluence mobile app

The Confluence iOS app is available for Confluence Cloud sites only. It cannot be used with Confluence Server. You can access Confluence Server on any device using a browser. Confluence will detect your device’s size and switch to the mobile web version when necessary.

See Supported Platforms for supported mobile browsers.

Spaces

What is a space?

Spaces are Confluence’s way of organizing content into meaningful categories. Think of it like having different folders into which you can put your work.

Spaces come in two main varieties:

- **Site spaces** – These spaces are found in the Space Directory and are the areas where you create content and collaborate with others. They are sometimes called global spaces.
- **Personal spaces** – Every Confluence user can set up a personal space which they can keep private or make public so others can view and edit. Personal spaces are listed in the People Directory and found under your personal profile.

How do I use a space?

Create as many spaces as you need to get things done:

On this page:
- What is a space?
- How do I use a space?

Related pages:
- Create a Space
- Space Permissions Overview
- Navigate Spaces
- Organize your Space
- Customize your Space
- Archive a Space
- Export Content to Word, PDF, HTML and XML
- Delete a Space
- **Team spaces** – Give each team (QA, HR, Engineering, Support, ...) their own space so they can focus and make their information easier for everyone to find.
- **Project spaces** – Put all the information related to your project in one place. This allows everyone to work together in Confluence instead of emailing back and forth.
- **Personal space** – Store everything you're working on individually, keep your to-do lists, and polish any content before you move it into another shared space.

**Stay up to date with spaces**
- Watch a space to stay up-to-date with any changes.
- Add important spaces to your dashboard so that they're easy to find again.

**Administer spaces**
If you have admin permissions for a space you can:
- Change the colors, logo, sidebar and homepage of that space.
- Control who can view and edit your space.
- Make your space public to share it with people who don't have access to Confluence.

**Space Permissions**
Some things we should make clear about space admin permissions:
- The person who creates a space automatically has admin permissions for that space.
- Space admins can grant admin permissions to others.
- Space admins don't have to be Confluence admins and can have special permissions for a single space. For example, you are the admin for your personal space, no matter what kind of access you have anywhere else.

---

Want more ideas for using spaces? Check out our kickass guides on how to:

- Use Confluence as a Knowledge Base
- Develop Technical Documentation in Confluence
- Use Confluence as your Intranet
- Use Confluence for Software Teams

---

**Create a Space**

There's no limit to the number of Spaces you can create on Confluence. You can choose to set up a space for each team, project, or a mix of both depending on your needs.

Each space in Confluence functions autonomously, which means that each space:
- Has its own homepage, blog, pages, comments, files, and RSS feeds.
- Can be customized with different color schemes, logo and sidebar.
- Has its own set of permissions, as set by the space admin.

For example, an IT team can create one overarching space with all their roadmaps, details of sub-teams, and a list of all the people and roles within that team. They could then create a new space for each sub-team, such as Quality Assurance, Developers, and Documentation, with guidelines, long term plans, and knowledge articles within them. Each project that these teams work on could also have its own space, which could be linked to the team spaces using labels.

**Create a personal space**

Your personal space is always owned by you, and you can use it to store...
your individual work, keep track of tasks, blog about what you've been working on, or just use it to polish your pages before you move them into a site space.

1. Choose your profile picture at top right of the screen, then choose Add Personal Space.
2. Choose Create.

You can change the permissions for your space at any time to determine who can and can't access the content. So if you want it to be a private sanctuary, that's no problem.

To create a personal space you need the 'Personal Space' global permission.

Create a personal space

With a personal space, you can...

1. **Stay organised**
   
   Keep your notes, task lists, files and other personal content organised.

2. **Share news**
   
   Use your blog to make announcements, capture ideas and share learnings.

3. **Introduce yourself**
   
   Customise your personal homepage and introduce yourself to the team.

Create a site space

You can create a site space for any team or project that would benefit from having a place where people can work together and store related files. You can create these as blank spaces, or use templates, called space blueprints, to help you create Team spaces, Knowledge Bases spaces, or Documentation spaces quickly and easily.

1. Hit Spaces > Create space in the header.
2. Pick a type of space.
3. Enter the required details and create your space.
Choose your space key carefully as you can't change this later.

Each space you create will automatically have a home page that you can customize to display relevant information for people viewing the space. If you use a space blueprint when creating a space, it will customize your home page for you.

To create a site space you need the 'Create Space' global permission.

Space permissions

Each space is created with a set of default permissions. The user who created a site space is automatically granted 'space admin' permissions for that space, which means that they can then grant permissions to other users and groups. See Space Permissions Overview for more information.

System Administrators can edit the permissions of spaces in their Confluence site at any time.

Linking related spaces

You can link related spaces together using labels. This will create categories in the space directory for each label, grouping all spaces with that label together.

- You can also add a space description to make it easier for visitors to find the right space within each category.
- To help navigate between related spaces, you can use the Spaces List Macro on a page and filter by category. This will let you insert a list of all the other spaces in a certain category into your space. You can use this, for example, to keep a list in your team space of all the project spaces your team is working on.
- If you want to link to only certain pages of related content, rather than whole spaces, you can use the Content Report Table Macro. You can use this, for example, in a space that functions as a workplace directory, to create a list of all the team pages with everyone's roles and contact details across your organization.
Tips

- If your needs change, or your spaces grow too big, it's easy to copy or move content from one space to another.
- If the content or purpose of your space changes, you can update the space name, logo, colors and description to reflect those changes.
- If you no longer need a space, such as when a project has been completed, you can archive it, which makes it less visible but retains the content on your site so that you can still refer back to it later.

Create a Space From a Template

Confluence comes with a number of templates, known as space blueprints, which have a customized homepage and sidebar, and may contain page blueprints or sample content to help you get started.

You can find blueprints for creating a team space, knowledge base space, documentation space, or software project space.

Your Confluence administrator can customize or disable your blueprint templates. See Create a Template and Administering Site Templates for more information on templates.

Types of Blueprints

Team space

A great building block if you are using Confluence as an intranet or to manage teams. Team spaces highlight the members of the team, and grants permissions to those users accordingly.

Knowledge base space

This space blueprint uses search and page labels to make content easier to find, right from the space homepage. It also contains two page blueprints for creating how-to and troubleshooting articles. The templates used in these page blueprints are completely customizable. The Knowledge Base space blueprint also Use JIRA applications and Confluence together.

Documentation space

This space blueprint displays the full page tree in the sidebar and hides other sidebar features including blogs and shared links. The homepage uses search and page labels to make content easy to find. Add the 'featured' label to any page you want to highlight on the homepage. This space does not include any page blueprints but you can create and promote templates for your documentation authors to use.

Software project space

This space is designed to help you organize your software project. The purpose-built space home page lets you view and edit your roadmap, see team members, and Use JIRA applications and Confluence together#JIRA Software. Create pages in this space for requirements, meeting notes, decisions, retros, and more. The software project space blueprint will only appear if you have linked Confluence to your JIRA Software instance.
Space Keys

Each Confluence space has a space key, which is a short, unique identifier that forms part of the URL for that space.

When you create a site space, Confluence will suggest a space key or you can enter your own key to make it more memorable.

For example, you might give your marketing team’s space a key of MARKETING. You can then navigate directly to the space using a URL like this - http://<yoursite>/display/marketing

Personal spaces always use your username as the space key.

Choosing a space key

Each space key:

- Must be unique.
- Can contain any alphanumeric character (a-z, 0-9).
- Can be up to 255 characters long.

⚠️ You can't change the space key after you create your space, so choose your space key carefully!
Navigate Spaces

How is content arranged in spaces?

Think of a space as the container that holds all the important stuff a team, group, or project needs to work. These are autonomous – that means that each space has its own pages, blogs, files, comments and RSS feeds.

Each space is automatically created with a homepage - the first page you'll see when you navigate to the space. You can edit your homepage and your sidebar to help people navigate their way around your space.

Spaces can't be nested – you can't have a space within a space – but you can Use Labels to Categorize Spaces. Spaces with the same label will appear together in the the space directory and in the recent activity area of the dashboard.

Inside the space, you can nest your pages, and you can create as many levels of hierarchy as you need. Each space also has its own blog, which lets you share news and make announcements. Blog posts are a great way to keep people involved in what's going on in your team or project.

You can set different levels of access for each space, and the pages and blogs within it, using Space Permissions Overview.

View all spaces in Confluence

There are two main ways to view spaces in Confluence:

- The space directory – choose Spaces > Space directory in the Confluence header for a list of all the site and personal spaces you have permission to see. Filter the list of spaces by selecting from the...
categories on the left of the space directory.

- **The dashboard** – you can make your most useful spaces appear under **My spaces** on the dashboard. Choose the star icon in the space sidebar or space directory to add a space to **My spaces**.

The **spaces menu** in the header also displays a list of your recently viewed spaces, allowing you to quickly navigate to the things you view most often.

The **Spaces List Macro** allows you to display a list of spaces on a Confluence page, and lets you filter them by category.

**Space Permissions Overview**

Each space in Confluence has its own set of permissions, which can be granted and revoked by a space administrator. The user that creates a space, like when you create your personal space, is automatically an administrator of that space, and they can add other space admins if they want to by adding the **Space Admin** permission to another user or group.

How do you find out who the space admin is for a particular space?
Choose **Spaces > Space directory** in the Confluence header, then choose the **Space Details** icon beside a space.

If you're one of those lucky space admins, you can assign permissions for the space to individual users, groups, or anonymous users. To change permissions for a space, choose **Space tools > Permissions** from the bottom of the sidebar, then choose **Edit Permissions** to change permission settings.

**Is your space using the Documentation theme?**

If your space is using the Documentation theme:

1. Choose **Browse > Space Admin** from the header

   **Note:** The **Space Admin** option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.

2. Choose **Permissions > Edit permissions**.

**Related pages:**

- Confluence Groups
- Assign Space Permissions
- Page Restrictions
- Global Permissions Overview
Space admins can also manage watchers for that space by choosing **Watch > Manage Watchers** at the top-right of any page in the space.

If you accidentally deny all admin access to a space so that nobody has access to administer the space any more, you can ask someone with Confluence Administrator global permission to **Assign Space Permissions**.

This page is about **Space Permissions**. Confluence also lets you set **Page Restrictions**.

### Permissions Summary

The following permissions can be assigned for each space:

<table>
<thead>
<tr>
<th>Permission</th>
<th>Applies to</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>This lets a user view all the content in your <strong>space</strong>.</td>
</tr>
<tr>
<td>Add</td>
<td>This lets a user add and edit <strong>pages</strong>, <strong>blogs</strong>, <strong>comments</strong> and <strong>attachments</strong>.</td>
</tr>
<tr>
<td>Restrict</td>
<td>This lets a user restrict others from viewing or editing a <strong>page</strong>.</td>
</tr>
<tr>
<td>Delete own</td>
<td>This lets a user delete any <strong>pages</strong>, <strong>blogs</strong> and <strong>attachments</strong> they originally created (regardless of whether other users have subsequently edited the content).</td>
</tr>
<tr>
<td>Delete</td>
<td>This can be used to let a user delete <strong>pages</strong>, <strong>comments</strong>, <strong>attachments</strong> and <strong>mail items</strong>.</td>
</tr>
<tr>
<td>Export</td>
<td>This lets a user export the whole <strong>space</strong>. This is different to <strong>page</strong> exports - anyone who can view a <strong>page</strong> can also export it.</td>
</tr>
<tr>
<td>Admin</td>
<td>This lets a user administer the <strong>space</strong>, including the ability to pass on admin permissions to other users.</td>
</tr>
</tbody>
</table>

Confluence administrators aren't necessarily space administrators. In order for them to be a space admin, they must belong to a group which has space admin and view permission for the space, or their username must be specifically granted space admin and view permission for the space. People with the System Administrator global permission automatically has space admin permissions for all spaces.

Space permissions are additive

Space permissions are additive. If a user is granted permissions as an individual or as a member of one or more groups, Confluence will combine these permissions together.

> Here's an example...

Sasha is a member of the **confluence-users** group and the **developers** group. The **confluence-users** group has 'export' permission, but does not have 'restrict' permission. The **developers** group has 'restrict' permission but does not have 'export' permission.

By being a member of these two groups, Sasha can restrict and export content. The permissions do not conflict, they combine to determine what Sasha is allowed to do in this space.

### Assign Space Permissions

If you are the administrator of a space, you control the permissions for it. You can choose to assign/revoke permissions on either an individual user basis, or by **Confluence Groups**.

Confluence Administrators can put users into groups to make it easier to manage permissions. If you are not an administrator and want to know if someone belongs to a group, ask your administrator.
Permissions in Confluence are additive, so if you belong to different groups with different permissions, you will have the combined permissions of those groups.

To access the permissions for a space:

1. Go to the space and choose **Space tools > Permissions** from the bottom of the sidebar
   - Using the documentation theme?
     Go to **Browse > Space Admin > Permissions**.
2. Choose **Edit Permissions**.

The Edit Space Permissions page is divided into the following sections:

- **Licensed Users** - this is where you grant permissions to groups and individual users.
- **Anonymous Access** - this is where you grant permissions to users who are not logged in (essentially making the space public)
## Assign space permissions

To add a new user or group to the permissions list, search for either a group or user in their respective sections and choose **Add**. The group or user will appear in the list of groups; select the specific permissions you’d like to apply then choose **Save all**. You can bulk assign or revoke permissions by selecting **Select All** or **Deselect All**.

There is no way to change permissions for multiple spaces at once. Permissions are managed on a space by space basis. However, your Confluence Administrator is able to set default space permissions, which will apply to any new spaces.

### Default Space Permissions

These are the default permissions that will be assigned to groups when someone adds a new space. The 'confluence-administrators' group always has all permissions for all spaces, and any permissions set for it here will be ignored.

<table>
<thead>
<tr>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Attachments</th>
<th>Comments</th>
<th>Restrictions</th>
<th>Mail</th>
<th>Space</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Delete Own</td>
<td>Add Delete</td>
<td>Add Delete</td>
<td>Add Delete</td>
<td>Add Delete</td>
<td>Add Delete</td>
<td>Add/Delete</td>
<td>Delete</td>
</tr>
<tr>
<td>confluence-users</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>developers</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
</tbody>
</table>
To set the default space permissions:

1. Go to
   > General Configuration > Space Permissions.
2. Choose Edit Permissions.

Default permissions are configurable for groups only, not for individual or anonymous users.

Revoke space permissions

To remove a user or group from the space permissions list, deselect all the checkboxes for that user or group and save the changes. The user or group won't appear in the list once you save.

Manage and recover space admin permissions

If you're a Confluence Administrator and a space admin accidentally denies all admin access to a space, so that nobody has access to administer that space any more, you are able to recover those permissions for them.

To recover Space Admin permissions:

1. Go to
   > General Configuration > Space Permissions.
2. Locate the space in the Individual Spaces list and choose Recover Permissions.

You can then choose Manage Permissions, and add any other appropriate permissions to the space. Requests to recover permissions are recorded in the Confluence audit log.

Users with System Administrator permissions are able to manage permissions for all spaces, they do not need to first recover permissions.

### Individual Spaces

<table>
<thead>
<tr>
<th>Name</th>
<th>Key</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design Team</td>
<td>AUDIT</td>
<td>Manage Permissions</td>
</tr>
<tr>
<td>Software project</td>
<td>SCRUM</td>
<td>Manage Permissions</td>
</tr>
</tbody>
</table>

Make a Space Public

If you want to share your space with people who are not logged in to Confluence (anonymous users), you can make your space public.

Making a space public does not let you choose who you want to share it with – a public space can be viewed by anyone inside or outside of your organization.

In order to make a space public, your administrator must first turn on the global permission for anonymous access.

This permission doesn't automatically grant anonymous users permission to see any of the content on your site, but it does need to be turned on to give space admins the option of granting anonymous users access to their space.
To make your space public:

1. Go to the space and choose Space tools > Permissions from the bottom of the sidebar.
2. Choose Edit Permissions.
3. Scroll down to the Anonymous Access section and select the specific permissions you’d like anonymous users to have.
4. Save All to apply the changes.

Is your space using the Documentation theme?

If your space is using the Documentation theme:

1. Choose Browse > Space Admin from the header
2. Choose Permissions in the space administration options.
3. Scroll down to the Anonymous Access section and select the specific permissions you’d like anonymous users to have.
4. Save All to apply the changes.

You can't grant space administration or page restriction rights to anonymous users.

If your Confluence administrator turns off anonymous access to your site, users who are not logged in will no longer be able to see any spaces. However, all logged in users (regardless of their group membership) will be able to see all spaces that have granted space permissions to anonymous users.

Give Access to Unlicensed Users from JIRA Service Desk

If you’re using Confluence as a knowledge base for JIRA Service Desk, you can choose to allow all active users and customers (that is, logged in users who do not have a Confluence license) to view specific spaces. This can only be turned on via JIRA Service Desk.

When a space is accessible to all active users, you’ll see the following message in the space permission screen.
Any active user can view this space

Any active user can view pages in this space, including users who don't have a Confluence license. This permission overrides all existing space permissions, so any logged in Confluence user will also be able to see the space (regardless of their group membership).

You can edit this permission at any time to revoke access to a space, but it can only be re-enabled from JIRA Service Desk.

Active users who don’t hold a Confluence license have very limited access to Confluence. They can view pages, but can't like, comment, edit, view the dashboard, use the space directory, see user profiles or search your full site.

See Use JIRA applications and Confluence together for more information about JIRA Service Desk integration.

Organize your Space

Here’s a few tips that'll help you organize your space so that everyone can find what they're looking for and stay on top of what's important to them.

How do I organize content within my space?

Pages and blogs

Everything you create in Confluence, from meeting notes to retrospectives and everything in between, takes the form of either pages or blogs.

- Your homepage will be the first thing that visitors to your site see, so to help them find relevant content, start by curating your homepage with useful macros and including information about what is in your space. See Set up a Space Home Page for more information.
- If you’re creating content that is specific mainly to the current time-frame, and isn’t going to change...
over time, create it as a blog post. Your blog displays as an infinite scroll, so it surfaces the latest news and visitors just need to scroll down if they’re interested in older content.

- If you’re creating content that you want to last, and possibly evolve over time, then create it as a page. Pages nest, so every page can have its own child pages, which lets you organize your content into categories and subcategories.

Configure the sidebar

You can Configure the Sidebar to make it easier to navigate through your space.

- The space shortcuts section of the sidebar lets you link to important content. You can use this to highlight pertinent pages within your space, related content from other spaces, or to external content that is relevant to your space.
- The navigation display lists all of the pages in your space in either a page tree or child pages format. If you only want some content to be visible in the sidebar, you can hide the navigation display and put the pages you want to remain visible under Space shortcuts instead.

![Screenshot: My Spaces in the dashboard](image)

Using Labels

Labels are keywords or tags that you can add to pages, blog posts, and attachments.

- Define your own labels and use them to categorize, identify, or bookmark content in Confluence. For example, if you assign the label 'accounting' to all accounts-related pages on your site, you’ll then be able to:
  a. Browse all pages with that label in a single space or across the site.
  b. Display a list of pages with that label.
  c. Search based on that label.
• Use the Content by Label Macro to create a table of contents for your space that is organized by label categories.
• Labels aren’t exclusive, so you can have as many labels as you want on a page. The page will then appear under each of those categories. See Use Labels to Categorize Spaces for more information.

How do I keep my space tidy?
If you have lots of people creating in the same space, things can get messy fast. You can prevent this by taking a few easy steps.

Create a set of guidelines
• Let your collaborators know about what parent pages to create their child pages under, so no content gets lost or misplaced.
• Decide on standard labels to add to pages, blogs, and attachments so all content gets neatly categorized.
• Add a link to this in the Space Shortcuts section of the sidebar so that it’s easy to find.

Use page blueprints
Blueprints are templates that come with formatting, macros and sample content. You can customize these Blueprints for each space. Everything created from a Blueprint will have it’s own index in the sidebar, so for example if you use the Meeting Notes Blueprint, you can select ‘Meeting Notes’ in the sidebar to see a list of all the meeting notes in your space.

Create from template macro
Make things simpler for other contributors by using the Create from Template Macro. The Create from Template Macro lets you put a button on a page that links to a specific template of your choice. When the button is clicked, the macro opens the editor, ready to add a new page, and adds content to that page based on the given template.

Create your own page templates
Create your own templates for any content that you want formatted the same way every time. For example, if you have to create a regular report tracking the same criteria, create a template with headings, variable dates, tables, and spaces for any graphics, so that each time all you have to do is input the new data instead of creating the whole report from scratch.

How do I help my team stay on top of what’s important?
If you’ve got a lot of content on Confluence, staying on top of everything may seem a little daunting – but these features will help your team save and track all the content they care about.

My Spaces
Add any spaces that you want to be able to navigate to easily to your list of 'My Spaces'. This list can be found under your dashboard and in the Space Directory, and you can also use the Spaces List Macro to display it on a page or blog.

To add a space to your list of 'My Spaces', either navigate to that space or find it under the Space Directory, and select the star icon next to the Space Name. To remove it from the list, just select the star icon again.

Screenshot: My Spaces in the dashboard

Save for later
If you only want links to certain pages or blogs rather than a whole space, you can choose Save for later and these will appear on your dashboard and under your profile. You can use the Favorite Pages Macro to display a list of all of everything you’ve saved for later.

Screenshot: Save for later

Watch a page, blog or space
If you want to keep track of all the changes made to a page, blog, or space, you can also watch them. Watching any content means that you will receive email notifications for all edits, deletions, attachments or comments made to that content.

- To watch a page, navigate to the page you want to watch, then choose Watch > Watch page, or if you want to watch the whole space, select Watch all content in this space.
- To watch a blog, navigate to that blog and choose Watch this blog.
- To stop watching something, deselect the relevant tick box.
You can also manage watchers for your own space. This is useful when, for example, you’re creating a new project, and want the team members on that project to stay notified of its progress. Go to any page in that space and choose **Watch > Manage Watchers**, then add or delete any names under ‘Watching this space’.

![Screenshot: Watching a page](image)

**@mentions**

Use @mentions for any work where you need someone else's input or want to assign someone a task. Mentioning someone works like a tag; they'll immediately receive a notification that they’ve been mentioned, and can click through to that page or blog. If you mention someone when creating a task, it'll assign that task to them and they'll also be able to find it under their profile.

You can use this in place of emails – if you want someone to look something over, add in additional information, or approve anything, simply put that work on Confluence and assign it to them as a task. They’ll be able to make any changes or comments within Confluence and let you know when they're done by mentioning you back.

**Set up a Space Home Page**

When you create a space, Confluence automatically creates a home page for that space. Spaces created with a blueprint come with a ready-made home page populated with useful macros and sample content specific to the blueprint’s use case.

However, even if you’ve started with a blank space, you can still customize your home page to make it easier for everyone using that space to navigate their way around and find useful content.

**On this page:**
- Create a kick-ass home page
- Top macros for common types of spaces
- Set up your personal space home page
- Set another page as your home page

**Related pages:**
- Organize your Space

Create a kick-ass home page

- **What is this space about?**
  Your home page is the first page visitors will see when they visit your space, so it helps to include some information about what the space is about, and what you're working on. You can use the Info, Tip, Note, and Warning Macros to create a colored box in which to put this information.

- **What is in this space?**
  You can use the Content Report Table Macro to create a table of contents for your space. You can also set this macro to only display content with a particular label, so if you would like only some content to display, you can do this by adding that label to only those pages and blogs you want listed...
on your home page.

- **Organize your space with labels**
  You can organize content in your space with labels, so that for example, if you have a Learning and Development space, you can create different labels for online learning resources, upcoming workshops, and training strategy. You can then use the **Labels List Macro** to create a list of those labels to make it easy for visitors to your space to find the content relating to each of those topics.

- **Add a search box so that it’s easy to find content within your space**
  The **Livesearch Macro** allows you to add a search box to a Confluence page, and you can set it to only find content within your space.

- **Keep everyone updated about the latest changes within your space**
  If it’s important for your visitors to know about the latest changes to your space, you can use the **Recently Updated Macro** to display a list of the most recently updated content. You can set the space parameter to show this for just your space, or, if you have related spaces, to show the most recently updated content across all of those spaces as well.

- **Using JIRA? Create and display your JIRA issues on Confluence**
  If your Confluence site is connected to a JIRA application, you can both create and display your JIRA issues without having to leave Confluence using the **JIRA Issues Macro**. You can connect Confluence to any JIRA application, including JIRA Software and JIRA Service Desk.

**Screenshot: Space Home Page**

**Top macros for common types of spaces**

**Team Spaces:**

- **Introduce the team:** The **User Profile Macro** displays a short summary of a given Confluence user's
profile with their role, profile photo and contact details.

- **Share news and announcements with your team:** The Blog Posts Macro displays a stream of your latest blog posts so your team can easily see what's been going on.

**Knowledge Base:**

- **Have external content that you need on your page?** Embed online videos, slideshows, photo streams, and more, directly into your page with the Widget Connector Macro.
- **Put your own multimedia content onto the page:** The Multimedia Macro embeds attached video, animation, and other multimedia files on a Confluence page.
- **Create an index of all your content:** The Page Index Macro creates a hyperlinked alphabetical index of all page titles within the current space.

**Planning/Project:**

- **Keep track of everyone's tasks:** Use the Task Report Macro to display a list of tasks on a page. Filter the tasks by space, page, user, label, created date and more.
- **Is your project on track?** The Status Macro displays a colored lozenge (a rounded box) that is useful for reporting project status. You can choose the color of the lozenge and the text that appears inside the lozenge.
- **Let everyone see where you're going:** The Roadmap Planner Macro creates simple, visual timelines that are useful for planning projects, software releases and much more.

### Using Macros

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Autocomplete for links, files, macros and mentions**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Set up your personal space home page

Whether you're using your personal space as a sandbox to draft and test content, a portfolio to show off what you're working on, a home base to navigate to your content in other spaces, or something completely different, these are some macros that should help you use your space more effectively.

- Use the Favorite Pages Macro to create a list on your home page of all the pages you've saved for later, so you can easily navigate back to any of them.
- Use the Content by User Macro to keep track of all the current pages, comments and spaces you've created so you can find everything you've been working on in one place.
- Use the Task Report Macro to keep track of all tasks assigned to you, and tick them off as you finish them.
- Use the Recently Updated Dashboard Macro to keep track of all the content across your Confluence site that you're interested in - the Dashboard lets you choose which spaces, users, blogs, pages or files you would like to keep updated about.

### Set another page as your home page

If at any point you decide that you would like another page within your space to be your home page, you can easily change this from the Edit Space Details tab.

To edit a space's details:

1. Go to the space and choose **Space tools > Overview** from the bottom of the sidebar.
2. Choose **Edit Space Details**.
3. Enter the page you want use in the **Home page** field then choose **Save**.
Use Labels to Categorize Spaces

If you've got lots of related spaces, you can use labels to group them together into categories in the Space Directory.

For example, if you're in an IT team who work on a number of projects, each in a different space, you could label each space 'IT-projects-open'. Then in the Space Directory you could select IT-projects-open to see all your current IT project spaces.

You can add as many space categories to a space as you need, so that if, for example, two different teams are working on a project together, you can add labels for both teams and space will appear under both categories.

Labels are easy to add or remove, so if your needs change, you can always recategorize your spaces.

Categorize a space

You need space administrator permissions to add categories to a space.

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar
2. Choose Edit next to Space Categories.
3. Under Space Categories, enter your category name and choose Add. Alternatively, choose a category in the list of Suggested Space Categories.
4. Choose Done.

Is your space using the Documentation theme?

If your space is using the Documentation theme:

1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're
part of the ‘confluence-administrators’ group.
2. Choose Space Labels in the space administration options.
3. Under Space Categories, enter your category name and choose Add
   Alternatively, choose a category in the list of Suggested Space Categories.
4. Choose Done.

Add a space description

Help make it easier to find the right space within a category by adding a description to your space:

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar.
2. Choose Edit Space Details.
3. Under the Description field, type a short description to tell visitors what your space is about, then choose Save.

View spaces in a category

To see what spaces are in a category, choose Spaces > Space directory in the Confluence header, then select one of the categories from the list.

Remove a space from a category

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar
2. Choose Edit next to Space Categories.
3. Under Space Categories, choose the x icon next to each category that you want to remove.
If you remove all spaces from a category, the category will no longer appear in the Space Directory. There's no way to bulk remove a category, but you can choose the category in the Space Directory to find all the spaces it appears on, and then remove it from each space.

Customize your Space

Make your space stand out from the crowd by customizing its appearance.

If you have space admin privileges, you can change the color scheme for your space, add your own space logo, choose what shows up in your space's sidebar, or use Atlassian Marketplace themes to change the whole look of your space.

- Configure the Sidebar
- Edit a Space's Color Scheme
- Apply a Theme to a Space
- Customize Space Layouts

Configure the Sidebar

If you have administration permissions for a space, you can customize the space's sidebar to have its
own logo, change the way the hierarchy is displayed, and add shortcut links to help navigate to important content quickly.

To start configuring the sidebar, choose **Space tools > Configure sidebar**.

If you're using the Documentation theme see **Configure the Documentation Theme** to find out how to edit the sidebar in that theme.

Change the space name and logo

**To change the space name:**

1. Choose

   next to the space name.

2. Type in a new space name and **Save**.

**To change the space logo:**

1. Choose the

   next to the space name.

2. Choose **Upload an image**.

3. Select an image from your computer.

4. Adjust the size of the image to fit within the highlighted circle.

5. Choose **Save**.

**Things you should know:**

- Space logos are 48px x 48px. Logos smaller than these dimensions will be centred with whitespace around them.
- You can only change the space logo for a site space. For your personal space, your profile picture is used as the space icon.
- The space logo in the default theme is always round. This cannot be changed.

Configure the sidebar links

- Choose the icons to show or hide **pages, blogs, shortcuts** or **navigation options**.

  For example, if you want your space to be used primarily as a blog you can hide the ‘Pages’ link.

- **Add-ons** such as **Team Calendars for Confluence** may add other links in this section of the sidebar and you can also show or hide these.

- Choose **Add link** to add a shortcut link to the sidebar. This could be a link to an important page for your team, or to an external site.

- Drag links to reorder them within each section (you can't move a link from one section to another).
Change the navigation display options

- Choose Child pages to see the current page and its children in the sidebar.
- Choose Page tree to see the page tree for the entire space, expanded to the current page.
- You can also choose to completely hide the navigation display options and instead add the pages you want to visible as shortcut links. Alternatively, you can remove the sidebar navigation altogether and use a Page Tree Macro or Children Display Macro on your homepage for navigation instead.

Adding custom content to a sidebar

You can further customize a sidebar using wiki markup to add custom content.

To add custom content to your sidebar:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar.
2. Choose Sidebar, Header and Footer.
3. Enter your custom content in the Sidebar field.

The sidebar, header and footer fields all use wiki markup, check our guide to wiki markup for help, or check out some common customizations below.

- Add a search field to your sidebar...

To add a search field to the sidebar add the following wiki markup for a search macro in the Sidebar field.

For the Livesearch Macro macro:

```
{livesearch}
```

For the Page Tree Search Macro macro:

```
{pagetreesearch}
```

- Add a panel with some content...

To add a panel with some custom content to the sidebar add the following wiki markup for the Panel Macro in the Sidebar field:

```
{panel}This is some custom content to appear in the sidebar{panel}
```

- Add your own page tree to replace the default page tree...

To hide the default page tree and add your own, with additional parameters:

1. Add the wiki markup for the Page Tree Macro in the Sidebar field.
   The following example includes parameters to expand the top three levels of the page tree by default and include an Expand All and Collapse All link above the tree.

   ```
   {pagetree:root=Page Name|startDepth=3|expandCollapseAll=true}
   ```

2. Go to Space Tools > Configure sidebar.
3. Use the Show and Hide icons to hide the default page tree from the sidebar.

Edit a Space’s Color Scheme

Spaces inherit the global color scheme by default, but if you have admin permissions for a space, you can jazz it up with your very own customizable color scheme.

To change the color scheme for a space:
1. Go to the space and choose **Space tools > Look and Feel** from the bottom of the sidebar
2. Choose **Color Scheme**
3. Choose **Select** next to a scheme listed under **Custom Color Scheme** (if not already selected)
4. Choose **Edit**
5. Enter standard HTML/CSS2 color codes or use the color-picker to choose a new color from the palette provided

**Customizable Elements**

The color scheme allows you to edit the colors of UI elements including the top bar, tabs and backgrounds.

Some UI elements below are for specific themes, and color changes may not take effect for other themes.

- **Top Bar** - the top navigation bar background
- **Top Bar Text** - the text on the top navigation bar
- **Header Button Background** - buttons on the top navigation bar (e.g. Create button)
- **Header Button Text** - the text on buttons on the top navigation bar
- **Top Bar Menu Selected Background** - background color of top navigation bar menu items when selected (e.g. spaces)
- **Top Bar Menu Selected Text** - text color of top navigation bar menu items when selected
- **Top Bar Menu Item Text** - text on top navigation bar drop down menus (e.g. help or cog)
- **Menu Item Selected Background** - highlight color on top navigation bar drop down menu items
- **Menu Item Selected Text** - text color on highlighted top navigation bar drop down menu items
- **Search Field Background** - the background color of the search field on the header
- **Search Field Text** - the color of the text in the search field on the header
- **Page Menu Selected Background** - the background color of the drop down page menu when selected
- **Page Menu Item Text** - the text of the menu items in the drop down page menu
- **Heading Text** - all heading tags throughout the space
- **Space Name Text** - the text of the current space name located above the page title
- **Links** - all links throughout the space
- **Borders and Dividers** - table borders and dividing lines
- **Tab Navigation Background** - the background color of the tab navigation
- **Tab Navigation Text** - the text of the tab navigation when highlighted
- **Tab Navigation Background Highlight** - the background color of the tab navigation when highlighted
- **Tab Navigation Text Highlight** - the text of the tab navigation elements when highlighted

*Screenshot: Editing the color scheme*
Handy Hint
If you mess things up, just choose Reset then try again.
Apply a Theme to a Space

Themes are used to change the appearance of your space. Confluence comes with two themes - the default theme and documentation theme, or your Administrator can download and install other themes from The Atlassian Marketplace.

Once a theme is installed it can be applied to the whole site or to individual spaces.

To apply a theme to a space:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar. You'll need Space Admin permissions to do this.
2. Choose Themes and select a theme option.
3. Choose Confirm.

Is your space using the Documentation theme?
If your space is using the Documentation theme:

1. Choose Browse > Space Admin from the header.

   Note: The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.
2. Choose Themes and select a theme option.
3. Choose Confirm.

What is the global look and feel?

When a new space is created, whichever theme is applied to the whole site will be applied by default to the new space. This is the global look and feel, and any changes made globally will flow through to all spaces that inherit the global look and feel.

If a space has its own theme applied, or if changes have been made to customize the look and feel of the space, it will no longer inherit changes from the global look and feel.

If you want to go back to inheriting the global look and feel choose Global look and feel from the Themes page.

Switch to the Default Theme

If you use the Documentation theme in your spaces, it’s time to consider switching to the Confluence default theme.

A growing number of great features (such as JIRA links button, space shortcuts and sticky table headers) are not available in the Documentation theme, and we plan to retire this theme altogether in the near future.

This page will show you how to turn on the default theme, and keep any existing header, footer or sidebar content.

Here’s an example of the documentation theme, and default theme with the same custom content side by side:
Understanding global look and feel

Before you start, it’s important to understand the idea of “global look and feel”. Confluence allows you to apply most themes to an individual space, or to the whole site. When a space says it is using the ‘global look and feel’ it means it is using whichever theme has been applied for the whole site, and inheriting any customizations from the site level.

The Confluence default theme, however, can only be applied to a space if it is currently applied to the entire site (it must be the current global look and feel).

Switch your space to the default theme

To turn on the default theme and keep any existing header, footer or custom sidebar content:

1. Go to Browse > Space Admin > Theme and then Configure theme.
2. Copy the wiki markup from the Navigation, Header and Footer fields to somewhere safe (like a document or text file) then Cancel.
   (If these fields are empty, you can go straight to the next step).
3. Select Global look and feel (that’s the default theme) and choose Confirm.

Choose Global Look and Feel to switch to the default theme

(If Global Look and Feel is already listed as your current theme you’ll need to follow the steps below to change your Site theme first).

4. The default theme is now enabled - you’ll notice the space admin options have moved. Choose the Header, Footer and Sidebar tab.
5. Paste the wiki markup for your custom sidebar content (navigation), header and footer into the fields provided then Save.
6. Use the space name link in the sidebar to get to the space homepage and check the appearance of your space.

The default theme includes some extras in the sidebar, such as shortcuts and index pages for blogs and blueprints. Your custom content will appear between the shortcuts and page tree. To choose what you'd like to show or hide:

1. Go to **Space Tools** (at the bottom of the sidebar) and select **Configure Sidebar**.
2. Use the
   
   −
   
   +
   
   icons to show and hide each section.
3. This is where you can change the site logo too.

You can't hide the space name or logo.

**Make the default theme available across the whole site**

If the Documentation theme is enabled for the entire site, you won't see an option to switch to the default theme in each space. This means that before you can switch each space over to the default theme, you'll need to make it available for the whole site.
To make the default theme available across your whole site:

1. Go to
   > General Configuration > Themes
2. Choose Configure theme beside the Documentation theme
3. Copy any wiki markup from your header, footer and sidebar fields to somewhere safe (like a document or text file) then Cancel.
   (If these fields are empty, the Documentation theme has not been customized for the entire site)
4. Select the Default theme and choose Confirm.
   The default theme is now the global look and feel. If you did not need to copy over any wiki markup, the process is now complete.
5. If you have wiki markup to migrate, go to
   > General Configuration > Sidebar, header and footer
6. Paste the wiki markup for your custom sidebar content (navigation), header and footer into the fields provided then Save.

All new spaces will now be created with the default theme.

The impact on existing spaces depends on how the theme is applied:

- All spaces that used the Documentation theme because it was the global look and feel will now use the default theme. You don’t need to do anything.
- All spaces that have the Documentation theme explicitly applied (for example to enable different wiki markup in the sidebar, header or footer) the documentation theme will still be applied, and you’ll need to migrate each one separately.

Hints and tips for the sidebar

Here’s a few hints and tips for making your sidebar migration as easy as possible.

Do you need to use wiki markup?

If the wiki markup in the Documentation theme for your space was simple, for example just adding a page tree and a couple of links to useful spaces or external sites, chances are you don’t need to continue to customize the sidebar at all. The default theme comes with a page tree option, and you can add links to pages, spaces or websites. These space shortcuts are much easier to keep up to date (and are safe from page renames). You can also hide the page tree if you’d rather not have it show.

Are you using space CSS to style the theme?

If you're overriding the space CSS to change the appearance of the doc theme sidebar, you'll probably need to make some changes to your CSS, as some class and ID names are different between the two themes.

For example, instead of specifying #splitter-sidebar, you'll need to use .acs-side-bar.

Edit the header, footer or custom sidebar content

You can update the wiki markup for the sidebar, header and footer at any time. Go to Space Tools > Look and Feel > Sidebar, Header and Footer.

These fields use wiki markup, check our guide to wiki markup for help, or check out some common customizations below.

- Add a search field to your sidebar...
  To add a search field to the sidebar:
   1. Go to Space Tools > Look and Feel > Sidebar, Header and Footer
   2. In the Sidebar field add the wiki markup for either the Livesearch or Page Tree Search macros
3. The search field will appear above the page tree.

Expand a panel with some content...

To add a panel with some custom content to the sidebar:

1. Go to Space Tools > Look and Feel > Sidebar, Header and Footer
2. In the Sidebar field add the wiki markup for the Panel Macro then add some text:

   {panel}This is some custom content to appear in the sidebar{panel}

3. Your content will appear above the page tree.

Documentation theme features that aren’t available in the default theme

Not all documentation theme features are available in the default theme.

Limit search results to the current space

We’ve decided not to add the ability to restrict the Confluence search on the header to a single space. You will still be able to add the Live Search or Page Tree Search macros to the sidebar or homepage of your space, and set these macros to only return results from the current space.

Space jump macro

This macro is part of the documentation theme. It will be removed when we remove the Documentation theme.

Child pages below the page content

In the Documentation theme, children of the current page are listed below the page content. This is not available in the default theme, however you could choose to add a Children Display Macro to the footer in the default theme.

View pages alphabetically

In the Documentation theme you could choose to view all pages in a site alphabetically. This isn’t available in the default theme.

Troubleshooting

Find out which spaces are using the Documentation theme

There’s no simple way to see a list of spaces using the Documentation theme in Confluence itself, however if you have a very large site, your Confluence Administrator can use the following query to get a list of spaces directly from the database.
This query will only find spaces that are explicitly using the documentation theme. It doesn't include spaces using the global look and feel (these spaces automatically change when you change the Site Theme, you won't need to change the theme space by space).

Check for layout changes

If the underlying layout templates for your spaces have been customized, you may find that your space looks strange or broken when you apply the default theme.

If this happens, you can reset the templates back to the default. You'll need to be a Site Administrator to do this.

1. Switch back to the Documentation theme temporarily.
   (If you're unable to use the space navigation, use this URL, replacing YOURSPACEKEY with the space key for the space.

   ![URL](http://<yoursite>/spaces/choosetheme.action?key=YOURSPACEKEY)

2. Go to **Browse > Administration > Layouts** or use the following link if you're unable to get there via the space navigation.

   ![URL](http://<yoursite>/spaces/listdecorators.action?key=YOURSPACEKEY)

3. Choose **Reset Default** next to any template that have been customized.
4. Return to the **Themes** page and try applying the default theme again.

The Documentation Theme

The Documentation theme is going away in Confluence 6.0.
[Read more about this change.](#)

The Documentation theme is one of the themes bundled with Confluence. It provides an inbuilt table of contents for your space, a configurable header and footer, and text styles suited to documentation. You can also configure it to restrict the search results to the current space, rather than searching the entire Confluence site.

⚠️ Please note, the Documentation theme doesn't support the JIRA links feature.
Quick guide to using the Documentation theme:

- The left-hand panel contains a page tree. This is a table of contents that shows the pages in the space.
- Pages with arrow symbols to their left have child pages. Choose the arrow(s) to show and hide child pages.
- Drag the thick vertical bar between the left-hand panel and the page to change its width.
- Choose the left-hand panel icon ![icon](image) in the header, next to the search field, to hide or show the left-hand panel. Alternatively, press '[' on your keyboard to show/hide the left-hand panel.
- Overriding a space-restricted search: If your theme is configured to restrict the search to the current space, you can enter 'all:' and your search term to search the entire site.
Customize the Documentation Theme

A space administrator can customize the Documentation theme as follows:

- Change the content in the left-hand panel and add a header and footer to the page.
- Restrict the search so that it will show results from the current space only, not from the entire Confluence site.

For more, see Configure the Documentation Theme

**Search the space or the site**

When using the Documentation theme, the Confluence search offers a few options as described below.

Using the search box at the top right of the page:

- By default, the main Confluence search is configured to search the entire Confluence site.
  - You will see the words ‘Search Confluence’ in the search box at top right of the page.
  - The Confluence search will look for matches in the entire Confluence site. This is the default behavior for other themes too.
- A space administrator can configure the Documentation theme to restrict the search to the current space.
  - You will see the words ‘Search this space’ in the search box at top right of the page.
  - The search will return results from the current space only.
  - You can override the search restriction. Enter ‘all:’ and your search term to search the entire site. For example, enter the following into the search box at top right of the page to search the entire site for ‘technical writing’:

```
all: technical writing
```

Using the search box in the left-hand panel:

- By default, the Documentation theme’s left-hand panel includes a search box. Enter your search term there, to restrict the search to the current space. Specifically, this will search only the pages that are children of the space’s home page.
- If your administrator has restricted the main search to the current space, there will not be a search box in the left-hand panel.
Hints and tips

Below are some hints that you may find useful when using the Documentation theme.

Where can I see a working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme's table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page. Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

**Cause 1: Your pages are not under the space’s home page.** The most probable reason why your pages do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space’s home page. If your pages are above the home page in the page tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

- You can change the designated space home page in the space administration section.
- Or you can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the ‘Pages’ section of the space ‘Browse’ screen. See Move and Reorder Pages.

**Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with Documentation theme bundled.** If your existing Confluence installation already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar icon at top right, next to the search box. Click the icon again to restore the panel.

Can I change the default width of the left-hand navigation panel?

The Confluence user interface does not offer a way to change the default width of the left-hand navigation panel supplied by the Documentation theme. Users can change the width by dragging the middle bar, but the default width is not configurable. This post on Atlassian Answers gives a way to do it with CSS: Documentati on Theme - Default Width (in px) of left panel.

Notes

- The Confluence default theme supplies a sidebar, which is different to the left-hand panel in the Documentation theme. For information about the sidebar, see Configure the Sidebar.
- The Documentation theme supplies a Browse menu in the Confluence header, which gives access to the space administration and advanced options.

Configure the Documentation Theme

The Documentation theme is designed for spaces containing technical documentation, but you may find it useful for other types of structured content. It provides a table of contents for your space, a configurable header and footer, and text styles suited to documentation. (See features below.)
Quick guide to applying and customizing the Documentation theme:

- Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar
- Choose Themes.
- Select Documentation Theme and choose Confirm.
- If you want to customize the theme, choose Configure theme.
  - Select or deselect the default page tree.
  - Select or deselect the space-restricted search.
  - Enter the text and wiki markup for your custom left-hand panel header and footer.
  - Choose Save.

The rest of this page gives more details of the above procedure.

On this page:

- Applying the Documentation theme to your space
- Applying the Documentation theme to your site
- Customizing the Documentation theme
  - Customizing the theme at site level
  - Features of the Documentation theme
  - Hints and tips
  - Notes

Related pages:

- Apply a Theme to a Space
- Apply a Theme to a Site
- Edit a Space's Color Scheme
- Customize your Space

*Screenshot: The Documentation theme showing the space sidebar replaced by a navigation sidebar.*
Applying the Documentation theme to your space

Follow the steps below to apply the Documentation theme to your space. All pages in the space will start using the theme immediately.

To apply a theme to a space:

1. Go to the space and choose **Space tools > Look and Feel** from the bottom of the sidebar. You'll need **Space Admin permissions** to do this.
2. Choose **Themes** and select a theme option.
3. Choose **Confirm**.

*Screenshot: Applying a theme*
If your space is using the Documentation theme:

1. Choose **Browse > Space Admin** from the header
   
   **Note:** The **Space Admin** option appears only if you have **space admin permissions**, or if you're part of the 'confluence-administrators' group.
2. Choose **Themes** from the space administration options
3. Select a theme option
4. Choose **Confirm**

**Applying the Documentation theme to your site**

If you have site administrator permissions, you can apply the theme at site level. It will then be the default theme for all spaces in the site. See the administrator's guide to **applying a theme**.

**Customizing the Documentation theme**

The theme works well without any customization. If necessary, you can restrict the search to just one space, change the content of the left-hand navigation panel and add your own header and footer. The following instructions assume you have already applied the Documentation theme.

**To customize the Documentation theme:**

1. Choose **Browse > Space Admin** from the header
   
   **Note:** The **Space Admin** option appears only if you have **space admin permissions**, or if you're part of the 'confluence-administrators' group.
2. Choose **Themes** in the left-hand panel under the heading 'Look and Feel'.
3. Choose **Configure theme** in the yellow area of the 'Current Theme' section at the top of the page. See screenshot below. The 'Documentation Theme Configuration' screen appears. See screenshot be low.
4. Select or deselect the **Page Tree** check box. This determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.
5. Select or deselect the **Limit search results to the current space** check box.
   - If you select the check box:
     - The Confluence search will look for matches only in the current space by default. Users can override this restriction when entering their search term. See [The Documentation Theme](#).
     - The default page tree in the left-hand panel will not include a search box.
   - If you do not select the check box:
     - The Confluence search will look for matches in the entire Confluence site. This is the default behavior for other themes too.
     - The default page tree in the left-hand panel will include a search box, which restricts search results to the current space.

6. Enter text, images, macros and other wiki markup into any or all of the three text boxes.
   - You can use the Include or Excerpt Include to include re-usable content into your footer. See hint below.
     - 'Navigation' – This text box contains content for the left-hand panel.
       - If the **Page Tree** check box is selected, the navigation panel contains the default search box and page tree. Any content you enter into the 'Navigation' text box will appear above the page tree and search box.
       - You can include your own content *underneath* the page tree as well as above. See hint below. In summary: Deselect the **Page Tree** check box. Insert your own page tree using the **Pagetree macro**, then add your own content under the macro.
     - 'Header' – This text box contains content for a page header that will appear above the page title on all pages in the space. See example screenshot below.
     - 'Footer' – This text box contains content for a page footer that will appear after the comments and above the site footer, on all pages in the space. See example screenshot below.

7. Choose **Save**.

*Screenshot: The 'Configure theme' option*
Current Theme

The current theme controls the layout and colours of this space.

**Documentation Theme**

This theme is well suited for structured content, such as documentation. It features a table of contents (page tree) on the left, making it easier to see the structure of a space and move from page to page. You can customise the left-hand panel, page header and page footer.

**Configure theme** - further customise this theme's options

Choose New Theme

To change the theme of this space, select one below.

- ☑ Global Look and Feel
  The globally configured look and feel. You can customise colour-schemes and layouts manually.

Find more themes...

Confirm

Screenshot: Customizing the Documentation theme
Customizing the theme at site level

If you have site administrator permissions, you can apply and customize the theme at site level. The customization options are the same as the space level options, as described above.

Features of the Documentation theme
Here's a summary of the features that the Documentation theme provides:

- By default, the left-hand panel contains a search box and a table of contents (page tree) showing all the pages in your space. Specifically, it shows the pages that are children of the space’s home page.
- The left-hand panel is fully customizable. You can choose to include or exclude the search box and page tree. You can enter your own text, images and wiki markup.
- People viewing the page can drag the thick bar between the left-hand panel and the content, to increase or decrease the width of the panel. They can also remove the panel altogether, by clicking the sidebar icon at top right, next to the search box.
- The left-hand and right-hand panels scroll independently of each other.
- The page title is neatly above the page content, and not uncomfortably above the navigation panel as tends to happen when you insert the navigation panel yourself.
- Because the left-hand panel is part of the theme, it will be upgraded whenever Confluence is upgraded. There is no need to remove and then re-apply your customizations on each upgrade, as you would do if you added your own left-hand navigation bar.
- The theme also provides a customizable header and footer, which will appear at the top and bottom of every page.
- The text and heading styles are designed to enhance the content typically found in a documentation space.
- You can use the Space Jump macro to link from a page in one wiki space to a page with the same name in another space, without knowing the name of the page when you create the link.
- You can limit the Confluence search results to the current space. If you choose this option, the Confluence search will look for matches only in the current space by default. Users can override the restriction. See The Documentation Theme.

Hints and tips

Below are some hints that you may find useful when using the Documentation theme.

Where can I see a working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme’s table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page. Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

Cause 1: Your pages are not under the space’s home page. The most probable reason why your pages do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space’s home page. If your pages are above the home page in the page tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

- You can change the designated space home page in the space administration section.
- Or you can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the ‘Pages’ section of the space ‘Browse’ screen. See Move and Reorder Pages.

Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with Documentation theme bundled. If your existing Confluence installation already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably
Can I change the default width of the left-hand navigation panel?

The Confluence user interface does not offer a way to change the default width of the left-hand navigation panel supplied by the Documentation theme. Users can change the width by dragging the middle bar, but the default width is not configurable. This post on Atlassian Answers gives a way to do it with CSS: Documentati on Theme - Default Width (in px) of left panel.

Hiding pages from the left-hand table of contents

You can ‘hide’ pages by putting them at the same level as or higher than the space home page.

Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page.

If your documentation pages are at the same level as the space home page, they will not appear in the left-hand navigation bar. So you can ‘hide’ pages by putting them at the same level as or higher than the space home page. The pages will show up in the search results and people can see the content if they open the page, but the pages will not appear in the left-hand panel.

More detail: The theme uses the Pagetree macro to produce the table of contents. When entering the Pagetree macro, you can choose the top page in the page tree. The Documentation theme chooses the space home page as the top page.

Using reusable content in your header, footer or sidebar

You can use any text or wiki markup in your theme header, footer or left-hand panel. One useful hint is to use the Include or Excerpt Include to include re-usable content into your footer.

The screenshot above shows the theme customization options, with examples of the macros used to include content from other pages. And the example screenshot also above shows the resulting header, footer and left-hand panel.

Adding content below the page tree in your sidebar

If you want to include your own content underneath the page tree, you can deselect the ‘Page Tree’ check box, add your own page tree using the Pagetree macro in the ‘Navigation’ text box, and then add your own content under the macro.

The screenshot above shows the theme customization options, with the default page tree deselected and a custom page tree inserted, along with additional content in the left-hand panel. The example screenshot also above shows the resulting left-hand panel.

Adding an expanding All Versions section to the sidebar

If you want to include a an expanding list of links to other spaces, as we have included in this space (see ‘Docs for all Confluence releases’ in the sidebar), you can use an Expand Macro and an Include Page Macro in the ‘Navigation’ text box. For example:

```
* {Docs for all Confluence releases|_Latest Versions of Confluence Documentation}*
{expand:Choose a version...}
{include:_Latest Versions of Confluence Documentation}
{expand}
```

If you would like this to display below the page tree, follow the steps above.

Adding underlines to your links

By default, the Documentation theme does not underline hyperlinks. If you prefer to have your links underlined, you can edit the CSS stylesheet for your space and add the following CSS code:
To edit a space’s CSS style sheets:

1. Go to the space and choose **Space tools > Look and Feel** from the bottom of the sidebar
2. Choose **Stylesheet** then **Edit**.
3. Paste your custom CSS into the text field.
4. Save your changes. The new CSS will be visible on all content pages in the space.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** from the header
   
   **Note:** The **Space Admin** option appears only if you have **space admin permissions**, or if you’re part of the ‘confluence-administrators’ group.
2. Click **Stylesheet** in the left-hand panel under the heading ‘Look and Feel’.
3. Choose **Edit**.
4. Paste your custom CSS into the text field.
5. Save your changes. The new CSS will be visible on all content pages in the space.

**Note:** By default, only system administrators can edit the CSS for a space or for the site. To allow any user with Space Admin permissions to edit the CSS for a space, go to

> **General Configuration** > **Security Configuration** and select **Custom Stylesheets for Spaces**.

Jumping to the same page in another space

The `{spacejump}` macro is provided along with the Documentation theme. You can use space jumping to link from a page in one wiki space to a page with the same name in another space, without knowing the name of the page when you create the link. When a reader is viewing a page and chooses the link provided by the macro, they will go to a page with the same name, but in the space specified in the macro. See more about the **Space Jump** macro.

Hiding the left-hand panel completely

It’s not possible to remove the left-hand panel entirely, using the user interface supplied by the theme. There is an improvement request here:

| CONF-25923 - Provide option to hide the left-hand panel entirely in the Documentation theme | RESOLVED |

If you like, you can comment on and/or vote for that request. In the meantime, **Atlassian Answers** is a good place to ask the question and see if other people can help you with custom code to remove the panel.

**Notes**

- The Confluence default theme supplies a **sidebar**, which is different to the left-hand panel in the Documentation theme. For information about the sidebar, see **Configure the Sidebar**.
- The Documentation theme supplies a **Browse** menu in the Confluence header, which gives access to the space administration and advanced options.

**Customize Space Layouts**

You can modify Confluence’s look and feel by editing the layout files. This page tells you how to customize the layout files for a space. You’ll need **space administrator** permissions for that space.

If you’re a Confluence system administrator, you can also customize the layout of your entire Confluence site. For more information, see **Customizing Site and Space Layouts**. Site layout customizations modify the default layout of all spaces in the Confluence site.
Any space layout customizations will override the equivalent site customizations.

If you modify the look and feel of Confluence by following these instructions, you'll need to update your customizations when you upgrade Confluence. The more dramatic the customizations are, the harder it'll be to reapply your changes when upgrading. Please take this into account before proceeding with any customizations.

For more information on updating your customizations, please refer to Upgrading Customized Site and Space Layouts.

Confluence is built on top of the Open Source SiteMesh library, a web-page layout system that provides a consistent look and feel across a site. SiteMesh works through 'decorators' that define a page’s layout and structure.

To edit the layout of Confluence, you will need to modify these decorator files. A decorator file is a .vmd file and is written in a very simple programming language called **Velocity**. Learn more about **Velocity**. Once you become familiar with Velocity, you can edit the decorator files to personalize the appearance of Confluence.

The decorator files in Confluence are grouped into the following categories:

- **Site layouts**: These are used to define the controls that surround each page in the site. For example, if you want to make changes to the header and the footer, you will need to modify these layouts.

- **Content layouts**: These control the appearance of content such as pages and blog posts. They do not change the way the pages themselves are displayed, but they allow you to alter the way the surrounding comments or attachments are shown.

- **Export layouts**: These control the appearance of spaces and pages when they are exported to HTML. If you are using Confluence to generate a static website, for example, you will need to modify these layouts.

Learn more about using **decorators**.

**To edit a decorator file:**

1. Go to the space and choose **Space tools > Look and Feel** from the bottom of the sidebar.
2. Choose **Layout** (*Layout* is displayed only if you are a Confluence system administrator.)
   You’ll see a list of the layouts for the space.
3. Click **Create Custom** to edit the default vmd file
   This will open up the vmd file in edit mode. If you only want to view the vmd file, click **View Default**.
4. Make any changes and click **Update**

You can’t update the layout templates if your space is using the Documentation theme.

**Screenshot : Edit Layouts Example**

<table>
<thead>
<tr>
<th>Decorator</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Space Layout</strong></td>
<td>Controls how a space is displayed.</td>
</tr>
<tr>
<td></td>
<td>&lt; default &gt; · Create custom · View Default</td>
</tr>
<tr>
<td><strong>Page Layout</strong></td>
<td>Controls how a page is displayed.</td>
</tr>
<tr>
<td></td>
<td>&lt; default &gt; · Create custom · View Default</td>
</tr>
</tbody>
</table>
Archive a Space
Archiving a space is useful when you have content that is no longer relevant, but you still want the option of accessing it at a later date. Archived spaces are less visible, but still available on your site. Archiving a space is easy to undo - you can make a space current again at any time.

Archive a space
1. Go to the space and choose Space tools > Overview from the bottom of the sidebar
2. Choose Edit Space Details.
3. Select Archived in the Status dropdown menu.
4. Choose Save.

Is your space using the Documentation theme?
If your space is using the Documentation theme:
1. Choose Browse > Space Admin from the header
   Note: The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group. The 'Edit Space Details' screen appears.
2. Select Archived from the Status dropdown menu.
3. Choose Save.

The effect of archiving a space

If a space is archived, that space and it’s contents:

- Won't appear in the Confluence search results unless you select Search archived spaces. This option is hidden if there are no archived spaces.
- Won't appear on any dropdown menus, including the Confluence quick navigation, which drops down when you enter text in the search box.
- Won't appear in the general spaces lists in the Space Directory, but will instead appear under the Archived Spaces list. It will, however, still appear under any categories it was labeled with.
- Won't show up in activity streams when updated.
- Won't appear on your dashboard.

These functions remain available for archived spaces:

- You can view the content as usual, by following a link or typing in a URL belonging to the archived space.
- You can edit the content as usual, as determined by the space permissions.
- RSS feeds, watches and notifications remain active.

Archiving a space has no effect on search results of external search engines. For example, a public space will still appear in Google search results.

Change a space from archived to current
Through the space directory:

1. Go to Spaces > Space directory in the header.
2. Choose Archived Spaces on the left.
3. Find your space and click the on the right.
4. Choose Edit Space Details.
5. Change the Status from ‘Archived’ to ‘Current’ and hit Save.

Through the archived space:

1. If you know the space key, you can navigate straight to the archived space - http://yoursite/display/SPACEKEY
2. Choose Space tools > Overview from the bottom of the sidebar.
3. Choose Edit Space Details.
4. Change the Status from ‘Archived’ to ‘Current’ and hit Save.

Delete a Space

Deleting a space permanently removes the space and all of its contents. Only someone with space admin permissions can delete that space.

⚠ Deleting a space is permanent – it does not go to the trash and cannot be undone.

If you're unsure about deleting a space, create an XML export of the space as a backup before proceeding. You can then restore the space from the XML export file if you need to.

To delete a space:

1. Go to the space and choose Space Tools > Overview from the bottom of the sidebar.
2. Choose Delete Space.
3. Choose OK.

Is your space using the Documentation theme?

If your space is using the Documentation theme:

1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.

2. Choose Delete Space in the space administration options.
3. Choose OK.

Related pages:

- Archive a Space
- Export Content to Word, PDF, HTML and XML
Export Content to Word, PDF, HTML and XML

You can export all or part of a Confluence space to various formats, including Microsoft Word, HTML, PDF and XML.

To use the space export functionality, you need the 'Export Space' permission. See the guide to space permissions.

Export single pages to Word or PDF

If you need to send content to people who don't have access to Confluence, you can export a single page as a Word document or a PDF. You can also export a single blog post to PDF.

If you've got permission to view the page in Confluence, you'll be able to export it in this way; go to the page and choose either Tools > Export to Word or Tools > Export to PDF.

When you export a single page to PDF, the PDF stylesheet customizations are applied, but any PDF layout customizations are not. To make your PDF layout customizations apply to a single page exported to PDF, you'll need to use the 'multiple page' method described below to export the single page. See Customize Exports to PDF.

Export to HTML, XML, or PDF

If you want to export a space – or selected pages in a space – to HTML, XML, or PDF, Confluence can create a zipped archive of the HTML or XML files, or a single, downloadable PDF file.

The HTML export is useful if you want convert your space into a static website, or you can use the XML export option if you need to import the space into another Confluence site, or use the data from the space in another application. You might use the PDF option if you're producing a user manual from your technical documentation in Confluence.

To export pages to HTML, XML, or PDF:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Export
3. Select either HTML, XML, or PDF, then choose Next
4. Select either a normal or custom export for HTML or PDF, or a Full or Custom XML export:
• **Normal Export (HTML and PDF)** – to produce an HTML file containing all the pages that you have permission to view.

• **Full Export (XML)** – to produce an XML file containing all the pages in the space, including those that you do not have permission to view.

• **Custom Export** – if you want to export selected pages only, or if you want to exclude comments from the export.

5. Choose **Export**

Blog posts aren’t included when exporting to PDF using this method, and comments are never included when exporting to PDF.

When the export process has finished, you can download the zipped archive or PDF. If your space uses the Documentation theme, choose **Browse > Space Operations**, then choose either **HTML**, **XML**, or **PDF Export** from the left menu, and follow the steps above to export the Space.

**Customizing the appearance of PDF exports**

You can add a title page, table of contents, and customized headers and footers to the PDF output. For more advanced customizations, you can apply Cascading Style Sheet (CSS) modifications. These customizations are specific to each space, and you need the ‘Space Administrator’ permission to apply these customizations. For more information, see **Customize Exports to PDF**.

**Notes on PDF exporting**

- To export a PDF containing international text, see **Create a PDF in Another Language**
- Confluence’s PDF export feature is designed to handle a wide variety of content, but on rare occasions the PDF Export process may fail due to an unrecognized customization. If that happens, the PDF export screen will indicate the title of the page in which the problem occurred, to help you diagnose the cause of the failure.

**Notes on HTML exporting**

- In the .zip file, page attachments are placed in individual folders with names in the following format: `...\download\attachments\xxxxxx`
  where 'xxxxxx' is the page ID of the page containing the attachments.
- Blog posts aren't included in the HTML export. See the feature request: 
  ![CONF-14684 - Export news to HTML](OPEN)

- To customize the HTML output, you'll need to modify the file `confluence-x.y.z-jar/com/atlassian/confluence/pages/Page.htmlexport.vm`. To learn how to repackage this file, see **How to Edit Files in Confluence JAR Files**

**Notes on XML exporting**

- See **Restoring a Space** for notes on restrictions when importing a space.
- If you’re doing the export for backup purposes, consider another means of backup. See **Production Backup Strategy**.
- If you are running Confluence behind Apache HTTP Server and are facing timeout errors, please consider creating the export directly from Tomcat, instead of going through Apache. This will speed up the process and prevent timeouts.

**Customize Exports to PDF**

Confluence administrators and space administrators can customize the PDF exports for individual spaces.

Please note:

- PDF customizations are unique to each
Confluence 5.10 Documentation

Customizing the PDF Layout

You can add your own HTML to customize the title page, page headers and page footers in the PDF output.

**Setting a global PDF layout**

1. Choose the cog icon

   ![Cog icon](image)

   , then choose General Configuration under Confluence Administration

2. Choose PDF Layout. You can enter HTML and CSS that will be rendered on the PDF title page, as well as page headers and footers.

**Setting the PDF layout at space level**

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar You'll need Space Admin permissions to do this.

2. Choose PDF Layout.

3. Choose Edit.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin from the header

   **Note:** The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.

2. Choose PDF Layout in space administration options.

3. Choose Edit.

You can customize the HTML that is generated for the following areas when the space is exported to PDF:

- PDF Space Export Title Page – title page.
- PDF Space Export Header – page headers.
- PDF Space Export Footer – page footers.

For further customizations, see the Advanced PDF Export Customizations page.
Enter your customizations into each text box as required. The PDF layout section accepts HTML code. You can include inline CSS in the HTML too.

Customizing the PDF Stylesheet

You can adjust the appearance of the PDF pages by customizing the CSS in the PDF Stylesheet screen. To get started, download the default CSS rules for the PDF stylesheet - confluencedefaultpdf.css. Any rule defined in this file can be customized and added to the PDF Export Stylesheet section. Your customizations override any default CSS rule. If no customizations are defined, the default CSS rules will be applied.

By default, the export does not include a title page, headers or footers. You can define these in the PDF layout.

To customize the PDF Stylesheet:

**Setting a global PDF Stylesheet**

1. Choose the cog icon, then choose General Configuration under Confluence Administration
2. Choose Look and Feel > PDF Stylesheet. The following screen allows you to enter and save CSS code that will render content on each page.

**Setting a space PDF stylesheet**

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar. You'll need Space Admin permissions to do this.
2. Choose PDF Stylesheet.
3. Choose Edit.
4. Enter your customizations.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin from the header
   *Note:* The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.
2. Choose PDF Stylesheet in the space administration options.
3. Choose Edit.
4. Enter your customizations.

The PDF Export Stylesheet field accepts Cascading Style Sheets (CSS) rules. The 'PDF Export Stylesheet' page shows the current (e.g. customized) contents of your PDF stylesheet.

Example Customizations

This section provides examples of typical customizations that you can add. See also Advanced PDF Customizations.

**Page Size**

The default page size is based on the location of your Confluence server. For example, if this server is located in the US then the default paper size of your PDF export will be US Letter (8.5 inches wide by 11 inches long). If the server is located in Australia, the default paper size will be A4 (210 mm wide by 297 mm long). More information about paper sizes can be found on Wikipedia.

To modify the page size to A4, edit the PDF Stylesheet to add a size property to the CSS@page rule, like this:
Page Orientation: Landscape or Portrait

To change the page orientation of your PDF document, simply reverse the order of the values declared in the `@page` rule’s `size` property. The first and second values of this property represent the width and height of the page, respectively.

For example, to generate PDF space exports in A4-sized landscape orientation, your `@page` rule might look like this:

```css
@page
{
/*A4-sized pages in landscape orientation are 297 mm wide by 210 mm long*/
size: 297mm 210mm;
}
```

Page Margins

To set all margins to 15 mm, with a paper size of A4, edit the `CSS @page` rule in the PDF Stylesheet, like this:

```css
@page
{
size: 210mm 297mm;
margin: 15mm;
}
```

To set the margins independently, edit the `@page` rule as follows:

```css
@page
{
margin-top: 2.54cm;
margin-bottom: 2.54cm;
margin-left: 1.27cm;
margin-right: 1.27cm;
}
```

To set margins to provide a gutter for binding a printed document, use the `:left` and `:right` pseudo-classes, as follows:

```css
@page
{
margin-top: 2.54cm;
margin-bottom: 2.54cm;
margin-left: 1.27cm;
margin-right: 1.27cm;
}
```
Note the use of the :first pseudo-class in the example above to define distinct margins for a cover or title page.

**Page Breaks**

By default, Confluence pages are exported without page breaks, so that shorter pages will appear on the same PDF page.

To make each Confluence page appear on a separate page in the PDF file, add the following rule in the PDF Stylesheet:

```css
@page :first {
  margin-top: 10cm /* Top margin on first page 10cm */
}
```

**Title Page**

You can add a title page to your PDF document by adding HTML to the Title Page section of the PDF Layout screen. The following example creates the title page and adds a title:

```html
<div class="fsTitlePage">
  <img src="/download/attachments/590719/titlepage.png" />
  <div class="fsTitle">Planning for Confluence 4.0</div>
</div>
```

Use CSS rules in the PDF Stylesheet to control the appearance of the title page and the title text:
Adding an Image to the Title Page

In the example above, the title page includes an image called 'titlepage.png', centred in the middle of the page. The "590719" in the src attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your title page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page, then right-click the image and copy its location.
3. Paste the link into the appropriate src="" attribute in your PDF Stylesheet, as shown above.
4. Edit the image URL so that it is relative, by removing the first part of the URL before /download/ . . .

Table of Contents

By default, a table of contents will be generated after the title page, or at the beginning of the PDF document if no title page is defined in the PDF Layout. To see the default CSS rules applied to the table of contents, download the default CSS rules (confluencedefaultpdf.css) and examine the specific rules with toc in their name.

To make changes to the appearance of the table of contents, define CSS rules in the PDF Stylesheet.

Disabling the Table of Contents

To prevent the table of contents from being generated in your PDF document, add the div.toc-macro rule to the PDF Stylesheet and set its display property to none:

Changing the Leader Character in the Table of Contents

The leader character is used to link a heading in the table of contents with its page number. By default, the leader character is the '.' (dot) character. Leader values of dotted, solid and space are allowed. You can also use a string, for example leader(". . . ").

To change the leader character to a solid line, modify the leader() value on the content property of the CSS rule as follows:
Headers and Footers

You can add headers and footers to your PDF pages using the ‘Header’ and ‘Footer’ sections of the PDF Layout screen. By default, headers and footers only apply to a space export and not to exports of single pages (however, see Advanced PDF Export Customizations). The following example adds a simple copyright notice.

```html
Copyright © 2013, Atlassian Pty Ltd.
```

Page Numbering

To add page numbering, you need to combine customized HTML in the PDF Layout with customized CSS in the PDF Stylesheet.

1. PDF Layout HTML: In the Footer section (or the Header section), use an empty span element with a unique ID, for example `pageNum`, to act as a place holder for the page number.

```html
<span id="pageNum"/>
```

2. PDF Stylesheet CSS: Create the following CSS selector rule for the empty span:

```css
#pageNum:before
{
    content: counter(page);
}
```

Analyzing the above CSS selector rule in more detail:

- The `#pageNum` rule selects the HTML element with the specified ID of "pageNum", which is the span element we created for the header or footer.
- The `:before` part of the selector is a pseudo class that allows the insertion of content before the span element is processed.
- The `counter(page)` is a function that returns the current page number as its content.
- The `content` property tells the CSS processor that dynamic content (that is, an incrementing page number) is to be inserted at the span tag.

Wrapping Long Words

In order to break long words or words that are not separated by whitespace, add a selector to the PDF stylesheet containing the `word-wrap` property with a value of `break-word`.

```css
.word-wrap
{
    word-break: break-word;
}
```
General Formatting

You can use the stylesheet to customize the output of just about anything else that will influence the look and feel of the final document. This includes fonts, tables, line spacing, macros, etc. The export engine works directly from the HTML output produced by Confluence. Therefore, the first step in customizing something is to find a selector for the HTML element produced by Confluence or the Confluence macro. Then add a CSS rule to the PDF stylesheet. Your customization will appear in the PDF export.

Notes

- **Demotion of heading elements: h1, h2, and so on.** Due to the hierarchical manner in which a space is exported, Confluence will modify the heading elements to generate a uniform appearance for the entire space export. This means that headings will be demoted. This will affect the application of custom PDF Stylesheets. It is possible to calculate the amount by which a heading will be demoted in order to have the correct CSS styling applied. A heading will be demoted by the value of its depth in the export tree. A page at the first level will be demoted by 1 (all `<h1>` elements will become `<h2>` elements, and so on). A page at the second level will be demoted by 2, and so on.

- **Atlassian support for PDF customization is limited.** We support the mechanism for customizing the PDF layout with HTML and CSS, and we will help if the mechanism is broken or does not work as we say it should in our published examples. But, since custom HTML and CSS offer potentially limitless possibilities, Atlassian will not support issues that are caused by or related to PDF customizations.

Advanced PDF Export Customizations

This page provides information about 'advanced' PDF export customizations. These expand upon the regular customizations described in Customize Exports to PDF.

⚠️ The information below is for advanced users. Be aware that the advanced customizations described below require knowledge of certain parts of Confluence, and of CSS and HTML. Customizations are not supported by Atlassian, so our support engineers won't be able to help you with these modifications.

On this page:

- Header and Footer
  - Adding Headers and Footers to Single Page Exports
  - Adding Images to Headers and Footers
- Incorporating Other Fonts
- Adding a Dynamic Title to the Title Page
- Hiding Text from the PDF Output
- Indexing
- Notes

Related pages:

- Customize Exports to PDF
- Create a PDF in Another Language

Header and Footer

Adding Headers and Footers to Single Page Exports

Single page exports don't support adding HTML headers and footers via the PDF Layout page, but you can use CSS rules in the PDF Stylesheet page (Space tools > Look and Feel > PDF Stylesheet) to produce
headers and/or footers for a single page export.

For custom headers, define any of the following rules within your @page rule: @top-left, @top-center, and @top-right. These rules allow you to define the content of the left-hand side, centre and right-hand side of your page’s header area, respectively.

For custom footers, define @bottom-left, @bottom-center and @bottom-right rules within your @page rule.

For example, the following rules add a document title at the centre of the header and a page number at the centre of the footer:

```css
@page
{
  @top-center
  {
    content: "Document Title Goes Here"; /* This is the content that will appear in the header */
    font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
    font-size: 8pt;
  }
  @bottom-center
  {
    content: "Page " counter(page); /* This is the content that will appear in the footer */
    font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
    font-size: 8pt;
  }
  /* Any other page-specific rules */
}
```

Notes:

- The font-family and font-size properties ensure that the header and footer text is rendered in the same default font style used for the body text, based on the default CSS rules.
- It is not possible to use this method to insert images (stored as attachments within your Confluence instance) into the headers and footers of single page exports.

Adding Images to Headers and Footers

To insert an image into the header or footer, add HTML to the Header or Footer section of the PDF Layout screen.

The following example uses an HTML img element with src attribute to add an image to the left of the header. The src attribute refers to an image attached to a Confluence page. The image element is usually placed within a div element container.
HTML - PDF Layout: Header Section

```html
<div style="margin-top: 10.0mm;">
<img 
src="https://confluence.atlassian.com/download/attachments/12346/headers-image.png" />
</div>
```

In the example above, the header includes an image called 'header-image.png'. The "12346" in the `src` attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page, then right-click the image and copy its location.
3. Paste the link into the appropriate `src=""` attribute in your PDF Stylesheet, as shown above.
4. Edit the image URL so that it is relative, by removing the first part of the URL before `/download/`.

Notes:

- This example uses an inline CSS property `margin-top` in the `style` attribute to force the image away from the top of the page by 10mm. This comes in handy when your header image is large enough to touch or spill over the top of the page.
- Likewise, for footers, you can use the `margin-bottom:XXmm` property to force an image away from the bottom of the page by 'XX' mm.
- Very large images can spill over into the body of a page or alter the position of text or other elements used within a header or footer. In such situations, it is recommended that you reduce the size of the image and then attach it to your Confluence page again. If you prefer to keep the image size and want to move the content lower instead, you can do so by configuring the `margin-top` properties in the `@page` CSS rule.
- By default, a header or footer image is aligned to the left-hand side of the page. However, you can align this image to the centre or right-hand side of a page by adding either the `text-align:center` or `text-align:right` properties to your `style` attribute. For example, to align the header image to the right-hand side of the page, your `style` attribute would look similar to this: `style="margin-top:10mm; text-align:right"`.

Incorporating Other Fonts

By default, Confluence provides Times New Roman, Helvetica or Courier fonts for use in PDF exports. You can use your own fonts for PDF exports by declaring them in a `@font-face` CSS rule in your PDF Stylesheet.

The following CSS rule example shows how to declare the Consolas font and apply it to some elements for your PDF export:

```css
@font-face { src: url(file:///usr/share/fonts/Consolas.ttf); -fs-pdf-font-embed: embed; } .code pre, .preformatted pre, tt, kbd, code, samp { font-family: Consolas, monospace; font-size: 9pt; }
```

The font path specified in the CSS must be the path to the font on the Confluence server.

**Adding a Dynamic Title to the Title Page**

When you export an arbitrary set of pages from Confluence, you may like to have a corresponding title added to the cover (or title) page automatically. This can be done (in a somewhat irregular way) by using the top level item from the default table of contents as the title. This method relies on having the exported pages
structured as sub-pages of the top-level page. In other words, the pages to be exported should consist of a page (at the top-level) and all of its child pages. The result is that the title that appears on the cover page changes depending on the top-level page that is used for the export.

The CSS below moves, and styles, the top-level TOC item for use as the title on the cover page, and turns off the leader and page number normally associated with this item in the TOC.

CSS - PDF Stylesheet

```
.fsTitlePage { position:relative; left:0px; } /* Turn off the default section numbering for this TOC item */ .toclvl0:before { content: &quot; &quot;; counter-reset: chapter 0; } /* Hide the default page numbering for this TOC item */ .toclvl0 .tocnum { display: none; } /* Move and style this TOC item */ .toclvl0 { position:absolute; top:250px; font-size: 42px; font-weight: bold; margin: 72px 0 4px 0; text-align:center; }
```

Hiding Text from the PDF Output

This section describes a way to hide text from your PDF export. In other words, you can have text on the Confluence page that will not appear in the PDF export.

There are three steps:

1. Follow the instructions to define the NoPrint user macro.
2. Use the NoPrint macro to mark some text on a Confluence page.
3. Add the following CSS to your PDF stylesheet to make the PDF export recognize the NoPrint macro:

CSS - PDF Stylesheet

```
.noprint { display: none; }
```

Indexing

To obtain an index at the end of the exported PDF file, consider using the Scroll Wiki PDF Exporter plugin that is produced by K15t Software GmbH.

Notes

If styling is not working as expected, it is useful to look at the intermediary HTML source to which the CSS is applied. This intermediary HTML is created whenever you create an HTML export that contains multiple pages, and is stored in the temp directory in Confluence’s home directory. For example:

```
/temp/htmlexport-20110308-154047-1/export-intermediate-154047-2.html
```

Create a PDF in Another Language

To export a Confluence page written in a language other than English, you’ll need the necessary font for that language.

Related pages:
- Export Content to Word, PDF, HTML and XML

Upload a Font File to Confluence

1. Find the appropriate font file:
• **Windows users:** All font files in Windows are stored in a directory called:

```
C:\WINDOWS\Fonts
```

• **Unix users:** All font files in Unix are stored in:

```
/usr/share/fonts
```

• Microsoft True Type core fonts such as Verdana can be downloaded from this page: [http://corefonts.sourceforge.net/](http://corefonts.sourceforge.net/)

2. Copy the font file into a temporary folder, for example a folder on your desktop.
3. Choose the cog icon , then choose **General Configuration** under Confluence Administration
   then choose **PDF Export Language Support**.
4. Upload the file you copied in step 2.
5. Choose **Install**.

**Notes**

• The only font files supported are **true type fonts** and **true type collections**. The accepted file extensions are *.ttf and *.ttc.
• Confluence can only store **one** font file at any one time. Please create a collection to install more than one *.ttf files.
• We recommend that you use Unicode font Verdana for correct character encoding and exporting to PDF.
• If the font file size is bigger than your current attachment size limit, you will not be able to upload it. Please increase the attachment size limit temporarily and re-upload again. An improvement of the error messaging is tracked at [CONF-24706](http://jira.atlassian.com/browse/CONF-24706)
• To make use of an installed font in your PDF Export style sheet (CSS) refer to it by the font-family **ConfluenceInstalledFont**.

**Pages and Blogs**

When you create any content in Confluence – whether it’s taking down some quick notes from a meeting, writing a requirements page, or letting your teammates know about the company’s latest marketing push – you’ll either be creating it as a page or a blog post. You may be shocked to know that this page you’re reading now, is, in fact, a Confluence page!

Pages and blog posts are the two things that allow you to capture and share information in Confluence, and which one you use depends on what you want to do with your content. If you want the information to last, and possibly evolve over time, then you likely want to create a page; if the information is specific mainly to the current time-frame, and isn’t going to change over time, then you’ll most likely want to create it as a blog post. These aren’t hard-and-fast rules; they’re just pointers to give you a place to start.

Each Confluence space, including your personal space, allows you to create pages in it, and has its own blog where you can create posts. If you’re not sure what a space is, or what you can do with spaces, check out our page on **Spaces**.

Take a look at the below pages to learn more about pages and blog posts in Confluence.

- Create and Edit Pages
- Blog Posts
- The Editor
Create and Edit Pages

Create a page

You can create a page from anywhere in Confluence; just choose Create in the header and you're ready to go. Pages are the place to capture important (and unimportant) information; start with a blank page and use it like a word processor to add rich text, tasks, images, macros and links, or use one of the useful blueprints to capture meeting notes, decisions, and more.

On this page:
- Create a page
- Collaborate or restrict
- Organize and move
- Other page actions

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a page from a template, hit the Create from template button.

Create blank page  Create  ❯❯❯ Create from template

Screenshot: The create dialog
Once you decide on a blank page or blueprint, you'll be taken straight into the Confluence editor. The editor is where you'll name or rename your page, add the content, and format it to look great. When you've added some content, choose Preview to take a peek at what your finished page will look like, and choose Save when you've finished your edits.

After you save you'll see the page in 'view' mode. You can re-enter the editor any time by choosing Edit or pressing E on your keyboard.

Another useful way to create a page is to use the Create from Template Macro. This macro allows you to choose a page template, and adds a button to the page allowing one-click page creation. If you want others to create pages using this template, this is a great option.
Collaborate or restrict

Once you've created a page, you can decide if you want to keep it private, using restrictions, or collaborate on it with others using @mentions, sharing, and comments.

Organize and move

You can also organize pages in a hierarchy, with child and/or parent pages for closely related content. When you navigate to a Confluence page and choose the Create button in the header, the page you're creating will by default be a child of the page you're viewing. Have as many child pages and levels in the hierarchy as you need to, and move pages if you want to change their location.

If you want to view all pages in a Confluence space, choose Pages in the sidebar, or choose Browse > Pages at the top of the screen if you're using the Documentation theme. If the space is using the Default theme, you'll see recent updates to pages and a page tree displaying all pages in the space; if it's using the Documentation theme, you can choose either Recently Updated, Alphabetical, or Tree view of the pages in the space.

Other page actions

- Copy a page
- Delete a page or remove a specific version of a page
- Monitor page updates and other activity through page notifications
- View page history, and manage and compare versions of a page
- Search page content, including attachments
- Export pages to Word, PDF, HTML or XML
- Like a page

⚠️ We recommend you don't use special characters in page or attachment names, as the page or attachment may not be found by Confluence search, and may cause some Confluence functions to behave unexpectedly.

If you rename a page, Confluence will automatically update all relative links to the page, except in some macros. Links from external sites will be broken, unless they use the permanent URL. See Working with Links for more information.

Blog Posts

Blog posts are an easy way to share announcements, journal entries, status reports, or any other timely information. Others can join in by commenting on and/or liking your blog post and, if you get enough of either, your post might make it to the popular feed on the dashboard!

Each space in Confluence, including your personal space, has its own blog. To view a space's blog, go to a space and choose Blog in the sidebar. You'll see a list of the latest blog posts, and you can click through to earlier posts via the navigation area in the sidebar.

Create a blog post

You can follow the same process to create a blog post as when you create a Confluence page.
1. Navigate to the space where you want to create your blog post
2. Choose Create in the Confluence header and select Blog post
3. Add your content and choose Publish

You can create blog posts from the Dashboard, but you'll need to make sure you choose the space it's going to appear in in the create dialog.

Blog posts can be attractive and engaging in the same way a page can be, so go ahead and add images, YouTube clips (preferably of cats), and tables to your post to really grab your audience.

To create a blog post, you need the 'Add Blog' permission. See Space Permissions.

Move a blog post

If you create a blog post in the wrong space, or want to reorganize your spaces, you can move an individual blog post to another space.

To move a blog post, go to the post and choose

***
>
Move and select the new destination space.

You'll need the 'Delete blog' permission in the current space, and 'Add blog' permission in the new (destination) space to do this.

Restrict a blog post

You can restrict a blog post so that it is only available to specific users or groups. Blog post restrictions work in the same way as page restrictions.

To restrict a blog post prior to publishing it, choose the Unrestricted button in the footer and apply your restrictions. To restrict a blog post after publishing, choose

***
>
Restrictions and apply your restrictions.

Notes:

- Notifications are sent at the point a blog post is created - removing restrictions does not trigger a new
notification.
• As a blog post has no parent, restrictions aren't inherited.

Delete a blog post

To delete a blog post, choose

> Delete. Deleting a blog post follows the same rules as deleting a page.

Export a blog post

You can export individual blog posts to PDF. This is useful, for example, if you want to email an internal blog post to people outside your organization.

See Export Content to Word, PDF, HTML and XML for more information on exporting blog pages to PDF.

The Editor

The Confluence editor is what you'll use to create and edit Confluence pages, blog posts, and comments. You can enter content as you would in a Word document, apply formatting, and embed other content and files on the page.

Note: To edit a page, you need the 'Add Pages' permission for the space. See space permissions. Someone may also apply page restrictions that prevent you from editing the page.

Edit a page or blog post

You'll be taken to the editor whenever you create a new page or blog post, or add a comment. To edit an existing page or blog post, choose Edit at the top of a page or press E on your keyboard.

Confluence automatically saves drafts of your page as you work. If another user begins editing the same page as you, Confluence will display a message and will try to merge the changes when you save your page. To see changes between different versions of the page, look at the history of the page.

The editor

The editor allows you to enter or change the title of your page; insert content including text, images, and links; and format your content using the toolbar.

If you're renaming your page, there are some things you should take into account.
Add your page title and body text

Page title

Capture the knowledge that’s too often lost in email inboxes and shared network drives. Team, project, or department own space its own permissions and theme. Keep feedback on any Confluence page or file – project plans, Office files, just place, so you don’t waste time connecting feedback in email with your work done elsewhere.

Editor toolbar

The editor toolbar is where you format your page layout and text, and add links, tables, images, attachments and macros. You can also perform a find and replace, or get help using the editor by choosing the help icon.

Screenshot: The editor toolbar
The Insert menu

The **Insert** menu is particularly useful. Use the **Insert** menu to include any of the following content types on your page:

- An image
- A link to another Confluence page or external URL, or a link to an attachment or image
- An emoticon or symbol, or a horizontal line
- A macro (choose a specific macro, or **Other Macros**, from the **Insert** menu)

You can also use keyboard shortcuts to insert links, images, and macros. Try out the shortcuts listed below:

- Type `[` (square bracket) to insert a link.
- Type `!` (exclamation mark) to insert an image or other media.
- Type `{` (curly bracket) to insert a macro.

Typing any of the above shortcuts will trigger the autocomplete functionality, prompting you with a list of suggestions to finish off the entry. For more shortcuts, click the help icon `?` on the editor toolbar.

Restrictions, labels, and notifications

When editing a page, you may want to set **restrictions** on who can view or edit the page, or add **labels** to the page to make it easily searchable.

Once you're ready to save, you can enter **change comments** to let others know what you've changed, and, if you like, **send an email notification** to anyone watching the page.

Things to help you work faster

Auto-formatting

You can type **Confluence wiki markup** directly into the editor to have Confluence auto-format your text as you type. To learn more, choose help icon `?` in the toolbar, then choose **Editor Autoformatting**.

Autoconvert for pasted links

When you paste certain URLs into Confluence, the editor will analyze what you're pasting and automatically convert it into something that will display well in Confluence. Examples include:
• YouTube videos
• JIRA issue queries
• Google Maps
• Confluence pages, blog posts, comments, user statuses, user profiles.
• Shared screenshot links from Skitch
• And more.

Drag-and-drop for external images and files

You can drag files, like images, multimedia, Office files and PDFs, from your computer and drop them directly into the editor. The contents of the file will be embedded into the page or blog post.

Drag-and-drop within the editor

In the editor panel, you can drag an image or a macro from one location to another on the page. Hover your cursor over the image or the macro placeholder and your cursor changes to a drag-and-drop icon. Click the image or macro and drag it to a new location.

**Note:** For the drag-and-drop of images and macros in the editor, Confluence supports the following browsers: Chrome, Firefox, and Internet Explorer 10 (desktop mode).

Keyboard shortcuts

To view the available keyboard shortcuts, choose the help icon in the editor toolbar.

Find and replace text

Click the icon on the toolbar, or use the keyboard shortcut **Ctrl+F** (Windows) or **Cmd+F** (Mac OS).

Search matches are highlighted in yellow. You can step through the results one by one, replace the matching text strings one by one, or replace all matching strings at once. Find and replace works only within the current page.

Record change comments and notify watchers

When you finish editing a page, you can add a comment to let others know what you changed. Type a short message in the change comments field in the footer. The comment will be visible in the page history.

If you want to send a notification to people watching the page, select **Notify watchers**. The change comment will be included in the notification email. The Notify watchers checkbox remembers your last selection, so if you choose not to notify people, the checkbox will be deselected for you next time.

Insert symbols and special characters

You can add various symbols and special characters to Confluence pages. You can also use them in other places that display content, such as blog posts, comments, and the dashboard welcome message.
1. Edit the page (if you’re viewing the page, press E on your keyboard)
2. Choose Insert > Symbol
3. Choose a symbol to insert it

Screenshot: Available symbols

Insert emoticons

There are two ways to add an emoticon, or smiley, to your page.

**By choosing an emoticon from those available:**
1. Choose Insert > Emoticon
2. Choose an emoticon to insert it

**By typing a character combination:**
You can insert emoticons by typing commonly-used character combinations. This table shows the emoticons (and other icons) available in Confluence, and the character combinations that create them:

<table>
<thead>
<tr>
<th>Smiley</th>
<th>Character Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>:)</td>
<td>:P :D :)</td>
</tr>
<tr>
<td>😃</td>
<td>😞 😍 😊 😅 😊 😅 😊</td>
</tr>
<tr>
<td>👍</td>
<td>😓 😓 😓 😓 😓 😓 😓</td>
</tr>
<tr>
<td>(y)</td>
<td>(n) (on) (off) (!)</td>
</tr>
<tr>
<td>✰✰✰✰✰</td>
<td>(<em>) (</em>) (g) (b) (y)</td>
</tr>
</tbody>
</table>
Prevent emoticons from appearing

To undo the conversion of a character combination into an emoticon, press Ctrl+Z (Windows) or Cmd+Z (Mac).

To prevent Confluence from converting text to emoticons automatically, disable 'Autoformatting' in your user profile. See Edit Your User Settings.

Move and Reorder Pages

The easiest way to set a page's location in Confluence is to navigate to the space where you want the page to live and, if necessary, find its parent page and choose Create. Sometimes though, you'll want to change a page's location either while you're creating it, or after it's been created.

You can also move and reorder pages in the page tree (hierarchy).

Set page location or move a page

1. Do either of the following:
   - While creating a page – choose the location icon at the top of the page
   - Once a page is created – choose
     > Move
2. Use the tabs on the left of the 'Set Page Location' dialog to help you find the new space and/or parent page for your page (the Current location and New location breadcrumbs at the bottom of the dialog indicate the current parent page and new parent page)
3. Select Reorder if you want to move the page to a different position amongst the child pages (when you choose Move in the next step, you'll be able to reorder the page)
4. Choose Move (If you're reordering the child pages, choose the new position for the page and choose Reorder)

The page – along with any attachments, comments, and child pages – is moved to your chosen location. Confluence will automatically adjust all links to the moved pages, to point to the page(s) in its new location.

When completing the New parent page field, you need to select the page suggested by Confluence’s autocomplete. Typing or pasting the page name (or using your browser’s autocomplete) won’t work.

Screenshot: Setting the location or moving a page
Reorder pages within a space

You can change the location of a page within its space, and reorder pages in the hierarchy. This allows you to:

- Move a single page, or a family of pages, to a different parent within the space.
- Reorder pages that are children of the same parent.

All links to the page are maintained. When you move a parent page, the entire hierarchy of child pages will move too.

To move or reorder a page:

1. Go to the space and choose **Space tools > Reorder pages** from the bottom of the sidebar
2. Expand the branches to locate the page you want to move
3. Drag the page to a new position in the tree

If you’re using the Documentation theme go to **Browse > Pages > Tree** and then drag the pages to a new position as above.

Alternatively, you can choose to order a group of child pages alphabetically by choosing the **So**
rt Alphabetically (A-Z) icon. The Sort Alphabetically (A-Z) icon only appears next to the parent page if the page family is currently sorted manually.

If you change your mind, you can use the Undo Sorting icon to revert back to the previous manual page order. This option is only available immediately after sorting the page, while you're still on the Reorder Pages tab, and haven't performed any other action.

Notes about permissions

To move a page, you need the following permissions:

- 'Add' permission on the page you're moving, and
- 'View' permission on the page's parent page. If you're moving the page to a different parent, you need 'View' permission on the new parent.

To move a page into a different space, you also need:
- 'Delete' permission on the space you're moving from, and
- 'Add' permission on the space you're moving to.

If the page has restrictions, and you want to keep the page restrictions in the new location, you'll also need 'Restrict' permission on the space you're moving to. Alternatively, remove the page restrictions before performing the move.

Copy a Page

If you need to duplicate the content of a page, the easiest way is to copy the page.

When you copy the page it'll need to be renamed if you intend to keep it in the same space – and Confluence will rename the page 'Copy of [originalPageName]' by default – as pages in a space must have unique names. If you plan on moving it to another space, you can keep the same name as long as you set the location while you're creating the copy. See Move and Reorder Pages for more information.

You need the 'Create Pages' permission in a space to copy pages within that space. See space permissions for more information.

To copy a page:

1. Go to a page in the space and choose
   ***
   > Copy
   Confluence will open a copy of the page in the editor. By default, Confluence will name the page 'Copy of [originalPageName]'.
2. Rename the page and make any other changes required in the body of the page
   If you need to move the new page to a different space or a different parent, choose Location at the bottom-left of the page. Refer to the instructions on moving a page.
3. Choose Save

Notes

- Copying a page will duplicate all of the original page's attachments and labels, but won't copy comments from the original page.
- This method of copying a page doesn't copy the child pages. Please add your vote to issue CONF-2814 if you'd like to see this improvement.
- You can copy an entire space, including all pages in the space (parents and children) — refer to these instructions on copying a space.
Delete or Restore a Page

When you delete a Confluence page, it moves to the space's trash much like an email moves to your email trash or a file moves to the trash on your computer. It's not permanently deleted, and is still retrievable, until you purge the page from the trash.

Delete a page

When you delete a page in Confluence, you're deleting all versions of the page. If you only want to delete a specific version of a page, take a look at the instructions below for deleting a specific version.

To delete a page and all its versions:

Go to the page and choose

***

> Delete (confirm you want to delete the page when prompted)

Note: The Delete option will only appear if you have permission to delete this page. See Space permissions.

If someone has applied page restrictions to the page, the restrictions may also prevent you from deleting the page.

To delete a specific version of a page:

If you want to delete a specific version of a page, you need to be a space administrator.

Deleting a page version is permanent. It won't be moved to the trash, so you can't restore a deleted version.

1. Go to the page and choose

***

> Page History

2. Choose Delete next to the version you want to delete (confirm the action when prompted)

Once you've deleted a version, the other versions are re-numbered where necessary. For example, if you delete version 2, version 3 will become the new version 2.

Delete a page with children

If you delete a page that has any child pages, the child pages moves up to the nearest parent page. If you want to keep the child pages under another parent, it's a good idea to move them before deleting their former parent.

Screenshot: Warning when deleting a page with children

On this page:
- Delete a page
- Delete a page with children
- Restore a deleted page
- Purge deleted pages

Related pages:
- Pages and Blogs
- Editing or Deleting a Page That Won't Render
- Copy a Page
Restore a deleted page

When you restore a Confluence page, you're moving it from the trash to the root of the space. You may want to move the page to another location after you've restored it, as it won't be easy to find at the root of the space.

You need to be a space administrator to restore a deleted page.

**To restore a deleted page:**

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Choose **Content Tools > Trash**
   - A list of deleted pages and blog posts for the space displays.
3. Choose **Restore** for the page you wish to restore

Is your space using the Documentation theme?

If your space is using the Documentation theme:

1. Choose **Browse > Space Admin** from the header
   - **Note:** The **Space Admin** option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.
2. Choose **Trash** from the space administration options
   - A list of deleted pages and blog posts for the space displays.
3. Choose **Restore** for the page you wish to restore

To find the page after you've restored it, choose **Pages** to go to the root of the space (the page isn't restored to its original position in the page hierarchy). See **Move and Reorder Pages** for more information.

If a new page has already been created in that space with the same name as the page you're restoring, you'll be given an option to rename the page before it's restored.

Purge deleted pages

If you want to permanently get rid of a page, you need to purge it from the trash. That'll mean the page, and all its versions and attachments, are gone for good.

Attachments of deleted pages will remain in the database (allowing potential retrieval) until the trash is purged. Once the trash is purged, all attachments on the page(s) are permanently removed.

You need to be a space administrator to purge deleted pages.

**To purge deleted pages:**

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Choose Trash
   A list of deleted pages and blog posts for the space displays.
3. Choose Purge for a specific page or Purge All to permanently clear all deleted pages and news items
   Is your space using the Documentation theme?
   If your space is using the Documentation theme:
   1. Choose Browse > Space Admin from the header
       Note: The Space Admin option appears only if you have space admin permissions, or if you're part of the ‘confluence-administrators’ group.
   2. Choose Trash from the space administration options
       A list of deleted pages and blog posts for the space displays.
   3. Choose Purge for a specific page or Purge All to permanently clear all deleted pages and news items

Add, Remove and Search for Labels
Labels are key words or tags that you can add to pages, blog posts and attachments. You can define your own labels and use them to categorize, identify or bookmark content in Confluence.

For example, you could assign the label ‘accounting’ to all accounts-related pages on your site. You can then browse all pages with that label in a single space or across the site, display a list of pages with that label, or search based on the label.

Because labels are user-defined, you can add any word that helps you identify the content in your site.

You can also apply labels (known as categories) to spaces, to help organize your Confluence spaces. See Use Labels to Categorize Spaces.

Label a page or blog post
Any user with permission to edit a page can add labels to it. Any existing labels appear at the bottom-right of the page, below the page content.

To add a label to a page or blog post:

1. Go to the page
   choose the edit icon
   beside the list
   of labels or
   press L on
   your keyboard
2. Type in a new label (existing labels are suggested as you type)
3. Choose Add

On this page:
- Label a page or blog post
- Label an attachment
- The Labeled content page
- Search by label
- Search for labeled pages using a URL
- Remove labels

Related pages:
- Use Labels to Categorize Spaces
- Display Pages with Label Macros
Label an attachment

1. Do either of the following:
   - Go to the page that contains the attachment and choose Go to ***\>
     Attachments
   - Go to the space and choose Space tools > Content Tools from the bottom of the sidebar, then choose Attachments
   You’ll see a list of attachments, with any existing labels listed in the Labels column.
2. Choose the edit icon
   beside the list of labels and type in a new label (existing labels are suggested as you type)
3. Choose Add

You can also add labels in a list of attachments displayed by the Attachments macro, by choosing the edit icon

beside each label.

If you add one or more labels to a template, that label will be copied to the page when someone adds a page based on that template. See Creating a Template.

The Labeled content page

If you're viewing a page or post that has labels or displays the Attachments macro, you can choose any label to go to the Labeled content page for the space. Choose Popular Labels or All Labels from the cog at the top-right – to view the most-used labels or all labels in the space – or choose See content from all spaces from the cog to view labeled content from all spaces in your Confluence site.

Screenshot: The Labeled content page

The Popular Labels option displays a word cloud, where the bigger a label is displayed, the more popular it is. Choose any label to view content tagged with that label.

You can also navigate to the labels view for a space by entering the following URL (replace SPACEKEY with the space’s key):
If the space is using the Documentation theme, access the Labeled content page by choosing Browse > Labels.

Search by label
You can use the 'labelText:' prefix to search specifically for content that has a specific label. For example, if you're looking for pages with the label 'chocolate', type `labelText:chocolate` into the search field in the Confluence header. For more examples of searching by label, see Confluence Search Syntax.

Search for labeled pages using a URL
Entering a URL with an appended label or labels is another way to search for pages with particular labels.

In your browser's address bar, enter the following URL and press enter: `http://<your.Confluence.site>/label/foo+bar`

The Labeled content page will load, showing search results for pages with the both labels, 'foo' and 'bar'. Replace 'foo' and 'bar' with the label(s) you want to search for, and separate multiple labels with a + symbol.

Adding a label to your results:
Once you're on the Labeled content page, you can add more labels to your search by choosing them from the Related Labels list at the top-right of the page. Each label is listed with a plus (+) sign.

If you want to remove labels from your search, locate the included labels at the top of the page and choose the label(s) you want to remove. Each included label will be listed with a minus (–) sign.

Remove labels
When viewing page, blog post, or attachment labels, an x appears alongside each label. Choose the x to remove the label.

If you have deleted pages that contain a label, you may need to purge the deleted pages from the space's trash to ensure that the label disappears too.

Display Pages with Label Macros
Using labels and macros, you can categorize pages and then display them in Confluence in a number of ways.

As an example, you could label all pages relevant to the marketing team with 'marketing', and then add more specific labels like 'online', 'mobile', and 'physical' to different pages where required.

You could then use the Content by Label Macro to display different combinations of pages with the marketing label. Some combinations you could use would be:

- All pages with the label 'marketing'.
- Pages with all of the following labels: ‘marketing’, ‘mobile’, and ‘online’.
- Pages with either the ‘mobile’ or ‘online’ labels, in the Marketing space.

There are a lot of ways you can filter the content, making it easier for you to find content that’s relevant to
you.

Other label macros

Here are some other macros that use labels, and can help you categorize and display your content.

*Navigation Map macro*

The **Navigation Map macro** renders the list of pages associated with a specified label as a navigation map.

*Related Labels macro*

The **Related Labels macro** lists labels commonly associated with the current page's labels.

*Content by Label macro*

The **Content by Label macro** displays a list of content marked with specified labels.

*Content Report Table macro*

The **Content Report Table macro** displays a set of pages and blog posts in tabular format, based on the specified labels.

*Labels List macro*

The **Labels List macro** lists all labels of a space, grouped alphabetically.

*Recently Used Labels macro*

The **Recently Used Labels macro** lists labels most recently used in a specified scope - global (site), space, or personal.

*Popular Labels macro*

The **Popular Labels macro** displays popular labels in a list or in a heatmap (also called a cloud).

**Drafts**

A draft is a 'snapshot' of unsaved page content, which Confluence creates automatically at regular intervals while you're creating or editing a page or blog post. Drafts can minimize the loss of work if your Confluence site experiences a problem, as you can retrieve the page content from the last saved draft.

By default, Confluence saves a draft of your page once every thirty seconds, however, a Confluence administrator can configure how often drafts are saved. In addition, whenever you edit a page and then move to another screen, Confluence will automatically save a draft. Each new draft replaces the previously saved draft.

Each time Confluence saves a draft, it displays a message and the time of the last save, to the right of the **undo** and **redo** buttons in the editor toolbar. When you edit a page that wasn't successfully saved, Confluence will let you know that a version of the page you're editing wasn't saved, and will give you the option to resume editing it from the draft.

*Screenshot: Message displaying the time when the draft was last saved*

More about drafts:
• You only have access to drafts of pages you’ve been working on, and whose content hasn’t yet been saved.
• You can’t create a draft explicitly.
• Your drafts are listed in the ‘Drafts’ tab of your profile.
• Once you’ve resumed editing a draft, or chosen to discard it, the draft is removed from your drafts tab.

View drafts
Your drafts are listed on the Drafts tab of your user profile. To see your drafts, choose your profile picture at top right of the screen, then choose Drafts.

Resume editing a draft
There are two ways to resume editing an unsaved page or blog post:

1. Using your drafts view. To resume editing a draft from this view:
   a. Choose your profile picture at top right of the screen, then choose Drafts.
   b. Choose Resume Editing next to the appropriate draft to resume editing that draft.

2. If you create a new page or blog post and didn’t save it, but a draft is saved, when you next add a page or blog post in that space, Confluence will ask you if you want to resume editing the page. If you choose resume editing, the draft and its unsaved content will be restored, allowing you to continue editing it.

What happens if I’m editing the draft of a page that has since been updated?
Confluence will display a message informing you that you’re editing an outdated page. If there are no conflicts between the two versions, Confluence will give you the option to Merge and Resume editing.

If there are conflicts, Confluence will give you the option to View the Conflict or to Discard your changes.

View your unsaved changes
When you edit a page or blog post, you can view any ‘unsaved’ changes you’ve made since the last automatically saved draft, by clicking the Draft autosaved at message in the toolbar.

Screenshot: Segment of the unpublished changes window

Concurrent Editing and Merging Changes
Sometimes, another user may edit the same page as you're editing, at the same time you do. When this happens, Confluence will do its best to ensure nobody's changes are lost.

**How will I know if someone else is editing the same page as I am?**

If another user is editing the same page as you, Confluence will display a message above your edit screen letting you know who the other user is and when the last edit was made.

_Screenshot: Notification of Simultaneous Page Editing_

![Notification](image.png)

**What happens if two of us are editing the same page and the other user saves before I do?**

If someone else has saved the page before you, when you click **Save**, Confluence will check if there are any conflicts between your changes and theirs. If there are no conflicting changes, Confluence will merge the changes.

If there are conflicts, Confluence will display them for you and give you the option to:

- **Continue editing** - Continue to edit the page; useful if you want to manually merge the changes.
- **Overwrite** - Replace the other person's edits with yours (their edits will not be included in the latest version).
- **Cancel** - Discard your changes and exit the editor, keeping the other person's edits.

**Example Scenario**

For example, Alice and Bob both edit the same page at the same time.

If Alice clicks save before Bob, Bob is now effectively editing an out-of-date version of the page. When Bob clicks save, Confluence will examine his changes to see if any overlap with Alice's. If the changes don't overlap (i.e. Alice and Bob edited different parts of the page), Bob's changes will be _merged_ with Alice's automatically.

If Bob's changes overlap with Alice's, Confluence will display an error message to Bob showing where Alice has changed the page, and giving Bob the options to overwrite Alice's changes with his own, to re-edit the document to incorporate Alice's work, or to cancel his own changes entirely, maintaining Alice's changes.

**Page Restrictions**

Page restrictions allow you to control who can view and/or edit individual pages in a space. So, if you're working on a page that shouldn't be viewed by just anybody, it's easy to lock it down to the people who need to know. You can add restrictions for individuals or for Confluence groups.

To add or remove page restrictions, you'll need to have permissions to edit the page and 'Restrict' or 'Admin' permission in the space.

**Restrict a page or blog post**

To restrict who can view or edit a page or blog post:

1. Chose the Restrictions
   ![Restrictions](image.png)
   icon at the top of the page.
2. Choose whether you just want to limit who can **Edit**, or who can **View and Edit**.
3. Enter users or groups then click **Add** to add them to the list. If you chose **Viewing and Editing restricted** you can further specify for each person or group whether they can edit or just view the page.

4. **Apply** the restrictions.

You can add as many users and/or groups as you need.

In this example, some users and groups can view only, others can also edit, plus there are inherited restrictions that might impact who can view the page.

![Restrictions](image)

Who is 'everyone'?  

When we say "everyone can view this page" **everyone** means all the people who can view the page by default. There's two things that can affect who can view a page - the space permissions, and view restrictions on any parent pages that are being inherited.

Restrictions don't override a person's space permission. For example, if you say a person 'can view' in the restrictions dialog and they don't have 'view' permissions for the space, they won't be able to see the page.

How do inherited restrictions work?

View restrictions are inherited, which means a restriction applied to one page will cascade down to any child pages. Edit restrictions are not inherited, which means pages need to be restricted individually.

The restrictions dialog will tell you when there are inherited restrictions that might affect who can view your page.

Here's the basics:

- If you restrict **viewing** to a person or group, only they will be able to see that page and all its child pages (unless there are further restrictions on the child pages)
- If you restrict **editing** to a person or group, they'll be able to see and edit that page, plus see its child pages.
- Parent pages (higher up in the page hierarchy) can have their own view restrictions that may prevent people from viewing your page.

If the person you've listed as a viewer or editor can't see the page, check to make sure:

- they have **View space permission** for that space, or
- there's no view restriction on a page higher up the page hierarchy that prevents them seeing any children of that page.
View current page restrictions

The restrictions icon at the top of the page gives you a clue that the page has restrictions:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🗝️</td>
<td>Viewing this page is not restricted. Everyone can see this page (but editing may be restricted).</td>
</tr>
<tr>
<td>🗠️</td>
<td>The page is restricted. Click the icon to see the list of who can view and edit this page.</td>
</tr>
<tr>
<td>🔒️</td>
<td>The page is inheriting restrictions from another page. Click the icon then choose Inherited Restrictions to see a list of pages this page is inheriting restrictions from.</td>
</tr>
</tbody>
</table>

Remove restrictions from a page

Removing restrictions is easy. Choose No restrictions to remove all restrictions, or click Remove next to each person or group in the list if you want to change who can view or edit the page.

Request and grant access to view a restricted page

If you navigate to a page that you’re not able to view because it has page restrictions applied (for example from a link or page URL) you may be able to request access to the page.

**To request access to a restricted page:**

1. On the restricted page choose Request access
2. Wait for an email confirming that access has been granted

If the request access message doesn’t appear, you’re not able to request access for that particular page. This usually is because the page has inherited view restrictions from a parent page, or you may not have adequate space permissions.

**To grant access to a restricted page:**

1. In the request access email, choose Grant access
   You’ll be taken to the restricted page, and a dialog will appear with the access request
2. Choose Grant access

The user will receive an email confirming that access has been granted.

This process is the same as navigating to *** > Restrictions and adding a ‘View’ restriction for the user.

**Who can grant access?**

To grant access to a restricted page you will need to have permission to edit that page, and have the ‘Restrict’ or ‘Admin’ permission for the space.
Confluence will send an email to a user who can grant permissions. The sequence that Confluence will use to search for the appropriate user is:

1. The last person to edit the page
2. **All** non-admin users that can set permissions on the page (given that an admin user can always set permissions)
3. The page creator
4. **All** the space administrators

Confluence will try each of these roles in turn, emailing the first user that has appropriate permissions.

**View all restricted pages in a space**

You need space admin permissions to view the list of restricted pages in a space.

**To view restricted pages:**

1. Go to the space and choose **Space tools > Permissions** from the bottom of the sidebar
2. Choose **Restricted Pages**

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** from the header
   
   **Note:** The **Space Admin** option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.

2. Choose **Restricted Pages** in the space administration options

**Screenshot: Restricted pages in a space**

### Notes

- **You can't exclude yourself**
  
  When you apply a restriction, Confluence will automatically add you to the list. You can't remove yourself from this list.

- **Space Admin and System Administrator access to restricted pages**
  
  Users with 'Admin' permissions in a space, or users with the System Administrator global permission can remove restrictions from pages, even if the page restriction prevents them from viewing the page. Go to **Space Administration > Restricted Pages**.

### Links

You can create links to pages, blog posts, anchors, attachments, external
websites, JIRA issues and more. Links can be text or images, and can be added in many different ways.

Links to pages within your Confluence site are relative, which means that you can move pages and rename pages without breaking links.

This page explains the most common ways to create links.

Insert a text link

To insert a link on a page:

1. Select some text or position your cursor where you want to insert the link
2. Choose Link on the toolbar or use the keyboard shortcut Ctrl+K
3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to particular types of content)
4. Enter or modify the link text (this is the text that will appear on the page. If this field is left blank, the page name or URL will be used as the link text.)
5. Choose Insert

Alternatively you can type [ followed by the page or attachment name. Autocomplete will suggest matching items for you.

You can also paste a URL directly onto your page. Confluence will automatically create the link, and if the URL is for a page in the current site, the page name will be set as the link text.

Insert an image link

1. Select an image on your page
2. Choose Link on the Image Properties toolbar
3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to particular types of content)
4. Choose Insert

Modify a link

1. Select the link text or image
2. Choose Edit from the link properties toolbar
3. Modify the link and choose Save

Remove a link

1. Select the link text or image
2. Choose Unlink from the properties toolbar
Link to specific types of content

Confluence supports many methods for creating links. Some of the common ones are listed here.

<table>
<thead>
<tr>
<th>Type of link</th>
<th>Ways to do this</th>
</tr>
</thead>
</table>
| Link to a page                       | Choose **Link > Search** then enter part of the page name.  
Choose **Link > Recently viewed** and select a page from the list.  
Type [ and enter part of the page name then select the page from the list.  
Paste the URL of the page onto your page (Confluence will automatically create the link). |
| Link to a page in another space      | Choose **Link > Search** enter part of the page name and select **All Spaces** from the drop down.  
Choose **Link > Advanced** then enter the space key followed by the page name `spacekey:mypage`.  
Type [ and enter part of the page name then select the page from the list.  
(you can hover over each suggestion to see which space the page is from). |
| Link to a blog post                  | Choose **Link > Search** and enter part of the blog post name.  
Type [ and enter part of the blog post name then select the blog post from the list. |
| Link to an attachment or image on this page | Choose **Link > Attachment** then upload or select an attachment from the list.  
Type [ and enter part of the attachment file name then select the attachment from the list. |
| Link to an attachment on another page | Choose **Link > Search** and enter part of the attachment name.  
Type [ and enter part of the attachment file name then select the attachment from the list  
(you can hover over each suggestion to see which space the page is from). |
| Link to a website                    | Choose **Link > Web Link** then enter the website URL.  
Type or paste the URL onto the page (Confluence will automatically create the link). |
| Link to an email address             | Choose **Link > Web Link** then enter the email address.  
Type or paste the email address onto the page (Confluence will automatically create a 'mailto:' link). |
| Link to an anchor on a page          | Choose **Link > Advanced** then enter the anchor name in one of the formats below.  
For an anchor on this page: `#anchor name`.  
For an anchor on another page in this space: `page name#anchor name`.  
For an Anchor on another page in another space: `spacekey:page name#anchor name`.  
See [Anchors](#) for more information on using anchors. |
| **Link to a heading on a page** | Choose **Link > Advanced** then enter the heading in one of the formats below. Heading text is case sensitive and must be entered without spaces.  
For a heading on this page: `#MyHeading`.  
For a heading on another page in this space: `Page Name#MyHeading`.  
For a heading on another page in another space: `spacekey:Page Name#MyHeading`.  
Be aware that these links will break if you edit the heading text. Consider using the Table of Contents macro or an Anchor instead. |
| **Link to a comment on a page** | Go to the comment, right click the **Date** at the bottom of the comment and copy the link. Paste the link directly onto your page or choose **Link > Web Link** and paste in the URL.  
Type `{[$ then enter the Comment ID ('12345' in this example): `[12345]` |
| **Link to an undefined page (a page that does not exist yet)** | Choose **Link > Advanced** then enter the new page name (a page will be created on click).  
Type `[ then enter the new page name then choose Insert link to create page.  
See Undefined Page Links for more information on undefined pages. |
| **Link to a personal space or user profile** | Choose **Link > Search** then enter the user's name and select their personal space homepage or their profile from the list.  
Type `[ then enter the user's name and select their personal space homepage or their profile from the list. |
| **Link to a JIRA issue (where Confluence is connected to JIRA)** | Paste the JIRA issue URL - Confluence will automatically create a JIRA Issue macro. |

**Link to Confluence pages from other websites**

The best way to link to a Confluence page from outside Confluence, for example on a website or in an email message, is to use the tiny link which is a permanent URL. This ensures that the link to the page is not broken if the page name changes.

To access the permanent URL for a page:

1. View the page you wish to link to.
2. Choose **Tools > Link to this page**.
3. Copy the **Tiny Link**.
4. Use the tiny link in your website or email message.

You do not need to use the tiny link to link to pages within your Confluence site. Confluence automatically updates links when you rename or move a page to another space.

If you want to link to specific content such as anchors, headings or comments you need to use the following link syntax. Note that there are no spaces in the page name, anchor name or heading text.

In the examples below, the anchor name is 'InsertLinkAnchor' and the heading text is 'Insert a link'.

<table>
<thead>
<tr>
<th>Purpose</th>
<th>Link syntax</th>
</tr>
</thead>
</table>
### Link to an anchor (from an external website)

<table>
<thead>
<tr>
<th>Link to an anchor (from an external website)</th>
<th><a href="http://myconfluence.com/display/spacekey/pagename#pagename-anchorname">http://myconfluence.com/display/spacekey/pagename#pagename-anchorname</a></th>
</tr>
</thead>
</table>

Example from this page:

https://confluence.atlassian.com/display/DOC/Working+with+Links#Workingw:

### Link to a heading (from an external website)

<table>
<thead>
<tr>
<th>Link to a heading (from an external website)</th>
<th><a href="http://myconfluence.com/display/spacekey/pagename#pagename-headingtext">http://myconfluence.com/display/spacekey/pagename#pagename-headingtext</a></th>
</tr>
</thead>
</table>

Example from this page:

https://confluence.atlassian.com/display/DOC/Working+with+Links#Workingw:

### Link to a comment (from an external website)

<table>
<thead>
<tr>
<th>Link to a comment (from an external website)</th>
<th><a href="http://myconfluence.com/display/spacekey/pagename?focusedCommentId=commentid#comment-commentid">http://myconfluence.com/display/spacekey/pagename?focusedCommentId=commentid#comment-commentid</a></th>
</tr>
</thead>
</table>

Example from this page:

https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803

Some things to note when linking to anchors from a website or email message:

- The page name is repeated in the URL, after the # sign. The second occurrence of the page name is concatenated into a single word, with all spaces removed.
- There is a single dash (hyphen) between the concatenated page name and the anchor name.
- The anchor name in the full URL is concatenated into a single word, with all spaces removed.
- The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as you used when creating the [Anchor](https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLinks-InsertLinkAnchor).

### Link to a comment

You can add a link to a comment by using the comment URL (a permanent link), or by using wiki markup to link to the Comment ID.

To find out the comment URL and comment ID:

1. Go to the comment you wish to link to
2. Choose the [Date](https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLinks-Insertalink) at the bottom of the comment and examine the URL

The number after 'comment-' is the Comment ID. An example is shown here.

https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803

You can use wiki markup directly in the editor to link to a comment. Enter [$ followed by the Comment ID, for example [$12345] where ‘12345’ is the Comment ID.

### Using shortcut Links

If you have configured shortcut links on your Confluence site, then you can link to an external site using a shortcut link that looks like this:CONF-17025@jira.

Our Confluence site (where this documentation is housed) is configured to allow shortcut links to our JIRA site, using the shortcut @jira. So the shortcut link CONF-17025@jira produces this link.

To add a shortcut link using the 'Insert Link' dialog:

1. Choose Link > Advanced and enter or paste the shortcut link into the Link field (shortcut links are case-insensitive)
2. Modify or enter link text (this is the text that will appear on the page)
3. Choose Insert
You can also type ‘[‘ and choose **Insert Web Link > Advanced** to enter a shortcut link.
See Configuring Shortcut Links for more details.

**Trackback**

Trackback enables two sites can stay informed each time one site refers to the other using trackback 'pings'.

In Confluence, Trackback can be enabled by a site administrator in the Administration Console. When Trackback is enabled, any time you link to an external webpage that supports Trackback Autodiscovery, Confluence will send a Trackback ping to that page to inform it that it has been linked to.

Confluence pages also support Trackback Autodiscovery, and when Trackback is enabled, can receive trackback pings sent by other sites.

To see who has sent a Trackback ping to a Confluence page:

1. Go to the page
2. Choose **Tools > Page Information**

Any Trackback pings the page has received will be listed under the page's **Incoming Links**.

Confluence incoming trackback pings only work with referenced pages that are public (anonymously viewable).

**Anchors**

You can use anchors to enable linking to specific locations on a page, and they can be especially useful for allowing your readers to navigate to specific parts of a long document. Anchors are invisible to the reader when the page is displayed.

There are two steps to using an anchor:

1. **Step 1:** Create the anchor
2. **Step 2:** Create a link to the anchor

**Step 1: Create the anchor**

Add the **Anchor Macro** to mark the location you want to link to:

1. Do either of the following in the Confluence editor:
   - Choose **Insert > Other Macros**, then find and select the Anchor macro
   - Type '{' and the beginning of the macro name, then select the Anchor macro
2. **Enter the Anchor Name** (For example, 'bottom' or 'important information')
3. **Choose Insert**

**Macro options (parameters)**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2016 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
### Anchor Name

<table>
<thead>
<tr>
<th>None</th>
</tr>
</thead>
</table>

This is the anchor name that you will use when creating the link.

- The anchor name can include spaces. Confluence will remove the spaces automatically when building a URL that points to this anchor.
- The anchor name is case sensitive. You must use the same pattern of upper and lower case letters when creating the link as you used when creating the Anchor macro.

---

### Step 2: Create a link to the anchor

You can link to an anchor from:

- A page on the same Confluence site. The link may be on the same page as the anchor, another page in the same space, or a page in another space on the same Confluence site.
- Another web page or another Confluence site, using a specifically formatted URL.

### Link to an anchor on the same Confluence site:

1. Select some text or position your cursor where you want to insert the link
2. Choose **Link** in the toolbar or press **Ctrl+K**
3. Choose **Advanced** and enter the anchor name in the **Link** field, following the format below.

<table>
<thead>
<tr>
<th>Anchor location</th>
<th>Link syntax for anchor</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same page</td>
<td>#anchor name</td>
<td>#bottom</td>
</tr>
<tr>
<td></td>
<td></td>
<td>#important information</td>
</tr>
<tr>
<td>Page in same space</td>
<td>page name#anchor name</td>
<td>My page#bottom</td>
</tr>
<tr>
<td></td>
<td></td>
<td>My page#important information</td>
</tr>
<tr>
<td>Page in different space</td>
<td>spacekey:page name#anchor name</td>
<td>DOC:My page#bottom</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DOC:My page#important information</td>
</tr>
</tbody>
</table>

4. Enter or modify the **Link Text** (this is the text that will appear on the page. If this field is left blank, the page name or URL will be used as the link text)
5. Choose **Save**

- Anchor names are case sensitive
- Enter page and anchor names with spaces when you link to them in the same Confluence site
- If you're linking to an anchor on a different page that has special characters in its name, where the URL displays a page ID rather than a name, you should still enter the page name when linking to it

---

**Screenshot: The 'Advanced' option in the link dialog**

**Edit link**

Here you can insert a link into the page using **wiki markup**.

- **Link**: #goodstuff
- **Link text**: Link to the good stuff!

Hint: type “T” in the editor to see a list of suggested pages and insert a link.
Link to an anchor from another web page or another Confluence site:

Use a full URL in the following format:

<table>
<thead>
<tr>
<th>Link syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><a href="http://myconfluence.com/display/DOCS/My+page#Mypage-bottom">http://myconfluence.com/display/DOCS/My+page#Mypage-bottom</a></td>
<td><a href="http://myconfluence.com/display/DOCS/My+page#Mypage-bottom">http://myconfluence.com/display/DOCS/My+page#Mypage-bottom</a></td>
</tr>
<tr>
<td><a href="http://myconfluence.com/display/DOCS/My+page#Mypage-importantinformation">http://myconfluence.com/display/DOCS/My+page#Mypage-importantinformation</a></td>
<td><a href="http://myconfluence.com/display/DOCS/My+page#Mypage-importantinformation">http://myconfluence.com/display/DOCS/My+page#Mypage-importantinformation</a></td>
</tr>
</tbody>
</table>

Notes about the full URL:

- The page name is repeated in the URL, after the # sign. The second occurrence of the page name is concatenated into a single word, with all spaces removed.
- There is a single dash (hyphen) between the concatenated page name and the anchor name.
- The anchor name in the full URL is concatenated into a single word, with all spaces removed.
- The anchor name is case sensitive.

Notes

- **Table of contents on a page**: Consider using the Table of Contents Macro to generate a list of links pointing to the headings on the page. The list of links will appear on the page, and will be automatically updated each time someone changes the wording of a heading.
- **Linking to headings**: You can link directly to the headings of a page. See Links. However, if someone changes the wording of a heading, those direct links will be broken. Use the Anchor macro to ensure a lasting link within the body of a page.
- **Site welcome message**: If you are adding an anchor to a page that you are using in the site welcome message, you can only link to that anchor from another page. Internal links within that page will not work.
- **Templates**: When you are previewing a template, a link to an anchor is displayed as a 'broken' link. However, when you create a page using the template the resulting page will have the correct link.

Tables

Confluence tables allow you to present important information and discuss it with your team. Use familiar table formatting options –resizing columns, coloring cells, rows and columns, and sorting the table by clicking the column headers – to view the information the way you like it.

Insert a table

**To create a table:**

1. Hit the Table button in the toolbar
2. Click a cell in the drop-down to set the number of columns and rows in your table

Screenshot: Insert a table with 3 rows and 3 columns

On this page:

- Insert a table
- Edit your table
- Shortcut keys
- Sort the table in view mode
- Sticky table headers in view mode

Related pages:

- Page Layouts, Columns and Sections
- The Editor
Edit your table

To resize table columns, just click and drag the column's border. To make other changes to your table, click inside it to reveal the table toolbar.

Here's a summary of the table tools:

<table>
<thead>
<tr>
<th>Column width modes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Responsive</strong> – The table will expand as you add content, and you can drag to resize the columns. It will also resize itself to fit the page-viewer's window size (within reason).</td>
</tr>
<tr>
<td><strong>Fixed width</strong> – Drag column borders to set width. Columns appear at your set size, regardless of content and window size.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Rows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert rows before or after the current row</td>
</tr>
<tr>
<td>Delete the current row</td>
</tr>
<tr>
<td>Cut, copy and paste the current row</td>
</tr>
<tr>
<td>Mark a row as a header row (shaded with bold text)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Columns</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert columns before or after the current column</td>
</tr>
<tr>
<td>Delete the current column</td>
</tr>
<tr>
<td>Cut, copy and paste the current column</td>
</tr>
<tr>
<td>Mark a column as a header column (shaded with bold text)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cells</th>
</tr>
</thead>
<tbody>
<tr>
<td>Merge selected cells</td>
</tr>
<tr>
<td>Split selected cells</td>
</tr>
<tr>
<td>Change cell color</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete table</td>
</tr>
<tr>
<td>Add a numbering column to automatically number each row</td>
</tr>
</tbody>
</table>

Table settings

- **Insert numbering column**

Shortcut keys

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+c</td>
<td>Copy the current table row, or the selected rows.</td>
<td>Cmd+Shift+c</td>
</tr>
</tbody>
</table>
1. Ctrl+Shift+i: Insert a table. (Opens the Insert Table dialog.)
2. Ctrl+Shift+v: Paste the table rows from your clipboard, placing them above the current row.
3. Ctrl+Shift+x: Cut the current table row, or the selected rows.
4. Alt+Up Arrow: Add a row above the current row.
5. Alt+Down Arrow: Add a row below the current row.

For more editor keyboard shortcuts, see Keyboard shortcuts.

Sort the table in view mode

When viewing a table on a page, you can sort it by clicking the sort icons in the header row.

Screenshot: A colorful, sortable table

Sticky table headers in view mode

In some instances table header rows will stick to the top when you're viewing a page, making those really long tables easier to read. There are a few exceptions, though. Table headers aren't sticky when your table:

- Is inside a page layout, or inside another table.
- Has no header row or there are cells in the top row that aren't marked as headers.
- Has a header column, instead of a header row, and scrolls horizontally.
- Contains another table, that has its own header row.

Add, Assign, and View Tasks

Keep track of the things that need to get done with tasks. With the ability to give each task an assignee and due date, and plenty of ways to see your tasks, you can make sure nothing slips through the cracks.

Add a task

You can add tasks on any page in Confluence. For example, you might add tasks under action items on a meeting notes page, or in a project planning page – anywhere you need a lightweight task management solution.

To create a task:

1. In the editor, choose the Task list button or use the keyboard shortcut [ ]
2. Start typing your task – @mention someone to assign the task to them, and type // and choose a due date
The first person you mention in a task is the assignee; you can even assign tasks to yourself.

**Note:** If you assign a task to someone who doesn’t have permission to view the page or space, they won’t see the task.

**View tasks**

There are a number of ways to keep track of tasks assigned to you, or tasks you’ve created for others.

**On a page**

The simplest way to see a task is on the page it was originally created on. It’s easy to see if a task is complete, who it’s assigned to, and when it’s due. If a task is nearing or passed its due date, the color of the date will change (red for overdue, orange for due in the next 7 days).

![Action items](image)

**In your profile**

The tasks page in your profile gives you a place to see all the tasks relevant to you. Easily keep track of the status of tasks assigned to you, and tasks you’ve created and assigned to others.

To view the tasks page, go to Profile > Tasks. Use the filters to show tasks that were assigned to you or created by you in the last 6 months, and toggle between complete or incomplete tasks.

![Tasks page](image)

If you need to see more than just your last 6 months of tasks, use a Task Report.

**In a Task Report**

If you’re looking for a more custom view of tasks, the Task Report blueprint is a great way to track tasks assigned to a specific team or project.

To create a task report:

1. Choose Create > Task Report
2. Select the type of report:
   - **Assigned to my team** – for tasks assigned to particular people.
   - **In my project** – for tasks that appear in a specific space or page.
   - **Custom** – for a wide range of filtering options, including by date or page label.
3. Follow the prompts to create the report.
This blueprint uses the Task Report Macro. You can also choose to use this macro on an existing page, for example, on a project or team space homepage.

![Meeting actions this month](image)

**Notes**

- The date picker can be triggered by typing // or by typing a date in the format dd/mm/yyyy or dd-mm-yyyy. Typing other date formats in the editor won't trigger the date picker.
- Personal Tasks (created in the Workbox in older versions of Confluence) don't appear in the Tasks view or Task Report. To migrate any incomplete personal tasks, go to Workbox > Personal Tasks and follow the prompts.
- The wiki markup based Tasklist Macro has been removed from the macro browser. If you have a Tasklist macro on a page it will continue to work, but you will be unable to add new Tasklists using this macro.

**Autocomplete for links, files, macros and mentions**

When using the Confluence editor, you can type a trigger character or press a keyboard shortcut to see a list of suggested links, files or macros to add to your page, or to mention another user (and automatically notify them of this).

### Summary of autocomplete

<table>
<thead>
<tr>
<th>What you want to do</th>
<th>Trigger character</th>
<th>Keyboard shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a link on your page</td>
<td>[</td>
<td>Ctrl+Shift+K</td>
<td>See a list of suggested pages or other locations to link to from your page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>More...</td>
</tr>
<tr>
<td>Display an image, video, audio file or document on your page</td>
<td>!</td>
<td>Ctrl+Shift+M</td>
<td>See a list of suggested images, multimedia files and documents to embed in your page. More...</td>
</tr>
<tr>
<td>Add a macro on your page</td>
<td>{</td>
<td>None</td>
<td>See a list of suggestions as you begin typing a macro name. More...</td>
</tr>
<tr>
<td>Notify another user by email that you have mentioned them on your page</td>
<td>@</td>
<td>None</td>
<td>See a list of suggested users to mention. More...</td>
</tr>
</tbody>
</table>
Using autocomplete for links

Type '[', or press Ctrl+Shift+K, to see a list of suggested pages or other locations to link to from your page. You can link to pages, user profiles, images, documents and other file attachments.

To autocomplete a link:

1. Edit the page.
2. Click where you want to insert a link and do one of the following:
   • Type '[' and then the first few characters of the page title, user's name, image name or file name.
   • Type the first few characters of the page title, user's name, image name or file name (or select
relevant text) and then press Ctrl+Shift+K.

3. Click the relevant link from the list of suggestions.

If the item you need is not in the list, either:

- Choose Search for ‘xxx’ to continue looking for the page within Confluence, or
- Choose Insert Web Link to insert a link to an external web page using the link browser.

**Screenshot: Autocomplete for a link**

Using autocomplete for images, videos, audio files and documents

You can use the autocomplete as a fast way of embedding images, videos, audio files and documents into your page. Type an exclamation mark or press Ctrl+Shift+M to see a list of suggested images, multimedia files and documents to display on your page. You can use autocomplete to embed the following file types:

- Images – any format that Confluence supports.
- Videos, audio files and all multimedia formats that Confluence supports.
- Office documents supported by the Confluence Office Connector: Word, Excel and PowerPoint.
- PDF files.

<i>Autocomplete works most efficiently for files that are already attached to the Confluence page.</i>

**To embed an image, video, audio file or document:**

1. Edit the page.
2. Click where you want to insert the image, video, audio file or document and do one of the following:
   - Type ‘!’ and then the first few characters of the image, file or document name.
   - Type the first few characters of the name of the image, file or document (or select relevant text) and then press Ctrl+Shift+M.
3. Choose the relevant file from the list of suggestions.

If the item you need is not in the list, either:

- Choose Open Image Browser to find images and documents using the image browser, or
- Choose Insert Other Media to embed videos, audio and other multimedia files using the macro browser. Insert the ‘Multimedia’ macro to display your multimedia file.

**Screenshot: Autocomplete for an image or document**
Using autocomplete for macros

Type '{' to see a list of suggested macros to add to your page.

Autocomplete provides access to all available macros in your Confluence site, including any user macros that your administrator has added and made visible to all.

You need to know the name of macro. Autocomplete for macros will only match the name of the macro, not the description.

To autocomplete a macro using '{':

1. Edit the page.
2. Click where you want to insert the macro.
3. Type '{' and then the first few characters of the macro name.
4. Choose the relevant macro from the list of suggestions.
5. Configure the macro by completing the form fields as prompted.

If the macro you need is not in the list, choose Open Macro Browser in the list of suggestions to continue looking for the macro in the macro browser. See Macros.

Screenshot: Autocomplete for a macro

Using autocomplete for mentions

You can use autocomplete to automatically notify another Confluence user that you have mentioned them in
a page, blog post, or comment. Type '@' and part of the person's name, to see a list of suggested users.

**Note:** Use the person's full name. Autocomplete will recognize users' full names only, not their usernames.

### Canceling autocomplete

The autocomplete starts automatically when you press the trigger characters. You may want to close the autocomplete menu or escape from autocomplete once it has started.

There are a few different ways to stop the autocomplete once it has started:
- Press the escape key, 'Esc', on your keyboard.
- Click somewhere else in the editor panel.
- Press an arrow key to move out of the autocomplete area.
- For the link autocomplete only: enter a right-hand square bracket, like this: ]

### Enabling and disabling autocomplete

You can turn off the triggering of autocomplete by the '[' and ']' characters. This will prevent the autocomplete from starting automatically when you press one of the trigger characters. You can also turn it back on again.

Notes:
- This setting does not affect the keyboard shortcuts for autocomplete (Ctrl+Shift+K and Ctrl+Shift+M). Even if the trigger characters are disabled, you can still use the keyboard shortcuts for autocomplete.
- This setting affects only you. Other people using Confluence can enable or disable the setting on their user profiles independently.
- Note that autocomplete is enabled by default.

**To enable or disable the autocomplete trigger characters:**

1. Choose **your profile picture** at top right of the screen, then choose **Settings**
2. Choose **Editor** under 'Your Settings' in the left-hand panel.
3. Choose **Edit**.
4. Either:
   - Disable autocompletion by selecting **Disable Autocomplete**.
   - Enable autocompletion by clearing **Disable Autocomplete**.
5. Choose **Submit**.

**Screenshot: User settings for the editor**
Ignoring autocomplete

You can add macros, links and images by wiki markup alone. Type the macro, including its parameters and the closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket. Insert an image or other embedded object, enclosed between exclamation marks. As soon as you close the macro, link, or embedded image, Confluence will convert it to rich text format and add it to the page.

For more information about mouse-free macros, links and images, choose Help > Keyboard Shortcuts from the Confluence header.

Page Layouts, Columns and Sections

The layout of your pages can have a big impact on how they're read, and layouts, used well, allow you to position text, images, macros, charts, and much more, to have the best visual impact.

There are two ways to modify the layout of a Confluence page:

- Use page layouts to add sections and columns
- Use macros to add sections and columns.

Page layouts provide a simple, visual representation of your page layout in the editor, while the macros are more flexible and allow for greater complexity in your layout.

Use page layouts

The page layouts tool allows you to structure your page using horizontal sections and vertical columns. By adding multiple sections with different column configurations you can build quite complex layouts very easily.

Screenshot: Editor view of a page showing three sections with different column configurations.

Start by adding a horizontal section to your page.

To add a section:

1. Choose the Page Layout
button in the toolbar
The Page Layout toolbar appears.
2. Choose Add Section

The new section appears below your current content, with the boundaries of the section(s) indicated by dotted lines (the dotted lines aren’t visible when you view the page).

**To change the column layout in a section:**

1. Place your cursor in the section you wish to change
2. Choose a layout from the page layout toolbar (for example, two columns or three columns)

Any text, images or macros in your section are not lost when you change the column layout. When you decrease the number of columns, Confluence will move your content to the left. When you increase the number of columns, Confluence will add blank columns to the right of your existing content.

**To move a section to another part of the page:**

1. Place your cursor in the section you wish to move
2. Choose the Move up or Move down buttons

The section and all of its content will be moved above or below other sections on the page.

**To delete a section:**

1. Place your cursor in the section you wish to remove
2. Choose Remove section

The section and all of its content will be removed.

**Notes about Page Layouts**

- **Column width** – The width of the columns are fixed. If you need more than three columns, or columns of a specific width, you should use the Section and Column macros described below.
- **Very wide tables** – The width of each column is set to a percentage of the page width. The icons in the drop-down menu indicate the relative widths for each layout. In most cases, Confluence will adapt the width of the columns to fit the width of the page. If a column includes an item that’s too wide for it, you’ll see a horizontal scroll bar when viewing the page.

**The Section and Column macros**

You can use the Section and Column macros to add a set of columns to the page. The Section macro defines an area that will contain the columns. You can have as many sections as you like. Within each section, you can have as many columns as you like.

The Section and Column macros are useful if you want to define a specific percentage or pixel width for each column.

**To add a section and some columns to a page:**

1. In the Confluence editor, choose Insert > Other Macros
2. Find the Section macro, select it and insert it onto the page
3. Choose Insert > Other Macros again
4. Find and insert the Column macro
5. Add your content to the column

Insert as many columns as you like within the section.

You should always have at least one column macro within a section macro. Using a section macro without any column macros can negatively affect page loading time.

**Screenshot: A section and two columns in the editor**
Macro parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

**Parameters of the Section macro**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Border</td>
<td>false</td>
<td>Select this option to draw a border around the section and columns. <strong>Note:</strong> Without a Column macro, the border will not be displayed correctly.</td>
</tr>
</tbody>
</table>

**Parameters of the Column macro**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Width</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>Specify the width of the column, in pixels (for example, 400px) or as a percentage of the available width (for example, 50%).</td>
</tr>
</tbody>
</table>

All content within your section must be enclosed within a Column macro, otherwise the section layout will not work as expected.

Create Beautiful and Dynamic Pages

Confluence has a number of features that help you build attractive pages to engage your readers and give them the opportunity to interact with up-to-date information. This page summarizes those features and provides links to detailed instructions.

When you see the page in view mode, the above layout is displayed like this:

Content for column 1 goes here
Content for column 2 goes here
Add visual appeal

**Pictures, photographs and screenshots.** Confluence pages can display images from your Confluence site and from other websites. To put an image into Confluence, you can upload it and attach it to a page or blog post, then display it on any page, blog post or comment. Alternatively, display a remote image using its web address (URL). See Displaying Images.

**Galleries.** Use the Gallery Macro to display a set of images. When viewing the page, people can click any of the pictures to zoom in and view the images as a slide show.

**People.** Add a Profile Picture Macro to show a picture of a Confluence user, or a User Profile Macro to show a summary of the person's profile as well as their avatar.

**Multimedia.** You can display movies, animations and videos, and embed audio files on your Confluence page. For example, Confluence supports Adobe Flash, MP3, MP4, and various other movie formats. See Embedding Multimedia Content.

**Social video and image sharing.** The Widget macro displays live content from social sites such as YouTube and other video sharing sites, and Flickr for shared photographs. See the guide to the Widget Connector Macro.

Bring numbers to life

The Chart Macro offers a variety of graphs and charts that you can use to illustrate statistics and other numerical data.

*Illustration: A 3-dimensional bar chart produced by the Chart macro*  
![3D Bar Chart](image)

Display presentations and documents

Display your Office documents and other presentations directly in Confluence.

- Attach your Office documents to a Confluence

*Illustration: A PowerPoint slide deck*
page then display them on the page, using the View File Macro. This works for Excel spreadsheets, PowerPoint presentations and Word documents.

- Display PDF files in Confluence too, also with the View File Macro.
- Use the Widget Connector Macro to show slide decks hosted on SlideShare and other online presentation sites.

Pull in content from JIRA applications

Many project teams and customers also use JIRA applications such as JIRA Software or JIRA Service Desk. Rather than copying and pasting issues onto your Confluence page, you can display it directly from the source, thus ensuring that the information shown in Confluence is always up to date.

Link to a feature request in your issue tracker, or display a list of fixed issues – useful for release notes and project planning. See the JIRA Issues Macro.

Tell a story in pictures

A number of Confluence add-ons provide sophisticated tools for creating diagrams and mockups.

For example:

- Balsamiq Mockups for Confluence
- Creately for Confluence
- Gliffy Confluence Plugin
- Graphviz Plugin for Confluence
- Lucidchart for Confluence

Search the Atlassian Marketplace for more add-ons.

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Vary the structure of your pages

You can build up a custom layout by using the page layout tool to add sections and columns to your page. See the detailed guidelines to Page Layouts, Columns and Sections.

Do you need to display tabular data, which your readers can sort when viewing the page? See Tables.

Use other macros to highlight and format sections of your page:

- Panel
- Info, Tip, Note, and Warning
- Code block
- Noformat
Integrate your content with social media

People share information on various social sites. You can make Confluence a focal point where people collect their shared information and see what is happening in the areas that matter to them.

Use the **Widget Connector macro**:
- Show a live stream of tweets from a Twitter user, or tweets matching a Twitter search.
- Display a video from YouTube or other online movie sites.
- Share photographs from Flickr.
- See what else the **Widget Connector macro** can do.

Show activity streams

Make your Confluence pages dynamic and interactive with:
- An activity stream showing updates and comments on Confluence and other linked applications. See **Gadgets**.
- An RSS feed from within Confluence or an external site. See **Subscribe to RSS Feeds within Confluence**.
- A list of recent blog posts from within Confluence. See **Blog Posts Macro**.

**Page Templates**

When you add a new page, you don't have to start from scratch. Instead, you can base your new page on a template – a Confluence page with predefined content. Some templates are provided by blueprints or add-ons, and you can even **create your own templates**.

Some examples of useful templates are:
- The **meeting notes template** will help you and your team collaborate on notes and follow-up tasks
- The **requirements template** allows you to capture your software/hardware product requirements, and create related JIRA issues from the page

**Global templates and space templates**

In Confluence, there are two categories of page templates:
- **Space templates**: These page templates are available in a specific space only. If you have **space administrator permission**, you can define templates via the space administration screen.
- **Global templates**: These page templates are available in every space on your site. If you have **Confluence Administrator permission**, you can define global templates via the Confluence Administration Console.

If you're a system administrator, you can also **download predefined templates**.

---

**On this page:**
- Global templates and space templates
- Create a template
- Use a template
- Templates provided by blueprints
- Promote templates in the Create dialog
- System templates

**Related pages:**
- Create a Template
- Administering Site Templates
- Importing Templates
- Create a Page from a Template

---

**Create a template**
You can write your template using the Confluence editor. You can also add special variables to the page, if you want to include fields that the author will complete when adding the page. See Create a Template for more information.

**Use a template**

Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the Atlassian Marketplace for template add-ons. See Create a Page from a Template for more information.

**Templates provided by blueprints**

A blueprint is a page template with added functionality to help you create, manage and organize content in Confluence, and there's a collection of predefined ones that ship with Confluence. You can also download additional blueprints from the Atlassian Marketplace. You can customize the blueprint templates to suit your individual needs, disable particular blueprints or even develop your own blueprints.

**Promote templates in the Create dialog**

If you're a space administrator, you can choose to promote specific templates and blueprints in the Create dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular types of content, instead of blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank Page and Blog Post collapsed under them. To view the other types of content available choose the Show more link.

To promote a template or blueprint:

1. Go to Space Tools > Content Tools
   If your space is using the Documentation theme choose Browse > Space Admin > Templates
2. Choose Promote next to the templates or blueprints you want to appear in the Create dialog

Remember, by promoting a blueprint or template you'll be hiding all other items, including blank page and blog post, under the Show more link.

If you use the Show more link in the create dialog more than three times in a single space, the dialog will show you all templates by default from then on.

**System templates**

Confluence also provides 'system templates' containing content like the site welcome message and default space content. See Administering Site Templates.

**Create a Template**

In Confluence, there are two categories of page templates:
• **Space templates**: These page templates are available in a specific space only. If you have space administrator permission, you can define templates via the space administration screen.

• **Global templates**: These page templates are available in every space on your site. If you have Confluence Administrator permission, you can define global templates via the Confluence Administration Console.

Add a space template

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Choose **Templates > Create new template**.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** from the header

   **Note**: The Space Admin option appears only if you have space admin permissions, or if you’re part of the ‘confluence-administrators’ group.

2. Choose **Templates** from the space administration options.
3. Choose **Create new template**.

Add a global template

1. Choose the **cog icon**, then choose **General Configuration** under Confluence Administration
2. Choose **Global Templates and Blueprints** in the left-hand panel
3. Choose **Add New Global Template**

On this page:

- Add a space template
- Add a global template
- The template editor
  - Template variables
  - Labels
  - Images and other attachments
  - Instructions

Related pages:

- Create a Page from a Template
- Page Templates
- Add, Remove and Search for Labels
- Macros
- The Editor

Check out the article [How to document releases and share release notes](#) to see how helpful creating templates in Confluence can be.

The template editor
When you create or edit a template, you’ll be using the editor in much the same way as when you edit a page or blog post. In addition you can add variables, which will produce a form for data collection when anyone adds a page based on the template.

Screenshot: The template editor with an image, table, text, and variables

Screenshot: The form displayed when you create a page based on the template
Template variables

When you add variables to your template, they will act as form fields. When you create a page based on a template, you'll see a text entry box for each field. Enter data into each field, and it'll be added to the page.

You can add the same variable more than once in the same template, which is useful if you need the same information in more than one place on the page.

To insert a variable into a template:

1. Choose Template > New Variable from the editor toolbar (or choose an existing variable to add it to the page)
2. Enter a name for the variable
3. Press Enter (by default this will create a single-line text input field)

To change the variable type, click the variable placeholder and the variable's property panel will appear. Choose one of the variable types: Text, Multi-line Text, or List.

You can change the number of lines and width in characters of a Multi-line Text field. If you choose List, enter each of the items in your list, separated by commas.
Hint: Type $ and the variable name, then press Enter to add a new variable or to select an existing variable from a list of suggestions. The suggestions dialog shows variables already defined in this template.

Labels

If you'd like all pages created using this template to have one or more labels, choose the labels icon next to the breadcrumbs at the top of the page to add them.

Images and other attachments

You can't upload an image or other file into a template directly. First you'll need to upload the file to a page in your site, then in your template, choose Insert > Files > Search on other pages to embed the file or image.

Instructional text

Instructional text is placeholder content in a template, and is only visible while you're editing the page. Use it to give guidance to whoever is creating a page from the template.

To insert instructional text:

1. Choose Template > Instructional Text in the toolbar
2. Type in your instructional text (for example, Insert an image of the interface here.)

Instructional text appears in italics with a shaded background, to distinguish it from normal paragraph text.

You can also change the placeholder type from Text to either:

- User mention – Opens the user mention dialog.
- JIRA Macro – Opens a dialog that allows you to create a new JIRA issue, or search for one or more JIRA issues to include on the page.

Add a description to your template

The template description displays in the 'Create' dialog, and is useful for explaining the purpose of your template to other users.

To add a description to a template:

- Go to the space or global templates page (as described above)
- Choose the Edit icon in the 'Description' column
- Enter your description and choose Save
Edit or delete a template

If you need to change anything about your template, or want to delete it, navigate to either your space or global template (as described above) and choose either **Edit** or **Delete**.

Notes

- Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the [Atlassian Marketplace](https://www.atlassian.com/marketplace) for template add-ons.
- When you use a Table of Contents macro in a template, you'll see an error when you preview the template, but the Table of Contents macro works on the pages that people create from the template.
- The editor for templates is available only in **Confluence 4.3 and later**. Please refer to the [earlier documentation](https://confluence.atlassian.com/display/DOC/Using+Templates) for a description of the wiki markup editor templates.
- Confluence also provides 'system templates' containing content like the site welcome message and default space content. See [Administering Site Templates](https://confluence.atlassian.com/display/DOC/Administering+Site+Templates).

Create a Page from a Template

You can create a page based on a global template (available to all spaces) or a space template (available only to that space).

Information copied from the template to the page

When you create a page based on a template, Confluence will copy the following content and information from the template to the new page:

- Labels
- Text and styles
- Layouts and formatting
- Macros
- Embedded images and other files. Note that you cannot attach an image or other file to a template. But if the template displays an image or file from another page, the new page will display that image or file too.

Form fields displayed by the template

If the template author included variables in the template, Confluence will display a form prompting you to supply values for the variables when you add the page.
Using a template to create a page

**To create a page based on a template:**

1. Choose Create from template
   in the Confluence header
2. Select a space and the template you want to use and choose Next
   If the template contains variables, you’ll see a form allowing you to add values for the form variables.
3. Type the relevant information into the form fields, and choose Next
   Now you’ll see a new page based on the template. If you added information in the form fields, the
   page content will include that information.
4. Name your page, add content or make any other changes required and hit Save

Screenshot: Form showing template variables when creating a page from a template

Notes

Page templates are used only when adding a page. It is not possible to apply a template to an
already-existing page. Once a page has been added using a template, the template is no longer linked to the
page. All further editing is performed as if the template was never used. Some plugins provide enhanced
Blueprints

What’s a blueprint?

A blueprint is a set of page templates with added functionality to help you create, manage and organize content in Confluence more easily.

Create meeting notes, shared file lists and requirements documentation out of the box, and Customize the blueprint templates to suit your individual needs. You can even develop your own blueprints.

Create content using a blueprint

1. Choose Create from template
   
   in the Confluence header

2. Select a blueprint from the create dialog

3. Hit Create

The editor will open, and, depending on the blueprint selected, a prompt to enter information or the page will appear. You can now follow the instructions built in to the blueprint to add content.

The first time a blueprint is used in a space, Confluence creates an index page and adds a shortcut to your sidebar (if you're using the default theme). The index displays a list of pages made with the blueprint, and information selected information from your blueprint pages. For example, the meeting notes index displays a list of all meeting notes pages in the space, who created them, and when they were last modified.

Screenshot: Index page for the Meeting Notes blueprint

If you're using the Documentation theme, your blueprint index page(s) will appear in the sidebar as children of the homepage.

Customize blueprint templates

Blueprints are made up of templates that can be customized for an individual space or the whole site. This means you can adapt the content of the blueprint pages to suit your specific needs. For example, you might update the Meeting Notes blueprint templates to include a heading for apologies.

If you have space administrator permissions, you can customize blueprint templates for the spaces you are an administrator of. You must be a Confluence Administrator to customize blueprint templates for a whole
To customize a blueprint template for a space:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Edit beside the blueprint template you wish to edit
3. Make your changes to the template and choose Save

Editing a blueprint template is very similar to editing a page template, except:

- Be careful not to remove any macros that the blueprint page or index page may use to store and display information
- You can't remove a blueprint template or change the template name

To reset a blueprint template back to the default:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Reset to default beside the blueprint template you wish to reset

See Working With Templates and Administering Site Templates for more information on templates.

As with user created space and site templates, editing a blueprint template will not change existing pages, but any new blueprint pages will be based on the updated template.

Promote blueprints in the Create dialog

If you're a space administrator, you can choose to promote specific templates and blueprints in the Create dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular types of content, instead of blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank Page and Blog Post collapsed under them. To view the other types of content available choose the Show more link.

To promote a template or blueprint:

1. Go to Space Tools > Content Tools
   If your space is using the Documentation theme choose Browse > Space Admin > Templates
2. Choose Promote next to the templates or blueprints you want to appear in the Create dialog

Remember, by promoting a blueprint or template you'll be hiding all other items, including blank page and blog post, under the Show more link.

If you use the Show more link in the create dialog more than three times in a single space, the dialog will show you all templates by default from then on.

Add more blueprints

You can find more blueprints for Confluence in the Atlassian Marketplace. Blueprints are managed using add-ons (also known as plugins).

See Request Add-ons for information on how you can search for new blueprint add-ons and send a request to your System Administrator.
If you are a System Administrator, see Managing Add-ons or Plugins for information on how to install new blueprint add-ons.

You can also develop your own blueprints. See our developer documentation on Writing a Blueprint.

Disable a blueprint

You may want to disable particular blueprints. For example, you may not want to see the Product Requirements blueprint in the create dialog in an HR or Social space. If you are a Confluence Administrator you can also disable particular page and space blueprints for the whole site.

To disable a blueprint in a space:

- Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
- Choose Disable next to the blueprint you wish to disable in that space

You can re-enable the blueprint at any time.

To disable a blueprint across a whole site:

- Choose the cog icon
  - then choose General Configuration under Confluence Administration (You need Confluence Administrator permissions to do this)
- Choose Global Templates and Blueprints
- Choose Disable next to the page or space blueprint you wish to disable

The blueprint will not appear in the ‘Create’ or ‘Create Space’ dialogs.

Full list of blueprints

Here’s the full list of blueprints bundled with Confluence.

<table>
<thead>
<tr>
<th>Page blueprints</th>
<th>Space blueprints</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meeting notes</td>
<td>Documentation space</td>
</tr>
<tr>
<td>File list</td>
<td>Team space</td>
</tr>
<tr>
<td>Decision</td>
<td>Knowledge base space</td>
</tr>
<tr>
<td>How-to article</td>
<td></td>
</tr>
<tr>
<td>Troubleshooting article</td>
<td></td>
</tr>
<tr>
<td>JIRA report</td>
<td></td>
</tr>
<tr>
<td>Product requirements</td>
<td></td>
</tr>
<tr>
<td>Retrospective</td>
<td></td>
</tr>
<tr>
<td>Share a link</td>
<td></td>
</tr>
<tr>
<td>Task report</td>
<td></td>
</tr>
</tbody>
</table>

Decisions Blueprint

The Decisions blueprint helps you make decisions and record the outcomes with your team.

The first time you use the Decisions blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you’re using the default theme). The index acts as your Decision Register and lists all the decisions in that space.

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a page from a template, hit the Create from template button.

Related pages:

- Blueprints
- File List Blueprint
- Meeting Notes Blueprint
- Product Requirements Blueprint
To create a decision page:

1. Choose **Create from template** in the Confluence header
2. Select **Decision** and hit **Next**
3. Enter information about the decision and relevant stakeholders (the blueprint will prompt you) and hit **Create**

Once you save your first decision page, Confluence will create a decision register page for the space you're in, and add a shortcut to it in the space's sidebar.

**Screenshot: Decision Register showing a series of Decision pages**

**Decision pages**
Your existing decisions appear here

**Screenshot: Editing a Decision page**

**What is our target launch date?**

The Decisions blueprint uses these Confluence features:

- Page Properties and Page Properties Report macro - content that you enter within the page properties macro can appear on the index page.
- **Mentions** - add a user as a stakeholder, owner or @mention them on the page and they will be notified in their workbox.

For an example of the Decisions Blueprint, and some other great page elements, check out: How to make better decisions as a development team.

### Customizing this blueprint

You can customize the templates that are used by the Decisions blueprint - see Customizing the blueprint templates. For example, you might choose to edit the decisions **index page** in a space to change the columns displayed by the Page Properties Report macro.

You can also edit the **page template** to add headings or instructional text to the background section, or even add rows to the Page Properties macro. For example, a row for the date the decision was made.

See Instructional text to find out more about using instructional text in templates.

### File List Blueprint

The File List blueprint helps you to create lists of files to share with your team. Great for organizing documents, images and presentations.

The first time you use the File List blueprint in a space, Confluence will create an index page and add a shortcut to your space sidebar (if you're using the default theme). The index page lists the latest File List pages in that space. You can have as many File List pages as you need.

To create a file list:

1. Choose **Create from template**
   - in the Confluence header
2. Select **File List** and hit **Next**
3. Enter the details for your file list and hit **Create**
4. Drag files from your desktop or choose **browse for files** to search for files on your computer

Attachments appear on the page, and you can expand each attachment to preview the file and/or view its details.

In this example, three file list pages have been created to store project related presentations, images and customer feedback. Confluence looks after the versioning of the files, so there’s no need to use the document file name to mark version numbers.

**Screenshot: Index page showing File List pages**
Customizing this blueprint

You can customize the templates that are used by the File List blueprint - see Customizing blueprint templates.

The File List blueprint template uses the attachments macro. You can customize the macro to change the sort order or hide features such as version history and the upload attachment fields.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages you want to display.

Meeting Notes Blueprint
The Meeting Notes blueprint helps you to plan your meetings and share notes and actions with your team.

The first time you use the Meeting Notes blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you are using the default theme). The index page lists the latest Meeting Notes pages in that space.

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a page from a template, hit the Create from template button.

To create a meeting notes page:

1. Choose Create from template
2. in the Confluence header
3. Select Meeting Notes and hit Next
4. Enter the information required by the template and hit Create
5. Save your page and get ready to attend your meeting

You can edit the page during or after your meeting, and enter your notes, action items and @mention users to assign tasks to them.

**Screenshot: A Meeting Notes index page**

**Screenshot: A blank Meeting Notes page showing instructional text**
The Meeting Notes blueprint uses some cool Confluence features:

- **Instructional text** - this handy text prompts you to enter information and disappears when you start typing or view the page.
- **Mentions** - @mention a user on the page and they will be notified in their workbox.
- **Task lists** - @mention a user in a task to assign it to them – the task will appear as a personal task in their workbox. You can also add a due date by typing //, then choosing a date from the calendar.

Customizing this blueprint

You can customize the templates that are used by the Meeting Notes blueprint – see Customizing the blueprint templates.

You might choose to edit the headings or add additional headings, or change the instructional text that prompts users to enter information to suit your context. To find out more about using instructional text in a template, see Instructional text.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages you want to display.

**Product Requirements Blueprint**

The Product Requirements blueprint helps you to define, scope and track requirements for your product or feature.

The first time you use the Product Requirements blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (shortcut only available in the default theme). The index lists all the Product Requirements pages in that space, and displays a summary of the
information on each page (such as status and owner). You can have as many Product Requirements pages as you need.

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a page from a template, hit the Create from template button.

To create a requirements page:

1. Choose Create from template in the Confluence header
2. Select Product Requirements and hit Next
3. Enter information about your product or feature (the instructional text will prompt you) and hit Create

You can @mention team members to bring them into the conversation about the page.

Screenshot: Index showing a series of Product Requirements pages and summary information

Screenshot: Editing a Product Requirements page
The Product Requirements blueprint uses these Confluence features:

- **Page Properties** and **Page Properties Report** macro - content that you enter within the page properties macro can appear on the index page.
- **Instructional text** - this handy text prompts you to enter information or create a JIRA issue and disappears when you start typing or view the page.
- **Mentions** - @mention a user on the page and they will be notified in their workbox.

Customizing this blueprint

As no two products or projects are alike, you can customize the templates that are used by the Product Requirements blueprint - see [Customizing the blueprint templates](#).

You might choose to edit the **index** page in a space to change the columns to be displayed by the Page Properties Report macro.

You might choose to edit the **page template** to:

- edit the headings or add additional headings
- change the instructional text that prompts users to enter information to suit your context
- add or remove rows within the Page Properties macro.

See [Instructional text](#) to find out more about using instructional text in templates.

**Shared Links Blueprint**

The Shared Links blueprint helps you take content from the web and share it with your team. You can use Shared Links to share and collaborate on web content, or to create a centralized repository of useful links.

The first time you use the Shared Links blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you’re using the default theme). The index lists all the shared links in that space.

If you want to quickly create a blank page, hit the **Create** button in the header; if you want to create a page from a template, hit the **Create from template** button.
To create a shared links page:

1. Choose Create from template
   in the Confluence header
2. Select Share a link and hit Next
3. Enter the URL of the web content you want to share, then hit Create

You can also:

- Include topics to help categorize your links – these are added as labels to your page.
- Share the link immediately with another user or group – users will receive a notification.
- Add a comment to start the discussion.

To make sharing links even faster, you can add a Share on Confluence button to your browser’s toolbar. Click this button and the webpage you’re currently viewing will be added as a shared link!

To add the Share on Confluence button to your browser:

1. Choose Create from template

   , then select Share a link
2. Drag the Share on Confluence button to your browser toolbar

Now, when you want to share a link in Confluence, choose the Share on Confluence button in your browser and follow the prompts.

Screenshot: Share a link from the Create dialog.
The JIRA Report blueprint helps you create easy to read reports to communicate the progress of your JIRA Software projects and releases. You can choose from a Change Log report that generates a list of JIRA issues or a Status Report that includes charts to visually communicate your progress.

The first time you use the JIRA Reports blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you’re using the default theme).

To use the JIRA Report Blueprint your Confluence and JIRA application (such as JIRA Software) must be connected via Application Links.

Create a Change Log

The Change Log report displays a list of issues from your JIRA application. This list can be static or dynamic, automatically updating as the status of your issues change in JIRA.

To create a static change Log:

1. Choose Create from template
   in the Confluence header
2. Select JIRA report and hit Next
3. Select a Change log and hit Next
4. Enter the information required for the change log and hit Create

A report page will be created with sample text and a list of all issues for the project and fix versions selected, organized by issue type. This list of issues is static; it won't be updated when the issues are updated, and is visible to users who don't have JIRA access or permissions to view that project.

Screenshot: Creating a Change Log in simple mode.

Screenshot: Static list of JIRA Issues displaying in the Change Log.
To create a dynamic change log:

1. Choose **Create from template** in the Confluence header.
2. Select **JIRA report** and hit **Next**.
3. Select a **Change log** and hit **Next**.
4. Choose **Switch to advanced**.
5. Enter a JQL query or paste in the URL of a JIRA search (find out about using JQL in the **JIRA** Documentation).
6. Hit **Create**.

A report page will be created with sample text and a JIRA issues macro that's configured to show your issues. The macro is dynamic and will update when the issues are updated. For more information on changing the information displayed, refer to the **JIRA Issues macro**.

*Screenshot: Dynamic list of JIRA Issues displaying in the Change Log.*

Create a Status Report

The Status Report displays the progress of a JIRA project and fix version in pie charts by status, priority, component and issue type. The Status Report uses the JIRA Chart macro, and is dynamic.

To create a status report:

1. Choose **Create from template** in the Confluence header.
2. Select **JIRA report** and hit **Next**.
3. Select a **Status report** and hit **Next**.
4. Enter the information required for the report and hit **Create**.

A report page will be created with sample text and a series of pie charts, using the JIRA Chart macro. The macro is dynamic and will update when the issues in JIRA are updated. For more information refer to the **JIRA Chart macro**.

*Screenshot: All updates for this release displaying in the Status Report.*
As with the Change Log, you can switch to Advanced mode and use JQL or paste in a JIRA URL to search for issues to display in the report.

Screenshot: Excerpt from the Status Report.

Customizing this blueprint

You can customize the templates used by this blueprint. The Change Log uses the Snapshot JIRA Report Template (for static list of issues) and the Dynamic JIRA Report Template, and the Status Report uses the Status Report Template. See Customizing the blueprint templates. Variables represent the JIRA Issues and JIRA Chart Macros. While these can't be edited, they can be moved around the page or deleted if you don't want every chart to be included.

You can also choose to edit the page template to modify the format of the page, change some headings, or modify the instructional text. To See Instructional text to find out more about using instructional text in templates.

Retrospective Blueprint

Retrospective pages help you track team successes and opportunities after projects or at the end of a sprint. Use this blueprint to document what went well, what needed improvement, and assign actions for the future.

The first time you create a retrospective page in a space, Confluence will automatically create an 'index' page, which will list all retrospectives in the space, and add a shortcut to it in the space sidebar.

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a page from a template, hit the Create from template button.

To create a retrospective page:

1. Choose Create from template
1. Select **Retrospective** and hit **Next**
2. Add participants, change the title if you want to and click **Create**

**Screenshot: The 'retrospective' template page**

The Retrospective blueprint uses the following Confluence features:

- **Page Properties** and the **Page Properties Report** macro make content listed within the macro visible on the index page.
- **Instructional text** prompts you to enter information and disappears when you start typing or view the page.
- **Mention** a user on the page to notify them in their workbox.

Check out how the retrospectives blueprint can be used in the article [Create sprint retrospective and demo pages (like a BOSS)](link).  

Customize this blueprint

Every team conducts retrospective meetings differently, so you can customize the Retrospective blueprint template to match your team’s culture and practices. You can:
Create a Blueprint-Style Report

Using a combination of templates and macros you can make a wide range of reports for managing anything from customer interviews, product requirements to IT service catalogs and more. In this tutorial we'll guide you through the process of creating a blueprint-style report.

In this example, we'll create a multi-team status report. Here's the scenario we'll use for this tutorial.

The Design, Development and QA teams working on the Blue Sky Project need to produce a short status update page each week, containing the focus area for the week, contact person, risks and overall status for each team. They like the way the Product Requirements blueprint works and want to be able to manage their status updates in a similar way.

What do each of the players want out of this report?

- **Project Lead** – Wants an at-a-glance report that shows only the status for each team.
- **Team Leads** – Want a summary report, including the focus areas and risk, just for their team.
- **All team members** – Want it to be easy to create the new page each week.
- **Management Team** – Want to see all the details for a week on one page, and don't want to have to look at a different page for each team.

With this scenario in mind, this tutorial will guide you through how to:

1. Create a status update template containing a separate page properties macro for each team's section of the report.
2. Create a high level status report, showing just the status of all teams.
3. Create a summary report for each team.
4. Create your first status update page.

You'll need Space Administrator permissions to complete some of the steps in this tutorial.

Part 1: Create a status update template

First we'll create a page template and add the Page Properties macros.

1. Go to Space Admin > Content Tools > Templates
2. Choose Create Template
3. Give the template a name (in this example the template will be called 'Status Update')
4. Add the skeleton of your status report to the page
5. Choose the label icon

   at the top of the page to add a label to the template (in this example, we'll add the label: 'status-update')

   *Screenshot: Adding teams to our status update template*
Now we’ll add a Page Properties macro to record the status of the Design team.

6. Choose **Insert > Other Macros > Page Properties** to add the Page Properties macro to the page
7. In the macro body create a two column table and remove the heading row
8. In the left column enter the column headings for your report (these are known as metadata 'keys')
   In this example we’ll add 'Design Focus', 'Design Status', 'Design Contact' and 'Design Risks').
9. In the right column, leave the cells blank, or enter some instructional text to prompt your users (Choose **Template > Instructional Text**)
   We’ve also added a status macro.
10. **Edit** the Page Properties macro and enter a **Page Properties ID** for this macro (in this example we’ll use 'status-update-design'. This will allow us to report on the status of just the Design team later on)
    Repeat this process for the Development and QA teams, remembering to specify a different ID for each macro (we used 'status-update-dev' and 'status-update-qa').
11. Finally, add any other headings, instructional text or content to your template and **Save**.
    You can enter a **Description** for your template - this appears in the Create dialog.

*Screenshot: Our status update template*
Part 2: Create a report showing the high level status of each team

Next we'll create an index page, just like you see in many blueprints.

1. In your space create a new blank page (this will be our ‘Status Report - all teams’ page, showing just the status of each team)
2. Choose Insert > Other Macros > Page Properties Report to add the Page Properties Report macro to the page
3. Enter the Label to report on (in this example, it’ll be the 'status-update' label we added to the template page)
4. Leave the Display options > Page Properties ID field blank (we want to report on all the macros on the page)
5. In the Columns to Show field, list the 'keys' from each macro that you want to include in the report (in this example, we only want to show the values of ‘Design Status’, ‘Dev Status’, ‘QA Status’)
6. Choose Save to add the macro to the page

*Screenshot: The page properties report macro on the ‘Status Report - all teams’ page*
Part 3: Create a separate report for each team

Now we'll create some index pages that show a more detailed summary for each team, starting with the Design team.

1. Create a new blank page – this will be the 'Design Status Report' index page, showing just information for that team.
2. Choose Insert > Other Macros > Page Properties Report to add the Page Properties Report macro to the page
3. Enter the Label (the page label is once again 'status-update', the label we added to the template)
4. Expand the Display options and enter the Page Properties ID that was specified in the Page Properties macro in the template (in this example it was 'status-update-design') – this allows us to report on just information in that macro.
5. Leave all of the other fields blank (we want to show all columns from this Page Properties macro)
6. Choose Save to add the macro to the page

Screenshot: The page properties report macro on the 'Design Status Report' index page
7. Add any other content, links or images to the page and **Save**

8. Choose **Space Tools > Configure Sidebar > Add Link** to add a shortcut to the page on the sidebar

9. Create a new page and repeat this process for each team
   Remember to specify a different Page Properties ID each time (in this example 'status-report-dev' and 'status-report-qa').

If your Design, Dev and QA teams have their own team spaces, this summary report could even be created in their team spaces. Just be sure to specify the space where the Status Updates pages are created in the **Restrict to spaces** field, to make sure the macro can find the pages to report on.

**Part 4: Create your first status update page**

**That's it! Create from template**

in the Confluence header, then select **Status Update**, or use the **Create a new status update** button to make your first status update page. Just like a blueprint, but 100% made by you.

Here's how our finished pages look.

*Screenshot: Team Leads and the management team still have a single page for the weekly status update*
The Project Lead can see the status of each team, each week, at a glance in the All Teams status report.

Each team can see their focus, risks and status at a glance in their status report.
Remember, these concepts don’t just apply to status updates – you can use them for any purpose at all.

Import Content Into Confluence

There are a number of ways you can get existing content, such as text, images and other content into Confluence.

Import content from other Confluence sites

To import content from another Confluence site you can:

- Import a backup of the entire Confluence site
- Import an XML export of an individual space.
  Page history, attachments, and page content will be preserved.

See Restoring a Site and Restoring a Space for more information.

Import content from a Microsoft Word document

The Office Connector allows you to create pages by importing Word documents. The document content is copied onto one or more Confluence pages. See Import a Word Document into Confluence.

Import web content

To displaying web content on a page:

- Use the Widget Connector Macro to display videos, slide shows, twitter chats, documents and more, sourced from other web sites and displayed on your Confluence page.
- Embed an external web page into Confluence with the HTML Include macro.
- Use HTML code in a page with the HTML macro.

Import other content

Importing non-wiki markup into Confluence requires a conversion process:

- Text with basic formatting can be pasted directly into the editor. This includes simple Word documents or web pages.
- Confluence pages saved to disk can be imported from disk.
- Files can be uploaded in bulk using the Confluence WebDav Plugin
- Full featured customization is available using the Confluence APIs.

Import a Word Document into Confluence
The Office Connector allows you to import Word documents and create one or more Confluence pages from the content.

You can create a single page, or divide the contents up into multiple pages, based on the headings in your document.

This is useful if you have a lot of content stored in existing documents, or if you are migrating from another system or platform that allows you to export to Word format.

⚠️ The Office Connector is only available for some browsers, operating systems and applications, so you'll need to check the Office Connector Prerequisites before you start.

**Import a Word document**

1. Create a page in Confluence or go to an existing page (you want to view the page, not edit it).
2. Choose
   *** > Import Word Document
3. Choose **Browse** and locate the Word document you want to import then choose **Next**.
   The import document options appear.
4. Enter a **title** for the new page (useful if you do not want to use the file name as your page title).
5. Choose **where** you want to import the file (as a brand new page, or overwriting an existing page with the same title).
6. Choose how to handle **title conflicts** (rename the new pages or replace existing pages).
7. Choose whether to create a single page or multiple pages based on the heading styles in the file (this option is only available if the file contains heading styles).
8. Click **Import**.

When the upload has finished, pages will be created with the content of the Word documents. You can then view and edit this page as normal. There's no connection between the original Word document and this page.

**Import options**

There are a number of options when importing a Word document that control how pages are created, whether the import should overwrite existing pages in the space, and how it should handle page name conflicts.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root page title</td>
<td>This is the title of the page that will be created or updated by the import.</td>
</tr>
<tr>
<td>Where to import</td>
<td>Controls whether the document is imported into the current page (the page you were viewing when you selected Tools &gt; Import) or created as a new page. Choose from</td>
</tr>
<tr>
<td></td>
<td>- <strong>Import as a new page in the current space</strong> - a new page will be created as a child of the space home page.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Replace &lt;page name&gt;</strong> - content will be imported into the current page. The title of this page will change to the title you specified in the Root page title field.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Delete existing children of &lt;pagename&gt;</strong> - any existing children of the current page will be removed when the content of the page is replaced.</td>
</tr>
</tbody>
</table>
Title conflicts

Controls how page name conflicts (a page with the same title already exists in the space) are handled.

- **Rename imported pages if page name already exists** - new pages get a new name (a number added to the end of the page title). Existing pages will be unchanged.
- **Replace existing pages with imported pages of the same title** - overwrite the content of existing pages. The change will be shown in the Page History for the page.
- **Remove existing pages with the same title as imported pages** - remove original pages and then create new pages. The change is not shown in the Page History for the page.

Split by heading

If the document contains Word heading styles you can choose to create multiple pages based on the heading. Options are:

- **Don't split** - creates a single page.
- **Level Headings** - creates multiple pages in a hierarchy based on the heading levels in the document.

A preview of the pages that will be created appears under Document Outline.

---

**Orphaned Pages**

An orphaned page is a page without any incoming links and is located at what's called the 'root of the space', meaning it sits alongside the space's home page. This means that, unless you know the page exists, you're not likely to come across it during the natural course of navigation.

There may be a legitimate reason you want to have a page at the root of a space. For example, you may be effectively hiding it in the navigation. If you don't want orphaned pages though, you can easily view all orphaned pages in a space so you can tidily delete the pages or reorganize them so they're no longer orphaned.

**To view the orphaned pages in a space:**

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Choose **Orphaned Pages**

If your space uses the Documentation theme:
1. Choose **Browse > Space Operations** at the top of the screen
2. Choose **Orphaned Pages** in the space operations options

While in the orphaned pages view, you can do any of the following:

- Delete an orphaned page by choosing the 'trash can' icon next to the page name.
- Edit a page by choosing the 'pencil' icon next to the page name.
- Give an orphaned page a parent — see **Move and Reorder Pages**.

**Screenshot: Managing orphaned pages**

<table>
<thead>
<tr>
<th>Title (Space)</th>
<th>Creator</th>
<th>Created</th>
<th>Last Updated By</th>
<th>Updated</th>
<th>Operations</th>
</tr>
</thead>
</table>

**Undefined Page Links**

You can add links to pages that don’t yet exist in Confluence, but you intend to create later. Known as links to ‘undefined pages’, they allow you to create a link which, when clicked, will create a page with the name you specify in the link.

Create an undefined page link

1. Choose **Insert > Link** or press **Ctrl+K** on your keyboard
2. Choose **Advanced**
3. Enter the name of the page to be created in the **Link** field

A link to an undefined page is shown in dark red while in the editor. When anyone clicks the link, Confluence will create a new page with the name you typed in the **Link** field.

**View undefined pages in a space**

The **Undefined Pages** view shows you all undefined pages in your space. The undefined page links are badged with a ♻ icon to remind you that those pages are yet to be created.

**To view a list of the undefined links in a space:**

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Choose **Undefined Pages**

If your space uses the Documentation theme:

1. Choose **Browse > Space Operations** at the top of the screen
2. Choose **Undefined Pages** in the space operations options
You can choose the link for an undefined page to create the page and add content to it.

**View Page Information**

The Page Information view for a page shows you useful information about the page.

To see the information about the page:

1. View the page.
2. Choose
   ***
   > **Page Information**

You will see the following information:

- **Page details**: Title, author, date of creation, date of last modification and the tiny link (permalink) of the page.
- **Page hierarchy**: Parent-child relationships of the page.
- **Incoming links**: Lists other pages in your Confluence Site that have links to this page, or reference this page in an Include Page or Excerpt Include macro.
- **Labels**: Any labels (tags) that have been applied to this page. See Add, Remove and Search for Labels.
- **Page Permissions**: Displays page-level security restrictions that apply to the page (if present). See Page Restrictions.
- **Hot Referrers**: The external website pages which send the most viewers to the page. See Trackback and External Referrers.
- **Recent Changes**: Links to the five most recent versions of the page along with the name of the editor and the date of modification. See Page History and Page Comparison Views. Choose View page history to see the page history view, all the versions of the page in reverse chronological order and allows you to compare versions or to restore a previous version.
- **Outgoing links**: A summary of the links contained on this page, pointing to other pages on the Confluence site or to external websites.

Note: if there is no information to report (for example the page has no restrictions or no incoming links), that section of the Page Information won't appear.

*Screenshot: Page information for this page*
Page History and Page Comparison Views

Confluence tracks the history of changes to each page by creating a new version of the page each time it's modified. You can view the changes between different versions, and roll back to a previous version if you need to.

Access the page history

To view the history of a page:

1. Go to the page and choose
   ***
   > Page History
2. Choose a version number to view the content of that version

Screenshot: Page history
View an older version

When you select a previous version of the page, you'll see a header like this at the top of the page:

⚠ You are viewing an old version of this page. View the current version.

Compare with Current  ·  Restore this Version  ·  View Page History

« Previous  Version 2  Next »

⚠ If you want to send this page version to someone, copy and paste the URL from your browser. The link will look something like this: http://confluence.atlassian.com/pages/viewpage.action?pageId=12345.

When you're viewing a specific version of the page, the following functions are available:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>current version</td>
<td>View the latest version of the page.</td>
</tr>
<tr>
<td>Compare with</td>
<td>Compare the differences between the version of the page you are viewing and</td>
</tr>
<tr>
<td>Current</td>
<td>the current version.</td>
</tr>
</tbody>
</table>

Created in 2016 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th><strong>Restore this Version</strong></th>
<th>Roll back the content of the page to the previous version that you are viewing.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>View Page History</strong></td>
<td>Return to the list of page versions.</td>
</tr>
<tr>
<td>&lt;&lt; Previous and Next &gt;&gt;</td>
<td>View the previous or next version of the page.</td>
</tr>
</tbody>
</table>

### Restore a previous version

1. Go to the page and choose
   
   ***
   
   > Page History

2. Choose **Restore this version** beside the version you want to restore (or at the top of the page if you’ve opened the version)

3. Change the default change comment if necessary, and choose **OK**

**Info:** All page history is retained; restoring an older version creates a copy of that version. For example, if you restore version 39, Confluence will create a copy of version 39 and the copy will become the new, current version.

### Delete a specific version

Choose **Delete** next to a version in the page history, to remove that version.

### View the changes made

Using the page history view or the **page information view**, you can see the recent changes made to a page.

**To view recent changes made to a page:**

1. Choose
   
   ***
   
   > Page Information

   In the section titled ‘Recent Changes’ you’ll see the most recent versions of the page, along with the date of their modification and the name of the modifying author.

2. Choose **View Changes** beside the required version

   The page comparison view is displayed, showing the differences between the selected and previous versions.

### Compare two versions

1. Go to the page and choose
   
   ***
   
   > Page History

2. Choose the versions you want to compare by selecting the check boxes beside them

3. Choose **Compare selected versions**

   You’ll see the page comparison view showing the differences between the selected versions. Changes are highlighted as follows:

<table>
<thead>
<tr>
<th><strong>Highlighted color</strong></th>
<th><strong>Meaning</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Added content</td>
</tr>
<tr>
<td>Red</td>
<td>Deleted content</td>
</tr>
</tbody>
</table>
More about the comparison view

When you view a page comparison, all large sections of unchanged text are hidden and reduced to an ellipsis (...).

You can view page changes between versions which are adjacent to your current page comparison view. Click the link containing:

- << to view the page comparison with the earlier adjacent version
- >> to view the page comparison with the more recent adjacent version

For example, if your page comparison view is between v. 30 and v. 34 of a page, you can view changes between:

- v. 29 and v. 30 by clicking Changes from 29 to 30
- v. 34 and v. 35 by clicking Changes from 34 to 35

Confluence Markup

This section describes two types of markup found in Confluence:

- **Confluence storage format.** Confluence stores the content of pages and blog posts in an XHTML-based format. Advanced users can view the storage format of a page and even edit it, provided their Confluence site is configured to allow that. See [Confluence Storage Format](#) for a description of the core elements of the storage format.

- **Wiki markup.** Confluence allows data entry via a shorthand code called wiki markup. Some parts of the Confluence administration interface also accept wiki markup for defining content. For a description of the wiki markup syntax, see [Confluence Wiki Markup](#). Storage format and wikimarkup code examples for macros can be found in the documentation for each [macro](#).

Related pages:
- [Macros](#)
- [The Editor](#)

Confluence Storage Format

This page describes the XHTML-based format that Confluence uses to store the content of pages, page templates, blueprints, blog posts and comments. This information is intended for advanced users who need to interpret and
edit the underlying markup of a Confluence page.

We refer to the Confluence storage format as 'XHTML-based'. To be correct, we should call it XML, because the Confluence storage format does not comply with the XHTML definition. In particular, Confluence includes custom elements for macros and more. We're using the term 'XHTML-based' to indicate that there is a large proportion of HTML in the storage format.

You can view the Confluence storage format for a given page by choosing...

**View Storage Format.** This option is only available if one of the following is true:

- You are a Confluence administrator.
- Your Confluence site has the Confluence Source Editor plugin installed and you have permission to use the source editor.
- If you would like to edit the storage format for a page, your Confluence system administrator will need to install the Confluence Source Editor plugin.
- Clarification of terminology: If you choose...

**View Source**, you'll see the format used within the editor panel, not the storage format of the page.

### Macros

Storage format and wiki markup examples have been included in the documentation for each macro.

### Headings

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heading 1</td>
<td>h1. Heading 1</td>
<td>&lt;h1&gt;Heading 1&lt;/h1&gt;</td>
<td>Underlined in the Documentation Theme</td>
</tr>
<tr>
<td>Heading 2</td>
<td>h2. Heading 2</td>
<td>&lt;h2&gt;Heading 2&lt;/h2&gt;</td>
<td>Underlined in the Documentation Theme</td>
</tr>
<tr>
<td>Heading 3</td>
<td>h3. Heading 3</td>
<td>&lt;h3&gt;Heading 3&lt;/h3&gt;</td>
<td></td>
</tr>
<tr>
<td>Heading 4 to 6 are also available and follow the same pattern</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Created in 2016 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
## Text effects

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>strong/bold</strong></td>
<td><em>strong</em></td>
<td><code>&lt;strong&gt;strong text&lt;/strong&gt;</code></td>
</tr>
<tr>
<td><strong>emphasis</strong></td>
<td><code>_emphasis_</code></td>
<td><code>&lt;em&gt;Italics Text&lt;/em&gt;</code></td>
</tr>
<tr>
<td><strong>strikethrough</strong></td>
<td><code>-strikethrough-</code></td>
<td><code>&lt;span style=&quot;text-decoration: line-through;&quot;&gt;strikethrough&lt;/span&gt;</code></td>
</tr>
<tr>
<td><strong>underline</strong></td>
<td><code>+underline+</code></td>
<td><code>&lt;u&gt;underline&lt;/u&gt;</code></td>
</tr>
<tr>
<td><strong>superscript</strong></td>
<td><code>^superscript^</code></td>
<td><code>&lt;sup&gt;superscript&lt;/sup&gt;</code></td>
</tr>
<tr>
<td><strong>subscript</strong></td>
<td><code>~subscript~</code></td>
<td><code>&lt;sub&gt;subscript&lt;/sub&gt;</code></td>
</tr>
<tr>
<td><strong>monospace</strong></td>
<td><code>{{monospaced}}</code></td>
<td><code>&lt;code&gt;monospaced&lt;/code&gt;</code></td>
</tr>
<tr>
<td><strong>preformatted</strong></td>
<td>n/a</td>
<td><code>&lt;pre&gt;preformatted text&lt;/pre&gt;</code></td>
</tr>
</tbody>
</table>
### Block Quotes

<table>
<thead>
<tr>
<th>Format</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>block quotes</td>
<td><code>bq. block quote</code> or <code>{quote}</code></td>
<td><code>&lt;blockquote&gt;</code> <code>&lt;p&gt;block quote&lt;/p&gt;</code> <code>&lt;/blockquote&gt;</code></td>
<td></td>
</tr>
</tbody>
</table>

### Text Color

<table>
<thead>
<tr>
<th>Format</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>text color</td>
<td><code>{color:red}red text</code></td>
<td><code>&lt;span style=&quot;color: rgb(255,0,0);&quot;&gt;red text&lt;/span&gt;</code></td>
<td></td>
</tr>
</tbody>
</table>

### Font Size

<table>
<thead>
<tr>
<th>Format</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>small</td>
<td>n/a</td>
<td><code>&lt;small&gt;small text&lt;/small&gt;</code></td>
<td></td>
</tr>
</tbody>
</table>

### Big Text

<table>
<thead>
<tr>
<th>Format</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>big</td>
<td>n/a</td>
<td><code>&lt;big&gt;big text&lt;/big&gt;</code></td>
<td></td>
</tr>
</tbody>
</table>

### Center-Align Text

<table>
<thead>
<tr>
<th>Format</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>center-align</td>
<td>n/a</td>
<td><code>&lt;p style=&quot;text-align: center;&quot;&gt;centered text&lt;/p&gt;</code></td>
<td></td>
</tr>
</tbody>
</table>

### Right-Align Text

<table>
<thead>
<tr>
<th>Format</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>right-align</td>
<td>n/a</td>
<td><code>&lt;p style=&quot;text-align: right;&quot;&gt;right aligned text&lt;/p&gt;</code></td>
<td></td>
</tr>
</tbody>
</table>

### Text Breaks

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>New paragraph</td>
<td>Paragraph 1 (empty line) Paragraph 2</td>
<td><code>&lt;p&gt;Paragraph 1&lt;/p&gt; &lt;p&gt;Paragraph 2&lt;/p&gt;</code></td>
<td>Paragraph 1 Paragraph 2</td>
</tr>
<tr>
<td>Line break</td>
<td><img src="#" alt="Line 1 \ Line 2" /></td>
<td><img src="#" alt="Line 1 \ Line 2" /></td>
<td></td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------</td>
<td>-----------------------</td>
<td></td>
</tr>
<tr>
<td>Note: Created in the editor using Shift + Return/Enter</td>
<td><img src="#" alt="Line 1 &lt;br /&gt; Line 2" /></td>
<td><img src="#" alt="Line 1 Line 2" /></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Horizontal rule</th>
<th><img src="#" alt="----" /></th>
<th><img src="#" alt="&lt;hr /&gt;" /></th>
</tr>
</thead>
<tbody>
<tr>
<td>— symbol</td>
<td><img src="#" alt="---" /></td>
<td><img src="#" alt="–" /></td>
</tr>
<tr>
<td>– symbol</td>
<td><img src="#" alt="--" /></td>
<td><img src="#" alt="–" /></td>
</tr>
</tbody>
</table>

### Lists

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Unordered list – round bullets</strong></td>
<td>* Round bullet list item</td>
<td>&lt;ul&gt;&lt;li&gt;round bullet list item&lt;/li&gt;&lt;/ul&gt;</td>
</tr>
<tr>
<td><strong>Ordered list (numbered list)</strong></td>
<td># Ordered list item</td>
<td>&lt;ol&gt;&lt;li&gt;numbered list item&lt;/li&gt;&lt;/ol&gt;</td>
</tr>
<tr>
<td><strong>Task Lists</strong></td>
<td>[] Task list item</td>
<td><code>&lt;ac:task-list&gt;</code>&lt;br /&gt;<code>&lt;ac:task&gt;</code>&lt;br /&gt;<code>&lt;ac:task-status&gt;incomplete&lt;/ac:task-status&gt;</code>&lt;br /&gt;<code>&lt;ac:task-body&gt;task list item&lt;/ac:task-body&gt;</code>&lt;br /&gt;<code>&lt;/ac:task&gt;</code>&lt;br /&gt;<code>&lt;/ac:task-list&gt;</code></td>
</tr>
</tbody>
</table>

### Links

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Link to another Confluence page</strong></td>
<td>![Link to another Confluence page</td>
<td>Page Title]</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>-----------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Link to an attachment</strong></td>
<td>![Link to an attachment^atlassian_logo.gif]</td>
<td>![ac:link&gt; &lt;ri:attachment ri:filename=&quot;atlassian_logo.gif&quot; &gt; &lt;![CDATA[Link to a Confluence Attachment]]&gt; &lt;/ac:plain-text-link-body&gt; &lt;/ac:link&gt;</td>
</tr>
<tr>
<td><strong>Link to an external site</strong></td>
<td>![Atlassian</td>
<td><a href="http://www.atlassian.com/">http://www.atlassian.com/</a>]</td>
</tr>
<tr>
<td><strong>Anchor link (same page)</strong></td>
<td>![Anchor Link</td>
<td>#anchor]</td>
</tr>
<tr>
<td><strong>Anchor link (another page)</strong></td>
<td>![Anchor Link</td>
<td>pagetitle#anchor]</td>
</tr>
<tr>
<td><strong>Link with an embedded image for the body</strong></td>
<td>![Image</td>
<td>pagetitle#anchor]</td>
</tr>
</tbody>
</table>

**For rich content like images, you need...**

---

**A note about link bodies**

For more information, please refer to the [Confluence documentation](http://confluence.atlassian.com).
All links received from the editor will be stored as plain text by default, unless they are detected to contain the limited set of mark up that we allow in link bodies. Here are some examples of markup we support in link bodies.

### An example of different link bodies

```xml
<ac:link>
   <!-- Any resource identifier -->
   <ri:page ri:content-title="Home" ri:space-key="SANDBOX" />
   <ac:link-body>Some <strong>Rich</strong> Text</ac:link-body>
</ac:link>

<ac:link>
   <ri:page ri:content-title="Plugin developer tutorial stuff"
   ri:space-key="TECHWRITING" />
   <ac:plain-text-link-body><![CDATA[A plain <text> link body]]></ac:plain-text-link-body>
</ac:link>

<ac:link>
   <ri:page ri:content-title="Plugin developer tutorial stuff"
   ri:space-key="TECHWRITING" />
   <!-- A link body isn't necessary. Auto-generated from the resource identifier for display. -->
</ac:link>
```

The markup tags permitted within the `<ac:link-body>` are `<b>`, `<strong>`, `<em>`, `<i>`, `<code>`, `<tt>`, `<sub>`, `<sup>`, `<br>` and `<span>`.

### Images

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attached image</td>
<td><img src="atlassian_logo.gif" alt="atlassian_logo.gif" /></td>
<td><img src="atlassian_logo.png" alt="atlassian_logo.png" /></td>
</tr>
</tbody>
</table>

Supported image attributes (some of these attributes mirror the equivalent HTML 4 IMG element):

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ac:align</td>
<td>image alignment</td>
</tr>
<tr>
<td>ac:border</td>
<td>Set to &quot;true&quot; to set a border</td>
</tr>
<tr>
<td>ac:class</td>
<td>css class attribute.</td>
</tr>
<tr>
<td>---------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>ac:title</td>
<td>image tool tip.</td>
</tr>
<tr>
<td>ac:style</td>
<td>css style</td>
</tr>
<tr>
<td>ac:thumbnail</td>
<td>Set to &quot;true&quot; to designate this image as a thumbnail.</td>
</tr>
<tr>
<td>ac:alt</td>
<td>alt text</td>
</tr>
<tr>
<td>ac:height</td>
<td>image height</td>
</tr>
<tr>
<td>ac:width</td>
<td>image width</td>
</tr>
<tr>
<td>ac:vspace</td>
<td>the white space on the top and bottom of an image</td>
</tr>
<tr>
<td>ac:hspace</td>
<td>the white space on the left and right of an image</td>
</tr>
</tbody>
</table>

**Tables**

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| Two column, two row (top header row) | Table Heading Cell 1 | Table Heading Cell 2 | <table>
|                               | Normal Cell 1 | Normal Cell 2 | <tbody>
|                               |                 |                 | <tr>
|                               |                 |                 | <th>Table Heading Cell 1</th>
|                               |                 |                 | <th>Table Heading Cell 2</th>
|                               |                 |                 | </tr>
|                               |                 |                 | <tr>
|                               |                 |                 | <td>Normal Cell 1</td>
|                               |                 | Normal Cell 2 | <td>Normal Cell 2</td>
|                               |                 |                 | </tr>
|                               |                 |                 | </tbody>
|                               |                 |                 | </table>


Page layouts

Confluence supports page layouts directly, as an alternative to macro-based layouts (using, for example, the section and column macros). This section documents the storage format XML created when these layouts are used in a page.

Notes:

- Page layouts were originally introduced in Confluence 4.2, and are not available in earlier versions of Confluence. If you are using Confluence 4.2 - 5.1 you should refer to the documentation for your version of Confluence:
  - Confluence Storage Format (Confluence 4.2)
  - Confluence Storage Format (Confluence 4.3)
  - Confluence Storage Format (Confluence 5.0)
  - Confluence Storage Format (Confluence 5.1)
- Pages with a layout created in the old format will be converted to 5.2 format.
- Confluence 5.2 provides more flexible layouts with a more concise storage format.

<table>
<thead>
<tr>
<th>Element name</th>
<th>In Confluence 5.2 and later</th>
<th>Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>ac:layout</td>
<td>Indicates that the page has a layout. It should be the top level element in the page.</td>
<td>None</td>
</tr>
<tr>
<td>ac:layout-section</td>
<td>Represents a <em>row</em> in the layout. It must be directly within the ac:layout tag. The type of the section indicates the appropriate number of cells and their relative widths.</td>
<td>ac:type</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td>ac:layout-cell</td>
<td>Represents a <em>column</em> in a layout. It must be directly within the ac:layout-section tag. There should be an appropriate number of cells within the layout-section to match the ac:type.</td>
<td>None</td>
</tr>
</tbody>
</table>

The recognized values of **ac:type** for ac:layout-section are:

<table>
<thead>
<tr>
<th>ac:type</th>
<th>Expected number of cells</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>single</td>
<td>1</td>
<td>One cell occupies the entire section.</td>
</tr>
<tr>
<td>two_equal</td>
<td>2</td>
<td>Two cells of equal width.</td>
</tr>
<tr>
<td>two_left_sidebar</td>
<td>2</td>
<td>A narrow (~30%) cell followed by a wide cell.</td>
</tr>
<tr>
<td>two_right_sidebar</td>
<td>2</td>
<td>A wide cell followed by a narrow (~30%) cell.</td>
</tr>
<tr>
<td>three_equal</td>
<td>3</td>
<td>Three cells of equal width.</td>
</tr>
<tr>
<td>three_with_sidebars</td>
<td>3</td>
<td>A narrow (~20%) cell at each end with a wide cell in the middle.</td>
</tr>
</tbody>
</table>

The following example shows one of the more complicated layouts from the old format built in the new. The word `{content}` indicates where further XHTML or Confluence storage format block content would be entered, such as `<p>` or `<table>` tags.

```
<ac:layout>
  <ac:layout-section ac:type="single">
    <ac:layout-cell>
      {content}
    </ac:layout-cell>
  </ac:layout-section>
  <ac:layout-section ac:type="three_with_sidebars">
    <ac:layout-cell>
      {content}
    </ac:layout-cell>
    <ac:layout-cell>
      {content}
    </ac:layout-cell>
    <ac:layout-cell>
      {content}
    </ac:layout-cell>
  </ac:layout-section>
  <ac:layout-section ac:type="single">
    <ac:layout-cell>
      {content}
    </ac:layout-cell>
  </ac:layout-section>
</ac:layout>
```

**Emoticons**
<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Emoticons</td>
<td>:)</td>
<td><code>&lt;ac:emoticon ac:name=&quot;smile&quot; /&gt;</code></td>
<td>😊</td>
</tr>
<tr>
<td></td>
<td>:(</td>
<td><code>&lt;ac:emoticon ac:name=&quot;sad&quot; /&gt;</code></td>
<td>😞</td>
</tr>
<tr>
<td></td>
<td>:P</td>
<td><code>&lt;ac:emoticon ac:name=&quot;cheeky&quot; /&gt;</code></td>
<td>😄</td>
</tr>
<tr>
<td></td>
<td>:D</td>
<td><code>&lt;ac:emoticon ac:name=&quot;laugh&quot; /&gt;</code></td>
<td>😄</td>
</tr>
<tr>
<td></td>
<td>:)</td>
<td><code>&lt;ac:emoticon ac:name=&quot;wink&quot; /&gt;</code></td>
<td>😄</td>
</tr>
<tr>
<td></td>
<td>(y)</td>
<td><code>&lt;ac:emoticon ac:name=&quot;thumbs-up&quot; /&gt;</code></td>
<td>👍</td>
</tr>
<tr>
<td></td>
<td>(n)</td>
<td><code>&lt;ac:emoticon ac:name=&quot;thumbs-down&quot; /&gt;</code></td>
<td>👎</td>
</tr>
<tr>
<td></td>
<td>(i)</td>
<td><code>&lt;ac:emoticon ac:name=&quot;information&quot; /&gt;</code></td>
<td>🌐</td>
</tr>
<tr>
<td></td>
<td>(✓)</td>
<td><code>&lt;ac:emoticon ac:name=&quot;tick&quot; /&gt;</code></td>
<td>✔</td>
</tr>
<tr>
<td></td>
<td>(✗)</td>
<td><code>&lt;ac:emoticon ac:name=&quot;cross&quot; /&gt;</code></td>
<td>✗</td>
</tr>
</tbody>
</table>
Resource identifiers

Resource identifiers are used to describe "links" or "references" to resources in the storage format. Examples of resources include pages, blog posts, comments, shortcuts, images and so forth.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Resource identifier format</th>
<th>Notes:</th>
</tr>
</thead>
</table>
| Page      | `<ri:page ri:space-key="FOO" ri:content-title="Test Page"/>` | - `ri:space-key:` *(optional)* denotes the space key. This can be omitted to create a relative reference.  
  - `ri:content-title:` *(required)* denotes the title of the page. |
| Blog Post | `<ri:blog-post ri:space-key="FOO" ri:content-title="First Post" ri:posting-day="2012/01/30" />` | - `ri:space-key:` *(optional)* denotes the space key. This can be omitted to create a relative reference.  
  - `ri:content-title:` *(required)* denotes the title of the page.  
  - `ri:posting-day:` *(required)* denotes the posting day. The format is YYYY/MM/DD. |
<table>
<thead>
<tr>
<th>Attachment</th>
</tr>
</thead>
</table>
| `<ri:attachment ri:filename>`  
  ... resource identifier for the container of the attachment ...  
  `</ri:attachment>` |

**Notes:**
- `ri:filename`: (required) denotes the name of the attachment.
- the body of the `ri:attachment` element should be a resource identifier denoting the container of the attachment. This can be omitted to create a relative attachment reference (similar to `[foo.png]` in wiki markup).

**Examples:**

**Relative Attachment Reference**

```
<ri:attachment ri:filename="happy.gif" />
```

**Absolute Attachment Reference**

```
<ri:attachment ri:filename="happy.gif">
  <ri:page ri:space-key="TST" ri:content-title="Test Page"/>
</ri:attachment>
```

<table>
<thead>
<tr>
<th>URL</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;ri:url ri:value=&quot;http://example.org/sample.gif&quot;/&gt;</code></td>
</tr>
</tbody>
</table>

**Notes:**
- `ri:value`: (required) denotes the actual URL value.

<table>
<thead>
<tr>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;ri:shortcut ri:key=&quot;jira&quot; ri:parameter=&quot;ABC-123&quot;&gt;</code></td>
</tr>
</tbody>
</table>

**Notes:**
- `ri:key`: (required) represents the key of the Confluence shortcut.
- `ri:parameter`: (required) represents the parameter to pass into the Confluence shortcut.
- The example above is equivalent to `[ABC-123@jira]` in wiki markup.

<table>
<thead>
<tr>
<th>User</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;ri:user ri:userkey=&quot;2c9680f7405147ee0140514c26120003&quot;/&gt;</code></td>
</tr>
</tbody>
</table>

**Notes:**
- `ri:userkey`: (required) denotes the unique identifier of the user.
Space

```
<ri:space ri:space-key="TST"/>
```

Notes:

- `ri:space-key`: (required) denotes the key of the space.

Content Entity

```
<ri:content-entity ri:content-id="123"/>
```

Notes:

- `ri:content-id`: (required) denotes the id of the content.

Template variables

This screenshot shows a simple template:

```
Dashboard > Chocolate > Browse Space > Edit Template

Sarah template

This is Sarah's template

A single-line text variable: $MyText

A multi-line text variable: $MyMulti

A selection list: $MyList

End of page.
```

The template contains the following variables:

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Type</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>$MyText</td>
<td>Single-line text</td>
<td></td>
</tr>
<tr>
<td>$MyMulti</td>
<td>Multi-line text</td>
<td>Size: 5 x 100</td>
</tr>
<tr>
<td>$MyList</td>
<td>List</td>
<td>List items: Apples, Pears, Peaches</td>
</tr>
</tbody>
</table>

The XML export produces the following code for the template:
Instructional Text

Instructional text allows you to include information on how to fill out a template for an end-user (the person using creating a page from the template). Instructional text will:

- automatically clear all instructional text as the user types in a specific text block, and
- automatically trigger a @mention prompt for user selection (for 'mention' type instructional text).

Screenshot: Example of instructional text.

- This is an example of instruction text that will get replaced when a user selects the text and begins typing. @mention example. This placeholder will automatically search for a user to mention in the page when the user begins typing.

<ul>
    <li><ac:placeholder>This is an example of instruction text that will get replaced when a user selects the text and begins typing.</ac:placeholder></li>
</ul>

<ac:task-list>
    <ac:task>
        <ac:task-status>incomplete</ac:task-status>
        <ac:task-body><ac:placeholder ac:type="mention">@mention example. This placeholder will automatically search for a user to mention in the page when the user begins typing.</ac:placeholder></ac:task-body>
    </ac:task>
</ac:task-list>
Confluence Wiki Markup

This page describes the wiki markup used on some administration screens in Confluence.

Wiki markup is useful when you want to do one of the following:

- Type wiki markup directly into the editor. Confluence will convert it to the rich text editor format as you type.
- Create links using the Advanced tab of the Links Browser.
- Add custom content to the sidebar, header or footer of a space.
- Insert a block of wiki markup (or markdown) into the Confluence editor. (Choose Insert > Markup.)

**Note: You cannot edit content in wiki markup.** Confluence does not store page content in wiki markup. Although you can enter wiki markup into the editor, Confluence will convert it to the rich text editor format immediately. You will not be able to edit the wiki markup after initial entry.

Can I type wiki markup into the editor?

Yes. You can type wiki markup directly into the editor, and Confluence will convert it as you type. (You cannot edit the wiki markup after conversion.) [See it in action in this video](#).

Can I insert markdown?

Confluence supports inserting content in markdown. This is often used in ReadMe files. See [Markdown syntax guide](#) for some examples of markdown syntax.

**To insert markdown in the editor:**

1. Choose Insert > Markup
2. Select Markdown
3. Type or paste your text - the preview will show you how it will appear on your page
4. Choose Insert.

As with wiki markup, Confluence will convert your markdown to the rich text editor format. You will not be able to edit your content using markdown.

**Headings**

To format a line as a heading, type "hn." at the start of your line, where n can be a number from 1 to 6.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>h1. Biggest heading</td>
<td>Biggest heading</td>
</tr>
<tr>
<td>h3. Big heading</td>
<td>Big heading</td>
</tr>
<tr>
<td>h5. Small heading</td>
<td>Small heading</td>
</tr>
</tbody>
</table>
Lists

Wiki markup allows you to create bulleted or numbered lists, and is flexible enough to allow a combination of the two list types.

If you need to separate the text within lists using line breaks, make sure you do so using a double slash (/\). Empty lines may disrupt the list.

Simple lists

Use the hyphen (-) to create simple lists with square bullets. Make sure there’s a space between the hyphen and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>- some</td>
<td>■ some</td>
</tr>
<tr>
<td>- bullet</td>
<td>■ bullet</td>
</tr>
<tr>
<td>- points</td>
<td>■ points</td>
</tr>
</tbody>
</table>

Bulleted lists

Use the asterisk (*) to create bullets. For each subsequent level, add an extra asterisk. Make sure there is a space between the asterisk and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>* some</td>
<td>■ some</td>
</tr>
<tr>
<td>* bullet</td>
<td>■ bullet</td>
</tr>
<tr>
<td>** indented</td>
<td></td>
</tr>
<tr>
<td>** bullets</td>
<td></td>
</tr>
<tr>
<td>* points</td>
<td>■ points</td>
</tr>
</tbody>
</table>

Numbered lists

Use the hash (#) to create numbered lists. Make sure there is a space between the hash and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
<tbody>
<tr>
<td># a</td>
<td>1. a</td>
</tr>
<tr>
<td># numbered</td>
<td>2. numbered</td>
</tr>
<tr>
<td># list</td>
<td>3. list</td>
</tr>
</tbody>
</table>

A second level of hashes will produce a sub-list, such as the alphabetical sub-list shown below.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
</table>

Created in 2016 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
You can use a third level of hashes to produce a sub-sub-list.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
<tbody>
<tr>
<td># Here's a sentence.</td>
<td></td>
</tr>
<tr>
<td>## This is a sub-list point.</td>
<td></td>
</tr>
<tr>
<td>### Third list level.</td>
<td></td>
</tr>
<tr>
<td>#### Another point at the third level.</td>
<td></td>
</tr>
<tr>
<td>## And a second sub-list point.</td>
<td></td>
</tr>
<tr>
<td># Here's another sentence.</td>
<td></td>
</tr>
<tr>
<td>1. Here's a sentence.</td>
<td></td>
</tr>
<tr>
<td>a. This is a sub-list point.</td>
<td></td>
</tr>
<tr>
<td>i. Third list level.</td>
<td></td>
</tr>
<tr>
<td>ii. Another point at the third level.</td>
<td></td>
</tr>
<tr>
<td>b. And a second sub-list point.</td>
<td></td>
</tr>
<tr>
<td>2. Here's another sentence.</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** In numbered lists as described above, the format of the ‘number’ displayed at each list level may be different, depending upon your browser and the style sheets installed on your Confluence instance. So in some cases, you may see letters (A, B, C, etc; or a, b, c, etc) or Roman numerals (i, ii, iii, etc) at different list levels.

**Mixed lists**

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
<tbody>
<tr>
<td># Here</td>
<td></td>
</tr>
<tr>
<td>* is</td>
<td></td>
</tr>
<tr>
<td>* an</td>
<td></td>
</tr>
<tr>
<td># example</td>
<td></td>
</tr>
<tr>
<td>* of</td>
<td></td>
</tr>
<tr>
<td>* a</td>
<td></td>
</tr>
<tr>
<td># mixed</td>
<td></td>
</tr>
<tr>
<td># list</td>
<td></td>
</tr>
<tr>
<td>1. Here</td>
<td></td>
</tr>
<tr>
<td>• is</td>
<td></td>
</tr>
<tr>
<td>• an</td>
<td></td>
</tr>
<tr>
<td>2. example</td>
<td></td>
</tr>
<tr>
<td>• of</td>
<td></td>
</tr>
<tr>
<td>• a</td>
<td></td>
</tr>
<tr>
<td>3. mixed</td>
<td></td>
</tr>
<tr>
<td>4. list</td>
<td></td>
</tr>
</tbody>
</table>

**Tables**

You can create two types of tables.

**Table Type 1**

Allows you to create a simple table with an optional header row. Once you’ve added this type of table, you can set the width of the columns using the table controls in the toolbar.

Use double bars for a table heading row.

**What you need to type:**
<table>
<thead>
<tr>
<th></th>
<th>heading 1</th>
<th>heading 2</th>
<th>heading 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>cell A1</td>
<td>cell A2</td>
<td>cell A3</td>
<td></td>
</tr>
<tr>
<td>cell B1</td>
<td>cell B2</td>
<td>cell B3</td>
<td></td>
</tr>
</tbody>
</table>

What you'll get:

You can also use a vertical header.

What you need to type:

<table>
<thead>
<tr>
<th></th>
<th>heading 1</th>
<th>col A1</th>
<th>col A2</th>
<th>col A3</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>heading 2</td>
<td>col B1</td>
<td>col B2</td>
<td>col B3</td>
</tr>
</tbody>
</table>

What you'll get:

Table Type 2

This method uses section and column macros to create the table, and allows you to specify the width of the columns in the markup.

What you need to type

```
{section:border=true}
{column:width=30%}
Text for this column goes here. This is the smaller column with a width of only 30%.
{column}
{column:width=70%}
Text for this column goes here. This is the larger column with a width of 70%.
{column}
{section}
```

What you'll get

Text for this column goes here. This is the smaller column with a width of only 30%.
Text for this column goes here. This is the larger column with a width of 70%.

For more details please see the Column Macro and the Section Macro.
To add color and other formatting to your tables, you can use the Panel Macro within columns. More table-formatting options may be available if your Confluence administrator has installed additional macros.

Lists

Here’s an example of how to embed lists in a table:

**What you need to type**

<table>
<thead>
<tr>
<th>Heading 1</th>
<th>Heading 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>* Item 1</td>
<td></td>
</tr>
<tr>
<td>* Item 2</td>
<td></td>
</tr>
<tr>
<td>* Item 3</td>
<td># Item 1</td>
</tr>
<tr>
<td># Item 2</td>
<td></td>
</tr>
<tr>
<td># Item 3</td>
<td></td>
</tr>
</tbody>
</table>

**What you’ll get**

<table>
<thead>
<tr>
<th>Heading 1</th>
<th>Heading 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item 1</td>
<td>1. Item 1</td>
</tr>
<tr>
<td>Item 2</td>
<td>2. Item 2</td>
</tr>
<tr>
<td>Item 3</td>
<td>3. Item 3</td>
</tr>
</tbody>
</table>

Text Effects

Use the markup shown in the examples below to format text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>strong</em></td>
<td>strong</td>
</tr>
<tr>
<td><em>bold text</em></td>
<td>bold text</td>
</tr>
<tr>
<td><em>emphasis</em></td>
<td>emphasis</td>
</tr>
<tr>
<td><em>italics</em></td>
<td>italics</td>
</tr>
<tr>
<td>Thing{<em>}x</em></td>
<td>gives you this: Thingx</td>
</tr>
<tr>
<td>??citation??</td>
<td>——citation</td>
</tr>
<tr>
<td>-deleted-</td>
<td>deleted</td>
</tr>
<tr>
<td>+inserted+</td>
<td>inserted</td>
</tr>
<tr>
<td>Text with superscript</td>
<td>Text with superscript</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------</td>
</tr>
<tr>
<td>Hint: There are two ways to make superscripts work, when used directly after another word or character:</td>
<td></td>
</tr>
<tr>
<td>- Add a space before the superscript. For example, kg/m (^3) gives you this: kg/m (^3)</td>
<td></td>
</tr>
<tr>
<td>- Add braces (curly brackets) around the superscript markup. For example, kg/m(^{,3})</td>
<td></td>
</tr>
<tr>
<td>gives you this: kg/m(^3)</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Text with subscript</th>
<th>Text with subscript</th>
</tr>
</thead>
<tbody>
<tr>
<td>{{monospaced}}</td>
<td>monospaced</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>bq. Here's how you make a paragraph appear as a block quotation.</th>
<th>Here’s how you make a paragraph appear as a block quotation.</th>
</tr>
</thead>
</table>

| {color:red}look ma, red text!{color} | look ma, red text! |

### Text Breaks

#### Paragraph Break

In wiki markup, a paragraph is a continuous line of text ending in two carriage returns. This is equivalent to a continuous line of text followed by a blank line.

When rendered into HTML, the result is a line of text wrapped in a set of \(<p>\)/\(<p>\) tags.

#### Line Break

Confluence provides two options for forcing a line break within a paragraph of text:

- Implicitly, by entering a single carriage return at its end.
- Explicitly, by entering two consecutive backslashes: `\`

When rendered into HTML, the result is a paragraph of text that is split into separate lines by \(<br>\) tags, wherever a forced line break appears.

ℹ️ For most purposes, explicit line breaks are not required because a single carriage return is enough.

The examples below show how to use explicit line breaks.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you'll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>here is some text \n \n divided \n using line \n breaks\n</td>
<td>here is some text divided using line breaks</td>
</tr>
</tbody>
</table>

---

Created in 2016 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
This is a short list:
* Point 1
  Text to go with point 1
* Point 2
  Text to go with point 2 with a break

This is a short list:
- Point 1
- Text to go with point 1
- Point 2
  Text to go with point 2 with a break

If you wish to use multiple consecutive line breaks, each should be separated by a space character. For example, use this for two consecutive line breaks:

Horizontal Rule

To create a horizontal line across the width of your page or content block, type four dashes (like this: ----) at the beginning of a line, then press Enter or space.

Make sure that the dashes are on a separate line from the rest of the text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>here is some text</td>
<td>here is some text</td>
</tr>
<tr>
<td></td>
<td>divided by a horizontal rule</td>
</tr>
</tbody>
</table>

Links

You can use wiki markup to add hyperlinks to your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>[#anchor]</td>
<td>A link to an anchor on the same page.</td>
</tr>
<tr>
<td>[Confluence Wiki Markup^attachment.ext]</td>
<td>A link to a file attached to the page.</td>
</tr>
<tr>
<td>[pagetitle]</td>
<td>A link to a page.</td>
</tr>
<tr>
<td>[pagetitle#anchor]</td>
<td>A link to an anchor on another page.</td>
</tr>
<tr>
<td>[pagetitle^attachment.ext]</td>
<td>A link to a file attached to another page.</td>
</tr>
<tr>
<td>[spacekey:pagetitle]</td>
<td>A link to a page in another space.</td>
</tr>
<tr>
<td>[spacekey:pagetitle#anchor]</td>
<td>A link to an anchor on a page in another space.</td>
</tr>
<tr>
<td>[spacekey:pagetitle^attachment.ext]</td>
<td>A link to a file attached to a page in another space.</td>
</tr>
<tr>
<td>[/2004/01/12/blogposttitle]</td>
<td>A link to a blog post. Note: blogposttitle is the title of the blog as it appears on the page.</td>
</tr>
<tr>
<td>[spacekey:/2004/01/12/blogposttitle]</td>
<td>A link to a blog post in another space. Note: blogposttitle is the title of the blog as it appears on the page.</td>
</tr>
<tr>
<td>[/2004/01/12]</td>
<td>A link to a whole day's blog posts.</td>
</tr>
<tr>
<td>[spacekey:/2004/01/12]</td>
<td>A link to a whole day's blog posts in another space.</td>
</tr>
<tr>
<td>Link Type</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>[spacekey:]</td>
<td>A link to the space homepage (or the space summary page of the space).</td>
</tr>
<tr>
<td>[~username]</td>
<td>A link to the user profile page of a particular user.</td>
</tr>
<tr>
<td>[phrase@shortcut]</td>
<td>A shortcut link to the specified shortcut site. Shortcuts are configured by the site administrator.</td>
</tr>
<tr>
<td>[<a href="mailto:legendaryservice@atlassian.com">mailto:legendaryservice@atlassian.com</a>]</td>
<td>A link to an email address.</td>
</tr>
<tr>
<td>[file://z:/file/on/network/share.txt]</td>
<td>A link to a file on your computer or on a network share that you have mapped to a drive. <em>This only works on Internet Explorer.</em></td>
</tr>
<tr>
<td><img src="http://external/link.html" alt="http://external/image.png" /></td>
<td>Displays an external image and links to an external URL.</td>
</tr>
</tbody>
</table>

Note that Confluence treats headings as anchors, so you can link to headings using this pattern: [spacekey:pagename#headingname], where headingname is case-sensitive and must be entered without spaces.

For each of these link forms:
- You can prepend a link alias, so that alternate text is displayed on the page. Example: [link alias|pagetitle#anchor]
- You can append a link tip, which appears as a tooltip. Example: [pagetitle#anchor|link tip]

**Images**

You can display images from attached files or remote sources.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>![<a href="http://www.host.com/image.gif">http://www.host.com/image.gif</a>]</td>
<td>An image from a remote source is displayed on the page. Uses a fully qualified URL.</td>
</tr>
<tr>
<td>![attached-image.gif]</td>
<td>An image file attached to the page is displayed.</td>
</tr>
<tr>
<td>![pageTitle^image.gif]</td>
<td>An image file attached to a different page is displayed.</td>
</tr>
<tr>
<td>![spaceKey:pageTitle^image.gif]</td>
<td>An image file attached to a page in a different space is displayed.</td>
</tr>
<tr>
<td>![/2010/05/23/My Blog Post^image.gif]</td>
<td>An image file attached to a blog post is displayed.</td>
</tr>
<tr>
<td>![image.jpg</td>
<td>thumbnail]</td>
</tr>
<tr>
<td>![image.gif</td>
<td>align=right, vspace=4]</td>
</tr>
</tbody>
</table>

Available HTML image tags include:

<table>
<thead>
<tr>
<th>Image tag</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>align</td>
<td>Available values are 'left', 'right', 'bottom', 'center', 'top'.</td>
</tr>
<tr>
<td>border</td>
<td>Specifies the width of the border (in pixels).</td>
</tr>
</tbody>
</table>
Page Layouts

There is no wiki markup representation for page layouts.

Macros

Storage format and wiki markup examples have been included in the documentation for each macro.

Files

Share your team’s PDFs, Office documents, images, and more in one place by uploading your files to Confluence. Automatic versioning, instant previews, permissions, and full-text search, means shared network drives can be a thing of the past for your team.

When you upload a file it is attached to the current page or blog post. This is why files are often referred to as attachments in Confluence.

You can attach anything from project plans and design mockups to video and audio files. You and your colleagues can also collaborate by commenting on files displayed on Confluence pages.

Using Files

- Upload Files
- Display Files and Images
- Manage Files
- Share and Comment on Files
- Edit Office Files

Permissions

The ‘Add Attachment’ and ‘Delete Attachment’ permissions are used to control who can upload and delete attachments in a space.

Users with ‘Add Page’ or ‘Add Blog’ permissions can insert existing attachments to their pages, but not upload new attachments unless they also have the ‘Add Attachment’ permission.

There is no permission that controls downloading attachments. See our knowledge base article about disabling the download of attachments if you need to do this.

Upload Files

When you upload a file, such as an image or document, it will be attached to the current page.
You can then choose to display the file on the page as a link, an image or embed it in the page (using a macro).

To upload a file you'll need the ‘Add Attachments’ space permission.

Upload a file

There are many ways to attach a file to a page. In the editor you can:

- Drag the file directly onto the page.
- Go to Insert > Files and images and upload a file.

When viewing a page you can:

- Drag the file directly onto the page.
- Go to > Attachments and upload a file.

You can attach multiple files at a time.

Accepted file types and size

Confluence allows you to attach most file types, but you cannot attach a folder of files (including folders created by applications like Keynote - you'll need to export your presentation to zip or other format).

Although just about any file type can be attached to a page, not all file types can be displayed on or embedded in a page. See Display Files and Images to find out more.
The maximum file size you can upload to Confluence is set by your system administrator. By default it is 10mb, but your administrator may have increased or reduced this limit.

File versions

If you upload a file with the same name as an existing attachment on the same page, Confluence will overwrite the existing attachment. Version history is kept for all attachments. See Manage Files to find out more.

Any changes you make to the source file will not affect the copy that was uploaded to Confluence. To update the Confluence copy, you need to upload the new version of the file.

Notes

⚠️ We recommend you don't use special characters in page or attachment names, as the page or attachment may not be found by Confluence search, and may cause some Confluence functions to behave unexpectedly.

Display Files and Images

Files can be displayed on a page as a thumbnail or as a link. There are a few different ways to Upload Files.

You can control how the file appears on your page. The options available depend on the type of file.
Insert a file into your page

There's a few ways to insert a file into your page:

- Go to **Insert > Files** on the editor toolbar and select any of the previously uploaded files, or
- Drag the file directly into the editor (this will upload and insert the file in one step), or
- Type ! and choose an attached file from the autocomplete drop down.

Your file will appear on your page as a thumbnail. Click the thumbnail to resize it or to switch to showing the file as a link.

![BlueSkyPresentation0DT.odp](BlueSkyPresentation0DT.odp)

Insert a file attached to another page

You can display a file that's attached to a different page of the same Confluence site, if you know the name of the file.

**To display an image attached to a different page:**

1. Go to **Insert > Files** and choose the **Search on other pages**.
2. Enter the name of the file.
3. Choose whether to search the current space or **All Spaces** and choose **Search**.
4. Select the file from the search results and choose **Insert**.

Insert an image file from the web

You can display an image from a remote web page on your Confluence page, without needing to attach it to your page. You need to know the URL for the image, not for the web page it appears on. This is only available for image files, not other types of files (like documents).

**To display an image from a web page:**

1. While editing the page, position the cursor where you want to place the image.
2. Choose **Insert > Files** and choose **Images from the web**.
4. Choose **Preview** to check that the URL and image are correct.
5. Choose **Insert**.

Delete files from your page

If you delete a file or image in the editor, the attached file will not be deleted. Go to *** > **Attachments** to delete the attachment completely from the page.

Seeing an 'unknown attachment' placeholder on your page? This means that the attached file has been deleted from the page (or another page).
Preview a file

Click an image, file thumbnail or link when viewing a page to launch the preview.

The preview includes images from the web that are displayed on the page and files that are attached to the page (even if they are not currently displayed on the page).

In the preview you can:

- Download the image file.
- Upload a new version of the file (attached files only).
- Comment on the file.
- Zoom in, out or fit the image to the width of your browser.
- Browse like a slideshow using the next and back buttons.
- See other files attached to the page and select a thumbnail to preview that file.
- Switch to a full screen presentation mode.

Many file types can be previewed, including Office files, PDFs and many image types.

Which files can be previewed?

<table>
<thead>
<tr>
<th>Images files</th>
<th>Office files</th>
<th>Other files</th>
</tr>
</thead>
<tbody>
<tr>
<td>JPEG</td>
<td>DOC</td>
<td>PDF</td>
</tr>
<tr>
<td>PNG</td>
<td>DOCX</td>
<td>MP3</td>
</tr>
<tr>
<td>TIFF</td>
<td>PPT</td>
<td></td>
</tr>
<tr>
<td>PSD</td>
<td>PPTX</td>
<td>MP4</td>
</tr>
<tr>
<td>WMF</td>
<td>XLS</td>
<td></td>
</tr>
<tr>
<td>EMF</td>
<td>XLSX</td>
<td></td>
</tr>
<tr>
<td>ICO</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ICNS</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Office and PDF files

Inserting a file in a page is a great way to make useful documents, spreadsheets, presentations and other files available to your team.

As with all file types, you can choose to insert the file as a link, or as a thumbnail. The thumbnail shows a preview of the document's contents, and can be resized.

To view an Office or PDF file, click the link or thumbnail to see the full preview (no need to have Excel, Word or PowerPoint installed). Alternatively, use the Download button in the preview to download the file and view...
offline.
You can even comment on Office and PDF files.

Image files

When editing the page, select an image to show the image properties panel. The panel allows you to set the display size, add a border and effects and link the image to other pages.

From the image properties panel you can:

- Choose a **preset size** for the image
- Enter a **width** for the image (between 16px and 900px)
- Add a **border** around the image
- **Link** the image to a page or URL
- **Align** the image (you can use the left and right align buttons to make the text wrap around the image too)
- Add a title, which is shown when you hover over the image (go to **Properties** > **Title**)
- Add alt text, which is used by screen readers and when the image can't be shown (go to **Properties** > **Title**)
- Add **effects** to the image such as drop shadow or snapshot (go to **Properties** > **Effects**).

To add a caption to an image using the Instant Camera effect:

- Choose **Effects** in the image properties panel and choose the Instant Camera image effect.
- Save the page.
- Go to *** > **Attachments** to go to the 'Attachments' view of the page.
- Choose **Properties** next to the image file.
- Add a **comment** to the attachment. The text in your comment will appear as the image caption.

You will need to re-enter the comment each time you upload a new version of the image.

Note: The Instant Camera effect only works with Latin character languages, due to a lack of handwriting style fonts in multi-byte languages.

**Note about image effects**

Displaying image effects can be resource intensive. Confluence limits the threads that are dedicated to displaying image effects so that it does not impact your whole instance. If a thread is not available, Confluence will display the image without the effect.

The following knowledge base article provides information if you need to adjust the number of threads - Image effects are not displayed in Confluence 5.5 or later.

Multimedia files

The file preview also supports MP3 audio and MP4 video files. It uses HTML5 to play attached audio and video files. This means the file types people can play in the preview depends on the audio and video formats their browser supports.
You can also display a wider range of multimedia files (video, audio and animation) using the Multimedia Macro.

Display online video (such as YouTube or Vimeo videos) using the Widget Connector Macro.

Show a list of files on a page

There are several ways you can display a list of files on a page. You can:

- Use the Attachments Macro to show files attached to the current page.
- Use the Space Attachments Macro to show all files in a space.
- Use the Gallery Macro to show thumbnails of images attached to a page.

You can also use the File List blueprint for uploading, viewing and managing lists of files.

Manage Files

Files are attached to Confluence pages. See Upload Files to find out about attaching files to pages.

Once attached you can download, delete and edit these files, for example if you need to upload a new version of the file, or change the page it is attached to.

Download attached files

Any user with permission to view a page can also download any files attached to that page.

To download an individual file:

- Click the Download button in the file preview, or
- Go to
  ***
  > Attachments
- and then right click on the file name and save the link.

To download all files attached to a page as a zip file:

1. Go to
   ***
   > Attachments
2. Click Download All.

There's no option to download all attachments in a space.

Delete an attached file

You'll need the 'Delete Attachment' space permission to delete an attached file.

To delete all versions of an attached file:

1. Go to the page that contains the attachment.
2. Go to
   ***
   > Attachments
3. Choose Delete next to the attachment you want to delete.
4. Choose Delete to confirm your action.

Deleted files can be restored from the trash. You'll need to be a space admin to do this.
Space Admins can also delete a specific versions of an attachment:

1. Go to
   ***
   > Attachments
2. Click the expand arrow next to the attachment name to see the list of attachment versions
3. Choose **Delete** next to the version you want to delete.

Deleted file versions are not recoverable from the trash.

*Screenshot: Attachments and attachment versions*

### Attachments

<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Creator</th>
<th>Creation Date</th>
<th>Labels</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>penguin.png</td>
<td>5 KB</td>
<td>Rach Admin</td>
<td>Feb 15, 2013 15:33</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Version 2</td>
<td>5 KB</td>
<td>Rach Admin</td>
<td>Feb 15, 2013 15:33</td>
<td>Updated</td>
<td></td>
</tr>
<tr>
<td>Version 1</td>
<td>5 KB</td>
<td>Josh User</td>
<td>Feb 14, 2013 10:58</td>
<td></td>
<td></td>
</tr>
<tr>
<td>bugs.gif</td>
<td>22 KB</td>
<td>Josh User</td>
<td>Feb 15, 2013 14:51</td>
<td></td>
<td></td>
</tr>
<tr>
<td>site logo.png</td>
<td>2 KB</td>
<td>Josh User</td>
<td>Feb 15, 2013 14:51</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Upload a new version of an attached file

There are two ways up upload a new version of an attached file. You can:

- Upload a file with the same file name to the page.
- Use the **Upload a new version**
  ![Upload button]
  button in the file preview to upload a file with a different name (for images and PDFs only).

To view attachment versions:

- Go to
  ***
  > Attachments
- Click the expand arrow next to the attachment name.

All earlier versions of the file will appear.

You can't revert to an earlier version of the file, but you can choose to remove earlier versions if you have Space Administrator permissions.

### Move a file to another page

You'll need the 'Add Page', 'Add Attachment' and 'Remove Attachment' space permissions to move an attached file to another page.

To change the page that a file is attached to:

- Go to
  ***
  > Attachments
- Choose **Properties** next to the attachment you want to move.
- Enter the name of the page you want to move the attachment to (for example My Destination Page).
- Choose **Save**.

If you want to move the file to a page in another space, add the space key before the page name (for example DOC:My Destination Page).
Edit properties of an attached file

You'll need the 'Add Attachment' permission in the space to edit the file properties.

To edit the properties of an attached file:

- Go to
- > Attachments
- Click Properties beside the attachment you want to edit.

You can:

- change the file name
- add a comment (used in the version list and also by the Snapshot image effect)
- change the MIME type
- move the attachment to another page
- add a label.

Changing the MIME type may cause your file to display incorrectly.

View all attached files in a space

There are two ways you can view all files in a space. You can:

- Use the Space Attachments macro to display the list of files on a page.
- Go to the space and choose Space tools > Content Tools from the bottom of the sidebar Then choose Attachments.
  If your space uses the Documentation theme go to Browse > Space Operations > Attachments.

You can use the filters to only show files with a particular label or file extension.

Screenshot: Space attachments macro

Share and Comment on Files

Collaboration doesn't just happen on pages; often you'll need to collaborate with your team on documents, presentations, images and spreadsheets. Whether it's mockups for a new marketing campaign or a full project plan, you can simplify your team's feedback loop by working together on files in Confluence.

Share a file

Do you have lots of files on a page and want to get a team member's input on just one of them? You can share the file with them directly.
It works just like sharing a page:
1. Click the thumbnail or link to preview the file
2. Choose the **Share** button
3. Enter an email address, user name or group name, add your message and send

Your team members will get an email with your message and a link to view the file.

Comment on a file

Whether it's an image – like a mockup of the new marketing campaign that needs feedback – a PDF, a presentation, or any other file you can preview in Confluence, you can drop a pin anywhere on the preview and add your comment to start a conversation.

To comment on a file:
1. Click the thumbnail or link to preview the file
2. Drag the pin icon from the bottom of the preview and drop it where you want to comment
3. Add your comment and **Save**

Pinned comments work just like inline comments on pages. You can use [@mentions](#), links, and macros, and drop as many pins as you need on any part of the file. Anyone with permission to add comments to the page can add and reply to comments on a file.

When you preview a file, you'll see pins for any existing comments. Select a pin to view the comment.

Once the conversation is finished, you can resolve the comment to hide it (and any replies) from view. If you need to see resolved comments again, you can reopen them. Go to...

> **Resolved comments** in the preview.
Edit a file

Need to go beyond commenting on files? You can even edit some files right from the Confluence page. See Edit Office Files to find out about supported file types and applications.

Edit Office Files

The Office Connector allows you to edit attached office files in their native application (such as Word, Excel, PowerPoint or OpenOffice) and save the file right back to the Confluence page. No need to download and re-upload the file.

⚠️ The Office Connector is only available for some browsers, operating systems and applications, check the Office Connector Prerequisites before you start for the combination that will work best for you.

Edit an attached document

To edit an Office document attached to a Confluence page:

1. Go to
   ⚠️ Attachments
2. Choose **Edit in Office** beside the attachment you want edit.
   Your browser will ask you to confirm that you want to open the file.
3. Choose **OK**.
   You may also see a security warning or be asked to log in to your Confluence server - enter your
   Confluence username and password, then choose **OK**.
4. The file will open in your Office application - make your changes then save the document. It will be
   saved back to Confluence

**Screenshot: Edit in Office option on the attachments page**

Other ways to edit

Edit options also appear in the:

- **Attachments macro** (choose **Edit in Office** beside each attached office file)
- File preview (choose

  > **Edit in Office**

Troubleshooting

Check out the **Office Connector Prerequisites** for the combinations of browsers, operating systems and office
applications that are supported. Here's some common issues:

- **Using Chrome?** You can't edit Office documents as Chrome does not support WebDAV clients. See
  **CONF-23322**
- **Using Firefox?** You'll need to install the WebDAV add-on. See **Installing the Firefox Add-On for the**
  **Office Connector**.
- **Using Internet Explorer?** You can only edit documents in Microsoft Office. OpenOffice is not
  supported.
- **Using Linux?** You can only edit documents in OpenOffice. Microsoft Office is not supported. See
  **CONF-17250**
- **Using Mac OS X?** You can't currently edit documents. See
  **CONF-25594**
- **Not seeing the Office Connector options?** Your system administrator may have disabled all or part
  of the Office Connector.
  See **Configuring the Office Connector**.

You can find more troubleshooting info in the **Office Connector Limitations and Known Issues** knowledge
base article.

**Office Connector Prerequisites**

The Office Connector allows you to **import**, and **edit**
office documents (such as Word, Excel and PowerPoint) within Confluence.

The browser, operating system and applications required depend on what you are trying to do with an office file.

Viewing Office files

You can upload, insert and preview Office files in the same way as any other file. You don't need to have an Office application installed on your computer in order to view Office files in Confluence.

Importing Word documents as pages

Confluence can import the content from Microsoft Word 97-2013 documents (.doc and .docx).

Editing Office files attached to a page

The Office Connector allows you to edit Office files that are attached to pages.

You'll need to use a browser, operating system and application (either Microsoft Office or OpenOffice) as described in the compatibility matrix below.

Here's a few common issues:

- **Using Chrome?** You can't edit Office documents as Chrome does not support WebDAV clients. See CONF-23322.

- **Using Firefox?** You'll need to install the WebDAV add-on. See Installing the Firefox Add-On for the Office Connector.

- **Using Internet Explorer?** You can only edit documents in Microsoft Office. OpenOffice is not supported.

- **Using Linux?** You can only edit documents in OpenOffice. Microsoft Office is not supported. See CONF-17250.

- **Using Mac OS X?** You can't currently edit documents. See CONF-25594.

- **Not seeing the Office Connector options?** Your system administrator may have disabled all or part of the Office Connector. See Configuring the Office Connector.

**Configuration matrix**

You need one of the following software combinations to edit Office files from your Confluence page.

<table>
<thead>
<tr>
<th>Software</th>
<th>Operating System</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Office 2013</td>
<td>• Windows 7</td>
<td>• Internet Explorer 11</td>
</tr>
<tr>
<td></td>
<td>• Windows 8</td>
<td>• Firefox – latest stable version</td>
</tr>
<tr>
<td>Microsoft Office XP, 2003, 2007, 2010</td>
<td>• Windows 7</td>
<td>• Internet Explorer - supported versions</td>
</tr>
<tr>
<td></td>
<td>• Windows Vista</td>
<td>• Firefox – latest stable version</td>
</tr>
<tr>
<td></td>
<td>• Windows XP (Service Pack 2 or 3)</td>
<td></td>
</tr>
</tbody>
</table>
| OpenOffice 2.x – 3.x | Windows 7  
| Windows Vista  
| Windows XP (Service Pack 2 or 3)  
| Linux | Firefox – latest stable version  
| Internet Explorer - supported versions  
(Windows Platforms only) |

Note: The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.

If you experience problems editing documents using the Office Connector (using an application, operating system and browser combination above) please raise an issue and tell us as much as you can about your operating system, application version, document version (if its different to the version of Office / Open Office you're using to open the document) and browser.

Troubleshooting

Having problems with the Office Connector?

- The WebDAV plugin must be enabled, because the Office Connector uses WebDAV to transfer information to and from Office documents. The WebDAV plugin is bundled with Confluence, and can be enabled or disabled by the System Administrator. If necessary, refer to the instructions on enabling plugins and configuring the WebDAV options.
- Ensure that your Confluence server's base URL is set correctly (see Configuring the Server Base URL to find out how to check this). When a user edits a Confluence page in Word and then uploads the page back to the Confluence server, the base URL determines where the document will be saved. If the base URL is incorrect, the documents may be saved to a different Confluence server.
- Using Office 2013? Your administrator will need to enable ‘Allow authentication tokens in the URL path’ in the Office Connector configuration. See Configuring the Office Connector.

See the Office Connector Limitations and Known Issues knowledge base article for more troubleshooting tips.

Install the Firefox Add-On for the Office Connector

If you are using Firefox as your browser, you will need to install an add-on into Firefox (the Firefox WebDAV Launcher) in order to use some features of the Office Connector. You will be prompted to install the add-on the first time you try to use a function which requires it.

⚠️ For more information on the browsers, operation systems and application combinations required to use the Office Connector see Office Connector Prerequisites.

Installing the Firefox Add-On

The first time you try to edit an attached Office document in Firefox you'll be prompted to install a WebDAV add-on for your browser. Without this add-on you can't edit Office documents from Firefox.

1. Choose Edit in Office or Edit Document next to the document you wish to edit. You'll see a prompt to download the add-on.

2. Choose OK. Your browser will ask you to confirm that you want to allow the add-on.
3. Choose **Allow**. An installation dialog like the one below will appear.

4. Choose **Install Now**. Once the installation is complete you'll be prompted to restart Firefox. Make sure you've saved any open pages or other work in your browser before you restart.

5. Next you need to configure the add-on, and tell it which applications to use.

### Configuring the Add-On

After installing the add-on you need to configure it, to tell the add-on which desktop applications to launch for each file type.

Configuring the add-on is slightly different in each operating system.

#### Configuring the add-on in Windows

In most cases the add-on will automatically configure itself, based on information from the system registry. The first time you edit a new file type, the add-on will look up the default editor for that file type and make that the permanent setting.

If you want to override the registry settings, or the automatic configuration is not working, you can configure the Firefox add-on manually.

1. In Firefox locate the **WebDAV Launcher** add-on and choose **Options**. The WebDAV Launcher Options dialog, like the one below, will appear.
2. Enter a file extension in the **File Extension** field. Do not include the leading period in the extension name. For example, to associate the 'doc' file extension with Microsoft Word 2003 you would type `doc` in the **File Extension** field.

Using Office 2007 or later?
You should configure the WebDAV launcher to open both Office 2003 file extensions (doc, ppt and xls) and Office 2007 and later file extensions (docx, xlsx and pptx).

3. Enter the **Application Path** - you can either:
   - Choose **Auto** to load the associated application from the Windows registry, or
   - Choose **Browse** to find the application on your computer, or
   - Manually enter the path to the application's executable file.
4. Choose **Add** to add the file extension association to the list. Repeat this process for all the file extensions you need.

*Configuring the Add-On in Mac OS X*

The configuration procedure is similar to Windows, as shown above. Note that there is no 'Auto' button in Mac OS X.

You can't currently edit documents in Mac OS X. See [CONF-25594](http://example.com/CONF-25594) RESOLVED.

*Configuring the Add-On in Linux*

The only known supported Office editor for Linux is [OpenOffice](http://example.com) (see Office Connector Prerequisites).

There is no automatic configuration on Linux. You will need to associate each file type with your Office editor in Firefox. Note that there is no 'Auto' button in Linux.

The configuration procedure is similar to Windows. For both Ubuntu and OpenSUSE, the configuration will look something like this:

<table>
<thead>
<tr>
<th>File Extension</th>
<th>Application Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>doc and docx</td>
<td>/usr/bin/oowriter</td>
</tr>
<tr>
<td>ppt and pptx</td>
<td>/usr/bin/ooimpress</td>
</tr>
<tr>
<td>xls and xlsx</td>
<td>/usr/bin/oocalc</td>
</tr>
</tbody>
</table>

*Security Risks*

Please be aware that there are security risks in installing this add-on to Firefox. Internet Explorer is exposed to the same risks, because it can directly open Office documents.

Summary of the risks:

- Office documents can contain macro viruses. Before opening an Office document, make sure that you
trust the source of the document.

- There are known flaws in the Office file formats and Microsoft Office that an attacker can exploit to gain control of your machine. Microsoft has fixed the known exploits in the latest Service Packs for all Microsoft Office versions, but new exploits may arise at any time. Be sure that you trust the source of a document before opening it.

The add-on reduces the risk by supporting:

- **Same origin policy** - the add-on can only open documents from the same host that initiated the action.
- **Digital signature** - the add-on is digitally signed. When you install the add-on please verify that it is signed by Atlassian.
- **Prompt the user for confirmation** - You will always be warned before a file is opened. **Please read these warnings carefully before opening a file.** The warning tells you the complete URL of the file as well as the complete application path of the application opening the file.

**Information about this Firefox add-on**

<table>
<thead>
<tr>
<th>Add-on name:</th>
<th>WebDAV Launcher</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description:</td>
<td>Adds the ability to launch a WebDAV URL directly in a WebDAV-aware client.</td>
</tr>
<tr>
<td>Latest version:</td>
<td>See the WebDAV Launcher add-on page at Mozilla</td>
</tr>
<tr>
<td>Compatible with:</td>
<td>All versions of Firefox, up to and including the latest stable version.</td>
</tr>
<tr>
<td>Author:</td>
<td>Atlassian Pty Ltd</td>
</tr>
</tbody>
</table>

**Macros**

Using macros helps you to expand the capabilities of your Confluence pages, allowing you to add extra functionality or include dynamic content. For example, use the Attachments macro to list files attached to a page, or use the Widget Connector macro to include things like a YouTube video or Twitter feed.

**Add a Macro to your Page**

Including Macros with the Macro Browser

**To add a macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Macro Parameters**

Many macros have optional parameters you can use to control the macro's output.

With the Attachments Macro, for instance, you have two optional parameters allowing you to:

- Specify the file formats of the attachments displayed
- Choose whether or not you want old versions of the attachments displayed
Macro Placeholders

Macro placeholders are displayed in the editor where you have added a macro to the page.

When editing a page, you can:

- Double-click a macro placeholder (or click the placeholder and choose Edit) to open the macro dialog window and edit the macro's parameters
- Select a macro placeholder to cut, copy and paste the macro

Confluence macros

Below is a list of the macros currently bundled with Confluence. Click a macro name for details of the usage, including optional parameters and examples.

- Activity Stream Macro
- Anchor Macro
- Attachments Macro
- Blog Posts Macro
- Change-History Macro
- Chart Macro
- Cheese Macro
- Children Display Macro
- Code Block Macro
- Column Macro
- Content by Label Macro
- Content by User Macro
- Content Report Table Macro
- Contributors Macro
- Contributors Summary Macro
- Create from Template Macro
- Create Space Button Macro
- Excerpt Include Macro
- Excerpt Macro
- Expand Macro
- Favorite Pages Macro
- Gadget Macro
- Gallery Macro
- Global Reports Macro
- HTML Include Macro
- HTML Macro
- IM Presence Macro
- Include Page Macro
- Info, Tip, Note, and Warning Macros
- JIRA Chart Macro
- JIRA Issues Macro
- JUnit Report Macro
- Labels List Macro
- Livesearch Macro
- Loremipsum Macro
- Multimedia Macro
- Navigation Map Macro
- Network Macro
- Noformat Macro
- Office Excel Macro
- Office PowerPoint Macro
- Office Word Macro
- Page Index Macro
- Page Properties Macro
- Page Properties Report Macro
- Page Tree Macro
- Page Tree Search Macro
- Panel Macro
Creating your own macros

Users with System Administrator permissions can create user macros - see Writing User Macros.

If you want to create something more complex, you can develop your own plugin - see Writing Confluence Plugins.

Getting more macros from The Marketplace

You can find a wide range of Atlassian and third party macros at The Marketplace. These are distributed as add-ons and can be installed by a Confluence Administrator.

Macro usage statistics

Confluence administrators can check how often each macro is used in your site.

To see how often a macro is used, go to

> General Configuration > Macro Usage. This lists how often each macro is used in current spaces but doesn't include any macros used on pages in archived spaces.

Activity Stream Macro

The Activity Stream macro is a specific instance of the Gadget macro. It inserts an Activity Stream gadget onto your page. For instructions, see Activity Stream Gadget.

Related pages:

- Activity Stream Gadget
- Gadget Macro

Anchor Macro

Allows you to link to a specific part of a page. For more information on using anchors see Anchors.

Code Examples
The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** anchor

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="anchor">
    <ac:parameter ac:name="">here</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```markdown
{anchor:here}
```

**Attachments Macro**

The Attachments macro displays a list of files attached to a page.

It also allows users (with appropriate permissions) to:

- upload a file to the page, directly from the list
- edit attachment properties and labels
- delete an attached file (this deletes all versions of the file)
- preview image attachments
- edit attached Office and PDF documents using the Office Connector.
- download all files attached to the page.

Note: you can use the macro parameters to turn off previews if you have very large attachments.

**Screenshot: The Attachments macro, showing details of an attachment**
Using the Attachments Macro

To add the Attachments macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filename Patterns</td>
<td>all</td>
<td>A comma-separated list of regular expressions, used to filter the attachments by file name. Note that the parameter values must be regular expressions. For example:</td>
</tr>
<tr>
<td>(patterns)</td>
<td></td>
<td>• To match a file suffix of 'jpg', use <code>.*jpg</code> (not <code>*.jpg</code>).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To match file names ending in 'jpg' or 'png', use <code>.*jpg</code>, <code>.*png</code></td>
</tr>
<tr>
<td>Parameter</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Attachment Labels (labels)</td>
<td>(none)</td>
<td>A list of labels, used to filter the attachments to display. If you wish to enter more than one label, separate the labels with commas. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.) For information on labeling the attachments, see Add, Remove and Search for Labels.</td>
</tr>
<tr>
<td>Include Old Attachment Versions (old)</td>
<td>false</td>
<td>A value of true will include previous attachment versions in the list.</td>
</tr>
<tr>
<td>Sort By (sortBy)</td>
<td>date</td>
<td>The sort order for attachments. Note that people viewing the page can change the sort order by clicking the column headings. Valid values are: • date – sorts by updated date in reverse chronological order (newest first) • size – sorts largest to smallest • name – sorts alphabetically • created date - sorts by creation date in reverse chronological order (newest first)</td>
</tr>
<tr>
<td>Sort Order (sortOrder)</td>
<td>ascending</td>
<td>Used in combination with the Sort By parameter, to sort the attachments in ascending or descending order.</td>
</tr>
<tr>
<td>Allow Upload (upload)</td>
<td>true</td>
<td>If selected, the list of attachments will include options allowing users to browse for, and attach, new files.</td>
</tr>
<tr>
<td>Page Title (page)</td>
<td>(none)</td>
<td>Used to display attachments from another page. If you do not enter a page title, the macro will display the files attached to the current page.</td>
</tr>
<tr>
<td>Show Previews (preview)</td>
<td>true</td>
<td>Used to display a preview of the attached file. If true, preview will be visible when the list item is expanded.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** attachments

**Macro body:** None.

*Storage format example*
Blog Posts Macro

The Blog Posts macro allows you to display blog posts on a Confluence page. Clicking on a title takes you to the blog post.

Using the Blog Posts Macro

To add the Blog Posts macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Wiki markup example

```wiki
{attachments:old=false|patterns=.*png,.*jpg|sortby=name|page=My page about chocolate|sortorder=descending|labels=chocolate,cookies|upload=false|preview=false}
```
| Content Type to Display (content) | No | titles | Available values:  
|-------------------------------|----|--------|-----------------------------------|
|                               |    |        | • **titles** — Display the title, creator, space, and created date stamp for each blog post.  
|                               |    |        | • **excerpts** — Display a short excerpt from each blog post. If the post contains an Excerpt macro, the Blog Posts macro will display the content defined in the Excerpt macro. If the post does not contain an Excerpt macro, the Blog Posts macro will display the first few sentences of the post.  
|                               |    |        | • **entire** - Display the whole content of each blog post.  
| Time Frame (time)             | No | no limit | Specify how far back in time Confluence should look for the blog posts to be displayed.  
|                               |    |        | Available values:  
|                               |    |        | • **m** — Minutes  
|                               |    |        | • **h** — Hours, so '12h' displays blog posts created in the last twelve hours.  
|                               |    |        | • **d** — Days, so '7d' displays blog posts created in the last seven days.  
|                               |    |        | • **w** — Weeks  
| Restrict to these Labels (label) | No | None | Filter the results by label. The macro will display only the blog posts which are tagged with the label(s) you specify here.  
|                               |    |        | You can specify one or more label values, separated by a comma or a space.  
|                               |    |        | • To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labeled with 'badpage'.  
|                               |    |        | • To indicate that the results **must** match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage,+goodpage you will get only content which has at least two labels, being 'superpage' and 'goodpage'.  
<p>| Restrict to these Authors (author) | No | None | Filter the results by author. The macro will display only the blog posts which are written by the author(s) you specify here. |</p>
<table>
<thead>
<tr>
<th>Restrict to these Spaces (spaces)</th>
<th>No</th>
<th>@self, i.e. the space which contains the page on which the macro is coded</th>
</tr>
</thead>
<tbody>
<tr>
<td>This parameter allows you to filter content by space. The macro will display only the pages which belong to the space(s) you specify here. You can specify one or more space keys, separated by a comma or a space.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Special values:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• <strong>@self</strong> — The current space.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• <strong>@personal</strong> — All personal spaces.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• <strong>@global</strong> — All site spaces.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• <strong>@favorite</strong> — The spaces you have marked as favorite.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• <strong>@all</strong> — All spaces in your Confluence site.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• * — The same as @all above.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~<a href="mailto:jbloggs@example.com">jbloggs@example.com</a>.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum Number of Blog Posts (max)</td>
<td>No</td>
<td>15</td>
</tr>
<tr>
<td>Specify the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sort By (sort)</td>
<td>No</td>
<td>creation</td>
</tr>
<tr>
<td>Specify how the results should be sorted. If this parameter is not specified, the sort order defaults to descending order (newest first) based on the creation date.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Values:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• <strong>title</strong> — Sort alphabetically by title.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• <strong>creation</strong> — Sort by the date on which the content was added.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• <strong>modified</strong> — Sort by the date on which the content was last updated.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reverse Sort (reverse)</td>
<td>No</td>
<td>false</td>
</tr>
<tr>
<td>Select to change the sort from descending to ascending order (oldest first). Use this parameter in conjunction with the Sort By parameter. This parameter is ignored if the Sort By parameter is not specified.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>In storage format and wikimarkup a value of <strong>true</strong> changes the sort order.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** blog-posts
**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="blog-posts">
   <ac:parameter ac:name="content">titles</ac:parameter>
   <ac:parameter ac:name="spaces">
      <ri:space ri:space-key="ds"/>
   </ac:parameter>
   <ac:parameter ac:name="author">
      <ri:user ri:userkey="12345678912345678912345678912345"/>
   </ac:parameter>
   <ac:parameter ac:name="time">4w</ac:parameter>
   <ac:parameter ac:name="sort">creation</ac:parameter>
   <ac:parameter ac:name="max">10</ac:parameter>
   <ac:parameter ac:name="labels">chocolate,cookies</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{blog-posts:content=titles|spaces=@self,ds|author=jsmith|time=4w|reverse=true|sort=creation|max=10|label=chocolate,cookies}
```

**Change-History Macro**

The Change-History macro shows the history of updates made to a page: version number, author, date and comment. It displays the information inline.

**Screenshot:** The Change-History macro in Confluence

<table>
<thead>
<tr>
<th>This is the change history macro</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Version</strong></td>
</tr>
<tr>
<td>Current Version (v. 4)</td>
</tr>
<tr>
<td>v. 3</td>
</tr>
<tr>
<td>v. 2</td>
</tr>
<tr>
<td>v. 1</td>
</tr>
</tbody>
</table>

**To add the Change-History macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in [Autocomplete for links, files, macros and mentions](#).

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Note:** There are no parameters for this macro.

**Code examples**
The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** change-history

**Macro body:** None.

**Parameters:** None.

**Storage format example**

```html
<ac:structured-macro ac:name="change-history"/>
```

**Wikimarkup example**

```
{change-history}
```

### Chart Macro

The Chart macro allows you to display a chart based on tabular data. When you add the macro to a page, you:

- supply the data to be charted by the macro as a table in the placeholder of the macro.
- edit the macro parameters in the Macro Browser to configure the format of the chart.

**Screenshot 1: A table of data in the Chart macro placeholder**

<table>
<thead>
<tr>
<th>Weeks</th>
<th>Issues Burndown</th>
</tr>
</thead>
<tbody>
<tr>
<td>04/07/2011</td>
<td>81</td>
</tr>
<tr>
<td>11/07/2011</td>
<td>68</td>
</tr>
<tr>
<td>18/07/2011</td>
<td>67</td>
</tr>
<tr>
<td>25/07/2011</td>
<td>66</td>
</tr>
<tr>
<td>01/08/2011</td>
<td>65</td>
</tr>
<tr>
<td>08/08/2011</td>
<td>65</td>
</tr>
<tr>
<td>15/08/2011</td>
<td>64</td>
</tr>
<tr>
<td>22/08/2011</td>
<td>44</td>
</tr>
<tr>
<td>29/08/2011</td>
<td>24</td>
</tr>
<tr>
<td>05/09/2011</td>
<td>0</td>
</tr>
</tbody>
</table>

**Screenshot 2: The resulting chart**
Using the Chart Macro

To add the Chart macro to a page:

1. Edit the page and use autocomplete to add the Chart macro. (Type '{chart}'.)
2. Enter your chart data as one or more tables in the body of the macro placeholder. (See the screenshot above.)
3. Click the macro placeholder and choose Edit.
4. Select a chart type using the Type parameter (see below).
5. Choose other parameter settings in the macro browser, as described below.
6. Click Refresh in the 'Preview' area, to check that the chart appears as you expect.
7. Click Save to add the chart to your page.
8. Click Save again when you are ready to save the page.
Parameters

Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification Parameters | Color Parameters | Axis Parameters | Pie Chart Parameters | Attachment Parameters

**Chart Type Parameters**

These parameters determine the type of chart to display and the way the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>pie</td>
<td>The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based (see the Time Series parameter). Standard — pie, bar, line, area XY Plots — xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries Other — gantt</td>
</tr>
<tr>
<td><strong>Display Orientation</strong></td>
<td>vertical</td>
<td>Applies to area, bar and line charts.</td>
</tr>
<tr>
<td><strong>Show in 3D</strong></td>
<td>false</td>
<td>Applies to area, bar and line charts.</td>
</tr>
<tr>
<td><strong>Stacked Values</strong></td>
<td>false</td>
<td>Applies to area and bar charts.</td>
</tr>
<tr>
<td><strong>Show shapes</strong></td>
<td>true</td>
<td>Applies to line charts. Shapes are shown at each data point.</td>
</tr>
<tr>
<td><strong>Opacity</strong></td>
<td></td>
<td>A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are. • 75 percent for 3D charts • 50 percent for non-stacked area charts • 100 percent for all other charts</td>
</tr>
</tbody>
</table>

**Display Control Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Width</strong></td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td><strong>Height</strong></td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
<tr>
<td><strong>Display rendered data</strong></td>
<td>false</td>
<td>Sets whether to display the rendered body of the macro (usually the data tables). By default, the chart data table isn't rendered. • before — the data are displayed before the chart. • after — the data are displayed after the chart.</td>
</tr>
<tr>
<td><strong>Image format</strong></td>
<td>png</td>
<td>The image format to be used for the chart. • png • jpg</td>
</tr>
</tbody>
</table>

**Title and Label Parameters**
### Data Specification Parameters

The data for the chart is taken from tables found when the macro body is rendered. These options control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. Additional conversion options can be specified using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart Title</td>
<td>none</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>Chart Subtitle</td>
<td>none</td>
<td>A subtitle for the chart, using a smaller font than for Title.</td>
</tr>
<tr>
<td>Horizontal-axis Label</td>
<td>none</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>Vertical-axis Label</td>
<td>none</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Show a legend or key.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables</td>
<td>all first level tables</td>
<td>Comma separated list of table ids and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
</tr>
<tr>
<td>Columns</td>
<td>all columns</td>
<td>Comma separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the (html) title attribute for the column in the header row.</td>
</tr>
<tr>
<td>Content Orientation</td>
<td>horizontal</td>
<td>• vertical — data table columns will be interpreted as series.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• horizontal — data tables rows will be interpreted as series.</td>
</tr>
<tr>
<td>Time Series</td>
<td>false</td>
<td>• true — the x values in an XY plot will be treated as time series data and so will be converted according to date formats.</td>
</tr>
<tr>
<td>Date format</td>
<td>Confluence language defined date formats</td>
<td>For time series data, the date format allows for additional customization of the conversion of data to date values. If a Date format is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See simple date format.</td>
</tr>
<tr>
<td>Time Period</td>
<td>Day</td>
<td>The time period for time series data. Defines the granularity of how the data is interpreted. Valid values are: Millisecond, Second, Minute, Hour, Day, Week, Month, Quarter, Year.</td>
</tr>
<tr>
<td>Language</td>
<td>none</td>
<td>Use in combination with the Country parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages. Valid values are 2 character ISO 639-1 alpha-2 codes.</td>
</tr>
<tr>
<td>Country</td>
<td>none</td>
<td>Use in combination with the Language parameter to form a locale. Valid values are 2 character ISO 3166 codes.</td>
</tr>
<tr>
<td>Forgive</td>
<td>true</td>
<td>• true — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• false — enforce strict data format. Data format errors will cause the chart to not be produced.</td>
</tr>
</tbody>
</table>
**Color Parameters**

Colors are specified using hexadecimal notation or HTML color names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background Color</td>
<td>White</td>
<td>Background of the chart.</td>
</tr>
<tr>
<td>Border Color</td>
<td>no border</td>
<td>Border around the chart.</td>
</tr>
<tr>
<td>Colors</td>
<td></td>
<td>Comma-separated list of colors used to customize category, sections, and series colors.</td>
</tr>
</tbody>
</table>

**Axis Parameters**

Depending on the chart type, the range and domain axis may be customized. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range Minimum Value</td>
<td>none</td>
<td>Range axis lower bound.</td>
</tr>
<tr>
<td>Range Maximum Value</td>
<td>none</td>
<td>Range axis upper bound.</td>
</tr>
<tr>
<td>Range Axis Tick Unit</td>
<td>none</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>Range Axis Label Angle</td>
<td>none</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>Domain Axis Lower Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the Date format parameter.</td>
</tr>
<tr>
<td>Domain Axis Upper Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the Date format parameter.</td>
</tr>
<tr>
<td>Domain Axis Tick Unit</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the Time Period parameter. The Time Period unit can be overridden by specifying a trailing character: y (years), M (months), d (days), h (hours), m (minutes), s (seconds), u (milliseconds).</td>
</tr>
<tr>
<td>Domain Axis Label Angle</td>
<td>none</td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
</tr>
<tr>
<td>Category Label Position</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>none</td>
<td></td>
<td>Placement of the axis label text for categories.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- up45 — 45 degrees going upward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- up90 — 90 degrees going upward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- down45 — 45 degrees going downward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- down90 — 90 degrees going downward</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Date Tick Mark Position</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>start</td>
<td></td>
<td>Placement of the date tick mark.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- start — tick mark is at the start of the date period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- middle — tick mark is in the middle of the date period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- end — tick mark is at the end of the date period.</td>
</tr>
</tbody>
</table>

**Pie Chart Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pie Section Label</td>
<td>Show only the pie section key value</td>
<td>Format for how pie section labels are displayed. The format uses a string with special replacement variables:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- %0% is replaced by the pie section key.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- %1% is replaced by the pie section numeric value.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- %2% is replaced by the pie section percent value.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example 1: &quot;%0% = %1%&quot; would display something like &quot;Independent = 20&quot;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example 2: &quot;%0% (%2%)&quot; would display something like &quot;Independent (20%)&quot;</td>
</tr>
</tbody>
</table>

| Pie Section Explode | No exploded sections | Comma separated list of pie keys that are to be shown exploded. Note: requires jFreeChart version 1.0.3 or higher. |

**Attachment Parameters**

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is displayed. These options allow for the generated image to be saved as an attachment and have subsequent access re-use the attachment. This can be useful especially when combined with the Cache Plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachment</td>
<td>none</td>
<td>The name and location with which the chart image will be saved as an attachment. The user must be authorized to add attachments to the page specified.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- ^attachmentName.png — the chart is saved as an attachment to the current page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- page^attachmentName.png — the chart is saved as an attachment to the page name provided.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- space:page^attachmentName.png — the chart is saved as an attachment to the page name provided in the space indicated.</td>
</tr>
</tbody>
</table>

| Attachment Version | new     | Defines the the versioning mechanism for saved charts. |
|                   |         | - new — creates new version of the attachment. |
|                   |         | - replace — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorized to remove attachments for the page specified. |
|                   |         | - keep — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated. |

| Attachment Comment | none    | Comment used for a saved chart attachment. |
Examples

**Pie Chart**

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>pie</td>
<td>Fish Sold 2011</td>
</tr>
<tr>
<td><strong>Chart Title</strong></td>
<td>Fish Sold 2011</td>
<td></td>
</tr>
<tr>
<td><strong>Show Legend</strong></td>
<td>true</td>
<td></td>
</tr>
<tr>
<td><strong>Content Orientation</strong></td>
<td>vertical</td>
<td></td>
</tr>
</tbody>
</table>

Fish Sold 2011

- Herring (9,500 - 68%)
- Salmon (2,900 - 21%)
- Tuna (1,500 - 11%)

**Bar Chart**

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>bar</td>
<td>Fish Sold</td>
</tr>
<tr>
<td><strong>Chart Title</strong></td>
<td>Fish Sold</td>
<td></td>
</tr>
<tr>
<td><strong>Show Legend</strong></td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

Fish Sold

- Herring
- Salmon
- Tuna
### 3D Bar Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>bar</td>
<td></td>
</tr>
<tr>
<td><strong>Show in 3D</strong></td>
<td>true</td>
<td></td>
</tr>
<tr>
<td><strong>Opacity</strong></td>
<td>50</td>
<td></td>
</tr>
<tr>
<td><strong>Show Legend</strong></td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Year</th>
<th>Revenue</th>
<th>Expense</th>
</tr>
</thead>
<tbody>
<tr>
<td>2009</td>
<td>12.4</td>
<td>43.6</td>
</tr>
<tr>
<td>2010</td>
<td>31.8</td>
<td>41.8</td>
</tr>
<tr>
<td>2011</td>
<td>41.1</td>
<td>31.1</td>
</tr>
</tbody>
</table>

### Time Series Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Tables in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>Time Series</td>
<td></td>
</tr>
<tr>
<td><strong>Date Format</strong></td>
<td>MM/yyyy</td>
<td></td>
</tr>
<tr>
<td><strong>Time Period</strong></td>
<td>Month</td>
<td></td>
</tr>
<tr>
<td><strong>Content Orientation</strong></td>
<td>vertical</td>
<td></td>
</tr>
<tr>
<td><strong>Range Axis Lower Bound</strong></td>
<td>0</td>
<td></td>
</tr>
<tr>
<td><strong>Show Legend</strong></td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Month</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2011</td>
<td>31.8</td>
</tr>
<tr>
<td>2/2011</td>
<td>41.8</td>
</tr>
<tr>
<td>3/2011</td>
<td>51.3</td>
</tr>
<tr>
<td>4/2011</td>
<td>33.8</td>
</tr>
<tr>
<td>5/2011</td>
<td>27.6</td>
</tr>
<tr>
<td>6/2011</td>
<td>49.8</td>
</tr>
<tr>
<td>7/2011</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2011</td>
<td>77.3</td>
</tr>
<tr>
<td>9/2011</td>
<td>73.8</td>
</tr>
<tr>
<td>10/2011</td>
<td>97.6</td>
</tr>
<tr>
<td>11/2011</td>
<td>101.2</td>
</tr>
<tr>
<td>12/2011</td>
<td>113.7</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Month</th>
<th>Expenses</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2011</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2011</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2011</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2011</td>
<td>45.0</td>
</tr>
<tr>
<td>5/2011</td>
<td>44.6</td>
</tr>
<tr>
<td>6/2011</td>
<td>43.8</td>
</tr>
<tr>
<td>7/2011</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2011</td>
<td>52.3</td>
</tr>
<tr>
<td>9/2011</td>
<td>53.8</td>
</tr>
<tr>
<td>10/2011</td>
<td>55.6</td>
</tr>
<tr>
<td>11/2011</td>
<td>61.2</td>
</tr>
<tr>
<td>12/2011</td>
<td>63.7</td>
</tr>
</tbody>
</table>

### XY Line Chart
### Parameters in Macro Browser

<table>
<thead>
<tr>
<th>Type</th>
<th>xyLine</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Legend</td>
<td>true</td>
</tr>
</tbody>
</table>

### Data Table in Macro Placeholder

<table>
<thead>
<tr>
<th></th>
<th>12</th>
<th>14</th>
<th>23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revenue</td>
<td>41.1</td>
<td>31.8</td>
<td>12.4</td>
</tr>
<tr>
<td>Expense</td>
<td>31.1</td>
<td>41.8</td>
<td>43.6</td>
</tr>
</tbody>
</table>

### Rendered Chart

![Revenue vs Expense Chart](chart.png)

## XY Area Chart

<table>
<thead>
<tr>
<th>Type</th>
<th>xyArea</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Legend</td>
<td>true</td>
</tr>
</tbody>
</table>

### Data Table in Macro Placeholder

<table>
<thead>
<tr>
<th></th>
<th>12</th>
<th>14</th>
<th>23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revenue</td>
<td>41.1</td>
<td>31.8</td>
<td>12.4</td>
</tr>
<tr>
<td>Expense</td>
<td>31.1</td>
<td>41.8</td>
<td>43.6</td>
</tr>
</tbody>
</table>

### Rendered Chart

![Revenue and Expense Area Chart](area chart.png)

## Area Charts

### Example 1

<table>
<thead>
<tr>
<th>Type</th>
<th>area</th>
</tr>
</thead>
<tbody>
<tr>
<td>Satisfaction</td>
<td>2009</td>
</tr>
<tr>
<td>Very</td>
<td>20</td>
</tr>
</tbody>
</table>

![Satisfaction Area Chart](satisfaction chart.png)
### Example 2

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>area</td>
<td></td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Stacked Values</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

#### Satisfaction 2009 2010 2011

<table>
<thead>
<tr>
<th>Very satisfied</th>
<th>12 23 31</th>
</tr>
</thead>
<tbody>
<tr>
<td>Satisfied</td>
<td>1 34 36</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>4 6 22</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>2 7 12</td>
</tr>
</tbody>
</table>

#### Gantt Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>gantt</td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>200</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Stage</th>
<th>Plan</th>
<th>Start</th>
<th>End</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stage 1</td>
<td>6/25/2013</td>
<td>7/10/2013</td>
<td>30%</td>
<td></td>
</tr>
<tr>
<td>Stage 2</td>
<td>7/13/2013</td>
<td>11/28/2013</td>
<td>40%</td>
<td></td>
</tr>
</tbody>
</table>
### Code examples

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** chart

**Macro body:** Accepts rich text, consisting of tables that hold the chart's data.

This macro recognizes a large number of parameters, listed here by type for convenience. See all parameters...

#### Chart type parameters

These parameters determine the type of chart to display and how the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| type           | No       | pie     | The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based. See the timeSeries parameter. Available values:  
- Standard charts – pie, bar, line, area  
- XY plots – xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries  
- Other charts – gantt  
| orientation    | No       | vertical | The display orientation. Applies to area, bar and line charts. Available values:  
- vertical – y-axis is vertical  
- horizontal – x-axis is vertical  
| 3D             | No       | false   | Show in three dimensions. Applies to area, bar and line charts.  
| stacked        | No       | false   | Stacked values. Applies to area and bar charts.  
| showShapes     | No       | true    | Applies to line charts. Shapes are shown at each data point.  

<table>
<thead>
<tr>
<th>Actual</th>
<th>Start</th>
<th>End</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stage 1</td>
<td>6/25/2013</td>
<td>7/26/2013</td>
<td>100%</td>
</tr>
<tr>
<td>Stage 2</td>
<td>7/29/2013</td>
<td>12/01/2013</td>
<td>40%</td>
</tr>
<tr>
<td>Stage 3</td>
<td>12/10/2013</td>
<td>12/25/2013</td>
<td></td>
</tr>
</tbody>
</table>
## Chart display parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
<tr>
<td>dataDisplay</td>
<td>No</td>
<td>false</td>
<td>Determines whether to display the body of the macro, consisting of the data table. By default, the chart data table is not displayed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- false – the data is not displayed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- true or after – the data is displayed after the chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- before – the data is displayed before the chart.</td>
</tr>
<tr>
<td>imageFormat</td>
<td>No</td>
<td>png</td>
<td>The image format to be used for the chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- png</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- jpg</td>
</tr>
</tbody>
</table>

## Chart title and label parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>subTitle</td>
<td>No</td>
<td>(None)</td>
<td>A subtitle for the chart.</td>
</tr>
<tr>
<td>xLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>yLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>legend</td>
<td>No</td>
<td>false</td>
<td>Determines whether to show a legend (key) for the chart.</td>
</tr>
</tbody>
</table>

## Chart data parameters

The data for the chart is taken from tables found in the macro body. The parameters below control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. You can specify additional conversion options using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

### opacity

- 75 percent for 3D charts
- 50 percent for non-stacked area charts
- 100 percent for all other charts

A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>tables</td>
<td>No</td>
<td>You can supply a comma-separated list of table IDs and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
</tr>
<tr>
<td>columns</td>
<td>No</td>
<td>You can supply a comma-separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the HTML title attribute for the column in the header row.</td>
</tr>
</tbody>
</table>
| dataOrientation | No      | The content orientation. By default, the data tables will be interpreted as columns (horizontally) representing domain and x values. Available values:  
  - vertical – data table columns will be interpreted as series.  
  - horizontal – data table rows will be interpreted as series. |
| timeSeries      | No      | If 'true', the x values in an XY plot will be treated as time series data and so will be converted according date formats.                         |
| dateFormat      | No      | For time series data, the date format allows for additional customization of the conversion of data to date values. If a dateFormat is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See simple date format. |
| timePeriod      | No      | The time period for time series data. Defines the granularity of how the data is interpreted. Available values: millisecond, second, minute, hour, day, week, month, quarter, year |
| language        | No      | Use in combination with the country parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages. Available values are the two-character ISO 639-1 alpha-2 codes. |
| country         | No      | Use in combination with the language parameter to form a locale. Valid values are the two-character ISO 3166 codes. |
### Chart color parameters

Colors are specified using hexadecimal notation or HTML color names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>bgColor</td>
<td>No</td>
<td>White</td>
<td>Background color of the chart.</td>
</tr>
<tr>
<td>borderColor</td>
<td>No</td>
<td>No border</td>
<td>Color of the border around the chart.</td>
</tr>
<tr>
<td>colors</td>
<td>No</td>
<td></td>
<td>A comma-separated list of colors used to customize the colors of categories, sections, and series.</td>
</tr>
</tbody>
</table>

### Chart axis parameters

Depending on the chart type, the range and domain axis may be customized. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rangeAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td>Minimum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td>Maximum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>rangeAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>domainAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the dateFormat parameter.</td>
</tr>
<tr>
<td>domainAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the dateFormat parameter.</td>
</tr>
<tr>
<td>domainAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the timePeriod parameter. The timePeriod unit can be overridden by specifying a trailing character: y (years), M (months), d (days), h (hours), m (minutes), s (seconds), u (milliseconds).</td>
</tr>
<tr>
<td>domainAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
</tr>
<tr>
<td><strong>Parameter</strong></td>
<td><strong>Required</strong></td>
<td><strong>Default</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>------------------------------</td>
<td>--------------</td>
<td>-------------</td>
<td>---------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>categoryLabelPosition</td>
<td>No</td>
<td>(None)</td>
<td>Placement of the axis label text for categories.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• up45 — 45 degrees going upward</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• up90 — 90 degrees going upward</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• down45 — 45 degrees going downward</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• down90 — 90 degrees going downward</td>
</tr>
<tr>
<td>dateTickMarkPosition</td>
<td>No</td>
<td>start</td>
<td>Placement of the date tick mark.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• start — tick mark is at the start of the date period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• middle — tick mark is in the middle of the date period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• end — tick mark is at the end of the date period.</td>
</tr>
</tbody>
</table>

**Pie chart Parameters**

**Parameter** | **Required** | **Default** | **Description**
--- | --- | --- | ---
pieSectionLabel | No | Show only the pie section key value | Format of pie section labels. The format uses a string with special replacement variables:
• %0% is replaced by the pie section key.
• %1% is replaced by the pie section numeric value.
• %2% is replaced by the pie section percent value.
Example 1: To display something like 'Independent = 20':
%0% = %1%
Example 2: To display something like 'Independent (20%)':
%0% (%2%)
pieSectionExplode | No | No exploded sections | A comma-separated list of pie keys that are to be shown exploded. Note: requires jFreeChart version 1.0.3 or higher.

**Chart attachment parameters**

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is displayed. These options allow for the generated image to be saved as an attachment and have subsequent access to re-use the attachment. This can be useful especially when combined with the Cache plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th><strong>Parameter</strong></th>
<th><strong>Required</strong></th>
<th><strong>Default</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Yes/No</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| attachment             | No     | (None)  | The name and location where the chart image will be saved as an attachment. The user must be authorized to add attachments to the page specified. Available syntax for this parameter:  
  - `attachmentName.png` — the chart is saved as an attachment to the current page.  
  - `page name^attachmentName.png` — the chart is saved as an attachment to the page name provided.  
  - `spacekey:page name^attachmentName.png` — the chart is saved as an attachment to the page name provided in the space indicated. |
| attachmentVersion      | No     | new     | Defines the versioning mechanism for saved charts. Available values:  
  - `new` — creates new version of the attachment.  
  - `replace` — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorized to remove attachments for the page specified.  
  - `keep` — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated. |
| attachmentComment      | No     | (None)  | Comment used for a saved chart attachment.                                                                                                                                                                  |
| thumbnail              | No     | false   | If true, the chart image attachment will be shown as a thumbnail (small, expandable) image.                                                                                                               |

Storage format example

Below is a simple example of a pie chart. See more examples in Storage Format Examples for Chart Macro.
### Fish Sold

<table>
<thead>
<tr>
<th>Fish Type</th>
<th>2004</th>
<th>2005</th>
</tr>
</thead>
<tbody>
<tr>
<td>Herring</td>
<td>9,500</td>
<td>8,300</td>
</tr>
<tr>
<td>Salmon</td>
<td>2,900</td>
<td>4,200</td>
</tr>
<tr>
<td>Tuna</td>
<td>1,500</td>
<td>1,500</td>
</tr>
</tbody>
</table>
**Wiki markup example**

Below is a simple example of a pie chart. See more examples in Wiki Markup Examples for Chart Macro.

```
{chart:type=pie|title=Fish Sold}
|| Fish Type || 2004 || 2005 ||
|| Herring   | 9,500 | 8,300 |
|| Salmon    | 2,900 | 4,200 |
|| Tuna      | 1,500 | 1,500 |
{chart}
```

**Confluence Storage Format Examples for Chart Macro**

This page is an extension of the documentation for the Chart Macro. This page contains additional examples for the Chart macro.

**Pie chart**

Here is a simple example of a pie chart.

**Storage format**
<table>
  <thead>
    <tr>
      <th>Fish Type</th>
      <th>2004</th>
      <th>2005</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td>Herring</td>
      <td>9,500</td>
      <td>8,300</td>
    </tr>
    <tr>
      <td>Salmon</td>
      <td>2,900</td>
      <td>4,200</td>
    </tr>
    <tr>
      <td>Tuna</td>
      <td>1,500</td>
      <td>1,500</td>
    </tr>
  </tbody>
</table>
Resulting chart

Fish Sold

360°

2004

2005

2004 (1,500 - 50%)  2005 (1,500 - 50%)

Bar chart

Here is a simple example of a bar chart.

Storage format
<table>
  <thead>
    <tr>
      <th>Fish Type</th>
      <th>2004</th>
      <th>2005</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td>Herring</td>
      <td>9,500</td>
      <td>8,300</td>
    </tr>
    <tr>
      <td>Salmon</td>
      <td>2,900</td>
      <td>4,200</td>
    </tr>
    <tr>
      <td>Tuna</td>
      <td>1,500</td>
      <td>1,500</td>
    </tr>
  </tbody>
</table>
Here is an example of a time series chart.

**Storage format**

```xml
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="timePeriod">Month</ac:parameter>
  <ac:parameter ac:name="dataOrientation">vertical</ac:parameter>
  <ac:parameter ac:name="rangeAxisLowerBound">0</ac:parameter>
  <ac:parameter ac:name="dateFormat">MM/yyyy</ac:parameter>
  <ac:parameter ac:name="type">timeSeries</ac:parameter>
  <ac:parameter ac:name="domainaxisrotateticklabel">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th>Month</th>
          <th>Revenue</th>
        </tr>
        <tr>
          <td>1/2005</td>
          <td>31.8</td>
        </tr>
        <tr>
          <td>2/2005</td>
          <td>31.8</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```
<table>
<thead>
<tr>
<th>Date</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>4/2005</td>
<td>41.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>51.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>33.8</td>
</tr>
<tr>
<td>5/2005</td>
<td>27.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>49.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>77.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>73.8</td>
</tr>
<tr>
<td>Month</td>
<td>Expenses</td>
</tr>
<tr>
<td>---------</td>
<td>----------</td>
</tr>
<tr>
<td>10/2005</td>
<td>97.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>101.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>113.7</td>
</tr>
<tr>
<td>1/2005</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2005</td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td>Value</td>
</tr>
<tr>
<td>----------</td>
<td>-------</td>
</tr>
<tr>
<td>4/2005</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>45.0</td>
</tr>
<tr>
<td>5/2005</td>
<td>44.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>52.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>53.8</td>
</tr>
<tr>
<td>10/2005</td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td>Value</td>
</tr>
<tr>
<td>----------</td>
<td>-------</td>
</tr>
<tr>
<td>11/2005</td>
<td>55.6</td>
</tr>
<tr>
<td>12/2005</td>
<td>61.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>63.7</td>
</tr>
</tbody>
</table>
Here is an example of an XY line chart.

**Storage format**
<ac:macro ac:name="chart">
 <ac:parameter ac:name="type">xyline</ac:parameter>
 <ac:rich-text-body>
   <table>
     <tbody>
       <tr>
         <th></th>
         <th>12</th>
         <th>14</th>
         <th>23</th>
       </tr>
       <tr>
         <td>Revenue</td>
         <td>41.1</td>
         <td>31.8</td>
         <td>12.4</td>
       </tr>
       <tr>
         <td>Expense</td>
         <td>31.1</td>
         <td>41.8</td>
         <td>43.6</td>
       </tr>
     </tbody>
   </table>
 </ac:rich-text-body>
</ac:macro>

Resulting chart
Here is an example of an XY bar chart.

Storage format
<ac:structured-macro ac:name="chart">
<ac:parameter ac:name="opacity">60</ac:parameter>
<ac:parameter ac:name="type">xybar</ac:parameter>
<ac:rich-text-body>
<table>
<tbody>
<tr>
<th></th>
<th>2005</th>
<th>2006</th>
<th>2007</th>
</tr>
<tr>
<td>Revenue</td>
<td>41.1</td>
<td>31.8</td>
<td>12.4</td>
</tr>
<tr>
<td>Expense</td>
<td>31.1</td>
<td>41.8</td>
<td>43.6</td>
</tr>
</tbody>
</table>
</ac:rich-text-body>
</ac:structured-macro>

**Resulting chart**
Here is an example of an XY area chart.

*Storage format*
<table>
<thead>
<tr>
<th></th>
<th>12</th>
<th>14</th>
<th>23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revenue</td>
<td>41.1</td>
<td>31.8</td>
<td>12.4</td>
</tr>
<tr>
<td>Expense</td>
<td>31.1</td>
<td>41.8</td>
<td>43.6</td>
</tr>
</tbody>
</table>

Resulting chart
Here are two examples of area charts.

Storage format for area chart 1

```xml
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="height">300</ac:parameter>
  <ac:parameter ac:name="legend">true</ac:parameter>
  <ac:parameter ac:name="width">300</ac:parameter>
  <ac:parameter ac:name="opacity">50</ac:parameter>
  <ac:parameter ac:name="type">area</ac:parameter>
  <ac:parameter ac:name="dataDisplay">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th>
            <p>Satisfaction</p>
          </th>
          <th></th>
          <th></th>
          <th></th>
        </tr>
        <tr>
          <td>
            <p>Very satisfied</p>
          </td>
          <td>
            <p>2002</p>
          </td>
          <td>
            <p>2003</p>
          </td>
          <td>
            <p>2004</p>
          </td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```
<table>
<thead>
<tr>
<th>Category</th>
<th>Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td>Satisfied</td>
<td>23</td>
</tr>
<tr>
<td>Disatisfied</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
</tr>
<tr>
<td>Overall satisfaction</td>
<td></td>
</tr>
</tbody>
</table>
### Resulting area chart 1

![Resulting area chart 1](chart1.png)

The chart shows satisfaction levels from 2002 to 2004 for different levels of satisfaction:
- **Very satisfied**
- **Satisfied**
- **Disatisfied**
- **Very disatisfied**

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
<td>34</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Disatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>

### Storage format for area chart 2

```xml
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="stacked">true</ac:parameter>
  <ac:parameter ac:name="height">300</ac:parameter>
  <ac:parameter ac:name="legend">true</ac:parameter>
  <ac:parameter ac:name="width">300</ac:parameter>
  <ac:parameter ac:name="type">area</ac:parameter>
  <ac:parameter ac:name="dataDisplay">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th>Satisfaction</th>
          <th>2002</th>
          <th>2003</th>
          <th>2004</th>
        </tr>
        <tr>
          <td>Very satisfied</td>
          <td>20</td>
          <td>23</td>
          <td>34</td>
        </tr>
        <tr>
          <td>Satisfied</td>
          <td>40</td>
          <td>34</td>
          <td>23</td>
        </tr>
        <tr>
          <td>Disatisfied</td>
          <td>25</td>
          <td>26</td>
          <td>25</td>
        </tr>
        <tr>
          <td>Very disatisfied</td>
          <td>15</td>
          <td>17</td>
          <td>18</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```
<table>
<thead>
<tr>
<th>Year</th>
<th>Very satisfied</th>
<th>Satisfied</th>
<th>Disatisfied</th>
<th>Very dissatisfied</th>
</tr>
</thead>
<tbody>
<tr>
<td>2004</td>
<td>12</td>
<td>34</td>
<td>6</td>
<td>7</td>
</tr>
<tr>
<td>2005</td>
<td>23</td>
<td>22</td>
<td>22</td>
<td>2</td>
</tr>
<tr>
<td>2006</td>
<td>31</td>
<td>36</td>
<td>22</td>
<td>7</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>----</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Resulting area chart 2

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>12</td>
<td>23</td>
<td>31</td>
</tr>
<tr>
<td>Satisfied</td>
<td>1</td>
<td>34</td>
<td>36</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>4</td>
<td>6</td>
<td>22</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>2</td>
<td>7</td>
<td>12</td>
</tr>
</tbody>
</table>

Wiki Markup Examples for Chart Macro

This page is an extension of the documentation for the Chart Macro. This page contains additional examples for the Chart macro.

Pie chart

Here is a simple example of a pie chart.

Wiki markup

```
{chart:type=pie|title=Fish Sold}
|| Fish Type || 2004 || 2005 ||
|| Herring | 9,500 | 8,300 |
|| Salmon  | 2,900 | 4,200 |
|| Tuna    | 1,500 | 1,500 |
{chart}
```

Resulting chart
Bar chart

Here is a simple example of a bar chart.

Wiki markup

```wiki
{chart:type=bar|title=Fish Sold}
|| Fish Type || 2004 || 2005 ||
|| Herring | 9,500 | 8,300 |
|| Salmon | 2,900 | 4,200 |
|| Tuna | 1,500 | 1,500 |
{chart}
```

Resulting chart

Time series chart

Here is an example of a time series chart.
### Wiki markup

```
{chart:type=timeSeries|dateFormat=MM/yyyy|timePeriod=Month|
dataOrientation=vertical|rangeAxisLowerBound=0|domainaxisrotateticklabel=true}

<table>
<thead>
<tr>
<th>Month</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2005</td>
<td>31.8</td>
</tr>
<tr>
<td>2/2005</td>
<td>41.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>51.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>33.8</td>
</tr>
<tr>
<td>5/2005</td>
<td>27.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>49.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>77.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>73.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>97.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>101.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>113.7</td>
</tr>
</tbody>
</table>
```

<table>
<thead>
<tr>
<th>Month</th>
<th>Expenses</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2005</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>45.0</td>
</tr>
<tr>
<td>5/2005</td>
<td>44.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>52.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>53.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>55.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>61.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>63.7</td>
</tr>
</tbody>
</table>

---

### Resulting chart

![XY line chart](chart)

**Revenue** vs. **Expenses**
Here is an example of an XY line chart.

*Wiki markup*

```
{chart:type=xyline}
<table>
<thead>
<tr>
<th></th>
<th></th>
<th>12</th>
<th>14</th>
<th>23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revenue</td>
<td>41.1</td>
<td>31.8</td>
<td>12.4</td>
<td></td>
</tr>
<tr>
<td>Expense</td>
<td>31.1</td>
<td>41.8</td>
<td>43.6</td>
<td></td>
</tr>
</tbody>
</table>
{chart}
```

*Resulting chart*

![XY line chart](image)

**XY bar chart**

Here is an example of an XY bar chart.

*Wiki markup*

```
{chart:type=xybar|opacity=60}
<table>
<thead>
<tr>
<th></th>
<th></th>
<th>2005</th>
<th>2006</th>
<th>2007</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revenue</td>
<td>41.1</td>
<td>31.8</td>
<td>12.4</td>
<td></td>
</tr>
<tr>
<td>Expense</td>
<td>31.1</td>
<td>41.8</td>
<td>43.6</td>
<td></td>
</tr>
</tbody>
</table>
{chart}
```

*Resulting chart*
XY area chart

Here is an example of an XY area chart.

Wiki markup

```wiki
{chart:type=xyarea}
|  |  | 12 | 14 | 23 |
| Revenue | 41.1 | 31.8 | 12.4 |
| Expense | 31.1 | 41.8 | 43.6 |
{chart}
```

Resulting chart

Area chart

Here are two examples of area charts.

Wiki markup for area chart 1

Created in 2016 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
<td>34</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Disatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>

Wiki markup for area chart 2

(resulting chart)

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>12</td>
<td>23</td>
<td>31</td>
</tr>
<tr>
<td>Satisfied</td>
<td>1</td>
<td>34</td>
<td>36</td>
</tr>
<tr>
<td>Disatisfied</td>
<td>4</td>
<td>6</td>
<td>22</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>2</td>
<td>7</td>
<td>12</td>
</tr>
</tbody>
</table>

(resulting chart)
Cheese Macro

The Cheese macro simply displays the words "I like cheese!" You can use this macro to test the Confluence macro functionality. 😊

To add the Cheese macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Note:** There are no parameters for this macro.

**Code examples**

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** cheese

**Macro body:** None.

**Parameters:** None

**Storage format example**

```
<ac:structured-macro ac:name="cheese"/>
```
Children Display Macro

Use the Children Display macro to list the child pages of a page and the further descendants (children’s children). By default, the macro displays links to the child pages as shown in the screenshot below. People viewing the page will see only the links for pages that they have permission to view.

**Screenshot: The Children Display macro in Confluence**

Using the Children Display macro

**To add the Children Display macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Example

This list of child pages is generated by a Children Display macro on this page:

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Descendants (all)</td>
<td>false</td>
<td>Choose whether to display all the parent page’s descendants. If true shows the complete tree of pages underneath the parent page, regardless of Depth of Descendants</td>
</tr>
</tbody>
</table>
Parent Page (page) | current | Specify the page to display children for, from either the current space or a different space. Enter:
- '/' — to list the top-level pages of the current space, i.e. those without parents.
- 'pagename' — to list the children of the specified page.
- 'spacekey:' — to list the top-level pages of the specified space.
- 'spacekey:pagename' — to list the children of the specified page in the specified space.

Number of Children (first) | none | Restrict the number of child pages that are displayed at the top level.

Depth of Descendants (depth) | none | Enter a number to specify the depth of descendants to display. For example, if the value is 2, the macro will display 2 levels of child pages.
This setting has no effect of Show Descendants is enabled.

Heading Style (style) | none | Choose the style used to display descendants.

Include Excerpts (excerpt) | none | Allows you to include a short excerpt under each page in the list. Choose between:
- None - no excerpt will be displayed
- Simple - displays the first line of text contained in an Excerpt macro any of the returned pages. If there is not an Excerpt macro on the page, nothing will be shown.
- Rich content - displays the contents of an Excerpt macro, or if there is not an Excerpt macro on the page, the first part of the page content, including formatted text, images and some macros.

Sort Children By (sort) | Manual if manually ordered, otherwise alphabetical | Optional. Choose:
- creation — to sort by content creation date
- title — to sort alphabetically on title
- modified — to sort of last modification date.

Reverse Sort (reverse) | false | Use with the Sort Children By parameter. When set, the sort order changes from ascending to descending.

Code examples
The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: children
Macro body: None.

Storage format example
Wiki markup example

{children:reverse=true|sort=creation|style=h4|page=Home|excerpt=none|first=99|depth=2|all=true}

Code Block Macro

The Code Block macro allows you to display source code in your page with syntax highlighting, like the one below:

```java
public static void main(String[] args) {
    System.out.println("Hello World!");
}
```

Add the Code Block Macro

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

You type the code block directly into the macro placeholder in the editor. Note that any white space contained in the placeholder is not manipulated in any way by the Code Block macro. This is to provide the writer with flexibility over code indentation.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Syntax highlighting</td>
<td>java</td>
<td>Specifies the language (or environment) for syntax highlighting. The default language is Java but you can choose from one of the following languages/environments:</td>
</tr>
<tr>
<td>(language)</td>
<td></td>
<td>• actionscript3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• bash</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• csharp (C#)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• coldfusion</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• cpp (C++)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• css</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• delphi</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• diff</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• erlang</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• groovy</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• html/xml</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• java</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• javafx</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• javascript</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• none (no syntax highlighting)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• perl</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• php</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• powershell</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• python</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• ruby</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• scala</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• sql</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• vb</td>
</tr>
<tr>
<td>Title</td>
<td>none</td>
<td>Adds a title to the code block. If specified, the title will be displayed in a header row at the top of the code block.</td>
</tr>
<tr>
<td>Collapsible (collapse)</td>
<td>false</td>
<td>If selected, the code macro’s content will be collapsed upon visiting or refreshing the Confluence page. Clicking the expand source link allows you to view this content. If false, the code macro’s content is always displayed in full.</td>
</tr>
<tr>
<td>Show line numbers</td>
<td>false</td>
<td>If selected, line numbers will be shown to the left of the lines of code.</td>
</tr>
<tr>
<td>(linenumbers)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>First line number</td>
<td>1</td>
<td>When Show line numbers is selected, this value defines the number of the first line of code.</td>
</tr>
<tr>
<td>(firstline)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Theme</td>
<td>Default</td>
<td>Specifies the color scheme used for displaying your code block. Many of these themes are based on the default color schemes of popular integrated development environments (IDEs). The default theme is Confluence (also known as Default), which is typically black and colored text on a blank background. However, you can also choose from one of the following other popular themes:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• DJango</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Emacs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• FadeToGrey</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Midnight</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• RDark</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Eclipse</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Confluence</td>
</tr>
</tbody>
</table>
Configure the Code Block macro

You can configure the Code Block macro to use a specific language and theme by default and also upload new languages. You need Confluence Administrator permissions to change the default theme and language and System Administrator permissions to upload new languages.

To set the default appearance of code blocks in your site:

1. Choose the cog icon , then choose General Configuration under Confluence Administration
2. Choose Configure Code Macro
3. Select a Default Theme and Default Language
4. Choose Save

All new code blocks will use the default theme and language unless you specify otherwise. Existing code blocks will be unchanged.

To add an additional language:

1. Choose the cog icon , then choose General Configuration under Confluence Administration
2. Choose Configure Code Macro
3. Choose Add a new language
4. Locate your language file and enter a Name for the new language (this will appear when selecting the language)
5. Choose Add

Language files must be correctly formatted JavaScript files and adhere to the Custom Brush syntax.

To disable or remove a user-installed language:

1. Choose the cog icon , then choose General Configuration under Confluence Administration
2. Choose Manage Add-ons
3. Go to User-installed Add-ons and locate the add-on for your uploaded language - it will appear like this ‘Custom Code Macro Highlighting for...’
4. Choose Uninstall or Disable

The language will no longer appear in the Code Macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: code

Macro body: Accepts plain text.

Storage format example

The following example shows all parameters and a body:
Below are three examples of the Code Block macro with various optional parameters used.

<table>
<thead>
<tr>
<th>Description</th>
<th>Markup</th>
<th>What you get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code block macro with a body and no optional parameters</td>
<td><code>&lt;ac:structured-macro ac:name=&quot;code&quot;&gt; &lt;ac:plain-text-body&gt;&lt;![CDATA[this is my code]]&gt;&lt;/ac:plain-text-body&gt; &lt;/ac:structured-macro&gt;</code></td>
<td>this is my code</td>
</tr>
</tbody>
</table>

| Code block macro with a body and the optional language parameter defined | `<ac:structured-macro ac:name="code"> <ac:parameter ac:name="language">html/xml</ac:parameter> <ac:plain-text-body><![CDATA[this is my code]]></ac:plain-text-body> </ac:structured-macro>` | this is my code |

| Code block macro with a body and optional title, line numbers and language parameters defined | `<ac:structured-macro ac:name="code"> <ac:parameter ac:name="title">This is my title</ac:parameter> <ac:parameter ac:name="linenumbers">true</ac:parameter> <ac:parameter ac:name="language">html/xml</ac:parameter> <ac:plain-text-body><![CDATA[this is my code]]></ac:plain-text-body> </ac:structured-macro>` | This is my title this is my code |

Wiki markup example

```
{code:title=This is my title|theme=FadeToGrey|linenumbers=true|language=html/xml|firstline=0001|collapse=true}
This is my code
{code}
```
Column Macro

Used with the Section macro to define columns on a page. See Working with page layouts and columns and sections.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: column

Macro body: Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>The width of the column. Can be specified either in pixels (for example, 400px) or as a percentage of the available page width (for example, 50%).</td>
</tr>
</tbody>
</table>

Storage format example

```xml
<ac:structured-macro ac:name="column">
  <ac:parameter ac:name="width">100px</ac:parameter>
  <ac:rich-text-body>
    <p>This is the content of <strong>column 1</strong>.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

Wiki markup example

```markdown
{column:width=100px}
This is the content of *column 1*.
{column}
```

Content by Label Macro

The Content by Label macro is used to display lists of pages, blog posts or attachments that have particular labels. It's great for collecting related pages together and filtering out content that you don't want to see.

For example, you could use this macro to display a list of all pages that have the label 'feature-shipped' and include the word 'Blueprint', or to list any pages with the label 'meeting-notes' that you've been mentioned in.

Here's how the macro looks on your page:
And here’s how you would set it up in the macro browser:

Using the Content by Label Macro

To add the Content by Label macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in *Autocomplete for links, files, macros and mentions.*

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**CQL filters**

CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add filters to build up a search query, adding as many filters as you need to narrow down the search results.
Use the **Add a filter** link to add more filters to your query.

**Use AND, OR, and NOT operators**

- For an OR search, specify multiple values in the same field.
  So to show pages with 'label-a', 'label-b' or both you'd put 'label-a' and 'label-b' in the same Label field, like this:

  ![Label filter example]

- For an AND search, add more than one filter and specify a single value in each.
  To show only pages with label-a and label-b you'd put 'label-a' in one label field, then add a second Label field to the macro, and put 'label-b' in the second one, like this:

  ![Label filter example]

  Put simply, OR values are entered in the same filter, AND values are entered in different filter.
  Only some filters support AND. If the filter doesn't support the AND operator, you won't be able to add that filter more than once.

- For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that label.

You can use the following CQL filters to build your query:

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
<th>Operators</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Label</strong></td>
<td>Include pages, blog posts or attachments with these labels.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AND (multiple Label filters)</td>
</tr>
<tr>
<td>With ancestor</td>
<td>Include pages that are children of this page. This allows you to restrict the macro to a single page tree.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>Contributor**</td>
<td>Include pages or blog posts that were created or edited by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>Creator</td>
<td>Include items created by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>Mentioning user</td>
<td>Include pages and blog posts that @mention these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>With parent</td>
<td>Include only direct children of this page (further sub-pages won't be included)</td>
<td>EQUALS (one page only)</td>
</tr>
<tr>
<td>In space**</td>
<td>Include items from these spaces.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>Including text**</td>
<td>Include items that contain this text.</td>
<td>CONTAINS (single word or phrase)</td>
</tr>
<tr>
<td>With title</td>
<td>Include items that contain this text in the title.</td>
<td>CONTAINS (single word or phrase)</td>
</tr>
</tbody>
</table>
**Of type**

Include only pages, blogs or attachments.

OR (multiple values in the same filter)

* This field is required in CQL-powered macros.

** You can add these filters in CQL-powered macros but in search they're part of the standard search filters, so they don't appear in the Add a filter menu.

Macro display options

These options control how the macro appears on your page.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sort by</strong></td>
<td>Modified</td>
<td>Sort the list by title, the date it was created, or the date it was last modified. If you don't select an option, CQL default ordering by relevancy is used.</td>
</tr>
<tr>
<td><strong>Reverse sort</strong></td>
<td>False</td>
<td>Sort the list descending instead of ascending (Z - A, earliest - latest)</td>
</tr>
<tr>
<td><strong>Maximum number of pages</strong></td>
<td>15</td>
<td>Limit the number of items to include in the list.</td>
</tr>
<tr>
<td><strong>List title</strong></td>
<td>Blank</td>
<td>Include an optional heading for the macro</td>
</tr>
<tr>
<td><strong>Show labels for each page</strong></td>
<td>True</td>
<td>Show or hide the labels applied to each item</td>
</tr>
<tr>
<td><strong>Show space name for each page</strong></td>
<td>True</td>
<td>Show or hide the space name for each item</td>
</tr>
</tbody>
</table>
| **Display excerpts**               | False   | Allows you to include a short excerpt under each page in the list. Choose between:
|                                    |         | • None - no excerpt will be displayed.                                        |
|                                    |         | • Simple - displays the first line of text contained in an Excerpt macro any of the returned pages. If there is not an Excerpt macro on the page, nothing will be shown. |
|                                    |         | • Rich content - displays the contents of an Excerpt macro, or if there is not an Excerpt macro on the page, the first part of the page content, as formatted text, including images and some macros. |

**Content by User Macro**

The Content by User macro generates a tabulated list of the content items, throughout the Confluence installation, that have been created by a specified Confluence user. The list includes all current pages, comments and spaces created by the user. Each item in the table is linked to its corresponding page, page comment or space dashboard.

Note that items for page comments contain a link to the page, followed by a second link to the comment itself, with these separated by a greater-than sign (>).

Using the Content by User macro

**To add the Content by User macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in *Autocomplete for links, files, macros and mentions*.

**To edit an existing macro:** Click the macro placeholder and choose *Edit*. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>yes</td>
<td>none</td>
<td>The Confluence username for a person who has created content. Parameter is unnamed in wikimarkup.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** content-by-user

**Macro body:** None.

**Storage format example**

```html
<ac:structured-macro ac:name="content-by-user">
    <ac:parameter ac:name="">
        <ri:user ri:userkey="12345678912345678912345678912345"/>
    </ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
{content-by-user:jsmith}
```

**Content Report Table Macro**

The Content Report Table macro displays a set of pages and blog posts in tabular format, based on the labels specified in the macro parameters.

**A working example**

Below is a working example of the Content Report Table macro, displaying content with the label 'LDAP'.

<table>
<thead>
<tr>
<th>Title</th>
<th>Creator</th>
<th>Modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connecting to LDAP or JIRA applications or Other Services via SSL</td>
<td>Nick Faiz</td>
<td>about 3 hours ago</td>
</tr>
<tr>
<td>Configuring the LDAP Connection Pool</td>
<td>Sarah Maddox [Atlassian]</td>
<td>about 3 hours ago</td>
</tr>
</tbody>
</table>
Synchronizing Data from External Directories Sarah Maddox [Atlassian] May 27, 2016


Configuring an SSL Connection to Active Directory Sarah Maddox [Atlassian] Sep 25, 2013

Using the Content Report Table Macro

To add the Content Report Table macro to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label(s) (labels)</td>
<td>Yes</td>
<td>None</td>
<td>This parameter is required. Specify one or more labels, separated by a comma. The macro will display the content tagged with any of the label(s) specified here.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For example, if you specify labels 'A' and 'B', the macro will display all pages that have the label 'A', and all pages that have the label 'B', and all pages that have both those labels.</td>
</tr>
</tbody>
</table>
Space(s) (spaces) | No | Specify one or more space keys, separated by a comma or a space. The macro will display only the content which belongs to the space(s) specified here.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.

Maximum Number of Pages (maxResults) | No | Define the maximum number of pages that the macro will show in a single set of results. If there are more pages to be shown, the macro will display a link labeled 'Find more results'. People viewing the page can choose the link to go to a search view, which shows all pages tagged with the specified label(s).

Which pages will appear? Before displaying the results, Confluence will sort them by the date the page was last modified. The most-recently created/updated pages will appear first.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** content-report-table

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="content-report-table">
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="DOC"/>
  </ac:parameter>
  <ac:parameter ac:name="labels">LDAP</ac:parameter>
  <ac:parameter ac:name="analytics-key">meeting-notes</ac:parameter>
  <ac:parameter ac:name="maxResults">5</ac:parameter>
</ac:structured-macro>
```

**Wiki markup**

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

**Contributors Macro**

The Contributors macro displays a list of Confluence users who have made a contribution of some type to a page. It can also be used to list watchers of the page.

The scope of this macro can be extended to include the immediate children or descendants of the specified page. The list of contributors can be based on people who have:

- authored or edited the page(s)
- contributed comments or added labels to the page(s), or
- are simply watching the page(s).

**Screenshot: Example list of Contributors**
Using the Contributors Macro

To add the Contributors macro to a page:
1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Contribution Type** (include)  | authors | Filters by either the type of contribution made to a page (and optionally its descendant pages), or the watches on the page. Contribution types are:  

- **authors** - includes people who created or have edited the page(s)
- **comments** - includes people who have added comments to the page(s)
- **labels** - includes people who have added labels to the page(s)
- **watches** - includes people who are watching the page(s).

You can specify one or more contribution types, separated by commas. |
| **Sort By** (order)              | count   | Specifies the criteria used to sort contributors. Sort criteria are:  

- **count** - sorts people based on the total number of contributions to the page(s)
- **name** - sorts people into alphabetical order
- **update** - sorts people based on the date of their last contribution to the page(s). |
| **Reverse Sort** (reverse)       | false   | Reverses the sort order of contributors in the list. Must be used in conjunction with the **Sort By** parameter. |
| **Maximum Number of Contributors** (limit) | no limit | Limits the number of contributors in the list. If a number is not specified, all contributors are included. |
| Display Format  | inline | Sets how the list of contributor’s names is formatted:  
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>• inline — a comma-separated list</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• list — a bullet list</td>
</tr>
<tr>
<td>Show Anonymous Contributions?</td>
<td>false</td>
<td>Sets whether to include those who contributed anonymously to a page.</td>
</tr>
<tr>
<td>(showAnonymous)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Count?</td>
<td>false</td>
<td>Sets whether to show the number of times each person made a contribution of the specified Contribution Type.</td>
</tr>
<tr>
<td>(showCount)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Last Contribution Time?</td>
<td>false</td>
<td>Sets whether to show the last time each person made a contribution of the specified Contribution Type.</td>
</tr>
<tr>
<td>(showLastTime)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page Name</td>
<td>current</td>
<td>Specifies the page to use when generating the list of contributors. If Page Name and Space(s) are left blank, the current page is assumed.</td>
</tr>
<tr>
<td>(page)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Label(s)</td>
<td>none</td>
<td>Filters the list of contributors to those who created the specified labels from a page. You can specify one or more labels, separated by commas.</td>
</tr>
<tr>
<td>(labels)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Space(s)</td>
<td>current</td>
<td>Specifies the space key of the Confluence space that contains the page set in Page Name or alternatively, specifies the spaces to search. Space keys are case-sensitive.</td>
</tr>
<tr>
<td>(spaces)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
| Content Type   | both pages and blog posts | Restricts the content type to use when generating the list of contributors:  
| (contentType)  |        | • pages — pages  
|                |        | • blogposts — blog posts.                               |
| Blog Post Date | none   | Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD. |
| (publishDate)  |        |                                                      |
| Include Page Hierarchy | specified page only | Specifies additional pages to include when generating the list of contributors:  
| (scope)        |        | • children — just the child pages of the specified page  
|                |        | • descendants — all descendants of the specified page. |
| Show Selected Pages | false | Sets whether to show a list of the pages used to generate the list of contributors. |
| (showPages)    |        |                                                      |
| Custom "None Found" Message | default message | Specifies the message to be used to override the default message that is displayed when no contributors are found. |
| (noneFoundMessage) |        |                                                      |
Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** contributors

**Macro body:** None.

**Storage format example**

This example specifies a content type of blog posts:

```xml
<ac:macro ac:name="contributors">
    <ac:parameter ac:name="limit">10</ac:parameter>
    <ac:parameter ac:name="spaces">ds,@personal</ac:parameter>
    <ac:parameter ac:name="reverse">true</ac:parameter>
    <ac:parameter ac:name="labels">chocolate,cake</ac:parameter>
    <ac:parameter ac:name="showPages">true</ac:parameter>
    <ac:parameter ac:name="noneFoundMessage">Oh dear, no contributors found</ac:parameter>
    <ac:parameter ac:name="showCount">true</ac:parameter>
    <ac:parameter ac:name="contentType">blogposts</ac:parameter>
    <ac:parameter ac:name="include">authors,comments,labels,watches</ac:parameter>
    <ac:parameter ac:name="mode">list</ac:parameter>
    <ac:parameter ac:name="showAnonymous">true</ac:parameter>
    <ac:parameter ac:name="order">update</ac:parameter>
    <ac:parameter ac:name="showLastTime">true</ac:parameter>
    <ac:parameter ac:name="publishDate">2012/06/30</ac:parameter>
</ac:macro>
```

**Wikimarkup example**

This example specifies a content type of blog posts:

```xml
{contributors:limit=10|spaces=ds,@personal|reverse=true|labels=chocolate,cake|showPages=true|noneFoundMessage=Oh dear, no contributors found|showCount=true|contentType=blogposts|include=authors,comments,labels,watches|mode=list|showAnonymous=true|order=update|showLastTime=true|publishDate=2012/06/30}
```

This example specifies a content type of pages:

```xml
{contributors:limit=10|spaces=ds,@personal|reverse=true|scope=descendants|labels=chocolate,cake|showPages=true|noneFoundMessage=Oh dear, no contributors found|showCount=true|contentType=pages|include=authors,comments,labels,watches|mode=list|showAnonymous=true|order=update|page=ds:Advanced Topics|showLastTime=true}
```

**Contributors Summary Macro**

The Contributors Summary macro displays a table of contribution-based statistics for a set of pages. These statistics can be grouped according to individual pages or individual contributors.
The default scope for this macro is an individual page, but this can be extended to include the immediate children or descendants of a specified page. The statistics cover the following types of contributions:

- edits to the page(s)
- comments added to the page(s)
- labels added to the page(s)
- people watching the page(s)

A simple example of the Contributors Summary macro is shown in the screenshot below. It lists statistics for the number of times each contributor has edited, added comments and added labels to this page.

Screenshot: Example Contributors Summary table of statistics

<table>
<thead>
<tr>
<th>User</th>
<th>Edits</th>
<th>Comments</th>
<th>Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sarah Maddox</td>
<td>2</td>
<td>2</td>
<td>0</td>
</tr>
<tr>
<td>Edwin Dawson</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Giles Gaskell</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Rosie Jameson</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Andrew Lui</td>
<td>2</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>Charles Miller</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Andrew Prentice</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
</tbody>
</table>

In this example, all default parameter settings are used. For more information about this macro’s parameters, refer to the Parameters section below.

Using the Contributors Summary Macro

To add the Contributors Summary macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group By (groupby)</td>
<td>contributors</td>
<td>Specifies the basis for grouping contribution-based statistics:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• contributors — group by the people who have contributed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• pages — group by the pages used to find contributors.</td>
</tr>
</tbody>
</table>
### Columns to Display (columns)

Sets the columns that should appear in the table. The statistics or type of information presented depends on the basis for grouping set with the **Group By** parameter. Statistics may be calculated for:

- **edits** — the number of times each contributor has edited the page(s) or the number of edits made to each page.
- **edited** — a list of the pages edited by each contributor or a list of contributors who have edited each page.
- **comments** — the number of times each contributor has added comments to the page(s) or the number of comments on each page.
- **commented** — a list of pages to which each contributor has added comments or a list of contributors who have commented on each page.
- **labels** — the number of times each contributor has added labels to the page(s) or the number of labels on each page.
- **labeled** — a list of pages to which each contributor has added labels or a list of contributors who have added a label to each page.
- **labellist** — a list of labels either added by each contributor or on each page.
- **watches** — the number of pages being watched by each contributor/person or the number of contributors/people watching each page.
- **watching** — a list of pages being watched by each contributor/person or a list of contributors/people watching each page.
- **lastupdate** — the last time each contributor made an update or when each page was last updated. Valid updates can include edit, comment or label modifications to a page.

One or more columns can be used.

### Sort By (order)

Sets the criterion used for sorting items in the table. The items sorted depend on the basis for grouping set with the **Group By** parameter. Sort criteria are:

- **edits** — sorts items in the table based on the total number of edits made, either by a contributor or to a page.
- **name** — sorts items in the table in alphabetical order, either by contributor or page name.
- **editTime** — sorts items in the table based on when the contributor last edited a page (or a specified set of pages) or when the page was last edited.
- **update** — sorts items in the table based on when the contributor last made any contribution to a page (or a specified set of pages) or when the page last had any contribution made to it.

### Reverse Sort (reverse)

Reverses the sort order of items in the table, as specified using the **Sort By** parameter. (Used only in conjunction with the **Sort By** parameter.)

### Maximum Number of Items (limit)

Limits the number of contributors or pages in the table to the value specified. If no number is specified, all items are included.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Anonymous Contributions? (showAnonymous)</td>
<td>false</td>
<td>Includes individuals who have made anonymous contributions to a page.</td>
</tr>
<tr>
<td>Show Zero Counts? (showZeroCounts)</td>
<td>false</td>
<td>Sets whether contributors or pages are included for which a calculated statistic is zero.</td>
</tr>
<tr>
<td>Page Name (page)</td>
<td>current</td>
<td>Sets the page for which to calculate the contribution-based statistics. If no values for Page Name and Space(s) are specified, the current page is assumed.</td>
</tr>
<tr>
<td>Label(s) (labels)</td>
<td>none</td>
<td>Restricts the contribution-based statistics to the specified labels only. You can specify one or more labels, separated by commas.</td>
</tr>
</tbody>
</table>
| Space(s) (spaces) | current | Specifies the space key of the Confluence space which contains the specified page name or alternatively, specifies a scope of spaces to search. Space keys are case-sensitive. This parameter also takes special values, including:  
  - @global — All site spaces.  
  - @personal — All personal spaces.  
  - @all — All spaces in your Confluence site.  
  You can specify one or more space keys or special values, separated by commas. If no Page Name and Label(s) are specified, all pages from the specified set of spaces are included. |
| Content Type (contentType) | both pages and blog posts | Restricts page types to either pages (pages) or blog posts (blogposts). If no value is specified in the Macro Browser, both pages and blog posts are included. Available values pages and blogposts. |
| Blog Post Date (publishDate) | none | Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD. |
| Include Page Hierarchy (scope) | specified page only | Includes either the immediate children or all descendants of the specified page. If no value is indicated in the Macro Browser, only the specified page is included. |

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** contributors-summary

**Macro body:** None.

**Storage format example**

This example specifies a content type of blog posts:
This example specifies a content type of pages:

```xml
<ac:structured-macro ac:name="contributors-summary">
   <ac:parameter ac:name="limit">10</ac:parameter>
   <ac:parameter ac:name="spaces">
      <ri:space ri:space-key="ds"/>
      <ri:space ri:space-key="@personal"/>
   </ac:parameter>
   <ac:parameter ac:name="reverse">true</ac:parameter>
   <ac:parameter ac:name="showAnonymous">true</ac:parameter>
   <ac:parameter ac:name="order">update</ac:parameter>
   <ac:parameter ac:name="labels">chocolate,cake</ac:parameter>
   <ac:parameter ac:name="columns">edits,comments,labels,lastupdate</ac:parameter>
   <ac:parameter ac:name="groupby">pages</ac:parameter>
   <ac:parameter ac:name="contentType">pages</ac:parameter>
   <ac:parameter ac:name="showZeroCounts">true</ac:parameter>
   <ac:parameter ac:name="publishDate">2012/06/07</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

This example specifies a content type of blog posts:

```
{contributors-summary:limit=10|spaces=ds,@personal|reverse=true|showAnonymous=true|order=update|scope=descendants|labels=chocolate,cake|columns=edits,comments,labels,lastupdate|groupby=pages|contentType=blogposts|showZeroCounts=true|publishDate=2012/06/07}
```

This example specifies a content type of pages:
Create from Template Macro

The Create from Template macro displays a button on a page, linked to a specific template. When someone clicks the button, the macro opens the editor, ready to add a new page, and adds content to the page based on the given template.

When adding the macro to the page, you can specify a blueprint or a user-created template in the macro. You will also specify the name of the button displayed, and the space in which the new page will appear.

Example

Screenshot: A page with three buttons, all displayed by the 'Create from Template' macro

Using the Create from Template Macro

To add the Create from Template macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Button Text</td>
<td></td>
<td>'Create from Template'</td>
<td>The description that people will see when viewing this macro on the page.</td>
</tr>
<tr>
<td>Template Name</td>
<td>None</td>
<td></td>
<td>Select the template or blueprint to base the new page on. Only global and</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>user-created templates for the current space appear (unless you have specified a different space in the 'Space Key' field).</td>
</tr>
</tbody>
</table>
Template Title  | Blank  | Specify a default title for pages created using this macro (optional). You can include @currentDate, @spaceName and @spaceKey variables in the title.
Space Key     | The space where the current page is located | Supply the unique space identifier (space key), to determine where the new page will be created when someone uses this macro to create a page.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** create-from-template

**Macro body:** None.

Parameters for storage format differ from those available in the macro browser as follows.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>templateId</td>
<td>Required for user-created templates</td>
<td>(None)</td>
<td>The ID of a user-created template. This is the unique identifier that Confluence assigns when you create a template. To find the ID of a template, edit the template and look at the URL in your browser. The template ID is given in the URL parameter named entityId.</td>
</tr>
<tr>
<td>blueprintModuleCompleteKey</td>
<td>Required for blueprints</td>
<td>(None)</td>
<td>The ID of a user-created template (for example, 299630593) or the qualified name of the add-on that defines the blueprint (for example, com.atlassian.confluence.plugins.e-shared-files-plugin:file-list-blueprint).</td>
</tr>
<tr>
<td>templateName</td>
<td>Yes</td>
<td>(None)</td>
<td>The ID of a user-created template (for example, 299630593) or the qualified name of the add-on that defines the blueprint (for example, com.atlassian.confluence.plugins.e-shared-files-plugin:file-list-blueprint).</td>
</tr>
<tr>
<td>buttonLabel</td>
<td>Yes</td>
<td>'Create from Template'</td>
<td>The description that people will seeing when viewing this macro on the page.</td>
</tr>
<tr>
<td>spaceKey</td>
<td>Yes</td>
<td>The space where the current page is located</td>
<td>The unique space identifier, to determine where the new page will be created when someone uses this macro to create a page.</td>
</tr>
<tr>
<td>Title</td>
<td>No</td>
<td>(None)</td>
<td>The title for pages created using this macro. You can include @currentDate, @spaceName and @spaceKey variables in the title. This title will override any title specified in a blueprint template.</td>
</tr>
</tbody>
</table>

**Storage format example**

This example specifies a user-created template:
This example uses a blueprint:

```xml
<ac:structured-macro ac:name="create-from-template">
  <ac:parameter ac:name="templateId">299630593</ac:parameter>
  <ac:parameter ac:name="buttonLabel">Blitz test</ac:parameter>
  <ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="DOCTHEME"/>
  </ac:parameter>
  <ac:parameter ac:name="templateName">299630593</ac:parameter>
</ac:structured-macro>
```

**Wiki markup**

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

### Create Space Button Macro

The Create Space Button macro displays a create space icon that links to the 'Create Space' page. To see this icon, viewers need the 'Create Space' permission which is assigned by a [site administrator](#).

#### Using the Create Space Button macro

**To add the Create Space Button macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in [Autocomplete for links, files, macros and mentions](#).

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

---

Created in 2016 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Icon Size<br>size<br>large Specify whether to use large or small icon. Available values:<br>• large<br>• small

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: create-space-button

Macro body: None.

The following additional parameters are available in storage format and wikimarkup.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>Natural size of icon (1:1 pixel ratio)</td>
<td>The width of the icon to be displayed, specified in pixels. Confluence will stretch or shrink the width of the icon to the number of pixels specified. Note: This parameter is not available via the macro browser.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>Natural size of icon (1:1 pixel ratio)</td>
<td>The height of the icon to be displayed, specified in pixels. Confluence will stretch or shrink the height of the icon to the number of pixels specified. Note: This parameter is not available via the macro browser.</td>
</tr>
</tbody>
</table>

Storage format example

```
<ac:structured-macro ac:name="create-space-button">
  <ac:parameter ac:name="size">small</ac:parameter>
  <ac:parameter ac:name="height">50px</ac:parameter>
  <ac:parameter ac:name="width">50px</ac:parameter>
</ac:structured-macro>
```

Wikimarkup example

```
{create-space-button:size=small}
{create-space-button:height=50px|width=50px}
```

Excerpt Include Macro

The Excerpt Include macro is used to display 'excerpted' (that is, a segment of) content from one page in another.

Before you can use this macro, the excerpt must have been defined using the Excerpt macro. Note that you can have more than one Excerpt Include macro on a page (although you can have only one Excerpt macro on a page).

Example
The paragraph below shows an example of an Excerpt Include macro, containing content from an excerpt which we have defined on the Excerpt Macro page. On the Excerpt Include macro below, we have set the options to show both the title of the page and the panel surrounding the content.

Define a part of a page as the page's 'excerpt' which can then be displayed in another page.

Using the Excerpt Include Macro

To add the Excerpt Include macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page Containing the Excerpt</strong> (default-parameter)</td>
<td>none</td>
<td>Type the name of the page that contains the excerpt to be displayed. You can use an excerpt from a page in the same space or another space in the same wiki. When you type the name of the page into the Excerpt Include macro dialog, Confluence will offer a list of matching pages, including those from other spaces. Alternatively, you can type the space key followed by a colon (:) and the page name, like this: SPACEKEY:Page name. This parameter is unnamed in wikimarkup.</td>
</tr>
<tr>
<td><strong>Remove Surrounding Panel</strong> (nopanel)</td>
<td>false</td>
<td>Determines whether Confluence will display a panel around the excerpted content. The panel includes the title of the page containing the excerpt, and the border of the panel. By default, the panel and title are shown.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** excerpt-include

**Macro body:** None.

**Storage format example**
Excerpt Macro

The Excerpt macro is used to mark a part of a page's content for re-use. Defining an excerpt enables other macros, such as the Excerpt Include and Blog Posts macros, to display the marked content elsewhere. You can only define one excerpt per page. In other words, you can only add the Excerpt macro once to a page.

Using the Excerpt Macro

To add the Excerpt macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

To add reusable content to the macro:

1. Add your content inside the Excerpt macro placeholder.
2. Choose the macro placeholder to see the options panel, and select the option to Display on new line or to Display inline. The default is to display the content of the macro on a new line. If you choose the inline option, the content of the macro will form part of the same paragraph as the text preceding and following it. Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused.

Screenshot: The Excerpt macro placeholder and options panel

Parameters
Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Excerpted Content (hidden)</td>
<td>false</td>
<td>Controls whether the page content contained in the Excerpt macro placeholder is displayed on the page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** excerpt

**Macro body:** Accepts rich text.

The following additional parameter is available in storage format and wikimarkup. It performs the same function as the options panel in the editor.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>atlassian-macro-output-type</td>
<td>No</td>
<td>BLOCK</td>
<td>Determines whether the content of the Excerpt macro body is displayed on a new line or inline.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• BLOCK – Displays the content of the macro on a new line.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• INLINE – Displays the the content of the macro as part of the same paragraph as the text preceding and following it.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused.</td>
</tr>
</tbody>
</table>

**Storage format example**

```
<ac:structured-macro ac:name="excerpt">
  <ac:parameter ac:name="hidden">true</ac:parameter>
  <ac:parameter ac:name="atlassian-macro-output-type">BLOCK</ac:parameter>
  <ac:rich-text-body>
    <p>This is the <strong>text</strong> I want to reuse in other pages. This text is inside an Excerpt macro.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Wikimarkup example**

```
|<p>This is the <strong>text</strong> I want to reuse in other pages. This text is inside an Excerpt macro.</p>|
|<ac:structured-macro ac:name="excerpt" ac:parameter="hidden" ac:parameter="atlassian-macro-output-type" ac:rich-text-body>|
```
Expand Macro

The Expand macro displays an expandable/collapsible section of text on your page.

Here is an example:

Expand me...

This text is hidden until you expand the section.

Using the Expand Macro

To insert the Expand macro into a page using the macro browser:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Click here to expand...</td>
<td>Defines the text that appears next to the expand/collapse icon.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: expand

Macro body: Accepts rich text.

Storage format example

```
<ac:structured-macro ac:name="expand">
  <ac:parameter ac:name="title">Expand me...</ac:parameter>
  <ac:rich-text-body>
    This text is hidden until you expand the section.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```
Wikimarkup example

{expand:This is my message}
This text is _hidden_ until you expand it.
{expand}

Notes

- **Text is expanded in PDF and HTML exports.** When you export the page to PDF or HTML, the text between the macro tags is expanded so that readers can see it in the PDF and HTML versions of the page.
- **Nesting your Expand macros.** You can put one Expand macro inside another, and Confluence will correctly show and hide the contents of all Expand macros, including the nested ones.

Favorite Pages Macro

Use the Favorite Pages macro to list the pages you've saved for later on a Confluence page. You can also get to your saved pages from the Dashboard.

**Screenshot: The Favorite Pages Macro in Confluence**

This is the Favourite Pages macro

**Favourite Pages**

Displaying pages recently added to your favourites list.

- Why I loved Angry Nerds (Angry Nerds)
- Which nerd are you? (Angry Nerds)
- Our new logo (Angry Nerds)

Using the Favorite Pages Macro

**To insert the favorite pages macro into a page using the Macro Browser:**

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

There are no parameters for this macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** favpages

**Macro body:** None.

**Parameters:** None.

**Storage format example**
Gadget Macro

Gadgets are small applications that can offer dynamic content. They are typically served from a web application server and can be re-used in many other web applications. In Confluence, use the Gadget macro to add gadgets to pages or blog posts.

Confluence comes bundled with a few of its own gadgets that you can add to your pages or blog posts. However, you can access additional gadgets in this list if your Confluence Administrator has:

- Installed additional gadgets in Confluence (typically as a Confluence plugin) or
- Registered gadgets served from an external web application or website (such as those from a JIRA application).

Unlike other macros, the name of each gadget macro is unique and follows the convention "<gadget-name> macro", where <gadget-name> is the name supplied by the gadget itself.

Inserting gadgets into a Confluence page or blog post

**To add a gadget to a page:**

1. Edit your page or blog post.
2. Choose Insert > Other Macros.
3. Click External Content to see a list of gadgets configured for use in your Confluence installation. (Some Confluence macros like the JIRA Issues, RSS Feed, and Widget Connector macros also appear in this category because they can also access external content.)
4. Click the desired gadget to access its parameters and properties. Almost all gadgets allow you to set basic parameters (listed below), which appear in the macro dialog. Some gadgets also have their own set of parameters, that can only be set in the gadget itself. You can use the preview in the macro browser to access them.
5. Set the parameters to your requirements.
6. Click Refresh to preview your changes.
7. Click Insert to add the gadget to the page.

Editing gadgets on a Confluence page or blog post

**To edit an existing gadget on a page or blog post:**

1. Edit your page or blog post.
2. Click the Gadget macro placeholder and choose Edit (or double-click the placeholder).
3. Set the gadget's parameters to your requirements.
4. Click Refresh to preview your changes.
5. Save the gadget.

**Standard gadget parameters**

Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the macro
dialog. Each gadget may also have its own set of parameters, which appear on the left of the macro dialog.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Width** | 450 pixels | Set the width of the gadget, using one of the following conventions:  
  - Width in pixels, using px or plain numbers. For example, `500px` or `500`.  
  - A percentage of the page width, using %. For example, `50%`.  
  - Automatic resizing of the gadget to fit 100% of the page width: `auto` |
| **Border** | true | Places a thin grey border around the gadget. |

Contents of a Gadget macro

In the addition to the standard parameters, the gadget macro contains 'parameter-like' content, which represents specific property settings that are particular to each gadget. Hence they are not documented here. Typically, this content would only be changed by customizing the gadget's default properties using the macro browser.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** gadget

**Macro body:** None.

The following additional parameters are available in storage format and wikimarkup.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>url</td>
<td>Yes</td>
<td>(none)</td>
<td>This is the location of the gadget specification (XML file).</td>
</tr>
<tr>
<td>preferences</td>
<td>No</td>
<td>(Gadget-dependent)</td>
<td>Specific property settings that are particular to each gadget.</td>
</tr>
</tbody>
</table>

**A note about editing a gadget's properties (preferences) in markup:** It is possible to edit the values of these properties directly in the wiki markup or storage format. However, this will allow the entry of invalid values. If a gadget property supports a certain set of values, the macro browser will restrict the user to selecting only valid values for that property. For that reason, we recommend that you use the macro browser to edit a gadget's properties.

**Storage format example**

This example shows the Confluence Page gadget:
This example shows the Confluence News gadget:

```xml
<ac:structured-macro ac:name="gadget">
    <ac:parameter ac:name="url">rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-news-gadget/gadgets/confluence-news-gadget.xml</ac:parameter>
    <ac:parameter ac:name="preferences"/>
</ac:structured-macro>
```

**Wiki markup example**

This example shows the Confluence Page gadget:

```
{gadget:width=500|border=false|url=rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-page-gadget/gadgets/confluence-page-gadget.xml} {gadget}
```

This example shows the Confluence News gadget:

```
{gadget:url=rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-news-gadget/gadgets/confluence-news-gadget.xml} {gadget}
```

**Gallery Macro**

The Gallery macro displays a collection of thumbnail images in a table, based on the images attached to a
Confluence page. When viewing the page, a user can click a thumbnail image to zoom into a screen-sized image and then view the images as a slide show.

Overview:

- The images shown in the gallery are taken from the files attached to the Confluence page. You can also specify a different page where the attachments are located. For information about attaching images to a page, see Upload Files.
- The captions below the images are drawn from the comments on the attachments. For information about adding comments to attachments, see Upload Files.
- By default, the gallery will include all the images attached to the page. You can also exclude or include images using parameters.
- You can sort your images into a particular order.
- You can specify a title for the gallery and also configure how many columns you want for the table in which your images are displayed.

*Illustration: Live example of the Gallery macro*

*Some office photos, and a waterfall*
Using the Gallery macro

To insert the Gallery macro onto a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

The full list of parameters is shown in the following table. If the name of an attached file or page contains a comma, you can refer to it in the relevant parameters below by enclosing it in single or double quotes, for example "this,that.jpg", theother.png

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gallery Title (title)</td>
<td>Nothing</td>
<td>Specify a title for your gallery.</td>
</tr>
<tr>
<td>Number of Columns (columns)</td>
<td>4</td>
<td>Specify the number of columns for your table.</td>
</tr>
<tr>
<td>Images to Exclude (exclude)</td>
<td>No exclusions. Include all the pictures on the page.</td>
<td>The gallery will ignore any pictures specified. You can specify more than one picture, separated by commas. Note: The filename and filetype for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognized as 'my picture.png'.</td>
</tr>
<tr>
<td>Include these Images Only (include)</td>
<td>Include all the pictures on the page.</td>
<td>If you specifically include one or more pictures, the gallery will show only those pictures. You can specify more than one picture, separated by commas. Note: The filename and filetype for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognized as 'my picture.png'.</td>
</tr>
</tbody>
</table>
### Exclude Images with these Labels
(\texttt{excludeLabel})

No exclusions. Include all the pictures on the page.

The gallery will ignore any pictures that have the specified label. You can specify more than one label, separated by commas. For information on labeling the attachments, see [Add, Remove and Search for Labels](#).

### Include Images with these Labels Only
(\texttt{includeLabel})

None. The images are not filtered by label.

Filters the images to display, based on a list of labels. If you wish to enter more than one label, separate the labels with commas. Confluence will show only images that have all the labels specified. (The match is an AND, not an OR.) For information on labeling the attachments, see [Add, Remove and Search for Labels](#).

### Use Images in these Pages
(\texttt{page})

If no page is specified, the gallery macro displays the images attached to the page on which the macro is used.

Specify the title of the page which contains the images you want displayed. You can specify more than one page name, separated by commas. To specify a page in a different space, use the following syntax: \texttt{SPACEKEY:Page Title}

### Sort Images By
(\texttt{sort})

None. The sort order is unspecified and therefore unpredictable.

Specify an attribute to sort the images by. Sort order is ascending, unless you select the \texttt{Reverse Sort} parameter (see below). Options are:

- \texttt{name} – file name.
- \texttt{comment} – comment linked to the attached file.
- \texttt{date} – date/time last modified.
- \texttt{size} – size of the attached file.

### Reverse Sort
(\texttt{reverse})

Off. Sort order is ascending

Used in combination with the \texttt{Sort Images By} parameter above. Use \texttt{Reverse Sort} to reverse the sort order, from ascending to descending.

Available values in storage format and wikimarkup:

- \texttt{true} – Sort order is descending.
- \texttt{false} – Sort order is ascending.

---

### Image file formats

You can attach image files of any format to a page. Confluence supports the following image formats in the Gallery macro and when displaying an image on a page:

- \texttt{gif}
- \texttt{jpeg}
- \texttt{png}
- \texttt{bmp} (depending on browser support)

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** gallery

**Macro body:** None.

**Storage format example**
Global Reports Macro

The Global Reports macro displays a list of links to some reports about content on your site. These reports include a list of new or updated pages, orphan pages, undefined pages, and RSS feeds for new pages and blog posts.

Screenshot: The Global Reports macro

Using the Global Reports Macro

To add the Global Reports macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters
Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width of Table</td>
<td>99%</td>
<td>Specify the width of the table in which the links are displayed, as a percentage of the window width.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** global-reports

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="global-reports">
  <ac:parameter ac:name="width">50%</ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
{global-reports:width=50%}
```

**HTML Include Macro**

The HTML Include macro allows you to include the contents of an external HTML file (a webpage) in a Confluence page.

**HTML macros are disabled by default**

The HTML macro will only be available if it has been enabled by an administrator. Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks.

**Using the HTML Include Macro**

**To insert the HTML Include macro into a page:**

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
### HTML Page's URL

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML Page's URL (url)</td>
<td>Yes</td>
<td>None</td>
<td>The URL of the page to include.</td>
</tr>
</tbody>
</table>

### Enabling the HTML Include Macro

The HTML Include macro is disabled by default. You'll need Confluence Administrator or System Administrator permissions to enable this macro.

⚠️ Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks. You should only turn on these macros if you trust all your users not to attempt to exploit them. We strongly recommend leaving this macro disabled if you allow self-signed up or anonymous users to create content.

### To enable the HTML Include macro:

1. Go to [Add-ons](#).
2. Select System from the drop down and search for the Confluence HTML Macros add-on.
3. Expand the add-on and enable the html-include (html-include-xhtml) module.

Administrators can also choose to use the whitelist to restrict URLs that can be displayed in the HTML Include macro.

### Troubleshooting

- Administrators can define a whitelist of trusted URLs. If a URL is not in the whitelist, you will see an error message in the HTML Include macro.
- You can only use the HTML Include macro for pages with absolute links. If you use the macro to include an HTML page that has relative links, you will see a 'Page Not Found' error. See [CONF-6567](#) - HTML Include macro should rewrite relative links to point to remote site.

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** html-include

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="html-include">
  <ac:parameter ac:name="url">
    <ri:url ri:value="http://www.example.com"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**
HTML Macro

The HTML macro allows you to add HTML code to a Confluence page.

### HTML macros are disabled by default

The HTML macro will only be available if it has been enabled by an administrator. Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks.

#### Using the HTML Macro

**To add the HTML macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

There are no parameters for this macro.

Enter the HTML code into the body of the macro placeholder.

#### Enabling the HTML Macro

The HTML macro is disabled by default. You'll need Confluence Administrator or System Administrator permissions to enable this macro.

⚠️ Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks. You should only turn on these macros if you trust all your users not to attempt to exploit them. We strongly recommend leaving this macro disabled if you allow self-signed up or anonymous users to create content.

**To enable the HTML macro:**

1. Go to
   > Add-ons.
2. Select System from the drop down and search for the Confluence HTML Macros add-on.
3. Expand the add-on and enable the html (html-xhtml) module.

#### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** html

**Macro body:** Text, consisting of HTML code.

**Parameters:** None.

**Storage format example**

```html
<ac:structured-macro ac:name="html">

  <ac:plain-text-body><![CDATA[<a href="http://www.atlassian.com">Click here</a> to see the <b>Atlassian</b> website.]]></ac:plain-text-body>

</ac:structured-macro>
```
IM Presence Macro

The IM Presence macro indicates graphically when a contact is signed into an Instant Messaging (IM) service. The IM Presence macro appears as a small icon on the page.

Using the IM Presence Macro

To add the IM Presence macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User ID/Screen Name</td>
<td>Identify the user by their ID, account name or screen name.</td>
</tr>
</tbody>
</table>
| Service (service) | aim – AOL Instant Messenger  
gtalk – Google Talk  
icq – ICQ  
jabber – Jabber  
msn – MSN Instant Messenger  
sametime – IBM Lotus Sametime  
skype – Skype. Note: Skype requires 'Show my status on the web' to be checked under 'Privacy' preferences  
skypeme – Skype  
wildfire – Openfire Server  
yahoo – Yahoo! Messenger |
| Show User ID (showid) | Shows or hides the User ID of the contact.                              |
Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** im

**Macro body:** None.

**Storage format example**

```html
<ac:structured-macro ac:name="im">
  <ac:parameter ac:name="showid">false</ac:parameter>
  <ac:parameter ac:name="service">skype</ac:parameter>
  <ac:parameter ac:name="">MySkypeName</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{im:MySkypeName|service=skype|showid=false}
```

Include Page Macro

You can use the Include Page macro to display the contents of one Confluence page or blog post in another page or blog post.

**To add the Include Page macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2016 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
This is the name of the Confluence page or blog post that you want to include in the current page. Start typing a page title, and Confluence will suggest matching pages from the current space and other spaces.

Alternatively you can specify the page as follows:

- If the page or blog post is located in another space, add the space key and a colon in front of the page name. For example, DOC:My page name. The space key is case sensitive.
- To include a blog post, specify the date as well as the title of the blog post. For example: /2010/12/01/My blog post.
- You can include pages from personal spaces using ~username as the space key, where ‘username’ is the person's username. For example, ~jsmith:My page name.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** include

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="include">
  <ac:parameter ac:name=""/>
  <ac:link>
    <ri:page ri:content-title="My chocolate page" ri:space-key="DOC"/>
  </ac:link>
</ac:structured-macro>
```

**Wiki markup example**

```
{include:DOC:My chocolate page}
```

**Notes**

- If you want to include part of a page rather than the whole page, use the Excerpt and Excerpt Include macros.
- To display a page’s contents, you need ‘View’ permission for that page. Similarly, people who view the page will need ‘View’ permissions for the embedded page as well as the page into which it is embedded. See space permissions or contact your Confluence space administrator for more information.
- If you want to embed an external page into a Confluence page, you need the HTML Include Macro.

**Sample Include Page**

Start of sample page content

Info, Tip, Note, and Warning Macros

The Info, Tip, Note, and Warning macros allow you to highlight information on a Confluence page. They create a colored box surrounding your text, like this:

![Info macro example](example.png)
This text is rendered inside the info macro.

![Note macro example](example.png)
This text is rendered inside the note macro.

![Tip macro example](example.png)
This text is rendered inside the tip macro.

![Warning macro example](example.png)
This text is rendered inside the warning macro.

To add an Info, Tip, Note, or Warning Macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title (title)</td>
<td>none</td>
<td>The title of the box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>Show information/tip/Exclamation Mark/Warning Icon (icon)</td>
<td>true</td>
<td>If &quot;false&quot;, the icon will not be displayed.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** info/tip/note/warning

**Macro body:** Accepts rich text.

**Storage format example**

The following example shows the info macro with all parameters and a body:
Wiki markup example

```
{info:title=This is my title|icon=false}
This is _important_ information.
{info}
```

JIRA Chart Macro

If your Confluence site is connected to a JIRA application, you can display issues as charts on Confluence pages. You can connect Confluence to any JIRA application, including JIRA Software and JIRA Service Desk.

Before you can use this macro, your Confluence and JIRA applications must be connected via Application Links. People viewing the page will see charts for publicly accessible issues. If your JIRA application has restricted viewing (that is, people need permission to view issues) then they’ll need to authenticate before seeing the charts. This macro is compatible with JIRA 5.x and later.

Adding the JIRA Chart macro to a page

**To add a JIRA chart to your page:**

1. In the editor choose Insert > Other macros > JIRA Chart.
2. Choose the type of report you want to create (for example Pie, Created vs Resolved)
3. Select your JIRA server.
   
   If you have multiple JIRA servers linked to Confluence the drop down will default to the primary application link.
4. Search for issues - you can enter the query in JQL or paste a JIRA URL directly into the search field.
5. Choose Preview to generate the chart.
6. Choose Display Options to further control how your chart appears.
7. Choose Insert.

To find out more about searching for issues see Displaying issues using JIRA Query Language (JQL).

*Screenshot: The JIRA Chart Macro in the macro browser*
Pie chart

Pie charts can be used to report on issue status, priority, assignee and more.

To further control how this chart appears on your page choose **Display options**:

- **Chart by** - select the field you want to segment the pie chart by such as:
  - Status
  - Fix version
  - Assignee name
  - Priority
  - Component
  - Issue type
- **Width** - define the total width of the chart area. You can enter values in pixels, percent or leave blank to auto fit.
- **Show border** - add a border around the chart area.
- **Show chart information** - include a text summary under the chart with the total issues count and chart by value.

Created vs Resolved chart

Created vs Resolved charts can be used to show the difference between the number of issues created versus the number of issues resolved over time.

To further control how this chart appears on your page choose **Display options**:

- **Period** - choose a time frame to report by (week, month, quarter etc).
- **Days previously** - the total number
of days to report on (counting back from today).
- **Cumulative totals** - choose to progressively add totals or report individual values for each period.
- **Show unresolved trend** - add a subplot showing unresolved issues over time.
- **Show versions** - indicate version release dates as a vertical line on the chart.
- **Width** - define the total width of the chart area. Enter values in pixels, percent or leave blank to auto fit.
- **Show border** - add a border around the chart area
- **Show chart information** - include a text summary under the chart with the total issues count and chart by value.

### Two Dimensional Chart

Two Dimensional Charts can be used to show issue statistics in a matrix. You can configure the X and Y axes to display these issue fields:
- Status
- Priority
- Assignee
- Fix version
- Component
- Issue type.

For example you could use the chart to show issue types by status (as shown above).

To configure the chart axes choose **Display options**:
- **X Axis** - the issue field to display on the X axis (columns).
- **Y Axis** - the issue field to display on the Y axis (rows).
- **Rows to display** - the maximum number to display in the chart.

### Disabling the JIRA Chart macro

The functionality is provided by an add-on (plugin) called ‘JIRA Macros’. This macro is also used for the JIRA Issues macro. To make the macro unavailable on your site, you can disable the add-on. See Disabling and enabling add-ons.

### Notes

**HTTPS**: The JIRA Chart macro can access a JIRA site running under SSL provided the Confluence server is configured to accept the JIRA SSL certificate. See Connecting to LDAP or JIRA applications or Other Services via SSL.

**Authentication**: If the query includes issues that require authentication (issues that are not visible to anonymous users in JIRA), users will be prompted to authenticate to view charts on the Confluence page.

In order to search for issues in the macro browser you may need to authenticate. With JIRA 5.x you will be able to search for unrestricted issues as an anonymous user, however with JIRA 6.x you must be
authenticated to search for any issues.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** jirachart

**Macro body:** None.

The following parameters are available in storage format. Note that some parameters are only available for specific chart types.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Chart type</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>chartType</td>
<td>all</td>
<td>Yes</td>
<td>Pie</td>
<td>Type of chart to display. Chart types include:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• pie</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• createdvsresolved</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• twodimensional</td>
</tr>
<tr>
<td>showinfor</td>
<td>all</td>
<td>No</td>
<td>False</td>
<td>Displays text information about the data below the chart. Includes the Total value and the Chart By value.</td>
</tr>
<tr>
<td>jql</td>
<td>all</td>
<td>Yes</td>
<td></td>
<td>JQL query for the chart to display.</td>
</tr>
<tr>
<td>width</td>
<td>all</td>
<td>600</td>
<td>(blank)</td>
<td>This is the total width of the chart area. Width can be entered in pixels, percent or left blank to fit to the available space.</td>
</tr>
<tr>
<td>border</td>
<td>all</td>
<td>No</td>
<td>False</td>
<td>Displays a border around the chart area.</td>
</tr>
<tr>
<td>statType</td>
<td>pie</td>
<td>Yes</td>
<td>Statues</td>
<td></td>
</tr>
<tr>
<td>------------------</td>
<td>--------------------------</td>
<td>-----</td>
<td>-------------------------------</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>The JIRA field to segment the</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>pie chart by:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- statuses - displays a</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>breakdown of issues by Status</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- allFixfor - breakdown</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>of issues by chart by all Fix</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Versions (useful if issues</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>have more than one fix version).</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- assignees - breakdown of</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>issues by the Assignee name.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- priorities - breakdown of</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>issues by Priority.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- components - breakdown of</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>issues by Component.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- issuetype - breakdown of</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>issues by Issue Type.</td>
<td></td>
</tr>
<tr>
<td>periodName</td>
<td>createdvsresolved</td>
<td>Yes</td>
<td>Time frame to report by.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Options are hourly, daily,</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>weekly, monthly, quarterly</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>and yearly.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>There is a limit to the</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>number of days the report can</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>generate for each period.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For example you can report</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>hourly for a maximum of ten</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>days, and report daily for a</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>maximum of 300 days.</td>
<td></td>
</tr>
<tr>
<td>daysprevious</td>
<td>createdvsresolved</td>
<td>Yes</td>
<td>False</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Number of days, counting</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>backwards from today, to</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>include in the report.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Note that maximum days</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>limits might apply depending</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>on the Period you have chosen.</td>
<td></td>
</tr>
<tr>
<td>isCumulative</td>
<td>createdvsresolved</td>
<td>No</td>
<td>False</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>If true, the chart will</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>progressively add data. If</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>false the chart will show</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>individual values for each</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>period.</td>
<td></td>
</tr>
<tr>
<td>showUnresolvedTrend</td>
<td>createdvsresolved</td>
<td>No</td>
<td>False</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Include a subplot showing</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>unresolved issues trend.</td>
<td></td>
</tr>
<tr>
<td>versionLabel</td>
<td>createdvsresolved</td>
<td>No</td>
<td>None</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Indicate version release</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>dates with a vertical line.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Values include major, all and</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>none.</td>
<td></td>
</tr>
</tbody>
</table>
### Storage format example - Pie Chart

Example chart by Issue Type - note that Confluence will insert the `server` and `serverId` parameters, based on settings in Application Links:

```html
<ac:structured-macro ac:name="jirachart">
  <ac:parameter ac:name="chartType">pie</ac:parameter>
  <ac:parameter ac:name="statType">issuetype</ac:parameter>
  <ac:parameter ac:name="showinfo">true</ac:parameter>
  <ac:parameter ac:name="jql">project%20%3D%20CONF%20and%20fixVersion%20in%20('5.3')</ac:parameter>
  <ac:parameter ac:name="width">600</ac:parameter>
  <ac:parameter ac:name="server">JAC</ac:parameter>
  <ac:parameter ac:name="serverId">144880e9-a353-312f-9412-e5028e8166fa</ac:parameter>
  <ac:parameter ac:name="border">true</ac:parameter>
</ac:structured-macro>
```

### Storage format example - Created vs Resolved

Example chart - note that Confluence will insert the `server` and `serverId` parameters, based on settings in Application Links:

```html
<ac:structured-macro ac:name="jirachart">
  <ac:parameter ac:name="chartType">pie</ac:parameter>
  <ac:parameter ac:name="statType">issuetype</ac:parameter>
  <ac:parameter ac:name="showinfo">true</ac:parameter>
  <ac:parameter ac:name="jql">project%20%3D%20CONF%20and%20fixVersion%20in%20('5.3')</ac:parameter>
  <ac:parameter ac:name="width">600</ac:parameter>
  <ac:parameter ac:name="server">JAC</ac:parameter>
  <ac:parameter ac:name="serverId">144880e9-a353-312f-9412-e5028e8166fa</ac:parameter>
  <ac:parameter ac:name="border">true</ac:parameter>
</ac:structured-macro>
```
Storage format example - Two Dimensional Chart

Example chart - note that Confluence will insert the server and serverId parameters, based on settings in Application Links:

```
<p><ac:structured-macro ac:name="jirachart">
  <ac:parameter ac:name="isAuthenticated">true</ac:parameter>
  <ac:parameter ac:name="chartType">twodimensional</ac:parameter>
  <ac:parameter ac:name="ystattype">issuetype</ac:parameter>
  <ac:parameter ac:name="sortBy" /></ac:structured-macro>
</p>
```

JIRA Issues Macro

If your Confluence site is connected to a JIRA application, you can create and display JIRA issues on Confluence pages. You can connect Confluence to any JIRA application, including JIRA Software and JIRA Service Desk.

Before you can use this macro, your Confluence and JIRA application must be connected via Application Links. People viewing the page will see the publicly accessible issues from the JIRA site. If your JIRA site has restricted viewing (that is, people need permission to view issues) then they will need to authenticate before seeing the restricted issues. See more about restricted JIRA issues below.
What you can do with the JIRA Issues macro

Using the JIRA Issues macro, you can:

- Display a list of issues on your page, based on a JIRA Query Language (JQL) search, filter or URL.
- Display a single issue.
- Display a count of issues.
- Create new issues and display the issues on your page without leaving Confluence.

Adding and updating the JIRA Issues macro – an overview

Quick guide to using the macro on a Confluence page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Screenshot: Example of JIRA issues macro on a Confluence page

Displaying issues via a JIRA Query Language (JQL) search

You can use the macro to display a table of issues on your page, based on the results of a search using JIRA Query Language (JQL).

JQL is a simple query language that is similar to SQL. A basic JQL query consists of a field, followed by an operator (such as = or >), followed by one or more values or functions.

Examples:

- The following query will find all issues in the 'TEST' project:

  ```
  project = "TEST"
  ```

- The following query will find all issues in the 'documentation' component of the 'CONF' project:

  ```
  project = CONF and component = documentation
  ```
For more information about JQL syntax, see Advanced searching in the JIRA Software documentation.

**To display a table of issues based on a JQL search:**

1. Insert the JIRA Issues macro onto your Confluence page, as described above.
2. Choose a JIRA server next to the Search button.
3. If prompted, log in to the JIRA server.
4. Enter the JQL query into the Search box.
5. Choose Search.
6. If you want to customize the display, choose Display options and adjust the columns and number of issues that will appear in your table of issues.
7. Choose Insert.

Screenshot: Display options in the JIRA Issues macro browser.

### Displaying issues via a JIRA URL

You can paste any of the following JIRA application URLs into the JIRA Issues macro. Confluence will immediately convert the URL to a JQL search.

- Any URL for an issue search or filter.
- A URL for a single issue.
- The URL of the XML view of a search.

**Auto-convert:** You can paste URLs directly into the Confluence editor (without calling up the macro browser). Confluence will automatically convert the URL into a JIRA Issues macro.

### Displaying a single issue, or selected issues

**To display a single JIRA issue,** choose one of the following methods:

- Paste the URL of the issue directly onto the Confluence page. (There is no need to use the macro browser.) Confluence will auto-convert the link to a JIRA Issues macro.
- Or: Add the JIRA issues macro to the page as described above, and choose Recently Viewed to see the issues you have visited recently. Select an issue and choose Insert.
- Or: Add the JIRA issues macro to the page as described above, and paste the issue URL into the search box in the macro browser.
- Or: Add the JIRA issues macro to the page, define your search criteria in the macro browser via JQL as described above, then select the check box next to the issue in the search results, within the macro browser.

You can choose to show just the issue key, or the issue key and a summary. Select the macro placeholder and choose Show Summary or Hide Summary.
To display a subset of JIRA issues from your search results:

1. Add the JIRA issues macro to the page.
2. Define your search criteria in the macro browser via JQL, as described above.
3. Select the check boxes next to the required issues in the search results, within the macro browser.

Screenshot: Selecting a subset of issues to display

Displaying a count of issues

You can choose to display the number of issues returned by your search, rather than a table of issues. The JIRA Issues macro will display a count of issues, linked to the search in your JIRA application.

Screenshot: The JIRA Issues macro displaying an issue count on a Confluence page

To display an issue count:

1. Add the JIRA Issues macro to the page.
2. Define your search criteria in the macro browser via JQL, as described above.
3. Choose **Display options**, then choose **Total issue count** next to ‘Display options’ in the macro browser.
4. Choose **Insert**.

Creating a new issue

While editing a Confluence page, you can create an issue in JIRA and display it on your Confluence page, without leaving the Confluence editor.

To create an issue and add it to your page:
1. Add the JIRA Issues macro to the page, as described above.
2. Choose Create New Issue.
3. Supply the information about your JIRA server, project, and issue, as prompted.
4. Choose Insert.

Confluence will send a request to your JIRA application, to create the issue, then display the newly created issue on your page.

Limitations

The JIRA Issues macro will notify you if it is unable to create an issue in the selected project. This may be because the project has a required field, field configuration or other customization that is not supported by the JIRA Issues macro. In this situation you will need to create the issue directly in your JIRA application.

Configuring application links to display restricted issues

Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links.

If the JIRA site allows anonymous users to view issues, you must configure an application link, but there’s no need to configure any incoming or outgoing authentication between the JIRA application and Confluence. People viewing the Confluence page will see the publicly accessible issues.

If your JIRA site has restricted viewing, or if some projects or issues are restricted to viewing by certain people, then people will be prompted to Log in & Approve before seeing the restricted issues.

Rendering HTML from JIRA applications

Formatted fields from JIRA can be displayed in Confluence if you set up a Confluence-to-JIRA application link. Otherwise, such formatted fields will be escaped within the output of the JIRA issues macro. This is to prevent the possibility of malicious HTML being served by an untrusted JIRA server. The most likely field where you will notice this is in the description field.

This example shows how a description column may be displayed in JIRA:

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is</td>
</tr>
<tr>
<td>- the description</td>
</tr>
<tr>
<td>- of my issue</td>
</tr>
</tbody>
</table>

If there is no application link between JIRA and Confluence, the description will appear in the JIRA issues macro like this:

```
<p>This is<ul><li>the description</li><li>of my issue</li></ul></p>
```

Disabling the JIRA Issues macro

The functionality is provided by an add-on (plugin) called ‘JIRA Macros’. To make the macro unavailable on your site, you can disable the add-on. See Disabling and enabling add-ons.

Notes

HTTPS: The JIRA Issues macro can access a JIRA application running under SSL provided the Confluence server is configured to accept the JIRA SSL certificate. See Connecting to LDAP or JIRA applications or Other Services via SSL.

Custom fields can be added as columns to the table simply by using the name of the field with no quotes. Earlier versions of the macro required you to use the custom field id, e.g. customfield_10100.
Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: jiraissues

Macro body: None.

Note: A number of additional parameters that are not available via the macro browser are available in storage format and wikimarkup.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| anonymous      | No       | false   | If this parameter is set to 'true', your JIRA application will return only the issues which allow unrestricted viewing. That is, the issues which are visible to anonymous viewers. If this parameter is omitted or set to 'false', then the results depend on how your administrator has configured the communication between the JIRA application and Confluence. By default, Confluence will show only the issues which the user is authorized to view.  
  **Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The macro browser does not offer this parameter. |
| baseurl        | No       | The value of the 'url' parameter | If you specify a 'baseurl', then the link in the header, pointing to your JIRA application, will use this base URL instead of the value of the 'url' parameter. This is useful when Confluence connects to JIRA with a different URL from the one used by other users. |
| columns        | No       | By default, the following columns are shown:  
  - type  
  - key  
  - summary  
  - assignee  
  - reporter  
  - priority  
  - status  
  - resolution  
  - created  
  - updated  
  - due | A list of JIRA column names, separated by semi-colons (;). You can include any columns recognized by your JIRA application, including custom columns. |
| count          | No       | false   | If this parameter is set to 'true', the issue list will show the number of issues in JIRA. The count will be linked to your JIRA site. |
| cache          | No       | on      | The macro maintains a cache of the issues which result from the JIRA query. If the 'cache' parameter is set to 'off', the relevant part of the cache is cleared each time the macro is reloaded. (The value 'false' also works and has the same effect as 'off'.)  
  **Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The macro browser does not offer this parameter. |
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| height      | No       | 480 (if render mode is dynamic) | The height in pixels of the table displaying the issues. Note that this height specification is ignored in the following situations:  
- If the 'renderMode' parameter (see below) is set to 'static'.  
- When the issues are displayed in a PDF or Word document, in an email message or in an RSS feed.  
**Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The macro browser does not offer this parameter. |
| renderMode  | No       | static        | If the value is 'dynamic', the JIRA Issues macro offers an interactive display which people can manipulate as follows:  
- Click the column headers to sort the output.  
- Drag and drop the columns into a different order.  
- Temporarily remove a column from the display.  
- View a page of issues at a time, for faster response times.  
A value of 'static' will disable the dynamic display features.  
**Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The macro browser does not offer this parameter. |
| title       | No       | JIRA Issues   | You can customize the title text at the top of the issues table with this parameter. For instance, setting the title to 'Bugs-to-fix' will replace the default 'JIRA Issues' text. This can help provide more context to the list of issues displayed.  
**Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The macro browser does not offer this parameter. |
| url         | Yes      | none          | The URL of the XML view of your selected issues.  
**Note:** If the URL in the 'url' parameter does not contain a `tempMax` argument, then the value of `tempMax` will default to 500. If your JIRA server is version 3.12 or earlier, this means that the JIRA Issues macro will return a maximum of 500 issues. If your JIRA server is version 3.13 or later, a value of 500 means that the JIRA Issues macro will return a maximum of 500 issues per page. |
| width       | No       | 100%          | The width of the table displaying the issues. Can be entered as a percentage (%) or in pixels (px).  
**Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The macro browser does not offer this parameter. |

*Storage format example*

Example using a filter:
Example using JQL – note that Confluence will insert the server and serverId parameters, based on settings in Application Links:

```
<ac:structured-macro ac:name="jira" ac:schema-version="1"
ac:macro-id="da6b6413-0b93-4052-af90-dbb252175860">
<ac:parameter ac:name="server">Atlassian JIRA (JAC)</ac:parameter>
<ac:parameter ac:name="columns">key,summary,created</ac:parameter>
<ac:parameter ac:name="maximumIssues">20</ac:parameter>
<ac:parameter ac:name="jqlQuery">project = CONF AND FixVersion=5.8</ac:parameter>
<ac:parameter ac:name="serverId">146780e9-1234-312f-1243-ed0555666fa</ac:parameter>
</ac:structured-macro>
```

Wiki markup example

```
{jiraissues:anonymous=true|url=https://jira.atlassian.com/issues/?filter=41225}
```

JUnit Report Macro

The JUnit Report macro displays a summary of JUnit test results from a directory accessible by the Confluence server. JUnit is a unit testing framework which allows programmers to ensure that individual units of Java source code are functioning correctly. For security reasons, JUnit test result files can only be imported from a specified location in the Confluence server’s file system. We recommend administrators create a folder in their Confluence home directory, add the system property `confluence.junit.report.directory` and specify the location for JUnit test result files to be imported from. JUnit Test result files cannot be imported from the server until this system property is set. The JUnit Report macro appears as shown in the screenshot below.

**Screenshot: The JUnit Report macro in Confluence**

<table>
<thead>
<tr>
<th>Test</th>
<th>Time</th>
<th>Messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>MoneyTest</td>
<td>00:03.391</td>
<td>0 Tests, 0 Failures, 0 Exceptions</td>
</tr>
<tr>
<td>testAdd</td>
<td>00:03.0</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** When generating reports from the JUnit Report macro, set the Apache Ant formatter to ‘XML’. 

Using the JUnit Report macro
To add the JUnit Report macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `>` and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| URL of the test result XML file (**url**) | Must include either the directory or the url parameter | None | URL of a particular test result XML file. Is overridden by the **Directory (URL) of your test result files** parameter if you use both. Example, from a Confluence instance: `http://yourConfluenceInstance.com/download/attachments/<page id>/file.xml` For Confluence installations without anonymous user access, you can specify logon credentials as part of this parameter in the form of URL parameters:
- **os_username** — The username of a Confluence user with permission to access the JUnit test results.
- **os_password** — The password of the Confluence user specified in the **os_username** parameter.
| Directory (URL) of your test result files (**directory**) | Must include either the directory or the url parameter | None | URL of a directory containing your test result files. This must be a directory name and **not** the XML file itself. Overrides the **URL of the test result XML file** parameter if you use both. Example, file:///C:/TEMP/ Example, for a network drive: `http://*host*/*path*` |
| Report Detail (**reportdetail**) | No | all | Detail for the report. Can be **all**, **fixture**, **summary** or **failuresonly**. |
| Debug (**debug**) | No | None | Shows the content of failures, as well as the error messages. |

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** `junitreport`

**Macro body:** None.

*Storage format example*
Wiki markup examples

Loading JUnit reports from a local drive:

{junitreport:directory=file:///C:/TEMP/}

Loading JUnit reports from a network drive:

{junitreport:url=http://*host*/*path*}

Loading JUnit reports from a Confluence site:

{junitreport:url=http://yourConfluenceInstance.com/download/attachments/<page id>/file.xml}

Loading JUnit reports from a Confluence site that requires authentication:

If your Confluence site is not accessible by anonymous users, specify login credentials with the os_username and os_password URL parameters (as part of the macro's url parameter). In this case, we are specifying a username of 'admin' and a password of 'secret'.

{junitreport:url=http://yourConfluenceInstance.com/download/attachments/<page id>/file.xml?os_username=admin&os_password=secret}

Labels List Macro

The Labels List macro displays a list of all labels within the current space. Each label in the list links to a page that displays all pages in the current space that contain that label.

Using the Labels List macro

To add the Labels List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro
**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restrict to this Space Key</strong> (spaceKey)</td>
<td>No</td>
<td>Current space</td>
<td>The key of the space whose labels you want to display.</td>
</tr>
<tr>
<td><strong>Excluded label(s)</strong> (excludedLabels)</td>
<td>No</td>
<td>Blank</td>
<td>The labels that you do not want to appear in the list.</td>
</tr>
</tbody>
</table>

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** listlabels

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="listlabels">
  <ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="DOC"/>
  </ac:parameter>
  <ac:parameter ac:name="excludedLabels">not-this-label</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{listlabels:spaceKey=DOC}
```

### Livesearch Macro

The Livesearch macro allows you to add a search box to a Confluence page. When users enter a search term into the search box, Confluence will dynamically display matching results as they type.

#### Using the Livesearch macro

**To add the Livesearch macro to a page:**

1. In the Confluence editor, choose **Insert** > **Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restrict to this Space Key</strong> <em>(spaceKey)</em></td>
<td>all spaces</td>
<td>Specify a space key to limit the search to the given space. Case-sensitive. Alternatively, use <code>@self</code> to restrict the search to the current space.</td>
</tr>
<tr>
<td><strong>Restrict to label(s)</strong> <em>(labels)</em></td>
<td></td>
<td>Specify labels to limit the search to content with that label. If unspecified will search all content regardless of label.</td>
</tr>
<tr>
<td><strong>Size</strong> <em>(size)</em></td>
<td>medium</td>
<td>Choose a medium or large search field size.</td>
</tr>
<tr>
<td><strong>Placeholder text</strong> <em>(placeholder)</em></td>
<td></td>
<td>Specify the placeholder text to appear in the search field, for example ‘Search this space’</td>
</tr>
<tr>
<td><strong>Type</strong> <em>(type)</em></td>
<td>all</td>
<td>Specify the content types to be included in the search - choose from pages, blogs, comments, space descriptions, or all content types.</td>
</tr>
<tr>
<td><strong>Additional</strong> <em>(additional)</em></td>
<td>space name</td>
<td>Display the space name, a page excerpt or nothing under the search result.</td>
</tr>
</tbody>
</table>

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** livesearch

**Macro body:** None.

*Storage format example*
Loremipsum Macro

The Loremipsum macro displays paragraphs of pseudo-Latin text (more information). You can use this macro to generate more-or-less meaningless text for demonstration purposes in pages showing a draft layout or arrangement of page elements. The text is deliberately non-meaningful so that it does not influence the viewer's perception of the page arrangement or design.

A basic example of the Loremipsum text:


Using the Loremipsum macro

To add the Loremipsum macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Number of Paragraphs</strong></td>
<td>3</td>
<td>Determines the amount of pseudo-Latin (space-filler) text to display. The macro will display a maximum number of 30 paragraphs. Parameter is unnamed in storage format and wikimarkup.</td>
</tr>
</tbody>
</table>
Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** loremipsum

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="loremipsum">
  <ac:parameter ac:name="">2</ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
{loremipsum:2}
```

**Multimedia Macro**

Use the multimedia macro to embed attached video, animation, and other multimedia files to your page. The macro uses the HTML5 `<video>` tag, so the type of video your page viewers can see depends on the video formats their browser supports with the HTML5 `<video>` tag. For example, Quicktime videos (.mov or .qt) can only be viewed in Safari, as that file type is not supported by other browsers.

If you want to display online multimedia content, like YouTube and Vimeo videos, take a look at the [Widget Connector Macro](https://confluenceforge.org/widget).

The file preview also supports MP3 audio and MP4 video files. This is handy when you want to play a video in a larger format.

**To add the Multimedia macro to your page:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in [Autocomplete for links, files, macros and mentions](https://confluencehelp.atlassian.com/display/DOC/Quickly+enter+links%2C+files%2C+macros+and+mentions).**

To edit an existing macro: Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Drag a supported multimedia file directly onto your page, and Confluence will attach the file and add the macro for you.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page name</strong> (page)</td>
<td>No</td>
<td>Current page</td>
<td>The name of the page to which the multimedia file is attached. Start typing the name of the page and then select it from list of suggested pages. Include the spacekey if you want to specify a page in another space (for example, MYSPACE:My Page Title)</td>
</tr>
<tr>
<td><strong>File</strong> (name)</td>
<td>Yes</td>
<td>None</td>
<td>File name of the attached multimedia file.</td>
</tr>
<tr>
<td><strong>Width</strong></td>
<td>No</td>
<td>If not specified, the browser will determine the width based on the file type.</td>
<td>Width of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's width, or any other value accepted by HTML.</td>
</tr>
<tr>
<td><strong>Height</strong></td>
<td>No</td>
<td>If not specified, the browser will determine the height based on the file type.</td>
<td>Height of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's height, or any other value accepted by HTML.</td>
</tr>
<tr>
<td><strong>Autoplay</strong> (autostart)</td>
<td>No</td>
<td>false</td>
<td>If the parameter is set to true then the video or audio file will start playing as soon as the page is loaded. If this option is set to false then the file will not play until the user clicks the icon or image on the page.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** multimedia  
**Macro body:** None.

**Storage format example**

```xml  
<ac:structured-macro ac:macro-id="4a589028-09cc-45ed-b8e8-d0able9c0523" ac:name="multimedia" ac:schema-version="1">  
  <ac:parameter ac:name="name">  
    <ri:attachment ri:filename="myVideo.mp4" />  
  </ac:parameter>  
  <ac:parameter ac:name="width">600</ac:parameter>  
  <ac:parameter ac:name="autostart">true</ac:parameter>  
  <ac:parameter ac:name="height">430</ac:parameter>  
</ac:structured-macro>
```

**Wikimarkup example**

```wikimarkup  
{multimedia:space=DOC|page=My macros|name=ninjas.swf|autostart=true}
```

**Navigation Map Macro**

The Navigation Map macro displays a navigable map of the pages tagged with a given label.
Using the Navigation Map Macro

To add the Navigation Map macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>none</td>
<td>Specify the label associated with the pages you want to show in the navigation map. This parameter is unnamed in storage format and wikimarkup.</td>
</tr>
<tr>
<td>Map Title (title)</td>
<td>none</td>
<td>Specify a title for the navigation map.</td>
</tr>
<tr>
<td>Number of Cells Per Row (wrapAfter)</td>
<td>5</td>
<td>Specify the number of cells in a row</td>
</tr>
<tr>
<td>Cell Width (Pixels) (cellWidth)</td>
<td>90</td>
<td>Specify the cell width (enter a number only, don't include px)</td>
</tr>
<tr>
<td>Cell Height (Pixels) (cellHeight)</td>
<td>60</td>
<td>Specify the cell height (enter a number only, don't include px)</td>
</tr>
<tr>
<td>Navigation Map Theme (theme)</td>
<td>Confluence</td>
<td>Define a theme for the navmap (Server only). If you want to create your own navmap 'look and feel' (for example, one with rounded corners), you need to add a customized navmap macro theme file to the WEB-INF/classes/templates/macros directory. The file name convention to use is navmap-mytheme.vm. Use the name of your choice for the mytheme part of the file name, which is also the value you use for this parameter. Hence, if your theme was called navmap-roundededges.vm, use the value of roundededges for this parameter.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: navmap
Macro body: None.

Storage format example

```xml
<ac:structured-macro ac:name="navmap">
    <ac:parameter ac:name="wrapAfter">4</ac:parameter>
    <ac:parameter ac:name="title">My map name</ac:parameter>
    <ac:parameter ac:name="cellHeight">50px</ac:parameter>
    <ac:parameter ac:name="theme">navmap-mytheme.vm</ac:parameter>
    <ac:parameter ac:name="cellWidth">80px</ac:parameter>
    <ac:parameter ac:name="">mylabel</ac:parameter>
</ac:structured-macro>
```

Wiki markup example

```
{navmap:mylabel|wrapAfter=4|title=My map name|cellHeight=50px|theme=navmap-mytheme.vm|cellWidth=80px}
```

Network Macro

The Network macro displays a list of Network activity on a Confluence page or blog post. You can specify the user whose network activity you wish to show. These interactions include the users that the specified user is following or users who are following the specified user. The Network macro shows each listed user by their profile picture. It also provides a choice of two themes and the ability to limit the number of users in the list.

Screenshot: Network macro

Using the Network macro

To add the Network macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>Current user's username</td>
<td>The username of the Confluence user whose network interactions you wish to show. If no username is specified, then current user's (that is, your) network interactions are shown.</td>
</tr>
</tbody>
</table>
| Mode | following | Determines which users are listed, with respect to the specified user:  
  • following – those who the user is following,  
  • followers – those who are following the user.  
This parameter is unnamed in storage format and wikimarkup. |
| Theme | full | Determines how the user's network is displayed:  
  • full – shows a large version of user's profile pictures and, if the following mode is set, provides an entry field function to follow more users.  
  • tiny – shows only the small version of user's profile pictures. |
| Maximum Results (max) | No limit imposed up to a maximum of 30 | Restricts the number of users displayed. If the number of users exceeds the specified maximum, then a Show All link is provided. This link leads to the specified user's Network view, showing the complete list of network interactions. |

Disabling the Network macro

The Network macro is provided by the 'network' module in the 'Profile Macros' plugin. To remove the macro from your site, you can disable the module in the plugin. See Disabling and enabling add-ons.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** network

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="network">
  <ac:parameter ac:name="username"/>
  <ri:user ri:userkey="12345678912345678912345"/>
</ac:structured-macro>
```

**Wiki markup example**

```
{network:followers|username=admin|max=10|theme=full}
```

**Noformat Macro**
The Noformat macro displays a block of text in monospace font with no other formatting.

**Using the Noformat Macro**

**To add the Noformat macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Enter the content that is to be unformatted into the body of the macro placeholder.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Panel (nopanel)</td>
<td>False</td>
<td>Removes the panel around the content.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** noformat

**Macro body:** Accepts plain text.

**Storage format example**

```xml
<ac:structured-macro ac:name="noformat">
  <ac:parameter ac:name="nopanel">true</ac:parameter>
  <ac:plain-text-body><![CDATA[http://www.example.com]]></ac:plain-text-body>
</ac:structured-macro>
```

**Wiki markup example**

```
{noformat:nopanel=true}http://www.example.com{noformat}
```

**Office Excel Macro**
The Office Excel macro is going away in a future release
Read more about this change or find out about a better way to insert and preview Excel files.

The Office Excel macro displays the content of an Excel spreadsheet on a wiki page. First attach the spreadsheet to a Confluence page, then use the macro to display the content. When viewing the page, people will see the content of the spreadsheet, without needing to have Office installed.

For details, see the View File Macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name**: `viewxls`

**Macro body**: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the Excel spreadsheet to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the Excel spreadsheet is attached.</td>
</tr>
<tr>
<td>col</td>
<td>No</td>
<td>Last column with content</td>
<td>The number of the last column you want displayed, starting from '0' as the first column. <strong>Hint for reducing the size of the spreadsheet:</strong> Use the <code>col</code> and <code>row</code> parameters to reduce the size of the spreadsheet displayed on the wiki page. This is especially useful to prevent the display from showing empty cells. This will also help to prevent 'out of memory' errors.</td>
</tr>
<tr>
<td>row</td>
<td>No</td>
<td>Last row with content</td>
<td>The number of the last row you want displayed, starting from '0' as the first row.</td>
</tr>
</tbody>
</table>
| grid           | No       | true    | Determines whether the macro will show borders around the cells in the spreadsheet. Accepted values:
  * true – Shows borders.
  * false – Does not show borders. |
| sheet          | No       | The most-recently viewed worksheet | The name of the worksheet that you want displayed. |

**Storage format example**
<ac:structured-macro ac:name="viewxls">
  <ac:parameter ac:name="col">E</ac:parameter>
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="Spreadsheet.xls"/>
  </ac:parameter>
  <ac:parameter ac:name="sheet">Sheet1</ac:parameter>
  <ac:parameter ac:name="row">5</ac:parameter>
</ac:structured-macro>

Wiki markup example

{viewxls:col=5|page=Docs|name=My
document.xls|grid=false|sheet=mysheet|row=5}

Office PowerPoint Macro

The Office PowerPoint macro is going away in a future release
Read more about this change or find out about a better way to insert and preview PowerPoint files.

The Office PowerPoint macro displays the content of a PowerPoint presentation on a wiki page. First attach the presentation to a Confluence page, then use the macro to display the content. When viewing the page, people will see the content of the presentation, without needing to have Office installed.

For details, see the View File Macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: viewppt

Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the PowerPoint presentation to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the PowerPoint presentation is attached.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td></td>
<td>The height of the macro display, specified in pixels (for example: 10 px, or just 10) or as a percentage (for example: 20%) of the window's height.</td>
</tr>
</tbody>
</table>
### Width

| width | No | The width of the macro display, specified in pixels (for example: 10 px, or just 10) or as a percentage (for example: 20%) of the window’s height. |

### Slide

| slide | No | All slides, starting with the first, as a slide show | The number of the slide that you want displayed on the Confluence page, where the first slide is numbered zero. Instead of a slide show, the page will display just the single slide, represented as a JPEG image. |

### Storage format example

```xml
<ac:structured-macro ac:name="viewppt">
  <ac:parameter ac:name="height">250</ac:parameter>
  <ac:parameter ac:name="width">250</ac:parameter>
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="101_samplepresentation.pptx"/>
  </ac:parameter>
</ac:structured-macro>
```

### Wiki markup example

```
{viewppt:height=20%|page=Docs|width=20%|name=My document.ppt|slide=4}
```

### Office Word Macro

The Office Word macro is going away in a future release

Read more about this change or find out about a better way to insert and preview Word files.

The Office Word macro displays the content of a Word document on a wiki page. First attach the document to a Confluence page, then use the macro to display the content. When viewing the page, people will see the content of the document, without needing to have Office installed.

For details, see the View File Macro.

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** viewdoc

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the Word document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the Word document is attached.</td>
</tr>
<tr>
<td>------</td>
<td>----</td>
<td>-------------------------------</td>
<td>---------------------------------------------------------------</td>
</tr>
</tbody>
</table>

**Storage format example**

```xml
<ac:structured-macro ac:name="viewdoc">
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="Chocolate.doc"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```plaintext
{viewdoc:page=Docs|name=My document.doc}
```

**Page Index Macro**

The Page Index macro creates a hyperlinked alphabetical index of all page titles within the current space. The top section of the index contains a cell for each letter of the alphabet, with cells for numbers and symbols. Each cell indicates how many pages are in the corresponding list.

The lower section contains lists of page titles followed by the first few sentences of content on that page. Each letter, number or symbol in the top section is hyperlinked to the corresponding cell in the lower section. Each page title in the lower section is hyperlinked to the page in the space.

**Screenshot: Page Index macro (partial view)**

<table>
<thead>
<tr>
<th>Space Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>0-9 ... 1</td>
</tr>
<tr>
<td>F ... 0</td>
</tr>
<tr>
<td>L ... 0</td>
</tr>
<tr>
<td>R ... 0</td>
</tr>
<tr>
<td>X ... 0</td>
</tr>
</tbody>
</table>

- **25 reasons people like Confluence**
  - Integration with JIRA Great product fits a wiki User experience design

- **Angry Nerds Home**
  - Welcome to Angry Nerds, a sample Confluence space. We think you’re gonna like it here!

- **Blog ideas**
  - Do users need to be told left side / right side of screen Macros and what you can do with them

- **Confluence hints and tips**
  - What hints and tips do you share with other Confluence users?

- **Games as a communication medium**
  - Can we use games as a communication medium?
Using the Page Index macro

**To add the Page Index macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

This macro accepts no parameters.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** index

**Macro body:** None.

**Parameters:** None.

**Storage format example**

```
<ac:structured-macro ac:name="index"/>
```

**Wiki markup example**

```
{index}
```

**Page Properties Macro**

The Page Properties and Page Properties Report macro work together to show summary information from one page on another page. You can see examples of these two macros in action in the Decisions and Product Requirements blueprints.

**Adding the Page Properties macro to a page**

The Page Properties macro uses key/value pairs.

To add the Page Properties macro to a page:

1. In the editor, choose Insert > Other Macros > Page Properties
2. In the macro body create a two column table
3. In the left column list your 'keys' – these will be the column headings in your report table
4. In the right column list the value for each key – these will populate the rows in your report table
5. Add a label to your page (you'll need to specify this label in the page properties report macro)
6. Save your page
Next you need to add the Page Properties Report macro to another page.

Here's an example of the Page Properties macro in the editor. Deadline, Current Status, and Team will be column headings in the report.

Here's what the example above will look like in the Page Properties Report.

Using multiple Page Properties macros on one page
You can add multiple Page Properties macros on a single page, and choose whether to include all or only specific macros in the report. You might use multiple macros because you want the information in the macro to display in context with the rest of the page, or because you want to be able to report on individual Page Properties macros separately.

The Page Properties macro includes an optional ID parameter that can be used to identify specific Page Properties macros.

To show the contents of all Page Properties macros in the report:

1. Add a label to the page containing the Page Properties macros
2. Specify this label in the Page Properties Report macro

To show the contents of selected Page Properties macros in the report:

1. Add a label to the page containing the Page Properties macros
2. Specify an ID in the Page Properties macro that you want to report on
3. Specify both the label and ID in the Page Properties Report macro

**Note:** The Page Properties Report macro can only accept one page label, and one ID.

See the Page Properties macro in action in How to document product requirements in Confluence. This powerful macro lets you create a summary page that pulls in information from multiple pages.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Properties ID</td>
<td>(None)</td>
<td>Optional ID used to identify a particular Page Properties macro on a page. Specify this ID in the Page Properties Report to include summary information from macros with this ID only.</td>
</tr>
<tr>
<td>Hidden</td>
<td>False</td>
<td>Determines whether the data in the Page Properties macro will be displayed on the current page. This setting does not affect the display of the detail in the Page Properties Report macro.</td>
</tr>
</tbody>
</table>

### Notes

- You can't use macros in the left column as the data in this column is used to populate the column headings in your Page Properties Report macro.
- It is not possible to reference the metadata using the metadata key from within the page, or anywhere else on a Confluence page.

### Page Properties Report Macro

The Page Properties and Page Properties Report macro work together to enable you to show summary information from one page on another page. You can see examples of these two macros in action on the Decision and Product Requirements blueprints.

This macro was previously known as the Details Summary macro.

### Adding the Page Properties Report macro to a page

To add the Page Properties Report macro to a page:

1. In the editor, choose **Insert > Other Macros > Page Properties**
Report.

1. Enter the **Labels** you want to report on - this is the label added to pages containing the Page Properties macro.

2. Further narrow down your search by adding more fields, or specifying a Page Properties ID (more info on this below)

3. Choose **Insert**.

---

Here's how the macro looks on your page:

<table>
<thead>
<tr>
<th>Title</th>
<th>Current status</th>
<th>Deadline</th>
<th>Team</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project DEF</td>
<td>Not started</td>
<td>1 June</td>
<td>Purple Monkeys</td>
</tr>
<tr>
<td>Project ABC</td>
<td>in Progress</td>
<td>15 November</td>
<td>Green Parrots</td>
</tr>
</tbody>
</table>

And here's how you would set it up in the macro browser:

---

On this page:
- Adding the Page Properties Report macro to a page
- Reporting on specific Page Properties macros
- CQL fields
- Macro display options
- Troubleshooting

Related pages:
- Page Properties Macro
- Decisions Blueprint
- Product Requirements Blueprint
Reporting on specific Page Properties macros

It's possible to add multiple Page Properties macros on a page, and choose whether to include all or only specific macros in the report. The Page Properties macro includes an optional ID parameter that can be used to identify specific Page Properties macros.

To show the contents of:

- **Selected Page Properties macros** in the report - specify the label for the page and the ID of the particular Page Properties macro (under Options)
- **All Page Properties macros** in the report - specify just the label for the page - leave the Page Properties ID field blank.

**Note:** The Page Properties Report macro can only accept one ID.

CQL fields

CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the **Add a filter** link to add more filters to your query.

- **Use AND, OR, and NOT operators**
  - For an OR search, specify multiple values in the same field.
    So to show pages with 'label-a', 'label-b' or both you'd put 'label-a' and 'label-b' in the same Label field, like this:

  ![Label field example](image)

  - For an AND search, add more than one filter and specify a single value in each.
    To show only pages with label-a and label-b you’d put 'label-a' in one label field, then add a second Label field to the macro, and put 'label-b' in the second one, like this:
Put simply, OR values are entered in the same filter, AND values are entered in different filter. Only some filters support AND. If the filter doesn't support the AND operator, you won't be able to add that filter more than once.

- For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that label.

You can use the following CQL filters to build your query:

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
<th>Operators</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Label</strong></td>
<td>Include pages, blog posts or attachments with these labels.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AND (multiple Label filters)</td>
</tr>
<tr>
<td><strong>With ancestor</strong></td>
<td>Include pages that are children of this page.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td></td>
<td>This allows you to restrict the macro to a single page tree.</td>
<td></td>
</tr>
<tr>
<td><strong>Contributor</strong></td>
<td>Include pages or blog posts that were created or edited by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>Creator</strong></td>
<td>Include items created by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>Mentioning user</strong></td>
<td>Include pages and blog posts that @mention these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>With parent</strong></td>
<td>Include only direct children of this page (further sub-pages won't be included)</td>
<td>EQUALS (one page only)</td>
</tr>
<tr>
<td><strong>In space</strong></td>
<td>Include items from these spaces.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>Including text</strong></td>
<td>Include items that contain this text.</td>
<td>CONTAINS (single word or phrase)</td>
</tr>
<tr>
<td><strong>With title</strong></td>
<td>Include items that contain this text in the title.</td>
<td>CONTAINS (single word or phrase)</td>
</tr>
<tr>
<td><strong>Of type</strong></td>
<td>Include only pages, blogs or attachments.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
</tbody>
</table>

* This field is required in CQL-powered macros.

** You can add these filters in CQL-powered macros but in search they're part of the standard search filters, so they don't appear in the **Add a filter** menu.

**Macro display options**

These options control how the macro appears on your page.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2016 by Atlassian. Licensed under a [Creative Commons Attribution 2.5 Australia License](https://creativecommons.org/licenses/by/2.5/au/).
<table>
<thead>
<tr>
<th>Page Properties ID</th>
<th>Blank</th>
<th>If not specified, the report will show data from all Page Properties macros on a page, where there are multiple macros. Specify an ID to include only data from Page Properties macros with the same ID.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title column heading</td>
<td>Title</td>
<td>The heading to display on the first column in the report table. This column contains links to pages displayed by the report. The default column heading is 'Title'.</td>
</tr>
<tr>
<td>Columns to show</td>
<td>If not specified, the report will show all columns. You can specify a comma separated list of columns to include. If your column heading includes commas, use double quotes around the column name. If your column heading includes quotes, use double quotes. For example, A column, “My &quot;new&quot; column, yes”, Third column</td>
<td></td>
</tr>
<tr>
<td>Number of items to display</td>
<td>30</td>
<td>Number of items to display in the table before displaying pagination options for additional items.</td>
</tr>
<tr>
<td>Sort by</td>
<td>Modified</td>
<td>Sort the table by a specific column heading. Enter the column name, exactly as it appears in the corresponding Page Properties macro. Select the Reverse Sort check box to sort the table in reverse order.</td>
</tr>
<tr>
<td>Show Comments Count</td>
<td>No</td>
<td>Displays the number of comments for each page in the table.</td>
</tr>
<tr>
<td>Show Likes Count</td>
<td>No</td>
<td>Displays the number of likes for each page in the table.</td>
</tr>
</tbody>
</table>

Troubleshooting

If your report is empty, check:

- You have entered the label correctly and that the label does appear on pages containing a Page Properties macro.
- The Page Properties macros on each page are configured correctly.
- Any other fields you have specified have not narrowed your search too far (for example there are no pages with that label under the Parent page you've specified).

Page Tree Macro

The Page Tree macro displays a dynamic, hierarchical list of pages starting from a specified parent (root) page. It can act as a table of contents or a list of related topics. When viewing the page tree, your reader can click a link to view the relevant page. The page's current position is highlighted in the page tree.

**Note:** The Page Tree macro is used in the Confluence Documentation theme, to create a navigation panel showing a table of contents for your space. Read the instructions on Configure the Documentation Theme.

Using the Page Tree Macro

**To add the Page Tree macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Click **Refresh** in the Macro Browser to see the effect of changes to the macro parameters.

## Macro Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Root Page** *(root)*             | The home page of the space | Specify the parent page for the page tree. The tree will include all children of the given page, plus their children and grand-children etc. The tree will *not* include the root page itself. Specify the page title or a special value as follows:  

- Your page title — to specify a page name for the parent or root of the tree. The tree will include all children and grand-children of the specified root. The tree will *not* include the specified root page itself.  
- '@home' — will include all pages under the home page of the space (default).  
- '@self' — will include all pages under the current page.  
- '@parent' — will include all pages under the parent of the current page, including the current page.  
- '@none' — will include all pages in the space, including orphaned pages and the home page. |
| **Sort Pages By** *(sort)*         | position | Specify the order to display the pages in the tree. This sort order is for display purposes only. It does not permanently re-arrange the page order. The value may be one of the following:  

- bitwise — sort alphabetically, for example: title1, title10, title2.  
- creation — sort by date of creation.  
- modified — sort by order of date last modified.  
- natural — sort in 'natural' alphabetical order, for example: title1, title2, title10.  
- position — sort by the default Confluence sorting rules. If your pages have been ordered manually, this sort will respect the defined order. Otherwise the pages will be displayed in the 'natural' alphabetical order, such as: title1, title2, title10. |
| **Include Excerpts in Page Tree** *(excerpt)* | false | Select if you want the page tree to show excerpts from each page. The excerpts must be defined on each page by the Excerpt macro. |
| **Reverse Order** *(reverse)*      | false | Select to show the pages in reverse (descending) natural order. Must be used in combination with the Sort Pages By parameter. |
| **Include Search Box above Page Tree** *(searchBox)* | false | Select if you want to include a search box above the page tree. The search box allows your readers to search within the page tree for the specified value. |
| **Show Expand/Collapse Links** *(expandCollapseAll)* | false | Select if you want to display the 'expand all' and 'collapse all' links at the top of your page tree. Your readers can click these links to open or close all branches of the tree at once. Available values in wikimarkup and storage format:  

- true — Show the 'expand all' and 'collapse all' options.  
- false — Do not show the options. |
### Start Depth

**Start Depth (startDepth)**

| Start Depth (startDepth) | 1 | Enter any number greater than 0 to set how many levels of children the tree should show when it opens for the first time. |

---

## Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** pagetree

**Macro body:** None.

### Storage format example

```
<ac:structured-macro ac:name="pagetree">
    <ac:parameter ac:name="reverse">false</ac:parameter>
    <ac:parameter ac:name="sort">natural</ac:parameter>
    <ac:parameter ac:name="root">
        <ac:link>
            <ri:page ri:content-title="Page Name"/>
        </ac:link>
    </ac:parameter>
    <ac:parameter ac:name="startDepth">3</ac:parameter>
    <ac:parameter ac:name="excerpt">true</ac:parameter>
    <ac:parameter ac:name="searchBox">true</ac:parameter>
    <ac:parameter ac:name="expandCollapseAll">true</ac:parameter>
</ac:structured-macro>
```

### Wiki markup example

```
{pagetree:root=Page Name|sort=natural|excerpt=true|reverse=false|startDepth=3|expandCollapseAll=true|searchBox=true}
```

---

## Page Tree Search Macro

Using the Page Tree Search macro, you can add a search box to your Confluence page. When a viewer enters a search term, Confluence will search a hierarchy of pages starting from a specified parent (root) page and return the search results.

You can also add a search box as part of a dynamic page tree, which looks like a table of contents. See the [Page Tree macro](#).

### Using the Page Tree Search macro

#### To add the Page Tree Search macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in [Autocomplete for links, files, macros and mentions](#).

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name of Root Page</td>
<td>none</td>
<td>The name of the root page whose hierarchy of pages will be searched by this macro. If this not specified, the root page is the current page.</td>
</tr>
<tr>
<td>(root)</td>
<td></td>
<td>Note: Unlike the Page Tree macro, the Page Tree Search macro does not accept the special values that start with an @ sign, such as @home or @self.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** pagetreesearch

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="pagetreesearch">
  <ac:parameter ac:name="root">My page name</ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
{pagetreesearch:root=My page name}
```

Panel Macro

The Panel macro displays a block of text within a customizable panel, like this:

```
My Title

A formatted panel.
```

**Handy hint:** You can use panels within columns, in table cells and in the sections defined by page layouts.

Using the Panel macro

**To add the Panel macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panel Title (title)</td>
<td>none</td>
<td>The title of the panel. If specified, this title will be displayed in its own title row.</td>
</tr>
<tr>
<td>Border Style (borderStyle)</td>
<td>solid</td>
<td>The style of the panel's border. Accepted values are solid, dashed and other valid CSS border styles.</td>
</tr>
<tr>
<td>Border Color (borderColor)</td>
<td></td>
<td>The color of the panel's border. Colors can be specified as HTML color names or hexadecimal codes.</td>
</tr>
<tr>
<td>Border Pixel Width (Value Only) (borderWidth)</td>
<td></td>
<td>The width of the panel's border (in pixels).</td>
</tr>
<tr>
<td>Background Color (bgColor)</td>
<td></td>
<td>The background color of the panel. Colors can be specified as HTML color names or hexadecimal codes.</td>
</tr>
<tr>
<td>Title Background Color (titleBGColor)</td>
<td></td>
<td>The background color of the title row of the panel. Colors can be specified as HTML color names or hexadecimal codes.</td>
</tr>
<tr>
<td>Title Text Color (titleColor)</td>
<td></td>
<td>The color of the text in the title row of the panel. Colors can be specified as HTML color names or hexadecimal codes.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: panel

Macro body: Accepts rich text.

Storage format example

```xml
<ac:structured-macro ac:name="panel">
  <ac:parameter ac:name="bgColor">#72bc72</ac:parameter>
  <ac:parameter ac:name="titleBGColor">#00a400</ac:parameter>
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:parameter ac:name="borderStyle">dashed</ac:parameter>
  <ac:parameter ac:name="borderColor">blue</ac:parameter>
  <ac:parameter ac:name="titleColor">white</ac:parameter>
  <ac:rich-text-body>
    <p>A formatted panel</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

Wiki markup example

```markdown
A formatted panel
```
The PDF macro displays the content of a PDF document on a page. First attach the document to a Confluence page, then use the macro to display the document.

For details, see the View File Macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** viewpdf

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the PDF document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td></td>
<td>The page containing the macro</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>The name of a Confluence page to which the PDF document is attached.</td>
</tr>
</tbody>
</table>

**Storage format example**

```xml
<ac:structured-macro ac:name="viewpdf">
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="My_document.pdf"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{viewpdf:page=Docs|name=My_document.pdf}
```
The Popular Labels macro displays the most popular labels used throughout your Confluence site or within a space. A popular label is a label that has been added to many pages.

Using the Popular Labels Macro

To add the Popular Labels macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Labels to Display (count)</td>
<td>100</td>
<td>Specifies the total number of labels to display in the heatmap.</td>
</tr>
<tr>
<td>Restrict Labels to this Space Key (spaceKey)</td>
<td>none</td>
<td>Restricts the list of popular labels to the specified space.</td>
</tr>
</tbody>
</table>
| Style of Labels (style)            | list    | • list – displays the popular labels as a bulleted list, ordered by popularity (highest first).
|                                    |         | • heatmap – displays the popular labels using different font sizes for each label depending on the label's popularity, ordered by label names. |

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** popular-labels

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="popular-labels">
  <ac:parameter ac:name="count">20</ac:parameter>
  <ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="ds"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
Profile Picture Macro

You can use the Profile Picture macro to display a user's profile picture on a page, and it's useful for things like creating team pages that show all members of a project team.

Hover your mouse-over the picture to see the Hover Profile for the user, and choose the user's picture or name to view their user profile. When editing the page, you can also select the macro and choose View User Profile to see the profile for the user.

Add the Profile Picture Macro

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the 'Profile picture' macro
3. Search for and select the user and choose Save

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, then select the macro from a list of suggested macros. For more information, see Using Autocomplete.

Code examples

The following example is provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** profile-picture

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="profile-picture">
  <ac:parameter ac:name="User">
    <ri:user ri:userkey="12345678912345678912345678912345"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup**

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

Recently Updated Dashboard Macro

The Recently Updated Dashboard macro displays a list of the most recently changed pages, blogs and files in your site. It is similar to the Recently Updated macro but with tabs to allow you to see all updates, updates from your favorite spaces or updates from your network (the people you follow).

Using the Recently Updated Dashboard macro
To add the Recently Updated Dashboard macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in [Autocomplete for links, files, macros and mentions](#).

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Space(s)</strong> (spaces)</td>
<td>The space which contains the page on which the macro is added</td>
<td>Filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here. You can specify one or more space keys, separated by commas. Use '*' for all spaces.</td>
</tr>
<tr>
<td><strong>Include these Content Types Only</strong> (types)</td>
<td>all types</td>
<td>Filter content by type. You can specify one or more types, separated by commas. Available types are: <code>page</code>, <code>blogpost</code> or <code>news</code>, <code>spacedesc</code>, <code>attachment</code>, <code>comment</code>, <code>mail</code>, <code>userinfo</code>.</td>
</tr>
</tbody>
</table>
| **Label(s)** (labels)        | none    | Filter content by label. The macro will display only the pages etc which are tagged with the label(s) you specify here. You can specify one or more labels, separated by commas.  
  Note: If there are no pages matching any of the specified labels, then Confluence will ignore the labels and will list all recently updated pages. |
| **User(s)** (users)          | all users | Filter by username of the user who updated the content. The macro will only display content created and updated by the user(s) you specify here. You can specify one or more usernames separated by commas. |
| **Width of Table** (width)   | 100%    | Specify the width of the macro display, as a percentage of the window width.                                                                 |
| **Show User Profile Pictures** (showProfilePic) | false | Select whether profile pictures of the users who updated the content are displayed.                                                        |

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** `recently-updated-dashboard`

**Macro body:** `None.`

*Storage format example*
Recently Updated Macro

The Recently Updated macro displays a list of the most recently changed content within Confluence.

Using the Recently Updated Macro

To add the Recently Updated macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Author(s) by username (author)</td>
<td>None specified.</td>
<td>Filter the results by author. The macro will display only the pages etc which were last modified by the author(s) you specify here.</td>
</tr>
<tr>
<td></td>
<td>That is, display all content</td>
<td>You can specify multiple users.</td>
</tr>
</tbody>
</table>

Wiki markup example

```
{recently-updated-dashboard:spaces=ds|users=admin|width=50%|showProfilePic=true|labels=choc|types=page}
```
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Space(s)</strong> (spaces)</td>
<td><code>@self</code></td>
<td>This parameter allows you to filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here. You can specify one or more space keys, separated by a comma or a space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of <code>-BADSPACE</code> you will get only content which is not in the BADSPACE.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To indicate that the results <strong>must</strong> come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of <code>+GOODSPACE</code> you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Special values:</td>
</tr>
<tr>
<td></td>
<td><code>@self</code></td>
<td>• The current space.</td>
</tr>
<tr>
<td></td>
<td><code>@personal</code></td>
<td>• All personal spaces.</td>
</tr>
<tr>
<td></td>
<td><code>@global</code></td>
<td>• All site spaces.</td>
</tr>
<tr>
<td></td>
<td><code>@favorite</code></td>
<td>• The spaces you have marked as favorite.</td>
</tr>
<tr>
<td></td>
<td><code>@favourite</code></td>
<td>• The same as <code>@favorite</code> above.</td>
</tr>
<tr>
<td></td>
<td><code>@all</code></td>
<td>• All spaces in your Confluence site.</td>
</tr>
<tr>
<td></td>
<td><code>*</code></td>
<td>• The same as <code>@all</code> above.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as <code>~jbloggs</code> or <code>~jbloggs@example.com</code>.</td>
</tr>
<tr>
<td><strong>Label(s)</strong> (labels)</td>
<td>None specified i.e. display all content</td>
<td>Filter the results by label. The macro will display only the pages etc which are tagged with the label(s) you specify here. You can specify one or more label values, separated by a comma or a space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of <code>-badpage</code> you will get only content which is not labeled with 'badpage'.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To indicate that the results <strong>must</strong> match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of <code>+superpage,+goodpage</code> you will get only content which has at least two labels, being 'superpage' and 'goodpage'.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The labels parameter only applies to the page and blog content types.</td>
</tr>
<tr>
<td><strong>Width of Table</strong> (width)</td>
<td>100%</td>
<td>Specify the width of the macro display, as a percentage of the window width.</td>
</tr>
</tbody>
</table>
### Include these Content Types Only (types)

| All types | This parameter allows you to filter content by content type. The macro will display only the content of the type you specify here. You can specify one or more types, separated by a comma or a space. To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of -blogpost you will get pages and all other content except for blog posts.

**Available values:**
- page — Pages.
- blogpost or news — Blog posts, also known as news items.
- comment — Comments on pages and blog posts.
- attachment — Attachments.

### Maximum Number of Results (max)

| 15 | Specify the maximum number of results to be displayed. If this parameter is omitted, then a maximum of 15 results are displayed. The theoretical maximum value that this parameter can accept is 2 to the power of 31, minus 1 (or 2147483647), though this has been limited to 200 in the code, for performance reasons. More details are here.

### theme (theme)

| concise | Choose the appearance of this macro:
- **concise** — the default list, showing the names of pages which were updated or commented on, the users who made the page modifications and time when the modifications occurred.
- **social** — lists recent modifications in reverse chronological order, but groups them by user into short time segments. A ‘sub’ list appears within each user’s time segment, showing the names of pages which they updated or commented on and time when these modifications occurred.
- **sidebar** — lists recent updates in reverse chronological order, showing the names of pages which were updated or commented on and time when the page modifications occurred. This theme does not show authorship.

### Show User Profile Pictures (showProfilePic)

| false | Specify `showProfilePic=true` to display the profile pictures of the users who updated the content.

### Hide Title (hideHeading)

| False | Determines whether the macro hides or displays the text ‘Recently Updated’ as a title above the list of content. Only available in wikimarkup and storage format.

**Accepted values:**
- **true** — Title is hidden.
- **false** — Title is shown.

### Notes

- The Recently Updated Dashboard macro is similar to this macro, but is intended for display on the Confluence dashboard.
- If you would like to change the wording displayed by the Recently Updated macro, please refer to the document on modifying the Confluence interface text.

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a...
Confluence page.

**Macro name:** recently-updated

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="recently-updated">
   <ac:parameter ac:name="spaces">
      <ri:space ri:space-key="ss"/>
   </ac:parameter>
   <ac:parameter ac:name="author">
      <ri:user ri:userkey="12345678912345678912345"/>
   </ac:parameter>
   <ac:parameter ac:name="users"/>
   <ac:parameter ac:name="max">10</ac:parameter>
   <ac:parameter ac:name="width">50%</ac:parameter>
   <ac:parameter ac:name="theme">sidebar</ac:parameter>
   <ac:parameter ac:name="labels">choc</ac:parameter>
   <ac:parameter ac:name="types">page</ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```wikimarkup
{recently-updated:spaces=ds|author=admin|max=10|hideHeading=true|width=50%|theme=sidebar|showProfilePic=true|labels=choc|types=page}
```

**Recently Used Labels Macro**

The Recently Used Labels macro displays a list of the labels that have been most recently added to a page, blog post or attachment. You can define the number of labels to be displayed and the scope (the current space, your personal space or site spaces, also known as ‘global’ spaces).

**Using the Recently Used Labels macro**

**To add the Recently Used Labels macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters of this macro**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Number of Labels to Display</strong></td>
<td>10</td>
<td>Specifies the total number of labels to display in the list.</td>
</tr>
<tr>
<td><strong>(count)</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Scope for Retrieving Labels</strong></td>
<td>global</td>
<td>Specifies the scope of labels to be displayed in the list. Valid values include:</td>
</tr>
<tr>
<td><strong>(scope)</strong></td>
<td></td>
<td>- global — covers all site spaces (non-personal) in the Confluence</td>
</tr>
<tr>
<td></td>
<td></td>
<td>installation.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- space — the current space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- personal — your own personal space.</td>
</tr>
<tr>
<td><strong>List Style</strong></td>
<td>list</td>
<td></td>
</tr>
<tr>
<td><strong>(style)</strong></td>
<td></td>
<td>- list — displays the list of labels horizontally.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- table — includes additional information such as the page to which the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>label was added and the user who added it.</td>
</tr>
<tr>
<td><strong>Table Title</strong></td>
<td>none</td>
<td>Adds a title to the top of the list in table style. Titles are only visible when the List Style parameter has been set to table.</td>
</tr>
<tr>
<td><strong>(title)</strong></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** recently-used-labels

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="recently-used-labels">
    <ac:parameter ac:name="title">My title</ac:parameter>
    <ac:parameter ac:name="scope">space</ac:parameter>
    <ac:parameter ac:name="style">table</ac:parameter>
    <ac:parameter ac:name="count">20</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{recently-used-labels:title=My title|scope=space|style=table|count=20}
```

**Related Labels Macro**

The Related Labels macro lists all labels from every page which has one or more labels in common with the current page.

**Using the Related Labels Macro**

**To add the Related Labels macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.
To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restrict to these</strong></td>
<td>none</td>
<td>Specify the labels for which you want to view related</td>
</tr>
<tr>
<td><strong>Labels (labels)</strong></td>
<td></td>
<td>labels. For example, documentation,my:stuff.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** related-labels

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="related-labels">
   <ac:parameter ac:name="labels">choc,cake</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{related-labels:labels=choc,cake}
```

Roadmap Planner Macro

Create simple, visual timelines that are useful for planning projects, software releases and much more with the Roadmap macro.

Roadmaps are made up of:

- bars to indicate phases of work
- lanes to differentiate between teams, products or streams
- markers to highlight important dates and milestones
- a timeline showing months or weeks.

You can provide more information about items on your roadmap by linking a bar to a page.

Adding the Roadmap macro

**To add the Roadmap macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro
Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Editing your Roadmap

To edit your roadmap:

- Select the roadmap and choose Edit.
- Add lanes, bars and markers.
- Drag lanes, bars and markers to the desired location on the roadmap.
- Select lanes, bars and markers to add text, change colors and remove from the roadmap.
- Select bars to add links to existing pages, create new pages or add a description.
- Set the start and end dates for the roadmap and choose to display it by weeks or months.

Screenshot: Roadmap macro in the editor

Parameters

This macro does not use the macro browser to set parameters. You also cannot add this macro via wiki markup or by editing the storage format directly.

Notes

The Roadmap macro was previously available as an add-on from The Marketplace. The macro has changed significantly. If you had an older version of the macro installed you will be able to view your existing roadmaps but not edit them.

RSS Feed Macro

The RSS Feed macro embeds an RSS feed on a page. It can display the contents of external feeds, or of internal feeds generated by Confluence. To display blog posts or to list recently updated pages in a space, use the Feed Builder to create an internal feed, then render it using this macro.

CAUTION: Including unknown HTML inside a webpage is dangerous. HTML inside an RSS feed can contain active scripting components. This means that it would be possible for a malicious attacker to present a user of your site with script that their web browser would believe came from you. Such code could be used, for example, to steal a user’s authentication cookie.
The RSS Feed macro may be disabled by your Confluence administrator. Also, your Confluence administrator can define a whitelist of trusted URLs. You will see an error message on the Confluence page, if the included URL is not in the whitelist.

Using the RSS Feed macro

To add the RSS Feed macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>RSS Feed URL (url)</strong></td>
<td>none</td>
<td>The URL of the RSS feed link you want to show.</td>
</tr>
<tr>
<td><strong>Maximum Number of Entries (max)</strong></td>
<td>15</td>
<td>Limit the number of entries displayed.</td>
</tr>
<tr>
<td><strong>Show Item Titles Only (showTitlesOnly)</strong></td>
<td>false</td>
<td>Show only the titles of the news items, not the content.</td>
</tr>
<tr>
<td><strong>Show Name/Title of RSS Feed (titleName)</strong></td>
<td>true</td>
<td>Hide the feeds title bar.</td>
</tr>
</tbody>
</table>

How up to date is the feed?

By default, the RSS Feed macro caches the feed results for 60 minutes before fetching the data again.

If you wish to change the default caching, use the Cache macro to define how often the RSS Feed macro fetches the feed updates. You will need to install the Cache plugin onto your Confluence site.

What happens to a page containing a disallowed URL?

Your Confluence Administrator can set up a whitelist of allowed URLs. If this is the case, you may see an error on the pages which contain the RSS Feed macro.

A user can add the RSS Feed macro or the HTML-include macro to a Confluence page. The macro code includes a URL from which the content is drawn. When the page is displayed, Confluence will check the URL against the whitelist. If the URL is not allowed, Confluence will display an error message on the page.

The error message says that Confluence “could not access the content at the URL because it is not from an allowed source” and displays the offending URL. If the person viewing the page is a Confluence Administrator, they will also see a link to the Administration page where they can configure the URL whitelist.

Here is an example of the error message, including the link shown only to Confluence Administrators:

and give the attacker their Confluence login password.
Here is an example of the error message, but without the link.

```
Could not access the content at the URL because it is not from an allowed source.
http://feathers.wordpress.com
Configure whitelist >>
```

Authentication

Private feeds from external sites

RSS feeds which require authentication cannot be accessed using the RSS Feed macro.

Accessing internal HTTPS feeds

This applies only to Confluence instances which have enabled HTTPS for all content. If your site is fully HTTPS, the RSS Feed macro cannot access internal feeds. To enable the RSS Feed macro to access internal feeds without affecting your HTTPS setup, enable local-only HTTP access:

1. Shut down Confluence.
2. Consult the SSL guide to enable HTTP access to Confluence. You'll want to ensure that you have an HTTP connector and an SSL connector, both commented in. This means that Confluence will be accessible via both HTTP and HTTPS. However, you should not have a redirect port, nor rules in web.xml to redirect all traffic.
3. Instead of using web.xml to redirect traffic, insert a firewall rule to redirect all HTTP requests not from the Confluence server to the equivalent HTTPS URL. This ensures that users will only be able to access Confluence via HTTPS, as intended. If you have still left HTTP access for attachments enabled (to avoid the IE download bug) you must selectively enable those URLs as well.
4. Modify your Confluence RSS Feed macro feed link to use the HTTP URL, and restart Confluence.

Enabling the RSS Feed macro

The RSS Feed macro is disabled by default.

To enable the RSS Feed macro:

1. Go to
   
   > Add-ons.
2. Select System from the drop down and search for the Confluence HTML Macros add-on.
3. Expand the add-on and enable the rss (rss-xhtml) module.

Code examples

Macro name: rss

Macro body: None.

Storage format example
<ac:structured-macro ac:name="rss">
   <ac:parameter ac:name="max">10</ac:parameter>
   <ac:parameter ac:name="showTitlesOnly">true</ac:parameter>
   <ac:parameter ac:name="url">
      <ri:url ri:value="http://myblog.com/feed"/>
   </ac:parameter>
   <ac:parameter ac:name="titleBar">false</ac:parameter>
</ac:structured-macro>

Wikimarkup example

{rss:max=10|showTitlesOnly=true|url=http://myblog.com/feed|titleBar=false}

Search Results Macro

The Search Results macro searches your Confluence site based on search terms specified in the macro parameters, and displays the results on the wiki page.

Using the Search Results macro

To add the Search Results macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Terms (query)</td>
<td>none</td>
<td>The search terms which this macro will use to generate its results.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can refine your search query by using operators such as ‘AND’ and ‘OR’.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For example: my_query1 AND my_query2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For more information, take a look at the documentation on the Confluence</td>
</tr>
<tr>
<td></td>
<td></td>
<td>search syntax.</td>
</tr>
<tr>
<td>Maximum Number of Results</td>
<td>10</td>
<td>Set a limit to the number of search results displayed.</td>
</tr>
<tr>
<td>(maxLimit)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Restrict to this Space Key</td>
<td>all</td>
<td>Start typing the space name to find the space, or specify the key of the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>space you want to search in. Note that the key is case sensitive.</td>
</tr>
<tr>
<td><strong>Content Type</strong> (type)</td>
<td>all</td>
<td>Specify the content type. The content types are: page, comment, blogpost, attachment, userinfo (the content of user profiles only) and spacedesc (the content of space descriptions only).</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| **Last Modified** (lastModified) | all | Specify a period of time in weeks, days, hours and/or minutes, to see the content modified within that time frame. These are the values you can use: • w = weeks • d = days • h = hours • m = minutes  
For example: • 2h 35m • 3d 30m  
Notes: • If no time category is specified, Confluence assumes minutes.  • If you specify more than one time period (for example, weeks and days), you must separate the periods with a space. You can put them in any order.  • The time categories are not case sensitive. For example, '4d' is the same as '4D'. |
| **Restrict to this Username** (contributor) | all | Specify the username of a Confluence user, to show only content created or updated by that user. |

**Notes**

**Permissions:** When a user views the page containing the Search Results macro, the search results will show only pages and other content types for which the user has 'View' permission.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** search

**Macro body:** None.

**Storage format example**
Section Macro

Used with the Column macro to define columns on a page. See Working with page layouts and columns and sections.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** section

**Macro body:** Rich text, consisting of one or more Column macros.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>border</td>
<td>No</td>
<td>False</td>
<td>If the value is true, the columns in this section will have a dashed border.</td>
</tr>
</tbody>
</table>

**Storage format example**

The following example shows a section and column macro together.
Wiki markup example

{section:border=true}
{column:width=100px}
This is the content of *column 1*.
{column}
This is the content of *column 2*.
{column}
{section}

Space Attachments Macro

The Space Attachments macro displays a list of all files attached to pages in a space. It shows details of the file and includes a link to the page a file is attached to.

Filters allow you to show only files with a particular label or file extension.

Screenshot: The Space Attachments macro
Using the Space Attachments macro

To add the Space Attachments macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

The Space Attachments macro displays a list of all the attachments in a space. You can choose to show attachments from the current space, or another space.

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>(none)</td>
<td>Selects the Confluence space to display attachments for. If you do not specify a space, the current space will be used.</td>
</tr>
<tr>
<td>Show Filter Controls (showFilter)</td>
<td>true</td>
<td>Determines whether or not the filter panel is shown. If you select this option, people viewing the page will be able to filter the list of attachments by file type (extension) and by label.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** space-attachments

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="space-attachments">
  <ac:parameter ac:name="showFilter">false</ac:parameter>
  <ac:parameter ac:name="space">
    <ri:space ri:space-key="ds"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{space-attachments:showFilter=false|space=ds}
```

**Space Details Macro**
The Space Details macro displays the details of a Confluence space, including the space name, description, and more.

Using the Space Details macro

**To add the Space Details macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in [Autocomplete for links, files, macros and mentions](#).

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width of Table</td>
<td>100%</td>
<td>The width of the space details table, specified as a percentage (%) of the page width.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** space-details

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="space-details">
  <ac:parameter ac:name="width">50%</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{space-details:width=50%}
```

**Space Jump Macro**

This page describes the Space Jump macro, which is provided with the [Documentation theme](#). You can use space jumping to link from a page in one space to a page with the same name in another space, without knowing the name of the page when you create the link.
The Space Jump macro inserts a link onto the page. When the reader clicks the link, they will jump to a page that has the same name in another space. You specify the space when you insert the Space Jump macro.

**Example:** We use the Space Jump macro to put a standard message at the top of our archive spaces, telling people that they’re reading an old version of the documentation and letting them jump quickly to the same page in the latest documentation. See the words 'this page in the current documentation' in the screenshot below.

**Screenshot:** One way of using the Space Jump macro

---

### Configuring the Documentation Theme

### Using the Space Jump macro

**To add the Space Jump macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ ` and the beginning of the macro name, to see a list of suggested macros. Details are in [Autocomplete for links, files, macros and mentions](https://confluence-docs.atlassian.com/customer帮助中心).

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>None</td>
<td>The space key that contains a page with the same page title that you want the link to jump to. Space keys are case-sensitive.</td>
</tr>
<tr>
<td>Alias</td>
<td>None</td>
<td>The text to display as the hyperlinked text. If you do not supply an alias, Confluence will display the page name.</td>
</tr>
</tbody>
</table>

### Notes

**What happens if there is no page with the same name in the target space?**

For the space jump to work, the target space must contain a page with the same name as the page that renders the Space Jump macro. If the target space does not contain such a page, you will see a broken link. Confluence handles this in its usual manner: the link is colored red. If you click the link, Confluence offers to create the page for you.
Can I use the Space Jump macro in any space?

Yes. You can use the Space Jump macro in any space, even if that space is not currently using the Documentation theme. Provided that the Documentation theme plugin and its components are installed and enabled on your Confluence site, the Space Jump macro is available in any space.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** spacejump

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="spacejump">
  <ac:parameter ac:name="alias">My Space</ac:parameter>
  <ac:parameter ac:name="space">
    <ri:space ri:space-key="SS"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{spacejump:alias=my link|space=ds}
```

Spaces List Macro

Use the Spaces List macro to display a list of spaces on a page.

Using the Spaces List macro

**To add the Spaces List macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in [Autocomplete for links, files, macros and mentions](#).

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2016 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
1. **Scope of spaces**
   - no  all
   - The view from which spaces are listed. Available options are:
     - **(blank)** - All spaces in your site, with tabs.
     - **all** - All spaces in your Confluence site.
     - **category** - Spaces grouped according to space categories.
     - **favorite** - Spaces which you have added to My Spaces.
     - **new** - spaces created within the last 7 days.
     - This parameter is unnamed in wiki markup and storage format.

2. **Width of List (width)**
   - no  100%
   - The width of the spaces list, specified as a percentage (%) of the window width.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** spaces

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="spaces">
    <ac:parameter ac:name="width">80%</ac:parameter>
    <ac:parameter ac:name="">favourite</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{spaces:favourite|width=80%}
```

**Status Macro**

The Status macro displays a colored lozenge (a rounded box) that is useful for reporting project status. You can choose the color of the lozenge and the text that appears inside the lozenge. The macro also displays its current status in the editor, and you can change the status directly in the editor.

**ALL GOOD!**

**Screenshot:** Click on the Status macro lozenge to change the status.

**Using the Status macro**

**To add the Status macro to a page using the Macro Browser:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find and select the required macro
**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Color</strong> <em>(colour)</em></td>
<td>Grey</td>
<td>The color of the lozenge. The following colors are available: Grey, Red, Yellow, Green and Blue.</td>
</tr>
<tr>
<td><strong>Title</strong> <em>(title)</em></td>
<td>The color that you select.</td>
<td>The text that will appear inside the lozenge. If you do not specify any text, the title will be the color of the lozenge, that is ‘Grey’, ‘Red’, ‘Yellow’, ‘Green’ or ‘Blue’.</td>
</tr>
<tr>
<td><strong>Use outline style</strong> <em>(subtle)</em></td>
<td>False</td>
<td>The style of the lozenge and its border. The default style lozenge is a solid background color with white text. The outline style lozenge is white with a colored border and colored text as shown here</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** status

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="status">
  <ac:parameter ac:name="colour">Green</ac:parameter>
  <ac:parameter ac:name="title">On track</ac:parameter>
  <ac:parameter ac:name="subtle">true</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{status:colour=Green|title=On track|subtle=true}
```

**Table of Contents Macro**

The Table of Contents macro scans the headings on the current Confluence page to create a table of contents based on those headings. This helps readers find their way around lengthy pages, by summarizing the content structure and providing links to headings.

Want to see the Table of Contents macro in action? Check out how it's used in Creating insightful customer interview pages.
Using the Table of Contents macro

Hint: For quick access from the editor toolbar, choose Insert > Table of Contents.

To add the Table of Contents macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Macro parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Output Type</strong> (type)</td>
<td>list</td>
<td>• list — produces a typical list-type table of contents.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• flat — produces a horizontal menu-type series of links.</td>
</tr>
<tr>
<td><strong>Display Section Numbering</strong> (outline)</td>
<td>clear</td>
<td>Select the check box to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.</td>
</tr>
<tr>
<td><strong>List Style</strong> (style)</td>
<td>disc</td>
<td>Select the style of bullet point for each list item. You can use any valid CSS style. For example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• none — no list style is displayed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• circle — the list style is a circle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• disc — the list style is a filled circle. This is the typical bullet list, and is used for this example list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• square — the list style is a square</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• decimal — the list is numbered (1, 2, 3, 4, 5)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• lower-alpha — the list is lower-case, alphabetized (a, b, c, d, e)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• lower-roman — the list style is lower roman numerals (i, ii, iii, iv, v, vi)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• upper-roman — the list style is upper roman numerals (I, II, III, IV, V, VI)</td>
</tr>
<tr>
<td><strong>Heading Indent</strong> (indent)</td>
<td></td>
<td>Sets the indent for a list according to CSS quantities. Entering 10px will successively indent heading groups by 10px. For example, level 1 headings will be indented 10px and level 2 headings will be indented an additional 10px.</td>
</tr>
<tr>
<td><strong>Separator</strong> (separator)</td>
<td>brackets</td>
<td>This parameter applies to flat lists only. You can enter any of the following values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• brackets — Each item is enclosed by square brackets: [ ].</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• braces — Each item is enclosed by braces: { }.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• parens — Each item is enclosed by parentheses: ( ).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• pipe — Each item is separated by a pipe:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• anything — Each item is separated by the value you enter. You can enter any text as a separator, for example &quot;***&quot;. If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters.</td>
</tr>
</tbody>
</table>
### Minimum Heading Level (minLevel)

<table>
<thead>
<tr>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
</tr>
</tbody>
</table>

Select the highest heading level to start your TOC list. For example, entering 2 will include levels 2, and lower, headings, but will not include level 1 headings.

### Maximum Heading Level (maxLevel)

<table>
<thead>
<tr>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>7</td>
</tr>
</tbody>
</table>

Select the lowest heading level to include. For example, entering 2 will include levels 1 and 2, but will not include level 3 headings and below.

### Include Headings (include)

Filter headings to include according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings.

### Exclude Headings (exclude)

Filter headings to exclude according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings.

### Printable (printable)

<table>
<thead>
<tr>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>checked</td>
</tr>
</tbody>
</table>

By default, the TOC is set to print. If you clear the check box, the TOC will not be visible when you print the page.

### CSS Class Name (class)

If you have custom TOC styles in your CSS style sheet, use this parameter to output the TOC inside `<div>` tags with the specified class attribute.

### Absolute URL (absoluteURL)

<table>
<thead>
<tr>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>checked</td>
</tr>
</tbody>
</table>

By default, the links in the TOC are relative URLs pointing to the current page. If checked, the links in the TOC will be full URLs. This setting is useful when you are including a page with a Table of Contents in another page, and want to control where the links should take the user.

### Examples

The examples below are based on this table of contents:

- Places
  - Favourite Places
  - Unknown Places
- Foods
  - Favourite Foods
  - Unknown Foods
- Things
  - Favourite Foods
  - Unknown Foods

#### Filtered Table of Contents

This example filters the headings to include those that contain 'Favorite', but excludes headings which end with 'Things'. The list is styled with Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
</tbody>
</table>
Exclude Headings .*Things

The resulting table of contents is:

I. Favourite Places
II. Favourite Foods

Flat List

This example filters all headings to render a flat list of 'Unknowns' enclosed in square brackets (the default list style).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Maximum Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

[ Unknown Places ] [ Unknown Foods ] [ Unknown Foods ]

Notes

- When you use a Table of Contents macro in a template, you will see an error when you preview the template itself. But the Table of Contents macro works on the pages that people create from the template – the table of contents shows up after they have saved the page. (This is probably because the template is not defined as a page, and the Table of Contents macro works for pages only.)
- Due to an outstanding issue in the Table of Contents macro (CONF-10619), the macro browser's Refresh function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Contents macro occurs only after the page is saved.
- Using HTML heading markup with the Table of Contents macro
  The Table of Contents macro cannot handle HTML heading markup on its own. Hence, if you use the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Contents macro will not create a contents list out of these headings. (For more information about this issue, please refer to TOC-93.) However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Contents macro will incorporate these headings into your contents list.

```html
<h2><a name="pagename-headingname"></a>Heading Name</h2>
```

The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: toc
Macro body: None.

Storage format example

This example shows a list-type table of contents.

```xml
<ac:structured-macro ac:name="toc">
  <ac:parameter ac:name="printable">true</ac:parameter>
  <ac:parameter ac:name="style">square</ac:parameter>
  <ac:parameter ac:name="maxLevel">2</ac:parameter>
  <ac:parameter ac:name="indent">5px</ac:parameter>
  <ac:parameter ac:name="minLevel">2</ac:parameter>
  <ac:parameter ac:name="class">bigpink</ac:parameter>
  <ac:parameter ac:name="exclude">[1//2]</ac:parameter>
  <ac:parameter ac:name="type">list</ac:parameter>
  <ac:parameter ac:name="outline">true</ac:parameter>
  <ac:parameter ac:name="include">.*</ac:parameter>
</ac:structured-macro>
```

This example shows a flat table of contents.

```xml
<ac:structured-macro ac:name="toc">
  <ac:parameter ac:name="maxLevel">2</ac:parameter>
  <ac:parameter ac:name="minLevel">2</ac:parameter>
  <ac:parameter ac:name="class">bigpink</ac:parameter>
  <ac:parameter ac:name="exclude">[1//2]</ac:parameter>
  <ac:parameter ac:name="type">flat</ac:parameter>
  <ac:parameter ac:name="outline">true</ac:parameter>
  <ac:parameter ac:name="separator">pipe</ac:parameter>
  <ac:parameter ac:name="include">.*</ac:parameter>
</ac:structured-macro>
```

Wiki markup example

This example shows a list-type table of contents.

```
{toc:printable=true|style=square|maxLevel=2|indent=5px|minLevel=2|class=bigpink|exclude=[1//2]|type=list|outline=true|include=.*}
```

This example shows a flat table of contents.

```
{toc:printable=true|maxLevel=2|minLevel=2|class=bigpink|exclude=[1//2]|type=flat|outline=true|separator=pipe|include=.*}
```

Table of Content Zone Macro

You can use the Table of Content Zone macro to mark out a section (zone) within the page from which to create a table of contents. You can style the headings as a flat list, and place the list of links at the top and bottom of the section or page, to provide navigation bars similar to web navigation.

Using the Table of Content Zone macro
To add the Table of Content Zone macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>location (location)</strong></td>
<td>both</td>
<td>Specifies where in the zone the output list is displayed: <strong>top</strong>, <strong>bottom</strong>, or <strong>both</strong>, which encloses the page zone content.</td>
</tr>
<tr>
<td><strong>Output Type (type)</strong></td>
<td>list</td>
<td>Specifies the layout for the table of contents:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>list</strong> – produces a vertical list, typical of a TOC.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>flat</strong> – produces a horizontal menu-type series of links, for example: [Heading 1] [Heading 2] [Heading 3].</td>
</tr>
<tr>
<td><strong>Display Section Numbering (outline)</strong></td>
<td>false</td>
<td>Select to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.</td>
</tr>
<tr>
<td><strong>List Style (style)</strong></td>
<td>none</td>
<td>Specifies the style of bullet point for each list item. You can use any valid CSS style. For example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>none</strong> — no list style is displayed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>circle</strong> — the list style is a circle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>disc</strong> — the list style is a filled circle. This is the typical bullet list, and is the one we're using for this example list</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>square</strong> — the list style is a square</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>decimal</strong> — the list is numbered (1, 2, 3, 4, 5)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>lower-alpha</strong> — the list is lower-case, alphabetized (a, b, c, d, e)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>lower-roman</strong> — the list style is lower roman numerals (i, ii, iii, iv, vi)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>upper-roman</strong> — the list style is upper roman numerals (I, II, III, IV, V, VI)</td>
</tr>
<tr>
<td><strong>Heading Indent (indent)</strong></td>
<td></td>
<td>Sets the indent for a <strong>list</strong> output type, according to CSS quantities. Entering &quot;10px&quot; will successively indent list heading levels by 10px. For example, h1 headings will be indented 10px and h2 headings will be indented an additional 10px.</td>
</tr>
<tr>
<td><strong>Separator (separator)</strong></td>
<td>brackets</td>
<td>Only applies to the <strong>flat</strong> output type. Specifies the display style of the links. You can enter any of the following values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>brackets</strong> — Each item is enclosed by square brackets: [ ].</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>braces</strong> — Each item is enclosed by braces: { }.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>paren</strong> — Each item is enclosed by parentheses: ( ).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>pipe</strong> — Each item is separated by a pipe:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>anything</strong> — Each is separated by the value you enter. You can enter any text as a separator, for example &quot;***&quot;. If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters.</td>
</tr>
</tbody>
</table>
Minimum Heading Level (minLevel) | 1 | Select the largest heading level to start your TOC list. For example, 2 will list h2, h3, and h4 headings, but will not include h1 headings.

Max Heading Level (maxLevel) | 7 | Select the smallest heading level to include in the TOC. For example, 2 will list h1 and h2, but will not include h3 and below.

Include Headings (include) | Filter the included headings according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings.

Exclude Headings (exclude) | Exclude headings according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings.

Printable (printable) | true | By default, the TOC is set to print. If you clear this parameter, the TOC will not be visible when you print the page.

CSS Class Name (class) | If you have a custom TOC in your CSS style sheet, you can use this parameter to output the TOC with the specified "class" attribute.

Examples

The examples are based on a page with the following headings:

- Places
  - Favourite Places
  - Unknown Places
- Foods
  - Favourite Foods
  - Unknown Foods
- Things
  - Favourite Foods
  - Unknown Foods

Filtered Table of Contents

This example will filter all headings to include those that contain "Favorite", but will exclude any heading which ends with the word "Things". The list is styled with upper-case Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>list</td>
</tr>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
<tr>
<td>Exclude Headings</td>
<td>.*Things</td>
</tr>
</tbody>
</table>
### Screenshot: Filtered TOC 'zone' headings

<table>
<thead>
<tr>
<th>Flat List</th>
</tr>
</thead>
<tbody>
<tr>
<td>This example will filter all headings to render a flat list of &quot;Unknowns&quot; enclosed in square brackets.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Separator</td>
<td>brackets</td>
</tr>
<tr>
<td>Max Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

### Screenshot: Filtered TOC 'zone' headings displayed as a flat list

[ Unknown Places ] [ Unknown Foods ] [ Unknown Foods ]

### Notes

- Due to an outstanding issue in the Table of Content Zone macro ([CONF-10619](#)), the Macro Browser's [Refesh](#) function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Content Zone macro occurs only after the page is saved.
- Using HTML heading markup with the Table of Content Zone macro — The Table of Content Zone macro cannot handle HTML heading markup on its own. Hence, if you used the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Content Zone macro will not create a contents list out of these headings. (For more information on about this issue, please refer to [TOC-93](#).)

However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Content Zone macro will incorporate these headings into your contents list.

```
<h2><a name="pagename-headingname"></a>Heading Name</h2>
```

The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** toc-zone

**Macro body:** Accepts rich text.

*Storage format example*
Task Report Macro

Use the Task Report macro to display a list of tasks on a page. Filter the tasks by space, page, user, label, created date and more.

See Add, Assign, and View Tasks for more information on creating and assigning tasks. You can also use the Task Report blueprint, which will create a page and add this macro for you.

Using the Task Report macro

To add the Content Report Table macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Task Report macro showing incomplete tasks, on pages with the label 'meeting-notes'.

---

Wiki markup example

{toc-zone:printable=false|maxLevel=2|minLevel=2|location=top|type=flat|outline=true|separator=pipe}
Only headings within this block are included in the table of contents.
{toc-zone}
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space(s) and Page(s) (spaceAndPage)</td>
<td>No</td>
<td>None</td>
<td>Filter by the task location. The macro will only display tasks in the pages or spaces specified. You can enter a combination of spaces and pages.</td>
</tr>
<tr>
<td>Label(s) (labels)</td>
<td>No</td>
<td>None</td>
<td>Filter by Label. The macro will only display tasks on pages with this label. You can enter multiple labels, separated by a comma.</td>
</tr>
<tr>
<td>Assigned to (assignee)</td>
<td>No</td>
<td>None</td>
<td>Filter by Assignee. The macro will only display tasks assigned to the users specified.</td>
</tr>
<tr>
<td>Created by (creator)</td>
<td>No</td>
<td>None</td>
<td>Filter by Creator. The macro will only display tasks created by the users specified.</td>
</tr>
<tr>
<td>Created after (createddateFrom)</td>
<td>No</td>
<td>None</td>
<td>Filter by created date. The macro will only display tasks created on or after the date specified. Date must be entered as dd-mm-yyyy.</td>
</tr>
<tr>
<td>Task status (status)</td>
<td>Yes</td>
<td>Incomplete</td>
<td>Show complete or incomplete tasks.</td>
</tr>
<tr>
<td>Number of tasks to display (pageSize)</td>
<td>No</td>
<td>20</td>
<td>The number of tasks to display on each page of results in the table. Choose from 10, 20 or 40.</td>
</tr>
<tr>
<td>Display columns (columns)</td>
<td>No</td>
<td>description,duedate,assignee,location</td>
<td>Columns to include in the table. Available columns include description, duedate, assignee, location, completedate and labels.</td>
</tr>
</tbody>
</table>
Sort by (sortBy) | No | Due date | Sort tasks by due date, assignee or page title. Select the Reverse Sort check box to sort the table in reverse order.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: tasks-report-macro

Macro body: None.

Storage format example

Note: The spaceAndPage multi-picker parameter populates the spaces and pages parameters.

```xml
<ac:structured-macro ac:name="tasks-report-macro">
  <ac:parameter ac:name="spaces">BSP</ac:parameter>
  <ac:parameter ac:name="status">complete</ac:parameter>
  <ac:parameter ac:name="assignees">
    <ri:user ri:userkey="2c9682654373c47f014373caa68a0003"/>
  </ac:parameter>
  <ac:parameter ac:name="spaceAndPage">space:BSP,page:2555905</ac:parameter>
  <ac:parameter ac:name="pages">2555905</ac:parameter>
  <ac:parameter ac:name="labels">meeting-notes</ac:parameter>
  <ac:parameter ac:name="pageSize">10</ac:parameter>
</ac:structured-macro>
```

Wiki markup

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

User List Macro

The User List macro displays a list of Confluence users, based on their group membership. The macro can also indicate when users are online or offline.

Using the User List macro

To add the User List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Group(s) (groups)</strong></td>
<td>none</td>
<td>Specify the group name. Specify multiple groups separated by a comma, or use * to show all users in Confluence. See this knowledge base page for more information about controlling which users can see the details of other users.</td>
</tr>
</tbody>
</table>
| **Display Online/Offline Users (online)** | All registered users | List online or offline users. Leave blank to show all users, irrespective of status. Accepted values:  
  - Unspecified – The macro will show all registered users.  
  - true – The macro will show only online users.  
  - false – The macro will show only offline users.  
  See below for information on how to configure this macro to display online / offline users. |

**Configuring the User List macro**

In order to use the **Display Online / Offline Users** parameter to indicate whether users are currently logged into Confluence, you will need to enable the User Log In Listener component in the add-on that provides this macro. You'll need Confluence Administrator permissions to do this.

**To enable the Display Online/Offline Users filter in the User List macro:**

1. Go to > Add-ons
2. Select System from the drop down and search for the User Lister add-on
3. Expand the add-on and enable the User Log In Listener module.
4. Restart Confluence for the change to take effect.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** userlister

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="userlister">
  <ac:parameter ac:name="groups">confluence-users</ac:parameter>
  <ac:parameter ac:name="online">false</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```wiki
{userlister:groups=confluence-users|online=false}
```
User Profile Macro

The User Profile macro displays a short summary of a given Confluence user's profile. This is the same summary that appears in a Hover Profile, which appears whenever you mouse over a user's name in the Confluence interface.

Screenshot: Example of the User Profile macro

![Leah Admin sample@email.com.au](example)

Position: Tech Writer
Department: Department of Awesome
Location: Atlassian, Sydney

Using the User Profile macro

To add the User Profile macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username (user)</td>
<td>none</td>
<td>The username of the Confluence user whose profile summary you wish to show.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** profile

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="profile">
  <ac:parameter ac:name="user">
    <ri:user ri:userkey="12345678912345678912345678912345"/>
  </ac:parameter>
</ac:structured-macro>
```
View File Macro

The View File macros are going away in a future release

Read more about this change or find out about a better way to insert Office and PDF files.

The View File macros allow you to embed an Office or PDF document on a page. First attach the document to a page and then use one of the View File macros to display the document's content.

When people view the page, they will see the content of the Office or PDF document. They do not need to have Office installed in order to see the content of the file.

For a full list of Office Connector prerequisites and limitations, please refer to:

- Office Connector Prerequisites
- Office Connector Limitations and Known Issue

Displaying an Office or PDF Document in Confluence

To display an Office or PDF document in a page, use one of the following View File macros in the macro browser:

- Office Excel
- Office PowerPoint
- Office Word
- PDF

To add one of the View File macros to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters for the Office and PDF macros

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Macro</th>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All View File macros</td>
<td>Page Name</td>
<td>The page which contains the macro</td>
<td>Enter a page name, if you wish to display a document which is attached to another Confluence page.</td>
</tr>
<tr>
<td></td>
<td>File Name</td>
<td>none</td>
<td>The file name of the Office or PDF document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>Office Excel</td>
<td>Show Grid?</td>
<td>true</td>
<td>Select to show grid lines around each cell of the Excel spreadsheet. Clear to hide these grid lines.</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Worksheet Name</td>
<td>Last worksheet viewed in the spreadsheet</td>
<td></td>
<td>The name of the worksheet that you want displayed.</td>
</tr>
<tr>
<td>Last Row</td>
<td>Last row with content</td>
<td></td>
<td>The number of the last row you want displayed, starting from '0' as the first row.</td>
</tr>
<tr>
<td>Last Column</td>
<td>Last column with content</td>
<td></td>
<td>The number of the last column you want displayed, starting from '0' as the first column.</td>
</tr>
</tbody>
</table>

**Hint for reducing the size of the spreadsheet:** Use the Last Column and Last Row parameters to reduce the size of the spreadsheet displayed on the wiki page. This is especially useful to prevent the display from showing empty cells. This will also help to prevent 'out of memory' errors.

<table>
<thead>
<tr>
<th>Office PowerPoint</th>
<th>Height</th>
<th></th>
<th>Specify the height of the display, in pixels (default) or as a percentage of the window’s height.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slide Number</td>
<td>none</td>
<td></td>
<td>Specify the number of the slide that you want displayed on the Confluence page, where the first slide is numbered zero. Instead of a slide show, the page will display just the single slide, represented as a JPEG image. If not specified, all slides display as a slideshow.</td>
</tr>
<tr>
<td>Width</td>
<td></td>
<td></td>
<td>Specify the width of the display, in pixels (default) or as a percentage of the window’s width.</td>
</tr>
</tbody>
</table>

**Editing an Office document**

You can launch your Office application and edit Office documents displaying in the view file macros directly from your Confluence page.

- **Word** and **Excel** - choose the **Edit Document** link above the content
- **PowerPoint** - choose the edit icon on the viewer.

You will find more information and other methods for editing attached Office documents in **Edit Office Files**.

**Troubleshooting**

Problems? Please refer to our guide to the Office Connector limitations and known issues.

**Widget Connector Macro**

Embed online videos, slideshows, photostreams and more directly into your page with the Widget Connector macro.

The macro currently supports content from these sites:

- YouTube
- Vimeo
- MySpace Video
- Flickr
- Twitter
- Slide Rocket
- Google Calendar
Using the Widget Connector

To add the Widget Connector to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web Site's Widget URL (url)</td>
<td>This is the external site's URL. In some sites this will be the URL shown in the address bar of your browser, and in other sites you may need to click a Share or Link button to get the URL.</td>
</tr>
<tr>
<td>Pixel Height (Value Only) (height)</td>
<td>The height of the display, in pixels.</td>
</tr>
<tr>
<td>Pixel Width (Value Only) (width)</td>
<td>The width of the display, in pixels.</td>
</tr>
</tbody>
</table>

Examples

Every site is a little different, so we've put together some info on what you'll need to do to embed each site's content on a page.

YouTube

The fastest way to embed a YouTube video is to paste the URL into the editor. Confluence will autoconvert the link and insert the macro for you, like magic. Autoconvert works with both long and short YouTube URLs.

If you're pasting the URL into the Widget Connector macro URL field manually, you'll need to use the long URL (from the address bar). Long URLs look something like this https://www.youtube.com/watch?v=k6lK5hlB1nQ.
Vimeo

The fastest way to embed a Vimeo video is to paste the URL into the editor. Confluence will autoconvert the link and insert the macro for you.

You can use the URL from the address bar in your browser or the Share button in Vimeo.

MySpace Video

We don't autoconvert MySpace videos, so you'll need to add the Widget Connector macro to your page first, and then paste the video's URL into the URL field.

You can use the URL from the address bar in your browser or the Sharing options in MySpace.

Flickr

You can embed a single photo, a set, an entire user's photo stream or collection of photos with a particular tag.

The fastest way is to paste a URL into the editor. This works for sets and tags. For other URLs you'll need to add the Widget Connector macro to the page first and then paste your link into the URL field.

Use the URL from the address bar in your browser.

Twitter

To embed a single tweet you'll need to click the Details link on the tweet so you can grab the URL for just that tweet. The URL will look something like https://twitter.com/atlassian/status/346976521250037760.

- If you're not able to see the video in some browsers, try using https rather than http in your link.
- Links that contain a parameter to start a video at a particular time won't autoconvert or work in the Widget Connector macro, like this link: https://www.youtube.com/watch?v=LhHKkodOPFo. Paste in the short sharing URL to be sure it works.
To embed a dynamic list of tweets you'll need to create a Widget in Twitter first:

1. In Twitter, go to **Settings > Widgets** and create a widget to display the tweets you want to embed (for example, a user timeline, list of tweets or hashtag search).
2. Save the widget, then copy the page URL. The URL should look something like this [https://twitter.com/settings/widgets/354381809263472640](https://twitter.com/settings/widgets/354381809263472640) (without /edit on the end).
3. In Confluence, paste the URL into the Widget Connector.
4. The list of tweets will display, like this one below.

---

**SlideRocket**

We don't autoconvert SlideRocket presentations, so you'll need to add the Widget Connector macro to your page first, and then paste the video's URL into the URL field.

You can get the URL from the **Sharing** button on the SlideRocket player.

**Google Calendar**

We don't autoconvert Google Calendars, so you'll need to add the Widget Connector macro to your page first, and then paste the calendar address into the URL field.

You can only embed public calendars. To get your calendar's URL, in Google Calendar go to **Calendar Settings > Calendar Address** and click the **HTML** button.

The URL will look something like this: [https://www.google.com/calendar/embed?src=en.australian%23holiday%40group.v.calendar.google.com&ctz=Australia/Sydney](https://www.google.com/calendar/embed?src=en.australian%23holiday%40group.v.calendar.google.com&ctz=Australia/Sydney)
Troubleshooting

If the Widget Connector can't display content from the external site, the macro will look like this:

example.com

We rely on the external website's APIs to display content in the Widget Connector macro. APIs do change from time to time and this can cause the Widget Connector macro to stop rendering content.

If you experience problems, you can raise an issue about it to let us know.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** widget

**Macro body:** None.

```
{widget:height=400|width=400|url=http://youtube.com/watch?v=23pLByj_q5U}
```

Your Profile and Settings

Confluence is very flexible – not only in the many ways you can create and share content, but also in how you can tailor your own Confluence experience. Things like your profile picture, favorite spaces and pages, and your personal space can say a lot about you, and can also make navigating Confluence much quicker and easier. Even a simple thing like adding shortcut links to the sidebar of your personal space, can save you a lot of time in finding the things you use all the time.

**Set up your personal space**, and take a look at any of the pages below, to start making Confluence feel like home.

- Your User Profile
- Change Your Password
- Edit Your User Settings
- Set Your Profile Picture
- Choose Your Home Page
- Save for later
- View and Revoke OAuth Access Tokens

**Your User Profile**

Your user profile contains basic information about you, which other Confluence users can see. It's also displayed to other users when they click your name in the People Directory, if you haven't set up your personal space.

In your own profile, you can access account management features and update information about yourself, like your name, email address, and password. You can also view other users' profiles.

**Find your user profile**

**To find your user profile:**

Choose your profile picture at top right of the screen, then choose Profile, or choose the Profile link in the sidebar of your personal space.
To find someone else's user profile:
Hover your mouse pointer over a user's linked name or profile picture and choose the user's linked name to open their user profile. Alternatively, you can choose the Profile link in the sidebar of their personal space, or go directly to this URL:

http://your.confluence.site/users/viewuserprofile.action?username=USERNAME

Screenshot: User profile screen for the current user

From your user profile, you can access the following:

<table>
<thead>
<tr>
<th>Profile</th>
<th>View and edit your personal details, such as your name and email address details and optionally, your photograph and other personal information. Note that as a security precaution, in order to change your email address, you will be required to re-enter your password.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Upload a profile picture (optional).</td>
</tr>
<tr>
<td></td>
<td>• Change your password.</td>
</tr>
<tr>
<td>Network</td>
<td>View the recent activity of users that you are following via the Network view.</td>
</tr>
<tr>
<td></td>
<td>• Follow other users from this view.</td>
</tr>
<tr>
<td>Favorites</td>
<td>View a list of your favorite spaces.</td>
</tr>
<tr>
<td>Watches</td>
<td>View a list of the pages and spaces you are currently watching.</td>
</tr>
<tr>
<td>Drafts</td>
<td>Retrieve any pages you were in the process of editing. See Working with Drafts.</td>
</tr>
<tr>
<td>Settings</td>
<td>• Edit your General Settings (homepage, language and timezone).</td>
</tr>
<tr>
<td></td>
<td>• Subscribe to email notifications.</td>
</tr>
<tr>
<td></td>
<td>• View and revoke your OAuth access tokens.</td>
</tr>
</tbody>
</table>

Edit your user profile
1. Choose your profile picture at top right of the screen, then choose **Profile**
   Or, choose the **Profile** link in the sidebar of your personal space.
2. Choose **Edit Profile**
3. Enter details about yourself in the form displayed
4. Choose **Save**

### Fields in your user profile:

<table>
<thead>
<tr>
<th>Detail</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Name</td>
<td>Your name as you'd like it to appear in your profile.</td>
</tr>
<tr>
<td>Email</td>
<td>Your email address that will be used to send you mail notifications.</td>
</tr>
<tr>
<td>Phone</td>
<td>Your phone number.</td>
</tr>
<tr>
<td>IM</td>
<td>Your Instant Messenger (IM) details. To suit a variety of IM applications,</td>
</tr>
<tr>
<td></td>
<td>this option accepts any string value. For example, you can enter IM details</td>
</tr>
<tr>
<td></td>
<td>in the form of an email address, or a user ID, like '123456789'.</td>
</tr>
<tr>
<td>Website</td>
<td>Your website's URL.</td>
</tr>
<tr>
<td>About me</td>
<td>Information about yourself that other users can view (such as your</td>
</tr>
<tr>
<td></td>
<td>professional information, hobbies, and other interests). You can use</td>
</tr>
<tr>
<td></td>
<td><strong>Confluence wiki markup</strong> in this field.</td>
</tr>
<tr>
<td>Position</td>
<td>Your title or position within your organization.</td>
</tr>
<tr>
<td>Department</td>
<td>The name of your department or team.</td>
</tr>
<tr>
<td>Location</td>
<td>Your location. This can be your town, city, region or country.</td>
</tr>
</tbody>
</table>

### Handy Hint

Confluence administrators can configure Confluence to mask email addresses (e.g. 'example at atlassian dot com'), protecting your email address from search engine spiders and the like.

### Notes

The ‘Administer User’ link is visible to Confluence administrators only. The administrator can click this link to go directly to the user management screen in the Administration Console.

### Change Your Password

There are two scenarios where you may want to change your Confluence password:

- You're logged in, but you want or need to change your password
- You've forgotten your password and can't log in, so you need to reset your password

#### Change your password when you're logged in:

1. Choose your profile picture at top right of the screen, then choose **Profile**
2. On your **Profile** tab, click **Password** in the left-hand column
3. Enter your current password and your new password in the form displayed
4. Click **Submit**

#### Reset your password from the login page:

If you've forgotten your password and need to reset it, you can do so from the Confluence login page. Choose the ‘Forgot your password?’ link and Confluence will step you through the process to reset your password.

### Related Topics:

- Your User Profile
- Set Your Profile Picture
- Create a Personal Space
password.

**Edit Your User Settings**

If you want to make Confluence fit *you*, like a well-worn pair of sneakers, you can set some preferences that will make you feel more at home:

- **General preferences** such as home page, language and time zone
- **Editor settings**
- **Email settings** for subscriptions to email reports.
- **OAuth access tokens** that you have granted from your Confluence user account.

**General User Preferences**

**To edit your general user settings:**

1. Choose *your profile picture* at top right of the screen, then choose **Settings**
2. Choose *Edit* and update the settings
3. Choose *Submit*

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site Homepage</td>
<td>Select the page that you would like to see whenever you log into Confluence.</td>
</tr>
<tr>
<td>Language</td>
<td>Select your language. See below.</td>
</tr>
<tr>
<td>Time zone</td>
<td>Select your time zone.</td>
</tr>
<tr>
<td>Use Keyboard Shortcuts</td>
<td>Enable <em>keyboard shortcuts</em>, other than for the editor.</td>
</tr>
<tr>
<td>Text select</td>
<td>Turn off the popup options panel when highlighting text.</td>
</tr>
</tbody>
</table>

*Screenshot: Editing your user profile settings*
More about Language

Setting your language preference in your user profile is described in the section above. This section gives more information about that setting and other settings that affect the language Confluence will use.

Individual users can choose the language that Confluence will use to display screen text and messages. Note that the list of supported languages depends on the language packs installed on your Confluence site.

The language used for your session will depend on the settings below, in the following order of priority from highest to lowest:

- The language preference defined in your user profile. Note that you need to be logged in for this setting to take effect.
- The language that you choose by clicking an option at the bottom of the Confluence login screen. Confluence stores this value in a cookie. When the cookie expires, the setting will expire too.
- The language set in your browser. The browser sends a header with a prioritized list of languages. Confluence will use the first supported language in that list. Your Confluence administrator can disable this option by setting a system property.
- The default language for your site, as defined by your Confluence site administrator.

Editor Preferences

You can set some options that determine the way the Confluence editor works. Note that these settings affect only you. Other people using Confluence can enable or disable the settings on their user profiles independently.

To change your editor preferences:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Click Editor under ‘Your Settings’ in the left-hand panel
3. Click Edit and make your changes
4. Click Submit
<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable Autocomplete</td>
<td>Select to disable autocompletion when you press one of the trigger characters.</td>
</tr>
<tr>
<td>Disable Autoformatting</td>
<td>Select to disable autoformatting when you type wiki markup in the editor. Click ? on the editor toolbar to learn more.</td>
</tr>
</tbody>
</table>

Screenshot: User settings for the editor

Set Your Profile Picture

Your profile picture is used as the icon for your personal space, to represent you in the People Directory, and to illustrate your comments. It also appears in various other places next to your name, such as in the list of recent updates on the dashboard.

When you upload your profile picture, you can resize and reposition it to make sure it looks great.

Upload and adjust your profile picture:

1. Choose your profile picture at top right of the screen, then choose Profile
2. Choose Picture on the left
3. Choose Upload image > Upload image
4. Locate and select the picture on your computer or file server
5. Adjust the size and position of your photo, then choose Save

Screenshot: Choosing a profile picture

Related pages:
- Your User Profile
- Create a Personal Space
- Your Profile and Settings

Screenshot: Resize your profile picture
Choose Your Home Page

The dashboard is the default landing page when you log into Confluence. It gives you easy access to what's happening in your site, and helps you get back to pages you recently viewed and worked on.

You can choose to personalize your experience. and use an existing space home page as your landing page.

To set your home page:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Choose Edit
3. Choose an option from the Site Homepage drop down. Only spaces you're allowed to view will appear.
4. Choose Submit.

You'll be directed to your new home page the next time you log in. You can change your personal home page at any time.

Alternatively, if your Confluence administrator has set a space home page as the landing page for the whole site, you can choose Dashboard from the Site Homepage drop down to use the dashboard as your landing page.

Screenshot: Profile Settings
You can access the dashboard at any time using the dashboard URL. It'll look something like this: https://yoursite.com/wiki/dashboard.action.

Save for later

Saving pages for later helps you access them quickly from the dashboard or from your profile.

No time to read that page now? No problem, hit Save for later and it'll be waiting for you on the dashboard when you have more time. It's also a great place to store those pages that you use on a day to day basis.

Save for later was previously called Favorites.

Save a page for later

To save a page for later, hit the Save for later button at the top of the page.

The star icon will change to dark grey to indicate the page is saved. Hit the button again if you want to remove the page from the list.

Get back to your saved pages

To view your saved pages:

- Choose Save for later on the dashboard sidebar.
- Choose your profile picture at top-right of the screen, then choose Saved for later – there's a list of your saved pages, and the spaces that you've added to My spaces.

You can also use the Favorite Pages Macro to include a list of your saved pages on any page.

Screenshot: Viewing and removing saved pages from the dashboard
View and Revoke OAuth Access Tokens

OAuth access tokens allow you to use a Confluence gadget on an external web application or website (also known as the 'consumer') and grant this gadget access to Confluence data which is restricted or privy to your Confluence user account.

OAuth access tokens will only appear in your user profile if the following conditions have been met:

1. Your Confluence Administrator has established an OAuth relationship between your Confluence site and the consumer. Confluence Administrators should refer to Configuring OAuth for more information about establishing these OAuth relationships.
2. You have accessed a Confluence gadget on the consumer and have conducted the following tasks:
   a. Logged in to your Confluence user account via the gadget and then,
   b. Clicked the 'Approve Access' button to allow the gadget access to data that is privy to your Confluence user account.

Confluence will then send the consumer an OAuth 'access token', which is specific to this gadget. You can view the details of this access token from your Confluence site's user account.

An OAuth access token acts as a type of 'key'. As long as the consumer is in possession of this access token, the Confluence gadget on the consumer will be able to access Confluence data that is both publicly available and privy to your Confluence user account. As a Confluence user, you can revoke this access token at any time. Furthermore, all access tokens expire after seven days. Once the access token is revoked or has expired, the Confluence gadget will only have access to publicly available Confluence data.

View your OAuth Access Tokens

To view all of your Confluence user account’s OAuth access tokens:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Click View OAuth Access Tokens. A view similar to screenshot below is displayed. Refer to OAuth Access Token Details below for information on interpreting this table.

   If no access tokens have been set, then ‘None specified’ is shown.

Screenshot: Viewing your OAuth Access Tokens
OAuth Access Token Details

Your list of OAuth access tokens is presented in a tabular format, with each access token presented in separate rows and each property of these tokens presented in a separate columns:

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Consumer</td>
<td>The name of the Confluence gadget that was added on the consumer.</td>
</tr>
<tr>
<td>Consumer Description</td>
<td>A description of this consumer application. This information would have been obtained from the consumer's own OAuth settings when an OAuth relationship was established between Confluence and that consumer. If the consumer is another Atlassian application, this information is obtained from the Consumer Info tab's 'Description' field of the OAuth Administration settings. The application's administrator can customize this Consumer Info detail.</td>
</tr>
<tr>
<td>Issued On</td>
<td>The date on which the OAuth access token was issued to the consumer by Confluence. This would have occurred immediately after you approved this gadget access to your Confluence data (privy to your Confluence user account).</td>
</tr>
<tr>
<td>Expires On</td>
<td>The date when the OAuth access token expires. This is seven days after the 'Issued On' date. When this date is reached, the access token will be automatically removed from this list.</td>
</tr>
<tr>
<td>Actions</td>
<td>The functionality for revoking the access token.</td>
</tr>
</tbody>
</table>

Revoke your OAuth Access Tokens

To revoke one of your OAuth access tokens:

1. View your Confluence user account's OAuth access tokens (described above).
2. Locate the Confluence gadget whose OAuth access token you wish to revoke and click **Revoke OAuth Access Token** next to it.
   The gadget's access token is revoked and the Confluence gadget on the consumer will only have access to publicly available Confluence data.

Collaboration

Confluence is all about encouraging team collaboration to get the best results, so we've built in a number of ways you can notify other people about content that may be of interest to them.

You can:

- **Share a link** to a page or blog post via email
- **Mention** a user when you write a page, blog post, comment, or add a task
- **Like** a page, blog post or comment

Whenever you mention another user, they'll receive an email notification; if you like a page, blog post, or comment, the author will be notified that you like the content.

Related pages:

- Pages and Blogs
- Watch Pages, Spaces and Blogs
- Export Content to Word, PDF, HTML and XML
Other users can also find out about changes to content in Confluence by watching pages and spaces.

Another way to share Confluence content is by exporting it to other formats such as XML, HTML, Microsoft Word and PDF.

Network Overview

You can create a network of users who are important to you, to make sure you're always up-to-date with their Confluence activity. You might want to follow your boss or teammates, to see what they're working on, or whoever creates the most entertaining blog posts.

When someone's part of your network, you'll be able to see when they:

- Add or edit pages or blog posts
- Comment on a page or blog post or edit existing comments
- Update their user profile

Follow another user

You can follow another user by using either their Hover Profile or your Network view.

To follow a user with their Hover Profile, hover your mouse over their profile picture when it appears in a page and choose Follow.

To follow a user from your Network view:

1. Choose your profile picture at top right of the screen, then choose Network
2. Alternatively, choose More in the Network section of your profile sidebar.
3. Search for and select the user in the Following field
4. Choose Follow

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just followed will appear within the Following list on the right. Their tracked activities will also start appearing in the Recent Activity list.

Access your network view

If you want to see what's been happening in your network, access your network view as described above.

You can access another user's Network view using the Hover Profile by choosing More > Network Page.

Screenshot: Example of the Network view
Notes

- **RSS feeds**: you can subscribe to any Confluence user's network RSS feed and receive summaries on the activities of other users they're following in their network. See [Subscribe to a Network RSS Feed](#).
- **Email notifications**: you can request email notifications of any activity in your network. See [Email Notifications](#).

### Likes and Popular Content

Has someone written a good blog post or page on Confluence? Or made a comment you agree with? Click the **Like** button to them know.

When you like a page, blog post or comment, the author of the content receives a notification. If enough people like the content, it'll appear on the **Popular** tab of the [dashboard](#).

#### Disabling the 'like' feature

The *like* functionality is provided by a plugin called the 'Confluence Like Plugin'. To remove the *like* functionality from your site, [disable the plugin](#).

#### Disabling notifications when your content is 'liked'

There are two ways to turn the 'someone likes your page' notifications off.

Do either of the following:

- Open an email notification of a like, and click **Manage Notifications**
- Go to `<your confluence_url>/plugins/likes/view-notifications.action`

### Mentions

Mentions (often known as @mentions) are a seamless way of drawing someone's attention to a page or comment, or assigning a task to them. When you mention a user, they'll receive a notification by email and in their workbox; if you mention them in a task, the task is assigned to them and appears in their **tasks list**.

There are two ways to mention someone: using **autocomplete**, or via the Insert menu in the editor toolbar.
Use autocomplete

To mention someone using autocomplete, type '[@] in the editor then start typing their name. Choose the person you want to mention from the list of suggestions.

Screenshot: Autocomplete for mentions

![Autocomplete for mentions](image)

Use the Insert menu

If you’d rather use the Insert menu, choose Insert > User Mention then search for and select the user you want to mention.

Notes

- **Disable the user mention feature** – The functionality is provided by a plugin called the 'Confluence Mentions Plugin'. If you need to remove the user mention functionality from your site, you can disable the plugin. See Disabling or Enabling a Plugin.

- **Mentioning groups** – You can only mention individual users. There's a feature request to allow mentions for groups: CONF-23015 - Extend 'Mentions' to work with groups as well

- **Link to a user profile** – You can use a square bracket '[' and a person's name to trigger Confluence autocomplete and link to a person's user profile or personal space. Confluence will send the person a notification just as if you had used @mention (unless the administrator has disabled the user mention feature).

Share a Page or Blog Post

You can use the 'Share' option in Confluence to email anyone a link to a page or blog post. The recipients can be Confluence users or any email address(es).

To share a link to a Confluence page or blog post:

1. Go to the page or blog post you wish to share
2. Choose Share
   - The Share button will only visible if your Confluence administrator has configured an outgoing mail server for your Confluence site.
3. Enter a username, group or email address, and select the appropriate user, group or email address from the list of suggestions

Related pages:
- The Editor
- Autocomplete for links, files, macros and mentions
- Keyboard shortcuts
- Workbox Notifications
Repeat this process to add multiple recipients to the list.
4. Enter an optional message into the Note box
5. Choose Share to send the link via email

In addition to an email, Confluence users will also receive a notification in their Confluence workbox. See Workbox Notifications.

To remove a recipient from the list, choose the delete icon to the right of the recipient.

**Comment on pages and blog posts**
Comments are a great way to bring others into the conversation about a page or blog post. They allow you to remark on content, add important information, ask questions, and generally drive collaboration and teamwork.

You can add a comment at the bottom of any page or blog post, or add an inline comment by highlighting specific text on the page.

**Add a page or blog post comment**

1. Type your comment in the comment field at the bottom of the page
2. Optionally, choose Preview to see how your comment will appear
3. By default, Watch this page is ticked (This means you'll start receiving notifications about the page. Uncheck it if you don't want to watch the page.)
4. Choose Save (Ctrl+S or +S)

Other users can reply and/or like your comment, and you or a space administrator can edit your comment(s).
Add an inline comment

1. Highlight the text you want to comment on
2. Choose the add comment button that appears above the highlighted text
3. Type your comment and choose Save (Ctrl+S or +S)

The selected text will appear with a yellow highlight indicating an inline comment; choose any highlighted text on the page to display the related comment(s).

Just like page and blog post comments, others can reply to, or like, your inline comments, and you'll be notified when they do.

Resolve inline comments
Hit **Resolve** to hide a set of inline comments once the conversation's finished. If you want to view resolved comments, choose

***

> **Resolved comments**; to reopen a resolved comment, choose **Reopen** at the bottom left.

**Rich comments**

Inline and page comments might look simple, but they support rich text (like **bold**, *italics*, and *emphasized* and numbered lists, **links**, and **@mentions**. You can also drop images into any comment, to really illustrate your point.

**Link to a comment**

You can link directly to a comment on a page. See [Links](#) for more information.

If you don’t see a popup when you highlight text, check that [Text Select](#) is enabled in your profile settings.

**Comment permissions**

- **Add a comment** – You need the ‘Add Comments’ permission in the space.
- **Edit a comment** – You need the ‘Add Comments’ permission. Space administrators can edit all comments within their space. The date on a comment always indicates the time the comment was last edited.
- **Delete a comment** – You need the ‘Remove Comments’ permission. Deleted comments cannot be restored. If you don’t have the ‘Remove Comments’ permission, you can delete your own comments, but only if there are no replies to your comment.
- **Disable comments** – If you don’t want comments in a particular space, remove the ‘Add Comments’ permission from the ‘confluence-users’ or ‘users’ group, anonymous users and all other users and groups. The option to add comments will no longer appear on pages or blog posts in that space.

See [Space permissions](#) for more information. There is no permission that controls comments across the entire site.

**Notes**

- Choose **Watch** at the top-right of the page to receive an email notification whenever anyone edits or adds a comment to the page.
- On blog posts only, an ‘Author’ lozenge will appear on any comments made by the original author of the post.
- It’s not possible to delete all comments on a page simultaneously, or change the order of comments.

**Watch Pages, Spaces and Blogs**

You can ‘watch’ a Confluence page, blog post or space. Confluence will then send you a notification email whenever anyone updates your watched content.

You’ll receive email notifications for:

- Edits (unless the author clears the ‘Notify watchers’ check box).
- Deletions.
- Attachments, including new versions or deletions of an existing attachment.
- Comments, including new comments, edits of existing comments or deletions of existing comments.

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behavior is called ‘**autowatch**’.

There’s no daily digest for email notifications. You’ll receive immediate
emails for important notifications (like mentions and new pages), but when lots of changes are being made at the same time, you’ll only receive a single email with all the changes (within a 10 minute window).

You **will not** receive email notifications for content changes due to the output of a macro, because the page content itself hasn’t been edited.

You need ‘View’ permission for the page, blog post or space to receive notifications.

**Watching a page or blog post**

To start watching a page or blog post:

1. Go to the page or blog post.
2. Choose **Watch** and select the relevant check box.

To stop watching the page or post, deselect the relevant check box.

**Watching an entire space**

You can choose to watch all the pages and blog posts in a particular space.

The quickest way is to use the **Watch** option on a page or blog post, as described above.

To stop watching the space, deselect the relevant check box.

Alternatively, choose **Pages** in the space sidebar, then choose **Watch this space** at the top right.

**Watch for new blog posts in a space**

You can choose to receive a notification whenever someone adds a blog post in the space. You will not receive notification of updates to or deletions of blog posts, nor of comments on the blog posts.

To watch for new posts:

1. Go to a blog post in the space.
2. Choose **Watch** and select **Watch all blog posts in this space**.

To stop watching for new blog posts, deselect the relevant check box. Alternatively, choose **Blog** in the space sidebar, then choose **Watch this blog** at the top right.
Watch all spaces on the site

You can receive notifications about changes to the content of pages, blog posts and comments from all spaces on a Confluence site.

To start watching for content changes across the whole site:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Choose Email.
3. Choose Edit then choose Subscribe to daily updates.
4. Choose Submit.

Watching for all new blog posts on the site

You can choose to watch for all new blog posts in all spaces on the Confluence site. You will not receive notification of updates to or deletions of blog posts, nor of comments on the blog posts.

To start watching for all new blog posts:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Choose Email.
3. Choose Edit then choose Subscribe to all blog posts.
4. Choose Submit.

Manage watches from your user profile

The ' Watches' page in your user profile displays a list of all pages and spaces you are currently watching.

To manage your watches:

1. Choose your profile picture at top right of the screen, then choose Watches.
2. Choose Stop Watching for any unwanted spaces or pages.

Manage watches from the email message

The email notifications that you receive from Confluence have some useful links at the bottom of the email message. The links in each message vary, depending on the context. In general, the links allow you to view the page online, reply to a comment, and so on.

In particular with respect to setting your notification preferences, you will see one or more of the following links:

- **Stop watching page** – Click this link to stop watching the page that triggered the email notification.
- **Stop watching space** – Click this link to stop watching the space that triggered the email notification.
- **Stop following this user** – Click this link to stop following the user whose update triggered the email notification.
- **Manage Notifications** – Click this link to go to the email settings page in your user profile.

*Screenshot: Example email notification footer showing links*

Autowatch and other notification options

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behavior is called ‘autowatch’. You can turn autowatch on or off, and set other notification options, in the
email settings section of your user profile. See Edit Your User Settings.

Manage Watchers

As a space admin, you may want to control who's notified about changes and updates to pages and posts within a space. You'll do this by managing the watchers of specific pages and posts, or of the entire space.

Take the example of a new member starting on your team, who should see when changes are made in the team space – you can add them as a space watcher so they get updates when any page or post in the space is changed. If someone no longer needs to be notified, you can remove them as a watcher just as easily.

To manage the watchers of a page or blog post:

1. Go to the page or blog post for which you want to manage the watchers
2. Choose Watch > Manage Watchers
   The left-hand column of the 'Manage Watchers' dialog shows the users watching the page or blog post. The right-hand column shows the users watching the space.
3. Do either of the following:
   • Add someone as a watcher of the page, post, or space – type their username in the relevant search box and hit Add
   • Remove an existing page, post, or space watcher – choose the trash icon next to their name

Manage Watchers

Watching this page
These people are notified when the page is changed.

Full name or username Add

Watching this space
These people are notified when any content in the space changed.

Full name or username Add

Email Notifications

You can 'watch' a page, blog post or space. Confluence will then send you a
notification by email whenever anyone adds or updates content on that page or space. You’ll receive immediate emails for important notifications (like mentions and new pages), but when lots of changes are being made at the same time, you’ll only receive a single email with all the changes (within a short window, usually 10 minutes).

You can also subscribe to daily email reports and other notifications of various updates, as described below.

You'll only receive notifications for content that you have permission to view. Users that have been disabled by an administrator will not receive email notifications.

**Subscribing to email notifications**

You can subscribe to be notified when:

- A blog post is added or changed in a space that you have permission to view.
- Someone you’re following makes an update in a space that you have permission to view.
- Someone follows you.

You can also subscribe to these summary reports:

- A daily report of all updates to all spaces that you have permission to view.
- A daily or weekly report of recommended updates, in all spaces that you have permission to view.

**To edit your email notification settings:**

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Click Email in the left-hand panel
3. Click Edit

Here’s an explanation of all the email settings.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Autowatch</strong></td>
<td><strong>Option:</strong> Do you want Confluence to automatically add you as a watcher on each page or blog post that you add or update? If you are a watcher of a page or a post, you will receive notification of future changes.</td>
<td>• Pages and blog posts that you create, edit or comment on.</td>
</tr>
</tbody>
</table>
| **Subscribe to daily updates** | Receive daily email reports showing changes to content in all spaces that you have permission to view. | • Pages and blog posts that are added, edited or deleted.  
• Comments on a page or blog post that are added, edited or deleted.  
• Updates by users who have changed their personal profile. |

**Notes for administrators**

**Related pages:**

- Watch Pages, Spaces and Blogs
- Subscribe to RSS Feeds within Confluence
- Your Profile and Settings
- Edit Your User Settings
<table>
<thead>
<tr>
<th><strong>Subscribe to all blog posts</strong></th>
<th>Receive email notifications for changes to blogs in your Confluence installation that you have permission to view.</th>
<th>• Blog posts added, edited or deleted.</th>
</tr>
</thead>
</table>
| **Subscribe to network** | Receive email notifications for changes to content by all users that you are following, which you have permission to view. | • Pages being added, edited or deleted.  
• Blog posts being added, edited or deleted.  
• Comments being added, edited or deleted. |
| **Subscribe to new follower notifications** | Receive an email message when anyone chooses to follow you. | |
| **Notify on my actions** | **Option:** Do you want to receive email notifications for your own changes?  
Note: If you have not subscribed to any email notifications and are not watching any pages/spaces, then selecting 'Notify on my actions' will not do anything. | • All pages and spaces that you are watching.  
• This affects all subscriptions set. |
| **Show changed content** | **Option:** Do you want your notifications to include details of the changes made to the content?  
• If you do not select this option, your notifications will include only the title of the page, and any comment the author made when updating the page.  
• If you do select this option, your notifications will show the differences between the current and previous versions of the page. See Page History and Page Comparison Views. | • Edits to pages and blog posts. |
Subscribe to recommended updates

Receive a daily or weekly email message showing the top content that is relevant to you from spaces that you have permission to view.

How do you set the frequency of the email message? A link in the email message allows you to choose daily or weekly notifications.

How do you enable and disable the notification? You can turn off the notification by clicking a link in the email message. You can also turn the notification on or off by setting the ‘Subscribe to recommended updates’ option in your user profile.

Confluence chooses the content to display, based on:

- Pages and blog posts that people have recently liked.
- Pages and blog posts that people have recently commented on.
- Pages and blog posts that have recently been created.

‘Recent’ means any activity that occurred since the last recommended updates message was sent to you.

The activities are listed in order of popularity, with the most popular at the top. Likes, comments and content creations are scored equally. Activity that involves people in your network ranks higher than activity not involving your network. Content from My spaces also ranks higher than content in other spaces. The recommended updates summary does not include any content that you created yourself, and it gives a lower ranking to content that you have participated in, for example by adding a comment or updating the page.

If there is no activity to report, Confluence will not send the email message.

Notes for administrators

- To enable Confluence to send email notifications, a System Administrator must configure an email server. See Configuring a Server for Outgoing Mail.
- System Administrators can change how long Confluence should wait before sending a notification for changes and comments on the same page or blog post in the Send batched notifications scheduled job.
- Confluence Administrators can set the default options for the recommended updates notification. Choose the cog icon , then choose General Configuration under Confluence Administration. Click Recommended Updates Email in the left-hand panel. See Configuring the Recommended Updates Email Notification.

Subscribe to RSS Feeds within Confluence

An RSS feed is a format for delivering summaries of regularly changing web content. Subscribing to an RSS feed allows you to stay informed of the latest content from sites that you are interested in.

RSS is not designed to be read in a regular web browser. Specialized RSS newsreader programs can check RSS files every so often, and tell you what's new on a site. Your reader may be on a website, an add-on to your browser, part of your email program, or a stand-alone program.

Confluence generates its own RSS feeds for tracking updates to content within Confluence. You will need an RSS reader which can grab the RSS feeds from Confluence and display them for you.

Confluence's RSS macro allows you to display the contents of an RSS feed on a Confluence page. The feeds may come from a Confluence feed generator or from external sites. In this way, Confluence can act as an RSS reader.

For a technical description of RSS, read Mark Pilgrim's "What is RSS?" article on XML.com.
Confluence RSS feeds

RSS feeds allow you to track updates to content within Confluence. You will need an RSS newsreader to read a feed.

You can create a customized RSS feed using the RSS Feed Builder or subscribe to one of the pre-specified feeds generated by Confluence.

What would you like to do?

- **Create and subscribe to customized RSS feeds using the RSS Feed Builder** – Create a customized RSS feed. For example, you can filter your feed using a label, specify the number of items and days to include in your feed, and so on.
- **Subscribe to pre-specified RSS feeds** – Generate an RSS feed automatically in a minimal number of steps.
- **Subscribe to a feed of any Confluence user’s network** – Track the activities of users the selected person is following.

RSS newsreaders

The following are some popular RSS readers for various operating systems. You can find a more comprehensive list on [Google's open directory](#).

**Windows**

- SharpReader
- NewsGator
- Syndirella
- FeedDemon
- NewzCrawler

**Mac OS X**

- Safari
- NetNewsWire
- NewsFire
- Shrook

**Multi-platform**

- NewsMonster (Runs in the Mozilla web browser)
- Radio Userland (Windows and MacOS)
- AmphetaDesk (Windows, Unix, Mac OS X)

Remove an RSS feed

There is no need to try to delete or remove an RSS feed built by the Confluence RSS feed builder.

Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL (address). For example, take a look at the following feed URL:

```
http://confluence.atlassian.com/createrssfeed.action?types=page&sort=modified&showContent=true...
```

The above feed URL will generate a list of pages ("types=page"), sorted by the modification date and showing the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no need to remove anything.

Subscribe to pre-specified RSS feeds

This page tells you how to get hold of an RSS feed which Confluence has predefined for you.

**To subscribe to predefined RSS feeds for a particular space:**

1. Go to the space and choose **Space tools > Content Tools** from the
bottom of the sidebar
2. Choose RSS Feeds
3. Copy and paste the link for one of the feeds into your RSS newsreader

If your space uses the Documentation theme:
1. Choose Browse > Space Operations
2. Choose RSS Feeds in the space operations options
3. Copy and paste the link for one of the feeds into your RSS newsreader

Feeds include:
- Pages
- Blog
- Mail
- Comments
- Attachments
- All content

To subscribe to predefined RSS feeds for a particular page (where available):

Note that the word 'page' here means a part of the Confluence user interface, rather than a page that contains Confluence content. For example, your Network view offers an RSS feed.

1. Go to the page
2. Locate the following icon, which is available in the top-right corner of certain pages:
3. Copy and paste the icon's link into your RSS newsreader

Notes

The predefined RSS feed will return no more than 10 entries within the last 5 days, if you want to customize your Confluence RSS feed (for example, use a label to filter your feed), use the RSS Feed builder instead of the above instructions.

The RSS Feed Builder

Using the RSS feed builder, you can create customized RSS feeds to subscribe to changes within Confluence.

Wondering what an RSS feed is? See more information about RSS Feeds.

Build an RSS feed

Follow the steps below to build your feed, choosing the type of content and the time period you want to monitor.

To create a customized RSS feed:

1. Choose the help icon
   at top right of the screen, then choose Feed Builder
2. Select the content types you want in your feed
   Check Mail if you want to know when the email archive is updated.
   (See the overview of mail archives in Confluence.)
3. Select one or more spaces from the list
4. Click Advanced Options to set the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feed Name</td>
<td>The default name is based on the name of your Confluence installation. For example, 'Extranet RSS Feed'.</td>
</tr>
<tr>
<td>With these labels</td>
<td>Enter one or more labels separated by spaces or commas. Confluence returns all content (of the selected types) that matches one or more of the labels. See the hint below about using labels to customize your feeds.</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Exclude these spaces</td>
<td>Exclude specific spaces from those already selected.</td>
</tr>
<tr>
<td>Sorted by</td>
<td>Sort content by either the date or creation or the date they were last updated.</td>
</tr>
<tr>
<td>Limit to</td>
<td>Specify the number of items returned in your feed.</td>
</tr>
<tr>
<td>Within the last</td>
<td>Specify how old items returned can be.</td>
</tr>
<tr>
<td>Include content for pages</td>
<td>Specify whether the entire page is displayed in the feed.</td>
</tr>
</tbody>
</table>

5. Choose Create RSS Feed
6. Drag or copy the link into your RSS reader

Hints

- **Separate feeds.** Try building separate feeds, one for pages only and one that includes comments as well. This allows you to monitor only pages if you are short of time, and to read the comments when you have more time.
- **Labels to customize your feed.** You can use the RSS feed builder to track updates to labeled pages and comments on those pages. Here is an idea for customizing your RSS feed by using your own personal label(s). This is useful if you want to track updates to specific pages or blog posts, and you do not want to deal with emails. You can use this method as an alternative to watching pages.
  - Build an RSS feed that returns pages, blog posts and comments labeled with a personal label, such as 'my:feed'.
  - Each time you want to ‘watch’ a page, just label it with 'my:feed'.
  - All updates and comments will automatically come through your RSS feed.

Notes

- **Removing an RSS feed:**

  There is no need to try to delete or remove an RSS feed built by the Confluence RSS feed builder.

  Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL (address). For example, take a look at the following feed URL:

  http://confluence.atlassian.com/createrssfeed.action?types=page&sort=modified&showContent=true...

  The above feed URL will generate a list of pages (‘types=page’), sorted by the modification date and showing the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no need to remove anything.
• **Feed authentication options:** Confluence can offer you the option of an anonymous feed or a feed that requires authentication.
  
  • An **anonymous** feed will show only the content that is visible to anonymous users. The feed URL does not contain the &os_authType parameter mentioned below. This feed is useful only if your Confluence site allows anonymous access. If a feed is anonymous, you only get anonymously-viewable content in the feed regardless of whether you are a Confluence user or not.
  
  • An **authenticated** feed requires you to log in to Confluence before you can retrieve the content. The feed URL contains the following parameter: &os_authType=basic.
  
  • The option to choose between an anonymous and an authenticated feed is currently not available on the feed builder screen. The feed builder offers only authenticated feeds. See CO NF-21601 for details and a workaround.

Subscribe to a Network RSS Feed

You can create an RSS Feed from any user’s network view, allowing you to receive summaries on the activities of users they are following in their network. The types of activities tracked in these RSS feed summaries include:

- Additions or edits to pages or blog posts
- Comments added to a page or blog post or edits to existing comments
- Updates to a user’s profile

Subscribe to a user’s network feed

**To subscribe to a user’s network RSS feed:**

1. Locate the RSS icon , which is available from the top-right of:
   - The ‘Recent activity of the users you are following’ section of your network page, or
   - The ‘Activity of followed users’ section of another user’s network page.
2. Copy and paste the icon’s link into your RSS newsreader

Customize your network RSS feed

Confluence does not provide a way of customizing a network RSS feed via the user interface. However, you can modify the maximum number of results and type of content displayed in these feeds by directly editing the RSS feed link in your RSS newsreader.

**To modify the maximum number of results displayed in your RSS feed:**

1. Edit the RSS feed link in your RSS newsreader.
2. Change the value of the max parameter from its default value of 40 to a value of your choice.
   - Example: http://confluence.atlassian.com/feeds/network.action?username=MYNAME&max=60&publicFeed=false&os_authType=basic&rssType=atom
3. Save the modified link in your RSS newsreader.

**To modify the type of content displayed in your RSS feed:**

1. Edit the RSS feed link in your RSS newsreader.
2. Append the parameter contentType to the end of the link, followed by an equals sign (=) and then add the appropriate content type value of your choice:
   - PAGE — restricts the RSS feed to page additions or updates.
   - BLOG — restricts the RSS feed to blog post additions or updates.
   - ATTACHMENT — restricts the RSS feed to attachment additions or updates.
   - COMMENT — restricts the RSS feed to comment additions or updates.
Content type values are case-sensitive. Ensure that each parameter is separated from the other by an ampersand (&).

Example:
http://confluence.atlassian.com/feeds/network.action?username=ggaskell&max=40&publicFeed=false&os_authType=basic&rssType=atom&contentType=BLOG

3. Save the modified link in your RSS newsreader.

Notes

It is not possible to filter for more than one type of content by adding multiple values to the contentType parameter.

**Workbox Notifications**

The Confluence workbox displays all notifications collected from Confluence page watches, shares, mentions, and tasks. From your workbox you can reply to comments, like a comment or page, watch a page, or open the relevant page or blog post.

If your Confluence site is linked to a JIRA application such as JIRA Software or JIRA Service Desk, you’ll also see notifications from your JIRA application in the workbox.

Looking to manage your notification email messages instead? See Email Notifications.

**On this page:**
- Manage your notifications
- Which notifications are included?
- Keyboard shortcuts
- Manage notifications with Confluence mobile
- Notes

**Related pages:**
- Configuring Workbox Notifications
- Email Notifications
- Watch Pages, Spaces and Blogs
- Likes and Popular Content

**Manage your notifications**

1. Choose the workbox icon in the header.
   - A number will appear the workbox icon, to indicate the number of unread notifications waiting for your attention.
   - You can use the keyboard shortcut: Type `g` then `n`. (When in the Confluence editor, click outside the editor before pressing the keyboard shortcut keys.)

2. Choose a notification from the list, to see the notification details. You can then:
   - Open the related page, blog post, or comment.
   - Like or Unlike the page, blog post, or comment.
   - Watch or Stop Watching to receive notifications, or stop receiving notifications, about a page or blog post.
   - Reply a comment, without leaving the workbox.

_Screenshot: Your Confluence notifications in the workbox_
Which notifications are included?

The workbox displays a notification when someone does one of the following in Confluence:

- Shares a page or blog post with you.
- Mentions you in a page, blog post, comment or task.
- Comments on a page or blog post that you are watching.
- Likes a page or blog post that you are watching.

The workbox does not show notifications triggered because you are watching a space. Only watches on pages and blog posts are relevant here.

The notification in your workbox appears as 'read' if you have already viewed the page or blog post.

If your Confluence site is linked to a JIRA application, you will also see the following JIRA notifications in your workbox:

- Comments on issues that you are watching.
- Mentions.
- Shares of issues, filters and searches.

Keyboard shortcuts

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
</table>

Created in 2016 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>g then n</td>
<td>Open the Confluence workbox.</td>
</tr>
<tr>
<td>j</td>
<td>Move down to the next entry in the notification list.</td>
</tr>
<tr>
<td>k</td>
<td>Move up to the previous entry in the notification list.</td>
</tr>
<tr>
<td>n</td>
<td>Move down to the next notification for a particular page or blog post.</td>
</tr>
<tr>
<td>p</td>
<td>Move up to the previous notification for a particular page or blog post.</td>
</tr>
<tr>
<td>Enter</td>
<td>Open the selected notification.</td>
</tr>
<tr>
<td>u</td>
<td>Return to the notification list after opening a particular notification.</td>
</tr>
</tbody>
</table>

**Manage notifications with Confluence mobile**

You can also view and respond to notifications on your phone or other mobile device. See [Confluence Mobile](https://confluence.atlassian.com/mb-mobile) for more about mobile platforms.

**Notes**

- Read notifications are automatically deleted after 2 weeks.
- Unread notifications are automatically deleted after 4 weeks.
- You cannot delete your notifications yourself.
- If a new notification arrives while you have workbox open, the count appears on the workbox icon but the notification is not added to the workbox. You need to close workbox and re-open it to see the new notification.
- The ability to receive notifications from JIRA or another Confluence site is available in [Confluence 4.3.3 and later](https://confluence.atlassian.com/mb-mobile). To receive JIRA notifications, you need [JIRA 5.2 or later](https://confluence.atlassian.com/mb-mobile).
- Administrators can enable and disable the workbox on your Confluence site. They can also connect a JIRA site or another Confluence site, so that notifications from those sites appear in your workbox too. See [Configuring Workbox Notifications](https://confluence.atlassian.com/mb-mobile).
- The Confluence workbox is provided by a set of plugins. To remove the personal notifications and tasks functionality from your site, you can disable the following plugins. See [Disabling or Enabling a Plugin](https://confluence.atlassian.com/mb-mobile) for instructions. Disabling these plugins will disable the entire workbox. It is not possible to disable only tasks or only notifications:
  - Workbox - Common Plugin
  - Workbox - Host Plugin
  - Workbox - Confluence Provider Plugin
- If you want to re-enable the plugins, do so in the following order: Common Plugin, Host Plugin, Confluence Provider Plugin.
- There is no option to disable the workbox for an individual user.

**Search**

Confluence gives you a few ways to find what you're looking for. Here's an overview of Confluence search, and a few tips to help you find things more easily.

**Quick search**

To perform a quick search in Confluence, choose the search field at the top-right of every page or type / on your keyboard to place your cursor in the search field. Type the name of a page, blog post, person, file/attachment, or space and choose from the list of options displayed.

If you don't immediately see what you need in the quick search, hit **Enter** or
choose the **Search for** option at the bottom of the search results to do a full search.

On this page:
- Quick search
- Full search
- Filter your search results
- Filter with CQL
- Advanced search
- Search options for the Documentation theme
- Search Confluence from your browser's search field
- Useful plugins

Related pages:
- Confluence Search Syntax
- Confluence Search Fields
- Recently Viewed Pages and Blog Posts
- Search Results Macro
- Livesearch Macro
- Search the People Directory

You can also search for administrative options in the quick search. For example, type ‘general’ into the search field to go to the General Configuration screen.

More information about quick navigation:
- Matching items are grouped by type so that you can quickly find the type you want. Confluence shows a maximum of 3 administrative items, 6 pages and/or blog posts, 2 attachments, 3 people and 2 spaces.
- Items are ordered with the most recently updated first.
- Permissions determine the admin options that appear in the search results. You'll only see the options
Full search

The full search allows you to search all content in all spaces (site and personal), mail, personal profiles, attachments and space descriptions, or filter the results to show only what you're after.

The search will also look at the content of the following types of attachments:

- Word
- Text
- PowerPoint
- Excel
- PDF
- HTML

To search the content of other attachment types, you will need to use an attachment content extractor plugin. For more information, take a look at the following:

- Existing extractor plugins which you can install on your Confluence site. See this search on Atlassian Marketplace.
- Guidelines on developing your own attachment content extractor plugin. See our developer documentation on extractor plugins.

To use the full search:

1. Type your query into the search field at the top-right corner of every screen (or at the top of the Search screen)
2. Hit the Enter key

Screenshot: Search results page
We recommend you don't use special characters in page or attachment names, as the page or attachment may not be found by Confluence search, and may cause some Confluence functions to behave unexpectedly.

Filter your search results

On the left of the search results page are options that allow you to filter the search results.

You can filter using the following fields:

- **Contributor** – Restrict your search to content that's been modified (created, edited, or commented on) by a particular person. Start typing the person's username or part of their name and Confluence will offer you a list of possible matches.

  You need to enter at least two letters. For example, if you enter just 'john s', the filter will look for users called 'john' and will ignore the 's'.

- **In space** – Only search in a particular space or list of spaces. There are also preset groups of spaces – favorite (my spaces), site, and personal spaces – which you can choose from the list of suggested spaces. Tick the checkbox to include archived spaces if you need to.

- **Last modified** – Choose or enter a date range to only show content updated within a particular period of time.

- **Of type** – Only return content of a certain type, like pages, blog posts, or comments.
Filter with CQL

Confluence search supports adding CQL filters to refine your results.

**What's CQL, and how do I use it?**

CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the Add a filter link to add more filters to your query.

**Use AND, OR, and NOT operators**

- For an OR search, specify multiple values in the same field.
  So to show pages with 'label-a', 'label-b' or both you’d put 'label-a' and 'label-b' in the same Label field, like this:

  ![Label filter example](image)

- For an AND search, add more than one filter and specify a single value in each.
  To show only pages with label-a and label-b you’d put 'label-a' in one label field, then add a second Label field to the macro, and put 'label-b' in the second one, like this:

  ![Label filter example](image)

  Put simply, OR values are entered in the same filter, AND values are entered in different filter. Only some filters support AND. If the filter doesn't support the AND operator, you won’t be able to add that filter more than once.

- For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that label.

You can use the following CQL filters to build your query:

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
<th>Operators</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Label</strong></td>
<td>Include pages, blog posts or attachments with these labels.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AND (multiple Label filters)</td>
</tr>
<tr>
<td><strong>With ancestor</strong></td>
<td>Include pages that are children of this page.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td></td>
<td>This allows you to restrict the macro to a single page tree.</td>
<td></td>
</tr>
<tr>
<td><strong>Contributor</strong></td>
<td>Include pages or blog posts that were created or edited by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>Creator</strong></td>
<td>Include items created by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>Mentioning user</strong></td>
<td>Include pages and blog posts that @mention these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>With parent</strong></td>
<td>Include only direct children of this page (further sub-pages won’t be included)</td>
<td><strong>EQUALS</strong> (one page only)</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------------------------------------------------------------------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td><strong>In space</strong></td>
<td>Include items from these spaces.</td>
<td><strong>OR</strong> (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>Including text</strong></td>
<td>Include items that contain this text.</td>
<td><strong>CONTAINS</strong> (single word or phrase)</td>
</tr>
<tr>
<td><strong>With title</strong></td>
<td>Include items that contain this text in the title.</td>
<td><strong>CONTAINS</strong> (single word or phrase)</td>
</tr>
<tr>
<td><strong>Of type</strong></td>
<td>Include only pages, blogs or attachments.</td>
<td><strong>OR</strong> (multiple values in the same filter)</td>
</tr>
</tbody>
</table>

* This field is required in CQL-powered macros.

** You can add these filters in CQL-powered macros but in search they’re part of the standard search filters, so they don’t appear in the Add a filter menu.

**Advanced search**

Still need more ways to search? For more advanced search syntax, check out Confluence Search Syntax for more ways to refine the text you enter in the search field. You can also read Confluence Search Fields for special parameters you can use to search various types of content metadata.

**Search options for the Documentation theme**

When using the Documentation theme, the Confluence search offers a few options as described below.

Using the search box at the top right of the page:

- By default, the main Confluence search is configured to search the entire Confluence site.
  - You will see the words ‘Search Confluence’ in the search box at top right of the page.
  - The Confluence search will look for matches in the entire Confluence site. This is the default behavior for other themes too.
- A space administrator can configure the Documentation theme to restrict the search to the current space.
  - You will see the words ‘Search this space’ in the search box at top right of the page.
  - The search will return results from the current space only.
  - You can override the search restriction. Enter ‘all:’ and your search term to search the entire site. For example, enter the following into the search box at top right of the page to search the entire site for ‘technical writing’:

  all: technical writing

Using the search box in the left-hand panel:

- By default, the Documentation theme’s left-hand panel includes a search box. Enter your search term there, to restrict the search to the current space. Specifically, this will search only the pages that are children of the space’s home page.
- If your administrator has restricted the main search to the current space, there will not be a search box in the left-hand panel.

For screenshots and a full description, see The Documentation Theme.
Search Confluence from your browser's search field

If you're using Firefox or Internet Explorer, you can add your Confluence site as a search provider using the dropdown menu next to the browser's search field.

The example to the right shows the 'Extranet' Confluence site offered for inclusion as a search engine in the browser's search field.

Information about OpenSearch:

- Confluence supports the autodiscovery part of the OpenSearch standard, by supplying an OpenSearch description document. This is an XML file that describes the web interface provided by Confluence's search function.
- Any client applications that support OpenSearch will be able to add Confluence to their list of search engines.
- Your Confluence Administrator can enable or disable the Open Search feature using the Confluence Administration Console.

Useful plugins

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support. This plugin extends the Confluence search, so that you can search for macro parameter names and values: the Confluence Macro Indexer plugin.

Confluence Search Syntax

This page describes the special words and punctuation marks you can use to refine your search.

Matched phrase search

Use double quotes to search for content that contains the phrase 'cheese one', or a phrase where 'cheese' and 'one' are the major words:

"cheese one"

Note: Confluence will ignore common words (stop words), including 'and', 'the', 'or', and more, even if they are included within double quotes. See the default list of stop words used by Confluence's search engine, Lucene, in the Lucene documentation.

For example:

1. Searching for "cheese one" returns only pages in which 'one' appears as the first word after 'cheese'.
2. Searching for "the one" returns all pages containing 'one' because 'the' is a stop word.

If you'd like to override Lucene's tokenization and stemming, cast your vote on this improvement request:

Conf-14910 - Provide ability to override Lucene tokenisation and stemming and search for exact text [OPEN]
OR search

To search for content that contains one of the terms, 'chalk' or 'cheese', use the operator OR in capital letters:

chalk OR cheese

AND search

To search for content that contains both the terms 'chalk' and 'cheese', use the operator AND in capital letters:

chalk AND cheese
NOT search

To search for content that contains 'chalk' but NOT 'cheese', use the operator NOT in capital letters:

chalk NOT cheese

Excluded term search

To search for content that contains 'chalk' and 'butter' but not 'cheese':

chalk butter -cheese

Group search terms

To search for content that must contain 'chalk' but can contain either 'cheese' or 'butter', use brackets to group the search terms:

(cheese OR butter) AND chalk

Title search

To search for pages and posts with certain words in the title, use the Add a filter option at the bottom left of the page and choose With title. Enter the words you’re looking for, in any order, and hit enter.

Confluence search filters are powered by CQL.

What’s CQL, and how do I use it?

CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the Add a filter link to add more filters to your query.

Use AND, OR, and NOT operators

- For an OR search, specify multiple values in the same field.
  So to show pages with 'label-a', 'label-b' or both you’d put 'label-a' and 'label-b' in the same Label field, like this:

- For an AND search, add more than one filter and specify a single value in each.
  To show only pages with label-a and label-b you’d put 'label-a' in one label field, then add a second Label field to the macro, and put 'label-b' in the second one, like this:
Put simply, OR values are entered in the same filter, AND values are entered in different filter. Only some filters support AND. If the filter doesn't support the AND operator, you won't be able to add that filter more than once.
- For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that label.

You can use the following CQL filters to build your query:

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
<th>Operators</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Label</strong></td>
<td>Include pages, blog posts or attachments with these labels.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AND (multiple Label filters)</td>
</tr>
<tr>
<td><strong>With ancestor</strong></td>
<td>Include pages that are children of this page.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td></td>
<td>This allows you to restrict the macro to a single page tree.</td>
<td></td>
</tr>
<tr>
<td><strong>Contributor</strong></td>
<td>Include pages or blog posts that were created or edited by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>Creator</strong></td>
<td>Include items created by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>Mentioning user</strong></td>
<td>Include pages and blog posts that @mention these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>With parent</strong></td>
<td>Include only direct children of this page (further sub-pages won't be included)</td>
<td>EQUALS (one page only)</td>
</tr>
<tr>
<td><strong>In space</strong></td>
<td>Include items from these spaces.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>Including text</strong></td>
<td>Include items that contain this text.</td>
<td>CONTAINS (single word or phrase)</td>
</tr>
<tr>
<td><strong>With title</strong></td>
<td>Include items that contain this text in the title.</td>
<td>CONTAINS (single word or phrase)</td>
</tr>
<tr>
<td><strong>Of type</strong></td>
<td>Include only pages, blogs or attachments.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
</tbody>
</table>

* This field is required in CQL-powered macros.

** You can add these filters in CQL-powered macros but in search they're part of the standard search filters, so they don't appear in the Add a filter menu.

Date range search

To search for content modified within a certain date range, pick a timeframe in the Last modified section on the left. If you're looking for something created within a particular date range, use the Add a filter option at the bottom left of the page and choose Created. For either option, you can pick from some predefined options, like last 24 hours and last week.

Confluence search filters are powered by CQL.

What's CQL, and how do I use it?
CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the Add a filter link to add more filters to your query.

- **Use AND, OR, and NOT operators**
  - For an OR search, specify multiple values in the same field. So to show pages with 'label-a', 'label-b' or both you'd put 'label-a' and 'label-b' in the same Label field, like this:
    
    ![Label filter example](image)
    
  - For an AND search, add more than one filter and specify a single value in each. To show only pages with label-a and label-b you'd put 'label-a' in one label field, then add a second Label field to the macro, and put 'label-b' in the second one, like this:
    
    ![Label filter example](image)

Put simply, OR values are entered in the same filter, AND values are entered in different filter. Only some filters support AND. If the filter doesn't support the AND operator, you won't be able to add that filter more than once.

- For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that label.

You can use the following CQL filters to build your query:

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
<th>Operators</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label*</td>
<td>Include pages, blog posts or attachments with these labels.</td>
<td>OR (multiple values in the same filter) AND (multiple Label filters)</td>
</tr>
<tr>
<td>With ancestor</td>
<td>Include pages that are children of this page.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>Contributor**</td>
<td>Include pages or blog posts that were created or edited by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>Creator</td>
<td>Include items created by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>Mentioning user</td>
<td>Include pages and blog posts that @mention these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>With parent</td>
<td>Include only direct children of this page (further sub-pages won't be included).</td>
<td>EQUALS (one page only)</td>
</tr>
<tr>
<td>In space**</td>
<td>Include items from these spaces.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
</tbody>
</table>
Wildcard searches

You can use one or more wildcard characters in your search. For example, you could search for http*.atlassian.* to find https://www.atlassian.com or http://www.atlassian.jp.

Leading wildcards
Lucene doesn't allow wildcards at the beginning of your search, but you can format your search as a regular expression as a workaround. For example, you can't search for *hum* or ?hum*, as they begin with a wildcard, but you can search for /.*hum.*/ and find things like hum, human, and inhumane.

Wildcards can either replace a single character in your search, or multiple characters.

Single character

To replace a single character in your search, use a question mark (?) as a wildcard. For example, to search for 'butter', 'bitter', 'better', or 'batter'.

```
b?tter
```

Multiple characters

To replace multiple characters in your search, use an asterisk (*) as a wildcard. For example, to search for 'chicken' or 'chickpea':

```
chick*
```

Multiple wildcards

Use multiple wildcards in your search. The following query will search find 'chick', 'coconut', or 'chickpea':

```
c*c*
```

You can also combine wildcard characters in one search. For example, the search term below will return
'chick' but not 'chickpea':

\[ c^c? \]

Note: Confluence doesn't support leading wildcards. This means searching for \*heese will not return cheese.

Proximity searches

Use a tilde character followed by a number, to find two words within a certain number of words of each other.

For example, the following search will return 'Octagon blog post', but not 'Octagon team blog post':

\[ "octagon post"\~1 \]

The following search isn't valid, because you can't search for two words within zero words of each other. If you think the words are next to each other, use the matched phrase search.

\[ "octagon post"\~0 \]

Range search

Use the operator 'TO', in capital letters, to search for names that fall alphabetically within a specified range:

\[ [adam TO ben] \]

Note: You can't use the AND keyword inside this statement.

Fuzzy search

Use a tilde (\~) character to find words spelled similarly.

If you want to search for octagon, but you're not sure how it's been spelt, type the word followed by a tilde:

\[ octogan\~ \]

Combined search

You can also combine various search terms together:

\[ o?tag* AND past\~ AND ("blog" AND "post") \]

Searching for macros

You can search Confluence content to find where a macro is used. Start your search string with macroName: and type the macro name after the colon. For example, to search for all excerpt-include macros:
Searching for labels

To search for pages and posts with a particular label or labels, use the Add a filter option at the bottom left of the page and choose Label.

Confluence search filters are powered by CQL.

What's CQL, and how do I use it?

CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the Add a filter link to add more filters to your query.

Use AND, OR, and NOT operators

• For an OR search, specify multiple values in the same field. So to show pages with 'label-a', 'label-b' or both you’d put 'label-a' and 'label-b' in the same Label field, like this:

• For an AND search, add more than one filter and specify a single value in each. To show only pages with label-a and label-b you’d put 'label-a' in one label field, then add a second Label field to the macro, and put 'label-b' in the second one, like this:

Put simply, OR values are entered in the same filter, AND values are entered in different filter. Only some filters support AND. If the filter doesn't support the AND operator, you won't be able to add that filter more than once.

• For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that label.

You can use the following CQL filters to build your query:

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
<th>Operators</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label*</td>
<td>Include pages, blog posts or attachments with these labels.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AND (multiple Label filters)</td>
</tr>
<tr>
<td>With ancestor</td>
<td>Include pages that are children of this page. This allows you to restrict the macro to a single page tree.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
</tbody>
</table>
**Confluence Search Fields**

This page gives an overview of the Apache Lucene search fields used in Confluence.

**Filter with CQL**

Before you dive into learning more about Lucene fields, you may want to learn about the powerful search filtering offered by Confluence Query Language (CQL).

- **What's CQL, and how do I use it?**
  
  CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add filters to build up a search query, adding as many filters as you need to narrow down the search results.

  Use the **Add a filter** link to add more filters to your query.

- **Use AND, OR, and NOT operators**
  
  - For an OR search, specify multiple values in the same field. So to show pages with 'label-a', 'label-b' or both you'd put 'label-a' and 'label-b' in the same Label field, like this:

    ![Label field](image)

  - For an AND search, add more than one filter and specify a
single value in each.
To show only pages with label-a and label-b you'd put 'label-a' in one label field, then add a second Label field to the macro, and put 'label-b' in the second one, like this:

```
Label *  
  label-a x
Label
  label-b x
```

Put simply, OR values are entered in the same filter, AND values are entered in different filter. Only some filters support AND. If the filter doesn't support the AND operator, you won't be able to add that filter more than once.
- For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that label.

You can use the following CQL filters to build your query:

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
<th>Operators</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label*</td>
<td>Include pages, blog posts or attachments with these labels.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AND (multiple Label filters)</td>
</tr>
<tr>
<td>With ancestor</td>
<td>Include pages that are children of this page.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td></td>
<td>This allows you to restrict the macro to a single page tree.</td>
<td></td>
</tr>
<tr>
<td>Contributor**</td>
<td>Include pages or blog posts that were created or edited by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>Creator</td>
<td>Include items created by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>Mentioning user</td>
<td>Include pages and blog posts that @mention these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>With parent</td>
<td>Include only direct children of this page (further sub-pages won't be included)</td>
<td>EQUALS (one page only)</td>
</tr>
<tr>
<td>In space**</td>
<td>Include items from these spaces.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
</tbody>
</table>
Searching for content in specific fields

Confluence data is stored in fields which can be specified in the search. To search a specific field, type the name of the field followed by a colon `:` and then the term you are looking for.

Preliminary examples:

```
title:"Some Title"

labelText:chalk
```

The field specification applies only to the term directly preceding the colon. For example, the query below will look for "Some" in the title field and will search for "Heading" in the default fields.

```
title:Some Heading
```

Confluence search fields

Below are the fields which can be searched, listed by content type.

**Personal Information**

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenized</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>fullName</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>
### Pages

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenized</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used on the page</td>
</tr>
</tbody>
</table>

### Blog

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenized</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used in the blog</td>
</tr>
</tbody>
</table>

### Attachments

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenized</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>filename</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>
Useful plugins

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

This plugin extends the Confluence search, so that you can search for macro parameter names and values: the Confluence Macro Indexer plugin.

Notes

To find out the version of Lucene Confluence is using go to <installation directory>/confluence/WEB-INF/lib and locate the Lucene jar files. The Lucene version number will be part of the filename.

Search the People Directory

The people directory displays a list of people who are authorized to log in to your Confluence site.

The people directory includes anybody who has logged into Confluence or who has had a user account created for them in Confluence.
The people directory does not include users who can log into Confluence using external user management if they have never yet logged in.

View the people directory

Choose People at the top of the screen.

Search for people

To search for a particular person, type their first name and/or last name into the search box and choose Search.

- To see everyone who uses your Confluence site, choose All People.
- To see just those people who have set up a personal space, choose People with Personal Spaces.

Follow people’s activities

Confluence’s network features allow you to ‘follow’ (that is, keep track of) other people’s activities in your Confluence site. For more information, please refer to Network Overview. You can use the hover profile feature in the people directory to start following other people.

- To start following someone, move your mouse over their name or profile picture and choose Follow in their profile popup.
- To stop following someone, move your mouse over their name or profile picture and choose Stop Following in their profile popup.

Once you start following another person, their activities will start appearing in your network view.

Screenshot: The people directory

Notes

- The people directory uses the hCard microformat for simple integration with a variety of microformat-enabled tools. hCard is an open data format for representing people, companies, organizations, and places. Read more about microformats and hCard.
- By default, deactivated users (disabled user accounts) are excluded from the people directory. You can include them by adding the showDeactivatedUsers parameter to the URL. For example:
http://my.confluence.com/dopeopledirectorysearch.action?showDeactivatedUsers=true

- By default, externally deleted users (for example, users deleted from an LDAP repository) are excluded from the people directory. You can include them by adding the `showExternallyDeletedUsers` parameter to the URL. For example:

  http://my.confluence.com/dopeopledirectorysearch.action?showExternallyDeletedUsers=true

- The Confluence administrator can hide the people directory. If it is hidden, you will not see the People Directory option.

**Recently Viewed Pages and Blog Posts**

The **Recently Viewed** list in Confluence keeps track of pages and blog posts you’ve recently visited, and allows you to easily navigate back to them.

To view your recently viewed content:

1. Choose your profile picture at top right of the screen, then choose Recently Viewed
2. Choose the title of the page you want to revisit

To filter the list, type part of a page title or user’s name in the **Filter** field.

Your last ten recently viewed pages also appear when you click in Confluence’s **Search** field before you start typing a search query.
Permissions and Restrictions

As a tool for communication and collaboration, we believe Confluence is at its best when everyone can participate fully. Confluence keeps a history of all changes to pages and other content, so it's easy to see who has changed what, and reverse any changes if you need to.

Confluence does, however, give you the choice to make your site, spaces, and pages as open or closed as you want to.

Levels of permission

There are three levels of permissions in Confluence: Global permissions, space permissions, and page restrictions.

Global permissions

Global permissions are site-wide permissions, and can be assigned by either a System or Confluence administrator.

These permissions are pretty broad, and don't really interact with space permissions or page restrictions.

On this page:
- Levels of permission
  - Global permissions
  - Space permissions
  - Page restrictions
- How do permissions and restrictions interact?

Related pages:
- Confluence Groups
- Global Permissions Overview
- Space Permissions Overview
- Page Restrictions
- Configuring Confluence Security
- Confluence Security Overview and Advisories
For full details, check out the overview of global permissions in the Administrator's Guide.

Space permissions

Every space has its own independent set of permissions, managed by the space admin(s), which determine the access settings for different users and groups.

They can be used to grant or revoke permission to view, add, edit, and delete content within that space, and can be applied to groups, users, and even to anonymous users (users who aren't logged in) if need be.

One thing to watch out for is where a user is a member of multiple groups. You may have revoked permission for that individual user to add pages, for example, but if they're a member of a groups that is allowed to add pages, they'll still be able to create new pages in the space.

If you can't get the result you want from space permissions, or you're not sure, check with one of your Confluence administrators to determine what permissions you should apply to individuals and groups.

Page restrictions

Page restrictions work a little differently to global and space permissions. Pages are open to viewing or editing by default, but you can restrict either viewing or editing to certain users or groups if you need to.

Don't forget, every page in Confluence lives within a space, and space permissions allow the space admin to revoke permission to view content for the whole space. Even the ability to apply restrictions to pages is controlled by the 'restrict pages' space permission.

How do permissions and restrictions interact?

You can restrict viewing of a page or blog post to certain users or groups, so that even if someone has the 'view' permission for the space, they won't be able to view the content of the page or blog post.

If someone's a space admin and you've used page restrictions to prevent them viewing a page, they won't be able to see the page when they navigate to it. As a space admin though, they can see a list of restricted pages in the space and remove the restrictions.

What about links?

Space permissions and page restrictions affect how links between Confluence pages are displayed.

- If someone doesn't have 'View' space permission, links to pages in that space won't be shown at all.
- If someone has the "View" space permission, but the page has view restrictions, the link will be visible but they'll get an "access denied" message when they click the link.

Links to attachments are also affected. If the visitor doesn't have permission to view the page the attachment lives on, the link won't be rendered.

Confluence Groups

For Confluence administrators, grouping users in Confluence is a great way to cut down the work required when managing permissions and restrictions.

Groups are also very useful, however, to anyone who's a space admin, or can apply page restrictions.

If you're a space admin, you can assign a set of space permissions to a group rather than to each individual user. And as a page creator with 'Add/Delete Restrictions' permission, you can also add and remove page restrictions for groups.
Default Confluence groups

There are some default groups in every Confluence instance but, beyond that, Confluence administrators are free to set up and edit groups in any way they see fit.

The two special groups in Confluence are:

- **confluence-administrators** – Can perform most of the Confluence administrative functions, like assign permissions to other users, but they can't perform any functions that could compromise the security of the Confluence system. They can also access the Confluence Admin console.

- **confluence-users** - this is the default group into which all new users are assigned. Permissions defined for this group will be assigned to all new Confluence users.

Anonymous Users

All users who don't log in when they access Confluence are know as 'anonymous' users. By default, anonymous users don't have access to view or change any content in your Confluence instance, but Confluence admins can assign permissions to this group if it's required.

Overlapping group and user permissions

When a user is assigned more than one permission, the more powerful permission will prevail.

Further explanation:

- A user may be assigned a permission specifically to their username. They may also be assigned a permission by belonging to a group, or even several groups.
- The user will then be able to perform all functions assigned to them.
- So if a user is allowed to do something over and above what the group can do, the user will be able to do it. And if the group is allowed to do something over and above the specific permissions granted to the user, the user will still be able to do it.
- If anonymous users are allowed to do something over and above what the user or group can do, the user will be able to do it, (even while logged in).
Unlicensed users from linked applications

If you're using Confluence as a knowledge base for JIRA Service Desk, your JIRA Service Desk administrator can choose to allow all active users and customers (that is logged in users who do not have a Confluence license) to view specific spaces.

These users have very limited access, and cannot be granted permissions in the same way as an individual or group. However, it's important to note that this permission overrides all existing space permissions, so any logged in Confluence user will also be able to see the space (regardless of their group membership). This is due to the way Confluence inherits permissions.

Add-ons and Integrations

Confluence has a wide range of features on its own, but you can also extend those features with add-ons, and by integrating Confluence with other applications. Integrating with JIRA applications and HipChat can really take your Confluence experience to the next level by improving the way your teams communicate and collaborate, track vital work, and plan and release new products.

If there's an extra piece of functionality you need, the Atlassian Marketplace is the place to look for useful Confluence add-ons (or add-ons for other Atlassian products). Whether you need to create diagrams, like the ones you can create with Gliffy, or you want to make awesome mockups and wireframes with Balsamiq, there are heaps of great add-ons in the marketplace. You may even find a really useful add-on you never knew you needed, but now can't live without.

In this section:

- Use JIRA applications and Confluence together
- Use HipChat and Confluence together
- Request Add-ons
- Use a WebDAV Client to Work with Pages
- Mail Archives
- Gadgets

Use JIRA applications and Confluence together

Confluence and JIRA are like bacon and eggs; coffee and cake; Simon and Garfunkel. Separately, they're great, but together, they're amazing!

If your Confluence and JIRA sites are connected using Application Links, you can display and create JIRA issues and more from within Confluence.

What you can do with Confluence and JIRA depends on the JIRA application and version you have. Find out about the required applications and versions later in this page.

For every project or team

Display issues on a page

You can display JIRA issues on a Confluence page using the JIRA Issues macro. Display a single issue, a list of issues, or show the total number of issues.

The simplest way to add a JIRA issue to Confluence is to paste a JIRA URL on a Confluence page.

Here's some examples...
• `<yourjirasite.com>/browse/CONF-1234` will insert the JIRA Issues macro and display a single issue.
• `<yourjirasite.com>/issues/?filter=56789` will insert the JIRA Issues macro and display a list of issues matching the saved filter.
• `<yourjirasite.com>/issues/?jql=project%20%3D%20CONF` will insert the JIRA Issues macro and display a list of issues matching the JIRA search.

Alternatively, you can add the JIRA Issues Macro to the page and search for issues directly:

1. In the editor choose **Insert > JIRA Issue**.
2. Follow the prompts in the macro browser to choose a project and search for an issue – you can even use JIRA Query Language (JQL).

Once you've added the macro, you can customize how the issue or list of issues appears on the page, including how much information to display, how many issues, and more.

Create reports and charts

Reporting on information stored in JIRA is simple in Confluence. In addition to the JIRA Issues Macro, you can use the JIRA Report blueprint or JIRA Chart macro to show information from your JIRA application visually. It's the best way to give your stakeholders a snapshot of your team or project's progress.

You can:

- Use the JIRA Report blueprint to create a Change Log or Status report.
- Use the JIRA Chart Macro to display data as a chart, including pie charts, created vs resolved, and two dimensional charts.
- Use JIRA Gadgets to display detailed JIRA reports and charts on pages.

Create issues from inside Confluence

You can create issues while viewing a page or from the within the editor. This is really useful if you use Confluence for planning and gathering requirements.

**To create an issue when viewing a page:**

1. Highlight some text on your page and choose the **Create JIRA issue** icon that appears above the highlighted text.
2. Enter your **server** (if you have multiple JIRA sites connected to Confluence), **project**, **issue type** and **description**. Your highlighted text will populate the issue **summary** automatically.
3. Choose **Create**.

The issue will be created in JIRA and added to your page. If your text is in a table, you'll have the option to create multiple issues using text from the same column.

If you don’t see a popup when you highlight text, check that **Text Select** is enabled in your profile settings.

**To create an issue in the editor:**

1. In the editor choose **Insert > JIRA Issue > Create new issue**.
2. Enter your **server** (if you have multiple JIRA sites connected to Confluence), **project**, **issue type**, **summary**, and **description**.
3. Choose **Insert**.
The issue will be created in JIRA and added to your page.

There are some limitations when creating JIRA issues from Confluence. The JIRA Issues macro or Create JIRA Issue dialog will notify you if it's unable to create an issue in the selected project. You can find out more in the JIRA Issues Macro page.

Move between JIRA and Confluence

Whenever you add a link to JIRA issues in Confluence, or link to a Confluence page from your JIRA application, the JIRA Links button appears at the top of the Confluence page. This makes it really easy to jump from Confluence to JIRA and vice versa, speeding up your workflow.

The number on the JIRA Links button indicates the total number of issues, epics, and sprints connected to that page, regardless of whether you have permission to view them. The dropdown, however, will only show details of issues, epics, and sprints that you have JIRA permissions to view.

The button doesn’t detect links from issues displayed in the JIRA Issues macro in table format.

For software teams

Here’s some suggestions to help you get the most out of Confluence and JIRA Software and unleash the potential in your agile development team.

Define your requirements

Confluence is the perfect place to start defining your requirements. You can use the Product Requirements Blueprint to capture your requirements, then create your JIRA epic and other issues right from the requirements page in Confluence.

Here’s how it works:

1. Create a Confluence page using the Product Requirements Blueprint.
2. Choose the placeholder text ‘Link to JIRA epic or feature’ and choose Create new issue to create your epic in JIRA.
3. Collaborate with your team to define your stories and save the page.
4. Highlight text on your requirements page and choose the Create JIRA issue link to create stories in JIRA, and automatically link them to your epic.
5. Track the progress of the stories from the Confluence page or from within JIRA.

The tight integration between Confluence and JIRA Software means you can easily access issues from the Confluence page and see their status at a glance, and from within JIRA Software you can see links to related Confluence pages. All the information you need is right there.

Manage your sprints
There's often a lot of material in Confluence that provides useful context for your team during a sprint. These might be requirements documents, designs, tech specs, customer research and more. By linking these pages to epics, you make them easy for your team to find during the sprint.

Here's how you can use Confluence to support your sprint from within JIRA Agile:

- In JIRA Software, create a Confluence page to plan your sprint. The page is created using the Meeting Notes Blueprint — a handy template that helps capture the details you need — and is automatically linked to the sprint.
- In an epic, link to useful Confluence pages, including requirements, designs, and more.
- Report on your progress to stakeholders using the JIRA Report blueprint in Confluence.
- Use the Retrospective Blueprint in Confluence at the end of your sprint to take stock of what went well and not so well.

For people who work mostly in JIRA Software, the integration means that useful Confluence pages are only a click away.

**For service desk teams**

Provide self help resources for your customers

If you use JIRA Service Desk, you can help your customers resolve their issues without creating a request by connecting your Service Desk project to a knowledge base in Confluence.

In Service Desk, head to Administration > Confluence KB (or Settings > Knowledge Base if you're using JIRA Service Desk 2.x or earlier) to connect or create a Confluence space.

When Service Desk customers search in the Customer Portal, pages in the linked knowledge base space will be suggested, allowing customers to help themselves.

Create knowledge base articles

The Knowledge Base space blueprint, along with templates for how-to and troubleshooting articles make creating new knowledge base articles super simple for your Service Desk agents.

The templates used in the how-to and troubleshooting blueprints are completely customizable too. Set up the template with all your standard information and let your agents take it from there.

Allow any active user to see knowledge base spaces

If your Confluence instance is not public, you can still make a knowledge base space available via the customer portal.

When you link your JIRA Service Desk project to a Confluence space, you can choose to allow all active users and customers to see pages in the linked space, even if they don't have a Confluence license. These people get very limited Confluence access.

Unlicensed users can:

- View pages via the JIRA Service Desk customer portal.
- Follow a URL to a page and then navigate within the linked space.

Unlicensed users can't:

- Like, comment on or edit pages (or be granted permission to do this).
- See the dashboard, user profiles, the people directory or space directory.
- Search the whole site.
This permission can only be enabled via JIRA Service Desk, but you can revoke access to the whole site or to particular spaces via Confluence's global permissions or space permissions.

A note about Confluence permissions...

Allowing all active users and customers to view a space will override all existing space permissions, so any logged in, licensed Confluence user will also be able to see the space (regardless of their group membership). This is due to the way Confluence inherits permissions.

JIRA applications required

As you've seen, Confluence has many integration points, some of which are only available in particular JIRA applications or versions.

This matrix outlines the specific JIRA applications you'll need for each feature. We've also included the minimum legacy JIRA Server version (plus any add-ons) that you'll need if you're not using the latest JIRA applications.

<table>
<thead>
<tr>
<th>Feature</th>
<th>JIRA Core</th>
<th>JIRA Software</th>
<th>JIRA Service Desk</th>
<th>Minimum legacy version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display issues using JIRA issues macro</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>JIRA 4.3</td>
</tr>
<tr>
<td>Display issue and project information using JIRA chart macro</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>JIRA 5.0</td>
</tr>
<tr>
<td>Display issue and project information using the JIRA Report blueprint</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>JIRA 5.0</td>
</tr>
<tr>
<td>Create an issue from JIRA issues macro</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>JIRA 4.3</td>
</tr>
<tr>
<td>Create issues by highlighting text on a Confluence page</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>JIRA 6.3.1</td>
</tr>
<tr>
<td>Create issue by highlighting text on a Confluence page and automatically link issues to an epic</td>
<td>✗</td>
<td>✔️</td>
<td>✗</td>
<td>JIRA 6.3.1 and JIRA Agile 6.3.5</td>
</tr>
<tr>
<td>Link and create Confluence pages from epics and sprints</td>
<td>✗</td>
<td>✔️</td>
<td>✗</td>
<td>JIRA 6.3.1 and JIRA Agile 6.3.5</td>
</tr>
<tr>
<td>View linked issues with the JIRA links button in Confluence</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>JIRA 6.3.1</td>
</tr>
<tr>
<td>Create a space using the Software Project space blueprint</td>
<td>✗</td>
<td>✔️</td>
<td>✗</td>
<td>JIRA Software 7.0</td>
</tr>
<tr>
<td>Use a Confluence space as a knowledge base in the customer portal</td>
<td>✗</td>
<td>✗</td>
<td>✔️</td>
<td>JIRA 5.2 and JIRA Service Desk 1.0</td>
</tr>
<tr>
<td>Allow Service Desk customers to view knowledge base articles without a Confluence license</td>
<td>✗</td>
<td>✗</td>
<td>✔️</td>
<td>JIRA Service Desk 3.1</td>
</tr>
<tr>
<td>Search for an existing Confluence page within the JIRA link dialog</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>JIRA 4.3</td>
</tr>
<tr>
<td>Delegate user management to JIRA</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>JIRA 4.3</td>
</tr>
<tr>
<td>Add a JIRA gadget to a Confluence page</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>JIRA 4.3</td>
</tr>
</tbody>
</table>

That's it? Time to jump into Confluence and give some of these great features a try with your team or project. Want to find out more about how to connect your JIRA application to Confluence? Check out Integrating JIRA and Confluence.
**Use HipChat and Confluence together**

HipChat is group and video chat for teams.

Connect Confluence to HipChat to send real time notifications to your team or project's HipChat room.

Don't have HipChat yet? You can sign up for free and start using HipChat right away.

---

### Connect Confluence and HipChat

First your organization's HipChat account needs to be connected to Confluence. It only takes a minute.

You'll need administrator permissions for your HipChat group to do this.

If you're a Confluence admin go to

> General Configuration > HipChat Integration and click Connect HipChat to get started.

If you're a Space Admin you can go to Space Tools > Integration > HipChat to get started.

> Using the Documentation theme?

If your space uses the Documentation theme go to Browse > Space Admin > HipChat.

You'll need to be logged in to HipChat as a Group Admin to complete the integration.

---

### Invite users

If you're a Confluence administrator you can send an email to invite users to join HipChat directly from the Integration screen (>

> General Configuration > HipChat Integration). You'll need at least one space integrated with a room to see the invite users link.

---

### Send space notifications to HipChat

Keep your team in the know by sending notifications about space activities, like new pages and blogs, to your team's HipChat room. Notifications appear in real-time, and one click takes you straight to Confluence.

To set up space notifications go to Space Tools > Integration > HipChat and add a room to the list.

> Using the Documentation theme?

If your space uses the Documentation theme go to Browse > Space Admin > HipChat.

You'll need Space Admin permissions, and if you are connecting to private HipChat rooms, you will need to log in to HipChat on the integration screen.
See who’s online

When you hover over a user mention or a byline it will show if the user is available in HipChat. Green, yellow and red icons indicate when someone is available, away or doesn’t want to be disturbed.

Request Add-ons

The Atlassian Marketplace website offers hundreds of add-ons that the administrator of your Atlassian application can install to enhance and extend Confluence. If the add-on request feature is enabled for your Confluence instance, you can submit requests for add-ons from the Marketplace to your Confluence administrator.

The ‘Atlassian Marketplace for Confluence’ page provides an integrated view of the Atlassian Marketplace from within your Confluence instance. The page offers the same features as the Marketplace website, such as searching and category filtering, but tailors the browsing experience to Confluence.

This in-product view of the Marketplace gives day-to-day users of the Atlassian applications, not just administrators, an easy way to discover the add-ons that can help them work. When you find an add-on of interest, you can submit a request with just a few clicks.

Submit an add-on request

To browse for add-ons in the Atlassian Marketplace, follow these steps:

1. Choose your profile picture at top right of the screen, then choose Atlassian Marketplace.
2. In the Atlassian Marketplace page, use the search box to find add-ons or use the category menus to browse or filter by add-ons by type, popularity, price or other criteria. You can see what your fellow users have requested by choosing the Most Requested filter.
3. When you find an add-on that interests you, click Request to generate a request for your administrator.
4. Optionally, type a personal message to your administrators in the text box. This message is visible to administrators in the details view for the add-on.
5. When ready, click **Submit Request**.

6. Click **Close** to dismiss the 'Success!' message dialog box.

At this point, a notification appears in the interface your administrators use to administer add-ons. Also your request message will appear in the add-on details view, visible from the administrator's 'Find New Add-ons' page. From there, your administrator can purchase the add-on, try it out or dismiss requests.

**Update an add-on request**

After submitting the request, you can update your message at any time. Click the **Update Request** button next to the listing in the Atlassian Marketplace page to modify the message to your administrator.

The administrator is not notified of the update. However, your updated message will appear as you have modified it in the details view for the add-on immediately.

**Use a WebDAV Client to Work with Pages**

Create, move and delete pages and attachments in Confluence using a file manager like Finder (OS X), Explorer (Windows) or Dolphin (Linux) or other WebDav compatible local client like CyberDuck.

For example, if you need to delete a lot of pages you can bulk delete them in your local file manager (like Finder or Explorer), rather than one by one in your browser.

Access to Confluence through a native client is provided by the WebDav plugin. Your administrator may have disabled the WebDav plugin, or may have restricted the actions that you can perform using a local client. See **Configuring a WebDAV client for Confluence** for more information on how to set it up.

**Manage pages and files in a native client**

Accessing Confluence through a native client is useful for performing bulk actions. Before you can start creating and moving things around, it’s useful to understand how the content is organized.

The hierarchy in the file system looks like this:

- Type of space (global or personal)
  - Space (folder name is the spacekey)
  - Homepage (and other top level pages)
    - Child pages (folder name is the name of the page)
    - Attachments (filename of the attachment)

Essentially the file structure is the same as the page tree in your space. Here’s how the Confluence demonstration space looks in Finder.
Here's some things you might choose to do in a local client, rather than in your browser:

- **Move pages to another space**
  Select the page folders, and drag them into the other space's folder (drag them from Space A to Space B)

- **Delete multiple pages**
  Select all the page folders you want to delete and delete them.

- **Delete multiple attachments from a page**
  Navigate down to the page folder, select the attachments you want to delete and delete them.

- **Upload multiple attachments**
  Navigate to the page folder, and drag the files into the folder (note you can attach multiple files through the insert dialog as well).

**Mail Archives**

Confluence allows you to collect and archive mail within each space. It's useful for storing the email messages that relate to a particular project – you can put them in the same Confluence space as the content for that project.

You can download mail from one or more POP or IMAP accounts, or import mail from an mbox file on your local system or on the Confluence server.

You need **space administration** permissions to manage the mail archives.

Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose

> General Configuration > Manage Add-ons. Then choose System in the drop down, and enable the Confluence Mail Archiving Plugin.

To see archived mail:

- Go to a space and choose **Space tools > Integrations > Mail**
  Or, if your space uses the Documentation theme, choose **Browse > Mail** in the header.
- Choose a message to see its contents, or choose **Next, Previous** and other options to navigate around the mail archives.

**Manage mail archives:**
- Add a Mail Account
- Delete and Restore Mail
- Import Mail from an mbox

**Screenshot: Viewing a message in the mail archive**

<table>
<thead>
<tr>
<th>Confluence Development / Browse Space / Mail Archive</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tom's on annual leave today (Monday)</td>
</tr>
<tr>
<td>Add •</td>
</tr>
<tr>
<td>Subject: Tom's on annual leave today (Monday)</td>
</tr>
<tr>
<td>From: Tom Davies <a href="mailto:tomdavies@example.com.au">tomdavies@example.com.au</a></td>
</tr>
<tr>
<td>Date: Oct 22, 2006 16:12</td>
</tr>
<tr>
<td>I'll see you all on Tuesday.</td>
</tr>
<tr>
<td>Tom</td>
</tr>
</tbody>
</table>

**Notes**

- Only site spaces – not personal spaces – can store mail archives. See Spaces for information on site and personal spaces.
- You can also search the mail messages and their attachments. See Search.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose
  > General Configuration > Manage Add-ons. Then choose System in the drop down, and enable the Confluence Mail Archiving Plugin.

**Add a Mail Account**

When you add a mail account, you’re configuring Confluence to download mail from that account and archive it within the space.

You need space administration permissions to add a mail account. See Space Permissions Overview.

⚠️ **Note:** Confluence will remove email messages from an email account when it transfers them to the mail archive. You must therefore configure Confluence to poll a clone email account rather than the actual account. For example, to archive the actual account sales@company.com to your Confluence Sales space, you must first create a clone account such as conf-sales@company.com that contains the same email content.

Add a mail account

**Step 1. Create a clone email account on the mail server**

1. Add a new email account on the mail server with the clone email address.
2. Copy all existing email messages from the actual account to the clone account.
3. Set up the actual account to bcc sent email messages to the clone account.
4. Set up the actual account to forward received email messages to the clone account.
Step 2. Configure Confluence to archive the clone account

1. Go to the 'Mail Accounts' view:
   - Go to the space and choose Space tools > Integrations from the bottom of the sidebar.
   - Choose Mail Accounts.
   - If your space uses the Documentation theme:
     Choose Browse > Space Admin from the header

   **Note:** The Space Admin option appears only if you have space admin permissions, or if you’re part of the ‘confluence-administrators’ group.

   Choose Integration > Mail Accounts.

2. Choose Add mail account

3. Enter configuration details for the account:
   - **Account Name:** Enter a name for this account by which it will be known in Confluence.
   - **Description:** Provide a description for this account (optional).
   - **Protocol:** Choose from POP, IMAP, POPS or IMAPS.
   - **Hostname:** Enter the host name of the mail server on which the account resides.
   - **Port:** Don’t edit this field. The mail server’s port number will be displayed by default.
   - **Username:** Enter a username that has permission to retrieve mail from this account.
   - **Password:** Enter the account’s password.

4. Choose Test Connection to verify the details

5. Choose Create to add the account to Confluence

For each mail account you add, you can perform these actions in the Mail Accounts tab:

- **Edit:** Change the configuration settings for the mail account.
- **Remove:** Remove the account permanently.
- **Disable/Enable:** Temporarily disable the account, or enable a disabled account.

Fetching Mail

Confluence automatically fetches mail from the server once every 30 minutes. You can manually retrieve new mail from the configured mail accounts by selecting the Mail tab and choosing Fetch new mail.

**You need to be a space administrator to manually retrieve mail.** See Space Permissions.

Notes

- Only site spaces – not personal spaces – can store mail archives. See Spaces for information on site and personal spaces.
- Confluence mail archiving is an optional feature. This means that the ‘Mail’ options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose > General Configuration > Manage Add-ons. Then choose System in the drop down, and enable the Confluence Mail Archiving Plugin.
- Once mail is fetched it will be removed from the server.
Delete and Restore Mail
To delete mail from a space, you need ‘Delete Mail’ permission.

Information
Only a space administrator can delete all email messages in the space simultaneously.

Delete mail from a space:
1. Go to a space and choose Space tools > Integrations > Mail
2. Or, if your space uses the Documentation theme, choose Browse > Mail in the header.
3. A list of email messages in the space is displayed in reverse chronological order
4. Do either of the following:
   - Delete an individual email message by choosing the trash icon beside it.
   - Delete all email messages within the space by choosing Delete All.

```
⚠️ Email messages deleted using the ‘Delete All’ option can’t be restored.
```

Space administrators can restore deleted email messages, provided they were deleted individually.

Restore mail that was deleted:
1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Trash
3. You’ll see a list of email messages and other content deleted from the space.
4. Choose Restore beside the email message you want to restore

```
Note: The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.
```

Import Mail from an mbox
Confluence allows you to import mail from mbox files located either on your local system or in a specified location on the Confluence server. Confluence will store the imported email messages in the space’s mail archive.

You need to be a space administrator to import mail for a space. See Space Permissions.

NB: You may need to enable the Confluence Mail Archiving Plugin as it is disabled by default.

To import mail from an mbox file:
1. Go to the space and choose Space tools > Integrations from the bottom of the sidebar.
2. Choose Mailbox Import.
3. To import from a location on your file system: Browse to the location of the mbox file, select the file and then choose Import.
4. To import from the Confluence server: Enter the location of the mbox file on the server, then choose Import.

```
If your space uses the Documentation theme:
1. Choose Browse > Space Admin from the header
2. Choose Trash in the left-hand panel
3. You will see a list of email messages and other content deleted from the space.
4. Choose Restore beside the email message you want to restore
```

Related pages:
- Mail Archives
- Add a Mail Account
2. Choose **Mailbox Import** in the space administration options.
   - To import from a location on your file system: Browse to the location of the mbox file, select the file and then choose **Import**.
   - To import from the Confluence server: Enter the location of the mbox file on the server, then choose **Import**.

**Notes**

- Only **site spaces** can store mail archives. Personal spaces cannot. See [Spaces](#) for an explanation of site spaces and personal spaces.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose **Manage Add-ons**. Then choose **System** in the drop down, and enable the **Confluence Mail Archiving Plugin**.
- For security reasons mail can only be imported from a specified location in the Confluence server's file system. We recommend administrators create a folder in their Confluence home directory, add the system property `confluence.mbox.directory` and specify the location for mailboxes to be imported from. Mail cannot be imported from the server until this system property is set. See [Configuring System Properties](#).

**Gadgets**

Gadgets allow you to add dynamic content to a Confluence page or JIRA application dashboard. Confluence can display gadgets that support the [OpenSocial](#) specification, including third party gadgets.

For more information about Atlassian gadgets, see the [introduction to Atlassian gadgets](#) and the [big list of Atlassian gadgets](#).

To see a list of available gadgets in your Confluence site go to Help > **Available Gadgets**.

The following gadgets are bundled with Confluence.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Confluence Page Gadget</strong></td>
<td>The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.</td>
</tr>
<tr>
<td><strong>Activity Stream Gadget</strong></td>
<td>The activity stream gadget is similar to the <a href="#">recently updated macro</a> and shows a list of the most recently changed content within your Confluence site.</td>
</tr>
<tr>
<td><strong>Confluence News Gadget</strong></td>
<td>The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs and events at Atlassian.</td>
</tr>
</tbody>
</table>

**Related pages:**
- [Gadget Macro](#)
- All [Atlassian gadgets](#)
- External Gadgets
### Add a Confluence gadget to a page

Where a similar result can be achieved using standard Confluence macros (for example using the Include Page Macro instead of Confluence Page Gadget), we recommend using macros as they have better performance and are easier to configure than gadgets.

To add a Confluence gadget to a page:

- In the editor go to Insert > Other Macros.
- Select the gadget you wish to add, and use the preview area to configure the gadget.
- Choose Insert.

See Gadget Macro for more information on adding the macro to your page, configuring the gadget itself and display options.

### Add a JIRA gadget to a page

For displaying basic JIRA information, such as issues and charts, we recommend using the JIRA Issues Macro and JIRA Chart Macro as these macros have better performance and are easier to configure than gadgets.

If the JIRA information you want to display is not available from either of these macros a gadget will likely do the trick.

To add a JIRA Gadget to a Confluence page:

- In the editor go to Insert > Other Macros.
- Select the gadget you wish to add, and use the preview area to configure the gadget.
- Choose Insert.

See Gadget Macro for more information on adding the macro to your page, configuring the gadget itself and display options.

If you don't see any JIRA Gadgets in the macro browser, ask your Confluence administrator to add the JIRA Gadget urls to the list of authorized external gadgets in Confluence, and check that the application link between Confluence and your JIRA application is configured correctly.

### Add a Confluence gadget to your JIRA application dashboard

To add a Confluence gadget to your JIRA dashboard:

1. Go to the dashboard by selecting the Dashboard link in the header.
2. On the dashboard, Click Add Gadget.
3. Use the gadget wizard to choose the gadgets you want to add.

If you don't see any Confluence gadgets in the JIRA gadget directory, ask your JIRA administrator to add the gadget URLs as follows.

To add a Confluence gadget to your JIRA application's gadget directory:

1. In Confluence, go to Help > Available Gadgets and copy the gadget URL for the gadget you want to make available in JIRA.
Activity Stream Gadget

The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your Confluence site.

In addition to showing a list of most recently changed content, the activity stream gadget also groups activities by separate date, and provides an RSS feed link to its content in the top-right corner.

Activity Stream Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

These properties are located in the preview panel in the macro browser.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Yes</td>
<td>None</td>
<td>Adds a title to the top of the Activity Stream.</td>
</tr>
<tr>
<td>Global filters</td>
<td>No</td>
<td>None</td>
<td>Allows you to add filters to the gadget including:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• space</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• username</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• update date</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• JIRA issue key (if your Confluence instance is integrated with a JIRA application)</td>
</tr>
<tr>
<td>Available streams</td>
<td>Yes</td>
<td>All</td>
<td>If you have application links to other sites, JIRA or another Confluence site, you can choose to include activity from those streams also.</td>
</tr>
<tr>
<td>Display options: limit</td>
<td>No</td>
<td>10</td>
<td>Specify the maximum number of results to be displayed. A maximum of 10 results will be displayed by default. The maximum value that this property can accept is 100.</td>
</tr>
<tr>
<td>Display options: Refresh Interval</td>
<td>No</td>
<td>Never/false</td>
<td>Specify the time interval between each 'refresh' action undertaken by the activity stream gadget. A refresh makes the activity stream gadget reflect any new activity that has been conducted on the Confluence site.</td>
</tr>
</tbody>
</table>

Confluence News Gadget

The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs and events at Atlassian.

Clicking an item in the Confluence news gadget takes you directly to the selected blog post of the Confluence Product Blogs feed or event details on the events at Atlassian page.

Clicking More news takes you to the Confluence Product Blogs feed page and clicking More events takes you to the events at Atlassian page.
Confluence: News Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show News?</td>
<td>No</td>
<td>True</td>
<td>Shows a short list of the most recent Confluence Product Blogs.</td>
</tr>
<tr>
<td>Show Events?</td>
<td>No</td>
<td>True</td>
<td>Shows a short list of the most recent events at Atlassian.</td>
</tr>
<tr>
<td>Show Banners?</td>
<td>No</td>
<td>True</td>
<td>Shows any banner advertisements (if available).</td>
</tr>
</tbody>
</table>

Confluence Page Gadget

The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.

On this page:
- Confluence Page Gadget Properties
- Working Macros

Macros that work with the page gadget

Please note, not all macros work with the page gadget. Please refer to the Working Macros section below for more information.

Screenshot: The Confluence page gadget displaying a sample page
Confluence Page Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>No</td>
<td>None</td>
<td>Specify the space that your desired page is located in. Suggestions will display in a dropdown when you start typing. (Note, this property is only used to make searching for pages easier. It is not required.)</td>
</tr>
<tr>
<td>Page</td>
<td>Yes</td>
<td>None</td>
<td>Specify the page that you want to display in your gadget. Suggestions will display in a dropdown when you start typing.</td>
</tr>
<tr>
<td>Show View Link</td>
<td>No</td>
<td>Yes</td>
<td>Select whether to display a link to view the page on your Confluence site. Clicking the link will open the page in Confluence.</td>
</tr>
<tr>
<td>Show Edit Link</td>
<td>No</td>
<td>No</td>
<td>Select whether to display a link to edit the page on your Confluence site. Clicking the link will open the page for editing in Confluence.</td>
</tr>
<tr>
<td>Refresh Interval</td>
<td>No</td>
<td>Never/false</td>
<td>Specify the time interval between each 'refresh' action undertaken by the page gadget. A refresh makes the activity stream gadget reflect any new activity that has been conducted on the Confluence site.</td>
</tr>
</tbody>
</table>

Working Macros

The Confluence page gadget will only render a subset of the macros that are used in Confluence correctly. Refer to the table below for the list of macros that work and do not work with the page gadget and known limitations.

Some of the issues with macros in the page gadget can be worked around, if you are comfortable developing in Confluence. Please see Troubleshooting Macros in the Page Gadget for more information.

Key:
- ☑️ Works with the page gadget
- ✗ Partially works with the page gadget
- ❌ Does not work with the page gadget
<table>
<thead>
<tr>
<th>Macro</th>
<th>Works with page gadget?</th>
<th>Limitations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Stream</td>
<td>✗</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Anchor (within a page)</td>
<td>✓ ✓ *</td>
<td>Opens in a new page</td>
</tr>
<tr>
<td>Attachments</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Blog Posts</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Chart</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Children Display</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By Label</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By User</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Excerpt</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Gallery</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Include Page</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Info</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Labels List</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Livesearch</td>
<td>✓ ✗</td>
<td>N/A</td>
</tr>
<tr>
<td>Note</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata Summary</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Pagetree Search</td>
<td>✗ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Pagetree</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Panel</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Quick Nav</td>
<td>✗ ✓</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Recently Updated</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>RSS Feed</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
<tr>
<td>Section &amp; Column</td>
<td>✓ ✓</td>
<td>N/A</td>
</tr>
</tbody>
</table>
### Spaces List
- N/A

### Table of Contents
- Works, however links will be opened in a new browser window when clicked.

### Team Calendars for Confluence
- See here for the Improvement Request:

  **TEAMCAL-862** - Make Team Calendars display in a Confluence Page Gadget, for use on a JIRA Dashboard [REOPENED](#).

### View File (PDF or PPT)
- Works, but you may need to refresh the gadget the first time (see CONF-19932).

### Widget Connector
- Only works for some content:
  - **Works**: blip.tv, Episodic, Flickr, Google Calendar, presentations on Google Docs, MySpace Video, Scribd, Skitch.com, SlideRocket, SlideShare, Viddler, Vimeo, YouTube, Dailymotion, Metacafe, FriendFeed, Yahoo Video, Wufoo HTML Form Builder
  - **Does not work**: FriendFeed, Google Gadgets, Google Video (consumer service discontinued), Twitter, Widgetbox, DabbleDB, BackType

### Confluence Quicknav Gadget

The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence site. For more information on how to use this feature, refer to the Quick Navigation Aid section of Search.

**Screenshot: Using the QuickNav Gadget**

The Confluence QuickNav gadget searches the Confluence site.

### Confluence QuickNav Gadget Properties

This gadget has no properties and cannot be customized.

### Confluence Use-Cases

This section describes some specific use cases for Confluence:

- Using Confluence for technical documentation
  - A technical communicator's guide to using Confluence – see Develop Technical Documentation in Confluence.
- Setting up a knowledge base
Develop Technical Documentation in Confluence

Confluence is a flexible platform with a range of features and add-ons that can help you capture, distribute, and update your technical documentation. Below are some tips to help you get your technical documentation site started, and to save you time and effort managing your documentation's life cycle.

Create your Documentation Space

Creating spaces in Confluence is quick and easy. All you need to do to get your documentation started is choose Spaces > Create space from the Confluence header. To make things even easier, choose the 'Documentation Space' option in the create space dialog; it'll give you a custom home page with a search box (the livesearch macro) to search just your documentation space, a recently updated macro, and a few other goodies.

Give your space a name, and Confluence will automatically create the home page and space key for it (change the space key if you're not happy with the one Confluence chooses for you). Feel free to customize the home page at any time; what it looks like is completely up to you!

Save time by re-using content

If there's something you're going to use multiple times in your documentation space – whether it's a word, sentence or paragraph; an image; a product version number; or anything else – you can create it once and include it on as many pages as you like (or use it in the header and/or footer). Inclusions not only save you typing the same thing many times, they also make it easier when things change – it's much better to update the info in one place, than 47!

There are 3 macros that allow you to re-use content:
1. The **Excerpt macro** to define a re-usable section, or ‘excerpt’, on a page – add content inside this macro, and you can reuse it on as many pages as you like.
2. The **Excerpt Include macro** (excerpt-include) to include the contents of an excerpt on another page.
3. The **Include Page macro** (include) to include the entire content of a page on another page.

For example, let's say you create release notes for each major release of your product, and you want to include the intro from each release notes page on a 'what's new' page. Place each release notes intro in an **Excerpt macro**, then add an **Excerpt Include macro** for each set of release notes to the what's new page. Your intros will magically appear on the what's new page, and if you update the release notes it'll automatically update the what's new.

Another example is one of the ways we use the **Include Page macro**. Whenever the ellipsis (```...``` ) appears in our documentation – for example, go to ```Copy``` – it's actually an **Include Page macro**. We have a page with just that image on it, so we can include it whenever we need an ellipsis.

Why do we do use an **Include Page macro** for one tiny image? Well, just in case that UI element is ever changed. If we attach the image to every page, there might be 50 pages we need to update when things change; if we use an **Include Page macro**, we update once and it's changed everywhere. Doing it this way also allows us to know how many pages we're using the image on. By going to ```Page Information```, we can see how many incoming links there are to this page, and that tells us how many pages use the image.

**Create an inclusions library (optional)**

You can include content from any Confluence page, but you may want to create an 'inclusions library' to hold content that's specifically for re-use. The inclusions library isn't a specific feature of Confluence; the pages in the inclusions library are just like any other Confluence page. This is just a **technique** you can use if you want a place to store content that's specifically for re-use.

To create your inclusions library:

1. Choose **Create** and create a new page in your space
2. Enter a suitable title. We use '_ConfluenceInclusions' (the underscore before the title helps to let people know this page is special)
3. Enter some content and **save** the page
   - We enter text explaining the purpose of the inclusions library and how to re-use the content
4. Choose **Space tools > Reorder pages** and drag your new page **above** the space homepage
5. Go to your new inclusions page and choose **Create** to add child pages containing your re-usable
content

Because you've moved the pages to the root of the space, they won't appear in the page tree in the sidebar. The pages will be picked up by other searches though, as they're normal Confluence pages.

Use page templates

Creating one or more page templates can be a real time-saver if you're creating a lot of pages with the same layout. If you're constantly adding the same macros, like panels and table of contents, save yourself from RSI and put them into a template – you can start with one, but make as many as you need to maximize your efficiency.

To create a page template that's available in all spaces:

1. Go to
2. Select Global Templates and Blueprints from the list on the left
3. Choose the Add global page template button at the top-right
4. Create your template page and choose Save

For detailed info on page templates, see Create a Template.

Draft your work

When you're creating a new page in your documentation, you'll likely want to do it over time, saving as you go, and have a select few people review it to provide feedback. A loose description of this workflow is 'draft, review, publish'.

You don't want any half-finished pages being seen by your users, and most documentation needs to be reviewed before it's finalized, so here's a technique for drafting pages and allowing for review:

1. Create a page and restrict its permissions
   For example, you might restrict viewing to a group of people such as your team, or a few select individuals. On a public site, you might restrict viewing to staff members, so that the general public can't see the page.
2. Write your page content
3. Share the page with your reviewers and ask them for feedback (make sure you haven't restricted them from seeing the page!)
   The reviewers can add comments to the bottom of the page or highlight text to add a comment inline.
   If you give them permission, they can also edit the page content directly.
4. Publish the page when ready, by doing the following:
   a. Delete any comments on the page
   b. Remove page restrictions so that your audience can see it
You've now published your page. The space permissions and site permissions now determine who can see and/or update the page.

Use links and anchors

Add links

In any documentation site, it's essential to be able to link from one page to another, and often to specific sections on a page. You can add any URL to a Confluence page and Confluence will automatically detect it and turn it into a link.

If you paste the URL for another page in your Confluence site, Confluence will display the link text as the page name and turn it into a relative link, meaning if the name of the page changes, Confluence will adjust the link so it doesn't break.

Add and link to anchors

The anchor macro allows you to create anchors in your documentation, which can be linked to from anywhere. I've added an anchor at the top of this page so you can click to go back to the top.

To add a macro and link to it from the same page:

1. Type \{anchor \} in the editor, select the anchor macro and give your anchor a name (\top \) in my example
2. Select the text that'll link to the macro and hit Ctrl+K (Windows) or Cmd+K (Mac) (this opens the link dialog)
3. Choose Advanced from the options on the left and type \# \ followed by your anchor name (#\top \) in my example

Check out our documentation for links and anchors to get the full rundown on linking to anchors on other pages and other anchor goodness.

Useful macros

Confluence ships with a great range of macros, and there are a few that are particularly useful in technical documentation. Here's a few:

Table of contents macro

The Table of Contents macro helps people navigate lengthy pages by summarizing the content structure and providing links to headings used on the page. The best part is, you don't need to do anything except add the macro; once you've added it, it'll automatically detect headings and add them to the table of contents.

Tip, Note, Info, Warning, and Panel macros

Often when creating documentation, there are elements of a page that you want to highlight or draw the viewers' attention to. Confluence ships with the Tip, Info, Warning, Note and Panel macros, which will help you focus a viewer's attention on a particular part of your content.

Tip of the day

Use the tip macro to give your readers handy hints!

Keep track of page updates
In Confluence, it's quite usual for a number of different people to update a single page. Technical writers need to know what happens to our documents, both during review and after publication.

**Watch pages or the space**

So that you know when changes are made, it's a good idea to watch pages or even the entire space. That way, when changes are made to pages you're watching, or someone comments on them, you'll get an email notification letting you know who changed what.

Whenever you're on a page in your documentation space, choose the Watch button at the top-right of the page. From there, you can choose to watch just that page, or all pages in the space.

**View page history**

Confluence creates a new version of the page every time someone edits the page. The page history shows all the versions, with date, author, and any comments made on the update.

To view page history, go to the page and choose *** &gt; Page History

On the page history view, you can:

- View the content of a specific version of the page.
- Revert to (restore) a specific version.
- Select any two versions and ask for a comparison, to see what has changed between those two versions.

Take a look at Page History and Page Comparison Views for a detailed explanation.

**Show a list of contributors**

If you want to see at a glance who's updated a page or pages, you can add the contributors macro. This macro displays a customizable list of people who've contributed by creating, editing, or, optionally, commenting on the page.

---

**Customize PDF export**

If you're planning to provide a PDF version of your documentation – whether it be for email, download, print, or any other form of delivery – you can customize the look of the PDF by adding a title page, header, and footer.

The process you take depends on whether you're trying to customize the PDF export for one space or for your whole site, so, if you're keen to make these changes, take a look at our page on Customize Exports to PDF for more detailed instructions.

---

**Other useful tools and add-ons**

Confluence is already a great tool for technical documentation, but you can still add to it depending on your documentation and workflow needs. Here are some useful add-ons available on the Atlassian Marketplace, most of which we use ourselves, which can extend the functionality of Confluence.

**Scroll Versions (supported)**

Scroll Versions, by K15t, allows you to tie versions of your documentation to versions of your product, so that when a new version of your product ships you can publish that version of your documentation. Create as many versions of your documentation as you like, make the changes you need to, and keep them up your sleeve until release time. You can even publish different variations of your documentation – like if you have versions of your documentation for different operating systems – to different spaces or Confluence instances.
**Copy Space (unsupported)**

The Copy Space add-on, by Atlassian Labs, does what its name suggests; it allows a space administrator to copy a space, including the pages within the space. Great for when you want a space template that you can copy to create other spaces.

This plugin is also useful when you need to archive a copy of a current space at a particular point in time, like when you're moving from one version of your product to the next – copy the space, give it a new name, and keep it wherever you like, all without losing the existing space.

ℹ️ At this point this plugin won't copy page history, blog posts and email.

**Scroll PDF Exporter (supported)**

If you're going to produce a PDF of your documentation space, wouldn't you like it to be professionally formatted? The Scroll PDF Exporter, by K15t, lets you style single pages or whole spaces for export, using handy PDF templates.

**Gliffy (supported)**

Create diagrams, wireframes, flowcharts and more with Gliffy. Gliffy features a highly intuitive drag-and-drop interface, and allows you to export your diagrams in multiple formats, including: JPEG, PNG and SVG. Add Gliffy flowcharts, UI wireframes, and network diagrams directly to your Confluence pages to communicate your ideas visually, making them easy to understand and faster to spread through your team.

**Lucidchart (supported)**

Lucidchart is available in versions for Cloud and Server, and allows you to create and insert diagrams within your Confluence Cloud environment. Quickly draw flowcharts, wireframes, UML diagrams, mind maps, and more inside our feature-rich editor.

The server version also comes with a free Visio viewer, so you can view Microsoft Visio (.vsd) files, Visio stencils (.vss) and it also supports exporting back to Visio.

**Documentation theme (deprecated)**

Confluence has historically provided a theme specifically for documentation. The Documentation theme featured a sidebar with a page tree that you could customize using wiki markup.

The Documentation theme has been deprecated and isn't compatible with some newer features like the JIRA links button or sticky table headers. A number of the original Documentation theme features, such as headers, footers and the ability to add custom content to the sidebar, are now available in Confluence's more modern default theme.

Although you can still choose to use the Documentation theme, you really don't need it to create great documentation. If you're setting up a documentation space for the first time, we recommend using the default theme right from the start.

**Use Confluence as a Knowledge Base**

A knowledge base is a repository for how-to and troubleshooting information. Knowledge Bases are commonly used by IT Support teams, but can be useful for procedural and troubleshooting information in any organization or team.

What do people want out of a knowledge base? Using an IT Support team as an example:

- Customers want fast access to a solution, and relevant search results.
- Help desk staff want to be able to create new articles quickly.
- Help Desk team leads wants the space to be self curating, and do not want to spend a lot of time manually organizing content.
• Everyone wants a way to be notified when articles they are interested in have been updated or important notices are added.

Create a knowledge base space

⚠️ You’ll need the Create Space global permission to do this.

To create your knowledge base space:

1. Choose Spaces > Create space > Knowledge base space
2. Choose Space Tools > Permissions to set permissions for the space, including anonymous access
3. Choose Create > How-to or Troubleshooting and follow the prompts to create your first knowledge base article

The knowledge base space blueprint includes everything you need to get started, including article templates, and a pre-configured homepage with Livesearch and Content By Label macros.

Page labels are essential in knowledge base spaces. These are used to add topics to your articles, and allows your knowledge base to become self-organizing over time.

Users will generally find articles by searching, and using the topic navigation on the homepage and end of each article, rather than navigating through a tree-like page hierarchy.

When starting off your knowledge base space, it's a good idea to brainstorm a few topics to get started.

Customize your knowledge base space

You’ll need Space Admin permissions to do this.

To make it easy for your users to create knowledge base articles, such as your help desk or support team, we recommend customizing the how-to and troubleshooting article templates to make them relevant for your organization. The more guidance and structure you can put in your template, the faster it will be for your team to create great articles.

To edit the article templates:

1. Go to Space Admin > Content Tools > Templates.
2. Edit the How-to or Troubleshooting article templates.
3. Add headings and instructional text (choose Template > Instructional Text).

You can also add additional templates, such as a policy or procedure page templates.

We also recommend customizing the look and feel of your space. Simple changes like a space logo and welcome message can make a huge difference.

To change the look and feel:

• Add a space logo and useful shortcuts to the sidebar (choose Space Tools > Configure Sidebar)
• Edit the homepage to add a custom welcome message.
• Edit the color scheme (choose Space Tools > Look and Feel > Color Scheme).

Provide communication and notification options

Channels of communication with your audience, internal or external, are essential in a good knowledge base. Here are some out-of-the-box options:

• Blog - blog updates and important notices, and encourage people to watch for new blogs in your space.
• Watch - encourage people to watch pages that interest them, or watch the entire space.
• Comments - allow logged in users (or even anonymous users) to comment on knowledge base articles. This is a simple way to connect with your end users.
• RSS - create an RSS feed and add the link to your knowledge base homepage (choose Help > Feed Builder). Alternatively encourage users to create their own feed - useful if they want to keep up with
particular topics (labels), rather than receive notifications for the whole space.

Integrating your knowledge base with other Atlassian products

If your Confluence site is connected to another Atlassian product (via an application link), you can make use of these great integration features:

- **If you use any JIRA application** - add a JIRA Issues macro to your troubleshooting article to provide quick access to known issues. This has the added advantage of automatically updating when an issue is resolved or its status changes. One simple way to do this would be to add some labels to JIRA to indicate the issue should appear in the knowledge base (for example 'printer-kb'), and then add a JIRA Issues macro with a query like 'label = 'printer-kb and status <> resolved'' on all articles with the printer topic.

- **If you use JIRA Service Desk** - link a Confluence space to be used as a knowledge base. Users (including those without a Confluence license) can search your knowledge base directly from within the Service Desk customer portal.

- **If you use Questions for Confluence** - add a Questions list macro to troubleshooting articles, to highlight the top questions with the same topic as the article, and an Ask a Question button to the knowledge base homepage.

Extending your knowledge base with third party add-ons

The Atlassian Marketplace has a large number of add-ons for Confluence. A common addition to Knowledge Base spaces is a survey or form tool, which enables you to get feedback on the usefulness or usability of your knowledge base articles.

Search for 'knowledge base' on Marketplace and see if there is an add-on that's right for your knowledge base.

Use Confluence as your Intranet

Your intranet is the hub of your organization. When choosing your intranet platform, you need to ensure that the system is simple enough for non-technical users, information and content can be shared easily, and access is restricted to those within your organization.

Confluence has a host of great out-of-the-box features that allow you to share and collaborate with your colleagues, while keeping your information secure. Share things like procedures, specifications and important files – or organize company events and functions – and get your teams working together. It's one place to share, find, and collaborate to get work done.

Create your community

It's quick and easy to add users to your Confluence site. Allow people to add themselves as users of the site; invite people to sign up by sending them an invitation link; add new users manually; or use an existing directory – like an LDAP directory – for authentication and to manage users and groups.

Whichever way you choose, you can quickly build a community of Confluence users and give them access to your intranet; you'll also have a ready-made people directory.

Match your company branding

Upload your company logo, and Confluence's auto look and feel will change the color scheme to match. It'll make your intranet feel more familiar to your colleagues, and help with adoption.

A space for everything, and everything in its space

A Confluence space is essentially a container for a group of pages and blog posts with related content.
When you're starting out with Confluence, the easiest way to organize things is to create a space for each team or department within your organization. Each team's space is then a place for them to create and share pages, blog posts, meeting notes, files, and much more – and becomes the place to go for team members to get the information they need.

Just choose Spaces > Create space from the header, and Confluence provides a list of space blueprints to help get you started.

Each space can have its own color scheme and has a customizable home page, which you can edit to suit your purpose – like displaying and tracking team goals and displaying a list of team members. Use the built-in 'Team Space' template to automatically add all members of the team to the homepage, to help everyone get to know each other.

You can set permissions for each space, so if there's sensitive information that should only been seen by certain users or groups, it's easy to secure it with Confluence.

Don't feel restricted to creating spaces for teams though; you can also create spaces for projects (large or small), events, and anything else where you want to collect information under a common heading or permissions structure.

Once you have some spaces set up, create some pages and blog posts to give your colleagues an example of how Confluence can be used, then invite them to create their own pages and blogs.

Add a personal space

Every Confluence user, including you, can also create their own personal space; it can be a place to keep your own work, add shortcuts to your most used content, and you even get your own blog for sharing your ideas and opinions with the rest of your organization (or just those that you want to see them).

Create pages, meeting notes and more

You can create pages for anything you want in Confluence - meeting notes, project plans, decisions, and more. Pages are editable so others can contribute and keep them up to date after you create them. Choose Create from the Confluence header and choose a blank page, or use a template to get you started.

Type your page, change its layout, add images and links, and do it all without any specialist skills or training. You can also attach files – allowing everyone in a team access to assets that are critical to the project – like mockups and requirements. You and your colleagues can like the page, and comment on it to start a conversation about the content.

Confluence also offers a series of useful built-in page blueprints, which help you with the content and formatting of the page. The meeting notes and decisions blueprints are two that can be really useful when others need to be in-the-know about what happened, and why it happened.

Avoid the reply-all and blog about it

Each space you create in Confluence has its own blog, where you and your teams can share news and events, discuss important projects and developments, or congratulate a teammate for a special effort; blogging is a great way to foster company culture and celebrate achievements across your organization.

You can watch any blog to make sure you get updated when there's a new post. Blog posts are automatically organized by date, and grouped by year and month, so they're also easy to find.
Share stuff that matters

If you need to be sure that the right people see a page or blog post, Confluence offers a range of ways to make sure you can get their attention. Type the @ symbol and the name of a Confluence user to mention them in a page, blog post, or comment. They’ll get an email notification that you’ve mentioned them, with a link to the page, post or comment.

There’s also a Share button at the top right of every page. Type the name or email address of a user or group and send them a short message with a link to the content you’re sharing.

Watch and learn

Don’t miss out on important updates. Watching spaces, pages, and blogs is a great way to stay up-to-date with what’s happening in your own team, or any other team or person you need to keep up with. When you watch something, you’ll get email updates when changes are made or a comment is added.

The Confluence dashboard also has a recent activity feed, which allows you and your team to see what’s trending throughout the company or in your network.

Let team collaboration take on a life of its own

If you want to communicate in-the-moment, HipChat — our private service for chat, video, and screen sharing — is built for teams. Share ideas and files in persistent group chat rooms, or chat 1-1 for that personal touch. HipChat integrates with Confluence, so you can get real-time notifications in HipChat whenever new information is shared in Confluence pages and blogs.

Got a question (that’s not rhetorical)? Why not ask your team? Questions for Confluence is an add-on for Confluence that gives you knowledge sharing with your own Q&A service. Run company-wide polls to gauge reaction to a new marketing initiative, or let people vote on the venue for the Christmas party. Ask questions, get answers, and identify experts.

You can also try Team Calendars for Confluence for organizing and sharing team events, leave, and other important appointments. Embed each team’s calendar on their home page so that everyone knows what’s happening, and when.
Confluence for Software Teams

Welcome to the Software Team's guide to using Confluence.

Check out the articles in this collection:

- How to write product requirements
- How to build a release planning page
- Creating insightful customer interview pages
- Create sprint retrospective
- How to make better decisions
- How to document releases
and demo pages (like a BOSS) as a development team and share release notes

Use blogs to share your development team’s progress

How to create technical and onboarding documentation

Like what you see? Start creating these pages and more in Confluence!

Try it for free