## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Confluence User’s Guide</td>
<td>7</td>
</tr>
<tr>
<td>Getting Started with Confluence</td>
<td>9</td>
</tr>
<tr>
<td>About Confluence</td>
<td>9</td>
</tr>
<tr>
<td>Dashboard</td>
<td>10</td>
</tr>
<tr>
<td>Page in View Mode</td>
<td>11</td>
</tr>
<tr>
<td>Confluence Glossary</td>
<td>13</td>
</tr>
<tr>
<td>Keyboard Shortcuts</td>
<td>17</td>
</tr>
<tr>
<td>Creating Content</td>
<td>21</td>
</tr>
<tr>
<td>Using the Editor</td>
<td>24</td>
</tr>
<tr>
<td>Quick Reference Guide for the Confluence Editor</td>
<td>28</td>
</tr>
<tr>
<td>Working with Text Effects</td>
<td>39</td>
</tr>
<tr>
<td>Working with Links</td>
<td>41</td>
</tr>
<tr>
<td>Working with Anchors</td>
<td>46</td>
</tr>
<tr>
<td>Displaying Images</td>
<td>49</td>
</tr>
<tr>
<td>Deleting an Image</td>
<td>52</td>
</tr>
<tr>
<td>Working with Tables</td>
<td>53</td>
</tr>
<tr>
<td>Using Symbols, Emoticons and Special Characters</td>
<td>55</td>
</tr>
<tr>
<td>Using Autocomplete</td>
<td>56</td>
</tr>
<tr>
<td>Working with Page Layouts and Columns and Sections</td>
<td>61</td>
</tr>
<tr>
<td>Working with Macros</td>
<td>64</td>
</tr>
<tr>
<td>Activity Stream Macro</td>
<td>69</td>
</tr>
<tr>
<td>Anchor Macro</td>
<td>69</td>
</tr>
<tr>
<td>Attachments Macro</td>
<td>69</td>
</tr>
<tr>
<td>Blog Posts Macro</td>
<td>69</td>
</tr>
<tr>
<td>Change-History Macro</td>
<td>73</td>
</tr>
<tr>
<td>Chart Macro</td>
<td>74</td>
</tr>
<tr>
<td>Cheese Macro</td>
<td>85</td>
</tr>
<tr>
<td>Children Display Macro</td>
<td>85</td>
</tr>
<tr>
<td>Code Block Macro</td>
<td>88</td>
</tr>
<tr>
<td>Column Macro</td>
<td>91</td>
</tr>
<tr>
<td>Content by Label Macro</td>
<td>91</td>
</tr>
<tr>
<td>Content by User Macro</td>
<td>95</td>
</tr>
<tr>
<td>Content Report Table Macro</td>
<td>96</td>
</tr>
<tr>
<td>Contributors Macro</td>
<td>98</td>
</tr>
<tr>
<td>Contributors Summary Macro</td>
<td>101</td>
</tr>
<tr>
<td>Create from Template Macro</td>
<td>106</td>
</tr>
<tr>
<td>Create Space Button Macro</td>
<td>108</td>
</tr>
<tr>
<td>Excerpt Include Macro</td>
<td>109</td>
</tr>
<tr>
<td>Excerpt Macro</td>
<td>110</td>
</tr>
<tr>
<td>Expand Macro</td>
<td>111</td>
</tr>
<tr>
<td>Favourite Pages Macro</td>
<td>112</td>
</tr>
<tr>
<td>Gadget Macro</td>
<td>113</td>
</tr>
<tr>
<td>Gallery Macro</td>
<td>115</td>
</tr>
<tr>
<td>Global Reports Macro</td>
<td>118</td>
</tr>
<tr>
<td>HTML Include Macro</td>
<td>119</td>
</tr>
<tr>
<td>HTML Macro</td>
<td>120</td>
</tr>
<tr>
<td>IM Presence Macro</td>
<td>120</td>
</tr>
<tr>
<td>Include Page Macro</td>
<td>121</td>
</tr>
<tr>
<td>Info Macro</td>
<td>123</td>
</tr>
<tr>
<td>JIRA Chart Macro</td>
<td>123</td>
</tr>
<tr>
<td>JIRA Issues Macro</td>
<td>125</td>
</tr>
<tr>
<td>JUnit Report Macro</td>
<td>130</td>
</tr>
<tr>
<td>Labels List Macro</td>
<td>131</td>
</tr>
<tr>
<td>Livesearch Macro</td>
<td>132</td>
</tr>
<tr>
<td>Loremipsum Macro</td>
<td>133</td>
</tr>
<tr>
<td>Multimedia Macro</td>
<td>134</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Navigation Map Macro</td>
<td>134</td>
</tr>
<tr>
<td>Network Macro</td>
<td>135</td>
</tr>
<tr>
<td>Noformat Macro</td>
<td>137</td>
</tr>
<tr>
<td>Note Macro</td>
<td>137</td>
</tr>
<tr>
<td>Office Excel Macro</td>
<td>138</td>
</tr>
<tr>
<td>Office PowerPoint Macro</td>
<td>138</td>
</tr>
<tr>
<td>Office Word Macro</td>
<td>139</td>
</tr>
<tr>
<td>Page Index Macro</td>
<td>139</td>
</tr>
<tr>
<td>Page Properties Macro</td>
<td>140</td>
</tr>
<tr>
<td>Page Properties Report Macro</td>
<td>146</td>
</tr>
<tr>
<td>Page Tree Macro</td>
<td>150</td>
</tr>
<tr>
<td>Page Tree Search Macro</td>
<td>153</td>
</tr>
<tr>
<td>Panel Macro</td>
<td>154</td>
</tr>
<tr>
<td>PDF Macro</td>
<td>155</td>
</tr>
<tr>
<td>Popular Labels Macro</td>
<td>155</td>
</tr>
<tr>
<td>Profile Picture Macro</td>
<td>156</td>
</tr>
<tr>
<td>Recently Updated Dashboard Macro</td>
<td>157</td>
</tr>
<tr>
<td>Recently Updated Macro</td>
<td>159</td>
</tr>
<tr>
<td>Recently Used Labels Macro</td>
<td>162</td>
</tr>
<tr>
<td>Related Labels Macro</td>
<td>164</td>
</tr>
<tr>
<td>RSS Feed Macro</td>
<td>164</td>
</tr>
<tr>
<td>Search Results Macro</td>
<td>167</td>
</tr>
<tr>
<td>Section Macro</td>
<td>168</td>
</tr>
<tr>
<td>Space Attachments Macro</td>
<td>168</td>
</tr>
<tr>
<td>Space Details Macro</td>
<td>168</td>
</tr>
<tr>
<td>Space Jump Macro</td>
<td>169</td>
</tr>
<tr>
<td>Spaces List Macro</td>
<td>171</td>
</tr>
<tr>
<td>Status Macro</td>
<td>172</td>
</tr>
<tr>
<td>Table of Contents Macro</td>
<td>173</td>
</tr>
<tr>
<td>Table of Content Zone Macro</td>
<td>177</td>
</tr>
<tr>
<td>Tasklist Macro</td>
<td>181</td>
</tr>
<tr>
<td>Tip Macro</td>
<td>184</td>
</tr>
<tr>
<td>User List Macro</td>
<td>185</td>
</tr>
<tr>
<td>User Profile Macro</td>
<td>186</td>
</tr>
<tr>
<td>User Status List Macro</td>
<td>187</td>
</tr>
<tr>
<td>View File Macro</td>
<td>188</td>
</tr>
<tr>
<td>Warning Macro</td>
<td>190</td>
</tr>
<tr>
<td>Widget Connector Macro</td>
<td>191</td>
</tr>
<tr>
<td>Working with Drafts</td>
<td>201</td>
</tr>
<tr>
<td>Configuring the Time Interval at which Drafts are Saved</td>
<td>202</td>
</tr>
<tr>
<td>Concurrent Editing and Merging Changes</td>
<td>203</td>
</tr>
<tr>
<td>Resuming the Editing of a Draft</td>
<td>203</td>
</tr>
<tr>
<td>Recording Change Comments</td>
<td>204</td>
</tr>
<tr>
<td>Creating Beautiful and Dynamic Pages</td>
<td>205</td>
</tr>
<tr>
<td>Working with Templates</td>
<td>209</td>
</tr>
<tr>
<td>Adding a Template</td>
<td>210</td>
</tr>
<tr>
<td>Creating a Page using a Template</td>
<td>216</td>
</tr>
<tr>
<td>Editing a template</td>
<td>218</td>
</tr>
<tr>
<td>Deleting a Template</td>
<td>219</td>
</tr>
<tr>
<td>Working with Blueprints</td>
<td>220</td>
</tr>
<tr>
<td>Decisions Blueprint</td>
<td>223</td>
</tr>
<tr>
<td>File List Blueprint</td>
<td>224</td>
</tr>
<tr>
<td>Meeting Notes Blueprint</td>
<td>226</td>
</tr>
<tr>
<td>Product Requirements Blueprint</td>
<td>227</td>
</tr>
<tr>
<td>Shared Links Blueprint</td>
<td>229</td>
</tr>
<tr>
<td>JIRA Report Blueprint</td>
<td>230</td>
</tr>
<tr>
<td>Retrospectives Blueprint</td>
<td>233</td>
</tr>
<tr>
<td>Working with the Office Connector</td>
<td>235</td>
</tr>
<tr>
<td>Office Connector Prerequisites</td>
<td>235</td>
</tr>
<tr>
<td>Displaying Office Files in Confluence</td>
<td>237</td>
</tr>
<tr>
<td>Importing a Word Document into Confluence</td>
<td>238</td>
</tr>
<tr>
<td>Editing an Office Document from Confluence</td>
<td>242</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Editing an Office Spreadsheet from Confluence</td>
<td>246</td>
</tr>
<tr>
<td>Editing an Office Presentation from Confluence</td>
<td>249</td>
</tr>
<tr>
<td>Installing the Firefox Add-On for the Office Connector</td>
<td>253</td>
</tr>
<tr>
<td>Importing Content Into Confluence</td>
<td>261</td>
</tr>
<tr>
<td>Importing Content from Another Wiki</td>
<td>262</td>
</tr>
<tr>
<td>Importing Pages from Disk</td>
<td>263</td>
</tr>
<tr>
<td>Sharing Content</td>
<td>264</td>
</tr>
<tr>
<td>Network Overview</td>
<td>264</td>
</tr>
<tr>
<td>Likes and Popular Content</td>
<td>266</td>
</tr>
<tr>
<td>User Status Updates</td>
<td>268</td>
</tr>
<tr>
<td>Using Mentions</td>
<td>270</td>
</tr>
<tr>
<td>Emailing a Page</td>
<td>272</td>
</tr>
<tr>
<td>Printing Confluence Pages</td>
<td>273</td>
</tr>
<tr>
<td>Exporting Confluence Pages and Spaces to Other Formats</td>
<td>273</td>
</tr>
<tr>
<td>Exporting Confluence Pages and Spaces to HTML</td>
<td>273</td>
</tr>
<tr>
<td>Exporting Confluence Pages and Spaces to PDF</td>
<td>275</td>
</tr>
<tr>
<td>Customising Exports to PDF</td>
<td>277</td>
</tr>
<tr>
<td>Creating PDF in Another Language</td>
<td>288</td>
</tr>
<tr>
<td>Exporting to a Word document</td>
<td>288</td>
</tr>
<tr>
<td>Exporting Confluence Pages and Spaces to XML</td>
<td>289</td>
</tr>
<tr>
<td>Managing Changes and Notifications and Tasks</td>
<td>290</td>
</tr>
<tr>
<td>Watching Pages, Spaces and Blogs</td>
<td>291</td>
</tr>
<tr>
<td>Managing Watchers</td>
<td>293</td>
</tr>
<tr>
<td>Subscribing to Email Notifications of Updates to Confluence Content</td>
<td>294</td>
</tr>
<tr>
<td>Subscribing to RSS Feeds within Confluence</td>
<td>297</td>
</tr>
<tr>
<td>Using pre-specified RSS feeds</td>
<td>299</td>
</tr>
<tr>
<td>Using the RSS Feed Builder</td>
<td>300</td>
</tr>
<tr>
<td>Subscribing to a Network RSS Feed</td>
<td>301</td>
</tr>
<tr>
<td>Managing Notifications in Confluence</td>
<td>302</td>
</tr>
<tr>
<td>Managing Tasks in Confluence</td>
<td>306</td>
</tr>
<tr>
<td>Finding Content</td>
<td>310</td>
</tr>
<tr>
<td>Searching Confluence</td>
<td>313</td>
</tr>
<tr>
<td>Confluence Search Syntax</td>
<td>319</td>
</tr>
<tr>
<td>Confluence Search Fields</td>
<td>323</td>
</tr>
<tr>
<td>Searching the People Directory</td>
<td>326</td>
</tr>
<tr>
<td>Organising Content</td>
<td>328</td>
</tr>
<tr>
<td>Working with Pages</td>
<td>328</td>
</tr>
<tr>
<td>Moving a Page</td>
<td>329</td>
</tr>
<tr>
<td>Copying a Page</td>
<td>331</td>
</tr>
<tr>
<td>Renaming a Page</td>
<td>332</td>
</tr>
<tr>
<td>Deleting a Page</td>
<td>332</td>
</tr>
<tr>
<td>Purging Deleted Pages</td>
<td>333</td>
</tr>
<tr>
<td>Restoring a Deleted Page</td>
<td>333</td>
</tr>
<tr>
<td>Viewing All Pages in a Space</td>
<td>334</td>
</tr>
<tr>
<td>Changing the Sequential Order of Pages</td>
<td>335</td>
</tr>
<tr>
<td>Managing Orphaned Pages</td>
<td>336</td>
</tr>
<tr>
<td>Managing Undefined Pages</td>
<td>337</td>
</tr>
<tr>
<td>Using the Documentation Theme</td>
<td>337</td>
</tr>
<tr>
<td>Viewing Page Information</td>
<td>341</td>
</tr>
<tr>
<td>Viewing Recently Visited Content</td>
<td>342</td>
</tr>
<tr>
<td>Page History and Page Comparison Views</td>
<td>343</td>
</tr>
<tr>
<td>Using a WebDAV Client to Work with Pages</td>
<td>346</td>
</tr>
<tr>
<td>Working with Blog Posts</td>
<td>346</td>
</tr>
<tr>
<td>Working with Spaces</td>
<td>347</td>
</tr>
<tr>
<td>Viewing All Confluence Spaces</td>
<td>349</td>
</tr>
<tr>
<td>Creating a Space</td>
<td>351</td>
</tr>
<tr>
<td>Setting Up your Personal Space</td>
<td>352</td>
</tr>
<tr>
<td>Administering a Space</td>
<td>354</td>
</tr>
<tr>
<td>Editing Space Details</td>
<td>355</td>
</tr>
<tr>
<td>Deleting a Space</td>
<td>356</td>
</tr>
<tr>
<td>Backing Up and Restoring a Space</td>
<td>356</td>
</tr>
<tr>
<td>Archiving a Space</td>
<td>356</td>
</tr>
</tbody>
</table>

Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Viewing Space Activity</td>
<td>358</td>
</tr>
<tr>
<td>Viewing Recently Updated Content</td>
<td>359</td>
</tr>
<tr>
<td>Working with Mail Archives</td>
<td>359</td>
</tr>
<tr>
<td>Adding a Mail Account</td>
<td>360</td>
</tr>
<tr>
<td>Deleting Mail</td>
<td>361</td>
</tr>
<tr>
<td>Fetching Mail</td>
<td>362</td>
</tr>
<tr>
<td>Importing Mail</td>
<td>362</td>
</tr>
<tr>
<td>Managing Mail Accounts</td>
<td>363</td>
</tr>
<tr>
<td>Working with Confluence Labels</td>
<td>364</td>
</tr>
<tr>
<td>Adding Labels</td>
<td>365</td>
</tr>
<tr>
<td>Using Labels to Categorise Spaces</td>
<td>366</td>
</tr>
<tr>
<td>Removing Labels</td>
<td>368</td>
</tr>
<tr>
<td>Using Label Macros to Categorise Wiki Content</td>
<td>369</td>
</tr>
<tr>
<td>Viewing Labels and Labelled Content</td>
<td>370</td>
</tr>
<tr>
<td>Viewing Personal Labels</td>
<td>372</td>
</tr>
<tr>
<td>Working with Favourites</td>
<td>372</td>
</tr>
<tr>
<td>Working with Attachments</td>
<td>374</td>
</tr>
<tr>
<td>Using Drag-and-Drop in Confluence</td>
<td>375</td>
</tr>
<tr>
<td>Attaching Files to a Page</td>
<td>377</td>
</tr>
<tr>
<td>Attachment Versions</td>
<td>378</td>
</tr>
<tr>
<td>Deleting an Attachment</td>
<td>379</td>
</tr>
<tr>
<td>Displaying a List of Attachments</td>
<td>379</td>
</tr>
<tr>
<td>Downloading Attachments</td>
<td>383</td>
</tr>
<tr>
<td>Editing Attachment Properties</td>
<td>383</td>
</tr>
<tr>
<td>Embedding Multimedia Content</td>
<td>384</td>
</tr>
<tr>
<td>Embedding PowerPoint Presentations in a Page</td>
<td>387</td>
</tr>
<tr>
<td>Moving an Attachment</td>
<td>388</td>
</tr>
<tr>
<td>Viewing Attachment Details</td>
<td>388</td>
</tr>
<tr>
<td>Customising Confluence</td>
<td>390</td>
</tr>
<tr>
<td>Personal Customisations</td>
<td>390</td>
</tr>
<tr>
<td>User Profile Overview</td>
<td>390</td>
</tr>
<tr>
<td>Changing Password</td>
<td>392</td>
</tr>
<tr>
<td>Editing User Settings</td>
<td>392</td>
</tr>
<tr>
<td>Editing Your User Profile</td>
<td>394</td>
</tr>
<tr>
<td>Email Address Privacy</td>
<td>395</td>
</tr>
<tr>
<td>Updating Email Address</td>
<td>395</td>
</tr>
<tr>
<td>Choosing a Profile Picture</td>
<td>396</td>
</tr>
<tr>
<td>Viewing User Profile</td>
<td>398</td>
</tr>
<tr>
<td>Viewing and Revoking OAuth Access Tokens</td>
<td>399</td>
</tr>
<tr>
<td>Choosing your Home Page</td>
<td>401</td>
</tr>
<tr>
<td>Customising your Personal Dashboard</td>
<td>402</td>
</tr>
<tr>
<td>Customising the Look and Feel of a Confluence Space</td>
<td>403</td>
</tr>
<tr>
<td>Applying a Theme to a Space</td>
<td>404</td>
</tr>
<tr>
<td>Configuring the Documentation Theme</td>
<td>405</td>
</tr>
<tr>
<td>Configuring a Sidebar</td>
<td>413</td>
</tr>
<tr>
<td>Changing a Space's Logo</td>
<td>414</td>
</tr>
<tr>
<td>Changing the Confluence Browser Icon, aka favicon</td>
<td>415</td>
</tr>
<tr>
<td>Customising Space Layouts</td>
<td>416</td>
</tr>
<tr>
<td>Editing a Space's Colour Scheme</td>
<td>417</td>
</tr>
<tr>
<td>Styling Confluence with CSS</td>
<td>419</td>
</tr>
<tr>
<td>Basic Styling Tutorial</td>
<td>422</td>
</tr>
<tr>
<td>Styling Fonts in Confluence</td>
<td>423</td>
</tr>
<tr>
<td>Requesting Add-ons</td>
<td>425</td>
</tr>
<tr>
<td>Giving People Access to Content</td>
<td>426</td>
</tr>
<tr>
<td>Page Restrictions</td>
<td>427</td>
</tr>
<tr>
<td>Site Administrators and their Permissions</td>
<td>431</td>
</tr>
<tr>
<td>Contacting Confluence Administrators</td>
<td>431</td>
</tr>
<tr>
<td>Space Administrators and their Permissions</td>
<td>432</td>
</tr>
<tr>
<td>Space Permissions Overview</td>
<td>433</td>
</tr>
<tr>
<td>Assigning Space Permissions</td>
<td>434</td>
</tr>
<tr>
<td>Users and Groups</td>
<td>437</td>
</tr>
<tr>
<td>Searching for Users</td>
<td>438</td>
</tr>
</tbody>
</table>

*Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Confluence on a Mobile Device</td>
<td>440</td>
</tr>
<tr>
<td>Notes about Confluence Mobile</td>
<td>444</td>
</tr>
<tr>
<td>Working with JIRA in Confluence</td>
<td>446</td>
</tr>
<tr>
<td>Working with JIRA Agile in Confluence</td>
<td>447</td>
</tr>
<tr>
<td>Advanced and Special Uses of Confluence</td>
<td>448</td>
</tr>
<tr>
<td>Working with Confluence Markup</td>
<td>448</td>
</tr>
<tr>
<td>Confluence Storage Format</td>
<td>449</td>
</tr>
<tr>
<td>Confluence Storage Format for Macros</td>
<td>468</td>
</tr>
<tr>
<td>Confluence Storage Format Examples for Chart Macro</td>
<td>574</td>
</tr>
<tr>
<td>Confluence Wiki Markup</td>
<td>592</td>
</tr>
<tr>
<td>Confluence Wiki Markup for Macros</td>
<td>600</td>
</tr>
<tr>
<td>Wiki Markup Examples for Chart Macro</td>
<td>690</td>
</tr>
<tr>
<td>Working with Confluence Gadgets</td>
<td>696</td>
</tr>
<tr>
<td>Adding a Confluence Gadget to a JIRA Dashboard</td>
<td>697</td>
</tr>
<tr>
<td>Configuring Confluence Gadgets for Use in Other Applications</td>
<td>702</td>
</tr>
<tr>
<td>Confluence Gadgets</td>
<td>705</td>
</tr>
<tr>
<td>Activity Stream Gadget</td>
<td>707</td>
</tr>
<tr>
<td>Confluence News Gadget</td>
<td>708</td>
</tr>
<tr>
<td>Confluence Page Gadget</td>
<td>709</td>
</tr>
<tr>
<td>Confluence Quicknav Gadget</td>
<td>712</td>
</tr>
<tr>
<td>Adding JIRA Gadgets to a Confluence Page</td>
<td>712</td>
</tr>
<tr>
<td>Developing Technical Documentation on Confluence Wiki</td>
<td>713</td>
</tr>
<tr>
<td>Creating your Technical Documentation Space</td>
<td>713</td>
</tr>
<tr>
<td>Using Templates in Technical Documentation</td>
<td>719</td>
</tr>
<tr>
<td>Re-using Content in Technical Documentation</td>
<td>720</td>
</tr>
<tr>
<td>Managing the Life Cycle of your Technical Documentation</td>
<td>725</td>
</tr>
<tr>
<td>Providing PDF Versions of your Technical Documentation</td>
<td>729</td>
</tr>
<tr>
<td>Exporting and Printing Technical Documentation</td>
<td>734</td>
</tr>
<tr>
<td>Essential Confluence Features for Technical Documentation</td>
<td>738</td>
</tr>
<tr>
<td>Confluence Add-ons for Technical Documentation</td>
<td>747</td>
</tr>
<tr>
<td>Further Reading about Developing Technical Documentation on Confluence</td>
<td>754</td>
</tr>
<tr>
<td>Developing a Knowledge Base on Confluence Wiki</td>
<td>755</td>
</tr>
<tr>
<td>Creating Your Knowledge Base Space</td>
<td>755</td>
</tr>
<tr>
<td>Using Templates and Formatting Macros in a Knowledge Base</td>
<td>766</td>
</tr>
<tr>
<td>Proactive Communications in a Knowledge Base</td>
<td>768</td>
</tr>
<tr>
<td>Additional Add-ons for a Knowledge Base</td>
<td>769</td>
</tr>
<tr>
<td>Developing an Intranet on Confluence Wiki</td>
<td>769</td>
</tr>
</tbody>
</table>
Confluence User's Guide

About this document

The Confluence user's guide begins with an overview of the key features of Confluence, and goes on to describe the use of Confluence as a knowledge management tool and a collaborative environment. If you still have a question that has not been answered, please ask us.

This guide assumes that your Confluence site uses the default theme. If your site's theme has been customized, then your site may look different and the menu items may appear in different locations from those in this guide.

Would you like a full list of the pages in this guide? Here it is: Table of Contents for Confluence User's Guide.

Downloads

You can download the Confluence documentation in PDF, HTML and XML formats.

More resources

Visit the Confluence Administrator's Guide for information on how to administer and configure your Confluence site, or go to the Confluence Documentation Home for a list of further resources.

In this guide
<table>
<thead>
<tr>
<th>Getting Started with Confluence</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating Content</td>
</tr>
<tr>
<td>Sharing Content</td>
</tr>
<tr>
<td>Managing Changes and Notifications and Tasks</td>
</tr>
<tr>
<td>Finding Content</td>
</tr>
<tr>
<td>Organising Content</td>
</tr>
<tr>
<td>Customising Confluence</td>
</tr>
<tr>
<td>Giving People Access to Content</td>
</tr>
<tr>
<td>Using Confluence on a Mobile Device</td>
</tr>
<tr>
<td>Working with JIRA in Confluence</td>
</tr>
<tr>
<td>Working with JIRA Agile in Confluence</td>
</tr>
</tbody>
</table>
Getting Started with Confluence

Getting to know Confluence
The dashboard
Page layout
Spaces in Confluence
Other users

Personalising Confluence
Changing your password
Updating your user profile
Creating your personal space
Choosing the home page you see when you log in
Customising the dashboard for yourself
Getting notifications about changes

Things to do
Creating Content
Adding a space

More helpful things
Keyboard shortcuts
Confluence glossary
About Confluence

Take me back to the Confluence User's Guide.

About Confluence

Confluence is a wiki. You can use it to collaborate on writing and sharing content with your team. Your team can be as small or as big as you like. It could encompass the whole world. Your content can be as simple or as rich as you like. It can be just words, or you can add images, diagrams, activity streams, web service integration and more.

In a nutshell, a wiki is a piece of software that runs on a server. It publishes web pages that you can read via a web browser such as Mozilla Firefox, Google Chrome or Microsoft Internet Explorer. The thing that makes wiki pages different from other web pages is the edit button. Provided that you have the right permissions, you can edit the page, save your changes, and the updates will be visible to other people immediately.

Confluence provides extra functionality that transforms it into a social collaboration platform:

- Add a space for your team, then add a page or comment on someone else's page.
- Share content by writing a blog post, sharing a link or calling

**Related pages:**
- Getting Started with Confluence
- Confluence User's Guide
someone's attention to a page via @mentions. Form a social network and tell people what you are doing via a status update.

- Add images, picture galleries, videos and more.

Dashboard

The dashboard is the front page of a Confluence site. It provides an overview of the site, gives access to the spaces that you have permission to view, and displays a few different lists of the most recently updated content.

You can go to the dashboard from anywhere in your site by choosing the site logo at the top left of the page. This might be the Confluence logo, or may be a customised logo set by your Confluence Administrator.

Overview of the dashboard

The dashboard is divided into these sections:

- **Welcome message**: The information that appears in the top left section of the dashboard. Confluence Administrators can customise this message.

- **Get started**: A quick-start guide for administrators. This section of the dashboard is visible to Confluence administrators and system administrators only. It is not configurable via the web interface, but you can update or remove it by editing the site layout.

- **Spaces, Pages, Network**: Tabs displaying your favourite content and people, displayed in the lower left favourite section of the dashboard.
  - **Spaces** displays the spaces you have marked as favourites, followed by all the spaces that you have permission to view.
  - **Pages** displays the pages you have marked as favourites.
  - **Network** displays the users that you are following (or who are following you).

- **Recent activity**: Tabs on the right-hand side of the dashboard, displaying recently-updated content:
  - **Popular** displays content that has been recently created, liked or commented on. See below for more details.
  - **All Updates** displays updates from all spaces that you have permission to view.
  - **Favourite Spaces** displays updates from your favourite spaces.
  - **Network** displays updates made by the users that you are following (or who are following you).
  - **Space Categories** displays updates from spaces in the category you have selected from the list.

On this page:
- Overview of the dashboard
- More about popular content
- Notes

Related pages:
- Confluence Glossary
- Working with Spaces
- Confluence User's Guide

Screenshot: The dashboard
More about popular content

The 'Popular' tab on the dashboard displays recent activity of the following types:

- Pages, blog posts and comments that people have recently **liked**.
- Pages and blog posts that people have recently **commented** on, and threaded comments that people have recently replied to.
- Pages and blog posts that have recently **been created**.

'Recent' means any activity in the last seven days.

A **bold** link means that you have not yet visited the page.

The activities are listed in order of popularity, with the most popular at the top. Likes, comments and content creations are scored equally. Activity that involves people in your network ranks higher than activity not involving your network. The most recent activity ranks higher than earlier activity.

Notes

- If you have the right permission, you can **add a new space** from the dashboard. Choose **Create Space** at the top right of the dashboard, or on the 'Spaces' tab.
- By default, the dashboard is the home page for the Confluence site. However, you can set any other page in Confluence as your home page via your user profile settings.
- If your site has a custom homepage, the site logo will take you to the homepage not the dashboard. You can still access the dashboard by invoking a URL like this one `https://yoursite.com/wiki/dashboard.action`. See Configuring the Site Home Page for more details.
- Users can **customise the dashboard** for themselves.
- Are you looking for a way to build an **RSS feed**? Choose Help > Feed Builder.
- Are you looking for a list of the **people** in your site? Choose People on the header.
- Administrators can **customise the global dashboard** that all users see.

Page in View Mode

The images below show the menus and other controls on a typical Confluence page using the default theme. The sidebar is on the left of each page. On the right is the body of the page.
## Related pages:
- Creating Content
- Using the Editor
- Overview of Spaces
- Sharing Content
- Confluence User's Guide

### Sidebar

The sidebar helps you to see where you are in the space, and helps you to find pages and other content in the space. The sidebar contains shortcut links to important pages in your space. Space administrators can access options to configure the sidebar and other parts of the space. At the bottom of the sidebar is a contextual navigation section, which adapts depending on the page or blog post that you are viewing. See **Finding Content**.

### Application Navigator

Use the application navigator for quick and easy access to applications that are linked to your site, for example JIRA. Confluence Administrators can add links to the application navigator, for example external websites.

### Dashboard / Home Page

Choose the site logo to access to the site home page. By default, the dashboard is the home page of your Confluence site. Your Confluence Administrator may have set a different homepage for your site.

### Spaces

Use the Spaces menu to access your recently viewed spaces and the Space Directory which contains a list of all the spaces that you have permission to view.

### People

Choose this option to see the people directory, showing all the users of your Confluence site.
<table>
<thead>
<tr>
<th>Create</th>
<th>Create pages, blog posts, and other content types in Confluence.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search</td>
<td>Type text into this box to see a list of matching pages. Select a page to go directly to it, or press Enter to use the full Confluence search. See Searching Confluence.</td>
</tr>
<tr>
<td>Help</td>
<td>Go to the documentation for help and support, view a list of keyboard shortcuts, or access other help options from this menu.</td>
</tr>
<tr>
<td>Administration</td>
<td>The cog icon gives access to the site administration menu. If you are a Confluence administrator or a system administrator, you can access user and add-on management, and other site administration options here. (Note that the space administration options are in the sidebar, not in the administration menu.)</td>
</tr>
<tr>
<td>Workbox</td>
<td>View and respond to notifications collected from Confluence page watches, shares and mentions. Manage your personal tasks. See Managing Notifications in Confluence and Managing Tasks in Confluence.</td>
</tr>
<tr>
<td>User</td>
<td>After you have logged in, your profile picture will appear at top right of the page. When you choose your profile picture, the user menu drops down with options to log out, access your user profile, or view your editing history, personal labels and page watches. You can also retrieve drafts of pages you are editing.</td>
</tr>
<tr>
<td>Tools</td>
<td>Perform miscellaneous actions relating to the page.</td>
</tr>
<tr>
<td>Like</td>
<td>Let people know that you like this page.</td>
</tr>
<tr>
<td>Edit</td>
<td>Edit the current page. (Shortcut: press e on your keyboard.)</td>
</tr>
<tr>
<td>Watch</td>
<td>Add yourself as a watcher of the page, to receive notifications of changes.</td>
</tr>
<tr>
<td>Share</td>
<td>Email a link to the current page to another Confluence user or email address.</td>
</tr>
<tr>
<td>Labels</td>
<td>View and edit labels (tags) attached to the current page. (Shortcut: press l on your keyboard.)</td>
</tr>
<tr>
<td>Add a comment</td>
<td>Click in the text box to begin writing a comment. (Shortcut: press m on your keyboard.)</td>
</tr>
<tr>
<td>Title and breadcrumbs</td>
<td>The title is the page name. The breadcrumbs show the position of the page in relation to its parent pages in the space.</td>
</tr>
<tr>
<td>Byline</td>
<td>Shows the original author and the most recent editor of the page, and the date of the most recent edit.</td>
</tr>
<tr>
<td>Byline icons</td>
<td>A small padlock indicates page restrictions. A paperclip indicates that the page has attachments. Both icons are clickable, leading to the 'Page Information' and 'Attachments' pages, respectively.</td>
</tr>
</tbody>
</table>
Confluence Glossary

Administration Console
The Administration Console is the interface for the global administration of Confluence.

Only administrators can access the Administration Console.

Administrators
The Confluence permission scheme allows the following main levels of administrator permissions:

- System Administrator – full administrative access to Confluence.
- Confluence Administrator – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

CamelCase
CamelCase is a form of markup commonly used in wikis where words compounded together LikeThis without spaces are used to create links.

In Confluence, Camelcasing can be turned on from the Administration Console.

Change Comment
A change comment is a short description entered during the edit of a page to record the changes being made in the edit.

Child Pages
Creating child pages is a means of hierarchically organising content in Confluence. A child page can only have one parent page.

Comments
A comment may be a remark, question, or any other additional information you wish to add to a page pertaining to the topic the page covers. You can comment on any page or news item in Confluence.

Confluence Administrators
The Confluence permission scheme allows the following main levels of administrator permissions:

- System Administrator – full administrative access to Confluence.
- Confluence Administrator – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

Custom Decorators
Decorator files are used to define layouts in Confluence. They are vmd files and require knowledge of the language, Velocity, to edit.

Dashboard
The dashboard is the front page of a Confluence site. It provides an overview of the site, access to all spaces, and displays a list of the most recently updated content within them.

Form Field Markup
Form field markup is a specialised markup used when creating page templates in Confluence 4.2 and earlier. It is no longer needed, because the template editor offers form fields as an option in the editor toolbar.
Global Administrators

A global administrator is the same as a system administrator.

Global Spaces

Known as Site Spaces, these spaces contain content on any theme or topic of your choice. For more information about site spaces and personal spaces, see Working with Spaces.

Hover Profile

The hover profile is the pop-up you see when the mouse pointer pauses over a Confluence user's name. Use the hover profile to follow the user, visit their profile, and more.

JIRA

JIRA is Atlassian's award winning Issue tracking and project management application. Visit Atlassian's website to learn more about JIRA.

Labels

Labels are user-defined tag words assigned to pages to categorise content in Confluence.

Macros

A macro is a command wrapped inside curly braces {...} used to perform programmatic functions and generate more complex content structures in Confluence.

Blog Posts

A blog post may be a journal entry, status report or any other timely information pertaining to a space.

Notifications

A notification is an email message sent to you updating you of changes to pages and spaces you choose to 'watch'.

Orphaned Pages

An orphaned page is a page without any incoming links.

Pages

Pages are the primary means of storing information in Confluence and are the building blocks of spaces.

Parent Page

A parent page is a page that has one or more child pages. It may itself be a child of another page.

People Directory

The People Directory contains a list of all users in your Confluence site. Each user's name links to their personal space.

Permalink

A permalink is the url used to link to specific content items like comments.

Personal Spaces

Personal spaces belong to particular users, and rather than being listed on the Dashboard, are available from the People Directory.
For more information about **global spaces** and **personal spaces**, see *Working with Spaces*.

### RSS Feeds

An RSS feed is a format for delivering summaries of regularly changing web content. RSS is read by RSS newsreader programs.

You will need an RSS reader to subscribe to feeds within Confluence.

Confluence acts as an RSS reader for feeds from sites outside of Confluence.

### RSS Reader

An RSS reader is a specialised RSS program (also called aggregator) that displays the contents of RSS feeds for you. To subscribe to RSS feeds within Confluence, you will need an RSS reader.

### Site Administrators

The Confluence permission scheme allows two levels of administrator permissions:

- **System Administrator** – full administrative access to Confluence.
- **Confluence Administrator** – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

### Site Spaces

Site spaces contain content on any theme or topic of your choice. Previously known as global spaces.

For more information about site spaces and personal spaces, see *Working with Spaces*.

### System Administrators

The Confluence permission scheme allows two levels of administrator permissions:

- **System Administrator** – full administrative access to Confluence.
- **Confluence Administrator** – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

### Space Administrators

A space administrator is a user with the ‘Space Admin’ permission for the space. A user with this permission can perform a host of functions relating to the management of a space and has complete access to the space regardless of any other control settings or permissions.

Permissions for a space are only assigned and modified by space administrators.

### Spaces

A space is an area within Confluence, containing your pages, blog posts and other content. You can think of each space as a sub-site, or mini-site, each with its own home page.

There are two types of spaces: site spaces and personal spaces - see *Working with Spaces*.

### Templates

A template is a pre-defined page that can be used as a prototype when creating pages. Templates are useful for giving pages a common style or format.

### Themes

Themes are pre-defined 'look and feel' styles which are configured from the administration menu and can be
applied across Confluence or to a single space.

**Thumbnails**
As of Confluence 4.0, all images on the page that aren't links are displayed as thumbnails: when you click on an image the full-size image is displayed in a pop-up.

**Tiny links**
A tiny link is the shortened url of a page which is useful when sending links to the page, for example, via email.

**Trackback**
Trackback is a mechanism by which two sites can stay informed each time one site refers to the other by means of trackback 'pings'.

In Confluence, Trackback is enabled from the Administration Console.

**Trackback Autodiscovery**
Trackback autodiscovery is a block of code that can be placed in a web-page to describe where trackback pings should be sent for that page. You can read the technical specification for autodiscovery here.

When Trackback is enabled, Confluence uses Trackback Autodiscovery to ping pages that are linked to, and to advertise its own pages as being able to receive pings.

**Undefined Links**
An undefined link is a link to a page that has not yet been created. Clicking on the page link allows you create the page.

**User Profile**
Every user account in Confluence is linked to a profile that contains user related information and options to configuring user preferences.

**Watching**
When you watch a page, you receive an email notification whenever that page has been modified. When you watch a space, you receive an email notification whenever content is added or modified in that space.

**Wiki**
Pioneered by Ward Cunningham, and named after the Hawaiian word for 'quick', a wiki is a website that makes it easy for anyone to contribute pages, and link them together.

**Wiki Markup**
This is the markup used to write and edit page templates in Confluence.

**Related Topics**
Take me back to Confluence User's Guide

**Keyboard Shortcuts**
Confluence provides a number of keyboard shortcuts that you can use to speed up your editing and viewing. This page describes the keyboard shortcuts for the English language. The shortcut keys (letters of the alphabet) may be different in other languages.

Confluence can display a list of available keyboard shortcuts. There are a few ways to see this keyboard shortcuts dialog:

- Choose the help icon at top right of the screen, then choose Keyboard Shortcuts.
- When viewing a page, press Shift+?
- In the editor, choose the question mark icon on the editor toolbar.
The keyboard shortcuts dialog shows the following information:

- **General** – global, page and blog post shortcuts.
- **Editor** – text editing and formatting shortcuts.
- **Editor Autoformatting** – wiki markup and autoformatting shortcuts.

### On this page:
- Keyboard shortcuts
  - All screens
  - Editor
  - Tables in the editor
  - Autocomplete in the editor
  - View screen
  - Workbox
- Disabling and re-enabling keyboard shortcuts
- Notes

### Related pages:
- Using Autocomplete
- Confluence User's Guide

### Keyboard shortcuts

The first section below describes the keyboard shortcuts that are available on all Confluence screens. Subsequent sections describe the shortcuts specific to each type of screen.

**Notes:**

- If you are using Safari on OS X, please substitute ‘Control’ for ‘Cmd’ in the shortcuts below.
- We have used capital letters (for example, ‘A’) instead of lower case (‘a’) to represent keys on the keyboard. Do not press the Shift key unless this guide explicitly mentions it.

#### All screens

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>/</td>
<td>Enable the quick search</td>
<td>/</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Submit (where a form is active). Editor -- save the Confluence page. Outside the editor -- save the browser page.</td>
<td>Cmd+S</td>
</tr>
<tr>
<td>G then D</td>
<td>Go to the dashboard</td>
<td>G then D</td>
</tr>
<tr>
<td>G then S</td>
<td>Browse the current space</td>
<td>G then S</td>
</tr>
<tr>
<td>G then G</td>
<td>Position cursor in the search box. See Searching Confluence.</td>
<td>G then G</td>
</tr>
<tr>
<td>?</td>
<td>Open the Keyboard Shortcut help</td>
<td>?</td>
</tr>
<tr>
<td>[</td>
<td>Toggle the sidebar (left-hand navigation panel) when the space is using the default Confluence theme or the Documentation theme.</td>
<td>[</td>
</tr>
<tr>
<td>Windows</td>
<td>Action</td>
<td>Mac OS X</td>
</tr>
<tr>
<td>------------------</td>
<td>------------------------------------------------------------------------</td>
<td>------------------</td>
</tr>
<tr>
<td>Ctr+0</td>
<td>Apply the paragraph style.</td>
<td>Cmd+0</td>
</tr>
<tr>
<td>Ctr+(1–6)</td>
<td>Apply a heading level (of the number chosen) to the current line.</td>
<td>Cmd+(1–6)</td>
</tr>
<tr>
<td>Ctr+7</td>
<td>Apply the preformatted style.</td>
<td>Cmd+7</td>
</tr>
<tr>
<td>Ctr+8</td>
<td>Apply the block quote style.</td>
<td>Cmd+8</td>
</tr>
<tr>
<td>Ctrl+Shift+A</td>
<td>Open the Macro Browser.</td>
<td>Cmd+Shift+A</td>
</tr>
<tr>
<td>Ctrl+B</td>
<td>Make the selected text <strong>bold</strong>.</td>
<td>Cmd+B</td>
</tr>
<tr>
<td>Ctrl+Shift+B</td>
<td>Format text as a bulleted list.</td>
<td>Cmd+Shift+B</td>
</tr>
<tr>
<td>Ctrl+Shift+D</td>
<td>Insert wiki markup. (Opens the Wiki Markup dialog.)</td>
<td>Cmd+Shift+D</td>
</tr>
<tr>
<td>Ctrl+Shift+E</td>
<td>Preview the page you are editing.</td>
<td>Cmd+Shift+E</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Open the Find and Replace toolbar.</td>
<td>Cmd+F</td>
</tr>
<tr>
<td>Ctr+I</td>
<td>Make the selected text <em>italic</em>.</td>
<td>Cmd+I</td>
</tr>
<tr>
<td>(letter I, not number 1)</td>
<td>Make the selected text <strong>italic</strong>.</td>
<td>(letter I, not number 1)</td>
</tr>
<tr>
<td>Ctrl+Shift+J</td>
<td>Insert a JIRA issue. (Opens the Insert JIRA Issue dialog.)</td>
<td>Cmd+Shift+J</td>
</tr>
<tr>
<td>Ctrl+K</td>
<td>Insert a link. (Opens the Insert Link dialog.)</td>
<td>Cmd+K</td>
</tr>
<tr>
<td>Ctrl+Shift+K</td>
<td>See a list of suggested pages or other locations to link to from your page. More about autocomplete...</td>
<td>Cmd+Shift+K</td>
</tr>
<tr>
<td>Ctrl+M</td>
<td>Insert an image. (Opens the Insert Image dialog.)</td>
<td>Cmd+M</td>
</tr>
<tr>
<td>Ctrl+Shift+M</td>
<td>See a list of suggested images, documents and other files to embed in your page. More about autocomplete...</td>
<td>Cmd+Shift+M</td>
</tr>
<tr>
<td>Ctrl+Shift+N</td>
<td>Format text as a numbered list.</td>
<td>Cmd+Shift+N</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Save the page you are editing.</td>
<td>Cmd+S</td>
</tr>
<tr>
<td>Ctrl+Shift+S</td>
<td>Format text with a strike through.</td>
<td>Cmd+Shift+S</td>
</tr>
<tr>
<td>Ctrl+U</td>
<td>Make the selected text <em>underlined</em>.</td>
<td>Cmd+U</td>
</tr>
<tr>
<td>Ctrl+Y</td>
<td>Revert an action that was undone.</td>
<td>Cmd+Y</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Undo the most recent action.</td>
<td>Cmd+Z</td>
</tr>
<tr>
<td>Tab</td>
<td>Indent current line (only in bulleted lists and numbered lists).</td>
<td>Tab</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>'Outdent' current line (only in bulleted lists and numbered lists).</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Shift+Enter</td>
<td>Force a line break without a paragraph break. This is a line break with no extra space.</td>
<td>Shift+Enter</td>
</tr>
<tr>
<td>Keyboard Shortcuts</td>
<td>Action Description</td>
<td>Notes</td>
</tr>
<tr>
<td>-------------------</td>
<td>--------------------</td>
<td>-------</td>
</tr>
<tr>
<td>Ctrl+Shift+F</td>
<td>Hide the tools at the top and bottom of the page, giving you a much larger editing area (a full-screen editor).</td>
<td>Ctrl+Shift+F (Yes, Ctrl not Cmd)</td>
</tr>
</tbody>
</table>

### Tables in the editor

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+c</td>
<td>Copy the current table row, or the selected rows.</td>
<td>Cmd+Shift+c</td>
</tr>
<tr>
<td>Ctrl+Shift+i</td>
<td>Insert a table. (Opens the Insert Table dialog.)</td>
<td>Cmd+Shift+i</td>
</tr>
<tr>
<td>Ctrl+Shift+v</td>
<td>Paste the table rows from your clipboard, placing them above the current row.</td>
<td>Cmd+Shift+v</td>
</tr>
<tr>
<td>Ctrl+Shift+x</td>
<td>Cut the current table row, or the selected rows.</td>
<td>Cmd+Shift+x</td>
</tr>
<tr>
<td>Alt+Up Arrow</td>
<td>Add a row above the current row.</td>
<td>Alt+Up Arrow</td>
</tr>
<tr>
<td>Alt+Down Arrow</td>
<td>Add a row below the current row.</td>
<td>Alt+Down Arrow</td>
</tr>
</tbody>
</table>

### Autocomplete in the editor

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>[</td>
<td>See a list of suggested pages or other locations to link to from your page.</td>
</tr>
<tr>
<td>!</td>
<td>See a list of suggested images, multimedia files and documents to embed in your page.</td>
</tr>
<tr>
<td>{</td>
<td>See a list of suggestions as you begin typing a macro name.</td>
</tr>
<tr>
<td>@</td>
<td>See a list of suggested users to mention.</td>
</tr>
</tbody>
</table>

See more about using autocomplete.

### View screen

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Create a blog post.</td>
<td>B</td>
</tr>
<tr>
<td>C</td>
<td>Create a child page of your current page.</td>
<td>C</td>
</tr>
<tr>
<td>E</td>
<td>Edit a page or blog post, or return to Edit mode when previewing.</td>
<td>E</td>
</tr>
<tr>
<td>K</td>
<td>Open the Link To dialog.</td>
<td>K</td>
</tr>
<tr>
<td>L</td>
<td>Add or edit labels.</td>
<td>L</td>
</tr>
<tr>
<td>M</td>
<td>Add a comment to a page or blog post.</td>
<td>M</td>
</tr>
</tbody>
</table>
Workbox

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>g then n</td>
<td>Open the Confluence workbox.</td>
</tr>
<tr>
<td>j</td>
<td>Move down to the next entry in the notification list.</td>
</tr>
<tr>
<td>k</td>
<td>Move up to the previous entry in the notification list.</td>
</tr>
<tr>
<td>n</td>
<td>Move down to the next notification for a particular page or blog post.</td>
</tr>
<tr>
<td>p</td>
<td>Move up to the previous notification for a particular page or blog post.</td>
</tr>
<tr>
<td>Enter</td>
<td>Open the selected notification.</td>
</tr>
<tr>
<td>u</td>
<td>Return to the notification list after opening a particular notification.</td>
</tr>
</tbody>
</table>

**Note:** The above keyboard shortcuts are available for notifications only, not for tasks, inside the Confluence workbox.

See more about managing notifications and tasks.

Disabling and re-enabling keyboard shortcuts

Keyboard shortcuts are enabled by default. You can disable general keyboard shortcuts for your personal editing sessions. This setting will not affect other Confluence users. You cannot disable the editor keyboard shortcuts.

**To disable or re-enable general keyboard shortcuts:**

1. Log in to Confluence.
2. Open the keyboard shortcuts dialog, by doing one of the following:
   - Choose the help icon at top right of the screen, then choose Keyboard Shortcuts.
   - When viewing a page, press Shift+?
   - In the editor, choose the question mark icon on the editor toolbar.
3. Choose the General tab.
4. Select or clear the Enable General Shortcuts check box as required.

Notes

- **Note about supported web browsers:** Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. Check the Supported Platforms page to find the list of supported web browsers and browser versions on this page.
- The keyboard shortcuts dialog also displays the trigger characters for the Confluence autocomplete feature. See Using Autocomplete.
- Confluence keyboard shortcuts are consistent with JIRA keyboard shortcuts.

Creating Content

Do you want to add a page or a blog post? Choose the Create option in the Confluence header.
Pages and blog posts are created within spaces, so you will need the 'Add Pages' or 'Add Blog' permission for the space. A space administrator can give you these permissions. See Giving People Access to Content.

**Adding a page or a blog post**

You can add pages and blog posts via the 'Create' dialog.

**To create content:**

1. Go to a space and choose **Create** in the Confluence header (or use shortcut key `c`).
2. Choose the **type of content** you want to create. You can create a blank page, a blog post, or a page based on a template or blueprint.
3. Choose **Next**.
4. The Confluence editor will open. Add your content in the editor pane, or update the default content supplied by the template.
5. Choose **Save**.

You can also select a space from the Create dialog to create a page in a different space to the one you are currently viewing.

Space administrators can customise the items that are visible in the Create dialog. If any items are hidden you will see a **Show more** link. See **Working with Templates** for more information.

**On this page:**

- Adding a page or a blog post
- Location of the new page
- Using an undefined link to create a page later
- Other ways to create a page

**Related pages:**

- Using the Editor
- Creating Beautiful and Dynamic Pages
- Adding a Template
- Working with Blueprints
- Finding Content
- Organising Content
- Confluence User's Guide

**Screenshot: Creating content**
Location of the new page

When you create a new page, that page will be a child of another page, in the space that you selected in the ‘Create’ dialog. The parent page depends on where you are when you create the page.

<table>
<thead>
<tr>
<th>Your location when creating the page</th>
<th>Location of new page</th>
</tr>
</thead>
<tbody>
<tr>
<td>You are viewing a page in the same space where you will put the new page – that is, the space that you select in the ‘Create’ dialog.</td>
<td>A child of the page you are currently viewing.</td>
</tr>
</tbody>
</table>
| You are viewing any other Confluence screen. For example:  
  • You are on the dashboard.  
  • You are on the ‘Pages’ view of a space.  
  • You are viewing a blog post.  
  • You are viewing a page in a space, and choose to add your new page in a different space. | A child of the home page in the space you select in the ‘Create’ dialog. |

The space sidebar in the default theme has useful links to your pages, blog posts, and other parts of the space. For more about the sidebar and the location of pages, see Finding Content.

Using an undefined link to create a page later

You may want to insert a link pointing to a Confluence page that does not yet exist, but which you intend to create later. This type of link is called an undefined link.

To add an undefined link for later creation of a page:

1. Edit the page in which the link should appear.
2. Type ‘[’ to trigger autocomplete, and type the name of the undefined page. Alternatively, type the text first, then select the text and type ‘[’.
3. Choose Insert Link to Create Page.

When you save the page, Confluence colours the undefined link red. When someone clicks the link, the new page opens in edit mode. That person can then enter the page name, add content and save the page, as usual.
Other ways to create a page

You can display a button on a page, which offers people the option of creating a page based on a given template. See Create from Template Macro.

You can import content from other Confluence sites, other wikis, Microsoft Word, and HTML pages. See Importing Content Into Confluence.

The Confluence APIs allow programmatic and scripted creation of pages. See our developer documentation.

Using the Editor

The Confluence editor is the tool that you will use to create and edit Confluence pages, blog posts and comments. You can enter content as you would in a Word document, apply formatting, and embed other content and files into the page.

Looking for a quick start? See the Quick Reference Guide for the Confluence Editor.

To begin an editing session, choose Edit at the top of a page (or press E on the keyboard).

A note about permissions: To edit a page, you need the ‘Add Pages’ permission for the space. See space permissions. Someone may also apply page restrictions that may prevent you from editing the page.

An editing session

You start an editing session whenever you:

- Create a new page or blog post, or add a comment.
- Edit an existing page, blog post or comment.

While in an editing session, you can also:

- Name, or rename, a page or blog post. Note that renaming has effects that you should consider.
- Add a comment describing the changes you made.
- Choose whether or not people watching the page get notified of the change you made.
- Add labels to the page.

Confluence automatically saves drafts of your page as you work. If another user begins editing the same page as you, Confluence will display a message, and will try to merge the changes when you save your page.

Choose Cancel (at the bottom of the page) if you want to end the session without saving any changes.

The session ends when you choose Save.

When you create a new page you can choose the location where the page should be saved. You can also move a page after it has been saved, to make it a child page of a different page, or to move it to another space.

To see changes between different versions of the page, look at the history of the page.
On this page:

- An editing session
- The editor
- Toolbars
- Embedding content in the page
- Things to help you work faster
  - Autoformatting
  - Autocomplete
  - Autoconvert for pasted links
  - Drag-and-drop for external images and files
  - Drag-and-drop within the editor
  - Keyboard shortcuts
- Finding and replacing text
- Enabling and disabling autocomplete and autoformatting

Related pages:

- Quick Reference Guide for the Confluence Editor
- Page in View Mode
- Working with Tables
- Working with Page Layouts and Columns and Sections
- Displaying Images
- Working with Links
- Using Symbols, Emoticons and Special Characters
- Confluence User's Guide

The editor

Screenshot: The Confluence editor

<table>
<thead>
<tr>
<th>Item</th>
<th>Explanation</th>
</tr>
</thead>
</table>

Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Page title</th>
<th>Type the name of the page. This name is used in links to the page.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page content</td>
<td>Add the words, images and other content that forms the content of the page.</td>
</tr>
<tr>
<td>Editor toolbar</td>
<td>Use these tools to format and colour content, create lists and tables, indent and align text, and insert other content into the page, such as symbols, links, images, multimedia files and macros. The toolbar also provides the find and replace option, help, and full-screen editing options.</td>
</tr>
<tr>
<td>Restrictions</td>
<td>Control who can view or edit the page. See Page Restrictions.</td>
</tr>
<tr>
<td>Attachments</td>
<td>View, and manage, the attached files on the page.</td>
</tr>
<tr>
<td>Labels</td>
<td>Add labels to a page, to categorise the page content.</td>
</tr>
<tr>
<td>Change comment</td>
<td>Type a comment that describes the changes you have made.</td>
</tr>
<tr>
<td>Notify watchers</td>
<td>Select this option to prompt Confluence to send an email notification of your changes to people who are watching the page.</td>
</tr>
<tr>
<td>Preview</td>
<td>See how your changes will appear, without saving the page.</td>
</tr>
<tr>
<td>Save</td>
<td>Save the changes you have made to the page. (Keyboard shortcut: Ctrl+S).</td>
</tr>
<tr>
<td>Cancel</td>
<td>End the editing session, without saving any changes.</td>
</tr>
</tbody>
</table>

**Toolbars**

From the toolbar you can:

- Apply paragraph styles and character formatting (such as bold, italics, superscript).
- Choose colour for text.
- Create numbered and bulleted lists.
- Set the indenting and alignment for text and images.
- Create links to other pages, attachments, anchors and external resources.
- Add tables, and add, remove, cut and paste rows and columns, highlight cells, rows and columns, and merge and split cells.
- Insert other content into the page, such as images, multimedia, attachments, symbols and markup.
- Use macros to add other types of content, such as a list of JIRA issues or a table of contents.
- Add layouts and columns and sections to your page.
- Find and replace content within the page that you are editing.
- Hide the tools at the top and bottom of the page, giving you a much larger editing area (a full-screen editor).

**Note:** The full-screen editing option is available in Firefox, Chrome and Safari. It is not supported in Internet Explorer. The editor remembers your full-screen preference the next time you edit a page.

*Screenshot: The editor toolbar*
Embedding content in the page

Choose **Insert** on the editor toolbar to include any of the following types of content on your page:

- An **image**.
- A link to another Confluence page or external URL, or a **link to an attachment or image**.
- An **emoticon or symbol**, or a horizontal line.
- A **macro**. Choose either a specific macro, or **Other Macros**, from the **Insert** menu.

Things to help you work faster

**Autoformatting**

You can type **Confluence wiki markup** directly into the editor to have Confluence auto-format your text as you type. To learn more, choose ? on the editor toolbar and choose the **Editor Autoformatting** tab. See also See the **Quick Reference Guide for the Confluence Editor**.

**Autocomplete**

When editing a page or blog post, you can enter a trigger character to show a list of suggested links, media files or macros to add to your page. This feature is called ‘autocomplete’ and provides you with a fast editing solution if you prefer to use key strokes rather than pointing and clicking with the mouse.

Quick summary of autocomplete:

<table>
<thead>
<tr>
<th>Type:</th>
<th>To see suggested:</th>
</tr>
</thead>
<tbody>
<tr>
<td>[ ]</td>
<td>pages and blog posts</td>
</tr>
<tr>
<td>!</td>
<td>multimedia files</td>
</tr>
<tr>
<td>{</td>
<td>macros</td>
</tr>
<tr>
<td>@</td>
<td>mentions</td>
</tr>
</tbody>
</table>

For details, see **Using Autocomplete**.

**Autoconvert for pasted links**

When you paste URLs into Confluence, the editor will analyse what you are pasting and automatically convert it into something that will display well in Confluence. Examples include:
Drag-and-drop for external images and files

You can drag a file from a location outside Confluence, and drop it directly into the editor. For example, try it with images, video files, audio files, Office documents, and PDF files. The contents of the file will be embedded into the page or blog post. Please refer to the following pages for more information:

- Displaying Images – Embedding images onto a Confluence page or blog post.
- Embedding Multimedia Content – Embedding videos, audio files and other multimedia files onto a Confluence page or blog post.
- Displaying Office Files in Confluence – Embedding Office and PDF files onto a Confluence page or blog post.

Drag-and-drop within the editor

Working within the editor panel, you can drag an image or a macro from one location on the page and drop it into a different location on the page. Hover your cursor over the image or the macro placeholder. The cursor changes to a drag-and-drop icon and you can click the image or macro and drag it to a new location. If you want to abandon the drag-and-drop action, press Escape. The image/macro will return to its original position.

Note: For the drag-and-drop of images and macros in the editor, Confluence supports the following browsers: Chrome, Firefox, and Internet Explorer 9. (Drag and drop in the editor does not work in Internet Explorer 8.)

Keyboard shortcuts

To see the keyboard shortcuts available, choose ? on the editor toolbar.

Finding and replacing text

Click the find / replace icon on the toolbar, or use the keyboard shortcut Ctrl+F (Windows) or Cmd+F (Mac OS). Search matches are highlighted in yellow. You can step through the results one by one, replace the matching text strings one by one, or replace all matching strings at once. This find and replace feature works only within the current page.

Enabling and disabling autocomplete and autoformatting

You can enable or disable the editor's autocomplete and autoformatting functions, by editing the settings in your user profile.

In summary:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Editor under ‘Your Settings’ in the left-hand panel.

For more details, see Editing User Settings.

Quick Reference Guide for the Confluence Editor

This page is a quick-reference guide to using the Confluence editor. The aim is to give you enough information about the editor's features for you to experiment yourself, rather than describing every possible shortcut key, autocomplete feature or toolbar option.

This guide is for people who want to use the autocomplete, autoformatting and keyboard shortcuts provided by the editor. If you prefer to use the toolbar options, the editor itself should be mostly self-explanatory.
Introductory tips

1. **Jump in and start using the Confluence editor.** The editor toolbar contains the most important buttons you'll need for creating and editing content.

2. **Use the keyboard shortcuts.** For example, type these characters in the editor panel:
   - Type `[]` (angle bracket) to insert a link.
   - Type `!` (exclamation mark) to insert an image or other media.
   - Type `{` (curly bracket) to insert a macro.
   These characters will trigger the autocomplete functionality, prompting you with a list of suggestions to finish off the entry. For more shortcuts, click the help icon on the editor toolbar.

3. **See how to undo the autocomplete and autoformatting actions.** To undo something that autocomplete or autoformatting has done, press Ctrl+Z (Windows) or Cmd+Z (Mac).

---

On this page:

- Introductory tips
- Seeing it in action
- Using the most common formats and features
  - Formatting text
  - Using symbols
  - Linking text
  - Using lists
  - Using tables
  - Using macros
  - Displaying images and multimedia
- Enabling and disabling autocomplete and autoformatting

Related pages:

- Using Autocomplete
- Using the Editor
- Confluence User’s Guide

---

See the video on YouTube

This video shows how to add macros, links and images by wiki markup alone. Type the macro, including its parameters and the closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket. Insert an image or other embedded object, enclosed between exclamation marks. As soon as you close the macro, link, or embedded image, Confluence will convert it to rich text format and add it to the page.

See the video on YouTube.

Using the most common formats and features

Below is a list of the most commonly used editor features, and the related keyboard shortcuts.

**Formatting text**

<table>
<thead>
<tr>
<th>Formatting text</th>
<th>What to do</th>
<th>Windows keyboard shortcuts (For Mac OS X, replace 'Ctrl' with 'Cmd')</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heading levels</td>
<td>Type the heading level and a full stop. Autoformat will convert the line to the appropriate heading immediately. You can continue typing your heading text immediately. Example: h2.</td>
<td>Ctrl + 1 to 6</td>
</tr>
<tr>
<td>Bold text</td>
<td>Type an asterisk &quot;*&quot;, your text, then another asterisk. Confluence autoformat will convert the text to bold immediately. Example: <em>Surf's Up</em></td>
<td>Ctrl + b</td>
</tr>
<tr>
<td>Italic text</td>
<td>Type an underscore '_', your text, then another underscore. Confluence autoformatting will convert the text to italics immediately. Example: <em>Surf's Up</em></td>
<td>Ctrl + i</td>
</tr>
<tr>
<td>Underlined text</td>
<td>Type a plus sign '+', your text, then another plus sign '+'. Confluence autoformatting will convert the text to underlined immediately. Example: +Surf's Up+</td>
<td>Ctrl + u</td>
</tr>
<tr>
<td>Monospace text</td>
<td>Type two curly braces {{, your text, then another two curly braces }}. Confluence autoformat will convert the text to monospace immediately. Example: {{Surf's Up}}</td>
<td></td>
</tr>
<tr>
<td>Left, centre and right alignment</td>
<td>Click the left, centre and right alignment buttons on the editor toolbar:</td>
<td>None</td>
</tr>
<tr>
<td>Indentation</td>
<td>Click the left and right indentation buttons on the editor toolbar:</td>
<td>Tab (right), Shift + Tab (left)</td>
</tr>
<tr>
<td>Line break</td>
<td>Press Shift + Enter to force a line break without a paragraph break. This is a line break with no extra space.</td>
<td>Shift + Enter</td>
</tr>
</tbody>
</table>
### Quotation

Use the *Quote* style – select 'Quote' from the style dropdown menu or use the keyboard shortcut. Example:

![Quotation Style](image)

**Ctrl + 8**

### Colour

Click the colour options on the editor toolbar. Example: None

![Colour Options](image)

### Using symbols

<table>
<thead>
<tr>
<th>Adding symbols and emoticons</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tick or check mark</td>
<td>Type a forward slash in round brackets. Autocomplete will convert it as you type. Example: (/)</td>
<td><code>( + / + )</code></td>
</tr>
<tr>
<td>Smiley</td>
<td>Type the globally-recognised markup for a smiley face (colon and round bracket), a wink (semicolon and round bracket), and so on. Autocomplete will convert it as you type. Example: <code>:</code></td>
<td><code>:+:</code></td>
</tr>
</tbody>
</table>

### Linking text
<table>
<thead>
<tr>
<th>Linking text</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linking to a Confluence page</td>
<td>Type a square bracket '[' and start typing the page name to see the suggested pages to link to. Press the arrow keys to select the page you want. Example:</td>
<td>[Modern Girl]</td>
</tr>
<tr>
<td></td>
<td>Alternatively, use <strong>wiki markup entirely</strong>. Type the link, including the alias and the page name or URL. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• This works if you have 'Autoformatting' enabled in the editor settings in your user profile.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Example: [Modern Girl</td>
<td>Modern Girl song lyrics]</td>
</tr>
</tbody>
</table>
| Linking text to a web page | Type a square bracket `[` and select 'Insert Web Link', then paste the URL into the link dialog. Example: ![Link suggestions](https://confluence.example.com/x/2.png)  
Alternatively, use **wiki markup entirely**. Type the link, including the alias and the URL. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.  
- This works if you have 'Autoformatting' enabled in the editor settings in your user profile.  
- This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.  
- Example: `[Modern Girl|http://www.example.com/song]` |
<table>
<thead>
<tr>
<th>Linking to a page that does not yet exist</th>
<th>Type a square bracket '[' and the name of the non-existent page, then select 'Insert Link to Create Page'. Example:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image" alt="Insert Link to Create Page" /></td>
</tr>
<tr>
<td></td>
<td>Alternatively, use <strong>wiki markup entirely</strong>. Type the link, including the alias and the page name or URL. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.</td>
</tr>
<tr>
<td></td>
<td>• This works if you have 'Autoformatting' enabled in the editor settings in your user profile.</td>
</tr>
<tr>
<td></td>
<td>• This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.</td>
</tr>
<tr>
<td></td>
<td>• Example: [Future of the Modern Girl]</td>
</tr>
<tr>
<td>Linking to an attachment</td>
<td>Type a square bracket <code>[</code> and start typing the attachment name to see the suggested attachments to link to. Press the arrow keys to select the item you want. Example:</td>
</tr>
<tr>
<td>--------------------------</td>
<td>------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>

Alternatively, use **wiki markup entirely**. Type the link, including the alias (if required), the caret character `^` and the attachment name. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.

- This works if you have 'Autoformatting' enabled in the editor settings in your user profile.
- This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.
- **Example:** `[^attachment name]`
### Linking to an anchor

**To create the anchor:** Add an anchor macro using wiki markup. Confluence will convert the macro to rich text format and add it to the page. For example, to create an anchor named 'index', type the following: `{anchor:index}`

**To create the link:** Use wiki markup too. Type the link, including the alias (if required), the hash character `#` and the anchor name. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.

- This works if you have 'Autoformatting' enabled in the editor settings in your user profile.
- This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.
- Example: `[Index|#index]`

### Using lists

<table>
<thead>
<tr>
<th>Using lists</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
</table>
| Adding a bullet list | Type an asterisk `*` followed by a space. Autoformat will convert the line to a bulleted list. You can continue typing your text immediately. Example:  
  My list:  
  - bullet item  
  > To add another line of text to an entry without creating a new list item, press Shift + Enter at the end of the line. | Ctrl + Shift + b |
| Adding a numbered list | Type a hash or pound `#` followed by a space. Autoformat will convert the line to a numbered list. You can continue typing your text immediately. Example:  
  My list:  
  1. bullet item  
  > To add another line of text to an entry without creating a new list item, press Shift + Enter at the end of the line. | Ctrl + Shift + n |
### Using tables

<table>
<thead>
<tr>
<th>Using tables</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a table</td>
<td>Type a series of pipe characters ']' then press <strong>Enter</strong>. Autoformat will convert the pipes to a table. Example – to create a table with three columns:</td>
<td>None</td>
</tr>
</tbody>
</table>

| | | |
| | | |

### Using macros

<table>
<thead>
<tr>
<th>Adding macros</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a macro to your page.</td>
<td>Type '{' and start typing the macro name to see a list of macros that match your text. Press the arrow keys to select the macro you want. Example:</td>
<td>{</td>
</tr>
</tbody>
</table>

Alternatively, use **wiki markup entirely**. Type the macro, including its parameters and the closing curly bracket. As soon as you close the macro, Confluence will convert it to rich text format and add it to the page. This means that you can skip the macro browser.

- This works if you have 'Autoformatting' enabled in the editor settings in your user profile.
- This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.
- **Example**: `{blogposts:content=titles|author=jsmith}`
- For details of wiki markup syntax, see [Confluence Wiki Markup for Macros](#).

### Displaying images and multimedia

<table>
<thead>
<tr>
<th>Displaying images</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
</table>

Created in 2013 by Atlassian. Licensed under a [Creative Commons Attribution 2.5 Australia License](#).
| Display an image attached to the page | Type an exclamation mark '!' and start typing the image name to see the suggested images to insert onto the page. Press the arrow keys to select the item you want. Example:  

!NoMatterWhat.png|align=right! | ! |

Alternatively, use **wiki markup entirely**. Type the wiki markup for the image insertion, including the exclamation marks, the space and/or page name (if different from the current page) and the image name, as well as any other allowed parameters. As soon as you type the closing exclamation mark, Confluence will convert the image to rich text format and add it to the page. This means that you can skip the image browser.

* This works if you have ‘Autoformatting’ enabled in the editor settings in your user profile.
* This does not work if you paste the wiki markup onto the page. You need to enter the closing exclamation mark manually.
* **Example:** !NoMatterWhat.png|align=right! |

| Displaying an image attached to another page | **Exactly the same as when the image is attached to the same page.** | ! |

| Embedding multimedia files | What to type | Keyboard shortcut (Windows) |
Embedding a video, movie or audio file into a page

Type an exclamation mark '!' and select 'Insert Other Media'.
Example:

Or type '{' and start typing the macro name 'Multimedia'.
Example:

Enabling and disabling autocomplete and autoformatting

You can enable or disable the editor's autocomplete and autoformatting functions, by editing the settings in your user profile.

In summary:

1. Choose **your profile picture** at top right of the screen, then choose **Settings**.
2. Choose **Editor** under 'Your Settings' in the left-hand panel.

For more details, see Editing User Settings.

**Working with Text Effects**

The Confluence editor supports most text effects available in standard text editing applications.

**Applying paragraph styles**

Choose a paragraph style from the editor toolbar, or click in the paragraph and use one of the keyboard shortcuts **Ctrl+(0–8)**.

*Screenshot: Choosing paragraph styles from the editor toolbar*
Applying character formats

To apply a character format, select the text and click one of the editor toolbar buttons, or use a keyboard shortcut. Some formats are available from the 'More' menu.

_Screenshot: Text formatting buttons on the editor toolbar_

<table>
<thead>
<tr>
<th>Format</th>
<th>Shortcut Key</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Ctrl+B</td>
</tr>
<tr>
<td><em>Italics</em></td>
<td>Ctrl+I</td>
</tr>
<tr>
<td><strong>Underline</strong></td>
<td>Ctrl+U</td>
</tr>
<tr>
<td><strong>Strikethrough</strong></td>
<td>Ctrl+Shift+S</td>
</tr>
<tr>
<td><strong>Subscript</strong></td>
<td>none</td>
</tr>
<tr>
<td><strong>Superscript</strong></td>
<td>none</td>
</tr>
<tr>
<td>Monospace</td>
<td>none</td>
</tr>
</tbody>
</table>

Choose **Clear Formatting** from the 'More' menu to remove all formatting.

Applying colours to text

To apply a colour to text, select the text and choose the colour option in the editor toolbar. To see the available
colours, choose the dropdown arrow next to the colour option.

*Screenshot: Picking colours from the editor toolbar*

Aligning text

You can align text to the left, right or centre of a content block. Select the text and click the appropriate alignment option on the editor toolbar.

*Screenshot: Left, centre and right alignment options on the editor toolbar*

Indenting text

You can move text to the left or right by a predefined sequence of indentations. Confluence determines the size of the indentation. Select the text and click the left or right indentation option on the editor toolbar.

*Screenshot: Left and right indentation options on the editor toolbar*

**Working with Links**

You can create links to pages, blog posts, anchors, attachments, external websites, JIRA issues and more. Links can be text or images, and can be added in many different ways.

Links to pages within your Confluence site are relative, which means that you can move pages and rename pages without breaking links.

This page explains the most common ways to create links.

**Inserting a text link**

To insert a link on a page:

1. Select some text or position your cursor where you want to insert the link.
2. Choose *Link* on the toolbar or use the *keyboard shortcut Ctrl+K*.
3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to particular types of content).
4. Enter or modify the link text - this is the text that will appear on the page. If this field is left blank, the page name or URL will be used as the link text.
5. Choose *Insert*.

Alternatively you can type `[` followed by the page or attachment name. *Autocomplete* will suggest matching items for you.

You can also paste a URL directly onto your page. Confluence will automatically create the link, and if the URL is for a page in the current site, the page name will be set as the link text.
On this page:
- Inserting a text link
- Inserting an image link
- Modifying a link
- Removing a link
- Linking to specific types of content
- Linking to Confluence pages from other websites
- Linking to comments
- Using shortcut Links
- Trackback

Related pages:
- Working with Anchors
- Inserting JIRA Issues
- Confluence User's Guide

Inserting an image link

To link from an image:

1. Select an image on your page.
3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to particular types of content).
4. Choose Insert.

Modifying a link

To modify a link:

1. Select the link text or image.
2. Choose Edit from the link properties toolbar.
3. Modify the link and choose Save.

Removing a link

To remove a link:

1. Select the link text or image
2. Choose Unlink from the properties toolbar.

Linking to specific types of content

Confluence supports many methods for creating links. Some of the common ones are listed here.
<table>
<thead>
<tr>
<th>Type of link</th>
<th>Ways to do this</th>
</tr>
</thead>
</table>
| Link to a page                       | Choose **Link > Search** then enter part of the page name.  
Choose **Link > Recently viewed** and select a page from the list.  
Type [ and enter part of the page name then select the page from the list.  
Paste the URL of the page onto your page (Confluence will automatically create the link). |
| Link to a page in another space      | Choose **Link > Search** enter part of the page name and select **All Spaces** from the drop down.  
Choose **Link > Advanced** then enter the space key followed by the page name `spacekey:mypage`.  
Type [ and enter part of the page name then select the page from the list.  
(you can hover over each suggestion to see which space the page is from). |
| Link to a blog post                  | Choose **Link > Search** and enter part of the blog post name.  
Type [ and enter part of the blog post name then select the blog post from the list. |
| Link to an attachment or image on this page | Choose **Link > Attachment** then upload or select an attachment from the list.  
Type [ and enter part of the attachment file name then select the attachment from the list. |
| Link to an attachment on another page | Choose **Link > Search** and enter part of the attachment name.  
Type [ and enter part of the attachment file name then select the attachment from the list  
(you can hover over each suggestion to see which space the page is from). |
| Link to a website                    | Choose **Link > Web Link** then enter the website URL.  
Type or paste the URL onto the page (Confluence will automatically create the link). |
| Link to an email address             | Choose **Link > Web Link** then enter the email address.  
Type or paste the email address onto the page (Confluence will automatically create a ‘mailto:’ link). |
| Link to an anchor on a page | Choose **Link > Advanced** then enter the anchor name in one of the formats below.  
For an anchor on this page: #anchor name.  
For an anchor on another page in this space: page name#anchor name.  
For an anchor on another page in another space: spacekey:page name#anchor name.  
See [Working with Anchors](#) for more information on using anchors. |
|———|———|
| Link to a heading on a page | Choose **Link > Advanced** then enter the heading in one of the formats below. Heading text is case sensitive and must be entered without spaces.  
For a heading on this page: #MyHeading.  
For a heading on another page in this space: Page Name#MyHeading.  
For a heading on another page in another space: spacekey:Page Name#MyHeading.  
Be aware that these links will break if you edit the heading text. Consider using the **Table of Contents** macro or an **Anchor** instead. |
| Link to a comment on a page | Go to the comment, right click the Date at the bottom of the comment and copy the link. Paste the link directly onto your page or choose **Link > Web Link** and paste in the URL.  
Type [$ then enter the Comment ID ('12345' in this example): ](example) |
| Link to an undefined page (a page that does not exist yet) | Choose **Link > Advanced** then enter the new page name (a page will be created on click).  
Type [ then enter the new page name then choose **Insert link to create page**.  
See [Managing Undefined Pages](#) for more information on undefined pages. |
| Link to a personal space or user profile | Choose **Link > Search** then enter the user’s name and select their personal space homepage or their profile from the list.  
Type [ then enter the user’s name and select their personal space homepage or their profile from the list. |
| Link to a JIRA issue (where Confluence is connected to JIRA) | Paste the JIRA issue URL - Confluence will automatically create a JIRA Issue macro. |

**Linking to Confluence pages from other websites**

The best way to link to a Confluence page from outside Confluence, for example on a website or in an email message, is to use the tiny link which is a permanent URL. This ensures that the link to the page is not broken if the page name changes.

To access the permanent URL for a page:

1. View the page you wish to link to.
2. Choose **Tools > Link to this page**.
3. Copy the **Tiny Link**.
4. Use the tiny link in your website or email message.

You do not need to use the tiny link to link to pages within your Confluence site. Confluence automatically updates links when you rename or move a page to another space.

If you want to link to specific content such as anchors, headings or comments you need to use the following link syntax. Note that there are no spaces in the page name, anchor name or heading text.

In the examples below, the anchor name is 'InsertLinkAnchor' and the heading text is 'Insert a link'.

<table>
<thead>
<tr>
<th>Purpose</th>
<th>Link syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link to an anchor (from an external website)</td>
<td><a href="http://myconfluence.com/display/spacekey/pagename#pagename-anchorname">http://myconfluence.com/display/spacekey/pagename#pagename-anchorname</a></td>
</tr>
<tr>
<td>Example from this page:</td>
<td><a href="https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLin">https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLin</a></td>
</tr>
<tr>
<td>Link to a heading (from an external website)</td>
<td><a href="http://myconfluence.com/display/spacekey/pagename#pagename-headingtext">http://myconfluence.com/display/spacekey/pagename#pagename-headingtext</a></td>
</tr>
<tr>
<td>Example from this page:</td>
<td><a href="https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLin">https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLin</a></td>
</tr>
<tr>
<td>Link to a comment (from an external website)</td>
<td><a href="http://myconfluence.com/display/spacekey/pagename?focusedCommentId=commentid">http://myconfluence.com/display/spacekey/pagename?focusedCommentId=commentid</a></td>
</tr>
<tr>
<td>Example from this page:</td>
<td><a href="https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803">https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803</a></td>
</tr>
</tbody>
</table>

Some things to note when linking to anchors from a website or email message:

- The page name is repeated in the URL, after the # sign. The second occurrence of the page name is concatenated into a single word, with all spaces removed.
- There is a single dash (hyphen) between the concatenated page name and the anchor name.
- The anchor name in the full URL is concatenated into a single word, with all spaces removed.
- The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as you used when creating the Anchor.

**Linking to comments**

You can add a link to a comment by using the comment URL (a permanent link), or by using wiki markup to link to the Comment ID.

To find out the comment URL and comment ID:

1. Go to the comment you wish to link to.
2. Choose the **Date** at the bottom of the comment and examine the URL.

The number after 'comment-' is the Comment ID. An example is shown here.

```
https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803
```
You can use wiki markup directly in the editor to link to a comment. Enter \[\$\] followed by the Comment ID, for example \[\$12345\] where '12345' is the Comment ID.

Using shortcut Links

If you have configured shortcut links on your Confluence site, then you can link to an external site using a shortcut link that looks like this: CONF-17025@jira.

Our Confluence site (where this documentation is housed) is configured to allow shortcut links to our JIRA site, using the shortcut @jira. So the shortcut link CONF-17025@jira produces this link.

To add a shortcut link using the 'Insert Link' dialog:

1. Choose Link > Advanced and enter or paste the shortcut link into the Link field. Shortcut links are case-insensitive.
2. Modify or enter link text - this is the text that will appear on the page.
3. Choose Insert.

You can also type '[' and choose Insert Web Link > Advanced to enter a shortcut link.

See Configuring Shortcut Links for more details.

Trackback

Trackback enables two sites can stay informed each time one site refers to the other using trackback 'pings'.

In Confluence, Trackback can be enabled by a site administrator in the Administration Console. When Trackback is enabled, any time you link to an external webpage that supports Trackback Autodiscovery, Confluence will send a Trackback ping to that page to inform it that it has been linked to.

Confluence pages also support Trackback Autodiscovery, and when Trackback is enabled, can receive trackback pings sent by other sites.

To see who has sent a Trackback ping to a Confluence page:

1. Go to the page.
2. Choose Tools > Page Information.

Any Trackback pings the page has received will be listed under the page's Incoming Links.

Confluence incoming trackback pings only work with referenced pages that are public (anonymously viewable).

Working with Anchors

Anchors are used to enable links to a specific location on a page. Anchor links can be especially useful when navigating between sections of a long document, or when you want to link to a segment of a page instead of the top of the page.

Anchors are invisible to the reader when the page is displayed.

There are two steps to using an anchor:

1. Create an anchor on the page.
2. Create a link to the anchor.

Creating an anchor

Use the Anchor macro to mark the location you want to link to.

1. Add the Anchor macro to a page.
   a. In the Confluence editor, choose Insert > Other Macros.
   b. Find and select the required macro.

   Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

   To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

   2. Specify the name of your anchor. For example, 'bottom' or 'important information'. See the 'Anchor Name' parameter described below.
Macro options (parameters)

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anchor Name</td>
<td>None</td>
<td>This is the anchor name that you will use when creating the link.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- The anchor name can include spaces. Confluence will remove the spaces automatically when building a URL that points to this anchor.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- The anchor name is case sensitive. You must use the same pattern of upper and lower case letters when creating the link as you used when creating the Anchor macro.</td>
</tr>
</tbody>
</table>

Creating a link to an anchor

You can link to an anchor from:

- A page on the same Confluence site. The link may be on the same page as the anchor, another page in the same space, or a page in another space on the same Confluence site.
- Another web page or another Confluence site, using a specifically formatted URL.

To link to an anchor from within the same Confluence site:

1. Select some text or position your cursor where you want to insert the link.
2. Choose Link on the toolbar or press Ctrl+K.
3. Choose Advanced and enter the anchor name in the Link field following the format below.

<table>
<thead>
<tr>
<th>Anchor location</th>
<th>Link syntax for anchor</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same page</td>
<td>#anchor name</td>
<td>#bottom</td>
</tr>
<tr>
<td></td>
<td></td>
<td>#important information</td>
</tr>
<tr>
<td>Page in same space</td>
<td>page name#anchor name</td>
<td>My page#bottom</td>
</tr>
<tr>
<td></td>
<td></td>
<td>My page#important information</td>
</tr>
</tbody>
</table>
The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as you used when creating the Anchor macro.

4. Enter or modify the **Link Text** - this is the text that will appear on the page. If this field is left blank, the page name or URL will be used as the link text.

5. Choose **Insert**.

**Screenshot: The ‘Advanced’ option in the link dialog**

<table>
<thead>
<tr>
<th>Link syntax</th>
<th>Examples</th>
</tr>
</thead>
</table>
| http://myconfluence.com/display/spac... | http://myconfluence.com/display/DOCS/My+page#My page-bottom  
http://myconfluence.com/display/DOCS/My+page#My page-importantinformation |

**Notes about the full URL:**

- The page name is repeated in the URL, after the # sign. The second occurrence of the page name is concatenated into a single word, with all spaces removed.
- There is a single dash (hyphen) between the concatenated page name and the anchor name.
- The anchor name in the full URL is concatenated into a single word, with all spaces removed.
- The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as you used when creating the Anchor macro.

**Code examples**

See:

- [Confluence Wiki Markup for Macros](#)
- [Confluence Storage Format for Macros](#)
• **Table of contents on page:** Consider using the Table of Contents Macro to generate a list of links pointing to the headings on the page. The list of links will appear on the page, and will be automatically updated each time someone changes the wording of a heading.

• **Linking to headings:** You can link directly to the headings of a page. See Working with Links. However, if someone changes the wording of a heading, those direct links will be broken. Use the Anchor macro to ensure a lasting link within the body of a page.

• **Site welcome message:** If you are adding an anchor to a page that you are using in the site welcome message, you can only link to that anchor from another page. Internal links within that page will not work.

• **Templates:** When you are previewing a template, a link to an anchor is displayed as a ‘broken’ link. However, when you create a page using the template the resulting page will have the correct link.

### Displaying Images

You can display an image on a Confluence page when:

- The image is attached to the page.
- The image is attached to another page in the same Confluence site, even if in another space.
- The image is on a remote web page.

Once the image is displayed on the page, you can:

- Move the image to a new position on the page by dragging or cut and paste.
- Change how the image appears on the page.
- Add a title and alt text for the image.
- Link from an image to another page.

### Displaying an image attached to the page

There are several methods for attaching image files to a page. Once you have attached an image to a page, there are different methods for choosing where on the page the image should appear:

#### Using the ‘Insert Image’ dialog

Once an image is attached to the page, you can edit the page to choose where the image should appear.

**On this page:**

- Displaying an image attached to the page
- Displaying an image attached to a different page
- Displaying an image from a remote web page
- Controlling the image appearance
- Setting other image attributes
- Displaying a gallery of images
- Image file formats

**Related pages:**

- Deleting an Image
- Working with Links
- Working with Attachments
- Choosing a Profile Picture
- Confluence User’s Guide

**To position an attached image on the page:**

1. While editing the page, position the cursor where you want to place the image.
2. Choose Insert > Image and choose the Attached Images tab.
3. Select the required image and choose Insert (or just double-click the image).

#### Using autocomplete

Once an image is attached to the page, you can use autocomplete while editing the page to choose where the image should appear.

**To position an attached image on the page:**

1. While editing the page, position the cursor where you want to place the image.
2. Trigger the autocomplete function by typing '!'.
3. Choose the image from the list that appears.

Using drag-and-drop

Depending on the browser you are using, you can attach and position an image in one step. While you are editing a page, simply drag-and-drop an image file on to the page. The image is attached to the page and is placed at the current cursor position.

Displaying an image attached to a different page

You can display an image that is attached to a different page of the same Confluence site, as long as you know the name of the image. This approach can make it easier to manage and reuse your images by allowing you to keep them all in the same place.

To display an image attached to a different page:

1. While editing the page, position the cursor where you want to place the image.
2. Choose Insert > Image and choose the Search tab.
3. Enter the name of the image.
4. Choose whether to search the current space or All Spaces and choose Search.
5. Select the required image from the search results and choose Insert.

Alternatively, you can cut and paste the image from another page (the image will still only be attached to the original page).

Displaying an image from a remote web page

You can display an image from a remote web page on your Confluence page, without needing to attach it to your page. You need to know the URL for the image, not for the web page it appears on. Note that you should have permission to use that image on your page.

To display an image located on a web page:

1. While editing the page, position the cursor where you want to place the image.
2. Choose Insert > Image and choose From the Web.
4. Choose Preview to check that the URL and image are correct.
5. Choose Insert.

Alternatively, you can simply cut and paste the image from a web page.

Controlling the image appearance

When editing the page, select the image to show the image properties panel. The panel allows you to set the display size, add a border and effects and link the image to other pages.

To set the size of the image, do one of the following:

- Choose one of the size 'preset' buttons (the image width in pixels is displayed to the left).
- Choose the image size text and enter a new image width in pixels (you can specify a size between 16px and 900px).

Images are displayed as thumbnails.

To add a border to the image:

- Choose Border in the image properties panel.

To add a hyperlink to the image:

- Choose Link in the image properties panel.

To align an image:

- Select the image and choose the paragraph alignment buttons on the editor toolbar.
- If you choose the left or right alignment, the text will wrap around the image. The text does not wrap for
centre alignment.

To add effects to an image:

- Choose Properties > Effects in the image properties panel.
- Select an effect and choose Save.

Note: The Instant Camera effect only works with Latin character languages, due to a lack of handwriting style fonts in multi-byte languages.

To add a caption to an image:

- Choose Effects in the image properties panel and choose the Instant Camera image effect.
- Save the page.
- Choose Tools > Attachments to go to the 'Attachments' view of the page.
- Choose Properties next to the image file.
- Add a comment to the attachment. The text in your comment will appear as the image caption.

You will need to re-enter the comment each time you upload a new version of the image.

Screenshot: The image properties panel beneath an image

![High Kicks!](image.png)

Screenshot: Examples of image border effects
Setting other image attributes

You can add a title and alt text to your image in the image properties panel. The image title displays when the user hovers over the image or views the full size image. The alt text is used by screen readers and when the image cannot be shown.

**To add a title and alt text:**

- Choose Properties > Title in the image properties panel.
- Enter a title and alt text and choose Save.

Other attributes can also be set by using the Insert > Wiki Markup function from the editor toolbar, then using the syntax described in Confluence Wiki Markup.

Displaying a gallery of images

See the Gallery Macro.

Image file formats

You can attach image files of any format to a page. Confluence supports the following image formats in the Gallery macro and when displaying an image on a page:

- gif
- jpeg
- png
- bmp (depending on browser support)

Deleting an Image

This page describes how to remove an image from a page. You may want to remove the image from the content of the page, but leave the image available in Confluence. Or you may want to remove the image from Confluence entirely.

**Removing an image from the content of a page**

A Confluence page can display one or more images, as described in Displaying Images.

**To remove an image from the content of a page:**

1. Edit the page.
2. Select the image. The image properties panel will appear, letting you know that the image is selected.
3. Press the Delete key on your keyboard.
4. Save the page.

The image will no longer appear as part of the page content. If the image file was originally uploaded as an attachment on the current page or another page, the image is still available in Confluence. If you want to remove the attachment, follow the steps below.

**Removing an image attachment from Confluence**

To remove an image file from Confluence, you must remove the attachment. See Deleting an Attachment.

**Note:** A page can display an image that is attached to another page. If you remove an image that is used on a page, readers will see an error message on that page.

*Example error message that appears when image attachment is removed:*

![Unknown Attachment](image-url)

**Related pages:**
- Displaying Images
- Working with Attachments
- Confluence User's Guide

**Working with Tables**

Confluence pages can include multi-row and multi-column tables. You can highlight cells, rows and columns in different colours. When viewing the page, people can sort the table by clicking the column headers.

**Inserting a table**

**To create a table:**

1. While editing the page, place your cursor at the point where you want to insert the table.
2. Choose **Table** on the toolbar.
3. A dropdown menu will appear, showing a table with a variable number of rows and columns. Click in a cell to set the number of columns and rows for your table.
4. Add content and more rows and columns as needed. See below for guidelines on what you can do with your table in the editor.

*Screenshot: Inserting a table with 3 rows and 3 columns*

**On this page:**
- Inserting a table
- What you can do with your table in the editor
- Shortcut keys
- Sorting the table in view mode

**Related pages:**
- Working with Page Layouts and Columns and Sections
- Using the Editor
- Confluence User's Guide

**What you can do with your table in the editor**

While editing a page, place your cursor inside a table to see the table toolbar.
Using the table toolbar you can:

- Insert an empty row above the current one.
- Insert an empty row below the current one.
- Remove the current row.
- Cut the current row and copy it to the clipboard.
- Copy the current row to the clipboard.
- Paste the row from the clipboard to the current row.
- Insert an empty column to the left of the current one.
- Insert an empty column to the right of the current one.
- Remove the current column.
- Merge the selected cells.
- Split the selected merged cells.
- Mark a row as a table header. The cells in the row will be highlighted in grey and the text will be bold.
- Mark a column as a table header. The cells in the column will be highlighted in grey and the text will be bold.
- Highlight cells with a background colour.
- Remove the table.

Shortcut keys

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+c</td>
<td>Copy the current table row, or the selected rows.</td>
<td>Cmd+Shift+c</td>
</tr>
<tr>
<td>Ctrl+Shift+i</td>
<td>Insert a table. (Opens the Insert Table dialog.)</td>
<td>Cmd+Shift+i</td>
</tr>
<tr>
<td>Ctrl+Shift+v</td>
<td>Paste the table rows from your clipboard, placing them above the current row.</td>
<td>Cmd+Shift+v</td>
</tr>
<tr>
<td>Ctrl+Shift+x</td>
<td>Cut the current table row, or the selected rows.</td>
<td>Cmd+Shift+x</td>
</tr>
<tr>
<td>Alt+Up Arrow</td>
<td>Add a row above the current row.</td>
<td>Alt+Up Arrow</td>
</tr>
<tr>
<td>Alt+Down Arrow</td>
<td>Add a row below the current row.</td>
<td>Alt+Down Arrow</td>
</tr>
</tbody>
</table>

For more editor keyboard shortcuts, see Keyboard Shortcuts.

Sorting the table in view mode

When readers view a table on a page, they can sort the table by clicking the sort icons in the header row.

Screenshot: A colourful, sortable table
Using Symbols, Emoticons and Special Characters

You can add various symbols and special characters to Confluence pages. You can also use them in other places that display content, such as blog posts, comments, the dashboard welcome message and the configuration panels offered by the Documentation theme.

Inserting symbols and special characters

To add a symbol to your page:

1. Edit the page.
2. Choose Insert > Symbol. This will display the 'Insert Custom Character' window.
3. Choose a symbol to insert it.

On this page:
- Inserting symbols and special characters
- Inserting emoticons
- Preventing emoticons from appearing

Related pages:
- Quick Reference Guide for the Confluence Editor
- Confluence Wiki Markup
- Confluence User's Guide

Screenshot: Available symbols
Inserting emoticons

There are two ways to add an emoticon, or smiley, to your page.

**By choosing an emoticon from those available:**

1. Choose Insert > Emoticon.
2. Choose an emoticon to insert it.

**By typing a character combination:**

You can insert emoticons by typing commonly-used character combinations. For example, the following code appears as an emoticon when the page is rendered.

`;)

The above example creates this emoticon: 😊

This table shows the emoticons (and other icons) available in Confluence, and the character combinations that create them:

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Notation</td>
<td>:)</td>
<td>:(</td>
<td>:P</td>
<td>:D</td>
<td>:)</td>
<td>(y)</td>
<td>(n)</td>
<td>(i)</td>
<td>(f)</td>
<td>(l)</td>
<td>(+)</td>
<td>(-)</td>
<td>(?)</td>
<td>(o)</td>
<td>(n)</td>
<td>(o)</td>
<td>(r)</td>
</tr>
</tbody>
</table>

Preventing emoticons from appearing

To undo the conversion of a character combination into an emoticon, press **Ctrl+Z** (Windows) or **Cmd+Z** (Mac).

To prevent Confluence from converting text to emoticons automatically, disable ‘Autoformatting’ in your user profile. See [Editing User Settings](#). The Confluence knowledge base has an article on disabling emoticons for the Confluence site as a whole.

**Using Autocomplete**

When using the Confluence editor, you can type a trigger character or press a keyboard shortcut to see a list of suggested links, files or macros to add to your page, or to mention another user (and automatically notify them of this).

**Summary of autocomplete**

<table>
<thead>
<tr>
<th>What you want to do</th>
<th>Trigger character</th>
<th>Keyboard shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a link on your page</td>
<td>[</td>
<td>Ctrl+Shift+K</td>
<td>See a list of suggested pages or other locations to link to from your page. More...</td>
</tr>
<tr>
<td>Display an image, video, audio file or document on your page</td>
<td>!</td>
<td>Ctrl+Shift+M</td>
<td>See a list of suggested images, multimedia files and documents to embed in your page. More...</td>
</tr>
<tr>
<td>Add a macro on your page</td>
<td>{</td>
<td>None</td>
<td>See a list of suggestions as you begin typing a macro name. More...</td>
</tr>
</tbody>
</table>
Using autocomplete for links

Type '[', or press Ctrl+Shift+K, to see a list of suggested pages or other locations to link to from your page. You can link to pages, user profiles, images, documents and other file attachments.

To autocomplete a link:

1. Edit the page.
2. Click where you want to insert a link and do one of the following:
   - Type '[' and then the first few characters of the page title, user's name, image name or file name.
   - Type the first few characters of the page title, user's name, image name or file name (or select relevant text) and then press Ctrl+Shift+K.
3. Click the relevant link from the list of suggestions.

If the item you need is not in the list, either:

- Choose Search for 'xxx' to continue looking for the page within Confluence, or
- Choose Insert Web Link to insert a link to an external web page using the link browser.

Screenshot: Autocomplete for a link
Using autocomplete for images, videos, audio files and documents

You can use the autocomplete as a fast way of embedding images, videos, audio files and documents into your page. Type an exclamation mark or press Ctrl+Shift+M to see a list of suggested images, multimedia files and documents to display on your page. You can use autocomplete to embed the following file types:

- Images – any format that Confluence supports. See Displaying Images.
- Videos, audio files and all multimedia formats that Confluence supports. See Embedding Multimedia Content.
- Office documents supported by the Confluence Office Connector: Word, Excel and PowerPoint.
- PDF files.

Autocomplete works most efficiently for files that are already attached to the Confluence page. See Attaching Files to a Page.

To embed an image, video, audio file or document:

1. Edit the page.
2. Click where you want to insert the image, video, audio file or document and do one of the following:
   - Type ‘!’ and then the first few characters of the image, file or document name.
   - Type the first few characters of the name of the image, file or document (or select relevant text) and then press Ctrl+Shift+M.
3. Choose the relevant file from the list of suggestions.

If the item you need is not in the list, either:

- Choose Open Image Browser to find images and documents using the image browser, or
- Choose Insert Other Media to embed videos, audio and other multimedia files using the macro browser. Insert the ‘Multimedia’ macro to display your multimedia file.

Screenshot: Autocomplete for an image or document
Using autocomplete for macros

Type '{' to see a list of suggested macros to add to your page.

Autocomplete provides access to all available macros in your Confluence site, including any user macros that your administrator has added and made visible to all.

ℹ️ You need to know the name of macro. Autocomplete for macros will only match the name of the macro, not the description.

**To autocomplete a macro using '{':**

1. Edit the page.
2. Click where you want to insert the macro.
3. Type '{' and then the first few characters of the macro name.
4. Choose the relevant macro from the list of suggestions.
5. Configure the macro by completing the form fields as prompted.

If the macro you need is not in the list, choose Open Macro Browser in the list of suggestions to continue looking for the macro in the macro browser. See Working with Macros.

**Screenshot: Autocomplete for a macro**

Using autocomplete for mentions

You can use autocomplete to automatically notify another Confluence user that you have mentioned them in a page, blog post, or comment. Type '@' and part of the person's name, to see a list of suggested users.

**Note:** Use the person's full name. Autocomplete will recognise users' full names only, not their usernames.
To mention someone using '@':

1. Edit the page.
2. Click where you want to insert a mention and type '@' and then the first few characters of the user's full name.
3. Choose the user's name from the list of suggestions.

Screenshot: Autocomplete for mentions

Cancelling autocomplete

The autocomplete starts automatically when you press the trigger characters. You may want to close the autocomplete menu or escape from autocomplete once it has started.

There are a few different ways to stop the autocomplete once it has started:

- Press the escape key, 'Esc', on your keyboard.
- Click somewhere else in the editor panel.
- Press an arrow key to move out of the autocomplete area.
- For the link autocomplete only: enter a right-hand square bracket, like this: ]

Enabling and disabling autocomplete

You can turn off the triggering of autocomplete by the '[' and ']' characters. This will prevent the autocomplete from starting automatically when you press one of the trigger characters. You can also turn it back on again.

Notes:

- This setting does not affect the keyboard shortcuts for autocomplete (Ctrl+Shift+K and Ctrl+Shift+M). Even if the trigger characters are disabled, you can still use the keyboard shortcuts for autocomplete.
- This setting affects only you. Other people using Confluence can enable or disable the setting on their user profiles independently.
- Note that autocomplete is enabled by default.

To enable or disable the autocomplete trigger characters:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Editor under 'Your Settings' in the left-hand panel.
3. Choose Edit.
4. Either:
   - Disable autocompletion by selecting Disable Autocomplete.
   - Enable autocompletion by clearing Disable Autocomplete.
5. Choose Submit.

Screenshot: User settings for the editor
Ignoring autocomplete

You can add macros, links and images by wiki markup alone. Type the macro, including its parameters and the closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket. Insert an image or other embedded object, enclosed between exclamation marks. As soon as you close the macro, link, or embedded image, Confluence will convert it to rich text format and add it to the page.

More information about mouse-free macros, links and images:

- Quick Reference Guide for the Confluence Editor
- Video

**Working with Page Layouts and Columns and Sections**

There are two ways to modify the layout of a Confluence page. You can:

- use Page Layouts to add sections and columns, or
- use macros to add sections and columns.

Page layouts provides a simple, visual representation of your page layout in the editor, while the macros are more flexible and allow for greater complexity in your layout.

**Using page layouts**

The Page Layouts tool allows you to structure your page using horizontal sections and vertical columns. By adding multiple sections with different column configurations you can build quite complex layouts very easily.

**Screenshot: Editor view of a page showing three sections with different column configurations.**
Start by adding a horizontal section to your page.

**To add a section:**

1. Choose the Page Layout button on the editor toolbar.
2. The Page Layout toolbar appears. Choose Add Section.

The new section appears below your current content. The boundaries of the section are indicated by dotted lines. These are not visible when you view the page.

**To change the column layout in a section:**

1. Place your cursor in the section you wish to change.
2. Choose a layout from the Page Layout toolbar (for example two column, three column).

Any text, images or macros in your section are not lost when you change the column layout. When you decrease the number of columns, Confluence will move your content to the left. When you increase the number of columns, Confluence will add blank columns to the right of your existing content.

**To move a section to another part of the page:**

1. Place your cursor in the section you wish to move.
2. Choose the Move up or Move down buttons.

The section and all of its content will be moved above or below other sections on the page.

**To delete a section:**

1. Place your cursor in the section you wish to remove.
2. Choose Remove section.

The section and all of its content will be removed.

**Notes about Page Layouts**

- **Column width** - The width of the columns are fixed. If you need more than three columns, or columns of a specific width, you should use the Section and Column macros described below.

- **Very wide tables.** The width of each column is set to a percentage of the page width. The icons in the drop down menu indicate the relative widths for each layout. In most cases, Confluence will adapt the width of the columns to fit the width of the page. If a column includes a large table, the content may not fit into the width of the page. You will see a horizontal scroll bar when viewing the page.

**Using the Section and Column macros**

You can use the Section and Column macros to add a set of columns to the page. The Section macro defines an area that will contain the columns. You can have as many sections as you like. Within each section, you can have as many columns as you like.

The Section and Column macros are useful if you want to define a specific percentage or pixel width for each column.

**To add a section and some columns to a page:**
1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find the **Section** macro, select it and insert it onto the page.
3. Choose **Insert > Other Macros** again.
4. Find and insert the **Column** macro.
5. Add your content to the column.
6. Insert as many columns as you like within the section.

**Screenshot: A section and two columns in the editor**

When you see the page in view mode, the above layout is displayed like this:

Content for column 1 goes here
Content for column 2 goes here

**Macro parameters**

Parameters are options that you can set to control the content or format of the macro output.

**Parameters of the Section macro**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Border</td>
<td>false</td>
<td>Select this option to draw a border around the section and columns.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Note:</strong> Without a Column macro, the border will not be displayed correctly.</td>
</tr>
</tbody>
</table>

**Parameters of the Column macro**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Width</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>Specify the width of the column, in pixels (for example, 400px) or as a percentage of the available width (for example, 50%).</td>
</tr>
</tbody>
</table>

**Notes about sections and columns**

- All content within your section must be enclosed within a Column macro, otherwise the section layout will not work as expected.
Confluence 5.4 Documentation

- You can put tables inside columns.
- PDF exports do not handle page layouts. See this issue report: [CONF-25240](#) - PDF export does not handle page layouts

Code examples

See:

- Confluence Wiki Markup for Macros -- Section macro
- Confluence Storage Format for Macros -- Section macro

Working with Macros

Using a macro, you can add extra functionality or include dynamic content on a page. For example, the Attachments macro will list a page's attachments in the page itself, so that readers do not have to visit the Attachments tab.

Adding a Macro to your Page

Including Macros with the Macro Browser

To add a macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Macro Parameters

Many macros allow you to include optional parameters to control the macro's output.

With the Attachments Macro, for instance, you have two optional parameters allowing you to:

- Specify the file formats of the attachments displayed.
- Choose whether or not you want old versions of the attachments displayed.

Macro Placeholders

Macro placeholders are displayed in the editor where you have added a macro to the page.

When editing a page, you can:

- Double-click a macro placeholder (or click the placeholder and choose Edit) to open the macro dialog window, where you can edit the macro's parameters.
- Select a macro placeholder to cut, copy and paste the macro.

On this page:

- Adding a Macro to your Page
- Macros Shipped with your Confluence Installation
- Information about Other Macros
- Writing your own Macros
- Code examples

Related pages:

- Confluence User's Guide

Macros Shipped with your Confluence Installation

When you download your Confluence installation file, many macros are shipped with the download. Below is a list of the macros currently shipped with Confluence. Click a macro name for details of the usage, including optional parameters and examples.
**Activity Stream Macro**

Allows you to link to a specific part of a page.

**Anchor Macro**

Displays a list of attachments on a given page.

**Attachments Macro**

Lists the most recent news items in the space.

**Blog Posts Macro**

Displays a history of updates made to a page.

**Change-History Macro**

Displays the children and descendants of the current page.

**Chart Macro**

Displays a chart based on tabular data.

**Cheese Macro**

Displays the words "I like cheese!"

**Children Display Macro**

Displays code in your document with the appropriate syntax highlighting.

**Code Block Macro**

Used with the Section macro to define columns on a page. See Working with page layouts and columns and sections.

**Content by Label Macro**

Displays a list of content associated with specific labels.

**Content by User Macro**

Displays a list of the content items that have been created by a specified Confluence user.

**Content Report Table Macro**

Displays a set of pages and blog posts in tabular format, based on the labels specified in the macro parameters.

**Contributors Macro**

Displays a list of Confluence users who have made a contribution of some type to a page.

**Contributors Summary Macro**

Displays a table of contribution-based statistics for a set of pages.

**Create from Template Macro**

Creates a page from a given template.

**Create Space Button Macro**

Displays a create space button linked to the create space page.

**Excerpt Include Macro**

Allows you to display an excerpt from another page within the current page.
**Excerpt Macro**

Define a part of a page as the page's 'excerpt' which can then be displayed in another page.

**Expand Macro**

Displays an expandable/collapsible section of text.

**Favourite Pages Macro**

Displays a list of your favourite pages.

**Gadget Macro**

Allows you to add Confluence gadgets to pages or blog posts.

**Gallery Macro**

Forms a thumbnail gallery of all images attached to a page.

**Global Reports Macro**

Displays a list of links to global reports within a table.

**HTML Include Macro**

Includes the content of an external HTML file into a Confluence page.

**HTML Macro**

Renders your specified HTML code within the current page.

**IM Presence Macro**

Displays graphically when a contact is online.

**Include Page Macro**

Inserts the contents of the specified page into the current one.

**Info Macro**

Displays a block of text in a blue highlight box.

**JIRA Chart Macro**

Displays information from JIRA as a pie chart.

**JIRA Issues Macro**

Displays one or more JIRA issues, and offers the option to create an issue in JIRA.

**JUnit Report Macro**

Display a summary of JUnit test results.

**Labels List Macro**

Displays a hyperlinked alphabetical index of all labels within the current space.

**Livesearch Macro**

Add a dynamic search box to a wiki page.

**Loremipsum Macro**

Display a few paragraphs of pseudo-Latin text.

**Multimedia Macro**

...
Displays videos, animations and more, sourced from a file attached to a Confluence page and displayed on your page.

**Navigation Map Macro**
Displays a navigable map of the pages tagged with a given label.

**Network Macro**
Displays a list of Network activity for users on your Confluence site.

**Noformat Macro**
Displays a block of text in monospace font.

**Note Macro**
Displays a block of text in a yellow highlighted box.

**Office Excel Macro**
Displays the content of an Excel spreadsheet on a wiki page.

**Office PowerPoint Macro**
Displays the content of a PowerPoint presentation on a wiki page.

**Office Word Macro**
Displays the content of a Word document on a wiki page.

**Page Index Macro**
Creates a hyperlinked alphabetical index of all page titles within the current space.

**Page Properties Macro**
Allows you to embed metadata into a page and then display that data in tabular form using the Page Properties Report macro. Previously known as the Metadata Details macro.

**Page Properties Report Macro**
Presents a tabulated summary of selected metadata, which has been embedded on pages using the Page Properties macro. Previously known as the Details Summary macro.

**Page Tree Macro**
Displays a dynamic, hierarchical list of pages starting from a specified parent (root) page.

**Page Tree Search Macro**
Adds a search box to your Confluence page and searches a hierarchy of pages starting from a specified parent (root) page.

**Panel Macro**
Displays a block of text within a customisable panel.

**PDF Macro**
Displays the content of a PDF document on a wiki page.

**Popular Labels Macro**
Displays the most popular labels used throughout your Confluence site or within a space.

**Profile Picture Macro**
Displays a user's profile picture on a page.
Recently Updated Dashboard Macro
Displays a list of the most recently changed content within Confluence and is intended for use on the Confluence dashboard.

Recently Updated Macro
Displays a list of recently changed content (pages, news items, comments, etc).

Recently Used Labels Macro
Lists labels most recently used in a specified scope (global, space, or personal)

Related Labels Macro
Lists labels frequently appearing on the same pages as the current page's labels.

RSS Feed Macro
Displays the contents of an RSS feed.

Search Results Macro
Searches Confluence, and includes the results in the page.

Section Macro
Used with the Column macro to define columns on a page. See Working with page layouts and columns and sections.

Space Attachments Macro
Displays a list of attachments belonging to the current space.

Space Details Macro
Displays the details of a Confluence space, including the space name, description, and more.

Space Jump Macro
Allows you to link from a page in one space to a page with the same name in another space, without knowing the name of the page when you create the link.

Spaces List Macro
Displays a list of the spaces visible to the user.

Status Macro
Displays a coloured lozenge, useful for reporting project status.

Table of Contents Macro
Displays a table of contents based on the headings on the page.

Table of Content Zone Macro
Displays a table of contents from a defined page 'zone'.

Tasklist Macro
Displays a dynamic task list which can be modified in view mode.

Tip Macro
Displays a block of text in a green box.

User List Macro
Displays a list of Confluence users in a given group.
User Profile Macro
Displays a summary of a given Confluence user's profile.

User Status List Macro
Displays a history of a given Confluence user's status updates.

View File Macro
Embeds an Office document or PDF file into your Confluence page.

Warning Macro
Displays a block of text in a red highlight box.

Widget Connector Macro
Displays videos, slide shows, twitter chats, documents and more, sourced from other web sites and displayed on your Confluence page.

Information about Other Macros
Other macros are available as plugins or as user macros, and can be installed by your Confluence administrator. For example, macros that may be of interest are available from Adaptavist, CustomWare and the Confluence SharePoint Connector.

Writing your own Macros
To learn how to write your own macro, take a look at the following documentation:

- User macros are simple template-like macros that allow you to create simple formatting macros using the Confluence web interface. Read more about Writing User Macros.
- The Confluence Plugin Guide tells you how to develop a plugin for Confluence.

Code examples
See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Activity Stream Macro
The Activity Stream macro is a specific instance of the Gadget macro. It inserts an Activity Stream gadget onto your page. For instructions, see Activity Stream Gadget.

Anchor Macro

The Anchor Macro is documented in Working with Anchors.

Attachments Macro
See Displaying a List of Attachments.

Blog Posts Macro
The Blog Posts macro allows you to display blog posts on a Confluence page. Clicking on a title takes you to the blog post.

Using the Blog Posts Macro

To add the Blog Posts macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose **Edit.** A macro dialog window will open, where you can edit the parameters of the macro.

---

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Content Type to Display  | titles   | Available values:
|                          |          | - **titles** — Display only the title of each blog post.  
|                          |          | - **excerpts** — Display a short excerpt from each blog post. If the post contains an Excerpt macro, the Blog Posts macro will display the content defined in the Excerpt macro. If the post does not contain an Excerpt macro, the Blog Posts macro will display the first few sentences of the post.  
| Time Frame               | no limit | Specify how far back in time Confluence should look for the blog posts to be displayed.  
|                          |          | Available values:
|                          |          | - m — Minutes  
|                          |          | - h — Hours, so ’12h’ displays blog posts created in the last twelve hours.  
|                          |          | - d — Days, so ’7d’ displays blog posts created in the last seven days.  
|                          |          | - w — Weeks  

---
| **Restrict to these Labels** | None | Filter the results by label. The macro will display only the blog posts which are tagged with the label(s) you specify here.

You can specify one or more label values, separated by a comma or a space.

- To exclude content which matches a given label, put a minus sign (`-`) immediately in front of that label value. For example: If you specify a label value of `-badpage` you will get only content which is not labelled with 'badpage'.
- To indicate that the results must match a given label value, put a plus sign (`+`) immediately in front of that label value. For example: If you specify a label value of `+superpage,+goodpage` you will get only content which has at least two labels, being 'superpage' and 'goodpage'. |
| **Restrict to these Authors** | None | Filter the results by author. The macro will display only the blog posts which are written by the author(s) you specify here.

You can specify one or more authors, separated by a comma. For example: `jsmith,jbrown`

To include content from one user, but exclude from another user: `jsmith,!jbrown` |
| **Restrict to these Spaces** | @self, i.e. the space which contains the page on which the macro is coded | This parameter allows you to filter content by space. The macro will display only the pages which belong to the space(s) you specify here. You can specify one or more space keys, separated by a comma or a space.  
- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of –BADSPACE you will get only content which is not in the BADSPACE.  
- To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.) Special values:  
- @self — The current space.  
- @personal — All personal spaces.  
- @global — All site spaces.  
- @favorite — The spaces you have marked as favourite.  
- @favourite — The same as @favorite above.  
- @all — All spaces in your Confluence site.  
- * — The same as @all above.  
When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com. |
| **Maximum Number of Blog Posts** | 15 | Specify the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied. |
Sort By | creation | Specify how the results should be sorted. If this parameter is not specified, the sort order defaults to descending order (newest first) based on the creation date.

Values:
- title — Sort alphabetically by title.
- creation — Sort by the date on which the content was added.
- modified — Sort by the date on which the content was last updated.

Reverse Sort | false | Select to change the sort from descending to ascending order (oldest first). Use this parameter in conjunction with the Sort By parameter. This parameter is ignored if the Sort By parameter is not specified.

**Code examples**

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Change-History Macro**

The Change-History macro shows the history of updates made to a page: version number, author, date and comment. It displays the information inline.

**Screenshot: The Change-History macro in Confluence**

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Current Version (v. 4)</strong></td>
<td>Feb 19, 2013 16:27</td>
<td>Rach Admin: Formatting change</td>
</tr>
<tr>
<td>v. 3</td>
<td>Feb 19, 2013 16:27</td>
<td>Rach Admin: Added the change history macro</td>
</tr>
<tr>
<td>v. 2</td>
<td>Feb 19, 2013 16:26</td>
<td>Rach Admin: Added a macro</td>
</tr>
<tr>
<td>v. 1</td>
<td>Feb 19, 2013 16:25</td>
<td>Rach Admin</td>
</tr>
</tbody>
</table>

**Related pages:**
- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

**To add the Change-History macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Note: There are no parameters for this macro.

Code examples

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Chart Macro

The Chart macro allows you to display a chart based on tabular data. When you add the macro to a page, you:

- supply the data to be charted by the macro as a table in the placeholder of the macro.
- edit the macro parameters in the Macro Browser to configure the format of the chart.

Screenshot 1: A table of data in the Chart macro placeholder

<table>
<thead>
<tr>
<th>Weeks</th>
<th>Issues Burndown</th>
</tr>
</thead>
<tbody>
<tr>
<td>04/07/2011</td>
<td>81</td>
</tr>
<tr>
<td>11/07/2011</td>
<td>68</td>
</tr>
<tr>
<td>18/07/2011</td>
<td>67</td>
</tr>
<tr>
<td>25/07/2011</td>
<td>66</td>
</tr>
<tr>
<td>01/08/2011</td>
<td>65</td>
</tr>
<tr>
<td>08/08/2011</td>
<td>65</td>
</tr>
<tr>
<td>15/08/2011</td>
<td>64</td>
</tr>
<tr>
<td>22/08/2011</td>
<td>44</td>
</tr>
<tr>
<td>29/08/2011</td>
<td>24</td>
</tr>
<tr>
<td>05/09/2011</td>
<td>0</td>
</tr>
</tbody>
</table>

Screenshot 2: The resulting chart
Using the Chart Macro

To add the Chart macro to a page:

1. Edit the page and use autocomplete to add the Chart macro. (Type '{chart}'.)
2. Enter your chart data as one or more tables in the body of the macro placeholder. (See the screenshot above.)
3. Click the macro placeholder and choose Edit.
4. Select a chart type using the Type parameter (see below).
5. Choose other parameter settings in the macro browser, as described below.
6. Click Refresh in the 'Preview' area, to check that the chart appears as you expect.
7. Click Save to add the chart to your page.
8. Click Save again when you are ready to save the page.

Parameters

Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification Parameters | Colour Parameters | Axis Parameters | Pie Chart Parameters | Attachment Parameters

Chart Type Parameters
These parameters determine the type of chart to display and the way the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Type**         | pie     | The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based (see the **Time Series** parameter).  
**Standard** — pie, bar, line, area  
**XY Plots** — xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries  
**Other** — gantt |
| **Display Orientation** | vertical | Applies to area, bar and line charts.  
- **vertical** — y-axis is vertical  
- **horizontal** — x-axis is vertical |
| **Show in 3D**   | false   | Applies to area, bar and line charts. |
| **Stacked Values** | false  | Applies to area and bar charts. |
| **Show shapes**  | true    | Applies to line charts. Shapes are shown at each data point. |
| **Opacity**      |         | A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are.  
- 75 percent for 3D charts  
- 50 percent for non-stacked area charts  
- 100 percent for all other charts |

**Display Control Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Width</strong></td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td><strong>Height</strong></td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
</tbody>
</table>
| **Display rendered data** | false  | Sets whether to display the rendered body of the macro (usually the data tables). By default, the chart data table isn't rendered.  
- **before** — the data are displayed before the chart.  
- **after** — the data are displayed after the chart. |
| **Image format** | png     | The image format to be used for the chart.  
- **png**  
- **jpg**  

**Title and Label Parameters**
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart Title</td>
<td>none</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>Chart Subtitle</td>
<td>none</td>
<td>A subtitle for the chart, using a smaller font than for Title.</td>
</tr>
<tr>
<td>Horizontal-axis Label</td>
<td>none</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>Vertical-axis Label</td>
<td>none</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Show a legend or key.</td>
</tr>
</tbody>
</table>

**Data Specification Parameters**

The data for the chart is taken from tables found when the macro body is rendered. These options control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. Additional conversion options can be specified using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables</td>
<td>all first level tables</td>
<td>Comma separated list of table ids and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
</tr>
<tr>
<td>Columns</td>
<td>all columns</td>
<td>Comma separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the (html) title attribute for the column in the header row.</td>
</tr>
<tr>
<td>Content Orientation</td>
<td>horizontal</td>
<td>• <strong>vertical</strong> — data table columns will be interpreted as series.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>horizontal</strong> — data table rows will be interpreted as series.</td>
</tr>
<tr>
<td>Time Series</td>
<td>false</td>
<td>• true — the x values in an XY plot will be treated as time series data and so will be converted according to date formats.</td>
</tr>
</tbody>
</table>
### Date format

Confluence language defined date formats

For time series data, the date format allows for additional customization of the conversion of data to date values. If a Date format is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See simple date format.

### Time Period

Day

The time period for time series data. Defines the granularity of how the data is interpreted. Valid values are: Millisecond, Second, Minute, Hour, Day, Week, Month, Quarter, Year.

### Language

none

Use in combination with the Country parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages. Valid values are 2 character ISO 639-1 alpha-2 codes.

### Country

none

Use in combination with the Language parameter to form a locale. Valid values are 2 character ISO 3166 codes.

### Forgive

true

- true — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.
- false — enforce strict data format. Data format errors will cause the chart to not be produced.

### Colour Parameters

Colours are specified using hexadecimal notation or HTML colour names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background Colour</td>
<td>White</td>
<td>Background of the chart.</td>
</tr>
<tr>
<td>Border Colour</td>
<td>no border</td>
<td>Border around the chart.</td>
</tr>
<tr>
<td>Colours</td>
<td></td>
<td>Comma-separated list of colours used to customise category, sections, and series colours.</td>
</tr>
</tbody>
</table>

### Axis Parameters

Depending on the chart type, the range and domain axis may be customised. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>---------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Range Minimum Value</td>
<td>none</td>
<td>Range axis lower bound.</td>
</tr>
<tr>
<td>Range Maximum Value</td>
<td>none</td>
<td>Range axis upper bound.</td>
</tr>
<tr>
<td>Range Axis Tick Unit</td>
<td>none</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>Range Axis Label Angle</td>
<td>none</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>Domain Axis Lower Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the Date format parameter.</td>
</tr>
<tr>
<td>Domain Axis Upper Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the Date format parameter.</td>
</tr>
<tr>
<td>Domain Axis Tick Unit</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the Time Period parameter. The Time Period unit can be overridden by specifying a trailing character: y (years), M (months), d (days), h (hours), m (minutes), s (seconds), u (milliseconds).</td>
</tr>
<tr>
<td>Domain Axis Label Angle</td>
<td>none</td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
</tr>
<tr>
<td>Category Label Position</td>
<td>none</td>
<td>Placement of the axis label text for categories.</td>
</tr>
<tr>
<td>Date Tick Mark Position</td>
<td>start</td>
<td>Placement of the date tick mark.</td>
</tr>
</tbody>
</table>

**Pie Chart Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

*Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
### Pie Section Label

Show only the pie section key value

Format for how pie section labels are displayed. The format uses a string with special replacement variables:

- %0% is replaced by the pie section key.
- %1% is replaced by the pie section numeric value.
- %2% is replaced by the pie section percent value.

**Example 1:** "%0% = %1%" would display something like "Independent = 20"

**Example 2:** "%0% (%2%)" would display something like "Independent (20%)"

### Pie Section Explode

No exploded sections

Comma separated list of pie keys that are to be shown exploded.

Note: requires jFreeChart version 1.0.3 or higher.

### Attachment Parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is displayed. These options allow for the generated image to be saved as an attachment and have subsequent access re-use the attachment. This can be useful especially when combined with the Cache Plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachment</td>
<td>none</td>
<td>The name and location with which the chart image will be saved as an attachment. The user must be authorised to add attachments to the page specified.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- ^attachmentName.png — the chart is saved as an attachment to the current page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- page^attachmentName.png — the chart is saved as an attachment to the page name provided.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- space:page^attachmentName.png — the chart is saved as an attachment to the page name provided in the space indicated.</td>
</tr>
</tbody>
</table>
Attachment Version | new
--- | ---
Defines the versioning mechanism for saved charts.
- new — creates new version of the attachment.
- replace — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorized to remove attachments for the page specified.
- keep — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated.

Attachment Comment | none
--- | ---
Comment used for a saved chart attachment.

Thumbnail | false
--- | ---
- true — the chart image attachment will be shown as a thumbnail.

Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification Parameters | Colour Parameters | Axis Parameters | Pie Chart Parameters | Attachment Parameters

**Examples**

**Pie Chart**

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>pie</td>
<td></td>
</tr>
<tr>
<td>Chart Title</td>
<td>Fish Sold 2011</td>
<td>Fish Sold 2011</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Herring</td>
</tr>
<tr>
<td>Content Orientation</td>
<td>vertical</td>
<td>Herring</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Salmon</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Tuna</td>
</tr>
</tbody>
</table>

**Bar Chart**

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>pie</td>
<td></td>
</tr>
<tr>
<td>Chart Title</td>
<td>Fish Sold 2011</td>
<td>Fish Sold 2011</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Herring</td>
</tr>
<tr>
<td>Content Orientation</td>
<td>vertical</td>
<td>Salmon</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Tuna</td>
</tr>
</tbody>
</table>

Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
### 3D Bar Chart

**Parameters in Macro Browser**
- **Type**: bar
- **Show in 3D**: true
- **Opacity**: 50
- **Show Legend**: true

**Data Table in Macro Placeholder**

<table>
<thead>
<tr>
<th>Year</th>
<th>Revenue</th>
<th>Expenses</th>
</tr>
</thead>
<tbody>
<tr>
<td>2009</td>
<td>12.4</td>
<td>43.6</td>
</tr>
<tr>
<td>2010</td>
<td>31.8</td>
<td>41.8</td>
</tr>
<tr>
<td>2011</td>
<td>41.1</td>
<td>31.1</td>
</tr>
</tbody>
</table>

**Rendered Chart**

### Time Series Chart

**Parameters in Macro Browser**
- **Type**: Time Series
- **Date Format**: MM/yyyy
- **Time Period**: Month
- **Content Orientation**: vertical
- **Range Axis Lower Bound**: 0

**Data Tables in Macro Placeholder**

<table>
<thead>
<tr>
<th>Month</th>
<th>Revenue</th>
<th>Expenses</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2011</td>
<td>31.8</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2011</td>
<td>41.8</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2011</td>
<td>51.3</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2011</td>
<td>33.8</td>
<td>45.0</td>
</tr>
</tbody>
</table>

**Rendered Chart**
### XY Line Chart

#### Parameters in Macro Browser

<table>
<thead>
<tr>
<th>Type</th>
<th>xyLine</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Legend</td>
<td>true</td>
</tr>
</tbody>
</table>

#### Data Table in Macro Placeholder

<table>
<thead>
<tr>
<th>Date</th>
<th>Revenue</th>
<th>Expense</th>
</tr>
</thead>
<tbody>
<tr>
<td>5/2011</td>
<td>27.6</td>
<td></td>
</tr>
<tr>
<td>6/2011</td>
<td>49.8</td>
<td></td>
</tr>
<tr>
<td>7/2011</td>
<td>51.8</td>
<td></td>
</tr>
<tr>
<td>8/2011</td>
<td>77.3</td>
<td></td>
</tr>
<tr>
<td>9/2011</td>
<td>73.8</td>
<td></td>
</tr>
<tr>
<td>10/2011</td>
<td>97.6</td>
<td></td>
</tr>
<tr>
<td>11/2011</td>
<td>101.2</td>
<td></td>
</tr>
<tr>
<td>12/2011</td>
<td>113.7</td>
<td></td>
</tr>
</tbody>
</table>

#### Rendered Chart

![XY Line Chart](chart_url)

### XY Area Chart

#### Parameters in Macro Browser

<table>
<thead>
<tr>
<th>Type</th>
<th>xyArea</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Legend</td>
<td>true</td>
</tr>
</tbody>
</table>

#### Data Table in Macro Placeholder

<table>
<thead>
<tr>
<th>Date</th>
<th>Revenue</th>
<th>Expense</th>
</tr>
</thead>
<tbody>
<tr>
<td>5/2011</td>
<td>44.6</td>
<td></td>
</tr>
<tr>
<td>6/2011</td>
<td>43.8</td>
<td></td>
</tr>
<tr>
<td>7/2011</td>
<td>51.8</td>
<td></td>
</tr>
<tr>
<td>8/2011</td>
<td>52.3</td>
<td></td>
</tr>
<tr>
<td>9/2011</td>
<td>53.8</td>
<td></td>
</tr>
<tr>
<td>10/2011</td>
<td>55.6</td>
<td></td>
</tr>
<tr>
<td>11/2011</td>
<td>61.2</td>
<td></td>
</tr>
<tr>
<td>12/2011</td>
<td>63.7</td>
<td></td>
</tr>
</tbody>
</table>

#### Rendered Chart

![XY Area Chart](chart_url)
### Area Charts

#### Example 1

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>area</td>
<td></td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Opacity</td>
<td>50</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Satisfaction</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>2009</strong></td>
<td><strong>2010</strong></td>
</tr>
<tr>
<td></td>
<td>Very satisfied</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>Satisfied</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td>Dissatisfied</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td>Very dissatisfied</td>
<td>15</td>
</tr>
</tbody>
</table>

#### Example 2

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Cheese Macro**

The Cheese macro simply displays the words "I like cheese!" You can use this macro to test the Confluence macro functionality. 😊

**To add the Cheese macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Note:** There are no parameters for this macro.

**Related pages:**

- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- How to Make Gorgonzola Cheese
- Confluence User's Guide

**Children Display Macro**

Use the Children Display macro to list the child pages of a page and the further descendants (children's
children). By default, the macro displays links to the child pages as shown in the screenshot below. People viewing the page will see only the links for pages that they have permission to view.

Screenshot: The Children Display macro in Confluence

<table>
<thead>
<tr>
<th>This is the Children Display macro</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Step 1 - download the game</td>
</tr>
<tr>
<td>• Step 2 - Play</td>
</tr>
<tr>
<td>• Step 3 - share your favourite nerd</td>
</tr>
<tr>
<td>• Sample page</td>
</tr>
<tr>
<td>• Games as a communication medium</td>
</tr>
</tbody>
</table>

On this page:
- Using the Children Display macro
- Example
- Parameters
- Code examples

Related pages:
- Working with Pages
- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

Using the Children Display macro

To add the Children Display macro to a page:
1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Example

This list of child pages is generated by a Children Display macro on this page:

- Child Page 1
- Child Page 2

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
| **Show Descendants** | false | Choose whether to display all the parent page's descendants.
- If true shows the complete tree of pages underneath the parent page, regardless of **Depth of Descendants** |
| **Parent Page** | current | Specify the page to display children for, from either the current space or a different space. Enter:
- '/ ' — to list the top-level pages of the current space, i.e. those without parents.
- 'pagename' — to list the children of the specified page.
- 'spacekey:' — to list the top-level pages of the specified space.
- 'spacekey:pagename' — to list the children of the specified page in the specified space. |
| **Number of Children** | none | Restrict the number of child pages that are displayed at the top level. |
| **Depth of Descendants** | none | Enter a number to specify the depth of descendants to display. This setting has no effect of **Show Descendants** is enabled. |
| **Heading Style** | none | Choose the style used to display descendants. |
| **Include Excerpts** | false | Display excerpts for the child pages, if they exist. |
| **Sort Children By** | Manual if manually ordered, otherwise alphabetical | Optional. Choose:
- **creation** — to sort by content creation date
- **title** — to sort alphabetically on title
- **modified** — to sort of last modification date. |
| **Reverse Sort** | false | Use with the **Sort Children By** parameter. When set, the sort order changes from ascending to descending. |

**Code examples**

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Child Page 1**

**Grandchild**

**Child Page 2**

This page is used to test the {children} macro.
The Code Block macro allows you to display source code in your document with the appropriate syntax highlighting. The code block displays on the page as shown below:

```java
public static void main(String[] args) {
    System.out.println("Hello World!");
}
```

### On this page:
- Using the Code Block Macro
- Parameters
- Configuring the Code Block macro
- Code examples

### Related pages:
- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

#### Using the Code Block Macro

To add the Code Block macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

You type the code block directly into the macro placeholder in the editor. Note that any white space contained in the placeholder is not manipulated in any way by the Code Block macro. This is to provide the writer with flexibility over code indentation.

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
| Syntax highlighting | java | Specifies the language (or environment) for syntax highlighting. The default language is Java but you can choose from one of the following languages/environments:  
- actionscript3  
- bash  
- csharp (C#)  
- coldfusion  
- cpp (C++)  
- css  
- delphi  
- diff  
- erlang  
- groovy  
- html/xml  
- java  
- javeafx  
- javascript  
- none (no syntax highlighting)  
- perl  
- php  
- powershell  
- python  
- ruby  
- scala  
- sql  
- vb |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>none</td>
<td>Adds a title to the code block. If specified, the title will be displayed in a header row at the top of the code block.</td>
</tr>
<tr>
<td>Collapsible</td>
<td>false</td>
<td>If selected, the code macro’s content will be collapsed upon visiting or refreshing the Confluence page. Clicking the <strong>exp and source</strong> link allows you to view this content. If false, the code macro’s content is always displayed in full.</td>
</tr>
<tr>
<td>Show line numbers</td>
<td>false</td>
<td>If selected, line numbers will be shown to the left of the lines of code.</td>
</tr>
<tr>
<td>First line number</td>
<td>1</td>
<td>When <strong>Show line numbers</strong> is selected, this value defines the number of the first line of code.</td>
</tr>
</tbody>
</table>
### Theme

<table>
<thead>
<tr>
<th>Theme</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specifies the colour scheme used for displaying your code block. Many of these themes are based on the default colour schemes of popular integrated development environments (IDEs). The default theme is <strong>Confluence</strong> (also known as <strong>Default</strong>), which is typically black and coloured text on a blank background. However, you can also choose from one of the following other popular themes:</td>
<td></td>
</tr>
<tr>
<td>DJango</td>
<td></td>
</tr>
<tr>
<td>Emacs</td>
<td></td>
</tr>
<tr>
<td>FadeToGrey</td>
<td></td>
</tr>
<tr>
<td>Midnight</td>
<td></td>
</tr>
<tr>
<td>RDark</td>
<td></td>
</tr>
<tr>
<td>Eclipse</td>
<td></td>
</tr>
<tr>
<td>Confluence</td>
<td></td>
</tr>
</tbody>
</table>

**Configuring the Code Block macro**

You can configure the Code Block macro to use a specific language and theme by default and also upload new languages. You need **Confluence Administrator** permissions to change the default theme and language and **System Administrator** permissions to upload new languages.

**To set the default appearance of code blocks in your site:**

1. Choose the cog icon at top right of the screen, then choose **Confluence Admin**.
2. Choose **Configure Code Macro**.
3. Select a **Default Theme** and **Default Language**.
4. Choose **Save**.

All new code blocks will use the default theme and language unless you specify otherwise. Existing code blocks will be unchanged.

**To add an additional language:**

1. Choose the cog icon at top right of the screen, then choose **Confluence Admin**.
2. Choose **Configure Code Macro**.
3. Choose **Add a new language**.
4. Locate your language file and enter a **Name** for the new language (this will appear when selecting the language).
5. Choose **Add**.

Language files must be correctly formatted JavaScript files and adhere to the **Custom Brush syntax**. You can find some examples of language files [here](#).

**To disable or remove a user-installed language:**

1. Choose the cog icon at top right of the screen, then choose **Confluence Admin**.
2. Choose **Manage Add-ons**.
3. Go to **User-installed Add-ons** and locate the add-on for your uploaded language - it will appear like this ‘Custom Code Macro Highlighting for...’
4. Choose **Uninstall** or **Disable**.

The language will no longer appear in the Code Macro.

**Code examples**

See:
Confluence Wiki Markup for Macros  
Confluence Storage Format for Macros  
Using the Code Block Macro  
Parameters  
Configuring the Code Block macro  
Code examples

Column Macro
Used with the Section macro to define columns on a page. See Working with page layouts and columns and sections.

Content by Label Macro
The Content by Label macro displays links to pages, blog posts and attachments that have been tagged with specific labels.

A working example
Below is a working example of the Content by Label macro, displaying content with the label 'LDAP'.

- Testing LDAP Connection using JXplorer (Atlassian Development)  
- InvalidSearchFilterException: Empty filter when Synchronising LDAP (JIRA Knowledge Base)  
- Issues associated to users deleted from LDAP or crowd can not be reassociated to a different user (JIRA Knowledge Base)  
- Customising atlassianUserContext.xml (Confluence 2.7)  
- Customising atlassian-user.xml (Confluence 2.8)

Showing first 5 of 856 results

On this page:
- A working example  
- Using the Content by Label Macro  
- Parameters  
- Code examples

Related pages:
- Related Labels Macro  
- Navigation Map Macro  
- Recently Used Labels Macro  
- Working with Confluence Labels  
- Working with Macros  
- Confluence Wiki Markup for Macros  
- Confluence Storage Format for Macros  
- Confluence User's Guide

Using the Content by Label Macro

To add the Content by Label macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.  
2. Find and select the required macro.
Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label(s)</td>
<td>None</td>
<td>Filter by label(s). The macro will display only the content tagged with the label(s) specified here. See also the Operator parameter below. This parameter is required. Specify one or more labels, separated by a comma or a single space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of <code>-badpage</code> you will get only content which is not labelled with 'badpage'.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of <code>+superpage,+goodpage</code> you will get only content which has at least two labels, being 'superpage' and 'goodpage'.</td>
</tr>
<tr>
<td>Author(s)</td>
<td>None</td>
<td>Filter by author. The macro will display only the content created or updated by the author(s) specified here. Specify one or more authors, separated by a comma. For example: jsmith, jbrown</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To include content from one user, but exclude from another user: jsmith,!jbrown</td>
</tr>
<tr>
<td>Include this Content Type Only</td>
<td>all</td>
<td>Filter by content type. The macro will display only the content of the type specified here. Specify one or more content types, separated by a comma or a space. To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of <code>-blogpost</code> you will get pages and all other content except for blog posts. Available values:</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----</td>
<td>---</td>
</tr>
<tr>
<td><code>page</code> – <strong>Pages</strong>.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>blogpost</code> or <code>news</code> – <strong>Blog posts</strong>, also known as news items.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>attachment</code> – <strong>Attachments</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Labels for Each Page</td>
<td>true</td>
<td>Show or hide labels in the results.</td>
</tr>
<tr>
<td>Show Space Name for Each Page</td>
<td>true</td>
<td>Show or hide spaces in the results.</td>
</tr>
<tr>
<td>List Title</td>
<td>None</td>
<td>Add a title or heading to the list.</td>
</tr>
<tr>
<td>Maximum Number of Pages</td>
<td>15</td>
<td>Limit the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied.</td>
</tr>
<tr>
<td>Display Excerpts</td>
<td>false</td>
<td>Include excerpts from each page listed. Note that you must have defined excerpts on each of those pages, by adding the <code>excerpt</code> macro to the page. Only the first few lines of the excerpt for each page are displayed.</td>
</tr>
<tr>
<td>Restrict to these Spaces</td>
<td>@all</td>
<td></td>
</tr>
<tr>
<td>--------------------------</td>
<td>------</td>
<td></td>
</tr>
</tbody>
</table>

Filter by space. The macro will display only the content which belongs to the space(s) specified here.

Specify one or more space keys, separated by a comma or a space.

- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.
- To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:

- @self — The current space.
- @personal — All personal spaces.
- @global — All site spaces.
- @favorite — The spaces you have marked as favourite.
- @favourite — The same as @favorite.
- @all — All spaces in your Confluence site.
- * — The same as @all above.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.
| **Operator** | **OR** | The operator to apply when matching content against the labels specified in the **Label(s)** parameter:  
- **OR** — Display content with *any* of the non-prefixed labels.  
- **AND** — Display content with *all* of the specified non-prefixed labels.  
  
  Note that this parameter only modifies the behaviour of the **Label(s)** parameter and only affects label values without a plus (+) or minus (-) sign prefix. |
| **Sort By** | **modified** | Specify how the results should be sorted.  
**Values:**  
- **title** — Sort alphabetically by title.  
- **creation** — Sort by the date on which the content was added.  
- **modified** — Sort by the date on which the content was last updated.  
  
  Note: If this parameter is not specified, the sort order defaults to descending, based on the last modification date (latest first). To change the sort order from ascending to descending, use the **Reverse Sort** parameter. |
| **Reverse Sort** | **false** | Select **Reverse Sort** to change the sort from descending to ascending. Use this parameter in conjunction with the **Sort By** parameter. **Reverse Sort** is ignored if **Sort By** is not specified. |

**Code examples**

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Content by User Macro**

The Content by User macro generates a tabulated list of the content items, throughout the Confluence installation, that have been created by a specified Confluence user. The list includes all current pages, comments and spaces created by the user. Each item in the table is linked to its corresponding page, page comment or space dashboard.

Note that items for page comments contain a link to the page, followed by a second link to the comment itself, with these separated by a greater-than sign (>).

**Using the Content by User macro**
To add the Content by User macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### On this page:
- Using the Content by User macro
- Parameters
- Code examples

### Related pages:
- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

#### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>none</td>
<td>The Confluence username for a person who has created content.</td>
</tr>
</tbody>
</table>

#### Code examples

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Content Report Table Macro**

The Content Report Table macro displays a set of pages and blog posts in tabular format, based on the labels specified in the macro parameters.

**A working example**

Below is a working example of the Content Report Table macro, displaying content with the label 'LDAP'.

<table>
<thead>
<tr>
<th>Title</th>
<th>Creator</th>
<th>Modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diagrams of Possible Configurations for User</td>
<td>Sarah Maddox [Atlassian]</td>
<td>Sep 25, 2013</td>
</tr>
</tbody>
</table>
Using the Content Report Table Macro

To add the Content Report Table macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

On this page:

- A working example
- Using the Content Report Table Macro
- Parameters
- Code examples

Related pages:

- Related Labels Macro
- Content by Label Macro
- Working with Confluence Labels
- Working with Macros
- Confluence Storage Format for Macros
- Confluence User’s Guide
Label(s) | None | This parameter is required. Specify one or more labels, separated by a comma. The macro will display the content tagged with any of the label(s) specified here.

For example, if you specify labels 'A' and 'B', the macro will display all pages that have the label 'A', and all pages that have the label 'B', and all pages that have both those labels.

Space(s) | (All spaces) | Specify one or more space keys, separated by a comma or a space. The macro will display only the content which belongs to the space(s) specified here.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.

Maximum Number of Pages | 20 | Define the maximum number of pages that the macro will show in a single set of results. If there are more pages to be shown, the macro will display a link labelled 'Find more results'. People viewing the page can choose the link to go to a search view, which shows all pages tagged with the specified label(s).

Which pages will appear? Before displaying the results, Confluence will sort them by the date the page was last modified. The most-recently created/updated pages will appear first.

**Code examples**

See Confluence Storage Format for Macros.

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

**Contributors Macro**

The Contributors macro displays a list of Confluence users who have made a contribution of some type to a page. It can also be used to list watchers of the page.

The scope of this macro can be extended to include the immediate children or descendants of the specified page. The list of contributors can be based on people who have:

- authored or edited the page(s)
- contributed comments or added labels to the page(s), or
- are simply watching the page(s).

**Screenshot: Example list of Contributors**
Using the Contributors Macro

To add the Contributors macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contribution Type</td>
<td>authors</td>
<td>Filters by either the type of contribution made to a page (and optionally its descendant pages), or the watches on the page. Contribution types are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- authors - includes people who created or have edited the page(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- comments - includes people who have added comments to the page(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- labels - includes people who have added labels to the page(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- watches - includes people who are watching the page(s).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can specify one or more contribution types, separated by commas.</td>
</tr>
<tr>
<td>Sort By</td>
<td>count</td>
<td>Specifies the criteria used to sort contributors. Sort criteria are:</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------</td>
<td>---------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>count</strong> - sorts people based on the total number of contributions to the page(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>name</strong> - sorts people into alphabetical order</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>update</strong> - sorts people based on the date of their last contribution to the page(s).</td>
</tr>
</tbody>
</table>

| Reverse Sort         | false | Reverses the sort order of contributors in the list. Must be used in conjunction with the **Sort By** parameter. |

| Maximum Number of Contributors | no limit | Limits the number of contributors in the list. If a number is not specified, all contributors are included. |

| Display Format        | inline | Sets how the list of contributor's names is formatted: |
|                      |       | • **inline** — a comma-separated list |
|                      |       | • **list** — a bullet list. |

| Show Anonymous Contributions? | false | Sets whether to include those who contributed anonymously to a page. |

| Show Count?           | false | Sets whether to show the number of times each person made a contribution of the specified **Contribution Type**. |

| Show Last Contribution Time? | false | Sets whether to show the last time each person made a contribution of the specified **Contribution Type**. |

| Page Name             | current | Specifies the page to use when generating the list of contributors. If **Page Name** and **Space(s)** are left blank, the current page is assumed. |

| Label(s)              | none   | Filters the list of contributors to those who created the specified labels from a page. You can specify one or more labels, separated by commas. |
Space(s) current

Specifies the space key of the Confluence space that contains the page set in Page Name or alternatively, specifies the spaces to search. Space keys are case-sensitive.

This parameter also takes special values, including:

- @global — All site spaces.
- @personal — All personal spaces.
- @all — All spaces in your Confluence site.

You can specify one or more space keys or special values, separated by commas.

If no Page Name and Label(s) are specified, all pages from the specified set of spaces are included.

Content Type both pages and blog posts

Restricts the content type to use when generating the list of contributors:

- pages — pages
- blogposts — blog posts.

Blog Post Date none

Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD.

Include Page Hierarchy specified page only

Specifies additional pages to include when generating the list of contributors:

- children — just the child pages of the specified page
- descendants — all descendants of the specified page.

Show Selected Pages false

Sets whether to show a list of the pages used to generate the list of contributors.

Custom "None Found" Message default message

Specifies the message to be used to override the default message that is displayed when no contributors are found.

Code examples

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

The Contributors Summary macro displays a table of contribution-based statistics for a set of pages. These
statistics can be grouped according to individual pages or individual contributors.

The default scope for this macro is an individual page, but this can be extended to include the immediate children or descendants of a specified page. The statistics cover the following types of contributions:

- edits to the page(s)
- comments added to the page(s)
- labels added to the page(s)
- people watching the page(s)

A simple example of the Contributors Summary macro is shown in the screenshot below. It lists statistics for the number of times each contributor has edited, added comments and added labels to this page.

**Screenshot: Example Contributors Summary table of statistics**

<table>
<thead>
<tr>
<th>User</th>
<th>Edits</th>
<th>Comments</th>
<th>Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sarah Maddox</td>
<td>2</td>
<td>2</td>
<td>0</td>
</tr>
<tr>
<td>Edwin Dawson</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Giles Gaskell</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Rosie Jameson</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Andrew Lui</td>
<td>2</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>Charles Miller</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Andrew Prentice</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
</tbody>
</table>

In this example, all default parameter settings are used. For more information about this macro's parameters, refer to the **Parameters** section below.

**Using the Contributors Summary Macro**

**To add the Contributors Summary macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Group By** | contributors | Specifies the basis for grouping contribution-based statistics:  
  - **contributors** — group by the people who have contributed  
  - **pages** — group by the pages used to find contributors. |
| Columns to Display | edits, comments, labels | Sets the columns that should appear in the table. The statistics or type of information presented depends on the basis for grouping set with the **Group By** parameter. Statistics may be calculated for:

- *edits* — the number of times each contributor has edited the page(s) or the number of edits made to each page.
- *edited* — a list of the pages edited by each contributor or a list of contributors who have edited each page.
- *comments* — the number of times each contributor has added comments to the page(s) or the number of comments on each page.
- *commented* — a list of pages to which each contributor has added comments or a list of contributors who have commented on each page.
- *labels* — the number of times each contributor has added labels to the page(s) or the number of labels on each page.
- *labeled* — a list of pages to which each contributor has added labels or a list of contributors who have added a label to each page.
- *labellist* — a list of labels either added by each contributor or on each page.
- *watches* — the number of pages being watched by each contributor/person or the number of contributors/people watching each page.
- *watching* — a list of pages being watched by each contributor/person or a list of contributors/people watching each page.
- *lastupdate* — the last time each contributor made an update or when each page was last updated. Valid updates can include edit, comment or label modifications to a page.

One or more columns can be used.
| **Sort By**       | edits           | Sets the criterion used for sorting items in the table. The items sorted depend on the basis for grouping set with the **Group By** parameter. Sort criteria are:  
|                  |                 | - **edits** — sorts items in the table based on the total number of edits made, either by a contributor or to a page.  
|                  |                 | - **name** — sorts items in the table in alphabetical order, either by contributor or page name.  
|                  |                 | - **editTime** — sorts items in the table based on when the contributor last edited a page (or a specified set of pages) or when the page was last edited.  
|                  |                 | - **update** — sorts items in the table based on when the contributor last made any contribution to a page (or a specified set of pages) or when the page last had any contribution made to it.  
| **Reverse Sort** | false           | Reverses the sort order of items in the table, as specified using the **Sort By** parameter. (Used only in conjunction with the **Sort By** parameter.)  
| **Maximum Number of Items** | no limit | Limits the number of contributors or pages in the table to the value specified. If no number is specified, all items are included.  
| **Show Anonymous Contributions?** | false | Includes individuals who have made anonymous contributions to a page.  
| **Show Zero Counts?** | false | Sets whether contributors or pages are included for which a calculated statistic is zero.  
| **Page Name** | current | Sets the page for which to calculate the contribution-based statistics. If no values for **Page Name** and **Space(s)** are specified, the current page is assumed.  
| **Label(s)** | none | Restricts the contribution-based statistics to the specified labels only. You can specify one or more labels, separated by commas.  |
Space(s) | current |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Specifies the space key of the Confluence space which contains the specified page name or alternatively, specifies a scope of spaces to search. Space keys are case-sensitive.</td>
<td></td>
</tr>
<tr>
<td>This parameter also takes special values, including:</td>
<td></td>
</tr>
<tr>
<td>• @global — All site spaces.</td>
<td></td>
</tr>
<tr>
<td>• @personal — All personal spaces.</td>
<td></td>
</tr>
<tr>
<td>• @all — All spaces in your Confluence site.</td>
<td></td>
</tr>
<tr>
<td>You can specify one or more space keys or special values, separated by commas.</td>
<td></td>
</tr>
<tr>
<td>If no Page Name and Label(s) are specified, all pages from the specified set of spaces are included.</td>
<td></td>
</tr>
</tbody>
</table>

Content Type | both pages and blog posts |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Restricts page types to either pages (pages) or blog posts (blog posts). If no value is specified in the Macro Browser, both pages and blog posts are included.</td>
<td></td>
</tr>
</tbody>
</table>

Blog Post Date | none |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD.</td>
<td></td>
</tr>
</tbody>
</table>

Include Page Hierarchy | specified page only |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Includes either the immediate children or all descendants of the specified page. If no value is indicated in the Macro Browser, only the specified page is included.</td>
<td></td>
</tr>
</tbody>
</table>

**Code examples**

See:

- [Confluence Wiki Markup for Macros](#)
- [Confluence Storage Format for Macros](#)

**Create from Template Macro**

The Create from Template macro displays a button on a page, linked to a specific template. When someone clicks the button, the macro opens the editor, ready to add a new page, and adds content to the page based on the given template.

When adding the macro to the page, you can specify a blueprint or a user-created template in the macro. You will also specify the name of the button displayed, and the space in which the new page will appear.
## Example

**Screenshot:** A page with three buttons, all displayed by the 'Create from Template' macro

### Using the Create from Template Macro

**To add the Create from Template macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Button Text</td>
<td>‘Create from Template’</td>
<td>The description that people will see when viewing this macro on the page.</td>
</tr>
<tr>
<td>Template Name</td>
<td>None</td>
<td>Select the template or blueprint to base the new page on. Only global and user-created templates for the current space appear (unless you have specified a different space in the 'Space Key' field).</td>
</tr>
<tr>
<td>Template Title</td>
<td>Blank</td>
<td>Specify a default title for pages created using this macro (optional). You can include @currentDate, @spaceName and @spaceKey variables in the title.</td>
</tr>
</tbody>
</table>
Space Key | The space where the current page is located | Supply the unique space identifier (space key), to determine where the new page will be created when someone uses this macro to create a page.

**Code examples**

See:

- Confluence Storage Format for Macros
- Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

**Create Space Button Macro**

The Create Space Button macro displays a create space icon that links to the ‘Create Space’ page. To see this icon, viewers need the ‘Create Space’ permission which is assigned by a site administrator.

**Screenshot: The ‘create space’ button in Confluence**

**Using the Create Space Button macro**

To add the Create Space Button macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

<table>
<thead>
<tr>
<th>On this page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>- Using the Create Space Button macro</td>
</tr>
<tr>
<td>- Parameters</td>
</tr>
<tr>
<td>- Code examples</td>
</tr>
</tbody>
</table>

**Related pages:**

- Creating a Space
- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Icon Size</td>
<td>large</td>
<td>Specify whether to use large or small icon. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- large</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- small</td>
</tr>
</tbody>
</table>

**Code examples**
See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Excerpt Include Macro

The Excerpt Include macro is used to display ‘excerpted’ (that is, a segment of) content from one page in another.

Before you can use this macro, the excerpt must have been defined using the Excerpt macro. Note that you can have more than one Excerpt Include macro on a page (although you can have only one Excerpt macro on a page).

Example

The paragraph below shows an example of an Excerpt Include macro, containing content from an excerpt which we have defined on the Excerpt Macro page. On the Excerpt Include macro below, we have set the options to show both the title of the page and the panel surrounding the content.

<table>
<thead>
<tr>
<th>Excerpt Macro</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define a part of a page as the page's 'excerpt' which can then be displayed in another page.</td>
</tr>
</tbody>
</table>

On this page:
- Example
- Using the Excerpt Include Macro
- Parameters
- Code examples

Related pages:
- Excerpt Macro
- Page Properties Macro
- Working with Macros
- Confluence Storage Format for Macros
- Confluence Wiki Markup for Macros
- Confluence User's Guide

Using the Excerpt Include Macro

To add the Excerpt Include macro to a page:
1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
**Code examples**

See:

- Confluence Storage Format for Macros
- Confluence Wiki Markup for Macros

**Excerpt Macro**

The Excerpt macro is used to mark a part of a page’s content for re-use. Defining an excerpt enables other macros, such as the **Excerpt Include** and **Blog Posts** macros, to display the marked content elsewhere.

You can only define one excerpt per page. In other words, you can only add the Excerpt macro once to a page.

**On this page:**

- Using the Excerpt Macro
- Parameters
- Code examples

**Related pages:**

- Excerpt Include Macro
- Working with Macros
- Confluence Storage Format for Macros
- Confluence Wiki Markup for Macros
- Confluence User’s Guide

**Using the Excerpt Macro**

**To add the Excerpt macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.
**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**To add reusable content to the macro:**
1. Add your content inside the Excerpt macro placeholder.
2. Choose the macro placeholder to see the options panel, and select the option to **Display on new line** or **to Display inline**. The default is to display the content of the macro on a new line. If you choose the inline option, the content of the macro will form part of the same paragraph as the text preceding and following it. Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused.

**Screenshot: The Excerpt macro placeholder and options panel**

![Excerpt Macro Screenshot](image)

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Excerpted Content</td>
<td>false</td>
<td>Controls whether the page content contained in the Excerpt macro placeholder is displayed on the page.</td>
</tr>
</tbody>
</table>

**Code examples**

See:
- Confluence Storage Format for Macros
- Confluence Wiki Markup for Macros

**Expand Macro**

The Expand macro displays an expandable/collapsible section of text on your page.

Here is an example:

> Click here to expand...

This text is hidden until you expand the section.

**Using the Expand Macro**

**To insert the Expand macro into a page using the macro browser:**
1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.
To edit an existing macro: Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### On this page:
- Using the Expand Macro
- Parameters
- Code examples
- Notes

### Related pages:
- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Click here to expand...</td>
<td>Defines the text that appears next to the expand/collapse icon.</td>
</tr>
</tbody>
</table>

### Code examples

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

### Notes

- **Text is expanded in PDF and HTML exports.** When you export the page to PDF or HTML, the text between the macro tags is expanded so that readers can see it in the PDF and HTML versions of the page.
- **Nesting your Expand macros.** You can put one Expand macro inside another, and Confluence will correctly show and hide the contents of all Expand macros, including the nested ones.

#### Favourite Pages Macro

Use the Favourite Pages macro to display a list of your favourite pages.

The output of the Favourite Pages macro appears as in the following screenshot.

**Screenshot: The Favourite Pages Macro in Confluence**

<table>
<thead>
<tr>
<th>This is the Favourite Pages macro</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Favourite Pages</strong></td>
</tr>
<tr>
<td>Displaying pages recently added to your favourites list.</td>
</tr>
<tr>
<td>- Why I loved Angry Nerds (Angry Nerds) ★★★</td>
</tr>
<tr>
<td>- Which nerd are you? (Angry Nerds) ★★★</td>
</tr>
<tr>
<td>- Our new logo (Angry Nerds) ★★★</td>
</tr>
</tbody>
</table>
Using the Favourite Pages Macro

To insert the favourite pages macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

There are no parameters for this macro.

Code examples

See:

- Confluence Storage Format for Macros
- Confluence Wiki Markup for Macros

Gadget Macro

Gadgets are small applications that can offer dynamic content. They are typically served from a web application server and can be re-used in many other web applications. In Confluence, use the Gadget macro to add gadgets to pages or blog posts.

Confluence comes bundled with a few of its own gadgets that you can add to your pages or blog posts. The Confluence gadgets are listed in Confluence Gadgets. However, you can access additional gadgets in this list if your Confluence Administrator has:

- Installed additional gadgets in Confluence (typically as a Confluence plugin) or
- Registered gadgets served from an external web application or website (such as those from a JIRA installation or iGoogle).

Unlike other macros, the name of each gadget macro is unique and follows the convention "<gadget-name>macro", where `<gadget-name>` is the name supplied by the gadget itself.
Inserting gadgets into a Confluence page or blog post

To add a gadget to a page:

1. Edit your page or blog post.
2. Choose Insert > Other Macros.
3. Click External Content to see a list of gadgets configured for use in your Confluence installation.
   (Some Confluence macros like the JIRA Issues, RSS Feed, Tasklist and Widget Connector macros also appear in this category because they can also access external content.)
4. Click the desired gadget to access its parameters and properties.
   Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the macro dialog. Each gadget may also have its own set of parameters, which appear on the left of the macro dialog.
5. Set the parameters to your requirements.
6. Click Refresh to preview your changes.
7. Click Insert to add the gadget to the page.

Editing gadgets on a Confluence page or blog post

To edit an existing gadget on a page or blog post:

1. Edit your page or blog post.
2. Click the Gadget macro placeholder and choose Edit (or double-click the placeholder).
3. Set the gadget's parameters to your requirements.
4. Click Refresh to preview your changes.
5. Save the gadget.

Standard gadget parameters

Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the macro dialog. Each gadget may also have its own set of parameters, which appear on the left of the macro dialog.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Related pages:
- The big list of Atlassian gadgets
- Confluence Storage Format for Macros
- Confluence Wiki Markup for Macros
- Confluence User's Guide
Contents of a Gadget macro

In the addition to the standard parameters, the gadget macro contains 'parameter-like' content, which represents specific property settings that are particular to each gadget. Hence they are not documented here. Typically, this content would only be changed by customising the gadget's default properties using the macro browser.

Code examples

See:

- Confluence Storage Format for Macros
- Confluence Wiki Markup for Macros

Gallery Macro

The Gallery macro displays a collection of thumbnail images in a table, based on the images attached to a Confluence page. When viewing the page, a user can click a thumbnail image to zoom into a screen-sized image and then view the images as a slide show.

Overview:

- The images shown in the gallery are taken from the files attached to the Confluence page. You can also specify a different page where the attachments are located. For information about attaching images to a page, see Attaching Files to a Page.
- The captions below the images are drawn from the comments on the attachments. For information about adding comments to attachments, see Attaching Files to a Page.
- By default, the gallery will include all the images attached to the page. You can also exclude or include images using parameters.
- You can sort your images into a particular order.
- You can specify a title for the gallery and also configure how many columns you want for the table in which your images are displayed.
Using the Gallery macro

To insert the Gallery macro onto a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.
To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

The full list of parameters is shown in the following table. If the name of an attached file or page contains a comma, you can refer to it in the relevant parameters below by enclosing it in single or double quotes, for example "this,that.jpg", theother.png

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gallery Title</td>
<td>Nothing</td>
<td>Specify a title for your gallery.</td>
</tr>
<tr>
<td>Number of Columns</td>
<td>4</td>
<td>Specify the number of columns for your table.</td>
</tr>
<tr>
<td>Images to Exclude</td>
<td>No exclusions. Include all the pictures on the page.</td>
<td>The gallery will ignore any pictures specified. You can specify more than one picture, separated by commas. Note: The filename and filetype for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
<tr>
<td>Include these Images Only</td>
<td>Include all the pictures on the page.</td>
<td>If you specifically include one or more pictures, the gallery will show only those pictures. You can specify more than one picture, separated by commas. Note: The filename and filetype for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
<tr>
<td>Exclude Images with these Labels</td>
<td>No exclusions. Include all the pictures on the page.</td>
<td>The gallery will ignore any pictures that have the specified label. You can specify more than one label, separated by commas. For information on labelling the attachments, see Adding Labels.</td>
</tr>
<tr>
<td>Include Images with these Labels Only</td>
<td>None. The images are not filtered by label.</td>
<td>Filters the images to display, based on a list of labels. If you wish to enter more than one label, separate the labels with commas. Confluence will show only images that have all the labels specified. (The match is an AND, not an OR.) For information on labelling the attachments, see Adding Labels.</td>
</tr>
<tr>
<td>Use Images in these Pages</td>
<td>If no page is specified, the gallery macro displays the images attached to the page on which the macro is used.</td>
<td>Specify the title of the page which contains the images you want displayed. You can specify more than one page name, separated by commas. To specify a page in a different space, use the following syntax: SPACEKEY:Page Title</td>
</tr>
</tbody>
</table>
Sort Images By

None. The sort order is unspecified and therefore unpredictable.

Specify an attribute to sort the images by. Sort order is ascending, unless you select the Reverse Sort parameter (see below). Options are:

- **name** – file name.
- **comment** – comment linked to the attached file.
- **date** – date/time last modified.
- **size** – size of the attached file.

Reverse Sort

Off. Sort order is ascending

Used in combination with the Sort Images By parameter above. Use Reverse Sort to reverse the sort order, from ascending to descending.

**Image file formats**

You can attach image files of any format to a page. Confluence supports the following image formats in the Gallery macro and when displaying an image on a page:

- gif
- jpeg
- png
- bmp (depending on browser support)

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Global Reports Macro

The Global Reports macro displays a list of links to some reports about content on your site. These reports include a list of new or updated pages, orphan pages, undefined pages, and RSS feeds for new pages and blog posts.

**Screenshot: The Global Reports macro**

This is the Global Reports macro

---

Global Reports

- New or updated pages since your last login.
- Find all pages that aren't linked from anywhere.
- Find all undefined pages.
- RSS Feed for new pages and blogs.

Related pages:

- Subscribing to RSS Feeds within Confluence
- Working with Macros
- Confluence User's Guide.

---

Using the Global Reports Macro

To add the Global Reports macro to a page:
In the Confluence editor, choose **Insert > Other Macros**.

2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width of Table</td>
<td>99%</td>
<td>Specify the width of the table in which the links are displayed, as a percentage of the window width.</td>
</tr>
</tbody>
</table>

**Code examples**

See:

- [Confluence Wiki Markup for Macros](#)
- [Confluence Storage Format for Macros](#)

**HTML Include Macro**

The HTML Include macro allows you to include the contents of an external HTML file in a Confluence page.

**CAUTION: Including unknown HTML inside a webpage is dangerous.**

HTML can contain active scripting components. This means that it would be possible for a malicious attacker to present a user of your site with script that their web browser would believe came from you. Such code could be used, for example, to steal a user’s authentication cookie and give the attacker their Confluence login password.

**Using the HTML Include Macro**

**To insert the HTML Include macro into a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Related pages:**

- [HTML Macro](#)
- [Working with Macros](#)
- [Configuring the Whitelist](#)
- [Confluence User's Guide](#)

**The information on this page does not apply to Confluence OnDemand.**

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

---

*The image of this page does not apply to Confluence OnDemand.*
HTML Page’s URL | None | The URL of the page to include.

Troubleshooting
- The HTML Include macro will only be available if it has been enabled by your Confluence administrator. Also, your Confluence Administrator can define a whitelist of trusted URLs. You will see an error message on the Confluence page if the included URL is not in the whitelist.
- You can only use the HTML Include macro for pages with absolute links. If you use the macro to include an HTML page that has relative links, navigating those links in the wiki results in a 'Page Not Found' error. See CONF-6567.

Code examples
See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

HTML Macro
The HTML macro allows you to add HTML code to a Confluence page.

Note that the HTML macro will only be available if it has been enabled by your System Administrator.

Using the HTML Macro
To add the HTML macro to a page:
1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type \ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

There are no parameters for this macro.

Enter the HTML code into the body of the macro placeholder.

Related pages:
- HTML Include Macro
- Working with Macros
- Enabling HTML macros
- Confluence User’s Guide

The information on this page does not apply to Confluence OnDemand.

Code examples
See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

IM Presence Macro

The IM Presence macro indicates graphically when a contact is signed into an Instant Messaging (IM) service. The IM Presence macro appears as a small icon on the page, like this image: Online Now.

Using the IM Presence Macro
To add the IM Presence macro to a page:
1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User ID/Screen Name</td>
<td>Identify the user by their ID, account name or screen name.</td>
</tr>
</tbody>
</table>
| Service                 | aim – AOL Instant Messenger  
gtalk – Google Talk  
icq – ICQ  
jabber – Jabber  
msn – MSN Instant Messenger  
SAMetime – IBM Lotus Sametime  
skype – Skype  
skypeme – Skype  
wildfire – Openfire Server  
yahoo – Yahoo! Messenger |
| Show User ID            | Shows or hides the User ID of the contact.                                  |

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Related Topics**

- Working with Macros
- Confluence User’s Guide

**Include Page Macro**

You can use the Include Page macro to display the contents of one Confluence page or blog post in another page or blog post.

**Using the Include Page Macro**

**To add the Include Page macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.
Speeding up macro entry with autocomplete: Type \{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page to Include</td>
<td>None</td>
<td>This is the name of the Confluence page or blog post that you want to include in the current page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• If the page or blog post is located in another space, add the space key and a colon in front of the page name. For example, DOC:My page name.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To include a blog post, specify the date as well as the title of the blog post. For example: /2010/12/01/My blog post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• The space key is case sensitive.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• You can include pages from personal spaces using ~username as the space key, where ‘username’ is the person’s username. For example, ~jsmith:My page name.</td>
</tr>
</tbody>
</table>

Code examples

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Notes

- If you want to include part of a page rather than the whole page, use the Excerpt and Excerpt Include macros.
- To display a page’s contents, you need ‘View’ permission for that page. Similarly, people who view the page will need ‘View’ permissions for the embedded page as well as the page into which it is embedded. See space permissions or contact your Confluence space administrator for more information.
- If you want to embed an external page into a Confluence page, you need the HTML Include Macro.

Related Topics

Working with Macros
Sample Include Page

Start of sample page content

The Info macro allows you to highlight helpful information on a Confluence page. It creates a blue-coloured box surrounding your text, as shown below.

<table>
<thead>
<tr>
<th>Info Macro Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>This text is rendered inside the info macro.</td>
</tr>
</tbody>
</table>

### Using the Info Macro

To add the Info macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

<table>
<thead>
<tr>
<th>On this page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the Info Macro</td>
</tr>
<tr>
<td>Parameters</td>
</tr>
<tr>
<td>Code examples</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Related pages:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working with Macros</td>
</tr>
<tr>
<td>Confluence Wiki Markup for Macros</td>
</tr>
<tr>
<td>Confluence Storage Format for Macros</td>
</tr>
<tr>
<td>Confluence User’s Guide</td>
</tr>
</tbody>
</table>

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>The title of the information box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>Show Information Icon</td>
<td>true</td>
<td>If &quot;false&quot;, the icon will not be displayed.</td>
</tr>
</tbody>
</table>

### Code examples

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

### JIRA Chart Macro

**JIRA** is Atlassian’s issue tracking and project management system. By adding the JIRA Chart macro to a Confluence page, you can display information about JIRA issues and projects as pie charts.

Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links. People viewing the page will see charts for publicly accessible issues from the JIRA site. If your JIRA site has restricted viewing (that is, people need permission to view issues) then they will need to authenticate before seeing the charts. This macro is compatible with JIRA 5.x and later.

**Adding the JIRA Chart macro to a page**
Quick guide to using the macro on a Confluence page:
1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

---

### Using the JIRA Chart Macro

**To add a JIRA chart to your page:**
1. Insert the JIRA Chart macro (see above).
2. Select your JIRA server.
   - If you have multiple JIRA instances linked to Confluence the drop down will default to the primary application link.
3. Search for issues - you can enter the query in JQL or paste a JIRA URL directly into the search field.
4. Choose **Preview** to see the chart.
5. Choose **Insert**.

To find out more about searching for issues see Displaying issues via a JIRA Query Language (JQL) search.

You can further control how the chart appears on your page. Choose **Display options:**

- **Chart by** - select the JIRA field you want to segment the pie chart by.
- **Width** - define the total width of the chart area. You can enter values in pixels or percent. Leave blank to auto fit.
- **Show border** - add a border around the chart area
- **Show chart information** - include a text summary under the chart with the total issues count and chart by value.

---

**Screenshot: The JIRA Chart Macro in the macro browser**
Disabling the JIRA Chart macro

The functionality is provided by an add-on (plugin) called 'JIRA Macros'. This macro is also used for the JIRA Issues macro. To make the macro unavailable on your site, you can disable the add-on. See Disabling and Enabling Add-ons.

Notes

HTTPS: The JIRA Chart macro can access a JIRA site running under SSL provided the Confluence server is configured to accept the JIRA SSL certificate. See Connecting to LDAP or JIRA or Other Services via SSL.

Authentication: If the query includes issues that require authentication (issues that are not visible to anonymous users in JIRA), users will be prompted to authenticate to view charts on the Confluence page.

In order to search for issues in the macro browser you may need to authenticate. With JIRA 5.x you will be able to search for unrestricted issues as an anonymous user, however with JIRA 6.x you must be authenticated to search for any issues.

Code examples for this macro

See:

- Confluence Storage Format for Macros
- JIRA Issues Macro

JIRA is the issue tracking and project management system supplied by Atlassian. By adding the JIRA Issues macro to a Confluence page, you can display one or more issues from a JIRA site. You can also choose to create an issue in JIRA, at the time of adding the macro to the Confluence page.

Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links. People viewing the page will see the publicly accessible issues from the JIRA site. If your JIRA site has restricted viewing (that is, people need permission to view issues) then they will need to authenticate before seeing the restricted issues. See more about restricted JIRA issues below.

What you can do with the JIRA Issues macro

Using the JIRA Issues macro, you can:

- Display a table of JIRA issues on your page, based on the results of a search using JIRA Query Language (JQL).
- Display a table of JIRA issues onto your page, using a JIRA URL.
- Display a single issue from the JIRA site, or a subset of selected issues from your JIRA search results.
- Display a count of issues from the JIRA site.
- Create new issues in JIRA and display the issues on your page without leaving Confluence.

**Adding and updating the JIRA Issues macro – an overview**

Quick guide to using the macro on a Confluence page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

---

**On this page:**
- What you can do with the JIRA Issues macro
- Adding and updating the JIRA Issues macro – an overview
- Displaying issues via a JIRA Query Language (JQL) search
- Displaying issues via a JIRA URL
- Displaying a single JIRA issue, or selected JIRA issues
- Displaying a count of issues
- Creating a new JIRA issue in the editor
- Configuring Application Links to display restricted JIRA issues
- Rendering HTML from JIRA
- Disabling the JIRA Issues macro
- Notes
- Code examples for this macro

**Related pages:**
- Working with Macros
- Confluence User’s Guide

---

**Screenshot: Example of JIRA issues macro on a Confluence page**

<table>
<thead>
<tr>
<th>Key</th>
<th>Summary</th>
<th>Type</th>
<th>Updated</th>
<th>Due</th>
<th>Priority</th>
<th>Status</th>
<th>Resolution</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONF-30694</td>
<td>User is not prompted before overwriting changes of another user if attempting to save after an editor error is thrown</td>
<td><img src="icon" alt="icon" /></td>
<td>Oct 22, 2013</td>
<td>🔼</td>
<td></td>
<td>🔴 Resolved</td>
<td>Fixed</td>
</tr>
<tr>
<td>CONF-30666</td>
<td>TableOfContents Macros navigation is not working in Firefox 23.x / 24.x and Opera 12-16</td>
<td><img src="icon" alt="icon" /></td>
<td>Sep 24, 2013</td>
<td>▼</td>
<td></td>
<td>🔴 Resolved</td>
<td>Fixed</td>
</tr>
<tr>
<td>CONF-30690</td>
<td>Dashboard popular stream won't render when it contains content from an anonymous user</td>
<td><img src="icon" alt="icon" /></td>
<td>Sep 19, 2013</td>
<td>🔼</td>
<td></td>
<td>🔴 Resolved</td>
<td>Fixed</td>
</tr>
<tr>
<td>CONF-30663</td>
<td>Left panel overlaps custom banner in Chrome</td>
<td><img src="icon" alt="icon" /></td>
<td>Sep 23, 2013</td>
<td>▼</td>
<td></td>
<td>🔴 Resolved</td>
<td>Fixed</td>
</tr>
</tbody>
</table>

4 Issues  🔄 Refresh

---

**Displaying issues via a JIRA Query Language (JQL) search**

You can use the macro to display a table of JIRA issues on your page, based on the results of a search using JIRA Query Language (JQL).

JQL is a simple query language, similar to SQL, which works in JIRA. A basic JQL query consists of a *field*,
followed by an operator (such as = or >), followed by one or more values or functions.

Examples:

- The following query will find all issues in the ‘TEST’ project:

  ```
  project = "TEST"
  ```

- The following query will find all issues in the ‘documentation’ component of the ‘CONF’ project:

  ```
  project = CONF and component = documentation
  ```

For more information about JQL syntax, see the JIRA documentation: [Advanced Searching](https://confluence.atlassian.com/display/DOC334879/Advanced+Searching).

To display a table of issues based on a JQL search:

1. Insert the JIRA Issues macro onto your Confluence page, as described above.
2. Choose a JIRA server next to the **Search** button.
3. If prompted, log in to the JIRA server.
4. Enter the JQL query into the **Search** box.
5. Choose **Search**.
6. If you want to customise the display, choose **Display options** and adjust the columns and number of issues that will appear in your table of issues.
7. Choose **Insert**.

**Screenshot: Display options in the JIRA Issues macro browser.**

### Displaying issues via a JIRA URL

You can paste any of the following JIRA URLs into the JIRA Issues macro. Confluence will immediately convert the URL to a JQL search:

- Any URL for a JIRA issue search or filter.
- A URL for a single issue.
- The URL of the XML view of a JIRA search.

**Auto-convert:** You can paste a JIRA URL directly into the Confluence editor (without calling up the macro browser). Confluence will automatically convert the URL into a JIRA Issues macro.

### Displaying a single JIRA issue, or selected JIRA issues

**To display a single JIRA issue**, choose one of the following methods:
- Paste the URL of the issue directly onto the Confluence page. (There is no need to use the macro browser.) Confluence will auto-convert the link to a JIRA Issues macro.
- Or: Add the JIRA issues macro to the page as described above, and choose Recently Viewed to see the JIRA issues you have visited recently. Select an issue and choose Insert.
- Or: Add the JIRA issues macro to the page as described above, and past the issue URL into the search box in the macro browser.
- Or: Add the JIRA issues macro to the page, define your search criteria in the macro browser via JQL as described above, then select the check box next to the issue in the search results, within the macro browser.

To display a subset of JIRA issues from your search results:

1. Add the JIRA issues macro to the page.
2. Define your search criteria in the macro browser via JQL, as described above.
3. Select the check boxes next to the required issues in the search results, within the macro browser.

Screenshot: Selecting a subset of issues to display

**Displaying a count of issues**

You can choose to display the number of issues returned by your search, rather than a table of issues. The JIRA Issues macro will display a count of issues, linked to the search in JIRA.

Screenshot: The JIRA Issues macro displaying an issue count on a Confluence page

To display an issue count:

1. Add the JIRA issues macro to the page.
2. Define your search criteria in the macro browser via JQL, as described above.
3. Choose Display options, then choose Total issue count next to 'Display options' in the macro browser.
4. Choose Insert.

Creating a new JIRA issue in the editor

While editing a Confluence page, you can create an issue in JIRA and display it on your Confluence page, without leaving the Confluence editor.

To insert an issue into JIRA:

1. Add the JIRA Issues macro to the page, as described above.
2. Choose Create New Issue.
3. Supply the information about your JIRA server, project, and issue, as prompted.
4. Choose Insert.

Confluence will send a request to JIRA, to add the issue to the JIRA site. Confluence will also display the resulting JIRA issue on the Confluence page.

Notes:

- This feature works best with JIRA issue types whose mandatory field requirements have not been altered. With the exception of a JIRA issue's 'Component/s' or 'Fix Version/s' fields, You cannot use the JIRA Issues macro to add an issue whose issue type has customised mandatory field requirements. (Exception: customisations of the 'Component/s' and 'Fix Version/s' fields are accepted.)
- If your JIRA project has customised fields, the JIRA Issues macro will not prompt you for information for those fields. In other words, those fields will not appear in the 'Create New Issue' dialog in the JIRA Issues macro browser.

Configuring Application Links to display restricted JIRA issues

Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links.

If the JIRA site allows anonymous viewing of issues, you must configure an application link, but there is no need to configure any incoming or outgoing authentication between JIRA and Confluence. People viewing the Confluence page will see the publicly accessible issues from the JIRA site.

If your JIRA site has restricted viewing, or if some JIRA projects or issues are restricted to viewing by certain people, then people will need to log in before seeing the restricted issues.

In such a case, the outgoing authentication in the Confluence Application Links determines how the JIRA Issues macro handles restricted issues:

- If the outgoing authentication is set to Trusted Applications, people can see restricted issues in JIRA if their username is the same in JIRA and Confluence, and if they have permission in JIRA to see the issue.
- If the outgoing authentication is set to OAuth, people may need to choose Login & Approve, to gain access to the JIRA server and restricted issues.
- If the outgoing authentication is set to Basic Access, people can see the JIRA issues that are visible to the user account configured in JIRA's outgoing authentication setting.

Rendering HTML from JIRA

Formatted fields from JIRA can be displayed in Confluence if you set up a Confluence-to-JIRA application link. Otherwise, such formatted fields will be escaped within the output of the JIRA issues macro. This is to prevent the possibility of malicious HTML being served by an untrusted JIRA server. The most likely field where you will notice this is in the description field.

This example shows how a description column may be displayed in JIRA:

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is</td>
</tr>
<tr>
<td>• the description</td>
</tr>
<tr>
<td>• of my issue</td>
</tr>
</tbody>
</table>
If there is no application link between JIRA and Confluence, the description will appear in the JIRA issues macro like this:

```
Description
<p>This is<ul><li>the description</li><li>of my issue</li></ul></p>
```

### Disabling the JIRA Issues macro

The functionality is provided by an add-on (plugin) called ‘JIRA Macros’. To make the macro unavailable on your site, you can disable the add-on. See Disabling and Enabling Add-ons.

### Notes

**HTTPS**: The JIRA Issues macro can access a JIRA site running under SSL provided the Confluence server is configured to accept the JIRA SSL certificate. See Connecting to LDAP or JIRA or Other Services via SSL.

Custom fields can be added as columns to the table simply by using the name of the field with no quotes. Earlier versions of the macro required you to use the custom field id, e.g. `customfield_10100`.

### Code examples for this macro

Note: Wiki markup offers a few additional parameters that are not available via the macro browser.

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

JUnit Report Macro

The JUnit Report macro displays a summary of JUnit test results from a directory accessible by the Confluence server. **JUnit** is a unit testing framework which allows programmers to ensure that individual units of Java source code are functioning correctly.

The JUnit Report macro appears as shown in the screenshot below.

**Screenshot: The JUnit Report macro in Confluence**

<table>
<thead>
<tr>
<th>Test</th>
<th>Time</th>
<th>Messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>MoneyTest</td>
<td>100%</td>
<td>Tests.Fails:Exce:0:0:0</td>
</tr>
<tr>
<td>testAdd</td>
<td>00:03.0</td>
<td>00:03.0</td>
</tr>
</tbody>
</table>

Note: When generating reports from the JUnit Report macro, set the Apache Ant formatter to ‘XML’.

### Using the JUnit Report macro

To add the JUnit Report macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete**: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro**: Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
### URL of the test result XML file

None

URL of a particular test result XML file. Is overridden by the **Directory (URL) of your test result files** parameter if you use both.

Example, from a Confluence instance: `http://yourConfluenceInstance.com/download/attachments/<page id>/file.xml`

For Confluence installations without anonymous user access, you can specify logon credentials as part of this parameter in the form of URL parameters:

- `os_username` — The username of a Confluence user with permission to access the JUnit test results.
- `os_password` — The password of the Confluence user specified in the `os_username` parameter.

### Directory (URL) of your test result files

None

URL of a directory containing your test result files. This must be a directory name and **not** the XML file itself. Overrides the **URL of the test result XML file** parameter if you use both.

Example, for a local drive: `file://C:/TEMP/`

Example, for a network drive: `http://*host*/*path*`

### Report Detail

**all**

Detail for the report. Can be **all**, **fixure**, **summary** or **failuresonly**.

### Debug

None

Shows the content of failures, as well as the error messages.

---

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Related topics**

Working with Macros

Take me back to the Confluence User's Guide.

Labels List Macro

The Labels List macro displays a list of all labels within the current space. Each label in the list links to a page that displays all pages in the current space that contain that label.

*Using the Labels List macro*
To add the Labels List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restrict to this Space Key</td>
<td>No</td>
<td>Current space</td>
<td>The key of the space whose labels you want to display.</td>
</tr>
<tr>
<td>Excluded label(s)</td>
<td>No</td>
<td>Blank</td>
<td>The labels that you do not want to appear in the list.</td>
</tr>
</tbody>
</table>

Code examples

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Related topics

Working with Macros

Take me back to the Confluence User’s Guide.

Livesearch Macro

The Livesearch macro allows you to add a search box to a Confluence page. When users enter a search term into the search box, Confluence will dynamically display matching results as they type.

Using the Livesearch macro

To add the Livesearch macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
### Restrict to this Space Key

| all spaces |

Specify a space key to limit the search to the given space. Case-sensitive.

### Restrict to label(s)

Specify labels to limit the search to content with that label. If unspecified will search all content regardless of label.

### Size

| medium |

Choose a medium or large search field size.

### Placeholder text

Specify the placeholder text to appear in the search field, for example 'Search this space'.

### Type

| all |

Specify the content types to be included in the search - choose from pages, blogs, comments, space descriptions, or all content types.

### Additional

| space name |

Display the space name, a page excerpt or nothing under the search result.

---

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Related topics**

- Searching Confluence
- Search Results Macro
- Working with Macros

Take me back to the Confluence User's Guide.

**Loremipsum Macro**

The Loremipsum macro displays paragraphs of pseudo-Latin text (more information). You can use this macro to generate more-or-less meaningless text for demonstration purposes in pages showing a draft layout or arrangement of page elements. The text is deliberately non-meaningful so that it does not influence the viewer's perception of the page arrangement or design.

A basic example of the Loremipsum text:

```
```

### Using the Loremipsum macro

**To add the Loremipsum macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.
**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Paragraphs</td>
<td>3</td>
<td>Determines the amount of pseudo-Latin (space-filler) text to display. The macro will display a maximum number of 30 paragraphs.</td>
</tr>
</tbody>
</table>

**Code examples**

See:

- [Confluence Wiki Markup for Macros](#)
- [Confluence Storage Format for Macros](#)

**Related topics**

Working with Macros

Take me back to the [Confluence User's Guide](#).

Multimedia Macro

See [Embedding Multimedia Content](#).

Navigation Map Macro

The Navigation Map macro displays a navigable map of the pages tagged with a given label.

**Using the Navigation Map Macro**

**To add the Navigation Map macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>none</td>
<td>Specify the label associated with the pages you want to show in the navigation map.</td>
</tr>
<tr>
<td>Map Title</td>
<td>none</td>
<td>Specify a title for the navigation map.</td>
</tr>
<tr>
<td>Number of Cells Per Row</td>
<td>5</td>
<td>Specify the number of cells in a row</td>
</tr>
<tr>
<td>Cell Width (Pixels)</td>
<td>90 px</td>
<td>Specify the cell width</td>
</tr>
<tr>
<td>Cell Height (Pixels)</td>
<td>60 px</td>
<td>Specify the cell height</td>
</tr>
<tr>
<td>Navigation Map Theme</td>
<td>Confluence</td>
<td>Define a theme for the navmap.</td>
</tr>
</tbody>
</table>

If you want to create your own navmap 'look and feel' (for example, one with rounded corners), you need to add a customised navmap macro theme file to the WEB-INF/classes/templates/macro directory. The file name convention to use is navmap-mytheme.vm. Use the name of your choice for the mytheme part of the file name, which is also the value you use for this parameter. Hence, if your theme was called navmap-roundededges.vm, use the value of rounded edges for this parameter.

**Code examples**

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Network Macro**

The Network macro displays a list of Network activity on a Confluence page or blog post. You can specify the user whose network activity you wish to show. These interactions include the users that the specified user is following or users who are following the specified user. The Network macro shows each listed user by their profile picture. It also provides a choice of two themes and the ability to limit the number of users in the list.

**Screenshot: Network macro**
Using the Network macro

To add the Network macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>Current user's username</td>
<td>The username of the Confluence user whose network interactions you wish to show. If no username is specified, then current user's (that is, your) network interactions are shown.</td>
</tr>
<tr>
<td>Mode</td>
<td>following</td>
<td>Determines which users are listed, with respect to the specified user:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- following – those who the user is following.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- followers – those who are following the user.</td>
</tr>
<tr>
<td>Theme</td>
<td>full</td>
<td>Determines how the user's network is displayed:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- full – shows a large version of user's profile pictures and, if the following mode is set, provides an entry field function to follow more users.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- tiny – shows only the small version of user's profile pictures.</td>
</tr>
</tbody>
</table>
**Maximum Results**

| Maximum Results | No limit imposed up to a maximum of 30 | Restricts the number of users displayed. If the number of users exceeds the specified maximum, then a **Show All** link is provided. This link leads to the specified user's **Network view**, showing the complete list of network interactions. |

**Disabling the Network macro**

The Network macro is provided by the 'network' module in the 'Profile Macros' plugin. To remove the macro from your site, you can disable the module in the plugin. See **Disabling and Enabling Add-ons**.

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Noformat Macro**

The Noformat macro displays a block of text in monospace font with no other formatting.

**Using the Noformat Macro**

**To add the Noformat macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Enter the content that is to be unformatted into the body of the macro placeholder.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Panel</td>
<td>False</td>
<td>Removes the panel around the content.</td>
</tr>
</tbody>
</table>

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Note Macro**
The Note macro displays a block of text in a yellow highlighted box. This is useful for emphasising important information.

Example:

My note
This is the content of my note.

**Using the Note Macro**

**To add the Note macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Add the text of the note to the body of the macro placeholder.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>If specified, the title is displayed in bold next to the icon.</td>
</tr>
<tr>
<td>Show Exclamation Mark Icon</td>
<td>true</td>
<td>• <strong>true</strong> – displays the warning icon&lt;br&gt;• <strong>false</strong> – the icon is not displayed</td>
</tr>
</tbody>
</table>

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Office Excel Macro**

The Office Excel macro displays the content of an Excel spreadsheet on a wiki page. First attach the spreadsheet to a Confluence page, then use the macro to display the content. When viewing the page, people will see the content of the spreadsheet, without needing to have Office installed.

For details, see the View File Macro.

**Office PowerPoint Macro**

The Office PowerPoint macro displays the content of a PowerPoint presentation on a wiki page. First attach the presentation to a Confluence page, then use the macro to display the content. When viewing the page, people will see the content of the presentation, without needing to have Office installed.
Confluence 5.4 Documentation

For details, see the View File Macro.

Office Word Macro

The Office Word macro displays the content of a Word document on a wiki page. First attach the document to a Confluence page, then use the macro to display the content. When viewing the page, people will see the content of the document, without needing to have Office installed.

For details, see the View File Macro.

Page Index Macro

The Page Index macro creates a hyperlinked alphabetical index of all page titles within the current space.

The top section of the index contains a cell for each letter of the alphabet, with cells for numbers and symbols. Each cell indicates how many pages are in the corresponding list.

The lower section contains lists of page titles followed by the first few sentences of content on that page.

Each letter, number or symbol in the top section is hyperlinked to the corresponding cell in the lower section. Each page title in the lower section is hyperlinked to the page in the space.

On this page:
- Using the Page Index macro
- Code examples

Related pages:
- Working with Macros
- Confluence User's Guide.

Screenshot: Page Index macro (partial view)

Using the Page Index macro

To add the Page Index macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

This macro accepts no parameters.

Code examples

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Page Properties Macro

The Page Properties macro enables you to embed data on a page and then display that data in tabular form on another page. You can put the Page Properties macro on as many pages as you like and use the Page Properties Report macro to display the collected data on one page. You can also choose to hide the metadata on the pages that contain the Page Properties macro.

This macro was previously known as the Metadata Details macro.

On this page:

- Basic usage of the Page Properties and Page Properties Report macros
- Using the Page Properties macro
- Parameters
- Examples
- Code examples
- Notes
- Other metadata macros

Related pages:

- Include Page Macro
- Excerpt Include Macro
- Using Label Macros to Categorise Wiki Content
- Working with Macros
- Working with Confluence Labels
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User's Guide

Basic usage of the Page Properties and Page Properties Report macros

The Page Properties macro is used in conjunction with the Page Properties Report macro.

To use the macros:

1. Add the Page Properties macro to your page and specify a label (for example, Status).
2. Add a two column table in the body of the macro placeholder for your metadata keys and values.
3. Repeat this process to add the Page Properties macro to other pages.
4. Create a new page to contain your report (for example, Status Report).
5. Add the Page Properties Report macro and specify the same label (for example, Status).

Screenshot: example 'Status' report
7. Choose a column heading to sort the report.

When you insert the Page Properties macro on a page Confluence automatically adds the label to the page. You can add more than one Page Properties macro to the page, but they will inherit the same label (e.g. you cannot have two Page Properties macros with different labels on the same page).

**Using the Page Properties macro**

1. **Add the Page Properties macro to the page:**
   a. In the Confluence editor, choose Insert > Other Macros.
   b. Find and select the required macro.

   **Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

   **To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

2. **Add a label to the macro, using the macro parameters.**
   In the macro browser, add a Label. For example, “Status”.

3. **Add metadata keys and values as rows in a table, in the body of the macro placeholder.**
   In the macro body add a two column table and remove the header row. In the left column specify the keys (these will be the column headings in your report. You cannot format this text). In the right column specify the values for each key.

   **Screenshot: The macro placeholder in the Confluence editor**

   ![Screenshot of the macro placeholder](image)

   **Parameters**

   Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>(None)</td>
<td>The label used to identify the metadata on this page. Confluence will add this label to the page. Any additional Page Properties macros will inherit this label.</td>
</tr>
<tr>
<td>Hidden</td>
<td>False</td>
<td>Determines whether the data in the Page Properties macro will be displayed on the current page. This setting does not affect the display of the detail in the Page Properties Report macro.</td>
</tr>
</tbody>
</table>

**Examples**

The following examples outline how you can use the Page Properties and Page Properties Report macros together to create a Status Report or a Risk Report.

**Example 1 - Status Report**

In this example we wish to create a Status Report page that displays project status metadata from a number of pages.

The **label** in this example is 'status'

The **keys** in this example are:

- Deadline
- Project Status
- Team.

The **values** for each key are:

- Deadline: 1 June, 15 November and so on.
- Project status: Not started, In progress, Complete.
- Team: Purple Monkeys, Green Parrots.

The **Page Properties macro** on each page looks like this:

*Screenshot: two examples of the Page Properties macro from different pages showing values for each key.*

The label keys are the same on each page. The values are different.

The **Page Properties Report macro** on the Status Report page looks like this:

*Screenshot: Page Properties Report macro with the label 'Status'*

The final Status Report page looks like this, with a row for each page:

*Screenshot: Example of the Page Properties Report macro showing data*

You could also use the **Status Macro** within the Page Properties macro, to provide a visual indication of
status.

Want to see this example in action? The following pages were created in this documentation space to create this example.

- Status and Risk Reports - example of Page Properties Report macro
- Project ABC - Example Metadata
- Project DEF - Example Metadata

Example 2 - Risk Report
In this example we wish to create a Risk Report page that displays project risk metadata from a number of pages.

The label in this example is ‘risk’

The keys in this example are:

- Impact
- Risk Level.

The values for each key are:

- Impact: critical, high, medium, low
- Risk Level: major, minor, trivial.

The Page Properties macro on each page looks like this:

Screenshot: example of the Page Properties macro from one page.

![Page Properties | label = risk](image)

The Page Properties Report macro on the Risk Report page looks like this:

Screenshot: Page Properties Report macro with the label ‘Risk’

![Page Properties Report | label = risk](image)

The final Risk Report page looks like this, with a row for each page:

Screenshot: Example of the Page Properties Report macro showing data

<table>
<thead>
<tr>
<th>Title</th>
<th>Impact</th>
<th>Risk level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Implementation Option A - Example Metadata</td>
<td>Major</td>
<td>Critical</td>
</tr>
<tr>
<td>Implementation Option B - Example Metadata</td>
<td>Trivial</td>
<td>High</td>
</tr>
<tr>
<td>Implementation Option C - Example Metadata</td>
<td>Major</td>
<td>High</td>
</tr>
</tbody>
</table>

Want to see this example in action? The following pages were created in this documentation space to create this example.

- Status and Risk Reports - example of Page Properties Report macro
- Implementation Option A - Example Metadata
- Implementation Option B - Example Metadata
- Implementation Option C - Example Metadata

Code examples
See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Notes**

- If you add a label to the parameter in the Page Properties macro, Confluence adds the label to the page.
  - If you remove the label from the Page Properties macro, the label remains on the page.
  - If you remove the label from the page but leave it in the Page Properties macro, Confluence puts the label back onto the page.
- You can add many Page Properties macros per page, however all Page Properties macros on the page will have the same labels applied to them. For example, if you add two Page Properties macros on a page, one with the label "risk" and the other with the label "status", both sets of metadata will appear in the Page Properties Report macro for the "status" label and for the "risk: label. This is true even if you have specified just one label in each Page Properties macro. It is the labels on the page that matter, not the labels in the macros.
- You cannot use text formatting or macros in the left column as the data in this column is used to populate the column headings in your Page Properties Report macro.
- If your table has a header row, this row will be ignored by the Page Properties Report macro. You should remove the header row.
- It is not possible to reference the metadata using the metadata key from within the page, or anywhere else on a Confluence page.

**Other metadata macros**

There are other metadata macros, which are not supported or documented on this page but which are worth mentioning:

- `{metadata-list}` – Adds metadata keys and values. See Atlassian Answers.
- `{metadata-values:pagename}` – Displays the metadata values without the keys. You can use @self to get the metadata on the current page. See Atlassian Answers.
- `{metadata-report}`
- Macros added by the Confluence Metadata Plugin 2.

**Status Report - Example of Page Properties Report Macro**

This page contains examples of the Page Properties Report macro used to show a status report and a risk report.

**Page Properties Report for label "status"**

<table>
<thead>
<tr>
<th>Title</th>
<th>Deadline</th>
<th>Project status</th>
<th>Team</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project DEF - Example Metadata</td>
<td>1 June</td>
<td>Not Started</td>
<td>Purple Monkeys</td>
</tr>
<tr>
<td>Project ABC - Example Metadata</td>
<td>15 November</td>
<td>In Progress</td>
<td>Green Parrots</td>
</tr>
</tbody>
</table>

**Page Properties Report for label "risk"**

<table>
<thead>
<tr>
<th>Title</th>
<th>Impact</th>
<th>Risk level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Implementation Option C - Example Metadata</td>
<td>Major</td>
<td>High</td>
</tr>
<tr>
<td>Implementation Option B - Example Metadata</td>
<td>Trivial</td>
<td>High</td>
</tr>
<tr>
<td>Implementation Option A - Example Metadata</td>
<td>Major</td>
<td>Critical</td>
</tr>
</tbody>
</table>

**Related pages:**

- Page Properties Report Macro
- Page Properties Macro
- Confluence User's Guide
This page contains an example of the Page Properties macro. The data in the macro is not hidden.

| Risk level | Critical |
| Impact     | Major    |

Related pages:
- Page Properties Report Macro
- Page Properties Macro
- Confluence User's Guide

Implementation Option B - Example Metadata
This page contains an example of the Page Properties macro. The data in the macro is not hidden.

| Risk level | High       |
| Impact     | Trivial    |

Related pages:
- Page Properties Report Macro
- Page Properties Macro
- Confluence User's Guide

Implementation Option C - Example Metadata
This page contains an example of the Page Properties macro. The data in the macro is not hidden.

| Risk level | High       |
| Impact     | Major      |

Related pages:
- Page Properties Report Macro
- Page Properties Macro
- Confluence User's Guide

Project ABC - Example Metadata
This page contains an example of the Page Properties macro. The data in the macro is not hidden.

| Project Status | In Progress |
| Team           | Green Parrots |
| Deadline       | 15 November  |

Related pages:
- Page Properties Report Macro
- Page Properties Macro
- Confluence User's Guide

Project DEF - Example Metadata
This page contains an example of the Page Properties macro. The data in this macro is hidden.
Page Properties Report Macro

The Page Properties Report macro presents a tabulated summary of metadata that has been embedded, using the Page Properties macro, on any page or blog post in the current Confluence space. The Page Properties Report macro collects metadata from only those pages or blog posts that have a specific label.

The left-hand column of the report shows the name of the page that contains the metadata. Each page name is presented on a single row with a link to the page.

The other columns in the report represent the fields (keys) defined in the Page Properties macros. You can sort the table by choosing the column headers.

This macro was previously known as the Details Summary macro.

Basic usage of Page Properties and Page Properties Report macros

The Page Properties macro is used in conjunction with the Page Properties Report macro.

To use the macros:

1. Add the Page Properties macro to your page and specify a label (for example, Status).
2. Add a two column table in the body of the macro placeholder for your metadata keys and values.
3. Repeat this process to add the Page Properties macro to other pages.
4. Create a new page to contain your report (for example, Status Report).
5. Add the Page Properties Report macro and specify the same label (for example, Status).

Screenshot: example 'Status' report
7. Choose a column heading to sort the report.

When you insert the Page Properties macro on a page Confluence automatically adds the label to the page. You can add more than one Page Properties macro to the page, but they will inherit the same label (e.g. you cannot have two Page Properties macros with *different* labels on the same page).

**Using the Page Properties Report macro**

1. **Add the Page Properties Report macro to the page:**
   a. In the Confluence editor, choose **Insert > Other Macros**.
   b. Find and select the required macro.

   **Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

   **To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

2. **Add a label to the macro, using the macro parameters.**
   In the macro browser, specify a **Label**. For example, 'Status'.
   ![Screenshot: Page Properties Report macro with label specified](image)

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>(None)</td>
<td>Identifies the label to be used in the Page Properties Report. The report will show data from all Page Properties macros with the same label on pages in the current space.</td>
</tr>
<tr>
<td>Restrict to spaces</td>
<td>(None)</td>
<td>If not specified, the report will only show data from the current space. You can specify a comma separated list of space keys, or use @all to show data from all spaces.</td>
</tr>
<tr>
<td>Title column heading</td>
<td>Title</td>
<td>The heading to display on the first column in the report table. This column contains links to pages displayed by the report. The default column heading is 'Title'.</td>
</tr>
</tbody>
</table>
### Columns to show

(None)

- If not specified, the report will show all columns. You can specify a comma separated list of columns to include.
- If your column heading includes commas, use double quotes around the column name. If your column heading includes quotes, use double quotes. For example, A column, "My "new" column, yes", Third column

### Number of items to display

30

- Number of items to display in the table before displaying pagination options for additional items.

### Sort by

Last modified date

- Sort the table by a specific column heading. Enter the column name, exactly as it appears in the corresponding Page Properties macro.
- Select the Reverse Sort check box to sort the table in reverse order.

### Show Comments Count

No

- Displays the number of comments for each page in the table.

### Show Likes Count

No

- Displays the number of likes for each page in the table.

### Examples

The following examples outline how you can use the Page Properties and Page Properties Report macros together.

The following examples outline how you can use the Page Properties and Page Properties Report macros together to create a Status Report or a Risk Report.

#### Example 1 - Status Report

In this example we wish to create a Status Report page that displays project status metadata from a number of pages.

- The **label** in this example is ‘status’
- The **keys** in this example are:
  - Deadline
  - Project Status
  - Team.
- The **values** for each key are:
  - Deadline: 1 June, 15 November and so on.
  - Project status: Not started, In progress, Complete.
  - Team: Purple Monkeys, Green Parrots.

- The **Page Properties macro** on each page looks like this:

  *Screenshot: two examples of the Page Properties macro from different pages showing values for each key.*
The label keys are the same on each page. The values are different.

The **Page Properties Report macro** on the Status Report page looks like this:

*Screenshot: Page Properties Report macro with the label 'Status'*

The final Status Report page looks like this, with a row for each page:

*Screenshot: Example of the Page Properties Report macro showing data*

You could also use the **Status Macro** within the Page Properties macro, to provide a visual indication of status.

Want to see this example in action? The following pages were created in this documentation space to create this example.

- Status and Risk Reports - example of Page Properties Report macro
- Project ABC - Example Metadata
- Project DEF - Example Metadata

**Example 2 - Risk Report**

In this example we wish to create a Risk Report page that displays project risk metadata from a number of pages.

The **label** in this example is 'risk'

The **keys** in this example are:

- Impact
- Risk Level.

The **values** for each key are:

- Impact: critical, high, medium, low
- Risk Level: major, minor, trivial.

The **Page Properties macro** on each page looks like this:

*Screenshot: example of the Page Properties macro from one page.*
The Page Properties Report macro on the Risk Report page looks like this:

*Screenshot: Page Properties Report macro with the label 'Risk'*

The final Risk Report page looks like this, with a row for each page:

*Screenshot: Example of the Page Properties Report macro showing data*

<table>
<thead>
<tr>
<th>Title</th>
<th>Impact</th>
<th>Risk level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Implementation Option A - Example Metadata</td>
<td>Major</td>
<td>Critical</td>
</tr>
<tr>
<td>Implementation Option B - Example Metadata</td>
<td>Trivial</td>
<td>High</td>
</tr>
<tr>
<td>Implementation Option C - Example Metadata</td>
<td>Major</td>
<td>High</td>
</tr>
</tbody>
</table>

Want to see this example in action? The following pages were created in this documentation space to create this example.

- Status and Risk Reports - example of Page Properties Report macro
- Implementation Option A - Example Metadata
- Implementation Option B - Example Metadata
- Implementation Option C - Example Metadata

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Page Tree Macro**

The Page Tree macro displays a dynamic, hierarchical list of pages starting from a specified parent (root) page. It can act as a table of contents or a list of related topics. When viewing the page tree, your reader can click a link to view the relevant page. The page's current position is highlighted in the page tree.

**Note:** The Page Tree macro is used in the Confluence Documentation theme, to create a navigation panel showing a table of contents for your space. Read the instructions on Configuring the Documentation Theme.

**Using the Page Tree Macro**

To add the Page Tree macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Click **Refresh** in the Macro Browser to see the effect of changes to the macro parameters.
On this page:
- Using the Page Tree Macro
- Macro Parameters
- Code examples

Related pages:
- Page Tree Search Macro
- Working with Macros
- Confluence User's Guide

**Macro Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Root Page  | The home page of the space | Specify the parent page for the page tree. The tree will include all children of the given page, plus their children and grand-children etc. The tree will **not** include the root page itself. Specify the page title or a special value as follows:  
- Your page title — to specify a page name for the parent or root of the tree. The tree will include all children and grand-children of the specified root. The tree will **not** include the specified root page itself.  
- '@home' — will include all pages under the home page of the space (default).  
- '@self' — will include all pages under the current page.  
- '@parent' — will include all pages under the parent of the current page, including the current page.  
- '@none' — will include all pages in the space, including orphaned pages and the home page. |
| Sort Pages By          | position          | Specify the order to display the pages in the tree. This sort order is for display purposes only. It does not permanently re-arrange the page order. The value may be one of the following:
|                       |                  | • bitwise — sort alphabetically, for example: title1, title10, title2.
|                       |                  | • creation — sort by date of creation.
|                       |                  | • modified — sort by order of date last modified.
|                       |                  | • natural — sort in 'natural' alphabetical order, for example: title1, title2, title10.
|                       |                  | • position — sort by the default Confluence sorting rules. If your pages have been ordered manually, this sort will respect the defined order. Otherwise the pages will be displayed in the 'natural' alphabetical order, such as: title1, title2, title10.
| Include Excerpts in Page Tree | false | Select if you want the page tree to show excerpts from each page. The excerpts must be defined on each page by the Excerpt macro.
| Reverse Order | false | Select to show the pages in reverse (descending) natural order. Must be used in combination with the Sort Pages By parameter.
| Include Search Box above Page Tree | false | Select if you want to include a search box above the page tree. The search box allows your readers to search within the page tree for the specified value.
| Show Expand/Collapse Links | false | Select if you want to display the 'expand all' and 'collapse all' links at the top of your page tree. Your readers can click these links to open or close all branches of the tree at once.
| Start Depth | 1 | Enter any number greater than 0 to set how many levels of children the tree should show when it opens for the first time.

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Sample Page Tree
This page is a sample, used to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Page Tree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetree:root=@@parent</td>
<td>expandCollapseAll=false}</td>
</tr>
</tbody>
</table>

**Another Sample Page Tree**

We’re using this page to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Page Tree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetree:root=@@parent</td>
<td>expandCollapseAll=true}</td>
</tr>
</tbody>
</table>

**Sample Page Tree 2**

This is another sample page, used to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Page Tree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetree:root=@@parent</td>
<td>expandCollapseAll=true}</td>
</tr>
</tbody>
</table>

**Page Tree Search Macro**

Using the Page Tree Search macro, you can add a search box to your Confluence page. When a viewer enters a search term, Confluence will search a hierarchy of pages starting from a specified parent (root) page and return the search results.

You can also add a search box as part of a dynamic page tree, which looks like a table of contents. See the Page Tree Macro.

**Using the Page Tree Search macro**

To add the Page Tree Search macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

On this page:
- Using the Page Tree Search macro
- Parameters
- Code examples

Related pages:
- Page Tree Macro
- Working with Macros
- Confluence User's Guide

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name of Root Page</td>
<td>none</td>
<td>The name of the root page whose hierarchy of pages will be searched by this macro. If this not specified, the root page is the current page. <strong>Note:</strong> Unlike the Page Tree macro, the Page Tree Search macro does not accept the special values that start with an @ sign, such as @home or @self.</td>
</tr>
</tbody>
</table>

**Code examples**

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Panel Macro**

The Panel macro displays a block of text within a customisable panel, like a text box. **Handy hint:** You can use panels within columns, in table cells and in the sections defined by page layouts.

Here is an example of a Panel macro:

```
My Title
A formatted panel.
```

**Using the Panel macro**

**To add the Panel macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

<table>
<thead>
<tr>
<th>On this page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the Panel macro</td>
</tr>
<tr>
<td>Parameters</td>
</tr>
<tr>
<td>Code examples</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Related pages:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working with Macros</td>
</tr>
<tr>
<td>Confluence User’s Guide</td>
</tr>
</tbody>
</table>

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panel Title</td>
<td>none</td>
<td>The title of the panel. If specified, this title will be displayed in its own title row.</td>
</tr>
<tr>
<td>Border Style</td>
<td>solid</td>
<td>The style of the panel's border. Accepted values are solid, dashed and other valid CSS border styles.</td>
</tr>
<tr>
<td>--------------</td>
<td>-------</td>
<td>--------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Border Colour</td>
<td></td>
<td>The colour of the panel's border. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
<tr>
<td>Border Pixel Width (Value Only)</td>
<td></td>
<td>The width of the panel's border (in pixels).</td>
</tr>
<tr>
<td>Background Colour</td>
<td></td>
<td>The background colour of the panel. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
<tr>
<td>Title Background Colour</td>
<td></td>
<td>The background colour of the title row of the panel. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
<tr>
<td>Title Text Colour</td>
<td></td>
<td>The colour of the text in the title row of the panel. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
</tbody>
</table>

**Code examples**

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**PDF Macro**

The PDF macro displays the content of a PDF document ([Adobe's Portable Document Format](https://www.adobe.com/products/acrobat/prodintro/)) on a wiki page. First attach the document to a Confluence page, then use the macro to display the document.

For details, see the View File Macro.

**Popular Labels Macro**

The Popular Labels macro displays the most popular labels used throughout your Confluence site or within a space.

**Using the Popular Labels Macro**

**To add the Popular Labels macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Labels to Display</td>
<td>100</td>
<td>Specifies the total number of labels to display in the heatmap.</td>
</tr>
<tr>
<td>Restrict Labels to this Space Key</td>
<td>none</td>
<td>Restricts the list of popular labels to the specified space.</td>
</tr>
</tbody>
</table>
| Style of Labels                  | list    | - list – displays the popular labels as a bulleted list, ordered by popularity (highest first).
|                                  |         | - heatmap – displays the popular labels using different font sizes for each label depending on the label's popularity, ordered by label names. |

Code examples

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Profile Picture Macro

The Profile Picture macro displays a user's profile picture on a page.

- When viewing the page, mouse-over the picture to see the Hover Profile for the user.
- When editing the page, click on the picture and choose View User Profile to see the profile for the user.

The Profile Picture macro is useful for such tasks as creating Team Pages that show all members of a project team.
Using the Profile Picture Macro

To add the Profile Picture macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User</td>
<td>none</td>
<td>The username, or real name, of a Confluence user.</td>
</tr>
</tbody>
</table>

Code examples

See Confluence Storage Format for Macros.

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

Recently Updated Dashboard Macro

The Recently Updated Dashboard macro displays a list of the most recently changed content within Confluence. It is similar to the Recently Updated macro but is intended for use on the Confluence dashboard.

Using the Recently Updated Dashboard macro

To add the Recently Updated Dashboard macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space(s)</td>
<td>The space which contains the page on which the macro is added</td>
<td>Filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here. You can specify one or more space keys, separated by commas. &quot;*&quot; means all spaces.</td>
</tr>
<tr>
<td>Include these Content Types Only</td>
<td>all types</td>
<td>Filter content by type. You can specify one or more types, separated by commas. Available types are: page, blogpost or news, spacedesc, attachment, comment, mail, userinfo.</td>
</tr>
</tbody>
</table>
| Label(s)                         | none       | Filter content by label. The macro will display only the pages etc which are tagged with the label(s) you specify here. You can specify one or more labels, separated by commas.  
Note: If there are no pages matching any of the specified labels, then Confluence will ignore the labels and will list all recently updated pages, as well as showing a message, “These labels don’t exist and were ignored: xxx ”. This unexpected behaviour is noted in issue [CONF-13860](https://confluence.jetbrains.com/conf-13860) - recently-updated-dashboard macro doesn't return an empty result when no pages match the specified label(s) (Open) |
| User(s)                          | all users  | Filter by username of the user who updated the content. The macro will only display content created and updated by the user(s) you specify here. You can specify one or more usernames separated by commas. |
| Width of Table                   | 100%       | Specify the width of the macro display, as a percentage of the window width.                                                                                                                                 |
| Show User Profile Pictures       | false      | Select whether profile pictures of the users who updated the content are displayed.                                                                                                                        |

Code examples

See:

Confluence Storage Format for Macros.

Recently Updated Macro

The Recently Updated macro displays a list of the most recently changed content within Confluence.

Using the Recently Updated Macro

To add the Recently Updated macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

On this page:
- Using the Recently Updated Macro
- Parameters
- Notes
- Code examples

Related pages:
- Recently Updated Dashboard Macro
- Viewing Recently Updated Content
- Working with Macros
- Confluence User's Guide

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Author(s) by username</td>
<td>None specified. That is, display all content</td>
<td>Filter the results by author. The macro will display only the pages etc which were last modified by the author(s) you specify here. You can specify one or more authors, separated by a comma or a space. For example: jsmith, jbrown To include content from one user, but exclude from another user: jsmith, !jbrown</td>
</tr>
</tbody>
</table>
| Space(s) | @self  
That is, the space which contains the page on which the macro is used | This parameter allows you to filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here.

You can specify one or more space keys, separated by a comma or a space.

- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.
- To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:
- @self — The current space.
- @personal — All personal spaces.
- @global — All site spaces.
- @favorite — The spaces you have marked as favourite.
- @favourite — The same as @favorite above.
- @all — All spaces in your Confluence site.
- * — The same as @all above.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com. |
| Label(s)                      | None specified i.e. display all content                                                                 | Filter the results by label. The macro will display only the pages etc which are tagged with the label(s) you specify here.

You can specify one or more label values, separated by a comma or a space.

- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of `-badpage` you will get only content which is not labelled with 'badpage'.

- To indicate that the results **must** match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of `+superpage,+goodpage` you will get only content which has at least two labels, being 'superpage' and 'goodpage'.

| Width of Table             | 100%                                                                                       | Specify the width of the macro display, as a percentage of the window width.

| Include these Content Types Only | All types                                                                 | This parameter allows you to filter content by content type. The macro will display only the content of the type you specify here.

You can specify one or more types, separated by a comma or a space.

To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of `-blogpost` you will get pages and all other content except for blog posts.

Available values:

- page — **Pages**.
- blogpost of news — **Blog posts**, also known as news items.
- comment — **Comments** on pages and blog posts.
- attachment — **Attachments**.
- status — **Status updates** made by other users.
| **Maximum Number of Results** | 15 | Specify the maximum number of results to be displayed. If this parameter is omitted, then a maximum of 15 results are displayed. The theoretical maximum value that this parameter can accept is 2 to the power of 31, minus 1 (or 2147483647), though this has been limited to 200 in the code, for performance reasons. More details are [here](https://confluence.atlassian.com/x/3Q3cB).

| **theme** | concise | Choose the appearance of this macro:
- **concise** — the default list, showing the names of pages which were updated or commented on, the users who made the page modifications and time when the modifications occurred.
- **social** — lists recent modifications in reverse chronological order, but groups them by user into short time segments. A ‘sub’ list appears within each user’s time segment, showing the names of pages which they updated or commented on and time when these modifications occurred.
- **sidebar** — lists recent updates in reverse chronological order, showing the names of pages which were updated or commented on and time when the page modifications occurred. This theme does not show authorship.

| **Show User Profile Pictures** | false | Specify `showProfilePic=true` to display the profile pictures of the users who updated the content.

**Notes**
- The Recently Updated Dashboard macro is similar to this macro, but is intended for display on the Confluence dashboard.
- If you would like to change the wording displayed by the Recently Updated macro, please refer to the document on modifying the Confluence interface text.

**Code examples**

See:
- Confluence Wiki Markup for Macros.
- Confluence Storage Format for Macros

Recently Used Labels Macro
The Recently Used Labels macro displays a list of the labels that have been most recently added to a page, blog post or attachment. You can define the number of labels to be displayed and the scope (the current space, your personal space or site spaces, also known as ‘global’ spaces).

**Using the Recently Used Labels macro**

**To add the Recently Used Labels macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Select and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters of this macro

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Labels to Display</td>
<td>10</td>
<td>Specifies the total number of labels to display in the list.</td>
</tr>
<tr>
<td>Scope for Retrieving Labels</td>
<td>global</td>
<td>Specifies the scope of labels to be displayed in the list. Valid values include:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>global</strong> — covers all site spaces (non-personal) in the Confluence installation.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>space</strong> — the current space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>personal</strong> — your own personal space.</td>
</tr>
<tr>
<td>List Style</td>
<td>list</td>
<td>• <strong>list</strong> — displays the list of labels horizontally.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>table</strong> — includes additional information such as the page to which the label was added and the user who added it.</td>
</tr>
<tr>
<td>Table Title</td>
<td>none</td>
<td>Adds a title to the top of the list in table style. Titles are only visible when the <strong>List Style</strong> parameter has been set to <strong>table</strong>.</td>
</tr>
</tbody>
</table>

### Code examples
See:

- Confluence Wiki Markup for Macros.
- Confluence Storage Format for Macros

Related Labels Macro

The Related Labels macro lists all labels from every page which has one or more labels in common with the current page.

Using the Related Labels Macro

To add the Related Labels macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

On this page:

- Using the Related Labels Macro
- Parameters
- Code examples

Related pages:

- Navigation Map Macro
- Content by Label Macro
- Recently Used Labels Macro
- Working with Confluence Labels
- Working with Macros
- Confluence User's Guide

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restrict to these Labels</td>
<td>none</td>
<td>Specify the labels for which you want to view related labels. For example, documentation, my:stuff.</td>
</tr>
</tbody>
</table>

Code examples

See:

- Confluence Wiki Markup for Macros.
- Confluence Storage Format for Macros

RSS Feed Macro

The RSS Feed macro embeds an RSS feed on a page. It can display the contents of external feeds, or of internal feeds generated by Confluence. To display blog posts or to list recently updated pages in a space, use the Feed Builder to create an internal feed, then render it using this macro.

⚠️ CAUTION: Including unknown HTML inside a webpage is dangerous.

HTML inside an RSS feed can contain active scripting components. This means that it would be possible for a malicious attacker to present a user of your site with script that their web browser would believe came from you. Such code could be used, for example, to steal a user's authentication cookie and give the attacker their Confluence login password.
The RSS Feed macro may be disabled by your Confluence administrator. Also, your Confluence administrator can define a whitelist of trusted URLs. You will see an error message on the Confluence page, if the included URL is not in the whitelist.

**Using the RSS Feed macro**

To add the RSS Feed macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**On this page:**

- Using the RSS Feed macro
- Parameters
- How up to date is the feed?
- What happens to a page containing a disallowed URL?
- Authentication
- Accessing internal HTTPS feeds
- Enabling and disabling the RSS Feed macro
- Code examples

**Related pages:**

- Subscribing to RSS Feeds within Confluence
- Managing Changes and Notifications and Tasks
- Working with Macros
- Configuring the Whitelist
- Confluence User’s Guide

⚠️ The information on this page does not apply to Confluence OnDemand.

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RSS Feed URL</td>
<td>none</td>
<td>The URL of the RSS feed link you want to show.</td>
</tr>
<tr>
<td>Maximum Number of Entries</td>
<td>15</td>
<td>Limit the number of entries displayed.</td>
</tr>
<tr>
<td>Show Item Titles Only</td>
<td>false</td>
<td>Show only the titles of the news items, not the content.</td>
</tr>
<tr>
<td>Show Name/Title of RSS Feed</td>
<td>true</td>
<td>Hide the feeds title bar.</td>
</tr>
</tbody>
</table>

**How up to date is the feed?**

By default, the RSS Feed macro caches the feed results for 60 minutes before fetching the data again.

If you wish to change the default caching, use the Cache macro to define how often the RSS Feed macro fetches the feed updates. You will need to install the Cache plugin onto your Confluence site.
What happens to a page containing a disallowed URL?

Your Confluence Administrator can set up a whitelist of allowed URLs. If this is the case, you may see an error on the pages which contain the RSS Feed macro.

A user can add the RSS Feed macro or the HTML-include macro to a Confluence page. The macro code includes a URL from which the content is drawn. When the page is displayed, Confluence will check the URL against the whitelist. If the URL is not allowed, Confluence will display an error message on the page.

The error message says that Confluence "could not access the content at the URL because it is not from an allowed source" and displays the offending URL. If the person viewing the page is a Confluence Administrator, they will also see a link to the Administration page where they can configure the URL whitelist.

Here is an example of the error message, including the link shown only to Confluence Administrators:

Could not access the content at the URL because it is not from an allowed source.
http://feathers.wordpress.com
Configure whitelist >>

Here is an example of the error message, but without the link.

Could not access the content at the URL because it is not from an allowed source.
http://feathers.wordpress.com
You may contact your site administrator and request that this URL be added to the list of allowed sources.

Authentication

Private feeds from external sites

RSS feeds which require authentication cannot be accessed using the RSS Feed macro.

Accessing internal HTTPS feeds

This applies only to Confluence instances which have enabled HTTPS for all content. If your site is fully HTTPS, the RSS Feed macro cannot access internal feeds. To enable the RSS Feed macro to access internal feeds without affecting your HTTPS setup, enable local-only HTTP access:

1. Shut down Confluence.
2. Consult the SSL guide to enable HTTP access to Confluence. You'll want to ensure that you have an HTTP connector and an SSL connector, both commented in. This means that Confluence will be accessible via both HTTP and HTTPS. However, you should not have a redirect port, nor rules in web.xml to redirect all traffic.
3. Instead of using web.xml to redirect traffic, insert a firewall rule to redirect all HTTP requests not from the Confluence server to the equivalent HTTPS URL. This ensures that users will only be able to access Confluence via HTTPS, as intended. If you have still left HTTP access for attachments enabled (to avoid the IE download bug) you must selectively enable those URLs as well.
4. Modify your Confluence RSS Feed macro feed link to use the HTTP URL, and restart Confluence.

Enabling and disabling the RSS Feed macro

The RSS Feed macro is a module of the Confluence HTML Macros plugin.

To enable or disable the RSS Feed macro:

1. Enable the Confluence HTML Macros plugin by following the instructions in Enabling HTML macros.
2. In the plugin module list of the HTML macros, find the RSS (rss-xhtml) module and hover your cursor over it to enable or disable it.

Code examples
See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Search Results Macro

The Search Results macro searches your Confluence site based on search terms specified in the macro parameters, and displays the results on the wiki page.

*Using the Search Results macro*

**To add the Search Results macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Terms</td>
<td>none</td>
<td>The search terms which this macro will use to generate its results. You can refine your search query by using operators such as 'AND' and 'OR'. For example: my_query1 AND my_query2. For more information, take a look at the documentation on the Confluence search syntax.</td>
</tr>
<tr>
<td>Maximum Number of Results</td>
<td>10</td>
<td>Set a limit to the number of search results displayed.</td>
</tr>
<tr>
<td>Restrict to this Space Key</td>
<td>all</td>
<td>Start typing the space name to find the space, or specify the key of the space you want to search in. Note that the key is case sensitive.</td>
</tr>
<tr>
<td>Content Type</td>
<td>all</td>
<td>Specify the content type. The content types are: page, comment, blogpost, attachment, user info (the content of user profiles only) and spacedesc (the content of space descriptions only).</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Last Modified      | all | Specify a period of time in weeks, days, hours and/or minutes, to see the content modified within that time frame. These are the values you can use:  
  • w = weeks  
  • d = days  
  • h = hours  
  • m = minutes  
  For example:  
  • 2h 35m  
  • 3d 30m  
  Notes:  
  • If no time category is specified, Confluence assumes minutes.  
  • If you specify more than one time period (for example, weeks and days), you must separate the periods with a space. You can put them in any order.  
  • The time categories are not case sensitive. For example, '4d' is the same as '4D'. |
| Restrict to this Username | all | Specify the username of a Confluence user, to show only content created or updated by that user. |

**Notes**

**Permissions:** When a user views the page containing the Search Results macro, the search results will show only pages and other content types for which the user has 'View' permission.

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Section Macro

Used with the Column macro to define columns on a page. See Working with page layouts and columns and sections.

Space Attachments Macro

See Displaying a List of Attachments.

Space Details Macro

The Space Details macro displays the details of a Confluence space, including the space name, description, and
Using the Space Details macro

To add the Space Details macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type {} and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

On this page:
- Using the Space Details macro
- Parameters
- Code examples

Related pages:
- Editing Space Details
- Working with Macros
- Confluence User's Guide

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width of Table</td>
<td>100%</td>
<td>The width of the space details table, specified as a percentage (%) of the page width.</td>
</tr>
</tbody>
</table>

Code examples

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Space Jump Macro

This page describes the Space Jump macro, which is provided with the Documentation theme. You can use space jumping to link from a page in one space to a page with the same name in another space, without knowing the name of the page when you create the link.

Advance warning of plans to merge Documentation theme with the default theme

This is an advance notice that we plan to merge the functionality of the Confluence Documentation theme with the Confluence default theme. We do not yet have a specific date for this plan, and we are interested in your feedback. The new default theme, introduced with Confluence 5.0, includes a sidebar with contextual navigation. Our plan is to include features from the Documentation theme in the default theme, and then remove the Documentation theme from Confluence.

If you are interested in this change and would like to give us feedback, please add a comment on this blog post: Advance warning of plans to merge Documentation theme with the default theme. We are especially interested to know which features of the Documentation theme you use and value the most.

The Space Jump macro inserts a link onto the page. When the reader clicks the link, they will jump to a page that has the same name in another space. You specify the space when you insert the Space Jump macro.

Example: We use the Space Jump macro to put a standard message at the top of our archive spaces, telling people that they’re reading an old version of the documentation and letting them jump quickly to the same page in the latest documentation. See the words ‘this page in the current documentation’ in the screenshot below.
Using the Space Jump macro

To add the Space Jump macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>None</td>
<td>The space key that contains a page with the same page title that you want the link to jump to. Space keys are case-sensitive.</td>
</tr>
<tr>
<td>Alias</td>
<td>None</td>
<td>The text to display as the hyperlinked text. If you do not supply an alias, Confluence will display the page name.</td>
</tr>
</tbody>
</table>

Notes

What happens if there is no page with the same name in the target space?

For the space jump to work, the target space must contain a page with the same name as the page that renders the Space Jump macro. If the target space does not contain such a page, you will see a broken link. Confluence handles this in its usual manner: the link is coloured red. If you click the link, Confluence offers to create the page for you.

Can I use the Space Jump macro in any space?

Yes. You can use the Space Jump macro in any space, even if that space is not currently using the
Documentation theme. Provided that the Documentation theme plugin and its components are installed and enabled on your Confluence site, the Space Jump macro is available in any space.

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Spaces List Macro**

The Spaces List macro displays a list of spaces, similar to the list of spaces seen on the dashboard.

**Using the Spaces List macro**

To add the Spaces List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scope of spaces</td>
<td>no</td>
<td>all</td>
<td>The view from which spaces are listed. Available options are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• all – All spaces in the Confluence installation.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• category – Spaces grouped according to space categories.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• favourite – Spaces which you have added to your favourites list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• new – New spaces which have been created within the last 7 days.</td>
</tr>
</tbody>
</table>
### Width of List

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width of List</td>
<td>no</td>
<td>100% The width of the spaces list, specified as a percentage (%) of the window width.</td>
</tr>
</tbody>
</table>

### Notes

There is a bug in this macro that prevents people from selecting a space category. For details, please refer to this issue:

- CONF-26597 - Changing category in Space List macro generates wrong URL (Resolved)

### Code examples

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

### Status Macro

The Status macro displays a coloured lozenge (a rounded box) that is useful for reporting project status. You can choose the colour of the lozenge and the text that appears inside the lozenge. The macro also displays its current status in the editor, and you can change the status directly in the editor.

**ALL GOOD!**

Screenshot: Click on the Status macro lozenge to change the status.

### Using the Status macro

To add the Status macro to a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Colour | Grey | The colour of the lozenge. The following colours are available: Grey, Red, Yellow, Green and Blue.
---|---|---
Title | The colour that you select. | The text that will appear inside the lozenge. If you do not specify any text, the title will be the colour of the lozenge, that is 'Grey', 'Red', 'Yellow', 'Green' or 'Blue'.
Use outline style | No | The style of the lozenge and its border. The default style lozenge is a solid background colour with white text. The outline style lozenge is white with a coloured border and coloured text as shown here.

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Table of Contents Macro**

The Table of Contents macro scans the headings on the current Confluence page to create a table of contents based on those headings. This helps readers find their way around lengthy pages, by summarising the content structure and providing links to headings.

**Using the Table of Contents macro**

**Hint:** For quick access from the editor toolbar, choose Insert > Table of Contents.

**To add the Table of Contents macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**On this page:**

- Using the Table of Contents macro
- Macro parameters
- Examples
- Notes
- Code examples

**Related topics:**

- Table of Content Zone Macro
- Page Tree Macro
- Using the Documentation Theme
- Working with Macros
- Confluence User's Guide

**Macro parameters**
Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Output Type**               | list    | • list — produces a typical list-type table of contents.  
                               |                                    | • flat — produces a horizontal menu-type series of links.                           |
| **Display Section Numbering**| clear   | Select the check box to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.                                               |
| **List Style**                | disc    | Select the style of bullet point for each list item. You can use any valid CSS style. For example:  
                               |                                    | • none — no list style is displayed  
                               |                                    | • circle — the list style is a circle  
                               |                                    | • disc — the list style is a filled circle. This is the typical bullet list, and is used for this example list.  
                               |                                    | • square — the list style is a square  
                               |                                    | • decimal — the list is numbered (1, 2, 3, 4, 5)  
                               |                                    | • lower-alpha — the list is lower-case, alphabetised (a, b, c, d, e)  
                               |                                    | • lower-roman — the list style is lower roman numerals (i, ii, iii, iv, v, vi)  
<pre><code>                           |                                    | • upper-roman — the list style is upper roman numerals (I, II, III, IV, V, VI) |
</code></pre>
<p>| <strong>Heading Indent</strong>            |         | Sets the indent for a list according to CSS quantities. Entering 10px will successively indent heading groups by 10px. For example, level 1 headings will be indented 10px and level 2 headings will be indented an additional 10px. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Separator</td>
<td>brackets</td>
<td>This parameter applies to flat lists only. You can enter any of the following values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• brackets — Each item is enclosed by square brackets: [ ].</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• braces — Each item is enclosed by braces: { }.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• parens — Each item is enclosed by parentheses: ( ).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• pipe — Each item is separated by a pipe:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• anything — Each item is separated by the value you enter. You can enter any text as a separator, for example &quot;**&quot;. If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters.</td>
</tr>
<tr>
<td>Minimum Heading Level</td>
<td>1</td>
<td>Select the highest heading level to start your TOC list. For example, entering 2 will include levels 2, and lower, headings, but will not include level 1 headings.</td>
</tr>
<tr>
<td>Maximum Heading Level</td>
<td>7</td>
<td>Select the lowest heading level to include. For example, entering 2 will include levels 1 and 2, but will not include level 3 headings and below.</td>
</tr>
<tr>
<td>Include Headings</td>
<td></td>
<td>Filter headings to include according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings.</td>
</tr>
<tr>
<td>Exclude Headings</td>
<td></td>
<td>Filter headings to exclude according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings.</td>
</tr>
<tr>
<td>Printable</td>
<td>checked</td>
<td>By default, the TOC is set to print. If you clear the check box, the TOC will not be visible when you print the page.</td>
</tr>
<tr>
<td>CSS Class Name</td>
<td></td>
<td>If you have custom TOC styles in your CSS style sheet, use this parameter to output the TOC inside &lt;div&gt; tags with the specified class attribute.</td>
</tr>
</tbody>
</table>
Examples

The examples below are based on this table of contents:

- Places
  - Favourite Places
  - Unknown Places
- Foods
  - Favourite Foods
  - Unknown Foods
- Things
  - Favourite Foods
  - Unknown Foods

Filtered Table of Contents

This example filters the headings to include those that contain 'Favourite', but excludes headings which end with 'Things'. The list is styled with Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
<tr>
<td>Exclude Headings</td>
<td>.*Things</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

I. Favourite Places
II. Favourite Foods

Flat List

This example filters all headings to render a flat list of 'Unknowns' enclosed in square brackets (the default list style).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Maximum Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

[ Unknown Places ] [ Unknown Foods ] [ Unknown Foods ]

Notes

- When you use a Table of Contents macro in a template, you will see an error when you preview the template itself. But the Table of Contents macro works on the pages that people create from the
template – the table of contents shows up after they have saved the page. (This is probably because the template is not defined as a page, and the Table of Contents macro works for pages only.)

- Due to an outstanding issue in the Table of Contents macro (CONF-10619), the macro browser’s Refresh function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Contents macro occurs only after the page is saved.

- **Using HTML heading markup with the Table of Contents macro**
  The Table of Contents macro cannot handle HTML heading markup on its own. Hence, if you use the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Contents macro will not create a contents list out of these headings. (For more information about this issue, please refer to TOC-93.)
  However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Contents macro will incorporate these headings into your contents list.

```html
<h2><a name="pagename-headingname"></a>Heading Name</h2>
```

The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.

**Code examples**

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Table of Content Zone Macro**

You can use the Table of Content Zone macro to mark out a section (zone) within the page from which to create a table of contents. You can style the headings as a flat list, and place the list of links at the top and bottom of the section or page, to provide navigation bars similar to web navigation.

**Using the Table of Content Zone macro**

To add the Table of Content Zone macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**On this page:**
- Using the Table of Content Zone macro
- Parameters
- Examples
- Notes
- Code examples

**Related pages:**
- Table of Contents Macro
- Page Tree Macro
- Working with Macros
- Confluence User's Guide

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>location</td>
<td>both</td>
<td>Specifies where in the zone the output list is displayed: <strong>top</strong>, <strong>bottom</strong>, or <strong>both</strong>, which encloses the page zone content.</td>
</tr>
<tr>
<td>Output Type</td>
<td>list</td>
<td>Specifies the layout for the table of contents:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>list</strong> – produces a vertical list, typical of a TOC.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>flat</strong> – produces a horizontal menu-type series of links, for example: [Heading 1] [Heading 2] [Heading 3].</td>
</tr>
<tr>
<td>Display Section Numbering</td>
<td>false</td>
<td>Select to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.</td>
</tr>
<tr>
<td>List Style</td>
<td>none</td>
<td>Specifies the style of bullet point for each list item. You can use any valid CSS style. For example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>none</strong> — no list style is displayed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>circle</strong> — the list style is a circle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>disc</strong> — the list style is a filled circle. This is the typical bullet list, and is the one we’re using for this example list</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>square</strong> — the list style is a square</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>decimal</strong> — the list is numbered (1, 2, 3, 4, 5)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>lower-alpha</strong> — the list is lower-case, alphabetised (a, b, c, d, e)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>lower-roman</strong> — the list style is lower roman numerals (i, ii, iii, iv, v, vi)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>upper-roman</strong> — the list style is upper roman numerals (I, II, III, IV, V, VI)</td>
</tr>
<tr>
<td>Heading Indent</td>
<td></td>
<td>Sets the indent for a list output type, according to CSS quantities. Entering &quot;10px&quot; will successively indent list heading levels by 10px. For example, h1 headings will be indented 10px and h2 headings will be indented an additional 10px.</td>
</tr>
</tbody>
</table>
### Separator

<table>
<thead>
<tr>
<th><strong>Separator</strong></th>
<th><strong>brackets</strong></th>
<th>Only applies to the flat output type. Specifies the display style of the links. You can enter any of the following values:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>- <strong>brackets</strong> — Each item is enclosed by square brackets: <code>[ ]</code>.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>braces</strong> — Each item is enclosed by braces: <code>{ }</code>.</td>
</tr>
</tbody>
</table>
|               |             | - **parens** — Each item is enclosed by parentheses: `()`.
|               |             | - **pipe** — Each item is separated by a pipe: |
|               |             | - **anything** — Each is separated by the value you enter. You can enter any text as a separator, for example "***". If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters. |

### Minimum Heading Level

| **Minimum Heading Level** | 1 | Select the largest heading level to start your TOC list. For example, 2 will list h2, h3, and h4 headings, but will not include h1 headings. |

### Max Heading Level

| **Max Heading Level** | 7 | Select the smallest heading level to include in the TOC. For example, 2 will list h1 and h2, but will not include h3 and below. |

### Include Headings

| **Include Headings** | Filter the included headings according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings. |

### Exclude Headings

| **Exclude Headings** | Exclude headings according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings. |

### Printable

| **Printable** | true | By default, the TOC is set to print. If you clear this parameter, the TOC will not be visible when you print the page. |

### CSS Class Name

| **CSS Class Name** | If you have a custom TOC in your CSS style sheet, you can use this parameter to output the TOC with the specified "class" attribute. |

---

**Examples**

The examples are based on a page with the following headings:
Filtered Table of Contents

This example will filter all headings to include those that contain "Favourite", but will exclude any heading which ends with the word "Things". The list is styled with upper-case Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>list</td>
</tr>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
<tr>
<td>Exclude Headings</td>
<td>.*Things</td>
</tr>
</tbody>
</table>

Screenshot: Filtered TOC 'zone' headings

I.  Favourite Places  
II.  Favourite Foods

Flat List

This example will filter all headings to render a flat list of "Unknowns" enclosed in square brackets.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Separator</td>
<td>brackets</td>
</tr>
<tr>
<td>Max Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

Screenshot: Filtered TOC 'zone' headings displayed as a flat list

[ Unknown Places ] [ Unknown Foods ] [ Unknown Foods ]

Notes

- Due to an outstanding issue in the Table of Content Zone macro (CONF-10619), the Macro Browser's Ref resh function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Content Zone macro occurs only after the page is saved.
- Using HTML heading markup with the Table of Content Zone macro — The Table of Content Zone macro cannot handle HTML heading markup on its own. Hence, if you used the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Content Zone macro will not create a contents list out of these headings. (For more information on about this issue, please refer to TOC-93.)
However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Content Zone macro will incorporate these headings into your contents list.

```
<h2><a name="pagename-headingname"></a>Heading Name</h2>
```

The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Tasklist Macro**

The Tasklist macro adds a list of tasks to the wiki page. Users viewing the page can modify the tasks without having to edit the page, provided they have the required permissions to modify the page.

You may also be interested in the lightweight task list that you can add directly onto your page, via the editor insert menu. This method also allows you to notify users that tasks have been assigned to them. See Managing Tasks in Confluence.

**Using the Tasklist macro**

**To add the Tasklist macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>'Task List'</td>
<td>The name of the task list. This is displayed as the title above the list of tasks.</td>
</tr>
<tr>
<td>Width of List</td>
<td>530px</td>
<td>The width of the task list.</td>
</tr>
</tbody>
</table>
Enable Locking | clear | When selected, you can lock individual tasks so that they cannot be changed. See instructions below on editing the task list.

Prompt on Delete | clear | When selected, the user must confirm the deletion of a task in the list.

**Editing the task list while viewing a page**

While viewing a page, you can change the tasks in a task list as follows:

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a task</td>
<td>Type the task description in the box under the list title, and click Add.</td>
</tr>
<tr>
<td>Completing/uncompleting a task</td>
<td>Click the check box next to a task to mark the task as complete. The task name will become a lighter color and the progress bar will be updated. Clear the check box to mark the task as uncompleted. You can also click Uncheck all to mark all tasks as uncompleted.</td>
</tr>
<tr>
<td>Editing a task</td>
<td>Move your cursor over the task and click the edit icon (pencil) that appears to the right of the task. The task name will become editable and the edit icon will be replaced with a save icon. Make your change and press the ‘Enter’ key to save or click the save icon.</td>
</tr>
<tr>
<td>Deleting a task</td>
<td>Move your cursor over the task and click the delete icon (trash can) that appears to the right of the task.</td>
</tr>
<tr>
<td>Viewing details of a task</td>
<td>Click the arrow icon to the left of the task name. The task details will open in an expanded view.</td>
</tr>
<tr>
<td>Locking a task</td>
<td>Provided that the Enable Locking parameter has been selected, you can click the lock icon to prevent the task from being edited, deleted, or otherwise changed.</td>
</tr>
<tr>
<td>Changing the priority</td>
<td>When the task details are visible, click the appropriate option — High, Medium or Low.</td>
</tr>
<tr>
<td>Assigning the task</td>
<td>When the task details are visible, change the assignee of the task by typing in or searching for a username.</td>
</tr>
</tbody>
</table>

**Screenshot: Task list showing task details**
Sorting the tasks

There are two ways to sort the tasks in the list:

- Using the Sort by list.
- Using drag and drop.

Select one of the sort options from the 'Sort by' list:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom</td>
<td>This is the default option.</td>
</tr>
<tr>
<td>Priority</td>
<td>Sort the list in order of the priority you have allocated to each task.</td>
</tr>
<tr>
<td>Date Created</td>
<td>Sort the list in order of the dates upon which the tasks were created.</td>
</tr>
<tr>
<td>Completed</td>
<td>Move all completed tasks to the bottom or top of the list.</td>
</tr>
<tr>
<td>Name</td>
<td>Sort the list in order of the task names.</td>
</tr>
<tr>
<td>Assignee</td>
<td>Sort the list in order of the usernames assigned to the tasks.</td>
</tr>
</tbody>
</table>

Once you have selected a sort option, use the icon beside the Sort by box to reverse the sort order.

Dragging and dropping a task into a new position:

Drag a task up or down the list using the 'drag me' handle to the right of the task name. Make sure the task is positioned to the left of the existing tasks. A space will open and you will be able to drop the task into its new position.

Viewing the progress on tasks completed

The bar at the top of the task list displays two different colours, indicating the percentage of tasks completed.

Screenshot: Progress Bar on Task List
Notes

- It is not possible to add a due date to the task list. If you interested in this improvement request, you can comment on or vote for this issue:

  ![CONF-7371 - Dynamic Tasklist macro - add due date for tasks](Open)

- The Tasklist macro does not notify users that a task has been assigned to them. But you can do that using the lightweight task list accessible from the editor tool bar. See Managing Tasks in Confluence.

Code examples

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Tip Macro

Using the Tip macro, you can highlight a helpful tip on a Confluence page. The macro creates a green-coloured box surrounding your text as shown below.

**Tip Macro Example**

This text is displayed inside the tip macro.

Using the Tip macro

To add the Tip macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>The title of the tip. If specified, it will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>Show Tip Icon</td>
<td>true</td>
<td>If cleared, the icon will not be displayed.</td>
</tr>
</tbody>
</table>

Code examples

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

User List Macro

The User List macro displays a list of users registered in Confluence, based on their group membership.

Using the User List macro

To add the User List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group(s)</td>
<td>none</td>
<td>Specifies one or more groups whose Confluence users you want to list, using a comma-separated list of group names. To see all users registered in a Confluence installation, specify an asterisk (*) for this parameter's value.</td>
</tr>
<tr>
<td>Display Online/Offline Users</td>
<td>All registered users</td>
<td>Select to generate a list of online users. Clear to generate a list of offline users. In order to make this feature functional, a System Administrator needs to enable the User Log In Listener for your Confluence site. Not applicable to Confluence OnDemand.</td>
</tr>
</tbody>
</table>

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**User Profile Macro**

The User Profile macro displays a short summary of a given Confluence user's profile. This is the same summary that appears in a Hover Profile, which appears whenever you mouse over a user's name in the Confluence interface.

**Screenshot: Example of the User Profile macro**

```
Leah Admin
sample@email.com.au

"Updating Confluence documentation"

**Position:** Tech Writer
**Department:** Department of Awesome
**Location:** Atlassian, Sydney
```

**On this page:**
- Using the User Profile macro
- Parameters
- Code examples

**Related pages:**
- Working with Macros
- User Profile Overview
- Confluence User's Guide

**Using the User Profile macro**

To add the User Profile macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open,
where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>none</td>
<td>The username of the Confluence user whose profile summary you wish to show.</td>
</tr>
</tbody>
</table>

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**User Status List Macro**

The User Status List macro displays a history of a given Confluence user’s status updates. This is the same history that appears in the user’s Status Updates view.

*Screenshot: Example output of the User Status List macro*

```
“Time to look at networks
Clear · Delete · Feb 15, 2013
```

```
“Updating my profile picture
Delete · Feb 15, 2013
```

```
“Making Confluence sing...
Delete · Feb 15, 2013
```

**On this page:**
- Using the User Status List macro
- Parameters
- Notes
- Code examples

**Related pages:**
- Working with Macros
- User Status Updates
- Confluence User’s Guide

**Using the User Status List macro**

To add the User Status List macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output.
### Parameter

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>none</td>
<td>The username of the Confluence user whose history of status updates you wish to show.</td>
</tr>
</tbody>
</table>

**Notes**

**Hint:** If you wish to list status updates made by more than one user, you can use the Recently Updated macro with the following parameter values:

- **Include these Content Types Only:** status
- **Author(s) by username:** The user(s) whose status updates you want to include in the list. If you leave this field blank, the status updates of all users will be included.

**Code examples**

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**View File Macro**

The View File macros allow you to embed an Office or PDF document into your Confluence page. First attach the document to a page and then use one of the View File macros to display the document's content.

When people view the page, they will see the content of the Office or PDF document. They do not need to have Office installed in order to see the content of an Office document. If they do have Office installed, people will be able to open the document for editing in their Office application.

For a full list of Office Connector prerequisites and limitations, please refer to:

- Office Connector Prerequisites
- Office Connector Limitations and Known Issue

For an overview of all Office Connector features, please refer to Working with the Office Connector.

**On this page:**

- Displaying an Office or PDF Document in Confluence
- Parameters for the Office and PDF macros
- Editing an Office document
- Troubleshooting
- Code examples

**Related pages:**

- Working with the Office Connector
- Working with Macros
- Confluence User's Guide

**Displaying an Office or PDF Document in Confluence**

To display an Office or PDF document in a page, use one of the following View File macros in the macro browser:

- Office Excel
- Office PowerPoint
- Office Word
- PDF

**To add one of the View File macros to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters for the Office and PDF macros**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Macro</th>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All View File macros</td>
<td><strong>Page Name</strong></td>
<td>The page which contains the macro</td>
<td>Enter a page name, if you wish to display a document which is attached to another Confluence page.</td>
</tr>
<tr>
<td></td>
<td><strong>File Name</strong></td>
<td>none</td>
<td>The file name of the Office or PDF document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>Office Excel</td>
<td><strong>Show Grid?</strong></td>
<td>true</td>
<td>Select to show grid lines around each cell of the Excel spreadsheet. Clear to hide these grid lines.</td>
</tr>
<tr>
<td></td>
<td><strong>Worksheet Name</strong></td>
<td>Last worksheet viewed in the spreadsheet</td>
<td>The name of the worksheet that you want displayed.</td>
</tr>
<tr>
<td></td>
<td><strong>Last Row</strong></td>
<td>Last row with content</td>
<td>The number of the last row you want displayed, starting from '0' as the first row.</td>
</tr>
<tr>
<td></td>
<td><strong>Last Column</strong></td>
<td>Last column with content</td>
<td>The number of the last column you want displayed, starting from '0' as the first column.</td>
</tr>
<tr>
<td>Office PowerPoint</td>
<td><strong>Height</strong></td>
<td></td>
<td>Specify the height of the display, in pixels (default) or as a percentage of the window's height.</td>
</tr>
</tbody>
</table>
**Editing an Office document**

You can launch your Office application and edit Office documents displaying in the view file macros directly from your Confluence page.

- **Word** and **Excel** - choose the **Edit Document** link above the content
- **PowerPoint** - choose the edit icon on the viewer.

You will find more information and other methods for editing attached Office documents in [Editing an Office Document from Confluence](#).

**Troubleshooting**

Problems? Please refer to our guide to the [Office Connector limitations and known issues](#).

**Code examples**

Office Excel macro:

- [Confluence Wiki Markup for Macros](#)
- [Confluence Storage Format for Macros](#)

Office PowerPoint macro:

- [Confluence Wiki Markup for Macros](#)
- [Confluence Storage Format for Macros](#)

Office Word macro:

- [Confluence Wiki Markup for Macros](#)
- [Confluence Storage Format for Macros](#)

**PDF macro:**

- [Confluence Wiki Markup for Macros](#)
- [Confluence Storage Format for Macros](#)

**Warning Macro**

The Warning macro is useful for highlighting a warning on a Confluence page. The macro creates a red-coloured box surrounding your text as shown below.

[Warning Macro Example](#)

**Using the Warning macro**

To add the Warning macro to a page:
1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### On this page:
- Using the Warning macro
- Parameters
- Code examples

### Related pages:
- Working with Macros
- Confluence User’s Guide

### Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>The title of the warning note. If specified, will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>Show Warning Icon</td>
<td>true</td>
<td>If &quot;false&quot;, the icon will not be displayed.</td>
</tr>
</tbody>
</table>

### Code examples

See:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Widget Connector Macro**

The Widget macro, or Widget Connector, allows you to embed certain multimedia content from other web sites into your Confluence page.

It supports the following content:

- Gadgets and other widgets: Google Gadgets, Widgetbox.
- Videos: YouTube, MySpace Video, Yahoo Video, Dailymotion, Episodic, Vimeo, Metacafe, blip.tv, Viddler.
- Photos and images: Flickr, Skitch.com.
- Micro-blogging: Twitter, FriendFeed, BackType.
- Documents and presentations: SlideShare, SlideRocket, Scribd, presentations on Google Docs. **Note:** The integration with Google Docs is currently broken. Please refer to CONF-24927 for details of the issue.
- Calendars: Google Calendar.
- Forms and online databases: Wufoo HTML Form Builder and Wufoo Reports.
- Support and customer satisfaction: Get Satisfaction.

There are live examples of many of these on the **widget examples page**. If you wish to extend the functionality of this plugin, please see **Extending the Widget Connector**.
Using the Widget Connector

To add the Widget Connector to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web Site's Widget URL</td>
<td>This is the URL provided by the external web site for embedding content from that web site onto another web page.</td>
</tr>
<tr>
<td>Pixel Height (Value Only)</td>
<td>Specify the height of the display, in pixels.</td>
</tr>
<tr>
<td>Pixel Width (Value Only)</td>
<td>Specify the width of the display, in pixels.</td>
</tr>
</tbody>
</table>

Examples of macro sources

Google Gadgets

You need to find the URL for the Google Gadget you want to display.

Here is one way to find a gadget's URL:

1. Go to the Google Gadgets directory.
2. Find the gadget you want then click its name, such as 'Spider'.
3. The gadget's summary page will open. Copy the URL from your browser's address bar. The URL looks something like this one:


You can also use the URL of the 'add gadget' page. The page is called 'Add "gadgetx" to your iGoogle page':

1. There are a couple of ways to get to the 'add gadget' page:
   - Click a '+Google' button underneath the gadget when displayed on a page somewhere.
   - Or click 'Add Stuff' on your iGoogle page.
2. Copy the URL from your browser's address bar. The URL would look something like this one:
Widgetbox widgets

You will need to find the URL for the Widgetbox widget you want to display.

Here is one way to find a widget's URL:

1. Ensure you are logged in to Widgetbox and that you are viewing the Widgetbox Gallery.
2. Find the widget you want then click its name, such as 'cyber-pet'.
3. The widget's summary page will open. Within the Get Widget section, click the Atlassian Confluence icon required for the Widget Macro.
4. In the Widgetbox Add to Confluence dialog box, click Copy.
5. Copy the URL from your browser's address bar. The URL looks something like this one:

   http://widgetbox.com/confluence/b8327e33-c8eb-4a38-b842-fba866ffdd28

YouTube

You will need to find the URL for the YouTube video that you want to display.

To find a YouTube video's URL:

1. Go to YouTube and search for the video you want.
2. Click the title of the video, such as 'Wikis in Plain English'.
3. The video's summary page will open on YouTube. Choose Share.
4. Choose Options, located under the video's URL. Choose Long link, then copy the long URL. It looks something like this:

   http://au.youtube.com/watch?v=-dnL00TdmLY

   **Note:** You must use the long YouTube URL. The shortened URL (like this one: http://www.youtu.be/<video_key>) does not work in the widget connector. If you are unable to view the video in some browsers, use https: rather than http in your link.

MySpace Videos

You will need to find the URL for the MySpace video that you want to display.

To find a MySpace video's URL:

1. Go to MySpace Video and search for the video you want.
2. Click the title of the video, such as 'Glacier Creek Confluence Time Lapse'.
3. The video's summary page will open. Copy the URL from your browser's address bar. The URL looks something like this one:

   http://vids.myspace.com/index.cfm?fuseaction=vids.individual&videoid=3376248&searchid=20c789f6-1ae9-459a-bfec-75ecfc2847c

Yahoo Video
You will need to find the URL for the Yahoo video that you want to display.

To find a Yahoo video's URL:

1. Go to Yahoo Video and search for the video you want.
2. Click the title of the video, such as ‘Wiki Technology Trend: Past, Now and Future’.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:

   http://video.yahoo.com/watch/423158/2424140

   If you are unable to obtain a unique URL from your browser’s address bar, click the envelope (Share) icon on the lower section of the video screen and copy the contents of the Link field.

Dailymotion Video

You will need to find the URL for the Dailymotion video that you want to display.

To find a Dailymotion video’s URL:

1. Go to Dailymotion and search for the video you want.
2. Click the title of the video, such as ‘Wiki Technology Trend: Past, Now and Future’.
3. The video’s summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:

   http://www.dailymotion.com/user/spacevidcast/video/x7zevj_spacevidcast-2009-promo-video_tech

   If you are unable to obtain a unique URL from your browser's address bar, click Menu at the lower right section of the video screen, select URL & Embed Code and copy the contents of the Link field.

Episodic

You will need an Episodic user account if you want to create and distribute videos via Episodic.

To embed an Episodic video onto a Confluence page:

1. Find the video and copy the URL from the address bar of your browser. The URL looks something like this:

   http://app.episodic.com/shows/13/episodes/493

2. Paste the URL into the Web Site's Widget URL box in the Macro Browser.

Vimeo

You will need to find the URL for the Vimeo video that you want to display.

To find a Vimeo video’s URL:

1. Go to Vimeo and search for the video you want.
2. Click the title of the video, such as ‘The Wiki Show - Allison the Russian High Kicker’.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.vimeo.com/909808

Metacafe

You will need to find the URL for the Metacafe video that you want to display.

To find a Metacafe video’s URL:
1. Go to Metacafe and search for the video you want.
2. Click the title of the video, such as 'Wikis In Plain English (How To)'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.metacafe.com/watch/679493/wikis_in_plain_english_how_to/

blip.tv

This integration is currently broken. Please refer to CONF-27266 for details of the issue.

Viddler

This integration is currently broken. Please refer to CONF-27267 for details of the issue.

Flickr

You can embed a slide show of photos from Flickr by supplying a URL that specifies one of the following:

- Photos with a specific tag.
- Photos belonging to the photostream of a specific Flickr user.
- A set of photos as defined by the Flickr user.
- A user's photostream starting at a specific photo.

If you want to do something else, we suggest that you try any Flickr URL. It should work.

Below are some examples of the Widget macro code for embedding Flickr images.

Flickr Photos with a Specific Tag

This URL displays a slide show of Flickr photos that are tagged with the word 'Atlassian' http://www.flickr.com/photos/tags/atlassian/

Flickr Photos from a Specific User

This URL displays a slide show of photos from the Flickr photostream of user 'Atlassian': http://www.flickr.com/photos/atlassian/

Flickr Photos from a Specific Set

This URL displays a slide show of Flickr photos from the set 'Melbourne Cup - November 2008' created by user 'Atlassian': http://www.flickr.com/photos/atlassian/sets/72157608657271078/

A Specific Flickr Photo

This URL displays a slide show of photos from the Flickr photostream of the user 'Atlassian', starting with a specific photo: http://www.flickr.com/photos/atlassian/3003538919/

Skitch.com

You will need to find the URL for the Skitch image that you want to display.

To embed a Skitch image onto a Confluence page:

2. Find the image and copy the URL from the address bar of your browser. The URL looks something like this:

   http://skitch.com/atlassian/411g/example-image

   Note: Skitch is now integrated with Evernote, as described in this blog post from The Next Web: Evernote is bringing Skitch into its core service, Skitch.com will be archived. As a result, private images on Skitch.com are no longer accessible and will not work in the Confluence widget connector. Existing public images on Skitch.com will remain available.

Twitter
Note: Due to a recent change to the Twitter API, the process for displaying Tweets has changed. The following instructions relate to v 2.1.6 of the Widget Connector plugin. Earlier versions of the Widget Connector no longer display tweets correctly.

To embed a single tweet:

1. In Twitter, navigate to the tweet you wish to embed and choose Details to display just that tweet in your browser.
2. Copy the page URL (the URL should be in the following format, https://twitter.com/atlassian/status/346976521250037760).
3. In Confluence, paste the URL into the Widget Connector.
4. The single tweet will display, like the one below.

![Single Tweet Example](image)

To embed a dynamic list of tweets:

1. In Twitter, create a Widget (go to Settings > Widgets).
2. Configure the widget to display the tweets you wish to embed (for example, a user timeline, list of tweets or hashtag search).
3. Save the widget, then copy the page URL (the URL should be in the following format, https://twitter.com/settings/widgets/354381809263472640/edit)
4. In Confluence, paste the URL into the Widget Connector.
5. The list of tweets will display, like the one below.

![Dynamic Tweet List Example](image)

FriendFeed

To display the latest messages from a FriendFeed user, add the user's FriendFeed link as the URL in the FriendFeed Widget macro. For example:

BackType
To display the latest blog or website comments from a BackType user, add the user's BackType widget link as the URL in the Widget macro. For example:

SlideShare

You will need to find the URL for the SlideShare presentation that you want to display.

To find a SlideShare presentation’s URL:

1. Go to SlideShare and search for the presentation you want.
2. Click the title of the presentation, such as 'Using JIRA & Greenhopper for Agile Development'.
3. The presentation's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.slideshare.net/jleyser/using-jira-greenhopper-for-agile-development-presentation

SlideRocket

You will need to find the URL for the SlideRocket presentation that you want to display.

To find a SlideRocket presentation’s URL:

1. Log in to SlideRocket and go to your library of presentations.
2. Copy the 'web link' for the presentation you want to display. This will give you a URL that looks something like this one:

   http://app.sliderocket.com/app/FullPlayer.aspx?id=132f9db7-b0fb-4f51-b974-36652774971b

3. Paste the URL into the Widget macro code on your Confluence page.

Scribd

You will need to find the URL for the Scribd presentation that you want to display.

To find a Scribd presentation’s URL:

1. Go to Scribd and search for the presentation you want.
2. Click the title of the presentation, such as 'My Sea Friends Coloring Book'.
3. The presentation's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:


4. Paste the URL into the Widget macro code on your Confluence page.

Google Docs Presentations

This integration is currently broken. Please refer to CONF-24927 for details of the issue.

Google Calendar

You can embed a Google Calendar into your page and to do this, you will need to add the URL for the Google Calendar that you want to display.

To find the URL for a Google Calendar:

1. Log in to Google Calendar.
2. In the calendar list on the left side of the page, ensure the appropriate calendar is selected, click the down-arrow button next to the calendar name and then select the Calendar settings option. (Alternatively, if available, click the Manage Calendars link at the bottom of the calendar list and then click the name of the appropriate calendar.)
3. In the Calendar Address section, click the HTML button. A pop-up message with your calendar's public
URL appears.
4. Copy the URL from this pop-up message. The URL looks something like this:

   http://www.google.com/calendar/embed?src=somebody@example.com&ctz=Australia/Sydney

5. Paste the URL into the Widget macro code on your Confluence page.

Wufoo HTML Form Builder

To display an HTML form built in the Wufoo HTML Form Builder, add the form's link as a URL to the Widget Macro. For example:

   http://examples.wufoo.com/forms/contact-form/

Wufoo Reports

To display a Wufoo Report built using the Wufoo Report Manager, add the report's link as a URL to the Widget Macro. For example:

   http://examples.wufoo.com/reports/example-satisfaction-survey-report/

Get Satisfaction social support application

To display a feedback form for a Get Satisfaction community, add the community or company link as a URL to the Widget Macro. For example:

   http://getsatisfaction.com/atlassian

Troubleshooting

If the URL given in the Widget Connector macro does not work, the macro displays an icon and the base URL. For example, the following code:

   http://example.com/invalid

will result in an image like the one below:

   ![Example Icon](example.com)

Code examples

See:

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

Widget Connector Examples

This page contains working examples of some services currently supported by the Widget Connector. This page lets you preview what each widget will look like and see how to interact with it. For detailed usage, see Widget Connector Macro.
Flickr

- http://www.flickr.com/photos/tags/atlassian
- http://www.flickr.com/photos/atlassian/
- http://www.flickr.com/photos/atlassian/sets/72157608657271078/
- http://www.flickr.com/photos/atlassian/3003538919/

On this page:
- Flickr
- Google Docs
- YouTube
- MySpace
- Vimeo
- BlipTV
- Viddler
- Skitch
- Twitter
- FriendFeed
- SlideShare
- SlideRocket
- Scribd
- Wufoo
- Example of widget error message

Related pages:
- Widget Connector Macro
- Working with Macros
- Confluence User’s Guide

Google Docs

This integration is currently broken. Please refer to 🔒 CONF-24927 for details of the issue.

YouTube

http://au.youtube.com/watch?v=-dnL00TdmLY

Note: You must use the long YouTube URL, available under Share > Options. For detailed instructions, see the user’s guide to the widget macro.
MySpace


Vimeo

http://www.vimeo.com/909808

BlipTV

This integration is currently broken. Please refer to CONF-27266 for details of the issue.

Viddler

This integration is currently broken. Please refer to CONF-27267 for details of the issue.

Skitch

Skitch is now integrated with Evernote, as described in this blog post from The Next Web: Evernote is bringing Skitch into its core service, Skitch.com will be archived. As a result, private images on Skitch.com are no longer accessible and will not work in the Confluence widget connector. Existing public images on Skitch.com will remain available.

Twitter

http://twitter.com/mcannonbrookes

http://search.twitter.com/search?q=AtlassianDragons

FriendFeed

http://friendfeed.com/mynname

SlideShare
Example of widget error message

This is an example of the error message you will see, if the Widget connector cannot find the URL or service specified.

http://example.com/invalid

Working with Drafts

A draft is a ‘snapshot’ of unsaved page content, which Confluence creates automatically at regular intervals while you are editing a page or blog post. This can minimise the loss of work if your Confluence site experiences a problem, since you can retrieve the page content from your last saved draft.

How do drafts work in Confluence?

At regular intervals, Confluence automatically saves a draft of the page you are editing. If a network failure or system error prevents you from saving your page, you can retrieve its last saved draft and continue working on the page from the last saved draft.

Drafts are created while you are adding and editing a page or blog post. Each new draft replaces the previously saved draft. By default, Confluence saves a draft of your page once every thirty seconds. However, a Confluence administrator can configure how often drafts are saved. In addition, whenever you edit a page and then move to another screen, Confluence will automatically save a draft.

When you edit the page again, Confluence will let you know that a version of the page you are editing was not saved and will give you the option to resume editing it.

Each time Confluence saves a draft, it displays a message and the time of the last save near the Save button on the edit screen.
On this page:
- How do drafts work in Confluence?
- Viewing drafts
- Viewing your unsaved changes

Related pages:
- Resuming the Editing of a Draft
- Configuring the Time Interval at which Drafts are Saved
- Concurrent Editing and Merging Changes
- Confluence User's Guide

More about drafts:
- A user only has access to the drafts of pages they have been working on and whose content has not yet been saved.
- A user cannot create a draft explicitly.
- A user's drafts are listed in the 'Drafts' tab of their profile.
- Once a user has resumed editing a draft, or chosen to discard it, the draft is removed from their drafts tab.

Viewing drafts

Your drafts are listed on the Drafts tab of your user profile.

To see your drafts:
Choose your profile picture at top right of the screen, then choose Drafts.

Viewing your unsaved changes

While editing a page or blog post, you can view any 'unsaved' changes you have made since the last automatically saved draft, by clicking view change (near the Save button).

Configuring the Time Interval at which Drafts are Saved
By default, Confluence saves a draft of your page once every thirty seconds. Confluence administrators can configure how often drafts are saved.

As a Confluence administrator, you can set the time interval at which drafts are saved as follows:

1. Choose the cog icon at top right of the screen, then choose Confluence Admin.
2. Click General Configuration in the left-hand panel.
3. Edit the setting for Draft Save Interval.

Concurrent Editing and Merging Changes

Sometimes, two or more people may edit a page at the same time. When this happens, Confluence will do its best to ensure that nobody's changes are lost.

How will I know if someone else is editing the same page as I am?

If another user is editing the same page as you, Confluence will display a message above your edit screen letting you know who the other user is and when the last edit was made.

What happens if two of us are editing the same page and the other user saves before I do?

If someone else has saved the page before you, when you click 'Save', Confluence will check if there are any conflicts between your changes and theirs. If there are no conflicting changes, Confluence will merge both the edits successfully. If there are any conflicts, Confluence will display them for you and give you the option to either 'Overwrite' the other user's changes, 'Merge your changes' manually, or 'Discard' them.

Example Scenario

For example, Alice and Bob both edit the same page at the same time.

If Alice clicks save before Bob, Bob is now effectively editing an out-of-date version of the page. When Bob clicks save, Confluence will examine his changes to see if any overlap with Alice's. If the changes do not overlap (i.e. Alice and Bob edited different parts of the page), Bob's changes will be merged with Alice's automatically.

If Bob's changes overlap with Alice's, Confluence will display an error message to Bob showing where Alice has changed the page, and giving Bob the options to overwrite Alice's changes with his own, to re-edit the document to incorporate Alice's work, or to cancel his own changes entirely.

Resuming the Editing of a Draft

If you have typed some content into a Confluence page or blog post, Confluence will save a draft of it, even if
you were not able to successfully save the page or blog post, or add a title to it.

**There are two ways to resume editing an unsaved page or blog post:**

A. Using your drafts view. To resume editing a draft from this view:

1. Choose your profile picture at top right of the screen, then choose Drafts.
2. Choose Resume Editing next to the appropriate draft to resume editing that draft.

**Note:** If you had not yet entered a page title, the draft will be listed with the title 'Untitled'.

B. If you had created a new page or blog post but did not save it, then when you next add a page or blog post in that space, Confluence will ask you if you want to resume editing the page that was not saved. If you click resume editing, the draft and its unsaved content will be restored, allowing you to continue editing it.

**Related pages:**
- Working with Drafts

**Screenshot: Resume Editing**

A version of this page you were editing at Feb 14, 2013 16:39 was saved as a draft. Do you want to view the change, resume editing or discard it?

---

**What happens if I am editing the draft of a page that has since been updated?**

When this happens, Confluence will display a message informing you that you are editing an outdated page. If there are no conflicts between the two versions, Confluence will give you the option to Merge and Resume editing.

If there are any conflicts, Confluence will give you the option to View the Conflict or to Discard your changes.

**Recording Change Comments**

A 'change comment' is a short description that summarises the changes made to a page during an editing session. Change comments are a useful way of keeping track of the history of a page. A change comment is not the same as a comment added to a page. Refer to Commenting on pages and blog posts for information about that type of comment.

Note that once a change comment has been added and the page has been saved, it is not possible to update or remove the change comment.

**On this page:**

- Entering a Change Comment
- Viewing a Change Comment
- Viewing a History of Change Comments

**Related pages:**
- Viewing Page Information
- Page History and Page Comparison Views
- Confluence User’s Guide

**Entering a Change Comment**

You can enter change comments in the field located below the edit screen:

**Screenshot: Entering change comments**

![Enter change comments](image)

**Viewing a Change Comment**

To see the most recent change to a page and any change comment that may have been entered, choose the edited date on the byline. You can also go to Tools > Page History to see change comments for all versions.
Displaying Images

Viewing a History of Change Comments

The change comments for a page are recorded under the ‘Recent Changes’ section of the page's 'Info' view and in the page's 'History' view.

Screenshot: History of change comments on Info view

Creating Beautiful and Dynamic Pages

Confluence has a number of features that help you build attractive pages to engage your readers and give them the opportunity to interact with up-to-date information. This page summarises those features and provides links to detailed instructions.

Adding visual appeal

Pictures, photographs and screenshots. Confluence pages can display images from your Confluence site and from other websites. To put an image into Confluence, you can upload it and attach it to a page or blog post, then display it on any page, blog post or comment. Alternatively, display an image from a remote location via the web address (URL). See .

Displaying Images

Galleries. Use the Gallery Macro to display a set of images. When viewing the page, people can click any of the pictures to zoom in and view the images as a slide show.

People. Add a Profile Picture Macro to show a picture of a Confluence user, or a User Profile Macro to show a summary of the person's profile as well as their avatar.
Multimedia. You can display movies, animations and videos, and embed audio files on your Confluence page. For example, Confluence supports Adobe Flash, MP3, MP4, and various other movie formats. See Embedding Multimedia Content.

Social video and image sharing. The Widget macro displays live content from social sites such as YouTube and other video sharing sites, and Flickr for shared photographs. See the guide to the Widget Connector Macro.

On this page:
- Adding visual appeal
- Bringing numbers to life
- Displaying presentations and documents
- Pulling in content from your issue tracker
- Telling a story in pictures
- Varying the structure of your pages
- Integrating your content with social media
- Showing activity streams

Related pages:
- Working with Macros
- Using the Editor
- Confluence User's Guide

Bringing numbers to life

The Chart Macro offers a variety of graphs and charts that you can use to illustrate statistics and other numerical data.

Illustration: A 3-dimensional bar chart produced by the Chart macro

Displaying presentations and documents

Display your Office documents and other presentations directly in Confluence.

- Attach your Office documents to a Confluence page then display them on the page, using the View File Macro. This works for Excel spreadsheets, PowerPoint presentations and Word documents.
- Display PDF files in Confluence too, also with the View File Macro.
- Use the Widget Connector Macro to show slide decks hosted on SlideShare and other online presentation sites.

Pulling in content from your issue tracker

Many project teams and customers have useful information on a JIRA issue tracker. Rather than copying and pasting it onto your Confluence page, you can display it directly from the source, thus ensuring that the information shown in Confluence is always up to date.
Link to a feature request in your issue tracker, or display a list of fixed issues – useful for release notes and project planning. See the JIRA Issues Macro.

Illustration: A PowerPoint slide deck

Telling a story in pictures

A number of Confluence add-ons provide sophisticated tools for creating diagrams and mockups.

For example:

- Balsamiq Mockups for Confluence
- Creately for Confluence
- Gliffy Confluence Plugin
- Graphviz Plugin for Confluence
- Lucidchart for Confluence

Search the Atlassian Marketplace for more add-ons.

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Varying the structure of your pages

You can build up a custom layout by using the page layout tool to add sections and columns to your page. See the detailed guidelines to Working with Page Layouts and Columns and Sections.

Do you need to display tabular data, which your readers can sort when viewing the page? See Working with Tables.

Use other macros to highlight and format sections of your page:

- Panel
- Tip
- Info
- Note
- Warning
- Code block
- Noformat

Illustration: A Gliffy diagram
Integrating your content with social media

People share information on various social sites. You can make Confluence a focal point where people collect their shared information and see what is happening in the areas that matter to them.

Use the **Widget Connector macro**:

- Show a live stream of tweets from a Twitter user, or tweets matching a Twitter search.
- Display a video from YouTube or other online movie sites.
- Share photographs from Flickr.
- Display slide decks hosted on SlideShare and other online presentation sites.
- See what else the **Widget Connector macro** can do.

Showing activity streams

Make your Confluence pages dynamic and interactive with:

- An activity stream showing updates and comments on Confluence and other linked applications. See Working with Confluence Gadgets.
- An RSS feed from within Confluence or an external site. See Subscribing to RSS Feeds within Confluence.
- A list of recent blog posts from within Confluence. See Blog Posts Macro.

Illustration: A Twitter stream via the Widget macro
# Working with Templates

When you add a new page, you do not have to write the content from scratch. Instead, you can base your new page on a template. A template is a Confluence page with predefined content. Some templates are provided by blueprints or add-ons, others are defined by Confluence users.

Some examples of where templates are useful:

- A software development project may have a template for use cases.
- A systems administration space may have a template for defining what information is kept about each server.

## Global templates and space templates

In Confluence, there are two places to store your page templates:

- **Space templates**: These page templates are available in a specific space only. People who have space administrator permission can define templates via the space administration screen.
- **Global templates**: These page templates are available in every space on the site. People who have Confluence Administrator permission can define the global templates via the Confluence Administration Console.

System administrators can also download predefined templates.

---

## Creating a template

You can write your template using the Confluence editor. You can also add special variables to the page, if you want to include fields that the author will complete when adding the page. See Adding a Template for more information.

## Using a template

Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the Atlassian Marketplace for template add-ons.

See Creating a Page using a Template for more information.

## Templates provided by blueprints

A blueprint is a page template with added functionality to help you create, manage and organise content in Confluence.
Confluence ships with some predefined blueprints. You can also download additional blueprints from the Atlassian Marketplace. You can customise the blueprint templates to suit your individual needs, disable particular blueprints or even develop your own blueprints. See Working with Blueprints.

Promoting templates in the Create dialog

Space administrators can choose to promote specific templates and blueprints in the Create dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular types of content over blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank Page and Blog Post collapsed under them. To view the other types of content available choose the Show more link.

To promote a template or blueprint:

1. Go to Space Tools > Content Tools.
   - If your space is using the Documentation theme choose Browse > Space Admin > Templates.
2. Choose Promote next to the templates or blueprints you want to appear in the Create dialog.

Remember: by promoting a blueprint or template you will be hiding all other items, including blank page and blog post, under the Show more link.

System templates

Confluence also provides 'system templates' containing content like the site welcome message and default space content. See Administering Site Templates.

Adding a Template

A template is a predefined page that can be used as a framework when creating new pages. Templates are useful for setting a common style or format for a page.

In Confluence, there are two places to store your page templates:

- **Space templates**: These page templates are available in a specific space only. People who have space administrator permission can define templates via the space administration screen.
- **Global templates**: These page templates are available in every space on the site. People who have Confluence Administrator permission can define the global templates via the Confluence Administration Console.

Adding a space template

Space templates are available in one space only.

To add a template for a space:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Templates > Add New Space Template.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   - Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **Templates** from the space administration options.
3. Choose **Add New Space Template**.

The 'Create Template' screen will appear. Add content as described below.

**On this page:**
- Adding a space template
- Adding a global template
- Using the template editor
  - The resulting form when the template contains variables
- Adding content to your template
  - Labels
  - Images and other attachments
  - Variables used as form fields
  - Instructional text
- Adding a description to your template
- Converting an existing page to a template
- Notes

**Related pages:**
- Creating a Page using a Template
- Working with Templates
- Working with Confluence Labels
- Working with Macros
- Using the Editor
- Confluence User's Guide

**Adding a global template**

Global templates are available in all spaces in your Confluence site.

**To add a global template:**

1. Choose the **cog icon** at top right of the screen, then choose **Confluence Admin**.
2. Choose **Global Templates** in the left-hand panel.
3. Choose **Add New Global Template**.

The 'Create Template' screen will appear. Add content as described below.

**Using the template editor**

This illustration shows the template editor with an image, some text, styling, and variables.
The resulting form when the template contains variables

This screenshot shows the form displayed when someone creates a page based on the template containing the above variables. (See Creating a Page using a Template.)
Adding content to your template

Add a name for your template.

Enter text into the body of the template, and use the editor toolbar to apply styles, layout and formatting. You can add links and macros. In general, you can use the Confluence editor in the same way as on a page. In addition, you can add variables which will produce a form for data collection when someone adds a page based on the template.

Below are some points of special interest in templates.

**Labels**

Choose **Labels** to add one or more labels to the template. These labels will be included in all pages created using this template.

**Images and other attachments**

You cannot attach an image or other file to a template. Instead, attach the file to another page, and insert it into the body of the template.

For example:

- You can attach an image to a page and then choose **Insert > Image** to embed the image into the
template.
- You can attach a PDF file to a page and then choose **Insert > Other Macros > PDF** to embed the PDF file into the template.

**Variables used as form fields**

You can add variables to your template, to act as form fields. When someone creates a page based on the template, Confluence will display a text entry box for each field. The user can enter data into each field, and the data is inserted onto the new page.

Every variable must have a unique name. If you add the same variable more than once in the same template, Confluence will make sure that they have the same value when the user saves the page. This is useful if you need the same information in more than one place in the page.

**To insert a variable into a template:**

1. Place your cursor on the template where you want the variable to appear.
2. Choose **Template > New Variable** from the editor toolbar. Alternatively, you can choose the name of an existing variable if you want the same variable to appear more than once in the template.
3. Enter the variable name.
4. Press **Enter**. By default this will create a single-line text input field.
5. To change the variable type, click the variable placeholder. The variable’s property panel will appear.
   - Choose one of the variable types: **Text**, **Multi-line Text**, or **List**. See below for a description of each type.

**Speeding up variable entry with autocomplete:** Type $ and the variable name, then press Enter, to add a new variable or to select an existing variable from a list of suggestions. The suggestions are drawn from variables already defined in this template.

These are the types of variable available:

<table>
<thead>
<tr>
<th>Variable type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Creates a single-line text input field.</td>
</tr>
<tr>
<td>Multi-line text</td>
<td>Creates a text box that allows more than one line of text.</td>
</tr>
</tbody>
</table>

**Text**

*Screenshot: A template variable called $purpose and its property panel*

- This tutorial helps you to:
  - $purpose

<table>
<thead>
<tr>
<th>Text</th>
<th>Multi-line Text</th>
<th>List</th>
</tr>
</thead>
</table>

**Multi-line text**

*Screenshot: A multi-line variable and its property panel*

- $description?

<table>
<thead>
<tr>
<th>Text</th>
<th>Multi-line Text</th>
<th>List</th>
<th>3</th>
<th>100</th>
</tr>
</thead>
</table>
List

Creates a dropdown list.
You must specify the values that will appear in the dropdown list. The values:

- Must be separated by commas.
- Can include letters, numbers, special characters, and spaces.
- Cannot include commas (except as the list separation character).

Screenshot: A list variable and its property panel

Instructional text

Instructional text allows you to add placeholder content to a template. This text is only visible in the editor and disappears when the author of the page begins typing.

To insert instructional text into a template:

1. Place your cursor on the template where you want the instructional text to appear.
2. Choose Template > Instructional Text on the editor toolbar.
3. Begin typing - the instructional text appears in italics with a shaded background to distinguish it from normal paragraph text.

You can also change the placeholder type from 'text' to other types, including some that trigger an action such as a user mention or creating a JIRA issue.

The following instructional text types are available:

<table>
<thead>
<tr>
<th>Instructional text type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Creates a line of text that is only visible in the editor. Instructional text disappears when the user begins typing.</td>
</tr>
<tr>
<td>User Mention</td>
<td>Creates a line of text that is only visible in the editor. When clicked it triggers the @mentions dialog.</td>
</tr>
</tbody>
</table>
Adding a description to your template

The template description displays in the 'Create' dialog and is useful for explaining the purpose of a template to users.

**To add a description to a template:**

- Go to the space or global templates page (as described above).
- Choose the **Edit** icon in the 'Description' column.
- Enter your description and save.

Converting an existing page to a template

If you would like to convert an existing page to a template, you can copy the content from the page and paste it into the template editor. There is no automated way of doing this.

Please note the section above about images and other attachments in templates.

Notes

- You cannot insert variables via the 'Insert wiki markup' option in the editor toolbar.
- Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the [Atlassian Marketplace](https://marketplace.atlassian.com) for template add-ons.
- When you use a Table of Contents macro in a template, you will see an error when you preview the template itself. But the Table of Contents macro works on the pages that people create from the template – the table of contents shows up after they have saved the page. (This is probably because the template is not defined as a page, and the Table of Contents macro works for pages only.)
- The editor for templates is available only in Confluence 4.3 and later. Please refer to the earlier documentation for a description of the wiki markup editor templates.
- Confluence also provides 'system templates' containing content like the site welcome message and default space content. See Administering Site Templates.

Creating a Page using a Template

You can create a page based on a global template (available to all spaces) or a space template (available only to that space). Before reading this page, make sure that someone has already created a template on your Confluence site.

Information copied from the template to the page

When you create a page based on a template, Confluence will copy the following content and information from the template to the new page:

- Labels
- Text and styles
• Layouts and formatting
• Macros
• Embedded images and other files. Note that you cannot attach an image or other file to a template. But if the template displays an image or file from another page, the new page will display that image or file too.

Form fields displayed by the template

If the template author included variables in the template, Confluence will display a form prompting you to supply values for the variables when you add the page.

On this page:
• Information copied from the template to the page
• Form fields displayed by the template
• Using a template to create a page
• Notes

Related pages:
• Adding a Template
• Using the Editor
• Working with Confluence Labels
• Confluence User's Guide

Using a template to create a page

To create a page based on a template:

1. Choose Create on the header
2. Select a space and the template you want to use and choose Next
3. If the template contains variables, you will now see a form. Type the relevant information into the form fields, and choose Next.
4. Now you will see a new page based on the template. If you added information in the form fields, the page content will include that information.
5. Type a name for the page where you see 'New Page'.
6. Add more content or make any other changes required.
7. Choose Save.

Screenshot: Form showing template variables when creating a page from a template
Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the Atlassian Marketplace for template add-ons.

**Editing a template**

A template is a predefined page that can be used as a prototype when creating new pages. Templates are useful for giving pages a common style or format. This page is about changing an existing template.

**Note:** Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the Atlassian Marketplace for template add-ons.

In Confluence, there are two places to store your page templates:

- **Space templates:** These page templates are available in a specific space only. People who have space administrator permission can define templates via the space administration screen.
- **Global templates:** These page templates are available in every space on the site. People who have Confluence Administrator permission can define the global templates via the Confluence Administration Console.

Confluence also provides 'system templates' containing content like the site welcome message and default space content. See Administering Site Templates.
To edit a space template:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. A list of templates for the space displays. Choose Edit next to the template that you want to modify.
3. Make changes, or add new content, as you would when adding a template.
4. Choose Save.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   Note: The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Templates from space administration options.
3. A list of templates for the space displays. Choose Edit next to the template that you want to modify.
4. Make changes, or add new content, as you would when adding a template.
5. Choose Save.

To edit a global template:

1. Choose the cog icon at top right of the screen, then choose Confluence Admin.
2. Choose Global Templates in the left-hand navigation panel.
3. A list of templates for the Confluence site displays. Choose Edit next to the template that you want to modify.
4. Make changes, or add new content, as you would when adding a template.
5. Choose Save.

For more information on editing the content of a template, including adding macros, variables and instructional text see - Adding Content to a Template.

Deleting a Template

A template is a predefined page that can be used as a prototype when creating new pages. Templates are useful for giving pages a common style or format. This page is about deleting an existing template, at space level or at site (global) level.

Templates are used only when adding a page. Once a page has been added, the template is no longer linked to the page. You can therefore delete the template without affecting any existing pages.

You need to be a space administrator to delete a space template, and you need Confluence Administrator permissions to delete a global template.

Note: Deleted templates cannot be restored.

To delete a space template:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. A list of templates for the space displays. Choose Delete next to the template that you want to delete.
3. Confirm the deletion when prompted.

If your space uses the Documentation Theme:

1. Choose Browse > Space Admin at the top of the screen.
   Note: The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Templates from the space administration options.
3. A list of templates for the space displays. Choose **Delete** next to the template that you want to delete.
4. Confirm the deletion when prompted.

**To delete a global template:**

1. Choose the **cog icon** at top right of the screen, then choose **Confluence Admin**.
2. Choose **Global Templates** in the left-hand navigation panel.
3. A list of templates for the Confluence site displays. Choose **Delete** next to the template that you want to delete.
4. Confirm the deletion when prompted.

**Working with Blueprints**

**What is a blueprint?**

A blueprint is a set of page templates with added functionality to help you create, manage and organise content in Confluence more easily.

Create meeting notes, shared file lists and requirements documentation out of the box. **Customise the blueprint templates** to suit your individual needs. You can even **develop your own blueprints**.

Find out more about specific blueprints:

- Decisions Blueprint
- File List Blueprint
- Meeting Notes Blueprint
- Product Requirements Blueprint
- Shared Links Blueprint
- JIRA Report Blueprint
- Retrospectives Blueprint

---

**On this page:**

- Creating content using a blueprint
- Customising blueprint templates
- Promoting blueprints in the Create dialog
- Adding more blueprints
- Disabling a blueprint

**Related pages:**

- Working with Templates
- Confluence User’s Guide
- Requesting Add-ons

---

**Creating content using a blueprint**

You create a page from a blueprint in the same way as other pages in Confluence. All blueprints are different and most contain instructions to guide you.

**To create a page from a blueprint in the current space:**

1. Choose **Create** on the header.
2. Choose a blueprint from the ‘Create’ dialog.
3. Choose **Create**.
4. The editor will open, a prompt to enter information, or the page will appear, depending on the blueprint selected. You can now follow the instructions built in to the blueprint to add content.

The first time a blueprint is used in a space, Confluence creates an index page and adds a shortcut to your sidebar (if you are using the default theme). The index shows information from your blueprint pages, for example the meeting notes index displays a list of all meeting notes pages in the space.

**Screenshot: Index page for the Meeting Notes blueprint**
If you are using the Documentation theme, your blueprint index pages will appear in the sidebar as children of the homepage.

**Screenshot: Index page for the File List blueprint with the Documentation theme applied to the space**

---

**Customising blueprint templates**

Blueprints are made up of templates that can be customised for an individual space or the whole site. This means you can adapt the content of the blueprint pages to suit your specific needs. For example, you might update the Meeting Notes blueprint templates to include a heading for apologies.

If you have **space administrator permissions**, you can customise blueprint templates for the spaces you are an administrator of. You must be a Confluence Administrator to customise blueprint templates for a whole site. See **Administering Site Templates** for more information.

To customise a blueprint template for a space:
1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Edit** beside the blueprint template you wish to edit.
3. Make your changes to the template and choose **Save**.

Editing a blueprint template is very similar to editing a page template except:
- You should be careful not to remove any macros that the blueprint page or index page may use to store and display information.
- You cannot remove a blueprint template or change the template name.

To reset a blueprint template back to the default:
1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Reset to default** beside the blueprint template you wish to reset.
See Working With Templates and Administering Site Templates for more information on templates.

As with user created space and site templates, editing a blueprint template will not change existing pages, but any new blueprint pages will be based on the updated template.

Promoting blueprints in the Create dialog

Space administrators can choose to promote specific templates and blueprints in the Create dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular types of content over blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank Page and Blog Post collapsed under them. To view the other types of content available choose the Show more link.

<table>
<thead>
<tr>
<th>To promote a template or blueprint:</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Go to <strong>Space Tools &gt; Content Tools.</strong></td>
</tr>
<tr>
<td>If your space is using the Documentation theme choose <strong>Browse &gt; Space Admin &gt; Templates.</strong></td>
</tr>
<tr>
<td>2. Choose <strong>Promote</strong> next to the templates or blueprints you want to appear in the Create dialog.</td>
</tr>
</tbody>
</table>

Remember: by promoting a blueprint or template you will be hiding all other items, including blank page and blog post, under the Show more link.

Adding more blueprints

You can find more blueprints for Confluence in the Atlassian Marketplace. Blueprints are managed using add-ons (also known as plugins).

See Requesting Add-ons for information on how you can search for new blueprint add-ons and send a request to your System Administrator.

If you are a System Administrator, see Managing Add-ons and Macros for information on how to install new blueprint add-ons.

You can also develop your own blueprints. See our developer documentation on Writing a Blueprint.

Disabling a blueprint

You may want to disable particular blueprints. For example, you may not want to see the Product Requirements blueprint in the Create dialog in a HR or Social space. If you are a Confluence Administrator you can also disable particular blueprints for the whole site.

To disable a blueprint in a space:

- Go to the space and choose **Space tools > Content Tools** on the sidebar.
- Choose **Disable** next to the blueprint you wish to disable in that space.

You can re-enable the blueprint at any time.

To disable a blueprint across a whole site:

- Choose the cog icon at top right of the screen, then choose **Confluence Admin.** You need
Confluence Administrator permissions to do this.

- Choose **Global Templates**.
- Choose **Disable** next to the blueprint you wish to disable.

The blueprint will not appear in the ‘Create’ dialog or any space in the site.

**Decisions Blueprint**

The Decisions blueprint helps you make decisions and record the outcomes with your team.

The first time you use the Decisions blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you are using the default theme). The index acts as your Decision Register and lists all the decisions in that space.

**Related pages:**

- Working with Blueprints
- File List Blueprint
- Meeting Notes Blueprint
- Product Requirements Blueprint

**To use the Decisions blueprint:**

- Create a Decisions blueprint page (choose **Create > Decision**)
- Enter information about the decision and stakeholders - the blueprint will prompt you.

**Screenshot: Decision Register showing a series of Decision pages.**

**Screenshot: Editing a Decision page.**
The Decisions blueprint uses these Confluence features:

- **Page Properties** and **Page Properties Report** macro - content that you enter within the page properties macro can appear on the index page.
- **Mentions** - add a user as a stakeholder, owner or @mention them on the page and they will be notified in their workbox.

Customising this blueprint

You can customise the templates that are used by the Decisions blueprint - see [Customising the blueprint templates](#).

You might choose to edit the index page in a space to change the columns to be displayed by the Page Properties Report macro.

You might choose to edit the page template to add some headings or instructional text to the background section, or even add rows to the Page Properties macro, for example a row for the date the decision was made.

To find out more about using instructional text in a template see - [Instructional text](#).

**File List Blueprint**

The File List blueprint helps you to create lists of files to share with your team. Great for organising documents, images and presentations.

The first time you use the File List blueprint in a space, Confluence will create an index page and add a shortcut to your space sidebar (if you are using the default theme). The index page lists the latest File List pages in that space. You can have as many File List pages as you need.

To use this blueprint:

- Create a File List page (choose **Create > File List**).
- Drag files from your desktop or choose Browse to attach files to the page.
- Attachments appear on the page. Expand each attachment to preview the file or see attachment details.

In this example three File List pages have been created to store project related presentations, images and
customer feedback. Confluence looks after the versioning of the files, so there is no need to use the document file name to mark version numbers.

**Screenshot: Index page showing File List pages.**

**Screenshot: A File List page.**
Customising this blueprint

You can customise the templates that are used by the File List blueprint - see Customising blueprint templates.

The File List blueprint template uses the attachments macro. You could customise the macro to change the sort order or hide features such as version history and the upload attachment fields. To find out more about the attachments macro see Displaying a List of Attachments.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages you want to display.

Meeting Notes Blueprint

The Meeting Notes blueprint helps you to plan your meetings and share notes and actions with your team.

The first time you use the Meeting Notes blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you are using the default theme). The index page lists the latest Meeting Notes pages in that space. You can have as many Meeting Notes pages as you need.

To use the Meeting Notes blueprint:

- Create a Meeting Notes blueprint page (choose Create > Meeting Notes).
- Enter goals, agenda items, @mention attendees - the instructional text will prompt you.
- Save your page and get ready to attend your meeting.
- During or after your meeting edit the page and enter your notes, action items and @mention users to assign them to tasks.

Related pages:
- Working with Blueprints
- File List Blueprint
- Product Requirements Blueprint

Screenshot: Index showing three Meeting Notes pages.

Screenshot: A blank Meeting Notes page showing instructional text.
The Meeting Notes blueprint uses some cool Confluence features:

- **Instructional text** - this handy text prompts you to enter information and disappears when you start typing or view the page.
- **Mentions** - @mention a user on the page and they will be notified in their workbox.
- **Task lists** - @mention a user in a task to assign them - the task will appear as a personal task in their workbox.

Customising this blueprint

You can customise the templates that are used by the Meeting Notes blueprint - see **Customising the blueprint templates**.

You might choose to edit the headings or add additional headings, or change the instructional text that prompts users to enter information to suit your context. To find out more about using instructional text in a template see - **Instructional text**.

You can also edit the **Content Report Table** macro used on the Index page to specify the number of pages you want to display.

**Product Requirements Blueprint**

The Product Requirements blueprint helps you to define, scope and track requirements for your product or feature.

The first time you use the Product Requirements blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you are using the default theme). The index lists all the Product Requirements pages in that space, and displays a summary of the information on each page (such as status and owner). You can have as many Product Requirements pages as you need.
To use the Product Requirements blueprint:

- Create a Product Requirements blueprint page (choose Create > Product Requirements)
- Enter information about your product or feature - the instructional text will prompt you.
- Mention team members and other contacts.

Screenshot: Index showing a series of Product Requirements pages and summary information.

Screenshot: Editing a Product Requirements page.
The Product Requirements blueprint uses these Confluence features:

- **Page Properties** and **Page Properties Report** macro - content that you enter within the page properties macro can appear on the index page.
- **Instructional text** - this handy text prompts you to enter information or create a JIRA issue and disappears when you start typing or view the page.
- **Mentions** - @mention a user on the page and they will be notified in their workbox.

Customising this blueprint

As no two products or projects are alike, you can customise the templates that are used by the Product Requirements blueprint - see [Customising the blueprint templates](#).

You might choose to edit the **index** page in a space to change the columns to be displayed by the Page Properties Report macro.

You might choose to edit the **page template** to:

- edit the headings or add additional headings
- change the instructional text that prompts users to enter information to suit your context
- add or remove rows within the Page Properties macro.

To find out more about using instructional text in a template see - [Instructional text](#).

**Shared Links Blueprint**

The Shared Links blueprint helps you take content from the web and share it with your team.
You can use Shared Links to share and collaborate on web content, or to create a centralised repository of useful links.

The first time you use the Shared Links blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you are using the default theme). The index lists all the shared links in that space.

To use the Shared Links blueprint:

- Choose Create > Share a link.
- Enter the URL of the web content you want to share.
- Choose Create.

You can also:

- include topics to help categorise your links - these are added as labels to your page.
- share the link immediately with another user or group - users will receive a notification.
- add a comment to start the discussion.

To make sharing links even faster, you can add a Share on Confluence button to your browser’s toolbar. Click this button and the webpage you are currently viewing will be added as a shared link!

To add the Share on Confluence button to your browser:

- Choose Create > Share a link.
- Drag the Share on Confluence button to your browser toolbar.

Now when you want to share a link on Confluence, you can choose the Share on Confluence button in your browser, and follow the prompts.

Screenshot: Share a link from the Create dialog.

JIRA Report Blueprint

The JIRA Report blueprint helps you create easy to read reports to communicate the progress of your JIRA projects and releases.
You can choose from a Change Log report that generates a list of JIRA issues or a Status Report that includes charts to visually communicate your progress.

The first time you use the JIRA Reports blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you are using the default theme).

To use the JIRA Report Blueprint your Confluence and JIRA sites must be connected via Application Links.

On this page:
- Creating a Change Log
- Creating a Status Report
- Customising this blueprint

Related pages:
- Working with Blueprints
- JIRA Issues Macro
- JIRA Chart Macro

Creating a Change Log

The Change Log report displays a list of issues from JIRA. This list can be static or dynamic, automatically updating as the status of your issues change in JIRA.

To create a static Change Log:
- Choose Create > JIRA Reports.
- Select a Report Type.
- Select your JIRA server.
- Choose a Project and Fix Version to report on.
- Choose Create.

A report page will be created with some sample text, and a list of all issues for the project and fix versions selected - organised by issue type. This list of issues is static, it will not be updated when the issues in JIRA are updated, and is visible to users who do not have JIRA access or permissions to view that project.

Screenshot: Creating a Change Log in simple mode.

Screenshot: Static list of JIRA Issues displaying in the Change Log.
To create a dynamic change log:

- Choose Create > JIRA Reports.
- Select a Report Type.
- Choose Advanced.
- Enter a JQL query or paste in the URL of a JIRA search. Find out about using JQL in the JIRA Documentation.
- Choose Create.

A report page will be created with sample text and a JIRA issues macro that is configured to show your issues. The macro is dynamic and will update when the issues in JIRA are updated. For more information on how to further change the information displayed, refer to the JIRA Issues macro.

Screenshot: Dynamic list of JIRA Issues displaying in the Change Log.

Creating a Status Report

The Status Report displays the progress of a JIRA project and fix version in pie charts by status, priority, component and issue type. The Status Report uses the JIRA Chart macro, and is dynamic.

To create a status report:

- Choose Create > JIRA Reports.
- Select Status Report.
- Select your JIRA server.
- Choose a Project and Fix Version to report on or enter a JQL query or JIRA URL.
- Choose Create.

A report page will be created with sample text and a series of pie charts, using the JIRA Chart macro. The macro is dynamic and will update when the issues in JIRA are updated. For more information refer to the JIRA Chart macro.

As with the Change Log, you can switch to Advanced mode and use JQL or paste in a JIRA URL to search for issues to display in the report.

Screenshot: Excerpt from the Status Report.
Customising this blueprint

You can customise the templates that are used by this blueprint. The Change Log uses the Snapshot JIRA Report Template (for static list of issues) and the Dynamic JIRA Report Template, and the Status Report uses the Status Report Template. See Customising the blueprint templates. Variables represent the JIRA Issues and JIRA Chart Macros - while these cannot be edited, they can be moved around the page or deleted if you do not want every chart to be included.

You might choose to edit the page template to modify the format of the page, change some headings or modify the instructional text. To find out more about using instructional text in a template see - Instructional text.

Retrospectives Blueprint

Retrospective blueprints help you track team successes and opportunities after projects or at the end of a sprint. Use this blueprint to document what went well, what needed improvement, and assign actions for the future.

**Related pages:**

- Working with Blueprints
- File List Blueprint
- Meeting Notes Blueprint

Using Retrospective blueprints

Here’s how to use this blueprint for your next retrospective:

1. Create a Retrospective from the Create button in the header.
   The Run a Retrospective dialog appears with today's date populated in the title.
2. Add teammates and participants.
3. Click **Create**.
Your new Retrospective blueprint loads.

The Retrospective blueprint uses the following Confluence features:

- **Page Properties** and the **Page Properties Report** macro make content listed within the macro visible on the index page.
- **Instructional text** prompts you to enter information and disappears when you start typing or view the page.
- **Mention** a user on the page to notify them in their workbox.

Customising this blueprint

Every team conducts retrospective meetings differently. You can customise the Retrospectives blueprint template to match your team's culture and practices. You can:

- Edit headings and pre-populated text.
- Add instructional text to capture specific information.
- Add additional sections and content.
Working with the Office Connector

The Office Connector is bundled with Confluence 2.10 and later. It allows you to:

- Import an Office document into Confluence format
- Attach an Office document to a Confluence page and display its content in Confluence, without converting the content.
- Edit the attached document in the Office application, directly from the Confluence page.

Please be aware that source code is currently not available for the Confluence Office Connector.

Table of Contents

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing a Word Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector

Related Topics

View File Macro
Confluence User's Guide
Configuring the Office Connector

Office Connector Prerequisites

The page describes the software and setup you need to use the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

Overall prerequisites

- Ensure that Java 5 (JDK 1.5) or higher is installed on your Confluence server.
- The WebDAV plugin must be enabled, because the Office Connector uses WebDAV to transfer information to and from Office documents. Note that the WebDAV plugin is bundled with Confluence, and can be enabled or disabled by the System Administrator. If necessary, refer to the instructions on enabling plugins and configuring the WebDAV options.
- Ensure that your Confluence server's base URL is set correctly. (Check it by going to the 'General Configuration' screen in the Confluence Administration Console, as described in Configuring the Server Base URL.) When a user edits a wiki page in Word and then uploads the page back to the Confluence server, the base URL determines where the document will be saved. If the base URL is incorrect, the documents may be saved to a different Confluence server.

Prerequisites for viewing Office and PDF files in Confluence

If you want to use the View File macro, or to view Office files attached to a Confluence page, you need the setup described below.

Browsers and Flash Player

You can use any browser to view an Office file on a wiki page or attachment view, provided that you have installed Adobe Flash Player version 9 or later. You do not need to have an Office desktop application installed...
on your computer in order to view Office files in Confluence.

**File Types**

Confluence can display files compatible with Microsoft Office 97-2007, and PDF files, of the following types:

- .doc and .docx
- .xls and .xlsx
- .ppt and .pptx
- .pdf

### On this page:

- Overall prerequisites
- Prerequisites for viewing Office and PDF files in Confluence
- Prerequisites for importing Word documents into Confluence
- Prerequisites for editing Office files directly from Confluence

### Related pages:

- Working with the Office Connector
- Confluence User's Guide

#### Prerequisites for importing Word documents into Confluence

- Document import can import Microsoft Word documents of the file types .doc and .docx. These must be valid Word 97-2007 format documents.

#### Prerequisites for editing Office files directly from Confluence

The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.

To make use of these editing capabilities, you will need the setup described below.

**Browsers**

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in [Installing the Firefox Add-On for the Office Connector](#).
- **Note: No Chrome support.** Chrome does not support WEBDAV clients, so this feature will not work. Please refer to this issue for more information: [CONF-23322](#).

**Office editors**

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See [Installing the Firefox Add-On for the Office Connector](#).
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

### Configuration matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, Windows Vista, or Windows XP with Service Pack 2 or 3</td>
<td><strong>OpenOffice</strong> 2.x – 3.x, or Microsoft Office XP, 2003, 2007 or 2010</td>
<td>Internet Explorer 8.x – 9.x, or Firefox – latest stable version</td>
</tr>
</tbody>
</table>
## Displaying Office Files in Confluence

Confluence can display Office files that are attached to a page. If you have an Office application installed, you will also be able to edit these Office files in your Office application.

These are two of the ways that Confluence can interact with Office files. For an overview of all Office Connector features, please refer to Working with the Office Connector.

### Prerequisites

If you want to use the View File macro, or to view Office files attached to a Confluence page, you need the setup described below.

### Browsers and Flash Player

You can use any browser to view an Office file on a wiki page or attachment view, provided that you have installed Adobe Flash Player version 9 or later. You do not need to have an Office desktop application installed on your computer in order to view Office files in Confluence.

### File Types

Confluence can display files compatible with Microsoft Office 97-2007, and PDF files, of the following types:

- .doc and .docx
- .xls and .xlsx
- .ppt and .pptx
- .pdf

### Attaching and displaying Office files and PDF files

There are two ways to do this in Confluence:

- Attach Office files to a page and display them in a Confluence page using the View File or Attachments macros
- Attach an Office or PDF file to a page and embed its contents onto the page by simply dragging and...
To attach and display Office files in Confluence using macros:

1. Attach the Office file(s) to a Confluence page:
   - View the Confluence page on which you want to display your document.
   - Choose Tools > Attachments.
   - Browse for your Office files and upload them to the Confluence page.
   - Refer to detailed instructions in Attaching Files to a Page.
2. Now you have two options for displaying the attached document:
   - You can embed the document into the Confluence page, using one of the Office Word, Office Excel, Office PowerPoint or View PDF macros. These macros can be found using the macro browser. Refer to the detailed instructions in the View File macro topic.
   - You can display a list of page attachments using the Attachments macro. People viewing the page will be able to click the View link to see the Office or PDF document in Confluence.

To attach and display an Office file on a Confluence page using 'drag and drop':

- Drag the Office file from your computer and drop it into the editor window. Only one file can be dragged and dropped at a time. The appropriate View File macro placeholder will appear in the position where you dragged the file. However, the contents of the file will be rendered in full when you preview, or save and view, the page.
  - Older browser versions may not support drag and drop - refer to Using Drag-and-Drop in Confluence.

Viewing and Editing the Attached Office Files

If an Office document is attached to a Confluence page, you can view the attached Office document from within Confluence. View the Office document in one of the following ways:

- View the list of attachments for a specific Confluence page, then click View next to the Office document on the Attachments page. (See Viewing Attachment Details.)
- View a list of attachments displayed on a page via the Attachments macro, then click View next to the Office document in the list of attachments. (See Displaying a List of Attachments.)
- View a Confluence page which has the Office document embedded in the page via the View File macro. (See View File Macro.)

Any Confluence user who has an Office application installed will also be able to launch their Office editor from within Confluence:

- Editing an Office Document from Confluence.
- Editing an Office Presentation from Confluence.
- Editing an Office Spreadsheet from Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Importing a Word Document into Confluence

The Office Connector in Confluence allows you to import a Word document into Confluence, so that the document's content is copied onto one or more Confluence pages.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

The simplest way to import a Word document is to import the entire content of the document into a single wiki page. By default, the content of the document will be created as a new wiki page.

More advanced options allow you to import the content into a new page, to split a single document into more than one wiki page, and to resolve conflicts in the titles of your pages.
These options are described below.

Prerequisites

Prerequisites for the Office Connector’s document import feature:

- Document import can import Microsoft Word documents of the file types `.doc` and `.docx`. These must be valid Word 97-2007 format documents.

For a full list of Office Connector prerequisites and limitations, please refer to:

- Office Connector Prerequisites
- Office Connector Limitations and Known Issues

On this page:
- Prerequisites
- Importing a Word Document
- Splitting a Word Document into Multiple Wiki Pages

Related pages:
- Exporting to a Word document
- Working with the Office Connector
- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing a Word Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector
- Confluence User’s Guide

Importing a Word Document

The simplest way to import a Word document is to import the entire content of the document into a single wiki page.

This method will replace any existing content on the wiki page.

To import a Word document onto a single wiki page:

1. Create a page in Confluence (see Creating Content) or go to an existing page whose content you want replaced. View the page in view mode (not edit mode).
3. Click Browse and find the Word document on your local drive or network.
4. Click the Open or Upload button provided by your browser. The path and file name of the document will now appear in the text box on the Office Connector import screen.
5. Click Next on the Office Connector import screen. The import document options screen will display.
6. The import document options are:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root page title</td>
<td>The title of the wiki page that will contain the information from your imported document.</td>
</tr>
<tr>
<td>Import as a new page in the current space</td>
<td>A new wiki page will be created with the page title specified above.</td>
</tr>
<tr>
<td>Replace &lt;pagename&gt;</td>
<td>The contents of the existing page will be replaced. The page will be renamed to the page title specified above.</td>
</tr>
</tbody>
</table>
Delete existing children of `<pagename>`
The existing child pages of the page you are replacing will be deleted.

Rename imported pages if page name already exists
Assign new names to any new page which would otherwise have a duplicate name. The content of existing pages will remain unchanged.

Replace existing pages with imported pages of the same title
If imported pages have titles equal to existing pages, then the content of the Word document will overwrite the content on the existing page. Page history will be preserved.

Remove existing pages with the same title as imported pages
If imported pages have titles equal to existing pages, then the existing pages will be deleted. This will remove the page history as well as the content.

Split by heading
The content of the Word document will be split over multiple wiki pages. If you don't want to split your document into multiple wiki pages, leave the default Don't split option selected. For more information on splitting your document, please see below.

7. Click Import.

When the upload has finished, the content of the Word document will have been transformed into Confluence page content. You can now view and edit this page in the usual way. There is no connection between the original Word document and this wiki page.

**Screenshot: Empty page ready for import**

**Screenshot: Selecting Word document to import**

**Screenshot: Importing a Word document**
Splitting a Word Document into Multiple Wiki Pages

When importing a Word document, you can split a single document into more than one wiki page, based on the heading styles in the document.

By default, the page names will be the same as the heading text. This may result in a conflict, if a page already exists with the same title. You can instruct the importer how to handle such conflicts.

To import a Word document into multiple wiki pages:

1. Import a Word document as described above. On the import document options screen, choose how to split your document in the 'Split by heading' field:
   - 'Split by heading' — If you want to split the content under each heading in your document into
1. Click 'Import' to import your document.
2. When the upload has finished, the content of the Word document will have been transformed into Confluence page content. You can now view and edit this page in the usual way. There is no connection between the original Word document and this wiki page.

---

**Screenshot: Splitting a single Word document into multiple wiki pages**

### Import Word Document: Configuration

<table>
<thead>
<tr>
<th>Root page title:</th>
<th>Chocolate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Where to import:</td>
<td>☑ Import as a new page in the current space</td>
</tr>
<tr>
<td></td>
<td>☑ Replace Chocolate</td>
</tr>
<tr>
<td></td>
<td>☑ Delete existing children of Chocolate</td>
</tr>
<tr>
<td>Title conflicts:</td>
<td>☑ Rename imported pages if page name already exists</td>
</tr>
<tr>
<td></td>
<td>☑ Replace existing pages with imported pages of the same title</td>
</tr>
<tr>
<td></td>
<td>☑ Remove existing pages with the same title as imported pages</td>
</tr>
<tr>
<td>Split by heading:</td>
<td>Level 1 Headings</td>
</tr>
<tr>
<td>Document Outline:</td>
<td>Chocolate</td>
</tr>
<tr>
<td></td>
<td>Overview</td>
</tr>
<tr>
<td></td>
<td>Survey Results</td>
</tr>
<tr>
<td></td>
<td>Conclusions</td>
</tr>
</tbody>
</table>

---

**Editing an Office Document from Confluence**

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows you to edit a Word document from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to [Working with the Office Connector](#). Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to [Configuring the Office Connector](#) in the Confluence Administration Guide and discuss any configuration problems with your administrator.

---

**Prerequisites for Editing an Attached Office Document**

The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.

To make use of these editing capabilities, you will need the setup described below.

**Browsers**

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in [Installing the Firefox Add-On for the Office Connector](#).

- **Note: No Chrome support.** Chrome does not support WEBDAV clients, so this feature will not work. Please refer to this issue for more information: CONF-23322.

**Office editors**

---

*Created in 2013 by Atlassian. Licensed under a [Creative Commons Attribution 2.5 Australia License](#).*
To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

Configuration matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7,</td>
<td><strong>OpenOffice</strong> 2.x – 3.x, or Microsoft Office XP, 2003, 2007 or 2010</td>
<td>Internet Explorer 8.x – 9.x, or Firefox – latest stable version</td>
</tr>
<tr>
<td>Windows Vista, or Windows XP with Service Pack 2 or 3</td>
<td><strong>OpenOffice</strong> 2.x – 3.x</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td>Mac OS X 10.5 and 10.6</td>
<td><strong>OpenOffice</strong> 2.x – 3.x The &quot;Edit in Word&quot; feature is known to work in <strong>OpenOffice</strong> 3.2.0.</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td>Linux</td>
<td><strong>OpenOffice</strong> 2.x – 3.x The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.</td>
<td>Firefox – latest stable version</td>
</tr>
</tbody>
</table>
On this page:

- Prerequisites for Editing an Attached Office Document
- Editing an Office Document in your Office Application
- Troubleshooting

Related pages:

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing a Word Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector
- Confluence User’s Guide.

Editing an Office Document in your Office Application

To edit an Office document in your Office application:

1. There are two ways to do this:

   - From an Office document embedded on a page:
     a. Go to a Confluence page with an Office document embedded on it.
     b. Choose Edit Document above the embedded document.

     *Screenshot: Page with an embedded Word document showing the 'Edit Document' link*
From an Office document in a list of attachments:
- If an Office file is attached to a Confluence page, you can edit this file directly in your compatible Office application, in one of the following ways:
  - View the list of attachments for a specific Confluence page, then click Edit in Office next to the Office file on the Attachments page. (See Viewing Attachment Details.)
  - View a list of attachments displayed on a page via the Attachments macro, then click Edit in Office next to the Office file in the list of attachments. (See Displaying a List of Attachments.)

2. A window will pop up, asking you to confirm that you want to open this document.

Screenshot: Confirmation window in Firefox

Screenshot: Confirmation window in Internet Explorer
3. Click ‘OK’. Now you may be asked to log in to your Confluence server.
4. Enter your Confluence username and password, then choose ‘OK’.
5. The Office document will open in your Office application.
6. Make the necessary changes, then save the document. It will be saved back into Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Editing an Office Spreadsheet from Confluence

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows you to edit an Excel spreadsheet from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.
Prerequisites for Editing an Attached Office Spreadsheet

The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.

To make use of these editing capabilities, you will need the setup described below.

**Browsers**

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in [Installing the Firefox Add-On for the Office Connector](#).

  **Note: No Chrome support.** Chrome does not support WEBDAV clients, so this feature will not work. Please refer to this issue for more information: [CONF-23322](#).

**Office editors**

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See [Installing the Firefox Add-On for the Office Connector](#).

- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

**Configuration matrix**

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
</table>

---

*Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
Editing an Office Spreadsheet in your Office Application

To edit an Office spreadsheet in your Office application:

1. There are two ways to do this:
   - **From an Office spreadsheet embedded on a page:**
     a. Open a Confluence page with an Office document embedded on it.
     b. Choose Edit Document above the embedded content.

   ![Screenshot: The title bar showing 'spreadsheet.xls' above an embedded Excel spreadsheet](image)

   - **From an Office spreadsheet in a list of attachments:**
     - If an Office file is attached to a Confluence page, you can edit this file directly in your compatible Office application, in one of the following ways:
       - View the list of attachments for a specific Confluence page, then click Edit in Office next to the Office file on the Attachments page. (See Viewing Attachment Details.)
       - View a list of attachments displayed on a page via the Attachments macro, then click Edit in Office next to the Office file in the list of attachments. (See Displaying a List of Attachments.)

   ![Screenshot: Confirmation window in Firefox](image)

2. A window will pop up, asking you to confirm that you want to open this document.
Click 'OK'. Now you may be asked to log in to your Confluence server. Enter your Confluence username and password, then click 'OK'.

4. The Office spreadsheet will open in your Office application.

5. Make the necessary changes, then save the spreadsheet. It will be saved back into Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Editing an Office Presentation from Confluence

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows you to edit a PowerPoint presentation from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

Prerequisites for Editing an Attached Office Presentation

The Office Connector allows you to edit Office files embedded in a wiki page or from the page’s attachments view.

To make use of these editing capabilities, you will need the setup described below.

Browsers

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.

- Note: No Chrome support. Chrome does not support WEBDAV clients, so this feature will not work.
Office editors

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

Configuration matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7,</td>
<td><strong>OpenOffice</strong> 2.x – 3.x, or Microsoft Office XP, 2003, 2007 or 2010</td>
<td>Internet Explorer 8.x – 9.x, or Firefox – latest stable version</td>
</tr>
<tr>
<td>Windows Vista, or Windows XP with Service Pack 2 or 3</td>
<td><strong>OpenOffice</strong> 2.x – 3.x The &quot;Edit in Word&quot; feature is known to work in OpenOffice 3.2.0.</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td>Mac OS X 10.5 and 10.6</td>
<td><strong>OpenOffice</strong> 2.x – 3.x</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td>Linux</td>
<td><strong>OpenOffice</strong> 2.x – 3.x The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.</td>
<td>Firefox – latest stable version</td>
</tr>
</tbody>
</table>
On this page:

- Prerequisites for Editing an Attached Office Presentation
- Editing an Office Presentation in your Office Application
- Troubleshooting

Related pages:

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing a Word Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector

Editing an Office Presentation in your Office Application

To edit an Office presentation in your Office application:

1. There are two ways to do this:

   - From an Office presentation embedded on a page:
     a. Open a Confluence page with an Office presentation embedded on it.
     b. Click the 'Edit' icon on the bottom frame of the slide show.

     Screenshot: PowerPoint presentation displayed on a Confluence page
From an Office document in a list of attachments:

- If an Office file is attached to a Confluence page, you can edit this file directly in your compatible Office application, in one of the following ways:
  - View the list of attachments for a specific Confluence page, then click **Edit in Office** next to the Office file on the Attachments page. (See Viewing Attachment Details.)
  - View a list of attachments displayed on a page via the Attachments macro, then click **Edit in Office** next to the Office file in the list of attachments. (See Displaying a List of Attachments.)

2. A window will pop up, asking you to confirm that you want to open this document.

_Screenshot: Confirmation window in Firefox_
3. Click ‘OK’. Now you may be asked to log in to your Confluence server. Enter your Confluence username and password, then click ‘OK’.

4. The presentation will open in your Office application.

5. Make the necessary changes, then save the presentation. It will be saved back into Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Installing the Firefox Add-On for the Office Connector

If you are using Firefox as your browser, you will need to install an add-on into Firefox (the Firefox WebDAV Launcher) in order to use some features of the Office Connector. You will be prompted to install the add-on the first time you try to use a function which requires it.

For an overview of all Office Connector features, please refer to Working with the Office Connector.

Note about supported web browsers: Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. Check the Supported Platforms page to find the list of supported web browsers and browser versions on this page.
Installing the Firefox Add-On

You will be prompted to install the add-on the first time you try to use a function which requires it. The add-on is required for editing a wiki page in Office, or for editing an Office document which is displayed on a wiki page.

1. When you choose an option which requires the Firefox add-on, you will see a popup window like this one:

   A plugin is required to use this feature. Would you like to download it?

      OK  Cancel

2. Click 'OK'. Some browsers may now ask you to confirm the download with a message bar across the top of the page, beneath the browser's address bar.

   - You may see a message like the one shown here:
Click 'Allow'.

- Or you may see a similar message with an 'Edit Options' button like this:

  ![Firefox prevented this site (localhost) from asking you to install software on your computer.](image)

  - If you see the above message, click 'Edit Options'. You will then see an 'Allowed Sites' window like this:

    ![Allowed Sites - Add-ons Installation](image)

    This window lets you tell Firefox that your Confluence server is allowed to install add-ons into Firefox. The 'Address of web site' box should already contain the address of your Confluence server.

    - Click the 'Allow' button to add your Confluence server to the list.
    - Go back to your Confluence page and try to edit your Office document again, e.g. by clicking 'Edit in Word' again. Now you will see the option to install the add-on.

3. A 'Software Installation' window will appear, asking you to confirm the installation. The window will look something like the one below, but the URL will be the address of your own Confluence server:
4. Click 'Install Now'. The installation will happen and a window will pop up asking you to restart Firefox:

![Image of add-ons installation window]

5. Make sure you have saved all your Confluence pages and any other work in your browser, then restart Firefox.
6. If Firefox asks you to confirm the restart, confirm it.
7. Firefox will close all the browser windows and will then start up again. You will see a window confirming that a new add-on has been installed, like this:

![Image of add-ons confirmation window]
Configuring the Add-On

After you have installed the add-on into Firefox, you will need to configure it. Basically, you will associate a desktop application (editor) with each relevant file type. This tells the Office Connector which application to launch when it encounters a link to an editable file. The configuration is slightly different for each operating system, as described below.

Configuring the Add-On in Windows

The add-on can will automatically configure itself on Windows via the system registry. The first time you edit a new file type, the add-on will look up the default editor for that file type and make that the permanent setting.

If you want to override the registry settings, or if for some reason the automatic configuration is not working, you can configure the Firefox add-on manually.

1. In Firefox, go to the 'Tools' menu and select 'WebDAV Launcher Options', as shown in this screenshot:
2. A 'WebDAV Launcher Options' window will appear, allowing you to associate a specific file type (file extension) with a desktop application (editor). The window looks like this one:

3. In the 'File Extension' box, enter the extension for a particular file type. For example, you may want to associate the 'doc' file extension with Microsoft Word 2003 or earlier. To do this, you would type 'doc' in the File Extension text box.

If you use or have recently upgraded to Office 2007

In addition to the original Office 2003 file extensions (that is, 'doc', 'ppt' and 'xls'), you **should additionally** configure the WebDAV launcher to handle the new Office 2007-specific file extensions for Microsoft Word ('docx'), Microsoft Excel ('xlsx') and PowerPoint ('pptx').

Screenshot: Configuring the WebDAV Launcher - adding the 'doc' file extension.
4. Enter the 'Application Path' — Use one of the following methods to specify the associated application for editing the given file type:

- Click the 'Auto' button to load the associated application from the Windows registry.
- Alternatively, you can click the 'Browse' button to find the application on your computer.
- Or you can manually type in the path to the application's executable file.

Screenshot: Configuring the WebDAV Launcher - adding the 'Application Path' for the 'doc' file extension.

**If you use or have recently upgraded to Office 2007**

Follow the instructions in this step to add the path to the relevant Office 2007 application for the Office 2007 file extension you configured above. For example, if you had a typical
5. Click the 'Add' button. The file extension association will be added to the list. For example, in the picture below you can see that the 'doc' extension has been associated with 'C:\Program Files\Microsoft Office\OFFICE11\WINWORD.EXE'. This is the path to the Microsoft Word 2003 executable on a specific Windows machine.

Screenshot: Configuring the WebDAV Launcher - configuration of the 'doc' file extension complete.

Configuring the Add-On in Mac OS X

The configuration procedure is similar to Windows, as shown above. Note that there is no 'Auto' button in Mac OS X.

Configuring the Add-On in Linux

The only known supported Office editor for Linux is OpenOffice. (See Office Connector Prerequisites.)

There is no automatic configuration on Linux. You will need to associate each file type with your Office editor in Firefox. Note that there is no 'Auto' button in Linux.

The configuration procedure is similar to Windows, as shown above.

For both Ubuntu and OpenSUSE, the configuration will look something like this:

<table>
<thead>
<tr>
<th>File Extension</th>
<th>Application Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>doc and docx</td>
<td>/usr/bin/oowriter</td>
</tr>
<tr>
<td>ppt and pptx</td>
<td>/usr/bin/ooimpress</td>
</tr>
<tr>
<td>xls and xlsx</td>
<td>/usr/bin/oocalc</td>
</tr>
</tbody>
</table>

Security Risks

⚠️ Please be aware that there are security risks in installing this add-on to Firefox. Internet Explorer is exposed to the same risks, because it can directly open Office documents. By installing the add-in into Firefox, you are exposing Firefox to the same risks.
Summary of the risks:

- Office documents can contain macro viruses. Before opening an Office document, make sure that you trust the source of the document.
- There are known flaws in the Office file formats and Microsoft Office that an attacker can exploit to gain control of your machine. Microsoft has fixed the known exploits in the latest Service Packs for all Microsoft Office versions. But new exploitations may arise at any time. Again, be sure that you trust the source of a document before opening it.

The add-on tries to reduce the risk by supporting the following:

- **Same origin policy** — The add-on can only open documents from the same host that initiated the action.
- **Digital signature** — The add-on is digitally signed. When you install the add-on please verify that it is signed by Benryan Software Inc.

- **Prompt the user for confirmation** — You will always be warned before a file is opened. Please read these warnings carefully before opening a file. The warning tells you the complete URL of the file as well as the complete application path of the application opening the file.

**Information about this Firefox Add-On**

<table>
<thead>
<tr>
<th>Add-on name:</th>
<th>WebDAV Launcher</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description:</td>
<td>Adds the ability to launch a WebDAV URL directly in a WebDAV-aware client.</td>
</tr>
<tr>
<td>Latest version:</td>
<td>See the WebDAV Launcher add-on page at Mozilla</td>
</tr>
<tr>
<td>Compatible with:</td>
<td>All versions of Firefox, up to and including the latest stable version.</td>
</tr>
<tr>
<td>Author:</td>
<td>Atlassian Pty Ltd</td>
</tr>
</tbody>
</table>

**Related Topics**

- Working with the Office Connector

**Importing Content Into Confluence**

This page describes how to get text, pages, images and other content into Confluence, by converting the content
from another storage format and importing it into the Confluence wiki.

Importing content from other Confluence sites

For content originating from other Confluence sites, you can:

- Import an entire Confluence site into a new site.
- Import a space from one Confluence site into another. Page history, attachments, and page content will be preserved and you will be able to do multiple pages at once. The drawbacks are that it may be inconvenient if the Confluence versions differ, and you cannot have a duplicate space key on the destination instance.

See Restoring a Site and Restoring a Space for more information.

On this page:

- Importing content from other Confluence sites
- Importing content from other wikis
- Importing content from a Microsoft Word document
- Importing web content
- Importing other non-wiki content
- Note about add-on support

Related pages:

- Working with the Office Connector
- Confluence User's Guide

Importing content from other wikis

Check whether the Universal Wiki Converter can import the content. See Importing Content from Another Wiki.

Importing content from a Microsoft Word document

The Office Connector in Confluence allows you to import a Word document into Confluence. The document's content is copied onto one or more Confluence pages. See Importing a Word Document into Confluence.

Importing web content

Here are some options for importing or displaying web content on a Confluence page:

- Use the Widget Connector Macro to display videos, slide shows, twitter chats, documents and more, sourced from other web sites and displayed on your Confluence page.
- Convert a HTML file to a Confluence page using the HTML To Confluence Converter plugin.
- Embed an external web page into Confluence with the HTML Include macro.
- Use HTML code in a page with the HTML macro.

Importing other non-wiki content

Importing non-wiki markup into Confluence requires a conversion process:

- Text with basic formatting can be pasted directly into the editor. This includes simple Word documents or web pages.
- Files such as Microsoft Excel documents can be imported using a content converter plugin. Not applicable to Confluence OnDemand.
- Confluence pages saved to disk can be imported from disk. Not applicable to Confluence OnDemand.
- Files can be uploaded in bulk using the Confluence WebDAV Plugin (Not applicable to Confluence OnDemand) or WebDAV upload (For Confluence OnDemand).
- Full featured customisation is available using the Confluence remote APIs.

Note about add-on support

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.
Importing Content from Another Wiki

The Universal Wiki Converter (UWC) allows you to import content from other wikis into Confluence. The Confluence Administration Console offers a link to the Universal Wiki Converter documentation and download sites.

**Note:** You need to install and run the UWC separately from Confluence. The UWC is a standalone application that communicates with Confluence remotely. You cannot install the UWC directly into Confluence. Instead, download the UWC separately and run it according to the instructions below.

The UWC supports many wiki dialects. In addition, the UWC is an extensible framework, which means that developers can continue writing new conversion modules for other wikis.

- Download the latest version of the UWC from the [Atlassian Marketplace](#).
- For information on installation and usage, see the [UWC User Documentation](#).
- For information on developing your own converter module, see the [UWC Developer Documentation](#).
- For information about a specific wiki, including a list of currently supported wikis, see the [UWC documentation - what wikis are currently supported?](#).
- To ask a question, see the [UWC discussions on Atlassian Answers](#).

### Related pages:
- Importing Content Into Confluence
- Data Import and Export
- Confluence Administrator's Guide

---

The information on this page does not apply to Confluence OnDemand.

---

Importing Pages from Disk

Confluence allows you to import text files from a directory on the Confluence server, and convert them into Confluence pages. Each file will be imported as a separate Confluence page with the same name as the file.

**Notes:**

- The text file may contain plain text, HTML or [Confluence Storage Format](#).
- You need to be logged in as a [System Administrator](#) to import text files.
- You can import pages from disk into site spaces, but not into personal spaces. Please see [Working with Spaces](#) for information about differences between site spaces and personal spaces.

### Related pages:
- Importing Content Into Confluence
- Confluence User's Guide

---

The information on this page does not apply to Confluence OnDemand.

---

To import text files:

1. Go to the space and choose **Space tools** > **Content Tools** on the sidebar.
2. Choose **Import**.
3. Type the your directory path into the **Import directory** box.
4. Select **Trim file extensions** to remove file extensions from the page titles when converting the files to Confluence pages. Note that the Confluence pages will take their titles from the files' names (including their extensions). To avoid having page titles with a suffix like `.txt` check this box.
5. Select **Overwrite existing pages** if you want to replace existing Confluence pages that have the same page title as one you are importing.
6. Choose **Import**.

If your space uses the Documentation theme:

1. Choose **Browse** > **Space Admin** at the top of the screen.
1. The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **Import** from the space administration options.
3. Follow the steps above.

Confluence will place the new pages at the root of the space.

**Screenshot: Importing text files**

1. You can use this action to import text files from a directory on the Confluence server.
2. These text files become pages in Confluence, with the following features:
   - The page title is taken from the filename
   - The content is the entire page body

<table>
<thead>
<tr>
<th>Import directory</th>
<th>Trim file extensions</th>
<th>Overwrite existing pages</th>
</tr>
</thead>
</table>

   **Import**  **Cancel**

**Sharing Content**

Confluence provides a number of ways for you to notify other people about content that may be of interest to them:

- You can **share a page link** with them.
- You can **mention** a user when you write a page, blog post or comment. Mentioning a user automatically emails a notification to them about that content.
- You can **broadcast a message** that appears in Confluence activity streams.
- You can **like** a page, blog post or comment. The author will receive a notification. If enough people like the content, it will appear in the list of popular content on the dashboard and in the recommended updates email message.

Other users can also find out about changes to content in Confluence by **watching** pages and spaces.

You may also be interested in **exporting Confluence content** to other formats such as XML, HTML, Microsoft Word and PDF.

**Related pages:**
- Creating Content
- Managing Changes and Notifications and Tasks
- Organising Content
- Confluence User’s Guide

**Network Overview**

The ‘network’ feature provides notifications on the activity of users that you choose to follow. This compares with Confluence’s other **content tracking** features, which provide notifications on specified types of content updates, made by any user.

The types of activities tracked by the network feature include:

- Additions or edits to **pages** or **blog posts**
- **Comments** added to a page or blog post or edits to existing comments
- Updates to a user’s **User Status Updates**
- Updates to a user’s **User Profile**
Accessing Your Network View

To see your network view:

- Choose your profile picture at top right of the screen, then choose Network. (Alternatively, choose More in the 'Network' section of your profile sidebar.)

You can access another user's Network view using the Hover Profile.

Screenshot: Example of the Network view

Following Another User

You can follow another user by using either the Hover Profile or your Network view.

To follow a user with the Hover Profile:

1. Open the user's hover profile popup:
   - Log in to Confluence, if you have not already done so.
   - Note: If a Confluence Administrator has granted the 'View User Profiles' permission to anonymous users, you can access people's hover profile popups without logging in. However, the hover profile features available to anonymous users are restricted.
   - Move your mouse pointer over a user's linked name or profile picture. The hover profile popup will appear.
2. Choose Follow.
To follow a user from your Network view:

1. Choose your profile picture at top right of the screen, then choose Network.
   (Alternatively, choose More in the ‘Network’ section of your profile sidebar.)
2. Enter the first few characters of the name (or username) of the user you wish to follow in the Following field and choose the user from the list of suggestions.
3. Choose Follow.

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just followed will appear within the ‘Following’ list on the right. Additionally, their tracked activities will start appearing in the ‘Recent Activity’ list on this page.

Stop Following a User

To stop following a user by using the Hover Profile:

1. Open the user’s hover profile popup:
   - Log in to Confluence, if you have not already done so.
     Note: If a Confluence Administrator has granted the ‘View User Profiles’ permission to anonymous users, you can access people’s hover profile popups without logging in. However, the hover profile features available to anonymous users are restricted.
   - Move your mouse pointer over a user’s linked name or profile picture. The hover profile popup will appear.
2. Choose Stop Following.

You can also stop following a user by going to their Profile view.

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just stopped following are removed from the ‘Following’ list on the right. Additionally, their tracked activities will stop appearing in the ‘Recent Activity’ list on this page.

Notes

Once you are following a user, you can see their activity in a number of ways:

- Your Network view: your Network view shows all the tracked activities that you have permission to view for all the users that you are following. In the same way, people who follow you will be able to see all your Confluence-based activities on their network views, provided they have permission to view the content. See below for instructions on accessing your network view.
- RSS feeds: you can subscribe to any Confluence user’s network RSS feed and receive summaries on the activities of other users they are following in their network. See Subscribing to a Network RSS Feed.
- Email notifications: you can request email notifications of any activity in your network. See Subscribing to Email Notifications of Updates to Confluence Content.

Note that it is not possible to stop another user from following you. If you are interested in the ability to block followers, please watch CONF-16285 for updates on the feature request.

Likes and Popular Content

Has someone written a good blog post or page on Confluence? Or has someone added a comment that you agree with? Click the Like button to let them know.

Confluence has like buttons on every page, blog post and comment. If enough people like a page or post, it will show on the dashboard’s ‘Popular’ tab. The information in the ‘Recommended Updates’ email message is based on the number of people who have liked the content.

Liking a page, blog post or comment

Click the Like button to let people know that you agree with or enjoy a page, blog post or comment. Click Unlike to remove your name from the list of people who like the content.

You can also see:

- Up to three names of people in your network who have most recently liked the content.
- A link showing the number of people who have liked the comment. For example, 19 people like this.

Click the link to see the names. At the top of the list are people in your network, sorted with the most recent likes first. Then follow other people, also sorted chronologically with the most recent first.
Liking a page, blog post or comment

Effects of liking content

When you like a page, blog post or comment:

- The author of the content receives a notification.
- People in your network receive a notification. They will receive the notification only if they do not already know about the content. Let's assume Arthur is in your network. Arthur will not receive a notification if:
  - Someone else in his network has already liked the content.
  - Arthur himself has already liked the content.
  - Arthur has already commented on it.
- In the case of a threaded comment, Arthur has already replied to the comment.
- If enough people like the content, it will appear on the 'Popular' tab of the dashboard.
- Similarly, if the content is popular enough it will appear in the 'Recommended Updates' summary sent out by email.

Disabling the 'like' feature
The functionality is provided by a plugin called the 'Confluence Like Plugin'. To remove the 'like' functionality from your site, you can disable the plugin. See Disabling or Enabling a Plugin.

Disabling notifications when your content is 'liked'

There are two ways to turn the 'someone likes your page' notifications off:

1. Open an email notification of a like, and click Manage Notifications
2. Go to _<your confluence URL>/plugins/likes/view-notifications.action_

**User Status Updates**

You can use your 'user status' to broadcast a short message, which other users can see on various activity streams in Confluence. These short messages could include:

- A description about what you are working on.
- A question you may want answered quickly.
- A hyperlink that you share immediately with other users.
- Any other message you may want to share quickly with other users.
- Another person's Confluence username, in the format [~username], to send that person an email message about your status.

Your 'Status Updates' view shows a history of updates you have made to your status. Your latest status message is shown on the profile popup that appears when people hover over your username, and in various other places in Confluence.

On this page:
- Setting or updating your status
- Mentioning another person in your status update
- Viewing status updates
- Clearing your current status
- Deleting a status update
- More about user status updates
- Enabling and disabling status updates

Related pages:
- User Profile Overview
- User Status List Macro
- Confluence User's Guide

**Setting or updating your status**

To set or update your status:

1. Log in to Confluence.
2. Choose your profile picture at top right of the screen, then choose Update Status. The 'What are you working on' dialog will open.
3. Enter a short message (140 characters maximum) that describes your current status or what you are working on.
4. Choose Update to publish your new or updated status.

Screenshot: User status
Mentioning another person in your status update

You can include another person's Confluence username in your status update, using square brackets and the tilde sign in the format \[~username\]. Confluence will send that person an email message containing your status update. For example, let's assume another Confluence user has the username ‘charlie’. You could put this message in your status update, and Charlie will receive an email message:

Enjoying all the blog posts that \[~charlie\] has written recently!

Note: Mentions in status updates do not appear as notifications in the Confluence workbox.

Viewing status updates

To view your status updates:

- Choose your profile picture at top right of the screen, then choose Status Updates.

You can also view another user’s status by going to their profile.

Screenshot: Status updates view

Clearing your current status

Clearing a message is not the same as deleting it. If you clear a message, it is still shown in your status updates view until it is deleted.

To clear your current status:

1. Choose your profile picture at top right of the screen, then choose Status Updates.
2. Choose **Clear** in the status message at the top of the page.

*Screenshot: Clearing your current status message*

Deleting a status update

**To delete your current or a previous status message:**

1. Choose **your profile picture** at top right of the screen, then choose **Status Updates**.
2. Choose **Delete** next to the appropriate status message. Your status updates view will be refreshed and the message you deleted will be removed from the list.

More about user status updates

There are a number of activity streams in Confluence that show different types of status updates. These include:

- The 'Recently Updated' list on the **Confluence Dashboard**, which shows all status updates (when the **All** tab is selected).
- Your **Network page**, which shows the status updates of Confluence users you are following.
- The **Network page** of Confluence users who are following you, which shows your status updates.
- The **Recently Updated** and **Recently Updated Dashboard** macros, which shows all status updates (provided that these macros' space parameters have been set to '@all').

Enabling and disabling status updates

The functionality is provided by a plugin called 'User Status'. To remove the status updates functionality from your site, you can disable the plugin. See [Disabling or Enabling a Plugin](#).

You can also set the Confluence site permissions to determine which users can use status updates. By default, users will not have permission to use this feature. See [Global Permissions Overview](#).

**Using Mentions**

You can mention a person in a special way that prompts Confluence to send that person an email message and a workbox notification. This way of mentioning someone is called an @mention. It works on Confluence pages, blog posts and comments.

When you save the page, Confluence sends an email message to the user letting them know that they have been mentioned on the page (if they have permission to view the page) with a link to the relevant page. Confluence also adds a notification to the person's workbox.

**Note:** Use the person's full name. The user mention feature recognises the full name only, not the username.

There are two ways to mention someone:

- The quickest way is to start typing '@' and the person's name, then choose from the suggestions that Confluence offers. This is called autocomplete.
- Alternatively, you can choose **Insert > User Mention** from the editor toolbar.

Each of these methods is described in more detail below.

**Using autocomplete to mention someone**
To mention someone using '@':

1. Edit the page.
2. Click where you want to insert a mention and type '@' and then the first few characters of the user's full name.
3. Choose the user's name from the list of suggestions.

**Screenshot: Autocomplete for mentions**

---

**On this page:**
- Using autocomplete to mention someone
- Accessing the user mention option in the editor toolbar
- Seeing your mentions in the Confluence workbox

**Notes**

**Related pages:**
- Using the Editor
- Using Autocomplete
- Keyboard Shortcuts
- Confluence User's Guide

---

Accessing the user mention option in the editor toolbar

**To add a user mention via the editor toolbar:**

1. Edit the page.
2. Choose **Insert > User Mention**. Confluence will add an '@' sign to the page, and display a dropdown list of suggested users for you to choose from.
3. Start typing the person's name, to refine the list of suggestions.
4. Choose the person from the list of names.

**Screenshot: The user mention option in the editor toolbar**
Seeing your mentions in the Confluence workbox

When someone mentions you, you will receive a notification in the Confluence workbox. See Managing Notifications in Confluence.

Notes

- **Disabling the user mention feature.** The functionality is provided by a plugin called the 'Confluence Mentions Plugin'. To remove the user mention functionality from your site, you can disable the plugin. See Disabling or Enabling a Plugin.
- **Mentioning groups.** It is not possible to mention a group and then have the email sent to the entire group. You can only mention individual users. There is a feature request allowed to mentions for groups:
  - [CONF-23015 - Extend `Mentions` to work with groups as well](Open)
- **Mentioning people in status updates.** You can use a square bracket `[` and a person's name to trigger Confluence autocomplete and link to a person's user profile or personal space. Confluence will send the person a notification just as if you had used @mention (unless the administrator has disabled the user mention feature).

Emailing a Page

You can share a Confluence page or blog post by emailing a link to recipients of your choice. The recipients can be Confluence users or any email addresses.

To share a link to a Confluence page or blog post by email:

1. Go to the page or blog post you wish to share.
2. Choose Share.
   - Note: The Share button will only visible if your Confluence administrator has configured an outgoing mail server for your Confluence site.
3. Enter a username, group or email address - autocomplete will suggest matching users and groups.
4. Select the appropriate user, group or email address from the dropdown. You can add multiple recipients to the list.
5. Enter an optional message into the Note box.
6. Choose Share to send the link via email.

In addition to an email, Confluence users will also receive a notification in their Confluence workbox. See Managing Notifications in Confluence.

Related pages:

- Managing Notifications in Confluence
- Working with Pages
- Working with Blog Posts
- Configuring a Server for Outgoing Mail
- Confluence User's Guide

Screenshot: Sharing a page
Notes

To remove a recipient from the list, choose the delete icon to the right of the recipient.

**Printing Confluence Pages**

You can print one or more Confluence pages:

- To print a single page, use your browser's 'Print' option.
- Confluence allows you to export a single page, single blog post, part of a space, or an entire space into a single PDF file. See Exporting Confluence Pages and Spaces to PDF.

**Exporting Confluence Pages and Spaces to Other Formats**

You can convert a part of, or the entire contents of a space to various formats, including Microsoft Word, HTML, PDF and XML. This is called 'exporting' the space.

**What would you like to do?**

- Exporting Confluence Pages and Spaces to HTML
- Exporting Confluence Pages and Spaces to PDF
- Exporting to a Word document
- Exporting Confluence Pages and Spaces to XML

**Related topics**

- Working with Spaces
- Confluence User's Guide

**Exporting Confluence Pages and Spaces to HTML**

In Confluence, you can export part of, or the entire contents of, a space into a zipped archive of HTML files. This is useful if you want convert your space into a static website.

To use the space export functionality, you need the 'Export Space' permission. See the guide to space permissions.

**To export pages to HTML:**

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose Export. This option will only be visible if you have the 'Export Space' permission.
3. Select **HTML** then choose **Next**.
4. Decide whether you need to customise the export:
   - Select Normal Export to produce an HTML file containing all the pages that you have permission to view.
   - Select Custom Export if you want to export a subset of pages, or to exclude comments from the export.

5. Select the Include Comments check box if you want to include comments for the pages you are exporting.

6. Select the pages you want to export.
   - You have the option to Select All or Deselect All pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.

7. Choose Export. This will create a zipped archive of HTML files.

8. When the export process has finished, download the zipped archive as prompted, and extract the files into a folder.

If your space uses the Documentation theme:

2. Choose HTML Export from the left menu.
3. Follow the steps above to export the Space.

### Related pages:
- Exporting Confluence Pages and Spaces to PDF
- Exporting Confluence Pages and Spaces to XML
- Confluence User's Guide

## Screenshot: Selecting pages to export

### Export HTML Options

Export content within this space as HTML.

- Normal Export
  - Generates a HTML file of all pages and blog posts in this space, including comments and attachments.
- Custom Export
  - Generates a HTML file of selected pages based on options that you choose from below.

### Includes:
- Include comments

### Choose pages to export:

Select All  ·  Deselect All

- Crowd Documentation
  - Crowd 101
  - Crowd Administration Guide
    - Getting Started

Select All  ·  Deselect All

Export

### Notes
- In the zip file, page attachments are placed in individual folders with names in the following format: `...\download\attachments\xxxxxx`
Where 'xxxxxx' is the page ID of the page containing the attachments.

- By default, the ‘Space Details’ page is exported as index.html and displays the space's details as well as a list of all available pages within it.
- Blog posts are not included in the HTML export. See the feature request: CONF-14684.
- To customise the HTML output, you will need to modify the file confluence-x.y.z-jar/com/atlassian/confluence/pages/Page.htmlexport.vm. To learn how to repackage this file, see How to Edit Files in Confluence JAR Files.

Exporting Confluence Pages and Spaces to PDF

This page explains how you can export individual Confluence pages, blog posts, entire spaces or selections of pages into a single PDF file.

Exporting single pages

You can export a Confluence page to PDF. This option exports a single page and is available to all users who have permission to view the page.

- Go to a page in the space and choose Tools > Export to PDF. Follow the prompts to export the page.

Note that the export of a single page to PDF applies any PDF stylesheet customisations, but does not apply any PDF layout customisations. To make your PDF layout customisations apply to a single page exported to PDF, use the ‘multiple page’ method described below to export that single page only. See Customising Exports to PDF.

Exporting a blog post

You can export a Confluence blog post to PDF. This option exports a single blog post and is available to all users who have permission to view the page.

- Go to a blog post and choose Tools > Export to PDF. Follow the prompts to export the page.

Blog posts can only be exported individually. Blogs cannot be exported at the space level.

Exporting multiple pages or the entire space

Using Confluence's space export functionality, you can convert multiple pages or an entire space to PDF.

To use the space export functionality, you need the ‘Export Space’ permission. See the guide to space permissions.

To export a space or selected pages to PDF:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Export. This option will only be visible if you have the ‘Export Space’ permission.
3. Select PDF then choose Next
4. Decide whether you need to customise the export:
   - Select Normal Export to produce a PDF file containing all the pages that you have permission to view.
   - Select Custom Export if you want to export a subset of pages.
5. Select the pages you want to export.
   - You have the option to Select All or Deselect All pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
6. Choose Export.
7. When the export process has finished, download and save the PDF file as prompted.

If your space uses the Documentation theme:

1. Choose Browse > Space Operations
2. Choose PDF Export from the left menu.
3. Follow the steps above to export the Space.
Customising the appearance of PDF exports

You can add a title page, a table of contents and customised headers and footers to the PDF output. For more advanced customisations, you can apply Cascading Style Sheet (CSS) modifications. These customisations are specific to each space. You need the ‘Space Administrator’ permission to be able to apply these customisations. For more information, see Customising Exports to PDF.

Notes

- PDF exports will not handle columns created via the page layout option in the editor. If you have a two- or three-column layout, the PDF export will contain the page content in one single column. The issue is tracked here: CONF-25240 - PDF export does not handle page layouts (Resolved)
- Comments on the page are not exported to the PDF file.
- Only image attachments that have been inserted into a page are included when exporting to PDF.
To export a PDF containing international text, you need to install a Unicode font in Confluence.

Blog posts can be individually exported, but are not included when you export a space to PDF.

If you have ‘Space Administrator’ permissions, the link to customise the PDF Stylesheet is provided at the top of the page tree, as shown in the screenshot above.

Confluence’s PDF export feature is designed to handle a wide variety of content. However, on rare occasions the PDF Export process may fail due to an unrecognised customisation. If that happens the PDF export screen will indicate the title of the page in which the problem occurred, to help you diagnose the cause of the failure.

Customising Exports to PDF

Confluence administrators and space administrators can customise the PDF exports for individual spaces.

Please note:

- PDF customisations are unique to each space.
- Confluence’s PDF customisations use a combination of HTML and CSS (Cascading Style Sheets).
- To achieve a particular requirement in the exported PDF file, you make changes in one or both of the following:
  - The PDF Layout, where HTML is used to define the structure of the exported content, including features such as the title page, headers and footers.
  - The PDF Stylesheet, where CSS is used to define the style of elements in the exported content, such as page size and margins, font, colour, and list numbering.

For further customisations, see the Advanced PDF Export Customisations page.

**Customising the PDF Layout**

You can add your own HTML to customise the title page, page headers and page footers in the PDF output.

**Setting a global PDF layout**

1. Choose the cog icon at top right of the screen, then choose Confluence Admin.
2. Choose PDF Layout. You can enter HTML and CSS that will be rendered on the PDF title page, as well as page headers and footers.

**Setting the PDF layout at space level**

1. Go to the space and choose Space tools > Look and Feel on the sidebar. You'll need Space Admin permissions to do this.
2. Choose PDF Layout.
3. Choose Edit.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   
   *Note:* The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose PDF Layout in space administration options.
3. Choose Edit.

You can customise the HTML that is generated for the following areas when the space is exported to PDF:

- PDF Space Export Title Page – title page.
- PDF Space Export Header – page headers.
- PDF Space Export Footer – page footers.

Enter your customisations into each text box as required. The PDF layout section accepts HTML code. You can include inline CSS in the HTML too.
Customising the PDF Stylesheet

You can adjust the appearance of the PDF pages by customising the CSS in the PDF Stylesheet screen.

To get started, download the default CSS rules for the PDF stylesheet - confluencedefaultpdf.css.

Any rule defined in this file can be customised and added to the PDF Export Stylesheet section. Your customisations override any default CSS rule. If no customisations are defined, the default CSS rules will be applied.

By default, the export does not include a title page, headers or footers. You can define these in the PDF layout.

To customise the PDF Stylesheet:

Setting a global PDF Stylesheet

1. Choose the cog icon at top right of the screen, then choose Confluence Admin.
2. Choose Look and Feel > PDF Stylesheet. The following screen allows you to enter and save CSS code that will render content on each page.

Setting a space PDF stylesheet

1. Go to the space and choose Space tools > Look and Feel on the sidebar. You'll need Space Admin permissions to do this.
2. Choose PDF Stylesheet.
3. Choose Edit.
4. Enter your customisations.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   Note: The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose PDF Stylesheet in the space administration options.
3. Choose Edit.
4. Enter your customisations.

The PDF Export Stylesheet field accepts Cascading Style Sheets (CSS) rules. The ‘PDF Export Stylesheet’ page shows the current (e.g. customised) contents of your PDF stylesheet.
Example Customisations

This section provides examples of typical customisations that you can add. See also Advanced PDF Customisations.

Page Size

The default page size is based on the location of your Confluence server. For example, if this server is located in the US then the default paper size of your PDF export will be US Letter (8.5 inches wide by 11 inches long). If the server is located in Australia, the default paper size will be A4 (210 mm wide by 297 mm long). More information about paper sizes can be found on Wikipedia.

To modify the page size to A4, edit the PDF Stylesheet to add a size property to the CSS page rule, like this:

```css
@page
{
/*The A4 paper size is 210 mm wide by 297 mm long*/
size: 210mm 297mm;
}
```

Page Orientation: Landscape or Portrait

To change the page orientation of your PDF document, simply reverse the order of the values declared in the @page rule's size property. The first and second values of this property represent the width and height of the page, respectively.

For example, to generate PDF space exports in A4-sized landscape orientation, your @page rule might look like this:

```css
@page
{
/*A4-sized pages in landscape orientation are 297 mm wide by 210 mm long*/
size: 297mm 210mm;
}
```

Page Margins

To set all margins to 15 mm, with a paper size of A4, edit the CSS page rule in the PDF Stylesheet, like this:

```css
@page
{
size: 210mm 297mm;
margin: 15mm;
}
```

To set the margins independently, edit the @page rule as follows:
To set margins to provide a gutter for binding a printed document, use the :left and :right pseudo-classes, as follows:

```css
@page :left
{
  margin-left: 4cm;
  margin-right: 3cm;
}
@page :right
{
  margin-left: 3cm;
  margin-right: 4cm;
}
@page :first
{
  margin-top: 10cm /* Top margin on first page 10cm */
}
```

Note the use of the :first pseudo-class in the example above to define distinct margins for a cover or title page.

**Page Breaks**

By default, Confluence pages are exported without page breaks, so that shorter pages will appear on the same PDF page.

To make each Confluence page appear on a separate page in the PDF file, add the following rule in the PDF Stylesheet:

```css
.pagetitle
{
  page-break-before: always;
}
```

**Title Page**

You can add a title page to your PDF document by adding HTML to the Title Page section of the PDF Layout screen. The following example creates the title page and adds a title:
Use CSS rules in the PDF Stylesheet to control the appearance of the title page and the title text:

**CSS - PDF Stylesheet**

```css
.fsTitlePage {
  margin-left: auto;
  margin-top: 50mm;
  margin-right: auto;
  page-break-after:always
}
.fsTitle {
  font-size: 42px;
  font-weight: bold;
  margin: 72px 0 4px 0;
  text-align:center;
}
```

Adding an Image to the Title Page

In the example above, the title page includes an image called 'titlepage.png', centred in the middle of the page. The "590719" in the src attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your title page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page, then right-click the image and copy its location.
3. Paste the link into the appropriate src="" attribute in your PDF Stylesheet, as shown above.
4. Edit the image URL so that it is relative, by removing the first part of the URL before /download/....

Table of Contents

By default, a table of contents will be generated after the title page, or at the beginning of the PDF document if no title page is defined in the PDF Layout. To see the default CSS rules applied to the table of contents, download the default CSS rules (confluencedefaultpdf.css) and examine the specific rules with toc in their name.

To make changes to the appearance of the table of contents, define CSS rules in the PDF Stylesheet.

**Disabling the Table of Contents**

To prevent the table of contents from being generated in your PDF document, add the div.toc rule to the PDF Stylesheet and set its display property to none:
Changing the Leader Character in the Table of Contents

The leader character is used to link a heading in the table of contents with its page number. By default, the leader character is the '.' (dot) character. Leader values of dotted, solid and space are allowed. You can also use a string, for example `leader(". . . ")`.

To change the leader character to a solid line, modify the `leader()` value on the `content` property of the CSS rule as follows:

```
css - PDF Stylesheet
span.toclead:before
{
  content: leader(solid);
}
```

Headers and Footers

You can add headers and footers to your PDF pages using the 'Header' and 'Footer' sections of the PDF Layout screen. By default, headers and footers only apply to a space export and not to exports of single pages (however, see [Advanced PDF Export Customisations](#)). The following example adds a simple copyright notice.

```
html - PDF Layout: Footer Section
Copyright © 2013, Atlassian Pty Ltd.
```

Page Numbering

To add page numbering, you need to combine customised HTML in the PDF Layout with customised CSS in the PDF Stylesheet.

1. PDF Layout HTML: In the Footer section (or the Header section), use an empty span element with a unique ID, for example `pageNum`, to act as a place holder for the page number.

```
html - PDF Layout: Footer Section
<span id="pageNum"/>
```

2. PDF Stylesheet CSS: Create the following CSS selector rule for the empty span:
Analysing the above CSS selector rule in more detail:

- The `#pageNum:before` rule selects the HTML element with the specified ID of "pageNum", which is the `span` element we created for the header or footer.
- The `:before` part of the selector is a pseudo class that allows the insertion of content before the `span` element is processed.
- The `counter(page)` is a function that returns the current page number as its content.
- The `content` property tells the CSS processor that dynamic content (that is, an incrementing page number) is to be inserted at the `span` tag.

Wrapping Long Words

In order to break long words or words that are not separated by whitespace, add a selector to the PDF stylesheet containing the `word-wrap` property with a value of `break-word`:

```css
CSS - PDF Stylesheet
div
{
  word-wrap: break-word;
}
```

General Formatting

You can use the stylesheet to customise the output of just about anything else that will influence the look and feel of the final document. This includes fonts, tables, line spacing, macros, etc. The export engine works directly from the HTML output produced by Confluence. Therefore, the first step in customising something is to find a selector for the HTML element produced by Confluence or the Confluence macro. Then add a CSS rule to the PDF stylesheet. Your customisation will appear in the PDF export.

Notes

- **Demotion of heading elements: h1, h2, and so on.** Due to the hierarchical manner in which a space is exported, Confluence will modify the heading elements to generate a uniform appearance for the entire space export. This means that headings will be demoted. This will affect the application of custom PDF Stylesheets. It is possible to calculate the amount by which a heading will be demoted in order to have the correct CSS styling applied. A heading will be demoted by the value of its depth in the export tree. A page at the first level will be demoted by 1 (all `<h1>` elements will become `<h2>` elements, and so on). A page at the second level will be demoted by 2, and so on.

- **Atlassian support for PDF customisation is limited.** We support the mechanism for customising the PDF layout with HTML and CSS, and we will help if the mechanism is broken or does not work as we say it should in our published examples. But, since custom HTML and CSS offer potentially limitless possibilities, Atlassian will not support issues that are caused by or related to PDF customisations.

Related Topics

- Advanced PDF Export Customisations

This page provides information about 'advanced' PDF export customisations. These expand upon the regular customisations described in `Customising Exports to PDF`.
The information below is for advanced users. Customisations are not supported by Atlassian. Be aware that the advanced customisations described below require knowledge of certain parts of Confluence, and of CSS and HTML. This documentation is intended for advanced users. Some of the suggestions below are moderately complex, or irregular in nature. If you are having trouble understanding them we strongly suggest you ask an expert. We do not support any of the customisations described below. This means that the Atlassian support engineers will not be able to help you with these modifications.

On this page:
- Header and Footer
  - Adding Headers and Footers to Single Page Exports
  - Adding Images to Headers and Footers
- Incorporating Other Fonts
- Adding a Dynamic Title to the Title Page
- Hiding Text from the PDF Output
- Indexing
- Notes

Related pages:
- Customising Exports to PDF
- Confluence User's Guide

Header and Footer

Adding Headers and Footers to Single Page Exports

By default, custom headers and footers set up in the PDF Layout screen (see Customising Exports to PDF), only apply to space exports and not to exports of single pages. However, it is possible to add CSS rules to your PDF Stylesheet that produce headers and footers in single page exports as well as space exports.

For custom headers, define @top-left, @top-center and @top-right rules within your @page rule. These rules apply respectively to content that appears on the left-hand side, centre and right-hand side of your page’s header area.

For custom footers, define @bottom-left, @bottom-center and @bottom-right rules within your @page rule.

For example, the following rules add a document title at the centre of the header and a page number at the centre of the footer:

```
@page
{
  @top-center
  {
    content: "Document Title Goes Here";
    font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
    font-size: 8pt;
  }
  @bottom-center
  {
    content: "Page " counter(page);
    font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
    font-size: 8pt;
  }
/* Any other page-specific rules */
}
```

Notes:
The font-family and font-size properties ensure that the header and footer text is rendered in the same default font style used for the body text, based on the default CSS rules. It is not possible to use this method to insert images (stored as attachments within your Confluence instance) into the headers and footers of single page exports.

Adding Images to Headers and Footers

To insert an image into the header or footer, add HTML to the Header or Footer section of the PDF Layout screen.

The following example uses an HTML img element with src attribute to add an image to the left of the header. The src attribute refers to an image attached to a Confluence page. The image element is usually placed within a div element container.

```
<div style="margin-top:10mm">
  <img src="/download/attachments/12346/header-image.png"/>
</div>
```

In the example above, the header includes an image called 'header-image.png'. The "12346" in the src attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page, then right-click the image and copy its location.
3. Paste the link into the appropriate src="" attribute in your PDF Stylesheet, as shown above.
4. Edit the image URL so that it is relative, by removing the first part of the URL before /download/....

Notes:

- This example uses an inline CSS property margin-top in the style attribute to force the image away from the top of the page by 10mm. This comes in handy when your header image is large enough to touch or spill over the top of the page.
- Likewise, for footers, you can use the margin-bottom:XXmm property to force an image away from the bottom of the page by 'XX' mm.
- Very large images can spill over into the body of a page or alter the position of text or other elements used within a header or footer. In such situations, it is recommended that you reduce the size of the image and then attach it to your Confluence page again. If you prefer to keep the image size and want to move the content lower instead, you can do so by configuring the margin-top properties in the @page CSS rule.
- By default, a header or footer image is aligned to the left-hand side of the page. However, you can align this image to the centre or right-hand side of a page by adding either the text-align:center or text-align:right properties to your style attribute. For example, to align the header image to the right-hand side of the page, your style attribute would look similar to this: style="margin-top:10mm; text-align:right".

Incorporating Other Fonts

By default, Confluence provides Times New Roman, Helvetica or Courier fonts for use in PDF exports. You can use your own fonts for PDF exports by declaring them in a @font-face CSS rule in your PDF Stylesheet.

The following CSS rule example shows how to declare the Consolas font and apply it to some elements for your PDF export:
Adding a Dynamic Title to the Title Page

When you export an arbitrary set of pages from Confluence, you may like to have a corresponding title added to the cover (or title) page automatically. This can be done (in a somewhat irregular way) by using the top level item from the default table of contents as the title. This method relies on having the exported pages structured as sub-pages of the top-level page. In other words, the pages to be exported should consist of a page (at the top-level) and all of its child pages. The result is that the title that appears on the cover page changes depending on the top-level page that is used for the export.

The CSS below moves, and styles, the top-level TOC item for use as the title on the cover page, and turns off the leader and page number normally associated with this item in the TOC.
Hiding Text from the PDF Output

This section describes a way to hide text from your PDF export. In other words, you can have text on the Confluence page that will not appear in the PDF export.

There are three steps:

1. Follow the instructions to define the NoPrint user macro. *Not applicable to Confluence OnDemand.*
2. Use the NoPrint macro to mark some text on a Confluence page.
3. Add the following CSS to your PDF stylesheet to make the PDF export recognise the NoPrint macro:

```css
.noprint
{
  display: none ;
}
```

Indexing

To obtain an index at the end of the exported PDF file, consider using the Scroll Wiki PDF Exporter plugin that is produced by K15t Software GmbH.

Notes
If styling is not working as expected, it is useful to look at the intermediary HTML source to which the CSS is applied. This intermediary HTML is created whenever you create an HTML export that contains multiple pages, and is stored in the temp directory in Confluence's home directory. For example:

```
<confluence-home>/temp/htmlexport-20110308-154047-1/export-intermediate-154047-2.html
```

Creating PDF in Another Language

To export a Confluence page written in a language other than English, you need to install the necessary font for that language. This means that you need to upload the font file to Confluence, as described below.

**Note:** If you are using Confluence OnDemand, please raise a support ticket at http://support.atlassian.com, asking Atlassian to perform this function for you. Confluence OnDemand users do not have access to this functionality. The Atlassian Support team will need to access this URL:

```
https://<account_name>.atlassian.net/wiki/admin/flyingpdf/configurepdflanguagesupport.action
```

**Uploading a Font File to Confluence**

1. Find the appropriate font file:
   - **Windows users:** All font files in Windows are stored in a directory called:
     ```
     C:\WINDOWS\Fonts
     ```
   - **Unix users:** All font files in Unix are stored in:
     ```
     /usr/share/fonts
     ```
   - Microsoft True Type core fonts such as Verdana can be downloaded from this page: http://corefonts.sourceforge.net/
2. Copy the font file into a temporary folder, for example a folder on your desktop.
3. Choose the cog icon at top right of the screen, then choose Confluence Admin, then choose PDF Export Language Support.
4. Upload the file you copied in step 2.
5. Choose Install.

**Related pages:**
- Exporting Confluence Pages and Spaces to PDF
- Confluence Administrator's Guide

**Notes**

- The only font files supported are true type fonts and true type collections. The accepted file extensions are *.ttf and *.ttc.
- We recommend that you use Unicode font Verdana for correct character encoding and exporting to PDF.
- If the font file size is bigger than your current attachment size limit, you will not be able to upload it. Please increase the attachment size limit temporarily and re-upload again. An improvement of the error messaging is tracked at CONF-24706 - Provide better error message when trying to upload a custom PDF font which is bigger than current attachment size limit.
- To make use of an installed font in your PDF Export style sheet (CSS) refer to it by the font-family ConfluenceInstalledFont.
Exporting to a Word document

Confluence allows you to export a single page into a Word document. By default, this will create a Word document with the same name as the Confluence page. This is useful for emailing content to people who do not have access to Confluence.

Anyone who has permission to view the page will be able to export it to Word.

To export a page to a Word document:

Go to the page and choose Tools > Export to Word.

Useful plugins

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

This plugin provides extended functionality for exporting Confluence pages to Microsoft Word: Scroll Office.

Exporting Confluence Pages and Spaces to XML

You can export part of, or the entire contents of, a Confluence space into a zipped archive of XML files and attachments. This is useful if you want to make a backup of the space, or import the space into another Confluence site, or use the data from the space in another application.

To export a space or pages to XML, you need the 'Export Space' permission. See Space Permissions.

Notes:

- See Restoring a Space for notes on restrictions when importing a space.
- If you are doing the export for backup purposes, consider another means of backup. See Production Backup Strategy

To export pages or an entire space to XML:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Export.
   Note: This option will only be visible if you have the 'Export Space' permission.
3. Select XML then choose Next.
4. Decide whether you need to customise the export:
   - Select Full Export to produce an XML file containing all the pages in the space, including those that you do not have permission to view.
   - Select Custom Export if you want to export a subset of pages, or to exclude comments from the export.
5. Select Include Comments if you want to include comments made on the pages you are exporting.
6. Select the pages you want to export.
   - You have the option to Select All or Deselect All pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
7. Choose Export. This will create a zipped archive of XML files and attachments.
8. When the export process has finished, download and save the zipped archive file as prompted.

If your space uses the Documentation theme:

2. Choose XML Export from the left-hand panel.
3. Follow the steps above to export the space.
Notes

If you are running Confluence behind Apache HTTP Server and are facing timeout errors, please consider creating the export directly from Tomcat, instead of going through Apache. This will speed up the process and prevent timeouts.

Managing Changes and Notifications and Tasks

Confluence provides several ways in which you can watch for changes to single pages, entire spaces, and all spaces on the site. You can also follow the updates made by specific people. You can only track updates to content that you have permission to see.

Personal tasks appear in the task-and-notification dialog, and you can assign team tasks via a task list on a page.

Making yourself a watcher of pages or spaces

You can ‘watch’ a page, blog post or space that you have permission to view. Confluence will then send you an email notification whenever someone adds or updates content on, or adds a comment to, that page or space.

See Watching Pages, Spaces and Blogs.

If you have space administrator permissions, you can manage watchers of pages and spaces.
Requesting other notifications

You can configure Confluence to send you various digest reports via email. See Subscribing to Email Notifications of Updates to Confluence Content.

On this page:

- Making yourself a watcher of pages or spaces
- Requesting other notifications
- Tracking updates by specific people
- Managing your notifications and tasks
- Using Confluence RSS feeds

Related pages:

- Page History and Page Comparison Views
- Viewing Space Activity
- Contributors Macro
- Confluence User's Guide

Tracking updates by specific people

You can also follow the activity of people who interest you (see Network Overview) and receive a notification when someone follows you (see Subscribing to Email Notifications of Updates to Confluence Content).

Managing your notifications and tasks

There are a few ways to manage notifications and tasks in Confluence:

- You can manage your email notification settings via the options in your user profile. See Subscribing to Email Notifications of Updates to Confluence Content.
- The Confluence workbox displays all notifications collected from Confluence page watches, shares and mentions. See Managing Notifications in Confluence.
- You can manage your personal tasks in the Confluence workbox, and also create a list of tasks on a page. See Managing Tasks in Confluence.

Using Confluence RSS feeds

You can build RSS feeds to monitor content changes in Confluence.

- Create a customised RSS feed using the RSS Feed Builder.
- Subscribe to one of the pre-specified feeds generated by Confluence.

Watching Pages, Spaces and Blogs

You can ‘watch’ a Confluence page, blog post or space. Confluence will then send you a notification by email whenever anyone updates the watched content.

You will receive email notifications for:

- Edits (unless the author clears the ‘Notify watchers’ check box).
- Deletions.
- Attachments, including new versions or deletions of an existing attachment.
- Comments, including new comments, edits of existing comments or deletions of existing comments.

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called ‘autowatch’. You can control autowatch.

There is no daily digest for email notifications. You will receive an email notification every time someone makes a change.

You will not receive email notifications for content changes due to the output of a macro, because the page content itself has not been edited.

You need ‘View’ permission for the page, blog post or space to receive notifications.
On this page:

- Watching a page or blog post
- Watching an entire space
- Watching for new blog posts in a space
- Watching all spaces on the site
- Watching for all new blog posts on the site
- Managing watches from your user profile
- Managing watches from the email message
- Setting autowatch and other notification options

Related pages:

- Managing Watchers
- Subscribing to Email Notifications of Updates to Confluence Content
- Managing Changes and Notifications and Tasks
- Updating Email Address
- Confluence User's Guide

Watching a page or blog post

To start watching a page or blog post:

1. Log in to Confluence, if you have not already done so.
2. Go to the page or blog post.
3. Choose Watch and select the relevant check box.

To stop watching the page or post, deselect the relevant check box.

Watching an entire space

You can choose to watch all the pages and blog posts in a particular space.

The quickest way is to use the Watch option on a page or blog post, as described above.

To stop watching the space, deselect the relevant check box.

Alternatively, choose Pages in the space sidebar, then choose Watch this space at the top right.

If your space uses the Documentation theme, choose Browse > Space Operations. Then choose Watch this space in the left-hand menu.

Watching for new blog posts in a space

You can choose to receive a notification whenever someone adds a blog post in the space. You will not receive notification of updates to or deletions of blog posts, nor of comments on the blog posts.

To watch for new posts:

1. Log in to Confluence, if you have not already done so.
2. Go to a blog post in the space.
3. Choose Watch and select Watch all blog posts in this space.

To stop watching for new blog posts, deselect the relevant check box.

Alternatively, choose Blog in the space sidebar, then choose Watch this blog at the top right.

If your space uses the Documentation theme, choose Browse > Space Operations. Then choose Watch this blog in the left-hand menu.

Watching all spaces on the site

You can receive notifications about changes to the content of pages, blog posts and comments from all spaces on a Confluence site.

To start watching for content changes across the whole site:
1. Choose **your profile picture** at top right of the screen, then choose **Settings**.
2. Choose **Email**.
3. Choose **Edit** then choose **Subscribe to daily updates**.
4. Choose **Submit**.

**Watching for all new blog posts on the site**

You can choose to watch for all new blog posts in all spaces on the Confluence site. You will not receive notification of updates to or deletions of blog posts, nor of comments on the blog posts.

To start watching for all new blog posts:

1. Choose **your profile picture** at top right of the screen, then choose **Settings**.
2. Choose **Email**.
3. Choose **Edit** then choose **Subscribe to all blog posts**.
4. Choose **Submit**.

**Managing watches from your user profile**

The 'Watches' page in your user profile displays a list of all pages and spaces you are currently watching.

**To manage your watches:**

1. Choose **your profile picture** at top right of the screen, then choose **Watches**.
2. Choose **Stop Watching** for any unwanted spaces or pages.

**Managing watches from the email message**

The email notifications that you receive from Confluence have some useful links at the bottom of the email message. The links in each message vary, depending on the context. In general, the links allow you to view the page online, reply to a comment, and so on.

In particular with respect to setting your notification preferences, you will see one or more of the following links:

- **Stop watching page** – Click this link to stop watching the page that triggered the email notification.
- **Stop watching space** – Click this link to stop watching the space that triggered the email notification.
- **Stop following this user** – Click this link to stop following the user whose update triggered the email notification.
- **Manage Notifications** – Click this link to go to the email settings page in your user profile.

**Screenshot: Example email notification footer showing links**

---

**Setting autowatch and other notification options**

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called ‘autowatch’. You can turn autowatch on or off, and set other notification options, in the email settings section of your user profile. See Setting User Settings.

**Managing Watchers**

If you are a **space administrator** for a space, you can manage the watchers for all pages and blog posts in that space. This means that you can:

- View a list of the watchers of a page or blog post.
- View a list of the watchers of the space that contains the page or blog post.
- Add users as watchers of the page or blog post.
- Remove existing watchers of the page or blog post.

You cannot remove watchers of the space.
To manage the watchers of a page or blog post:

1. Go to the page or blog post for which you want to manage the watchers.
2. Choose Watch > Manage Watchers.
3. The 'Manage Watchers' screen will appear. The left-hand column shows the users watching the page or blog post. The right-hand column shows the users watching the space.
   - To remove an existing page watcher, choose the icon (trash can) next to the user's name.
   - To add a user as a watcher of the page, type their username and choose Add.

Screenshot: Managing watchers

---

**Subscribing to Email Notifications of Updates to Confluence Content**

You can 'watch' a page, blog post or space. Confluence will then send you a notification by email whenever anyone adds or updates content on that page or space. You can also subscribe to daily email reports and other notifications of various updates, as described below.

You will only receive notifications for content that you have permission to view. Users that have been disabled by an administrator will not receive email notifications.

**Subscribing to email notifications**

You can subscribe to the following email summary reports:

- A daily report of updates to all spaces that you have permission to view.
- An immediate report of all blog posts added or changed, in all spaces that you have permission to view.
- An immediate report of all updates made by the people you are following, in all spaces that you have permission to view.
- An immediate report when someone follows you.
- A daily or weekly report of recommended updates, in all spaces that you have permission to view.

**To edit your email notification settings:**

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Click Email in the left-hand panel.
3. Click Edit.
Below is an explanation of all the email settings is explained below.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Content</th>
<th>Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autowatch</td>
<td><strong>Option:</strong> Do you want Confluence to automatically add you as a watcher on each page or blog post that you add or update? If you are a watcher of a page or a post, you will receive notification of future changes.</td>
<td>- Pages and blog posts that you create, edit or comment on.</td>
<td>(Not applicable)</td>
</tr>
<tr>
<td>Subscribe to daily updates</td>
<td>Receive email reports showing changes to content in all spaces that you have permission to view. Note: <strong>Daily email reports do not include information about attachments on a page or blog post that are added, edited or deleted.</strong></td>
<td>- Pages and blog posts that are added, edited or deleted.</td>
<td>Daily</td>
</tr>
<tr>
<td>Subscribe to all blog posts</td>
<td>Receive email notifications for changes to blogs in your Confluence installation that you have permission to view.</td>
<td>- Blog posts added, edited or deleted.</td>
<td>Immediately</td>
</tr>
</tbody>
</table>
| **Subscribe to network** | Receive email notifications for changes to content by all users that you are following, which you have permission to view. | • Pages being added, edited or deleted.  
• Blog posts being added, edited or deleted.  
• Comments being added, edited or deleted.  
• Status updates by the user. | Immediately |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Subscribe to new follower notifications</strong></td>
<td>Receive an email message when anyone chooses to follow you.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
| **Notify on my actions** | **Option:** Do you want to receive email notifications for your own changes?  
Note: If you have not subscribed to any email notifications and are not watching any pages/spaces, then selecting 'Notify on my actions' will not do anything. | • All pages and spaces that you are watching.  
• This affects all subscriptions set. | (Not applicable) |
| **Show changed content** | **Option:** Do you want your notifications to include details of the changes made to the content?  
• If you do not select this option, your notifications will include only the title of the page, and any comment the author made when updating the page.  
• If you do select this option, your notifications will show the differences between the current and previous versions of the page.  
See Page History and Page Comparison Views. | • Edits to pages and blog posts. | (Not applicable) |
<table>
<thead>
<tr>
<th>Subscribe to recommended updates</th>
<th>Confluence chooses the content to display, based on:</th>
<th>Daily (weekdays at 1pm) or weekly</th>
</tr>
</thead>
</table>
| Receive an email message showing the top content that is relevant to you from spaces that you have permission to view. | • Pages and blog posts that people have recently liked.  
• Pages and blog posts that people have recently commented on.  
• Pages and blog posts that have recently been created. | |
| How do you set the frequency of the mail message? A link in the email message allows you to choose daily or weekly notifications. | 'Recent' means any activity that occurred since the last recommended updates message was sent to you. | |
| How do you enable and disable the notification? You can turn off the notification by clicking a link in the email message. You can also turn the notification on or off by setting the ‘Subscribe to recommended updates’ option in your user profile. | The activities are listed in order of popularity, with the most popular at the top. Likes, comments and content creations are scored equally. Activity that involves people in your network ranks higher than activity not involving your network. Content in your favourite spaces also ranks higher than content in other spaces. The recommended updates summary does not include any content that you created yourself, and it gives a lower ranking to content that you have participated in, for example by adding a comment or updating the page. If there is no activity to report, Confluence will not send the email message. | |

Notes for administrators

- To enable Confluence to send email notifications, a System Administrator must configure an email server. See [Configuring a Server for Outgoing Mail](http://confluencedocs.org).  
- Confluence Administrators can set the default options for the recommended updates notification. Choose the cog icon at top right of the screen, then choose Confluence Admin. Click Recommended Updates Email in the left-hand panel. See [Configuring the Recommended Updates Email Notification](http://confluencedocs.org).
Subscribing to RSS Feeds within Confluence

An RSS feed is a format for delivering summaries of regularly changing web content. Subscribing to an RSS feed allows you to stay informed of the latest content from sites that you are interested in.

RSS is not designed to be read in a regular web browser. Specialised RSS newsreader programs can check RSS files every so often, and tell you what's new on a site. Your reader may be on a website, an add-on to your browser, part of your email program, or a stand-alone program.

Confluence works with RSS in two ways:

- Confluence generates its own RSS feeds for tracking updates to content within Confluence. You will need an RSS reader which can grab the RSS feeds from Confluence and display them for you.
- Confluence's RSS macro allows you to display the contents of an RSS feed on a Confluence page. The feeds may come from a Confluence feed generator or from external sites. In this way, Confluence can act as an RSS reader.

For a technical description of RSS, read Mark Pilgrim's "What is RSS?" article on XML.com.

Confluence RSS feeds

RSS feeds allow you to track updates to content within Confluence. You will need an RSS newsreader to read a feed.

You can create a customised RSS feed using the RSS Feed Builder or subscribe to one of the pre-specified feeds generated by Confluence.

What would you like to do?

- Create and subscribe to customised RSS feeds using the RSS Feed Builder – Create a customised RSS feed. For example, you can filter your feed using a label, specify the number of items and days to include in your feed, and so on.
- Subscribe to pre-specified RSS feeds – Generate an RSS feed automatically in a minimal number of steps.
- Subscribe to a feed of any Confluence user's network – Track the activities of users the selected person is following.

On this page:
- Confluence RSS feeds
- RSS newsreaders
- Removing an RSS feed

Related pages:
- Managing Changes and Notifications and Tasks
- RSS Feed Macro
- Confluence User's Guide

RSS newsreaders

The following are some popular RSS readers for various operating systems. You can find a more comprehensive list on Google's open directory.

Windows

- SharpReader
- NewsGator
- Syndirella
- FeedDemon
- NewzCrawler

Mac OS X

- Safari
- NetNewsWire
- NewsFire
Multi-platform

- **Shrook**
- **NewsMonster** (Runs in the Mozilla web browser)
- **Radio Userland** (Windows and MacOS)
- **AmphetaDesk** (Windows, Unix, Mac OS X)

Removing an RSS feed

There is no need to try to delete or remove an RSS feed built by the Confluence **RSS feed builder**.

Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL (address). For example, take a look at the following feed URL:

```
http://confluence.atlassian.com/createrssfeed.action?types=page&sort=modified&showContent=true...
```

The above feed URL will generate a list of pages ("types=page"), sorted by the modification date and showing the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no need to remove anything.

Using pre-specified RSS feeds

This page tells you how to get hold of an RSS feed which Confluence has predefined for you.

To subscribe to predefined RSS feeds for a particular space:

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **RSS Feeds**.
3. Copy and paste the link for one of the feeds into your RSS newsreader:

If your space uses the Documentation theme:

1. Choose **Browse > Space Operations**
2. Choose **RSS Feeds** in the space operations options.
3. Copy and paste the link for one of the feeds into your RSS newsreader.

Feeds include:

- Pages
- Blog
- Mail
- Comments
- Attachments
- All content

To subscribe to predefined RSS feeds for a particular page (where available):

Note that the word 'page' here means a part of the Confluence user interface, rather than a page that contains Confluence content. For example, your **Network** view offers an RSS feed.

1. Go to the page.
2. Locate the following icon, which is available in the top-right corner of certain pages:
3. Copy and paste the icon's link into your RSS newsreader.

**Related pages:**

- Using the RSS Feed Builder
- Managing Changes and Notifications and Tasks
- RSS Feed Macro
- Confluence User's Guide

**Notes**

If you want to customise your Confluence RSS feed (for example, use a label to filter your feed), use the **RSS**
Feed builder instead of the above instructions.

Using the RSS Feed Builder

Using the RSS feed builder, you can create customised RSS feeds to subscribe to changes within Confluence.

Wondering what an RSS feed is? See more information about RSS Feeds.

Building an RSS feed

Follow the steps below to build your feed, choosing the type of content and the time period you want to monitor.

To create a customised RSS feed:

1. Choose the help icon at top right of the screen, then choose Feed Builder.
2. Select the content types you want in your feed.
   - Check Mail if you want to know when the email archive is updated. (See the overview of mail archives in Confluence.)
3. Select one or more spaces from the list.
4. Click Advanced Options to set the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feed Name</td>
<td>The default name is based on the name of your Confluence installation. For example, 'Extranet RSS Feed'.</td>
</tr>
<tr>
<td>With these labels</td>
<td>Enter one or more labels separated by spaces or commas. Confluence returns all content (of the selected types) that matches one or more of the labels. See the hint below about using labels to customise your feeds.</td>
</tr>
<tr>
<td>Exclude these spaces</td>
<td>Exclude specific spaces from those already selected.</td>
</tr>
<tr>
<td>Sorted by</td>
<td>Sort content by either the date or creation or the date they were last updated.</td>
</tr>
<tr>
<td>Limit to</td>
<td>Specify the number of items returned in your feed.</td>
</tr>
<tr>
<td>Within the last</td>
<td>Specify how old items returned can be.</td>
</tr>
<tr>
<td>Include content for pages</td>
<td>Specify whether the entire page is displayed in the feed.</td>
</tr>
</tbody>
</table>

5. Choose Create RSS Feed.
6. Drag or copy the link into your RSS reader.

On this page:

- Building an RSS feed
- Hints
- Notes

Related pages:

- Managing Changes and Notifications and Tasks
- Subscribing to RSS Feeds within Confluence
- Confluence User's Guide

Hints

- Separate feeds. Try building separate feeds, one for pages only and one that includes comments as well. This allows you to monitor only pages if you are short of time, and to read the comments when you have
more time.

- **Labels to customise your feed.**

  You can use the RSS feed builder to track updates to labelled pages and comments on those pages. Here is an idea for customising your RSS feed by using your own personal label(s). This is useful if you want to track updates to specific pages or blog posts, and you do not want to deal with emails. You can use this method as an alternative to watching pages.
  - Build an RSS feed that returns pages, blog posts and comments labelled with a personal label, such as `my:feed`.
  - Each time you want to ‘watch’ a page, just label it with ‘my:feed’.
  - All updates and comments will automatically come through your RSS feed.

**Notes**

- **Removing an RSS feed:**

  There is no need to try to delete or remove an RSS feed built by the Confluence **RSS feed builder**.

  Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL (address). For example, take a look at the following feed URL:

  ```
  http://confluence.atlassian.com/createrssfeed.action?types=page&sort=modified&showContent=true...
  ```

  The above feed URL will generate a list of pages (`types=page`), sorted by the modification date and showing the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no need to remove anything.

- **Feed authentication options:** Confluence can offer you the option of an anonymous feed or a feed that requires authentication.
  - An anonymous feed will show only the content that is visible to anonymous users. The feed URL does not contain the `&os_authType` parameter mentioned below. This feed is useful only if your Confluence site allows anonymous access. If a feed is anonymous, you only get anonymously-viewable content in the feed regardless of whether you are a Confluence user or not.
  - An authenticated feed requires you to log in to Confluence before you can retrieve the content. The feed URL contains the following parameter: `&os_authType=basic`.
  - The option to choose between an anonymous and an authenticated feed is currently not available on the feed builder screen. The feed builder offers only authenticated feeds. See CONF-21601 for details and a workaround.

**Subscribing to a Network RSS Feed**

You can create an RSS Feed from any user’s network view, allowing you to receive summaries on the activities of users they are following in their network. The types of activities tracked in these RSS feed summaries include:

- Additions or edits to pages or blog posts
- Comments added to a page or blog post or edits to existing comments
- Updates to a user's status updates
- Updates to a user's profile

**Subscribing to a user's network feed**

**To subscribe to a user's network RSS feed:**

1. Locate the RSS icon, which is available from the top-right of:
   - The ‘Recent activity of the users you are following’ section of your network page, or
   - The ‘Activity of followed users’ section of another user's network page.
2. Copy and paste the icon's link into your RSS newsreader.
Customising your network RSS feed

Confluence does not provide a way of customising a network RSS feed via the user interface. However, you can modify the maximum number of results and type of content displayed in these feeds by directly editing the RSS feed link in your RSS newsreader.

To modify the maximum number of results displayed in your RSS feed:

1. Edit the RSS feed link in your RSS newsreader.
2. Change the value of the max parameter from its default value of 40 to a value of your choice. Example: http://confluence.atlassian.com/feeds/network.action?username=MYNAME&max=60&publicFeed=false&os_authType=basic&rssType=atom
3. Save the modified link in your RSS newsreader.

To modify the type of content displayed in your RSS feed:

1. Edit the RSS feed link in your RSS newsreader.
2. Append the parameter contentType to the end of the link, followed by an equals sign (=) and then add the appropriate content type value of your choice:
   - USER_STATUS — restricts the RSS feed to user status updates.
   - PAGE — restricts the RSS feed to page additions or updates.
   - BLOG — restricts the RSS feed to blog post additions or updates.
   - ATTACHMENT — restricts the RSS feed to attachment additions or updates.
   - COMMENT — restricts the RSS feed to comment additions or updates.
   Content type values are case-sensitive. Ensure that each parameter is separated from the other by an ampersand (&).
   Example: http://confluence.atlassian.com/feeds/network.action?username=ggaskell&max=40&publicFeed=false&os_authType=basic&rssType=atom&contentType=USER_STATUS
3. Save the modified link in your RSS newsreader.

Notes

It is not possible to filter for more than one type of content by adding multiple values to the contentType parameter.

Managing Notifications in Confluence

This page is about the notification-and-task dialog, known as the Confluence 'workbox', which drops down when you choose the icon on the Confluence page header.

Do you want to manage your notification email messages instead? See Subscribing to Email Notifications of Updates to Confluence Content.

Managing your notifications in the Confluence workbox

The workbox displays all notifications collected from Confluence page watches, shares, mentions, and tasks. If your Confluence site is linked to a JIRA issue tracker, you will also see JIRA notifications in your workbox.

You can view your notifications and convert them to personal tasks. Use the inline actions to reply to comments, like a comment or page, or watch a page. Follow the links in a notification to open the relevant page or blog post. With JIRA integration, you can watch or unwatch issues, comment on issues, or follow the link to open the issue
The workbox displays your notifications and your personal tasks in separate tabs.

**To manage your notifications:**

1. Choose the workbox icon in the Confluence page header.
   - A number may appear on the workbox icon, indicating the number of unread notifications waiting for your attention.
   - You can use the keyboard shortcut: Type g then n. (When in the Confluence editor, click outside the editor pane before pressing the keyboard shortcut keys.)

2. Choose the notifications icon:

3. Choose a notification from the list, to see the notification details. Now you can do the following:
   - Choose a link or Open to open the related page, blog post, or comment. The page will open in a new tab in your browser.
   - Choose Like or Unlike to let people know that you like, or have stopped liking, a page, blog post, or comment.
   - Choose Watch or Stop Watching to receive notifications, or stop receiving notifications, about a page or blog post.
   - Choose Reply to respond to a comment inline, within the workbox.
   - Choose the 'add task' icon to flag a notification as a task. The notification will remain in the notification list too.

**On this page:**
- Managing your notifications in the Confluence workbox
- Which notifications are included?
- Keyboard shortcuts
- Managing notifications with Confluence mobile
- Notes

**Related pages:**
- Configuring Workbox Notifications
- Subscribing to Email Notifications of Updates to Confluence Content
- Watching Pages, Spaces and Blogs
- Likes and Popular Content
- Managing Tasks in Confluence
- Confluence User's Guide

**Screenshot:** Your Confluence notifications in the workbox
Which notifications are included?

The workbox displays a notification when someone does one of the following in Confluence:

- Shares a page or blog post with you.
- Mentions you in a page, blog post or comment.
- Assigns you a task by mentioning you in a task list.
- Comments on a page or blog post that you are watching.
- Likes a page or blog post that you are watching.

The workbox does not show notifications triggered because you are watching a space. Only watches on pages and blog posts are relevant here.

The notification in your workbox appears as 'read' if you have already viewed the page or blog post.

If your Confluence site is linked to JIRA, you will also see the following JIRA notifications in your workbox:

- Comments on issues that you are watching.
- Mentions.
- Shares of issues, filters and searches.

Keyboard shortcuts

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>g then n</td>
<td>Open the Confluence workbox.</td>
</tr>
<tr>
<td>j</td>
<td>Move down to the next entry in the notification list.</td>
</tr>
<tr>
<td>k</td>
<td>Move up to the previous entry in the notification list.</td>
</tr>
</tbody>
</table>
Move down to the next notification for a particular page or blog post.

Move up to the previous notification for a particular page or blog post.

Open the selected notification.

Return to the notification list after opening a particular notification.

**Note:** The above keyboard shortcuts are available for notifications only, not for tasks, inside the Confluence workbox.

**Managing notifications with Confluence mobile**

You can view and respond to your notifications on your phone or other mobile device too. See *Using Confluence on a Mobile Device* for more about mobile platforms.

**Notes**

- Read notifications are automatically deleted after 2 weeks.
- Unread notifications are automatically deleted after 4 weeks.
- You cannot delete your notifications yourself.
- If a new notification arrives while you have workbox open, the count appears on the workbox icon but the notification is not added to the workbox. You need to close workbox and re-open it to see the new notification.
- The ability to receive notifications from JIRA or another Confluence site is available in Confluence 4.3.3 and later. To receive JIRA notifications, you need JIRA 5.2 or later.
- Administrators can enable and disable the workbox on your Confluence site. They can also connect a JIRA site or another Confluence site, so that notifications from those sites appear in your workbox too. See *Configuring Workbox Notifications*.
- The Confluence workbox is provided by a set of plugins. To remove the personal notifications and tasks functionality from your site, you can disable the following plugins. See *Disabling or Enabling a Plugin* for instructions. Disabling these plugins will disable the entire workbox. It is not possible to disable only tasks or only notifications:
  - Workbox - Common Plugin
  - Workbox - Host Plugin
  - Workbox - Confluence Provider Plugin
- If you want to re-enable the plugins, do so in the following order: Common Plugin, Host Plugin, Confluence Provider Plugin.
- There is no option to disable the workbox for an individual user.
- The workbox is not available in clustered environments. The plugin will be installed and enabled, but it will...
Managing Tasks in Confluence

You can manage your personal tasks in the notification-and-task dialog, known as the Confluence 'workbox', which drops down when you choose the icon in the Confluence page header.

You can also create a list of tasks on a page, and assign them to your colleagues via @mention. Changes made in the workbox are reflected in the task list on the page, and changes made on the page are reflected in the workbox too.

Creating personal tasks and having tasks assigned to you

There are a few ways that you and other people can assign tasks to you:

- You can add a personal task via the workbox.
- You can add a notification to your task list, via the notification workbox. This is useful if you want to get back to it later.
- Someone can assign you a task from a task list on a Confluence page.
- Other Confluence actions may create a task for you. For example, your Confluence site may be running a plugin that creates and assigns tasks.

Managing your personal tasks in the workbox

The workbox displays your notifications and your personal tasks in separate tabs. The task tab shows the tasks assigned to you. When you update a task that originated in a task list on a page, the update is reflected in the task list too.

Screenshot: Your personal tasks in the workbox
To manage your tasks:

1. Choose the workbox icon \( \text{} \) in the Confluence page header.
   - You can use the keyboard shortcut: Type \text{g} then \text{n}. (When in the Confluence editor, click outside the editor pane before pressing the keyboard shortcut keys.)
   - The icon indicates the number of unread notifications.

2. Choose the personal tasks icon: \( \text{} \)
3. To add a task and assign it to yourself, type the task summary in the text box and choose \textbf{Add task}.
4. To prioritise tasks, drag and drop them into your chosen order. (Click a task, hold down your mouse button to drag the task into position, then release the mouse button.)
5. To complete a task, or mark it as incomplete, choose the check box next to the task.
6. To add notes to a task and see further information (for example, a related page) choose the task item. The task details dialog will open.
7. To see the tasks that are marked as complete, choose \textbf{View completed}.

Adding your notifications to your task list

You can flag a notification as a task. This is useful if you want to take action on the notification later.

To add a notification to your task list:

1. Choose the workbox icon \( \text{} \) in the Confluence page header.
   - You can use the keyboard shortcut: Type \text{g} then \text{n}. (When in the Confluence editor, click outside the editor pane before pressing the keyboard shortcut keys.)
   - The icon above shows that you have 3 unread notifications.
1. Choose the notifications icon:

2. Choose the notification that you want to add to your task list. The notification details dialog will open.

3. Choose the 'add task' icon to add this notification to your tasks. The notification will remain in the notification list too.

See Managing Notifications in Confluence for a full description of notifications.

Screenshot: The notification details dialog

Creating task lists and managing tasks on a page

Task lists on a page are useful for assigning and managing tasks in a team.

**To add a task list on a page:**

1. Edit the page.
2. Choose the task-list icon in the editor toolbar, or press [ and then ] on your keyboard.
3. Type the description of the task.
4. If you want to assign a task to someone, type '@' and the person's name in the task description. (For more information about @mentions, see Using Mentions.) That person will receive a notification, and the task will appear in their personal task list in the workbox. If you @mention yourself, the task will appear in your personal task list.
5. To end the list, press Enter twice.

**Keyboard shortcuts:**

- To add a task list, press [ and then ] on your keyboard.
- To indent a task, press Tab.
- To undo an indent, press Shift+Tab.

**Managing tasks on a page:**

- When viewing a page, you and other viewers can mark tasks as complete or incomplete. Updates to a task on the page will be transferred to the workbox too. (See above.)
- To be able to update a task list when in view mode, you need permission to edit the page:
  - You need the 'Create page' permission in the space. See Space Permissions Overview.
  - There must not be any page restrictions that prevent you from editing the page. See Page Restrictions.

**What if the update fails?**
This section describes what you should do if Confluence displays an error message saying that your change to a task list could not be saved. The cause is probably one of the following:

- Your session has expired. **Resolution:** Log in and update the task list again.
- You do not have permission to update the task list. **Resolution:** Check your permissions. You need 'Create page' permission in the space. Please check also that there are no page restrictions that prevent you from editing the page.
- The network is down. **Resolution:** Please try again when the network is available.

**Screenshot: A task list on a page**

Managing tasks with Confluence mobile

You can view and manage your tasks on your phone or other mobile device too. See Using Confluence on a Mobile Device for more about mobile platforms.

**Notes**

- Administrators can enable and disable the workbox on your Confluence site. They can also connect a JIRA site or another Confluence site, so that notifications from those sites appear in your workbox too. See Configuring Workbox Notifications.
- The Confluence workbox is provided by a set of plugins. To remove the personal notifications and tasks functionality from your site, you can disable the following plugins. See Disabling or Enabling a Plugin for instructions. Disabling these plugins will disable the entire workbox. It is not possible to disable only tasks or only notifications:
  - Workbox - Common Plugin
  - Workbox - Host Plugin
  - Workbox - Confluence Provider Plugin
- If you want to re-enable the plugins, do so in the following order: Common Plugin, Host Plugin, Confluence Provider Plugin.
- There is no option to disable the workbox for an individual user.
- The workbox is not available in clustered environments. The plugin will be installed and enabled, but it will detect that the site is in clustered mode and will not display the dialog.
Completed tasks in the workbox are automatically deleted after 7 days.
You cannot disable the functionality that provides task lists on a page.
There is no link between the tasks in a Tasklist Macro and the tasks described above. The tasks from the macro do not appear in the workbox.

Have a feature request? If you are interested in expanding the functionality of tasks in Confluence, you can collaborate with other customers, vote and view all the open feature requests for this feature in the workbox component of the Confluence issue tracker.
For example, here are some of the feature requests on the issue tracker:
- Ability to get a list of tasks from content: CONF-26688
- Ability to see other users tasks: CONF-26615

Finding Content
Where does a page or blog post go when you create it, and how can you find it again? How can you find content that is most relevant to your team or project, or search for pages that cover the topic you are interested in?

Hint for space administrators: Help your team members and colleagues find important pages and other content, by adding links to the space's sidebar. See Configuring a Sidebar.

A space is an area within Confluence, containing your pages, blog posts and other content. You can think of each space as a sub-site, or mini-site, each with its own home page.

Finding pages and blog posts
These are the quickest ways to find your content:
- Use the links in the sidebar to find your pages, blog posts, and other parts of the space. See more details below.
- Type the page name or key words into the search box at the top right of the Confluence screen. See Searching Confluence.
- Go to the pages view for a list of pages in the space. You can see recently updated pages or browse through a hierarchical (tree) view. See Viewing All Pages in a Space.

More about the sidebar
The sidebar appears on the left of every page in spaces that use the default Confluence theme. You can:
- Choose a different type of content, or perform various operations, via the links on the sidebar.
- Use the contextual navigation options that appear at the bottom of the sidebar, based on the type of content you are viewing.
- Collapse or expand the sidebar.
- Access the sidebar options via slide-out menus even when the sidebar is collapsed.
- Configure the links that appear in the 'Shortcut links' section, if you are a space administrator.

On this page:
- Finding pages and blog posts
- More about the sidebar
- Collapsing the sidebar
- Where does Confluence put your pages and blog posts?
- Can you change the location of a page?
- Can you change the location of a blog post?

Related pages:
- Creating Content
- Organising Content
- Giving People Access to Content
- Using the Documentation Theme
- Confluence User's Guide

Screenshot: Sidebar in the default theme
<table>
<thead>
<tr>
<th>Section or option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link to the space home page</td>
<td>This link appears next to the space logo at the top of the sidebar. It takes you to the home page for this space. Clicking on the space logo will also take you to the home page for the space.</td>
</tr>
</tbody>
</table>
| Pages and Blog             | This section can contain the links to the following locations:  
  - **Pages**: An index of all pages in the space. See Viewing All Pages in a Space. Note that space administrators can hide the 'Pages' link.  
  - **Blog**: An index of all blog posts in the space. See Working with Blog Posts. Note that space administrators can hide the 'Blog' link.  
  - Other links added by add-ons. |
| Space shortcuts            | This area contains links to important pages and other locations for your project or team. Space administrators can add and remove links here. See Configuring a Sidebar. |
| Space Tools                | The 'Advanced' option gives access to space administration and advanced operations like space exports and space watches.                         |
| Configure sidebar          | The 'Configure sidebar' option is available to space administrators for setting up shortcut links, changing the space name and logo, and other configuration options. See Configuring a Sidebar. |
Contextual navigation

The links in this area change, depending on the section of the space that you are viewing.

- For pages, you will see the child pages (if any) of the current page, and a quick link to create a child page.
- For blogs, you will see links to blog posts in the current month, and an expandable list of previous months.
- If you are viewing the space tools option, you will see content toots, space administration, and other advanced options. Add-ons can add options here too.

Collapsing the sidebar

Advanced users will find it useful to collapse the sidebar and gain more space on the page.

- Grab and drag the border, choose the >> button or use the keyboard shortcut [ to collapse and expand the sidebar.
- Access the sidebar options via slide-out menus even when the sidebar is collapsed.

Where does Confluence put your pages and blog posts?

When you create a new page, that page will be a child of another page, in the space that you selected in the ‘Create’ dialog. The parent page depends on where you are when you create the page.

<table>
<thead>
<tr>
<th>Your location when creating the page</th>
<th>Location of new page</th>
</tr>
</thead>
<tbody>
<tr>
<td>You are viewing a page in the same space where you will put the new page – that is, the space that you select in the ‘Create’ dialog.</td>
<td>A child of the page you are currently viewing.</td>
</tr>
</tbody>
</table>
You are viewing any other Confluence screen. For example:

- You are on the dashboard.
- You are on the ‘Pages’ view of a space.
- You are viewing a blog post.
- You are viewing a page in a space, and choose to add your new page in a different space.

A child of the home page in the space you select in the ‘Create’ dialog.

A blog post is part of a chronological sequence of posts, linked from the space's 'Blog' index page.

**Can you change the location of a page?**

Yes. See [Moving a Page](#).

**Can you change the location of a blog post?**

No.

**Searching Confluence**

Quick guide to searching in Confluence:

1. Use the search box at the top right of your Confluence screen. It offers you a quick navigation aid as well as a full site search.
2. You can search for administrative actions via the quick navigation aid too.
3. You can search Confluence directly from your browser's search box. Just add your Confluence site as a search provider using the dropdown menu in your browser's search box.
4. While editing a page or a blog post, you can find and replace text on the page. See [Using the Editor](#).

Using the quick navigation aid to find content and administrative actions

When you enter text into the Confluence search box, the quick navigation aid automatically offers a dropdown list of pages, administrative options, and other items. The items are matched by page name to your search query. You can choose one of the offered items or ignore them altogether.

To use the quick navigation aid to find content:

1. Start typing your query into the search box located at the top right-hand corner of every screen. Confluence matches titles as you type, showing a quickly-adjusting dropdown list of pages, blog posts, personal profiles, attachments and so on.
   - Press the Enter key if you want to bypass the quick navigation aid and perform a full search, as described below.
2. To see the space to which an item belongs, let your mouse pointer hover over the item in the dropdown list.
3. Use the up- and down-arrows on your keyboard to move up and down the list of matching titles and select an item.
4. Press the Enter key to open the selected item.
5. If you do not find what you are looking for, click Search for at the bottom of the list to do a full search. This has the same effect as pressing Enter immediately after typing your search query. The full search is described below.

To use the quick navigation aid to get to administration functions: Start typing what you want to do into the Confluence search box. The matching administrative functions will appear with a cog icon at the top of the dropdown search results.

**Even faster via 'GG':** Press ‘G’ twice on your keyboard then continue typing the search term.

*Screenshot: The quick navigation aid showing titles matching the query 'st'*
Here is more information about how the quick navigation feature works:

- Confluence will truncate any titles that are too long to be displayed.
- The matching items are grouped by type so that you can quickly find the type you want. Confluence shows a maximum of 3 administrative items, 6 pages and/or blog posts, 2 attachments, 3 people and 2 spaces. If no matches are found in a particular category, then that category does not appear in the list.
- Items are ordered with the most recent updates first.
- When the matching item is a person's name, their profile picture appears next to their name in the list.
- The part of the title that is matched by the search query is highlighted in bold text.
- Your Confluence Administrator can enable or disable the quick navigation feature using the Confluence Administration Console.

Notes about finding administrative options via the search box:
- Pressing 'GG' puts your cursor into the search box.
- The 'GG' combination is familiar to JIRA users, because the same shortcut opens the JIRA administration search dialog.
- System administration, Confluence administration and space administration options may appear in the
search results.

- Confluence permissions determine the administrative options that appear in the search results. You will only see the options that you have permission to perform.

On this page:

- Using the quick navigation aid to find content and administrative actions
- Performing a full search
- Filtering your search results
- Searching for labels
- Searching the content of attachments
- Search options when using the Documentation theme
- Advanced search syntax
- Searching Confluence from your browser’s search box
- Useful plugins
- Notes

Related pages:

- Confluence Search Syntax
- Confluence Search Fields
- Search Results Macro
- Livesearch Macro
- Page Tree Macro (includes an optional search box)
- Viewing Labels and Labelled Content
- Searching the People Directory
- Confluence User’s Guide

Performing a full search

When you perform a full search, Confluence will search all content in all spaces (site and personal), mail, personal profiles, attachments and the space description. The results will appear on a new screen.

To use the full search:

1. Type your query into the search box located at the top right-hand corner of every screen (or type it into the text box at the top of the Search screen).
2. Press the Enter key. (This means that you will ignore the dropdown list of titles offered by Confluence’s quick navigation aid, described above.)
3. The search screen appears, as shown below. If any Confluence pages or items match your search query, the search screen shows a list of the matching items.
4. Click an item's title to open the Confluence page or other item.

Screenshot: Search results page
On the right of the screen you will see a text block for each item that matched the search criteria, with the following information for each item:

- An icon representing the content type (user profile, space, page, blog post, etc).
- The title or name of the content item, linked to the item.
- The most relevant few lines of content from within the item. Any words that match your search query are highlighted within the content.
- The space to which the item belongs, displayed on the last line of the item’s text block.
- The date when the content item was last modified.

You will see only search results which you have permission to view.

On the left of the screen are further options which allow you to tailor or filter your search results. See below.

Filtering your search results

The search screen, pictured above, appears when you do your first search. By default, Confluence will search all content across your Confluence site, including all spaces, mail archives, attachments and all other content types.
On the left of the screen are options which allow you to tailor (filter) the search results.

Define your filter criteria:

- **Type** – Restrict your search results to a particular content type (pages, blog posts, comments, etc).
- **Last modified** – Restrict your search results to content updated within a particular period of time (within the previous 24 hours, within a week, within a month, or within a year).
- **Space** – Restrict your search results to a particular space, or to your favourite spaces, site spaces or personal spaces. You can also set an option to include archived spaces. (See Archiving a Space.)
- **By** – Restrict your search results to content last modified by a particular person. You can start typing the person's username or part of their name into the text box as follows:
  - Type the username (for example: 'jsmith').
  - Or start typing the person's first name (for example: 'john').
  - Or their last name (for example: 'smith').
  - Or another part of their name, such as a middle name. Confluence will offer you a list of possible matches. Use your mouse to select the person you want, then press the Enter key to filter the search results.

More information about the user-matching filter:

- The user-matching filter is *not* case sensitive. You can enter upper or lower case letters and will receive the same results.
- When looking for users to match the name you entered, Confluence divides a person’s name into logical units corresponding to first name, middle name (one or more) and last name. It matches the letters of each unit in the name you entered against the letters of each unit in the user directory. For example, you can enter ‘jo sm’ to look for John Smith. The search is triggered after you have entered at least two letters.
- For each part of the name, you need to enter at least two letters. For example, if you enter just ‘john s’, the filter will look for users called ‘john’ and will ignore the ‘s’. Similarly, if you enter ‘j smith’ you will see everyone with the name ‘smith’ even if their first name does not start with a ‘j’.
- You are not forced to use the auto-complete list. You can just type ‘jsmith’ or ‘jo sm’ and filter on that without choosing a match from the dropdown list. Confluence will warn you if there is more than one user corresponding to the name you have entered.

**Searching for labels**

Use the 'labelText:' prefix to search specifically for content that has a specific label. The table below gives examples of search terms that you can enter into Confluence's search box, and the search results that you can expect.

<table>
<thead>
<tr>
<th>Searching for ...</th>
<th>Returns content that ...</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>recipe labelText:chocolate</code></td>
<td>contains the word 'recipe' or has the label 'chocolate'</td>
</tr>
<tr>
<td><code>recipe AND labelText:chocolate</code></td>
<td>contains the word 'recipe' and has the label 'chocolate'</td>
</tr>
<tr>
<td><code>labelText:cake labelText:chocolate</code></td>
<td>has the label 'cake' or the label 'chocolate'</td>
</tr>
<tr>
<td><code>labelText:cake AND labelText:chocolate</code></td>
<td>has both labels 'cake' and 'chocolate'</td>
</tr>
</tbody>
</table>
The 'labelText:' prefix is an example of a search field. See more about Confluence Search Fields.

Searching the content of attachments

When you search Confluence, by default the search will include the content of the following types of attachments:

- Word
- Text
- PowerPoint
- Excel
- PDF
- HTML

To search the content of other attachment types, you will need to use an attachment content extractor plugin. For more information, take a look at the following:

- Existing extractor plugins which you can install on your Confluence site. See this search on Atlassian Marketplace.
- Guidelines on developing your own attachment content extractor plugin. See our developer documentation on extractor plugins.

Search options when using the Documentation theme

When using the Documentation theme, the Confluence search offers a few options as described below.

Using the search box at the top right of the page:

- By default, the main Confluence search is configured to search the entire Confluence site. You will see the words 'Search Confluence' in the search box at top right of the page.
- The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
- A space administrator can configure the Documentation theme to restrict the search to the current space. You will see the words 'Search this space' in the search box at top right of the page.
- The search will return results from the current space only.
- You can override the search restriction. Enter 'all:' and your search term to search the entire site for 'technical writing':

  all: technical writing

Using the search box in the left-hand panel:

- By default, the Documentation theme's left-hand panel includes a search box. Enter your search term there, to restrict the search to the current space. Specifically, this will search only the pages that are children of the space's home page.
- If your administrator has restricted the main search to the current space, there will not be a search box in the left-hand panel.

For screenshots and a full description, see Using the Documentation Theme.

Advanced search syntax

See Confluence Search Syntax for more ways to refine the text you enter into the search box.

Additionally, see Confluence Search Fields for special parameters you can use in the search box to search on various metadata.
Searching Confluence from your browser’s search box

If you are using Firefox or Internet Explorer 7 or later, you can add add your Confluence site as a search provider, using the dropdown menu next to the browser’s search box.

The example below shows the 'Extranet' Confluence site offered for inclusion as a search engine in the browser's search box.

*Screenshot: Adding your Confluence site to your browser's search box*

Information about OpenSearch:

- Confluence supports the autodiscovery part of the OpenSearch standard, by supplying an OpenSearch description document. This is an XML file that describes the web interface provided by Confluence’s search function.
- Any client applications that support OpenSearch will be able to add Confluence to their list of search engines.
- Your Confluence Administrator can enable or disable the Open Search feature using the Confluence Administration Console.

Useful plugins

*Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.*

This plugin extends the Confluence search, so that you can search for macro parameter names and values: the *Confluence Macro Indexer plugin*.

Notes

**For developers:** The rendering of search results in Confluence is pluggable. If you are a developer, you may wish to write your own search result renderer to change how the search results are displayed. For more information, please refer to the following developer document: *Writing a search result renderer*.

**Confluence Search Syntax**

This page describes the special words and punctuation marks you can use to refine your search.

Matched phrase search

Use double quotes to search for content that contains the phrase 'cheese one', or a phrase where 'cheese' and 'one' are the major words:

"cheese one"

**Note:** Confluence will ignore common words (stop words), including 'and', 'the', 'or', and more, even if they are...
included within double quotes. See the default list of stop words used by Confluence’s search engine, Lucene, in the Lucene documentation.

For example:

1. Searching for "cheese one" returns only pages in which ‘one’ appears as the first word (other than stop words) after ‘cheese’. So it will return ‘cheese for one’ or ‘cheese to one’ or ‘cheese one’. It does not return ‘one cheese’ or ‘cheese flamingo one’.
2. Searching for "the one" returns all pages containing ‘one’ because ‘the’ is a stop word.

If you would like to override Lucene’s tokenisation and stemming, please cast your vote on this improvement request: CONF-14910.

OR search

To search for content that contains one of the terms, ‘chalk’ or ‘cheese’, use the operator OR in capital letters:

chalk OR cheese

On this page:
- Matched phrase search
- OR search
- AND search
- NOT search
- Excluded term search
- Grouping search
- Title search
- Wildcard searches
- Proximity searches
- Range search
- Fuzzy search
- Combined search
- Searching for macros
- Searching for labels

Related pages:
- Searching Confluence
- Confluence Search Fields
- Confluence User’s Guide

AND search

To search for content that contains both the terms ‘chalk’ and ‘cheese’, use the operator AND in capital letters:

chalk AND cheese

NOT search

To search for content that contains ‘chalk’ but NOT ‘cheese’, use the operator NOT in capital letters:

chalk NOT cheese

Excluded term search

To search for content that contains ‘chalk’ and ‘butter’ but not ‘cheese’:
Grouping search
To search for content that must contain 'chalk' but can contain either 'cheese' or 'butter', use brackets to group the search terms:

(cheese OR butter) AND chalk

Title search
To search for content with 'chalk' in its title, where title is the field keyword.

title:chalk

Wildcard searches

**Single character**
To search for 'butter' or 'batter' you can use a question mark as a wildcard:

b?tter

To search for 'chicken' or 'chickpea' you can use an asterisk as a wildcard:

chick*

⚠️ Leading wildcards is an experimental feature currently only available in our OnDemand offering.

You can use wildcards anywhere within a word, even at the very beginning:

*chick

**Multiple characters**
To search for 'chick' or 'chickpea':

c*c*

You can also combine search characters to get the exact word. For example the search term below will return 'chick' but not 'chickpea':

c*c?
**Case sensitivity in wildcard searches**

Confluence is case sensitive for wildcard searches.

Note: All the example searches given above will search across the default set of fields which are stored as lower case and therefore all searches of that style should be given lower case search terms (as shown in the examples).

However, if you were to search one of the case sensitive fields, such as 'content-name-untokenized' the case of your search term would need to match the document you are searching for.

**Proximity searches**

Use a tilde character followed by a number, to find two words within a certain number of words of each other. For example, the following search will return 'Octagon blog post':

```
"octagon post"~1
```

The following search is not valid:

```
"octagon post"~0
```

**Range search**

Use the operator 'TO', in capital letters, to search for names that fall alphabetically within a specified range:

```
[adam TO ben]
```

Note: You cannot use the AND keyword inside this statement.

**Fuzzy search**

Use a tilde character to find words spelled similarly.

To search for octagon, if unsure about spelling:

```
ocotgan~
```

**Combined search**

You can also combine various search terms together:

```
o?tag* AND past~ AND ("blog" AND "post")
```

**Searching for macros**

You can search Confluence content for anywhere a macro is used. To do this, just add macroName: to your search and append the macro name after the column. For example, search for all excerpt-include macros:

```
macroName:excerpt-include*
```

For more information about macroName and other search fields, see Confluence Search Fields.

**Searching for labels**
Use the 'labelText:' prefix to search specifically for content that has a specific label. The table below gives examples of search terms that you can enter into Confluence's search box, and the search results that you can expect.

<table>
<thead>
<tr>
<th>Searching for ...</th>
<th>Returns content that ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>recipe labelText:chocolate</td>
<td>contains the word 'recipe' or has the label 'chocolate'</td>
</tr>
<tr>
<td>recipe AND labelText:chocolate</td>
<td>contains the word 'recipe' and has the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake labelText:chocolate</td>
<td>has the label 'cake' or the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake AND labelText:chocolate</td>
<td>has both labels 'cake' and 'chocolate'</td>
</tr>
</tbody>
</table>

The 'labelText:' prefix is an example of a search field. See more about Confluence Search Fields.

**Confluence Search Fields**

This page gives an overview of the Apache Lucene search fields used in Confluence.

**Searching for content in specific fields**

Confluence data is stored in fields which can be specified in the search. To search a specific field, type the name of the field followed by a colon ':' and then the term you are looking for.

Preliminary examples:

- title:"Some Title"
- labelText:chalk

The field specification applies only to the term directly preceding the colon. For example, the query below will look for "Some" in the title field and will search for "Heading" in the default fields.

- title:Some Heading

**On this page:**
- Searching for content in specific fields
- Confluence search fields
  - Personal Information
  - Pages
  - Blog
  - Attachments
  - Mail items
- More examples
- Searching for labels
- Useful plugins

**Related pages:**
- Searching Confluence
- Confluence Search Syntax
- Confluence User's Guide

Confluence search fields

Below are the fields which can be searched, listed by content type.
### Personal Information

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>fullName</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>username</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

### Pages

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>lastModifiers</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>Username of the user who last updated the page.</td>
</tr>
<tr>
<td>creatorName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>Username of the user who added the page.</td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used on the page</td>
</tr>
</tbody>
</table>

### Blog

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Indexed</td>
<td>Stored</td>
<td>Tokenised</td>
<td>Notes</td>
</tr>
<tr>
<td>------------</td>
<td>---------</td>
<td>--------</td>
<td>-----------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>filename</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>comment</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>lastModifiers</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>Username of the user who last updated the blog post.</td>
</tr>
<tr>
<td>creatorName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>Username of the user who created the blog post.</td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used in the blog</td>
</tr>
</tbody>
</table>

Attachments

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>filename</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>comment</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

Mail items

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>messageid</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>inreplyto</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>recipients</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>userpermission</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>lastModifiers</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
</tbody>
</table>

| creatorName | true | true | false |

The username of the user who did the mail import, not the person who sent the email message.

More examples

**Searching for labels**

Use the 'labelText:' prefix to search specifically for content that has a specific label. The table below gives examples of search terms that you can enter into Confluence's search box, and the search results that you can expect.

<table>
<thead>
<tr>
<th>Searching for ...</th>
<th>Returns content that ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>recipe labelText:chocolate</td>
<td>contains the word 'recipe' or has the label 'chocolate'</td>
</tr>
<tr>
<td>recipe AND labelText:chocolate</td>
<td>contains the word 'recipe' and has the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake labelText:chocolate</td>
<td>has the label 'cake' or the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake AND labelText:chocolate</td>
<td>has both labels 'cake' and 'chocolate'</td>
</tr>
</tbody>
</table>

The 'labelText:' prefix is an example of a search field. See more about Confluence Search Fields.

**Useful plugins**

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

This plugin extends the Confluence search, so that you can search for macro parameter names and values: the Confluence Macro Indexer plugin.
Searching the People Directory

The people directory displays a list of people who are authorised to log in to your Confluence site.

The people directory includes anybody who has logged into Confluence or who has had a user account created for them in Confluence.

The people directory does not include users who can log into Confluence using external user management if they have never yet logged in.

Viewing the people directory

Choose People at the top of the screen.

Searching for people

To search for a particular person, type their first name and/or last name into the search box and choose Search.

- To see everyone who uses your Confluence site, choose All People.
- To see just those people who have set up a personal space, choose People with Personal Spaces.

Following people’s activities

Confluence’s network features allow you to ‘follow’ (that is, keep track of) other people's activities in your Confluence site. For more information, please refer to Network Overview. You can use the hover profile feature in the people directory to start following other people.

- To start following someone, move your mouse over their name or profile picture and choose Follow in their profile popup.
- To stop following someone, move your mouse over their name or profile picture and choose Stop Following in their profile popup.

Once you start following another person, their activities will start appearing in your network view.

On this page:
- Viewing the people directory
- Searching for people
- Following people’s activities
- Notes

Related pages:
- Setting Up your Personal Space
- Editing your User Profile
- Choosing a Profile Picture
- Confluence User’s Guide

Screenshot: The people directory

<table>
<thead>
<tr>
<th>People Directory</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>All People</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>People with Personal Spaces</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>All People</th>
</tr>
</thead>
<tbody>
<tr>
<td>Josh User</td>
</tr>
<tr>
<td>Sophie Staunton</td>
</tr>
<tr>
<td>Ewan User</td>
</tr>
<tr>
<td>Rach Admin</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><a href="mailto:sample@email.com.au">sample@email.com.au</a></td>
</tr>
<tr>
<td><a href="mailto:sample@email.com.au">sample@email.com.au</a></td>
</tr>
<tr>
<td><a href="mailto:sample@email.com.au">sample@email.com.au</a></td>
</tr>
</tbody>
</table>

Notes
The **people directory** uses the hCard microformat for simple integration with a variety of microformat-enabled tools. hCard is an open data format for representing people, companies, organisations, and places. Read more about [microformats](#) and [hCard](#).

By default, deactivated users (disabled user accounts) are excluded from the people directory. You can include them by adding the `showDeactivatedUsers` parameter to the URL. For example:

```
http://my.confluence.com/dopeopledirectorysearch.action?showDeactivatedUsers=true
```

By default, externally deleted users (for example, users deleted from an LDAP repository) are excluded from the people directory. You can include them by adding the `showExternallyDeletedUsers` parameter to the URL. For example:

```
http://my.confluence.com/dopeopledirectorysearch.action?showExternallyDeletedUsers=true
```

The Confluence administrator can hide the people directory. If it is hidden, you will not see the **People Directory** option.

### Organising Content

Confluence provides a number of ways for organising and structuring content in the wiki:

- **Spaces** allow you to group content according to major categories.
- **Pages** are used for discrete topics, and can be structured into page trees to show the relation between them.
- **Favourites** are particular pages or spaces that have been bookmarked by a user, to make them easy to find again.
- **Labels** are user-defined tags that are added to related pages in order to categorise them in some way.
- **Attachments** to a page can include images, multimedia, Office and PDF files, and provide a way to include other forms of content in the wiki.

- The **sidebar** is a good place to display important links for your team or project.
- **Email** can be collected and archived within each space, to manage all mail related to a project.

![Related pages](#)

**Changing the Sequential Order of Pages**
**Creating Content**
**Searching Confluence**
**Confluence User’s Guide**

### Working with Pages

Pages are the primary means of storing and sharing information in Confluence. Pages are contained within **spaces**.

- Use **spaces** to organise your wiki content into your primary logical groups. For example, you could have a space per team, per product, or per department.
- Use **pages** to organise your content into lower-level groups. For example, you could have a page for a particular team activity, or for a feature in a product, or for a chapter in a book. Add more child pages to contain lower-level details if necessary.

Things you can do with pages in Confluence:

- Create a new page from anywhere within the site.
- Write content using the editor.
- Rename a page.
- Copy a page.
- Delete a page or remove a specific version of a page.
• Move pages and organise them hierarchically while editing a page or while viewing the space's Tree view.
• Navigate within and between spaces through flexible linking.
• Collaborate via comments on a page.
• Control access through page security restrictions.
• Monitor page updates and other activity through page notifications.
• View page history, and manage and compare versions of a page.
• Search page content, including attachments.
• Export pages to PDF, WORD, HTML or XML.
• Email page content.
• Like a page.

**Related pages:**
- Creating Content
- Working with Drafts
- Working with the Office Connector
- Viewing Recently Visited Content
- Confluence User's Guide

### Moving a Page

This guide describes how to change a page's location. You can:

- Change the default location of a new page.
- Move an existing page to a different space.
- Move an existing page to a different parent page within the same space.
- Reorder pages that are children of the same parent.

When you move a page, attachments and comments will be moved with the page. All child and descendent pages will also be moved.

**Notes about permissions:**

To move a page, you need the following permissions:

- 'Add' permission on the page you are moving, and
- 'View' permission on the page's parent page. So if you are moving the page to a different parent, you need 'View' permission on the new parent.

To move a page into a different space, you also need:

- 'Delete' permission on the space you are moving from, and
- 'Add' permission on the space you are moving to.

If the page has page restrictions, and you want to keep the page restrictions in the new location, you will also need 'Restrict' permission on the space you are moving to. Alternatively, remove the page restrictions before performing the move.

### On this page:
- Setting the location of a new page
- Moving a page to a different space
- Moving a page within a space
- Notes

**Related pages:**
- Moving an Attachment
- Copying a Page
- Deleting a Page
- Changing the Sequential Order of Pages
- Overview of Pages
- Confluence User's Guide

### Setting the location of a new page

While you are creating a **new** page, you can set the page's location before saving the page.

**To set the location for a new page:**
1. While editing the page, choose Location.
2. Use the tabs on the left of the 'Set Page Location' dialog to help you find the new space and parent page for your page. They determine the location of your page. The 'Current location' and 'New location' breadcrumb trails at the bottom of the dialog indicate the current parent page and new parent page.
3. If you want to move a page to a different position amongst the child pages, select Reorder. (When you choose Move in the next step, you will be able to reorder the page.)
4. Choose Move.
5. If you are reordering the child pages, position the pointer in the list to set the new position for the page and choose Reorder.

**Screenshot: Setting the location of a new page**

Moving a page to a different space

You can move a page, along with its child pages, to a different space. Confluence will automatically adjust all links to the moved pages, to point to the pages in the new space.

**To move a page to another space in your Confluence site:**

1. Go to the page and choose Tools > Move.
2. Use the tabs on the left to help you find the new space and parent page for your page. They determine the location of your page. The 'Current location' and 'New location' breadcrumb trails at the bottom of the dialog indicate the current parent page and new parent page.
3. If you want to move a page to a different position amongst the child pages, select Reorder. (When you choose Move in the next step, you will be able to reorder the page.)
4. Choose Move.
5. If you are reordering the child pages, position the pointer in the list to set the new position for the page and choose Reorder.

Moving a page within a space

You can move a page to a different position in the page tree. This allows you to:
• Move a single page, or a family of pages, to a different parent within the space.
• Reorder pages that are children of the same parent.

All links to the page are maintained. When you move a parent page, the entire hierarchy of child pages will move too.

To move a page:

1. Go to the space and choose Space tools > Reorder pages on the sidebar.
   If your space is using the Documentation theme choose Browse > Pages.
2. Expand the branches to locate the page you want to move.
3. Drag the page to a new position in the tree.
4. While dragging the page, you see one of the following:
   • A thin line between existing pages - this indicates the potential new position for the page. Release the mouse button when the page is where you want it.
   • A wide highlight over one or more existing pages - this indicates that you can drop the page into a page family. Release the mouse button to add the page to the family. The page will appear either in alphabetical sequence or as the last page in the family, depending on the family’s sequential order.

Notes

• The new position of the page is saved as soon as you release the mouse button.
• To cancel the move, press the 'Esc' key before releasing the mouse button.

Copying a Page

You can copy a page, to create a duplicate of the page content. You will need to rename the page, because a page name must be unique within a space.

You need 'Create Pages' permission, which is assigned by a space administrator from the Space Administration screens. See space permissions or contact a space administrator for more information.

To copy a page:

1. Go to a page in the space and choose Tools > Copy. Confluence will open a copy of the page in the editor. By default, Confluence will name the page 'Copy of <<original page name>>'.
2. Rename the page and make any other changes required in the body of the page.
3. If you need to move the new page to a different space or a different parent, you can edit the Location. Refer to the instructions on moving a page.
4. Click Save.

Related pages:
• Working with Pages
• Moving a Page
• Confluence User's Guide

Screenshot: Copying a page

Notes

• Copying a page will duplicate all of the original page's attachments and labels, but will not copy comments from the original page.
• This method of copying a page does not copy the child pages. Please add your vote to issue CONF-2814 if you’d like to see this improvement.
• You can copy an entire space, including all pages in the space (parents and children) — refer to these instructions on copying a space.
• Consider using WebDAV to move or copy a page hierarchy from one space to another, provided that none of the page names already exist in the target space.

Renaming a Page
To rename an existing page, you require 'Edit Pages' permission which is assigned by a space administrator from the Space Administration screens. See Space permissions or contact a space administrator for more information.

To rename a page:
1. Go to a page in the space, and click Edit at the top to view the page in 'Edit' mode.
2. Change the page title as required.
3. Click Save.

Related pages:
• Working with Pages
• Confluence User's Guide

Notes
• Confluence will automatically update all internal links to point to your new page title. This only works for relative links that use the relative link syntax, for example [Renaming a Page].
• In macros, page links will not be updated. You need to update these manually.
• Links from external sites will be broken, unless they use the permanent URL - see Working with Links.

Deleting a Page
By default, when you delete a page in Confluence, this will delete all versions of the page. To do that, you need the 'Delete Pages' permission. See Space permissions. If someone has applied page restrictions to the page, the restrictions may prevent you from deleting the page too.

If you want to delete a specific version of a page, you need to be a space administrator.

Deleting all versions of a page

To delete a page:
Go to the page and choose Tools > Delete. Confirm the action as prompted.

Note: The 'Delete' option will only appear if you have permission to delete this page.

Deleting a specific version of a page

To delete just one version of a page:
1. Go to the page and choose Tools > Page History.
2. Choose Delete next to the version you want to delete, and confirm the action as prompted.

On this page:
• Deleting all versions of a page
• Deleting a specific version of a page
• Deleting a page and all its children
• Notes

Related pages:
• Restoring a Deleted Page
• Purging Deleted Pages
• Creating Content
• Editing or Deleting a Page That Won't Render
• Confluence User's Guide

Deleting a page and all its children
If the page you are deleting has any child pages, the child pages will move to the root of the space. The child pages will not be deleted, but they will lose the parent-child relationship with the deleted page.

**Hint:** If you need to remove a parent page and a large number of child pages:

- Create a temporary new space.
- Move the parent page to the new space. The child pages will move too.
- Remove the space.

**Notes**

- When you delete a page, Confluence moves it to the trash. Space administrators can recover pages from the trash. For important notes about what happens when you restore deleted pages, see [Restoring a Deleted Page](#).
- Purge the trash to delete the page permanently.
- When you delete a version of a page, the version is not stored in the trash. The deletion of a version is therefore permanent and cannot be undone.
- Attachments attached to a deleted page will remain in the database (allowing potential retrieval) until the trash is purged. When the trash is purged, all attachments on that page are permanently removed.
- When you delete a version of a page, the version numbers of the later versions will change accordingly. For example, if a page has four versions and you delete version 2, then version 3 will become version 2 and version 4 will become version 3.

**Purging Deleted Pages**

When a user deletes a page from a Confluence space, the page is not permanently removed. Instead, Confluence places the deleted page into the 'Trash'. The page will remain in 'Trash' until a space administrator purges the page.

Purging deleted pages permanently clears them from 'Trash'.

You need to be a space administrator to purge deleted pages for a space.

To purge deleted pages:

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Trash**
3. A list of deleted pages and blog posts for the space displays. Choose **Purge** for a specific page or **Purge All** to permanently clear all deleted pages and news items.

If your space is using the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   
   **Note:** The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **Trash** from the space administration options
3. A list of deleted pages and blog posts for the space displays. Choose **Purge** for a specific page or **Purge All** to permanently clear all deleted pages and news items.

When the trash is purged, all attachments on purged pages are permanently removed as well.

**Restoring a Deleted Page**

When you restore a page, you are moving it from 'Trash' to the root of the space.

You need to be a space administrator to restore deleted pages.

**Related pages:**

- Deleting a Page
- Restoring a Deleted Page
- Confluence User's Guide

**Related pages:**

- Deleting a Page
- Purging Deleted Pages
- Confluence User's Guide
To restore a deleted page:

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Content Tools > Trash**
3. A list of deleted pages and blog posts for the space displays. Choose **Restore** for the page you wish to restore.

If your space is using the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   *Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).*
2. Choose **Trash** from the space administration options
3. A list of deleted pages and blog posts for the space displays. Choose **Restore** for the page you wish to restore.

To find the page after you have restored it, choose **Pages** to go to the root of the space. (The page is not restored to its original position in the page hierarchy.)

Notes

- If a new page has already been created in that space with the same name as the deleted page, you will be given an option to rename the page before it is restored.
- If the page had any child pages before it was deleted, Confluence moved the child pages to the root of the space when the page was deleted. The parent-child relationship will **not** be automatically restored when you restore the page.

**Viewing All Pages in a Space**

All Confluence pages are contained within a space. You can use the Pages view to see a list of recently updated pages and all pages within a space.

To access the Pages view:

1. Go to a page in the space and choose **Pages** in the sidebar.
   Or, if you are using the Documentation theme, choose **Browse > Pages** at the top of the screen.
2. Recently updated pages and a hierarchical (tree) view of all pages in the space display.

**Related pages:**

- Moving a Page
- Changing the Sequential Order of Pages
- Working with Pages
- Confluence User's Guide

**Screenshot: The pages view in the default theme**

If you are using the Documentation theme, you can choose between Recently Updated, Alphabetical and Tree view of the pages in your space.
Changing the Sequential Order of Pages

Confluence allows you to present your pages in any order (sequence) you choose. The position of a page is reflected in the following places:

- The navigation area of the space sidebar. (See Finding Content.)
- The pages Tree on the 'Pages' view in the space.
- Pages exported to PDF, HTML and XML.
- The Page Tree macro.
- The Children macro.

Alphabetical versus manual order

By default, Confluence will present your pages in alphabetical order. When you move a page to a different position, the order becomes manual for the affected page family. When we say 'page family' we mean the immediate children of the parent page, not including the grand-children.

When ordering pages alphabetically, Confluence applies a more sophisticated 'natural' order rather than a straight alphabetical order. The natural order handles numeric values correctly when doing string comparisons.

Now let's consider what happens when you add a page to a page family, by creating a new page or by moving or copying a page into the family:

- If the page family's order is alphabetical, the new page will appear in alphabetical order too.
- If the page family's order is manual, the new page will appear at the bottom of the list of pages in the family.

On this page:
- Alphabetical versus manual order
- Changing the page order manually
- Changing the page order to alphabetical

Related pages:
- Finding Content
- Working with Pages
- Confluence User’s Guide

Changing the page order manually

To change the order of pages in the space:
1. Go to the space and choose **Space tools > Reorder pages** on the sidebar. If your space is using the Documentation theme choose **Browse > Pages**.

2. Expand the branches of the tree to find the page family you wish to sort.

3. Drag each page to a new position in the tree.

When you drag a page to a new position, the order of the page family changes to Manual. Newly added pages will not be sorted alphabetically, but will appear at the bottom of the list.

**Changing the page order to alphabetical**

If the pages in a page family have been ordered manually, you can change the page order back to alphabetical.

**To set the page order to alphabetical:**

1. Go to the space and choose **Space tools > Reorder pages** on the sidebar. If your space is using the Documentation theme choose **Browse > Pages**.

2. Expand branches of the tree to find the page family you wish to sort.

3. Choose the **Sort Alphabetically** (A-Z) icon beside the parent page.

The **Sort Alphabetically** (A-Z) icon only appears next to the parent page if the page family is currently sorted manually.

If you change your mind, you can use the **Undo Sorting** icon to revert back to the previous manual page order for that page family. This option is only available immediately after sorting the page (while you are still on the ‘Reorder Pages’ tab and have not performed any other action).

**Screenshot: Page tree showing the Sort Alphabetically and Undo Sorting icons.**

Sort Alphabetically only sorts the immediate children of the parent page. The grandchildren will not be re-ordered, sorting happens for one node at a time. If you want to re-order grandchildren, you need to click the **Sort Alphabetically** icon next to the parent of those pages.

**Managing Orphaned Pages**

An orphaned page is a page without any incoming links. This means that, unless you know that the page exists, you are not likely to come across it in the space during the natural course of navigation.

When you are working in a large space with a number of pages, it is difficult to keep track of all of them. An orphaned page may be redundant or may need to be referred to from another page. Confluence allows you to view all the orphaned pages in a space so you can tidy up the space by either deleting pages or reorganising them.

**To view the orphaned pages in a space:**

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.

2. Choose **Orphaned Pages**.

If your space uses the Documentation theme:

1. Choose **Browse > Space Operations** at the top of the screen.

2. Choose **Orphaned Pages** in the space operations options.
You can do the following:

- Delete an orphaned page by choosing the 'trash can' icon next to the page name.
- Edit a page by choosing the 'pencil' icon next to the page name.
- Give an orphaned page a parent — see Moving a Page.

Related pages:
- Managing Undefined Pages
- Working with Pages
- Confluence User's Guide

Managing Undefined Pages

In Confluence, you can add links to pages that you intend to create later. These are links to 'undefined pages'. This is useful because it allows you to create links first and enter content for those pages later.

The link to an undefined page is shown in dark red. If someone clicks the link, Confluence will create a new page called 'link to new page'.

The 'Undefined Pages' view gives a consolidated report of all undefined pages so that you can manage your space better. The undefined page links are badged with this icon to remind you that those pages need to be created.

To view a list of the undefined links in a space:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Undefined Pages

If your space uses the Documentation theme:

1. Choose Browse > Space Operations at the top of the screen.
2. Choose Undefined Pages in the space operations options.

You can choose the link for an undefined page to create the page and add content to it.

Related pages:
- Managing Orphaned Pages
- Working with Pages
- Confluence User's Guide

Using the Documentation Theme

The Documentation theme is one of the themes bundled with Confluence. It provides an inbuilt table of contents for your wiki space, a configurable header and footer, and text styles suited to documentation. You can also configure it to restrict the search results to the current space, rather than searching the entire Confluence site.

---

Advance warning of plans to merge Documentation theme with the default theme

This is an advance notice that we plan to merge the functionality of the Confluence Documentation theme with the Confluence default theme. We do not yet have a specific date for this plan, and we are interested in your feedback. The new default theme, introduced with Confluence 5.0, includes a sidebar.
with contextual navigation. Our plan is to include features from the Documentation theme in the default theme, and then remove the Documentation theme from Confluence.

If you are interested in this change and would like to give us feedback, please add a comment on this blog post: Advance warning of plans to merge Documentation theme with the default theme. We are especially interested to know which features of the Documentation theme you use and value the most.

This page tells you how to view pages in your Confluence space when your space uses the Documentation theme. For the full list of features and instructions on applying the theme to a space, see the guide to configuring the Documentation theme.

Quick guide to using the Documentation theme:

- The left-hand panel contains a page tree. This is a table of contents that shows the pages in the space.
- Click the plus signs in the page tree to see the child pages.
- Drag the thick vertical bar to change the width of the panels.
- Show/hide the left-hand panel: Click the sidebar icon at top right, next to the search box, to remove the left-hand panel altogether. Click the icon again to restore the panel.
- Alternatively, press '[' on your keyboard to show/hide the left-hand panel.
- Overriding a space-restricted search: If your theme is configured to restrict the search to the current space, you can enter 'all:' and your search term to search the entire site.

The rest of this page gives more details of the above guidelines.

On this page:
- Using the Documentation theme
- Searching the space or the site
- Hints and tips
- Notes

Related pages:
- Configuring the Documentation Theme
- Space Jump Macro
- Changing the Sequential Order of Pages
- Confluence User's Guide

Using the Documentation theme

By default in a space that uses the Documentation theme, the left-hand panel contains a search box and a table of contents (page tree) showing all the pages in your space. Specifically, it shows the pages that are children of the space’s home page.

Diagram: The Documentation theme with default settings
A **space administrator** can customise the Documentation theme as follows:

- Change the content in the left-hand panel and add a header and footer to the page. This means that your own pages may look different from the screenshot above.
- Restrict the search so that it will show results from the current space only, not from the entire Confluence site.

**Diagram: The Documentation theme with space-restricted search**

Here is a summary of the things you can do on a page that uses the Documentation theme:

- Click the plus signs to open and close the branches of the page tree (table of contents) in the left-hand panel.
- Drag the thick bar between the left-hand panel and the content, to increase or decrease the width of the panel.
- Click the sidebar icon at top right, next to the search box, to remove the left-hand panel. This will remove the panel for you only. Other people will still see it.
• Click the sidebar icon  again to restore the left-hand panel.
• Alternatively, press '[' on your keyboard to show/hide the left-hand panel.
• Use the scroll bars to scroll the left-hand and right-hand panels independently of each other.
• Search the content of the space or the site. See below.

Searching the space or the site

When using the Documentation theme, the Confluence search offers a few options as described below.

Using the search box at the top right of the page:

• By default, the main Confluence search is configured to search the entire Confluence site.
  • You will see the words 'Search Confluence' in the search box at top right of the page.
  • The Confluence search will look for matches in the entire Confluence site. This is the default
    behaviour for other themes too.
• A space administrator can configure the Documentation theme to restrict the search to the current space.
  • You will see the words 'Search this space' in the search box at top right of the page.
  • The search will return results from the current space only.
  • You can override the search restriction. Enter 'all:' and your search term to search the entire
    site for 'technical writing':

    all: technical writing

Using the search box in the left-hand panel:

• By default, the Documentation theme's left-hand panel includes a search box. Enter your search term
  there, to restrict the search to the current space. Specifically, this will search only the pages that are
  children of the space’s home page.
• If your administrator has restricted the main search to the current space, there will not be a search box in
  the left-hand panel.

Hints and tips

Below are some hints that you may find useful when using the Documentation theme.

*Where can I see a working example of the Documentation theme?*

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on
the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

*Which pages will appear in the Documentation theme’s table of contents?*

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s
home page. Each space has a single page designated as the 'Home' page. You can specify the home page in
the space administration section.

*Help, my pages do not appear in the Documentation theme table of contents*

**Cause 1: Your pages are not under the space’s home page.** The most probable reason why your pages do
not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from all
pages that are child pages of the space’s home page. If your pages are above the home page in the page tree,
they will not appear in the left-hand panel.

There are two ways to fix the problem:

• You can change the designated space home page in the space administration section.
• Or you can drag and drop all your pages to make them children of the current home page. You can drag
  and drop pages in the 'Pages' section of the space 'Browse' screen. See *Moving a Page*.

**Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to
Confluence 3.2 or later with Documentation theme bundled.** If your existing Confluence installation already
has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the Documentation theme plugin. See the knowledge base article.

**Help, my left-hand panel has disappeared**

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar icon [at top right, next to the search box. Click the icon again to restore the panel.

**Can I change the default width of the left-hand navigation panel?**

The Confluence user interface does not offer a way to change the default width of the left-hand navigation panel supplied by the Documentation theme. Users can change the width by dragging the middle bar, but the default width is not configurable. This post on Atlassian Answers gives a way to do it with CSS: Documentation Theme - Default Width (in px) of left panel.

**Notes**

- The Confluence default theme supplies a sidebar, which is different to the left-hand panel in the Documentation theme. For information about the sidebar, see Finding Content and Configuring a Sidebar.
- The Documentation theme supplies a Browse menu in the Confluence header, which gives access to the space administration and advanced options.

**Viewing Page Information**

The 'information' view for a page shows you various bits of useful information about the page.

**To see the information view for a page:**

1. View the page.
2. Choose Tools > Info to go to the 'Information' view for the page.

You will see the following information:

1. Page details: Title, author, date of creation, date of last modification and the tiny link of the page.
3. Labels: Any labels (tags) that have been applied to this page. See Working with Confluence Labels.
4. Page Permissions: Displays page-level security restrictions that apply to the page (if present). See Page Restrictions.
5. Hot Referrers: The external website pages which send the most viewers to the page. See Managing External Referrers.
6. Recent Changes: Links to the five most recent versions of the page along with the name of the editor and the date of modification. See Page History and Page Comparison Views. Choose View page history to see the page history view, all the versions of the page in reverse chronological order and allows you to compare versions or to restore a previous version.
7. Outgoing links: A summary of the links contained on this page, pointing to other pages on the Confluence site or to external websites.

**Related pages:**

- Working with Pages
- Confluence User's Guide

**Screenshot:** A page's information view
Viewing Recently Visited Content

Confluence keeps track of pages you have recently visited in Confluence. You can access your recently viewed pages and navigate back to them using the Recently Viewed list.

To view the full list of recently viewed pages:

1. Choose your profile picture at top right of the screen, then choose Recently Viewed.
2. Choose the title of the page you wish to revisit.

To filter the list type part of a page title or user’s name in the Filter field.

Your last ten recently viewed pages also appear when you select the ‘Search’ field anywhere in Confluence.

Related pages:
- Working with Pages
- Confluence User’s Guide

Screenshot: Recently viewed content
Page History and Page Comparison Views

Confluence tracks the history of changes to each page by creating a new version of the page each time it is modified. You can view the changes between different versions, and roll back to a previous version if required.

Accessing the page history

To view the history of a page:

Go to the page and choose Tools > Page History.

You can choose a version number to view the content of that version.

On this page:

- Accessing the page history
- Viewing an older version of a page
- Restoring an older version of a page
- Deleting a specific version of a page
- Viewing the changes made to a page
- Comparing two versions of a page

Related pages:

- Viewing Page Information
- Working with Pages
- Tracking Updates
- Confluence User's Guide

Screenshot: Page history
Viewing an older version of a page

To view a specific version of a page:

1. Go to the page and choose Tools > Page History.
2. Choose a version number to view the contents of that version of the page. You will see a header like this, at the top of the old version of the page:

   ![Header for old version of page]

   If you want to send this page version to someone, copy and paste the URL from your browser. The link will look something like this: `http://confluence.atlassian.com/pages/viewpage.action?pageId=12345`.

When you are viewing a specific version of the page, the following functions are available:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>current version</td>
<td>View the latest version of the page.</td>
</tr>
<tr>
<td>Compare with Current</td>
<td>Compare the differences between the version of the page you are viewing and the current version.</td>
</tr>
<tr>
<td>Restore this Version</td>
<td>Roll back the content of the page to the previous version that you are viewing.</td>
</tr>
<tr>
<td>View Page History</td>
<td>Return to the list of page versions.</td>
</tr>
<tr>
<td>&lt;&lt; Previous and Next &gt;&gt;</td>
<td>View the previous or next version of the page.</td>
</tr>
</tbody>
</table>

Restoring an older version of a page

You can roll back the content of the page to a specific version.

To restore an older version of a page:

1. Go to the page and choose Tools > Page History.
2. Choose Restore this version beside the version you want to restore.
3. Change the default comment if necessary, and choose OK.
Notes

- All page history is retained. Restoring an older version creates a copy of that version. For example, if you restore version 39, Confluence will create a copy of version 39. This copy will become the new, current version.
- If you are viewing a specific version of a page, you can restore that version of the page by choosing **Restore this Version** at the top of the page.

Deleting a specific version of a page

Choose **Delete** next to a version, to remove that version. See **Deleting a Page**.

Viewing the changes made to a page

Using the page history view or the page information view, you can see the recent changes made to a page.

**To view recent changes made to a page:**

1. Choose **Tools > Info** to go to the 'Information' view for the page.
2. In the section titled 'Recent Changes' you will see the most recent versions of the page, along with the date of their modification and the name of the modifying author.
3. Choose **View Changes** beside the required version. The page comparison view is displayed, showing the differences between the selected and previous versions.

Comparing two versions of a page

**To compare two versions of a page:**

1. Go to the page and choose **Tools > Page History**.
2. Choose the versions you want to compare by selecting the check boxes beside them.
3. Choose **Compare selected versions**. The page comparison view is displayed, showing the differences between the selected versions.

Changes are highlighted in different colours, as shown in this table:

<table>
<thead>
<tr>
<th>Highlighted colour</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Added content</td>
</tr>
<tr>
<td>Red</td>
<td>Deleted content</td>
</tr>
<tr>
<td>Blue</td>
<td>Changed formatting</td>
</tr>
</tbody>
</table>

Screenshot: Comparing changes
More options on the comparison view

When a page comparison view is first displayed, all large sections of unchanged text are hidden and reduced to an ellipsis, like this: . . .

You can view page changes between versions which are adjacent to your current page comparison view. Click the link containing:

- << to view the page comparison with the earlier adjacent version
- >> to view the page comparison with the more recent adjacent version.

For example, if your page comparison view is between v. 30 and v. 34 of a page, you can view changes between:

- v. 29 and v. 30 by clicking << Changes from 29 to 30
- v. 34 and v. 35 by clicking Changes from 34 to 35 >>

Using a WebDAV Client to Work with Pages

You can access Confluence content via a WebDAV client, such as ‘My Network Places’ in Microsoft Windows. Provided that you have permission, you will be able to read and write to spaces, pages and attachments in Confluence. You will be asked to log in and the standard Confluence content access permissions will apply to the equivalent content available through the WebDAV client.

Please refer to the page on configuring and setting up a WebDAV client.

Working with Blog Posts

You can publish a blog post from any space in Confluence, provided you have permission. Blog posts may be announcements, journal entries, status reports, or any other timely information.

To view the blog posts within a space: Go to a page in the space and choose Blog in the sidebar. Or, if you are using the Documentation theme, choose Browse > Blog at the top of the screen.

Confluence lists the latest blog posts. You can click through to earlier posts via the navigation area in the sidebar.

Creating and editing a blog post is just as easy as creating and editing any other page in Confluence. You can also let people know you care by liking a blog post.

Creating a blog post

To create a blog post, you need the ‘Add Blog’ permission. See Space Permissions, and Creating Content.

You can create attractive, engaging content in a blog post in the same way as in a page. See Creating Beautiful and Dynamic Pages.
Editing a blog post

To edit a blog post, you need the 'Add Blog' permission. See Space Permissions.

To edit a blog post:

1. Go to a page in the space and choose Blog in the sidebar.
   Or, if you are using the Documentation theme, choose Browse > Blog at the top of the screen. You will see the most recent blog posts within the space, and you can find earlier posts via the navigation area in the sidebar.
2. Go to the blog post and choose Edit.
3. Make changes to the blog post.
4. (optional) Add a comment, in the text box below the editing pane, to describe your changes.
5. Preview your changes if desired, and choose Publish.

Editing a blog post is similar to editing any other page in Confluence. However, there are a few things to keep in mind:

- You cannot change the date of an existing blog post. You can only backdate when adding a blog post.
- You cannot move a blog post to another space.
- A blog post has no parent.

Deleting a blog post

By default, when you delete a blog post in Confluence, this will remove all versions of the post. To do that, you need the 'Delete Blog' permission. See Space permissions. If someone has applied page restrictions to the blog post, the restrictions may prevent you from deleting the post too. Deleted blog posts are stored in the space's trash and can be recovered by a space administrator.

If you want to delete a specific version of a blog post, you need to be a space administrator. When you delete a version of a blog post, the version is not stored in the trash. The deletion of a version is therefore permanent and cannot be undone.

To delete all versions of a blog post:

Go to the page and choose Tools > Delete. Confirm the action as prompted.
Note: The 'Delete' option will only appear if you have permission to delete this page.

To delete just one version of a blog post:

1. Go to the page and choose Tools > Page History.
2. Choose Delete next to the version you want to delete, and confirm the action as prompted.

Exporting a blog post

You can export individual blog posts to PDF format. This is useful, for example, if you want to email an internal blog post to people outside your organisation.

See Exporting Confluence Pages and Spaces to PDF for more information on exporting blog pages to PDF.

Working with Spaces
In Confluence, content is organised into spaces. There are two main types of space:

- **Site spaces**, sometimes called 'global' spaces, are areas on your site where you can create content and collaborate with other users. For example, you might create a space for each team or project in your organisation.
- **Personal spaces** belong to specific users. You can keep your personal space private, or open it up for other users to view or edit. Personal spaces are listed in the [People Directory](#).

**What is a Space?**

A space is an area within Confluence, containing your pages, blog posts and other content. You can think of each space as a sub-site, or mini-site, each with its own home page.

You can create a blank space or choose to use a space blueprint.

Each space:

- Has its own **pages**, **blog posts**, **comments**, and more.
- Has its own **access control settings**. You can set different levels of access for different spaces.
- Cannot be nested under another space, but can be grouped using **space categories**.
- Can be separately exported to **PDF**, **HTML** or **XML**. The XML export provides a way of **backing up and restoring a space**.

There is no limit to the number of site spaces you can create in Confluence.

---

**On this page:**

- What is a Space?
- What is a Space Blueprint?
- Viewing the spaces in a Confluence site
- Example: Favourite spaces as shown on the dashboard
- Notes

**Related pages:**

- Creating a Space
- Configuring a Sidebar
- Setting Up your Personal Space
- Viewing All Confluence Spaces
- Archiving a Space
- Deleting a Space
- Backing Up and Restoring a Space
- Administering a Space
- Confluence User’s Guide

---

**What is a Space Blueprint?**

Space Blueprints allow you to create common types of spaces, such as a team space or knowledge base, quickly and easily.

A space created using a space blueprint will have a customised homepage, sidebar and may contain page blueprints or sample content that is specific to that type of space.

When you create a space using a blueprint a wizard will prompt you to enter information to help set up your space. For example the Team Space blueprint asks for the members of your team, and displays them on the homepage.

**Viewing the spaces in a Confluence site**

Confluence displays a list of spaces in the following locations:

- The **dashboard** displays a list of all the spaces that you have permission to see. You can make a space a **favourite**, or **categorise the space**, to get easy access to the content that is most relevant to you. See Customising your Personal Dashboard.
- The **space directory** displays a list of all the site and personal spaces that you have permission to see. You can filter the list of spaces. See Viewing All Confluence Spaces.
• The **people directory** displays a list of all Confluence users, including those who have personal spaces. See [Searching the People Directory](#).

**Example: Favourite spaces as shown on the dashboard**

The screenshot below shows the area of the Confluence dashboard that displays the spaces that you have marked as favourite:

![Confluence Dashboard with Favourite Spaces](image)

**Notes**

* A **space key** is a short, unique identifier for a space. For example, you might give your documentation space a key of "DOC". To find the key of an existing space, look at the Confluence URL for a page in the space. The standard Confluence URL has this format:

  ```
  http://my.confluence.site.com/display/SPACEKEY/Page+Name
  ```

**Viewing All Confluence Spaces**

Quick guide to viewing spaces:

• The **dashboard** displays a list of all the spaces that you have permission to see. You can make a space a **favourite**, or **categorise the space**, to get easy access to the content that is most relevant to you. See [Customising your Personal Dashboard](#).

• The **space directory** displays a list of all the site and personal spaces that you have permission to see. You can filter the list of spaces. See [Viewing All Confluence Spaces](#).

• The **people directory** displays a list of all Confluence users, including those who have personal spaces. See [Searching the People Directory](#).

**On this page:**

• Viewing spaces on the dashboard
• Viewing spaces in the space directory
• Viewing personal spaces in the people directory
• Notes

**Related pages:**

• Working with Spaces
• Archiving a Space
• Confluence User's Guide
Viewing spaces on the dashboard

The Confluence dashboard displays a list of spaces that you have permission to view. Remember to log in, so that you can see the complete list of spaces based on your username's permissions.

The **Spaces** tab displays all the global spaces on the site that you have permission to view, and the spaces you have marked as your **favourites**.

**To see the spaces on the dashboard:**

1. Choose the **site logo** at the top left of your Confluence screen.
2. Scroll down and choose the **Spaces** tab.

![Screenshot: Viewing spaces on the dashboard](image)

Viewing spaces in the space directory

The space directory displays a list of site and personal spaces that you have permission to view. Remember to log in, so that you can see the complete list of spaces based on your permissions.

**To view all spaces:**

1. Choose **Spaces > Space directory** on the header.
2. All the spaces that you have permission to view will appear.

If you have a large number of spaces in your site, you can filter the list.

**To filter the list of spaces:**

- Enter part of the space name or description in the **Filter** field, or
- Choose a pre-defined filter or category.

Only those spaces that match your filter will appear.

The filters include:

- **All Spaces** – Shows all global and personal spaces. The list excludes spaces that you do not have permission to view and spaces that have been **archived**.
- **Site Spaces** – Excludes personal spaces.
- **Personal Spaces** – Shows only personal spaces.
- **Favourite Spaces** – Shows the spaces that you have marked as your **favourites**.
- **Archived Spaces** – Shows all global and personal spaces that have been **archived**, and that you have
 permission to view.

- **Categories** – Shows spaces that have been labelled with the selected space category. See [Using Labels to Categorise Spaces](#).

**Screenshot: Viewing favourite spaces in the space directory**

<table>
<thead>
<tr>
<th>All Spaces</th>
<th>Site Spaces</th>
<th>Personal Spaces</th>
<th>Favourite Spaces</th>
<th>Archived Spaces</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Categories</strong></td>
<td><strong>Development</strong></td>
<td><strong>Documentation</strong></td>
<td><strong>Projects</strong></td>
<td></td>
</tr>
</tbody>
</table>

**Viewing personal spaces in the people directory**

The people directory displays a list of Confluence users, including those who have personal spaces. See [Searching the People Directory](#). It excludes spaces that have been [archived](#).

**To see the personal spaces in the people directory:**

1. Choose **People** at the top of the screen.
2. Choose **People with Personal Spaces**.

**Screenshot: The people directory**

**Notes**

- If you do not log in, you will be treated as an 'anonymous user'. Confluence will display only those spaces that anonymous users have permission to see.
- Permission to access a space is granted by a **space administrator**. See the overview of **space permissions**.
- You can use the **Spaces List macro** to display a list of spaces on a Confluence page.

**Creating a Space**

In Confluence pages and other content are stored in spaces. There are two main types of spaces - site spaces and personal spaces. Your Confluence site can contain many site spaces, and each user can have one personal space.

To create a site space you need the 'Create Space' **global permission**.
To create a personal space you need the 'Personal Space' global permission.

To create a space:

1. Choose Create Space on the dashboard or from the Spaces drop down.
2. Choose the type of space you would like to create then choose Next.
3. Enter details of your space including Name, Space Key, and set any permissions - the wizard will prompt you.
4. Choose Create.

Once your new space has been created you will be taken to the space homepage, which will be customised depending on the type of space you selected.

You can now start creating content to your space.

Choosing a space key

The space key is the unique identifier for your space and is used in URLs and macros. Your space key must be unique, can contain any alphanumeric character (A-Z, a-z, 0-9), and be up to 255 characters long.

Personal spaces use your username as the space key.

You cannot change the space key after your space has been created, so choose your space key carefully.

Space permissions

Spaces are created with a set of default permissions. The user who created a site space is automatically granted 'space admin' permissions for that space. They can then grant permissions to other users and groups. See Space Administrators and their Permissions for more information.

Note: System Administrators can edit the permissions of spaces in their Confluence site at any time.

Using space blueprints to create a space

Space blueprints help you create common types of spaces quickly and easily. Space blueprints vary widely, so here are some examples of the spaces you can create:

- **Team space**
  A great building block if you are using Confluence as an intranet or to manage teams. Team spaces highlight the members of the team, and grant permissions to those users accordingly.

- **Knowledge Base space**
  This space blueprint uses search and page labels to make content easier to find, right from the space homepage. It also contains two page blueprints for creating how-to and troubleshooting articles. The templates used in these page blueprints are completely customisable to meet your needs. The Knowledge Base space blueprint also integrates with JIRA Service Desk.

- **Documentation space**
  This space blueprint displays the full page tree in the sidebar and hides other sidebar features including blogs and shared links. The homepage uses search and page labels to make content easy to find. Add the 'featured' label to any page you want to highlight on the homepage. This space does not include any page blueprints but you can create and promote templates for your documentation authors to use.

  Note: If you have set a specific theme (such as the Documentation or other third party theme) for your whole site, spaces will be created with that theme. You may not see some of space blueprint specific sidebar customisation if you are not using the default theme.

Setting Up your Personal Space

Your personal space is a place where you can publish your own pages and blog posts. Once you have set up your personal space, Confluence users can reach it by clicking your name in the People Directory. You can get to your personal space by clicking your name at the top of the page and choosing 'Personal Space'.
Creating your personal space

To set up your personal space, you need the 'Personal Space' permission which is assigned by a Confluence administrator. See Giving People Access to Content and Global Permissions Overview.

To create your personal space:

1. Choose your profile picture at top right of the screen, then choose Add Personal Space.
2. Indicate whether your space should be private or not. A private space will be visible only to you. If you do not make it private, the space will have the default space permissions. Note that you can change these settings again later. You will have space administrator permissions on your space.
3. Choose Create.
4. The home page of your new space will appear. Your home page will contain any default space content as defined by your Confluence administrator. You can change this content at any time.

On this page:
- Creating your personal space
- Adding and changing content in your space
- Changing the look and feel of your space
- Granting access to your space
- Watching updates made in your space

Related pages:
- Configuring a Sidebar
- User Profile Overview
- Working with Spaces
- Confluence User's Guide

Screenshot: Adding a personal space

Adding and changing content in your space

Now you can start adding pages to your personal space. You may also want to upload your photo.

Changing the look and feel of your space

If you like, you can apply a different theme to your personal space, or modify its colour scheme. You can also add and arrange links in the sidebar.

Granting access to your space

When you created the space, you set the option to make your space private, or to allow other people to view and contribute content to your space. You can change the permissions on your space at any time.

Watching updates made in your space
By default, Confluence assigns you as a watcher of your space. This means that you will receive an email notification each time someone adds or updates content in your space. You can stop watching the space (see Watching Pages, Spaces and Blog Posts) and change your notification settings at any time.

**Administering a Space**

This page gives an overview of the administration functions available in site and personal spaces. You need to be a space administrator to perform space administration functions.

Space administrators can also add and remove links in the space sidebar. See Configuring a Sidebar.

**To view the space tools page:**

1. Go to the space and choose Space tools > Permissions on the sidebar.
2. The 'Space Permissions' page displays.

The administration options are divided into the following categories. Some options may not be applicable for personal spaces.

- **Overview**
  - Space Details - see Editing Space Details
  - Space Labels - see Using Labels to Categorise Spaces
  - Delete Space - see Deleting a Space

- **Permissions**
  - Permissions - see Assigning Space Permissions
  - Restricted Pages - see Page Restrictions

- **Content Tools**
  - Templates - see Working with Templates
  - Orphaned Pages - see Managing Orphaned Pages
  - Undefined Pages - see Managing Undefined Pages
  - Attachments - see Viewing Attachment Details
  - Trash - see Purging Deleted Pages and Restoring a Deleted Page
  - Export - see Exporting Confluence Pages and Spaces to Other Formats
  - RSS Feeds - see Using pre-specified RSS feeds
  - Import - see Importing Pages from Disk. *Not available for personal spaces.*

- **Look and Feel**
  - Themes – see Applying a Theme to a Space
  - Colour Scheme – see Editing a Space's Colour Scheme
  - Layout - see Customising Space Layouts
  - Stylesheet - see Styling Confluence with CSS
  - PDF Layout – see Customising Exports to PDF
  - PDF Stylesheet – see Customising Exports to PDF

- **Integrations**
  - Application Links – see Linking to Another Application
  - Mail Accounts – see Working with Mail Archives. *Not available for personal spaces.*
  - Mailbox Import – see Importing Mail. *Not available for personal spaces.*
  - Mail – see Working with Mail Archives. *Not available for personal spaces.*

You can also customise the sidebar, including changing the space logo and adding shortcuts to other spaces - see Configuring a Sidebar for more information.

Administering a space that uses the Documentation theme
In this theme the standard Confluence sidebar is replaced by a page navigation sidebar. As a result the layout of the space administration options are slightly different.

To view the space admin page:

1. Go to the space you wish to manage.
2. Choose Browse > Space Admin at the top of the screen.
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
3. The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).

For spaces using the Documentation theme, the administration options are divided into the following categories:

- **General**
  - Space Details – see Editing Space Details.
  - Space Labels – see Using Labels to Categorise Spaces.
  - Templates – see Working with Templates.
  - Delete Space – see Deleting a Space.
  - Trash – see Purging Deleted Pages and Restoring a Deleted Page.

- **Security**
  - Permissions – see Assigning Space Permissions.
  - Restricted Pages – see Page Restrictions.
  - Application Links – see Linking to Another Application.

- **Mail**
  - Mail Accounts – see Working with Mail Archives
  - Mailbox Import – see Importing Mail

- **Look and Feel**
  - Themes – see Applying a Theme to a Space.
  - Colour Scheme – see Editing a Space’s Colour Scheme.
  - PDF Layout – see Customising Exports to PDF.
  - PDF Stylesheet – see Customising Exports to PDF.
  - Change Space Logo – see Changing a Space’s Logo.

**Import**

- Import Pages from Disk – see Importing Pages from Disk.

### Editing Space Details

To edit the details of a space you need to be a space administrator for the space.

To edit the details of a space:

1. Go to the space and choose Space tools on the sidebar.
   Note: The options available in 'Space tools' differ depending on your space permissions. All space tools options are available if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Overview > Edit Space Details
3. The 'Edit Space Details' page displays.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. The 'Edit Space Details' page displays.

On the 'Edit Space Details' page you can:

- Change the name of the space (you can also do this via the sidebar - see Configuring a Sidebar).
- Change the description of the space.
- Change the status of the space from 'Current' to 'Archived' or back again - see Archiving a Space.
- Select a new home page for the space. The home page is the default page that users see when they navigate to the space.
   Note: If you set this field to blank (no selection) the default home page will be the 'Pages' page.
Notes

- You cannot edit the space key or the space creator's name.
- The space fields do not accept wiki markup. Any wiki markup entered in these fields will be displayed as plain text.

Deleting a Space

Deleting a space permanently removes the space and all of its contents. To delete a space you must be the space administrator for the space.

Note: Deleting a space is permanent. Always create an XML backup of the space before proceeding. Once you have deleted the space, there is no way to restore it unless you have made an XML space backup.

To delete a space:
1. Go to the space and choose Space tools > Overview on the sidebar.
2. Choose Delete Space.
3. Choose OK.

If your space is using the Documentation theme:
1. Choose Browse > Space Admin at the top of the screen.
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Delete Space in the space administration options.
3. Choose OK.

Related pages:
- Configuring a Sidebar
- Working with Spaces
- Archiving a Space
- Confluence User's Guide

Backing Up and Restoring a Space

Confluence can back up all the content, comments and attachments for a space. The process involves converting the data in the space into XML format. The end product is a zip file that contains XML file(s) that define the content of the space, and optionally a folder containing the attachments in the space. To transfer this data to another Confluence site, you can upload the zip file.

Creating a space backup

See Exporting Confluence Pages and Spaces to XML.

Restoring (importing) a space backup

See Restoring a Space.

Archiving a Space

You can archive a space, so that its content is less visible but still available on your Confluence site. You need to be a space administrator to archive a space. You can change a space's status from archived to current at any time.

The effect of archiving a space

If a space is archived:
- The pages and other content do not appear in the Confluence quick navigation aid, which drops down when you enter text in the search box.
• By default, the pages and other content do not appear in the Confluence search results. If a Confluence site contains any archived spaces, the search screen will provide an option to include them in the search results.
• The space and its pages do not appear on the dashboard.
• Updates to the space’s content do not appear in activity streams, such as the recent updates section of the dashboard.
• The space does not appear in space-selection dropdown menus. Similarly, its pages and other content do not appear in any dropdown menus in the Confluence user interface.
• In the space directory, the archived space will no longer appear in the general space lists. Archived spaces will appear on the ‘archived spaces’ tab. They will also appear on the category tabs, as determined by their labels.

These functions remain available for archived spaces:
• People can view the content as usual, by following a link or typing in a URL belonging to the archived space.
• People can edit the content as usual, as determined by the space permissions.
• RSS feeds, watches and notifications remain active.

### On this page:
- The effect of archiving a space
- Archiving a space
- Notes

### Related pages:
- Working with Spaces
- Deleting a Space
- Confluence User’s Guide

#### Archiving a space

**To archive a space:**

1. Go to the space and choose **Space tools** > **Overview** on the sidebar.
2. Choose **Edit Space Details**.
3. Select **Archived** in the **Status** dropdown menu.
4. Choose **Save**.

If your space uses the Documentation theme:

1. Choose **Browse** > **Space Admin** at the top of the screen.
   **Note:** The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the **confluence-administrators** group).
2. The ‘Edit Space Details’ page displays. Select **Archived** in the **Status** dropdown menu.
3. Choose **Save**.

#### Notes

Archiving a space has no effect on search results of external search engines. For example, the space will still appear in Google search results.

**Screenshot: An archived space**
Viewing Space Activity

Space activity information is **disabled by default**.

If enabled, the space activity screen displays statistics on the activity in each space. These include:

- How many pages and blog posts have been viewed, added or updated over a given period.
- Which content is the most popular (most frequently viewed).
- Which content is the most active (most frequently edited).
- Which people are the most active contributors/editors of content.

The 'Activity' tab will not be visible unless the Confluence Usage Stats plugin is enabled. See notes below.

To view the activity in a space:

1. Choose **Space Tools** in the space sidebar.
2. Choose the **Activity** tab.

Confluence will show a graphic display of the number of pages and blog posts that have been viewed, added and edited, showing trends over a period of time.

**Related pages:**
- Page History and Page Comparison Views
- Managing Changes and Notifications and Tasks
- How Do I Get More Statistics from Confluence?
- Confluence User's Guide

In addition to the graphical representation of Views and Edits, the top ten most popular and most active pages and/or blog posts will be listed, with a link to each.
Viewing Recently Updated Content

The ‘Recently Updated’ view is a useful way of keeping track of the changes being made in a space. It displays links to the most recently added or modified content within the space including pages, blog posts, mail messages and comments.

Are you looking for a way to display a list of recently updated pages on a page? Try the Recently Updated Macro.

To view the recently updated content in a space:

1. Go to a page in the space and choose Pages in the sidebar.
   Or, if you are using the Documentation theme, choose Browse > Pages at the top of the screen.
2. Choose Recently Updated. A list of the most recently added or modified content in the space is displayed. Choose a link to open the corresponding document.

Related pages:
- Recently Updated Macro
- Viewing All Pages in a Space
- Viewing Space Activity
- Confluence User’s Guide

Working with Mail Archives

Confluence allows you to collect and archive mail within each space. This is useful for storing the email messages that relate to a particular project – you can put them in the same Confluence space as the content for that project.

You can download mail from one or more POP or IMAP accounts. You can also import mail from mbox files either on your local system or on the Confluence server.

You need space administration permissions to manage the mail archives. See Space Permissions Overview.

Confluence mail archiving is an optional feature. This means that the ‘Mail’ options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose Confluence Admin > Manage Add-ons > Choose System in the drop down, then enable the Confluence Mail Archiving Plugin.
To see archived mail:

- Go to a space and choose **Space Tools > Integration > Mail**
  Or, if your space uses the Documentation theme, choose **Browse > Mail** at the top of the screen.
- Choose a message to see its contents, or choose **Next, Previous** and other options to navigate around the mail archives.

Managing mail archives:

- **Adding a Mail Account**
- **Deleting Mail**
- **Fetching Mail**
- **Importing Mail**
- **Managing Mail Accounts**

**Related pages:**

- Working with Spaces
- Confluence User’s Guide

⚠️ The information on this page does not apply to Confluence OnDemand.

**Screenshot: Viewing a message in the mail archive**

**Notes**

- **Only site spaces** can store mail archives. Personal spaces cannot. See **Working with Spaces** for an explanation of site spaces and personal spaces.
- You can also search the mail messages and their attachments. See **Searching Confluence**.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose **Confluence Admin > Manage Add-ons > Choose System** in the drop down, then enable the **Confluence Mail Archiving Plugin**.

**Adding a Mail Account**

When you add a mail account, you are configuring Confluence to download mail from that account and archive the mail within the space.

You need space administration permissions to add a mail account. See **Space Permissions Overview**.

⚠️ **Note:** Confluence will remove email messages from an email account when it transfers them to the mail archive. You must therefore configure Confluence to poll a **clone** email account rather than the actual account. For example, to archive the actual account sales@company.com to your Confluence Sales space, you must first create a clone account such as conf-sales@company.com that contains the same email content.
Step 1. Create a clone email account on the mail server

1. Add a new email account on the mail server with the clone email address.
2. Copy all existing email messages from the actual account to the clone account.
3. Set up the actual account to bcc sent email messages to the clone account.
4. Set up the actual account to forward received email messages to the clone account.

Related pages:
- Working with Mail Archives
- Managing Mail Accounts
- How Do I Check Which Spaces Have Email Accounts?
- How Do I Disable Automatic Mail Polling?
- Confluence User’s Guide

⚠️ The information on this page does not apply to Confluence OnDemand.

Step 2. Configure Confluence to archive the clone account

1. Go to the 'Mail Accounts' view:
   • Go to the space and choose Space tools > Integrations on the sidebar.
     Choose Mail Accounts.
   • If your space uses the Documentation theme:
     Choose Browse > Space Admin at the top of the screen.
     Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
     Choose Integration > Mail Accounts.
2. Choose Add mail account.
3. Enter configuration details for the account.
   • Account Name: Enter a name for this account by which it will be known in Confluence.
   • Description: Provide a description for this account (optional).
   • Protocol: Choose from POP, IMAP, POPS or IMAPS.
   • Hostname: Enter the host name of the mail server on which the account resides.
   • Port: Do not edit this field. The mail server's port number will be displayed by default.
   • Username: Enter a username that has permission to retrieve mail from this account.
   • Password: Enter the account's password.
4. Choose Test Connection to verify the details.
5. Choose Create to add the account to Confluence.

Notes
- Only site spaces can store mail archives. Personal spaces cannot. See Working with Spaces for an explanation of site spaces and personal spaces.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose Confluence > Manage Add-ons > Choose System in the drop down, then enable the Confluence Mail Archiving Plugin.

Deleting Mail

To delete mail from a space, you need 'Delete Mail' permission. See Space Permissions.

Only a space administrator can delete all email messages for the space simultaneously.

To delete mail from a space:

1. Go to a space and choose Space Tools > Integration > Mail
   Or, if your space uses the Documentation theme, choose Browse > Mail at the top of the screen. A list of email messages in the space is displayed in reverse chronological order.
2. Delete an individual email message by choosing the trash icon beside it.
3. If you are a space administrator, you can delete all email messages within a space at once by choosing Delete All.
Space administrators can restore deleted email messages, provided they were deleted individually.

**Note:** Email messages deleted using the 'Delete All' option cannot be restored.

**To restore mail that has been deleted:**

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Trash**.
3. You will see a list of email messages and other content deleted from the space. Choose Restore beside the email message you want to restore.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   
   **Note:** The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the **confluence-administrators** group).
2. Choose **Trash** in the left-hand panel.
3. You will see a list of email messages and other content deleted from the space. Choose **Restore** beside the email message you want to restore.

**Related pages:**
- Working with Mail Archives
- Confluence User's Guide

---

**The information on this page does not apply to Confluence OnDemand.**

### Fetching Mail

Confluence fetches mail from the server once every 30 minutes. If necessary, you can manually retrieve new mail from the configured mail accounts.

You need to be a space administrator to manually retrieve mail. See **Space Permissions**.

**To manually retrieve mail:**

1. Go to a space and choose **Space Tools > Integration > Mail**
   Or, if your space uses the Documentation theme, choose **Browse > Mail** at the top of the screen.
2. Choose **Fetch new mail**. Any new messages will be displayed in order of most recent first.

**Notes**

- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose **Confluence Admin > Manage Add-ons > Choose System** in the drop down, then enable the **Confluence Mail Archiving Plugin**.
- Once mail is fetched, it will be removed from the server.

**Related pages:**
- Adding a Mail Account
- Working with Mail Archives
- How Do I Disable Automatic Mail Polling?
- Confluence User's Guide

---

**The information on this page does not apply to Confluence OnDemand.**

### Importing Mail

Confluence allows you to import mail from mbox files located either on your local system or on the Confluence server. Confluence will store the imported email messages in the space’s mail archive.

You need to be a space administrator to import mail for a space. See **Space Permissions**.

**NB:** You may need to enable the **Confluence Mail Archiving Plugin** as it is disabled by default.

**To import mail from an mbox file:**
1. Go to the space and choose **Space tools** > **Integrations** on the sidebar.
2. Choose **Mailbox Import**.
   - To import from a location on your file system: Browse to the location of the mbox file, select the file and then choose **Import**.
   - To import from the Confluence server: Enter the location of the mbox file on the server, then choose **Import**.

If your space uses the Documentation theme:

1. Choose **Browse** > **Space Admin** at the top of the screen.
   *Note:* The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **Mailbox Import** in the space administration options.
   - To import from a location on your file system: Browse to the location of the mbox file, select the file and then choose **Import**.
   - To import from the Confluence server: Enter the location of the mbox file on the server, then choose **Import**.

**Related pages:**
- Working with Mail Archives
- Adding a Mail Account
- Confluence User's Guide

**Notes**
- Only **site spaces** can store mail archives. Personal spaces cannot. See Working with Spaces for an explanation of site spaces and personal spaces.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose **Confluence Admin** > **Manage Add-ons** > Choose **System** in the drop down, then enable the **Confluence Mail Archiving Plugin**.

**Managing Mail Accounts**

You need to be a space administrator to manage mail accounts for a space. See **Space Permissions**.

Confluence will import mail from these POP/IMAP mail accounts into the space's mail archive.

**To manage mail accounts:**

1. Go to the 'Mail Accounts' view:
   - Go to the space and choose **Space tools** > **Integrations** on the sidebar.
   - Choose **Mail Accounts**.
   - If your space uses the Documentation theme:
     - Choose **Browse** > **Space Admin** at the top of the screen.
     *Note:* The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
     - Choose **Integration** > **Mail Accounts**.
2. Add an account if required. See **Adding a Mail Account**.
3. For each of the existing mail accounts listed, you can:
   - **Edit**: Change the configuration settings for the mail account.
   - **Remove**: Remove the account permanently.
   - **Disable/Enable**: Temporarily disable the account, or enable a disabled account.

**Related pages:**
- Working with Mail Archives
- Importing Mail
- Confluence User's Guide

⚠️ The information on this page does not apply to Confluence OnDemand.
Notes

Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose **Confluence Admin > Manage Add-ons > Choose System** in the drop down, then enable the **Confluence Mail Archiving Plugin**.

**Working with Confluence Labels**

Labels are key words or tags that you can add to pages, blog posts, attachments and spaces. You can define your own labels and use them to categorise, identify or bookmark content in Confluence.

For example, you could assign the label 'accounting' to all accounts-related pages on the site. You can then browse all pages with that label in a single space or across the site, or display a list of pages with that label. You can search based on the label, or use it to filter items when you subscribe to a Confluence RSS feed.

Because labels are user-defined, you can add any word that helps you identify the content in the site.

You can add or remove labels without affecting the page content.

**Content labels**

You can add labels to pages, blog posts and attachments. Any user with permission to view the page can also view its labels. See **Adding Labels**.

**Space categories**

You can also apply labels to spaces and use them to categorise your spaces. These are known as **space categories**. See **Using Labels to Categorise Spaces**.

---

**On this page:**
- Content labels
- Space categories
- Advantages of labels
- Using labels
- Notes

**Related pages:**
- Using Label Macros to Categorise Wiki Content
- Viewing Labels and Labelled Content
- Using Labels in the Search
- Using Labels to Categorise Spaces
- Using the RSS Feed Builder
- Confluence User's Guide

---

**Advantages of labels**

Here are some of the advantages of using labels:

- Labels are user-defined which means that you decide what information is relevant to you and how you are going to label it.
- You can group pages and spaces without having to restructure the site.
- Labels are easy to add and edit, and do not affect the content of the page.
- You can add as many labels as you like to a page or space.

**Using labels**

- Adding Labels
- Using Labels to Categorise Spaces
- Removing Labels
- Using Label Macros to Categorise Wiki Content
- Viewing Labels and Labelled Content
- Viewing Personal Labels

---

**Notes**
**Note: Personal labels are deprecated:** Earlier versions of Confluence recognised a special type of label called a ‘personal’ label. A personal label starts with ‘my:’ and is only visible to the user who created it. We are removing personal labels from Confluence, as announced in the Confluence 4.1 Upgrade Notes. The functionality for personal labels is still in Confluence, but we recommend that you stop using them. In a future release, we plan to remove the functionality altogether.

**Adding Labels**

Labels are key words or tags that you can add to pages, blog posts, attachments and spaces. You can define your own labels and use them to categorise, identify or bookmark content.

**Labelling a page or blog post**

Any user with permission to edit a page can add a label to a page.

**To add a label to a page or blog post:**

1. Go to the page. If the page already has labels, these will be listed at the bottom of the page, below the page content.
2. Choose the edit icon beside the list of labels, or press L on your keyboard.
3. Type in a new label. Existing labels are suggested as you type.
4. Choose Add.

**Labelling an attachment**

If you have permission to view or edit the page that contains the attachment, you can add a label to the attachment.
To add a label to an attachment:

1. Go to the page that contains the attachment. Choose **Tools > Attachments**.
2. Alternatively, go to the attachments view of the space:
   a. Go to the space and choose **Space tools > Content Tools** on the sidebar.
   b. Choose **Attachments**.
3. You will see a list of attachments, with columns for attachment name and other details. If the attachment already has labels, these will be listed in the **Labels** column.
4. Choose the edit icon beside the list of labels.
5. Type in a new label. Existing labels are suggested as you type.
6. Choose **Add**.

You can also add labels in a list of attachments displayed by the **Attachments macro**, by choosing the edit icon beside each label.

### Screenshot 2: Adding a label to an attachment

![](image.png)

**Notes**

- **Note: Personal labels are deprecated.** Earlier versions of Confluence recognised a special type of label called a 'personal' label. A personal label starts with 'my:' and is only visible to the user who created it. We are removing personal labels from Confluence, as announced in the [Confluence 4.1 Upgrade Notes](https://confluence.atlassian.com/display/CIV41/Confluence+4.1+Upgrade+Notes). The functionality for personal labels is still in Confluence, but we recommend that you stop using them. In a future release, we plan to remove the functionality altogether.
- If you add a label to a template, that label will be copied to the page when someone adds a page based on that template. See [Adding a Template](https://confluence.atlassian.com/display/CIV41/Adding+a+Template).

### Using Labels to Categorise Spaces

A **space category** is a label that you can apply to a whole space for the purpose of categorising your spaces in the space directory, and in the recent activity area of the dashboard.

You need to be a space administrator to add space categories.

#### Using space categories

Here is an example of using space categories. Let’s assume that you have one or more spaces that your Sales
team may be interested in. You can use the category ‘sales’ to group those spaces together.

1. First add the ‘sales’ category to the relevant spaces, as described below.
2. Then, in the space directory, you can click the relevant tab to see only the spaces with the chosen label. See Viewing All Confluence Spaces.
3. And, you can see updated content in those spaces by choosing the ‘sales’ category under the Space Categories tab in the recent activity area of the dashboard. See Customising your Personal Dashboard.

Categorising a space

When you categorise a space, you add a ‘space category’ to the space. A category does not exist if there are no spaces labelled with that category.

To add a space category to a space:

1. Go to the space and choose Space tools > Overview on the sidebar.
2. Choose Space Categories: Edit.
3. Under ‘Space Categories’, enter your category name and choose Add. Alternatively, choose a category in the list of ‘Suggested Space Categories’.
4. Choose Done.

If your space is using the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen. Note: The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Space Labels in the space administration options.
3. Under ‘Space Categories’, enter your category name and choose Add. Alternatively, choose a category in the list of ‘Suggested Space Categories’.
4. Choose Done.

Removing a space from a category

Removing a space from a category is the same as removing the category from the space.

To remove a space category from a space:

1. Go to the space and choose Space tools > Overview on the sidebar.
2. Choose Space Categories: Edit.
3. Choose the x next to the space category.

If you are using the Documentation theme:

1. Go to the space and choose Space tools on the sidebar. Note: The options available in ‘Space tools’ differ depending on your space permissions. All space tools options are available if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Space Labels in the space administration options.
3. Choose the x next to the space category.

Removing an entire space category
To remove a whole space category from Confluence, just remove that category from all spaces, as described above. A category cannot exist if there are no spaces labelled with that category. The space category will disappear from the dashboard and space directory.

**To remove an entire space category from Confluence:**

1. Choose **Spaces > Space directory** on the header.
2. Choose the space category that you want to remove.
3. You will see a list of all spaces in that category. Choose the spaces one by one, and remove the category from each space, as described above.

**Screenshot: Space categories**

```
| Space Details | Remove Space |
```

**Space Categories**

Space Categories will appear inside the categories tab on your dashboard and as tabs in the space directory. They can be used to group together related spaces.

![Space Categories](image)

**Labels**

confluence × development ×

Add

Notes

The ability to add space labels has been removed in Confluence 5.0 in order to simplify the way labels are used in spaces. Existing space labels will be preserved, but you will be unable to add new space labels. Space categories are unaffected by this change.

**Removing Labels**

Labels are key words or tags that you can add to pages, blog posts and attachments. You can define your own labels and use them to categorise, identify or bookmark content in Confluence. You can see the existing labels, and the pages which contain the labels, by viewing labels and labelled content.

**Removing labels in Confluence**

**To remove a label from a page or blog post:**

1. Go to the page that contains the label. You will see the labels at the bottom of the page below the page content.
2. Choose the edit icon beside the list of labels, or press L on your keyboard.
3. In the 'Labels' dialog, choose the X next to a label to remove that label.
4. Choose Close.

**Related pages:**

- Working with Confluence Labels
- Confluence User's Guide

**To remove a label from an attachment:**

1. Go to the page that contains the attachment. Choose **Tools > Attachments**.
2. Alternatively, go to the attachments view of the space:
   - Go to the space and choose **Space tools > Content Tools** on the sidebar.
   - Choose **Attachments**.
3. You will see a list of attachments, with columns for the attachment name and other details. If the attachment already has labels, these will be listed in the **Labels** column.
4. Choose the edit icon beside the list of labels.
5. In the 'Labels' dialog, choose the X next to a label to remove that label.
6. Choose Close.

When you have removed the label from all content, the label will disappear from the labels view in the space too.

Notes

- **Deleted pages containing labels**: If you have deleted pages that contain a label, you may need to purge the deleted pages from the space's trash to ensure that the label disappears too.
- **Bulk removal of labels**: There is no way to remove a number of labels at once, via the Confluence user interface. Instead, we suggest that you use the Confluence Command Line Interface. See the 'removeLabels' action described in the CLI documentation. For an introduction to the CLI, see this blog post: Confluence CLI for bulk actions like deleting or publishing pages.

Using Label Macros to Categorise Wiki Content

Using labels, you can categorise pages and refer to content across multiple categories, pages and even spaces.

Example

For the purpose of this example, imagine we have a space with pages of content on various types of vehicles. Pages are shown in bold text, while the labels are in blue.

- **Cars** vehicle-type
  - Toyota Prius vehicle car
  - Honda Civic vehicle car
  - Porsche Carrera vehicle car
- **Motorbikes** vehicle-type
  - Harley Davidson Sportster vehicle motorbike
  - Suzuki GSX-R vehicle motorbike

This page hierarchy can then be categorised using labels, with pages referenced using the Content by Label Macro.

<table>
<thead>
<tr>
<th>If you want to list...</th>
<th>You would use this label:</th>
<th>These would be the pages that you would get:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vehicle types</td>
<td>vehicle-type</td>
<td>Cars, Motorbikes</td>
</tr>
<tr>
<td>All vehicles</td>
<td>vehicle</td>
<td>Toyota Prius, Honda Civic, Porsche Carrera, Harley Davidson Sportster, Suzuki GSX-R</td>
</tr>
<tr>
<td>All cars</td>
<td>car</td>
<td>Toyota Prius, Honda Civic, Porsche Carrera</td>
</tr>
</tbody>
</table>

Related pages:

- Working with Confluence Labels
- Working with Macros
- Confluence User's Guide

Label macros

**Navmap macro**

The Navigation Map macro renders the list of pages associated with a specified label as a navigation map.

**Related Labels macro**
The `Related Labels macro` lists labels commonly associated with the current page's labels.

`Content by Label macro`

The `Content by Label macro` displays a list of content marked with specified labels.

`Content Report Table macro`

The `Content Report Table macro` displays a set of pages and blog posts in tabular format, based on the specified labels.

`Labels List macro`

The `Labels List macro` lists all labels of a space, grouped alphabetically.

`Recently Used Labels macro`

The `Recently Used Labels macro` lists labels most recently used in a specified scope - global (site), space, or personal.

`Popular Labels macro`

The `Popular Labels macro` displays popular labels in a list or in a heatmap (also called a cloud).

**Viewing Labels and Labelled Content**

Labels are key words or tags that you can add to pages, blog posts, attachments and spaces. You can define your own labels and use them to categorise, identify or bookmark content in Confluence. This page describes a few ways of viewing labels and labelled content. The focus of this page is on labels that are visible to everyone. You may also be interested in viewing personal labels.

**Finding the labels view**

Global labels are visible to all users with 'view' permission on the page, and personal labels are visible only to the person who added them.

- Any page or blog post that has labels will have them listed together in a block at the bottom of the page.
- You will also see labels in the 'Attachments' view or in a listing of attachments provided by the `Attachments macro`. (See [Displaying a List of Attachments](#).)

**To find the labels view by choosing a label:**

If you are in a page that has labels, choose a label.

- If it is a personal label (starts with 'my:') you will go to the personal labels page in your user profile. See [Viewing Personal Labels](#).
- If it is a global label, you will go to the 'Labels' tab of the space. Choose [Popular Labels](#) or [All Labels](#) to see all labels in the space.

**Screenshot: Labels as they are displayed on a page**

![Labels displayed on a page]

**To find the labels view via URL:**

Visit the following URL:

```
<MY.CONFLUENCE.SITE>/labels/listlabels-alphaview.action?key=MYSPACEKEY
```

For example: `https://confluence.atlassian.com/labels/listlabels-alphaview.action?key=DOC`

**To find the labels view from the menu (Documentation theme only):**
If the space is using the Documentation theme, you can access the labels view directly via the menu:

- Go to a page in the space and choose **Browse > Labels**.
- Choose **Popular Labels** or **All Labels** to see all labels in the space.

**On this page:**

- Finding the labels view
- Using the labels view
- Searching for labels
- Navigating pages by URL and label

**Related pages:**

- Viewing Personal Labels
- Searching Confluence
- Confluence User's Guide

**Using the labels view**

The labels view in a space offers the following options:

- **Popular Labels**: Choose this option to see a list of the most frequently used labels in that space. From here, you can also view the most popular labels across the site. The bigger the font size, the more popular the label.

- **All Labels**: View all labels in the space. From this view, you can choose a link to view an alphabetical listing of all labels across the site. Choosing a label will list all content in the space with that label. It will also display any related labels if they exist. **Related labels** are labels that frequently appear on pages together. For example, if pages labelled with 'sales' also tend to have the label 'marketing', these will be displayed as related labels.

- **See content from all spaces**: Expand the list of labels to include pages and other labelled content from all spaces.

**Screenshot: The labels view, showing all 'logo' labels**

**Searching for labels**

Use the 'labelText:' prefix to search specifically for content that has a specific label. The table below gives examples of search terms that you can enter into Confluence's search box, and the search results that you can expect.

<table>
<thead>
<tr>
<th>Searching for ...</th>
<th>Returns content that ...</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>labelText:</code>logo</td>
<td>... with the label 'logo'</td>
</tr>
<tr>
<td><code>labelText:</code>useful</td>
<td>... with the label 'useful'</td>
</tr>
</tbody>
</table>
### Confluence 5.4 Documentation

**Navigating pages by URL and label**

This section describes how to move around your Confluence pages by adding and subtracting labels from the list of labels that you want to match. You can search for matching labels by entering a URL. You can also add and subtract labels from the search.

**To search labelled pages by typing a URL:**

1. Open a new web browser window.
2. In the address bar of your web browser, type an URL such as:
   
   http://CONFLUENCE_HOSTNAME/label/foo+bar
   
3. Press Enter.
4. The 'View Labels' page will load, showing search results for pages with the labels 'foo' and 'bar'.

**Adding a label to your results:**

- Choose a label from the Related Labels list (at the top left).
- A new page loads, showing pages that contain all of the labels selected so far. You can continue to add labels to the results in this way.

**Subtracting a label from your search results:**

When two labels are in use, links to subtract a label from the search appear at the end of the labels list. These are easily identified because these links have a preceding minus sign, like this:

- education

### Viewing Personal Labels

Any page that has labels (global or personal) will have them listed at the bottom of the page. Personal labels start with 'my:', and are only visible to the user that created them.

**Note: Personal labels are deprecated.** The functionality for personal labels is still in Confluence, but we recommend that you stop using them. In a future release, we plan to remove the functionality altogether.

**To view your personal labels:**

- If you are on a page that has personal labels, click one of those labels to get to the screen showing all your personal labels.
- Alternatively, visit the URL: `<your Confluence site>/users/viewmylabels.action`. For example: http://confluence.atlassian.com/users/viewmylabels.action

You will see a list of your personal labels along with the pages that contain the label.

**Related pages:**

- Adding Labels
- Viewing Labels and Labelled Content
- Confluence User's Guide

### Working with Favourites

*Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
You can mark pages and spaces as favourites and then access them quickly from the Confluence dashboard and from your user profile.

Adding favourites

**To add a page as a favourite:**

1. Go to the page.
2. Choose **Tools > Favourite.**
   The menu item will change to ‘Remove Favourite’ to indicate the page is a favourite.

**To add a space as a favourite:**

1. Choose **Spaces > Space directory** on the header.
2. Choose the star icon next to the space name in the list of spaces.
   The star icon will change colour to indicate that you have added this space as a favourite.

**To add someone's personal space as a favourite:**

This option is only available for personal spaces. You cannot mark a person's profile as favourite, so this option is not available if the person has not yet created a personal space.

1. Choose **Spaces > Space directory** on the header.
2. Choose **Personal Spaces.**
3. Choose the star icon next to the space name in the list of spaces.
   The star icon will change colour to indicate that you have added this space as a favourite.

Removing favourites

**To remove a page as a favourite:**

1. Go to the page.
2. Choose **Tools > Remove Favourite.**
   This will change to 'Favourite' to indicate that you have removed this page from your favourites.

**To remove a space as a favourite:**

1. Go to the dashboard or choose Spaces in the header.
2. Choose the star icon beside the space in the list of spaces.
   The star icon will change colour to indicate that you have removed this space as a favourite.

**To remove a personal space as a favourite:**

1. Choose **Spaces** in the header.
2. Choose **Personal Spaces.**
3. Choose the star icon beside the space in the list of personal spaces.
   The star icon will change colour to indicate that you have removed this space as a favourite.

Viewing favourites

You can see your favourite pages via your user profile and on the dashboard.

**To view your favourites via your profile:**

1. Log in to Confluence, if you have not already done so.
2. Choose your profile picture at top right of the screen, then choose Favourites.
Screenshot: Viewing your favourites in your profile

On the dashboard, you can see:

- your favourite spaces on the Spaces tab.
- your most recently added favourite pages on the Pages tab.

Recently updated content in your favourite spaces will be listed on the Favourite Spaces tab on the dashboard.

Working with Attachments

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format. You can attach files to any page or blog post, provided you have permission to do so.

When a page you are viewing contains attachments, a small paperclip icon appears next to the breadcrumbs.
Clicking the paperclip icon will take you to the ‘Attachments’ view, where you will see the full list of attachments.

A quick guide to attachments

Choose **Tools > Attachments** to view and attach files to a Confluence page. (See **Attaching Files to a Page**.) If you attach a file with the same name as an existing attachment, Confluence will create a **new version** of the existing attachment.

Once you have attached the relevant files, you can **display attached images** and **multimedia content** on the page. If the attachment is an Office document, use the **View File macro** to display the content of the document on the Confluence page. If you have an Office application installed, you will also be able to launch your Office editor from within Confluence. See **Displaying Office Files in Confluence** and **Working with the Office Connector**.

Your page can display a **list of attachments** – these may be the files that are attached to the page or to any page in the space. You can also **display a link to an attachment**. When a user clicks the link, the attachment will open, provided that the user has the software application needed to open the attachment.

You can **label an attachment**, and then **use labels to categorise your content**.

---

### On this page:
- A quick guide to attachments
- Working with attachments
- Notes

### Related pages:
- Configuring Attachment Size
- Confluence User’s Guide
- Configuring your Attachment Storage

---

**Working with attachments**

- Using Drag-and-Drop in Confluence
- Attaching Files to a Page
- Attachment Versions
- Deleting an Attachment
- Displaying a List of Attachments
- Downloading Attachments
- Editing Attachment Properties
- Embedding Multimedia Content
- Embedding PowerPoint Presentations in a Page
- Moving an Attachment
- Viewing Attachment Details

---

**Notes**

If you want an attachment to be displayed on more than one page, you may wish to consider creating a special page to hold such attachments. This special page could be part of an ‘inclusions library’.

---

**Using Drag-and-Drop in Confluence**

This page describes the drag-and-drop functionality in Confluence, and the browser configurations needed to support that functionality.

**Overview of the drag-and-drop features**

Confluence supports these forms of drag-and-drop:

- **Drag-and-drop within the editor.** Working inside the editor panel, you can drag an image or a macro and drop it into a different location on the page.
- **Drag-and-drop for external images and files.** You can drag a file from a location outside Confluence, and drop it directly into the editor. For example, try it with images, video files, audio files, Office documents, and PDF files. The contents of the file will be embedded into the page or blog post.

**Drag-and-drop within the editor**
Working within the editor panel, you can drag an image or a macro from one location on the page and drop it into a different location on the page. Hover your cursor over the image or the macro placeholder. The cursor changes to a drag-and-drop icon and you can click the image or macro and drag it to a new location.

If you want to abandon the drag-and-drop action, press Escape. The image/macro will return to its original position.

**Requirements for internal drag-and-drop**

For the drag-and-drop of images and macros in the editor, Confluence supports the following browsers: Chrome, Firefox, and Internet Explorer 9. (Drag and drop in the editor does not work in Internet Explorer 8.)

**On this page:**
- Overview of the drag-and-drop features
- Drag-and-drop within the editor
  - Requirements for internal drag-and-drop
- Drag-and-drop for external images and files
  - Requirements for external drag-and-drop
  - Disabling drag-and-drop for external files

**Related pages:**
- Attaching Files to a Page
- Using the Editor
- Displaying Images
- Confluence User’s Guide

**Drag-and-drop for external images and files**

You can drag files from your computer or file system onto your browser and attach them to your Confluence pages or blog posts. You can drag and drop:

- multiple files at once.
- image, multimedia and PDF files, and Office documents.

When you drag and drop files onto the different Confluence views, you get the following results:

<table>
<thead>
<tr>
<th>Confluence View</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachments</td>
<td>Files are attached</td>
</tr>
<tr>
<td>Page</td>
<td>Files are attached</td>
</tr>
<tr>
<td>Edit</td>
<td>Files are attached, and embedded at the cursor position</td>
</tr>
</tbody>
</table>

**Requirements for external drag-and-drop**

- For dragging files from your computer or file system onto your browser, your browser must support the drag-and-drop functionality of HTML5. Browsers such as Firefox 3.5, Safari 4 and Internet Explorer 9 offer limited HTML5 functionality and don't support drag-and-drop.

**Note about supported web browsers:** Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. Check the Supported Platforms page to find the list of supported web browsers and browser versions on this page.

- Some older Confluence themes do not support Confluence's drag-and-drop feature.
  - **Supported themes:** Confluence Default theme, Documentation theme.
  - **Themes that are not supported:** Left Navigation theme, Clickr theme. You cannot drag and drop attachments into spaces that use these themes.
Disabling drag-and-drop for external files

- If you wish to disable the drag-and-drop feature, you can disable the entire Confluence Drag and Drop Plugin. See Disabling and Enabling Add-ons.
- You can also disable the drop zone that appears on the 'Attachments' view or the image dialog box, by disabling the View Attachments Drop Zone or Image Dialog Drop Zone modules of the above plugin. This will remove these drop zones while retaining Confluence's drag-and-drop functionality.

Attaching Files to a Page

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format. Read more in Working with Attachments.

When you attach a file to a page, Confluence makes a copy of the file and stores it on the Confluence server. Page attachments in Confluence are managed using the 'Attachments' view of the page.

To attach a file, you need the 'Create Attachments' permission. See Space Permissions.

When a page you are viewing contains attachments, a small paperclip icon appears next to the breadcrumbs. Clicking the paperclip icon will take you to the 'Attachments' view, where you will see the full list of attachments.

**On this page:**
- Attaching files
- Attachment versions
- Notes

**Related pages:**
- Working with Attachments
- Configuring Attachment Size
- Displaying Images
- Attachment Versions
- Deleting an Attachment
- Confluence User's Guide

Attaching files

This page describes the following ways of attaching files to a Confluence page:

- Drag and drop files on to a Confluence page.
- Browse to, and upload files from, your computer or network.

To attach a file to a page using drag-and-drop:

1. View the page to which you want to attach files.
2. Drag one or more files from your computer onto the page. The 'Attach File(s)' message box appears, indicating the upload status of the files being attached to your page.

You can drag and drop more than one file at a time onto a page. You cannot drag a folder of files onto a page. Expand this section to see other ways to drag-and-drop a file on to a page...

You can also drag and drop files:

- directly onto the 'Attachments' view for the page.
- directly onto the editor view of the page.
- onto any tab of the 'Insert Link' or 'Insert Image' dialogs, which are available from the Insert menu while editing.

To attach a file to a page from the computer's (or network's) file system:

2. Choose Browse and navigate to the file.
3. Select the file and click Open.
4. Add a descriptive comment for the file (optional).
5. Choose **Attach more files** if required.
6. Choose **Attach**.

You can attach than one file at a time. You cannot attach a folder of files.

Expand this section to see other ways to upload a file to a page...

You can also browse for, and upload, a file from:

- the 'Attachments' tab of the 'Insert Link' dialog. (While editing the page, choose **Insert > Link**.)
- the 'Attached Images' tab of the 'Insert Image' dialog. (While editing the page, choose **Insert > Image**.)

**Attachment versions**

If you upload a file with the same name as an existing attachment, Confluence will rename the old file and keep it as a previous version. Read more about **Attachment Versions** and **Viewing Attachment Details**.

**Notes**

- **Reusing attachments**: If you want to display the same file on more than one page, the best way is to put the attachment on a page (say, page A) and then use the **Include Page Macro** to include page A into page B, page C, and all the pages where you want the diagram, presentation, or other file. Alternatively, you can **display an image that is attached to another page**.
- **Updating the original file**: Any changes you make to the source file do not affect the copy that was uploaded to Confluence. To update the Confluence copy, you need to upload the new version of the file.

**Attachment Versions**

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

When **viewing a list of attachments**, you can add a **new version of an existing attachment** by uploading an attachment with the same file name, as displayed on the attachment view. Existing files will be kept with the name 'Version x', where the value of 'x' increments with each upload of an attachment with the same file name.

**To see all versions of an attachment**: Choose the arrow next to an attachment name.

**Related pages:**
- Attaching Files to a Page
- Deleting an Attachment
- Moving an Attachment
- Viewing Attachment Details
- Working with Attachments
- Confluence User's Guide

**Screenshot: Attachment versions**

![Attachment versions table]

**Notes**

- You cannot revert to a previous version of an attachment. See feature request **CONF-1943**.
- Confluence does not track the history of attachments in the same way as it does for pages. See feature request **CONF-13943**.
There is no limit to the number of attachments or attachment versions, provided that there is enough disk space.

By default, attachments and their versions are stored in the `<confluence_home>/attachments` directory. (See Attachment Storage Configuration.)

Deleting an Attachment

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

By default, when you delete an attachment, this will delete all versions of the attachment. To do that, you need the 'Delete Attachments' permission. See Space permissions.

If you want to delete a specific version of an attachment, you need to be a space administrator.

To delete all versions of an attachment:

1. Go to the page that contains the attachment.
3. Choose Delete next to the attachment you want to delete.
4. Choose Delete to confirm your action.

To delete a specific version of an attachment:

1. Go to the page that contains the attachment.
2. Choose Tools > Attachments. A list of the page’s attachments will appear.
3. Choose the arrow on the left next to the attachment you want to manage. A list of attachment versions will appear.
4. Choose Delete next to the version you want to delete.
5. Choose Delete to confirm your action.

Screenshot: Attachments and attachment versions

Displaying a List of Attachments

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

You can display a list of attachments on your page – these may be the files that are attached to the current page or to any page in the space. Use the

- Use the Attachments macro to show a list of the attachments on the current page, or
- Use the Space Attachments macro to show a list of the attachments in the current space.

Both these macros generate a table of attachments which is clickable.

Using the macros
To add the Attachments or Space Attachments macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters of the Attachments macro

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filename Patterns</td>
<td>all</td>
<td>A comma-separated list of regular expressions, used to filter the attachments by file name. Note that the parameter values must be regular expressions. For example: • To match a file suffix of 'jpg', use .*jpg (not *.jpg). • To match file names ending in 'jpg' or 'png', use .*jpg,.*png</td>
</tr>
<tr>
<td>Attachment Labels</td>
<td>(none)</td>
<td>A list of labels, used to filter the attachments to display. If you wish to enter more than one label, separate the labels with commas. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.) For information on labelling the attachments, see Adding Labels.</td>
</tr>
<tr>
<td>Include Old Attachment Versions</td>
<td>false</td>
<td>A value of true will include previous attachment versions in the list.</td>
</tr>
</tbody>
</table>

On this page:
- Using the macros
- Parameters of the Attachments macro
- Viewing files and changing file properties via the Attachments macro
- Parameters of the Space Attachments macro
- Code examples

Related pages:
- Attaching Files to a Page
- Working with Attachments
- Working with Macros
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros
- Confluence User’s Guide
### Viewing files and changing file properties via the Attachments macro

The list of files displayed by the Attachments macro can be expanded to show options for viewing the files and other actions, provided you have the relevant permissions.

- If you have specified the 'Allow Upload' parameter, users will be able to upload attachments directly from the list.
- You can delete attachments. Note that you can only delete the entire attachment (including all versions). To delete a specific version of an attachment, you must go to the 'Attachments' view. See [Deleting an Attachment](#).
- You can edit attachment properties and labels. If an attachment is an Office or PDF file, they will see the appropriate options for [Office Connector](#) files.

**Screenshot: The Attachments macro, showing details of an attachment**
Parameters of the Space Attachments macro

The Space Attachments macro displays a list of all the attachments in a space. You can choose to show attachments from the current space, or another space.

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>(none)</td>
<td>Selects the Confluence space to display attachments for. If you do not specify a space, the current space will be used.</td>
</tr>
<tr>
<td>Show Filter Controls</td>
<td>true</td>
<td>Determines whether or not the filter panel is shown. If you select this option, people viewing the page will be able to filter the list of attachments by file type (extension) and by label.</td>
</tr>
</tbody>
</table>

Screenshot: The Space Attachments macro
Code examples

For the Attachments macro:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

For the Space Attachments macro:
- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Downloading Attachments**

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

**To download a single attachment from a page:**

1. View the page.
2. Choose **Tools > Attachments**.
3. Right-click the link on the attachment name, and select **Save Link As**, **Save Target As** or a similar option provided by your browser. This will open a ‘Save’ dialog.
4. Select the location into which you want to download the file and choose **Save**.

**Related pages:**
- Attaching Files to a Page
- Working with Attachments
- Confluence User’s Guide

**To download all the attachments from a page:**

1. View the page.
2. Choose **Tools > Attachments**.
3. Choose the **Download All** button at the end of the page to download a zipped file of all the page’s attachments.

**Notes**

- There is no permission that controls the downloading of attachments. See an article in our knowledge base about disabling the download of attachments.
- Confluence does not supply an option to download all attachments from a space. See the closed feature request: 

  ![CONF-5669](https://confluenceohnline.com/CONF-5669) - Download all attachments from a Space

**Editing Attachment Properties**
An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

To edit an attachment's properties, you need the 'Create Attachments' permission. See Space Permissions.

**To edit the properties of an attachment:**

1. View the page that contains the attachment.
2. Choose **Tools > Attachments**.
3. Choose **Properties** next to the attachment. The 'Properties' screen will appear.
4. Make your changes:
   - **File Name** — Rename or modify the name of the attachment.
   - **New Comment** — Update the existing comment or enter a new comment.
   - **New Content Type** — Change the content type of the attachment by entering a valid MIME type.
   - **Page** — Move the attachment to another page.
5. Choose **Save**.

**Related pages:**
- Attaching Files to a Page
- Moving an Attachment
- Viewing Attachment Details
- Working with Attachments
- Confluence User's Guide

**Embedding Multimedia Content**

Using multimedia files you can display movies, animations and videos, and embed audio files on your Confluence page.

There are several methods for attaching files to a page. Once you have attached the multimedia file to a Confluence page, you then edit the page to set where the multimedia content should appear.

In the example below, we display a Flash file that is attached to this page.

Error rendering macro 'multimedia' : null

Confluence supports the following multimedia formats:

- Adobe Flash (.swf)
- Apple QuickTime (.mov)
Quick guide to displaying multimedia content on a page

Choose one of these methods:

- **Add the macro yourself**: Attach the multimedia file to the page in the usual way. Add the Multimedia macro using the macro browser.
- **Autocomplete**: Attach the multimedia file to the page in the usual way. Type '!\' in the editor and choose the multimedia file from the list that appears.
- **Drag and drop**: Drop the video or other file into the editor. Confluence will attach the file and insert the Multimedia macro for you.
- **Adjust parameters if necessary**: Click on the Multimedia macro placeholder to set options for the macro, such as adjusting the width or height of the display, or setting autoplay on.

Displaying a multimedia file attached to the page

Once you have attached a multimedia file to a page, there are different methods for choosing where on the page the multimedia content should appear:

**Inserting the Multimedia macro yourself**

You can add the Multimedia macro to the page yourself using the Macro Browser. This allows you to display a multimedia file that is attached to either the current page or to another page in the Confluence site.

**To insert the Multimedia macro on the page at the current cursor position:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete**: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro**: Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Using autocomplete**

Once a multimedia file is attached to the page, you can use autocomplete, while editing the page, to choose where the multimedia content should appear.

**To position an attached multimedia file on the page using autocomplete:**

1. While editing the page, position the cursor where you want to place the multimedia content.
2. Trigger the autocomplete function by typing '!\'.
3. Choose the multimedia file from the list that appears.
4. If necessary, click on the Multimedia macro placeholder and choose **Edit** to set various options such as the width, height or autoplay.

**Using drag-and-drop**

Depending on the browser you are using, you can attach and position a multimedia file in one step using drag-and-drop.

**To attach and position multimedia content using drag-and-drop:**

1. While you are editing a page, simply **drag-and-drop** the multimedia file on to the page. Confluence will...
attach the file to the page and insert the Multimedia macro at the current cursor position for you.

2. If necessary, click on the Multimedia macro placeholder and choose **Edit** to set various options such as the width, height or autoplay.

**Multimedia macro parameters**

Parameters are options that you can set to control the content or format of the macro output.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page Name</strong></td>
<td>Current page</td>
<td>Name of the page to which the multimedia file is attached. If you are using the Macro Browser, just start typing the name of the page and then select it from the dropdown list that appears. The page can be in the same space or another space.</td>
</tr>
<tr>
<td><strong>Attachment</strong></td>
<td>None</td>
<td>File name of the multimedia file.</td>
</tr>
<tr>
<td><strong>Width</strong></td>
<td>If not specified, the browser will determine the width based on the file type.</td>
<td>Width of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's width, or any other value accepted by HTML.</td>
</tr>
<tr>
<td><strong>Height</strong></td>
<td>If not specified, the browser will determine the height based on the file type.</td>
<td>Height of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's height, or any other value accepted by HTML.</td>
</tr>
<tr>
<td><strong>Autoplay</strong></td>
<td>False</td>
<td>If this option is checked (that is, if the parameter is set to 'true') then the video or audio file will start playing as soon as the page is loaded. If this option is not checked (set to 'false') then the file will not play until the user clicks the icon or image on the page. See the note about autoplay below.</td>
</tr>
</tbody>
</table>

**Notes**

- **The multimedia file must be attached to a Confluence page.** For security reasons, files located on remote servers are not permitted. See the [Widget Connector](#) for displaying live content from external sites.

- **You will need the relevant multimedia plugin for your browser.** Your browser (Firefox, Internet Explorer, Safari and others) needs a plugin to play the video or audio file on a Confluence page. For example, to play a Flash movie you need the Flash plugin. Many plugins are shipped with the major browsers by default. If a user does not have the required plugin installed and enabled in their browser, they will not be able to view the multimedia files on the page.

- **Autoplay may not always work as expected.** You can set autoplay on, so that your video or audio file should start playing as soon as the page is loaded into the browser. (See [parameters](#).) However, this
setting may not always work as expected. Confluence will send an instruction to the browser plugin that plays the multimedia file. Different browsers and different media plugins behave in different ways, and not all of them respect such instructions.

- **Use the Office Connector to display Office documents.** Take a look at the Office Connector for embedding Word documents, presentations and other Office documents onto your Confluence page.

- If you get the error, 'Unable to embed content of type application/octet-stream', this means the MIME type is not recognised.

- **Advanced users can try styling via CSS.** By default, each embedded object is wrapped in a div tag. If you wish to style the div and its contents, override the embeddedObject CSS class. Specifying an ID as a property also allows you to style different embedded objects differently. CSS class names in the format embeddedObject-ID are used.

**Code examples**

**See:**

- Confluence Wiki Markup for Macros
- Confluence Storage Format for Macros

**Related topics**

Working with Macros
Widget Connector Macro
Working with the Office Connector
Working with Attachments

Take me back to Confluence User's Guide

**Embedding PowerPoint Presentations in a Page**

Below are some ideas on how you can display a presentation on a Confluence page.

**Option 1 - Office Connector for Confluence**

The Office Connector provides the most straightforward way to display PowerPoint slides.

1. Attach your PowerPoint file to a Confluence page - see Attaching Files to a Page.
2. Use the Office PowerPoint View File macro to display the presentation on the page.

Alternatively you can drag your PowerPoint file directly into the editor, and Confluence will attach the file and display it in the Office PowerPoint View File Macro for you.

**On this page:**

- Option 1 - Office Connector for Confluence
- Option 2 - PDF View File macro
- Option 3 - Gallery or Slide Show of JPEG or PNG Images

**Related pages:**

- Working with the Office Connector
- Working with Attachments
- Confluence User's Guide

**Option 2 - PDF View File macro**

1. Convert your presentation to PDF, using ‘Save as > PDF’ in PowerPoint (PowerPoint 2007 and later).
2. Attach the PDF file to your Confluence page.
3. Use the PDF View File macro to display the presentation on the page. The PDF View File macro contains Next Slide, Previous Slide and Full Screen Mode buttons for controlling your presentation.

Alternatively you can drag your PDF file directly into the editor, and Confluence will attach the file and display it in the PDF View File Macro for you.

This method is also useful for presentations created in other packages such as Keynote.
Option 3 - Gallery or Slide Show of JPEG or PNG Images

1. Convert your PowerPoint presentation into JPEG or PNG images, using 'save as' from PowerPoint (slide1.jpg, slide2.jpg...).
2. Upload the image files as attachments to your Confluence page.
3. Use the Gallery macro to display the images as a slide show in Confluence.

Moving an Attachment

You can move an attachment from its current location to any page within the site.

To move an attachment, you need the following permissions (see Space Permissions):

- 'Add Page' permissions on the page where the attachment currently exists.
- 'Remove Attachment' permissions for the space where the attachment currently exists.
- 'Add Attachment' permission on the space into which you are moving the attachment.

To move an attachment:

1. Go to the page that contains the attachment.
2. Choose Tools > Attachments.
3. Choose Properties next to the attachment.
4. Enter the name of the page where you want to move the attachment into the Page field, for example, My Destination Page.
5. Choose Save.

If you wish to move the attachment to a page in a different space, add the space key before the page name, for example, DOC:My Destination Page.

Related pages:
- Moving a Page
- Working with Attachments
- Confluence User's Guide

Viewing Attachment Details

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

You can view attachment details in the following places:

- The list of attachments in a space. This will show all files attached to all pages in the space. See below.
- The list of attachments for a specific page. See below.
- A list of attachments created by a macro and displayed on a page. See Displaying a List of Attachments.

Viewing attachments in a space

To view the attachments associated with a space:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Attachments. You will see a list of all the attachments in the space, along with their details and the pages they are attached to.
   
   To see only files of a particular type:
   - Type the last part of the file name in the Filter By File Extension box. For example, enter 'gif' to see only image files of the GIF format.
   - Choose Filter.

3. To see only files that have a particular label or labels:
   - Type the label or labels in the Filter by Label box. If you enter more than one label, separate the labels with commas or spaces. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.)
   - Choose Filter.

If your space uses the Documentation theme:

2. Choose Attachments from the left menu.
## Viewing attachments on a page

When a page you are viewing contains attachments, a small paperclip icon appears next to the breadcrumbs. Clicking the paperclip icon will take you to the ‘Attachments’ view, where you will see the full list of attachments.

### To view the attachments associated with a page:

1. Go to the page.
2. Choose **Tools > Attachments**. You will see a list of the attachments in the page along with their details.
3. To see all versions of an attachment, choose the arrow on the left of the attachment name.

The list of attachments includes options for viewing the files, and other actions, provided the user has the relevant permissions. If you have specified the 'Allow Upload' parameter, users will be able to upload attachments directly from the list too. Users can also delete attachments or edit attachment properties and labels. If an attachment is an Office or PDF file, you will see the appropriate options for Office Connector files.

### Attachment details

Note that the page view shows a different subset of fields from the space view.

- **Name** is the name of the attached file.
- **Size** tells you how much space the attachment takes up. You can sort by size by clicking the column title.
- **Creator** is the person who attached the file. Clicking on the link takes you to the person's user profile.
- **Creation Date** is the date the file was attached. You can sort by date by clicking the column title.
- **Labels** are keywords, or tags, that you can enter to categorise the attachments. See how to add labels.
- **Last Mod. Date** (in the space view) is the date the file was last modified.
- **Attached To** (in the space view) tells you which page contains the attachment.
• **Comment** (in the page view) is a short description of the attachment.

• The **Properties** link (in the page view) lets you edit the attachment details. See how to edit attachment properties.

• The **Delete** link (in the page view) lets you delete the attachment, or a specific version of the attachment.

• The **Edit in Office** link (in the page view) appears next to Office files only, and lets you edit that attachment.

• The **Attach File** option lets you add another attachment or another version of an existing attachment. See how to upload attachments.

### Customising Confluence

You can customise or configure many aspects of Confluence:

• The **look and feel** of any Confluence space.

• **Personal aspects**, including your personal profile and homepage.

• Setting up your **user profile**.

• **User access**, including permissions and page restrictions.

• Add-ons such as **gadgets** and **macros**.

• Customisations for **specific uses** of Confluence.

### Related pages:

• Configuring Confluence

• Configuring Confluence Security

• Confluence User’s Guide

• Managing Add-ons and Macros

### Personal Customisations

There are several ways that you can customise the way that Confluence works for you, including:

• Your **personal home page**

• Your **personal dashboard**

• Your **personal profile**

• Your **email notifications**

• Your **RSS Feed settings**

### Related pages:

• Customising Confluence

• Confluence User’s Guide

### User Profile Overview

Each Confluence user has a user profile. In your own profile, you can access account management features and updated information about yourself. You can also view other users’ profiles.

#### To find your user profile:

Choose your **profile picture** at top right of the screen, then choose **Profile**.

Or, choose the **Profile** link in the sidebar of your personal space.

#### To find someone else’s user profile:

1. Open the user's hover profile popup:
   - Log in to Confluence, if you have not already done so.
   - Note: If a Confluence Administrator has granted the 'View User Profiles' permission to anonymous users, you can access people's hover profile popups without logging in. However, the hover profile features available to anonymous users are restricted.
   - Move your mouse pointer over a user's linked name or profile picture. The hover profile popup will appear.

2. Choose the user’s linked name to open the user profile.

Alternatively, you can choose the **Profile** link in the sidebar of the user’s personal space or go directly to this URL:

http://MY.CONFLUENCE.COM/users/viewuserprofile.action?username=USERNAME
Profile

- View and edit your personal details, such as your name and email address details and optionally, your photograph and other personal information. Note that as a security precaution, in order to change your email address, you will be required to re-enter your password.
- Upload a profile picture (optional).
- Change your password.

Network

- View the recent activity of users that you are following via the Network view.
- Follow other users from this view.

Status Updates

- View your history of status updates.

Favourites

- View a list of your favourite spaces.

Watches

- View a list of the pages and spaces you are currently watching.

Drafts

- Retrieve any pages you were in the process of editing. See Working with Drafts.

Settings

- Edit your General Settings (homepage, language and timezone).
- Subscribe to email notifications.
- View and revoke your OAuth access tokens.
Notes

The ‘Administer User’ link is visible to Confluence administrators only. The administrator can click this link to go directly to the user management screen in the Administration Console.

Changing Password

To change your Confluence password:

1. Choose your profile picture at top right of the screen, then choose Profile.
2. On your Profile tab, click Password in the left-hand column.
3. Enter your current password and your new password in the form displayed.
4. Click Submit.

Related Topics

Viewing User Profile
Editing Your User Profile
Choosing a Profile Picture
Setting Up your Personal Space
Updating Email Address
Email Address Privacy

Take me back to the Confluence User's Guide.

Editing User Settings

You can set various Confluence preferences that affect your personal session:

- General preferences such as home page, language and time zone, as described below.
- Editor settings, as described below.
- Email settings for subscriptions to email reports. See Subscribing to Email Notifications of Updates to Confluence Content.
- OAuth access tokens that you have granted from your Confluence user account. See Viewing and Revoking OAuth Access Tokens.

General User Preferences

To edit your general user settings:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Click Edit and update the settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site Homepage</td>
<td>Select the page that you would like to see whenever you log into Confluence.</td>
</tr>
<tr>
<td>Language</td>
<td>Select your language. See below.</td>
</tr>
<tr>
<td>Time zone</td>
<td>Select your time zone.</td>
</tr>
<tr>
<td>Use Keyboard Shortcuts</td>
<td>Enable keyboard shortcuts, other than for the editor.</td>
</tr>
<tr>
<td>Text select</td>
<td>Turn off the popup options panel when highlighting text.</td>
</tr>
</tbody>
</table>

3. Click Submit.
More about Language

Setting your language preference in your user profile is described in the section above. This section gives more information about that setting and other settings that affect the language Confluence will use.

Individual users can choose the language that Confluence will use to display screen text and messages. Note that the list of supported languages depends on the language packs installed on your Confluence site.

The language used for your session will depend on the settings below, in the following order of priority from highest to lowest:

- The language preference defined in your user profile. Note that you need to be logged in for this setting to take effect.
- The language that you choose by clicking an option at the bottom of the Confluence login screen. Confluence stores this value in a cookie. When the cookie expires, the setting will expire too.
- The language set in your browser. The browser sends a header with a prioritised list of languages. Confluence will use the first supported language in that list. Your Confluence administrator can disable this option by setting a system property.
• The default language for your site, as defined by your Confluence site administrator.

**Editor Preferences**

You can set some options that determine the way the Confluence editor works. Note that these settings affect only you. Other people using Confluence can enable or disable the settings on their user profiles independently.

To change your editor preferences:

1. Choose your profile picture at top right of the screen, then choose **Settings**.
2. Click **Editor** under "Your Settings" in the left-hand panel.
3. Click **Edit**.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable Autocomplete</td>
<td>Select to disable <em>autocompletion</em> when you press one of the trigger characters.</td>
</tr>
<tr>
<td>Disable Autoformatting</td>
<td>Select to disable <em>autoformatting</em> when you type wiki markup in the editor. Click ? on the editor toolbar to learn more.</td>
</tr>
</tbody>
</table>

4. Click **Submit**.

**Screenshot: User settings for the editor**

---

**Editing Your User Profile**

Your user profile contains basic information about you. If you do not have a **personal space**, your user profile will be displayed when anyone clicks your name in the **People Directory**.

To edit your user profile:

1. Choose your profile picture at top right of the screen, then choose **Profile**.
   Or, choose the **Profile** link in the sidebar of your personal space.
2. Choose **Edit Profile**.
3. Enter details about yourself in the form displayed.
4. Click **Save**.
### Related pages:
- Viewing User Profile
- Choosing a Profile Picture
- Setting Up your Personal Space
- Email Address Privacy
- Confluence User's Guide.

### Detail | Description
--- | ---
**Full Name** | Your name as you would like it to appear in your profile.
**Email** | Your email address which will be used to send you mail notifications.
**Phone** | Your phone number.
**IM** | Your Instant Messenger (IM) details. To suit a variety of IM applications, this option accepts any string value. For example, you can enter IM details in the form of an email address, such as `example@example.com` or a user ID, like `123456789`.
**Website** | Your website's URL.
**About me** | Information about yourself that other users can view (such as your professional information, hobbies, and other interests). You can use Confluence wiki markup in this field.
**Position** | The title of your position within your organisation.
**Department** | The name of your department within your organisation.
**Location** | Your location. This could be a town, city, region or country.

#### Handy Hint
Confluence administrators can configure Confluence to mask email addresses (e.g. ‘example at atlassian dot com’), protecting your email address from search engine spiders and the like.

### Email Address Privacy
Confluence can mask the email addresses of users to protect them from mail spammers.

This is done by a Confluence administrator and is configured through the Administration Console. The Confluence administrator has three options for email address privacy:

- **Public**: email addresses are displayed publicly.
- **Masked**: email addresses are still displayed publicly, but masked in such a way to make it harder for spam-bots to harvest them.
- **Private**: only Confluence administrators can see the email addresses.

For more information on setting these options, which are configured using the Administration Console, refer to User Email Visibility.

#### Related pages:
- Editing Your User Profile
- Viewing User Profile
- User Email Visibility
- Confluence User's Guide

### Updating Email Address
The email address you specify in your profile settings is used for your mail notifications and is also displayed in your profile description.

**To update your email address:**

1. Choose your profile picture at top right of the screen, then choose Profile.
2. Click Edit in the 'Personal' section.
3. In the Email field, specify your new email address which will be used when sending you mail notifications.
4. Click Save.

Related Topics

Changing Password
Editing Your User Profile

Take me back to the Confluence User's Guide.

Choosing a Profile Picture

Your profile picture is used as the icon for your personal space, to represent you in the People Directory, and to illustrate your comments. It also appears in various other places next to your name, such as in the list of recent updates on the dashboard.

You can upload your own profile picture or use one of the images provided by Confluence. If you upload your own profile picture, you will have an opportunity to crop (trim) the picture.

**To choose a profile picture:**

1. Choose your profile picture at top right of the screen, then choose Profile.
2. Click Picture on the left.
3. Choose one of the following two options:
   - Upload a new picture: Click Browse to locate your picture, then click Upload to upload it from your computer or file server.
   - Or select one of the default icons provided.
4. Click Set Profile Picture.

**On this page:**

**Related pages:**

- Deleting a Profile Picture
- Editing Your User Profile
- Setting Up your Personal Space
- Confluence User's Guide

**Screenshot:** Choosing a profile picture
If you upload a profile picture that is larger than 48x48 pixels, the 'Edit My Profile Picture' screen will appear. You can select part of the picture or the entire picture, to be used as the final image for your profile. Note that the size of the final image will always be scaled down to 48x48 pixels.

To edit your profile picture:

1. Click and drag the centre of the superimposed square to select the centre of the new image.
2. Click the corners of the square to resize the area for your new image.
3. Click Save.
4. The image from your selected area will be cropped, resized to 48x48 pixels and saved.

Screenshot: Trimming a profile picture
Deleting a Profile Picture

You can delete the profile picture images that you have uploaded to Confluence.

To delete a profile picture:

1. Choose your profile picture at top right of the screen, then choose Profile.
2. Click Picture on the left.
3. Locate and select the picture file you wish to delete, then click Delete.
   - Note that you can only delete images that you have uploaded to Confluence. The standard icons cannot be deleted.
4. Click Delete to confirm the action. The picture is permanently removed from the server.

Related pages:
- Choosing a Profile Picture
- Editing Your User Profile
- Setting Up your Personal Space
- Confluence User's Guide.

Screenshot: Deleting a Profile Picture
Viewing User Profile

Each Confluence user has a user profile. In your own profile, you can access account management features and update information about yourself. You can also view other users' profiles, add them to your network, and add their personal spaces to your list of favourites.

To find your user profile:

Choose your profile picture at top right of the screen, then choose Profile. Or, choose the Profile link in the sidebar of your personal space.

To find someone else's user profile:

1. Open the user's hover profile popup:
   - Log in to Confluence, if you have not already done so.
   - Note: If a Confluence Administrator has granted the 'View User Profiles' permission to anonymous users, you can access people's hover profile popups without logging in. However, the hover profile features available to anonymous users are restricted.
   - Move your mouse pointer over a user's linked name or profile picture. The hover profile popup will appear.

2. Choose the user's linked name to open the user profile.

Alternatively, you can choose the Profile link in the sidebar of the user's personal space or go directly to this URL:

http://MY.CONFLUENCE.COM/users/viewuserprofile.action?username=USERNAME

Related pages:
- User Profile Overview
- Setting Up your Personal Space
- Confluence User's Guide

Screenshot: User profile for the current user.

Updating your profile

You can update the following aspects of your profile from this view:

- **Information about yourself** – see Editing Your User Profile.
- **Your Profile picture** – see Choosing a Profile Picture.
- **Your login password** – see Changing Password.
Viewing and Revoking OAuth Access Tokens

This page describes the purpose of OAuth access tokens which have been issued on behalf of your Confluence user account and provides instructions on how to revoke them.

On this page:

- OAuth Access Tokens
- Viewing your OAuth Access Tokens
  - OAuth Access Token Details
- Revoking your OAuth Access Tokens

OAuth Access Tokens

OAuth access tokens allow you to use a Confluence gadget on an external web application or website (also known as the 'consumer') and grant this gadget access to Confluence data which is restricted or privy to your Confluence user account.

OAuth access tokens will only appear in your user profile if the following conditions have been met:

1. Your Confluence Administrator has established an OAuth relationship between your Confluence site and the consumer. Confluence Administrators should refer to Configuring OAuth for more information about establishing these OAuth relationships.
2. You have accessed a Confluence gadget on the consumer and have conducted the following tasks:
   a. Logged in to your Confluence user account via the gadget and then,
   b. Clicked the 'Approve Access' button to allow the gadget access to data that is privy to your Confluence user account.

   Confluence will then send the consumer an OAuth 'access token', which is specific to this gadget. You can view the details of this access token from your Confluence site's user account.

   An OAuth access token acts as a type of 'key'. As long as the consumer is in possession of this access token, the Confluence gadget on the consumer will be able to access Confluence data that is both publicly available and privy to your Confluence user account. As a Confluence user, you can revoke this access token at any time. Furthermore, all access tokens expire after seven days. Once the access token is revoked or has expired, the Confluence gadget will only have access to publicly available Confluence data.

Viewing your OAuth Access Tokens

To view all of your Confluence user account's OAuth access tokens:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Click View OAuth Access Tokens. A view similar to screenshot below is displayed. Refer to OAuth Access Token Details below for information on interpreting this table.

   If no access tokens have been set, then 'None specified' is shown.

### Screenshot: Viewing your OAuth Access Tokens

<table>
<thead>
<tr>
<th>Authorised Applications</th>
</tr>
</thead>
<tbody>
<tr>
<td>The following applications are using your account to access Confluence data:</td>
</tr>
<tr>
<td>Consumer</td>
</tr>
<tr>
<td>Atlassian JIRA</td>
</tr>
</tbody>
</table>

### OAuth Access Token Details

Your list of OAuth access tokens is presented in a tabular format, with each access token presented in separate rows and each property of these tokens presented in a separate columns:
<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Consumer</td>
<td>The name of the Confluence gadget that was added on the consumer.</td>
</tr>
<tr>
<td>Consumer Description</td>
<td>A description of this consumer application. This information would have been obtained from the consumer's own OAuth settings when an OAuth relationship was established between Confluence and that consumer. If the consumer is another Atlassian application, this information is obtained from the Consumer Info tab's 'Description' field of the OAuth Administration settings. The application's administrator can customise this Consumer Info detail.</td>
</tr>
<tr>
<td>Issued On</td>
<td>The date on which the OAuth access token was issued to the consumer by Confluence. This would have occurred immediately after you approved this gadget access to your Confluence data (privy to your Confluence user account).</td>
</tr>
<tr>
<td>Expires On</td>
<td>The date when the OAuth access token expires. This is seven days after the 'Issued On' date. When this date is reached, the access token will be automatically removed from this list.</td>
</tr>
<tr>
<td>Actions</td>
<td>The functionality for revoking the access token.</td>
</tr>
</tbody>
</table>

**Revoking your OAuth Access Tokens**

**To revoke one of your OAuth access tokens:**

1. View your Confluence user account's OAuth access tokens *(described above).*
2. Locate the Confluence gadget whose OAuth access token you wish to revoke and click **Revoke OAuth Access Token** next to it.
   The gadget's access token is revoked and the Confluence gadget on the consumer will only have access to publicly available Confluence data.

**Choosing your Home Page**

By default, all users are directed to the dashboard after logging in. However, you can choose to be redirected to the home page of any space on the Confluence site after logging in.

**To set the home page:**

1. Choose **your profile picture** at top right of the screen, then choose **Settings**.
2. Choose **Edit**.
3. Choose a page from the **Site Homepage** drop down. Only spaces for which you have 'view' access display. You will be directed to the home page of the selected space when you next log in.
4. Click **Submit**.

**Related pages:**

- User Profile Overview
- Confluence User's Guide

**Screenshot: Profile Settings**
Customising your Personal Dashboard

You can customise the Confluence dashboard to provide access to the content on the site that is most relevant to you. The options described on this page will change your own personal dashboard, but will not affect the dashboard that other people see.

If you have System Administrator permissions, you can change the global dashboard, as seen by all Confluence users. See the administrator’s guide to customising the dashboard.

Displaying your favourite spaces

Mark some spaces as favourites. You can now choose the Spaces tab on the dashboard to see a list of your favourite spaces. You can also choose the Favourite Spaces tab at the top right of the dashboard to see recently updated content from just your favourite spaces.

Categorising your spaces

To help keep Confluence spaces organised, you can label spaces with different space categories. See Using Labels to Categorise Spaces. Space categories are used to group related spaces.

For example, you might want to group spaces on your Confluence site by applying the following space categories to the relevant spaces:

- 'design' (for spaces relevant to a design team), and
- 'development' (for spaces relevant to a development team).

If a subset of these spaces is relevant to both teams, apply both the ‘design’ and ‘development’ categories to each of these spaces to make the spaces appear in both groups.

Once you have added space categories, you can choose the Space Categories tab at the top right of the dashboard and select a category from the drop-down menu to display only spaces belonging to that category.
On this page:
- Displaying your favourite spaces
- Categorising your spaces
- Displaying your favourite pages

Related pages:
- Working with Confluence Labels
- Working with Favourites
- Configuring the Site Home Page
- Customising the Confluence Dashboard
- Confluence User's Guide

Displaying your favourite pages

Mark some pages as favourites. You can now choose the Pages tab on the dashboard to see a list of your favourite pages.

Screenshot: The dashboard, showing favourite pages and space categories

Customising the Look and Feel of a Confluence Space

You can customise the 'look and feel' of a space on your Confluence site through options available in the Space Administration menu. By default, the look and feel of a space is based on site-wide settings configured from the Administration Console.

You need to be a space administrator to change the look and feel of a space.

- Applying a Theme to a Space
- Configuring a Sidebar
- Changing a Space's Logo
- Changing the Confluence Browser Icon, aka favicon
- Customising Space Layouts
Applying a Theme to a Space

Themes allow you to personalise the 'look and feel' of Confluence. You can apply a theme to your entire Confluence site or to individual spaces. Choose a specific theme if you want to add new functionality or significantly alter the appearance of Confluence.

Confluence comes with a selection of themes. In addition, a site administrator can install new themes as plugins via the Confluence Administration Console. Provided that the theme is installed into your Confluence site, any space administrator can apply a theme to a space.

By default when you create a new space, the space will have the Confluence default theme.

To apply a theme to a space:

1. Go to the space and choose **Space tools > Look and Feel** on the sidebar.
   You'll need **Space Admin permissions** to do this.
2. Choose **Themes** and select a theme option.
3. Choose **Confirm**.

   *Screenshot: Applying a theme*
If your space is using the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   *Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).*
2. Choose **Themes** from the space administration options
3. Select a theme option.
4. Choose **Confirm**.

Configuring the Documentation Theme

The Documentation theme is one of the themes bundled with Confluence.

**Advance warning of plans to merge Documentation theme with the default theme**

This is an advance notice that we plan to merge the functionality of the Confluence Documentation theme with the Confluence default theme. We do not yet have a specific date for this plan, and we are interested in your feedback. The new default theme, introduced with Confluence 5.0, includes a sidebar with contextual navigation. Our plan is to include features from the Documentation theme in the default theme, and then remove the Documentation theme from Confluence.

If you are interested in this change and would like to give us feedback, please add a comment on this blog post: *Advance warning of plans to merge Documentation theme with the default theme*. We are especially interested to know which features of the Documentation theme you use and value the most.

The Documentation theme is designed for spaces containing technical documentation, but you may find it useful for other types of structured content. It provides a table of contents for your space, a configurable header and footer, and text styles suited to documentation. (See features below.)

**Quick guide to applying and customising the Documentation theme:**

- Go to the space and choose **Space tools > Look and Feel** on the sidebar.
- Choose **Themes**.
- Select **Documentation Theme** and choose **Confirm**.
- If you want to customise the theme, choose **Configure theme**.
  - Select or deselect the default page tree.
  - Select or deselect the space-restricted search.
  - Enter the text and wiki markup for your custom left-hand panel header and footer.
  - Choose **Save**.

The rest of this page gives more details of the above procedure.

**On this page:**
- Applying the Documentation theme to your space
- Applying the Documentation theme to your site
- Customising the Documentation theme
  - Customising the theme at site level
- Features of the Documentation theme
- Hints and tips
- Notes

**Related pages:**
- Using the Documentation Theme
- Space Jump Macro
- Applying a Theme to a Space
- Applying a Theme to a Site
- Editing a Space's Colour Scheme
- Customising the Look and Feel of a Confluence Space
- Confluence User's Guide

**Screenshot: The Documentation theme showing the space sidebar replaced by a navigation sidebar.**

---

**Applying the Documentation theme to your space**

Follow the steps below to apply the Documentation theme to your space. All pages in the space will start using the theme immediately.

**To apply a theme to a space:**

1. Go to the space and choose **Space tools > Look and Feel** on the sidebar.
   You'll need **Space Admin permissions** to do this.
2. Choose **Themes** and select a theme option.
3. Choose **Confirm**.

**Screenshot: Applying a theme**
If your space is using the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   - **Note:** The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the **confluence-administrators** group).
2. Choose **Themes** from the space administration options.
3. Select a theme option.
4. Choose **Confirm**.

---

### Applying the Documentation theme to your site

If you have **site administrator** permissions, you can apply the theme at site level. It will then be the default theme for all spaces in the site. See the administrator's guide to [applying a theme](#).

---

### Customising the Documentation theme

The theme works well without any customisation. If necessary, you can restrict the search to just one space, change the content of the left-hand navigation panel and add your own header and footer. The following instructions assume you have already applied the Documentation theme.

#### To customise the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   - **Note:** The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the **confluence-administrators** group).
2. Choose **Themes** in the left-hand panel under the heading 'Look and Feel'.
3. Choose **Configure theme** in the yellow area of the 'Current Theme' section at the top of the page. See screenshot below. The 'Documentation Theme Configuration' screen appears. See screenshot below.
4. Select or deselect the **Page Tree** check box. This determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.
5. Select or deselect the **Limit search results to the current space** check box.
If you select the check box:

- The Confluence search will look for matches only in the current space by default. Users can override this restriction when entering their search term. See Using the Documentation Theme.
- The default page tree in the left-hand panel will not include a search box.

If you do not select the check box:

- The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
- The default page tree in the left-hand panel will include a search box, which restricts search results to the current space.

6. Enter text, images, macros and other wiki markup into any or all of the three text boxes.

   You can use the Include or Excerpt Include to include re-usable content into your footer. See hint below.

   - 'Navigation' – This text box contains content for the left-hand panel.
     - If the Page Tree check box is selected, the navigation panel contains the default search box and page tree. Any content you enter into the 'Navigation' text box will appear above the page tree and search box.
     - You can include your own content underneath the page tree as well as above. See hint below. In summary: Deselect the Page Tree check box. Insert your own page tree using the Page Tree macro, then add your own content under the macro.
   - 'Header' – This text box contains content for a page header that will appear above the page title on all pages in the space. See example screenshot below.
   - 'Footer' – This text box contains content for a page footer that will appear after the comments and above the site footer, on all pages in the space. See example screenshot below.

7. Choose Save.

**Screenshot: The 'Configure theme' option**

Current Theme

The current theme controls the layout and colours of this space.

**Documentation Theme**

This theme is well suited for structured content, such as documentation. It features a table of contents (page tree) on the left, making it easier to see the structure of a space and move from page to page. You can customise the left-hand panel, page header and page footer.

**Configure theme** - further customise this theme's options

Choose New Theme

To change the theme of this space, select one below.

- **Global Look and Feel**
  
  The globally configured look and feel. You can customise colour-schemes and layouts manually.

**Find more themes...**

**Confirm**
Screenshot: Customising the Documentation theme

**Navigation**

- **Page Tree**: Show the page tree in the sidebar.
- **Limit search results to the current space**: Limit search results returned by the top right search field to the current space.

```markdown
- [Latest Confluence Documentation]
- [Confluence Documentation Home]
- [pagetree:root=Confluence Documentation Home|searchBox=false]
- [Downloads (PDF, HTML &...]
```

Add your own links and content to the sidebar using wiki markup.

**Messages**

**Header**

```markdown
{section}
{column:width=1%}{column}
{column}{panel}
[*include:_MajorReleaseNumber]
Confluence[nopanel=true]"
-- This documentation is for "Confluence 5.0" developer (EAP) releases only. Not for you? [See...]
```

Display a banner or text at the top of every page in this space by entering wiki markup here.

**Footer**

```markdown
*include:_Documentation
Footer[nopanel=true]
*include:ALLDOC:_Copyright
Notice[nopanel=true]
```

Display a banner or text at the bottom of every page in this space by entering wiki markup here.

**Customising the theme at site level**
If you have site administrator permissions, you can apply and customise the theme at site level. The customisation options are the same as the space level options, as described above.

**Features of the Documentation theme**

**Screenshot: A customised header, footer and left-hand panel**

The above screenshot shows a wiki space with a customised left-hand panel, header and footer.

Here is a summary of the features that the Documentation theme provides:

- By default, the left-hand panel contains a search box and a table of contents (page tree) showing all the pages in your space. Specifically, it shows the pages that are children of the space's home page.
- The left-hand panel is fully customisable. You can choose to include or exclude the search box and page tree. You can enter your own text, images and wiki markup.
- People viewing the page can drag the thick bar between the left-hand panel and the content, to increase or decrease the width of the panel. They can also remove the panel altogether, by clicking the sidebar icon at top right, next to the search box.
- The left-hand and right-hand panels scroll independently of each other.
- The page title is neatly above the page content, and not uncomfortably above the navigation panel as tends to happen when you insert the navigation panel yourself.
- Because the left-hand panel is part of the theme, it will be upgraded whenever Confluence is upgraded. There is no need to remove and then re-apply your customisations on each upgrade, as you would do if you added your own left-hand navigation bar.
- The theme also provides a customisable header and footer, which will appear at the top and bottom of every page.
- The text and heading styles are designed to enhance the content typically found in a documentation space.
- You can use the Space Jump macro to link from a page in one wiki space to a page with the same name in another space, without knowing the name of the page when you create the link.
You can limit the Confluence search results to the current space. If you choose this option, the Confluence search will look for matches only in the current space by default. Users can override the restriction. See Using the Documentation Theme.

Hints and tips

Below are some hints that you may find useful when using the Documentation theme. Where can I see a working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme’s table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page. Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

Cause 1: Your pages are not under the space’s home page. The most probable reason why your pages do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space’s home page. If your pages are above the home page in the page tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

• You can change the designated space home page in the space administration section.
• Or you can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the ‘Pages’ section of the space ‘Browse’ screen. See Moving a Page.

Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with Documentation theme bundled. If your existing Confluence installation already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar icon at top right, next to the search box. Click the icon again to restore the panel.

Can I change the default width of the left-hand navigation panel?

The Confluence user interface does not offer a way to change the default width of the left-hand navigation panel supplied by the Documentation theme. Users can change the width by dragging the middle bar, but the default width is not configurable. This post on Atlassian Answers gives a way to do it with CSS: Documentation Theme - Default Width (in px) of left panel.

Hiding pages from the left-hand table of contents

You can ‘hide’ pages by putting them at the same level as or higher than the space home page.

Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page.

If your documentation pages are at the same level as the space home page, they will not appear in the left-hand navigation bar. So you can ‘hide’ pages by putting them at the same level as or higher than the space home page. The pages will show up in the search results and people can see the content if they open the page, but the pages will not appear in the left-hand panel.

More detail: The theme uses the Pagetree macro to produce the table of contents. When entering the Pagetree macro, you can choose the top page in the page tree. The Documentation theme chooses the space home page.
Using reusable content in your header, footer or sidebar

You can use any text or wiki markup in your theme header, footer or left-hand panel. One useful hint is to use the Include or Excerpt Include to include re-usable content into your footer.

The screenshot above shows the theme customisation options, with examples of the macros used to include content from other pages. And the example screenshot also above shows the resulting header, footer and left-hand panel.

Adding content below the page tree in your sidebar

If you want to include your own content underneath the page tree, you can deselect the 'Page Tree' check box, add your own page tree using the Pagetree macro in the 'Navigation' text box, and then add your own content under the macro.

The screenshot above shows the theme customisation options, with the default page tree deselected and a custom page tree inserted, along with additional content in the left-hand panel. The example screenshot also above shows the resulting left-hand panel.

Adding an expanding All Versions section to the sidebar

If you want to include a an expanding list of links to other spaces, as we have included in this space (see 'Docs for all Confluence releases' in the sidebar), you can use an Expand Macro and an Include Page Macro in the 'Navigation' text box. For example:

```markdown
*{Docs for all Confluence releases|_Latest Versions of Confluence Documentation}*  
{expand:Choose a version...}  
{include:_Latest Versions of Confluence Documentation}  
{expand}
```

If you would like this to display below the page tree, follow the steps above.

Adding underlines to your links

By default, the Documentation theme does not underline hyperlinks. If you prefer to have your links underlined, you can edit the CSS stylesheet for your space and add the following CSS code:

```css
.wiki-content a:link, .wiki-content a:visited, .wiki-content a:active {  
  text-decoration: underline;
}
```

To edit a space's CSS style sheets:

1. Go to the space and choose Space tools > Look and Feel on the sidebar.
2. Choose Stylesheet then Edit.
3. Paste your custom CSS into the text field.
4. Save your changes. The new CSS will be visible on all content pages in the space.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.  
   **Note:** The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Click Stylesheet in the left-hand panel under the heading 'Look and Feel'.
3. Choose Edit.
4. Paste your custom CSS into the text field.
5. Save your changes. The new CSS will be visible on all content pages in the space.

Notes:

- You need system administrator permissions to edit the CSS for a space or for the site.
- This function is turned off by default. To turn it on, go to Confluence Admin > Security Configuration a
Jumping to the same page in another space

The {spacejump} macro is provided along with the Documentation theme. You can use space jumping to link from a page in one wiki space to a page with the same name in another space, without knowing the name of the page when you create the link. When a reader is viewing a page and chooses the link provided by the macro, they will go to a page with the same name, but in the space specified in the macro. See more about the Space Jump macro.

Hiding the left-hand panel completely

It's not possible to remove the left-hand panel entirely, using the user interface supplied by the theme. There is an improvement request here:

- [CONF-25923 - Provide option to hide the left-hand panel entirely in the Documentation theme](https://confluence.atlassian.com/display/CONF-25923/Provide+option+to+hide+the+left-hand+panel+entirely+in+the+Documentation+theme) (Resolved)

If you like, you can comment on and/or vote for that request. In the meantime, Atlassian Answers is a good place to ask the question and see if other people can help you with custom code to remove the panel.

Notes

- The Confluence default theme supplies a sidebar, which is different to the left-hand panel in the Documentation theme. For information about the sidebar, see Finding Content and Configuring a Sidebar.
- The Documentation theme supplies a Browse menu in the Confluence header, which gives access to the space administration and advanced options.

Configuring a Sidebar

The default theme and documentation theme in Confluence both feature a left sidebar.

This page outlines how to customise the sidebar in the default theme. To find out how to customise the sidebar in the Documentation theme, see Configuring the Documentation Theme.

You need space administrator permissions to configure the sidebar. See Space Permissions. Any changes you make to the sidebar will be visible to all Confluence users viewing that space.

To configure a space's sidebar:

1. Go to the space and choose Space tools > Configure sidebar on the sidebar.
2. Change the space name and/or space logo:
   - Choose the edit icon next to the space name.
   - Type in a space Name.
   - Browse to find an image for the space Logo, and crop the image to the required size.
   - Choose Save.
3. Configure the Pages and Blog links:
   - Choose the icons to hide or show the ‘Pages’ or ‘Blog’ link. For example, you may want your space to be used primarily as a blog (hide the ‘Pages’ link) or you may not need a blog in your space (hide the ‘Blog’ link).
   - Drag the links to a different sequence within the section. Note that you cannot move a link from one section to another.
   - Note that add-ons may add other links in this section of the sidebar. For example, the Team Calendars add-on may put a link in this location.
4. Add or remove the shortcut links:
   - Choose Add link to add a shortcut link to the sidebar. This can be a link to an important page for your team, or to an external site, for example.
   - Choose the icon to remove a shortcut link.
   - Drag the links to a different sequence within the section. Note that you cannot move a link from one section to another.
   - Choose the hide or show icon beside the ‘Space Shortcuts’ heading to show or hide all shortcuts on the sidebar.
5. Change the navigation display options:
   - Choose Child pages to see the current page and its children in the sidebar.
   - Choose Page tree to see the page tree for the entire space, expanded to the current page.
Notes

The default theme and Documentation theme both feature a sidebar. If you are using a third party theme it may not feature a sidebar.

Changing a Space's Logo

In Confluence, you can replace the default logo for a space with an image of your choice. The instructions below apply to site spaces. For your personal space, your profile picture is used as the space icon.

You need to be a space administrator to replace a space's logo.

To change a space's logo, in spaces using the default theme:

1. Go to the space and choose Space tools > Configure sidebar on the sidebar.
2. Choose the edit icon next to the space name.
3. Choose Choose File.
4. Browse to find and upload an image.
5. Adjust the size of the highlighted circle on the image, to crop the image to the required size.
6. Choose Save.

To change a space's logo, in spaces using the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Change Space Logo in the left-hand panel.
3. Use the browse option to locate the new logo and choose Upload.
1. Related pages:
   - Configuring a Sidebar
   - Customising the Look and Feel of a Confluence Space
   - Confluence User's Guide

2. Screenshot: Changing a space logo in the default theme

3. Notes
   - **Dimensions of image when using the Documentation theme**: A space logo in the Documentation theme looks best if the height and width of the image are of the same or similar length. In other words, the area occupied by the image, including white space, should be square rather than rectangular.
   - **Minimum dimensions**: Space logos are set at 48 x 48px. Logos less than these dimensions will be centred with whitespace around them.
   - **Space logos in the default theme are circular.**

4. Changing the Confluence Browser Icon, aka favicon

   The Confluence logo 🚀 is displayed in the user’s browser to identify the Confluence browser tab. To use a custom image for your Confluence site:

   1. Obtain or create an image in ICO file format. To maximise browser compatibility, it should be 32x32 pixels in size, 71x71 DPI (dots per inch) and have an 8 bit colour depth.
   2. Inside the root of your Confluence installation directory, find the `confluence` subdirectory.
   3. Back up the file `favicon.ico`.
   4. Replace the `favicon.ico` file with your custom ICO image.
   5. Restart your application server.

   ![The information on this page does not apply to Confluence OnDemand.](image)

   Users may need to clear their browser cache before they will see the new image. This can be done by pressing ctrl+refresh in the browser when a page in Confluence is open.
Customising the Look and Feel of a Confluence Space

You can modify Confluence's look and feel by editing the layout files. This page tells you how to customise the layout files for a space. You will require need space administrator permissions for that space.

Confluence system administrators can also customise the layout of their entire Confluence site as a whole. For more information, please refer to Customising Site and Space Layouts. Site layout customisations modify the default layout of all spaces in the Confluence site.

Any space layout customisations will override the equivalent site customisations.

Confluence is built on top of the Open Source SiteMesh library, a web-page layout system that provides a consistent look and feel across a site. SiteMesh works through 'decorators' that define a page's layout and structure.

To edit the layout of Confluence, you will need to modify these decorator files. A decorator file is a .vmd file and is written in a very simple programming language called Velocity. Learn more about Velocity. Once you become familiar with Velocity, you can edit the decorator files to personalise the appearance of Confluence.

The decorator files in Confluence are grouped into the following categories:

- **Site layouts**: These are used to define the controls that surround each page in the site. For example, if you want to make changes to the header and the footer, you will need to modify these layouts.
- **Content layouts**: These control the appearance of content such as pages and blog posts. They do not change the way the pages themselves are displayed, but they allow you to alter the way the surrounding comments or attachments are shown.
- **Export layouts**: These control the appearance of spaces and pages when they are exported to HTML. If you are using Confluence to generate a static website, for example, you will need to modify these layouts.

Learn more about using decorators.

To edit a decorator file:

1. Go to the space and choose Space tools > Look and Feel on the sidebar.
2. Choose Layout (Layout is displayed only if you are a Confluence system administrator.)
3. You will see a list of the layouts for the space.
   - Click View Default to view the vmd file.
   - Click Create Custom to edit the default vmd file. This will open up the vmd file in edit mode. Make changes and click Update.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.

Converting a PNG to an icon

To create an ICO out of a PNG image, you can use the freeware tool png2ico or the the online tool at http://converticon.com/.
Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).

2. Choose Layout in the left-hand panel (Layout is displayed only if you are a Confluence system administrator.)

3. You will see a list of the layouts for the space.
   - Click View Default to view the vmd file.
   - Click Create Custom to edit the default vmd file. This will open up the vmd file in edit mode. Make changes and click Update.

Screenshot: Edit Layouts Example

Click the thumbnail to see an example of a vmd file:

Editing a Space’s Colour Scheme

Confluence allows you to customise the colour scheme of a space. By default, a space’s colour scheme is based on global settings configured from the Administration Console.

You need to be a space administrator to edit a space’s colour scheme.

Related pages:
- Customising the Look and Feel of a Confluence Space
- Confluence User’s Guide

To change the colour scheme for a space:

1. Go to the space and choose Space tools > Look and Feel on the sidebar.
2. Choose Colour Scheme.
3. Choose Select next to a scheme listed under Custom Colour Scheme (if not already selected).
4. Choose Edit.
5. Enter standard HTML/CSS2 colour codes, or use the colour-picker  to choose a new colour from the palette provided. Any changes you make will immediately be reflected in this space.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   
   Note: The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Colour Scheme under the heading Look and Feel.
3. Follow the steps above to select a custom colour scheme and edit the colours.

The colour scheme allows you to edit the colours of UI elements including the top bar, tabs and backgrounds.

Some UI elements below are for specific themes, and colour changes may not take effect for other themes.

- **Top Bar** - the top navigation bar background
- **Top Bar Text** - the text on the top navigation bar
- **Header Button Background** - buttons on the top navigation bar (e.g. Create button)
- **Header Button Text** - the text on buttons on the top navigation bar
- **Top Bar Menu Selected Background** - background colour of top navigation bar menu items when selected (e.g. spaces)
- **Top Bar Menu Selected Text** - text colour of top navigation bar menu items when selected
- **Top Bar Menu Item Text** - text on top navigation bar drop down menus (e.g. help or cog)
- **Menu Item Selected Background** - highlight colour on top navigation bar drop down menu items
- **Menu Item Selected Text** - text colour on highlighted top navigation bar drop down menu items
- **Page Menu Selected Background** - the background colour of the drop down page menu when selected
- **Page Menu Item Text** - the text of the menu items in the drop down page menu
- **Heading Text** - all heading tags throughout the space
- **Space Name Text** - the text of the current space name located above the page title
- **Links** - all links throughout the space
- **Borders and Dividers** - table borders and dividing lines
- **Tab Navigation Background** - the background colour of the tab navigation
- **Tab Navigation Text** - the text of the tab navigation when highlighted
- **Tab Navigation Background Highlight** - the background colour of the tab navigation when highlighted
- **Tab Navigation Text Highlight** - the text of the tab navigation elements when highlighted

Screenshot: Editing the colour scheme
Handy Hint
If you mess things up, just choose Reset then try again.

Styling Confluence with CSS
The information on this page does not apply to Confluence OnDemand.

Introduction

Cascading Style Sheets (CSS) are an industry-standard way of styling a web page. The content of a page is rendered with HTML, and its look and feel is determined by CSS files. You can upload a CSS text file, or simply type in a stylesheet, and apply it to a space or even a whole Confluence site.

Notes:

- You need system administrator permissions to edit the CSS for a space or for the site.
- This function is turned off by default. To turn it on, go to Confluence Admin > Security Configuration and choose Custom Stylesheets for Spaces.

Creating CSS styles that work seamlessly across different browsers is a delicate task for basic web sites, and reasonably challenging when customising web applications like Confluence. It is important to test each change that you make and ensure it works as expected in all areas of Confluence – for example, on the Confluence dashboard as well as on regular pages.

In order to get you started, we have compiled this introduction, a basic styling tutorial.

Considerations for Using Custom CSS

CSS Knowledge is Required

If you are not familiar with CSS, see the links in the CSS Resources section below. You should spend some time to become confident with Cascading Style Sheets before you start editing your Confluence style sheets.

Security

Custom CSS can be used to inject scripts into a page, opening the risk of cross-site scripting (XSS) attacks. With this feature enabled, space administrators could upload styles that steal other users’ login credentials, trick their browsers into performing actions on the wiki without their knowledge, or even obtain global administration privileges. As such, this feature is disabled by default. Confluence administrators should only enable custom CSS if they are comfortable with the risks listed in this paragraph.

Scaling

Each page needs to scale. Depending on the resolution of the user's screen, the content should render intelligently. Your designs needs to degrade gracefully. Try resizing each page that exists in Confluence. There are quite a few pages in the browse-space-section, like drafts, labels, page hierarchy, and so on. Your style has to work everywhere, not just in the first page you happen to be looking at.

Features Cannot Be Disabled

It is easy to turn off certain links, headers, or even menu items by simply setting their style to 'hidden'. This can help you to roll out Confluence to users that may not be very Wiki-savvy yet. The simpler the UI, the easier it
may be for them to use. However, please remember that removing the link to a part of the application does not mean that the functionality is not available. Every user can still change their style from within their browsers, or access the URL directly. Don't rely on CSS to disable parts of Confluence.

**Features Should Not Be Disabled**

Users familiar with Confluence will expect to find the same controls that they are accustomed to. Removing buttons or controls from the interface is not advised as it may frustrate your users and cause them to circumvent your design by using direct URL access, as mentioned above.

**Custom CSS does not apply to Admin screens**

Any CSS styling applied to your site will not be applied to the Administration console. This is to ensure changes to CSS do not prevent administrators from accessing Admin functions in future.

**Confluence Version Compatibility**

Be aware of any plans to upgrade your Confluence instance. Future versions of Confluence may not be compatible with your custom CSS — this may cause your CSS to break, requiring maintenance when Confluence is upgraded. Ask your Confluence administrator for more information.

**Test on Different Web Browsers**

As a rule you should test your modifications on different web browsers. Internet Explorer, Firefox, Opera and Safari (on Mac OS X) are some of the more popular browsers.

**Note about supported web browsers:** Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. Check the [Supported Platforms](https://confluence.atlassian.com()) page to find the list of supported web browsers and browser versions on this page.

**CSS Customisation is Not Supported**

As creating custom CSS has potentially limitless possibilities, Atlassian will not support issues that are caused by or related to CSS customisation.

**Getting Started**

**Editing the CSS**

**To edit a space's CSS style sheets:**

1. Go to the space and choose **Space tools > Look and Feel** on the sidebar.
2. Choose **Stylesheet** then **Edit**.
3. Paste your custom CSS into the text field.
4. Save your changes. The new CSS will be visible on all content pages in the space.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Click **Stylesheet** in the left-hand panel under the heading 'Look and Feel'.
3. Choose **Edit**.
4. Paste your custom CSS into the text field.
5. Save your changes. The new CSS will be visible on all content pages in the space.

**To edit your global CSS stylesheet:**

1. Choose the cog icon at top right of the screen, then choose **Confluence Admin**.
2. Choose **Stylesheet**.
3. Choose **Edit**.
4. Paste your custom CSS into the text field.
5. Choose **Save**.

**Note:**
The new CSS will be visible across all spaces, provided they do not define their own custom stylesheet and are not using a theme. This CSS will also overwrite all styles defined in custom global themes.

You may be able to add CSS to your site by choosing Custom HTML in the administration section, and adding your CSS definitions to the HEAD or BODY of the page. You should only use this option if you cannot achieve the desired results via the global stylesheet.

Follow the Tutorial

Follow the examples in the Basic Styling Tutorial to get started.

CSS Resources

- W3C CSS Standards
- W3schools CSS Introduction
- Mozilla Developer Network
- W3resource.com

Basic Styling Tutorial

This page contains instructions on how to get started with custom CSS styling in Confluence.

CSS Editing Quick-Start

To edit a space's CSS style sheets:

1. Go to the space and choose Space tools > Look and Feel on the sidebar.
2. Choose Stylesheet then Edit.
3. Paste your custom CSS into the text field.
4. Save your changes. The new CSS will be visible on all content pages in the space.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Click Stylesheet in the left-hand panel under the heading 'Look and Feel'.
3. Choose Edit.
4. Paste your custom CSS into the text field.
5. Save your changes. The new CSS will be visible on all content pages in the space.

On this page:

- CSS Editing Quick-Start
- Tutorial: Changing the Header Background
- CSS Editing Tips
- Notes

Related pages:

- Styling Confluence with CSS
- Confluence User's Guide

⚠️ The information on this page does not apply to Confluence OnDemand.

Tutorial: Changing the Header Background

The header is the menu area at the top of a default Confluence page where the Breadcrumb Links, Browse menu, User menu and the Quick Search box reside. In this example, we are going to change the background of the header to include a custom graphic.

1. Create a custom graphic. For this example, we created a custom header graphic of 1046 x 61 pixels.
2. Upload the custom graphic to a page in the space that you are customising.
3. Note the page ID of the page where you uploaded the new graphic. (in this example, the page ID was ‘658833839’).
4. Compose your custom CSS for the header. The example below loads the new graphic (called 'header.png') from a specific page (denoted by page ID ‘658833839’) in the same space.
#header .aui-header {
    background-image:url('../download/attachments/658833839/header.png'
    );
    background-repeat: no-repeat;
}

5. Log in as the Space Administrator.
6. Open the Space Admin page.
7. Click Stylesheet.
8. Click Edit to change the code in the text field.
9. Paste your custom CSS into the text field.
10. Click Save and then reload the page (you may have to shift-reload). The background of the header will change.
11. The custom header will be visible on all content pages in the space. To revert your change, simple delete the custom code from the ‘Stylesheet’ page and click Save.

**CSS Editing Tips**

Begin With a Space Stylesheet

A space stylesheet is a good starting point for CSS customisation, as it already includes all of the elements that can be changed. When you work on the space stylesheet it styles all content pages in the space. Build and test it at space-level, before considering applying the new stylesheet to your entire site. Once you are satisfied with your space design, test it thoroughly until you are confident that it has no problems. Then, you can look into advanced customisation of the Confluence CSS such as adjusting the Search page, the Dashboard and other integral pages.

Use the Right Tools

As the Confluence CSS is reasonably sophisticated, web development applications will help you to understand how the page styles have been created. In particular, you will need to view the existing source for the pages you’re starting to work on. If you don't already have some, tools such as the following free applications will allow you to do this.

1. Firebug
   Firebug, a plugin for the Firefox web browser, allows you to take a look at the style of each element on your page. This is very useful to see what styles are currently applied, for example styles applied to the header only.

2. Web Developer
   The Web Developer plugin for Firefox allows you to edit CSS inline and create new page designs.

3. CSS Edit
   CSS Edit is a stand-alone CSS editor for Macintosh that extracts all existing styles from a given page and allows you to overwrite these.

   **Edit Simple Elements First**

   Begin by editing simple elements and checking that they work. By making changes, then checking that each one worked, you can easily isolate any CSS code that is causing problems. Be aware that some page elements are more suited to customisation than others. For example, adding a gradient to the toolbar is less likely to 'break' the page than changing the page width. Editing reasonably static elements such as background graphics will render more predictably than designs which attempt to completely change the user interface or the Javascript-powered drop-down menus (which we don’t recommend editing).

**Notes**

Notes:

- You need system administrator permissions to edit the CSS for a space or for the site.
- This function is turned off by default. To turn it on, go to Confluence Admin > Security Configuration and choose Custom Stylesheets for Spaces.

Styling Fonts in Confluence

Confluence provides the ability to adjust its visual style via Cascading Style Sheets (CSS). This tutorial shows
you to change the fonts and font sizes of a Confluence page, using a few lines of CSS.

Screenshot 1: Default font in a Confluence page

![Home](image1)

My name is Matt Ryall. I'm a developer on the Confluence team, and I started at Atlassian in January 2006.

I'm very interested in web development, specifically accessible and semantic site design. Wikis are actually one of the most interesting areas of web development, I believe, because they're a totally new form of content. Blogs came from the idea of personal journals; most static websites look like marketing brochures, but there's nothing comparable to a wiki in the physical world. On a wiki you can create an array of linked and searchable content, then anyone can improve on the words you've written, collaborating on whatever you want.

Below are some of the pages on this wiki where I've made a significant contribution:

- Character Encodings in Confluence (and the other Confluence Internals documents)
- Running Confluence behind Apache
- Understanding User Management in Confluence

Screenshot 2: Custom font in a Confluence page

![Home](image2)

My name is Matt Ryall. I'm a developer on the Confluence team, and I started at Atlassian in January 2006.

I'm very interested in web development, specifically accessible and semantic site design. Wikis are actually one of the most interesting areas of web development, I believe, because they're a totally new form of content. Blogs came from the idea of personal journals; most static websites look like marketing brochures, but there's nothing comparable to a wiki in the physical world. On a wiki you can create an array of linked and searchable content, then anyone can improve on the words you've written, collaborating on whatever you want.

Below are some of the pages on this wiki where I've made a significant contribution:

- Character Encodings in Confluence (and the other Confluence Internals documents)
- Running Confluence behind Apache
- Understanding User Management in Confluence

Below is the code for the custom font. Copy and paste it into the Space Stylesheet form within the Space Administration section.

```css
Related pages:
- Basic Styling Tutorial
- Confluence User's Guide

⚠️ The information on this page does not apply to Confluence OnDemand.

Changing the fonts

In order to customise the fonts in Confluence, you first need to set the body font to the font you want. Secondly, you may want to adjust the font size because different fonts have different relative sizes.

The relevant CSS is shown below. It changes Confluence's font from the default of Helvetica/Arial – *sans serif* to Times/Times New Roman – *serif*. To adjust for the fact that Times is a bit smaller than Helvetica, we increase the font size to 14 pixels. The many styles that 'wiki-content' in their definition are necessary to change the font size for all the tags in the wiki content.
Notes

Notes:
- You need system administrator permissions to edit the CSS for a space or for the site.
- This function is turned off by default. To turn it on, go to Confluence Admin > Security Configuration and choose Custom Stylesheets for Spaces.

Requesting Add-ons

The Atlassian Marketplace website offers hundreds of add-ons that the administrator of your Atlassian application can install to enhance and extend Confluence. If the add-on request feature is enabled for your Confluence instance, you can submit requests for add-ons from the Marketplace to your Confluence administrator.

The ‘Atlassian Marketplace for Confluence’ page provides an integrated view of the Atlassian Marketplace from within your Confluence instance. The page offers the same features as the Marketplace website, such as searching and category filtering, but tailors the browsing experience to Confluence.

This in-product view of the Marketplace gives day-to-day users of the Atlassian applications, not just administrators, an easy way to discover the add-ons that can help them work. When you find an add-on of interest, you can submit a request with just a few clicks.

Submitting an add-on request

To browse for add-ons in the Atlassian Marketplace, follow these steps:

1. Choose your profile picture at top right of the screen, then choose Atlassian Marketplace.
2. In the Atlassian Marketplace page, use the search box to find add-ons or use the category menus to browse or filter by add-ons by type, popularity, price or other criteria. You can see what your fellow users have requested by choosing the Most Requested filter.
3. When you find an add-on that interests you, click Request to generate a request for your administrator.
4. Optionally, type a personal message to your administrators in the text box. This message is visible to administrators in the details view for the add-on.
5. When ready, click **Submit Request**.
6. Click **Close** to dismiss the 'Success!' message dialog box.

At this point, a notification appears in the interface your administrators use to administer add-ons. Also your request message will appear in the add-on details view, visible from the administrator’s ‘Find New Add-ons’ page. From there, your administrator can purchase the add-on, try it out or dismiss requests.

**Updating an add-on request**

After submitting the request, you can update your message at any time. Click the **Update Request** button next to the listing in the Atlassian Marketplace page to modify the message to your administrator.

The administrator is not notified of the update. However, your updated message will appear as you have modified it in the details view for the add-on immediately.

**Giving People Access to Content**

Confluence gives you the choice to make the site as open or as closed as you wish. Here are some points to consider:

- As a tool for communication and collaboration, Confluence is at its best when all your users can participate fully.
- So it is advisable not to restrict users unless you have a good reason for doing so.
- Confluence keeps a history of all changes to pages and other content. So it is easy to see who has changed what, and to reverse any edits if required.

**Levels of permission**

There are three levels of permissions in Confluence.

**Global permissions**

- **Global permissions** are site-wide permissions, and are assigned by administrators:
  - **System Administrator** - Users with this permission can perform all the Confluence administrative functions. These users can assign permissions to other users.
  - **Confluence Administrator** - Users with this permission can perform most of the Confluence administrative functions, but excluding those functions which could compromise the security of the Confluence system. These users can assign permissions to other users.

For full details, please refer to the overview of global permissions in the Administrator’s Guide.

**Space permissions**

The permission to create a new space or to administer one is granted by a **Confluence Administrator** from the
global Administration Console.

Every space has its own independent set of permissions. These permissions determine the access settings for different users of the space. In order to assign these permissions to other users, a user must be a space administrator i.e. must have the 'Admin' permission for that space.

See Users and Groups to learn how these permissions are assigned.

Note: If you misconfigure a space so that nobody has access to administer it any more, a Confluence Administrator will need to fix the permissions for you.

Page restrictions

You can set page-level restrictions, if you have the 'Restrict Pages' permission within the space concerned.

Page restrictions allow you to control who can view or edit individual pages. To set page restrictions, edit the page and use the page restriction options below the text-entry box.

On this page:

- Levels of permission
  - Global permissions
  - Space permissions
  - Page restrictions
- More information
  - How do space permissions and page restrictions work together?
  - How do space permissions and page restrictions affect links?

Related pages:

- Users and Groups
- Global Permissions Overview
- Space Permissions Overview
- Page Restrictions
- Configuring Confluence Security
- Confluence User’s Guide
- Confluence Security Overview and Advisories

More information

How do space permissions and page restrictions work together?

Example: In the HR (Human Resources) space, everyone in the organisation has the 'View' space permission, but only the HR team has the 'Pages --> Create' space permission (i.e. the ability to create and edit pages in the space). A member of the HR team starts to create a new page called 'Annual Leave Policy'. Because the page is not yet finished, she sets the 'Viewing' page restriction so that only the HR team can view the page. When the page is finished, she will remove the 'Viewing' restriction so that everyone in the company can see the page.

How do space permissions and page restrictions affect links?

Space permissions and page restrictions affect how links between pages are displayed to a visitor:

- if the link points to a page in a space to which the visitor does not have 'View' space permission, the link will not be rendered at all.
- if the visitor has 'View' space permission, but page restrictions prohibit her from viewing the page, the link will be rendered but an 'Access Denied' message will be displayed when she clicks the link.
- if the visitor has 'View' space permission, and is not restricted from viewing the page, the link will display and behave as normal.

Links to attachments are also affected: If the visitor does not have permission to view the page to which the attachment is attached, the link will not be rendered.

Page Restrictions

Page restrictions allow you to control who can view or edit individual pages in a space.
To add or remove restrictions to a page you will need to have permissions to edit the page and 'Restrict' or 'Admin' permission in the space.

About page restrictions and space permissions

Confluence permissions are hierarchical, so page restrictions will not override any space permissions for the user or group.

For example, if you restrict viewing or editing a page to a user who does not have 'view' permissions for the space, they will not be able to see the page, as the page level restrictions cannot override their space permissions.

Some page restrictions are inherited. If you restrict viewing a page to a user or group, all children of that page will also be restricted to the user or group. Edit page restrictions are not inherited.

Adding restrictions to a page

You can restrict viewing a page or editing a page to a specific user or group.

To restrict viewing or editing a page to a user or group:

1. Go to the page and choose Tools > Restrictions.
2. Choose Restrict viewing of this page or Restrict editing of this page.
3. Enter part of user or group name, and then choose the appropriate user or group from the autocomplete drop down. You can add multiple users and groups.

The page restrictions have now been applied:

- Viewing the page is now restricted to the users and / or groups listed. All other users will not be able to view the page. Any children of this page will inherit the viewing restrictions.
- Editing the page is now restricted to the users and / or groups listed. All other users will be able to view, but not edit, the page.

On this page:

- About page restrictions and space permissions
- Adding restrictions to a page
- Viewing the current page restrictions
- Removing restrictions from a page
- Request and grant access to view a restricted page
- Viewing all restricted pages in a space
- Notes

Related pages:

- Working with Pages
- Confluence User's Guide.

Viewing the current page restrictions

Confluence displays a padlock icon on the byline when a page has current viewing or editing restrictions.

Screenshot: Byline showing page restrictions icon.

To view the restrictions:
1. Go to the page and:
   - choose Tools > Restrictions, or
   - choose the padlock icon on the byline, or
   - choose the Restricted button on the footer, if you are in the editor.

2. The Page Restrictions dialog appears, listing the users and / or groups that have restrictions applied.

   Screenshot: Page Restrictions dialog showing viewing restricted to the 'developers' group and editing restricted to two users.

Removing restrictions from a page

To remove restrictions from a page:

1. Go to the page and:
   - choose Tools > Restrictions, or
   - choose the padlock icon on the byline, or
   - choose the Restricted button on the footer, if you are in the editor.

2. Choose Remove next to each restriction you would like to remove.

Request and grant access to view a restricted page

If you navigate to a page that you are not able to view because it has page restrictions applied (for example from a link or page URL) you may be able to request access to the page.

To request access to a restricted page:

1. On the restricted page choose Request access.
2. Wait for an email confirming that access has been granted.

If the request access message does not appear, you are not able to request access for that particular page. This usually is because the page has inherited restrictions from a parent page, or you may not have adequate space permissions.

   Screenshot: Request access message on a restricted page.

To grant access to a restricted page:
1. In the request access email, choose **Grant access**.
2. You will be taken to the restricted page, a banner will appear with the access request.
3. Choose **Confirm** on the banner.

The user will receive an email confirming that access has been granted.

This process is the same as navigating to **Tools > Restrictions** and adding a 'View' restriction for the user.

*Screenshot: Confirm access request.*

### Who can grant access?

To grant access to a restricted page you will need to have permission to edit that page, and have the 'Restrict' or 'Admin' permission for the space.

Confluence will send an email to the user who can grant permissions - this will be either the last user (with appropriate permissions) to edit the page, the page creator or a space admin.

### Viewing all restricted pages in a space

You need 'Admin' permissions to view the list of restricted pages in a space.

**To view restricted pages:**

1. Go to the space and choose **Space tools > Permissions** on the sidebar.
2. Choose **Restricted Pages**.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   
   *Note:* The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the *confluence-administrators* group).
2. Choose **Restricted Pages** in the space administration options.

A list of all restricted pages in the space displays.

### Space Administrators can remove restrictions from a page

*Screenshot: Restricted pages in a space*

<table>
<thead>
<tr>
<th>Permissions</th>
<th>Restricted Pages</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Title (Space)</th>
<th>Type</th>
<th>Permitted User/Group</th>
<th>Creator</th>
<th>Created</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Induction plan - Sophie User (Stars)</td>
<td>Edit</td>
<td>leah</td>
<td>Leah Admin</td>
<td>Feb 18, 2013</td>
<td></td>
</tr>
<tr>
<td>Induction plan - Ewan User (Stars)</td>
<td>Edit</td>
<td>leah</td>
<td>Leah Admin</td>
<td>Feb 18, 2013</td>
<td></td>
</tr>
<tr>
<td>Draft status report (Stars)</td>
<td>View</td>
<td>admin</td>
<td>Rach Admin</td>
<td>Feb 18, 2013</td>
<td></td>
</tr>
<tr>
<td>Draft status report (Stars)</td>
<td>View</td>
<td>sophie</td>
<td>Rach Admin</td>
<td>Feb 18, 2013</td>
<td></td>
</tr>
</tbody>
</table>

**Notes**
• **Inherited restrictions**
  If a page has a 'View' restriction set, that restriction will be inherited by all its children (and their children, and so on). If a 'View' restriction is added to a child page that has already inherited page restrictions from its parent, users must satisfy both restrictions in order to see the page.

• **Space Admin and Confluence Administrator access to restricted pages**
  Users with 'Admin' permissions in a space, or members of the 'confluence-administrators' group can remove restrictions from pages, even if the page restriction prevents them from viewing the page. Go to Space Administration > Restricted Pages.

• **You cannot exclude yourself**
  As creator or editor of a page, you cannot use page restrictions to deny yourself access to the page. Confluence will automatically add your username into the list of users/groups allowed to view/edit the page. If you remove your username, Confluence will put it back again.

### Site Administrators and their Permissions

All site administrative functions are performed from the Administration Console. You need 'System Administrator' or 'Confluence Administrator' permissions to access the Administration Console.

The Confluence permission scheme allows the following levels of site administrator permissions:

- **Super user** – A 'super user' belongs to the `confluence-administrators` group, has full administrative access to Confluence, and can see all the content.
- **System Administrator** – A person with 'System Administrator' permission has full administrative access to Confluence.
- **Confluence Administrator** – A person with 'Confluence Administrator' permission has access to most of the Confluence administrative functions.

Please refer to the overview of global permissions for full details.

**Related Topics**

- Users and Groups
- Confluence User's Guide

### Contacting Confluence Administrators

If you receive an error message from Confluence, the error page may offer you a link to click in order to contact the administrators of the Confluence site.

When you click the link to contact the Confluence administrators, you will see an administrator contact page with the title 'Contact Site Administrators'. By default, the administrator contact page looks like the screenshot below.

**Related pages:**

- Configuring the Administrator Contact Page

**Screenshot:** The administrator contact screen
The screen may look different

In certain configurations of Confluence, you will not be able to use the form shown in the screenshot above. Instead, you will see a message telling you about one of the following conditions:

- If your Confluence administrator has not configured a mail server for Confluence, this means that Confluence will not be able to send an email message to the administrators.
- If none of the Confluence administrators has an email address, Confluence will not be able to send an email message to them.
- If there are no Confluence administrators defined to Confluence, Confluence will not be able to send an email message to them.
- The Confluence administrator can disable the form and specify a different message to be displayed on the above screen instead of the default message and form. See the administrator's guide.

Notes

You can also access this contact form using the following URL. Replace 'yoursite.com/wiki' with the correct path for your Confluence instance.

```
yoursite.com/wiki/contactadministrators.action
```

Space Administrators and their Permissions
A space administrator is a user with the ‘Space Admin’ permission for a space. This permission itself is assigned from the Space Administration screens by a space administrator.

Who is a space administrator?

The person who creates a space is automatically the administrator of that space. That person can then assign other space administrators as required.

To find the space administrator for a specific space:

1. Choose Spaces > Space directory on the header.
2. Choose the Space Details icon beside a space.
3. The space administrators are listed.

On this page:
- Who is a space administrator?
- What can a space administrator do?

Related pages:
- Space Permissions Overview
- Confluence User’s Guide

Confluence administrators are not necessarily space administrators.
- A user who has the 'Administer Confluence' permission is not automatically a space administrator for a particular space. In order for them to be a space administrator, they must belong to a group which has space administration rights on the space, or their username must be specifically granted space administration rights on the space.
- Users who are members of the 'confluence-administrators' group do automatically have space administration permissions for all spaces.

Refer to the Administrator's Guide for more details about Confluence administrator permissions.

What can a space administrator do?

A space administrator has permission to do anything in the space regardless of any other setting. Space administrators are responsible for the management of a space and its contents. Note that page permissions affect space administrators differently from other users.

Space administrators can:
- view all content in the space. If there are page permissions that restrict the viewing of a page to a single user, or to a group to which the space administrator doesn't belong, a space administrator can still view the page by removing the restriction.
- edit all content on any page in the space.
- remove restrictions from any page in the space (using the Space Administration interface).
- manage the watchers for any page in the space (but not watchers of the space).
- grant themselves any other space permissions (e.g. permission to set restrictions on a particular page).

All space administration functions, with the exception of managing watchers, are performed from the Space Tools menu (choose Browse > Space Admin in the Documentation theme). You need to be a space administrator to access the Space Administration screens.

Space Permissions Overview

Every space has its own independent set of permissions. Space permissions can only be granted by a space administrator.

Permissions can be assigned to any group, to any individual user in the 'confluence-user’ or ‘user’ group, and to users in the ‘anonymous’ group.

These are the permissions that can be assigned at the space level:
- View: user can view this space's content, including the space's details, and its pages and news items (blog posts)
- Pages:
  - Add – user may create and edit pages in this space.
- Restrict – user may apply page-level restrictions.
- Delete – user may delete pages in this space.

**Blog:**
- Add – user may add and edit blog posts in this space.
- Delete – user may delete blog posts in this space.

**Comments:**
- Add – user may make comments in this space.
- Delete – user may delete comments from this space.

**Attachments:**
- Add – user may add attachments in this space.
- Delete – user may delete attachments from this space.

**Mail:**
- Delete – user may delete individual mail items.

**Space:**
- Export – user may export content from this space via the space-level export screens. Note that this permission does not affect the exporting of a single page's content. Anyone who has permission to view the page also has permission to export its content.
- Admin – user has administrative permissions over this space.

**Related pages:**
- Space Administrators and their Permissions
- Users and Groups
- Assigning Space Permissions
- Page Restrictions
- Confluence User's Guide

**Notes**
- **Warning:** If you deny all administrative access to a space by mistake, so that nobody has access to administer the space any more, you will need to ask someone in the confluence-administrators group to fix the permissions for you.
- The Confluence CLI tool is useful for bulk operations, including adjustments to space permissions. You can download it from the Atlassian Marketplace. The documentation for the Confluence CLI includes information about the AddPermissions action.

**Assigning Space Permissions**
You can assign space permissions to groups or to individual users. You need to be a space administrator to assign space permissions. In addition, Confluence administrators can set the default permissions that will be applied to new spaces as described below.

To access the permissions for a space:
1. Go to the space and choose Space tools > Permissions on the sidebar.
2. Choose Edit Permissions.

If your space is using the Documentation theme:
1. Go to the 'Space Permissions' page:
   - Choose Browse > Space Admin at the top of the screen.
   - Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
   - Choose Permissions from the space administration options.
2. Choose Edit Permissions.

The 'Edit Space Permissions' page is divided into the following sections:
- Groups – a list of groups which already have permissions to access the site.
- Individual Users – a list of users who already have permissions to access the site.
- Anonymous Access – the space permissions granted to all anonymous users of the site.
On this page:

- Assigning space permissions to groups
- Assigning space permissions to users
- Assigning space permissions to anonymous users
- Setting default space permissions
- Managing and Recovering Space Admin Permissions
- Notes

Related pages:

- Space Permissions Overview
- Users and Groups
- Confluence User’s Guide

Screenshot: Space permissions
Assigning space permissions to groups

- To assign a permission, check the box next to the relevant group.
- To deny a permission, uncheck the relevant box.
- To add a new group to the list, type the group name into the text box in the ‘Groups’ section and choose Add. The group will appear in the list of groups. You can then assign the permissions.
- To search for a group:
  - Choose the icon.
  - The Group Search window opens. Enter all or part of the group name. You can use an asterisk ‘*’ as a wild card.
  - Check the boxes to select the required group(s).
  - Choose Select Groups. The group name(s) will appear in the text box in the ‘Groups’ section.
  - Choose Add.
- To bulk assign or revoke group member permissions, choose either Select All or Deselect All from the Actions dropdown list.

Choose Save All to apply the changes.

Assigning space permissions to users

- To assign a permission, check the box next to the relevant user.
- To deny a permission, uncheck the relevant box.
- To add a new user to the list, type the username into the text box in the 'Individual Users' section and choose Add. The user will appear in the list of users, with 'View' permission assigned. You can then add more permissions if necessary.
- To search for a user:
  - Choose the icon.
  - The User Search window opens. You can read more about searching for users.
  - Check the boxes to select the required user(s).
  - Choose Select User(s). The username(s) will appear in the text box in the 'Individual Users' section.
  - Choose Add.
- To bulk assign or revoke individual user permissions, choose either Select All or Deselect All from the Actions dropdown list.

Choose Save All to apply the changes.

Assigning space permissions to anonymous users

- To assign a permission, check the box for the required permission.
- To deny a permission, uncheck the relevant box.
- To bulk assign or revoke anonymous user permissions, choose either Select All or Deselect All from the Actions dropdown list.

Choose Save All to apply the changes.

Note: You cannot grant space administration rights or page restriction rights to anonymous users.

Setting default space permissions

If you are a Confluence Administrator, you can set the default permissions that will be applied to new spaces. The default permissions are configurable for groups only, not for individual users or anonymous users.

To set the default space permissions:

1. Choose the cog icon at top right of the screen, then choose Confluence Admin.
2. Choose Space Permissions under Security in the sidebar.
3. Choose Edit Permissions.

Screenshot: Default space permissions
Managing and Recovering Space Admin Permissions

Users with System Administrator permissions are able to manage permissions for spaces, including adding or removing Space Admin permissions for a space.

To manage space permissions:

1. Choose the cog icon at top right of the screen, then choose Confluence Admin.
2. Choose Space Permissions under Users & Security in the sidebar.
3. Locate the space in the Individual Spaces list and choose Manage Permissions.

There may be some instances where a space administrator has removed Space Admin permissions from all other users and groups for a space, meaning that no other user can administer the space. Users with Confluence Administrator permissions can recover permissions for the space in this instance.

To recover Space Admin permissions:

1. Choose the cog icon at top right of the screen, then choose Confluence Admin.
2. Choose Space Permissions under Users & Security in the sidebar.
3. Locate the space in the Individual Spaces list and choose Recover Permissions.

The user will then be able to choose Manage Permissions, and add any appropriate permissions to the space. Requests to recover permissions are recorded in the Confluence log files.

Notes

Assigning permissions in bulk. There is no way to change a number of space permissions at once, via the Confluence user interface. Instead, take a look at the Confluence Command Line Interface. Here is a link to the CLI documentation. For an introduction to the CLI, see this blog post: Confluence CLI for bulk actions like deleting or publishing pages.

Users and Groups

A ‘user’ is the account for an individual who accesses Confluence.

New users are created by a Confluence administrator via the Administration Console. See Searching For and Administering Users for more information.

A Confluence administrator can also group users together into user groups for more convenient administration. This means that any permissions you assign at the site, space and page levels can be assigned to a whole group. A user in one of these groups will automatically be granted all permissions granted to the group.

There are two special groups in Confluence:

- **Confluence-Administrators** - This is a ‘super-group’ and a user from this group has permission to do
anything in the site regardless of any other setting.

- **Confluence-Users** - This is the default group into which all new users are assigned. Permissions you assign to this group will be assigned to all newly signed-up users of Confluence.

### Anonymous Users

Confluence treats all users who do not log in when they access Confluence as being 'Anonymous'. Administrators can assign permissions to this group separately.

---

#### Overlapping group and user permissions

When a user is assigned more than one permission, the most powerful permission will prevail.

Further explanation:

- A user may be assigned a permission specifically to their username. They may also be assigned a permission by belonging to a group, or even several groups.
- The user will then be able to perform all functions assigned to them.
- So if a user is allowed to do something over and above what the group can do, the user will be able to do it. And if the group is allowed to do something over and above the specific permissions granted to the user, the user will still be able to do it.

---

**Related Topics**

- Space Permissions Overview
- Assigning Space Permissions
- Page Permissions
- Managing Confluence Users
- Confluence User's Guide

#### Searching for Users

This page describes how to use the 'User Search' window, which appears when you click **Choose Users** or a user search icon on a Confluence page.

**Accessing the User Search**

To access the 'User Search' window:

1. Choose the user search icon when you are performing one of the following actions:
   - When assigning space permissions, choose the **user search** icon in the users section.
   - When adding members to a group, choose the **user search** icon.

2. The simple 'User Search' window will appear, as shown below.
On this page:
- Accessing the User Search
- Using the Simple User Search
- Searching for Users in One or More Groups
- Selecting One or More Users
- Notes

Related pages:
- Searching Confluence
- Page Restrictions
- Assigning Space Permissions
- Adding or Removing Users in Groups
- Confluence User's Guide

Using the Simple User Search

**To search via the simple user search:**

1. Select the **User** tab on the 'User Search' screen. (See above for instructions on accessing the screen.)
2. Enter information about the user in the User Details field, such as all or part of a username, full name or email address.
3. Choose **Search**.
4. Confluence will return a list of matching users. See below for instructions on selecting one or more users.

**Screenshot: Simple user search**

Searching for Users in One or More Groups

You can also list the users who appear in a particular group or in a set of groups.

**To search for users in a particular group:**

1. Select the **Membership** tab on the 'User Search' screen. (See above for instructions on accessing the screen.)
2. Enter all or part of a group name into the **Group Membership** field.
3. Choose **Search**.
4. Confluence will return a list of users belonging to any groups which match your search term.
   - In the example screenshot below, we entered a group name of 'dev'. The search results show all users belonging to the group 'developers' and all users belonging to the group 'developers-mates'.
5. Now you can select one or more users, as described below.

**Screenshot: Searching for users in a group**
Selecting One or More Users

After searching for users and receiving a list of names from Confluence, as described above, you can now select the user(s) you need.

To select one or more users:

1. Click the box next to the username(s) to select or deselect one or more users.
   You can click Check All to select or deselect all users.
2. Click Select User(s).
3. The 'User Search' window will close and the selected users will appear on the screen which you were using before you accessed the user search.

Notes

- **Case sensitivity**: The search is not case sensitive. You can enter either upper- or lower-case text, and it will make no difference to the search results.
- **Wild cards**: The search allows the asterisk as a wild card, but you do not need to use it. The search results will be the same whether you use a wild card or not. The wildcard functionality remains available for compatibility with older versions of Confluence.
- **Multiple user directories**: You may define multiple user directories in Confluence, so that Confluence looks in more than one place for its users and groups. For example, you may use the default Confluence internal directory and also connect to an LDAP directory server. In such cases, you can define the directory order to determine where Confluence looks first when processing users and groups.

Here is a summary of how the directory order affects the processing:

- The order of the directories is the order in which they will be searched for users and groups.
- Changes to users and groups will be made only in the first directory where the application has permission to make changes.

See Managing Multiple Directories.

- **Crowd and the user search**: If you are using Atlassian's Crowd for user management, you will need Crowd 1.5.1 or later to use the 'Simple' option in the user search. If your version of Crowd does not support the simple user search, you will see only the 'Advanced' search form.
Using Confluence on a Mobile Device

When you view a Confluence page on a mobile device, such as an iPhone, iPad or Android device, Confluence will display an optimised version of the page. Confluence chooses the mobile or desktop interface based on your device. See Supported Platforms for details of supported mobile devices.

On your supported mobile device, you can:

- View the Confluence dashboard, pages, blog posts, and user profiles.
- Add or reply to a comment on a page or blog post.
- Like a page, blog post or comment.
- Watch a page or blog post.
- Manage your personal tasks and notifications.

You cannot add or edit pages or blog posts, or edit existing comments, using the mobile interface.

The dashboard – the first thing you see

Screenshot: The dashboard in Confluence mobile

Choose a tab to see:

- Popular content – what people like in your wiki.
- Recent blogs – the latest blog posts.
- Network – updates by people in your network.

Tap the links to view the full content of a page, blog post or comment.

Searching for content and people

Tap the menu icon to open the menu panel on the left of the page. Then type text or a person’s name in the Search box. The mobile interface offers the quick navigation search, which returns matches on page title only. (See Searching Confluence.) To use the full search, switch to desktop mode.

Screenshot: The menu panel in Confluence mobile
Viewing pages, blog posts and comments

Tap a link on the dashboard or on any other page. Confluence will display the linked page, blog post or comment.

You can:

- View the content, tap a link to move to another page, and interact with the page using the standard functionality supported by mobile browsers.
- Like or unlike a page, blog post or comment.
- Watch or stop watching a page or blog post.
- Add or reply to a comment. Confluence mobile supports plain-text comments only.

Screenshot: A page showing Like, Watch and Comment options.

Viewing people's profiles
Search for a person's name, then view that person's user profile. Tap the options to phone, SMS or email a colleague directly from your mobile device.

**Screenshot: A user profile on Confluence mobile**

---

**Following up on notifications**

You can view and respond to your notifications on your phone or other mobile device. Tap the menu icon to open the menu panel on the left of the page. Choose **Notifications**, and tap a notification to see its details. You can reply, watch or like via the inline actions. Tap **Open** to open the page or blog post in a new page. For full details, see **Managing Notifications in Confluence**.

**Screenshot: Notifications in Confluence mobile**

---

**Managing tasks**
You can view and manage your tasks on your phone or other mobile device too. Tap the menu icon to open the menu panel on the left of the page. Choose **Tasks**, and tap the plus sign to add a new task. Tap a task to see its details. You can add notes, complete a task, and tap a link to open the related page. For full details, see **Managing Tasks in Confluence**.

**Screenshot: Tasks in Confluence mobile**

---

**More things you may need to know**

See **Notes about Confluence Mobile**.

**Related pages**

- Dashboard
- Managing Notifications in Confluence
- Managing Tasks in Confluence
- Confluence User's Guide

**Notes about Confluence Mobile**

When you view a Confluence page on a mobile device, such as an iPhone, iPad or Android device, Confluence will display an optimised version of the page. Confluence chooses the mobile or desktop interface based on your device. See **Supported Platforms** for details of supported mobile devices.

For a summary of mobile features, see **Using Confluence on a Mobile Device**. Below are additional notes that you will find useful.

**On this page:**

- Some macros may not work
- You can swap from mobile to standard Confluence and back again
- Administrators can disable Confluence mobile on your site
- Confluence mobile is a web interface, not a native app
- Related pages

**Some macros may not work**

Confluence macros are not yet fully supported in Confluence mobile. If you view a page that contains an unsupported macro, you will see a message inviting you to click through to the desktop version of the page.
You can swap from mobile to standard Confluence and back again

You can swap from the mobile view to the standard view of a page at any time. Choose the menu icon \((\text{Menu})\) then choose **Switch to desktop version**.

You can also swap from the desktop view to the mobile view, if you are on a mobile device. Choose the option **Switch to Confluence Mobile** at the top of the window.

Administrators can disable Confluence mobile on your site

The mobile functionality is provided by a plugin called the ‘Confluence Mobile Plugin’. To remove the functionality from your site, you can disable the plugin.

Confluence mobile is a web interface, not a native app

Atlassian does not supply a native mobile application that you can download and install onto your mobile device. Confluence mobile is a web-based user interface that Confluence displays when it detects a mobile client.
Related pages

- Using Confluence on a Mobile Device
- Dashboard
- Confluence User's Guide

**Working with JIRA in Confluence**

If you use JIRA and have your Confluence and JIRA instances connected using Application Links you can display and create JIRA issues and more from within Confluence. Some of these features require a specific version of JIRA.

This page provides some basics to get you stared working with JIRA issues in Confluence.

**Displaying JIRA issues**

You can display JIRA issues on a Confluence page using the JIRA Issues macro. You can display a single issue, a list of issues, or show the total number of issues.

One of the simplest ways to add a JIRA issue to a page is to paste a JIRA URL. For example:

- `<yourjirasite.com>/browse/CONF-1234` will insert the JIRA Issues macro and display a single issue.
- `<yourjirasite.com>/issues/?filter=56789` will insert the JIRA Issues macro and display a list of issues matching the saved filter.
- `<yourjirasite.com>/issues/?jql=project%20%3D%20CONF` will insert the JIRA Issues macro and display a list of issues matching the JIRA search.

Alternatively you can add the JIRA Issues macro to the page and use the macro browser to search for issues directly.

- In the editor choose Insert > JIRA Issue.
- Follow the prompts in the macro browser to choose a project and search for an issue - you can even use JIRA Query Language (JQL).

You can customise how the issue or list of issues appears on the page, including how much information to display, how many issues, and more.

Find out more about using the JIRA Issues Macro.

**Creating JIRA Issues**

You can create issues from a page, or from the editor. This is particularly useful if you use Confluence for requirements gathering.

**To create an issue when viewing a page:**

- Highlight some text on your page - a panel with appear near your selection.
- Choose Create JIRA Issue.
- Follow the prompts to enter information about your project and issue - your highlighted text will populate the issue summary.
- Choose Create - the issue will be created in JIRA, and added to your page.

If your text is in a table, you will have the option to create multiple issues using text from the same column.

**To create an issue in the editor:**

- In the editor choose Insert > JIRA Issue > Create new issue.
- Follow the prompts to enter information about your project and issue.
- Choose Insert - the issue will be created in JIRA, and added to your page.

There are some limitations when creating JIRA Issues from Confluence, particularly if you have required fields or custom field configurations. You can find out more in the JIRA Issues Macro page.
Creating reports and charts

Reporting on information stored in JIRA couldn't be easier in Confluence. In addition to the JIRA Issues Macro, you can use the JIRA Report blueprint or JIRA Chart macro.

You can:

- Use the JIRA Report blueprint to create a Change Log or Status report.
- Use the JIRA Issues Macro to display a list of resolved issues, for example for use in release notes.
- Use the JIRA Chart Macro to display data as a pie chart.

Prompting users to add JIRA Issues to a page

If you use templates (including templates provided by blueprints), you can add a JIRA Issue placeholder that, when clicked, opens the JIRA Issues macro and prompts users to search for or create a JIRA issue.

You can see the JIRA Issues placeholder in the Product Requirements blueprint.

See Adding a Template for more information on using instructional text and placeholders.

View connections between Confluence and JIRA

The JIRA Links button gives you quick access to issues connected to the Confluence page you are viewing.

Links are displayed when:

- you have created or added single issues to the page using the JIRA Issues macro in Confluence.
- you have added a link from the issue to the Confluence page in JIRA.

If you use JIRA Agile, sprints and epics will also appear on the JIRA Links button.

The number on the JIRA Links button indicates the total number of issues connected to that page, regardless of whether you have permissions to view the issues. The dropdown will only show issues, epics and sprints that you have JIRA permissions to view.

Working with JIRA Agile in Confluence

By using Confluence and JIRA Agile together, you can unleash the potential in your development team. This page provides some suggestions for how you can get the most of Confluence and JIRA Agile.

The features described on this page require JIRA 6.1.3 and JIRA Agile 6.3.5 and later.

Using Confluence and JIRA Agile to define requirements

Confluence is the perfect place to start defining your requirements. Here's how you can use Confluence features to support this process:

- Create a page using the Product Requirements Blueprint.
- Create an epic in JIRA - the blueprint template will prompt you.
- Collaborate with your team to define your stories.
- Highlight text on your requirements page to create stories in JIRA and automatically link them to your epic.
- Track the progress of the stories from the Confluence page or from within JIRA.

The tight integration between Confluence and JIRA mean that you can easily access JIRA issues from the Confluence page, and see their status at a glance, and from within JIRA you can see links to related Confluence pages. All the information you need is never more than a few clicks away.

Using Confluence and JIRA Agile during a sprint

Often there is a lot of material in Confluence that provides useful context for your team during a sprint. These might be requirements documents, designs, technical specifications, customer research and more. By linking these pages to epics, you make them easy for your team to access during the sprint.
Here's how you can use Confluence to support your sprint from within JIRA Agile:

- In JIRA Agile create a Confluence page to plan your sprint - this page is automatically linked to the sprint.
- In an epic link to useful Confluence pages, including requirements, designs, and more.
- Report on your progress to stakeholders using the JIRA Reports blueprint.
- Use the Retrospective blueprint at the end of your sprint to take stock of what went well, and areas for improvement.

For users who work primarily in JIRA, the integration means that useful Confluence pages are only a click away.

**Viewing links between Confluence and JIRA**

The JIRA Links button appears on your page when there are links back to JIRA or JIRA Agile. These might be:

- Links from a JIRA issue back to a Confluence Page.
- Links from a JIRA Agile epic or sprint back to a Confluence Page.
- Link from a Confluence page to a JIRA Issue or epic (created by adding a single issue in the JIRA Issues macro).

The number on the JIRA Links button indicates the total number of issues, epics and sprints connected to that page, regardless of whether you have permissions to view them. The dropdown will only show details of issues, epics and sprints that you have JIRA permissions to view.

**Advanced and Special Uses of Confluence**

This section describes the more advanced features of Confluence, and gives guidelines on some specific uses of the wiki.

**Confluence markup formats**

The syntax and usage of Confluence wiki markup and the Confluence XHTML-based storage format – see Working with Confluence Markup.

**Gadgets**

How to add gadgets to a wiki page, or use Confluence gadgets on other sites – see Working with Confluence Gadgets.

**Using Confluence for technical documentation**

A technical communicator's guide to using Confluence – see Developing Technical Documentation on Confluence Wiki.

**Setting up a knowledge base**

A support engineer's guide to using Confluence as a knowledge base – see Developing a Knowledge Base on Confluence Wiki.

**Setting up an intranet**

A quick guide to setting up an intranet wiki – see Developing an Intranet on Confluence Wiki.

**Related pages:**

- Confluence User's Guide
- Confluence Administrator's Guide

**Working with Confluence Markup**

This section describes two types of markup found in Confluence:

- **Confluence storage format.** Confluence stores the content of pages and blog posts in an XHTML-based format. Advanced users can view the storage format of a page and even edit it, provided their Confluence site is configured to allow that. See Confluence Storage Format for a description of the core elements of the storage format. For details of the elements used to define a macro, see Confluence Storage Format for Macros.
- **Wiki markup.** Confluence allows data entry via a shorthand code called wiki markup. Some parts of the Confluence administration interface also accept wiki markup for defining content. For a description of the
wiki markup syntax, see Confluence Wiki Markup. For details of the wiki markup used to define Confluence macros, see Confluence Wiki Markup for Macros.

Related pages:
- Working with Macros
- Confluence User's Guide

A request from the Atlassian technical writers about comments and feedback: When adding comments to this page, please restrict your comments to constructive feedback on the documentation itself: Things we've missed in the documentation, and things that will be useful to other readers. If you have other feedback about the editor, wiki markup, the XML storage format, and Confluence 4 in general, please add your comments in the section titled Confluence 4 Editor - Customer Feedback, and its child pages. Our reason for this request: When a page attracts a large number of comments, it makes it difficult for everyone to read the page, and to add or respond to comments about the documentation. Thanks.

Confluence Storage Format

This page describes the XHTML-based format that Confluence uses to store the content of pages, page templates, blueprints, blog posts and comments. This information is intended for advanced users who need to interpret and edit the underlying markup of a Confluence page.

We refer to the Confluence storage format as 'XHTML-based'. To be correct, we should call it XML, because the Confluence storage format does not comply with the XHTML definition. In particular, Confluence includes custom elements for macros and more. We're using the term 'XHTML-based' to indicate that there is a large proportion of HTML in the storage format.

Notes:

- You can view the Confluence storage format for a given page by choosing Tools > View Storage Format. This option is only available if one of the following is true:
  - You are a Confluence administrator.
  - Your Confluence site has the Confluence Source Editor plugin installed and you have permission to use the source editor.
- If you would like to edit the storage format for a page, your Confluence system administrator will need to install the Confluence Source Editor plugin.
- Clarification of terminology: If you choose Tools > View Source, you will see the format used within the editor panel, not the storage format of the page.

A request from the Atlassian technical writers about comments and feedback: When adding comments to this page, please restrict your comments to constructive feedback on the documentation itself: Things we've missed in the documentation, and things that will be useful to other readers. If you have other feedback about the editor, wiki markup, the XML storage format, and Confluence 4 in general, please add your comments in the section titled Confluence 4 Editor - Customer Feedback, and its child pages. Our reason for this request: When a page attracts a large number of comments, it makes it difficult for everyone to read the page, and to add or respond to comments about the documentation. Thanks.

On this page:
- Macros
- Headings
- Text effects
- Text breaks
- Lists
- Links
- Images
- Tables
- Page layouts
- Resource identifiers
- Template variables
- Instructional Text

Related pages:
- Confluence Storage Format for Macros
- Working with Confluence Markup
Macros

See Confluence Storage Format for Macros.

### Headings

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heading 1</td>
<td>h1. Heading 1</td>
<td></td>
<td><strong>Heading 1</strong> Underlined in the Documentation Theme</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Heading 2</td>
<td>h2. Heading 2</td>
<td></td>
<td><strong>Heading 2</strong> Underlined in the Documentation Theme</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Heading 3</td>
<td>h3. Heading 3</td>
<td></td>
<td><strong>Heading 3</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Headings 4 to 6 are also available and follow the same pattern

### Text effects

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>strong/bold</td>
<td><em>strong</em></td>
<td></td>
<td><strong>strong</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>&lt;b&gt; will also work but get converted to &lt;strong&gt; upon saving</td>
</tr>
<tr>
<td>emphasis</td>
<td><em>emphasis</em></td>
<td></td>
<td><strong>emphasis</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>&lt;i&gt; will also work but get converted to &lt;em&gt; upon saving</td>
</tr>
<tr>
<td>strikethrough</td>
<td>-strikethrough-</td>
<td><code>&lt;span style=&quot;text-decoration: line-through;&quot;&gt;s trikethrough&lt;/span&gt;</code></td>
<td>strikethrough</td>
</tr>
<tr>
<td>underline</td>
<td>+underline+</td>
<td><code>&lt;u&gt;u n d e r l i n e&lt;/u&gt;</code></td>
<td>underline</td>
</tr>
<tr>
<td>subscript</td>
<td><del>subscript</del></td>
<td><code>&lt;sub&gt;subscript&lt;/sub&gt;</code></td>
<td>subscript</td>
</tr>
<tr>
<td>monospace</td>
<td><code>{monospaced}</code></td>
<td><code>&lt;code&gt;monospaced&lt;/code&gt;</code></td>
<td>monospaced</td>
</tr>
<tr>
<td>preformatted</td>
<td>n/a</td>
<td><code>&lt;pre&gt;preformatted text&lt;/pre&gt;</code></td>
<td>preformatted text</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------</td>
<td>--------------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>block quotes</td>
<td>bq. block quote or {quote}</td>
<td><code>&lt;blockquote&gt;&lt;p&gt;block quote&lt;/p&gt;&lt;p&gt;block quote&lt;/p&gt;&lt;/blockquote&gt;</code></td>
<td>block quote</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>text colour</td>
<td>{color:red}red text{color}</td>
<td><code>&lt;span style=&quot;color:rgb(255,0,0);&quot;&gt;red text&lt;/span&gt;</code></td>
<td>red text</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>small</td>
<td>n/a</td>
<td><code>&lt;small&gt;small text&lt;/small&gt;</code></td>
<td>small text</td>
</tr>
<tr>
<td>Format type</td>
<td>In Confluence 3.5 and earlier</td>
<td>In Confluence 4.0 and later</td>
<td>What you will get</td>
</tr>
<tr>
<td>-----------------</td>
<td>--------------------------------</td>
<td>-----------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>New paragraph</td>
<td>Paragraph 1 (empty line)</td>
<td>Paragraph 1 Paragraph 2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Paragraph 2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Line break</td>
<td>Line 1 \ Line 2</td>
<td>Line 1 &lt;br /&gt; Line 2</td>
<td>Line 1 Line 2</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------</td>
<td>----------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Note: Created in the editor using Shift + Return/Enter</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

| Horizontal rule | ---- | <hr /> |
| --- | | |

| — symbol | --- | &mdash; |
| --- | | |

| – symbol | -- | &mdash; |
| --- | | |

### Lists

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unordered list – round bullets</td>
<td>* Round bullet list item</td>
<td>&lt;ul&gt; &lt;li&gt;round bullet list item&lt;/li&gt; &lt;/ul&gt;</td>
<td>• Round bullet list item</td>
</tr>
<tr>
<td>Ordered list (numbered list)</td>
<td># Ordered list item</td>
<td>&lt;ol&gt; &lt;li&gt;numbered list item&lt;/li&gt; &lt;/ol&gt;</td>
<td>1. Ordered list item</td>
</tr>
</tbody>
</table>
### Task Lists

<table>
<thead>
<tr>
<th>[] Task list item</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Task List Item" /></td>
</tr>
</tbody>
</table>

---

### Links

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link to another Confluence page</td>
<td>![Link to another Confluence page</td>
<td>Page Title]</td>
<td><img src="image" alt="Link to another Confluence page" /></td>
</tr>
</tbody>
</table>

---

*Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
<table>
<thead>
<tr>
<th>Link to an attachment</th>
<th><img src="atlassian_logo.gif" alt="Link to an attachment" /></th>
</tr>
</thead>
<tbody>
<tr>
<td>Link to an external site</td>
<td><img src="http://www.atlassian.com/" alt="Atlassian" /> Atlassian</td>
</tr>
<tr>
<td>Anchor link (same page)</td>
<td><img src="#anchor" alt="Anchor Link" /> Anchor Link</td>
</tr>
</tbody>
</table>

---

*Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
<table>
<thead>
<tr>
<th>Anchor link (another page)</th>
<th><img src="pagetitle#anchor" alt="Anchor Link" /></th>
<th>Anchor Link</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="pagetitle#anchor" alt="Anchor Link" /></td>
<td>&lt;ac:link ac:anchor=&quot;anchor&quot;&gt; &lt;ri:page ri:content-title=&quot;pagetitle&quot;/&gt; <a href="">ac:plain-text-link-body</a> &lt;![CDATA[Anchor Link]]&gt; &lt;/ac:plain-text-link-body&gt; &lt;/ac:link&gt;</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Link with an embedded image for the body</th>
<th><img src="pagetitle#anchor" alt="google.png" /></th>
<th><img src="pagetitle#anchor" alt="For rich content like images, you need to use ac:link-body to wrap the contents." /></th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="pagetitle#anchor" alt="google.png" /></td>
<td>&lt;ac:link ac:anchor=&quot;Anchor Link&quot;&gt; <a href="">ac:link-body</a> <a href="">ac:image</a>&lt;ri:url ri:value=&quot;<a href="https://confluence.atlassian.com/images/logo/confluence_48_trans.png%22/%3E">https://confluence.atlassian.com/images/logo/confluence_48_trans.png&quot;/&gt;</a>&lt;/ac:image&gt; &lt;/ac:link-body&gt; &lt;/ac:link&gt;</td>
<td></td>
</tr>
</tbody>
</table>

**A note about link bodies**

All links received from the editor will be stored as plain text by default, unless they are detected to contain the limited set of mark up that we allow in link bodies. Here are some examples of markup we support in link bodies.
An example of different link bodies

```xml
<ac:link>
  <!-- Any resource identifier -->
  <ri:page ri:content-title="Home" ri:space-key="SANDBOX" />
  <ac:link-body>Some <strong>Rich</strong> Text</ac:link-body>
</ac:link>

<ac:link>
  <ri:page ri:content-title="Plugin developer tutorial stuff" ri:space-key="TECHWRITING" />
  <ac:plain-text-link-body><![CDATA[A plain <text> link body]]></ac:plain-text-link-body>
</ac:link>

<ac:link>
  <ri:page ri:content-title="Plugin developer tutorial stuff" ri:space-key="TECHWRITING" />
  <!-- A link body isn't necessary. Auto-generated from the resource identifier for display. -->
</ac:link>
```

The markup tags permitted within the `<ac:link-body>` are `<b>`, `<strong>`, `<em>`, `<i>`, `<code>`, `<tt>`, `<sub>`, `<sup>`, `<br>` and `<span>`.

Images

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attached image</td>
<td><img src="" alt="atlassian_logo.png" /></td>
<td><img src="" alt="atlassian_logo.png" /></td>
<td><img src="" alt="Atlassian Logo" /></td>
</tr>
</tbody>
</table>
Supported image attributes (some of these attributes mirror the equivalent HTML 4 IMG element):

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ac:align</td>
<td>image alignment</td>
</tr>
<tr>
<td>ac:border</td>
<td>Set to &quot;true&quot; to set a border</td>
</tr>
<tr>
<td>ac:class</td>
<td>css class attribute.</td>
</tr>
<tr>
<td>ac:title</td>
<td>image tool tip.</td>
</tr>
<tr>
<td>ac:style</td>
<td>css style</td>
</tr>
<tr>
<td>ac:thumbnail</td>
<td>Set to &quot;true&quot; to designate this image as a thumbnail.</td>
</tr>
<tr>
<td>ac:alt</td>
<td>alt text</td>
</tr>
<tr>
<td>ac:height</td>
<td>image height</td>
</tr>
<tr>
<td>ac:width</td>
<td>image width</td>
</tr>
<tr>
<td>ac:vspace</td>
<td>the white space on the top and bottom of an image</td>
</tr>
<tr>
<td>ac:hspace</td>
<td>the white space on the left and right of an image</td>
</tr>
</tbody>
</table>

Tables

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
| Two column, two row (top header row) | <table>
| Table Heading Cell 1 | Table Heading Cell 2 |
| Normal Cell 1 | Normal Cell 2 |
| Table Heading Cell 1 | Table Heading Cell 2 |
| Normal Cell 1 | Normal Cell 2 |
Two column, three rows, 2nd and third with merged cells in first row | N/A
---|---
<table>
<thead>
<tr>
<th>Table Heading Cell 1</th>
<th>Table Heading Cell 2</th>
</tr>
</thead>
<tbody>
<tr>
<td rowspan="2">Merged Cell</td>
<td>Normal Cell 1</td>
</tr>
<tr>
<td>Normal Cell 2</td>
</tr>
</tbody>
</table>

### Page layouts

Confluence supports page layouts directly, as an alternative to macro-based layouts (using, for example, the section and column macros). This section documents the storage format XML created when these layouts are used in a page.

**Notes:**

- Page layouts were originally introduced in Confluence 4.2, and are not available in earlier versions of Confluence. If you are using Confluence 4.2 - 5.1 you should refer to the documentation for your version of Confluence:
  - Confluence Storage Format (Confluence 4.2)
  - Confluence Storage Format (Confluence 4.3)
  - Confluence Storage Format (Confluence 5.0)
  - Confluence Storage Format (Confluence 5.1)
- Pages with a layout created in the old format will be converted to 5.2 format.
- Confluence 5.2 provides more flexible layouts with a more concise storage format.
<table>
<thead>
<tr>
<th>Element name</th>
<th>In Confluence 5.2 and later</th>
<th>Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>ac:layout</td>
<td>Indicates that the page has a layout. It should be the top level element in the page.</td>
<td>None</td>
</tr>
<tr>
<td>ac:layout-section</td>
<td>Represents a row in the layout. It must be directly within the ac:layout tag. The type of the section indicates the appropriate number of cells and their relative widths.</td>
<td>ac:type</td>
</tr>
<tr>
<td>ac:layout-cell</td>
<td>Represents a column in a layout. It must be directly within the ac:layout-section tag. There should be an appropriate number of cells within the layout-section to match the ac:type.</td>
<td>None</td>
</tr>
</tbody>
</table>

The recognised values of ac:type for ac:layout-section are:

<table>
<thead>
<tr>
<th>ac:type</th>
<th>Expected number of cells</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>single</td>
<td>1</td>
<td>One cell occupies the entire section.</td>
</tr>
<tr>
<td>two_equal</td>
<td>2</td>
<td>Two cells of equal width.</td>
</tr>
<tr>
<td>two_left_sidebar</td>
<td>2</td>
<td>A narrow (~30%) cell followed by a wide cell.</td>
</tr>
<tr>
<td>two_right_sidebar</td>
<td>2</td>
<td>A wide cell followed by a narrow (~30%) cell.</td>
</tr>
<tr>
<td>three_equal</td>
<td>3</td>
<td>Three cells of equal width.</td>
</tr>
<tr>
<td>three_with_sidebars</td>
<td>3</td>
<td>A narrow (~20%) cell at each end with a wide cell in the middle.</td>
</tr>
</tbody>
</table>

The following example shows one of the more complicated layouts from the old format built in the new. The word {content} indicates where further XHTML or Confluence storage format block content would be entered, such as <p> or <table> tags.
### Emoticons

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Emoticons</td>
<td>:)</td>
<td>&lt;ac:emoticon ac:name=&quot;smile&quot; /&gt;</td>
<td>😊</td>
</tr>
<tr>
<td></td>
<td>:(</td>
<td>&lt;ac:emoticon ac:name=&quot;sad&quot; /&gt;</td>
<td>😞</td>
</tr>
<tr>
<td></td>
<td>:P</td>
<td>&lt;ac:emoticon ac:name=&quot;cheeky&quot; /&gt;</td>
<td>😄</td>
</tr>
<tr>
<td></td>
<td>:D</td>
<td>&lt;ac:emoticon ac:name=&quot;laugh&quot; /&gt;</td>
<td>😄</td>
</tr>
</tbody>
</table>
Resource identifiers

Resource identifiers are used to describe "links" or "references" to resources in the storage format. Examples of resources include pages, blog posts, comments, shortcuts, images and so forth.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Resource identifier format</th>
</tr>
</thead>
</table>

Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Page</th>
<th><code>&lt;ri:page ri:space-key=&quot;FOO&quot; ri:content-title=&quot;Test Page&quot;/&gt;</code></th>
</tr>
</thead>
<tbody>
<tr>
<td>Notes:</td>
<td></td>
</tr>
<tr>
<td>• <code>ri:space-key:</code> (optional) denotes the space key. This can be omitted to create a relative reference.</td>
<td></td>
</tr>
<tr>
<td>• <code>ri:content-title:</code> (required) denotes the title of the page.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Blog Post</th>
<th><code>&lt;ri:blog-post ri:space-key=&quot;FOO&quot; ri:content-title=&quot;First Post&quot; ri:posting-day=&quot;2012/01/30&quot;/&gt;</code></th>
</tr>
</thead>
<tbody>
<tr>
<td>Notes:</td>
<td></td>
</tr>
<tr>
<td>• <code>ri:space-key:</code> (optional) denotes the space key. This can be omitted to create a relative reference.</td>
<td></td>
</tr>
<tr>
<td>• <code>ri:content-title:</code> (required) denotes the title of the page.</td>
<td></td>
</tr>
<tr>
<td>• <code>ri:posting-day:</code> (required) denotes the posting day. The format is YYYY/MM/DD.</td>
<td></td>
</tr>
</tbody>
</table>
### Attachment

```
<ri:attachment ri:filename>
... resource identifier for the container of the attachment ...
</ri:attachment>
```

**Notes:**

- `ri:filename`: (required) denotes the name of the attachment.
- The body of the `ri:attachment` element should be a resource identifier denoting the container of the attachment. This can be omitted to create a relative attachment reference (similar to `[foo.png]` in wiki markup).

**Examples:**

<table>
<thead>
<tr>
<th>Relative Attachment Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;ri:attachment ri:filename=&quot;happy.gif&quot; /&gt;</code></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Absolute Attachment Reference</th>
</tr>
</thead>
</table>
| `<ri:attachment ri:filename="happy.gif">
   <ri:page ri:space-key="TST"
   ri:content-title="Test Page"/>
</ri:attachment>` |

### URL

```
<ri:url ri:value="http://example.org/sample.gif"/>
```

**Notes:**

- `ri:value`: (required) denotes the actual URL value.

### Shortcut

```
<ri:shortcut ri:key="jira"
ri:parameter="ABC-123">
```

**Notes:**

- `ri:key`: (required) represents the key of the Confluence shortcut.
- `ri:parameter`: (required) represents the parameter to pass into the Confluence shortcut.
- The example above is equivalent to `[ABC-123@jira]` in wiki markup.
Template variables

This screenshot shows a simple template:

```
Dashboard › Chocolate › Browse Space › Edit Template

Sarah template

This is Sarah's template

A single-line text variable: $MyText
A multi-line text variable: $MyMulti
A selection list: $MyList

End of page.
```

The template contains the following variables:

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Type</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>$MyText</td>
<td>Single-line text</td>
<td></td>
</tr>
<tr>
<td>$MyMulti</td>
<td>Multi-line text</td>
<td>Size: 5 x 100</td>
</tr>
</tbody>
</table>
The XML export produces the following code for the template:

```xml
<at:declarations>
    <at:string at:name="MyText" />
    <at:textarea at:columns="100" at:name="MyMulti" at:rows="5" />
    <at:list at:name="MyList">
        <at:option at:value="Apples" />
        <at:option at:value="Pears" />
        <at:option at:value="Peaches" />
    </at:list>
</at:declarations>

This is Sarah's template

A single-line text variable: &nbsp;<at:var at:name="MyText" />

A multi-line text variable: &nbsp;<at:var at:name="MyMulti" />

A selection list: &nbsp;<at:var at:name="MyList" />

End of page.
```

### Instructional Text

Instructional text allows you to include information on how to fill out a template for an end-user (the person using creating a page from the template). Instructional text will:

- automatically clear all *instructional text* as the user types in a specific text block, and
- automatically trigger a @mention prompt for user selection (for 'mention' type instructional text).

**Screenshot: Example of instructional text.**

```
<ul>
    <li><ac:placeholder>This is an example of instruction text that will get replaced when a user selects the text and begins typing.</ac:placeholder></li>
</ul>

<ac:task-list>
    <ac:task>
        <ac:task-status>incomplete</ac:task-status>
        <ac:task-body><ac:placeholder ac:type="mention">@mention example. This placeholder will automatically search for a user to mention in the page when the user begins typing.</ac:placeholder></ac:task-body>
    </ac:task>
</ac:task-list>
```

### Confluence Storage Format for Macros

This page is an extension of the page about the Confluence storage format. This page describes the XML used to define specific Confluence macros – those that are shipped with Confluence. For each macro, we define the macro name, parameter names, and accepted parameter values.

This information is intended for advanced users who need to interpret and edit the underlying markup for a...
Anchor macro

Allows you to link to a specific part of a page.

**Macro name:** anchor

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>Yes</td>
<td>(None)</td>
<td>The name of the anchor.</td>
</tr>
</tbody>
</table>

(Unnamed in wiki markup)

**Example:**

```xml
<ac:structured-macro ac:name="anchor">
  <ac:parameter ac:name=""/>here</ac:parameter>
</ac:structured-macro>
```

Attachments macro

Displays a list of attachments on a given page.

**Macro name:** attachments

**Macro body:** None.

---

Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>old</td>
<td>No</td>
<td>false</td>
</tr>
<tr>
<td>patterns</td>
<td>No</td>
<td>(None)</td>
</tr>
<tr>
<td>sortBy</td>
<td>No</td>
<td>date</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page on which the macro exists.</td>
</tr>
</tbody>
</table>
| sortOrder    | No      | The default sort order is determined by the `sortBy` type:  
  - Reverse chronological for 'date'.  
  - Largest to smallest for 'size'.  
  - Alphabetical for 'name'.  
| labels       | No      | (None) |
| upload       | No      | false  |

Available values:
- `false` - Displays only the latest version of each attachment.
- `true` – Displays all versions of each attachment, including the old versions.

A comma-separated list of regular expressions, used to filter the attachments by file name. Note that the parameter values must be regular expressions. For example:
- To match a file suffix of 'jpg', use `.jpg (not *.jpg).`
- To match file names ending in 'jpg' or 'png', use `.jpg,.png`

The default sort order is determined by the `sortBy` type:
- Reverse chronological for 'date'.
- Largest to smallest for 'size'.
- Alphabetical for 'name'.

A comma-separated list of labels. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.)

Determines whether the list of attachments will include options allowing users to browse for, and attach, new files.

Example:
Blog Posts macro

Lists the most recent news items in the space.

**Macro name:** blog-posts

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>content</td>
<td>No</td>
<td>entire</td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• entire – Display the whole content of each blog post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• excerpts – Display a short extract from each blog post. If the post contains an Excerpt macro, the Blog Posts macro will display the content defined in the Excerpt macro. If the post does not contain an Excerpt macro, the Blog Posts macro will display the first few sentences of the post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• titles – Display a list of blog posts, showing titles only.</td>
</tr>
<tr>
<td>spaces</td>
<td>No</td>
<td>@self</td>
<td>One or more space keys, separated by a comma or a space.</td>
</tr>
</tbody>
</table>
To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.

To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:

- @self — The current space.
- @personal — All personal spaces.
- @global — All site spaces.
- @favorite — The spaces you have marked as favourite.
- @favourite — The same as @favorite above.
- @all — All spaces in your Confluence site.
- * — The same as @all above.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>author</td>
<td>No</td>
<td>(None)</td>
<td>One or more usernames, separated by commas.</td>
</tr>
</tbody>
</table>
| time      | No       | (None)  | Available values:  
- m — Minutes  
- h — Hours  
- d — Days  
- w — Weeks  
For example,  
- time=12h — Display blog posts created in the last twelve hours.  
- time=7d — Display blog posts created in the last seven days. |
| reverse   | No       | false   | A value of true changes the sort order. |
| sort      | No       | creation | Available values:  
- title — Sort alphabetically by title.  
- creation — Sort by the date on which the content was added.  
- modified — Sort by the date on which the content was last updated. |
<p>| max       | No       | 15      | The maximum number of results to be displayed. |</p>
<table>
<thead>
<tr>
<th>label</th>
<th>No</th>
<th>(None)</th>
<th>One or more label values, separated by a comma or a space.</th>
</tr>
</thead>
</table>

- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of `badpage` you will get only content which is not labelled with 'badpage'.
- To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of `superpage,goodpage` you will get only content which has at least two labels, being 'superpage' and 'goodpage'.

Example:

```xml
<ac:structured-macro ac:name="blog-posts">
  <ac:parameter ac:name="content">titles</ac:parameter>
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="ds"/>
  </ac:parameter>
  <ac:parameter ac:name="author">
    <ri:user ri:userkey="12345678912345678912345678912345"/>
  </ac:parameter>
  <ac:parameter ac:name="time">4w</ac:parameter>
  <ac:parameter ac:name="sort">creation</ac:parameter>
  <ac:parameter ac:name="max">10</ac:parameter>
  <ac:parameter ac:name="labels">chocolate,cookies</ac:parameter>
</ac:structured-macro>
```

Change-History macro

Displays a history of updates made to a page.

**Macro name:** change-history

**Macro body:** None.

**Parameters:** None.

**Example:**
Chart macro

Displays a chart based on tabular data.

**Macro name:** chart

**Macro body:** Accepts rich text, consisting of tables that hold the chart's data.

This macro recognises a large number of parameters, listed here by type for convenience.

**Chart type parameters**

These parameters determine the type of chart to display and how the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| type        | No       | pie     | The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based. See the `timeSeries` parameter. Available values:  
  - **Standard charts** – pie, bar, line, area  
  - **XY plots** – xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries  
  - **Other charts** – gantt (beta) |
| orientation | No       | vertical| The display orientation. Applies to area, bar and line charts. Available values:  
  - `vertical` – y-axis is vertical  
  - `horizontal` – x-axis is vertical |
| 3D          | No       | false   | Show in three dimensions. Applies to area, bar and line charts. |
| stacked     | No       | false   | Stacked values. Applies to area and bar charts. |
| showShapes  | No       | true    | Applies to line charts. Shapes are shown at each data point. |
### Chart display parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
<tr>
<td>dataDisplay</td>
<td>No</td>
<td>false</td>
<td>Determines whether to display the body of the macro, consisting of the data table. By default, the chart data table is not displayed. Available values: - false – the data is not displayed. - true or after – the data is displayed after the chart. - before – the data is displayed before the chart.</td>
</tr>
<tr>
<td>imageFormat</td>
<td>No</td>
<td>png</td>
<td>The image format to be used for the chart. Available values: - png - jpg</td>
</tr>
</tbody>
</table>

### Chart title and label parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>subTitle</td>
<td>No</td>
<td>(None)</td>
<td>A subtitle for the chart.</td>
</tr>
<tr>
<td>xLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>yLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>legend</td>
<td>No</td>
<td>false</td>
<td>Determines whether to show a legend (key) for the chart.</td>
</tr>
</tbody>
</table>

### Chart data parameters

- opacity
  - No
  - 75 percent for 3D charts
  - 50 percent for non-stacked area charts
  - 100 percent for all other charts
  - A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are.
The data for the chart is taken from tables found in the macro body. The parameters below control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. You can specify additional conversion options using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>tables</td>
<td>No</td>
<td>All first level tables</td>
<td>You can supply a comma-separated list of table IDs and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
</tr>
<tr>
<td>columns</td>
<td>No</td>
<td>All columns</td>
<td>You can supply a comma-separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the HTML title attribute for the column in the header row.</td>
</tr>
<tr>
<td>dataOrientation</td>
<td>No</td>
<td>horizontal</td>
<td>The content orientation. By default, the data tables will be interpreted as columns (horizontally) representing domain and x values. Available values: • vertical – data table columns will be interpreted as series. • horizontal – data table rows will be interpreted as series.</td>
</tr>
<tr>
<td>timeSeries</td>
<td>No</td>
<td>false</td>
<td>If 'true', the x values in an XY plot will be treated as time series data and so will be converted according date formats.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>----------</td>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>dateFormat</td>
<td>No</td>
<td>(None)</td>
<td>Confluence language defined date formats. For time series data, the date format allows for additional customisation of the conversion of data to date values. If a date format is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See simple date format.</td>
</tr>
<tr>
<td>timePeriod</td>
<td>No</td>
<td>day</td>
<td>The time period for time series data. Defines the granularity of how the data is interpreted. Available values: millisecond, second, minute, hour, day, week, month, quarter, year</td>
</tr>
<tr>
<td>language</td>
<td>No</td>
<td>(None)</td>
<td>Use in combination with the country parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages. Available values are the two-character ISO 639-1 alpha-2 codes.</td>
</tr>
<tr>
<td>country</td>
<td>No</td>
<td>(None)</td>
<td>Use in combination with the language parameter to form a locale. Valid values are the two-character ISO 3166 codes.</td>
</tr>
</tbody>
</table>
forgive | No | true | Determines whether the macro will forgive (allow) some data formatting errors.

Available values:
- `true` — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.
- `false` — the macro enforces strict data formatting. If there are data format errors, the chart will not be produced.

Chart colour parameters

Colours are specified using hexadecimal notation or HTML colour names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>bgColor</td>
<td>No</td>
<td>White</td>
<td>Background colour of the chart.</td>
</tr>
<tr>
<td>borderColor</td>
<td>No</td>
<td>No border</td>
<td>Colour of the border around the chart.</td>
</tr>
<tr>
<td>colors</td>
<td>No</td>
<td>A comma-separated list of colours used to customise the colours of categories, sections, and series.</td>
<td></td>
</tr>
</tbody>
</table>

Chart axis parameters

Depending on the chart type, the range and domain axis may be customised. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rangeAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td>Minimum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td>Maximum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>rangeAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>Property</td>
<td>Default</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-----------------------</td>
<td>---------</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td>domainAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the <code>dateFormat</code> parameter.</td>
<td></td>
</tr>
<tr>
<td>domainAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the <code>dateFormat</code> parameter.</td>
<td></td>
</tr>
<tr>
<td>domainAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the <code>timePeriod</code> parameter. The <code>timePeriod</code> unit can be overridden by specifying a trailing character: <code>y</code> (years), <code>M</code> (months), <code>d</code> (days), <code>h</code> (hours), <code>m</code> (minutes), <code>s</code> (seconds), <code>u</code> (milliseconds).</td>
<td></td>
</tr>
<tr>
<td>domainAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
<td></td>
</tr>
<tr>
<td>categoryLabelPosition</td>
<td>No</td>
<td>(None)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Placement of the axis label text for categories. Available values:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <code>up45</code> — 45 degrees going upward</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <code>up90</code> — 90 degrees going upward</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <code>down45</code> — 45 degrees going downward</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <code>down90</code> — 90 degrees going downward</td>
<td></td>
</tr>
</tbody>
</table>
| dateTickMarkPosition | No | start | Placement of the date tick mark. Available values:
- `start` — tick mark is at the start of the date period.
- `middle` — tick mark is in the middle of the date period.
- `end` — tick mark is at the end of the date period. |

### Pie chart Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| pieSectionLabel        | No       | Show only the pie section key value | Format of pie section labels. The format uses a string with special replacement variables:
- `%0%` is replaced by the pie section key.
- `%1%` is replaced by the pie section numeric value.
- `%2%` is replaced by the pie section percent value.
Example 1: To display something like 'Independent = 20':
```
%0% = %1%
```
Example 2: To display something like 'Independent (20%)':
```
%0% (%2%)
```

| pieSectionExplode      | No       | No exploded sections | A comma-separated list of pie keys that are to be shown exploded. Note: requires jFreeChart version 1.0.3 or higher. |

### Chart attachment parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is...
displayed. These options allow for the generated image to be saved as an attachment and have subsequent access to re-use the attachment. This can be useful especially when combined with the Cache plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| attachment               | No       | (None)  | The name and location where the chart image will be saved as an attachment. The user must be authorised to add attachments to the page specified. Available syntax for this parameter:  
  - ^attachmentName.png — the chart is saved as an attachment to the current page.  
  - page name^attachmentName.png — the chart is saved as an attachment to the page name provided.  
  - spacekey:page name^attachmentName.png — the chart is saved as an attachment to the page name provided in the space indicated. |
| attachmentVersion        | No       | new     | Defines the the versioning mechanism for saved charts. Available values:  
  - new — creates new version of the attachment.  
  - replace — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorised to remove attachments for the page specified.  
  - keep — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated. |
<table>
<thead>
<tr>
<th>attachmentComment</th>
<th>No</th>
<th>(None)</th>
<th>Comment used for a saved chart attachment.</th>
</tr>
</thead>
<tbody>
<tr>
<td>thumbnail</td>
<td>No</td>
<td>false</td>
<td>If true, the chart image attachment will be shown as a thumbnail (small, expandable) image.</td>
</tr>
</tbody>
</table>

**Example:**

Below is a simple example of a pie chart. See more examples in Storage Format Examples for Chart Macro.
Fish Sold

<table>
<thead>
<tr>
<th>Fish Type</th>
<th>2004</th>
<th>2005</th>
</tr>
</thead>
<tbody>
<tr>
<td>Herring</td>
<td>9,500</td>
<td>8,300</td>
</tr>
<tr>
<td>Salmon</td>
<td>2,900</td>
<td>4,200</td>
</tr>
<tr>
<td>Tuna</td>
<td>1,500</td>
<td>1,500</td>
</tr>
</tbody>
</table>

---

Cheese macro

Displays the words "I like cheese!"

**Macro name:** cheese
**Macro body:** None.

**Parameters:** None

**Example:**

```
<ac:structured-macro ac:name="cheese"/>
```

**Children Display macro**

Displays the children and descendants of the current page.

**Macro name:** children

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>reverse</td>
<td>No</td>
<td>false</td>
<td>Reverses the sort order in the list of child pages. Use this parameter in conjunction with the sort parameter described below. A value of true will change the sort order from ascending to descending.</td>
</tr>
</tbody>
</table>
| sort           | No       | Manual if the pages have been manually reordered, otherwise alphabetical by page title | Determines the sort order of the list of child pages. Available values:  
  - `creation` – Sort by the date on which the page was created.  
  - `title` – Sort alphabetically by page name.  
  - `modified` – Sort by the date on which the page was last updated. |
<p>| style          | No       | Bullet list | A heading style to be applied to the list of child pages. Available values: <code>h1</code> (heading level 1) through to <code>h6</code> (heading level 6). |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>page</td>
<td>No</td>
<td>The page that contains the macro. The name of the parent page. The macro will display the children of the specified page. To specify a page in a different space, use a space key followed by a colon. For example: **MYSPEACE:**My page If the value of this parameter is a forward slash (/) the macro will list the pages at the root of the current space. In other words, the pages without parents.</td>
</tr>
<tr>
<td>excerpt</td>
<td>No</td>
<td>false If true, Confluence will display any excerpts that are defined on the child pages. The excerpts must be defined via an Excerpt macro.</td>
</tr>
<tr>
<td>first</td>
<td>No</td>
<td>(None) The maximum number of child pages to be displayed (at the top level). For example, if the value of this parameter is 99, the macro will display the first 99 pages at the top level. It will also display their children, as determined by the depth and all parameters.</td>
</tr>
<tr>
<td>depth</td>
<td>No</td>
<td>(None) The number of levels of child pages to display. For example, if the value is 2, the macro will display 2 levels of child pages.</td>
</tr>
<tr>
<td>all</td>
<td>No</td>
<td>false If true, Confluence will display all levels of child pages. This setting will override the depth setting.</td>
</tr>
</tbody>
</table>

**Example:**
Code Block macro

Displays code in your document with the appropriate syntax highlighting.

**Macro name:** code

**Macro body:** Accepts plain text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>Adds a title to the code macro box.</td>
</tr>
<tr>
<td>theme</td>
<td>No</td>
<td>Confluence</td>
<td>Specifies the colour scheme used for displaying your code. Many of these themes are based on the default colour schemes of popular integrated development environments (IDEs). The default theme is Confluence (also known as Default), which is typically black and coloured text on a blank background. Available themes:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• DJango</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Emacs</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• FadeToGrey</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Midnight</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• RDark</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Eclipse</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Confluence (same as default)</td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>---------</td>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td><code>linenumbers</code></td>
<td>No</td>
<td><code>false</code></td>
<td>If <code>true</code>, a line number will be shown to the left of each line of code. Numbering is incremented by 1. If <code>false</code>, no line numbers are shown.</td>
</tr>
<tr>
<td><code>language</code></td>
<td>No</td>
<td><code>java</code></td>
<td>Specifies the language (or environment) for syntax highlighting.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- (none) — that is, no syntax highlighting</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>actionscript3</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>bash</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>csharp</code> — that is, C#</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>coldfusion</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>cpp</code> — that is, C++</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>css</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>delphi</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>diff</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>erlang</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>groovy</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>java</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>jаваfх</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>javascript</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>perl</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>php</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>powershell</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>python</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>ruby</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>scala</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>sql</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>vb</code> — that is, Visual Basic</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>html/xml</code></td>
</tr>
<tr>
<td><code>firstline</code></td>
<td>No</td>
<td><code>1</code></td>
<td>When <code>linenumbers</code> is <code>true</code>, this value defines the number of the first line of code.</td>
</tr>
<tr>
<td><code>collapse</code></td>
<td>No</td>
<td><code>false</code></td>
<td>If <code>true</code>, the code macro’s content will be collapsed upon visiting or refreshing the Confluence page. Clicking the ‘expand source’ link allows you to view the content. If <code>false</code>, the code macro’s content is always displayed in full.</td>
</tr>
</tbody>
</table>

**Example:**

The following example shows all parameters and a body:
Below are three examples of the Code Block macro with various optional parameters used.

<table>
<thead>
<tr>
<th>Description</th>
<th>Markup</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| Code block macro with a body and no optional parameters   | `<ac:structured-macro ac:name="code">
    <ac:plain-text-body>
        <![CDATA[<b>This is my code</b>]]>
    </ac:plain-text-body>
</ac:structured-macro>` | this is my code     |
| Code block macro with a body and the optional `language` parameter defined | `<ac:structured-macro ac:name="code">
    <ac:parameter ac:name="language">xml</ac:parameter>
    <ac:plain-text-body>
        <![CDATA[<b>This is my code</b>]]>
    </ac:plain-text-body>
</ac:structured-macro>` | this is my code     |
## Code block macro

With a body and optional **title**, **line numbers** and **language** parameters defined.

```xml
<ac:structured-macro ac:name="code">
  <ac:parameter ac:name="title">This is my title</ac:parameter>
  <ac:parameter ac:name="linenumbers">true</ac:parameter>
  <ac:parameter ac:name="language">html/xml</ac:parameter>
  <ac:plain-text-body><![CDATA[this is my code]]></ac:plain-text-body>
</ac:structured-macro>
```

This is my title
this is my code

### Column macro

Used with the Section macro to define columns on a page. See [Working with page layouts and columns and sections](#).

**Macro name:** `column`

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>The width of the column. Can be specified either in pixels (for example, 400 px) or as a percentage of the available page width (for example, 50%).</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="column">
  <ac:parameter ac:name="width">100px</ac:parameter>
  <ac:rich-text-body>
    <p>This is the content of <strong>column 1</strong>.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

### Content by Label macro

Displays a list of content associated with specific labels.

**Macro name:** `contentbylabel`
Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>spaces</td>
<td>No</td>
<td>@all</td>
<td>Filters the results by space. The macro will display only the pages and other content types which belong to the space(s) you specify here. You can specify one or more space keys, separated by a comma or a space.</td>
</tr>
</tbody>
</table>

- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of ~BADSPACE you will get only content which is not in the BADSPACE.
- To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:
- `@self` — The current space.
- `@personal` — All personal spaces.
- `@global` — All site spaces.
- `@favorite` — The spaces you have marked as favourite.
- `@favourite` — The same as `@favorite` above.
- `@all` — All spaces in your Confluence site.
- `*` — The same as `@all` above.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as `~jbloggs` or `~jbloggs@example.com`.

<table>
<thead>
<tr>
<th>Filter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>author</td>
<td>No</td>
<td>(None)</td>
<td>Filters the results by author. The macro will display only the pages and other content types which are written or updated by the author(s) you specify here. You can specify one or more authors, separated by a comma. For example: <code>jsmith,jbrown</code> To include content from one user, but exclude from another user: <code>jsmith,!jbrown</code></td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>Adds a heading to the list.</td>
</tr>
<tr>
<td>showLabels</td>
<td>No</td>
<td>true</td>
<td>Determines whether to display the matching labels in the list of results.</td>
</tr>
<tr>
<td>reverse</td>
<td>No</td>
<td>false</td>
<td>Use this parameter in conjunction with the <code>sort</code> parameter. Set <code>reverse=true</code> to change the sort from ascending to descending. This parameter is ignored if the <code>sort</code> parameter is not specified.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Value</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-----------</td>
<td>-------</td>
<td>-------------</td>
<td></td>
</tr>
</tbody>
</table>
| sort      | No    | modified    | Determines how the results are sorted. To change the sort order from ascending to descending, use the `reverse` parameter described above. If this parameter is not specified, the sort order defaults to descending order based on the last modification date. Values:  
- **title** — Sort alphabetically by title.  
- **creation** — Sort by the date on which the content was added.  
- **modified** — Sort by the date on which the content was last updated. |
<p>| max       | No    | 15          | Determines the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied. |
| excerpt   | No    | false       | If this parameter is set to <code>true</code>, the macro displays an excerpt from each page listed in the results. Note that you must define the excerpts on each of those pages, by adding the <code>Excerpt macro</code> to each page. If a particular page does not have an excerpt defined, then the Content by Label macro will not attempt to show an excerpt for that page. The Content by Label macro will show only the first few lines of the excerpt for each page. |</p>
<table>
<thead>
<tr>
<th>labels</th>
<th>Yes</th>
<th>(None)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Use this parameter to filter the results by label. The macro will display only the pages and other content types which are tagged with the label(s) you specify here. See also the operator parameter. You can specify one or more label values, separated by a comma or a space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labelled with 'badpage'.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage, goodpage you will get only content which has at least two labels, being 'superpage' and 'goodpage'.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>showSpace</th>
<th>No</th>
<th>true</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Determines whether to display the spaces in the list of results.</td>
</tr>
</tbody>
</table>
| **type** | No | All | Filters the results by content type. The macro will display only the content of the type you specify here. You can specify one or more types, separated by a comma or a space. To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of -blogpost you will get pages and all other content except for blog posts. Available values:  
  - page — pages.  
  - blogpost or news — blog posts, also known as news items.  
  - attachment — attachments. |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>operator</strong></td>
<td>No</td>
<td>OR</td>
<td>The operator to apply to the supplied lists of labels. By default, a page with any of the non-prefixed labels (that is, labels without a plus (+) or minus (-) sign immediately preceding it) will be listed. If you specify a value of AND, only pages with all of the supplied non-prefixed labels will be listed. Note that this parameter only modifies the behaviour of the 'Label(s)' parameter and only affects label values without a plus (+) or minus (-) sign prefix. To avoid confusion or unexpected results, we recommend that you do not use the <strong>operator</strong> parameter in conjunction with any label values prefixed with '+' or '-' signs.</td>
</tr>
</tbody>
</table>

**Example:**
Content by User macro

Displays a list of the content items that have been created by a specified Confluence user.

**Macro name:** content-by-user

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>Yes</td>
<td>(None)</td>
<td>The Confluence username for the person whose content you wish to display</td>
</tr>
</tbody>
</table>

**Example:**

```
<ac:structured-macro ac:name="content-by-user">
  <ac:parameter ac:name=""/>
  <ri:user ri:userkey="12345678912345678912345678912345"/>
</ac:parameter>
</ac:structured-macro>
```

Content Report Table macro

Displays a set of pages and blog posts in tabular format, based on the labels specified in the macro parameters.

**Macro name:** content-report-table

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>spaces</td>
<td>No</td>
<td>(None)</td>
<td>This parameter is required. Specify one or more labels, separated by a comma. The macro will display only the content tagged with the label(s) specified here.</td>
</tr>
</tbody>
</table>
labels | Yes | (None) | Specify one or more space keys, separated by a comma or a space. The macro will display only the content which belongs to the space(s) specified here.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.

maxResults | No | (None) | Define the maximum number of pages that the macro will show in a single set of results. If there are more pages to be shown, the macro will display a link labelled ‘Find more results’.

Example:

```xml
<ac:structured-macro ac:name="content-report-table">
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="DOC"/>
  </ac:parameter>
  <ac:parameter ac:name="labels">LDAP</ac:parameter>
  <ac:parameter ac:name="analytics-key">meeting-notes</ac:parameter>
  <ac:parameter ac:name="maxResults">5</ac:parameter>
</ac:structured-macro>
```

Contributors macro

Displays a list of Confluence users who have made a contribution of some type to a page.

**Macro name:** contributors

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>limit</td>
<td>No</td>
<td>(None)</td>
<td>Limits the number of contributors displayed in the list.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-----------------</td>
<td>---------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>spaces</td>
<td>No</td>
<td>Specifies the space key of the Confluence space to search. Space keys are case sensitive. Special values: • @global — All site spaces. • @personal — All personal spaces. • @all — All spaces in the Confluence site. You can specify one or more space keys or special values, separated by commas. If no page and labels are specified, all pages from the specified set of spaces are included.</td>
<td></td>
</tr>
<tr>
<td>reverse</td>
<td>No</td>
<td>false                                                                                                                                            Reverses the order of contributors in the list. Must be used in conjunction with the order parameter.</td>
<td></td>
</tr>
<tr>
<td>scope</td>
<td>No</td>
<td>The specified page only                                                                                                                        Specifies additional pages to include when generating the list of contributors. Available values: • children — only the child pages of the specified page. • descendants — all descendants of the specified page.</td>
<td></td>
</tr>
<tr>
<td>labels</td>
<td>No</td>
<td>(None)                                                                                                                                          Limits the list of contributors to those who created the specified labels on a page. You can specify one or more labels, separated by commas.</td>
<td></td>
</tr>
<tr>
<td>showPages</td>
<td>No</td>
<td>false                                                                                                                                          If the value is true, the macro will display a list of the pages used to generate the list of contributors.</td>
<td></td>
</tr>
<tr>
<td>noneFoundMessage</td>
<td>No</td>
<td>&quot;No contributors found for:&quot; (and a summary of selected parameter values)                                                                     Any message given here will override the default message that is displayed when no contributors are found.</td>
<td></td>
</tr>
<tr>
<td>Attribute</td>
<td>Required</td>
<td>Optional Value(s)</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>----------</td>
<td>-------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>showCount</td>
<td>No</td>
<td>false</td>
<td>Determines whether the macro will show the number of times each person made a contribution.</td>
</tr>
<tr>
<td>contentType</td>
<td>No</td>
<td>Both pages and blog posts</td>
<td>Restrictions the content type that the macro will use when generating the list of contributors. Possible values are: <em>pages</em>, <em>blogposts</em>.</td>
</tr>
<tr>
<td>include</td>
<td>No</td>
<td>authors</td>
<td>Filters by either the type of contribution made to a page (and optionally its descendant pages), or the watches on the page. Contribution types are: <em>authors</em> - includes people who created or have edited the page(s), <em>comments</em> - includes people who have added comments to the page(s), <em>labels</em> - includes people who have added labels to the page(s), <em>watches</em> - includes people who are watching the page(s). You can specify one or more contribution types, separated by commas.</td>
</tr>
<tr>
<td>mode</td>
<td>No</td>
<td>inline</td>
<td>Determines how the list of contributors is formatted: <em>inline</em> - a comma-separated list, <em>list</em> - a bullet list.</td>
</tr>
<tr>
<td>showAnonymous</td>
<td>No</td>
<td>false</td>
<td>Determines whether to include those who contributed anonymously to a page.</td>
</tr>
</tbody>
</table>
| order          | No | count          | Specifies the criteria used to sort contributors. Sort criteria are:
|               |    |                | • count – sorts the names based on the total number of contributions to the page(s)
|               |    |                | • name – sorts the names into alphabetical order
|               |    |                | • update – sorts the names by the date of their last contribution to the page(s).

| page          | No | The current page | Specifies the page to use when generating the list of contributors. If page and spaces are left blank, the current page is assumed.
|               |    |                | 

| showLastTime  | No | false          | Determines whether to show the last time each person made a contribution.
|               |    |                | 

| publishDate   | No | (None)         | Specifies the publication date for a blog post. The date format required is: YYYY/MM/DD.
|               |    |                | 

**Example:**

This example specifies a content type of blog posts:

```
<ac:macro ac:name="contributors">
    <ac:parameter ac:name="limit">10</ac:parameter>
    <ac:parameter ac:name="spaces">ds, @personal</ac:parameter>
    <ac:parameter ac:name="reverse">true</ac:parameter>
    <ac:parameter ac:name="labels">chocolate, cake</ac:parameter>
    <ac:parameter ac:name="showPages">true</ac:parameter>
    <ac:parameter ac:name="noneFoundMessage">Oh dear, no contributors found</ac:parameter>
    <ac:parameter ac:name="showCount">true</ac:parameter>
    <ac:parameter ac:name="contentType">blogposts</ac:parameter>
    <ac:parameter ac:name="include">authors, comments, labels, watches</ac:parameter>
    <ac:parameter ac:name="mode">list</ac:parameter>
    <ac:parameter ac:name="showAnonymous">true</ac:parameter>
    <ac:parameter ac:name="order">update</ac:parameter>
    <ac:parameter ac:name="showLastTime">true</ac:parameter>
    <ac:parameter ac:name="publishDate">2012/06/30</ac:parameter>
</ac:macro>
```

This example specifies a content type of pages:

```
<ac:macro ac:name="contributors">
    <ac:parameter ac:name="limit">10</ac:parameter>
    <ac:parameter ac:name="spaces">ds, @personal</ac:parameter>
    <ac:parameter ac:name="reverse">true</ac:parameter>
    <ac:parameter ac:name="labels">chocolate, cake</ac:parameter>
    <ac:parameter ac:name="showPages">true</ac:parameter>
    <ac:parameter ac:name="noneFoundMessage">Oh dear, no contributors found</ac:parameter>
    <ac:parameter ac:name="showCount">true</ac:parameter>
    <ac:parameter ac:name="contentType">blogposts</ac:parameter>
    <ac:parameter ac:name="include">authors, comments, labels, watches</ac:parameter>
    <ac:parameter ac:name="mode">list</ac:parameter>
    <ac:parameter ac:name="showAnonymous">true</ac:parameter>
    <ac:parameter ac:name="order">update</ac:parameter>
    <ac:parameter ac:name="showLastTime">true</ac:parameter>
    <ac:parameter ac:name="publishDate">2012/06/30</ac:parameter>
</ac:macro>
```
Contributors Summary macro

Displays a table of contribution-based statistics for a set of pages.

**Macro name:** contributors-summary

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>limit</td>
<td>No</td>
<td>(None)</td>
<td>Limits the number of contributors or pages displayed in the table.</td>
</tr>
</tbody>
</table>
| spaces         | No       | Current space | Specifies the space key of the Confluence space to search. Space keys are case sensitive. Special values:  
|                |          |         | • @global — All site spaces.  
|                |          |         | • @personal — All personal spaces.  
|                |          |         | • @all — All spaces in the Confluence site.  
|                |          |         | You can specify one or more space keys or special values, separated by commas.  
<p>|                |          |         | If no page and labels are specified, all pages from the specified set of spaces are included. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>reverse</td>
<td>No</td>
<td>false</td>
<td>Reverses the order of items in the table. Must be used in conjunction with the order parameter.</td>
</tr>
<tr>
<td>showAnonymous</td>
<td>No</td>
<td>false</td>
<td>Determines whether to include those who contributed anonymously to a page.</td>
</tr>
</tbody>
</table>
| scope       | No      | The specified page only | Specifies additional pages to include when generating the list of contributors. Available values:  
- children – only the child pages of the specified page.  
- descendants – all descendants of the specified page. |
| order       | No      | edits | Sets the criterion used for sorting items in the table. Available values:  
- edits – sorts items in the table based on the total number of edits made, either by a contributor or to a page.  
- name – sorts items in the table in alphabetical order, either by contributor or page name.  
- editTime – sorts items in the table based on when the contributor last edited a page (or a specified set of pages) or when the page was last edited.  
- update – sorts items in the table based on when the contributor last made any contribution to a page (or a specified set of pages) or when the page last had any contribution made to it. |
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Requirement</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>page</td>
<td>No</td>
<td>The current page</td>
<td>A page title. Specifies the page to use when generating the list of contributors. If <code>page</code> and <code>spaces</code> are left blank, the current page is assumed.</td>
</tr>
<tr>
<td>labels</td>
<td>No</td>
<td>(None)</td>
<td>Limits contribution-based statistics to the specified labels only. You can specify one or more labels, separated by commas.</td>
</tr>
</tbody>
</table>
| columns   | No          | edits, comments, labels | Determines the columns that should appear in the table. The statistics or type of information presented depends on the `groupby` parameter. Available values:<br><ul><li>edits – the number of times each contributor has edited the page(s) or the number of edits made to each page.</li><li>edited – a list of the pages edited by each contributor or a list of contributors who have edited each page.</li><li>comments – the number of times each contributor has added comments to the page(s) or the number of comments on each page.</li><li>commented – a list of pages to which each contributor has added comments or a list of contributors who have commented on each page.</li><li>labels – the number of times each contributor has added labels to the page(s) or the number of labels on each page.</li></ul>
<table>
<thead>
<tr>
<th>groupby</th>
<th>No</th>
<th>contributors</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>specifies the basis for grouping contribution-based statistics:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• contributors – group by the people who have contributed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• pages – group by the pages used to find the contributors.</td>
</tr>
</tbody>
</table>

- **labeled** – a list of pages to which each contributor has added labels or a list of contributors who have added a label to each page.
- **labellist** – a list of labels either added by each contributor or on each page.
- **watches** – the number of pages being watched by each contributor/person or the number of contributors/people watching each page.
- **watching** – a list of pages being watched by each contributor/person or a list of contributors/people watching each page.
- **lastupdate** – the last time each contributor made an update or when each page was last updated. Valid updates can include edits, comments or label modifications to a page.

You can specify one or more columns, separated by commas.
| **contentType** | No | Both pages and blog posts | Restricts the content type that the macro will use when generating the list of contributors. Available values:  
- pages – pages  
- blogposts – blog posts. |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>showZeroCounts</strong></td>
<td>No</td>
<td>false</td>
<td>Determines whether contributors or pages are included for which the calculated statistic is zero.</td>
</tr>
<tr>
<td><strong>publishDate</strong></td>
<td>No</td>
<td>(None)</td>
<td>Specifies the publication date for a blog post. The date format required is: YYYY/MM/DD.</td>
</tr>
</tbody>
</table>

**Example:**

This example specifies a content type of blog posts:

```xml
<ac:structured-macro ac:name="contributors-summary">
  <ac:parameter ac:name="limit">10</ac:parameter>
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="ds"/>
    <ri:space ri:space-key="@personal"/>
  </ac:parameter>
  <ac:parameter ac:name="reverse">true</ac:parameter>
  <ac:parameter ac:name="showAnonymous">true</ac:parameter>
  <ac:parameter ac:name="order">update</ac:parameter>
  <ac:parameter ac:name="labels">chocolate,cake</ac:parameter>
  <ac:parameter ac:name="columns">edits,comments,labels,lastupdate</ac:parameter>
  <ac:parameter ac:name="groupby">pages</ac:parameter>
  <ac:parameter ac:name="contentType">blogposts</ac:parameter>
  <ac:parameter ac:name="showZeroCounts">true</ac:parameter>
  <ac:parameter ac:name="publishDate">2012/06/07</ac:parameter>
</ac:structured-macro>
```

This example specifies a content type of pages:
Create from Template macro

Creates a page from a given template.

**Macro name:** create-from-template

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>templateId</td>
<td>Required for user-created templates</td>
<td>(None)</td>
<td>The ID of a user-created template. This is the unique identifier that Confluence assigns when you create a template. For example, 299630593. To find the ID of a template, edit the template and look at the URL in your browser. The template ID is given in the URL parameter named entityId.</td>
</tr>
<tr>
<td>blueprintModuleCompleteKey</td>
<td>Required for blueprints</td>
<td>(None)</td>
<td>The qualified name of the add-on that defines the blueprint (for example, com.atlassian.confluence.plugins.conffluence-shared-files-plugin:file-list-blueprint).</td>
</tr>
</tbody>
</table>
| **TemplateName** | **Yes** | **(None)** | The ID of a user-created template (for example, 299630593) or the qualified name of the add-on that defines the blueprint (for example, com.atlassian.confluence.plugins.confucence-shared-files-plugin:file-list-blueprint).

| **ButtonLabel** | **Yes** | ‘Create from Template’ | The description that people will seeing when viewing this macro on the page.

| **SpaceKey** | **Yes** | The space where the current page is located | The unique space identifier, to determine where the new page will be created when someone uses this macro to create a page.

| **Title** | **No** | **(None)** | The title for pages created using this macro. You can include @currentDate, @spaceName and @spaceKey variables in the title. This title will override any title specified in a blueprint template.

**Example:**

This example specifies a user-created template:

```
<ac:structured-macro ac:name="create-from-template">
  <ac:parameter ac:name="templateId">299630593</ac:parameter>
  <ac:parameter ac:name="buttonLabel">Blitz test</ac:parameter>
  <ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="DOCTHEME"/>
  </ac:parameter>
  <ac:parameter ac:name="templateName">299630593</ac:parameter>
</ac:structured-macro>
```

This example uses a blueprint:
Create Space Button macro

Displays a create space button linked to the create space page.

**Macro name:** create-space-button

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| size           | No       | large   | Determines the size of the 'create space' icon displayed. Available values:  
|                |          |         |   • large  
|                |          |         |   • small  |
| width          | No       | Natural size of icon (1:1 pixel ratio)  | The width of the icon to be displayed, specified in pixels. Confluence will stretch or shrink the width of the icon to the number of pixels specified.  
|                |          |         | Note: This parameter is not available via the macro browser. |
| height         | No       | Natural size of icon (1:1 pixel ratio)  | The height of the icon to be displayed, specified in pixels. Confluence will stretch or shrink the height of the icon to the number of pixels specified.  
|                |          |         | Note: This parameter is not available via the macro browser. |

**Example:**

```xml
<ac:structured-macro ac:name="create-from-template">
    <ac:parameter ac:name="blueprintModuleCompleteKey">com.atlassian.confluence.plugins.confluence-shared-files-plugin:file-list-blueprint</ac:parameter>
    <ac:parameter ac:name="buttonLabel">Shared files</ac:parameter>
    <ac:parameter ac:name="spaceKey">
        <ri:space ri:space-key="DOCTHEME"/>
    </ac:parameter>
    <ac:parameter ac:name="templateName">com.atlassian.confluence.plugins.confluence-shared-files-plugin:file-list-blueprint</ac:parameter>
</ac:structured-macro>
```
Excerpt Include macro

Allows you to display an excerpt from another page within the current page.

**Macro name:** excerpt-include

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>Yes</td>
<td>(None.)</td>
<td>The name of the page that contains the excerpt to be displayed. To include an excerpt from a page in another space, type the space key followed by a colon (:) and the page name, like this: SPACEKEY:My page name</td>
</tr>
<tr>
<td>nopanel</td>
<td>No</td>
<td>False</td>
<td>Determines whether Confluence will display a panel around the excerpted content. The panel includes the title of the page containing the excerpt, and the border of the panel. By default, the panel and title are shown.</td>
</tr>
</tbody>
</table>

**Example:**

```
<ac:macro ac:name="excerpt-include">
  <ac:parameter ac:name="nopanel">true</ac:parameter>
  <ac:default-parameter>My page name</ac:default-parameter>
</ac:macro>
```
Excerpt macro

Define a part of a page as the page’s 'excerpt' which can then be displayed in another page.

**Macro name:** excerpt

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>hidden</td>
<td>No</td>
<td>False</td>
<td>Determines whether the content of the Excerpt macro body is displayed on the page that contains the Excerpt macro. Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused.</td>
</tr>
</tbody>
</table>
| atlassian-macro-output-type | No       | BLOCK   | Determines whether the content of the Excerpt macro body is displayed on a new line or inline. Available values:  
- BLOCK – Displays the content of the macro on a new line.  
- INLINE – Displays the content of the macro as part of the same paragraph as the text preceding and following it.  
Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused. |

**Example:**

```xml
<ac:structured-macro ac:name="excerpt">
   <ac:parameter ac:name="hidden">true</ac:parameter>
   <ac:parameter ac:name="atlassian-macro-output-type">BLOCK</ac:parameter>
   <ac:rich-text-body>
      <p>This is the <strong>text</strong> I want to reuse in other pages. This text is inside an Excerpt macro.</p>
   </ac:rich-text-body>
</ac:structured-macro>
```

Expand macro
Displays an expandable/collapsible section of text.

**Macro name:** expand

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>No</td>
<td>Click here to expand...</td>
<td>Text that will be displayed on the line that people can click to expand the hidden text.</td>
</tr>
<tr>
<td>(Unnamed in wiki markup)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="expand">
  <ac:parameter ac:name="">This is my message</ac:parameter>
  <ac:rich-text-body>
    <p>This text is <em>hidden</em> until you expand it.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Favourite Pages macro**

Displays a list of your favourite pages.

**Macro name:** favpages

**Macro body:** None.

**Parameters:** None.

**Example:**

```xml
<ac:structured-macro ac:name="favpages"/>
```

**Gadget macro**

Allows you to add Confluence gadgets to pages or blog posts.

**Macro name:** gadget

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Property</td>
<td>Required</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>----------</td>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td>450 pixels</td>
<td>The width of the gadget, using one of the following conventions:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Width in pixels, using <code>px</code> or plain numbers. For example, <code>500px</code> or <code>500</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- A percentage of the page width, using <code>%</code>. For example, <code>50%</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Automatic resizing of the gadget to fit 100% of the page width: <code>auto</code></td>
</tr>
<tr>
<td>border</td>
<td>No</td>
<td>true</td>
<td>Determines whether Confluence will draw a border around the gadget.</td>
</tr>
<tr>
<td>url</td>
<td>Yes</td>
<td>(none.)</td>
<td>This is the location of the gadget specification (XML file).</td>
</tr>
<tr>
<td>preferences</td>
<td>No</td>
<td>(Gadget-dependent.)</td>
<td>Specific property settings that are particular to each gadget.</td>
</tr>
</tbody>
</table>

**A note about editing a gadget’s properties (preferences) in markup:** It is possible to edit the values of these properties directly in the wiki markup or storage format. However, this will allow the entry of invalid values. If a gadget property supports a certain set of values, the macro browser will restrict the user to selecting only valid values for that property. For that reason, we recommend that you use the macro browser to edit a gadget’s properties.

**Example:**

This example shows the Confluence Page gadget:

```xml
<ac:structured-macro ac:name="gadget">
    <ac:parameter ac:name="width">500</ac:parameter>
    <ac:parameter ac:name="border">false</ac:parameter>
    <ac:parameter ac:name="url">rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-page-gadget/gadgets/confluence-page-gadget.xml</ac:parameter>
    <ac:parameter ac:name="preferences">spaceName=Documentation&spaceKey=DOC&quickfind-space=Documentation&pageId=753666&pageName=Documentation%20Home&quickfind-page=Documentation%20Home&isEditable=true&isConfigured=true&refresh=15&amp;showLink=false</ac:parameter>
</ac:structured-macro>
```

This example shows the Confluence News gadget:

```xml
<ac:structured-macro ac:name="gadget">
    <ac:parameter ac:name="url">rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-news-gadget/gadgets/confluence-news-gadget.xml</ac:parameter>
    <ac:parameter ac:name="preferences"/>
</ac:structured-macro>
```
Gallery macro

Forms a thumbnail gallery of all images attached to a page.

**Macro name:** gallery

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>Specify a title to be displayed above your gallery of pictures.</td>
</tr>
</tbody>
</table>
| reverse        | No       | Not specified. Sort order is ascending. | Used in combination with the `sort` parameter, to change the sort order from ascending to descending. Available values:
- **true** – Sort order is descending.
- **false** – Sort order is ascending. |
| sort           | No       | None. The sort order is unspecified and therefore unpredictable. | Specify an attribute to sort the images by. Sort order is ascending, unless you specify the `reverse` parameter. Available values:
- **name** – file name.
- **comment** – comment linked to the attached file.
- **date** – date/time last modified.
- **size** – size of the attached file. |
<p>| page           | No       | If no page is specified, the gallery macro displays the images attached to the page on which the macro is used. | Specify the title of the page which contains the images you want displayed. You can specify more than one page name, separated by commas. To specify a page in a different space, use the following syntax: SPACEKEY:Page title. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>includeLabel</td>
<td>No</td>
<td>None. The images are not filtered by label.</td>
<td>The gallery will include only those pictures that have the specified label. If you wish to enter more than one label, separate the labels with commas. Confluence will show only images that have <strong>all</strong> the labels specified. (The match is an AND, not an OR.) For information on labelling the attachments, see Adding Labels.</td>
</tr>
<tr>
<td>excludeLabel</td>
<td>No</td>
<td>No exclusions. The gallery will include all the pictures on the page.</td>
<td>The gallery will ignore any pictures that have the specified label. You can specify more than one label, separated by commas. For information on labelling the attachments, see Adding Labels.</td>
</tr>
<tr>
<td>columns</td>
<td>No</td>
<td>4</td>
<td>Specify the number of columns for the table that forms the gallery.</td>
</tr>
<tr>
<td>exclude</td>
<td>No</td>
<td>No exclusions. Include all the pictures on the page.</td>
<td>Specify images by file name. The gallery will ignore any images specified. You can specify more than one image, separated by commas. Note: The file name and file type for this parameter are case sensitive. For example, 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
<tr>
<td>include</td>
<td>No</td>
<td>Include all the pictures on the page.</td>
<td>If you specifically include one or more pictures, the gallery will show only those pictures. You can specify more than one picture, separated by commas. Note: The file name and file type for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
</tbody>
</table>

**Example:**
### Global Reports macro

Displays a list of links to global reports within a table.

**Macro name:** global-reports  
**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>99%</td>
<td>Specify the width of the table in which the links are displayed, as a percentage of the window width.</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="global-reports">
  <ac:parameter ac:name="width">50%</ac:parameter>
</ac:structured-macro>
```

### HTML Include macro

Includes the content of an external HTML file into a Confluence page.

**Macro name:** html-include  
**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>url</td>
<td>Yes</td>
<td>(None)</td>
<td>Specify a URL of the content to be included into your Confluence page.</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="html-include">
  <ac:parameter ac:name="url">
    <ri:url ri:value="http://www.example.com"/>
  </ac:parameter>
</ac:structured-macro>
```
HTML macro

Renders your specified HTML code within the current page.

**Macro name:** html

**Macro body:** Text, consisting of HTML code.

**Parameters:** None.

**Example:**

```html
<ac:structured-macro ac:name="html">
  <ac:plain-text-body><![CDATA[<a href="http://www.atlassian.com">Click here</a> to see the <b>Atlassian</b> website.]]></ac:plain-text-body>
</ac:structured-macro>
```

IM Presence macro

Displays graphically when a contact is online.

**Macro name:** im

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| showid         | No       | true    | Determines whether the macro shows or hides the user ID of the contact. Available values:  
  - **true** – User ID is shown on the page.  
  - **false** – User ID is not shown on the page. |
| service        | Yes      | Not specified. | The web service that Confluence should query. Available values:  
  - **aim** – AOL Instant Messenger  
  - **gtalk** – Google Talk  
  - **icq** – ICQ  
  - **jabber** – Jabber  
  - **msn** – MSN Instant Messenger  
  - **sametime** – IBM Lotus Sametime  
  - **skype** – Skype  
  - **skypeme** – Skype  
  - **wildfire** – Openfire Server  
  - **yahoo** – Yahoo! Messenger |
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>Yes</td>
<td>(None.)</td>
<td>The name of the page whose content should be included on the current page</td>
</tr>
<tr>
<td>(Unnamed in wiki markup)</td>
<td></td>
<td></td>
<td>To include content from a page in another space, type the space key followed by a colon (:) and the page name, like this: SPACEKEY:My page name</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>To include a blog post, specify the date as well as the title of the blog post. For example: /2010/12/01/My blog post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>You can include pages from personal spaces using ~username as the space key, where 'username' is the person's username. For example, ~jsmith:My page name.</td>
</tr>
</tbody>
</table>

Example:

```xml
<ac:structured-macro ac:name="im">
  <ac:parameter ac:name="showid">false</ac:parameter>
  <ac:parameter ac:name="service">skype</ac:parameter>
  <ac:parameter ac:name="">MySkypeName</ac:parameter>
</ac:structured-macro>
```
Info macro

Displays a block of text in a blue highlight box.

**Macro name:** info

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>icon</td>
<td>No</td>
<td>true</td>
<td>Determines whether to display the icon in the title bar of the information box.</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the information box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
</tbody>
</table>

**Example:**

The following example shows all parameters and a body:

```xml
<ac:structured-macro ac:name="info">
  <ac:parameter ac:name="icon">false</ac:parameter>
  <ac:parameter ac:name="title">This is my title</ac:parameter>
  <ac:rich-text-body>
    <p>This is <em>important</em> information.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

Below are some examples of the Info macro with various optional parameters used.

<table>
<thead>
<tr>
<th>Description</th>
<th>Markup</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Info macro with a body defined and no optional parameters</td>
<td></td>
<td></td>
</tr>
<tr>
<td>----------------------------------------------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>&lt;ac:structured-macro ac:name=&quot;info&quot;&gt;</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>&lt;ac:rich-text-body&gt;</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>&lt;p&gt;This is &lt;em&gt;important information.&lt;/em&gt;</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>&lt;/ac:structured-macro&gt;</code></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Info macro with a body and an optional Title parameter defined</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;ac:structured-macro ac:name=&quot;info&quot;&gt;</code></td>
</tr>
<tr>
<td><code>&lt;ac:parameter ac:name=&quot;title&quot;&gt;This is my title&lt;/ac:parameter&gt;</code></td>
</tr>
<tr>
<td><code>&lt;ac:rich-text-body&gt;</code></td>
</tr>
<tr>
<td><code>&lt;p&gt;This is &lt;em&gt;important information.&lt;/em&gt;</code></td>
</tr>
<tr>
<td><code>&lt;/ac:structured-macro&gt;</code></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Info macro with a body and optional Title and Icon parameters defined</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;ac:structured-macro ac:name=&quot;info&quot;&gt;</code></td>
</tr>
<tr>
<td><code>&lt;ac:parameter ac:name=&quot;icon&quot;&gt;false&lt;/ac:parameter&gt;</code></td>
</tr>
<tr>
<td><code>&lt;ac:parameter ac:name=&quot;title&quot;&gt;This is my title&lt;/ac:parameter&gt;</code></td>
</tr>
<tr>
<td><code>&lt;ac:rich-text-body&gt;</code></td>
</tr>
<tr>
<td><code>&lt;p&gt;</code></td>
</tr>
<tr>
<td><code>&lt;span&gt;This is &lt;/span&gt;</code></td>
</tr>
<tr>
<td><code>&lt;em&gt;important&lt;/em&gt;</code></td>
</tr>
<tr>
<td><code>&lt;span&gt;information.&lt;/span&gt;</code></td>
</tr>
<tr>
<td><code>&lt;/p&gt;</code></td>
</tr>
<tr>
<td><code>&lt;/ac:rich-text-body&gt;</code></td>
</tr>
<tr>
<td><code>&lt;/ac:structured-macro&gt;</code></td>
</tr>
</tbody>
</table>
JIRA Chart macro

Displays information from JIRA as a pie chart.

**Macro name:** jirachart

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>chartType</td>
<td>Yes</td>
<td>Pie</td>
<td>Type of chart to display. Currently Pie is the only available chart type. Other types may be added in future.</td>
</tr>
<tr>
<td>statType</td>
<td>Yes</td>
<td>Statuses</td>
<td>The JIRA field to segment the pie chart by:</td>
</tr>
</tbody>
</table>
|                |          |         | • statuses - displays a breakdown of issues by Status.  
|                |          |         | • allFixfor - displays a breakdown of issues by chart by all Fix Versions (useful if issues have more than one fix version).  
|                |          |         | • assignees - displays a breakdown of issues by the Assignee name.  
|                |          |         | • priorities - displays a breakdown of issues by Priority.  
|                |          |         | • components - displays a breakdown of issues by Component.  
|                |          |         | • issuetype displays a breakdown of issues by Issue Type.  |
| showinfor      | No       | False   | Displays text information about the data below the chart. Includes the Total value and the Chart By value. |
| jql            | Yes      |         | JQL query for the chart to display. |
| width          | 600      | (blank) | This is the total width of the chart area. Width can be entered in pixels, percent or left blank to fit to the available space. |
| border         | No       | False   | Displays a border around the chart area. |

**Example:**
Example chart by Issue Type - note that Confluence will insert the server and serverId parameters, based on settings in Application Links:

```
<ac:structured-macro ac:name="jirachart">
  <ac:parameter ac:name="chartType">pie</ac:parameter>
  <ac:parameter ac:name="statType">issuetype</ac:parameter>
  <ac:parameter ac:name="showinfor">true</ac:parameter>
  <ac:parameter ac:name="jql">project%20%3D%20CONF%20and%20fixVersion%20in%20('5.3')</ac:parameter>
  <ac:parameter ac:name="width">600</ac:parameter>
  <ac:parameter ac:name="server">JAC</ac:parameter>
  <ac:parameter ac:name="serverId">144880e9-a353-312f-9412-ed028e8166fa</ac:parameter>
  <ac:parameter ac:name="border">true</ac:parameter>
</ac:structured-macro>
```

**JIRA Issues macro**

Displays one or more JIRA issues, and offers the option to create an issue in JIRA.

**Macro name:** jiraissues

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>anonymous</td>
<td>No</td>
<td>false</td>
<td>If this parameter is set to 'true', JIRA will return only the issues which allow unrestricted viewing. That is, the issues which are visible to anonymous viewers, as determined by JIRA's viewing restrictions. If this parameter is omitted or set to 'false', then the results depend on how your administrator has configured the communication between JIRA and Confluence. By default, Confluence will show only the JIRA issues which the user is authorised to view. <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>baseurl</td>
<td>No</td>
<td></td>
<td>The value of the 'url' parameter. If you specify a 'baseurl', then the link in the header, pointing to your JIRA site, will use this base URL instead of the value of the 'url' parameter. This is useful when Confluence connects to JIRA with a different URL from the one used by other users.</td>
</tr>
<tr>
<td>columns</td>
<td>No</td>
<td></td>
<td>By default, the following columns are shown: type, key, summary, assignee, reporter, priority, status, resolution, created, updated, due. A list of JIRA column names, separated by semi-colons (;). You can include any columns recognised by your JIRA site, including custom columns. See the <a href="https://confluence.atlassian.com/jiraxi">JIRA documentation</a> for a list of names.</td>
</tr>
<tr>
<td>count</td>
<td>No</td>
<td>false</td>
<td>If this parameter is set to 'true', the issue list will show the number of issues in JIRA. The count will be linked to your JIRA site.</td>
</tr>
<tr>
<td>cache</td>
<td>No</td>
<td>on</td>
<td>The macro maintains a cache of the issues which result from the JIRA query. If the 'cache' parameter is set to 'off', the relevant part of the cache is cleared each time the macro is reloaded. (The value 'false' also works and has the same effect as 'off'.) <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>---------------</td>
<td>---------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>The height in pixels of the table displaying the JIRA issues. Note that this height specification is ignored in the following situations:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• If the 'renderMode' parameter (see below) is set to 'static'.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• When the JIRA issues are displayed in a PDF or Word document, in an email message or in an RSS feed.</td>
<td></td>
</tr>
<tr>
<td>renderMode</td>
<td>No</td>
<td>If the value is 'dynamic', the JIRA Issues macro offers an interactive display which people can manipulate as follows:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Click the column headers to sort the output.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Drag and drop the columns into a different order.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Temporarily remove a column from the display.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• View a page of issues at a time, for faster response times.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>A value of 'static' will disable the dynamic display features.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
<td></td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Value Example</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
<td>---------------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| title     | No       | JIRA Issues   | You can customise the title text at the top of the JIRA issues table with this parameter. For instance, setting the title to 'Bugs-to-fix' will replace the default 'JIRA Issues' text. This can help provide more context to the list of issues displayed.  
**Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter. |
| url       | Yes      | none          | The URL of the XML view of your selected issues in JIRA Issue Navigator.  
**Note:** If the URL in the 'url' parameter does not contain a `tempMax` argument, then the value of `tempMax` will default to 500. If your JIRA server is version 3.12 or earlier, this means that the JIRA Issues macro will return a maximum of 500 issues. If your JIRA server is version 3.13 or later, a value of 500 means that the JIRA Issues macro will return a maximum of 500 issues per page. |
| width     | No       | 100%          | The width of the table displaying the JIRA issues. Can be indicated either as a percentage (%) or in pixels (px).  
**Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter. |
Example:

Example using a URL that points to the XML view of a JIRA search:

```xml
<ac:structured-macro ac:name="jiraissues">
  <ac:parameter ac:name="anonymous">true</ac:parameter>
  <ac:parameter ac:name="columns">type;key;summary</ac:parameter>
  <ac:parameter ac:name="url">
    <ri:url ri:value="http://jira.atlassian.com/sr/jira.issuеviews:searchrequest-xml/temp/SearchRequest.xml?jqlQuery=project+%3D+CONF+AND+%28summary+%7E+jiraissues+OR+description+%7E+jiraissues+OR+comment+%7E+jiraissues%29&amp;tempMax=10"/>
  </ac:parameter>
</ac:structured-macro>
```

Example using JQL – note that Confluence will insert the server and serverId parameters, based on settings in Application Links:

```xml
<ac:structured-macro ac:name="jira">
  <ac:parameter ac:name="columns">key,summary,type,created,assignee,status</ac:parameter>
  <ac:parameter ac:name="server">Atlassian JIRA</ac:parameter>
  <ac:parameter ac:name="serverId">144880e9-a1111-333f-9412-ed999a9999fa</ac:parameter>
  <ac:parameter ac:name="jqlQuery">project = CONF AND component = documentation AND resolution = unresolved</ac:parameter>
</ac:structured-macro>
```

JUnit Report macro

Display a summary of JUnit test results.

**Macro name:** junitreport

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>directory</td>
<td>Must include either the directory or the url parameter</td>
<td>(None)</td>
<td>URL of a directory containing your test result files. This must be a directory name and not the XML file itself. Overrides the url parameter if you use both. <strong>Note:</strong> When using a local drive, you must use a directory name and not the XML file itself.</td>
</tr>
<tr>
<td>reportdetail</td>
<td>No</td>
<td>all</td>
<td>Level of detail required in the report. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• all</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• fixture</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• summary</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• failuresonly</td>
</tr>
</tbody>
</table>
## url

Must include either the directory or the url parameter

(Nothing)

URL of a particular test result XML file.

This parameter is overridden by the directory parameter if you use both.

For Confluence installations that require authentication, you can specify login credentials as part of this parameter, in the form of URL parameters:

- os_username — The username of a Confluence user with permission to access the JUnit test results.
- os_password — The password of the Confluence user specified in the os_username parameter.

## debug

No

false

If the value of this parameter is true, the report will show the content of failures, as well as the error messages.

### Example:

```xml
<ac:structured-macro ac:name="junitreport">
  <ac:parameter ac:name="reportdetail">summary</ac:parameter>
  <ac:parameter ac:name="directory">
    <ri:url ri:value="http://confluence.com/download/attachments/123/"/>
  </ac:parameter>
  <ac:parameter ac:name="debug">true</ac:parameter>
  <ac:parameter ac:name="url">
    <ri:url ri:value="http://confluence.com/download/attachments/123/file.xml"/>
  </ac:parameter>
</ac:structured-macro>
```

### Labels List macro

Displays a hyperlinked alphabetical index of all labels within the current space.

**Macro name:** listlabels

**Macro body:** None.
spaceKey | No | Current space | The key of the space whose labels you want to display.

Example:

```xml
<ac:structured-macro ac:name="listlabels">
   <ac:parameter ac:name="spaceKey">
      <ri:space ri:space-key="DOC"/>
   </ac:parameter>
   <ac:parameter ac:name="excludedLabels">not-this-label</ac:parameter>
</ac:structured-macro>
```

Livesearch macro

Add a dynamic search box to a wiki page.

**Macro name:** livesearch

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>placeholder</td>
<td>No</td>
<td>(None)</td>
<td>Specify the placeholder text to appear in the search field.</td>
</tr>
<tr>
<td>labels</td>
<td>No</td>
<td>(None)</td>
<td>Specify labels to limit the search to content with that label.</td>
</tr>
<tr>
<td>spaceKey</td>
<td>No</td>
<td>All spaces</td>
<td>Specify a space key to limit the search to the given space.</td>
</tr>
<tr>
<td>type</td>
<td>No</td>
<td>All</td>
<td>Specify the content types to be included in the search - pages, blogs, comments, space descriptions, or all content types.</td>
</tr>
<tr>
<td>size</td>
<td>No</td>
<td>Medium</td>
<td>Specify the size of the search field - medium or large.</td>
</tr>
<tr>
<td>additional</td>
<td>No</td>
<td>Space Name</td>
<td>Display the space name, a page excerpt or none under the search result.</td>
</tr>
</tbody>
</table>

Example:
Loremipsum macro

Display a few paragraphs of pseudo-Latin text.

**Macro name:** loremipsum

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>No</td>
<td>3</td>
<td>Number of paragraphs. Determines the amount of pseudo-Latin (space-filler) text to display. The macro will display a maximum number of 30 paragraphs.</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="loremipsum">
    <ac:parameter ac:name="">2</ac:parameter>
</ac:structured-macro>
```

Multimedia macro

Displays videos, animations and more, sourced from a file attached to a Confluence page and displayed on your page.

**Macro name:** multimedia

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>page</td>
<td>No</td>
<td>Current page</td>
<td>Name of the page to which the multimedia file is attached.</td>
</tr>
<tr>
<td>space</td>
<td>No</td>
<td>Current space</td>
<td>Space key of the page that has the multimedia file attached.</td>
</tr>
<tr>
<td>Parameter name</td>
<td>Required</td>
<td>Default</td>
<td>Parameter description and accepted values</td>
</tr>
<tr>
<td>----------------</td>
<td>----------</td>
<td>---------</td>
<td>-------------------------------------------</td>
</tr>
<tr>
<td>name</td>
<td>Yes</td>
<td>None</td>
<td>File name of the multimedia file, which is attached to a Confluence page.</td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td>If not specified, the browser will determine the width based on the file type.</td>
<td>Width of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's width, or any other value accepted by HTML.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>If not specified, the browser will determine the height based on the file type.</td>
<td>Height of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's height, or any other value accepted by HTML.</td>
</tr>
<tr>
<td>autostart</td>
<td>No</td>
<td>false</td>
<td>If the parameter is set to true then the video or audio file will start playing as soon as the page is loaded. If this option is set to false then the file will not play until the user clicks the icon or image on the page.</td>
</tr>
</tbody>
</table>

Example:

```xml
<ac:structured-macro ac:name="multimedia">
  <ac:parameter ac:name="width">500</ac:parameter>
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="Ninjas.MOV"/>
  </ac:parameter>
</ac:structured-macro>
```

Navigation Map macro

Displays a navigable map of the pages tagged with a given label.

**Macro name:** navmap

**Macro body:** None.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>Yes</td>
<td>(None)</td>
<td>The label that pages must contain to be included in the navigation map.</td>
</tr>
<tr>
<td>wrapAfter</td>
<td>No</td>
<td>5</td>
<td>The number of cells in a row.</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>A title for the navigation map.</td>
</tr>
<tr>
<td>cellHeight</td>
<td>No</td>
<td>60</td>
<td>Height of the cells, in pixels.</td>
</tr>
<tr>
<td>cellWidth</td>
<td>No</td>
<td>90</td>
<td>Width of the cells, in pixels.</td>
</tr>
<tr>
<td>theme</td>
<td>No</td>
<td>(None)</td>
<td>Not applicable to Confluence OnDemand. The name of a Velocity template that defines a theme for the navigation map. The name of your theme file must have the following format: navmap-mytheme.vm, where mytheme is the name of your theme. That is also the value to use for the theme parameter of the macro. For example, if your theme file is navmap-roundededges.vm, use the value roundededges for this parameter. Put your theme file in the confluence/WEB-INF/classes/templates/macros directory, in your Confluence installation. (Create the directory if it does not exist.)</td>
</tr>
</tbody>
</table>

Example:

```html
<ac:structured-macro ac:name="navmap">
    <ac:parameter ac:name="wrapAfter">4</ac:parameter>
    <ac:parameter ac:name="title">My map name</ac:parameter>
    <ac:parameter ac:name="cellHeight">50px</ac:parameter>
    <ac:parameter ac:name="cellWidth">navmap-mytheme.vm</ac:parameter>
    <ac:parameter ac:name="cellWidth">80px</ac:parameter>
    <ac:parameter ac:name="mylabel"/>
</ac:structured-macro>
```
Displays a list of Network activity for users on your Confluence site.

**Macro name:** network

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| default-parameter (Unnamed in wiki markup) | Yes | following | The display mode, which determines the set of users to be listed, based on their relationship to the specified user:  
- following – those whom the user is following.  
- followers – those who are following the user. |
| username | No | Current user's username | The username of the Confluence user whose network interactions you wish to show. |
| max | No | 30 | The maximum number of users to show. If the number of users exceeds the specified maximum, then the macro provides a 'Show All' link. This link leads to the specified user's network view, showing the complete list of network interactions. |
| theme | No | full | Determines how the user's network is displayed:  
- full – Shows a large version of user's profile pictures. If the display mode is set to 'following', the macro offers the option to follow more users.  
- tiny – Shows only the small version of user's profile pictures. |

**Example:**
Noformat macro
Displays a block of text in monospace font.

**Macro name:** noformat

**Macro body:** Accepts plain text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>nopanel</td>
<td>No</td>
<td>false</td>
<td>Determines whether the macro draws a box around the content. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• true – Box is removed. In other words, there is no panel.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• false – Box is drawn. In other words, there is a panel.</td>
</tr>
</tbody>
</table>

**Example:**

```ac:structured-macro ac:name="noformat">
   <ac:parameter ac:name="nopanel">true</ac:parameter>
   <ac:plain-text-body><![CDATA[http://www.example.com]]></ac:plain-text-body>
</ac:structured-macro>
```

Note macro
Displays a block of text in a yellow highlighted box.

**Macro name:** note

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The words that will appear in the header of the note block.</td>
</tr>
<tr>
<td>icon</td>
<td>No</td>
<td>true</td>
<td>Determines whether an icon appears next to the title. The icon is an exclamation mark inside a yellow triangle. Available values:</td>
</tr>
<tr>
<td>------</td>
<td>----</td>
<td>------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
|      |    |      | true – the icon appears  
false – the icon does not appear |

**Example:**

```xml
<ac:structured-macro ac:name="note">
  <ac:parameter ac:name="icon">false</ac:parameter>
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:rich-text-body>
    <p>This is the content of my note.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Office Excel macro**

Displays the content of an Excel spreadsheet on a wiki page.

**Macro name:** viewxls

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the Excel spreadsheet to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the Excel spreadsheet is attached.</td>
</tr>
</tbody>
</table>
### Parameter description and accepted values

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>col</td>
<td>No</td>
<td></td>
<td>The number of the last column you want displayed, starting from '0' as the first column. <strong>Hint for reducing the size of the spreadsheet:</strong> Use the <code>col</code> and <code>row</code> parameters to reduce the size of the spreadsheet displayed on the wiki page. This is especially useful to prevent the display from showing empty cells. This will also help to prevent 'out of memory' errors.</td>
</tr>
<tr>
<td>row</td>
<td>No</td>
<td></td>
<td>The number of the last row you want displayed, starting from '0' as the first row.</td>
</tr>
</tbody>
</table>
| grid           | No       | true    | Determines whether the macro will show borders around the cells in the spreadsheet. Accepted values:  
  - `true` – Shows borders.  
  - `false` – Does not show borders. |
| sheet          | No       |         | The name of the worksheet that you want displayed. |

### Example:

```xml
<ac:structured-macro ac:name="viewxls">
  <ac:parameter ac:name="col">E</ac:parameter>
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="Spreadsheet.xls"/>
  </ac:parameter>
  <ac:parameter ac:name="sheet">Sheet1</ac:parameter>
  <ac:parameter ac:name="row">5</ac:parameter>
</ac:structured-macro>
```

---

### Office PowerPoint macro

Displays the content of a PowerPoint presentation on a wiki page.

**Macro name:** `viewppt`  
**Macro body:** None.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the PowerPoint presentation to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the PowerPoint presentation is attached.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td></td>
<td>The height of the macro display, specified in pixels (for example: 100px, or just 10) or as a percentage (for example: 20%) of the window's height.</td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td></td>
<td>The width of the macro display, specified in pixels (for example: 100px, or just 10) or as a percentage (for example: 20%) of the window's height.</td>
</tr>
<tr>
<td>slide</td>
<td>No</td>
<td>All slides, starting with the first, as a slide show</td>
<td>The number of the slide that you want displayed on the Confluence page, where the first slide is numbered zero. Instead of a slide show, the page will display just the single slide, represented as a JPEG image.</td>
</tr>
</tbody>
</table>

Example:

```xml
<ac:structured-macro ac:name="viewppt">
  <ac:parameter ac:name="height">250</ac:parameter>
  <ac:parameter ac:name="width">250</ac:parameter>
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="101_samplepresentation.pptx"/>
  </ac:parameter>
</ac:structured-macro>
```

Office Word macro

Displays the content of a Word document on a wiki page.

**Macro name:** viewdoc

**Macro body:** None.
### Table: viewdoc Macro Parameters

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the Word document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the Word document is attached.</td>
</tr>
</tbody>
</table>

#### Example:

```xml
<ac:structured-macro ac:name="viewdoc">
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="Chocolate.doc"/>
  </ac:parameter>
</ac:structured-macro>
```

---

**Page Index macro**

Creates a hyperlinked alphabetical index of all page titles within the current space.

**Macro name:** index

**Macro body:** None.

**Parameters:** None.

**Example:**

```xml
<ac:structured-macro ac:name="index"/>
```

---

**Page Properties macro**

Allows you to embed metadata into a page and then display that data in tabular form using the Page Properties Report macro. Previously known as the Metadata Details macro.

**Macro name:** details

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>hidden</td>
<td>No</td>
<td>false</td>
<td>Determines whether the data in the Page Properties macro will be displayed on the current page. This setting does not affect the display of the detail in the Page Properties Report macro.</td>
</tr>
<tr>
<td>label</td>
<td>No</td>
<td>(None)</td>
<td>The label used to identify the metadata on this page. Confluence will add this label to the page.</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="details">
  <ac:parameter ac:name="hidden">true</ac:parameter>
  <ac:parameter ac:name="label">status</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <td style="text-align: left;">Project Status</td>
          <td style="text-align: left;">Complete</td>
        </tr>
        <tr>
          <td style="text-align: left;">Team</td>
          <td style="text-align: left;">Green Parrots</td>
        </tr>
        <tr>
          <td style="text-align: left;">Deadline</td>
          <td style="text-align: left;">2012-09</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Page Properties Report macro**

Presents a tabulated summary of selected metadata, which has been embedded on pages using the Page Properties macro. Previously known as the Details Summary macro.

**Macro name:** detailssummary

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>label</td>
<td>No</td>
<td>(None)</td>
<td>Identifies the metadata to be included in the Page Properties Report. The report will show data from the Page Properties macros on the pages in the current space that have this label on the page.</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="detailssummary">
  <ac:parameter ac:name="label">status</ac:parameter>
</ac:structured-macro>
```
Page Tree macro

Displays a dynamic, hierarchical list of pages starting from a specified parent (root) page.

**Macro name:** pagetree

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| excerpt            | No       | false   | Determines whether the page tree will show excerpts from each page. The excerpts must be defined on the individual pages by the Excerpt macro.  
Available values:  
- **true** – Show excerpts.  
- **false** – Do not show excerpts. |
| expandCollapseAll  | No       | false   | Determines whether the macro will offer the 'expand all' and 'collapse all' options at the top of the page tree. Your readers can click these links to open or close all branches of the tree at once.  
Available values:  
- **true** – Show the 'expand all' and 'collapse all' options.  
- **false** – Do not show the options. |
| reverse            | No       | false   | Used in combination with the sort parameter. Determines the order of pages displayed in the tree, by reversing the default (ascending) order.  
Available values:  
- **true** – Pages will be displayed in descending order by title.  
- **false** – Pages will be displayed in ascending order by title. |
| root | No | The home page of the space | Specifies the parent page for the page tree. The tree will include all children of the given page, plus their children and grand-children, and so on. The tree will *not* include the root page itself. Available values:

- A page title – to specify a page name for the parent or root of the tree. The tree will include all children and grand-children of the specified root. The tree will *not* include the specified root page itself.
- @home – will include all pages under the home page of the space (default).
- @self – will include all pages under the current page.
- @parent – will include all pages under the parent of the current page, including the current page.
- @none – will include all pages in the space, including orphaned pages and the home page. |

| searchBox | No | false | Determines whether the macro will offer a search box above the page tree. The search box allows your readers to enter a search term, and then searches within the page tree for the specified value. Available values:

- true – Include the search box.
- false – Do not include the search box. |
| sort        | No       | position | Determines the order in which pages are displayed in the tree. This sort order is for display purposes only. It does not permanently re-arrange the page order. Available values:
- bitwise - sort alphabetically, for example: title1, title10, title2.
- creation - sort by date of creation.
- modified - sort by order of date last modified.
- natural - sort in 'natural' alphabetical order, for example: title1, title2, title10.
- position - sort by the default Confluence sorting rules. If your pages have been ordered manually, this sort will respect the defined order. Otherwise the pages will be displayed in the 'natural' alphabetical order, such as: title1, title2, title10. |
| startDepth | No       | 1        | Indicates how many levels of children the tree should show when it opens for the first time. Available values: Any number greater than 0. |

Example:
Page Tree Search macro

Adds a search box to your Confluence page and searches a hierarchy of pages starting from a specified parent (root) page.

**Macro name:** pagetreesearch

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>root</td>
<td>No</td>
<td>The home page of the space</td>
<td>Specifies the parent page for the page tree. The tree will include all children of the given page, plus their children and grand-children, and so on. The tree will not include the root page itself.</td>
</tr>
</tbody>
</table>

**Note:** Unlike the Page Tree macro, the Page Tree Search macro does **not** accept the special values that start with an @ sign, such as @home or @self.

**Example:**

```xml
<ac:structured-macro ac:name="pagetreesearch">
  <ac:parameter ac:name="root">My page name</ac:parameter>
</ac:structured-macro>
```

Panel macro

Displays a block of text within a customisable panel.

**Macro name:** panel

**Macro body:** Accepts rich text.
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The words that will appear in the header of the panel.</td>
</tr>
<tr>
<td>borderStyle</td>
<td>No</td>
<td>solid</td>
<td>The style of the panel's border. Accepted values: • solid • dashed • Other valid CSS border styles.</td>
</tr>
<tr>
<td>borderColor</td>
<td>No</td>
<td></td>
<td>The colour of the panel's border. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
<tr>
<td>borderWidth</td>
<td>No</td>
<td></td>
<td>The width of the panel's border, in pixels.</td>
</tr>
<tr>
<td>bgColor</td>
<td>No</td>
<td></td>
<td>The background colour of the panel. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
<tr>
<td>titleBGColor</td>
<td>No</td>
<td></td>
<td>The background colour of the title row of the panel. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
<tr>
<td>titleColor</td>
<td>No</td>
<td></td>
<td>The colour of the text in the title row of the panel. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
</tbody>
</table>

**Example:**

```apl
<ac:structured-macro ac:name="panel">
  <ac:parameter ac:name="bgColor">#72bc72</ac:parameter>
  <ac:parameter ac:name="titleBGColor">#00a400</ac:parameter>
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:parameter ac:name="borderStyle">dashed</ac:parameter>
  <ac:parameter ac:name="borderColor">blue</ac:parameter>
  <ac:parameter ac:name="titleColor">white</ac:parameter>
  <ac:rich-text-body>
    <p>A formatted panel</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**PDF macro**

Displays the content of a PDF document on a wiki page.
**Macro name:** viewpdf

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the PDF document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the PDF document is attached.</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="viewpdf">
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="My_document.pdf"/>
  </ac:parameter>
</ac:structured-macro>
```

**Popular Labels macro**

Displays the most popular labels used throughout your Confluence site or within a space.

**Macro name:** popular-labels

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>style</td>
<td>No</td>
<td>list</td>
<td>Determines how the macro displays the labels. Accepted values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- list – displays the labels as a bullet list, ordered by popularity (highest first).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- heatmap – displays the labels using different font sizes for each label depending on the label’s popularity, ordered alphabetically by label name.</td>
</tr>
<tr>
<td>count</td>
<td>No</td>
<td>100</td>
<td>The number of labels to display.</td>
</tr>
<tr>
<td>spaceKey</td>
<td>No</td>
<td>No restriction – include labels from all spaces in the site</td>
<td>If a space key is given, the macro will include only labels in that space.</td>
</tr>
<tr>
<td>----------</td>
<td>----</td>
<td>-------------------------------------------------------------</td>
<td>-------------------------------------------------------------------</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="popular-labels">
  <ac:parameter ac:name="count">20</ac:parameter>
  <ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="ds"/>
  </ac:parameter>
</ac:structured-macro>
```

**Profile Picture macro**

Displays a user's profile picture on a page.

**Macro name:** profile-picture

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>User</td>
<td>Yes</td>
<td>(None)</td>
<td>The username of a Confluence user.</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="profile-picture">
  <ac:parameter ac:name="User">
    <ri:user ri:userkey="12345678912345678912345"/>
  </ac:parameter>
</ac:structured-macro>
```

**Recently Updated Dashboard macro**

Displays a list of the most recently changed content within Confluence and is intended for use on the Confluence dashboard.

**Macro name:** recently-updated-dashboard

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| **spaces** | No | The space that contains the page on which the macro is added. Filters content by space. The macro will display only the pages and other content which belong to the space(s) you specify here. Accepted values:  
- One or more space keys, separated by commas.  
- An asterisk (*) means all spaces. |
| **users** | No | All users. Filters by username of the user who updated the content. The macro will only display content created and updated by the user(s) you specify here. You can specify one or more usernames separated by commas. |
| **width** | No | 100% The width of the macro display, specified as a percentage of the window width. |
| **showProfilePic** | No | false Determines whether the macro displays profile pictures of the users who updated the content. Accepted values:  
- true – the macro will show profile pictures.  
- false – the macro will not show profile pictures. |
### labels

<table>
<thead>
<tr>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| No       | None. Labels are not used to filter the content. | Filters content by label. The macro will display only the pages and other content which are tagged with the label(s) you specify here. You can specify one or more labels, separated by commas.  
*Note:* If there are no pages matching any of the specified labels, then Confluence will ignore the labels and will list all recently updated pages, as well as showing a message, "These labels don't exist and were ignored: xxx ". |

### types

<table>
<thead>
<tr>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| No       | All content types. | Filters content by type. You can specify one or more types, separated by commas.  
Accepted values:  
- page  
- blogpost or news  
- spacedesc  
- attachment  
- comment  
- mail  
- userinfo |

### Example:

```xml
<ac:structured-macro ac:name="recently-updated-dashboard">
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="ss"/>
  </ac:parameter>
  <ac:parameter ac:name="users">
    <ri:user ri:userkey="12345678912345678912345"/>
  </ac:parameter>
  <ac:parameter ac:name="width">50%</ac:parameter>
  <ac:parameter ac:name="labels">choc</ac:parameter>
  <ac:parameter ac:name="types">page</ac:parameter>
</ac:structured-macro>
```

Recently Updated macro

Displays a list of recently changed content (pages, news items, comments, etc).

**Macro name:** recently-updated

**Macro body:** None.
spaces

<table>
<thead>
<tr>
<th></th>
<th>No</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>The space that contains the page on which the macro is added.</td>
</tr>
</tbody>
</table>

Filters content by space. The macro will display only the pages and other content which belong to the space(s) you specify here. You can specify one or more space keys, separated by a comma or a space.

- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.
- To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>author</td>
<td>No</td>
<td>Filters by the username of the user who updated the content. The macro will only display content created and updated by the user(s) you specify here. You can specify one or more authors, separated by a comma or a space. For example: <code>jsmith, jbrown</code> To include content from one user, but exclude from another user: <code>jsmith, !jbrown</code></td>
</tr>
<tr>
<td>max</td>
<td>No</td>
<td>The maximum number of results to be displayed. The theoretical maximum value that this parameter can accept is 2 to the power of 31, minus 1 (or 2147483647). But this maximum is limited to 200 in the code, for performance reasons. More details are in this issue: CONF-19096</td>
</tr>
<tr>
<td>Property</td>
<td>Default</td>
<td>Value</td>
</tr>
<tr>
<td>----------------</td>
<td>---------</td>
<td>--------</td>
</tr>
</tbody>
</table>
| hideHeading    | No      | false  | Determines whether the macro hides or displays the text 'Recently Updated' as a title above the list of content. Accepted values:  
  - true – Title is hidden.  
  - false – Title is shown. |
| width          | No      | 100%   | The width of the macro display, specified as a percentage of the window width. |
| theme          | No      | concise | Choose the appearance of the macro. Accepted values:  
  - concise – The default list, showing the names of pages which were updated or commented on, the users who made the page modifications, and time when the modifications occurred.  
  - social – Shows recent modifications in reverse chronological order, grouped by user in short time segments. A sub list appears within each user's time segment, showing the names of pages which they updated or commented on and the time when these modifications occurred.  
  - sidebar – Lists recent updates in reverse chronological order, showing the names of pages which were updated or commented on and time when the page modifications occurred. This theme does not show authorship. |
| showProfilePic | No | false | Determines whether the macro displays profile pictures of the users who updated the content. 
Accepted values:
• true – the macro will show profile pictures.
• false – the macro will not show profile pictures. |
| labels | No | None. Labels are not used to filter the content. | Filters content by label. The macro will display only the pages and other content which are tagged with the label(s) you specify here. You can specify one or more labels, separated by commas.

**Note:** If there are no pages matching any of the specified labels, then Confluence will ignore the labels and will list all recently updated pages, as well as showing a message, "These labels don't exist and were ignored: xxx ".

Filter the results by label. The macro will display only the pages etc which are tagged with the label(s) you specify here.

You can specify one or more label values, separated by a comma or a space.

- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of `-badpage` you will get only content which is not labelled with 'badpage'.
- To indicate that the results **must** match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of `+superpage,+goodpage` you will get only content which has at least two labels, being 'superpage' and 'goodpage'. |
<table>
<thead>
<tr>
<th>types</th>
<th>No</th>
<th>All content types.</th>
</tr>
</thead>
</table>

Filters content by type. You can specify one or more types, separated by commas. You can specify one or more types, separated by a comma or a space.

To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of -blogpost you will get pages and all other content except for blog posts.

Available values:

- `page` — Pages.
- `blogpost` or `news` — Blog posts, also known as news items.
- `comment` — Comments on pages and blog posts.
- `attachment` — Attachments.
- `status` — Status updates made by other users.

**Example:**

```xml
<ac:structured-macro ac:name="recently-updated">
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="ss"/>
  </ac:parameter>
  <ac:parameter ac:name="author">
    <ri:user ri:userkey="12345678912345678912345"/>
  </ac:parameter>
  <ac:parameter ac:name="users"/>
  <ac:parameter ac:name="max">10</ac:parameter>
  <ac:parameter ac:name="width">50%</ac:parameter>
  <ac:parameter ac:name="theme">sidebar</ac:parameter>
  <ac:parameter ac:name="labels">choc</ac:parameter>
  <ac:parameter ac:name="types">page</ac:parameter>
</ac:structured-macro>
```

**Recently Used Labels macro**

Lists labels most recently used in a specified scope (global, space, or personal)

**Macro name:** recently-used-labels

**Macro body:** None.
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>None.</td>
<td>Adds a title to the top of the list in table style. Titles are only visible when the style parameter is set to table.</td>
</tr>
</tbody>
</table>
| scope          | No       | global  | The scope of labels to be displayed in the list. Accepted values:  
|                |          |         |    • global – All spaces (non-personal) in the Confluence installation.  
|                |          |         |    • space – The current space.  
|                |          |         |    • personal – Your own personal space. |
| style          | No       | list    | The style of the list of labels:  
|                |          |         |    • list – Displays the list of labels horizontally.  
|                |          |         |    • table – Includes additional information such as the page to which the label was added and the user who added it. |
| count          | No       | 10      | The maximum number of labels to display in the list. |

**Example:**

```xml
<ac:structured-macro ac:name="recently-used-labels">
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:parameter ac:name="scope">space</ac:parameter>
  <ac:parameter ac:name="style">table</ac:parameter>
  <ac:parameter ac:name="count">20</ac:parameter>
</ac:structured-macro>
```

**Related Labels macro**

Lists labels frequently appearing on the same pages as the current page's labels.

**Macro name:** related-labels

**Macro body:** None.
### labels

| labels | No | None | The label(s) for which you want to view related labels. If you include more than one label, separate them with commas. |

#### Example:

```xml
<ac:structured-macro ac:name="related-labels">
  <ac:parameter ac:name="labels">choc,cake</ac:parameter>
</ac:structured-macro>
```

**RSS Feed macro**

Displays the contents of an RSS feed.

**Macro name:** rss

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>max</td>
<td>No</td>
<td>15</td>
<td>The maximum number of news items to display.</td>
</tr>
</tbody>
</table>
| showTitlesOnly | No       | false   | Determines whether the macro will show only the titles of the news items, or the titles plus content. Accepted values:
  * true – Displays titles only.
  * false – Displays titles and content. |
| url            | Yes      | (None)  | The URL of the RSS feed. |
| titleBar       | No       | true    | Determines whether the macro will show a title above the list of news items. Accepted values:
  * true – Displays the title.
  * false – Does not display a title. |

#### Example:

```xml
<ac:structured-macro ac:name="rss">
  <ac:parameter ac:name="url">(None)</ac:parameter>
</ac:structured-macro>
```
Search Results macro

Searches Confluence, and includes the results in the page.

**Macro name:** search

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| lastModified     | No       | (None.)  | Defines a period of time in weeks, days, hours and/or minutes. The macro will display the content modified within that time frame. These are the values you can use:  
|                  |          |          | • w = weeks  
|                  |          |          | • d = days  
|                  |          |          | • h = hours  
|                  |          |          | • m = minutes  
|                  |          |          | For example:  
|                  |          |          | • 2h  35m  
|                  |          |          | • 3d  30m  
|                  |          |          | Notes:  
|                  |          |          | • If no time category is specified, Confluence assumes minutes.  
|                  |          |          | • If you specify more than one time period (for example, weeks and days), you must separate the periods with a space. You can put them in any order.  
<p>|                  |          |          | • The time categories are not case sensitive. For example, '4d' is the same as '4D'. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>query</td>
<td>Yes</td>
<td>(None.)</td>
<td>The search terms which this macro will use to generate its results. You can refine your search query by using operators such as 'AND' and 'OR'. For example: my_term1 AND my_term2. For more information, take a look at the Confluence search syntax.</td>
</tr>
<tr>
<td>contributor</td>
<td>No</td>
<td>(None.)</td>
<td>The username of a Confluence user. If this parameter is present, the macro will show only content created or updated by the given user.</td>
</tr>
<tr>
<td>maxLimit</td>
<td>No</td>
<td>10</td>
<td>The maximum number of search results to display.</td>
</tr>
<tr>
<td>type</td>
<td>No</td>
<td>(None.)</td>
<td>The type of content to include in the search results. Accepted values: page, comment, blogpost, attachment, userinfo, spacedesc.</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="search">
  <ac:parameter ac:name="lastModified">3w</ac:parameter>
  <ac:parameter ac:name="query">choc</ac:parameter>
  <ac:parameter ac:name="contributor">
    <ri:user ri:userkey="1235678912345678912345678912345"/>
  </ac:parameter>
  <ac:parameter ac:name="maxLimit">10</ac:parameter>
  <ac:parameter ac:name="type">page</ac:parameter>
  <ac:parameter ac:name="spacekey">
    <ri:space ri:space-key="ss"/>
  </ac:parameter>
</ac:structured-macro>
```
Used with the Column macro to define columns on a page. See Working with page layouts and columns and sections.

**Macro name:** section

**Macro body:** Rich text, consisting of one or more Column macros.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>border</td>
<td>No</td>
<td>False</td>
<td>If the value is true, the columns in this section will have a dashed border.</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="section">
  <ac:parameter ac:name="border">true</ac:parameter>
  <ac:rich-text-body>
    <ac:structured-macro ac:name="column">
      <ac:parameter ac:name="width">100px</ac:parameter>
      <ac:rich-text-body>
        <p>This is the content of <strong>column 1</strong>.</p>
      </ac:rich-text-body>
    </ac:structured-macro>
    <ac:structured-macro ac:name="column">
      <ac:rich-text-body>
        <p>This is the content of <strong>column 2</strong>.</p>
      </ac:rich-text-body>
    </ac:structured-macro>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Space Attachments macro**

Displays a list of attachments belonging to the current space.

**Macro name:** space-attachments

**Macro body:** None.
**showFilter**  
Yes  
Determines whether or not the filter panel is shown. If you select this option, people viewing the page will be able to filter the list of attachments by file type (extension) and by label.

**space**  
No  
Determines the Confluence space containing the attachments that the macro will display.

### Example:

```<ac:structured-macro ac:name="space-attachments">  <ac:parameter ac:name="showFilter">false</ac:parameter>  <ac:parameter ac:name="space">    <ri:space ri:space-key="ds"/>  </ac:parameter> </ac:structured-macro>```

**Space Details macro**

Displays the details of a Confluence space, including the space name, description, and more.

**Macro name:** `space-details`

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>100%</td>
<td>The width of the space details table, specified as a percentage of the page width.</td>
</tr>
</tbody>
</table>

### Example:

```<ac:structured-macro ac:name="space-details">  <ac:parameter ac:name="width">50%</ac:parameter> </ac:structured-macro>```

**Space Jump macro**

Allows you to link from a page in one space to a page with the same name in another space, without knowing
the name of the page when you create the link.

**Macro name**: spacejump

**Macro body**: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>alias</td>
<td>No</td>
<td>The name of the current page</td>
<td>The text to display as the hyperlinked text.</td>
</tr>
<tr>
<td>space</td>
<td>Yes</td>
<td>(None.)</td>
<td>The key of the space that contains a page with the same name as the current page. Space keys are case sensitive.</td>
</tr>
</tbody>
</table>

**Example:**

```
<ac:structured-macro ac:name="spacejump">
  <ac:parameter ac:name="alias">My Space</ac:parameter>
  <ac:parameter ac:name="space">
    <ri:space ri:space-key="SS"/>
  </ac:parameter>
</ac:structured-macro>
```

**Spaces List macro**

Displays a list of the spaces visible to the user.

**Macro name**: spaces

**Macro body**: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>No</td>
<td>All spaces</td>
<td>Specify the view from which spaces are listed. Accepted values:</td>
</tr>
<tr>
<td>(Unnamed in wiki markup)</td>
<td></td>
<td></td>
<td>- all – All spaces in the Confluence site.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- category – Spaces grouped according to space categories.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- favourite – Spaces in the reader's list of favourites.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- new – Spaces created within the last 7 days.</td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td>100%</td>
<td>The width of the list of spaces, specified as a percentage (%) of the window.</td>
</tr>
</tbody>
</table>
Example:

```xml
<ac:structured-macro ac:name="spaces">
  <ac:parameter ac:name="width">80%</ac:parameter>
  <ac:parameter ac:name=""&&!favourite</ac:parameter>
</ac:structured-macro>
```

Status macro
Displays a coloured lozenge, useful for reporting project status.

**Macro name:** status

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>colour</td>
<td>No</td>
<td>Grey</td>
<td>The colour of the lozenge. Accepted values: Grey, Red, Yellow, Green, Blue</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>The value of the colour parameter</td>
<td>The text that will appear inside the lozenge. If you do not specify any text, the title will be the colour of the lozenge, that is 'Grey', 'Red', 'Yellow', 'Green' or 'Blue'.</td>
</tr>
<tr>
<td>subtle</td>
<td>No</td>
<td>false</td>
<td>The style of the lozenge and its border. Accepted values:</td>
</tr>
</tbody>
</table>

Example:

```xml
<ac:structured-macro ac:name="status">
  <ac:parameter ac:name="colour">Green</ac:parameter>
  <ac:parameter ac:name="title">On track</ac:parameter>
  <ac:parameter ac:name="subtle">true</ac:parameter>
</ac:structured-macro>
```
Table of Contents macro
Displays a table of contents based on the headings on the page.

**Macro name:** toc

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>printable</td>
<td>No</td>
<td>true</td>
<td>If you set this parameter to false, the table of contents will not be visible when you print the page.</td>
</tr>
<tr>
<td>style</td>
<td>No</td>
<td>none</td>
<td>The style of bullet point for each list item. You can use any valid CSS style. For example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• none – No list style is displayed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• circle – The list style is a circle.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• disc – The list style is a filled circle. This is the typical bullet list, and is the one we are using in this example list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• square — The list style is a square.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• decimal — The list is numbered (1, 2, 3, 4, 5).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• lower-alpha — The list style is lower case, alphabetised (a, b, c, d, e).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• lower-roman — The list style is lower-case roman numerals (i, ii, iii, iv, v, vi).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• upper-roman — The list style is upper-case roman numerals (I, II, III, IV, V, VI).</td>
</tr>
<tr>
<td>maxLevel</td>
<td>No</td>
<td>7</td>
<td>Maximum heading level. Use this parameter to select the highest heading level to include. For example, a value of 2 will list h1 and h2 levels, but will not include h3 and below.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>indent</td>
<td>No</td>
<td>(None)</td>
<td>This parameter applies to vertical lists only (type = list). Use this parameter to indent the list items according to CSS quantities. For example, a value of 10px will successively indent list heading groups by 10 pixels. Level 1 headings will be indented 10px, and level 2 headings by an additional 10px, and so on.</td>
</tr>
<tr>
<td>minLevel</td>
<td>No</td>
<td>1</td>
<td>Minimum heading level. The heading level at which the table of contents will start. For example, a value of 2 will list h2, h3, and h4 headings, but will not include h1 headings.</td>
</tr>
<tr>
<td>class</td>
<td>No</td>
<td>(None)</td>
<td>A CSS class name. If you have a custom style sheet, you can use this parameter to output the table of contents with the specified class attribute.</td>
</tr>
<tr>
<td>exclude</td>
<td>No</td>
<td>(None)</td>
<td>Specifies the headings to exclude by pattern matching. The value must be a regular expression. If this parameter is specified, the table of contents will include only the headings that match the regular expression. Example: .* .[1/2] See Sun's Regexp documentation for examples of constructing regular expression strings.</td>
</tr>
</tbody>
</table>
| **type** | No | **list** | Defines the overall format of the table of contents.  
Available values:  
- **list** – displays the table of contents in a vertical list.  
- **flat** – displays a horizontal series of links. For example: [Heading 1] [Heading 2] [Heading 3]. |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>outline</strong></td>
<td>No</td>
<td><strong>false</strong></td>
<td>A value of <strong>true</strong> will apply outline numbering to the headings as displayed in the table of contents. For example: 1.1, 1.2, 1.3.</td>
</tr>
</tbody>
</table>
| **separator** | No | **brackets** | This parameter applies to flat lists only (**type** = **flat**). Use this parameter to style the display of a flat list.  
Available values:  
- **brackets** – Each item is enclosed by square brackets: [].  
- **braces** – Each item is enclosed by braces: {}.  
- **parens** – Each item is enclosed by parentheses: ().  
- **pipe** – The items are separated by a pipe: |  
- **anything** – The items are separated by the value you enter. You can enter any text as a separator, for example “**”**. If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters. |
| include | No | (None) | Specifies the headings to include by pattern matching. The value must be a regular expression. If this parameter is specified, the table of contents will ignore any headings that do not match the regular expression. Example: .* \[1//2\]  
See Sun's Regex documentation for examples of constructing regular expression strings. |

Example:
This example shows a list-type table of contents.

```xml
<ac:structured-macro ac:name="toc">
   <ac:parameter ac:name="printable">true</ac:parameter>
   <ac:parameter ac:name="style">square</ac:parameter>
   <ac:parameter ac:name="maxLevel">2</ac:parameter>
   <ac:parameter ac:name="indent">5px</ac:parameter>
   <ac:parameter ac:name="minLevel">2</ac:parameter>
   <ac:parameter ac:name="class">bigpink</ac:parameter>
   <ac:parameter ac:name="exclude">[1//2]</ac:parameter>
   <ac:parameter ac:name="type">list</ac:parameter>
   <ac:parameter ac:name="outline">true</ac:parameter>
   <ac:parameter ac:name="include">.*</ac:parameter>
</ac:structured-macro>
```

This example shows a flat table of contents.

```xml
<ac:structured-macro ac:name="toc">
   <ac:parameter ac:name="maxLevel">2</ac:parameter>
   <ac:parameter ac:name="minLevel">2</ac:parameter>
   <ac:parameter ac:name="class">bigpink</ac:parameter>
   <ac:parameter ac:name="exclude">[1//2]</ac:parameter>
   <ac:parameter ac:name="type">flat</ac:parameter>
   <ac:parameter ac:name="outline">true</ac:parameter>
   <ac:parameter ac:name="separator">pipe</ac:parameter>
   <ac:parameter ac:name="include">.*</ac:parameter>
</ac:structured-macro>
```

Table of Content Zone macro
Displays a table of contents from a defined page 'zone'.

**Macro name:** toc-zone

**Macro body:** Accepts rich text.
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| location       | Yes      | both    | Determines where the macro will display the table of contents, relative to the zone delineated by the macro. Accepted values:  
  - **top** – The table of contents appears at the start of the zone.  
  - **bottom** – The table of contents appears at the end of the zone.  
  - **both** – The table of contents appears at the start and end of the zone. |
| printable      | No       | true    | If you set this parameter to `false`, the table of contents will not be visible when you print the page. |
| Style | No | none | The style of bullet point for each list item. You can use any valid CSS style. For example:  
- none – No list style is displayed.  
- circle – The list style is a circle.  
- disc – The list style is a filled circle. This is the typical bullet list, and is the one we are using in this example list.  
- square – The list style is a square.  
- decimal – The list is numbered (1, 2, 3, 4, 5).  
- lower-alpha – The list style is lower case, alphabetised (a, b, c, d, e).  
- lower-roman – The list style is lower-case roman numerals (i, ii, iii, iv, v, vi).  
- upper-roman – The list style is upper-case roman numerals (I, II, III, IV, V, VI). |
| MaxLevel | No | 7 | Maximum heading level. Use this parameter to select the highest heading level to include. For example, a value of 2 will list h1 and h2 levels, but will not include h3 and below. |
| Indent | No | (None) | This parameter applies to vertical lists only (type = list).  
Use this parameter to indent the list items according to CSS quantities. For example, a value of 10px will successively indent list heading groups by 10 pixels. Level 1 headings will be indented 10px, and level 2 headings by an additional 10px, and so on. |
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>minLevel</td>
<td>No</td>
<td>Minimum heading level. The heading level at which the table of contents will start. For example, a value of 2 will list h2, h3, and h4 headings, but will not include h1 headings.</td>
</tr>
<tr>
<td>class</td>
<td>No</td>
<td>A CSS class name. If you have a custom style sheet, you can use this parameter to output the table of contents with the specified class attribute.</td>
</tr>
<tr>
<td>exclude</td>
<td>No</td>
<td>Specifies the headings to exclude by pattern matching. The value must be a regular expression. If this parameter is specified, the table of contents will include only the headings that match the regular expression. Example: .* .(1//2) See Sun's Regex documentation for examples of constructing regular expression strings.</td>
</tr>
<tr>
<td>type</td>
<td>No</td>
<td>Defines the overall format of the table of contents.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• list – displays the table of contents in a vertical list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• flat – displays a horizontal series of links. For example: [Heading 1] [Heading 2] [Heading 3].</td>
</tr>
<tr>
<td>outline</td>
<td>No</td>
<td>A value of true will apply outline numbering to the headings as displayed in the table of contents. For example: 1.1, 1.2, 1.3.</td>
</tr>
<tr>
<td>separator</td>
<td>No</td>
<td>brackets</td>
</tr>
<tr>
<td>-----------</td>
<td>----</td>
<td>----------</td>
</tr>
</tbody>
</table>
|           |    | This parameter applies to flat lists only (`type = flat`). Use this parameter to style the display of a flat list. Available values:  
|           |    | - `brackets` – Each item is enclosed by square brackets: `[ ]`.  
|           |    | - `braces` – Each item is enclosed by braces: `{ }`.  
|           |    | - `parens` – Each item is enclosed by parentheses: `()`.  
|           |    | - `pipe` – The items are separated by a pipe: `|`.  
|           |    | - `anything` – The items are separated by the value you enter. You can enter any text as a separator, for example `***`. If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters. |

<table>
<thead>
<tr>
<th>include</th>
<th>No</th>
<th>(None)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Specifies the headings to include by pattern matching. The value must be a regular expression. If this parameter is specified, the table of contents will ignore any headings that do not match the regular expression. Example: <code>.* \.\{1/2\}</code></td>
</tr>
</tbody>
</table>

See [Sun’s Regex documentation](https://docs.oracle.com/javase/7/docs/api/java/util/regex/package-summary.html) for examples of constructing regular expression strings.

Example:
Tasklist macro

Displays a dynamic task list which can be modified in view mode.

**Macro name:** tasklist

**Macro body:** Accepts wiki markup, for defining the tasks.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>Task List</td>
<td>The title to be displayed above the list of tasks.</td>
</tr>
</tbody>
</table>
| enableLocking       | No       | false   | Determines whether the macro allows users to lock individual tasks so that they cannot be changed. Accepted values:  
  - `true` – The task list offers the option to lock tasks.  
  - `false` – There is no option to lock a task. |
| width               | No       | 530px   | The width of the task list, specified in pixels (for example: `200px`) or as a percentage of page width (for example: `20%`). |
| promptOnDelete      | No       | false   | Determines whether Confluence will ask the user to confirm the deletion of a task. Accepted values:  
  - `true` – Asks for confirmation before deleting a task.  
  - `false` – Deletes the task without asking for confirmation. |
Example:

**Note:** The \texttt{CDATA} content inside the macro body defines the tasks in the list. This content is coded in wiki markup, as a table. The first row in the table defines the column headings for the task list. Each subsequent row defines a task.

```xml
<ac:structured-macro ac:name="tasklist">
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:parameter ac:name="enableLocking">true</ac:parameter>
  <ac:parameter ac:name="width">20%</ac:parameter>
  <ac:parameter ac:name="promptOnDelete">true</ac:parameter>
  <ac:plain-text-body><![CDATA[||Completed||Priority||Locked||CreatedDate||CompletedDate||Assignee||Name||
|F|M|F|1371784117215|          |admin|Book tickets|
|F|M|F|1371784127222|          |admin|Check passport expiry|
]]></ac:plain-text-body>
</ac:structured-macro>

**Tip macro**

Displays a block of text in a green box.

**Macro name:** \texttt{tip}

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>icon</td>
<td>No</td>
<td>true</td>
<td>Determines whether to display the standard Confluence tip icon in the title bar of the tip box.</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the tip box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="tip">
  <ac:parameter ac:name="icon">false</ac:parameter>
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:rich-text-body>
    <p>This is my hint.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**User List macro**

Displays a list of Confluence users in a given group.

**Macro name:** \texttt{userlister}

**Macro body:** None.
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| groups         | Yes      | (None.) | One or more groups containing the Confluence users that the macro will list. Accepted values:  
- A comma-separated list of group names.  
- *(an asterisk – The macro will list all users registered on the Confluence site.)* |

An additional parameter is available to indicate whether a user is online. In order to make this parameter functional, a System Administrator needs to enable the User Log In Listener for your Confluence site.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| online         | No       | All users | Instructs the macro to differentiate between online and offline users. Accepted values:  
- Unspecified – The macro will show all registered users.  
- true – The macro will show only online users.  
- false – The macro will show only offline users.  
**Note:** In order to make this parameter functional, a System Administrator needs to enable the User Log In Listener for your Confluence site. *Not applicable to Confluence OnDemand.* |

Example:

```
<ac:structured-macro ac:name="userlister">
  <ac:parameter ac:name="groups">confluence-users</ac:parameter>
  <ac:parameter ac:name="online">false</ac:parameter>
</ac:structured-macro>
```

User Profile macro

Displays a summary of a given Confluence user's profile.
**Macro name:** profile

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>user</td>
<td>Yes</td>
<td>(None.)</td>
<td>The username of the Confluence user whose profile summary you wish to show.</td>
</tr>
</tbody>
</table>

**Example:**

```
<ac:structured-macro ac:name="profile">
  <ac:parameter ac:name="user">
    <ri:user ri:userkey="12345678912345678912345678912345"/>
  </ac:parameter>
</ac:structured-macro>
```

**User Status List macro**

Displays a history of a given Confluence user's status updates.

**Macro name:** status-list

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>username</td>
<td>Yes</td>
<td>(None.)</td>
<td>The username of the Confluence user whose status updates you wish to show.</td>
</tr>
</tbody>
</table>

**Example:**

```
<ac:structured-macro ac:name="status-list">
  <ac:parameter ac:name="username">
    <ri:user ri:userkey="12345678912345678912345678912345"/>
  </ac:parameter>
</ac:structured-macro>
```

**Warning macro**

Displays a block of text in a red highlight box.

**Macro name:** warning

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>icon</td>
<td>No</td>
<td>true</td>
<td>Determines whether to display a warning icon in the title bar of the text box.</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>(None.)</td>
<td>The title of the warning box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="warning">
   <ac:parameter ac:name="icon">false</ac:parameter>
   <ac:parameter ac:name="title">This is my title</ac:parameter>
   <ac:rich-text-body>
      <p>This is <em>important</em> information.</p>
   </ac:rich-text-body>
</ac:structured-macro>
```

**Widget Connector macro**

Displays videos, slide shows, twitter chats, documents and more, sourced from other web sites and displayed on your Confluence page.

**Macro name:** widget

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>height</td>
<td>No</td>
<td></td>
<td>The height of the display, in pixels. Specify the number of pixels only.</td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td></td>
<td>The width of the display, in pixels. Specify the number of pixels only.</td>
</tr>
<tr>
<td>url</td>
<td>Yes</td>
<td>(None.)</td>
<td>The URL provided by the external website for embedding content from that website onto another web page.</td>
</tr>
</tbody>
</table>

**Example:**

```xml
<ac:structured-macro ac:name="widget">
   <ac:parameter ac:name="height">480</ac:parameter>
   <ac:parameter ac:name="width">640</ac:parameter>
   <ac:parameter ac:name="url">
      <ri:url ri:value="http://youtube.com/watch?v=23pLByj_q5U"/>
   </ac:parameter>
</ac:structured-macro>
```

**Macro format notes**

**Macro bodies**

Some macros accept a body as well as parameters.

- The Info macro and Expand macro are examples of macros that accept a rich text body.
- The Code Block macro is a good example of a macro that accepts a plain text body.
Plain text bodies

The body of a plain text macro must be inside a CDATA block. So the following is not sufficient:

```
<ac:plain-text-body>text</ac:plain-text-body>
```

The correct usage is:

```
<ac:plain-text-body><![CDATA[text]]></ac:plain-text-body>
```

Other notes

- The 'Required' column indicates whether the parameter is required on data entry. If the parameter is not supplied, Confluence will insert default values as indicated in the 'Default' column.
- **A request from the Atlassian technical writers about comments and feedback**: When adding comments to this page, please restrict your comments to constructive feedback on the documentation itself: Things we've missed in the documentation, and things that will be useful to other readers. If you have other feedback about the editor, wiki markup, the XML storage format, and Confluence 4 in general, please add your comments in the section titled Confluence 4 Editor - Customer Feedback, and its child pages. Our reason for this request: When a page attracts a large number of comments, it makes it difficult for everyone to read the page, and to add or respond to comments about the documentation. Thanks. 😊

Confluence Storage Format Examples for Chart Macro

This page is an extension of Confluence Storage Format for Macros, which contains storage format examples for all Confluence macros. The Chart macro is a special case, because it offers so many options via parameters and chart types. This page offers additional examples for the Chart macro.

Pie chart

Here is a simple example of a pie chart.

Storage format
**Resulting chart**

<table>
<thead>
<tr>
<th>Fish Type</th>
<th>2004</th>
<th>2005</th>
</tr>
</thead>
<tbody>
<tr>
<td>Herring</td>
<td>9,500</td>
<td>8,300</td>
</tr>
<tr>
<td>Salmon</td>
<td>2,900</td>
<td>4,200</td>
</tr>
<tr>
<td>Tuna</td>
<td>1,500</td>
<td>1,500</td>
</tr>
</tbody>
</table>
Fish Sold

![Bar chart example](image)

<table>
<thead>
<tr>
<th>Year</th>
<th>2004 (1,500 - 50%)</th>
<th>2005 (1,500 - 50%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>2004</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2005</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Bar chart**

Here is a simple example of a bar chart.

**Storage format**
<ac:macro ac:name="chart">
  <ac:parameter ac:name="title">Fish Sold</ac:parameter>
  <ac:parameter ac:name="type">bar</ac:parameter>
  <ac:rich-text-body>
  <table>
    <tbody>
      <tr>
        <th>Fish Type</th>
        <th>2004</th>
        <th>2005</th>
      </tr>
      <tr>
        <th>Herring</th>
        <td>9,500</td>
        <td>8,300</td>
      </tr>
      <tr>
        <th>Salmon</th>
        <td>2,900</td>
        <td>4,200</td>
      </tr>
      <tr>
        <th>Tuna</th>
        <td>1,500</td>
        <td>1,500</td>
      </tr>
    </tbody>
  </table>
  </ac:rich-text-body>
</ac:macro>

Resulting chart
Here is an example of a time series chart.

### Time series chart

Storage format

```xml
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="timePeriod">Month</ac:parameter>
  <ac:parameter ac:name="dataOrientation">vertical</ac:parameter>
  <ac:parameter ac:name="rangeAxisLowerBound">0</ac:parameter>
  <ac:parameter ac:name="dateFormat">MM/yyyy</ac:parameter>
  <ac:parameter ac:name="type">timeSeries</ac:parameter>
  <ac:parameter ac:name="domainaxisrotateticklabel">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <thead>
        <tr>
          <th>Month</th>
          <th>Revenue</th>
        </tr>
      </thead>
      <tbody>
        <tr>
          <td>1/2005</td>
          <td>31.8</td>
        </tr>
        <tr>
          <td>2/2005</td>
          <td>41.8</td>
        </tr>
        <tr>
          <td>3/2005</td>
          <td></td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```
<table>
<thead>
<tr>
<th>Date</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>4/2005</td>
<td>51.3</td>
</tr>
<tr>
<td>5/2005</td>
<td>33.8</td>
</tr>
<tr>
<td>6/2005</td>
<td>27.6</td>
</tr>
<tr>
<td>7/2005</td>
<td>49.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>9/2005</td>
<td>77.3</td>
</tr>
<tr>
<td>10/2005</td>
<td>73.8</td>
</tr>
<tr>
<td></td>
<td>97.6</td>
</tr>
<tr>
<td>Month</td>
<td>Expenses</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
</tr>
<tr>
<td>1/2005</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>45.0</td>
</tr>
<tr>
<td>5/2005</td>
<td></td>
</tr>
<tr>
<td>Month</td>
<td>Value</td>
</tr>
<tr>
<td>-------------</td>
<td>-------</td>
</tr>
<tr>
<td>6/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>52.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>53.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>55.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>61.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>63.7</td>
</tr>
</tbody>
</table>
Resulting chart

Here is an example of an XY line chart.

Storage format
<table>
  <tbody>
    <tr>
      <th>&nbsp;</th>
      <th>12</th>
      <th>14</th>
      <th>23</th>
    </tr>
    <tr>
      <td>Revenue</td>
      <td>41.1</td>
      <td>31.8</td>
      <td>12.4</td>
    </tr>
    <tr>
      <td>Expense</td>
      <td>31.1</td>
      <td>41.8</td>
      <td>43.6</td>
    </tr>
  </tbody>
</table>

Resulting chart
XY bar chart

Here is an example of an XY bar chart.

Storage format
<ac:structured-macro ac:name="chart">
<ac:parameter ac:name="opacity">60</ac:parameter>
<ac:parameter ac:name="type">xybar</ac:parameter>
<ac:rich-text-body>
<table>
<tbody>
<tr>
<th></th>
<th>2005</th>
<th>2006</th>
<th>2007</th>
</tr>
<tr>
<td>Revenue</td>
<td>41.1</td>
<td>31.8</td>
<td>12.4</td>
</tr>
<tr>
<td>Expense</td>
<td>31.1</td>
<td>41.8</td>
<td>43.6</td>
</tr>
</tbody>
</table>
</ac:rich-text-body>
</ac:structured-macro>

Resulting chart
**XY area chart**

Here is an example of an XY area chart.

**Storage format**
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="type">xyarea</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th></th>
          <th>12</th>
          <th>14</th>
          <th>23</th>
        </tr>
        <tr>
          <td><p>Revenue</p></td>
          <td>41.1</td>
          <td>31.8</td>
          <td>12.4</td>
        </tr>
        <tr>
          <td><p>Expense</p></td>
          <td>31.1</td>
          <td>41.8</td>
          <td>43.6</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>

Resulting chart
Here are two examples of area charts.

Storage format for area chart 1

```html
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="height">300</ac:parameter>
  <ac:parameter ac:name="legend">true</ac:parameter>
  <ac:parameter ac:name="width">300</ac:parameter>
  <ac:parameter ac:name="opacity">50</ac:parameter>
  <ac:parameter ac:name="type">area</ac:parameter>
  <ac:parameter ac:name="dataDisplay">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th>Satisfaction</th>
          <th>2002</th>
          <th>2003</th>
          <th>2004</th>
        </tr>
        <tr>
          <td>Very satisfied</td>
          <td>20</td>
          <td>23</td>
          <td>34</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```
<table>
<thead>
<tr>
<th>Category</th>
<th>Count</th>
</tr>
</thead>
<tbody>
<tr>
<td>Satisfied</td>
<td>40</td>
</tr>
<tr>
<td>Disatisfied</td>
<td>25</td>
</tr>
<tr>
<td>Very disatisfied</td>
<td>15</td>
</tr>
</tbody>
</table>
Resulting area chart 1

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
<td>34</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>

Storage format for area chart 2
<tr>
<td>
<p>Very satisfied</p>
</td>
<td>
12</td>
<td>
23</td>
<td>
31</td>
</tr>
<tr>
<td>
<p>Satisfied</p>
</td>
<td>
1</td>
<td>
34</td>
<td>
36</td>
</tr>
<tr>
<td>
<p>Disatisfied</p>
</td>
<td>
4</td>
<td>
6</td>
<td>
22</td>
</tr>
<tr>
<td>
<p>Very disatisfied</p>
</td>
<td>
2</td>
<td>
7</td>
<td>
12</td>
</tr>
</tbody>
Confluence Wiki Markup

This page describes the wiki markup used on some administration screens in Confluence. Another page describes the wiki markup for macros.

Wiki markup is useful when you want to do one of the following:
- Configure the Documentation theme.
- Type wiki markup directly into the editor. Confluence will convert it to the rich text editor format as you type.
- Create links using the Advanced tab of the Links Browser.
- Insert a block of wiki markup into the Confluence editor. (Choose Insert > Wiki Markup.)

Note: You cannot edit content in wiki markup. Confluence does not store page content in wiki markup. Although you can enter wiki markup into the editor, Confluence will convert it to the rich text editor format immediately. You will not be able to edit the wiki markup after initial entry.

A request from the Atlassian technical writers about comments and feedback: When adding comments to this page, please restrict your comments to constructive feedback on the documentation itself: Things we’ve missed in the documentation, and things that will be useful to other readers. If you have other feedback about the editor, wiki markup, the XML storage format, and Confluence 4 in general, please add your comments in the section titled Confluence 4 Editor - Customer Feedback, and its child pages. Our reason for this request: When a page attracts a large number of comments, it makes it difficult for everyone to read the page, and to add or respond to comments about the documentation. Thanks. 😊

Can I type wiki markup into the editor?

Yes. You can type wiki markup directly into the editor, and Confluence will convert it as you type. (You cannot edit the wiki markup after conversion.) See it in action in this video:

Confluence Wiki Markup

This page describes the wiki markup used on some administration screens in Confluence. Another page describes the wiki markup for macros.

Wiki markup is useful when you want to do one of the following:
- Configure the Documentation theme.
- Type wiki markup directly into the editor. Confluence will convert it to the rich text editor format as you type.
- Create links using the Advanced tab of the Links Browser.
- Insert a block of wiki markup into the Confluence editor. (Choose Insert > Wiki Markup.)

Note: You cannot edit content in wiki markup. Confluence does not store page content in wiki markup. Although you can enter wiki markup into the editor, Confluence will convert it to the rich text editor format immediately. You will not be able to edit the wiki markup after initial entry.

A request from the Atlassian technical writers about comments and feedback: When adding comments to this page, please restrict your comments to constructive feedback on the documentation itself: Things we’ve missed in the documentation, and things that will be useful to other readers. If you have other feedback about the editor, wiki markup, the XML storage format, and Confluence 4 in general, please add your comments in the section titled Confluence 4 Editor - Customer Feedback, and its child pages. Our reason for this request: When a page attracts a large number of comments, it makes it difficult for everyone to read the page, and to add or respond to comments about the documentation. Thanks. 😊

Can I type wiki markup into the editor?

Yes. You can type wiki markup directly into the editor, and Confluence will convert it as you type. (You cannot edit the wiki markup after conversion.) See it in action in this video:
Read this blog post for more examples: 12 Things You Didn’t Know About the Confluence Editor.

On this page:
- Can I type wiki markup into the editor?
- Headings
- Lists
- Tables
- Text Effects
- Text Breaks
- Links
- Images
- Page Layouts
- Useful Information

Related pages:
- Confluence Wiki Markup for Macros
- Confluence User's Guide

Headings
To format a line as a heading, type "hn." at the start of your line, where n can be a number from 1 to 6.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>h1. Biggest heading</td>
<td>Biggest heading</td>
</tr>
<tr>
<td>h3. Big heading</td>
<td>Big heading</td>
</tr>
<tr>
<td>h5. Small heading</td>
<td>Small heading</td>
</tr>
</tbody>
</table>

Lists
Wiki markup allows you to create bulleted or numbered lists, and is flexible enough to allow a combination of the two list types.

Important: If you need to separate the text within lists using line breaks, make sure you do so using a double slash (/\). Empty lines may disrupt the list.

Simple lists
Use the hyphen (-) to create simple lists.
Make sure there is a space between the hyphen and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>- some</td>
<td>• some</td>
</tr>
<tr>
<td>- bullet</td>
<td>• bullet</td>
</tr>
<tr>
<td>- points</td>
<td>• points</td>
</tr>
</tbody>
</table>

Bulleted lists
Use the asterisk (*) to create bullets. For each subsequent level, add an extra asterisk.
Make sure there is a space between the asterisk and your text.
### What you need to type | What you will get
---|---
* some
* bullet
** indented
** bullets
* points

### Numbered lists

Use the hash (#) to create numbered lists. Make sure there is a space between the hash and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| # a  
# numbered  
# list | 1. a  
2. numbered  
3. list |

A second level of hashes will produce a sub-list, such as the **alphabetical** sub-list shown below.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| # Here's a sentence.  
## This is a sub-list point.  
## And a second sub-list point.  
# Here's another sentence. | 1. Here's a sentence.  
a. This is a sub-list point.  
b. And a second sub-list point.  
2. Here's another sentence. |

You can use a third level of hashes to produce a sub-sub-list.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| # Here's a sentence.  
## This is a sub-list point.  
### Third list level.  
### Another point at the third level.  
## And a second sub-list point.  
# Here's another sentence. | 1. Here's a sentence.  
a. This is a sub-list point.  
i. Third list level.  
ii. Another point at the third level.  
b. And a second sub-list point.  
2. Here's another sentence. |

**Note:** In numbered lists as described above, the format of the 'number' displayed at each list level may be different, depending upon your browser and the style sheets installed on your Confluence instance. So in some cases, you may see letters (A, B, C, etc; or a, b, c, etc) or Roman numerals (i, ii, iii, etc) at different list levels.

### Mixed lists

| What you need to type | What you will get |
Tables

You can create two types of tables.

**Table Type 1**

Allows you to create a simple table with an optional header row. You cannot set the width of the columns in this table.

Use double bars for a table heading row.

**What you need to type:**

```
||heading 1||heading 2||heading 3||
|cell A1|cell A2|cell A3|
|cell B1|cell B2|cell B3|
```

**What you will get:**

<table>
<thead>
<tr>
<th>heading 1</th>
<th>heading 2</th>
<th>heading 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>cell A1</td>
<td>cell A2</td>
<td>cell A3</td>
</tr>
<tr>
<td>cell B1</td>
<td>cell B2</td>
<td>cell B3</td>
</tr>
</tbody>
</table>

You can also use a vertical header.

**What you need to type:**

```
||heading 1|col A1|col A2|col A3||
|heading 2|col B1|col B2|col B3||
```

**What you will get:**

<table>
<thead>
<tr>
<th>heading 1</th>
<th>col A1</th>
<th>col A2</th>
<th>col A3</th>
</tr>
</thead>
<tbody>
<tr>
<td>heading 2</td>
<td>col B1</td>
<td>col B2</td>
<td>col B3</td>
</tr>
</tbody>
</table>

**Table Type 2**

This method allows you to specify the width of the columns in the table.

**What you need to type**
Advanced Formatting

Colour and Other Formatting

To add colour and other formatting to your tables, you can use the Panel Macro within columns. More table-formatting options may be available if your Confluence administrator has installed additional macros.

Lists

Here’s an example of how to embed lists in a table:

What you need to type

<table>
<thead>
<tr>
<th></th>
<th>Heading 1</th>
<th>Heading 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>Item 1</td>
<td>1. Item 1</td>
</tr>
<tr>
<td>*</td>
<td>Item 2</td>
<td>2. Item 2</td>
</tr>
<tr>
<td>*</td>
<td>Item 3</td>
<td>3. Item 3</td>
</tr>
</tbody>
</table>

What you will get

<table>
<thead>
<tr>
<th>Heading 1</th>
<th>Heading 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item 1</td>
<td>1. Item 1</td>
</tr>
<tr>
<td>Item 2</td>
<td>2. Item 2</td>
</tr>
<tr>
<td>Item 3</td>
<td>3. Item 3</td>
</tr>
</tbody>
</table>

Text Effects

Use the markup shown in the examples below to format text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>strong</em></td>
<td>strong</td>
</tr>
<tr>
<td><em>bold text</em></td>
<td>bold text</td>
</tr>
<tr>
<td><em>emphasis</em></td>
<td>emphasis</td>
</tr>
</tbody>
</table>
| _italics_ | *italics*  
|----------|---  
| **Hint:** To italicise parts of a word, add braces (curly brackets) around the underscore. For example,  
| Thing(_)_x_ | gives you this: Thingx  
| ??citation?? | —citation  
| -deleted- | deleted  
| +inserted+ | inserted  
| **Text with^superscript^** | **Text with**superscript  
| **Hint:** There are two ways to make superscripts work, when used directly after another word or character:  
| • Add a space before the superscript. For example,  
| kg/m ^3^ | gives you this: kg/m³  
| • Add braces (curly brackets) around the superscript markup. For example,  
| kg/m{^3^} | gives you this: kg/m³  
| **Text with~subscript~** | **Text with**subscript  
| **{monospaced}** | monospaced  
| **bq. Here's how you make a paragraph appear as a block quotation.** | **Here's how you make a paragraph appear as a block quotation.**  
| *(color: red)*look ma, red text!*(color)* | look ma, red text!  

**Text Breaks**

**Paragraph Break**

In wiki markup, a paragraph is a continuous line of text ending in two carriage returns. This is equivalent to a continuous line of text followed by a blank line.

When rendered into HTML, the result is a line of text wrapped in a set of `<p>` tags.

**Line Break**

Confluence provides two options for forcing a line break within a paragraph of text:

- Implicitly, by entering a single carriage return at its end.
- Explicitly, by entering two consecutive backslashes: `\`

When rendered into HTML, the result is a paragraph of text that is split into separate lines by `<br>` tags, wherever a forced line break appears.

ℹ️ For most purposes, explicit line breaks are not required because a single carriage return is enough.

The examples below show how to use explicit line breaks.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>{}</code></td>
<td><code>{}</code></td>
</tr>
<tr>
<td><code>{color: red}</code></td>
<td><code>{color: red}</code></td>
</tr>
<tr>
<td><code>\</code></td>
<td><code>\</code></td>
</tr>
<tr>
<td><code>{blockquote}</code></td>
<td><code>{blockquote}</code></td>
</tr>
</tbody>
</table>

---

*Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
here is some text

\\
divided \\
using line \\
breaks\\

This is a short list:
* Point 1
  Text to go with point 1
* Point 2
  Text to go with point 2 with a break

If you wish to use multiple consecutive line breaks, each should be separated by a space character. For example, use this for two consecutive line breaks:

Horizontal Rule

To create a horizontal line across the width of your page or content block, type four dashes (like this: ----) at the beginning of a line, then press Enter or space.

Make sure that the dashes are on a separate line from the rest of the text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>here is some text</td>
<td>here is some text</td>
</tr>
<tr>
<td>----</td>
<td>divided by a horizontal rule</td>
</tr>
</tbody>
</table>

Links

You can use wiki markup to add hyperlinks to your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>[#anchor]</td>
<td>A link to an anchor on the same page.</td>
</tr>
<tr>
<td>[Confluence Wiki Markup^attachment.ext]</td>
<td>A link to a file attached to the page.</td>
</tr>
<tr>
<td>[pagetitle]</td>
<td>A link to a page.</td>
</tr>
<tr>
<td>[pagetitle#anchor]</td>
<td>A link to an anchor on another page.</td>
</tr>
<tr>
<td>[pagetitle^attachment.ext]</td>
<td>A link to a file attached to another page.</td>
</tr>
<tr>
<td>[spacekey:pagetitle]</td>
<td>A link to a page in another space.</td>
</tr>
<tr>
<td>[spacekey:pagetitle#anchor]</td>
<td>A link to an anchor on a page in another space.</td>
</tr>
<tr>
<td>[spacekey:pagetitle^attachment.ext]</td>
<td>A link to a file attached to a page in another space.</td>
</tr>
<tr>
<td>[/2004/01/12/blogposttitle]</td>
<td>A link to a blog post.</td>
</tr>
<tr>
<td>[spacekey:/2004/01/12/blogposttitle]</td>
<td>A link to a blog post in another space.</td>
</tr>
<tr>
<td>[/2004/01/12]</td>
<td>A link to a whole day's blog posts.</td>
</tr>
<tr>
<td>[spacekey:/2004/01/12]</td>
<td>A link to a whole day's blog posts in another space.</td>
</tr>
</tbody>
</table>
### [spacekey:]
A link to the space homepage (or the space summary page of the space).

### [~username]
A link to the user profile page of a particular user.

### [phrase@shortcut]
A shortcut link to the specified shortcut site. Shortcuts are configured by the site administrator.

### [http://confluence.atlassian.com]
A link to an external resource.

### [mailto:legendaryservice@atlassian.com]
A link to an email address.

### [file://z:/file/on/network/share.txt]
A link to a file on your computer or on a network share that you have mapped to a drive. This only works on Internet Explorer.

Note that Confluence treats headings as anchors, so you can link to headings using this pattern: [spacekey:pagename#headingname], where headingname is case-sensitive and must be entered without spaces.

For each of these link forms:
- You can prepend a link alias, so that alternate text is displayed on the page. Example: [link alias|pagetitle#anchor]
- You can append a link tip, which appears as a tooltip. Example: [pagetitle#anchor|link tip]

### Images
You can display images from attached files or remote sources.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>![<a href="http://www.host.com/image.gif">http://www.host.com/image.gif</a>!]</td>
<td>An image from a remote source is displayed on the page. Uses a fully qualified URL.</td>
</tr>
<tr>
<td>![attached-image.gif!]</td>
<td>An image file attached to the page is displayed.</td>
</tr>
<tr>
<td>![pageTitle^image.gif!]</td>
<td>An image file attached to a different page is displayed.</td>
</tr>
<tr>
<td>![spaceKey:pageTitle^image.gif!]</td>
<td>An image file attached to a page in a different space is displayed.</td>
</tr>
<tr>
<td>![2010/05/23/My Blog Post^image.gif!]</td>
<td>An image file attached to a blog post is displayed.</td>
</tr>
<tr>
<td>![image.jpg</td>
<td>thumbnail!]</td>
</tr>
<tr>
<td>![image.gif</td>
<td>align=right, vspace=4!]</td>
</tr>
</tbody>
</table>

Available HTML image tags include:

<table>
<thead>
<tr>
<th>Image tag</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>align</td>
<td>Available values are 'left', 'right', 'bottom', 'center', 'top'.</td>
</tr>
<tr>
<td>border</td>
<td>Specifies the width of the border (in pixels).</td>
</tr>
</tbody>
</table>
bordercolor | Use with the ‘border’ tag. Specify colours by name or hex value.
---|---
hspace | Specifies the amount of whitespace to be inserted to the left and right of the image (in pixels).
vspace | Specifies the amount of whitespace to be inserted above and below the image (in pixels).
width | Specifies the width of the image (in pixels). This will override the natural width of the image.
height | Specifies the height of the image (in pixels). This will override the natural height of the image.
title | Specifies alternate text for the image, which is displayed when the pointer hovers over the image.
alt | Specifies alternate text for the image. This text is retrievable via search, and contributes to accessibility of the page for text-only viewing.

Page Layouts
There is no wiki markup representation for page layouts.

Useful Information
- A **space key** is a short, unique identifier for a space. For example, you might give your documentation space a key of “DOC”. To find the key of an existing space, look at the Confluence URL for a page in the space. The standard Confluence URL has this format:

  http://my.confluence.site.com/display/SPACEKEY/Page+Name

- If you would like to edit the XML source of a page, your Confluence system administrator will need to install the Confluence Source Editor plugin. See more about the Confluence Storage Format.

- **Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.**

**Confluence Wiki Markup for Macros**
This page is an extension of Confluence Wiki Markup. It describes the wiki markup used to define specific Confluence macros – the macros that are shipped with Confluence. For each macro, we define the macro name, parameter names, and accepted parameter values.

Wiki markup is useful when you want to do one of the following:
- Configure the Documentation theme.
- Type wiki markup directly into the editor. Confluence will convert it to the rich text editor format as you type.
- Create links using the Advanced tab of the Links Browser.
- Insert a block of wiki markup into the Confluence editor. (Choose Insert > Wiki Markup.)

**Note: You cannot edit content in wiki markup.** Confluence does not store page content in wiki markup. Although you can enter wiki markup into the editor, Confluence will convert it to the rich text editor format immediately. You will not be able to edit the wiki markup after initial entry.
Related pages:
- Confluence Wiki Markup
- Working with Confluence Markup
- Working with Macros
- Confluence User’s Guide

On this page:

[ Anchor macro ] [ Attachments macro ] [ Blog Posts macro ] [ Change-History macro ] [ Chart macro ] [ Cheese macro ] [ Children Display macro ] [ Code Block macro ] [ Column macro ] [ Content by Label macro ] [ Content by User macro ] [ Content Report Table macro ] [ Contributors macro ] [ Contributors Summary macro ] [ Create from Template macro ] [ Create Space Button macro ] [ Excerpt Include macro ] [ Excerpt macro ] [ Expand macro ] [ Favourite Pages macro ] [ gadget macro ] [ Gallery macro ] [ Global Reports macro ] [ HTML Include macro ] [ HTML macro ] [ IM Presence macro ] [ Include Page macro ] [ Info macro ] [ JIRA Issues macro ] [ JUnit Report macro ] [ Labels List macro ] [ Livesearch macro ] [ Loremipsum macro ] [ Multimedia macro ] [ Navigation Map macro ] [ Network macro ] [ Noformat macro ] [ Note macro ] [ Office Excel macro ] [ Office PowerPoint macro ] [ Office Word macro ] [ Page Index macro ] [ Page Properties macro ] [ Page Properties Report macro ] [ Page Tree macro ] [ Page Tree Search macro ] [ Panel macro ] [ PDF macro ] [ Popular Labels macro ] [ Profile Picture macro ] [ Recently Updated Dashboard macro ] [ Recently Updated macro ] [ Recently Used Labels macro ] [ Related Labels macro ] [ RSS Feed macro ] [ Search Results macro ] [ Section macro ] [ Space Attachments macro ] [ Space Details macro ] [ Space Jump macro ] [ Spaces List macro ] [ Status macro ] [ Table of Contents macro ] [ Table of Content Zone macro ] [ Tasklist macro ] [ Tip macro ] [ User List macro ] [ User Profile macro ] [ User Status List macro ] [ Warning macro ] [ Widget Connector macro ] [ Notes ]

Anchor macro

Allows you to link to a specific part of a page.

Macro name: anchor

Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>Yes</td>
<td>(None)</td>
<td>The name of the anchor.</td>
</tr>
<tr>
<td>(Unnamed in wiki markup)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Example:

```none
(anchor:here)
```

Attachments macro

Displays a list of attachments on a given page.

Macro name: attachments

Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>old</td>
<td>No</td>
<td>false</td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- false - Displays only the latest version of each attachment.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- true - Displays all versions of each attachment, including the old versions.</td>
</tr>
<tr>
<td>patterns</td>
<td>No</td>
<td>(None)</td>
<td>A comma-separated list of regular expressions, used to filter the attachments by file name. Note that the parameter values must be regular expressions. For example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- To match a file suffix of 'jpg', use .*jpg (not *.jpg).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- To match file names ending in 'jpg' or 'png', use <em>.jpg,</em>.png</td>
</tr>
<tr>
<td>sortBy</td>
<td>No</td>
<td>date</td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- date</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- size</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- name</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page on which the macro exists.</td>
<td>Page name, used to display attachments from another page.</td>
</tr>
<tr>
<td>sortOrder</td>
<td>No</td>
<td>The default sort order is determined by the sortBy type:</td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Reverse chronological for 'date'.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Largest to smallest for 'size'.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Alphabetical for 'name'.</td>
</tr>
<tr>
<td>labels</td>
<td>No</td>
<td>(None)</td>
<td>A comma-separated list of labels. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.)</td>
</tr>
<tr>
<td>upload</td>
<td>No</td>
<td>false</td>
<td>Determines whether the list of attachments will include options allowing users to browse for, and attach, new files.</td>
</tr>
</tbody>
</table>
Blog Posts macro

Lists the most recent news items in the space.

**Macro name:** blog-posts

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>content</td>
<td>No</td>
<td>entire</td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>entire</strong> – Display the whole content of each blog post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>excerpts</strong> – Display a short extract from each blog post. If the post contains an Excerpt macro, the Blog Posts macro will display the content defined in the Excerpt macro. If the post does not contain an Excerpt macro, the Blog Posts macro will display the first few sentences of the post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>titles</strong> – Display a list of blog posts, showing titles only.</td>
</tr>
<tr>
<td>spaces</td>
<td>No</td>
<td>@self</td>
<td>One or more space keys, separated by a comma or a space.</td>
</tr>
</tbody>
</table>
To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.

To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:

- @self — The current space.
- @personal — All personal spaces.
- @global — All site spaces.
- @favorite — The spaces you have marked as favourite.
- @favourite — The same as @favorite above.
- @all — All spaces in your Confluence site.
- * — The same as @all above.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>author</td>
<td>No</td>
<td>(None)</td>
<td>One or more usernames, separated by commas.</td>
</tr>
</tbody>
</table>
| time      | No       | (None)| Available values:  
- m — Minutes  
- h — Hours  
- d — Days  
- w — Weeks  
For example,  
- time=12h — Display blog posts created in the last twelve hours.  
- time=7d — Display blog posts created in the last seven days. |
| reverse   | No       | false| A value of true changes the sort order. |
| sort      | No       | creation| Available values:  
- title — Sort alphabetically by title.  
- creation — Sort by the date on which the content was added.  
- modified — Sort by the date on which the content was last updated. |
| max       | No       | 15    | The maximum number of results to be displayed. |
### label

<table>
<thead>
<tr>
<th>label</th>
<th>No</th>
<th>(None)</th>
<th>One or more label values, separated by a comma or a space.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>• To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labelled with 'badpage'.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage,+goodpage you will get only content which has at least two labels, being 'superpage' and 'goodpage'.</td>
</tr>
</tbody>
</table>

#### Example:

```plaintext
(blog-posts:content=titles|spaces=@self,ds|author=jsmith|time=4w|reverse=true|sort=creation|max=10|label=chocolate,cookies)
```

---

### Change-History macro

Displays a history of updates made to a page.

**Macro name:** `change-history`

**Macro body:** None.

**Parameters:** None.

**Example:**

```plaintext
(change-history)
```

---

### Chart macro

Displays a chart based on tabular data.

**Macro name:** `chart`

**Macro body:** Accepts rich text, consisting of tables that hold the chart’s data.
This macro recognises a large number of parameters, listed here by type for convenience.

**Chart type parameters**

These parameters determine the type of chart to display and how the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| type      | No       | pie     | The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based. See the `timeSeries` parameter. Available values:  
  - *Standard charts* – pie, bar, line, area  
  - *XY plots* – xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries  
  - *Other charts* – gantt (beta) |
| orientation | No      | vertical | The display orientation. Applies to area, bar and line charts. Available values:  
  - `vertical` – y-axis is vertical  
  - `horizontal` – x-axis is vertical |
| 3D | No | false | Show in three dimensions. Applies to area, bar and line charts. |
| stacked | No | false | Stacked values. Applies to area and bar charts. |
| showShapes | No | true | Applies to line charts. Shapes are shown at each data point. |
| opacity | No | • 75 percent for 3D charts  
  • 50 percent for non-stacked area charts  
  • 100 percent for all other charts | A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are. |

**Chart display parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
### Chart title and label parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>subTitle</td>
<td>No</td>
<td>(None)</td>
<td>A subtitle for the chart.</td>
</tr>
<tr>
<td>xLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>yLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>legend</td>
<td>No</td>
<td>false</td>
<td>Determines whether to show a legend (key) for the chart.</td>
</tr>
</tbody>
</table>

### Chart data parameters

The data for the chart is taken from tables found in the macro body. The parameters below control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. You can specify additional conversion options using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
<tr>
<td>dataDisplay</td>
<td>No</td>
<td>false</td>
<td>Determines whether to display the body of the macro, consisting of the data table. By default, the chart data table is not displayed. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>false – the data is not displayed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>true or after – the data is displayed after the chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>before – the data is displayed before the chart.</td>
</tr>
<tr>
<td>imageFormat</td>
<td>No</td>
<td>png</td>
<td>The image format to be used for the chart. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>png</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>jpg</td>
</tr>
<tr>
<td>Parameter</td>
<td>Value</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-----------------</td>
<td>--------</td>
<td>------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>tables</td>
<td>No</td>
<td>All first level tables. You can supply a comma-separated list of table IDs and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
<td></td>
</tr>
<tr>
<td>columns</td>
<td>No</td>
<td>All columns. You can supply a comma-separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the HTML title attribute for the column in the header row.</td>
<td></td>
</tr>
</tbody>
</table>
| dataOrientation | No     | horizontal. The content orientation. By default, the data tables will be interpreted as columns (horizontally) representing domain and x values. Available values:  
  - vertical – data table columns will be interpreted as series.  
  - horizontal – data table rows will be interpreted as series. |
<p>| timeSeries      | No     | false. If 'true', the x values in an XY plot will be treated as time series data and so will be converted according date formats. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>dateFormat</code></td>
<td>No</td>
<td>Confluence language defined date formats</td>
<td>For time series data, the date format allows for additional customisation of the conversion of data to date values. If a date format is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See simple date format.</td>
</tr>
<tr>
<td><code>timePeriod</code></td>
<td>No</td>
<td>day</td>
<td>The time period for time series data. Defines the granularity of how the data is interpreted.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values: millisecond, second, minute, hour, day, week, month, quarter, year</td>
</tr>
<tr>
<td><code>language</code></td>
<td>No</td>
<td>(None)</td>
<td>Use in combination with the <code>country</code> parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values are the two-character ISO 639-1 alpha-2 codes.</td>
</tr>
<tr>
<td><code>country</code></td>
<td>No</td>
<td>(None)</td>
<td>Use in combination with the <code>language</code> parameter to form a locale. Valid values are the two-character ISO 3166 codes.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>----------</td>
<td>---------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>forgive</td>
<td>No</td>
<td>true</td>
<td>Determines whether the macro will forgive (allow) some data formatting errors.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• true — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• false — the macro enforces strict data formatting. If there are data format errors, the chart will not be produced.</td>
</tr>
</tbody>
</table>

Chart colour parameters

Colours are specified using hexadecimal notation or HTML colour names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>bgColor</td>
<td>No</td>
<td>White</td>
<td>Background colour of the chart.</td>
</tr>
<tr>
<td>borderColor</td>
<td>No</td>
<td>No border</td>
<td>Colour of the border around the chart.</td>
</tr>
<tr>
<td>colors</td>
<td>No</td>
<td></td>
<td>A comma-separated list of colours used to customise the colours of categories, sections, and series.</td>
</tr>
</tbody>
</table>

Chart axis parameters

Depending on the chart type, the range and domain axis may be customised. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rangeAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td>Minimum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td>Maximum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>rangeAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Value</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-------</td>
<td>-----------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>domainAxisLowerBound</td>
<td>No</td>
<td>(None) Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the <code>dateFormat</code> parameter.</td>
<td></td>
</tr>
<tr>
<td>domainAxisUpperBound</td>
<td>No</td>
<td>(None) Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the <code>dateFormat</code> parameter.</td>
<td></td>
</tr>
<tr>
<td>domainAxisTickUnit</td>
<td>No</td>
<td>(None) Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the <code>timePeriod</code> parameter. The <code>timePeriod</code> unit can be overridden by specifying a trailing character: <code>y</code> (years), <code>M</code> (months), <code>d</code> (days), <code>h</code> (hours), <code>m</code> (minutes), <code>s</code> (seconds), <code>u</code> (milliseconds).</td>
<td></td>
</tr>
<tr>
<td>domainAxisLabelAngle</td>
<td>No</td>
<td>(None) Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
<td></td>
</tr>
<tr>
<td>categoryLabelPosition</td>
<td>No</td>
<td>(None) Placement of the axis label text for categories. Available values:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <code>up45</code> — 45 degrees going upward</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <code>up90</code> — 90 degrees going upward</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <code>down45</code> — 45 degrees going downward</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <code>down90</code> — 90 degrees going downward</td>
<td></td>
</tr>
</tbody>
</table>
### Pie chart Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| dateTickMarkPosition | No       | start         | Placement of the date tick mark. Available values:  
- **start** — tick mark is at the start of the date period.  
- **middle** — tick mark is in the middle of the date period.  
- **end** — tick mark is at the end of the date period. |
| pieSectionLabel  | No       | Show only the pie section key value | Format of pie section labels. The format uses a string with special replacement variables:  
- `%0%` is replaced by the pie section key.  
- `%1%` is replaced by the pie section numeric value.  
- `%2%` is replaced by the pie section percent value.  
Example 1: To display something like 'Independent = 20':  

\[
\%0\% = \%1\%
\]
Example 2: To display something like 'Independent (20%)':  

\[
\%0\% (\%2\%)
\]
| pieSectionExplode | No       | No exploded sections | A comma-separated list of pie keys that are to be shown exploded. Note: requires jFreeChart version 1.0.3 or higher. |

### Chart attachment parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is updated.
displayed. These options allow for the generated image to be saved as an attachment and have subsequent access to re-use the attachment. This can be useful especially when combined with the Cache plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>attachment</td>
<td>No</td>
<td>(None)</td>
<td>The name and location where the chart image will be saved as an attachment. The user must be authorised to add attachments to the page specified. Available syntax for this parameter:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>^attachmentName.png</code> — the chart is saved as an attachment to the current page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>page name^attachmentName.png</code> — the chart is saved as an attachment to the page name provided.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>spacekey:page name^attachmentName.png</code> — the chart is saved as an attachment to the page name provided in the space indicated.</td>
</tr>
<tr>
<td>attachmentVersion</td>
<td>No</td>
<td>new</td>
<td>Defines the the versioning mechanism for saved charts. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>new</code> — creates new version of the attachment.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>replace</code> — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorised to remove attachments for the page specified.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <code>keep</code> — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated.</td>
</tr>
</tbody>
</table>
attachmentComment | No | (None) | Comment used for a saved chart attachment.

| thumbnail | No | false | If true, the chart image attachment will be shown as a thumbnail (small, expandable) image.

**Example:**
Below is a simple example of a pie chart. See more examples in Wiki Markup Examples for Chart Macro.

```
{chart:type=pie|title=Fish Sold}
|| Fish Type || 2004 || 2005 ||
|| Herring | 9,500 | 8,300 |
|| Salmon | 2,900 | 4,200 |
|| Tuna | 1,500 | 1,500 |
{chart}
```

**Cheese macro**
Displays the words "I like cheese!"

**Macro name:** cheese

**Macro body:** None.

**Parameters:** None

**Example:**
```
{cheese}
```

**Children Display macro**
Displays the children and descendants of the current page.

**Macro name:** children

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>reverse</td>
<td>No</td>
<td>false</td>
<td>Reverses the sort order in the list of child pages. Use this parameter in conjunction with the sort parameter described below. A value of true will change the sort order from ascending to descending.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-----------</td>
<td>---------</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td>sort</td>
<td>No</td>
<td>Manual if the pages have been manually reordered, otherwise alphabetical by page title. Determines the sort order of the list of child pages. Available values: - creation – Sort by the date on which the page was created. - title – Sort alphabetically by page name. - modified – Sort by the date on which the page was last updated.</td>
<td></td>
</tr>
<tr>
<td>style</td>
<td>No</td>
<td>Bullet list A heading style to be applied to the list of child pages. Available values: h1 (heading level 1) through to h6 (heading level 6).</td>
<td></td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page that contains the macro. The name of the parent page. The macro will display the children of the specified page. To specify a page in a different space, use a space key followed by a colon. For example: MYSPACE:My page If the value of this parameter is a forward slash (/) the macro will list the pages at the root of the current space. In other words, the pages without parents.</td>
<td></td>
</tr>
<tr>
<td>excerpt</td>
<td>No</td>
<td>false If true, Confluence will display any excerpts that are defined on the child pages. The excerpts must be defined via an Excerpt macro.</td>
<td></td>
</tr>
<tr>
<td>first</td>
<td>No</td>
<td>(None) The maximum number of child pages to be displayed (at the top level). For example, if the value of this parameter is 99, the macro will display the first 99 pages at the top level. It will also display their children, as determined by the depth and all parameters.</td>
<td></td>
</tr>
</tbody>
</table>
depth | No | (None) | The number of levels of child pages to display. For example, if the value is 2, the macro will display 2 levels of child pages.

all | No | false | If true, Confluence will display all levels of child pages. This setting will override the depth setting.

Example:

```
{children:reverse=true|sort=creation|style=h4|page=Home|excerpt=true|first=99|depth=2|all=true}
```

**Code Block macro**

Displays code in your document with the appropriate syntax highlighting.

**Macro name:** code

**Macro body:** Accepts plain text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>Adds a title to the code macro box.</td>
</tr>
</tbody>
</table>
| theme          | No       | Confluence | Specifies the colour scheme used for displaying your code. Many of these themes are based on the default colour schemes of popular integrated development environments (IDEs). The default theme is Confluence (also known as Default), which is typically black and coloured text on a blank background. Available themes:  
<p>|                |          |         | DJango  |
|                |          |         | Emacs   |
|                |          |         | FadeToGrey |
|                |          |         | Midnight |
|                |          |         | RDark   |
|                |          |         | Eclipse |
|                |          |         | Confluence (same as default) |</p>
<table>
<thead>
<tr>
<th>Setting</th>
<th>Default</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>linenumbers</td>
<td>No</td>
<td>false</td>
<td>If <code>true</code>, a line number will be shown to the left of each line of code. Numbering is incremented by 1. If <code>false</code>, no line numbers are shown.</td>
</tr>
<tr>
<td>language</td>
<td>No</td>
<td>java</td>
<td>Specifies the language (or environment) for syntax highlighting.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- (none) — that is, no syntax highlighting</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- actionscript3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- bash</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- csharp — that is, C#</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- coldfusion</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- cpp — that is, C++</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- css</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- delphi</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- diff</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- erlang</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- groovy</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- java</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- javeaX</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- javascript</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- perl</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- php</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- powershell</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- python</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- ruby</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- scala</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- sql</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- vb — that is, Visual Basic</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- html/xml</td>
</tr>
<tr>
<td>firstline</td>
<td>No</td>
<td>1</td>
<td>When <code>linenumbers</code> is <code>true</code>, this value defines the number of the first line of code.</td>
</tr>
<tr>
<td>collapse</td>
<td>No</td>
<td>false</td>
<td>If <code>true</code>, the code macro's content will be collapsed upon visiting or refreshing the Confluence page. Clicking the 'expand source' link allows you to view the content. If <code>false</code>, the code macro's content is always displayed in full.</td>
</tr>
</tbody>
</table>

**Example:**
Column macro

Used with the Section macro to define columns on a page. See Working with page layouts and columns and sections.

**Macro name:** column

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>The width of the column. Can be specified either in pixels (for example, 400 px) or as a percentage of the available page width (for example, 50%).</td>
</tr>
</tbody>
</table>

**Example:**

```plaintext
{column:width=100px}
This is the content of *column 1*.
{column}
```

Content by Label macro

Displays a list of content associated with specific labels.

**Macro name:** contentbylabel

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>spaces</td>
<td>No</td>
<td>@all</td>
<td>Filters the results by space. The macro will display only the pages and other content types which belong to the space(s) you specify here. You can specify one or more space keys, separated by a comma or a space.</td>
</tr>
</tbody>
</table>
To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of BADSPACE you will get only content which is not in the BADSPACE.

To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of GOODSPACE you will get only content in GOODSPACE.

(Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:

- @self — The current space.
- @personal — All personal spaces.
- @global — All site spaces.
- @favorite — The spaces you have marked as favourite.
- @favourite — The same as @favorite above.
- @all — All spaces in your Confluence site.
- * — The same as @all above.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>author</td>
<td>No</td>
<td>Filters the results by author. The macro will display only the pages and other content types which are written or updated by the author(s) you specify here. You can specify one or more authors, separated by a comma. For example: jsmith,jbrown. To include content from one user, but exclude from another user: jsmith,!jbrown.</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>Adds a heading to the list.</td>
</tr>
<tr>
<td>showLabels</td>
<td>No</td>
<td>Determines whether to display the matching labels in the list of results.</td>
</tr>
<tr>
<td>reverse</td>
<td>No</td>
<td>Use this parameter in conjunction with the sort parameter. Set reverse=true to change the sort from ascending to descending. This parameter is ignored if the sort parameter is not specified.</td>
</tr>
</tbody>
</table>
| sort | No | modified | Determines how the results are sorted. To change the sort order from ascending to descending, use the `reverse` parameter described above. If this parameter is not specified, the sort order defaults to descending order based on the last modification date. Values:  
  - **title** — Sort alphabetically by title.  
  - **creation** — Sort by the date on which the content was added.  
  - **modified** — Sort by the date on which the content was last updated. |
| max | No | 15 | Determines the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied. |
| excerpt | No | false | If this parameter is set to `true`, the macro displays an excerpt from each page listed in the results. Note that you must define the excerpts on each of those pages, by adding the **Excerpt macro** to each page. If a particular page does not have an excerpt defined, then the Content by Label macro will not attempt to show an excerpt for that page. The Content by Label macro will show only the first few lines of the excerpt for each page. |
| labels     | Yes    | (None) | Use this parameter to filter the results by label. The macro will display only the pages and other content types which are tagged with the label(s) you specify here. See also the `operator` parameter.

You can specify one or more label values, separated by a comma or a space.

- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of `-badpage` you will get only content which is not labelled with 'badpage'.
- To indicate that the results **must** match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of `+superpage,+goodpage` you will get only content which has at least two labels, being 'superpage' and 'goodpage'. |
| showSpace | No     | true   | Determines whether to display the spaces in the list of results. |
| **Type** | **No** | **All** | Filters the results by content type. The macro will display only the content of the type you specify here.  
You can specify one or more types, separated by a comma or a space.  
To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of `-blogpost` you will get pages and all other content except for blog posts.  
Available values:  
- `page` — pages.  
- `blogpost` or `news` — blog posts, also known as news items.  
- `attachment` — attachments. |
| --- | --- | --- | --- |
| **Operator** | **No** | **OR** | The operator to apply to the supplied lists of labels. By default, a page with any of the non-prefixed labels (that is, labels without a plus (+) or minus (-) sign immediately preceding it) will be listed. If you specify a value of AND, only pages with all of the supplied non-prefixed labels will be listed.  
Note that this parameter only modifies the behaviour of the 'Label(s)' parameter and only affects label values without a plus (+) or minus (-) sign prefix. To avoid confusion or unexpected results, we recommend that you do not use the operator parameter in conjunction with any label values prefixed with '+' or '-' signs. |

**Example:**
Content by User macro

Displays a list of the content items that have been created by a specified Confluence user.

**Macro name:** content-by-user

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>Yes</td>
<td>(None)</td>
<td>The Confluence username for the person whose content you wish to display</td>
</tr>
</tbody>
</table>

*(Unnamed in wiki markup)*

**Example:**

```
{content-by-user:jsmith}
```

Content Report Table macro

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

Contributors macro

Displays a list of Confluence users who have made a contribution of some type to a page.

**Macro name:** contributors

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>limit</td>
<td>No</td>
<td>(None)</td>
<td>Limits the number of contributors displayed in the list.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default Value</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>----------</td>
<td>---------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| `spaces`           | No       | Current space | Specifies the space key of the Confluence space to search. Space keys are case sensitive. Special values:  
|                    |          |               | - `@global` — All site spaces.  
|                    |          |               | - `@personal` — All personal spaces.  
|                    |          |               | - `@all` — All spaces in the Confluence site.  
|                    |          |               | You can specify one or more space keys or special values, separated by commas.  
|                    |          |               | If no page and labels are specified, all pages from the specified set of spaces are included. |
| `reverse`          | No       | false         | Reverses the order of contributors in the list. Must be used in conjunction with the order parameter. |
| `scope`            | No       | The specified page only | Specifies additional pages to include when generating the list of contributors. Available values:  
|                    |          |               | - `children` — only the child pages of the specified page.  
<p>|                    |          |               | - <code>descendants</code> — all descendants of the specified page. |
| <code>labels</code>           | No       | (None)        | Limits the list of contributors to those who created the specified labels on a page. You can specify one or more labels, separated by commas. |
| <code>showPages</code>        | No       | false         | If the value is true, the macro will display a list of the pages used to generate the list of contributors. |
| <code>noneFoundMessage</code> | No       | &quot;No contributors found for:&quot; (and a summary of selected parameter values) | Any message given here will override the default message that is displayed when no contributors are found. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>showCount</td>
<td>No</td>
<td>false</td>
<td>Determines whether the macro will show the number of times each person made a contribution.</td>
</tr>
</tbody>
</table>
| contentType   | No      | Both pages and blog posts | Restricts the content type that the macro will use when generating the list of contributors. Available values:  
- pages - pages  
- blogposts - blog posts. |
| include       | No      | authors | Filters by either the type of contribution made to a page (and optionally its descendant pages), or the watches on the page. Contribution types are:  
- authors - includes people who created or have edited the page(s)  
- comments - includes people who have added comments to the page(s)  
- labels - includes people who have added labels to the page(s)  
- watches - includes people who are watching the page(s). You can specify one or more contribution types, separated by commas. |
| mode          | No      | inline | Determines how the list of contributors is formatted:  
- inline — a comma-separated list  
- list — a bullet list. |
<p>| showAnonymous | No      | false | Determines whether to include those who contributed anonymously to a page. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| order      | No    | Specifies the criteria used to sort contributors. Sort criteria are:  
  - `count` — sorts the names based on the total number of contributions to the page(s)  
  - `name` — sorts the names into alphabetical order  
  - `update` — sorts the names by the date of their last contribution to the page(s). |
| page       | No    | Specifies the page to use when generating the list of contributors. If `page` and `spaces` are left blank, the current page is assumed. |
| showLastTime | No | false | Determines whether to show the last time each person made a contribution. |
| publishDate | No | (None) | Specifies the publication date for a blog post. The date format required is: YYYY/MM/DD. |

**Example:**

This example specifies a content type of blog posts:

```{contributors:limit=10|spaces=ds,@personal|reverse=true|labels=chocolate,cake|showPages=true|noneFoundMessage=Oh dear, no contributors found|showCount=true|contentType=blogposts|include=authors,comments,labels,watches|mode=list|showAnonymous=true|order=update|showLastTime=true|publishDate=2012/06/30}
```

This example specifies a content type of pages:

```{contributors:limit=10|spaces=ds,@personal|reverse=true|scope=descendants|labels=chocolate,cake|showPages=true|noneFoundMessage=Oh dear, no contributors found|showCount=true|contentType=pages|include=authors,comments,labels,watches|mode=list|showAnonymous=true|order=update|page=ds:Advanced Topics|showLastTime=true}
```

**Contributors Summary macro**

Displays a table of contribution-based statistics for a set of pages.

**Macro name:** contributors-summary
Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>limit</td>
<td>No</td>
<td>(None)</td>
<td>Limits the number of contributors or pages displayed in the table.</td>
</tr>
<tr>
<td>spaces</td>
<td>No</td>
<td>Current space</td>
<td>Specifies the space key of the Confluence space to search. Space keys are case sensitive. Special values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- @global — All site spaces.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- @personal — All personal spaces.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- @all — All spaces in the Confluence site.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>You can specify one or more space keys or special values, separated by commas.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>If no page and labels are specified, all pages from the specified set of spaces are included.</td>
</tr>
<tr>
<td>reverse</td>
<td>No</td>
<td>false</td>
<td>Reverses the order of items in the table. Must be used in conjunction with the order parameter.</td>
</tr>
<tr>
<td>showAnonymous</td>
<td>No</td>
<td>false</td>
<td>Determines whether to include those who contributed anonymously to a page.</td>
</tr>
<tr>
<td>scope</td>
<td>No</td>
<td>The specified page only</td>
<td>Specifies additional pages to include when generating the list of contributors. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- children — only the child pages of the specified page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- descendants — all descendants of the specified page.</td>
</tr>
<tr>
<td>parameter</td>
<td>required</td>
<td>value</td>
<td>description</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
<td>-------</td>
<td>-------------</td>
</tr>
<tr>
<td>order</td>
<td>No</td>
<td>edits</td>
<td>Sets the criterion used for sorting items in the table. Available values: - <code>edits</code> - sorts items in the table based on the total number of edits made, either by a contributor or to a page. - <code>name</code> - sorts items in the table in alphabetical order, either by contributor or page name. - <code>editTime</code> - sorts items in the table based on when the contributor last edited a page (or a specified set of pages) or when the page was last edited. - <code>update</code> - sorts items in the table based on when the contributor last made any contribution to a page (or a specified set of pages) or when the page last had any contribution made to it.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The current page</td>
<td>A page title. Specifies the page to use when generating the list of contributors. If <code>page</code> and <code>spaces</code> are left blank, the current page is assumed.</td>
</tr>
<tr>
<td>labels</td>
<td>No</td>
<td>(None)</td>
<td>Limits contribution-based statistics to the specified labels only. You can specify one or more labels, separated by commas.</td>
</tr>
<tr>
<td>columns</td>
<td>No</td>
<td>edits, comments, labels</td>
<td>Determines the columns that should appear in the table. The statistics or type of information presented depends on the <code>groupby</code> parameter. Available values:</td>
</tr>
</tbody>
</table>
• **edits** – the number of times each contributor has edited the page(s) or the number of edits made to each page.
• **edited** – a list of the pages edited by each contributor or a list of contributors who have edited each page.
• **comments** – the number of times each contributor has added comments to the page(s) or the number of comments on each page.
• **commented** – a list of pages to which each contributor has added comments or a list of contributors who have commented on each page.
• **labels** – the number of times each contributor has added labels to the page(s) or the number of labels on each page.
• **labeled** – a list of pages to which each contributor has added labels or a list of contributors who have added a label to each page.
• **labellist** – a list of labels either added by each contributor or on each page.
• **watches** – the number of pages being watched by each contributor/person or the number of contributors/people watching each page.
• **watching** – a list of pages being watched by each contributor/person or a list of contributors/people watching each page.
- **lastupdate** – the last time each contributor made an update or when each page was last updated. Valid updates can include edits, comments or label modifications to a page.

You can specify one or more columns, separated by commas.

| groupby     | No     | contributors | Specifies the basis for grouping contribution-based statistics:
|            |        |              | • contributors – group by the people who have contributed.
|            |        |              | • pages – group by the pages used to find the contributors.
| contentType | No     | Both pages and blog posts | Restricts the content type that the macro will use when generating the list of contributors.
|            |        |              | Available values:
|            |        |              | • pages – pages
|            |        |              | • blogposts – blog posts.
| showZeroCounts | No | false | Determines whether contributors or pages are included for which the calculated statistic is zero.
| publishDate | No | (None) | Specifies the publication date for a blog post. The date format required is: YYYY/MM/DD.

**Example:**

This example specifies a content type of blog posts:

```
{contributors-summary:limit=10|spaces=ds,@personal|reverse=true|showAnonymous=true|order=update|labels=chocolate,cake|columns=edits,comments,labels,lastupdate|groupby=pages|contentType=blogposts|showZeroCounts=true|publishDate=2012/06/07}
```

This example specifies a content type of pages:
Create from Template macro

Creates a page from a given template.

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

Create Space Button macro

Displays a create space button linked to the create space page.

**Macro name:** create-space-button

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>size</strong></td>
<td>No</td>
<td>large</td>
<td>Determines the size of the 'create space' icon displayed. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• large</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• small</td>
</tr>
<tr>
<td><strong>width</strong></td>
<td>No</td>
<td>Natural size of icon (1:1 pixel ratio)</td>
<td>The width of the icon to be displayed, specified in pixels. Confluence will stretch or shrink the width of the icon to the number of pixels specified.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Note: This parameter is not available via the macro browser.</td>
</tr>
<tr>
<td><strong>height</strong></td>
<td>No</td>
<td>Natural size of icon (1:1 pixel ratio)</td>
<td>The height of the icon to be displayed, specified in pixels. Confluence will stretch or shrink the height of the icon to the number of pixels specified.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Note: This parameter is not available via the macro browser.</td>
</tr>
</tbody>
</table>

**Example:**
Excerpt Include macro

Allows you to display an excerpt from another page within the current page.

**Macro name:** excerpt-include

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>Yes</td>
<td>(None.)</td>
<td>The name of the page that contains the excerpt to be displayed. To include an excerpt from a page in another space, type the space key followed by a colon (:) and the page name, like this: SPACEKEY:My page name</td>
</tr>
<tr>
<td>(Unnamed in wiki markup)</td>
<td></td>
<td></td>
<td>Note: The ability to include excerpts from other spaces is available only in Confluence 4.3.2 and later. In earlier versions of Confluence, the Excerpt Include macro does not work across spaces. Use the Include Page macro instead.</td>
</tr>
<tr>
<td>nopanel</td>
<td>No</td>
<td>False</td>
<td>Determines whether Confluence will display a panel around the excerpted content. The panel includes the title of the page containing the excerpt, and the border of the panel. By default, the panel and title are shown.</td>
</tr>
</tbody>
</table>

Example:

```
{excerpt-include:My page name|nopanel=true}
```

Excerpt macro

Define a part of a page as the page's 'excerpt' which can then be displayed in another page.
Macro name: excerpt

Macro body: Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>hidden</td>
<td>No</td>
<td>False</td>
<td>Determines whether the content of the Excerpt macro body is displayed on the page that contains the Excerpt macro. Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused.</td>
</tr>
</tbody>
</table>
| atlassian-macro-output-type | No       | BLOCK   | Determines whether the content of the Excerpt macro body is displayed on a new line or inline. Available values:
- **BLOCK** – Displays the content of the macro on a new line.
- **INLINE** – Displays the content of the macro as part of the same paragraph as the text preceding and following it. Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused. |

Example:

```
{excerpt:hidden=true|atlassian-macro-output-type=BLOCK}
This is the *text* I want to reuse in other pages. This text is inside an Excerpt macro.
{excerpt}
```

Expand macro

Displays an expandable/collapsible section of text.

Macro name: expand

Macro body: Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
default-parameter
(Unnamed in wiki markup) | No | Click here to expand... | Text that will be displayed on the line that people can click to expand the hidden text.

Example:

```
{expand:This is my message}
This text is _hidden_ until you expand it.
{expand}
```

Favourite Pages macro
Displays a list of your favourite pages.

Macro name: favpages

Macro body: None.

Parameters: None.

Example:

```
{favpages}
```

Gadget macro
Allows you to add Confluence gadgets to pages or blog posts.

Macro name: gadget

Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| width          | No       | 450 pixels | The width of the gadget, using one of the following conventions:  
|                |          |          | • Width in pixels, using px or plain numbers. For example, 500px or 500  
|                |          |          | • A percentage of the page width, using %. For example, 50%  
|                |          |          | • Automatic resizing of the gadget to fit 100% of the page width: auto |
| border         | No       | true    | Determines whether Confluence will draw a border around the gadget. |
| url            | Yes      | (none.) | This is the location of the gadget specification (XML file). |
preferences | No | (Gadget-dependent.) | Specific property settings that are particular to each gadget.

A note about editing a gadget's properties (preferences) in markup: It is possible to edit the values of these properties directly in the wiki markup or storage format. However, this will allow the entry of invalid values. If a gadget property supports a certain set of values, the macro browser will restrict the user to selecting only valid values for that property. For that reason, we recommend that you use the macro browser to edit a gadget's properties.

Example:

This example shows the Confluence Page gadget:

```
{gadget:width=500|border=false|url=rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-page-gadget/gadgets/confluence-page-gadget.xml}
```

This example shows the Confluence News gadget:

```
{gadget:url=rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-news-gadget/gadgets/confluence-news-gadget.xml}
```

Gallery macro

Forms a thumbnail gallery of all images attached to a page.

**Macro name:** gallery

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>Specify a title to be displayed above your gallery of pictures.</td>
</tr>
</tbody>
</table>
| reverse        | No       | Not specified. Sort order is ascending. | Used in combination with the sort parameter, to change the sort order from ascending to descending. Available values:  
  • true – Sort order is descending. 
  • false – Sort order is ascending. |
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Value</th>
</tr>
</thead>
</table>
| sort        | No       | None    | Specify an attribute to sort the images by. Sort order is ascending, unless you specify the reverse parameter. Available values:  
- name – file name.  
- comment – comment linked to the attached file.  
- date – date/time last modified.  
- size – size of the attached file. |
<p>| page        | No       | None    | Specify the title of the page which contains the images you want displayed. You can specify more than one page name, separated by commas. To specify a page in a different space, use the following syntax: SPACEKEY:Page title.  |
| includeLabel| No       | None    | The gallery will include only those pictures that have the specified label. If you wish to enter more than one label, separate the labels with commas. Confluence will show only images that have all the labels specified. (The match is an AND, not an OR.) For information on labelling the attachments, see Adding Labels. |
| excludeLabel| No       | None    | The gallery will ignore any pictures that have the specified label. You can specify more than one label, separated by commas. For information on labelling the attachments, see Adding Labels. |
| columns     | No       | 4       | Specify the number of columns for the table that forms the gallery. |</p>
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>exclude</td>
<td>No</td>
<td></td>
<td>No exclusions. Include all the pictures on the page. Specify images by file name. The gallery will ignore any images specified. You can specify more than one image, separated by commas. Note: The file name and file type for this parameter are case sensitive. For example, 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
<tr>
<td>include</td>
<td>No</td>
<td></td>
<td>Include all the pictures on the page. If you specifically include one or more pictures, the gallery will show only those pictures. You can specify more than one picture, separated by commas. Note: The file name and file type for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
</tbody>
</table>

Example:

```
gallery:title=My holiday pictures|reverse=true|sort=size|page=My page1, ds:Welcome to Confluence|excludeLabel=badlabel1, badlabel2|columns=3|exclude=badpicture.png
```

Global Reports macro

Displays a list of links to global reports within a table.

**Macro name:** global-reports

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>99%</td>
<td>Specify the width of the table in which the links are displayed, as a percentage of the window width.</td>
</tr>
</tbody>
</table>

Example:

```
(global-reports:width=50%)
```
**HTML Include macro**
Includes the content of an external HTML file into a Confluence page.

**Macro name:** html-include

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>url</td>
<td>Yes</td>
<td>(None)</td>
<td>Specify a URL of the content to be included into your Confluence page.</td>
</tr>
</tbody>
</table>

**Example:**

```
{html-include:url=http://www.example.com}
```

**HTML macro**
Renders your specified HTML code within the current page.

**Macro name:** html

**Macro body:** Text, consisting of HTML code.

**Parameters:** None.

**Example:**

```
(html)<a href="http://www.atlassian.com">Click here</a> to see the <b>Atlassian</b> website.{html}
```

**IM Presence macro**
Displays graphically when a contact is online.

**Macro name:** im

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>showid</td>
<td>No</td>
<td>true</td>
<td>Determines whether the macro shows or hides the user ID of the contact. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• true – User ID is shown on the page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• false – User ID is not shown on the page.</td>
</tr>
</tbody>
</table>
| service         | Yes | Not specified. | The web service that Confluence should query. Available values:
|-----------------|-----|----------------|--------------------------------------------------------------------------------|
|                 |     |                | - aim – AOL Instant Messenger
|                 |     |                | - gtalk – Google Talk
|                 |     |                | - icq – ICQ
|                 |     |                | - jabber – Jabber
|                 |     |                | - msn – MSN Instant Messenger
|                 |     |                | - sametime – IBM Lotus Sametime
|                 |     |                | - skype – Skype
|                 |     |                | - skypeme – Skype
|                 |     |                | - wildfire – Openfire Server
|                 |     |                | - yahoo – Yahoo! Messenger
| default-parameter | Yes | Not specified. | User ID. Identifies the IM contact by their ID, account name or screen name. Example:
| (Unnamed in wiki markup) | | | `{im:MySkypeName|service=skype|showid=false}`

Include Page macro

Inserts the contents of the specified page into the current one.

**Macro name:** include

**Macro body:** None.
**default-parameter**

(Unnamed in wiki markup)

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>icon</td>
<td>No</td>
<td>true</td>
<td>Determines whether to display the icon in the title bar of the information box.</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the information box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
</tbody>
</table>

Example:

```
{include:DOC:My chocolate page}
```

Info macro

Displays a block of text in a blue highlight box.

**Macro name:** info

**Macro body:** Accepts rich text.
This is __important__ information.

JIRA Issues macro

Displays one or more JIRA issues, and offers the option to create an issue in JIRA.

**Macro name:** jiraissues

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>anonymous</td>
<td>No</td>
<td>false</td>
<td>If this parameter is set to 'true', JIRA will return only the issues which allow unrestricted viewing. That is, the issues which are visible to anonymous viewers, as determined by JIRA's viewing restrictions. If this parameter is omitted or set to 'false', then the results depend on how your administrator has configured the communication between JIRA and Confluence. By default, Confluence will show only the JIRA issues which the user is authorised to view. <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
</tr>
<tr>
<td>baseurl</td>
<td>No</td>
<td>The value of the 'url' parameter</td>
<td>If you specify a 'baseurl', then the link in the header, pointing to your JIRA site, will use this base URL instead of the value of the 'url' parameter. This is useful when Confluence connects to JIRA with a different URL from the one used by other users.</td>
</tr>
<tr>
<td><strong>columns</strong></td>
<td>No</td>
<td>By default, the following columns are shown:</td>
<td>A list of JIRA column names, separated by semi-colons (;). You can include any columns recognised by your JIRA site, including custom columns. See the <a href="http://jira.atlassian.com/software/DOCS/display/JIRAHOWTO">JIRA documentation</a> for a list of names.</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------</td>
<td>-----------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>count</strong></td>
<td>No</td>
<td><strong>false</strong></td>
<td>If this parameter is set to 'true', the issue list will show the number of issues in JIRA. The count will be linked to your JIRA site.</td>
</tr>
<tr>
<td><strong>cache</strong></td>
<td>No</td>
<td><strong>on</strong></td>
<td>The macro maintains a cache of the issues which result from the JIRA query. If the 'cache' parameter is set to 'off', the relevant part of the cache is cleared each time the macro is reloaded. (The value 'false' also works and has the same effect as 'off'.) <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
</tr>
<tr>
<td>Parameter</td>
<td>No</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------</td>
<td>---------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>height</td>
<td></td>
<td>480</td>
<td>The height in pixels of the table displaying the JIRA issues. Note that this height specification is ignored in the following situations:</td>
</tr>
</tbody>
</table>
|               |              | (if render mode is dynamic) | • If the 'renderMode' parameter (see below) is set to 'static'.  
• When the JIRA issues are displayed in a PDF or Word document, in an email message or in an RSS feed. |
| renderMode    |              | static  | If the value is 'dynamic', the JIRA Issues macro offers an interactive display which people can manipulate as follows:                          |
|               |              |         | • Click the column headers to sort the output.  
• Drag and drop the columns into a different order.  
• Temporarily remove a column from the display.  
• View a page of issues at a time, for faster response times. |
<p>|               |              |         | A value of 'static' will disable the dynamic display features.                                                                                   |
|               |              |         | <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>JIRA Issues</td>
<td>You can customise the title text at the top of the JIRA issues table with this parameter. For instance, setting the title to 'Bugs-to-fix' will replace the default 'JIRA Issues' text. This can help provide more context to the list of issues displayed. <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
</tr>
<tr>
<td>url</td>
<td>Yes</td>
<td>none</td>
<td>The URL of the XML view of your selected issues in JIRA Issue Navigator. <strong>Note:</strong> If the URL in the 'url' parameter does not contain a <code>tempMax</code> argument, then the value of <code>tempMax</code> will default to 500. If your JIRA server is version 3.12 or earlier, this means that the JIRA Issues macro will return a maximum of 500 issues. If your JIRA server is version 3.13 or later, a value of 500 means that the JIRA Issues macro will return a maximum of 500 issues per page.</td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td>100%</td>
<td>The width of the table displaying the JIRA issues. Can be indicated either as a percentage (%) or in pixels (px). <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
</tr>
</tbody>
</table>
Example:

```
(jiraissues:anonymous=true|url=http://jira.atlassian.com/sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml?jqlQuery=project%3DCONF+AND+%28summary+AND+project+jira issues+OR+description+AND+project+jira issues+OR+comment+AND+project+jira issues%29&tempMax=10|columns=type;key;summary|title=My List of Issues}
```

JUnit Report macro

Display a summary of JUnit test results.

**Macro name:** junitreport

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>directory</td>
<td>Must include either the directory or the url parameter</td>
<td>(None)</td>
<td>URL of a directory containing your test result files. This must be a directory name and not the XML file itself. Overrides the url parameter if you use both. Note: When using a local drive, you must use a directory name and not the XML file itself.</td>
</tr>
<tr>
<td>reportdetail</td>
<td>No</td>
<td>all</td>
<td>Level of detail required in the report. Available values: all, fixture, summary, failuresonly</td>
</tr>
</tbody>
</table>
| **url** | **Must include either the directory or the url parameter** | **(None)** | **URL of a particular test result XML file.**
This parameter is overridden by the directory parameter if you use both.
For Confluence installations that require authentication, you can specify login credentials as part of this parameter, in the form of URL parameters:

- **os_username** — The username of a Confluence user with permission to access the JUnit test results.
- **os_password** — The password of the Confluence user specified in the os_username parameter. |

| **debug** | **No** | **false** | **If the value of this parameter is true, the report will show the content of failures, as well as the error messages.** |

**Example:**

Loading JUnit reports from a local drive:

```plaintext
{junitreport:directory=file:///C:/TEMP/}
```

Loading JUnit reports from a network drive:

```plaintext
{junitreport:url=http://*host*/*path*}
```

Loading JUnit reports from a Confluence site:

```plaintext
{junitreport:url=http://yourConfluenceInstance.com/download/attachments/<page id>/file.xml}
```

Loading JUnit reports from a Confluence site that requires authentication:

If your Confluence site is not accessible by anonymous users, specify login credentials with the **os_username** and **os_password** URL parameters (as part of the macro’s url parameter). In this case, we are specifying a username of 'admin' and a password of 'secret'.
Labels List macro

Displays a hyperlinked alphabetical index of all labels within the current space.

**Macro name:** listlabels

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>spaceKey</td>
<td>No</td>
<td>Current space</td>
<td>The key of the space whose labels you want to display.</td>
</tr>
</tbody>
</table>

**Example:**

```
{livelsearch:spaceKey=DOC}
```

Livesearch macro

Add a dynamic search box to a wiki page.

**Macro name:** livelsearch

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>placeholder</td>
<td>No</td>
<td>(None)</td>
<td>Specify the placeholder text to appear in the search field.</td>
</tr>
<tr>
<td>labels</td>
<td>No</td>
<td>(None)</td>
<td>Specify labels to limit the search to content with that label.</td>
</tr>
<tr>
<td>spaceKey</td>
<td>No</td>
<td>All spaces</td>
<td>Specify a space key to limit the search to the given space.</td>
</tr>
<tr>
<td>type</td>
<td>No</td>
<td>All</td>
<td>Specify the content types to be included in the search - pages, blogs, comments, space descriptions, or all content types.</td>
</tr>
<tr>
<td>size</td>
<td>No</td>
<td>Medium</td>
<td>Specify the size of the search field - medium or large.</td>
</tr>
<tr>
<td>additional</td>
<td>No</td>
<td>Space Name</td>
<td>Display the space name, a page excerpt or none under the search result.</td>
</tr>
</tbody>
</table>
Example:

```text
{livesearch:spaceKey=DOC|size=large|placeholder=Search this space}
```

Lorem ipsum macro

Display a few paragraphs of pseudo-Latin text.

**Macro name:** loremipsum

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>default-parameter</td>
<td>No</td>
<td>3</td>
<td>Number of paragraphs. Determines the amount of pseudo-Latin (space-filler) text to display. The macro will display a maximum number of 30 paragraphs.</td>
</tr>
<tr>
<td>(No name in wiki markup)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Example:

```text
(loremipsum:2)
```

Multimedia macro

Displays videos, animations and more, sourced from a file attached to a Confluence page and displayed on your page.

**Macro name:** multimedia

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>page</td>
<td>No</td>
<td>Current page</td>
<td>Name of the page to which the multimedia file is attached.</td>
</tr>
<tr>
<td>space</td>
<td>No</td>
<td>Current space</td>
<td>Space key of the page that has the multimedia file attached.</td>
</tr>
<tr>
<td>name</td>
<td>Yes</td>
<td>None</td>
<td>File name of the multimedia file, which is attached to a Confluence page.</td>
</tr>
<tr>
<td>Parameter name</td>
<td>Required</td>
<td>Default</td>
<td>Parameter description and accepted values</td>
</tr>
<tr>
<td>------------------</td>
<td>----------</td>
<td>---------</td>
<td>----------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td></td>
<td>If not specified, the browser will determine the width based on the file type.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td></td>
<td>If not specified, the browser will determine the height based on the file type.</td>
</tr>
<tr>
<td>autostart</td>
<td>No</td>
<td>false</td>
<td>If the parameter is set to true then the video or audio file will start playing as soon as the page is loaded. If this option is set to false then the file will not play until the user clicks the icon or image on the page.</td>
</tr>
</tbody>
</table>

Example:

```
{multimedia:space=DOC|page=My macros|name=ninjas.swf|autostart=true}
```

Navigation Map macro

Displays a navigable map of the pages tagged with a given label.

**Macro name:** navmap

**Macro body:** None.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>cellWidth</td>
<td>No</td>
<td>90</td>
<td>Width of the cells, in pixels.</td>
</tr>
<tr>
<td>theme</td>
<td>No</td>
<td>(None)</td>
<td>Not applicable to Confluence OnDemand.</td>
</tr>
</tbody>
</table>

The name of a Velocity template that defines a theme for the navigation map.

The name of your theme file must have the following format: navmap-mytheme.vm, where mytheme is the name of your theme. That is also the value to use for the theme parameter of the macro. For example, if your theme file is navmap-roundededges.vm, use the value roundededges for this parameter.

Put your theme file in the confluence/WEB-INF/classes/templates/macros directory, in your Confluence installation. (Create the directory if it does not exist.)

Example:

```
(navmap:mylabel|wrapAfter=4|title=My map name|cellHeight=50px|theme=navmap-mytheme.vm|cellWidth=80px)
```

Network macro

Displays a list of Network activity for users on your Confluence site.

**Macro name:** network

**Macro body:** None.
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description</th>
</tr>
</thead>
</table>
| default-parameter              | Yes      | following | The display mode, which determines the set of users to be listed, based on their relationship to the specified user:  
  - following – those whom the user is following.  
  - followers – those who are following the user. |
| username                       | No       | Current user's username | The username of the Confluence user whose network interactions you wish to show. |
| max                            | No       | 30      | The maximum number of users to show. If the number of users exceeds the specified maximum, then the macro provides a 'Show All' link. This link leads to the specified user's network view, showing the complete list of network interactions. |
| theme                          | No       | full    | Determines how the user's network is displayed:  
  - full – Shows a large version of user's profile pictures. If the display mode is set to 'following', the macro offers the option to follow more users.  
  - tiny – Shows only the small version of user's profile pictures. |

**Example:**

```
{network:followers|username=admin|max=10|theme=full}
```

**Noformat macro**

Displays a block of text in monospace font.

**Macro name:** noformat

**Macro body:** Accepts plain text.
| nopanel       | No     | false   | Determines whether the macro draws a box around the content. Available values:  
|              |        |         | • true – Box is removed. In other words, there is no panel.  
|              |        |         | • false – Box is drawn. In other words, there is a panel.  |

**Example:**

```
{noformat:nopanel=true}http://www.example.com{noformat}
```

**Note macro**

Displays a block of text in a yellow highlighted box.

**Macro name:** note

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The words that will appear in the header of the note block.</td>
</tr>
</tbody>
</table>
| icon           | No       | true    | Determines whether an icon appears next to the title. The icon is an exclamation mark inside a yellow triangle. Available values:  
|                |          |         | • true – the icon appears  
|                |          |         | • false – the icon does not appear |

**Example:**

```
{note:icon=false|title=My title}
This is the content of my note.
{note}
```

**Office Excel macro**

Displays the content of an Excel spreadsheet on a wiki page.

**Macro name:** viewxls
## Macro body

None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the Excel spreadsheet to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the Excel spreadsheet is attached.</td>
</tr>
<tr>
<td>col</td>
<td>No</td>
<td>Last column with content</td>
<td>The number of the last column you want displayed, starting from '0' as the first column. <strong>Hint for reducing the size of the spreadsheet:</strong> Use the col and row parameters to reduce the size of the spreadsheet displayed on the wiki page. This is especially useful to prevent the display from showing empty cells. This will also help to prevent 'out of memory' errors.</td>
</tr>
<tr>
<td>row</td>
<td>No</td>
<td>Last row with content</td>
<td>The number of the last row you want displayed, starting from '0' as the first row.</td>
</tr>
</tbody>
</table>
| grid           | No       | true        | Determines whether the macro will show borders around the cells in the spreadsheet. Accepted values:  
  - true – Shows borders.  
  - false – Does not show borders. |
| sheet          | No       | The most-recently viewed worksheet | The name of the worksheet that you want displayed. |

**Example:**

```
{viewxls:col=5|page=Docs|name=My document.xls|grid=false|sheet=mySheet|row=5}
```
Office PowerPoint macro

Displays the content of a PowerPoint presentation on a wiki page.

**Macro name:** `viewppt`

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the PowerPoint presentation to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the PowerPoint presentation is attached.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>The height of the macro display, specified in pixels (for example: <code>10p x</code>, or just <code>10</code>) or as a percentage (for example: <code>20%</code>) of the window's height.</td>
<td></td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td>The width of the macro display, specified in pixels (for example: <code>10p x</code>, or just <code>10</code>) or as a percentage (for example: <code>20%</code>) of the window's height.</td>
<td></td>
</tr>
<tr>
<td>slide</td>
<td>No</td>
<td>All slides, starting with the first, as a slide show</td>
<td>The number of the slide that you want displayed on the Confluence page, where the first slide is numbered zero. Instead of a slide show, the page will display just the single slide, represented as a JPEG image.</td>
</tr>
</tbody>
</table>

**Example:**

```
(viewppt:height=20%|page=Docs|width=20%|name=My document.ppt|slide=4)
```

Office Word macro

Displays the content of a Word document on a wiki page.

**Macro name:** `viewdoc`

**Macro body:** None.
### Parameter name

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the Word document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the Word document is attached.</td>
</tr>
</tbody>
</table>

**Example:**

```
{viewdoc:page=Docs|name=My document.doc}
```

### Page Index macro

Creates a hyperlinked alphabetical index of all page titles within the current space.

**Macro name:** `index`

**Macro body:** None.

**Parameters:** None.

**Example:**

```
@index
```

### Page Properties macro

Allows you to embed metadata into a page and then display that data in tabular form using the Page Properties Report macro. Previously known as the Metadata Details macro.

**Macro name:** `details`

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>hidden</td>
<td>No</td>
<td>false</td>
<td>Determines whether the data in the Page Properties macro will be displayed on the current page. This setting does not affect the display of the detail in the Page Properties Report macro.</td>
</tr>
<tr>
<td>label</td>
<td>No</td>
<td>(None)</td>
<td>The label used to identify the metadata on this page. Confluence will add this label to the page.</td>
</tr>
</tbody>
</table>
Page Properties Report macro

Presents a tabulated summary of selected metadata, which has been embedded on pages using the Page Properties macro. Previously known as the Details Summary macro.

**Macro name:** detailssummary

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>label</td>
<td>No</td>
<td>(None)</td>
<td>Identifies the metadata to be included in the Page Properties Report. The report will show data from the Page Properties macros on the pages in the current space that have this label on the page.</td>
</tr>
</tbody>
</table>

Example:

```
{detailssummary:label=status}
```

Page Tree macro

Displays a dynamic, hierarchical list of pages starting from a specified parent (root) page.

**Macro name:** pagetree

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| excerpt        | No       | false   | Determines whether the page tree will show excerpts from each page. The excerpts must be defined on the individual pages by the Excerpt macro. Available values:  
- true – Show excerpts.  
- false – Do not show excerpts. |
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| expandCollapseAll    | No      | Determines whether the macro will offer the 'expand all' and 'collapse all' options at the top of the page tree. Your readers can click these links to open or close all branches of the tree at once. Available values:  
|                      | false   | • true – Show the 'expand all' and 'collapse all' options.  
|                      |         | • false – Do not show the options.                                                                                                      |
| reverse              | No      | Used in combination with the sort parameter. Determines the order of pages displayed in the tree, by reversing the default (ascending) order. Available values:  
|                      | false   | • true – Pages will be displayed in descending order by title.  
|                      |         | • false – Pages will be displayed in ascending order by title.                                                                         |
| root               | No    | The home page of the space | Specifies the parent page for the page tree. The tree will include all children of the given page, plus their children and grand-children, and so on. The tree will *not* include the root page itself. Available values:  
- A page title – to specify a page name for the parent or root of the tree. The tree will include all children and grand-children of the specified root. The tree will *not* include the specified root page itself.  
- `@home` – will include all pages under the home page of the space (default).  
- `@self` – will include all pages under the current page.  
- `@parent` – will include all pages under the parent of the current page, including the current page.  
- `@none` – will include all pages in the space, including orphaned pages and the home page. |
| searchBox         | No    | false                        | Determines whether the macro will offer a search box above the page tree. The search box allows your readers to enter a search term, and then searches within the page tree for the specified value. Available values:  
- `true` – Include the search box.  
- `false` – Do not include the search box. |
### sort

<table>
<thead>
<tr>
<th>No</th>
</tr>
</thead>
</table>

Determines the order in which pages are displayed in the tree. This sort order is for display purposes only. It does not permanently re-arrange the page order.

**Available values:**

- **bitwise** — sort alphabetically, for example: title1, title10, title2.
- **creation** — sort by date of creation.
- **modified** — sort by order of date last modified.
- **natural** — sort in 'natural' alphabetical order, for example: title1, title2, title10.
- **position** — sort by the default Confluence sorting rules. If your pages have been ordered manually, this sort will respect the defined order. Otherwise the pages will be displayed in the 'natural' alphabetical order, such as: title1, title2, title10.

### startDepth

| No | 1 |

Indicates how many levels of children the tree should show when it opens for the first time.

**Available values:** Any number greater than 0.

### Example:

```
{pagetree:root=Page Name|sort=natural|excerpt=true|reverse=false|startDepth=3|expandCollapseAll=true|searchBox=true}
```

### Page Tree Search macro

Adds a search box to your Confluence page and searches a hierarchy of pages starting from a specified parent (root) page.

**Macro name:** pagetreeSearch
Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>root</td>
<td>No</td>
<td>The home page of the space</td>
<td>Specifies the parent page for the page tree. The tree will include all children of the given page, plus their children and grand-children, and so on. The tree will not include the root page itself.</td>
</tr>
</tbody>
</table>

**Note:** Unlike the Page Tree macro, the Page Tree Search macro does not accept the special values that start with an @ sign, such as @home or @self.

Example:

```
{pagetreesearch:root=My page name}
```

Panel macro

Displays a block of text within a customisable panel.

**Macro name:** panel

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The words that will appear in the header of the panel.</td>
</tr>
</tbody>
</table>
| borderStyle    | No       | solid   | The style of the panel's border. Accepted values: *
|                |          |         | solid
|                |          |         | dashed
|                |          |         | Other valid CSS border styles. |
| borderColor    | No       |         | The colour of the panel's border. Colours can be specified as HTML colour names or hexadecimal codes. |
| borderWidth    | No       |         | The width of the panel's border, in pixels. |
**bgColor**

No

The background colour of the panel. Colours can be specified as HTML colour names or hexadecimal codes.

**titleBGColor**

No

The background colour of the title row of the panel. Colours can be specified as HTML colour names or hexadecimal codes.

**titleColor**

No

The colour of the text in the title row of the panel. Colours can be specified as HTML colour names or hexadecimal codes.

Example:

```
(panel:title=My title|borderStyle=dashed|borderColor=blue|titleBGColor=#00a400|titleColor=white|bgColor=#72bc72)
```

A formatted panel

---

**PDF macro**

Displays the content of a PDF document on a wiki page.

**Macro name:** viewpdf

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the PDF document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the PDF document is attached.</td>
</tr>
</tbody>
</table>

Example:

```
{viewpdf:page=Docs|name=My document.pdf}
```

---

**Popular Labels macro**

Displays the most popular labels used throughout your Confluence site or within a space.
**Macro name:** `popular-labels`  
**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| **style**      | No       | list    | Determines how the macro displays the labels. Accepted values:  
|                |          |         | • list – displays the labels as a bullet list, ordered by popularity (highest first).  
|                |          |         | • heatmap – displays the labels using different font sizes for each label depending on the label's popularity, ordered alphabetically by label name. |
| **count**      | No       | 100     | The number of labels to display.             |
| **spaceKey**   | No       | No restriction – include labels from all spaces in the site | If a space key is given, the macro will include only labels in that space. |

**Example:**

```
{popular-labels:style=heatmap|count=20|spaceKey=ds}
```

Profile Picture macro

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

Recently Updated Dashboard macro

Displays a list of the most recently changed content within Confluence and is intended for use on the Confluence dashboard.

**Macro name:** `recently-updated-dashboard`  
**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter</td>
<td>Value</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-----------</td>
<td>-------</td>
<td>-------------</td>
<td></td>
</tr>
</tbody>
</table>
| spaces    | No    | The space that contains the page on which the macro is added. Filters content by space. The macro will display only the pages and other content which belong to the space(s) you specify here. Accepted values:  
  - One or more space keys, separated by commas.  
  - An asterisk (*) means all spaces. |
| users     | No    | All users. Filters by username of the user who updated the content. The macro will only display content created and updated by the user(s) you specify here. You can specify one or more usernames separated by commas. |
| width     | No    | 100% The width of the macro display, specified as a percentage of the window width. |
| showProfilePic | No | false Determines whether the macro displays profile pictures of the users who updated the content. Accepted values:  
  - true – the macro will show profile pictures.  
  - false – the macro will not show profile pictures. |
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>labels</td>
<td>No</td>
<td>None. Labels are not used to filter the content.</td>
<td>Filters content by label. The macro will display only the pages and other content which are tagged with the label(s) you specify here. You can specify one or more labels, separated by commas. Note: If there are no pages matching any of the specified labels, then Confluence will ignore the labels and will list all recently updated pages, as well as showing a message, &quot;These labels don't exist and were ignored: xxx &quot;.</td>
</tr>
</tbody>
</table>
| types          | No       | All content types. | Filters content by type. You can specify one or more types, separated by commas. Accepted values:  
- page  
- blogpost or news  
- spacedesc  
- attachment  
- comment  
- mail  
- userinfo  

Example:

```
(recently-updated-dashboard:spaces=ds|users=admin|width=50%|showProfilePic=true|labels=choc|types=page)
```

Recently Updated macro

Displays a list of recently changed content (pages, news items, comments, etc).

**Macro name:** recently-updated

**Macro body:** None.
You can specify one or more space keys, separated by a comma or a space.

- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.
- To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:

- @self — The current space.
- @personal — All personal spaces.
- @global — All site spaces.
- @favorite — The spaces you have marked as favourite.
- @favourite — The same as @favorite above.
- @all — All spaces in your Confluence site.
- * — The same as @all above.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>author</td>
<td>No</td>
<td>All users.</td>
<td>Filters by the username of the user who updated the content. The macro will only display content created and updated by the user(s) you specify here. You can specify one or more authors, separated by a comma or a space. For example: jsmith, jbrown To include content from one user, but exclude from another user: jsmith,!jbrown</td>
</tr>
<tr>
<td>max</td>
<td>No</td>
<td>15</td>
<td>The maximum number of results to be displayed. The theoretical maximum value that this parameter can accept is 2 to the power of 31, minus 1 (or 2147483647). But this maximum is limited to 200 in the code, for performance reasons. More details are in this issue: CONF-19096</td>
</tr>
</tbody>
</table>
| hideHeading   | No       | false   | Determines whether the macro hides or displays the text "Recently Updated" as a title above the list of content. Accepted values:  
- true – Title is hidden.  
- false – Title is shown. |
| width         | No       | 100%    | The width of the macro display, specified as a percentage of the window width. |
| theme | No | concise | Choose the appearance of the macro.  
| labels | No | None. Labels are not used to filter the content. | Filters content by label. The macro will display only the pages and other content which are tagged with the label(s) you specify here. You can specify one or more labels, separated by commas.

**Note:** If there are no pages matching any of the specified labels, then Confluence will ignore the labels and will list all recently updated pages, as well as showing a message, "These labels don't exist and were ignored: xxx ".

Filter the results by label. The macro will display only the pages etc which are tagged with the label(s) you specify here.

You can specify one or more label values, separated by a comma or a space.

- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labelled with 'badpage'.
- To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage,+goodpage you will get only content which has at least two labels, being 'superpage' and 'goodpage'.
| types       | No          | All content types. | Filters content by type. You can specify one or more types, separated by commas. You can specify one or more types, separated by a comma or a space. To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of `-blogpost` you will get pages and all other content except for blog posts. Available values:  
- `page` — **Pages**.  
- `blogpost` or `news` — **Blog posts**, also known as news items.  
- `comment` — **Comments** on pages and blog posts.  
- `attachment` — **Attachments**.  
- `status` — **Status updates** made by other users. |

**Example:**

```
(recently-updated:spaces=ds|author=admin|max=10|hideHeading=true|width=50%|theme=sidebar|showProfilePic=true|labels=choc|types=page)
```

Recently Used Labels macro

Lists labels most recently used in a specified scope (global, space, or personal)

**Macro name:** `recently-used-labels`

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>None.</td>
<td>Adds a title to the top of the list in table style. Titles are only visible when the <code>style</code> parameter is set to <code>table</code>.</td>
</tr>
</tbody>
</table>
### Recently Used Labels macro

Lists labels frequently appearing on the same pages as the current page's labels.

**Macro name:** related-labels

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>labels</td>
<td>No</td>
<td>None</td>
<td>The label(s) for which you want to view related labels. If you include more than one label, separate them with commas.</td>
</tr>
</tbody>
</table>

**Example:**

```
{related-labels:labels=choc,cake}
```

### Related Labels macro

Lists labels frequently appearing on the same pages as the current page's labels.

**Macro name:** related-labels

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>labels</td>
<td>No</td>
<td>None</td>
<td>The label(s) for which you want to view related labels. If you include more than one label, separate them with commas.</td>
</tr>
</tbody>
</table>

**Example:**

```
{related-labels:labels=choc,cake}
```
Displays the contents of an RSS feed.

**Macro name:** rss

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>max</td>
<td>No</td>
<td>15</td>
<td>The maximum number of news items to display.</td>
</tr>
</tbody>
</table>
| showTitlesOnly | No       | false   | Determines whether the macro will show only the titles of the news items, or the titles plus content. Accepted values:  
|                |          |         | • true – Displays titles only.  
|                |          |         | • false – Displays titles and content. |
| url            | Yes      | (None)  | The URL of the RSS feed. |
| titleBar       | No       | true    | Determines whether the macro will show a title above the list of news items. Accepted values:  
|                |          |         | • true – Displays the title.  
|                |          |         | • false – Does not display a title. |

**Example:**

```
{rss:max=10|showTitlesOnly=true|url=http://myblog.com/feed|titleBar=false}
```

Search Results macro

Searches Confluence, and includes the results in the page.

**Macro name:** search

**Macro body:** None.
| **lastModified** | **No** | **(None.)** | Defines a period of time in weeks, days, hours and/or minutes. The macro will display the content modified within that time frame.  
These are the values you can use:  
- w = weeks  
- d = days  
- h = hours  
- m = minutes  
For example:  
- 2h 35m  
- 3d 30m  
Notes:  
- If no time category is specified, Confluence assumes minutes.  
- If you specify more than one time period (for example, weeks and days), you must separate the periods with a space. You can put them in any order.  
- The time categories are not case sensitive. For example, '4d' is the same as '4D'. |
| **query** | **Yes** | **(None.)** | The search terms which this macro will use to generate its results.  
You can refine your search query by using operators such as 'AND' and 'OR'. For example: my_term1 AND my_term2  
For more information, take a look at the documentation on the Confluence search syntax. |
<p>| <strong>contributor</strong> | <strong>No</strong> | <strong>(None.)</strong> | The username of a Confluence user. If this parameter is present, the macro will show only content created or updated by the given user. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>maxLimit</td>
<td>No</td>
<td>10</td>
<td>The maximum number of search results to display.</td>
</tr>
<tr>
<td>type</td>
<td>No</td>
<td>(None.)</td>
<td>The type of content to include in the search results. Accepted values: page, comment, blogpost, attachment, userinfo – the content of user profiles, spacedesc – the content of space descriptions</td>
</tr>
</tbody>
</table>

Example:

```
{search:lastModified=3w|query=choc|contributor=admin|maxLimit=10|type=page|spacekey=ds}
```

Section macro

Used with the Column macro to define columns on a page. See Working with page layouts and columns and sections.

**Macro name:** section

**Macro body:** Rich text, consisting of one or more Column macros.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>border</td>
<td>No</td>
<td>False</td>
<td>If the value is true, the columns in this section will have a dashed border.</td>
</tr>
</tbody>
</table>

Example:

```
{section:border=true}
{column:width=100px}
This is the content of *column 1*.
{column}
This is the content of *column 2*.
{section}
```

Space Attachments macro

Displays a list of attachments belonging to the current space.

**Macro name:** space-attachments
Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| showFilter     | No       | true    | Determines whether or not the filter panel is shown. If you select this option, people viewing the page will be able to filter the list of attachments by file type (extension) and by label. Accepted values:  
  - true – Macro displays the filter panel.  
  - false – Macro does not display the filter panel. |
| space          | No       | Current space. | Determines the Confluence space containing the attachments that the macro will display. |

Example:

```
{space-attachments:showFilter=false|space=ds}
```

Space Details macro

Displays the details of a Confluence space, including the space name, description, and more.

Macro name: space-details

Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>100%</td>
<td>The width of the space details table, specified as a percentage of the page width.</td>
</tr>
</tbody>
</table>

Example:

```
{space-details:width=50%}
```

Space Jump macro

Allows you to link from a page in one space to a page with the same name in another space, without knowing the name of the page when you create the link.

Macro name: spacejump
Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>alias</td>
<td>No</td>
<td>The name of the current page</td>
<td>The text to display as the hyperlinked text.</td>
</tr>
<tr>
<td>space</td>
<td>Yes</td>
<td>(None.)</td>
<td>The key of the space that contains a page with the same name as the current page. Space keys are case sensitive.</td>
</tr>
</tbody>
</table>

Example:

```text
{spacejump:alias=my link|space=ds}
```

Spaces List macro

Displays a list of the spaces visible to the user.

Macro name: spaces

Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| default-parameter      | No       | All spaces | Specify the view from which spaces are listed. Accepted values:  
| (Unnamed in wiki markup)|          |          |   • all – All spaces in the Confluence site.  
|                        |          |          |   • category – Spaces grouped according to space categories.  
|                        |          |          |   • favourite – Spaces in the reader’s list of favourites.  
|                        |          |          |   • new – Spaces created within the last 7 days.  
| width                  | No       | 100%     | The width of the list of spaces, specified as a percentage (%) of the window. |

Example:

```text
{spaces:favourite|width=80%}
```

Status macro
Displays a coloured lozenge, useful for reporting project status.

**Macro name:** status

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>colour</td>
<td>No</td>
<td>Grey</td>
<td>The colour of the lozenge. Accepted values: Grey, Red, Yellow, Green, Blue</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>The value of the colour parameter</td>
<td>The text that will appear inside the lozenge. If you do not specify any text, the title will be the colour of the lozenge, that is 'Grey', 'Red', 'Yellow', 'Green' or 'Blue'.</td>
</tr>
</tbody>
</table>
| subtle         | No       | false        | The style of the lozenge and its border. Accepted values:  
|                |          |              | false – The lozenge will have the default style: a solid coloured background with white text.  
|                |          |              | true – The lozenge will have the outline, or subtle, style: a white background with a coloured border and coloured text. |

Example:

```
{status:colour=Green|title=On track|subtle=true}
```

Table of Contents macro

Displays a table of contents based on the headings on the page.

**Macro name:** toc

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>printable</td>
<td>No</td>
<td>true</td>
<td>If you set this parameter to false, the table of contents will not be visible when you print the page.</td>
</tr>
</tbody>
</table>

Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
| **style** | **No** | **none** | The style of bullet point for each list item. You can use any valid CSS style. For example:  
- `none` – No list style is displayed.  
- `circle` – The list style is a circle.  
- `disc` – The list style is a filled circle. This is the typical bullet list, and is the one we are using in this example list.  
- `square` – The list style is a square.  
- `decimal` – The list is numbered (1, 2, 3, 4, 5).  
- `lower-alpha` – The list style is lower case, alphabetised (a, b, c, d, e).  
- `lower-roman` – The list style is lower-case roman numerals (i, ii, iii, iv, v, vi).  
- `upper-roman` – The list style is upper-case roman numerals (I, II, III, IV, V, VI). |
<p>| <strong>maxLevel</strong> | <strong>No</strong> | <strong>7</strong> | Maximum heading level. Use this parameter to select the highest heading level to include. For example, a value of 2 will list h1 and h2 levels, but will not include h3 and below. |
| <strong>indent</strong> | <strong>No</strong> | <strong>(None)</strong> | This parameter applies to vertical lists only (type = list). Use this parameter to indent the list items according to CSS quantities. For example, a value of <code>10px</code> will successively indent list heading groups by 10 pixels. Level 1 headings will be indented 10px, and level 2 headings by an additional 10px, and so on. |
| minLevel | No | 1 | Minimum heading level. The heading level at which the table of contents will start. For example, a value of 2 will list h2, h3, and h4 headings, but will not include h1 headings. |
| class | No | (None) | A CSS class name. If you have a custom style sheet, you can use this parameter to output the table of contents with the specified class attribute. |
| exclude | No | (None) | Specifies the headings to exclude by pattern matching. The value must be a regular expression. If this parameter is specified, the table of contents will include only the headings that match the regular expression. Example: .*[1//2] See Sun's Regex documentation for examples of constructing regular expression strings. |
| type | No | list | Defines the overall format of the table of contents. Available values: |
| | | | • list – displays the table of contents in a vertical list. |
| | | | • flat – displays a horizontal series of links. For example: [Heading 1] [Heading 2] [Heading 3]. |
| outline | No | false | A value of true will apply outline numbering to the headings as displayed in the table of contents. For example: 1.1, 1.2, 1.3. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>separator</td>
<td>No</td>
<td>This parameter applies to flat lists only (type = flat). Use this parameter to style the display of a flat list. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- brackets – Each item is enclosed by square brackets: [ ].</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- braces – Each item is enclosed by braces: { }.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- parens – Each item is enclosed by parentheses: ( ).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- pipe – The items are separated by a pipe:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- anything – The items are separated by the value you enter. You can enter any text as a separator, for example ***. If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters.</td>
</tr>
<tr>
<td>include</td>
<td>No</td>
<td>Specifies the headings to include by pattern matching. The value must be a regular expression. If this parameter is specified, the table of contents will ignore any headings that do not match the regular expression. Example: .* .(1//2)</td>
</tr>
<tr>
<td></td>
<td>(None)</td>
<td>See Sun's Regex documentation for examples of constructing regular expression strings.</td>
</tr>
</tbody>
</table>

**Example:**

This example shows a list-type table of contents.

```markdown
{toc:printable=true|style=square|maxLevel=2|indent=5px|minLevel=2|class=bigpink|exclude=[1//2]|type=list|outline=true|include=.*}
```

This example shows a flat table of contents.
Table of Content Zone macro

Displays a table of contents from a defined page 'zone'.

**Macro name:** toc-zone

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| location       | Yes      | both    | Determines where the macro will display the table of contents, relative to the zone delineated by the macro. Accepted values:  
  - **top** – The table of contents appears at the start of the zone.  
  - **bottom** – The table of contents appears at the end of the zone.  
  - **both** – The table of contents appears at the start and end of the zone. |
| printable      | No       | true    | If you set this parameter to false, the table of contents will not be visible when you print the page. |
| style          | No                  | none                  | The style of bullet point for each list item. You can use any valid CSS style. For example:  
|               |                     |                      | - none – No list style is displayed.  
|               |                     |                      | - circle – The list style is a circle.  
|               |                     |                      | - disc – The list style is a filled circle. This is the typical bullet list, and is the one we are using in this example list.  
|               |                     |                      | - square — The list style is a square.  
|               |                     |                      | - decimal — The list is numbered (1, 2, 3, 4, 5).  
|               |                     |                      | - lower-alpha — The list style is lower case, alphabetised (a, b, c, d, e).  
|               |                     |                      | - lower-roman — The list style is lower-case roman numerals (i, ii, iii, iv, v, vi).  
|               |                     |                      | - upper-roman — The list style is upper-case roman numerals (I, II, III, IV, V, VI).  
| maxLevel      | No                  | 7                    | Maximum heading level. Use this parameter to select the highest heading level to include. For example, a value of 2 will list h1 and h2 levels, but will not include h3 and below.  
| indent        | No                  | (None)               | This parameter applies to vertical lists only. Use this parameter to indent the list items according to CSS quantities. For example, a value of 10px will successively indent list heading groups by 10 pixels. Level 1 headings will be indented 10px, and level 2 headings by an additional 10px, and so on.  

Created in 2013 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>minLevel</td>
<td>No</td>
<td>1</td>
<td>Minimum heading level. The heading level at which the table of contents will start. For example, a value of 2 will list h2, h3, and h4 headings, but will not include h1 headings.</td>
</tr>
<tr>
<td>class</td>
<td>No</td>
<td>(None)</td>
<td>A CSS class name. If you have a custom style sheet, you can use this parameter to output the table of contents with the specified class attribute.</td>
</tr>
<tr>
<td>exclude</td>
<td>No</td>
<td>(None)</td>
<td>Specifies the headings to exclude by pattern matching. The value must be a regular expression. If this parameter is specified, the table of contents will include only the headings that match the regular expression. Example: .*/.[1</td>
</tr>
<tr>
<td>type</td>
<td>No</td>
<td>list</td>
<td>Defines the overall format of the table of contents. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- list – displays the table of contents in a vertical list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- flat – displays a horizontal series of links. For example: [Heading 1] [Heading 2] [Heading 3].</td>
</tr>
<tr>
<td>outline</td>
<td>No</td>
<td>false</td>
<td>A value of true will apply outline numbering to the headings as displayed in the table of contents. For example: 1.1, 1.2, 1.3.</td>
</tr>
</tbody>
</table>
| separator | No | brackets | This parameter applies to flat lists only (type=flat). Use this parameter to style the display of a flat list. Available values:
  - *brackets* – Each item is enclosed by square brackets: `[]`.
  - *braces* – Each item is enclosed by braces: `{}`.
  - *parens* – Each item is enclosed by parentheses: `( )`.
  - *pipe* – The items are separated by a pipe: `|`
  - *anything* – The items are separated by the value you enter. You can enter any text as a separator, for example `***`. If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters. |

| include | No | (None) | Specifies the headings to include by pattern matching. The value must be a regular expression. If this parameter is specified, the table of contents will ignore any headings that do not match the regular expression. Example: `.* \.[1/2]`

See Sun's Regexp documentation for examples of constructing regular expression strings. |

**Example:**

```plaintext
{toc-zone:printable=false|maxLevel=2|minLevel=2|location=top|type=flat|outline=true
|separator=pipe}
Only headings within this block are included in the table of contents.
{toc-zone}
```
**Tasklist macro**

Displays a dynamic task list which can be modified in view mode.

**Macro name:** tasklist

**Macro body:** Accepts wiki markup, for defining the tasks.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>Task List</td>
<td>The title to be displayed above the list of tasks.</td>
</tr>
</tbody>
</table>
| enableLocking      | No       | false       | Determines whether the macro allows users to lock individual tasks so that they cannot be changed. Accepted values:  
  - `true` – The task list offers the option to lock tasks.  
  - `false` – There is no option to lock a task. |
| width              | No       | 530px       | The width of the task list, specified in pixels (for example: `200px`) or as a percentage of page width (for example: `20%`). |
| promptOnDelete     | No       | false       | Determines whether Confluence will ask the user to confirm the deletion of a task. Accepted values:  
  - `true` – Asks for confirmation before deleting a task.  
  - `false` – Deletes the task without asking for confirmation. |

**Example:**

Note: The content inside the macro body (between the `{tasklist}` tags) defines the tasks in the list. This content is coded in wiki markup, as a table. The first row in the table defines the column headings for the task list. Each subsequent row defines a task.

```
{tasklist:title=My title|enableLocking=true|width=20%|promptOnDelete=true} |
||Completed||Priority||Locked||CreatedDate||CompletedDate||Assignee||Name|| |
|F|M|F|1371784117215|          |admin|Book tickets|
|F|M|F|1371784127222|          |admin|Check passport expiry|
{tasklist}
```

**Tip macro**
Displays a block of text in a green box.

**Macro name:** tip

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>icon</td>
<td>No</td>
<td>true</td>
<td>Determines whether to display the standard Confluence tip icon in the title bar of the tip box.</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the tip box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
</tbody>
</table>

**Example:**

```
{tip:icon=false|title=My title}
This is my hint.
{tip}
```

**User List macro**

Displays a list of Confluence users in a given group.

**Macro name:** userlister

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>groups</td>
<td>Yes</td>
<td>(None.)</td>
<td>One or more groups containing the Confluence users that the macro will list.</td>
</tr>
</tbody>
</table>

Accepted values:

- A comma-separated list of group names.
- * (an asterisk – The macro will list all users registered on the Confluence site.

An additional parameter is available to indicate whether a user is online. In order to make this parameter functional, a System Administrator needs to enable the User Log In Listener for your Confluence site.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter name</td>
<td>Required</td>
<td>Default</td>
<td>Parameter description and accepted values</td>
</tr>
<tr>
<td>----------------</td>
<td>----------</td>
<td>---------</td>
<td>-------------------------------------------</td>
</tr>
</tbody>
</table>
| online         | No       | All users | Instructs the macro to differentiate between online and offline users. Accepted values:  
  - Unspecified – The macro will show all registered users.  
  - true – The macro will show only online users.  
  - false – The macro will show only offline users.  
  Note: In order to make this parameter functional, a System Administrator needs to enable the User Log In Listener for your Confluence site. Not applicable to Confluence OnDemand.  

Example:  
{(userlister:groups=confluence-users|online=false)}

User Profile macro
Displays a summary of a given Confluence user's profile.

**Macro name:** profile

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| user           | Yes      | (None.) | The username of the Confluence user whose profile summary you wish to show.  

Example:  
(profile:user=admin)

User Status List macro
Displays a history of a given Confluence user's status updates.

**Macro name:** status-list

**Macro body:** None.
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>username</td>
<td>Yes</td>
<td>(None.)</td>
<td>The username of the Confluence user whose status updates you wish to show.</td>
</tr>
</tbody>
</table>

Example:

```
{status-list:username=admin}
```

Warning macro
Displays a block of text in a red highlight box.

**Macro name:** warning

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>icon</td>
<td>No</td>
<td>true</td>
<td>Determines whether to display a warning icon in the title bar of the text box.</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>(None.)</td>
<td>The title of the warning box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
</tbody>
</table>

Example:

```
{warning:icon=false|title=This is my title}
This is _important_ information.
{warning}
```

Widget Connector macro
Displays videos, slide shows, twitter chats, documents and more, sourced from other web sites and displayed on your Confluence page.

**Macro name:** widget

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>height</td>
<td>No</td>
<td></td>
<td>The height of the display, in pixels. Specify the number of pixels only.</td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td></td>
<td>The width of the display, in pixels. Specify the number of pixels only.</td>
</tr>
</tbody>
</table>
The URL provided by the external website for embedding content from that website onto another web page.

Example:

```html
```

Notes

- The 'Required' column indicates whether the parameter is required on data entry. If the parameter is not supplied, Confluence will insert default values as indicated in the 'Default' column.
- Wiki markup is not case sensitive. For example, you can specify a parameter name of sortBy or sortby.
- For a few macros in wiki markup, the default parameter may be unnamed. The examples on this page show the macros concerned. In such cases, the unnamed parameter is always the first parameter specified.
- A request from the Atlassian technical writers about comments and feedback: We would like to distinguish between the documentation of the current solution (this page) and any discussion of the solution and possible changes to Confluence wiki markup and/or the XHTML-based storage format. If you have a suggestion for, or correction of, this documentation, please add your suggestion to this page.

Wiki Markup Examples for Chart Macro

This page is an extension of Confluence Wiki Markup for Macros, which contains wiki markup examples for all Confluence macros. The Chart macro is a special case, because it offers so many options via parameters and chart types. This page offers additional examples for the Chart macro.

**Pie chart**

Here is a simple example of a pie chart.

Wiki markup

```
{chart:type=pie|title=Fish Sold}
|| Fish Type || 2004 || 2005 ||
|| Herring | 9,500 | 8,300 |
|| Salmon | 2,900 | 4,200 |
|| Tuna | 1,500 | 1,500 |
{chart}
```

Resulting chart
Bar chart

Here is a simple example of a bar chart.

Wiki markup

```
{chart:type=bar|title=Fish Sold}
|| Fish Type || 2004 || 2005 ||
|| Herring | 9,500 | 8,300 |
|| Salmon | 2,900 | 4,200 |
|| Tuna | 1,500 | 1,500 |
{chart}
```

Resulting chart

Time series chart

Here is an example of a time series chart.

Wiki markup
### Revenue

<table>
<thead>
<tr>
<th>Month</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2005</td>
<td>31.8</td>
</tr>
<tr>
<td>2/2005</td>
<td>41.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>51.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>33.8</td>
</tr>
<tr>
<td>5/2005</td>
<td>27.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>49.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>77.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>73.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>97.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>101.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>113.7</td>
</tr>
</tbody>
</table>

### Expenses

<table>
<thead>
<tr>
<th>Month</th>
<th>Expenses</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2005</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>45.0</td>
</tr>
<tr>
<td>5/2005</td>
<td>44.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>52.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>53.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>55.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>61.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>63.7</td>
</tr>
</tbody>
</table>

---

**Resulting chart**

![Resulting chart](chart)

**XY line chart**

Here is an example of an XY line chart.
Resulting chart

**XY bar chart**

Here is an example of an XY bar chart.
**XY area chart**

Here is an example of an XY area chart.

Wiki markup

```
{chart:type=xyarea}
<table>
<thead>
<tr>
<th></th>
<th>12</th>
<th>14</th>
<th>23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revenue</td>
<td>41.1</td>
<td>31.8</td>
<td>12.4</td>
</tr>
<tr>
<td>Expense</td>
<td>31.1</td>
<td>41.8</td>
<td>43.6</td>
</tr>
</tbody>
</table>
{chart}
```

Resulting chart

**Area chart**

Here are two examples of area charts.

Wiki markup for area chart 1
<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
<td>34</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Disatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very disatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>

Resulting area chart 1
Working with Confluence Gadgets

This section introduces the concept of gadgets in Confluence and provides an outline on how to use gadgets in Confluence and other web applications.

Introduction to Gadgets in Confluence

A gadget is a small object (i.e. a piece of functionality) offering dynamic content that can be placed into the page of:

- An Atlassian application's website, such as a Confluence page or blog post or a JIRA 4.0+ dashboard.
- A third-party application's website, such as iGoogle or Gmail. (But see the limitations on using Confluence gadgets in other applications.)

Gadgets allow interactions between Confluence and other compatible websites. Confluence interacts with gadgets that support the OpenSocial specification.

For more information about Atlassian gadgets, please refer to the introduction to Atlassian gadgets and the big list of Atlassian gadgets.

Using Gadgets in Confluence

You can place any gadget that complies with the OpenSocial specification from an external source, such as iGoogle or other Atlassian applications such as JIRA 4.0+, onto a Confluence page or blog post. To add a gadget to a page, use the Confluence macro browser to add a Gadget macro.

See the page on adding JIRA gadgets to a Confluence page.
Adding Confluence Gadgets in Other Applications

You can add a Confluence gadget to a JIRA dashboard or another Confluence site. In principle, you can also put a Confluence gadget on any other OpenSocial-compliant website such as iGoogle or Gmail. See the limitations on using Confluence gadgets in other applications.

**Adding a Confluence Gadget to JIRA**

See Adding a Confluence Gadget to a JIRA Dashboard.

**Adding a Confluence Gadget to Non-Atlassian Web Applications**

For instructions on how to add Confluence gadgets in another compatible non-Atlassian web application or container, refer to Configuring Confluence Gadgets for Use in Other Applications.

**Confluence Gadgets**

The Confluence Gadgets topic explains the purpose of the 'Confluence Gadgets' window and provides information about the gadgets which are bundled with Confluence.

**Adding a Confluence Gadget to a JIRA Dashboard**

JIRA 4.0 is the first major Atlassian application that can incorporate OpenSocial-compliant gadgets, such as Confluence gadgets onto its dashboard. This page explains how to add a Confluence gadget to the dashboard of a JIRA 4.0+ installation.

To add a Confluence gadget to a JIRA dashboard, complete the steps below.

Creating an Application Link between Confluence and JIRA

If your Confluence gadgets need to access user-restricted Confluence data, then your Confluence administrator must first establish an Application Link between your Confluence site and the JIRA site.

If you only need to access anonymously accessible Confluence data, then you can skip the section about adding an Application Link, and go directly to Finding a Confluence Gadget's URL, below.
On this page:
- Creating an Application Link between Confluence and JIRA
- Finding a Confluence Gadget's URL
- Adding a Confluence gadget to JIRA's gadget directory
- Adding a Confluence gadget to the JIRA dashboard

Related pages:
- All Atlassian gadgets
- Working with Confluence Gadgets
- Confluence User's Guide

Finding a Confluence Gadget's URL

A gadget's URL points to the gadget's XML specification file. These URLs look something like this:

```
http://example.com/my-gadget-location/my-gadget.xml
```

To find a Confluence gadget's URL:

1. Choose the help icon at top right of the screen, then choose Available Gadgets.
2. Find the gadget you want.
3. Copy the Gadget URL link to your clipboard.

**Screenshot: Finding a gadget's URL**

Adding a Confluence gadget to JIRA's gadget directory

To add a Confluence gadget to the gadget directory in JIRA:
1. Go to the dashboard by clicking **Dashboard** at the top left of the screen.

2. The dashboard will appear. Click **Add Gadget**.

3. The 'Add Gadget' screen appears, showing the list of gadgets in your directory. See **screenshot 1** below. Click **Add Gadget to Directory**.

   Note: You will only see this button if you have system administrator permissions in JIRA.

4. The 'Add Gadget to Directory' screen appears. See **screenshot 2** below. Paste the gadget URL (which you copied to your clipboard above) into the text box.

5. Click **Add Gadget**.

6. The gadget appears in your gadget directory. (It will be highlighted for a short time, so that you can see it easily.)

*Screenshot 1: Gadget directory with 'Add Gadget to Directory' button*
Adding a Confluence gadget to the JIRA dashboard

In the procedure below, 'your Atlassian dashboard' and 'your Atlassian application' refer to the JIRA dashboard and application, respectively.

You can add a gadget from the directory of gadgets that are available to your Atlassian application.

**To add a gadget to your Atlassian dashboard,**

1. Go to the dashboard by clicking the 'Dashboard' link or the 'Home' link at the top left of the screen.
2. The dashboard will appear, looking something like screenshot 1 below. Click 'Add Gadget'.
3. The 'Add Gadget' screen will display a list of available gadgets in your gadget directory, as shown in screenshot 2 below. Find the gadget you want, using one or more of the following tools:
   - Use the scroll bar on the right to move up and down the list of gadgets.
   - Select a category in the left-hand panel to display only gadgets in that category.
   - Start typing a key word for your gadget in the 'Search' textbox. The list of gadgets will change as you type, showing only gadgets that match your search term.
4. When you have found the gadget you want, click the 'Add it Now' button to add the gadget to your dashboard.

*Screenshot 1: An Atlassian dashboard*
Note:

- You need administrator privileges to add a gadget to the list of available gadgets. If you have permission to add gadgets to and remove gadgets from the directory itself, you will see the 'Add Gadget to Directory' and 'Remove' buttons on the 'Add Gadget' screen, as shown in the screenshot about. Please refer to the Gadgets and Dashboards Administration Guide.
- In Atlassian OnDemand products, it is not possible for administrators to add gadgets to the directory. If you would like to add an Atlassian gadget to a directory, please contact Atlassian Support.

Configuring Confluence Gadgets for Use in Other Applications

This page tells you how to add a Confluence gadget to another (external) application. The instructions and examples given in this topic focus on adding and using Confluence Gadgets in other web applications.

Atlassian support does not cover gadgets on external sites like iGoogle and Gmail

In principle, you should be able to add Atlassian gadgets to iGoogle, Gmail and other external sites that support OpenSocial gadgets. However, these external integrations are experimental at this stage and we have encountered problems with them. Please do have fun playing around with them, but be aware that Atlassian does not support the use of Atlassian gadgets on iGoogle, Gmail or other external web sites. See the detailed section on gadget limitations.

Gadgets that display information from Atlassian applications, such as Confluence, should be able to run on iGoogle, Gmail and other web applications that provide OpenSocial containers. Below are specific instructions for iGoogle and Gmail. You can experiment by adding a Confluence gadget to other web sites and applications, such as a Ning community like The Content Wrangler.

On this page:
- Overview of Adding a Confluence Gadget to Another Web Application
- Finding a Confluence Gadget's URL
- Adding an Atlassian Gadget to iGoogle
- Adding an Atlassian Gadget to Gmail
- Limitations and Support
- Related Topics
Overview of Adding a Confluence Gadget to Another Web Application

The exact procedure for adding a Confluence gadget depends on the application where you want to add the gadget. The basic steps are the same:

1. Find the Confluence gadget's URL, i.e. the URL for the gadget's XML specification file.
2. Ensure one of the following two mandatory (typically one-off) procedures have been conducted:
   • An OAuth relationship between Confluence (as the 'service provider') and the other web application (as the 'consumer') has been established. Refer to Configuring OAuth for more information about OAuth and instructions on establishing these relationships.
   • A Trusted Applications relationship between Confluence and JIRA has been established. Refer to Configuring Trusted Applications in the JIRA documentation for more information about establishing these relationships.
3. Follow the procedure provided by the external web application where you want to add the Confluence gadget.

Finding a Confluence Gadget's URL

A gadget's URL points to the gadget's XML specification file. These URLs look something like this:

```
http://example.com/my-gadget-location/my-gadget.xml
```

To find a Confluence gadget's URL:

1. Choose the help icon at top right of the screen, then choose Available Gadgets.
2. Find the gadget you want.
3. Copy the Gadget URL link to your clipboard.

Adding an Atlassian Gadget to iGoogle
You can customise your iGoogle home page by adding gadgets and moving them around on the page.

**To add an Atlassian gadget to your iGoogle page:**

1. First find the gadget's URL as described above.
2. Go to iGoogle and log in if you have a username and password.
3. Click **Add stuff** near the top right of the iGoogle page.
4. The Google gadget directory will appear, showing a list of available gadgets. Click **Add feed or gadget** in the right-hand panel.

5. A text box will open, as shown above. Enter or paste the gadget's URL from your clipboard into the textbox and click **Add**.
6. Go back to your iGoogle home page. The gadget will appear on your iGoogle page.

Adding an Atlassian Gadget to Gmail

You can add gadgets to the left-hand panel of your Gmail page.

**To add an Atlassian gadget to your Gmail page:**

1. First find the gadget's URL as described above.
2. Log in to Gmail.
3. Click **Settings** near the top right of the Gmail page. The Gmail settings page will appear.
4. Click the **Labs** tab. The Gmail Labs page will appear. This is a laboratory area or testing ground where Google allows you to use experimental features in Gmail.
5. Scroll down to find the feature called 'Add any gadget by URL'.
6. Select the **Enable** option, as shown here:

7. Click **Save Changes**.
8. A new **Gadgets** tab will appear on your ‘Settings’ page. Click the **Gadgets** tab. The ‘Gadgets’ page will appear, as shown in the screenshot below.
9. Enter or paste your gadget's URL into the **Add a gadget by its URL** box, then click **Add**.
10. The gadget will appear in the left-hand panel of your Gmail page, as shown in the screenshot below.

**Screenshot: Adding a gadget to Gmail**
Limitations and Support

⚠️ **Atlassian support does not cover gadgets on external sites like iGoogle and Gmail**
In principle, you should be able to add Atlassian gadgets to iGoogle, Gmail and other external sites that support OpenSocial gadgets. However, these external integrations are experimental at this stage and we have encountered problems with them. Please do have fun playing around with them, but be aware that Atlassian does not support the use of Atlassian gadgets on iGoogle, Gmail or other external web sites. See the detailed section on gadget limitations.

Related Topics

**The big list of Atlassian gadgets**

**Confluence Gadgets**
This page describes the purpose of the 'Confluence Gadgets' dialog and how to access it, and provides information about the gadgets that are bundled with Confluence.

Gadgets:
- Interact with and provide access to data in your Confluence installation.
- Can be used externally such as on a JIRA dashboard, a page or blog post of another Confluence site, or any compatible page on a web site that accepts gadgets, such as iGoogle. (But see the limitations on using Confluence gadgets in other applications.)

The gadgets dialog
The 'Confluence Gadgets' dialog displays a list of all the Confluence gadgets available in your Confluence installation. The Confluence gadgets bundled with Confluence are described below. Any additional Confluence gadgets installed by your Confluence administrator (typically as Confluence plugins), will also appear in this list.
To access the Confluence Gadgets dialog: Choose the help icon at top right of the screen, then choose Available Gadgets.

You can use a Confluence gadget within the same Confluence site, by adding it to a page or blog post using the gadget macro.

You can also add Confluence gadgets to external applications. See Adding a Confluence Gadget to a JIRA Dashboard and Configuring Confluence Gadgets for Use in Other Applications.

On this page:
- The gadgets dialog
- Confluence gadgets

Related pages:
- Adding a Confluence Gadget to a JIRA Dashboard
- Configuring Confluence Gadgets for Use in Other Applications
- Gadget Macro
- The big list of Atlassian gadgets
- Confluence User's Guide

Confluence gadgets

This following table lists the gadgets which are bundled with Confluence. Click the name of the gadget for more information.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
</table>

Screenshot: The 'Confluence Gadgets' dialog
### Confluence Page Gadget
The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.

### Activity Stream Gadget
The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your Confluence site.

### Confluence News Gadget
The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs and events at Atlassian.

### Confluence Quicknav Gadget
The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence site. For more information on how to use this feature, refer to the Quick Navigation Aid section of Searching Confluence.

**Activity Stream Gadget**
The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your Confluence site.

ℹ️ For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

In addition to showing a list of most recently changed content, the activity stream gadget also groups activities by separate date, and provides an RSS feed link to its content in the top-right corner.

**Activity Stream Gadget Properties**
Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Yes</td>
<td>None</td>
<td>Adds a title to the top of the Activity Stream.</td>
</tr>
<tr>
<td>Projects</td>
<td>No</td>
<td>None specified (i.e. display content in all spaces)</td>
<td>.Filters the content by space. This gadget will display only the pages etc. which belong to the space(s) you specify here.</td>
</tr>
<tr>
<td>Username</td>
<td>No</td>
<td>None specified (i.e. display content by all users)</td>
<td>Filters the results by user. The macro will display only the pages etc. which were last modified by the user(s) you specify here. You can specify one or more user, separated by a comma or a space.</td>
</tr>
</tbody>
</table>
### Number of Entries

<table>
<thead>
<tr>
<th></th>
<th>No</th>
<th>10</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Specify the maximum number of results to be displayed. A maximum of 10 results will be displayed by default. The maximum value that this property can accept is 100.</td>
<td></td>
</tr>
</tbody>
</table>

### Refresh Interval

<table>
<thead>
<tr>
<th></th>
<th>No</th>
<th>Never/(false)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Specify the time interval between each 'refresh' action undertaken by the activity stream gadget. A refresh makes the activity stream gadget reflect any new activity that has been conducted on the Confluence site.</td>
<td></td>
</tr>
</tbody>
</table>

---

**Confluence News Gadget**

The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent **Confluence Product Blogs** and **events at Atlassian**.

> For instructions on how to use Confluence gadgets in your applications, please see **Confluence Gadgets**.

Clicking an item in the Confluence news gadget takes you directly to the selected blog post of the **Confluence Product Blogs** feed or event details on the **events at Atlassian** page.

Clicking **More news** takes you to the **Confluence Product Blogs** feed page and clicking **More events** takes you to the **events at Atlassian** page.

**Screenshot: The News Gadget**

- **News**
  - **Confluence 5 Highlights: 4 Improvements to User and Content Managogs**
  - **Confluence 5 Highlights: Automagic Theming**
  - **How-to: Building a Company Glossary with Confluence – Part Three**

- **Events**
  - **INTRANET Reloaded**  
    **When**: Thu Apr 25, 2013 to Fri Apr 26, 2013
  - **Facebook Conference**  
    **When**: Tue Mar 12, 2013 5am to 10:30am PDT
  - **Zertifizierungsschulungen zum JIRA Professional von SEIBERT MEDIA**

  **More news...**

**Confluence: News Gadget Properties**

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.
Confluence Page Gadget

The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.

For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show News?</td>
<td>No</td>
<td>True</td>
<td>Shows a short list of the most recent Confluence Product Blogs.</td>
</tr>
<tr>
<td>Show Events?</td>
<td>No</td>
<td>True</td>
<td>Shows a short list of the most recent events at Atlassian.</td>
</tr>
<tr>
<td>Show Banners?</td>
<td>No</td>
<td>True</td>
<td>Shows any banner advertisements (if available).</td>
</tr>
</tbody>
</table>

Confluence Page Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.
Space | No | None | Specify the space that your desired page is located in. Suggestions will display in a dropdown when you start typing. (Note, this property is only used to make searching for pages easier. It is not required.)

Page | Yes | None | Specify the page that you want to display in your gadget. Suggestions will display in a dropdown when you start typing.

Show View Link | No | Yes | Select whether to display a link to view the page on your Confluence site. Clicking the link will open the page in Confluence.

Show Edit Link | No | No | Select whether to display a link to edit the page on your Confluence site. Clicking the link will open the page for editing in Confluence.

Refresh Interval | No | Never/false | Specify the time interval between each ‘refresh’ action undertaken by the page gadget. A refresh makes the activity stream gadget reflect any new activity that has been conducted on the Confluence site.

Working Macros

The Confluence page gadget will only render a subset of the macros that are used in Confluence correctly. Refer to the table below for the list of macros that work and do not work with the page gadget and known limitations.

<table>
<thead>
<tr>
<th>Macro</th>
<th>Works with page gadget?</th>
<th>Limitations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Stream</td>
<td>✗</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Anchor (within a page)</td>
<td>✅ *</td>
<td>Opens in a new page</td>
</tr>
<tr>
<td>Attachments</td>
<td>✅</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Some of the issues with macros in the page gadget can be worked around, if you are comfortable developing in Confluence. Please see Troubleshooting Macros in the Page Gadget for more information.

Key:

✅ Works with the page gadget
✅ * Partially works with the page gadget
❌ Does not work with the page gadget
<table>
<thead>
<tr>
<th>Feature</th>
<th>Status</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blog Posts</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Chart</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Children Display</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By Label</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By User</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Excerpt</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Gallery</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Include Page</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Info</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Labels List</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Livesearch</td>
<td>❌</td>
<td>N/A</td>
</tr>
<tr>
<td>Note</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata Summary</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Pagetree Search</td>
<td>❌</td>
<td>N/A</td>
</tr>
<tr>
<td>Pagetree</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Panel</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Quick Nav</td>
<td>❌</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Recently Updated</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>RSS Feed</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Section &amp; Column</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Spaces List</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>✔️</td>
<td>Works, however links will be opened in a new browser window when clicked.</td>
</tr>
<tr>
<td>Tasklist</td>
<td>✔️</td>
<td>Tasks can be viewed but not added/edited.</td>
</tr>
<tr>
<td>View File (PDF or PPT)</td>
<td>✔️</td>
<td>Works, but you may need to refresh the gadget the first time (see CONF-19932).</td>
</tr>
</tbody>
</table>
Confluence QuickNav Gadget

The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence site. For more information on how to use this feature, refer to the Quick Navigation Aid section of Searching Confluence.

ℹ️ For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

Screenshot: Using the QuickNav Gadget

Confluence QuickNav Gadget Properties

This gadget has no properties and cannot be customised.

Adding JIRA Gadgets to a Confluence Page

The Confluence Gadget macro is a specific type of macro which is used to display gadgets, including JIRA gadgets, in a Confluence page. Once you have configured external gadgets in the Confluence Administration Console, they will appear in the Macro Browser.

Before you can start adding JIRA Gadgets:

- Your JIRA administrator will need to configure JIRA to trust Confluence via Application Links. (Not required if your JIRA site allows anonymous access)
- Your Confluence administrator will need to add the JIRA gadget URL to the list of authorised external...
To add a JIRA Gadget to a Confluence page:

- Choose Insert > Other Macros.
- Navigate to the gadget you wish to add to the page and choose Insert.

Refer to the Gadget Macro page for more information on adding the macro to your page.

Developing Technical Documentation on Confluence Wiki

Confluence now ships with a space blueprint for creating documentation spaces. It has a homepage that can be customised to suit your needs and the sidebar displays all pages in the space in a page tree.

Go to Create Space > Documentation Space to try it out for yourself.

Welcome! This is a guide to using Confluence wiki for technical documentation. You will find this guide useful if you want to write a technical manual such as a user's guide, administrator's guide, installation guide, and so on.

- Creating your Technical Documentation Space
- Using Templates in Technical Documentation
- Re-using Content in Technical Documentation
- Managing the Life Cycle of your Technical Documentation
- Providing PDF Versions of your Technical Documentation
- Exporting and Printing Technical Documentation
- Essential Confluence Features for Technical Documentation
- Confluence Add-ons for Technical Documentation
- Further Reading about Developing Technical Documentation on Confluence

Related pages:
- Confluence User's Guide
- Confluence Administrator's Guide

Creating your Technical Documentation Space

This guide is for people who want to develop and publish technical documentation on Confluence wiki. You will find it useful if you want to write a technical manual such as a user's guide, administrator's guide, installation guide, and so on. This page is a quick-start guide to creating a wiki space for technical documentation.

Quick guide to creating a technical documentation space:

- Add a space and select the Documentation theme.
- Set the space permissions.
- Change the title and content of the space home page.
- Customise the Documentation theme.
- Create an inclusions library to manage your re-usable content.
- Create the table of contents for your manual or manuals, by adding top-level pages for all the usual sections (user's guide, administrator's guide, and so on).
- Customise your PDF layout and stylesheet, if required.
- Hint: Now that you have a good skeleton for a documentation space, save the space as a template space.

The rest of this page gives more details of the above procedure.

On this page:
- Step 1. Add your space
- Step 2. Set the space permissions
- Step 3. Customise the title and content of the space home page
- Step 4. Customise the Documentation theme
- Step 5. Create an inclusions library
- Step 6. Create the table of contents
- Step 7. (Optional) Customise the PDF layout and stylesheet
- Step 8. Save your new space as a template

Step 1. Add your space
Below is a quick guide to adding a space. See Creating a Space for a full description.

1. Go to the Confluence dashboard and choose Create Space > Blank Space.  
   *Hint*: If you cannot see Create Space, this means that you do not have permission to add spaces. Please contact your Confluence administrator.

2. Choose Next then enter a space name and a short, unique space key.

3. Leave the permission settings as default, or choose to allow only yourself to view or contribute content to this space. You can change these settings later and with more flexible options.

4. Choose Create.


6. Choose Look and Feel > Themes and select the Documentation theme.

7. Choose OK.

The home page of your new space will appear. Because you created the space, you are the space administrator. Now you can do some basic configuration, as described in the sections below. From this point on, instructions will refer to navigating in the Documentation theme, which is slightly different to the default theme.

Step 2. Set the space permissions

Define the space permissions to determine who can do what in your new space.

1. Choose Browse > Space Admin at the top of the screen.  
   *Note:* The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).

2. Choose Permissions.

3. Choose Edit Permissions.

4. Set the permissions to suit your needs then choose Save All.  
   - You can add groups and/or individual users to the list, then select the permissions for each group or user.
   - You can also set the permissions for anonymous users – these are people who have not logged in to the wiki. Anonymous access is available only if enabled for the entire Confluence site.
   - Note that you can change these permissions at any time. You may want to restrict the permissions to specific groups now, and later open the space to more people.

A bit more about permissions

Confluence has a robust and granular permissions scheme that you can use to determine who can view, comment on and even update the documentation. There are three levels of permissions in Confluence:

- Global permissions apply across the entire site.
- Space permissions apply to a space.
- Page restrictions allow you to restrict the editing and/or viewing of a specific page. Below we discuss a way of using these in the draft, review and publishing workflow.

Space permissions in Confluence are simple yet granular enough to be useful for technical documentation. You can:

- Use the permission levels to control who can create pages in the space, delete pages, create comments, delete comments, administer the space, and so on.
- Grant a permission level to one or more users, and/or to one or more groups, and/or to anonymous users.

Terminology:

- 'Anonymous' means people who have not logged in to the wiki.
- The 'confluence-users' group is the default group into which all new users are assigned (in OnDemand this group is called 'users'). Everyone who can log in to Confluence is a member of this group.

For example, you might allow your team full edit and administration rights while others can only add comments. Or you might grant the general public access to your documentation, while only staff members can update it.
Step 3. Customise the title and content of the space home page

When you created your space, Confluence created a home page with default content and a default title. You will want to change the title and content.

1. Go to your space home page.
2. By default, the page title is 'X Home', where 'X' is the name you gave the space.
3. Choose Edit.
4. The page opens in the editor. Change the title to suit your needs.
5. Update the content to suit your needs.  
   *Hint:* If you do not know what to add yet, just add a short description. You can refine the content of the page later. Take a look at an example of a home page.

6. Choose **Save**.

**Step 4: Customise the Documentation theme**

When you added the space you chose the Documentation theme, which provides a left-hand navigation bar and a good look and feel for technical documentation. If necessary, you can configure the Documentation theme to add your own page header and footer or to customise the default left-hand navigation bar. These customisations affect the online look and feel of your documentation. See [Configuring the Documentation Theme](#) for the full description.

1. Choose **Browse > Space Admin**. (If you have not yet applied the Documentation theme choose **Space Tools > Look and Feel > Themes**.)
2. Choose **Themes** in the left menu.
3. If the space is not yet using the Documentation theme, apply the theme now.
4. Choose **Configure theme**.

---

5. The 'Documentation Theme Configuration' screen appears. Customise the left-hand navigation bar, header and footer to suit your needs. Details are in the [documentation](#). Here are some hints:
   - The **Page Tree** check box determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.
   - The **Limit search results to the current space** check box determines whether Confluence will search only the current space or the whole Confluence site. This setting affects the default search. Viewers can override it each time they do a search.
   - Enter text, images, macros and other wiki markup into any or all of the three text boxes for the the left-hand navigation bar, header and footer. You can use the **Include macro** and the **Excerpt Include macro** to include re-usable content.
   - Any content you add to the navigation panel will appear **above** the default page tree.
   - If you like, you can remove the default page tree (by unticking the box) and add your own, customised version of the **Pagetree** macro instead.

6. Choose **Save**.
Example of a customised footer

Take a look at the footer of a page in the Crowd documentation space.

To produce the above footer, we have the following content in the footer panel in the Documentation theme configuration screen:

```
{include:_Documentation Footer|nopanel=true}
{include:ALLDOC:_Copyright Notice|nopanel=true}
```

Here it is in text form:

```
{include:_Documentation Footer|nopanel=true}
{include:ALLDOC:_Copyright Notice|nopanel=true}
```

The above content consists of two Include macros.

- The first macro includes a page called _Documentation Footer. This page contains the big blue buttons and hyperlinked text.
- The second macro includes a page from a different space, the ALLDOC space, called _Copyright Notice. This page includes our standard copyright notice, used in all our documentation spaces.

Step 5. Create an inclusions library

In Confluence, you can dynamically include content from one page into another page. You can include a whole page into another one, using the Include macro. You can also define an ‘excerpt’ on a page, and then include that excerpted text into another page using the Excerpt Include macro.

To organise your re-usable content, we recommend that you create a set of pages called an ‘inclusions library’.

1. Choose Create and create a new page in your space.
2. Enter a suitable title. We use '_InclusionsLibrary'. The unusual format of the title helps to let people know this page is special.
3. Enter some content and save the page. We enter text explaining the purpose of the inclusions library and how to re-use the content. You can copy our text by clicking through to one of the example pages listed below.
4. Choose Browse > Pages and drag your new page above the space homepage.
5. Go to your new inclusions page and choose Create to add child pages containing your re-usable content. See the examples of our own inclusions libraries listed in the examples below.
Some notes about inclusions libraries:

- The inclusions library is not a specific feature of Confluence. The pages in the inclusions library are just like any other Confluence page.
- The pages are located at the root of the wiki space, not under the home page. This means that they will not appear in the table of contents on the left and they will not be picked up by the search in the left-hand navigation bar either.
- The pages will be picked up by other searches, because they are just normal wiki pages.
- We have decided to start the page name with an underscore. For example, '_My Page Name'. This indicates that the page is slightly unusual, and will help prevent people from changing the page name or updating the content without realising that the content is re-used in various pages.

Examples of inclusions libraries

Here are some examples in our documentation:

- Crowd inclusions library
- Confluence inclusions library

Step 6. Create the table of contents

Create the table of contents for your documentation, by adding the top-level pages for all the usual sections:

- User's guide
- Administrator's guide
- Installation guide
- Configuration guide
- Release notes
- FAQ
- Whatever else you need

Follow these steps to create the table of contents:

1. Go to your space home page.
2. Choose Create to add a page as a child of the homepage.
3. Type the page title, 'User's Guide'.
4. Type the content of the page.
   
   Hint: If you do not know what to add yet, just add a short description then refine the content of the page later. If you like, you can add the Children macro. That will act as a table of contents on the page once you have added child pages.
5. Choose Save.

Now do the same for all the sections of your technical document.

Step 7. (Optional) Customise the PDF layout and stylesheet

If you are planning to provide PDF versions of your documentation, you may want to customise the PDF layout and styles for your space. You can skip this step for now and do it later, if you prefer. The instructions are in a separate section of this guide, dedicated to PDF. See Providing PDF Versions of your Technical Documentation.

Step 8. Save your new space as a template

This is a useful suggestion. Once you have set up your first documentation space and are more-or-less happy with it, use the Copy Space add-on (see notes below) to copy the space while it still has very little content. From this point on, you can copy it each time you want to create a new documentation space.

1. Choose Browse > Space Admin
2. Choose Copy Space in the left menu
   
   Hint: If you cannot see the 'Copy Space' option, this means that the add-on is not installed on your Confluence site. Refer to the documentation on installing add-ons. (Not applicable to Confluence OnDemand.)
3. The 'Copy Space' screen will appear. Enter the details as prompted, to copy your space to another new space.
4. Choose **Save**.

You now have a template space. From this point on, you can use the Copy Space add-on to copy the template space each time you want to create a new documentation space.

**Notes:**

- The Copy Space add-on is not covered by Atlassian support. However, the Atlassian technical writers use it for all our documentation. If you like, you can vote for an comment on the request for Atlassian support to cover this add-on: CONF-14198.
- Your site administrator will need to install the Copy Space add-on into Confluence. Refer to the documentation on installing add-ons. *Not applicable to Confluence OnDemand.*

**Next Steps**

You now have the basic structure and configuration for your technical documentation space. You have also created a handy template to use next time you need a space. What next? Take a look at **Using Templates in Technical Documentation**.

**Using Templates in Technical Documentation**

This page is part of the guide to developing technical documentation on Confluence Wiki. We have already shown you how to create your technical documentation space. Now we offer an introduction to the templates that Confluence provides.

**Quick guide to templates in Confluence:**

- A template is a page with predefined content that can be used as a prototype when creating other pages.
- Templates are available across the Confluence site (global templates) or per space (space templates).
- Both 'global templates' and 'space templates', as described on this page, define the content of a page. They do not define the content of an entire space.
- To create a template for an entire space, see our guide to creating your documentation space.
- Confluence blueprints provide predefined templates and added functionality.
- You can import predefined templates from the Atlassian Marketplace.
Deciding where to put your templates

Decide whether your template is useful across more than one space.

- If yes, create a global template. You will need Confluence administrator permissions.
- If no, create a space template.
  - You will need space administrator permissions for the relevant space(s).
  - You may have already saved your documentation space as a template, as described in our guide to creating your documentation space. In that case, it may be useful to save your template page in your template space. When you later copy the space, the template pages will be copied too.

Creating a global template

1. Choose the cog icon at top right of the screen, then choose Confluence Admin.
2. Choose Global Templates in the left-hand panel.
3. Choose Add New Global Template.

See Administering Site Templates for more information.

Creating a space template

1. Choose Browse > Space Admin at the top of the screen.
   Note: The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Templates from the space administration options.
3. Choose Add New Space Template.

See Adding a Template for more information.

Importing templates

If you have System Administrator permissions, you can download pre-defined templates from the Atlassian Marketplace in the form of a template bundle. Each template bundle contains one or more templates, created by Atlassian or third parties. See Importing Templates.

Using templates provided by blueprints

A blueprint is a page template with added functionality to help you create, manage and organise content in Confluence.

Confluence ships with some predefined blueprints. You can also download additional blueprints from the Atlassian Marketplace. You can customise the blueprint templates to suit your individual needs and even develop your own blueprints.

See Working with Blueprints.

Using a template to create a page

When people create a page on your Confluence site, they can choose to base their new page on a template.

1. Go to the page that will be the parent of your new page, and choose Create.
2. You will see a list of all available templates. Select a template then choose Next.

Next Steps

You now have a good idea of how Confluence templates work. What next? Take a look at Re-using Content in Technical Documentation.
Re-using Content in Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. In the page about creating your technical documentation space, we showed you how to set up an 'inclusions library' to contain content that you can re-use on more than one page. Now we offer further guidelines on re-using content in your documentation space.

Your documentation may be about using a software application, or it may be a technical manual for your product range. On this page, we use the term 'widget' to describe the things that you are documenting, such as the screen, form, document, product or object.

**Quick guide to re-using content:**

- Create an 'inclusions library' to manage your re-usable content. See our guide to creating your technical documentation space.
- Use the excerpt macro to define a re-usable section ('excerpt') on a page, or just decide to re-use the entire content of the page.
- Use the excerpt-include macro to include the excerpt from one page onto another page.
- Use the include macro to include the entire content of a page onto another page.
- Consider installing the Multi Excerpt add-on if you need to define multiple excerpts per page.

The rest of this page gives an overview and more details of the above procedures.

<table>
<thead>
<tr>
<th>On this page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reasons for re-using content</td>
</tr>
<tr>
<td>Defining an inclusions library</td>
</tr>
<tr>
<td>Working with excerpts and inclusions</td>
</tr>
<tr>
<td>Using the Include Page macro</td>
</tr>
<tr>
<td>Using the Excerpt Include macro</td>
</tr>
<tr>
<td>Using the Multi Excerpt add-on</td>
</tr>
<tr>
<td>An example of content re-use: a glossary</td>
</tr>
<tr>
<td>Creating a one-page glossary</td>
</tr>
<tr>
<td>Creating a glossary with child pages</td>
</tr>
<tr>
<td>Referring to glossary terms</td>
</tr>
<tr>
<td>Further reading</td>
</tr>
</tbody>
</table>

Reasons for re-using content

A golden rule for technical documentation is to write the content only once but allow that content to be used in many places and in many forms.

For example, you may have the following types of content:

- A technical manual that describes each widget in detail.
- Tips and tricks on how to get the most out of the widget.
- A step-by-step user guide for first-time users on how to use the most common widgets.
- A training manual with exercises or videos that people can follow in their own time.
- A one-page cheat sheet for users to stick up on their workstation.
- Text for a sales brochure that is sent out to a print house for production.

Each of these types of content will share common information, such as a glossary entry, a technical or marketing description of the widget, or a step-by-step guide on how to use the widget.

Some initial planning of your technical documentation will allow you to re-use any or all of the content you write, so there is only ever one place to update the content, and those changes flow through to all of your other documentation.

Defining an inclusions library

We recommend that you create an 'inclusions library' to manage your re-usable content. If you have not already done this, see our guide to creating your technical documentation space.

Working with excerpts and inclusions

Excerpts and inclusions (sometimes called 'includes') are very useful for re-using content:

- Use the Excerpt macro (excerpt) to define a re-usable section ('excerpt') on a page.
Use the Excerpt Include macro (`excerpt-include`) to include the excerpt on another page.
Use the Include Page macro (`include`) to include the entire content of a page onto another page.

A simple use case for an inclusion is a note or warning that is used in many places in your documentation. Here is an example:

**Example note -- "Draft in progress"
This document is still in draft status. Please treat the content with caution.**

Tip: Keep your re-usable pages short and sweet. Do not worry if you find that you need hundreds of pages to hold your inclusions. It helps to keep things separate and organised.

**Using the Include Page macro**

In this example, we use the Include Page macro to create a note that you can re-use on your documentation pages. The Include Page macro will include the entire content of one page into another page.

1. Create a page in your inclusions library called **_Draft Note**.
2. Add the content of the page. In this example, we use the Note macro with some text in the title and body:

   ```
   {note:title=Draft in progress}This document is still in draft status. Please treat the content with caution.{note}
   ```

3. Use the Include Page macro to include that note in any page in your documentation. For example:

   ```
   {include:_Draft Note|nopanel=true}
   ```

See the documentation on the Include Page macro for more details.

**Using the Excerpt Include macro**

An excerpt is a section of a page that you can include into another page.

1. Use the excerpt macro to define any content in your page that you want to be able to use elsewhere. This content can be as short as a word or as long as the entire page. For example, let's assume we have a page called 'My Short Poem':

   ```
   I really love this poem:
   {excerpt}
   Mary had a little lamb
   Its fleece was white as snow
   {excerpt}
   And I'm going to use it all over the place.
   ```

2. Use the Excerpt Include macro to include the excerpt into another page. For example:

   ```
   {excerpt-include:My Short Poem|nopanel=true}
   ```

You can only define one excerpt on a page. See the documentation on the Excerpt Include macro for more details.

To have multiple excerpts on a page, see the 'Multi Excerpt add-on' below.

**Using the Multi Excerpt add-on**

The Multi Excerpt add-on provides additional macros that enable you to have multiple excerpts on a page. A good example of where you would find this useful is in the glossary page discussed below. If you want to include a single glossary entry or a subset of the glossary entries in another page, then the named excerpts provided by
the Multi Excerpt add-on are very useful.

Notes:

- The Multi Excerpt add-on is a commercial add-on and is not free.
- Your Confluence system administrator will need to download and install the add-on into your Confluence site before you can use the macros described below. Refer to the documentation on installing add-ons.
- **Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.** Please refer to the Multi Excerpt add-on page for support details.

To have multiple excerpts on a page:

1. Use the following code on the base page containing the content you want to use elsewhere:

   ```
   {multi-excerpt:name=ExcerptName1}
   Excerpt text 1
   {multi-excerpt}
   Any other text
   {multi-excerpt:name=ExcerptName2}
   Excerpt text 2
   {multi-excerpt}
   ```

2. Use the following code on the page where you want to include the named excerpt:

   ```
   {multi-excerpt-include:pageTitle=PageName|name=ExcerptName1|nopanel=true}
   ```

3. You can also include excerpts from other spaces using the following syntax:

   ```
   {multi-excerpt-include:spaceKey:pageName|name=excerptName|nopanel=true}
   ```

See the Multi Excerpt add-on page for more details.

An example of content re-use: a glossary

A glossary is something that most technical documentation will require. There are a few ways to set up glossaries in Confluence. These are the most popular:

- All glossary entries on one page.
- Each glossary entry on separate child pages with a main page showing excerpts of the glossary.

Once you have defined the glossary entry, you can refer to it from the main pages of your technical documentation.

*Creating a one-page glossary*

This style of glossary is useful if the glossary entries tend to be short and there are not too many of them. The code blocks below use wiki markup. To insert wiki markup onto your page, open the editor and chose **Insert > Wiki Markup**.

1. Create a page named **Glossary**.
2. Add an alphabetical index at the top of the page and a heading for each letter of the alphabet:
3. Enter each glossary entry under the relevant alphabetical heading. Each glossary entry (term) should include:
   - An anchor tag, so that you can link to it from other pages.
   - The term itself.
   - A definition of the term.
   - A link to the page in your technical documentation that explains the term in greater detail, where relevant.

   {anchor:MyGlossaryTerm}
   h4. MyGlossaryTerm
   This is the definition of MyGlossaryTerm. See [Page Name] for more information.

4. Optionally, include a horizontal line between the terms. This depends on how long each entry is. If your glossary tends to have short entries, it may look too cluttered with horizontal lines.

---

See the glossary in the Confluence documentation for an example of this style of glossary (without the alphabetical index).

**Creating a glossary with child pages**

This style of glossary is useful if the glossary entries tend to be quite long or have additional information over and above the definition of the term. The code blocks below use wiki markup. To insert wiki markup onto your page, open the editor and choose Insert > Wiki Markup.

1. Create a page named **Glossary**.
2. Create a child page for each glossary entry (term). Each child page should contain:
   - The term as the title of the page.
   - The definition of the term in the body of the page.
   - Excerpt tags (excerpt) tags surrounding the definition.
   - Any additional information after the excerpt tags.

   (excerpt)
   This is the definition of MyGlossaryTerm
   (excerpt)
   More information to describe MyGlossaryTerm

3. On the 'Glossary' page, use the children macro to show the excerpts from each child page in a list, with the page name displayed in 'h4' style.

   {children:excerpt=true|style=h4}

See the glossary in the Crowd documentation for an example of this style of glossary.
Referring to glossary terms

In the main pages of your technical documentation, create a link to the glossary page for each glossary term.

_[MyGlossary Term|Glossary#MyGlossaryTerm]_

Note that this is a standard page link with an anchor. We have formatted the link as italics, because it helps to have the glossary links looking different to other page links. Readers can just skip over the glossary link if they are already familiar with the term.

Further reading

A blog post about content re-use: Technical Writing in a Wiki - Content Re-use and Structure (November 2010).

Next Steps

You now have a good idea of how to re-use content in a Confluence documentation space. What next? Take a look at Managing the Life Cycle of your Technical Documentation.

Managing the Life Cycle of your Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. We have already shown you how to create your technical documentation space, including how to set permissions for your space. Now we offer a quick-start guide to managing the life cycle of your technical documentation in Confluence. The life cycle includes drafting, reviewing and publishing a document, as well as managing documentation that is release-specific.

Quick guide to managing the technical documentation life cycle:

- Create draft pages with restricted permissions, to hide them until they are ready for publication.
- Set the permissions to allow reviewers to comment on and/or update the pages.
- When ready, publish the page by removing the permission restrictions.
- Monitor updates to your draft and published pages by watching your space and/or subscribing to RSS feeds.
- Use spaces as a mechanism for matching your documentation version to product releases: one space per major release number.
- Consider installing add-ons for extended workflow and publication management.

The rest of this page gives more details of the above procedures.

On this page:

- Using the built-in Confluence functionality to manage workflow and release cycle
  - Drafting, reviewing and publishing a page
  - Keeping track of documentation updates
    - Viewing the history of a page
    - Receiving email notification of updates
    - Monitoring updates via RSS feeds
  - Release management
    - Space keys
    - The release management process
  - Other scenarios using the built-in Confluence functionality
    - Using add-ons for extended workflow, publication and version management
  - Notes

Using the built-in Confluence functionality to manage workflow and release cycle

This section describes how to use the built-in Confluence functionality to manage your workflow (draft, review, publish) and to align your documentation version control to the product release cycle.

In this scenario we also assume that you want a live space that always has the same space key and always
contains the latest version of your documentation. This scenario suits the requirements of an organisation that wants their technical documentation to be 'live'. Various groups of people can refine the content as and when required. People can also subscribe to the space, knowing that they will always get the latest version of the documentation and comments.

This is the way we manage our documentation at Atlassian. The content of the wiki is dynamic, continuously updated, commented on, subscribed to and watched by thousands of people all over the world.

*Drafting, reviewing and publishing a page*

The workflow is as follows.

1. Create a page with restricted permissions. For example, you might restrict viewing to a group of people such as your team. On a public wiki, you might restrict viewing to staff members, so that the general public cannot see the page.
2. Write the page content.
3. Ask other people to review the page. They can add comments to the page or simply edit the page content directly.
4. Publish the page when ready, by doing the following:
   - Delete the comments on the page.
   - Remove the permission restrictions on the page. The page has now been published. The space permissions and site permissions now determine who can see and/or update the page.

The screenshot below shows a page under review. Notice the lock icon at top left, indicating that restricted permissions apply to this page.

*Keeping track of documentation updates*

On a wiki, it is quite usual for a number of different people to update a single page. Technical writers need to know what happens to our documents, both during review and after publication.

*Viewing the history of a page*

Confluence creates a new version of the page every time someone edits the page. The page history shows all the versions, with date, author, and any comments made on the update.

Go to the page and choose Tools > Page History.
On the page history view, you can:

- View the content of a specific version of the page.
- Revert to (restore) a specific version.
- Select any two versions and ask for a comparison, to see what has changed between those two versions.

See Page History and Page Comparison Views for detailed information.

It is all very well to go to a specific page and see what has happened to it, but how do you know when to go and look at the page? You need a notification of any changes made to your documentation space.

In Confluence, you can monitor updates to your documentation via email notifications and via RSS feeds.

Receiving email notification of updates

You can ‘watch’ a page or an entire space. Whenever anyone updates the page or space, you will receive an email notification.

1. Log in to Confluence, if you have not already done so.
2. Go to the page or blog post.
3. Choose Watch and select the relevant check box.

See Subscribing to Email Notifications of Updates to Confluence Content for details of the various notifications Confluence will send, and how to configure your notification settings.

Monitoring updates via RSS feeds

RSS feeds provide another way to keep track of updates. The simplest way to build an RSS feed is to use Confluence’s feed builder. This will give you a URL that you can ping to get the latest updates.

Below we describe how to set up a useful feed for your technical documentation space. Remember that you can adjust the settings to suit your own needs.

2. Check the boxes to select all the content types. (Even if you are not expecting comments, blog posts or mail in your documentation space, it does no harm to receive notifications if they do arrive.)
   - Pages and the comments and attachments on pages.
   - Blog posts and their comments and attachments.
   - Mail.
3. Select your documentation space from the list. Press Ctrl and click to select multiple spaces.
4. Choose Create RSS Feed.
5. This will take you to a new screen. Drag or copy the link into your RSS reader. The feed URL is linked to the words Drag or copy this link to your RSS reader.

Now that you have set up your RSS feed, you need to decide how to read it. There are various options to choose from. For example:

- Use an RSS reader, such as the Sage add-on for Firefox.
- Use an email client, such as Thunderbird.
See [Subscribing to RSS Feeds within Confluence](https://confluence.help) for details.

**Release management**

Let's assume that your product goes through a regular release cycle, and that you need to retain separate documentation for each major version of the product.

At Atlassian, we use spaces as our version-control mechanism.

- **Archive spaces.** At each release, we create a new archive space to house the *previous* version of the documentation.
- **The live space.** The documentation for the *latest* version of the product resides in the live space. The live space always retains the same space key and is always available for viewing and updating.

**Space keys**

The live space has just the product name as its space key. For example, for the Bamboo product the space key is ‘BAMBOO’. (See the [Bamboo documentation space](https://confluence.help).)

For the archived versions, we use a combination of the product name plus version number as the space key. For example, we use ‘BAMBOO040’ for the Bamboo 4.0 documentation, ‘BAMBOO041’ for the Bamboo 4.1 documentation, and so on.

**The release management process**

Here is an overview of the process we follow at Atlassian.

1. **Leading up to release date.** Work with hidden draft pages in the live space. A 'hidden draft' is simply a page that has [restricted permissions](https://confluence.help) applied:
   - For each new feature, create a new page with restricted permissions.
   - If you need to update existing pages, create a hidden copy of the existing page and apply the updates to the copy.
   - Follow the usual draft and review procedure for each page.

2. **A few days before release date.** Use the Copy Space add-on to copy the live space to a new space. This creates a snapshot of the current documentation, and will act as an archive for the current release which is soon to become the previous release. (We described the use of the Copy Space add-on in the earlier section of this guide: [Creating your Technical Documentation Space](https://confluence.help).)

3. **On release date.** Publish the updated documentation for the new version of the product:
   - Rebrand the live documentation space to reflect the new release number. In other words, change the space name and any other descriptions that include the product release number.
   - Unhide all the new pages, by removing the permission restrictions on each hidden page.
   - Copy the content of the updated pages to the proper pages, then delete the copies.
   - Export the newly updated space to PDF, HTML and XML, for those customers who prefer offline versions of the documentation.

Note that the above process is applicable to major releases of the product. For minor bug-fix releases, we simply update the documentation in the live space. We do not create archive spaces for every minor release.

The example below shows an extract from the dashboard of our documentation wiki, listing the spaces for different versions of the Bamboo documentation. (Bamboo is one of our products.) Each space holds the documentation for a specific major release of Bamboo.

**Screenshot:** Archive Bamboo spaces and Bamboo Latest for the current version of the documentation.
Other scenarios using the built-in Confluence functionality

It is easy to design other ways of managing your documentation spaces using the built-in Confluence functionality. For example, the simplest scenario is to publish a new space for every new release of your product, using the same Copy Space add-on as described above.

Using add-ons for extended workflow, publication and version management

For advanced workflow features, consider installing the Ad Hoc Workflows add-on onto your Confluence site. For advanced publication and concurrent version management consider using the Scroll Versions add-on. With Scroll Versions, you can set up and manage concurrent versions of your documentation in a single space. You can manage multiple versions of software, different product variants, and even multiple languages of documentation. Plan your page updates for a specified version and then publish them all at once.

See the documentation of Scroll Versions for more information.

Similarly, consider using the Content Publishing add-on to publish content from a master space to a published space. In this scenario, you will create a master space that contains your drafts in progress and new releases. The master space is visible only to the authors and reviewers. You will periodically publish the master space to a published space. This suits the requirements of an organisation that needs a ‘published’ or ‘official’ set of documentation, published only when a new version of the product is released. There is no requirement for continual updating of the documentation.

Automatic publishing. The Content Publishing add-on can work together with the Ad Hoc Workflows add-on to publish pages automatically when the page reaches a specified state in the workflow.

Notes

- **Installing add-ons.** If you decide to use additional add-ons, your system administrator will need to install them into your Confluence site. Refer to the documentation on Installing Add-ons.

- **Add-on support.** Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Next steps

Now you know about managing your workflow and documentation release process on Confluence. What next? Take a look at Providing PDF Versions of your Technical Documentation.
Providing PDF Versions of your Technical Documentation

This page is part of the guide on Developing Technical Documentation on Confluence Wiki.

Confluence is a platform for publishing online documentation. It also provides functionality for producing PDF versions of your documentation, allowing you to print the documentation, or to provide a copy to customers who are unable to access the online version. This guide describes how to export your technical documentation to PDF using Confluence's built-in PDF export. We also introduce a third-party add-on that provides additional PDF layout and style functionality.

Quick guide to PDF exports:

- Customise the PDF layout (title page, header and footer) and style, for use each time you export your documentation.
- Export a single page to PDF.
- Export a selection of pages or an entire space to PDF.
- Consider installing a third-party add-on for advanced PDF export functionality.

The rest of this page gives more details of the above procedures.

On this page:

- Customising the PDF layout and style
- Editing the PDF layout
- Setting a global PDF layout
- Setting the PDF layout at space level
- Editing the PDF stylesheet
- Setting a global PDF Stylesheet
- Setting a space PDF stylesheet
- Examples of PDF customisation
- Exporting to PDF
  - Exporting a single page to PDF
  - Exporting a selection of pages or a space to PDF
- Using the Scroll PDF Exporter add-on (Not applicable to Confluence OnDemand.)
- Notes

Customising the PDF layout and style

If you plan to create PDF versions of your documentation, you may want to customise the PDF layout and styles for your space. These customisations will be applied every time you export documentation to PDF.

Under PDF layout you can add HTML to customise the PDF title page, and the page headers and footers. Under PDF stylesheet, you can adjust the appearance of the PDF pages.

Editing the PDF layout

Setting a global PDF layout

1. Choose the cog icon at top right of the screen, then choose Confluence Admin.
2. Choose PDF Layout. You can enter HTML and CSS that will be rendered on the PDF title page, as well as page headers and footers.

Setting the PDF layout at space level

1. Go to the space and choose Space tools > Look and Feel on the sidebar. You'll need Space Admin permissions to do this.
2. Choose PDF Layout.
3. Choose Edit.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **PDF Layout** in space administration options.
3. Choose **Edit**.

You can customise the HTML that is generated for the following areas when the space is exported to PDF:

- **PDF Space Export Title Page** – title page.
- **PDF Space Export Header** – page headers.
- **PDF Space Export Footer** – page footers.

Enter your customisations into each text box as required. The PDF layout section accepts HTML code. You can include inline CSS in the HTML too.

### Editing the PDF stylesheet

#### Setting a global PDF Stylesheet

1. Choose the cog icon at top right of the screen, then choose **Confluence Admin**.
2. Choose **Look and Feel > PDF Stylesheet**. The following screen allows you to enter and save CSS code that will render content on each page.

#### Setting a space PDF stylesheet

1. Go to the space and choose **Space tools > Look and Feel** on the sidebar. You’ll need **Space Admin permissions** to do this.
2. Choose **PDF Stylesheet**.
3. Choose **Edit**.
4. Enter your customisations.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   
   **Note:** The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **PDF Stylesheet** in the space administration options.
3. Choose **Edit**.
4. Enter your customisations.

The PDF Export Stylesheet field accepts Cascading Style Sheets (CSS) rules. The ‘PDF Export Stylesheet’ page shows the current (e.g. customised) contents of your PDF stylesheet.

#### Examples of PDF customisation

Below are typical customisations you may want to make for your technical documentation. For more examples, see [Customising Exports to PDF](#).

### Adding a title page

You can create a title or cover page to your PDF document using HTML. Use the **PDF Space Export Title Page** section of the PDF layout to do this.

#### Adding a New Title Page

The following example uses HTML with an inline CSS rule to generate a title page.

```html
<div class="fsTitlePage" style="margin-left:auto;margin-top:75mm;margin-right:auto;page-break-after:always">
  <img src="/download/attachments/12345/titlepage.png"/>
</div>
```

#### Including Content Above Table of Contents in Default Title Page

The following example includes content above the automatically-generated table of contents that appears on the default title page, so that your title page includes your own content plus the table of contents.
Adding an Image to your Title Page

In the examples above, the title page includes an image called 'titlepage.png', centred in the middle of the page. The image is attached to a Confluence page and is referenced via its relative URL (that is, we use only the last part of the URL, excluding the Confluence site's base URL).

Follow these instructions to include an image on your title page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page.
3. Right-click the image and copy its location.
4. Paste the link into the appropriate `src` attribute within your PDF stylesheet, as shown above.
5. Remove the first part of the URL before `/download/`.

Adding headers and footers

You can add headers and footers to your PDF pages using HTML. Use the 'PDF Space Export Header' and 'PDF Space Export Footer' sections of the PDF layout to do this. For simple headers and footers, plain text is enough. The following example adds a simple copyright notice.

Copyright © 2010, Atlassian Pty Ltd.

Adding page numbers to a header or footer

To add page numbering, you need to combine customised HTML in the PDF Layout with customised CSS in the PDF Stylesheet.

1. PDF Layout HTML: In the Footer section (or the Header section), use an empty span element with a unique ID, for example `pageNum`, to act as a place holder for the page number.

   HTML - PDF Layout: Footer Section

   ```html
   <span id="pageNum"/>
   ```

2. PDF Stylesheet CSS: Create the following CSS selector rule for the empty span:

   CSS - PDF Stylesheet

   ```css
   #pageNum:before
   {
   content: counter(page);
   }
   ```

Analysing the above CSS selector rule in more detail:

- The `#pageNum` rule selects the HTML element with the specified ID of "pageNum", which is the span element we created for the header or footer.
- The `:before` part of the selector is a pseudo class that allows the insertion of content before the span element is processed.
- The `counter(page)` is a function that returns the current page number as its content.
- The `content` property tells the CSS processor that dynamic content (that is, an incrementing page number) is to be inserted at the span tag.

### Exporting to PDF

You can use the built-in Confluence PDF export to export a single page, a selection of pages or an entire space to a single PDF file.

#### Exporting a single page to PDF

You can export a Confluence page to PDF. This option exports a single page and is available to all users who have permission to view the page.

- Go to a page in the space and choose **Tools > Export to PDF**. Follow the prompts to export the page.

#### Exporting a selection of pages or a space to PDF

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Export**. This option will only be visible if you have the 'Export Space' permission.
3. Select **PDF** then choose **Next**
4. Decide whether you need to customise the export:
   - Select **Normal Export** to produce a PDF file containing all the pages that you have permission to view.
   - Select **Custom Export** if you want to export a subset of pages.
5. Select the pages you want to export.
   - You have the option to Select All or Deselect All pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
6. Choose **Export**.
7. When the export process has finished, download and save the PDF file as prompted.

If your space uses the Documentation theme:

1. Choose **Browse > Space Operations**
2. Choose **PDF Export** from the left menu.
3. Follow the steps above to export the Space.
Using the Scroll PDF Exporter add-on (Not applicable to Confluence OnDemand.)

The Scroll PDF Exporter provides flexible themes for configuring PDF layout and styles. You can select one of Scroll PDF Exporter's built-in themes and configure your table of contents, header and title pages. For even more flexibility, see the section How Tos in the Scroll PDF Exporter documentation.

For this advanced PDF export functionality, you will need to install the Scroll PDF Exporter add-on into your Confluence site.

Notes

- **Permissions required to export a space**: To use the space export functionality, you need the ‘Export Space’ permission. See the guide to space permissions.

- **Installing add-ons**: If you decide to use additional add-ons, your site administrator will need to install the add-ons into your Confluence site. Refer to the documentation on installing add-ons. (Not applicable to Confluence OnDemand.)

- **Add-on support**: Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

**Next Steps**

Now you know all about providing PDF versions of your documentation. What next? See other ways of Exporting and Printing Technical Documentation.

**Exporting and Printing Technical Documentation**
This page is part of the guide to developing technical documentation on Confluence Wiki. Confluence is a great tool for writing and maintaining technical documentation. There are times when we need to export the content out of Confluence into other forms, such as PDF, HTML, Microsoft Word and paper.

Confluence itself provides an export to both PDF and HTML. Add-ons provide additional functionality. Below are guidelines on exporting your technical documentation to various formats, including printed output.

**Quick guide to printing and exporting content:**

- Use the browser’s print option to print a single page.
- To print more than one page and for more advanced printing options, export your documentation to PDF.
- Confluence can export your pages to PDF, HTML, Confluence-specific XML and Word.
- Consider installing add-ons to export your pages to PDF (enhanced functionality), Word (enhanced functionality), DocBook XML, Eclipse Help and JavaHelp.
- Make your exports available to your customers for download by attaching the exported file to a Confluence page.

The rest of this page gives more details of the above procedures.

**On this page:**
- Printing
- Exporting to PDF
- Exporting to HTML
- Exporting to Confluence-specific XML
- Exporting to DocBook XML via an add-on
- Exporting to Microsoft Word
- Exporting to Microsoft Word via an add-on
- Exporting to Eclipse Help via an add-on
- Exporting to EPUB via an add-on
- Exporting to HTML via an add-on
- Making the PDF and other exported files available to your readers
- Notes
- Further reading

Printing

To print a single Confluence page, just use the browser’s print option. This option is available to all users who have permission to view the page.

To print more than one page and for more advanced printing options, export your documentation to PDF. See Providing PDF Versions of your Technical Documentation.

Exporting to PDF

Because this is such an important topic, we have a section of this guide dedicated to PDF. See Providing PDF Versions of your Technical Documentation.

Exporting to HTML

Using the built-in Confluence HTML export, you can export a single page, a selection of pages or an entire space to HTML. Confluence supplies the HTML and associated files in a zip file.

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Export. This option will only be visible if you have the ‘Export Space’ permission.
3. Select HTML then choose Next.
4. Decide whether you need to customise the export:
   - Select Normal Export to produce an HTML file containing all the pages that you have permission to view.
   - Select Custom Export if you want to export a subset of pages, or to exclude comments from the export.
5. Select the Include Comments check box if you want to include comments for the pages you are exporting.
6. Select the pages you want to export.
   - You have the option to Select All or Deselect All pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a
Choose Export. This will create a zipped archive of HTML files.

8. When the export process has finished, download the zipped archive as prompted, and extract the files into a folder.

If your space uses the Documentation theme:

2. Choose HTML Export from the left menu.
3. Follow the steps above to export the Space.

Exporting to Confluence-specific XML

Confluence provides an XML export. The XML produced is a proprietary format and is intended for backups or for transferring a space from one Confluence site to another. If you write your documentation on Confluence and your customers have Confluence too, then you can export your manuals to XML and customers can upload them onto their own Confluence site.

Exporting to DocBook XML via an add-on

Scroll DocBook Exporter converts Confluence pages to DocBook XML. Your Confluence system administrator
will need install the add-on onto your Confluence site.

Exporting to Microsoft Word

Confluence can export a page to Word. (Choose Tools > Export to Word.) This option performs a basic conversion of wiki content to HTML and applies some Word CSS stylesheets. It processes just one page at a time.

Exporting to Microsoft Word via an add-on

Scroll Office is a Confluence add-on. Once installed, Scroll Office replaces Confluence's built-in 'Export to Word' functionality. You can export a single page or a hierarchy of pages.

You can define your templates in Word in the usual way, and upload them to Confluence as global templates or space templates. When you export your Confluence pages to Word, Scroll Office will use those templates to build native Word documents from the wiki pages.

Scroll Office provides additional features such as enforcing page-breaks, setting the page orientation to landscape or portrait, and ignoring content. The latest version offers a REST-style API for automated export.

Exporting to Eclipse Help via an add-on

Scroll EclipseHelp Exporter provides an export to Eclipse Help format.

You can produce embeddable online help for Eclipse-based applications. Scroll EclipseHelp Exporter converts the Confluence content into EclipseHelp-compatible JAR files to create a standalone online help or a context-sensitive help.

**A hint about the Eclipse Help platform:** You can use a cut-down version of the Eclipse Help platform to provide online documentation for any system. It doesn't have to be an Eclipse tool that you are documenting. For some ideas, take a look at a couple of articles about documenting your project using the Eclipse help system.

Exporting to EPUB via an add-on

The Scroll EPUB Exporter outputs an ebook in the common EPUB format that can be read on iPads, iPhones and any other ebook reader.

Exporting to HTML via an add-on

The Scroll HTML Exporter enables the delivery of Confluence content from a web server. It converts the pages into static HTML pages that can be uploaded to a web server. The output of the Scroll HTML exporter can also be used as an input to produce other HTML-based help formats such as WinHelp and HTML Help.

Making the PDF and other exported files available to your readers

There are a number of ways to make your exported files available to your readers, such as putting the files on a disc and shipping them with your product.

One of the simplest ways is to attach the files to a Confluence page. (See Attaching Files to a Page.)

Atlassian uses the out-of-the-box Confluence export functionality to provide PDF, HTML and XML versions of our documentation. People can download the files from our documentation wiki. For example, here are the JIRA documentation downloads and the Confluence documentation downloads.

Notes

- **Permissions required to export a space.** To use the space export functionality, you need the 'Export Space' permission. See the guide to space permissions.

- **Installing add-ons.** If you decide to use additional add-ons, your site administrator will need to install the add-ons into your Confluence site. Refer to the documentation on installing add-ons.

- **Add-on support.** Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Further reading
• A blog post about exporting and importing content from/to Confluence: Technical Writing in a Wiki - Single Source Publishing (November 2010).
• A good overview of the Scroll Office features in this blog post (August 2010) and the followup post (November 2010).

**Next steps**

Now you know about a number of ways to get your technical documentation out of Confluence into various formats, for printing or for input into another system or process flow. What next? Take a look at Essential Confluence Features for Technical Documentation.

**Essential Confluence Features for Technical Documentation**

This page is part of the guide to developing technical documentation on Confluence. In this section we highlight the built-in Confluence macros that are most useful in technical documentation. For more information about Confluence macros, see Working with Macros.

### On this page:
- Auto-generating a table of contents for page content
- Drawing attention to elements of a page
- Putting content inside customisable Panels
- Inserting anchor links on pages
- Structuring content using sections and columns
- Making your documentation more engaging by embedding videos

**Auto-generating a table of contents for page content**

It is important to make it easy for viewers to jump to the section of a Confluence page that they are most interested in. The Table of Contents macro helps people navigate lengthy pages by summarising the content structure and providing links to headings used on the page.

- Click here to see a common example >>

2. Each feature in the release is a heading on the page.
3. You can generate a list of hyperlinks to each of the features in the release notes by inserting the Table of Contents macro:

   ![Inserting a Table of Contents macro](image)

4. The image below shows the Table of Contents macro inserted at the top of the 'Release Notes' page. Note that we have excluded the 'Highlights of Confluence 4.0' heading from the table of contents by modifying the macro's parameters.
The image below shows the macro parameters specified in the macro browser. Note the 'Minimum Heading Level' and 'Maximum Heading Level' parameters.
Often when creating documentation there are elements of a page that you want to highlight, or draw the viewers' attention to. Confluence ships with the following macros that help you focus a viewer's attention to a note, information, tip or warning.  

Click here to see a common example >>

**Note macro**

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
</table>
| The Note macro allows you to highlight a note on a Confluence page. It creates a yellow coloured box surrounding your text, as shown to the right. See Note Macro for more examples and instructions. | Draft in progress  
This document is a draft and is under development. |

**Info macro**

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
</table>
| The Info macro allows you to highlight helpful information on a Confluence page. It creates a blue coloured box surrounding your text, as shown to the right. See Info Macro for more examples and instructions. | Did you know?  
Confluence is the best wiki ever. |

**Tip macro**

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
</table>
| The Tip macro allows you to highlight a helpful tip on a Confluence page. It creates a green coloured box surrounding your text, as shown to the right. See Tip Macro for more examples and instructions. | Learn more  
Check out this blog post: Technical Writing in a Wiki: Technical Communicators Explain How & Why? |

**Warning macro**

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
</table>
| The Warning macro allows you to highlight a warning note on a Confluence page. It creates a red coloured box surrounding your text, as shown to the right. See Warning Macro for more examples and instructions. | Draft  
This page is a draft in progress and visible to Atlassian staff only. |

---

**Return to top of page**

Putting content inside customisable Panels

Using the Panel macro, you can place content inside a customisable coloured panel. This is particularly useful when you want to clearly separate elements on a page.
Click here to see a common example >>

1. You are documenting a procedure which involves a number of steps.
2. You want to call out the steps of the procedure from the rest of the page by placing it inside a coloured box, or panel.
3. You can create a coloured panel using the Panel macro.
4. The image below shows the parameters set for the panel using the macro browser.

Inserting anchor links on pages

Anchor links can be especially useful when navigating between sections of a long document or when you want to link to a segment of a page from another page. The Anchor macro allows you to link to specific parts of a page.

Click here to see a common example >>

1. You are documenting part of a user guide.
2. The page is split into multiple sections.
3. After each section you want to provide a link for viewers to click, taking them back to the top of the page.
4. To achieve this you first must create an anchor at the top of the page using the Anchor macro. You can give the anchor any name you like. In the image below, the anchor at the top of the page will be named 'top'.
5. The anchor placeholder will appear to indicate where your anchor link is located on the page:

![Anchor placeholder](image)

6. Create a link to the anchor, anywhere on the page, using the Link Browser. The image below shows a link to the anchor called 'top' by using the hash '#' followed by the name of the anchor you created earlier, with an alias of 'Return to Top'.

![Link to Anchor](image)
Structuring content using sections and columns

Sometimes it is necessary to structure content into sections and columns. The details are in Working with Page Layouts and Columns and Sections.

- Page layouts allow you to add sections to your page and then apply pre-defined column layouts to each section (for example, 2 column, three column). You can add multiple sections to a page.
- The Section and Column macros allow more flexibility. You can set the width of the columns, and put the sections and columns in any part of the page. Each section can contain any number of columns, created using the Column macro.
- Columns can either have a fixed width, specified in pixels, or a dynamic width, specified as a percentage of the page width.
- Note: whether you are using page layouts or macros, a column is always created inside a section.

See Working with Anchors for more examples and instructions.

Click here to see a common example >>

The images below show part of a Confluence page with two sections (outlined in red), each with two columns (blue) of different widths.
1. **Section 1:**

   1. Put a name to your face
   2. Learn how content is organised
   3. Get familiar with the Confluence screens
   4. Start creating content
   5. Add a panel to your page

2. **Columns in section 1 – left column has a fixed width of 400 pixels:**

   1. Put a name to your face
   2. Learn how content is organised
   3. Get familiar with the Confluence screens
   4. Start creating content
   5. Add a panel to your page
3. Section 2:

1. Put a name to your face
2. Learn how content is organised
3. Get familiar with the Confluence screens
4. Start creating content
5. Add a panel to your page

Put a face to your name
Your profile picture is used to identify you across Confluence. Upload your own picture via your Profile.
Learn More >>

1. Put a name to your face
2. Learn how content is organised
3. Get familiar with the Confluence screens
4. Start creating content
5. Add a panel to your page

4. Columns in section 2 – left column has a fixed width of 10 pixels:

Put a face to your name
Your profile picture is used to identify you across Confluence. Upload your own picture via your Profile.
Learn More >>

Return to top of page

Making your documentation more engaging by embedding videos

Pictures can be worth a thousand words. The same can be said for videos. Often, it’s easy to explain a concept or demonstrate a procedure using a video. The Widget macro allows you to embed web content, including YouTube and Vimeo videos, in a Confluence page.
Click here to see a common example >>

1. You release a new version of your product.
2. You document the release notes on a Confluence page.
3. The marketing team creates a video demonstrating the new features of the release and uploads it to YouTube.
4. You can embed the video in your release notes using the Widget macro, for playback on your Confluence page.
a. Edit the page and choose **Insert > Other Macros** in the editor toolbar.

b. Search for the 'Widget Connector'.

c. Insert the URL of your YouTube video into the **Web Sites Widget URL** field.
d. Choose **Insert** and save your page.

![Confluence 4.0 Release Notes](image)

See **Widget Connector Macro** for information on the supported services and for more examples.

**Return to top of page**

**Next steps**

Take a look at **Confluence Add-ons for Technical Documentation**.

**Confluence Add-ons for Technical Documentation**

This page is part of the guide to developing technical documentation on Confluence. In this section we highlight some of the Confluence add-ons that are useful for technical writers in designing and developing documentation.

An add-on is an extension module that you can add to your Confluence site to extend the wiki’s core functionality. It is similar to an add-on for your browser.

An add-on that specifically plugs into an Atlassian application such as Confluence is sometimes called a plugin. The terms 'plugin' and 'add-on' are often used interchangeably. Confluence add-ons may be developed by Atlassian or by third parties. To find an add-on featured on this page, and other add-ons too, visit the [Atlassian Marketplace](https://marketplace.atlassian.com).

**Drawing tools**

Below are some popular tools. Search the [Atlassian Marketplace](https://marketplace.atlassian.com) to see a full list of drawing and diagram add-ons for Confluence.

**Gliffy**

The Gliffy add-on provides an embedded diagram editor. With Gliffy you can create and edit diagrams directly on a Confluence page. Gliffy supports various diagram types (UML, business process, and so on).

**Commercial or free?** Commercial.

**Alternatives:** As an alternative you can use the standalone version of Gliffy available at [http://www.gliffy.com/](http://www.gliffy.com/). Gliffy online has a free basic version.

**More information:** See the [Gliffy add-on page](https://marketplace.atlassian.com/plugins/gliffy).

**Lucidchart**

Using Lucidchart, you can draw flowcharts, wireframes, UML diagrams, mind maps, and more, inside the web editor, then integrate the diagram with Confluence. Include interactivity such as linking to pages within Confluence or other pages inside the diagram.

**Commercial or free?** Commercial.

**More information:** See the [Lucidchart add-on page](https://marketplace.atlassian.com/plugins/lucidchart).

**Creately**

Use Creately to draw flowcharts, UML diagrams, database diagrams, wireframes, mindmaps, UI mockups,
workflow diagrams, network diagrams, org charts, and Gantt charts.

**Commercial or free?** Commercial.

**More information:** See the [Creately add-on page](#).

**yWorks Diagrams**

Use [yWorks Diagrams](#) to create and edit diagrams directly inside Confluence.

**Commercial or free?** Commercial.

**More information:** See the [yWorks Diagrams add-on page](#).

---

**On this page:**

- Drawing tools
  - Gliffy
  - Lucidchart
  - Creately
  - yWorks Diagrams
- Add-ons for enhanced content manipulation
  - Quick overview of macros
  - Composition add-on
  - Using the Composition add-on to outline text blocks
  - Using the Composition add-on to add tabs to a page
  - Using the Composition add-on to flow your text around images
  - Scaffolding add-on
- Extended version control
  - Scroll Versions
  - Attachment Checkout add-on
- Add-ons featured in other parts of this guide
- Notes
- Further reading

---

**Add-ons for enhanced content manipulation**

All content extensions are provided by **macros** in Confluence. Some macros are built in to Confluence. Other macros are supplied by add-ons.

**Quick overview of macros**

Before looking at add-ons, let’s take a quick look at macros in general. There are two ways to add a macro to your page:

- Use the **macro browser**. This is the simplest and recommended way.
- Or insert the macro’s name in curly brackets into the text of your page and specify the parameters.

**Click here to see an example of a macro >>**

The following code uses the (include) macro to insert the text from the page called 'My Page'.

```text
Some content on my page.
{include:My Page}
Some more content on my page.
```

Let’s assume ‘My Page’ contains just two lines:

```
I love chocolate.
Chocolate loves me.
```

The resulting page will look like this:

```
Some content on my page.
```

A number of macros are shipped with your Confluence installation by default. See Working with Macros. Below we describe some add-ons that provide additional useful macros for Confluence:

**Composition add-on**

The Composition add-on provides macros which allow finer control over the layout (composition) of a page. Using these macros, you can:

- Outline your text blocks.
- Add tabs to a page.
- Flow your text around the images or diagrams on the page.

**Commercial or free:** Commercial.

**Using the Composition add-on to outline text blocks**

Use the \{cloak\} macro to outline a text block.

**Usage:** The following code creates a text block named 'SeeAlso' for the outlined 'See Also' section within a page. The text block with id='SeeAlso' will be hidden after the 'See Also' title:

```plaintext
{composition-setup}

h2. {toggle-cloak:id=SeeAlso} See Also
{cloak:id=SeeAlso}

h3. Working With Macros:
[Link 1]
[Link 2]

h3. Working with Rich Text Editor:
[Link 3]
[Link 4]

{cloak}
```

**Alternatives:** You can also use the \{expand\} macro available in Confluence by default, but this macro can outline only text of the same level and cannot hide headings within the text. The \{expand\} macro does not require parameters and just hides the text placed between the \{expand\} tags.

**Note:** If you need to outline a text block containing nested headings, consider the text structure. Maybe the block is too big. You could create a child page from this block to decompose the whole text. Then you can include and outline the text block using the \{include\} macro within \{expand\}.

**Using the Composition add-on to add tabs to a page**

Use the \{deck\} and \{card\} macros to separate content between tabs on the same page.

**Usage:** The following code creates two tabs with client information:

```plaintext
{composition-setup}

h2. {toggle-cloak:id=SeeAlso} See Also
{cloak:id=SeeAlso}

h3. Working With Macros:
[Link 1]
[Link 2]

h3. Working with Rich Text Editor:
[Link 3]
[Link 4]

{cloak}
```
Using the Composition add-on to flow your text around images

Use the {float} macro to make your text flow around images or diagrams.

Usage: The following code demonstrates how a picture can be surrounded by the description, as often shown in printed publications:

```plaintext
{composition-setup}
(float:left)
!shakespeare.jpg!
(float)
William Shakespeare (baptised 26 April 1564; died 23 April 1616) was an English poet and playwright, widely regarded as the greatest writer in the English language and the world's pre-eminent dramatist. ...
```

The page will look like this:
Floating Text demo

William Shakespeare (baptised 26 April 1564, died 23 April 1616) was an English poet and playwright, widely regarded as the greatest writer in the English language and the world's pre-eminent dramatist. He is often called England's national poet and the "Bard of Avon". His surviving works, including some collaborations, consist of about 39 plays, 154 sonnets, two long narrative poems, and several other poems. His plays have been translated into every major living language and are performed more often than those of any other playwright.

Shakespeare was born and raised in Stratford-upon-Avon. At the age of 18, he married Anne Hathaway, with whom he had three children: Susanna, and twins Hamnet and Judith. Between 1588 and 1592, he began a successful career in London as an actor, writer, and part owner of a playing company called the Lord Chamberlain's Men, later known as the King's Men. He appears to have retired to Stratford around 1613, where he died three years later. Few records of Shakespeare's private life survive, and there has been considerable speculation about such matters as his physical appearance, sexuality, religious beliefs, and whether the works attributed to him were written by others.

Shakespeare produced most of his known work between 1598 and 1613. His early plays were mainly comedies and histories, genres he raised to the peak of sophistication and artistry by the end of the 16th century. He then wrote mainly tragedies until about 1608, including Hamlet, King Lear, and Macbeth, considered some of the finest works in the English language. In his last phase, he wrote tragicomedies, also known as romances, and collaborated with other playwrights.

For more macros, see the Composition add-on page.

**Scaffolding add-on**

The Scaffolding add-on provides macros for creating 'permanent templates' and editable forms. You can create sophisticated page templates in order to add content easily and fast. Scaffolding templates are suitable for dynamically-filled data and allow people to create pages by completing form fields and selecting values from drop-down lists.

The Scaffolding templates are useful for creating pages with a well-determined structure, such as:

- API methods or property descriptions.
- Constant list.
- Feature description.
- Software requirement specifications.

**Commercial or free**: Commercial.

**Example**: The following Scaffolding template creates a description of an API method:
h3. Method Name
{text-data:methodName|required=true}{text-data}

h3. Method Description
{text-data:methodDescription|type=area|required=true|width=100%}description{text-data}

h3. Parameters
{table-data:parameters}
|| Name || Type || Mandatory || Description ||
| {text-data:paramName}ParamName{text-data} |
{list-data:paramType}{list-option:Number}Number{list-option}{list-option:String}String{list-option}{list-option:DateTime}DateTime{list-option}{list-option:MACaddress}MACaddress{list-option}{list-option:IPaddress}IPaddress{list-option}{list-data} |
{list-data:paramMandatory}{list-option:Required}Required{list-option}{list-option:Optional}Optional{list-option}{list-data} |
{text-data:paramDescription|type=area}param description{text-data} |
{table-data}

h3. Return Value
The returned value is an XML structure of the following format:
\{code:xml\}
\{code\}

Where elements mean:
{table-data:returnValues}
|| Name || Type || Description ||
| {text-data:paramName}ParamName{text-data} |
{list-data:paramType}{list-option:Number}Number{list-option}{list-option:String}String{list-option}{list-option:DateTime}DateTime{list-option}{list-option:MACaddress}MACaddress{list-option}{list-option:IPaddress}IPaddress{list-option}{list-data} |
{text-data:paramDescription}param description{text-data} |
{table-data}

h3. Remarks
{text-data:remarks}remarks{text-data}

h3. See Also

This template will look like this:
For more information on how to create templates in Confluence, see Adding a Template.

**Alternatives:** Confluence includes built-in templates which as useful for static data and simple text. For more information, see Working with Templates.

**Notes:** The Scaffolding (and any) template changes will affect only new pages created from the modified template. In order to change the existing pages, you need to edit each individual page and add or modify the formatting manually.

For more information on Scaffolding, see the Scaffolding add-on page.

Extended version control

**Scroll Versions**

Scroll Versions adds functionality for sophisticated version management, enhanced content reuse, support for context-sensitive help, permalinks, and duplicate page titles. You can set up and manage concurrent versions of your documentation in a single space. Multiple versions of software, different product variants, and even multiple translations of documentation can be managed. Changes to pages are scheduled for a specified version and then published all at once. See the Scroll Versions documentation for an overview of the key features.

**Commercial or free:** Commercial.

Video: Scroll Versions - Version Management for Confluence (4.20)
**Attachment Checkout add-on**

The **Arsenale Lockpoint: Attachments Checkout** adds check-out/check-in functionality for Confluence attachments.

**Commercial or free:** Free for up to 50 users, then commercial.

**More information:**
- Please visit the [Attachments Checkout add-on page](https://confluence.atlassian.com/) for an overview, including a video.
- See the [Attachments Checkout documentation](https://confluence.atlassian.com/) for further reference.
- For information on working with attachments in Confluence, see [Working with Attachments](https://confluence.atlassian.com/).
- For information on attachment versioning, see [Attachment Versions](https://confluence.atlassian.com/).

**Add-ons featured in other parts of this guide**

- **Copy Space add-on** – Provides an easy way of copying a space within a Confluence site. Free. See [Creating your Technical Documentation Space](https://confluence.atlassian.com/).
- **Multi Excerpt add-on** – Enables you to have more than one excerpt (re-usable chunk) on a page. Commercial. See [Re-using Content in Technical Documentation](https://confluence.atlassian.com/).
- **Ad Hoc Workflows add-on** – Provides advanced workflow features. Commercial. See [Managing the Life Cycle of your Technical Documentation](https://confluence.atlassian.com/).
- **Content Publishing add-on** – Publishes content from a master space to a published space. Commercial no charge. See [Managing the Life Cycle of your Technical Documentation](https://confluence.atlassian.com/).
- **Scroll Office** – Provides advanced features for export to Microsoft Word. Commercial. See [Exporting and Printing Technical Documentation](https://confluence.atlassian.com/).
- **Scroll PDF Exporter** – Provides advanced PDF export features. Commercial. See [Providing PDF Versions of your Technical Documentation](https://confluence.atlassian.com/) and [Exporting and Printing Technical Documentation](https://confluence.atlassian.com/).
- **Scroll EPUB Exporter** – Outputs an ebook in the common EPUB format that can be read on iPads, iPhones and any other ebook reader. Commercial.
- **Scroll HTML Exporter** – Enables the delivery of Confluence content from a web server. It converts the pages into static HTML pages that can be uploaded to a web server. The output of the Scroll HTML exporter can also be used as an input to produce other HTML-based help formats such as WinHelp and HTML Help. Commercial.
- **Scroll EclipseHelp Exporter** – Enables you to collaborate and author all your content in your wiki, and generate embeddable online help for Eclipse-based applications. Commercial.

**Notes**

- **Add-on support.** Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.
- **Installing add-ons.** If you decide to use additional add-ons, your site administrator will need to install the add-ons into your Confluence site. Refer to the documentation on installing add-ons.

**Further reading**

- A blog post about useful add-ons and tools for exporting and importing content from/to Confluence: [Technical Writing in a Wiki - Single Source Publishing](https://confluence.atlassian.com/) (November 2010).
- Website for exploring and downloading the available add-ons: [Atlassian Marketplace](https://confluence.atlassian.com/).
- Documentation on installing and configuring add-ons: [Universal Plugin Manager Documentation](https://confluence.atlassian.com/).
- Documentation on using macros: [Working with Macros](https://confluence.atlassian.com/).
- **Further Reading about Developing Technical Documentation on Confluence**

**Further Reading about Developing Technical Documentation on Confluence**

This page is part of the guide to developing technical documentation on Confluence. Once you have absorbed all the information in this guide, you may be ready for more reading. 😊

- The Confluence documentation: [Confluence Latest](https://confluence.atlassian.com/).
- Blog post about using Confluence for online help: [Using a wiki for online help](https://confluence.atlassian.com/).
- Blog posts about version management in Confluence with Scroll Versions plugin:  
  - [Announcing Scroll Versions](https://confluence.atlassian.com/).
  - Version management gets serious with Confluence Scroll Versions plugin.
Now you have your documentation space up and running, it’s fun and rewarding to use the full power of the wiki to engage your readers and embed content from other social sites. Here is a blog post and presentation slides on engaging readers in the documentation.


Webinar recording: Confluence as a Platform for Technical Documentation.

Let us know about more links
We plan to add more links to this page or to the ‘Tips of the Trade’ page. Let us know of any we have missed.

Developing a Knowledge Base on Confluence Wiki

Welcome! This is a guide to using Confluence as a knowledge base. You will find this guide useful if you want to produce a knowledge base with a survey, content curation, intelligent search and standardized templates.

Confluence now ships with a space blueprint for creating Knowledge Base spaces. Go to Create Space > Knowledge Base to try it out for yourself.

The Knowledge Base space integrates with JIRA Service Desk too - see Connecting to a Knowledge Base.

In these pages, we’ll show you how to use Confluence to achieve a high-functioning knowledge base, including these features:

- Using templates
- Subscriptions (RSS or email)
- Organising content (hierarchically or by label)
- Populating data via templates
- A ‘was this helpful?’ survey
- Intelligent searching algorithms (higher ranked articles are promoted in search results)
- Targeted searching across specified Confluence spaces and content types
- How to show related content via labels
- Extensive metrics and reporting
- Re-using content for easier maintenance and consistency

In addition, you may find the following topics useful, in the guide to technical documentation in Confluence: Exporting articles to PDF, HTML and other formats

Related pages:
- Confluence User’s Guide
- Confluence Administrator's Guide

Creating Your Knowledge Base Space

This guide is for people who want to develop and publish a knowledge base using Confluence. You’ll find Confluence useful because it combines professional web publishing features with the ease-of-use and flexibility of a wiki - requiring a low barrier to entry, but high quality output for all your team members. Confluence provides all of the collaborative features for your reports (such as automatic versioning, granular enterprise security, email and RSS subscriptions, and JIRA integration). This page is a quick-start guide to creating a wiki space for a knowledge base.

Step 1. Add a space and select the Documentation theme

Below is a quick guide to adding a space. See Setting up a New Global Space for a full description.

1. Go to the Confluence dashboard and choose Create Space > Blank Space.

   Hint: If you cannot see Create Space, this means that you do not have permission to add spaces. Please...
contact your Confluence administrator.
2. Choose Next then enter a space name and a short, unique space key.
3. Leave the permission settings as default, or choose to allow only yourself to view or contribute content to this space. You can change these settings later and with more flexible options.
4. Choose Create.
6. Choose Look and Feel > Themes and select the Documentation theme.
7. Choose OK.

The home page of your new space will appear, and your space will be using the Documentation theme. Because you created the space, you are the space administrator. Now you can do some basic configuration, as described in the sections below. From this point on, instructions will refer to navigating in the Documentation theme, which is slightly different to the default theme.

On this page:
- Step 1. Add a space and select the Documentation theme
- Step 2. Set the space permissions
- Step 3. Customise the title and content of the home page
- Step 4. Customise the Documentation theme
- Step 5. Create an inclusions library to manage reusable content
- Step 6. Create the table of contents
- Step 7. Give people an RSS feed they can subscribe to
- Step 8. Set up Atlassian's Content Survey and Reporting add-on
- Step 9. Insert Google Analytics code into Confluence's custom HTML
- Note about add-on support

Step 2. Set the space permissions

Define the space permissions to determine who can do what in your new space:

1. Choose Browse > Space Admin at the top of the screen.
   
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Permissions.
3. Choose Edit Permissions.
4. Set the permissions to suit your needs then choose Save All.
   - You can add groups and/or individual users to the list, then select the permissions for each group or user.
   - You can also set the permissions for anonymous users – these are people who have not logged in to the wiki. Anonymous access is available only if enabled for the entire Confluence site. We recommend this setting if you are using this space for Technical Documentation or for a Knowledge Base.
   - Note that you can change these permissions at any time. You may want to restrict the permissions to specific groups now, and later open the space to more people.

More about permissions

Confluence has a robust and granular permissions scheme that you can use to determine who can view, comment on and even update the documentation. There are three levels of permissions in Confluence:

- Global permissions apply across the entire site.
- Space permissions apply to a space.
- Page restrictions allow you to restrict the editing and/or viewing of a specific page. Below we discuss a way of using these in the draft, review and publishing workflow.

Space permissions in Confluence are simple yet granular enough to be useful for technical documentation. You can:

- Use the permission levels to control who can create pages in the space, delete pages, create comments,
delete comments, administer the space, and so on.
  
- Grant a permission level to one or more users, and/or to one or more groups, and/or to anonymous users.

Terminology:

- 'Anonymous' means people who have not logged in to the wiki. These are users that won’t affect your the number permitted by your license.
- The 'confluence-users' or 'users' group is the default group into which all new users are assigned. Everyone who can log in to Confluence is a member of this group.

For example, you might allow 'Anonymous' users specific view and content creation rights so that they can access and engage with your knowledge base while your team lead (Rach) maintains full Space Administration rights.

Screenshot: Allowing anonymous users to add specific content

For detailed information, see the documentation on:

- Global permissions
- Space permissions
- Page restrictions
- Users and groups

Step 3. Customise the title and content of the home page

When you created your space, Confluence created a home page with default content and a default title. You will want to change the title and content.

1. Go back to your space home page, by choosing the space name in the breadcrumbs at the top of the screen.
2. The space home page appears. By default, the page title is 'X Home', where 'X' is the name you gave your space.
3. Choose Edit.
4. Change the title to suit your needs.
5. Update the content to suit your needs. 
   Hint: If you do not know what to add yet, just add a short description. You can refine the content of the page later. Take a look at an example of a homepage.
6. Choose Save.

Step 4. Customise the Documentation theme

When you added this space you chose the Documentation theme, which provides a left-hand navigation bar and a good look and feel for a knowledge base. If necessary, you can configure the Documentation theme to add your own page header and footer, or to customise the default left-hand navigation bar. These customisations
affect the online look and feel of your knowledge base. See Configuring the Documentation Theme for the full description.

1. Choose Browse > Space Admin (if you have not yet selected the documentation theme choose Space Tools > Look and Feel).
2. Choose Themes.
3. If the space is not yet using the Documentation theme, apply the theme now.
4. Choose Configure theme.

5. The 'Documentation Theme Configuration' screen appears. Customise the left-hand navigation bar, header and footer to suit your needs. Details are in the documentation. Here are some hints:
   • The Page Tree check box determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.
   • The Limit search results to the current space check box determines whether Confluence will search only the current space or the whole Confluence site. This setting affects the default search. Viewers can override it each time they do a search.
   • Enter text, images, macros and other wiki markup into any or all of the three text boxes for the the left-hand navigation bar, header and footer. You can use the Include macro and the Excerpt to include re-usable content.
   • Any content you add to the navigation panel will appear above the default page tree.
   • If you like, you can remove the default page tree (by unticking the box) and add your own, customised version of the Pagetree macro instead.

6. Choose Save.

Example of a customised footer

Take a look at the footer of a page in the Crowd documentation space.

To produce the above footer, we have the following content in the footer panel in the Documentation theme configuration screen:

Footer

```{include: Documentation Footer|nopanel=true}
{include: ALLDOC__Copyright Notice|nopanel=true}
```

Here it is in text form:
The above content consists of two **Include macros**.

- The first macro includes a page called _Documentation Footer_. This page contains the big blue buttons and hyperlinked text.
- The second macro includes a page from a different space, the ALLDOC space, called _Copyright Notice_. This page includes our standard copyright notice, used in all our documentation spaces.
- In each include macro, the content has been drawn from an inclusions library, a hidden content repository, from which you can store frequently and re-usable content throughout your knowledge base space.

**Step 5. Create an inclusions library to manage reusable content**

Using Confluence, you can dynamically include content from one page into another page. You can include a whole page into another one, using the **Include macro**. You can also define an 'excerpt' on a page, and then include that excerpted text into another page using the **Excerpt Include macro**.

To organise your re-usable content, we recommend that you create a set of pages called an 'inclusions library':

1. Choose **Create** and create a new page in your space.
2. Enter a suitable title. We use '_InclusionsLibrary'. The unusual format of the title helps to let people know this page is special.
3. Enter some content and **save** the page. We enter text explaining the purpose of the inclusions library and how to re-use the content. You can copy our text by clicking through to one of the example pages listed below.
4. Choose **Browse > Pages** and drag your new page above the space homepage.
5. Go to your new inclusions page and choose **Create** to add child pages containing your re-usable content. See the examples of our own inclusions libraries listed in the examples below.

Some notes about inclusions libraries:

- The inclusions library is not a specific feature of Confluence. The pages in the inclusions library are just like any other Confluence page.
- The pages are located at the root of the wiki space, not under the homepage. This means that they will not appear in the table of contents on the left and they will not be picked up by the search in the left-hand navigation bar either.
- The pages will be picked up by other global searches, because they are just normal wiki pages.
- We have decided to start the page name with an underscore. For example, '_InclusionLibrary'. This indicates that the page is slightly unusual, and will help prevent people from changing the page name or updating the content without realising that the content is re-used in various pages.

**Examples of inclusions libraries**

Here are some examples in our documentation:

- Crowd inclusions library
- Confluence inclusions library

**Step 6. Create the table of contents**
Create the table of contents for your knowledge base, by adding the top-level pages for all the usual sections. For example, our technical support team designed the following pages in the Confluence Knowledge Base on our public wiki:

- Browse Articles by Label
- Browse Articles by Top Ranked Content
- Browse Articles by Page Tree Hierarchy
- Browse Articles by Version
- Subscribe to Proactive Announcements

To start your table of contents:

1. Go back to your space home page, by clicking the space name in the breadcrumbs at the top of the screen.
2. Choose Create to add the page as a child of the home page.
3. Enter the page title. For example: 'Browse Articles by Label'.
4. Enter the content of the page.
   - Hint: If you do not know what to add yet, just add a short description then refine the content of the page later. If you like, you can follow an outline similar to the Confluence Knowledge Base and add the Label List macro. This displays a hyperlinked alphabetical index of all labels within the current space. As you create content in this space and apply appropriate labels, the macro will update this page automatically.

**Browse Content by Label**

Click on one of the labels below to find related content:

Below are the 181 labels used in Confluence Knowledge Base listed alphabetically. Click on a label to see its associated content.

A-B  apache, applinks, appserver, attachments, backup, bamboo, build

C  cache, calendar, camel_case, captche, case_sensitivity,

D  dashboard, database, db2, deadlock, directory, doc_import, documentation_theme, dynamic_tasklist

5. Choose Save.

Now do the same for all the sections of your knowledge base that you wish to appear in the left-hand navigation bar of the Documentation theme. Below is what the table of contents looks like for our Confluence Knowledge Base:

**Search the Knowledge Base and Documentation Spaces**

**Browse Content**

- Browse Articles by Label
- Browse Articles by Top Ranked Content
- Browse Articles by Page Tree Hierarchy
- Browse Articles by Version
- Subscribe to Proactive Announcements

Step 7. Give people an RSS feed they can subscribe to

Let's populate the knowledge base home page with content by creating an RSS feed that your co-workers and
customers can subscribe to, so they can receive important updates from your knowledge base and technical alerts on your products.

This is a strategy that Atlassian’s technical support team uses to create a proactive knowledge base that provides technical alerts to customers and coworkers and helps solve support issues before they’re even created.

By following the quick guide below, you’ll create a homepage similar to the one Atlassian’s technical support team has created for the Confluence Knowledge Base on our public wiki:

Creating your RSS feed:

Confluence can filter spaces by content type. To filter your knowledge base for ‘blog post’ content, do the following:

1. Go to a page in the space and choose Blog in the sidebar.
   Or, if you are using the Documentation theme, choose Browse > Blog at the top of the screen.
2. Copy this URL to your clipboard.
3. Create an RSS feed for the URL of your knowledge base space.
   Now your RSS feed will consist of any blog posts created in the knowledge base space.

Highlighting your technical announcement RSS feed

1. Go to your space home page.
2. Choose Edit.
3. Insert an 'h2' heading, such as 'Important Technical Announcements'.
4. Insert bold text that reads something like, 'Copy the RSS feed into your favourite RSS reader:'.
5. Choose Insert > Other Macros to open the Macro Browser.
6. Select the 'Panel' macro in the Macro Browser and specify your desired macro preferences. We recommend that you change the Panel Title, Border Style, and Background Color to further highlight the panel on the page.
7. Choose Insert.

Inserting a Blog Posts macro

1. Inside the Panel macro placeholder choose Insert > Other Macros to open the Macro Browser again.
2. Select the Blog Posts macro in the Macro Browser and specify the following preferences:
Inserting your RSS feed into your 'Technical Announcements' panel

First, let's create a link so that your coworkers and customers can view all of the blog posts in your knowledge base space. See Working with Links for a full description in our product documentation.

1. Place your cursor after/below the Blog Posts macro in the Panel macro placeholder.
2. Type: 'View more recent blog posts'.
3. Highlight this text and click Link on the editor toolbar.

4. Select 'Web Link' and paste the link you copied to create your RSS Feed.
5. Choose Insert.

Now, let's insert your RSS Feed into your panel by linking an image. See Linking an Image for a full description in our product documentation.

1. Attach an RSS Icon to the page by dragging and dropping it into the editor (preferably below the link you just created). See Drag-and-Drop for a full description in our product documentation.
2. Choose the RSS Icon image and choose the 'Align right' button on the editor toolbar.
3. Choose Border in the image properties panel.
4. Link the RSS Icon by selecting the image and then choosing Link on the editor toolbar.
5. Choose the 'Web Link' tab and insert the RSS Feed URL you created.
6. Choose Insert to link your RSS Feed to the RSS Icon image.
7. Choose Save to save your page and test your RSS Icon.

Congratulations! You have successfully created a proactive knowledge base.

Step 8. Set up Atlassian’s Content Survey and Reporting add-on

⚠️ The information in this step does not apply to Confluence OnDemand.

Now that you can monitor the traffic and activity of your knowledge base, let’s measure its effectiveness. When the Content Survey and Reporting add-on is activated for a space, it will generate a report that includes:

- Direct feedback from customers about article quality
Confluence 5.4 Documentation

- Amalgamated 'composite score' results
- Answers to secondary questions, such as 'Was the information complete?' or 'Was the article well-written?'
- A rollup at-a-glance view of the metrics for the whole space.

Lastly, the Content Survey and Reporting add-on will institute 'intelligent searching' which means that, based on the results of the surveys, higher ranked pages are promoted in search results, so your best and most popular pages are found easiest. This is a quick guide for how to set up the Content Survey and Reporting add-on.

This add-on only functions properly if the Documentation theme is applied to the space. Let's install the Content Survey and Reporting add-on using Confluence's Universal Plugin Manager:

1. Log into Confluence as a System Administrator or Confluence Administrator.
2. Choose the cog icon at top right of the screen, then choose Confluence Admin.
3. Choose Manage Add-ons.
4. Search for the 'Content Survey and Reporting add-on'.
5. Choose Install.

You can also go to the Atlassian Marketplace and download the add-on and install it directly.

Now that you've installed the Content Survey and Reporting add-on, let's configure a survey:

1. Go to your space.
2. Choose Browse > Space Admin at the top of the screen.
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
3. Click Configure Survey under 'Knowledge Base Survey'. Here you can:
   - Add a question
   - Edit a question's text
   - Activate or deactivate a question
   - Edit the response text
4. Configure a 'Primary Question' for the survey

   ![Primary Question Form](image)

5. Choose Save.

Now that you've added a primary question, let's test out the add-on by adding it to the footer of the Documentation theme so that every page within your knowledge base space includes your survey:

1. Choose Browse > Space Admin at the top of the screen.
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Themes.
3. Choose Configure theme.
4. Go to the 'Footer' section of the 'Documentation Theme Configuration' page and insert this recommended markup to achieve a nice layout of the Content Survey and Reporting add-on:
5. Choose **Save** and go to your space homepage to view your Content Survey and Reporting add-on in the footer of the page.

With the Content Survey and Reporting add-on you can dramatically improve the quality of your knowledge base and the efficiency with which your team creates and maintains it. Here is an example of how our technical support team uses the Content Survey and Reporting add-on in the Confluence Knowledge Base:

**Results displayed by the Content Survey and Reporting add-on**

Survey results are viewable by space administrators only. The add-on develops three results:

- **Pages with results** - Determine page-by-page, which are your most effective knowledge base articles and which ones need improvement.

<table>
<thead>
<tr>
<th>View</th>
<th>Pages with Results</th>
<th>Pages without Results</th>
<th>Rollup Report</th>
</tr>
</thead>
<tbody>
<tr>
<td>LDAP Error Code 49</td>
<td>284</td>
<td>0</td>
<td>586</td>
</tr>
<tr>
<td>Confluence Does Not Start with 'MySql session isolation level 'REPEATABLE-READ' is no longer supported′ Message</td>
<td>69</td>
<td>167</td>
<td>66% (59/89)</td>
</tr>
<tr>
<td>Unable to Connect to SSL Services due to PXO Path Building Failed</td>
<td>86</td>
<td>110</td>
<td>57% (49/85)</td>
</tr>
<tr>
<td>sun.security.provider.certpath.SunCertPathBuilderException</td>
<td>3</td>
<td>102</td>
<td>67% (2/3)</td>
</tr>
<tr>
<td>How to Edit the Footer in Confluence</td>
<td>44</td>
<td>100</td>
<td>62% (36/59)</td>
</tr>
<tr>
<td>Exceeds Max Allowed Packet for MySQL</td>
<td>63</td>
<td>77</td>
<td>56% (35/63)</td>
</tr>
<tr>
<td>MySQL Table is Marked as Crashed and Should be Repaired</td>
<td>32</td>
<td>72</td>
<td>61% (20/32)</td>
</tr>
<tr>
<td>Problems Installing Confluence as a Service on Windows 6/8</td>
<td>63</td>
<td>77</td>
<td>56% (35/63)</td>
</tr>
</tbody>
</table>

As you can see, the add-on develops a *Composite Score* which ranks articles in search, so your highest scoring (best) content can be found most easily. The score is based on the last 32 votes cast, using the global search configuration. See [Confluence Content Survey and Reporting Add-on](https://confluence.atlassian.com/display/C24/C24) for a full description on how Global Search boosting works.

- **Pages without Results** - These are the pages in your knowledge base without survey results.
- **Rollup Report** - This is the summary of all survey results. The report can be used to determine how effective your overall knowledge base content is.
**Searching multiple spaces from your knowledge base**

As mentioned, the Content Survey and Reporting add-on generates a composite score that ranks pages and articles within your knowledge base to make the highest (most well regarded) pages more retrievable by visitors. The add-on also improves Confluence search by allowing users to search multiple spaces without ever leaving your knowledge base space. This is really helpful for users that are unfamiliar with Confluence because they can keep the knowledge base as a point of reference within the greater instance of Confluence.

At Atlassian, our product knowledge bases and product documentation exist in the same Confluence instance so that we can make both available to 'Anonymous' users. Our Technical Support team uses the Content Survey and Reporting add-on to allow visiting users to search for Confluence resources in the product documentation space from the Confluence Knowledge Base space. This provides the visitor twice the chances of finding an answer to their question.

In the image below, you can see the space specific search used in the left-navigation bar to find content related to Confluence in both the 'Documentation' and 'Knowledge Base' spaces. Pages in the 'Documentation' space are listed first and pages in the 'Knowledge Base' space are listed second.

---

**Step 9. Insert Google Analytics code into Confluence’s custom HTML**

⚠️ The information in this step does not apply to Confluence OnDemand.

Now that you have a strong foundation for a knowledge base, it’s critical to assess how effectively it services your customers. Google Analytics is a tool that gives you rich insights into your website traffic and marketing effectiveness. You are going to want to understand how your customers are accessing the resources in your knowledge base. This is a quick guide to inserting Google Analytics HTML code into Confluence so you can measure your knowledge base traffic.

1. If you don't have one already, create a Google Account and then create a Google Analytics Account using
1. Your Confluence instance's URL.
2. Copy the Google Analytics code to your clipboard.
3. Log into Confluence as a System Administrator or Confluence Administrator.
4. Choose the cog icon at top right of the screen, then choose Confluence Admin.
5. Choose Custom HTML under 'Look and Feel'.
6. Choose Edit to insert custom HTML into your Confluence instance.

7. Paste your Analytics code you have saved to your clipboard into the table labeled At end of the BODY.
8. Choose Save.

You can now monitor the activity and traffic for every page you create in your Confluence instance and Knowledge Base.

Hint: If your knowledge base only represents a space within your greater Confluence instance, you can search Google Analytics for activity in the specific space by exclusively filtering for the space key.

i Read David Simpson's blog post about Tracking Confluence Usage with Google Analytics for more information.

Note about add-on support

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Next Steps

See Using Templates and Formatting Macros in a Knowledge Base for next steps.

Using Templates and Formatting Macros in a Knowledge Base

This page is part of the guide to developing a knowledge base on Confluence Wiki. We have already shown you how to create your knowledge base space. Now we offer an introduction to the templates that Confluence provides, and show you some useful macros for formatting your content.
Quick guide to templates

A template is a page with predefined content that can be used as a prototype when creating other pages. Templates are available across the Confluence site (global templates) or per space (space templates).

Both 'global templates' and 'space templates', as described on this page, define the content of a page. They do not define the content of an entire space. To create a template for an entire space, see our guide to creating your documentation space.

You can import predefined page templates from the Atlassian Marketplace.

Space information design

One question that comes up is whether a knowledge base should be implemented as a decision matrix, with a multi-select or other list. We knew that most of our users visit our documentation directly from search engines. Early on, we learned from Google Analytics that most traffic was coming from search engines, not from within our site. So, we knew to focus on optimising page titles and tags rather than focus on a decision matrix.

Page templates

Confluence's page templates are a good place to start. Begin by choosing how you want your templates to look. Here's the wiki markup for our page template:

```wiki
h3. Symptoms
FILL IN SYMPTOMS HERE

h3. Cause
FILL IN CAUSE HERE

h3. Resolution
FILL IN RESOLUTION HERE

(htmlcomment)
ENTER SUPPORT TICKET LINKS
(htmlcomment)
```

Useful add-ons:

- The `htmlcomment` macro is part of Adaptavist's Content Formatting Macros, a handy add-on.
- Consider the Scaffolding add-on or Form Field Markup for filling out forms. Our support engineers are quite used to using wiki markup (we live and breathe Confluence!), so we left this template as is.

Content macros

Some favourite macros for formatting content are the Tip, Info, Warning, and Note Macros, and the Code macro. Try the Noformat Macro for ensuring plain text.

We also use Adaptavist's Content Formatting Macros when we really want to make our content look great.

JIRA Issues macro

Using JIRA for bug tracking? You can't expect your users to have exactly the right JQL filters to show the appropriate topics. We have some nice JIRA Issues macros on display. One of my favourites is in the JIRA KB's Causes for OutOfMemory Errors:
The JQL includes components and sorting, plus the specific columns.

**Labels and macros**

Sometimes an article needs to be cross listed. For that we label our articles. Some great macros to use for this are `{contentbylabel}`, `{listlabels}` and the `{dynamiccontentbylabels}` macro in the [Content Survey add-on](https://developer.atlassian.com/jiradoctor/pages/article/confluence-templates-augmented#labels-and-macros).

### Next Steps

You now have a good idea of how Confluence templates work, and have seen some useful formatting macros. What next? Take a look at [Proactive Communications in a Knowledge Base](https://confluence Atlassian.com/pages/viewpage.action?pageId=102482364).

**Proactive Communications in a Knowledge Base**

This page is part of the guide to [developing a knowledge base on Confluence Wiki](https://confluence Atlassian.com/pages/viewpage.action?pageId=102482364). We have already shown you how to [create your knowledge base space](https://confluence Atlassian.com/pages/viewpage.action?pageId=102482364) and how to [use templates and formatting macros](https://confluence Atlassian.com/pages/viewpage.action?pageId=102482364). We touched on [creating proactive communications](https://confluence Atlassian.com/pages/viewpage.action?pageId=102482364). Now let's discuss it further.

**Quick guide to proactive communications:**

- Confluence can both produce and consume RSS feeds.
- Both the RSS macro and the Blog Posts macro offer a good way to show summaries.

### Proactive alerts

Sending technical alerts to customers is a great way to keep customers and staff informed, and good way to reduce support load. At Atlassian we use the knowledge base both to consume and to produce proactive content that customers can opt into. This page describes how to achieve that.

#### Using Confluence as a producer

- **Working with Blog Posts** describes how to produce blog posts in Confluence.
- **Emailing a Page** is a great way to send email messages to users or an email distribution list.

#### Using Confluence as a consumer

Even if your Confluence site is not producing your proactive content, it can consume and display the content in a prominent way:

- The **RSS Feed Macro** can consume content from any RSS feed on the Internet.
- We use the **Blog Posts Macro** to display blog posts written in Confluence. The macro output looks especially handsome in a panel, accentuated by an RSS image in a link. Here’s the wiki markup:
Next steps

You now have a good idea of how to do proactive communications. Next up, consider Additional Add-ons for a Knowledge Base.

**Additional Add-ons for a Knowledge Base**

This page is part of the guide to developing a knowledge base on Confluence Wiki. This page lists additional add-ons that might expand your usage.

**Useful add-ons for a knowledge base**

These are some great add-ons for Confluence as a knowledge base:

- The [Content Survey and Reporting add-on](http://confluence.atlassian.com/contentsurveyandreporting) gives a good report on popular and unpopular content.
- The [Confluence Archiving add-on](http://confluence.atlassian.com/confluencearchiving) flags old content.
- The [Ad hoc Workflows add-on](http://confluence.atlassian.com/adhocworkflows) and [Content Publishing add-on](http://confluence.atlassian.com/contentpublishing) manage workflows and review process.

**Note about add-on support**

*Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.*

Bye

Hope you enjoyed the tutorial! Have a chocolate, and please share with us your experiences. You can comment directly on this page.

**Developing an Intranet on Confluence Wiki**

Confluence now ships with a space blueprint for creating Team spaces, which is useful if you use Confluence as an intranet.

Go to Create Space > Team Space to try it out for yourself.

This guide is for people who are using Confluence as a platform for an intranet. You will find this guide useful if you want to create a space where your team can collaborate and share information.

**Step 1. Create a space**

Below is a quick guide to adding a space for your team.

1. Go to the Confluence dashboard and choose Create Space > Blank Space.
2. The Create Space screen appears. Enter a space name and a short, unique space key.
3. Choose Create.

The home page of your new space will appear. Because you created the space, you are the space administrator.
administrator. Now you can do some basic configuration, as described in the sections below.

---

**On this page:**
- Step 1. Create a space
- Step 2. Set the space permissions
- Step 3. Customise the title and content of the home page
- Step 4. Subscribe to email notifications for updates made to the space
- Step 5. Attach or import Office documents, if applicable
- Step 6. Import page templates and blueprints
- Step 8. Publish a blog post

**Related pages:**
- Creating a Space
- Global Permissions Overview
- Assigning Space Permissions
- Page Restrictions
- Users and Groups

---

**Step 2. Set the space permissions**

Define the space permissions to determine who can do what in your new space.

1. Go to the space and choose **Space tools > Permissions** on the sidebar.
2. Choose **Edit Permissions**.
3. Set the permissions to suit your needs then choose **Save All**.
   - You can add **groups** and/or individual **users** to the list, then select the permissions for each group or user.
   - You can also set the permissions for **anonymous** users – these are people who have not logged in to Confluence and will not count towards the number allocated by your license. Anonymous access is only available if enabled for your entire Confluence site. It is unlikely you will need anonymous users for your intranet.
   - You can change these permissions at any time. You may want to restrict the permissions to specific groups now, and later open the space to more people.

**More about permissions**

Confluence has a robust and granular permissions scheme that you can use to determine who can view, create content and comment within your intranet. There are three levels of permissions in Confluence:

- Global permissions apply across the entire site.
- Space permissions apply to a space.
- Page restrictions allow you to restrict the editing and/or viewing of a specific page.

**Space permissions** in Confluence are simple yet granular enough to be useful for an intranet. You can:

- Use the permission levels to control who can create pages, delete pages, create comments, delete comments, administer the space, and so on.
- Grant a permission level to one or more users, and/or to one or more groups, and/or to anonymous users. A space administrator has complete control.

**Terminology:**

- 'Anonymous' means people who have not logged in to Confluence
- The 'confluence-users' ('users' in OnDemand) group is the default group into which all new users are assigned. Everyone who can log in to Confluence is a member of this group.

For example, you might allow the 'confluence-users' group permission to create and edit comments, but reserve full editing rights for your team members. Let's assume your team members are all members of the 'developers' group. The example below shows that members of the 'developers' group have all permissions except space administration, but, members of the 'confluence-users' group and the individual 'Josh User' only have a
few editing rights.

### Groups

These are the permissions currently assigned to groups for this space.

<table>
<thead>
<tr>
<th></th>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Comments</th>
<th>Attachments</th>
<th>Mail</th>
<th>Space</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>View</td>
<td>Add</td>
<td>Restrict</td>
<td>Remove</td>
<td>Add</td>
<td>Remove</td>
<td>Add</td>
</tr>
<tr>
<td>confluence-users</td>
<td>✓</td>
<td>✓</td>
<td>×</td>
<td>×</td>
<td>✓</td>
<td>×</td>
<td>✓</td>
</tr>
<tr>
<td>developers</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td>✓</td>
<td></td>
<td>✓</td>
</tr>
</tbody>
</table>

**Edit Permissions**

### Individual Users

These are the permissions currently assigned to individual users for this space.

<table>
<thead>
<tr>
<th></th>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Comments</th>
<th>Attachments</th>
<th>Mail</th>
<th>Space</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>View</td>
<td>Add</td>
<td>Restrict</td>
<td>Remove</td>
<td>Add</td>
<td>Remove</td>
<td>Add</td>
</tr>
<tr>
<td>Rach Admin (admin)</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Josh User (josh)</td>
<td>✓</td>
<td>✓</td>
<td>×</td>
<td>×</td>
<td>✓</td>
<td>×</td>
<td>✓</td>
</tr>
</tbody>
</table>

**Edit Permissions**

For detailed information, see the documentation on:

- Global permissions
- Space permissions
- Page restrictions
- Users and groups

### Step 3. Customise the title and content of the home page

When you created your space, Confluence created a home page with default content and a default title. You will want to change the title and content to suit your team.

1. Go to your space home page
2. By default, the page title is 'X Home' (where 'X' is the name you gave your space).
3. Choose **Edit**.
4. The page opens in the editor.
5. Change the title and update the content to suit your needs.
   **Hint:** If you do not know what to add yet, add a short description. You can refine the content of the page at any time.
6. Choose **Save** to save your home page.

### Step 4. Subscribe to email notifications for updates made to the space

You can configure your email notifications to suit your needs: You can choose to be notified about all pages in a space, blog posts in a space, or both. Below is a quick guide to monitoring a space's content. See Watching Pages, Spaces and Blog Posts for a full description.

1. Go to your space homepage.
2. Choose **Pages** in the sidebar.
3. Choose **Watch this space**.
4. Choose **Blog** in the sidebar.
5. Choose **Watch this blog**.

If at any time you wish to stop watching activity in the space, choose **Stop watching this space** or **stop watching this blog**.

Example of an email notification
Here is an example of the email notification you will receive when someone adds a comment to a page or blog post:

![Email notification example](image)

More about notifications

You can specify the notifications you want to receive at a global, space, and page level. The quick guide above demonstrated how to set up notifications for a space. Now we will show you how to configure your notifications at the global and page levels.

**Global notifications**

Global notification settings determine the overall behaviour of the notifications you receive from Confluence.

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Email.
3. Choose Edit.
4. Change the default settings to suit your needs. You can alter these email settings at any time.
5. Choose Submit to save your changes.

**Page and blog post notifications**

Follow the quick guide below to receive notifications from Confluence about changes to and comments on a specific page or blog post. See Watching Pages, Spaces and Blogs for a full description.

You can watch any given page or blog post that you have permission to view. We will use your space's home page as an example.

1. Go to the home page of your space.
2. Choose Watch.

You can choose to watch just that page, or all pages in the space.

You are now watching the current page and Confluence will notify you about any updates made or comments added.

Note that Confluence will **not** notify you about content changes that are due to the output of a macro. For example: The output of the Children macro will change if someone adds a child page. The page containing the Children macro will show the new child page. But the page content itself has not been edited, so no notifications will be sent.

You can stop watching a page or blog post at any time. Choose Watch and deselect the Watch Page or Watch all content in this space checkboxes.

**Step 5. Attach or import Office documents, if applicable**

Below are some guidelines on managing your existing Microsoft Office documents in Confluence. You can choose to attach them to a Confluence page, so that team members can view and access them in Confluence, and edit them in Office. Or you can import the documents into Confluence, converting the content to Confluence pages.
Attaching Office documents to a page

You can use Confluence as a central repository for your team’s Office documents. This means that you can share your Office documents without having to email them to your teammates. People can view the Office documents even if they do not have Office installed on their computers.

1. Go to a page in your space.
2. Choose Tools > Attachments.
3. Use one of the following methods for attaching files to the page:
   - Choose Browser and to locate the file on your computer, enter a comment then choose Attach
   - Alternatively, drag and drop one or more file(s) directly onto the ‘Drop files here’ region of the attachments screen. The ‘Attach File(s)’ message box appears, indicating the upload status of the file(s) being attached to your page.

Importing Word documents into Confluence

You can also import content from Microsoft Word into Confluence, so that it becomes a Confluence page. See Importing a Word Document into Confluence for a full description.

1. Go to your space home page.
3. Choose Browse and locate the Office document on your local drive or network.
4. Choose Next. The import document options screen will display.
5. Choose how you would like the Office Connector to import the file:
   - **Root page title** – This will be the title of the page.
   - **Import as a new page in the current space** – This option specifies that a new page will be created with the title specified.
   - **Rename imported pages if page name already exists** – This is what Confluence will do if there is a conflict.
   - **Split by heading** – If your document contains headings, Confluence can use the heading information to split the document into multiple wiki pages. If you do not want to split your document leave the default ‘Don’t split’ option selected.

6. Choose **Import**.

When the upload has finished, the content of the Office document will have been transformed into Confluence page content. You can now view and edit this page in the normal way, using the Confluence editor. There is now no connection between the original Office document and this page.

**Step 6. Import page templates and blueprints**

In order for an intranet to be effective, people need to use it. One way to spur new user adoption is to provide your team with templates so that they can focus more on content creation and less on page format. You can create your own templates or download some from the Atlassian Marketplace. See Importing Templates and Adding a Template for more information.

A blueprint is a page template with added functionality to help you create, manage and organise content in Confluence. Confluence ships with some predefined blueprints. You can also download additional blueprints from the Atlassian Marketplace. You can customise the blueprint templates to suit your individual needs and even develop your own blueprints. See Working with Blueprints.

**Creating a page from a template**

Now that you have made some templates available to your site or space, other Confluence users will be able to choose a template when they want to create a page. Templates appear in the **Create** dialog for users to select when creating a new page.

1. Go to your Intranet space.
2. Choose **Create** on the header. Available templates will be listed in the Create dialog.
3. Select a template and choose **Next**.
4. If the template contains variables, a form will appear. Type the relevant information into the form fields, and choose **Next**.
5. Enter a title for the page, update the content and choose **Save**.

**Step 7. Set up your personal space**

Now that you have created a space for your team, let's create your **personal space**. This is a place where you can publish your own pages and blog posts. Once you have created it, Confluence users can reach your personal space by clicking your name in the **People Directory** or by searching for your name via the **quick navigation search box**.

1. Choose **your profile picture** at top right of the screen, then choose **Add Personal Space**.
2. Enter a few details about your space:
   - Choose who can **view** content.
   - Choose who can **contribute** (create and edit) content.
   - Choose the ‘**Global Look and Feel**’ for your personal space.
3. Choose **Create**.
4. The ‘Home’ page for your new space is displayed.

**Step 8. Publish a blog post**

Blog posts are a good way of letting your team mates and the company know your news. People can blog about product and strategic ideas, team updates, and things they want to get ideas about. New employees can write blog posts introducing themselves. People write about getting married or the birth of a child. Blog posts are a great way for people to share their visions, get to know their c-oworkers and start lively discussions.

Remember to set your email notifications to alert you about the blog posts published within Confluence, as described in an earlier step.

See **Working with Blog Posts** for a full description of adding, editing, viewing and linking to blog posts.

1. Go to a page in your space.
2. Choose **Create** in the header.
3. Select **Blog** then choose **Next**.
4. Add a title and some content.
5. Choose **Save** to publish your blog post.