# Contents

Confluence User's Guide .......................................................... 7
Getting Started with Confluence .............................................. 8
  About Confluence ............................................................... 8
  Dashboard .............................................................................. 9
Page in View Mode .................................................................... 10
Confluence Glossary .................................................................. 12
Keyboard Shortcuts ..................................................................... 16
Using Confluence on a Mobile Device ....................................... 20
Creating Content ....................................................................... 24
Using the Editor ......................................................................... 27
  Quick Reference Guide for the Confluence Editor .................... 31
  Working with Text Effects ....................................................... 42
  Working with Links .................................................................. 44
  Working with Anchors ............................................................ 49
  Displaying Images ................................................................... 51
    Deleting an Image ................................................................. 55
  Working with Tables ............................................................... 55
  Using Symbols, Emoticons and Special Characters .................. 57
  Using Autocomplete .................................................................. 59
  Working with Page Layouts and Columns and Sections ............ 63
Working with Macros .................................................................... 66
  Activity Stream Macro ............................................................ 68
  Anchor Macro ........................................................................ 68
  Attachments Macro ................................................................. 68
  Blog Posts Macro .................................................................... 70
  Change-History Macro ............................................................. 75
  Chart Macro .......................................................................... 76
  Cheese Macro ......................................................................... 123
  Children Display Macro .......................................................... 124
  Code Block Macro .................................................................... 126
  Column Macro ......................................................................... 130
  Content by Label Macro .......................................................... 131
  Content by User Macro ........................................................... 136
  Content Report Table Macro ................................................... 137
  Contributors Macro .................................................................. 139
  Contributors Summary Macro .................................................. 143
  Create from Template Macro ................................................... 148
  Create Space Button Macro ..................................................... 151
  Excerpt Include Macro ............................................................ 153
  Excerpt Macro ........................................................................ 154
  Expand Macro ......................................................................... 156
  Favourite Pages Macro ............................................................ 157
  Gadget Macro ......................................................................... 158
  Gallery Macro ......................................................................... 161
  Global Reports Macro ............................................................. 164
  HTML Include Macro .............................................................. 165
  HTML Macro .......................................................................... 166
  IM Presence Macro .................................................................... 167
  Include Page Macro ................................................................. 168
  Info Macro .............................................................................. 170
  JIRA Chart Macro ..................................................................... 172
  JIRA Issues Macro .................................................................... 175
  JUnit Report Macro .................................................................. 184
  Labels List Macro ..................................................................... 187
  Livesearch Macro ...................................................................... 188
  Loremipsum Macro .................................................................. 189
Multimedia Macro .......................................................... 190
Navigation Map Macro .................................................. 191
Network Macro .............................................................. 193
Notefile Macro .............................................................. 195
Note Macro ................................................................. 196
Office Excel Macro ......................................................... 197
Office PowerPoint Macro ............................................... 198
Office Word Macro ......................................................... 200
Page Index Macro .......................................................... 201
Page Properties Macro ................................................... 202
Page Properties Report Macro ......................................... 204
Page Tree Macro ............................................................ 207
Page Tree Search Macro .................................................. 210
Panel Macro ................................................................. 211
PDF Macro ................................................................. 213
Popular Labels Macro ..................................................... 213
Profile Picture Macro ....................................................... 214
Recently Updated Dashboard Macro ................................ 215
Recently Updated Macro .................................................. 217
Recently Used Labels Macro .......................................... 223
Related Labels Macro ..................................................... 224
RSS Feed Macro ............................................................ 225
Search Results Macro ..................................................... 227
Section Macro ............................................................... 230
Space Attachments Macro ............................................. 231
Space Details Macro ....................................................... 232
Space Jump Macro .......................................................... 233
Spaces List Macro .......................................................... 235
Status Macro ............................................................... 236
Table of Contents Macro ............................................... 237
Table of Content Zone Macro ......................................... 242
Tip Macro ................................................................. 246
User List Macro ............................................................. 247
User Profile Macro .......................................................... 248
User Status List Macro ................................................... 249
View File Macro ............................................................ 250
Warning Macro ............................................................. 253
Widget Connector Macro ................................................. 254
Task Report Macro .......................................................... 264
Working with Drafts .......................................................... 266
Configuring the Time Interval at which Drafts are Saved ..... 267
Concurrent Editing and Merging Changes ....................... 268
Resuming the Editing of a Draft ...................................... 268
Recording Change Comments ........................................ 269
Creating Beautiful and Dynamic Pages ......................... 270
Working with Templates .................................................... 273
Adding a Template .......................................................... 274
Creating a Page using a Template .................................... 280
Editing a template ........................................................... 282
Deleting a Template ........................................................ 283
Working with Blueprints ................................................... 284
Decisions Blueprint ........................................................ 287
File List Blueprint ............................................................ 288
Meeting Notes Blueprint .................................................. 290
Product Requirements Blueprint .................................... 291
Shared Links Blueprint .................................................... 293
JIRA Report Blueprint ..................................................... 294
Retrospectives Blueprint ............................................... 297
Creating a blueprint style report ....................................... 299
Working with the Office Connector ................................... 305
Office Connector Prerequisites ........................................ 305
Displaying Office Files in Confluence ............................... 307
Organising Content

Sharing Content

Working with Pages

Managing Changes and Notifications and Tasks

Finding Content

Organising Content

Importing a Word Document into Confluence
Editing an Office Document from Confluence
Editing an Office Spreadsheet from Confluence
Editing an Office Presentation from Confluence
Installing the Firefox Add-On for the Office Connector
Importing Content Into Confluence
Importing Content from Another Wiki
Importing Pages from Disk

Network Overview
Likes and Popular Content
User Status Updates
Using Mentions
Emailing a Page
Commenting on pages and blog posts
Printing Confluence Pages

Exporting Confluence Pages and Spaces to Other Formats
Exporting Confluence Pages and Spaces to HTML
Exporting Confluence Pages and Spaces to PDF
Customising Exports to PDF
Creating PDF in Another Language
Exporting to a Word document
Exporting Confluence Pages and Spaces to XML

Managing Changes and Notifications and Tasks
Watching Pages, Spaces and Blogs
Managing Watchers
Subscribing to Email Notifications of Updates to Confluence Content
Subscribing to RSS Feeds within Confluence
Using pre-specified RSS feeds
Using the RSS Feed Builder
Subscribing to a Network RSS Feed
Managing Notifications in Confluence
Working with Tasks

Finding Content
Searching Confluence
Confluence Search Syntax
Confluence Search Fields

Organising Content
Working with Pages
Moving a Page
Copying a Page
Renaming a Page
Deleting a Page
Purging Deleted Pages
Restoring a Deleted Page
Viewing All Pages in a Space
Changing the Sequential Order of Pages
Managing Orphaned Pages
Managing Undefined Pages
Using the Documentation Theme
Viewing Page Information
Viewing Recently Visited Content
Page History and Page Comparison Views
Using a WebDAV Client to Work with Pages

Working with Blog Posts

Working with Spaces
Viewing All Confluence Spaces
Creating a Space
Setting Up your Personal Space
Administering a Space
Editing Space Details

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deleting a Space</td>
<td>422</td>
</tr>
<tr>
<td>Backing Up and Restoring a Space</td>
<td>422</td>
</tr>
<tr>
<td>Archiving a Space</td>
<td>423</td>
</tr>
<tr>
<td>Viewing Space Activity</td>
<td>424</td>
</tr>
<tr>
<td>Viewing Recently Updated Content</td>
<td>425</td>
</tr>
<tr>
<td>Working with Mail Archives</td>
<td>425</td>
</tr>
<tr>
<td>Adding a Mail Account</td>
<td>426</td>
</tr>
<tr>
<td>Deleting Mail</td>
<td>427</td>
</tr>
<tr>
<td>Fetching Mail</td>
<td>428</td>
</tr>
<tr>
<td>Importing Mail</td>
<td>428</td>
</tr>
<tr>
<td>Managing Mail Accounts</td>
<td>429</td>
</tr>
<tr>
<td>Space Administrators and their Permissions</td>
<td>430</td>
</tr>
<tr>
<td>Adding Labels</td>
<td>431</td>
</tr>
<tr>
<td>Using Labels to Categorise Spaces</td>
<td>433</td>
</tr>
<tr>
<td>Removing Labels</td>
<td>434</td>
</tr>
<tr>
<td>Using Label Macros to Categorise Wiki Content</td>
<td>435</td>
</tr>
<tr>
<td>Viewing Labels and Labelled Content</td>
<td>436</td>
</tr>
<tr>
<td>Viewing Personal Labels</td>
<td>439</td>
</tr>
<tr>
<td>Working with Favourites</td>
<td>439</td>
</tr>
<tr>
<td>Working with Attachments</td>
<td>441</td>
</tr>
<tr>
<td>Using Drag-and-Drop in Confluence</td>
<td>442</td>
</tr>
<tr>
<td>Attaching Files to a Page</td>
<td>443</td>
</tr>
<tr>
<td>Attachment Versions</td>
<td>445</td>
</tr>
<tr>
<td>Deleting an Attachment</td>
<td>445</td>
</tr>
<tr>
<td>Displaying a List of Attachments</td>
<td>446</td>
</tr>
<tr>
<td>Downloading Attachments</td>
<td>450</td>
</tr>
<tr>
<td>Editing Attachment Properties</td>
<td>450</td>
</tr>
<tr>
<td>Embedding Multimedia Content</td>
<td>451</td>
</tr>
<tr>
<td>Embedding PowerPoint Presentations in a Page</td>
<td>454</td>
</tr>
<tr>
<td>Moving an Attachment</td>
<td>454</td>
</tr>
<tr>
<td>Viewing Attachment Details</td>
<td>455</td>
</tr>
<tr>
<td>Customising Confluence</td>
<td>456</td>
</tr>
<tr>
<td>Personal Customisations</td>
<td>457</td>
</tr>
<tr>
<td>User Profile Overview</td>
<td>457</td>
</tr>
<tr>
<td>Changing Password</td>
<td>458</td>
</tr>
<tr>
<td>Editing User Settings</td>
<td>459</td>
</tr>
<tr>
<td>Editing Your User Profile</td>
<td>461</td>
</tr>
<tr>
<td>Email Address Privacy</td>
<td>462</td>
</tr>
<tr>
<td>Updating Email Address</td>
<td>462</td>
</tr>
<tr>
<td>Choosing a Profile Picture</td>
<td>462</td>
</tr>
<tr>
<td>Viewing User Profile</td>
<td>464</td>
</tr>
<tr>
<td>Viewing and Revoking OAuth Access Tokens</td>
<td>465</td>
</tr>
<tr>
<td>Choosing your Home Page</td>
<td>467</td>
</tr>
<tr>
<td>Customising your Personal Dashboard</td>
<td>468</td>
</tr>
<tr>
<td>Customising the Look and Feel of a Confluence Space</td>
<td>469</td>
</tr>
<tr>
<td>Applying a Theme to a Space</td>
<td>470</td>
</tr>
<tr>
<td>Configuring the Documentation Theme</td>
<td>471</td>
</tr>
<tr>
<td>Configuring a Sidebar</td>
<td>480</td>
</tr>
<tr>
<td>Changing a Space's Logo</td>
<td>481</td>
</tr>
<tr>
<td>Customising Space Layouts</td>
<td>482</td>
</tr>
<tr>
<td>Editing a Space's Colour Scheme</td>
<td>484</td>
</tr>
<tr>
<td>Styling Confluence with CSS</td>
<td>486</td>
</tr>
<tr>
<td>Basic Styling Tutorial</td>
<td>488</td>
</tr>
<tr>
<td>Styling Fonts in Confluence</td>
<td>490</td>
</tr>
<tr>
<td>Requesting Add-ons</td>
<td>491</td>
</tr>
<tr>
<td>Giving People Access to Content</td>
<td>492</td>
</tr>
<tr>
<td>Page Restrictions</td>
<td>493</td>
</tr>
<tr>
<td>Site Administrators and their Permissions</td>
<td>497</td>
</tr>
<tr>
<td>Contacting Confluence Administrators</td>
<td>497</td>
</tr>
<tr>
<td>Space Administrators and their Permissions</td>
<td>499</td>
</tr>
<tr>
<td>Space Permissions Overview</td>
<td>499</td>
</tr>
<tr>
<td>Assigning Space Permissions</td>
<td>500</td>
</tr>
</tbody>
</table>
Confluence User's Guide

About the Confluence User's Guide

This guide covers features and functions that are available to Confluence users and space administrators.

For information on administering your Confluence site, including customising your site, refer to the Confluence Administrator's Guide.

This guide assumes that you are using the Confluence default theme. If your Confluence site has been customised the header may look different, and menu items appear in different locations to the examples given in this guide.

- Getting Started with Confluence
  - About Confluence
  - Dashboard
  - Page in View Mode
  - Confluence Glossary
  - Keyboard Shortcuts
  - Using Confluence on a Mobile Device

- Creating Content
  - Using the Editor
  - Creating Beautiful and Dynamic Pages
  - Working with Templates
  - Working with Blueprints
  - Working with the Office Connector
  - Importing Content Into Confluence

- Sharing Content
  - Network Overview
  - Likes and Popular Content
  - User Status Updates
  - Using Mentions
  - Emailing a Page
  - Commenting on pages and blog posts
  - Printing Confluence Pages
  - Exporting Confluence Pages and Spaces to Other Formats

- Managing Changes and Notifications and Tasks
  - Watching Pages, Spaces and Blogs
  - Managing Watchers
  - Subscribing to Email Notifications of Updates to Confluence Content
  - Subscribing to RSS Feeds within Confluence
  - Managing Notifications in Confluence
  - Working with Tasks

- Finding Content
  - Searching Confluence
  - Searching the People Directory

- Organising Content
  - Working with Pages
  - Working with Blog Posts
  - Working with Spaces
  - Working with Mail Archives
  - Working with Confluence Labels
  - Working with Favourites
  - Working with Attachments

- Customising Confluence
  - Personal Customisations
  - Customising the Look and Feel of a Confluence Space

Downloads

Download the Confluence documentation in PDF format.

Other Resources

Confluence Administrator's Guide
Confluence Knowledge Base
Atlassian Answers
Getting Started with Confluence

Getting to know Confluence
- The dashboard
- Page layout
- Spaces in Confluence
- Other users

Personalising Confluence
- Changing your password
- Updating your user profile
- Creating your personal space
- Choosing the home page you see when you log in
- Customising the dashboard for yourself
- Getting notifications about changes

Things to do
- Creating Content
- Adding a space

More helpful things
- Keyboard shortcuts
- Confluence glossary
- About Confluence

About Confluence
Confluence is a wiki. You can use it to collaborate on writing and sharing content with your team. Your team can be as small or as big as you like. It could encompass the whole world. Your content can be as simple or as rich as you like. It can be just words, or you can add images, diagrams, activity streams, web service integration and more.

In a nutshell, a wiki is a piece of software that runs on a server. It publishes
web pages that you can read via a web browser such as Mozilla Firefox, Google Chrome or Microsoft Internet Explorer. The thing that makes wiki pages different from other web pages is the edit button. Provided that you have the right permissions, you can edit the page, save your changes, and the updates will be visible to other people immediately.

Confluence provides extra functionality that transforms it into a social collaboration platform:

- Add a space for your team, then add a page or comment on someone else's page.
- Share content by writing a blog post, sharing a link or calling someone's attention to a page via @mentions. Form a social network and tell people what you are doing via a status update.
- Add images, picture galleries, videos and more.

Dashboard

The dashboard is the front page of a Confluence site. It provides an overview of the site, gives access to the spaces that you have permission to view, and displays a few different lists of the most recently updated content.

You can go to the dashboard from anywhere in your site by choosing the site logo at the top left of the page. This might be the Confluence logo, or may be a customised logo set by your Confluence Administrator.

Overview of the dashboard

The dashboard is divided into these sections:

- **Welcome message**: The information that appears in the top left section of the dashboard. Confluence Administrators can customise this message.

- **Get started**: A quick-start guide for administrators. This section of the dashboard is visible to Confluence administrators and system administrators only.

  It is not configurable via the web interface, but you can update or remove it by editing the site layout.

- **Spaces, Pages, Network**: Tabs displaying your favourite content and people, displayed in the lower left section of the dashboard.
  - **Spaces** displays the spaces you have marked as favourites, followed by all the spaces that you have permission to view.
  - **Pages** displays the pages you have marked as favourites.
  - **Network** displays the users that you are following (or who are following you).

- **Recent activity**: Tabs on the right-hand side of the dashboard, displaying recently-updated content:
  - **Popular** displays content that has been recently created, liked or commented on. See below for more details.
  - **All Updates** displays updates from all spaces that you have permission to view.
  - **Favourite Spaces** displays updates from your favourite spaces.
  - **Network** displays updates made by the users that you are following (or who are following you).
  - **Space Categories** displays updates from spaces in the category you have selected from the list.
The 'Popular' tab on the dashboard displays recent activity of the following types:

- Pages, blog posts and comments that people have recently **liked**.
- Pages and blog posts that people have recently **commented** on, and threaded comments that people have recently replied to.
- Pages and blog posts that have recently been **created**.

'Recent' means any activity in the last seven days.

A **bold** link means that you have not yet visited the page.

The activities are listed in order of popularity, with the most popular at the top. Likes, comments and content creations are scored equally. Activity that involves people in your network ranks higher than activity not involving your network. The most recent activity ranks higher than earlier activity.

**Notes**

- If you have the right permission, you can **add a new space** from the dashboard. Choose **Create Space** at the top right of the dashboard, or on the ‘Spaces’ tab.
- By default, the dashboard is the home page for the Confluence site. However, you can set any other page in Confluence as your home page via your **user profile** settings.
- If your site has a custom homepage, the site logo will take you to the homepage not the dashboard. You can still access the dashboard by invoking a URL like this one: `https://yoursite.com/wiki/dashboar.action`. See **Configuring the Site Home Page** for more details.
- Users can **customise the dashboard** for themselves.
- Are you looking for a way to build an **RSS feed**? Choose **Help > Feed Builder**.
- Are you looking for a list of the **people** in your site? Choose **People** on the header.
- Administrators can **customise the global dashboard** that all users see.

**Page in View Mode**

The images below show the menus and other controls on a typical Confluence page using the default theme. The sidebar is on the left of each page. On the right is the body of the page.
### Section or option

<table>
<thead>
<tr>
<th>Section or option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sidebar</strong></td>
<td>The sidebar helps you to see where you are in the space, and helps you to find pages and other content in the space. The sidebar contains shortcut links to important pages in your space. Space administrators can access options to configure the sidebar and other parts of the space. At the bottom of the sidebar is a contextual navigation section, which adapts depending on the page or blog post that you are viewing. See <strong>Finding Content</strong>.</td>
</tr>
<tr>
<td><strong>Application Navigator</strong></td>
<td>Use the application navigator for quick and easy access to applications that are linked to your site, for example JIRA. Confluence Administrators can add links to the application navigator, for example external websites.</td>
</tr>
<tr>
<td><strong>Dashboard / Home Page</strong></td>
<td>Choose the site logo to access to the site home page. By default, the dashboard is the home page of your Confluence site. Your Confluence Administrator may have set a different homepage for your site.</td>
</tr>
<tr>
<td><strong>Spaces</strong></td>
<td>Use the Spaces menu to access your recently viewed spaces and the Space Directory which contains a list of all the spaces that you have permission to view.</td>
</tr>
<tr>
<td><strong>People</strong></td>
<td>Choose this option to see the people directory, showing all the users of your Confluence site.</td>
</tr>
<tr>
<td>Create</td>
<td>Create pages, blog posts, and other content types in Confluence.</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td>Search</td>
<td>Type text into this box to see a list of matching pages. Select a page to go directly to it, or press Enter to use the full Confluence search. See Searching Confluence.</td>
</tr>
<tr>
<td>Help</td>
<td>Go to the documentation for help and support, view a list of keyboard shortcuts, or access other help options from this menu.</td>
</tr>
<tr>
<td>Administration</td>
<td>The cog icon gives access to the site administration menu. If you are a Confluence administrator or a system administrator, you can access user and add-on management, and other site administration options here. (Note that the space administration options are in the sidebar, not in the administration menu.)</td>
</tr>
<tr>
<td>Workbox</td>
<td>View and respond to notifications collected from Confluence page watches, shares and mentions. See Managing Notifications in Confluence.</td>
</tr>
<tr>
<td>User</td>
<td>After you have logged in, your profile picture will appear at top right of the page. When you choose your profile picture, the user menu drops down with options to log out, access your user profile, or view your editing history, personal labels and page watches. You can also retrieve drafts of pages you are editing.</td>
</tr>
<tr>
<td>Tools</td>
<td>Perform miscellaneous actions relating to the page.</td>
</tr>
<tr>
<td>Like</td>
<td>Let people know that you like this page.</td>
</tr>
<tr>
<td>Edit</td>
<td>Edit the current page. (Shortcut: press e on your keyboard.)</td>
</tr>
<tr>
<td>Watch</td>
<td>Add yourself as a watcher of the page, to receive notifications of changes.</td>
</tr>
<tr>
<td>Share</td>
<td>Email a link to the current page to another Confluence user or email address.</td>
</tr>
<tr>
<td>Labels</td>
<td>View and edit labels (tags) attached to the current page. (Shortcut: press l on your keyboard.)</td>
</tr>
<tr>
<td>Add a comment</td>
<td>Click in the text box to begin writing a comment. (Shortcut: press m on your keyboard.)</td>
</tr>
<tr>
<td>Title and breadcrumbs</td>
<td>The title is the page name. The breadcrumbs show the position of the page in relation to its parent pages in the space.</td>
</tr>
<tr>
<td>Byline</td>
<td>Shows the original author and the most recent editor of the page, and the date of the most recent edit.</td>
</tr>
<tr>
<td>Byline icons</td>
<td>A small padlock indicates page restrictions. A paperclip indicates that the page has attachments. Both icons are clickable, leading to the 'Page Information' and 'Attachments' pages, respectively.</td>
</tr>
</tbody>
</table>

**Confluence Glossary**

**Administration Console**
The Administration Console is the interface for the global administration of Confluence. Only **administrators** can access the Administration Console.

**Administrators**

The Confluence permission scheme allows the following main levels of administrator permissions:

- **System Administrator** – full administrative access to Confluence.
- **Confluence Administrator** – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the [overview of global permissions](#) for details of the functions which each level of administrator can perform.

**CamelCase**

CamelCase is a form of markup commonly used in wikis where words compounded together LikeThis without spaces are used to create links.

In Confluence, Camelcasing can be turned on from the Administration Console.

**Change Comment**

A change comment is a short description entered during the edit of a page to record the changes being made in the edit.

**Child Pages**

Creating child pages is a means of hierarchically organising content in Confluence. A child page can only have one parent page.

**Comments**

A comment may be a remark, question, or any other additional information you wish to add to a page pertaining to the topic the page covers. You can comment on any page or news item in Confluence.

**Confluence Administrators**

The Confluence permission scheme allows the following main levels of administrator permissions:

- **System Administrator** – full administrative access to Confluence.
- **Confluence Administrator** – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the [overview of global permissions](#) for details of the functions which each level of administrator can perform.

**Custom Decorators**

Decorator files are used to define layouts in Confluence. They are vmd files and require knowledge of the language, **Velocity**, to edit.

**Dashboard**

The dashboard is the front page of a Confluence site. It provides an overview of the site, access to all spaces, and displays a list of the most recently updated content within them.

**Form Field Markup**

Form field markup is a specialised markup used when creating page templates in Confluence 4.2 and earlier. It is no longer needed, because the template editor offers form fields as an option in the editor toolbar.

**Global Administrators**

A global administrator is the same as a **system administrator**.
Global Spaces
Known as Site Spaces, these spaces contain content on any theme or topic of your choice.
For more information about site spaces and personal spaces, see Working with Spaces.

Hover Profile
The hover profile is the pop-up you see when the mouse pointer pauses over a Confluence user’s name. Use the hover profile to follow the user, visit their profile, and more.

JIRA
JIRA is Atlassian's award winning Issue tracking and project management application.
Visit Atlassian’s website to learn more about JIRA.

Labels
Labels are user-defined tag words assigned to pages to categorise content in Confluence.

Macros
A macro is a command wrapped inside curly braces {...} used to perform programmatic functions and generate more complex content structures in Confluence.

Blog Posts
A blog post may be a journal entry, status report or any other timely information pertaining to a space.

Notifications
A notification is an email message sent to you updating you of changes to pages and spaces you choose to ‘watch’.

Orphaned Pages
An orphaned page is a page without any incoming links.

Pages
Pages are the primary means of storing information in Confluence and are the building blocks of spaces.

Parent Page
A parent page is a page that has one or more child pages. It may itself be a child of another page.

People Directory
The People Directory contains a list of all users in your Confluence site. Each user's name links to their personal space.

Permalink
A permalink is the url used to link to specific content items like comments.

Personal Spaces
Personal spaces belong to particular users, and rather than being listed on the Dashboard, are available from the People Directory.
For more information about global spaces and personal spaces, see Working with Spaces.

RSS Feeds
An RSS feed is a format for delivering summaries of regularly changing web content. RSS is read by RSS newsreader programs.

You will need an RSS reader to subscribe to feeds within Confluence.

Confluence acts as an RSS reader for feeds from sites outside of Confluence.

**RSS Reader**

An RSS reader is a specialised RSS program (also called aggregator) that displays the contents of RSS feeds for you. To subscribe to RSS feeds within Confluence, you will need an RSS reader.

**Site Administrators**

The Confluence permission scheme allows two levels of administrator permissions:

- System Administrator – full administrative access to Confluence.
- Confluence Administrator – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

**Site Spaces**

Site spaces contain content on any theme or topic of your choice. Previously known as global spaces.

For more information about site spaces and personal spaces, see Working with Spaces.

**System Administrators**

The Confluence permission scheme allows two levels of administrator permissions:

- System Administrator – full administrative access to Confluence.
- Confluence Administrator – access to most of the Confluence administrative functions, but excluding those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

**Space Administrators**

A space administrator is a user with the ‘Space Admin’ permission for the space. A user with this permission can perform a host of functions relating to the management of a space and has complete access to the space regardless of any other control settings or permissions.

Permissions for a space are only assigned and modified by space administrators.

**Spaces**

A space is an area within Confluence, containing your pages, blog posts and other content. You can think of each space as a sub-site, or mini-site, each with its own home page.

There are two types of spaces: site spaces and personal spaces - see Working with Spaces.

**Templates**

A template is a pre-defined page that can be used as a prototype when creating pages. Templates are useful for giving pages a common style or format.

**Themes**

Themes are pre-defined ‘look and feel’ styles which are configured from the administration menu and can be applied across Confluence or to a single space.

** Thumbnails**
As of Confluence 4.0, all images on the page that aren’t links are displayed as thumbnails: when you click on an image the full-size image is displayed in a pop-up.

**Tiny links**

A tiny link is the shortened URL of a page which is useful when sending links to the page, for example, via email.

**Trackback**

Trackback is a mechanism by which two sites can stay informed each time one site refers to the other by means of trackback ‘pings’.

In Confluence, Trackback is enabled from the Administration Console.

**Trackback Autodiscovery**

Trackback autodiscovery is a block of code that can be placed in a web-page to describe where trackback pings should be sent for that page. You can read the technical specification for autodiscovery here.

When Trackback is enabled, Confluence uses Trackback Autodiscovery to ping pages that are linked to, and to advertise its own pages as being able to receive pings.

**Undefined Links**

An undefined link is a link to a page that has not yet been created. Clicking on the page link allows you create the page.

**User Profile**

Every user account in Confluence is linked to a profile that contains user-related information and options for configuring user preferences.

**Watching**

When you watch a page, you receive an email notification whenever that page has been modified. When you watch a space, you receive an email notification whenever content is added or modified in that space.

**Wiki**

Pioneered by Ward Cunningham, and named after the Hawaiian word for 'quick', a wiki is a website that makes it easy for anyone to contribute pages, and link them together.

**Wiki Markup**

This is the markup used in some macros and the site welcome message. You can also insert wiki markup into the editor using Insert > Markup.

**Related Topics**

Take me back to Confluence User's Guide

**Keyboard Shortcuts**

Confluence provides a number of keyboard shortcuts that you can use to speed up your editing and viewing. This page describes the keyboard shortcuts for the English language. The shortcut keys (letters of the alphabet) may be different in other languages.

Confluence can display a list of available keyboard shortcuts. There are a few ways to see this keyboard shortcuts dialog:

- Choose the help icon at top right of the screen, then choose Keyboard Shortcuts.
- When viewing a page, press Shift+?
- In the editor, choose the question mark icon on the editor toolbar.

The keyboard shortcuts dialog shows the following information:
• **General** – global, page and blog post shortcuts.
• **Editor** – text editing and formatting shortcuts.
• **Editor Autoformatting** – wiki markup and autoformatting shortcuts.

### On this page:
- Keyboard shortcuts
- All screens
- Editor
- Tables in the editor
- Autocomplete in the editor
- View screen
- Workbox
- Disabling and re-enabling keyboard shortcuts
- Notes

### Related pages:
- Using Autocomplete
- Confluence User’s Guide

---

**Keyboard shortcuts**

The first section below describes the keyboard shortcuts that are available on all Confluence screens. Subsequent sections describe the shortcuts specific to each type of screen.

**Notes:**

- If you are using Chrome or Firefox on OS X, you may use 'Cmd' or 'Control' in the shortcuts below. Safari users may only use 'Control'.
- We have used capital letters (for example, 'A') instead of lower case ('a') to represent keys on the keyboard. Do not press the Shift key unless this guide explicitly mentions it.

### All screens

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>/</td>
<td>Enable the quick search</td>
</tr>
</tbody>
</table>
| Ctrl+S   | • Submit (where a form is active).  
|          | • Editor -- save the Confluence page.  
|          | • Outside the editor -- save the browser page. |
| G then D | Go to the dashboard |
| G then S | Browse the current space |
| G then G | Position cursor in the search box. See [Searching Confluence](#). |
| ?        | Open the Keyboard Shortcut help |
| [        | Toggle the sidebar. |

### Editor

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctr+0</td>
<td>Apply the paragraph style.</td>
</tr>
<tr>
<td>Ctr+(1–6)</td>
<td>Apply a heading level (of the number chosen) to the current line.</td>
</tr>
<tr>
<td>Ctr+7</td>
<td>Apply the preformatted style.</td>
</tr>
<tr>
<td>Ctr+8</td>
<td>Apply the block quote style.</td>
</tr>
<tr>
<td>Key Sequence</td>
<td>Action</td>
</tr>
<tr>
<td>--------------</td>
<td>--------</td>
</tr>
<tr>
<td>Ctrl+Shift+A</td>
<td>Open the Macro Browser.</td>
</tr>
<tr>
<td>Ctrl+B</td>
<td>Make the selected text <strong>bold</strong>.</td>
</tr>
<tr>
<td>Ctrl+Shift+B</td>
<td>Format text as a bulleted list.</td>
</tr>
<tr>
<td>Ctrl+Shift+D</td>
<td>Insert wiki markup. (Opens the Wiki Markup dialog.)</td>
</tr>
<tr>
<td>Ctrl+Shift+E</td>
<td>Preview the page you are editing.</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Open the Find and Replace toolbar.</td>
</tr>
<tr>
<td>Ctrl+I</td>
<td>Make the selected text <em>italic</em>.</td>
</tr>
<tr>
<td>Ctrl+Shift+J</td>
<td>Insert a JIRA issue. (Opens the Insert JIRA Issue dialog.)</td>
</tr>
<tr>
<td>Ctrl+K</td>
<td>Insert a link. (Opens the Insert Link dialog.)</td>
</tr>
<tr>
<td>Ctrl+Shift+K</td>
<td>See a list of suggested pages or other locations to link to from your page. More about autocomplete...</td>
</tr>
<tr>
<td>Ctrl+M</td>
<td>Insert an image. (Opens the Insert Image dialog.)</td>
</tr>
<tr>
<td>Ctrl+Shift+M</td>
<td>See a list of suggested images, documents and other files to embed in your page. More about autocomplete...</td>
</tr>
<tr>
<td>Ctrl+Shift+N</td>
<td>Format text as a numbered list.</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Save the page you are editing.</td>
</tr>
<tr>
<td>Ctrl+Shift+S</td>
<td>Format text with a strike through.</td>
</tr>
<tr>
<td>Ctrl+U</td>
<td>Make the selected text <strong>underlined</strong>.</td>
</tr>
<tr>
<td>Ctrl+Y</td>
<td>Revert an action that was undone.</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Undo the most recent action.</td>
</tr>
<tr>
<td>Tab</td>
<td>Indent current line (only in bulleted lists and numbered lists).</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>'Outdent' current line (only in bulleted lists and numbered lists).</td>
</tr>
<tr>
<td>Shift+Enter</td>
<td>Force a line break without a paragraph break. This is a line break with no extra space.</td>
</tr>
<tr>
<td>[ then ]</td>
<td>Add a task.</td>
</tr>
<tr>
<td>Ctrl+Shift+F</td>
<td>Hide the tools at the top and bottom of the page, giving you a much larger editing area (a full-screen editor).</td>
</tr>
</tbody>
</table>

**Tables in the editor**

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+c</td>
<td>Copy the current table row, or the selected rows.</td>
<td>Cmd+Shift+c</td>
</tr>
<tr>
<td>Ctrl+Shift+i</td>
<td>Insert a table. (Opens the Insert Table dialog.)</td>
<td>Cmd+Shift+i</td>
</tr>
</tbody>
</table>
### Paste the table rows from your clipboard, placing them above the current row.

### Cut the current table row, or the selected rows.

### Add a row above the current row.

### Add a row below the current row.

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+v</td>
<td>Paste the table rows from your clipboard, placing them above the current row.</td>
</tr>
<tr>
<td>Ctrl+Shift+x</td>
<td>Cut the current table row, or the selected rows.</td>
</tr>
<tr>
<td>Alt+Up Arrow</td>
<td>Add a row above the current row.</td>
</tr>
<tr>
<td>Alt+Down Arrow</td>
<td>Add a row below the current row.</td>
</tr>
</tbody>
</table>

### Autocomplete in the editor

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>[</td>
<td>See a list of suggested pages or other locations to link to from your page.</td>
</tr>
<tr>
<td>!</td>
<td>See a list of suggested images, multimedia files and documents to embed in your page.</td>
</tr>
<tr>
<td>{</td>
<td>See a list of suggestions as you begin typing a macro name.</td>
</tr>
<tr>
<td>@</td>
<td>See a list of suggested users to mention.</td>
</tr>
<tr>
<td>//</td>
<td>Insert a date using the date picker.</td>
</tr>
</tbody>
</table>

See more about using [autocomplete](#).  

### View screen

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Create a blog post.</td>
</tr>
<tr>
<td>C</td>
<td>Create a child page of your current page.</td>
</tr>
<tr>
<td>E</td>
<td>Edit a page or blog post, or return to Edit mode when previewing.</td>
</tr>
<tr>
<td>K</td>
<td>Open the Link To dialog.</td>
</tr>
<tr>
<td>L</td>
<td>Add or edit labels.</td>
</tr>
<tr>
<td>M</td>
<td>Add a comment to a page or blog post.</td>
</tr>
<tr>
<td>S</td>
<td>Share the current page</td>
</tr>
<tr>
<td>T</td>
<td>View attachments.</td>
</tr>
<tr>
<td>V</td>
<td>Return to page view (only if you are viewing page attachments).</td>
</tr>
<tr>
<td>W</td>
<td>Add or edit watchers.</td>
</tr>
</tbody>
</table>

### Workbox

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>g then n</td>
<td>Open the Confluence workbox.</td>
</tr>
<tr>
<td>j</td>
<td>Move down to the next entry in the notification list.</td>
</tr>
<tr>
<td>k</td>
<td>Move up to the previous entry in the notification list.</td>
</tr>
</tbody>
</table>
See more about managing notifications.

Disabling and re-enabling keyboard shortcuts

Keyboard shortcuts are enabled by default. You can disable general keyboard shortcuts for your personal editing sessions. This setting will not affect other Confluence users. You cannot disable the editor keyboard shortcuts.

To disable or re-enable general keyboard shortcuts:

1. Log in to Confluence.
2. Open the keyboard shortcuts dialog, by doing one of the following:
   - Choose the help icon at top right of the screen, then choose Keyboard Shortcuts.
   - When viewing a page, press Shift+?
   - In the editor, choose the question mark icon on the editor toolbar.
3. Choose the General tab.
4. Select or clear the Enable General Shortcuts check box as required.

Notes

- **Note about supported web browsers**: Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. Check the Supported Platforms page to find the list of supported web browsers and browser versions on this page.
- The keyboard shortcuts dialog also displays the trigger characters for the Confluence autocomplete feature. See Using Autocomplete.
- Confluence keyboard shortcuts are consistent with JIRA keyboard shortcuts.

Using Confluence on a Mobile Device

When you view a Confluence page on a mobile device, such as an iPhone, iPad or Android device, Confluence will display an optimised version of the page. Confluence chooses the mobile or desktop interface based on your device. See Supported Platforms for details of supported mobile devices.

On your supported mobile device, you can:

- View the Confluence dashboard, pages, blog posts, and user profiles.
- Add or reply to a comment on a page or blog post.
- Like a page, blog post or comment.
- Watch a page or blog post.
- See your notifications and tasks.

You cannot add or edit pages or blog posts, or edit existing comments, using the mobile interface.

The dashboard – the first thing you see

_Screenshot: The dashboard in Confluence mobile_
Choose a tab to see:

- Popular content – what people like in your wiki.
- Recent blogs – the latest blog posts.
- Network – updates by people in your network.

Tap the links to view the full content of a page, blog post or comment.

Searching for content and people

Tap the menu icon to open the menu panel on the left of the page. Then type text or a person's name in the Search box. The mobile interface offers the quick navigation search, which returns matches on page title only. (See Searching Confluence.) To use the full search, switch to desktop mode.

Screenshot: The menu panel in Confluence mobile

Viewing pages, blog posts and comments

Tap a link on the dashboard or on any other page. Confluence will display the linked page, blog post or
comment.

You can:

- View the content, tap a link to move to another page, and interact with the page using the standard functionality supported by mobile browsers.
- Like or unlike a page, blog post or comment.
- Watch or stop watching a page or blog post.
- Add or reply to a comment. Confluence mobile supports plain-text comments only.

Screenshot: A page showing Like, Watch and Comment options.

Viewing people's profiles

Search for a person's name, then view that person's user profile. Tap the options to phone, SMS or email a colleague directly from your mobile device.

Screenshot: A user profile on Confluence mobile

Following up on notifications

You can view and respond to your notifications on your phone or other mobile device. Tap the menu icon.
to open the menu panel on the left of the page. Choose **Notifications**, and tap a notification to see its details. You can reply, watch or like via the inline actions. Tap **Open** to open the page or blog post in a new page. For full details, see **Managing Notifications in Confluence**.

*Screenshot: Notifications in Confluence mobile*

---

**Notifications**

- 7 likes of Feedback requested - all …
- Joe Clark liked Last chance for a da...
- Re: UI Text Guidelines
- Atlassian Foundation’s bush regene...
- EOFY 2012: Choose your own Adv...
- 2 comments on Confluence for tech …

> More

**Tasks**

- Atlassian Foundation’s bush regene…
- Overview of FY12 Speaking Events
- Leave work early to pick up choco…
- Sarah Maddox – buy the chocolates
- Sarah Maddox – write the docum…
- Recommended database migratio…

**Viewing tasks**

You can view and manage your tasks on your phone or other mobile device too. Tap the menu icon to open the menu panel on the left of the page. Choose **Tasks** then tap a task to see its details.

*Screenshot: Tasks in Confluence mobile*
More things you may need to know

Some macros may not appear

Confluence macros are not yet fully supported in Confluence mobile. If you view a page that contains an unsupported macro, you will see a message inviting you to click through to the desktop version of the page.

*Screenshot: Macro not rendered in Confluence mobile*

You can swap from mobile to standard Confluence and back again

You can swap from the mobile view to the standard view of a page at any time. Choose the menu icon then choose **Switch to desktop version**.

*Screenshot: The menu panel in Confluence mobile*

You can also swap from the desktop view to the mobile view, if you are on a mobile device. Choose the option **Switch to Confluence Mobile** at the top of the window.

Administrators can disable Confluence mobile on your site

The mobile functionality is provided by a plugin called the ‘Confluence Mobile Plugin’. To remove the functionality from your site, you can disable the plugin.

Confluence mobile is a web interface, not a native app

Atlassian does not supply a native mobile application that you can download and install onto your mobile device. Confluence mobile is a web-based user interface that Confluence displays when it detects a mobile client.

See **Supported Platforms** for supported mobile browsers.
Creating Content

Do you want to add a page or a blog post? Choose the Create option in the Confluence header.

Pages and blog posts are created within spaces, so you will need the 'Add Pages' or 'Add Blog' permission for the space. A space administrator can give you these permissions. See Giving People Access to Content.

Adding a page or a blog post

You can add pages and blog posts via the 'Create' dialog.

To create content:

1. Go to a space and choose Create in the Confluence header (or use shortcut key c).
2. Choose the type of content you want to create. You can create a blank page, a blog post, or a page based on a template or blueprint.
3. Choose Next.
4. The Confluence editor will open. Add your content in the editor pane, or update the default content supplied by the template.
5. Choose Save.

You can also select a space from the Create dialog to create a page in a different space to the one you are currently viewing.

Space administrators can customise the items that are visible in the Create dialog. If any items are hidden you will see a Show more link. See Working with Templates for more information.

On this page:
- Adding a page or a blog post
- Location of the new page
- Using an undefined link to create a page later
- Other ways to create a page

Related pages:
- Using the Editor
- Creating Beautiful and Dynamic Pages
- Adding a Template
- Working with Blueprints
- Finding Content
- Organising Content
- Confluence User's Guide

Screenshot: Creating content
### Location of the new page

When you create a new page, that page will be a child of another page, in the space that you selected in the 'Create' dialog. The parent page depends on where you are when you create the page.

<table>
<thead>
<tr>
<th>Your location when creating the page</th>
<th>Location of new page</th>
</tr>
</thead>
<tbody>
<tr>
<td>You are viewing a page in the same space where you will put the new page – that is, the space that you select in the 'Create' dialog.</td>
<td>A child of the page you are currently viewing.</td>
</tr>
</tbody>
</table>
| You are viewing any other Confluence screen. For example:  
  - You are on the dashboard.  
  - You are on the 'Pages' view of a space.  
  - You are viewing a blog post.  
  - You are viewing a page in a space, and choose to add your new page in a different space. | A child of the home page in the space you select in the 'Create' dialog. |

The space sidebar in the default theme has useful links to your pages, blog posts, and other parts of the space. For more about the sidebar and the location of pages, see Finding Content.

### Using an undefined link to create a page later

You may want to insert a link pointing to a Confluence page that does not yet exist, but which you intend to create later. This type of link is called an undefined link.

**To add an undefined link for later creation of a page:**

1. Edit the page in which the link should appear.
2. Type ‘’ to trigger autocomplete, and type the name of the undefined page. Alternatively, type the text first, then select the text and type ‘’.
3. Choose **Insert Link to Create Page**.

When you save the page, Confluence colours the undefined link red. When someone clicks the link, the new page opens in edit mode. That person can then enter the page name, add content and save the page, as usual.
Other ways to create a page

You can display a button on a page, which offers people the option of creating a page based on a given template. See Create from Template Macro.

You can import content from other Confluence sites, other wikis, Microsoft Word, and HTML pages. See Importing Content Into Confluence.

The Confluence APIs allow programmatic and scripted creation of pages. See our developer documentation.

Using the Editor

The Confluence editor is the tool that you will use to create and edit Confluence pages, blog posts and comments. You can enter content as you would in a Word document, apply formatting, and embed other content and files into the page.

Looking for a quick start? See the Quick Reference Guide for the Confluence Editor.

To begin an editing session, choose Edit at the top of a page (or press E on the keyboard).

A note about permissions: To edit a page, you need the ‘Add Pages’ permission for the space. See space permissions. Someone may also apply page restrictions that may prevent you from editing the page.

An editing session

You start an editing session whenever you:

- Create a new page or blog post, or add a comment.
- Edit an existing page, blog post or comment.

While in an editing session, you can also:

- Name, or rename, a page or blog post. Note that renaming has effects that you should consider.
- Add a comment describing the changes you made.
- Choose whether or not people watching the page get notified of the change you made.
- Add labels to the page.

Confluence automatically saves drafts of your page as you work. If another user begins editing the same page as you, Confluence will display a message, and will try to merge the changes when you save your page.

Choose Cancel (at the bottom of the page) if you want to end the session without saving any changes.

The session ends when you choose Save.

When you create a new page you can choose the location where the page should be saved. You can also move a page after it has been saved, to make it a child page of a different page, or to move it to another space.

To see changes between different versions of the page, look at the history of the page.
On this page:
- An editing session
- The editor
- Toolbars
- Embedding content in the page
- Things to help you work faster
  - Autoformatting
  - Autocomplete
  - Autoconvert for pasted links
  - Drag-and-drop for external images and files
  - Drag-and-drop within the editor
  - Keyboard shortcuts
- Finding and replacing text
- Enabling and disabling autocomplete and autoformatting

Related pages:
- Quick Reference Guide for the Confluence Editor
- Page in View Mode
- Working with Tables
- Working with Page Layouts and Columns and Sections
- Displaying Images
- Working with Links
- Using Symbols, Emoticons and Special Characters
- Confluence User's Guide

The editor

Screenshot: The Confluence editor

<table>
<thead>
<tr>
<th>Item</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Page title

Type the name of the page. This name is used in links to the page.

Page content

Add the words, images and other content that forms the content of the page.

Editor toolbar

Use these tools to format and colour content, create lists and tables, indent and align text, and insert other content into the page, such as symbols, links, images, multimedia files and macros. The toolbar also provides the find and replace option, help, and full-screen editing options.

Restrictions

Control who can view or edit the page. See Page Restrictions.

Attachments

View, and manage, the attached files on the page.

Labels

Add labels to a page, to categorise the page content.

Change comment

Type a comment that describes the changes you have made.

Notify watchers

Select this option to prompt Confluence to send an email notification of your changes to people who are watching the page.

Preview

See how your changes will appear, without saving the page.

Save

Save the changes you have made to the page. (Keyboard shortcut: Ctrl+S).

Cancel

End the editing session, without saving any changes.

Toolbars

From the toolbar you can:

- Apply paragraph styles and character formatting (such as bold, italics, superscript).
- Choose colour for text.
- Create numbered and bulleted lists.
- Set the indenting and alignment for text and images.
- Create links to other pages, attachments, anchors and external resources.
- Add tables, and add, remove, cut and paste rows and columns, highlight cells, rows and columns, and merge and split cells.
- Insert other content into the page, such as images, multimedia, attachments, symbols and markup.
- Use macros to add other types of content, such as a list of JIRA issues or a table of contents.
- Add layouts and sections to your page.
- Find and replace content within the page that you are editing.
- Hide the tools at the top and bottom of the page, giving you a much larger editing area (a full-screen editor).

Note: The full-screen editing option is available in Firefox, Chrome and Safari. It is not supported in Internet Explorer. The editor remembers your full-screen preference the next time you edit a page.

Screenshot: The editor toolbar
Embedding content in the page

Choose **Insert** on the editor toolbar to include any of the following types of content on your page:

- An *image*.
- A link to another Confluence page or external URL, or a **link to an attachment or image**.
- An *emoticon or symbol*, or a horizontal line.
- A **macro**. Choose either a specific macro, or *Other Macros*, from the **Insert** menu.

Things to help you work faster

**Autoformatting**

You can type *Confluence wiki markup* directly into the editor to have Confluence auto-format your text as you type. To learn more, choose `?` on the editor toolbar and choose the **Editor Autoformatting** tab. See also See the Quick Reference Guide for the Confluence Editor.

**Autocomplete**

When editing a page or blog post, you can enter a trigger character to show a list of suggested links, media files or macros to add to your page. This feature is called 'autocomplete' and provides you with a fast editing solution if you prefer to use key strokes rather than pointing and clicking with the mouse.

Quick summary of autocomplete:

<table>
<thead>
<tr>
<th>Type</th>
<th>To see suggested:</th>
</tr>
</thead>
<tbody>
<tr>
<td>[</td>
<td>pages and blog posts</td>
</tr>
<tr>
<td>!</td>
<td>multimedia files</td>
</tr>
<tr>
<td>{</td>
<td>macros</td>
</tr>
<tr>
<td>@</td>
<td>mentions</td>
</tr>
</tbody>
</table>

For details, see **Using Autocomplete**.

**Autoconvert for pasted links**

When you paste URLs into Confluence, the editor will analyse what you are pasting and automatically convert it into something that will display well in Confluence. Examples include:
Confluence 5.5 Documentation

- YouTube videos
- JIRA issue queries
- Google Maps
- Confluence pages, blog posts, comments, user statuses, user profiles.
- Shared screenshot links from Skitch
- And more.

Drag-and-drop for external images and files

You can drag a file from a location outside Confluence, and drop it directly into the editor. For example, try it with images, video files, audio files, Office documents, and PDF files. The contents of the file will be embedded into the page or blog post. Please refer to the following pages for more information:

- **Using Drag-and-Drop in Confluence** – Using Confluence's drag-and-drop feature, including details about its requirements and configuration.
- **Displaying Images** – Embedding images onto a Confluence page or blog post.
- **Embedding Multimedia Content** – Embedding videos, audio files and other multimedia files onto a Confluence page or blog post.
- **Displaying Office Files in Confluence** – Embedding Office and PDF files onto a Confluence page or blog post.

Drag-and-drop within the editor

Working within the editor panel, you can drag an image or a macro from one location on the page and drop it into a different location on the page. Hover your cursor over the image or the macro placeholder. The cursor changes to a drag-and-drop icon and you can click the image or macro and drag it to a new location.

If you want to abandon the drag-and-drop action, press Escape. The image/macro will return to its original position.

**Note:** For the drag-and-drop of images and macros in the editor, Confluence supports the following browsers: Chrome, Firefox, and Internet Explorer 9. (Drag and drop in the editor does not work in Internet Explorer 8.)

Keyboard shortcuts

To see the keyboard shortcuts available, choose ? on the editor toolbar.

Finding and replacing text

Click the find / replace icon on the toolbar, or use the keyboard shortcut Ctrl+F (Windows) or Cmd+F (Mac OS).

Search matches are highlighted in yellow. You can step through the results one by one, replace the matching text strings one by one, or replace all matching strings at once. This find and replace feature works only within the current page.

Enabling and disabling autocomplete and autoformatting

You can enable or disable the editor's autocomplete and autoformatting functions, by editing the settings in your user profile.

In summary:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Editor under “Your Settings” in the left-hand panel.

For more details, see Editing User Settings.

Quick Reference Guide for the Confluence Editor

This page is a quick-reference guide to using the Confluence editor. The aim is to give you enough information about the editor's features for you to experiment yourself, rather than describing every possible shortcut key, autocomplete feature or toolbar option.

This guide is for people who want to use the autocomplete, autoformatting and keyboard shortcuts provided by the editor. If you prefer to use the toolbar options, the editor itself should be mostly self-explanatory.
Introductory tips

1. **Jump in and start using the Confluence editor.** The editor toolbar contains the most important buttons you’ll need for creating and editing content.

2. **Use the keyboard shortcuts.** For example, type these characters in the editor panel:
   - Type `[` (angle bracket) to insert a link.
   - Type `!` (exclamation mark) to insert an image or other media.
   - Type `{` (curly bracket) to insert a macro.
     These characters will trigger the autocomplete functionality, prompting you with a list of suggestions to finish off the entry. For more shortcuts, click the help icon on the editor toolbar.

3. **See how to undo the autocomplete and autoformatting actions.** To undo something that autocomplete or autoformatting has done, press **Ctrl+Z** (Windows) or **Cmd+Z** (Mac).

---

### On this page:

- Introductory tips
- Seeing it in action
- Using the most common formats and features
  - Formatting text
  - Using symbols
  - Linking text
  - Using lists
  - Using tables
  - Using macros
  - Displaying images and multimedia
- Enabling and disabling autocomplete and autoformatting

### Related pages:

- Using Autocomplete
- Using the Editor
- Confluence User’s Guide

---

**Seeing it in action**

This short video shows the autoformatting and autocomplete features of the editor.

**See the video on YouTube**

This video shows how to add macros, links and images by wiki markup alone. Type the macro, including its parameters and the closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket. Insert an image or other embedded object, enclosed between exclamation marks. As soon as you close the macro, link, or embedded image, Confluence will convert it to rich text format and add it to the page.

**See the video on YouTube.**

**Using the most common formats and features**

Below is a list of the most commonly used editor features, and the related keyboard shortcuts.

### Formatting text

<table>
<thead>
<tr>
<th>Formatting text</th>
<th>What to do</th>
<th>Windows keyboard shortcuts (For Mac OS X, replace 'Ctrl' with 'Cmd')</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feature</td>
<td>Description</td>
<td>Keyboard Shortcuts</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Heading levels</td>
<td>Type the heading level and a full stop. Autoformat will convert the line to the appropriate heading immediately. You can continue typing your heading text immediately. Example: h2.</td>
<td>Ctrl + 1 to 6</td>
</tr>
<tr>
<td><strong>Bold text</strong></td>
<td>Type an asterisk ‘*’, your text, then another asterisk. Confluence autoformat will convert the text to bold immediately. Example: <em>Surf’s Up</em></td>
<td>Ctrl + b</td>
</tr>
<tr>
<td><strong>Italic text</strong></td>
<td>Type an underscore ‘_’, your text, then another underscore. Confluence autoformatting will convert the text to italics immediately. Example: <em>Surf’s Up</em></td>
<td>Ctrl + i</td>
</tr>
<tr>
<td><strong>Underlined text</strong></td>
<td>Type a plus sign ‘+’, your text, then another plus sign ‘+’. Confluence autoformatting will convert the text to underlined immediately. Example: +Surf’s Up+</td>
<td>Ctrl + u</td>
</tr>
<tr>
<td><strong>Monospace text</strong></td>
<td>Type two curly braces {{, your text, then another two curly braces }}. Confluence autoformat will convert the text to monospace immediately. Example: {{Surf's Up}}</td>
<td>{}</td>
</tr>
</tbody>
</table>
| Left, centre and right alignment | Click the left, centre and right alignment buttons on the editor toolbar: ![Alignment Buttons](https://example.com)  

This can also be used to align images independently of text. | None |
| Indentation             | Click the left and right indentation buttons on the editor toolbar: ![Indentation Buttons](https://example.com)  

Tab (right), Shift + Tab (left) | |
<p>| Line break              | Press Shift + Enter to force a line break without a paragraph break. This is a line break with no extra space.                                                                                                                   | Shift + Enter     |</p>
<table>
<thead>
<tr>
<th>Quotation</th>
<th>Use the <em>Quote</em> style – select 'Quot*e' from the style dropdown menu or use the keyboard shortcut. Example:</th>
<th>Ctrl + 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>Colour</td>
<td>Click the colour options on the editor toolbar. Example:</td>
<td>None</td>
</tr>
</tbody>
</table>

### Using symbols

<table>
<thead>
<tr>
<th>Adding symbols and emoticons</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tick or check mark</td>
<td>Type a forward slash in round brackets. Autocomplete will convert it as you type. Example: (: / )</td>
<td>( + / + )</td>
</tr>
<tr>
<td>Smiley</td>
<td>Type the globally-recognised markup for a smiley face (colon and round bracket), a wink (semicolon and round bracket), and so on. Autocomplete will convert it as you type. Example: : )</td>
<td>: + )</td>
</tr>
</tbody>
</table>

### Linking text

<table>
<thead>
<tr>
<th>Linking text</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
</table>
## Linking to a Confluence page

Type a square bracket `['` and start typing the page name to see the suggested pages to link to. Press the arrow keys to select the page you want. Example:

```
[Modern Girl]
```

Alternatively, use **wiki markup entirely**. Type the link, including the alias and the page name or URL. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.

- This works if you have 'Autoformatting' enabled in the editor settings in your user profile.
- This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.
- **Example:** `[Modern Girl|Modern Girl song lyrics]`
<table>
<thead>
<tr>
<th>Linking text to a web page</th>
<th>Type a square bracket <code>[</code> and select <strong>Insert Web Link</strong>, then paste the URL into the link dialog. Example:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image" alt="Insert Web Link" /></td>
</tr>
<tr>
<td></td>
<td>Alternatively, use <strong>wiki markup entirely</strong>. Type the link, including the alias and the URL. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.</td>
</tr>
<tr>
<td></td>
<td>• This works if you have 'Autoformatting' enabled in the editor settings in your user profile.</td>
</tr>
<tr>
<td></td>
<td>• This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Example:</strong> [Modern Girl</td>
</tr>
</tbody>
</table>

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Linking to a page that does not yet exist

Type a square bracket '[' and the name of the non-existent page, then select 'Insert Link to Create Page'. Example:

```
[future of the modern girl]
```

Alternatively, use **wiki markup entirely**. Type the link, including the alias and the page name or URL. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.

- This works if you have 'Autoformatting' enabled in the editor settings in your user profile.
- This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.
- **Example**: `[Future of the Modern Girl]`
<table>
<thead>
<tr>
<th>Linking to an attachment</th>
<th>Type a square bracket '[' and start typing the attachment name to see the suggested attachments to link to. Press the arrow keys to select the item you want. Example:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image" alt="Link suggestions" /> Alternatively, use <strong>wiki markup entirely</strong>. Type the link, including the alias (if required), the caret character <code>^</code> and the attachment name. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.</td>
</tr>
<tr>
<td></td>
<td>• This works if you have 'Autoformatting' enabled in the editor settings in your user profile.</td>
</tr>
<tr>
<td></td>
<td>• This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.</td>
</tr>
</tbody>
</table>
|                          | • **Example:** `[^attachment name]`
Linking to an anchor

To create the anchor: Add an anchor macro using wiki markup. Confluence will convert the macro to rich text format and add it to the page. For example, to create an anchor named 'index', type the following: `{anchor:index}`

To create the link: Use wiki markup too. Type the link, including the alias (if required), the hash character `#` and the anchor name. As soon as you type the closing square bracket, Confluence will convert the link to rich text format and add it to the page. This means that you can skip the link browser.

- This works if you have 'Autoformatting' enabled in the editor settings in your user profile.
- This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.
- Example: `[Index|#index]`

### Using lists

<table>
<thead>
<tr>
<th>Using lists</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
</table>
| Adding a bullet list | Type an asterisk `*` followed by a space. Autoformat will convert the line to a bulleted list. You can continue typing your text immediately. Example: 

```
My list:

- bullet item
```

To add another line of text to an entry without creating a new list item, press Shift + Enter at the end of the line. | Ctrl + Shift + b |
| Adding a numbered list | Type a hash or pound `#` followed by a space. Autoformat will convert the line to a numbered list. You can continue typing your text immediately. Example: 

```
My list:

1. bullet item
```

To add another line of text to an entry without creating a new list item, press Shift + Enter at the end of the line. | Ctrl + Shift + n |
### Using tables

<table>
<thead>
<tr>
<th>Using tables</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a table</td>
<td>Type a series of pipe characters `</td>
<td><code>then press **Enter**. Autoformat will convert the pipes to a table. Example — to create a table with three columns:</code></td>
</tr>
</tbody>
</table>

### Using macros

<table>
<thead>
<tr>
<th>Adding macros</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a macro to your page.</td>
<td>Type `{' and start typing the macro name to see a list of macros that match your text. Press the arrow keys to select the macro you want. Example:</td>
<td>`{</td>
</tr>
</tbody>
</table>

Alternatively, use **wiki markup entirely**. Type the macro, including its parameters and the closing curly bracket. As soon as you close the macro, Confluence will convert it to rich text format and add it to the page. This means that you can skip the macro browser.

- This works if you have 'Autoformatting' enabled in the editor settings in your user profile.
- This does not work if you paste the wiki markup onto the page. You need to enter the closing bracket manually.
- **Example:** `{blogposts:content=titles|author=jsmith}

### Displaying images and multimedia

<table>
<thead>
<tr>
<th>Displaying images</th>
<th>What to type</th>
<th>Keyboard shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display an image attached to the page</td>
<td>Type an exclamation mark '!' and start typing the image name to see the suggested images to insert onto the page. Press the arrow keys to select the item you want. Example: <img src="image-name" alt="NoMatterWhat.png" /></td>
<td><img src="image-name" alt="NoMatterWhat.png" /></td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
<td>----------------------------------</td>
</tr>
<tr>
<td>Displaying an image attached to another page</td>
<td><em>Exactly the same as when the image is attached to the same page.</em></td>
<td><img src="image-name" alt="NoMatterWhat.png" /></td>
</tr>
<tr>
<td>Embedding multimedia files</td>
<td>What to type</td>
<td>Keyboard shortcut (Windows)</td>
</tr>
</tbody>
</table>

Alternatively, use **wiki markup entirely**. Type the wiki markup for the image insertion, including the exclamation marks, the space and/or page name (if different from the current page) and the image name, as well as any other allowed parameters. As soon as you type the closing exclamation mark, Confluence will convert the image to rich text format and add it to the page. This means that you can skip the image browser.

- This works if you have ‘Autoformatting’ enabled in the editor settings in your user profile.
- This does not work if you paste the wiki markup onto the page. You need to enter the closing exclamation mark manually.
- **Example:** `!NoMatterWhat.png|align=right!`
Embedding a video, movie or audio file into a page

Type an exclamation mark '!' and select 'Insert Other Media'.

Example:

Or type '{' and start typing the macro name 'Multimedia'.

Example:

Enabling and disabling autocomplete and autoformatting

You can enable or disable the editor's autocomplete and autoformatting functions, by editing the settings in your user profile.

In summary:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Editor under 'Your Settings' in the left-hand panel.

For more details, see Editing User Settings.

Working with Text Effects

The Confluence editor supports most text effects available in standard text editing applications.

Applying paragraph styles

Choose a paragraph style from the editor toolbar, or click in the paragraph and use one of the keyboard shortcuts Ctrl+(0–8).

Screenshot: Choosing paragraph styles from the editor toolbar
Applying character formats

To apply a character format, select the text and click one of the editor toolbar buttons, or use a keyboard shortcut. Some formats are available from the 'More' menu.

Screenshot: Text formatting buttons on the editor toolbar

<table>
<thead>
<tr>
<th>Format</th>
<th>Shortcut Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bold</td>
<td>Ctrl+B</td>
</tr>
<tr>
<td><em>Italics</em></td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Underline</td>
<td>Ctrl+U</td>
</tr>
<tr>
<td>Strikethrough</td>
<td>Ctrl+Shift+S</td>
</tr>
<tr>
<td><em>Sub</em>script</td>
<td>none</td>
</tr>
<tr>
<td><em>Super</em>script</td>
<td>none</td>
</tr>
<tr>
<td>Monospace</td>
<td>none</td>
</tr>
</tbody>
</table>

Choose Clear Formatting from the 'More' menu to remove all formatting.

Applying colours to text

To apply a colour to text, select the text and choose the colour option in the editor toolbar. To see the available colours, choose the dropdown arrow next to the colour option.
Aligning text

You can align text to the left, right or centre of a content block. Select the text and click the appropriate alignment option on the editor toolbar.

Screenshot: Left, centre and right alignment options on the editor toolbar

Indenting text

You can move text to the left or right by a predefined sequence of indentations. Confluence determines the size of the indentation. Select the text and click the left or right indentation option on the editor toolbar.

Screenshot: Left and right indentation options on the editor toolbar

Working with Links

You can create links to pages, blog posts, anchors, attachments, external websites, JIRA issues and more. Links can be text or images, and can be added in many different ways.

Links to pages within your Confluence site are relative, which means that you can move pages and rename pages without breaking links.

This page explains the most common ways to create links.

Inserting a text link

To insert a link on a page:

1. Select some text or position your cursor where you want to insert the link.
2. Choose Link on the toolbar or use the keyboard shortcut Ctrl+K.
3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to particular types of content).
4. Enter or modify the link text - this is the text that will appear on the page. If this field is left blank, the page name or URL will be used as the link text.
5. Choose Insert.

Alternatively you can type [ followed by the page or attachment name. Autocomplete will suggest matching items for you.

You can also paste a URL directly onto your page. Confluence will automatically create the link, and if the URL is for a page in the current site, the page name will be set as the link text.
Inserting an image link

To link from an image:

1. Select an image on your page.
3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to particular types of content).
4. Choose Insert.

Modifying a link

To modify a link:

1. Select the link text or image.
2. Choose Edit from the link properties toolbar.
3. Modify the link and choose Save.

Removing a link

To remove a link:

1. Select the link text or image
2. Choose Unlink from the properties toolbar.

Linking to specific types of content

Confluence supports many methods for creating links. Some of the common ones are listed here.
<table>
<thead>
<tr>
<th>Type of link</th>
<th>Ways to do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link to a page</td>
<td>Choose <strong>Link</strong> &gt; <strong>Search</strong> then enter part of the page name.</td>
</tr>
<tr>
<td></td>
<td>Choose <strong>Link</strong> &gt; <strong>Recently viewed</strong> and select a page from the list.</td>
</tr>
<tr>
<td></td>
<td>Type [ ] and enter part of the page name then select the page from the list.</td>
</tr>
<tr>
<td></td>
<td>Paste the URL of the page onto your page (Confluence will automatically create the link).</td>
</tr>
<tr>
<td>Link to a page in another space</td>
<td>Choose <strong>Link</strong> &gt; <strong>Search</strong> enter part of the page name and select <strong>All Spaces</strong> from the drop down.</td>
</tr>
<tr>
<td></td>
<td>Choose <strong>Link</strong> &gt; <strong>Advanced</strong> then enter the space key followed by the page name <strong>spacekey:mypage</strong>.</td>
</tr>
<tr>
<td></td>
<td>Type [ ] and enter part of the page name then select the page from the list.</td>
</tr>
<tr>
<td></td>
<td>(you can hover over each suggestion to see which space the page is from).</td>
</tr>
<tr>
<td>Link to a blog post</td>
<td>Choose <strong>Link</strong> &gt; <strong>Search</strong> and enter part of the blog post name.</td>
</tr>
<tr>
<td></td>
<td>Type [ ] and enter part of the blog post name then select the blog post from the list.</td>
</tr>
<tr>
<td>Link to an attachment or image on this page</td>
<td>Choose <strong>Link</strong> &gt; <strong>Attachment</strong> then upload or select an attachment from the list.</td>
</tr>
<tr>
<td></td>
<td>Type [ ] and enter part of the attachment file name then select the attachment from the list.</td>
</tr>
<tr>
<td>Link to an attachment on another page</td>
<td>Choose <strong>Link</strong> &gt; <strong>Search</strong> and enter part of the attachment name.</td>
</tr>
<tr>
<td></td>
<td>Type [ ] and enter part of the attachment file name then select the attachment from the list (you can hover over each suggestion to see which space the page is from).</td>
</tr>
<tr>
<td>Link to a website</td>
<td>Choose <strong>Link</strong> &gt; <strong>Web Link</strong> then enter the website URL.</td>
</tr>
<tr>
<td></td>
<td>Type or paste the URL onto the page (Confluence will automatically create the link).</td>
</tr>
<tr>
<td>Link to an email address</td>
<td>Choose <strong>Link</strong> &gt; <strong>Web Link</strong> then enter the email address.</td>
</tr>
<tr>
<td></td>
<td>Type or paste the email address onto the page (Confluence will automatically create a ‘mailto:’ link).</td>
</tr>
</tbody>
</table>
| Link to an anchor on a page | Choose **Link > Advanced** then enter the anchor name in one of the formats below.  
For an anchor on this page: #anchor name.  
For an anchor on another page in this space: page name#anchor name.  
For an anchor on another page in another space: spacekey:page name#anchor name.  
See [Working with Anchors](#) for more information on using anchors. |
| Link to a heading on a page | Choose **Link > Advanced** then enter the heading in one of the formats below. Heading text is case sensitive and must be entered without spaces.  
For a heading on this page: #MyHeading.  
For a heading on another page in this space: Page Name#MyHeading.  
For a heading on another page in another space: spacekey:Page Name#MyHeading.  
Be aware that these links will break if you edit the heading text. Consider using the **Table of Contents** macro or an **Anchor** instead. |
| Link to a comment on a page | Go to the comment, right click the **Date** at the bottom of the comment and copy the link. Paste the link directly onto your page or choose **Link > Web Link** and paste in the URL.  
Type [($) then enter the Comment ID ('12345' in this example): [$(12345)]  
See [Managing Undefined Pages](#) for more information on undefined pages. |
| Link to an undefined page (a page that does not exist yet) | Choose **Link > Advanced** then enter the new page name (a page will be created on click).  
Type [ then enter the new page name then choose **Insert link to create page**.  
See [Managing Undefined Pages](#) for more information on undefined pages. |
| Link to a personal space or user profile | Choose **Link > Search** then enter the user's name and select their personal space homepage or their profile from the list.  
Type [ then enter the user's name and select their personal space homepage or their profile from the list. |
| Link to a JIRA issue (where Confluence is connected to JIRA) | Paste the JIRA issue URL - Confluence will automatically create a JIRA Issue macro. |

**Linking to Confluence pages from other websites**

The best way to link to a Confluence page from outside Confluence, for example on a website or in an email message, is to use the tiny link which is a permanent URL. This ensures that the link to the page is not broken if the page name changes.

To access the permanent URL for a page:

1. View the page you wish to link to.
2. Choose **Tools > Link to this page**.
3. Copy the **Tiny Link**.
4. Use the tiny link in your website or email message.

You do not need to use the tiny link to link to pages within your Confluence site. Confluence automatically updates links when you rename or move a page to another space.

If you want to link to specific content such as anchors, headings or comments you need to use the following link syntax. Note that there are no spaces in the page name, anchor name or heading text.

In the examples below, the anchor name is 'InsertLinkAnchor' and the heading text is 'Insert a link'.

<table>
<thead>
<tr>
<th>Purpose</th>
<th>Link syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link to an anchor (from an external website)</td>
<td><a href="http://myconfluence.com/display/spacekey/pagename#pagename-anchorname">http://myconfluence.com/display/spacekey/pagename#pagename-anchorname</a></td>
</tr>
<tr>
<td><strong>Example from this page:</strong></td>
<td><a href="https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLinks-InsertLinkAnchor">https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLinks-InsertLinkAnchor</a></td>
</tr>
<tr>
<td>Link to a heading (from an external website)</td>
<td><a href="http://myconfluence.com/display/spacekey/pagename#pagename-headingtext">http://myconfluence.com/display/spacekey/pagename#pagename-headingtext</a></td>
</tr>
<tr>
<td><strong>Example from this page:</strong></td>
<td><a href="https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLink">https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLink</a></td>
</tr>
<tr>
<td>Link to a comment (from an external website)</td>
<td><a href="http://myconfluence.com/display/spacekey/pagename?focusedCommentId=commentid#comment-commentid">http://myconfluence.com/display/spacekey/pagename?focusedCommentId=commentid#comment-commentid</a></td>
</tr>
<tr>
<td><strong>Example from this page:</strong></td>
<td><a href="https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803">https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803</a></td>
</tr>
</tbody>
</table>

Some things to note when linking to anchors from a website or email message:

- The page name is repeated in the URL, after the # sign. The second occurrence of the page name is concatenated into a single word, with all spaces removed.
- There is a single dash (hyphen) between the concatenated page name and the anchor name.
- The anchor name in the full URL is concatenated into a single word, with all spaces removed.
- The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as you used when creating the Anchor.

**Linking to comments**

You can add a link to a comment by using the comment URL (a permanent link), or by using wiki markup to link to the Comment ID.

To find out the comment URL and comment ID:

1. Go to the comment you wish to link to.
2. Choose the **Date** at the bottom of the comment and examine the URL.

The number after 'comment-' is the Comment ID. An example is shown here.

```
https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803
```

You can use wiki markup directly in the editor to link to a comment. Enter `$` followed by the Comment ID, for
example \([12345]\) where '12345' is the Comment ID.

Using shortcut Links

If you have configured shortcut links on your Confluence site, then you can link to an external site using a shortcut link that looks like this:CONF-17025@jira.

Our Confluence site (where this documentation is housed) is configured to allow shortcut links to our JIRA site, using the shortcut @jira. So the shortcut link CONF-17025@jira produces this link.

To add a shortcut link using the 'Insert Link' dialog:

1. Choose Link > Advanced and enter or paste the shortcut link into the Link field. Shortcut links are case-insensitive.
2. Modify or enter link text - this is the text that will appear on the page.
3. Choose Insert.

You can also type '[' and choose Insert Web Link > Advanced to enter a shortcut link.

See Configuring Shortcut Links for more details.

Trackback

Trackback enables two sites can stay informed each time one site refers to the other using trackback 'pings'.

In Confluence, Trackback can be enabled by a site administrator in the Administration Console. When Trackback is enabled, any time you link to an external webpage that supports Trackback Autodiscovery, Confluence will send a Trackback ping to that page to inform it that it has been linked to.

Confluence pages also support Trackback Autodiscovery, and when Trackback is enabled, can receive trackback pings sent by other sites.

To see who has sent a Trackback ping to a Confluence page:

1. Go to the page.
2. Choose Tools > Page Information.

Any Trackback pings the page has received will be listed under the page's Incoming Links.

Confluence incoming trackback pings only work with referenced pages that are public (anonymously viewable).

Working with Anchors

Anchors are used to enable links to a specific location on a page. Anchor links can be especially useful when navigating between sections of a long document, or when you want to link to a segment of a page instead of the top of the page.

Anchors are invisible to the reader when the page is displayed.

There are two steps to using an anchor:

1. Create an anchor on the page.
2. Create a link to the anchor.

Creating an anchor

Use the Anchor macro to mark the location you want to link to.

1. **Add the Anchor macro to a page.**
   a. In the Confluence editor, choose Insert > Other Macros.
   b. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type \{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

2. **Specify the name of your anchor.** For example, 'bottom' or 'important information'. See the 'Anchor Name' parameter described below.
On this page:
- Creating an anchor
- Creating a link to an anchor
- Notes

Related pages:
- Working with Links

Macro options (parameters)
Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anchor Name</td>
<td>None</td>
<td>This is the anchor name that you will use when creating the link.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- The anchor name can include spaces. Confluence will remove the spaces automatically when building a URL that points to this anchor.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- The anchor name is case sensitive. You must use the same pattern of upper and lower case letters when creating the link as you used when creating the Anchor macro.</td>
</tr>
</tbody>
</table>

Creating a link to an anchor
You can link to an anchor from:
- A page on the same Confluence site. The link may be on the same page as the anchor, another page in the same space, or a page in another space on the same Confluence site.
- Another web page or another Confluence site, using a specifically formatted URL.

To link to an anchor from within the same Confluence site:
1. Select some text or position your cursor where you want to insert the link.
2. Choose Link on the toolbar or press Ctrl+K.
3. Choose Advanced and enter the anchor name in the Link field following the format below.

<table>
<thead>
<tr>
<th>Anchor location</th>
<th>Link syntax for anchor</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same page</td>
<td>#anchor name</td>
<td>#bottom</td>
</tr>
<tr>
<td></td>
<td></td>
<td>#important information</td>
</tr>
<tr>
<td>Page in same space</td>
<td>page name#anchor name</td>
<td>My page#bottom</td>
</tr>
<tr>
<td></td>
<td></td>
<td>My page#important information</td>
</tr>
<tr>
<td>Page in different space</td>
<td>spacekey:page name#anchor name</td>
<td>DOC:My page#bottom</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DOC:My page#important information</td>
</tr>
</tbody>
</table>

The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as you used when creating the Anchor macro.
4. Enter or modify the Link Text - this is the text that will appear on the page. If this field is left blank, the
page name or URL will be used as the link text.

5. Choose **Insert**.

**Screenshot: The 'Advanced' option in the link dialog**

To link to an anchor from another web page or another Confluence site:

Use a full URL in the following format:

<table>
<thead>
<tr>
<th>Link syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><a href="http://myconfluence.com/display/spacekey/pagename#pagename-anchornam">http://myconfluence.com/display/spacekey/pagename#pagename-anchornam</a></td>
<td><a href="http://myconfluence.com/display/DOCS/My+page#My">http://myconfluence.com/display/DOCS/My+page#My</a> page-bottom</td>
</tr>
<tr>
<td></td>
<td><a href="http://myconfluence.com/display/DOCS/My+page#My">http://myconfluence.com/display/DOCS/My+page#My</a> page-importantinformation</td>
</tr>
</tbody>
</table>

Notes about the full URL:

- The page name is repeated in the URL, after the # sign. The second occurrence of the page name is concatenated into a single word, with all spaces removed.
- There is a single dash (hyphen) between the concatenated page name and the anchor name.
- The anchor name in the full URL is concatenated into a single word, with all spaces removed.
- The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as you used when creating the Anchor macro.

Notes

- **Table of contents on page:** Consider using the Table of Contents Macro to generate a list of links pointing to the headings on the page. The list of links will appear on the page, and will be automatically updated each time someone changes the wording of a heading.
- **Linking to headings:** You can link directly to the headings of a page. See Working with Links. However, if someone changes the wording of a heading, those direct links will be broken. Use the Anchor macro to ensure a lasting link within the body of a page.
- **Site welcome message:** If you are adding an anchor to a page that you are using in the site welcome message, you can only link to that anchor from another page. Internal links within that page will not work.
- **Templates:** When you are previewing a template, a link to an anchor is displayed as a 'broken' link. However, when you create a page using the template the resulting page will have the correct link.

**Displaying Images**

You can display an image on a Confluence page when:

- The image is attached to the page.
The image is attached to another page in the same Confluence site, even if in another space.
The image is on a remote web page.

Once the image is displayed on the page, you can:

- Move the image to a new position on the page by dragging or cut and paste.
- Change how the image appears on the page.
- Add a title and alt text for the image.
- Link from an image to another page.

Displaying an image attached to the page

There are several methods for attaching image files to a page. Once you have attached an image to a page, there are different methods for choosing where on the page the image should appear:

Using the 'Insert Image' dialog

Once an image is attached to the page, you can edit the page to choose where the image should appear.

To position an attached image on the page:

1. While editing the page, position the cursor where you want to place the image.
2. Choose Insert > Image and choose the Attached Images tab.
3. Select the required image and choose Insert (or just double-click the image).

Using autocomplete

Once an image is attached to the page, you can use autocomplete while editing the page to choose where the image should appear.

To position an attached image on the page:

1. While editing the page, position the cursor where you want to place the image.
2. Trigger the autocomplete function by typing '!'.
3. Choose the image from the list that appears.

Using drag-and-drop

Depending on the browser you are using, you can attach and position an image in one step. While you are editing a page, simply drag-and-drop an image file on to the page. The image is attached to the page and is placed at the current cursor position.

Displaying an image attached to a different page

You can display an image that is attached to a different page of the same Confluence site, as long as you know the name of the image. This approach can make it easier to manage and reuse your images by allowing you to keep them all in the same place.

To display an image attached to a different page:
1. While editing the page, position the cursor where you want to place the image.
2. Choose Insert > Image and choose the Search tab.
3. Enter the name of the image.
4. Choose whether to search the current space or All Spaces and choose Search.
5. Select the required image from the search results and choose Insert.

Alternatively, you can cut and paste the image from another page (the image will still only be attached to the original page).

Displaying an image from a remote web page

You can display an image from a remote web page on your Confluence page, without needing to attach it to your page. You need to know the URL for the image, not for the web page it appears on. Note that you should have permission to use that image on your page.

To display an image located on a web page:

1. While editing the page, position the cursor where you want to place the image.
2. Choose Insert > Image and choose From the Web.
4. Choose Preview to check that the URL and image are correct.
5. Choose Insert.

Alternatively, you can simply cut and paste the image from a web page.

Controlling the image appearance

When editing the page, select the image to show the image properties panel. The panel allows you to set the display size, add a border and effects and link the image to other pages.

To set the size of the image, do one of the following:

- Choose one of the size 'preset' buttons (the image width in pixels is displayed to the left).
- Choose the image size text and enter a new image width in pixels (you can specify a size between 16px and 900px).

Images are displayed as thumbnails.

To add a border to the image:

- Choose Border in the image properties panel.

To add a hyperlink to the image:

- Choose Link in the image properties panel.

To align an image:

- Select the image and choose the paragraph alignment buttons on the editor toolbar.
- If you choose the left or right alignment, the text will wrap around the image. The text does not wrap for centre alignment.

To add effects to an image:

- Choose Properties > Effects in the image properties panel.
- Select an effect and choose Save.

Note: The Instant Camera effect only works with Latin character languages, due to a lack of handwriting style fonts in multi-byte languages.

To add a caption to an image:

- Choose Effects in the image properties panel and choose the Instant Camera image effect.
- Save the page.
- Choose Tools > Attachments to go to the 'Attachments' view of the page.
- Choose Properties next to the image file.
- Add a comment to the attachment. The text in your comment will appear as the image caption.
You will need to re-enter the comment each time you upload a new version of the image.

Screenshot: The image properties panel beneath an image

Screenshot: Examples of image border effects

Setting other image attributes
You can add a title and alt text to your image in the image properties panel. The image title displays when the user hovers over the image or views the full size image. The alt text is used by screen readers and when the image cannot be shown.

**To add a title and alt text:**

- Choose Properties > Title in the image properties panel.
- Enter a title and alt text and choose Save.

Other attributes can also be set by using the Insert > Wiki Markup function from the editor toolbar, then using the syntax described in Confluence Wiki Markup.

Displaying a gallery of images

See the Gallery Macro.

Image file formats

You can attach image files of any format to a page. Confluence supports the following image formats in the Gallery macro and when displaying an image on a page:

- gif
- jpeg
- png
- bmp (depending on browser support)

Deleting an Image

This page describes how to remove an image from a page. You may want to remove the image from the content of the page, but leave the image available in Confluence. Or you may want to remove the image from Confluence entirely.

**Removing an image from the content of a page**

A Confluence page can display one or more images, as described in Displaying Images.

**To remove an image from the content of a page:**

1. Edit the page.
2. Select the image. The image properties panel will appear, letting you know that the image is selected.
3. Press the Delete key on your keyboard.
4. Save the page.

The image will no longer appear as part of the page content. If the image file was originally uploaded as an attachment on the current page or another page, the image is still available in Confluence. If you want to remove the attachment, follow the steps below.

**Removing an image attachment from Confluence**

To remove an image file from Confluence, you must remove the attachment. See Deleting an Attachment.

**Note:** A page can display an image that is attached to another page. If you remove an image that is used on a page, readers will see an error message on that page.

**Example error message that appears when image attachment is removed:**

[Unknown Attachment]

**Related pages:**

- Displaying Images
- Working with Attachments
- Confluence User's Guide

**Working with Tables**

Confluence pages can include multi-row and multi-column tables. You can highlight cells, rows and columns in different colours. When viewing the page, people can sort the table by clicking the column headers.
Inserting a table

To create a table:

1. While editing the page, place your cursor at the point where you want to insert the table.
2. Choose Table on the toolbar.
3. A dropdown menu will appear, showing a table with a variable number of rows and columns. Click in a cell to set the number of columns and rows for your table.
4. Add content and more rows and columns as needed. See below for guidelines on what you can do with your table in the editor.

Screenshot: Inserting a table with 3 rows and 3 columns

On this page:
- Inserting a table
- What you can do with your table in the editor
- Shortcut keys
- Sorting the table in view mode

Related pages:
- Working with Page Layouts and Columns and Sections
- Using the Editor
- Confluence User’s Guide

What you can do with your table in the editor

While editing a page, place your cursor inside a table to see the table toolbar.

Using the table toolbar you can:

- Insert an empty row above the current one.
- Insert an empty row below the current one.
- Remove the current row.
- Cut the current row and copy it to the clipboard.
- Copy the current row to the clipboard.
- Paste the row from the clipboard to the current row.
- Insert an empty column to the left of the current one.
- Insert an empty column to the right of the current one.
- Remove the current column.
- Merge the selected cells.
- Split the selected merged cells.
- Mark a row as a table header. The cells in the row will be highlighted in grey and the text will be bold.
- Mark a column as a table header. The cells in the column will be highlighted in grey and the text will be bold.
- Highlight cells with a background colour.
• Remove the table.

Shortcut keys

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+c</td>
<td>Copy the current table row, or the selected rows.</td>
<td>Cmd+Shift+c</td>
</tr>
<tr>
<td>Ctrl+Shift+i</td>
<td>Insert a table. (Opens the Insert Table dialog.)</td>
<td>Cmd+Shift+i</td>
</tr>
<tr>
<td>Ctrl+Shift+v</td>
<td>Paste the table rows from your clipboard, placing them above the current row.</td>
<td>Cmd+Shift+v</td>
</tr>
<tr>
<td>Ctrl+Shift+x</td>
<td>Cut the current table row, or the selected rows.</td>
<td>Cmd+Shift+x</td>
</tr>
<tr>
<td>Alt+Up Arrow</td>
<td>Add a row above the current row.</td>
<td>Alt+Up Arrow</td>
</tr>
<tr>
<td>Alt+Down Arrow</td>
<td>Add a row below the current row.</td>
<td>Alt+Down Arrow</td>
</tr>
</tbody>
</table>

For more editor keyboard shortcuts, see [Keyboard Shortcuts](#).

Sorting the table in view mode

When readers view a table on a page, they can sort the table by clicking the sort icons in the header row.

*Screenshot: A colourful, sortable table*

Using Symbols, Emoticons and Special Characters

You can add various symbols and special characters to Confluence pages. You can also use them in other places that display content, such as blog posts, comments, the dashboard welcome message and the configuration panels offered by the Documentation theme.

Inserting symbols and special characters

To add a symbol to your page:

1. Edit the page.
2. Choose **Insert > Symbol**. This will display the 'Insert Custom Character’ window.
3. Choose a symbol to insert it.

*On this page:*
  * Inserting symbols and special characters
  * Inserting emoticons
  * Preventing emoticons from appearing

*Related pages:*
  * Quick Reference Guide for the Confluence Editor
  * Confluence Wiki Markup
  * Confluence User’s Guide

*Screenshot: Available symbols*
Inserting emoticons

There are two ways to add an emoticon, or smiley, to your page.

By choosing an emoticon from those available:

1. Choose Insert > Emoticon.
2. Choose an emoticon to insert it.

By typing a character combination:
You can insert emoticons by typing commonly-used character combinations. For example, the following code appears as an emoticon when the page is rendered.

`;)

The above example creates this emoticon: 😊

This table shows the emoticons (and other icons) available in Confluence, and the character combinations that create them:

<table>
<thead>
<tr>
<th>Image</th>
<th>Notation</th>
</tr>
</thead>
<tbody>
<tr>
<td>:)</td>
<td>:( :P :D</td>
</tr>
</tbody>
</table>

Preventing emoticons from appearing

To undo the conversion of a character combination into an emoticon, press Ctrl+Z (Windows) or Cmd+Z (Mac).
To prevent Confluence from converting text to emoticons automatically, disable ‘Autoformatting’ in your user profile. See Editing User Settings.

The Confluence knowledge base has an article on disabling emoticons for the Confluence site as a whole.

Using Autocomplete

When using the Confluence editor, you can type a trigger character or press a keyboard shortcut to see a list of suggested links, files or macros to add to your page, or to mention another user (and automatically notify them of this).

Summary of autocomplete

<table>
<thead>
<tr>
<th>What you want to do</th>
<th>Trigger character</th>
<th>Keyboard shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a link on your page</td>
<td>[</td>
<td>Ctrl+Shift+K</td>
<td>See a list of suggested pages or other locations to link to from your page. More...</td>
</tr>
<tr>
<td>Display an image, video, audio file or document on your page</td>
<td>!</td>
<td>Ctrl+Shift+M</td>
<td>See a list of suggested images, multimedia files and documents to embed in your page. More...</td>
</tr>
<tr>
<td>Add a macro on your page</td>
<td>{</td>
<td>None</td>
<td>See a list of suggestions as you begin typing a macro name. More...</td>
</tr>
<tr>
<td>Notify another user by email that you have mentioned them on your page</td>
<td>@</td>
<td>None</td>
<td>See a list of suggested users to mention. More...</td>
</tr>
</tbody>
</table>

Using autocomplete for links

Type ‘[’, or press Ctrl+Shift+K, to see a list of suggested pages or other locations to link to from your page. You can link to pages, user profiles, images, documents and other file attachments.

To autocomplete a link:

1. Edit the page.
2. Click where you want to insert a link and do one of the following:
   - Type '[' and then the first few characters of the page title, user's name, image name or file name.
   - Type the first few characters of the page title, user's name, image name or file name (or select relevant text) and then press Ctrl+Shift+K.
3. Click the relevant link from the list of suggestions.

If the item you need is not in the list, either:
   - Choose Search for 'xxx' to continue looking for the page within Confluence, or
   - Choose Insert Web Link to insert a link to an external web page using the link browser.

Screenshot: Autocomplete for a link

Using autocomplete for images, videos, audio files and documents

You can use the autocomplete as a fast way of embedding images, videos, audio files and documents into your page. Type an exclamation mark or press Ctrl+Shift+M to see a list of suggested images, multimedia files and documents to display on your page. You can use autocomplete to embed the following file types:

- Images – any format that Confluence supports. See Displaying Images.
- Videos, audio files and all multimedia formats that Confluence supports. See Embedding Multimedia Content.
- Office documents supported by the Confluence Office Connector: Word, Excel and PowerPoint.
- PDF files.

Autocomplete works most efficiently for files that are already attached to the Confluence page. See Attaching Files to a Page.

To embed an image, video, audio file or document:

1. Edit the page.
2. Click where you want to insert the image, video, audio file or document and do one of the following:
   - Type '!' and then the first few characters of the image, file or document name.
   - Type the first few characters of the name of the image, file or document (or select relevant text) and then press Ctrl+Shift+M.
3. Choose the relevant file from the list of suggestions.

If the item you need is not in the list, either:

- Choose Open Image Browser to find images and documents using the image browser, or
- Choose Insert Other Media to embed videos, audio and other multimedia files using the macro browser. Insert the 'Multimedia' macro to display your multimedia file.

Screenshot: Autocomplete for an image or document
Using autocomplete for macros

Type '{' to see a list of suggested macros to add to your page.

Autocomplete provides access to all available macros in your Confluence site, including any user macros that your administrator has added and made visible to all.

ℹ️ You need to know the name of macro. Autocomplete for macros will only match the name of the macro, not the description.

To autocomplete a macro using '{':

1. Edit the page.
2. Click where you want to insert the macro.
3. Type '{' and then the first few characters of the macro name.
4. Choose the relevant macro from the list of suggestions.
5. Configure the macro by completing the form fields as prompted.

If the macro you need is not in the list, choose Open Macro Browser in the list of suggestions to continue looking for the macro in the macro browser. See Working with Macros.

Screenshot: Autocomplete for a macro

Using autocomplete for mentions

You can use autocomplete to automatically notify another Confluence user that you have mentioned them in a page, blog post, or comment. Type '@' and part of the person's name, to see a list of suggested users.

⚠️ Note: Use the person's full name. Autocomplete will recognise users' full names only, not their usernames.
To mention someone using '@':

1. In the editor, type '@' then the first few characters of the person's name or username.
2. Choose the user's name from the list of suggestions.

Screenshot: Autocomplete for mentions

Cancelling autocomplete

The autocomplete starts automatically when you press the trigger characters. You may want to close the autocomplete menu or escape from autocomplete once it has started.

There are a few different ways to stop the autocomplete once it has started:

- Press the escape key, 'Esc', on your keyboard.
- Click somewhere else in the editor panel.
- Press an arrow key to move out of the autocomplete area.
- For the link autocomplete only: enter a right-hand square bracket, like this: ]

Enabling and disabling autocomplete

You can turn off the triggering of autocomplete by the '[' and ']' characters. This will prevent the autocomplete from starting automatically when you press one of the trigger characters. You can also turn it back on again.

Notes:

- This setting does not affect the keyboard shortcuts for autocomplete (Ctrl+Shift+K and Ctrl+Shift+M). Even if the trigger characters are disabled, you can still use the keyboard shortcuts for autocomplete.
- This setting affects only you. Other people using Confluence can enable or disable the setting on their user profiles independently.
- Note that autocomplete is enabled by default.

To enable or disable the autocomplete trigger characters:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Editor under 'Your Settings' in the left-hand panel.
3. Choose Edit.
4. Either:
   - Disable autocompletion by selecting Disable Autocomplete.
   - Enable autocompletion by clearing Disable Autocomplete.
5. Choose Submit.

Screenshot: User settings for the editor
Ignoring autocomplete

You can add macros, links and images by wiki markup alone. Type the macro, including its parameters and the closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket. Insert an image or other embedded object, enclosed between exclamation marks. As soon as you close the macro, link, or embedded image, Confluence will convert it to rich text format and add it to the page.

More information about mouse-free macros, links and images:

- Quick Reference Guide for the Confluence Editor
- Video

Working with Page Layouts and Columns and Sections

There are two ways to modify the layout of a Confluence page. You can:

- use Page Layouts to add sections and columns, or
- use macros to add sections and columns.

Page layouts provides a simple, visual representation of your page layout in the editor, while the macros are more flexible and allow for greater complexity in your layout.

Using page layouts

The Page Layouts tool allows you to structure your page using horizontal sections and vertical columns. By adding multiple sections with different column configurations you can build quite complex layouts very easily.

On this page:

- Using page layouts
- Using the Section and Column macros

Screenshot: Editor view of a page showing three sections with different column configurations.
Start by adding a horizontal section to your page.

**To add a section:**

1. Choose the Page Layout button on the editor toolbar.
2. The Page Layout toolbar appears. Choose Add Section.

The new section appears below your current content. The boundaries of the section are indicated by dotted lines. These are not visible when you view the page.

**To change the column layout in a section:**

1. Place your cursor in the section you wish to change.
2. Choose a layout from the Page Layout toolbar (for example two column, three column).

Any text, images or macros in your section are not lost when you change the column layout. When you decrease the number of columns, Confluence will move your content to the left. When you increase the number of columns, Confluence will add blank columns to the right of your existing content.

**To move a section to another part of the page:**

1. Place your cursor in the section you wish to move.
2. Choose the Move up or Move down buttons.

The section and all of its content will be moved above or below other sections on the page.

**To delete a section:**

1. Place your cursor in the section you wish to remove.
2. Choose Remove section.

The section and all of its content will be removed.

**Notes about Page Layouts**

- **Column width** - The width of the columns are fixed. If you need more than three columns, or columns of a specific width, you should use the Section and Column macros described below.
- **Very wide tables.** The width of each column is set to a percentage of the page width. The icons in the drop down menu indicate the relative widths for each layout. In most cases, Confluence will adapt the width of the columns to fit the width of the page. If a column includes a large table, the content may not fit into the width of the page. You will see a horizontal scroll bar when viewing the page.

**Using the Section and Column macros**

You can use the Section and Column macros to add a set of columns to the page. The Section macro defines an area that will contain the columns. You can have as many sections as you like. Within each section, you can have as many columns as you like.

The Section and Column macros are useful if you want to define a specific percentage or pixel width for each column.

**To add a section and some columns to a page:**
1. In the Confluence editor, choose Insert > Other Macros.
2. Find the Section macro, select it and insert it onto the page.
3. Choose Insert > Other Macros again.
4. Find and insert the Column macro.
5. Add your content to the column.
6. Insert as many columns as you like within the section.

Screenshot: A section and two columns in the editor

When you see the page in view mode, the above layout is displayed like this:
Content for column 1 goes here
Content for column 2 goes here

Macro parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Parameters of the Section macro

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Border</td>
<td>false</td>
<td>Select this option to draw a border around the section and columns. Note: Without a Column macro, the border will not be displayed correctly.</td>
</tr>
</tbody>
</table>

Parameters of the Column macro

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Width</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>Specify the width of the column, in pixels (for example, 400px) or as a percentage of the available width (for example, 50%).</td>
</tr>
</tbody>
</table>

Notes about sections and columns

- All content within your section must be enclosed within a Column macro, otherwise the section layout will
not work as expected.
• You can put tables inside columns.

Working with Macros
Using a macro, you can add extra functionality or include dynamic content on a page. For example, the Attachments macro will list a page's attachments in the page itself, so that readers do not have to visit the Attachments tab.

Adding a Macro to your Page

Including Macros with the Macro Browser

To add a macro to a page:
1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Macro Parameters
Many macros allow you to include optional parameters to control the macro's output.

With the Attachments Macro, for instance, you have two optional parameters allowing you to:
• Specify the file formats of the attachments displayed.
• Choose whether or not you want old versions of the attachments displayed.

Macro Placeholders
Macro placeholders are displayed in the editor where you have added a macro to the page.

When editing a page, you can:
• Double-click a macro placeholder (or click the placeholder and choose Edit) to open the macro dialog window, where you can edit the macro's parameters.
• Select a macro placeholder to cut, copy and paste the macro.

On this page:
• Adding a Macro to your Page
• Macros Shipped with your Confluence Installation
• Information about Other Macros
• Writing your own Macros

Macros Shipped with your Confluence Installation
When you download your Confluence installation file, many macros are shipped with the download. Below is a list of the macros currently shipped with Confluence. Click a macro name for details of the usage, including optional parameters and examples.
• Activity Stream Macro
• Anchor Macro
• Attachments Macro
• Blog Posts Macro
• Change-History Macro
• Chart Macro
• Cheese Macro
• Children Display Macro
• Code Block Macro
• Column Macro
• Content by Label Macro
- Content by User Macro
- Content Report Table Macro
- Contributors Macro
- Contributors Summary Macro
- Create from Template Macro
- Create Space Button Macro
- Excerpt Include Macro
- Excerpt Macro
- Expand Macro
- Favourite Pages Macro
- Gadget Macro
- Gallery Macro
- Global Reports Macro
- HTML Include Macro
- HTML Macro
- IM Presence Macro
- Include Page Macro
- Info Macro
- JIRA Chart Macro
- JIRA Issues Macro
- JUnit Report Macro
- Labels List Macro
- Livesearch Macro
- Loremipsum Macro
- Multimedia Macro
- Navigation Map Macro
- Network Macro
- Noformat Macro
- Note Macro
- Office Excel Macro
- Office PowerPoint Macro
- Office Word Macro
- Page Index Macro
- Page Properties Macro
- Page Properties Report Macro
- Page Tree Macro
- Page Tree Search Macro
- Panel Macro
- PDF Macro
- Popular Labels Macro
- Profile Picture Macro
- Recently Updated Dashboard Macro
- Recently Updated Macro
- Recently Used Labels Macro
- Related Labels Macro
- RSS Feed Macro
- Search Results Macro
- Section Macro
- Space Attachments Macro
- Space Details Macro
- Space Jump Macro
- Spaces List Macro
- Status Macro
- Table of Contents Macro
- Table of Content Zone Macro
- Task Report Macro
- Tip Macro
- User List Macro
- User Profile Macro
- User Status List Macro
- View File Macro
- Warning Macro
• **Widget Connector Macro**

**Information about Other Macros**

Other macros are available as plugins or as user macros, and can be installed by your Confluence administrator. For example, macros that may be of interest are available from Adaptavist, CustomWare and the Confluence SharePoint Connector.

**Writing your own Macros**

To learn how to write your own macro, take a look at the following documentation:

- User macros are simple template-like macros that allow you to create simple formatting macros using the Confluence web interface. Read more about **Writing User Macros**.
- The **Confluence Plugin Guide** tells you how to develop a plugin for Confluence.

**Activity Stream Macro**

The Activity Stream macro is a specific instance of the Gadget macro. It inserts an Activity Stream gadget onto your page. For instructions, see **Activity Stream Gadget**.

**Related pages:**
- Activity Stream Gadget
- Gadget Macro
- Confluence User's Guide

**Anchor Macro**

Allows you to link to a specific part of a page. For more information on using anchors see **Working with Anchors**.

**Code Examples**

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** anchor

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="anchor">
  <ac:parameter ac:name=""/>here</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
(anchor:here)
```

**Attachments Macro**

Displays a list of attachments on a given page. For more information see **Displaying a List of Attachments**.

**Code examples**

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** attachments

**Macro body:** None.
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| old | No | false | Available values:  
- **false** - Displays only the latest version of each attachment.  
- **true** – Displays all versions of each attachment, including the old versions. |
| patterns | No | (None) | A comma-separated list of regular expressions, used to filter the attachments by file name. Note that the parameter values must be regular expressions. For example:  
- To match a file suffix of 'jpg', use .*jpg (not *.jpg).  
- To match file names ending in 'jpg' or 'png', use .*jpg,.*png. |
| sortBy | No | date | Available values:  
- date  
- size  
- name  
- createdate |
| page | No | The page on which the macro exists. | Page name, used to display attachments from another page. |
| sortOrder | No | The default sort order is determined by the sortBy type:  
- Reverse chronological for 'date'.  
- Largest to smallest for 'size'.  
- Alphabetical for 'name'. | Available values:  
- ascending  
- descending |
| labels | No | (None) | A comma-separated list of labels. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.) |
| upload | No | false | Determines whether the list of attachments will include options allowing users to browse for, and attach, new files. |
Blog Posts Macro

The Blog Posts macro allows you to display blog posts on a Confluence page. Clicking on a title takes you to the blog post.

Using the Blog Posts Macro

To add the Blog Posts macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>preview</td>
<td>No</td>
<td>true</td>
<td>Determines whether a preview of the attached file appears when the item is expanded.</td>
</tr>
</tbody>
</table>

Storage format example

```
<ac:structured-macro ac:name="attachments">
  <ac:parameter ac:name="old">false</ac:parameter>
  <ac:parameter ac:name="patterns">.*png,.*jpg</ac:parameter>
  <ac:parameter ac:name="sortBy">name</ac:parameter>
  <ac:parameter ac:name="page">
    <ac:link>
      <ri:page ri:content-title="My page about chocolate"/>
    </ac:link>
  </ac:parameter>
  <ac:parameter ac:name="sortOrder">descending</ac:parameter>
  <ac:parameter ac:name="labels">chocolate,cookies</ac:parameter>
  <ac:parameter ac:name="upload">false</ac:parameter>
</ac:structured-macro>
```

Wiki markup example

```
{attachments:old=false|patterns=.*png,.*jpg|sortby=name|page=My page about chocolate|sortorder=descending|labels=chocolate,cookies|upload=false|preview=false}
```
<table>
<thead>
<tr>
<th>Content Type to Display (content)</th>
<th>No</th>
<th>titles</th>
<th>Available values:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>titles</strong> — Display only the title of each blog post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>excerpts</strong> — Display a short excerpt from each blog post. If the post contains an Excerpt macro, the Blog Posts macro will display the content defined in the Excerpt macro. If the post does not contain an Excerpt macro, the Blog Posts macro will display the first few sentences of the post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>entire</strong> - Display the whole content of each blog post.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Time Frame (time)</th>
<th>No</th>
<th>no limit</th>
<th>Specify how far back in time Confluence should look for the blog posts to be displayed.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>m</strong> — Minutes</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>h</strong> — Hours, so '12h' displays blog posts created in the last twelve hours.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>d</strong> — Days, so '7d' displays blog posts created in the last seven days.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>W</strong> — Weeks</td>
</tr>
</tbody>
</table>
| **Restrict to these Labels** *(label)* | No | None | Filter the results by label. The macro will display only the blog posts which are tagged with the label(s) you specify here. You can specify one or more label values, separated by a comma or a space.  
- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labelled with 'badpage'.  
- To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage, +goodpage you will get only content which has at least two labels, being 'superpage' and 'goodpage'. |
| **Restrict to these Authors** *(author)* | No | None | Filter the results by author. The macro will display only the blog posts which are written by the author(s) you specify here. You can specify one or more authors, separated by a comma. For example: jsmith, jbrown  
To include content from one user, but exclude from another user: jsmith,!jbrown |
| **Restrict to these Spaces** *(spaces)* | No | @self, i.e. the space which contains the page on which the macro is coded |
This parameter allows you to filter content by space. The macro will display only the pages which belong to the space(s) you specify here.

You can specify one or more space keys, separated by a comma or a space.

- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.
- To indicate that the results **must** come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:
When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.

<table>
<thead>
<tr>
<th>Maximum Number of Blog Posts (max)</th>
<th>No</th>
<th>15</th>
<th>Specify the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort By (sort)</td>
<td>No</td>
<td>creation</td>
<td>Specify how the results should be sorted. If this parameter is not specified, the sort order defaults to descending order (newest first) based on the creation date.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><strong>Values:</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• title — Sort alphabetically by title.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• creation — Sort by the date on which the content was added.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• modified — Sort by the date on which the content was last updated.</td>
</tr>
</tbody>
</table>
Reverse Sort (reverse)

No

false

Select to change the sort from descending to ascending order (oldest first). Use this parameter in conjunction with the **Sort By** parameter. This parameter is ignored if the **Sort By** parameter is not specified.

In storage format and wikimarkup a value of **true** changes the sort order.

### Code examples

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** blog-posts

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="blog-posts">
  <ac:parameter ac:name="content">titles</ac:parameter>
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="ds"/>
  </ac:parameter>
  <ac:parameter ac:name="author">
    <ri:user ri:userkey="12345678912345678912345678912345"/>
  </ac:parameter>
  <ac:parameter ac:name="time">4w</ac:parameter>
  <ac:parameter ac:name="sort">creation</ac:parameter>
  <ac:parameter ac:name="max">10</ac:parameter>
  <ac:parameter ac:name="labels">chocolate,cookies</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```wiki
{blog-posts:content=titles|spaces=@self,ds|author=jsmith|time=4w|reverse=true|sort=creation|max=10|label=chocolate,cookies}
```

**Change-History Macro**

The Change-History macro shows the history of updates made to a page: version number, author, date and comment. It displays the information inline.

**Screenshot: The Change-History macro in Confluence**
To add the Change-History macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Note:** There are no parameters for this macro.

**Code examples**

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** change-history

**Macro body:** None.

**Parameters:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="change-history"/>
```

**Wiki markup example**

```
{change-history}
```

**Chart Macro**

The Chart macro allows you to display a chart based on tabular data. When you add the macro to a page, you:

- supply the data to be charted by the macro as a table in the placeholder of the macro.
- edit the macro parameters in the Macro Browser to configure the format of the chart.

**Screenshot 1:** A table of data in the Chart macro placeholder
<table>
<thead>
<tr>
<th>Weeks</th>
<th>Issues Burndown</th>
</tr>
</thead>
<tbody>
<tr>
<td>04/07/2011</td>
<td>81</td>
</tr>
<tr>
<td>11/07/2011</td>
<td>68</td>
</tr>
<tr>
<td>18/07/2011</td>
<td>67</td>
</tr>
<tr>
<td>25/07/2011</td>
<td>66</td>
</tr>
<tr>
<td>01/08/2011</td>
<td>65</td>
</tr>
<tr>
<td>08/08/2011</td>
<td>65</td>
</tr>
<tr>
<td>15/08/2011</td>
<td>64</td>
</tr>
<tr>
<td>22/08/2011</td>
<td>44</td>
</tr>
<tr>
<td>29/08/2011</td>
<td>24</td>
</tr>
<tr>
<td>05/09/2011</td>
<td>0</td>
</tr>
</tbody>
</table>

**Screenshot 2: The resulting chart**

![Chart showing issues burndown over time](image)
On this page:

- Using the Chart Macro
- Parameters
- Examples
  - Pie Chart
  - Bar Chart
  - 3D Bar Chart
  - Time Series Chart
  - XY Line Chart
  - XY Area Chart
  - Area Charts
  - Gantt Chart
- Code examples
  - Chart type parameters
  - Chart display parameters
  - Chart title and label parameters
  - Chart data parameters
  - Chart colour parameters
  - Chart axis parameters
  - Pie chart Parameters
  - Chart attachment parameters
  - Wiki markup example

Using the Chart Macro

To add the Chart macro to a page:

1. Edit the page and use autocomplete to add the Chart macro. (Type `{chart}`.)
2. Enter your chart data as one or more tables in the body of the macro placeholder. (See the screenshot above.)
3. Click the macro placeholder and choose Edit.
4. Select a chart type using the Type parameter (see below).
5. Choose other parameter settings in the macro browser, as described below.
6. Click Refresh in the 'Preview' area, to check that the chart appears as you expect.
7. Click Save to add the chart to your page.
8. Click Save again when you are ready to save the page.

Parameters

Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification Parameters | Colour Parameters | Axis Parameters | Pie Chart Parameters | Attachment Parameters

Chart Type Parameters

These parameters determine the type of chart to display and the way the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Type      | pie     | The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based (see the Time Series parameter). Standard — pie, bar, line, area

*XY Plots* — xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries

*Other* — gantt
### Display Control Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td>Height</td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
</tbody>
</table>
| Display rendered data      | false   | Sets whether to display the rendered body of the macro (usually the data tables). By default, the chart data table isn't rendered.  
  - **before** — the data are displayed before the chart.  
  - **after** — the data are displayed after the chart. |
| Image format               | png     | The image format to be used for the chart.  
  - png  
  - jpg |

### Title and Label Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart Title</td>
<td>none</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>Chart Subtitle</td>
<td>none</td>
<td>A subtitle for the chart, using a smaller font than for Title.</td>
</tr>
<tr>
<td>Horizontal-axis Label</td>
<td>none</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>Vertical-axis Label</td>
<td>none</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Show a legend or key.</td>
</tr>
</tbody>
</table>

### Data Specification Parameters

The data for the chart is taken from tables found when the macro body is rendered. These options control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. Additional conversion options can be specified using the parameters below.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables</td>
<td>all first level tables</td>
<td>Comma separated list of table ids and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
</tr>
<tr>
<td>Columns</td>
<td>all columns</td>
<td>Comma separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the (html) title attribute for the column in the header row.</td>
</tr>
</tbody>
</table>
| Content Orientation | horizontal          | • vertical — data table columns will be interpreted as series.  
• horizontal — data tables rows will be interpreted as series. |
<p>| Time Series   | false                    | • true — the x values in an XY plot will be treated as time series data and so will be converted according to date formats. |
| Date format   | Confluence language defined date formats | For time series data, the date format allows for additional customization of the conversion of data to date values. If a Date format is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See simple date format. |
| Time Period   | Day                      | The time period for time series data. Defines the granularity of how the data is interpreted. Valid values are: Millisecond, Second, Minute, Hour, Day, Week, Month, Quarter, Year. |
| Language      | none                     | Use in combination with the Country parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages. Valid values are 2 character ISO 639-1 alpha-2 codes. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Country</td>
<td>none</td>
<td>Use in combination with the <strong>Language</strong> parameter to form a locale. Valid values are 2 character ISO 3166 codes.</td>
</tr>
</tbody>
</table>
| Forgive         | true        | • true — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.  
• false — enforce strict data format. Data format errors will cause the chart to not be produced. |

**Colour Parameters**

Colours are specified using hexadecimal notation or HTML colour names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background Colour</td>
<td>White</td>
<td>Background of the chart.</td>
</tr>
<tr>
<td>Border Colour</td>
<td>no border</td>
<td>Border around the chart.</td>
</tr>
<tr>
<td>Colours</td>
<td>Comma-separated list of colours used to customise category, sections, and series colours.</td>
<td></td>
</tr>
</tbody>
</table>

**Axis Parameters**

Depending on the chart type, the range and domain axis may be customised. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range Minimum Value</td>
<td>none</td>
<td>Range axis lower bound.</td>
</tr>
<tr>
<td>Range Maximum Value</td>
<td>none</td>
<td>Range axis upper bound.</td>
</tr>
<tr>
<td>Range Axis Tick Unit</td>
<td>none</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>Range Axis Label Angle</td>
<td>none</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>Domain Axis Lower Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the <strong>Date format</strong> parameter.</td>
</tr>
<tr>
<td>Domain Axis Upper Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the <strong>Date format</strong> parameter.</td>
</tr>
</tbody>
</table>
### Domain Axis Tick Unit

| None |

Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the **Time Period** parameter. The **Time Period** unit can be overridden by specifying a trailing character: y (years), M (months), d (days), h (hours), m (minutes), s (seconds), u (milliseconds).

### Domain Axis Label Angle

| None |

Only applies to XY plots. The angle for the domain axis label, in degrees.

### Category Label Position

| None |

Placement of the axis label text for categories.
- **up45** — 45 degrees going upward
- **up90** — 90 degrees going upward
- **down45** — 45 degrees going downward
- **down90** — 90 degrees going downward

### Date Tick Mark Position

| Start |

Placement of the date tick mark.
- **start** — tick mark is at the start of the date period.
- **middle** — tick mark is in the middle of the date period.
- **end** — tick mark is at the end of the date period.

### Pie Chart Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Pie Section Label | Show only the pie section key value | Format for how pie section labels are displayed. The format uses a string with special replacement variables:  
- `%0%` is replaced by the pie section key.  
- `%1%` is replaced by the pie section numeric value.  
- `%2%` is replaced by the pie section percent value.  

Example 1: "%0% = %1%" would display something like "Independent = 20"  
Example 2: "%0% (%2%)" would display something like "Independent (20%)" |
### Pie Section Explode

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pie Section Explode</td>
<td>No exploded sections</td>
<td>Comma separated list of pie keys that are to be shown exploded. Note: requires jFreeChart version 1.0.3 or higher.</td>
</tr>
</tbody>
</table>

### Attachment Parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is displayed. These options allow for the generated image to be saved as an attachment and have subsequent access re-use the attachment. This can be useful especially when combined with the Cache Plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachment</td>
<td>none</td>
<td>The name and location with which the chart image will be saved as an attachment. The user must be authorised to add attachments to the page specified.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• ^attachmentName.png — the chart is saved as an attachment to the current page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• page^attachmentName.png — the chart is saved as an attachment to the page name provided.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• space:page^attachmentName.png — the chart is saved as an attachment to the page name provided in the space indicated.</td>
</tr>
<tr>
<td>Attachment Version</td>
<td>new</td>
<td>Defines the versioning mechanism for saved charts.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• new — creates new version of the attachment.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• replace — replaces all previous versions of the chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To replace an existing attachment, the user must be authorized to remove attachments for the page specified.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• keep — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated.</td>
</tr>
<tr>
<td>Attachment Comment</td>
<td>none</td>
<td>Comment used for a saved chart attachment.</td>
</tr>
<tr>
<td>Thumbnail</td>
<td>false</td>
<td>• true — the chart image attachment will be shown as a thumbnail.</td>
</tr>
</tbody>
</table>
### Examples

#### Pie Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>pie</td>
<td>Fish Type</td>
</tr>
<tr>
<td>Chart Title</td>
<td>Fish Sold 2011</td>
<td>Herring</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Salmon</td>
</tr>
<tr>
<td>Content Orientation</td>
<td>vertical</td>
<td>Tuna</td>
</tr>
</tbody>
</table>

#### Bar Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>bar</td>
<td>Fish Type</td>
</tr>
<tr>
<td>Chart Title</td>
<td>Fish Sold</td>
<td>Herring</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Salmon</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Tuna</td>
</tr>
</tbody>
</table>

#### 3D Bar Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>bar</td>
<td></td>
</tr>
<tr>
<td>Show in 3D</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>
### Time Series Chart

#### Parameters in Macro Browser
- **Type**: Time Series
- **Date Format**: MM/yyyy
- **Time Period**: Month
- **Content Orientation**: vertical
- **Range Axis Lower Bound**: 0
- **Show Legend**: true

#### Data Tables in Macro Placeholder

<table>
<thead>
<tr>
<th>Month</th>
<th>Revenue</th>
<th>Expenditure</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2011</td>
<td>31.8</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2011</td>
<td>41.8</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2011</td>
<td>51.3</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2011</td>
<td>33.8</td>
<td>45.0</td>
</tr>
<tr>
<td>5/2011</td>
<td>27.6</td>
<td>44.6</td>
</tr>
<tr>
<td>6/2011</td>
<td>49.8</td>
<td>43.8</td>
</tr>
<tr>
<td>7/2011</td>
<td>51.8</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2011</td>
<td>77.3</td>
<td>52.3</td>
</tr>
<tr>
<td>9/2011</td>
<td>73.8</td>
<td>53.8</td>
</tr>
<tr>
<td>10/2011</td>
<td>97.6</td>
<td>55.6</td>
</tr>
<tr>
<td>11/2011</td>
<td>101.2</td>
<td>61.2</td>
</tr>
<tr>
<td>12/2011</td>
<td>113.7</td>
<td>63.7</td>
</tr>
</tbody>
</table>

### XY Line Chart

#### Parameters in Macro Browser
- **Type**: xyLine
- **Show Legend**: true

#### Data Table in Macro Placeholder

<table>
<thead>
<tr>
<th>Month</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>12</td>
<td>41.1</td>
</tr>
<tr>
<td>14</td>
<td>31.8</td>
</tr>
<tr>
<td>23</td>
<td>12.1</td>
</tr>
</tbody>
</table>

#### Rendered Chart
### XY Area Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>xyArea</td>
<td></td>
</tr>
<tr>
<td><strong>Show Legend</strong></td>
<td>true</td>
<td></td>
</tr>
<tr>
<td><strong>Revenue</strong></td>
<td>31.1 41.8 43.6</td>
<td><img src="chart1.png" alt="Revenue Chart" /></td>
</tr>
<tr>
<td><strong>Expense</strong></td>
<td>1 8 4</td>
<td></td>
</tr>
</tbody>
</table>

### Area Charts

**Example 1**

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>area</td>
<td></td>
</tr>
<tr>
<td><strong>Show Legend</strong></td>
<td>true</td>
<td></td>
</tr>
<tr>
<td><strong>Width</strong></td>
<td>300</td>
<td></td>
</tr>
<tr>
<td><strong>Height</strong></td>
<td>300</td>
<td></td>
</tr>
<tr>
<td><strong>Opacity</strong></td>
<td>50</td>
<td></td>
</tr>
<tr>
<td><strong>Satisfaction</strong></td>
<td>200 9 201 0 201 1</td>
<td><img src="chart2.png" alt="Satisfaction Chart" /></td>
</tr>
<tr>
<td><strong>Very</strong></td>
<td>20 23 34</td>
<td></td>
</tr>
</tbody>
</table>
### Example 2

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>area</td>
<td></td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Stacked Values</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

**Parameters in Macro Browser**

<table>
<thead>
<tr>
<th>Type</th>
<th>2009</th>
<th>2010</th>
<th>2011</th>
</tr>
</thead>
<tbody>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>

**Gantt Chart**

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>gantt</td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td>300</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Plan</th>
<th>Start</th>
<th>End</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Code examples

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

Macro name: chart

Macro body: Accepts rich text, consisting of tables that hold the chart's data.

This macro recognises a large number of parameters, listed here by type for convenience.

See all parameters...

Chart type parameters

These parameters determine the type of chart to display and how the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
<td>---------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| type      | No       | pie     | The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based. See the timeSeries parameter. Available values:  
  - Standard charts – pie, bar, line, area  
  - XY plots – xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries  
  - Other charts – gantt |
| orientation | No       | vertical | The display orientation. Applies to area, bar and line charts. Available values:  
  - vertical – y-axis is vertical  
  - horizontal – x-axis is vertical |
| 3D        | No       | false   | Show in three dimensions. Applies to area, bar and line charts. |
| stacked   | No       | false   | Stacked values. Applies to area and bar charts. |
| showShapes | No       | true    | Applies to line charts. Shapes are shown at each data point. |
| opacity   | No       | • 75 percent for 3D charts  
  • 50 percent for non-stacked area charts  
  • 100 percent for all other charts | A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are. |

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>----------</td>
<td>---------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>dataDisplay</td>
<td>No</td>
<td>false</td>
<td>Determines whether to display the body of the macro, consisting of the data table. By default, the chart data table is not displayed. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- false – the data is not displayed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- true or after – the data is displayed after the chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- before – the data is displayed before the chart.</td>
</tr>
<tr>
<td>imageFormat</td>
<td>No</td>
<td>png</td>
<td>The image format to be used for the chart. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- png</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- jpg</td>
</tr>
</tbody>
</table>

**Chart title and label parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>subTitle</td>
<td>No</td>
<td>(None)</td>
<td>A subtitle for the chart.</td>
</tr>
<tr>
<td>xLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>yLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>legend</td>
<td>No</td>
<td>false</td>
<td>Determines whether to show a legend (key) for the chart.</td>
</tr>
</tbody>
</table>

**Chart data parameters**

The data for the chart is taken from tables found in the macro body. The parameters below control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. You can specify additional conversion options using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>tables</td>
<td>No</td>
<td>All first level tables</td>
<td>You can supply a comma-separated list of table IDs and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
</tr>
<tr>
<td>columns</td>
<td>No</td>
<td>All columns</td>
<td>You can supply a comma-separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the HTML title attribute for the column in the header row.</td>
</tr>
</tbody>
</table>
| dataOrientation | No     | horizontal             | The content orientation. By default, the data tables will be interpreted as columns (horizontally) representing domain and x values. 
Available values:
• vertical – data table columns will be interpreted as series.
• horizontal – data tables rows will be interpreted as series. |
<p>| timeSeries  | No          | false                  | If 'true', the x values in an XY plot will be treated as time series data and so will be converted according date formats. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>dateFormat</td>
<td>No</td>
<td>(None)</td>
<td>For time series data, the date format allows for additional customisation of the conversion of data to date values. If a <strong>dateFormat</strong> is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See simple date format.</td>
</tr>
<tr>
<td>timePeriod</td>
<td>No</td>
<td>day</td>
<td>The time period for time series data. Defines the granularity of how the data is interpreted.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values: millisecond, second, minute, hour, day, week, month, quarter, year</td>
</tr>
<tr>
<td>language</td>
<td>No</td>
<td>(None)</td>
<td>Use in combination with the <strong>country</strong> parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values are the two-character ISO 639-1 alpha-2 codes.</td>
</tr>
<tr>
<td>country</td>
<td>No</td>
<td>(None)</td>
<td>Use in combination with the <strong>language</strong> parameter to form a locale. Valid values are the two-character ISO 3166 codes.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>----------</td>
<td>---------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>forgive</td>
<td>No</td>
<td>true</td>
<td>Determines whether the macro will forgive (allow) some data formatting errors.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• true — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• false — the macro enforces strict data formatting. If there are data format errors, the chart will not be produced.</td>
</tr>
<tr>
<td>Chart colour parameters</td>
<td></td>
<td></td>
<td>Colours are specified using hexadecimal notation or HTML colour names.</td>
</tr>
<tr>
<td>bgColor</td>
<td>No</td>
<td>White</td>
<td>Background colour of the chart.</td>
</tr>
<tr>
<td>borderColor</td>
<td>No</td>
<td>No border</td>
<td>Colour of the border around the chart.</td>
</tr>
<tr>
<td>colors</td>
<td>No</td>
<td></td>
<td>A comma-separated list of colours used to customise the colours of categories, sections, and series.</td>
</tr>
<tr>
<td>Chart axis parameters</td>
<td></td>
<td></td>
<td>Depending on the chart type, the range and domain axis may be customised. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.</td>
</tr>
<tr>
<td>rangeAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td>Minimum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td>Maximum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>rangeAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>---------------------------------</td>
<td>---------</td>
<td>-----------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>domainAxisLowerBound</td>
<td>No</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the <code>dateFormat</code> parameter.</td>
<td></td>
</tr>
<tr>
<td>domainAxisUpperBound</td>
<td>No</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the <code>dateFormat</code> parameter.</td>
<td></td>
</tr>
<tr>
<td>domainAxisTickUnit</td>
<td>No</td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the <code>timePeriod</code> parameter. The <code>timePeriod</code> unit can be overridden by specifying a trailing character: <code>y</code> (years), <code>M</code> (months), <code>d</code> (days), <code>h</code> (hours), <code>m</code> (minutes), <code>s</code> (seconds), <code>u</code> (milliseconds).</td>
<td></td>
</tr>
<tr>
<td>domainAxisLabelAngle</td>
<td>No</td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
<td></td>
</tr>
<tr>
<td>categoryLabelPosition</td>
<td>No</td>
<td>Placement of the axis label text for categories.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Available values:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>up45</code> — 45 degrees going upward</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>up90</code> — 90 degrees going upward</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>down45</code> — 45 degrees going downward</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <code>down90</code> — 90 degrees going downward</td>
<td></td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------</td>
<td>-------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>dateTickMarkPosition</td>
<td>No</td>
<td>start</td>
<td>Placement of the date tick mark.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• start — tick mark is at the start of the date period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• middle — tick mark is in the middle of the date period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• end — tick mark is at the end of the date period.</td>
</tr>
<tr>
<td>pieSectionLabel</td>
<td>No</td>
<td>Show only the pie section key value</td>
<td>Format of pie section labels. The format uses a string with special replacement variables:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• %0% is replaced by the pie section key.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• %1% is replaced by the pie section numeric value.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• %2% is replaced by the pie section percent value.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Example 1: To display something like ‘Independent = 20’:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>%0% = %1%</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Example 2: To display something like ‘Independent (20%)’:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>%0% (%2%)</td>
</tr>
<tr>
<td>pieSectionExplode</td>
<td>No</td>
<td>No exploded sections</td>
<td>A comma-separated list of pie keys that are to be shown exploded. Note: requires jFreeChart version 1.0.3 or higher.</td>
</tr>
</tbody>
</table>

**Chart attachment parameters**

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is displayed. These options allow for the generated image to be saved as an attachment and have subsequent
access to re-use the attachment. This can be useful especially when combined with the Cache plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| attachment    | No       | (None)      | The name and location where the chart image will be saved as an attachment. The user must be authorised to add attachments to the page specified. Available syntax for this parameter:  
  - `^attachmentName.png` — the chart is saved as an attachment to the current page.  
  - `page name^attachmentName.png` — the chart is saved as an attachment to the page name provided.  
  - `spacekey:page name^attachmentName.png` — the chart is saved as an attachment to the page name provided in the space indicated. |
<table>
<thead>
<tr>
<th>Field</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| attachmentVersion         | No      | Defines the versioning mechanism for saved charts. Available values:  
  * new — creates new version of the attachment.  
  * replace — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorised to remove attachments for the page specified.  
  * keep — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated. |
| attachmentComment         | No      | (None) Comment used for a saved chart attachment. |
| thumbnail                 | No      | false If true, the chart image attachment will be shown as a thumbnail (small, expandable) image. |

Storage format example

Below is a simple example of a pie chart. See more examples in [Storage Format Examples for Chart Macro](#).
Below is a simple example of a pie chart. See more examples in Wiki Markup Examples for Chart Macro.
Confluence Storage Format Examples for Chart Macro

This page is an extension of the documentation for the Chart Macro. This page contains additional examples for the Chart macro.

**Pie chart**

Here is a simple example of a pie chart.

```
{chart:type=pie|title=Fish Sold}  
|| Fish Type || 2004 || 2005 || 
|| Herring | 9,500 | 8,300 | 
|| Salmon | 2,900 | 4,200 | 
|| Tuna | 1,500 | 1,500 | 
{chart}
```
<ac:structured-macro ac:name="chart">
   <ac:parameter ac:name="title">Fish Sold</ac:parameter>
   <ac:parameter ac:name="type">pie</ac:parameter>
   <ac:rich-text-body>
   <table>
      <tbody>
         <tr>
            <th>Fish Type</th>
            <th>2004</th>
            <th>2005</th>
         </tr>
         <tr>
            <td>Herring</td>
            <td>9,500</td>
            <td>8,300</td>
         </tr>
         <tr>
            <td>Salmon</td>
            <td>2,900</td>
            <td>4,200</td>
         </tr>
         <tr>
            <td>Tuna</td>
            <td>1,500</td>
            <td>1,500</td>
         </tr>
      </tbody>
   </table>
   </ac:rich-text-body>
</ac:structured-macro>

Resulting chart

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
**Fish Sold**

![Bar chart](image)

- 2004 (1,500 - 50%)
- 2005 (1,500 - 50%)

**Bar chart**

Here is a simple example of a bar chart.

**Storage format**
Resulting chart
# Time series chart

Here is an example of a time series chart.

**Storage format**

```xml
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="timePeriod">Month</ac:parameter>
  <ac:parameter ac:name="dataOrientation">vertical</ac:parameter>
  <ac:parameter ac:name="rangeAxisLowerBound">0</ac:parameter>
  <ac:parameter ac:name="dateFormat">MM/yyyy</ac:parameter>
  <ac:parameter ac:name="type">timeSeries</ac:parameter>
  <ac:parameter ac:name="domainaxisrotateticklabel">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th>Month</th>
          <th>Revenue</th>
        </tr>
        <tr>
          <td>1/2005</td>
          <td>31.8</td>
        </tr>
        <tr>
          <td>2/2005</td>
          <td>41.8</td>
        </tr>
        <tr>
          <td>3/2005</td>
          <td></td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```
<table>
<thead>
<tr>
<th>Date</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>4/2005</td>
<td>51.3</td>
</tr>
<tr>
<td>5/2005</td>
<td>33.8</td>
</tr>
<tr>
<td>6/2005</td>
<td>27.6</td>
</tr>
<tr>
<td>7/2005</td>
<td>49.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>9/2005</td>
<td>77.3</td>
</tr>
<tr>
<td>10/2005</td>
<td>73.8</td>
</tr>
<tr>
<td>Month</td>
<td>Expenses</td>
</tr>
<tr>
<td>-------</td>
<td>----------</td>
</tr>
<tr>
<td>1/2005</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>45.0</td>
</tr>
<tr>
<td>5/2005</td>
<td>101.2</td>
</tr>
<tr>
<td>6/2005</td>
<td>113.7</td>
</tr>
<tr>
<td>Date</td>
<td>Value</td>
</tr>
<tr>
<td>-----------</td>
<td>-------</td>
</tr>
<tr>
<td>4/2005</td>
<td>44.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>52.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>53.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>55.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>61.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>63.7</td>
</tr>
</tbody>
</table>
Here is an example of an XY line chart.

**Storage format**
### Resulting chart

```
<ac:macro ac:name="chart">
<ac:parameter ac:name="type">xyline</ac:parameter>
<ac:rich-text-body>
<ac:macronamespace ac:name="table">
  <tbody>
    <tr>
      <th>&nbsp;</th>
      <th>12</th>
      <th>14</th>
      <th>23</th>
    </tr>
    <tr>
      <td>Revenue</td>
      <td>41.1</td>
      <td>31.8</td>
      <td>12.4</td>
    </tr>
    <tr>
      <td>Expense</td>
      <td>31.1</td>
      <td>41.8</td>
      <td>43.6</td>
    </tr>
  </tbody>
</ac:macronamespace>
</ac:rich-text-body>
</ac:macro>
```
Here is an example of an XY bar chart.

Storage format
<ac:structured-macro ac:name="chart">
    <ac:parameter ac:name="opacity">60</ac:parameter>
    <ac:parameter ac:name="type">xybar</ac:parameter>
    <ac:rich-text-body>
        <table>
            <tbody>
                <tr>
                    <th></th>
                    <th>2005</th>
                    <th>2006</th>
                    <th>2007</th>
                </tr>
                <tr>
                    <td>Revenue</td>
                    <td>41.1</td>
                    <td>31.8</td>
                    <td>12.4</td>
                </tr>
                <tr>
                    <td>Expense</td>
                    <td>31.1</td>
                    <td>41.8</td>
                    <td>43.6</td>
                </tr>
            </tbody>
        </table>
    </ac:rich-text-body>
</ac:structured-macro>

Resulting chart
XY area chart

Here is an example of an XY area chart.

Storage format
Resulting chart

```xml
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="type">xyarea</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th></th>
          <th>12</th>
          <th>14</th>
          <th>23</th>
        </tr>
        <tr>
          <td>Revenue</td>
          <td>41.1</td>
          <td>31.8</td>
          <td>12.4</td>
        </tr>
        <tr>
          <td>Expense</td>
          <td>31.1</td>
          <td>41.8</td>
          <td>43.6</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```
Area chart

Here are two examples of area charts.

Storage format for area chart 1

```
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="height">300</ac:parameter>
  <ac:parameter ac:name="legend">true</ac:parameter>
  <ac:parameter ac:name="width">300</ac:parameter>
  <ac:parameter ac:name="opacity">50</ac:parameter>
  <ac:parameter ac:name="type">area</ac:parameter>
  <ac:parameter ac:name="dataDisplay">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th>Satisfaction</th>
          <th>2002</th>
          <th>2003</th>
          <th>2004</th>
        </tr>
        <tr>
          <td>Very satisfied</td>
          <td>20</td>
          <td>23</td>
          <td>34</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```
<table>
<thead>
<tr>
<th>Satisfied</th>
<th>40</th>
<th>34</th>
<th>23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>
Resulting area chart 1

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
<td>34</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>

Storage format for area chart 2

```xml
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="stacked">true</ac:parameter>
  <ac:parameter ac:name="height">300</ac:parameter>
  <ac:parameter ac:name="legend">true</ac:parameter>
  <ac:parameter ac:name="width">300</ac:parameter>
  <ac:parameter ac:name="type">area</ac:parameter>
  <ac:parameter ac:name="dataDisplay">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tr>
        <th><p>Satisfaction</p></th>
        <th><p>2002</p></th>
        <th><p>2003</p></th>
        <th><p>2004</p></th>
      </tr>
      <tr>
        <td>Very satisfied</td>
        <td>20</td>
        <td>23</td>
        <td>34</td>
      </tr>
      <tr>
        <td>Satisfied</td>
        <td>40</td>
        <td>34</td>
        <td>23</td>
      </tr>
      <tr>
        <td>Dissatisfied</td>
        <td>25</td>
        <td>26</td>
        <td>25</td>
      </tr>
      <tr>
        <td>Very dissatisfied</td>
        <td>15</td>
        <td>17</td>
        <td>18</td>
      </tr>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```
<table>
<thead>
<tr>
<th>Rating</th>
<th>12</th>
<th>23</th>
<th>31</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Satisfied</td>
<td>1</td>
<td>34</td>
<td>36</td>
</tr>
<tr>
<td>Disatisfied</td>
<td>4</td>
<td>6</td>
<td>22</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>2</td>
<td>7</td>
<td>12</td>
</tr>
</tbody>
</table>
Resulting area chart 2

Satisfaction  | 2002  | 2003  | 2004  |
-------------|-------|-------|-------|
Very satisfied | 12    | 23    | 31    |
Satisfied    | 1     | 34    | 36    |
Disatisfied  | 4     | 6     | 22    |
Very dissatisfied | 2    | 7     | 12    |

Wiki Markup Examples for Chart Macro

This page is an extension of the documentation for the Chart Macro. This page contains additional examples for the Chart macro.

Pie chart

Here is a simple example of a pie chart.

Wiki markup

```
{chart:type=pie|title=Fish Sold} || Fish Type || 2004 || 2005 ||
|| Herring  | 9,500 | 8,300 |
|| Salmon   | 2,900 | 4,200 |
|| Tuna     | 1,500 | 1,500 |
{chart}
```

Resulting chart
Bar chart

Here is a simple example of a bar chart.

Wiki markup

```
{chart:type=bar|title=Fish Sold}
| Herring | 9,500 | 8,300 |
| Salmon  | 2,900 | 4,200 |
| Tuna    | 1,500 | 1,500 |
{chart}
```

Resulting chart

Time series chart

Here is an example of a time series chart.

Wiki markup
<table>
<thead>
<tr>
<th>Month</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2005</td>
<td>31.8</td>
</tr>
<tr>
<td>2/2005</td>
<td>41.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>51.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>33.8</td>
</tr>
<tr>
<td>5/2005</td>
<td>27.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>49.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>77.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>73.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>97.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>101.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>113.7</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Month</th>
<th>Expenses</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2005</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>45.0</td>
</tr>
<tr>
<td>5/2005</td>
<td>44.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>52.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>53.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>55.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>61.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>63.7</td>
</tr>
</tbody>
</table>

Resulting chart

XY line chart

Here is an example of an XY line chart.

Wiki markup
Here is an example of an XY bar chart.

Wiki markup

```wikimarkup
{chart:type=xybar\|opacity=60}
|| || 2005 || 2006 || 2007 ||
| Revenue | 41.1 | 31.8 | 12.4 |
| Expense | 31.1 | 41.8 | 43.6 |
{chart}
```

Resulting chart
Here is an example of an XY area chart.

Wiki markup

```
{chart:type=xyarea}
\|  12 | 14 | 23 |
| Revenue | 41.1 | 31.8 | 12.4 |
| Expense | 31.1 | 41.8 | 43.6 |
{chart}
```

Resulting chart

Here are two examples of area charts.

Wiki markup for area chart 1

```
<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
<td>34</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>

Wiki markup for area chart 2

{chart:type=area|dataDisplay=true|legend=true|width=300|height=300|stacked=true}

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>12</td>
<td>23</td>
<td>31</td>
</tr>
<tr>
<td>Satisfied</td>
<td>1</td>
<td>34</td>
<td>36</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>4</td>
<td>6</td>
<td>22</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>2</td>
<td>7</td>
<td>12</td>
</tr>
</tbody>
</table>

Resulting area chart 2
The Cheese macro simply displays the words "I like cheese!" You can use this macro to test the Confluence macro functionality.

To add the Cheese macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Note: There are no parameters for this macro.

Code examples

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

Macro name: cheese

Macro body: None.

Parameters: None

Storage format example

```xml
<ac:structured-macro ac:name="cheese"/>
```

Wiki markup example
Children Display Macro

Use the Children Display macro to list the child pages of a page and the further descendants (children's children). By default, the macro displays links to the child pages as shown in the screenshot below. People viewing the page will see only the links for pages that they have permission to view.

**Screenshot: The Children Display macro in Confluence**

This is the Children Display macro
- Step 1 - download the game
- Step 2 - Play
- Step 3 - share your favourite nerd
- Sample page
- Games as a communication medium

**Using the Children Display macro**

**To add the Children Display macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Example**

This list of child pages is generated by a Children Display macro on this page:
- Child Page 1
- Child Page 2

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Descendants</td>
<td>false</td>
<td>Choose whether to display all the parent page's descendants.</td>
</tr>
<tr>
<td>(all)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Depth of Descendants</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Parent Page

**(page)**

| current |

Specify the page to display children for, from either the current space or a different space. Enter:
- `'/'` — to list the top-level pages of the current space, i.e., those without parents.
- `'pagename'` — to list the children of the specified page.
- `'spacekey:'` — to list the top-level pages of the specified space.
- `'spacekey:pagename'` — to list the children of the specified page in the specified space.

### Number of Children

**(first)**

| none |

Restrict the number of child pages that are displayed at the top level.

### Depth of Descendants

**(depth)**

| none |

Enter a number to specify the depth of descendants to display. For example, if the value is 2, the macro will display 2 levels of child pages.

This setting has no effect of **Show Descendants** is enabled.

### Heading Style

**(style)**

| none |

Choose the style used to display descendants.

### Include Excerpts

**(excerpt)**

| false |

Display excerpts for the child pages, if they exist.

### Sort Children By

**(sort)**

| Manual if manually ordered, otherwise alphabetical |

Optional. Choose:
- **creation** — to sort by content creation date
- **title** — to sort alphabetically on title
- **modified** — to sort of last modification date.

### Reverse Sort

**(reverse)**

| false |

Use with the **Sort Children By** parameter. When set, the sort order changes from ascending to descending.

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name**: children

**Macro body**: None.

**Storage format example**
Wiki markup example

{children:reverse=true|sort=creation|style=h4|page=Home|excerpt=true|first=99|depth=2|all=true}

Child Page 1

Grandchild

Child Page 2

This page is used to test the {children} macro.

Related Topics

Children Display Macro

Code Block Macro

The Code Block macro allows you to display source code in your document with the appropriate syntax highlighting. The code block displays on the page as shown below:

```java
public static void main(String[] args) {
    System.out.println("Hello World!");
}
```

Using the Code Block Macro

To add the Code Block macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

You type the code block directly into the macro placeholder in the editor. Note that any white space contained in the placeholder is not manipulated in any way by the Code Block macro. This is to provide the writer with flexibility over code indentation.

Parameters
Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Syntax highlighting</strong></td>
<td><strong>(language)</strong></td>
<td>java</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Title</strong></td>
<td>none</td>
<td>Adds a title to the code block. If specified, the title will be displayed in a header row at the top of the code block.</td>
</tr>
<tr>
<td><strong>Collapsible</strong></td>
<td>false</td>
<td>If selected, the code macro's content will be collapsed upon visiting or refreshing the Confluence page. Clicking the expand and source link allows you to view this content. If false, the code macro's content is always displayed in full.</td>
</tr>
<tr>
<td><strong>Show line numbers</strong></td>
<td>false</td>
<td>If selected, line numbers will be shown to the left of the lines of code.</td>
</tr>
<tr>
<td><strong>First line number</strong></td>
<td>1</td>
<td>When Show line numbers is selected, this value defines the number of the first line of code.</td>
</tr>
</tbody>
</table>
### Theme

<table>
<thead>
<tr>
<th>Theme</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specifies the colour scheme used for displaying your code block. Many of these themes are based on the default colour schemes of popular integrated development environments (IDEs). The default theme is <strong>Confluence</strong> (also known as <strong>Default</strong>), which is typically black and coloured text on a blank background. However, you can also choose from one of the following other popular themes:</td>
<td></td>
</tr>
<tr>
<td>DJango</td>
<td></td>
</tr>
<tr>
<td>Emacs</td>
<td></td>
</tr>
<tr>
<td>FadeToGrey</td>
<td></td>
</tr>
<tr>
<td>Midnight</td>
<td></td>
</tr>
<tr>
<td>RDark</td>
<td></td>
</tr>
<tr>
<td>Eclipse</td>
<td></td>
</tr>
<tr>
<td>Confluence</td>
<td></td>
</tr>
</tbody>
</table>

### Configuring the Code Block macro

You can configure the Code Block macro to use a specific language and theme by default and also upload new languages. You need **Confluence Administrator** permissions to change the default theme and language and **System Administrator** permissions to upload new languages.

To set the default appearance of code blocks in your site:

1. Choose the cog icon , then choose **General Configuration** under Confluence Administration.
2. Choose **Configure Code Macro**.
3. Select a **Default Theme** and **Default Language**.
4. Choose **Save**.

All new code blocks will use the default theme and language unless you specify otherwise. Existing code blocks will be unchanged.

To add an additional language:

1. Choose the cog icon , then choose **General Configuration** under Confluence Administration.
2. Choose **Configure Code Macro**.
3. Choose **Add a new language**.
4. Locate your language file and enter a **Name** for the new language (this will appear when selecting the language).
5. Choose **Add**.

Language files must be correctly formatted JavaScript files and adhere to the **Custom Brush syntax**. You can find some examples of language files [here](#).

To disable or remove a user-installed language:

1. Choose the cog icon , then choose **General Configuration** under Confluence Administration.
2. Choose **Manage Add-ons**.
3. Go to **User-installed Add-ons** and locate the add-on for your uploaded language - it will appear like this 'Custom Code Macro Highlighting for...'
4. Choose **Uninstall** or **Disable**.

The language will no longer appear in the Code Macro.

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.
Macro name: code

Macro body: Accepts plain text.

Storage format example

The following example shows all parameters and a body:

```xml
<ac:structured-macro ac:name="code">
  <ac:parameter ac:name="title">This is my title</ac:parameter>
  <ac:parameter ac:name="theme">FadeToGrey</ac:parameter>
  <ac:parameter ac:name="linenumbers">true</ac:parameter>
  <ac:parameter ac:name="language">xml</ac:parameter>
  <ac:parameter ac:name="firstline">0001</ac:parameter>
  <ac:parameter ac:name="collapse">true</ac:parameter>
  <ac:plain-text-body><![CDATA[<b>This is my code</b>]]></ac:plain-text-body>
</ac:structured-macro>
```

Below are three examples of the Code Block macro with various optional parameters used.

<table>
<thead>
<tr>
<th>Description</th>
<th>Markup</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| Code block macro with a body and no optional parameters | `<ac:structured-macro ac:name="code">
  <ac:plain-text-body><![CDATA[this is my code]]></ac:plain-text-body>
</ac:structured-macro>` | this is my code |
| Code block macro with a body and the optional language parameter defined | `<ac:structured-macro ac:name="code">
  <ac:parameter ac:name="language">html/xml</ac:parameter>
  <ac:plain-text-body><![CDATA[this is my code]]></ac:plain-text-body>
</ac:structured-macro>` | this is my code |
Code block macro with a body and optional title, line numbers and language parameters defined

```
<ac:structured-macro ac:name="code">
  <ac:parameter ac:name="title">This is my title</ac:parameter>
  <ac:parameter ac:name="linenumbers">true</ac:parameter>
  <ac:parameter ac:name="language">html/xml</ac:parameter>
  <ac:plain-text-body><![CDATA[this is my code]]></ac:plain-text-body>
</ac:structured-macro>
```

Wiki markup example

```
{code:title=This is my title|theme=FadeToGrey|linenumbers=true|language=html/xml|firstline=0001|collapse=true}
This is my code
{code}
```

Column Macro

Used with the Section macro to define columns on a page. See Working with page layouts and columns and sections.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** column

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>The width of the column. Can be specified either in pixels (for example, 400 px) or as a percentage of the available page width (for example, 50%).</td>
</tr>
</tbody>
</table>

Storage format example
Content by Label Macro

The Content by Label macro displays links to pages, blog posts and attachments that have been tagged with specific labels.

**A working example**

Below is a working example of the Content by Label macro, displaying content with the label 'LDAP'.

- [Testing LDAP Connection using JXplorer](#) *(Atlassian Development)*
- [Customising atlassianUserContext.xml](#) *(Confluence 2.7)*
- [Customising atlassian-user.xml](#) *(Confluence 2.8)*
- [Customising atlassian-user.xml](#) *(Confluence 2.9)*
- [LDAP Error Code 50](#) *(JIRA Knowledge Base)*

Showing first 5 of 877 results

**Using the Content by Label Macro**

**To add the Content by Label macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

---

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
| **Label(s)** (labels) | None | Filter by label(s). The macro will display only the content tagged with the label(s) specified here. See also the **Operator** parameter below. This parameter is required. Specify one or more labels, separated by a comma or a single space.  
- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labelled with 'badpage'.  
- To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage,+good page you will get only content which has at least two labels, being 'superpage' and 'goodpage'. |
| **Author(s)** (author) | None | Filter by author. The macro will display only the content created or updated by the author(s) specified here. Specify one or more authors, separated by a comma. For example: jsmith, jbrown To include content from one user, but exclude from another user: jsmith,!jbrown |
| Include this Content Type Only (type) | all | Filter by content type. The macro will display only the content of the type specified here. Specify one or more content types, separated by a comma or a space. To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of -blogpost you will get pages and all other content except for blog posts. Available values:  
  - page – Pages.  
  - blogpost or news – Blog posts, also known as news items.  
  - attachment – Attachments |
| Show Labels for Each Page (showLabels) | true | Show or hide labels in the results. |
| Show Space Name for Each Page (showSpace) | true | Show or hide spaces in the results. |
| List Title (title) | None | Add a title or heading to the list. |
| Maximum Number of Pages (max) | 15 | Limit the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied. |
| Display Excerpts (excerpt) | false | Include excerpts from each page listed. Note that you must have defined excerpts on each of those pages, by adding the excerpt macro to the page. Only the first few lines of the excerpt for each page are displayed. |
| Restrict to these Spaces (spaces) | @all | Filter by space. The macro will display only the content which belongs to the space(s) specified here. 

Specify one or more space keys, separated by a comma or a space. 

- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE. 
- To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.) 

Special values: 

- @self — The current space. 
- @personal — All personal spaces. 
- @global — All site spaces. 
- @favorite — The spaces you have marked as favourite. 
- @favourite — The same as @favorite. 
- @all — All spaces in your Confluence site. 
- * — The same as @all. 

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.
| Operator (operator) | OR | The operator to apply when matching content against the labels specified in the **Label(s)** parameter:  
  - **OR** – Display content with *any* of the non-prefixed labels.  
  - **AND** – Display content with *all* of the specified non-prefixed labels.  
  - Note that this parameter only modifies the behaviour of the **Label(s)** parameter and only affects label values without a plus (+) or minus (-) sign prefix. |
|---------------------|----|---|
| Sort By (sort) | modified | Specify how the results should be sorted.  
  Values:  
  - **title** — Sort alphabetically by title.  
  - **creation** — Sort by the date on which the content was added.  
  - **modified** — Sort by the date on which the content was last updated.  
  - Note: If this parameter is not specified, the sort order defaults to descending, based on the last modification date (latest first). To change the sort order from ascending to descending, use the **Reverse Sort** parameter. |
| Reverse Sort (reverse) | false | Select **Reverse Sort** to change the sort from descending to ascending. Use this parameter in conjunction with the **Sort By** parameter. **Reverse Sort** is ignored if **Sort By** is not specified. |

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** contentbylabel  
**Macro body:** None.

*Storage format example*
Content by User Macro

The Content by User macro generates a tabulated list of the content items, throughout the Confluence installation, that have been created by a specified Confluence user. The list includes all current pages, comments and spaces created by the user. Each item in the table is linked to its corresponding page, page comment or space dashboard.

Note that items for page comments contain a link to the page, followed by a second link to the comment itself, with these separated by a greater-than sign (>).

Using the Content by User macro

To add the Content by User macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username (name)</td>
<td>yes</td>
<td>none</td>
<td>The Confluence username for a person who has created content. Parameter is unnamed in wikimarkup.</td>
</tr>
</tbody>
</table>

Code examples
The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** content-by-user

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="content-by-user">
<ac:parameter ac:name="">
    <ri:user ri:userkey="12345678912345678912345678912345"/>
</ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
{content-by-user:jsmith}
```

**Content Report Table Macro**

The Content Report Table macro displays a set of pages and blog posts in tabular format, based on the labels specified in the macro parameters.

**A working example**

Below is a working example of the Content Report Table macro, displaying content with the label 'LDAP'.

<table>
<thead>
<tr>
<th>Title</th>
<th>Creator</th>
<th>Modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diagrams of Possible Configurations for User Management</td>
<td>Sarah Maddox [Atlassian]</td>
<td>Sep 25, 2013</td>
</tr>
<tr>
<td>Synchronising Data from External Directories</td>
<td>Sarah Maddox [Atlassian]</td>
<td>Sep 25, 2013</td>
</tr>
<tr>
<td>Configuring an SSL Connection to Active Directory</td>
<td>Sarah Maddox [Atlassian]</td>
<td>Sep 25, 2013</td>
</tr>
<tr>
<td>Configuring the LDAP Connection Pool</td>
<td>Sarah Maddox [Atlassian]</td>
<td>Sep 25, 2013</td>
</tr>
<tr>
<td>Managing Multiple Directories</td>
<td>Sarah Maddox [Atlassian]</td>
<td>Sep 13, 2013</td>
</tr>
<tr>
<td>Connecting to LDAP or JIRA or Other Services via SSL</td>
<td>Nick Faiz</td>
<td>Apr 29, 2013</td>
</tr>
</tbody>
</table>
Using the Content Report Table Macro

To add the Content Report Table macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label(s) (labels)</td>
<td>No</td>
<td>None</td>
<td>This parameter is required. Specify one or more labels, separated by a comma. The macro will display the content tagged with any of the label(s) specified here. For example, if you specify labels 'A' and 'B', the macro will display all pages that have the label 'A', and all pages that have the label 'B', and all pages that have both those labels.</td>
</tr>
<tr>
<td>Space(s) (spaces)</td>
<td>Yes</td>
<td>(All spaces)</td>
<td>Specify one or more space keys, separated by a comma or a space. The macro will display only the content which belongs to the space(s) specified here. When specifying a personal space, remember to use the tilde (<code>~</code>) sign in front of the username, such as <code>~jbloggs</code> or <code>~jbloggs@example.com</code>.</td>
</tr>
</tbody>
</table>
Maximum Number of Pages (maxResults)

No

20

Define the maximum number of pages that the macro will show in a single set of results. If there are more pages to be shown, the macro will display a link labelled 'Find more results'. People viewing the page can choose the link to go to a search view, which shows all pages tagged with the specified label(s).

Which pages will appear? Before displaying the results, Confluence will sort them by the date the page was last modified. The most-recently created/updated pages will appear first.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** content-report-table

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="content-report-table">
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="DOC"/>
  </ac:parameter>
  <ac:parameter ac:name="labels">LDAP</ac:parameter>
  <ac:parameter ac:name="analytics-key">meeting-notes</ac:parameter>
  <ac:parameter ac:name="maxResults">5</ac:parameter>
</ac:structured-macro>
```

**Wiki markup**

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

**Contributors Macro**

The Contributors macro displays a list of Confluence users who have made a contribution of some type to a page. It can also be used to list watchers of the page.

The scope of this macro can be extended to include the immediate children or descendants of the specified page. The list of contributors can be based on people who have:

- authored or edited the page(s)
- contributed comments or added labels to the page(s), or
- are simply watching the page(s).
### Using the Contributors Macro

To add the Contributors macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in *Using Autocomplete*.  

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contribution Type</td>
<td>authors</td>
<td>Filters by either the type of contribution made to a page (and optionally its descendant pages), or the watches on the page.</td>
</tr>
<tr>
<td><strong>(include)</strong></td>
<td></td>
<td>Contribution types are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- authors - includes people who created or have edited the page(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- comments - includes people who have added comments to the page(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- labels - includes people who have added labels to the page(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- watches - includes people who are watching the page(s).</td>
</tr>
</tbody>
</table>

You can specify one or more contribution types, separated by commas.
<table>
<thead>
<tr>
<th>Parameters</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort By (order)</td>
<td>count</td>
<td>Specifies the criteria used to sort contributors. Sort criteria are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>count</strong> - sorts people based on the total number of contributions to the page(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>name</strong> - sorts people into alphabetical order</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>update</strong> - sorts people based on the date of their last contribution to the page(s).</td>
</tr>
<tr>
<td>Reverse Sort (reverse)</td>
<td>false</td>
<td>Reverses the sort order of contributors in the list. Must be used in conjunction with the <strong>Sort By</strong> parameter.</td>
</tr>
<tr>
<td>Maximum Number of Contributors (limit)</td>
<td>no limit</td>
<td>Limits the number of contributors in the list. If a number is not specified, all contributors are included.</td>
</tr>
<tr>
<td>Display Format (mode)</td>
<td>inline</td>
<td>Sets how the list of contributor's names is formatted:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>inline</strong> — a comma-separated list</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>list</strong> — a bullet list</td>
</tr>
<tr>
<td>Show Anonymous Contributions? (showAnonymous)</td>
<td>false</td>
<td>Sets whether to include those who contributed anonymously to a page.</td>
</tr>
<tr>
<td>Show Count? (showCount)</td>
<td>false</td>
<td>Sets whether to show the number of times each person made a contribution of the specified <strong>Contribution Type</strong>.</td>
</tr>
<tr>
<td>Show Last Contribution Time? (showLastTime)</td>
<td>false</td>
<td>Sets whether to show the last time each person made a contribution of the specified <strong>Contribution Type</strong>.</td>
</tr>
<tr>
<td>Page Name (page)</td>
<td>current</td>
<td>Specifies the page to use when generating the list of contributors. If <strong>Page Name</strong> and <strong>Space(s)</strong> are left blank, the current page is assumed.</td>
</tr>
<tr>
<td>Label(s) (labels)</td>
<td>none</td>
<td>Filters the list of contributors to those who created the specified labels from a page. You can specify one or more labels, separated by commas.</td>
</tr>
</tbody>
</table>
| Space(s) (spaces) | current | Specifies the space key of the Confluence space that contains the page set in Page Name or alternatively, specifies the spaces to search. Space keys are case-sensitive. This parameter also takes special values, including:
- @global — All site spaces.
- @personal — All personal spaces.
- @all — All spaces in your Confluence site.

If no Page Name and Label(s) are specified, all pages from the specified set of spaces are included. |
| Content Type (contentType) | both pages and blog posts | Restricts the content type to use when generating the list of contributors:
- pages — pages
- blogposts — blog posts. |
| Blog Post Date (publishDate) | none | Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD. |
| Include Page Hierarchy (scope) | specified page only | Specifies additional pages to include when generating the list of contributors:
- children — just the child pages of the specified page
- descendants — all descendants of the specified page. |
| Show Selected Pages (showPages) | false | Sets whether to show a list of the pages used to generate the list of contributors. |
| Custom "None Found" Message (noneFoundMessage) | default message | Specifies the message to be used to override the default message that is displayed when no contributors are found. |

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** contributors

**Macro body:** None.

**Storage format example**
This example specifies a content type of blog posts:

```xml
<ac:macro ac:name="contributors">
  <ac:parameter ac:name="limit">10</ac:parameter>
  <ac:parameter ac:name="spaces">ds,@personal</ac:parameter>
  <ac:parameter ac:name="reverse">true</ac:parameter>
  <ac:parameter ac:name="labels">chocolate,cake</ac:parameter>
  <ac:parameter ac:name="showPages">true</ac:parameter>
  <ac:parameter ac:name="noneFoundMessage">Oh dear, no contributors found</ac:parameter>
  <ac:parameter ac:name="showCount">true</ac:parameter>
  <ac:parameter ac:name="contentType">blogposts</ac:parameter>
  <ac:parameter ac:name="include">authors,comments,labels,watches</ac:parameter>
  <ac:parameter ac:name="mode">list</ac:parameter>
  <ac:parameter ac:name="showAnonymous">true</ac:parameter>
  <ac:parameter ac:name="order">update</ac:parameter>
  <ac:parameter ac:name="showLastTime">true</ac:parameter>
  <ac:parameter ac:name="publishDate">2012/06/30</ac:parameter>
</ac:macro>
```

**Wikimarkup example**

This example specifies a content type of blog posts:

```wikimarkup
{contributors:limit=10|spaces=ds,@personal|reverse=true|labels=chocolate,cake|showPages=true|noneFoundMessage=Oh dear, no contributors found|showCount=true|contentType=blogposts|include=authors,comments,labels,watches|mode=list|showAnonymous=true|order=update|showLastTime=true|publishDate=2012/06/30}
```

This example specifies a content type of pages:

```wikimarkup
{contributors:limit=10|spaces=ds,@personal|reverse=true|scope=descendants|labels=chocolate,cake|showPages=true|noneFoundMessage=Oh dear, no contributors found|showCount=true|contentType=pages|include=authors,comments,labels,watches|mode=list|showAnonymous=true|order=update|page=ds:Advanced Topics|showLastTime=true}
```

**Contributors Summary Macro**

The Contributors Summary macro displays a table of contribution-based statistics for a set of pages. These statistics can be grouped according to individual pages or individual contributors.

The default scope for this macro is an individual page, but this can be extended to include the immediate children or descendants of a specified page. The statistics cover the following types of contributions:

- edits to the page(s)
- comments added to the page(s)
- labels added to the page(s)
- people watching the page(s)

A simple example of the Contributors Summary macro is shown in the screenshot below. It lists statistics for the number of times each contributor has edited, added comments and added labels to this page.

**Screenshot: Example Contributors Summary table of statistics**

In this example, all default parameter settings are used. For more information about this macro's parameters, refer to the **Parameters** section below.

**Using the Contributors Summary Macro**
To add the Contributors Summary macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group By (groupby)</td>
<td>contributors</td>
<td>Specifies the basis for grouping contribution-based statistics:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• contributors — group by the people who have contributed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• pages — group by the pages used to find contributors.</td>
</tr>
</tbody>
</table>
| Columns to Display (columns) | edits,comments,labels | Sets the columns that should appear in the table. The statistics or type of information presented depends on the basis for grouping set with the **Group By** parameter. Statistics may be calculated for:

- **edits** — the number of times each contributor has edited the page(s) or the number of edits made to each page.
- **edited** — a list of the pages edited by each contributor or a list of contributors who have edited each page.
- **comments** — the number of times each contributor has added comments to the page(s) or the number of comments on each page.
- **commented** — a list of pages to which each contributor has added comments or a list of contributors who have commented on each page.
- **labels** — the number of times each contributor has added labels to the page(s) or the number of labels on each page.
- **labeled** — a list of pages to which each contributor has added labels or a list of contributors who have added a label to each page.
- **labellist** — a list of labels either added by each contributor or on each page.
- **watches** — the number of pages being watched by each contributor/person or the number of contributors/people watching each page.
- **watching** — a list of pages being watched by each contributor/person or a list of contributors/people watching each page.
- **lastupdate** — the last time each contributor made an update or when each page was last updated. Valid updates can include edit, comment or label modifications to a page.

One or more columns can be used.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sort By</strong> (order)</td>
<td>edits</td>
<td>Sets the criterion used for sorting items in the table. The items sorted depend on the basis for grouping set with the <code>Group By</code> parameter. Sort criteria are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>edits</strong> — sorts items in the table based on the total number of edits made, either by a contributor or to a page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>name</strong> — sorts items in the table in alphabetical order, either by contributor or page name.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>editTime</strong> — sorts items in the table based on when the contributor last edited a page (or a specified set of pages) or when the page was last edited.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>update</strong> — sorts items in the table based on when the contributor last made any contribution to a page (or a specified set of pages) or when the page last had any contribution made to it.</td>
</tr>
<tr>
<td><strong>Reverse Sort</strong> (reverse)</td>
<td>false</td>
<td>Reverses the sort order of items in the table, as specified using the <code>Sort By</code> parameter. (Used only in conjunction with the <code>Sort By</code> parameter.)</td>
</tr>
<tr>
<td><strong>Maximum Number of Items</strong> (limit)</td>
<td>no limit</td>
<td>Limits the number of contributors or pages in the table to the value specified. If no number is specified, all items are included.</td>
</tr>
<tr>
<td><strong>Show Anonymous Contributions?</strong></td>
<td>false</td>
<td>Includes individuals who have made anonymous contributions to a page.</td>
</tr>
<tr>
<td>(showAnonymous)</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Show Zero Counts?</strong></td>
<td>false</td>
<td>Sets whether contributors or pages are included for which a calculated statistic is zero.</td>
</tr>
<tr>
<td>(showZeroCounts)</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Page Name</strong> (page)</td>
<td>current</td>
<td>Sets the page for which to calculate the contribution-based statistics. If no values for <code>Page Name</code> and <code>Space(s)</code> are specified, the current page is assumed.</td>
</tr>
<tr>
<td><strong>Label(s)</strong> (labels)</td>
<td>none</td>
<td>Restricts the contribution-based statistics to the specified labels only. You can specify one or more labels, separated by commas.</td>
</tr>
</tbody>
</table>
| Space(s) (spaces) | current | Specifies the space key of the Confluence space which contains the specified page name or alternatively, specifies a scope of spaces to search. Space keys are case-sensitive. This parameter also takes special values, including:
- @global — All site spaces.
- @personal — All personal spaces.
- @all — All spaces in your Confluence site.
You can specify one or more space keys or special values, separated by commas.
If no Page Name and Label(s) are specified, all pages from the specified set of spaces are included. |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Content Type (contentType)</td>
<td>both pages and blog posts</td>
<td>Restricts page types to either pages (pages) or blog posts (blog posts). If no value is specified in the Macro Browser, both pages and blog posts are included. Available values pages and blog posts.</td>
</tr>
<tr>
<td>Blog Post Date (publishDate)</td>
<td>none</td>
<td>Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD.</td>
</tr>
<tr>
<td>Include Page Hierarchy (scope)</td>
<td>specified page only</td>
<td>Includes either the immediate children or all descendants of the specified page. If no value is indicated in the Macro Browser, only the specified page is included.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** contributors-summary

**Macro body:** None.

**Storage format example**

This example specifies a content type of blog posts:
This example specifies a content type of pages:

```
<ac:structured-macro ac:name="contributors-summary">
  <ac:parameter ac:name="limit">10</ac:parameter>
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="ds"/>
    <ri:space ri:space-key="@personal"/>
  </ac:parameter>
  <ac:parameter ac:name="reverse">true</ac:parameter>
  <ac:parameter ac:name="showAnonymous">true</ac:parameter>
  <ac:parameter ac:name="scope">descendants</ac:parameter>
  <ac:parameter ac:name="order">update</ac:parameter>
  <ac:parameter ac:name="page">
    <ac:link>
      <ri:page ri:content-title="Advanced Topics" ri:space-key="ds"/>
    </ac:link>
  </ac:parameter>
  <ac:parameter ac:name="labels">chocolate,cake</ac:parameter>
  <ac:parameter ac:name="columns">edits,comments,labels,lastupdate</ac:parameter>
  <ac:parameter ac:name="groupby">pages</ac:parameter>
  <ac:parameter ac:name="contentType">pages</ac:parameter>
  <ac:parameter ac:name="showZeroCounts">true</ac:parameter>
  <ac:parameter ac:name="publishDate">2012/06/07</ac:parameter>
</ac:structured-macro>
```

Wiki markup example

This example specifies a content type of blog posts:

```
{contributors-summary:limit=10|spaces=ds,@personal|reverse=true|showAnonymous=true|order=update|labels=chocolate,cake|columns=edits,comments,labels,lastupdate|groupby=pages|contentType=blogposts|showZeroCounts=true|publishDate=2012/06/07}
```

This example specifies a content type of pages:

```
{contributors-summary:limit=10|spaces=ds,@personal|reverse=true|showAnonymous=true|scope=descendants|order=update|page=ds:Advanced Topics|labels=chocolate,cake|columns=edits,comments,labels,lastupdate|groupby=pages|contentType=pages|showZeroCounts=true}
```
Create from Template Macro

The Create from Template macro displays a button on a page, linked to a specific template. When someone clicks the button, the macro opens the editor, ready to add a new page, and adds content to the page based on the given template.

When adding the macro to the page, you can specify a blueprint or a user-created template in the macro. You will also specify the name of the button displayed, and the space in which the new page will appear.

Example

Screenshot: A page with three buttons, all displayed by the 'Create from Template' macro

Using the Create from Template Macro

To add the Create from Template macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Button Text</td>
<td></td>
<td>'Create from Template'</td>
<td>The description that people will see when viewing this macro on the page.</td>
</tr>
<tr>
<td>Template Name</td>
<td></td>
<td>None</td>
<td>Select the template or blueprint to base the new page on. Only global and user-created templates for the current space appear (unless you have specified a different space in the 'Space Key' field).</td>
</tr>
<tr>
<td>Template Title</td>
<td>Blank</td>
<td>Specify a default title for pages created using this macro (optional). You can include @currentDate, @spaceName and @spaceKey variables in the title.</td>
<td></td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------</td>
<td>-----------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Space Key</td>
<td>The space where the current page is located</td>
<td>Supply the unique space identifier (space key), to determine where the new page will be created when someone uses this macro to create a page.</td>
<td></td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** create-from-template

**Macro body:** None.

Parameters for storage format differ from those available in the macro browser as follows.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>templateId</td>
<td>Required for user-created templates</td>
<td>(None)</td>
<td>The ID of a user-created template. This is the unique identifier that Confluence assigns when you create a template. For example, 299630593. To find the ID of a template, edit the template and look at the URL in your browser. The template ID is given in the URL parameter named entityId.</td>
</tr>
<tr>
<td>blueprintModuleCompleteKey</td>
<td>Required for blueprints</td>
<td>(None)</td>
<td>The ID of a user-created template (for example, 299630593) or the qualified name of the add-on that defines the blueprint (for example, com.atlassian.confluence.plugins.confluence-shared-files-plugin:file-list-blueprint).</td>
</tr>
<tr>
<td>templateName</td>
<td>Yes</td>
<td>(None)</td>
<td>The description that people will seeing when viewing this macro on the page.</td>
</tr>
<tr>
<td>buttonLabel</td>
<td>Yes</td>
<td>'Create from Template'</td>
<td></td>
</tr>
</tbody>
</table>
spaceKey | Yes | The space where the current page is located | The unique space identifier, to determine where the new page will be created when someone uses this macro to create a page.

Title | No | (None) | The title for pages created using this macro. You can include @currentDate, @spaceName and @spaceKey variables in the title. This title will override any title specified in a blueprint template.

### Storage format example

This example specifies a user-created template:

```xml
<ac:structured-macro ac:name="create-from-template">
  <ac:parameter ac:name="templateId">299630593</ac:parameter>
  <ac:parameter ac:name="buttonLabel">Blitz test</ac:parameter>
  <ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="DOCTHEME"/>
  </ac:parameter>
  <ac:parameter ac:name="templateName">299630593</ac:parameter>
</ac:structured-macro>
```

This example uses a blueprint:

```xml
<ac:structured-macro ac:name="create-from-template">
  <ac:parameter
  ac:name="blueprintModuleCompleteKey">com.atlassian.confluence.plugins.confluence-shared-files-plugin:file-list-blueprint</ac:parameter>
  <ac:parameter ac:name="buttonLabel">Shared files</ac:parameter>
  <ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="DOCTHEME"/>
  </ac:parameter>
  <ac:parameter ac:name="TemplateName">com.atlassian.confluence.plugins.confluence-shared-files-plugin:file-list-blueprint</ac:parameter>
</ac:structured-macro>
```

### Wikimarkup

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

### Create Space Button Macro

The Create Space Button macro displays a create space icon that links to the ‘Create Space’ page. To see this icon, viewers need the ‘Create Space’ permission which is assigned by a site administrator.

#### Using the Create Space Button macro

**To add the Create Space Button macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.
Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Icon Size size</td>
<td>large</td>
<td>Specify whether to use large or small icon. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• large</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• small</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: create-space-button

Macro body: None.

The following additional parameters are available in storage format and wikimarkup.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>Natural size of icon (1:1 pixel ratio)</td>
<td>The width of the icon to be displayed, specified in pixels. Confluence will stretch or shrink the width of the icon to the number of pixels specified. Note: This parameter is not available via the macro browser.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>Natural size of icon (1:1 pixel ratio)</td>
<td>The height of the icon to be displayed, specified in pixels. Confluence will stretch or shrink the height of the icon to the number of pixels specified. Note: This parameter is not available via the macro browser.</td>
</tr>
</tbody>
</table>
Excerpt Include Macro

The Excerpt Include macro is used to display ‘excerpted’ (that is, a segment of) content from one page in another.

Before you can use this macro, the excerpt must have been defined using the **Excerpt macro**. Note that you can have more than one Excerpt Include macro on a page (although you can have only one Excerpt macro on a page).

**Example**

The paragraph below shows an example of an Excerpt Include macro, containing content from an excerpt which we have defined on the **Excerpt Macro** page. On the Excerpt Include macro below, we have set the options to show both the title of the page and the panel surrounding the content.

---

### Excerpt Macro

Define a part of a page as the page’s ‘excerpt’ which can then be displayed in another page.

---

**Using the Excerpt Include Macro**

To add the Excerpt Include macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

---
Type the name of the page that contains the excerpt to be displayed. You can use an excerpt from a page in the same space or another space in the same wiki.

When you type the name of the page into the Excerpt Include macro dialog, Confluence will offer a list of matching pages, including those from other spaces.

Alternatively, you can type the space key followed by a colon (:) and the page name, like this:

```
SPACEKEY:Page name
```

This parameter is unnamed in wikimarkup.

Determines whether Confluence will display a panel around the excerpted content. The panel includes the title of the page containing the excerpt, and the border of the panel. By default, the panel and title are shown.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** excerpt-include

**Macro body:** None.

**Storage format example**

```xml
<ac:macro ac:name="excerpt-include">
    <ac:parameter ac:name="nopanel">true</ac:parameter>
    <ac:default-parameter>My page name</ac:default-parameter>
</ac:macro>
```

**Wikimarkup example**

```
{excerpt-include:My page name|nopanel=true}
```

**Excerpt Macro**

The Excerpt macro is used to mark a part of a page's content for re-use. Defining an excerpt enables other macros, such as the Excerpt Include and Blog Posts macros, to display the marked content elsewhere.

You can only define one excerpt per page. In other words, you can only add the Excerpt macro once to a page.
Using the Excerpt Macro

To add the Excerpt macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type \ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

To add reusable content to the macro:

1. Add your content inside the Excerpt macro placeholder.
2. Choose the macro placeholder to see the options panel, and select the option to Display on new line or to Display inline. The default is to display the content of the macro on a new line. If you choose the inline option, the content of the macro will form part of the same paragraph as the text preceding and following it. Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused.

Screenshot: The Excerpt macro placeholder and options panel

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Excerpted Content (hidden)</td>
<td>false</td>
<td>Controls whether the page content contained in the Excerpt macro placeholder is displayed on the page. Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: excerpt

Macro body: Accepts rich text.
The following additional parameter is available in storage format and wikimarkup. It performs the same function as the options panel in the editor.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| atlassian-macro-output-type     | No       | BLOCK    | Determines whether the content of the Excerpt macro body is displayed on a new line or inline. Available values:  
- **BLOCK** – Displays the content of the macro on a new line.  
- **INLINE** – Displays the content of the macro as part of the same paragraph as the text preceding and following it.  
Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused. |

**Storage format example**

```xml
<ac:structured-macro ac:name="excerpt">
  <ac:parameter ac:name="hidden">true</ac:parameter>
  <ac:parameter ac:name="atlassian-macro-output-type">BLOCK</ac:parameter>
  <ac:rich-text-body>
    <p>This is the <strong>text</strong> I want to reuse in other pages. This text is inside an Excerpt macro.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Wikimarkup example**

```
{excerpt:hidden=true|atlassian-macro-output-type=BLOCK}
This is the *text* I want to reuse in other pages. This text is inside an Excerpt macro.
{excerpt}
```

Expand Macro

The Expand macro displays an expandable/collapsible section of text on your page.  

Here is an example:

Expand me...

This text is hidden until you expand the section.

***Using the Expand Macro***

To insert the Expand macro into a page using the macro browser:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Click here to expand...</td>
<td>Defines the text that appears next to the expand/collapse icon.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** expand

**Macro body:** Accepts rich text.

**Storage format example**

```xml
<ac:structured-macro ac:name="expand">
  <ac:parameter ac:name="title">Expand me...</ac:parameter>
  <ac:rich-text-body>
    <p>This text is hidden until you expand the section.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Wikimarkup example**

```wikimarkup
{expand:This is my message}
This text is _hidden_ until you expand it.
{expand}
```

**Notes**

- **Text is expanded in PDF and HTML exports.** When you export the page to PDF or HTML, the text between the macro tags is expanded so that readers can see it in the PDF and HTML versions of the page.
- **Nesting your Expand macros.** You can put one Expand macro inside another, and Confluence will correctly show and hide the contents of all Expand macros, including the nested ones.

**Favourite Pages Macro**

Use the Favourite Pages macro to display a list of your favourite pages.

The output of the Favourite Pages macro appears as in the following screenshot.

**Screenshot: The Favourite Pages Macro in Confluence**
Using the Favourite Pages Macro

To insert the favourite pages macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

There are no parameters for this macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: favpages

Macro body: None.

Parameters: None.

Storage format example

<ac:structured-macro ac:name="favpages"/>

Wiki markup example

{favpages}

Gadget Macro

Gadgets are small applications that can offer dynamic content. They are typically served from a web application server and can be re-used in many other web applications. In Confluence, use the Gadget macro to add gadgets to pages or blog posts.

Confluence comes bundled with a few of its own gadgets that you can add to your pages or blog posts. The Confluence gadgets are listed in Confluence Gadgets. However, you can access additional gadgets in this list if your Confluence Administrator has:

- Installed additional gadgets in Confluence (typically as a Confluence plugin) or
- Registered gadgets served from an external web application or website (such as those from a JIRA installation or iGoogle).
Unlike other macros, the name of each gadget macro is unique and follows the convention "<gadget-name>macro", where <gadget-name> is the name supplied by the gadget itself.

Inserting gadgets into a Confluence page or blog post

To add a gadget to a page:

1. Edit your page or blog post.
2. Choose Insert > Other Macros.
3. Click External Content to see a list of gadgets configured for use in your Confluence installation. (Some Confluence macros like the JIRA Issues, RSS Feed, and Widget Connector macros also appear in this category because they can also access external content.)
4. Click the desired gadget to access its parameters and properties. Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the macro dialog. Each gadget may also have its own set of parameters, which appear on the left of the macro dialog.
5. Set the parameters to your requirements.
6. Click Refresh to preview your changes.
7. Click Insert to add the gadget to the page.

Editing gadgets on a Confluence page or blog post

To edit an existing gadget on a page or blog post:

1. Edit your page or blog post.
2. Click the Gadget macro placeholder and choose Edit (or double-click the placeholder).
3. Set the gadget's parameters to your requirements.
4. Click Refresh to preview your changes.
5. Save the gadget.

Standard gadget parameters

Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the macro dialog. Each gadget may also have its own set of parameters, which appear on the left of the macro dialog.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Width     | 450 pixels | Set the width of the gadget, using one of the following conventions:  
- Width in pixels, using px or plain numbers. For example, 500px or 500  
- A percentage of the page width, using %. For example, 50%  
- Automatic resizing of the gadget to fit 100% of the page width: auto |
| Border    | true    | Places a thin grey border around the gadget. |

Contents of a Gadget macro

In the addition to the standard parameters, the gadget macro contains 'parameter-like' content, which represents specific property settings that are particular to each gadget. Hence they are not documented here. Typically, this content would only be changed by customising the gadget's default properties using the macro browser.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

**Macro name:** gadget

**Macro body:** None.

The following additional parameters are available in storage format and wikimarkup.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>url</td>
<td>Yes</td>
<td>(none)</td>
<td>This is the location of the gadget specification (XML file).</td>
</tr>
<tr>
<td>preferences</td>
<td>No</td>
<td>(Gadget-dependent)</td>
<td>Specific property settings that are particular to each gadget.</td>
</tr>
</tbody>
</table>

**A note about editing a gadget's properties (preferences) in markup:** It is possible to edit the values of these properties directly in the wiki markup or storage format. However, this will allow the entry of invalid values. If a gadget property supports a certain set of values, the macro browser will restrict the user to selecting only valid values for that property. For that reason, we recommend that you use the macro browser to edit a gadget's properties.

**Storage format example**

This example shows the Confluence Page gadget:

```xml
<ac:structured-macro ac:name="gadget">
  <ac:parameter ac:name="width">500</ac:parameter>
  <ac:parameter ac:name="border">false</ac:parameter>
  <ac:parameter ac:name="url">rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-page-gadget/gadgets/confluence-page-gadget.xml</ac:parameter>
  <ac:parameter ac:name="preferences">spaceName=Documentation&spaceKey=DOC&quickfind-space=Documentation&pageId=753666&pageName=Documentation%20Home&quickfind-page=Documentation%20Home&isEditable=true&isConfigured=true&refresh=15&amp;showLink=false</ac:parameter>
</ac:structured-macro>
```

This example shows the Confluence News gadget:

```xml
<ac:structured-macro ac:name="gadget">
  <ac:parameter ac:name="url">rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-news-gadget/gadgets/confluence-news-gadget.xml</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

This example shows the Confluence Page gadget:
This example shows the Confluence News gadget:

Gallery Macro

The Gallery macro displays a collection of thumbnail images in a table, based on the images attached to a Confluence page. When viewing the page, a user can click a thumbnail image to zoom into a screen-sized image and then view the images as a slide show.

Overview:

- The images shown in the gallery are taken from the files attached to the Confluence page. You can also specify a different page where the attachments are located. For information about attaching images to a page, see Attaching Files to a Page.
- The captions below the images are drawn from the comments on the attachments. For information about adding comments to attachments, see Attaching Files to a Page.
- By default, the gallery will include all the images attached to the page. You can also exclude or include images using parameters.
- You can sort your images into a particular order.
- You can specify a title for the gallery and also configure how many columns you want for the table in which your images are displayed.

Illustration: Live example of the Gallery macro

Some office photos, and a waterfall
Using the Gallery macro

To insert the Gallery macro onto a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

The full list of parameters is shown in the following table. If the name of an attached file or page contains a comma, you can refer to it in the relevant parameters below by enclosing it in single or double quotes, for example "this,that.jpg", theother.png

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gallery Title</td>
<td>Nothing</td>
<td>Specify a title for your gallery.</td>
</tr>
<tr>
<td>(title)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of Columns</td>
<td>4</td>
<td>Specify the number of columns for your table.</td>
</tr>
<tr>
<td>(columns)</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Images to Exclude</strong> (exclude)</td>
<td>No exclusions. Include all the pictures on the page.</td>
<td>The gallery will ignore any pictures specified. You can specify more than one picture, separated by commas. Note: The filename and filetype for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Include these Images Only</strong> (include)</td>
<td>Include all the pictures on the page.</td>
<td>If you specifically include one or more pictures, the gallery will show only those pictures. You can specify more than one picture, separated by commas. Note: The filename and filetype for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
<tr>
<td><strong>Exclude Images with these Labels</strong> (excludeLabel)</td>
<td>No exclusions. Include all the pictures on the page.</td>
<td>The gallery will ignore any pictures that have the specified label. You can specify more than one label, separated by commas. For information on labelling the attachments, see Adding Labels.</td>
</tr>
<tr>
<td><strong>Include Images with these Labels Only</strong> (includeLabel)</td>
<td>None. The images are not filtered by label.</td>
<td>Filters the images to display, based on a list of labels. If you wish to enter more than one label, separate the labels with commas. Confluence will show only images that have all the labels specified. (The match is an AND, not an OR.) For information on labelling the attachments, see Adding Labels.</td>
</tr>
<tr>
<td><strong>Use Images in these Pages</strong> (page)</td>
<td>If no page is specified, the gallery macro displays the images attached to the page on which the macro is used.</td>
<td>Specify the title of the page which contains the images you want displayed. You can specify more than one page name, separated by commas. To specify a page in a different space, use the following syntax: SPACEKEY:Page Title</td>
</tr>
</tbody>
</table>
| **Sort Images By** (sort) | None. The sort order is unspecified and therefore unpredictable. | Specify an attribute to sort the images by. Sort order is ascending, unless you select the Reverse Sort parameter (see below). Options are:  
  - **name** – file name.  
  - **comment** – comment linked to the attached file.  
  - **date** – date/time last modified.  
  - **size** – size of the attached file. |
**Reverse Sort** *(reverse)*

| **Off. Sort order is ascending** | Used in combination with the **Sort Images By** parameter above. Use **Reverse Sort** to reverse the sort order, from ascending to descending. Available values in storage format and wikimarkup:
|  |  |
|  |  |
|  |  |
|  |  |

**Image file formats**

You can attach image files of any format to a page. Confluence supports the following image formats in the Gallery macro and when displaying an image on a page:

- gif
- jpeg
- png
- bmp (depending on browser support)

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** gallery

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="gallery">
  <ac:parameter ac:name="title">My holiday pictures</ac:parameter>
  <ac:parameter ac:name="reverse">true</ac:parameter>
  <ac:parameter ac:name="sort">size</ac:parameter>
  <ac:parameter ac:name="page">My page1, ds:Welcome to Confluence</ac:parameter>
  <ac:parameter ac:name="excludeLabel">badlabel1, badlabel2</ac:parameter>
  <ac:parameter ac:name="columns">3</ac:parameter>
  <ac:parameter ac:name="exclude">badpicture.png</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{gallery:title=My holiday pictures|reverse=true|sort=size|page=My page1, ds:Welcome to Confluence|excludeLabel=badlabel1, badlabel2|columns=3|exclude=badpicture.png}
```

**Global Reports Macro**

The Global Reports macro displays a list of links to some reports about content on your site.

These reports include a list of new or updated pages, orphan pages, undefined pages, and RSS feeds for new pages and blog posts.

**Screenshot:** The Global Reports macro
Using the Global Reports Macro

To add the Global Reports macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type \{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width of Table (width)</td>
<td>99%</td>
<td>Specify the width of the table in which the links are displayed, as a percentage of the window width.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: global-reports

Macro body: None.

Storage format example

```ac:structured-macro ac:name="global-reports">
<ac:parameter ac:name="width">50%</ac:parameter>
</ac:structured-macro>
```

Wikimarkup example

```(global-reports:width=50%)```

HTML Include Macro

The HTML Include macro allows you to include the contents of an external HTML file in a Confluence page.

⚠️ CAUTION: Including unknown HTML inside a webpage is dangerous.
Using the HTML Include Macro

To insert the HTML Include macro into a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML Page’s URL (url)</td>
<td>Yes</td>
<td>None</td>
<td>The URL of the page to include.</td>
</tr>
</tbody>
</table>

**Troubleshooting**

- The HTML Include macro will only be available if it has been enabled by your Confluence administrator. Also, your Confluence Administrator can define a whitelist of trusted URLs. You will see an error message on the Confluence page if the included URL is not in the whitelist.
- You can only use the HTML Include macro for pages with absolute links. If you use the macro to include an HTML page that has relative links, navigating those links in the wiki results in a 'Page Not Found' error. See CONF-6567.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** html-include

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="html-include">
    <ac:parameter ac:name="url">
        <ri:url ri:value="http://www.example.com"/>
    </ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```xml
{html-include:url=http://www.example.com}
```

HTML Macro

---

HTML can contain active scripting components. This means that it would be possible for a malicious attacker to present a user of your site with script that their web browser would believe came from you. Such code could be used, for example, to steal a user’s authentication cookie and give the attacker their Confluence login password.
The HTML macro allows you to add HTML code to a Confluence page.

ℹ️ Note that the HTML macro will only be available if it has been enabled by your System Administrator.

### Using the HTML Macro

#### To add the HTML macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

#### Speeding up macro entry with autocomplete:
Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

#### To edit an existing macro:
Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

There are no parameters for this macro.

Enter the HTML code into the body of the macro placeholder.

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** `html`

**Macro body:** Text, consisting of HTML code.

**Parameters:** None.

#### Storage format example

```
<ac:structured-macro ac:name="html">
  <ac:plain-text-body><![CDATA[<a href="http://www.atlassian.com">Click here</a> to see the <b>Atlassian</b> website.]]></ac:plain-text-body>
</ac:structured-macro>
```

#### Wikimarkup example

```
(html){html}<a href="http://www.atlassian.com">Click here</a> to see the <b>Atlassian</b> website.(html)
```

### IM Presence Macro

The IM Presence macro indicates graphically when a contact is signed into an Instant Messaging (IM) service. The IM Presence macro appears as a small icon on the page.

### Using the IM Presence Macro

#### To add the IM Presence macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

#### Speeding up macro entry with autocomplete:
Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

#### To edit an existing macro:
Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**
Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User ID/Screen Name</td>
<td>Identify the user by their ID, account name or screen name.</td>
</tr>
<tr>
<td>Service (service)</td>
<td>aim – AOL Instant Messenger</td>
</tr>
<tr>
<td></td>
<td>gtalk – Google Talk</td>
</tr>
<tr>
<td></td>
<td>icq – ICQ</td>
</tr>
<tr>
<td></td>
<td>jabber – Jabber</td>
</tr>
<tr>
<td></td>
<td>msn – MSN Instant Messenger</td>
</tr>
<tr>
<td></td>
<td>sametime – IBM Lotus Sametime</td>
</tr>
<tr>
<td></td>
<td>skype – Skype. Note: Skype requires 'Show my status on the web' to be checked under 'Privacy' preferences</td>
</tr>
<tr>
<td></td>
<td>skypeme – Skype</td>
</tr>
<tr>
<td></td>
<td>wildfire – Openfire Server</td>
</tr>
<tr>
<td></td>
<td>yahoo – Yahoo! Messenger</td>
</tr>
<tr>
<td>Show User ID (showid)</td>
<td>Shows or hides the User ID of the contact.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** `im`

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="im">
  <ac:parameter ac:name="showid">false</ac:parameter>
  <ac:parameter ac:name="service">skype</ac:parameter>
  <ac:parameter ac:name="">MySkypeName</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{im:MySkypeName|service=skype|showid=false}
```

**Include Page Macro**

You can use the Include Page macro to display the contents of one Confluence page or blog post in another page or blog post.

**Using the Include Page Macro**

To add the Include Page macro to a page:
1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Page to Include      | None    | This is the name of the Confluence page or blog post that you want to include in the current page. Start typing a page title, and Confluence will suggest matching pages from the current space and other spaces. Alternatively you can specify the page as follows:  
  - If the page or blog post is located in another space, add the space key and a colon in front of the page name. For example, DOC:My page name. The space key is case sensitive.  
  - To include a blog post, specify the date as well as the title of the blog post. For example: /2010/12/01/My blog post.  
  - You can include pages from personal spaces using `~username` as the space key, where 'username' is the person's username. For example, ~jsmith:My page name. |

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** `include`

**Macro body:** None.

**Storage format example**
Wiki markup example

{include:DOC:My chocolate page}

Notes

- If you want to include part of a page rather than the whole page, use the Excerpt and Excerpt Include macros.
- To display a page's contents, you need 'View' permission for that page. Similarly, people who view the page will need 'View' permissions for the embedded page as well as the page into which it is embedded. See space permissions or contact your Confluence space administrator for more information.
- If you want to embed an external page into a Confluence page, you need the HTML Include Macro.

Sample Include Page

Start of sample page content

End of sample page content

Info Macro

The Info macro allows you to highlight helpful information on a Confluence page. It creates a blue-coloured box surrounding your text, as shown below.

Info Macro Example
This text is rendered inside the info macro.

Using the Info Macro

To add the Info macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type \{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
## Parameter

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title (title)</td>
<td>none</td>
<td>The title of the information box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>Show Information Icon (icon)</td>
<td>true</td>
<td>If &quot;false&quot;, the icon will not be displayed.</td>
</tr>
</tbody>
</table>

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name: info**

**Macro body:** Accepts rich text.

**Storage format example**

The following example shows all parameters and a body:

```xml
<ac:structured-macro ac:name="info">
    <ac:parameter ac:name="icon">false</ac:parameter>
    <ac:parameter ac:name="title">This is my title</ac:parameter>
    <ac:rich-text-body>
        <p>
            <span>This is </span> <em>important</em> <span> information.</span>
        </p>
    </ac:rich-text-body>
</ac:structured-macro>
```

Below are some examples of the Info macro with various optional parameters used.

<table>
<thead>
<tr>
<th>Description</th>
<th>Markup</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| Info macro with a body defined and no optional parameters | <ac:structured-macro ac:name="info">
  <ac:rich-text-body>
    <p>This is <em>important</em> information.</p>
  </ac:rich-text-body>
</ac:structured-macro> | ![This is important information.](image) |
Info macro with a body and an optional Title parameter defined

```
<ac:structured-macro ac:name="info">
  <ac:parameter ac:name="title">This is my title</ac:parameter>
  <ac:rich-text-body>
    <p>This is <em>important</em> information.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

Info macro with a body and optional Title and Icon parameters defined

```
<ac:structured-macro ac:name="info">
  <ac:parameter ac:name="icon">false</ac:parameter>
  <ac:parameter ac:name="title">This is my title</ac:parameter>
  <ac:rich-text-body>
    <p>This is <em>important</em> information.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

Wiki markup example

```
{info:title=This is my title|icon=false}
This is _important_ information.
{info}
```

JIRA Chart Macro

JIRA is Atlassian’s issue tracking and project management system. By adding the JIRA Chart macro to a Confluence page, you can display information about JIRA issues and projects as pie charts.

Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links. People viewing the page will see charts for publicly accessible issues from the JIRA site. If your JIRA site has restricted viewing (that is, people need permission to view issues) then they will need to authenticate before seeing the
charts. This macro is compatible with JIRA 5.x and later.

**Adding the JIRA Chart macro to a page**

Quick guide to using the macro on a Confluence page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Using the JIRA Chart Macro**

**To add a JIRA chart to your page:**

1. Insert the JIRA Chart macro (see above).
2. Select your JIRA server.
   - If you have multiple JIRA instances linked to Confluence the drop down will default to the primary application link.
3. Search for issues - you can enter the query in JQL or paste a JIRA URL directly into the search field.
4. Choose **Preview** to see the chart.
5. Choose **Insert**.

To find out more about searching for issues see **Displaying issues via a JIRA Query Language (JQL) search**.

You can further control how the chart appears on your page. Choose **Display options**:

- **Chart by** - select the JIRA field you want to segment the pie chart by.
- **Width** - define the total width of the chart area. You can enter values in pixels or percent. Leave blank to auto fit.
- **Show border** - add a border around the chart area
- **Show chart information** - include a text summary under the chart with the total issues count and chart by value.

**Screenshot: The JIRA Chart Macro in the macro browser**

**Disabling the JIRA Chart macro**
The functionality is provided by an add-on (plugin) called 'JIRA Macros'. This macro is also used for the JIRA Issues macro. To make the macro unavailable on your site, you can disable the add-on. See Disabling and enabling add-ons.

**Notes**

**HTTPS**: The JIRA Chart macro can access a JIRA site running under SSL provided the Confluence server is configured to accept the JIRA SSL certificate. See Connecting to LDAP or JIRA or Other Services via SSL.

**Authentication**: If the query includes issues that require authentication (issues that are not visible to anonymous users in JIRA), users will be prompted to authenticate to view charts on the Confluence page. In order to search for issues in the macro browser you may need to authenticate. With JIRA 5.x you will be able to search for unrestricted issues as an anonymous user, however with JIRA 6.x you must be authenticated to search for any issues.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: jirachart

Macro body: None.

The following parameters are available in storage format.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>chartType</td>
<td>Yes</td>
<td>Pie</td>
<td>Type of chart to display. Currently Pie is the only available chart type. Other types may be added in future.</td>
</tr>
</tbody>
</table>
| statType       | Yes      | Statuses | The JIRA field to segment the pie chart by:  
• statuses - displays a breakdown of issues by Status.  
• allFixfor - displays a breakdown of issues by chart by all Fix Versions (useful if issues have more than one fix version).  
• assignees - displays a breakdown of issues by the Assignee name.  
• priorities - displays a breakdown of issues by Priority.  
• components - displays a breakdown of issues by Component.  
• issuuetype displays a breakdown of issues by Issue Type. |

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
showinfor | No | False | Displays text information about the data below the chart. Includes the Total value and the Chart By value.

jql | Yes | | JQL query for the chart to display.

width | 600 | (blank) | This is the total width of the chart area. Width can be entered in pixels, percent or left blank to fit to the available space.

border | No | False | Displays a border around the chart area.

Storage format example

Example chart by Issue Type - note that Confluence will insert the server and serverId parameters, based on settings in Application Links:

```xml
<ac:structured-macro ac:name="jirachart">
  <ac:parameter ac:name="chartType">pie</ac:parameter>
  <ac:parameter ac:name="statType">issuetype</ac:parameter>
  <ac:parameter ac:name="showinfor">true</ac:parameter>
  <ac:parameter ac:name="jql">project%20%3D%20CONF%20and%20fixVersion%20in%20('5.3')</ac:parameter>
  <ac:parameter ac:name="width">600</ac:parameter>
  <ac:parameter ac:name="server">JAC</ac:parameter>
  <ac:parameter ac:name="serverId">144880e9-a353-312f-9412-ed028e8166fa</ac:parameter>
  <ac:parameter ac:name="border">true</ac:parameter>
</ac:structured-macro>
```

JIRA Issues Macro

**JIRA** is the issue tracking and project management system supplied by Atlassian. By adding the JIRA Issues macro to a Confluence page, you can display one or more issues from a JIRA site. You can also choose to create an issue in JIRA, at the time of adding the macro to the Confluence page.

Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links. People viewing the page will see the publicly accessible issues from the JIRA site. If your JIRA site has restricted viewing (that is, people need permission to view issues) then they will need to authenticate before seeing the restricted issues. See more about restricted JIRA issues below.

**What you can do with the JIRA Issues macro**

Using the JIRA Issues macro, you can:

- Display a table of JIRA issues on your page, based on the results of a search using JIRA Query Language (JQL).
- Display a table of JIRA issues onto your page, using a JIRA URL.
- Display a single issue from the JIRA site, or a subset of selected issues from your JIRA search results.
- Display a count of issues from the JIRA site.
- Create new issues in JIRA and display the issues on your page without leaving Confluence.

**Adding and updating the JIRA Issues macro – an overview**

Quick guide to using the macro on a Confluence page:
In the Confluence editor, choose **Insert > Other Macros**.

2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Screenshot: Example of JIRA issues macro on a Confluence page

<table>
<thead>
<tr>
<th>Key</th>
<th>Summary</th>
<th>T</th>
<th>P</th>
<th>Status</th>
<th>Resolution</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONF-30894</td>
<td>User is not prompted before overwriting changes of another user if attempting to save after an editor error is thrown</td>
<td>Oct 22, 2013</td>
<td>↑</td>
<td>RESOLVED</td>
<td>Fixed</td>
</tr>
<tr>
<td>CONF-30886</td>
<td>TableOfContents Macros navigation is not working in Firefox 23 x / 24 x and Opera 12.16</td>
<td>Sep 24, 2013</td>
<td>↓</td>
<td>RESOLVED</td>
<td>Fixed</td>
</tr>
<tr>
<td>CONF-30663</td>
<td>Left panel overlaps custom banner in Chrome</td>
<td>Sep 23, 2013</td>
<td>↓</td>
<td>RESOLVED</td>
<td>Fixed</td>
</tr>
<tr>
<td>CONF-30690</td>
<td>Dashboard popular stream won't render when it contains content from an anonymous user</td>
<td>Sep 19, 2013</td>
<td>↑</td>
<td>RESOLVED</td>
<td>Fixed</td>
</tr>
</tbody>
</table>

4 issues  ![Refresh](refresh.png)

### Displaying issues via a JIRA Query Language (JQL) search

You can use the macro to display a table of JIRA issues on your page, based on the results of a search using JIRA Query Language (JQL).

JQL is a simple query language, similar to SQL, which works in JIRA. A basic JQL query consists of a field, followed by an operator (such as = or >), followed by one or more values or functions.

Examples:

- The following query will find all issues in the ‘TEST’ project:

  ```jql
  project = "TEST"
  ```

- The following query will find all issues in the ‘documentation’ component of the ‘CONF’ project:

  ```jql
  project = CONF and component = documentation
  ```

For more information about JQL syntax, see the JIRA documentation: Advanced Searching.

### To display a table of issues based on a JQL search:

1. Insert the JIRA Issues macro onto your Confluence page, as described above.
2. Choose a JIRA server next to the **Search** button.
3. If prompted, log in to the JIRA server.
4. Enter the JQL query into the **Search** box.
5. Choose **Search**.
6. If you want to customise the display, choose **Display options** and adjust the columns and number of issues that will appear in your table of issues.
7. Choose **Insert**.

**Screenshot: Display options in the JIRA Issues macro browser.**
Displaying issues via a JIRA URL

You can paste any of the following JIRA URLs into the JIRA Issues macro. Confluence will immediately convert the URL to a JQL search.

- Any URL for a JIRA issue search or filter.
- A URL for a single issue.
- The URL of the XML view of a JIRA search.

Auto-convert: You can paste a JIRA URL directly into the Confluence editor (without calling up the macro browser). Confluence will automatically convert the URL into a JIRA Issues macro.

Displaying a single JIRA issue, or selected JIRA issues

To display a single JIRA issue, choose one of the following methods:

- Paste the URL of the issue directly onto the Confluence page. (There is no need to use the macro browser.) Confluence will auto-convert the link to a JIRA Issues macro.
- Or: Add the JIRA issues macro to the page as described above, and choose Recently Viewed to see the JIRA issues you have visited recently. Select an issue and choose Insert.
- Or: Add the JIRA issues macro to the page as described above, and past the issue URL into the search box in the macro browser.
- Or: Add the JIRA issues macro to the page, define your search criteria in the macro browser via JQL as described above, then select the check box next to the issue in the search results, within the macro browser.

You can display a single issue in a simple format with only its description and status, or in table form.

To display a subset of JIRA issues from your search results:

1. Add the JIRA issues macro to the page.
2. Define your search criteria in the macro browser via JQL, as described above.
3. Select the check boxes next to the required issues in the search results, within the macro browser.

**Screenshot: Selecting a subset of issues to display**

### Displaying a count of issues

You can choose to display the number of issues returned by your search, rather than a table of issues. The JIRA Issues macro will display a count of issues, linked to the search in JIRA.

**Screenshot: The JIRA Issues macro displaying an issue count on a Confluence page**

To display an issue count:

1. Add the JIRA issues macro to the page.
2. Define your search criteria in the macro browser via JQL, as described above.
3. Choose **Display options**, then choose **Total issue count** next to ‘Display options’ in the macro browser.
4. Choose **Insert**.

### Creating a new JIRA issue in the editor

While editing a Confluence page, you can create an issue in JIRA and display it on your Confluence page, without leaving the Confluence editor.

To **insert an issue into JIRA**:

1. Add the JIRA Issues macro to the page, as described above.
2. Choose **Create New Issue**.
3. Supply the information about your JIRA server, project, and issue, as prompted.
4. Choose **Insert**.

Confluence will send a request to JIRA, to add the issue to the JIRA site. Confluence will also display the resulting JIRA issue on the Confluence page.

**Limitations**

The JIRA Issues macro will notify you if it is unable to create an issue in the selected project. This may be because the project has a required field, field configuration or other customisation that is not supported by the JIRA Issues macro. In this situation you will need to create the issue directly in JIRA.

**Configuring Application Links to display restricted JIRA issues**

Before you can use this macro, your Confluence and JIRA sites must be connected via [Application Links](#).

If the JIRA site allows anonymous viewing of issues, you must configure an application link, but there is no need to configure any incoming or outgoing authentication between JIRA and Confluence. People viewing the Confluence page will see the publicly accessible issues from the JIRA site.

If your JIRA site has restricted viewing, or if some JIRA projects or issues are restricted to viewing by certain people, then people will need to log in before seeing the restricted issues.

In such a case, the **outgoing authentication** in the Confluence Application Links determines how the JIRA Issues macro handles restricted issues:

- If the outgoing authentication is set to [Trusted Applications](#), people can see restricted issues in JIRA if their username is the same in JIRA and Confluence, and if they have permission in JIRA to see the issue.
- If the outgoing authentication is set to [OAuth](#), people may need to choose [Login & Approve](#), to gain access to the JIRA server and restricted issues.
- If the outgoing authentication is set to [Basic Access](#), people can see the JIRA issues that are visible to the user account configured in JIRA's **outgoing authentication** setting.

**Rendering HTML from JIRA**

Formatted fields from JIRA can be displayed in Confluence if you set up a Confluence-to-JIRA application link. Otherwise, such formatted fields will be escaped within the output of the JIRA issues macro. This is to prevent the possibility of malicious HTML being served by an untrusted JIRA server. The most likely field where you will notice this is in the description field.

This example shows how a description column may be displayed in JIRA:

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>This is</strong></td>
</tr>
<tr>
<td>• the description</td>
</tr>
<tr>
<td>• of my issue</td>
</tr>
</tbody>
</table>

If there is no application link between JIRA and Confluence, the description will appear in the JIRA issues macro like this:

<p>This is<ul><li>the description</li><li>of my issue</li></ul></p>

**Disabling the JIRA Issues macro**

The functionality is provided by an add-on (plugin) called 'JIRA Macros'. To make the macro unavailable on your site, you can disable the add-on. See [Disabling and enabling add-ons](#).

**Notes**

**HTTPS**: The JIRA Issues macro can access a JIRA site running under SSL provided the Confluence server is configured to accept the JIRA SSL certificate. See [Connecting to LDAP or JIRA or Other Services via SSL](#).

Custom fields can be added as columns to the table simply by using the name of the field with no quotes. Earlier versions of the macro required you to use the custom field id, e.g. `customfield_10100`.
**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** jiraissues

**Macro body:** None.

Note: A number of additional parameters that are not available via the macro browser are available in storage format and wikimarkup.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>anonymous</td>
<td>No</td>
<td>false</td>
<td>If this parameter is set to 'true', JIRA will return only the issues which allow unrestricted viewing. That is, the issues which are visible to anonymous viewers, as determined by JIRA's viewing restrictions. If this parameter is omitted or set to 'false', then the results depend on how your administrator has configured the communication between JIRA and Confluence. By default, Confluence will show only the JIRA issues which the user is authorised to view. <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
</tr>
<tr>
<td>baseurl</td>
<td>No</td>
<td>The value of the 'url' parameter</td>
<td>If you specify a 'baseurl', then the link in the header, pointing to your JIRA site, will use this base URL instead of the value of the 'url' parameter. This is useful when Confluence connects to JIRA with a different URL from the one used by other users.</td>
</tr>
</tbody>
</table>
| columns   | No | By default, the following columns are shown:  
|-----------|----|---------------------------------------------------------------|
|           |    |   - type  
|           |    |   - key  
|           |    |   - summary  
|           |    |   - assignee  
|           |    |   - reporter  
|           |    |   - priority  
|           |    |   - status  
|           |    |   - resolution  
|           |    |   - created  
|           |    |   - updated  
|           |    |   - due  
|           |    | A list of JIRA column names, separated by semi-colons (;). You can include any columns recognised by your JIRA site, including custom columns. See the [JIRA documentation](#) for a list of names. |
| count     | No | false  
| cache     | No | on  
|           |    | If this parameter is set to 'true', the issue list will show the number of issues in JIRA. The count will be linked to your JIRA site.  
|           |    | The macro maintains a cache of the issues which result from the JIRA query. If the 'cache' parameter is set to 'off', the relevant part of the cache is cleared each time the macro is reloaded. (The value 'false' also works and has the same effect as 'off'.)  
<p>|           |    | <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>height</strong></td>
<td>No</td>
<td>480 (if render mode is dynamic)</td>
</tr>
<tr>
<td><strong>renderMode</strong></td>
<td>No</td>
<td>static</td>
</tr>
</tbody>
</table>

The height in pixels of the table displaying the JIRA issues. Note that this height specification is ignored in the following situations:

- If the 'renderMode' parameter (see below) is set to 'static'.
- When the JIRA issues are displayed in a PDF or Word document, in an email message or in an RSS feed.

**Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.

If the value is 'dynamic', the JIRA Issues macro offers an interactive display which people can manipulate as follows:

- Click the column headers to sort the output.
- Drag and drop the columns into a different order.
- Temporarily remove a column from the display.
- View a page of issues at a time, for faster response times.

A value of 'static' will disable the dynamic display features.

**Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td></td>
<td>You can customise the title text at the top of the JIRA issues table with this parameter. For instance, setting the title to 'Bugs-to-fix' will replace the default 'JIRA Issues' text. This can help provide more context to the list of issues displayed. <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
</tr>
<tr>
<td>url</td>
<td>Yes</td>
<td>none</td>
<td>The URL of the XML view of your selected issues in JIRA Issue Navigator. <strong>Note:</strong> If the URL in the 'url' parameter does not contain a <code>tempMax</code> argument, then the value of <code>tempMax</code> will default to 500. If your JIRA server is version 3.12 or earlier, this means that the JIRA Issues macro will return a maximum of 500 issues. If your JIRA server is version 3.13 or later, a value of 500 means that the JIRA Issues macro will return a maximum of 500 issues per page.</td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td>100%</td>
<td>The width of the table displaying the JIRA issues. Can be indicated either as a percentage (%) or in pixels (px). <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
</tr>
</tbody>
</table>
Example using a URL that points to the XML view of a JIRA search:

```
<ac:structured-macro ac:name="jiraissues">
  <ac:parameter ac:name="anonymous">true</ac:parameter>
  <ac:parameter ac:name="columns">type;key;summary</ac:parameter>
  <ac:parameter ac:name="url">
    <ri:url ri:value="http://jira.atlassian.com/sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml?jqlQuery=project+%3D+CONF+AND+%28summary+%7E+jiraissues+OR+description+%7E+jiraissues+OR+comment+%7E+jiraissues%29&tempMax=10"/>
  </ac:parameter>
</ac:structured-macro>
```

Example using JQL – note that Confluence will insert the server and serverId parameters, based on settings in Application Links:

```
<ac:structured-macro ac:name="jira">
  <ac:parameter ac:name="columns">key,summary,type,created,assignee,status</ac:parameter>
  <ac:parameter ac:name="server">Atlassian JIRA</ac:parameter>
  <ac:parameter ac:name="serverId">144880e9-a1111-333f-9412-ed999a9999fa</ac:parameter>
  <ac:parameter ac:name="jqlQuery">project = CONF AND component = documentation AND resolution = unresolved</ac:parameter>
</ac:structured-macro>
```

Wikimarkup example

```
{jiraissues:anonymous=true|url=http://jira.atlassian.com/sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml?jqlQuery=project+%3D+CONF+AND+%28summary+%7E+jiraissues+OR+description+%7E+jiraissues+OR+comment+%7E+jiraissues%29&tempMax=10|columns=type;key;summary|title=My List of Issues}
```

JUnit Report Macro

The JUnit Report macro displays a summary of JUnit test results from a directory accessible by the Confluence server. JUnit is a unit testing framework which allows programmers to ensure that individual units of Java source code are functioning correctly.

For security reasons JUnit test result files can only be imported from a specified location in the Confluence server's file system. We recommend administrators create a folder in their Confluence home directory, add the system property `confluence.junit.report.directory` and specify the location for JUnit test result files to be imported from. JUnit Test result files cannot be imported from the server until this system property is set.

The JUnit Report macro appears as shown in the screenshot below.

**Screenshot: The JUnit Report macro in Confluence**

<table>
<thead>
<tr>
<th>Test</th>
<th>Time</th>
<th>Messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>MoneyTest</td>
<td>100%</td>
<td>00:03:391</td>
</tr>
<tr>
<td>testAdd</td>
<td></td>
<td>Tests: Failures: 1, Exceptions: 0</td>
</tr>
<tr>
<td></td>
<td>00:03:0</td>
<td></td>
</tr>
</tbody>
</table>
### Using the JUnit Report macro

To add the JUnit Report macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>URL of the test result XML file</td>
<td>Must include either the directory or the url parameter</td>
<td>None</td>
<td>URL of a particular test result XML file. Is overridden by the Directory (URL) of your test result files parameter if you use both.</td>
</tr>
<tr>
<td>(url)</td>
<td></td>
<td></td>
<td>Example, from a Confluence instance: <a href="http://yourConfluenceInstance.com/download/attachments/">http://yourConfluenceInstance.com/download/attachments/</a>&lt;page_id&gt;/file.xml</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For Confluence installations without anonymous user access, you can specify logon credentials as part of this parameter in the form of URL parameters:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• os_username — The username of a Confluence user with permission to access the JUnit test results.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• os_password — The password of the Confluence user specified in the os_username parameter.</td>
</tr>
</tbody>
</table>
Directory (URL) of your test result files (directory)

Must include either the directory or the url parameter

None

URL of a directory containing your test result files. This must be a directory name and not the XML file itself. Overrides the URL of the test result XML file parameter if you use both.

Example, file:///C:/TEMP/
Example, for a network drive: http://*host*/*path*

Report Detail (reportdetail)

No

all

Detail for the report. Can be all, fixture, summary or failuresonly.

Debug (debug)

No

None

Shows the content of failures, as well as the error messages.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: junitreport

Macro body: None.

Storage format example

```xml
<ac:structured-macro ac:name="junitreport">
  <ac:parameter ac:name="reportdetail">summary</ac:parameter>
  <ac:parameter ac:name="directory">
    <ri:url ri:value="http://confluence.com/download/attachments/123/*"/>
  </ac:parameter>
  <ac:parameter ac:name="debug">true</ac:parameter>
  <ac:parameter ac:name="url">
    <ri:url ri:value="http://confluence.com/download/attachments/123/file.xml"/>
  </ac:parameter>
</ac:structured-macro>
```

Wiki markup examples

Loading JUnit reports from a local drive:

```markdown
(junitreport:directory=file:///C:/TEMP/)
```

Loading JUnit reports from a network drive:

```markdown
(junitreport:url=http://*host*/*path*)
```

Loading JUnit reports from a Confluence site:
Loading JUnit reports from a Confluence site that requires authentication:

If your Confluence site is not accessible by anonymous users, specify login credentials with the `os_username` and `os_password` URL parameters (as part of the macro's `url` parameter). In this case, we are specifying a username of 'admin' and a password of 'secret'.

```{junitreport:url=http://yourConfluenceInstance.com/download/attachments/<page id>/file.xml?os_username=admin&os_password=secret}
```

Labels List Macro

The Labels List macro displays a list of all labels within the current space. Each label in the list links to a page that displays all pages in the current space that contain that label.

**Using the Labels List macro**

To add the Labels List macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restrict to this Space Key</strong></td>
<td>No</td>
<td>Current space</td>
<td>The key of the space whose labels you want to display.</td>
</tr>
<tr>
<td>(spaceKey)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Excluded label(s)</strong></td>
<td>No</td>
<td>Blank</td>
<td>The labels that you do not want to appear in the list.</td>
</tr>
<tr>
<td>(excludedLabels)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** listlabels

**Macro body:** None.

**Storage format example**
Livesearch Macro

The Livesearch macro allows you to add a search box to a Confluence page. When users enter a search term into the search box, Confluence will dynamically display matching results as they type.

Using the Livesearch macro

To add the Livesearch macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type \ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restrict to this Space Key (spaceKey)</td>
<td>all spaces</td>
<td>Specify a space key to limit the search to the given space. Case-sensitive.</td>
</tr>
<tr>
<td>Restrict to label(s) (labels)</td>
<td></td>
<td>Specify labels to limit the search to content with that label. If unspecified will search all content regardless of label.</td>
</tr>
<tr>
<td>Size (size)</td>
<td>medium</td>
<td>Choose a medium or large search field size.</td>
</tr>
<tr>
<td>Placeholder text (placeholder)</td>
<td></td>
<td>Specify the placeholder text to appear in the search field, for example ‘Search this space’</td>
</tr>
</tbody>
</table>
Type (type) | all | Specify the content types to be included in the search - choose from pages, blogs, comments, space descriptions, or all content types.
--- | --- | ---
Additional (additional) | space name | Display the space name, a page excerpt or nothing under the search result.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** livesearch

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="livesearch">
  <ac:parameter ac:name="additional">page excerpt</ac:parameter>
  <ac:parameter ac:name="placeholder">Search this space</ac:parameter>
  <ac:parameter ac:name="labels">myLabel</ac:parameter>
  <ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="SS"/>
  </ac:parameter>
  <ac:parameter ac:name="type">page</ac:parameter>
  <ac:parameter ac:name="size">large</ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
{livesearch:spaceKey=DOC|size=large|placeholder=Search this space}
```

**Loremipsum Macro**

The Loremipsum macro displays paragraphs of pseudo-Latin text (more information). You can use this macro to generate more-or-less meaningless text for demonstration purposes in pages showing a draft layout or arrangement of page elements. The text is deliberately non-meaningful so that it does not influence the viewer's perception of the page arrangement or design.

A basic example of the Loremipsum text:

```
```

**Using the Loremipsum macro**

To add the Loremipsum macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.
To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Paragraphs</td>
<td>3</td>
<td>Determines the amount of pseudo-Latin (space-filler) text to display. The macro will display a maximum number of 30 paragraphs. Parameter is unnamed in storage format and wikimarkup.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** loremipsum

**Macro body:** None.

- **Storage format example**

  ```xml
  <ac:structured-macro ac:name="loremipsum">
    <ac:parameter ac:name="">2</ac:parameter>
  </ac:structured-macro>
  ```

- **Wikimarkup example**

  ```wikimarkup
  {loremipsum:2}
  ```

**Multimedia Macro**

Displays videos, animations and more, sourced from a file attached to a Confluence page and displayed on your page. See [Embedding Multimedia Content](#) for more information.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** multimedia

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>page</td>
<td>No</td>
<td>Current page</td>
<td>Name of the page to which the multimedia file is attached.</td>
</tr>
<tr>
<td>parameter</td>
<td>required</td>
<td>current value</td>
<td>description</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
<td>---------------</td>
<td>-------------</td>
</tr>
<tr>
<td>space</td>
<td>No</td>
<td>Current space</td>
<td>Space key of the page that has the multimedia file attached.</td>
</tr>
<tr>
<td>name</td>
<td>Yes</td>
<td>None</td>
<td>File name of the multimedia file, which is attached to a Confluence page.</td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td>If not specified, the browser will determine the width based on the file type.</td>
<td>Width of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's width, or any other value accepted by HTML.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>If not specified, the browser will determine the height based on the file type.</td>
<td>Height of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's height, or any other value accepted by HTML.</td>
</tr>
<tr>
<td>autostart</td>
<td>No</td>
<td>false</td>
<td>If the parameter is set to true then the video or audio file will start playing as soon as the page is loaded. If this option is set to false then the file will not play until the user clicks the icon or image on the page.</td>
</tr>
</tbody>
</table>

**Storage format example**

```xml
<ac:structured-macro ac:name="multimedia">
  <ac:parameter ac:name="width">500</ac:parameter>
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="Ninjas.MOV"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
{multimedia:space=DOC|page=My macros|name=ninjas.swf|autostart=true}
```

**Navigation Map Macro**

The Navigation Map macro displays a navigable map of the pages tagged with a given label.
Using the Navigation Map Macro

To add the Navigation Map macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>none</td>
<td>Specify the label associated with the pages you want to show in the navigation map.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This parameter is unnamed in storage format and wikimarkup.</td>
</tr>
<tr>
<td>Map Title (title)</td>
<td>none</td>
<td>Specify a title for the navigation map.</td>
</tr>
<tr>
<td>Number of Cells Per Row (wrapAfter)</td>
<td>5</td>
<td>Specify the number of cells in a row</td>
</tr>
<tr>
<td>Cell Width (Pixels) (cellWidth)</td>
<td>90 px</td>
<td>Specify the cell width</td>
</tr>
<tr>
<td>Cell Height (Pixels) (cellHeight)</td>
<td>60 px</td>
<td>Specify the cell height</td>
</tr>
<tr>
<td>Navigation Map Theme (theme)</td>
<td>Confluence</td>
<td>Define a theme for the navmap. If you want to create your own navmap 'look and feel' (for example, one with rounded corners), you need to add a customised navmap macro theme file to the WEB-INF/classes/templates/macros directory. The file name convention to use is navmap-mytheme.vm. Use the name of your choice for the mytheme part of the file name, which is also the value you use for this parameter. Hence, if your theme was called navmap-roundededges.vm, use the value of rounded edges for this parameter.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: navmap
**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="navmap">
  <ac:parameter ac:name="wrapAfter">4</ac:parameter>
  <ac:parameter ac:name="title">My map name</ac:parameter>
  <ac:parameter ac:name="cellHeight">50px</ac:parameter>
  <ac:parameter ac:name="theme">navmap-mytheme.vm</ac:parameter>
  <ac:parameter ac:name="cellWidth">80px</ac:parameter>
  <ac:parameter ac:name="mylabel"></ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{navmap:mylabel|wrapAfter=4|title=My map name|cellHeight=50px|theme=navmap-mytheme.vm|cellWidth=80px}
```

**Network Macro**

The Network macro displays a list of Network activity on a Confluence page or blog post. You can specify the user whose network activity you wish to show. These interactions include the users that the specified user is following or users who are following the specified user. The Network macro shows each listed user by their profile picture. It also provides a choice of two themes and the ability to limit the number of users in the list.

**Screenshot: Network macro**

![Network macro example](image)

**Using the Network macro**

**To add the Network macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>wrapAfter</td>
<td></td>
<td></td>
</tr>
<tr>
<td>title</td>
<td></td>
<td></td>
</tr>
<tr>
<td>cellHeight</td>
<td></td>
<td></td>
</tr>
<tr>
<td>theme</td>
<td></td>
<td></td>
</tr>
<tr>
<td>cellWidth</td>
<td></td>
<td></td>
</tr>
<tr>
<td>mylabel</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Username

| Username | Current user's username | The username of the Confluence user whose network interactions you wish to show. If no username is specified, then current user's (that is, your) network interactions are shown. |

### Mode

<table>
<thead>
<tr>
<th>Mode</th>
<th>following</th>
<th>Determines which users are listed, with respect to the specified user:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>• <strong>following</strong> – those who the user is following.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>followers</strong> – those who are following the user.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This parameter is unnamed in storage format and wikimarkup.</td>
</tr>
</tbody>
</table>

### Theme

<table>
<thead>
<tr>
<th>Theme</th>
<th>full</th>
<th>Determines how the user’s network is displayed:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>• <strong>full</strong> – shows a large version of user’s profile pictures and, if the <strong>following</strong> mode is set, provides an entry field function to follow more users.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>tiny</strong> – shows only the small version of user’s profile pictures.</td>
</tr>
</tbody>
</table>

### Maximum Results

| Maximum Results (max) | No limit imposed up to a maximum of 30 | Restricts the number of users displayed. If the number of users exceeds the specified maximum, then a **Show All** link is provided. This link leads to the specified user’s **Network view**, showing the complete list of network interactions. |

---

**Disabling the Network macro**

The Network macro is provided by the 'network' module in the 'Profile Macros' plugin. To remove the macro from your site, you can disable the module in the plugin. See [Disabling and enabling add-ons](#).

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** network

**Macro body:** None.

**Storage format example**

---
Noformat Macro

The Noformat macro displays a block of text in monospace font with no other formatting.

Using the Noformat Macro

To add the Noformat macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type \ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Enter the content that is to be unformatted into the body of the macro placeholder.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Panel (nopanel)</td>
<td>False</td>
<td>Removes the panel around the content.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: noformat

Macro body: Accepts plain text.

Storage format example
Wiki markup example

{(noformat:nopanel=true)http://www.example.com(noformat)}

Note Macro

The Note macro displays a block of text in a yellow highlighted box. This is useful for emphasising important information.

Example:

⚠️ My note
This is the content of my note.

Using the Note Macro

To add the Note macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Add the text of the note to the body of the macro placeholder.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title (title)</td>
<td>none</td>
<td>If specified, the title is displayed in bold next to the icon.</td>
</tr>
</tbody>
</table>
| Show Exclamation Mark Icon (icon) | true    | • true – displays the warning icon  
||                   |         | • false – the icon is not displayed   |

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: note

Macro body: Accepts rich text.
**Storage format example**

```
<ac:structured-macro ac:name="note">
    <ac:parameter ac:name="icon">false</ac:parameter>
    <ac:parameter ac:name="title">My title</ac:parameter>
    <ac:rich-text-body>
        <p>This is the content of my note.</p>
    </ac:rich-text-body>
</ac:structured-macro>
```

**Wiki markup example**

```
{note:icon=false|title=My title}
This is the content of my note.
{note}
```

**Office Excel Macro**

The Office Excel macro displays the content of an Excel spreadsheet on a wiki page. First attach the spreadsheet to a Confluence page, then use the macro to display the content. When viewing the page, people will see the content of the spreadsheet, without needing to have Office installed.

For details, see the [View File Macro](#).

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** viewxls

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the Excel spreadsheet to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the Excel spreadsheet is attached.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-----------</td>
<td>---------</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td>col</td>
<td>No</td>
<td>Last column with content</td>
<td>The number of the last column you want displayed, starting from '0' as the first column. <strong>Hint for reducing the size of the spreadsheet:</strong> Use the <code>col</code> and <code>row</code> parameters to reduce the size of the spreadsheet displayed on the wiki page. This is especially useful to prevent the display from showing empty cells. This will also help to prevent 'out of memory' errors.</td>
</tr>
<tr>
<td>row</td>
<td>No</td>
<td>Last row with content</td>
<td>The number of the last row you want displayed, starting from '0' as the first row.</td>
</tr>
</tbody>
</table>
| grid      | No      | true                     | Determines whether the macro will show borders around the cells in the spreadsheet. Accepted values:  
  - true – Shows borders.  
  - false – Does not show borders. |
| sheet     | No      | The most-recently viewed worksheet | The name of the worksheet that you want displayed. |

**Storage format example**

```xml
<ac:structured-macro ac:name="viewxls">
  <ac:parameter ac:name="col">E</ac:parameter>
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="Spreadsheet.xls"/>
  </ac:parameter>
  <ac:parameter ac:name="sheet">Sheet1</ac:parameter>
  <ac:parameter ac:name="row">5</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{viewxls:col=5|page=Docs|name=My document.xls|grid=false|sheet=mysheet|row=5}
```

**Office PowerPoint Macro**
The Office PowerPoint macro displays the content of a PowerPoint presentation on a wiki page. First attach the presentation to a Confluence page, then use the macro to display the content. When viewing the page, people will see the content of the presentation, without needing to have Office installed.

For details, see the View File Macro.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** viewppt

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the PowerPoint presentation to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the PowerPoint presentation is attached.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>The height of the macro display, specified in pixels (for example: 10p x, or just 10) or as a percentage (for example: 20%) of the window's height.</td>
<td></td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td>The width of the macro display, specified in pixels (for example: 10p x, or just 10) or as a percentage (for example: 20%) of the window's height.</td>
<td></td>
</tr>
<tr>
<td>slide</td>
<td>No</td>
<td>All slides, starting with the first, as a slide show</td>
<td>The number of the slide that you want displayed on the Confluence page, where the first slide is numbered zero. Instead of a slide show, the page will display just the single slide, represented as a JPEG image.</td>
</tr>
</tbody>
</table>

**Storage format example**
Office Word Macro

The Office Word macro displays the content of a Word document on a wiki page. First attach the document to a Confluence page, then use the macro to display the content. When viewing the page, people will see the content of the document, without needing to have Office installed.

For details, see the [View File Macro](#).

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** viewdoc

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the Word document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the Word document is attached.</td>
</tr>
</tbody>
</table>

**Storage format example**

```xml
<ac:structured-macro ac:name="viewdoc">
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="Chocolate.doc"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```wikimarkup
{viewppt:height=20%|page=Docs|width=20%|name=My document.ppt|slide=4}
```
Page Index Macro

The Page Index macro creates a hyperlinked alphabetical index of all page titles within the current space.

The top section of the index contains a cell for each letter of the alphabet, with cells for numbers and symbols. Each cell indicates how many pages are in the corresponding list.

The lower section contains lists of page titles followed by the first few sentences of content on that page.

Each letter, number or symbol in the top section is hyperlinked to the corresponding cell in the lower section. Each page title in the lower section is hyperlinked to the page in the space.

Screenshot: Page Index macro (partial view)

Using the Page Index macro

To add the Page Index macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

This macro accepts no parameters.
**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** index

**Macro body:** None.

**Parameters:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="index"/>
```

**Wiki markup example**

```
{index}
```

---

**Page Properties Macro**

The Page Properties and Page Properties Report macro work together to enable you to show summary information from one page on another page. You can see examples of these two macros in action in the Decisions Blueprint and Product Requirements blueprints.

This macro was previously known as the Metadata Details macro.

**Adding the Page Properties macro to a page**

The Page Properties macro uses key value pairs. The body of the macro must be set up correctly for your information to appear in the Page Properties Report.

To add the Page Properties macro to a page:

1. In the editor, choose Insert > Other Macros > Page Properties.
2. In the macro body create a two column table and remove the header row.
3. In the left column list your 'keys' - these will be the column headings in your report table.
4. In the right column list the value for each key - these will populate the rows in your report table.
5. Add a label to your page - you will need to specify this label in the page properties report macro.
6. Save your page.

---

**On this page:**
- Adding the Page Properties macro to a page
- Using multiple Page Properties macros on one page
- Parameters
- Code examples

**Related pages:**
- Page Properties Report Macro
- Decisions Blueprint
- Product Requirements Blueprint

---

⚠️ Don't forget to add a label to your page, or your page will not appear in the Page Properties Report macro.

Next you need to add the Page Properties Report macro to another page.

**Screenshot:** Page Properties macro in the editor. Deadline, Current Status and Team will be column headings in the report.
Using multiple Page Properties macros on one page

You can add multiple Page Properties macros on a single page, and choose whether to include all or only specific macros in the report. You might use multiple macros because you want the information in the macro to display in context with the rest of the page, or because you want to be able to report on individual Page Properties macros separately.

The Page Properties macro includes an optional ID parameter that can be used to identify specific Page Properties macros.

To show the contents of all Page Properties macros in the report:
- Add a label to the page containing the Page Properties macros.
- Specify this label in the Page Properties Report macro.

To show the contents of selected Page Properties macros in the report:
- Add a label to the page containing the Page Properties macros.
- Specify an ID in the Page Properties macro that you want to report on.
- Specify both the label and ID in the Page Properties Report macro.

Note: The Page Properties Report macro can only accept one page label, and one ID.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Page Properties ID</th>
<th>(None)</th>
<th>Optional ID used to identify a particular Page Properties macro on a page. Specify this ID in the Page Properties Report to include summary information from macros with this ID only.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hidden</td>
<td>False</td>
<td>Determines whether the data in the Page Properties macro will be displayed on the current page. This setting does not affect the display of the detail in the Page Properties Report macro.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** details

**Macro body:** Accepts rich text.

**Storage format example**

The following example contains two pieces of data - Owner and Date.

```xml
<ac:structured-macro ac:name="details">
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <td>Owner</td>
          <td>Rach Admin</td>
        </tr>
        <tr>
          <td>Date</td>
          <td>1 May</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Notes**

- You cannot use text formatting or macros in the left column as the data in this column is used to populate the column headings in your Page Properties Report macro.
- If your table has a header row, this row will be ignored by the Page Properties Report macro. You should remove the header row.
- It is not possible to reference the metadata using the metadata key from within the page, or anywhere else on a Confluence page.

**Page Properties Report Macro**

The Page Properties and Page Properties Report macro work together to enable you to show summary information from one page on another page. You can see examples of these two macros in action on the Decision and Product Requirements blueprints.

This macro was previously known as the Details Summary macro.

**Adding the Page Properties Report macro to a page**
To add the Page Properties Report macro to a page:

1. In the editor, choose Insert > Other Macros > Page Properties Report.
2. Enter the Label you want to report on - this is the label added to pages containing the Page Properties macro.
3. Restrict the report by ID, space or specify column headings or sort order - see the Parameters table below for more details.
4. Choose Insert.

**Note:** If your report is empty, check:

- You have specified the label correctly and the label appears on pages containing the Page Properties macros.
- The Page Properties macros on each page are configured correctly.

**Screenshot: Page Properties Report**

![Sample space / Project ABC Status Report](image)

<table>
<thead>
<tr>
<th>Title</th>
<th>Current Status</th>
<th>Deadline</th>
<th>Team</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project ABC</td>
<td>In Progress</td>
<td>15 November</td>
<td>Green Parrots</td>
</tr>
<tr>
<td>Project DEF</td>
<td>Not Started</td>
<td>1 June</td>
<td>Purple Monkeys</td>
</tr>
</tbody>
</table>

**Reporting on specific Page Properties macros**

You can add multiple Page Properties macros on a page, and choose whether to include all or only specific macros in the report. The Page Properties macro includes an optional ID parameter that can be used to identify specific Page Properties macros.

To show the contents of:

- **All Page Properties macros** in the report - specify just the label for the page.
- **Selected Page Properties macros** in the report - specify both the label for the page and the ID of the particular Page Properties macro.
Note: The Page Properties Report macro can only accept one page label, and one ID.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>(None)</td>
<td>Identifies the label to be used in the Page Properties Report. The report will show data from all pages in the current space containing a Page Properties macro with the same label.</td>
</tr>
<tr>
<td>Page Properties ID</td>
<td>(None)</td>
<td>If not specified, the report will show data from all Page Properties macros on a page, where there are multiple macros. Specify an ID to include only data from Page Properties macros with the same ID.</td>
</tr>
<tr>
<td>Restrict to spaces</td>
<td>(None)</td>
<td>If not specified, the report will only show data from the current space. You can specify a comma separated list of space keys, or use @all to show data from all spaces.</td>
</tr>
<tr>
<td>Title column heading</td>
<td>Title</td>
<td>The heading to display on the first column in the report table. This column contains links to pages displayed by the report. The default column heading is 'Title'.</td>
</tr>
<tr>
<td>Columns to show</td>
<td>(None)</td>
<td>If not specified, the report will show all columns. You can specify a comma separated list of columns to include.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If your column heading includes commas, use double quotes around the column name. If your column heading includes quotes, use double quotes. For example, A column, &quot;My &quot;&quot;new&quot;&quot; column, yes&quot;, Third column</td>
</tr>
<tr>
<td>Number of items to display</td>
<td>30</td>
<td>Number of items to display in the table before displaying pagination options for additional items.</td>
</tr>
<tr>
<td>Sort by</td>
<td>Last modified date</td>
<td>Sort the table by a specific column heading. Enter the column name, exactly as it appears in the corresponding Page Properties macro.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Select the Reverse Sort check box to sort the table in reverse order.</td>
</tr>
</tbody>
</table>
Show Comments Count | No | Displays the number of comments for each page in the table.
---|---|---
Show Likes Count | No | Displays the number of likes for each page in the table.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** detailssummary

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="detailssummary">
    <ac:parameter ac:name="id">status-dev</ac:parameter>
    <ac:parameter ac:name="sortBy">Created</ac:parameter>
    <ac:parameter ac:name="label">status</ac:parameter>
</ac:structured-macro>
```

**Page Tree Macro**

The Page Tree macro displays a dynamic, hierarchical list of pages starting from a specified parent (root) page. It can act as a table of contents or a list of related topics. When viewing the page tree, your reader can click a link to view the relevant page. The page's current position is highlighted in the page tree.

**Note:** The Page Tree macro is used in the Confluence Documentation theme, to create a navigation panel showing a table of contents for your space. Read the instructions on Configuring the Documentation Theme.

**Using the Page Tree Macro**

To add the Page Tree macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Click Refresh in the Macro Browser to see the effect of changes to the macro parameters.

**Macro Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
| **Root Page**  
| **(root)** | **The home page of the space** | Specify the parent page for the page tree. The tree will include all children of the given page, plus their children and grand-children etc. The tree will *not* include the root page itself.

Specify the page title or a special value as follows:

- **Your page title** — to specify a page name for the parent or root of the tree. The tree will include all children and grand-children of the specified root. The tree will *not* include the specified root page itself.
- **@home** — will include all pages under the home page of the space (default).
- **@self** — will include all pages under the current page.
- **@parent** — will include all pages under the parent of the current page, including the current page.
- **@none** — will include all pages in the space, including orphaned pages and the home page.

| **Sort Pages By**  
| **(sort)** | **position** | Specify the order to display the pages in the tree. This sort order is for display purposes only. It does not permanently re-arrange the page order. The value may be one of the following:

- **bitwise** — sort alphabetically, for example: title1, title10, title2.
- **creation** — sort by date of creation.
- **modified** — sort by order of date last modified.
- **natural** — sort in 'natural' alphabetical order, for example: title1, title2, title10.
- **position** — sort by the default Confluence sorting rules. If your pages have been ordered manually, this sort will respect the defined order. Otherwise the pages will be displayed in the 'natural' alphabetical order, such as: title1, title2, title10.

| **Include Excerpts in Page Tree**  
| **(excerpt)** | **false** | Select if you want the page tree to show excerpts from each page. The excerpts must be defined on each page by the **Excerpt macro**.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reverse Order (reverse)</td>
<td>false</td>
<td>Select to show the pages in reverse (descending) natural order. Must be used in combination with the Sort Pages By parameter.</td>
</tr>
<tr>
<td>Include Search Box above Page Tree (searchBox)</td>
<td>false</td>
<td>Select if you want to include a search box above the page tree. The search box allows your readers to search within the page tree for the specified value.</td>
</tr>
</tbody>
</table>
| Show Expand/Collapse Links (expandCollapseAll) | false   | Select if you want to display the 'expand all' and 'collapse all' links at the top of your page tree. Your readers can click these links to open or close all branches of the tree at once. Available values in wikimarkup and storage format:  
- true – Show the 'expand all' and 'collapse all' options.  
- false – Do not show the options. |
| Start Depth (startDepth)              | 1       | Enter any number greater than 0 to set how many levels of children the tree should show when it opens for the first time.                   |

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** pagetree

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="pagetree">
  <ac:parameter ac:name="reverse">false</ac:parameter>
  <ac:parameter ac:name="sort">natural</ac:parameter>
  <ac:parameter ac:name="root">
    <ac:link>
      <ri:page ri:content-title="Page Name"/>
    </ac:link>
  </ac:parameter>
  <ac:parameter ac:name="startDepth">3</ac:parameter>
  <ac:parameter ac:name="excerpt">true</ac:parameter>
  <ac:parameter ac:name="searchBox">true</ac:parameter>
  <ac:parameter ac:name="expandCollapseAll">true</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**
Sample Page Tree

This page is a sample, used to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Page Tree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetree:root=@parent</td>
<td>expandCollapseAll=false}</td>
</tr>
</tbody>
</table>

Another Sample Page Tree

We’re using this page to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Page Tree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetree:root=@parent</td>
<td>expandCollapseAll=true}</td>
</tr>
</tbody>
</table>

Sample Page Tree 2

This is another sample page, used to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Page Tree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetree:root=@parent</td>
<td>expandCollapseAll=true}</td>
</tr>
</tbody>
</table>

Page Tree Search Macro

Using the Page Tree Search macro, you can add a search box to your Confluence page. When a viewer enters a search term, Confluence will search a hierarchy of pages starting from a specified parent (root) page and return the search results.

You can also add a search box as part of a dynamic page tree, which looks like a table of contents. See the Page Tree macro.

Using the Page Tree Search macro

To add the Page Tree Search macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name of Root Page (root)</td>
<td>none</td>
<td>The name of the root page whose hierarchy of pages will be searched by this macro. If this not specified, the root page is the current page. Note: Unlike the Page Tree macro, the Page Tree Search macro does not accept the special values that start with an @ sign, such as @home or @self.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** pagetreesearch

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="pagetreesearch">
  <ac:parameter ac:name="root">My page name</ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```text
{pagetreesearch:root=My page name}
```

**Panel Macro**

The Panel macro displays a block of text within a customisable panel, like a text box.

**Handy hint:** You can use panels within columns, in table cells and in the sections defined by page layouts.

Here is an example of a Panel macro:

![My Title](image)

**A formatted panel.**

**Using the Panel macro**

**To add the Panel macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type \{ and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panel Title (title)</td>
<td>none</td>
<td>The title of the panel. If specified, this title will be displayed in its own title row.</td>
</tr>
<tr>
<td>Border Style (borderStyle)</td>
<td>solid</td>
<td>The style of the panel's border. Accepted values are solid, dashed and other valid CSS border styles.</td>
</tr>
<tr>
<td>Border Colour (borderColor)</td>
<td></td>
<td>The colour of the panel's border. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
<tr>
<td>Border Pixel Width (Value Only) (borderWidth)</td>
<td></td>
<td>The width of the panel's border (in pixels).</td>
</tr>
<tr>
<td>Background Colour (bgColor)</td>
<td></td>
<td>The background colour of the panel. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
<tr>
<td>Title Background Colour (titleBGColor)</td>
<td></td>
<td>The background colour of the title row of the panel. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
<tr>
<td>Title Text Colour (titleColor)</td>
<td></td>
<td>The colour of the text in the title row of the panel. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** `panel`

**Macro body:** Accepts rich text.

**Storage format example**

```xml
<ac:structured-macro ac:name="panel">
  <ac:parameter ac:name="bgColor">#72bc72</ac:parameter>
  <ac:parameter ac:name="titleBGColor">#00a400</ac:parameter>
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:parameter ac:name="borderStyle">dashed</ac:parameter>
  <ac:parameter ac:name="borderColor">blue</ac:parameter>
  <ac:parameter ac:name="titleColor">white</ac:parameter>
  <ac:rich-text-body>
    <p>A formatted panel</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Wiki markup example**
PDF Macro

The PDF macro displays the content of a PDF document on a page. First attach the document to a Confluence page, then use the macro to display the document.

For details, see the View File Macro.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: viewpdf

Macro body: None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the PDF document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the PDF document is attached.</td>
</tr>
</tbody>
</table>

**Storage format example**

```xml
<ac:structured-macro ac:name="viewpdf">
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="My_document.pdf"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{viewpdf:page=Docs|name=My document.pdf}
```

Popular Labels Macro

The Popular Labels macro displays the most popular labels used throughout your Confluence site or within a space. A popular label is a label that has been added to many pages.
**Using the Popular Labels Macro**

To add the Popular Labels macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Labels to Display</td>
<td>100</td>
<td>Specifies the total number of labels to display in the heatmap.</td>
</tr>
<tr>
<td>(count)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Restrict Labels to this Space Key</td>
<td>none</td>
<td>Restricts the list of popular labels to the specified space.</td>
</tr>
<tr>
<td>(spaceKey)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
| Style of Labels                  | list    | • list – displays the popular labels as a bulleted list, ordered by popularity (highest first).
| (style)                          |         | • heatmap – displays the popular labels using different font sizes for each label depending on the label's popularity, ordered by label names. |

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** popular-labels

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="popular-labels">
  <ac:parameter ac:name="count">20</ac:parameter>
  <ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="ds"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```wikimarkup
{popular-labels:style=heatmap|count=20|spaceKey=ds}
```

Profile Picture Macro
The Profile Picture macro displays a user's profile picture on a page.

- When viewing the page, mouse-over the picture to see the Hover Profile for the user.
- When editing the page, click on the picture and choose View User Profile to see the profile for the user.

The Profile Picture macro is useful for such tasks as creating Team Pages that show all members of a project team.

**Using the Profile Picture Macro**

To add the Profile Picture macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

### Speeding up macro entry with autocomplete:
Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

### To edit an existing macro:
Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User</td>
<td>none</td>
<td>The username, or real name, of a Confluence user.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** profile-picture

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="profile-picture">
  <ac:parameter ac:name="User">
    <ri:user ri:userkey="12345678912345678912345"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup**

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

**Recently Updated Dashboard Macro**

The Recently Updated Dashboard macro displays a list of the most recently changed content within Confluence. It is similar to the Recently Updated macro but is intended for use on the Confluence dashboard.
Using the Recently Updated Dashboard macro

To add the Recently Updated Dashboard macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type \{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space(s) (spaces)</td>
<td>The space which contains the page on which the macro is added</td>
<td>Filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here. You can specify one or more space keys, separated by commas. '*' means all spaces.</td>
</tr>
<tr>
<td>Include these Content Types Only (types)</td>
<td>all types</td>
<td>Filter content by type. You can specify one or more types, separated by commas. Available types are: page, blogpost, news, spacedesc, attachment, comment, mail, userinfo.</td>
</tr>
<tr>
<td>Label(s) (labels)</td>
<td>none</td>
<td>Filter content by label. The macro will display only the pages etc which are tagged with the label(s) you specify here. You can specify one or more labels, separated by commas. Note: If there are no pages matching any of the specified labels, then Confluence will ignore the labels and will list all recently updated pages, as well as showing a message, &quot;These labels don't exist and were ignored: xxx &quot;. This unexpected behaviour is noted in issue CONF-13860 - recently-updated-dashboard macro doesn't return an empty result when no pages match the specified label(s)</td>
</tr>
<tr>
<td>User(s) (users)</td>
<td>all users</td>
<td>Filter by username of the user who updated the content. The macro will only display content created and updated by the user(s) you specify here. You can specify one or more usernames separated by commas.</td>
</tr>
</tbody>
</table>

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Width of Table (width) | 100% | Specify the width of the macro display, as a percentage of the window width.

Show User Profile Pictures (showProfilePic) | false | Select whether profile pictures of the users who updated the content are displayed.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** recently-updated-dashboard

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="recently-updated-dashboard">
    <ac:parameter ac:name="spaces">
        <ri:space ri:space-key="ss"/>
    </ac:parameter>
    <ac:parameter ac:name="users">
        <ri:user ri:userkey="12345678912345678912345"/>
    </ac:parameter>
    <ac:parameter ac:name="width">50%</ac:parameter>
    <ac:parameter ac:name="labels">choc</ac:parameter>
    <ac:parameter ac:name="types">page</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{recently-updated-dashboard:spaces=ds|users=admin|width=50%|showProfilePic=true|labels=choc|types=page}
```

**Recently Updated Macro**

The Recently Updated macro displays a list of the most recently changed content within Confluence.

**Using the Recently Updated Macro**

**To add the Recently Updated macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type ` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Author(s) by username</strong></td>
<td><strong>None specified. That is, display all content</strong></td>
<td>Filter the results by author. The macro will display only the pages etc which were last modified by the author(s) you specify here.</td>
</tr>
<tr>
<td><strong>(author)</strong></td>
<td></td>
<td>You can specify one or more authors, separated by a comma or a space. For example: jsmith, jbrown</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To include content from one user, but exclude from another user: jsmith, !jbrown</td>
</tr>
</tbody>
</table>
| Space(s) (spaces) | @self  
That is, the space which contains the page on which the macro is used | This parameter allows you to filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here.

You can specify one or more space keys, separated by a comma or a space.

- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of `-BADSPACE` you will get only content which is not in the BADSPACE.
- To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of `+GOODSPACE` you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)

Special values:

- `@self` — The current space.
- `@personal` — All personal spaces.
- `@global` — All site spaces.
- `@favorite` — The spaces you have marked as favourite.
- `@favourite` — The same as @favorite above.
- `@all` — All spaces in your Confluence site.
- `*` — The same as `@all` above.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as `~jbloggs` or `~jbloggs@example.com`. |
| Label(s)  
| (labels) | None specified i.e. display all content | Filter the results by label. The macro will display only the pages etc which are tagged with the label(s) you specify here.

You can specify one or more label values, separated by a comma or a space.

- To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labelled with 'badpage'.
- To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage,+goodpage you will get only content which has at least two labels, being 'superpage' and 'goodpage'.

The labels parameter only applies to the page and blog content types. |
| Width of Table  
| (width) | 100% | Specify the width of the macro display, as a percentage of the window width. |
| Include these Content Types Only (types) | All types | This parameter allows you to filter content by content type. The macro will display only the content of the type you specify here. You can specify one or more types, separated by a comma or a space. To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of -blogpost you will get pages and all other content except for blog posts. Available values:  
- page — Pages  
- blogpost or news — Blog posts, also known as news items  
- comment — Comments on pages and blog posts  
- attachment — Attachments  
- status — Status updates made by other users. |
| Maximum Number of Results (max) | 15 | Specify the maximum number of results to be displayed. If this parameter is omitted, then a maximum of 15 results are displayed. The theoretical maximum value that this parameter can accept is 2 to the power of 31, minus 1 (or 2147483647), though this has been limited to 200 in the code, for performance reasons. More details are here. |
| theme (theme) | concise | Choose the appearance of this macro:
| | | • concise — the default list, showing the names of pages which were updated or commented on, the users who made the page modifications and time when the modifications occurred.
| | | • social — lists recent modifications in reverse chronological order, but groups them by user into short time segments. A 'sub' list appears within each user's time segment, showing the names of pages which they updated or commented on and time when these modifications occurred.
| | | • sidebar — lists recent updates in reverse chronological order, showing the names of pages which were updated or commented on and time when the page modifications occurred. This theme does not show authorship.
| Show User Profile Pictures (showProfilePic) | false | Specify showProfilePic=true to display the profile pictures of the users who updated the content.
| Hide Title (hideHeading) | False | Determines whether the macro hides or displays the text 'Recently Updated' as a title above the list of content. Only available in wikimarkup and storage format.
| | | Accepted values:
| | | • true – Title is hidden.
| | | • false – Title is shown.

**Notes**

- The Recently Updated Dashboard macro is similar to this macro, but is intended for display on the Confluence dashboard.
- If you would like to change the wording displayed by the Recently Updated macro, please refer to the document on modifying the Confluence interface text.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** recently-updated

**Macro body:** None.

**Storage format example**
Recently Used Labels Macro

The Recently Used Labels macro displays a list of the labels that have been most recently added to a page, blog post or attachment. You can define the number of labels to be displayed and the scope (the current space, your personal space or site spaces, also known as 'global' spaces).

Using the Recently Used Labels macro

To add the Recently Used Labels macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type \{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters of this macro

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Labels to Display</td>
<td>10</td>
<td>Specifies the total number of labels to display in the list.</td>
</tr>
</tbody>
</table>
Scope for Retrieving Labels (scope)

- `global` — covers all site spaces (non-personal) in the Confluence installation.
- `space` — the current space.
- `personal` — your own personal space.

List Style (style)

- `list` — displays the list of labels horizontally.
- `table` — includes additional information such as the page to which the label was added and the user who added it.

Table Title (title)

- `none` — Adds a title to the top of the list in table style. Titles are only visible when the List Style parameter has been set to table.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** `recently-used-labels`

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="recently-used-labels">
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:parameter ac:name="scope">space</ac:parameter>
  <ac:parameter ac:name="style">table</ac:parameter>
  <ac:parameter ac:name="count">20</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{recently-used-labels:title=My title|scope=space|style=table|count=20}
```

**Related Labels Macro**

The Related Labels macro lists all labels from every page which has one or more labels in common with the current page.

**Using the Related Labels Macro**

To add the Related Labels macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restrict to these Labels</strong></td>
<td>none</td>
<td>Specify the labels for which you want to view related labels. For example, documentation, my:stuff.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** related-labels

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="related-labels">
  <ac:parameter ac:name="labels">choc,cake</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{related-labels:labels=choc,cake}
```

RSS Feed Macro

The RSS Feed macro embeds an RSS feed on a page. It can display the contents of external feeds, or of internal feeds generated by Confluence. To display blog posts or to list recently updated pages in a space, use the Feed Builder to create an internal feed, then render it using this macro.

**CAUTION:** Including unknown HTML inside a webpage is dangerous. HTML inside an RSS feed can contain active scripting components. This means that it would be possible for a malicious attacker to present a user of your site with script that their web browser would believe came from you. Such code could be used, for example, to steal a user's authentication cookie and give the attacker their Confluence login password.

The RSS Feed macro may be disabled by your Confluence administrator. Also, your Confluence administrator can define a whitelist of trusted URLs. You will see an error message on the Confluence page, if the included URL is not in the whitelist.

**Using the RSS Feed macro**

**To add the RSS Feed macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RSS Feed URL (url)</td>
<td>none</td>
<td>The URL of the RSS feed link you want to show.</td>
</tr>
<tr>
<td>Maximum Number of Entries (max)</td>
<td>15</td>
<td>Limit the number of entries displayed.</td>
</tr>
<tr>
<td>Show Item Titles Only (showTitlesOnly)</td>
<td>false</td>
<td>Show only the titles of the news items, not the content.</td>
</tr>
<tr>
<td>Show Name/Title of RSS Feed (titleBar)</td>
<td>true</td>
<td>Hide the feeds title bar.</td>
</tr>
</tbody>
</table>

How up to date is the feed?

By default, the RSS Feed macro caches the feed results for 60 minutes before fetching the data again.

If you wish to change the default caching, use the Cache macro to define how often the RSS Feed macro fetches the feed updates. You will need to install the Cache plugin onto your Confluence site.

What happens to a page containing a disallowed URL?

Your Confluence Administrator can set up a whitelist of allowed URLs. If this is the case, you may see an error on the pages which contain the RSS Feed macro.

A user can add the RSS Feed macro or the HTML-include macro to a Confluence page. The macro code includes a URL from which the content is drawn. When the page is displayed, Confluence will check the URL against the whitelist. If the URL is not allowed, Confluence will display an error message on the page.

The error message says that Confluence "could not access the content at the URL because it is not from an allowed source" and displays the offending URL. If the person viewing the page is a Confluence Administrator, they will also see a link to the Administration page where they can configure the URL whitelist.

Here is an example of the error message, including the link shown only to Confluence Administrators:

```
Could not access the content at the URL because it is not from an allowed source.
http://feathers.wordpress.com
Configure whitelist >>
```

Here is an example of the error message, but without the link.

```
Could not access the content at the URL because it is not from an allowed source.
http://feathers.wordpress.com
You may contact your site administrator and request that this URL be added to the list of allowed sources.
```

Authentication

Private feeds from external sites

RSS feeds which require authentication cannot be accessed using the RSS Feed macro.

Accessing internal HTTPS feeds
This applies only to Confluence instances which have enabled HTTPS for all content. If your site is fully HTTPS, the RSS Feed macro cannot access internal feeds. To enable the RSS Feed macro to access internal feeds without affecting your HTTPS setup, enable local-only HTTP access:

1. Shut down Confluence.
2. Consult the SSL guide to enable HTTP access to Confluence. You'll want to ensure that you have an HTTP connector and an SSL connector, both commented in. This means that Confluence will be accessible via both HTTP and HTTPS. However, you should not have a redirect port, nor rules in web.xml to redirect all traffic.
3. Instead of using web.xml to redirect traffic, insert a firewall rule to redirect all HTTP requests not from the Confluence server to the equivalent HTTPS URL. This ensures that users will only be able to access Confluence via HTTPS, as intended. If you have still left HTTP access for attachments enabled (to avoid the IE download bug) you must selectively enable those URLs as well.
4. Modify your Confluence RSS Feed macro feed link to use the HTTP URL, and restart Confluence.

Enabling and disabling the RSS Feed macro

The RSS Feed macro is a module of the Confluence HTML Macros plugin.

To enable or disable the RSS Feed macro:

1. Enable the Confluence HTML Macros plugin by following the instructions in Enabling HTML macros.
2. In the plugin module list of the HTML macros, find the RSS (rss-xhtml) module and hover your cursor over it to enable or disable it.

Code examples

Macro name: rss

Macro body: None.

Storage format example

```xml
<ac:structured-macro ac:name="rss">
  <ac:parameter ac:name="max">10</ac:parameter>
  <ac:parameter ac:name="showTitlesOnly">true</ac:parameter>
  <ac:parameter ac:name="url">
    <ri:url ri:value="http://myblog.com/feed"/>
  </ac:parameter>
  <ac:parameter ac:name="titleBar">false</ac:parameter>
</ac:structured-macro>
```

Wikimarkup example

```wiki
{rss:max=10|showTitlesOnly=true|url=http://myblog.com/feed|titleBar=false}
```

Search Results Macro

The Search Results macro searches your Confluence site based on search terms specified in the macro parameters, and displays the results on the wiki page.

Using the Search Results macro

To add the Search Results macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Search Terms</strong> (query)</td>
<td>none</td>
<td>The search terms which this macro will use to generate its results. You can refine your search query by using operators such as 'AND' and 'OR'. For example: my_query1 AND my_query2. For more information, take a look at the documentation on the Confluence search syntax.</td>
</tr>
<tr>
<td><strong>Maximum Number of Results</strong> (maxLimit)</td>
<td>10</td>
<td>Set a limit to the number of search results displayed.</td>
</tr>
<tr>
<td><strong>Restrict to this Space Key</strong></td>
<td>all</td>
<td>Start typing the space name to find the space, or specify the key of the space you want to search in. Note that the key is case sensitive.</td>
</tr>
<tr>
<td><strong>Content Type</strong> (type)</td>
<td>all</td>
<td>Specify the content type. The content types are: page, comment, blogpost, attachment, userinfo (the content of user profiles only) and spacedesc (the content of space descriptions only).</td>
</tr>
</tbody>
</table>
| Last Modified  
(lastModified) | all | Specify a period of time in weeks, days, hours and/or minutes, to see the content modified within that time frame. These are the values you can use:
  - `w` = weeks
  - `d` = days
  - `h` = hours
  - `m` = minutes
For example:
  - `2h 35m`
  - `3d 30m`
Notes:
  - If no time category is specified, Confluence assumes minutes.
  - If you specify more than one time period (for example, weeks and days), you must separate the periods with a space. You can put them in any order.
  - The time categories are not case sensitive. For example, `'4d'` is the same as `'4D'`.

| Restrict to this Username  
(contributor) | all | Specify the username of a Confluence user, to show only content created or updated by that user.

**Notes**

**Permissions:** When a user views the page containing the Search Results macro, the search results will show only pages and other content types for which the user has 'View' permission.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** search

**Macro body:** None.

**Storage format example**
Wiki markup example

```markdown
{search:lastModified=3w|query=choc|contributor=admin|maxLimit=10|type=page|spacekey=ds}
```

Section Macro

Used with the Column macro to define columns on a page. See Working with page layouts and columns and sections.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** section

**Macro body:** Rich text, consisting of one or more Column macros.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>border</td>
<td>No</td>
<td>False</td>
<td>If the value is true, the columns in this section will have a dashed border.</td>
</tr>
</tbody>
</table>

Storage format example

The following example shows a section and column macro together.
Wiki markup example

```wiki
{section:border=true}
{column:width=100px}
This is the content of *column 1*.
{column}
This is the content of *column 2*.
{section}
```

Space Attachments Macro

Displays a list of attachments belonging to the current space. See Displaying a List of Attachments for more information on using this and other attachment macros.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** space-attachments

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
### showFilter

No  |  true  | Determines whether or not the filter panel is shown. If you select this option, people viewing the page will be able to filter the list of attachments by file type (extension) and by label. Accepted values:
- **true** – Macro displays the filter panel.
- **false** – Macro does not display the filter panel.

### space

No  |  Current space.  | Determines the Confluence space containing the attachments that the macro will display.

#### Storage format example

```xml
<ac:structured-macro ac:name="space-attachments">
  <ac:parameter ac:name="showFilter">false</ac:parameter>
  <ac:parameter ac:name="space">
    <ri:space ri:space-key="ds"/>
  </ac:parameter>
</ac:structured-macro>
```

#### Wiki markup example

```
{space-attachments:showFilter=false|space=ds}
```

### Space Details Macro

The Space Details macro displays the details of a Confluence space, including the space name, description, and more.

#### Using the Space Details macro

**To add the Space Details macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in [Using Autocomplete](#).

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

#### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width of Table</td>
<td>100%</td>
<td>The width of the space details table, specified as a percentage (%) of the page width.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** space-details

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="space-details">
   <ac:parameter ac:name="width">50%</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{space-details:width=50%}
```

**Space Jump Macro**

This page describes the Space Jump macro, which is provided with the Documentation theme. You can use space jumping to link from a page in one space to a page with the same name in another space, without knowing the name of the page when you create the link.

**Advance warning of plans to merge Documentation theme with the default theme**

This is an advance notice that we plan to merge the functionality of the Confluence Documentation theme with the Confluence default theme. We do not yet have a specific date for this plan, and we are interested in your feedback. The new default theme, introduced with Confluence 5.0, includes a sidebar with contextual navigation. Our plan is to include features from the Documentation theme in the default theme, and then remove the Documentation theme from Confluence.

If you are interested in this change and would like to give us feedback, please add a comment on this [blog post](https://confluence.atlassian.com/blog/): *Advance warning of plans to merge Documentation theme with the default theme*. We are especially interested to know which features of the Documentation theme you use and value the most.

The Space Jump macro inserts a link onto the page. When the reader clicks the link, they will jump to a page that has the same name in another space. You specify the space when you insert the Space Jump macro.

**Example:** We use the Space Jump macro to put a standard message at the top of our archive spaces, telling people that they’re reading an old version of the documentation and letting them jump quickly to the same page in the latest documentation. See the words ‘this page in the current documentation’ in the screenshot below.

**Screenshot:** One way of using the Space Jump macro

---

**Configuring the Documentation Theme**

---

*Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
Using the Space Jump macro

To add the Space Jump macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>None</td>
<td>The space key that contains a page with the same page title that you want the link to jump to. Space keys are case-sensitive.</td>
</tr>
<tr>
<td>Alias</td>
<td>None</td>
<td>The text to display as the hyperlinked text. If you do not supply an alias, Confluence will display the page name.</td>
</tr>
</tbody>
</table>

Notes

What happens if there is no page with the same name in the target space?

For the space jump to work, the target space must contain a page with the same name as the page that renders the Space Jump macro. If the target space does not contain such a page, you will see a broken link. Confluence handles this in its usual manner: the link is coloured red. If you click the link, Confluence offers to create the page for you.

Can I use the Space Jump macro in any space?

Yes. You can use the Space Jump macro in any space, even if that space is not currently using the Documentation theme. Provided that the Documentation theme plugin and its components are installed and enabled on your Confluence site, the Space Jump macro is available in any space.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: spacejump

Macro body: None.

Storage format example

```
<ac:structured-macro ac:name="spacejump">
   <ac:parameter ac:name="alias">My Space</ac:parameter>
   <ac:parameter ac:name="space">
      <ri:space ri:space-key="SS"/>
   </ac:parameter>
</ac:structured-macro>
```
Spaces List Macro

The Spaces List macro displays a list of spaces, similar to the list of spaces seen on the dashboard.

**Using the Spaces List macro**

**To add the Spaces List macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{' and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scope of spaces</td>
<td>no</td>
<td>all</td>
<td>The view from which spaces are listed. Available options are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>all</strong> – All spaces in the Confluence installation.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>category</strong> – Spaces grouped according to space categories.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>favourite</strong> – Spaces which you have added to your favourites list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• <strong>new</strong> – New spaces which have been created within the last 7 days.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>This parameter is unnamed in wikimarkup and storage format.</td>
</tr>
<tr>
<td>Width of List</td>
<td>no</td>
<td>100%</td>
<td>The width of the spaces list, specified as a percentage (%) of the window</td>
</tr>
<tr>
<td>(width)</td>
<td></td>
<td></td>
<td>width.</td>
</tr>
</tbody>
</table>

**Notes**

There is a bug in this macro that prevents people from selecting a space category. For details, please refer to this issue: [CONF-26597](#) - Changing category in Space List macro generates wrong URL | RESOLVED.
Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: spaces

Macro body: None.

Storage format example

```
<ac:structured-macro ac:name="spaces">
  <ac:parameter ac:name="width">80%</ac:parameter>
  <ac:parameter ac:name="">favourite</ac:parameter>
</ac:structured-macro>
```

Wiki markup example

```
{spaces:favourite|width=80%}
```

Status Macro

The Status macro displays a coloured lozenge (a rounded box) that is useful for reporting project status. You can choose the colour of the lozenge and the text that appears inside the lozenge. The macro also displays its current status in the editor, and you can change the status directly in the editor.

Screenshot: Click on the Status macro lozenge to change the status.

Using the Status macro

To add the Status macro to a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type \{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Colour</td>
<td>Grey</td>
<td>The colour of the lozenge. The following colours are available: Grey, Red, Yellow, Green and Blue.</td>
</tr>
</tbody>
</table>
Title
(title)

The colour that you select. The text that will appear inside the lozenge. If you do not specify any text, the title will be the colour of the lozenge, that is 'Grey', 'Red', 'Yellow', 'Green' or 'Blue'.

Use outline style
(subtle)

False

The style of the lozenge and its border. The default style lozenge is a solid background colour with white text. The outline style lozenge is white with a coloured border and coloured text as shown here

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: status

Macro body: None.

Storage format example

<ac:structured-macro ac:name="status">
  <ac:parameter ac:name="colour">Green</ac:parameter>
  <ac:parameter ac:name="title">On track</ac:parameter>
  <ac:parameter ac:name="subtle">true</ac:parameter>
</ac:structured-macro>

Wiki markup example

{status:colour=Green|title=On track|subtle=true}

Table of Contents Macro

The Table of Contents macro scans the headings on the current Confluence page to create a table of contents based on those headings. This helps readers find their way around lengthy pages, by summarising the content structure and providing links to headings.

Using the Table of Contents macro

Hint: For quick access from the editor toolbar, choose Insert > Table of Contents.

To add the Table of Contents macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type \{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Macro parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
In a browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Output Type (type)</strong></td>
<td>list</td>
<td>• <strong>list</strong> — produces a typical list-type table of contents.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>flat</strong> — produces a horizontal menu-type series of links.</td>
</tr>
<tr>
<td><strong>Display Section Numbering (outline)</strong></td>
<td>clear</td>
<td>Select the check box to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.</td>
</tr>
<tr>
<td><strong>List Style (style)</strong></td>
<td>disc</td>
<td>Select the style of bullet point for each list item. You can use any valid CSS style. For example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>none</strong> — no list style is displayed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>circle</strong> — the list style is a circle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>disc</strong> — the list style is a filled circle. This is the typical bullet list, and is used for this example list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>square</strong> — the list style is a square</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>decimal</strong> — the list is numbered (1, 2, 3, 4, 5)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>lower-alpha</strong> — the list is lower-case, alphabetised (a, b, c, d, e)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>lower-roman</strong> — the list style is lower roman numerals (i, ii, iii, iv, v, vi)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>upper-roman</strong> — the list style is upper roman numerals (I, II, III, IV, V, VI)</td>
</tr>
<tr>
<td><strong>Heading Indent (indent)</strong></td>
<td></td>
<td>Sets the indent for a list according to CSS quantities. Entering <strong>10px</strong> will successively indent heading groups by 10px. For example, level 1 headings will be indented 10px and level 2 headings will be indented an additional 10px.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------------</td>
<td>-------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| **Separator** (separator)             | brackets | This parameter applies to flat lists only. You can enter any of the following values:  
|                                       |       |  
|                                       |       | • **brackets** — Each item is enclosed by square brackets: `[ ]`.  
|                                       |       | • **braces** — Each item is enclosed by braces: `{ }`.  
|                                       |       | • **parens** — Each item is enclosed by parentheses: `()`.
|                                       |       | • **pipe** — Each item is separated by a pipe:  
|                                       |       | • **anything** — Each item is separated by the value you enter. You can enter any text as a separator, for example `*** **`. If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters. |
| **Minimum Heading Level** (minLevel)  | 1     | Select the highest heading level to start your TOC list. For example, entering 2 will include levels 2, and lower, headings, but will not include level 1 headings. |
| **Maximum Heading Level** (maxLevel)  | 7     | Select the lowest heading level to include. For example, entering 2 will include levels 1 and 2, but will not include level 3 headings and below. |
| **Include Headings** (include)        |       | Filter headings to include according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings. |
| **Exclude Headings** (exclude)        |       | Filter headings to exclude according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings. |
| **Printable** (printable)             | checked | By default, the TOC is set to print. If you clear the check box, the TOC will not be visible when you print the page. |
| **CSS Class Name** (class)            |       | If you have custom TOC styles in your CSS style sheet, use this parameter to output the TOC inside `<div>` tags with the specified class attribute. |
Examples

The examples below are based on this table of contents:

- Places
  - Favourite Places
  - Unknown Places
- Foods
  - Favourite Foods
  - Unknown Foods
- Things
  - Favourite Foods
  - UNKNOWN FOODS

Filtered Table of Contents

This example filters the headings to include those that contain 'Favourite', but excludes headings which end with 'Things'. The list is styled with Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
<tr>
<td>Exclude Headings</td>
<td>.*Things</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

I. Favourite Places
   II. Favourite Foods

Flat List

This example filters all headings to render a flat list of 'Unknowns' enclosed in square brackets (the default list style).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Maximum Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

[ Unknown Places ] [ Unknown Foods ] [ Unknown Foods ]

Notes

- When you use a Table of Contents macro in a template, you will see an error when you preview the template itself. But the Table of Contents macro works on the pages that people create from the template – the table of contents shows up after they have saved the page. (This is probably because the template is not defined as a page, and the Table of Contents macro works for pages only.)
- Due to an outstanding issue in the Table of Contents macro (CONF-10619), the macro browser's Refresh function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Contents macro occurs only after the page is saved.

- **Using HTML heading markup with the Table of Contents macro**
  The Table of Contents macro cannot handle HTML heading markup on its own. Hence, if you use the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Contents macro will not create a contents list out of these headings. (For more information about this issue, please refer to TOC-93.)

  However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Contents macro will incorporate these headings into your contents list.

  ```html
  <h2><a name="pagename-headingname"></a>Heading Name</h2>
  ```

  The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** toc

**Macro body:** None.

**Storage format example**

This example shows a list-type table of contents.

```xml
<ac:structured-macro ac:name="toc">
    <ac:parameter ac:name="printable">true</ac:parameter>
    <ac:parameter ac:name="style">square</ac:parameter>
    <ac:parameter ac:name="maxLevel">2</ac:parameter>
    <ac:parameter ac:name="indent">5px</ac:parameter>
    <ac:parameter ac:name="minLevel">2</ac:parameter>
    <ac:parameter ac:name="class">bigpink</ac:parameter>
    <ac:parameter ac:name="exclude">[1/2]</ac:parameter>
    <ac:parameter ac:name="type">list</ac:parameter>
    <ac:parameter ac:name="outline">true</ac:parameter>
    <ac:parameter ac:name="include">.*</ac:parameter>
</ac:structured-macro>
```

This example shows a flat table of contents.

```xml
<ac:structured-macro ac:name="toc">
    <ac:parameter ac:name="maxLevel">2</ac:parameter>
    <ac:parameter ac:name="minLevel">2</ac:parameter>
    <ac:parameter ac:name="class">bigpink</ac:parameter>
    <ac:parameter ac:name="exclude">[1/2]</ac:parameter>
    <ac:parameter ac:name="type">flat</ac:parameter>
    <ac:parameter ac:name="outline">true</ac:parameter>
    <ac:parameter ac:name="separator">pipe</ac:parameter>
    <ac:parameter ac:name="include">.*</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**
This example shows a list-type table of contents.

```
{toc:printable=true|style=square|maxLevel=2|indent=5px|minLevel=2|class=bigpink|exclude=[1//2]|type=list|outline=true|include=.*)
```

This example shows a flat table of contents.

```
{toc:printable=true|maxLevel=2|minLevel=2|class=bigpink|exclude=[1//2]|type=flat|outline=true|separator=pipe|include=.*}
```

Table of Content Zone Macro

You can use the Table of Content Zone macro to mark out a section (zone) within the page from which to create a table of contents. You can style the headings as a flat list, and place the list of links at the top and bottom of the section or page, to provide navigation bars similar to web navigation.

**Using the Table of Content Zone macro**

**To add the Table of Content Zone macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>location (location)</td>
<td>both</td>
<td>Specifies where in the zone the output list is displayed: top, bottom, or both, which encloses the page zone content.</td>
</tr>
</tbody>
</table>
| Output Type (type)         | list    | Specifies the layout for the table of contents:  
  - list – produces a vertical list, typical of a TOC.  
  - flat – produces a horizontal menu-type series of links, for example: [Heading 1] [Heading 2] [Heading 3]. |
| Display Section Numbering (outline) | false  | Select to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3. |
| **List Style**  
**(style)** | none | Specifies the style of bullet point for each list item. You can use any valid CSS style. For example:
- **none** — no list style is displayed
- **circle** — the list style is a circle
- **disc** — the list style is a filled circle. This is the typical bullet list, and is the one we’re using for this example list
- **square** — the list style is a square
- **decimal** — the list is numbered (1, 2, 3, 4, 5)
- **lower-alpha** — the list is lower-case, alphabetised (a, b, c, d, e)
- **lower-roman** — the list style is lower roman numerals (i, ii, iii, iv, v, vi)
- **upper-roman** — the list style is upper roman numerals (I, II, III, IV, V, VI) |
| **Heading Indent**  
**(indent)** |  | Sets the indent for a list output type, according to CSS quantities. Entering "10px" will successively indent list heading levels by 10px. For example, h1 headings will be indented 10px and h2 headings will be indented an additional 10px. |
| **Separator**  
**(separator)** | brackets | Only applies to the `flat` output type. Specifies the display style of the links. You can enter any of the following values:
- **brackets** — Each item is enclosed by square brackets: [ ].
- **braces** — Each item is enclosed by braces: { }.
- **parens** — Each item is enclosed by parentheses: ( ).
- **pipe** — Each item is separated by a pipe:
- **anything** — Each is separated by the value you enter. You can enter any text as a separator, for example "****". If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters. |
Minimum Heading Level (minLevel) | 1 | Select the largest heading level to start your TOC list. For example, 2 will list h2, h3, and h4 headings, but will not include h1 headings.

Max Heading Level (maxLevel) | 7 | Select the smallest heading level to include in the TOC. For example, 2 will list h1 and h2, but will not include h3 and below.

Include Headings (include) | | Filter the included headings according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings.

Exclude Headings (exclude) | | Exclude headings according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings.

Printable (printable) | true | By default, the TOC is set to print. If you clear this parameter, the TOC will not be visible when you print the page.

CSS Class Name (class) | | If you have a custom TOC in your CSS style sheet, you can use this parameter to output the TOC with the specified “class” attribute.

**Examples**

The examples are based on a page with the following headings:

- Places
  - Favourite Places
  - Unknown Places
- Foods
  - Favourite Foods
  - Unknown Foods
- Things
  - Favourite Foods
  - Unknown Foods

**Filtered Table of Contents**

This example will filter all headings to include those that contain "Favourite", but will exclude any heading which ends with the word "Things". The list is styled with upper-case Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>list</td>
</tr>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
</tbody>
</table>
Exclude Headings | .*Things

**Screenshot: Filtered TOC ‘zone’ headings**

- I. Favourite Places
- II. Favourite Foods

**Flat List**

This example will filter all headings to render a flat list of "Unknowns" enclosed in square brackets.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Separator</td>
<td>brackets</td>
</tr>
<tr>
<td>Max Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

**Screenshot: Filtered TOC ‘zone’ headings displayed as a flat list**

[ Unknown Places ] [ Unknown Foods ] [ Unknown Foods ]

**Notes**

- Due to an outstanding issue in the Table of Content Zone macro (CONF-10619), the Macro Browser's Refresh function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Content Zone macro occurs only after the page is saved.

- Using HTML heading markup with the Table of Content Zone macro — The Table of Content Zone macro cannot handle HTML heading markup on its own. Hence, if you used the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Content Zone macro will not create a contents list out of these headings. (For more information on about this issue, please refer to TOC-93.)

However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Content Zone macro will incorporate these headings into your contents list.

```
<h2><a name="pagename-headingname"></a>Heading Name</h2>
```

The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** toc-zone

**Macro body:** Accepts rich text.

**Storage format example**
Tip Macro

Using the Tip macro, you can highlight a helpful tip on a Confluence page. The macro creates a green-coloured box surrounding your text as shown below.

Using the Tip macro

To add the Tip macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros.**
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete.**

**To edit an existing macro:** Click the macro placeholder and choose **Edit.** A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>The title of the tip. If specified, it will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>(title)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Tip Icon</td>
<td>true</td>
<td>If cleared, the icon will not be displayed.</td>
</tr>
<tr>
<td>(icon)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** tip

**Macro body:** Accepts rich text.

**Storage Format example**

```xml
<ac:structured-macro ac:name="tip">
  <ac:parameter ac:name="icon">false</ac:parameter>
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:rich-text-body>
    <p>This is my hint.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Wiki markup example**

```
{tip:icon=false|title=My title}
This is my hint.
{tip}
```

User List Macro

The User List macro displays a list of users registered in Confluence, based on their group membership.

**Using the User List macro**

To add the User List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group(s) (groups)</td>
<td>none</td>
<td>Specifies one or more groups whose Confluence users you want to list, using a comma-separated list of group names. To see all users registered in a Confluence installation, specify an asterisk (**) for this parameter’s value.</td>
</tr>
</tbody>
</table>
| **Display Online/Offline Users (online)** | All registered users | List online or offline users. Leave blank to show all users, irrespective of status.  
Accepted values:  
- Unspecified – The macro will show all registered users.  
- true – The macro will show only online users.  
- false – The macro will show only offline users.  
In order to make this feature functional, a System Administrator needs to enable the User Log In Listener for your Confluence site. |

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** userlister

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="userlister">
  <ac:parameter ac:name="groups">confluence-users</ac:parameter>
  <ac:parameter ac:name="online">false</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{userlister:groups=confluence-users|online=false}
```

**User Profile Macro**

The User Profile macro displays a short summary of a given Confluence user’s profile. This is the same summary that appears in a Hover Profile, which appears whenever you mouse over a user’s name in the Confluence interface.

**Screenshot: Example of the User Profile macro**

![User Profile macro example](image)

**Using the User Profile macro**

To add the User Profile macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>none</td>
<td>The username of the Confluence user whose profile summary you wish to show.</td>
</tr>
<tr>
<td>(user)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** profile

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="profile">
  <ac:parameter ac:name="user">
    <ri:user ri:userkey="12345678912345678912345678912345"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{profile:user=admin}
```

**User Status List Macro**

The User Status List macro displays a history of a given Confluence user's status updates. This is the same history that appears in the user's Status Updates view.

**Screenshot: Example output of the User Status List macro**

```
“Time to look at networks
  Clear · Delete · Feb 15, 2013

“Updating my profile picture
  Delete · Feb 15, 2013

“Making Confluence sing...
  Delete · Feb 15, 2013
```
Using the User Status List macro

To add the User Status List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>none</td>
<td>The username of the Confluence user whose history of status updates you wish to show.</td>
</tr>
<tr>
<td>(username)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Notes

Hint: If you wish to list status updates made by more than one user, you can use the Recently Updated macro with the following parameter values:

- Include these Content Types Only: status
- Author(s) by username: The user(s) whose status updates you want to include in the list. If you leave this field blank, the status updates of all users will be included.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: status-list

Macro body: None.

Storage format example

```<ac:structured-macro ac:name="status-list">
<ac:parameter ac:name="username">
  <ri:user ri:userkey="12345678912345678912345678912345"/>
</ac:parameter>
</ac:structured-macro>```

Wiki markup example

`{status-list:username=admin}`

View File Macro

The View File macros allow you to embed an Office or PDF document into your Confluence page. First attach the document to a page and then use one of the View File macros to display the document's content.

When people view the page, they will see the content of the Office or PDF document. They do not need to have
Office installed in order to see the content of an Office document. If they do have Office installed, people will be able to open the document for editing in their Office application.

For a full list of Office Connector prerequisites and limitations, please refer to:

- Office Connector Prerequisites
- Office Connector Limitations and Known Issue

For an overview of all Office Connector features, please refer to Working with the Office Connector.

**Displaying an Office or PDF Document in Confluence**

To display an Office or PDF document in a page, use one of the following View File macros in the macro browser:

- Office Excel
- Office PowerPoint
- Office Word
- PDF

To add one of the View File macros to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters for the Office and PDF macros**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Macro</th>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All View File macros</td>
<td>Page Name</td>
<td>The page which contains the macro</td>
<td>Enter a page name, if you wish to display a document which is attached to another Confluence page.</td>
</tr>
<tr>
<td></td>
<td>File Name</td>
<td>none</td>
<td>The file name of the Office or PDF document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>Office Excel</td>
<td>Show Grid?</td>
<td>true</td>
<td>Select to show grid lines around each cell of the Excel spreadsheet. Clear to hide these grid lines.</td>
</tr>
<tr>
<td></td>
<td>Worksheet Name</td>
<td>Last worksheet viewed in the spreadsheet</td>
<td>The name of the worksheet that you want displayed.</td>
</tr>
<tr>
<td></td>
<td>Last Row</td>
<td>Last row with content</td>
<td>The number of the last row you want displayed, starting from '0' as the first row.</td>
</tr>
<tr>
<td><strong>Last Column</strong></td>
<td><strong>Last column with content</strong></td>
<td><strong>The number of the last column you want displayed, starting from ‘0’ as the first column.</strong></td>
<td></td>
</tr>
<tr>
<td>-----------------</td>
<td>----------------------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Hint for reducing the size of the spreadsheet:</strong> Use the <strong>Last Column</strong> and <strong>Last Row</strong> parameters to reduce the size of the spreadsheet displayed on the wiki page. This is especially useful to prevent the display from showing empty cells. This will also help to prevent ‘out of memory’ errors.</td>
<td></td>
</tr>
</tbody>
</table>

**Office PowerPoint**

<table>
<thead>
<tr>
<th><strong>Height</strong></th>
<th><strong>Specify the height of the display, in pixels (default) or as a percentage of the window's height.</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Slide Number</strong></td>
<td><strong>none</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Specify the number of the slide that you want displayed on the Confluence page, where the first slide is numbered zero. Instead of a slide show, the page will display just the single slide, represented as a JPEG image. If not specified, all slides display as a slideshow.</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Width</strong></th>
<th><strong>Specify the width of the display, in pixels (default) or as a percentage of the window's width.</strong></th>
</tr>
</thead>
</table>

**Editing an Office document**

You can launch your Office application and edit Office documents displaying in the view file macros directly from your Confluence page.

- **Word** and **Excel** - choose the **Edit Document** link above the content
- **PowerPoint** - choose the edit icon on the viewer.

You will find more information and other methods for editing attached Office documents in **Editing an Office Document from Confluence**.

**Troubleshooting**

Problems? Please refer to our guide to the **Office Connector limitations and known issues**.

**Code examples**

Refer to the page for each macro to see storage format and wikimarkup examples.

- **Office Excel Macro**
- **Office PowerPoint Macro**
Confluence 5.5 Documentation

- Office Word Macro
- PDF Macro

Warning Macro

The Warning macro is useful for highlighting a warning on a Confluence page. The macro creates a red-coloured box surrounding your text as shown below.

⚠️ Example of a Warning Macro
This text appears inside the Warning macro.

Using the Warning macro

To add the Warning macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>The title of the warning note. If specified, will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>(title)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Warning Icon</td>
<td>true</td>
<td>If &quot;false&quot;, the icon will not be displayed.</td>
</tr>
<tr>
<td>(icon)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** warning

**Macro body:** Accepts rich text.

**Storage format example**

```xml
<ac:structured-macro ac:name="warning">
    <ac:parameter ac:name="icon">false</ac:parameter>
    <ac:parameter ac:name="title">This is my title</ac:parameter>
    <ac:rich-text-body>
        <p>This is <em>important</em> information.</p>
    </ac:rich-text-body>
</ac:structured-macro>
```

**Wiki markup example**
Widget Connector Macro
The Widget macro, or Widget Connector, allows you to embed certain multimedia content from other web sites into your Confluence page.

It supports the following content:

- Gadgets and other widgets: Google Gadgets, Widgetbox.
- Videos: YouTube, MySpace Video, Yahoo Video, Dailymotion, Episodic, Vimeo, Metacafe, blip.tv, Viddler.
- Photos and images: Flickr, Skitch.com.
- Micro-blogging: Twitter, FriendFeed, BackType.
- Documents and presentations: SlideShare, SlideRocket, Scribd, presentations on Google Docs. Note: The integration with Google Docs is currently broken. Please refer to CONF-24927 for details of the issue.
- Calendars: Google Calendar.
- Forms and online databases: Wufoo HTML Form Builder and Wufoo Reports.
- Support and customer satisfaction: Get Satisfaction.

There are live examples of many of these on the widget examples page. If you wish to extend the functionality of this plugin, please see Extending the Widget Connector.

---

On this page:
- Using the Widget Connector
- Parameters
- Examples of macro sources
- Troubleshooting
- Code examples
  - Storage format example
  - Wiki markup example

Related pages:
- Working with Macros
- Confluence User's Guide

---

Using the Widget Connector

To add the Widget Connector to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
</table>

---

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Web Site's Widget URL
(url)

This is the URL provided by the external web site for embedding content from that web site onto another web page.

Pixel Height (Value Only)
(height)

Specify the height of the display, in pixels.

Pixel Width (Value Only)
(width)

Specify the width of the display, in pixels.

**Examples of macro sources**

**Google Gadgets**

You need to find the URL for the Google Gadget you want to display.

Here is one way to find a gadget's URL:

1. Go to the [Google Gadgets directory](#).
2. Find the gadget you want then click its name, such as ‘Spider’.
3. The gadget's summary page will open. Copy the URL from your browser's address bar. The URL looks something like this one:


You can also use the URL of the 'add gadget' page. The page is called 'Add "gadgetx" to your iGoogle page':

1. There are a couple of ways to get to the 'add gadget' page:
   - Click a '+Google' button underneath the gadget when displayed on a page somewhere.
   - Or click 'Add Stuff' on your iGoogle page.
2. Copy the URL from your browser's address bar. The URL would look something like this one:

   http://www.google.com/ig/adde?synd=open&source=ggyp&moduleurl=abowman.googlepages.com/spider.xml

**Widgetbox widgets**

You will need to find the URL for the Widgetbox widget you want to display.

Here is one way to find a widget's URL:

1. Ensure you are logged in to Widgetbox and that you are viewing the [Widgetbox Gallery](#).
2. Find the widget you want then click its name, such as 'cyber-pet'.
3. The widget's summary page will open. Within the Get Widget section, click the Atlassian Confluence icon. The Widgetbox Add to Confluence dialog box appears, containing the URL required for the Widget Macro.
   - If you cannot see this icon, click the **more...** link to reveal it.
4. In the Widgetbox Add to Confluence dialog box, click **Copy**.
5. Copy the URL from your browser's address bar. The URL looks something like this one:

   http://widgetbox.com/confluence/b832?e33-c8eb-4a38-b842-fba866ffdd28

**YouTube**

You will need to find the URL for the YouTube video that you want to display.

To find a YouTube video's URL:

1. Go to [YouTube](#) and search for the video you want.
2. Click the title of the video, such as 'Wikis in Plain English'.
3. The video's summary page will open on YouTube. Choose **Share**.
4. Choose **Options**, located under the video's URL.
5. Choose **Long link**, then copy the long URL. It looks something like this:

   ![Long link example](http://au.youtube.com/watch?v=-dnL00TdmLY)

**Note:** You must use the long YouTube URL. The shortened URL (like this one: [http://www.youtu.be](http://www.youtu.be) /<video_key>) does not work in the widget connector. If you are unable to view the video in some browsers, use https: rather than http in your link.

**MySpace Videos**

You will need to find the URL for the MySpace video that you want to display.

To find a MySpace video's URL:

1. Go to [MySpace Video](http://www.myspace.com) and search for the video you want.
2. Click the title of the video, such as 'Glacier Creek Confluence Time Lapse'.
3. The video's summary page will open. Copy the URL from your browser's address bar. The URL looks something like this:

   ![MySpace URL example](http://vids.myspace.com/index.cfm?fuseaction=vids.individual&videoid=3376248&searchid=20c789f6-laе9-459a-bfec-75efcfc2847c)

**Yahoo Video**

You will need to find the URL for the Yahoo video that you want to display.

To find a Yahoo video's URL:

1. Go to [Yahoo Video](http://video.yahoo.com) and search for the video you want.
2. Click the title of the video, such as 'Wiki Technology Trend: Past, Now and Future'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:

   ![Yahoo URL example](http://video.yahoo.com/watch/423158/2424140)

   *Tip:* If you are unable to obtain a unique URL from your browser's address bar, click the envelope (Share) icon on the lower section of the video screen and copy the contents of the **Link** field.

**Dailymotion Video**

You will need to find the URL for the Dailymotion video that you want to display.

To find a Dailymotion video's URL:

1. Go to [Dailymotion](http://www.dailymotion.com) and search for the video you want.
2. Click the title of the video, such as 'Wiki Technology Trend: Past, Now and Future'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:

   ![Dailymotion URL example](http://www.dailymotion.com/user/spacevidcast/video/x7zevj_spacevidcast-2009-promo-video_tech)

   *Tip:* If you are unable to obtain a unique URL from your browser's address bar, click **Menu** at the lower right section of the video screen, select **URL & Embed Code** and copy the contents of the **Link** field.
Episodic

You will need an Episodic user account if you want to create and distribute videos via Episodic.

To embed an Episodic video onto a Confluence page:

1. Find the video and copy the URL from the address bar of your browser. The URL looks something like this:

   http://app.episodic.com/shows/13/episodes/493

2. Paste the URL into the Web Site's Widget URL box in the Macro Browser.

Vimeo

You will need to find the URL for the Vimeo video that you want to display.

To find a Vimeo video's URL:

1. Go to Vimeo and search for the video you want.
2. Click the title of the video, such as 'The Wiki Show - Allison the Russian High Kicker'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.vimeo.com/909808

Metacafe

You will need to find the URL for the Metacafe video that you want to display.

To find a Metacafe video's URL:

1. Go to Metacafe and search for the video you want.
2. Click the title of the video, such as 'Wikis In Plain English (How To)'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.metacafe.com/watch/679493/wikis_in_plain_english_how_to/

Blip.tv

This integration is currently broken. Please refer to CONF-27266 for details of the issue.

Viddler

This integration is currently broken. Please refer to CONF-27267 for details of the issue.

Flickr

You can embed a slide show of photos from Flickr by supplying a URL that specifies one of the following:

- Photos with a specific tag.
- Photos belonging to the photostream of a specific Flickr user.
- A set of photos as defined by the Flickr user.
- A user's photostream starting at a specific photo.

If you want to do something else, we suggest that you try any Flickr URL. It should work.

Below are some examples of the Widget macro code for embedding Flickr images.

Flickr Photos with a Specific Tag

This URL displays a slide show of Flickr photos that are tagged with the word 'Atlassian' http://www.flickr.com/ph
Flickr Photos from a Specific User

This URL displays a slide show of photos from the Flickr photostream of user 'Atlassian': http://www.flickr.com/photos/atlassian/

Flickr Photos from a Specific Set

This URL displays a slide show of Flickr photos from the set 'Melbourne Cup - November 2008' created by user 'Atlassian': http://www.flickr.com/photos/atlassian/sets/72157608657271078/

A Specific Flickr Photo

This URL displays a slide show of photos from the Flickr photostream of the user 'Atlassian', starting with a specific photo: http://www.flickr.com/photos/atlassian/3003538919/

Skitch.com

You will need to find the URL for the Skitch image that you want to display.

To embed a Skitch image onto a Confluence page:

2. Find the image and copy the URL from the address bar of your browser. The URL looks something like this:
   
   [URL]

   **Note:** Skitch is now integrated with Evernote, as described in this blog post from *The Next Web*: Evernote is bringing Skitch into its core service, Skitch.com will be archived. As a result, private images on Skitch.com are no longer accessible and will not work in the Confluence widget connector. Existing public images on Skitch.com will remain available.

Twitter

**Note:** Due to a recent change to the Twitter API, the process for displaying Tweets has changed. The following instructions relate to v 2.1.6 of the Widget Connector plugin. Earlier versions of the Widget Connector no longer display tweets correctly.

To embed a single tweet:

1. In Twitter, navigate to the tweet you wish to embed and choose Details to display just that tweet in your browser.
2. Copy the page URL (the URL should be in the following format, https://twitter.com/atlassian/status/346976521250037760).
3. In Confluence, paste the URL into the Widget Connector.
4. The single tweet will display, like the one below.

   ![Twitter Tweet]

To embed a dynamic list of tweets:

1. In Twitter, create a Widget (go to Settings > Widgets).
2. Configure the widget to display the tweets you wish to embed (for example, a user timeline, list of tweets...
or hashtag search).

3. Save the widget, then copy the page URL (the URL should be in the following format, https://twitter.com/settings/widgets/354381809263472640/edit)

4. In Confluence, paste the URL into the Widget Connector.

5. The list of tweets will display, like the one below.

FriendFeed

To display the latest messages from a FriendFeed user, add the user's FriendFeed link as the URL in the Widget macro. For example:

BackType

To display the latest blog or website comments from a BackType user, add the user's BackType widget link as the URL in the Widget macro. For example:

SlideShare

You will need to find the URL for the SlideShare presentation that you want to display.

To find a SlideShare presentation's URL:

1. Go to SlideShare and search for the presentation you want.
2. Click the title of the presentation, such as 'Using JIRA & Greenhopper for Agile Development'.
3. The presentation's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.slideshare.net/jleyser/using-jira-greenhopper-for-agile-development

SlideRocket

You will need to find the URL for the SlideRocket presentation that you want to display.

To find a SlideRocket presentation's URL:

1. Log in to SlideRocket and go to your library of presentations.
2. Copy the 'web link' for the presentation you want to display. This will give you a URL that looks something like this one:

   http://app.sliderocket.com/app/FullPlayer.aspx?id=132f9db7-b0fb-4f51-b974-36652774971b
3. Paste the URL into the Widget macro code on your Confluence page.

Scribd

You will need to find the URL for the Scribd presentation that you want to display.

To find a Scribd presentation's URL:

1. Go to Scribd and search for the presentation you want.
2. Click the title of the presentation, such as 'My Sea Friends Coloring Book'.
3. The presentation's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:


4. Paste the URL into the Widget macro code on your Confluence page.

Google Docs Presentations

This integration is currently broken. Please refer to CONF-24927 for details of the issue.

Google Calendar

You can embed a Google Calendar into your page and to do this, you will need to add the URL for the Google Calendar that you want to display.

To find the URL for a Google Calendar:

1. Log in to Google Calendar.
2. In the calendar list on the left side of the page, ensure the appropriate calendar is selected, click the down-arrow button next to the calendar name and then select the Calendar settings option. (Alternatively, if available, click the Manage Calendars link at the bottom of the calendar list and then click the name of the appropriate calendar.)
3. In the Calendar Address section, click the HTML button. A pop-up message with your calendar's public URL appears.
4. Copy the URL from this pop-up message. The URL looks something like this:

   http://www.google.com/calendar/embed?src=somebody%40example.com&ctz=Australia/Sydney

5. Paste the URL into the Widget macro code on your Confluence page.

Wufoo HTML Form Builder

To display an HTML form built in the Wufoo HTML Form Builder, add the form's link as a URL to the Widget Macro. For example:

http://examples.wufoo.com/forms/contact-form/

Wufoo Reports

To display a Wufoo Report built using the Wufoo Report Manager, add the report's link as a URL to the Widget Macro. For example:

http://examples.wufoo.com/reports/example-satisfaction-survey-report/

Get Satisfaction social support application

To display a feedback form for a Get Satisfaction community, add the community or company link as a URL to the Widget Macro. For example:
**Troubleshooting**

If the URL given in the Widget Connector macro does not work, the macro displays an icon and the base URL. For example, the following code:

```
http://example.com/invalid
```

will result in an image like the one below:

![example.com](http://example.com)

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** widget

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="widget">
   <ac:parameter ac:name="height">480</ac:parameter>
   <ac:parameter ac:name="width">640</ac:parameter>
   <ac:parameter ac:name="url">
      <ri:url ri:value="http://youtube.com/watch?v=23pLByj_q5U"/>
   </ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
```

**Widget Connector Examples**

This page contains working examples of some services currently supported by the Widget Connector. This page lets you preview what each widget will look like and see how to interact with it. For detailed usage, see [Widget Connector Macro](#).

**Flickr**
On this page:
- Flickr
- Google Docs
- YouTube
- MySpace
- Vimeo
- BlipTV
- Viddler
- Skitch
- Twitter
- FriendFeed
- SlideShare
- SlideRocket
- Scribd
- Wufoo
- Example of widget error message

Related pages:
- Widget Connector Macro
- Working with Macros
- Confluence User's Guide

Google Docs

This integration is currently broken. Please refer to ⚠ CONF-24927 for details of the issue.

YouTube

[http://au.youtube.com/watch?v=-dnL00TdmLY](http://au.youtube.com/watch?v=-dnL00TdmLY)

Note: You must use the long YouTube URL, available under Share > Options. For detailed instructions, see the user's guide to the widget macro.

MySpace

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Vimeo

http://www.vimeo.com/909808

BlipTV

This integration is currently broken. Please refer to CONF-27266 for details of the issue.

Viddler

This integration is currently broken. Please refer to CONF-27267 for details of the issue.

Skitch

Skitch is now integrated with Evernote, as described in this blog post from *The Next Web: Evernote is bringing Skitch into its core service*, Skitch.com will be archived. As a result, private images on Skitch.com are no longer accessible and will not work in the Confluence widget connector. Existing public images on Skitch.com will remain available.

Twitter

http://twitter.com/mcannonbrookes

search.twitter.com

http://search.twitter.com/search?q=AtlassianDragons

FriendFeed

http://friendfeed.com/myname

SlideShare

http://www.slideshare.net/jleyser/using-jira-greenhopper-for-agile-development-presentation
SlideRocket

http://app.sliderocket.com/app/FullPlayer.aspx?id=132f9db7-b0fb-4f51-b974-36652774971b

Scribd


Wufoo

http://examples.wufoo.com/forms/contact-form/

Example of widget error message

This is an example of the error message you will see, if the Widget connector cannot find the URL or service specified.

http://example.com/invalid

Task Report Macro

Use the Task Report macro to display a list of tasks on a page. Filter the tasks by space, page, user, label, created date and more.

See Working with Tasks for more information on creating and assigning tasks. You can also use the Task Report blueprint, which will create a page and add this macro for you.

Using the Task Report macro

To add the Content Report Table macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Task Report macro showing incomplete tasks, on pages with the label 'meeting-notes'.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space(s) and Page(s) (spaceAndPage)</td>
<td>No</td>
<td>None</td>
<td>Filter by the task location. The macro will only display tasks in the pages or spaces specified. You can enter a combination of spaces and pages.</td>
</tr>
<tr>
<td>Label(s) (labels)</td>
<td>No</td>
<td>None</td>
<td>Filter by Label. The macro will only display tasks on pages with this label. You can enter multiple labels, separated by a comma.</td>
</tr>
<tr>
<td>Assigned to (assignee)</td>
<td>No</td>
<td>None</td>
<td>Filter by Assignee. The macro will only display tasks assigned to the users specified.</td>
</tr>
<tr>
<td>Created by (creator)</td>
<td>No</td>
<td>None</td>
<td>Filter by Creator. The macro will only display tasks created by the users specified.</td>
</tr>
<tr>
<td>Created after (createddateFrom)</td>
<td>No</td>
<td>None</td>
<td>Filter by created date. The macro will only display tasks created on or after the date specified. Date must be entered as dd-mm-yyyy.</td>
</tr>
<tr>
<td>Task status (status)</td>
<td>No</td>
<td>None</td>
<td>Show complete, incomplete or all tasks.</td>
</tr>
<tr>
<td>Number of tasks to display (pageSize)</td>
<td>No</td>
<td>20</td>
<td>The number of tasks to display on each page of results in the table. Choose from 10, 20 or 40.</td>
</tr>
</tbody>
</table>
Display columns
(columns)
| No |
| description,duedate,assignee,location |
| Columns to include in the table. Available columns include description, duedate, assignee, location, completedate and labels. |

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** tasks-report-macro

**Macro body:** None.

**Storage format example**

Note: The `spaceAndPage` multi-picker parameter populates the `spaces` and `pages` parameters.

```xml
<ac:structured-macro ac:name="tasks-report-macro">
  <ac:parameter ac:name="spaces">BSP</ac:parameter>
  <ac:parameter ac:name="status">complete</ac:parameter>
  <ac:parameter ac:name="assignees">
    <ri:user ri:userkey="2c9682654373c47f014373caa68a0003"/>
  </ac:parameter>
  <ac:parameter ac:name="spaceAndPage">space:BSP,page:2555905</ac:parameter>
  <ac:parameter ac:name="pages">2555905</ac:parameter>
  <ac:parameter ac:name="labels">meeting-notes</ac:parameter>
  <ac:parameter ac:name="pageSize">10</ac:parameter>
</ac:structured-macro>
```

**Wiki markup**

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

**Working with Drafts**

A draft is a ‘snapshot’ of unsaved page content, which Confluence creates automatically at regular intervals while you are editing a page or blog post. This can minimise the loss of work if your Confluence site experiences a problem, since you can retrieve the page content from your last saved draft.

How do drafts work in Confluence?

At regular intervals, Confluence automatically saves a draft of the page you are editing. If a network failure or system error prevents you from saving your page, you can retrieve its last saved draft and continue working on the page from the last saved draft.

Drafts are created while you are adding and editing a page or blog post. Each new draft replaces the previously saved draft. By default, Confluence saves a draft of your page once every thirty seconds. However, a Confluence administrator can configure how often drafts are saved. In addition, whenever you edit a page and then move to another screen, Confluence will automatically save a draft.

When you edit the page again, Confluence will let you know that a version of the page you are editing was not saved and will give you the option to resume editing it.

Each time Confluence saves a draft, it displays a message and the time of the last save near the Save button on the edit screen.
How do drafts work in Confluence?

Viewing drafts

Viewing your unsaved changes

Related pages:

- Resuming the Editing of a Draft
- Configuring the Time Interval at which Drafts are Saved
- Concurrent Editing and Merging Changes
- Confluence User's Guide

More about drafts:

- A user only has access to the drafts of pages they have been working on and whose content has not yet been saved.
- A user cannot create a draft explicitly.
- A user's drafts are listed in the 'Drafts' tab of their profile.
- Once a user has resumed editing a draft, or chosen to discard it, the draft is removed from their drafts tab.

Viewing drafts

Your drafts are listed on the **Drafts** tab of your user profile.

**To see your drafts:**

Choose your profile picture at top right of the screen, then choose **Drafts**.

Viewing your unsaved changes

While editing a page or blog post, you can view any 'unsaved' changes you have made since the last automatically saved draft, by clicking **view change** (near the **Save** button).

Configuring the Time Interval at which Drafts are Saved
By default, Confluence saves a draft of your page once every thirty seconds. Confluence administrators can configure how often drafts are saved.

As a Confluence administrator, you can set the time interval at which drafts are saved as follows:

1. Choose the cog icon, then choose General Configuration under Confluence Administration.
2. Click Further Configuration in the left-hand panel.
3. Edit the setting for Draft Save Interval.

Concurrent Editing and Merging Changes

Sometimes, two or more people may edit a page at the same time. When this happens, Confluence will do its best to ensure that nobody's changes are lost.

How will I know if someone else is editing the same page as I am?

If another user is editing the same page as you, Confluence will display a message above your edit screen letting you know who the other user is and when the last edit was made.

Screenshot: Notification of Simultaneous Page Editing

What happens if two of us are editing the same page and the other user saves before I do?

If someone else has saved the page before you, when you click 'Save', Confluence will check if there are any conflicts between your changes and theirs. If there are no conflicting changes, Confluence will merge the changes.

If there are conflicts, Confluence will display them for you and give you the option to:

- **Continue editing** - you can continue to edit the page, useful if you want to manually merge the changes.
- **Overwrite** - this will replace the other person's edits with yours.
- **Cancel** - this will discard your changes and exit the editor, keeping the other person's edits.

Example Scenario

For example, Alice and Bob both edit the same page at the same time.

If Alice clicks save before Bob, Bob is now effectively editing an out-of-date version of the page. When Bob clicks save, Confluence will examine his changes to see if any overlap with Alice's. If the changes do not overlap (i.e. Alice and Bob edited different parts of the page), Bob's changes will be merged with Alice's automatically.

If Bob's changes overlap with Alice's, Confluence will display an error message to Bob showing where Alice has changed the page, and giving Bob the options to overwrite Alice's changes with his own, to re-edit the document to incorporate Alice's work, or to cancel his own changes entirely, maintaining Alice's changes.

Resuming the Editing of a Draft

If you have typed some content into a Confluence page or blog post, Confluence will save a draft of it, even if you were not able to successfully save the page or blog post, or add a title to it.

There are two ways to resume editing an unsaved page or blog post:

A. Using your drafts view. To resume editing a draft from this view:

1. Choose **your profile picture** at top right of the screen, then choose **Drafts**.
2. Choose **Resume Editing** next to the appropriate draft to resume editing that draft.
**Note:** If you had not yet entered a page title, the draft will be listed with the title 'Untitled'.

B. If you had created a new page or blog post but did not save it, then when you next add a page or blog post in that space, Confluence will ask you if you want to resume editing the page that was not saved. If you click **resume editing**, the draft and its unsaved content will be restored, allowing you to continue editing it.

**Related pages:**
- Working with Drafts

**Screenshot: Resume Editing**

---

**What happens if I am editing the draft of a page that has since been updated?**

When this happens, Confluence will display a message informing you that you are editing an outdated page. If there are no conflicts between the two versions, Confluence will give you the option to **Merge and Resume editing**.

If there are any conflicts, Confluence will give you the option to **View the Conflict** or to **Discard** your changes.

**Recording Change Comments**

A 'change comment' is a short description that summarises the changes made to a page during an editing session. Change comments are a useful way of keeping track of the history of a page.

A change comment is not the same as a comment added to a page. Refer to [Commenting on pages and blog posts](#) for information about that type of comment.

Note that once a change comment has been added and the page has been saved, it is not possible to update or remove the change comment.

**On this page:**
- Entering a Change Comment
- Viewing a Change Comment
- Viewing a History of Change Comments

**Related pages:**
- Viewing Page Information
- Page History and Page Comparison Views
- Confluence User's Guide

**Entering a Change Comment**

You can enter change comments in the field located below the edit screen:

**Screenshot: Entering change comments**

---

**Viewing a Change Comment**

To see the most recent change to a page and any change comment that may have been entered, choose the edited date on the byline. You can also go to **Tools > Page History** to see change comments for all versions.
Viewing a History of Change Comments

The change comments for a page are recorded under the ‘Recent Changes’ section of the page’s ‘Info’ view and in the page’s ‘History’ view.

Screenshot: History of change comments on Info view

Creating Beautiful and Dynamic Pages

Confluence has a number of features that help you build attractive pages to engage your readers and give them the opportunity to interact with up-to-date information. This page summarises those features and provides links to detailed instructions.

Adding visual appeal

Pictures, photographs and screenshots. Confluence pages can display images from your Confluence site and from other websites. To put an image into Confluence, you can upload it and attach it to a page or blog post, then display it on any page, blog post or comment. Alternatively, display an
image from a remote location via the web address [Displaying Images](URL). See .

**Galleries.** Use the [Gallery Macro](#) to display a set of images. When viewing the page, people can click any of the pictures to zoom in and view the images as a slide show.

**People.** Add a [Profile Picture Macro](#) to show a picture of a Confluence user, or a [User Profile Macro](#) to show a summary of the person's profile as well as their avatar.

**Multimedia.** You can display movies, animations and videos, and embed audio files on your Confluence page. For example, Confluence supports Adobe Flash, MP3, MP4, and various other movie formats. See [Embedding Multimedia Content](#).

**Social video and image sharing.** The Widget macro displays live content from social sites such as [YouTube](#) and other video sharing sites, and [Flickr](#) for shared photographs. See the guide to the .

**Widget Connector Macro**

**Bringing numbers to life**

The [Chart Macro](#) offers a variety of graphs and charts that you can use to illustrate statistics and other numerical data.

*Illustration: A 3-dimensional bar chart produced by the Chart macro*

**Displaying presentations and documents**

Display your Office documents and other presentations directly in Confluence.

- Attach your Office documents to a Confluence page then display them on the page, using the [View File Macro](#). This works for Excel spreadsheets, PowerPoint presentations and Word documents.
- Display PDF files in Confluence too, also with the [View File Macro](#).
- Use the [Widget Connector Macro](#) to show slide decks hosted on SlideShare and other
online presentation sites.

Pulling in content from your issue tracker

Many project teams and customers have useful information on a JIRA issue tracker. Rather than copying and pasting it onto your Confluence page, you can display it directly from the source, thus ensuring that the information shown in Confluence is always up to date.

Link to a feature request in your issue tracker, or display a list of fixed issues – useful for release notes and project planning. See the JIRA Issues Macro.

Telling a story in pictures

A number of Confluence add-ons provide sophisticated tools for creating diagrams and mockups.

For example:

- Balsamiq Mockups for Confluence
- Creately for Confluence
- Gliffy Confluence Plugin
- Graphviz Plugin for Confluence
- Lucidchart for Confluence

Search the Atlassian Marketplace for more add-ons.

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Varying the structure of your pages

You can build up a custom layout by using the page layout tool to add sections and columns to your page. See the detailed guidelines to Working with Page Layouts and Columns and Sections.

Do you need to display tabular data, which your readers can sort when viewing the page? See Working with Tables.

Use other macros to highlight and format sections of your page:

- Panel
- Tip
- Info
- Note
- Warning
- Code block
- Noformat

Integrating your content with social media

People share information on various social sites. You can make Confluence a focal point where people collect their shared information and see what is happening in the areas that matter to them.
Use the **Widget Connector macro**:
- Show a live stream of tweets from a Twitter user, or tweets matching a Twitter search.
- Display a video from YouTube or other online movie sites.
- Share photographs from Flickr.
- Display slide decks hosted on SlideShare and other online presentation sites.
- See what else the **Widget Connector macro** can do.

**Showing activity streams**

Make your Confluence pages dynamic and interactive with:

- An activity stream showing updates and comments on Confluence and other linked applications. See *Working with Confluence Gadgets*.
- An RSS feed from within Confluence or an external site. See *Subscribing to RSS Feeds within Confluence*.
- A list of recent blog posts from within Confluence. See *Blog Posts Macro*.

**Working with Templates**

When you add a new page, you do not have to write the content from scratch. Instead, you can base your new page on a template. A template is a Confluence page with predefined content. Some templates are provided by blueprints or add-ons, others are defined by Confluence users.

Some examples of where templates are useful:

- A software development project may have a template for use cases.
- A systems administration space may have a template for defining what information is kept about each server.

**Global templates and space templates**

In Confluence, there are two places to store your page templates:

- **Space templates**: These page templates are available in a specific space only. People who have space administrator permission can define templates via the space administration screen.
- **Global templates**: These page templates are available in every space on the site. People who have Confluence Administrator permission can define the global templates via the Confluence Administration Console.

System administrators can also download predefined templates.

**On this page:**

- Global templates and space templates
- Creating a template
- Using a template
- Templates provided by blueprints
- Promoting templates in the Create dialog
- System templates

**Related pages:**

- Adding a Template
- Administering Site Templates
- Importing Templates
- Creating a Page using a Template
- Confluence User's Guide

Creating a template
You can write your template using the Confluence editor. You can also add special variables to the page, if you want to include fields that the author will complete when adding the page. See Adding a Template for more information.

Using a template

Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the Atlassian Marketplace for template add-ons.

See Creating a Page using a Template for more information.

Templates provided by blueprints

A blueprint is a page template with added functionality to help you create, manage and organise content in Confluence.

Confluence ships with some predefined blueprints. You can also download additional blueprints from the Atlassian Marketplace. You can customise the blueprint templates to suit your individual needs, disable particular blueprints or even develop your own blueprints.

See Working with Blueprints.

Promoting templates in the Create dialog

Space administrators can choose to promote specific templates and blueprints in the Create dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular types of content over blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank Page and Blog Post collapsed under them. To view the other types of content available choose the Show more link.

To promote a template or blueprint:

1. Go to Space Tools > Content Tools.
   If your space is using the Documentation theme choose Browse > Space Admin > Templates.
2. Choose Promote next to the templates or blueprints you want to appear in the Create dialog.

Remember: by promoting a blueprint or template you will be hiding all other items, including blank page and blog post, under the Show more link.

System templates

Confluence also provides 'system templates' containing content like the site welcome message and default space content. See Administering Site Templates.

Adding a Template

A template is a predefined page that can be used as a framework when creating new pages. Templates are
useful for setting a common style or format for a page.

In Confluence, there are two places to store your page templates:

- **Space templates**: These page templates are available in a specific space only. People who have space administrator permission can define templates via the space administration screen.
- **Global templates**: These page templates are available in every space on the site. People who have Confluence Administrator permission can define the global templates via the Confluence Administration Console.

### Adding a space template

Space templates are available in one space only.

**To add a template for a space:**

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Templates > Add New Space Template**.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   
   Note: The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **Templates** from the space administration options.
3. Choose **Add New Space Template**.

The 'Create Template' screen will appear. Add content as described **below**.

### Adding a global template

Global templates are available in all spaces in your Confluence site.

**To add a global template:**

1. Choose the cog icon, then choose **General Configuration** under Confluence Administration.
2. Choose **Global Templates and Blueprints** in the left-hand panel.
3. Choose **Add New Global Template**.

The 'Create Template' screen will appear. Add content as described **below**.
This illustration shows the template editor with an image, some text, styling, and variables.

This screenshot shows the form displayed when someone creates a page based on the template containing the above variables. (See Creating a Page using a Template.)
Adding content to your template

Add a name for your template.

Enter text into the body of the template, and use the editor toolbar to apply styles, layout and formatting. You can add links and macros. In general, you can use the Confluence editor in the same way as on a page. In addition, you can add variables which will produce a form for data collection when someone adds a page based on the template.

Below are some points of special interest in templates.

**Labels**

Choose [Labels](#) to add one or more labels to the template. These labels will be included in all pages created using this template.

**Images and other attachments**

You cannot attach an image or other file to a template. Instead, attach the file to another page, and insert it into the body of the template.

For example:

- You can attach an image to a page and then choose **Insert > Image** to embed the image into the
template.

- You can attach a PDF file to a page and then choose Insert > Other Macros > PDF to embed the PDF file into the template.

**Variables used as form fields**

You can add variables to your template, to act as form fields. When someone creates a page based on the template, Confluence will display a text entry box for each field. The user can enter data into each field, and the data is inserted onto the new page.

Every variable must have a unique name. If you add the same variable more than once in the same template, Confluence will make sure that they have the same value when the user saves the page. This is useful if you need the same information in more than one place in the page.

**To insert a variable into a template:**

1. Place your cursor on the template where you want the variable to appear.
2. Choose Template > New Variable from the editor toolbar. Alternatively, you can choose the name of an existing variable if you want the same variable to appear more than once in the template.
3. Enter the variable name.
4. Press Enter. By default this will create a single-line text input field.
5. To change the variable type, click the variable placeholder. The variable’s property panel will appear. Choose one of the variable types: Text, Multi-line Text, or List. See below for a description of each type.

**Speeding up variable entry with autocomplete:** Type $ and the variable name, then press Enter, to add a new variable or to select an existing variable from a list of suggestions. The suggestions are drawn from variables already defined in this template.

These are the types of variable available:

<table>
<thead>
<tr>
<th>Variable type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Creates a single-line text input field.</td>
</tr>
<tr>
<td></td>
<td><em>Screenshot: A template variable called $purpose and its property panel</em></td>
</tr>
<tr>
<td></td>
<td>This tutorial helps you to $purpose.</td>
</tr>
<tr>
<td></td>
<td><img src="image1.png" alt="Text, Multi-line Text, List" /></td>
</tr>
<tr>
<td>Multi-line text</td>
<td>Creates a text box that allows more than one line of text.</td>
</tr>
<tr>
<td></td>
<td>By default, the text area is 5 rows depth and 100 characters wide. You can change the size by typing over the digits in the variable property panel.</td>
</tr>
<tr>
<td></td>
<td><em>Screenshot: A multi-line variable and its property panel</em></td>
</tr>
<tr>
<td></td>
<td><img src="image2.png" alt="Text, Multi-line Text, List" /></td>
</tr>
</tbody>
</table>
List

Creates a dropdown list.

You must specify the values that will appear in the dropdown list. The values:

- Must be separated by commas.
- Can include letters, numbers, special characters, and spaces.
- Cannot include commas (except as the list separation character).

Screenshot: A list variable and its property panel

<table>
<thead>
<tr>
<th>Instructional text</th>
</tr>
</thead>
</table>

Instructional text allows you to add placeholder content to a template. This text is only visible in the editor and disappears when the author of the page begins typing.

To insert instructional text into a template:

1. Place your cursor on the template where you want the instructional text to appear.
2. Choose Template > Instructional Text on the editor toolbar.
3. Begin typing - the instructional text appears in italics with a shaded background to distinguish it from normal paragraph text.

You can also change the placeholder type from 'text' to other types, including some that trigger an action such as a user mention or creating a JIRA issue.

The following instructional text types are available:

<table>
<thead>
<tr>
<th>Instructional text type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Creates a line of text that is only visible in the editor. Instructional text disappears when the user begins typing.</td>
</tr>
<tr>
<td>User Mention</td>
<td>Creates a line of text that is only visible in the editor. When clicked it triggers the @mentions dialog.</td>
</tr>
</tbody>
</table>
Adding a description to your template

The template description displays in the 'Create' dialog and is useful for explaining the purpose of a template to users.

**To add a description to a template:**

- Go to the space or global templates page (as described above).
- Choose the **Edit** icon in the 'Description' column.
- Enter your description and save.

Converting an existing page to a template

If you would like to convert an existing page to a template, you can copy the content from the page and paste it into the template editor. There is no automated way of doing this.

Please note the section above about images and other attachments in templates.

Notes

- You cannot insert variables via the 'Insert wiki markup' option in the editor toolbar.
- Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the [Atlassian Marketplace](https://marketplace.atlassian.com) for template add-ons.
- When you use a Table of Contents macro in a template, you will see an error when you preview the template itself. But the Table of Contents macro works on the pages that people create from the template – the table of contents shows up after they have saved the page. (This is probably because the template is not defined as a page, and the Table of Contents macro works for pages only.)
- The editor for templates is available only in [Confluence 4.3 and later](https://confluence-docs.atlassian.com/confluence/4.3). Please refer to the [earlier documentation](https://confluence-docs.atlassian.com/) for a description of the wiki markup editor templates.
- Confluence also provides 'system templates' containing content like the site welcome message and default space content. See [Administering Site Templates](https://confluence-docs.atlassian.com/).

Creating a Page using a Template

You can create a page based on a global template (available to all spaces) or a space template (available only to that space). Before reading this page, make sure that someone has already created a template on your Confluence site.

Information copied from the template to the page

When you create a page based on a template, Confluence will copy the following content and information from the template to the new page:

- Labels
- Text and styles
• Layouts and formatting
• Macros
• Embedded images and other files. Note that you cannot attach an image or other file to a template. But if the template displays an image or file from another page, the new page will display that image or file too.

Form fields displayed by the template

If the template author included variables in the template, Confluence will display a form prompting you to supply values for the variables when you add the page.

On this page:
• Information copied from the template to the page
• Form fields displayed by the template
• Using a template to create a page
• Notes

Related pages:
• Adding a Template
• Using the Editor
• Working with Confluence Labels
• Confluence User's Guide

Using a template to create a page

To create a page based on a template:

1. Choose Create on the header
2. Select a space and the template you want to use and choose Next
3. If the template contains variables, you will now see a form. Type the relevant information into the form fields, and choose Next.
4. Now you will see a new page based on the template. If you added information in the form fields, the page content will include that information.
5. Type a name for the page where you see 'New Page'.
6. Add more content or make any other changes required.
7. Choose Save.

Screenshot: Form showing template variables when creating a page from a template
Notes

Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the Atlassian Marketplace for template add-ons.

Editing a template

A template is a predefined page that can be used as a prototype when creating new pages. Templates are useful for giving pages a common style or format. This page is about changing an existing template.

Note: Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the Atlassian Marketplace for template add-ons.

In Confluence, there are two places to store your page templates:

- **Space templates:** These page templates are available in a specific space only. People who have space administrator permission can define templates via the space administration screen.
- **Global templates:** These page templates are available in every space on the site. People who have Confluence Administrator permission can define the global templates via the Confluence Administration Console.

Confluence also provides 'system templates' containing content like the site welcome message and default space content. See Administering Site Templates.

---

**Minutes for**

**Status Meeting** *(MeetingName)*

**Date**  
15/02/2013 *(Date)*

**Time**  
9:00 AM *(Time)*

**Location**  
Meeting Room 1 *(Location)*

**Attendees**

**Apologies**

---

**Minutes**

- Add the first item here...
To edit a space template:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. A list of templates for the space displays. Choose Edit next to the template that you want to modify.
3. Make changes, or add new content, as you would when adding a template.
4. Choose Save.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   Note: The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Templates from space administration options.
3. A list of templates for the space displays. Choose Edit next to the template that you want to modify.
4. Make changes, or add new content, as you would when adding a template.
5. Choose Save.

To edit a global template:

1. Choose the cog icon, then choose General Configuration under Confluence Administration.
2. Choose Global Templates and Blueprints in the left-hand navigation panel.
3. A list of templates for the Confluence site displays. Choose Edit next to the template that you want to modify.
4. Make changes, or add new content, as you would when adding a template.
5. Choose Save.

For more information on editing the content of a template, including adding macros, variables and instructional text see - Adding Content to a Template.

Deleting a Template

A template is a predefined page that can be used as a prototype when creating new pages. Templates are useful for giving pages a common style or format. This page is about deleting an existing template, at space level or at site (global) level.

Templates are used only when adding a page. Once a page has been added, the template is no longer linked to the page. You can therefore delete the template without affecting any existing pages.

You need to be a space administrator to delete a space template, and you need Confluence Administrator permissions to delete a global template.

Note: Deleted templates cannot be restored.

To delete a space template:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. A list of templates for the space displays. Choose Delete next to the template that you want to delete.
3. Confirm the deletion when prompted.

If your space uses the Documentation Theme:

1. Choose Browse > Space Admin at the top of the screen.
   Note: The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Templates from the space administration options.
3. A list of templates for the space displays. Choose **Delete** next to the template that you want to delete.
4. Confirm the deletion when prompted.

**To delete a global template:**

1. Choose the cog icon ️, then choose **General Configuration** under Confluence Administration.
2. Choose **Global Templates and Blueprints** in the left-hand navigation panel.
3. A list of templates for the Confluence site displays. Choose **Delete** next to the template that you want to delete.
4. Confirm the deletion when prompted.

**Working with Blueprints**

**What is a blueprint?**

A blueprint is a set of page templates with added functionality to help you create, manage and organise content in Confluence more easily.

Create meeting notes, shared file lists and requirements documentation out of the box. **Customise the blueprint templates** to suit your individual needs. You can even **develop your own blueprints**.

**On this page:**

- Creating content using a blueprint
- Customising blueprint templates
- Promoting blueprints in the Create dialog
- Adding more blueprints
- Disabling a blueprint
- Full list of blueprints

**Related pages:**

- Working with Templates
- Confluence User’s Guide
- Requesting Add-ons

**Creating content using a blueprint**

You create a page from a blueprint in the same way as other pages in Confluence. All blueprints are different and most contain instructions to guide you.

**To create a page from a blueprint in the current space:**

1. Choose **Create** on the header.
2. Choose a blueprint from the ‘Create’ dialog.
3. Choose **Create**.
4. The editor will open, a prompt to enter information, or the page will appear, depending on the blueprint selected. You can now follow the instructions built in to the blueprint to add content.

The first time a blueprint is used in a space, Confluence creates an index page and adds a shortcut to your sidebar (if you are using the default theme). The index shows information from your blueprint pages, for example the meeting notes index displays a list of all meeting notes pages in the space.

**Screenshot: Index page for the Meeting Notes blueprint**
If you are using the Documentation theme, your blueprint index pages will appear in the sidebar as children of the homepage.

_Screenshot: Index page for the File List blueprint with the Documentation theme applied to the space_

Customising blueprint templates

Blueprints are made up of templates that can be customised for an individual space or the whole site. This means you can adapt the content of the blueprint pages to suit your specific needs. For example, you might update the Meeting Notes blueprint templates to include a heading for apologies.

If you have _space administrator permissions_, you can customise blueprint templates for the spaces you are an administrator of. You must be a Confluence Administrator to customise blueprint templates for a whole site. See _Administering Site Templates_ for more information.

To customise a blueprint template for a space:

1. Go to the space and choose _Space tools > Content Tools_ on the sidebar.
2. Choose _Edit_ beside the blueprint template you wish to edit.
3. Make your changes to the template and choose _Save_.

Editing a blueprint template is very similar to editing a page template except:

- You should be careful not to remove any macros that the blueprint page or index page may use to store and display information.
- You cannot remove a blueprint template or change the template name.

To reset a blueprint template back to the default:

1. Go to the space and choose _Space tools > Content Tools_ on the sidebar.
2. Choose _Reset to default_ beside the blueprint template you wish to reset.
See Working With Templates and Administering Site Templates for more information on templates.

As with user created space and site templates, editing a blueprint template will not change existing pages, but any new blueprint pages will be based on the updated template.

Promoting blueprints in the Create dialog

Space administrators can choose to promote specific templates and blueprints in the Create dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular types of content over blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank Page and Blog Post collapsed under them. To view the other types of content available choose the Show more link.

To promote a template or blueprint:

1. Go to Space Tools > Content Tools.
   If your space is using the Documentation theme choose Browse > Space Admin > Templates.
2. Choose Promote next to the templates or blueprints you want to appear in the Create dialog.

Remember: by promoting a blueprint or template you will be hiding all other items, including blank page and blog post, under the Show more link.

Adding more blueprints

You can find more blueprints for Confluence in the Atlassian Marketplace. Blueprints are managed using add-ons (also known as plugins).

See Requesting Add-ons for information on how you can search for new blueprint add-ons and send a request to your System Administrator.

If you are a System Administrator, see Managing Add-ons and Macros for information on how to install new blueprint add-ons.

You can also develop your own blueprints. See our developer documentation on Writing a Blueprint.

Disabling a blueprint

You may want to disable particular blueprints. For example, you may not want to see the Product Requirements blueprint in the Create dialog in a HR or Social space. If you are a Confluence Administrator you can also disable particular page and space blueprints for the whole site.

To disable a blueprint in a space:

- Go to the space and choose Space tools > Content Tools on the sidebar.
- Choose Disable next to the blueprint you wish to disable in that space.

You can re-enable the blueprint at any time.

To disable a blueprint across a whole site:
• Choose the cog icon, then choose General Configuration under Confluence Administration. You need Confluence Administrator permissions to do this.
• Choose Global Templates and Blueprints.
• Choose Disable next to the page or space blueprint you wish to disable.

The blueprint will not appear in the ‘Create’ or ‘Create Space’ dialogs.

Full list of blueprints

Here’s the full list of blueprints that are bundled with Confluence.

<table>
<thead>
<tr>
<th>Page blueprints</th>
<th>Space blueprints</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Meeting notes</td>
<td>• Documentation space</td>
</tr>
<tr>
<td>• File list</td>
<td>• Team space</td>
</tr>
<tr>
<td>• Decision</td>
<td>• Knowledge base space</td>
</tr>
<tr>
<td>• How-to article</td>
<td></td>
</tr>
<tr>
<td>• Troubleshooting article</td>
<td></td>
</tr>
<tr>
<td>• JIRA report</td>
<td></td>
</tr>
<tr>
<td>• Product requirements</td>
<td></td>
</tr>
<tr>
<td>• Retrospective</td>
<td></td>
</tr>
<tr>
<td>• Share a link</td>
<td></td>
</tr>
<tr>
<td>• Task report</td>
<td></td>
</tr>
</tbody>
</table>

Decisions Blueprint

The Decisions blueprint helps you make decisions and record the outcomes with your team.

The first time you use the Decisions blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you are using the default theme). The index acts as your Decision Register and lists all the decisions in that space.

Related pages:
• Working with Blueprints
• File List Blueprint
• Meeting Notes Blueprint
• Product Requirements Blueprint

To use the Decisions blueprint:

• Create a Decisions blueprint page (choose Create > Decision)
• Enter information about the decision and stakeholders - the blueprint will prompt you.

Screenshot: Decision Register showing a series of Decision pages.

Screenshot: Editing a Decision page.
The Decisions blueprint uses these Confluence features:

- **Page Properties** and **Page Properties Report** macro - content that you enter within the page properties macro can appear on the index page.
- **Mentions** - add a user as a stakeholder, owner or @mention them on the page and they will be notified in their workbox.

Customising this blueprint

You can customise the templates that are used by the Decisions blueprint - see Customising the blueprint templates.

You might choose to edit the index page in a space to change the columns to be displayed by the Page Properties Report macro.

You might choose to edit the page template to add some headings or instructional text to the background section, or even add rows to the Page Properties macro, for example a row for the date the decision was made.

To find out more about using instructional text in a template see - Instructional text.

### File List Blueprint

The File List blueprint helps you to create lists of files to share with your team. Great for organising documents, images and presentations.

The first time you use the File List blueprint in a space, Confluence will create an index page and add a shortcut to your space sidebar (if you are using the default theme). The index page lists the latest File List pages in that space. You can have as many File List pages as you need.

**Related pages:**
- Working with Blueprints
- Meeting Notes Blueprint
- Product Requirements Blueprint

**To use this blueprint:**

- Create a File List page (choose Create > File List).
- Drag files from your desktop or choose Browse to attach files to the page.
- Attachments appear on the page. Expand each attachment to preview the file or see attachment details.

In this example three File List pages have been created to store project related presentations, images and
customer feedback. Confluence looks after the versioning of the files, so there is no need to use the document file name to mark version numbers.

Screenshot: Index page showing File List pages.

Screenshot: A File List page.

Add a new file list page

File list pages

Add File Lists

Expand to see attachment detail

Preview attachment

Version history

Upload and download files

Drag and drop to upload or browse for files

Download All
Customising this blueprint

You can customise the templates that are used by the File List blueprint - see Customising blueprint templates.

The File List blueprint template uses the attachments macro. You could customise the macro to change the sort order or hide features such as version history and the upload attachment fields. To find out more about the attachments macro see Displaying a List of Attachments.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages you want to display.

Meeting Notes Blueprint

The Meeting Notes blueprint helps you to plan your meetings and share notes and actions with your team.

The first time you use the Meeting Notes blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you are using the default theme). The index page lists the latest Meeting Notes pages in that space.

To use the Meeting Notes blueprint:

- Create a Meeting Notes blueprint page (choose Create > Meeting Notes).
- Enter goals, agenda items, @mention attendees - the instructional text will prompt you.
- Save your page and get ready to attend your meeting.
- During or after your meeting edit the page and enter your notes, action items and @mention users to assign them to tasks.

Screenshot: Index showing three Meeting Notes pages.

<table>
<thead>
<tr>
<th>Blue Sky Project</th>
<th>Pages / Blue Sky Project Home</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meeting Notes</td>
<td>Add a meeting notes page</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Title</th>
<th>Creator</th>
<th>Modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>2013-03-12 - Meeting Notes</td>
<td>Ewan User</td>
<td>Mar 12, 2013</td>
</tr>
<tr>
<td>2013-02-20 - Meeting Notes</td>
<td>Leah Admin</td>
<td>Feb 25, 2013</td>
</tr>
<tr>
<td>2013-02-24 - Meeting Notes</td>
<td>Leah Admin</td>
<td>Feb 25, 2013</td>
</tr>
</tbody>
</table>

Screenshot: A blank Meeting Notes page showing instructional text.
The Meeting Notes blueprint uses some cool Confluence features:

- **Instructional text** - this handy text prompts you to enter information and disappears when you start typing or view the page.
- **Mentions** - @mention a user on the page and they will be notified in their workbox.
- **Task lists** - @mention a user in a task to assign them - the task will appear as a personal task in their workbox.

Customising this blueprint

You can customise the templates that are used by the Meeting Notes blueprint - see Customising the blueprint templates.

You might choose to edit the headings or add additional headings, or change the instructional text that prompts users to enter information to suit your context. To find out more about using instructional text in a template see - Instructional text.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages you want to display.

**Product Requirements Blueprint**

The Product Requirements blueprint helps you to define, scope and track requirements for your product or feature.

The first time you use the Product Requirements blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (shortcut only available in the default theme). The index lists all the Product Requirements pages in that space, and displays a summary of the information on each page (such as status and owner). You can have as many Product Requirements pages as you need.
To use the Product Requirements blueprint:

- Create a Product Requirements blueprint page (choose Create > Product Requirements)
- Enter information about your product or feature - the instructional text will prompt you.
- Mention team members and other contacts.

Screenshot: Index showing a series of Product Requirements pages and summary information.

Screenshot: Editing a Product Requirements page.
The Product Requirements blueprint uses these Confluence features:

- **Page Properties** and **Page Properties Report** macro - content that you enter within the page properties macro can appear on the index page.
- **Instructional text** - this handy text prompts you to enter information or create a JIRA issue and disappears when you start typing or view the page.
- **Mentions** - @mention a user on the page and they will be notified in their workbox.

**Customising this blueprint**

As no two products or projects are alike, you can customise the templates that are used by the Product Requirements blueprint - see [Customising the blueprint templates](#).

You might choose to edit the **index** page in a space to change the columns to be displayed by the Page Properties Report macro.

You might choose to edit the **page template** to:

- edit the headings or add additional headings
- change the instructional text that prompts users to enter information to suit your context
- add or remove rows within the Page Properties macro.

To find out more about using instructional text in a template see - [Instructional text](#).

**Shared Links Blueprint**

The Shared Links blueprint helps you take content from the web and share it with your team.
You can use Shared Links to share and collaborate on web content, or to create a centralised repository of useful links.

The first time you use the Shared Links blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you are using the default theme). The index lists all the shared links in that space.

**Related pages:**
- Working with Blueprints
- Decisions Blueprint
- File List Blueprint
- Meeting Notes Blueprint
- Product Requirements Blueprint

**To use the Shared Links blueprint:**
- Choose Create > Share a link.
- Enter the URL of the web content you want to share.
- Choose Create.

You can also:
- include topics to help categorise your links - these are added as labels to your page.
- share the link immediately with another user or group - users will receive a notification.
- add a comment to start the discussion.

To make sharing links even faster, you can add a Share on Confluence button to your browser’s toolbar. Click this button and the webpage you are currently viewing will be added as a shared link!

**To add the Share on Confluence button to your browser:**
- Choose Create > Share a link.
- Drag the Share on Confluence button to your browser toolbar.

Now when you want to share a link on Confluence, you can choose the Share on Confluence button in your browser, and follow the prompts.

**Screenshot: Share a link from the Create dialog.**

**JIRA Report Blueprint**

The JIRA Report blueprint helps you create easy to read reports to communicate the progress of your JIRA projects and releases.
You can choose from a Change Log report that generates a list of JIRA issues or a Status Report that includes charts to visually communicate your progress.

The first time you use the JIRA Reports blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you are using the default theme).

To use the JIRA Report Blueprint your Confluence and JIRA sites must be connected via Application Links.

Creating a Change Log

The Change Log report displays a list of issues from JIRA. This list can be static or dynamic, automatically updating as the status of your issues change in JIRA.

To create a static Change Log:

- Choose Create > JIRA Reports.
- Select a Report Type.
- Select your JIRA server.
- Choose a Project and Fix Version to report on.
- Choose Create.

A report page will be created with some sample text, and a list of all issues for the project and fix versions selected - organised by issue type. This list of issues is static, it will not be updated when the issues in JIRA are updated, and is visible to users who do not have JIRA access or permissions to view that project.

Screenshot: Creating a Change Log in simple mode.

Screenshot: Static list of JIRA Issues displaying in the Change Log.
To create a dynamic change log:

- Choose Create > JIRA Reports.
- Select a Report Type.
- Choose Advanced.
- Enter a JQL query or paste in the URL of a JIRA search. Find out about using JQL in the JIRA Documentation.
- Choose Create.

A report page will be created with sample text and a JIRA issues macro that is configured to show your issues. The macro is dynamic and will update when the issues in JIRA are updated. For more information on how to further change the information displayed, refer to the JIRA Issues macro.

Screenshot: Dynamic list of JIRA Issues displaying in the Change Log.

Creating a Status Report

The Status Report displays the progress of a JIRA project and fix version in pie charts by status, priority, component and issue type. The Status Report uses the JIRA Chart macro, and is dynamic.

To create a status report:

- Choose Create > JIRA Reports.
- Select Status Report.
- Select your JIRA server.
- Choose a Project and Fix Version to report on or enter a JQL query or JIRA URL.
- Choose Create.

A report page will be created with sample text and a series of pie charts, using the JIRA Chart macro. The macro is dynamic and will update when the issues in JIRA are updated. For more information refer to the JIRA Chart macro.

As with the Change Log, you can switch to Advanced mode and use JQL or paste in a JIRA URL to search for issues to display in the report.

Screenshot: Excerpt from the Status Report.
Customising this blueprint

You can customise the templates that are used by this blueprint. The Change Log uses the **Snapshot JIRA Report Template** (for static list of issues) and the **Dynamic JIRA Report Template**, and the Status Report uses the **Status Report Template**. See **Customising the blueprint templates**. Variables represent the JIRA Issues and JIRA Chart Macros - while these cannot be edited, they can be moved around the page or deleted if you do not want every chart to be included.

You might choose to edit the **page template** to modify the format of the page, change some headings or modify the instructional text. To find out more about using instructional text in a template see - **Instructional text**.

### Retrospectives Blueprint

Retrospective blueprints help you track team successes and opportunities after projects or at the end of a sprint. Use this blueprint to document what went well, what needed improvement, and assign actions for the future.

**Related pages:**
- Working with Blueprints
- File List Blueprint
- Meeting Notes Blueprint

**Using Retrospective blueprints**

Here’s how to use this blueprint for your next retrospective:

1. Create a Retrospective from the **Create** button in the header. The Run a Retrospective dialog appears with today’s date populated in the title.
2. Add teammates and participants.
3. Click **Create**.

Your new Retrospective blueprint loads.

The Retrospective blueprint uses the following Confluence features:

- **Page Properties** and the **Page Properties Report** macro make content listed within the macro visible on the index page.
- **Instructional text** prompts you to enter information and disappears when you start typing or view the page.
- **Mention** a user on the page to notify them in their workbox.

Customising this blueprint

Every team conducts retrospective meetings differently. You can customise the Retrospectives blueprint template to match your team's culture and practices. You can:

- Edit headings and pre-populated text.
- Add instructional text to capture specific information.
- Add additional sections and content.
Creating a blueprint style report

Using a combination of templates and macros you can make a wide range of reports for managing anything from customer interviews, product requirements to IT service catalogues and more. In this tutorial we will guide you through the process of creating a blueprint style report.

In this example we will create a multi-team status report. Here's the scenario we will use for this tutorial.

The Design, Development and QA teams working on the Blue Sky Project need to produce a short status update page each week, containing the focus area for the week, contact person, risks and overall status for each team. They like the way the Product Requirements blueprint works and want to be able to manage their status updates in a similar way.

What do each of the players want out of this report?

- **Project Lead** wants an at a glance report that shows only the status for each team.
- **Team Leads** want a summary report, including the focus areas and risk, just for their team.
- **All team members** want it to be easy to create the new page each week.
- **Management Team** want to see all the details for a week on one page, and do not want to have to look at a different page for each team.

With this scenario in mind, this tutorial will guide you through how to:

1. Create a status update template containing a separate page properties macro for each team's section of the report.
2. Create a high level status report, showing just the status of all teams.
3. Create a summary report for each team.
4. Add a button that can be used to create a new report page each week.

⚠️ You’ll need Space Administrator permissions to complete some of the steps in this tutorial.

### 1 Create a status update template

First we will create a page template and add the Page Properties macros.

1. Go to **Space Admin > Content Tools > Templates**.
2. Choose **Create Template**.
3. Give the template a name (in this example the template will be called ‘Status Update’)
4. Add the skeleton of your status report to the page.
   - Here’s what ours looks like...
5. Add a **Label** to the template (in this example we will add 'status-update' as the label).

Now we will add a Page Properties macro to record the status of the Design team.

1. Add the Page Properties macro to the page (Choose **Insert > Other Macros > Page Properties**).
2. In the macro body create a two column table and remove the heading row.
3. In the left column enter the column headings for your report, these are known as metadata 'keys' (in this example we will add 'Design Focus', 'Design Status', 'Design Contact' and 'Design Risks').
4. In the right column, leave the cells blank, or enter some instructional text to prompt your users (Choose **Template > Instructional Text**). We've also added a status macro.
5. **Edit** the Page Properties macro, and enter a **Page Properties ID** for this macro (in this example we will use 'status-update-design') this will allow us to report on the status of just the Design team later on.

Repeat this process for the Development and QA teams, remembering to specify a different ID for each macro (we used 'status-update-dev' and 'status-update-qa').

Here's what ours looks like...
Finally, add any other headings, instructional text or content to your template and Save. You can enter a Description for your template - this appears in the Create dialog.

2 Create a report showing the high level status of each team

Next we will create an index page, just like you see in many blueprints.

1. In your space create a new blank page - this will be our ‘Status Report - all teams’ page, showing just the status of each team.
3. Enter the Label to report on (in this example it will be 'status-update', the label we added to the template page earlier)
4. Leave the Page Properties ID field blank - we want to report on all the macros on the page.
5. In the Columns to Show field, list the 'keys' from each macro that you want to include in the report (in this example we only want to show the values of 'Design Status', 'Dev Status', 'QA Status').
   - See how this looks in the macro browser...
6. Choose Save to add the macro to the page.

Now we will add a button to the page to allow team leads to easily create new status update pages from the template we created earlier.

1. Add the Create from Template macro to the page (Choose Insert > Other Macros > Create from Template)
2. Enter the text for the button (in this example we will call the button 'Create a new status update')
3. Select the template from the Template Name drop down (in this example our template was called 'Status Update')
4. Specify the title of any pages to be created - this is a great way to keep your titles consistent (in this example we will call the page 'Status update week ending @Date' which will append the current date when the page is created - as in the meeting notes blueprint)
5. Choose Insert.
6. Add any other content, links or images to the page and Save.
7. Add a shortcut to the page on the sidebar (Choose Space Tools > Configure Sidebar > Add Link).

3 Create a separate report for each team

Now we will create some index pages that show a more detailed summary for each team. We'll start with the Design team.

1. Create a new blank page - this will be the 'Design Status Report' index page, showing just information for that team.
3. Enter the Label (the page label is once again 'status-update', the label we added to the template)
4. Enter the Page Properties ID that was specified in the Page Properties macro in the template (in this example it was 'status-report-design') - this allows us to report on just information in that macro.
5. Leave the Columns to Show field blank this time, we want to show all columns from this Page Properties macro.
   - See how this looks in the macro browser...
6. Choose **Save** to add the macro to the page.
7. Add any other content, links or images to the page and **Save**.
8. Add a shortcut to the page on the sidebar (Choose **Space Tools** > **Configure Sidebar** > **Add Link**)

Create a new page and repeat this process for each team, remember to specify a different Page Properties ID each time (in this example 'status-report-dev' and 'status-report-qa').

If your Design, Dev and QA teams have their own team spaces, this summary report could even be created in their team spaces. Just be sure to specify the space where the Status Updates pages are created in the **Restrict to spaces** field, to make sure the macro can find the pages to report on.

4 Create your first status update page

That's it - choose **Create** > **Status Update** or use the **Create a new status update** button to make your first status update page. Just like a blueprint, but 100% made by you.

Here’s how our finished pages look.

*Team Leads and the management team still have a single page for the weekly status update.*
The Project Lead can see the status of each team, each week, at a glance in the All Teams status report.

Each team can see their focus, risks and status at a glance in their status report.
Remember, these concepts don’t just apply to status updates - you can use them for any purpose at all. Tell us about how you’ve made your own blueprint style reports in comments.

**Working with the Office Connector**

The Office Connector is bundled with Confluence 2.10 and later. It allows you to:

- Import an Office document into Confluence format
- Attach an Office document to a Confluence page and display its content in Confluence, without converting the content.
- Edit the attached document in the Office application, directly from the Confluence page.

Please be aware that source code is currently not available for the Confluence Office Connector.

**Table of Contents**

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing a Word Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Installing the Firefox Add-On for the Office Connector

**Related Topics**

- View File Macro
- Confluence User’s Guide
  - Configuring the Office Connector

**Office Connector Prerequisites**

The page describes the software and setup you need to use the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site.

Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

**Overall prerequisites**
- Ensure that Java 5 (JDK 1.5) or higher is installed on your Confluence server.
- The WebDAV plugin must be enabled, because the Office Connector uses WebDAV to transfer information to and from Office documents. Note that the WebDAV plugin is bundled with Confluence, and can be enabled or disabled by the System Administrator. If necessary, refer to the instructions on enabling plugins and configuring the WebDAV options.
- Ensure that your Confluence server's base URL is set correctly. (Check it by going to the 'General Configuration' screen in the Confluence Administration Console, as described in Configuring the Server Base URL.) When a user edits a wiki page in Word and then uploads the page back to the Confluence server, the base URL determines where the document will be saved. If the base URL is incorrect, the documents may be saved to a different Confluence server.

Prerequisites for viewing Office and PDF files in Confluence

If you want to use the View File macro, or to view Office files attached to a Confluence page, you need the setup described below.

**Browsers and Flash Player**

You can use any browser to view an Office file on a wiki page or attachment view, provided that you have installed Adobe Flash Player version 9 or later. You do not need to have an Office desktop application installed on your computer in order to view Office files in Confluence.

**File Types**

Confluence can display files compatible with Microsoft Office 97-2007, and PDF files, of the following types:

- .doc and .docx
- .xls and .xlsx
- .ppt and .pptx
- .pdf

---

**On this page:**

- Overall prerequisites
- Prerequisites for viewing Office and PDF files in Confluence
- Prerequisites for importing Word documents into Confluence
- Prerequisites for editing Office files directly from Confluence

**Related pages:**

- Working with the Office Connector
- Confluence User's Guide

---

Prerequisites for importing Word documents into Confluence

- Document import can import Microsoft Word documents of the file types .doc and .docx. These must be valid Word 97-2007 format documents.

Prerequisites for editing Office files directly from Confluence

The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.

To make use of these editing capabilities, you will need the setup described below.

**Browsers**

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.
- **Note: No Chrome support.** Chrome does not support WEBDAV clients, so this feature will not work. Please refer to this issue for more information: CONF-23322.
Office editors

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

Configuration matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, Windows Vista, or Windows XP with Service Pack 2 or 3</td>
<td>OpenOffice 2.x – 3.x, or Microsoft Office XP, 2003, 2007 or 2010</td>
<td>Internet Explorer 8.x – 9.x, or Firefox – latest stable version</td>
</tr>
<tr>
<td>Mac OS X 10.5 and 10.6</td>
<td>OpenOffice 2.x – 3.x The &quot;Edit in Word&quot; feature is known to work in OpenOffice 3.2.0.</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td>Linux</td>
<td>OpenOffice 2.x – 3.x The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.</td>
<td>Firefox – latest stable version</td>
</tr>
</tbody>
</table>

Displaying Office Files in Confluence

Confluence can display Office files that are attached to a page. If you have an Office application installed, you will also be able to edit these Office files in your Office application.

These are two of the ways that Confluence can interact with Office files. For an overview of all Office Connector features, please refer to Working with the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

On this page:

- Prerequisites
- Attaching and displaying Office files and PDF files
- Viewing and Editing the Attached Office Files
- Troubleshooting

Related pages:

- View File Macro
- Working with the Office Connector
- Confluence User's Guide

Prerequisites

If you want to use the View File macro, or to view Office files attached to a Confluence page, you need the setup described below.

Browsers and Flash Player

You can use any browser to view an Office file on a wiki page or attachment view, provided that you have
installed Adobe Flash Player version 9 or later. You do not need to have an Office desktop application installed on your computer in order to view Office files in Confluence.

File Types

Confluence can display files compatible with Microsoft Office 97-2007, and PDF files, of the following types:

- .doc and .docx
- .xls and .xlsx
- .ppt and .pptx
- .pdf

Attaching and displaying Office files and PDF files

There are two ways to do this in Confluence:

- Attach Office files to a page and display them in a Confluence page using the View File or Attachments macros
- Attach an Office or PDF file to a page and embed its contents onto the page by simply dragging and dropping it into the editor window

To attach and display Office files in Confluence using macros:

1. Attach the Office file(s) to a Confluence page:
   - View the Confluence page on which you want to display your document.
   - Choose Tools > Attachments.
   - Browse for your Office files and upload them to the Confluence page.
   - Refer to detailed instructions in Attaching Files to a Page.
2. Now you have two options for displaying the attached document:
   - You can embed the document into the Confluence page, using one of the Office Word, Office Excel, Office PowerPoint or View PDF macros. These macros can be found using the macro browser. Refer to the detailed instructions in the View File macro topic.
   - You can display a list of page attachments using the Attachments macro. People viewing the page will be able to click the View link to see the Office or PDF document in Confluence.

To attach and display an Office file on a Confluence page using 'drag and drop':

- Drag the Office file from your computer and drop it into the editor window. Only one file can be dragged and dropped at a time. The appropriate View File macro placeholder will appear in the position where you dragged the file. However, the contents of the file will be rendered in full when you preview, or save and view, the page.
  ⚠ Older browser versions may not support drag and drop - refer to Using Drag-and-Drop in Confluence.

Viewing and Editing the Attached Office Files

If an Office document is attached to a Confluence page, you can view the attached Office document from within Confluence. View the Office document in one of the following ways:

- View the list of attachments for a specific Confluence page, then click View next to the Office document on the Attachments page. (See Viewing Attachment Details.)
- View a list of attachments displayed on a page via the Attachments macro, then click View next to the Office document in the list of attachments. (See Displaying a List of Attachments.)
- View a Confluence page which has the Office document embedded in the page via the View File macro. (See View File Macro.)

Any Confluence user who has an Office application installed will also be able to launch their Office editor from within Confluence:

- Editing an Office Document from Confluence.
- Editing an Office Presentation from Confluence.
- Editing an Office Spreadsheet from Confluence.

Troubleshooting
Importing a Word Document into Confluence

The Office Connector in Confluence allows you to import a Word document into Confluence, so that the
document’s content is copied onto one or more Confluence pages.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office
Connector features, please refer to Working with the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector
options can appear in different places on your Confluence page, depending on the themes and configuration of
your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and
discuss any configuration problems with your administrator.

The simplest way to import a Word document is to import the entire content of the document into a single wiki
page. By default, the content of the document will be created as a new wiki page.

More advanced options allow you to import the content into a new page, to split a single document into more
than one wiki page, and to resolve conflicts in the titles of your pages.

These options are described below.

Prerequisites

Prerequisites for the Office Connector's document import feature:

- Document import can import Microsoft Word documents of the file types .doc and .docx. These must be
  valid Word 97-2007 format documents.

For a full list of Office Connector prerequisites and limitations, please refer to:

- Office Connector Prerequisites
- Office Connector Limitations and Known Issues

On this page:

- Prerequisites
- Importing a Word Document
- Splitting a Word Document into Multiple Wiki Pages

Related pages:

- Exporting to a Word document
- Working with the Office Connector
- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing a Word Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector
- Confluence User’s Guide

Importing a Word Document

The simplest way to import a Word document is to import the entire content of the document into a single wiki
page.

This method will replace any existing content on the wiki page.

To import a Word document onto a single wiki page:

1. Create a page in Confluence (see Creating Content) or go to an existing page whose content you want
   replaced. View the page in view mode (not edit mode).
2. Choose **Tools > Import Word Document**.
3. Click **Browse** and find the Word document on your local drive or network.
4. Click the **Open** or **Upload** button provided by your browser. The path and file name of the document will now appear in the text box on the Office Connector import screen.
5. Click **Next** on the Office Connector import screen. The import document options screen will display.
6. The import document options are:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root page title</td>
<td>The title of the wiki page that will contain the information from your imported document.</td>
</tr>
<tr>
<td>Import as a new page in the current space</td>
<td>A new wiki page will be created with the page title specified above.</td>
</tr>
<tr>
<td>Replace &lt;pagename&gt;</td>
<td>The contents of the existing page will be replaced. The page will be renamed to the page title specified above.</td>
</tr>
<tr>
<td>Delete existing children of &lt;pagename&gt;</td>
<td>The existing child pages of the page you are replacing will be deleted.</td>
</tr>
<tr>
<td>Rename imported pages if page name already exists</td>
<td>Assign new names to any new page which would otherwise have a duplicate name. The content of existing pages will remain unchanged.</td>
</tr>
<tr>
<td>Replace existing pages with imported pages of the same title</td>
<td>If imported pages have titles equal to existing pages, then the content of the Word document will overwrite the content on the existing page. Page history will be preserved.</td>
</tr>
<tr>
<td>Remove existing pages with the same title as imported pages</td>
<td>If imported pages have titles equal to existing pages, then the existing pages will be deleted. This will remove the page history as well as the content.</td>
</tr>
<tr>
<td>Split by heading</td>
<td>The content of the Word document will be split over multiple wiki pages. If you don't want to split your document into multiple wiki pages, leave the default <strong>Don't split</strong> option selected. For more information on splitting your document, please see below.</td>
</tr>
</tbody>
</table>

7. Click **Import**.

When the upload has finished, the content of the Word document will have been transformed into Confluence page content. You can now view and edit this page in the usual way. There is no connection between the original Word document and this wiki page.

**Screenshot: Empty page ready for import**

**Screenshot: Selecting Word document to import**
Splitting a Word Document into Multiple Wiki Pages

When importing a Word document, you can split a single document into more than one wiki page, based on the heading styles in the document.

By default, the page names will be the same as the heading text. This may result in a conflict, if a page already
exists with the same title. You can instruct the importer how to handle such conflicts.

**To import a Word document into multiple wiki pages:**

1. Import a Word document as described above. On the import document options screen, choose how to split your document in the ‘Split by heading’ field:
   - ‘Split by heading’ — If you want to split the content under each heading in your document into separate child pages, select the desired heading level to split by. A preview of the page hierarchy that will be created by the split will be displayed under ‘Document Outline’. Each bullet point in the ‘Document Outline’ represents a new page after import into Confluence.

2. Click ‘Import’ to import your document.

3. When the upload has finished, the content of the Word document will have been transformed into Confluence page content. You can now view and edit this page in the usual way. There is no connection between the original Word document and this wiki page.

**Screenshot: Splitting a single Word document into multiple wiki pages**

---

**Editing an Office Document from Confluence**

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows you to edit a Word document from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

**Prerequisites for Editing an Attached Office Document**

The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.

To make use of these editing capabilities, you will need the setup described below.

**Browsers**

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first
time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.

- **Note: No Chrome support.** Chrome does not support WEBDAV clients, so this feature will not work. Please refer to this issue for more information: CONF-23322.

**Office editors**

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

**Configuration matrix**

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7,</td>
<td>OpenOffice 2.x – 3.x, or Microsoft Office XP, 2003, 2007 or 2010</td>
<td>Internet Explorer 8.x – 9.x, or Firefox – latest stable version</td>
</tr>
<tr>
<td>Windows Vista, or</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows XP with Service Pack 2 or 3</td>
<td>Microsoft Office XP, 2003, 2007 or 2010</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td>Mac OS X 10.5 and 10.6</td>
<td>OpenOffice 2.x – 3.x</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td>The &quot;Edit in Word&quot; feature is known to work in OpenOffice 3.2.0.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Linux</td>
<td>OpenOffice 2.x – 3.x</td>
<td>Firefox – latest stable version</td>
</tr>
<tr>
<td>The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Editing an Office Document in your Office Application

To edit an Office document in your Office application:

1. There are two ways to do this:

   - **From an Office document embedded on a page:**
     a. Go to a Confluence page with an Office document embedded on it.
     b. Choose **Edit Document** above the embedded document.

   *Screenshot: Page with an embedded Word document showing the 'Edit Document' link*

   - **From an Office document in a list of attachments:**
     - If an Office file is **attached to a Confluence page**, you can edit this file directly in your compatible Office application, in one of the following ways:
• View the list of attachments for a specific Confluence page, then click **Edit in Office** next to the Office file on the Attachments page. (See Viewing Attachment Details.)
• View a list of attachments displayed on a page via the Attachments macro, then click **Edit in Office** next to the Office file in the list of attachments. (See Displaying a List of Attachments.)

2. A window will pop up, asking you to confirm that you want to open this document.

_Screenshot: Confirmation window in Firefox_

3. Click 'OK'. Now you may be asked to log in to your Confluence server.
4. Enter your Confluence username and password, then choose 'OK'.
5. The Office document will open in your Office application.
6. Make the necessary changes, then save the document. It will be saved back into Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

**Editing an Office Spreadsheet from Confluence**

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows you to edit an Excel spreadsheet from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.
Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

On this page:

- Prerequisites for Editing an Attached Office Spreadsheet
- Editing an Office Spreadsheet in your Office Application
- Troubleshooting

Related pages:

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing a Word Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector

Prerequisites for Editing an Attached Office Spreadsheet

The Office Connector allows you to edit Office files embedded in a wiki page or from the page’s attachments view.

To make use of these editing capabilities, you will need the setup described below.

Browsers

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.
- **Note: No Chrome support.** Chrome does not support WEBDAV clients, so this feature will not work. Please refer to this issue for more information: CONF-23322.

Office editors

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

Configuration matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
1. There are two ways to do this:

- **From an Office spreadsheet embedded on a page:**
  a. Open a Confluence page with an Office document embedded on it.
  b. Choose **Edit Document** above the embedded content.

  *Screenshot: The title bar showing 'spreadsheet.xls' above an embedded Excel spreadsheet*

- **From an Office spreadsheet in a list of attachments:**
  - If an Office file is **attached to a Confluence page**, you can edit this file directly in your compatible Office application, in one of the following ways:
    - View the list of attachments for a specific Confluence page, then click **Edit in Office** next to the Office file on the Attachments page. (See **Viewing Attachment Details**.)
    - View a list of attachments displayed on a page via the Attachments macro, then click **Edit in Office** next to the Office file in the list of attachments. (See **Displaying a List of Attachments**.)

2. A window will pop up, asking you to confirm that you want to open this document.

  *Screenshot: Confirmation window in Firefox*
3. Click 'OK'. Now you may be asked to log in to your Confluence server. Enter your Confluence username and password, then click 'OK'.
4. The Office spreadsheet will open in your Office application.
5. Make the necessary changes, then save the spreadsheet. It will be saved back into Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Editing an Office Presentation from Confluence

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows you to edit a PowerPoint presentation from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to Working with the Office Connector.

Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

Prerequisites for Editing an Attached Office Presentation

The Office Connector allows you to edit Office files embedded in a wiki page or from the page’s attachments view.

To make use of these editing capabilities, you will need the setup described below.

**Browsers**

- If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is required. You will find instructions in Installing the Firefox Add-On for the Office Connector.
- **Note: No Chrome support.** Chrome does not support WEBDAV clients, so this feature will not work. Please refer to this issue for more information: CONF-23322.
Office editors

To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

- If you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this option for each file type. See Installing the Firefox Add-On for the Office Connector.
- If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet Explorer.

Configuration matrix

You need one of the following software combinations to edit Office files from your wiki page:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Office Version</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, Windows Vista,</td>
<td><strong>OpenOffice</strong> 2.x – 3.x, or</td>
<td>Internet Explorer 8.x – 9.x,</td>
</tr>
<tr>
<td>Windows XP with Service</td>
<td>Microsoft Office XP, 2003,</td>
<td>Firefox – latest stable</td>
</tr>
<tr>
<td>Pack 2 or 3</td>
<td>2007 or 2010</td>
<td>version</td>
</tr>
<tr>
<td>Mac OS X 10.5 and 10.6</td>
<td><strong>OpenOffice</strong> 2.x – 3.x</td>
<td>Firefox – latest stable</td>
</tr>
<tr>
<td></td>
<td>The &quot;Edit in Word&quot; feature is</td>
<td>version</td>
</tr>
<tr>
<td></td>
<td>known to work in <strong>OpenOffice</strong> 3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>.2.0.</td>
<td></td>
</tr>
<tr>
<td>Linux</td>
<td><strong>OpenOffice</strong> 2.x – 3.x</td>
<td>Firefox – latest stable</td>
</tr>
<tr>
<td></td>
<td>The only known supported Office</td>
<td>version</td>
</tr>
<tr>
<td></td>
<td>editor for Linux is OpenOffice.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>But in theory it should work with</td>
<td></td>
</tr>
<tr>
<td></td>
<td>any WebDAV-aware application.</td>
<td></td>
</tr>
</tbody>
</table>

On this page:

- Prerequisites for Editing an Attached Office Presentation
- Editing an Office Presentation in your Office Application
- Troubleshooting

Related pages:

- Office Connector Prerequisites
- Displaying Office Files in Confluence
- Importing a Word Document into Confluence
- Editing an Office Document from Confluence
- Editing an Office Spreadsheet from Confluence
- Editing an Office Presentation from Confluence
- Installing the Firefox Add-On for the Office Connector
Editing an Office Presentation in your Office Application

To edit an Office presentation in your Office application:

1. There are two ways to do this:

   - **From an Office presentation embedded on a page:**
     a. Open a Confluence page with an Office presentation embedded on it.
     b. Click the 'Edit' icon on the bottom frame of the slide show.

   ![Screenshot: PowerPoint presentation displayed on a Confluence page](image)

   - **From an Office document in a list of attachments:**
     - If an Office file is attached to a Confluence page, you can edit this file directly in your compatible Office application, in one of the following ways:
       - View the list of attachments for a specific Confluence page, then click **Edit in Office** next to the Office file on the Attachments page. (See Viewing Attachment Details.)
       - View a list of attachments displayed on a page via the Attachments macro, then click **Edit in Office** next to the Office file in the list of attachments. (See Displaying a List of Attachments.)

   ![Attachments Table](image)
2. A window will pop up, asking you to confirm that you want to open this document.

Screenshot: Confirmation window in Firefox

![Warning window in Firefox](image1)

Screenshot: Confirmation window in Internet Explorer

![Warning window in Internet Explorer](image2)

3. Click 'OK'. Now you may be asked to log in to your Confluence server. Enter your Confluence username and password, then click 'OK'.

4. The presentation will open in your Office application.

5. Make the necessary changes, then save the presentation. It will be saved back into Confluence.

Troubleshooting

Problems? Please refer to our guide to the **Office Connector limitations and known issues**.

**Installing the Firefox Add-On for the Office Connector**

If you are using Firefox as your browser, you will need to install an add-on into Firefox (the **Firefox WebDAV Launcher**) in order to use some features of the Office Connector. You will be prompted to install the add-on the first time you try to use a function which requires it.

For an overview of all Office Connector features, please refer to **Working with the Office Connector**.

**Note about supported web browsers:** Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. Check the **Supported Platforms** page to find the list of supported web browsers and browser versions on this page.
Installing the Firefox Add-On

You will be prompted to install the add-on the first time you try to use a function which requires it. The add-on is required for editing a wiki page in Office, or for editing an Office document which is displayed on a wiki page.

1. When you choose an option which requires the Firefox add-on, you will see a popup window like this one:

   A plugin is required to use this feature. Would you like to download it?

   OK  Cancel

2. Click 'OK'. Some browsers may now ask you to confirm the download with a message bar across the top of the page, beneath the browser's address bar.

   • You may see a message like the one shown here:
Click ‘Allow’.

- Or you may see a similar message with an ‘Edit Options’ button like this:

If you see the above message, click ‘Edit Options’. You will then see an ‘Allowed Sites’ window like this one:

This window lets you tell Firefox that your Confluence server is allowed to install add-ons into Firefox. The ‘Address of web site’ box should already contain the address of your Confluence server.

- Click the ‘Allow’ button to add your Confluence server to the list.
- Go back to your Confluence page and try to edit your Office document again, e.g. by clicking ‘Edit in Word’ again. Now you will see the option to install the add-on.

3. A ‘Software Installation’ window will appear, asking you to confirm the installation. The window will look something like the one below, but the URL will be the address of your own Confluence server:
4. Click 'Install Now'. The installation will happen and a window will pop up asking you to restart Firefox:

5. Make sure you have saved all your Confluence pages and any other work in your browser, then restart Firefox.
6. If Firefox asks you to confirm the restart, confirm it.
7. Firefox will close all the browser windows and will then start up again. You will see a window confirming that a new add-on has been installed, like this:
Configuring the Add-On

After you have installed the add-on into Firefox, you will need to configure it. Basically, you will associate a desktop application (editor) with each relevant file type. This tells the Office Connector which application to launch when it encounters a link to an editable file. The configuration is slightly different for each operating system, as described below.

Configuring the Add-On in Windows

The add-on can will automatically configure itself on Windows via the system registry. The first time you edit a new file type, the add-on will look up the default editor for that file type and make that the permanent setting.

If you want to override the registry settings, or if for some reason the automatic configuration is not working, you can configure the Firefox add-on manually.

1. In Firefox, go to the 'Tools' menu and select 'WebDAV Launcher Options', as shown in this screenshot:
2. A 'WebDAV Launcher Options' window will appear, allowing you to associate a specific file type (file extension) with a desktop application (editor). The window looks like this one:

3. In the 'File Extension' box, enter the extension for a particular file type. For example, you may want to associate the 'doc' file extension with Microsoft Word 2003 or earlier. To do this, you would type 'doc' in the File Extension text box.

If you use or have recently upgraded to Office 2007

In addition to the original Office 2003 file extensions (that is, 'doc', 'ppt' and 'xls'), you should additionally configure the WebDAV launcher to handle the new Office 2007-specific file extensions for Microsoft Word ('docx'), Microsoft Excel ('xlsx') and PowerPoint ('pptx').

Screenshot: Configuring the WebDAV Launcher - adding the 'doc' file extension.
4. Enter the 'Application Path' — Use one of the following methods to specify the associated application for editing the given file type:

- Click the 'Auto' button to load the associated application from the Windows registry.
- Alternatively, you can click the 'Browse' button to find the application on your computer.
- Or you can manually type in the path to the application's executable file.

*Screenshot: Configuring the WebDAV Launcher - adding the 'Application Path' for the 'doc' file extension.*

---

**If you use or have recently upgraded to Office 2007**

Follow the instructions in this step to add the path to the relevant Office 2007 application for the Office 2007 file extension you configured above. For example, if you had a typical
5. Click the 'Add' button. The file extension association will be added to the list. For example, in the picture below you can see that the 'doc' extension has been associated with 'C:\Program Files\Microsoft Office\OFFICE11\WINWORD.EXE'. This is the path to the Microsoft Word 2003 executable on a specific Windows machine.

Screenshot: Configuring the WebDAV Launcher - configuration of the 'doc' file extension complete.

### Configuring the Add-On in Mac OS X

The configuration procedure is similar to Windows, as shown above. Note that there is no 'Auto' button in Mac OS X.

### Configuring the Add-On in Linux

The only known supported Office editor for Linux is OpenOffice. (See Office Connector Prerequisites.)

There is no automatic configuration on Linux. You will need to associate each file type with your Office editor in Firefox. Note that there is no 'Auto' button in Linux.

The configuration procedure is similar to Windows, as shown above.

For both Ubuntu and OpenSUSE, the configuration will look something like this:

<table>
<thead>
<tr>
<th>File Extension</th>
<th>Application Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>doc and docx</td>
<td>/usr/bin/oowriter</td>
</tr>
<tr>
<td>ppt and pptx</td>
<td>/usr/bin/ooimpress</td>
</tr>
<tr>
<td>xls and xlsx</td>
<td>/usr/bin/oocalc</td>
</tr>
</tbody>
</table>

### Security Risks

⚠️ Please be aware that there are security risks in installing this add-on to Firefox. Internet Explorer is exposed to the same risks, because it can directly open Office documents. By installing the add-in into Firefox, you are exposing Firefox to the same risks.
Summary of the risks:

- Office documents can contain macro viruses. Before opening an Office document, make sure that you trust the source of the document.
- There are known flaws in the Office file formats and Microsoft Office that an attacker can exploit to gain control of your machine. Microsoft has fixed the known exploits in the latest Service Packs for all Microsoft Office versions. But new exploitations may arise at any time. Again, be sure that you trust the source of a document before opening it.

The add-on tries to reduce the risk by supporting the following:

- **Same origin policy** — The add-on can only open documents from the same host that initiated the action.
- **Digital signature** — The add-on is digitally signed. When you install the add-on please verify that it is signed by Benryan Software Inc.
- **Prompt the user for confirmation** — You will always be warned before a file is opened. Please read these warnings carefully before opening a file. The warning tells you the complete URL of the file as well as the complete application path of the application opening the file.

Information about this Firefox Add-On

<table>
<thead>
<tr>
<th>Add-on name:</th>
<th>WebDAV Launcher</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description:</td>
<td>Adds the ability to launch a WebDAV URL directly in a WebDAV-aware client.</td>
</tr>
<tr>
<td>Latest version:</td>
<td>See the WebDAV Launcher add-on page at Mozilla</td>
</tr>
<tr>
<td>Compatible with:</td>
<td>All versions of Firefox, up to and including the latest stable version.</td>
</tr>
<tr>
<td>Author:</td>
<td>Atlassian Pty Ltd</td>
</tr>
</tbody>
</table>

**Related Topics**

- Working with the Office Connector

**Importing Content Into Confluence**

This page describes how to get text, pages, images and other content into Confluence, by converting the content from another storage format and importing it into the Confluence wiki.
Importing content from other Confluence sites

For content originating from other Confluence sites, you can:

- Import an entire Confluence site into a new site.
- Import a space from one Confluence site into another. Page history, attachments, and page content will be preserved and you will be able to do multiple pages at once. The drawbacks are that it may be inconvenient if the Confluence versions differ, and you cannot have a duplicate space key on the destination instance.

See Restoring a Site and Restoring a Space for more information.

On this page:
- Importing content from other Confluence sites
- Importing content from other wikis
- Importing content from a Microsoft Word document
- Importing web content
- Importing other non-wiki content
- Note about add-on support

Related pages:
- Working with the Office Connector
- Confluence User's Guide

Importing content from other wikis

Check whether the Universal Wiki Converter can import the content. See Importing Content from Another Wiki.

Importing content from a Microsoft Word document

The Office Connector in Confluence allows you to import a Word document into Confluence. The document's content is copied onto one or more Confluence pages. See Importing a Word Document into Confluence.

Importing web content

Here are some options for importing or displaying web content on a Confluence page:

- Use the Widget Connector Macro to display videos, slide shows, twitter chats, documents and more, sourced from other web sites and displayed on your Confluence page.
- Convert a HTML file to a Confluence page using the HTML To Confluence Converter plugin.
- Embed an external web page into Confluence with the HTML Include macro.
- Use HTML code in a page with the HTML macro.

Importing other non-wiki content

Importing non-wiki markup into Confluence requires a conversion process:

- Text with basic formatting can be pasted directly into the editor. This includes simple Word documents or web pages.
- Files such as Microsoft Excel documents can be imported using a content converter plugin. Not applicable to Confluence OnDemand.
- Confluence pages saved to disk can be imported from disk. Not applicable to Confluence OnDemand.
- Files can be uploaded in bulk using the Confluence WebDav Plugin (Not applicable to Confluence OnDemand.) or WebDAV upload (For Confluence OnDemand.).
- Full featured customisation is available using the Confluence remote APIs.

Note about add-on support

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Importing Content from Another Wiki
The Universal Wiki Converter (UWC) allows you to import content from other wikis into Confluence. The Confluence Administration Console offers a link to the Universal Wiki Converter documentation and download sites.

**Note:** You need to install and run the UWC separately from Confluence. The UWC is a standalone application that communicates with Confluence remotely. You cannot install the UWC directly into Confluence. Instead, download the UWC separately and run it according to the instructions below.

The UWC supports many wiki dialects. In addition, the UWC is an extensible framework, which means that developers can continue writing new conversion modules for other wikis.

- Download the latest version of the UWC from the Atlassian Marketplace.
- For information on installation and usage, see the UWC User Documentation.
- For information on developing your own converter module, see the UWC Developer Documentation.
- For information about a specific wiki, including a list of currently supported wikis, see the UWC documentation - what wikis are currently supported?
- To ask a question, see the UWC discussions on Atlassian Answers.

**Related pages:**
- Importing Content Into Confluence
- Data Import and Export
- Confluence Administrator's Guide

**The information on this page does not apply to Confluence OnDemand.**

### Importing Pages from Disk

Confluence allows you to import text files from a directory on the Confluence server, and convert them into Confluence pages. Each file will be imported as a separate Confluence page with the same name as the file.

**Notes:**
- The text file may contain plain text, HTML or Confluence Storage Format.
- You need to be logged in as a System Administrator to import text files.
- You can import pages from disk into site spaces, but not into personal spaces. Please see Working with Spaces for information about differences between site spaces and personal spaces.

**Related pages:**
- Importing Content Into Confluence
- Confluence User's Guide

**The information on this page does not apply to Confluence OnDemand.**

To import text files:

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Import**.
3. Type the your directory path into the **Import directory** box.
4. Select **Trim file extensions** to remove file extensions from the page titles when converting the files to Confluence pages. Note that the Confluence pages will take their titles from the files' names (including their extensions). To avoid having page titles with a suffix like `.txt` check this box.
5. Select **Overwrite existing pages** if you want to replace existing Confluence pages that have the same page title as one you are importing.
6. Choose **Import**.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.

**Note:** The 'Space Admin' option appears only if you are a space administrator for the space or you are a

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
super user (a member of the confluence-administrators group).
2. Choose **Import** from the space administration options.
3. Follow the steps above.

Confluence will place the new pages at the root of the space.

**Screenshot: Importing text files**

You can use this action to import text files from a directory on the Confluence server. These text files become pages in Confluence, with the following features:

- The page title is taken from the filename
- The content is the entire page body

**Sharing Content**

Confluence provides a number of ways for you to notify other people about content that may be of interest to them:

- You can share a page link with them.
- You can mention a user when you write a page, blog post or comment. Mentioning a user automatically emails a notification to them about that content.
- You can broadcast a message that appears in Confluence activity streams.
- You can like a page, blog post or comment. The author will receive a notification. If enough people like the content, it will appear in the list of popular content on the dashboard and in the recommended updates email message.

Other users can also find out about changes to content in Confluence by watching pages and spaces.

You may also be interested in exporting Confluence content to other formats such as XML, HTML, Microsoft Word and PDF.

**Related pages:**
- Creating Content
- Managing Changes and Notifications and Tasks
- Organising Content
- Confluence User's Guide

**Network Overview**

The ‘network’ feature provides notifications on the activity of users that you choose to follow. This compares with Confluence’s other content tracking features, which provide notifications on specified types of content updates, made by any user.

The types of activities tracked by the network feature include:

- Additions or edits to pages or blog posts
- Comments added to a page or blog post or edits to existing comments
- Updates to a user’s User Status Updates
- Updates to a user’s User Profile
Accessing Your Network View

To see your network view:

- Choose your profile picture at top right of the screen, then choose Network.
  (Alternatively, choose More in the 'Network' section of your profile sidebar.)

You can access another user's Network view using the Hover Profile.

Screenshot: Example of the Network view

Following Another User

You can follow another user by using either the Hover Profile or your Network view.

To follow a user with the Hover Profile:

1. Open the user's hover profile popup:
   - Log in to Confluence, if you have not already done so.
   - Move your mouse pointer over a user's linked name or profile picture. The hover profile popup will appear.
2. Choose Follow.
To follow a user from your Network view:

1. Choose your profile picture at top right of the screen, then choose Network.
   (Alternatively, choose More in the 'Network' section of your profile sidebar.)
2. Enter the first few characters of the name (or username) of the user you wish to follow in the Following field and choose the user from the list of suggestions.
3. Choose Follow.

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just followed will appear within the 'Following' list on the right. Additionally, their tracked activities will start appearing in the 'Recent Activity' list on this page.

Stop Following a User

To stop following a user by using the Hover Profile:

1. Open the user's hover profile popup:
   - Log in to Confluence, if you have not already done so.
   - Note: If a Confluence Administrator has granted the 'View User Profiles' permission to anonymous users, you can access people's hover profile popups without logging in. However, the hover profile features available to anonymous users are restricted.
   - Move your mouse pointer over a user's linked name or profile picture. The hover profile popup will appear.
2. Choose Stop Following.

You can also stop following a user by going to their Profile view.

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just stopped following are removed from the 'Following' list on the right. Additionally, their tracked activities will stop appearing in the 'Recent Activity' list on this page.

Notes

Once you are following a user, you can see their activity in a number of ways:

- Your Network view: your Network view shows all the tracked activities that you have permission to view for all the users that you are following. In the same way, people who follow you will be able to see all your Confluence-based activities on their network views, provided they have permission to view the content. See below for instructions on accessing your network view.
- RSS feeds: you can subscribe to any Confluence user’s network RSS feed and receive summaries on the activities of other users they are following in their network. See Subscribing to a Network RSS Feed.
- Email notifications: you can request email notifications of any activity in your network. See Subscribing to Email Notifications of Updates to Confluence Content.

Note that it is not possible to stop another user from following you. If you are interested in the ability to block followers, please watch CONF-16285 for updates on the feature request.

Likes and Popular Content

Has someone written a good blog post or page on Confluence? Or has someone added a comment that you agree with? Click the Like button to let them know.

Confluence has like buttons on every page, blog post and comment. If enough people like a page or post, it will show on the dashboard’s ‘Popular’ tab. The information in the ‘Recommended Updates’ email message is based on the number of people who have liked the content.

Liking a page, blog post or comment

Click the Like button to let people know that you agree with or enjoy a page, blog post or comment. Click Unlike to remove your name from the list of people who like the content.

You can also see:

- Up to three names of people in your network who have most recently liked the content.
- A link showing the number of people who have liked the comment. For example, 19 people like this. Click the link to see the names. At the top of the list are people in your network, sorted with the most recent likes first. Then follow other people, also sorted chronologically with the most recent first.
Effects of liking content

When you like a page, blog post or comment:

- The author of the content receives a notification.
- People in your network receive a notification. They will receive the notification only if they do not already know about the content. Let's assume Arthur is in your network. Arthur will not receive a notification if:
  - Someone else in his network has already liked the content.
  - Arthur himself has already liked the content.
  - Arthur has already commented on it.
  - In the case of a threaded comment, Arthur has already replied to the comment.
- If enough people like the content, it will appear on the 'Popular' tab of the dashboard.
- Similarly, if the content is popular enough it will appear in the 'Recommended Updates' summary sent out by email.

Disabling the 'like' feature
The functionality is provided by a plugin called the 'Confluence Like Plugin'. To remove the 'like' functionality from your site, you can disable the plugin. See Disabling or Enabling a Plugin.

Disabling notifications when your content is 'liked'

There are two ways to turn the 'someone likes your page' notifications off:

1. Open an email notification of a like, and click Manage Notifications
2. Go to _<your confluence URL>/plugins/likes/view-notifications.action_

User Status Updates

You can use your 'user status' to broadcast a short message, which other users can see on various activity streams in Confluence. These short messages could include:

- A description about what you are working on.
- A question you may want answered quickly.
- A hyperlink that you share immediately with other users.
- Any other message you may want to share quickly with other users.
- Another person's Confluence username, in the format [~username], to send that person an email message about your status.

Your 'Status Updates' view shows a history of updates you have made to your status. Your latest status message is shown on the profile popup that appears when people hover over your username, and in various other places in Confluence.

Setting or updating your status

To set or update your status:

1. Log in to Confluence.
2. Choose your profile picture at top right of the screen, then choose Update Status. The 'What are you working on' dialog will open.
3. Enter a short message (140 characters maximum) that describes your current status or what you are working on.
4. Choose Update to publish your new or updated status.

Screenshot: User status
Mentioning another person in your status update

You can include another person's Confluence username in your status update, using square brackets and the tilde sign in the format \[~username\]. Confluence will send that person an email message containing your status update. For example, let's assume another Confluence user has the username 'charlie'. You could put this message in your status update, and Charlie will receive an email message:

```
Enjoying all the blog posts that ~charlie has written recently!
```

**Note:** Mentions in status updates do **not** appear as notifications in the Confluence workbox.

Viewing status updates

To view your status updates:

- Choose **your profile picture** at top right of the screen, then choose **Status Updates**.

You can also view another user's status by going to their profile.

**Screenshot: Status updates view**

Clearing your current status

Clearing a message is not the same as deleting it. If you clear a message, it is still shown in your status updates view until it is deleted.

To clear your current status:

1. Choose **your profile picture** at top right of the screen, then choose **Status Updates**.
2. Choose **Clear** in the status message at the top of the page.

*Screenshot: Clearing your current status message*

Deleting a status update

**To delete your current or a previous status message:**

1. Choose **your profile picture** at top right of the screen, then choose **Status Updates**.
2. Choose **Delete** next to the appropriate status message. Your status updates view will be refreshed and the message you deleted will be removed from the list.

More about user status updates

There are a number of activity streams in Confluence that show different types of status updates. These include:

- The 'Recently Updated' list on the **Confluence Dashboard**, which shows all status updates (when the All tab is selected).
- Your **Network page**, which shows the status updates of Confluence users you are following.
- The **Network** page of Confluence users who are following you, which shows your status updates.
- The **Recently Updated** and **Recently Updated Dashboard** macros, which shows all status updates (provided that these macros' space parameters have been set to '@all').

Enabling and disabling status updates

The functionality is provided by a plugin called 'User Status'. To remove the status updates functionality from your site, you can disable the plugin. See [Disabling or Enabling a Plugin](#).

You can also set the Confluence site permissions to determine which users can use status updates. By default, users will not have permission to use this feature. See [Global Permissions Overview](#).

**Using Mentions**

When you mention a user on a page, Confluence sends that person a notification by email and in their workbox.

Mentions (often known as @mentions) are great for drawing users attention to a page or comment, assigning tasks and clarifying responsibilities.

There are two ways to mention someone, using autocomplete, or via the Insert menu in the editor.

**Using autocomplete to mention someone**

**To mention someone using '@':**

1. In the editor, type '@' then the first few characters of the person's name or username.
2. Choose the user's name from the list of suggestions.

*Screenshot: Autocomplete for mentions*
Using the Insert menu to mention someone

To add a user mention via the editor toolbar:

1. In the editor choose Insert > User Mention. Confluence will add an '@' sign to the page, and display a dropdown list of suggested users for you to choose from.
2. Start typing the person's name or username, to refine the list of suggestions.
3. Choose the person from the list of names.

Screenshot: The user mention option in the editor toolbar
Seeing your mentions in the Confluence workbox

When someone mentions you, you will receive a notification in the Confluence workbox. See Managing Notifications in Confluence.

Notes

- **Disabling the user mention feature.** The functionality is provided by a plugin called the 'Confluence Mentions Plugin'. To remove the user mention functionality from your site, you can disable the plugin. See Disabling or Enabling a Plugin.
- **Mentioning groups.** It is not possible to mention a group and then have the email sent to the entire group. You can only mention individual users. There is a feature request to allow mentions for groups: CONF-23015 - Extend 'Mentions' to work with groups as well.[OPEN](#)
- **Mentioning people in status updates.** See User Status Updates.
- **Linking to a user profile.** You can use a square bracket `[ ]` and a person's name to trigger Confluence autocomplete and link to a person's user profile or personal space. Confluence will send the person a notification just as if you had used @mention (unless the administrator has disabled the user mention feature).

Emailing a Page

You can share a Confluence page or blog post by emailing a link to recipients of your choice. The recipients can be Confluence users or any email addresses.

To share a link to a Confluence page or blog post by email:

1. Go to the page or blog post you wish to share.
2. Choose Share.
   
   Note: The Share button will only visible if your Confluence administrator has configured an outgoing mail server for your Confluence site.
3. Enter a username, group or email address - autocomplete will suggest matching users and groups.
4. Select the appropriate user, group or email address from the dropdown. Repeat this process to add multiple recipients to the list.
5. Enter an optional message into the Note box.
6. Choose Share to send the link via email.

In addition to an email, Confluence users will also receive a notification in their Confluence workbox. See Managing Notifications in Confluence.
Related pages:
- Managing Notifications in Confluence
- Working with Pages
- Working with Blog Posts
- Configuring a Server for Outgoing Mail
- Confluence User's Guide

Screenshot: Sharing a page

Notes
To remove a recipient from the list, choose the delete icon to the right of the recipient.

Commenting on pages and blog posts
A comment is a remark, question, or any other additional information you wish to add to a page or blog post. People can use comments to interact with each other on your Confluence site.

You can add a comment to any page or blog post, provided that you have the 'Add Comments' permission in the space. You can also show that you agree with or enjoyed someone else's comment, by liking it.

Comments are displayed at the bottom of the page, below the page content. They appear in one of two views, configured globally by a site administrator:
- **Threaded** – This view shows the comments in a hierarchy (tree) of responses. The replies are indented to indicate the relationships between the comments.
- **Flat** – This view displays all the comments in a single list and does not indicate the relationships between comments.
Adding a comment

You can add a comment on pages and blog posts in Confluence. To add a comment, you need the ‘Add Comments’ permission. See Space permissions.

To add a new comment:

1. Type your comment in the comment field at the bottom of the page.
2. Choose Preview to see how your comment will appear.
3. By default, Watch this page is ticked. This means that you will start receiving notifications about this page. Uncheck this if you do not want to watch the page.
4. Choose Save.

You can also highlight any text on a page, and choose the Quote in Comment button that appears near your selection. This will add the highlighted text into the comment field, apply the Quote style, and leave the cursor in the comment field ready to type a comment. If you do not see a popup when you highlight text, check that Text Select is enabled in your profile settings.

To respond to a comment:

1. Choose Reply located below the text of a comment.
2. Type in your response.
3. Choose Save.

To reply to comments, your Confluence site must display comments in threaded view.

Editing a comment

To edit a comment, you need the ‘Add Comments’ permission. See Space permissions. Space administrators can edit all comments within their space. The date on a comment always indicates the time the comment was last edited.

To edit a comment:

1. Go to the comment and choose Edit.
2. Make changes to the comment just as if you were adding a comment.
3. Choose Save.

Deleting a comment

To delete a comment from a page, you need the ‘Remove Comments’ permission. See Space permissions. Deleted comments cannot be restored.

To delete a comment:

1. Go to the page that contains the comment.
2. Choose Delete at the bottom of the comment box.

If you do not have ‘Remove Comments’ permission, you are able to delete your own comments, but only if there are no replies to the comment.
Linking to a comment

You can link directly to a comment on a page. See Working with Links for more information on linking to comments.

Disabling comments

To prevent all users from adding comments in a space, remove the 'Add Comments' permission from the 'confluence-users' or 'users' group, anonymous users and all other users and groups. See Space permissions. The option to add comments will no longer appear on pages or blog posts. You need to be a space administrator to change the space permissions.

There is no permission that controls comments across the entire site.

Notes

- You can choose Tools > Watch to receive an email notification whenever anyone edits the page or adds a comment to the page.
- Your profile picture will appear next to each comment that you have added. (This is true if your space uses the Confluence Default theme.)
- On blog posts only, an ‘Author’ lozenge will appear on any comments made by the original author of the post.
- Comments are not auto-saved. See feature request:  
  ![CONF-12978 - Add auto-save/draft feature for comments](open)
- It is not possible to delete all comments for a page simultaneously.
- Individual users can choose to disable the Text Select popup that is used to enable quote in comment. See Editing User Settings.
- There is no option in the default Confluence user interface, to change the order of comments. For example, it is not possible to show the most recent comments at the top. Here are some options to investigate:
  - Answers and comments on this question on Atlassian Answers.
  - Available themes on Atlassian Marketplace.

Printing Confluence Pages

You can print one or more Confluence pages:

- To print a single page, use your browser’s 'Print' option.
- Confluence allows you to export a single page, single blog post, part of a space, or an entire space into a single PDF file. See Exporting Confluence Pages and Spaces to PDF.

Exporting Confluence Pages and Spaces to Other Formats

You can convert a part of, or the entire contents of a space to various formats, including Microsoft Word, HTML, PDF and XML. This is called 'exporting' the space.

What would you like to do?

- Exporting Confluence Pages and Spaces to HTML
- Exporting Confluence Pages and Spaces to PDF
- Exporting to a Word document
- Exporting Confluence Pages and Spaces to XML

Related topics

- Working with Spaces
- Confluence User's Guide

Exporting Confluence Pages and Spaces to HTML

In Confluence, you can export part of, or the entire contents of, a space into a zipped archive of HTML files. This is useful if you want convert your space into a static website.

To use the space export functionality, you need the 'Export Space' permission. See the guide to space permissions.

To export pages to HTML:
1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Export**. This option will only be visible if you have the 'Export Space' permission.
3. Select **HTML** then choose **Next**.
4. Decide whether you need to customise the export:
   - Select **Normal Export** to produce an HTML file containing all the pages that you have permission to view.
   - Select **Custom Export** if you want to export a subset of pages, or to exclude comments from the export.
5. Select the **Include Comments** check box if you want to include comments for the pages you are exporting.
6. Select the pages you want to export.
   - You have the option to **Select All** or **Deselect All** pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
7. Choose **Export**. This will create a zipped archive of HTML files.
8. When the export process has finished, download the zipped archive as prompted, and extract the files into a folder.

If your space uses the Documentation theme:

1. Choose **Browse > Space Operations**.
2. Choose **HTML Export** from the left menu.
3. Follow the steps above to export the Space.

### Related pages:
- Exporting Confluence Pages and Spaces to PDF
- Exporting Confluence Pages and Spaces to XML
- Confluence User's Guide

**Screenshot: Selecting pages to export**
In the zip file, page attachments are placed in individual folders with names in the following format:

```
...\download\attachments\xxxxxx
```

where 'xxxxxx' is the page ID of the page containing the attachments.

- By default, the 'Space Details' page is exported as `index.html` and displays the space's details as well as a list of all available pages within it.
- Blog posts are not included in the HTML export. See the feature request: CONF-14684.
- To customise the HTML output, you will need to modify the file `confluence-x.y.z-jar/com/atlassian/confluence/pages/Page.htmlexport.vm`. To learn how to repackage this file, see [How to Edit Files in Confluence JAR Files](#).

### Exporting Confluence Pages and Spaces to PDF

This page explains how you can export individual Confluence pages, blog posts, entire spaces or selections of pages into a single PDF file.

#### Exporting single pages

You can export a Confluence page to PDF. This option exports a single page and is available to all users who have permission to view the page.

- Go to a page in the space and choose **Tools > Export to PDF**. Follow the prompts to export the page.

Note that the export of a single page to PDF applies any PDF stylesheet customisations, but does not apply any PDF layout customisations. To make your PDF layout customisations apply to a single page exported to PDF, use the 'multiple page' method described below to export that single page only. See [Customising Exports to PDF](#).

#### Exporting a blog post

You can export a Confluence blog post to PDF. This option exports a single blog post and is available to all users who have permission to view the page.

- Go to a blog post and choose **Tools > Export to PDF**. Follow the prompts to export the page.

Blog posts can only be exported individually. Blogs cannot be exported at the space level.

#### Exporting multiple pages or the entire space

Using Confluence's space export functionality, you can convert multiple pages or an entire space to PDF.

To use the space export functionality, you need the 'Export Space' permission. See the guide to [space permissions](#).

To export a space or selected pages to PDF:

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Export**. This option will only be visible if you have the 'Export Space' permission.
3. Select **PDF** then choose **Next**
4. Decide whether you need to customise the export:
   - Select **Normal Export** to produce a PDF file containing all the pages that you have permission to view.
   - Select **Custom Export** if you want to export a subset of pages.
5. Select the pages you want to export.
   - You have the option to **Select All** or **Deselect All** pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
6. Choose **Export**.
7. When the export process has finished, download and save the PDF file as prompted.

If your space uses the Documentation theme:

1. Choose **Browse > Space Operations**
2. Choose **PDF Export** from the left menu.
3. Follow the steps above to export the Space.
Customising the appearance of PDF exports

You can add a title page, a table of contents and customised headers and footers to the PDF output. For more advanced customisations, you can apply Cascading Style Sheet (CSS) modifications. These customisations are specific to each space. You need the ‘Space Administrator’ permission to be able to apply these customisations. For more information, see Customising Exports to PDF.

Notes

- Comments on the page are not exported to the PDF file.
- Only image attachments that have been inserted into a page are included when exporting to PDF.
- To export a PDF containing international text, you need to install a Unicode font in Confluence.
- Blog posts can be individually exported, but are not included when you export a space to PDF.
- If you have ‘Space Administrator’ permissions, the link to customise the PDF Stylesheet is provided at the top of the page tree, as shown in the screenshot above.
- Confluence’s PDF export feature is designed to handle a wide variety of content. However, on rare occasions the PDF Export process may fail due to an unrecognised customisation. If that happens the PDF export screen will indicate the title of the page in which the problem occurred, to help you diagnose the cause of the failure.

Customising Exports to PDF

Confluence administrators and space administrators can customise the PDF exports for individual spaces.

Please note:

- PDF customisations are unique to each space.
- PDF customisation only applies to space exports (not single page exports via Tools > Export to PDF)
- Confluence’s PDF customisations use a combination of HTML and CSS (Cascading Style Sheets).
- To achieve a particular requirement in the exported PDF file, you make changes in one or both of the following:
  - The PDF Layout, where HTML is used to define the structure of the exported content, including features such as the title page, headers and footers.
  - The PDF Stylesheet, where CSS is used to define the style of elements in the exported content, such as page size and margins, font, colour, and list numbering.

For further customisations, see the Advanced PDF Export Customisations page.

Customising the PDF Layout

You can add your own HTML to customise the title page, page headers and page footers in the PDF output.

Setting a global PDF layout

1. Choose the cog icon, then choose General Configuration under Confluence Administration.
2. Choose PDF Layout. You can enter HTML and CSS that will be rendered on the PDF title page, as well as page headers and footers.
Setting the PDF layout at space level

1. Go to the space and choose **Space tools > Look and Feel** on the sidebar. You'll need **Space Admin permissions** to do this.
2. Choose **PDF Layout**.
3. Choose **Edit**.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   
   *Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).*
2. Choose **PDF Layout** in space administration options.
3. Choose **Edit**.

You can customise the HTML that is generated for the following areas when the space is exported to PDF:

- **PDF Space Export Title Page** – title page.
- **PDF Space Export Header** – page headers.
- **PDF Space Export Footer** – page footers.

Enter your customisations into each text box as required. The PDF layout section accepts HTML code. You can include inline CSS in the HTML too.

---

**On this page:**

- Customising the PDF Layout
  - Setting a global PDF layout
  - Setting the PDF layout at space level
- Customising the PDF Stylesheet
  - Setting a global PDF Stylesheet
  - Setting a space PDF stylesheet
- Example Customisations
  - Page Size
  - Page Orientation: Landscape or Portrait
  - Page Margins
  - Page Breaks
  - Title Page
  - Table of Contents
  - Headers and Footers
  - Page Numbering
  - Wrapping Long Words
  - General Formatting

- Notes
- Related Topics

**Related pages:**

- Advanced PDF Export Customisations

---

**Customising the PDF Stylesheet**

You can adjust the appearance of the PDF pages by customising the CSS in the PDF Stylesheet screen.

To get started, download the default CSS rules for the PDF stylesheet - `confluencedefaultpdf.css`.

Any rule defined in this file can be customised and added to the PDF Export Stylesheet section. Your customisations override any default CSS rule. If no customisations are defined, the default CSS rules will be applied.

By default, the export does not include a title page, headers or footers. You can define these in the PDF layout.

**To customise the PDF Stylesheet:**

**Setting a global PDF Stylesheet**

1. Choose the cog icon, then choose **General Configuration** under Confluence Administration.
2. Choose **Look and Feel > PDF Stylesheet**. The following screen allows you to enter and save CSS code that will render content on each page.

**Setting a space PDF stylesheet**

1. Go to the space and choose **Space tools > Look and Feel** on the sidebar. You'll need **Space Admin permissions** to do this.
2. Choose **PDF Stylesheet**.
3. Choose **Edit**.
4. Enter your customisations.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.  
   *Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the **confluence-administrators** group).*
2. Choose **PDF Stylesheet** in the space administration options.
3. Choose **Edit**.
4. Enter your customisations.

The PDF Export Stylesheet field accepts Cascading Style Sheets (CSS) rules. The ‘PDF Export Stylesheet’ page shows the current (e.g. customised) contents of your PDF stylesheet.

**Example Customisations**

This section provides examples of typical customisations that you can add. See also **Advanced PDF Customisations**.

**Page Size**

The default page size is based on the location of your Confluence server. For example, if this server is located in the US then the default paper size of your PDF export will be US Letter (8.5 inches wide by 11 inches long). If the server is located in Australia, the default paper size will be A4 (210 mm wide by 297 mm long). More information about paper sizes can be found on [Wikipedia](https://en.wikipedia.org/wiki/Paper_size).

To modify the page size to A4, edit the PDF Stylesheet to add a *size* property to the **CSS@page** rule, like this:

```css
@page
{
/*The A4 paper size is 210 mm wide by 297 mm long*/
size: 210mm 297mm;
}
```

**Page Orientation: Landscape or Portrait**

To change the page orientation of your PDF document, simply reverse the order of the values declared in the **@p age** rule’s **size** property. The first and second values of this property represent the width and height of the page, respectively.

For example, to generate PDF space exports in A4-sized landscape orientation, your **@page** rule might look like this:
CSS - PDF Stylesheet

@page
{
/*A4-sized pages in landscape orientation are 297 mm wide by 210 mm long*/
size: 297mm 210mm;
}

Page Margins

To set all margins to 15 mm, with a paper size of A4, edit the CSS `@page` rule in the PDF Stylesheet, like this:

CSS - PDF Stylesheet

@page
{
size: 210mm 297mm;
margin: 15mm;
}

To set the margins independently, edit the `@page` rule as follows:

CSS - PDF Stylesheet

@page
{
margin-top: 2.54cm;
margin-bottom: 2.54cm;
margin-left: 1.27cm;
margin-right: 1.27cm;
}

To set margins to provide a gutter for binding a printed document, use the `:left` and `:right` pseudo-classes, as follows:

CSS - PDF Stylesheet

@page:left
{
margin-left: 4cm;
margin-right: 3cm;
}
@page:right
{
margin-left: 3cm;
margin-right: 4cm;
}
@page:first
{
margin-top: 10cm /* Top margin on first page 10cm */
}

Note the use of the `:first` pseudo-class in the example above to define distinct margins for a cover or title page.
Page Breaks

By default, Confluence pages are exported without page breaks, so that shorter pages will appear on the same PDF page.

To make each Confluence page appear on a separate page in the PDF file, add the following rule in the PDF Stylesheet:

```
.pagetitle
{
  page-break-before: always;
}
```

Title Page

You can add a title page to your PDF document by adding HTML to the Title Page section of the PDF Layout screen. The following example creates the title page and adds a title:

```
<div class="fsTitlePage">
  <img src="/download/attachments/590719/titlepage.png" />
  <div class="fsTitle">Planning for Confluence 4.0</div>
</div>
```

Use CSS rules in the PDF Stylesheet to control the appearance of the title page and the title text:

```
.fsTitlePage
{
  margin-left: auto;
  margin-top: 50mm;
  margin-right: auto;
  page-break-after:always
}

.fsTitle
{
  font-size: 42px;
  font-weight: bold;
  margin: 72px 0 4px 0;
  text-align:center;
}
```

Adding an Image to the Title Page

In the example above, the title page includes an image called 'titlepage.png', centred in the middle of the page. The "590719" in the src attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your title page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page, then right-click the image and copy its location.
3. Paste the link into the appropriate src="" attribute in your PDF Stylesheet, as shown above.
4. Edit the image URL so that it is relative, by removing the first part of the URL before /download/...
Table of Contents

By default, a table of contents will be generated after the title page, or at the beginning of the PDF document if no title page is defined in the PDF Layout. To see the default CSS rules applied to the table of contents, download the default CSS rules (confluencedefaultpdf.css) and examine the specific rules with toc in their name.

To make changes to the appearance of the table of contents, define CSS rules in the PDF Stylesheet.

Disabling the Table of Contents

To prevent the table of contents from being generated in your PDF document, add the div.toc rule to the PDF Stylesheet and set its display property to none:

CSS - PDF Stylesheet

```css
div.toc
{
  display: none;
}
```

Changing the Leader Character in the Table of Contents

The leader character is used to link a heading in the table of contents with its page number. By default, the leader character is the '.' (dot) character. Leader values of dotted, solid and space are allowed. You can also use a string, for example leader(". . . ").

To change the leader character to a solid line, modify the leader() value on the content property of the CSS rule as follows:

CSS - PDF Stylesheet

```css
span.toclead:before
{
  content: leader(solid);
}
```

Headers and Footers

You can add headers and footers to your PDF pages using the 'Header' and 'Footer' sections of the PDF Layout screen. By default, headers and footers only apply to a space export and not to exports of single pages (however, see Advanced PDF Export Customisations). The following example adds a simple copyright notice.

HTML - PDF Layout: Footer Section

```html
Copyright © 2013, Atlassian Pty Ltd.
```

Page Numbering

To add page numbering, you need to combine customised HTML in the PDF Layout with customised CSS in the PDF Stylesheet.

1. PDF Layout HTML: In the Footer section (or the Header section), use an empty span element with a unique ID, for example pageNum, to act as a place holder for the page number.
2. PDF Stylesheet CSS: Create the following CSS selector rule for the empty span:

```
#pageNum:before {
  content: counter(page);
}
```

Analysing the above CSS selector rule in more detail:

- The #pageNum rule selects the HTML element with the specified ID of "pageNum", which is the span element we created for the header or footer.
- The :before part of the selector is a pseudo class that allows the insertion of content before the span element is processed.
- The counter(page) is a function that returns the current page number as its content.
- The content property tells the CSS processor that dynamic content (that is, an incrementing page number) is to be inserted at the span tag.

Wrapping Long Words

In order to break long words or words that are not separated by whitespace, add a selector to the PDF stylesheet containing the word-wrap property with a value of break-word:

```
div {
  word-wrap: break-word;
}
```

General Formatting

You can use the stylesheet to customise the output of just about anything else that will influence the look and feel of the final document. This includes fonts, tables, line spacing, macros, etc. The export engine works directly from the HTML output produced by Confluence. Therefore, the first step in customising something is to find a selector for the HTML element produced by Confluence or the Confluence macro. Then add a CSS rule to the PDF stylesheet. Your customisation will appear in the PDF export.

Notes

- **Demotion of heading elements: h1, h2, and so on.** Due to the hierarchical manner in which a space is exported, Confluence will modify the heading elements to generate a uniform appearance for the entire space export. This means that headings will be demoted. This will affect the application of custom PDF Stylesheets. It is possible to calculate the amount by which a heading will be demoted in order to have the correct CSS styling applied. A heading will be demoted by the value of its depth in the export tree. A page at the first level will be demoted by 1 (all <h1> elements will become <h2> elements, and so on). A page at the second level will be demoted by 2, and so on.

- **Atlassian support for PDF customisation is limited.** We support the mechanism for customising the PDF layout with HTML and CSS, and we will help if the mechanism is broken or does not work as we say it should in our published examples. But, since custom HTML and CSS offer potentially limitless
possibilities, Atlassian will not support issues that are caused by or related to PDF customisations.

Related Topics

Advanced PDF Export Customisations
Advanced PDF Export Customisations

This page provides information about 'advanced' PDF export customisations. These expand upon the regular customisations described in Confluence 5.5 Documentation.

⚠️ The information below is for advanced users. Customisations are not supported by Atlassian. Be aware that the advanced customisations described below require knowledge of certain parts of Confluence, and of CSS and HTML. This documentation is intended for advanced users. Some of the suggestions below are moderately complex, or irregular in nature. If you are having trouble understanding them we strongly suggest you ask an expert. We do not support any of the customisations described below. This means that the Atlassian support engineers will not be able to help you with these modifications.

On this page:
- Header and Footer
  - Adding Headers and Footers to Single Page Exports
  - Adding Images to Headers and Footers
- Incorporating Other Fonts
- Adding a Dynamic Title to the Title Page
- Hiding Text from the PDF Output
- Indexing
- Notes

Related pages:
- Customising Exports to PDF
- Confluence User’s Guide

Header and Footer

Adding Headers and Footers to Single Page Exports

By default, custom headers and footers set up in the PDF Layout screen (see Confluence 5.5 Documentation), only apply to space exports and not to exports of single pages. However, it is possible to add CSS rules to your PDF Stylesheet that produce headers and footers in single page exports as well as space exports.

For custom headers, define @top-left, @top-center and @top-right rules within your @page rule. These rules apply respectively to content that appears on the left-hand side, centre and right-hand side of your page's header area.

For custom footers, define @bottom-left, @bottom-center and @bottom-right rules within your @page rule.

For example, the following rules add a document title at the centre of the header and a page number at the centre of the footer:
CSS - PDF Stylesheet
@page
{
    @top-center
    {
        content: "Document Title Goes Here";
        font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
        font-size: 8pt;
    }
    @bottom-center
    {
        content: "Page " counter(page);
        font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
        font-size: 8pt;
    }
    /* Any other page-specific rules */
}

Notes:

- The font-family and font-size properties ensure that the header and footer text is rendered in the same default font style used for the body text, based on the default CSS rules.
- It is not possible to use this method to insert images (stored as attachments within your Confluence instance) into the headers and footers of single page exports.

Adding Images to Headers and Footers

To insert an image into the header or footer, add HTML to the Header or Footer section of the PDF Layout screen.

The following example uses an HTML img element with src attribute to add an image to the left of the header. The src attribute refers to an image attached to a Confluence page. The image element is usually placed within a div element container.

HTML - PDF Layout: Header Section

```html
<div style="margin-top:10mm">
    <img src="/download/attachments/12346/header-image.png"/>
</div>
```

In the example above, the header includes an image called 'header-image.png'. The "12346" in the src attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page, then right-click the image and copy its location.
3. Paste the link into the appropriate src="" attribute in your PDF Stylesheet, as shown above.
4. Edit the image URL so that it is relative, by removing the first part of the URL before /download/....

Notes:

- This example uses an inline CSS property margin-top in the style attribute to force the image away from the top of the page by 10mm. This comes in handy when your header image is large enough to touch or spill over the top of the page.
- Likewise, for footers, you can use the margin-bottom:XXmm property to force an image away from the bottom of the page by 'XX' mm.
- Very large images can spill over into the body of a page or alter the position of text or other elements used within a header or footer. In such situations, it is recommended that you reduce the size of the
image and then attach it to your Confluence page again. If you prefer to keep the image size and want to move the content lower instead, you can do so by configuring the `margin-top` properties in the `@page` CSS rule.

- By default, a header or footer image is aligned to the left-hand side of the page. However, you can align this image to the centre or right-hand side of a page by adding either the `text-align: center` or `text-align: right` properties to your style attribute. For example, to align the header image to the right-hand side of the page, your style attribute would look similar to this: `style="margin-top:10mm; text-align:right"`.

### Incorporating Other Fonts

By default, Confluence provides Times New Roman, Helvetica or Courier fonts for use in PDF exports. You can use your own fonts for PDF exports by declaring them in a `@font-face` CSS rule in your PDF Stylesheet.

The following CSS rule example shows how to declare the Consolas font and apply it to some elements for your PDF export:

```css
@font-face
{
  src: url(file:///usr/share/fonts/Consolas.ttf);  
  -fs-pdf-font-embed: embed;
}

.code pre, .preformatted pre, tt, kbd, code, samp
{
  font-family: Consolas, monospace;
  font-size: 9pt;
}
```

The font path specified in the CSS must be the path to the font on the Confluence server.

### Adding a Dynamic Title to the Title Page

When you export an arbitrary set of pages from Confluence, you may like to have a corresponding title added to the cover (or title) page automatically. This can be done (in a somewhat irregular way) by using the top level item from the default table of contents as the title. This method relies on having the exported pages structured as sub-pages of the top-level page. In other words, the pages to be exported should consist of a page (at the top-level) and all of its child pages. The result is that the title that appears on the cover page changes depending on the top-level page that is used for the export.

The CSS below moves, and styles, the top-level TOC item for use as the title on the cover page, and turns off the leader and page number normally associated with this item in the TOC.
Hiding Text from the PDF Output

This section describes a way to hide text from your PDF export. In other words, you can have text on the Confluence page that will not appear in the PDF export.

There are three steps:

1. Follow the instructions to define the NoPrint user macro. Not applicable to Confluence OnDemand.
2. Use the NoPrint macro to mark some text on a Confluence page.
3. Add the following CSS to your PDF stylesheet to make the PDF export recognise the NoPrint macro:

```
CSS - PDF Stylesheet

.noprint
{
  display: none;
}
```

Indexing

To obtain an index at the end of the exported PDF file, consider using the Scroll Wiki PDF Exporter plugin that is produced by K15t Software GmbH.

Notes
If styling is not working as expected, it is useful to look at the intermediary HTML source to which the CSS is applied. This intermediary HTML is created whenever you create an HTML export that contains multiple pages, and is stored in the `temp` directory in Confluence's home directory. For example:

```
<cconfluence-home>/temp/htmlexport-20110308-154047-1/export-intermediate-154047-2.html
```

Creating PDF in Another Language

To export a Confluence page written in a language other than English, you need to install the necessary font for that language. This means that you need to upload the font file to Confluence, as described below.

**Note:** If you are using Confluence OnDemand, please raise a support ticket at http://support.atlassian.com, asking Atlassian to perform this function for you. Confluence OnDemand users do not have access to this functionality. The Atlassian Support team will need to access this URL:

https://<account_name>.atlassian.net/wiki/admin/flyingpdf/configurepdflanguagesupport.action

**Related pages:**
- Exporting Confluence Pages and Spaces to PDF
- Confluence Administrator's Guide

Uploading a Font File to Confluence

1. Find the appropriate font file:
   - **Windows users:** All font files in Windows are stored in a directory called:
     ```
     C:\WINDOWS\Fonts
     ```
   - **Unix users:** All font files in Unix are stored in:
     ```
     /usr/share/fonts
     ```
   - Microsoft True Type core fonts such as Verdana can be downloaded from this page: http://corefonts.sourceforge.net/

2. Copy the font file into a temporary folder, for example a folder on your desktop.

3. Choose the cog icon , then choose General Configuration under Confluence Administration, then choose PDF Export Language Support.
4. Upload the file you copied in step 2.
5. Choose Install.

**Notes**

- The only font files supported are *true type fonts* and *true type collections*. The accepted file extensions are *.ttf* and *.ttc*.
- Confluence can only store one font file at any one time. Please create a collection to install more than one *.ttf* files.
- We recommend that you use Unicode font Verdana for correct character encoding and exporting to PDF.
- If the font file size is bigger than your current attachment size limit, you will not be able to upload it. Please increase the attachment size limit temporarily and re-upload again. An improvement of the error messaging is tracked at
• To make use of an installed font in your PDF Export style sheet (CSS) refer to it by the font-family ConfluenceInstalledFont.

Exporting to a Word document

Confluence allows you to export a single page into a Word document. By default, this will create a Word document with the same name as the Confluence page. This is useful for emailing content to people who do not have access to Confluence.

Anyone who has permission to view the page will be able to export it to Word.

To export a page to a Word document:
Go to the page and choose Tools > Export to Word.

Useful plugins

*Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.*

This plugin provides extended functionality for exporting Confluence pages to Microsoft Word: Scroll Office.

Exporting Confluence Pages and Spaces to XML

You can export part of, or the entire contents of, a Confluence space into a zipped archive of XML files and attachments. This is useful if you want to make a backup of the space, or import the space into another Confluence site, or use the data from the space in another application.

To export a space or pages to XML, you need the ‘Export Space’ permission. See Space Permissions.

Notes:

• See Restoring a Space for notes on restrictions when importing a space.
• If you are doing the export for backup purposes, consider another means of backup. See Production Backup Strategy

To export pages or an entire space to XML:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Export
   Note: This option will only be visible if you have the ‘Export Space’ permission.
3. Select XML then choose Next.
4. Decide whether you need to customise the export:
   • Select Full Export to produce an XML file containing all the pages in the space, including those that you do not have permission to view.
   • Select Custom Export if you want to export a subset of pages, or to exclude comments from the export.
5. Select Include Comments if you want to include comments made on the pages you are exporting.
6. Select the pages you want to export.
   • You have the option to Select All or Deselect All pages.
   • When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
7. Choose Export. This will create a zipped archive of XML files and attachments.
8. When the export process has finished, download and save the zipped archive file as prompted.

If your space uses the Documentation theme:

2. Choose XML Export from the left-hand panel.
3. Follow the steps above to export the space.
On this page:
Related pages:
- Exporting Confluence Pages and Spaces to PDF
- Exporting Confluence Pages and Spaces to HTML
- Working with Spaces
- Confluence User’s Guide
- Restoring a Space

Screenshot: Exporting a space

Export XML Options

Export content within this space as XML.

- Full Export (includes pages not visible to you)
  Generates a XML file of all pages and blog posts (including ones not visible to you) in this space, including comments and attachments.

- Custom Export
  Generates a XML file of selected pages based on options that you choose from below.

Includes:
- Include comments

Choose pages to export:
Select All  ·  Deselect All

- Crowd 101
- Crowd Administration Guide
- Getting Started

Select All  ·  Deselect All

Export

Notes

If you are running Confluence behind Apache HTTP Server and are facing timeout errors, please consider creating the export directly from Tomcat, instead of going through Apache. This will speed up the process and prevent timeouts.

Managing Changes and Notifications and Tasks

Confluence provides several ways in which you can watch for changes to single pages, entire spaces, and all spaces on the site. You can also follow the updates made by specific people. You can only track updates to content that you have permission to see.

Making yourself a watcher of pages or spaces

You can watch a page, blog post or space that you have permission to view. Confluence will then send you an email notification whenever someone adds or updates content on, or adds a comment to, that page or space. See Watching Pages, Spaces and Blogs.

If you have space administrator permissions, you can manage watchers of pages and spaces.

Requesting other notifications
You can configure Confluence to send you various digest reports via email. See Subscribing to Email Notifications of Updates to Confluence Content.

On this page:
- Making yourself a watcher of pages or spaces
- Requesting other notifications
- Tracking updates by specific people
- Managing your notifications
- Using Confluence RSS feeds

Related pages:
- Page History and Page Comparison Views
- Viewing Space Activity
- Working with Tasks

Tracking updates by specific people

You can also follow the activity of people who interest you (see Network Overview) and receive a notification when someone follows you (see Subscribing to Email Notifications of Updates to Confluence Content).

Managing your notifications

There are two ways to manage notifications in Confluence:

- You can manage your email notification settings via the options in your user profile. See Subscribing to Email Notifications of Updates to Confluence Content.
- The Confluence workbox displays all notifications collected from Confluence page watches, shares and mentions. See Managing Notifications in Confluence.

Using Confluence RSS feeds

You can build RSS feeds to monitor content changes in Confluence.

- Create a customised RSS feed using the RSS Feed Builder.
- Subscribe to one of the pre-specified feeds generated by Confluence.

Watching Pages, Spaces and Blogs

You can ‘watch’ a Confluence page, blog post or space. Confluence will then send you a notification by email whenever anyone updates the watched content.

You will receive email notifications for:

- Edits (unless the author clears the ‘Notify watchers’ check box).
- Deletions.
- Attachments, including new versions or deletions of an existing attachment.
- Comments, including new comments, edits of existing comments or deletions of existing comments.

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called ‘autowatch’. You can control autowatch.

There is no daily digest for email notifications. You will receive an email notification every time someone makes a change.

You will not receive email notifications for content changes due to the output of a macro, because the page content itself has not been edited.

You need ‘View’ permission for the page, blog post or space to receive notifications.
On this page:

- Watching a page or blog post
- Watching an entire space
- Watching for new blog posts in a space
- Watching all spaces on the site
- Watching for all new blog posts on the site
- Managing watches from your user profile
- Managing watches from the email message
- Setting autowatch and other notification options

Related pages:

- Managing Watchers
- Subscribing to Email Notifications of Updates to Confluence Content
- Managing Changes and Notifications and Tasks
- Updating Email Address
- Confluence User's Guide

Watching a page or blog post

To start watching a page or blog post:

1. Log in to Confluence, if you have not already done so.
2. Go to the page or blog post.
3. Choose Watch and select the relevant check box.

To stop watching the page or post, deselect the relevant check box.

Watching an entire space

You can choose to watch all the pages and blog posts in a particular space.

The quickest way is to use the Watch option on a page or blog post, as described above.

To stop watching the space, deselect the relevant check box.

Alternatively, choose Pages in the space sidebar, then choose Watch this space at the top right.

If your space uses the Documentation theme, choose Browse > Space Operations. Then choose Watch this space in the left-hand menu.

Watching for new blog posts in a space

You can choose to receive a notification whenever someone adds a blog post in the space. You will not receive notification of updates to or deletions of blog posts, nor of comments on the blog posts.

To watch for new posts:

1. Log in to Confluence, if you have not already done so.
2. Go to a blog post in the space.
3. Choose Watch and select Watch all blog posts in this space.

To stop watching for new blog posts, deselect the relevant check box.

Alternatively, choose Blog in the space sidebar, then choose Watch this blog at the top right.

If your space uses the Documentation theme, choose Browse > Space Operations. Then choose Watch this blog in the left-hand menu.

Watching all spaces on the site

You can receive notifications about changes to the content of pages, blog posts and comments from all spaces on a Confluence site.

To start watching for content changes across the whole site:
1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Email.
3. Choose Edit then choose Subscribe to daily updates.
4. Choose Submit.

Watching for all new blog posts on the site

You can choose to watch for all new blog posts in all spaces on the Confluence site. You will not receive notification of updates to or deletions of blog posts, nor of comments on the blog posts.

To start watching for all new blog posts:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Email.
3. Choose Edit then choose Subscribe to all blog posts.
4. Choose Submit.

Managing watches from your user profile

The 'Watches' page in your user profile displays a list of all pages and spaces you are currently watching.

To manage your watches:

1. Choose your profile picture at top right of the screen, then choose Watches.
2. Choose Stop Watching for any unwanted spaces or pages.

Managing watches from the email message

The email notifications that you receive from Confluence have some useful links at the bottom of the email message. The links in each message vary, depending on the context. In general, the links allow you to view the page online, reply to a comment, and so on.

In particular with respect to setting your notification preferences, you will see one or more of the following links:

- Stop watching page – Click this link to stop watching the page that triggered the email notification.
- Stop watching space – Click this link to stop watching the space that triggered the email notification.
- Stop following this user – Click this link to stop following the user whose update triggered the email notification.
- Manage Notifications – Click this link to go to the email settings page in your user profile.

Screenshot: Example email notification footer showing links

Setting autowatch and other notification options

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called ‘autowatch’. You can turn autowatch on or off, and set other notification options, in the email settings section of your user profile. See Setting User Settings.

Managing Watchers

If you are a space administrator for a space, you can manage the watchers for all pages and blog posts in that space. This means that you can:

- View a list of the watchers of a page or blog post.
- View a list of the watchers of the space that contains the page or blog post.
- Add users as watchers of the page or blog post.
- Remove existing watchers of the page or blog post.

You cannot remove watchers of the space.
To manage the watchers of a page or blog post:

1. Go to the page or blog post for which you want to manage the watchers.
2. Choose Watch > Manage Watchers.
3. The ‘Manage Watchers’ screen will appear. The left-hand column shows the users watching the page or blog post. The right-hand column shows the users watching the space.
   - To remove an existing page watcher, choose the icon (trash can) next to the user’s name.
   - To add a user as a watcher of the page, type their username and choose Add.

Screenshot: Managing watchers

### Related pages:
- Watching Pages, Spaces and Blogs
- Subscribing to Email Notifications of Updates to Confluence Content
- Managing Changes and Notifications and Tasks
- User Profile Overview
- Confluence User’s Guide

### Subscribing to Email Notifications of Updates to Confluence Content

You can ‘watch’ a page, blog post or space. Confluence will then send you a notification by email whenever anyone adds or updates content on that page or space. You can also subscribe to daily email reports and other notifications of various updates, as described below.

You will only receive notifications for content that you have permission to view. Users that have been disabled by an administrator will not receive email notifications.

#### Subscribing to email notifications

You can subscribe to the following email summary reports:

- A daily report of updates to all spaces that you have permission to view.
- An immediate report of all blog posts added or changed, in all spaces that you have permission to view.
- An immediate report of all updates made by the people you are following, in all spaces that you have permission to view.
- An immediate report when someone follows you.
- A daily or weekly report of recommended updates, in all spaces that you have permission to view.

#### To edit your email notification settings:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Click Email in the left-hand panel.
3. Click Edit.
Below is an explanation of all the email settings is explained below.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Content</th>
<th>Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autowatch</td>
<td><strong>Option:</strong> Do you want Confluence to automatically add you as a watcher on each page or blog post that you add or update? If you are a watcher of a page or a post, you will receive notification of future changes.</td>
<td>• Pages and blog posts that you create, edit or comment on.</td>
<td>(Not applicable)</td>
</tr>
<tr>
<td>Subscribe to daily updates</td>
<td>Receive email reports showing changes to content in all spaces that you have permission to view.</td>
<td>• Pages and blog posts that are added, edited or deleted. • Comments on a page or blog post that are added, edited or deleted. • Updates by users who have changed their personal profile.</td>
<td>Daily</td>
</tr>
<tr>
<td>Subscribe to all blog posts</td>
<td>Receive email notifications for changes to blogs in your Confluence installation that you have permission to view.</td>
<td>• Blog posts added, edited or deleted.</td>
<td>Immediately</td>
</tr>
</tbody>
</table>
| Subscribe to network | Receive email notifications for changes to content by all users that you are following, which you have permission to view. | • Pages being added, edited or deleted.  
• Blog posts being added, edited or deleted.  
• Comments being added, edited or deleted.  
• Status updates by the user. | Immediately |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Subscribe to new follower notifications</td>
<td>Receive an email message when anyone chooses to follow you.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
| Notify on my actions | **Option:** Do you want to receive email notifications for your own changes?  
Note: If you have not subscribed to any email notifications and are not watching any pages/spaces, then selecting 'Notify on my actions' will not do anything. | • All pages and spaces that you are watching.  
• This affects all subscriptions set. | (Not applicable) |
| Show changed content | **Option:** Do you want your notifications to include details of the changes made to the content?  
• If you do not select this option, your notifications will include only the title of the page, and any comment the author made when updating the page.  
• If you do select this option, your notifications will show the differences between the current and previous versions of the page. See Page History and Page Comparison Views. | • Edits to pages and blog posts. | (Not applicable) |
<table>
<thead>
<tr>
<th>Subscribe to recommended updates</th>
<th>Confluence chooses the content to display, based on:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Receive an email message showing the top content that is relevant to you from spaces that you have permission to view. How do you set the frequency of the mail message? A link in the email message allows you to choose daily or weekly notifications. How do you enable and disable the notification? You can turn off the notification by clicking a link in the email message. You can also turn the notification on or off by setting the ‘Subscribe to recommended updates’ option in your user profile.</td>
<td>• Pages and blog posts that people have recently liked. • Pages and blog posts that people have recently commented on. • Pages and blog posts that have recently been created.</td>
</tr>
<tr>
<td>Daily (weekdays at 1pm) or weekly</td>
<td></td>
</tr>
</tbody>
</table>

Recent' means any activity that occurred since the last recommended updates message was sent to you.

The activities are listed in order of popularity, with the most popular at the top. Likes, comments and content creations are scored equally. Activity that involves people in your network ranks higher than activity not involving your network. Content in your favourite spaces also ranks higher than content in other spaces. The recommended updates summary does not include any content that you created yourself, and it gives a lower ranking to content that you have participated in, for example by adding a comment or updating the page.

If there is no activity to report, Confluence will not send the email message.

**Notes for administrators**

- To enable Confluence to send email notifications, a System Administrator must configure an email server. See Configuring a Server for Outgoing Mail.
- Confluence Administrators can set the default options for the recommended updates notification. Choose the cog icon, then choose General Configuration under Confluence Administration. Click Recommended Updates Email in the left-hand panel. See Configuring the Recommended Updates Email Notification.
Subscribing to RSS Feeds within Confluence

An RSS feed is a format for delivering summaries of regularly changing web content. Subscribing to an RSS feed allows you to stay informed of the latest content from sites that you are interested in.

RSS is not designed to be read in a regular web browser. Specialised RSS newsreader programs can check RSS files every so often, and tell you what's new on a site. Your reader may be on a website, an add-on to your browser, part of your email program, or a stand-alone program.

Confluence generates its own RSS feeds for tracking updates to content within Confluence. You will need an RSS reader which can grab the RSS feeds from Confluence and display them for you.

Confluence's RSS macro allows you to display the contents of an RSS feed on a Confluence page. The feeds may come from a Confluence feed generator or from external sites. In this way, Confluence can act as an RSS reader.

For a technical description of RSS, read Mark Pilgrim's "What is RSS?" article on XML.com.

Confluence RSS feeds

RSS feeds allow you to track updates to content within Confluence. You will need an RSS newsreader to read a feed.

You can create a customised RSS feed using the RSS Feed Builder or subscribe to one of the pre-specified feeds generated by Confluence.

What would you like to do?

- Create and subscribe to customised RSS feeds using the RSS Feed Builder – Create a customised RSS feed. For example, you can filter your feed using a label, specify the number of items and days to include in your feed, and so on.
- Subscribe to pre-specified RSS feeds – Generate an RSS feed automatically in a minimal number of steps.
- Subscribe to a feed of any Confluence user's network – Track the activities of users the selected person is following.

RSS newsreaders

The following are some popular RSS readers for various operating systems. You can find a more comprehensive list on Google's open directory.

Windows
- SharpReader
- NewsGator
- Syndirella
- FeedDemon
- NewzCrawler

Mac OS X
- Safari
- NetNewsWire
- NewsFire
- Shrook
Multi-platform

- **NewsMonster** (Runs in the Mozilla web browser)
- **Radio Userland** (Windows and MacOS)
- **AmphetaDesk** (Windows, Unix, Mac OS X)

Removing an RSS feed

There is no need to try to delete or remove an RSS feed built by the Confluence **RSS feed builder**.

Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL (address). For example, take a look at the following feed URL:

```
http://confluence.atlassian.com/createrssfeed.action?types=page&sort=modified&showContent=true...
```

The above feed URL will generate a list of pages ('types=page'), sorted by the modification date and showing the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no need to remove anything.

Using pre-specified RSS feeds

This page tells you how to get hold of an RSS feed which Confluence has predefined for you.

To subscribe to predefined RSS feeds for a particular space:

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **RSS Feeds**.
3. Copy and paste the link for one of the feeds into your RSS newsreader:

If your space uses the Documentation theme:

1. Choose **Browse > Space Operations**
2. Choose **RSS Feeds** in the space operations options.
3. Copy and paste the link for one of the feeds into your RSS newsreader.

Feeds include:

- Pages
- Blog
- Mail
- Comments
- Attachments
- All content

To subscribe to predefined RSS feeds for a particular page (where available):

Note that the word 'page' here means a part of the Confluence user interface, rather than a page that contains Confluence content. For example, your **Network** view offers an RSS feed.

1. Go to the page.
2. Locate the following icon, which is available in the top-right corner of certain pages:
3. Copy and paste the icon's link into your RSS newsreader.

**Related pages:**

- Using the RSS Feed Builder
- Managing Changes and Notifications and Tasks
- RSS Feed Macro
- Confluence User's Guide

**Notes**

If you want to customise your Confluence RSS feed (for example, use a label to filter your feed), use the **RSS Feed builder** instead of the above instructions.
Using the RSS Feed Builder

Using the RSS feed builder, you can create customised RSS feeds to subscribe to changes within Confluence. Wondering what an RSS feed is? See more information about RSS Feeds.

Building an RSS feed

Follow the steps below to build your feed, choosing the type of content and the time period you want to monitor.

To create a customised RSS feed:

1. Choose the help icon at top right of the screen, then choose Feed Builder.
2. Select the content types you want in your feed.
   Check Mail if you want to know when the email archive is updated. (See the overview of mail archives in Confluence.)
3. Select one or more spaces from the list.
4. Click Advanced Options to set the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feed Name</td>
<td>The default name is based on the name of your Confluence installation. For example, 'Extranet RSS Feed'.</td>
</tr>
<tr>
<td>With these labels</td>
<td>Enter one or more labels separated by spaces or commas. Confluence returns all content (of the selected types) that matches one or more of the labels. See the hint below about using labels to customise your feeds.</td>
</tr>
<tr>
<td>Exclude these spaces</td>
<td>Exclude specific spaces from those already selected.</td>
</tr>
<tr>
<td>Sorted by</td>
<td>Sort content by either the date or creation or the date they were last updated.</td>
</tr>
<tr>
<td>Limit to</td>
<td>Specify the number of items returned in your feed.</td>
</tr>
<tr>
<td>Within the last</td>
<td>Specify how old items returned can be.</td>
</tr>
<tr>
<td>Include content for pages</td>
<td>Specify whether the entire page is displayed in the feed.</td>
</tr>
</tbody>
</table>

5. Choose Create RSS Feed.
6. Drag or copy the link into your RSS reader.

On this page:

- Building an RSS feed
- Hints
- Notes

Related pages:

- Managing Changes and Notifications and Tasks
- Subscribing to RSS Feeds within Confluence
- Confluence User's Guide

Hints

- Separate feeds. Try building separate feeds, one for pages only and one that includes comments as well. This allows you to monitor only pages if you are short of time, and to read the comments when you have more time.
• **Labels to customise your feed.**

  You can use the RSS feed builder to track updates to labelled pages and comments on those pages. Here is an idea for customising your RSS feed by using your own personal label(s). This is useful if you want to track updates to specific pages or blog posts, and you do not want to deal with emails. You can use this method as an alternative to watching pages.
  
  • Build an RSS feed that returns pages, blog posts and comments labelled with a personal label, such as 'my:feed'.
  • Each time you want to 'watch' a page, just label it with 'my:feed'.
  • All updates and comments will automatically come through your RSS feed.

**Notes**

• **Removing an RSS feed:**

  There is no need to try to delete or remove an RSS feed built by the Confluence RSS feed builder.

  Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL (address). For example, take a look at the following feed URL:

  ```
  http://confluence.atlassian.com/createrssfeed.action?types=page&sort=modified&showContent=true...
  ```

  The above feed URL will generate a list of pages ('types=page'), sorted by the modification date and showing the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no need to remove anything.

  • **Feed authentication options:** Confluence can offer you the option of an anonymous feed or a feed that requires authentication.

  • An **anonymous** feed will show only the content that is visible to anonymous users. The feed URL does not contain the `&os_authType` parameter mentioned below. This feed is useful only if your Confluence site allows anonymous access. If a feed is anonymous, you only get anonymously-viewable content in the feed regardless of whether you are a Confluence user or not.

  • An **authenticated** feed requires you to log in to Confluence before you can retrieve the content. The feed URL contains the following parameter: `&os_authType=basic`.

  • The option to choose between an anonymous and an authenticated feed is currently not available on the feed builder screen. The feed builder offers only **authenticated** feeds. See CONF-21601 for details and a workaround.

**Subscribing to a Network RSS Feed**

You can create an RSS Feed from any user’s network view, allowing you to receive summaries on the activities of users they are following in their network. The types of activities tracked in these RSS feed summaries include:

• Additions or edits to pages or blog posts
• Comments added to a page or blog post or edits to existing comments
• Updates to a user's status updates
• Updates to a user's profile

Subscribing to a user's network feed

**To subscribe to a user's network RSS feed:**

1. Locate the RSS icon 📩, which is available from the top-right of:
   • The 'Recent activity of the users you are following' section of your network page, or
   • The 'Activity of followed users' section of another user’s network page.
2. Copy and paste the icon's link into your RSS newsreader.
Customising your network RSS feed

Confluence does not provide a way of customising a network RSS feed via the user interface. However, you can modify the maximum number of results and type of content displayed in these feeds by directly editing the RSS feed link in your RSS newsreader.

**To modify the maximum number of results displayed in your RSS feed:**

1. Edit the RSS feed link in your RSS newsreader.
2. Change the value of the `max` parameter from its default value of 40 to a value of your choice. Example:
   
   ```
   http://confluence.atlassian.com/feeds/network.action?username=MYNAME&max=60&publicFeed=false&os_authType=basic&rssType=atom
   ```
3. Save the modified link in your RSS newsreader.

**To modify the type of content displayed in your RSS feed:**

1. Edit the RSS feed link in your RSS newsreader.
2. Append the parameter `contentType` to the end of the link, followed by an equals sign (`=`) and then add the appropriate content type value of your choice:
   - `USER_STATUS` — restricts the RSS feed to user status updates.
   - `PAGE` — restricts the RSS feed to page additions or updates.
   - `BLOG` — restricts the RSS feed to blog post additions or updates.
   - `ATTACHMENT` — restricts the RSS feed to attachment additions or updates.
   - `COMMENT` — restricts the RSS feed to comment additions or updates.
   
   Content type values are case-sensitive. Ensure that each parameter is separated from the other by an ampersand (`&`).

   Example:
   ```
   http://confluence.atlassian.com/feeds/network.action?username=ggaskell&max=40&publicFeed=false&os_authType=basic&rssType=atom&contentType=USER_STATUS
   ```
3. Save the modified link in your RSS newsreader.

**Notes**

It is not possible to filter for more than one type of content by adding multiple values to the `contentType` parameter.

### Managing Notifications in Confluence

This page is about the notification-and-task dialog, known as the Confluence ‘workbox’, which drops down when you choose the 📦 icon on the Confluence page header.

Do you want to manage your notification email messages instead? See **Subscribing to Email Notifications of Updates to Confluence Content**.

Managing your notifications in the Confluence workbox

The workbox displays all notifications collected from Confluence page watches, shares, mentions, and tasks. If your Confluence site is linked to a JIRA issue tracker, you will also see JIRA notifications in your workbox.

You can view your notifications and convert them to personal tasks. Use the inline actions to reply to comments, like a comment or page, or watch a page. Follow the links in a notification to open the relevant page or blog post. With JIRA integration, you can watch or unwatch issues, comment on issues, or follow the link to open the issue.
in JIRA.

The workbox displays your notifications and your personal tasks in separate tabs.

**To manage your notifications:**

1. Choose the workbox icon in the Confluence page header.
   - A number may appear on the workbox icon, indicating the number of unread notifications waiting for your attention.
   - You can use the keyboard shortcut: Type _g_ then _n_. (When in the Confluence editor, click outside the editor pane before pressing the keyboard shortcut keys.)

2. Choose the notifications icon:

3. Choose a notification from the list, to see the notification details. Now you can do the following:
   - Choose a link or **Open** to open the related page, blog post, or comment. The page will open in a new tab in your browser.
   - Choose **Like** or **Unlike** to let people know that you like, or have stopped liking, a page, blog post, or comment.
   - Choose **Watch** or **Stop Watching** to receive notifications, or stop receiving notifications, about a page or blog post.
   - Choose **Reply** to respond to a comment inline, within the workbox.
   - Choose the ‘add task’ icon to flag a notification as a task. The notification will remain in the notification list too.

**On this page:**
- Managing your notifications in the Confluence workbox
- Which notifications are included?
- Keyboard shortcuts
- Managing notifications with Confluence mobile
- Notes

**Related pages:**
- Configuring Workbox Notifications
- Subscribing to Email Notifications of Updates to Confluence Content
- Watching Pages, Spaces and Blogs
- Likes and Popular Content

**Screenshot: Your Confluence notifications in the workbox**
Which notifications are included?

The workbox displays a notification when someone does one of the following in Confluence:

- Shares a page or blog post with you.
- Mentions you in a page, blog post, comment or task.
- Comments on a page or blog post that you are watching.
- Likes a page or blog post that you are watching.

The workbox does not show notifications triggered because you are watching a space. Only watches on pages and blog posts are relevant here.

The notification in your workbox appears as 'read' if you have already viewed the page or blog post.

If your Confluence site is linked to JIRA, you will also see the following JIRA notifications in your workbox:

- Comments on issues that you are watching.
- Mentions.
- Shares of issues, filters and searches.

Keyboard shortcuts

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>g then n</td>
<td>Open the Confluence workbox.</td>
</tr>
<tr>
<td>j</td>
<td>Move down to the next entry in the notification list.</td>
</tr>
<tr>
<td>k</td>
<td>Move up to the previous entry in the notification list.</td>
</tr>
<tr>
<td>n</td>
<td>Move down to the next notification for a particular page or blog post.</td>
</tr>
</tbody>
</table>
Managing notifications with Confluence mobile

You can view and respond to your notifications on your phone or other mobile device too. See Using Confluence on a Mobile Device for more about mobile platforms.

### Notes

- Read notifications are automatically deleted after 2 weeks.
- Unread notifications are automatically deleted after 4 weeks.
- You cannot delete your notifications yourself.
- If a new notification arrives while you have workbox open, the count appears on the workbox icon but the notification is not added to the workbox. You need to close workbox and re-open it to see the new notification.
- The ability to receive notifications from JIRA or another Confluence site is available in Confluence 4.3.3 and later. To receive JIRA notifications, you need JIRA 5.2 or later.
- Administrators can enable and disable the workbox on your Confluence site. They can also connect a JIRA site or another Confluence site, so that notifications from those sites appear in your workbox too. See Configuring Workbox Notifications.
- The Confluence workbox is provided by a set of plugins. To remove the personal notifications and tasks functionality from your site, you can disable the following plugins. See Disabling or Enabling a Plugin for instructions. Disabling these plugins will disable the entire workbox. It is not possible to disable only tasks or only notifications:
  - Workbox - Common Plugin
  - Workbox - Host Plugin
  - Workbox - Confluence Provider Plugin
- If you want to re-enable the plugins, do so in the following order: Common Plugin, Host Plugin, Confluence Provider Plugin.
- There is no option to disable the workbox for an individual user.
- The workbox is not available in clustered environments. The plugin will be installed and enabled, but it will detect that the site is in clustered mode and will not display the dialog.

### Working with Tasks
Keep track of the things that need to get done with tasks. With the ability to give each task an assignee and due date, and plenty of ways to see your tasks, you can make sure nothing slips through the cracks in your project or team.

Creating a task

Tasks are created on pages. For example, you might add tasks under action items on a meeting notes page, or in a project planning page - anywhere you need a lightweight task management solution.

To create a task:

1. In the editor choose the Task list button or use the keyboard shortcut [ ]
2. Start typing your task - use @ to assign the task to someone or // to choose a due date.

The first person you mention in a task is the assignee. You can mention more people in the task, but the first person mentioned will be the assignee - you can even assign tasks to yourself.

Note: If you assign a task to someone who does not have permissions to view the page or space, they won’t see the task.

Keeping track of tasks

There are a number of ways to keep track of tasks assigned to you, or tasks you’ve created for others.

On a page

The simplest way to see a task is on the page it was originally created on, for example in a meeting notes page.

It is easy to see if a task is complete, who it is assigned to, and when it is due. If a task is nearing, or has passed its due date, the colour of the date will change (red for overdue, orange for due in the next 7 days).

In your profile

The tasks page in your profile gives you a place to see all the tasks relevant to you in one place. Easily keep track of the status of tasks assigned to you, and tasks you’ve created and assigned to others.

To view the tasks page, go to Profile > Tasks.

Use the filters to show tasks that were assigned to you or created by you and toggle between complete or incomplete tasks.
In a Task Report

If you're looking for a more custom view of tasks, the Task Report blueprint is a great way to track tasks assigned to a specific team or project.

To create a task report:

1. Choose Create > Task Report
2. Select the type of report:
   - **Assigned to my team** for tasks assigned to particular people
   - **In my project** for tasks that appear in a specific space or page, or
   - **Custom** for a wide range of filtering options, including by date or page label.
3. Follow the prompts to create the report.

This blueprint uses the Task Report macro. You can also choose to use this macro on an existing page, for example, on a project or team space homepage. See Task Report Macro for more about using this macro.

Notes

- Personal Tasks (created in the Workbox in older versions of Confluence) do not appear in the Tasks view or Task Report. To migrate any incomplete personal tasks, go to Workbox > Personal Tasks and follow the prompts.
- The existing wiki markup based Tasklist Macro has been removed from the macro browser. If you have a Tasklist macro on a page it will continue to work, but you will be unable to add new Tasklists using this macro.

Finding Content

Where does a page or blog post go when you create it, and how can you find it again? How can you find content that is most relevant to your team or project, or search for pages that cover the topic you are interested in?

**Hint for space administrators:** Help your team members and colleagues find important pages and other content, by adding links to the space's sidebar. See Configuring a Sidebar.

A space is an area within Confluence, containing your pages, blog posts and other content. You can think of each space as a sub-site, or mini-site, each with its own home page.

**Finding pages and blog posts**

These are the quickest ways to find your content:
• Use the links in the sidebar to find your pages, blog posts, and other parts of the space. See more details below.
• Type the page name or key words into the search box at the top right of the Confluence screen. See Searching Confluence.
• Go to the pages view for a list of pages in the space. You can see recently updated pages or browse through a hierarchical (tree) view. See Viewing All Pages in a Space.

More about the sidebar

The sidebar appears on the left of every page in spaces that use the default Confluence theme. You can:

• Choose a different type of content, or perform various operations, via the links on the sidebar.
• Use the contextual navigation options that appear at the bottom of the sidebar, based on the type of content you are viewing.
• Collapse or expand the sidebar.
• Access the sidebar options via slide-out menus even when the sidebar is collapsed.
• Configure the links that appear in the 'Shortcut links' section, if you are a space administrator.

On this page:
• Finding pages and blog posts
• More about the sidebar
• Collapsing the sidebar
• Where does Confluence put your pages and blog posts?
• Can you change the location of a page?
• Can you change the location of a blog post?

Related pages:
• Creating Content
• Organising Content
• Giving People Access to Content
• Using the Documentation Theme
• Confluence User's Guide

Screenshot: Sidebar in the default theme
<table>
<thead>
<tr>
<th>Section or option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link to the space home page</td>
<td>This link appears next to the space logo at the top of the sidebar. It takes you to the home page for this space. Clicking on the space logo will also take you to the home page for the space.</td>
</tr>
<tr>
<td>Pages and Blog</td>
<td>This section can contain the links to the following locations:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Pages</strong>: An index of all pages in the space. See <a href="https://confluence.atlassian.com/doc/viewing-all-pages-in-a-space">Viewing All Pages in a Space</a>. Note that space administrators can hide the 'Pages' link.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Blog</strong>: An index of all blog posts in the space. See <a href="https://confluence.atlassian.com/doc/working-with-blog-posts">Working with Blog Posts</a>. Note that space administrators can hide the 'Blog' link.</td>
</tr>
<tr>
<td></td>
<td>• Other links added by add-ons.</td>
</tr>
<tr>
<td>Space shortcuts</td>
<td>This area contains links to important pages and other locations for your project or team. Space administrators can add and remove links here. See <a href="https://confluence.atlassian.com/doc/configuring-a-sidebar">Configuring a Sidebar</a>.</td>
</tr>
<tr>
<td>Space Tools</td>
<td>The 'Advanced' option gives access to space administration and advanced operations like space exports and space watches.</td>
</tr>
<tr>
<td>Configure sidebar</td>
<td>The 'Configure sidebar' option is available to space administrators for setting up shortcut links, changing the space name and logo, and other configuration options. See <a href="https://confluence.atlassian.com/doc/configuring-a-sidebar">Configuring a Sidebar</a>.</td>
</tr>
<tr>
<td>Contextual navigation</td>
<td>The links in this area change, depending on the section of the space that you are viewing.</td>
</tr>
<tr>
<td></td>
<td>• For pages, you will see the child pages (if any) of the current page, and a quick link to create a child page.</td>
</tr>
<tr>
<td></td>
<td>• For blogs, you will see links to blog posts in the current month, and an expandable list of previous months.</td>
</tr>
<tr>
<td></td>
<td>• If you are viewing the space tools option, you will see content tools, space administration, and other advanced options. Add-ons can add options here too.</td>
</tr>
</tbody>
</table>

**Collapsing the sidebar**

Advanced users will find it useful to collapse the sidebar and gain more space on the page.

- Grab and drag the border, choose the >> button or use the keyboard shortcut [ to collapse and expand the sidebar.
- Access the sidebar options via slide-out menus even when the sidebar is collapsed.
Where does Confluence put your pages and blog posts?

When you create a new page, that page will be a child of another page, in the space that you selected in the 'Create' dialog. The parent page depends on where you are when you create the page.

<table>
<thead>
<tr>
<th>Your location when creating the page</th>
<th>Location of new page</th>
</tr>
</thead>
<tbody>
<tr>
<td>You are viewing a page in the same space where you will put the new page – that is, the space that you select in the 'Create' dialog.</td>
<td>A child of the page you are currently viewing.</td>
</tr>
<tr>
<td>You are viewing any other Confluence screen. For example:</td>
<td>A child of the home page in the space you select in the 'Create' dialog.</td>
</tr>
<tr>
<td>- You are on the dashboard.</td>
<td></td>
</tr>
<tr>
<td>- You are on the 'Pages' view of a space.</td>
<td></td>
</tr>
<tr>
<td>- You are viewing a blog post.</td>
<td></td>
</tr>
<tr>
<td>- You are viewing a page in a space, and choose to add your new page in a different space.</td>
<td></td>
</tr>
</tbody>
</table>

A blog post is part of a chronological sequence of posts, linked from the space's 'Blog' index page.

Can you change the location of a page?

Yes. See Moving a Page.

Can you change the location of a blog post?

No.

Searching Confluence

Quick guide to searching in Confluence:

1. Use the search box at the top right of your Confluence screen. It offers you a quick navigation aid as well as a full site search.
2. You can search for administrative actions via the quick navigation aid too.
3. You can search Confluence directly from your browser’s search box. Just add your Confluence site as a search provider using the dropdown menu in your browser’s search box.
4. While editing a page or a blog post, you can find and replace text on the page. See Using the Editor.

**Using the quick navigation aid to find content and administrative actions**

When you enter text into the Confluence search box, the quick navigation aid automatically offers a dropdown list of pages, administrative options, and other items. The items are matched by page name to your search query. You can choose one of the offered items or ignore them altogether.

**To use the quick navigation aid to find content:**

1. Start typing your query into the search box located at the top right-hand corner of every screen. Confluence matches titles as you type, showing a quickly-adjusting dropdown list of pages, blog posts, personal profiles, attachments and so on.
   - Press the Enter key if you want to bypass the quick navigation aid and perform a full search, as described below.
2. To see the space to which an item belongs, let your mouse pointer hover over the item in the dropdown list.
3. Use the up- and down-arrows on your keyboard to move up and down the list of matching titles and select an item.
4. Press the Enter key to open the selected item.
5. If you do not find what you are looking for, click **Search for** at the bottom of the list to do a full search.
   - This has the same effect as pressing Enter immediately after typing your search query. The full search is described below.

**To use the quick navigation aid to get to administration functions:** Start typing what you want to do into the Confluence search box. The matching administrative functions will appear with a cog icon at the top of the dropdown search results.

**Even faster via ‘GG’:** Press ‘G’ twice on your keyboard then continue typing the search term.

*Screenshot: The quick navigation aid showing titles matching the query 'st'*
Here is more information about how the quick navigation feature works:

- Confluence will truncate any titles that are too long to be displayed.
- The matching items are grouped by type so that you can quickly find the type you want. Confluence shows a maximum of 3 administrative items, 6 pages and/or blog posts, 2 attachments, 3 people and 2 spaces. If no matches are found in a particular category, then that category does not appear in the list.
- Items are ordered with the most recent updates first.
- When the matching item is a person's name, their profile picture appears next to their name in the list.
- The part of the title that is matched by the search query is highlighted in bold text.
- Your Confluence Administrator can enable or disable the quick navigation feature using the Confluence Administration Console.

Notes about finding administrative options via the search box:
- Pressing 'GG' puts your cursor into the search box.
- The 'GG' combination is familiar to JIRA users, because the same shortcut opens the JIRA administration search dialog.
- System administration, Confluence administration and space administration options may appear in the
search results.

- Confluence permissions determine the administrative options that appear in the search results. You will only see the options that you have permission to perform.

**On this page:**

- Using the quick navigation aid to find content and administrative actions
- Performing a full search
- Filtering your search results
- Searching for labels
- Searching the content of attachments
- Search options when using the Documentation theme
- Advanced search syntax
- Searching Confluence from your browser’s search box
- Useful plugins

**Related pages:**

- Confluence Search Syntax
- Confluence Search Fields
- Search Results Macro
- Livesearch Macro
- Page Tree Macro (includes an optional search box)
- Viewing Labels and Labelled Content
- Searching the People Directory
- Confluence User’s Guide

### Performing a full search

When you perform a full search, Confluence will search all content in all spaces (site and personal), mail, personal profiles, attachments and the space description. The results will appear on a new screen.

**To use the full search:**

1. Type your query into the search box located at the top right-hand corner of every screen (or type it into the text box at the top of the Search screen).
2. Press the Enter key. (This means that you will ignore the dropdown list of titles offered by Confluence’s quick navigation aid, described above.)
3. The search screen appears, as shown below. If any Confluence pages or items match your search query, the search screen shows a list of the matching items.
4. Click an item’s title to open the Confluence page or other item.

*Screenshot: Search results page*
On the right of the screen you will see a text block for each item that matched the search criteria, with the following information for each item:

- An icon representing the content type (user profile, space, page, blog post, etc).
- The title or name of the content item, linked to the item.
- The most relevant few lines of content from within the item. Any words that match your search query are highlighted within the content.
- The space to which the item belongs, displayed on the last line of the item's text block.
- The date when the content item was last modified.

You will see only search results which you have permission to view.

On the left of the screen are further options which allow you to tailor or filter your search results. See below.

**Filtering your search results**

The search screen, pictured above, appears when you do your first search. By default, Confluence will search all content across your Confluence site, including all spaces, mail archives, attachments and all other content types.
On the left of the screen are options which allow you to tailor (filter) the search results.

Define your filter criteria:

- **Type** – Restrict your search results to a particular content type (pages, blog posts, comments, etc).
- **Last modified** – Restrict your search results to content updated within a particular period of time (within the previous 24 hours, within a week, within a month, or within a year).
- **Space** – Restrict your search results to a particular space, or to your favourite spaces, site spaces or personal spaces. You can also set an option to include archived spaces. (See Archiving a Space.)
- **By** – Restrict your search results to content last modified by a particular person. You can start typing the person's username or part of their name into the text box as follows:
  - Type the username (for example: 'jsmith').
  - Or start typing the person's first name (for example: 'john')
  - Or their last name (for example: 'smith').
  - Or another part of their name, such as a middle name. Confluence will offer you a list of possible matches. Use your mouse to select the person you want, then press the Enter key to filter the search results.

More information about the user-matching filter:

- The user-matching filter is not case sensitive. You can enter upper or lower case letters and will receive the same results.
- When looking for users to match the name you entered, Confluence divides a person's name into logical units corresponding to first name, middle name (one or more) and last name. It matches the letters of each unit in the name you entered against the letters of each unit in the user directory. For example, you can enter 'jo sm' to look for John Smith. The search is triggered after you have entered at least two letters.
- For each part of the name, you need to enter at least two letters. For example, if you enter just 'john s', the filter will look for users called 'john' and will ignore the 's'. Similarly, if you enter 'j smith' you will see everyone with the name 'smith' even if their first name does not start with a 'j'.
- You are not forced to use the auto-complete list. You can just type 'jsmith' or 'jo sm' and filter on that without choosing a match from the dropdown list. Confluence will warn you if there is more than one user corresponding to the name you have entered.

Searching for labels

Use the 'labelText:' prefix to search specifically for content that has a specific label. The table below gives examples of search terms that you can enter into Confluence's search box, and the search results that you can expect.

<table>
<thead>
<tr>
<th>Searching for ...</th>
<th>Returns content that ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>recipe labelText:chocolate</td>
<td>contains the word 'recipe' or has the label 'chocolate'</td>
</tr>
<tr>
<td>recipe AND labelText:chocolate</td>
<td>contains the word 'recipe' and has the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake OR labelText:chocolate</td>
<td>has the label 'cake' or the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake AND labelText:chocolate</td>
<td>has both labels 'cake' and 'chocolate'</td>
</tr>
</tbody>
</table>
Searching the content of attachments

When you search Confluence, by default the search will include the content of the following types of attachments:

- Word
- Text
- PowerPoint
- Excel
- PDF
- HTML

To search the content of other attachment types, you will need to use an attachment content extractor plugin. For more information, take a look at the following:

- Existing extractor plugins which you can install on your Confluence site. See this search on Atlassian Marketplace.
- Guidelines on developing your own attachment content extractor plugin. See our developer documentation on extractor plugins.

Search options when using the Documentation theme

When using the Documentation theme, the Confluence search offers a few options as described below.

Using the search box at the top right of the page:

- By default, the main Confluence search is configured to search the entire Confluence site.
  - You will see the words 'Search Confluence' in the search box at top right of the page.
  - The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
- A space administrator can configure the Documentation theme to restrict the search to the current space.
  - You will see the words 'Search this space' in the search box at top right of the page.
  - The search will return results from the current space only.
  - You can override the search restriction. Enter 'all:' and your search term to search the entire site. For example, enter the following into the search box at top right of the page to search the entire site for 'technical writing':

```
all: technical writing
```

Using the search box in the left-hand panel:

- By default, the Documentation theme's left-hand panel includes a search box. Enter your search term there, to restrict the search to the current space. Specifically, this will search only the pages that are children of the space's home page.
- If your administrator has restricted the main search to the current space, there will not be a search box in the left-hand panel.

For screenshots and a full description, see Using the Documentation Theme.

Advanced search syntax

See Confluence Search Syntax for more ways to refine the text you enter into the search box.

Additionally, see Confluence Search Fields for special parameters you can use in the search box to search on various metadata.
Searching Confluence from your browser's search box

If you are using Firefox or Internet Explorer 7 or later, you can add your Confluence site as a search provider, using the dropdown menu next to the browser's search box.

The example below shows the 'Extranet' Confluence site offered for inclusion as a search engine in the browser's search box.

Screenshot: Adding your Confluence site to your browser's search box

Information about OpenSearch:

- Confluence supports the autodiscovery part of the OpenSearch standard, by supplying an OpenSearch description document. This is an XML file that describes the web interface provided by Confluence’s search function.
- Any client applications that support OpenSearch will be able to add Confluence to their list of search engines.
- Your Confluence Administrator can enable or disable the Open Search feature using the Confluence Administration Console.

Useful plugins

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

This plugin extends the Confluence search, so that you can search for macro parameter names and values: the Confluence Macro Indexer plugin.

Confluence Search Syntax

This page describes the special words and punctuation marks you can use to refine your search.

Matched phrase search

Use double quotes to search for content that contains the phrase 'cheese one', or a phrase where 'cheese' and 'one' are the major words:

"cheese one"

Note: Confluence will ignore common words (stop words), including 'and', 'the', 'or', and more, even if they are included within double quotes. See the default list of stop words used by Confluence's search engine, Lucene, in the Lucene documentation.

For example:

1. Searching for "cheese one" returns only pages in which 'one' appears as the first word (other than stop
words) after ‘cheese’. So it will return ‘cheese for one’ or ‘cheese to one’ or ‘cheese one’. It does not return ‘one cheese’ or ‘cheese flamingo one’.

2. Searching for “the one” returns all pages containing ‘one’ because ‘the’ is a stop word.

If you would like to override Lucene’s tokenisation and stemming, please cast your vote on this improvement request: CONF-14910.

OR search

To search for content that contains one of the terms, ‘chalk’ or ‘cheese’, use the operator OR in capital letters:

chalk OR cheese

AND search

To search for content that contains both the terms ‘chalk’ and ‘cheese’, use the operator AND in capital letters:

chalk AND cheese

NOT search

To search for content that contains ‘chalk’ but NOT ‘cheese’, use the operator NOT in capital letters:

chalk NOT cheese

Excluded term search

To search for content that contains ‘chalk’ and ‘butter’ but not ‘cheese’:

chalk butter -cheese

Grouping search

To search for content that must contain ‘chalk’ but can contain either ‘cheese’ or ‘butter’, use brackets to group
the search terms:

(cheese OR butter) AND chalk

Title search

To search for content with 'chalk' in its title, where title is the field keyword.

title:chalk

Wildcard searches

Single character

To search for 'butter' or 'batter' you can use a question mark as a wildcard:

b?tter

To search for 'chicken' or 'chickpea' you can use an asterisk as a wildcard:

chick*

You can use wildcards anywhere within a word, even at the very beginning:

*c*chick

Multiple characters

To search for 'chick' or 'chickpea':

c*c*

You can also combine search characters to get the exact word. For example the search term below will return 'chick' but not 'chickpea':

c*c?

Case sensitivity in wildcard searches

Confluence is case sensitive for wildcard searches.

Note: All the example searches given above will search across the default set of fields which are stored as lower case and therefore all searches of that style should be given lower case search terms (as shown in the examples).

However, if you were to search one of the case sensitive fields, such as 'content-name-untokenized' the case of your search term would need to match the document you are searching for.

Proximity searches

Use a tilde character followed by a number, to find two words within a certain number of words of each other.
For example, the following search will return 'Octagon blog post':

"octagon post"~1

The following search is not valid:

"octagon post"~0

Range search

Use the operator 'TO', in capital letters, to search for names that fall alphabetically within a specified range:

[adam TO ben]

Note: You cannot use the AND keyword inside this statement.

Fuzzy search

Use a tilde character to find words spelled similarly.

To search for octagon, if unsure about spelling:

octogan~

Combined search

You can also combine various search terms together:

o?tag* AND past~ AND ("blog" AND "post")

Searching for macros

You can search Confluence content for anywhere a macro is used. To do this, just add macroName: to your search and append the macro name after the column. For example, search for all excerpt-include macros:

macroName:excerpt-include*

For more information about macroName and other search fields, see Confluence Search Fields.

Searching for labels

Use the 'labelText:' prefix to search specifically for content that has a specific label. The table below gives examples of search terms that you can enter into Confluence's search box, and the search results that you can expect.

<table>
<thead>
<tr>
<th>Searching for ...</th>
<th>Returns content that ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>recipe labelText:chocolate</td>
<td>contains the word 'recipe' or has the label 'chocolate'</td>
</tr>
<tr>
<td>recipe AND labelText:chocolate</td>
<td>contains the word 'recipe' and has the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake OR labelText:chocolate</td>
<td>has the label 'cake' or the label 'chocolate'</td>
</tr>
</tbody>
</table>
The `labelText:` prefix is an example of a search field. See more about Confluence Search Fields.

### Confluence Search Fields

This page gives an overview of the Apache Lucene search fields used in Confluence.

**Searching for content in specific fields**

Confluence data is stored in fields which can be specified in the search. To search a specific field, type the name of the field followed by a colon `:` and then the term you are looking for.

**Preliminary examples:**

```
title:"Some Title"
```

```
labelText:chalk
```

The field specification applies only to the term directly preceding the colon. For example, the query below will look for "Some" in the title field and will search for "Heading" in the default fields.

```
title:Some Heading
```

---

**Confluence search fields**

**Personal Information**

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>fullName</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Indexed</td>
<td>Stored</td>
<td>Tokenised</td>
<td>Notes</td>
</tr>
<tr>
<td>------------</td>
<td>---------</td>
<td>--------</td>
<td>-----------</td>
<td>-----------------------------------------------------------------------</td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

**Pages**

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used on the page</td>
</tr>
</tbody>
</table>

**Blog**

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used in the blog</td>
</tr>
</tbody>
</table>

**Attachments**

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>filename</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>
More examples

**Searching for labels**

Use the 'labelText:' prefix to search specifically for content that has a specific label. The table below gives examples of search terms that you can enter into Confluence's search box, and the search results that you can expect.

<table>
<thead>
<tr>
<th>Searching for ...</th>
<th>Returns content that ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>recipe labelText:chocolate</td>
<td>contains the word 'recipe' or has the label 'chocolate'</td>
</tr>
<tr>
<td>recipe AND labelText:chocolate</td>
<td>contains the word 'recipe' and has the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake OR labelText:chocolate</td>
<td>has the label 'cake' or the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake AND labelText:chocolate</td>
<td>has both labels 'cake' and 'chocolate'</td>
</tr>
</tbody>
</table>

The 'labelText:' prefix is an example of a search field. See more about **Confluence Search Fields**.

**Useful plugins**

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on **add-on support**.
This plugin extends the Confluence search, so that you can search for macro parameter names and values: the Confluence Macro Indexer plugin.

**Searching the People Directory**

The people directory displays a list of people who are authorised to log in to your Confluence site.

The people directory includes anybody who has logged into Confluence or who has had a user account created for them in Confluence.

The people directory does not include users who can log into Confluence using external user management if they have never yet logged in.

**Viewing the people directory**

Choose **People** at the top of the screen.

**Searching for people**

To search for a particular person, type their first name and/or last name into the search box and choose **Search**.

- To see everyone who uses your Confluence site, choose **All People**.
- To see just those people who have set up a personal space, choose **People with Personal Spaces**.

**Following people’s activities**

Confluence’s network features allow you to ‘follow' (that is, keep track of) other people’s activities in your Confluence site. For more information, please refer to Network Overview. You can use the hover profile feature in the people directory to start following other people.

- To start following someone, move your mouse over their name or profile picture and choose **Follow** in their profile popup.
- To stop following someone, move your mouse over their name or profile picture and choose **Stop Following** in their profile popup.

Once you start following another person, their activities will start appearing in your network view.

---

**On this page:**
- Viewing the people directory
- Searching for people
- Following people’s activities
- Notes

**Related pages:**
- Setting Up your Personal Space
- Editing your User Profile
- Choosing a Profile Picture
- Confluence User’s Guide

---

**Screenshot: The people directory**

<table>
<thead>
<tr>
<th>People Directory</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>All People</strong></td>
</tr>
<tr>
<td><img src="sample@email.com.au" alt="Josh User" /></td>
</tr>
<tr>
<td><img src="sample@email.com.au" alt="Sophie Staunton" /></td>
</tr>
<tr>
<td><img src="sample@email.com.au" alt="Ewan User" /></td>
</tr>
<tr>
<td><img src="sample@email.com.au" alt="Rach Admin" /></td>
</tr>
</tbody>
</table>

Created in 2014 by Atlassian. Licensed under a [Creative Commons Attribution 2.5 Australia License](https://creativecommons.org/licenses/by/2.5/au/).
Notes

- The people directory uses the hCard microformat for simple integration with a variety of microformat-enabled tools. hCard is an open data format for representing people, companies, organisations, and places. Read more about microformats and hCard.
- By default, deactivated users (disabled user accounts) are excluded from the people directory. You can include them by adding the showDeactivatedUsers parameter to the URL. For example:

  http://my.confluence.com/dopeopledirectorysearch.action?showDeactivatedUsers=true

- By default, externally deleted users (for example, users deleted from an LDAP repository) are excluded from the people directory. You can include them by adding the showExternallyDeletedUsers parameter to the URL. For example:

  http://my.confluence.com/dopeopledirectorysearch.action?showExternallyDeletedUsers=true

- The Confluence administrator can hide the people directory. If it is hidden, you will not see the People Directory option.

Organising Content

Confluence provides a number of ways for organising and structuring content in the wiki:

- Spaces allow you to group content according to major categories.
- Pages are used for discrete topics, and can be structured into page trees to show the relation between them.
- Favourites are particular pages or spaces that have been bookmarked by a user, to make them easy to find again.
- Labels are user-defined tags that are added to related pages in order to categorise them in some way.
- Attachments to a page can include images, multimedia, Office and PDF files, and provide a way to include other forms of content in the wiki.
- The sidebar is a good place to display important links for your team or project.
- Email can be collected and archived within each space, to manage all mail related to a project.

Related pages:

- Changing the Sequential Order of Pages
- Creating Content
- Searching Confluence
- Confluence User’s Guide

Working with Pages

Pages are the primary means of storing and sharing information in Confluence. Pages are contained within spaces.

- Use spaces to organise your wiki content into your primary logical groups. For example, you could have a space per team, per product, or per department.
- Use pages to organise your content into lower-level groups. For example, you could have a page for a particular team activity, or for a feature in a product, or for a chapter in a book. Add more child pages to contain lower-level details if necessary.

Things you can do with pages in Confluence:

- Create a new page from anywhere within the site.
- Write content using the editor.
- Rename a page.
Moving a Page

This guide describes how to change a page's location. You can:

- Change the default location of a new page.
- Move an existing page to a different space.
- Move an existing page to a different parent page within the same space.
- Reorder pages that are children of the same parent.

When you move a page, attachments and comments will be moved with the page. All child and descendent pages will also be moved.

Notes about permissions:

To move a page, you need the following permissions:

- 'Add' permission on the page you are moving, and
- 'View' permission on the page's parent page. So if you are moving the page to a different parent, you need 'View' permission on the new parent.

To move a page into a different space, you also need:

- 'Delete' permission on the space you are moving from, and
- 'Add' permission on the space you are moving to.

If the page has page restrictions, and you want to keep the page restrictions in the new location, you will also need 'Restrict' permission on the space you are moving to. Alternatively, remove the page restrictions before performing the move.
To set the location for a new page:

1. While editing the page, choose Location.
2. Use the tabs on the left of the 'Set Page Location' dialog to help you find the new space and parent page for your page. They determine the location of your page. The 'Current location' and 'New location' breadcrumb trails at the bottom of the dialog indicate the current parent page and new parent page.
3. If you want to move a page to a different position amongst the child pages, select Reorder. (When you choose Move in the next step, you will be able to reorder the page.)
4. Choose Move.
5. If you are reordering the child pages, position the pointer in the list to set the new position for the page and choose Reorder.

Screenshot: Setting the location of a new page

Moving a page to a different space

You can move a page, along with its child pages, to a different space. Confluence will automatically adjust all links to the moved pages, to point to the pages in the new space.

To move a page to another space in your Confluence site:

1. Go to the page and choose Tools > Move.
2. Use the tabs on the left to help you find the new space and parent page for your page. They determine the location of your page. The 'Current location' and 'New location' breadcrumb trails at the bottom of the dialog indicate the current parent page and new parent page.
3. If you want to move a page to a different position amongst the child pages, select Reorder. (When you choose Move in the next step, you will be able to reorder the page.)
4. Choose Move.
5. If you are reordering the child pages, position the pointer in the list to set the new position for the page and choose Reorder.

Moving a page within a space
You can move a page to a different position in the page tree. This allows you to:

- Move a single page, or a family of pages, to a different parent within the space.
- Reorder pages that are children of the same parent.

All links to the page are maintained. When you move a parent page, the entire hierarchy of child pages will move too.

**To move a page:**

1. Go to the space and choose **Space tools > Reorder pages** on the sidebar. If your space is using the Documentation theme choose **Browse > Pages**.
2. Expand the branches to locate the page you want to move.
3. Drag the page to a new position in the tree.
4. While dragging the page, you see one of the following:
   - A thin line between existing pages - this indicates the potential new position for the page. Release the mouse button when the page is where you want it.
   - A wide highlight over one or more existing pages - this indicates that you can drop the page into a page family. Release the mouse button to add the page to the family. The page will appear either in alphabetical sequence or as the last page in the family, depending on the family's sequential order.

**Notes**

- The new position of the page is saved as soon as you release the mouse button.
- To cancel the move, press the 'Esc' key before releasing the mouse button.

### Copying a Page

You can copy a page, to create a duplicate of the page content. You will need to rename the page, because a page name must be unique within a space.

You need ‘Create Pages’ permission, which is assigned by a **space administrator** from the Space Administration screens. See **space permissions** or contact a space administrator for more information.

**To copy a page:**

1. Go to a page in the space and choose **Tools > Copy**. Confluence will open a copy of the page in the editor. By default, Confluence will name the page 'Copy of <<original page name>>'.
2. Rename the page and make any other changes required in the body of the page.
3. If you need to move the new page to a different space or a different parent, you can edit the **Location**. Refer to the instructions on moving a page.
4. Click **Save**.

**Related pages:**
- Working with Pages
- Moving a Page
- Confluence User's Guide

---

**Screenshot: Copying a page**

---

**Notes**

- Copying a page will duplicate all of the original page’s attachments and labels, but will not copy comments from the original page.
This method of copying a page does not copy the child pages. Please add your vote to issue CONF-2814 if you’d like to see this improvement.

You can copy an entire space, including all pages in the space (parents and children) — refer to these instructions on copying a space.

Consider using WebDAV to move or copy a page hierarchy from one space to another, provided that none of the page names already exist in the target space.

Renaming a Page

To rename an existing page, you require ‘Edit Pages’ permission which is assigned by a space administrator from the Space Administration screens. See Space permissions or contact a space administrator for more information.

To rename a page:

1. Go to a page in the space, and click Edit at the top to view the page in ‘Edit’ mode.
2. Change the page title as required.
3. Click Save.

Related pages:
- Working with Pages
- Confluence User’s Guide

Notes

- Confluence will automatically update all internal links to point to your new page title. This only works for relative links that use the relative link syntax, for example [Renaming a Page].
- In macros, page links will not be updated. You need to update these manually.
- Links from external sites will be broken, unless they use the permanent URL - see Working with Links.

Deleting a Page

By default, when you delete a page in Confluence, this will delete all versions of the page. To do that, you need the ‘Delete Pages’ permission. See Space permissions. If someone has applied page restrictions to the page, the restrictions may prevent you from deleting the page too.

If you want to delete a specific version of a page, you need to be a space administrator.

Deleting a specific version of a page

To delete just one version of a page:

1. Go to the page and choose Tools > Page History. Choose Delete next to the version you want to delete, and confirm the action as prompted.

On this page:
- Deleting all versions of a page
- Deleting a specific version of a page
- Deleting a page and all its children
- Notes

Related pages:
- Restoring a Deleted Page
- Purging Deleted Pages
- Creating Content
- Editing or Deleting a Page That Won't Render
- Confluence User’s Guide
Deleting a page and all its children

If the page you are deleting has any child pages, the child pages will move to the root of the space. The child pages will not be deleted, but they will lose the parent-child relationship with the deleted page.

**Hint:** If you need to remove a parent page and a large number of child pages:

- Create a temporary new space.
- Move the parent page to the new space. The child pages will move too.
- Remove the space.

**Notes**

- When you delete a page, Confluence moves it to the trash. Space administrators can recover pages from the trash. For important notes about what happens when you restore deleted pages, see [Restoring a Deleted Page](#).
- Purge the trash to delete the page permanently.
- When you delete a version of a page, the version is not stored in the trash. The deletion of a version is therefore permanent and cannot be undone.
- Attachments attached to a deleted page will remain in the database (allowing potential retrieval) until the trash is purged. When the trash is purged, all attachments on that page are permanently removed.
- When you delete a version of a page, the version numbers of the later versions will change accordingly. For example, if a page has four versions and you delete version 2, then version 3 will become version 2 and version 4 will become version 3.

**Purging Deleted Pages**

When a user deletes a page from a Confluence space, the page is not permanently removed. Instead, Confluence places the deleted page into the ‘Trash’. The page will remain in ‘Trash’ until a space administrator purges the page.

Purging deleted pages permanently clears them from ‘Trash’.

You need to be a [space administrator](#) to purge deleted pages for a space.

**Related pages:**

- Deleting a Page
- Restoring a Deleted Page
- Confluence User’s Guide

**To purge deleted pages:**

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Trash**
3. A list of deleted pages and blog posts for the space displays. Choose **Purge** for a specific page or **Purge All** to permanently clear all deleted pages and news items.

If your space is using the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.  
   **Note:** The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **Trash** from the space administration options
3. A list of deleted pages and blog posts for the space displays. Choose **Purge** for a specific page or **Purge All** to permanently clear all deleted pages and news items.

**i** When the trash is purged, all attachments on purged pages are permanently removed as well.

**Restoring a Deleted Page**

When you restore a page, you are moving it from ‘Trash’ to the root of the space.

You need to be a [space administrator](#) to restore deleted pages.
To restore a deleted page:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Content Tools > Trash
3. A list of deleted pages and blog posts for the space displays. Choose Restore for the page you wish to restore.

If your space is using the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   *Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Trash from the space administration options
3. A list of deleted pages and blog posts for the space displays. Choose Restore for the page you wish to restore.

To find the page after you have restored it, choose Pages to go to the root of the space. (The page is not restored to its original position in the page hierarchy.)

Notes

- If a new page has already been created in that space with the same name as the deleted page, you will be given an option to rename the page before it is restored.
- If the page had any child pages before it was deleted, Confluence moved the child pages to the root of the space when the page was deleted. The parent-child relationship will not be automatically restored when you restore the page.

Viewing All Pages in a Space

All Confluence pages are contained within a space. You can use the Pages view to see a list of recently updated pages and all pages within a space.

To access the Pages view:

1. Go to a page in the space and choose Pages in the sidebar.
   Or, if you are using the Documentation theme, choose Browse > Pages at the top of the screen.
2. Recently updated pages and a hierarchical (tree) view of all pages in the space display.
If you are using the Documentation theme, you can choose between Recently Updated, Alphabetical and Tree view of the pages in your space.

*Screenshot: Tree view in the Documentation theme*

**List Pages - Tree View**

- View: Recently Updated · Alphabetical · Tree
- Rachel Robins’s Home
  - Project DEF
  - Project ABC
- Status Reports
  - Status Report - February
  - Status Report - January
  - Status Report - March
- Status and Risk Reports

**Changing the Sequential Order of Pages**

Confluence allows you to present your pages in any order (sequence) you choose. The position of a page is reflected in the following places:

- The navigation area of the space sidebar. (See Finding Content.)
- The pages Tree on the ‘Pages’ view in the space.
- Pages exported to PDF, HTML and XML.
- The Page Tree macro.
- The Children macro.

**Alphabetical versus manual order**

By default, Confluence will present your pages in alphabetical order. When you move a page to a different position, the order becomes manual for the affected page family. When we say ‘page family’ we mean the immediate children of the parent page, not including the grand-children.

When ordering pages alphabetically, Confluence applies a more sophisticated 'natural' order rather than a
straight alphabetical order. The natural order handles numeric values correctly when doing string comparisons.

Now let's consider what happens when you add a page to a page family, by creating a new page or by moving or copying a page into the family:

- If the page family's order is alphabetical, the new page will appear in alphabetical order too.
- If the page family's order is manual, the new page will appear at the bottom of the list of pages in the family.

**On this page:**
- Alphabetical versus manual order
- Changing the page order manually
- Changing the page order to alphabetical

**Related pages:**
- Finding Content
- Working with Pages
- Confluence User's Guide

---

**Changing the page order manually**

**To change the order of pages in the space:**

1. Go to the space and choose Space tools > Reorder pages on the sidebar.
   If your space is using the Documentation theme choose Browse > Pages.
2. Expand the branches of the tree to find the page family you wish to sort.
3. Drag each page to a new position in the tree.

When you drag a page to a new position, the order of the page family changes to Manual. Newly added pages will not be sorted alphabetically, but will appear at the bottom of the list.

**Changing the page order to alphabetical**

If the pages in a page family have been ordered manually, you can change the page order back to alphabetical.

**To set the page order to alphabetical:**

1. Go to the space and choose Space tools > Reorder pages on the sidebar.
   If your space is using the Documentation theme choose Browse > Pages.
2. Expand branches of the tree to find the page family you wish to sort.
3. Choose the Sort Alphabetically (A-Z) icon beside the parent page.

The Sort Alphabetically (A-Z) icon only appears next to the parent page if the page family is currently sorted manually.

If you change your mind, you can use the Undo Sorting icon to revert back to the previous manual page order for that page family. This option is only available immediately after sorting the page (while you are still on the 'Reorder Pages' tab and have not performed any other action).

*Screenshot: Page tree showing the Sort Alphabetically and Undo Sorting icons.*
Sort Alphabetically only sorts the immediate children of the parent page. The grandchildren will not be re-ordered, sorting happens for one node at a time. If you want to re-order grandchildren, you need to click the Sort Alphabetically icon next to the parent of those pages.

Managing Orphaned Pages

An orphaned page is a page without any incoming links. This means that, unless you know that the page exists, you are not likely to come across it in the space during the natural course of navigation.

When you are working in a large space with a number of pages, it is difficult to keep track of all of them. An orphaned page may be redundant or may need to be referred to from another page. Confluence allows you to view all the orphaned pages in a space so you can tidy up the space by either deleting pages or reorganising them.

To view the orphaned pages in a space:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Orphaned Pages.

If your space uses the Documentation theme:

1. Choose Browse > Space Operations at the top of the screen.
2. Choose Orphaned Pages in the space operations options.

You can do the following:

- Delete an orphaned page by choosing the 'trash can' icon next to the page name.
- Edit a page by choosing the 'pencil' icon next to the page name.
- Give an orphaned page a parent — see Moving a Page.

Related pages:
- Managing Undefined Pages
- Working with Pages
- Confluence User's Guide

Screenshot: Managing orphaned pages
Managing Undefined Pages

In Confluence, you can add links to pages that you intend to create later. These are links to 'undefined pages'. This is useful because it allows you to create links first and enter content for those pages later.

The link to an undefined page is shown in dark red. If someone clicks the link, Confluence will create a new page called 'link to new page'.

The 'Undefined Pages' view gives a consolidated report of all undefined pages so that you can manage your space better. The undefined page links are badged with this icon to remind you that those pages need to be created.

To view a list of the undefined links in a space:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Undefined Pages

If your space uses the Documentation theme:

1. Choose Browse > Space Operations at the top of the screen.
2. Choose Undefined Pages in the space operations options.

You can choose the link for an undefined page to create the page and add content to it.

Related pages:

- Managing Orphaned Pages
- Working with Pages
- Confluence User's Guide

Using the Documentation Theme

The Documentation theme is one of the themes bundled with Confluence. It provides an inbuilt table of contents for your wiki space, a configurable header and footer, and text styles suited to documentation. You can also configure it to restrict the search results to the current space, rather than searching the entire Confluence site.

![Advance warning of plans to merge Documentation theme with the default theme]

This is an advance notice that we plan to merge the functionality of the Confluence Documentation theme with the Confluence default theme. We do not yet have a specific date for this plan, and we are interested in your feedback. The new default theme, introduced with Confluence 5.0, includes a sidebar with contextual navigation. Our plan is to include features from the Documentation theme in the default theme, and then remove the Documentation theme from Confluence.

If you are interested in this change and would like to give us feedback, please add a comment on this blog post: Advance warning of plans to merge Documentation theme with the default theme. We are especially interested to know which features of the Documentation theme you use and value the most.

This page tells you how to view pages in your Confluence space when your space uses the Documentation theme. For the full list of features and instructions on applying the theme to a space, see the guide to configuring the Documentation theme.

Quick guide to using the Documentation theme:

- The left-hand panel contains a page tree. This is a table of contents that shows the pages in the space.
- Click the arrow symbols in the page tree to show and hide child pages.
- Drag the thick vertical bar to change the width of the panels.
- Show/hide the left-hand panel: Click the sidebar icon at top right, next to the search box, to remove the left-hand panel altogether. Click the icon again to restore the panel.
- Alternatively, press 'T' on your keyboard to show/hide the left-hand panel.
- Overriding a space-restricted search: If your theme is configured to restrict the search to the current space, you can enter 'all:' and your search term to search the entire site.

The rest of this page gives more details of the above guidelines.
Using the Documentation theme

By default in a space that uses the Documentation theme, the left-hand panel contains a search box and a table of contents (page tree) showing all the pages in your space. Specifically, it shows the pages that are children of the space’s home page.

*Diagram: The Documentation theme with default settings*

A space administrator can customise the Documentation theme as follows:

- Change the content in the left-hand panel and add a header and footer to the page. This means that your own pages may look different from the screenshot above.
- Restrict the search so that it will show results from the current space only, not from the entire Confluence site.

*Diagram: The Documentation theme with space-restricted search*
Here is a summary of the things you can do on a page that uses the Documentation theme:

- Click the plus signs to open and close the branches of the page tree (table of contents) in the left-hand panel.
- Drag the thick bar between the left-hand panel and the content, to increase or decrease the width of the panel.
- Click the sidebar icon at top right, next to the search box, to remove the left-hand panel. This will remove the panel for you only. Other people will still see it.
- Click the sidebar icon again to restore the left-hand panel.
- Alternatively, press ' on your keyboard to show/hide the left-hand panel.
- Use the scroll bars to scroll the left-hand and right-hand panels independently of each other.
- Search the content of the space or the site. See below.

Searching the space or the site

When using the Documentation theme, the Confluence search offers a few options as described below.

Using the search box at the top right of the page:

- By default, the main Confluence search is configured to search the entire Confluence site.
  - You will see the words ‘Search Confluence’ in the search box at top right of the page.
  - The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
- A space administrator can configure the Documentation theme to restrict the search to the current space.
  - You will see the words ‘Search this space’ in the search box at top right of the page.
  - The search will return results from the current space only.
  - You can override the search restriction. Enter ‘all:’ and your search term to search the entire site. For example, enter the following into the search box at top right of the page to search the entire site for ‘technical writing’:

  ```plaintext
  all: technical writing
  ```

Using the search box in the left-hand panel:

- By default, the Documentation theme’s left-hand panel includes a search box. Enter your search term there, to restrict the search to the current space. Specifically, this will search only the pages that are children of the space’s home page.
- If your administrator has restricted the main search to the current space, there will not be a search box in
Hints and tips

Below are some hints that you may find useful when using the Documentation theme.

Where can I see a working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme’s table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page. Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

Cause 1: Your pages are not under the space’s home page. The most probable reason why your pages do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space’s home page. If your pages are above the home page in the page tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

- You can change the designated space home page in the space administration section.
- Or you can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the ‘Pages’ section of the space ‘Browse’ screen. See Moving a Page.

Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with Documentation theme bundled. If your existing Confluence installation already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar icon at top right, next to the search box. Click the icon again to restore the panel.

Can I change the default width of the left-hand navigation panel?

The Confluence user interface does not offer a way to change the default width of the left-hand navigation panel supplied by the Documentation theme. Users can change the width by dragging the middle bar, but the default width is not configurable. This post on Atlassian Answers gives a way to do it with CSS: Documentation Theme - Default Width (in px) of left panel.

Notes

- The Confluence default theme supplies a sidebar, which is different to the left-hand panel in the Documentation theme. For information about the sidebar, see Finding Content and Configuring a Sidebar.
- The Documentation theme supplies a Browse menu in the Confluence header, which gives access to the space administration and advanced options.

Viewing Page Information

The ‘information’ view for a page shows you various bits of useful information about the page.

To see the information view for a page:

1. View the page.
2. Choose Tools > Info to go to the ‘Information’ view for the page.

You will see the following information:
1. Page details: Title, author, date of creation, date of last modification and the tiny link of the page.
3. Labels: Any labels (tags) that have been applied to this page. See Working with Confluence Labels.
4. Page Permissions: Displays page-level security restrictions that apply to the page (if present). See Page Restrictions.
5. Hot Referrers: The external website pages which send the most viewers to the page. See Managing External Referrers.
6. Recent Changes: Links to the five most recent versions of the page along with the name of the editor and the date of modification. See Page History and Page Comparison Views. Choose View page history to see the page history view, all the versions of the page in reverse chronological order and allows you to compare versions or to restore a previous version.
7. Outgoing links: A summary of the links contained on this page, pointing to other pages on the Confluence site or to external websites.

Related pages:
- Working with Pages
- Confluence User’s Guide

Viewing Recently Visited Content
Confluence keeps track of pages you have recently visited in Confluence. You can access your recently viewed pages and navigate back to them using the Recently Viewed list.

To view the full list of recently viewed pages:
1. Choose your profile picture at top right of the screen, then choose Recently Viewed.
2. Choose the title of the page you wish to revisit.
To filter the list type part of a page title or user's name in the Filter field.

Your last ten recently viewed pages also appear when you select the 'Search' field anywhere in Confluence.

Related pages:
- Working with Pages
- Confluence User's Guide

Screenshot: Recently viewed content

Page History and Page Comparison Views

Confluence tracks the history of changes to each page by creating a new version of the page each time it is modified. You can view the changes between different versions, and roll back to a previous version if required.

Accessing the page history

To view the history of a page:

Go to the page and choose Tools > Page History.

You can choose a version number to view the content of that version.
On this page:

- Accessing the page history
- Viewing an older version of a page
- Restoring an older version of a page
- Deleting a specific version of a page
- Viewing the changes made to a page
- Comparing two versions of a page

Related pages:

- Viewing Page Information
- Working with Pages
- Tracking Updates
- Confluence User's Guide

Screenshot: Page history

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Changed By</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>CURRENT</td>
<td>Apr 26, 2013 13:53</td>
<td>Rach Admin [Administrator]: Fixed a typo</td>
<td>Restore this version · Delete</td>
</tr>
<tr>
<td>v. 3</td>
<td>Apr 26, 2013 13:53</td>
<td>Leah Admin</td>
<td>Restore this version · Delete</td>
</tr>
<tr>
<td>v. 2</td>
<td>Apr 26, 2013 13:52</td>
<td>Josh User: (Added note about changes)</td>
<td>Restore this version · Delete</td>
</tr>
<tr>
<td>v. 1</td>
<td>Apr 26, 2013 11:56</td>
<td>Rach Admin [Administrator]</td>
<td>Restore this version · Delete</td>
</tr>
</tbody>
</table>

Viewing an older version of a page

To view a specific version of a page:

1. Go to the page and choose Tools > Page History.
2. Choose a version number to view the contents of that version of the page. You will see a header like this, at the top of the old version of the page:

   ![Header]

If you want to send this page version to someone, copy and paste the URL from your browser. The link will look something like this: http://confluence.atlassian.com/pages/viewpage.action?pageId=12345.

When you are viewing a specific version of the page, the following functions are available:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>current version</td>
<td>View the latest version of the page.</td>
</tr>
<tr>
<td>Compare with Current</td>
<td>Compare the differences between the version of the page you are viewing and the current version.</td>
</tr>
</tbody>
</table>
Restoring an older version of a page

You can roll back the content of the page to a specific version.

To restore an older version of a page:

1. Go to the page and choose Tools > Page History.
2. Choose Restore this version beside the version you want to restore.
3. Change the default comment if necessary, and choose OK.

Notes

- All page history is retained. Restoring an older version creates a copy of that version. For example, if you restore version 39, Confluence will create a copy of version 39. This copy will become the new, current version.
- If you are viewing a specific version of a page, you can restore that version of the page by choosing Restore this Version at the top of the page.

Deleting a specific version of a page

Choose Delete next to a version, to remove that version. See Deleting a Page.

Viewing the changes made to a page

Using the page history view or the page information view, you can see the recent changes made to a page.

To view recent changes made to a page:

1. Choose Tools > Info to go to the 'Information' view for the page.
2. In the section titled 'Recent Changes' you will see the most recent versions of the page, along with the date of their modification and the name of the modifying author.
3. Choose View Changes beside the required version. The page comparison view is displayed, showing the differences between the selected and previous versions.

Comparing two versions of a page

To compare two versions of a page:

1. Go to the page and choose Tools > Page History.
2. Choose the versions you want to compare by selecting the check boxes beside them.
3. Choose Compare selected versions. The page comparison view is displayed, showing the differences between the selected versions.

Changes are highlighted in different colours, as shown in this table:

<table>
<thead>
<tr>
<th>Highlighted colour</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Added content</td>
</tr>
<tr>
<td>Red</td>
<td>Deleted content</td>
</tr>
<tr>
<td>Blue</td>
<td>Changed formatting</td>
</tr>
</tbody>
</table>

Screenshot: Comparing changes
More options on the comparison view

When a page comparison view is first displayed, all large sections of unchanged text are hidden and reduced to an ellipsis, like this: . . .

You can view page changes between versions which are adjacent to your current page comparison view. Click the link containing:

- << to view the page comparison with the earlier adjacent version
- >> to view the page comparison with the more recent adjacent version.

For example, if your page comparison view is between v. 30 and v. 34 of a page, you can view changes between:

- v. 29 and v. 30 by clicking << Changes from 29 to 30
- v. 34 and v. 35 by clicking Changes from 34 to 35 >>

Using a WebDAV Client to Work with Pages

You can access Confluence content via a WebDAV client, such as 'My Network Places' in Microsoft Windows. Provided that you have permission, you will be able to read and write to spaces, pages and attachments in Confluence. You will be asked to log in and the standard Confluence content access permissions will apply to the equivalent content available through the WebDAV client.

Please refer to the page on configuring and setting up a WebDAV client.

Working with Blog Posts

You can publish a blog post from any space in Confluence, provided you have permission. Blog posts may be announcements, journal entries, status reports, or any other timely information.

To view the blog posts within a space: Go to a page in the space and choose Blog in the sidebar.

Or, if you are using the Documentation theme, choose Browse > Blog at the top of the screen.

Confluence lists the latest blog posts. You can click through to earlier posts via the navigation area in the sidebar.

Creating and editing a blog post is just as easy as creating and editing any other page in Confluence. You can also let people know you care by liking a blog post.

Creating a blog post

To create a blog post, you need the 'Add Blog' permission. See Space Permissions, and Creating Content.

You can create attractive, engaging content in a blog post in the same way as in a page. See Creating Beautiful and Dynamic Pages.
On this page:
- Creating a blog post
- Editing a blog post
- Moving a blog post
- Deleting a blog post
- Exporting a blog post

Related pages:
- Subscribing to RSS Feeds within Confluence
- Managing Changes and Notifications and Tasks
- Blog Posts Macro
- Sharing Content
- Exporting Confluence Pages and Spaces to PDF
- Confluence User's Guide

Editing a blog post

To edit a blog post, you need the 'Add Blog' permission. See Space Permissions.

To edit a blog post:

1. Go to a page in the space and choose Blog in the sidebar.
   Or, if you are using the Documentation theme, choose Browse > Blog at the top of the screen. You will see the most recent blog posts within the space, and you can find earlier posts via the navigation area in the sidebar.
2. Go to the blog post and choose Edit.
3. Make changes to the blog post.
4. (optional) Add a comment, in the text box below the editing pane, to describe your changes.
5. Preview your changes if desired, and choose Publish.

Editing a blog post is similar to editing any other page in Confluence. However, there are a few things to keep in mind:

- You cannot change the date of an existing blog post. You can only backdate when adding a blog post.
- You cannot move a blog post to another space.
- A blog post has no parent.

Moving a blog post

If you create a blog post in the incorrect space, or want to reorganise your spaces, you can move an individual blog post to another space.

To move a blog post go to the post and choose Tools > Move and select the new destination space.

You will need the 'Delete blog' permission in the current space and 'Add blog' permission in the new (destination) space to do this.

Deleting a blog post

By default, when you delete a blog post in Confluence, this will remove all versions of the post. To do that, you need the 'Delete Blog' permission. See Space permissions. If someone has applied page restrictions to the blog post, the restrictions may prevent you from deleting the post too. Deleted blog posts are stored in the space's trash and can be recovered by a space administrator.

If you want to delete a specific version of a blog post, you need to be a space administrator. When you delete a version of a blog post, the version is not stored in the trash. The deletion of a version is therefore permanent and cannot be undone.

To delete all versions of a blog post:

Go to the page and choose Tools > Delete. Confirm the action as prompted.
Note: The 'Delete' option will only appear if you have permission to delete this page.

To delete just one version of a blog post:
1. Go to the page and choose **Tools > Page History**.
2. Choose **Delete** next to the version you want to delete, and confirm the action as prompted.

**Exporting a blog post**

You can export individual blog posts to PDF format. This is useful, for example, if you want to email an internal blog post to people outside your organisation.

See [Exporting Confluence Pages and Spaces to PDF](#) for more information on exporting blog pages to PDF.

**Working with Spaces**

In Confluence, content is organised into spaces. There are two main types of space:

- Site spaces, sometimes called ‘global’ spaces, are areas on your site where you can create content and collaborate with other users. For example, you might create a space for each team or project in your organisation.
- Personal spaces belong to specific users. You can keep your personal space private, or open it up for other users to view or edit. Personal spaces are listed in the People Directory.

**What is a Space?**

A space is an area within Confluence, containing your pages, blog posts and other content. You can think of each space as a sub-site, or mini-site, each with its own home page.

You can create a blank space or choose to use a space blueprint.

Each space:

- Has its own pages, blog posts, comments, and more.
- Has its own access control settings. You can set different levels of access for different spaces.
- Cannot be nested under another space, but can be grouped using space categories.
- Can be separately exported to PDF, HTML or XML. The XML export provides a way of backing up and restoring a space.

There is no limit to the number of site spaces you can create in Confluence.

**What is a Space Blueprint?**

Space Blueprints allow you to create common types of spaces, such as a team space or knowledge base, quickly and easily.

A space created using a space blueprint will have a customised homepage, sidebar and may contain page blueprints or sample content that is specific to that type of space.

When you create a space using a blueprint a wizard will prompt you to enter information to help set up your space. For example the Team Space blueprint asks for the members of your team, and displays them on the...
Viewing the spaces in a Confluence site

Confluence displays a list of spaces in the following locations:

- The **dashboard** displays a list of all the spaces that you have permission to see. You can make a space a **favourite**, or **categorise the space**, to get easy access to the content that is most relevant to you. See **Customising your Personal Dashboard**.
- The **space directory** displays a list of all the site and personal spaces that you have permission to see. You can filter the list of spaces. See **Viewing All Confluence Spaces**.
- The **people directory** displays a list of all Confluence users, including those who have personal spaces. See **Searching the People Directory**.

Example: Favourite spaces as shown on the dashboard

The screenshot below shows the area of the Confluence dashboard that displays the spaces that you have marked as favourite:

![Screen shot of Confluence dashboard showing favourite spaces](image)

Notes

A **space key** is a short, unique identifier for a space. For example, you might give your documentation space a key of "DOC". To find the key of an existing space, look at the Confluence URL for a page in the space. The standard Confluence URL has this format:

```
http://my.confluence.site.com/display/SPACEKEY/Page+Name
```

**Viewing All Confluence Spaces**

Quick guide to viewing spaces:

- The **dashboard** displays a list of all the spaces that you have permission to see. You can make a space a **favourite**, or **categorise the space**, to get easy access to the content that is most relevant to you. See **Customising your Personal Dashboard**.
- The **space directory** displays a list of all the site and personal spaces that you have permission to see. You can filter the list of spaces. See **Viewing All Confluence Spaces**.
- The **people directory** displays a list of all Confluence users, including those who have personal spaces. See **Searching the People Directory**.
Viewing spaces on the dashboard

The Confluence dashboard displays a list of spaces that you have permission to view. Remember to log in, so that you can see the complete list of spaces based on your username's permissions.

The Spaces tab displays all the global spaces on the site that you have permission to view, and the spaces you have marked as your favourites.

To see the spaces on the dashboard:

1. Choose the site logo at the top left of your Confluence screen.
2. Scroll down and choose the Spaces tab.

Screenshot: Viewing spaces on the dashboard

Viewing spaces in the space directory

The space directory displays a list of site and personal spaces that you have permission to view. Remember to log in, so that you can see the complete list of spaces based on your permissions.

To view all spaces:

1. Choose Spaces > Space directory on the header.
2. All the spaces that you have permission to view will appear.

If you have a large number of spaces in your site, you can filter the list.

To filter the list of spaces:
Enter part of the space name or description in the Filter field, or Choose a pre-defined filter or category.

Only those spaces that match your filter will appear.

The filters include:

- **All Spaces** – Shows all global and personal spaces. The list excludes spaces that you do not have permission to view and spaces that have been archived.
- **Site Spaces** – Excludes personal spaces.
- **Personal Spaces** – Shows only personal spaces.
- **Favourite Spaces** – Shows the spaces that you have marked as your favourites.
- **Archived Spaces** – Shows all global and personal spaces that have been archived, and that you have permission to view.
- **Categories** – Shows spaces that have been labelled with the selected space category. See Using Labels to Categorise Spaces.

**Screenshot: Viewing favourite spaces in the space directory**

Viewing personal spaces in the people directory

The people directory displays a list of Confluence users, including those who have personal spaces. See Searching the People Directory. It excludes spaces that have been archived.

**To see the personal spaces in the people directory:**

1. Choose **People** at the top of the screen.
2. Choose **People with Personal Spaces**.

**Screenshot: The people directory**
• If you do not log in, you will be treated as an ‘anonymous user’. Confluence will display only those spaces that anonymous users have permission to see.
• Permission to access a space is granted by a space administrator. See the overview of space permissions.
• You can use the Spaces List macro to display a list of spaces on a Confluence page.

Creating a Space

In Confluence pages and other content are stored in spaces. There are two main types of spaces - site spaces and personal spaces. Your Confluence site can contain many site spaces, and each user can have one personal space.

To create a site space you need the ‘Create Space’ global permission.

To create a personal space you need the ‘Personal Space’ global permission.

To create a space:

1. Choose Create Space on the dashboard or from the Spaces dropdo wn.
2. Choose the type of space you would like to create then choose Next.
3. Enter details of your space including Name, Space Key, and set any permissions - the wizard will prompt you.
4. Choose Create.

Once your new space has been created you will be taken to the space homepage, which will be customised depending on the type of space you selected.

You can now start creating content to your space.

Choosing a space key

The space key is the unique identifier for your space and is used in URLs and macros. Your space key must be unique, can contain any alphanumeric character (A-Z, a-z, 0-9), and be up to 255 characters long. Personal spaces use your username as the space key.

You cannot change the space key after your space has been created, so choose your space key carefully.

Space permissions

Spaces are created with a set of default permissions. The user who created a site space is automatically granted 'space admin' permissions for that space. They can then grant permissions to other users and groups. See Space Administrators and their Permissions for more information.

Note: System Administrators can edit the permissions of spaces in their Confluence site at any time.

Using space blueprints to create a space

Space blueprints help you create common types of spaces quickly and easily. Space blueprints vary widely, so here are some examples of the spaces you can create:

• Team space
  A great building block if you are using Confluence as an intranet or to manage teams. Team spaces highlight the members of the team, and grant permissions to those users accordingly.

• Knowledge Base space
  This space blueprint uses search and page labels to make content easier to find, right from the space homepage. It also contains two page blueprints for creating how-to and troubleshooting articles. The templates used in these page blueprints are completely customisable to meet your needs. The Knowledge Base space blueprint also integrates with JIRA Service Desk.

• Documentation space
  This space blueprint displays the full page tree in the sidebar and hides other sidebar features including blogs and shared links. The homepage uses search and page labels to make content easy to find. Add the 'featured' label to any page you want to highlight on the homepage. This space does
not include any page blueprints but you can create and promote templates for your documentation authors to use.

Notes:

- If you have set a specific theme (such as the Documentation or other third party theme) for your whole site, spaces will be created with that theme. You may not see some of space blueprint specific sidebar customisation if you are not using the default theme.
- Administrators can disable individual space blueprints - see Administering Site Templates.

**Setting Up your Personal Space**

Your personal space is a place where you can publish your own pages and blog posts. Once you have set up your personal space, Confluence users can reach it by clicking your name in the People Directory. You can get to your personal space by clicking your name at the top of the page and choosing 'Personal Space'.

Creating your personal space

To set up your personal space, you need the 'Personal Space' permission which is assigned by a Confluence administrator. See Giving People Access to Content and Global Permissions Overview.

To create your personal space:

1. Choose your profile picture at top right of the screen, then choose Add Personal Space.
2. Indicate whether your space should be private or not. A private space will be visible only to you. If you do not make it private, the space will have the default space permissions. Note that you can change these settings again later. You will have space administrator permissions on your space.
3. Choose Create.
4. The home page of your new space will appear. Your home page will contain any default space content as defined by your Confluence administrator. You can change this content at any time.

On this page:

- Creating your personal space
- Adding and changing content in your space
- Changing the look and feel of your space
- Granting access to your space
- Watching updates made in your space

Related pages:

- Configuring a Sidebar
- User Profile Overview
- Working with Spaces
- Confluence User's Guide

**Add your personal space**

Your personal space is your own private workspace within Confluence. You can optionally let other people view or contribute to it.

- Make this space private

Adding and changing content in your space
Now you can start adding pages to your personal space. You may also want to upload your photo.

Changing the look and feel of your space

If you like, you can apply a different theme to your personal space, or modify its colour scheme. You can also add and arrange links in the sidebar.

Granting access to your space

When you created the space, you set the option to make your space private, or to allow other people to view and contribute content to your space. You can change the permissions on your space at any time.

Watching updates made in your space

By default, Confluence assigns you as a watcher of your space. This means that you will receive an email notification each time someone adds or updates content in your space. You can stop watching the space (see Watching Pages, Spaces and Blog Posts) and change your notification settings at any time.

Administering a Space

This page gives an overview of the administration functions available in site and personal spaces. You need to be a space administrator to perform space administration functions.

Space administrators can also add and remove links in the space sidebar. See Configuring a Sidebar.

Administering a space

To view the space tools page:

1. Go to the space and choose Space tools > Permissions on the sidebar.
2. The 'Space Permissions' page displays.

The administration options are divided into the following categories. Some options may not be applicable for personal spaces.

- **Overview**
  - Space Details - see Editing Space Details
  - Space Labels - see Using Labels to Categorise Spaces
  - Delete Space - see Deleting a Space

- **Permissions**
  - Permissions - see Assigning Space Permissions
  - Restricted Pages - see Page Restrictions

- **Content Tools**
  - Templates - see Working with Templates
  - Orphaned Pages - see Managing Orphaned Pages
  - Undefined Pages - see Managing Undefined Pages
  - Attachments - see Viewing Attachment Details
  - Trash - see Purging Deleted Pages and Restoring a Deleted Page
  - Export - see Exporting Confluence Pages and Spaces to Other Formats
  - RSS Feeds - see Using pre-specified RSS feeds
  - Import - see Importing Pages from Disk. *Not available for personal spaces.*

- **Look and Feel**
  - Themes – see Applying a Theme to a Space
  - Colour Scheme – see Editing a Space’s Colour Scheme
  - Layout - see Customising Space Layouts
You can also customise the sidebar, including changing the space logo and adding shortcuts to other spaces - see Configuring a Sidebar for more information.

Administering a space that uses the Documentation theme

In this theme the standard Confluence sidebar is replaced by a page navigation sidebar. As a result the layout of the space administration options are slightly different.

To view the space admin page:

1. Go to the space you wish to manage.
2. Choose Browse > Space Admin at the top of the screen.
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
3. The 'Space Details' page displays.

For spaces using the Documentation theme, the administration options are divided into the following categories:

- **General**
  - Space Details – see Editing Space Details.
  - Space Labels – see Using Labels to Categorise Spaces.
  - Templates – see Working with Templates.
  - Delete Space – see Deleting a Space.
  - Trash – see Purging Deleted Pages and Restoring a Deleted Page.

- **Security**
  - Permissions – see Assigning Space Permissions.
  - Restricted Pages – see Page Restrictions.
  - Application Links – see Linking to Another Application.

- **Mail**
  - Mail Accounts – see Working with Mail Archives
  - Mailbox Import – see Importing Mail

- **Look and Feel**
  - Themes – see Applying a Theme to a Space.
  - Colour Scheme – see Editing a Space's Colour Scheme.
  - PDF Layout – see Customising Exports to PDF.
  - PDF Stylesheet – see Customising Exports to PDF.
  - Change Space Logo – see Changing a Space's Logo.

**Import**

- Import Pages from Disk – see Importing Pages from Disk.

**Editing Space Details**

To edit the details of a space you need to be a space administrator for the space.

To edit the details of a space:

1. Go to the space and choose Space tools on the sidebar.
   Note: The options available in 'Space tools' differ depending on your space permissions. All space tools options are available if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Overview > Edit Space Details
3. The 'Edit Space Details' page displays.

If your space uses the Documentation theme:
Choose **Browse > Space Admin** at the top of the screen.  
*Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).

2. The 'Edit Space Details' page displays.

On the 'Edit Space Details' page you can:

- Change the name of the space (you can also do this via the sidebar - see Configuring a Sidebar).
- Change the description of the space.
- Change the status of the space from 'Current' to 'Archived' or back again - see Archiving a Space.
- Select a new home page for the space. The home page is the default page that users see when they navigate to the space.  
*Note: If you set this field to blank (no selection) the default home page will be the 'Pages' page.

### Related pages:

- Configuring a Sidebar
- Working with Spaces
- Archiving a Space
- Confluence User's Guide

### Notes

- You cannot edit the space key or the space creator's name.
- The space fields do not accept wiki markup. Any wiki markup entered in these fields will be displayed as plain text.

### Deleting a Space

Deleting a space permanently removes the space and all of its contents. To delete a space you must be the space administrator for the space.  
*Note: Deleting a space is permanent. Always create an XML backup of the space before proceeding. Once you have deleted the space, there is no way to restore it unless you have made an XML space backup.

To delete a space:

1. Go to the space and choose **Space tools > Overview** on the sidebar.
2. Choose **Delete Space**.
3. Choose **OK**.

If your space is using the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.  
*Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **Delete Space** in the space administration options.
3. Choose **OK**.

### Related pages:

- Working with Spaces
- Archiving a Space
- Copying or Renaming a Space
- Confluence User's Guide

*Note: Users with System Administrator permission can also delete spaces, including personal spaces.

### Backing Up and Restoring a Space

Confluence can back up all the content, comments and attachments for a space. The process involves converting the data in the space into XML format. The end product is a zip file that contains XML file(s) that define the content of the space, and optionally a folder containing the attachments in the space. To transfer this data to another Confluence site, you can upload the zip file.

**Creating a space backup**

See **Exporting Confluence Pages and Spaces to XML**.

**Restoring (importing) a space backup**
See Restoring a Space.

Archiving a Space

You can archive a space, so that its content is less visible but still available on your Confluence site. You need to be a space administrator to archive a space. You can change a space's status from archived to current at any time.

The effect of archiving a space

If a space is archived:

- The pages and other content do not appear in the Confluence quick navigation aid, which drops down when you enter text in the search box.
- By default, the pages and other content do not appear in the Confluence search results. If a Confluence site contains any archived spaces, the search screen will provide an option to include them in the search results.
- The space and its pages do not appear on the dashboard.
- Updates to the space's content do not appear in activity streams, such as the recent updates section of the dashboard.
- The space does not appear in space-selection dropdown menus. Similarly, its pages and other content do not appear in any dropdown menus in the Confluence user interface.
- In the space directory, the archived space will no longer appear in the general space lists. Archived spaces will appear on the 'archived spaces' tab. They will also appear on the category tabs, as determined by their labels.

These functions remain available for archived spaces:

- People can view the content as usual, by following a link or typing in a URL belonging to the archived space.
- People can edit the content as usual, as determined by the space permissions.
- RSS feeds, watches and notifications remain active.

On this page:

- The effect of archiving a space
- Archiving a space
- Notes

Related pages:

- Working with Spaces
- Deleting a Space
- Confluence User's Guide

Archiving a space

To archive a space:

1. Go to the space and choose Space tools > Overview on the sidebar.
2. Choose Edit Space Details.
3. Select Archived in the Status dropdown menu.
4. Choose Save.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. The 'Edit Space Details' page displays. Select Archived in the Status dropdown menu.
3. Choose Save.

Notes

Archiving a space has no effect on search results of external search engines. For example, the space will still appear in Google search results.

Screenshot: An archived space
Viewing Space Activity

Space activity information is **disabled by default**. See notes below.

If enabled, the space activity screen displays statistics on the activity in each space. These include:

- How many pages and blog posts have been viewed, added or updated over a given period.
- Which content is the most popular (most frequently viewed).
- Which content is the most active (most frequently edited).
- Which people are the most active contributors/editors of content.

The ‘Activity’ tab will not be visible unless the Confluence Usage Stats plugin is enabled. See notes below.

To view the activity in a space:

1. Choose **Space Tools** in the space sidebar.
2. Choose **Activity**.

Confluence will show a graphic display of the number of pages and blog posts that have been viewed, added and edited, showing trends over a period of time.

In addition to the graphical representation of Views and Edits, the top ten most popular and most active pages and/or blog posts will be listed, with a link to each.
### Viewing Recently Updated Content

The 'Recently Updated' view is a useful way of keeping track of the changes being made in a space. It displays links to the most recently added or modified content within the space including pages, blog posts, mail messages and comments.

Are you looking for a way to display a list of recently updated pages on a page? Try the **Recently Updated Macro**.

**To view the recently updated content in a space:**

1. Go to a page in the space and choose **Pages** in the sidebar.
   Or, if you are using the Documentation theme, choose **Browse > Pages** at the top of the screen.
2. Choose **Recently Updated**. A list of the most recently added or modified content in the space is displayed. Choose a link to open the corresponding document.

**Related pages:**
- Recently Updated Macro
- Viewing All Pages in a Space
- Viewing Space Activity
- Confluence User's Guide

### Working with Mail Archives

Confluence allows you to collect and archive mail within each space. This is useful for storing the email messages that relate to a particular project – you can put them in the same Confluence space as the content for that project.

You can download mail from one or more POP or IMAP accounts. You can also import mail from mbox files either on your local system or on the Confluence server.

You need space administration permissions to manage the mail archives. See **Space Permissions Overview**.

---

Notes

- To view Space Activity the **Confluence Usage Stats** system plugin must be enabled. This plugin is known to cause performance problems on large installations and in OnDemand, and is disabled by default. System administrators can enable this plugin (go to add-ons, select System add-ons and search for Confluence Usage Stats).
- The plugin collects data only when it is activated.
- If your Confluence site is clustered, the space activity information will not be available.
- Page hits are not unique - the graph on the Space Activity screen includes all page hits, including multiple visits by the same user.

---

**Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose G.**
To see archived mail:

- Go to a space and choose **Space Tools > Integration > Mail**
  - Or, if your space uses the Documentation theme, choose **Browse > Mail** at the top of the screen.
- Choose a message to see its contents, or choose **Next, Previous** and other options to navigate around the mail archives.

Managing mail archives:

- **Adding a Mail Account**
- **Deleting Mail**
- **Fetching Mail**
- **Importing Mail**
- **Managing Mail Accounts**

**Related pages:**
- Working with Spaces
- Confluence User’s Guide

**Notes**

- Only **site spaces** can store mail archives. Personal spaces cannot. See **Working with Spaces** for an explanation of site spaces and personal spaces.
- You can also search the mail messages and their attachments. See **Searching Confluence**.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose **General Configuration > Manage Add-ons**. Then choose **System** in the drop down, and enable the **Confluence Mail Archiving Plugin**.

**Adding a Mail Account**

When you add a mail account, you are configuring Confluence to download mail from that account and archive the mail within the space.

You need space administration permissions to add a mail account. See **Space Permissions Overview**.

**Note:** Confluence will remove email messages from an email account when it transfers them to the mail
archive. You must therefore configure Confluence to poll a clone email account rather than the actual account. For example, to archive the actual account sales@company.com to your Confluence Sales space, you must first create a clone account such as conf-sales@company.com that contains the same email content.

**Step 1. Create a clone email account on the mail server**

1. Add a new email account on the mail server with the clone email address.
2. Copy all existing email messages from the actual account to the clone account.
3. Set up the actual account to bcc sent email messages to the clone account.
4. Set up the actual account to forward received email messages to the clone account.

**Related pages:**
- Working with Mail Archives
- Managing Mail Accounts
- How Do I Check Which Spaces Have Email Accounts?
- How Do I Disable Automatic Mail Polling?
- Confluence User's Guide

⚠️ The information on this page does not apply to Confluence OnDemand.

**Step 2. Configure Confluence to archive the clone account**

1. Go to the 'Mail Accounts' view:
   - Go to the space and choose Space tools > Integrations on the sidebar. Choose Mail Accounts.
   - If your space uses the Documentation theme:
     Choose Browse > Space Admin at the top of the screen.
   *Note:* The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).

   Choose Integration > Mail Accounts.

2. Choose Add mail account.
3. Enter configuration details for the account.
   - **Account Name:** Enter a name for this account by which it will be known in Confluence.
   - **Description:** Provide a description for this account (optional).
   - **Protocol:** Choose from POP, IMAP, POPS or IMAPS.
   - **Hostname:** Enter the host name of the mail server on which the account resides.
   - **Port:** Do not edit this field. The mail server's port number will be displayed by default.
   - **Username:** Enter a username that has permission to retrieve mail from this account.
   - **Password:** Enter the account's password.

4. Choose Test Connection to verify the details.
5. Choose Create to add the account to Confluence.

**Notes**

- Only site spaces can store mail archives. Personal spaces cannot. See Working with Spaces for an explanation of site spaces and personal spaces.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose General Configuration > Manage Add-ons. Then choose System in the drop down, and enable the Confluence Mail Archiving Plugin.

**Deleting Mail**
To delete mail from a space, you need 'Delete Mail' permission. See Space Permissions.

Only a space administrator can delete all email messages for the space simultaneously.

To delete mail from a space:

1. Go to a space and choose Space Tools > Integration > Mail
   Or, if your space uses the Documentation theme, choose Browse > Mail at the top of the screen. A list of
email messages in the space is displayed in reverse chronological order.

2. Delete an individual email message by choosing the trash 🗑️ icon beside it.
3. If you are a space administrator, you can delete all email messages within a space at once by choosing **Delete All**.

Space administrators can restore deleted email messages, provided they were deleted individually.

**Note:** Email messages deleted using the 'Delete All' option cannot be restored.

**To restore mail that has been deleted:**

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Trash**.
3. You will see a list of email messages and other content deleted from the space. Choose **Restore** beside the email message you want to restore.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   **Note:** The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **Trash** in the left-hand panel.
3. You will see a list of email messages and other content deleted from the space. Choose **Restore** beside the email message you want to restore.

**Related pages:**
- Working with Mail Archives
- Confluence User's Guide

⚠️ The information on this page does not apply to Confluence OnDemand.

**Fetching Mail**

Confluence fetches mail from the server once every 30 minutes. If necessary, you can manually retrieve new mail from the configured mail accounts.

You need to be a space administrator to manually retrieve mail. See **Space Permissions**.

**To manually retrieve mail:**

1. Go to a space and choose **Space Tools > Integration > Mail**
   Or, if your space uses the Documentation theme, choose **Browse > Mail** at the top of the screen.
2. Choose **Fetch new mail**. Any new messages will be displayed in order of most recent first.

**Notes**

- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose **General Configuration > Manage Add-ons**. Then choose **System** in the drop down, and enable the **Confluence Mail Archiving Plugin**.
- Once mail is fetched, it will be removed from the server.

**Related pages:**
- Adding a Mail Account
- Working with Mail Archives
- How Do I Disable Automatic Mail Polling?
- Confluence User's Guide

⚠️ The information on this page does not apply to Confluence OnDemand.

**Importing Mail**

Confluence allows you to import mail from mbox files located either on your local system or in a specified
location on the Confluence server. Confluence will store the imported email messages in the space's mail archive.

You need to be a space administrator to import mail for a space. See Space Permissions.

NB: You may need to enable the Confluence Mail Archiving Plugin as it is disabled by default.

To import mail from an mbox file:

1. Go to the space and choose Space tools > Integrations on the sidebar.
2. Choose Mailbox Import.
   - To import from a location on your file system: Browse to the location of the mbox file, select the file and then choose Import.
   - To import from the Confluence server: Enter the location of the mbox file on the server, then choose Import.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Mailbox Import in the space administration options.
   - To import from a location on your file system: Browse to the location of the mbox file, select the file and then choose Import.
   - To import from the Confluence server: Enter the location of the mbox file on the server, then choose Import.

Related pages:
- Working with Mail Archives
- Adding a Mail Account
- Confluence User's Guide

Notes

- Only site spaces can store mail archives. Personal spaces cannot. See Working with Spaces for an explanation of site spaces and personal spaces.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose General Configuration > Manage Add-ons. Then choose System in the drop down, and enable the Confluence Mail Archiving Plugin.
- For security reasons mail can only be imported from a specified location in the Confluence server’s file system. We recommend administrators create a folder in their Confluence home directory, add the system property confluence.mbox.directory and specify the location for mailboxes to be imported from. Mail cannot be imported from the server until this system property is set. See Configuring System Properties.

Managing Mail Accounts

You need to be a space administrator to manage mail accounts for a space. See Space Permissions.

Confluence will import mail from these POP/IMAP mail accounts into the space's mail archive.

To manage mail accounts:

1. Go to the 'Mail Accounts' view:
   - Go to the space and choose Space tools > Integrations on the sidebar.
     Choose Mail Accounts.
   - If your space uses the Documentation theme:
     Choose Browse > Space Admin at the top of the screen.
     Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
     Choose Integration > Mail Accounts.
2. Add an account if required. See Adding a Mail Account.
3. For each of the existing mail accounts listed, you can:
   - **Edit**: Change the configuration settings for the mail account.
   - **Remove**: Remove the account permanently.
   - **Disable/Enable**: Temporarily disable the account, or enable a disabled account.

Related pages:
- Working with Mail Archives
- Importing Mail
- Confluence User's Guide

⚠️ The information on this page does not apply to Confluence OnDemand.

Notes

Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin.

To activate mail archiving features in Confluence, enable the plugin — choose 🛠️ > General Configuration > Manage Add-ons. Then choose System in the drop down, and enable the Confluence Mail Archiving Plugin.

### Working with Confluence Labels

Labels are key words or tags that you can add to pages, blog posts, attachments and spaces. You can define your own labels and use them to categorise, identify or bookmark content in Confluence.

For example, you could assign the label 'accounting' to all accounts-related pages on the site. You can then browse all pages with that label in a single space or across the site, or display a list of pages with that label. You can search based on the label, or use it to filter items when you subscribe to a Confluence RSS feed.

Because labels are user-defined, you can add any word that helps you identify the content in the site.

You can add or remove labels without affecting the page content.

#### Content labels

You can add labels to pages, blog posts and attachments. Any user with permission to view the page can also view its labels. See Adding Labels.

#### Space categories

You can also apply labels to spaces and use them to categorise your spaces. These are known as space categories. See Using Labels to Categorise Spaces.

On this page:
- Content labels
- Space categories
- Advantages of labels
- Using labels
- Notes

Related pages:
- Using Label Macros to Categorise Wiki Content
- Viewing Labels and Labelled Content
- Using Labels in the Search
- Using Labels to Categorise Spaces
- Using the RSS Feed Builder
- Confluence User's Guide

Advantages of labels

Here are some of the advantages of using labels:

- Labels are user-defined which means that you decide what information is relevant to you and how you are going to label it.
You can group pages and spaces without having to restructure the site. Labels are easy to add and edit, and do not affect the content of the page. You can add as many labels as you like to a page or space.

Using labels
- Adding Labels
- Using Labels to Categorise Spaces
- Removing Labels
- Using Label Macros to Categorise Wiki Content
- Viewing Labels and Labelled Content
- Viewing Personal Labels

Notes

Note: Personal labels are deprecated: Earlier versions of Confluence recognised a special type of label called a 'personal' label. A personal label starts with 'my:' and is only visible to the user who created it. We are removing personal labels from Confluence, as announced in the Confluence 4.1 Upgrade Notes. The functionality for personal labels is still in Confluence, but we recommend that you stop using them. In a future release, we plan to remove the functionality altogether.

Adding Labels

Labels are key words or tags that you can add to pages, blog posts, attachments and spaces. You can define your own labels and use them to categorise, identify or bookmark content.

Labelling a page or blog post

Any user with permission to edit a page can add a label to a page.

To add a label to a page or blog post:

1. Go to the page. If the page already has labels, these will be listed at the bottom of the page, below the page content.
2. Choose the edit icon beside the list of labels, or press L on your keyboard.
3. Type in a new label. Existing labels are suggested as you type.
4. Choose Add.

On this page:
- Labelling a page or blog post
- Labelling an attachment
- Notes

Related pages:
- Removing Labels
- Viewing Labels and Labelled Content
- Using Label Macros to Categorise Wiki Content
- Using Labels to Categorise Spaces
- Confluence User's Guide

Screenshot: Labels as they are displayed on a page

Screenshot: Adding a label to a page or blog post
Labelling an attachment

If you have permission to view or edit the page that contains the attachment, you can add a label to the attachment.

To add a label to an attachment:

1. Go to the page that contains the attachment. Choose Tools > Attachments.
2. Alternatively, go to the attachments view of the space:
   - Go to the space and choose Space tools > Content Tools on the sidebar.
   - Choose Attachments.
3. You will see a list of attachments, with columns for attachment name and other details. If the attachment already has labels, these will be listed in the Labels column.
4. Choose the edit icon beside the list of labels.
5. Type in a new label. Existing labels are suggested as you type.
6. Choose Add.

You can also add labels in a list of attachments displayed by the Attachments macro, by choosing the edit icon beside each label.

Screenshot 2: Adding a label to an attachment
Notes

- **Note: Personal labels are deprecated.** Earlier versions of Confluence recognised a special type of label called a 'personal' label. A personal label starts with 'my:' and is only visible to the user who created it. We are removing personal labels from Confluence, as announced in the Confluence 4.1 Upgrade Notes. The functionality for personal labels is still in Confluence, but we recommend that you stop using them. In a future release, we plan to remove the functionality altogether.
- If you add a label to a template, that label will be copied to the page when someone adds a page based on that template. See Adding a Template.

**Using Labels to Categorise Spaces**

A **space category** is a label that you can apply to a whole space for the purpose of categorising your spaces in the space directory, and in the recent activity area of the dashboard.

You need to be a space administrator to add space categories.

**Using space categories**

Here is an example of using space categories. Let's assume that you have one or more spaces that your Sales team may be interested in. You can use the category 'sales' to group those spaces together.

1. First add the 'sales' category to the relevant spaces, as described below.
2. Then, in the space directory, you can click the relevant tab to see only the spaces with the chosen label. See Viewing All Confluence Spaces.
3. And, you can see updated content in those spaces by choosing the 'sales' category under the Space Categories tab in the recent activity area of the dashboard. See Customising your Personal Dashboard.

**On this page:**
- Using space categories
- Categorising a space
- Removing a space from a category
- Removing an entire space category
- Notes

**Related pages:**
- Working with Confluence Labels
- Viewing All Confluence Spaces
- Confluence User's Guide

**Categorising a space**

When you categorise a space, you add a 'space category' to the space. A category does not exist if there are no spaces labelled with that category.

**To add a space category to a space:**

1. Go to the space and choose Space tools > Overview on the sidebar.
2. Choose Space Categories: Edit.
3. Under 'Space Categories', enter your category name and choose Add.
   Alternatively, choose a category in the list of 'Suggested Space Categories'
4. Choose Done.

If your space is using the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   *Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).*
2. Choose Space Labels in the space administration options.
3. Under 'Space Categories', enter your category name and choose Add.
   Alternatively, choose a category in the list of 'Suggested Space Categories'.
4. Choose Done.
Removing a space from a category

Removing a space from a category is the same as removing the category from the space.

To remove a space category from a space:

1. Go to the space and choose **Space tools > Overview** on the sidebar.
2. Choose Space Categories: **Edit**.
3. Choose the x next to the space category.

If you are using the Documentation theme:

1. Go to the space and choose **Space tools** on the sidebar.
   
   **Note:** The options available in ‘Space tools’ differ depending on your space permissions. All space tools options are available if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **Space Labels** in the space administration options.
3. Choose the x next to the space category.

Removing an entire space category

To remove an entire space category from Confluence, just remove that category from all spaces, as described above. A category cannot exist if there are no spaces labelled with that category. The space category will disappear from the dashboard and space directory.

To remove an entire space category from Confluence:

1. Choose **Spaces > Space directory** on the header.
2. Choose the space category that you want to remove.
3. You will see a list of all spaces in that category. Choose the spaces one by one, and remove the category from each space, as described above.

**Screenshot: Space categories**

![Space Categories](image)

**Space Categories**

Space Categories will appear inside the categories tab on your dashboard and as tabs in the space directory. They can be used to group together related spaces.

![Labels](image)

**Labels**

confluence \[x\] development \[x\]

Add

Notes

The ability to add space labels has been removed in Confluence 5.0 in order to simplify the way labels are used in spaces. Existing space labels will be preserved, but you will be unable to add new space labels. Space categories are unaffected by this change.

**Removing Labels**

Labels are key words or tags that you can add to pages, blog posts and attachments. You can define your own labels and use them to categorise, identify or bookmark content in Confluence. You can see the existing labels, and the pages which contain the labels, by viewing labels and labelled content.

Removing labels in Confluence

**To remove a label from a page or blog post:**

1. Go to the page that contains the label. You will see the labels at the bottom of the page below the page
content.

2. Choose the edit icon beside the list of labels, or press L on your keyboard.

3. In the 'Labels' dialog, choose the X next to a label to remove that label.

4. Choose Close.

To remove a label from an attachment:

1. Go to the page that contains the attachment. Choose Tools > Attachments.

2. Alternatively, go to the attachments view of the space:
   - Go to the space and choose Space tools > Content Tools on the sidebar.
   - Choose Attachments.

3. You will see a list of attachments, with columns for the attachment name and other details. If the attachment already has labels, these will be listed in the Labels column.

4. Choose the edit icon beside the list of labels.

5. In the 'Labels' dialog, choose the X next to a label to remove that label.

6. Choose Close.

When you have removed the label from all content, the label will disappear from the labels view in the space too.

Notes

- **Deleted pages containing labels**: If you have deleted pages that contain a label, you may need to purge the deleted pages from the space's trash to ensure that the label disappears too.

- **Bulk removal of labels**: There is no way to remove a number of labels at once, via the Confluence user interface. Instead, we suggest that you use the Confluence Command Line Interface. See the 'removeLabels' action described in the CLI documentation. For an introduction to the CLI, see this blog post: Confluence CLI for bulk actions like deleting or publishing pages.

### Using Label Macros to Categorise Wiki Content

Using labels, you can categorise pages and refer to content across multiple categories, pages and even spaces.

**Example**

For the purpose of this example, imagine we have a space with pages of content on various types of vehicles. Pages are shown in bold text, while the labels are in blue.

- **Cars** vehicle-type
  - Toyota Prius vehicle car
  - Honda Civic vehicle car
  - Porsche Carrera vehicle car

- **Motorbikes** vehicle-type
  - Harley Davidson Sportster vehicle motorbike
  - Suzuki GSX-R vehicle motorbike

This page hierarchy can then be categorised using labels, with pages referenced using the Content by Label Macro.

<table>
<thead>
<tr>
<th>If you want to list...</th>
<th>You would use this label:</th>
<th>These would be the pages that you would get:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vehicle types</td>
<td>vehicle-type</td>
<td>Cars, Motorbikes</td>
</tr>
</tbody>
</table>
A few ways of viewing labels and labelled content. The focus of this page is on labels that are visible to everyone. You may also be interested in viewing personal labels.

Finding the labels view

Global labels are visible to all users with 'view' permission on the page, and personal labels are visible only to the person who added them.

- Any page or blog post that has labels will have them listed together in a block at the bottom of the page.
- You will also see labels in the 'Attachments' view or in a listing of attachments provided by the Attachments macro. (See Displaying a List of Attachments.)

To find the labels view by choosing a label:

If you are in a page that has labels, choose a label.

### Label macros

#### Navmap macro

The Navigation Map macro renders the list of pages associated with a specified label as a navigation map.

#### Related Labels macro

The Related Labels macro lists labels commonly associated with the current page's labels.

#### Content by Label macro

The Content by Label macro displays a list of content marked with specified labels.

#### Content Report Table macro

The Content Report Table macro displays a set of pages and blog posts in tabular format, based on the specified labels.

#### Labels List macro

The Labels List macro lists all labels of a space, grouped alphabetically.

#### Recently Used Labels macro

The Recently Used Labels macro lists labels most recently used in a specified scope - global (site), space, or personal.

#### Popular Labels macro

The Popular Labels macro displays popular labels in a list or in a heatmap (also called a cloud).

### Viewing Labels and Labelled Content

Labels are key words or tags that you can add to pages, blog posts, attachments and spaces. You can define your own labels and use them to categorise, identify or bookmark content in Confluence. This page describes a few ways of viewing labels and labelled content. The focus of this page is on labels that are visible to everyone. You may also be interested in viewing personal labels.

<table>
<thead>
<tr>
<th>All vehicles</th>
<th>vehicle</th>
<th>Toyota Prius, Honda Civic, Porsche Carrera, Harley Davidson Sportster, Suzuki GSX-R</th>
</tr>
</thead>
<tbody>
<tr>
<td>All cars</td>
<td>car</td>
<td>Toyota Prius, Honda Civic, Porsche Carrera</td>
</tr>
</tbody>
</table>

Related pages:

- Working with Confluence Labels
- Working with Macros
- Confluence User's Guide
• If it is a **personal** label (starts with 'my:') you will go to the personal labels page in your user profile. See [Viewing Personal Labels](#).
• If it is a global label, you will go to the 'Labels' tab of the space. Choose **Popular Labels** or **All Labels** to see all labels in the space.

![Screenshot: Labels as they are displayed on a page](#)

**To find the labels view via URL:**

Visit the following URL:

<MY.CONFLUENCE.SITE>/labels/listlabels-alphaview.action?key=MYSPACEKEY

For example: https://confluence.atlassian.com/labels/listlabels-alphaview.action?key=DOC

**To find the labels view from the menu (Documentation theme only):**

If the space is using the Documentation theme, you can access the labels view directly via the menu:

• Go to a page in the space and choose **Browse > Labels**.
• Choose **Popular Labels** or **All Labels** to see all labels in the space.

**On this page:**

- Finding the labels view
- Using the labels view
- Searching for labels
- Navigating pages by URL and label

**Related pages:**

- Viewing Personal Labels
- Searching Confluence
- Confluence User's Guide

Using the labels view

The labels view in a space offers the following options:

• **Popular Labels**: Choose this option to see a list of the most frequently used labels in that space. From here, you can also view the most popular labels across the site. The bigger the font size, the more popular the label.

• **All Labels**: View all labels in the space. From this view, you can choose a link to view an alphabetical listing of all labels across the site. Choosing a label will list all content in the space with that label. It will also display any related labels if they exist. **Related labels** are labels that frequently appear on pages together. For example, if pages labelled with 'sales' also tend to have the label 'marketing', these will be displayed as related labels.

• **See content from all spaces**: Expand the list of labels to include pages and other labelled content from all spaces.

![Screenshot: The labels view, showing all 'logo' labels](#)
Searching for labels

Use the 'labelText:' prefix to search specifically for content that has a specific label. The table below gives examples of search terms that you can enter into Confluence's search box, and the search results that you can expect.

<table>
<thead>
<tr>
<th>Searching for ...</th>
<th>Returns content that ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>recipe labelText:chocolate</td>
<td>contains the word 'recipe' or has the label 'chocolate'</td>
</tr>
<tr>
<td>recipe AND labelText:chocolate</td>
<td>contains the word 'recipe' and has the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake OR labelText:chocolate</td>
<td>has the label 'cake' or the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake AND labelText:chocolate</td>
<td>has both labels 'cake' and 'chocolate'</td>
</tr>
</tbody>
</table>

The 'labelText:' prefix is an example of a search field. See more about Confluence Search Fields.

Navigating pages by URL and label

This section describes how to move around your Confluence pages by adding and subtracting labels from the list of labels that you want to match. You can search for matching labels by entering a URL. You can also add and subtract labels from the search.

To search labelled pages by typing a URL:

1. Open a new web browser window.
2. In the address bar of your web browser, type an URL such as:
   
   http://CONFLUENCE_HOSTNAME/label/foo+bar

3. Press Enter.
4. The 'View Labels' page will load, showing search results for pages with the labels 'foo' and 'bar'.

Adding a label to your results:

- Choose a label from the Related Labels list (at the top left).
- A new page loads, showing pages that contain all of the labels selected so far. You can continue to add labels to the results in this way.
Subtracting a label from your search results:

When two labels are in use, links to subtract a label from the search appear at the end of the labels list. These are easily identified because these links have a preceding minus sign, like this:

- education

Viewing Personal Labels

Any page that has labels (global or personal) will have them listed at the bottom of the page. Personal labels start with 'my:', and are only visible to the user that created them.

Note: Personal labels are deprecated. The functionality for personal labels is still in Confluence, but we recommend that you stop using them. In a future release, we plan to remove the functionality altogether.

To view your personal labels:

- If you are on a page that has personal labels, click one of those labels to get to the screen showing all your personal labels.
- Alternatively, visit the URL: `<your Confluence site>/users/viewmylabels.action`. For example: `http://confluence.atlassian.com/users/viewmylabels.action`

You will see a list of your personal labels along with the pages that contain the label.

Related pages:
- Adding Labels
- Viewing Labels and Labelled Content
- Confluence User’s Guide

Working with Favourites

You can mark pages and spaces as favourites and then access them quickly from the Confluence dashboard and from your user profile.

Adding favourites

To add a page as a favourite:

1. Go to the page.
2. Choose Tools > Favourite.
   The menu item will change to ‘Remove Favourite’ to indicate the page is a favourite.

To add a space as a favourite:

1. Choose Spaces > Space directory on the header.
2. Choose the star icon next to the space name in the list of spaces.
   The star icon will change colour to indicate that you have added this space as a favourite.

To add someone's personal space as a favourite:

This option is only available for personal spaces. You cannot mark a person's profile as favourite, so this option is not available if the person has not yet created a personal space.

1. Choose Spaces > Space directory on the header.
2. Choose Personal Spaces.
3. Choose the star icon next to the space name in the list of spaces.
   The star icon will change colour to indicate that you have added this space as a favourite.
Removing favourites

To remove a page as a favourite:

1. Go to the page.
2. Choose Tools > Remove Favourite.
   This will change to ‘Favourite’ to indicate that you have removed this page from your favourites.

To remove a space as a favourite:

1. Go to the dashboard or choose Spaces in the header.
2. Choose the star icon beside the space in the list of spaces.
   The star icon will change colour to indicate that you have removed this space as a favourite.

To remove a personal space as a favourite:

1. Choose Spaces in the header.
2. Choose Personal Spaces.
3. Choose the star icon beside the space in the list of personal spaces.
   The star icon will change colour to indicate that you have removed this space as a favourite.

Viewing favourites

You can see your favourite pages via your user profile and on the dashboard.

To view your favourites via your profile:

1. Log in to Confluence, if you have not already done so.
2. Choose your profile picture at top right of the screen, then choose Favourites.

Screenshot: Viewing your favourites in your profile

Viewing your favourites via the dashboard
On the dashboard, you can see:

- your favourite spaces on the **Spaces** tab.
- your most recently added favourite pages on the **Pages** tab.

Recently updated content in your favourite spaces will be listed on the **Favourite Spaces** tab on the dashboard.

Screenshot: Viewing your favourites on the dashboard

![Favourite Spaces](image)

**Working with Attachments**

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files.

Attachments are useful when you want to share information that exists in another file format. You can attach files to any page or blog post, provided you have permission to do so.

When a page you are viewing contains attachments, a small paperclip icon appears next to the breadcrumbs. Clicking the paperclip icon will take you to the 'Attachments' view, where you will see the full list of attachments.

A quick guide to attachments

Choose **Tools > Attachments** to view and attach files to a Confluence page. (See **Attaching Files to a Page**.) If you attach a file with the same name as an existing attachment, Confluence will create a new version of the existing attachment.

Once you have attached the relevant files, you can display attached images and multimedia content on the page. If the attachment is an Office document, use the **View File macro** to display the content of the document on the Confluence page. If you have an Office application installed, you will also be able to launch your Office editor from within Confluence. See **Displaying Office Files in Confluence** and **Working with the Office Connector**.

Your page can display a list of attachments – these may be the files that are attached to the page or to any page in the space. You can also display a link to an attachment. When a user clicks the link, the attachment will open, provided that the user has the software application needed to open the attachment.

You can **label an attachment**, and then **use labels to categorise your content**.

---

**On this page:**
- A quick guide to attachments
- Working with attachments
- Notes
Related pages:
- Configuring Attachment Size
- Confluence User’s Guide
- Configuring your Attachment Storage

Working with attachments
- Using Drag-and-Drop in Confluence
- Attaching Files to a Page
- Attachment Versions
- Deleting an Attachment
- Displaying a List of Attachments
- Downloading Attachments
- Editing Attachment Properties
- Embedding Multimedia Content
- Embedding PowerPoint Presentations in a Page
- Moving an Attachment
- Viewing Attachment Details

Notes
If you want an attachment to be displayed on more than one page, you may wish to consider creating a special page to hold such attachments. This special page could be part of an ‘inclusions library’.

Using Drag-and-Drop in Confluence
This page describes the drag-and-drop functionality in Confluence, and the browser configurations needed to support that functionality.

Overview of the drag-and-drop features
Confluence supports these forms of drag-and-drop:
- **Drag-and-drop within the editor.** Working inside the editor panel, you can drag an image or a macro and drop it into a different location on the page.
- **Drag-and-drop for external images and files.** You can drag a file from a location outside Confluence, and drop it directly into the editor. For example, try it with images, video files, audio files, Office documents, and PDF files. The contents of the file will be embedded into the page or blog post.

Drag-and-drop within the editor
Working within the editor panel, you can drag an image or a macro from one location on the page and drop it into a different location on the page. Hover your cursor over the image or the macro placeholder. The cursor changes to a drag-and-drop icon and you can click the image or macro and drag it to a new location.

If you want to abandon the drag-and-drop action, press Escape. The image/macro will return to its original position.

**Requirements for internal drag-and-drop**
For the drag-and-drop of images and macros in the editor, Confluence supports the following browsers: Chrome, Firefox, and Internet Explorer 9. (Drag and drop in the editor does not work in Internet Explorer 8.)
Drag-and-drop for external images and files

You can drag files from your computer or file system onto your browser and attach them to your Confluence pages or blog posts. You can drag and drop:

- multiple files at once.
- image, multimedia and PDF files, and Office documents.

When you drag and drop files onto the different Confluence views, you get the following results:

<table>
<thead>
<tr>
<th>Confluence View</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachments</td>
<td>Files are attached</td>
</tr>
<tr>
<td>Page</td>
<td>Files are attached</td>
</tr>
<tr>
<td>Edit</td>
<td>Files are attached, and embedded at the cursor position</td>
</tr>
</tbody>
</table>

**Requirements for external drag-and-drop**

- For dragging files from your computer or file system onto your browser, your browser must support the drag-and-drop functionality of HTML5. Browsers such as Firefox 3.5, Safari 4 and Internet Explorer 9 offer limited HTML5 functionality and don't support drag-and-drop.

**Note about supported web browsers:** Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. Check the Supported Platforms page to find the list of supported web browsers and browser versions on this page.

- Some older Confluence themes do not support Confluence's drag-and-drop feature.

  - **Supported themes:** Confluence Default theme, Documentation theme.
  - **Themes that are not supported:** Left Navigation theme, Clickr theme. You cannot drag and drop attachments into spaces that use these themes.

**Disabling drag-and-drop for external files**

- If you wish to disable the drag-and-drop feature, you can disable the entire Confluence Drag and Drop Plugin. See Disabling and enabling add-ons.
- You can also disable the drop zone that appears on the 'Attachments' view or the image dialog box, by disabling the View Attachments Drop Zone or Image Dialog Drop Zone modules of the above plugin. This will remove these drop zones while retaining Confluence's drag-and-drop functionality.

**Attaching Files to a Page**

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files.
Attachments are useful when you want to share information that exists in another file format. Read more in Working with Attachments.

When you attach a file to a page, Confluence makes a copy of the file and stores it on the Confluence server. Page attachments in Confluence are managed using the 'Attachments' view of the page.

To attach a file, you need the 'Create Attachments' permission. See Space Permissions.

When a page you are viewing contains attachments, a small paperclip icon appears next to the breadcrumbs. Clicking the paperclip icon will take you to the 'Attachments' view, where you will see the full list of attachments.

On this page:
- Attaching files
- Attachment versions
- Notes

Related pages:
- Working with Attachments
- Configuring Attachment Size
- Displaying Images
- Attachment Versions
- Deleting an Attachment
- Confluence User's Guide

Attaching files

This page describes the following ways of attaching files to a Confluence page:

- Drag and drop files on to a Confluence page.
- Browse to, and upload files from, your computer or network.

To attach a file to a page using drag-and-drop:

1. View the page to which you want to attach files.
2. Drag one or more files from your computer onto the page. The 'Attach File(s)' message box appears, indicating the upload status of the files being attached to your page.

You can drag and drop more than one file at a time onto a page. You cannot drag a folder of files onto a page.

You can also drag and drop files:
- directly onto the 'Attachments' view for the page.
- directly onto the editor view of the page.
- onto any tab of the 'Insert Link' or 'Insert Image' dialogs, which are available from the Insert menu while editing.

To attach a file to a page from the computer's (or network's) file system:

2. Choose Browse and navigate to the file.
3. Select the file and click Open.
4. Add a descriptive comment for the file (optional).
5. Choose Attach more files if required.
6. Choose Attach.

You can attach than one file at a time. You cannot attach a folder of files.

You can also browse for, and upload, a file from:
- the 'Attachments' tab of the 'Insert Link' dialog. (While editing the page, choose Insert > Link.)
- the 'Attached Images' tab of the 'Insert Image' dialog. (While editing the page, choose Insert > Image.)
Attachment versions

If you upload a file with the same name as an existing attachment, Confluence will rename the old file and keep it as a previous version. Read more about Attachment Versions and Viewing Attachment Details.

Notes

- **Reusing attachments**: If you want to display the same file on more than one page, the best way is to put the attachment on a page (say, page A) and then use the Include Page Macro to include page A into page B, page C, and all the pages where you want the diagram, presentation, or other file. Alternatively, you can display an image that is attached to another page.
- **Updating the original file**: Any changes you make to the source file do not affect the copy that was uploaded to Confluence. To update the Confluence copy, you need to upload the new version of the file.

Attachment Versions

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

When viewing a list of attachments, you can add a new version of an existing attachment by uploading an attachment with the same file name, as displayed on the attachment view. Existing files will be kept with the name 'Version x', where the value of 'x' increments with each upload of an attachment with the same file name.

To see all versions of an attachment: Choose the arrow next to an attachment name.

Screenshot: Attachment versions

<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Creator</th>
<th>Creation Date</th>
<th>Labels</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>penguin.png</td>
<td>5 KB</td>
<td>Rach Admin</td>
<td>Feb 15, 2013</td>
<td>penguin</td>
<td>Updated colours</td>
</tr>
<tr>
<td>Version 2</td>
<td>5 KB</td>
<td>Rach Admin</td>
<td>Feb 15, 2013</td>
<td>penguin</td>
<td>Updated colours</td>
</tr>
<tr>
<td>Version 1</td>
<td>5 KB</td>
<td>Rach Admin</td>
<td>Feb 14, 2013</td>
<td>penguin</td>
<td>Updated colours</td>
</tr>
<tr>
<td>Bugs.gif</td>
<td>22 KB</td>
<td>Josh User</td>
<td>Feb 15, 2013</td>
<td>useful</td>
<td>Properties</td>
</tr>
<tr>
<td>site.png</td>
<td>2 KB</td>
<td>Josh User</td>
<td>Feb 15, 2013</td>
<td>logo</td>
<td>Properties</td>
</tr>
</tbody>
</table>

Notes

- You cannot revert to a previous version of an attachment. See feature request CONF-1943.
- Confluence does not track the history of attachments in the same way as it does for pages. See feature request CONF-13943.
- There is no limit to the number of attachments or attachment versions, provided that there is enough disk space.
- By default, attachments and their versions are stored in the `<confluence_home>/attachments` directory. (See Attachment Storage Configuration.)

Deleting an Attachment

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

By default, when you delete an attachment, this will delete all versions of the attachment. To do that, you need the 'Delete Attachments' permission. See Space permissions.
If you want to delete a specific version of an attachment, you need to be a space administrator.

### Related pages:
- Working with Attachments
- Deleting an Image
- Displaying Images
- Confluence User's Guide

#### To delete all versions of an attachment:
1. Go to the page that contains the attachment.
2. Choose Tools > Attachments. A list of the page’s attachments will appear.
3. Choose Delete next to the attachment you want to delete.
4. Choose Delete to confirm your action.

#### To delete a specific version of an attachment:
1. Go to the page that contains the attachment.
2. Choose Tools > Attachments. A list of the page’s attachments will appear.
3. Choose the arrow on the left next to the attachment you want to manage. A list of attachment versions will appear.
4. Choose Delete next to the version you want to delete.
5. Choose Delete to confirm your action.

**Screenshot: Attachments and attachment versions**

### Displaying a List of Attachments

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

You can display a list of attachments on your page – these may be the files that are attached to the current page or to any page in the space. Use the

- Use the **Attachments** macro to show a list of the attachments on the current page, or
- Use the **Space Attachments** macro to show a list of the attachments in the current space.

Both these macros generate a table of attachments which is clickable.

**Using the macros**

#### To add the Attachments or Space Attachments macro to a page:
1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

#### To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters of the Attachments macro

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Filename Patterns                 | all       | A comma-separated list of regular expressions, used to filter the attachments by file name. Note that the parameter values must be regular expressions. For example:  
  - To match a file suffix of 'jpg', use .jpg (not *.jpg).  
  - To match file names ending in 'jpg' or 'png', use .jpg,.*png. |
| Attachment Labels                 | (none)    | A list of labels, used to filter the attachments to display. If you wish to enter more than one label, separate the labels with commas. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.) For information on labelling the attachments, see Adding Labels. |
| Include Old Attachment Versions   | false     | A value of true will include previous attachment versions in the list.                                                                        |
| Sort By                           | date      | The sort order for attachments. Note that people viewing the page can change the sort order by clicking the column headings. Valid values are:  
  - date – sorts by updated date in reverse chronological order (newest first)  
  - size – sorts largest to smallest  
  - name – sorts alphabetically  
  - Created date - sorts by creation date in reverse chronological order (newest first) |
| **Sort Order** | ascending | Used in combination with the **Sort By** parameter, to sort the attachments in ascending or descending order. |
| **Allow Upload** | true | If selected, the list of attachments will include options allowing users to browse for, and attach, new files. |
| **Page Title** | (none) | Used to display attachments from another page. If you do not enter a page title, the macro will display the files attached to the current page. |
| **Show Previews** | true | Used to display a preview of the attached file. If true, preview will be visible when the list item is expanded. |

**Viewing files and changing file properties via the Attachments macro**

The list of files displayed by the Attachments macro can be expanded to show options for viewing the files and other actions, provided you have the relevant permissions.

- If you have specified the 'Allow Upload' parameter, users will be able to upload attachments directly from the list.
- You can delete attachments. Note that you can only delete the entire attachment (including all versions). To delete a specific version of an attachment, you must go to the 'Attachments' view. See Deleting an Attachment.
- You can edit attachment properties and labels. If an attachment is an Office or PDF file, they will see the appropriate options for Office Connector files.
- You can choose not to display previews in the macro. This is useful if you have very large attachments.

*Screenshot: The Attachments macro, showing details of an attachment*
Parameters of the Space Attachments macro

The Space Attachments macro displays a list of all the attachments in a space. You can choose to show attachments from the current space, or another space.

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>(none)</td>
<td>Selects the Confluence space to display attachments for. If you do not specify a space, the current space will be used.</td>
</tr>
<tr>
<td>Show Filter Controls</td>
<td>true</td>
<td>Determines whether or not the filter panel is shown. If you select this option, people viewing the page will be able to filter the list of attachments by file type (extension) and by label.</td>
</tr>
</tbody>
</table>

Screenshot: The Space Attachments macro
### Downloading Attachments

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

**To download a single attachment from a page:**

1. View the page.
2. Choose **Tools > Attachments**.
3. Right-click the link on the attachment name, and select **Save Link As, Save Target As** or a similar option provided by your browser. This will open a 'Save' dialog.
4. Select the location into which you want to download the file and choose **Save**.

**Related pages:**
- Attaching Files to a Page
- Working with Attachments
- Confluence User's Guide

**To download all the attachments from a page:**

1. View the page.
2. Choose **Tools > Attachments**.
3. Choose the **Download All** button at the end of the page to download a zipped file of all the page's attachments.

**Notes**

- There is no permission that controls the downloading of attachments. See an article in our knowledge base about [disabling the download of attachments](https://confluence-docs.atlassian.com/pages/viewpage.action?pageId=1199320116).
- Confluence does not supply an option to download all attachments from a space. See the closed feature request: ![CONF-5669](https://confluence-docs.atlassian.com/projects/CONF-5669-Download-all-attachments-from-a-Space) CLOSED

### Editing Attachment Properties

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

To edit an attachment's properties, you need the 'Create Attachments' permission. See [Space Permissions](https://confluence-docs.atlassian.com/pages/viewpage.action?pageId=1199320116).

**To edit the properties of an attachment:**

1. View the page that contains the attachment.
2. Choose **Tools > Attachments**.
3. Choose **Properties** next to the attachment. The 'Properties' screen will appear.
4. Make your changes:
• **File Name** — Rename or modify the name of the attachment.
• **New Comment** — Update the existing comment or enter a new comment.
• **New Content Type** — Change the content type of the attachment by entering a valid MIME type.
• **Page** — Move the attachment to another page.

5. Choose **Save**.

### Related pages:
- Attaching Files to a Page
- Moving an Attachment
- Viewing Attachment Details
- Working with Attachments
- Confluence User's Guide

---

**Embedding Multimedia Content**

Using multimedia files you can display movies, animations and videos, and embed audio files on your Confluence page. There are several methods for attaching files to a page. Once you have attached the multimedia file to a Confluence page, you then edit the page to set where the multimedia content should appear.

In the example below, we display a Flash file that is attached to this page.

**Error rendering macro 'multimedia' : null**

Confluence supports the following multimedia formats:

- Adobe Flash (.swf)
- Apple QuickTime (.mov)
- Windows Media (.wma, .wmv)
- Real Media (.rm, .ram)
- MP3 and MP4 files (.mp3, .mp4)
- MPEG files (.mpeg, .mpg)
- AVI files (.avi) *You may need to enable an avi decoder within your browser.*
Displaying a multimedia file attached to the page

Once you have attached a multimedia file to a page, there are different methods for choosing where on the page the multimedia content should appear:

Inserting the Multimedia macro yourself

You can add the Multimedia macro to the page yourself using the Macro Browser. This allows you to display a multimedia file that is attached to either the current page or to another page in the Confluence site.

To insert the Multimedia macro on the page at the current cursor position:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type '{' and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click on the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Using autocomplete

Once a multimedia file is attached to the page, you can use autocomplete, while editing the page, to choose where the multimedia content should appear.

To position an attached multimedia file on the page using autocomplete:

1. While editing the page, position the cursor where you want to place the multimedia content.
2. Trigger the autocomplete function by typing '{'.
3. Choose the multimedia file from the list that appears.
4. If necessary, click on the Multimedia macro placeholder and choose Edit to set various options such as the width, height or autoplay.

Using drag-and-drop

Depending on the browser you are using, you can attach and position a multimedia file in one step using drag-and-drop.

To attach and position multimedia content using drag-and-drop:
1. While you are editing a page, simply **drag-and-drop** the multimedia file on to the page. Confluence will attach the file to the page and insert the Multimedia macro at the current cursor position for you.
2. If necessary, click on the Multimedia macro placeholder and choose **Edit** to set various **options** such as the width, height or autoplay.

**Multimedia macro parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page Name</strong></td>
<td>Current page</td>
<td>Name of the page to which the multimedia file is attached. If you are using the Macro Browser, just start typing the name of the page and then select it from the dropdown list that appears. The page can be in the same space or another space.</td>
</tr>
<tr>
<td><strong>Attachment</strong></td>
<td>None</td>
<td>File name of the multimedia file.</td>
</tr>
<tr>
<td><strong>Width</strong></td>
<td>If not specified, the browser will determine the width based on the file type.</td>
<td>Width of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window’s width, or any other value accepted by HTML.</td>
</tr>
<tr>
<td><strong>Height</strong></td>
<td>If not specified, the browser will determine the height based on the file type.</td>
<td>Height of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window’s height, or any other value accepted by HTML.</td>
</tr>
<tr>
<td><strong>Autoplay</strong></td>
<td>False</td>
<td>If this option is checked (that is, if the parameter is set to ‘true’) then the video or audio file will start playing as soon as the page is loaded. If this option is not checked (set to ‘false’) then the file will not play until the user clicks the icon or image on the page. See the note about autoplay below.</td>
</tr>
</tbody>
</table>

**Notes**

- **The multimedia file must be attached to a Confluence page.** For security reasons, files located on remote servers are not permitted. See the **Widget Connector** for displaying live content from external sites.

- **You will need the relevant multimedia plugin for your browser.** Your browser (Firefox, Internet Explorer, Safari and others) needs a plugin to play the video or audio file on a Confluence page. For example, to play a Flash movie you need the Flash plugin. Many plugins are shipped with the major browsers by default. If a user does not have the required plugin installed and enabled in their browser, they will not be able to view the multimedia files on the page.
• **Autoplay may not always work as expected.** You can set autoplay on, so that your video or audio file should start playing as soon as the page is loaded into the browser. (See parameters.) However, this setting may not always work as expected. Confluence will send an instruction to the browser plugin that plays the multimedia file. Different browsers and different media plugins behave in different ways, and not all of them respect such instructions.

• **Use the Office Connector to display Office documents.** Take a look at the Office Connector for embedding Word documents, presentations and other Office documents onto your Confluence page.

• If you get the error, 'Unable to embed content of type application/octet-stream', this means the MIME type is not recognised.

• **Advanced users can try styling via CSS.** By default, each embedded object is wrapped in a div tag. If you wish to style the div and its contents, override the embeddedObject CSS class. Specifying an ID as a property also allows you to style different embedded objects differently. CSS class names in the format `embeddedObject-ID` are used.

**Embedding PowerPoint Presentations in a Page**

Below are some ideas on how you can display a presentation on a Confluence page.

**Option 1 - Office Connector for Confluence**

The Office Connector provides the most straightforward way to display PowerPoint slides.

1. Attach your PowerPoint file to a Confluence page - see Attaching Files to a Page.
2. Use the Office PowerPoint View File macro to display the presentation on the page.

Alternatively you can drag your PowerPoint file directly into the editor, and Confluence will attach the file and display it in the Office PowerPoint View File Macro for you.

**On this page:**

- Option 1 - Office Connector for Confluence
- Option 2 - PDF View File macro
- Option 3 - Gallery or Slide Show of JPEG or PNG Images

**Related pages:**

- Working with the Office Connector
- Working with Attachments
- Confluence User's Guide

**Option 2 - PDF View File macro**

1. Convert your presentation to PDF, using 'Save as > PDF' in PowerPoint (PowerPoint 2007 and later).
2. Attach the PDF file to your Confluence page.
3. Use the PDF View File macro to display the presentation on the page. The PDF View File macro contains Next Slide, Previous Slide and Full Screen Mode buttons for controlling your presentation.

Alternatively you can drag your PDF file directly into the editor, and Confluence will attach the file and display it in the PDF View File Macro for you.

This method is also useful for presentations created in other packages such as Keynote.

**Option 3 - Gallery or Slide Show of JPEG or PNG Images**

1. Convert your PowerPoint presentation into JPEG or PNG images, using 'save as' from PowerPoint (slide1.jpg, slide2.jpg...).
2. Upload the image files as attachments to your Confluence page.
3. Use the Gallery macro to display the images as a slide show in Confluence.

**Moving an Attachment**

You can move an attachment from its current location to any page within the site.

To move an attachment, you need the following permissions (see Space Permissions):

- 'Add Page' permissions on the page where the attachment currently exists.
• 'Remove Attachment' permissions for the space where the attachment currently exists.
• 'Add Attachment' permission on the space into which you are moving the attachment.

To move an attachment:

1. Go to the page that contains the attachment.
2. Choose Tools > Attachments.
3. Choose Properties next to the attachment.
4. Enter the name of the page where you want to move the attachment into the Page field, for example, My Destination Page.
5. Choose Save.

If you wish to move the attachment to a page in a different space, add the space key before the page name, for example, DOC:My Destination Page.

Related pages:
- Moving a Page
- Working with Attachments
- Confluence User's Guide

Viewing Attachment Details

An attachment is any file that is included with your page. Examples of attachments are screenshots, photographs, other images, Word documents, presentations, PDF documents, videos and sound files. Attachments are useful when you want to share information that exists in another file format.

You can view attachment details in the following places:

• The list of attachments in a space. This will show all files attached to all pages in the space. See below.
• The list of attachments for a specific page. See below.
• A list of attachments created by a macro and displayed on a page. See Displaying a List of Attachments.

Viewing attachments in a space

To view the attachments associated with a space:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Attachments. You will see a list of all the attachments in the space, along with their details and the pages they are attached to.
   To see only files of a particular type:
   • Type the last part of the file name in the Filter By File Extension box. For example, enter ‘gif’ to see only image files of the GIF format.
   • Choose Filter.
3. To see only files that have a particular label or labels:
   • Type the label or labels in the Filter by Label box. If you enter more than one label, separate the labels with commas or spaces. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.)
   • Choose Filter.

If your space uses the Documentation theme:

2. Choose Attachments from the left menu.

On this page:
- Viewing attachments in a space
- Viewing attachments on a page
- Attachment details

Related pages:
- Working with Attachments
- Displaying a List of Attachments
- Confluence User's Guide

Screenshot: List of attachments for a space
Viewing attachments on a page

When a page you are viewing contains attachments, a small paperclip icon appears next to the breadcrumbs. Clicking the paperclip icon will take you to the 'Attachments' view, where you will see the full list of attachments.

To view the attachments associated with a page:

1. Go to the page.
2. Choose Tools > Attachments. You will see a list of the attachments in the page along with their details.
3. To see all versions of an attachment, choose the arrow on the left of the attachment name.

The list of attachments includes options for viewing the files, and other actions, provided the user has the relevant permissions. If you have specified the 'Allow Upload' parameter, users will be able to upload attachments directly from the list too. Users can also delete attachments or edit attachment properties and labels. If an attachment is an Office or PDF file, you will see the appropriate options for Office Connector files.

**Screenshot: List of attachments for a page**

### Attachment details

Note that the page view shows a different subset of fields from the space view.

- **Name** is the name of the attached file.
- **Size** tells you how much space the attachment takes up. You can sort by size by clicking the column title.
- **Creator** is the person who attached the file. Clicking on the link takes you to the person's user profile.
- **Creation Date** is the date the file was attached. You can sort by date by clicking the column title.
- **Labels** are keywords, or tags, that you can enter to categorise the attachments. See how to add labels.
- **Last Mod. Date** (in the space view) is the date the file was last modified.
- **Attached To** (in the space view) tells you which page contains the attachment.
- **Comment** (in the page view) is a short description of the attachment.
- **The Properties link** (in the page view) lets you edit the attachment details. See how to edit attachment properties.
- **The Delete link** (in the page view) lets you delete the attachment, or a specific version of the attachment.
- **The Edit in Office link** (in the page view) appears next to Office files only, and lets you edit that attachment.
- **The Attach File option** lets you add another attachment or another version of an existing attachment. See how to upload attachments.

### Customising Confluence

You can customise or configure many aspects of Confluence:

- The **look and feel** of any Confluence space.
• **Personal aspects**, including your personal profile and homepage.
• **Setting up your user profile**.
• **User access**, including permissions and page restrictions.
• **Add-ons** such as **gadgets** and **macros**.
• **Customisations for specific uses** of Confluence.

**Personal Customisations**

There are several ways that you can customise the way that Confluence works for you, including:

• Your personal home page
• Your personal dashboard
• Your personal profile
• Your email notifications
• Your RSS Feed settings

**User Profile Overview**

Each Confluence user has a user profile. In your own profile, you can access account management features and updated information about yourself. You can also view other users' profiles.

**To find your user profile:**

Choose your profile picture at top right of the screen, then choose Profile.

Or, choose the Profile link in the sidebar of your personal space.

**To find someone else's user profile:**

1. Open the user's hover profile popup:
   • Log in to Confluence, if you have not already done so.
   Note: If a Confluence Administrator has granted the 'View User Profiles' permission to anonymous users, you can access people's hover profile popups without logging in. However, the hover profile features available to anonymous users are restricted.
   • Move your mouse pointer over a user's linked name or profile picture. The hover profile popup will appear.
2. Choose the user's linked name to open the user profile.

Alternatively, you can choose the Profile link in the sidebar of the user's personal space or go directly to this URL:

http://MY.CONFLUENCE.COM/users/viewuserprofile.action?username=USERNAME

**Screenshot:** User profile screen for the current user
Profile

- View and edit your personal details, such as your name and email address details and optionally, your photograph and other personal information. Note that as a security precaution, in order to change your email address, you will be required to re-enter your password.
- Upload a profile picture (optional).
- Change your password.

Network

- View the recent activity of users that you are following via the Network view.
- Follow other users from this view.

Status Updates

- View your history of status updates.

Favourites

- View a list of your favourite spaces.

Watches

- View a list of the pages and spaces you are currently watching.

Drafts

- Retrieve any pages you were in the process of editing. See Working with Drafts.

Settings

- Edit your General Settings (homepage, language and timezone).
- Subscribe to email notifications.
- View and revoke your OAuth access tokens.

Notes

The ‘Administer User’ link is visible to Confluence administrators only. The administrator can click this link to go directly to the user management screen in the Administration Console.

Changing Password

To change your Confluence password:
1. Choose your profile picture at top right of the screen, then choose Profile.
2. On your Profile tab, click Password in the left-hand column.
3. Enter your current password and your new password in the form displayed.
4. Click Submit.

Related Topics

- Viewing User Profile
- Editing Your User Profile
- Choosing a Profile Picture
- Setting Up your Personal Space
- Updating Email Address
- Email Address Privacy

Take me back to the Confluence User's Guide.

Editing User Settings

You can set various Confluence preferences that affect your personal session:

- General preferences such as home page, language and time zone, as described below.
- Editor settings, as described below.
- Email settings for subscriptions to email reports. See Subscribing to Email Notifications of Updates to Confluence Content.
- OAuth access tokens that you have granted from your Confluence user account. See Viewing and Revoking OAuth Access Tokens.

**General User Preferences**

To edit your general user settings:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Click Edit and update the settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site Homepage</td>
<td>Select the page that you would like to see whenever you log into Confluence.</td>
</tr>
<tr>
<td>Language</td>
<td>Select your language. See below.</td>
</tr>
<tr>
<td>Time zone</td>
<td>Select your time zone.</td>
</tr>
<tr>
<td>Use Keyboard Shortcuts</td>
<td>Enable keyboard shortcuts, other than for the editor.</td>
</tr>
<tr>
<td>Text select</td>
<td>Turn off the popup options panel when highlighting text.</td>
</tr>
</tbody>
</table>

3. Click Submit.

On this page:

- General User Preferences
- More about Language
- Editor Preferences

Related pages:

- Editing Your User Profile
- Choosing a Profile Picture
- Setting Up your Personal Space
- Email Address Privacy
- Using Autocomplete
- Confluence User's Guide

Screenshot: Editing your user profile settings
More about Language

Setting your language preference in your user profile is described in the section above. This section gives more information about that setting and other settings that affect the language Confluence will use.

Individual users can choose the language that Confluence will use to display screen text and messages. Note that the list of supported languages depends on the language packs installed on your Confluence site.

The language used for your session will depend on the settings below, in the following order of priority from highest to lowest:

- The language preference defined in your user profile. Note that you need to be logged in for this setting to take effect.
- The language that you choose by clicking an option at the bottom of the Confluence login screen. Confluence stores this value in a cookie. When the cookie expires, the setting will expire too.
- The language set in your browser. The browser sends a header with a prioritised list of languages. Confluence will use the first supported language in that list. Your Confluence administrator can disable this option by setting a system property.
- The default language for your site, as defined by your Confluence site administrator.

Editor Preferences

You can set some options that determine the way the Confluence editor works. Note that these settings affect only you. Other people using Confluence can enable or disable the settings on their user profiles independently.

To change your editor preferences:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Click Editor under 'Your Settings' in the left-hand panel.
3. Click Edit.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Disable Autocomplete

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select to disable autocompletion when you press one of the trigger characters.</td>
</tr>
</tbody>
</table>

Disable Autoformatting

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select to disable autoformatting when you type wiki markup in the editor. Click ? on the editor toolbar to learn more.</td>
</tr>
</tbody>
</table>

4. Click Submit.

Screenshot: User settings for the editor

Editing Your User Profile

Your user profile contains basic information about you. If you do not have a personal space, your user profile will be displayed when anyone clicks your name in the People Directory.

To edit your user profile:

1. Choose your profile picture at top right of the screen, then choose Profile.
   Or, choose the Profile link in the sidebar of your personal space.
2. Choose Edit Profile.
3. Enter details about yourself in the form displayed.
4. Click Save.

Related pages:
- Viewing User Profile
- Choosing a Profile Picture
- Setting Up your Personal Space
- Email Address Privacy
- Confluence User's Guide.

<table>
<thead>
<tr>
<th>Detail</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Name</td>
<td>Your name as you would like it to appear in your profile.</td>
</tr>
<tr>
<td>Email</td>
<td>Your email address which will be used to send you mail notifications.</td>
</tr>
<tr>
<td>Phone</td>
<td>Your phone number.</td>
</tr>
</tbody>
</table>
IM

Your Instant Messenger (IM) details. To suit a variety of IM applications, this option accepts any string value. For example, you can enter IM details in the form of an email address, such as 'example@atlassian.com' or a user ID, like '123456789'.

Website

Your website's URL.

About me

Information about yourself that other users can view (such as your professional information, hobbies, and other interests). You can use Confluence wiki markup in this field.

Position

The title of your position within your organisation.

Department

The name of your department within your organisation.

Location

Your location. This could be a town, city, region or country.

Handy Hint

Confluence administrators can configure Confluence to mask email addresses (e.g. 'example@atlassian.com'), protecting your email address from search engine spiders and the like.

Email Address Privacy

Confluence can mask the email addresses of users to protect them from mail spammers.

This is done by a Confluence administrator and is configured through the Administration Console. The Confluence administrator has three options for email address privacy:

- **Public**: email addresses are displayed publicly.
- **Masked**: email addresses are still displayed publicly, but masked in such a way to make it harder for spam-bots to harvest them.
- **Private**: only Confluence administrators can see the email addresses.

For more information on setting these options, which are configured using the Administration Console, refer to User Email Visibility.

Related pages:

- Editing Your User Profile
- Viewing User Profile
- User Email Visibility
- Confluence User's Guide

Updating Email Address

The email address you specify in your profile settings is used for your mail notifications and is also displayed in your profile description.

To update your email address:

1. Choose your profile picture at top right of the screen, then choose Profile.
2. Click Edit in the 'Personal' section.
3. In the Email field, specify your new email address which will be used when sending you mail notifications.
4. Click Save.

Related Topics

Changing Password
Editing Your User Profile

Take me back to the Confluence User's Guide.

Choosing a Profile Picture

Your profile picture is used as the icon for your personal space, to represent you in the People Directory, and to illustrate your comments. It also appears in various other places next to your name, such as in the list of recent
updates on the dashboard.

You can upload your own profile picture or use one of the images provided by Confluence. If you upload your own profile picture, you will have an opportunity to crop (trim) the picture.

To choose a profile picture:

1. Choose your profile picture at top right of the screen, then choose Profile.
2. Click Picture on the left.
3. Choose one of the following two options:
   - Upload a new picture: Click Browse to locate your picture, then click Upload to upload it from your computer or file server.
   - Or select one of the default icons provided.
4. Click Set Profile Picture.

On this page:

Related pages:
- Deleting a Profile Picture
- Editing Your User Profile
- Setting Up your Personal Space
- Confluence User's Guide

If you upload a profile picture that is larger than 48x48 pixels, the 'Edit My Profile Picture' screen will appear. You can select part of the picture or the entire picture, to be used as the final image for your profile. Note that the size of the final image will always be scaled down to 48x48 pixels.

To edit your profile picture:

1. Click and drag the centre of the superimposed square to select the centre of the new image.
2. Click the corners of the square to resize the area for your new image.
3. Click Save.
4. The image from your selected area will be cropped, resized to 48x48 pixels and saved.

Screenshot: Trimming a profile picture
Deleting a Profile Picture

You can delete the profile picture images that you have uploaded to Confluence.

To delete a profile picture:

1. Choose your profile picture at top right of the screen, then choose Profile.
2. Click Picture on the left.
3. Locate and select the picture file you wish to delete, then click Delete.
   - Note that you can only delete images that you have uploaded to Confluence. The standard icons cannot be deleted.
4. Click Delete to confirm the action. The picture is permanently removed from the server.

Related pages:

- Choosing a Profile Picture
- Editing Your User Profile
- Setting Up your Personal Space
- Confluence User's Guide
Viewing User Profile

Each Confluence user has a user profile. In your own profile, you can access account management features and update information about yourself. You can also view other users' profiles, add them to your network, and add their personal spaces to your list of favourites.

To find your user profile:

Choose your profile picture at top right of the screen, then choose Profile.

Or, choose the Profile link in the sidebar of your personal space.

To find someone else’s user profile:

1. Open the user's hover profile popup:
   - Log in to Confluence, if you have not already done so. Note: If a Confluence Administrator has granted the 'View User Profiles' permission to anonymous users, you can access people's hover profile popups without logging in. However, the hover profile features available to anonymous users are restricted.
   - Move your mouse pointer over a user’s linked name or profile picture. The hover profile popup will appear.
2. Choose the user’s linked name to open the user profile.

Alternatively, you can choose the Profile link in the sidebar of the user's personal space or go directly to this URL:


Related pages:
- User Profile Overview
- Setting Up your Personal Space
- Confluence User's Guide

Screenshot: User profile for the current user.

Updating your profile

You can update the following aspects of your profile from this view:

- Information about yourself – see Editing Your User Profile.
- Your Profile picture – see Choosing a Profile Picture.
- Your login password – see Changing Password.
Viewing and Revoking OAuth Access Tokens

This page describes the purpose of OAuth access tokens which have been issued on behalf of your Confluence user account and provides instructions on how to revoke them.

On this page:
- OAuth Access Tokens
- Viewing your OAuth Access Tokens
  - OAuth Access Token Details
- Revoking your OAuth Access Tokens

OAuth Access Tokens

OAuth access tokens allow you to use a Confluence gadget on an external web application or website (also known as the 'consumer') and grant this gadget access to Confluence data which is restricted or privy to your Confluence user account.

OAuth access tokens will only appear in your user profile if the following conditions have been met:

1. Your Confluence Administrator has established an OAuth relationship between your Confluence site and the consumer. Confluence Administrators should refer to Configuring OAuth for more information about establishing these OAuth relationships.
2. You have accessed a Confluence gadget on the consumer and have conducted the following tasks:
   a. Logged in to your Confluence user account via the gadget and then,
   b. Clicked the 'Approve Access' button to allow the gadget access to data that is privy to your Confluence user account.

Confluence will then send the consumer an OAuth 'access token', which is specific to this gadget. You can view the details of this access token from your Confluence site's user account.

An OAuth access token acts as a type of 'key'. As long as the consumer is in possession of this access token, the Confluence gadget on the consumer will be able to access Confluence data that is both publicly available and privy to your Confluence user account. As a Confluence user, you can revoke this access token at any time. Furthermore, all access tokens expire after seven days. Once the access token is revoked or has expired, the Confluence gadget will only have access to publicly available Confluence data.

Viewing your OAuth Access Tokens

To view all of your Confluence user account's OAuth access tokens:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Click View OAuth Access Tokens. A view similar to screenshot below is displayed. Refer to OAuth Access Token Details below for information on interpreting this table.

   If no access tokens have been set, then 'None specified' is shown.

Screenshot: Viewing your OAuth Access Tokens

<table>
<thead>
<tr>
<th>Authorised Applications</th>
</tr>
</thead>
<tbody>
<tr>
<td>Consumer</td>
</tr>
<tr>
<td>Atlassian JIRA Special Projects Atlassian JIRA at <a href="https://atlassian.com/jira">https://atlassian.com/jira</a></td>
</tr>
</tbody>
</table>

OAuth Access Token Details

Your list of OAuth access tokens is presented in a tabular format, with each access token presented in separate rows and each property of these tokens presented in a separate columns:
<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Consumer</td>
<td>The name of the Confluence gadget that was added on the consumer.</td>
</tr>
<tr>
<td>Consumer Description</td>
<td>A description of this consumer application. This information would have been obtained from the consumer's own OAuth settings when an OAuth relationship was established between Confluence and that consumer. If the consumer is another Atlassian application, this information is obtained from the Consumer Info tab's 'Description' field of the OAuth Administration settings. The application's administrator can customise this Consumer Info detail.</td>
</tr>
<tr>
<td>Issued On</td>
<td>The date on which the OAuth access token was issued to the consumer by Confluence. This would have occurred immediately after you approved this gadget access to your Confluence data (privy to your Confluence user account).</td>
</tr>
<tr>
<td>Expires On</td>
<td>The date when the OAuth access token expires. This is seven days after the 'Issued On' date. When this date is reached, the access token will be automatically removed from this list.</td>
</tr>
<tr>
<td>Actions</td>
<td>The functionality for revoking the access token.</td>
</tr>
</tbody>
</table>

**Revoking your OAuth Access Tokens**

**To revoke one of your OAuth access tokens:**

1. View your Confluence user account's OAuth access tokens (described above).
2. Locate the Confluence gadget whose OAuth access token you wish to revoke and click **Revoke OAuth Access Token** next to it.
   - The gadget's access token is revoked and the Confluence gadget on the consumer will only have access to publicly available Confluence data.

**Choosing your Home Page**

By default, all users are directed to the dashboard after logging in. However, you can choose to be redirected to the home page of any space on the Confluence site after logging in.

**To set the home page:**

1. Choose **your profile picture** at top right of the screen, then choose **Settings**.
2. Choose **Edit**.
3. Choose a page from the **Site Homepage** drop down. Only spaces for which you have 'view' access display. You will be directed to the home page of the selected space when you next log in.
4. Click **Submit**.

**Related pages:**

- User Profile Overview
- Confluence User's Guide

**Screenshot: Profile Settings**
Customising your Personal Dashboard

You can customise the Confluence dashboard to provide access to the content on the site that is most relevant to you. The options described on this page will change your own personal dashboard, but will not affect the dashboard that other people see.

If you have System Administrator permissions, you can change the global dashboard, as seen by all Confluence users. See the administrator’s guide to customising the dashboard.

Displaying your favourite spaces

Mark some spaces as favourites. You can now choose the Spaces tab on the dashboard to see a list of your favourite spaces. You can also choose the Favourite Spaces tab at the top right of the dashboard to see recently updated content from just your favourite spaces.

Categorising your spaces

To help keep Confluence spaces organised, you can label spaces with different space categories. See Using Labels to Categorise Spaces. Space categories are used to group related spaces.

For example, you might want to group spaces on your Confluence site by applying the following space categories to the relevant spaces:

- 'design' (for spaces relevant to a design team), and
- 'development' (for spaces relevant to a development team).

If a subset of these spaces is relevant to both teams, apply both the ‘design’ and ‘development’ categories to each of these spaces to make the spaces appear in both groups.

Once you have added space categories, you can choose the Space Categories tab at the top right of the dashboard and select a category from the drop-down menu to display only spaces belonging to that category.
Displaying your favourite pages

Mark some pages as favourites. You can now choose the Pages tab on the dashboard to see a list of your favourite pages.

Screenshot: The dashboard, showing favourite pages and space categories

Customising the Look and Feel of a Confluence Space

You can customise the 'look and feel' of a space on your Confluence site through options available in the Space Administration menu. By default, the look and feel of a space is based on site-wide settings configured from the Administration Console.

You need to be a space administrator to change the look and feel of a space.

- Applying a Theme to a Space
- Configuring a Sidebar
- Changing a Space's Logo
- Customising Space Layouts
- Editing a Space's Colour Scheme
- Styling Confluence with CSS
Applying a Theme to a Space

Themes allow you to personalise the 'look and feel' of Confluence. You can apply a theme to your entire Confluence site or to individual spaces. Choose a specific theme if you want to add new functionality or significantly alter the appearance of Confluence.

Confluence comes with a selection of themes. In addition, a site administrator can install new themes as plugins via the Confluence Administration Console. Provided that the theme is installed into your Confluence site, any space administrator can apply a theme to a space.

By default when you create a new space, the space will have the Confluence default theme.

To apply a theme to a space:

1. Go to the space and choose Space tools > Look and Feel on the sidebar.
   You'll need Space Admin permissions to do this.
2. Choose Themes and select a theme option.
3. Choose Confirm.

Want to customise Confluence or make it even more beautiful? Try a Confluence theme from the Atlassian Marketplace.
If your space is using the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.  
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Themes from the space administration options
3. Select a theme option.
4. Choose Confirm.

Configuring the Documentation Theme

The Documentation theme is one of the themes bundled with Confluence.

**Advance warning of plans to merge Documentation theme with the default theme**

This is an advance notice that we plan to merge the functionality of the Confluence Documentation theme with the Confluence default theme. We do not yet have a specific date for this plan, and we are interested in your feedback. The new default theme, introduced with Confluence 5.0, includes a sidebar with contextual navigation. Our plan is to include features from the Documentation theme in the default theme, and then remove the Documentation theme from Confluence.

If you are interested in this change and would like to give us feedback, please add a comment on this blog post: [Advance warning of plans to merge Documentation theme with the default theme](#). We are especially interested to know which features of the Documentation theme you use and value the most.

The Documentation theme is designed for spaces containing technical documentation, but you may find it useful for other types of structured content. It provides a table of contents for your space, a configurable header and footer, and text styles suited to documentation. (See features below.)

**Quick guide to applying and customising the Documentation theme:**

- Go to the space and choose Space tools > Look and Feel on the sidebar.
- Choose Themes.
• Select **Documentation Theme** and choose **Confirm**.
• If you want to customise the theme, choose **Configure theme**.
  • Select or deselect the default page tree.
  • Select or deselect the space-restricted search.
  • Enter the text and wiki markup for your custom left-hand panel header and footer.
  • Choose **Save**.

The rest of this page gives more details of the above procedure.

### On this page:

• Applying the Documentation theme to your space
• Applying the Documentation theme to your site
• Customising the Documentation theme
  • Customising the theme at site level
• Features of the Documentation theme
• Hints and tips
• Notes

### Related pages:

• Using the Documentation Theme
• Space Jump Macro
• Applying a Theme to a Space
• Applying a Theme to a Site
• Editing a Space's Colour Scheme
• Customising the Look and Feel of a Confluence Space
• Confluence User's Guide

**Screenshot: The Documentation theme showing the space sidebar replaced by a navigation sidebar.**

---

**Applying the Documentation theme to your space**

Follow the steps below to apply the Documentation theme to your space. All pages in the space will start using the theme immediately.

**To apply a theme to a space:**

1. Go to the space and choose **Space tools > Look and Feel** on the sidebar.
   You'll need **Space Admin permissions** to do this.
2. Choose **Themes** and select a theme option.
3. Choose **Confirm**.

**Screenshot: Applying a theme**

If your space is using the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   *Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **Themes** from the space administration options
3. Select a theme option.
4. Choose **Confirm**.

**Applying the Documentation theme to your site**

If you have **site administrator** permissions, you can apply the theme at site level. It will then be the default theme for all spaces in the site. See the administrator's guide to **applying a theme**.

**Customising the Documentation theme**

The theme works well without any customisation. If necessary, you can restrict the search to just one space, change the content of the left-hand navigation panel and add your own header and footer. The following instructions assume you have already applied the Documentation theme.

**To customise the Documentation theme:**

1. Choose **Browse > Space Admin** at the top of the screen.
   *Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **Themes** in the left-hand panel under the heading 'Look and Feel'.
3. Choose **Configure theme** in the yellow area of the 'Current Theme' section at the top of the page. See
screenshot below. The 'Documentation Theme Configuration' screen appears. See screenshot below.

4. Select or deselect the **Page Tree** check box. This determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.

5. Select or deselect the **Limit search results to the current space** check box.
   - If you select the check box:
     - The Confluence search will look for matches only in the current space by default. Users can override this restriction when entering their search term. See Using the Documentation Theme.
     - The default page tree in the left-hand panel will not include a search box.
   - If you do not select the check box:
     - The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
     - The default page tree in the left-hand panel will include a search box, which restricts search results to the current space.

6. Enter text, images, macros and other wiki markup into any or all of the three text boxes.
   - You can use the **Include** or **Excerpt Include** to include re-usable content into your footer. See hint below.
   - 'Navigation' – This text box contains content for the left-hand panel.
     - If the **Page Tree** check box is selected, the navigation panel contains the default search box and page tree. Any content you enter into the 'Navigation' text box will appear **above** the page tree and search box.
     - You can include your own content **underneath** the page tree as well as above. See hint below. In summary: Deselect the **Page Tree** check box. Insert your own page tree using the **Page Tree** macro, then add your own content under the macro.

   - 'Header' – This text box contains content for a page header that will appear above the page title on all pages in the space. See example screenshot below.

   - 'Footer' – This text box contains content for a page footer that will appear after the comments and above the site footer, on all pages in the space. See example screenshot below.

7. Choose **Save**.

**Screenshot: The 'Configure theme' option**
Current Theme

The current theme controls the layout and colours of this space.

**Documentation Theme**

This theme is well suited for structured content, such as documentation. It features a table of contents (page tree) on the left, making it easier to see the structure of a space and move from page to page. You can customise the left-hand panel, page header and page footer.

Configure theme - further customise this theme's options

Choose New Theme

To change the theme of this space, select one below.

- **Global Look and Feel**

  The globally configured look and feel. You can customise colour-schemes and layouts manually.

Find more themes...

Confirm

Screenshot: Customising the Documentation theme
Customising the theme at site level

If you have site administrator permissions, you can apply and customise the theme at site level. The customisation options are the same as the space level options, as described above.
Features of the Documentation theme

Screenshot: A customised header, footer and left-hand panel

The above screenshot shows a wiki space with a customised left-hand panel, header and footer.

Here is a summary of the features that the Documentation theme provides:

- By default, the left-hand panel contains a search box and a table of contents (page tree) showing all the pages in your space. Specifically, it shows the pages that are children of the space's home page.
- The left-hand panel is fully customisable. You can choose to include or exclude the search box and page tree. You can enter your own text, images and wiki markup.
- People viewing the page can drag the thick bar between the left-hand panel and the content, to increase or decrease the width of the panel. They can also remove the panel altogether, by clicking the sidebar icon at top right, next to the search box.
- The left-hand and right-hand panels scroll independently of each other.
- The page title is neatly above the page content, and not uncomfortably above the navigation panel as tends to happen when you insert the navigation panel yourself.
- Because the left-hand panel is part of the theme, it will be upgraded whenever Confluence is upgraded. There is no need to remove and then re-apply your customisations on each upgrade, as you would do if you added your own left-hand navigation bar.
- The theme also provides a customisable header and footer, which will appear at the top and bottom of every page.
- The text and heading styles are designed to enhance the content typically found in a documentation space.
- You can use the Space Jump macro to link from a page in one wiki space to a page with the same name in another space, without knowing the name of the page when you create the link.
- You can limit the Confluence search results to the current space. If you choose this option, the Confluence search will look for matches only in the current space by default. Users can override the restriction. See Using the Documentation Theme.
**Hints and tips**

Below are some hints that you may find useful when using the Documentation theme.

Where can I see a working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme’s table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page. Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

**Cause 1: Your pages are not under the space’s home page.** The most probable reason why your pages do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space’s home page. If your pages are above the home page in the page tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

- You can change the designated space home page in the space administration section.
- Or you can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the ‘Pages’ section of the space ‘Browse’ screen. See Moving a Page.

**Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with Documentation theme bundled.** If your existing Confluence installation already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar icon at top right, next to the search box. Click the icon again to restore the panel.

Can I change the default width of the left-hand navigation panel?

The Confluence user interface does not offer a way to change the default width of the left-hand navigation panel supplied by the Documentation theme. Users can change the width by dragging the middle bar, but the default width is not configurable. This post on Atlassian Answers gives a way to do it with CSS: Documentation Theme - Default Width (in px) of left panel.

Hiding pages from the left-hand table of contents

You can ‘hide’ pages by putting them at the same level as or higher than the space home page.

Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page.

If your documentation pages are at the same level as the space home page, they will not appear in the left-hand navigation bar. So you can ‘hide’ pages by putting them at the same level as or higher than the space home page. The pages will show up in the search results and people can see the content if they open the page, but the pages will not appear in the left-hand panel.

More detail: The theme uses the Pagetree macro to produce the table of contents. When entering the Pagetree macro, you can choose the top page in the page tree. The Documentation theme chooses the space home page as the top page.

Using reusable content in your header, footer or sidebar
You can use any text or wiki markup in your theme header, footer or left-hand panel. One useful hint is to use the Include or Excerpt Include to include re-usable content into your footer.

The screenshot above shows the theme customisation options, with examples of the macros used to include content from other pages. And the example screenshot also above shows the resulting header, footer and left-hand panel.

Adding content below the page tree in your sidebar

If you want to include your own content underneath the page tree, you can deselect the ‘Page Tree’ check box, add your own page tree using the Pagetree macro in the ‘Navigation’ text box, and then add your own content under the macro.

The screenshot above shows the theme customisation options, with the default page tree deselected and a custom page tree inserted, along with additional content in the left-hand panel. The example screenshot also above shows the resulting left-hand panel.

Adding an expanding All Versions section to the sidebar

If you want to include a an expanding list of links to other spaces, as we have included in this space (see ‘Docs for all Confluence releases’ in the sidebar), you can use an Expand Macro and an Include Page Macro in the ‘Navigation’ text box. For example:

```markdown
*{Docs for all Confluence releases|_Latest Versions of Confluence Documentation}*  
{expand:Choose a version...}  
{include:_Latest Versions of Confluence Documentation}  
{expand}
```

If you would like this to display below the page tree, follow the steps above.

Adding underlines to your links

By default, the Documentation theme does not underline hyperlinks. If you prefer to have your links underlined, you can edit the CSS stylesheet for your space and add the following CSS code:

```css
.wiki-content a:link, .wiki-content a:visited, .wiki-content a:active {  
  text-decoration: underline;  
}
```

To edit a space’s CSS style sheets:

1. Go to the space and choose Space tools > Look and Feel on the sidebar.
2. Choose Stylesheet then Edit.
3. Paste your custom CSS into the text field.
4. Save your changes. The new CSS will be visible on all content pages in the space.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.  
   Note: The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Click Stylesheet in the left-hand panel under the heading 'Look and Feel'.
3. Choose Edit.
4. Paste your custom CSS into the text field.
5. Save your changes. The new CSS will be visible on all content pages in the space.

Notes:

- You need system administrator permissions to edit the CSS for a space or for the site.
- This function is turned off by default. To turn it on, go to Gear > General Configuration > Security Configuration and choose Custom Stylesheets for Spaces.

Jumping to the same page in another space
The \{spacejump\} macro is provided along with the Documentation theme. You can use space jumping to link from a page in one wiki space to a page with the same name in another space, without knowing the name of the page when you create the link. When a reader is viewing a page and chooses the link provided by the macro, they will go to a page with the same name, but in the space specified in the macro. See more about the Space Jump macro.

Hiding the left-hand panel completely

It's not possible to remove the left-hand panel entirely, using the user interface supplied by the theme. There is an improvement request here:

[X CONF-25923] - Provide option to hide the left-hand panel entirely in the Documentation theme

If you like, you can comment on and/or vote for that request. In the meantime, Atlassian Answers is a good place to ask the question and see if other people can help you with custom code to remove the panel.

Notes

- The Confluence default theme supplies a sidebar, which is different to the left-hand panel in the Documentation theme. For information about the sidebar, see Finding Content and Configuring a Sidebar.
- The Documentation theme supplies a Browse menu in the Confluence header, which gives access to the space administration and advanced options.

Configuring a Sidebar

The default theme and documentation theme in Confluence both feature a left sidebar.

This page outlines how to customise the sidebar in the default theme. To find out how to customise the sidebar in the documentation theme, see Configuring the Documentation Theme.

You need space administrator permissions to configure the sidebar. See Space Permissions. Any changes you make to the sidebar will be visible to all Confluence users viewing that space.

To configure a space's sidebar:

1. Go to the space and choose Space tools > Configure sidebar on the sidebar.
2. Change the space name and/or space logo:
   - Choose the edit icon next to the space name.
   - Type in a space Name.
   - Browse to find an image for the space Logo, and crop the image to the required size.
   - Choose Save.
3. Configure the Pages and Blog links:
   - Choose the icons to hide or show the 'Pages' or 'Blog' link. For example, you may want your space to be used primarily as a blog (hide the 'Pages' link) or you may not need a blog in your space (hide the 'Blog' link).
   - Drag the links to a different sequence within the section. Note that you cannot move a link from one section to another.
   - Note that add-ons may add other links in this section of the sidebar. For example, the Team Calendars add-on may put a link in this location.
4. Add or remove the shortcut links:
   - Choose Add link to add a shortcut link to the sidebar. This can be a link to an important page for your team, or to an external site, for example.
   - Choose the icon to remove a shortcut link.
   - Drag the links to a different sequence within the section. Note that you cannot move a link from one section to another.
   - Choose the hide or show icon beside the 'Space Shortcuts' heading to show or hide all shortcuts on the sidebar.
5. Change the navigation display options:
   - Choose Child pages to see the current page and its children in the sidebar.
   - Choose Page tree to see the page tree for the entire space, expanded to the current page.

Related pages:

- Finding Content
- Administering a Space
- Confluence User's Guide

Screenshot: Configuring a space's sidebar
Notes

The default theme and Documentation theme both feature a sidebar. If you are using a third party theme it may not feature a sidebar.

**Changing a Space's Logo**

In Confluence, you can replace the default logo for a space with an image of your choice. The instructions below apply to site spaces. For your personal space, your profile picture is used as the space icon.

You need to be a space administrator to replace a space’s logo.

**To change a space's logo, in spaces using the default theme:**

1. Go to the space and choose Space tools > Configure sidebar on the sidebar.
2. Choose the edit icon next to the space name.
3. Choose Choose File.
4. Browse to find and upload an image.
5. Adjust the size of the highlighted circle on the image, to crop the image to the required size.
6. Choose Save.

**To change a space's logo, in spaces using the Documentation theme:**

1. Choose Browse > Space Admin at the top of the screen.
   
   *Note:* The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Change Space Logo in the left-hand panel.
3. Use the browse option to locate the new logo and choose Upload.

**Related pages:**

- Configuring a Sidebar
- Customising the Look and Feel of a Confluence Space
- Confluence User’s Guide
Customising Space Layouts

You can modify Confluence’s look and feel by editing the layout files. This page tells you how to customise the layout files for a space. You will require need space administrator permissions for that space.

Confluence system administrators can also customise the layout of their entire Confluence site as a whole. For more information, please refer to Customising Site and Space Layouts. Site layout customisations modify the default layout of all spaces in the Confluence site.

Any space layout customisations will override the equivalent site customisations.

If you modify the look and feel of Confluence by following these instructions, you will need to update your customisations when Confluence is upgraded. The more dramatic the customisations are, the harder it will be to reapply your changes when upgrading. Please take this into account before proceeding with any customisations.

For more information on updating your customisations, please refer to Upgrading Customised Site and Space Layouts.

Related pages:
- Customising the Look and Feel of a Confluence Space
- Applying a Theme to a Space
- Confluence User’s Guide.

Confluence is built on top of the Open Source SiteMesh library, a web-page layout system that provides a consistent look and feel across a site. SiteMesh works through 'decorators' that define a page's layout and structure.

To edit the layout of Confluence, you will need to modify these decorator files. A decorator file is a .vmd file and
is written in a very simple programming language called Velocity. Learn more about Velocity. Once you become familiar with Velocity, you can edit the decorator files to personalise the appearance of Confluence.

The decorator files in Confluence are grouped into the following categories:

- **Site layouts**: These are used to define the controls that surround each page in the site. For example, if you want to make changes to the header and the footer, you will need to modify these layouts.

- **Content layouts**: These control the appearance of content such as pages and blog posts. They do not change the way the pages themselves are displayed, but they allow you to alter the way the surrounding comments or attachments are shown.

- **Export layouts**: These control the appearance of spaces and pages when they are exported to HTML. If you are using Confluence to generate a static website, for example, you will need to modify these layouts.

Learn more about using *decorators*.

**To edit a decorator file:**

1. Go to the space and choose **Space tools > Look and Feel** on the sidebar.
2. Choose **Layout** (*Layout* is displayed only if you are a Confluence system administrator.)
3. You will see a list of the layouts for the space.
   - Click **View Default** to view the vmd file.
   - Click **Create Custom** to edit the default vmd file. This will open up the vmd file in edit mode.
     Make changes and click **Update**.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   *Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).*
2. Choose **Layout** in the left-hand panel (*Layout* is displayed only if you are a Confluence system administrator.)
3. You will see a list of the layouts for the space.
   - Click **View Default** to view the vmd file.
   - Click **Create Custom** to edit the default vmd file. This will open up the vmd file in edit mode.
     Make changes and click **Update**.

**Screenshot : Edit Layouts Example**

### Export Layouts

Export layouts control the appearance of spaces and pages when they are exported to HTML. If you are using Confluence to generate a static website, or you commonly distribute HTML exports of pages or spaces, you will probably want to modify these layouts.

<table>
<thead>
<tr>
<th>Decorator</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Space Export Layout</strong></td>
<td>When you export a space to HTML, this layout is used to create the index page.</td>
</tr>
<tr>
<td><strong>Page Export Layout</strong></td>
<td>When you perform an export, each page is converted to HTML using this layout.</td>
</tr>
</tbody>
</table>

Click the thumbnail to see an example of a vmd file:
Editing a Space's Colour Scheme

Confluence allows you to customise the colour scheme of a space. By default, a space’s colour scheme is based on global settings configured from the Administration Console.

You need to be a space administrator to edit a space’s colour scheme.

**Related pages:**
- Customising the Look and Feel of a Confluence Space
- Confluence User’s Guide

To change the colour scheme for a space:

1. Go to the space and choose Space tools > Look and Feel on the sidebar.
2. Choose Colour Scheme.
3. Choose Select next to a scheme listed under Custom Colour Scheme (if not already selected).
4. Choose Edit.
5. Enter standard HTML/CSS2 colour codes, or use the colour-picker to choose a new colour from the palette provided. Any changes you make will immediately be reflected in this space.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   *Note: The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Colour Scheme under the heading Look and Feel.
3. Follow the steps above to select a custom colour scheme and edit the colours.

The colour scheme allows you to edit the colours of UI elements including the top bar, tabs and backgrounds.

Some UI elements below are for specific themes, and colour changes may not take effect for other themes.

- **Top Bar** - the top navigation bar background
- **Top Bar Text** - the text on the top navigation bar
- **Header Button Background** - buttons on the top navigation bar (e.g. Create button)
- **Header Button Text** - the text on buttons on the top navigation bar
- **Top Bar Menu Selected Background** - background colour of top navigation bar menu items when selected (e.g. spaces)
- **Top Bar Menu Selected Text** - text colour of top navigation bar menu items when selected
- **Top Bar Menu Item Text** - text on top navigation bar drop down menus (e.g. help or cog)
- **Menu Item Selected Background** - highlight colour on top navigation bar drop down menu items
- **Menu Item Selected Text** - text colour on highlighted top navigation bar drop down menu items
- **Page Menu Selected Background** - the background colour of the drop down page menu when selected
- **Page Menu Item Text** - the text of the menu items in the drop down page menu
- **Heading Text** - all heading tags throughout the space
- **Space Name Text** - the text of the current space name located above the page title
- **Links** - all links throughout the space
- **Borders and Dividers** - table borders and dividing lines
- **Tab Navigation Background** - the background colour of the tab navigation
- **Tab Navigation Text** - the text of the tab navigation when highlighted
- **Tab Navigation Background Highlight** - the background colour of the tab navigation when highlighted
- **Tab Navigation Text Highlight** - the text of the tab navigation elements when highlighted

**Screenshot: Editing the colour scheme**

![Custom Colour Scheme]

**A custom colour scheme which can be edited.**

- **Top Bar** #205081
- **Top Bar Text** #FFFFFF
- **Header Button Background** #387FC4
- **Header Button Text** #FFFFFF
- **Top Bar Menu Selected Background** #3873AF
- **Top Bar Menu Selected Text** #FFFFFF
- **Top Bar Menu Item Text** #333333
- **Menu Item Selected Background** #3873AF
- **Menu Item Selected Text** #FFFFFF
- **Page Menu Selected Background** #3873AF
- **Page Menu Item Text** #333333
- **Heading Text** #333333
- **Space Name Text** #990099
- **Links** #3873AF
- **Borders and Dividers** #CCCCCC
- **Tab Navigation Background** #3873AF
- **Tab Navigation Text** #FFFFFF
- **Tab Navigation Background Highlight** #205081
- **Tab Navigation Text Highlight** #FFFFFF

[Reset][Save][Cancel]
Styling Confluence with CSS

The information in this page relates to customisations or development changes in Confluence. Consequently, Atlassian Support cannot guarantee to provide any support for the steps described on this page. Please be aware that this material is provided for your information only and that you use it at your own risk.

This page explains the facility for changing the look and feel of Confluence with CSS.

Introduction

Cascading Style Sheets (CSS) are an industry-standard way of styling a web page. The content of a page is rendered with HTML, and its look and feel is determined by CSS files. You can upload a CSS text file, or simply type in a stylesheet, and apply it to a space or even a whole Confluence site.

Notes:
- You need system administrator permissions to edit the CSS for a space or for the site.
- This function is turned off by default. To turn it on, go to General Configuration > Security Configuration and choose Custom Stylesheets for Spaces.

Creating CSS styles that work seamlessly across different browsers is a delicate task for basic web sites, and reasonably challenging when customising web applications like Confluence. It is important to test each change that you make and ensure it works as expected in all areas of Confluence – for example, on the Confluence dashboard as well as on regular pages.

In order to get you started, we have compiled this introduction, a basic styling tutorial.

On this page:
- Introduction
- Considerations for Using Custom CSS
- Getting Started
- CSS Resources

Related pages:
- Basic Styling Tutorial
- Styling Fonts in Confluence
- Confluence User's Guide

Considerations for Using Custom CSS

CSS Knowledge is Required

If you are not familiar with CSS, see the links in the CSS Resources section below. You should spend some time to become confident with Cascading Style Sheets before you start editing your Confluence style sheets.

Security

Custom CSS can be used to inject scripts into a page, opening the risk of cross-site scripting (XSS) attacks. With this feature enabled, space administrators could upload styles that steal other users' login credentials, trick their browsers into performing actions on the wiki without their knowledge, or even obtain global administration privileges. As such, this feature is disabled by default. Confluence administrators should only enable custom CSS if they are comfortable with the risks listed in this paragraph.

Scaling

Each page needs to scale. Depending on the resolution of the user's screen, the content should render
intelligently. Your designs needs to degrade gracefully. Try resizing each page that exists in Confluence. There are quite a few pages in the browse-space-section, like drafts, labels, page hierarchy, and so on. Your style has to work everywhere, not just in the first page you happen to be looking at.

**Features Cannot Be Disabled**

It is easy to turn off certain links, headers, or even menu items by simply setting their style to 'hidden'. This can help you to roll out Confluence to users that may not be very Wiki-savvy yet. The simpler the UI, the easier it may be for them to use. However, please remember that removing the link to a part of the application does not mean that the functionality is not available. Every user can still change their style from within their browsers, or access the URL directly. Don't rely on CSS to disable parts of Confluence.

**Features Should Not Be Disabled**

Users familiar with Confluence will expect to find the same controls that they are accustomed to. Removing buttons or controls from the interface is not advised as it may frustrate your users and cause them to circumvent your design by using direct URL access, as mentioned above.

**Custom CSS does not apply to Admin screens**

Any CSS styling applied to your site will not be applied to the Administration console. This is to ensure changes to CSS do not prevent administrators from accessing Admin functions in future.

**Confluence Version Compatibility**

Be aware of any plans to upgrade your Confluence instance. Future versions of Confluence may not be compatible with your custom CSS — this may cause your CSS to break, requiring maintenance when Confluence is upgraded. Ask your Confluence administrator for more information.

**Test on Different Web Browsers**

As a rule you should test your modifications on different web browsers. Internet Explorer, Firefox, Opera and Safari (on Mac OS X) are some of the more popular browsers.

**Note about supported web browsers:** Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. Check the Supported Platforms page to find the list of supported web browsers and browser versions on this page.

**CSS Customisation is Not Supported**

As creating custom CSS has potentially limitless possibilities, Atlassian will not support issues that are caused by or related to CSS customisation.

### Getting Started

#### Editing the CSS

**To edit a space's CSS style sheets:**

1. Go to the space and choose **Space tools > Look and Feel** on the sidebar.
2. Choose **Stylesheet** then **Edit**.
3. Paste your custom CSS into the text field.
4. Save your changes. The new CSS will be visible on all content pages in the space.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   *Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).*
2. Click **Stylesheet** in the left-hand panel under the heading 'Look and Feel'.
3. Choose **Edit**.
4. Paste your custom CSS into the text field.
5. Save your changes. The new CSS will be visible on all content pages in the space.

**To edit your global CSS stylesheet:**
1. Choose the cog icon, then choose General Configuration under Confluence Administration.
2. Choose Stylesheet.
3. Choose Edit.
4. Paste your custom CSS into the text field.
5. Choose Save.

Note:
- The new CSS will be visible across all spaces, provided they do not define their own custom stylesheets and are not using a theme. This CSS will also overwrite all styles defined in custom global themes.
- You may be able to add CSS to your site by choosing Custom HTML in the administration section, and adding your CSS definitions to the HEAD or BODY of the page. You should only use this option if you cannot achieve the desired results via the global stylesheet.

Follow the Tutorial
Follow the examples in the Basic Styling Tutorial to get started.

CSS Resources
- W3C CSS Standards
- W3schools CSS Introduction
- Mozilla Developer Network
- W3resource.com

Basic Styling Tutorial
This page contains instructions on how to get started with custom CSS styling in Confluence.

CSS Editing Quick-Start
To edit a space’s CSS style sheets:
1. Go to the space and choose Space tools > Look and Feel on the sidebar.
2. Choose Stylesheet then Edit.
3. Paste your custom CSS into the text field.
4. Save your changes. The new CSS will be visible on all content pages in the space.

If your space uses the Documentation theme:
1. Choose Browse > Space Admin at the top of the screen.
   *Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Click Stylesheet in the left-hand panel under the heading 'Look and Feel'.
3. Choose Edit.
4. Paste your custom CSS into the text field.
5. Save your changes. The new CSS will be visible on all content pages in the space.

On this page:
- CSS Editing Quick-Start
- Tutorial: Changing the Header Background
- CSS Editing Tips
- Notes

Related pages:
- Styling Confluence with CSS
- Confluence User’s Guide

⚠️ The information on this page does not apply to Confluence OnDemand.

Tutorial: Changing the Header Background
The header is the menu area at the top of a default Confluence page where the Breadcrumb Links, Browse menu, User menu and the Quick Search box reside. In this example, we are going to change the background of
the header to include a custom graphic.

1. Create a custom graphic. For this example, we created a custom header graphic of 1046 x 61 pixels.
2. Upload the custom graphic to a page in the space that you are customising.
3. Note the page ID of the page where you uploaded the new graphic. (in this example, the page ID was '658833839'.
4. Compose your custom CSS for the header. The example below loads the new graphic (called 'header.png') from a specific page (denoted by page ID '658833839') in the same space.

```css
#header .aui-header {
  background-image:url('../download/attachments/658833839/header.png');
  background-repeat: no-repeat;
}
```

5. Log in as the Space Administrator.
6. Open the Space Admin page.
7. Click Stylesheet.
8. Click Edit to change the code in the text field.
9. Paste your custom CSS into the text field.
10. Click Save and then reload the page (you may have to shift-reload). The background of the header will change.
11. The custom header will be visible on all content pages in the space. To revert your change, simple delete the custom code from the 'Stylesheet' page and click Save.

**CSS Editing Tips**

**Begin With a Space Stylesheet**

A space stylesheet is a good starting point for CSS customisation, as it already includes all of the elements that can be changed. When you work on the space stylesheet it styles all content pages in the space. Build and test it at space-level, before considering applying the new stylesheet to your entire site. Once you are satisfied with your space design, test it thoroughly until you are confident that it has no problems. Then, you can look into advanced customisation of the Confluence CSS such as adjusting the Search page, the Dashboard and other integral pages.

**Use the Right Tools**

As the Confluence CSS is reasonably sophisticated, web development applications will help you to understand how the page styles have been created. In particular, you will need to view the existing source for the pages you're starting to work on. If you don't already have some, tools such as the following free applications will allow you to do this.

1. **Firebug**
   Firebug, a plugin for the Firefox web browser, allows you to take a look at the style of each element on your page. This is very useful to see what styles are currently applied, for example styles applied to the header only.

2. **Web Developer**
   The Web Developer plugin for Firefox allows you to edit CSS inline and create new page designs.

3. **CSS Edit**
   CSS Edit is a stand-alone CSS editor for Macintosh that extracts all existing styles from a given page and allows you to overwrite these.

**Edit Simple Elements First**

Begin by editing simple elements and checking that they work. By making changes, then checking that each one worked, you can easily isolate any CSS code that is causing problems. Be aware that some page elements are more suited to customisation than others. For example, adding a gradient to the toolbar is less likely to 'break' the page than changing the page width. Editing reasonably static elements such as background graphics will render more predictably than designs which attempt to completely change the user interface or the Javascript-powered drop-down menus (which we don't recommend editing).

**Notes**
Notes:

- You need **system administrator** permissions to edit the CSS for a space or for the site.
- This function is turned off by default. To turn it on, go to [General Configuration] > Security Configuration and choose Custom Stylesheets for Spaces.

**Styling Fonts in Confluence**

Confluence provides the ability to adjust its visual style via Cascading Style Sheets (CSS). This tutorial shows you to change the fonts and font sizes of a Confluence page, using a few lines of CSS.

**Screenshot 1: Default font in a Confluence page**

Below is the code for the custom font. Copy and paste it into the Space Stylesheet form within the Space Administration section.

**Screenshot 2: Custom font in a Confluence page**

In order to customise the fonts in Confluence, you first need to set the body font to the font you want. Secondly, you may want to adjust the font size because different fonts have different relative sizes.

The relevant CSS is shown below. It changes Confluence's font from the default of Helvetica/Arial – *sans serif* to Times/Times New Roman – *serif*. To adjust for the fact that Times is a bit smaller than Helvetica, we increase the font size to 14 pixels. The many styles that 'wiki-content' in their definition are necessary to change the font size for all the tags in the wiki content.

---

**Related pages:**
- Basic Styling Tutorial
- Confluence User's Guide

⚠️ The information on this page does not apply to Confluence OnDemand.

---
Notes

Notes:

- You need system administrator permissions to edit the CSS for a space or for the site.
- This function is turned off by default. To turn it on, go to General Configuration > Security Configuration and choose Custom Stylesheets for Spaces.

Requesting Add-ons

The Atlassian Marketplace website offers hundreds of add-ons that the administrator of your Atlassian application can install to enhance and extend Confluence. If the add-on request feature is enabled for your Confluence instance, you can submit requests for add-ons from the Marketplace to your Confluence administrator.

The ‘Atlassian Marketplace for Confluence’ page provides an integrated view of the Atlassian Marketplace from within your Confluence instance. The page offers the same features as the Marketplace website, such as searching and category filtering, but tailors the browsing experience to Confluence.

This in-product view of the Marketplace gives day-to-day users of the Atlassian applications, not just administrators, an easy way to discover the add-ons that can help them work. When you find an add-on of interest, you can submit a request with just a few clicks.

Submitting an add-on request

To browse for add-ons in the Atlassian Marketplace, follow these steps:

1. Choose your profile picture at top right of the screen, then choose Atlassian Marketplace.
2. In the Atlassian Marketplace page, use the search box to find add-ons or use the category menus to browse or filter by add-ons by type, popularity, price or other criteria. You can see what your fellow users have requested by choosing the Most Requested filter.
3. When you find an add-on that interests you, click Request to generate a request for your administrator.
4. Optionally, type a personal message to your administrators in the text box. This message is visible to administrators in the details view for the add-on.
5. When ready, click **Submit Request**.
6. Click **Close** to dismiss the ‘Success!’ message dialog box.

At this point, a notification appears in the interface your administrators use to administer add-ons. Also your request message will appear in the add-on details view, visible from the administrator’s ‘Find New Add-ons’ page. From there, your administrator can purchase the add-on, try it out or dismiss requests.

### Updating an add-on request

After submitting the request, you can update your message at any time. Click the **Update Request** button next to the listing in the Atlassian Marketplace page to modify the message to your administrator.

The administrator is not notified of the update. However, your updated message will appear as you have modified it in the details view for the add-on immediately.

### Giving People Access to Content

Confluence gives you the choice to make the site as open or as closed as you wish. Here are some points to consider:

- As a tool for communication and collaboration, Confluence is at its best when all your users can participate fully.
- So it is advisable not to restrict users unless you have a good reason for doing so.
- Confluence keeps a history of all changes to pages and other content. So it is easy to see who has changed what, and to reverse any edits if required.

### Levels of permission

There are three levels of permissions in Confluence.

#### Global permissions

**Global permissions** are site-wide permissions, and are assigned by administrators:

- **System Administrator** - Users with this permission can perform all the Confluence administrative functions. These users can assign permissions to other users.
- **Confluence Administrator** - Users with this permission can perform most of the Confluence administrative functions, but excluding those functions which could compromise the security of the Confluence system. These users can assign permissions to other users.

For full details, please refer to the overview of global permissions in the **Administrator's Guide**.

#### Space permissions

The permission to create a new space or to administer one is granted by a **Confluence Administrator** from the
global Administration Console.

Every space has its own independent set of permissions. These permissions determine the access settings for different users of the space. In order to assign these permissions to other users, a user must be a space administrator i.e. must have the 'Admin' permission for that space.

See Users and Groups to learn how these permissions are assigned.

**Note:** If you misconfigure a space so that nobody has access to administer it any more, a Confluence Administrator will need to fix the permissions for you.

### Page restrictions

You can set page-level restrictions, if you have the 'Restrict Pages' permission within the space concerned.

Page restrictions allow you to control who can view or edit individual pages. To set page restrictions, edit the page and use the page restriction options below the text-entry box.

**Example:** In the HR (Human Resources) space, everyone in the organisation has the 'View' space permission, but only the HR team has the 'Pages --> Create' space permission (i.e. the ability to create and edit pages in the space). A member of the HR team starts to create a new page called 'Annual Leave Policy'. Because the page is not yet finished, she sets the 'Viewing' page restriction so that only the HR team can view the page. When the page is finished, she will remove the 'Viewing' restriction so that everyone in the company can see the page.

### Related pages:

- Users and Groups
- Global Permissions Overview
- Space Permissions Overview
- Page Restrictions
- Configuring Confluence Security
- Confluence User's Guide
- Confluence Security Overview and Advisories

### More information

**How do space permissions and page restrictions work together?**

**Example:** In the HR (Human Resources) space, everyone in the organisation has the 'View' space permission, but only the HR team has the 'Pages --> Create' space permission (i.e. the ability to create and edit pages in the space). A member of the HR team starts to create a new page called 'Annual Leave Policy'. Because the page is not yet finished, she sets the 'Viewing' page restriction so that only the HR team can view the page. When the page is finished, she will remove the 'Viewing' restriction so that everyone in the company can see the page.

How do space permissions and page restrictions affect links?

Space permissions and page restrictions affect how links between pages are displayed to a visitor:

- if the link points to a page in a space to which the visitor does not have 'View' space permission, the link will not be rendered at all.
- if the visitor has 'View' space permission, but page restrictions prohibit her from viewing the page, the link will be rendered but an 'Access Denied' message will be displayed when she clicks the link.
- if the visitor has 'View' space permission, and is not restricted from viewing the page, the link will display and behave as normal.

Links to attachments are also affected: If the visitor does not have permission to view the page to which the attachment is attached, the link will not be rendered.

### Page Restrictions

Page restrictions allow you to control who can view or edit individual pages in a space.
To add or remove restrictions to a page you will need to have permissions to edit the page and 'Restrict' or 'Admin' permission in the space.

About page restrictions and space permissions

Confluence permissions are hierarchical, so page restrictions will not override any space permissions for the user or group.

For example, if you restrict viewing or editing a page to a user who does not have 'view' permissions for the space, they will not be able to see the page, as the page level restrictions cannot override their space permissions.

Some page restrictions are inherited. If you restrict viewing a page to a user or group, all children of that page will also be restricted to the user or group. Edit page restrictions are not inherited.

Adding restrictions to a page

You can restrict viewing a page or editing a page to a specific user or group.

**To restrict viewing or editing a page to a user or group:**

1. Go to the page and choose **Tools > Restrictions**.
2. Choose **Restrict viewing of this page** or **Restrict editing of this page**.
3. Enter part of user or group name, and then choose the appropriate user or group from the autocomplete drop down. You can add multiple users and groups.

The page restrictions have now been applied:

- Viewing the page is now restricted to the users and / or groups listed. All other users will not be able to view the page. Any children of this page will inherit the viewing restrictions.
- Editing the page is now restricted to the users and / or groups listed. All other users will be able to view, but not edit, the page.

**On this page:**

- About page restrictions and space permissions
- Adding restrictions to a page
- Viewing the current page restrictions
- Removing restrictions from a page
- Request and grant access to view a restricted page
- Viewing all restricted pages in a space
- Notes

**Related pages:**

- Working with Pages
- Confluence User’s Guide

Viewing the current page restrictions

Confluence displays a padlock icon on the byline when a page has current viewing or editing restrictions.

Screenshot: Byline showing page restrictions icon.

To view the restrictions:
1. Go to the page and:
   - choose **Tools > Restrictions**, or
   - choose the padlock icon on the byline, or
   - choose the **Restricted** button on the footer, if you are in the editor.
2. The Page Restrictions dialog appears, listing the users and / or groups that have restrictions applied.

   **Screenshot: Page Restrictions dialog showing viewing restricted to the ‘developers’ group and editing restricted to two users.**

Removing restrictions from a page

**To remove restrictions from a page:**

1. Go to the page and:
   - choose **Tools > Restrictions**, or
   - choose the padlock icon on the byline, or
   - choose the **Restricted** button on the footer, if you are in the editor.
2. Choose **Remove** next to each restriction you would like to remove.

Request and grant access to view a restricted page

If you navigate to a page that you are not able to view because it has page restrictions applied (for example from a link or page URL) you may be able to request access to the page.

**To request access to a restricted page:**

1. On the restricted page choose **Request access**.
2. Wait for an email confirming that access has been granted.

If the request access message does not appear, you are not able to request access for that particular page. This usually is because the page has inherited restrictions from a parent page, or you may not have adequate space permissions.

**Screenshot: Request access message on a restricted page.**

**To grant access to a restricted page:**
1. In the request access email, choose **Grant access**.
2. You will be taken to the restricted page, a dialog will appear with the access request.
3. Choose **Grant access**.

The user will receive an email confirming that access has been granted.

This process is the same as navigating to **Tools > Restrictions** and adding a 'View' restriction for the user.

*Screenshot: Grant access to the page.*

---

**Who can grant access?**

To grant access to a restricted page you will need to have permission to edit that page, and have the 'Restrict' or 'Admin' permission for the space.

Confluence will send an email to the a user who can grant permissions - this will be either the last user (with appropriate permissions) to edit the page, the page creator or a space admin.

**Viewing all restricted pages in a space**

You need 'Admin' permissions to view the list of restricted pages in a space.

**To view restricted pages:**

1. Go to the space and choose **Space tools > Permissions** on the sidebar.
2. Choose **Restricted Pages**.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   
   *Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the **confluence-administrators** group).*

2. Choose **Restricted Pages** in the space administration options.

A list of all restricted pages in the space displays.

**Space Administrators can remove restrictions from a page**

*Screenshot: Restricted pages in a space*
Notes

- **Inherited restrictions**
  If a page has a ‘View’ restriction set, that restriction will be inherited by all its children (and their children, and so on). If a ‘View’ restriction is added to a child page that has already inherited page restrictions from its parent, users must satisfy both restrictions in order to see the page.

- **Space Admin and Confluence Administrator access to restricted pages**
  Users with ‘Admin’ permissions in a space, or members of the ‘confluence-administrators’ group can remove restrictions from pages, even if the page restriction prevents them from viewing the page. Go to [Space Administration > Restricted Pages](#).

- **You cannot exclude yourself**
  As creator or editor of a page, you cannot use page restrictions to deny yourself access to the page. Confluence will automatically add your username into the list of users/groups allowed to view/edit the page. If you remove your username, Confluence will put it back again.

### Site Administrators and their Permissions

All site administrative functions are performed from the Administration Console. You need ‘System Administrator’ or ‘Confluence Administrator’ permissions to access the Administration Console.

The Confluence permission scheme allows the following levels of site administrator permissions:

- **Super user** – A ‘super user’ belongs to the confluence-administrators group, has full administrative access to Confluence, and can see all the content.
- **System Administrator** – A person with ‘System Administrator’ permission has full administrative access to Confluence.
- **Confluence Administrator** – A person with ‘Confluence Administrator’ permission has access to most of the Confluence administrative functions.

Please refer to the overview of global permissions for full details.

**Related Topics**

- Users and Groups
- Confluence User's Guide

### Contacting Confluence Administrators

If you receive an error message from Confluence, the error page may offer you a link to click in order to contact the administrators of the Confluence site.

When you click the link to contact the Confluence administrators, you will see an administrator contact page with the title ‘Contact Site Administrators’. By default, the administrator contact page looks like the screenshot below.
In certain configurations of Confluence, you will not be able to use the form shown in the screenshot above. Instead, you will see a message telling you about one of the following conditions:

- If your Confluence administrator has not configured a mail server for Confluence, this means that Confluence will not be able to send an email message to the administrators.
- If none of the Confluence administrators has an email address, Confluence will not be able to send an email message to them.
- If there are no Confluence administrators defined to Confluence, Confluence will not be able to send an email message to them.
- The Confluence administrator can disable the form and specify a different message to be displayed on the above screen instead of the default message and form. See the administrator's guide.

Notes

You can also access this contact form using the following URL. Replace 'yoursite.com/wiki' with the correct path for your Confluence instance.
Space Administrators and their Permissions

A space administrator is a user with the ‘Space Admin’ permission for a space. This permission itself is assigned from the Space Administration screens by a space administrator.

Who is a space administrator?

The person who creates a space is automatically the administrator of that space. That person can then assign other space administrators as required.

To find the space administrator for a specific space:

1. Choose Spaces > Space directory on the header.
2. Choose the Space Details icon beside a space.
3. The space administrators are listed.

On this page:
- Who is a space administrator?
- What can a space administrator do?

Related pages:
- Space Permissions Overview
- Confluence User’s Guide

Confluence administrators are not necessarily space administrators.

- A user who has the 'Confluence Administrator' global permission is not automatically a space administrator for a particular space. In order for them to be a space administrator, they must belong to a group which has space administration rights on the space, or their username must be specifically granted space administration rights on the space.
- A user who has the 'System Administrator' global permission does automatically have space admin permissions for all spaces.

What can a space administrator do?

A space administrator has permission to do anything in the space regardless of any other setting. Space administrators are responsible for the management of a space and its contents. Note that page permissions affect space administrators differently from other users.

Space administrators can:

- view all content in the space. If there are page permissions that restrict the viewing of a page to a single user, or to a group to which the space administrator doesn’t belong, a space administrator can still view the page by removing the restriction.
- edit all content on any page in the space.
- remove restrictions from any page in the space (using the Space Administration interface).
- manage the watchers for any page in the space (but not watchers of the space).
- grant themselves any other space permissions (e.g. permission to set restrictions on a particular page).

All space administration functions, with the exception of managing watchers, are performed from the Space menu (choose Browse > Space Admin in the Documentation theme). You need to be a space administrator to access the Space Administration screens.

Space Permissions Overview

Every space has its own independent set of permissions. Space permissions can only be granted by a space administrator.

Permissions can be assigned to individual users, groups or anonymous users.

These are the permissions that can be assigned at the space level:
• **View:** user can view this space's content, including the space's details, and its pages and news items (blog posts)

• **Pages:**
  - Add – user may create and edit pages in this space.
  - Restrict – user may apply page-level restrictions.
  - Delete – user may delete pages in this space.

• **Blog:**
  - Add – user may add and edit blog posts in this space.
  - Delete – user may delete blog posts in this space.

• **Comments:**
  - Add – user may make comments in this space.
  - Delete – user may delete comments from this space.

• **Attachments:**
  - Add – user may add attachments in this space.
  - Delete – user may delete attachments from this space.

• **Mail:**
  - Delete – user may delete individual mail items.

• **Space:**
  - Export – user may export content from this space via the space-level export screens. Note that this permission does not affect the exporting of a single page's content. Anyone who has permission to view the page also has permission to export its content.
  - Admin – user has administrative permissions over this space.

**Related pages:**
- Space Administrators and their Permissions
- Users and Groups
- Assigning Space Permissions
- Page Restrictions
- Confluence User's Guide

**Notes**

**Warning:** If you deny all administrative access to a space by mistake, so that nobody has access to administer the space any more, you will need to ask someone with Confluence Administrator global permission to restore the permissions for you.

**Assigning Space Permissions**

You can assign space permissions to groups or to individual users. You need to be a space administrator to assign space permissions. In addition, Confluence administrators can set the default permissions that will be applied to new spaces as described below.

**To access the permissions for a space:**

1. Go to the space and choose **Space tools > Permissions** on the sidebar.
2. Choose **Edit Permissions**.

If your space is using the Documentation theme:

1. Go to the 'Space Permissions' page:
   - Choose **Browse > Space Admin** at the top of the screen.
   *Note:* The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
   - Choose **Permissions** from the space administration options.
2. Choose **Edit Permissions**.

The 'Edit Space Permissions' page is divided into the following sections:

- Groups – a list of groups which already have permissions to access the site.
- Individual Users – a list of users who already have permissions to access the site.
- Anonymous Access – the space permissions granted to all anonymous users of the site.
On this page:

- Assigning space permissions to groups
- Assigning space permissions to users
- Assigning space permissions to anonymous users
- Setting default space permissions
- Managing and Recovering Space Admin Permissions
- Notes

Related pages:

- Space Permissions Overview
- Users and Groups
- Confluence User’s Guide

Screenshot: Space permissions

---

## Groups

These are the permissions currently assigned to groups for this space.

<table>
<thead>
<tr>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Comments</th>
<th>Attachments</th>
<th>Mail</th>
<th>Space</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Add</td>
<td>Restrict</td>
<td>Delete</td>
<td>Add</td>
<td>Delete</td>
<td>Add</td>
</tr>
<tr>
<td>confluence-users</td>
<td>✔️</td>
<td>✗</td>
<td>✗</td>
<td>✔️</td>
<td>✗</td>
<td>✔️</td>
</tr>
</tbody>
</table>

[Edit Permissions]

## Individual Users

These are the permissions currently assigned to individual users for this space.

<table>
<thead>
<tr>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Comments</th>
<th>Attachments</th>
<th>Mail</th>
<th>Space</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Add</td>
<td>Restrict</td>
<td>Delete</td>
<td>Add</td>
<td>Delete</td>
<td>Add</td>
</tr>
<tr>
<td>Rach Admin [Administrator]</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
</tbody>
</table>

[Edit Permissions]

## Anonymous Access

When a user is using Confluence while not logged in, they are using it anonymously. For example: Enabling anonymous ‘commenting’ permission, allows non-logged-in users to make comments in this space.

<table>
<thead>
<tr>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Comments</th>
<th>Attachments</th>
<th>Mail</th>
<th>Space</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Add</td>
<td>Restrict</td>
<td>Delete</td>
<td>Add</td>
<td>Delete</td>
<td>Add</td>
</tr>
<tr>
<td>Anonymous</td>
<td>✗</td>
<td>✗</td>
<td>✗</td>
<td>✔️</td>
<td>✗</td>
<td>✔️</td>
</tr>
</tbody>
</table>
Assigning space permissions to groups

- To assign a permission, check the box next to the relevant group.
- To deny a permission, uncheck the relevant box.
- To add a new group to the list, type the group name into the text box in the 'Groups' section and choose Add. The group will appear in the list of groups. You can then assign the permissions.
- To search for a group:
  - Choose the icon.
  - The Group Search window opens. Enter all or part of the group name. You can use an asterisk '*' as a wild card.
  - Check the boxes to select the required group(s).
  - Choose Select Groups. The group name(s) will appear in the text box in the 'Groups' section.
  - Choose Add.
- To bulk assign or revoke group member permissions, choose either Select All or Deselect All from the Actions dropdown list.

Choose Save All to apply the changes.

Assigning space permissions to users

- To assign a permission, check the box next to the relevant user.
- To deny a permission, uncheck the relevant box.
- To add a new user to the list, type the username into the text box in the 'Individual Users' section and choose Add. The user will appear in the list of users, with 'View' permission assigned. You can then add more permissions if necessary.
- To search for a user:
  - Choose the icon.
  - The User Search window opens. You can read more about searching for users.
  - Check the boxes to select the required user(s).
  - Choose Select User(s). The username(s) will appear in the text box in the 'Individual Users' section.
  - Choose Add.
- To bulk assign or revoke individual user permissions, choose either Select All or Deselect All from the Actions dropdown list.

Choose Save All to apply the changes.

Assigning space permissions to anonymous users

- To assign a permission, check the box for the required permission.
- To deny a permission, uncheck the relevant box.
- To bulk assign or revoke anonymous user permissions, choose either Select All or Deselect All from the Actions dropdown list.

Choose Save All to apply the changes.

Note: You cannot grant space administration rights or page restriction rights to anonymous users.

Setting default space permissions

If you are a Confluence Administrator, you can set the default permissions that will be applied to new spaces. The default permissions are configurable for groups only, not for individual users or anonymous users.

To set the default space permissions:

1. Choose the cog icon, then choose General Configuration under Confluence Administration.
2. Choose Space Permissions under Security in the sidebar.
3. Choose Edit Permissions.

Screenshot: Default space permissions
Managing and Recovering Space Admin Permissions

Users with System Administrator permissions are able to manage permissions for spaces, including adding or removing Space Admin permissions for a space.

To manage space permissions:

1. Choose the cog icon \(\text{icon}\) then choose General Configuration under Confluence Administration.
2. Choose Space Permissions under Users & Security in the sidebar.
3. Locate the space in the Individual Spaces list and choose Manage Permissions.

There may be some instances where a space administrator has removed Space Admin permissions from all other users and groups for a space, meaning that no other user can administer the space. Users with Confluence Administrator permissions can recover permissions for the space in this instance.

To recover Space Admin permissions:

1. Choose the cog icon \(\text{icon}\) then choose General Configuration under Confluence Administration.
2. Choose Space Permissions under Users & Security in the sidebar.
3. Locate the space in the Individual Spaces list and choose Recover Permissions.

The user will then be able to choose Manage Permissions, and add any appropriate permissions to the space. Requests to recover permissions are recorded in the Confluence log files.

Notes

Assigning permissions in bulk. There is no way to change a number of space permissions at once, via the Confluence user interface. Instead, take a look at the Confluence Command Line Interface. Here is a link to the CLI documentation. For an introduction to the CLI, see this blog post: Confluence CLI for bulk actions like deleting or publishing pages.

Users and Groups

A 'user' is the account for an individual who accesses Confluence.

New users are created by an administrator via the Administration Console.

New users are created by administrators, who can also group users together into user groups for more convenient administration. This means that any permissions you assign at the site, space and page levels can be assigned to a whole group. A user in one of these groups will automatically be granted all permissions granted to the group.

There are two special groups in Confluence:
• **confluence-administrators** - these users have permissions to administer users and access the Confluence Admin console.
• **confluence-users** - this is the default group into which all new users are assigned. Permissions defined for this group will be assigned to all new Confluence users.

Your Confluence instance may include additional groups.

### Anonymous Users

Confluence treats all users who do not log in when they access Confluence as being ‘Anonymous’. Administrators can assign permissions to this group separately.

#### Overlapping group and user permissions

When a user is assigned more than one permission, the more powerful permission will prevail.

Further explanation:

- A user may be assigned a permission specifically to their username. They may also be assigned a permission by belonging to a group, or even several groups.
- The user will then be able to perform all functions assigned to them.
- So if a user is allowed to do something over and above what the group can do, the user will be able to do it. And if the group is allowed to do something over and above the specific permissions granted to the user, the user will still be able to do it.

### Searching for Users

This page describes how to use the 'User Search' window, which appears when you click **Choose Users** or a user search icon on a Confluence page.

#### Accessing the User Search

**To access the 'User Search' window:**

1. Choose the user search icon when you are performing one of the following actions:
   - When assigning space permissions, choose the **user search** icon in the users section.
   - When adding members to a group, choose the **user search** icon.

2. The simple 'User Search' window will appear, as shown below.
Using the Simple User Search

To search via the simple user search:

1. Select the User tab on the 'User Search' screen. (See above for instructions on accessing the screen.)
2. Enter information about the user in the User Details field, such as all or part of a username, full name or email address.
3. Choose Search.
4. Confluence will return a list of matching users. See below for instructions on selecting one or more users.

Screenshot: Simple user search

Searching for Users in One or More Groups

You can also list the users who appear in a particular group or in a set of groups.

To search for users in a particular group:

1. Select the Membership tab on the 'User Search' screen. (See above for instructions on accessing the screen.)
2. Enter all or part of a group name into the Group Membership field.
3. Choose Search.
4. Confluence will return a list of users belonging to any groups which match your search term.
5. Now you can select one or more users, as described below.

Screenshot: Searching for users in a group
Selecting One or More Users

After searching for users and receiving a list of names from Confluence, as described above, you can now select the user(s) you need.

To select one or more users:

1. Click the box next to the username(s) to select or deselect one or more users.
   You can click Check All to select or deselect all users.
2. Click Select User(s).
3. The 'User Search' window will close and the selected users will appear on the screen which you were using before you accessed the user search.

Notes

- **Case sensitivity:** The search is not case sensitive. You can enter either upper- or lower-case text, and it will make no difference to the search results.
- **Wild cards:** The search allows the asterisk as a wild card, but you do not need to use it. The search results will be the same whether you use a wild card or not. The wildcard functionality remains available for compatibility with older versions of Confluence.
- **Multiple user directories:** You may define multiple user directories in Confluence, so that Confluence looks in more than one place for its users and groups. For example, you may use the default Confluence internal directory and also connect to an LDAP directory server. In such cases, you can define the directory order to determine where Confluence looks first when processing users and groups.

Here is a summary of how the directory order affects the processing:
- The order of the directories is the order in which they will be searched for users and groups.
- Changes to users and groups will be made only in the first directory where the application has permission to make changes.

See Managing Multiple Directories.

- **Crowd and the user search:** If you are using Atlassian's Crowd for user management, you will need Crowd 1.5.1 or later to use the 'Simple' option in the user search. If your version of Crowd does not support the simple user search, you will see only the 'Advanced' search form.
Working with JIRA in Confluence

If you use JIRA and have your Confluence and JIRA instances connected using Application Links you can display and create JIRA issues and more from within Confluence. Some of these features require a specific version of JIRA.

This page provides some basics to get you started working with JIRA issues in Confluence.

Displaying JIRA issues

You can display JIRA issues on a Confluence page using the JIRA Issues macro. You can display a single issue, a list of issues, or show the total number of issues.

One of the simplest ways to add a JIRA issue to a page is to paste a JIRA URL. For example:

- `<yourjirasite.com>/browse/CONF-1234` will insert the JIRA Issues macro and display a single issue.
- `<yourjirasite.com>/issues/?filter=56789` will insert the JIRA Issues macro and display a list of issues matching the saved filter.
- `<yourjirasite.com>/issues/?jql=project%20%3D%20CONF` will insert the JIRA Issues macro and display a list of issues matching the JIRA search.

Alternatively you can add the JIRA Issues macro to the page and use the macro browser to search for issues directly.

- In the editor choose Insert > JIRA Issue.
- Follow the prompts in the macro browser to choose a project and search for an issue - you can even use JIRA Query Language (JQL).

You can customise how the issue or list of issues appears on the page, including how much information to display, how many issues, and more.

Find out more about using the JIRA Issues Macro.

Creating JIRA Issues

You can create issues from a page, or from the editor. This is particularly useful if you use Confluence for requirements gathering.

To create an issue when viewing a page:

- Highlight some text on your page - a panel will appear near your selection.
- Choose Create JIRA Issue.
- Follow the prompts to enter information about your project and issue - your highlighted text will populate the issue summary.
- Choose Create - the issue will be created in JIRA, and added to your page.

If your text is in a table, you will have the option to create multiple issues using text from the same column.

If you do not see a popup when you highlight text, check that Text Select is enabled in your profile settings.

To create an issue in the editor:

- In the editor choose Insert > JIRA Issue > Create new issue.
- Follow the prompts to enter information about your project and issue.
- Choose Insert - the issue will be created in JIRA, and added to your page.

There are some limitations when creating JIRA Issues from Confluence. The JIRA Issues macro or Create JIRA Issue dialog will notify you if it is unable to create an issue in the selected project. You can find out more in the JIRA Issues Macro page.

Creating reports and charts

Reporting on information stored in JIRA couldn't be easier in Confluence. In addition to the JIRA Issues Macro, you can use the JIRA Report blueprint or JIRA Chart macro.
You can:

- Use the JIRA Report blueprint to create a Change Log or Status report.
- Use the JIRA Issues Macro to display a list of resolved issues, for example for use in release notes.
- Use the JIRA Chart Macro to display data as a pie chart.

**Prompting users to add JIRA Issues to a page**

If you use templates (including templates provided by blueprints), you can add a JIRA Issue placeholder that, when clicked, opens the JIRA Issues macro and prompts users to search for or create a JIRA issue.

You can see the JIRA Issues placeholder in the Product Requirements blueprint.

See Adding a Template for more information on using instructional text and placeholders.

**View connections between Confluence and JIRA**

The JIRA Links button gives you quick access to issues connected to the Confluence page you are viewing.

Links are displayed when:

- you have created or added single issues to the page using the JIRA Issues macro in Confluence.
- you have added a link from the issue to the Confluence page in JIRA.

If you use JIRA Agile, sprints and epics will also appear on the JIRA Links button.

The number on the JIRA Links button indicates the total number of issues connected to that page, regardless of whether you have permissions to view the issues. The dropdown will only show issues, epics and sprints that you have JIRA permissions to view.

**Note:**

- The JIRA Links button only appears in the default theme. It is not visible in the Documentation theme.
- The button also does not detect links from issues displayed in the JIRA Issues macro in table format.

**Working with JIRA Agile in Confluence**

By using Confluence and JIRA Agile together, you can unleash the potential in your development team. This page provides some suggestions for how you can get the most of Confluence and JIRA Agile.

The features described on this page require JIRA 6.1.3 and JIRA Agile 6.3.5 and later.

**Using Confluence and JIRA Agile to define requirements**

Confluence is the perfect place to start defining your requirements. Here’s how you can use Confluence features to support this process:

- Create a page using the Product Requirements Blueprint.
- Create an epic in JIRA - the blueprint template will prompt you.
- Collaborate with your team to define your stories.
- Highlight text on your requirements page to create stories in JIRA and automatically link them to your epic.
- Track the progress of the stories from the Confluence page or from within JIRA.

The tight integration between Confluence and JIRA mean that you can easily access JIRA issues from the Confluence page, and see their status at a glance, and from within JIRA you can see links to related Confluence pages. All the information you need is never more than a few clicks away.

**Using Confluence and JIRA Agile during a sprint**

Often there is a lot of material in Confluence that provides useful context for your team during a sprint. These might be requirements documents, designs, technical specifications, customer research and more. By linking these pages to epics, you make them easy for your team to access during the sprint.

Here’s how you can use Confluence to support your sprint from within JIRA Agile:
• In JIRA Agile create a Confluence page to plan your sprint - this page is automatically linked to the sprint.
• In an epic link to useful Confluence pages, including requirements, designs, and more.
• Report on your progress to stakeholders using the JIRA Reports blueprint.
• Use the Retrospective blueprint at the end of your sprint to take stock of what went well, and areas for improvement.

For users who work primarily in JIRA, the integration means that useful Confluence pages are only a click away.

**Viewing links between Confluence and JIRA**

The **JIRA Links** button appears on your page when there are links back to JIRA or JIRA Agile. These might be:

- Links from a JIRA issue back to a Confluence Page.
- Links from a JIRA Agile epic or sprint back to a Confluence Page.
- Link from a Confluence page to a JIRA Issue or epic (created by adding a single issue in the JIRA Issues macro).

The number on the JIRA Links button indicates the total number of issues, epics and sprints connected to that page, regardless of whether you have permissions to view them. The dropdown will only show details of issues, epics and sprints that you have JIRA permissions to view.

**Note:**

- The JIRA Links button only appears in the default theme. It is not visible in the Documentation theme.
- The button does not detect links from issues displayed in the JIRA Issues macro in table format.

**Advanced and Special Uses of Confluence**

This section describes the more advanced features of Confluence, and gives guidelines on some specific uses of the wiki.

**Confluence markup formats**

The syntax and usage of Confluence wiki markup and the Confluence XHTML-based storage format – see **Working with Confluence Markup**.

**Gadgets**

How to add gadgets to a wiki page, or use Confluence gadgets on other sites – see **Working with Confluence Gadgets**.

**Using Confluence for technical documentation**

A technical communicator’s guide to using Confluence – see **Developing Technical Documentation on Confluence Wiki**.

**Setting up a knowledge base**

A support engineer's guide to using Confluence as a knowledge base – see **Using Confluence as a Knowledge Base**.

**Setting up an intranet**

A quick guide to setting up an intranet wiki – see **Developing an Intranet on Confluence Wiki**.

**Related pages:**

- Confluence User's Guide
- Confluence Administrator's Guide

**Working with Confluence Markup**

This section describes two types of markup found in Confluence:

- **Confluence storage format.** Confluence stores the content of pages and blog posts in an XHTML-based format. Advanced users can view
the storage format of a page and even edit it, provided their Confluence site is configured to allow that. See Confluence Storage Format for a description of the core elements of the storage format.

- **Wiki markup.** Confluence allows data entry via a shorthand code called wiki markup. Some parts of the Confluence administration interface also accept wiki markup for defining content. For a description of the wiki markup syntax, see Confluence Wiki Markup. Storage format and wikimarkup code examples for macros can be found in the documentation for each macro.

### Confluence Storage Format

This page describes the XHTML-based format that Confluence uses to store the content of pages, page templates, blueprints, blog posts and comments. This information is intended for advanced users who need to interpret and edit the underlying markup of a Confluence page.

We refer to the Confluence storage format as 'XHTML-based'. To be correct, we should call it XML, because the Confluence storage format does not comply with the XHTML definition. In particular, Confluence includes custom elements for macros and more. We're using the term 'XHTML-based' to indicate that there is a large proportion of HTML in the storage format.

You can view the Confluence storage format for a given page by choosing **Tools > View Storage Format.** This option is only available if one of the following is true:

- You are a Confluence administrator.
- Your Confluence site has the Confluence Source Editor plugin installed and you have permission to use the source editor.
- If you would like to edit the storage format for a page, your Confluence system administrator will need to install the Confluence Source Editor plugin.
- Clarification of terminology: If you choose Tools > View Source, you will see the format used within the editor panel, not the storage format of the page.

### Headings

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heading 1</td>
<td>h1. Heading 1</td>
<td><code>&lt;h1&gt;Heading 1&lt;/h1&gt;</code></td>
<td>Underlined in the Documentation Theme</td>
</tr>
<tr>
<td>Heading 2</td>
<td>h2. Heading 2</td>
<td><code>&lt;h2&gt;Heading 2&lt;/h2&gt;</code></td>
<td></td>
</tr>
<tr>
<td>Heading 3</td>
<td>h3. Heading 3</td>
<td><code>&lt;h3&gt;Heading 3&lt;/h3&gt;</code></td>
<td></td>
</tr>
</tbody>
</table>
### Text effects

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>strong/bold</td>
<td><em>strong</em></td>
<td><code>&lt;strong&gt;</code></td>
<td><code>&lt;b&gt;</code> will also work but get converted to <code>&lt;strong&gt;</code> upon saving</td>
</tr>
<tr>
<td>emphasis</td>
<td><code>_emphasis_</code></td>
<td><code>&lt;em&gt;</code></td>
<td><code>&lt;i&gt;</code> will also work but get converted to <code>&lt;em&gt;</code> upon saving</td>
</tr>
<tr>
<td>strikethrough</td>
<td><code>-strikethrough-</code></td>
<td><code>&lt;span style=text-decoration: line-through;</code>&gt;<code>s strikethrough </code>&lt;/span&gt;`</td>
<td><code>&lt;s&gt;</code> and <code>&lt;del&gt;</code> will also work</td>
</tr>
<tr>
<td>underline</td>
<td><code>+underline+</code></td>
<td><code>&lt;u&gt;</code></td>
<td><code>&lt;u&gt;</code></td>
</tr>
<tr>
<td>Format</td>
<td>Example</td>
<td>HTML Code</td>
<td>Example Code</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------</td>
<td>---------------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Superscript</td>
<td>^superscript^</td>
<td><code>&lt;sup&gt;superscript&lt;/sup&gt;</code></td>
<td><code>&lt;sup&gt;superscript&lt;/sup&gt;</code></td>
</tr>
<tr>
<td>Subscript</td>
<td><del>subscript</del></td>
<td><code>&lt;sub&gt;subscript&lt;/sub&gt;</code></td>
<td><code>&lt;sub&gt;subscript&lt;/sub&gt;</code></td>
</tr>
<tr>
<td>Monospace</td>
<td>{{monospace d}}</td>
<td><code>&lt;code&gt;monospaced&lt;/code&gt;</code></td>
<td><code>&lt;code&gt;monospaced&lt;/code&gt;</code></td>
</tr>
<tr>
<td>Preformatted</td>
<td>n/a</td>
<td><code>&lt;pre&gt;preformatted text&lt;/pre&gt;</code></td>
<td><code>&lt;pre&gt;preformatted text&lt;/pre&gt;</code></td>
</tr>
<tr>
<td>Block Quotes</td>
<td>bq. block quote or {quote} block quote {quote}</td>
<td><code>&lt;blockquote&gt;block quote&lt;/blockquote&gt;</code></td>
<td><code>&lt;blockquote&gt;block quote&lt;/blockquote&gt;</code></td>
</tr>
<tr>
<td>text colour</td>
<td>{color:red}red text{color}</td>
<td>&lt;span style=&quot;color:rgb(255,0,0);&quot;&gt;red text&lt;/span&gt;</td>
<td>red text</td>
</tr>
<tr>
<td>-------------</td>
<td>--------------------------</td>
<td>-------------------</td>
<td>---------</td>
</tr>
<tr>
<td>small</td>
<td>n/a</td>
<td>&lt;small&gt;small text&lt;/small&gt;</td>
<td>small text</td>
</tr>
<tr>
<td>big</td>
<td>n/a</td>
<td>&lt;big&gt;big text&lt;/big&gt;</td>
<td>big text</td>
</tr>
<tr>
<td>center-align</td>
<td>n/a</td>
<td>&lt;p style=&quot;text-align:center;&quot;&gt;centered text&lt;/p&gt;</td>
<td>centered text</td>
</tr>
</tbody>
</table>
### Text breaks

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>New paragraph</td>
<td>Paragraph 1</td>
<td>Paragraph 1 \ Paragraph 2</td>
<td>Paragraph 1 \ Paragraph 2</td>
</tr>
<tr>
<td></td>
<td>(empty line)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Paragraph 2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Line break</td>
<td>Line 1 \ Line 2</td>
<td>Line 1 &lt;br /&gt; Line 2</td>
<td>Line 1 \ Line 2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note: Created in the editor using Shift + Return/Enter</td>
<td></td>
</tr>
<tr>
<td>Horizontal rule</td>
<td>----</td>
<td>&lt;hr /&gt;</td>
<td></td>
</tr>
<tr>
<td>— symbol</td>
<td>---</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>– symbol</td>
<td>--</td>
<td>—</td>
<td>–</td>
</tr>
</tbody>
</table>

### Lists

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unordered list – round bullets</td>
<td>* Round bullet list item</td>
<td>• Round bullet list item</td>
<td></td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------</td>
<td>------------------------</td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;ul&gt;</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;li&gt;</code></td>
<td><code>round bullet list item&lt;/li&gt;</code></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;/li&gt;</code></td>
<td><code>&lt;/ul&gt;</code></td>
<td></td>
</tr>
<tr>
<td>Ordered list (numbered list)</td>
<td># Ordered list item</td>
<td>1. Ordered list item</td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;ol&gt;</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;li&gt;</code></td>
<td><code>numbered list item&lt;/li&gt;</code></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;/li&gt;</code></td>
<td><code>&lt;/ol&gt;</code></td>
<td></td>
</tr>
<tr>
<td>Task Lists</td>
<td>[] Task list item</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:task-list&gt;</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:task&gt;</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:task-status&gt;</code></td>
<td><code>incomplete&lt;/ac:task-status&gt;</code></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:task-body&gt;</code></td>
<td><code>task list item&lt;/ac:task-body&gt;</code></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;/ac:task&gt;</code></td>
<td><code>&lt;/ac:task-list&gt;</code></td>
<td></td>
</tr>
</tbody>
</table>

Links

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link to another Confluence page</td>
<td>[Link to another Confluence page</td>
<td>Page Title]</td>
<td>Link to another Confluence page</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-----------------------------------------------</td>
<td>---------------------------------</td>
<td></td>
</tr>
<tr>
<td>![CDATA[L ink to another Confluence Page]]&gt;</td>
<td>![CDATA[L ink to another Confluence Page]]&gt;</td>
<td>![CDATA[L ink to another Confluence Page]]&gt;</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Link to an attachment</th>
<th>[Link to an attachment^atlassian_logo.gif]</th>
<th>Link to an attachment</th>
</tr>
</thead>
<tbody>
<tr>
<td>![CDATA[L ink to a Confluence Attachment]]&gt;</td>
<td>![CDATA[L ink to a Confluence Attachment]]&gt;</td>
<td>![CDATA[L ink to a Confluence Attachment]]&gt;</td>
</tr>
</tbody>
</table>

<p>| Link to an external site | [Atlassian|<a href="http://www.atlassian.com/">http://www.atlassian.com/</a>] | Atlassian |
|--------------------------|-----------------------------------|-----------|
| ![a href=”<a href="http://www.atlassian.com%E2%80%9D%3EAtlassian">http://www.atlassian.com”&gt;Atlassian</a>&lt;/a&gt; | ![a href=”<a href="http://www.atlassian.com%E2%80%9D%3EAtlassian">http://www.atlassian.com”&gt;Atlassian</a>&lt;/a&gt; | ![a href=”<a href="http://www.atlassian.com%E2%80%9D%3EAtlassian">http://www.atlassian.com”&gt;Atlassian</a>&lt;/a&gt; |</p>
<table>
<thead>
<tr>
<th>Anchor link (same page)</th>
<th>[Anchor Link]#anchor</th>
<th></th>
<th>Anchor Link</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>![CDATA[Anchor Link]]&gt;</td>
<td>![CDATA[Anchor Link]]&gt;</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Anchor link (another page)</th>
<th>[Anchor Link]pagetitle#anchor</th>
<th></th>
<th>Anchor Link</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>![CDATA[Anchor Link]]&gt;</td>
<td>![CDATA[Anchor Link]]&gt;</td>
<td></td>
</tr>
</tbody>
</table>
## A note about link bodies

All links received from the editor will be stored as plain text by default, unless they are detected to contain the limited set of mark up that we allow in link bodies. Here are some examples of markup we support in link bodies.

### An example of different link bodies

```xml
<ac:link>
  <!-- Any resource identifier -->
  <ri:page ri:content-title="Home" ri:space-key="SANDBOX" />
  <ac:link-body>Some <strong>Rich</strong> Text</ac:link-body>
</ac:link>

<ac:link>
  <ri:page ri:content-title="Plugin developer tutorial stuff" ri:space-key="TECHWRITING" />
  <ac:plain-text-link-body><![CDATA[A plain <text> link body]]></ac:plain-text-link-body>
</ac:link>

<ac:link>
  <!-- A link body isn't necessary. Auto-generated from the resource identifier for display. -->
</ac:link>
```

For rich content like images, you need to use `<ac:link-body>` to wrap the contents.

---

**Confluence 5.5 Documentation**

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
The markup tags permitted within the `<ac:link-body>` are `<b>`, `<strong>`, `<em>`, `<i>`, `<code>`, `<tt>`, `<sub>`, `<sup>`, `<br>` and `<span>`.

**Images**

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attached image</td>
<td>![atlassian_logo.gif!](attachment:ri:file name=&quot;atlassian_logo.gif&quot;)</td>
<td><code>&lt;ac:image&gt;</code></td>
<td>![Atlassian](attachment:ri:file name=&quot;atlassian_logo.gif&quot;)</td>
</tr>
</tbody>
</table>

Supported image attributes (some of these attributes mirror the equivalent HTML 4 IMG element):

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ac:align</td>
<td>image alignment</td>
</tr>
<tr>
<td>ac:border</td>
<td>Set to &quot;true&quot; to set a border</td>
</tr>
<tr>
<td>ac:class</td>
<td>css class attribute</td>
</tr>
<tr>
<td>ac:title</td>
<td>image tool tip</td>
</tr>
<tr>
<td>ac:style</td>
<td>css style</td>
</tr>
<tr>
<td>ac:thumbnail</td>
<td>Set to &quot;true&quot; to designate this image as a thumbnail.</td>
</tr>
<tr>
<td>ac:alt</td>
<td>alt text</td>
</tr>
<tr>
<td>ac:height</td>
<td>image height</td>
</tr>
<tr>
<td>Format type</td>
<td>In Confluence 3.5 and earlier</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>---------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Two column, two row (top header row)</td>
<td><img src="#" alt="Table" /> Table Heading Cell 1</td>
</tr>
<tr>
<td></td>
<td><img src="#" alt="Table" /> Normal Cell 1</td>
</tr>
</tbody>
</table>
Confluence supports page layouts directly, as an alternative to macro-based layouts (using, for example, the section and column macros). This section documents the storage format XML created when these layouts are used in a page.

Notes:

- Page layouts were originally introduced in Confluence 4.2, and are not available in earlier versions of Confluence. If you are using Confluence 4.2 - 5.1 you should refer to the documentation for your version of Confluence:
  - Confluence Storage Format (Confluence 4.2)
  - Confluence Storage Format (Confluence 4.3)
  - Confluence Storage Format (Confluence 5.0)
  - Confluence Storage Format (Confluence 5.1)
- Pages with a layout created in the old format will be converted to 5.2 format.
- Confluence 5.2 provides more flexible layouts with a more concise storage format.
### Element name | In Confluence 5.2 and later | Attributes
--- | --- | ---
ac:layout | Indicates that the page has a layout. It should be the top level element in the page. | None
ac:layout-section | Represents a row in the layout. It must be directly within the ac:layout tag. The type of the section indicates the appropriate number of cells and their relative widths. | ac:type
ac:layout-cell | Represents a column in a layout. It must be directly within the ac:layout-section tag. There should be an appropriate number of cells within the layout-section to match the ac:type. | None

The recognised values of `ac:type` for `ac:layout-section` are:

<table>
<thead>
<tr>
<th><code>ac:type</code></th>
<th>Expected number of cells</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>single</td>
<td>1</td>
<td>One cell occupies the entire section.</td>
</tr>
<tr>
<td>two_equal</td>
<td>2</td>
<td>Two cells of equal width.</td>
</tr>
<tr>
<td>two_left_sidebar</td>
<td>2</td>
<td>A narrow (~30%) cell followed by a wide cell.</td>
</tr>
<tr>
<td>two_right_sidebar</td>
<td>2</td>
<td>A wide cell followed by a narrow (~30%) cell.</td>
</tr>
<tr>
<td>three_equal</td>
<td>3</td>
<td>Three cells of equal width.</td>
</tr>
<tr>
<td>three_with_sidebars</td>
<td>3</td>
<td>A narrow (~20%) cell at each end with a wide cell in the middle.</td>
</tr>
</tbody>
</table>

The following example shows one of the more complicated layouts from the old format built in the new. The word `<content>` indicates where further XHTML or Confluence storage format block content would be entered, such as `<p>` or `<table>` tags.
### Emoticons

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Emoticons</td>
<td>:)</td>
<td>&lt;:emoticon ac:name=&quot;smile&quot; /&gt;</td>
<td>😊</td>
</tr>
<tr>
<td></td>
<td>:(</td>
<td>&lt;:emoticon ac:name=&quot;sad&quot; /&gt;</td>
<td>😞</td>
</tr>
<tr>
<td></td>
<td>;P</td>
<td>&lt;:emoticon ac:name=&quot;cheeky&quot; /&gt;</td>
<td>😊</td>
</tr>
<tr>
<td></td>
<td>;D</td>
<td>&lt;:emoticon ac:name=&quot;laugh&quot; /&gt;</td>
<td>😊</td>
</tr>
</tbody>
</table>
Resource identifiers

Resource identifiers are used to describe "links" or "references" to resources in the storage format. Examples of resources include pages, blog posts, comments, shortcuts, images and so forth.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Resource identifier format</th>
</tr>
</thead>
<tbody>
<tr>
<td>;</td>
<td>&lt;ac:emoticon ac:name=&quot;wink&quot; /&gt;</td>
</tr>
<tr>
<td>(y)</td>
<td>&lt;ac:emoticon ac:name=&quot;thumbs-up&quot; /&gt;</td>
</tr>
<tr>
<td>(n)</td>
<td>&lt;ac:emoticon ac:name=&quot;thumbs-down&quot; /&gt;</td>
</tr>
<tr>
<td>(i)</td>
<td>&lt;ac:emoticon ac:name=&quot;information&quot; /&gt;</td>
</tr>
<tr>
<td>(!)</td>
<td>&lt;ac:emoticon ac:name=&quot;tick&quot; /&gt;</td>
</tr>
<tr>
<td>(x)</td>
<td>&lt;ac:emoticon ac:name=&quot;cross&quot; /&gt;</td>
</tr>
<tr>
<td>(!)</td>
<td>&lt;ac:emoticon ac:name=&quot;warning&quot; /&gt;</td>
</tr>
<tr>
<td>Page</td>
<td><code>&lt;ri:page ri:space-key=&quot;FOO&quot; ri:content-title=&quot;Test Page&quot;/&gt;</code></td>
</tr>
<tr>
<td>------</td>
<td>----------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Notes: | • `ri:space-key:` *(optional)* denotes the space key. This can be omitted to create a relative reference.  
• `ri:content-title:` *(required)* denotes the title of the page. |

<table>
<thead>
<tr>
<th>Blog Post</th>
<th><code>&lt;ri:blog-post ri:space-key=&quot;FOO&quot; ri:content-title=&quot;First Post&quot; ri:posting-day=&quot;2012/01/30&quot; /&gt;</code></th>
</tr>
</thead>
</table>
| Notes: | • `ri:space-key:` *(optional)* denotes the space key. This can be omitted to create a relative reference.  
• `ri:content-title:` *(required)* denotes the title of the page.  
• `ri:posting-day:` *(required)* denotes the posting day. The format is YYYY/MM/DD. |
<table>
<thead>
<tr>
<th><strong>Attachment</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;ri:attachment ri:filename&gt;</code></td>
</tr>
</tbody>
</table>
| ... resource identifier for the container of the attachment ...
| `</ri:attachment>` |

**Notes:**
- `ri:filename`: (required) denotes the name of the attachment.
- The body of the `ri:attachment` element should be a resource identifier denoting the container of the attachment. This can be omitted to create a relative attachment reference (similar to `[foo.png]` in wiki markup).

**Examples:**

**Relative Attachment Reference**

```xml
<ri:attachment
   ri:filename="happy.gif" />
```

**Absolute Attachment Reference**

```xml
<ri:attachment
   ri:filename="happy.gif">
   <ri:page ri:space-key="TST"
            ri:content-title="Test Page"/>
</ri:attachment>
```

<table>
<thead>
<tr>
<th><strong>URL</strong></th>
</tr>
</thead>
</table>
| `<ri:url
   ri:value="http://example.org/sample.gif"/>` |

**Notes:**
- `ri:value`: (required) denotes the actual URL value.

<table>
<thead>
<tr>
<th><strong>Shortcut</strong></th>
</tr>
</thead>
</table>
| `<ri:shortcut ri:key="jira"
              ri:parameter="ABC-123"/>` |

**Notes:**
- `ri:key`: (required) represents the key of the Confluence shortcut.
- `ri:parameter`: (required) represents the parameter to pass into the Confluence shortcut.
- The example above is equivalent to `[ABC-123 @jira]` in wiki markup.
### Template variables

This screenshot shows a simple template:

```
Dashboard › Chocolate › Browse Space › Edit Template

Sarah template

This is Sarah's template

A single-line text variable: $MyText
A multi-line text variable: $MyMulti
A selection list: $MyList
End of page.
```

The template contains the following variables:

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Type</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>$MyText</td>
<td>Single-line text</td>
<td></td>
</tr>
<tr>
<td>$MyMulti</td>
<td>Multi-line text</td>
<td>Size: 5 x 100</td>
</tr>
</tbody>
</table>
Instructional Text

Instructional text allows you to include information on how to fill out a template for an end-user (the person using creating a page from the template). Instructional text will:

- automatically clear all instructional text as the user types in a specific text block, and
- automatically trigger a @mention prompt for user selection (for 'mention' type instructional text).

Screenshot: Example of instructional text.

```
<ul>
    <li>This is an example of instruction text that will get replaced when a user selects the text and begins typing.</li>
</ul>
<ac:task-list>
    <ac:task>
        <ac:task-status>incomplete</ac:task-status>
        <ac:task-body>
            <ac:placeholder ac:type="mention">@mention example. This placeholder will automatically search for a user to mention in the page when the user begins typing.</ac:placeholder>
        </ac:task-body>
    </ac:task>
</ac:task-list>
```

Confluence Wiki Markup

This page describes the wiki markup used on some administration screens in Confluence.

Wiki markup is useful when you want to do one of the following:

- Configure the Documentation theme.
- Type wiki markup directly into the editor. Confluence will convert it to the rich text editor format as you
Can I type wiki markup into the editor?

Yes. You can type wiki markup directly into the editor, and Confluence will convert it as you type. (You cannot edit the wiki markup after conversion.) See it in action in this video:

Read this blog post for more examples: 12 Things You Didn’t Know About the Confluence Editor.

Can I insert markdown?

Confluence supports inserting content in markdown. This is often used in ReadMe files. See Markdown syntax guide for some examples of markdown syntax.

To insert markdown in the editor:

1. Choose Insert > Markup
2. Select Markdown
3. Type or paste your text - the preview will show you how it will appear on your page
4. Choose Insert.

As with wiki markup, Confluence will convert your markdown to the rich text editor format. You will not be able to edit your content using markdown.

On this page:
- Can I type wiki markup into the editor?
- Can I insert markdown?
- Headings
- Lists
- Tables
- Text Effects
- Text Breaks
- Links
- Images
- Page Layouts
- Macros

Headings

To format a line as a heading, type "hn." at the start of your line, where n can be a number from 1 to 6.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>h1. Biggest heading</td>
<td>Biggest heading</td>
</tr>
<tr>
<td>h3. Big heading</td>
<td>Big heading</td>
</tr>
<tr>
<td>h5. Small heading</td>
<td>Small heading</td>
</tr>
</tbody>
</table>

Lists

Wiki markup allows you to create bulleted or numbered lists, and is flexible enough to allow a combination of the two list types.
If you need to separate the text within lists using line breaks, make sure you do so using a double slash (/\/). Empty lines may disrupt the list.

**Simple lists**

Use the hyphen (-) to create simple lists. Make sure there is a space between the hyphen and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>- some</td>
<td>• some</td>
</tr>
<tr>
<td>- bullet</td>
<td>• bullet</td>
</tr>
<tr>
<td>- points</td>
<td>• points</td>
</tr>
</tbody>
</table>

**Bulleted lists**

Use the asterisk (*) to create bullets. For each subsequent level, add an extra asterisk. Make sure there is a space between the asterisk and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>* some</td>
<td>• some</td>
</tr>
<tr>
<td>* bullet</td>
<td>• bullet</td>
</tr>
<tr>
<td>** indented</td>
<td>• indented</td>
</tr>
<tr>
<td>** bullets</td>
<td>• bullets</td>
</tr>
<tr>
<td>* points</td>
<td>• points</td>
</tr>
</tbody>
</table>

**Numbered lists**

Use the hash (#) to create numbered lists. Make sure there is a space between the hash and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td># a</td>
<td>1. a</td>
</tr>
<tr>
<td># numbered</td>
<td>2. numbered</td>
</tr>
<tr>
<td># list</td>
<td>3. list</td>
</tr>
</tbody>
</table>

A second level of hashes will produce a sub-list, such as the alphabetical sub-list shown below.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td># Here's a sentence.</td>
<td>1. Here's a sentence.</td>
</tr>
<tr>
<td>## This is a sub-list point.</td>
<td>a. This is a sub-list point.</td>
</tr>
<tr>
<td>## And a second sub-list point.</td>
<td>b. And a second sub-list point.</td>
</tr>
<tr>
<td># Here's another sentence.</td>
<td>2. Here's another sentence.</td>
</tr>
</tbody>
</table>

You can use a third level of hashes to produce a sub-sub-list.
Here's a sentence.

This is a sub-list point.

Another point at the third level.

And a second sub-list point.

Here's another sentence.

### Mixed lists

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| # Here
| * is
| * an
| # example
| * of
| * a
| # mixed
| # list | 1. Here
| • is
| • an
| 2. example
| • of
| • a
| 3. mixed
| 4. list |

### Tables

You can create two types of tables.

#### Table Type 1

Allows you to create a simple table with an optional header row. You cannot set the width of the columns in this table.

Use double bars for a table heading row.

#### What you need to type:

<table>
<thead>
<tr>
<th>heading 1</th>
<th>heading 2</th>
<th>heading 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>cell A1</td>
<td>cell A2</td>
<td>cell A3</td>
</tr>
<tr>
<td>cell B1</td>
<td>cell B2</td>
<td>cell B3</td>
</tr>
</tbody>
</table>

#### What you will get:

<table>
<thead>
<tr>
<th>heading 1</th>
<th>heading 2</th>
<th>heading 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>cell A1</td>
<td>cell A2</td>
<td>cell A3</td>
</tr>
<tr>
<td>cell B1</td>
<td>cell B2</td>
<td>cell B3</td>
</tr>
</tbody>
</table>

You can also use a vertical header.

#### What you need to type:
Table Type 2
This method allows you to specify the width of the columns in the table.

What you need to type

```markdown
{section:border=true}
{column:width=30%}
Text for this column goes here. This is the smaller column with a width of only 30%.
{column}
{column:width=70%}
Text for this column goes here. This is the larger column with a width of 70%.
{section}
```

What you will get
Text for this column goes here. This is the smaller column with a width of only 30%.
Text for this column goes here. This is the larger column with a width of 70%.

For more details please see the Column Macro and the Section Macro.

Advanced Formatting
Colour and Other Formatting
To add colour and other formatting to your tables, you can use the Panel Macro within columns.
More table-formatting options may be available if your Confluence administrator has installed additional macros.

Lists
Here’s an example of how to embed lists in a table:

What you need to type

```markdown
<table>
<thead>
<tr>
<th>Heading 1</th>
<th>Heading 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>* Item 1</td>
<td></td>
</tr>
<tr>
<td>* Item 2</td>
<td></td>
</tr>
<tr>
<td>* Item 3</td>
<td># Item 1</td>
</tr>
<tr>
<td></td>
<td># Item 2</td>
</tr>
<tr>
<td></td>
<td># Item 3</td>
</tr>
</tbody>
</table>
```

What you will get

<table>
<thead>
<tr>
<th>Heading 1</th>
<th>Heading 2</th>
</tr>
</thead>
</table>
Text Effects

Use the markup shown in the examples below to format text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>strong</em></td>
<td>strong</td>
</tr>
<tr>
<td><em>bold text</em></td>
<td>bold text</td>
</tr>
<tr>
<td><em>emphasis</em></td>
<td>emphasis</td>
</tr>
<tr>
<td><em>italics</em></td>
<td>italics</td>
</tr>
<tr>
<td></td>
<td>Hint: To italicise parts of a word, add braces (curly brackets) around the underscore. For example, Thing(_)<em>x</em> gives you this: Thingx</td>
</tr>
<tr>
<td>??citation??</td>
<td>—citation</td>
</tr>
<tr>
<td>-deleted-</td>
<td>deleted</td>
</tr>
<tr>
<td>+inserted+</td>
<td>inserted</td>
</tr>
<tr>
<td>Text with*superscript^</td>
<td>Text with^superscript^</td>
</tr>
<tr>
<td></td>
<td>Hint: There are two ways to make superscripts work, when used directly after another word or character:</td>
</tr>
<tr>
<td></td>
<td>• Add a space before the superscript. For example, kg/m^3^ gives you this: kg/m^3^</td>
</tr>
<tr>
<td></td>
<td>• Add braces (curly brackets) around the superscript markup. For example, kg/m{^3^} gives you this: kg/m^3^</td>
</tr>
<tr>
<td>Text with<del>subscript</del></td>
<td>Text with^subscript^</td>
</tr>
<tr>
<td>({monospaced})</td>
<td>monospaced</td>
</tr>
<tr>
<td>bq. Here’s how you make a paragraph appear as a block quotation.</td>
<td>Here’s how you make a paragraph appear as a block quotation.</td>
</tr>
<tr>
<td>(color:red)look ma, red text!(color)</td>
<td>look ma, red text!</td>
</tr>
</tbody>
</table>

Text Breaks

Paragraph Break

In wiki markup, a paragraph is a continuous line of text ending in two carriage returns. This is equivalent to a continuous line of text followed by a blank line.

When rendered into HTML, the result is a line of text wrapped in a set of `<p></p>` tags.

Line Break
Confluence provides two options for forcing a line break within a paragraph of text:

- Implicitly, by entering a single carriage return at its end.
- Explicitly, by entering two consecutive backslashes: `\`

When rendered into HTML, the result is a paragraph of text that is split into separate lines by `<br>` tags, wherever a forced line break appears.

**For most purposes, explicit line breaks are not required because a single carriage return is enough.**

The examples below show how to use explicit line breaks.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>here is some text</td>
<td>here is some text divided using line breaks</td>
</tr>
<tr>
<td><code>\</code></td>
<td></td>
</tr>
<tr>
<td>divided <code>\</code></td>
<td></td>
</tr>
<tr>
<td>using line <code>\</code> <code>\</code></td>
<td></td>
</tr>
<tr>
<td>breaks<code>\</code></td>
<td></td>
</tr>
<tr>
<td>This is a short list:</td>
<td>This is a short list:</td>
</tr>
<tr>
<td>* Point 1</td>
<td>* Point 1</td>
</tr>
<tr>
<td>Text to go with point 1</td>
<td>Text to go with point 1</td>
</tr>
<tr>
<td>* Point 2</td>
<td>* Point 2</td>
</tr>
<tr>
<td><code>\</code> <code>\</code></td>
<td></td>
</tr>
<tr>
<td>Text to go with point 2 with a break</td>
<td>Text to go with point 2 with a break</td>
</tr>
</tbody>
</table>

If you wish to use multiple consecutive line breaks, each should be separated by a space character. For example, use this for two consecutive line breaks:

`\` `\`

**Horizontal Rule**

To create a horizontal line across the width of your page or content block, type four dashes (like this: `----`) at the beginning of a line, then press Enter or space.

Make sure that the dashes are on a separate line from the rest of the text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>here is some text</td>
<td>here is some text</td>
</tr>
<tr>
<td><code>----</code></td>
<td></td>
</tr>
<tr>
<td>divided by a horizontal rule</td>
<td>divided by a horizontal rule</td>
</tr>
</tbody>
</table>

**Links**

You can use wiki markup to add hyperlinks to your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>[#anchor]</td>
<td>A link to an anchor on the same page.</td>
</tr>
<tr>
<td>[Confluence Wiki Markup*attachment.ext]</td>
<td>A link to a file attached to the page.</td>
</tr>
<tr>
<td>[pagetitle]</td>
<td>A link to a page.</td>
</tr>
<tr>
<td>[pagetitle#anchor]</td>
<td>A link to an anchor on another page.</td>
</tr>
<tr>
<td>[pagetitle*attachment.ext]</td>
<td>A link to a file attached to another page.</td>
</tr>
<tr>
<td>Link Form</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>[spacekey:pagetitle]</td>
<td>A link to a page in another space.</td>
</tr>
<tr>
<td>[spacekey:pagetitle#anchor]</td>
<td>A link to an anchor on a page in another space.</td>
</tr>
<tr>
<td>[spacekey:pagetitle^attachment.ext]</td>
<td>A link to a file attached to a page in another space.</td>
</tr>
<tr>
<td>[/2004/01/12/blogposttitle]</td>
<td>A link to a blog post.</td>
</tr>
<tr>
<td>[spacekey:/2004/01/12/blogposttitle]</td>
<td>A link to a blog post in another space.</td>
</tr>
<tr>
<td>[/2004/01/12]</td>
<td>A link to a whole day's blog posts.</td>
</tr>
<tr>
<td>[spacekey:/2004/01/12]</td>
<td>A link to a whole day's blog posts in another space.</td>
</tr>
<tr>
<td>[~username]</td>
<td>A link to the space homepage (or the space summary page of the space.</td>
</tr>
<tr>
<td>[phrase@shortcut]</td>
<td>A shortcut link to the specified shortcut site. Shortcuts are configured by the site administrator.</td>
</tr>
<tr>
<td>[<a href="mailto:legendaryservice@atlassian.com">mailto:legendaryservice@atlassian.com</a>]</td>
<td>A link to an email address.</td>
</tr>
<tr>
<td>[file://z:/file/on/network/share.txt]</td>
<td>A link to a file on your computer or on a network share that you have mapped to a drive. This only works on Internet Explorer.</td>
</tr>
</tbody>
</table>

Note that Confluence treats headings as anchors, so you can link to headings using this pattern: [spacekey:pagename#headingname], where headingname is case-sensitive and must be entered without spaces.

For each of these link forms:
- You can prepend a link alias, so that alternate text is displayed on the page. Example: [link alias|pagetitle#anchor]
- You can append a link tip, which appears as a tooltip. Example: [pagetitle#anchor|link tip]

Images

You can display images from attached files or remote sources.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>![<a href="http://www.host.com/image.gif">http://www.host.com/image.gif</a>!]</td>
<td>An image from a remote source is displayed on the page. Uses a fully qualified URL.</td>
</tr>
<tr>
<td>![attached-image.gif!]</td>
<td>An image file attached to the page is displayed.</td>
</tr>
<tr>
<td>![pageTitle^image.gif!]</td>
<td>An image file attached to a different page is displayed.</td>
</tr>
<tr>
<td>![spaceKey:pageTitle^image.gif!]</td>
<td>An image file attached to a page in a different space is displayed.</td>
</tr>
<tr>
<td>![/2010/05/23/My Blog Post^image.gif!]</td>
<td>An image file attached to a blog post is displayed.</td>
</tr>
<tr>
<td>![image.jpg</td>
<td>thumbnail!]</td>
</tr>
</tbody>
</table>
For any image, you can specify attributes of the HTML image tag as a comma separated list of name=value pairs.

Available HTML image tags include:

<table>
<thead>
<tr>
<th>Image tag</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>align</td>
<td>Available values are 'left', 'right', 'bottom', 'center', 'top'.</td>
</tr>
<tr>
<td>border</td>
<td>Specifies the width of the border (in pixels).</td>
</tr>
<tr>
<td>bordercolor</td>
<td>Use with the 'border' tag. Specify colours by name or hex value.</td>
</tr>
<tr>
<td>hspace</td>
<td>Specifies the amount of whitespace to be inserted to the left and right of the image (in pixels).</td>
</tr>
<tr>
<td>vspace</td>
<td>Specifies the amount of whitespace to be inserted above and below the image (in pixels).</td>
</tr>
<tr>
<td>width</td>
<td>Specifies the width of the image (in pixels). This will override the natural width of the image.</td>
</tr>
<tr>
<td>height</td>
<td>Specifies the height of the image (in pixels). This will override the natural height of the image.</td>
</tr>
<tr>
<td>title</td>
<td>Specifies alternate text for the image, which is displayed when the pointer hovers over the image.</td>
</tr>
<tr>
<td>alt</td>
<td>Specifies alternate text for the image. This text is retrievable via search, and contributes to accessibility of the page for text-only viewing.</td>
</tr>
</tbody>
</table>

Page Layouts

There is no wiki markup representation for page layouts.

Macros

Storage format and wiki markup examples have been included in the documentation for each macro.

**Working with Confluence Gadgets**

This section introduces the concept of gadgets in Confluence and provides an outline on how to use gadgets in Confluence and other web applications.

**Introduction to Gadgets in Confluence**

A gadget is a small object (i.e. a piece of functionality) offering dynamic content that can be placed into the page of:

- An Atlassian application's website, such as a Confluence page or blog post or a JIRA 4.0+ dashboard.
- A third-party application's website, such as iGoogle or Gmail. (But see the limitations on using Confluence gadgets in other applications.)

Gadgets allow interactions between Confluence and other compatible websites. Confluence interacts with gadgets that support the OpenSocial specification.

For more information about Atlassian gadgets, please refer to the introduction to Atlassian gadgets and the big list of Atlassian gadgets.

**Using Gadgets in Confluence**

You can place any gadget that complies with the OpenSocial specification from an external source, such as iGoogle or other Atlassian applications such as JIRA 4.0+, onto a Confluence page or blog post. To add a gadget to
a page, use the Confluence macro browser to add a **Gadget macro**.

See the page on adding JIRA gadgets to a Confluence page.

---

**On this page:**
- Introduction to Gadgets in Confluence
- Using Gadgets in Confluence
- Adding Confluence Gadgets in Other Applications
  - Adding a Confluence Gadget to JIRA
  - Adding a Confluence Gadget to Non-Atlassian Web Applications
  - Confluence Gadgets

**Related pages:**
- Gadget Macro
- Configuring Confluence Gadgets for Use in Other Applications
- Adding a Confluence Gadget to a JIRA Dashboard
- Confluence Gadgets
- All Atlassian gadgets
- External Gadgets

---

### Adding Confluence Gadgets in Other Applications

You can add a Confluence gadget to a JIRA dashboard or another Confluence site. In principle, you can also put a Confluence gadget on any other OpenSocial-compliant website such as iGoogle or Gmail. See the limitations on using Confluence gadgets in other applications.

**Adding a Confluence Gadget to JIRA**

See Adding a Confluence Gadget to a JIRA Dashboard.

**Adding a Confluence Gadget to Non-Atlassian Web Applications**

For instructions on how to add Confluence gadgets in another compatible non-Atlassian web application or container, refer to Configuring Confluence Gadgets for Use in Other Applications.

### Confluence Gadgets

The Confluence Gadgets topic explains the purpose of the 'Confluence Gadgets' window and provides information about the gadgets which are bundled with Confluence.

**Adding a Confluence Gadget to a JIRA Dashboard**

JIRA 4.0 is the first major Atlassian application that can incorporate OpenSocial-compliant gadgets, such as Confluence gadgets onto its dashboard. This page explains how to add a Confluence gadget to the dashboard of a JIRA 4.0+ installation.

To add a Confluence gadget to a JIRA dashboard, complete the steps below.

**Creating an Application Link between Confluence and JIRA**

If your Confluence gadgets need to access user-restricted Confluence data, then your Confluence administrator must first establish an Application Link between your Confluence site and the JIRA site.

If you only need to access anonymously accessible Confluence data, then you can skip the section about adding an Application Link, and go directly to Finding a Confluence Gadget’s URL, below.
On this page:
- Creating an Application Link between Confluence and JIRA
- Finding a Confluence Gadget's URL
- Adding a Confluence gadget to JIRA’s gadget directory
- Adding a Confluence gadget to the JIRA dashboard

Related pages:
- All Atlassian gadgets
- Working with Confluence Gadgets
- Confluence User's Guide

Finding a Confluence Gadget's URL

A gadget's URL points to the gadget's XML specification file. These URLs look something like this:

```
http://example.com/my-gadget-location/my-gadget.xml
```

To find a Confluence gadget's URL:

1. Choose the help icon at top right of the screen, then choose Available Gadgets.
2. Find the gadget you want.
3. Copy the Gadget URL link to your clipboard.

Screenshot: Finding a gadget's URL

Adding a Confluence gadget to JIRA's gadget directory

To add a Confluence gadget to the gadget directory in JIRA:
1. Go to the dashboard by clicking **Dashboard** at the top left of the screen.
2. The dashboard will appear. Click **Add Gadget**.
3. The 'Add Gadget' screen appears, showing the list of gadgets in your directory. See screenshot 1 below. Click **Add Gadget to Directory**.
   
   Note: You will only see this button if you have system administrator permissions in JIRA.
4. The 'Add Gadget to Directory' screen appears. See screenshot 2 below. Paste the gadget URL (which you copied to your clipboard above) into the text box.
5. Click **Add Gadget**.
6. The gadget appears in your gadget directory. (It will be highlighted for a short time, so that you can see it easily.)

*Screenshot 1: Gadget directory with 'Add Gadget to Directory' button*
Adding a Confluence gadget to the JIRA dashboard

In the procedure below, 'your Atlassian dashboard' and 'your Atlassian application' refers to the JIRA dashboard and application, respectively.

You can add a gadget from the directory of gadgets that are available to your Atlassian application.

To add a gadget to your Atlassian dashboard,

1. Go to the dashboard by clicking the 'Dashboard' link or the 'Home' link at the top left of the screen.
2. The dashboard will appear, looking something like screenshot 1 below. Click 'Add Gadget'.
3. The 'Add Gadget' screen will display a list of available gadgets in your gadget directory, as shown in screenshot 2 below. Find the gadget you want, using one or more of the following tools:
   - Use the scroll bar on the right to move up and down the list of gadgets.
   - Select a category in the left-hand panel to display only gadgets in that category.
   - Start typing a key word for your gadget in the 'Search' textbox. The list of gadgets will change as you type, showing only gadgets that match your search term.
4. When you have found the gadget you want, click the 'Add it Now' button to add the gadget to your dashboard.

**Screenshot 1: An Atlassian dashboard**
Hello world

Remember The Milk

Username:
Password:

Login

JIRA issues

Apache Struts JIRA

TILES-2071 Separate 2.1.x examples from 2.0.x ones

To show the new features of Tiles 2.1.x, examples in tiles-test webapp should be separated into 2.0.x and 2.1.x ones.

TILES-2071 Fix assembly creation for optional dependencies

The binary assembly should contain optional dependencies in a separate directory.

TILES-2061 Move inheritance resolution from UnDefinitionsFactory to a separate LocalesUnDefinitionMap

Currently the UnDefinitionsFactory resolves inheritance between definitions. It should be moved to a class like LocalesUnDefinitionDao.

This way, we can move the wildcard management code, present in CachingLocalesUnDefinitionDao, into a base class, thus providing wildcards for UnDefinitionsFactory too (that is the default).

TILES-2781 Allow the use of multiple containers

Currently only one Tiles container can be used. It should be possible to use more than one container under the same application, for example, in portal applications.

TILES-2701 Update to Servlet 2.5 and JSTP 2.1

This Javadoc and others should be updated to reflect Servlet 2.5 and JSTP 2.1.
**Note:**

- You need administrator privileges to add a gadget to the list of available gadgets. If you have permission to add gadgets to and remove gadgets from the directory itself, you will see the 'Add Gadget to Directory' and 'Remove' buttons on the 'Add Gadget' screen, as shown in the screenshot about. Please refer to the [Gadgets and Dashboards Administration Guide](#).
- In [Atlassian OnDemand](#) products, it is not possible for administrators to add gadgets to the directory. If you would like to add an Atlassian gadget to a directory, please contact Atlassian Support.

### Configuring Confluence Gadgets for Use in Other Applications

This page tells you how to add a Confluence gadget to another (external) application. The instructions and examples given in this topic focus on adding and using Confluence Gadgets in other web applications.

---

**Atlassian support does not cover gadgets on external sites like iGoogle and Gmail**

In principle, you should be able to add Atlassian gadgets to iGoogle, Gmail and other external sites that support OpenSocial gadgets. However, these external integrations are experimental at this stage and we have encountered problems with them. Please do have fun playing around with them, but be aware that Atlassian does not support the use of Atlassian gadgets on iGoogle, Gmail or other external web sites. See the detailed section on [gadget limitations](#).

Gadgets that display information from Atlassian applications, such as Confluence, should be able to run on iGoogle, Gmail and other web applications that provide OpenSocial containers. Below are specific instructions for iGoogle and Gmail. You can experiment by adding a Confluence gadget to other web sites and applications, such as a Ning community like The Content Wrangler.

**On this page:**

- Overview of Adding a Confluence Gadget to Another Web Application
- Finding a Confluence Gadget's URL
- Adding an Atlassian Gadget to iGoogle
- Adding an Atlassian Gadget to Gmail
- Limitations and Support
- Related Topics

---

*Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
Overview of Adding a Confluence Gadget to Another Web Application

The exact procedure for adding a Confluence gadget depends on the application where you want to add the gadget. The basic steps are the same:

1. Find the Confluence gadget's URL, i.e. the URL for the gadget's XML specification file.
2. Ensure one of the following two mandatory (typically one-off) procedures have been conducted:
   - An OAuth relationship between Confluence (as the 'service provider') and the other web application (as the 'consumer') has been established. Refer to Configuring Authentication for an Application Link for more information about OAuth and instructions on establishing these relationships.
   - A Trusted Applications relationship between Confluence and JIRA has been established. Refer to Configuring Trusted Applications in the JIRA documentation for more information about establishing these relationships.
3. Follow the procedure provided by the external web application where you want to add the Confluence gadget.

Finding a Confluence Gadget's URL

A gadget's URL points to the gadget's XML specification file. These URLs look something like this:

```
http://example.com/my-gadget-location/my-gadget.xml
```

To find a Confluence gadget's URL:

1. Choose the help icon at top right of the screen, then choose Available Gadgets.
2. Find the gadget you want.
3. Copy the Gadget URL link to your clipboard.

Adding an Atlassian Gadget to iGoogle
You can customise your iGoogle home page by adding gadgets and moving them around on the page.

**To add an Atlassian gadget to your iGoogle page:**

1. First find the gadget's URL as described above.
2. Go to iGoogle and log in if you have a username and password.
3. Click Add stuff near the top right of the iGoogle page.
4. The Google gadget directory will appear, showing a list of available gadgets. Click Add feed or gadget in the right-hand panel.

![Add feed or gadget](image)

5. A text box will open, as shown above. Enter or paste the gadget's URL from your clipboard into the textbox and click Add.
6. Go back to your iGoogle home page. The gadget will appear on your iGoogle page.

Adding an Atlassian Gadget to Gmail

You can add gadgets to the left-hand panel of your Gmail page.

**To add an Atlassian gadget to your Gmail page:**

1. First find the gadget's URL as described above.
2. Log in to Gmail.
3. Click Settings near the top right of the Gmail page. The Gmail settings page will appear.
4. Click the Labs tab. The Gmail Labs page will appear. This is a laboratory area or testing ground where Google allows you to use experimental features in Gmail.
5. Scroll down to find the feature called 'Add any gadget by URL'.
6. Select the Enable option, as shown here:

![Enable option](image)

7. Click Save Changes.
8. A new Gadgets tab will appear on your ‘Settings’ page. Click the Gadgets tab. The ‘Gadgets’ page will appear, as shown in the screenshot below.
9. Enter or paste your gadget's URL into the Add a gadget by its URL box, then click Add.
10. The gadget will appear in the left-hand panel of your Gmail page, as shown in the screenshot below.

![Screenshot: Adding a gadget to Gmail](image)
Limitations and Support

Atlassian support does not cover gadgets on external sites like iGoogle and Gmail

In principle, you should be able to add Atlassian gadgets to iGoogle, Gmail and other external sites that support OpenSocial gadgets. However, these external integrations are experimental at this stage and we have encountered problems with them. Please do have fun playing around with them, but be aware that Atlassian does not support the use of Atlassian gadgets on iGoogle, Gmail or other external web sites. See the detailed section on gadget limitations.

Related Topics

The big list of Atlassian gadgets

Confluence Gadgets

This page describes the purpose of the 'Confluence Gadgets' dialog and how to access it, and provides information about the gadgets that are bundled with Confluence.

Gadgets:

- Interact with and provide access to data in your Confluence installation.
- Can be used externally such as on a JIRA dashboard, a page or blog post of another Confluence site, or any compatible page on a web site that accepts gadgets, such as iGoogle. (But see the limitations on using Confluence gadgets in other applications.)

The gadgets dialog

The 'Confluence Gadgets' dialog displays a list of all the Confluence gadgets available in your Confluence installation. The Confluence gadgets bundled with Confluence are described below. Any additional Confluence gadgets installed by your Confluence administrator (typically as Confluence plugins), will also appear in this list.
To access the Confluence Gadgets dialog: Choose the help icon at top right of the screen, then choose Available Gadgets.

You can use a Confluence gadget within the same Confluence site, by adding it to a page or blog post using the gadget macro.

You can also add Confluence gadgets to external applications. See Adding a Confluence Gadget to a JIRA Dashboard and Configuring Confluence Gadgets for Use in Other Applications.

---

**On this page:**
- The gadgets dialog
- Confluence gadgets

**Related pages:**
- Adding a Confluence Gadget to a JIRA Dashboard
- Configuring Confluence Gadgets for Use in Other Applications
- Gadget Macro
- The big list of Atlassian gadgets
- Confluence User's Guide

---

**Screenshot: The 'Confluence Gadgets' dialog**

---

**Confluence gadgets**

This following table lists the gadgets which are bundled with Confluence. Click the name of the gadget for more information.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
</table>

---

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
**Confluence Page Gadget**

The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.

**Activity Stream Gadget**

The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your Confluence site.

**Confluence News Gadget**

The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs and events at Atlassian.

**Confluence Quicknav Gadget**

The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence site. For more information on how to use this feature, refer to the Quick Navigation Aid section of Searching Confluence.

### Activity Stream Gadget

The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your Confluence site.

For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

In addition to showing a list of most recently changed content, the activity stream gadget also groups activities by separate date, and provides an RSS feed link to its content in the top-right corner.

### Activity Stream Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Yes</td>
<td>None</td>
<td>Adds a title to the top of the Activity Stream.</td>
</tr>
<tr>
<td>Spaces</td>
<td>No</td>
<td>None specified (i.e. display content in all spaces)</td>
<td>Filters the content by space. This gadget will display only the pages etc. which belong to the space(s) you specify here.</td>
</tr>
<tr>
<td>Username</td>
<td>No</td>
<td>None specified (i.e. display content by all users)</td>
<td>Filters the results by user. The macro will display only the pages etc. which were last modified by the user(s) you specify here. You can specify one or more user, separated by a comma or a space.</td>
</tr>
<tr>
<td>Number of Entries</td>
<td>No</td>
<td>10</td>
<td>Specify the maximum number of results to be displayed. A maximum of 10 results will be displayed by default. The maximum value that this property can accept is 100.</td>
</tr>
<tr>
<td>-------------------</td>
<td>----</td>
<td>----</td>
<td>----------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Refresh Interval</td>
<td>No</td>
<td>Never/false</td>
<td>Specify the time interval between each 'refresh' action undertaken by the activity stream gadget. A refresh makes the activity stream gadget reflect any new activity that has been conducted on the Confluence site.</td>
</tr>
</tbody>
</table>

Confluence News Gadget

The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs and events at Atlassian.

ℹ️ For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

Clicking an item in the Confluence news gadget takes you directly to the selected blog post of the Confluence Product Blogs feed or event details on the events at Atlassian page.

Clicking More news takes you to the Confluence Product Blogs feed page and clicking More events takes you to the events at Atlassian page.

Screenshot: The News Gadget

Confluence: News Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.
Confluence Page Gadget

The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.

For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

Macros that work with the page gadget
Please note, not all macros work with the page gadget. Please refer to the Working Macros section below for more information.

Confluence Page Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show News?</td>
<td>No</td>
<td>True</td>
<td>Shows a short list of the most recent Confluence Product Blogs.</td>
</tr>
<tr>
<td>Show Events?</td>
<td>No</td>
<td>True</td>
<td>Shows a short list of the most recent events at Atlassian.</td>
</tr>
<tr>
<td>Show Banners?</td>
<td>No</td>
<td>True</td>
<td>Shows any banner advertisements (if available).</td>
</tr>
</tbody>
</table>

Confluence Page Gadget

Two penguins find themselves together on an ice floe, drifting helplessly into warmer waters. The penguins are very fond of each other. Suddenly, the ice floe splits in half, right between the penguins. As they drift apart, one penguin sadly waves a flipper and calls out "Chocolate milk!"

Sample Page
### Space

<table>
<thead>
<tr>
<th>No</th>
<th>None</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Specify the space that your desired page is located in. Suggestions will display in a dropdown when you start typing. (Note, this property is only used to make searching for pages easier. It is not required.)</td>
</tr>
</tbody>
</table>

### Page

<table>
<thead>
<tr>
<th>Yes</th>
<th>None</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Specify the page that you want to display in your gadget. Suggestions will display in a dropdown when you start typing.</td>
</tr>
</tbody>
</table>

### Show View Link

<table>
<thead>
<tr>
<th>No</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Select whether to display a link to view the page on your Confluence site. Clicking the link will open the page in Confluence.</td>
</tr>
</tbody>
</table>

### Show Edit Link

<table>
<thead>
<tr>
<th>No</th>
<th>No</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Select whether to display a link to edit the page on your Confluence site. Clicking the link will open the page for editing in Confluence.</td>
</tr>
</tbody>
</table>

### Refresh Interval

<table>
<thead>
<tr>
<th>No</th>
<th>Never/false</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Specify the time interval between each ‘refresh’ action undertaken by the page gadget. A refresh makes the activity stream gadget reflect any new activity that has been conducted on the Confluence site.</td>
</tr>
</tbody>
</table>

### Working Macros

The Confluence page gadget will only render a subset of the macros that are used in Confluence correctly. Refer to the table below for the list of macros that work and do not work with the page gadget and known limitations.

![Some of the issues with macros in the page gadget can be worked around, if you are comfortable developing in Confluence. Please see Troubleshooting Macros in the Page Gadget for more information.](image)

**Key:**
- ✅ Works with the page gadget
- * Partially works with the page gadget
- ✗ Does not work with the page gadget

<table>
<thead>
<tr>
<th>Macro</th>
<th>Works with page gadget?</th>
<th>Limitations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Stream</td>
<td>✗</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Anchor (within a page)</td>
<td>✅ *</td>
<td>Opens in a new page</td>
</tr>
<tr>
<td>Attachments</td>
<td>✅</td>
<td>N/A</td>
</tr>
<tr>
<td>Feature</td>
<td>Status</td>
<td>Notes</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------</td>
<td>-----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Blog Posts</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Chart</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Children Display</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By Label</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By User</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Excerpt</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Gallery</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Include Page</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Info</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Labels List</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Livesearch</td>
<td>✗</td>
<td>N/A</td>
</tr>
<tr>
<td>Note</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata Summary</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Pagetree Search</td>
<td>✗</td>
<td>N/A</td>
</tr>
<tr>
<td>Pagetree</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Panel</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Quick Nav</td>
<td>✗</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Recently Updated</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>RSS Feed</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Section &amp; Column</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Spaces List</td>
<td>✔️</td>
<td>N/A</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>✔️ *</td>
<td>Works, however links will be opened in a new browser window when clicked.</td>
</tr>
<tr>
<td>Team Calendars</td>
<td>✗</td>
<td>See here for the Improvement Request: TEAMCAL-862 - Make Team Calendars display in a Confluence Page Gadget, for use on a JIRA Dashboard REOPENED</td>
</tr>
<tr>
<td>View File (PDF or PPT)</td>
<td>✔️ *</td>
<td>Works, but you may need to refresh the gadget the first time (see CONF-19932).</td>
</tr>
</tbody>
</table>
**Widget Connector**

Only works for some content:

- **Works:** blip.tv, Episodic, Flickr, Google Calendar, presentations on Google Docs, MySpace Video, Scribd, Skitch.com, SlideRocket, SlideShare, Viddler, Vimeo, YouTube, Dailymotion, Metacafe, FriendFeed, Yahoo Video, Wufoo HTML Form Builder
- **Does not work:** FriendFeed, Google Gadgets, Google Video (consumer service discontinued), Twitter, Widgetbox, DabbleDB, BackType

---

**Confluence Quicknav Gadget**

The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence site. For more information on how to use this feature, refer to the Quick Navigation Aid section of Searching Confluence.

ℹ️ For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

**Screenshot: Using the QuickNav Gadget**

![Example QuickNav Gadget](image)

**Confluence QuickNav Gadget Properties**

This gadget has no properties and cannot be customised.

**Adding JIRA Gadgets to a Confluence Page**

The Confluence Gadget macro is a specific type of macro which is used to display gadgets, including JIRA gadgets, in a Confluence page. Once you have configured external gadgets in the Confluence Administration Console, they will appear in the Macro Browser.

Before you can start adding JIRA Gadgets:

- Your JIRA administrator will need to configure JIRA to trust Confluence via Application Links. (Not required if your JIRA site allows anonymous access)
- Your Confluence administrator will need to add the JIRA gadget URL to the list of authorised external gadgets
To add a JIRA Gadget to a Confluence page:

- Choose Insert > Other Macros.
- Navigate to the gadget you wish to add to the page and choose Insert.

Refer to the Gadget Macro page for more information on adding the macro to your page.

Developing Technical Documentation on Confluence Wiki

Confluence now ships with a space blueprint for creating documentation spaces. It has a homepage that can be customised to suit your needs and the sidebar displays all pages in the space in a page tree.

Go to Create Space > Documentation Space to try it out for yourself.

Welcome! This is a guide to using Confluence wiki for technical documentation. You will find this guide useful if you want to write a technical manual such as a user's guide, administrator's guide, installation guide, and so on.

- Creating your Technical Documentation Space
- Using Templates in Technical Documentation
- Re-using Content in Technical Documentation
- Managing the Life Cycle of your Technical Documentation
- Providing PDF Versions of your Technical Documentation
- Exporting and Printing Technical Documentation
- Essential Confluence Features for Technical Documentation
- Confluence Add-ons for Technical Documentation
- Further Reading about Developing Technical Documentation on Confluence

Related pages:

- Confluence User's Guide
- Confluence Administrator's Guide

Creating your Technical Documentation Space

This guide is for people who want to develop and publish technical documentation on Confluence wiki. You will find it useful if you want to write a technical manual such as a user's guide, administrator's guide, installation guide, and so on. This page is a quick-start guide to creating a wiki space for technical documentation.

Quick guide to creating a technical documentation space:

- Add a space and select the Documentation theme.
- Set the space permissions.
- Change the title and content of the space home page.
- Customise the Documentation theme.
- Create an inclusions library to manage your re-usable content.
- Create the table of contents for your manual or manuals, by adding top-level pages for all the usual sections (user's guide, administrator's guide, and so on).
- Customise your PDF layout and stylesheet, if required.
- Hint: Now that you have a good skeleton for a documentation space, save the space as a template space.

The rest of this page gives more details of the above procedure.

On this page:

- Step 1. Add your space
- Step 2. Set the space permissions
- Step 3. Customise the title and content of the space home page
- Step 4. Customise the Documentation theme
- Step 5. Create an inclusions library
- Step 6. Create the table of contents
- Step 7. (Optional) Customise the PDF layout and stylesheet
- Step 8. Save your new space as a template

Step 1. Add your space
Below is a quick guide to adding a space. See Creating a Space for a full description.

1. Go to the Confluence dashboard and choose Create Space > Blank Space.  
   *Hint:* If you cannot see Create Space, this means that you do not have permission to add spaces. Please contact your Confluence administrator.
2. Choose Next then enter a space name and a short, unique space key.
3. Leave the permission settings as default, or choose to allow only yourself to view or contribute content to this space. You can change these settings later and with more flexible options.
4. Choose Create.
6. Choose Look and Feel > Themes and select the Documentation theme.
7. Choose OK.

The home page of your new space will appear. Because you created the space, you are the space administrator. Now you can do some basic configuration, as described in the sections below. From this point on, instructions will refer to navigating in the Documentation theme, which is slightly different to the default theme.

**Step 2. Set the space permissions**

Define the space permissions to determine who can do what in your new space.

1. Choose Browse > Space Admin at the top of the screen.  
   *Note:* The ‘Space Admin’ option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Permissions.
3. Choose Edit Permissions.
4. Set the permissions to suit your needs then choose Save All.
   - You can add groups and/or individual users to the list, then select the permissions for each group or user.
   - You can also set the permissions for anonymous users – these are people who have not logged in to the wiki. Anonymous access is available only if enabled for the entire Confluence site.
   - Note that you can change these permissions at any time. You may want to restrict the permissions to specific groups now, and later open the space to more people.

**A bit more about permissions**

Confluence has a robust and granular permissions scheme that you can use to determine who can view, comment on and even update the documentation. There are three levels of permissions in Confluence:

- Global permissions apply across the entire site.
- Space permissions apply to a space.
- Page restrictions allow you to restrict the editing and/or viewing of a specific page. Below we discuss a way of using these in the draft, review and publishing workflow.

**Space permissions** in Confluence are simple yet granular enough to be useful for technical documentation. You can:

- Use the permission levels to control who can create pages in the space, delete pages, create comments, delete comments, administer the space, and so on.
- Grant a permission level to one or more users, and/or to one or more groups, and/or to anonymous users.

**Terminology:**

- *Anonymous* means people who have not logged in to the wiki.
- The *confluence-users* group is the default group into which all new users are assigned (in OnDemand this group is called *users*). Everyone who can log in to Confluence is a member of this group.

For example, you might allow your team full edit and administration rights while others can only add comments. Or you might grant the general public access to your documentation, while only staff members can update it.
For detailed information, see the documentation on:

- Global permissions
- Space permissions
- Page restrictions
- Users and groups

Step 3. Customise the title and content of the space home page

When you created your space, Confluence created a home page with default content and a default title. You will want to change the title and content.

1. Go to your space home page.
2. By default, the page title is 'X Home', where 'X' is the name you gave the space.
3. Choose Edit.
4. The page opens in the editor. Change the title to suit your needs.
5. Update the content to suit your needs.  
*Hint:* If you do not know what to add yet, just add a short description. You can refine the content of the page later. Take a look at an example of a home page.

6. Choose **Save**.

**Step 4. Customise the Documentation theme**

When you added the space you chose the Documentation theme, which provides a left-hand navigation bar and a good look and feel for technical documentation. If necessary, you can configure the Documentation theme to add your own page header and footer or to customise the default left-hand navigation bar. These customisations affect the online look and feel of your documentation. See Configuring the Documentation Theme for the full description.

1. Choose **Browse > Space Admin.** (If you have not yet applied the Documentation theme choose **Space Tools > Look and Feel > Themes.**)
2. Choose **Themes** in the left menu.
3. If the space is not yet using the Documentation theme, apply the theme now.
4. Choose **Configure theme**.

The 'Documentation Theme Configuration' screen appears. Customise the left-hand navigation bar, header and footer to suit your needs. Details are in the documentation. Here are some hints:

- The **Page Tree** check box determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.
- The **Limit search results to the current space** check box determines whether Confluence will search only the current space or the whole Confluence site. This setting affects the default search. Viewers can override it each time they do a search.
- Enter text, images, macros and other wiki markup into any or all of the three text boxes for the the left-hand navigation bar, header and footer. You can use the **Include macro** and the **Excerpt Include macro** to include re-usable content.
- Any content you add to the navigation panel will appear **above** the default page tree.
- If you like, you can remove the default page tree (by unticking the box) and add your own, customised version of the **Pagetree** macro instead.

5. Choose **Save**.
Example of a customised footer

Take a look at the footer of a page in the Crowd documentation space.

To produce the above footer, we have the following content in the footer panel in the Documentation theme configuration screen:

```
{include:_Documentation Footer|nopanel=true}
{include:ALLDOC:_Copyright Notice|nopanel=true}
```

Here it is in text form:

```
{include:_Documentation Footer|nopanel=true}
{include:ALLDOC:_Copyright Notice|nopanel=true}
```

The above content consists of two Include macros.

- The first macro includes a page called _Documentation Footer. This page contains the big blue buttons and hyperlinked text.
- The second macro includes a page from a different space, the ALLDOC space, called _Copyright Notice. This page includes our standard copyright notice, used in all our documentation spaces.

Step 5. Create an inclusions library

In Confluence, you can dynamically include content from one page into another page. You can include a whole page into another one, using the Include macro. You can also define an ‘excerpt’ on a page, and then include that excerpted text into another page using the Excerpt Include macro.

To organise your re-usable content, we recommend that you create a set of pages called an ‘inclusions library’.

1. Choose Create and create a new page in your space.
2. Enter a suitable title. We use '_InclusionsLibrary'. The unusual format of the title helps to let people know this page is special.
3. Enter some content and save the page. We enter text explaining the purpose of the inclusions library and how to re-use the content. You can copy our text by clicking through to one of the example pages listed below.
4. Choose Browse > Pages and drag your new page above the space homepage.
5. Go to your new inclusions page and choose Create to add child pages containing your re-usable content. See the examples of our own inclusions libraries listed in the examples below.
Some notes about inclusions libraries:

- The inclusions library is not a specific feature of Confluence. The pages in the inclusions library are just like any other Confluence page.
- The pages are located at the root of the wiki space, not under the home page. This means that they will not appear in the table of contents on the left and they will not be picked up by the search in the left-hand navigation bar either.
- The pages will be picked up by other searches, because they are just normal wiki pages.
- We have decided to start the page name with an underscore. For example, '_My Page Name'. This indicates that the page is slightly unusual, and will help prevent people from changing the page name or updating the content without realising that the content is re-used in various pages.

Examples of inclusions libraries

Here are some examples in our documentation:

- Crowd inclusions library
- Confluence inclusions library

Step 6. Create the table of contents

Create the table of contents for your documentation, by adding the top-level pages for all the usual sections:

- User's guide
- Administrator's guide
- Installation guide
- Configuration guide
- Release notes
- FAQ
- Whatever else you need

Follow these steps to create the table of contents:

1. Go to your space home page.
2. Choose Create to add a page as a child of the homepage.
3. Type the page title, 'User's Guide'.
4. Type the content of the page.
   
   Hint: If you do not know what to add yet, just add a short description then refine the content of the page later. If you like, you can add the Children macro. That will act as a table of contents on the page once you have added child pages.
5. Choose Save.

Now do the same for all the sections of your technical document.

Step 7. (Optional) Customise the PDF layout and stylesheet

If you are planning to provide PDF versions of your documentation, you may want to customise the PDF layout and styles for your space. You can skip this step for now and do it later, if you prefer. The instructions are in a separate section of this guide, dedicated to PDF. See Providing PDF Versions of your Technical Documentation.

Step 8. Save your new space as a template

This is a useful suggestion. Once you have set up your first documentation space and are more-or-less happy with it, use the Copy Space add-on (see notes below) to copy the space while it still has very little content. From this point on, you can copy it each time you want to create a new documentation space.

1. Choose Browse > Space Admin
2. Choose Copy Space in the left menu
   
   Hint: If you cannot see the 'Copy Space' option, this means that the add-on is not installed on your Confluence site. Refer to the documentation on installing add-ons. (Not applicable to Confluence OnDemand.)
3. The 'Copy Space' screen will appear. Enter the details as prompted, to copy your space to another new space.
4. Choose **Save**.

You now have a template space. From this point on, you can use the Copy Space add-on to copy the template space each time you want to create a new documentation space.

**Notes:**

- The Copy Space add-on is not covered by Atlassian support. However, the Atlassian technical writers use it for all our documentation. If you like, you can vote for an comment on the request for Atlassian support to cover this add-on: CONF-14198.
- Your site administrator will need to install the Copy Space add-on into Confluence. Refer to the documentation on installing add-ons. *Not applicable to Confluence OnDemand.*

**Next Steps**

You now have the basic structure and configuration for your technical documentation space. You have also created a handy template to use next time you need a space. What next? Take a look at Using Templates in Technical Documentation.

**Using Templates in Technical Documentation**

This page is part of the guide to developing technical documentation on Confluence Wiki. We have already shown you how to create your technical documentation space. Now we offer an introduction to the templates that Confluence provides.

**Quick guide to templates in Confluence:**

- A template is a page with predefined content that can be used as a prototype when creating other pages.
- Templates are available across the Confluence site (global templates) or per space (space templates).
- Both 'global templates' and 'space templates', as described on this page, define the content of a page. They do not define the content of an entire space.
- To create a template for an entire space, see our guide to creating your documentation space.
- Confluence blueprints provide predefined templates and added functionality.
- You can import predefined templates from the Atlassian Marketplace.
Deciding where to put your templates

Decide whether your template is useful across more than one space.

- If yes, create a global template. You will need Confluence administrator permissions.
- If no, create a space template.
  - You will need space administrator permissions for the relevant space(s).
  - You may have already saved your documentation space as a template, as described in our guide to creating your documentation space. In that case, it may be useful to save your template page in your template space. When you later copy the space, the template pages will be copied too.

Creating a global template

1. Choose the cog icon, then choose General Configuration under Confluence Administration.
2. Choose Global Templates and Blueprints in the left-hand panel.
3. Choose Add New Global Template.

See Administering Site Templates for more information.

Creating a space template

1. Choose Browse > Space Admin at the top of the screen.
   - Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose Templates from the space administration options.
3. Choose Add New Space Template.

See Adding a Template for more information.

Importing templates

If you have System Administrator permissions, you can download pre-defined templates from the Atlassian Marketplace in the form of a template bundle. Each template bundle contains one or more templates, created by Atlassian or third parties. See Importing Templates.

Using templates provided by blueprints

A blueprint is a page template with added functionality to help you create, manage and organise content in Confluence.

Confluence ships with some predefined blueprints. You can also download additional blueprints from the Atlassian Marketplace. You can customise the blueprint templates to suit your individual needs and even develop your own blueprints.

See Working with Blueprints.

Using a template to create a page

When people create a page on your Confluence site, they can choose to base their new page on a template.

1. Go to the page that will be the parent of your new page, and choose Create.
2. You will see a list of all available templates. Select a template then choose Next.

Next Steps

You now have a good idea of how Confluence templates work. What next? Take a look at Re-using Content in Technical Documentation.
Re-using Content in Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. In the page about creating your technical documentation space, we showed you how to set up an 'inclusions library' to contain content that you can re-use on more than one page. Now we offer further guidelines on re-using content in your documentation space.

Your documentation may be about using a software application, or it may be a technical manual for your product range. On this page, we use the term 'widget' to describe the things that you are documenting, such as the screen, form, document, product or object.

Quick guide to re-using content:

- Create an 'inclusions library' to manage your re-usable content. See our guide to creating your technical documentation space.
- Use the excerpt macro to define a re-usable section ('excerpt') on a page, or just decide to re-use the entire content of the page.
- Use the excerpt-include macro to include the excerpt from one page onto another page.
- Use the include macro to include the entire content of a page onto another page.
- Consider installing the Multi Excerpt add-on if you need to define multiple excerpts per page.

The rest of this page gives an overview and more details of the above procedures.

On this page:

- Reasons for re-using content
- Defining an inclusions library
- Working with excerpts and inclusions
  - Using the Include Page macro
  - Using the Excerpt Include macro
  - Using the Multi Excerpt add-on
- An example of content re-use: a glossary
  - Creating a one-page glossary
  - Creating a glossary with child pages
  - Referring to glossary terms
- Further reading

Reasons for re-using content

A golden rule for technical documentation is to write the content only once but allow that content to be used in many places and in many forms.

For example, you may have the following types of content:

- A technical manual that describes each widget in detail.
- Tips and tricks on how to get the most out of the widget.
- A step-by-step user guide for first-time users on how to use the most common widgets.
- A training manual with exercises or videos that people can follow in their own time.
- A one-page cheat sheet for users to stick up on their workstation.
- Text for a sales brochure that is sent out to a print house for production.

Each of these types of content will share common information, such as a glossary entry, a technical or marketing description of the widget, or a step-by-step guide on how to use the widget.

Some initial planning of your technical documentation will allow you to re-use any or all of the content you write, so there is only ever one place to update the content, and those changes flow through to all of your other documentation.

Defining an inclusions library

We recommend that you create an ‘inclusions library’ to manage your re-usable content. If you have not already done this, see our guide to creating your technical documentation space.

Working with excerpts and inclusions

Excerpts and inclusions (sometimes called ‘includes’) are very useful for re-using content:

- Use the Excerpt macro (excerpt) to define a re-usable section ('excerpt') on a page.
• Use the Excerpt Include macro (`excerpt-include`) to include the excerpt on another page.
• Use the Include Page macro (`include`) to include the entire content of a page onto another page.

A simple use case for an inclusion is a note or warning that is used in many places in your documentation. Here is an example:

---

**Example note -- "Draft in progress"**
This document is still in draft status. Please treat the content with caution.

---

**Tip:** Keep your re-usable pages short and sweet. Do not worry if you find that you need hundreds of pages to hold your inclusions. It helps to keep things separate and organised.

**Using the Include Page macro**

In this example, we use the Include Page macro to create a note that you can re-use on your documentation pages. The Include Page macro will include the entire content of one page into another page.

1. Create a page in your inclusions library called `_Draft Note`.
2. Add the content of the page. In this example, we use the Note macro with some text in the title and body:

   ```
   {note:title=Draft in progress}This document is still in draft status. Please treat the content with caution.{note}
   ```

3. Use the Include Page macro to include that note in any page in your documentation. For example:

   ```
   {include:_Draft Note|nopanel=true}
   ```

See the documentation on the **Include Page macro** for more details.

**Using the Excerpt Include macro**

An excerpt is a section of a page that you can include into another page.

1. Use the `excerpt` macro to define any content in your page that you want to be able to use elsewhere. This content can be as short as a word or as long as the entire page. For example, let's assume we have a page called 'My Short Poem':

   ```
   I really love this poem:
   {excerpt}
   Mary had a little lamb
   Its fleece was white as snow
   {excerpt}
   And I'm going to use it all over the place.
   ```

2. Use the Excerpt Include macro to include the excerpt into another page. For example:

   ```
   {excerpt-include:My Short Poem|nopanel=true}
   ```

You can only define one excerpt on a page. See the documentation on the **Excerpt Include macro** for more details.

To have multiple excerpts on a page, see the 'Multi Excerpt add-on' below.

**Using the Multi Excerpt add-on**

The Multi Excerpt add-on provides additional macros that enable you to have multiple excerpts on a page. A good example of where you would find this useful is in the glossary page discussed below. If you want to include a single glossary entry or a subset of the glossary entries in another page, then the named excerpts provided by
the Multi Excerpt add-on are very useful.

Notes:

- The Multi Excerpt add-on is a commercial add-on and is not free.
- Your Confluence system administrator will need to download and install the add-on into your Confluence site before you can use the macros described below. Refer to the documentation on installing add-ons.
- Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support. Please refer to the Multi Excerpt add-on page for support details.

To have multiple excerpts on a page:

1. Use the following code on the base page containing the content you want to use elsewhere:

   ```
   {multi-excerpt:name=ExcerptName1}
   Excerpt text 1
   {multi-excerpt}
   Any other text
   {multi-excerpt:name=ExcerptName2}
   Excerpt text 2
   {multi-excerpt}
   ```

2. Use the following code on the page where you want to include the named excerpt:

   ```
   {multi-excerpt-include:pageTitle=PageName|name=ExcerptName1|nopanel=true}
   ```

3. You can also include excerpts from other spaces using the following syntax:

   ```
   {multi-excerpt-include:spaceKey:pageName|name=excerptName|nopanel=true}
   ```

See the Multi Excerpt add-on page for more details.

An example of content re-use: a glossary

A glossary is something that most technical documentation will require. There are a few ways to set up glossaries in Confluence. These are the most popular:

- All glossary entries on one page.
- Each glossary entry on separate child pages with a main page showing excerpts of the glossary.

Once you have defined the glossary entry, you can refer to it from the main pages of your technical documentation.

*Creating a one-page glossary*

This style of glossary is useful if the glossary entries tend to be short and there are not too many of them. The code blocks below use wiki markup. To insert wiki markup onto your page, open the editor and choose Insert > Wiki Markup.

1. Create a page named Glossary.
2. Add an alphabetical index at the top of the page and a heading for each letter of the alphabet:
3. Enter each glossary entry under the relevant alphabetical heading. Each glossary entry (term) should include:
   - An anchor tag, so that you can link to it from other pages.
   - The term itself.
   - A definition of the term.
   - A link to the page in your technical documentation that explains the term in greater detail, where relevant.

   ![Glossary entries example]

   (anchor:MyGlossaryTerm)
   h4. MyGlossaryTerm
   This is the definition of MyGlossaryTerm. See [Page Name] for more information.

4. Optionally, include a horizontal line between the terms. This depends on how long each entry is. If your glossary tends to have short entries, it may look too cluttered with horizontal lines.

   ---

See the glossary in the Confluence documentation for an example of this style of glossary (without the alphabetical index).

**Creating a glossary with child pages**

This style of glossary is useful if the glossary entries tend to be quite long or have additional information over and above the definition of the term. The code blocks below use wiki markup. To insert wiki markup onto your page, open the editor and choose Insert > Wiki Markup.

1. Create a page named Glossary.
2. Create a child page for each glossary entry (term). Each child page should contain:
   - The term as the title of the page.
   - The definition of the term in the body of the page.
   - Excerpt tags (excerpt) tags surrounding the definition.
   - Any additional information after the excerpt tags.

   ![Child page example]

   (excerpt)
   This is the definition of MyGlossaryTerm
   (excerpt)
   More information to describe MyGlossaryTerm

3. On the 'Glossary' page, use the children macro to show the excerpts from each child page in a list, with the page name displayed in 'h4' style.

   ![Child page list example]

   {children:excerpt=true|style=h4}

See the glossary in the Crowd documentation for an example of this style of glossary.
Referring to glossary terms

In the main pages of your technical documentation, create a link to the glossary page for each glossary term.

__[MyGlossary Term|Glossary#MyGlossaryTerm]__

Note that this is a standard page link with an anchor. We have formatted the link as italics, because it helps to have the glossary links looking different to other page links. Readers can just skip over the glossary link if they are already familiar with the term.

Further reading

A blog post about content re-use: Technical Writing in a Wiki - Content Re-use and Structure (November 2010).

Next Steps

You now have a good idea of how to re-use content in a Confluence documentation space. What next? Take a look at Managing the Life Cycle of your Technical Documentation.

Managing the Life Cycle of your Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. We have already shown you how to create your technical documentation space, including how to set permissions for your space. Now we offer a quick-start guide to managing the life cycle of your technical documentation in Confluence. The life cycle includes drafting, reviewing and publishing a document, as well as managing documentation that is release-specific.

Quick guide to managing the technical documentation life cycle:

- Create draft pages with restricted permissions, to hide them until they are ready for publication.
- Set the permissions to allow reviewers to comment on and/or update the pages.
- When ready, publish the page by removing the permission restrictions.
- Monitor updates to your draft and published pages by watching your space and/or subscribing to RSS feeds.
- Use spaces as a mechanism for matching your documentation version to product releases: one space per major release number.
- Consider installing add-ons for extended workflow and publication management.

The rest of this page gives more details of the above procedures.

On this page:

- Using the built-in Confluence functionality to manage workflow and release cycle
  - Drafting, reviewing and publishing a page
  - Keeping track of documentation updates
    - Viewing the history of a page
    - Receiving email notification of updates
    - Monitoring updates via RSS feeds
  - Release management
    - Space keys
    - The release management process
  - Other scenarios using the built-in Confluence functionality
    - Using add-ons for extended workflow, publication and version management
  - Notes

Using the built-in Confluence functionality to manage workflow and release cycle

This section describes how to use the built-in Confluence functionality to manage your workflow (draft, review, publish) and to align your documentation version control to the product release cycle.

In this scenario we also assume that you want a live space that always has the same space key and always
contains the latest version of your documentation. This scenario suits the requirements of an organisation that wants their technical documentation to be ‘live’. Various groups of people can refine the content as and when required. People can also subscribe to the space, knowing that they will always get the latest version of the documentation and comments.

This is the way we manage our documentation at Atlassian. The content of the wiki is dynamic, continuously updated, commented on, subscribed to and watched by thousands of people all over the world.

**Drafting, reviewing and publishing a page**

The workflow is as follows.

1. Create a page with restricted permissions. For example, you might restrict viewing to a group of people such as your team. On a public wiki, you might restrict viewing to staff members, so that the general public cannot see the page.
2. Write the page content.
3. Ask other people to review the page. They can add comments to the page or simply edit the page content directly.
4. Publish the page when ready, by doing the following:
   - Delete the comments on the page.
   - Remove the permission restrictions on the page. The page has now been published. The space permissions and site permissions now determine who can see and/or update the page.

The screenshot below shows a page under review. Notice the lock icon at top left, indicating that restricted permissions apply to this page.

**Keeping track of documentation updates**

On a wiki, it is quite usual for a number of different people to update a single page. Technical writers need to know what happens to our documents, both during review and after publication.

**Viewing the history of a page**

Confluence creates a new version of the page every time someone edits the page. The page history shows all the versions, with date, author, and any comments made on the update.

Go to the page and choose **Tools > Page History**.
On the page history view, you can:

- View the content of a specific version of the page.
- Revert to (restore) a specific version.
- Select any two versions and ask for a comparison, to see what has changed between those two versions.

See Page History and Page Comparison Views for detailed information.

It is all very well to go to a specific page and see what has happened to it, but how do you know when to go and look at the page? You need a notification of any changes made to your documentation space.

In Confluence, you can monitor updates to your documentation via email notifications and via RSS feeds.

Receiving email notification of updates

You can ‘watch’ a page or an entire space. Whenever anyone updates the page or space, you will receive an email notification.

1. Log in to Confluence, if you have not already done so.
2. Go to the page or blog post.
3. Choose Watch and select the relevant check box.

See Subscribing to Email Notifications of Updates to Confluence Content for details of the various notifications Confluence will send, and how to configure your notification settings.

Monitoring updates via RSS feeds

RSS feeds provide another way to keep track of updates. The simplest way to build an RSS feed is to use Confluence’s feed builder. This will give you a URL that you can ping to get the latest updates.

Below we describe how to set up a useful feed for your technical documentation space. Remember that you can adjust the settings to suit your own needs.

1. Choose Help > Feed Builder. The RSS feed builder form appears.
2. Check the boxes to select all the content types. (Even if you are not expecting comments, blog posts or mail in your documentation space, it does no harm to receive notifications if they do arrive.)
   - Pages and the comments and attachments on pages.
   - Blog posts and their comments and attachments.
   - Mail.
3. Select your documentation space from the list. Press Ctrl and click to select multiple spaces.
4. Choose Create RSS Feed.
5. This will take you to a new screen. Drag or copy the link into your RSS reader. The feed URL is linked to the words Drag or copy this link to your RSS reader.

Now that you have set up your RSS feed, you need to decide how to read it. There are various options to choose from. For example:

- Use an RSS reader, such as the Sage add-on for Firefox.
- Use an email client, such as Thunderbird.
Release management

Let's assume that your product goes through a regular release cycle, and that you need to retain separate documentation for each major version of the product.

At Atlassian, we use spaces as our version-control mechanism.

- **Archive spaces.** At each release, we create a new archive space to house the previous version of the documentation.
- **The live space.** The documentation for the latest version of the product resides in the live space. The live space always retains the same space key and is always available for viewing and updating.

**Space keys**

The live space has just the product name as its space key. For example, for the Bamboo product the space key is 'BAMBOO'. (See the Bamboo documentation space.)

For the archived versions, we use a combination of the product name plus version number as the space key. For example, we use 'BAMBOO040' for the Bamboo 4.0 documentation, 'BAMBOO041' for the Bamboo 4.1 documentation, and so on.

The release management process

Here is an overview of the process we follow at Atlassian.

1. **Leading up to release date.** Work with hidden draft pages in the live space. A 'hidden draft' is simply a page that has restricted permissions applied:
   - For each new feature, create a new page with restricted permissions.
   - If you need to update existing pages, create a hidden copy of the existing page and apply the updates to the copy.
   - Follow the usual draft and review procedure for each page.

2. **A few days before release date.** Use the Copy Space add-on to copy the live space to a new space. This creates a snapshot of the current documentation, and will act as an archive for the current release which is soon to become the previous release. (We described the use of the Copy Space add-on in the earlier section of this guide: Creating your Technical Documentation Space.)

3. **On release date.** Publish the updated documentation for the new version of the product:
   - Rebrand the live documentation space to reflect the new release number. In other words, change the space name and any other descriptions that include the product release number.
   - Unhide all the new pages, by removing the permission restrictions on each hidden page.
   - Copy the content of the updated pages to the proper pages, then delete the copies.
   - Export the newly updated space to PDF, HTML and XML, for those customers who prefer offline versions of the documentation.

Note that the above process is applicable to major releases of the product. For minor bug-fix releases, we simply update the documentation in the live space. We do not create archive spaces for every minor release.

The example below shows an extract from the dashboard of our documentation wiki, listing the spaces for different versions of the Bamboo documentation. (Bamboo is one of our products.) Each space holds the documentation for a specific major release of Bamboo.

*Screenshot: Archive Bamboo spaces and Bamboo Latest for the current version of the documentation.*
Other scenarios using the built-in Confluence functionality

It is easy to design other ways of managing your documentation spaces using the built-in Confluence functionality. For example, the simplest scenario is to publish a new space for every new release of your product, using the same Copy Space add-on as described above.

Using add-ons for extended workflow, publication and version management

For advanced workflow features, consider installing the Ad Hoc Workflows add-on onto your Confluence site.

For advanced publication and concurrent version management consider using the Scroll Versions add-on. With Scroll Versions, you can set up and manage concurrent versions of your documentation in a single space. You can manage multiple versions of software, different product variants, and even multiple languages of documentation. Plan your page updates for a specified version and then publish them all at once.

See the documentation of Scroll Versions for more information.

Similarly, consider using the Content Publishing add-on to publish content from a master space to a published space. In this scenario, you will create a master space that contains your drafts in progress and new releases. The master space is visible only to the authors and reviewers. You will periodically publish the master space to a published space. This suits the requirements of an organisation that needs a 'published' or 'official' set of documentation, published only when a new version of the product is released. There is no requirement for continual updating of the documentation.

Automatic publishing. The Content Publishing add-on can work together with the Ad Hoc Workflows add-on to publish pages automatically when the page reaches a specified state in the workflow.

Notes

- Installing add-ons. If you decide to use additional add-ons, your system administrator will need to install them into your Confluence site. Refer to the documentation on Installing add-ons.

- Add-on support. Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Next steps

Now you know about managing your workflow and documentation release process on Confluence. What next? Take a look at Providing PDF Versions of your Technical Documentation.
Providing PDF Versions of your Technical Documentation

This page is part of the guide on Developing Technical Documentation on Confluence Wiki.

Confluence is a platform for publishing online documentation. It also provides functionality for producing PDF versions of your documentation, allowing you to print the documentation, or to provide a copy to customers who are unable to access the online version. This guide describes how to export your technical documentation to PDF using Confluence’s built-in PDF export. We also introduce a third-party add-on that provides additional PDF layout and style functionality.

Quick guide to PDF exports:

- Customise the PDF layout (title page, header and footer) and style, for use each time you export your documentation.
- Export a single page to PDF.
- Export a selection of pages or an entire space to PDF.
- Consider installing a third-party add-on for advanced PDF export functionality.

The rest of this page gives more details of the above procedures.

On this page:
- Customising the PDF layout and style
- Editing the PDF layout
- Setting a global PDF layout
- Setting the PDF layout at space level
- Editing the PDF stylesheet
- Setting a global PDF Stylesheet
- Setting a space PDF stylesheet
- Examples of PDF customisation
- Exporting to PDF
- Exporting a single page to PDF
- Exporting a selection of pages or a space to PDF
- Using the Scroll PDF Exporter add-on (Not applicable to Confluence OnDemand.)
- Notes

Customising the PDF layout and style

If you plan to create PDF versions of your documentation, you may want to customise the PDF layout and styles for your space. These customisations will be applied every time you export documentation to PDF.

Under PDF layout you can add HTML to customise the PDF title page, and the page headers and footers. Under PDF stylesheet, you can adjust the appearance of the PDF pages.

Editing the PDF layout

Setting a global PDF layout

1. Choose the cog icon, then choose General Configuration under Confluence Administration.
2. Choose PDF Layout. You can enter HTML and CSS that will be rendered on the PDF title page, as well as page headers and footers.

Setting the PDF layout at space level

1. Go to the space and choose Space tools > Look and Feel on the sidebar. You'll need Space Admin permissions to do this.
2. Choose PDF Layout.
3. Choose Edit.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
   Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the confluence-administrators group).
2. Choose **PDF Layout** in space administration options.
3. Choose **Edit**.

You can customise the HTML that is generated for the following areas when the space is exported to PDF:

- **PDF Space Export Title Page** – title page.
- **PDF Space Export Header** – page headers.
- **PDF Space Export Footer** – page footers.

Enter your customisations into each text box as required. The PDF layout section accepts HTML code. You can include inline CSS in the HTML too.

**Editing the PDF stylesheet**

**Setting a global PDF Stylesheet**

1. Choose the cog icon, then choose **General Configuration** under Confluence Administration.
2. Choose **Look and Feel > PDF Stylesheet**. The following screen allows you to enter and save CSS code that will render content on each page.

**Setting a space PDF stylesheet**

1. Go to the space and choose **Space tools > Look and Feel** on the sidebar. You'll need **Space Admin permissions** to do this.
2. Choose **PDF Stylesheet**.
3. Choose **Edit**.
4. Enter your customisations.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** at the top of the screen.
   
   *Note:* The 'Space Admin' option appears only if you are a space administrator for the space or you are a super user (a member of the *confluence-administrators* group).
2. Choose **PDF Stylesheet** in the space administration options.
3. Choose **Edit**.
4. Enter your customisations.

The PDF Export Stylesheet field accepts Cascading Style Sheets (CSS) rules. The 'PDF Export Stylesheet' page shows the current (e.g. customised) contents of your PDF stylesheet.

**Examples of PDF customisation**

Below are typical customisations you may want to make for your technical documentation. For more examples, see **Customising Exports to PDF**.

Adding a title page

You can create a title or cover page to your PDF document using HTML. Use the **PDF Space Export Title Page** section of the PDF layout to do this.

**Adding a New Title Page**

The following example uses HTML with an inline CSS rule to generate a title page.

```
<div class="fsTitlePage" style="margin-left:auto;margin-top:75mm;margin-right:auto;page-break-after:always">
<img src="/download/attachments/12345/titlepage.png"/>
</div>
```

**Including Content Above Table of Contents in Default Title Page**

The following example includes content above the automatically-generated table of contents that appears on the default title page, so that your title page includes your own content plus the table of contents.
Adding an Image to your Title Page

In the examples above, the title page includes an image called 'titlepage.png', centred in the middle of the page. The image is attached to a Confluence page and is referenced via its relative URL (that is, we use only the last part of the URL, excluding the Confluence site's base URL).

Follow these instructions to include an image on your title page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page.
3. Right-click the image and copy its location.
4. Paste the link into the appropriate src attribute within your PDF stylesheet, as shown above.
5. Remove the first part of the URL before /download/....

Adding headers and footers

You can add headers and footers to your PDF pages using HTML. Use the 'PDF Space Export Header' and 'PDF Space Export Footer' sections of the PDF layout to do this. For simple headers and footers, plain text is enough. The following example adds a simple copyright notice.

Copyright © 2010, Atlassian Pty Ltd.

Adding page numbers to a header or footer

To add page numbering, you need to combine customised HTML in the PDF Layout with customised CSS in the PDF Stylesheet.

1. PDF Layout HTML: In the Footer section (or the Header section), use an empty span element with a unique ID, for example pageNum, to act as a place holder for the page number.

   HTML - PDF Layout: Footer Section
   ```html
   <span id="pageNum"/>
   ```

2. PDF Stylesheet CSS: Create the following CSS selector rule for the empty span:

   CSS - PDF Stylesheet
   ```css
   #pageNum:before
   {
   content: counter(page);
   }
   ```

Analysing the above CSS selector rule in more detail:

- The #pageNum rule selects the HTML element with the specified ID of "pageNum", which is the span element we created for the header or footer.
- The :before part of the selector is a pseudo class that allows the insertion of content before the span element is processed.
- The counter(page) is a function that returns the current page number as its content.
• The `content` property tells the CSS processor that dynamic content (that is, an incrementing page number) is to be inserted at the span tag.

**Exporting to PDF**

You can use the built-in Confluence PDF export to export a single page, a selection of pages or an entire space to a single PDF file.

**Exporting a single page to PDF**

You can export a Confluence page to PDF. This option exports a single page and is available to all users who have permission to view the page.

• Go to a page in the space and choose **Tools > Export to PDF**. Follow the prompts to export the page.

**Exporting a selection of pages or a space to PDF**

1. Go to the space and choose **Space tools > Content Tools** on the sidebar.
2. Choose **Export**. This option will only be visible if you have the ‘Export Space’ permission.
3. Select **PDF** then choose **Next**
4. Decide whether you need to customise the export:
   • Select **Normal Export** to produce a PDF file containing all the pages that you have permission to view.
   • Select **Custom Export** if you want to export a subset of pages.
5. Select the pages you want to export.
   • You have the option to **Select All** or **Deselect All** pages.
   • When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
6. Choose **Export**
7. When the export process has finished, download and save the PDF file as prompted.

If your space uses the Documentation theme:

1. Choose **Browse > Space Operations**
2. Choose **PDF Export** from the left menu.
3. Follow the steps above to export the Space.
Using the Scroll PDF Exporter add-on (Not applicable to Confluence OnDemand.)

The Scroll PDF Exporter provides flexible themes for configuring PDF layout and styles. You can select one of Scroll PDF Exporter’s built-in themes and configure your table of contents, header and title pages. For even more flexibility, see the section How Tos in the Scroll PDF Exporter documentation.

For this advanced PDF export functionality, you will need to install the Scroll PDF Exporter add-on into your Confluence site.

Notes

- Permissions required to export a space: To use the space export functionality, you need the ‘Export Space’ permission. See the guide to space permissions.

- Installing add-ons: If you decide to use additional add-ons, your site administrator will need to install the add-ons into your Confluence site. Refer to the documentation on installing add-ons. (Not applicable to Confluence OnDemand.)

- Add-on support: Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Next Steps

Now you know all about providing PDF versions of your documentation. What next? See other ways of Exporting and Printing Technical Documentation.

Exporting and Printing Technical Documentation
This page is part of the guide to developing technical documentation on Confluence Wiki. Confluence is a great tool for writing and maintaining technical documentation. There are times when we need to export the content out of Confluence into other forms, such as PDF, HTML, Microsoft Word and paper.

Confluence itself provides an export to both PDF and HTML. Add-ons provide additional functionality. Below are guidelines on exporting your technical documentation to various formats, including printed output.

**Quick guide to printing and exporting content:**

- Use the browser’s print option to print a single page.
- To print more than one page and for more advanced printing options, export your documentation to PDF.
- Confluence can export your pages to PDF, HTML, Confluence-specific XML and Word.
- Consider installing add-ons to export your pages to PDF (enhanced functionality), Word (enhanced functionality), DocBook XML, Eclipse Help and JavaHelp.
- Make your exports available to your customers for download by attaching the exported file to a Confluence page.

The rest of this page gives more details of the above procedures.

### On this page:
- Printing
- Exporting to PDF
- Exporting to HTML
- Exporting to Confluence-specific XML
- Exporting to DocBook XML via an add-on
- Exporting to Microsoft Word
- Exporting to Microsoft Word via an add-on
- Exporting to Eclipse Help via an add-on
- Exporting to EPUB via an add-on
- Exporting to HTML via an add-on
- Making the PDF and other exported files available to your readers
- Notes
- Further reading

#### Printing

To print a single Confluence page, just use the browser’s print option. This option is available to all users who have permission to view the page.

To print more than one page and for more advanced printing options, export your documentation to PDF. See Providing PDF Versions of your Technical Documentation.

#### Exporting to PDF

Because this is such an important topic, we have a section of this guide dedicated to PDF. See Providing PDF Versions of your Technical Documentation.

#### Exporting to HTML

Using the built-in Confluence HTML export, you can export a single page, a selection of pages or an entire space to HTML. Confluence supplies the HTML and associated files in a zip file.

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Export. This option will only be visible if you have the 'Export Space' permission.
3. Select HTML then choose Next.
4. Decide whether you need to customise the export:
   - Select Normal Export to produce an HTML file containing all the pages that you have permission to view.
   - Select Custom Export if you want to export a subset of pages, or to exclude comments from the export.
5. Select the Include Comments check box if you want to include comments for the pages you are exporting.
6. Select the pages you want to export.
   - You have the option to Select All or Deselect All pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a
7. Choose Export. This will create a zipped archive of HTML files.
8. When the export process has finished, download the zipped archive as prompted, and extract the files into a folder.

If your space uses the Documentation theme:

2. Choose HTML Export from the left menu.
3. Follow the steps above to export the Space.

Exporting to Confluence-specific XML

Confluence provides an XML export. The XML produced is a proprietary format and is intended for backups or for transferring a space from one Confluence site to another. If you write your documentation on Confluence and your customers have Confluence too, then you can export your manuals to XML and customers can upload them onto their own Confluence site.

Exporting to DocBook XML via an add-on

Scroll DocBook Exporter converts Confluence pages to DocBook XML. Your Confluence system administrator
will need install the add-on onto your Confluence site.

Exporting to Microsoft Word

Confluence can export a page to Word. (Choose Tools > Export to Word.) This option performs a basic conversion of wiki content to HTML and applies some Word CSS stylesheets. It processes just one page at a time.

Exporting to Microsoft Word via an add-on

Scroll Office is a Confluence add-on. Once installed, Scroll Office replaces Confluence's built-in 'Export to Word' functionality. You can export a single page or a hierarchy of pages.

You can define your templates in Word in the usual way, and upload them to Confluence as global templates or space templates. When you export your Confluence pages to Word, Scroll Office will use those templates to build native Word documents from the wiki pages.

Scroll Office provides additional features such as enforcing page-breaks, setting the page orientation to landscape or portrait, and ignoring content. The latest version offers a REST-style API for automated export.

Exporting to Eclipse Help via an add-on

Scroll EclipseHelp Exporter provides an export to Eclipse Help format.

You can produce embeddable online help for Eclipse-based applications. Scroll EclipseHelp Exporter converts the Confluence content into EclipseHelp-compatible JAR files to create a standalone online help or a context-sensitive help.

A hint about the Eclipse Help platform: You can use a cut-down version of the Eclipse Help platform to provide online documentation for any system. It doesn't have to be an Eclipse tool that you are documenting. For some ideas, take a look at a couple of articles about documenting your project using the Eclipse help system.

Exporting to EPUB via an add-on

The Scroll EPUB Exporter outputs an ebook in the common EPUB format that can be read on iPads, iPhones and any other ebook reader.

Exporting to HTML via an add-on

The Scroll HTML Exporter enables the delivery of Confluence content from a web server. It converts the pages into static HTML pages that can be uploaded to a web server. The output of the Scroll HTML exporter can also be used as an input to produce other HTML-based help formats such as WinHelp and HTML Help.

Making the PDF and other exported files available to your readers

There are a number of ways to make your exported files available to your readers, such as putting the files on a disc and shipping them with your product.

One of the simplest ways is to attach the files to a Confluence page. (See Attaching Files to a Page.)

Atlassian uses the out-of-the-box Confluence export functionality to provide PDF, HTML and XML versions of our documentation. People can download the files from our documentation wiki. For example, here are the JIRA documentation downloads and the Confluence documentation downloads.

Notes

- **Permissions required to export a space.** To use the space export functionality, you need the 'Export Space' permission. See the guide to space permissions.
- **Installing add-ons.** If you decide to use additional add-ons, your site administrator will need to install the add-ons into your Confluence site. Refer to the documentation on installing add-ons.
- **Add-on support.** Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Further reading
A blog post about exporting and importing content from/to Confluence: Technical Writing in a Wiki - Single Source Publishing (November 2010).

A good overview of the Scroll Office features in this blog post (August 2010) and the followup post (November 2010).

Next steps

Now you know about a number of ways to get your technical documentation out of Confluence into various formats, for printing or for input into another system or process flow. What next? Take a look at Essential Confluence Features for Technical Documentation.

Essential Confluence Features for Technical Documentation

This page is part of the guide to developing technical documentation on Confluence. In this section we highlight the built-in Confluence macros that are most useful in technical documentation. For more information about Confluence macros, see Working with Macros.

On this page:
- Auto-generating a table of contents for page content
- Drawing attention to elements of a page
- Putting content inside customisable Panels
- Inserting anchor links on pages
- Structuring content using sections and columns
- Making your documentation more engaging by embedding videos

Auto-generating a table of contents for page content

It is important to make it easy for viewers to jump to the section of a Confluence page that they are most interested in. The Table of Contents macro helps people navigate lengthy pages by summarising the content structure and providing links to headings used on the page. 

Click here to see a common example >>

2. Each feature in the release is a heading on the page.
3. You can generate a list of hyperlinks to each of the features in the release notes by inserting the Table of Contents macro:

4. The image below shows the Table of Contents macro inserted at the top of the 'Release Notes' page. Note that we have excluded the 'Highlights of Confluence 4.0' heading from the table of contents by modifying the macro's parameters.
The image below shows the macro parameters specified in the macro browser. Note the 'Minimum Heading Level' and 'Maximum Heading Level' parameters.
Often when creating documentation there are elements of a page that you want to highlight, or draw the the viewers' attention to. Confluence ships with the following macros that help you focus a viewer's attention to a note, information, tip or warning.

Click here to see a common example >>

### Note macro

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Note macro allows you to highlight a note on a Confluence page.</td>
<td><img src="image" alt="Draft in progress" /> This document is a draft and is under development.</td>
</tr>
<tr>
<td>It creates a yellow coloured box surrounding your text, as shown to the right.</td>
<td></td>
</tr>
<tr>
<td>See Note Macro for more examples and instructions.</td>
<td></td>
</tr>
</tbody>
</table>

### Info macro

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Info macro allows you to highlight helpful information on a Confluence page.</td>
<td><img src="image" alt="Did you know?" /> Confluence is the best wiki ever.</td>
</tr>
<tr>
<td>It creates a blue coloured box surrounding your text, as shown to the right.</td>
<td></td>
</tr>
<tr>
<td>See Info Macro for more examples and instructions.</td>
<td></td>
</tr>
</tbody>
</table>

### Tip macro

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Tip macro allows you to highlight a helpful tip on a Confluence page.</td>
<td><img src="image" alt="Learn more" /> Check out this blog post: Technical Writing in a Wiki: Technical Communicators Explain How &amp; Why?</td>
</tr>
<tr>
<td>It creates a green coloured box surrounding your text, as shown to the right.</td>
<td></td>
</tr>
<tr>
<td>See Tip Macro for more examples and instructions.</td>
<td></td>
</tr>
</tbody>
</table>

### Warning macro

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Warning macro allows you to highlight a warning note on a Confluence page.</td>
<td><img src="image" alt="Draft" /> This page is a draft in progress and visible to Atlassian staff only.</td>
</tr>
<tr>
<td>It creates a red coloured box surrounding your text, as shown to the right.</td>
<td></td>
</tr>
<tr>
<td>See Warning Macro for more examples and instructions.</td>
<td></td>
</tr>
</tbody>
</table>

---

**Putting content inside customisable Panels**

Using the Panel macro, you can place content inside a customisable coloured panel. This is particularly useful when you want to clearly separate elements on a page.

Click here to see a common example >>

1. You are documenting a procedure which involves a number of steps.
2. You want to call out the steps of the procedure from the rest of the page by placing it inside a coloured
3. You can create a coloured panel using the Panel macro.
4. The image below shows the parameters set for the panel using the macro browser.

![Edit 'Panel' Macro](image)

**Return to top of page**

Inserting anchor links on pages

Anchor links can be especially useful when navigating between sections of a long document or when you want to link to a segment of a page from another page. The Anchor macro allows you to link to specific parts of a page.

Click here to see a common example >>

1. You are documenting part of a user guide.
2. The page is split into multiple sections.
3. After each section you want to provide a link for viewers to click, taking them back to the top of the page.
4. To achieve this you first must create an anchor at the top of the page using the Anchor macro. You can give the anchor any name you like. In the image below, the anchor at the top of the page will be named 'top'.
5. The anchor placeholder will appear to indicate where your anchor link is located on the page:

![Anchor placeholder]

6. Create a link to the anchor, anywhere on the page, using the Link Browser. The image below shows a link to the anchor called 'top' by using the hash '#', followed by the name of the anchor you created earlier, with an alias of 'Return to Top'.

![Link to anchor example]
See [Working with Anchors](#) for more examples and instructions.

## Structuring content using sections and columns

Sometimes it is necessary to structure content into sections and columns. The details are in [Working with Page Layouts and Columns and Sections](#).

- Page layouts allow you to add sections to your page and then apply pre-defined column layouts to each section (for example, 2 column, three column). You can add multiple sections to a page.
- The Section and Column macros allow more flexibility. You can set the width of the columns, and put the sections and columns in any part of the page. Each section can contain any number of columns, created using the Column macro.
- Columns can either have a fixed width, specified in pixels, or a dynamic width, specified as a percentage of the page width.
- Note: whether you are using page layouts or macros, a column is always created inside a section.

[Click here to see a common example >>](#)

The images below show part of a Confluence page with two sections (outlined in red), each with two columns (blue) of different widths.
1. Section 1:

1. Put a name to your face
2. Learn how content is organised
3. Get familiar with the Confluence screens
4. Start creating content
5. Add a panel to your page

Put a face to your name
Your profile picture is used to identify you across Confluence. Upload your own picture via your Profile.

Dashboard | People | Fred Flintsone | Profile Picture

Fred Flintsone
Your profile picture is used as the icon for your personal space, and to represent you in Confluence. You can upload your own profile picture, or you can choose from one of our standard icons.

Upload a Profile Picture: Upload your own profile picture. Profile pictures will be resized to 48 x 48 pixels.

Upload

Browse...

2. Columns in section 1 – left column has a fixed width of 400 pixels:

1. Put a name to your face
2. Learn how content is organised
3. Get familiar with the Confluence screens
4. Start creating content
5. Add a panel to your page

Put a face to your name
Your profile picture is used to identify you across Confluence. Upload your own picture via your Profile.

Dashboard | People | Fred Flintsone | Profile Picture

Fred Flintsone
Your profile picture is used as the icon for your personal space, and to represent you in Confluence. You can upload your own profile picture, or you can choose from one of our standard icons.

Upload a Profile Picture: Upload your own profile picture. Profile pictures will be resized to 48 x 48 pixels.

Upload

Browse...
3. Section 2:

1. Put a name to your face
2. Learn how content is organised
3. Get familiar with the Confluence screens
4. Start creating content
5. Add a panel to your page

Put a face to your name
Your profile picture is used to identify you across Confluence. Upload your own picture via your Profile.

1. Put a name to your face
2. Learn how content is organised
3. Get familiar with the Confluence screens
4. Start creating content
5. Add a panel to your page

4. Columns in section 2 – left column has a fixed width of 10 pixels:

Return to top of page

Making your documentation more engaging by embedding videos

Pictures can be worth a thousand words. The same can be said for videos. Often, it’s easy to explain a concept or demonstrate a procedure using a video. The Widget macro allows you to embed web content, including YouTube and Vimeo videos, in a Confluence page.

Click here to see a common example >>

1. You release a new version of your product.
2. You document the release notes on a Confluence page.
3. The marketing team creates a video demonstrating the new features of the release and uploads it to YouTube.
4. You can embed the video in your release notes using the Widget macro, for playback on your Confluence page.
a. Edit the page and choose **Insert > Other Macros** in the editor toolbar.

b. Search for the 'Widget Connector'.

c. Insert the URL of your YouTube video into the **Web Sites Widget URL** field.
See Widget Connector Macro for information on the supported services and for more examples.

Return to top of page

Next steps

Take a look at Confluence Add-ons for Technical Documentation.

Confluence Add-ons for Technical Documentation

This page is part of the guide to developing technical documentation on Confluence. In this section we highlight some of the Confluence add-ons that are useful for technical writers in designing and developing documentation.

An add-on is an extension module that you can add to your Confluence site to extend the wiki’s core functionality. It is similar to an add-on for your browser.

An add-on that specifically plugs into an Atlassian application such as Confluence is sometimes called a plugin. The terms 'plugin' and 'add-on' are often used interchangeably. Confluence add-ons may be developed by Atlassian or by third parties. To find an add-on featured on this page, and other add-ons too, visit the Atlassian Marketplace.

Drawing tools

Below are some popular tools. Search the Atlassian Marketplace to see a full list of drawing and diagram add-ons for Confluence.

**Gliffy**

The Gliffy add-on provides an embedded diagram editor. With Gliffy you can create and edit diagrams directly on a Confluence page. Gliffy supports various diagram types (UML, business process, and so on).

Commercial or free? Commercial.

Alternatives: As an alternative you can use the standalone version of Gliffy available at http://www.gliffy.com. Gliffy online has a free basic version.

More information: See the Gliffy add-on page.

**Lucidchart**

Using Lucidchart, you can draw flowcharts, wireframes, UML diagrams, mind maps, and more, inside the web editor, then integrate the diagram with Confluence. Include interactivity such as linking to pages within Confluence or other pages inside the diagram.

Commercial or free? Commercial.

More information: See the Lucidchart add-on page.

**Creately**

Use Creately to draw flowcharts, UML diagrams, database diagrams, wireframes, mindmaps, UI mockups,
workflow diagrams, network diagrams, org charts, and Gantt charts.

Commercial or free? Commercial.

More information: See the Creately add-on page.

**yWorks Diagrams**

Use **yWorks Diagrams** to create and edit diagrams directly inside Confluence.

Commercial or free? Commercial.

More information: See the yWorks Diagrams add-on page.

---

**Add-ons for enhanced content manipulation**

All content extensions are provided by **macros** in Confluence. Some macros are built in to Confluence. Other macros are supplied by add-ons.

**Quick overview of macros**

Before looking at add-ons, let's take a quick look at macros in general. There are two ways to add a macro to your page:

- Use the **macro browser**. This is the simplest and recommended way.
- Or insert the macro's name in curly brackets into the text of your page and specify the parameters.

Click here to see an example of a macro >>

The following code uses the (include) macro to insert the text from the page called 'My Page'.

```markdown
Some content on my page.
{include:My Page}
Some more content on my page.
```

Let's assume 'My Page' contains just two lines:

```markdown
I love chocolate.
Chocolate loves me.
```

The resulting page will look like this:

```markdown
Some content on my page.
I love chocolate.
Chocolate loves me.
Some content on my page.
```
I love chocolate.
Chocolate loves me.
Some more content on my page.

A number of macros are shipped with your Confluence installation by default. See Working with Macros. Below we describe some add-ons that provide additional useful macros for Confluence:

**Composition add-on**

The Composition add-on provides macros which allow finer control over the layout (composition) of a page. Using these macros, you can:

- Outline your text blocks.
- Add tabs to a page.
- Flow your text around the images or diagrams on the page.

**Commercial or free:** Commercial.

**Using the Composition add-on to outline text blocks**

Use the {cloak} macro to outline a text block.

**Usage:** The following code creates a text block named 'SeeAlso' for the outlined 'See Also' section within a page. The text block with id='SeeAlso' will be hidden after the 'See Also' title:

```plaintext
{composition-setup}

h2. {toggle-cloak:id=SeeAlso} See Also
{cloak:id=SeeAlso}

h3. Working With Macros:
[Link 1]
[Link 2]

h3. Working with Rich Text Editor:
[Link 3]
[Link 4]

{cloak}
```

**Alternatives:** You can also use the {expand} macro available in Confluence by default, but this macro can outline only text of the same level and cannot hide headings within the text. The {expand} macro does not require parameters and just hides the text placed between the {expand} tags.

**Note:** If you need to outline a text block containing nested headings, consider the text structure. Maybe the block is too big. You could create a child page from this block to decompose the whole text. Then you can include and outline the text block using the {include} macro within {expand}.

**Using the Composition add-on to add tabs to a page**

Use the {deck} and {card} macros to separate content between tabs on the same page.

**Usage:** The following code creates two tabs with client information:
The tabs on a page will look like this:

```
Client Name

Basic  Contacts

Client Company Name: Company
Client Web Site
Our projects: Project1
```

**Using the Composition add-on to flow your text around images**

Use the `{float}` macro to make your text flow around images or diagrams.

**Usage:** The following code demonstrates how a picture can be surrounded by the description, as often shown in printed publications:

```
{composition-setup}
{float:left}
!shakespeare.jpg!
{float}
William Shakespeare (baptised 26 April 1564; died 23 April 1616) was an English poet and playwright, widely regarded as the greatest writer in the English language and the world's pre-eminent dramatist.
...
```

The page will look like this:
William Shakespeare (baptised 26 April 1564, died 23 April 1616) was an English poet and playwright, widely regarded as the greatest writer in the English language and the world's pre-eminent dramatist. He is often called England's national poet and the "Bard of Avon". His surviving works, including some collaborations, consist of about 39 plays, 164 sonnets, two long narrative poems, and several other poems. His plays have been translated into every major living language and are performed more often than those of any other playwright.

Shakespeare was born and raised in Stratford-upon-Avon. At the age of 18, he married Anne Hathaway, with whom he had three children: Susanna and twins Hamnet and Judith. Between 1596 and 1599, he began a successful career in London as an actor, writer, and part owner of a playing company called the Lord Chamberlain's Men, later known as the King's Men. He appears to have retired to Stratford around 1613, where he died three years later. Few records of Shakespeare's private life survive, and there has been considerable speculation about many matters such as his physical appearance, sexual orientation, and religious beliefs, and whether the works attributed to him were written by others.

Shakespeare produced most of his known work between 1593 and 1613. His early plays were mainly comedies and histories, genres he raised to the peak of sophistication and artistry by the end of the 16th century. He then wrote mainly tragedies until about 1608, including Hamlet, King Lear, and Macbeth, considered some of the finest works in the English language. In his last phase, he wrote tragicomedies, also known as romances, and collaborated with other playwrights.

For more macros, see the Composition add-on page.

**Scaffolding add-on**

The Scaffolding add-on provides macros for creating 'permanent templates' and editable forms. You can create sophisticated page templates in order to add content easily and fast. Scaffolding templates are suitable for dynamically-filled data and allow people to create pages by completing form fields and selecting values from drop-down lists.

The Scaffolding templates are useful for creating pages with a well-determined structure, such as:

- API methods or property descriptions.
- Constant list.
- Feature description.
- Software requirement specifications.

**Commercial or free**: Commercial.

**Example**: The following Scaffolding template creates a description of an API method:
h3. Method Name
{text-data:methodName|required=true}{text-data}

h3. Method Description
{text-data:methodDescription|type=area|required=true|width=100%}{description}{text-data}

h3. Parameters
{table-data:parameters}
|| Name || Type || Mandatory || Description ||
| {text-data:paramName}ParamName{text-data} |
{list-data:paramType}{list-option:Number}Number{list-option}{list-option:String}String{list-option}{list-option:DateTime}DateTime{list-option}{list-option:MACaddress}MACaddress{list-option}{list-option:IPaddress}IPaddress{list-option}{list-data} |
{list-data:paramMandatory}{list-option:Required}Required{list-option}{list-option:Optional}Optional{list-option}{list-data} |
{text-data:paramDescription|type=area}param description{text-data} |
{table-data}

h3. Return Value
The returned value is an XML structure of the following format:

```xml
declared namespace="http://www.w3.org/2003/05/xsd"; ?
<result>

Where elements mean:
{table-data:returnValues}
|| Name || Type || Description ||
| {text-data:paramName}ParamName{text-data} |
{list-data:paramType}{list-option:Number}Number{list-option}{list-option:String}String{list-option}{list-option:DateTime}DateTime{list-option}{list-option:MACaddress}MACaddress{list-option}{list-option:IPaddress}IPaddress{list-option}{list-data} |
{text-data:paramDescription}param description{text-data} |
{table-data}

h3. Remarks
{text-data:remarks}remarks{text-data}

h3. See Also
For more information on how to create templates in Confluence, see Adding a Template.

**Alternatives:** Confluence includes built-in templates which as useful for static data and simple text. For more information, see Working with Templates.

**Notes:** The Scaffolding (and any) template changes will affect only new pages created from the modified template. In order to change the existing pages, you need to edit each individual page and add or modify the formatting manually.

For more information on Scaffolding, see the Scaffolding add-on page.

Extended version control

**Scroll Versions**

Scroll Versions adds functionality for sophisticated version management, enhanced content reuse, support for context-sensitive help, permalinks, and duplicate page titles. You can set up and manage concurrent versions of your documentation in a single space. Multiple versions of software, different product variants, and even multiple translations of documentation can be managed. Changes to pages are scheduled for a specified version and then published all at once. See the Scroll Versions documentation for an overview of the key features.

**Commercial or free:** Commercial.

**Video:** Scroll Versions - Version Management for Confluence (4:20)
Attachment Checkout add-on


Commercial or free: Free for up to 50 users, then commercial.

More information:

- Please visit the Attachments Checkout add-on page for an overview, including a video.
- See the Attachments Checkout documentation for further reference.
- For information on working with attachments in Confluence, see Working with Attachments.
- For information on attachment versioning, see Attachment Versions.

Add-ons featured in other parts of this guide

- Copy Space add-on – Provides an easy way of copying a space within a Confluence site. Free. See Creating your Technical Documentation Space.
- Multi Excerpt add-on – Enables you to have more than one excerpt (re-usable chunk) on a page. Commercial. See Re-using Content in Technical Documentation.
- Content Publishing add-on – Publishes content from a master space to a published space. Commercial no charge. See Managing the Life Cycle of your Technical Documentation.
- Scroll EPUB Exporter – Outputs an ebook in the common EPUB format that can be read on iPads, iPhones and any other ebook reader. Commercial.
- Scroll HTML Exporter – Enables the delivery of Confluence content from a web server. It converts the pages into static HTML pages that can be uploaded to a web server. The output of the Scroll HTML exporter can also be used as an input to produce other HTML-based help formats such as WinHelp and HTML Help. Commercial.
- Scroll EclipseHelp Exporter – Enables you to collaborate and author all your content in your wiki, and generate embeddable online help for Eclipse-based applications. Commercial.

Notes

- Add-on support. Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.
- Installing add-ons. If you decide to use additional add-ons, your site administrator will need to install the add-ons into your Confluence site. Refer to the documentation on installing add-ons.

Further reading

- A blog post about useful add-ons and tools for exporting and importing content from/to Confluence: Technical Writing in a Wiki - Single Source Publishing (November 2010).
- Website for exploring and downloading the available add-ons: Atlassian Marketplace.
- Documentation on installing and configuring add-ons: Universal Plugin Manager Documentation.
- Documentation on using macros: Working with Macros.
- Further Reading about Developing Technical Documentation on Confluence

Further Reading about Developing Technical Documentation on Confluence

This page is part of the guide to developing technical documentation on Confluence. Once you have absorbed all the information in this guide, you may be ready for more reading. 😊

- The Confluence documentation: Confluence Latest.
- Blog post about using Confluence for online help: Using a wiki for online help.
- Blog posts about version management in Confluence with Scroll Versions plugin:
  - Announcing Scroll Versions.
  - Version management gets serious with Confluence Scroll Versions plugin.
Now you have your documentation space up and running, it's fun and rewarding to use the full power of the wiki to engage your readers and embed content from other social sites. Here is a blog post and presentation slides on engaging readers in the documentation.


Webinar recording: Confluence as a Platform for Technical Documentation.

Let us know about more links
We plan to add more links to this page or to the 'Tips of the Trade' page. Let us know of any we have missed.

Using Confluence as a Knowledge Base

A knowledge base is a repository for how-to and troubleshooting information. Knowledge Bases are commonly used by IT Support teams, but can be useful for procedural and troubleshooting information in any organisation or team.

What do people want out of a knowledge base? Using an IT Support team as an example:

- Customers want fast access to a solution, and relevant search results.
- Help desk staff want to be able to create new articles quickly.
- Help Desk team leads want the space to be self curating, and do not want to spend a lot of time manually organising content.
- Everyone wants a way to be notified when articles they are interested in have been updated or important notices are added.

Creating a knowledge base space

⚠️ You'll need the Create Space global permission to do this.

To create your knowledge base space:

1. Create a space using the knowledge base space blueprint (Choose Spaces > Create space > Knowledge base space).
2. Set permissions for the space, including anonymous access (Choose Space Tools > Permissions)
3. Create your first knowledge base article (Choose Create > How-to or Troubleshooting and follow the prompts)

The knowledge base space blueprint includes everything you need to get started, including article templates, and a pre-configured homepage with Livesearch and Content By Label macros.

Page labels are essential in knowledge base spaces. These are used to add topics to your articles, and allows your knowledge base to become self organising over time.

Users will generally find articles by searching, and using the topic navigation on the homepage and end of each article, rather than navigating through a tree-like page hierarchy.

When starting off your knowledge base space, it is a good idea to brainstorm a few topics to get started.

Customising your knowledge base space

⚠️ You'll need Space Admin permissions to do this.

To make it easy for your users to create knowledge base articles (such as your help desk or support team) we recommend customising the how-to and troubleshooting article templates to make them relevant for your organisation. The more guidance and structure you can put in your template, the faster it will be for your team to create great articles.

To edit the article templates:
1. Go to Space Admin > Content Tools > Templates.
2. Edit the How-to or Troubleshooting article templates.
3. Add headings and instructional text (choose Template > Instructional Text).

You can also add additional templates, such as a policy or procedure page templates.

We also recommend customising the look and feel of your space. Simple changes like a space logo and welcome message can make a huge difference.

To change the look and feel:

- Add a space logo and useful shortcuts to the sidebar (choose Space Tools > Configure Sidebar)
- Edit the homepage to add a custom welcome message.
- Edit the colour scheme (choose Space Tools > Look and Feel > Colour Scheme).

Providing communication and notification options

Channels of communication with your audience, internal or external, is essential in a good knowledge base. Here are some out of the box options:

- **Blog** - blog updates and important notices, and encourage people to watch for new blogs in your space.
- **Watch** - encourage people to watch pages that interest them, or watch the entire space.
- **Comments** - allow logged in users (or even anonymous users) to comment on knowledge base articles. This is a simple way to connect with your end users.
- **RSS** - create an RSS feed and add the link to your knowledge base homepage (choose Help > Feed Builder). Alternatively encourage users to create their own feed - useful if they want to keep up with particular topics (labels), rather than receive notifications for the whole space.

Integrating your knowledge base with other Atlassian products

If your Confluence site is connected to another Atlassian product (via an application link), you can make use of these great integration features:

- **If you use JIRA** - add a JIRA Issues macro to your troubleshooting article to provide quick access to known issues. This has the added advantage of automatically updating when an issue is resolved or its status changes. One simple way to do this would be to add some labels to JIRA to indicate the issue should appear in the knowledge base (for example 'printer-kb'), and then add a JIRA Issues macro with a query like 'label = 'printer-kb and status <> resolved'' on all articles with the printer topic.
- **If you use JIRA Service Desk** - specify your Confluence space to be used as a knowledge base. Users can search your knowledge base directly from within the Service Desk customer portal.
- **If you use Confluence Questions** - add a Questions list macro to troubleshooting articles, to highlight the top questions with the same topic as the article, and an Ask a Question button to the knowledge base homepage.

Extending your knowledge base with third party add-ons

The Atlassian Marketplace has a large number of add-ons for Confluence. A common addition to Knowledge Base spaces is a survey or form tool, which enables you to get feedback on the usefulness or usability of your knowledge base articles.

Search for 'knowledge base' on Marketplace and see if there is an add-on that's right for your knowledge base.

**Developing an Intranet on Confluence Wiki**

Confluence now ships with a space blueprint for creating Team spaces, which is useful if you use Confluence as an intranet.

Go to Create Space > Team Space to try it out for yourself.

This guide is for people who are using Confluence as a platform for an intranet. You will find this guide useful if you want to create a space where your team can collaborate and share information.

Step 1. Create a space
Below is a quick guide to adding a space for your team.

1. Go to the Confluence dashboard and choose **Create Space > Blank Space**.
2. The **Create Space** screen appears. Enter a **space name** and a short, unique **space key**.
3. Choose **Create**.

The home page of your new space will appear. Because you created the space, you are the space administrator. Now you can do some basic configuration, as described in the sections below.

### On this page:
- **Step 1. Create a space**
- **Step 2. Set the space permissions**
- **Step 3. Customise the title and content of the home page**
- **Step 4. Subscribe to email notifications for updates made to the space**
- **Step 5. Attach or import Office documents, if applicable**
- **Step 6. Import page templates and blueprints**
- **Step 8. Publish a blog post**

### Related pages:
- Creating a Space
- Global Permissions Overview
- Assigning Space Permissions
- Page Restrictions
- Users and Groups

### Step 2. Set the space permissions

Define the space permissions to determine who can do what in your new space.

1. Go to the space and choose **Space tools > Permissions** on the sidebar.
2. Choose **Edit Permissions**.
3. Set the permissions to suit your needs then choose **Save All**.
   - You can add **groups** and/or individual **users** to the list, then select the permissions for each group or user.
   - You can also set the permissions for **anonymous** users – these are people who have not logged in to Confluence and will not count towards the number allocated by your license. Anonymous access is only available if enabled for your entire Confluence site. It is unlikely you will need anonymous users for your intranet.
   - You can change these permissions at any time. You may want to restrict the permissions to specific groups now, and later open the space to more people.

### More about permissions

Confluence has a robust and granular permissions scheme that you can use to determine who can view, create content and comment within your intranet. There are three levels of permissions in Confluence:

- **Global permissions** apply across the entire site.
- **Space permissions** apply to a space.
- **Page restrictions** allow you to restrict the editing and/or viewing of a specific page.

**Space permissions** in Confluence are simple yet granular enough to be useful for an intranet. You can:

- Use the permission levels to control who can create pages, delete pages, create comments, delete comments, administer the space, and so on.
- Grant a permission level to one or more users, and/or to one or more groups, and/or to anonymous users.
  A space administrator has complete control.

### Terminology:

- **Anonymous** means people who have not logged in to Confluence
- The **confluence-users** (‘users’ in OnDemand) group is the default group into which all new users are assigned. Everyone who can log in to Confluence is a member of this group.
For example, you might allow the 'confluence-users' group permission to create and edit comments, but reserve full editing rights for your team members. Let's assume your team members are all members of the 'developers' group. The example below shows that members of the 'developers' group have all permissions except space administration, but, members of the 'confluence-users' group and the individual 'Josh User' only have a few editing rights.

<table>
<thead>
<tr>
<th>Groups</th>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Comments</th>
<th>Attachments</th>
<th>Mail</th>
<th>Space</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>View</td>
<td>Add</td>
<td>Restrict</td>
<td>Remove</td>
<td>Add</td>
<td>Remove</td>
<td>Add</td>
</tr>
<tr>
<td>confluence-users</td>
<td>✔️</td>
<td>✔️</td>
<td>❌</td>
<td>❌</td>
<td>✔️</td>
<td>X</td>
<td>✔️</td>
</tr>
<tr>
<td>developers</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Individual Users</th>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Comments</th>
<th>Attachments</th>
<th>Mail</th>
<th>Space</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>View</td>
<td>Add</td>
<td>Restrict</td>
<td>Remove</td>
<td>Add</td>
<td>Remove</td>
<td>Add</td>
</tr>
<tr>
<td>Rach Admin (admin)</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>Josh User (Josh)</td>
<td>✔️</td>
<td>✔️</td>
<td>❌</td>
<td>❌</td>
<td>✔️</td>
<td>X</td>
<td>✔️</td>
</tr>
</tbody>
</table>

For detailed information, see the documentation on:

- Global permissions
- Space permissions
- Page restrictions
- Users and groups

Step 3. Customise the title and content of the home page

When you created your space, Confluence created a home page with default content and a default title. You will want to change the title and content to suit your team.

1. Go to your space home page
2. By default, the page title is 'X Home' (where 'X' is the name you gave your space).
3. Choose Edit.
4. The page opens in the editor.
5. Change the title and update the content to suit your needs. 
   Hint: If you do not know what to add yet, add a short description. You can refine the content of the page at any time.
6. Choose Save to save your home page.

Step 4. Subscribe to email notifications for updates made to the space

You can configure your email notifications to suit your needs: You can choose to be notified about all pages in a space, blog posts in a space, or both. Below is a quick guide to monitoring a space's content. See Watching Pages, Spaces and Blog Posts for a full description.

1. Go to your space homepage.
2. Choose Pages in the sidebar.
3. Choose Watch this space.
4. Choose Blog in the sidebar.
5. Choose Watch this blog.
If at any time you wish to stop watching activity in the space, choose Stop watching this space or stop watching this blog.

Example of an email notification

Here is an example of the email notification you will receive when someone adds a comment to a page or blog post:

![Email notification example](image)

More about notifications

You can specify the notifications you want to receive at a global, space, and page level. The quick guide above demonstrated how to set up notifications for a space. Now we will show you how to configure your notifications at the global and page levels.

**Global notifications**

Global notification settings determine the overall behaviour of the notifications you receive from Confluence.

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Email.
3. Choose Edit.
4. Change the default settings to suit your needs. You can alter these email settings at any time.
5. Choose Submit to save your changes.

**Page and blog post notifications**

Follow the quick guide below to receive notifications from Confluence about changes to and comments on a specific page or blog post. See Watching Pages, Spaces and Blogs for a full description.

You can watch any given page or blog post that you have permission to view. We will use your space's home page as an example.

1. Go to the home page of your space.
2. Choose Watch.

You can choose to watch just that page, or all pages in the space.

You are now watching the current page and Confluence will notify you about any updates made or comments added.

Note that Confluence will not notify you about content changes that are due to the output of a macro. For example: The output of the Children macro will change if someone adds a child page. The page containing the Children macro will show the new child page. But the page content itself has not been edited, so no notifications will be sent.

You can stop watching a page or blog post at any time. Choose Watch and deselect the Watch Page or Watch all content in this space checkboxes.

**Step 5. Attach or import Office documents, if applicable**

Below are some guidelines on managing your existing Microsoft Office documents in Confluence. You can
choose to attach them to a Confluence page, so that team members can view and access them in Confluence, and edit them in Office. Or you can import the documents into Confluence, converting the content to Confluence pages.

Attaching Office documents to a page

You can use Confluence as a central repository for your team's Office documents. This means that you can share your Office documents without having to email them to your teammates. People can view the Office documents even if they do not have Office installed on their computers.

1. Go to a page in your space.
2. Choose **Tools > Attachments**.
3. Use one of the following methods for attaching files to the page:
   - Choose **Browse** and to locate the file on your computer, enter a comment then choose **Attach**

   ![Attach File](image)

   *Alternatively, drag and drop one or more file(s) directly onto the 'Drop files here' region of the attachments screen. The 'Attach File(s)' message box appears, indicating the upload status of the file(s) being attached to your page.*

   ![Attach File(s)](image)

Importing Word documents into Confluence

You can also import content from Microsoft Word into Confluence, so that it becomes a Confluence page. See **Importing a Word Document into Confluence** for a full description.

1. Go to your space home page.
3. Choose **Browse** and locate the Office document on your local drive or network.
4. Choose **Next**. The import document options screen will display.

![Import Word Document: Configuration](image)

5. Choose how you would like the Office Connector to import the file:
   - **Root page title** – This will be the title of the page.
   - **Import as a new page in the current space** – This option specifies that a new page will be created with the title specified.
   - **Rename imported pages if page name already exists** – This is what Confluence will do if there is a conflict.
   - **Split by heading** – If your document contains headings, Confluence can use the heading information to split the document into multiple wiki pages. If you do not want to split your document leave the default ‘Don’t split’ option selected.

6. Choose **Import**.

When the upload has finished, the content of the Office document will have been transformed into Confluence page content. You can now view and edit this page in the normal way, using the Confluence editor. There is now no connection between the original Office document and this page.

**Step 6. Import page templates and blueprints**

In order for an intranet to be effective, people need to use it. One way to spur new user adoption is to provide your team with templates so that they can focus more on content creation and less on page format. You can create your own templates or download some from the [Atlassian Marketplace](https://marketplace.atlassian.com). See [Importing Templates](https://confluence.atlassian.com/doc/importing-templates-27370) and [Adding a Template](https://confluence.atlassian.com/doc/adding-a-template-27369) for more information.

A blueprint is a page template with added functionality to help you create, manage and organise content in Confluence. Confluence ships with some predefined blueprints. You can also download additional blueprints from the [Atlassian Marketplace](https://marketplace.atlassian.com). You can customise the blueprint templates to suit your individual needs and even develop your own blueprints. See [Working with Blueprints](https://confluence.atlassian.com/doc/working-with-blueprints-27375).

**Creating a page from a template**

Now that you have made some templates available to your site or space, other Confluence users will be able to choose a template when they want to create a page. Templates appear in the **Create** dialog for users to select when creating a new page.

1. Go to your Intranet space.
2. Choose **Create** on the header. Available templates will be listed in the Create dialog.
3. Select a template and choose **Next**.
4. If the template contains variables, a form will appear. Type the relevant information into the form fields, and choose Next.
5. Enter a title for the page, update the content and choose Save.

Step 7. Set up your personal space

Now that you have created a space for your team, let's create your **personal space**. This is a place where you can publish your own pages and blog posts. Once you have created it, Confluence users can reach your personal space by clicking your name in the People Directory or by searching for your name via the quick navigation search box.

1. Choose your profile picture at top right of the screen, then choose Add Personal Space.
2. Enter a few details about your space:
   - Choose who can view content.
   - Choose who can contribute (create and edit) content.
   - Choose the 'Global Look and Feel' for your personal space.
3. Choose Create.
4. The 'Home' page for your new space is displayed.

Step 8. Publish a blog post

Blog posts are a good way of letting your team mates and the company know your news. People can blog about product and strategic ideas, team updates, and things they want to get ideas about. New employees can write blog posts introducing themselves. People write about getting married or the birth of a child. Blog posts are a great way for people to share their visions, get to know their c-oworkers and start lively discussions.

Remember to set your email notifications to alert you about the blog posts published within Confluence, as described in an earlier step.

See Working with Blog Posts for a full description of adding, editing, viewing and linking to blog posts.

1. Go to a page in your space.
2. Choose Create in the header.
3. Select Blog then choose Next.
4. Add a title and some content.
5. Choose Save to publish your blog post.